Introduction

MvcDiagram Programmer's Guide
Introduction

MvcDiagram is a general-purpose software component that can be used to display various types of diagrams and charts in web applications. It can be easily integrated into any project targeting the Microsoft ASP.NET MVC platform. By providing your software with ready to use capabilities for visualizing and editing relational data, MvcDiagram saves you from hundreds of hours of coding and debugging efforts.

MvcDiagram can give graphical representation to:

  • Workflow processes
  • Object hierarchies and relationships
  • Graphs and networks
  • Entity-relationship / database diagrams
  • IVR systems
  • Industrial automation processes
  • Genealogy trees
  • Algorithms and flowcharts
  • Organizational charts
  • XML documents
  • Classification hierarchies
  • Data mappings

MvcDiagram provides intuitive user-interaction model for creating or editing diagrams. In addition, its programmatic interface places at your disposal many useful functions, ranging from printing and XML serialization to path-finding and automatic layout algorithms.

© 2015 MindFusion


What's New in this Release

What's New in this Release

The list below describes recent changes and additions to MvcDiagram:

New in version 2.6

Resize table columns and rows

Columns and rows of a TableNode can now be resized interactively if its AllowResizeColumns or AllowResizeRows properties are enabled. In order to resize, move the mouse pointer to the border line on column's right side or row's bottom side until it shows resize cursor and start dragging. The control raises tableColumnResizing and tableRowResizing events to let you validate new size or prevent resizing some elements. The tableColumnResized and tableRowResized events are raised after the operation completes.

Shape libraries

The ShapeLibrary class lets you use custom geometric shapes created using MindFusion ShapeDesigner tool. Call the ShapeLibrary.loadFromXml(url) method to load a library XML file. ShapeLibrary.getShapes() returns an array of the loaded Shape objects. The NodeListView.setShapeLibraryLocation(url) method creates a prototype ShapeNode object for each shape from the specified library. Location of a shape library can also be specified server-side through the DiagramView's ShapeLibraryLocation property.

Miscellaneous

  • getTextStroke and getTextStrokeThickness properties of DiagramItem let you set color and thickness of text outlines;
  • Items can now be deleted using Backspace key when running on Mac;
  • Caption divider line in TableNode and ContainerNode is now rendered clipped when caption height is smaller than corner radius;
  • Diagram.TooltipDelay property specifies the delay in milliseconds before showing tooltips;
  • The NodeListView.Orientation property lets you set the view's orientation to Horizontal or Vertical (members of MindFusion.Diagramming.Orientation enum);
  • Fixed overlaps in TreeLayout when arranging nodes of different sizes;
  • Anchor points indices are now serialized;
  • Deserialization of custom item classes now works regardless of whether names contain Node or Link suffix;


Version History

Version History

The list below describes recent changes and additions to MvcDiagram:

New in version 2.5

Appearance improvements

  • Set the Shape property of tables and containers to RoundedRectangle to render them with rounded corners.
  • Hide the frames of table cells by setting the CellFrameStyle property to None.
  • Set the EnableStyledText property of TableNode class to render styled text in tables.

New events

  • The control raises cellTextEdited event when users edit the text of table cells.
  • The createEditControl event lets you create custom DOM element or fragment to use as in-place text editor.
  • NodeListView raises nodeSelected event when the user selects a node.

Miscellaneous

  • Width and Height properties and the corresponding setter methods for DiagramView, NodeListView, Overview and ZoomControl are now obsolete. You can use the new helper methods of the controls to pass an HTML attributes object, containing style data.
  • Stop the controls from adding references to the client scripts by disabling the AddScriptReferences property.
  • the loadFromXml method of Diagram class lets you load XML files from client side.
  • fixed setZoomFactorPivot bug in virtual scroll mode.

New in version 2.4

Styled text

The EnableStyledText property of ShapeNode allows using HTML-like formatting tags to apply various attributes to the node's text. At this time the component supports the following formatting tags:

  • <b> specifies bold text
  • <i> specifies italic text
  • <u> specifies underlined text
  • <color=value> specifies text color
  • <br /> specifies line break

Improved text rendering

  • General text rendering quality improved. The component removes scale transformations applied for MeasureUnit and ZoomFactor before drawing text on the canvas, and instead specifies a scaled font size, which helps improve text appearance in Firefox and older versions of Chrome.
  • Now items' text can be drawn underlined. To enable this, set the underline attribute of the Font class.
  • Font styles can be specified via Style instance by setting its FontStyle property.

License keys

There is no separate trial build of the control assemblies anymore. Instead, set the LicenseKey property to disable the component's evaluation mode and stop displaying trial messages. If your application contains more than one DiagramView instance or other controls by MindFusion, you could call MindFusion.Licensing.LicenseManager.AddLicense(key) to specify the key once instead of setting it per each control. License key strings are listed on the Keys & Downloads page at MindFusion's customer portal.

Miscellaneous

  • Items can be rendered using dashed lines in browsers that support the setLineDash function. To enable this, set pen's DashStyle property for DiagramItem or the StrokeDashStyle property of Style.
  • Client-side TreeLayout supports organizational charts with assistant nodes as in Microsoft Office diagrams. To mark nodes as assistants, set node.LayoutTraits[TreeLayout.Assistant] to a member of the AssistantType enumeration . Set TreeLayout.enableAssistants = true to arrange assistant nodes in a separate branch between the main node levels.
  • Specify if separate connected components of a graph should be arranged horizontally or vertically relatively to each other by setting the multipleGraphsPlacement attribute of layout classes.
  • The type of Margin property of LinkLabel has been changed from number to Thickness, letting you specify different margin sizes at each side of the label.
  • Masters for Start and Arrow7 shapes added to VisioExporter template file.
  • VisioImporter now tries to preserve Shape of ShapeNode objects when importing from files created by VisioExporter.

New in version 2.3

Import diagrams from SVG

The SvgImporter class allows importing Scalable Vector Graphics files (*.svg) into MindFusion.Diagramming. Each top-level SVG group element is imported as a separate SvgNode, whose Content is set to the group's child elements. If the SVG file was exported from Visio or OpenOffice Draw, SvgImporter will create DiagramLink objects for groups it recognizes as connectors in order to recreate the original diagram model, though in this case it will not preserve fully the original appearance of connectors in SVG.

Zoom control

The ZoomControl class lets users change interactively the current zoom level and scroll position of a Diagram. Bind the ZoomControl to the corresponding Diagram by setting its TargetId property. Set the ZoomStep and ScrollStep properties to specify the amount added to diagram's zoom level or scroll position by ZoomControl's buttons. You can customize the control's appearance by setting properties such as Fill, BorderColor, CornerRadius and TickPosition.

Shadow styles

The Diagram.ShadowsStyle property and ShadowsStyle enumeration let you switch shadow rendering order between rendering all shadows in a single background layer (OneLevel) and drawing each shadow close to its node, possibly overlapping other nodes (ZOrder). ShadowsStyle.None lets you disable shadows altogether.

Miscellaneous

  • Set the LinkLabel.Brush property to fill the background of link labels.
  • Number of link segments can now be set by calling the DiagramLink.setSegmentCount() method.
  • The BackgroundImageAlign property specifies the alignment of diagram's BackgroundImage.
  • The TextPadding property specifies the padding distance between the borders of a node and its text.
  • Nodes of all classes can be rotated.
  • VisioExporter export speed has been improved greatly for large diagrams.
  • For consistence with MindFusion libraries for other platforms, BackBrush in default diagram style has been changed to white brush.
  • Fixed KeepInsideParent constraint for rotated parent nodes.
  • Set the AutoGrow property to false to prevent containers from resizing automatically when they would not fit newly added nodes.
  • The Brush property of LinkLabel class lets you set background color for link labels.
  • Now the NodeModified event is raised after the undo record for that modification has been added to the command history. This makes it easier to merge the ModifyItemCmd with custom commands created from NodeModified handler.
  • The ChangeUnit method sets a new MeasureUnit and rescales the coordinates of diagram items to keep them the same size.
  • OrthogonalLayout no longer ignores repeating links, and will now place them at a distance specified via RepeatingLinksPadding property.

New in version 2.2

SVG Nodes

The SvgNode class represents nodes that can display SVG drawings. SVG graphics are rendered instead of Image, and on top of the geometry rendered by the base ShapeNode class. The SVG drawing of the node is specified through its SvgUrl property.

jQuery support

Now the control can use jQuery for browser abstraction instead of Microsoft Ajax. To choose between Microsoft Ajax and jQuery support use the ClientSideMode property.

Visio2013Exporter improvements

  • Support for multi-segment links
  • Bezier links are now exported as NURBS lines
  • Support for rotated nodes
  • Proper scale for all MeasureUnit values
  • Support for semi-transparent colors

Miscellaneous

  • Set the BackgroundImageUrl property to draw an image as Diagram's background.
  • The TextStyle property of links provides support for several different text position and orientation styles, defined by the LinkTextStyle enumeration.
  • Set the AllowUnconnectedLinks property to true to let users draw links without connecting them to nodes.
  • OrthogonalLayout no longer ignores repeating links, and will now place them at a distance specified via RepeatingLinksPadding property.

New in version 2.1

Tree map layout

Tree maps represent hierarchies by nesting child nodes within their parents, where the areas of leaf nodes are proportional to their Weight values. Unlike other layout algorithms, TreeMapLayout expects hierarchies to be defined via grouping or containment (see AttachTo method and ContainerNode class), and will ignore any links in the diagram. The diagram area covered by the topmost nodes in a hierarchy is specified via the LayoutArea property. By default, the layout tries to keep the ratio of node sides as close as possible to one. However this could make it hard to distinguish separate levels of the hierarchy. To alleviate that, set Squarify to false, and child nodes will be arranged either as a row or a column inside their parent node, alternating directions for each level. The drawback is that when Weight ratios differ greatly or nodes contain many children, some nodes could end up with very narrow rectangles.

Decision flowchart layout

DecisionLayout arranges simple flowcharts consisting of decision boxes with up to three outgoing links per node and activity boxes with a single outgoing link per node. The nodes are arranged in columns and rows, whose distance depends on the HorizontalPadding and VerticalPadding property values. When links share the same row or column, they are placed at a distance specified via LinkPadding. The layout arranges nodes recursively starting from StartNode. If StartNode is not specified, the algorithm selects the root of the deepest branch of the graph's spanning tree as start node.

Miscellaneous

  • Layout algorithms now automatically resize diagram's Bounds if it's not large enough to fit the arranged content. To revert to old behavior and keep fixed Bounds size, set GrowToFit to false.
  • Fixed hit-testing offset bug when using version 4 of Microsoft Ajax in Chrome browser.
  • Fixed error when using gradient brushes for painting swimlane grid cells.

New in version 2.0

Export Visio 2013 files

The Visio2013Exporter class can export the contents of Diagram and DiagramDocument objects to Visio 2013 VSDX files. In order to use it, add a reference to the MindFusion.Diagramming.Export.Visio.dll assembly. Similarly to the VDX format exporter, Visio2013Exporter relies on a template file, called Visio2013.vxt, containing some boilerplate Visio XML code. The template must be either located in same folder as the application assemblies, or its path must be specified via the TemplatePath property. At this time the exporter supports shapes from Visio basic and flowchart stencils.

Visio2013Importer improvements

  • The importer now supports Visio group shapes. Child shapes in groups are no longer lost when importing, and their corresponding diagram nodes are attached to the corresponding group node.
  • Visio NURBS curves are now imported as Bezier-style links.
  • Fix for importing connectors with applied rotation transform.
  • Shapes with a ‘hidden’ attribute in master definition are now imported as invisible items.

Headers and footers in PDF

PdfExporter can now add headers and footers to exported pages. To specify their contents and font, set the HeaderFormat, HeaderFont, FooterFormat and FooterFont properties. Adding a %P placeholder to HeaderFormat or FooterFormat will render the current page number at its position.

Resize multiple nodes

Now it is possible to resize multiple selected nodes simultaneously. To enable that, set the AllowMultipleResize property to true. When enabled, dragging a corner or side adjustment handle of any node resizes all nodes in the selection. The operation will be cancelled for all nodes if any of them does not accept its new size, e.g. if it's smaller than MinimumNodeSize value. The operation can be cancelled on the client side for all nodes by handling the selectionModifying validation event.

Undo / redo support

If the UndoEnabled property is set to true, the Diagram control tracks changes done to its items and allows undoing and redoing them later by calling the undo and redo methods respectively. Multiple changes could be recorded as a single undoable operation by enclosing them between startCompositeOperation and commitCompositeOperation calls. It is also possible to create custom undoable operations by deriving from the Command class and calling executeCommand with the custom command as argument.

Animations

Diagram items can now be animated through the Animation class in the MindFusion.Animations namespace. The class implements several built-in animation and easing types, and allows definition of custom animation functions, to create fluid and pleasing animation effects. The new Animations example demonstrates how to apply several animation types to both nodes and links.

Clipboard support

A single item or a selection of items can be copied or cut to a clipboard maintained by the diagram control. This is done programmatically using the copyToClipboard and cutToClipboard methods. To paste the clipboard contents into the current diagram, call pasteFromClipboard. If running under Internet Explorer, it is also possible to copy to the system clipboard by passing a true argument to clipboard methods.

Swimlanes

The lane grid lets you emphasize the relationship between a group of diagram items by displaying them in a distinct lane or cell within the grid. To display the lane grid, set the ShowLaneGrid property of the Diagram class to true. In order to customize the grid, set the various attributes exposed by the LaneGrid property, which lets you specify the number of rows and columns, add headers, customize the cell appearance, etc. The new Lanes sample page uses the lane grid to let users draw Gantt charts.

Magnifier

The new magnifier tool allows users to interactively zoom in (or out) portions of the diagram by holding down a modifier key or pressing a mouse button. The magnifier's appearance can be customized via properties such as MagnifierShape and MagnifierFrameColor. Its size and magnification can be set via MagnifierWidth, MagnifierHeight and MagnifierFactor properties. The magnifier appears when users press the mouse button mapped to MouseButtonActions.Magnify. It can also be shown programmatically by setting the MagnifierEnabled property.

Intellisense support

The package now includes a MindFusion.Diagramming-vsdoc.js file providing code completion information. To load it in Visual Studio, add e /// <reference path="MindFusion.Diagramming-vsdoc.js" /> tag to the top of your script files. Use the static Diagram.create and Diagram.find methods instead of $create and $find to let Visual Studio infer the type of returned Diagram objects correctly.

Miscellaneous

  • Several new shapes added for better compatibility with Visio 2013 basic stencil: RightTriangle, Decagon, Trapezoid, Star4Pointed, Star5Pointed, Star6Pointed, Star7Pointed, Star16Pointed, Star24Pointed, Star32Pointed, Donut, Plaque.
  • Set the ModificationStart property to AutoHandles to let users start moving or resizing an item without selecting it first.
  • The diagram area can be resized automatically to fit the current diagram items as set through the AutoResize property.
  • The AutoScroll property enables automatic scrolling when the mouse is dragged near the diagram edges.
  • enterInplaceEditMode and leaveInplaceEditMode events raised when the control shows or hides the in-place edit box.
  • linkPointed and nodePointed events raised when the mouse hovers over an item.
  • The control displays a scaled-down copy of the node being dragged from the NodeListView control.
  • Set Behavior to SelectOnly to let users select existing items but not to modify them or draw new ones.
  • Added chainable Set* methods for all DiagramView properties.

API changes

  • The HitTestHandle method now returns an AdjustmentHandle result instead of bool and ref int values.
  • The type of HitResult argument of the HitTestAdjustmentHandles event has been changed to AdjustmentHandle.
  • AnchorUnitType enumeration has been renamed to UnitType.
  • The SelectionMoved event has been renamed to SelectionModified, and is also raised if nodes are resized when AllowMultipleResize is enabled. Event handlers now receive SelectionEventArgs parameter instead of EventArgs.
  • The SelectionMoving event has been renamed to SelectionModifying, and is also raised if nodes are resized when AllowMultipleResize is enabled. Event handlers now receive SelectionValidationEventArgs parameter instead of ValidationEventArgs

New in version 1.8

Rounded links

Links whose Shape is set to Polyline or Cascading can be rendered with rounded joints between their segments. To enable that, set the diagram's RoundedLinks property to true. The RoundedLinksRadius property lets you specify the radius of joint arcs.

Link crossings

The component can represent the crossing point of two links either as an arc (bridge) drawn for the link with higher Z index, or as a cut in the link with lower Z index. To enable that, set the diagram's LinkCrossings property to either Arcs or Cut member of LinkCrossings enumeration. Set CrossingRadius to specify the radius of crossing arcs.

Visio2013Importer improvements

  • The Item argument of ImportItem event handlers is now pre-set to a DiagramItem instance created for the imported Visio shape, letting you avoid parsing some standard data such as Bounds or Text. You can either modify this item's properties, or replace it with a new instance of a different type.
  • Fixed a crash when a shape master does not have a name attribute (this happens with custom stencils).
  • Fixed a crash when theme1.xml is missing from the imported vsdx archive (this happens with files converted from old Visio versions to 2013 format).
  • Fixed a parse exception for some non-English locales.
  • Fixed a bug where one-segment connectors were imported at wrong positions.

Miscellaneous

  • Node rotation was ignored by link routing algorithm; now links are routed around the rotated node's boundaries.
  • The routeAllLinks function pulls apart link segments when they would overlap.
  • Set Behavior to Pan to only let users pan the view when dragging the mouse.
  • The component now raises clicked event for the diagram when there isn't any item at the click location (which would cause nodeClicked or linkClicked event).

New in version 1.7

Import Visio .vsdx files

The Visio2013Importer class can import .vsdx files, created by Visio 2013. In order to use it, you must add a reference to the MindFusion.Diagramming.Import.Visio.dll assembly. Various overloads of the Import method can be used to import the file into a DiagramDocument whose pages correspond to the Visio drawing pages, or into a single Diagram whose content is merged from all imported pages. Visio2013Importer supports the basic flowchart and data flow Visio stencils. For each node shape from the .vsdx file, the importer creates a ShapeNode object whose Shape, Text, Brush and Pen properties are set to values corresponding to the imported Visio shape. For each connector shape, the importer creates a DiagramLink object whose Origin and Destination are set to the corresponding imported nodes, and whose ControlPoints reflect the geometry of the connector.

Adjustment handle styles

Appearance of nodes' adjustment handles can be customized by setting the HandlesStyle property. Supported styles include round and square handles, dashed and hatched frames, and some combinations. Apart from appearance, the handles style also controls what part of a node can be dragged to move or resize it. It is also possible to render custom handles by handling the drawAdjustmentHandles event, and implement custom hit-testing by handling the hitTestAdjustmentHandles event.

Dynamic links

A dynamic link automatically orients its end segments so that they point to the target nodes' centers while the link's nodes are dragged around. If a node's AnchorPattern is set, link ends will align to the closest anchor point instead. Positions of the link's end points are also updated when the next-to-last control points are being modified. To enable this, set the Dynamic property to true.

ContainerNode enhancements

  • Apply layout algorithms to content of a ContainerNode by calling its arrange method.
  • Selectively prevent adding or removing child nodes to/from a container by handling the containerChildAdding and containerChildRemoving events.

Miscellaneous

  • The Dirty flag is automatically set when a serializable property of an item or the diagram has been modified. It lets you determine where there are any changes that need to be saved.
  • The AdjustmentHandlesSize property specifies the size of adjustment handles.
  • The ShowDisabledHandles property controls whether disabled adjustment handles are draw on screen.
  • Several new predefined shapes available in the Shapes class - RightTriangle, Decagon, Trapezoid, Star4Pointed, Star5Pointed, Star6Pointed, Star7Pointed, Star16Pointed, Star24Pointed, Star32Pointed, Donut and Plaque.

New in version 1.6

Import OpenOffice Draw files

The DrawImporter class can import .odg files, created by the OpenOffice Draw vector graphics editor. In order to use it, you must add a reference to the MindFusion.Diagramming.Import.Draw.dll assembly. Various overloads of the Import method can be used to import the OpenOffice drawing into a DiagramDocument whose pages correspond to the Draw pages, or into a single Diagram whose content is merged from all imported pages. DrawImporter supports shapes from the General and Flowchart shape palettes in Draw. For each node shape from the .odg file, the importer creates a ShapeNode object whose Shape, Text, Brush and Pen properties are set to values corresponding to the imported OpenOffice shape. For each connector shape, the importer creates a DiagramLink object whose Origin and Destination are set to the corresponding imported nodes, and whose ControlPoints reflect the geometry of the connector.

ContainerNode improvements

  • Child nodes are now drawn by their containers; when containers overlap, the children of a lower container cannot appear in front of the upper container anymore.
  • The ClipChildren property specifies whether to clip child items to container's boundaries.
  • The ZIndex property no longer changes automatically when dropping nodes into a container.
  • The Visible property of child items no longer changes when folding or unfolding containers; this lets you keep invisible items inside containers.
  • When selection including a container and its child node is dropped into another container, the child node now remains in its original container.

PdfExporter improvements

  • Improved handling of clip regions in custom drawing code.
  • PdfExporter now honors the target Rectangle property of linear gradients.
  • PDF shadings now include all colors from a ColorBlend.
  • More precise character widths set when text includes both eastern glyphs and Latin characters.
  • More precise widths set for Cyrillic characters.

Miscellaneous

  • New overloads of the DiagramView, Overview and NodeListView extension methods have been added. The initFunction parameter can be used to set the name of the javascript function, which will contain the initialization code for the corresponding control.
  • controlLoaded event is now raised when a control is loaded on the client-side.
  • Added support for Diagram.LinkHitDistance, DiagramItem.HyperLink and DiagramNode.EnabledHandles properties.
  • Added support for custom node and link types - check the new CustomNodes sample on how to use them.
  • Two new measure units - Centimeter and WpfPoint are now available.

New in version 1.5

Server Side

Miscellaneous

  • DiagramView's *Script properties have been modified to chainable methods.
  • Use the FromRequest method of the DiagramView for easier recreation of the view's data after postback.
  • FallbackContent property allows specifying of a fallback content for the DiagramView.
  • NodeSelectedScript, NodeDeselectedScript, NodeDoubleClickedScript, LinkSelectedScript, LinkDeselectedScript and LinkDoubleClickedScript methods have been added to support the corresponding client-side events.

Client Side

Node effects

Two visual effects, represented by GlassEffect and AeroEffect classes, can be applied to nodes. To apply an effect, create an instance of the respective class, set up its properties, then add the instance to the Effects collection of a node (or to Diagram.NodeEffects collection to apply it to all nodes). Effects can be added, removed or modified at any time and this will immediately reflect on the diagram. Effects of different types can be applied simultaneously. It is also possible to apply more than one effect of the same type.

Radial gradients

Nodes can be filled using radial gradients by passing objects in following format to setBrush. If the gradient should blend only two colors, they can be specified using color1 and color2 fields instead of colorStops.

JavaScript [image] Copy Code

var brush =
{
type: "RadialGradientBrush",
colorStops:
[
{ position: 0, color: "white" },
{ position: 0.5, color: "lightGray" },
{ position: 1, color: "blue" }
],
x1: 20, y1: 20, radius1: 30,
x2: 40, y2: 20, radius2: 80
};
node.setBrush(brush);

Multiple labels per link

The LinkLabel class allows multiple captions to be displayed for a single DiagramLink object. Link labels provide a set of properties allowing full customization of their display and positioning. Labels can also be arranged automatically to avoid overlapping nodes and other labels by setting LinkLabel.AutoArrange to true.

New events

  • nodeSelected and linkSelected events are now raised when an item is selected, either programmatically or by the user.
  • nodeDeselected and linkDeselected events are now raised when an item is deselected, either programmatically or by the user.
  • nodeDoubleClicked and linkDoubleClicked events raised when the user double clicks an item.
  • nodeCreating is now also raised while the user drags a node from the NodeListView control.

Miscellaneous

  • Call setVirtualScroll to enable virtual scrolling mode. In this mode, the canvas stays as big as its containing div, and its content is drawn with a translation bound to the div's scrollbar positions. This allow displaying large diagrams in browsers and on mobile devices where the size of HTML canvas elements is limited.
  • resizeToFitText method added to ShapeNode.
  • Improved support for nested containers.

New in version 1.4

Server side

Styles and themes

The appearance of the items in a diagram can now be modified using styles. The style represents a set of properties, which can be applied to an individual diagram item (by assigning it to the DiagramItem.Style property) or to all items of a specific type (by using a Theme).
The theme represents a collection of styles. Each style in the theme is associated with the diagram items of a specific type and affects all items of this type. Themes can be loaded from XML files.

For more information about this new feature, check Styles and Themes.

One-way graph Layout

The OneWayLayout class ensures that links enter into nodes from the same general direction and exit them from the opposite side. If the graph contains cycles, some links bend around the nodes to keep the enter/exit direction consistent. The algorithm aims to minimize the number of such links.

Composite layout improvements

The CompositeLayout exposes several new properties. The UseAdditionalPartitioning property can be set to true in order to enable additional partitioning pass after the default partition. This is especially useful when the initial partitioning produces a graph with nodes with many leaf children.

Parallel layouts

The .NET 4 version of MindFusion.Diagramming takes advantage of the Task Parallel Library (TPL) to enable parallelism on the different layout algorithms. Set the EnableParallelism property on the Layout class to true to enable arranging different subgraphs on different threads to possibly improve performance on multiprocessor systems. In addition, the maximum degree of concurrency can be manipulated through the MaxDegreeOfParallelism property. Note that only independent subgraphs are processed in parallel, so the SplitGraph property of layout classes that provide it must also be set.

Preserve order in tree layout

The Balance property of TreeLayout can be set to Preserve to keep the original geometric order of child nodes when arranging them under their parent. This can be used to arrange tree branches in a specific order by first positioning them in increasing horizontal or vertical positions.

Export improvements

  • RenderOptions property added to PdfExporter, SvgExporter and WmfExporter allows controlling various aspects of exported diagrams.
  • Speed of PDF generation by PdfExporter greatly improved.
  • VisioExporter.DynamicsOff can be used to disable dynamic link routing in Visio 2010 in order to preserve the position of control points from the exported diagram;
  • PdfExporter now creates PDF Bezier objects for Bezier curves in the diagram instead of approximating them with lines;
  • If VisioImporter.ApplyVisioUnit is enabled, the diagram's unit will be set to the one from the imported VDX file;

Miscellaneous

  • The value of DiagramItem.ZIndex property is no longer required to be unique and smaller than the number of items;
  • Diagram item collection types now implement the generic IList interface;
  • The last row in a TableNode will now be rendered clipped if it fits only partially inside the node, whereas in previous versions the row would not be rendered at all.
  • The AllowAddChildren and AllowRemoveChildren properties of ContainerNode specify whether users are allowed to add or remove child nodes to / from the container.
  • The GetNearestBorderPoint method of DiagramNode can be used to find a point from the node's border closest to a specified point.

API changes

  • RotationAngle property moved from ShapeNode to base DiagramNode;
  • Type of Group.FollowMasterRotation changed from boolean to enum GroupRotation;
  • LinkStyle enum renamed to LinkShape;
  • DiagramLink.Style property renamed to Shape;
  • The type of TextColor and CaptionColor properties have been changed to Brush; the properties have been renamed to TextBrush and CaptionBrush;
  • The default value of Pen, Brush and Font properties of items is now null (Nothing in Visual Basic) to allow for inheritance from DiagramItem.Style or Diagram.Theme.
  • ZIndex no longer corresponds to the position of items within Diagram.Items collection. Items however still contains the items sorted by Z order, as defined by item's ZIndex;
  • Event handler delegates have been removed; events are now defined as generic EventHandler specialized via EventArgs type. For example the type of NodeCreated is now EventHandler<NodeEventArgs>;
  • InitializeNodeScript and InitializeLinkScript properties have been added to support initializeNode and initializeLink client-side events.
  • NodeListView.AddShapeNode method renamed to AddNode.

For more detailed description of changes and additional information about how to move to version 1.4, check the Moving to MvcDiagram 1.4 topic.

Client side

Table Nodes

A TableNode displays tabular data, and can be used to represent table schemas in database diagrams or classes in class-hierarchies. A table contains cells arranged in a grid, and every cell can display text and/or image. Cells, columns and rows can be customized in various ways - there are properties available for setting their extents, style, image and text alignment. The number of cells in a table's grid can be programmatically changed by calling methods such as redimTable, insertRow and insertColumn. If a table contains many rows, you can let users scroll them up or down by calling the setScrollable method.

Container Nodes

A ContainerNode can contain other diagram nodes. When a container is moved, its child nodes move too. Containers can be nested one within another to unlimited depth. They can be folded to a smaller size, hiding their child items, and unfolded to show content again. Nodes inside a container can be linked to nodes both inside and outside of it. If a link connects items in the same container, the container is not considered an obstacle by the auto-routing algorithm.

Styles and Themes

An instance of the Style class can be used to set items' appearance properties as a single unit via the setStyle method. In order for style attributes to be used, the respective local appearance properties of a DiagramItem objects must have undefined or null values. If an item's Style does not define a value for some attribute, it is looked up in the styling hierarchy, first in the diagram's Style, next in the current Theme, and finally in the set of default styles defined for each item class.

Shadows

Diagram items can now cast shadows. The shadow color is specified via the setShadowColor method and the offset of a shadow from its item is set via setShadowOffsetX and setShadowOffsetY methods. Shadows aren't rendered if getEffectiveShadowColor returns null or undefined value.

Miscellaneous

  • The Locked property can be used to disable interaction with a diagram item.
  • Improved rendering speed when changing items' appearance properties.
  • Call the setTooltip method to associate tooltip text with an item. The tooltip appears when the mouse pointer hovers over an item for a second.
  • Specify the line width of item frames via the setStrokeThickness method.
  • initializeNode and initializeLink events are raised when users start drawing a node or a link interactively.
  • The NodeListView control can now host table and containers. The addBox and selectBox methods have been replaced by addNode and selectItem methods.
  • The setStartPoint and setEndPoint methods of links provide shortcuts for setting the first and last points in ControlPoints.

New in version 1.3

Attaching and grouping items

MvcDiagram allows attaching a node to another node, establishing a subordinate - master relationship between them. The easiest way to attach nodes is to call the attachTo method. When a master node is moved, all of its subordinates follow it, so that the initial distance between them stays constant. This happens both when a user moves the master node around, and when the node's position is changed using a method or a property.

Collapse and expand tree branches

If a diagram represents a tree structure, the tree branch starting from a node can be collapsed or expanded again in order to hide or display hierarchy details. To enable this, call the setExpandable method. There is a [±] button displayed beside an expandable node to allow users to collapse or expand the tree branch starting there. By default, pressing that button automatically toggles the Expanded property of the node and raises the TreeExpanded or TreeCollapsed events.

User interaction modes

Call setBehavior with one of the Behavior members as argument to specify how the diagram should handle mouse input.

  • DoNothing: the diagram is read-only, but nodeClicked and linkClicked events are still raised.
  • Modify: existing diagram items can be selected and modified, but no new items can be created interactively.
  • DrawLinks: existing nodes can be linked interactively, but no new nodes can be drawn.
  • DrawShapes: drawing with the mouse creates new ShapeNode objects; links cannot be created interactively.
  • LinkShapes: this is the default behavior, where drawing over an empty spot of the diagram creates a ShapeNode, and drawing over a node creates a link.

Touch input

When running under the iOS Safari web browser, the control handles one-finger touch events to allow drawing and selecting items interactively. In addition, the hit-test area around adjustment handles is larger to make touch modifications easier. Two-finger gestures are delegated to the browser - they either scroll the canvas when dragging in the same direction or zoom the page when dragging in opposite directions. The preventDefaultTouch flag can be set to false to revert to the default one-finger touch behavior (scroll the whole page).

Miscellaneous

  • The Visible property specifies whether an item should be shown on screen.
  • Validation events added: NodeCreating, LinkCreating, NodeDeleting, LinkDeleting, NodeModifying and LinkModifying.
  • The ScrollX and ScrollY properties and scrollTo method lets you set the diagram's scroll position.
  • getViewport returns the currently visible part of the diagram.
  • setZoomFactorPivot sets the zoom level in such way that the pivot point's screen position does not change.
  • zoomToRect zooms and scrolls the view to fit the specified document rectangle in the Diagram's visible area.
  • zoomToFit zooms the view to fit the document contents into the current view size.
  • getContentBounds returns the smallest rectangle that bounds all diagram objects.
  • keepGroupLayout indicates whether to treat each group of attached nodes as a single vertex in the arranged graph.
  • Extension methods are modified to add MVC3 Razor support.

New in version 1.2

Server side

Fractal tree Layout

FractalLayout is a tree layout algorithm that places child nodes symmetrically around their parent node. Nodes at the lowest level are arranged directly in a circle around their parent. At upper levels, the already arranged nodes form branches that are arranged in a circle around the new parent node. The algorithm is recursively repeated till the highest level is reached. If nodes in the tree have uniform number of children, the end result has fractal-like appearance (subsets of the graph look like scaled-down copies of the whole graph). You can choose which node should be displayed at the center of the topmost circle by setting the Root property. If it is not specified, the algorithm automatically selects a root that leads to more balanced distribution of nodes.

LayeredLayout enhancements

- Specify start and end nodes in LayeredLayout via the StartNode and EndNode properties.
- EnforceLinkFlow specifies whether to attempt to force all links to go in the same direction. If the graph being arranged contains cycles, some of the links will still go backward.

Client side

Alignment grid

The alignment grid help users place the diagram items more precisely. To activate the grid, set the AlignToGrid property to true. If the grid is active while an item is being created or modified, the item's control-points are aligned to the nearest grid points. The distance between adjacent grid points is set via the GridSizeX and GridSizeY properties. The grid can be either visible or invisible, depending on whether the ShowGrid value is true or false. If visible, the grid is painted as a matrix of points or as series of crossing lines, as specified by the GridStyle property. GridColor defines the color with which the alignment points or lines are painted.

Bordered tree layout

In contrast to TreeLayout, which centers the parent node above its child nodes, BorderedTreeLayout arranges children in columns at a horizontal offset form their parent. BorderedTreeLayout members control the tree direction, how much space to leave between tree levels, and between nodes on the same level.

Anchor points

The AnchorPattern class represents a set of AnchorPoint objects, which specify the exact locations where links are allowed to connect to nodes. A pattern can be assigned to nodes by calling their setAnchorPattern method. The AnchorPattern class exposes several predefined patterns as static fields: decision2In2Out, decision1In3Out, leftInRightOut, topInBottomOut.


Moving to MvcDiagram 1.4

Moving to MvcDiagram 1.4

The following topics describe the changes you need to do when moving from version 1.3 to version 1.4 of the control.


Changes in Control's Behavior

Changes in Control's Behavior

Z order

A significant change in the control's behavior is that it now allows different items to have the same ZIndex values. You must revise your code if it relies on ZIndex being unique or corresponding to the item's position within the Items collection.

Beware of Null Property Values

Brush, Pen and Font properties of diagram items now have null values by default. This allows items to be skinned via styles and themes. If you need to set a specific object member of one of these properties, you must assign a new object instance to the respective property. For example, such code might throw an exception now:

C# [image] Copy Code

node.Pen.Color = Color.Black;
node.Pen.Width = 3;

You must replace it with the following:

C# [image] Copy Code

node.Pen = new Pen(Color.Black, 3);

When drawing custom graphic elements for an item, use the EffectiveBrush, EffectivePen and EffectiveFont properties to access the objects that should be used for drawing - whether they come from local property values, from the item's Style or from a Theme applied to the diagram.


API Changes

API Changes

Removed delegates

Delegate types that used to define events have been removed. Events are now defined using the generic EventHandler delegate with the respective EventArgs-derived type as argument. For example, NodeCreated is now defined as follows:

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeCreated;

The follow list shows all delegate types that have been removed:

  • ControlNodeEventHandler
  • CopyHostedControlEventHandler
  • InPlaceEditEventHandler
  • PaintControlEventHandler
  • AnchorPointEventHandler
  • AreaEventHandler
  • CellEventHandler
  • CellValidationEventHandler
  • ClipboardEventHandler
  • ContainerChildEventHandler
  • DiagramEventHandler
  • DrawAnchorPointEventHandler
  • DrawCellEventHandler
  • DrawItemEventHandler
  • DrawLinkEventHandler
  • DrawNodeEventHandler
  • EditCellTextEventHandler
  • EditLinkTextEventHandler
  • EditNodeTextEventHandler
  • GroupEventHandler
  • HitTestEventHandler
  • InstantiateItemEventHandler
  • ItemEventHandler
  • LinkEventHandler
  • LinkValidationEventHandler
  • NodeEventHandler
  • NodeValidationEventHandler
  • RepaintEventHandler
  • RowEventHandler
  • SerializeTagEventHandler
  • ShapeEventHandler
  • TimerEventHandler
  • TreeItemEventHandler
  • TreeItemValidationEventHandler
  • UndoEventHandler
  • UndoValidationEventHandler
  • ValidationEventHandler

Removed delegates in the MindFusion.Diagramming.Import namespace:

  • ConnectorImportedEventHandler
  • GroupImportedEventHandler
  • ShapeImportedEventHandler

Renamed types and members

The following table lists the renamed types.

Old name | New name
LinkStyle | LinkShape
TableStyle | SimpleShape
GroupImportedArgs | GroupImportedEventArgs

The following table lists the renamed members.

Old name (old type) | New name (new type)
Diagram.LinkStyle (LinkStyle) | Diagram.LinkShape (LinkShape)
DiagramLink.Style (LinkStyle) | DiagramLink.Shape (LinkShape)
ContainerNode.CaptionColor (Color) | ContainerNode.CaptionBrush (Brush)
TableNode.CaptionColor (Color) | TableNode.CaptionBrush (Brush)
DiagramItem.TextColor (Color) | DiagramItem.TextBrush (Brush)
DiagramItem.ShadowColor (Color) | DiagramItem.ShadowBrush (Brush)

The z-order related methods in the DiagramItem class now also accept a single boolean argument.

Collections

Several collections have been converted to generic types. The table below provides an overview of this change.

Old signature | New signature
ItemCollectionBase | ItemCollectionBase<T>
PersistableCollection | PersistableCollection<T>
ReadOnlyCollection | ReadOnlyCollection<T>

In addition the collection classes no longer implement IList and ICollection. Calls that expect those interfaces will result in compilation errors. The collection classes also do not expose the Capacity property.


Default Values

Default values

With the introduction of the new style system, the following default-value properties in the Diagram class are considered obsolete and will no longer have any effect on newly created items:

  • ShapePen
  • ShapeBrush
  • LinkPen
  • LinkBrush
  • TablePen
  • TableBrush
  • ShadowBrush
  • Font
  • TextColor

To provide the same functionality as those properties did before, use a Theme object with styles associated with the appropriate diagram item types. For example, to provide default pen for shape nodes, use the following code:

C# [image] Copy Code

ShapeNodeStyle defaultStyle = new ShapeNodeStyle();
defaultStyle.Stroke = ...;
defaultStyle.StrokeThickness = ...;
Theme theme = new Theme();
theme.RegisterStyle(typeof(ShapeNode), defaultStyle);
diagram.Theme = theme;

Visual Basic [image] Copy Code

Dim defaultStyle As New ShapeNodeStyle()
defaultStyle.Stroke = ...
defaultStyle.StrokeThickness = ...
Dim theme As New Theme()
theme.RegisterStyle(GetType(ShapeNode), defaultStyle)
diagram.Theme = theme

For convenience, the CreateThemeFromDefaults method of the Diagram class can create this Theme object from the diagram's current default values.

Alternatively, you can set the default values through a set of shortcut properties in the Diagram class. These shortcut properties create a Theme object internally, register the appropriate classes and assign the theme to the diagram. The following table illustrates this.

Old property | New equivalent
Diagram.ShapePen | Diagram.ShapeNodeStyle.Stroke Diagram.ShapeNodeStyle.StrokeThickness
Diagram.ShapeBrush | Diagram.ShapeNodeStyle.Brush
Diagram.LinkPen | Diagram.DiagramLinkStyle.Stroke Diagram.DiagramLinkStyle.StrokeThickness
Diagram.LinkBrush | Diagram.DiagramLinkStyle.Brush
Diagram.TablePen | Diagram.TableNodeStyle.Stroke Diagram.TableNodeStyle.StrokeThickness
Diagram.TableBrush | Diagram.TableNodeStyle.Brush
Diagram.ShadowBrush | Diagram.DiagramStyle.ShadowBrush
Diagram.Font | Diagram.DiagramStyle.FontFamily Diagram.DiagramStyle.FontSize Diagram.DiagramStyle.FontStyle Diagram.DiagramStyle.FontUnit
Diagram.TextColor | Diagram.DiagramStyle.TextBrush

Important!

The Font, Brush, and Pen properties of diagram items are no longer guaranteed to be non-null. In fact their default value is now null, so replace these properties with their EffectiveFont, EffectiveBrush, and EffectivePen counterparts.


MvcDiagram Fundamentals

MvcDiagram Fundamentals

MvcDiagram consists of two main components, a .NET class library running on the server and a client side control implemented in JavaScript.

Server side

The .NET library implements a flow-diagramming object model that lets you define structures such as trees, flowcharts and graphs. The most important classes from the library are Diagram, ShapeNode, TableNode, ContainerNode, SvgNode and DiagramLink. A Diagram instance serves as the container for relational graph data, whose content is accessed through the Nodes and Links collections. Nodes contain DiagramNode instances that represent the nodes (a.k.a. vertices) in a graph or tree, and Links contain DiagramLink instances that represents the links (a.k.a. edges/arcs) between nodes in the graph. Usually a Diagram instance will be a part of a Model class in an MVC application, or will be used as an intermediate object that only maps the model data to the client-side diagram view.

Once the Diagram is populated, it can be rendered as part of an HTML page by calling the DiagramView extension method from the MVC view code.

There are also various export classes you can use on the server to export diagrams to PDF, SVG, Flash, DXF, Visio and WMF formats.

Client side

On the client side a diagram is rendered by a Diagram JavaScript control that draws the diagram content on an HTML Canvas. The Diagram control is implemented using the Microsoft Ajax library. It also allows the user to add new nodes and links to the diagram by drawing them with the mouse. New nodes can also be created via drag-and-drop from the NodeListView control.

Some of the automatic layout features you might know from other MindFusion diagramming controls are implemented on the client side, including Layered, Tree, Spring and Fractal layouts.

The Canvas HTML element is supported by all current browsers. Built-in Canvas support in Internet Explorer initially appeared in IE9, but can be enabled in older versions via the Google ExplorerCanvas (http://code.google.com/p/explorercanvas/ [image] ) library.


User Interaction

User Interaction

Most likely an application will use MvcDiagram to enable users to interactively create diagrams, flowcharts and other kinds of presentation documents. A user composes or edits a diagram by drawing its elements on the diagram canvas area. With the help of a mouse or another pointing device users draw shapes and links, possibly connecting them in complex hierarchies, graphs, trees or other structures they might need.

Creating New Items

New items can be created by drawing them with the mouse. While a user drags the mouse, the view of the control is updated to show what the new item would look like at the pointer location. If the operation cannot be completed at the current mouse position, the cursor changes to a crossed out circle. When the user releases the button, the item is created. The control does not let users create very tiny nodes which would be hard to select and modify. By default links can be drawn only between nodes, unless the AllowUnconnectedLinks property is enabled. Users can cancel item creation by pressing the right mouse button while drawing.

A node can also be created via drag-and-drop from the NodeListView control. Its instance can be added to the html page by calling the NodeListView extension method and specifying a collection of prototype nodes that should be listed in the palette.

Modifying Items

A user modifies an item by dragging its manipulation handles. The ModificationStart property specifies when these handles appear. The first option, AutoHandles, makes the handles appear when the mouse hovers over an item; modification of the item can start immediately by pointing it and dragging a handle. The second option is SelectedOnly: in order to be modified, an item should first be selected. Manipulation handles appear around the item to indicate that now it can be moved or resized. Number and functionality of those handles depend on the item type and the value of the corresponding HandlesStyle property.

Modifying a Node

Usually nodes have nine adjustment handles. The one at the center can be used to move the node. When dragged, each corner handle resizes the node by moving the two edges adjacent to the corresponding corner. The edge handles placed at the center of each side can be used to resize a node either horizontally or vertically. Shape nodes can be rotated using an additional round handle drawn above them. Each handle can be enabled or disabled by setting or clearing the respective bit in EnabledHandles.

Modifying a Link

Variety and behavior of link adjustment handles depend on the link's Shape and SegmentCount. Control-points stay at both ends of each segment that constitutes a link. MvcDiagram offers three link styles. Following sections discuss how to modify links of each style.

  • The first style called Polyline defines links, which consist of a series of straight segments, drawn between control-points. There are no restrictions as to the number of segments. Dragging a control-point modifies each segment adjacent to the point. If the AllowSplitLinks property is enabled, users are allowed to insert new control points or to remove existing ones. Inserting a control point is done by pressing the left mouse button over a segment and dragging. The new point appears at the mouse location and splits the pointed segment in two.
  • If link's style is set to Bezier, each segment has 4 manipulation handles that define a curve. Each curve goes through the end-points, which are shaped as circles. Bend of the curve is defined by the middle two points shaped as rectangles. If a user drags an end-point modification handle, the adjacent control points will be moved with same translation vector as that of the end-point. If a bend control point is dragged, the symmetric control point of the neighboring curve is also moved to ensure the two stay on the same line with the end-point and on the same distance from it.
  • Cascading links consist of straight horizontal and vertical segments, each one orthogonal to its neighbors. If a control-point is dragged, the segments adjacent to it are moved and resized preserving their orthogonal orientation to each other. If the AllowSplitLinks property is enabled, users are allowed to insert new control points to Cascading links or remove existing ones. The orientation of the link segments can be changed if CascadeOrientation is set to Auto.

Selecting Items

Multiple items are selected by dragging while CTRL key is down. Selection can also be toggled with CTRL + clicking an item. A rectangle appears around selected items, allowing a user to move all of them at once.


Programming Interface Overview

Programming Interface Overview


Diagram Structure

Diagram Structure


Standard Item Types

Standard Item Types

Diagram elements in MvcDiagram are represented by ShapeNode, TableNode, ContainerNode and DiagramLink instances. Combined and linked together, they can form complex data structures such as process or entity-relationship diagrams, class hierarchies, networks and graphs. Each of their rich features can be customized through numerous methods and properties.

Shape Nodes

ShapeNode objects can represent geometric shapes, flowchart elements, icons in network diagrams, and so on. They can display both graphics and text in different fonts, sizes and colors. There are more than 100 predefined node shapes (you can preview them here) and apart from them, MvcDiagram offers an easy way to define custom shapes. Shape nodes can be rotated, either interactively using the round selection handle drawn above them, or programmatically using the RotationAngle property. Each node can also display a distinct bitmap image specified via its ImageUrl property.

Table Nodes

A TableNode displays tabular data, and can be used to represent table schemas in database diagrams or classes in class-hierarchies. A table contains cells arranged in a grid, and every cell can display text and/or image. Cells, columns and rows can be customized in various ways - there are properties available for setting their extents, style, image and text alignment. Tables' dimensions can be programmatically changed; inserting, appending or deleting rows and columns can be done in a very comprehensive, intuitive way whenever you might need it. Tables can also display background images and graphics.

Container Nodes

A ContainerNode can contain other diagram nodes. When a container is moved, its child nodes move too. Containers can be nested one within another to unlimited depth. They can be folded to a smaller size, hiding their child items, and unfolded to show content again. Nodes inside a container can be linked to nodes both inside and outside of it. If a link connects items in the same container, the container is not considered an obstacle by the auto-routing algorithm.

Diagram elements in MvcDiagram are represented by ShapeNode, TableNode, ControlNode and DiagramLink instances. Combined and linked together, they can form complex data structures such as process or entity-relationship diagrams, class hierarchies, networks and graphs. Each of their rich features can be customized through numerous methods and properties. MvcDiagram also offers intuitive user interface for drawing and editing diagram items interactively.

SVG Nodes

The SvgNode class represents nodes that can display SVG drawings. SVG graphics are rendered instead of Image, and on top of the geometry rendered by the base ShapeNode class. The SVG drawing of the node is specified through its SvgUrl property.

Links

DiagramLink objects are used to represent various types of connections and relations in diagrams. MvcDiagram offers three basic link types:

  • polyline links composed of straight-line segments;
  • curved links composed of Bйzier-spline segments;
  • links composed of horizontal and vertical segments, alternating their orientation so that every segment is orthogonal to its neighbor.

A link can be connected to a node at each of the link's ends. It is also possible to have unconnected links - having one or both of their ends not connected to nodes.


Creating and Deleting Items

Creating and Deleting Items

Creating Items Programmatically

In order to add a new node or link to a diagram, create an instance of the item class via the new operator and add it to the diagram's Nodes or Links collection. This works the same way for adding both items from your custom class or ones from the MvcDiagram predefined types.

There are several shortcut methods provided for creating instances of the predefined node and link types. The methods are members of the diagram's Factory object:

  • The CreateShapeNode method creates a ShapeNode at the specified position.
  • There are several overloads of the CreateDiagramLink method that allow connecting two nodes of the same type or of different types.

Drawing New Items

Users can draw diagram elements with the mouse. This creates either a node or a link, depending on whether there is already another diagram item under the mouse cursor. When a user starts drawing, an item is created and its appearance is initialized from the default-value properties of the Diagram, such as ShapePen and ShapeBrush. When the user releases the mouse button, the item is added to the collection that contains items from the same type - either Nodes or Links.

Deleting Items

Call the Remove method of the Nodes or Links collection to delete an item from the diagram. The ClearAll method clears diagram contents by deleting all items.


Accessing Items

Accessing Items

One of the most common tasks when using the component is iterating over all items in the diagram document or navigating through the connections between items - from a node to the incoming or outgoing links, or from a link to its origin and destination nodes. To enumerate items of a diagram use the Items, Links or Nodes collections. The nodes that a link connects are referenced by the link's Destination and Origin properties. To access the links that are connected to a node, use its IncomingLinks and OutgoingLinks collections. The first collection contains references to all links pointing to the node, the second - to the links that start from it. Links can connect to rows of a table; to find such links use table's Rows collection and the IncomingLinks and OutgoingLinks collections. A shortcut for accessing the other end of a relation in entity-relationship diagrams is provided by the RelatedOneToMany and RelatedManyToOne properties of the Row class.

Selected Items

If only one item is selected, it is considered the active item and can be accessed with the ActiveItem property. The type of this property is DiagramItem; you can get the actual type of the selected item through .NET reflection. Multiple items can be selected when clicking or dragging with the CTRL key pressed at the same time. Multiple selection is represented by the Selection property of the Diagram class. The Selection object provides collections to access the selected Links and Nodes.

Finding Items

You can search for diagram items by their Tag or Id using the FindLink, FindNode, FindLinkById and FindNodeById methods. Tag and id objects are compared by calling the Equals method of the System.Object class. Thus if they are of value type, they are compared by value (that is bitwise equality). If they are of reference type their Equals method is used. If there are more items with the same tag, the first one will be returned. If no item with the specified tag or id exists, a null reference (Nothing in Visual Basic) will be returned. Groups can also be searched by tag using FindGroup.

Relationship Queries

The Query method traverses the graph by following node/link connections and group's parent/child relationships to find items in specific relation to the current one. The method receives a string argument consisting of selectors and optional predicates. The query is executed in several steps. In each step the result set is constructed from the previous result set by following the relationship specified by the current selector. If a predicate is specified after the selector identifier, the result set is filtered to include only items for which the predicate evaluates to true.


Attaching and Grouping Items

Attaching and Grouping Items

MvcDiagram allows attaching a node to another diagram element, establishing a subordinate - master relationship between the two items. The easiest way to attach nodes is to call the AttachTo method. When a master element is moved or resized, any subordinated node follows it, so that the initial distance between the two items stays constant. This happens both when a user moves the master item around, and when the item position is changed using a method or a property.

Possible Uses

  • Attach a Transparent shape node to another item and set its Text, so that the shape node acts as an additional label assigned to the main item.
  • Attach a shape node to another item and set the node's Image, so it acts as an additional icon displayed inside or near the main item.
  • In all previous cases, the Locked property can be set for attached nodes, which are used only as decorations embellishing the main item. That prevents users from selecting, modifying or drawing links to the subordinates.

Hierarchical Grouping

A unit of attached items is represented by an instance of the Group class. To create a group, instantiate a Group object and add it to the diagram's Groups collection, or call the CreateGroup method passing the master object as argument. Attach items to the group using the various Group methods. The AttachTo method of nodes is a shortcut to creating a group and attaching an item to it.

Every member of a group can be the master item of another group, that is, an item can be subordinate in one group and meanwhile be another group's master. MvcDiagram doesn't impose any limits to the depth and width of group hierarchies built that way. However, it is not possible to put an item as a subordinate in more than one groups because the hierarchy relations would become ambiguous.

Unions

It is possible to create such groups, that if any item in the hierarchy is modified, all other items are updated too. This can be done by putting the items in circular chain of dependencies - that is, item1 is attached to item2, item2 to item3 ... itemN to item1. If any of these items is modified, the change will propagate through the chain until it reaches its originator.

Attaching Items to a Group

Links cannot be attached to groups but can be master items of groups. If a group's master item is a link, nodes can be attached to the control points or segments of the link. See the AttachToLinkPoint and AttachToLinkSegment methods for details. If the master item is a node, other nodes can be attached to any of its corners, or to an area specified as percent of master-node's bounding rectangle. Check AttachToCorner and AttachProportional for details. A shortcut to creating Group instance and calling the appropriate AttachTo* methods is provided by the AttachTo method of the DiagramNode class.

Accessing Group Items

Group members can be accessed using the MainItem property and the AttachedNodes collection. To get the groups in which an item participates, use its MasterGroup and SubordinateGroup properties.

Destroying Groups

If a user deletes the master item of a group, the group is destroyed automatically and the GroupDestroyed event is raised. If AutoDeleteItems is enabled, subordinated items in the group are deleted too. If AutoDeleteItems is disabled, subordinated items are just detached from their master and remain intact. Groups can be destroyed programmatically by removing them from the diagram's Groups collection.


Laying Out Diagrams Automatically

Laying Out Diagrams Automatically

Applications that process hierarchical or more complex entity-relationship data might need to present that data to end-users in an aesthetical and visually appealing manner. Such applications would store their data as graph of connected nodes possibly having additional information attached to them. However, position and size coordinates of nodes might be unnecessary and/or unavailable. MvcDiagram provides a way to automatically arrange the nodes of a diagram, applying attractive layouts on the overall structure of the diagram. To utilize that functionality, an application can create a diagram by assigning generic coordinates to its nodes, instantiating a layout object and invoking the layout's Arrange method. The Arrange methods can be prevented from changing positions of individual items by setting the IgnoreLayout property of those items to true.

The classes that implement automatic layout algorithms are located in the MindFusion.Diagramming.Layout namespace. The following sections list the available algorithms categorized by their general implementation strategy: force-directed algorithms, graph topology based algorithms and semantics based algorithms.


Force-directed layout algorithms

Force-directed layout algorithms

Force-directed algorithms simulate forces acting between objects in the graph and iteratively run a physical simulation that pulls the objects closer or pushes them apart. At each iteration the energy associated with the simulated system decreases, and the node positions calculated by this process usually lead to evenly distributed nodes and uniform link lengths.

Spring-Embedder Graph Layout

Spring-Embedder is force-directed layout algorithm. It simulates a physical system in which nodes repulse each other, and the links between them act as confining springs. Graphs processed by Spring-Embedder have their nodes distributed uniformly across the diagram area. The algorithm can be applied on a graph by creating a SpringLayout object and calling its Arrange method. Members of SpringLayout allow you to set the desired distance between graph nodes and the number of iteration steps to use while calculating node positions. You can also specify to minimize link crossings. If you select that option, the algorithm would produce better result with more iteration steps. However, it needs more time to complete if more steps are specified. In VB.NET and C#, Spring-Embedder layout might be applied like this:

C# [image] Copy Code

using MindFusion.Diagramming;
using MindFusion.Diagramming.Layout;

...

private void button1_Click(object sender, EventArgs e)
{
SpringLayout sl = new SpringLayout();
sl.IterationCount = 500;
sl.NodeDistance = 30;
sl.Arrange(diagram);
}

Visual Basic [image] Copy Code

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click

Dim sl As New SpringLayout()
sl.IterationCount = 500
sl.NodeDistance = 30
sl.Arrange(diagram)

End Sub

Grid Graph Layout

The GridLayout algorithm arranges diagram nodes in a grid, keeping connected nodes close together. The algorithm strives to achieve a small number of link crossings. It is based on an iterative process whose initial steps shuffle the grid nodes randomly. That can lead to very different results each time the algorithm is run.

To apply the layout to a diagram, create a GridLayout instance, set its members and invoke the Arrange method. Grid layout might be applied like this:

C# [image] Copy Code

using MindFusion.Diagramming;
using MindFusion.Diagramming.Layout;

...

private void button1_Click(object sender, EventArgs e)
{
GridLayout gl = new GridLayout();
gl.GridSize = 75;
gl.Arrange(diagram);
}

Visual Basic [image] Copy Code

Imports MindFusion.Diagramming
Imports MindFusion.Diagramming.Layout

...

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click

Dim gl As New GridLayout()
gl.GridSize = 75
gl.Arrange(diagram)

End Sub

Simulated Annealing Graph Layout

The AnnealLayout class implements the Simulated Annealing graph layout algorithm. Simulated Annealing is a general-purpose optimization method used to solve large-scale combinatorial problems by simulating the process of heating and cooling of metal to achieve freedom from defects. Finding a nice arrangement of a graph is a combinatorial problem that can be reduced to assigning costs to graph configurations and finding the minimum cost configuration. AnnealLayout assigns costs to graph configurations by evaluating different aesthetic criteria such as distance between nodes, length of links and the number of link crossings. Thus the best configuration found will have good aesthetic properties.

Circular Graph Layout

CircularLayout distributes nodes evenly on the circumference of a circle at positions that result in as few link crossing as possible. Set its Radius property to specify the size of the layout circle. Use SiftingRounds to set the number of fine-tuning crossing-reduction iterations.


Topology based layout algorithms

Topology based layout algorithms

The following algorithms are based on the topological features of the graph being arranged, such as the size and adjacency of faces (a face is a region bounded by links) and the overall direction of links. The algorithms differ in the shape they apply to graph faces and the manner in which faces are embedded in the plane.

One-way Graph Layout

The OneWayLayout class ensures that links enter into nodes from the same general direction and exit them from the opposite side. If the graph contains cycles, some links bend around the nodes to keep the enter/exit direction consistent. The algorithm aims to minimize the number of such links.

Orthogonal Graph Layout

The OrthogonalLayout class implements an orthogonal graph layout algorithm. Each link is drawn as a chain of alternating horizontal and vertical segments. Nodes are placed in a way that facilitates few links bends and crossings. This algorithm was designed for planar graphs where the nodes have at most four incident links, and produces best results with such graphs as input. It can arrange any arbitrary graph as well, by adding some dummy nodes and links to planarize the graph and reduce its vertex degree, and removing them after the layout. However this might lead to using larger area than necessary, due to the space occupied by dummy elements.

Orthogonal Router

OrthogonalRouter is a secondary layout algorithm that can be used to arrange links after an initial node arrangement has already been applied. The orthogonal layout is useful when there are much more links than nodes in a graph. The algorithm strives to achieve the following criteria, while preserving as much of the initial node configuration as possible.

  • links must not overlap;
  • only vertical and horizontal routing lines are used;
  • graph routing is performed with respect to the specified main layout direction;
  • links crossings are minimized;
  • bends are minimized;

Topological Layout

If the underlying graph if acyclic, TopologicalLayout arranges the nodes linearly in such a way that each node comes before all destination nodes of its outgoing links. The links are drawn as arcs above the chain of nodes, with their height proportional to the distance between the nodes. If the graph is not acyclic, the layout algorithm finds an ordering with a minimal number of back links, and draws the back links below the chain of nodes.

Cascade Graph Layout

CascadeLayout places nodes on a virtual grid and arranges links orthogonally, such that if the source graph is planar all links are guaranteed to have no more than two bends and will not intersect. By default the layout method arranges nodes in rows and link segments in columns; this can be changed by setting the Orientation property.

Triangular Graph Layout

TriangularLayout places nodes on a virtual grid, such that if the source graph is planar, all links are guaranteed to have a single segment and not intersect. If the graph is not planar, its intersecting links can be optionally segmented and bended in order to improve readability. The layout method places the nodes from the external face on a triangle and recursively adds the rest of the nodes as vertices of internal triangles. As a result, it is very effective for near maximal-planar (a.k.a. triangular) graphs.


Semantics based layout algorithms

Semantics based layout algorithms

The following algorithms arrange the diagram in a way that shows the semantics of individual items or the overall graph structure, such as hierarchical relations between objects, loops and decisions in flowcharts, assignments of nodes to layers or swimlanes.

Tree Layout

If application's data is structured hierarchically, it is appropriate to apply tree layout on it. To do this, create a TreeLayout object and call its Arrange method. Members of TreeLayout control many aspects of the layout process. The type of layout can be directional or radial. You can choose how much space to leave between tree levels and between nodes on the same level. For directional layouts the style of links in the arranged tree can be set to straight, orthogonal or curved. Global tree direction and alignment can be customized too. In VB.NET and C#, tree layout might be applied like this:

C# [image] Copy Code

using MindFusion.Diagramming;
using MindFusion.Diagramming.Layout;

...

private void button1_Click(object sender, EventArgs e)
{
TreeLayout tl = new TreeLayout();
tl.Type = TreeLayoutType.Cascading;
tl.Direction = TreeLayoutDirections.LeftToRight;
tl.LinkStyle = TreeLayoutLinkType.Cascading2;
tl.LevelDistance = 10;
tl.Arrange(diagram);
}

Visual Basic [image] Copy Code

Imports MindFusion.Diagramming
Imports MindFusion.Diagramming.Layout

...

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click

Dim tl As New TreeLayout()
tl.Type = TreeLayoutType.Cascading
tl.Direction = TreeLayoutDirections.LeftToRight
tl.LinkStyle = TreeLayoutLinkType.Cascading2
tl.LevelDistance = 10
tl.Arrange(diagram)

End Sub

Fractal Tree Layout

FractalLayout is a tree layout algorithm that places child nodes symmetrically around their parent node. Nodes at the lowest level are arranged directly in a circle around their parent. At the upper level, the already arranged nodes form branches that are arranged in a circle around the new parent node. The algorithm is recursively repeated till the highest level is reached. If nodes in the tree have uniform number of children, the end result has fractal-like appearance (subsets of the graph look like scaled-down copies of the whole graph).

You can choose which node should be displayed at the center of the topmost circle by setting the Root property. If it is not specified, the algorithm automatically selects a root that leads to more balanced distribution of nodes.

Layered Graph Layout

The LayeredLayout algorithm arranges diagram nodes in layers according to several criteria, most important of which are: connected nodes must be placed close together; links must flow in one direction if possible; links must cross as few layers as possible; links must not cross other links. To apply the layout to a diagram, create a LayeredLayout instance, set its members and invoke the Arrange method. In C# and VB.NET, layered layout can be applied like this:

C# [image] Copy Code

using MindFusion.Diagramming;
using MindFusion.Diagramming.Layout;

...

private void btnArrange_Click(object sender, System.EventArgs e)
{
LayeredLayout ll = new LayeredLayout();
ll.Orientation = MindFusion.Diagramming.Layout.Orientation.Horizontal;
ll.SplitLayers = true;
ll.LayerDistance = 35;
ll.Arrange(diagram);
}

Visual Basic [image] Copy Code

Imports MindFusion.Diagramming
Imports MindFusion.Diagramming.Layout

...

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click

Dim ll = New LayeredLayout()
ll.Orientation = MindFusion.Diagramming.Layout.Orientation.Horizontal
ll.SplitLayers = True
ll.LayerDistance = 35
ll.Arrange(Diagram)

End Sub

Tree map layout

Tree maps represent hierarchies by nesting child nodes within their parents, where the areas of leaf nodes are proportional to their Weight values. Unlike other layout algorithms, TreeMapLayout expects hierarchies to be defined via grouping or containment (see AttachTo method and ContainerNode class), and will ignore any links in the diagram. The diagram area covered by the topmost nodes in a hierarchy is specified via the LayoutArea property. By default, the layout tries to keep the ratio of node sides as close as possible to one. However this could make it hard to distinguish separate levels of the hierarchy. To alleviate that, set Squarify to false, and child nodes will be arranged either as a row or a column inside their parent node, alternating directions for each level. The drawback is that when Weight ratios differ greatly or nodes contain many children, some nodes could end up with very narrow rectangles.

Decision flowchart layout

DecisionLayout arranges simple flowcharts consisting of decision boxes with up to three outgoing links per node and activity boxes with a single outgoing link per node. The nodes are arranged in columns and rows, whose distance depends on the HorizontalPadding and VerticalPadding property values. When links share the same row or column, they are placed at a distance specified via LinkPadding. The layout arranges nodes recursively starting from StartNode. If StartNode is not specified, the algorithm selects the root of the deepest branch of the graph's spanning tree as start node.

Flowchart Graph Layout

FlowchartLayout recognizes program code -like patterns in the graph, such as loops, sequences and if/switch branchings, and arranges them recursively. FlowchartLayout could be used to arrange other types of graphs as well, though with some restrictions. For example it treats all back links as loops in the code, and expects that they are nested - loop links starting closer to the stop node should end closer to the start node. Another similar restriction is that there shouldn't be any cross-links that connect different branches of a decision sub-graph.

Workflow Graph Layout

The FlowLayout algorithm can be used to lay out flowcharts, workflow and process diagrams. It works by applying a customizable set of rules for local positioning of connected nodes relatively to each other. On a larger scale, the algorithm keeps groups of nodes separate and prevents links between the groups from crossing nodes. The FlowLayout and ProcessLayout examples included in the MvcDiagram package demonstrate two sample sets of layout rules.

Swimlane Layout

SwimlaneLayout can be used to arrange process diagrams in which nodes representing activities are placed in swimlanes representing resources. The index of the resource allocated to an activity should be assigned to the corresponding node's LayoutTraits[SwimlaneLayoutTraits.Lane].

By default, the algorithm works with the diagram's LaneGrid, but its SwimlaneGrid property can be set to any class that implements ISwimlaneGrid. This allows applying the layout to a custom-drawn grid rendered through the DrawBackground event, or one composed of locked background nodes.

Hierarchical Graph Layout

HierarchicalLayout places nodes on user-defined levels, such that if the source graph is level-planar, all links are guaranteed to have a single segment and not intersect. The layout method requires that for each node LayoutTraits contains a HierarchicalLayoutTraits.Level entry specifying the level, and no two connected nodes must be on the same level.


Diagram Serialization and Output

Diagram Serialization and Output


Serializing the Diagram

Serializing the Diagram

Binary Serialization

Diagrams can be serialized in byte sequences wrapped by .NET streams. Such streams may represent files, memory buffers, communication pipes, TCP sockets, and so on. In serialized form a diagram might be saved in a database record too. To save the current diagram into a stream, call the SaveToStream method, and respectively to load a diagram from a stream call LoadFromStream. Two shortcut methods are provided for work with files. SaveToFile creates a disk file and a stream that wraps it and invokes SaveToStream. LoadFromFile opens a read-stream on a disk file and invokes LoadFromStream. If using custom item classes, binary serialization for their additional properties can be implemented by overriding the SaveTo and LoadFrom methods. In addition, such classes must specify a string to use as their identifier in the stream by calling RegisterItemClass.

XML Serialization

It is possible to save a diagram as an XML document. To do that, call the SaveToXml method of the Diagram class. To deserialize a diagram back from its XML representation, call the LoadFromXml method.

Custom item classes can implement XML serialization for their additional properties by overriding the SaveToXml and LoadFromXml methods. In addition, such classes must specify a string to use as their identifier in the XML document by calling RegisterItemClass.

The control raises SerializeTag and DeserializeTag to enable serialization of complex Id and Tag objects without overriding the item classes. The PropertyName event argument specifies which property is being serialized.


Exporting the Diagram

Exporting the Diagram

Export Bitmap Images

You can create a static image representing the current diagram using the CreateImage method. The method returns an instance of the System.Drawing.Image class. The following example shows how to export a diagram to a Png image file:

C# [image] Copy Code

Image image = diagram.CreateImage();
image.Save(exportPath + "diagram.png");
image.Dispose();

VB.NET [image] Copy Code

Dim image As Image = diagram.CreateImage()
image.Save(exportPath + "diagram.png")
image.Dispose()

The MindFusion.Diagramming.Export Namespace contains classes for exporting to Dxf, Pdf, Svg, Wmf, Swf and Visio formats.

Export DXF files

Add a reference to the MindFusion.Diagramming.Export.Dxf.dll to your project. Create a DxfExporter instance and call its Export method, specifying a Diagram object and a file path as arguments. Raster images can be used in DXF by referencing external image files. To export the images displayed in diagram elements, enable the ExportImages property. If your application supports the multiple-line text DXF entity - MTEXT, use the ExportTextAsMultiline property. The following example shows how to create a DxfExporter instance and export a diagram:

C# [image] Copy Code

MindFusion.Diagramming.Export.DxfExporter dxfExp = new MindFusion.Diagramming.Export.DxfExporter();
dxfExp.Export(diagram, exportPath + "diagram.dxf");

Export Pdf files

Add references to the MindFusion.Diagramming.Export.Pdf.dll and MindFusion.Pdf.dll assemblies to your project. Create a PdfExporter instance and call its Export method. Margins specifies the page margins for all pages in the document. If you need to set the page size and orientation, use the PageSize, and PageOrientation properties. The AutoScale property allows scaling the diagram to fit in one or more PDF pages. If invisible items should be displayed in the PDF, enable the InvisibleItems property. The following example shows how to export a diagram to PDF:

C# [image] Copy Code

MindFusion.Diagramming.Export.PdfExporter pdfExp = new MindFusion.Diagramming.Export.PdfExporter();
pdfExp.Export(diagram, exportPath + "diagram.pdf");

VB.NET [image] Copy Code

Dim pdfExp As New MindFusion.Diagramming.Export.PdfExporter()
pdfExp.Export(diagram, exportPath + "diagram.pdf")

Export Svg files

Add references to the MindFusion.Diagramming.Export.Svg.dll and MindFusion.Svg.dll assemblies to your project. Create an SvgExporter instance and call its Export method, passing a Diagram object and the full path to the .svg file as parameters. To export images displayed by diagram items to external files, enable the ExternalImages property.

C# [image] Copy Code

MindFusion.Diagramming.Export.SvgExporter svgExp = new MindFusion.Diagramming.Export.SvgExporter();
svgExp.ExternalImages = false;
svgExp.Export(diagram, exportPath + "diagram.svg");

VB.NET [image] Copy Code

Dim svgExp as MindFusion.Diagramming.Export.SvgExporter = _
New MindFusion.Diagramming.Export.SvgExporter()
svgExp.ExternalImages = False
svgExp.Export(diagram, exportPath + "diagram.svg")

Export Visio files

Add a reference to the MindFusion.Diagramming.Export.Visio.dll to your project. Create a new instance of the VisioExporter class and call its Export method passing a Diagram object and the full path to the exported Visio .vdx file as parameters. The exporter requires the VisioExport.vxt file to be present in the application's directory or the path specified by TemplatePath. This file contains an XML template data used by the component to generate Visio documents.

ShapeNode objects are mapped to their closest Visio counterparts and DiagramLink instances are exported as Visio connectors of a similar style. In addition, most of the attributes of diagram items such as text, text formatting, fill and line colors and styles are preserved.

TableNode objects are exported as groups of Visio shapes or as Entity shapes. If TableNodes should be exported as groups of Visio rectangular shapes, enable the ExportTablesAsGroups property.

C# [image] Copy Code

VisioExporter export = new VisioExporter();
export.Export(diagram, exportPath + "diagram.vdx");

Export WMF images

Add a reference to the MindFusion.Diagramming.Export.Wmf.dll assembly to your project. Create a WmfExporter instance and call its Export method, passing a Diagram object and the full path to the .wmf file as parameters.

Export Adobe Flash files

Add a reference to the MindFusion.Diagramming.Export.Swf.dll assembly to your project. Create an SwfExporter instance and call its Export method, passing a Diagram object and the full path to the .swf file as parameters.


Appearance

Appearance


Styles and Themes

Styles and Themes

The style and theme system provides a consistent way to customize the appearance of a Diagram and its items. By using styles and themes, it is easier to achieve coherent look and feel across the entire diagram. In addition, changing the look and feel can be achieved by simply replacing the current theme.

Styles

The style is a set of properties. Styles can be applied to diagrams and individual diagram items and this can potentially affect the values of some properties of the target object. More specifically, if the value of a style-affected property in the target object is null, then the value is obtained from the associated style. The style does not necessarily need to provide values for all of its properties. If a styled property is null and it is not defined in the associated style, the style system searches for a value in the current theme. A complete value precedence list can be found later in this topic.

The styles are represented by the Style class and its various subclasses. Styles can be applied to diagram objects through the Style property of the Diagram class and to diagram items through the Style property of the DiagramItem class. Styles can also participate in themes, in which case they affect all objects of specific type.

Themes

The theme is a set of styles, each associated with specific diagram or item type. When the theme is applied to a diagram, the styles registered in the theme affect all objects of their associated type.

Themes are represented by the Theme class and can be assigned to Diagram objects through the Theme property. Styles are associated with types within the theme through the RegisterStyle method. The following code creates a new theme, with a single style for ShapeNode items and applies this theme to an existing diagram.

C# [image] Copy Code

Theme theme = new Theme();
ShapeNodeStyle style = new ShapeNodeStyle();
style.FontFamily = "Courier New";
theme.RegisterStyle(typeof(ShapeNode), style);
diagram.Theme = theme;

VB.NET [image] Copy Code

Dim theme As New Theme()
Dim style As New ShapeNodeStyle()
style.FontFamily = "Courier New"
theme.RegisterStyle(GetType(ShapeNode), style)
diagram.Theme = theme

Alternatively, themes can be loaded from XML files by calling the LoadFromXml method. Such XML files can be produced by calling the SaveToXml method of an existing theme.

Value Precedence

The style and theme system is hierarchical. This means that, when a value of a styled property is requested, the system starts searching for this value along a chain of defined styles. The system returns the first valid value encountered. If no valid value is encountered along the chain, the system returns a globally defined default value for the property. The following list explains the search order in more details:

  1. If the local value of the object is not null, the local value is returned.
  2. If the object has a style and the property in this style has value, this value is returned.
  3. If the object is an item, which is part of a diagram, the local style of the diagram is searched.
  4. If the object is an item, which is part of a diagram and the diagram has associated theme, the theme is searched for styles registered for the item's type or its base types. If a style with a defined property value is found, this value is returned.
  5. Similar search as the previous one is performed for a theme-registered style for the Diagram class.
  6. If the above steps do not produce value; the system returns a globally define default for the property.

For example, if the effective value of the text brush property of a ShapeNode is requested (through the EffectiveTextBrush property), the style system performs the following search, according to the above rules:

  1. If ShapeNode.TextBrush is not null, ShapeNode.TextBrush is returned.
  2. If ShapeNode.Style is set and the DiagramItemStyle.TextBrush property in this style has value, this value is returned.
  3. If the node is part of a diagram, the Diagram.Style is set, and the DiagramStyle.TextBrush property of this style has value, this value is returned.
  4. If the node is part of a diagram and the Diagram.Theme is set, the theme is searched for a style registered for the ShapeNode type. If there is such style and its DiagramItemStyle.TextBrush property has value, this value is returned.
  5. Similar search as the previous one is performed for a theme-registered style for the Diagram type.
  6. Finally, the system returns a globally-defined default value for the TextBrush property (which is a solid Black brush).


Brush and Pen Classes

Brush and Pen Classes

MvcDiagram defines proxy classes to wrap the functionality of standard .NET brushes and pens and expose them as properties of diagram elements. Those classes, located in the MindFusion.Drawing namespace, have the same names as their System.Drawing counterparts. There are two brush classes available in MvcDiagram that inherit the abstract class Brush, namely LinearGradientBrush and SolidBrush. There's also a Pen class - proxy for the .NET Pen.

There are two reasons to use proxy classes instead the original GDI classes. First, the GDI resources are limited and would be exhausted by keeping a GDI pen and brush attached all the time to each diagram element; by using proxies the GDI pen and brush are created only at the time of drawing, and immediately disposed after that. Second, the GDI Pen and Brush classes don't support serialization; the proxy-classes implement the required interfaces instead.

Otherwise the proxy classes expose the same properties as their GDI counterparts. You might set default pen and brush properties like this:

C# [image] Copy Code

diagram.ShapeBrush = new MindFusion.Drawing.LinearGradientBrush(
Color.Yellow, Color.BurlyWood, 20);

MindFusion.Drawing.Brush penBrush = new MindFusion.Drawing.LinearGradientBrush(
Color.Bisque, Color.Blue, 0);
diagram.ShapePen = new MindFusion.Drawing.Pen(penBrush);

Visual Basic [image] Copy Code

Diagram.ShapeBrush = New MindFusion.Drawing.LinearGradientBrush( _
Color.Yellow, Color.BurlyWood, 20)

Dim penBrush As MindFusion.Drawing.Brush = New MindFusion.Drawing.LinearGradientBrush( _
Color.Bisque, Color.Blue, 0)
Diagram.ShapePen = New MindFusion.Drawing.Pen(penBrush)

After that piece of code is executed, every new shape node created will have gradient brush and pen.

Instances of those classes can be assigned to the Pen and Brush properties of each diagram element.


Node Effects

Node Effects

To apply an effect to the nodes in a diagram, create an instance of one of the effect classes and add this instance to the Diagram.NodeEffects collection. To apply the effect to individual nodes, add the instance to the node's Effects collection. To discard the diagram effects for a particular node, add a null reference (Nothing in Visual Basic) at position 0 in the node's Effects collection. Effects can also be applied through styles by adding them to the DiagramStyle.NodeEffects and DiagramNodeStyle.Effects collections respectively.

It is possible to combine different effects by adding instances of their appropriate types to the effect collections. If is also admissible to apply more than one effect of the same type.

The currently supplied effect types are Aero and Glass. They are examined in more details in the sections below.

Aero Effect

The Aero effect is represented by the AeroEffect class. The effect is designed to roughly resemble the Aero theme of Windows. More specifically, the effect adds semi transparency to the nodes, a smooth shade at the outside and a thin inset stroke. The semi transparency is specified through the Opacity property. Opacity varies from 0 to 1 inclusive, where 0 indicates full transparency and 1 indicates the original node color. The semi transparency is applied only on the node brush. The colors of the shade and the inner stroke are specified through the ShadeColor and InnerOutlineColor properties respectively. The following image illustrates how these properties affect the output:

The following example applies the Aero effect on the nodes of an existing diagram:

C# [image] Copy Code

AeroEffect effect = new AeroEffect();
effect.Opacity = 0.5f;
effect.InnerOutlineColor = Color.FromArgb(100, Color.White);
diagram.NodeEffects.Add(effect);

Visual Basic [image] Copy Code

Dim effect As New AeroEffect()
effect.Opacity = 0.5F
effect.InnerOutlineColor = Color.FromArgb(100, Color.White)
diagram.NodeEffects.Add(effect)

Tips

  • The Aero effect works very well in scenarios with overlapping nodes or in cases where the background is more complex than solid color, due to the effect of semi transparency.
  • Aero combines well with the Glass effect. There are some examples at the end of this topic.
  • The ShadeColor is usually black or another dark color. However, some nice glow effects can be achieved by setting bright ShadeColor on a diagram with dark background.
  • The Aero effect can impact performance if there are many nodes visible in the diagram.

Glass Effect

The Glass effect is represented by the GlassEffect class. The Glass effect adds visuals on top of the nodes in order to give the impression of a reflective surface. There are several variations of this effect, which can be selected through the Type property. The color of the reflection and the ambient color can be specified through the ReflectionColor and GlowColor properties respectively. When UsePenAsGlow is set to true the color of the node's pen is used as the ambient color. The following image illustrates the differences between the distinct effect types:

The following example applies a Glass effect with the default settings to the nodes of a diagram:

C# [image] Copy Code

diagram.NodeEffects.Add(new GlassEffect());

Visual Basic [image] Copy Code

diagram.NodeEffects.Add(New GlassEffect())

Tips

  • The GlowColor is usually white. However, for Type4 glass effects it is often more suitable to use black glow.
  • The Glass effect combines well with the Aero effect. There are some examples at the end of this topic.
  • Several glass effects of different types can be applied simultaneously for emphasized effect.

Examples

The values of the effect properties are usually selected in accordance with the color scheme of the target diagram and the desired end result. In addition different types of effects can be applied simultaneously to achieve more interesting results. The examples below demonstrate possible effect combinations in various color contexts.

Aero & Glass (Dark on Light)

In this example the Aero and Glass effects are combined. The Aero effect is useful in scenarios when dark nodes are placed on light background or vice versa, in order to emphasize the contrast.

Here is the code that applies the above effects:

C# [image] Copy Code

diagram.NodeEffects.Add(new GlassEffect());
diagram.NodeEffects.Add(new AeroEffect());

Visual Basic [image] Copy Code

diagram.NodeEffects.Add(New GlassEffect())
diagram.NodeEffects.Add(New AeroEffect())

Aero & Glass (Light on Dark)

This example is similar to the first one, only this time the nodes are painted in light colors and the background is dark.

Here is the code that applies the above effect:

C# [image] Copy Code

GlassEffect glassEffect = new GlassEffect();
glassEffect.Type = GlassEffectType.Type3;
diagram.NodeEffects.Add(glassEffect);
diagram.NodeEffects.Add(new AeroEffect());

Visual Basic [image] Copy Code

Dim glassEffect As New GlassEffect()
glassEffect.Type = GlassEffectType.Type3
diagram.NodeEffects.Add(glassEffect)
diagram.NodeEffects.Add(New AeroEffect())

Glow Effect

This example uses bright colors on black background to create a glow effect. The example utilizes an Aero effect with ShadeColor set to the color of the nodes' pens.

Here is the code that applies the above effects:

C# [image] Copy Code

GlassEffect glassEffect = new GlassEffect();
glassEffect.Type = GlassEffectType.Type2;
glassEffect.UsePenAsGlow = true;
diagram.NodeEffects.Add(glassEffect);
AeroEffect aeroEffect = new AeroEffect();
aeroEffect.Opacity = 0;
aeroEffect.InnerOutlineColor = Color.Black;
aeroEffect.ShadeColor = Color.FromArgb(128, 255, 255);
diagram.NodeEffects.Add(aeroEffect);

Visual Basic [image] Copy Code

Dim glassEffect As New GlassEffect()
glassEffect.Type = GlassEffectType.Type2
glassEffect.UsePenAsGlow = True
diagram.NodeEffects.Add(glassEffect)
Dim aeroEffect As New AeroEffect()
aeroEffect.Opacity = 0
aeroEffect.InnerOutlineColor = Color.Black
aeroEffect.ShadeColor = Color.FromArgb(128, 255, 255)
diagram.NodeEffects.Add(aeroEffect)


Client Side API Overview

Client Side API Overview


Standard Item Types

Standard Item Types

Diagram elements in MvcDiagram are represented by ShapeNode, ContainerNode, TableNode and DiagramLink instances. Combined and linked together, they can form complex data structures such as process or entity-relationship diagrams, class hierarchies, networks and graphs. Each of their rich features can be customized through numerous methods and properties.

Shape Nodes

ShapeNode objects can represent geometric shapes, flowchart elements, icons in network diagrams, and so on. They can display both graphics and text in different fonts, sizes and colors. A node's shape can be set by calling its setShape method. There are more than 100 predefined node shapes and apart from them, MvcDiagram offers an easy way to define custom shapes. Shape nodes can be rotated, either interactively using the round selection handle drawn above them, or programmatically using the RotationAngle property.

SVG Nodes

The SvgNode class represents nodes that can display SVG drawings. SVG graphics are rendered instead of Image, and on top of the geometry rendered by the base ShapeNode class. Enable the Transparent property to hide the node's geometry and leave only the drawing visible. The SVG file is loaded and associated with the node through an SvgContent object, which should be initialized and then assigned to the Content property.

Table Nodes

A TableNode displays tabular data, and can be used to represent table schemas in database diagrams or classes in class-hierarchies. A table contains cells arranged in a grid, and every cell can display text and/or image. Cells, columns and rows can be customized in various ways - there are properties available for setting their extents, style, image and text alignment. Tables' dimensions can be programmatically changed; inserting, appending or deleting rows and columns can be done in a very comprehensive, intuitive way whenever you might need it. Tables can also display background images and graphics.

Container Nodes

A ContainerNode can contain other diagram nodes. When a container is moved, its child nodes move too. Containers can be nested one within another to unlimited depth. They can be folded to a smaller size, hiding their child items, and unfolded to show content again. Nodes inside a container can be linked to nodes both inside and outside of it. If a link connects items in the same container, the container is not considered an obstacle by the auto-routing algorithm.

Links

DiagramLink objects are used to represent various types of connections and relations in diagrams. MvcDiagram offers three basic link shapes, which can be set by calling setShape:

  • polyline links composed of straight-line segments;
  • curved links composed of Bйzier-spline segments;
  • cascading links composed of horizontal and vertical segments, alternating their orientation so that every segment is orthogonal to its neighbor.

A link can be connected to a node at each of the link's ends. It is also possible to have unconnected links - having one or both of their ends not connected to nodes. Some customizable link's properties are: arrowheads, style, text, pen width and style, modification behavior and number of segments.

See Also
Controlling User Interaction


Creating and Deleting Items

Creating and Deleting Items

New items can be added programmatically to the diagram by calling the constructors of the item's class, such as ShapeNode or DiagramLink, and adding the new instance via the addItem method. A shortcut to creating new items is provided by the methods of the Factory class. An instance of that class is returned by the getFactory method of Diagram. Factory methods such as createShapeNode and createDiagramLink accept respectively node position or link's origin and destination arguments, create an instance of the class and add it to the diagram. The Factory class can create instances of JsDiagram predefined item types, while addItem can be used to add instances of custom types as well.

JavaScript [image] Copy Code

var ShapeNode = MindFusion.Diagramming.ShapeNode;
var Rect = MindFusion.Drawing.Rect;

function initDiagram()
{
var diagram = $find("diagram");

// create the start node
var startNode = diagram.getFactory().createShapeNode(10, 10, 30, 20);
startNode.setText("start");

// create the end node
var endNode = new ShapeNode(diagram);
endNode.setBounds(new Rect(10, 60, 30, 20));
endNode.setText("end");
diagram.addItem(endNode);

// connect the nodes
diagram.getFactory().createDiagramLink(startNode, endNode);
}

If an existing item should be removed from the diagram, call the removeItem method. If a node is removed, any links connected to the node are removed too.


Accessing Items

Accessing Items

Items in the diagram are exposed via its nodes and links members. nodes contains all DiagramNode -derived objects that have been added to the diagram, and links contains all DiagramLink objects. By iterating these arrays, you can access all diagram elements and apply common attributes to them:

JavaScript [image] Copy Code

// paint all nodes with light blue color
diagram.nodes.forEach(function (node)
{
node.setBrush("lightBlue");
});

// set the links' arrowheads to triangles
diagram.links.forEach(function (link)
{
link.setHeadShape("Triangle");
});

Individual items provide methods that let you access their related items in the diagram. DiagramNode exposes the links coming into or going out of nodes via the getIncomingLinks and getOutgoingLinks methods. The nodes connected by a link can be accessed by calling the getOrigin and getDestination methods of DiagramLink.

The component lets users select multiple diagram items of interest. The getSelection method of Diagram returns a Selection instance representing currently selected items. The Selection class provides nodes and links arrays containing respectively DiagramNode and DiagramLink -derived objects.


Collapsing and Expanding Tree Branches

Collapsing and Expanding Tree Branches

If a diagram represents a tree structure, the tree branch starting from a node can be collapsed or expanded again in order to hide or display hierarchy details. To enable this, call the setExpandable method. To get or set whether a tree branch is expanded or collapsed, use the Expanded property of its root node.

Displaying Expand/Collapse Button

If the Expandable property of a node is set to true, there is a [±] button displayed beside the node to allow users to collapse or expand the tree branch starting there. By default, pressing that button automatically toggles the Expanded property of the node and raises the treeExpanded or treeCollapsed events.

Defining Tree Direction

A node can be connected to other nodes through outgoing and incoming links. Setting the ExpandOnIncoming property specifies which items connected to a node will be regarded as its descendants. If ExpandOnIncoming is false (default value) then each node will be regarded as a parent of its outgoing links and the items attached to them. If ExpandOnIncoming is set to true, the node's incoming links define its children. So, this property specifies the direction of parent-children relationship between diagram items and respectively the overall direction in which collapsing / expanding is done.


Attaching and Grouping Items

Attaching and Grouping Items

MvcDiagram allows attaching a node to another node, establishing a subordinate - master relationship between them. The easiest way to attach nodes is to call the attachTo method. When a master node is moved, its subordinated nodes follow it, so that the initial distance between the nodes stays constant. This happens both when a user moves the master node around, and when the node position is changed using a method or a property.

Possible Uses

  • Attach a Transparent shape node to another node and set its Text, so that the shape node acts as an additional label assigned to the master node.
  • Attach a shape node to another node and set its Image, so it acts as an additional icon displayed inside or near the master node.
  • Attach a node to another node and handle nodeClicked or similar events to perform some action on the master node. This makes the subordinated node act as a button or another type of UI element attached to the master node.
  • Attach child elements in a tree branch to the branch root, so that when a user moves a tree node, the node's children moves simultaneously with it. Modifying an item in such hierarchical group makes the modification pervade through all dependant subordinated items.
  • In all previous scenarios, the Locked property can be set for attached nodes which are used only as decorations embellishing the main item. That prevents users from selecting, modifying or drawing links to the subordinate nodes.

Hierarchical Grouping

Every node in a group can be the master node of another group, that is, a node can be subordinate in one group and meanwhile be another group's master. MvcDiagram doesn't impose any limits to the depth and width of group hierarchies built that way. However, it is not possible to put a node as a subordinate in more than one groups because the hierarchy relations would become ambiguous.

Unions

It is possible to create such groups, that if any item in the hierarchy is modified, all other items are updated too. This can be done by putting the items in circular chain of dependencies - that is, item1 is attached to item2, item2 to item3 ... itemN to item1. If any of these items is modified, the change will propagate through the chain until it reaches its originator.

Accessing Group Items

The master node in a group can be accessed using the getMasterNode method of attached nodes. The array returned by invoking getAttachedNodes on a master node contains references to all subordinate nodes attached to it.


User Interaction

User Interaction


Controlling User Interaction

Controlling User Interaction

There are several ways to control user actions on the diagram as a whole, or on individual items in the diagram.

Specify How User's Actions are Interpreted

The Behavior property provides several predefined sets of rules specifying how user input with the mouse is interpreted. If Behavior is set to LinkShapes, mouse dragging started from an unoccupied point of the document is processed as a ShapeNode creation request and dragging over a node creates a link. Additional members of the Behavior enumeration provide more limited interaction modes.

In-place Text Editing

The text of nodes and links can be edited in-place by double-clicking the respective items. To enable this feature, set the AllowInplaceEdit property to true. Depending on the type of item, the control raises either the nodeTextEdited, cellTextEdited or linkTextEdited event when its text has been edited. In-place editing mode is exited when users click outside the text entry control.

By default, the control creates a textarea DOM element over an item to allow editing the item's text. If you prefer using a different type of element as in-place editor, handle the createEditControl event and set the Control property of the provided InplaceEditEventArgs object.

Validation Events

While the user draws new nodes or links, the control raises the nodeCreating or linkCreating events after each change of the mouse position. By calling the setCancel method of the event object, you can prevent the operation from being completed at the current position but let the user continue drawing. Calling the cancelDrag method immediately stops the operation. The nodeModifying and linkModifying events provide the same functionality during modification of existing objects. Finally, if the user tries to delete an item, you can handle the nodeDeleting or linkDeleting event to prevent this.


Alignment Grid

Alignment Grid

MindFusion.Diagramming provides an alignment grid to help users place the diagram items more precisely. To activate the grid, set the AlignToGrid property to true. If the grid is active while an item is being created or modified, the item's control-points are aligned to the nearest grid points. The distance between adjacent grid points is set by the GridSizeX and GridSizeY properties. The GridOffsetX and GridOffsetY properties allow specifying the horizontal and vertical offset of the first point in the alignment grid.

Items created or modified by a user are automatically aligned to the grid. However, if items are placed in the diagram programmatically, their coordinates are set to the specified positions without aligning. In such cases use the alignPointToGrid method if items must be placed exactly at grid points.

The grid can be either visible or invisible, depending on whether the ShowGrid value is true or false. If visible, the grid is painted as a matrix of points or as series of crossing lines, as specified by the GridStyle property. GridColor defines the color with which the alignment points or lines are painted.


Undo and Redo

Undo and Redo

If the UndoEnabled property is set to true, the control records users actions and allows undoing them later. The records are stored in a list, and can be undone consecutively by calling the undo method. An action that has been undone can be redone by calling the redo method. You can enable or disable UI elements that undo or redo commands by binding them to the canUndo and canRedo properties.

The control also runs and saves in the undo history AddItemCommand and RemoveItemCommand commands when items are programmatically added or removed from the Items collection of the Diagram. No other changes are recorded automatically when done from code. If support for undo/redo of such changes is required, they must be done through the executeCommand method.

To allow undoing changes of DiagramItem properties, create a ChangeItemCommand instance before setting the property values, and call executeCommand afterwards. Any other types of undoable changes can be implemented by deriving from the Command class and overriding its execute, undo and redo methods.


Diagram Events

Diagram Events

There are various events raised after user interaction in JsDiagram. These events are accessible as static fields of the Events class. Event listeners are attached to a Diagram instance through the addEventListener method.

The following sample code attaches an event listener to the nodeCreated event. The variable diagram identifies a Diagram object and onNodeCreated is the name of the listener function.

JavaScript [image] Copy Code

// a shortcut to the Events class
var Events = MindFusion.Diagramming.Events;

// add the listener
diagram.addEventListener(Events.nodeCreated, onNodeCreated);

The declaration of all event handlers should look similar to the following, with a sender event specifying the diagram, and an args argument that is an instance of either NodeEventArgs or LinkEventArgs:

JavaScript [image] Copy Code

function onNodeCreated(sender, args)
{
// ...
}


Placement and Layout

Placement and Layout


Items Placement and Z-order

Items Placement and Z-order

Measure Unit

The MeasureUnit property specifies the unit of measure for all location and size-related values assigned to JsDiagram properties or passed as arguments to its methods.

Location and Size of Nodes

Call the setBounds method to change the location and size of a node. The method takes a Rect instance as argument. Call getBounds to find the current location and size of a node, returned as a Rect object.

Links Control Points

Links must have two or more control points, depending on their Shape property. You can get access to the control points via link's ControlPoints collection. You must call updateFromPoints after programmatically moving control points of a link; that's needed in order to repaint the link and update its internal state variables, such as arrowhead angles.

Link Dynamics

The Dynamic property of a link can be enabled to make the link automatically recalculate its end point positions if the nodes connected to the link are moved or resized; the end points are moved in such a way that the link points to the centers of the connected nodes. Links also expose an AutoRoute property that enables or disables automatic routing for a link. Routed links avoid nodes by finding the shortest path between their origin and destination that does not cross any other nodes.

Interactive Moving or Resizing

End-users of your application can move or resize the diagram elements. They do this by selecting an item and dragging any of its adjustment handles, a point inside its interior, any of its sides or a selection frame. The HandlesStyle property of nodes controls how interaction can be performed. Additionally it defines the representation of selected items on screen. EnabledHandles lets you disable specific manipulations users are allowed to perform on a node, for example resizing the item horizontally or moving it. If an item is modified interactively, the nodeModified or linkModified event is raised, depending on the item's type.

Controlling Z-order

The Z-order defines how items are ordered along the Z-axis, so that one item appears in front of or behind another one. Diagram items are sorted by the value of their ZIndex property, and rendered on screen in ascending order. You can change the Z index of a DiagramItem by calling its setZIndex method.


Lane Grid

Lane Grid

The classes from the MindFusion.Diagramming.Lanes namespace let you develop process maps and lane diagrams, useful in business process planning and reporting. Processes consist of consecutive operations accomplished by people involved, technical installations, means of contact, and flow of information. The MvcDiagram lane grid features allow indicating and arranging related diagram items in complicated processes and systems, that is, Swim lane diagrams (known as Rummler-Brache diagram), Gantt Charts (planning and scheduling of projects). A lane in the grid can visually contain nodes, links, shapes or images, that represent tasks fulfilled in specified periods of time by people, companies or departments.

The MindFusion.Diagramming.Lanes namespace provides the Grid, Header, Cell and Style classes, and the ResizeType enumeration. These types expose additional properties and methods that let you define your own grids as required by your application logic. Grids can include varying number of lanes, divided into child rows and columns whose intersections form cells. The cell color and style can be customized too.

Use the ShowLaneGrid property of the Diagram class to display lanes in your application. The LaneGrid lets you setup the rows and columns in the grid by defining horizontal and vertical lanes, where each lane can be titled by its own header and/or subheadings. The grid can be resized by setting the ColumnCount and RowCount properties or by adding headers via the addColumnHeader and addRowHeader methods. A column or row can be divided into child elements by adding subheaders, which lets you form a complex hierarchy of unlimited depth. The intersection of rows and columns can be either a simple cell for bottommost elements in the hierarchy, or a group of cells for parent rows and columns. Cells or cell groups can be accessed via the grid class get method, that lets you index cells either by their integer positions, or by their Header objects.

The position of the grid and grid headers within the diagram is defined via TopMargin and LeftMargin, which specify the grid offset relative to the diagram bounds. HookHeaders enables lane headers to be anchored to the left or right side of the control's visible area. The sizes of headers at different levels in the lane hierarchy can be set in a single operation by the RowHeadersWidths and ColumnHeadersHeights properties.

The appearance of the lanes grid can be customized further via the HeadersOnTop poperty, which specifies whether headers should appear on top of the Z-order, and the TopLeftAreaStyle specifying the appearance of the grid's top-left corner.

The Grid class provides many miscellaneous methods that can be used to find grid elements, for determining their bounds and for hit-testing: findColumn, findRow, getCellBounds, getCellColumn, getCellFromPoint, getCellRow, getColumn, getRow, getRowIndex, getColumnHeaderBounds, getColumnIndex, getHeaderBounds, getRowHeaderBounds, getHeaderFromPoint.

The headers in the lanes grid can be customized by using the following members of the Header class:

Member name | Description
getHeight/setHeight | Gets or sets the height of the header and the related row in the grid.
getResizeType/setResizeType | Gets or sets the resize type of the header.
getRotateTitle/setRotateTitle | Gets or sets a value indicating whether rotating of the header caption at 90 degree is enabled.
getStyle/setStyle | Gets or sets the style of the header.
getSubHeaders | Gets a collection with the subheaders of the header.
getTitle/setTitle | Gets or sets the header caption.
getWidth/setWidth | Gets or sets the width of the header and the related column in the grid.


Anchor Points and Patterns

Anchor Points and Patterns

Anchor Points

For each node you can define one or more points to which links should dock when connecting to that node. Such points are represented by instances of the AnchorPoint class. The position of an anchor point relative to node's bounding rectangle is specified via the X and Y properties. Their values are expressed as percent of the node's width and height to accommodate for moving and resizing. You can control whether an anchor point accepts incoming or outgoing links or both. That is done via the AllowIncoming and AllowOutgoing properties. When a link is drawn, its ends are aligned to the nearest anchors allowing docking of the respective end type.

Anchor Patterns

An AnchorPattern instance defines a set of anchor points to be used together. When creating an anchor pattern, pass to its constructor an array of AnchorPoint objects. The AnchorPattern class exposes several predefined patterns as static properties. An existing pattern can be assigned as a single entity to the AnchorPattern property of nodes. The following example creates a pattern of four anchor points:

JavaScript [image] Copy Code

var AnchorPattern = MindFusion.Diagramming.AnchorPattern;
var AnchorPoint = MindFusion.Diagramming.AnchorPoint;

var apat1 = new AnchorPattern([
new AnchorPoint(50, 0, true, true),
new AnchorPoint(100, 50, true, true),
new AnchorPoint(50, 100, true, true),
new AnchorPoint(0, 50, true, true)
]);

The points are located at the middles of bounding rectangle sides of nodes to which the pattern is assigned. All four points accept both incoming and outgoing links.


Laying out the Diagram

Laying out the Diagram

The diagram can be arranged automatically by calling its arrange method and specifying a layout algorithm. Different layout algorithms are implemented by the various Layout classes from the MindFusion.Graphs namespace. To apply one of them, create an instance of the respective class, customize its properties and pass it as an argument to arrange. It is also possible to lay out the contents of an individual ContainerNode by calling the container's arrange method.

Layered Graph Layout

The LayeredLayout algorithm arranges diagram nodes in layers according to several criteria, most important of which are: connected nodes must be placed close together; links must flow in one direction if possible; links must cross as few layers as possible; links must not cross other links. To apply the layout to a diagram, create a LayeredLayout instance, set its members and invoke the arrange method.

Spring-Embedder Graph Layout

Spring-Embedder is force-directed layout algorithm. It simulates a physical system in which nodes repulse each other, and the links between them act as confining springs. Graphs processed by Spring-Embedder have their nodes distributed uniformly across the diagram area. The algorithm can be applied on a graph by creating a SpringLayout object and calling the arrange method. Members of SpringLayout allow you to set the desired distance between graph nodes and the number of iteration steps to run while processing the simulation.

Tree Layout

If application's data is structured hierarchically, it is appropriate to apply tree layout on it. To do this, create a TreeLayout or BorderedTreeLayout instance and call the arrange method. The difference between two classes is where they place child nodes in relation to their parent; the former centers the parent above its children, the latter arranges children in columns at a horizontal offset form their parent (see Tutorial 2). Members of both classes control the tree direction, how much space to leave between tree levels and between nodes on the same level.

Fractal Layout

The FractalLayout tree layout algorithm places child nodes symmetrically around their parent node. Nodes at the lowest level are arranged directly in a circle around their parent. At the upper level, the already arranged nodes form branches that are arranged in a circle around the new parent node. The algorithm is recursively repeated till the highest level is reached.


Customizing Node Appearance

Customizing Node Appearance

Nodes can have different shape, background image or color. They can also have differently aligned text.

Customizing the shape of nodes

ShapeNode has setShape method that sets the shape of the node. The argument can be either a Shape object (returned by one of the static methods of the Shapes class), or a string id of the shape, which coincides with the name of the method that gets it. Here is an example:

JavaScript [image] Copy Code

myNode.setShape("Arrow1");

TableNode and ContainerNode provide setShape method too, but their shapes can only be set to either rectangle or rounded rectangle, as specified via SimpleShape enumeration.

Bitmap images

Each node can display an image as its content. The image is set via the setImage method. Be default it is centered inside the node. You can change the alignment by calling setImageAlign. Images can be loaded by their URL via setImageLocation.

Fill color

Nodes can be painted in any color that you choose. Use setBrush to specify how the node is painted.

JavaScript [image] Copy Code

myNode.setBrush("Red");

Linear gradients

Nodes can be filled using linear gradients by passing objects in following format to setBrush. If the gradient should blend only two colors, they can be specified using color1 and color2 fields instead of colorStops.

JavaScript [image] Copy Code

var brush1 =
{
type: "LinearGradientBrush",
colorStops:
[
{ position: 0, color: "red" },
{ position: 0.5, color: "green" },
{ position: 1, color: "blue" }
],
angle: 30
};
myNode.setBrush(brush1);

Radial gradients

Nodes can be filled using radial gradients by passing objects in following format to setBrush. If the gradient should blend only two colors, they can be specified using color1 and color2 fields instead of colorStops.

JavaScript [image] Copy Code

var brush2 =
{
type: "RadialGradientBrush",
colorStops:
[
{ position: 0, color: "white" },
{ position: 0.5, color: "lightGray" },
{ position: 1, color: "blue" }
],
x1: 20, y1: 20, radius1: 30,
x2: 40, y2: 20, radius2: 80
};
myNode.setBrush(brush2);

Text and font

Nodes can have text with customizable font and text alignment. Use setText to specify the text for the node; setTextColor changes the color of the text and setTextAlignment - its alignment. The setFont method lets you specify a distinct font for each node:

JavaScript [image] Copy Code

var Font = MindFusion.Drawing.Font;

//the two arguments specify whether the font is bold and italic
startNode.setFont(new Font("sans-serif", 5, true, false));

Styled Text

The EnableStyledText property of shape nodes and tables enables or disables styled text rendering. Styled text can have various attributes applied to the characters it contains. The attributes are specified using HTML-like formatting tags embedded in the raw text. The following table lists the currently supported style tags:

Tag | Description
<i>text</i> | Indicates italic text.
<b>text</b> | Indicates bold text.
<u>text</u> | Indicates underlined text.
<color=#RRGGBB>text</color> | Changes the color of the text. The red green and blue color channels are specified as two-digit hexadecimal numbers.
<br /> | Indicates line break.


Node Effects

Node Effects

To apply an effect to the nodes in a diagram, create an instance of one of the effect classes and add this instance to the Diagram.NodeEffects array. To apply the effect to individual nodes, add the instance to the node's Effects array. To discard the diagram effects for a particular node, add a null reference at position 0 in the node's Effects. Effects can also be applied through styles by adding them to the Style.NodeEffects array of the diagram or a node.

It is possible to combine different effects by adding instances of their appropriate types to the effect collections. If is also admissible to apply more than one effect of the same type.

The currently supplied effect types are Aero and Glass. They are examined in more details in the sections below.

Aero Effect

The Aero effect is represented by the AeroEffect class. The effect is designed to roughly resemble the Aero theme of Windows. More specifically, the effect adds semi transparency to the nodes, a smooth shade at the outside and a thin inset stroke. The semi transparency is specified through the setOpacity method. Opacity varies from 0 to 1 inclusive, where 0 indicates full transparency and 1 indicates the original node color. The semi transparency is applied only on the node brush. The colors of the shade and the inner stroke are specified through the setShadeColor and setInnerOutlineColor methods respectively. The following image illustrates how these properties affect the output:

The following example applies the Aero effect on the nodes of an existing diagram:

JavaScript [image] Copy Code

var AeroEffect = MindFusion.Diagramming.AeroEffect;

var effect = new AeroEffect();
effect.setOpacity(0.5);
effect.setInnerOutlineColor("rgba(255,255,255,0.5)");
diagram.getNodeEffects().push(effect);

Tips

  • The Aero effect works very well in scenarios with overlapping nodes or in cases where the background is more complex than solid color, due to the effect of semi transparency.
  • Aero combines well with the Glass effect. There are some examples at the end of this topic.
  • The ShadeColor is usually black or another dark color. However, some nice glow effects can be achieved by setting bright ShadeColor on a diagram with dark background.
  • The Aero effect can impact performance if there are many nodes visible in the diagram.

Glass Effect

The Glass effect is represented by the GlassEffect class. The Glass effect adds visuals on top of the nodes in order to give the impression of a reflective surface. There are several variations of this effect, which can be selected through the setType method. The color of the reflection and the ambient color can be specified through the setReflectionColor and setGlowColor methods respectively. When UsePenAsGlow is set to true the color of the node's pen is used as the ambient color. The following image illustrates the differences between the distinct effect types:

The following example applies a Glass effect with the default settings to the nodes of a diagram:

JavaScript [image] Copy Code

var GlassEffect = MindFusion.Diagramming.GlassEffect;
diagram.getNodeEffects().push(new GlassEffect());

Tips

  • The GlowColor is usually white. However, for Type4 glass effects it is often more suitable to use black glow.
  • The Glass effect combines well with the Aero effect. There are some examples at the end of this topic.
  • Several glass effects of different types can be applied simultaneously for emphasized effect.

Examples

The values of the effect properties are usually selected in accordance with the color scheme of the target diagram and the desired end result. In addition different types of effects can be applied simultaneously to achieve more interesting results. The examples below demonstrate possible effect combinations in various color contexts.

Aero & Glass (Dark on Light)

In this example the Aero and Glass effects are combined. The Aero effect is useful in scenarios when dark nodes are placed on light background or vice versa, in order to emphasize the contrast.

Here is the code that applies the above effects:

JavaScript [image] Copy Code

diagram.getNodeEffects().push(new GlassEffect());
diagram.getNodeEffects().push(new AeroEffect());

Aero & Glass (Light on Dark)

This example is similar to the first one, only this time the nodes are painted in light colors and the background is dark.

Here is the code that applies the above effect:

JavaScript [image] Copy Code

var AeroEffect = MindFusion.Diagramming.AeroEffect;
var GlassEffect = MindFusion.Diagramming.GlassEffect;
var GlassEffectType = MindFusion.Diagramming.GlassEffectType;

var glassEffect = new GlassEffect();
glassEffect.setType(GlassEffectType.Type3);

diagram.getNodeEffects().push(glassEffect);
diagram.getNodeEffects().push(new AeroEffect());

Glow Effect

This example uses bright colors on black background to create a glow effect. The example utilizes an Aero effect with ShadeColor set to the color of the nodes' pens.

Here is the code that applies the above effects:

JavaScript [image] Copy Code

var AeroEffect = MindFusion.Diagramming.AeroEffect;
var GlassEffect = MindFusion.Diagramming.GlassEffect;
var GlassEffectType = MindFusion.Diagramming.GlassEffectType;

var glassEffect = new GlassEffect();
glassEffect.setType(GlassEffectType.Type2);
glassEffect.setUsePenAsGlow(true);
diagram.getNodeEffects().push(glassEffect);

var aeroEffect = new AeroEffect();
aeroEffect.setOpacity(0);
aeroEffect.setInnerOutlineColor("black");
aeroEffect.setShadeColor("rgb(128, 255, 255)");
diagram.getNodeEffects().push(aeroEffect);


Customizing Link Appearance

Customizing Link Appearance

DiagramLinks-s consist of series of straight or Bezier segments and arrowhead shapes. The link and arrowhead shapes, and also color attributes and text can be customized as detailed below:

Customizing the shape of a link

Your link can be straight or curved and can have one or more segments. Call DiagramLink.setShape to change the shape. It takes as an argument one of the LinkShape enumeration values:

JavaScript [image] Copy Code

myLink.setShape(LinkShape.Cascading);

The link can further be customized by changing its control points - they specify the position of the link. The number of control points per segment depends on the link's Shape: Bezier links have four control points per segment. Each straight segment has two control points. Adjacent segments share a control point.

The following code sets three control points of a polyline link which has two segments:

JavaScript [image] Copy Code

var Point = MindFusion.Drawing.Point;
myLink.setControlPoints([new Point(10, 10), new Point(30, 30), new Point(30, 50)]);
myLink.updateFromPoints();

Note

Always call DiagramLink.updateFromPoints() after you have changed the control points of a link.

Rounded Links

Links comprising straight segments, that is, ones whose Shape is set to Polyline or Cascading, can draw arcs as joinis between their adjacent segments. To enable that feature, set RoundedLinks to true. Use RoundedLinksRadius to specify the radius of the joining arcs.

Link Crossings

Intersection points where links cross their paths can be rendered as arcs or cuts, as specified via LinkCrossings. It depends on the Z-order, which links jump over the others, or which links appear cut by the others. If LinkCrossings is set to Arcs, links with higher ZIndex jump over those with lower ZIndex. If set to Cut, links at lower Z position are cut by links at higher Z. Radius of arcs and breaks can be set through the CrossingRadius property.

Customizing the arrowheads

Each link can start and end with a shape. The shape at the start is called BaseShape, the shape at the end is called HeadShape. The methods that set the shapes are setBaseShape and setHeadShape. They take as argument either the Shape to set or a string that identifies it:

JavaScript [image] Copy Code

myLink.setHeadShape("BowArrow");

The Shape identifiers are also exposed as static members of the Shapes class.

Specifying colors

Link lines are rendered according to Stroke, StrokeThickness and StrokeDashStyle attributes. The shapes at the head and base are filled with HeadBrush and BaseBrush. To access them use setHeadBrush and setBaseBrush as shown below:

JavaScript [image] Copy Code

//paints the link head with red brush
myLink.setHeadBrush("Red");

Setting text

Use setText to set a label of your link, setFont specifies the font. Here is an example how to do this:

JavaScript [image] Copy Code

myLink.setText("myLabel");

var Font = MindFusion.Drawing.Font;

//the two boolean arguments specify whether the font is bold and italic
myLink.setFont(new Font("sans-serif", 5, true, false));

The font size is specified in the diagram's current measure unit, which is millimeter by default.


Animations

MindFusion.Diagramming Programmer's Guide
Animations

Animating Diagram Items

To animate a DiagramItem, instantiate a new Animation object specifying it's properties and call the start method to begin the animation. The following example will animate a node along it's Y-axis from 5 to 100 Y-coordinate, using the Power animation function and the EaseOut easing function:

JavaScript [image] Copy Code

var Animation = MindFusion.Animations.Animation;
var AnimationType = MindFusion.Animations.AnimationType;
var EasingType = MindFusion.Animations.EasingType;

var options =
{
duration: 500,
fromValue: 5,
toValue: 100,
animationType: AnimationType.Power,
param: 2,
easingType: EasingType.EaseOut
};
var animation = new Animation(node, options);
animation.start();

Animate
This page requires a browser that supports HTML 5 Canvas element.

Example 1

Looping Animations

To create looping animations, use the repeat and reverse properties. To stop an animation, call its stop method.

JavaScript [image] Copy Code

// Use this property to repeat the animation until stopped.
animation.setRepeat(true);
// Use this property to reverse the to and from values.
animation.setReverse(true);

// Use the stop method to complete the animation.
animation.stop();

Animate
This page requires a browser that supports HTML 5 Canvas element.

Example 2

OnUpdate Callback

In order to specify which property will be animated, when instantiating an Animation instance, pass an onUpdateCallback function as a parameter to the object's constructor. This callback function can be used to specify which property of the animated item will be animated. The callback signature should contain two arguments - the animation object instance and a value representing the animated property delta. This callback is called at every animation timer "tick". The following example creates a pulse-like effect, using an onUpdateCallback:

JavaScript [image] Copy Code

var Animation = MindFusion.Animations.Animation;
var Utils = MindFusion.Diagramming.Utils;

var options =
{
duration: 550,
fromValue: -0.15,
toValue: 0.15,
repeat: true,
reverse: true
};

/**
* @param [Animation] animation The animation object instance.
* @param [Number] animationDelta A number representing the percentage of displacement
* of the animated property's value in the [fromValue, toValue] range.
*/
function pulse(animation, animationDelta)
{
var bounds = animation.item.getBounds().clone();
var to = animation.getToValue();
bounds = Utils.inflate(bounds, to * animationDelta, to * animationDelta);
animation.item.setBounds(bounds, true);
}

var animation = new Animation(node, options, pulse);
animation.start();

Animate
This page requires a browser that supports HTML 5 Canvas element.

Example 3

Default Animation and Easing Functions

The following example demonstrates the built-in animation and easing functions that the Animation class provides:

EaseIn EaseOut EaseInOut EaseOutIn
This page requires a browser that supports HTML 5 Canvas element.

Example 4

Custom Animation Functions

In addition to the provided default animation functions, it is also possible to define custom animation effects. Set the AnimationType to Custom and pass a custom animation function callback to the Animation constructor. The callback signature should contain two arguments - the time progressed as a percentage from the start of the animation and the user-set parameter, used in the animation function. The following example uses a custom function [image] where x is a value between 0 and 1 and y is a parameter, passed as an argument to the Animation constructor.

JavaScript [image] Copy Code

var Animation = MindFusion.Animations.Animation;
var AnimationType = MindFusion.Animations.AnimationType;

var options =
{
duration: 500,
fromValue: 5,
toValue: 100,
param: 5,
animationType: AnimationType.Custom
};

/**
* @param [Number] progress The time progress in the animation loop. A value between 0 and 1.
* @param [Object] param The user-set value, used to parameterize the animation function.
*/
function custom(progress, param)
{
return Math.pow(Math.E, 1 - (1 / Math.pow(progress, param)));
}

var animation = new Animation(node, options, null, custom);
animation.start();

Animate
This page requires a browser that supports HTML 5 Canvas element.

Example 5

© 2014 MindFusion


Initial Values of Item Properties

Initial Values of Item Properties

Each new item, created either by the user or programmatically, is initialized with some kind of default property values.

If you create items by using the new operator and adding them the diagram's Nodes or Links collection, you can initialize the items by passing a Diagram reference to the respective constructor, or by passing another item to the copy constructor. In the former case, item properties are initialized from the default-property values defined in Diagram. In the latter case, properties are copied from the prototype item.

When users draw new items, the items are initialized from the Diagram properties, but you can change the default values by handling the initializeNode and initializeLink events.

Items created via the diagram's Factory object are always initialized from the default-property values defined in Diagram.

Below are listed item properties and the corresponding constants or Diagram properties through which they are initialized.

Note that some properties in the tables below are marked as styled. Styled properties usually default to null (Nothing in Visual Basic), unless the item is created through the prototype constructor, in which case the values of the styled properties are obtained from the prototype item. When a style property is null, its effective value is determined by the style associated with the item or the theme applied to the diagram. For more information on how the style system works, check Styles and Themes.

DiagramItem Property | Initialized With
Brush (styled) | null (affected by Brush of the corresponding DiagramItemStyle)
Locked | false
Font (styled) | null (affected by FontFamily, FontSize, FontStyle, and FontUnit of the corresponding DiagramItemStyle)
Pen (styled) | null (affected by Stroke and StrokeThickness of the corresponding DiagramItemStyle)
ShadowBrush (styled) | null (affected by ShadowBrush of the corresponding DiagramItemStyle)
ShadowOffsetX | ShadowOffsetX
ShadowOffsetY | ShadowOffsetY
Tag | null
TextBrush (styled) | null (affected by TextBrush of the corresponding DiagramItemStyle)
ToolTip | (empty string)
Visible | true

ShapeNode Property | Initialized With
EnabledHandles | AdjustmentHandles.All
Expandable | NodesExpandable
ImageUrl | (empty string)
ImageAlign | ImageAlign.Fit
Text | ShapeText
TextFormat | TextFormat
Transparent | false

ContainerNode Property | Initialized With
Caption | ContainerCaption
CaptionHeight | ContainerCaptionHeight
Foldable | ContainersFoldable
Folded | false
Margin | ContainerMargin

TableNode Property | Initialized With
Caption | TableCaption
ConnectionStyle | TableConnectionStyle
Scrollable | TablesScrollable

DiagramLink Property | Initialized With
BaseShape | LinkBaseShape
HeadShape | LinkHeadShape
Shape | LinkShape
Text | LinkText


Tutorials

Tutorials


Tutorial 1: Getting started

Tutorial 1: Getting started

This tutorial will show you how to set up your project to use MvcDiagram.

1. Creating an ASP.NET MVC Application

Go to File->New->Project. From the list of installed templates choose Visual C# and then select the ASP.NET MVC 4 Web application option. Enter as name of the application "Tutorial1" and press OK.

2. Referencing the dll-s

Add references to MindFusion.Common.dll, MindFusion.Diagramming.dll and MindFusion.Diagramming.Mvc.dll to the project. To add the references, locate the "References" node in the Solution Explorer tree to the right and choose "Add reference" from the context menu. When the dialog appears, navigate to the MvcDiagram's installation folder, select the needed dll-s and press OK. The three dll-s should now appear below the "References" node.

3. Referencing the client scripts

Add MindFusion.Diagramming.js file to the Scripts folder of the project. To do this, locate the "Scripts" node in the Solution Explorer tree and select Add-> Existing item from the context menu. Navigate to the MvcDiagram's installation folder, select the MindFusion.Diagramming.js file and click "Add". The MindFusion.Diagramming.js file should now appear below the "Scripts" node. If you need to change the location of the MindFusion.Diagramming.js use the ClientScriptLocation to notify the control:

C# [image] Copy Code

view.ClientScriptLocation = "/SomeFolder/MindFusion.Diagramming.js";

The control can use either jQuery or Microsoft Ajax for browser abstraction, with JQuery being the default. You can switch to Microsoft Ajax by setting the DiagramView.ClientSideMode property to ClientSideMode.MsAjax. Additionally, you will need to add the MicrosoftAjax.js script to the Scripts folder and a reference to it in the head section of the _Layout.cshtml file.

HTML [image] Copy Code

@Scripts.Render("~/Scripts/MicrosoftAjax.js")

If you need to use a different version of JQuery than the one shipped with MVC (1.7.1 for MVC4 and 1.10.2 for MVC5) set the JQueryLocation property to the corresponding value:

C# [image] Copy Code

view.JQueryLocation = "Scripts/jquery-1.x.1.js";

4. Adding a DiagramView to the page

Open the Index.cshtml page, which is located below the Views->Home node in the Solution Explorer tree. Add references to the MindFusion.Diagramming and MindFusion.Diagramming.Mvc namespaces by typing the following lines in the beginning of the file:

HTML [image] Copy Code
@using MindFusion.Diagramming;
@using MindFusion.Diagramming.Mvc;

For the purpose of this tutorial also add references to System.Drawing and MindFusion.Drawing namespaces.

HTML [image] Copy Code

@using System.Drawing;
@using SolidBrush = MindFusion.Drawing.SolidBrush;
@using LinearGradientBrush = MindFusion.Drawing.LinearGradientBrush;

Add a call to the HTML helper's DiagramView method by typing the following line:

HTML [image] Copy Code

@Html.DiagramView((DiagramView)ViewBag.DiagramView, new {style = "width:700px; height:500px"})

5. Creating the diagram

Add the following code block before the call to the DiagramView's HTML helper method:

C# [image] Copy Code

@{
// initialize the DiagramView
DiagramView view = new DiagramView("diagramView1");
}

The code above creates a new DiagramView object with Id set to "diagramView1".

Change some properties of the view's Diagram object:

C# [image] Copy Code

Diagram diagram = view.Diagram;
diagram.BackBrush = new SolidBrush(Color.White);
diagram.LinkHeadShape = ArrowHeads.Triangle;
diagram.LinkHeadShapeSize = 3;

DiagramStyle style = new DiagramStyle();
style.FontFamily = "Verdana";
style.Brush = new LinearGradientBrush(Color.LightBlue, Color.Blue, 90);
style.Stroke = new SolidBrush(Color.Black);
diagram.Style = style;

Diagram's BackBrush property defines the default color with which the interior of the diagram will be filled. Diagram's LinkHeadShape and LinkHeadShapeSize properties define the default base shape and size for links' ending arrowhead. Additional styles can be applied to the diagram items by using the diagram's Style property.

Add the following code to add some ShapeNodes to the diagram. ShapeNode objects can be drawn as various geometric shapes, as set through their Shape property. There are over 100 predefined shapes exposed as static members of the Shapes class. The Shape property can be set to one of the predefined shapes: RoundRect, Rectangle, Ellipse, Process, Procedure, Delay and much more.

C# [image] Copy Code

// add some nodes and links to the view's Diagram
ShapeNode node1 = diagram.Factory.CreateShapeNode(new RectangleF(55, 10, 40, 15));
node1.Shape = Shapes.Terminator;
node1.Text = "Start";
node1.Brush = new LinearGradientBrush(Color.Yellow, Color.Orange, 90);

ShapeNode node2 = diagram.Factory.CreateShapeNode(new RectangleF(50, 40, 50, 20));
node2.Text = "Receive order via e-mail";

ShapeNode node3 = diagram.Factory.CreateShapeNode(new RectangleF(50, 70, 50, 20));
node3.Text = "Copy and paste e-mail data into database";

ShapeNode node4 = diagram.Factory.CreateShapeNode(new RectangleF(55, 100, 40, 40));
node4.Shape = Shape.FromId("Decision");
node4.Text = "Shipping involved?";
node4.Brush = new LinearGradientBrush(Color.White, Color.Fuchsia, 90);

ShapeNode node5 = diagram.Factory.CreateShapeNode(new RectangleF(100, 135, 50, 20));
node5.Shape = Shape.FromId("Save");
node5.Text = "Print invoice and UPS label";
node5.Brush = new SolidBrush(Color.Chartreuse);

ShapeNode node6 = diagram.Factory.CreateShapeNode(new RectangleF(100, 165, 50, 20));
node6.Text = "Send e-mail to confirm shipping";
diagram.Nodes.Add(node6);

ShapeNode node7 = diagram.Factory.CreateShapeNode(new RectangleF(100, 195, 50, 20));
node7.Text = "Assemble package and ship";

ShapeNode node8 = diagram.Factory.CreateShapeNode(new RectangleF(55, 230, 40, 15));
node8.Shape = Shapes.Terminator;
node8.Text = "End";
node8.Brush = new LinearGradientBrush(Color.Yellow, Color.Orange, 90);

Add the following code to add some DiagramLinks to the diagram:

C# [image] Copy Code

diagram.Factory.CreateDiagramLink(node1, node2);
diagram.Factory.CreateDiagramLink(node2, node3);
diagram.Factory.CreateDiagramLink(node3, node4);

DiagramLink link4 = diagram.Factory.CreateDiagramLink(node4, node5);
link4.Text = "Yes";

diagram.Factory.CreateDiagramLink(node5, node6);
diagram.Factory.CreateDiagramLink(node6, node7);
diagram.Factory.CreateDiagramLink(node7, node8);

DiagramLink link8 = diagram.Factory.CreateDiagramLink(node4, node8);
link8.Text = "No";

Finally, store the newly created view in the ViewBag dictionary:

C# [image] Copy Code

ViewBag.DiagramView = view;

6. Running the application

From the main menu choose Debug->Start without debugging or press CTRL+F5. The image below depicts how the application would look like:


Tutorial 2: Handling client-side events

Tutorial 2: Handling client-side events

This tutorial will show you how to use client events in MvcDiagram.

1. Create a new ASP.NET MVC Application and add a DiagramView control to the page

Follow steps 1-4 from Tutorial 1: Getting started.

2. Create and arrange the diagram

Open the Index.cshtml file and add a reference to the MindFusion.Diagramming.Layout namespace in the 'using' section of the page:

C# [image] Copy Code
@using MindFusion.Diagramming.Layout;

Add the following code block to create a new DiagramView object and add some nodes and links to its Diagram.

C# [image] Copy Code

@{
// initialize the DiagramView
DiagramView view = new DiagramView("diagramView1");
Diagram diagram = view.Diagram;

// add some nodes and links
for (var i = 0; i < 5; i++)
{
var node = diagram.Factory.CreateShapeNode(new RectangleF(0, 0, 25, 25));
node.Text = "node " + i;
diagram.Nodes.Add(node);
if (i > 0)
{
var link = diagram.Factory.CreateDiagramLink(diagram.Nodes[0], node);
diagram.Links.Add(link);
}
}
}

Set the Brush property of the first node to DarkRed and its Text to "Root":

C# [image] Copy Code

var rootNode = diagram.Nodes[0];
rootNode.Brush = new SolidBrush(Color.DarkRed);
((ShapeNode)rootNode).Text = "Root";

Create a FractalLayout object and apply it to the Diagram:

C# Copy Code
var layout = new FractalLayout();
layout.Root = rootNode;
layout.Arrange(diagram);

Add the newly created view to the ViewData dictionary:

C# Copy Code
ViewBag.DiagramView = view;

Modify the call to the DiagramView HTML helper method as following to set the NodeCreatedScript to "nodeCreated" and NodeDeletedScript to "nodeDeleted". These are the names of the JavaScript functions that will handle the corresponding events. We will define them a bit later in the Index.cshtml file.

HTML [image] Copy Code

@Html.DiagramView(
((DiagramView)ViewBag.DiagramView)
.NodeCreatedScript("nodeCreated")
.NodeDeletedScript("nodeDeleted"),
new { style="width:700px; height:500px;" }
)

3. Handling client events

Add the following JavaScript block to the end of the page:

JavaScript [image] Copy Code

<script type="text/javascript">
function nodeCreated(sender, args) {
if (args.getNode()) {
// send an ajax request to the Controller's Test action method
$.ajax(
{
type: "POST", url: "/Home/Test", data: { json: sender.toJson(), index: Array.indexOf(sender.nodes, args.getNode()) }, dataType: 'json',
success: function (result) {
sender.fromJson(result.success);
},
error: function (req, status, error) {
alert(error);
}
});
}
}

function nodeDeleted(sender, args) {
if (args.getNode().getZIndex() == 0) {
if (sender.nodes.length > 0) {
// set the root node to the first node in the diagram.nodes collection
var rootNode = sender.nodes[0];
rootNode.setBrush({ type: 'SolidBrush', color: 'firebrick' });
rootNode.setText("root");
rootNode.setZIndex(0);
// create links between the root and children nodes
for (var i = 1; i < sender.nodes.length; i++) {
sender.getFactory().createDiagramLink(sender.nodes[0], sender.nodes[i]);
}
}
}
}
</script>

Open the HomeController.cs file and add the Test action method:

C# [image] Copy Code

public JsonResult Test(string json, string index)
{
DiagramView view = DiagramView.FromJson(json);
Diagram diagram = view.Diagram;
var newNode = ((ShapeNode)diagram.Nodes[Int32.Parse(index)]);
newNode.Text = "node " + (diagram.Nodes.Count-1).ToString();
if (diagram.Nodes.Count > 1)
{
// create a link between the root node and the newly created node and apply the layout to the diagram
var link = diagram.Factory.CreateDiagramLink(diagram.Nodes[0], newNode);
var layout = new FractalLayout();
layout.Root = diagram.Nodes[0];
layout.Arrange(diagram);
}
else
{
// set the newly created node as a root node
newNode.Brush = new SolidBrush(Color.DarkRed);
((ShapeNode)newNode).Text = "Root";
}
return Json(new { success = DiagramView.ToJson(view) });
}

When a new node is added to the diagram the nodeCreated function will be called. It will send an ajax request, containing the serialized to JSON view and the index of the new node to the controller's Test action method. Within the Test method the view will be recreated from the JSON string and depending of the number of nodes in the diagram either a link between the root node and the new node will be created or the new node will be set as root.

The nodeDeleted function is called upon node deletion. If the deleted node is the root node a new root node will be assigned and will be linked to all other nodes in the diagram.

4. Run the application

Run the application. Try adding and deleting some nodes to see how the events will be handled.


Tutorial 3: Overview and NodeListView

Tutorial 3: Overview and NodeListView

This tutorial shows how to use the Overview and NodeListView components.

1. Create a new ASP.NET MVC Application and add a DiagramView control to the page

Follow steps 1-5 from Tutorial 1: Getting started.

2. Add the controls to the page

Add the following initialization code for the DiagramView, Overview, and NodeListView controls in the Index.cshtml file's code block :

HTML [image] Copy Code

diagram.ShowGrid = true;
diagram.GridColor = Color.Red;
diagram.AlignToGrid = true;
view.AllowInplaceEdit = true;

Overview overview = new Overview("overview1", "diagramView1");
overview.BackColor = Color.LightGray;
overview.DimColor = new MindFusion.Drawing.SolidBrush(Color.White);
ViewBag.Overview = overview;

NodeListView nodelist = new NodeListView("nodelist1");
for (var i = 0; i < Shape.Shapes.Count; ++i)
{
if (Shape.Shapes[i].Id != "RoundRect1" && !Shape.Shapes[i].IsArrowhead)
{
var node = new MindFusion.Diagramming.ShapeNode();
node.Brush = new MindFusion.Drawing.SolidBrush(Color.LightBlue);
node.Shape = Shape.Shapes[i];
nodelist.AddNode(node);
}
}

Setting the Diagram's ShowGrid property to true will display the alignment grid, and setting the AlignToGrid property will ensure the that the sides newly created nodes will be aligned to the nearest grid point.

The view's AllowInplaceEdit property defines whether items' text can be edited inplace.

The Overview's BackColor property defines the background color of the control and the DimColor property sets the color of the displayed diagram.

Use the NodeListView control's AddNode method to add an arbitrary number of nodes to its nodes collection.

Remove the call to the Diagram's HTML Helper method and add the following form declaration instead:

HTML [image] Copy Code

@using (Html.BeginForm())
{
<input type="submit" name="submitButton" value="submit" />

@Html.DiagramView(((DiagramView)ViewBag.DiagramView), new { style="width:700px; height:700px;" })

@Html.Overview(((Overview)ViewBag.Overview), new { style="width:200px; height:200px;" })

@Html.NodeListView(((NodeListView)ViewBag.NodeListView), new { style="width:200px; height:500px;" })

3. Submitting the form

Upon form submission the DiagramView control will serialize itself to JSON and will store the serialized string in a hidden field. This field will be added automatically to the form by the DiagramView control and will have a name matching the following pattern: DiagramViewId + "_PostData" e.g. "diagramView1_PostData". You can access the field through the Request.Form collection and pass the data to the DiagramView's FromJson method in order to keep the changes made from the client. The diagram's FromRequest static method can be used as a shortcut to achieve the same effect.

Enclose the diagram's initialization code within the following IsPost block:

C# [image] Copy Code

if (!IsPost)
{
DiagramView view = new DiagramView("diagramView1");

Diagram diagram = view.Diagram;
diagram.BackBrush = new SolidBrush(Color.White);
[...]
link8.Text = "No";

ViewBag.DiagramView = view;
}
else
{
ViewBag.DiagramView = DiagramView.FromRequest("diagramView1", Request);
}

4. Running the application

Run the application. Try drawing some nodes and/or links. Double-click on an object to inplace-edit it's text. Drag items from the NodeListView control onto the Diagram to create new nodes. Submit the form to see how the control will store your changes.
The image below depicts how the application would look like with some nodes and links added to the diagram.


Tutorial 4: Loading graph data

Tutorial 4: Loading graph data

This tutorial shows how to load graph data from XML and create diagram objects corresponding to the graph nodes and edges.

1. Create a new ASP.NET MVC Application and add a DiagramView control to the page

Follow steps 1-5 from Tutorial 1: Getting started.

2. Create the XML file

From the project's context menu choose Add -> New Item. Create a new XML file called SampleGraph.xml and add the following markup to its content.

XML [image] Copy Code

<?xml version="1.0" encoding="utf-8" ?>
<Graph>
<Nodes>
<Node id="0" name="start" />
<Node id="1" name="activity 1" />
<Node id="2" name="task 1" />
<Node id="3" name="task 2" />
<Node id="4" name="activity 2" />
<Node id="5" name="task 3" />
<Node id="6" name="task 4" />
<Node id="7" name="activity 3" />
<Node id="8" name="task 5" />
<Node id="9" name="task 6" />
<Node id="10" name="end" />
</Nodes>
<Links>
<Link origin="0" target="1" />
<Link origin="1" target="2" />
<Link origin="1" target="3" />
<Link origin="2" target="4" />
<Link origin="3" target="4" />
<Link origin="4" target="5" />
<Link origin="4" target="6" />
<Link origin="5" target="10" />
<Link origin="6" target="10" />
<Link origin="0" target="7" />
<Link origin="7" target="8" />
<Link origin="8" target="9" />
<Link origin="1" target="9" />
<Link origin="9" target="10" />
</Links>
</Graph>

Set the file's "Build Action" property to "Content" and "Copy to Output Directory" to "Copy if newer".

3. Load the XML document

Open Index.cshtml file and and references to System.Xml.Linq and MindFusion.Diagramming.Layout namespaces.

C# [image] Copy Code

@using System.Xml.Linq
@using MindFusion.Diagramming.Layout

Delete the code for creating nodes and links in the code block and add declarations for the following variables. "nodeMap" maps diagram nodes to their identifiers, and "bounds" contains the default node size.

C# [image] Copy Code

Dictionary<string, DiagramNode> nodeMap = new Dictionary<string, DiagramNode>();
RectangleF bounds = new RectangleF(0, 0, 60, 20);

Load the XML document and its root element using the Linq for XML API:

C# [image] Copy Code

var xml = XDocument.Load(Server.MapPath("~/SampleGraph.xml"));
var graph = xml.Element("Graph");

4. Create the Shape nodes

Load the graph node elements and create their corresponding ShapeNode objects by calling the CreateShapeNode method of the Factory class. CreateShapeNode is just a shortcut to creating a ShapeNode instance using the "new" operator and adding it to the Nodes collection of the diagram. Additionally, this code maps the new node to the "id" attribute of the XML element, and sets the node's Text to the value of the "name" attribute.

C# [image] Copy Code

var nodes = xml.Descendants("Node");
foreach (var node in nodes)
{
var diagramNode = diagram.Factory.CreateShapeNode(bounds);
nodeMap[node.Attribute("id").Value] = diagramNode;
diagramNode.Text = node.Attribute("name").Value;
}

5. Create the Diagram links

Load the graph links and create corresponding DiagramLink objects. The Origin and Destination of the links are accessed by their ids through the "nodeMap" dictionary.

C# [image] Copy Code

var links = xml.Descendants("Link");
foreach (var link in links)
{
diagram.Factory.CreateDiagramLink(
nodeMap[link.Attribute("origin").Value],
nodeMap[link.Attribute("target").Value]);
}

6. Arrange the diagram

Arrange the diagram using the LayeredLayout class. Call the Diagram's ResizeToFitItems method to ensure that its bounds will fit all diagram items.

C# [image] Copy Code

var layout = new LayeredLayout();
layout.NodeDistance = 80;
layout.Arrange(diagram);
diagram.ResizeToFitItems(5);

7. Run the application

Build and run the project. If everything is fine, you should see this representation of the graph:


Tutorial 5: Loading hierarhical data

Tutorial 5: Loading hierarhical data

This tutorial shows how to load hierarchical data recursively from XML and create diagram items corresponding to the hierarchy.

1. Create a new ASP.NET MVC Application and add a DiagramView control to the page

Follow steps 1-4 from Tutorial 1: Getting started.

2. Create the XML file

From the project's context menu choose Add -> New Item. Create a new XML file called SampleTree.xml and add the following markup to its content.

XML [image] Copy Code

<?xml version="1.0" encoding="utf-8" ?>
<Project>
<Activity Name="Activity 1">
<Activity Name="sub-activity 1">
<Activity Name="sub-activity 1-1" />
<Activity Name="sub-activity 1-2" />
</Activity>
<Activity Name="sub-activity 2">
<Activity Name="sub-activity 2-1" />
<Activity Name="sub-activity 2-2" />
<Activity Name="sub-activity 2-3" />
</Activity>
<Activity Name="sub-activity 3">
<Activity Name="sub-activity 3-1" />
<Activity Name="sub-activity 3-2" />
</Activity>
</Activity>
<Activity Name="Activity 2">
<Activity Name="sub-activity 1">
<Activity Name="sub-activity 1-1" />
<Activity Name="sub-activity 1-2" />
<Activity Name="sub-activity 1-3" />
</Activity>
<Activity Name="sub-activity 2">
<Activity Name="sub-activity 2-1" />
<Activity Name="sub-activity 2-2" />
</Activity>
</Activity>
<Activity Name="Activity 3">
<Activity Name="sub-activity 1">
<Activity Name="sub-activity 1-1" />
<Activity Name="sub-activity 1-2" />
<Activity Name="sub-activity 1-3" />
<Activity Name="sub-activity 1-4" />
</Activity>
<Activity Name="sub-activity 2" />
<Activity Name="sub-activity 3">
<Activity Name="sub-activity 3-1" />
<Activity Name="sub-activity 3-2" />
</Activity>
</Activity>
</Project>

Set the file's "Build Action" property to "Content" and "Copy to Output Directory" to "Copy if newer".

3. Load the XML document

Open HomeController.cs file and and the following references:

C# [image] Copy Code

using System.Xml.Linq;
using System.Drawing;
using MindFusion.Diagramming;
using MindFusion.Diagramming.Mvc;
using MindFusion.Diagramming.Layout;
using SolidBrush = MindFusion.Drawing.SolidBrush;
using LinearGradientBrush = MindFusion.Drawing.LinearGradientBrush;

Add the following member to the page class to hold the default node size:

C# [image] Copy Code

RectangleF nodeBounds = new RectangleF(0, 0, 30, 10);

Add the diagram's initialization code to the body of the Index method.

C# [image] Copy Code

DiagramView view = new DiagramView("diagramView1");

Diagram diagram = view.Diagram;
diagram.LinkHeadShape = ArrowHeads.Triangle;
diagram.LinkHeadShapeSize = 3;

DiagramStyle style = new DiagramStyle();
style.FontFamily = "Verdana";
style.BackBrush = new SolidBrush(Color.White);
style.Brush = new LinearGradientBrush(Color.LightBlue, Color.Blue, 90);
style.Stroke = new SolidBrush(Color.Black);
diagram.Style = style;

ViewBag.DiagramView = view;
return View();

4. Define CreateChildren method

Define CreateChildren as follows. It takes as parameters the parent DiagramNode and parent XML element, iterates the child XML elements to build the next level of the hierarchy, and creates corresponding diagram items by calling CreateShapeNode and CreateDiagramLink.

C# [image] Copy Code

private void CreateChildren(Diagram diagram, DiagramNode parentDiagNode, XElement parentXmlElement)
{
foreach (var element in parentXmlElement.Elements("Activity"))
{
var node = diagram.Factory.CreateShapeNode(nodeBounds);
node.Text = element.Attribute("Name").Value;
diagram.Factory.CreateDiagramLink(parentDiagNode, node);
CreateChildren(diagram, node, element);
}
}

Add the following block to the Index method to create the tree root node, and add a call to the CreateChildren method, which builds the tree recursively.

C# [image] Copy Code
var root = diagram.Factory.CreateShapeNode(nodeBounds);
root.Text = "Project";
var document = XDocument.Load(Server.MapPath("~/SampleTree.xml"));
CreateChildren(diagram, root, document.Element("Project"));

5. Arrange the diagram

Use TreeLayout to arrange the diagram. Add the following code to the end of the Index method.

C# [image] Copy Code

var layout = new TreeLayout();
layout.Type = TreeLayoutType.Cascading;
layout.Direction = TreeLayoutDirections.LeftToRight;
layout.LinkStyle = TreeLayoutLinkType.Cascading2;
layout.NodeDistance = 5;
layout.LevelDistance = -25; // let horizontal positions overlap
layout.Arrange(diagram);

Call the Diagram's ResizeToFitItems method to ensure that its bounds will fit all diagram items. Set the ZoomFactor property of the view to 70.

C# [image] Copy Code
diagram.ResizeToFitItems(5);

6. Run the application

Build and run the project. If everything is fine, you should see this representation of the hierarchy:


Tutorial 6: Create a Custom Node Type

Tutorial 6: Create a Custom Node Type

This tutorial shows how to define a custom node class that adds several new properties.

1. Create a new ASP.NET MVC Application and add a DiagramView control to the page

Follow steps 1-4 from Tutorial 1: Getting started.

2. Create the custom node type

Switch to Index.aspx and add the following Javascript block to the end of the page.

JavaScript [image] Copy Code

<script type="text/javascript">

var Diagram = MindFusion.Diagramming.Diagram;
var Behavior = MindFusion.Diagramming.Behavior;

var Font = MindFusion.Drawing.Font;
var Rect = MindFusion.Drawing.Rect;
var Text = MindFusion.Drawing.Text;

var diagram = null;

var OrgChartNode = function (parent)
{
MindFusion.AbstractionLayer.initializeBase(OrgChartNode, this, [parent]);

this.setTitle('title');
this.setFullName('full name');
this.setNodeImageLocation('Content/icon4.png');

this.setShape('Rectangle');
this.setText('node text');
this.setBrush('#fff');
}

OrgChartNode.prototype =
{
// draw logic
updateCanvasElements: function (node)
{
MindFusion.AbstractionLayer.callBaseMethod(OrgChartNode, this, 'updateCanvasElements');

// add the node image;
if (this.nodeImage)
{
this.nodeImage.setBounds(new Rect(this.bounds.x, this.bounds.y + (this.bounds.height - 20) / 2, 20, 20));
this.graphicsContainer.content.push(this.nodeImage);
}

// add the title label
var titleFont = Font.copy(this.getEffectiveFont());
var titleLabel = new Text(this.getTitle(),
new Rect(this.bounds.x + 21, this.bounds.y + 5, this.bounds.width - 22, titleFont.size));
titleLabel.font = titleFont;
titleLabel.font.bold = true;
titleLabel.fitInBounds = false;
this.graphicsContainer.content.push(titleLabel);

// add the name label
var nameFont = Font.copy(this.getEffectiveFont());
var nameLabel = new Text(this.getFullName(),
new Rect(this.bounds.x + 21, this.bounds.y + 5 + titleFont.size, this.bounds.width - 22, nameFont.size));
nameLabel.font = nameFont;
nameLabel.pen = "blue";
nameLabel.fitInBounds = false;
this.graphicsContainer.content.push(nameLabel);

// adjust the text label properties
var textFont = Font.copy(this.getEffectiveFont());
textFont.size = 3;
var textRect = new Rect(this.bounds.x + 21, this.bounds.y + 3 + titleFont.size + nameFont.size, this.bounds.width - 22, this.bounds.height - 2 - titleFont.size - nameFont.size);
this.text.font = textFont;
this.text.textAlignment = Alignment.Near;
this.text.lineAlignment = Alignment.Near;
this.text.margin = 0;
this.text.setBounds(textRect, 0);
},

loadNodeImage: function ()
{
this.nodeImage.loaded = true;
if (this.parent)
this.invalidate();
},

// properties
getTitle: function ()
{
return this.title;
},

setTitle: function (value)
{
if (this.title !== value)
{
this.title = value;
}
},

getFullName: function ()
{
return this.fullName;
},

setFullName: function (value)
{
if (this.fullName !== value)
{
this.fullName = value;
}
},

getNodeImageLocation: function ()
{
return this.nodeImageLocation;
},

setNodeImageLocation: function (value)
{
if (this.nodeImageLocation != value)
{
this.nodeImageLocation = value;
if (value)
{
this.nodeImage = new MindFusion.Drawing.Image(new Rect(this.bounds.x, this.bounds.y + (this.bounds.height - 20) / 2, 20, 20));
MindFusion.AbstractionLayer.addHandlers(this.nodeImage.image, { load: MindFusion.AbstractionLayer.createDelegate(this, this.loadNodeImage) });
this.nodeImage.image.src = value;
}
}
}
};

</script>

In the above code, shorter names are assigned to the Diagram, Behavior, Font, Rect and Text classes. Then a new class constructor for an object called OrgChartNode is created. This class inherits from ShapeNode and has property getters and setters for a custom title, full name and image in its prototype. OrgChartNode also exposes an updateCanvasElements override with the custom draw logic.

3. Register the custom type and create some test data

Modify the DiagramView declaration to set the value of the ControlLoadedScript property.

HTML [image] Copy Code

@Html.DiagramView(((DiagramView)ViewBag.DiagramView).ControlLoadedScript("onLoaded"), new { style = "width:700px;height:500px;"})

Add the onLoaded function to the JavaScript block. The below code registers the OrgChartNode type, enables the interactive drawing of custom nodes and adds a couple of OrgChartNode instances to the diagram.

JavaScript [image] Copy Code

function onLoaded(sender)
{
MindFusion.registerClass(OrgChartNode, "OrgChartNode", MindFusion.Diagramming.ShapeNode);

diagram = sender;

// enable drawing of custom nodes interactively
diagram.setCustomNodeType(OrgChartNode);
diagram.setBehavior(Behavior.Custom);

var node1 = new OrgChartNode(diagram);
node1.setBounds(new Rect(25, 15, 60, 25));
node1.setTitle("CEO");
node1.setFullName("John Smith");
node1.setText(
"Our beloved leader. \r\n" +
"The CEO of this great corporation.");
node1.setNodeImageLocation("Content/icon4.png");
diagram.addItem(node1);

var node2 = new OrgChartNode(diagram);
node2.setBounds(new Rect(55, 55, 60, 25));
node2.setTitle("CIO");
node2.setFullName("Bob Smith");
node2.setText("The CIO of this great corporation.");
node2.setNodeImageLocation("Content/icon5.png");
diagram.addItem(node2);

diagram.getFactory().createDiagramLink(node1, node2);
}

4. Running the application

Build and run. The image below depicts how the application would look like:


Tutorial 7: Custom Nodes Integration

Tutorial 7: Custom Nodes Integration

This tutorial shows how to fully integrate the custom type with other MvcDiagram features, such as clipboard support, undo support, creating nodes by drag-and-drop or drawing with the mouse on the canvas.

1. Create a custom node type

Follow steps 1-3 from Tutorial 6: Create a Custom Node Type.

2. Modify the OrgChartNode's prototype

Add the following methods to the OrgChartNode's prototype:

JavaScript [image] Copy Code

// support for the NodeListView drag'n'drop
clone: function () {
Diagram.suppressSetDirty = true;
var copy = MindFusion.AbstractionLayer.callBaseMethod(OrgChartNode, this, "clone", []);

copy.setTitle(this.getTitle());
copy.setFullName(this.getFullName());
copy.setNodeImageLocation(this.getNodeImageLocation());

Diagram.suppressSetDirty = false;
return copy;
},

// clipboard support
toJson: function () {
var json = MindFusion.AbstractionLayer.callBaseMethod(OrgChartNode, this, "toJson", []);

json.title = this.getTitle();
json.fullName = this.getFullName();
json.nodeImageLocation = this.getNodeImageLocation();

return json;
},

fromJson: function (json) {
MindFusion.AbstractionLayer.callBaseMethod(OrgChartNode, this, "fromJson", [json]);

this.setTitle(json.title);
this.setFullName(json.fullName);
this.setNodeImageLocation(json.nodeImageLocation);

return json;
},

// undo/redo
saveState: function () {
var state = MindFusion.AbstractionLayer.callBaseMethod(OrgChartNode, this, "saveState", []);

state.title = this.getTitle();
state.fullName = this.getFullName();
state.nodeImageLocation = this.getNodeImageLocation();

return state;
},

restoreState: function (state) {
MindFusion.AbstractionLayer.callBaseMethod(OrgChartNode, this, "restoreState", [state]);

this.setTitle(state.title);
this.setFullName(state.fullName);
this.setNodeImageLocation(state.nodeImageLocation);
},

3. Add a NodeListView control

Add a NodeListView control to the page:

HTML [image] Copy Code
@Html.NodeListView(((NodeListView)ViewBag.NodeListView), new { style = "width:300px;height:500px;"})

Add the initialization code for the NodeListView to the onLoaded handler:

JavaScript [image] Copy Code

nodeListView = MindFusion.Diagramming.NodeListView.find("nodeListView1");
nodeListView.setMeasureUnit(6);
nodeListView.setPadding(1);
nodeListView.setIconSize(new Size(60, 25));
nodeListView.setDefaultNodeSize(new Size(60, 25));

4. Enable the undo/redo support

Set the diagram's undoEnabled property value to true in the onLoaded handler:

JavaScript [image] Copy Code

// enable undo/redo support
diagram.setUndoEnabled(true);

5. Call diagram methods

Add five buttons to the page - copy, cut, paste, undo and redo and define click handlers that will be used to call the corresponding diagram methods.

HTML [image] Copy Code

<button onclick="diagram.copyToClipboard()">copy</button>
<button onclick="diagram.cutToClipboard()">cut</button>
<button onclick="diagram.pasteFromClipboard(5, 5)">paste</button>
<button onclick="diagram.undo()">undo</button>
<button onclick="diagram.redo()">redo</button>

6. Running the application

Build and run. The image below depicts how the application would look like after adding some nodes and links:


Reference

Reference


Client Side Reference

Client Side Reference


MindFusion.Animations Namespace

MindFusion.Animations Namespace
Classes Enumerations

Classes

Class | Description
Animation | Represents an object that is used to animate diagram items on the canvas.
Events | Defines all events raised in the Animations namespace.

Enumerations

Enumeration | Description
AnimationType | Specifies the animation function used by an Animation object.
EasingType | Specifies the easing applied to an animation.


MindFusion.Animations.Animation Class

Animation Class
Remarks See Also
[image]

Represents an object that is used to animate diagram items on the canvas.

Namespace: MindFusion.Animations
Assembly: Animation.js

Syntax

JavaScript [image] Copy Code

// class
Animation.prototype = {}

Remarks

For more information on how to use the Animation class, please refer to the Animations topic in the Programming Interface Overview.

Inheritance Hierarchy

See Also

Animation Members
MindFusion.Animations Namespace


MindFusion.Animations.Animation Members

Animation Members
Constructors Methods
[image]

Represents an object that is used to animate diagram items on the canvas.

The following tables list the members exposed by the Animation type.

Public Constructors

Name | Description
Animation | Initializes a new instance of the Animation class.

Public Methods

Name | Description
addEventListener | Registers a single event listener on the Animation.
dispose | Sys.IDisposable implementation.
getAnimationType | Gets the type of the animation.
getDuration | Gets the duration of the animation function in milliseconds.
getEasingType | Gets the easing type of the animation.
getFromValue | Gets the initial value of the property that will be animated.
getParam | Gets the optional parameter to use in the animation function.
getProgress | Gets the progress of the current animation iteration.
getRepeat | Gets a value indicating whether to restart the animation after it completes.
getReverse | Gets a value indicating whether to swap the from and to values after the animation completes.
getToValue | Gets the target value of the property that will be animated.
isRunning | Indicates whether the animation is currently running.
raiseEvent | Raises an event.
removeEventListener | Removes a single event listener attached to the Animation.
setAnimationType | Sets the type of the animation.
setDuration | Sets the duration of the animation function in milliseconds.
setEasingType | Sets the easing type of the animation.
setFromValue | Sets the initial value of the property that will be animated.
setParam | Sets the optional parameter to use in the animation function.
setRepeat | Sets a value indicating whether to restart the animation after it completes.
setReverse | Sets a value indicating whether to swap the from and to values after the animation completes.
setToValue | Sets the target value of the property that will be animated.
start | Starts or resumes the animation.
stop | Stops the animation.

See Also

Animation Class
MindFusion.Animations Namespace


MindFusion.Animations.Animation Constructor

Animation Constructor
See Also
[image]

Initializes a new instance of the Animation class.

Namespace: MindFusion.Animations
Assembly: Animation.js

Syntax

JavaScript [image] Copy Code

function Animation (item, [options, [onUpdateCallback, [onCustomFunctionCallback]]])

Parameters

item

The diagram item to animate.

options
Optional.

An object used to specify various property values for the animation.

onUpdateCallback
Optional.

A callback function called on every animation tick.

onCustomFunctionCallback
Optional.

A callback function called when the animation type is set to Custom.

See Also

Animation Class
Animations
MindFusion.Animations Namespace


MindFusion.Animations.Animation Methods

Animation Methods
[image]

Public Methods

Name | Description
addEventListener | Registers a single event listener on the Animation.
dispose | Sys.IDisposable implementation.
getAnimationType | Gets the type of the animation.
getDuration | Gets the duration of the animation function in milliseconds.
getEasingType | Gets the easing type of the animation.
getFromValue | Gets the initial value of the property that will be animated.
getParam | Gets the optional parameter to use in the animation function.
getProgress | Gets the progress of the current animation iteration.
getRepeat | Gets a value indicating whether to restart the animation after it completes.
getReverse | Gets a value indicating whether to swap the from and to values after the animation completes.
getToValue | Gets the target value of the property that will be animated.
isRunning | Indicates whether the animation is currently running.
raiseEvent | Raises an event.
removeEventListener | Removes a single event listener attached to the Animation.
setAnimationType | Sets the type of the animation.
setDuration | Sets the duration of the animation function in milliseconds.
setEasingType | Sets the easing type of the animation.
setFromValue | Sets the initial value of the property that will be animated.
setParam | Sets the optional parameter to use in the animation function.
setRepeat | Sets a value indicating whether to restart the animation after it completes.
setReverse | Sets a value indicating whether to swap the from and to values after the animation completes.
setToValue | Sets the target value of the property that will be animated.
start | Starts or resumes the animation.
stop | Stops the animation.

See Also

Animation Class
MindFusion.Animations Namespace


MindFusion.Animations.Animation.addEventListener Method

Animation.addEventListener Method
[image]

Registers a single event listener on the Animation.

Namespace: MindFusion.Animations
Assembly: Animation.js

Syntax

JavaScript [image] Copy Code

function addEventListener (eventName, handler)

Parameters

eventName

The name of the event.

handler

Represents the method that will handle the event specified with eventName.

See Also

Animation Members
Animation Class
MindFusion.Animations Namespace


MindFusion.Animations.Animation.dispose Method

Animation.dispose Method
[image]

Sys.IDisposable implementation.

Namespace: MindFusion.Animations
Assembly: Animation.js

Syntax

JavaScript [image] Copy Code

function dispose ()

See Also

Animation Members
Animation Class
MindFusion.Animations Namespace


MindFusion.Animations.Animation.getAnimationType Method

Animation.getAnimationType Method
[image]

Gets the type of the animation.

Namespace: MindFusion.Animations
Assembly: Animation.js

Syntax

JavaScript [image] Copy Code

function getAnimationType ()

Return Value

The animation type.

See Also

Animation Members
Animation Class
MindFusion.Animations Namespace


MindFusion.Animations.Animation.getDuration Method

Animation.getDuration Method
[image]

Gets the duration of the animation function in milliseconds.

Namespace: MindFusion.Animations
Assembly: Animation.js

Syntax

JavaScript [image] Copy Code

function getDuration ()

Return Value

The duration of the animation.

See Also

Animation Members
Animation Class
MindFusion.Animations Namespace


MindFusion.Animations.Animation.getEasingType Method

Animation.getEasingType Method
[image]

Gets the easing type of the animation.

Namespace: MindFusion.Animations
Assembly: Animation.js

Syntax

JavaScript [image] Copy Code

function getEasingType ()

Return Value

The easing type.

See Also

Animation Members
Animation Class
MindFusion.Animations Namespace


MindFusion.Animations.Animation.getFromValue Method

Animation.getFromValue Method
[image]

Gets the initial value of the property that will be animated.

Namespace: MindFusion.Animations
Assembly: Animation.js

Syntax

JavaScript [image] Copy Code

function getFromValue ()

Return Value

The initial value.

See Also

Animation Members
Animation Class
MindFusion.Animations Namespace


MindFusion.Animations.Animation.getParam Method

Animation.getParam Method
[image]

Gets the optional parameter to use in the animation function.

Namespace: MindFusion.Animations
Assembly: Animation.js

Syntax

JavaScript [image] Copy Code

function getParam ()

Return Value

The optional parameter.

See Also

Animation Members
Animation Class
MindFusion.Animations Namespace


MindFusion.Animations.Animation.getProgress Method

Animation.getProgress Method
[image]

Gets the progress of the current animation iteration.

Namespace: MindFusion.Animations
Assembly: Animation.js

Syntax

JavaScript [image] Copy Code

function getProgress ()

See Also

Animation Members
Animation Class
MindFusion.Animations Namespace


MindFusion.Animations.Animation.getRepeat Method

Animation.getRepeat Method
[image]

Gets a value indicating whether to restart the animation after it completes.

Namespace: MindFusion.Animations
Assembly: Animation.js

Syntax

JavaScript [image] Copy Code

function getRepeat ()

Return Value

True to loop the animation, otherwise false.

See Also

Animation Members
Animation Class
MindFusion.Animations Namespace


MindFusion.Animations.Animation.getReverse Method

Animation.getReverse Method
[image]

Gets a value indicating whether to swap the from and to values after the animation completes.

Namespace: MindFusion.Animations
Assembly: Animation.js

Syntax

JavaScript [image] Copy Code

function getReverse ()

Return Value

True to swap the values, otherwise false.

See Also

Animation Members
Animation Class
MindFusion.Animations Namespace


MindFusion.Animations.Animation.getToValue Method

Animation.getToValue Method
[image]

Gets the target value of the property that will be animated.

Namespace: MindFusion.Animations
Assembly: Animation.js

Syntax

JavaScript [image] Copy Code

function getToValue ()

Return Value

The target value.

See Also

Animation Members
Animation Class
MindFusion.Animations Namespace


MindFusion.Animations.Animation.isRunning Method

Animation.isRunning Method
[image]

Indicates whether the animation is currently running.

Namespace: MindFusion.Animations
Assembly: Animation.js

Syntax

JavaScript [image] Copy Code

function isRunning ()

See Also

Animation Members
Animation Class
MindFusion.Animations Namespace


MindFusion.Animations.Animation.raiseEvent Method

Animation.raiseEvent Method
[image]

Raises an event.

Namespace: MindFusion.Animations
Assembly: Animation.js

Syntax

JavaScript [image] Copy Code

function raiseEvent (eventName, args)

Parameters

eventName

The name of the event to raise.

args

An instance of type EventArgs that holds data for the event specified with eventName.

See Also

Animation Members
Animation Class
MindFusion.Animations Namespace


MindFusion.Animations.Animation.removeEventListener Method

Animation.removeEventListener Method
[image]

Removes a single event listener attached to the Animation.

Namespace: MindFusion.Animations
Assembly: Animation.js

Syntax

JavaScript [image] Copy Code

function removeEventListener (eventName, handler)

Parameters

eventName

The name of the event.

handler

Represents the method that handles the event specified with eventName.

See Also

Animation Members
Animation Class
MindFusion.Animations Namespace


MindFusion.Animations.Animation.setAnimationType Method

Animation.setAnimationType Method
[image]

Sets the type of the animation.

Namespace: MindFusion.Animations
Assembly: Animation.js

Syntax

JavaScript [image] Copy Code

function setAnimationType (value)

Parameters

value

The animation type. The default value is AnimationType.Linear.

See Also

Animation Members
Animation Class
MindFusion.Animations Namespace


MindFusion.Animations.Animation.setDuration Method

Animation.setDuration Method
[image]

Sets the duration of the animation function in milliseconds.

Namespace: MindFusion.Animations
Assembly: Animation.js

Syntax

JavaScript [image] Copy Code

function setDuration (value)

Parameters

value

The duration of the animation. The default value is 1000.

See Also

Animation Members
Animation Class
MindFusion.Animations Namespace


MindFusion.Animations.Animation.setEasingType Method

Animation.setEasingType Method
[image]

Sets the easing type of the animation.

Namespace: MindFusion.Animations
Assembly: Animation.js

Syntax

JavaScript [image] Copy Code

function setEasingType (value)

Parameters

value

The easing type. The default value is EasingType.EaseIn.

See Also

Animation Members
Animation Class
MindFusion.Animations Namespace


MindFusion.Animations.Animation.setFromValue Method

Animation.setFromValue Method
[image]

Sets the initial value of the property that will be animated.

Namespace: MindFusion.Animations
Assembly: Animation.js

Syntax

JavaScript [image] Copy Code

function setFromValue (value)

Parameters

value

The initial value.

See Also

Animation Members
Animation Class
MindFusion.Animations Namespace


MindFusion.Animations.Animation.setParam Method

Animation.setParam Method
[image]

Sets the optional parameter to use in the animation function.

Namespace: MindFusion.Animations
Assembly: Animation.js

Syntax

JavaScript [image] Copy Code

function setParam (value)

Parameters

value

The optional parameter. The default value is null.

See Also

Animation Members
Animation Class
MindFusion.Animations Namespace


MindFusion.Animations.Animation.setRepeat Method

Animation.setRepeat Method
[image]

Sets a value indicating whether to restart the animation after it completes.

Namespace: MindFusion.Animations
Assembly: Animation.js

Syntax

JavaScript [image] Copy Code

function setRepeat (value)

Parameters

value

True to loop the animation, otherwise false. The default value is false.

See Also

Animation Members
Animation Class
MindFusion.Animations Namespace


MindFusion.Animations.Animation.setReverse Method

Animation.setReverse Method
[image]

Sets a value indicating whether to swap the from and to values after the animation completes.

Namespace: MindFusion.Animations
Assembly: Animation.js

Syntax

JavaScript [image] Copy Code

function setReverse (value)

Parameters

value

True to swap the values, otherwise false. The default value is false.

See Also

Animation Members
Animation Class
MindFusion.Animations Namespace


MindFusion.Animations.Animation.setToValue Method

Animation.setToValue Method
[image]

Sets the target value of the property that will be animated.

Namespace: MindFusion.Animations
Assembly: Animation.js

Syntax

JavaScript [image] Copy Code

function setToValue (The)

Parameters

The

target value.

See Also

Animation Members
Animation Class
MindFusion.Animations Namespace


MindFusion.Animations.Animation.start Method

Animation.start Method
[image]

Starts or resumes the animation.

Namespace: MindFusion.Animations
Assembly: Animation.js

Syntax

JavaScript [image] Copy Code

function start ()

See Also

Animation Members
Animation Class
MindFusion.Animations Namespace


MindFusion.Animations.Animation.stop Method

Animation.stop Method
[image]

Stops the animation.

Namespace: MindFusion.Animations
Assembly: Animation.js

Syntax

JavaScript [image] Copy Code

function stop ()

See Also

Animation Members
Animation Class
MindFusion.Animations Namespace


MindFusion.Animations.AnimationType Enumeration

AnimationType Enumeration
[image]

Specifies the animation function used by an Animation object.

Namespace: MindFusion.Animations
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
AnimationType = {}

Members

Member name | Description
BackBow | Represents an effect that simulates a retraction in the motion of the animation. The amplitude of the retraction can be controlled through the Animation's param property. The default param value is 1.5;
Bounce | Represents a bouncing effect animation.
Circular | Represents an animation that accelerates/deccelerates using a circular function.
Custom | Specifies a user-set function. When this value is used the actual animation function must be set through the Animation's custom function callback.
Elastic | Represents an oscillating effect animation. The oscillation frequency can be controlled through the Animation's param property. The default param value is 0.5;
Exponential | Represents an animation that accelerates/deccelerates using an exponential function. The exponent can be set through the Animation's param property. The default exponent equals 10.
Linear | Represents an animation that accelerates/deccelerates using a linear function.
Power | Represents an animation that accelerates/deccelerates through exponentiation formula - x^n where n can be set through the Animation's param property. The default exponent equals 2.

See Also

MindFusion.Animations Namespace


MindFusion.Animations.EasingType Enumeration

EasingType Enumeration
[image]

Specifies the easing applied to an animation.

Namespace: MindFusion.Animations
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
EasingType = {}

Members

Member name | Description
EaseIn | Follows the animation function associated with the Animation.
EaseInOut | Uses EaseIn for the first half the the Animation's duration and EaseOut for the second half.
EaseOut | Inverses the animation function associated with the Animation.
EaseOutIn | Uses EaseOut for the first half the the Animation's duration and EaseIn for the second half.

See Also

MindFusion.Animations Namespace


MindFusion.Animations.Events Class

Events Class
[image]

Defines all events raised in the Animations namespace.

Namespace: MindFusion.Animations
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

// class
Events.prototype = {}

Inheritance Hierarchy

See Also

Events Members
MindFusion.Animations Namespace


MindFusion.Animations.Events Members

Events Members
Fields
[image]

Defines all events raised in the Animations namespace.

The following tables list the members exposed by the Events type.

Public Fields

Name | Description
animationComplete | Raised when an Animation is complete.

See Also

Events Class
MindFusion.Animations Namespace


MindFusion.Animations.Events Fields

Events Fields
[image]

Public Fields

Name | Description
animationComplete | Raised when an Animation is complete.

See Also

Events Class
MindFusion.Animations Namespace


MindFusion.Animations.Events.animationComplete Field

Events.animationComplete Field
[image]

Raised when an Animation is complete.

Namespace: MindFusion.Animations
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var animationComplete

See Also

Events Members
Events Class
MindFusion.Animations Namespace


MindFusion.Collections Namespace

MindFusion.Collections Namespace
Classes

Classes

Class | Description
ArrayList | Represents an array of arbitrary objects.
Dictionary | Represents a collection of keys and values.
Grid | Represents a collection of tabular data.
ItemEventArgs | Contains the arguments passed to event handlers of the ObservableCollection class.
ObservableCollection | Represents a collection that provides notifications when items get added or removed.
Queue | Represents a first-in, first-out collection of objects.
Set | Represents a collection of unique elements with no particular ordering.


MindFusion.Collections.ArrayList Class

ArrayList Class
[image]

Represents an array of arbitrary objects.

Namespace: MindFusion.Collections
Assembly: ArrayList.js

Syntax

JavaScript [image] Copy Code

// class
ArrayList.prototype = {}

Inheritance Hierarchy

See Also

ArrayList Members
MindFusion.Collections Namespace


MindFusion.Collections.ArrayList Members

ArrayList Members
Constructors
[image]

Represents an array of arbitrary objects.

The following tables list the members exposed by the ArrayList type.

Public Constructors

Name | Description
ArrayList | Initializes a new instance of the ArrayList class.

See Also

ArrayList Class
MindFusion.Collections Namespace


MindFusion.Collections.ArrayList Constructor

ArrayList Constructor
[image]

Initializes a new instance of the ArrayList class.

Namespace: MindFusion.Collections
Assembly: ArrayList.js

Syntax

JavaScript [image] Copy Code

function ArrayList ()

See Also

ArrayList Class
MindFusion.Collections Namespace


MindFusion.Collections.Dictionary Class

Dictionary Class
[image]

Represents a collection of keys and values.

Namespace: MindFusion.Collections
Assembly: Dictionary.js

Syntax

JavaScript [image] Copy Code

// class
Dictionary.prototype = {}

Inheritance Hierarchy

See Also

Dictionary Members
MindFusion.Collections Namespace


MindFusion.Collections.Dictionary Members

Dictionary Members
Constructors Methods
[image]

Represents a collection of keys and values.

The following tables list the members exposed by the Dictionary type.

Public Constructors

Name | Description
Dictionary | Initializes a new instance of the Dictionary class.

Public Methods

Name | Description
contains | Determines whether the dictionary contains a specific key.
forEach | Calls a defined callback function for each entry in the dictionary.
forEachKey | Calls a defined callback function for each key in the dictionary.
forEachValue | Calls a defined callback function for each value in the dictionary.
get | Gets the value associated with the specified key within the dictionary.
keys | Gets an array with all keys in the dictionary.
remove | Removes the element with the specified key from the dictionary.
set | Associates the specified value with the specified key within the dictionary.

See Also

Dictionary Class
MindFusion.Collections Namespace


MindFusion.Collections.Dictionary Constructor

Dictionary Constructor
[image]

Initializes a new instance of the Dictionary class.

Namespace: MindFusion.Collections
Assembly: Dictionary.js

Syntax

JavaScript [image] Copy Code

function Dictionary ()

See Also

Dictionary Class
MindFusion.Collections Namespace


MindFusion.Collections.Dictionary Methods

Dictionary Methods
[image]

Public Methods

Name | Description
contains | Determines whether the dictionary contains a specific key.
forEach | Calls a defined callback function for each entry in the dictionary.
forEachKey | Calls a defined callback function for each key in the dictionary.
forEachValue | Calls a defined callback function for each value in the dictionary.
get | Gets the value associated with the specified key within the dictionary.
keys | Gets an array with all keys in the dictionary.
remove | Removes the element with the specified key from the dictionary.
set | Associates the specified value with the specified key within the dictionary.

See Also

Dictionary Class
MindFusion.Collections Namespace


MindFusion.Collections.Dictionary.contains Method

Dictionary.contains Method
[image]

Determines whether the dictionary contains a specific key.

Namespace: MindFusion.Collections
Assembly: Dictionary.js

Syntax

JavaScript [image] Copy Code

function contains (key)

Parameters

key

The key to locate in the dictionary.

Return Value

true if the dictionary contains an element with the specified key; otherwise, false.

See Also

Dictionary Members
Dictionary Class
MindFusion.Collections Namespace


MindFusion.Collections.Dictionary.forEach Method

Dictionary.forEach Method
[image]

Calls a defined callback function for each entry in the dictionary.

Namespace: MindFusion.Collections
Assembly: Dictionary.js

Syntax

JavaScript [image] Copy Code

function forEach (func, [thisRef])

Parameters

func
A function that accepts three arguments. forEach calls this function one time for each element in the dictionary.
thisRef
Optional. A value passed as the first parameter of func.

See Also

Dictionary Members
Dictionary Class
MindFusion.Collections Namespace


MindFusion.Collections.Dictionary.forEachKey Method

Dictionary.forEachKey Method
[image]

Calls a defined callback function for each key in the dictionary.

Namespace: MindFusion.Collections
Assembly: Dictionary.js

Syntax

JavaScript [image] Copy Code

function forEachKey (func, [thisRef])

Parameters

func
A function that accepts two arguments. forEachKey calls this function one time for each key in the dictionary.
thisRef
Optional. A value passed as the first parameter of func.

See Also

Dictionary Members
Dictionary Class
MindFusion.Collections Namespace


MindFusion.Collections.Dictionary.forEachValue Method

Dictionary.forEachValue Method
[image]

Calls a defined callback function for each value in the dictionary.

Namespace: MindFusion.Collections
Assembly: Dictionary.js

Syntax

JavaScript [image] Copy Code

function forEachValue (func, [thisRef])

Parameters

func
A function that accepts two arguments. forEachValue calls this function one time for each value in the dictionary.
thisRef
Optional. A value passed as the first parameter of func.

See Also

Dictionary Members
Dictionary Class
MindFusion.Collections Namespace


MindFusion.Collections.Dictionary.get Method

Dictionary.get Method
[image]

Gets the value associated with the specified key within the dictionary.

Namespace: MindFusion.Collections
Assembly: Dictionary.js

Syntax

JavaScript [image] Copy Code

function get (key)

Parameters

key

The key whose value to get.

Return Value

The value associated with the specified key.

Remarks

An exception is thrown if the specified key is not present in the dictionary.

See Also

Dictionary Members
Dictionary Class
MindFusion.Collections Namespace


MindFusion.Collections.Dictionary.keys Method

Dictionary.keys Method
[image]

Gets an array with all keys in the dictionary.

Namespace: MindFusion.Collections
Assembly: Dictionary.js

Syntax

JavaScript [image] Copy Code

function keys ()

Return Value

An array containing all keys in the dictionary.

See Also

Dictionary Members
Dictionary Class
MindFusion.Collections Namespace


MindFusion.Collections.Dictionary.remove Method

Dictionary.remove Method
[image]

Removes the element with the specified key from the dictionary.

Namespace: MindFusion.Collections
Assembly: Dictionary.js

Syntax

JavaScript [image] Copy Code

function remove (key)

Parameters

key

The key of the element to remove.

Return Value

The value corresponding to the specified key or null, if the key is not found.

See Also

Dictionary Members
Dictionary Class
MindFusion.Collections Namespace


MindFusion.Collections.Dictionary.set Method

Dictionary.set Method
[image]

Associates the specified value with the specified key within the dictionary.

Namespace: MindFusion.Collections
Assembly: Dictionary.js

Syntax

JavaScript [image] Copy Code

function set (key, value)

Parameters

key

The key to associate the value with.

value

The value to associate.

See Also

Dictionary Members
Dictionary Class
MindFusion.Collections Namespace


MindFusion.Collections.Grid Class

Grid Class
[image]

Represents a collection of tabular data.

Namespace: MindFusion.Collections
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

// class
Grid.prototype = {}

Inheritance Hierarchy

See Also

Grid Members
MindFusion.Collections Namespace


MindFusion.Collections.Grid Members

Grid Members
Constructors
[image]

Represents a collection of tabular data.

The following tables list the members exposed by the Grid type.

Public Constructors

Name | Description
Grid | Initializes a new instance of the Grid class.

See Also

Grid Class
MindFusion.Collections Namespace


MindFusion.Collections.Grid Constructor

Grid Constructor
[image]

Initializes a new instance of the Grid class.

Namespace: MindFusion.Collections
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function Grid ()

See Also

Grid Class
MindFusion.Collections Namespace


MindFusion.Collections.ItemEventArgs Class

ItemEventArgs Class
[image]

Contains the arguments passed to event handlers of the ObservableCollection class.

Namespace: MindFusion.Collections
Assembly: ItemEventArgs.js

Syntax

JavaScript [image] Copy Code

// class
ItemEventArgs.prototype = {}

Inheritance Hierarchy

See Also

ItemEventArgs Members
MindFusion.Collections Namespace


MindFusion.Collections.ItemEventArgs Members

ItemEventArgs Members
Constructors Methods
[image]

Contains the arguments passed to event handlers of the ObservableCollection class.

The following tables list the members exposed by the ItemEventArgs type.

Public Constructors

Name | Description
ItemEventArgs | Initializes a new instance of the ItemEventArgs class.

Public Methods

Name | Description
get_item | Gets the item related to the event.

See Also

ItemEventArgs Class
MindFusion.Collections Namespace


MindFusion.Collections.ItemEventArgs Constructor

ItemEventArgs Constructor
[image]

Initializes a new instance of the ItemEventArgs class.

Namespace: MindFusion.Collections
Assembly: ItemEventArgs.js

Syntax

JavaScript [image] Copy Code

function ItemEventArgs (item)

Parameters

item

The item related to the event.

See Also

ItemEventArgs Class
MindFusion.Collections Namespace


MindFusion.Collections.ItemEventArgs Methods

ItemEventArgs Methods
[image]

Public Methods

Name | Description
get_item | Gets the item related to the event.

See Also

ItemEventArgs Class
MindFusion.Collections Namespace


MindFusion.Collections.ItemEventArgs.get_item Method

ItemEventArgs.get_item Method
[image]

Gets the item related to the event.

Namespace: MindFusion.Collections
Assembly: ItemEventArgs.js

Syntax

JavaScript [image] Copy Code

function get_item ()

Return Value

See Also

ItemEventArgs Members
ItemEventArgs Class
MindFusion.Collections Namespace


MindFusion.Collections.ObservableCollection Class

ObservableCollection Class
[image]

Represents a collection that provides notifications when items get added or removed.

Namespace: MindFusion.Collections
Assembly: ObservableCollection.js

Syntax

JavaScript [image] Copy Code

// class
ObservableCollection.prototype = {}

Inheritance Hierarchy

See Also

ObservableCollection Members
MindFusion.Collections Namespace


MindFusion.Collections.ObservableCollection Members

ObservableCollection Members
Constructors Methods
[image]

Represents a collection that provides notifications when items get added or removed.

The following tables list the members exposed by the ObservableCollection type.

Public Constructors

Name | Description
ObservableCollection | Initializes a new instance of the ObservableCollection class.

Public Methods

Name | Description
add | Adds the specified element to the collection.
add_itemAdded | Registers the specified function as a handler for the itemAdded event.
remove_itemAdded | Unregisters the specified function as a handler for the itemAdded event.

See Also

ObservableCollection Class
MindFusion.Collections Namespace


MindFusion.Collections.ObservableCollection Constructor

ObservableCollection Constructor
[image]

Initializes a new instance of the ObservableCollection class.

Namespace: MindFusion.Collections
Assembly: ObservableCollection.js

Syntax

JavaScript [image] Copy Code

function ObservableCollection ()

See Also

ObservableCollection Class
MindFusion.Collections Namespace


MindFusion.Collections.ObservableCollection Methods

ObservableCollection Methods
[image]

Public Methods

Name | Description
add | Adds the specified element to the collection.
add_itemAdded | Registers the specified function as a handler for the itemAdded event.
remove_itemAdded | Unregisters the specified function as a handler for the itemAdded event.

See Also

ObservableCollection Class
MindFusion.Collections Namespace


MindFusion.Collections.ObservableCollection.add Method

ObservableCollection.add Method
[image]

Adds the specified element to the collection.

Namespace: MindFusion.Collections
Assembly: ObservableCollection.js

Syntax

JavaScript [image] Copy Code

function add (item)

Parameters

item

The element to add.

See Also

ObservableCollection Members
ObservableCollection Class
MindFusion.Collections Namespace


MindFusion.Collections.ObservableCollection.add_itemAdded Method

ObservableCollection.add_itemAdded Method
[image]

Registers the specified function as a handler for the itemAdded event.

Namespace: MindFusion.Collections
Assembly: ObservableCollection.js

Syntax

JavaScript [image] Copy Code

function add_itemAdded (handler)

Parameters

handler

The function to be invoked when items are added to the collection.

See Also

ObservableCollection Members
ObservableCollection Class
MindFusion.Collections Namespace


MindFusion.Collections.ObservableCollection.remove_itemAdded Method

ObservableCollection.remove_itemAdded Method
[image]

Unregisters the specified function as a handler for the itemAdded event.

Namespace: MindFusion.Collections
Assembly: ObservableCollection.js

Syntax

JavaScript [image] Copy Code

function remove_itemAdded (handler)

Parameters

handler

The function to unregister.

See Also

ObservableCollection Members
ObservableCollection Class
MindFusion.Collections Namespace


MindFusion.Collections.Queue Class

Queue Class
[image]

Represents a first-in, first-out collection of objects.

Namespace: MindFusion.Collections
Assembly: Queue.js

Syntax

JavaScript [image] Copy Code

// class
Queue.prototype = {}

Inheritance Hierarchy

See Also

Queue Members
MindFusion.Collections Namespace


MindFusion.Collections.Queue Members

Queue Members
Constructors Methods
[image]

Represents a first-in, first-out collection of objects.

The following tables list the members exposed by the Queue type.

Public Constructors

Name | Description
Queue | Initializes a new instance of the Queue class.

Public Methods

Name | Description
dequeue | Removes and returns the object at the beginning of the queue.
enqueue | Adds an object to the end of the queue.
getSize | Gets the number of elements in the queue.

See Also

Queue Class
MindFusion.Collections Namespace


MindFusion.Collections.Queue Constructor

Queue Constructor
[image]

Initializes a new instance of the Queue class.

Namespace: MindFusion.Collections
Assembly: Queue.js

Syntax

JavaScript [image] Copy Code

function Queue ()

See Also

Queue Class
MindFusion.Collections Namespace


MindFusion.Collections.Queue Methods

Queue Methods
[image]

Public Methods

Name | Description
dequeue | Removes and returns the object at the beginning of the queue.
enqueue | Adds an object to the end of the queue.
getSize | Gets the number of elements in the queue.

See Also

Queue Class
MindFusion.Collections Namespace


MindFusion.Collections.Queue.dequeue Method

Queue.dequeue Method
[image]

Removes and returns the object at the beginning of the queue.

Namespace: MindFusion.Collections
Assembly: Queue.js

Syntax

JavaScript [image] Copy Code

function dequeue ()

Return Value

The object that is removed from the beginning of the queue.

Remarks

If the queue is empty this method will throw an exception.

See Also

Queue Members
Queue Class
MindFusion.Collections Namespace


MindFusion.Collections.Queue.enqueue Method

Queue.enqueue Method
[image]

Adds an object to the end of the queue.

Namespace: MindFusion.Collections
Assembly: Queue.js

Syntax

JavaScript [image] Copy Code

function enqueue (value)

Parameters

value

The object to add.

See Also

Queue Members
Queue Class
MindFusion.Collections Namespace


MindFusion.Collections.Queue.getSize Method

Queue.getSize Method
[image]

Gets the number of elements in the queue.

Namespace: MindFusion.Collections
Assembly: Queue.js

Syntax

JavaScript [image] Copy Code

function getSize ()

Return Value

See Also

Queue Members
Queue Class
MindFusion.Collections Namespace


MindFusion.Collections.Set Class

Set Class
[image]

Represents a collection of unique elements with no particular ordering.

Namespace: MindFusion.Collections
Assembly: Set.js

Syntax

JavaScript [image] Copy Code

// class
Set.prototype = {}

Inheritance Hierarchy

See Also

Set Members
MindFusion.Collections Namespace


MindFusion.Collections.Set Members

Set Members
Constructors Methods
[image]

Represents a collection of unique elements with no particular ordering.

The following tables list the members exposed by the Set type.

Public Constructors

Name | Description
Set | Initializes a new instance of the Set class.

Public Methods

Name | Description
add | Adds the specified value to the set.
contains | Determines whether the set contains a specific value.
forEach | Calls a defined callback function for each entry in the set.
remove | Removes the specified element from the set.

See Also

Set Class
MindFusion.Collections Namespace


MindFusion.Collections.Set Constructor

Set Constructor
[image]

Initializes a new instance of the Set class.

Namespace: MindFusion.Collections
Assembly: Set.js

Syntax

JavaScript [image] Copy Code

function Set ()

See Also

Set Class
MindFusion.Collections Namespace


MindFusion.Collections.Set Methods

Set Methods
[image]

Public Methods

Name | Description
add | Adds the specified value to the set.
contains | Determines whether the set contains a specific value.
forEach | Calls a defined callback function for each entry in the set.
remove | Removes the specified element from the set.

See Also

Set Class
MindFusion.Collections Namespace


MindFusion.Collections.Set.add Method

Set.add Method
[image]

Adds the specified value to the set.

Namespace: MindFusion.Collections
Assembly: Set.js

Syntax

JavaScript [image] Copy Code

function add (key)

Parameters

key

The element to add to the set.

See Also

Set Members
Set Class
MindFusion.Collections Namespace


MindFusion.Collections.Set.contains Method

Set.contains Method
[image]

Determines whether the set contains a specific value.

Namespace: MindFusion.Collections
Assembly: Set.js

Syntax

JavaScript [image] Copy Code

function contains (key)

Parameters

key

The element to locate in the set.

Return Value

true if the set contains the specified element; otherwise, false.

See Also

Set Members
Set Class
MindFusion.Collections Namespace


MindFusion.Collections.Set.forEach Method

Set.forEach Method
[image]

Calls a defined callback function for each entry in the set.

Namespace: MindFusion.Collections
Assembly: Set.js

Syntax

JavaScript [image] Copy Code

function forEach (func, [thisRef])

Parameters

func
A function that accepts two arguments. forEach calls this function one time for each element in the set.
thisRef
Optional. A value passed as the first parameter of func.

See Also

Set Members
Set Class
MindFusion.Collections Namespace


MindFusion.Collections.Set.remove Method

Set.remove Method
[image]

Removes the specified element from the set.

Namespace: MindFusion.Collections
Assembly: Set.js

Syntax

JavaScript [image] Copy Code

function remove (key)

Parameters

key

The element to remove.

See Also

Set Members
Set Class
MindFusion.Collections Namespace


MindFusion.Controls Namespace

MindFusion.Controls Namespace
Classes Enumerations

Classes

Class | Description
ZoomControl | The ZoomControl lets users zoom and pan a target view control interactively.

Enumerations

Enumeration | Description
TickPosition | Specifies the position of trackbar ticks.


MindFusion.Controls.TickPosition Enumeration

TickPosition Enumeration
[image]

Specifies the position of trackbar ticks.

Namespace: MindFusion.Controls
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
TickPosition = {}

Members

Member name | Description
Both | Ticks are rendered on both sides of the trackbar.
Left | Ticks are rendered on the left side of the trackbar.
None | There are no ticks rendered.
Right | Ticks are rendered on the right side of the trackbar.

See Also

MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl Class

ZoomControl Class
[image]

The ZoomControl lets users zoom and pan a target view control interactively.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

// class
ZoomControl.prototype = {}

Inheritance Hierarchy

See Also

ZoomControl Members
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl Members

ZoomControl Members
Constructors Methods
[image]

The ZoomControl lets users zoom and pan a target view control interactively.

The following tables list the members exposed by the ZoomControl type.

Public Constructors

Name | Description
ZoomControl | Creates an instance of ZoomControl.

Public Methods

Name | Description
create | Creates and initializes a new ZoomControl from the specified element. This method is static and can be called without creating an instance of the class.
find | Returns the specified ZoomControl object. This member is static and can be invoked without creating an instance of the class.
getActiveColor | Gets the color used to render depressed buttons.
getBackColor | Gets the background color of the control.
getBorderColor | Gets the color of ZoomControl elements' borders.
getCornerRadius | Gets the corner radius of rounded child elements.
getEnabled | Checks if mouse events are enabled.
getFill | Gets the color used to fill the ZoomControl elements.
getInnerColor | Gets the color of plus, minus and arrow icons.
getMaxZoomFactor | Gets the maximum zoom level allowed to set through this control.
getMinZoomFactor | Gets the minimum zoom level allowed to set through this control.
getPadding | Gets the padding of the control's contents.
getScrollStep | Gets the scroll offset added when users click the pan arrows.
getShadowColor | Gets the color of the control elements' shadow.
getShowLabel | Gets a value indicating whether the label that shows the current zoom level should be visible.
getSnapToZoomStep | Gets a value indicating whether the trackbar should snap to ZoomStep values when dragged.
getTextColor | Gets the color of the the label that shows the current zoom level.
getTickPosition | Gets the current tick position of the trackbar.
getZoomFactor | Gets the zoom factor.
getZoomStep | Gets the amount by which to change zoom level when + and - buttons are clicked.
registerForSubmit | Registers an onsubmit handler for the ZoomControl's parent html form to flush postback data.
setActiveColor | Sets the color used to render depressed buttons.
setBackColor | Sets the background color of the control.
setBorderColor | Sets the color of ZoomControl elements' borders.
setCornerRadius | Sets the corner radius of rounded child elements.
setEnabled | Enables or disables handling of mouse events.
setFill | Sets the color used to fill the ZoomControl elements.
setInnerColor | Sets the color of plus, minus and arrow icons.
setMaxZoomFactor | Sets the maximum zoom level allowed to set through this control.
setMinZoomFactor | Sets the minimum zoom level allowed to set through this control.
setPadding | Sets the padding of the control's contents.
setScrollStep | Sets the scroll offset added when users click the pan arrows.
setShadowColor | Sets the color of the control elements' shadow.
setShowLabel | Sets a value indicating whether the label that shows the current zoom level should be visible.
setSnapToZoomStep | Sets a value indicating whether the trackbar should snap to ZoomStep values when dragged.
setTarget | Sets the control modified by this ZoomControl.
setTextColor | Sets the color of the the label that shows the current zoom level.
setTickPosition | Sets the current tick position of the trackbar.
setZoomFactor | Sets the zoom factor.
setZoomStep | Sets the amount by which to change zoom level when + and - buttons are clicked.

See Also

ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl Constructor

ZoomControl Constructor
[image]

Creates an instance of ZoomControl.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function ZoomControl (element)

Parameters

element

Type: Canvas
The Canvas DOM Element this ZoomControl is associated with.

See Also

ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl Methods

ZoomControl Methods
[image]

Public Methods

Name | Description
create | Creates and initializes a new ZoomControl from the specified element. This method is static and can be called without creating an instance of the class.
find | Returns the specified ZoomControl object. This member is static and can be invoked without creating an instance of the class.
getActiveColor | Gets the color used to render depressed buttons.
getBackColor | Gets the background color of the control.
getBorderColor | Gets the color of ZoomControl elements' borders.
getCornerRadius | Gets the corner radius of rounded child elements.
getEnabled | Checks if mouse events are enabled.
getFill | Gets the color used to fill the ZoomControl elements.
getInnerColor | Gets the color of plus, minus and arrow icons.
getMaxZoomFactor | Gets the maximum zoom level allowed to set through this control.
getMinZoomFactor | Gets the minimum zoom level allowed to set through this control.
getPadding | Gets the padding of the control's contents.
getScrollStep | Gets the scroll offset added when users click the pan arrows.
getShadowColor | Gets the color of the control elements' shadow.
getShowLabel | Gets a value indicating whether the label that shows the current zoom level should be visible.
getSnapToZoomStep | Gets a value indicating whether the trackbar should snap to ZoomStep values when dragged.
getTextColor | Gets the color of the the label that shows the current zoom level.
getTickPosition | Gets the current tick position of the trackbar.
getZoomFactor | Gets the zoom factor.
getZoomStep | Gets the amount by which to change zoom level when + and - buttons are clicked.
registerForSubmit | Registers an onsubmit handler for the ZoomControl's parent html form to flush postback data.
setActiveColor | Sets the color used to render depressed buttons.
setBackColor | Sets the background color of the control.
setBorderColor | Sets the color of ZoomControl elements' borders.
setCornerRadius | Sets the corner radius of rounded child elements.
setEnabled | Enables or disables handling of mouse events.
setFill | Sets the color used to fill the ZoomControl elements.
setInnerColor | Sets the color of plus, minus and arrow icons.
setMaxZoomFactor | Sets the maximum zoom level allowed to set through this control.
setMinZoomFactor | Sets the minimum zoom level allowed to set through this control.
setPadding | Sets the padding of the control's contents.
setScrollStep | Sets the scroll offset added when users click the pan arrows.
setShadowColor | Sets the color of the control elements' shadow.
setShowLabel | Sets a value indicating whether the label that shows the current zoom level should be visible.
setSnapToZoomStep | Sets a value indicating whether the trackbar should snap to ZoomStep values when dragged.
setTarget | Sets the control modified by this ZoomControl.
setTextColor | Sets the color of the the label that shows the current zoom level.
setTickPosition | Sets the current tick position of the trackbar.
setZoomFactor | Sets the zoom factor.
setZoomStep | Sets the amount by which to change zoom level when + and - buttons are clicked.

See Also

ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.create Method

ZoomControl.create Method
[image]

Creates and initializes a new ZoomControl from the specified element. This method is static and can be called without creating an instance of the class.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function create (element)

Parameters

element

The DOM element that the ZoomControl should be attached to.

Return Value

A ZoomControl instance that represents the newly created zoom control.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.find Method

ZoomControl.find Method
[image]

Returns the specified ZoomControl object. This member is static and can be invoked without creating an instance of the class.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function find (id, [parent])

Parameters

id

A string that contains the ID of the zoomControl to find.

parent
Optional.

The component or element that contains the zoomControl to find.

Return Value

Type: ZoomControl
A ZoomControl object that contains the zoomControl requested by id, if found; otherwise, null.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.getActiveColor Method

ZoomControl.getActiveColor Method
[image]

Gets the color used to render depressed buttons.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function getActiveColor ()

Return Value

The color used to render depressed buttons.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.getBackColor Method

ZoomControl.getBackColor Method
[image]

Gets the background color of the control.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function getBackColor ()

Return Value

The color of the control background.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.getBorderColor Method

ZoomControl.getBorderColor Method
[image]

Gets the color of ZoomControl elements' borders.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function getBorderColor ()

Return Value

Type: String
The color of ZoomControl elements' borders.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.getCornerRadius Method

ZoomControl.getCornerRadius Method
[image]

Gets the corner radius of rounded child elements.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function getCornerRadius ()

Return Value

The corner radius of rounded child elements.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.getEnabled Method

ZoomControl.getEnabled Method
[image]

Checks if mouse events are enabled.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function getEnabled ()

Return Value

true if handling of mouse events is enabled; otherwise, false.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.getFill Method

ZoomControl.getFill Method
[image]

Gets the color used to fill the ZoomControl elements.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function getFill ()

Return Value

Type: String
The color used to fill the ZoomControl elements.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.getInnerColor Method

ZoomControl.getInnerColor Method
[image]

Gets the color of plus, minus and arrow icons.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function getInnerColor ()

Return Value

The color of plus, minus and arrow icons.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.getMaxZoomFactor Method

ZoomControl.getMaxZoomFactor Method
[image]

Gets the maximum zoom level allowed to set through this control.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function getMaxZoomFactor ()

Return Value

The maximum zoom level.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.getMinZoomFactor Method

ZoomControl.getMinZoomFactor Method
[image]

Gets the minimum zoom level allowed to set through this control.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function getMinZoomFactor ()

Return Value

The minimum zoom level.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.getPadding Method

ZoomControl.getPadding Method
[image]

Gets the padding of the control's contents.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function getPadding ()

Return Value

The padding of the control's contents.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.getScrollStep Method

ZoomControl.getScrollStep Method
[image]

Gets the scroll offset added when users click the pan arrows.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function getScrollStep ()

Return Value

The scroll step.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.getShadowColor Method

ZoomControl.getShadowColor Method
[image]

Gets the color of the control elements' shadow.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function getShadowColor ()

Return Value

The color of the control elements' shadow.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.getShowLabel Method

ZoomControl.getShowLabel Method
[image]

Gets a value indicating whether the label that shows the current zoom level should be visible.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function getShowLabel ()

Return Value

True if the label is visible, otherwise false.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.getSnapToZoomStep Method

ZoomControl.getSnapToZoomStep Method
[image]

Gets a value indicating whether the trackbar should snap to ZoomStep values when dragged.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function getSnapToZoomStep ()

Return Value

True if snapping is enabled, otherwise false.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.getTextColor Method

ZoomControl.getTextColor Method
[image]

Gets the color of the the label that shows the current zoom level.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function getTextColor ()

Return Value

The color of the the label that shows the current zoom level.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.getTickPosition Method

ZoomControl.getTickPosition Method
[image]

Gets the current tick position of the trackbar.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function getTickPosition ()

Return Value

Type: TickPosition
One of the TickPosition enumeration values.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.getZoomFactor Method

ZoomControl.getZoomFactor Method
[image]

Gets the zoom factor.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function getZoomFactor ()

Return Value

The current zoom factor.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.getZoomStep Method

ZoomControl.getZoomStep Method
[image]

Gets the amount by which to change zoom level when + and - buttons are clicked.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function getZoomStep ()

Return Value

The zoom step.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.registerForSubmit Method

ZoomControl.registerForSubmit Method
[image]

Registers an onsubmit handler for the ZoomControl's parent html form to flush postback data.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function registerForSubmit (id)

Parameters

id

The id of the hidden field to flush the data to.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.setActiveColor Method

ZoomControl.setActiveColor Method
[image]

Sets the color used to render depressed buttons.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function setActiveColor (value)

Parameters

value

The color used to render depressed buttons.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.setBackColor Method

ZoomControl.setBackColor Method
[image]

Sets the background color of the control.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function setBackColor (value)

Parameters

value

The color of the control background.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.setBorderColor Method

ZoomControl.setBorderColor Method
[image]

Sets the color of ZoomControl elements' borders.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function setBorderColor (value)

Parameters

value

Type: String
The color of ZoomControl elements' borders.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.setCornerRadius Method

ZoomControl.setCornerRadius Method
[image]

Sets the corner radius of rounded child elements.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function setCornerRadius (value)

Parameters

value

The corner radius of rounded child elements.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.setEnabled Method

ZoomControl.setEnabled Method
[image]

Enables or disables handling of mouse events.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function setEnabled (value)

Parameters

value

true if handling of mouse events is enabled; otherwise, false.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.setFill Method

ZoomControl.setFill Method
[image]

Sets the color used to fill the ZoomControl elements.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function setFill (value)

Parameters

value

Type: String
The color used to fill the ZoomControl elements.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.setInnerColor Method

ZoomControl.setInnerColor Method
[image]

Sets the color of plus, minus and arrow icons.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function setInnerColor (value)

Parameters

value

The color of plus, minus and arrow icons.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.setMaxZoomFactor Method

ZoomControl.setMaxZoomFactor Method
[image]

Sets the maximum zoom level allowed to set through this control.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function setMaxZoomFactor (value)

Parameters

value

The maximum zoom level.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.setMinZoomFactor Method

ZoomControl.setMinZoomFactor Method
[image]

Sets the minimum zoom level allowed to set through this control.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function setMinZoomFactor (value)

Parameters

value

The minimum zoom level.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.setPadding Method

ZoomControl.setPadding Method
[image]

Sets the padding of the control's contents.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function setPadding (value)

Parameters

value

The padding of the control's contents.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.setScrollStep Method

ZoomControl.setScrollStep Method
[image]

Sets the scroll offset added when users click the pan arrows.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function setScrollStep (value)

Parameters

value

The scroll step.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.setShadowColor Method

ZoomControl.setShadowColor Method
[image]

Sets the color of the control elements' shadow.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function setShadowColor (value)

Parameters

value

The color of the control elements' shadow.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.setShowLabel Method

ZoomControl.setShowLabel Method
[image]

Sets a value indicating whether the label that shows the current zoom level should be visible.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function setShowLabel (value)

Parameters

value

True if the label is visible, otherwise false.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.setSnapToZoomStep Method

ZoomControl.setSnapToZoomStep Method
[image]

Sets a value indicating whether the trackbar should snap to ZoomStep values when dragged.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function setSnapToZoomStep (value)

Parameters

value

True if snapping is enabled, otherwise false.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.setTarget Method

ZoomControl.setTarget Method
[image]

Sets the control modified by this ZoomControl.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function setTarget ([target])

Parameters

target
Optional.

Type: Control
The control modified by this ZoomControl.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.setTextColor Method

ZoomControl.setTextColor Method
[image]

Sets the color of the the label that shows the current zoom level.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function setTextColor (value)

Parameters

value

The color of the the label that shows the current zoom level.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.setTickPosition Method

ZoomControl.setTickPosition Method
[image]

Sets the current tick position of the trackbar.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function setTickPosition (value)

Parameters

value

Type: TickPosition
One of the TickPosition enumeration values.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.setZoomFactor Method

ZoomControl.setZoomFactor Method
[image]

Sets the zoom factor.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function setZoomFactor (value)

Parameters

value

The zoom factor.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Controls.ZoomControl.setZoomStep Method

ZoomControl.setZoomStep Method
[image]

Sets the amount by which to change zoom level when + and - buttons are clicked.

Namespace: MindFusion.Controls
Assembly: ZoomControl.js

Syntax

JavaScript [image] Copy Code

function setZoomStep (value)

Parameters

value

The zoom step.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Controls Namespace


MindFusion.Diagramming Namespace

MindFusion.Diagramming Namespace
Classes Enumerations

Classes

Class | Description
AddItemCommand | Implements creation of new diagram items.
AeroEffect | Represents an effect that adds semitransparency to the node and emphasizes its outline by adding a shade and an inner stroke.
AnchorPattern | The AnchorPattern class represents a set of anchor points, which specify the exact locations where links are allowed to connect to nodes.
AnchorPoint | The AnchorPoint class represents a location in a node to which links are allowed to connect.
BehaviorBase | An abstract base class for types that define how the control reacts to users' actions with a mouse or other pointing devices.
Cell | Represents a cell of a TableNode.
CellEventArgs | Contains the arguments passed to handlers of inplace edit related events.
ChangeItemCommand | Handles undo / redo of property changes.
Command | Represents an action that changes the diagram and whose effects can be undone.
CompositeCommand | Represents a set of Command instances as a single operation. Undoing or redoing the composite action, respectively undoes or redoes all its constituent subactions at the same time.
ConnectionPoint | A class that represents a connection between an edge and a node in a graph. It decouples the DiagramLink class from the DiagramNode class, allowing edges to connect different types of nodes without knowing anything of their implementation details. Each DiagramLink object contains two ConnectionPoint instances describing the connections at both ends of the link.
ContainerNode | ContainerNode instances are diagram nodes that can contain other nodes.
Diagram | The Diagram class represents a flow diagram.
DiagramEventArgs | Contains the arguments passed to handlers of global diagram events such as clicked.
DiagramItem | Represents an item in the diagram document. All classes representing diagram elements derive from DiagramItem.
DiagramLink | Represents a link between two diagram nodes.
DiagramNode | DiagramNode is an abstract base class from which specific types such as ShapeNode and TableNode derive. DiagramNode instances can represent graph vertices, nodes in organizational or flow diagrams, entities in ER diagrams, and so on.
DoNothingBehavior | Implements the DoNothing behavior.
DrawLinksBehavior | This class is used when the diagram behavior is set to Behavior.DrawLinks.
DrawNodesBehavior | The base class for behavior types that allow drawing of nodes, but not links.
DrawShapesBehavior | This class is used when the diagram behavior is set to Behavior.DrawShapes.
DummyNode | DummyNode represents virtual nodes set as targets of disconnected links.
Events | Defines all events raised by the Diagram component.
Factory | Provides shortcut methods for creating and adding instances of the standard item types.
FoldContainerCommand | Handles undo / redo of container folding.
GlassEffect | Represents a glass-like visual effect.
InplaceEditEventArgs | Contains the arguments passed to handlers of inplace edit related events.
Interaction | Encapsulates the current state of user interaction with the control.
InteractionState | Encapsulates the current state of user interaction with the control.
LinkEventArgs | Contains the arguments passed to handlers of link validation events.
LinkLabel | Represents a label displayed by a DiagramLink. New labels can be added to a link by calling its addLabel method.
LinkNodesBehavior | The base class for behavior types that allow drawing both nodes and links.
LinkShapesBehavior | This class is used when the diagram behavior is set to Behavior.LinkShapes.
MagnifyBehavior | This class is used when the diagram behavior is set to Behavior.Magnify.
Manipulator | Manipulator is an abstract base class which defines the behavior of miscellaneous UI widgets attached to nodes.
ModifierKeyActions | Maps keyboard modifier keys to special actions in MindFusion.Diagramming such as panning and drawing selection rectangle.
ModifyBehavior | This class is used when the diagram behavior is set to Behavior.Modify.
NodeEventArgs | Contains the arguments passed to handlers of node-related events.
NodeListView | ListBox control with support for hosting DiagramNodes and dragging them to the Diagram control. Items' labels can be set by assigning them to the Tag property of nodes.
Overview | The Overview control provides a scaled-down view of a Diagram contents and allows scrolling and zooming the diagram with the mouse.
PanBehavior | Pans the diagram when the users drags the mouse.
RemoveItemCommand | Implements deletion of diagram items.
ScrollTableCommand | Handles undo / redo of table scrolling.
Selection | Represents a set of items selected in the Diagram document.
SelectionEventArgs | Contains the arguments passed to handlers of selection-related events.
SelectOnlyBehavior | Allows only selection of existing items. Modifying them or drawing new ones is disabled.
SerializeTagEventArgs | Contains the arguments passed to the serializeTag and deserializeTag event handlers.
Shape | An instance of this class represents a shape defined through a series of arc, line and Bezier segments. The segments can be a part of the shape outline, in which case they define the part of the shape is filled, used for hit-testing and for aligning links to the node edges. Segments can also be added as decoration elements, in which case they only affect the appearance of a ShapeNode.
ShapeLibrary | The ShapeLibrary class represents a collection of shape definitionsstored together.
ShapeNode | ShapeNode instances are diagram nodes that represent geometric shapes.
Shapes | Provides alternative methods of access to the predefined shapes.
Style | Represents a set of appearance properties whose values can be inherited from parent objects if not set locally for an item.
SvgContent | SvgContent represents the markup code of an SVG drawing.
SvgNode | SvgNode instances are diagram nodes that can render SVG drawings.
TableConnectionPoint | A class that represents a connection between an edge and a node in a graph.
TableNode | TableNode instances are diagram nodes that can be used to display tabular or list data.
Theme | Represents a set of Style objects whose properties are used to render items of a specific type in the current diagram.
XmlPersistContext | Contains helper methods for serialization of diagram contents to and from XML documents.

Enumerations

Enumeration | Description
Action | Specifies the possible actions a user can carry out on diagram items.
AdjustmentHandles | Identifies the distinct selection handles of a node.
Alignment | Specifies the alignment of text relative to its layout rectangle.
AutoResize | Defines in which directions automatic resizing can enlarge the diagram scrollable area.
Behavior | Defines values that specify how the component responds to actions performed by the user.
CellFrameStyle | Specifies the style of the cells' frame lines.
ConnectionStyle | Specifies whether links should connect to a node or its rows.
DelKeyAction | Specifies the type of action performed when the user presses the DEL key.
EffectPhase | Specifies the rendering phase during which an effect application is requested.
FitSize | Specifies how the ResizeToFitText method should resize a node.
GlassEffectType | Specifies the type of a GlassEffect node effect.
GridStyle | Defines values that specify the visual style of the alignment grid.
HandlesStyle | Enumerates possible visual styles for frames and handles drawn around selected nodes.
ImageAlign | Specifies the position and alignment of a picture in a node, or that of the background image.
LinkCrossings | Defines values that indicate how to render link intersection points.
LinkShape | Specifies available styles for the segments of links.
LinkTextStyle | Specifies the position and alignment of links' labels.
MarkStyle | Specifies the visual style of anchor point marks.
ModificationStart | Specifies how the user can start modifying an item.
ModifierKeyAction | Defines the actions that can be assigned to a modifier key such as CTRL or ALT.
MouseButtonActions | Specifies what actions can be associated with the middle and right mouse buttons.
RelativeToLink | Specifies how the link labels are positioned.
ShadowsStyle | Enumerates possible shadows-drawing styles.
ShowAnchors | Specifies when anchors points should be displayed.
SimpleShape | Defines the possible values for Shape property of tables and containers.


MindFusion.Diagramming.Action Enumeration

Action Enumeration
[image]

Specifies the possible actions a user can carry out on diagram items.

Namespace: MindFusion.Diagramming
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
Action = {}

Members

Member name | Description
Create | Draw a new item.
Modify | Modify an existing item.
None | Do not perform any action.
Split | Split a link's segment.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.AddItemCommand Class

AddItemCommand Class
Remarks See Also
[image]

Implements creation of new diagram items.

Namespace: MindFusion.Diagramming
Assembly: AddItemCommand.js

Syntax

JavaScript [image] Copy Code

// class
AddItemCommand.prototype = {}

Remarks

The control automatically creates instances of this class when items are added either interactively or from code.

Inheritance Hierarchy

See Also

AddItemCommand Members
MindFusion.Diagramming Namespace
RemoveItemCommand Class
ChangeItemCommand Class


MindFusion.Diagramming.AddItemCommand Members

AddItemCommand Members
Constructors Methods
[image]

Implements creation of new diagram items.

The following tables list the members exposed by the AddItemCommand type.

Public Constructors

Name | Description
AddItemCommand | Initializes a new instance of the AddItemCommand class.

Public Methods

Name | Description
execute | Command.execute override.
redo | Command.redo override.
undo | Command.undo override.

See Also

AddItemCommand Class


MindFusion.Diagramming.AddItemCommand Constructor

AddItemCommand Constructor
[image]

Initializes a new instance of the AddItemCommand class.

Namespace: MindFusion.Diagramming
Assembly: AddItemCommand.js

Syntax

JavaScript [image] Copy Code

function AddItemCommand (diagram, item)

Parameters

diagram

The Diagram modified by this command.

item

A new DiagramItem that should be added to the Diagram.

See Also

AddItemCommand Class


MindFusion.Diagramming.AddItemCommand Methods

AddItemCommand Methods
[image]

Public Methods

Name | Description
execute | Command.execute override.
redo | Command.redo override.
undo | Command.undo override.

See Also

AddItemCommand Class


MindFusion.Diagramming.AddItemCommand.execute Method

AddItemCommand.execute Method
[image]

Command.execute override.

Namespace: MindFusion.Diagramming
Assembly: AddItemCommand.js

Syntax

JavaScript [image] Copy Code

function execute ()

See Also

AddItemCommand Members
AddItemCommand Class


MindFusion.Diagramming.AddItemCommand.redo Method

AddItemCommand.redo Method
[image]

Command.redo override.

Namespace: MindFusion.Diagramming
Assembly: AddItemCommand.js

Syntax

JavaScript [image] Copy Code

function redo ()

See Also

AddItemCommand Members
AddItemCommand Class


MindFusion.Diagramming.AddItemCommand.undo Method

AddItemCommand.undo Method
[image]

Command.undo override.

Namespace: MindFusion.Diagramming
Assembly: AddItemCommand.js

Syntax

JavaScript [image] Copy Code

function undo ()

See Also

AddItemCommand Members
AddItemCommand Class


MindFusion.Diagramming.AdjustmentHandles Enumeration

AdjustmentHandles Enumeration
[image]

Identifies the distinct selection handles of a node.

Namespace: MindFusion.Diagramming
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
AdjustmentHandles = {}

Members

Member name | Description
All | All selection handles are enabled and can be used to modify the node.
Move | The center selection handle is enabled and can be used to move the node.
None | Specifies that none of the selection handles can be used to modify the node.
ResizeBottomCenter | The bottom-center handle is enabled and can be used to resize the node vertically.
ResizeBottomLeft | The bottom-left handle is enabled and can be used to resize the node.
ResizeBottomRight | The bottom-right handle is enabled and can be used to resize the node.
ResizeMiddleLeft | The middle-left handle is enabled and can be used to resize the node horizontally.
ResizeMiddleRight | The middle-right handle is enabled and can be used to resize the node horizontally.
ResizeTopCenter | The top-center handle is enabled and can be used to resize the node vertically.
ResizeTopLeft | The top-left handle is enabled and can be used to resize the node.
ResizeTopRight | The top-right handle is enabled and can be used to resize the node.
Rotate | The rotation handle is enabled and can be used to rotate the node.

See Also


MindFusion.Diagramming.AeroEffect Class

AeroEffect Class
Remarks See Also
[image]

Represents an effect that adds semitransparency to the node and emphasizes its outline by adding a shade and an inner stroke.

Namespace: MindFusion.Diagramming
Assembly: NodeEffects.js

Syntax

JavaScript [image] Copy Code

// class
AeroEffect.prototype = {}

Remarks

This effect can be applied to the nodes in a Diagram by adding an instance of this class to the NodeEffects collection.

The following image illustrates the Aero effect applied to a rectangular node as well as how the different properties affect the output:

Example

The following example demonstrates how to apply aero effect to the nodes of an existing diagram.

JavaScript [image] Copy Code

var AeroEffect = MindFusion.Diagramming.AeroEffect;

var effect = new AeroEffect();
effect.setOpacity(0.5);
effect.setInnerOutlineColor("rgba(255,255,255,0.5)");
diagram.getNodeEffects().push(effect);

Inheritance Hierarchy

See Also

AeroEffect Members
MindFusion.Diagramming Namespace
Node Effects
GlassEffect Class


MindFusion.Diagramming.AeroEffect Members

AeroEffect Members
Constructors Methods
[image]

Represents an effect that adds semitransparency to the node and emphasizes its outline by adding a shade and an inner stroke.

The following tables list the members exposed by the AeroEffect type.

Public Constructors

Name | Description
AeroEffect | Initializes a new instance of the AeroEffect class.

Public Methods

Name | Description
getInnerOutlineColor | Gets the color of the inner outline.
getOpacity | Gets the opacity to apply to the node's background.
getShadeColor | Gets the color of the shade.
setInnerOutlineColor | Sets the color of the inner outline.
setOpacity | Sets the opacity to apply to the node's background.
setShadeColor | Sets the color of the shade.

See Also

AeroEffect Class


MindFusion.Diagramming.AeroEffect Constructor

AeroEffect Constructor
[image]

Initializes a new instance of the AeroEffect class.

Namespace: MindFusion.Diagramming
Assembly: NodeEffects.js

Syntax

JavaScript [image] Copy Code

function AeroEffect ()

See Also

AeroEffect Class


MindFusion.Diagramming.AeroEffect Methods

AeroEffect Methods
[image]

Public Methods

Name | Description
getInnerOutlineColor | Gets the color of the inner outline.
getOpacity | Gets the opacity to apply to the node's background.
getShadeColor | Gets the color of the shade.
setInnerOutlineColor | Sets the color of the inner outline.
setOpacity | Sets the opacity to apply to the node's background.
setShadeColor | Sets the color of the shade.

See Also

AeroEffect Class


MindFusion.Diagramming.AeroEffect.getInnerOutlineColor Method

AeroEffect.getInnerOutlineColor Method
[image]

Gets the color of the inner outline.

Namespace: MindFusion.Diagramming
Assembly: NodeEffects.js

Syntax

JavaScript [image] Copy Code

function getInnerOutlineColor ()

Return Value

A string specifying the color name or hexadecimal value. The default value is "white".

See Also

AeroEffect Members
AeroEffect Class


MindFusion.Diagramming.AeroEffect.getOpacity Method

AeroEffect.getOpacity Method
[image]

Gets the opacity to apply to the node's background.

Namespace: MindFusion.Diagramming
Assembly: NodeEffects.js

Syntax

JavaScript [image] Copy Code

function getOpacity ()

Return Value

A floating point value between 0 and 1.

See Also

AeroEffect Members
AeroEffect Class


MindFusion.Diagramming.AeroEffect.getShadeColor Method

AeroEffect.getShadeColor Method
[image]

Gets the color of the shade.

Namespace: MindFusion.Diagramming
Assembly: NodeEffects.js

Syntax

JavaScript [image] Copy Code

function getShadeColor ()

Return Value

A string specifying the color name or hexadecimal value. The default value is "black".

See Also

AeroEffect Members
AeroEffect Class


MindFusion.Diagramming.AeroEffect.setInnerOutlineColor Method

AeroEffect.setInnerOutlineColor Method
[image]

Sets the color of the inner outline.

Namespace: MindFusion.Diagramming
Assembly: NodeEffects.js

Syntax

JavaScript [image] Copy Code

function setInnerOutlineColor (value)

Parameters

value

A string specifying the color name or hexadecimal value. The default value is "white".

See Also

AeroEffect Members
AeroEffect Class


MindFusion.Diagramming.AeroEffect.setOpacity Method

AeroEffect.setOpacity Method
[image]

Sets the opacity to apply to the node's background.

Namespace: MindFusion.Diagramming
Assembly: NodeEffects.js

Syntax

JavaScript [image] Copy Code

function setOpacity (value)

Parameters

value

A floating point value between 0 and 1.

See Also

AeroEffect Members
AeroEffect Class


MindFusion.Diagramming.AeroEffect.setShadeColor Method

AeroEffect.setShadeColor Method
[image]

Sets the color of the shade.

Namespace: MindFusion.Diagramming
Assembly: NodeEffects.js

Syntax

JavaScript [image] Copy Code

function setShadeColor (value)

Parameters

value

A string specifying the color name or hexadecimal value. The default value is "black".

See Also

AeroEffect Members
AeroEffect Class


MindFusion.Diagramming.Alignment Enumeration

Alignment Enumeration
[image]

Specifies the alignment of text relative to its layout rectangle.

Namespace: MindFusion.Diagramming
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
Alignment = {}

Members

Member name | Description
Center | The text is drawn in the center of the layout rectangle.
Far | The text is drawn in the far corner of the layout rectangle.
Near | The text is drawn in the near corner of the layout rectangle.

See Also


MindFusion.Diagramming.AnchorPattern Class

AnchorPattern Class
Remarks See Also
[image]

The AnchorPattern class represents a set of anchor points, which specify the exact locations where links are allowed to connect to nodes.

Namespace: MindFusion.Diagramming
Assembly: AnchorPattern.js

Syntax

JavaScript [image] Copy Code

// class
AnchorPattern.prototype = {}

Remarks

A pattern can be assigned to nodes by calling their setAnchorPattern method. The AnchorPattern class exposes several predefined patterns as static fields: decision2In2Out, decision1In3Out, leftInRightOut, topInBottomOut.

Inheritance Hierarchy

See Also

AnchorPattern Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPattern Members

AnchorPattern Members
Constructors Fields Methods
[image]

The AnchorPattern class represents a set of anchor points, which specify the exact locations where links are allowed to connect to nodes.

The following tables list the members exposed by the AnchorPattern type.

Public Constructors

Name | Description
AnchorPattern | Initializes a new instance of the AnchorPattern class.

Public Fields

Name | Description
decision1In3Out | Gets the predefined anchor pattern decision1In3Out.
decision2In2Out | Gets the predefined anchor pattern decision2In2Out.
leftInRightOut | Gets the predefined anchor pattern leftInRightOut.
topInBottomOut | Gets the predefined anchor pattern topInBottomOut.

Public Methods

Name | Description
fromId | Returns a reference to the anchor pattern with the specified string identifier.
getId | Gets the unique AnchorPattern identifier.
getPoints | Gets a collection of the anchor points in this pattern.
setPoints | Sets the collection of the anchor points in this pattern to the specified value.

See Also

AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Fields

AnchorPattern Fields
[image]

Public Fields

Name | Description
decision1In3Out | Gets the predefined anchor pattern decision1In3Out.
decision2In2Out | Gets the predefined anchor pattern decision2In2Out.
leftInRightOut | Gets the predefined anchor pattern leftInRightOut.
topInBottomOut | Gets the predefined anchor pattern topInBottomOut.

See Also

AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.decision1In3Out Field

AnchorPattern.decision1In3Out Field
[image]

Gets the predefined anchor pattern decision1In3Out.

Namespace: MindFusion.Diagramming
Assembly: AnchorPattern.js

Syntax

JavaScript [image] Copy Code

var decision1In3Out

Remarks

Incoming links connect to the top vertex; outgoing links can start from the other vertices.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.decision2In2Out Field

AnchorPattern.decision2In2Out Field
[image]

Gets the predefined anchor pattern decision2In2Out.

Namespace: MindFusion.Diagramming
Assembly: AnchorPattern.js

Syntax

JavaScript [image] Copy Code

var decision2In2Out

Remarks

Incoming links can connect with the top and left vertices; outgoing links can start from the right and bottom vertices.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.leftInRightOut Field

AnchorPattern.leftInRightOut Field
[image]

Gets the predefined anchor pattern leftInRightOut.

Namespace: MindFusion.Diagramming
Assembly: AnchorPattern.js

Syntax

JavaScript [image] Copy Code

var leftInRightOut

Remarks

The middle point of a node's bounding rectangle left side is anchor for incoming links; that on the right side - for outgoing.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.topInBottomOut Field

AnchorPattern.topInBottomOut Field
[image]

Gets the predefined anchor pattern topInBottomOut.

Namespace: MindFusion.Diagramming
Assembly: AnchorPattern.js

Syntax

JavaScript [image] Copy Code

var topInBottomOut

Remarks

The middle point of a node's bounding rectangle top side is anchor for incoming links; that on the bottom - for outgoing.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Constructor

AnchorPattern Constructor
[image]

Initializes a new instance of the AnchorPattern class.

Namespace: MindFusion.Diagramming
Assembly: AnchorPattern.js

Syntax

JavaScript [image] Copy Code

function AnchorPattern (points, [id])

Parameters

points

Contains the initial set of AnchorPoint instances for the new pattern.

id
Optional.

An unique identifier for this anchor pattern.

See Also

AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Methods

AnchorPattern Methods
[image]

Public Methods

Name | Description
fromId | Returns a reference to the anchor pattern with the specified string identifier.
getId | Gets the unique AnchorPattern identifier.
getPoints | Gets a collection of the anchor points in this pattern.
setPoints | Sets the collection of the anchor points in this pattern to the specified value.

See Also

AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.fromId Method

AnchorPattern.fromId Method
[image]

Returns a reference to the anchor pattern with the specified string identifier.

Namespace: MindFusion.Diagramming
Assembly: AnchorPattern.js

Syntax

JavaScript [image] Copy Code

function fromId (id)

Parameters

id

A string identifying an AnchorPattern instance.

Return Value

The AnchorPattern object whose Id is equal to the id parameter.

Remarks

The id argument should match an identifier passed to the constructor of an existing AnchorPattern object.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.getId Method

AnchorPattern.getId Method
[image]

Gets the unique AnchorPattern identifier.

Namespace: MindFusion.Diagramming
Assembly: AnchorPattern.js

Syntax

JavaScript [image] Copy Code

function getId ()

Return Value

The AnchorPattern id.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.getPoints Method

AnchorPattern.getPoints Method
[image]

Gets a collection of the anchor points in this pattern.

Namespace: MindFusion.Diagramming
Assembly: AnchorPattern.js

Syntax

JavaScript [image] Copy Code

function getPoints ()

Return Value

An array containing the anchor points in this pattern.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.setPoints Method

AnchorPattern.setPoints Method
[image]

Sets the collection of the anchor points in this pattern to the specified value.

Namespace: MindFusion.Diagramming
Assembly: AnchorPattern.js

Syntax

JavaScript [image] Copy Code

function setPoints (value)

Parameters

value

A collection of anchor points.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPoint Class

AnchorPoint Class
Remarks See Also
[image]

The AnchorPoint class represents a location in a node to which links are allowed to connect.

Namespace: MindFusion.Diagramming
Assembly: AnchorPoint.js

Syntax

JavaScript [image] Copy Code

// class
AnchorPoint.prototype = {}

Remarks

Anchor points can be assigned to nodes only as constituent elements of an AnchorPattern object.

An anchor point can accept incoming or outgoing links, or both, as specified via the allowIncoming and allowOutgoing constructor parameters. The position of the anchor point inside a node's bounding rectangle is set through the x and y parameters, expressed as percent of the rectangle width and height.

How anchor points are marked on the display can be set using MarkStyle and Color properties.

Inheritance Hierarchy

See Also

AnchorPoint Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPoint Members

AnchorPoint Members
Constructors Methods
[image]

The AnchorPoint class represents a location in a node to which links are allowed to connect.

The following tables list the members exposed by the AnchorPoint type.

Public Constructors

Name | Description
AnchorPoint | Initializes a new instance of the AnchorPoint class.

Public Methods

Name | Description
getAllowIncoming | Gets a value indicating whether incoming links can be connected to this point.
getAllowOutgoing | Gets a value indicating whether the anchor point accepts outgoing connections.
getColor | Gets the color of the anchor point mark.
getColumn | Gets the column index of a cell with which the anchor point is associated.
getMarkStyle | Gets the appearance of the anchor point mark.
getSize | Gets the size of the anchor point mark.
getTag | Gets a user-defined data associated with the anchor point.
getToolTip | Gets a tooltip text that should be displayed when the mouse hovers over an anchor point mark.
getX | Gets the horizontal position of the anchor point expressed as percent of a node's width.
getY | Gets the vertical position of the anchor point expressed as percent of a node's height.
setAllowIncoming | Sets a value indicating whether incoming links can be connected to this point.
setAllowOutgoing | Sets a value indicating whether the anchor point accepts outgoing connections.
setColor | Sets the color of the anchor point mark.
setColumn | Sets the column index of a cell with which the anchor point is associated.
setMarkStyle | Sets the appearance of the anchor point mark.
setSize | Sets the size of the anchor point mark.
setTag | Sets a user-defined data associated with the anchor point.
setToolTip | Sets a tooltip text that should be displayed when the mouse hovers over an anchor point mark.
setX | Sets the horizontal position of the anchor point expressed as percent of a node's width.
setY | Sets the vertical position of the anchor point expressed as percent of a node's height.

See Also

AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Constructor

AnchorPoint Constructor
[image]

Initializes a new instance of the AnchorPoint class.

Namespace: MindFusion.Diagramming
Assembly: AnchorPoint.js

Syntax

JavaScript [image] Copy Code

function AnchorPoint (x, y, [allowIncoming, [allowOutgoing, [style, [color, [size]]]]])

Parameters

x

The horizontal position of the anchor expressed as percent of the width of a node.

y

The vertical position of the anchor expressed as percent of the height of a node.

allowIncoming
Optional.

Specifies whether incoming links can connect to this anchor.

allowOutgoing
Optional.

Specifies whether outgoing links can connect to this anchor.

style
Optional.

Defines how the anchor point is marked visually.

color
Optional.

Defines the color with which the anchor mark is painted.

size
Optional.

Defines the size of the anchor mark.

See Also

AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Methods

AnchorPoint Methods
[image]

Public Methods

Name | Description
getAllowIncoming | Gets a value indicating whether incoming links can be connected to this point.
getAllowOutgoing | Gets a value indicating whether the anchor point accepts outgoing connections.
getColor | Gets the color of the anchor point mark.
getColumn | Gets the column index of a cell with which the anchor point is associated.
getMarkStyle | Gets the appearance of the anchor point mark.
getSize | Gets the size of the anchor point mark.
getTag | Gets a user-defined data associated with the anchor point.
getToolTip | Gets a tooltip text that should be displayed when the mouse hovers over an anchor point mark.
getX | Gets the horizontal position of the anchor point expressed as percent of a node's width.
getY | Gets the vertical position of the anchor point expressed as percent of a node's height.
setAllowIncoming | Sets a value indicating whether incoming links can be connected to this point.
setAllowOutgoing | Sets a value indicating whether the anchor point accepts outgoing connections.
setColor | Sets the color of the anchor point mark.
setColumn | Sets the column index of a cell with which the anchor point is associated.
setMarkStyle | Sets the appearance of the anchor point mark.
setSize | Sets the size of the anchor point mark.
setTag | Sets a user-defined data associated with the anchor point.
setToolTip | Sets a tooltip text that should be displayed when the mouse hovers over an anchor point mark.
setX | Sets the horizontal position of the anchor point expressed as percent of a node's width.
setY | Sets the vertical position of the anchor point expressed as percent of a node's height.

See Also

AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.getAllowIncoming Method

AnchorPoint.getAllowIncoming Method
[image]

Gets a value indicating whether incoming links can be connected to this point.

Namespace: MindFusion.Diagramming
Assembly: AnchorPoint.js

Syntax

JavaScript [image] Copy Code

function getAllowIncoming ()

Return Value

true if incoming links can be connected to this point, otherwise, false.

Remarks

If no incoming anchors are defined for a node, link end points can be placed anywhere inside that node.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.getAllowOutgoing Method

AnchorPoint.getAllowOutgoing Method
[image]

Gets a value indicating whether the anchor point accepts outgoing connections.

Namespace: MindFusion.Diagramming
Assembly: AnchorPoint.js

Syntax

JavaScript [image] Copy Code

function getAllowOutgoing ()

Return Value

true if the anchor point accepts outgoing connections, otherwise, false.

Remarks

If no outgoing anchors are defined for a node, link start points can be placed anywhere inside that node.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.getColor Method

AnchorPoint.getColor Method
[image]

Gets the color of the anchor point mark.

Namespace: MindFusion.Diagramming
Assembly: AnchorPoint.js

Syntax

JavaScript [image] Copy Code

function getColor ()

Return Value

The color of the anchor point mark.

Remarks

The anchor mark shape specified via MarkStyle is painted with this color.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.getColumn Method

AnchorPoint.getColumn Method
[image]

Gets the column index of a cell with which the anchor point is associated.

Namespace: MindFusion.Diagramming
Assembly: AnchorPoint.js

Syntax

JavaScript [image] Copy Code

function getColumn ()

Return Value

The column index of a cell with which the anchor point is associated.

Remarks

If Column is set to -1, the point relative coordinates specify percents of row's extents. Otherwise the point coordinates specify percents of cell's extents.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.getMarkStyle Method

AnchorPoint.getMarkStyle Method
[image]

Gets the appearance of the anchor point mark.

Namespace: MindFusion.Diagramming
Assembly: AnchorPoint.js

Syntax

JavaScript [image] Copy Code

function getMarkStyle ()

Return Value

One of the MarkStyle enumeration values.

Remarks

Specifies how anchor points are marked visually on the display.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.getSize Method

AnchorPoint.getSize Method
[image]

Gets the size of the anchor point mark.

Namespace: MindFusion.Diagramming
Assembly: AnchorPoint.js

Syntax

JavaScript [image] Copy Code

function getSize ()

Return Value

The size.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.getTag Method

AnchorPoint.getTag Method
[image]

Gets a user-defined data associated with the anchor point.

Namespace: MindFusion.Diagramming
Assembly: AnchorPoint.js

Syntax

JavaScript [image] Copy Code

function getTag ()

Return Value

The user-defined data associated with the anchor point.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.getToolTip Method

AnchorPoint.getToolTip Method
[image]

Gets a tooltip text that should be displayed when the mouse hovers over an anchor point mark.

Namespace: MindFusion.Diagramming
Assembly: AnchorPoint.js

Syntax

JavaScript [image] Copy Code

function getToolTip ()

Remarks

When the mouse rests for a while over an anchor point, the tool-tip text is displayed in a small popup window near the mouse cursor.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.getX Method

AnchorPoint.getX Method
[image]

Gets the horizontal position of the anchor point expressed as percent of a node's width.

Namespace: MindFusion.Diagramming
Assembly: AnchorPoint.js

Syntax

JavaScript [image] Copy Code

function getX ()

Return Value

The horizontal position of the anchor point expressed as percent of a node's width.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.getY Method

AnchorPoint.getY Method
[image]

Gets the vertical position of the anchor point expressed as percent of a node's height.

Namespace: MindFusion.Diagramming
Assembly: AnchorPoint.js

Syntax

JavaScript [image] Copy Code

function getY ()

Return Value

The vertical position of the anchor point expressed as percent of a node's height.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.setAllowIncoming Method

AnchorPoint.setAllowIncoming Method
[image]

Sets a value indicating whether incoming links can be connected to this point.

Namespace: MindFusion.Diagramming
Assembly: AnchorPoint.js

Syntax

JavaScript [image] Copy Code

function setAllowIncoming (value)

Parameters

value

true if incoming links can beconnected to this anchor, otherwise, false.

Remarks

If no incoming anchor points are defined for a node, link end points can be placed anywhere inside that node.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.setAllowOutgoing Method

AnchorPoint.setAllowOutgoing Method
[image]

Sets a value indicating whether the anchor point accepts outgoing connections.

Namespace: MindFusion.Diagramming
Assembly: AnchorPoint.js

Syntax

JavaScript [image] Copy Code

function setAllowOutgoing (value)

Parameters

value

true if the anchor point acceptsoutgoing connections, otherwise, false.

Remarks

If no outgoing anchor points are defined for a node, link start points can be placed anywhere inside that node.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.setColor Method

AnchorPoint.setColor Method
[image]

Sets the color of the anchor point mark.

Namespace: MindFusion.Diagramming
Assembly: AnchorPoint.js

Syntax

JavaScript [image] Copy Code

function setColor (value)

Parameters

value

The color of the anchor point mark.

Remarks

The anchor mark shape specified via MarkStyle is painted with this color.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.setColumn Method

AnchorPoint.setColumn Method
[image]

Sets the column index of a cell with which the anchor point is associated.

Namespace: MindFusion.Diagramming
Assembly: AnchorPoint.js

Syntax

JavaScript [image] Copy Code

function setColumn (value)

Parameters

value

The column index of a cell with which the anchorpoint is associated.

Remarks

If Column is set to -1, the point relative coordinates specify percents of row's extents. Otherwise the point coordinates specify percents of cell's extents.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.setMarkStyle Method

AnchorPoint.setMarkStyle Method
[image]

Sets the appearance of the anchor point mark.

Namespace: MindFusion.Diagramming
Assembly: AnchorPoint.js

Syntax

JavaScript [image] Copy Code

function setMarkStyle (value)

Parameters

value

One of the MarkStyle enumeration values.

Remarks

Specifies how anchor points are marked visually on the display.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.setSize Method

AnchorPoint.setSize Method
[image]

Sets the size of the anchor point mark.

Namespace: MindFusion.Diagramming
Assembly: AnchorPoint.js

Syntax

JavaScript [image] Copy Code

function setSize (value)

Parameters

value

The size.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.setTag Method

AnchorPoint.setTag Method
[image]

Sets a user-defined data associated with the anchor point.

Namespace: MindFusion.Diagramming
Assembly: AnchorPoint.js

Syntax

JavaScript [image] Copy Code

function setTag (value)

Parameters

value

The user-defined data associated with the anchor point.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.setToolTip Method

AnchorPoint.setToolTip Method
[image]

Sets a tooltip text that should be displayed when the mouse hovers over an anchor point mark.

Namespace: MindFusion.Diagramming
Assembly: AnchorPoint.js

Syntax

JavaScript [image] Copy Code

function setToolTip (value)

Parameters

value

Remarks

When the mouse rests for a while over an anchor point, the tool-tip text is displayed in a small popup window near the mouse cursor.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.setX Method

AnchorPoint.setX Method
[image]

Sets the horizontal position of the anchor point expressed as percent of a node's width.

Namespace: MindFusion.Diagramming
Assembly: AnchorPoint.js

Syntax

JavaScript [image] Copy Code

function setX (value)

Parameters

value

The horizontal position of the anchor pointexpressed as percent of a node's width.

Remarks

Set the property value to a number between 0 and 100, otherwise you might get unexpected behavior.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.setY Method

AnchorPoint.setY Method
[image]

Sets the vertical position of the anchor point expressed as percent of a node's height.

Namespace: MindFusion.Diagramming
Assembly: AnchorPoint.js

Syntax

JavaScript [image] Copy Code

function setY (value)

Parameters

value

The vertical position of the anchor pointexpressed as percent of a node's height.

Remarks

Set the property value to a number between 0 and 100, otherwiseyou might get unexpected behavior.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AutoResize Enumeration

AutoResize Enumeration
[image]

Defines in which directions automatic resizing can enlarge the diagram scrollable area.

Namespace: MindFusion.Diagramming
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
AutoResize = {}

Members

Member name | Description
AllDirections | Enlarge the diagram area in any direction if an item is moved outside the boundaries.
None | Do not enlarge the diagram area automatically.
RightAndDown | Enlarge the diagram area to the right and down if an item is moved outside the boundaries in these directions.

See Also


MindFusion.Diagramming.Behavior Enumeration

Behavior Enumeration
[image]

Defines values that specify how the component responds to actions performed by the user.

Namespace: MindFusion.Diagramming
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
Behavior = {}

Members

Member name | Description
Custom | Drawing with the mouse creates instances of the type assigned to CustomNodeType.
DoNothing | The control ignores users actions with the mouse, but raises the appropriate mouse events. This mode allows applications to implement their own mouse-drawing behavior, disabling the default response to users actions.
DrawContainers | Drawing with the mouse creates ContainerNode instances.
DrawLinks | Drawing started over a node creates a DiagramLink. Otherwise a lasso rectangle is displayed allowing the selection of items.
DrawShapes | Drawing with the mouse creates ShapeNode instances.
DrawSvgNodes | Drawing with the mouse creates SvgNode instances.
DrawTables | Drawing with the mouse creates TableNode instances.
LinkContainers | Drawing over empty document area creates a ContainerNode instance. Drawing started over a node creates a DiagramLink.
LinkShapes | A mode that is suitable for creating flowcharts and process diagrams. Drawing over empty document area creates a ShapeNode instance. Drawing started over a node creates a DiagramLink.
LinkSvgNodes | Drawing over empty document area creates an SvgNode instance. Drawing started over a node creates a DiagramLink.
LinkTables | A mode that is suitable for creating entity-relationship diagrams. Drawing over empty document area creates a TableNode instance. Drawing started over a node creates a DiagramLink.
Modify | Objects can be selected and modified. New objects cannot be created.
Pan | Dragging with depressed mouse button pans the view.
SelectOnly | Allow only selection of existing items. Modifying them or drawing new ones is disabled.

Remarks

Member of this enumeration can be assigned to the Behavior property of the Diagram class.

See Also


MindFusion.Diagramming.BehaviorBase Class

BehaviorBase Class
[image]

An abstract base class for types that define how the control reacts to users' actions with a mouse or other pointing devices.

Namespace: MindFusion.Diagramming
Assembly: BehaviorBase.js

Syntax

JavaScript [image] Copy Code

// class
BehaviorBase.prototype = {}

Inheritance Hierarchy

See Also

BehaviorBase Members


MindFusion.Diagramming.BehaviorBase Members

BehaviorBase Members
Constructors Methods
[image]

An abstract base class for types that define how the control reacts to users' actions with a mouse or other pointing devices.

The following tables list the members exposed by the BehaviorBase type.

Public Constructors

Name | Description
BehaviorBase | Initializes a new instance of the BehaviorBase class.

Public Methods

Name | Description
onMouseDown | Overrides Interaction.OnMouseDown.
onMouseMove | Raises the MouseMove event.
onMouseUp | Interaction.OnMouseUp override.

See Also

BehaviorBase Class


MindFusion.Diagramming.BehaviorBase Constructor

BehaviorBase Constructor
[image]

Initializes a new instance of the BehaviorBase class.

Namespace: MindFusion.Diagramming
Assembly: BehaviorBase.js

Syntax

JavaScript [image] Copy Code

function BehaviorBase (parent)

Parameters

parent
The Diagram this behavior will be associated with.

See Also

BehaviorBase Class


MindFusion.Diagramming.BehaviorBase Methods

BehaviorBase Methods
[image]

Public Methods

Name | Description
onMouseDown | Overrides Interaction.OnMouseDown.
onMouseMove | Raises the MouseMove event.
onMouseUp | Interaction.OnMouseUp override.

See Also

BehaviorBase Class


MindFusion.Diagramming.BehaviorBase.onMouseDown Method

BehaviorBase.onMouseDown Method
[image]

Overrides Interaction.OnMouseDown.

Namespace: MindFusion.Diagramming
Assembly: BehaviorBase.js

Syntax

JavaScript [image] Copy Code

function onMouseDown (e)

Parameters

e

A MouseButtonEventArgs that contains the event data.

See Also

BehaviorBase Members
BehaviorBase Class


MindFusion.Diagramming.BehaviorBase.onMouseMove Method

BehaviorBase.onMouseMove Method
[image]

Raises the MouseMove event.

Namespace: MindFusion.Diagramming
Assembly: BehaviorBase.js

Syntax

JavaScript [image] Copy Code

function onMouseMove (e)

Parameters

e

A MouseEventArgs that contains the event data.

See Also

BehaviorBase Members
BehaviorBase Class


MindFusion.Diagramming.BehaviorBase.onMouseUp Method

BehaviorBase.onMouseUp Method
[image]

Interaction.OnMouseUp override.

Namespace: MindFusion.Diagramming
Assembly: BehaviorBase.js

Syntax

JavaScript [image] Copy Code

function onMouseUp (e)

Parameters

e

A MouseButtonEventArgs that contains the event data.

See Also

BehaviorBase Members
BehaviorBase Class


MindFusion.Diagramming.Cell Class

Cell Class
[image]

Represents a cell of a TableNode.

Namespace: MindFusion.Diagramming
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

// class
Cell.prototype = {}

Inheritance Hierarchy

See Also

Cell Members


MindFusion.Diagramming.Cell Members

Cell Members
Constructors Methods
[image]

Represents a cell of a TableNode.

The following tables list the members exposed by the Cell type.

Public Constructors

Name | Description
Cell | Initializes a new instance of the Cell class.

Public Methods

Name | Description
getBrush | Gets the object that specifies how to paint the interior of this cell.
getColumnSpan | Gets the number of columns spanned by this cell.
getFont | Gets the font used to render this cell's text.
getImage | Gets the image displayed inside this cell.
getImageAlign | Gets the alignment for the image of this cell.
getImageLocation | Gets the URL of the image displayed inside this cell.
getLineAlignment | Gets how the text should be vertically aligned inside the cell's bounding rectangle.
getRowSpan | Gets the number of rows spanned by this cell.
getText | Gets the string containing the cell's text.
getTextAlignment | Gets how the text should be aligned inside the cell's bounding rectangle.
getTextColor | Gets a string specifying the color of the text of this cell.
setBrush | Sets an object that specifies how to paint the interior of this cell.
setColumnSpan | Sets the number of columns spanned by this cell.
setFont | Sets the font used to render this cell's text.
setImage | Sets the image displayed inside this cell.
setImageAlign | Sets the alignment for the image of this cell.
setImageLocation | Sets the URL of the image displayed inside this cell.
setLineAlignment | Sets how the text should be vertically aligned inside the cell's bounding rectangle.
setRowSpan | Sets the number of rows spanned by this cell.
setText | Sets a string containing the cell's text.
setTextAlignment | Sets how the text should be aligned inside the cell's bounding rectangle.
setTextColor | Sets a string specifying the color of the text of this cell.

See Also

Cell Class


MindFusion.Diagramming.Cell Constructor

Cell Constructor
[image]

Initializes a new instance of the Cell class.

Namespace: MindFusion.Diagramming
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function Cell ()

See Also

Cell Class


MindFusion.Diagramming.Cell Methods

Cell Methods
[image]

Public Methods

Name | Description
getBrush | Gets the object that specifies how to paint the interior of this cell.
getColumnSpan | Gets the number of columns spanned by this cell.
getFont | Gets the font used to render this cell's text.
getImage | Gets the image displayed inside this cell.
getImageAlign | Gets the alignment for the image of this cell.
getImageLocation | Gets the URL of the image displayed inside this cell.
getLineAlignment | Gets how the text should be vertically aligned inside the cell's bounding rectangle.
getRowSpan | Gets the number of rows spanned by this cell.
getText | Gets the string containing the cell's text.
getTextAlignment | Gets how the text should be aligned inside the cell's bounding rectangle.
getTextColor | Gets a string specifying the color of the text of this cell.
setBrush | Sets an object that specifies how to paint the interior of this cell.
setColumnSpan | Sets the number of columns spanned by this cell.
setFont | Sets the font used to render this cell's text.
setImage | Sets the image displayed inside this cell.
setImageAlign | Sets the alignment for the image of this cell.
setImageLocation | Sets the URL of the image displayed inside this cell.
setLineAlignment | Sets how the text should be vertically aligned inside the cell's bounding rectangle.
setRowSpan | Sets the number of rows spanned by this cell.
setText | Sets a string containing the cell's text.
setTextAlignment | Sets how the text should be aligned inside the cell's bounding rectangle.
setTextColor | Sets a string specifying the color of the text of this cell.

See Also

Cell Class


MindFusion.Diagramming.Cell.getBrush Method

Cell.getBrush Method
[image]

Gets the object that specifies how to paint the interior of this cell.

Namespace: MindFusion.Diagramming
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function getBrush ()

Return Value

An object specifying the fill of the cell.

See Also

Cell Members
Cell Class


MindFusion.Diagramming.Cell.getColumnSpan Method

Cell.getColumnSpan Method
[image]

Gets the number of columns spanned by this cell.

Namespace: MindFusion.Diagramming
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function getColumnSpan ()

Return Value

An integer value specifying the number of spanned columns.

See Also

Cell Members
Cell Class


MindFusion.Diagramming.Cell.getFont Method

Cell.getFont Method
[image]

Gets the font used to render this cell's text.

Namespace: MindFusion.Diagramming
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function getFont ()

Return Value

A Font instance.

See Also

Cell Members
Cell Class


MindFusion.Diagramming.Cell.getImage Method

Cell.getImage Method
[image]

Gets the image displayed inside this cell.

Namespace: MindFusion.Diagramming
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function getImage ()

Return Value

The cell's image.

See Also

Cell Members
Cell Class


MindFusion.Diagramming.Cell.getImageAlign Method

Cell.getImageAlign Method
[image]

Gets the alignment for the image of this cell.

Namespace: MindFusion.Diagramming
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function getImageAlign ()

Return Value

One of the ImageAlign Enumeration values.

See Also

Cell Members
Cell Class


MindFusion.Diagramming.Cell.getImageLocation Method

Cell.getImageLocation Method
[image]

Gets the URL of the image displayed inside this cell.

Namespace: MindFusion.Diagramming
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function getImageLocation ()

Return Value

A valid URL string that identifies the image to be loaded.

See Also

Cell Members
Cell Class


MindFusion.Diagramming.Cell.getLineAlignment Method

Cell.getLineAlignment Method
[image]

Gets how the text should be vertically aligned inside the cell's bounding rectangle.

Namespace: MindFusion.Diagramming
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function getLineAlignment ()

Return Value

One of the Alignment enumeration values.

See Also

Cell Members
Cell Class


MindFusion.Diagramming.Cell.getRowSpan Method

Cell.getRowSpan Method
[image]

Gets the number of rows spanned by this cell.

Namespace: MindFusion.Diagramming
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function getRowSpan ()

Return Value

An integer value specifying the number of spanned rows.

See Also

Cell Members
Cell Class


MindFusion.Diagramming.Cell.getText Method

Cell.getText Method
[image]

Gets the string containing the cell's text.

Namespace: MindFusion.Diagramming
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function getText ()

Return Value

The string that contains the text.

See Also

Cell Members
Cell Class


MindFusion.Diagramming.Cell.getTextAlignment Method

Cell.getTextAlignment Method
[image]

Gets how the text should be aligned inside the cell's bounding rectangle.

Namespace: MindFusion.Diagramming
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function getTextAlignment ()

Return Value

One of the Alignment enumeration values.

See Also

Cell Members
Cell Class


MindFusion.Diagramming.Cell.getTextColor Method

Cell.getTextColor Method
[image]

Gets a string specifying the color of the text of this cell.

Namespace: MindFusion.Diagramming
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function getTextColor ()

Return Value

A string value identifying the color of the text.

See Also

Cell Members
Cell Class


MindFusion.Diagramming.Cell.setBrush Method

Cell.setBrush Method
[image]

Sets an object that specifies how to paint the interior of this cell.

Namespace: MindFusion.Diagramming
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function setBrush ([value])

Parameters

value
Optional.

A Brush object specifying the fill of the cell.

See Also

Cell Members
Cell Class


MindFusion.Diagramming.Cell.setColumnSpan Method

Cell.setColumnSpan Method
[image]

Sets the number of columns spanned by this cell.

Namespace: MindFusion.Diagramming
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function setColumnSpan (value)

Parameters

value

An integer value specifying the number of spanned columns.

See Also

Cell Members
Cell Class


MindFusion.Diagramming.Cell.setFont Method

Cell.setFont Method
[image]

Sets the font used to render this cell's text.

Namespace: MindFusion.Diagramming
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function setFont (value)

Parameters

value

A Font instance.

See Also

Cell Members
Cell Class


MindFusion.Diagramming.Cell.setImage Method

Cell.setImage Method
[image]

Sets the image displayed inside this cell.

Namespace: MindFusion.Diagramming
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function setImage (value)

Parameters

value

The image to set.

See Also

Cell Members
Cell Class


MindFusion.Diagramming.Cell.setImageAlign Method

Cell.setImageAlign Method
[image]

Sets the alignment for the image of this cell.

Namespace: MindFusion.Diagramming
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function setImageAlign (value)

Parameters

value

One of the ImageAlign Enumeration values.

See Also

Cell Members
Cell Class


MindFusion.Diagramming.Cell.setImageLocation Method

Cell.setImageLocation Method
[image]

Sets the URL of the image displayed inside this cell.

Namespace: MindFusion.Diagramming
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function setImageLocation (value)

Parameters

value

A valid URL string that identifies the image to be loaded.

See Also

Cell Members
Cell Class


MindFusion.Diagramming.Cell.setLineAlignment Method

Cell.setLineAlignment Method
[image]

Sets how the text should be vertically aligned inside the cell's bounding rectangle.

Namespace: MindFusion.Diagramming
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function setLineAlignment (value)

Parameters

value

One of the Alignment enumeration values.

See Also

Cell Members
Cell Class


MindFusion.Diagramming.Cell.setRowSpan Method

Cell.setRowSpan Method
[image]

Sets the number of rows spanned by this cell.

Namespace: MindFusion.Diagramming
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function setRowSpan (value)

Parameters

value

An integer value specifying the number of spanned rows.

See Also

Cell Members
Cell Class


MindFusion.Diagramming.Cell.setText Method

Cell.setText Method
[image]

Sets a string containing the cell's text.

Namespace: MindFusion.Diagramming
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function setText (value)

Parameters

value

The string to set.

See Also

Cell Members
Cell Class


MindFusion.Diagramming.Cell.setTextAlignment Method

Cell.setTextAlignment Method
[image]

Sets how the text should be aligned inside the cell's bounding rectangle.

Namespace: MindFusion.Diagramming
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function setTextAlignment (value)

Parameters

value

One of the Alignment enumeration values.

See Also

Cell Members
Cell Class


MindFusion.Diagramming.Cell.setTextColor Method

Cell.setTextColor Method
[image]

Sets a string specifying the color of the text of this cell.

Namespace: MindFusion.Diagramming
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function setTextColor (value)

Parameters

value

A string value identifying the color of the text.

See Also

Cell Members
Cell Class


MindFusion.Diagramming.CellEventArgs Class

CellEventArgs Class
[image]

Contains the arguments passed to handlers of inplace edit related events.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

// class
CellEventArgs.prototype = {}

Inheritance Hierarchy

See Also

CellEventArgs Members


MindFusion.Diagramming.CellEventArgs Members

CellEventArgs Members
Constructors Methods
[image]

Contains the arguments passed to handlers of inplace edit related events.

The following tables list the members exposed by the CellEventArgs type.

Public Constructors

Name | Description
CellEventArgs | Initializes a new instance of the CellEventArgs class.

Public Methods

Name | Description
getCancel | Gets a value indicating whether to allow the current operation.
getCell | Gets the cell related to the event.
getContext | Gets the canvas rendering context.
getHandled | Gets a value indicating whether the event has been handled.
getMouseButton | Gets the index of the table's column that contains the cell.
getNewText | Gets the text that has just been entered by the user.
getOldText | Gets the text that had been displayed in the node before the user edited it.
setCancel | Sets a value indicating whether to allow the current operation.
setHandled | Sets a value indicating whether the event has been handled.

See Also

CellEventArgs Class


MindFusion.Diagramming.CellEventArgs Constructor

CellEventArgs Constructor
[image]

Initializes a new instance of the CellEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function CellEventArgs ()

See Also

CellEventArgs Class


MindFusion.Diagramming.CellEventArgs Methods

CellEventArgs Methods
[image]

Public Methods

Name | Description
getCancel | Gets a value indicating whether to allow the current operation.
getCell | Gets the cell related to the event.
getContext | Gets the canvas rendering context.
getHandled | Gets a value indicating whether the event has been handled.
getMouseButton | Gets the index of the table's column that contains the cell.
getNewText | Gets the text that has just been entered by the user.
getOldText | Gets the text that had been displayed in the node before the user edited it.
setCancel | Sets a value indicating whether to allow the current operation.
setHandled | Sets a value indicating whether the event has been handled.

See Also

CellEventArgs Class


MindFusion.Diagramming.CellEventArgs.getCancel Method

CellEventArgs.getCancel Method
[image]

Gets a value indicating whether to allow the current operation.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getCancel ()

Return Value

true to cancel the operation; otherwise, false.

See Also

CellEventArgs Members
CellEventArgs Class


MindFusion.Diagramming.CellEventArgs.getCell Method

CellEventArgs.getCell Method
[image]

Gets the cell related to the event.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getCell ()

Return Value

A Cell instance.

See Also

CellEventArgs Members
CellEventArgs Class


MindFusion.Diagramming.CellEventArgs.getContext Method

CellEventArgs.getContext Method
[image]

Gets the canvas rendering context.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getContext ()

Return Value

A rendering context used to draw on the Canvas element.

See Also

CellEventArgs Members
CellEventArgs Class


MindFusion.Diagramming.CellEventArgs.getHandled Method

CellEventArgs.getHandled Method
[image]

Gets a value indicating whether the event has been handled.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getHandled ()

See Also

CellEventArgs Members
CellEventArgs Class


MindFusion.Diagramming.CellEventArgs.getMouseButton Method

CellEventArgs.getMouseButton Method
[image]

Gets the index of the table's column that contains the cell.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getMouseButton ()

Return Value

The index of the table's column that contains the cell.

See Also

CellEventArgs Members
CellEventArgs Class


MindFusion.Diagramming.CellEventArgs.getNewText Method

CellEventArgs.getNewText Method
[image]

Gets the text that has just been entered by the user.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getNewText ()

Return Value

A string specifying the new text of the node.

See Also

CellEventArgs Members
CellEventArgs Class


MindFusion.Diagramming.CellEventArgs.getOldText Method

CellEventArgs.getOldText Method
[image]

Gets the text that had been displayed in the node before the user edited it.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getOldText ()

Return Value

A string specifying the old text of the node.

See Also

CellEventArgs Members
CellEventArgs Class


MindFusion.Diagramming.CellEventArgs.setCancel Method

CellEventArgs.setCancel Method
[image]

Sets a value indicating whether to allow the current operation.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function setCancel (value)

Parameters

value

true to cancel the operation; otherwise, false.

See Also

CellEventArgs Members
CellEventArgs Class


MindFusion.Diagramming.CellEventArgs.setHandled Method

CellEventArgs.setHandled Method
[image]

Sets a value indicating whether the event has been handled.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function setHandled (value)

Parameters

value

true to indicate that the event has been handled; otherwise, false.

See Also

CellEventArgs Members
CellEventArgs Class


MindFusion.Diagramming.CellFrameStyle Enumeration

CellFrameStyle Enumeration
[image]

Specifies the style of the cells' frame lines.

Namespace: MindFusion.Diagramming
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
CellFrameStyle = {}

Members

Member name | Description
None | Table cells have no border.
Simple | The border of table cells is simple line.

Remarks

Members of this enumeration can be assigned to CellFrameStyle property of TableNode.

See Also


MindFusion.Diagramming.ChangeItemCommand Class

ChangeItemCommand Class
Remarks See Also
[image]

Handles undo / redo of property changes.

Namespace: MindFusion.Diagramming
Assembly: ChangeItemCommand.js

Syntax

JavaScript [image] Copy Code

// class
ChangeItemCommand.prototype = {}

Remarks

The ChangeItemCommand constructor records the state of an item, and its undo and redo methods restore the item to either its old or new state.

Example

See executeCommand for an example showing how item's state is saved for later undo / redo.

Inheritance Hierarchy

See Also

ChangeItemCommand Members


MindFusion.Diagramming.ChangeItemCommand Members

ChangeItemCommand Members
Constructors Methods
[image]

Handles undo / redo of property changes.

The following tables list the members exposed by the ChangeItemCommand type.

Public Constructors

Name | Description
ChangeItemCommand | Initializes a new instance of the ChangeItemCommand class.

Public Methods

Name | Description
execute | Command.execute override.
redo | Command.redo override.
undo | Command.undo override.

See Also

ChangeItemCommand Class


MindFusion.Diagramming.ChangeItemCommand Constructor

ChangeItemCommand Constructor
[image]

Initializes a new instance of the ChangeItemCommand class.

Namespace: MindFusion.Diagramming
Assembly: ChangeItemCommand.js

Syntax

JavaScript [image] Copy Code

function ChangeItemCommand (diagram, item)

Parameters

diagram

The Diagram modified by this command.

item

The DiagramItem that will be modified.

See Also

ChangeItemCommand Class


MindFusion.Diagramming.ChangeItemCommand Methods

ChangeItemCommand Methods
[image]

Public Methods

Name | Description
execute | Command.execute override.
redo | Command.redo override.
undo | Command.undo override.

See Also

ChangeItemCommand Class


MindFusion.Diagramming.ChangeItemCommand.execute Method

ChangeItemCommand.execute Method
[image]

Command.execute override.

Namespace: MindFusion.Diagramming
Assembly: ChangeItemCommand.js

Syntax

JavaScript [image] Copy Code

function execute ()

See Also

ChangeItemCommand Members
ChangeItemCommand Class


MindFusion.Diagramming.ChangeItemCommand.redo Method

ChangeItemCommand.redo Method
[image]

Command.redo override.

Namespace: MindFusion.Diagramming
Assembly: ChangeItemCommand.js

Syntax

JavaScript [image] Copy Code

function redo ()

See Also

ChangeItemCommand Members
ChangeItemCommand Class


MindFusion.Diagramming.ChangeItemCommand.undo Method

ChangeItemCommand.undo Method
[image]

Command.undo override.

Namespace: MindFusion.Diagramming
Assembly: ChangeItemCommand.js

Syntax

JavaScript [image] Copy Code

function undo ()

See Also

ChangeItemCommand Members
ChangeItemCommand Class


MindFusion.Diagramming.Command Class

Command Class
[image]

Represents an action that changes the diagram and whose effects can be undone.

Namespace: MindFusion.Diagramming
Assembly: Command.js

Syntax

JavaScript [image] Copy Code

// class
Command.prototype = {}

Inheritance Hierarchy

See Also

Command Members


MindFusion.Diagramming.Command Members

Command Members
Constructors Methods
[image]

Represents an action that changes the diagram and whose effects can be undone.

The following tables list the members exposed by the Command type.

Public Constructors

Name | Description
Command | Initializes a new instance of the Command class.

Public Methods

Name | Description
execute | Carries out an action that changes the diagram or a diagram item.
redo | Repeats an action that has been undone.
undo | Undoes an action, restoring the diagram to the state it was in before carrying out the action.

See Also

Command Class


MindFusion.Diagramming.Command Constructor

Command Constructor
[image]

Initializes a new instance of the Command class.

Namespace: MindFusion.Diagramming
Assembly: Command.js

Syntax

JavaScript [image] Copy Code

function Command (diagram)

Parameters

diagram

The Diagram modified by this command.

See Also

Command Class


MindFusion.Diagramming.Command Methods

Command Methods
[image]

Public Methods

Name | Description
execute | Carries out an action that changes the diagram or a diagram item.
redo | Repeats an action that has been undone.
undo | Undoes an action, restoring the diagram to the state it was in before carrying out the action.

See Also

Command Class


MindFusion.Diagramming.Command.execute Method

Command.execute Method
[image]

Carries out an action that changes the diagram or a diagram item.

Namespace: MindFusion.Diagramming
Assembly: Command.js

Syntax

JavaScript [image] Copy Code

function execute ()

See Also

Command Members
Command Class


MindFusion.Diagramming.Command.redo Method

Command.redo Method
[image]

Repeats an action that has been undone.

Namespace: MindFusion.Diagramming
Assembly: Command.js

Syntax

JavaScript [image] Copy Code

function redo ()

See Also

Command Members
Command Class


MindFusion.Diagramming.Command.undo Method

Command.undo Method
[image]

Undoes an action, restoring the diagram to the state it was in before carrying out the action.

Namespace: MindFusion.Diagramming
Assembly: Command.js

Syntax

JavaScript [image] Copy Code

function undo ()

See Also

Command Members
Command Class


MindFusion.Diagramming.CompositeCommand Class

CompositeCommand Class
[image]

Represents a set of Command instances as a single operation. Undoing or redoing the composite action, respectively undoes or redoes all its constituent subactions at the same time.

Namespace: MindFusion.Diagramming
Assembly: CompositeCommand.js

Syntax

JavaScript [image] Copy Code

// class
CompositeCommand.prototype = {}

Inheritance Hierarchy

See Also

CompositeCommand Members


MindFusion.Diagramming.CompositeCommand Members

CompositeCommand Members
Constructors Methods
[image]

Represents a set of Command instances as a single operation. Undoing or redoing the composite action, respectively undoes or redoes all its constituent subactions at the same time.

The following tables list the members exposed by the CompositeCommand type.

Public Constructors

Name | Description
CompositeCommand | Initializes a new instance of the CompositeCommand class.

Public Methods

Name | Description
execute | Command.execute override.
getCommands | Gets a list containing the child Command objects.
redo | Command.redo override.
undo | Command.undo override.

See Also

CompositeCommand Class


MindFusion.Diagramming.CompositeCommand Constructor

CompositeCommand Constructor
[image]

Initializes a new instance of the CompositeCommand class.

Namespace: MindFusion.Diagramming
Assembly: CompositeCommand.js

Syntax

JavaScript [image] Copy Code

function CompositeCommand (diagram)

Parameters

diagram

The Diagram modified by this command.

See Also

CompositeCommand Class


MindFusion.Diagramming.CompositeCommand Methods

CompositeCommand Methods
[image]

Public Methods

Name | Description
execute | Command.execute override.
getCommands | Gets a list containing the child Command objects.
redo | Command.redo override.
undo | Command.undo override.

See Also

CompositeCommand Class


MindFusion.Diagramming.CompositeCommand.execute Method

CompositeCommand.execute Method
[image]

Command.execute override.

Namespace: MindFusion.Diagramming
Assembly: CompositeCommand.js

Syntax

JavaScript [image] Copy Code

function execute ()

See Also

CompositeCommand Members
CompositeCommand Class


MindFusion.Diagramming.CompositeCommand.getCommands Method

CompositeCommand.getCommands Method
[image]

Gets a list containing the child Command objects.

Namespace: MindFusion.Diagramming
Assembly: CompositeCommand.js

Syntax

JavaScript [image] Copy Code

function getCommands ()

Return Value

The list of child Command objects.

See Also

CompositeCommand Members
CompositeCommand Class


MindFusion.Diagramming.CompositeCommand.redo Method

CompositeCommand.redo Method
[image]

Command.redo override.

Namespace: MindFusion.Diagramming
Assembly: CompositeCommand.js

Syntax

JavaScript [image] Copy Code

function redo ()

See Also

CompositeCommand Members
CompositeCommand Class


MindFusion.Diagramming.CompositeCommand.undo Method

CompositeCommand.undo Method
[image]

Command.undo override.

Namespace: MindFusion.Diagramming
Assembly: CompositeCommand.js

Syntax

JavaScript [image] Copy Code

function undo ()

See Also

CompositeCommand Members
CompositeCommand Class


MindFusion.Diagramming.ConnectionPoint Class

ConnectionPoint Class
[image]

A class that represents a connection between an edge and a node in a graph. It decouples the DiagramLink class from the DiagramNode class, allowing edges to connect different types of nodes without knowing anything of their implementation details. Each DiagramLink object contains two ConnectionPoint instances describing the connections at both ends of the link.

Namespace: MindFusion.Diagramming
Assembly: ConnectionPoint.js

Syntax

JavaScript [image] Copy Code

// class
ConnectionPoint.prototype = {}

Inheritance Hierarchy

See Also

ConnectionPoint Members


MindFusion.Diagramming.ConnectionPoint Members

ConnectionPoint Members
Constructors Methods
[image]

A class that represents a connection between an edge and a node in a graph. It decouples the DiagramLink class from the DiagramNode class, allowing edges to connect different types of nodes without knowing anything of their implementation details. Each DiagramLink object contains two ConnectionPoint instances describing the connections at both ends of the link.

The following tables list the members exposed by the ConnectionPoint type.

Public Constructors

Name | Description
ConnectionPoint | Initializes a new instance of the ConnectionPoint class between the specified node and link.

Public Methods

Name | Description
addLinkToNode | Adds the DiagramLink associated with this connection point to the associated DiagramNode.
getEndPoint | Calculates the coordinates of this connection point expressed in document coordinates.
getInitialPoint | Returns a Point (usually the center of the bounding rectangle) contained within the associated node.
getIntersection | Calculates the intersection point between the specified line segment and the contour of the node associated with this connection point.
getNearestAnchorPoint | Returns the nearest anchor Point pertinent to this connection.
getNearestBorderPoint | Returns the nearest point lying on the DiagramNode border.
getNodeRect | Returns the bounding rectangle of the node associated with this connection point.
linkChanges | Checks whether the link would change if attached to the specified node at the specified point.
nodesIntersect | Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect.
removeLinkFromNode | Removes the link associated with this connection point from the associated node.
saveEndRelative | Updates the coordinates of the connection point represented by this link, relative to the bounding rectangle of the associated node.

See Also

ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint Constructor

ConnectionPoint Constructor
[image]

Initializes a new instance of the ConnectionPoint class between the specified node and link.

Namespace: MindFusion.Diagramming
Assembly: ConnectionPoint.js

Syntax

JavaScript [image] Copy Code

function ConnectionPoint ([node, [link, [incoming]]])

Parameters

node
Optional. The node whose connection to a link is managed by this ConnectionPoint.
link
Optional. The link whose connection to a node is managed by this ConnectionPoint.
incoming
Optional. Specifies which end of the link is represented by this ConnectionPoint.

See Also

ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint Methods

ConnectionPoint Methods
[image]

Public Methods

Name | Description
addLinkToNode | Adds the DiagramLink associated with this connection point to the associated DiagramNode.
getEndPoint | Calculates the coordinates of this connection point expressed in document coordinates.
getInitialPoint | Returns a Point (usually the center of the bounding rectangle) contained within the associated node.
getIntersection | Calculates the intersection point between the specified line segment and the contour of the node associated with this connection point.
getNearestAnchorPoint | Returns the nearest anchor Point pertinent to this connection.
getNearestBorderPoint | Returns the nearest point lying on the DiagramNode border.
getNodeRect | Returns the bounding rectangle of the node associated with this connection point.
linkChanges | Checks whether the link would change if attached to the specified node at the specified point.
nodesIntersect | Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect.
removeLinkFromNode | Removes the link associated with this connection point from the associated node.
saveEndRelative | Updates the coordinates of the connection point represented by this link, relative to the bounding rectangle of the associated node.

See Also

ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.addLinkToNode Method

ConnectionPoint.addLinkToNode Method
[image]

Adds the DiagramLink associated with this connection point to the associated DiagramNode.

Namespace: MindFusion.Diagramming
Assembly: ConnectionPoint.js

Syntax

JavaScript [image] Copy Code

function addLinkToNode ()

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.getEndPoint Method

ConnectionPoint.getEndPoint Method
[image]

Calculates the coordinates of this connection point expressed in document coordinates.

Namespace: MindFusion.Diagramming
Assembly: ConnectionPoint.js

Syntax

JavaScript [image] Copy Code

function getEndPoint ()

Return Value

A Point that represents the coordinate.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.getInitialPoint Method

ConnectionPoint.getInitialPoint Method
[image]

Returns a Point (usually the center of the bounding rectangle) contained within the associated node.

Namespace: MindFusion.Diagramming
Assembly: ConnectionPoint.js

Syntax

JavaScript [image] Copy Code

function getInitialPoint ()

Return Value

A Point contained within the node.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.getIntersection Method

ConnectionPoint.getIntersection Method
[image]

Calculates the intersection point between the specified line segment and the contour of the node associated with this connection point.

Namespace: MindFusion.Diagramming
Assembly: ConnectionPoint.js

Syntax

JavaScript [image] Copy Code

function getIntersection (point1, point2)

Parameters

point1
The first Point of the segment.
point2
The second point of the segment.

Return Value

A Point object representing the intersection point.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.getNearestAnchorPoint Method

ConnectionPoint.getNearestAnchorPoint Method
[image]

Returns the nearest anchor Point pertinent to this connection.

Namespace: MindFusion.Diagramming
Assembly: ConnectionPoint.js

Syntax

JavaScript [image] Copy Code

function getNearestAnchorPoint (point)

Parameters

point
A Point instance specifying location in the diagram.

Return Value

An AnchorPointDetails specifying the anchor point properties.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.getNearestBorderPoint Method

ConnectionPoint.getNearestBorderPoint Method
[image]

Returns the nearest point lying on the DiagramNode border.

Namespace: MindFusion.Diagramming
Assembly: ConnectionPoint.js

Syntax

JavaScript [image] Copy Code

function getNearestBorderPoint (point)

Parameters

point
A Point instance specifying location in the diagram.

Return Value

An AnchorPointDetails specifying the anchor point properties.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.getNodeRect Method

ConnectionPoint.getNodeRect Method
[image]

Returns the bounding rectangle of the node associated with this connection point.

Namespace: MindFusion.Diagramming
Assembly: ConnectionPoint.js

Syntax

JavaScript [image] Copy Code

function getNodeRect ()

Return Value

The bounding rectangle of the node.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.linkChanges Method

ConnectionPoint.linkChanges Method
[image]

Checks whether the link would change if attached to the specified node at the specified point.

Namespace: MindFusion.Diagramming
Assembly: ConnectionPoint.js

Syntax

JavaScript [image] Copy Code

function linkChanges (item, point)

Parameters

item
A DiagramItem under the mouse cursor.
point
A point where the link will be connected.

Return Value

true if the link would connect to a different entity if dropped at the specified location; otherwise, false.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.nodesIntersect Method

ConnectionPoint.nodesIntersect Method
[image]

Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect.

Namespace: MindFusion.Diagramming
Assembly: ConnectionPoint.js

Syntax

JavaScript [image] Copy Code

function nodesIntersect (connectionPoint)

Parameters

connectionPoint
A ConnectionPoint instance.

Return Value

true if the node associated with the current connection point and the node associated with the specified connection point intersect; otherwise, false.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.removeLinkFromNode Method

ConnectionPoint.removeLinkFromNode Method
[image]

Removes the link associated with this connection point from the associated node.

Namespace: MindFusion.Diagramming
Assembly: ConnectionPoint.js

Syntax

JavaScript [image] Copy Code

function removeLinkFromNode ()

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.saveEndRelative Method

ConnectionPoint.saveEndRelative Method
[image]

Updates the coordinates of the connection point represented by this link, relative to the bounding rectangle of the associated node.

Namespace: MindFusion.Diagramming
Assembly: ConnectionPoint.js

Syntax

JavaScript [image] Copy Code

function saveEndRelative ([ctrRelative])

Parameters

ctrRelative
Optional.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionStyle Enumeration

ConnectionStyle Enumeration
[image]

Specifies whether links should connect to a node or its rows.

Namespace: MindFusion.Diagramming
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
ConnectionStyle = {}

Members

Member name | Description
Node | Links should connect to the table node when drawn interactively.
Rows | Links should connect to one of the table's rows when drawn interactively.

See Also


MindFusion.Diagramming.ContainerNode Class

ContainerNode Class
Remarks See Also
[image]

ContainerNode instances are diagram nodes that can contain other nodes.

Namespace: MindFusion.Diagramming
Assembly: ContainerNode.js

Syntax

JavaScript [image] Copy Code

// class
ContainerNode.prototype = {}

Remarks

Child node can be added to or removed from containers interactively when the AllowAddChildren and AllowRemoveChildren properties are enabled. Use the add method to add a node to container programmatically. Use the remove method to remove a node from the container.

A container node can be folded and unfolded, either interactively or programmatically, as specified through the Foldable and Folded properties. When a container is folded, it occupies a minimal area and its child nodes are hidden.

Inheritance Hierarchy

See Also

ContainerNode Members


MindFusion.Diagramming.ContainerNode Members

ContainerNode Members
Constructors Methods
[image]

ContainerNode instances are diagram nodes that can contain other nodes.

The following tables list the members exposed by the ContainerNode type.

Public Constructors

Name | Description
ContainerNode | Initializes a new instance of the ContainerNode class with default values supplied from the specified Diagram.

Public Methods

Name | Description
add | Adds a node to this container.
arrange | Arranges the container's children with the given layout.
containsPoint | Checks if the ContainerNode contains the specified point.
containsRecursively | Determines whether the specified node is contained within this container, either directly or inside child containers.
getAllowAddChildren | Gets a value indicating whether users are allowed to add child nodes to the container.
getAllowRemoveChildren | Gets a value indicating whether users are allowed to remove child nodes from the container.
getCaptionHeight | Gets the height of the container's caption area.
getClipChildren | Gets a value indicating whether child items should be clipped by container boundaries.
getContentPath | Creates a path corresponding to the content area rectangle, excluding caption bar.
getFoldable | Gets a value indicating whether users are allowed to fold the container.
getFolded | Gets a value indicating whether the container is folded.
getOutline | Gets an array of points that define the outline of this node shape.
getShape | Gets the shape of the container's outline.
hitTest | Returns the diagram item that contains the specified point.
onRemove | DiagramItem.onRemove override.
remove | Removes a node from this container.
resizeToFitChildren | Resizes the container making it big enough to contain its child nodes.
setAllowAddChildren | Sets a value indicating whether users are allowed to add child nodes to the container.
setAllowRemoveChildren | Sets a value indicating whether users are allowed to remove child nodes from the container.
setCaptionHeight | Sets the height of the container's caption area.
setClipChildren | Sets a value indicating whether child items should be clipped by container boundaries.
setFoldable | Sets a value indicating whether users are allowed to fold the container.
setFolded | Folds or unfolds the container.
setShape | Sets the shape of the container's outline.
visitNodes | Visits the diagram nodes in reverse Z order.

See Also

ContainerNode Class


MindFusion.Diagramming.ContainerNode Constructor

ContainerNode Constructor
[image]

Initializes a new instance of the ContainerNode class with default values supplied from the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: ContainerNode.js

Syntax

JavaScript [image] Copy Code

function ContainerNode ([parent])

Parameters

parent
Optional.

The Diagram from which to obtain default values for the node properties.

See Also

ContainerNode Class


MindFusion.Diagramming.ContainerNode Methods

ContainerNode Methods
[image]

Public Methods

Name | Description
add | Adds a node to this container.
arrange | Arranges the container's children with the given layout.
containsPoint | Checks if the ContainerNode contains the specified point.
containsRecursively | Determines whether the specified node is contained within this container, either directly or inside child containers.
getAllowAddChildren | Gets a value indicating whether users are allowed to add child nodes to the container.
getAllowRemoveChildren | Gets a value indicating whether users are allowed to remove child nodes from the container.
getCaptionHeight | Gets the height of the container's caption area.
getClipChildren | Gets a value indicating whether child items should be clipped by container boundaries.
getContentPath | Creates a path corresponding to the content area rectangle, excluding caption bar.
getFoldable | Gets a value indicating whether users are allowed to fold the container.
getFolded | Gets a value indicating whether the container is folded.
getOutline | Gets an array of points that define the outline of this node shape.
getShape | Gets the shape of the container's outline.
hitTest | Returns the diagram item that contains the specified point.
onRemove | DiagramItem.onRemove override.
remove | Removes a node from this container.
resizeToFitChildren | Resizes the container making it big enough to contain its child nodes.
setAllowAddChildren | Sets a value indicating whether users are allowed to add child nodes to the container.
setAllowRemoveChildren | Sets a value indicating whether users are allowed to remove child nodes from the container.
setCaptionHeight | Sets the height of the container's caption area.
setClipChildren | Sets a value indicating whether child items should be clipped by container boundaries.
setFoldable | Sets a value indicating whether users are allowed to fold the container.
setFolded | Folds or unfolds the container.
setShape | Sets the shape of the container's outline.
visitNodes | Visits the diagram nodes in reverse Z order.

See Also

ContainerNode Class


MindFusion.Diagramming.ContainerNode.add Method

ContainerNode.add Method
[image]

Adds a node to this container.

Namespace: MindFusion.Diagramming
Assembly: ContainerNode.js

Syntax

JavaScript [image] Copy Code

function add (node)

Parameters

node

The node that should be added to the container.

See Also

ContainerNode Members
ContainerNode Class
remove Method


MindFusion.Diagramming.ContainerNode.arrange Method

ContainerNode.arrange Method
[image]

Arranges the container's children with the given layout.

Namespace: MindFusion.Diagramming
Assembly: ContainerNode.js

Syntax

JavaScript [image] Copy Code

function arrange (layout)

Parameters

layout

The layout algorithm to apply.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace
TreeLayout Class
LayeredLayout Class
SpringLayout Class


MindFusion.Diagramming.ContainerNode.containsPoint Method

ContainerNode.containsPoint Method
[image]

Checks if the ContainerNode contains the specified point.

Namespace: MindFusion.Diagramming
Assembly: ContainerNode.js

Syntax

JavaScript [image] Copy Code

function containsPoint (point)

Parameters

point

The Point to check.

Return Value

true if the point is within the bounds of this node; otherwise, false.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.containsRecursively Method

ContainerNode.containsRecursively Method
[image]

Determines whether the specified node is contained within this container, either directly or inside child containers.

Namespace: MindFusion.Diagramming
Assembly: ContainerNode.js

Syntax

JavaScript [image] Copy Code

function containsRecursively (node)

Parameters

node

Return Value

true if the specified node is inside the container, otherwise false.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.getAllowAddChildren Method

ContainerNode.getAllowAddChildren Method
[image]

Gets a value indicating whether users are allowed to add child nodes to the container.

Namespace: MindFusion.Diagramming
Assembly: ContainerNode.js

Syntax

JavaScript [image] Copy Code

function getAllowAddChildren ()

Return Value

true if child nodes can be added interactively; otherwise false.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.getAllowRemoveChildren Method

ContainerNode.getAllowRemoveChildren Method
[image]

Gets a value indicating whether users are allowed to remove child nodes from the container.

Namespace: MindFusion.Diagramming
Assembly: ContainerNode.js

Syntax

JavaScript [image] Copy Code

function getAllowRemoveChildren ()

Return Value

true if child nodes can be removed interactively; otherwise false.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.getCaptionHeight Method

ContainerNode.getCaptionHeight Method
[image]

Gets the height of the container's caption area.

Namespace: MindFusion.Diagramming
Assembly: ContainerNode.js

Syntax

JavaScript [image] Copy Code

function getCaptionHeight ()

Return Value

A number specifying the height of the container caption. The default value is 6.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.getClipChildren Method

ContainerNode.getClipChildren Method
[image]

Gets a value indicating whether child items should be clipped by container boundaries.

Namespace: MindFusion.Diagramming
Assembly: ContainerNode.js

Syntax

JavaScript [image] Copy Code

function getClipChildren ()

Return Value

true if child items are clipped; otherwise, false.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.getContentPath Method

ContainerNode.getContentPath Method
[image]

Creates a path corresponding to the content area rectangle, excluding caption bar.

Namespace: MindFusion.Diagramming
Assembly: ContainerNode.js

Syntax

JavaScript [image] Copy Code

function getContentPath ()

Return Value

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.getFoldable Method

ContainerNode.getFoldable Method
[image]

Gets a value indicating whether users are allowed to fold the container.

Namespace: MindFusion.Diagramming
Assembly: ContainerNode.js

Syntax

JavaScript [image] Copy Code

function getFoldable ()

Return Value

true if the container can be folded; otherwise false.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.getFolded Method

ContainerNode.getFolded Method
[image]

Gets a value indicating whether the container is folded.

Namespace: MindFusion.Diagramming
Assembly: ContainerNode.js

Syntax

JavaScript [image] Copy Code

function getFolded ()

Return Value

true if the container is folded; otherwise false.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.getOutline Method

ContainerNode.getOutline Method
[image]

Gets an array of points that define the outline of this node shape.

Namespace: MindFusion.Diagramming
Assembly: ContainerNode.js

Syntax

JavaScript [image] Copy Code

function getOutline ()

Return Value

An array containing the outline points.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.getShape Method

ContainerNode.getShape Method
[image]

Gets the shape of the container's outline.

Namespace: MindFusion.Diagramming
Assembly: ContainerNode.js

Syntax

JavaScript [image] Copy Code

function getShape ()

Return Value

A member of the SimpleShape enumeration.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.hitTest Method

ContainerNode.hitTest Method
[image]

Returns the diagram item that contains the specified point.

Namespace: MindFusion.Diagramming
Assembly: ContainerNode.js

Syntax

JavaScript [image] Copy Code

function hitTest (point, [threshold, onlyNodes, onlyInteractive])

Parameters

point

A Point value specifying the logical coordinates of a diagram point.

threshold
Optional.

Specifies the size of the area around the item outlines where the point is still considered inside the item.

onlyNodes

true to exclude child links from the search.

onlyInteractive

true to exclude locked items from the search.

Return Value

The item that contains the specified point.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.onRemove Method

ContainerNode.onRemove Method
[image]

DiagramItem.onRemove override.

Namespace: MindFusion.Diagramming
Assembly: ContainerNode.js

Syntax

JavaScript [image] Copy Code

function onRemove ()

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.remove Method

ContainerNode.remove Method
[image]

Removes a node from this container.

Namespace: MindFusion.Diagramming
Assembly: ContainerNode.js

Syntax

JavaScript [image] Copy Code

function remove (node)

Parameters

node

The node that should be removed from the container.

See Also

ContainerNode Members
ContainerNode Class
add Method


MindFusion.Diagramming.ContainerNode.resizeToFitChildren Method

ContainerNode.resizeToFitChildren Method
[image]

Resizes the container making it big enough to contain its child nodes.

Namespace: MindFusion.Diagramming
Assembly: ContainerNode.js

Syntax

JavaScript [image] Copy Code

function resizeToFitChildren (allowShrink, margin)

Parameters

allowShrink

margin

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.setAllowAddChildren Method

ContainerNode.setAllowAddChildren Method
[image]

Sets a value indicating whether users are allowed to add child nodes to the container.

Namespace: MindFusion.Diagramming
Assembly: ContainerNode.js

Syntax

JavaScript [image] Copy Code

function setAllowAddChildren (value)

Parameters

value

true if child nodes can be added interactively; otherwise false.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.setAllowRemoveChildren Method

ContainerNode.setAllowRemoveChildren Method
[image]

Sets a value indicating whether users are allowed to remove child nodes from the container.

Namespace: MindFusion.Diagramming
Assembly: ContainerNode.js

Syntax

JavaScript [image] Copy Code

function setAllowRemoveChildren (value)

Parameters

value

true if child nodes can be removed interactively; otherwise false.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.setCaptionHeight Method

ContainerNode.setCaptionHeight Method
[image]

Sets the height of the container's caption area.

Namespace: MindFusion.Diagramming
Assembly: ContainerNode.js

Syntax

JavaScript [image] Copy Code

function setCaptionHeight (value)

Parameters

value

A number specifying the height of the container caption. The default value is 6.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.setClipChildren Method

ContainerNode.setClipChildren Method
[image]

Sets a value indicating whether child items should be clipped by container boundaries.

Namespace: MindFusion.Diagramming
Assembly: ContainerNode.js

Syntax

JavaScript [image] Copy Code

function setClipChildren (value)

Parameters

value

true to clip child items; otherwise, false. The default value is true.

See Also

ContainerNode Members
ContainerNode Class
Shape Property


MindFusion.Diagramming.ContainerNode.setFoldable Method

ContainerNode.setFoldable Method
[image]

Sets a value indicating whether users are allowed to fold the container.

Namespace: MindFusion.Diagramming
Assembly: ContainerNode.js

Syntax

JavaScript [image] Copy Code

function setFoldable (value)

Parameters

value

true if the container can be folded; otherwise false.

Remarks

A foldable container can be folded and unfolded by clicking the up/down arrow displayed in the caption area.

See Also

ContainerNode Members
ContainerNode Class
setFolded Property


MindFusion.Diagramming.ContainerNode.setFolded Method

ContainerNode.setFolded Method
[image]

Folds or unfolds the container.

Namespace: MindFusion.Diagramming
Assembly: ContainerNode.js

Syntax

JavaScript [image] Copy Code

function setFolded (value)

Parameters

value

true to fold the container; false to unfold it.

Remarks

When folded, the container children are not visible, and only its caption bar is displayed.

See Also

ContainerNode Members
ContainerNode Class
setFoldable Method


MindFusion.Diagramming.ContainerNode.setShape Method

ContainerNode.setShape Method
[image]

Sets the shape of the container's outline.

Namespace: MindFusion.Diagramming
Assembly: ContainerNode.js

Syntax

JavaScript [image] Copy Code

function setShape (value)

Parameters

value

A member of the SimpleShape enumeration.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.visitNodes Method

ContainerNode.visitNodes Method
[image]

Visits the diagram nodes in reverse Z order.

Namespace: MindFusion.Diagramming
Assembly: ContainerNode.js

Syntax

JavaScript [image] Copy Code

function visitNodes (point, visitNode, relatedItem)

Parameters

point

visitNode

relatedItem

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.DelKeyAction Enumeration

DelKeyAction Enumeration
[image]

Specifies the type of action performed when the user presses the DEL key.

Namespace: MindFusion.Diagramming
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
DelKeyAction = {}

Members

Member name | Description
DeleteActiveItem | Indicates that only the ActiveItem is deleted.
DeleteSelectedItems | Indicates that all selected items are deleted.
None | Indicates that nothing happens.

Remarks

Members of this enumeration can be given as parameters of the setDelKeyAction method of Diagram.

See Also


MindFusion.Diagramming.Diagram Class

Diagram Class
Remarks See Also
[image]

The Diagram class represents a flow diagram.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

// class
Diagram.prototype = {}

Remarks

A diagram can contain connected nodes and links. Nodes are instances of DiagramNode-derived classes. Nodes are stored in the nodes collection. Links in MindFusion.Diagramming for JavaScript are instances of the DiagramLink class and are stored in the links collection.

Managing items

Items can be created by using the new operator and added to the diagram by means of the addItem method. Items are deleted by using the deleteItem method of the Diagram class. There are shortcut methods provided by the diagram's Factory object that can be used to create an item and add it to the diagram with just one method call. - they are createShapeNode and createDiagramLink.

Controlling Users' Actions

Users actions can be validated by handling various events, fired while items are being created, modified or deleted. The setInplaceEdit/getInplaceEdit methods control whether the user is allowed to do some in-place editing of items.

Inheritance Hierarchy

See Also

Diagram Members


MindFusion.Diagramming.Diagram Members

Diagram Members
Constructors Fields Methods
[image]

The Diagram class represents a flow diagram.

The following tables list the members exposed by the Diagram type.

Public Constructors

Name | Description
Diagram | Initializes a new instance of the Diagram class.

Public Fields

Name | Description
items | A list of DiagramItem objects.
links | A list of DiagramLink objects.
nodes | A list of DiagramNode objects.
preventDefaultTouch | Indicates whether to stop default touch behavior of browsers in order to allow interactive drawing and modification of diagram items.

Public Methods

Name | Description
addEventListener | Registers a single event listener on the Diagram.
addItem | Adds an item to the Diagram.
alignPointToGrid | Returns a point of the alignment grid nearest to the one passed as an argument.
arrange | Arranges the diagram with the given layout.
arrangeLinkLabels | Rearranges link labels whose AutoArrange property is enabled.
beginEdit | Begins in-place editing of the specified object.
cancelCompositeOperation | Stops recording undo/redo commands into a CompositeCommand and discards the records created so far.
clearAll | Removes all items from the diagram [image] .
commitCompositeOperation | Stops recording undo/redo commands into a CompositeCommand and saves the composite in the history queue.
copyToClipboard | Copies the current selection of items to the clipboard.
create | Creates and initializes a new Diagram from the specified element. This method is static and can be called without creating an instance of the class.
cutToClipboard | Cuts the currently selected items to the clipboard.
dispose | Overrides Component.Dispose
endEdit | Exits the in-place editing mode and either accepts or rejects the changes made to the item's text.
executeCommand | Executes the specified command on this diagram.
find | Returns the specified Diagram object. This member is static and can be invoked without creating an instance of the class.
fromJson | Deserializes the diagram from a JSON string.
getActiveItem | Gets the active diagram element.
getAdjustmentHandlesSize | Gets the size of adjustment handles that appear around selected items.
getAlignToGrid | Gets a value indicating whether the diagram items should be aligned to a grid.
getAllowInplaceEdit | Gets a value indicating whether in-place editing of the text of objects is enabled.
getAllowMultipleResize | Gets a value indicating whether multiple selected nodes can be resized simultaneously.
getAllowUnconnectedLinks | Gets a value indicating whether users are allowed to draw links that are not connected to any node.
getAutoResize | Gets a value indicating whether the document area should be resized automatically so it fits the diagram contents.
getAutoScroll | Gets a value indicating whether auto scrolling of the document area is enabled.
getAutoScrollAmount | Gets the amount by which to auto-scroll the view when the mouse leaves the view boundaries while drawing.
getBackBrush | Gets the object used for painting the diagram background.
getBackgroundImageAlign | Gets a value indicating how the background image is positioned.
getBackgroundImageContent | Gets the Base64-encoded data of the background image.
getBackgroundImageUrl | Gets the URL of the image displayed as background of this diagram.
getBehavior | Gets a value indicating how the control responds to user actions.
getContentBounds | Returns the smallest rectangle that bounds all diagram items.
getCrossingRadius | Gets the radius length of decorations displayed at link intersection points.
getCustomLinkType | Gets the type of a MindFusion.Diagramming.DiagramLink derived class whose instance should be created when a user starts drawing.
getCustomNodeType | Gets the type of a MindFusion.Diagramming.DiagramNode derived class whose instance should be created when a user starts drawing.
getDefaultShape | Gets the default Shape of shapeNode-s.
getDelKeyAction | Gets a value that specifies what action should be performed when the user hits the Del key.
getDirty | Gets a value indicating whether the diagram has changed since loading it.
getDynamicLinks | Gets the default value for the Dynamic property of new links.
getEnabled | Checks if mouse events are enabled.
getExpandOnIncoming | Gets a value indicating the link direction in which tree branches are expanded.
getFactory | Gets a Factory instance that lets you add programmatically new items to the diagram.
getFont | Gets the font for text written on diagram items.
getGridColor | Gets the color of the grid points.
getGridOffsetX | Gets the horizontal offset of the first point of the alignment grid.
getGridOffsetY | Gets the vertical offset of the first point of the alignment grid.
getGridPointSize | Gets the size of shapes used to represent grid points.
getGridSizeX | Gets the horizontal distance between adjacent grid points.
getGridSizeY | Gets the vertical distance between adjacent grid points.
getGridStyle | Gets the visual style of the alignment grid.
getItemAt | Finds and returns the topmost DiagramItem found at the specified location.
getItems | Returns the array of all items in this diagram.
getItemsAt | Finds and returns an array of the diagram items found at the specified location.
getLaneGrid | Gets the lane grid.
getLeftButtonActions | Gets a combination of flags that specify what actions can be performed via the left mouse button.
getLinkAt | Finds and returns the topmost DiagramLink found at the specified location.
getLinkBaseShape | Gets the shape displayed at the base of new links.
getLinkBaseShapeSize | Gets the default size of the base of new links.
getLinkBrush | Gets the default fill of links.
getLinkCrossings | Gets a value indicating how to render the intersection points where two links cross each other.
getLinkHeadShape | Gets the shape displayed as head of new links.
getLinkHeadShapeSize | Gets the default size of arrowheads.
getLinkHitDistance | Gets a value specifying how far from a link a click is still considered a hit.
getLinkPen | Gets the default stroke of links.
getLinks | Returns the array of all links in this diagram.
getLinksAt | Finds and returns an array of the diagram DiagramLink-s found at the specified location.
getLinkShape | Gets the initial shape assigned to new links.
getLinkTextStyle | Gets the default placement and orientation for links' text.
getMagnifierEnabled | Gets a value indicating whether the magnifier tool is currently enabled.
getMagnifierFactor | Gets the zoom factor of the magnifier tool.
getMagnifierFrameColor | Gets the color of the magnifier tool's frame.
getMagnifierFrameThickness | Gets the thickness of the magnifier frame.
getMagnifierHeight | Gets the height of the magnifier tool.
getMagnifierSecondaryFrameColor | Gets the color of the magnifier tool's secondary frame.
getMagnifierShading | Gets a value indicating whether to enhance the effect of a magnifier lense by using a gradient shading.
getMagnifierShape | Gets a reference to the geometric shape definition of the magnifier tool.
getMagnifierWidth | Gets the width of the magnifier tool.
getMiddleButtonActions | Gets a combination of flags that specify what actions can be performed via the middle mouse button.
getModificationStart | Gets how users can start modifying diagram items.
getModifierKeyActions | Gets an object, which allows changing the function of keyboard modifier keys such as Ctrl and Alt.
getNearestNode | Returns the node nearest to the specified point.
getNodeAt | Finds and returns the topmost DiagramNode found at the specified location.
getNodeEffects | Gets an array with all effects applied to the nodes of this diagram.
getNodes | Returns the array of all nodes in this diagram.
getNodesAt | Finds and returns an array of the DiagramNode-s found at the specified location.
getNodesExpandable | Gets a value indicating whether newly created nodes can be expanded.
getRightButtonActions | Gets a combination of flags that specify what actions can be performed via the right mouse button.
getRoundedLinks | Gets a value indicating whether the joints between segments of Polyline and Cascading links should be rounded.
getRoundedLinksRadius | Gets the radius of joint arcs of rounded links' segments.
getRouteLinks | Gets a value indicating whether links should avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes.
getRouteMargin | Gets the minimal distance between nodes and auto-routed links.
getScrollX | Gets the diagram's horizontal scroll position.
getScrollY | Gets the diagram's vertical scroll position.
getScrollZoneSize | Gets the size of the auto scroll zone near the edges of the control.
getSelection | Gets a Selection instance that represents the selection of items in this diagram.
getShadowOffsetX | Gets the horizontal offset of objects' shadows.
getShadowOffsetY | Gets the vertical offset of objects' shadows.
getShadowsStyle | Gets the style for rendering shadows.
getShapeBrush | Gets the default fill of shape nodes.
getShapeLibraryLocation | Gets the location of a shape library file containing custom shape definitions.It can be set to a full URL of the file, or a relative file path.
getShapePen | Gets the default stroke of shape node-s.
getShowAnchors | Gets a value indicating whether and when anchor point marks are displayed.
getShowDisabledHandles | Gets a value indicating whether adjustment handles are painted when they are disabled.
getShowGrid | Gets a value indicating whether the alignment grid is visible.
getShowLaneGrid | Gets a value indicating whether the lane grid is visible.
getStyle | Gets the style associated with this diagram.
getTag | Gets custom data associated with this diagram.
getTheme | Gets the theme associated with this diagram.
getTooltipDelay | Gets the delay before a tooltip is shown.
getUndoEnabled | Gets a value indicating whether saving action records for later undo is enabled.
getViewport | Returns the visible portion of the diagram area.
getVirtualScroll | Gets a value indicating whether virtual scroll mode is enabled.
initialize | Overrides Component.Initialize
isItemInteractive | Checks if the specified item can be modified interactively.
isItemVisible | Checks if the specified item is currently visible.
loadFromXml | Loads the diagram from an XML file.
pasteFromClipboard | Overloaded.
raiseClicked | Raises an event which notifies that a Diagram item has been clicked.
raiseCreated | Overloaded.
raiseDeleted | Raises an event which notifies that a Diagram item has been deleted.
raiseDeselected | Raises an event which notifies that a Diagram item has been deselected.
raiseDoubleClicked | Raises an event which notifies that a Diagram item has been double-clicked.
raiseEvent | Raises an event.
raiseModified | Raises an event which notifies that a Diagram item has been modified.
raiseSelected | Raises an event which notifies that a Diagram item has been selected.
redo | Executes again an action saved in the command history.
registerForSubmit | Registers an onsubmit handler for the Diagram's parent html form to flush postback data.
removeEventListener | Removes a single event listener attached to the Diagram.
removeItem | Removes the specified item from the Diagram.
resizeToFitItem | Resize the document extents so that the specified item is contained within.
resizeToFitItems | Resizes the document scrollable area so that it fits all diagram items.
routeAllLinks | Routes all links in the diagram in such a way they do not cross nodes.
scrollTo | Scrolls the diagram to the specified point.
setAdjustmentHandlesSize | Sets the size of adjustment handles that appear around selected items.
setAlignToGrid | Sets a value indicating whether the diagram items should be aligned to a grid.
setAllowInplaceEdit | Sets a value indicating whether in-place editing of the text of objects is enabled.
setAllowMultipleResize | Sets a value indicating whether multiple selected nodes can be resized simultaneously.
setAllowUnconnectedLinks | Sets a value indicating whether users are allowed to draw links that are not connected to any node.
setAutoResize | Sets a value indicating whether the document area should be resized automatically so it fits the diagram contents.
setAutoScroll | Sets a value indicating whether auto scrolling of the document area is enabled.
setAutoScrollAmount | Sets the amount by which to auto-scroll the view when the mouse leaves the view boundaries while drawing.
setBackBrush | Sets an object used for painting the diagram background.
setBackgroundImageAlign | Sets a value indicating how the background image is positioned.
setBackgroundImageContent | Sets the Base64-encoded data of the background image.
setBackgroundImageUrl | Sets the URL of the image displayed as background of this diagram.
setBehavior | Sets a value indicating how the control responds to user actions.
setCrossingRadius | Sets the radius length of decorations displayed at link intersection points.
setCustomLinkType | Sets the type of a MindFusion.Diagramming.DiagramLink derived class whose instance should be created when a user starts drawing.
setCustomNodeType | Sets the type of a MindFusion.Diagramming.DiagramNode derived class whose instance should be created when a user starts drawing.
setDefaultShape | Sets the default shape of shape nodes.
setDelKeyAction | Sets a value that specifies what action should be performed when the user hits the Del key.
setDirty | Sets a value indicating whether the diagram has changed since loading it.
setDynamicLinks | Sets the default value for the Dynamic property of new links.
setEnabled | Enables or disables handling of mouse events.
setExpandOnIncoming | Sets a value indicating the link direction in which tree branches are expanded.
setFont | Sets the font for text written on DiagramItem-s.
setGridColor | Sets the color of the grid points.
setGridOffsetX | Sets the horizontal offset of the first point of the alignment grid.
setGridOffsetY | Sets the vertical offset of the first point of the alignment grid.
setGridPointSize | Sets the size of shapes used to represent grid points.
setGridSizeX | Sets the horizontal distance between adjacent grid points.
setGridSizeY | Sets the vertical distance between adjacent grid points.
setGridStyle | Sets the visual style of the alignment grid.
setLinkBaseShape | Sets the Shape displayed at the base of new links.
setLinkBaseShapeSize | Sets the default size of the base of new links.
setLinkBrush | Sets the default fill of links.
setLinkCrossings | Sets a value indicating how to render the intersection points where two links cross each other.
setLinkHeadShape | Sets the Shape displayed as head of new links.
setLinkHeadShapeSize | Sets the default size of arrowheads.
setLinkHitDistance | Sets a value specifying how far from a link a click is still considered a hit.
setLinkPen | Sets the default stroke of links.
setLinkShape | Sets the initial shape assigned to new links.
setLinkTextStyle | Sets the default placement and orientation for links' text.
setMagnifierEnabled | Sets a value indicating whether the magnifier tool is currently enabled.
setMagnifierFactor | Sets the zoom factor of the magnifier tool.
setMagnifierFrameColor | Sets the color of the magnifier tool's frame.
setMagnifierFrameThickness | Sets the thickness of the magnifier frame.
setMagnifierHeight | Sets the height of the magnifier tool.
setMagnifierSecondaryFrameColor | Sets the color of the magnifier tool's secondary frame.
setMagnifierShading | Sets a value indicating whether to enhance the effect of a magnifier lense by using a gradient shading.
setMagnifierShape | Sets a reference to the geometric shape definition of the magnifier tool.
setMagnifierWidth | Sets the width of the magnifier tool.
setMiddleButtonActions | Sets a combination of flags that specify what actions can be performed via the middle mouse button.
setModificationStart | Sets how users can start modifying diagram items.
setNodesExpandable | Sets a value indicating whether newly created nodes can be collapsed and expanded by users.
setRightButtonActions | Sets a combination of flags that specify what actions can be performed via the right mouse button.
setRoundedLinks | Sets a value indicating whether the joints between segments of Polyline and Cascading links should be rounded.
setRoundedLinksRadius | Sets the radius of joint arcs of rounded links' segments.
setRouteLinks | Sets a value indicating whether links should avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes.
setRouteMargin | Sets the minimal distance between nodes and auto-routed links.
setScroll | IZoomTarget implementation
setScrollX | Sets the diagram's horizontal scroll position.
setScrollY | Sets the diagram's vertical scroll position.
setScrollZoneSize | Sets the size of the auto scroll zone near the edges of the control.
setShadowOffsetX | Sets the horizontal offset of objects' shadows.
setShadowOffsetY | Sets the vertical offset of objects' shadows.
setShadowsStyle | Sets the style for rendering shadows.
setShapeBrush | Sets the default fill of shape nodes.
setShapeLibraryLocation | Sets the location of a shape library file containing custom shape definitions.It can be set to a full URL of the file, or a relative file path.
setShapePen | Sets the default stroke of shape nodes.
setShowAnchors | Sets a value indicating whether and when anchor point marks are displayed.
setShowDisabledHandles | Sets a value indicating whether adjustment handles are painted when they are disabled.
setShowGrid | Sets a value indicating whether the alignment grid is visible.
setShowLaneGrid | Sets a value indicating whether the lane grid is visible.
setStyle | Sets the style associated with this diagram.
setTag | Sets custom data associated with this diagram.
setTheme | Sets the theme associated with this diagram.
setTooltipDelay | Sets the delay before a tooltip is shown.
setUndoEnabled | Sets a value indicating whether saving action records for later undo is enabled.
setVirtualScroll | Enables or disables virtual scroll mode.
setZoomFactorPivot | Sets the zoom factor, preserving the on-screen position of the specified diagram point.
setZoomLevel | IZoomTarget implementation.
startCompositeOperation | Starts recording undo/redo commands into a CompositeCommand.
toJson | Serializes the diagram into a JSON string.
undo | Undoes an action saved in the command history.
zoomToFit | Zooms the view to fit the document contents in the Diagram client area.
zoomToRect | Zooms and scrolls the view to fit the specified document rectangle in the Diagram's visible area.

See Also

Diagram Class


MindFusion.Diagramming.Diagram Fields

Diagram Fields
[image]

Public Fields

Name | Description
items | A list of DiagramItem objects.
links | A list of DiagramLink objects.
nodes | A list of DiagramNode objects.
preventDefaultTouch | Indicates whether to stop default touch behavior of browsers in order to allow interactive drawing and modification of diagram items.

See Also

Diagram Class


MindFusion.Diagramming.Diagram.items Field

Diagram.items Field
[image]

A list of DiagramItem objects.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

var items

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.links Field

Diagram.links Field
[image]

A list of DiagramLink objects.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

var links

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.nodes Field

Diagram.nodes Field
[image]

A list of DiagramNode objects.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

var nodes

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.preventDefaultTouch Field

Diagram.preventDefaultTouch Field
[image]

Indicates whether to stop default touch behavior of browsers in order to allow interactive drawing and modification of diagram items.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

var preventDefaultTouch

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram Constructor

Diagram Constructor
[image]

Initializes a new instance of the Diagram class.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function Diagram (element)

Parameters

element
The Canvas DOM Element this Diagram is associated with.

See Also

Diagram Class


MindFusion.Diagramming.Diagram Methods

Diagram Methods
[image]

Public Methods

Name | Description
addEventListener | Registers a single event listener on the Diagram.
addItem | Adds an item to the Diagram.
alignPointToGrid | Returns a point of the alignment grid nearest to the one passed as an argument.
arrange | Arranges the diagram with the given layout.
arrangeLinkLabels | Rearranges link labels whose AutoArrange property is enabled.
beginEdit | Begins in-place editing of the specified object.
cancelCompositeOperation | Stops recording undo/redo commands into a CompositeCommand and discards the records created so far.
clearAll | Removes all items from the diagram [image] .
commitCompositeOperation | Stops recording undo/redo commands into a CompositeCommand and saves the composite in the history queue.
copyToClipboard | Copies the current selection of items to the clipboard.
create | Creates and initializes a new Diagram from the specified element. This method is static and can be called without creating an instance of the class.
cutToClipboard | Cuts the currently selected items to the clipboard.
dispose | Overrides Component.Dispose
endEdit | Exits the in-place editing mode and either accepts or rejects the changes made to the item's text.
executeCommand | Executes the specified command on this diagram.
find | Returns the specified Diagram object. This member is static and can be invoked without creating an instance of the class.
fromJson | Deserializes the diagram from a JSON string.
getActiveItem | Gets the active diagram element.
getAdjustmentHandlesSize | Gets the size of adjustment handles that appear around selected items.
getAlignToGrid | Gets a value indicating whether the diagram items should be aligned to a grid.
getAllowInplaceEdit | Gets a value indicating whether in-place editing of the text of objects is enabled.
getAllowMultipleResize | Gets a value indicating whether multiple selected nodes can be resized simultaneously.
getAllowUnconnectedLinks | Gets a value indicating whether users are allowed to draw links that are not connected to any node.
getAutoResize | Gets a value indicating whether the document area should be resized automatically so it fits the diagram contents.
getAutoScroll | Gets a value indicating whether auto scrolling of the document area is enabled.
getAutoScrollAmount | Gets the amount by which to auto-scroll the view when the mouse leaves the view boundaries while drawing.
getBackBrush | Gets the object used for painting the diagram background.
getBackgroundImageAlign | Gets a value indicating how the background image is positioned.
getBackgroundImageContent | Gets the Base64-encoded data of the background image.
getBackgroundImageUrl | Gets the URL of the image displayed as background of this diagram.
getBehavior | Gets a value indicating how the control responds to user actions.
getContentBounds | Returns the smallest rectangle that bounds all diagram items.
getCrossingRadius | Gets the radius length of decorations displayed at link intersection points.
getCustomLinkType | Gets the type of a MindFusion.Diagramming.DiagramLink derived class whose instance should be created when a user starts drawing.
getCustomNodeType | Gets the type of a MindFusion.Diagramming.DiagramNode derived class whose instance should be created when a user starts drawing.
getDefaultShape | Gets the default Shape of shapeNode-s.
getDelKeyAction | Gets a value that specifies what action should be performed when the user hits the Del key.
getDirty | Gets a value indicating whether the diagram has changed since loading it.
getDynamicLinks | Gets the default value for the Dynamic property of new links.
getEnabled | Checks if mouse events are enabled.
getExpandOnIncoming | Gets a value indicating the link direction in which tree branches are expanded.
getFactory | Gets a Factory instance that lets you add programmatically new items to the diagram.
getFont | Gets the font for text written on diagram items.
getGridColor | Gets the color of the grid points.
getGridOffsetX | Gets the horizontal offset of the first point of the alignment grid.
getGridOffsetY | Gets the vertical offset of the first point of the alignment grid.
getGridPointSize | Gets the size of shapes used to represent grid points.
getGridSizeX | Gets the horizontal distance between adjacent grid points.
getGridSizeY | Gets the vertical distance between adjacent grid points.
getGridStyle | Gets the visual style of the alignment grid.
getItemAt | Finds and returns the topmost DiagramItem found at the specified location.
getItems | Returns the array of all items in this diagram.
getItemsAt | Finds and returns an array of the diagram items found at the specified location.
getLaneGrid | Gets the lane grid.
getLeftButtonActions | Gets a combination of flags that specify what actions can be performed via the left mouse button.
getLinkAt | Finds and returns the topmost DiagramLink found at the specified location.
getLinkBaseShape | Gets the shape displayed at the base of new links.
getLinkBaseShapeSize | Gets the default size of the base of new links.
getLinkBrush | Gets the default fill of links.
getLinkCrossings | Gets a value indicating how to render the intersection points where two links cross each other.
getLinkHeadShape | Gets the shape displayed as head of new links.
getLinkHeadShapeSize | Gets the default size of arrowheads.
getLinkHitDistance | Gets a value specifying how far from a link a click is still considered a hit.
getLinkPen | Gets the default stroke of links.
getLinks | Returns the array of all links in this diagram.
getLinksAt | Finds and returns an array of the diagram DiagramLink-s found at the specified location.
getLinkShape | Gets the initial shape assigned to new links.
getLinkTextStyle | Gets the default placement and orientation for links' text.
getMagnifierEnabled | Gets a value indicating whether the magnifier tool is currently enabled.
getMagnifierFactor | Gets the zoom factor of the magnifier tool.
getMagnifierFrameColor | Gets the color of the magnifier tool's frame.
getMagnifierFrameThickness | Gets the thickness of the magnifier frame.
getMagnifierHeight | Gets the height of the magnifier tool.
getMagnifierSecondaryFrameColor | Gets the color of the magnifier tool's secondary frame.
getMagnifierShading | Gets a value indicating whether to enhance the effect of a magnifier lense by using a gradient shading.
getMagnifierShape | Gets a reference to the geometric shape definition of the magnifier tool.
getMagnifierWidth | Gets the width of the magnifier tool.
getMiddleButtonActions | Gets a combination of flags that specify what actions can be performed via the middle mouse button.
getModificationStart | Gets how users can start modifying diagram items.
getModifierKeyActions | Gets an object, which allows changing the function of keyboard modifier keys such as Ctrl and Alt.
getNearestNode | Returns the node nearest to the specified point.
getNodeAt | Finds and returns the topmost DiagramNode found at the specified location.
getNodeEffects | Gets an array with all effects applied to the nodes of this diagram.
getNodes | Returns the array of all nodes in this diagram.
getNodesAt | Finds and returns an array of the DiagramNode-s found at the specified location.
getNodesExpandable | Gets a value indicating whether newly created nodes can be expanded.
getRightButtonActions | Gets a combination of flags that specify what actions can be performed via the right mouse button.
getRoundedLinks | Gets a value indicating whether the joints between segments of Polyline and Cascading links should be rounded.
getRoundedLinksRadius | Gets the radius of joint arcs of rounded links' segments.
getRouteLinks | Gets a value indicating whether links should avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes.
getRouteMargin | Gets the minimal distance between nodes and auto-routed links.
getScrollX | Gets the diagram's horizontal scroll position.
getScrollY | Gets the diagram's vertical scroll position.
getScrollZoneSize | Gets the size of the auto scroll zone near the edges of the control.
getSelection | Gets a Selection instance that represents the selection of items in this diagram.
getShadowOffsetX | Gets the horizontal offset of objects' shadows.
getShadowOffsetY | Gets the vertical offset of objects' shadows.
getShadowsStyle | Gets the style for rendering shadows.
getShapeBrush | Gets the default fill of shape nodes.
getShapeLibraryLocation | Gets the location of a shape library file containing custom shape definitions.It can be set to a full URL of the file, or a relative file path.
getShapePen | Gets the default stroke of shape node-s.
getShowAnchors | Gets a value indicating whether and when anchor point marks are displayed.
getShowDisabledHandles | Gets a value indicating whether adjustment handles are painted when they are disabled.
getShowGrid | Gets a value indicating whether the alignment grid is visible.
getShowLaneGrid | Gets a value indicating whether the lane grid is visible.
getStyle | Gets the style associated with this diagram.
getTag | Gets custom data associated with this diagram.
getTheme | Gets the theme associated with this diagram.
getTooltipDelay | Gets the delay before a tooltip is shown.
getUndoEnabled | Gets a value indicating whether saving action records for later undo is enabled.
getViewport | Returns the visible portion of the diagram area.
getVirtualScroll | Gets a value indicating whether virtual scroll mode is enabled.
initialize | Overrides Component.Initialize
isItemInteractive | Checks if the specified item can be modified interactively.
isItemVisible | Checks if the specified item is currently visible.
loadFromXml | Loads the diagram from an XML file.
pasteFromClipboard | Overloaded.
raiseClicked | Raises an event which notifies that a Diagram item has been clicked.
raiseCreated | Overloaded.
raiseDeleted | Raises an event which notifies that a Diagram item has been deleted.
raiseDeselected | Raises an event which notifies that a Diagram item has been deselected.
raiseDoubleClicked | Raises an event which notifies that a Diagram item has been double-clicked.
raiseEvent | Raises an event.
raiseModified | Raises an event which notifies that a Diagram item has been modified.
raiseSelected | Raises an event which notifies that a Diagram item has been selected.
redo | Executes again an action saved in the command history.
registerForSubmit | Registers an onsubmit handler for the Diagram's parent html form to flush postback data.
removeEventListener | Removes a single event listener attached to the Diagram.
removeItem | Removes the specified item from the Diagram.
resizeToFitItem | Resize the document extents so that the specified item is contained within.
resizeToFitItems | Resizes the document scrollable area so that it fits all diagram items.
routeAllLinks | Routes all links in the diagram in such a way they do not cross nodes.
scrollTo | Scrolls the diagram to the specified point.
setAdjustmentHandlesSize | Sets the size of adjustment handles that appear around selected items.
setAlignToGrid | Sets a value indicating whether the diagram items should be aligned to a grid.
setAllowInplaceEdit | Sets a value indicating whether in-place editing of the text of objects is enabled.
setAllowMultipleResize | Sets a value indicating whether multiple selected nodes can be resized simultaneously.
setAllowUnconnectedLinks | Sets a value indicating whether users are allowed to draw links that are not connected to any node.
setAutoResize | Sets a value indicating whether the document area should be resized automatically so it fits the diagram contents.
setAutoScroll | Sets a value indicating whether auto scrolling of the document area is enabled.
setAutoScrollAmount | Sets the amount by which to auto-scroll the view when the mouse leaves the view boundaries while drawing.
setBackBrush | Sets an object used for painting the diagram background.
setBackgroundImageAlign | Sets a value indicating how the background image is positioned.
setBackgroundImageContent | Sets the Base64-encoded data of the background image.
setBackgroundImageUrl | Sets the URL of the image displayed as background of this diagram.
setBehavior | Sets a value indicating how the control responds to user actions.
setCrossingRadius | Sets the radius length of decorations displayed at link intersection points.
setCustomLinkType | Sets the type of a MindFusion.Diagramming.DiagramLink derived class whose instance should be created when a user starts drawing.
setCustomNodeType | Sets the type of a MindFusion.Diagramming.DiagramNode derived class whose instance should be created when a user starts drawing.
setDefaultShape | Sets the default shape of shape nodes.
setDelKeyAction | Sets a value that specifies what action should be performed when the user hits the Del key.
setDirty | Sets a value indicating whether the diagram has changed since loading it.
setDynamicLinks | Sets the default value for the Dynamic property of new links.
setEnabled | Enables or disables handling of mouse events.
setExpandOnIncoming | Sets a value indicating the link direction in which tree branches are expanded.
setFont | Sets the font for text written on DiagramItem-s.
setGridColor | Sets the color of the grid points.
setGridOffsetX | Sets the horizontal offset of the first point of the alignment grid.
setGridOffsetY | Sets the vertical offset of the first point of the alignment grid.
setGridPointSize | Sets the size of shapes used to represent grid points.
setGridSizeX | Sets the horizontal distance between adjacent grid points.
setGridSizeY | Sets the vertical distance between adjacent grid points.
setGridStyle | Sets the visual style of the alignment grid.
setLinkBaseShape | Sets the Shape displayed at the base of new links.
setLinkBaseShapeSize | Sets the default size of the base of new links.
setLinkBrush | Sets the default fill of links.
setLinkCrossings | Sets a value indicating how to render the intersection points where two links cross each other.
setLinkHeadShape | Sets the Shape displayed as head of new links.
setLinkHeadShapeSize | Sets the default size of arrowheads.
setLinkHitDistance | Sets a value specifying how far from a link a click is still considered a hit.
setLinkPen | Sets the default stroke of links.
setLinkShape | Sets the initial shape assigned to new links.
setLinkTextStyle | Sets the default placement and orientation for links' text.
setMagnifierEnabled | Sets a value indicating whether the magnifier tool is currently enabled.
setMagnifierFactor | Sets the zoom factor of the magnifier tool.
setMagnifierFrameColor | Sets the color of the magnifier tool's frame.
setMagnifierFrameThickness | Sets the thickness of the magnifier frame.
setMagnifierHeight | Sets the height of the magnifier tool.
setMagnifierSecondaryFrameColor | Sets the color of the magnifier tool's secondary frame.
setMagnifierShading | Sets a value indicating whether to enhance the effect of a magnifier lense by using a gradient shading.
setMagnifierShape | Sets a reference to the geometric shape definition of the magnifier tool.
setMagnifierWidth | Sets the width of the magnifier tool.
setMiddleButtonActions | Sets a combination of flags that specify what actions can be performed via the middle mouse button.
setModificationStart | Sets how users can start modifying diagram items.
setNodesExpandable | Sets a value indicating whether newly created nodes can be collapsed and expanded by users.
setRightButtonActions | Sets a combination of flags that specify what actions can be performed via the right mouse button.
setRoundedLinks | Sets a value indicating whether the joints between segments of Polyline and Cascading links should be rounded.
setRoundedLinksRadius | Sets the radius of joint arcs of rounded links' segments.
setRouteLinks | Sets a value indicating whether links should avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes.
setRouteMargin | Sets the minimal distance between nodes and auto-routed links.
setScroll | IZoomTarget implementation
setScrollX | Sets the diagram's horizontal scroll position.
setScrollY | Sets the diagram's vertical scroll position.
setScrollZoneSize | Sets the size of the auto scroll zone near the edges of the control.
setShadowOffsetX | Sets the horizontal offset of objects' shadows.
setShadowOffsetY | Sets the vertical offset of objects' shadows.
setShadowsStyle | Sets the style for rendering shadows.
setShapeBrush | Sets the default fill of shape nodes.
setShapeLibraryLocation | Sets the location of a shape library file containing custom shape definitions.It can be set to a full URL of the file, or a relative file path.
setShapePen | Sets the default stroke of shape nodes.
setShowAnchors | Sets a value indicating whether and when anchor point marks are displayed.
setShowDisabledHandles | Sets a value indicating whether adjustment handles are painted when they are disabled.
setShowGrid | Sets a value indicating whether the alignment grid is visible.
setShowLaneGrid | Sets a value indicating whether the lane grid is visible.
setStyle | Sets the style associated with this diagram.
setTag | Sets custom data associated with this diagram.
setTheme | Sets the theme associated with this diagram.
setTooltipDelay | Sets the delay before a tooltip is shown.
setUndoEnabled | Sets a value indicating whether saving action records for later undo is enabled.
setVirtualScroll | Enables or disables virtual scroll mode.
setZoomFactorPivot | Sets the zoom factor, preserving the on-screen position of the specified diagram point.
setZoomLevel | IZoomTarget implementation.
startCompositeOperation | Starts recording undo/redo commands into a CompositeCommand.
toJson | Serializes the diagram into a JSON string.
undo | Undoes an action saved in the command history.
zoomToFit | Zooms the view to fit the document contents in the Diagram client area.
zoomToRect | Zooms and scrolls the view to fit the specified document rectangle in the Diagram's visible area.

See Also

Diagram Class


MindFusion.Diagramming.Diagram.addEventListener Method

Diagram.addEventListener Method
[image]

Registers a single event listener on the Diagram.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function addEventListener (eventName, handler)

Parameters

eventName

The name of the event. See a list of supported events here.

handler
Represents the method that will handle the event specified with eventName.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Events Class
removeEventListener Method


MindFusion.Diagramming.Diagram.addItem Method

Diagram.addItem Method
[image]

Adds an item to the Diagram.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function addItem (item)

Parameters

item
The item to add.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.alignPointToGrid Method

Diagram.alignPointToGrid Method
[image]

Returns a point of the alignment grid nearest to the one passed as an argument.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function alignPointToGrid (point)

Parameters

point

A point specified in diagram coordinates.

Return Value

A point from the alignment grid.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.arrange Method

Diagram.arrange Method
[image]

Arranges the diagram with the given layout.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function arrange (layout)

Parameters

layout

The layout algorithm to apply.

Remarks

Available layouts are SpringLayout, TreeLayout, LayeredLayout.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.arrangeLinkLabels Method

Diagram.arrangeLinkLabels Method
[image]

Rearranges link labels whose AutoArrange property is enabled.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function arrangeLinkLabels ()

See Also

Diagram Members
Diagram Class
LinkLabel Class


MindFusion.Diagramming.Diagram.beginEdit Method

Diagram.beginEdit Method
[image]

Begins in-place editing of the specified object.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function beginEdit (item, point)

Parameters

item
The DiagramItem whose text should be edited.
point
A Point specifying where the in-place edit box should appear.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.cancelCompositeOperation Method

Diagram.cancelCompositeOperation Method
[image]

Stops recording undo/redo commands into a CompositeCommand and discards the records created so far.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function cancelCompositeOperation ()

Remarks

You must call either commitCompositeOperation or this method when the diagram modifications are done after a startCompositeOperation call.

See Also

Diagram Members
Diagram Class
UndoEnabled Property


MindFusion.Diagramming.Diagram.clearAll Method

Diagram.clearAll Method
[image]

Removes all items from the diagram [image] .

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function clearAll ()

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.commitCompositeOperation Method

Diagram.commitCompositeOperation Method
[image]

Stops recording undo/redo commands into a CompositeCommand and saves the composite in the history queue.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function commitCompositeOperation ()

Remarks

You must call either cancelCompositeOperation or this method when the diagram modifications are done after a startCompositeOperation call.

See Also

Diagram Members
Diagram Class
UndoEnabled Property


MindFusion.Diagramming.Diagram.copyToClipboard Method

Diagram.copyToClipboard Method
[image]

Copies the current selection of items to the clipboard.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function copyToClipboard ([systemClipboard])

Parameters

systemClipboard
Optional.

true to copy to the system clipboard, or false otherwise. The default value is false.

Remarks

The diagram control maintains its own local clipboard and items are copied to it by default. If you specify a true argument and running under browsers that allow access to the system clipboard, the items are copied to the system clipboard; in all other cases they are copied to the local clipboard. At the time of writing this, access to the system clipboard is supported only by Internet Explorer.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
cutToClipboard Method
pasteFromClipboard Method


MindFusion.Diagramming.Diagram.create Method

Diagram.create Method
[image]

Creates and initializes a new Diagram from the specified element. This method is static and can be called without creating an instance of the class.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function create (element)

Parameters

element

The DOM element that the diagram should be attached to.

Return Value

A Diagram object that represents the newly created diagram.

Remarks

This method is a shortcut method for Sys.Component.create and can be used to enable IntelliSense on the returned object.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.cutToClipboard Method

Diagram.cutToClipboard Method
[image]

Cuts the currently selected items to the clipboard.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function cutToClipboard ([systemClipboard])

Parameters

systemClipboard
Optional.

true to copy to the system clipboard, or false otherwise. The default value is false.

Remarks

The diagram control maintains its own local clipboard and items are copied to it by default. If you specify a true argument and running under browsers that allow access to the system clipboard, the items are copied to the system clipboard; in all other cases they are copied to the local clipboard. At the time of writing this, access to the system clipboard is supported only by Internet Explorer.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
copyToClipboard Method
pasteFromClipboard Method


MindFusion.Diagramming.Diagram.dispose Method

Diagram.dispose Method
[image]

Overrides Component.Dispose

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function dispose ()

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.endEdit Method

Diagram.endEdit Method
[image]

Exits the in-place editing mode and either accepts or rejects the changes made to the item's text.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function endEdit ([accept])

Parameters

accept
Optional.

true to accept changes made to text; false to reject them.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.executeCommand Method

Diagram.executeCommand Method
[image]

Executes the specified command on this diagram.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function executeCommand (command)

Parameters

command

The Command to execute.

Remarks

If undo/redo is enabled, the command is saved in the undo history or added to the active composite command.

AddItemCommand and RemoveItemCommand objects are created automatically by the control when adding or removing items, both programmatically or interactively. Calling this method explicitly could be necessary in order to save item's state for later undo using a ChangeItemCommand, or to run a custom operation represented by a class derived from Command.

Example

The following example shows the pattern that should be used to save the state of an item for later undo.

JavaScript [image] Copy Code

var ChangeItemCommand = MindFusion.Diagramming.ChangeItemCommand;
var DiagramNode = MindFusion.Diagramming.DiagramNode;

var diagram = $find("diagram");
var node = diagram.getActiveItem();
if (DiagramNode.isInstanceOfType(node))
{
var change = new ChangeItemCommand(diagram, node);
node.setText("new text");
node.setBrush("red");
diagram.executeCommand(change);
}

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
UndoEnabled Property
undo Method
startCompositeOperation Method


MindFusion.Diagramming.Diagram.find Method

Diagram.find Method
[image]

Returns the specified Diagram object. This member is static and can be invoked without creating an instance of the class.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function find (id, [parent])

Parameters

id

A string that contains the ID of the diagram to find.

parent
Optional.

The component or element that contains the diagram to find.

Return Value

A Diagram object that contains the diagram requested by id, if found; otherwise, null.

Remarks

This method is a shortcut method for Sys.Component.find and can be used to enable IntelliSense on the returned object.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.fromJson Method

Diagram.fromJson Method
[image]

Deserializes the diagram from a JSON string.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function fromJson (json)

Parameters

json

A string created by the toJson method.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getActiveItem Method

Diagram.getActiveItem Method
[image]

Gets the active diagram element.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getActiveItem ()

Return Value

The active item; null if no item is active.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getAdjustmentHandlesSize Method

Diagram.getAdjustmentHandlesSize Method
[image]

Gets the size of adjustment handles that appear around selected items.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getAdjustmentHandlesSize ()

Return Value

A number specifying the size of selection handles. The default value is 2.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getAlignToGrid Method

Diagram.getAlignToGrid Method
[image]

Gets a value indicating whether the diagram items should be aligned to a grid.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getAlignToGrid ()

Return Value

true if the diagram items should be aligned to a grid; otherwise, false.

Remarks

When the property is set to true, the sides of every newly created diagram item are aligned to the nearest grid points.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getAllowInplaceEdit Method

Diagram.getAllowInplaceEdit Method
[image]

Gets a value indicating whether in-place editing of the text of objects is enabled.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getAllowInplaceEdit ()

Return Value

true if in-place editing of the text of objects is enabled; otherwise, false.

Remarks

Specifies whether users are allowed to edit in-place text of diagram nodes. If enabled, a text-entry field appears at node's position when the node is double-clicked. In-place editing mode can be exited by clicking anywhere outside the text field.

To enter or exit in-place editing mode programmatically, use the beginEdit and endEdit methods of Diagram.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getAllowMultipleResize Method

Diagram.getAllowMultipleResize Method
[image]

Gets a value indicating whether multiple selected nodes can be resized simultaneously.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getAllowMultipleResize ()

Return Value

true to let the user resize multiple selected nodes; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getAllowUnconnectedLinks Method

Diagram.getAllowUnconnectedLinks Method
[image]

Gets a value indicating whether users are allowed to draw links that are not connected to any node.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getAllowUnconnectedLinks ()

Return Value

true to let the user draw unconnected links; otherwise, false.

Remarks

If the property is set to true, users will be able to draw links from or to any point of the document. Depending on which end of a link is unconnected, its Origin or Destination nodes will be set to a DummyNode instance.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getAutoResize Method

Diagram.getAutoResize Method
[image]

Gets a value indicating whether the document area should be resized automatically so it fits the diagram contents.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getAutoResize ()

Return Value

A member of the AutoResize enumeration indicating the auto resize method.

Remarks

If automatic resizing is enabled, the size of the document scrollable area is updated each time an item is created, deleted or moved by the end-user. To resize the diagram after programmatic changes, call the resizeToFitItems method.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Bounds Property
AutoScroll Property


MindFusion.Diagramming.Diagram.getAutoScroll Method

Diagram.getAutoScroll Method
[image]

Gets a value indicating whether auto scrolling of the document area is enabled.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getAutoScroll ()

Return Value

true if auto scrolling is enabled, otherwise false.

Remarks

If enabled, the control will scroll its content automatically when the user drags the mouse near the viewport edges. This works only if the diagram is placed inside a DIV whose overflow attribute is set to scroll or auto.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Bounds Property
AutoResize Property


MindFusion.Diagramming.Diagram.getAutoScrollAmount Method

Diagram.getAutoScrollAmount Method
[image]

Gets the amount by which to auto-scroll the view when the mouse leaves the view boundaries while drawing.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getAutoScrollAmount ()

Return Value

A number specifying the amount by which to auto-scroll.

See Also

Diagram Members
Diagram Class
AutoScroll Property


MindFusion.Diagramming.Diagram.getBackBrush Method

Diagram.getBackBrush Method
[image]

Gets the object used for painting the diagram background.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getBackBrush ()

Return Value

The object used for painting the background.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getBackgroundImageAlign Method

Diagram.getBackgroundImageAlign Method
[image]

Gets a value indicating how the background image is positioned.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getBackgroundImageAlign ()

Return Value

One of the ImageAlign enumeration values. The default is ImageAlign.TopLeft.

Remarks

The background image can be aligned to a corner, stretched, centered, or tiled to cover the control's area.

See Also

Diagram Members
Diagram Class
BackgroundImageUrl Property


MindFusion.Diagramming.Diagram.getBackgroundImageContent Method

Diagram.getBackgroundImageContent Method
[image]

Gets the Base64-encoded data of the background image.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getBackgroundImageContent ()

Return Value

The Base64-encoded data for the background image to be loaded.

See Also

Diagram Members
Diagram Class
BackgroundImageAlign Property


MindFusion.Diagramming.Diagram.getBackgroundImageUrl Method

Diagram.getBackgroundImageUrl Method
[image]

Gets the URL of the image displayed as background of this diagram.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getBackgroundImageUrl ()

Return Value

A string specifying the location of the image file.

See Also

Diagram Members
Diagram Class
BackgroundImageAlign Property


MindFusion.Diagramming.Diagram.getBehavior Method

Diagram.getBehavior Method
[image]

Gets a value indicating how the control responds to user actions.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getBehavior ()

Return Value

A member of the Behavior enumeration.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getContentBounds Method

Diagram.getContentBounds Method
[image]

Returns the smallest rectangle that bounds all diagram items.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getContentBounds ()

Return Value

A Rect instance specifying the smallest rectangle that bounds all diagram items.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
zoomToFit Method
setBounds Method


MindFusion.Diagramming.Diagram.getCrossingRadius Method

Diagram.getCrossingRadius Method
[image]

Gets the radius length of decorations displayed at link intersection points.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getCrossingRadius ()

Return Value

A number specifying the radius of the arcs drawn at link intersection points. The default value is 1.5.

Remarks

If LinkCrossings is set to Cut, link segments are cut at intersection points and this property defines the length of the break left between adjacent cut points. If LinkCrossings is set to Arcs, this property defines the radius of the arcs drawn over intersection points.

See Also

Diagram Members
Diagram Class
RoundedLinksRadius Property


MindFusion.Diagramming.Diagram.getCustomLinkType Method

Diagram.getCustomLinkType Method
[image]

Gets the type of a MindFusion.Diagramming.DiagramLink derived class whose instance should be created when a user starts drawing.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getCustomLinkType ()

Return Value

The type.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getCustomNodeType Method

Diagram.getCustomNodeType Method
[image]

Gets the type of a MindFusion.Diagramming.DiagramNode derived class whose instance should be created when a user starts drawing.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getCustomNodeType ()

Return Value

The type.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getDefaultShape Method

Diagram.getDefaultShape Method
[image]

Gets the default Shape of shapeNode-s.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getDefaultShape ()

Return Value

A ShapeNode object.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getDelKeyAction Method

Diagram.getDelKeyAction Method
[image]

Gets a value that specifies what action should be performed when the user hits the Del key.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getDelKeyAction ()

Return Value

A DelKeyAction Enumeration value.

Remarks

Depending on this property value, the control can delete all selected items, delete only the active item, or ignore the Del key press. When an item is deleted the nodeDeleted and linkDeleted events are raised.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getDirty Method

Diagram.getDirty Method
[image]

Gets a value indicating whether the diagram has changed since loading it.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getDirty ()

Return Value

A boolean value that indicates whether the diagram has changed.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getDynamicLinks Method

Diagram.getDynamicLinks Method
[image]

Gets the default value for the Dynamic property of new links.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getDynamicLinks ()

Return Value

true if dynamic links are enabled; otherwise, false. The default is false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getEnabled Method

Diagram.getEnabled Method
[image]

Checks if mouse events are enabled.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getEnabled ()

Return Value

true if handling of mouse events is enabled; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getExpandOnIncoming Method

Diagram.getExpandOnIncoming Method
[image]

Gets a value indicating the link direction in which tree branches are expanded.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getExpandOnIncoming ()

Return Value

true if trees are expanded in the direction of incoming links; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getFactory Method

Diagram.getFactory Method
[image]

Gets a Factory instance that lets you add programmatically new items to the diagram.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getFactory ()

Return Value

A Factory instance.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getFont Method

Diagram.getFont Method
[image]

Gets the font for text written on diagram items.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getFont ()

Return Value

The font used for drawing text on DiagramItem-s.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getGridColor Method

Diagram.getGridColor Method
[image]

Gets the color of the grid points.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getGridColor ()

Return Value

The color of the grid points.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getGridOffsetX Method

Diagram.getGridOffsetX Method
[image]

Gets the horizontal offset of the first point of the alignment grid.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getGridOffsetX ()

Return Value

The horizontal offset of the first point of the alignment grid.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getGridOffsetY Method

Diagram.getGridOffsetY Method
[image]

Gets the vertical offset of the first point of the alignment grid.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getGridOffsetY ()

Return Value

The vertical offset of the first point of the alignment grid.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getGridPointSize Method

Diagram.getGridPointSize Method
[image]

Gets the size of shapes used to represent grid points.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getGridPointSize ()

Return Value

The size of shapes used to represent grid points.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getGridSizeX Method

Diagram.getGridSizeX Method
[image]

Gets the horizontal distance between adjacent grid points.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getGridSizeX ()

Return Value

The horizontal distance between adjacent grid points.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getGridSizeY Method

Diagram.getGridSizeY Method
[image]

Gets the vertical distance between adjacent grid points.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getGridSizeY ()

Return Value

The vertical distance between adjacent grid points.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getGridStyle Method

Diagram.getGridStyle Method
[image]

Gets the visual style of the alignment grid.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getGridStyle ()

Return Value

One of the GridStyle enumeration values.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getItemAt Method

Diagram.getItemAt Method
[image]

Finds and returns the topmost DiagramItem found at the specified location.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getItemAt (point, [onlyInteractive])

Parameters

point

A Point instance identifying a diagram location.

onlyInteractive
Optional.

true to return only items that can be interacted with; otherwise, false.

Return Value

The topmost DiagramItem found at the given location or null if no DiagramItem has been found.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getItems Method

Diagram.getItems Method
[image]

Returns the array of all items in this diagram.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getItems ()

Return Value

Array of all DiagramItem instances in the diagram.

Remarks

This collection gives you access to all items contained in this diagram. You cannot add or remove items directly through it, but must use the addItem and removeItem methods instead.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getItemsAt Method

Diagram.getItemsAt Method
[image]

Finds and returns an array of the diagram items found at the specified location.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getItemsAt (point)

Parameters

point

instance identifying a location in the diagram.

Return Value

Array of the DiagramItem-s found at the given location or null if no items have been found. The items are arranged according to their Z-index.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getLaneGrid Method

Diagram.getLaneGrid Method
[image]

Gets the lane grid.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getLaneGrid ()

Return Value

An instance of the Grid class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getLeftButtonActions Method

Diagram.getLeftButtonActions Method
[image]

Gets a combination of flags that specify what actions can be performed via the left mouse button.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getLeftButtonActions ()

Return Value

A member of the MouseButtonActions enumeration.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getLinkAt Method

Diagram.getLinkAt Method
[image]

Finds and returns the topmost DiagramLink found at the specified location.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getLinkAt (point)

Parameters

point

A Point instance identifying a diagram location.

Return Value

The topmost DiagramLink found at the given location or null if no DiagramLink has been found.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getLinkBaseShape Method

Diagram.getLinkBaseShape Method
[image]

Gets the shape displayed at the base of new links.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getLinkBaseShape ()

Return Value

A Shape instance that represents an arrowhead shape.

Remarks

This property specifies the default shape displayed as arrowhead at the links' origin points. The Shapes class exposes several predefined shapes as static members.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getLinkBaseShapeSize Method

Diagram.getLinkBaseShapeSize Method
[image]

Gets the default size of the base of new links.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getLinkBaseShapeSize ()

Return Value

A number that specifies the size. The default is 5.

Remarks

The property specifies the size of the graphical shapes that are displayed at the start of new DiagramLink-s, for example, at the beginning of the links.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getLinkBrush Method

Diagram.getLinkBrush Method
[image]

Gets the default fill of links.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getLinkBrush ()

Return Value

An object identifying the fill of links.

Remarks

The property provides a default value for the brush, with which an arrowhead's interior is filled.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getLinkCrossings Method

Diagram.getLinkCrossings Method
[image]

Gets a value indicating how to render the intersection points where two links cross each other.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getLinkCrossings ()

Return Value

A member of the LinkCrossings enumeration. The default value is Straight.

Remarks

Intersection points where links cross each other's paths can be rendered as arcs or cuts, depending on the value of this property. The diagram z-order defines which links jump over the others or which links are cut by the others. If LinkCrossings is set to Arcs, links with higher ZIndex jump over those with lower ZIndex. If set to Cut, segments of links at lower z-position are cut by links at higher z-position. Radius of arcs and cuts can be set via the CrossingRadius property.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
RouteLinks Property
RoundedLinks Property


MindFusion.Diagramming.Diagram.getLinkHeadShape Method

Diagram.getLinkHeadShape Method
[image]

Gets the shape displayed as head of new links.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getLinkHeadShape ()

Return Value

A Shape instance that represents an arrowhead shape. The default is Arrow.

Remarks

This property specifies the default shape displayed as arrowhead at the links' end points. The Shapes class exposes several predefined shapes as static members.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getLinkHeadShapeSize Method

Diagram.getLinkHeadShapeSize Method
[image]

Gets the default size of arrowheads.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getLinkHeadShapeSize ()

Return Value

A number that measures the size. The default is 5.

Remarks

The property specifies how big the shapes of new arrowheads are.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getLinkHitDistance Method

Diagram.getLinkHitDistance Method
[image]

Gets a value specifying how far from a link a click is still considered a hit.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getLinkHitDistance ()

Return Value

A value specifying how far from a link a click is still considered a hit.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getLinkPen Method

Diagram.getLinkPen Method
[image]

Gets the default stroke of links.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getLinkPen ()

Return Value

A string value specifying the stroke of links.

Remarks

This property specifies the default value for the pen of new links.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getLinks Method

Diagram.getLinks Method
[image]

Returns the array of all links in this diagram.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getLinks ()

Return Value

Array of all DiagramLink instances in the diagram.

Remarks

You cannot add or remove links directly through this array, but must use the addItem and removeItem methods instead.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getLinksAt Method

Diagram.getLinksAt Method
[image]

Finds and returns an array of the diagram DiagramLink-s found at the specified location.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getLinksAt (point)

Parameters

point

instance identifying a diagram location.

Return Value

Array of the DiagramLink-s found at the given location or null if no DiagramLink-s have been found. The links are arranged according to their Z-index.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getLinkShape Method

Diagram.getLinkShape Method
[image]

Gets the initial shape assigned to new links.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getLinkShape ()

Return Value

One of the LinkShape enumeration values.

See Also

Diagram Members
Diagram Class
RoundedLinks Property


MindFusion.Diagramming.Diagram.getLinkTextStyle Method

Diagram.getLinkTextStyle Method
[image]

Gets the default placement and orientation for links' text.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getLinkTextStyle ()

Return Value

A member of the LinkTextStyle enumeration.

Remarks

The value of this property is used to initialize the TextStyle property of new links.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getMagnifierEnabled Method

Diagram.getMagnifierEnabled Method
[image]

Gets a value indicating whether the magnifier tool is currently enabled.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getMagnifierEnabled ()

Return Value

true if the magnifier is enabled, otherwise false.

Remarks

The magnifier tool can be alternatively enabled on-demand through a modifier key or a mouse button.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getMagnifierFactor Method

Diagram.getMagnifierFactor Method
[image]

Gets the zoom factor of the magnifier tool.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getMagnifierFactor ()

Return Value

A number specifying the zoom factor of the magnifier tool.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getMagnifierFrameColor Method

Diagram.getMagnifierFrameColor Method
[image]

Gets the color of the magnifier tool's frame.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getMagnifierFrameColor ()

Return Value

The color of the magnifier tool's frame.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getMagnifierFrameThickness Method

Diagram.getMagnifierFrameThickness Method
[image]

Gets the thickness of the magnifier frame.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getMagnifierFrameThickness ()

Return Value

A number specifying the thickness of the magnifier frame.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getMagnifierHeight Method

Diagram.getMagnifierHeight Method
[image]

Gets the height of the magnifier tool.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getMagnifierHeight ()

Return Value

A number specifying the height of the magnifier tool.

See Also

Diagram Members
Diagram Class
MagnifierWidth Property


MindFusion.Diagramming.Diagram.getMagnifierSecondaryFrameColor Method

Diagram.getMagnifierSecondaryFrameColor Method
[image]

Gets the color of the magnifier tool's secondary frame.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getMagnifierSecondaryFrameColor ()

Return Value

The color of the magnifier tool's secondary frame.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getMagnifierShading Method

Diagram.getMagnifierShading Method
[image]

Gets a value indicating whether to enhance the effect of a magnifier lense by using a gradient shading.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getMagnifierShading ()

Return Value

true if the shading is enabled, otherwise false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getMagnifierShape Method

Diagram.getMagnifierShape Method
[image]

Gets a reference to the geometric shape definition of the magnifier tool.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getMagnifierShape ()

Return Value

An instance of the Shape class whose outline definition should be used as magnifier's shape.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getMagnifierWidth Method

Diagram.getMagnifierWidth Method
[image]

Gets the width of the magnifier tool.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getMagnifierWidth ()

Return Value

A number specifying the width of the magnifier tool.

See Also

Diagram Members
Diagram Class
MagnifierHeight Property


MindFusion.Diagramming.Diagram.getMiddleButtonActions Method

Diagram.getMiddleButtonActions Method
[image]

Gets a combination of flags that specify what actions can be performed via the middle mouse button.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getMiddleButtonActions ()

Return Value

A member of the MouseButtonActions enumeration.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getModificationStart Method

Diagram.getModificationStart Method
[image]

Gets how users can start modifying diagram items.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getModificationStart ()

Return Value

A member of the ModificationStart enumeration. The default is SelectedOnly.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getModifierKeyActions Method

Diagram.getModifierKeyActions Method
[image]

Gets an object, which allows changing the function of keyboard modifier keys such as Ctrl and Alt.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getModifierKeyActions ()

Return Value

An instance of the ModifierKeyActions class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getNearestNode Method

Diagram.getNearestNode Method
[image]

Returns the node nearest to the specified point.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getNearestNode (point, maxDistance, ignored)

Parameters

point

A point in the diagram.

maxDistance

The maximum distance from the point at which to look for nodes.

ignored

A node that should be ignored.

Return Value

The DiagramNode nearest to the specified point.

Remarks

The last argument is useful when calling this method from nodeCreated and nodeModified handlers and the affected node should not be included in the search.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getNodeAt Method

Diagram.getNodeAt Method
[image]

Finds and returns the topmost DiagramNode found at the specified location.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getNodeAt (point, [onlyInteractive])

Parameters

point

A Point instance identifying a diagram location.

onlyInteractive
Optional.

true to return only items that can be interacted with; otherwise, false.

Return Value

The topmost DiagramNode found at the given location or null if no DiagramNode has been found.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getNodeEffects Method

Diagram.getNodeEffects Method
[image]

Gets an array with all effects applied to the nodes of this diagram.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getNodeEffects ()

Return Value

An array with all node effects.

See Also

Diagram Members
Diagram Class
DiagramNode.getEffects Method


MindFusion.Diagramming.Diagram.getNodes Method

Diagram.getNodes Method
[image]

Returns the array of all nodes in this diagram.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getNodes ()

Return Value

Array of all DiagramNode instances in the diagram.

Remarks

You cannot add or remove nodes directly through this array, but must use the addItem and removeItem methods instead.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getNodesAt Method

Diagram.getNodesAt Method
[image]

Finds and returns an array of the DiagramNode-s found at the specified location.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getNodesAt (point)

Parameters

point

instance identifying a diagram location.

Return Value

Array of the DiagramNode-s found at the given location or null if no DiagramNode-s have been found. The nodes are arranged according to their Z-index.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getNodesExpandable Method

Diagram.getNodesExpandable Method
[image]

Gets a value indicating whether newly created nodes can be expanded.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getNodesExpandable ()

Return Value

A boolean value assigned to the Expandable property of new nodes.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getRightButtonActions Method

Diagram.getRightButtonActions Method
[image]

Gets a combination of flags that specify what actions can be performed via the right mouse button.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getRightButtonActions ()

Return Value

A member of the MouseButtonActions enumeration.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getRoundedLinks Method

Diagram.getRoundedLinks Method
[image]

Gets a value indicating whether the joints between segments of Polyline and Cascading links should be rounded.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getRoundedLinks ()

Return Value

true to draw rounded segment joints; otherwise, false. The default value is false.

Remarks

The value of this property is considered when drawing links whose Shape is set to Polyline or Cascading. If the property is enabled, the joins between the segments of all such links are drawn as arcs, whose radius equals the value of RoundedLinksRadius.

See Also

Diagram Members
Diagram Class
LinkCrossings Property


MindFusion.Diagramming.Diagram.getRoundedLinksRadius Method

Diagram.getRoundedLinksRadius Method
[image]

Gets the radius of joint arcs of rounded links' segments.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getRoundedLinksRadius ()

Return Value

A number specifying the radius length. The default value is 2.

Remarks

The value of this property is used when RoundedLinks is enabled. It specifies the radius of the arcs drawn as joins between link segments.

See Also

Diagram Members
Diagram Class
CrossingRadius Property


MindFusion.Diagramming.Diagram.getRouteLinks Method

Diagram.getRouteLinks Method
[image]

Gets a value indicating whether links should avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getRouteLinks ()

Return Value

true to route links; otherwise, false. The default is false.

See Also

Diagram Members
Diagram Class
LinkCrossings Property


MindFusion.Diagramming.Diagram.getRouteMargin Method

Diagram.getRouteMargin Method
[image]

Gets the minimal distance between nodes and auto-routed links.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getRouteMargin ()

Return Value

A value specifying distance in the current MeasureUnit; default is 8.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getScrollX Method

Diagram.getScrollX Method
[image]

Gets the diagram's horizontal scroll position.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getScrollX ()

Return Value

A number specifying the horizontal scroll position in the current unit of measure.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getScrollY Method

Diagram.getScrollY Method
[image]

Gets the diagram's vertical scroll position.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getScrollY ()

Return Value

A number specifying the vertical scroll position in the current unit of measure.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getScrollZoneSize Method

Diagram.getScrollZoneSize Method
[image]

Gets the size of the auto scroll zone near the edges of the control.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getScrollZoneSize ()

Return Value

An integer specifying the size in pixels of the area near the view edges where auto-scrolling is triggered.

See Also

Diagram Members
Diagram Class
AutoScroll Property


MindFusion.Diagramming.Diagram.getSelection Method

Diagram.getSelection Method
[image]

Gets a Selection instance that represents the selection of items in this diagram.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getSelection ()

Return Value

An instance of the Selection class representing the current selection.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getShadowOffsetX Method

Diagram.getShadowOffsetX Method
[image]

Gets the horizontal offset of objects' shadows.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getShadowOffsetX ()

Return Value

A number specifying the shadow's horizontal offset.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getShadowOffsetY Method

Diagram.getShadowOffsetY Method
[image]

Gets the vertical offset of objects' shadows.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getShadowOffsetY ()

Return Value

A number specifying the shadow's vertical offset.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getShadowsStyle Method

Diagram.getShadowsStyle Method
[image]

Gets the style for rendering shadows.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getShadowsStyle ()

Return Value

A member of the ShadowsStyle enumeration. The default value is ShadowsStyle.OneLevel.

Remarks

This property specifies how the shadows of diagram items are drawn. If its value is None no shadows are painted. OneLevel makes all shadows paint on the lowest z-level, not covering any items. Thus the diagram items will seem to appear on the same z-level. ZOrder makes the shadow paint immediately under their items, possibly covering other items. This style gives more 3D-like outlook to the diagram.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getShapeBrush Method

Diagram.getShapeBrush Method
[image]

Gets the default fill of shape nodes.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getShapeBrush ()

Return Value

An object identifying the fill of shape nodes.

Remarks

The property provides a default value for the brush, with which a node' interior is filled.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getShapeLibraryLocation Method

Diagram.getShapeLibraryLocation Method
[image]

Gets the location of a shape library file containing custom shape definitions.It can be set to a full URL of the file, or a relative file path.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getShapeLibraryLocation ()

Return Value

The location of a shape library file containing custom shape definitions.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getShapePen Method

Diagram.getShapePen Method
[image]

Gets the default stroke of shape node-s.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getShapePen ()

Return Value

A string value specifying the stroke of ShapeNode-s.

Remarks

This property provides a default value for the pen with which shape nodes border lines are painted.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getShowAnchors Method

Diagram.getShowAnchors Method
[image]

Gets a value indicating whether and when anchor point marks are displayed.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getShowAnchors ()

Return Value

One of the ShowAnchors enumeration values.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getShowDisabledHandles Method

Diagram.getShowDisabledHandles Method
[image]

Gets a value indicating whether adjustment handles are painted when they are disabled.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getShowDisabledHandles ()

Return Value

true if disabled handles are displayed, or false otherwise. The default is true.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getShowGrid Method

Diagram.getShowGrid Method
[image]

Gets a value indicating whether the alignment grid is visible.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getShowGrid ()

Return Value

true if the alignment grid is visible; otherwise, false.

Remarks

If it is visible, the grid is painted as either a matrix of points or crossing horizontal and vertical lines. That depends on the value of GridStyle.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getShowLaneGrid Method

Diagram.getShowLaneGrid Method
[image]

Gets a value indicating whether the lane grid is visible.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getShowLaneGrid ()

Return Value

true if the lane grid is visible; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getStyle Method

Diagram.getStyle Method
[image]

Gets the style associated with this diagram.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getStyle ()

Return Value

An instance of the Style class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getTag Method

Diagram.getTag Method
[image]

Gets custom data associated with this diagram.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getTag ()

Return Value

The custom data.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getTheme Method

Diagram.getTheme Method
[image]

Gets the theme associated with this diagram.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getTheme ()

Return Value

An instance of the Theme class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getTooltipDelay Method

Diagram.getTooltipDelay Method
[image]

Gets the delay before a tooltip is shown.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getTooltipDelay ()

Return Value

The tooltip delay in milliseconds.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getUndoEnabled Method

Diagram.getUndoEnabled Method
[image]

Gets a value indicating whether saving action records for later undo is enabled.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getUndoEnabled ()

Return Value

true if undo is enabled, otherwise false.

Remarks

To undo the last recorded action, call the undo method. It can be redone again by calling redo. Custom operations can be integrated into the JsDiagram's undo/redo system by deriving from the Command class and running the operations by means of the executeCommand method.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getViewport Method

Diagram.getViewport Method
[image]

Returns the visible portion of the diagram area.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getViewport ()

Return Value

A Rect instance specifying the viewport coordinates.

Remarks

When the Diagram canvas element is placed inside a scrollable div element, this method returns what part of the diagram is currently visible within the div. The result is specified in the current measure unit.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.getVirtualScroll Method

Diagram.getVirtualScroll Method
[image]

Gets a value indicating whether virtual scroll mode is enabled.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function getVirtualScroll ()

Return Value

true if virtual scroll is enabled; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.initialize Method

Diagram.initialize Method
[image]

Overrides Component.Initialize

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function initialize ()

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.isItemInteractive Method

Diagram.isItemInteractive Method
[image]

Checks if the specified item can be modified interactively.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function isItemInteractive (item)

Parameters

item

The DiagramItem to check.

Return Value

true, if the item is currently visible and unlocked and it is not associated with a hidden or locked layer; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.isItemVisible Method

Diagram.isItemVisible Method
[image]

Checks if the specified item is currently visible.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function isItemVisible (item)

Parameters

item

The DiagramItem to check.

Return Value

true if the item's Visible property is set to true and the item is not associated with a hidden layer; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.loadFromXml Method

Diagram.loadFromXml Method
[image]

Loads the diagram from an XML file.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function loadFromXml (fileUrl, [onLoad, [onError]])

Parameters

fileUrl

The URL of an XML file where the data should be read from.

onLoad
Optional.

A callback that should be invoked if the file is loaded successfully.

onError
Optional.

A callback that should be invoked if the file could not be downloaded.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.pasteFromClipboard Method

Diagram.pasteFromClipboard Method
[image]

Overload List

Name | Description
Diagram.pasteFromClipboard (Number, Number, Boolean) | Pastes diagram items from the clipboard.
Diagram.pasteFromClipboard (Number, Number, Boolean, Boolean) | Pastes diagram items from the clipboard.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.pasteFromClipboard Method (Number, Number, Boolean)

Diagram.pasteFromClipboard Method (Number, Number, Boolean)
See Also
[image]

Pastes diagram items from the clipboard.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function pasteFromClipboard (offsetX, offsetY, [systemClipboard])

Parameters

offsetX

Horizontal offset of pasted items from their original positions.

offsetY

Vertical offset of pasted items from their original positions.

systemClipboard
Optional.

true to paste from the system clipboard, or false otherwise. The default value is false.

Remarks

The diagram control maintains its own local clipboard and items are copied to it by default. If you specify a true argument and running under browsers that allow access to the system clipboard, the items are copied to the system clipboard; in all other cases they are copied to the local clipboard. At the time of writing this, access to the system clipboard is supported only by Internet Explorer.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
copyToClipboard Method
cutToClipboard Method


MindFusion.Diagramming.Diagram.pasteFromClipboard Method (Number, Number, Boolean, Boolean)

Diagram.pasteFromClipboard Method (Number, Number, Boolean, Boolean)
See Also
[image]

Pastes diagram items from the clipboard.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function pasteFromClipboard (offsetX, offsetY, [systemClipboard, [unconnectedLinks]])

Parameters

offsetX

Horizontal offset of pasted items from their original positions.

offsetY

Vertical offset of pasted items from their original positions.

systemClipboard
Optional.

true to paste from the system clipboard, or false otherwise. The default value is false.

unconnectedLinks
Optional.

true to allow pasting arrows whose origin or destination node has not been copied; otherwise, false. The default value is false.

See Also

pasteFromClipboard Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.raiseClicked Method

Diagram.raiseClicked Method
[image]

Raises an event which notifies that a Diagram item has been clicked.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function raiseClicked (item, mousePosition, mouseButton)

Parameters

item

The Diagram item.

mousePosition

The position of the mouse.

mouseButton

The mouse button, with which the item has been clicked.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.raiseCreated Method

Diagram.raiseCreated Method
[image]

Overload List

Name | Description
Diagram.raiseCreated (DiagramItem) | Raises an event which notifies that a Diagram item has been created.
Diagram.raiseCreated (Link) | Raises an event which notifies that a Diagram item has been created.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.raiseCreated Method (DiagramItem)

Diagram.raiseCreated Method (DiagramItem)
See Also
[image]

Raises an event which notifies that a Diagram item has been created.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function raiseCreated (item)

Parameters

item

The diagram item that has been created.

See Also

raiseCreated Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.raiseCreated Method (Link)

Diagram.raiseCreated Method (Link)
See Also
[image]

Raises an event which notifies that a Diagram item has been created.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function raiseCreated (item)

Parameters

item

The diagram item that has been created.

See Also

raiseCreated Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.raiseDeleted Method

Diagram.raiseDeleted Method
[image]

Raises an event which notifies that a Diagram item has been deleted.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function raiseDeleted (item)

Parameters

item

The DiagramItem that has been deleted.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.raiseDeselected Method

Diagram.raiseDeselected Method
[image]

Raises an event which notifies that a Diagram item has been deselected.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function raiseDeselected (item)

Parameters

item

The Diagram item.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.raiseDoubleClicked Method

Diagram.raiseDoubleClicked Method
[image]

Raises an event which notifies that a Diagram item has been double-clicked.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function raiseDoubleClicked (item, mousePosition, mouseButton)

Parameters

item

The Diagram item.

mousePosition

The position of the mouse.

mouseButton

The mouse button, with which the item has been clicked.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.raiseEvent Method

Diagram.raiseEvent Method
[image]

Raises an event.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function raiseEvent (eventName, args)

Parameters

eventName

The name of the event to raise.

args

An instance of type EventArgs that holds data for the event specified with eventName.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.raiseModified Method

Diagram.raiseModified Method
[image]

Raises an event which notifies that a Diagram item has been modified.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function raiseModified (item, mousePosition, adjustmentHandle)

Parameters

item

The DiagramItem that has been modified.

mousePosition

The current mouse pointer position.

adjustmentHandle

Identifies the handle used to modify the item.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.raiseSelected Method

Diagram.raiseSelected Method
[image]

Raises an event which notifies that a Diagram item has been selected.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function raiseSelected (item)

Parameters

item

The Diagram item.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.redo Method

Diagram.redo Method
[image]

Executes again an action saved in the command history.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function redo ()

Remarks

Calling this method has no effect before undo has been called at least once. Any command that has been undone can later be redone by redo. The method processes the commands in the same order they were initially executed, which is opposite to the order in which they are undone.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
UndoEnabled Property
executeCommand Method


MindFusion.Diagramming.Diagram.registerForSubmit Method

Diagram.registerForSubmit Method
[image]

Registers an onsubmit handler for the Diagram's parent html form to flush postback data.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function registerForSubmit (id)

Parameters

id

The id of the hidden field to flush the data to.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.removeEventListener Method

Diagram.removeEventListener Method
[image]

Removes a single event listener attached to the Diagram.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function removeEventListener (eventName, handler)

Parameters

eventName

The name of the event. See a list of supported events here.

handler

Represents the method that handles the event specified with eventName.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Events Class
addEventListener Method


MindFusion.Diagramming.Diagram.removeItem Method

Diagram.removeItem Method
[image]

Removes the specified item from the Diagram.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function removeItem (item)

Parameters

item
The DiagramItem to be removed.

Remarks

The Diagram object calls this method automatically when an item is removed from the items collection. Classes that inherit Diagram can override it to implement some additional processing, but in any case they must call the base method.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.resizeToFitItem Method

Diagram.resizeToFitItem Method
[image]

Resize the document extents so that the specified item is contained within.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function resizeToFitItem (item)

Parameters

item

The item to be contained.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.resizeToFitItems Method

Diagram.resizeToFitItems Method
[image]

Resizes the document scrollable area so that it fits all diagram items.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function resizeToFitItems (margin)

Parameters

margin

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.routeAllLinks Method

Diagram.routeAllLinks Method
[image]

Routes all links in the diagram in such a way they do not cross nodes.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function routeAllLinks ()

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.scrollTo Method

Diagram.scrollTo Method
[image]

Scrolls the diagram to the specified point.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function scrollTo (x, y)

Parameters

x

A number specifying the new horizontal scroll position in the current unit of measure.

y

A number specifying the new vertical scroll position in the current unit of measure.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
setScrollX Method
setScrollY Method


MindFusion.Diagramming.Diagram.setAdjustmentHandlesSize Method

Diagram.setAdjustmentHandlesSize Method
[image]

Sets the size of adjustment handles that appear around selected items.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setAdjustmentHandlesSize (value)

Parameters

value

A number specifying the size of selection handles.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setAlignToGrid Method

Diagram.setAlignToGrid Method
[image]

Sets a value indicating whether the diagram items should be aligned to a grid.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setAlignToGrid (value)

Parameters

value

true if the diagram items should be aligned to a grid; otherwise, false.

Remarks

When the property is set to true, the sides of every newly created diagram item are aligned to the nearest grid points.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
setShowGrid Method
setGridStyle Method
setGridSizeX Method
setGridSizeY Method


MindFusion.Diagramming.Diagram.setAllowInplaceEdit Method

Diagram.setAllowInplaceEdit Method
[image]

Sets a value indicating whether in-place editing of the text of objects is enabled.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setAllowInplaceEdit (value)

Parameters

value
A Boolean value.

Remarks

Specifies whether users are allowed to edit in-place text of diagram nodes. If enabled, a text-entry field appears at node's position when the node is double-clicked. In-place editing mode can be exited by clicking anywhere outside the text field.

To enter or exit in-place editing mode programmatically, use the beginEdit and endEdit methods of Diagram.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setAllowMultipleResize Method

Diagram.setAllowMultipleResize Method
[image]

Sets a value indicating whether multiple selected nodes can be resized simultaneously.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setAllowMultipleResize (value)

Parameters

value

true to let the user resize multiple selected nodes; otherwise, false. The default value is false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setAllowUnconnectedLinks Method

Diagram.setAllowUnconnectedLinks Method
[image]

Sets a value indicating whether users are allowed to draw links that are not connected to any node.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setAllowUnconnectedLinks (value)

Parameters

value
true to allow drawing unconnected links; otherwise, false. The default is false.

Remarks

If this property is set to true, users will be able to draw links from or to any point of the document. To draw links that do not start from a node, you must also set Behavior to DrawLinks.

Depending on which end of a link is unconnected, its Origin or Destination nodes will be set to a DummyNode instance.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setAutoResize Method

Diagram.setAutoResize Method
[image]

Sets a value indicating whether the document area should be resized automatically so it fits the diagram contents.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setAutoResize (value)

Parameters

value

A member of the AutoResize enumeration indicating the auto resize method. The default is RightAndDown.

Remarks

If automatic resizing is enabled, the size of the document scrollable area is updated each time an item is created, deleted or moved by the end-user. To resize the diagram after programmatic changes, call the resizeToFitItems method.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Bounds Property
AutoScroll Property


MindFusion.Diagramming.Diagram.setAutoScroll Method

Diagram.setAutoScroll Method
[image]

Sets a value indicating whether auto scrolling of the document area is enabled.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setAutoScroll (value)

Parameters

value
true if the diagram should scroll automatically; otherwise, false. The default value is false.

Remarks

If enabled, the control will scroll its content automatically when the user drags the mouse near the viewport edges. This works only if the diagram is placed inside a DIV whose overflow attribute is set to scroll or auto.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Bounds Property
AutoResize Property


MindFusion.Diagramming.Diagram.setAutoScrollAmount Method

Diagram.setAutoScrollAmount Method
[image]

Sets the amount by which to auto-scroll the view when the mouse leaves the view boundaries while drawing.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setAutoScrollAmount (value)

Parameters

value

A number specifying the amount by which to auto-scroll.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setBackBrush Method

Diagram.setBackBrush Method
[image]

Sets an object used for painting the diagram background.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setBackBrush (value)

Parameters

value

The object used for painting the background.

Remarks

This property enables more spectacular background painting with effects such as gradients, textures and color patterns.

Example

The following example demonstrates how a gradient brush is created and how a solid brush is created - from a string that identifies a predefined color or from a RGB value.

Java Script

//create gradient brush
var gradientBrush = { type: "LinearGradientBrush", color1: "green", color2: "white", angle: 30 };

//create blue solid brush
var solidBrush = "blue";

//create gray solid brush
var solidBrush = "#COCOCO";

See Also

Diagram Members
Diagram Class
BackgroundImageUrl Property


MindFusion.Diagramming.Diagram.setBackgroundImageAlign Method

Diagram.setBackgroundImageAlign Method
[image]

Sets a value indicating how the background image is positioned.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setBackgroundImageAlign (value)

Parameters

value

One of the ImageAlign enumeration values. The default is ImageAlign.TopLeft.

Remarks

The background image can be aligned to a corner, stretched, centered, or tiled to cover the control's area.

See Also

Diagram Members
Diagram Class
BackgroundImageUrl Property


MindFusion.Diagramming.Diagram.setBackgroundImageContent Method

Diagram.setBackgroundImageContent Method
[image]

Sets the Base64-encoded data of the background image.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setBackgroundImageContent (value)

Parameters

value

The Base64-encoded data for the background image to be loaded.

See Also

Diagram Members
Diagram Class
BackgroundImageAlign Property


MindFusion.Diagramming.Diagram.setBackgroundImageUrl Method

Diagram.setBackgroundImageUrl Method
[image]

Sets the URL of the image displayed as background of this diagram.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setBackgroundImageUrl (value)

Parameters

value
A string specifying the location of the image file.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
BackBrush Property
BackgroundImageAlign Property


MindFusion.Diagramming.Diagram.setBehavior Method

Diagram.setBehavior Method
[image]

Sets a value indicating how the control responds to user actions.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setBehavior (value)

Parameters

value

A member of the Behavior enumeration. The default is LinkShapes.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setCrossingRadius Method

Diagram.setCrossingRadius Method
[image]

Sets the radius length of decorations displayed at link intersection points.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setCrossingRadius (value)

Parameters

value

A number specifying the radius of the arcs drawn at link intersection points.

Remarks

If LinkCrossings is set to Cut, link segments are cut at intersection points and this property defines the length of the break left between adjacent cut points. If LinkCrossings is set to Arcs, this property defines the radius of the arcs drawn over intersection points.

See Also

Diagram Members
Diagram Class
RoundedLinksRadius Property


MindFusion.Diagramming.Diagram.setCustomLinkType Method

Diagram.setCustomLinkType Method
[image]

Sets the type of a MindFusion.Diagramming.DiagramLink derived class whose instance should be created when a user starts drawing.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setCustomLinkType (value)

Parameters

value

The type.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setCustomNodeType Method

Diagram.setCustomNodeType Method
[image]

Sets the type of a MindFusion.Diagramming.DiagramNode derived class whose instance should be created when a user starts drawing.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setCustomNodeType (value)

Parameters

value

The type.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setDefaultShape Method

Diagram.setDefaultShape Method
[image]

Sets the default shape of shape nodes.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setDefaultShape (value)

Parameters

value
A Shape instance or a string that identifies the Shape.

Remarks

The Shape property of newly created shape nodes is initialized with the value of this property. It defines a series of lines, arcs and curves composed in a complex shape. There are predefined shapes exposed as static members of the Shapes class. You can also define your own shapes as shown below.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setDelKeyAction Method

Diagram.setDelKeyAction Method
[image]

Sets a value that specifies what action should be performed when the user hits the Del key.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setDelKeyAction (value)

Parameters

value
A DelKeyAction Enumeration value.

Remarks

Depending on this property value, the control can delete all selected items, delete only the active item, or ignore the Del key press.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setDirty Method

Diagram.setDirty Method
[image]

Sets a value indicating whether the diagram has changed since loading it.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setDirty (value)

Parameters

value

A boolean value that indicates whether the diagram has changed.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setDynamicLinks Method

Diagram.setDynamicLinks Method
[image]

Sets the default value for the Dynamic property of new links.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setDynamicLinks (value)

Parameters

value

true if dynamic links should be enabled; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setEnabled Method

Diagram.setEnabled Method
[image]

Enables or disables handling of mouse events.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setEnabled (value)

Parameters

value

true if handling of mouse events is enabled; otherwise, false.

Remarks

When this method is called with "false" there aren't any item click events raised.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setExpandOnIncoming Method

Diagram.setExpandOnIncoming Method
[image]

Sets a value indicating the link direction in which tree branches are expanded.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setExpandOnIncoming (value)

Parameters

value

true if trees are expanded in the direction of incoming links; otherwise, false. The default is false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setFont Method

Diagram.setFont Method
[image]

Sets the font for text written on DiagramItem-s.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setFont (value)

Parameters

value

The font to set.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setGridColor Method

Diagram.setGridColor Method
[image]

Sets the color of the grid points.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setGridColor (value)

Parameters

value

The color of the grid points.

Remarks

Use the property to specify the color of grid points and lines.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setGridOffsetX Method

Diagram.setGridOffsetX Method
[image]

Sets the horizontal offset of the first point of the alignment grid.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setGridOffsetX (value)

Parameters

value

The horizontal offset of the first point of the alignment grid.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setGridOffsetY Method

Diagram.setGridOffsetY Method
[image]

Sets the vertical offset of the first point of the alignment grid.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setGridOffsetY (value)

Parameters

value

The vertical offset of the first point of the alignment grid.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setGridPointSize Method

Diagram.setGridPointSize Method
[image]

Sets the size of shapes used to represent grid points.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setGridPointSize (value)

Parameters

value

Return Value

value The size of shapes used to represent grid points.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setGridSizeX Method

Diagram.setGridSizeX Method
[image]

Sets the horizontal distance between adjacent grid points.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setGridSizeX (value)

Parameters

value

The horizontal distance between adjacent grid points.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
setAlignToGrid Method
setShowGrid Method
setGridStyle Method


MindFusion.Diagramming.Diagram.setGridSizeY Method

Diagram.setGridSizeY Method
[image]

Sets the vertical distance between adjacent grid points.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setGridSizeY (value)

Parameters

value

The vertical distance between adjacent grid points.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
setAlignToGrid Method
setShowGrid Method
setGridStyle Method


MindFusion.Diagramming.Diagram.setGridStyle Method

Diagram.setGridStyle Method
[image]

Sets the visual style of the alignment grid.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setGridStyle (value)

Parameters

value

One of the GridStyle enumeration values.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setLinkBaseShape Method

Diagram.setLinkBaseShape Method
[image]

Sets the Shape displayed at the base of new links.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setLinkBaseShape (value)

Parameters

value
A Shape instance that represents an arrowhead shape. The default is None.

Remarks

This property specifies the default shape displayed as arrowhead at the links' origin points.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setLinkBaseShapeSize Method

Diagram.setLinkBaseShapeSize Method
[image]

Sets the default size of the base of new links.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setLinkBaseShapeSize (value)

Parameters

value

A number that specifies the size. The default is 5.

Remarks

The property specifies how big is the shape that is displayed at the origin of a link.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setLinkBrush Method

Diagram.setLinkBrush Method
[image]

Sets the default fill of links.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setLinkBrush (value)

Parameters

value

An object identifying the fill of links.

Remarks

The property provides a default value for the brush, with which an arrowhead's interior is filled.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setLinkCrossings Method

Diagram.setLinkCrossings Method
[image]

Sets a value indicating how to render the intersection points where two links cross each other.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setLinkCrossings (value)

Parameters

value

A member of the LinkCrossings enumeration.

Remarks

Intersection points where links cross each other's paths can be rendered as arcs or cuts, depending on the value of this property. The diagram z-order defines which links jump over the others or which links are cut by the others. If LinkCrossings is set to Arcs, links with higher ZIndex jump over those with lower ZIndex. If set to Cut, segments of links at lower z-position are cut by links at higher z-position. Radius of arcs and cuts can be set via the CrossingRadius property.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
RouteLinks Property
RoundedLinks Property


MindFusion.Diagramming.Diagram.setLinkHeadShape Method

Diagram.setLinkHeadShape Method
[image]

Sets the Shape displayed as head of new links.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setLinkHeadShape (value)

Parameters

value
A ShapeNode instance that represents an arrowhead shape. The default is Arrow.

Remarks

This method sets the default shape displayed as arrowhead at the links' end points.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setLinkHeadShapeSize Method

Diagram.setLinkHeadShapeSize Method
[image]

Sets the default size of arrowheads.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setLinkHeadShapeSize (value)

Parameters

value

A number that measures the size. The default is 5.

Remarks

The property specifies how big the shapes of new arrowheads are.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setLinkHitDistance Method

Diagram.setLinkHitDistance Method
[image]

Sets a value specifying how far from a link a click is still considered a hit.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setLinkHitDistance (value)

Parameters

value

A value specifying how far from a link a click is still considered a hit.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setLinkPen Method

Diagram.setLinkPen Method
[image]

Sets the default stroke of links.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setLinkPen (value)

Parameters

value

A string value specifying the stroke of links.

Remarks

This property specifies the default value for the Pen property of new links.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setLinkShape Method

Diagram.setLinkShape Method
[image]

Sets the initial shape assigned to new links.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setLinkShape (value)

Parameters

value

One of the LinkShape enumeration values.

Remarks

The specified value is assigned to the Shape property of new links. The default is Polyline.

See Also

Diagram Members
Diagram Class
RoundedLinks Property


MindFusion.Diagramming.Diagram.setLinkTextStyle Method

Diagram.setLinkTextStyle Method
[image]

Sets the default placement and orientation for links' text.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setLinkTextStyle (value)

Parameters

value
A member of the LinkTextStyle enumeration. The default value is Center.

Remarks

The value of this property is used to initialize the TextStyle property of new links.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setMagnifierEnabled Method

Diagram.setMagnifierEnabled Method
[image]

Sets a value indicating whether the magnifier tool is currently enabled.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setMagnifierEnabled (value)

Parameters

value

true to enable the magnifier; otherwise, false. The default value is false.

Remarks

The magnifier tool can be alternatively enabled on-demand through a modifier key or a mouse button.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setMagnifierFactor Method

Diagram.setMagnifierFactor Method
[image]

Sets the zoom factor of the magnifier tool.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setMagnifierFactor (value)

Parameters

value

A number specifying the zoom factor of the magnifier tool.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setMagnifierFrameColor Method

Diagram.setMagnifierFrameColor Method
[image]

Sets the color of the magnifier tool's frame.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setMagnifierFrameColor (value)

Parameters

value

The color of the magnifier tool's frame.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setMagnifierFrameThickness Method

Diagram.setMagnifierFrameThickness Method
[image]

Sets the thickness of the magnifier frame.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setMagnifierFrameThickness (value)

Parameters

value

A number specifying the thickness of the magnifier frame.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setMagnifierHeight Method

Diagram.setMagnifierHeight Method
[image]

Sets the height of the magnifier tool.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setMagnifierHeight (value)

Parameters

value

A number specifying the height of the magnifier tool.

See Also

Diagram Members
Diagram Class
MagnifierWidth Property


MindFusion.Diagramming.Diagram.setMagnifierSecondaryFrameColor Method

Diagram.setMagnifierSecondaryFrameColor Method
[image]

Sets the color of the magnifier tool's secondary frame.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setMagnifierSecondaryFrameColor (value)

Parameters

value

The color of the magnifier tool's secondary frame.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setMagnifierShading Method

Diagram.setMagnifierShading Method
[image]

Sets a value indicating whether to enhance the effect of a magnifier lense by using a gradient shading.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setMagnifierShading (value)

Parameters

value

true to enable the shading; otherwise, false. The default value is true.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setMagnifierShape Method

Diagram.setMagnifierShape Method
[image]

Sets a reference to the geometric shape definition of the magnifier tool.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setMagnifierShape (value)

Parameters

value
An instance of the Shape class whose outline definition should be used as magnifier's shape. The default is Circle.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setMagnifierWidth Method

Diagram.setMagnifierWidth Method
[image]

Sets the width of the magnifier tool.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setMagnifierWidth (value)

Parameters

value

A number specifying the width of the magnifier tool.

See Also

Diagram Members
Diagram Class
MagnifierHeight Property


MindFusion.Diagramming.Diagram.setMiddleButtonActions Method

Diagram.setMiddleButtonActions Method
[image]

Sets a combination of flags that specify what actions can be performed via the middle mouse button.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setMiddleButtonActions (value)

Parameters

value

A member of the MouseButtonActions enumeration.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setModificationStart Method

Diagram.setModificationStart Method
[image]

Sets how users can start modifying diagram items.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setModificationStart (value)

Parameters

value
A member of the ModificationStart enumeration. The default is SelectedOnly.

Remarks

Use this property to specify what should users do in order to start item modification.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setNodesExpandable Method

Diagram.setNodesExpandable Method
[image]

Sets a value indicating whether newly created nodes can be collapsed and expanded by users.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setNodesExpandable (value)

Parameters

value

A boolean value assigned to the Expandable property of new nodes. The default is false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setRightButtonActions Method

Diagram.setRightButtonActions Method
[image]

Sets a combination of flags that specify what actions can be performed via the right mouse button.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setRightButtonActions (value)

Parameters

value

A member of the MouseButtonActions enumeration.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setRoundedLinks Method

Diagram.setRoundedLinks Method
[image]

Sets a value indicating whether the joints between segments of Polyline and Cascading links should be rounded.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setRoundedLinks (value)

Parameters

value

true to draw rounded segment joints; otherwise, false.

Remarks

The value of this property is considered when drawing links whose Shape is set to Polyline or Cascading. If the property is enabled, the joins between the segments of all such links are drawn as arcs, whose radius equals the value of RoundedLinksRadius.

See Also

Diagram Members
Diagram Class
LinkCrossings Property


MindFusion.Diagramming.Diagram.setRoundedLinksRadius Method

Diagram.setRoundedLinksRadius Method
[image]

Sets the radius of joint arcs of rounded links' segments.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setRoundedLinksRadius (value)

Parameters

value

A number specifying the radius length.

Remarks

The value of this property is used when RoundedLinks is enabled. It specifies the radius of the arcs drawn as joins between link segments.

See Also

Diagram Members
Diagram Class
CrossingRadius Property


MindFusion.Diagramming.Diagram.setRouteLinks Method

Diagram.setRouteLinks Method
[image]

Sets a value indicating whether links should avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setRouteLinks (value)

Parameters

value

true to route links; otherwise, false. The default is false.

See Also

Diagram Members
Diagram Class
LinkCrossings Property


MindFusion.Diagramming.Diagram.setRouteMargin Method

Diagram.setRouteMargin Method
[image]

Sets the minimal distance between nodes and auto-routed links.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setRouteMargin (value)

Parameters

value

A value specifying distance in the current MeasureUnit; default is 8.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setScroll Method

Diagram.setScroll Method
[image]

IZoomTarget implementation

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setScroll (x, y)

Parameters

x

y

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setScrollX Method

Diagram.setScrollX Method
[image]

Sets the diagram's horizontal scroll position.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setScrollX (value)

Parameters

value

A number specifying the new horizontal scroll position in the current unit of measure.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setScrollY Method

Diagram.setScrollY Method
[image]

Sets the diagram's vertical scroll position.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setScrollY (value)

Parameters

value

A number specifying the new vertical scroll position in the current unit of measure.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setScrollZoneSize Method

Diagram.setScrollZoneSize Method
[image]

Sets the size of the auto scroll zone near the edges of the control.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setScrollZoneSize (value)

Parameters

value
A number specifying the size in pixels of the area near the view edges where auto-scrolling is triggered. The default value is 8.

See Also

Diagram Members
Diagram Class
AutoScroll Property


MindFusion.Diagramming.Diagram.setShadowOffsetX Method

Diagram.setShadowOffsetX Method
[image]

Sets the horizontal offset of objects' shadows.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setShadowOffsetX (value)

Parameters

value

A number specifying the shadow's horizontal offset.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setShadowOffsetY Method

Diagram.setShadowOffsetY Method
[image]

Sets the vertical offset of objects' shadows.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setShadowOffsetY (value)

Parameters

value

A number specifying the shadow's vertical offset.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setShadowsStyle Method

Diagram.setShadowsStyle Method
[image]

Sets the style for rendering shadows.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setShadowsStyle (value)

Parameters

value

A member of the ShadowsStyle enumeration. The default value is ShadowsStyle.OneLevel.

Remarks

This property specifies how the shadows of diagram items are drawn. If its value is None no shadows are painted. OneLevel makes all shadows paint on the lowest z-level, not covering any items. Thus the diagram items will seem to appear on the same z-level. ZOrder makes the shadow paint immediately under their items, possibly covering other items. This style gives more 3D-like outlook to the diagram.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setShapeBrush Method

Diagram.setShapeBrush Method
[image]

Sets the default fill of shape nodes.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setShapeBrush (value)

Parameters

value

An object identifying the fill of shape nodes.

Remarks

The property provides a default value for the brush, with which a node' interior is filled.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setShapeLibraryLocation Method

Diagram.setShapeLibraryLocation Method
[image]

Sets the location of a shape library file containing custom shape definitions.It can be set to a full URL of the file, or a relative file path.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setShapeLibraryLocation (value)

Parameters

value

The location of a shape library file containing custom shape definitions.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setShapePen Method

Diagram.setShapePen Method
[image]

Sets the default stroke of shape nodes.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setShapePen (value)

Parameters

value

A string value specifying the stroke of shape nodes.

Remarks

This property provides a default value for the pen with which shape nodes border lines are painted.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setShowAnchors Method

Diagram.setShowAnchors Method
[image]

Sets a value indicating whether and when anchor point marks are displayed.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setShowAnchors (value)

Parameters

value

One of the ShowAnchors enumeration values.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setShowDisabledHandles Method

Diagram.setShowDisabledHandles Method
[image]

Sets a value indicating whether adjustment handles are painted when they are disabled.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setShowDisabledHandles (value)

Parameters

value

true to display disabled manipulation handles; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setShowGrid Method

Diagram.setShowGrid Method
[image]

Sets a value indicating whether the alignment grid is visible.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setShowGrid (value)

Parameters

value

true if the alignment grid is visible; otherwise, false.

Remarks

If it is visible, the grid is painted as either a matrix of points or crossing horizontal and vertical lines. That depends on the value of GridStyle.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
setAlignToGrid Method
setGridSizeX Method
setGridSizeY Method
setGridStyle Method


MindFusion.Diagramming.Diagram.setShowLaneGrid Method

Diagram.setShowLaneGrid Method
[image]

Sets a value indicating whether the lane grid is visible.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setShowLaneGrid (value)

Parameters

value

true if the lane grid is visible; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setStyle Method

Diagram.setStyle Method
[image]

Sets the style associated with this diagram.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setStyle (value)

Parameters

value

An instance of the Style class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setTag Method

Diagram.setTag Method
[image]

Sets custom data associated with this diagram.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setTag (value)

Parameters

value

The custom data.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setTheme Method

Diagram.setTheme Method
[image]

Sets the theme associated with this diagram.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setTheme (value)

Parameters

value

An instance of the Theme class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setTooltipDelay Method

Diagram.setTooltipDelay Method
[image]

Sets the delay before a tooltip is shown.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setTooltipDelay (value)

Parameters

value

The tooltip delay in milliseconds.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setUndoEnabled Method

Diagram.setUndoEnabled Method
[image]

Sets a value indicating whether saving action records for later undo is enabled.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setUndoEnabled (value)

Parameters

value
true to save actions for later undo; otherwise false. The default is false.

Remarks

To undo the last recorded action, call the undo method. It can be redone again by calling redo. Custom operations can be integrated into the JsDiagram's undo/redo system by deriving from the Command class and running the operations by means of the executeCommand method.

See Also

Diagram Members
Diagram Class
startCompositeOperation Method


MindFusion.Diagramming.Diagram.setVirtualScroll Method

Diagram.setVirtualScroll Method
[image]

Enables or disables virtual scroll mode.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setVirtualScroll (value)

Parameters

value

true to enable virtual scroll; otherwise, false.

Remarks

If this mode is enabled, the canvas stays as big as its containing div, and its content is drawn with a translation bound to the div's scrollbar positions. This allow displaying large diagrams in browsers and on mobile devices where the size of HTML canvas elements is limited.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.setZoomFactorPivot Method

Diagram.setZoomFactorPivot Method
[image]

Sets the zoom factor, preserving the on-screen position of the specified diagram point.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setZoomFactorPivot (zoomFactor, pivotPoint)

Parameters

zoomFactor

The new zoom factor.

pivotPoint

A Point instance specifying the zoom center.

See Also

Diagram Members
Diagram Class
zoomToRect Method


MindFusion.Diagramming.Diagram.setZoomLevel Method

Diagram.setZoomLevel Method
[image]

IZoomTarget implementation.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function setZoomLevel (value)

Parameters

value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.startCompositeOperation Method

Diagram.startCompositeOperation Method
[image]

Starts recording undo/redo commands into a CompositeCommand.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function startCompositeOperation ()

Remarks

After the diagram modifications are done, call commitCompositeOperation or cancelCompositeOperation.

See Also

Diagram Members
Diagram Class
UndoEnabled Property


MindFusion.Diagramming.Diagram.toJson Method

Diagram.toJson Method
[image]

Serializes the diagram into a JSON string.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function toJson ()

Return Value

A string containing the diagram's JSON representation.

See Also

Diagram Members
Diagram Class
fromJson Method


MindFusion.Diagramming.Diagram.undo Method

Diagram.undo Method
[image]

Undoes an action saved in the command history.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function undo ()

Remarks

The control supports unlimited undo/redo depth. This method moves the "current command" pointer one position back, and calling it again will undo the previous command. The commands can later be redone by calling redo.

See Also

Diagram Members
Diagram Class
UndoEnabled Property


MindFusion.Diagramming.Diagram.zoomToFit Method

Diagram.zoomToFit Method
[image]

Zooms the view to fit the document contents in the Diagram client area.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function zoomToFit ()

See Also

Diagram Members
Diagram Class
zoomToRect Method


MindFusion.Diagramming.Diagram.zoomToRect Method

Diagram.zoomToRect Method
[image]

Zooms and scrolls the view to fit the specified document rectangle in the Diagram's visible area.

Namespace: MindFusion.Diagramming
Assembly: Diagram.js

Syntax

JavaScript [image] Copy Code

function zoomToRect (rect)

Parameters

rect

A Rect instance specifying the viewport position and size.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
scrollTo Method
zoomToFit Method


MindFusion.Diagramming.DiagramEventArgs Class

DiagramEventArgs Class
[image]

Contains the arguments passed to handlers of global diagram events such as clicked.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

// class
DiagramEventArgs.prototype = {}

Inheritance Hierarchy

See Also

DiagramEventArgs Members


MindFusion.Diagramming.DiagramEventArgs Members

DiagramEventArgs Members
Constructors Methods
[image]

Contains the arguments passed to handlers of global diagram events such as clicked.

The following tables list the members exposed by the DiagramEventArgs type.

Public Constructors

Name | Description
DiagramEventArgs | Initializes a new instance of the DiagramEventArgs class.

Public Methods

Name | Description
getMouseButton | Gets which mouse button has been pressed.
getMousePosition | Gets the current mouse pointer position.

See Also

DiagramEventArgs Class


MindFusion.Diagramming.DiagramEventArgs Constructor

DiagramEventArgs Constructor
[image]

Initializes a new instance of the DiagramEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function DiagramEventArgs ()

See Also

DiagramEventArgs Class


MindFusion.Diagramming.DiagramEventArgs Methods

DiagramEventArgs Methods
[image]

Public Methods

Name | Description
getMouseButton | Gets which mouse button has been pressed.
getMousePosition | Gets the current mouse pointer position.

See Also

DiagramEventArgs Class


MindFusion.Diagramming.DiagramEventArgs.getMouseButton Method

DiagramEventArgs.getMouseButton Method
[image]

Gets which mouse button has been pressed.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getMouseButton ()

Return Value

One of the MouseButton enumeration values.

See Also

DiagramEventArgs Members
DiagramEventArgs Class


MindFusion.Diagramming.DiagramEventArgs.getMousePosition Method

DiagramEventArgs.getMousePosition Method
[image]

Gets the current mouse pointer position.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getMousePosition ()

Return Value

A Point instance.

See Also

DiagramEventArgs Members
DiagramEventArgs Class


MindFusion.Diagramming.DiagramItem Class

DiagramItem Class
Remarks See Also
[image]

Represents an item in the diagram document. All classes representing diagram elements derive from DiagramItem.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

// class
DiagramItem.prototype = {}

Remarks

All items in the diagram document - links and nodes - share common base class called DiagramItem. Its main function is to provide interface for the most common methods and properties of every diagram element.

Inheritance Hierarchy

See Also

DiagramItem Members


MindFusion.Diagramming.DiagramItem Members

DiagramItem Members
Constructors Methods
[image]

Represents an item in the diagram document. All classes representing diagram elements derive from DiagramItem.

The following tables list the members exposed by the DiagramItem type.

Public Constructors

Name | Description
DiagramItem | Initializes a new instance of the DiagramItem class.

Public Methods

Name | Description
addCanvasElements | Derived classes must implement this method by adding their graphics primitives to the canvas.elements collection.
allowDrag | Invoked to validate the drag operation.
cancelDrag | Invoked when the interactive modification of this object has been canceled.
containsPoint | Determines whether this item contains the specified point.
fromJson | Deserializes this item from a JSON string.
getBrush | Gets the object that specifies how to paint the interior of the DiagramItem.
getEffectiveBrush | Gets the effective brush that should be used to paint this item.
getEffectiveFont | Gets the effective font that should be used to render this item's text.
getEffectiveFontName | Gets the name of the effective font that should be used to render this item's text.
getEffectiveFontSize | Gets the size of the effective font that should be used to render this item's text.
getEffectiveFontStyle | Gets the style of the effective font that should be used to render this item's text.
getEffectiveShadowColor | Gets the effective color that should be used to render this item's shadow.
getEffectiveStroke | Gets the effective color that should be used to stroke this item.
getEffectiveStrokeDashStyle | Gets the effective line dash pattern that should be applied when stroking this item.
getEffectiveStrokeThickness | Gets the effective line thickness that should be applied when stroking this item.
getEffectiveTextColor | Gets the effective text color that should be used to render this item's text.
getEffectiveTextStroke | Gets the effective text color that should be used to render this item's text outline.
getEffectiveTextStrokeThickness | Gets the effective width of the text outline of this item.
getFont | Gets the font used to render this item's text.
getHyperLink | Gets the hyperlink associated with this diagram item.
getId | Gets the id of the item.
getIgnoreLayout | Gets a value indicating whether the position of this item should not be changed by automatic layout methods.
getLayoutTraits | Gets an object containing properties of the node specific to some layout algorithms.
getLocked | Gets a value indicating whether users are allowed to modify this item.
getParent | Gets the parent diagram.
getPen | Gets an object used to paint the frame of the item.
getSelected | Gets a value indicating whether a DiagramItem is selected.
getShadowColor | Gets the color used to draw the shadow of this item.
getShadowOffsetX | Gets the horizonal offset of the item's shadow.
getShadowOffsetY | Gets the vertical offset of the item's shadow.
getStroke | Gets a string specifying the color used to stroke the item's frame.
getStrokeDashStyle | Gets the line dash pattern applied when stroking the item's frame.
getStrokeThickness | Gets the line width applied when stroking the item's frame.
getStyle | Gets the style associated with this item.
getTag | Gets the tag of the item.
getText | Gets the string containing the DiagramItem's text.
getTextColor | Gets a string specifying the color of the text of this item.
getTextPadding | Gets the spacing between the item boundaries and its text.
getTextStroke | Gets a string specifying the color of the text outline of this item.
getTextStrokeThickness | Gets the width of the text outline of this item.
getTooltip | Gets the tooltip text that should be displayed when the mouse hovers over this item.
getVisible | Gets a value indicating whether this item is visible.
getZIndex | Gets the z-order position of the object.
hitTest | Returns the diagram item that contains the specified point.
loadFromXml | Override this method to load custom item properties from XML.
onRemove | Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo.
removeCanvasElements | Derived classes must implement this method by removing their graphics primitives from the canvas.elements collection.
saveLocationState | Saves the state of this DiagramItem.
setBrush | Sets an object that specifies how to paint the interior of the DiagramItem.
setFont | Sets the font used to render this item's text.
setHyperLink | Sets the hyperlink associated with this diagram item.
setId | Lets you set any object as an id for this item.
setIgnoreLayout | Sets a value indicating whether the position of this item should not be changed by automatic layout methods.
setLocked | Sets a value indicating whether users are allowed to modify this item.
setPen | Sets an object used to paint the frame of the item.
setSelected | Sets a value indicating whether a DiagramItem is selected.
setShadowColor | Sets the color used to draw the shadow of this item.
setShadowOffsetX | Sets the horizonal offset of the item's shadow.
setShadowOffsetY | Sets the vertical offset of the item's shadow.
setStroke | Sets a string specifying the color used to stroke the item's frame.
setStrokeDashStyle | Sets the line dash pattern applied when stroking the item's frame.
setStrokeThickness | Sets the line width applied when stroking the item's frame.
setStyle | Sets the style associated with this item.
setTag | Lets you set any object as a tag for this item.
setText | Sets a string containing the DiagramItem's text.
setTextColor | Sets a string specifying the color of the text of this item.
setTextPadding | Sets the spacing between the item boundaries and its text.
setTextStroke | Sets a string specifying the color of the text outline of this item.
setTextStrokeThickness | Sets the width of the text outline of this item.
setTooltip | Sets the tooltip text that should be displayed when the mouse hovers over this item.
setVisible | Sets a value indicating whether this item is visible.
setZIndex | Sets the z-order position of the object.
startDrag | Invoked when the user starts dragging this item.
toJson | Serializes this item into a JSON string.
updateCanvasElements | Derived classes must implement this method to update the item's visual elements.
updateDrag | Invoked while the user drags this item.

See Also

DiagramItem Class


MindFusion.Diagramming.DiagramItem Constructor

DiagramItem Constructor
[image]

Initializes a new instance of the DiagramItem class.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function DiagramItem ([parent])

Parameters

parent
Optional.

The Diagram from which to obtain default values for the item properties.

See Also

DiagramItem Class


MindFusion.Diagramming.DiagramItem Methods

DiagramItem Methods
[image]

Public Methods

Name | Description
addCanvasElements | Derived classes must implement this method by adding their graphics primitives to the canvas.elements collection.
allowDrag | Invoked to validate the drag operation.
cancelDrag | Invoked when the interactive modification of this object has been canceled.
containsPoint | Determines whether this item contains the specified point.
fromJson | Deserializes this item from a JSON string.
getBrush | Gets the object that specifies how to paint the interior of the DiagramItem.
getEffectiveBrush | Gets the effective brush that should be used to paint this item.
getEffectiveFont | Gets the effective font that should be used to render this item's text.
getEffectiveFontName | Gets the name of the effective font that should be used to render this item's text.
getEffectiveFontSize | Gets the size of the effective font that should be used to render this item's text.
getEffectiveFontStyle | Gets the style of the effective font that should be used to render this item's text.
getEffectiveShadowColor | Gets the effective color that should be used to render this item's shadow.
getEffectiveStroke | Gets the effective color that should be used to stroke this item.
getEffectiveStrokeDashStyle | Gets the effective line dash pattern that should be applied when stroking this item.
getEffectiveStrokeThickness | Gets the effective line thickness that should be applied when stroking this item.
getEffectiveTextColor | Gets the effective text color that should be used to render this item's text.
getEffectiveTextStroke | Gets the effective text color that should be used to render this item's text outline.
getEffectiveTextStrokeThickness | Gets the effective width of the text outline of this item.
getFont | Gets the font used to render this item's text.
getHyperLink | Gets the hyperlink associated with this diagram item.
getId | Gets the id of the item.
getIgnoreLayout | Gets a value indicating whether the position of this item should not be changed by automatic layout methods.
getLayoutTraits | Gets an object containing properties of the node specific to some layout algorithms.
getLocked | Gets a value indicating whether users are allowed to modify this item.
getParent | Gets the parent diagram.
getPen | Gets an object used to paint the frame of the item.
getSelected | Gets a value indicating whether a DiagramItem is selected.
getShadowColor | Gets the color used to draw the shadow of this item.
getShadowOffsetX | Gets the horizonal offset of the item's shadow.
getShadowOffsetY | Gets the vertical offset of the item's shadow.
getStroke | Gets a string specifying the color used to stroke the item's frame.
getStrokeDashStyle | Gets the line dash pattern applied when stroking the item's frame.
getStrokeThickness | Gets the line width applied when stroking the item's frame.
getStyle | Gets the style associated with this item.
getTag | Gets the tag of the item.
getText | Gets the string containing the DiagramItem's text.
getTextColor | Gets a string specifying the color of the text of this item.
getTextPadding | Gets the spacing between the item boundaries and its text.
getTextStroke | Gets a string specifying the color of the text outline of this item.
getTextStrokeThickness | Gets the width of the text outline of this item.
getTooltip | Gets the tooltip text that should be displayed when the mouse hovers over this item.
getVisible | Gets a value indicating whether this item is visible.
getZIndex | Gets the z-order position of the object.
hitTest | Returns the diagram item that contains the specified point.
loadFromXml | Override this method to load custom item properties from XML.
onRemove | Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo.
removeCanvasElements | Derived classes must implement this method by removing their graphics primitives from the canvas.elements collection.
saveLocationState | Saves the state of this DiagramItem.
setBrush | Sets an object that specifies how to paint the interior of the DiagramItem.
setFont | Sets the font used to render this item's text.
setHyperLink | Sets the hyperlink associated with this diagram item.
setId | Lets you set any object as an id for this item.
setIgnoreLayout | Sets a value indicating whether the position of this item should not be changed by automatic layout methods.
setLocked | Sets a value indicating whether users are allowed to modify this item.
setPen | Sets an object used to paint the frame of the item.
setSelected | Sets a value indicating whether a DiagramItem is selected.
setShadowColor | Sets the color used to draw the shadow of this item.
setShadowOffsetX | Sets the horizonal offset of the item's shadow.
setShadowOffsetY | Sets the vertical offset of the item's shadow.
setStroke | Sets a string specifying the color used to stroke the item's frame.
setStrokeDashStyle | Sets the line dash pattern applied when stroking the item's frame.
setStrokeThickness | Sets the line width applied when stroking the item's frame.
setStyle | Sets the style associated with this item.
setTag | Lets you set any object as a tag for this item.
setText | Sets a string containing the DiagramItem's text.
setTextColor | Sets a string specifying the color of the text of this item.
setTextPadding | Sets the spacing between the item boundaries and its text.
setTextStroke | Sets a string specifying the color of the text outline of this item.
setTextStrokeThickness | Sets the width of the text outline of this item.
setTooltip | Sets the tooltip text that should be displayed when the mouse hovers over this item.
setVisible | Sets a value indicating whether this item is visible.
setZIndex | Sets the z-order position of the object.
startDrag | Invoked when the user starts dragging this item.
toJson | Serializes this item into a JSON string.
updateCanvasElements | Derived classes must implement this method to update the item's visual elements.
updateDrag | Invoked while the user drags this item.

See Also

DiagramItem Class


MindFusion.Diagramming.DiagramItem.addCanvasElements Method

DiagramItem.addCanvasElements Method
[image]

Derived classes must implement this method by adding their graphics primitives to the canvas.elements collection.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function addCanvasElements ()

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.allowDrag Method

DiagramItem.allowDrag Method
[image]

Invoked to validate the drag operation.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function allowDrag (ist)

Parameters

ist
An InteractionState object that encapsulates the current state of user interaction with the control.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.cancelDrag Method

DiagramItem.cancelDrag Method
[image]

Invoked when the interactive modification of this object has been canceled.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function cancelDrag (ist)

Parameters

ist
An InteractionState object that encapsulates the current state of user interaction with the control.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.containsPoint Method

DiagramItem.containsPoint Method
[image]

Determines whether this item contains the specified point.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function containsPoint (point)

Parameters

point
The Point to check.

Return Value

true if this item contains the specified point; otherwise, false.

Remarks

This method is used during hit-testing to see if the mouse is inside the item.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.fromJson Method

DiagramItem.fromJson Method
[image]

Deserializes this item from a JSON string.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function fromJson (json)

Parameters

json

A string created by the toJson method.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getBrush Method

DiagramItem.getBrush Method
[image]

Gets the object that specifies how to paint the interior of the DiagramItem.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getBrush ()

Return Value

An object specifying the fill of the item.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getEffectiveBrush Method

DiagramItem.getEffectiveBrush Method
[image]

Gets the effective brush that should be used to paint this item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getEffectiveBrush ()

Return Value

An object specifying the fill of this item.

Remarks

This method returns the brush set locally for an item via setBrush, or looks up in the styling hierarchy for a brush set in the item's Style, the diagram's Style or the current Theme.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
setBrush Method
setStyle Method


MindFusion.Diagramming.DiagramItem.getEffectiveFont Method

DiagramItem.getEffectiveFont Method
[image]

Gets the effective font that should be used to render this item's text.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getEffectiveFont ()

Return Value

A Font instance.

Remarks

This method returns a font set locally for an item via setFont, or constructs a font from the results of getEffectiveFontName and getEffectiveFontSize methods.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
setFont Method
setStyle Method


MindFusion.Diagramming.DiagramItem.getEffectiveFontName Method

DiagramItem.getEffectiveFontName Method
[image]

Gets the name of the effective font that should be used to render this item's text.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getEffectiveFontName ()

Return Value

A string specifying the font name.

Remarks

This method looks up in the styling hierarchy for font names set in the item's Style, the diagram's Style or the current Theme.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getEffectiveFontSize Method

DiagramItem.getEffectiveFontSize Method
[image]

Gets the size of the effective font that should be used to render this item's text.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getEffectiveFontSize ()

Return Value

A number specifying the font size.

Remarks

This method looks up in the styling hierarchy for font sizes set in the item's Style, the diagram's Style or the current Theme.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getEffectiveFontStyle Method

DiagramItem.getEffectiveFontStyle Method
[image]

Gets the style of the effective font that should be used to render this item's text.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getEffectiveFontStyle ()

Return Value

A combination of FontStyle enumeration members.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getEffectiveShadowColor Method

DiagramItem.getEffectiveShadowColor Method
[image]

Gets the effective color that should be used to render this item's shadow.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getEffectiveShadowColor ()

Return Value

A string specifying the item's shadow color.

Remarks

This method returns the shadow color set locally for an item via setShadowColor, or looks up in the styling hierarchy for a shadow color set in the item's Style, the diagram's Style or the current Theme.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
setShadowColor Method
setStyle Method


MindFusion.Diagramming.DiagramItem.getEffectiveStroke Method

DiagramItem.getEffectiveStroke Method
[image]

Gets the effective color that should be used to stroke this item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getEffectiveStroke ()

Return Value

A string specifying the item's stroke color.

Remarks

This method returns the stroke color set locally for an item via setStroke, or looks up in the styling hierarchy for a stroke color set in the item's Style, the diagram's Style or the current Theme.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
setStroke Method
setStyle Method


MindFusion.Diagramming.DiagramItem.getEffectiveStrokeDashStyle Method

DiagramItem.getEffectiveStrokeDashStyle Method
[image]

Gets the effective line dash pattern that should be applied when stroking this item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getEffectiveStrokeDashStyle ()

Return Value

A member of the DashStyle enumeration.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getEffectiveStrokeThickness Method

DiagramItem.getEffectiveStrokeThickness Method
[image]

Gets the effective line thickness that should be applied when stroking this item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getEffectiveStrokeThickness ()

Return Value

A number specifying the item's stroke thickness.

Remarks

This method returns the stroke thickness set locally for an item via setStrokeThickness, or looks up in the styling hierarchy for a stroke color set in the item's Style, the diagram's Style or the current Theme.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
setStrokeThickness Method
setStyle Method


MindFusion.Diagramming.DiagramItem.getEffectiveTextColor Method

DiagramItem.getEffectiveTextColor Method
[image]

Gets the effective text color that should be used to render this item's text.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getEffectiveTextColor ()

Return Value

A string specifying the item's text color.

Remarks

This method returns the text color set locally for an item via setTextColor, or looks up in the styling hierarchy for a text color set in the item's Style, the diagram's Style or the current Theme.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
setTextColor Method
setStyle Method


MindFusion.Diagramming.DiagramItem.getEffectiveTextStroke Method

DiagramItem.getEffectiveTextStroke Method
[image]

Gets the effective text color that should be used to render this item's text outline.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getEffectiveTextStroke ()

Return Value

A string specifying the item's text outline color.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getEffectiveTextStrokeThickness Method

DiagramItem.getEffectiveTextStrokeThickness Method
[image]

Gets the effective width of the text outline of this item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getEffectiveTextStrokeThickness ()

Return Value

The width of the text outline of this item.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getFont Method

DiagramItem.getFont Method
[image]

Gets the font used to render this item's text.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getFont ()

Return Value

A Font instance.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getHyperLink Method

DiagramItem.getHyperLink Method
[image]

Gets the hyperlink associated with this diagram item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getHyperLink ()

Return Value

The hyperlink.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getId Method

DiagramItem.getId Method
[image]

Gets the id of the item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getId ()

Return Value

The id.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getIgnoreLayout Method

DiagramItem.getIgnoreLayout Method
[image]

Gets a value indicating whether the position of this item should not be changed by automatic layout methods.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getIgnoreLayout ()

Return Value

true if this item is not affected by automatic layout; otherwise, false.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getLayoutTraits Method

DiagramItem.getLayoutTraits Method
[image]

Gets an object containing properties of the node specific to some layout algorithms.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getLayoutTraits ()

Return Value

An object containing the node's layout properties.

Remarks

At this time this property is used only by TreeLayout in JavaScript version of the library:

  • TreeLayout looks for a treeLayoutAssistant value set to a member of the AssistantType enumeration.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getLocked Method

DiagramItem.getLocked Method
[image]

Gets a value indicating whether users are allowed to modify this item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getLocked ()

Return Value

true to prevent users from modifying the item, otherwise false.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getParent Method

DiagramItem.getParent Method
[image]

Gets the parent diagram.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getParent ()

Return Value

Gets the Diagram this DiagramItem belongs to.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getPen Method

DiagramItem.getPen Method
[image]

Gets an object used to paint the frame of the item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getPen ()

Return Value

A string value identifying the stroke of the item frame.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getSelected Method

DiagramItem.getSelected Method
[image]

Gets a value indicating whether a DiagramItem is selected.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getSelected ()

Return Value

true if the item is selected; otherwise, false.

Remarks

Use the property to check which items are selected by the user, or to programmatically select items if needed.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getShadowColor Method

DiagramItem.getShadowColor Method
[image]

Gets the color used to draw the shadow of this item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getShadowColor ()

Return Value

A string specifying the shadow color.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getShadowOffsetX Method

DiagramItem.getShadowOffsetX Method
[image]

Gets the horizonal offset of the item's shadow.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getShadowOffsetX ()

Return Value

A number specifying the shadow's horizontal offset.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getShadowOffsetY Method

DiagramItem.getShadowOffsetY Method
[image]

Gets the vertical offset of the item's shadow.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getShadowOffsetY ()

Return Value

A number specifying the shadow's vertical offset.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getStroke Method

DiagramItem.getStroke Method
[image]

Gets a string specifying the color used to stroke the item's frame.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getStroke ()

Return Value

A string value identifying the stroke color.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getStrokeDashStyle Method

DiagramItem.getStrokeDashStyle Method
[image]

Gets the line dash pattern applied when stroking the item's frame.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getStrokeDashStyle ()

Return Value

A member of the DashStyle enumeration.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getStrokeThickness Method

DiagramItem.getStrokeThickness Method
[image]

Gets the line width applied when stroking the item's frame.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getStrokeThickness ()

Return Value

A number identifying the stroke thickness.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getStyle Method

DiagramItem.getStyle Method
[image]

Gets the style associated with this item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getStyle ()

Return Value

An instance of the Style class.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getTag Method

DiagramItem.getTag Method
[image]

Gets the tag of the item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getTag ()

Return Value

The tag.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getText Method

DiagramItem.getText Method
[image]

Gets the string containing the DiagramItem's text.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getText ()

Return Value

A string that contains the text.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
setFont Method
setTextColor Method


MindFusion.Diagramming.DiagramItem.getTextColor Method

DiagramItem.getTextColor Method
[image]

Gets a string specifying the color of the text of this item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getTextColor ()

Return Value

A string value identifying the color of the text.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getTextPadding Method

DiagramItem.getTextPadding Method
[image]

Gets the spacing between the item boundaries and its text.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getTextPadding ()

Return Value

A Thickness instance specifying the size of padding space left around the text.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getTextStroke Method

DiagramItem.getTextStroke Method
[image]

Gets a string specifying the color of the text outline of this item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getTextStroke ()

Return Value

A string value identifying the color of the text outline.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getTextStrokeThickness Method

DiagramItem.getTextStrokeThickness Method
[image]

Gets the width of the text outline of this item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getTextStrokeThickness ()

Return Value

The width of the text outline of this item.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getTooltip Method

DiagramItem.getTooltip Method
[image]

Gets the tooltip text that should be displayed when the mouse hovers over this item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getTooltip ()

Return Value

A string containing the tooltip text.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getVisible Method

DiagramItem.getVisible Method
[image]

Gets a value indicating whether this item is visible.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getVisible ()

Return Value

true if this item should be displayed; otherwise, false.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.getZIndex Method

DiagramItem.getZIndex Method
[image]

Gets the z-order position of the object.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function getZIndex ()

Return Value

A number specifying the position of the diagram item within the z-order.

Remarks

Use the method to arrange item in z-order. Items with lower ZIndex appear behind items with higher ZIndex.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.hitTest Method

DiagramItem.hitTest Method
[image]

Returns the diagram item that contains the specified point.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function hitTest (point, [threshold, [onlyNodes, [onlyInteractive]]])

Parameters

point

A Point value specifying the logical coordinates of a diagram point.

threshold
Optional.

Specifies the size of the area around the item outlines where the point is still considered inside the item.

onlyNodes
Optional.

true to exclude child links from the search.

onlyInteractive
Optional.

true to exclude locked items from the search.

Return Value

The item that contains the specified point.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.loadFromXml Method

DiagramItem.loadFromXml Method
[image]

Override this method to load custom item properties from XML.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function loadFromXml (xmlElement, context)

Parameters

xmlElement

An XML DOM element that contains the item's serialized content.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.onRemove Method

DiagramItem.onRemove Method
[image]

Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function onRemove ()

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.removeCanvasElements Method

DiagramItem.removeCanvasElements Method
[image]

Derived classes must implement this method by removing their graphics primitives from the canvas.elements collection.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function removeCanvasElements ()

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.saveLocationState Method

DiagramItem.saveLocationState Method
[image]

Saves the state of this DiagramItem.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function saveLocationState ()

Return Value

A DiagramLinkState instance.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.setBrush Method

DiagramItem.setBrush Method
[image]

Sets an object that specifies how to paint the interior of the DiagramItem.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function setBrush (value)

Parameters

value
A Brush object specifying the fill of the item.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.setFont Method

DiagramItem.setFont Method
[image]

Sets the font used to render this item's text.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function setFont (value)

Parameters

value

A Font instance.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.setHyperLink Method

DiagramItem.setHyperLink Method
[image]

Sets the hyperlink associated with this diagram item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function setHyperLink (value)

Parameters

value

The hyperlink.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.setId Method

DiagramItem.setId Method
[image]

Lets you set any object as an id for this item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function setId (value)

Parameters

value

The id of the item.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.setIgnoreLayout Method

DiagramItem.setIgnoreLayout Method
[image]

Sets a value indicating whether the position of this item should not be changed by automatic layout methods.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function setIgnoreLayout (value)

Parameters

value

true to prevent layout methods from changing the position of this item; otherwise, false.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.setLocked Method

DiagramItem.setLocked Method
[image]

Sets a value indicating whether users are allowed to modify this item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function setLocked (value)

Parameters

value

true to prevent users from modifying the item, otherwise false.

Remarks

A locked item cannot be selected, moved or resized interactively. Additionally, its text cannot be edited in-place.

Locked nodes still can be moved or resized programmatically through their setBounds method. Positions of locked links' control points can be changed programmatically too - through their ControlPoints collections.

Locked items positions can be changed also by the automatic layout algorithms. To prevent automatic layout methods from changing positions of individual items, set the IgnoreLayout property of DiagramItem to false.

See Also

DiagramItem Members
DiagramItem Class
setVisible Method


MindFusion.Diagramming.DiagramItem.setPen Method

DiagramItem.setPen Method
[image]

Sets an object used to paint the frame of the item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function setPen (value)

Parameters

value

A Pen value identifying the stroke of the item frame.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.setSelected Method

DiagramItem.setSelected Method
[image]

Sets a value indicating whether a DiagramItem is selected.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function setSelected (value)

Parameters

value

true if the item is selected; otherwise, false.

Remarks

Use the property to check which items are selected by the user, or to programmatically select items if needed.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.setShadowColor Method

DiagramItem.setShadowColor Method
[image]

Sets the color used to draw the shadow of this item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function setShadowColor (value)

Parameters

value

A string specifying the shadow color.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
setShadowOffsetX Method
setShadowOffsetY Method


MindFusion.Diagramming.DiagramItem.setShadowOffsetX Method

DiagramItem.setShadowOffsetX Method
[image]

Sets the horizonal offset of the item's shadow.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function setShadowOffsetX (value)

Parameters

value

A number specifying the shadow's horizontal offset.

See Also

DiagramItem Members
DiagramItem Class
setShadowColor Method


MindFusion.Diagramming.DiagramItem.setShadowOffsetY Method

DiagramItem.setShadowOffsetY Method
[image]

Sets the vertical offset of the item's shadow.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function setShadowOffsetY (value)

Parameters

value

A number specifying the shadow's vertical offset.

See Also

DiagramItem Members
DiagramItem Class
setShadowColor Method


MindFusion.Diagramming.DiagramItem.setStroke Method

DiagramItem.setStroke Method
[image]

Sets a string specifying the color used to stroke the item's frame.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function setStroke (value)

Parameters

value

A string value identifying the stroke color.

See Also

DiagramItem Members
DiagramItem Class
setStrokeThickness Method


MindFusion.Diagramming.DiagramItem.setStrokeDashStyle Method

DiagramItem.setStrokeDashStyle Method
[image]

Sets the line dash pattern applied when stroking the item's frame.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function setStrokeDashStyle (value)

Parameters

value

A member of the DashStyle enumeration.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.setStrokeThickness Method

DiagramItem.setStrokeThickness Method
[image]

Sets the line width applied when stroking the item's frame.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function setStrokeThickness (value)

Parameters

value

A number identifying the stroke thickness.

See Also

DiagramItem Members
DiagramItem Class
setStroke Method


MindFusion.Diagramming.DiagramItem.setStyle Method

DiagramItem.setStyle Method
[image]

Sets the style associated with this item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function setStyle (value)

Parameters

value

An instance of the Style class.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.setTag Method

DiagramItem.setTag Method
[image]

Lets you set any object as a tag for this item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function setTag (value)

Parameters

value

The tag of the item.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.setText Method

DiagramItem.setText Method
[image]

Sets a string containing the DiagramItem's text.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function setText (value)

Parameters

value

The string to set.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
TextColor Property
TextPadding Property
EnableStyledText Property


MindFusion.Diagramming.DiagramItem.setTextColor Method

DiagramItem.setTextColor Method
[image]

Sets a string specifying the color of the text of this item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function setTextColor (value)

Parameters

value

A string value identifying the color of the text.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.setTextPadding Method

DiagramItem.setTextPadding Method
[image]

Sets the spacing between the item boundaries and its text.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function setTextPadding (value)

Parameters

value

A Thickness instance specifying the size of padding space left around the text.

See Also

DiagramItem Members
DiagramItem Class
Text Property


MindFusion.Diagramming.DiagramItem.setTextStroke Method

DiagramItem.setTextStroke Method
[image]

Sets a string specifying the color of the text outline of this item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function setTextStroke (value)

Parameters

value

A string value identifying the color of the text outline.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.setTextStrokeThickness Method

DiagramItem.setTextStrokeThickness Method
[image]

Sets the width of the text outline of this item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function setTextStrokeThickness (value)

Parameters

value

The width of the text outline of this item.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.setTooltip Method

DiagramItem.setTooltip Method
[image]

Sets the tooltip text that should be displayed when the mouse hovers over this item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function setTooltip (value)

Parameters

value

A string containing the tooltip text.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.setVisible Method

DiagramItem.setVisible Method
[image]

Sets a value indicating whether this item is visible.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function setVisible (value)

Parameters

value

true to display this item; otherwise, false.

Remarks

Invisible items are not drawn at all. You might use the property to hide or show items temporarily, or to construct complex group hierarchies in which intermediate helper items are invisible.

Invisible nodes are ignored by automatic layout classes. The position of such nodes won't change when the arrange method of Diagram is called. Visible items can be ignored too by enabling their IgnoreLayout property.

See Also

DiagramItem Members
DiagramItem Class
setLocked Method


MindFusion.Diagramming.DiagramItem.setZIndex Method

DiagramItem.setZIndex Method
[image]

Sets the z-order position of the object.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function setZIndex (value)

Parameters

value

A number specifying the position of the diagram item within the z-order.

Remarks

Use the method to arrange item in z-order. Items with lower ZIndex appear behind items with higher ZIndex.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.startDrag Method

DiagramItem.startDrag Method
[image]

Invoked when the user starts dragging this item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function startDrag (ist)

Parameters

ist
An InteractionState object that encapsulates the current state of user interaction with the control.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.toJson Method

DiagramItem.toJson Method
[image]

Serializes this item into a JSON string.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function toJson ()

Return Value

A string containing the item's JSON representation.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.updateCanvasElements Method

DiagramItem.updateCanvasElements Method
[image]

Derived classes must implement this method to update the item's visual elements.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function updateCanvasElements ()

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.updateDrag Method

DiagramItem.updateDrag Method
[image]

Invoked while the user drags this item.

Namespace: MindFusion.Diagramming
Assembly: DiagramItem.js

Syntax

JavaScript [image] Copy Code

function updateDrag (ist)

Parameters

ist
An InteractionState object that encapsulates the current state of user interaction with the control.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramLink Class

DiagramLink Class
Remarks See Also
[image]

Represents a link between two diagram nodes.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

// class
DiagramLink.prototype = {}

Remarks

Links between nodes in MvcDiagram are represented by instances of the diagramLink class. Links connect at most two nodes, which can be accessed via the Origin and Destination properties.

Links are built of smaller parts called segments, which can be straight lines, cascading orthogonal lines or Bezier curves. The type of segments is set through the Shape property. The number of link's segments is specified by the setControlPoints method. Access to control point locations is provided by the getControlPoints method.

Inheritance Hierarchy

See Also

DiagramLink Members


MindFusion.Diagramming.DiagramLink Members

DiagramLink Members
Constructors Methods
[image]

Represents a link between two diagram nodes.

The following tables list the members exposed by the DiagramLink type.

Public Constructors

Name | Description
DiagramLink | Initializes a new instance of the DiagramLink class between the specified nodes using the specified diagram link as a prototype.

Public Methods

Name | Description
addLabel | Adds a new label to this link.
allowDrag | DiagramItem.allowDrag override.
containsPoint | DiagramItem.containsPoint override.
endDrag | DiagramItem.endDrag override.
getAutoRoute | Gets a value indicating whether a link should avoid nodes by going the shortest path from its origin to its destination without crossing any other nodes.
getBaseBrush | Gets an object that specifies how to paint the interior of the link's base shape.
getBaseShape | Gets the shape displayed at the beginning of this link.
getBaseShapeSize | Gets the size of the shape displayed at the beginning of this link.
getControlPoints | Gets a collection of the control points of this link.
getDestination | Gets the destination node of this link.
getDynamic | Gets a value indicating whether a link automatically adjusts its end points' positions in order to keep pointing to the centers of nodes that it connects.
getEndPoint | Gets the last control point of this link.
getHeadBrush | Gets a Brush that specifies how to paint the interior of the link's arrowhead shape.
getHeadShape | Gets the shape displayed at the end of this link.
getHeadShapeSize | Gets the size of the shape displayed at the end of this link.
getOrigin | Gets the origin node of this link.
getSegmentCount | Gets the number of segments that form the link's geometry.
getShape | Gets the type of link segments and how they are positioned relatively to each other.
getStartPoint | Gets the first control point of this link.
getText | Gets the text displayed over this link.
getTextAlignment | Gets the link's text alignment.
getTextStyle | Gets the link's text placement and orientation.
getTopLevel | DiagramItem.getTopLevel override.
intersects | Checks whether the link contour intersects with the outline of the specified node.
putEndPointsAtNodeBorders | Places the link's end points on the outline of its origin and destination nodes.
removeLabel | Removes the specified label from this link.
restoreLocationState | DiagramItem.restoreLocationState override.
route | Routes this link, regardless of whether the link's AutoRoute flag is enabled.
saveLocationState | DiagramItem.saveLocationState override.
setAutoRoute | Sets a value indicating whether a link should avoid nodes by going the shortest path from its origin to its destination without crossing any other nodes.
setBaseBrush | Sets an object that specifies how to paint the interior of the link's base shape.
setBaseShape | Sets the shape to display at the beginning of this link.
setBaseShapeSize | Gets the size of the BaseShape shape.
setControlPoints | Sets a collection of the control points of this link.
setDestination | Sets the destination node of this link.
setDynamic | Sets a value indicating whether a link automatically adjusts its end points' positions in order to keep pointing to the centers of nodes that it connects.
setEndPoint | Sets the last control point of this link.
setHeadBrush | Sets a Brush that specifies how to paint the interior of the link's arrowhead ShapeNode.
setHeadShape | Sets the shape to display at the end of this link.
setHeadShapeSize | Gets the size of the arrowhead shape.
setOrigin | Sets the origin node of this link.
setSegmentCount | Sets the number of segments that form the link's geometry.
setShape | Sets the type of link segments and how they are positioned relatively to each other.
setStartPoint | Sets the first control point of this link.
setText | Sets the text displayed over a link.
setTextAlignment | Sets the link's text alignment.
setTextStyle | Sets the link's text placement and orientation.
startDrag | DiagramItem.startDrag override.
updateCanvasElements | Updates the elements on the HTML Canvas.
updateDrag | DiagramItem.updateDrag override.
updateFromPoints | Updates the link's internal state after the link's control points have been changed.

See Also

DiagramLink Class


MindFusion.Diagramming.DiagramLink Constructor

DiagramLink Constructor
[image]

Initializes a new instance of the DiagramLink class between the specified nodes using the specified diagram link as a prototype.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function DiagramLink ([parent, [origin, [destination]]])

Parameters

parent
Optional. The Diagram from which to obtain default values for the link properties.
origin
Optional.

The origin node of the new link.

destination
Optional.

The destination node of the new link.

See Also

DiagramLink Class


MindFusion.Diagramming.DiagramLink Methods

DiagramLink Methods
[image]

Public Methods

Name | Description
addLabel | Adds a new label to this link.
allowDrag | DiagramItem.allowDrag override.
containsPoint | DiagramItem.containsPoint override.
endDrag | DiagramItem.endDrag override.
getAutoRoute | Gets a value indicating whether a link should avoid nodes by going the shortest path from its origin to its destination without crossing any other nodes.
getBaseBrush | Gets an object that specifies how to paint the interior of the link's base shape.
getBaseShape | Gets the shape displayed at the beginning of this link.
getBaseShapeSize | Gets the size of the shape displayed at the beginning of this link.
getControlPoints | Gets a collection of the control points of this link.
getDestination | Gets the destination node of this link.
getDynamic | Gets a value indicating whether a link automatically adjusts its end points' positions in order to keep pointing to the centers of nodes that it connects.
getEndPoint | Gets the last control point of this link.
getHeadBrush | Gets a Brush that specifies how to paint the interior of the link's arrowhead shape.
getHeadShape | Gets the shape displayed at the end of this link.
getHeadShapeSize | Gets the size of the shape displayed at the end of this link.
getOrigin | Gets the origin node of this link.
getSegmentCount | Gets the number of segments that form the link's geometry.
getShape | Gets the type of link segments and how they are positioned relatively to each other.
getStartPoint | Gets the first control point of this link.
getText | Gets the text displayed over this link.
getTextAlignment | Gets the link's text alignment.
getTextStyle | Gets the link's text placement and orientation.
getTopLevel | DiagramItem.getTopLevel override.
intersects | Checks whether the link contour intersects with the outline of the specified node.
putEndPointsAtNodeBorders | Places the link's end points on the outline of its origin and destination nodes.
removeLabel | Removes the specified label from this link.
restoreLocationState | DiagramItem.restoreLocationState override.
route | Routes this link, regardless of whether the link's AutoRoute flag is enabled.
saveLocationState | DiagramItem.saveLocationState override.
setAutoRoute | Sets a value indicating whether a link should avoid nodes by going the shortest path from its origin to its destination without crossing any other nodes.
setBaseBrush | Sets an object that specifies how to paint the interior of the link's base shape.
setBaseShape | Sets the shape to display at the beginning of this link.
setBaseShapeSize | Gets the size of the BaseShape shape.
setControlPoints | Sets a collection of the control points of this link.
setDestination | Sets the destination node of this link.
setDynamic | Sets a value indicating whether a link automatically adjusts its end points' positions in order to keep pointing to the centers of nodes that it connects.
setEndPoint | Sets the last control point of this link.
setHeadBrush | Sets a Brush that specifies how to paint the interior of the link's arrowhead ShapeNode.
setHeadShape | Sets the shape to display at the end of this link.
setHeadShapeSize | Gets the size of the arrowhead shape.
setOrigin | Sets the origin node of this link.
setSegmentCount | Sets the number of segments that form the link's geometry.
setShape | Sets the type of link segments and how they are positioned relatively to each other.
setStartPoint | Sets the first control point of this link.
setText | Sets the text displayed over a link.
setTextAlignment | Sets the link's text alignment.
setTextStyle | Sets the link's text placement and orientation.
startDrag | DiagramItem.startDrag override.
updateCanvasElements | Updates the elements on the HTML Canvas.
updateDrag | DiagramItem.updateDrag override.
updateFromPoints | Updates the link's internal state after the link's control points have been changed.

See Also

DiagramLink Class


MindFusion.Diagramming.DiagramLink.addLabel Method

DiagramLink.addLabel Method
[image]

Adds a new label to this link.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function addLabel (text)

Parameters

text

The label's text.

Return Value

A LinkLabel instance.

See Also

DiagramLink Members
DiagramLink Class
removeLabel Method


MindFusion.Diagramming.DiagramLink.allowDrag Method

DiagramLink.allowDrag Method
[image]

DiagramItem.allowDrag override.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function allowDrag (ist)

Parameters

ist
An InteractionState object that encapsulates the current state of user interaction with the control.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.containsPoint Method

DiagramLink.containsPoint Method
[image]

DiagramItem.containsPoint override.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function containsPoint (point)

Parameters

point
The Point to check.

Return Value

true if the link contains the point; otherwise, false.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.endDrag Method

DiagramLink.endDrag Method
[image]

DiagramItem.endDrag override.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function endDrag (ist)

Parameters

ist
An InteractionState object that encapsulates the current state of user interaction with the control.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.getAutoRoute Method

DiagramLink.getAutoRoute Method
[image]

Gets a value indicating whether a link should avoid nodes by going the shortest path from its origin to its destination without crossing any other nodes.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function getAutoRoute ()

Return Value

true to route this link automatically; otherwise, false.

See Also

DiagramLink Members
DiagramLink Class
Dynamic Property


MindFusion.Diagramming.DiagramLink.getBaseBrush Method

DiagramLink.getBaseBrush Method
[image]

Gets an object that specifies how to paint the interior of the link's base shape.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function getBaseBrush ()

Return Value

An object specifying the fill of the shape.

Remarks

If this field is not set, the arrowhead is filled using the link's Brush.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.getBaseShape Method

DiagramLink.getBaseShape Method
[image]

Gets the shape displayed at the beginning of this link.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function getBaseShape ()

Return Value

A Shape instance that represents an arrowhead shape.

Remarks

This property specifies the shape that is displayed at the beginning of a link, that is, the point where it connects to its origin node. This shape is rotated simultaneously with the first segment of the link so that it follows the overall link direction.

The Shapes class exposes several predefined shapes as static properties.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
setBaseShape Method
getHeadShape Method


MindFusion.Diagramming.DiagramLink.getBaseShapeSize Method

DiagramLink.getBaseShapeSize Method
[image]

Gets the size of the shape displayed at the beginning of this link.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function getBaseShapeSize ()

Return Value

A number that represents the size of the arrowhead shape.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.getControlPoints Method

DiagramLink.getControlPoints Method
[image]

Gets a collection of the control points of this link.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function getControlPoints ()

Return Value

A collection of control Points that specify the link's shape.

Remarks

Use this method to find the positions of link's points, or to set new point coordinates. The number of points per link segment depends on the Shape property. Links made of Bйzier-splines have four control points for each segment. Links of the other styles have two control points per segment. Adjacent segments share a common control point. After setting new positions of control points you must call the updateFromPoints method.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
Shape Property
SegmentCount Property


MindFusion.Diagramming.DiagramLink.getDestination Method

DiagramLink.getDestination Method
[image]

Gets the destination node of this link.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function getDestination ()

Return Value

The DiagramNode that is destination of this link.

Remarks

The link's destination can be changed programmatically with the setDestination method.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
setDestination Method
getOrigin Method


MindFusion.Diagramming.DiagramLink.getDynamic Method

DiagramLink.getDynamic Method
[image]

Gets a value indicating whether a link automatically adjusts its end points' positions in order to keep pointing to the centers of nodes that it connects.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function getDynamic ()

Return Value

true if the link automatically adjusts its end points; otherwise, false.

Remarks

If this property is enabled, moving link's adjacent nodes or next-to-last link control points will also update the position of link end points along the node border.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.getEndPoint Method

DiagramLink.getEndPoint Method
[image]

Gets the last control point of this link.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function getEndPoint ()

Return Value

The Point where the user ended drawing.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.getHeadBrush Method

DiagramLink.getHeadBrush Method
[image]

Gets a Brush that specifies how to paint the interior of the link's arrowhead shape.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function getHeadBrush ()

Return Value

An object specifying the fill of the shape.

Remarks

If this property is not set, the arrowhead is filled using the link's Brush.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.getHeadShape Method

DiagramLink.getHeadShape Method
[image]

Gets the shape displayed at the end of this link.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function getHeadShape ()

Return Value

A Shape instance that represents an arrowhead shape.

Remarks

This property specifies the shape that is displayed at the end of a link, that is, the point where it connects to its destination node. This shape is rotated simultaneously with the last segment of the link so that it follows the overall link direction.

The Shapes class exposes several predefined shapes as static properties.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
setHeadShape Method
getBaseShape Method


MindFusion.Diagramming.DiagramLink.getHeadShapeSize Method

DiagramLink.getHeadShapeSize Method
[image]

Gets the size of the shape displayed at the end of this link.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function getHeadShapeSize ()

Return Value

A number that represents the size of the arrowhead shape.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.getOrigin Method

DiagramLink.getOrigin Method
[image]

Gets the origin node of this link.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function getOrigin ()

Return Value

The DiagramNode that is the origin of this link.

Remarks

The link's origin can be changed programmatically with the setOrigin method.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
setOrigin Method
getDestination Method


MindFusion.Diagramming.DiagramLink.getSegmentCount Method

DiagramLink.getSegmentCount Method
[image]

Gets the number of segments that form the link's geometry.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function getSegmentCount ()

Return Value

An integer value specifying the number of segments of this link.

Remarks

Link segments are either straight lines or Bezier curves, depending on the value of the link's Shape property. The segment coordinates are defined by the elements of ControlPoints, which contains four points per Bezier segment or two points per straight line segment, where each pair of adjacent segments share a common point.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.getShape Method

DiagramLink.getShape Method
[image]

Gets the type of link segments and how they are positioned relatively to each other.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function getShape ()

Return Value

One of the LinkShape enumeration values.

Remarks

This property specifies whether the segments of a link are straight lines or curves. In case of straight lines, they can be set all horizontal and vertical, each segment orthogonal to its neighbor, by using the Cascading shape.

See Also

DiagramLink Members
DiagramLink Class
getControlPoints Method


MindFusion.Diagramming.DiagramLink.getStartPoint Method

DiagramLink.getStartPoint Method
[image]

Gets the first control point of this link.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function getStartPoint ()

Return Value

The Point where the user starts drawing.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.getText Method

DiagramLink.getText Method
[image]

Gets the text displayed over this link.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function getText ()

Return Value

A string containing the link's text.

Remarks

Gets or sets the text that should be drawn over a link. Use this to provide to end-users a short description of the relation's purpose. The text appearance can be customized through the TextColor and TextStyle properties.

Version 1.6 of the control adds the capability to display multiple labels per link via the LinkLabel class. Labels can automatically avoid overlapping nodes or other labels when their AutoArrange property is set.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
ToolTip Property
addLabel Method


MindFusion.Diagramming.DiagramLink.getTextAlignment Method

DiagramLink.getTextAlignment Method
[image]

Gets the link's text alignment.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function getTextAlignment ()

Return Value

A member of the Alignment enumeration.

Remarks

Currently this property is considered only when TextStyle is set to OverLongestSegment.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.getTextStyle Method

DiagramLink.getTextStyle Method
[image]

Gets the link's text placement and orientation.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function getTextStyle ()

Return Value

A member of the LinkTextStyle enumeration.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
Text Property
TextColor Property


MindFusion.Diagramming.DiagramLink.getTopLevel Method

DiagramLink.getTopLevel Method
[image]

DiagramItem.getTopLevel override.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function getTopLevel ()

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.intersects Method

DiagramLink.intersects Method
[image]

Checks whether the link contour intersects with the outline of the specified node.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function intersects (rect)

Parameters

rect

The bounding rectangle of the specified node.

Return Value

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.putEndPointsAtNodeBorders Method

DiagramLink.putEndPointsAtNodeBorders Method
[image]

Places the link's end points on the outline of its origin and destination nodes.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function putEndPointsAtNodeBorders (action, routing)

Parameters

action

routing

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.removeLabel Method

DiagramLink.removeLabel Method
[image]

Removes the specified label from this link.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function removeLabel (label)

Parameters

label

A LinkLabel instance.

See Also

DiagramLink Members
DiagramLink Class
addLabel Method


MindFusion.Diagramming.DiagramLink.restoreLocationState Method

DiagramLink.restoreLocationState Method
[image]

DiagramItem.restoreLocationState override.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function restoreLocationState (ist)

Parameters

ist
A DiagramLinkState instance.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.route Method

DiagramLink.route Method
[image]

Routes this link, regardless of whether the link's AutoRoute flag is enabled.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function route (args)

Parameters

args

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.saveLocationState Method

DiagramLink.saveLocationState Method
[image]

DiagramItem.saveLocationState override.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function saveLocationState ()

Return Value

A DiagramLinkState instance.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.setAutoRoute Method

DiagramLink.setAutoRoute Method
[image]

Sets a value indicating whether a link should avoid nodes by going the shortest path from its origin to its destination without crossing any other nodes.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function setAutoRoute (value)

Parameters

value

true to route this link automatically; otherwise, false.

See Also

DiagramLink Members
DiagramLink Class
Dynamic Property


MindFusion.Diagramming.DiagramLink.setBaseBrush Method

DiagramLink.setBaseBrush Method
[image]

Sets an object that specifies how to paint the interior of the link's base shape.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function setBaseBrush (value)

Parameters

value
A Brush specifying the fill of the shape.

Remarks

If this property is not set, the arrowhead is filled using the link's Brush.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.setBaseShape Method

DiagramLink.setBaseShape Method
[image]

Sets the shape to display at the beginning of this link.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function setBaseShape (shape)

Parameters

shape
A Shape instance that represents an arrowhead shape or a String that identifies it.

Remarks

This property specifies the shape that is displayed at the beginning of a link, that is, the point where it connects to its origin node. This shape is rotated simultaneously with the first segment of the link so that it follows the overall link direction.

The Shapes class exposes several predefined shapes as static properties.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
getBaseShape Method
setHeadShape Method


MindFusion.Diagramming.DiagramLink.setBaseShapeSize Method

DiagramLink.setBaseShapeSize Method
[image]

Gets the size of the BaseShape shape.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function setBaseShapeSize (value)

Parameters

value

A number that represents the size of the arrowhead shape.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.setControlPoints Method

DiagramLink.setControlPoints Method
[image]

Sets a collection of the control points of this link.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function setControlPoints (value)

Parameters

value
A collection of control Point-s that specify the link's shape.

Remarks

You can replace all link points via this method. The number of points per segment depends on the link shape. Links made of Bйzier-splines have four control points for each segment. Links of the other styles have two control points per segment. Adjacent segments share a common control point. After setting new positions of control points, you must call the updateFromPoints method.

See Also

DiagramLink Members
DiagramLink Class
setShape Method


MindFusion.Diagramming.DiagramLink.setDestination Method

DiagramLink.setDestination Method
[image]

Sets the destination node of this link.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function setDestination (destination)

Parameters

destination
The DiagramNode to set as destination for this link.

Remarks

The link's destination can be changed programmatically with this property.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
getDestination Method
setOrigin Method


MindFusion.Diagramming.DiagramLink.setDynamic Method

DiagramLink.setDynamic Method
[image]

Sets a value indicating whether a link automatically adjusts its end points' positions in order to keep pointing to the centers of nodes that it connects.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function setDynamic (value)

Parameters

value

true to make the link automatically adjust its end points; otherwise, false.

Remarks

If this property is enabled, moving link's adjacent nodes or next-to-last link control points will also update the position of link end points along the node border.

See Also

DiagramLink Members
DiagramLink Class
AutoRoute Property


MindFusion.Diagramming.DiagramLink.setEndPoint Method

DiagramLink.setEndPoint Method
[image]

Sets the last control point of this link.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function setEndPoint (value)

Parameters

value

A Point instance containing the control point coordinates.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.setHeadBrush Method

DiagramLink.setHeadBrush Method
[image]

Sets a Brush that specifies how to paint the interior of the link's arrowhead ShapeNode.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function setHeadBrush (value)

Parameters

value
An object specifying the fill of the Shape.

Remarks

If this property is not set, the arrowhead is filled using the link's Brush.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.setHeadShape Method

DiagramLink.setHeadShape Method
[image]

Sets the shape to display at the end of this link.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function setHeadShape (value)

Parameters

value
A Shape instance that represents an arrowhead shape or a String that identifies it.

Remarks

This property specifies the shape that is displayed at the end of a link, that is, the point where it connects to its destination node. This shape is rotated simultaneously with the last segment of the link so that it follows the overall link direction.

The Shapes class exposes several predefined shapes as static properties.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
getHeadShape Method
setBaseShape Method


MindFusion.Diagramming.DiagramLink.setHeadShapeSize Method

DiagramLink.setHeadShapeSize Method
[image]

Gets the size of the arrowhead shape.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function setHeadShapeSize (value)

Parameters

value

A number that represents the size of the arrowhead shape.

See Also

DiagramLink Members
DiagramLink Class
HeadShape Property


MindFusion.Diagramming.DiagramLink.setOrigin Method

DiagramLink.setOrigin Method
[image]

Sets the origin node of this link.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function setOrigin (origin)

Parameters

origin
The DiagramNode to set as origin of this link.

Remarks

The link's origin can be changed programmatically with this method.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
getOrigin Method
setDestination Method


MindFusion.Diagramming.DiagramLink.setSegmentCount Method

DiagramLink.setSegmentCount Method
[image]

Sets the number of segments that form the link's geometry.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function setSegmentCount (value)

Parameters

value

An integer value specifying the number of segments of this link.

Remarks

Link segments are either straight lines or Bezier curves, depending on the value of the link's Shape property. The segment coordinates are defined by the elements of ControlPoints, which contains four points per Bezier segment or two points per straight line segment, where each pair of adjacent segments share a common point. Changing the SegmentCount property value will resize the ControlPoints array so that it contains appropriate number of points.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.setShape Method

DiagramLink.setShape Method
[image]

Sets the type of link segments and how they are positioned relatively to each other.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function setShape (value)

Parameters

value
One of the LinkShape enumeration values.

Remarks

This property specifies whether the segments of a link are straight lines or curves. In case of straight lines, they can be set all horizontal and vertical, each segment orthogonal to its neighbor, by using the Cascading shape.

See Also

DiagramLink Members
DiagramLink Class
getControlPoints Method


MindFusion.Diagramming.DiagramLink.setStartPoint Method

DiagramLink.setStartPoint Method
[image]

Sets the first control point of this link.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function setStartPoint (value)

Parameters

value

A Point instance containing the control point coordinates.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.setText Method

DiagramLink.setText Method
[image]

Sets the text displayed over a link.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function setText (value)

Parameters

value
A string containing the text.

Remarks

Gets or sets the text that should be drawn over a link. Use this to provide to end-users a short description of the relation's purpose. The text appearance can be customized through the TextColor and TextStyle properties.

Version 1.6 of the control adds the capability to display multiple labels per link via the LinkLabel class. Labels can automatically avoid overlapping nodes or other labels when their AutoArrange property is set.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
ToolTip Property
addLabel Method


MindFusion.Diagramming.DiagramLink.setTextAlignment Method

DiagramLink.setTextAlignment Method
[image]

Sets the link's text alignment.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function setTextAlignment (value)

Parameters

value
A member of the Alignment enumeration. The default value is Center.

Remarks

Currently this property is considered only when TextStyle is set to OverLongestSegment.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.setTextStyle Method

DiagramLink.setTextStyle Method
[image]

Sets the link's text placement and orientation.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function setTextStyle (value)

Parameters

value
A member of the LinkTextStyle enumeration. Initialized with the value of LinkTextStyle.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.startDrag Method

DiagramLink.startDrag Method
[image]

DiagramItem.startDrag override.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function startDrag (ist)

Parameters

ist
An InteractionState object that encapsulates the current state of user interaction with the control.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.updateCanvasElements Method

DiagramLink.updateCanvasElements Method
[image]

Updates the elements on the HTML Canvas.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function updateCanvasElements ()

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.updateDrag Method

DiagramLink.updateDrag Method
[image]

DiagramItem.updateDrag override.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function updateDrag (ist)

Parameters

ist
An InteractionState object that encapsulates the current state of user interaction with the control.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.updateFromPoints Method

DiagramLink.updateFromPoints Method
[image]

Updates the link's internal state after the link's control points have been changed.

Namespace: MindFusion.Diagramming
Assembly: DiagramLink.js

Syntax

JavaScript [image] Copy Code

function updateFromPoints ()

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramNode Class

DiagramNode Class
[image]

DiagramNode is an abstract base class from which specific types such as ShapeNode and TableNode derive. DiagramNode instances can represent graph vertices, nodes in organizational or flow diagrams, entities in ER diagrams, and so on.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

// class
DiagramNode.prototype = {}

Inheritance Hierarchy

See Also

DiagramNode Members


MindFusion.Diagramming.DiagramNode Members

DiagramNode Members
Constructors Methods
[image]

DiagramNode is an abstract base class from which specific types such as ShapeNode and TableNode derive. DiagramNode instances can represent graph vertices, nodes in organizational or flow diagrams, entities in ER diagrams, and so on.

The following tables list the members exposed by the DiagramNode type.

Public Constructors

Name | Description
DiagramNode | Initializes a new instance of the DiagramNode class.

Public Methods

Name | Description
acceptLinks | Determines whether the node can be connected with links of the specified type.
allowDrag | DiagramItem.allowDrag override.
attach | Attaches the specified subordinate node to this node, so that when this node is moved, the subordinate follows it.
attachTo | Attaches this node to the specified master node so that when the master is moved, the attached node follows it.
containsPoint | DiagramItem.containsPoint override.
createConnectionPoint | Creates a connection point between this node and the specified link at the specified point.
detach | Detaches this node from its current master node.
endDrag | DiagramItem.endDrag override.
getAllowIncomingLinks | Gets a value indicating whether users are allowed to draw incoming links to this node.
getAllowOutgoingLinks | Sets a value indicating whether users are allowed to draw outgoing links to this node.
getAnchorPattern | Gets the anchor points to which links are attached when connected to this node.
getAttachedNodes | Returns the nodes attached to this node.
getBounds | Gets the rectangle that defines the position of the diagram node.
getCenter | Gets the center of this node's bounding rectangle.
getEffectiveEffects | Gets the effects that should be applied to this item.
getEffects | Gets an array with all effects applied to this node.
getEnabledHandles | Gets the kinds of modifications that end-users are permitted to perform on the node.
getExpandable | Gets a value indicating whether users are allowed to expand or collapse the tree branch that starts at this node.
getExpanded | Gets a value indicating whether the tree branch starting at this node is expanded.
getHandlesStyle | Gets a value indicating how the node adjustment handles behave and what do they look like.
getIncomingLinks | Gets the incoming links collection of this DiagramNode.
getIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline.
getMasterNode | Returns the node to which this node is attached.
getObstacle | Sets a value indicating whether this node is considered an obstacle by the link-routing algorithm.
getOutgoingLinks | Gets the outgoing links collection of this node.
getOutline | Gets the bounding rectangle of this node.
getRotatedBounds | Gets the bounding rectangle of this item when it is rotated.
getRotationAngle | Gets the angle at which this node is rotated.
getTopLevel | DiagramItem.getTopLevel override.
raiseClicked | Raises an event which notifies that a node has been clicked.
raiseDoubleClicked | Raises an event which notifies that a node has been double-clicked.
removeCanvasElements | DiagramItem.removeCanvasElements override.
restoreLocationState | DiagramItem.restoreLocationState override.
saveLocationState | DiagramItem.saveLocationState override.
setAllowIncomingLinks | Sets a value indicating whether users are allowed to draw incoming link-s to this node.
setAllowOutgoingLinks | Sets a value indicating whether users are allowed to draw outgoing link-s from this node.
setAnchorPattern | Sets the anchor points to which links are attached when connected to this node.
setBounds | Sets the rectangle that defines the position of the diagram node.
setEnabledHandles | Sets the kinds of modifications that end-users are permitted to perform on the node.
setExpandable | Sets a value indicating whether users are allowed to expand or collapse the tree branch that starts at this node.
setExpanded | Expands or collapses the tree branch that starts at this node.
setHandlesStyle | Sets a value indicating how the node adjustment handles behave and what do they look like.
setObstacle | Sets a value indicating whether this node is considered an obstacle by the link-routing algorithm.
setRotationAngle | Sets the angle at which this node is rotated.
startDrag | DiagramItem.startDrag override.
updateDrag | DiagramItem.updateDrag override.

See Also

DiagramNode Class


MindFusion.Diagramming.DiagramNode Constructor

DiagramNode Constructor
[image]

Initializes a new instance of the DiagramNode class.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function DiagramNode ([parent])

Parameters

parent
Optional.

A Diagram instance whose default node attributes are copied to this node.

See Also

DiagramNode Class


MindFusion.Diagramming.DiagramNode Methods

DiagramNode Methods
[image]

Public Methods

Name | Description
acceptLinks | Determines whether the node can be connected with links of the specified type.
allowDrag | DiagramItem.allowDrag override.
attach | Attaches the specified subordinate node to this node, so that when this node is moved, the subordinate follows it.
attachTo | Attaches this node to the specified master node so that when the master is moved, the attached node follows it.
containsPoint | DiagramItem.containsPoint override.
createConnectionPoint | Creates a connection point between this node and the specified link at the specified point.
detach | Detaches this node from its current master node.
endDrag | DiagramItem.endDrag override.
getAllowIncomingLinks | Gets a value indicating whether users are allowed to draw incoming links to this node.
getAllowOutgoingLinks | Sets a value indicating whether users are allowed to draw outgoing links to this node.
getAnchorPattern | Gets the anchor points to which links are attached when connected to this node.
getAttachedNodes | Returns the nodes attached to this node.
getBounds | Gets the rectangle that defines the position of the diagram node.
getCenter | Gets the center of this node's bounding rectangle.
getEffectiveEffects | Gets the effects that should be applied to this item.
getEffects | Gets an array with all effects applied to this node.
getEnabledHandles | Gets the kinds of modifications that end-users are permitted to perform on the node.
getExpandable | Gets a value indicating whether users are allowed to expand or collapse the tree branch that starts at this node.
getExpanded | Gets a value indicating whether the tree branch starting at this node is expanded.
getHandlesStyle | Gets a value indicating how the node adjustment handles behave and what do they look like.
getIncomingLinks | Gets the incoming links collection of this DiagramNode.
getIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline.
getMasterNode | Returns the node to which this node is attached.
getObstacle | Sets a value indicating whether this node is considered an obstacle by the link-routing algorithm.
getOutgoingLinks | Gets the outgoing links collection of this node.
getOutline | Gets the bounding rectangle of this node.
getRotatedBounds | Gets the bounding rectangle of this item when it is rotated.
getRotationAngle | Gets the angle at which this node is rotated.
getTopLevel | DiagramItem.getTopLevel override.
raiseClicked | Raises an event which notifies that a node has been clicked.
raiseDoubleClicked | Raises an event which notifies that a node has been double-clicked.
removeCanvasElements | DiagramItem.removeCanvasElements override.
restoreLocationState | DiagramItem.restoreLocationState override.
saveLocationState | DiagramItem.saveLocationState override.
setAllowIncomingLinks | Sets a value indicating whether users are allowed to draw incoming link-s to this node.
setAllowOutgoingLinks | Sets a value indicating whether users are allowed to draw outgoing link-s from this node.
setAnchorPattern | Sets the anchor points to which links are attached when connected to this node.
setBounds | Sets the rectangle that defines the position of the diagram node.
setEnabledHandles | Sets the kinds of modifications that end-users are permitted to perform on the node.
setExpandable | Sets a value indicating whether users are allowed to expand or collapse the tree branch that starts at this node.
setExpanded | Expands or collapses the tree branch that starts at this node.
setHandlesStyle | Sets a value indicating how the node adjustment handles behave and what do they look like.
setObstacle | Sets a value indicating whether this node is considered an obstacle by the link-routing algorithm.
setRotationAngle | Sets the angle at which this node is rotated.
startDrag | DiagramItem.startDrag override.
updateDrag | DiagramItem.updateDrag override.

See Also

DiagramNode Class


MindFusion.Diagramming.DiagramNode.acceptLinks Method

DiagramNode.acceptLinks Method
[image]

Determines whether the node can be connected with links of the specified type.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function acceptLinks (outgoing)

Parameters

outgoing

true to check for outgoing links; otherwise, false.

Return Value

true if the node accepts connections of the specified type; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.allowDrag Method

DiagramNode.allowDrag Method
[image]

DiagramItem.allowDrag override.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function allowDrag (ist)

Parameters

ist

An InteractionState object that encapsulates the current state of user interaction with the control.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.attach Method

DiagramNode.attach Method
[image]

Attaches the specified subordinate node to this node, so that when this node is moved, the subordinate follows it.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function attach (subordinate)

Parameters

subordinate

A DiagramNode instance specifying the node that should be attached.

Remarks

Layout algorithms can treat a group of attached nodes either as a single node to be placed in the arranged graph, or as distinct nodes whose final positions are set independently from the initial group layout. This is controlled via the keepGroupLayout property.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
detach Method
attachTo Method
getAttachedNodes Method


MindFusion.Diagramming.DiagramNode.attachTo Method

DiagramNode.attachTo Method
[image]

Attaches this node to the specified master node so that when the master is moved, the attached node follows it.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function attachTo (node)

Parameters

node

A DiagramNode instance specifying the master node.

Remarks

Layout algorithms can treat a group of attached nodes either as a single node to be placed in the arranged graph, or as distinct nodes whose final positions are set independently from the initial group layout. This is controlled via the keepGroupLayout property.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
detach Method
attach Method
getAttachedNodes Method


MindFusion.Diagramming.DiagramNode.containsPoint Method

DiagramNode.containsPoint Method
[image]

DiagramItem.containsPoint override.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function containsPoint (point)

Parameters

point

The point to check.

Return Value

true it this node contains the specified point; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.createConnectionPoint Method

DiagramNode.createConnectionPoint Method
[image]

Creates a connection point between this node and the specified link at the specified point.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function createConnectionPoint (link, point, incoming)

Parameters

link
A DiagramLink that should be connected to this node.
point
The Point at which the link should be connected.
incoming

true if link is an incoming link, otherwise, false.

Return Value

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.detach Method

DiagramNode.detach Method
[image]

Detaches this node from its current master node.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function detach ()

Remarks

This method does nothing if the node hasn't been previously attached to another node via the attach or attachTo methods.

See Also

DiagramNode Members
DiagramNode Class
getAttachedNodes Method


MindFusion.Diagramming.DiagramNode.endDrag Method

DiagramNode.endDrag Method
[image]

DiagramItem.endDrag override.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function endDrag (ist)

Parameters

ist
An InteractionState object that encapsulates the current state of user interaction with the control.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.getAllowIncomingLinks Method

DiagramNode.getAllowIncomingLinks Method
[image]

Gets a value indicating whether users are allowed to draw incoming links to this node.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function getAllowIncomingLinks ()

Return Value

true if users are allowed to draw incoming links to this node; otherwise, false.

Remarks

Links to a node can be created programmatically regardless of the value of this property.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.getAllowOutgoingLinks Method

DiagramNode.getAllowOutgoingLinks Method
[image]

Sets a value indicating whether users are allowed to draw outgoing links to this node.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function getAllowOutgoingLinks ()

Return Value

true if users are allowed to draw outgoing links to this node; otherwise, false.

Remarks

Links from a node can be created programmatically regardless of the value of this property.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.getAnchorPattern Method

DiagramNode.getAnchorPattern Method
[image]

Gets the anchor points to which links are attached when connected to this node.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function getAnchorPattern ()

Return Value

An AnchorPattern object that defines the anchor points for this node.

Remarks

This property specifies a set of points to which links can be attached. Each anchor point can accept either incoming links, outgoing links or both. If a node does not have any anchor points defined, links can be connected to any part of the node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.getAttachedNodes Method

DiagramNode.getAttachedNodes Method
[image]

Returns the nodes attached to this node.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function getAttachedNodes ()

Return Value

An array of nodes attached to this node via the attach or attachTo methods.

See Also

DiagramNode Members
DiagramNode Class
detach Method


MindFusion.Diagramming.DiagramNode.getBounds Method

DiagramNode.getBounds Method
[image]

Gets the rectangle that defines the position of the diagram node.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function getBounds ()

Return Value

The node's bounding rectangle.

Remarks

Use this property to get the size and/or location of a node. Moving a node also updates the control points coordinates of all links connected to it.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.getCenter Method

DiagramNode.getCenter Method
[image]

Gets the center of this node's bounding rectangle.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function getCenter ()

Return Value

A Point object representing the center point of this node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.getEffectiveEffects Method

DiagramNode.getEffectiveEffects Method
[image]

Gets the effects that should be applied to this item.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function getEffectiveEffects ()

Return Value

An array with the effective node effects.

Remarks

Returns the local Effects array if it's not empty, or otherwise the effects defined in item's Style or diagram's Theme.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.getEffects Method

DiagramNode.getEffects Method
[image]

Gets an array with all effects applied to this node.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function getEffects ()

Return Value

An array with all node effects.

Remarks

The local node effects are applied after the diagram-wide node effects defined in NodeEffects. However, if the first effect in this list is null, the diagram effects are ignored.

See Also

DiagramNode Members
DiagramNode Class
Node Effects


MindFusion.Diagramming.DiagramNode.getEnabledHandles Method

DiagramNode.getEnabledHandles Method
[image]

Gets the kinds of modifications that end-users are permitted to perform on the node.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function getEnabledHandles ()

Return Value

A combination of the AdjustmentHandles enumeration members.

Remarks

Disabling some selection handles allows restricting the types of modifications that users can perform on a node. Call setEnabledHandles method to do that.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.getExpandable Method

DiagramNode.getExpandable Method
[image]

Gets a value indicating whether users are allowed to expand or collapse the tree branch that starts at this node.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function getExpandable ()

Return Value

true if users are allowed to expand/collapse the tree branch, otherwise false.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.getExpanded Method

DiagramNode.getExpanded Method
[image]

Gets a value indicating whether the tree branch starting at this node is expanded.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function getExpanded ()

Return Value

true if the branch starting at this node is expanded; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.getHandlesStyle Method

DiagramNode.getHandlesStyle Method
[image]

Gets a value indicating how the node adjustment handles behave and what do they look like.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function getHandlesStyle ()

Return Value

A member of the HandlesStyle enumeration. The default value is SquareHandles.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.getIncomingLinks Method

DiagramNode.getIncomingLinks Method
[image]

Gets the incoming links collection of this DiagramNode.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function getIncomingLinks ()

Return Value

An array with the incoming DiagramLink-s.

Remarks

Use this collection to get access to every link pointing to the node, as well as get the number of such links.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.getIntersection Method

DiagramNode.getIntersection Method
[image]

Calculates the intersection point between the segment defined by the specified point pair and the node's outline.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function getIntersection (point1, point2)

Parameters

point1
The first Point of the segment.
point2
The second Point of the segment.

Return Value

A Point object representing the intersection point.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.getMasterNode Method

DiagramNode.getMasterNode Method
[image]

Returns the node to which this node is attached.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function getMasterNode ()

Return Value

A DiagramNode reference specifying the node to which this node has been previously attached via the attach or attachTo method.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.getObstacle Method

DiagramNode.getObstacle Method
[image]

Sets a value indicating whether this node is considered an obstacle by the link-routing algorithm.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function getObstacle ()

Return Value

true if routed links look for a path going around this node; false lets links cross the node. The default value is true.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.getOutgoingLinks Method

DiagramNode.getOutgoingLinks Method
[image]

Gets the outgoing links collection of this node.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function getOutgoingLinks ()

Return Value

An array with the outgoing DiagramLink-s.

Remarks

Use this collection to get access to every link starting from the node, as well as get the number of such links.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.getOutline Method

DiagramNode.getOutline Method
[image]

Gets the bounding rectangle of this node.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function getOutline ()

Return Value

A rectangle.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.getRotatedBounds Method

DiagramNode.getRotatedBounds Method
[image]

Gets the bounding rectangle of this item when it is rotated.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function getRotatedBounds ()

Return Value

that bounds the rotated shape of the item.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.getRotationAngle Method

DiagramNode.getRotationAngle Method
[image]

Gets the angle at which this node is rotated.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function getRotationAngle ()

Return Value

A Number specifying the rotation angle. The default is 0.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.getTopLevel Method

DiagramNode.getTopLevel Method
[image]

DiagramItem.getTopLevel override.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function getTopLevel ()

Return Value

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.raiseClicked Method

DiagramNode.raiseClicked Method
[image]

Raises an event which notifies that a node has been clicked.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function raiseClicked (mousePosition, mouseButton)

Parameters

mousePosition

The position of the mouse.

mouseButton

A value identifying the clicked mouse button.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.raiseDoubleClicked Method

DiagramNode.raiseDoubleClicked Method
[image]

Raises an event which notifies that a node has been double-clicked.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function raiseDoubleClicked (mousePosition, mouseButton)

Parameters

mousePosition

The position of the mouse.

mouseButton

A value identifying the clicked mouse button.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.removeCanvasElements Method

DiagramNode.removeCanvasElements Method
[image]

DiagramItem.removeCanvasElements override.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function removeCanvasElements ()

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.restoreLocationState Method

DiagramNode.restoreLocationState Method
[image]

DiagramItem.restoreLocationState override.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function restoreLocationState (ist)

Parameters

ist

A DiagramLinkState instance.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.saveLocationState Method

DiagramNode.saveLocationState Method
[image]

DiagramItem.saveLocationState override.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function saveLocationState ()

Return Value

A DiagramLinkState instance.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.setAllowIncomingLinks Method

DiagramNode.setAllowIncomingLinks Method
[image]

Sets a value indicating whether users are allowed to draw incoming link-s to this node.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function setAllowIncomingLinks (value)

Parameters

value

true to let users draw incoming links to this node; otherwise, false. The default is true.

Remarks

Links from a node can be created programmatically regardless of the value of this property.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.setAllowOutgoingLinks Method

DiagramNode.setAllowOutgoingLinks Method
[image]

Sets a value indicating whether users are allowed to draw outgoing link-s from this node.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function setAllowOutgoingLinks (value)

Parameters

value

true to let users draw outgoing links to this node; otherwise, false. The default is true.

Remarks

Links from a node can be created programmatically regardless of the value of this property.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.setAnchorPattern Method

DiagramNode.setAnchorPattern Method
[image]

Sets the anchor points to which links are attached when connected to this node.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function setAnchorPattern (value)

Parameters

value

An AnchorPattern object that defines the anchor points for this node.

Remarks

This property specifies a set of points to which links can be attached. Each anchor point can accept either incoming links, outgoing links or both. If a node does not have any anchor points defined, links can be connected to any part of the node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.setBounds Method

DiagramNode.setBounds Method
[image]

Sets the rectangle that defines the position of the diagram node.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function setBounds (bounds, [updateLinks])

Parameters

bounds
The node's bounding rectangle.
updateLinks
Optional.

true if the links must be updated; otherwise, false.

Remarks

Use this method to set the size and/or location of a node. Moving a node also updates the control points coordinates of all links connected to it.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.setEnabledHandles Method

DiagramNode.setEnabledHandles Method
[image]

Sets the kinds of modifications that end-users are permitted to perform on the node.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function setEnabledHandles (value)

Parameters

value
A combination of the AdjustmentHandles enumeration members. The default is AdjustmentHandles.All.

Remarks

Disabling some selection handles allows restricting the types of modifications that users can perform on a node. Each manipulation handle can be enabled or disabled by setting or clearing the respective flag in the combination.

For example, to make a node resizable only horizontally, set this property to a combination of the Move, ResizeMiddleLeft and ResizeMiddleRight flags. That will disable all manipulation handles, except the left and right ones, which allow horizontal resizing, and the central one allowing movement of the node.

See Also

DiagramNode Members
DiagramNode Class
HandlesStyle Property


MindFusion.Diagramming.DiagramNode.setExpandable Method

DiagramNode.setExpandable Method
[image]

Sets a value indicating whether users are allowed to expand or collapse the tree branch that starts at this node.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function setExpandable (value)

Parameters

value

true to display expand/collapse button beside the node, otherwise false.

Remarks

This property is useful mostly when nodes form a tree-like hierarchical structure.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
setExpanded Method
treeCollapsed Event
treeExpanded Event


MindFusion.Diagramming.DiagramNode.setExpanded Method

DiagramNode.setExpanded Method
[image]

Expands or collapses the tree branch that starts at this node.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function setExpanded (value)

Parameters

value

true if the branch starting at this node should be expanded; otherwise, false.

Remarks

By default, the control considers nodes that can be reached by following outgoing links to be the child nodes in a tree, and respectively outgoing links determine the direction in which tree branches collapse or expand. This direction can be reversed by setting the ExpandOnIncoming property to true.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
setExpandable Method
getOutgoingLinks Method
getIncomingLinks Method


MindFusion.Diagramming.DiagramNode.setHandlesStyle Method

DiagramNode.setHandlesStyle Method
[image]

Sets a value indicating how the node adjustment handles behave and what do they look like.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function setHandlesStyle (value)

Parameters

value

A member of the HandlesStyle enumeration.

See Also

DiagramNode Members
DiagramNode Class
EnabledHandles Property


MindFusion.Diagramming.DiagramNode.setObstacle Method

DiagramNode.setObstacle Method
[image]

Sets a value indicating whether this node is considered an obstacle by the link-routing algorithm.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function setObstacle (value)

Parameters

value

true makes routed links look for a path going around this node; false lets links cross the node. The default value is true.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.setRotationAngle Method

DiagramNode.setRotationAngle Method
[image]

Sets the angle at which this node is rotated.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function setRotationAngle (value)

Parameters

value

A Number specifying the rotation angle. The default is 0.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.startDrag Method

DiagramNode.startDrag Method
[image]

DiagramItem.startDrag override.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function startDrag (ist)

Parameters

ist

An InteractionState object that encapsulates the current state of user interaction with the control.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.updateDrag Method

DiagramNode.updateDrag Method
[image]

DiagramItem.updateDrag override.

Namespace: MindFusion.Diagramming
Assembly: DiagramNode.js

Syntax

JavaScript [image] Copy Code

function updateDrag (ist)

Parameters

ist
An InteractionState object that encapsulates the current state of user interaction with the control.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DoNothingBehavior Class

DoNothingBehavior Class
[image]

Implements the DoNothing behavior.

Namespace: MindFusion.Diagramming
Assembly: DoNothingBehavior.js

Syntax

JavaScript [image] Copy Code

// class
DoNothingBehavior.prototype = {}

Inheritance Hierarchy

See Also

DoNothingBehavior Members


MindFusion.Diagramming.DoNothingBehavior Members

DoNothingBehavior Members
Constructors Methods
[image]

Implements the DoNothing behavior.

The following tables list the members exposed by the DoNothingBehavior type.

Public Constructors

Name | Description
DoNothingBehavior | Initializes a new instance of the DoNothingBehavior class.

Public Methods

Name | Description
onMouseDown | BehaviorBase.onMouseDown override.
onMouseMove | BehaviorBase.onMouseMove override.
onMouseUp | BehaviorBase.onMouseUp override.
setMouseCursor | BehaviorBase.setMouseCursor override.
startDraw | BehaviorBase.StartDraw override.

See Also

DoNothingBehavior Class


MindFusion.Diagramming.DoNothingBehavior Constructor

DoNothingBehavior Constructor
[image]

Initializes a new instance of the DoNothingBehavior class.

Namespace: MindFusion.Diagramming
Assembly: DoNothingBehavior.js

Syntax

JavaScript [image] Copy Code

function DoNothingBehavior (parent)

Parameters

parent

The Diagram this behavior will be associated with.

See Also

DoNothingBehavior Class


MindFusion.Diagramming.DoNothingBehavior Methods

DoNothingBehavior Methods
[image]

Public Methods

Name | Description
onMouseDown | BehaviorBase.onMouseDown override.
onMouseMove | BehaviorBase.onMouseMove override.
onMouseUp | BehaviorBase.onMouseUp override.
setMouseCursor | BehaviorBase.setMouseCursor override.
startDraw | BehaviorBase.StartDraw override.

See Also

DoNothingBehavior Class


MindFusion.Diagramming.DoNothingBehavior.onMouseDown Method

DoNothingBehavior.onMouseDown Method
[image]

BehaviorBase.onMouseDown override.

Namespace: MindFusion.Diagramming
Assembly: DoNothingBehavior.js

Syntax

JavaScript [image] Copy Code

function onMouseDown (e)

Parameters

e

A MouseButtonEventArgs that contains the event data.

See Also

DoNothingBehavior Members
DoNothingBehavior Class


MindFusion.Diagramming.DoNothingBehavior.onMouseMove Method

DoNothingBehavior.onMouseMove Method
[image]

BehaviorBase.onMouseMove override.

Namespace: MindFusion.Diagramming
Assembly: DoNothingBehavior.js

Syntax

JavaScript [image] Copy Code

function onMouseMove (e)

Parameters

e

A MouseEventArgs that contains the event data.

See Also

DoNothingBehavior Members
DoNothingBehavior Class


MindFusion.Diagramming.DoNothingBehavior.onMouseUp Method

DoNothingBehavior.onMouseUp Method
[image]

BehaviorBase.onMouseUp override.

Namespace: MindFusion.Diagramming
Assembly: DoNothingBehavior.js

Syntax

JavaScript [image] Copy Code

function onMouseUp (e)

Parameters

e

A MouseButtonEventArgs that contains the event data.

See Also

DoNothingBehavior Members
DoNothingBehavior Class


MindFusion.Diagramming.DoNothingBehavior.setMouseCursor Method

DoNothingBehavior.setMouseCursor Method
[image]

BehaviorBase.setMouseCursor override.

Namespace: MindFusion.Diagramming
Assembly: DoNothingBehavior.js

Syntax

JavaScript [image] Copy Code

function setMouseCursor (point, startInteraction)

Parameters

point

startInteraction

See Also

DoNothingBehavior Members
DoNothingBehavior Class


MindFusion.Diagramming.DoNothingBehavior.startDraw Method

DoNothingBehavior.startDraw Method
[image]

BehaviorBase.StartDraw override.

Namespace: MindFusion.Diagramming
Assembly: DoNothingBehavior.js

Syntax

JavaScript [image] Copy Code

function startDraw (point)

Parameters

point

A Point structure, which specifies the current position of the mouse cursor, in document coordinates.

Return Value

An instance of the InteractionState class.

See Also

DoNothingBehavior Members
DoNothingBehavior Class


MindFusion.Diagramming.DrawLinksBehavior Class

DrawLinksBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.DrawLinks.

Namespace: MindFusion.Diagramming
Assembly: DrawLinksBehavior.js

Syntax

JavaScript [image] Copy Code

// class
DrawLinksBehavior.prototype = {}

Inheritance Hierarchy

See Also

DrawLinksBehavior Members


MindFusion.Diagramming.DrawLinksBehavior Members

DrawLinksBehavior Members
Constructors Methods
[image]

This class is used when the diagram behavior is set to Behavior.DrawLinks.

The following tables list the members exposed by the DrawLinksBehavior type.

Public Constructors

Name | Description
DrawLinksBehavior | Initializes a new instance of the DrawLinksBehavior class.

Public Methods

Name | Description
startDraw | BehaviorBase.startDraw override.

See Also

DrawLinksBehavior Class


MindFusion.Diagramming.DrawLinksBehavior Constructor

DrawLinksBehavior Constructor
[image]

Initializes a new instance of the DrawLinksBehavior class.

Namespace: MindFusion.Diagramming
Assembly: DrawLinksBehavior.js

Syntax

JavaScript [image] Copy Code

function DrawLinksBehavior (parent)

Parameters

parent

The Diagram this behavior will be associated with.

See Also

DrawLinksBehavior Class


MindFusion.Diagramming.DrawLinksBehavior Methods

DrawLinksBehavior Methods
[image]

Public Methods

Name | Description
startDraw | BehaviorBase.startDraw override.

See Also

DrawLinksBehavior Class


MindFusion.Diagramming.DrawLinksBehavior.startDraw Method

DrawLinksBehavior.startDraw Method
[image]

BehaviorBase.startDraw override.

Namespace: MindFusion.Diagramming
Assembly: DrawLinksBehavior.js

Syntax

JavaScript [image] Copy Code

function startDraw (point)

Parameters

point

A Point structure, which specifies the current position of the mouse cursor, in document coordinates.

Return Value

An instance of the InteractionState class.

See Also

DrawLinksBehavior Members
DrawLinksBehavior Class


MindFusion.Diagramming.DrawNodesBehavior Class

DrawNodesBehavior Class
[image]

The base class for behavior types that allow drawing of nodes, but not links.

Namespace: MindFusion.Diagramming
Assembly: DrawNodesBehavior.js

Syntax

JavaScript [image] Copy Code

// class
DrawNodesBehavior.prototype = {}

Inheritance Hierarchy

See Also

DrawNodesBehavior Members


MindFusion.Diagramming.DrawNodesBehavior Members

DrawNodesBehavior Members
Constructors Methods
[image]

The base class for behavior types that allow drawing of nodes, but not links.

The following tables list the members exposed by the DrawNodesBehavior type.

Public Constructors

Name | Description
DrawNodesBehavior | Initializes a new instance of the DrawNodesBehavior class.

Public Methods

Name | Description
startDraw | BehaviorBase.StartDraw override.

See Also

DrawNodesBehavior Class


MindFusion.Diagramming.DrawNodesBehavior Constructor

DrawNodesBehavior Constructor
[image]

Initializes a new instance of the DrawNodesBehavior class.

Namespace: MindFusion.Diagramming
Assembly: DrawNodesBehavior.js

Syntax

JavaScript [image] Copy Code

function DrawNodesBehavior (parent)

Parameters

parent

The Diagram this behavior will be associated with.

See Also

DrawNodesBehavior Class


MindFusion.Diagramming.DrawNodesBehavior Methods

DrawNodesBehavior Methods
[image]

Public Methods

Name | Description
startDraw | BehaviorBase.StartDraw override.

See Also

DrawNodesBehavior Class


MindFusion.Diagramming.DrawNodesBehavior.startDraw Method

DrawNodesBehavior.startDraw Method
[image]

BehaviorBase.StartDraw override.

Namespace: MindFusion.Diagramming
Assembly: DrawNodesBehavior.js

Syntax

JavaScript [image] Copy Code

function startDraw (point)

Parameters

point

A Point structure, which specifies the current position of the mouse cursor, in document coordinates.

Return Value

An instance of the InteractionState class.

See Also

DrawNodesBehavior Members
DrawNodesBehavior Class


MindFusion.Diagramming.DrawShapesBehavior Class

DrawShapesBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.DrawShapes.

Namespace: MindFusion.Diagramming
Assembly: DrawShapesBehavior.js

Syntax

JavaScript [image] Copy Code

// class
DrawShapesBehavior.prototype = {}

Inheritance Hierarchy

See Also

DrawShapesBehavior Members


MindFusion.Diagramming.DrawShapesBehavior Members

DrawShapesBehavior Members
Constructors Methods
[image]

This class is used when the diagram behavior is set to Behavior.DrawShapes.

The following tables list the members exposed by the DrawShapesBehavior type.

Public Constructors

Name | Description
DrawShapesBehavior | Initializes a new instance of the DrawShapesBehavior class.

Public Methods

Name | Description
createNode | DrawNodesBehavior.CreateNode override.

See Also

DrawShapesBehavior Class


MindFusion.Diagramming.DrawShapesBehavior Constructor

DrawShapesBehavior Constructor
[image]

Initializes a new instance of the DrawShapesBehavior class.

Namespace: MindFusion.Diagramming
Assembly: DrawShapesBehavior.js

Syntax

JavaScript [image] Copy Code

function DrawShapesBehavior (parent)

Parameters

parent

The Diagram this behavior will be associated with.

See Also

DrawShapesBehavior Class


MindFusion.Diagramming.DrawShapesBehavior Methods

DrawShapesBehavior Methods
[image]

Public Methods

Name | Description
createNode | DrawNodesBehavior.CreateNode override.

See Also

DrawShapesBehavior Class


MindFusion.Diagramming.DrawShapesBehavior.createNode Method

DrawShapesBehavior.createNode Method
[image]

DrawNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming
Assembly: DrawShapesBehavior.js

Syntax

JavaScript [image] Copy Code

function createNode ()

Return Value

An instance of the DiagramNode class.

See Also

DrawShapesBehavior Members
DrawShapesBehavior Class


MindFusion.Diagramming.DummyNode Class

DummyNode Class
[image]

DummyNode represents virtual nodes set as targets of disconnected links.

Namespace: MindFusion.Diagramming
Assembly: DummyNode.js

Syntax

JavaScript [image] Copy Code

// class
DummyNode.prototype = {}

Inheritance Hierarchy

See Also

DummyNode Members


MindFusion.Diagramming.DummyNode Members

DummyNode Members
Constructors
[image]

DummyNode represents virtual nodes set as targets of disconnected links.

The following tables list the members exposed by the DummyNode type.

Public Constructors

Name | Description
DummyNode | Initializes a new instance of the DummyNode class.

See Also

DummyNode Class


MindFusion.Diagramming.DummyNode Constructor

DummyNode Constructor
[image]

Initializes a new instance of the DummyNode class.

Namespace: MindFusion.Diagramming
Assembly: DummyNode.js

Syntax

JavaScript [image] Copy Code

function DummyNode ([parent])

Parameters

parent
Optional.

A Diagram instance whose default node attributes are copied to this node.

See Also

DummyNode Class


MindFusion.Diagramming.EffectPhase Enumeration

EffectPhase Enumeration
[image]

Specifies the rendering phase during which an effect application is requested.

Namespace: MindFusion.Diagramming
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
EffectPhase = {}

Members

Member name | Description
AfterFill | Indicates that the NodeEffect.apply method is invoked after the target node is filled.
AfterOutline | Indicates that the NodeEffect.apply method is invoked after the target node is stroked.
BeforeFill | Indicates that the NodeEffect.apply method is invoked before the target node is filled.

See Also


MindFusion.Diagramming.Events Class

Events Class
[image]

Defines all events raised by the Diagram component.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

// class
Events.prototype = {}

Inheritance Hierarchy

See Also

Events Members
addEventListener Method


MindFusion.Diagramming.Events Members

Events Members
Fields
[image]

Defines all events raised by the Diagram component.

The following tables list the members exposed by the Events type.

Public Fields

Name | Description
cellTextEdited | Raised when the user edits the text of a table cell. The event handlers get a CellEventArgs instance that contains data for this event.
clicked | Raised when the user clicks the diagram at a point where no items are located. The event handlers get a DiagramEventArgs instance that contains data for this event.
containerChildAdded | Raised when the user adds a node to a ContainerNode.
containerChildAdding | A validation event raised to let you prevent users from adding child nodes to a container.
containerChildRemoved | Raised when the user removes a node from a ContainerNode.
containerChildRemoving | A validation event raised to let you prevent users from removing child nodes from a container.
containerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area.
containerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area.
controlLoaded | Raised when the control is loaded.
createEditControl | Raised to let you create a custom inplace editor control. Event handlers get an InplaceEditEventArgs instance that contains data for this event.
deserializeTag | Raised when the Tag or Id of a diagram item must be deserialized from XML format.
drawAdjustmentHandles | Raised to draw custom adjustment handles.
enterInplaceEditMode | Raised when entering inplace-edit mode. Event handlers get an InplaceEditEventArgs instance that contains data for this event.
hitTestAdjustmentHandles | Raised to hit-test custom adjustment handles.
initializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created.
initializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created.
laneGridCellTextEdited | Raised when the used edits the text of a grid cell. The event handlers get a CellEventArgs instance that contains data for this event.
leaveInplaceEditMode | Raised when leaving inplace-edit mode. Event handlers get an InplaceEditEventArgs instance that contains data for this event.
linkClicked | Raised when the user clicks a link. The event handlers get a LinkEventArgs instance that contains data for this event.
linkCreated | Raised when the user draws a new link. The event handlers get a LinkEventArgs instance that contains data for this event.
linkCreating | A validation event raised while the user is drawing a new link. The event handlers get a LinkEventArgs instance that contains data for this event.
linkDeleted | Raised when a link is deleted, either programmatically or by the user. The event handlers get a LinkEventArgs instance that contains data for this event.
linkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation. The event handlers get a LinkEventArgs instance that contains data for this event.
linkDeselected | Raised when a link is deselected, either programmatically or by the user. The event handlers get a LinkEventArgs instance that contains data for this event.
linkDoubleClicked | Raised when the user double-clicks a link. The event handlers get a LinkEventArgs instance that contains data for this event.
linkModified | Raised when the user moves any control point of a link. The event handlers get a LinkEventArgs instance that contains data for this event.
linkModifying | A validation event raised while the user is modifying a link. The event handlers get a LinkEventArgs instance that contains data for this event.
linkPointed | Raised when the mouse pointer hovers over a link. Event handlers get a LinkEventArgs instance that contains data for this event.
linkSelected | Raised when a link is selected, either programmatically or by the user. The event handlers get a LinkEventArgs instance that contains data for this event.
linkTextEdited | Raised when the user edits the text of a link. The event handlers get a LinkEventArgs instance that contains data for this event.
nodeClicked | Raised when the user clicks a node. The event handlers get a NodeEventArgs instance that contains data for this event.
nodeCreated | Raised when the user draws a new node. The event handlers get a NodeEventArgs instance that contains data for this event.
nodeCreating | A validation event raised while the user is drawing a new node. The event handlers get a NodeEventArgs instance that contains data for this event.
nodeDeleted | Raised when a node is deleted, either programmatically or by the user. The event handlers get a NodeEventArgs instance that contains data for this event.
nodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation. The event handlers get a NodeEventArgs instance that contains data for this event.
nodeDeselected | Raised when a node is deselected, either programmatically or by the user. The event handlers get a NodeEventArgs instance that contains data for this event.
nodeDoubleClicked | Raised when the user double-clicks a node. The event handlers get a NodeEventArgs instance that contains data for this event.
nodeModified | Raised when the user moves or resizes a node. The event handlers get a NodeEventArgs instance that contains data for this event.
nodeModifying | A validation event raised while the user is moving or resizing a node. The event handlers get a NodeEventArgs instance that contains data for this event.
nodePointed | Raised when the mouse pointer hovers over a node. The event handlers get a NodeEventArgs instance that contains data for this event.
nodeSelected | Raised when a node is selected, either programmatically or by the user. The event handlers get a NodeEventArgs instance that contains data for this event.
nodeTextEdited | Raised when the user edits the text of a node. The event handlers get a NodeEventArgs instance that contains data for this event.
repaint | Raised when the diagram has been repainted.
selectionModifying | A validation event raised while the user is moving or resizing multiple items. The event handlers get a NodeEventArgs instance that contains data for this event.
sizeChanged | Raised when the size of the diagram canvas has changed.
tableColumnResized | Raised when the user finishes resizing a column in a table.
tableColumnResizing | Raised when the user resizes a column in a table interactively.
tableRowResized | Raised when the user finishes resizing a row in a table.
tableRowResizing | Raised when the user resizes a row in a table interactively.
treeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node. The event handlers get a NodeEventArgs instance that contains data for this event.
treeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node. The event handlers get a NodeEventArgs instance that contains data for this event.

See Also

Events Class


MindFusion.Diagramming.Events Fields

Events Fields
[image]

Public Fields

Name | Description
cellTextEdited | Raised when the user edits the text of a table cell. The event handlers get a CellEventArgs instance that contains data for this event.
clicked | Raised when the user clicks the diagram at a point where no items are located. The event handlers get a DiagramEventArgs instance that contains data for this event.
containerChildAdded | Raised when the user adds a node to a ContainerNode.
containerChildAdding | A validation event raised to let you prevent users from adding child nodes to a container.
containerChildRemoved | Raised when the user removes a node from a ContainerNode.
containerChildRemoving | A validation event raised to let you prevent users from removing child nodes from a container.
containerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area.
containerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area.
controlLoaded | Raised when the control is loaded.
createEditControl | Raised to let you create a custom inplace editor control. Event handlers get an InplaceEditEventArgs instance that contains data for this event.
deserializeTag | Raised when the Tag or Id of a diagram item must be deserialized from XML format.
drawAdjustmentHandles | Raised to draw custom adjustment handles.
enterInplaceEditMode | Raised when entering inplace-edit mode. Event handlers get an InplaceEditEventArgs instance that contains data for this event.
hitTestAdjustmentHandles | Raised to hit-test custom adjustment handles.
initializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created.
initializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created.
laneGridCellTextEdited | Raised when the used edits the text of a grid cell. The event handlers get a CellEventArgs instance that contains data for this event.
leaveInplaceEditMode | Raised when leaving inplace-edit mode. Event handlers get an InplaceEditEventArgs instance that contains data for this event.
linkClicked | Raised when the user clicks a link. The event handlers get a LinkEventArgs instance that contains data for this event.
linkCreated | Raised when the user draws a new link. The event handlers get a LinkEventArgs instance that contains data for this event.
linkCreating | A validation event raised while the user is drawing a new link. The event handlers get a LinkEventArgs instance that contains data for this event.
linkDeleted | Raised when a link is deleted, either programmatically or by the user. The event handlers get a LinkEventArgs instance that contains data for this event.
linkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation. The event handlers get a LinkEventArgs instance that contains data for this event.
linkDeselected | Raised when a link is deselected, either programmatically or by the user. The event handlers get a LinkEventArgs instance that contains data for this event.
linkDoubleClicked | Raised when the user double-clicks a link. The event handlers get a LinkEventArgs instance that contains data for this event.
linkModified | Raised when the user moves any control point of a link. The event handlers get a LinkEventArgs instance that contains data for this event.
linkModifying | A validation event raised while the user is modifying a link. The event handlers get a LinkEventArgs instance that contains data for this event.
linkPointed | Raised when the mouse pointer hovers over a link. Event handlers get a LinkEventArgs instance that contains data for this event.
linkSelected | Raised when a link is selected, either programmatically or by the user. The event handlers get a LinkEventArgs instance that contains data for this event.
linkTextEdited | Raised when the user edits the text of a link. The event handlers get a LinkEventArgs instance that contains data for this event.
nodeClicked | Raised when the user clicks a node. The event handlers get a NodeEventArgs instance that contains data for this event.
nodeCreated | Raised when the user draws a new node. The event handlers get a NodeEventArgs instance that contains data for this event.
nodeCreating | A validation event raised while the user is drawing a new node. The event handlers get a NodeEventArgs instance that contains data for this event.
nodeDeleted | Raised when a node is deleted, either programmatically or by the user. The event handlers get a NodeEventArgs instance that contains data for this event.
nodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation. The event handlers get a NodeEventArgs instance that contains data for this event.
nodeDeselected | Raised when a node is deselected, either programmatically or by the user. The event handlers get a NodeEventArgs instance that contains data for this event.
nodeDoubleClicked | Raised when the user double-clicks a node. The event handlers get a NodeEventArgs instance that contains data for this event.
nodeModified | Raised when the user moves or resizes a node. The event handlers get a NodeEventArgs instance that contains data for this event.
nodeModifying | A validation event raised while the user is moving or resizing a node. The event handlers get a NodeEventArgs instance that contains data for this event.
nodePointed | Raised when the mouse pointer hovers over a node. The event handlers get a NodeEventArgs instance that contains data for this event.
nodeSelected | Raised when a node is selected, either programmatically or by the user. The event handlers get a NodeEventArgs instance that contains data for this event.
nodeTextEdited | Raised when the user edits the text of a node. The event handlers get a NodeEventArgs instance that contains data for this event.
repaint | Raised when the diagram has been repainted.
selectionModifying | A validation event raised while the user is moving or resizing multiple items. The event handlers get a NodeEventArgs instance that contains data for this event.
sizeChanged | Raised when the size of the diagram canvas has changed.
tableColumnResized | Raised when the user finishes resizing a column in a table.
tableColumnResizing | Raised when the user resizes a column in a table interactively.
tableRowResized | Raised when the user finishes resizing a row in a table.
tableRowResizing | Raised when the user resizes a row in a table interactively.
treeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node. The event handlers get a NodeEventArgs instance that contains data for this event.
treeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node. The event handlers get a NodeEventArgs instance that contains data for this event.

See Also

Events Class


MindFusion.Diagramming.Events.cellTextEdited Field

Events.cellTextEdited Field
[image]

Raised when the user edits the text of a table cell. The event handlers get a CellEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var cellTextEdited

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.clicked Field

Events.clicked Field
[image]

Raised when the user clicks the diagram at a point where no items are located. The event handlers get a DiagramEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var clicked

Remarks

This event is raised only if the user clicks an unoccupied point of the diagram. If the user clicks a diagram item, either nodeClicked or linkClicked event occurs.

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.containerChildAdded Field

Events.containerChildAdded Field
[image]

Raised when the user adds a node to a ContainerNode.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var containerChildAdded

See Also

Events Members
Events Class
containerChildAdded Event


MindFusion.Diagramming.Events.containerChildAdding Field

Events.containerChildAdding Field
[image]

A validation event raised to let you prevent users from adding child nodes to a container.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var containerChildAdding

Remarks

Call getNode and getContainer methods of the provided NodeEventArgs instance to access the relevant nodes. Set the Cancel argument to true to display the stop cursor and indicate that releasing the mouse button at the current position will cancel the operation.

See Also

Events Members
Events Class
MindFusion.Diagramming Namespace
containerChildAdded Event
containerChildRemoving Event


MindFusion.Diagramming.Events.containerChildRemoved Field

Events.containerChildRemoved Field
[image]

Raised when the user removes a node from a ContainerNode.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var containerChildRemoved

See Also

Events Members
Events Class
containerChildRemoving Event


MindFusion.Diagramming.Events.containerChildRemoving Field

Events.containerChildRemoving Field
[image]

A validation event raised to let you prevent users from removing child nodes from a container.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var containerChildRemoving

Remarks

Call getNode and getContainer methods of the provided NodeEventArgs instance to access the relevant nodes. Set the Cancel argument to true to display the stop cursor and indicate that releasing the mouse button at the current position will cancel the operation.

See Also

Events Members
Events Class
MindFusion.Diagramming Namespace
containerChildRemoved Event
containerChildAdding Event


MindFusion.Diagramming.Events.containerFolded Field

Events.containerFolded Field
[image]

Raised when the user folds a container by clicking the arrow-up button in the container's caption area.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var containerFolded

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.containerUnfolded Field

Events.containerUnfolded Field
[image]

Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var containerUnfolded

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.controlLoaded Field

Events.controlLoaded Field
[image]

Raised when the control is loaded.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var controlLoaded

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.createEditControl Field

Events.createEditControl Field
[image]

Raised to let you create a custom inplace editor control. Event handlers get an InplaceEditEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var createEditControl

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.deserializeTag Field

Events.deserializeTag Field
[image]

Raised when the Tag or Id of a diagram item must be deserialized from XML format.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var deserializeTag

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.drawAdjustmentHandles Field

Events.drawAdjustmentHandles Field
[image]

Raised to draw custom adjustment handles.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var drawAdjustmentHandles

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.enterInplaceEditMode Field

Events.enterInplaceEditMode Field
[image]

Raised when entering inplace-edit mode. Event handlers get an InplaceEditEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var enterInplaceEditMode

Remarks

This event allows setting properties of the TextArea control used for in-place editing or attaching custom event handlers to that control. A TextArea instance is created each time in-place editing starts, so it could be necessary to set its properties and register event handlers each time enterInplaceEditMode is raised.

See Also

Events Members
Events Class
MindFusion.Diagramming Namespace
AllowInplaceEdit Property
leaveInplaceEditMode Event


MindFusion.Diagramming.Events.hitTestAdjustmentHandles Field

Events.hitTestAdjustmentHandles Field
[image]

Raised to hit-test custom adjustment handles.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var hitTestAdjustmentHandles

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.initializeLink Field

Events.initializeLink Field
[image]

Raised when the user starts drawing a new link, just after the DiagramLink instance is created.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var initializeLink

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.initializeNode Field

Events.initializeNode Field
[image]

Raised when the user starts drawing a new node, just after the DiagramNode instance is created.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var initializeNode

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.laneGridCellTextEdited Field

Events.laneGridCellTextEdited Field
[image]

Raised when the used edits the text of a grid cell. The event handlers get a CellEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var laneGridCellTextEdited

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.leaveInplaceEditMode Field

Events.leaveInplaceEditMode Field
[image]

Raised when leaving inplace-edit mode. Event handlers get an InplaceEditEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var leaveInplaceEditMode

See Also

Events Members
Events Class
enterInplaceEditMode Event


MindFusion.Diagramming.Events.linkClicked Field

Events.linkClicked Field
[image]

Raised when the user clicks a link. The event handlers get a LinkEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var linkClicked

See Also

Events Members
Events Class
clicked Event


MindFusion.Diagramming.Events.linkCreated Field

Events.linkCreated Field
[image]

Raised when the user draws a new link. The event handlers get a LinkEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var linkCreated

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.linkCreating Field

Events.linkCreating Field
[image]

A validation event raised while the user is drawing a new link. The event handlers get a LinkEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var linkCreating

Remarks

Event handlers can set the Cancel property to true to display the stop cursor and indicate that releasing the mouse button at the current position will cancel the operation. Alternatively, calling the cancelDrag method immediately cancels the operation.

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.linkDeleted Field

Events.linkDeleted Field
[image]

Raised when a link is deleted, either programmatically or by the user. The event handlers get a LinkEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var linkDeleted

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.linkDeleting Field

Events.linkDeleting Field
[image]

Raised when the user tries to delete a link, this event lets you cancel the operation. The event handlers get a LinkEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var linkDeleting

Remarks

Event handlers can set the Cancel property to true to prevent deleting the link.

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.linkDeselected Field

Events.linkDeselected Field
[image]

Raised when a link is deselected, either programmatically or by the user. The event handlers get a LinkEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var linkDeselected

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.linkDoubleClicked Field

Events.linkDoubleClicked Field
[image]

Raised when the user double-clicks a link. The event handlers get a LinkEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var linkDoubleClicked

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.linkModified Field

Events.linkModified Field
[image]

Raised when the user moves any control point of a link. The event handlers get a LinkEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var linkModified

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.linkModifying Field

Events.linkModifying Field
[image]

A validation event raised while the user is modifying a link. The event handlers get a LinkEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var linkModifying

Remarks

Event handlers can set the Cancel property to true to display the stop cursor and indicate that releasing the mouse button at the current position will cancel the operation. Alternatively, calling the cancelDrag method immediately cancels the operation.

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.linkPointed Field

Events.linkPointed Field
[image]

Raised when the mouse pointer hovers over a link. Event handlers get a LinkEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var linkPointed

See Also

Events Members
Events Class
linkClicked Event


MindFusion.Diagramming.Events.linkSelected Field

Events.linkSelected Field
[image]

Raised when a link is selected, either programmatically or by the user. The event handlers get a LinkEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var linkSelected

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.linkTextEdited Field

Events.linkTextEdited Field
[image]

Raised when the user edits the text of a link. The event handlers get a LinkEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var linkTextEdited

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.nodeClicked Field

Events.nodeClicked Field
[image]

Raised when the user clicks a node. The event handlers get a NodeEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var nodeClicked

See Also

Events Members
Events Class
MindFusion.Diagramming Namespace
clicked Event
nodeDoubleClicked Event
linkClicked Event


MindFusion.Diagramming.Events.nodeCreated Field

Events.nodeCreated Field
[image]

Raised when the user draws a new node. The event handlers get a NodeEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var nodeCreated

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.nodeCreating Field

Events.nodeCreating Field
[image]

A validation event raised while the user is drawing a new node. The event handlers get a NodeEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var nodeCreating

Remarks

Event handlers can set the Cancel property to true to display the stop cursor and indicate that releasing the mouse button at the current position will cancel the operation. Alternatively, calling the cancelDrag method immediately cancels the operation.

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.nodeDeleted Field

Events.nodeDeleted Field
[image]

Raised when a node is deleted, either programmatically or by the user. The event handlers get a NodeEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var nodeDeleted

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.nodeDeleting Field

Events.nodeDeleting Field
[image]

Raised when the user tries to delete a node, this event lets you cancel the operation. The event handlers get a NodeEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var nodeDeleting

Remarks

Event handlers can set the Cancel property to true to prevent deleting the node.

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.nodeDeselected Field

Events.nodeDeselected Field
[image]

Raised when a node is deselected, either programmatically or by the user. The event handlers get a NodeEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var nodeDeselected

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.nodeDoubleClicked Field

Events.nodeDoubleClicked Field
[image]

Raised when the user double-clicks a node. The event handlers get a NodeEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var nodeDoubleClicked

See Also

Events Members
Events Class
MindFusion.Diagramming Namespace
nodeClicked Event
linkDoubleClicked Event


MindFusion.Diagramming.Events.nodeModified Field

Events.nodeModified Field
[image]

Raised when the user moves or resizes a node. The event handlers get a NodeEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var nodeModified

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.nodeModifying Field

Events.nodeModifying Field
[image]

A validation event raised while the user is moving or resizing a node. The event handlers get a NodeEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var nodeModifying

Remarks

Event handlers can set the Cancel property to true to display the stop cursor and indicate that releasing the mouse button at the current position will cancel the operation. Alternatively, calling the cancelDrag method immediately cancels the operation.

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.nodePointed Field

Events.nodePointed Field
[image]

Raised when the mouse pointer hovers over a node. The event handlers get a NodeEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var nodePointed

See Also

Events Members
Events Class
nodeClicked Event


MindFusion.Diagramming.Events.nodeSelected Field

Events.nodeSelected Field
[image]

Raised when a node is selected, either programmatically or by the user. The event handlers get a NodeEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var nodeSelected

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.nodeTextEdited Field

Events.nodeTextEdited Field
[image]

Raised when the user edits the text of a node. The event handlers get a NodeEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var nodeTextEdited

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.repaint Field

Events.repaint Field
[image]

Raised when the diagram has been repainted.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var repaint

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.selectionModifying Field

Events.selectionModifying Field
[image]

A validation event raised while the user is moving or resizing multiple items. The event handlers get a NodeEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var selectionModifying

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.sizeChanged Field

Events.sizeChanged Field
[image]

Raised when the size of the diagram canvas has changed.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var sizeChanged

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.tableColumnResized Field

Events.tableColumnResized Field
[image]

Raised when the user finishes resizing a column in a table.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var tableColumnResized

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.tableColumnResizing Field

Events.tableColumnResizing Field
[image]

Raised when the user resizes a column in a table interactively.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var tableColumnResizing

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.tableRowResized Field

Events.tableRowResized Field
[image]

Raised when the user finishes resizing a row in a table.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var tableRowResized

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.tableRowResizing Field

Events.tableRowResizing Field
[image]

Raised when the user resizes a row in a table interactively.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var tableRowResizing

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.treeCollapsed Field

Events.treeCollapsed Field
[image]

Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node. The event handlers get a NodeEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var treeCollapsed

See Also

Events Members
Events Class


MindFusion.Diagramming.Events.treeExpanded Field

Events.treeExpanded Field
[image]

Raised when a user expands a tree branch by clicking the [+] button of an Expandable node. The event handlers get a NodeEventArgs instance that contains data for this event.

Namespace: MindFusion.Diagramming
Assembly: Events.js

Syntax

JavaScript [image] Copy Code

var treeExpanded

See Also

Events Members
Events Class


MindFusion.Diagramming.Factory Class

Factory Class
Remarks See Also
[image]

Provides shortcut methods for creating and adding instances of the standard item types.

Namespace: MindFusion.Diagramming
Assembly: Factory.js

Syntax

JavaScript [image] Copy Code

// class
Factory.prototype = {}

Remarks

Obtain an instance of this class through the getFactory method of the Diagram class.

Inheritance Hierarchy

See Also

Factory Members


MindFusion.Diagramming.Factory Members

Factory Members
Methods
[image]

Provides shortcut methods for creating and adding instances of the standard item types.

The following tables list the members exposed by the Factory type.

Public Methods

Name | Description
createContainerNode | Creates a new ContainerNode instance and adds it to the nodes collection of the underlying diagram.
createDiagramLink | Creates a new DiagramLink instance between the specified nodes and adds it to the links collection of the underlying diagram.
createShapeNode | Creates a new ShapeNode instance and adds it to the nodes collection of the underlying diagram.
createSvgNode | Creates a new SvgNode instance and adds it to the nodes collection of the underlying diagram.
createTableNode | Creates a new TableNode instance and adds it to the nodes collection of the underlying diagram.

See Also

Factory Class


MindFusion.Diagramming.Factory Methods

Factory Methods
[image]

Public Methods

Name | Description
createContainerNode | Creates a new ContainerNode instance and adds it to the nodes collection of the underlying diagram.
createDiagramLink | Creates a new DiagramLink instance between the specified nodes and adds it to the links collection of the underlying diagram.
createShapeNode | Creates a new ShapeNode instance and adds it to the nodes collection of the underlying diagram.
createSvgNode | Creates a new SvgNode instance and adds it to the nodes collection of the underlying diagram.
createTableNode | Creates a new TableNode instance and adds it to the nodes collection of the underlying diagram.

See Also

Factory Class


MindFusion.Diagramming.Factory.createContainerNode Method

Factory.createContainerNode Method
[image]

Creates a new ContainerNode instance and adds it to the nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: Factory.js

Syntax

JavaScript [image] Copy Code

function createContainerNode ([bounds] | [x, y, width, height])

Parameters

bounds
Optional.

Specifies the bounding rectangle of the new node.

x
Optional.

The x-coordinate of the upper-left corner of the new node.

y
Optional.

The y-coordinate of the upper-left corner of the new node.

width
Optional.

The width of the new node.

height
Optional.

The height of the new node.

Return Value

The newly created ContainerNode instance.

See Also

Factory Members
Factory Class


MindFusion.Diagramming.Factory.createDiagramLink Method

Factory.createDiagramLink Method
[image]

Creates a new DiagramLink instance between the specified nodes and adds it to the links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: Factory.js

Syntax

JavaScript [image] Copy Code

function createDiagramLink ([origin, [destination]])

Parameters

origin
Optional. The origin node.
destination
Optional. The destination node.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the nodes specified by origin and destination.

See Also

Factory Members
Factory Class


MindFusion.Diagramming.Factory.createShapeNode Method

Factory.createShapeNode Method
[image]

Creates a new ShapeNode instance and adds it to the nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: Factory.js

Syntax

JavaScript [image] Copy Code

function createShapeNode ([bounds] | [x, y, width, height])

Parameters

bounds
Optional.

Sets the bounds of the shape to create.

x
Optional.

The x-coordinate of the upper-left corner of the new node.

y
Optional.

The y-coordinate of the upper-left corner of the new node.

width
Optional.

The width of the new node.

height
Optional.

The height of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

This method accepts either a single Rect object specifying the bounding rectangle of the new node, or a list of four numbers specifying the location and size.

The method creates a shape node with the specified arguments, if any.

See Also

Factory Members
Factory Class


MindFusion.Diagramming.Factory.createSvgNode Method

Factory.createSvgNode Method
[image]

Creates a new SvgNode instance and adds it to the nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: Factory.js

Syntax

JavaScript [image] Copy Code

function createSvgNode ([bounds] | [x, y, width, height])

Parameters

bounds
Optional.

Sets the bounds of the shape to create.

x
Optional.

The x-coordinate of the upper-left corner of the new node.

y
Optional.

The y-coordinate of the upper-left corner of the new node.

width
Optional.

The width of the new node.

height
Optional.

The height of the new node.

Return Value

The newly created SvgNode instance.

See Also

Factory Members
Factory Class


MindFusion.Diagramming.Factory.createTableNode Method

Factory.createTableNode Method
[image]

Creates a new TableNode instance and adds it to the nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: Factory.js

Syntax

JavaScript [image] Copy Code

function createTableNode ([bounds] | [x, y, width, height])

Parameters

bounds
Optional.

Specifies the bounding rectangle of the new node.

x
Optional.

The x-coordinate of the upper-left corner of the new node.

y
Optional.

The y-coordinate of the upper-left corner of the new node.

width
Optional.

The width of the new node.

height
Optional.

The height of the new node.

Return Value

The newly created TableNode instance.

See Also

Factory Members
Factory Class


MindFusion.Diagramming.FitSize Enumeration

FitSize Enumeration
[image]

Specifies how the ResizeToFitText method should resize a node.

Namespace: MindFusion.Diagramming
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
FitSize = {}

Members

Member name | Description
KeepHeight | The original node height should remain intact.
KeepRatio | Allow changing both the width and height of a node, but keep the original width/height ratio if possible.
KeepWidth | The original node width should remain intact.

See Also


MindFusion.Diagramming.FoldContainerCommand Class

FoldContainerCommand Class
[image]

Handles undo / redo of container folding.

Namespace: MindFusion.Diagramming
Assembly: FoldContainerCommand.js

Syntax

JavaScript [image] Copy Code

// class
FoldContainerCommand.prototype = {}

Inheritance Hierarchy

See Also

FoldContainerCommand Members


MindFusion.Diagramming.FoldContainerCommand Members

FoldContainerCommand Members
Constructors Methods
[image]

Handles undo / redo of container folding.

The following tables list the members exposed by the FoldContainerCommand type.

Public Constructors

Name | Description
FoldContainerCommand | Initializes a new instance of the FoldContainerCommand class.

Public Methods

Name | Description
execute | Command.execute override.
redo | Command.redo override.
undo | Command.undo override.

See Also

FoldContainerCommand Class


MindFusion.Diagramming.FoldContainerCommand Constructor

FoldContainerCommand Constructor
[image]

Initializes a new instance of the FoldContainerCommand class.

Namespace: MindFusion.Diagramming
Assembly: FoldContainerCommand.js

Syntax

JavaScript [image] Copy Code

function FoldContainerCommand (diagram, container)

Parameters

diagram

The Diagram modified by this command.

container

The ContainerNode instance that will be modified.

See Also

FoldContainerCommand Class


MindFusion.Diagramming.FoldContainerCommand Methods

FoldContainerCommand Methods
[image]

Public Methods

Name | Description
execute | Command.execute override.
redo | Command.redo override.
undo | Command.undo override.

See Also

FoldContainerCommand Class


MindFusion.Diagramming.FoldContainerCommand.execute Method

FoldContainerCommand.execute Method
[image]

Command.execute override.

Namespace: MindFusion.Diagramming
Assembly: FoldContainerCommand.js

Syntax

JavaScript [image] Copy Code

function execute ()

See Also

FoldContainerCommand Members
FoldContainerCommand Class


MindFusion.Diagramming.FoldContainerCommand.redo Method

FoldContainerCommand.redo Method
[image]

Command.redo override.

Namespace: MindFusion.Diagramming
Assembly: FoldContainerCommand.js

Syntax

JavaScript [image] Copy Code

function redo ()

See Also

FoldContainerCommand Members
FoldContainerCommand Class


MindFusion.Diagramming.FoldContainerCommand.undo Method

FoldContainerCommand.undo Method
[image]

Command.undo override.

Namespace: MindFusion.Diagramming
Assembly: FoldContainerCommand.js

Syntax

JavaScript [image] Copy Code

function undo ()

See Also

FoldContainerCommand Members
FoldContainerCommand Class


MindFusion.Diagramming.GlassEffect Class

GlassEffect Class
Remarks See Also
[image]

Represents a glass-like visual effect.

Namespace: MindFusion.Diagramming
Assembly: NodeEffects.js

Syntax

JavaScript [image] Copy Code

// class
GlassEffect.prototype = {}

Remarks

This effect can be applied to the nodes in a Diagram by adding an instance of this class to the NodeEffects collection.

The following image illustrates the Glass effect applied to an item as well as how the different properties affect the output:

Example

The following example demonstrates how to apply glass effect to the nodes of an existing diagram.

JavaScript [image] Copy Code
var GlassEffect = MindFusion.Diagramming.GlassEffect;
diagram.getNodeEffects().push(new GlassEffect());

Inheritance Hierarchy

See Also

GlassEffect Members
MindFusion.Diagramming Namespace
Node Effects
AeroEffect Class


MindFusion.Diagramming.GlassEffect Members

GlassEffect Members
Constructors Methods
[image]

Represents a glass-like visual effect.

The following tables list the members exposed by the GlassEffect type.

Public Constructors

Name | Description
GlassEffect | Initializes a new instance of the GlassEffect class.

Public Methods

Name | Description
getGlowColor | Gets the color of the glow portion of the effect.
getReflectionColor | Gets the color of the reflection portion of the effect.
getType | Gets the type of the glass effect.
getUsePenAsGlow | Gets a value indicating whether the glow portion of the effect should be painted with the stroke color of the respective node.
setGlowColor | Sets the color of the glow portion of the effect.
setReflectionColor | Sets the color of the reflection portion of the effect.
setType | Sets the type of the glass effect.
setUsePenAsGlow | Sets a value indicating whether the glow portion of the effect should be painted with the stroke color of the respective node.

See Also

GlassEffect Class


MindFusion.Diagramming.GlassEffect Constructor

GlassEffect Constructor
[image]

Initializes a new instance of the GlassEffect class.

Namespace: MindFusion.Diagramming
Assembly: NodeEffects.js

Syntax

JavaScript [image] Copy Code

function GlassEffect ()

See Also

GlassEffect Class


MindFusion.Diagramming.GlassEffect Methods

GlassEffect Methods
[image]

Public Methods

Name | Description
getGlowColor | Gets the color of the glow portion of the effect.
getReflectionColor | Gets the color of the reflection portion of the effect.
getType | Gets the type of the glass effect.
getUsePenAsGlow | Gets a value indicating whether the glow portion of the effect should be painted with the stroke color of the respective node.
setGlowColor | Sets the color of the glow portion of the effect.
setReflectionColor | Sets the color of the reflection portion of the effect.
setType | Sets the type of the glass effect.
setUsePenAsGlow | Sets a value indicating whether the glow portion of the effect should be painted with the stroke color of the respective node.

See Also

GlassEffect Class


MindFusion.Diagramming.GlassEffect.getGlowColor Method

GlassEffect.getGlowColor Method
[image]

Gets the color of the glow portion of the effect.

Namespace: MindFusion.Diagramming
Assembly: NodeEffects.js

Syntax

JavaScript [image] Copy Code

function getGlowColor ()

Return Value

A string specifying the color name or hexadecimal value. The default value is "white".

See Also

GlassEffect Members
GlassEffect Class


MindFusion.Diagramming.GlassEffect.getReflectionColor Method

GlassEffect.getReflectionColor Method
[image]

Gets the color of the reflection portion of the effect.

Namespace: MindFusion.Diagramming
Assembly: NodeEffects.js

Syntax

JavaScript [image] Copy Code

function getReflectionColor ()

Return Value

A string specifying the color name or hexadecimal value. The default value is "white".

See Also

GlassEffect Members
GlassEffect Class


MindFusion.Diagramming.GlassEffect.getType Method

GlassEffect.getType Method
[image]

Gets the type of the glass effect.

Namespace: MindFusion.Diagramming
Assembly: NodeEffects.js

Syntax

JavaScript [image] Copy Code

function getType ()

Return Value

A member of the GlassEffectType enumeration. The default is Type1.

See Also

GlassEffect Members
GlassEffect Class


MindFusion.Diagramming.GlassEffect.getUsePenAsGlow Method

GlassEffect.getUsePenAsGlow Method
[image]

Gets a value indicating whether the glow portion of the effect should be painted with the stroke color of the respective node.

Namespace: MindFusion.Diagramming
Assembly: NodeEffects.js

Syntax

JavaScript [image] Copy Code

function getUsePenAsGlow ()

Return Value

true to ignore GlowColor and use the node's stroke color for the effect glow; otherwise, false.

See Also

GlassEffect Members
GlassEffect Class


MindFusion.Diagramming.GlassEffect.setGlowColor Method

GlassEffect.setGlowColor Method
[image]

Sets the color of the glow portion of the effect.

Namespace: MindFusion.Diagramming
Assembly: NodeEffects.js

Syntax

JavaScript [image] Copy Code

function setGlowColor (value)

Parameters

value

A string specifying the color name or hexadecimal value. The default value is "white".

See Also

GlassEffect Members
GlassEffect Class


MindFusion.Diagramming.GlassEffect.setReflectionColor Method

GlassEffect.setReflectionColor Method
[image]

Sets the color of the reflection portion of the effect.

Namespace: MindFusion.Diagramming
Assembly: NodeEffects.js

Syntax

JavaScript [image] Copy Code

function setReflectionColor (value)

Parameters

value

A string specifying the color name or hexadecimal value. The default value is "white".

See Also

GlassEffect Members
GlassEffect Class


MindFusion.Diagramming.GlassEffect.setType Method

GlassEffect.setType Method
[image]

Sets the type of the glass effect.

Namespace: MindFusion.Diagramming
Assembly: NodeEffects.js

Syntax

JavaScript [image] Copy Code

function setType (value)

Parameters

value

A member of the GlassEffectType enumeration. The default is Type1.

See Also

GlassEffect Members
GlassEffect Class


MindFusion.Diagramming.GlassEffect.setUsePenAsGlow Method

GlassEffect.setUsePenAsGlow Method
[image]

Sets a value indicating whether the glow portion of the effect should be painted with the stroke color of the respective node.

Namespace: MindFusion.Diagramming
Assembly: NodeEffects.js

Syntax

JavaScript [image] Copy Code

function setUsePenAsGlow (value)

Parameters

value

true to ignore GlowColor and use the node's stroke color for the effect glow; otherwise, false.

See Also

GlassEffect Members
GlassEffect Class


MindFusion.Diagramming.GlassEffectType Enumeration

GlassEffectType Enumeration
[image]

Specifies the type of a GlassEffect node effect.

Namespace: MindFusion.Diagramming
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
GlassEffectType = {}

Members

Member name | Description
Type1 | Indicates a glass effect with soft radial glow at the bottom and a sharp reflection at the top.
Type2 | Indicates a glass effect with linear glow at the bottom and sharp reflection at the top.
Type3 | Indicates a glass effect with radial glow at the bottom and smooth reflection and emphasized outline at the top.
Type4 | Indicates a glass effect with sharp reflection at the top and soft glow at the left and right sides.

See Also


MindFusion.Diagramming.GridStyle Enumeration

GridStyle Enumeration
[image]

Defines values that specify the visual style of the alignment grid.

Namespace: MindFusion.Diagramming
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
GridStyle = {}

Members

Member name | Description
Crosses | The grid is painted as a matrix of crosses.
Lines | The grid is represented as a series of crossing horizontal and vertical lines.
Points | The grid is painted as a matrix of points.

See Also


MindFusion.Diagramming.HandlesStyle Enumeration

HandlesStyle Enumeration
[image]

Enumerates possible visual styles for frames and handles drawn around selected nodes.

Namespace: MindFusion.Diagramming
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
HandlesStyle = {}

Members

Member name | Description
Custom | The control raises the drawAdjustmentHandles and hitTestAdjustmentHandles events to let your application perform custom drawing and hit testing of selection handles.
DashFrame | If selected, a node is drawn with a dashed frame. The frame enables resizing the node. The center of the node allows moving it and the edge area enables creating links.
EasyMove | Any point of the interior of a node enables moving the node, except a small area in the center that allows creating links. Best used with ModificationStart set to AutoHandles.
HatchFrame | If selected, the item is drawn with hatched frame. Modifications can be done as with DashFrame.
HatchHandles | If selected, a node is drawn with both hatched frame and modification handles. The frame enable moving the node, and the handles enable resizing. Links are created from any point of the interior.
HatchHandles2 | Looks like HatchHandles, but allows moving the node from the interior area. Links are created from the points near the edge.
HatchHandles3 | Behaves like HatchHandles2, but paints the selection frame using a denser brush pattern.
Invisible | There is no visible difference between selected and unselected node.
InvisibleMove | There aren't any selection handles displayed. The selected node can be only moved, but not resized.
MoveOnly | If a node is selected, it can be only moved. Best used with ModificationStart set to AutoHandles.
RoundAndSquare | Corner resize handles are round, remaining handles are square.
RoundAndSquare2 | Corner resize handles are round, remaining handles are square. In addition, there is a dashed frame drawn around selected nodes.
SquareHandles | If selected, the node is drawn with square modification handles.
SquareHandles2 | Square resize handles are drawn around a selected node. There isn't a move handle in the center as with the SquareHandles style, but nodes can be moved by dragging their interior or caption areas. Links can be created by drawing from near the edges of a node.

See Also


MindFusion.Diagramming.ImageAlign Enumeration

ImageAlign Enumeration
[image]

Specifies the position and alignment of a picture in a node, or that of the background image.

Namespace: MindFusion.Diagramming
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
ImageAlign = {}

Members

Member name | Description
BottomCenter | The image is centered horizontally and aligned to the bottom side.
BottomLeft | The image is aligned to the bottom left corner of the node or the diagram.
BottomRight | The image is aligned to the bottom right corner of the node or the diagram.
Center | The image is centered in the node or diagram.
Fit | The image is resized to fit the size of the object or the component's client area.
MiddleLeft | The image is centered vertically and aligned to the left-hand side.
MiddleRight | The image is centered vertically and aligned to the right-hand side.
Stretch | The image is stretched to fill the object or the component's client area.
Tile | The image is tiled to cover the node or the diagram.
TopCenter | The image is centered horizontally and aligned to the top side.
TopLeft | The image is aligned to the top left corner of the node or the diagram.
TopRight | The image is aligned to the top right corner of the node or the diagram.

See Also


MindFusion.Diagramming.InplaceEditEventArgs Class

InplaceEditEventArgs Class
[image]

Contains the arguments passed to handlers of inplace edit related events.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

// class
InplaceEditEventArgs.prototype = {}

Inheritance Hierarchy

See Also

InplaceEditEventArgs Members


MindFusion.Diagramming.InplaceEditEventArgs Members

InplaceEditEventArgs Members
Constructors Methods
[image]

Contains the arguments passed to handlers of inplace edit related events.

The following tables list the members exposed by the InplaceEditEventArgs type.

Public Constructors

Name | Description
InplaceEditEventArgs | Initializes a new instance of the InplaceEditEventArgs class.

Public Methods

Name | Description
getBounds | Gets the bounds of the item being edited.
getControl | Gets the control used to edit the item's text.
getItem | Gets a reference to the item being edited.
setControl | Sets the control used to edit the item's text.

See Also

InplaceEditEventArgs Class


MindFusion.Diagramming.InplaceEditEventArgs Constructor

InplaceEditEventArgs Constructor
[image]

Initializes a new instance of the InplaceEditEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function InplaceEditEventArgs ()

See Also

InplaceEditEventArgs Class


MindFusion.Diagramming.InplaceEditEventArgs Methods

InplaceEditEventArgs Methods
[image]

Public Methods

Name | Description
getBounds | Gets the bounds of the item being edited.
getControl | Gets the control used to edit the item's text.
getItem | Gets a reference to the item being edited.
setControl | Sets the control used to edit the item's text.

See Also

InplaceEditEventArgs Class


MindFusion.Diagramming.InplaceEditEventArgs.getBounds Method

InplaceEditEventArgs.getBounds Method
[image]

Gets the bounds of the item being edited.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getBounds ()

Return Value

A Rect instance

See Also

InplaceEditEventArgs Members
InplaceEditEventArgs Class


MindFusion.Diagramming.InplaceEditEventArgs.getControl Method

InplaceEditEventArgs.getControl Method
[image]

Gets the control used to edit the item's text.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getControl ()

Return Value

Html DOM element to use as editor.

See Also

InplaceEditEventArgs Members
InplaceEditEventArgs Class


MindFusion.Diagramming.InplaceEditEventArgs.getItem Method

InplaceEditEventArgs.getItem Method
[image]

Gets a reference to the item being edited.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getItem ()

Return Value

A DiagramItem instance.

See Also

InplaceEditEventArgs Members
InplaceEditEventArgs Class


MindFusion.Diagramming.InplaceEditEventArgs.setControl Method

InplaceEditEventArgs.setControl Method
[image]

Sets the control used to edit the item's text.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function setControl (value)

Parameters

value

Html DOM element to use as editor.

See Also

InplaceEditEventArgs Members
InplaceEditEventArgs Class


MindFusion.Diagramming.Interaction Class

Interaction Class
[image]

Encapsulates the current state of user interaction with the control.

Namespace: MindFusion.Diagramming
Assembly: Interaction.js

Syntax

JavaScript [image] Copy Code

// class
Interaction.prototype = {}

Inheritance Hierarchy

See Also

Interaction Members


MindFusion.Diagramming.Interaction Members

Interaction Members
Constructors
[image]

Encapsulates the current state of user interaction with the control.

The following tables list the members exposed by the Interaction type.

Public Constructors

Name | Description
Interaction | Initializes a new instance of the Interaction class.

See Also

Interaction Class


MindFusion.Diagramming.Interaction Constructor

Interaction Constructor
[image]

Initializes a new instance of the Interaction class.

Namespace: MindFusion.Diagramming
Assembly: Interaction.js

Syntax

JavaScript [image] Copy Code

function Interaction ([diagram])

Parameters

diagram
Optional.

See Also

Interaction Class


MindFusion.Diagramming.InteractionState Class

InteractionState Class
[image]

Encapsulates the current state of user interaction with the control.

Namespace: MindFusion.Diagramming
Assembly: InteractionState.js

Syntax

JavaScript [image] Copy Code

// class
InteractionState.prototype = {}

Inheritance Hierarchy

See Also

InteractionState Members


MindFusion.Diagramming.InteractionState Members

InteractionState Members
Constructors Methods
[image]

Encapsulates the current state of user interaction with the control.

The following tables list the members exposed by the InteractionState type.

Public Constructors

Name | Description
InteractionState | Initializes a new instance of the InteractionState class.

Public Methods

Name | Description
cancel | Cancels the user interaction. Call this method to cancel interaction, usually in response to the user clicking the right mouse button while dragging.
commit | Invoked to commit the changes made by the user.
isAllowed | Checks whether the current interaction can be completed at the specified point.
start | This method is invoked in the beginning of the interaction, usually when the user presses the left mouse button over a modification handle.
update | This method is invoked to update the interaction state, usually in response to the user moving the mouse after the modification has started.

See Also

InteractionState Class


MindFusion.Diagramming.InteractionState Constructor

InteractionState Constructor
[image]

Initializes a new instance of the InteractionState class.

Namespace: MindFusion.Diagramming
Assembly: InteractionState.js

Syntax

JavaScript [image] Copy Code

function InteractionState (modifiedItem, action, adjustmentHandle, point)

Parameters

modifiedItem
The DiagramItem to be created or modified.
action
One of the Action enumeration values, specifying what kind of action to perform.
adjustmentHandle

The index of the selection handle to be dragged with the mouse, defines what kind of modification to perform.

point
A Point specifying the mouse position where the user starts to draw or modify an item.

See Also

InteractionState Class


MindFusion.Diagramming.InteractionState Methods

InteractionState Methods
[image]

Public Methods

Name | Description
cancel | Cancels the user interaction. Call this method to cancel interaction, usually in response to the user clicking the right mouse button while dragging.
commit | Invoked to commit the changes made by the user.
isAllowed | Checks whether the current interaction can be completed at the specified point.
start | This method is invoked in the beginning of the interaction, usually when the user presses the left mouse button over a modification handle.
update | This method is invoked to update the interaction state, usually in response to the user moving the mouse after the modification has started.

See Also

InteractionState Class


MindFusion.Diagramming.InteractionState.cancel Method

InteractionState.cancel Method
[image]

Cancels the user interaction. Call this method to cancel interaction, usually in response to the user clicking the right mouse button while dragging.

Namespace: MindFusion.Diagramming
Assembly: InteractionState.js

Syntax

JavaScript [image] Copy Code

function cancel (diagram)

Parameters

diagram
The Diagram, at which the action is performed.

Remarks

Call this method to cancel interaction, usually in response to the user clicking the right mouse button while dragging.

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.commit Method

InteractionState.commit Method
[image]

Invoked to commit the changes made by the user.

Namespace: MindFusion.Diagramming
Assembly: InteractionState.js

Syntax

JavaScript [image] Copy Code

function commit (point)

Parameters

point
A Point instance indicating the location of the cursor, in document coordinates.

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.isAllowed Method

InteractionState.isAllowed Method
[image]

Checks whether the current interaction can be completed at the specified point.

Namespace: MindFusion.Diagramming
Assembly: InteractionState.js

Syntax

JavaScript [image] Copy Code

function isAllowed (point)

Parameters

point
A Point instance indicating the location of the cursor, in document coordinates.

Return Value

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.start Method

InteractionState.start Method
[image]

This method is invoked in the beginning of the interaction, usually when the user presses the left mouse button over a modification handle.

Namespace: MindFusion.Diagramming
Assembly: InteractionState.js

Syntax

JavaScript [image] Copy Code

function start ()

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.update Method

InteractionState.update Method
[image]

This method is invoked to update the interaction state, usually in response to the user moving the mouse after the modification has started.

Namespace: MindFusion.Diagramming
Assembly: InteractionState.js

Syntax

JavaScript [image] Copy Code

function update (point)

Parameters

point
A Point instance indicating the location of the cursor, in document coordinates.

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.LinkCrossings Enumeration

LinkCrossings Enumeration
[image]

Defines values that indicate how to render link intersection points.

Namespace: MindFusion.Diagramming
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
LinkCrossings = {}

Members

Member name | Description
Arcs | An arc is drawn at the intersection point of two links. It connects the segments of the link at higher Z position and goes over the link at lower Z.
Cut | The intersection segments of links at lower Z position are cut by links at higher Z position.
Straight | No special indication for link intersection points.

Remarks

Values from this enumeration can be assigned to LinkCrossings.

See Also


MindFusion.Diagramming.LinkEventArgs Class

LinkEventArgs Class
[image]

Contains the arguments passed to handlers of link validation events.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

// class
LinkEventArgs.prototype = {}

Inheritance Hierarchy

See Also

LinkEventArgs Members


MindFusion.Diagramming.LinkEventArgs Members

LinkEventArgs Members
Constructors Methods
[image]

Contains the arguments passed to handlers of link validation events.

The following tables list the members exposed by the LinkEventArgs type.

Public Constructors

Name | Description
LinkEventArgs | Overloaded.

Public Methods

Name | Description
cancelDrag | Immediately cancels the creation or modification of the link.
getAdjustmentHandle | Gets or sets the adjustment handle being moved by the user.
getCancel | Gets a value indicating whether to allow the current operation.
getLink | Gets the link for which the event raised.
getMouseButton | Gets which mouse button was pressed.
getMousePosition | Gets the current mouse pointer position.
getNewText | Gets the text that has just been entered by the user.
getOldText | Gets the text that had been displayed as a link label before the user edited it.
setCancel | Sets a value indicating whether to allow the current operation.

See Also

LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs Constructor

LinkEventArgs Constructor
[image]

Overload List

Name | Description
LinkEventArgs () | Initializes a new instance of the LinkEventArgs class.
LinkEventArgs (Object) | Initializes a new instance of the LinkEventArgs class.

See Also

LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs Constructor ()

LinkEventArgs Constructor ()
See Also
[image]

Initializes a new instance of the LinkEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function LinkEventArgs ()

See Also

LinkEventArgs Constructor Overload List
LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs Constructor (Object)

LinkEventArgs Constructor (Object)
See Also
[image]

Initializes a new instance of the LinkEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function LinkEventArgs (args)

Parameters

args

See Also

LinkEventArgs Constructor Overload List
LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs Methods

LinkEventArgs Methods
[image]

Public Methods

Name | Description
cancelDrag | Immediately cancels the creation or modification of the link.
getAdjustmentHandle | Gets or sets the adjustment handle being moved by the user.
getCancel | Gets a value indicating whether to allow the current operation.
getLink | Gets the link for which the event raised.
getMouseButton | Gets which mouse button was pressed.
getMousePosition | Gets the current mouse pointer position.
getNewText | Gets the text that has just been entered by the user.
getOldText | Gets the text that had been displayed as a link label before the user edited it.
setCancel | Sets a value indicating whether to allow the current operation.

See Also

LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs.cancelDrag Method

LinkEventArgs.cancelDrag Method
[image]

Immediately cancels the creation or modification of the link.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function cancelDrag ()

See Also

LinkEventArgs Members
LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs.getAdjustmentHandle Method

LinkEventArgs.getAdjustmentHandle Method
[image]

Gets or sets the adjustment handle being moved by the user.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getAdjustmentHandle ()

Return Value

One of the AdjustmentHandle enumeration values.

See Also

LinkEventArgs Members
LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs.getCancel Method

LinkEventArgs.getCancel Method
[image]

Gets a value indicating whether to allow the current operation.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getCancel ()

Return Value

true if the current operation is allowed; otherwise, false.

See Also

LinkEventArgs Members
LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs.getLink Method

LinkEventArgs.getLink Method
[image]

Gets the link for which the event raised.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getLink ()

Return Value

A DiagramLink instance.

See Also

LinkEventArgs Members
LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs.getMouseButton Method

LinkEventArgs.getMouseButton Method
[image]

Gets which mouse button was pressed.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getMouseButton ()

Return Value

One of the MouseButton enumeration values.

See Also

LinkEventArgs Members
LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs.getMousePosition Method

LinkEventArgs.getMousePosition Method
[image]

Gets the current mouse pointer position.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getMousePosition ()

Return Value

A Point instance that indicates the mouse position.

See Also

LinkEventArgs Members
LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs.getNewText Method

LinkEventArgs.getNewText Method
[image]

Gets the text that has just been entered by the user.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getNewText ()

Return Value

A string specifying the new text of the link.

See Also

LinkEventArgs Members
LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs.getOldText Method

LinkEventArgs.getOldText Method
[image]

Gets the text that had been displayed as a link label before the user edited it.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getOldText ()

Return Value

A string specifying the old text of the link.

See Also

LinkEventArgs Members
LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs.setCancel Method

LinkEventArgs.setCancel Method
[image]

Sets a value indicating whether to allow the current operation.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function setCancel (value)

Parameters

value

true to allow the current operation; otherwise, false.

See Also

LinkEventArgs Members
LinkEventArgs Class


MindFusion.Diagramming.LinkLabel Class

LinkLabel Class
[image]

Represents a label displayed by a DiagramLink. New labels can be added to a link by calling its addLabel method.

Namespace: MindFusion.Diagramming
Assembly: LinkLabel.js

Syntax

JavaScript [image] Copy Code

// class
LinkLabel.prototype = {}

Inheritance Hierarchy

See Also

LinkLabel Members


MindFusion.Diagramming.LinkLabel Members

LinkLabel Members
Constructors Methods
[image]

Represents a label displayed by a DiagramLink. New labels can be added to a link by calling its addLabel method.

The following tables list the members exposed by the LinkLabel type.

Public Constructors

Name | Description
LinkLabel | Initializes a new instance of the LinkLabel class.

Public Methods

Name | Description
getAutoArrange | Gets a value indicating whether the label can be auto arranged.
getBrush | Gets the brush used to draw the label's background.
getFont | Gets the font used to render this item's text.
getHorizontalAlign | Gets the label's horizontal align.
getMargin | Gets the label's margin.
getText | Gets the item's text.
getTextColor | Gets a string specifying the color of the text of this item.
getVerticalAlign | Gets the label's vertical align.
setAutoArrange | Sets a value indicating whether the label can be auto arranged.
setBrush | Sets the brush used to draw the label's background.
setControlPointPosition | Positions this label relatively to the specified control point.
setFont | Sets the font used to render this item's text.
setHorizontalAlign | Sets the label's horizontal align.
setLinkLengthPosition | Positions this label relatively to the link length.
setMargin | Sets the label's margin.
setSegmentPosition | Positions this label relatively to the specified link segment.
setText | Sets the item's text.
setTextColor | Sets a string specifying the color of the text of this item.
setVerticalAlign | Sets the label's vertical align.

See Also

LinkLabel Class


MindFusion.Diagramming.LinkLabel Constructor

LinkLabel Constructor
[image]

Initializes a new instance of the LinkLabel class.

Namespace: MindFusion.Diagramming
Assembly: LinkLabel.js

Syntax

JavaScript [image] Copy Code

function LinkLabel (link, text)

Parameters

link

The DiagramLink that displays the label.

text

The label's text.

See Also

LinkLabel Class


MindFusion.Diagramming.LinkLabel Methods

LinkLabel Methods
[image]

Public Methods

Name | Description
getAutoArrange | Gets a value indicating whether the label can be auto arranged.
getBrush | Gets the brush used to draw the label's background.
getFont | Gets the font used to render this item's text.
getHorizontalAlign | Gets the label's horizontal align.
getMargin | Gets the label's margin.
getText | Gets the item's text.
getTextColor | Gets a string specifying the color of the text of this item.
getVerticalAlign | Gets the label's vertical align.
setAutoArrange | Sets a value indicating whether the label can be auto arranged.
setBrush | Sets the brush used to draw the label's background.
setControlPointPosition | Positions this label relatively to the specified control point.
setFont | Sets the font used to render this item's text.
setHorizontalAlign | Sets the label's horizontal align.
setLinkLengthPosition | Positions this label relatively to the link length.
setMargin | Sets the label's margin.
setSegmentPosition | Positions this label relatively to the specified link segment.
setText | Sets the item's text.
setTextColor | Sets a string specifying the color of the text of this item.
setVerticalAlign | Sets the label's vertical align.

See Also

LinkLabel Class


MindFusion.Diagramming.LinkLabel.getAutoArrange Method

LinkLabel.getAutoArrange Method
[image]

Gets a value indicating whether the label can be auto arranged.

Namespace: MindFusion.Diagramming
Assembly: LinkLabel.js

Syntax

JavaScript [image] Copy Code

function getAutoArrange ()

Return Value

true if the label can be auto arranged, otherwise false.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.getBrush Method

LinkLabel.getBrush Method
[image]

Gets the brush used to draw the label's background.

Namespace: MindFusion.Diagramming
Assembly: LinkLabel.js

Syntax

JavaScript [image] Copy Code

function getBrush ()

Return Value

An object specifying the label's background.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.getFont Method

LinkLabel.getFont Method
[image]

Gets the font used to render this item's text.

Namespace: MindFusion.Diagramming
Assembly: LinkLabel.js

Syntax

JavaScript [image] Copy Code

function getFont ()

Return Value

A Font instance.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.getHorizontalAlign Method

LinkLabel.getHorizontalAlign Method
[image]

Gets the label's horizontal align.

Namespace: MindFusion.Diagramming
Assembly: LinkLabel.js

Syntax

JavaScript [image] Copy Code

function getHorizontalAlign ()

Return Value

One of the Alignment enumeration values.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.getMargin Method

LinkLabel.getMargin Method
[image]

Gets the label's margin.

Namespace: MindFusion.Diagramming
Assembly: LinkLabel.js

Syntax

JavaScript [image] Copy Code

function getMargin ()

Return Value

A Thickness instance specifying the size of margin on all sides of label.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.getText Method

LinkLabel.getText Method
[image]

Gets the item's text.

Namespace: MindFusion.Diagramming
Assembly: LinkLabel.js

Syntax

JavaScript [image] Copy Code

function getText ()

Return Value

The text.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.getTextColor Method

LinkLabel.getTextColor Method
[image]

Gets a string specifying the color of the text of this item.

Namespace: MindFusion.Diagramming
Assembly: LinkLabel.js

Syntax

JavaScript [image] Copy Code

function getTextColor ()

Return Value

A string value identifying the color of the text.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.getVerticalAlign Method

LinkLabel.getVerticalAlign Method
[image]

Gets the label's vertical align.

Namespace: MindFusion.Diagramming
Assembly: LinkLabel.js

Syntax

JavaScript [image] Copy Code

function getVerticalAlign ()

Return Value

One of the Alignment enumeration values.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.setAutoArrange Method

LinkLabel.setAutoArrange Method
[image]

Sets a value indicating whether the label can be auto arranged.

Namespace: MindFusion.Diagramming
Assembly: LinkLabel.js

Syntax

JavaScript [image] Copy Code

function setAutoArrange (value)

Parameters

value

true if the label can be auto arranged, otherwise false.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.setBrush Method

LinkLabel.setBrush Method
[image]

Sets the brush used to draw the label's background.

Namespace: MindFusion.Diagramming
Assembly: LinkLabel.js

Syntax

JavaScript [image] Copy Code

function setBrush (value)

Parameters

value

A Brush object specifying the label's background.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.setControlPointPosition Method

LinkLabel.setControlPointPosition Method
[image]

Positions this label relatively to the specified control point.

Namespace: MindFusion.Diagramming
Assembly: LinkLabel.js

Syntax

JavaScript [image] Copy Code

function setControlPointPosition (controlPoint, dx, dy)

Parameters

controlPoint

The control point index.

dx

Horizontal offset from the segment center.

dy

Vertical offset from the segment center.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.setFont Method

LinkLabel.setFont Method
[image]

Sets the font used to render this item's text.

Namespace: MindFusion.Diagramming
Assembly: LinkLabel.js

Syntax

JavaScript [image] Copy Code

function setFont (value)

Parameters

value

A Font instance.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.setHorizontalAlign Method

LinkLabel.setHorizontalAlign Method
[image]

Sets the label's horizontal align.

Namespace: MindFusion.Diagramming
Assembly: LinkLabel.js

Syntax

JavaScript [image] Copy Code

function setHorizontalAlign (value)

Parameters

value

One of the Alignment enumeration values.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.setLinkLengthPosition Method

LinkLabel.setLinkLengthPosition Method
[image]

Positions this label relatively to the link length.

Namespace: MindFusion.Diagramming
Assembly: LinkLabel.js

Syntax

JavaScript [image] Copy Code

function setLinkLengthPosition (lengthFactor)

Parameters

lengthFactor

A value between 0 and 1 specifying the position of the label relatively to the link's length.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.setMargin Method

LinkLabel.setMargin Method
[image]

Sets the label's margin.

Namespace: MindFusion.Diagramming
Assembly: LinkLabel.js

Syntax

JavaScript [image] Copy Code

function setMargin (value)

Parameters

value
A Thickness instance specifying the size of margin on all sides of label.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.setSegmentPosition Method

LinkLabel.setSegmentPosition Method
[image]

Positions this label relatively to the specified link segment.

Namespace: MindFusion.Diagramming
Assembly: LinkLabel.js

Syntax

JavaScript [image] Copy Code

function setSegmentPosition (segment, dx, dy)

Parameters

segment

The segment index.

dx

Horizontal offset from the segment center.

dy

Vertical offset from the segment center.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.setText Method

LinkLabel.setText Method
[image]

Sets the item's text.

Namespace: MindFusion.Diagramming
Assembly: LinkLabel.js

Syntax

JavaScript [image] Copy Code

function setText (value)

Parameters

value

The text.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.setTextColor Method

LinkLabel.setTextColor Method
[image]

Sets a string specifying the color of the text of this item.

Namespace: MindFusion.Diagramming
Assembly: LinkLabel.js

Syntax

JavaScript [image] Copy Code

function setTextColor (value)

Parameters

value

A string value identifying the color of the text.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.setVerticalAlign Method

LinkLabel.setVerticalAlign Method
[image]

Sets the label's vertical align.

Namespace: MindFusion.Diagramming
Assembly: LinkLabel.js

Syntax

JavaScript [image] Copy Code

function setVerticalAlign (value)

Parameters

value

One of the Alignment enumeration values.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkNodesBehavior Class

LinkNodesBehavior Class
[image]

The base class for behavior types that allow drawing both nodes and links.

Namespace: MindFusion.Diagramming
Assembly: LinkNodesBehavior.js

Syntax

JavaScript [image] Copy Code

// class
LinkNodesBehavior.prototype = {}

Inheritance Hierarchy

See Also

LinkNodesBehavior Members


MindFusion.Diagramming.LinkNodesBehavior Members

LinkNodesBehavior Members
Constructors Methods
[image]

The base class for behavior types that allow drawing both nodes and links.

The following tables list the members exposed by the LinkNodesBehavior type.

Public Constructors

Name | Description
LinkNodesBehavior | Overloaded.

Public Methods

Name | Description
startDraw | BehaviorBase.StartDraw override.

See Also

LinkNodesBehavior Class


MindFusion.Diagramming.LinkNodesBehavior Constructor

LinkNodesBehavior Constructor
[image]

Overload List

Name | Description
LinkNodesBehavior () | Initializes a new instance of the LinkNodesBehavior class.
LinkNodesBehavior (Diagram) | Initializes a new instance of the LinkNodesBehavior class.

See Also

LinkNodesBehavior Class


MindFusion.Diagramming.LinkNodesBehavior Constructor ()

LinkNodesBehavior Constructor ()
See Also
[image]

Initializes a new instance of the LinkNodesBehavior class.

Namespace: MindFusion.Diagramming
Assembly: LinkNodesBehavior.js

Syntax

JavaScript [image] Copy Code

function LinkNodesBehavior ()

See Also

LinkNodesBehavior Constructor Overload List
LinkNodesBehavior Class


MindFusion.Diagramming.LinkNodesBehavior Constructor (Diagram)

LinkNodesBehavior Constructor (Diagram)
See Also
[image]

Initializes a new instance of the LinkNodesBehavior class.

Namespace: MindFusion.Diagramming
Assembly: LinkNodesBehavior.js

Syntax

JavaScript [image] Copy Code

function LinkNodesBehavior (parent)

Parameters

parent

The Diagram this behavior will be associated with.

See Also

LinkNodesBehavior Constructor Overload List
LinkNodesBehavior Class


MindFusion.Diagramming.LinkNodesBehavior Methods

LinkNodesBehavior Methods
[image]

Public Methods

Name | Description
startDraw | BehaviorBase.StartDraw override.

See Also

LinkNodesBehavior Class


MindFusion.Diagramming.LinkNodesBehavior.startDraw Method

LinkNodesBehavior.startDraw Method
[image]

BehaviorBase.StartDraw override.

Namespace: MindFusion.Diagramming
Assembly: LinkNodesBehavior.js

Syntax

JavaScript [image] Copy Code

function startDraw (point)

Parameters

point

A Point structure, which specifies the current position of the mouse cursor, in document coordinates.

Return Value

An instance of the InteractionState class.

See Also

LinkNodesBehavior Members
LinkNodesBehavior Class


MindFusion.Diagramming.LinkShape Enumeration

LinkShape Enumeration
[image]

Specifies available styles for the segments of links.

Namespace: MindFusion.Diagramming
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
LinkShape = {}

Members

Member name | Description
Bezier | The segments of a link are Bйzier curves.
Cascading | The segments of a link are alternating horizontal and vertical lines, orthogonal to each other.
Polyline | The segments of a link are straight lines.

See Also


MindFusion.Diagramming.LinkShapesBehavior Class

LinkShapesBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.LinkShapes.

Namespace: MindFusion.Diagramming
Assembly: LinkShapesBehavior.js

Syntax

JavaScript [image] Copy Code

// class
LinkShapesBehavior.prototype = {}

Inheritance Hierarchy

See Also

LinkShapesBehavior Members


MindFusion.Diagramming.LinkShapesBehavior Members

LinkShapesBehavior Members
Constructors Methods
[image]

This class is used when the diagram behavior is set to Behavior.LinkShapes.

The following tables list the members exposed by the LinkShapesBehavior type.

Public Constructors

Name | Description
LinkShapesBehavior | Initializes a new instance of the LinkShapesBehavior class.

Public Methods

Name | Description
createNode | LinkNodesBehavior.CreateNode override.

See Also

LinkShapesBehavior Class


MindFusion.Diagramming.LinkShapesBehavior Constructor

LinkShapesBehavior Constructor
[image]

Initializes a new instance of the LinkShapesBehavior class.

Namespace: MindFusion.Diagramming
Assembly: LinkShapesBehavior.js

Syntax

JavaScript [image] Copy Code

function LinkShapesBehavior (parent)

Parameters

parent
The Diagram this behavior will be associated with.

See Also

LinkShapesBehavior Class


MindFusion.Diagramming.LinkShapesBehavior Methods

LinkShapesBehavior Methods
[image]

Public Methods

Name | Description
createNode | LinkNodesBehavior.CreateNode override.

See Also

LinkShapesBehavior Class


MindFusion.Diagramming.LinkShapesBehavior.createNode Method

LinkShapesBehavior.createNode Method
[image]

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming
Assembly: LinkShapesBehavior.js

Syntax

JavaScript [image] Copy Code

function createNode ()

Return Value

An instance of the DiagramNode class.

See Also

LinkShapesBehavior Members
LinkShapesBehavior Class


MindFusion.Diagramming.LinkTextStyle Enumeration

LinkTextStyle Enumeration
[image]

Specifies the position and alignment of links' labels.

Namespace: MindFusion.Diagramming
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
LinkTextStyle = {}

Members

Member name | Description
Center | The text is displayed horizontally above the middle link segment or control point, depending on whetherthere are an odd or even number of segments.
Follow | The label text starts from the first point of the link and follows the path defined by the link segments.This style is useful for displaying long text.
MiddleSegment | The text is displayed horizontally above the middle link segment.If there are an even number of segments, the label is drawn over the longer from the two segments adjacent to the middle control point.
MiddleSegmentRotated | The text is displayed rotated at the same angle as the segment where the text is placed. A long enough segmentfrom the middle link segments is chosen for that purpose.
OverLongestSegment | The text follows the longest link segment and is displayed centered at the segment's middle point.
Rotate | The text is displayed rotated at the same angle as the segment where the text is placed. A long enough segmentfrom the middle link segments is chosen for that purpose.

See Also


MindFusion.Diagramming.MagnifyBehavior Class

MagnifyBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.Magnify.

Namespace: MindFusion.Diagramming
Assembly: MagnifyBehavior.js

Syntax

JavaScript [image] Copy Code

// class
MagnifyBehavior.prototype = {}

Inheritance Hierarchy

See Also

MagnifyBehavior Members


MindFusion.Diagramming.MagnifyBehavior Members

MagnifyBehavior Members
Constructors Methods
[image]

This class is used when the diagram behavior is set to Behavior.Magnify.

The following tables list the members exposed by the MagnifyBehavior type.

Public Constructors

Name | Description
MagnifyBehavior | Initializes a new instance of the MagnifyBehavior class.

Public Methods

Name | Description
onMouseDown | BehaviorBase.onMouseDown override.
onMouseMove | BehaviorBase.onMouseMove override.
onMouseUp | BehaviorBase.onMouseUp override.

See Also

MagnifyBehavior Class


MindFusion.Diagramming.MagnifyBehavior Constructor

MagnifyBehavior Constructor
[image]

Initializes a new instance of the MagnifyBehavior class.

Namespace: MindFusion.Diagramming
Assembly: MagnifyBehavior.js

Syntax

JavaScript [image] Copy Code

function MagnifyBehavior (parent)

Parameters

parent

The Diagram this behavior will be associated with.

See Also

MagnifyBehavior Class


MindFusion.Diagramming.MagnifyBehavior Methods

MagnifyBehavior Methods
[image]

Public Methods

Name | Description
onMouseDown | BehaviorBase.onMouseDown override.
onMouseMove | BehaviorBase.onMouseMove override.
onMouseUp | BehaviorBase.onMouseUp override.

See Also

MagnifyBehavior Class


MindFusion.Diagramming.MagnifyBehavior.onMouseDown Method

MagnifyBehavior.onMouseDown Method
[image]

BehaviorBase.onMouseDown override.

Namespace: MindFusion.Diagramming
Assembly: MagnifyBehavior.js

Syntax

JavaScript [image] Copy Code

function onMouseDown (e)

Parameters

e

A MouseButtonEventArgs that contains the event data.

See Also

MagnifyBehavior Members
MagnifyBehavior Class


MindFusion.Diagramming.MagnifyBehavior.onMouseMove Method

MagnifyBehavior.onMouseMove Method
[image]

BehaviorBase.onMouseMove override.

Namespace: MindFusion.Diagramming
Assembly: MagnifyBehavior.js

Syntax

JavaScript [image] Copy Code

function onMouseMove (e)

Parameters

e

A MouseEventArgs that contains the event data.

See Also

MagnifyBehavior Members
MagnifyBehavior Class


MindFusion.Diagramming.MagnifyBehavior.onMouseUp Method

MagnifyBehavior.onMouseUp Method
[image]

BehaviorBase.onMouseUp override.

Namespace: MindFusion.Diagramming
Assembly: MagnifyBehavior.js

Syntax

JavaScript [image] Copy Code

function onMouseUp (e)

Parameters

e

A MouseButtonEventArgs that contains the event data.

See Also

MagnifyBehavior Members
MagnifyBehavior Class


MindFusion.Diagramming.Manipulator Class

Manipulator Class
[image]

Manipulator is an abstract base class which defines the behavior of miscellaneous UI widgets attached to nodes.

Namespace: MindFusion.Diagramming
Assembly: Manipulator.js

Syntax

JavaScript [image] Copy Code

// class
Manipulator.prototype = {}

Inheritance Hierarchy

See Also

Manipulator Members


MindFusion.Diagramming.Manipulator Members

Manipulator Members
Constructors
[image]

Manipulator is an abstract base class which defines the behavior of miscellaneous UI widgets attached to nodes.

The following tables list the members exposed by the Manipulator type.

Public Constructors

Name | Description
Manipulator | Initializes a new instance of the Manipulator class.

See Also

Manipulator Class


MindFusion.Diagramming.Manipulator Constructor

Manipulator Constructor
[image]

Initializes a new instance of the Manipulator class.

Namespace: MindFusion.Diagramming
Assembly: Manipulator.js

Syntax

JavaScript [image] Copy Code

function Manipulator ([node])

Parameters

node
Optional.

The DiagramNode containing this manipulator.

See Also

Manipulator Class


MindFusion.Diagramming.MarkStyle Enumeration

MarkStyle Enumeration
[image]

Specifies the visual style of anchor point marks.

Namespace: MindFusion.Diagramming
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
MarkStyle = {}

Members

Member name | Description
Circle | Anchor point marked with a circle.
Cross | Anchor point marked with a cross.
None | No visual indication for the anchor point.
Rectangle | Anchor point marked with a rectangle.
X | Anchor point marked with an 'X'.

See Also


MindFusion.Diagramming.ModificationStart Enumeration

ModificationStart Enumeration
[image]

Specifies how the user can start modifying an item.

Namespace: MindFusion.Diagramming
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
ModificationStart = {}

Members

Member name | Description
AutoHandles | Adjustment handles appear automatically around the object under the mouse; it can be modified without selecting it first.
SelectedOnly | Only selected objects can be modified.

See Also


MindFusion.Diagramming.ModifierKeyAction Enumeration

ModifierKeyAction Enumeration
[image]

Defines the actions that can be assigned to a modifier key such as CTRL or ALT.

Namespace: MindFusion.Diagramming
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
ModifierKeyAction = {}

Members

Member name | Description
Magnify | Magnifies the diagram objects under the mouse while the modifier key is pressed down.
None | Specifies that a modifier key does not have any specific function assigned to it.
OverrideBehavior | While the modifier key is pressed down, dragging the mouse starts creating a new item or drawing a selection rectangle instead of modifying a selected item. Otherwise, dragging the mouse could start modification of the selected item.
Pan | Pan the view if the mouse is dragged while the modifier key is pressed down.
Select | Start drawing a selection rectangle if the mouse is dragged while a modifier key is pressed down. Toggle the selection if an item is clicked while the key is down.

Remarks

The values from this enumeration can be assigned to the members of the diagram's ModifierKeyActions.

See Also


MindFusion.Diagramming.ModifierKeyActions Class

ModifierKeyActions Class
Remarks See Also
[image]

Maps keyboard modifier keys to special actions in MindFusion.Diagramming such as panning and drawing selection rectangle.

Namespace: MindFusion.Diagramming
Assembly: ModifierKeyActions.js

Syntax

JavaScript [image] Copy Code

// class
ModifierKeyActions.prototype = {}

Remarks

The ModifierKeyActions property of Diagram returns an object from this class, letting you specify the modifier key functions for each Diagram instance.

Assign member of the ModifierKeyAction enumeration to the Alt, Control and Shift properties to specify what function is assigned to the ALT, CTRL and SHIFT keys.

Inheritance Hierarchy

See Also

ModifierKeyActions Members


MindFusion.Diagramming.ModifierKeyActions Members

ModifierKeyActions Members
Constructors Methods
[image]

Maps keyboard modifier keys to special actions in MindFusion.Diagramming such as panning and drawing selection rectangle.

The following tables list the members exposed by the ModifierKeyActions type.

Public Constructors

Name | Description
ModifierKeyActions | Initializes a new instance of the ModifierKeyActions class.

Public Methods

Name | Description
getAlt | Gets the action triggered by the ALT key.
getControl | Gets the action triggered by the CTRL key.
getShift | Gets the action triggered by the SHIFT key.
setAlt | Sets the action triggered by the ALT key.
setControl | Sets the action triggered by the CTRL key.
setShift | Sets the action triggered by the SHIFT key.

See Also

ModifierKeyActions Class


MindFusion.Diagramming.ModifierKeyActions Constructor

ModifierKeyActions Constructor
[image]

Initializes a new instance of the ModifierKeyActions class.

Namespace: MindFusion.Diagramming
Assembly: ModifierKeyActions.js

Syntax

JavaScript [image] Copy Code

function ModifierKeyActions ()

See Also

ModifierKeyActions Class


MindFusion.Diagramming.ModifierKeyActions Methods

ModifierKeyActions Methods
[image]

Public Methods

Name | Description
getAlt | Gets the action triggered by the ALT key.
getControl | Gets the action triggered by the CTRL key.
getShift | Gets the action triggered by the SHIFT key.
setAlt | Sets the action triggered by the ALT key.
setControl | Sets the action triggered by the CTRL key.
setShift | Sets the action triggered by the SHIFT key.

See Also

ModifierKeyActions Class


MindFusion.Diagramming.ModifierKeyActions.getAlt Method

ModifierKeyActions.getAlt Method
[image]

Gets the action triggered by the ALT key.

Namespace: MindFusion.Diagramming
Assembly: ModifierKeyActions.js

Syntax

JavaScript [image] Copy Code

function getAlt ()

Return Value

A member of the ModifierKeyAction enumeration.

See Also

ModifierKeyActions Members
ModifierKeyActions Class


MindFusion.Diagramming.ModifierKeyActions.getControl Method

ModifierKeyActions.getControl Method
[image]

Gets the action triggered by the CTRL key.

Namespace: MindFusion.Diagramming
Assembly: ModifierKeyActions.js

Syntax

JavaScript [image] Copy Code

function getControl ()

Return Value

A member of the ModifierKeyAction enumeration.

See Also

ModifierKeyActions Members
ModifierKeyActions Class


MindFusion.Diagramming.ModifierKeyActions.getShift Method

ModifierKeyActions.getShift Method
[image]

Gets the action triggered by the SHIFT key.

Namespace: MindFusion.Diagramming
Assembly: ModifierKeyActions.js

Syntax

JavaScript [image] Copy Code

function getShift ()

Return Value

A member of the ModifierKeyAction enumeration.

See Also

ModifierKeyActions Members
ModifierKeyActions Class


MindFusion.Diagramming.ModifierKeyActions.setAlt Method

ModifierKeyActions.setAlt Method
[image]

Sets the action triggered by the ALT key.

Namespace: MindFusion.Diagramming
Assembly: ModifierKeyActions.js

Syntax

JavaScript [image] Copy Code

function setAlt (value)

Parameters

value

A member of the ModifierKeyAction enumeration. The default is Pan.

Remarks

The value of this property specifies what happens when a user holds down the ALT key and drags the mouse. The default value Pan makes the control enter pan mode, letting the user scroll the diagram contents by dragging it with the mouse. You can change the function of ALT by assigning a different value to this property.

See Also

ModifierKeyActions Members
ModifierKeyActions Class


MindFusion.Diagramming.ModifierKeyActions.setControl Method

ModifierKeyActions.setControl Method
[image]

Sets the action triggered by the CTRL key.

Namespace: MindFusion.Diagramming
Assembly: ModifierKeyActions.js

Syntax

JavaScript [image] Copy Code

function setControl (value)

Parameters

value

A member of the ModifierKeyAction enumeration. The default is Select.

Remarks

The value of this property specifies what happens when a user holds down the CTRL key and drags the mouse. The default value Select makes the control enter selection mode, letting the user draw a lasso rectangle around diagram items in order to select them. You can change the function of CTRL by assigning a different value to this property.

See Also

ModifierKeyActions Members
ModifierKeyActions Class


MindFusion.Diagramming.ModifierKeyActions.setShift Method

ModifierKeyActions.setShift Method
[image]

Sets the action triggered by the SHIFT key.

Namespace: MindFusion.Diagramming
Assembly: ModifierKeyActions.js

Syntax

JavaScript [image] Copy Code

function setShift (value)

Parameters

value

A member of the ModifierKeyAction enumeration. The default value is OverrideBehavior.

Remarks

The value of this property specifies what happens when a user holds down the SHIFT key and drags the mouse. The default value OverrideBehavior makes the control ignore item's selection handles, thus not allowing modifying a selected item but starts the creation of a new item. You can change the function of SHIFT by assigning a different value to this property.

See Also

ModifierKeyActions Members
ModifierKeyActions Class


MindFusion.Diagramming.ModifyBehavior Class

ModifyBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.Modify.

Namespace: MindFusion.Diagramming
Assembly: ModifyBehavior.js

Syntax

JavaScript [image] Copy Code

// class
ModifyBehavior.prototype = {}

Inheritance Hierarchy

See Also

ModifyBehavior Members


MindFusion.Diagramming.ModifyBehavior Members

ModifyBehavior Members
Constructors Methods
[image]

This class is used when the diagram behavior is set to Behavior.Modify.

The following tables list the members exposed by the ModifyBehavior type.

Public Constructors

Name | Description
ModifyBehavior | Initializes a new instance of the ModifyBehavior class.

Public Methods

Name | Description
startDraw | BehaviorBase.startDraw override.

See Also

ModifyBehavior Class


MindFusion.Diagramming.ModifyBehavior Constructor

ModifyBehavior Constructor
[image]

Initializes a new instance of the ModifyBehavior class.

Namespace: MindFusion.Diagramming
Assembly: ModifyBehavior.js

Syntax

JavaScript [image] Copy Code

function ModifyBehavior (parent)

Parameters

parent

The Diagram this behavior will be associated with.

See Also

ModifyBehavior Class


MindFusion.Diagramming.ModifyBehavior Methods

ModifyBehavior Methods
[image]

Public Methods

Name | Description
startDraw | BehaviorBase.startDraw override.

See Also

ModifyBehavior Class


MindFusion.Diagramming.ModifyBehavior.startDraw Method

ModifyBehavior.startDraw Method
[image]

BehaviorBase.startDraw override.

Namespace: MindFusion.Diagramming
Assembly: ModifyBehavior.js

Syntax

JavaScript [image] Copy Code

function startDraw (point)

Parameters

point

A Point structure, which specifies the current position of the mouse cursor, in document coordinates.

Return Value

An instance of the InteractionState class.

See Also

ModifyBehavior Members
ModifyBehavior Class


MindFusion.Diagramming.MouseButtonActions Enumeration

MouseButtonActions Enumeration
[image]

Specifies what actions can be associated with the middle and right mouse buttons.

Namespace: MindFusion.Diagramming
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
MouseButtonActions = {}

Members

Member name | Description
Cancel | Cancels the current drawing operation.
Draw | Draw new items or modify existing items.
Magnify | Magnifies the items under the mouse while the button is pressed down.
None | Do not associate any action with the button.
Pan | Pans the view if the mouse is dragged while the button is pressed down.
Select | Starts a multiple selection operation.

See Also


MindFusion.Diagramming.NodeEventArgs Class

NodeEventArgs Class
[image]

Contains the arguments passed to handlers of node-related events.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

// class
NodeEventArgs.prototype = {}

Inheritance Hierarchy

See Also

NodeEventArgs Members


MindFusion.Diagramming.NodeEventArgs Members

NodeEventArgs Members
Constructors Methods
[image]

Contains the arguments passed to handlers of node-related events.

The following tables list the members exposed by the NodeEventArgs type.

Public Constructors

Name | Description
NodeEventArgs | Overloaded.

Public Methods

Name | Description
cancelDrag | Immediately cancels the creation or modification of the node.
getAdjustmentHandle | Gets the adjustment handle being moved by the user.
getCancel | Gets a value indicating whether to allow the current operation.
getContainer | Gets the container a node has been added to or removed from.
getMouseButton | Gets which mouse button has been pressed.
getMousePosition | Gets the current mouse pointer position.
getNewText | Gets the text that has just been entered by the user.
getNode | Gets the node for which the event was raised.
getOldText | Gets the text that had been displayed in the node before the user edited it.
setCancel | Sets a value indicating whether to allow the current operation.

See Also

NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs Constructor

NodeEventArgs Constructor
[image]

Overload List

Name | Description
NodeEventArgs () | Initializes a new instance of the NodeEventArgs class.
NodeEventArgs (Object) | Initializes a new instance of the NodeEventArgs class.

See Also

NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs Constructor ()

NodeEventArgs Constructor ()
See Also
[image]

Initializes a new instance of the NodeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function NodeEventArgs ()

See Also

NodeEventArgs Constructor Overload List
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs Constructor (Object)

NodeEventArgs Constructor (Object)
See Also
[image]

Initializes a new instance of the NodeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function NodeEventArgs (args)

Parameters

args

See Also

NodeEventArgs Constructor Overload List
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs Methods

NodeEventArgs Methods
[image]

Public Methods

Name | Description
cancelDrag | Immediately cancels the creation or modification of the node.
getAdjustmentHandle | Gets the adjustment handle being moved by the user.
getCancel | Gets a value indicating whether to allow the current operation.
getContainer | Gets the container a node has been added to or removed from.
getMouseButton | Gets which mouse button has been pressed.
getMousePosition | Gets the current mouse pointer position.
getNewText | Gets the text that has just been entered by the user.
getNode | Gets the node for which the event was raised.
getOldText | Gets the text that had been displayed in the node before the user edited it.
setCancel | Sets a value indicating whether to allow the current operation.

See Also

NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs.cancelDrag Method

NodeEventArgs.cancelDrag Method
[image]

Immediately cancels the creation or modification of the node.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function cancelDrag ()

See Also

NodeEventArgs Members
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs.getAdjustmentHandle Method

NodeEventArgs.getAdjustmentHandle Method
[image]

Gets the adjustment handle being moved by the user.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getAdjustmentHandle ()

Return Value

One of the AdjustmentHandles enumeration values.

See Also

NodeEventArgs Members
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs.getCancel Method

NodeEventArgs.getCancel Method
[image]

Gets a value indicating whether to allow the current operation.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getCancel ()

Return Value

true if the current operation is allowed; otherwise, false.

See Also

NodeEventArgs Members
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs.getContainer Method

NodeEventArgs.getContainer Method
[image]

Gets the container a node has been added to or removed from.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getContainer ()

Return Value

A ContainerNode instance.

See Also

NodeEventArgs Members
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs.getMouseButton Method

NodeEventArgs.getMouseButton Method
[image]

Gets which mouse button has been pressed.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getMouseButton ()

Return Value

One of the MouseButton enumeration values.

See Also

NodeEventArgs Members
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs.getMousePosition Method

NodeEventArgs.getMousePosition Method
[image]

Gets the current mouse pointer position.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getMousePosition ()

Return Value

A Point instance.

See Also

NodeEventArgs Members
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs.getNewText Method

NodeEventArgs.getNewText Method
[image]

Gets the text that has just been entered by the user.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getNewText ()

Return Value

A string specifying the new text of the node.

See Also

NodeEventArgs Members
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs.getNode Method

NodeEventArgs.getNode Method
[image]

Gets the node for which the event was raised.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getNode ()

Return Value

An instance of the DiagramNode class.

See Also

NodeEventArgs Members
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs.getOldText Method

NodeEventArgs.getOldText Method
[image]

Gets the text that had been displayed in the node before the user edited it.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getOldText ()

Return Value

A string specifying the old text of the node.

See Also

NodeEventArgs Members
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs.setCancel Method

NodeEventArgs.setCancel Method
[image]

Sets a value indicating whether to allow the current operation.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function setCancel (value)

Parameters

value

true to allow the current operation; otherwise, false.

See Also

NodeEventArgs Members
NodeEventArgs Class


MindFusion.Diagramming.NodeListView Class

NodeListView Class
[image]

ListBox control with support for hosting DiagramNodes and dragging them to the Diagram control. Items' labels can be set by assigning them to the Tag property of nodes.

Namespace: MindFusion.Diagramming
Assembly: NodeListView.js

Syntax

JavaScript [image] Copy Code

// class
NodeListView.prototype = {}

Inheritance Hierarchy

See Also

NodeListView Members


MindFusion.Diagramming.NodeListView Members

NodeListView Members
Constructors Methods
[image]

ListBox control with support for hosting DiagramNodes and dragging them to the Diagram control. Items' labels can be set by assigning them to the Tag property of nodes.

The following tables list the members exposed by the NodeListView type.

Public Constructors

Name | Description
NodeListView | Creates an instance of NodeListView

Public Methods

Name | Description
addEventListener | Registers a single event listener on the NodeListView.
addNode | Adds a node to the NodeListView.
clearAll | Removes all items from the NodeListView.
create | Creates and initializes a new NodeListView from the specified element. This method is static and can be called without creating an instance of the class.
find | Returns the specified NodeListView object. This member is static and can be invoked without creating an instance of the class.
getDefaultNodeSize | Gets the default size of the nodes in the list view.
getEnabled | Checks if mouse events are enabled.
getIconSize | Gets the default size of the nodes in the list view.
getNodeAt | Gets the item at the specified location.
getNodes | Gets an array with all DiagramNode-s in this NodeListView.
getOrientation | Gets the orientation of the nodes' layout.
getPadding | Gets the space between the NodeListView control and its contents.
getShapeLibraryLocation | Gets the location of a shape library file containing custom shape definitions.It can be set to a full URL of the file, or a relative file path.
registerForSubmit | Registers an onsubmit handler for the NodeListView's parent html form to flush postback data.
selectItem | Selects the specified item.
setDefaultNodeSize | Sets the default size of the nodes in the list view.
setEnabled | Enables or disables handling of mouse events.
setIconSize | Sets the default size of the icons in the list view.
setOrientation | Sets the orientation of the nodes' layout.
setPadding | Sets the space between the NodeListView control and its contents.
setShapeLibraryLocation | Sets the location of a shape library file containing custom shape definitions.It can be set to a full URL of the file, or a relative file path.

See Also

NodeListView Class


MindFusion.Diagramming.NodeListView Constructor

NodeListView Constructor
[image]

Creates an instance of NodeListView

Namespace: MindFusion.Diagramming
Assembly: NodeListView.js

Syntax

JavaScript [image] Copy Code

function NodeListView (element)

Parameters

element
The Canvas DOM Element this NodeListView is associated with.

See Also

NodeListView Class


MindFusion.Diagramming.NodeListView Methods

NodeListView Methods
[image]

Public Methods

Name | Description
addEventListener | Registers a single event listener on the NodeListView.
addNode | Adds a node to the NodeListView.
clearAll | Removes all items from the NodeListView.
create | Creates and initializes a new NodeListView from the specified element. This method is static and can be called without creating an instance of the class.
find | Returns the specified NodeListView object. This member is static and can be invoked without creating an instance of the class.
getDefaultNodeSize | Gets the default size of the nodes in the list view.
getEnabled | Checks if mouse events are enabled.
getIconSize | Gets the default size of the nodes in the list view.
getNodeAt | Gets the item at the specified location.
getNodes | Gets an array with all DiagramNode-s in this NodeListView.
getOrientation | Gets the orientation of the nodes' layout.
getPadding | Gets the space between the NodeListView control and its contents.
getShapeLibraryLocation | Gets the location of a shape library file containing custom shape definitions.It can be set to a full URL of the file, or a relative file path.
registerForSubmit | Registers an onsubmit handler for the NodeListView's parent html form to flush postback data.
selectItem | Selects the specified item.
setDefaultNodeSize | Sets the default size of the nodes in the list view.
setEnabled | Enables or disables handling of mouse events.
setIconSize | Sets the default size of the icons in the list view.
setOrientation | Sets the orientation of the nodes' layout.
setPadding | Sets the space between the NodeListView control and its contents.
setShapeLibraryLocation | Sets the location of a shape library file containing custom shape definitions.It can be set to a full URL of the file, or a relative file path.

See Also

NodeListView Class


MindFusion.Diagramming.NodeListView.addEventListener Method

NodeListView.addEventListener Method
[image]

Registers a single event listener on the NodeListView.

Namespace: MindFusion.Diagramming
Assembly: NodeListView.js

Syntax

JavaScript [image] Copy Code

function addEventListener (eventName, handler)

Parameters

eventName

The name of the event. Currently supported events are controlLoaded and nodeSelected.

handler

Represents the method that will handle the event specified with eventName.

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.addNode Method

NodeListView.addNode Method
[image]

Adds a node to the NodeListView.

Namespace: MindFusion.Diagramming
Assembly: NodeListView.js

Syntax

JavaScript [image] Copy Code

function addNode (node, [caption])

Parameters

node

The node to add.

caption
Optional.

The caption to display for the node.

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.clearAll Method

NodeListView.clearAll Method
[image]

Removes all items from the NodeListView.

Namespace: MindFusion.Diagramming
Assembly: NodeListView.js

Syntax

JavaScript [image] Copy Code

function clearAll ()

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.create Method

NodeListView.create Method
[image]

Creates and initializes a new NodeListView from the specified element. This method is static and can be called without creating an instance of the class.

Namespace: MindFusion.Diagramming
Assembly: NodeListView.js

Syntax

JavaScript [image] Copy Code

function create (element)

Parameters

element

The DOM element that the NodeListView should be attached to.

Return Value

A NodeListView object that represents the newly created list view.

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.find Method

NodeListView.find Method
[image]

Returns the specified NodeListView object. This member is static and can be invoked without creating an instance of the class.

Namespace: MindFusion.Diagramming
Assembly: NodeListView.js

Syntax

JavaScript [image] Copy Code

function find (id, [parent])

Parameters

id

A string that contains the ID of the nodeListView to find.

parent
Optional.

The component or element that contains the nodeListView to find.

Return Value

A NodeListView object that contains the nodeListView requested by id, if found; otherwise, null.

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.getDefaultNodeSize Method

NodeListView.getDefaultNodeSize Method
[image]

Gets the default size of the nodes in the list view.

Namespace: MindFusion.Diagramming
Assembly: NodeListView.js

Syntax

JavaScript [image] Copy Code

function getDefaultNodeSize ()

Return Value

The size.

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.getEnabled Method

NodeListView.getEnabled Method
[image]

Checks if mouse events are enabled.

Namespace: MindFusion.Diagramming
Assembly: NodeListView.js

Syntax

JavaScript [image] Copy Code

function getEnabled ()

Return Value

true if handling of mouse events is enabled; otherwise, false.

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.getIconSize Method

NodeListView.getIconSize Method
[image]

Gets the default size of the nodes in the list view.

Namespace: MindFusion.Diagramming
Assembly: NodeListView.js

Syntax

JavaScript [image] Copy Code

function getIconSize ()

Return Value

The size.

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.getNodeAt Method

NodeListView.getNodeAt Method
[image]

Gets the item at the specified location.

Namespace: MindFusion.Diagramming
Assembly: NodeListView.js

Syntax

JavaScript [image] Copy Code

function getNodeAt (point)

Parameters

point

The location where to look.

Return Value

The item found.

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.getNodes Method

NodeListView.getNodes Method
[image]

Gets an array with all DiagramNode-s in this NodeListView.

Namespace: MindFusion.Diagramming
Assembly: NodeListView.js

Syntax

JavaScript [image] Copy Code

function getNodes ()

Return Value

an array of all DiagramNode-s in this NodeListView.

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.getOrientation Method

NodeListView.getOrientation Method
[image]

Gets the orientation of the nodes' layout.

Namespace: MindFusion.Diagramming
Assembly: NodeListView.js

Syntax

JavaScript [image] Copy Code

function getOrientation ()

Return Value

The orientation.

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.getPadding Method

NodeListView.getPadding Method
[image]

Gets the space between the NodeListView control and its contents.

Namespace: MindFusion.Diagramming
Assembly: NodeListView.js

Syntax

JavaScript [image] Copy Code

function getPadding ()

Return Value

he Padding that specifies the space between the NodeListView control and its contents.

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.getShapeLibraryLocation Method

NodeListView.getShapeLibraryLocation Method
[image]

Gets the location of a shape library file containing custom shape definitions.It can be set to a full URL of the file, or a relative file path.

Namespace: MindFusion.Diagramming
Assembly: NodeListView.js

Syntax

JavaScript [image] Copy Code

function getShapeLibraryLocation ()

Return Value

The location of a shape library file containing custom shape definitions.

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.registerForSubmit Method

NodeListView.registerForSubmit Method
[image]

Registers an onsubmit handler for the NodeListView's parent html form to flush postback data.

Namespace: MindFusion.Diagramming
Assembly: NodeListView.js

Syntax

JavaScript [image] Copy Code

function registerForSubmit (id)

Parameters

id

The id of the hidden field to flush the data to.

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.selectItem Method

NodeListView.selectItem Method
[image]

Selects the specified item.

Namespace: MindFusion.Diagramming
Assembly: NodeListView.js

Syntax

JavaScript [image] Copy Code

function selectItem (item)

Parameters

item

The item to select.

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.setDefaultNodeSize Method

NodeListView.setDefaultNodeSize Method
[image]

Sets the default size of the nodes in the list view.

Namespace: MindFusion.Diagramming
Assembly: NodeListView.js

Syntax

JavaScript [image] Copy Code

function setDefaultNodeSize (value)

Parameters

value

The size.

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.setEnabled Method

NodeListView.setEnabled Method
[image]

Enables or disables handling of mouse events.

Namespace: MindFusion.Diagramming
Assembly: NodeListView.js

Syntax

JavaScript [image] Copy Code

function setEnabled (value)

Parameters

value

true if handling of mouse events is enabled; otherwise, false.

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.setIconSize Method

NodeListView.setIconSize Method
[image]

Sets the default size of the icons in the list view.

Namespace: MindFusion.Diagramming
Assembly: NodeListView.js

Syntax

JavaScript [image] Copy Code

function setIconSize (value)

Parameters

value

The size.

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.setOrientation Method

NodeListView.setOrientation Method
[image]

Sets the orientation of the nodes' layout.

Namespace: MindFusion.Diagramming
Assembly: NodeListView.js

Syntax

JavaScript [image] Copy Code

function setOrientation (value)

Parameters

value

The orientation.

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.setPadding Method

NodeListView.setPadding Method
[image]

Sets the space between the NodeListView control and its contents.

Namespace: MindFusion.Diagramming
Assembly: NodeListView.js

Syntax

JavaScript [image] Copy Code

function setPadding (value)

Parameters

value
The Padding that specifies the space between the NodeListView control and its contents.

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.setShapeLibraryLocation Method

NodeListView.setShapeLibraryLocation Method
[image]

Sets the location of a shape library file containing custom shape definitions.It can be set to a full URL of the file, or a relative file path.

Namespace: MindFusion.Diagramming
Assembly: NodeListView.js

Syntax

JavaScript [image] Copy Code

function setShapeLibraryLocation (value)

Parameters

value

The location of a shape library file containing custom shape definitions.

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.Overview Class

Overview Class
Remarks See Also
[image]

The Overview control provides a scaled-down view of a Diagram contents and allows scrolling and zooming the diagram with the mouse.

Namespace: MindFusion.Diagramming
Assembly: Overview.js

Syntax

JavaScript [image] Copy Code

// class
Overview.prototype = {}

Remarks

To specify which Diagram instance is shown in the overview, use the setDiagram method. Currently the whole diagram fits into the control.

Inheritance Hierarchy

See Also

Overview Members


MindFusion.Diagramming.Overview Members

Overview Members
Constructors Methods
[image]

The Overview control provides a scaled-down view of a Diagram contents and allows scrolling and zooming the diagram with the mouse.

The following tables list the members exposed by the Overview type.

Public Constructors

Name | Description
Overview | Initializes a new instance of the Overview class.

Public Methods

Name | Description
create | Creates and initializes a new Overview from the specified element. This method is static and can be called without creating an instance of the class.
find | Returns the specified Overview object. This member is static and can be invoked without creating an instance of the class.
getEnabled | Checks if mouse events are enabled.
registerForSubmit | Registers an onsubmit handler for the Overview's parent html form to flush postback data.
setDiagram | Sets the Diagram shown by this Overview.
setEnabled | Enables or disables handling of mouse events.

See Also

Overview Class


MindFusion.Diagramming.Overview Constructor

Overview Constructor
[image]

Initializes a new instance of the Overview class.

Namespace: MindFusion.Diagramming
Assembly: Overview.js

Syntax

JavaScript [image] Copy Code

function Overview (element)

Parameters

element
The Canvas DOM Element this Diagram is associated with.

See Also

Overview Class


MindFusion.Diagramming.Overview Methods

Overview Methods
[image]

Public Methods

Name | Description
create | Creates and initializes a new Overview from the specified element. This method is static and can be called without creating an instance of the class.
find | Returns the specified Overview object. This member is static and can be invoked without creating an instance of the class.
getEnabled | Checks if mouse events are enabled.
registerForSubmit | Registers an onsubmit handler for the Overview's parent html form to flush postback data.
setDiagram | Sets the Diagram shown by this Overview.
setEnabled | Enables or disables handling of mouse events.

See Also

Overview Class


MindFusion.Diagramming.Overview.create Method

Overview.create Method
[image]

Creates and initializes a new Overview from the specified element. This method is static and can be called without creating an instance of the class.

Namespace: MindFusion.Diagramming
Assembly: Overview.js

Syntax

JavaScript [image] Copy Code

function create (element)

Parameters

element

The DOM element that the overview should be attached to.

Return Value

A Overview object that represents the newly created overview.

See Also

Overview Members
Overview Class


MindFusion.Diagramming.Overview.find Method

Overview.find Method
[image]

Returns the specified Overview object. This member is static and can be invoked without creating an instance of the class.

Namespace: MindFusion.Diagramming
Assembly: Overview.js

Syntax

JavaScript [image] Copy Code

function find (id, [parent])

Parameters

id

A string that contains the ID of the overview to find.

parent
Optional.

The component or element that contains the overview to find.

Return Value

An Overview object that contains the overview requested by id if found, or null otherwise.

See Also

Overview Members
Overview Class


MindFusion.Diagramming.Overview.getEnabled Method

Overview.getEnabled Method
[image]

Checks if mouse events are enabled.

Namespace: MindFusion.Diagramming
Assembly: Overview.js

Syntax

JavaScript [image] Copy Code

function getEnabled ()

Return Value

true if handling of mouse events is enabled; otherwise, false.

See Also

Overview Members
Overview Class


MindFusion.Diagramming.Overview.registerForSubmit Method

Overview.registerForSubmit Method
[image]

Registers an onsubmit handler for the Overview's parent html form to flush postback data.

Namespace: MindFusion.Diagramming
Assembly: Overview.js

Syntax

JavaScript [image] Copy Code

function registerForSubmit (id)

Parameters

id

The id of the hidden field to flush the data to.

See Also

Overview Members
Overview Class


MindFusion.Diagramming.Overview.setDiagram Method

Overview.setDiagram Method
[image]

Sets the Diagram shown by this Overview.

Namespace: MindFusion.Diagramming
Assembly: Overview.js

Syntax

JavaScript [image] Copy Code

function setDiagram ([diagram])

Parameters

diagram
Optional. The Diagram shown by the overview.

Remarks

The overview control needs a Diagram reference to present the diagram in overview mode.

See Also

Overview Members
Overview Class


MindFusion.Diagramming.Overview.setEnabled Method

Overview.setEnabled Method
[image]

Enables or disables handling of mouse events.

Namespace: MindFusion.Diagramming
Assembly: Overview.js

Syntax

JavaScript [image] Copy Code

function setEnabled (value)

Parameters

value

true if handling of mouse events is enabled; otherwise, false.

See Also

Overview Members
Overview Class


MindFusion.Diagramming.PanBehavior Class

PanBehavior Class
[image]

Pans the diagram when the users drags the mouse.

Namespace: MindFusion.Diagramming
Assembly: PanBehavior.js

Syntax

JavaScript [image] Copy Code

// class
PanBehavior.prototype = {}

Inheritance Hierarchy

See Also

PanBehavior Members


MindFusion.Diagramming.PanBehavior Members

PanBehavior Members
Constructors Methods
[image]

Pans the diagram when the users drags the mouse.

The following tables list the members exposed by the PanBehavior type.

Public Constructors

Name | Description
PanBehavior | Initializes a new instance of the PanBehavior class.

Public Methods

Name | Description
onMouseDown | Overrides Interaction.OnMouseDown.
onMouseMove | Raises the MouseMove event.
onMouseUp | Interaction.OnMouseUp override.

See Also

PanBehavior Class


MindFusion.Diagramming.PanBehavior Constructor

PanBehavior Constructor
[image]

Initializes a new instance of the PanBehavior class.

Namespace: MindFusion.Diagramming
Assembly: PanBehavior.js

Syntax

JavaScript [image] Copy Code

function PanBehavior (parent)

Parameters

parent

The Diagram this behavior will be associated with.

See Also

PanBehavior Class


MindFusion.Diagramming.PanBehavior Methods

PanBehavior Methods
[image]

Public Methods

Name | Description
onMouseDown | Overrides Interaction.OnMouseDown.
onMouseMove | Raises the MouseMove event.
onMouseUp | Interaction.OnMouseUp override.

See Also

PanBehavior Class


MindFusion.Diagramming.PanBehavior.onMouseDown Method

PanBehavior.onMouseDown Method
[image]

Overrides Interaction.OnMouseDown.

Namespace: MindFusion.Diagramming
Assembly: PanBehavior.js

Syntax

JavaScript [image] Copy Code

function onMouseDown (e)

Parameters

e

A MouseButtonEventArgs that contains the event data.

See Also

PanBehavior Members
PanBehavior Class


MindFusion.Diagramming.PanBehavior.onMouseMove Method

PanBehavior.onMouseMove Method
[image]

Raises the MouseMove event.

Namespace: MindFusion.Diagramming
Assembly: PanBehavior.js

Syntax

JavaScript [image] Copy Code

function onMouseMove (e)

Parameters

e

A MouseEventArgs that contains the event data.

See Also

PanBehavior Members
PanBehavior Class


MindFusion.Diagramming.PanBehavior.onMouseUp Method

PanBehavior.onMouseUp Method
[image]

Interaction.OnMouseUp override.

Namespace: MindFusion.Diagramming
Assembly: PanBehavior.js

Syntax

JavaScript [image] Copy Code

function onMouseUp (e)

Parameters

e

A MouseButtonEventArgs that contains the event data.

See Also

PanBehavior Members
PanBehavior Class


MindFusion.Diagramming.RelativeToLink Enumeration

RelativeToLink Enumeration
[image]

Specifies how the link labels are positioned.

Namespace: MindFusion.Diagramming
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
RelativeToLink = {}

Members

Member name | Description
ControlPoint | The link labels are positioned relative to a specified control point.
LinkLength | The link labels are positioned relative to the link.
Segment | The link labels are positioned relative to a specified segment.

See Also


MindFusion.Diagramming.RemoveItemCommand Class

RemoveItemCommand Class
[image]

Implements deletion of diagram items.

Namespace: MindFusion.Diagramming
Assembly: RemoveItemCommand.js

Syntax

JavaScript [image] Copy Code

// class
RemoveItemCommand.prototype = {}

Inheritance Hierarchy

See Also

RemoveItemCommand Members


MindFusion.Diagramming.RemoveItemCommand Members

RemoveItemCommand Members
Constructors Methods
[image]

Implements deletion of diagram items.

The following tables list the members exposed by the RemoveItemCommand type.

Public Constructors

Name | Description
RemoveItemCommand | Initializes a new instance of the RemoveItemCommand class.

Public Methods

Name | Description
execute | Command.execute override.
redo | Command.redo override.
undo | Command.undo override.

See Also

RemoveItemCommand Class


MindFusion.Diagramming.RemoveItemCommand Constructor

RemoveItemCommand Constructor
[image]

Initializes a new instance of the RemoveItemCommand class.

Namespace: MindFusion.Diagramming
Assembly: RemoveItemCommand.js

Syntax

JavaScript [image] Copy Code

function RemoveItemCommand (diagram, item)

Parameters

diagram

The Diagram modified by this command.

item

A DiagramItem that should be removed from the Diagram.

See Also

RemoveItemCommand Class


MindFusion.Diagramming.RemoveItemCommand Methods

RemoveItemCommand Methods
[image]

Public Methods

Name | Description
execute | Command.execute override.
redo | Command.redo override.
undo | Command.undo override.

See Also

RemoveItemCommand Class


MindFusion.Diagramming.RemoveItemCommand.execute Method

RemoveItemCommand.execute Method
[image]

Command.execute override.

Namespace: MindFusion.Diagramming
Assembly: RemoveItemCommand.js

Syntax

JavaScript [image] Copy Code

function execute ()

See Also

RemoveItemCommand Members
RemoveItemCommand Class


MindFusion.Diagramming.RemoveItemCommand.redo Method

RemoveItemCommand.redo Method
[image]

Command.redo override.

Namespace: MindFusion.Diagramming
Assembly: RemoveItemCommand.js

Syntax

JavaScript [image] Copy Code

function redo ()

See Also

RemoveItemCommand Members
RemoveItemCommand Class


MindFusion.Diagramming.RemoveItemCommand.undo Method

RemoveItemCommand.undo Method
[image]

Command.undo override.

Namespace: MindFusion.Diagramming
Assembly: RemoveItemCommand.js

Syntax

JavaScript [image] Copy Code

function undo ()

See Also

RemoveItemCommand Members
RemoveItemCommand Class


MindFusion.Diagramming.ScrollTableCommand Class

ScrollTableCommand Class
[image]

Handles undo / redo of table scrolling.

Namespace: MindFusion.Diagramming
Assembly: ScrollTableCommand.js

Syntax

JavaScript [image] Copy Code

// class
ScrollTableCommand.prototype = {}

Inheritance Hierarchy

See Also

ScrollTableCommand Members


MindFusion.Diagramming.ScrollTableCommand Members

ScrollTableCommand Members
Constructors Methods
[image]

Handles undo / redo of table scrolling.

The following tables list the members exposed by the ScrollTableCommand type.

Public Constructors

Name | Description
ScrollTableCommand | Initializes a new instance of the ScrollTableCommand class.

Public Methods

Name | Description
execute | Command.execute override.
redo | Command.redo override.
undo | Command.undo override.

See Also

ScrollTableCommand Class


MindFusion.Diagramming.ScrollTableCommand Constructor

ScrollTableCommand Constructor
[image]

Initializes a new instance of the ScrollTableCommand class.

Namespace: MindFusion.Diagramming
Assembly: ScrollTableCommand.js

Syntax

JavaScript [image] Copy Code

function ScrollTableCommand (diagram, table)

Parameters

diagram

The Diagram modified by this command.

table

The TableNode instance that will be modified.

See Also

ScrollTableCommand Class


MindFusion.Diagramming.ScrollTableCommand Methods

ScrollTableCommand Methods
[image]

Public Methods

Name | Description
execute | Command.execute override.
redo | Command.redo override.
undo | Command.undo override.

See Also

ScrollTableCommand Class


MindFusion.Diagramming.ScrollTableCommand.execute Method

ScrollTableCommand.execute Method
[image]

Command.execute override.

Namespace: MindFusion.Diagramming
Assembly: ScrollTableCommand.js

Syntax

JavaScript [image] Copy Code

function execute ()

See Also

ScrollTableCommand Members
ScrollTableCommand Class


MindFusion.Diagramming.ScrollTableCommand.redo Method

ScrollTableCommand.redo Method
[image]

Command.redo override.

Namespace: MindFusion.Diagramming
Assembly: ScrollTableCommand.js

Syntax

JavaScript [image] Copy Code

function redo ()

See Also

ScrollTableCommand Members
ScrollTableCommand Class


MindFusion.Diagramming.ScrollTableCommand.undo Method

ScrollTableCommand.undo Method
[image]

Command.undo override.

Namespace: MindFusion.Diagramming
Assembly: ScrollTableCommand.js

Syntax

JavaScript [image] Copy Code

function undo ()

See Also

ScrollTableCommand Members
ScrollTableCommand Class


MindFusion.Diagramming.Selection Class

Selection Class
Remarks See Also
[image]

Represents a set of items selected in the Diagram document.

Namespace: MindFusion.Diagramming
Assembly: Selection.js

Syntax

JavaScript [image] Copy Code

// class
Selection.prototype = {}

Remarks

In a diagram document several items can be selected simultaneously. If more than one item is selected, the compound set of selected items is handled by an instance of the Selection class. Items in the selection can be of any element type. The items field gives a collection of all the items in the selection. You can get type-safe access to items of specific class by the links and nodes collections properties.

Inheritance Hierarchy

See Also

Selection Members


MindFusion.Diagramming.Selection Members

Selection Members
Constructors Fields Methods
[image]

Represents a set of items selected in the Diagram document.

The following tables list the members exposed by the Selection type.

Public Constructors

Name | Description
Selection | Initializes a new instance of the Selection class.

Public Fields

Name | Description
items | A list of DiagramItem objects.
links | A list of DiagramLink objects.
nodes | A list of DiagramNode objects.

Public Methods

Name | Description
addItem | Adds an item to the Selection.
allowDrag | DiagramItem.allowDrag override.
clear | Removes all items from the selection.
endDrag | DiagramItem.endDrag override.
onRemove | DiagramItem.onRemove override.
removeItem | Removes an item from the Diagram.
startDrag | DiagramItem.startDrag override.
updateDrag | DiagramItem.updateDrag override.

See Also

Selection Class


MindFusion.Diagramming.Selection Fields

Selection Fields
[image]

Public Fields

Name | Description
items | A list of DiagramItem objects.
links | A list of DiagramLink objects.
nodes | A list of DiagramNode objects.

See Also

Selection Class


MindFusion.Diagramming.Selection.items Field

Selection.items Field
[image]

A list of DiagramItem objects.

Namespace: MindFusion.Diagramming
Assembly: Selection.js

Syntax

JavaScript [image] Copy Code

var items

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.links Field

Selection.links Field
[image]

A list of DiagramLink objects.

Namespace: MindFusion.Diagramming
Assembly: Selection.js

Syntax

JavaScript [image] Copy Code

var links

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.nodes Field

Selection.nodes Field
[image]

A list of DiagramNode objects.

Namespace: MindFusion.Diagramming
Assembly: Selection.js

Syntax

JavaScript [image] Copy Code

var nodes

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection Constructor

Selection Constructor
[image]

Initializes a new instance of the Selection class.

Namespace: MindFusion.Diagramming
Assembly: Selection.js

Syntax

JavaScript [image] Copy Code

function Selection (parent)

Parameters

parent
The diagram where the items are selected.

See Also

Selection Class


MindFusion.Diagramming.Selection Methods

Selection Methods
[image]

Public Methods

Name | Description
addItem | Adds an item to the Selection.
allowDrag | DiagramItem.allowDrag override.
clear | Removes all items from the selection.
endDrag | DiagramItem.endDrag override.
onRemove | DiagramItem.onRemove override.
removeItem | Removes an item from the Diagram.
startDrag | DiagramItem.startDrag override.
updateDrag | DiagramItem.updateDrag override.

See Also

Selection Class


MindFusion.Diagramming.Selection.addItem Method

Selection.addItem Method
[image]

Adds an item to the Selection.

Namespace: MindFusion.Diagramming
Assembly: Selection.js

Syntax

JavaScript [image] Copy Code

function addItem ([item])

Parameters

item
Optional. The item to add.

Remarks

This method adds a new item to the selection. It also deactivates the activeItem, if any, and makes the newly added item the active one.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.allowDrag Method

Selection.allowDrag Method
[image]

DiagramItem.allowDrag override.

Namespace: MindFusion.Diagramming
Assembly: Selection.js

Syntax

JavaScript [image] Copy Code

function allowDrag (ist)

Parameters

ist

An InteractionState object that encapsulates the current state of user interaction with the control.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.clear Method

Selection.clear Method
[image]

Removes all items from the selection.

Namespace: MindFusion.Diagramming
Assembly: Selection.js

Syntax

JavaScript [image] Copy Code

function clear ()

Remarks

Call clear to deselect all items. The items are not deleted. The method also sets the diagram's activeItem to Null.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.endDrag Method

Selection.endDrag Method
[image]

DiagramItem.endDrag override.

Namespace: MindFusion.Diagramming
Assembly: Selection.js

Syntax

JavaScript [image] Copy Code

function endDrag (ist)

Parameters

ist

An InteractionState object that encapsulates the current state of user interaction with the control.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.onRemove Method

Selection.onRemove Method
[image]

DiagramItem.onRemove override.

Namespace: MindFusion.Diagramming
Assembly: Selection.js

Syntax

JavaScript [image] Copy Code

function onRemove ()

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.removeItem Method

Selection.removeItem Method
[image]

Removes an item from the Diagram.

Namespace: MindFusion.Diagramming
Assembly: Selection.js

Syntax

JavaScript [image] Copy Code

function removeItem (item)

Parameters

item
The item to add.

Remarks

Call this method to deselect an item. Note that the item is not deleted, but just removed from the selection.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.startDrag Method

Selection.startDrag Method
[image]

DiagramItem.startDrag override.

Namespace: MindFusion.Diagramming
Assembly: Selection.js

Syntax

JavaScript [image] Copy Code

function startDrag ([ist])

Parameters

ist
Optional. An InteractionState object that encapsulates the current state of user interaction with the control.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.updateDrag Method

Selection.updateDrag Method
[image]

DiagramItem.updateDrag override.

Namespace: MindFusion.Diagramming
Assembly: Selection.js

Syntax

JavaScript [image] Copy Code

function updateDrag (ist)

Parameters

ist
An InteractionState object that encapsulates the current state of user interaction with the control.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.SelectionEventArgs Class

SelectionEventArgs Class
[image]

Contains the arguments passed to handlers of selection-related events.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

// class
SelectionEventArgs.prototype = {}

Inheritance Hierarchy

See Also

SelectionEventArgs Members


MindFusion.Diagramming.SelectionEventArgs Members

SelectionEventArgs Members
Constructors Methods
[image]

Contains the arguments passed to handlers of selection-related events.

The following tables list the members exposed by the SelectionEventArgs type.

Public Constructors

Name | Description
SelectionEventArgs | Overloaded.

Public Methods

Name | Description
cancelDrag | Immediately cancels the current selection modification.
getAdjustmentHandle | Gets the adjustment handle being moved by the user.
getCancel | Gets a value indicating whether to allow the current operation.
getMousePosition | Gets the current mouse pointer position.
setCancel | Sets a value indicating whether to allow the current operation.

See Also

SelectionEventArgs Class


MindFusion.Diagramming.SelectionEventArgs Constructor

SelectionEventArgs Constructor
[image]

Overload List

Name | Description
SelectionEventArgs () | Initializes a new instance of the SelectionEventArgs class.
SelectionEventArgs (Object) | Initializes a new instance of the SelectionEventArgs class.

See Also

SelectionEventArgs Class


MindFusion.Diagramming.SelectionEventArgs Constructor ()

SelectionEventArgs Constructor ()
See Also
[image]

Initializes a new instance of the SelectionEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function SelectionEventArgs ()

See Also

SelectionEventArgs Constructor Overload List
SelectionEventArgs Class


MindFusion.Diagramming.SelectionEventArgs Constructor (Object)

SelectionEventArgs Constructor (Object)
See Also
[image]

Initializes a new instance of the SelectionEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function SelectionEventArgs (args)

Parameters

args

See Also

SelectionEventArgs Constructor Overload List
SelectionEventArgs Class


MindFusion.Diagramming.SelectionEventArgs Methods

SelectionEventArgs Methods
[image]

Public Methods

Name | Description
cancelDrag | Immediately cancels the current selection modification.
getAdjustmentHandle | Gets the adjustment handle being moved by the user.
getCancel | Gets a value indicating whether to allow the current operation.
getMousePosition | Gets the current mouse pointer position.
setCancel | Sets a value indicating whether to allow the current operation.

See Also

SelectionEventArgs Class


MindFusion.Diagramming.SelectionEventArgs.cancelDrag Method

SelectionEventArgs.cancelDrag Method
[image]

Immediately cancels the current selection modification.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function cancelDrag ()

See Also

SelectionEventArgs Members
SelectionEventArgs Class


MindFusion.Diagramming.SelectionEventArgs.getAdjustmentHandle Method

SelectionEventArgs.getAdjustmentHandle Method
[image]

Gets the adjustment handle being moved by the user.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getAdjustmentHandle ()

Return Value

One of the AdjustmentHandles enumeration values.

See Also

SelectionEventArgs Members
SelectionEventArgs Class


MindFusion.Diagramming.SelectionEventArgs.getCancel Method

SelectionEventArgs.getCancel Method
[image]

Gets a value indicating whether to allow the current operation.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getCancel ()

Return Value

true if the current operation is allowed; otherwise, false.

See Also

SelectionEventArgs Members
SelectionEventArgs Class


MindFusion.Diagramming.SelectionEventArgs.getMousePosition Method

SelectionEventArgs.getMousePosition Method
[image]

Gets the current mouse pointer position.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getMousePosition ()

Return Value

A Point instance.

See Also

SelectionEventArgs Members
SelectionEventArgs Class


MindFusion.Diagramming.SelectionEventArgs.setCancel Method

SelectionEventArgs.setCancel Method
[image]

Sets a value indicating whether to allow the current operation.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function setCancel (value)

Parameters

value

true to allow the current operation; otherwise, false.

See Also

SelectionEventArgs Members
SelectionEventArgs Class


MindFusion.Diagramming.SelectOnlyBehavior Class

SelectOnlyBehavior Class
[image]

Allows only selection of existing items. Modifying them or drawing new ones is disabled.

Namespace: MindFusion.Diagramming
Assembly: SelectOnlyBehavior.js

Syntax

JavaScript [image] Copy Code

// class
SelectOnlyBehavior.prototype = {}

Inheritance Hierarchy

See Also

SelectOnlyBehavior Members


MindFusion.Diagramming.SelectOnlyBehavior Members

SelectOnlyBehavior Members
Constructors Methods
[image]

Allows only selection of existing items. Modifying them or drawing new ones is disabled.

The following tables list the members exposed by the SelectOnlyBehavior type.

Public Constructors

Name | Description
SelectOnlyBehavior | Initializes a new instance of the SelectOnlyBehavior class.

Public Methods

Name | Description
startDraw | BehaviorBase.startDraw override.

See Also

SelectOnlyBehavior Class


MindFusion.Diagramming.SelectOnlyBehavior Constructor

SelectOnlyBehavior Constructor
[image]

Initializes a new instance of the SelectOnlyBehavior class.

Namespace: MindFusion.Diagramming
Assembly: SelectOnlyBehavior.js

Syntax

JavaScript [image] Copy Code

function SelectOnlyBehavior (parent)

Parameters

parent

The Diagram this behavior will be associated with.

See Also

SelectOnlyBehavior Class


MindFusion.Diagramming.SelectOnlyBehavior Methods

SelectOnlyBehavior Methods
[image]

Public Methods

Name | Description
startDraw | BehaviorBase.startDraw override.

See Also

SelectOnlyBehavior Class


MindFusion.Diagramming.SelectOnlyBehavior.startDraw Method

SelectOnlyBehavior.startDraw Method
[image]

BehaviorBase.startDraw override.

Namespace: MindFusion.Diagramming
Assembly: SelectOnlyBehavior.js

Syntax

JavaScript [image] Copy Code

function startDraw (point)

Parameters

point

A Point structure, which specifies the current position of the mouse cursor, in document coordinates.

Return Value

An instance of the InteractionState class.

See Also

SelectOnlyBehavior Members
SelectOnlyBehavior Class


MindFusion.Diagramming.SerializeTagEventArgs Class

SerializeTagEventArgs Class
[image]

Contains the arguments passed to the serializeTag and deserializeTag event handlers.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

// class
SerializeTagEventArgs.prototype = {}

Inheritance Hierarchy

See Also

SerializeTagEventArgs Members


MindFusion.Diagramming.SerializeTagEventArgs Members

SerializeTagEventArgs Members
Constructors Methods
[image]

Contains the arguments passed to the serializeTag and deserializeTag event handlers.

The following tables list the members exposed by the SerializeTagEventArgs type.

Public Constructors

Name | Description
SerializeTagEventArgs | Initializes a new instance of the SerializeTagEventArgs class.

Public Methods

Name | Description
getContext | Gets an XmlPersistContext object providing helper read and write methods for various value types.
getElement | Gets the XML element where the tag value should be serialized to or deserialized from.
getHandled | Gets a value indicating whether the event has been handled.
getObject | Gets the object whose property is being serialized or deserialized.
getPropertyName | Gets an XmlPersistContext object providing helper read and write methods for various value types.
getTag | Gets the tag value being serialized or deserialized.
setHandled | Sets a value indicating whether the event has been handled.
setTag | Sets the tag value being serialized or deserialized.

See Also

SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs Constructor

SerializeTagEventArgs Constructor
[image]

Initializes a new instance of the SerializeTagEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function SerializeTagEventArgs ()

See Also

SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs Methods

SerializeTagEventArgs Methods
[image]

Public Methods

Name | Description
getContext | Gets an XmlPersistContext object providing helper read and write methods for various value types.
getElement | Gets the XML element where the tag value should be serialized to or deserialized from.
getHandled | Gets a value indicating whether the event has been handled.
getObject | Gets the object whose property is being serialized or deserialized.
getPropertyName | Gets an XmlPersistContext object providing helper read and write methods for various value types.
getTag | Gets the tag value being serialized or deserialized.
setHandled | Sets a value indicating whether the event has been handled.
setTag | Sets the tag value being serialized or deserialized.

See Also

SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs.getContext Method

SerializeTagEventArgs.getContext Method
[image]

Gets an XmlPersistContext object providing helper read and write methods for various value types.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getContext ()

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs.getElement Method

SerializeTagEventArgs.getElement Method
[image]

Gets the XML element where the tag value should be serialized to or deserialized from.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getElement ()

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs.getHandled Method

SerializeTagEventArgs.getHandled Method
[image]

Gets a value indicating whether the event has been handled.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getHandled ()

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs.getObject Method

SerializeTagEventArgs.getObject Method
[image]

Gets the object whose property is being serialized or deserialized.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getObject ()

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs.getPropertyName Method

SerializeTagEventArgs.getPropertyName Method
[image]

Gets an XmlPersistContext object providing helper read and write methods for various value types.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getPropertyName ()

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs.getTag Method

SerializeTagEventArgs.getTag Method
[image]

Gets the tag value being serialized or deserialized.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function getTag ()

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs.setHandled Method

SerializeTagEventArgs.setHandled Method
[image]

Sets a value indicating whether the event has been handled.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function setHandled (value)

Parameters

value

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs.setTag Method

SerializeTagEventArgs.setTag Method
[image]

Sets the tag value being serialized or deserialized.

Namespace: MindFusion.Diagramming
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function setTag (value)

Parameters

value

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Diagramming.ShadowsStyle Enumeration

ShadowsStyle Enumeration
[image]

Enumerates possible shadows-drawing styles.

Namespace: MindFusion.Diagramming
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
ShadowsStyle = {}

Members

Member name | Description
None | No shadows are drawn.
OneLevel | All shadows are drawn at the lowest z-level, and appear to be on one level.
ZOrder | Every shadows is drawn just below its object, possibly covering other objects.

See Also


MindFusion.Diagramming.Shape Class

Shape Class
[image]

An instance of this class represents a shape defined through a series of arc, line and Bezier segments. The segments can be a part of the shape outline, in which case they define the part of the shape is filled, used for hit-testing and for aligning links to the node edges. Segments can also be added as decoration elements, in which case they only affect the appearance of a ShapeNode.

Namespace: MindFusion.Diagramming
Assembly: Shape.js

Syntax

JavaScript [image] Copy Code

// class
Shape.prototype = {}

Example

The following code defines a custom shape object:

Inheritance Hierarchy

See Also

Shape Members


MindFusion.Diagramming.Shape Members

Shape Members
Constructors Methods
[image]

An instance of this class represents a shape defined through a series of arc, line and Bezier segments. The segments can be a part of the shape outline, in which case they define the part of the shape is filled, used for hit-testing and for aligning links to the node edges. Segments can also be added as decoration elements, in which case they only affect the appearance of a ShapeNode.

The following tables list the members exposed by the Shape type.

Public Constructors

Name | Description
Shape | Initializes a new instance of the Shape class.

Public Methods

Name | Description
fromId | Returns a reference to the Shape with the specified string identifier.
getId | Gets the id of this Shape.
isElliptic | Gets a value indicating whether this shape is elliptic.

See Also

Shape Class


MindFusion.Diagramming.Shape Constructor

Shape Constructor
[image]

Initializes a new instance of the Shape class.

Namespace: MindFusion.Diagramming
Assembly: Shape.js

Syntax

JavaScript [image] Copy Code

function Shape ([params])

Parameters

params.outline
Optional.

A string defining the shape's outline.

params.decoration
Optional.

A string defining the shape's decoration.

params.shapeDecoration
Optional.

A string defining additional shape decoration.

params.id
Optional.

The string identifier of the shape.

params.outlinePen
Optional.

A string specifying the stroke of the shape's outline.

params.outlineBrush
Optional.

A string specifying the fill of the shape's outline.

params.decorationPen
Optional.

A string specifying the stroke of the shape's decoration.

params.decorationBrush
Optional.

A string specifying the fill of the shape's decoration.

params.shapeDecorationPen
Optional.

A string specifying the stroke of the additional shape decoration.

params.shapeDecorationBrush
Optional.

A string specifying the fill of the additional shape decoration.

Remarks

The id argument should match an identifier passed to a constructor of the existing shape templates.

See Also

Shape Class


MindFusion.Diagramming.Shape Methods

Shape Methods
[image]

Public Methods

Name | Description
fromId | Returns a reference to the Shape with the specified string identifier.
getId | Gets the id of this Shape.
isElliptic | Gets a value indicating whether this shape is elliptic.

See Also

Shape Class


MindFusion.Diagramming.Shape.fromId Method

Shape.fromId Method
[image]

Returns a reference to the Shape with the specified string identifier.

Namespace: MindFusion.Diagramming
Assembly: Shape.js

Syntax

JavaScript [image] Copy Code

function fromId (id)

Parameters

id
The identifier of the Shape of interest.

Return Value

A reference to the Shape with the specified identifier or null if there is no such shape.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.getId Method

Shape.getId Method
[image]

Gets the id of this Shape.

Namespace: MindFusion.Diagramming
Assembly: Shape.js

Syntax

JavaScript [image] Copy Code

function getId ()

Return Value

The string identifier.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.isElliptic Method

Shape.isElliptic Method
[image]

Gets a value indicating whether this shape is elliptic.

Namespace: MindFusion.Diagramming
Assembly: Shape.js

Syntax

JavaScript [image] Copy Code

function isElliptic ()

Return Value

True if the shape is elliptic, otherwise false.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.ShapeLibrary Class

ShapeLibrary Class
[image]

The ShapeLibrary class represents a collection of shape definitionsstored together.

Namespace: MindFusion.Diagramming
Assembly: ShapeLibrary.js

Syntax

JavaScript [image] Copy Code

// class
ShapeLibrary.prototype = {}

Inheritance Hierarchy

See Also

ShapeLibrary Members


MindFusion.Diagramming.ShapeLibrary Members

ShapeLibrary Members
Constructors Fields Methods
[image]

The ShapeLibrary class represents a collection of shape definitionsstored together.

The following tables list the members exposed by the ShapeLibrary type.

Public Constructors

Name | Description
ShapeLibrary | Initializes a new instance of the ShapeLibrary class.

Public Fields

Name | Description
shapes | A list containing all the shapes.

Public Methods

Name | Description
getShapes | Gets the list with all shapes contained in the library.
loadFromXml | Loads the library from the specified XML document.

See Also

ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary Fields

ShapeLibrary Fields
[image]

Public Fields

Name | Description
shapes | A list containing all the shapes.

See Also

ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.shapes Field

ShapeLibrary.shapes Field
[image]

A list containing all the shapes.

Namespace: MindFusion.Diagramming
Assembly: ShapeLibrary.js

Syntax

JavaScript [image] Copy Code

var shapes

See Also

ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary Constructor

ShapeLibrary Constructor
[image]

Initializes a new instance of the ShapeLibrary class.

Namespace: MindFusion.Diagramming
Assembly: ShapeLibrary.js

Syntax

JavaScript [image] Copy Code

function ShapeLibrary (shapes)

Parameters

shapes

A list of MindFusion.Diagramming.Shape objects to initialize the library with.

See Also

ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary Methods

ShapeLibrary Methods
[image]

Public Methods

Name | Description
getShapes | Gets the list with all shapes contained in the library.
loadFromXml | Loads the library from the specified XML document.

See Also

ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.getShapes Method

ShapeLibrary.getShapes Method
[image]

Gets the list with all shapes contained in the library.

Namespace: MindFusion.Diagramming
Assembly: ShapeLibrary.js

Syntax

JavaScript [image] Copy Code

function getShapes ()

See Also

ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.loadFromXml Method

ShapeLibrary.loadFromXml Method
[image]

Loads the library from the specified XML document.

Namespace: MindFusion.Diagramming
Assembly: ShapeLibrary.js

Syntax

JavaScript [image] Copy Code

function loadFromXml (fileUrl, [onLoad, [onError]])

Parameters

fileUrl

The URL of an XML file where the data should be read from.

onLoad
Optional.

A callback that should be invoked if the file is loaded successfully.

onError
Optional.

A callback that should be invoked if the file could not be downloaded.

See Also

ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeNode Class

ShapeNode Class
Remarks See Also
[image]

ShapeNode instances are diagram nodes that represent geometric shapes.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

// class
ShapeNode.prototype = {}

Remarks

ShapeNode instance might represent nodes in graphs, tree, process diagrams, and so on. The default shape of nodes in the Diagram is specified by the setDefaultShape property. Shapes can be rotated, either interactively using the rotation handle above the node, or programmatically using the setRotationAngle property. Shape nodes can display images and text. Set an image to be painted inside a node by calling the setImageLocation function. The position of the image within the node as well as its alignment are set by the setImageAlign method.

Text inside a shape node is represented by the Text property. Its attributes can be changed by the TextColor and Font properties. To get even richer text formatting, set EnableStyledText to true and embed HTML-like formatting tags in the raw text. To make a node big enough to display its text without clipping, call resizeToFitText.

Inheritance Hierarchy

See Also

ShapeNode Members


MindFusion.Diagramming.ShapeNode Members

ShapeNode Members
Constructors Methods
[image]

ShapeNode instances are diagram nodes that represent geometric shapes.

The following tables list the members exposed by the ShapeNode type.

Public Constructors

Name | Description
ShapeNode | Initializes a new instance of the ShapeNode class with default values supplied form the specified Diagram.

Public Methods

Name | Description
containsPoint | Checks if the ShapeNode contains the specified point.
getEnableStyledText | Gets a value indicating whether styled text rendering is enabled.
getImage | Gets the image of the node.
getImageAlign | Gets the alignment for the image of this node.
getImageContent | Gets the Base64-encoded data of the image displayed in this ShapeNode.
getImageLocation | Gets the URL of the image displayed in this ShapeNode.
getLineAlignment | Gets how the text should be vertically aligned in the ShapeNode's text box.
getOutline | Gets an array of points that define the outline of this node shape.
getRotateImage | Gets a value indicating whether the image is rotated when the node is rotated.
getRotateText | Gets a value indicating whether text is rotated when the node is rotated.
getShape | Gets a reference to the node's geometric shape definition.
getTextAlignment | Gets how the text should be aligned in the ShapeNode's text box.
getTextColor | Gets a string specifying the color of the text of this node.
getTransparent | Gets or sets a value indicating whether this ShapeNode is transparent.
resizeToFitText | Makes the shape node big enough to display its text without clipping.
setEnableStyledText | Sets a value indicating whether styled text rendering is enabled.
setImage | Sets the image of the node.
setImageAlign | Sets the alignment for the image of this node.
setImageContent | Sets the Base64-encoded data of the image displayed in this ShapeNode.
setImageLocation | Sets the URL of the image displayed in this ShapeNode.
setLineAlignment | Sets how the text should be vertically aligned in the ShapeNode's text box.
setRotateImage | Sets a value indicating whether the image is rotated when the node is rotated.
setRotateText | Sets a value indicating whether text is rotated when the node is rotated.
setShape | Sets a reference to the node's geometric shape definition.
setTextAlignment | Sets how the text should be aligned in the ShapeNode's text box.
setTextColor | Sets a string specifying the color of the text of this node.
setTransparent | Sets or sets a value indicating whether this ShapeNode is transparent.

See Also

ShapeNode Class


MindFusion.Diagramming.ShapeNode Constructor

ShapeNode Constructor
[image]

Initializes a new instance of the ShapeNode class with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function ShapeNode ([parent])

Parameters

parent
Optional. The Diagram from which to obtain default values for the node properties.

Remarks

If parent is not specified, this constructor initializes the ShapeNode properties with the values specified in the respective default-value properties of the Diagram object.

If parent is specified, the constructor copies the ShapeNode property values from the specified prototype node.

See Also

ShapeNode Class


MindFusion.Diagramming.ShapeNode Methods

ShapeNode Methods
[image]

Public Methods

Name | Description
containsPoint | Checks if the ShapeNode contains the specified point.
getEnableStyledText | Gets a value indicating whether styled text rendering is enabled.
getImage | Gets the image of the node.
getImageAlign | Gets the alignment for the image of this node.
getImageContent | Gets the Base64-encoded data of the image displayed in this ShapeNode.
getImageLocation | Gets the URL of the image displayed in this ShapeNode.
getLineAlignment | Gets how the text should be vertically aligned in the ShapeNode's text box.
getOutline | Gets an array of points that define the outline of this node shape.
getRotateImage | Gets a value indicating whether the image is rotated when the node is rotated.
getRotateText | Gets a value indicating whether text is rotated when the node is rotated.
getShape | Gets a reference to the node's geometric shape definition.
getTextAlignment | Gets how the text should be aligned in the ShapeNode's text box.
getTextColor | Gets a string specifying the color of the text of this node.
getTransparent | Gets or sets a value indicating whether this ShapeNode is transparent.
resizeToFitText | Makes the shape node big enough to display its text without clipping.
setEnableStyledText | Sets a value indicating whether styled text rendering is enabled.
setImage | Sets the image of the node.
setImageAlign | Sets the alignment for the image of this node.
setImageContent | Sets the Base64-encoded data of the image displayed in this ShapeNode.
setImageLocation | Sets the URL of the image displayed in this ShapeNode.
setLineAlignment | Sets how the text should be vertically aligned in the ShapeNode's text box.
setRotateImage | Sets a value indicating whether the image is rotated when the node is rotated.
setRotateText | Sets a value indicating whether text is rotated when the node is rotated.
setShape | Sets a reference to the node's geometric shape definition.
setTextAlignment | Sets how the text should be aligned in the ShapeNode's text box.
setTextColor | Sets a string specifying the color of the text of this node.
setTransparent | Sets or sets a value indicating whether this ShapeNode is transparent.

See Also

ShapeNode Class


MindFusion.Diagramming.ShapeNode.containsPoint Method

ShapeNode.containsPoint Method
[image]

Checks if the ShapeNode contains the specified point.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function containsPoint (point)

Parameters

point
The Point to check.

Return Value

true if the Point is within the bounds of this node; otherwise, false.

Remarks

This method is used during hit-testing to see if the mouse is inside the item.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.getEnableStyledText Method

ShapeNode.getEnableStyledText Method
[image]

Gets a value indicating whether styled text rendering is enabled.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function getEnableStyledText ()

Return Value

true to parse the node's text in order to find formatting tags; or false otherwise.

Remarks

Styled text allows applying various attributes to the characters it contains. Attributes are specified using HTML-like formatting tags embedded in the raw text. At this time the component supports the following formatting tags:

  • <b> specifies bold text
  • <i> specifies italic text
  • <u> specifies underlined text
  • <color=value> specifies text color
  • <br /> specifies line break

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
getText Method
getFont Method


MindFusion.Diagramming.ShapeNode.getImage Method

ShapeNode.getImage Method
[image]

Gets the image of the node.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function getImage ()

Return Value

The image of the node.

Remarks

This property lets you display an image inside the node. Use the setImageAlign method to specify how the image is aligned to that area. By default, the image is displayed in the center of the bounding rectangle of the node.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.getImageAlign Method

ShapeNode.getImageAlign Method
[image]

Gets the alignment for the image of this node.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function getImageAlign ()

Return Value

One of the ImageAlign Enumeration values.

Remarks

This property specifies how the image is aligned to the bounding rectangle of this node.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.getImageContent Method

ShapeNode.getImageContent Method
[image]

Gets the Base64-encoded data of the image displayed in this ShapeNode.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function getImageContent ()

Return Value

The Base64-encoded data for the image to be loaded.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.getImageLocation Method

ShapeNode.getImageLocation Method
[image]

Gets the URL of the image displayed in this ShapeNode.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function getImageLocation ()

Return Value

A valid URL string that identifies the image to be loaded.

Remarks

Calling this method with a valid path will automatically load the image and assign it to the image field.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.getLineAlignment Method

ShapeNode.getLineAlignment Method
[image]

Gets how the text should be vertically aligned in the ShapeNode's text box.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function getLineAlignment ()

Return Value

One of the Alignment enumeration values.

Remarks

Calling this method with a valid path will automatically load the image and assign it to the image field.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.getOutline Method

ShapeNode.getOutline Method
[image]

Gets an array of points that define the outline of this node shape.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function getOutline ()

Return Value

An array with the points.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.getRotateImage Method

ShapeNode.getRotateImage Method
[image]

Gets a value indicating whether the image is rotated when the node is rotated.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function getRotateImage ()

Return Value

true if the image is rotated; otherwise, false.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.getRotateText Method

ShapeNode.getRotateText Method
[image]

Gets a value indicating whether text is rotated when the node is rotated.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function getRotateText ()

Return Value

true if the text is rotated; otherwise, false.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.getShape Method

ShapeNode.getShape Method
[image]

Gets a reference to the node's geometric shape definition.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function getShape ()

Return Value

The Shape of this node.

Remarks

Use this property to get the geometric shape of the node.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.getTextAlignment Method

ShapeNode.getTextAlignment Method
[image]

Gets how the text should be aligned in the ShapeNode's text box.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function getTextAlignment ()

Return Value

One of the Alignment enumeration values.

Remarks

Gets the vertical alignment of the text drawn in this node.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.getTextColor Method

ShapeNode.getTextColor Method
[image]

Gets a string specifying the color of the text of this node.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function getTextColor ()

Return Value

A string value identifying the color of the text.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.getTransparent Method

ShapeNode.getTransparent Method
[image]

Gets or sets a value indicating whether this ShapeNode is transparent.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function getTransparent ()

Return Value

true if the node is transparent; otherwise, false.

Remarks

If a node is transparent, only its image and text are drawn. Shape, filling and frames are not painted.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.resizeToFitText Method

ShapeNode.resizeToFitText Method
[image]

Makes the shape node big enough to display its text without clipping.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function resizeToFitText (fit)

Parameters

fit

One of the FitSize enumeration values.

Return Value

true if the node is resized successfully; otherwise, false.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
setText Method
setFont Method


MindFusion.Diagramming.ShapeNode.setEnableStyledText Method

ShapeNode.setEnableStyledText Method
[image]

Sets a value indicating whether styled text rendering is enabled.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function setEnableStyledText (value)

Parameters

value

true to parse the node's text in order to find formatting tags; or false otherwise.

Remarks

Styled text allows applying various attributes to the characters it contains. Attributes are specified using HTML-like formatting tags embedded in the raw text. At this time the component supports the following formatting tags:

  • <b> specifies bold text
  • <i> specifies italic text
  • <u> specifies underlined text
  • <color=value> specifies text color

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
Text Property
Font Property
TextColor Property


MindFusion.Diagramming.ShapeNode.setImage Method

ShapeNode.setImage Method
[image]

Sets the image of the node.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function setImage (value)

Parameters

value

The image to set.

Remarks

This property lets you display an image inside the node. Use the setImageAlign method to specify how the image is aligned to that area. By default, the image is displayed in the center of the bounding rectangle of the node.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.setImageAlign Method

ShapeNode.setImageAlign Method
[image]

Sets the alignment for the image of this node.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function setImageAlign (value)

Parameters

value
One of the ImageAlign Enumeration values.

Remarks

This property specifies how the image is aligned to the bounding rectangle of this node.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.setImageContent Method

ShapeNode.setImageContent Method
[image]

Sets the Base64-encoded data of the image displayed in this ShapeNode.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function setImageContent (value)

Parameters

value

The Base64-encoded data for the image to be loaded.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.setImageLocation Method

ShapeNode.setImageLocation Method
[image]

Sets the URL of the image displayed in this ShapeNode.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function setImageLocation (value)

Parameters

value

A valid URL string that identifies the image to be loaded.

Remarks

Use getImageLocation to retrieve the location of an image for this node.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.setLineAlignment Method

ShapeNode.setLineAlignment Method
[image]

Sets how the text should be vertically aligned in the ShapeNode's text box.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function setLineAlignment (value)

Parameters

value
One of the Alignment enumeration values.

Remarks

This method sets the vertical alignment of text drawn in this node.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.setRotateImage Method

ShapeNode.setRotateImage Method
[image]

Sets a value indicating whether the image is rotated when the node is rotated.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function setRotateImage (value)

Parameters

value

true if the image is rotated; otherwise, false.

Remarks

Use the setImage method to specify an image drawn in the node.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.setRotateText Method

ShapeNode.setRotateText Method
[image]

Sets a value indicating whether text is rotated when the node is rotated.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function setRotateText (value)

Parameters

value

true if the text is rotated; otherwise, false.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.setShape Method

ShapeNode.setShape Method
[image]

Sets a reference to the node's geometric shape definition.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function setShape (value)

Parameters

value
An instance of the Shape class.

Remarks

Use this property to assign a geometric shape to a node.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.setTextAlignment Method

ShapeNode.setTextAlignment Method
[image]

Sets how the text should be aligned in the ShapeNode's text box.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function setTextAlignment (value)

Parameters

value

One of the Alignment enumeration values.

Remarks

This method sets the vertical alignment of the text drawn in the node.

See Also

ShapeNode Members
ShapeNode Class
EnableStyledText Property


MindFusion.Diagramming.ShapeNode.setTextColor Method

ShapeNode.setTextColor Method
[image]

Sets a string specifying the color of the text of this node.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function setTextColor (value)

Parameters

value

A string value identifying the color of the text.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.setTransparent Method

ShapeNode.setTransparent Method
[image]

Sets or sets a value indicating whether this ShapeNode is transparent.

Namespace: MindFusion.Diagramming
Assembly: ShapeNode.js

Syntax

JavaScript [image] Copy Code

function setTransparent (value)

Parameters

value
true if the ShapeNode is transparent; otherwise, false.

Remarks

If a node is transparent, only its image and text are drawn. Shape, filling and frames are not painted.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.Shapes Class

Shapes Class
[image]

Provides alternative methods of access to the predefined shapes.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

// class
Shapes.prototype = {}

Inheritance Hierarchy

See Also

Shapes Members


MindFusion.Diagramming.Shapes Members

Shapes Members
Methods
[image]

Provides alternative methods of access to the predefined shapes.

The following tables list the members exposed by the Shapes type.

Public Methods

Name | Description
Actor | Gets the Actor predefined shape.
Alternative | Gets the Alternative predefined shape.
Arrow | Gets the Arrow predefined shape.
Arrow1 | Gets the Arrow1 predefined shape.
Arrow2 | Gets the Arrow2 predefined shape.
Arrow3 | Gets the Arrow3 predefined shape.
Arrow4 | Gets the Arrow4 predefined shape.
Arrow5 | Gets the Arrow5 predefined shape.
Arrow6 | Gets the Arrow6 predefined shape.
Arrow7 | Gets the Arrow7 predefined shape.
Arrow8 | Gets the Arrow8 predefined shape.
Arrow9 | Gets the Arrow9 predefined shape.
BackSlash | Gets the BackSlash predefined shape.
BeginLoop | Gets the BeginLoop predefined shape.
BowArrow | Gets the BowArrow predefined shape.
BpmnComplex | Gets the BpmnComplex predefined shape.
BpmnDataBasedXor | Gets the BpmnDataBasedXor predefined shape.
BpmnEndCancel | Gets the BpmnEndCancel predefined shape.
BpmnEndCompensation | Gets the BpmnEndCompensation predefined shape.
BpmnEndError | Gets the BpmnEndError predefined shape.
BpmnEndLink | Gets the BpmnEndLink predefined shape.
BpmnEndMessage | Gets the BpmnEndMessage predefined shape.
BpmnEndMultiple | Gets the BpmnEndMultiple predefined shape.
BpmnEndTerminate | Gets the BpmnEndTerminate predefined shape.
BpmnEventBasedXor | Gets the BpmnEventBasedXor predefined shape.
BpmnInclusive | Gets the BpmnInclusive predefined shape.
BpmnIntermediateCancel | Gets the BpmnIntermediateCancel predefined shape.
BpmnIntermediateCompensation | Gets the BpmnIntermediateCompensation predefined shape.
BpmnIntermediateError | Gets the BpmnIntermediateError predefined shape.
BpmnIntermediateLink | Gets the BpmnIntermediateLink predefined shape.
BpmnIntermediateMessage | Gets the BpmnIntermediateMessage predefined shape.
BpmnIntermediateMultiple | Gets the BpmnIntermediateMultiple predefined shape.
BpmnIntermediateRule | Gets the BpmnIntermediateRule predefined shape.
BpmnIntermediateTimer | Gets the BpmnIntermediateTimer predefined shape.
BpmnParallelFork | Gets the BpmnParallelFork predefined shape.
BpmnStartLink | Gets the BpmnStartLink predefined shape.
BpmnStartMessage | Gets the BpmnStartMessage predefined shape.
BpmnStartMultiple | Gets the BpmnStartMultiple predefined shape.
BpmnStartRule | Gets the BpmnStartRule predefined shape.
BpmnStartTimer | Gets the BpmnStartTimer predefined shape.
Circle | Gets the Circle predefined shape.
Cloud | Gets the Cloud predefined shape.
Collate | Gets the Collate predefined shape.
ConeDown | Gets the ConeDown predefined shape.
ConeUp | Gets the ConeUp predefined shape.
ConnectedIssues | Gets the ConnectedIssues predefined shape.
CreateRequest | Gets the CreateRequest predefined shape.
Cross | Gets the Cross predefined shape.
Cube | Gets the Cube predefined shape.
Cylinder | Gets the Cylinder predefined shape.
Database | Gets the Database predefined shape.
DataTransmition | Gets the DataTransmition predefined shape.
DDelay | Gets the DDelay predefined shape.
Decagon | Gets the Decagon predefined shape.
Decision | Gets the Decision predefined shape.
Decision2 | Gets the Decision2 predefined shape.
DefaultFlow | Gets the DefaultFlow predefined shape.
Delay | Gets the Delay predefined shape.
DInDelay | Gets the DInDelay predefined shape.
DirectAccessStorage | Gets the DirectAccessStorage predefined shape.
DiskStorage | Gets the DiskStorage predefined shape.
Display | Gets the Display predefined shape.
DividedEvent | Gets the DividedEvent predefined shape.
DividedProcess | Gets the DividedProcess predefined shape.
Document | Gets the Document predefined shape.
Donut | Gets the Donut predefined shape.
DoubleArrow | Gets the DoubleArrow predefined shape.
DOutDelay | Gets the DOutDelay predefined shape.
Ellipse | Gets the Ellipse predefined shape.
EndLoop | Gets the EndLoop predefined shape.
ExternalOrganization | Gets the ExternalOrganization predefined shape.
ExternalProcess | Gets the ExternalProcess predefined shape.
File | Gets the File predefined shape.
FramedRectangle | Gets the FramedRectangle predefined shape.
Gate | Gets the Gate predefined shape.
Heart | Gets the Heart predefined shape.
Heptagon | Gets the Heptagon predefined shape.
Hourglass | Gets the Hourglass predefined shape.
Input | Gets the Input predefined shape.
InternalStorage | Gets the InternalStorage predefined shape.
Interrupt | Gets the Interrupt predefined shape.
Interrupt2 | Gets the Interrupt2 predefined shape.
IsoProcess | Gets the IsoProcess predefined shape.
Junction | Gets the Junction predefined shape.
Lightning | Gets the Lightning predefined shape.
LinedDocument | Gets the LinedDocument predefined shape.
ManualOperation | Gets the ManualOperation predefined shape.
Merge | Gets the Merge predefined shape.
MessageFromUser | Gets the MessageFromUser predefined shape.
MessageToUser | Gets the MessageToUser predefined shape.
Microform | Gets the Microform predefined shape.
MicroformProcessing | Gets the MicroformProcessing predefined shape.
MicroformRecording | Gets the MicroformRecording predefined shape.
MultiDocument | Gets the MultiDocument predefined shape.
MultiProc | Gets the MultiProc predefined shape.
Octagon | Gets the Octagon predefined shape.
OfflineStorage | Gets the OfflineStorage predefined shape.
OffpageConnection | Gets the OffpageConnection predefined shape.
OffpageReference | Gets the OffpageReference predefined shape.
Or | Gets the Or predefined shape.
Pentagon | Gets the Pentagon predefined shape.
PentagonArrow | Gets the PentagonArrow predefined shape.
Plaque | Gets the Plaque predefined shape.
PointerArrow | Gets the PointerArrow predefined shape.
PrimitiveFromCall | Gets the PrimitiveFromCall predefined shape.
PrimitiveToCall | Gets the PrimitiveToCall predefined shape.
Procedure | Gets the Procedure predefined shape.
Process | Gets the Process predefined shape.
Prysm | Gets the Prysm predefined shape.
PunchedCard | Gets the PunchedCard predefined shape.
PyramidDown | Gets the PyramidDown predefined shape.
PyramidUp | Gets the PyramidUp predefined shape.
Quill | Gets the Quill predefined shape.
Rectangle | Gets the Rectangle predefined shape.
Reversed | Gets the Reversed predefined shape.
RevTriangle | Gets the RevTriangle predefined shape.
RevWithCirc | Gets the RevWithCirc predefined shape.
RevWithLine | Gets the RevWithLine predefined shape.
Rhombus | Gets the Rhombus predefined shape.
RightTriangle | Gets the RightTriangle predefined shape.
RoundRect | Gets the RoundRect predefined shape.
RSave | Gets the RSave predefined shape.
Save | Gets the Save predefined shape.
Slash | Gets the Slash predefined shape.
Sort | Gets the Sort predefined shape.
Sphere | Gets the Sphere predefined shape.
Star | Gets the Star predefined shape.
Star16Pointed | Gets the Star16Pointed predefined shape.
Star24Pointed | Gets the Star24Pointed predefined shape.
Star32Pointed | Gets the Star32Pointed predefined shape.
Star4Pointed | Gets the Star4Pointed predefined shape.
Star5Pointed | Gets the Star5Pointed predefined shape.
Star6Pointed | Gets the Star6Pointed predefined shape.
Star7Pointed | Gets the Star7Pointed predefined shape.
Start | Gets the Start predefined shape.
Tape | Gets the Tape predefined shape.
Terminator | Gets the Terminator predefined shape.
Tetragon | Gets the Tetragon predefined shape.
TransmittalTape | Gets the TransmittalTape predefined shape.
Trapezoid | Gets the Trapezoid predefined shape.
Triangle | Gets the Triangle predefined shape.

See Also

Shapes Class


MindFusion.Diagramming.Shapes Methods

Shapes Methods
[image]

Public Methods

Name | Description
Actor | Gets the Actor predefined shape.
Alternative | Gets the Alternative predefined shape.
Arrow | Gets the Arrow predefined shape.
Arrow1 | Gets the Arrow1 predefined shape.
Arrow2 | Gets the Arrow2 predefined shape.
Arrow3 | Gets the Arrow3 predefined shape.
Arrow4 | Gets the Arrow4 predefined shape.
Arrow5 | Gets the Arrow5 predefined shape.
Arrow6 | Gets the Arrow6 predefined shape.
Arrow7 | Gets the Arrow7 predefined shape.
Arrow8 | Gets the Arrow8 predefined shape.
Arrow9 | Gets the Arrow9 predefined shape.
BackSlash | Gets the BackSlash predefined shape.
BeginLoop | Gets the BeginLoop predefined shape.
BowArrow | Gets the BowArrow predefined shape.
BpmnComplex | Gets the BpmnComplex predefined shape.
BpmnDataBasedXor | Gets the BpmnDataBasedXor predefined shape.
BpmnEndCancel | Gets the BpmnEndCancel predefined shape.
BpmnEndCompensation | Gets the BpmnEndCompensation predefined shape.
BpmnEndError | Gets the BpmnEndError predefined shape.
BpmnEndLink | Gets the BpmnEndLink predefined shape.
BpmnEndMessage | Gets the BpmnEndMessage predefined shape.
BpmnEndMultiple | Gets the BpmnEndMultiple predefined shape.
BpmnEndTerminate | Gets the BpmnEndTerminate predefined shape.
BpmnEventBasedXor | Gets the BpmnEventBasedXor predefined shape.
BpmnInclusive | Gets the BpmnInclusive predefined shape.
BpmnIntermediateCancel | Gets the BpmnIntermediateCancel predefined shape.
BpmnIntermediateCompensation | Gets the BpmnIntermediateCompensation predefined shape.
BpmnIntermediateError | Gets the BpmnIntermediateError predefined shape.
BpmnIntermediateLink | Gets the BpmnIntermediateLink predefined shape.
BpmnIntermediateMessage | Gets the BpmnIntermediateMessage predefined shape.
BpmnIntermediateMultiple | Gets the BpmnIntermediateMultiple predefined shape.
BpmnIntermediateRule | Gets the BpmnIntermediateRule predefined shape.
BpmnIntermediateTimer | Gets the BpmnIntermediateTimer predefined shape.
BpmnParallelFork | Gets the BpmnParallelFork predefined shape.
BpmnStartLink | Gets the BpmnStartLink predefined shape.
BpmnStartMessage | Gets the BpmnStartMessage predefined shape.
BpmnStartMultiple | Gets the BpmnStartMultiple predefined shape.
BpmnStartRule | Gets the BpmnStartRule predefined shape.
BpmnStartTimer | Gets the BpmnStartTimer predefined shape.
Circle | Gets the Circle predefined shape.
Cloud | Gets the Cloud predefined shape.
Collate | Gets the Collate predefined shape.
ConeDown | Gets the ConeDown predefined shape.
ConeUp | Gets the ConeUp predefined shape.
ConnectedIssues | Gets the ConnectedIssues predefined shape.
CreateRequest | Gets the CreateRequest predefined shape.
Cross | Gets the Cross predefined shape.
Cube | Gets the Cube predefined shape.
Cylinder | Gets the Cylinder predefined shape.
Database | Gets the Database predefined shape.
DataTransmition | Gets the DataTransmition predefined shape.
DDelay | Gets the DDelay predefined shape.
Decagon | Gets the Decagon predefined shape.
Decision | Gets the Decision predefined shape.
Decision2 | Gets the Decision2 predefined shape.
DefaultFlow | Gets the DefaultFlow predefined shape.
Delay | Gets the Delay predefined shape.
DInDelay | Gets the DInDelay predefined shape.
DirectAccessStorage | Gets the DirectAccessStorage predefined shape.
DiskStorage | Gets the DiskStorage predefined shape.
Display | Gets the Display predefined shape.
DividedEvent | Gets the DividedEvent predefined shape.
DividedProcess | Gets the DividedProcess predefined shape.
Document | Gets the Document predefined shape.
Donut | Gets the Donut predefined shape.
DoubleArrow | Gets the DoubleArrow predefined shape.
DOutDelay | Gets the DOutDelay predefined shape.
Ellipse | Gets the Ellipse predefined shape.
EndLoop | Gets the EndLoop predefined shape.
ExternalOrganization | Gets the ExternalOrganization predefined shape.
ExternalProcess | Gets the ExternalProcess predefined shape.
File | Gets the File predefined shape.
FramedRectangle | Gets the FramedRectangle predefined shape.
Gate | Gets the Gate predefined shape.
Heart | Gets the Heart predefined shape.
Heptagon | Gets the Heptagon predefined shape.
Hourglass | Gets the Hourglass predefined shape.
Input | Gets the Input predefined shape.
InternalStorage | Gets the InternalStorage predefined shape.
Interrupt | Gets the Interrupt predefined shape.
Interrupt2 | Gets the Interrupt2 predefined shape.
IsoProcess | Gets the IsoProcess predefined shape.
Junction | Gets the Junction predefined shape.
Lightning | Gets the Lightning predefined shape.
LinedDocument | Gets the LinedDocument predefined shape.
ManualOperation | Gets the ManualOperation predefined shape.
Merge | Gets the Merge predefined shape.
MessageFromUser | Gets the MessageFromUser predefined shape.
MessageToUser | Gets the MessageToUser predefined shape.
Microform | Gets the Microform predefined shape.
MicroformProcessing | Gets the MicroformProcessing predefined shape.
MicroformRecording | Gets the MicroformRecording predefined shape.
MultiDocument | Gets the MultiDocument predefined shape.
MultiProc | Gets the MultiProc predefined shape.
Octagon | Gets the Octagon predefined shape.
OfflineStorage | Gets the OfflineStorage predefined shape.
OffpageConnection | Gets the OffpageConnection predefined shape.
OffpageReference | Gets the OffpageReference predefined shape.
Or | Gets the Or predefined shape.
Pentagon | Gets the Pentagon predefined shape.
PentagonArrow | Gets the PentagonArrow predefined shape.
Plaque | Gets the Plaque predefined shape.
PointerArrow | Gets the PointerArrow predefined shape.
PrimitiveFromCall | Gets the PrimitiveFromCall predefined shape.
PrimitiveToCall | Gets the PrimitiveToCall predefined shape.
Procedure | Gets the Procedure predefined shape.
Process | Gets the Process predefined shape.
Prysm | Gets the Prysm predefined shape.
PunchedCard | Gets the PunchedCard predefined shape.
PyramidDown | Gets the PyramidDown predefined shape.
PyramidUp | Gets the PyramidUp predefined shape.
Quill | Gets the Quill predefined shape.
Rectangle | Gets the Rectangle predefined shape.
Reversed | Gets the Reversed predefined shape.
RevTriangle | Gets the RevTriangle predefined shape.
RevWithCirc | Gets the RevWithCirc predefined shape.
RevWithLine | Gets the RevWithLine predefined shape.
Rhombus | Gets the Rhombus predefined shape.
RightTriangle | Gets the RightTriangle predefined shape.
RoundRect | Gets the RoundRect predefined shape.
RSave | Gets the RSave predefined shape.
Save | Gets the Save predefined shape.
Slash | Gets the Slash predefined shape.
Sort | Gets the Sort predefined shape.
Sphere | Gets the Sphere predefined shape.
Star | Gets the Star predefined shape.
Star16Pointed | Gets the Star16Pointed predefined shape.
Star24Pointed | Gets the Star24Pointed predefined shape.
Star32Pointed | Gets the Star32Pointed predefined shape.
Star4Pointed | Gets the Star4Pointed predefined shape.
Star5Pointed | Gets the Star5Pointed predefined shape.
Star6Pointed | Gets the Star6Pointed predefined shape.
Star7Pointed | Gets the Star7Pointed predefined shape.
Start | Gets the Start predefined shape.
Tape | Gets the Tape predefined shape.
Terminator | Gets the Terminator predefined shape.
Tetragon | Gets the Tetragon predefined shape.
TransmittalTape | Gets the TransmittalTape predefined shape.
Trapezoid | Gets the Trapezoid predefined shape.
Triangle | Gets the Triangle predefined shape.

See Also

Shapes Class


MindFusion.Diagramming.Shapes.Actor Method

Shapes.Actor Method
[image]

Gets the Actor predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Actor ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Alternative Method

Shapes.Alternative Method
[image]

Gets the Alternative predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Alternative ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow Method

Shapes.Arrow Method
[image]

Gets the Arrow predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Arrow ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow1 Method

Shapes.Arrow1 Method
[image]

Gets the Arrow1 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Arrow1 ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow2 Method

Shapes.Arrow2 Method
[image]

Gets the Arrow2 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Arrow2 ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow3 Method

Shapes.Arrow3 Method
[image]

Gets the Arrow3 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Arrow3 ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow4 Method

Shapes.Arrow4 Method
[image]

Gets the Arrow4 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Arrow4 ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow5 Method

Shapes.Arrow5 Method
[image]

Gets the Arrow5 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Arrow5 ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow6 Method

Shapes.Arrow6 Method
[image]

Gets the Arrow6 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Arrow6 ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow7 Method

Shapes.Arrow7 Method
[image]

Gets the Arrow7 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Arrow7 ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow8 Method

Shapes.Arrow8 Method
[image]

Gets the Arrow8 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Arrow8 ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow9 Method

Shapes.Arrow9 Method
[image]

Gets the Arrow9 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Arrow9 ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BackSlash Method

Shapes.BackSlash Method
[image]

Gets the BackSlash predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BackSlash ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BeginLoop Method

Shapes.BeginLoop Method
[image]

Gets the BeginLoop predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BeginLoop ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BowArrow Method

Shapes.BowArrow Method
[image]

Gets the BowArrow predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BowArrow ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnComplex Method

Shapes.BpmnComplex Method
[image]

Gets the BpmnComplex predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BpmnComplex ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnDataBasedXor Method

Shapes.BpmnDataBasedXor Method
[image]

Gets the BpmnDataBasedXor predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BpmnDataBasedXor ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndCancel Method

Shapes.BpmnEndCancel Method
[image]

Gets the BpmnEndCancel predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BpmnEndCancel ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndCompensation Method

Shapes.BpmnEndCompensation Method
[image]

Gets the BpmnEndCompensation predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BpmnEndCompensation ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndError Method

Shapes.BpmnEndError Method
[image]

Gets the BpmnEndError predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BpmnEndError ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndLink Method

Shapes.BpmnEndLink Method
[image]

Gets the BpmnEndLink predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BpmnEndLink ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndMessage Method

Shapes.BpmnEndMessage Method
[image]

Gets the BpmnEndMessage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BpmnEndMessage ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndMultiple Method

Shapes.BpmnEndMultiple Method
[image]

Gets the BpmnEndMultiple predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BpmnEndMultiple ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndTerminate Method

Shapes.BpmnEndTerminate Method
[image]

Gets the BpmnEndTerminate predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BpmnEndTerminate ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEventBasedXor Method

Shapes.BpmnEventBasedXor Method
[image]

Gets the BpmnEventBasedXor predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BpmnEventBasedXor ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnInclusive Method

Shapes.BpmnInclusive Method
[image]

Gets the BpmnInclusive predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BpmnInclusive ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateCancel Method

Shapes.BpmnIntermediateCancel Method
[image]

Gets the BpmnIntermediateCancel predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BpmnIntermediateCancel ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateCompensation Method

Shapes.BpmnIntermediateCompensation Method
[image]

Gets the BpmnIntermediateCompensation predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BpmnIntermediateCompensation ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateError Method

Shapes.BpmnIntermediateError Method
[image]

Gets the BpmnIntermediateError predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BpmnIntermediateError ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateLink Method

Shapes.BpmnIntermediateLink Method
[image]

Gets the BpmnIntermediateLink predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BpmnIntermediateLink ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateMessage Method

Shapes.BpmnIntermediateMessage Method
[image]

Gets the BpmnIntermediateMessage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BpmnIntermediateMessage ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateMultiple Method

Shapes.BpmnIntermediateMultiple Method
[image]

Gets the BpmnIntermediateMultiple predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BpmnIntermediateMultiple ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateRule Method

Shapes.BpmnIntermediateRule Method
[image]

Gets the BpmnIntermediateRule predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BpmnIntermediateRule ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateTimer Method

Shapes.BpmnIntermediateTimer Method
[image]

Gets the BpmnIntermediateTimer predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BpmnIntermediateTimer ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnParallelFork Method

Shapes.BpmnParallelFork Method
[image]

Gets the BpmnParallelFork predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BpmnParallelFork ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnStartLink Method

Shapes.BpmnStartLink Method
[image]

Gets the BpmnStartLink predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BpmnStartLink ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnStartMessage Method

Shapes.BpmnStartMessage Method
[image]

Gets the BpmnStartMessage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BpmnStartMessage ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnStartMultiple Method

Shapes.BpmnStartMultiple Method
[image]

Gets the BpmnStartMultiple predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BpmnStartMultiple ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnStartRule Method

Shapes.BpmnStartRule Method
[image]

Gets the BpmnStartRule predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BpmnStartRule ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnStartTimer Method

Shapes.BpmnStartTimer Method
[image]

Gets the BpmnStartTimer predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function BpmnStartTimer ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Circle Method

Shapes.Circle Method
[image]

Gets the Circle predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Circle ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Cloud Method

Shapes.Cloud Method
[image]

Gets the Cloud predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Cloud ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Collate Method

Shapes.Collate Method
[image]

Gets the Collate predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Collate ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.ConeDown Method

Shapes.ConeDown Method
[image]

Gets the ConeDown predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function ConeDown ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.ConeUp Method

Shapes.ConeUp Method
[image]

Gets the ConeUp predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function ConeUp ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.ConnectedIssues Method

Shapes.ConnectedIssues Method
[image]

Gets the ConnectedIssues predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function ConnectedIssues ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.CreateRequest Method

Shapes.CreateRequest Method
[image]

Gets the CreateRequest predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function CreateRequest ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Cross Method

Shapes.Cross Method
[image]

Gets the Cross predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Cross ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Cube Method

Shapes.Cube Method
[image]

Gets the Cube predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Cube ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Cylinder Method

Shapes.Cylinder Method
[image]

Gets the Cylinder predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Cylinder ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Database Method

Shapes.Database Method
[image]

Gets the Database predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Database ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DataTransmition Method

Shapes.DataTransmition Method
[image]

Gets the DataTransmition predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function DataTransmition ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DDelay Method

Shapes.DDelay Method
[image]

Gets the DDelay predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function DDelay ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Decagon Method

Shapes.Decagon Method
[image]

Gets the Decagon predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Decagon ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Decision Method

Shapes.Decision Method
[image]

Gets the Decision predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Decision ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Decision2 Method

Shapes.Decision2 Method
[image]

Gets the Decision2 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Decision2 ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DefaultFlow Method

Shapes.DefaultFlow Method
[image]

Gets the DefaultFlow predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function DefaultFlow ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Delay Method

Shapes.Delay Method
[image]

Gets the Delay predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Delay ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DInDelay Method

Shapes.DInDelay Method
[image]

Gets the DInDelay predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function DInDelay ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DirectAccessStorage Method

Shapes.DirectAccessStorage Method
[image]

Gets the DirectAccessStorage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function DirectAccessStorage ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DiskStorage Method

Shapes.DiskStorage Method
[image]

Gets the DiskStorage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function DiskStorage ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Display Method

Shapes.Display Method
[image]

Gets the Display predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Display ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DividedEvent Method

Shapes.DividedEvent Method
[image]

Gets the DividedEvent predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function DividedEvent ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DividedProcess Method

Shapes.DividedProcess Method
[image]

Gets the DividedProcess predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function DividedProcess ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Document Method

Shapes.Document Method
[image]

Gets the Document predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Document ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Donut Method

Shapes.Donut Method
[image]

Gets the Donut predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Donut ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DoubleArrow Method

Shapes.DoubleArrow Method
[image]

Gets the DoubleArrow predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function DoubleArrow ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DOutDelay Method

Shapes.DOutDelay Method
[image]

Gets the DOutDelay predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function DOutDelay ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Ellipse Method

Shapes.Ellipse Method
[image]

Gets the Ellipse predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Ellipse ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.EndLoop Method

Shapes.EndLoop Method
[image]

Gets the EndLoop predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function EndLoop ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.ExternalOrganization Method

Shapes.ExternalOrganization Method
[image]

Gets the ExternalOrganization predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function ExternalOrganization ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.ExternalProcess Method

Shapes.ExternalProcess Method
[image]

Gets the ExternalProcess predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function ExternalProcess ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.File Method

Shapes.File Method
[image]

Gets the File predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function File ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.FramedRectangle Method

Shapes.FramedRectangle Method
[image]

Gets the FramedRectangle predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function FramedRectangle ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Gate Method

Shapes.Gate Method
[image]

Gets the Gate predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Gate ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Heart Method

Shapes.Heart Method
[image]

Gets the Heart predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Heart ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Heptagon Method

Shapes.Heptagon Method
[image]

Gets the Heptagon predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Heptagon ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Hourglass Method

Shapes.Hourglass Method
[image]

Gets the Hourglass predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Hourglass ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Input Method

Shapes.Input Method
[image]

Gets the Input predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Input ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.InternalStorage Method

Shapes.InternalStorage Method
[image]

Gets the InternalStorage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function InternalStorage ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Interrupt Method

Shapes.Interrupt Method
[image]

Gets the Interrupt predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Interrupt ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Interrupt2 Method

Shapes.Interrupt2 Method
[image]

Gets the Interrupt2 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Interrupt2 ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.IsoProcess Method

Shapes.IsoProcess Method
[image]

Gets the IsoProcess predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function IsoProcess ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Junction Method

Shapes.Junction Method
[image]

Gets the Junction predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Junction ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Lightning Method

Shapes.Lightning Method
[image]

Gets the Lightning predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Lightning ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.LinedDocument Method

Shapes.LinedDocument Method
[image]

Gets the LinedDocument predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function LinedDocument ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.ManualOperation Method

Shapes.ManualOperation Method
[image]

Gets the ManualOperation predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function ManualOperation ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Merge Method

Shapes.Merge Method
[image]

Gets the Merge predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Merge ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.MessageFromUser Method

Shapes.MessageFromUser Method
[image]

Gets the MessageFromUser predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function MessageFromUser ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.MessageToUser Method

Shapes.MessageToUser Method
[image]

Gets the MessageToUser predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function MessageToUser ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Microform Method

Shapes.Microform Method
[image]

Gets the Microform predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Microform ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.MicroformProcessing Method

Shapes.MicroformProcessing Method
[image]

Gets the MicroformProcessing predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function MicroformProcessing ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.MicroformRecording Method

Shapes.MicroformRecording Method
[image]

Gets the MicroformRecording predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function MicroformRecording ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.MultiDocument Method

Shapes.MultiDocument Method
[image]

Gets the MultiDocument predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function MultiDocument ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.MultiProc Method

Shapes.MultiProc Method
[image]

Gets the MultiProc predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function MultiProc ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Octagon Method

Shapes.Octagon Method
[image]

Gets the Octagon predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Octagon ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.OfflineStorage Method

Shapes.OfflineStorage Method
[image]

Gets the OfflineStorage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function OfflineStorage ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.OffpageConnection Method

Shapes.OffpageConnection Method
[image]

Gets the OffpageConnection predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function OffpageConnection ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.OffpageReference Method

Shapes.OffpageReference Method
[image]

Gets the OffpageReference predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function OffpageReference ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Or Method

Shapes.Or Method
[image]

Gets the Or predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Or ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Pentagon Method

Shapes.Pentagon Method
[image]

Gets the Pentagon predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Pentagon ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.PentagonArrow Method

Shapes.PentagonArrow Method
[image]

Gets the PentagonArrow predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function PentagonArrow ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Plaque Method

Shapes.Plaque Method
[image]

Gets the Plaque predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Plaque ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.PointerArrow Method

Shapes.PointerArrow Method
[image]

Gets the PointerArrow predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function PointerArrow ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.PrimitiveFromCall Method

Shapes.PrimitiveFromCall Method
[image]

Gets the PrimitiveFromCall predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function PrimitiveFromCall ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.PrimitiveToCall Method

Shapes.PrimitiveToCall Method
[image]

Gets the PrimitiveToCall predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function PrimitiveToCall ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Procedure Method

Shapes.Procedure Method
[image]

Gets the Procedure predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Procedure ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Process Method

Shapes.Process Method
[image]

Gets the Process predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Process ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Prysm Method

Shapes.Prysm Method
[image]

Gets the Prysm predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Prysm ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.PunchedCard Method

Shapes.PunchedCard Method
[image]

Gets the PunchedCard predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function PunchedCard ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.PyramidDown Method

Shapes.PyramidDown Method
[image]

Gets the PyramidDown predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function PyramidDown ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.PyramidUp Method

Shapes.PyramidUp Method
[image]

Gets the PyramidUp predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function PyramidUp ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Quill Method

Shapes.Quill Method
[image]

Gets the Quill predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Quill ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Rectangle Method

Shapes.Rectangle Method
[image]

Gets the Rectangle predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Rectangle ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Reversed Method

Shapes.Reversed Method
[image]

Gets the Reversed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Reversed ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.RevTriangle Method

Shapes.RevTriangle Method
[image]

Gets the RevTriangle predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function RevTriangle ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.RevWithCirc Method

Shapes.RevWithCirc Method
[image]

Gets the RevWithCirc predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function RevWithCirc ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.RevWithLine Method

Shapes.RevWithLine Method
[image]

Gets the RevWithLine predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function RevWithLine ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Rhombus Method

Shapes.Rhombus Method
[image]

Gets the Rhombus predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Rhombus ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.RightTriangle Method

Shapes.RightTriangle Method
[image]

Gets the RightTriangle predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function RightTriangle ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.RoundRect Method

Shapes.RoundRect Method
[image]

Gets the RoundRect predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function RoundRect ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.RSave Method

Shapes.RSave Method
[image]

Gets the RSave predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function RSave ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Save Method

Shapes.Save Method
[image]

Gets the Save predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Save ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Slash Method

Shapes.Slash Method
[image]

Gets the Slash predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Slash ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Sort Method

Shapes.Sort Method
[image]

Gets the Sort predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Sort ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Sphere Method

Shapes.Sphere Method
[image]

Gets the Sphere predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Sphere ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star Method

Shapes.Star Method
[image]

Gets the Star predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Star ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star16Pointed Method

Shapes.Star16Pointed Method
[image]

Gets the Star16Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Star16Pointed ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star24Pointed Method

Shapes.Star24Pointed Method
[image]

Gets the Star24Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Star24Pointed ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star32Pointed Method

Shapes.Star32Pointed Method
[image]

Gets the Star32Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Star32Pointed ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star4Pointed Method

Shapes.Star4Pointed Method
[image]

Gets the Star4Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Star4Pointed ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star5Pointed Method

Shapes.Star5Pointed Method
[image]

Gets the Star5Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Star5Pointed ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star6Pointed Method

Shapes.Star6Pointed Method
[image]

Gets the Star6Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Star6Pointed ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star7Pointed Method

Shapes.Star7Pointed Method
[image]

Gets the Star7Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Star7Pointed ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Start Method

Shapes.Start Method
[image]

Gets the Start predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Start ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Tape Method

Shapes.Tape Method
[image]

Gets the Tape predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Tape ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Terminator Method

Shapes.Terminator Method
[image]

Gets the Terminator predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Terminator ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Tetragon Method

Shapes.Tetragon Method
[image]

Gets the Tetragon predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Tetragon ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.TransmittalTape Method

Shapes.TransmittalTape Method
[image]

Gets the TransmittalTape predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function TransmittalTape ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Trapezoid Method

Shapes.Trapezoid Method
[image]

Gets the Trapezoid predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Trapezoid ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Triangle Method

Shapes.Triangle Method
[image]

Gets the Triangle predefined shape.

Namespace: MindFusion.Diagramming
Assembly: Shapes.js

Syntax

JavaScript [image] Copy Code

function Triangle ()

Return Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.ShowAnchors Enumeration

ShowAnchors Enumeration
[image]

Specifies when anchors points should be displayed.

Namespace: MindFusion.Diagramming
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
ShowAnchors = {}

Members

Member name | Description
Always | Anchor point marks are always painted.
Auto | Anchor point marks are shown for the node under the mouse cursor.
Never | Anchor point marks are never painted.
Selected | Anchor point marks are painted for the selected node.

See Also


MindFusion.Diagramming.SimpleShape Enumeration

SimpleShape Enumeration
[image]

Defines the possible values for Shape property of tables and containers.

Namespace: MindFusion.Diagramming
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
SimpleShape = {}

Members

Member name | Description
Rectangle | Sets node's shape to rectangle.
RoundedRectangle | Sets node's shape to rounded rectangle.

See Also


MindFusion.Diagramming.Style Class

Style Class
Remarks See Also
[image]

Represents a set of appearance properties whose values can be inherited from parent objects if not set locally for an item.

Namespace: MindFusion.Diagramming
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

// class
Style.prototype = {}

Remarks

An instance of this class can be used to set items' appearance properties as a single unit via the setStyle method. In order for style attributes to be used, the respective local appearance properties of a DiagramItem objects must have undefined or null values. If an item's Style does not define a value for some attribute, it is looked up in the styling hierarchy, first in the diagram's Style, next in the current Theme, and finally in the set of default styles defined for each item class.

Inheritance Hierarchy

See Also

Style Members


MindFusion.Diagramming.Style Members

Style Members
Constructors Methods
[image]

Represents a set of appearance properties whose values can be inherited from parent objects if not set locally for an item.

The following tables list the members exposed by the Style type.

Public Constructors

Name | Description
Style | Initializes a new instance of the Style class.

Public Methods

Name | Description
getBackBrush | Gets the brush used to fill the diagram background.
getBrush | Gets the brush used to fill the interior of diagram items.
getFontName | Gets the name of the font used to draw text of diagram items.
getFontSize | Gets the size of the font used to draw text of diagram items.
getFontStyle | Gets the style of the font used to draw text of diagram items.
getNodeEffects | Gets a list with all effects applied to the nodes of this diagram.
getShadowColor | Gets the color used to draw shadows of diagram items.
getStroke | Gets the color used to stroke the frame of diagram items.
getStrokeDashStyle | Gets the line dash pattern applied when stroking the frame of diagram items.
getStrokeThickness | Gets the line width applied when stroking the frame of diagram items.
getTextColor | Gets the color used to draw text of diagram items.
setBackBrush | Sets an object that specifies how to paint the interior of the diagram background.
setBrush | Sets an object that specifies how to paint the interior of diagram items.
setFontName | Sets the name of the font used to draw text of diagram items.
setFontSize | Sets the size of the font used to draw text of diagram items.
setFontStyle | Sets the style of the font used to draw text of diagram items.
setNodeEffects | Sets a list with all effects applied to the nodes of this diagram.
setShadowColor | Sets the color used to draw shadows of diagram items.
setStroke | Sets the color used to stroke the frame of diagram items.
setStrokeDashStyle | Sets the line dash pattern applied when stroking the frame of diagram items.
setStrokeThickness | Sets the line width applied when stroking the frame of diagram items.
setTextColor | Sets the color used to draw text of diagram items.

See Also

Style Class


MindFusion.Diagramming.Style Constructor

Style Constructor
[image]

Initializes a new instance of the Style class.

Namespace: MindFusion.Diagramming
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function Style ([prototype])

Parameters

prototype
Optional.

See Also

Style Class


MindFusion.Diagramming.Style Methods

Style Methods
[image]

Public Methods

Name | Description
getBackBrush | Gets the brush used to fill the diagram background.
getBrush | Gets the brush used to fill the interior of diagram items.
getFontName | Gets the name of the font used to draw text of diagram items.
getFontSize | Gets the size of the font used to draw text of diagram items.
getFontStyle | Gets the style of the font used to draw text of diagram items.
getNodeEffects | Gets a list with all effects applied to the nodes of this diagram.
getShadowColor | Gets the color used to draw shadows of diagram items.
getStroke | Gets the color used to stroke the frame of diagram items.
getStrokeDashStyle | Gets the line dash pattern applied when stroking the frame of diagram items.
getStrokeThickness | Gets the line width applied when stroking the frame of diagram items.
getTextColor | Gets the color used to draw text of diagram items.
setBackBrush | Sets an object that specifies how to paint the interior of the diagram background.
setBrush | Sets an object that specifies how to paint the interior of diagram items.
setFontName | Sets the name of the font used to draw text of diagram items.
setFontSize | Sets the size of the font used to draw text of diagram items.
setFontStyle | Sets the style of the font used to draw text of diagram items.
setNodeEffects | Sets a list with all effects applied to the nodes of this diagram.
setShadowColor | Sets the color used to draw shadows of diagram items.
setStroke | Sets the color used to stroke the frame of diagram items.
setStrokeDashStyle | Sets the line dash pattern applied when stroking the frame of diagram items.
setStrokeThickness | Sets the line width applied when stroking the frame of diagram items.
setTextColor | Sets the color used to draw text of diagram items.

See Also

Style Class


MindFusion.Diagramming.Style.getBackBrush Method

Style.getBackBrush Method
[image]

Gets the brush used to fill the diagram background.

Namespace: MindFusion.Diagramming
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function getBackBrush ()

Return Value

A brush object specifying the fill of the diagram background.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.getBrush Method

Style.getBrush Method
[image]

Gets the brush used to fill the interior of diagram items.

Namespace: MindFusion.Diagramming
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function getBrush ()

Return Value

A brush object specifying the fill of diagram items.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.getFontName Method

Style.getFontName Method
[image]

Gets the name of the font used to draw text of diagram items.

Namespace: MindFusion.Diagramming
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function getFontName ()

Return Value

A string value identifying the font name of diagram items.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.getFontSize Method

Style.getFontSize Method
[image]

Gets the size of the font used to draw text of diagram items.

Namespace: MindFusion.Diagramming
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function getFontSize ()

Return Value

A number identifying the font size of diagram items.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.getFontStyle Method

Style.getFontStyle Method
[image]

Gets the style of the font used to draw text of diagram items.

Namespace: MindFusion.Diagramming
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function getFontStyle ()

Return Value

A combination of FontStyle enumeration members.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.getNodeEffects Method

Style.getNodeEffects Method
[image]

Gets a list with all effects applied to the nodes of this diagram.

Namespace: MindFusion.Diagramming
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function getNodeEffects ()

Return Value

A list with all effects applied to the nodes of this diagram.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.getShadowColor Method

Style.getShadowColor Method
[image]

Gets the color used to draw shadows of diagram items.

Namespace: MindFusion.Diagramming
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function getShadowColor ()

Return Value

A string value identifying the shadow color of diagram items.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.getStroke Method

Style.getStroke Method
[image]

Gets the color used to stroke the frame of diagram items.

Namespace: MindFusion.Diagramming
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function getStroke ()

Return Value

A string value identifying the stroke color of diagram items.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.getStrokeDashStyle Method

Style.getStrokeDashStyle Method
[image]

Gets the line dash pattern applied when stroking the frame of diagram items.

Namespace: MindFusion.Diagramming
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function getStrokeDashStyle ()

Return Value

A member of the DashStyle enumeration.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.getStrokeThickness Method

Style.getStrokeThickness Method
[image]

Gets the line width applied when stroking the frame of diagram items.

Namespace: MindFusion.Diagramming
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function getStrokeThickness ()

Return Value

A number identifying the stroke thickness of diagram items.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.getTextColor Method

Style.getTextColor Method
[image]

Gets the color used to draw text of diagram items.

Namespace: MindFusion.Diagramming
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function getTextColor ()

Return Value

A string value identifying the text color of diagram items.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.setBackBrush Method

Style.setBackBrush Method
[image]

Sets an object that specifies how to paint the interior of the diagram background.

Namespace: MindFusion.Diagramming
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function setBackBrush (value)

Parameters

value

A brush object specifying the fill of the diagram background.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.setBrush Method

Style.setBrush Method
[image]

Sets an object that specifies how to paint the interior of diagram items.

Namespace: MindFusion.Diagramming
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function setBrush (value)

Parameters

value

A brush object specifying the fill of diagram items.

See Also

Style Members
Style Class
MindFusion.Diagramming Namespace
setStroke Method
setShadowColor Method


MindFusion.Diagramming.Style.setFontName Method

Style.setFontName Method
[image]

Sets the name of the font used to draw text of diagram items.

Namespace: MindFusion.Diagramming
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function setFontName (value)

Parameters

value

A string value identifying the font name of diagram items.

See Also

Style Members
Style Class
setFontSize Method


MindFusion.Diagramming.Style.setFontSize Method

Style.setFontSize Method
[image]

Sets the size of the font used to draw text of diagram items.

Namespace: MindFusion.Diagramming
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function setFontSize (A)

Parameters

A

number identifying the font size of diagram items.

See Also

Style Members
Style Class
MindFusion.Diagramming Namespace
setFontName Method
setTextColor Method


MindFusion.Diagramming.Style.setFontStyle Method

Style.setFontStyle Method
[image]

Sets the style of the font used to draw text of diagram items.

Namespace: MindFusion.Diagramming
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function setFontStyle (value)

Parameters

value

A combination of FontStyle enumeration members.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.setNodeEffects Method

Style.setNodeEffects Method
[image]

Sets a list with all effects applied to the nodes of this diagram.

Namespace: MindFusion.Diagramming
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function setNodeEffects (value)

Parameters

value

A list with all effects applied to the nodes of this diagram.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.setShadowColor Method

Style.setShadowColor Method
[image]

Sets the color used to draw shadows of diagram items.

Namespace: MindFusion.Diagramming
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function setShadowColor (value)

Parameters

value

A string value identifying the shadow color of diagram items.

See Also

Style Members
Style Class
setBrush Method


MindFusion.Diagramming.Style.setStroke Method

Style.setStroke Method
[image]

Sets the color used to stroke the frame of diagram items.

Namespace: MindFusion.Diagramming
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function setStroke (value)

Parameters

value

A string value identifying the stroke color of diagram items.

See Also

Style Members
Style Class
MindFusion.Diagramming Namespace
setBrush Method
setStrokeThickness Method


MindFusion.Diagramming.Style.setStrokeDashStyle Method

Style.setStrokeDashStyle Method
[image]

Sets the line dash pattern applied when stroking the frame of diagram items.

Namespace: MindFusion.Diagramming
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function setStrokeDashStyle (value)

Parameters

value

A member of the DashStyle enumeration.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.setStrokeThickness Method

Style.setStrokeThickness Method
[image]

Sets the line width applied when stroking the frame of diagram items.

Namespace: MindFusion.Diagramming
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function setStrokeThickness (value)

Parameters

value

A number identifying the stroke thickness of diagram items.

See Also

Style Members
Style Class
setStroke Method


MindFusion.Diagramming.Style.setTextColor Method

Style.setTextColor Method
[image]

Sets the color used to draw text of diagram items.

Namespace: MindFusion.Diagramming
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function setTextColor (value)

Parameters

value

A string value identifying the text color of diagram items.

See Also

Style Members
Style Class
MindFusion.Diagramming Namespace
setFontName Method
setFontSize Method


MindFusion.Diagramming.SvgContent Class

SvgContent Class
[image]

SvgContent represents the markup code of an SVG drawing.

Namespace: MindFusion.Diagramming
Assembly: SvgNode.js

Syntax

JavaScript [image] Copy Code

// class
SvgContent.prototype = {}

Inheritance Hierarchy

See Also

SvgContent Members


MindFusion.Diagramming.SvgContent Members

SvgContent Members
Methods
[image]

SvgContent represents the markup code of an SVG drawing.

The following tables list the members exposed by the SvgContent type.

Public Methods

Name | Description
parse | Loads SVG code from the specified file.
parseSvg | Loads SVG code from the specified string.

See Also

SvgContent Class


MindFusion.Diagramming.SvgContent Methods

SvgContent Methods
[image]

Public Methods

Name | Description
parse | Loads SVG code from the specified file.
parseSvg | Loads SVG code from the specified string.

See Also

SvgContent Class


MindFusion.Diagramming.SvgContent.parse Method

SvgContent.parse Method
[image]

Loads SVG code from the specified file.

Namespace: MindFusion.Diagramming
Assembly: SvgNode.js

Syntax

JavaScript [image] Copy Code

function parse (value)

Parameters

value

A string specifying the SVG file location.

Remarks

The MIME type of .svg files on server should be set to image/svg+xml.

See Also

SvgContent Members
SvgContent Class


MindFusion.Diagramming.SvgContent.parseSvg Method

SvgContent.parseSvg Method
[image]

Loads SVG code from the specified string.

Namespace: MindFusion.Diagramming
Assembly: SvgNode.js

Syntax

JavaScript [image] Copy Code

function parseSvg (value)

Parameters

value

A string containing the SVG markup code.

See Also

SvgContent Members
SvgContent Class


MindFusion.Diagramming.SvgNode Class

SvgNode Class
Remarks See Also
[image]

SvgNode instances are diagram nodes that can render SVG drawings.

Namespace: MindFusion.Diagramming
Assembly: SvgNode.js

Syntax

JavaScript [image] Copy Code

// class
SvgNode.prototype = {}

Remarks

An SvgNode instance represents nodes that can display SVG drawings in addition to the rendering provided by the base ShapeNode class. The SVG drawing of a node is specified through its Content property. The SVG graphics are loaded and associated with the node through an SvgContent object, which should be initialized and then assigned to this property. Note that the MIME type of .svg files on server should be set to image/svg+xml.

Example

The following code illustrates how to load SVG graphics from a server file and associate it with a new SvgNode:

JavaScript [image] Copy Code
var node = diagram.getFactory().createSvgNode(bounds);
node.setTransparent(true); // hide ShapeNode geometry

var svg = new SvgContent();
svg.parse("image.svg");
node.setContent(svg);

Inheritance Hierarchy

See Also

SvgNode Members


MindFusion.Diagramming.SvgNode Members

SvgNode Members
Constructors Methods
[image]

SvgNode instances are diagram nodes that can render SVG drawings.

The following tables list the members exposed by the SvgNode type.

Public Constructors

Name | Description
SvgNode | Initializes a new instance of the SvgNode class with default values supplied from the specified Diagram.

Public Methods

Name | Description
getContent | Gets an SvgContent instance representing the SVG drawing rendered in this node.
setContent | Sets an SvgContent instance representing the SVG drawing rendered in this node.

See Also

SvgNode Class


MindFusion.Diagramming.SvgNode Constructor

SvgNode Constructor
[image]

Initializes a new instance of the SvgNode class with default values supplied from the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: SvgNode.js

Syntax

JavaScript [image] Copy Code

function SvgNode ([parent])

Parameters

parent
Optional.

The Diagram from which to obtain default values for the node properties.

See Also

SvgNode Class


MindFusion.Diagramming.SvgNode Methods

SvgNode Methods
[image]

Public Methods

Name | Description
getContent | Gets an SvgContent instance representing the SVG drawing rendered in this node.
setContent | Sets an SvgContent instance representing the SVG drawing rendered in this node.

See Also

SvgNode Class


MindFusion.Diagramming.SvgNode.getContent Method

SvgNode.getContent Method
[image]

Gets an SvgContent instance representing the SVG drawing rendered in this node.

Namespace: MindFusion.Diagramming
Assembly: SvgNode.js

Syntax

JavaScript [image] Copy Code

function getContent ()

Return Value

An instance of the SvgContent class.

See Also

SvgNode Members
SvgNode Class


MindFusion.Diagramming.SvgNode.setContent Method

SvgNode.setContent Method
[image]

Sets an SvgContent instance representing the SVG drawing rendered in this node.

Namespace: MindFusion.Diagramming
Assembly: SvgNode.js

Syntax

JavaScript [image] Copy Code

function setContent (value)

Parameters

value

An instance of the SvgContent class.

See Also

SvgNode Members
SvgNode Class


MindFusion.Diagramming.TableConnectionPoint Class

TableConnectionPoint Class
[image]

A class that represents a connection between an edge and a node in a graph.

Namespace: MindFusion.Diagramming
Assembly: TableConnectionPoint.js

Syntax

JavaScript [image] Copy Code

// class
TableConnectionPoint.prototype = {}

Inheritance Hierarchy

See Also

TableConnectionPoint Members


MindFusion.Diagramming.TableConnectionPoint Members

TableConnectionPoint Members
Methods
[image]

A class that represents a connection between an edge and a node in a graph.

The following tables list the members exposed by the TableConnectionPoint type.

Public Methods

Name | Description
addLinkToNode | Adds the link associated with this connection point to the associated node.
getEndPoint | Calculates the coordinates of this connection point expressed in document coordinates.
getInitialPoint | Returns a point (usually the center of the bounding rectangle) contained within the associated node.
getIntersection | Calculates the intersection point between the specified line segment and the contour of the node associated with this connection point.
getNearestBorderPoint | Returns the nearest point lying on the node border.
linkChanges | Checks whether the link would change if attached to the specified node at the specified point.
removeLinkFromNode | Removes the link associated with this connection point from the associated node.
saveEndRelative | Updates the coordinates of the connection point represented by this link, relative to the bounding rectangle of the associated node.

See Also

TableConnectionPoint Class


MindFusion.Diagramming.TableConnectionPoint Methods

TableConnectionPoint Methods
[image]

Public Methods

Name | Description
addLinkToNode | Adds the link associated with this connection point to the associated node.
getEndPoint | Calculates the coordinates of this connection point expressed in document coordinates.
getInitialPoint | Returns a point (usually the center of the bounding rectangle) contained within the associated node.
getIntersection | Calculates the intersection point between the specified line segment and the contour of the node associated with this connection point.
getNearestBorderPoint | Returns the nearest point lying on the node border.
linkChanges | Checks whether the link would change if attached to the specified node at the specified point.
removeLinkFromNode | Removes the link associated with this connection point from the associated node.
saveEndRelative | Updates the coordinates of the connection point represented by this link, relative to the bounding rectangle of the associated node.

See Also

TableConnectionPoint Class


MindFusion.Diagramming.TableConnectionPoint.addLinkToNode Method

TableConnectionPoint.addLinkToNode Method
[image]

Adds the link associated with this connection point to the associated node.

Namespace: MindFusion.Diagramming
Assembly: TableConnectionPoint.js

Syntax

JavaScript [image] Copy Code

function addLinkToNode ()

See Also

TableConnectionPoint Members
TableConnectionPoint Class


MindFusion.Diagramming.TableConnectionPoint.getEndPoint Method

TableConnectionPoint.getEndPoint Method
[image]

Calculates the coordinates of this connection point expressed in document coordinates.

Namespace: MindFusion.Diagramming
Assembly: TableConnectionPoint.js

Syntax

JavaScript [image] Copy Code

function getEndPoint ()

Return Value

A Point that represents the coordinate.

See Also

TableConnectionPoint Members
TableConnectionPoint Class


MindFusion.Diagramming.TableConnectionPoint.getInitialPoint Method

TableConnectionPoint.getInitialPoint Method
[image]

Returns a point (usually the center of the bounding rectangle) contained within the associated node.

Namespace: MindFusion.Diagramming
Assembly: TableConnectionPoint.js

Syntax

JavaScript [image] Copy Code

function getInitialPoint ()

Return Value

A Point contained within the node.

See Also

TableConnectionPoint Members
TableConnectionPoint Class


MindFusion.Diagramming.TableConnectionPoint.getIntersection Method

TableConnectionPoint.getIntersection Method
[image]

Calculates the intersection point between the specified line segment and the contour of the node associated with this connection point.

Namespace: MindFusion.Diagramming
Assembly: TableConnectionPoint.js

Syntax

JavaScript [image] Copy Code

function getIntersection (point1, point2)

Parameters

point1

The first point of the segment.

point2

The second point of the segment.

Return Value

A Point object representing the intersection point.

See Also

TableConnectionPoint Members
TableConnectionPoint Class


MindFusion.Diagramming.TableConnectionPoint.getNearestBorderPoint Method

TableConnectionPoint.getNearestBorderPoint Method
[image]

Returns the nearest point lying on the node border.

Namespace: MindFusion.Diagramming
Assembly: TableConnectionPoint.js

Syntax

JavaScript [image] Copy Code

function getNearestBorderPoint (point)

Parameters

point

A Point instance specifying location in the diagram.

Return Value

An AnchorPointDetails specifying the anchor point properties.

See Also

TableConnectionPoint Members
TableConnectionPoint Class


MindFusion.Diagramming.TableConnectionPoint.linkChanges Method

TableConnectionPoint.linkChanges Method
[image]

Checks whether the link would change if attached to the specified node at the specified point.

Namespace: MindFusion.Diagramming
Assembly: TableConnectionPoint.js

Syntax

JavaScript [image] Copy Code

function linkChanges (item, point)

Parameters

item

A DiagramItem under the mouse cursor.

point

A point where the link will be connected.

Return Value

true if the link would connect to a different entity if dropped at the specified location; otherwise, false.

See Also

TableConnectionPoint Members
TableConnectionPoint Class


MindFusion.Diagramming.TableConnectionPoint.removeLinkFromNode Method

TableConnectionPoint.removeLinkFromNode Method
[image]

Removes the link associated with this connection point from the associated node.

Namespace: MindFusion.Diagramming
Assembly: TableConnectionPoint.js

Syntax

JavaScript [image] Copy Code

function removeLinkFromNode ()

See Also

TableConnectionPoint Members
TableConnectionPoint Class


MindFusion.Diagramming.TableConnectionPoint.saveEndRelative Method

TableConnectionPoint.saveEndRelative Method
[image]

Updates the coordinates of the connection point represented by this link, relative to the bounding rectangle of the associated node.

Namespace: MindFusion.Diagramming
Assembly: TableConnectionPoint.js

Syntax

JavaScript [image] Copy Code

function saveEndRelative ()

See Also

TableConnectionPoint Members
TableConnectionPoint Class


MindFusion.Diagramming.TableNode Class

TableNode Class
Remarks See Also
[image]

TableNode instances are diagram nodes that can be used to display tabular or list data.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

// class
TableNode.prototype = {}

Remarks

Tables consist of Cell instances distributed across rows and columns. The number of rows and columns can be set by calling the redimTable method. Cells can be made to span several rows and columns by setting their RowSpan and ColumnSpan properties to values larger than one.

The structure of a table can be dynamically changed by adding and deleting rows and columns. This can be done with the addColumn and addRow methods as well as with the insertColumn, insertRow and redimTable methods. deleteRow and deleteColumn methods delete existing rows and columns.

Table cells can display text as specified via their setText, setTextColor and setTextAlignment methods. Cells can also contain images, specified via the setImage and setImageAlign methods. Table nodes can show a caption in their title bar, whose text is set via the Text property. The height of the caption bar is set via the CaptionHeight property.

Inheritance Hierarchy

See Also

TableNode Members


MindFusion.Diagramming.TableNode Members

TableNode Members
Constructors Methods
[image]

TableNode instances are diagram nodes that can be used to display tabular or list data.

The following tables list the members exposed by the TableNode type.

Public Constructors

Name | Description
TableNode | Initializes a new instance of the TableNode class with default values supplied from the specified Diagram.

Public Methods

Name | Description
addColumn | Adds a new column to the table.
addRow | Adds a new row to the table.
cellFromPoint | Returns the cell that contains the specified point.
containsPoint | Checks if the TableNode contains the specified point.
createConnectionPoint | Creates a connection point between this node and the specified link at the specified point.
deleteColumn | Deletes the specified column.
deleteRow | Deletes the specified row.
getAllowResizeColumns | Gets a value indicating whether users are allowed to resize table columns.
getAllowResizeRows | Gets a value indicating whether users are allowed to resize table rows.
getCaptionBackBrush | Gets the object that specifies how to fill the caption bar.
getCaptionFont | Gets the font used to render the table's caption text.
getCaptionHeight | Gets the height of the table's caption area.
getCell | Returns a reference to the cell located at the specified column and row of this table.
getCellFrameStyle | Gets the style of the cell frame lines.
getColumn | Returns a reference to the column at the specified position within the table's list of columns.
getEnableStyledText | Gets a value indicating whether styled text rendering is enabled.
getOutline | Gets an array of points that define the outline of this node shape.
getRow | Returns a reference to the row at the specified position within the table's list of rows.
getRowRect | Returns the bounding rectangle of the specified row.
getScrollable | Gets a value indicating whether the user is allowed to scroll the table rows.
getShape | Gets the shape of the table's outline.
insertColumn | Inserts a new column at the specified position.
insertRow | Inserts a new row at the specified position.
redimTable | Changes the number of columns and rows in this table.
rowFromPoint | Returns the index of the table's row that contains the specified point.
scrollDown | Scrolls the table's rows down.
scrollUp | Scrolls the table's rows up.
setAllowResizeColumns | Sets a value indicating whether users are allowed to resize table columns.
setAllowResizeRows | Sets a value indicating whether users are allowed to resize table rows.
setCaptionBackBrush | Sets an object that specifies how to fill the caption bar.
setCaptionFont | Sets the font used to render the table's caption text.
setCaptionHeight | Sets the height of the table's caption area.
setCellFrameStyle | Sets the style of the cell frame lines.
setCurrScrollRow | Sets the table's current scroll position.
setEnableStyledText | Sets a value indicating whether styled text rendering is enabled.
setScrollable | Sets a value indicating whether the user is allowed to scroll the table rows.
setShape | Sets the shape of the table's outline.

See Also

TableNode Class


MindFusion.Diagramming.TableNode Constructor

TableNode Constructor
[image]

Initializes a new instance of the TableNode class with default values supplied from the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function TableNode ([parent])

Parameters

parent
Optional.

The Diagram from which to obtain default values for the node properties.

See Also

TableNode Class


MindFusion.Diagramming.TableNode Methods

TableNode Methods
[image]

Public Methods

Name | Description
addColumn | Adds a new column to the table.
addRow | Adds a new row to the table.
cellFromPoint | Returns the cell that contains the specified point.
containsPoint | Checks if the TableNode contains the specified point.
createConnectionPoint | Creates a connection point between this node and the specified link at the specified point.
deleteColumn | Deletes the specified column.
deleteRow | Deletes the specified row.
getAllowResizeColumns | Gets a value indicating whether users are allowed to resize table columns.
getAllowResizeRows | Gets a value indicating whether users are allowed to resize table rows.
getCaptionBackBrush | Gets the object that specifies how to fill the caption bar.
getCaptionFont | Gets the font used to render the table's caption text.
getCaptionHeight | Gets the height of the table's caption area.
getCell | Returns a reference to the cell located at the specified column and row of this table.
getCellFrameStyle | Gets the style of the cell frame lines.
getColumn | Returns a reference to the column at the specified position within the table's list of columns.
getEnableStyledText | Gets a value indicating whether styled text rendering is enabled.
getOutline | Gets an array of points that define the outline of this node shape.
getRow | Returns a reference to the row at the specified position within the table's list of rows.
getRowRect | Returns the bounding rectangle of the specified row.
getScrollable | Gets a value indicating whether the user is allowed to scroll the table rows.
getShape | Gets the shape of the table's outline.
insertColumn | Inserts a new column at the specified position.
insertRow | Inserts a new row at the specified position.
redimTable | Changes the number of columns and rows in this table.
rowFromPoint | Returns the index of the table's row that contains the specified point.
scrollDown | Scrolls the table's rows down.
scrollUp | Scrolls the table's rows up.
setAllowResizeColumns | Sets a value indicating whether users are allowed to resize table columns.
setAllowResizeRows | Sets a value indicating whether users are allowed to resize table rows.
setCaptionBackBrush | Sets an object that specifies how to fill the caption bar.
setCaptionFont | Sets the font used to render the table's caption text.
setCaptionHeight | Sets the height of the table's caption area.
setCellFrameStyle | Sets the style of the cell frame lines.
setCurrScrollRow | Sets the table's current scroll position.
setEnableStyledText | Sets a value indicating whether styled text rendering is enabled.
setScrollable | Sets a value indicating whether the user is allowed to scroll the table rows.
setShape | Sets the shape of the table's outline.

See Also

TableNode Class


MindFusion.Diagramming.TableNode.addColumn Method

TableNode.addColumn Method
[image]

Adds a new column to the table.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function addColumn ()

Return Value

The newly created column object.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
deleteColumn Method
addRow Method
redimTable Method


MindFusion.Diagramming.TableNode.addRow Method

TableNode.addRow Method
[image]

Adds a new row to the table.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function addRow ()

Return Value

The newly created row object.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
deleteRow Method
addColumn Method
redimTable Method


MindFusion.Diagramming.TableNode.cellFromPoint Method

TableNode.cellFromPoint Method
[image]

Returns the cell that contains the specified point.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function cellFromPoint (point)

Parameters

point

A Point instance.

Return Value

A JavaScript object containing following fields:
{
cell: Cell reference,
cellRect: Rect,
column: Number,
row: Number
};

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.containsPoint Method

TableNode.containsPoint Method
[image]

Checks if the TableNode contains the specified point.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function containsPoint (point)

Parameters

point

The Point to check.

Return Value

true if the point is within the bounds of this node; otherwise, false.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.createConnectionPoint Method

TableNode.createConnectionPoint Method
[image]

Creates a connection point between this node and the specified link at the specified point.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function createConnectionPoint (link, point, incoming)

Parameters

link

A DiagramLink that should be connected to this node.

point

The point at which the link should be connected.

incoming

true if link is an incoming link, otherwise, false.

Return Value

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.deleteColumn Method

TableNode.deleteColumn Method
[image]

Deletes the specified column.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function deleteColumn (col)

Parameters

col

An integer value specifying which column to delete.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.deleteRow Method

TableNode.deleteRow Method
[image]

Deletes the specified row.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function deleteRow (row)

Parameters

row

An integer value specifying which row to delete.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.getAllowResizeColumns Method

TableNode.getAllowResizeColumns Method
[image]

Gets a value indicating whether users are allowed to resize table columns.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function getAllowResizeColumns ()

Return Value

true if users are allowed to resize table columns, otherwise false.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.getAllowResizeRows Method

TableNode.getAllowResizeRows Method
[image]

Gets a value indicating whether users are allowed to resize table rows.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function getAllowResizeRows ()

Return Value

true if users are allowed to resize table rows, otherwise false.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.getCaptionBackBrush Method

TableNode.getCaptionBackBrush Method
[image]

Gets the object that specifies how to fill the caption bar.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function getCaptionBackBrush ()

Return Value

An object specifying the fill of the caption bar.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.getCaptionFont Method

TableNode.getCaptionFont Method
[image]

Gets the font used to render the table's caption text.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function getCaptionFont ()

Return Value

An object specifying the font of the caption bar.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.getCaptionHeight Method

TableNode.getCaptionHeight Method
[image]

Gets the height of the table's caption area.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function getCaptionHeight ()

Return Value

A number specifying the height of the table caption. The default value is 6.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.getCell Method

TableNode.getCell Method
[image]

Returns a reference to the cell located at the specified column and row of this table.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function getCell (col, row)

Parameters

col

An integer value specifying the index of a table's column.

row

An integer value specifying the index of a table's row.

Return Value

A Cell instance representing the specified cell.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.getCellFrameStyle Method

TableNode.getCellFrameStyle Method
[image]

Gets the style of the cell frame lines.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function getCellFrameStyle ()

Return Value

A member of the CellFrameStyle enumeration.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.getColumn Method

TableNode.getColumn Method
[image]

Returns a reference to the column at the specified position within the table's list of columns.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function getColumn (col)

Parameters

col

An integer value specifying the index of a table's column.

Return Value

A JavaScript object representing the specified column.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.getEnableStyledText Method

TableNode.getEnableStyledText Method
[image]

Gets a value indicating whether styled text rendering is enabled.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function getEnableStyledText ()

Return Value

true to parse the node's text in order to find formatting tags, or false otherwise.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.getOutline Method

TableNode.getOutline Method
[image]

Gets an array of points that define the outline of this node shape.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function getOutline ()

Return Value

An array with the points.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.getRow Method

TableNode.getRow Method
[image]

Returns a reference to the row at the specified position within the table's list of rows.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function getRow (row)

Parameters

row

An integer value specifying the index of a table's row.

Return Value

A JavaScript object representing the specified row.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.getRowRect Method

TableNode.getRowRect Method
[image]

Returns the bounding rectangle of the specified row.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function getRowRect (row)

Parameters

row

An integer value specifying the index of a table's row.

Return Value

A Rect object representing the row's bounding rectangle.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.getScrollable Method

TableNode.getScrollable Method
[image]

Gets a value indicating whether the user is allowed to scroll the table rows.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function getScrollable ()

Return Value

true if the table can be scrolled; otherwise, false.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.getShape Method

TableNode.getShape Method
[image]

Gets the shape of the table's outline.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function getShape ()

Return Value

A member of the SimpleShape enumeration.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.insertColumn Method

TableNode.insertColumn Method
[image]

Inserts a new column at the specified position.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function insertColumn (col)

Parameters

col

An integer value specifying the position within the table's list of columns where the new column should be inserted.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.insertRow Method

TableNode.insertRow Method
[image]

Inserts a new row at the specified position.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function insertRow (row)

Parameters

row

An integer value specifying the position within the table's list of rows where the new row should be inserted.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.redimTable Method

TableNode.redimTable Method
[image]

Changes the number of columns and rows in this table.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function redimTable (columns, rows)

Parameters

columns

An integer value specifying the new number of columns.

rows

An integer value specifying the new number of rows.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.rowFromPoint Method

TableNode.rowFromPoint Method
[image]

Returns the index of the table's row that contains the specified point.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function rowFromPoint (point)

Parameters

point

A Point instance.

Return Value

An integer value specifying the row's index.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.scrollDown Method

TableNode.scrollDown Method
[image]

Scrolls the table's rows down.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function scrollDown ()

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.scrollUp Method

TableNode.scrollUp Method
[image]

Scrolls the table's rows up.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function scrollUp ()

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.setAllowResizeColumns Method

TableNode.setAllowResizeColumns Method
[image]

Sets a value indicating whether users are allowed to resize table columns.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function setAllowResizeColumns (value)

Parameters

value

true if users are allowed to resize table columns, otherwise false.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.setAllowResizeRows Method

TableNode.setAllowResizeRows Method
[image]

Sets a value indicating whether users are allowed to resize table rows.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function setAllowResizeRows (value)

Parameters

value

true if users are allowed to resize table rows, otherwise false.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.setCaptionBackBrush Method

TableNode.setCaptionBackBrush Method
[image]

Sets an object that specifies how to fill the caption bar.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function setCaptionBackBrush (value)

Parameters

value

A Brush object specifying the fill of the caption bar.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.setCaptionFont Method

TableNode.setCaptionFont Method
[image]

Sets the font used to render the table's caption text.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function setCaptionFont (value)

Parameters

value

An object specifying the font of the caption bar.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.setCaptionHeight Method

TableNode.setCaptionHeight Method
[image]

Sets the height of the table's caption area.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function setCaptionHeight (value)

Parameters

value

A number specifying the height of the table caption. The default value is 6.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.setCellFrameStyle Method

TableNode.setCellFrameStyle Method
[image]

Sets the style of the cell frame lines.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function setCellFrameStyle (value)

Parameters

value

A member of the CellFrameStyle enumeration.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.setCurrScrollRow Method

TableNode.setCurrScrollRow Method
[image]

Sets the table's current scroll position.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function setCurrScrollRow (row)

Parameters

row

The index of the first row that should be visible in the table.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.setEnableStyledText Method

TableNode.setEnableStyledText Method
[image]

Sets a value indicating whether styled text rendering is enabled.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function setEnableStyledText (value)

Parameters

value

true to parse the node's text in order to find formatting tags, or false otherwise.

Remarks

Styled text allows applying various attributes to the characters it contains. Attributes are specified using HTML-like formatting tags embedded in the raw text. At this time the component supports the following formatting tags:

  • <b> specifies bold text
  • <i> specifies italic text
  • <u> specifies underlined text
  • <color=value> specifies text color

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.setScrollable Method

TableNode.setScrollable Method
[image]

Sets a value indicating whether the user is allowed to scroll the table rows.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function setScrollable (value)

Parameters

value

true if the table can be scrolled; otherwise, false.

Remarks

A button containing up and down arrows appears in the caption area of a table for which scrolling is enabled. If a user clicks these arrows, table rows scroll up or down. The table can always be scrolled programmatically using the setCurrScrollRow method.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.setShape Method

TableNode.setShape Method
[image]

Sets the shape of the table's outline.

Namespace: MindFusion.Diagramming
Assembly: TableNode.js

Syntax

JavaScript [image] Copy Code

function setShape (value)

Parameters

value

A member of the SimpleShape enumeration.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.Theme Class

Theme Class
[image]

Represents a set of Style objects whose properties are used to render items of a specific type in the current diagram.

Namespace: MindFusion.Diagramming
Assembly: Theme.js

Syntax

JavaScript [image] Copy Code

// class
Theme.prototype = {}

Inheritance Hierarchy

See Also

Theme Members


MindFusion.Diagramming.Theme Members

Theme Members
Constructors Fields
[image]

Represents a set of Style objects whose properties are used to render items of a specific type in the current diagram.

The following tables list the members exposed by the Theme type.

Public Constructors

Name | Description
Theme | Initializes a new instance of the Theme class.

Public Fields

Name | Description
styles | A dictionary object that maps item type identifiers to Style objects.

See Also

Theme Class


MindFusion.Diagramming.Theme Fields

Theme Fields
[image]

Public Fields

Name | Description
styles | A dictionary object that maps item type identifiers to Style objects.

See Also

Theme Class


MindFusion.Diagramming.Theme.styles Field

Theme.styles Field
[image]

A dictionary object that maps item type identifiers to Style objects.

Namespace: MindFusion.Diagramming
Assembly: Theme.js

Syntax

JavaScript [image] Copy Code

var styles

See Also

Theme Members
Theme Class


MindFusion.Diagramming.Theme Constructor

Theme Constructor
[image]

Initializes a new instance of the Theme class.

Namespace: MindFusion.Diagramming
Assembly: Theme.js

Syntax

JavaScript [image] Copy Code

function Theme ()

See Also

Theme Class


MindFusion.Diagramming.XmlPersistContext Class

XmlPersistContext Class
[image]

Contains helper methods for serialization of diagram contents to and from XML documents.

Namespace: MindFusion.Diagramming
Assembly: XmlPersistContext.js

Syntax

JavaScript [image] Copy Code

// class
XmlPersistContext.prototype = {}

Inheritance Hierarchy

See Also

XmlPersistContext Members


MindFusion.Diagramming.XmlPersistContext Members

XmlPersistContext Members
Constructors
[image]

Contains helper methods for serialization of diagram contents to and from XML documents.

The following tables list the members exposed by the XmlPersistContext type.

Public Constructors

Name | Description
XmlPersistContext | Initializes a new instance of the XmlPersistContext class.

See Also

XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext Constructor

XmlPersistContext Constructor
[image]

Initializes a new instance of the XmlPersistContext class.

Namespace: MindFusion.Diagramming
Assembly: XmlPersistContext.js

Syntax

JavaScript [image] Copy Code

function XmlPersistContext (diagram)

Parameters

diagram

The Diagram that will be serialized or deserialized.

See Also

XmlPersistContext Class


MindFusion.Diagramming.Lanes Namespace

MindFusion.Diagramming.Lanes Namespace
Classes Enumerations

Classes

Class | Description
Cell | Represents a single cell in a lane grid.
Grid | Represents a lane grid.
Header | Represents a header in a lane grid.
Style | Encapsulates the appearance properties of an element in a lane grid.

Enumerations

Enumeration | Description
ResizeType | Specifies how to resize child columns and rows in the lanes grid when their parent column or row is resized.


MindFusion.Diagramming.Lanes.Cell Class

Cell Class
[image]

Represents a single cell in a lane grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

// class
Cell.prototype = {}

Inheritance Hierarchy

See Also

Cell Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Cell Members

Cell Members
Constructors Methods
[image]

Represents a single cell in a lane grid.

The following tables list the members exposed by the Cell type.

Public Constructors

Name | Description
Cell | Initializes a new instance of the Cell class. For internal use only.

Public Methods

Name | Description
getStyle | Gets the style of the cell.
getText | Gets the text of the cell.
setStyle | Sets the style of the cell.
setText | Sets the text of the cell.

See Also

Cell Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Cell Constructor

Cell Constructor
[image]

Initializes a new instance of the Cell class. For internal use only.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function Cell ()

See Also

Cell Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Cell Methods

Cell Methods
[image]

Public Methods

Name | Description
getStyle | Gets the style of the cell.
getText | Gets the text of the cell.
setStyle | Sets the style of the cell.
setText | Sets the text of the cell.

See Also

Cell Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Cell.getStyle Method

Cell.getStyle Method
[image]

Gets the style of the cell.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function getStyle ()

Return Value

A Style object that specifies the style of this cell.

See Also

Cell Members
Cell Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Cell.getText Method

Cell.getText Method
[image]

Gets the text of the cell.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function getText ()

Return Value

A string specifying the text of the cell.

See Also

Cell Members
Cell Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Cell.setStyle Method

Cell.setStyle Method
[image]

Sets the style of the cell.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function setStyle (value)

Parameters

value

A Style object that specifies the style of this cell.

See Also

Cell Members
Cell Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Cell.setText Method

Cell.setText Method
[image]

Sets the text of the cell.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Cell.js

Syntax

JavaScript [image] Copy Code

function setText (value)

Parameters

value

A string specifying the text of the cell.

See Also

Cell Members
Cell Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid Class

Grid Class
[image]

Represents a lane grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

// class
Grid.prototype = {}

Inheritance Hierarchy

See Also

Grid Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid Members

Grid Members
Constructors Methods
[image]

Represents a lane grid.

The following tables list the members exposed by the Grid type.

Public Constructors

Name | Description
Grid | Initializes a new instance of the Grid class. For internal use only.

Public Methods

Name | Description
addColumnHeader | Adds the specified header to the grid as a new column header.
addRowHeader | Adds the specified header to the grid as a new row header.
findColumn | Returns the first column header matching the specified caption.
findRow | Finds the first row whose header caption matches the specified string.
get | Gets the cell or the cluster of cells corresponding to the specified row and column.
getCellBounds | Returns the bounding rectangle of the specified cell.
getCellColumn | Returns the column index of the specified cell.
getCellFromPoint | Gets the cell located at the specified point.
getCellRow | Returns the row index of the specified cell.
getColumn | Returns the column header with the specified index from the bottommost column header level.
getColumnCount | Gets the number of columns in the grid.
getColumnDepth | Gets the number of levels of the column headers.
getColumnHeaderBounds | Returns the bounding rectangle of all column headers.
getColumnHeaders | Gets the collection with the topmost column headers.
getColumnHeadersHeights | Gets an array with float values specifying the heights of individual column levels.
getColumnIndex | Returns the 0-based index of the specified column. Only works for bottommost headers. If the specified column is a group header, returns -1.
getHeaderBounds | Returns the bounding rectangle of the specified header.
getHeaderFromPoint | Gets the Header that is located at the specified point.
getHeadersOnTop | Gets a value indicating whether lane headers appear at the top of the z-order above all other items.
getHookHeaders | Gets a value indicating whether headers will be anchored to the corresponding side (that is, the column header anchored to the top side and the row header anchored to the left side).
getLeftMargin | Gets the offset of the lane grid from the left side of the document bounds.
getMinHeaderSize | Gets the minimum size of a header.
getRow | Returns the row header with the specified index from the bottommost row header level.
getRowCount | Gets the number of rows in the grid.
getRowDepth | Gets the number of levels of the row headers.
getRowHeaderBounds | Returns the bounding rectangle of all row headers.
getRowHeaders | Gets the collection with the topmost row headers.
getRowHeadersWidths | Gets an array with float values specifying the widths of individual row levels.
getRowIndex | Returns the 0-based index of the specified row. Only works for bottommost headers. If the specified row is a group header, returns -1;
getStyle | Gets the default style of the grid.
getTopLeftAreaStyle | Gets the style of the area above all row headers and to the left of all column headers.
getTopLeftAreaText | Gets the text displayed in the top left area.
getTopMargin | Gets the offset of the lane grid from the top side of the document bounds.
getTotalColumnHeight | Gets the total height of all column headers.
getTotalRowWidth | Gets the total width of all row headers.
removeColumnHeader | Removes the specified column header and all of its associated cells from the grid.
removeRowHeader | Removes the specified row header and all of its associated cells from the grid.
setColumnCount | Gets the number of columns in the grid.
setColumnHeadersHeights | Sets an array with float values specifying the heights of individual column levels.
setHeadersOnTop | Sets a value indicating whether lane headers appear at the top of the z-order above all other items.
setHookHeaders | Sets a value indicating whether headers will be anchored to the corresponding side (that is, the column header anchored to the top side and the row header anchored to the left side).
setLeftMargin | Sets the offset of the lane grid from the left side of the document bounds.
setMinHeaderSize | Sets the minimum size of a header.
setRowCount | Sets the number of rows in the grid.
setRowHeadersWidths | Sets an array with float values specifying the widths of individual row levels.
setTopLeftAreaStyle | Sets the style of the area above all row headers and to the left of all column headers.
setTopLeftAreaText | Sets the text displayed in the top left area.
setTopMargin | Sets the offset of the lane grid from the top side of the document bounds.

See Also

Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid Constructor

Grid Constructor
[image]

Initializes a new instance of the Grid class. For internal use only.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function Grid ()

See Also

Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid Methods

Grid Methods
[image]

Public Methods

Name | Description
addColumnHeader | Adds the specified header to the grid as a new column header.
addRowHeader | Adds the specified header to the grid as a new row header.
findColumn | Returns the first column header matching the specified caption.
findRow | Finds the first row whose header caption matches the specified string.
get | Gets the cell or the cluster of cells corresponding to the specified row and column.
getCellBounds | Returns the bounding rectangle of the specified cell.
getCellColumn | Returns the column index of the specified cell.
getCellFromPoint | Gets the cell located at the specified point.
getCellRow | Returns the row index of the specified cell.
getColumn | Returns the column header with the specified index from the bottommost column header level.
getColumnCount | Gets the number of columns in the grid.
getColumnDepth | Gets the number of levels of the column headers.
getColumnHeaderBounds | Returns the bounding rectangle of all column headers.
getColumnHeaders | Gets the collection with the topmost column headers.
getColumnHeadersHeights | Gets an array with float values specifying the heights of individual column levels.
getColumnIndex | Returns the 0-based index of the specified column. Only works for bottommost headers. If the specified column is a group header, returns -1.
getHeaderBounds | Returns the bounding rectangle of the specified header.
getHeaderFromPoint | Gets the Header that is located at the specified point.
getHeadersOnTop | Gets a value indicating whether lane headers appear at the top of the z-order above all other items.
getHookHeaders | Gets a value indicating whether headers will be anchored to the corresponding side (that is, the column header anchored to the top side and the row header anchored to the left side).
getLeftMargin | Gets the offset of the lane grid from the left side of the document bounds.
getMinHeaderSize | Gets the minimum size of a header.
getRow | Returns the row header with the specified index from the bottommost row header level.
getRowCount | Gets the number of rows in the grid.
getRowDepth | Gets the number of levels of the row headers.
getRowHeaderBounds | Returns the bounding rectangle of all row headers.
getRowHeaders | Gets the collection with the topmost row headers.
getRowHeadersWidths | Gets an array with float values specifying the widths of individual row levels.
getRowIndex | Returns the 0-based index of the specified row. Only works for bottommost headers. If the specified row is a group header, returns -1;
getStyle | Gets the default style of the grid.
getTopLeftAreaStyle | Gets the style of the area above all row headers and to the left of all column headers.
getTopLeftAreaText | Gets the text displayed in the top left area.
getTopMargin | Gets the offset of the lane grid from the top side of the document bounds.
getTotalColumnHeight | Gets the total height of all column headers.
getTotalRowWidth | Gets the total width of all row headers.
removeColumnHeader | Removes the specified column header and all of its associated cells from the grid.
removeRowHeader | Removes the specified row header and all of its associated cells from the grid.
setColumnCount | Gets the number of columns in the grid.
setColumnHeadersHeights | Sets an array with float values specifying the heights of individual column levels.
setHeadersOnTop | Sets a value indicating whether lane headers appear at the top of the z-order above all other items.
setHookHeaders | Sets a value indicating whether headers will be anchored to the corresponding side (that is, the column header anchored to the top side and the row header anchored to the left side).
setLeftMargin | Sets the offset of the lane grid from the left side of the document bounds.
setMinHeaderSize | Sets the minimum size of a header.
setRowCount | Sets the number of rows in the grid.
setRowHeadersWidths | Sets an array with float values specifying the widths of individual row levels.
setTopLeftAreaStyle | Sets the style of the area above all row headers and to the left of all column headers.
setTopLeftAreaText | Sets the text displayed in the top left area.
setTopMargin | Sets the offset of the lane grid from the top side of the document bounds.

See Also

Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.addColumnHeader Method

Grid.addColumnHeader Method
[image]

Adds the specified header to the grid as a new column header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function addColumnHeader (header, parent, i)

Parameters

header

The Header object to add.

parent

The parent header to add to, or null, to add the new header as a root column.

i

The index at which the header was added in the collection.

Example

The following example adds a new header at the end of the column collection of an existing lane grid.

JavaScript [image] Copy Code

grid.addColumnHeader(new Header());

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.addRowHeader Method

Grid.addRowHeader Method
[image]

Adds the specified header to the grid as a new row header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function addRowHeader (header, parent, i)

Parameters

header

The Header object to add.

parent

The parent header to add to, or null, to add the new header as a root column.

i

The index at which the header was added in the collection.

Example

The following example adds a new header at the end of the row collection of an existing lane grid.

JavaScript [image] Copy Code

grid.addRowHeader(new Header());

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.findColumn Method

Grid.findColumn Method
[image]

Returns the first column header matching the specified caption.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function findColumn (title)

Parameters

title

A string containing the header title to look for.

Return Value

Returns the first column Header that has the specified caption.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.findRow Method

Grid.findRow Method
[image]

Finds the first row whose header caption matches the specified string.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function findRow (title)

Parameters

title

A string containing the header title to look for.

Return Value

Returns the first row Header that has the specified caption.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.get Method

Grid.get Method
[image]

Gets the cell or the cluster of cells corresponding to the specified row and column.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function get (column, row)

Parameters

column

A Header object or a cell index.

row

A Header object or a cell index.

Return Value

A Cell object representing the cell or cluster of cells with the specified coordinates.

Remarks

This method accepts either Header objects or numbers as arguments, but not a mix of both. If more than one cell corresponds to a specified Header object, this method returns an object identifying all corresponding cells. Modifying the style of the returned object will affect all cells in the cluster. Calling the method without arguments, or with null arguments, will return an object identifying all cells in the grid.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getCellBounds Method

Grid.getCellBounds Method
[image]

Returns the bounding rectangle of the specified cell.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getCellBounds (cell)

Parameters

cell

An Cell object representing a cell or a group of cells in the grid.

Return Value

A Rect instance representing the rectangle that bounds the specified cell or group of cells.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getCellColumn Method

Grid.getCellColumn Method
[image]

Returns the column index of the specified cell.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getCellColumn (cell)

Parameters

cell

A Cell object representing a single cell in the grid.

Return Value

The index of the column that contains cell; -1 if cell is not found or refers to a group of cells.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getCellFromPoint Method

Grid.getCellFromPoint Method
[image]

Gets the cell located at the specified point.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getCellFromPoint (point, cellBounds)

Parameters

point

A Point instance specifying a point within the grid.

cellBounds

An object that receives the coordinates of the found cell in its cellBounds field.

Return Value

A Cell object identifying the found cell, or null if there is no cell located at the specified point.

Example

The following example illustrates how to find the cell at a specific position as well as its bounding rectangle:

JavaScript [image] Copy Code

var boundsResult = {};
var cell = grid.getCellFromPoint(new Point(50, 50), boundsResult);
if (cell)
{
var cellBounds = boundsResult.cellBounds;
}

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getCellRow Method

Grid.getCellRow Method
[image]

Returns the row index of the specified cell.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getCellRow (cell)

Parameters

cell

A Cell object representing a single cell in the grid.

Return Value

The index of the row that contains cell; -1 if cell is not found or refers to a group of cells.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getColumn Method

Grid.getColumn Method
[image]

Returns the column header with the specified index from the bottommost column header level.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getColumn (index)

Parameters

index

A number specifying the column index.

Return Value

A Header object representing the column at the specified index.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getColumnCount Method

Grid.getColumnCount Method
[image]

Gets the number of columns in the grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getColumnCount ()

Return Value

The number of columns.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getColumnDepth Method

Grid.getColumnDepth Method
[image]

Gets the number of levels of the column headers.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getColumnDepth ()

Return Value

A number representing the column depth.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getColumnHeaderBounds Method

Grid.getColumnHeaderBounds Method
[image]

Returns the bounding rectangle of all column headers.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getColumnHeaderBounds ()

Return Value

A Rect that bounds all column headers.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getColumnHeaders Method

Grid.getColumnHeaders Method
[image]

Gets the collection with the topmost column headers.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getColumnHeaders ()

Return Value

An array containing the topmost column headers.

Remarks

The returned array should not be modified directly. To add and remove column headers to the grid, use the addColumnHeader and removeColumnHeader methods perspectively.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getColumnHeadersHeights Method

Grid.getColumnHeadersHeights Method
[image]

Gets an array with float values specifying the heights of individual column levels.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getColumnHeadersHeights ()

Return Value

An array of numbers representing the heights of the various header levels.

Remarks

If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the height is calculated as the maximum height of the columns in that level.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getColumnIndex Method

Grid.getColumnIndex Method
[image]

Returns the 0-based index of the specified column. Only works for bottommost headers. If the specified column is a group header, returns -1.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getColumnIndex (column)

Parameters

column

A Header instance that represents a grid column.

Return Value

The index of column, or -1 if the specified header represents a row or a group of child columns.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getHeaderBounds Method

Grid.getHeaderBounds Method
[image]

Returns the bounding rectangle of the specified header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getHeaderBounds (header, includeSubHeaders)

Parameters

header

The Header object whose coordinates to return.

includeSubHeaders

true to include the coordinates of the child headers in the returned rectangle; otherwise, false.

Return Value

A Rect that bounds the specified header, and optionally its child headers.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getHeaderFromPoint Method

Grid.getHeaderFromPoint Method
[image]

Gets the Header that is located at the specified point.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getHeaderFromPoint (point, headerBounds, scrollPosition)

Parameters

point

A Point instance specifying a point within the grid.

headerBounds

An object that receives the coordinates of the found header in its headerBounds field.

scrollPosition

When the headers are hooked this parameter should provide information about the current scroll position in the view.

Return Value

The found Header object, or null if there is no header located at the specified point.

Example

The following example illustrates how to find the header at a specific position as well as its bounding rectangle:

JavaScript [image] Copy Code

var boundsResult = {};
var header = grid.getHeaderFromPoint(new Point(20, 10), boundsResult);
if (header)
{
var headerBounds = boundsResult.headerBounds;
}

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getHeadersOnTop Method

Grid.getHeadersOnTop Method
[image]

Gets a value indicating whether lane headers appear at the top of the z-order above all other items.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getHeadersOnTop ()

Return Value

true to always display the headers above the items; otherwise, false.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getHookHeaders Method

Grid.getHookHeaders Method
[image]

Gets a value indicating whether headers will be anchored to the corresponding side (that is, the column header anchored to the top side and the row header anchored to the left side).

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getHookHeaders ()

Return Value

true to anchor the headers; otherwise, false.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getLeftMargin Method

Grid.getLeftMargin Method
[image]

Gets the offset of the lane grid from the left side of the document bounds.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getLeftMargin ()

Return Value

A number representing the left margin.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getMinHeaderSize Method

Grid.getMinHeaderSize Method
[image]

Gets the minimum size of a header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getMinHeaderSize ()

Return Value

A number representing the minimum size for headers in the grid.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getRow Method

Grid.getRow Method
[image]

Returns the row header with the specified index from the bottommost row header level.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getRow (index)

Parameters

index

A number specifying the row index.

Return Value

A Header object representing the row at the specified index.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getRowCount Method

Grid.getRowCount Method
[image]

Gets the number of rows in the grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getRowCount ()

Return Value

The number of rows.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getRowDepth Method

Grid.getRowDepth Method
[image]

Gets the number of levels of the row headers.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getRowDepth ()

Return Value

A number representing the row depth.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getRowHeaderBounds Method

Grid.getRowHeaderBounds Method
[image]

Returns the bounding rectangle of all row headers.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getRowHeaderBounds ()

Return Value

A Rect that bounds all row headers.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getRowHeaders Method

Grid.getRowHeaders Method
[image]

Gets the collection with the topmost row headers.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getRowHeaders ()

Return Value

An array containing the topmost row headers.

Remarks

The returned array should not be modified directly. To add and remove row headers to the grid, use the addRowHeader and removeRowHeader methods perspectively.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getRowHeadersWidths Method

Grid.getRowHeadersWidths Method
[image]

Gets an array with float values specifying the widths of individual row levels.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getRowHeadersWidths ()

Return Value

An array of numbers representing the widths of the various header levels.

Remarks

If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the width is calculated as the maximum width of the rows in that level.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getRowIndex Method

Grid.getRowIndex Method
[image]

Returns the 0-based index of the specified row. Only works for bottommost headers. If the specified row is a group header, returns -1;

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getRowIndex (row)

Parameters

row

A Header instance that represents a grid row.

Return Value

The index of row, or -1 if the specified header represents a column or a group of child rows.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getStyle Method

Grid.getStyle Method
[image]

Gets the default style of the grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getStyle ()

Return Value

A Style object representing the style of all grid elements, which do not have an explicitly assigned style.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getTopLeftAreaStyle Method

Grid.getTopLeftAreaStyle Method
[image]

Gets the style of the area above all row headers and to the left of all column headers.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getTopLeftAreaStyle ()

Return Value

A Style object that specifies the appearance of the top-left area.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getTopLeftAreaText Method

Grid.getTopLeftAreaText Method
[image]

Gets the text displayed in the top left area.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getTopLeftAreaText ()

Return Value

A string specifying the text.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getTopMargin Method

Grid.getTopMargin Method
[image]

Gets the offset of the lane grid from the top side of the document bounds.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getTopMargin ()

Return Value

A number representing the top margin.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getTotalColumnHeight Method

Grid.getTotalColumnHeight Method
[image]

Gets the total height of all column headers.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getTotalColumnHeight ()

Return Value

A number representing the height.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.getTotalRowWidth Method

Grid.getTotalRowWidth Method
[image]

Gets the total width of all row headers.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function getTotalRowWidth ()

Return Value

A number representing the width.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.removeColumnHeader Method

Grid.removeColumnHeader Method
[image]

Removes the specified column header and all of its associated cells from the grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function removeColumnHeader (header)

Parameters

header

The Header object to remove.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.removeRowHeader Method

Grid.removeRowHeader Method
[image]

Removes the specified row header and all of its associated cells from the grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function removeRowHeader (header)

Parameters

header

The Header object to remove.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.setColumnCount Method

Grid.setColumnCount Method
[image]

Gets the number of columns in the grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function setColumnCount (value)

Parameters

value

The number of columns.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.setColumnHeadersHeights Method

Grid.setColumnHeadersHeights Method
[image]

Sets an array with float values specifying the heights of individual column levels.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function setColumnHeadersHeights (value)

Parameters

value

An array of numbers representing the heights of the various header levels.

Remarks

If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the height is calculated as the maximum height of the columns in that level.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.setHeadersOnTop Method

Grid.setHeadersOnTop Method
[image]

Sets a value indicating whether lane headers appear at the top of the z-order above all other items.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function setHeadersOnTop (value)

Parameters

value

true to always display the headers above the items; otherwise, false.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.setHookHeaders Method

Grid.setHookHeaders Method
[image]

Sets a value indicating whether headers will be anchored to the corresponding side (that is, the column header anchored to the top side and the row header anchored to the left side).

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function setHookHeaders (value)

Parameters

value

true to anchor the headers; otherwise, false.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.setLeftMargin Method

Grid.setLeftMargin Method
[image]

Sets the offset of the lane grid from the left side of the document bounds.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function setLeftMargin (value)

Parameters

value

A number representing the left margin.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.setMinHeaderSize Method

Grid.setMinHeaderSize Method
[image]

Sets the minimum size of a header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function setMinHeaderSize (value)

Parameters

value

A number representing the minimum size for headers in the grid.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.setRowCount Method

Grid.setRowCount Method
[image]

Sets the number of rows in the grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function setRowCount (value)

Parameters

value

The number of rows.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.setRowHeadersWidths Method

Grid.setRowHeadersWidths Method
[image]

Sets an array with float values specifying the widths of individual row levels.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function setRowHeadersWidths (value)

Parameters

value

An array of numbers representing the widths of the various header levels.

Remarks

If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the width is calculated as the maximum width of the rows in that level.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.setTopLeftAreaStyle Method

Grid.setTopLeftAreaStyle Method
[image]

Sets the style of the area above all row headers and to the left of all column headers.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function setTopLeftAreaStyle (value)

Parameters

value

A Style object that specifies the appearance of the top-left area.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.setTopLeftAreaText Method

Grid.setTopLeftAreaText Method
[image]

Sets the text displayed in the top left area.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function setTopLeftAreaText (value)

Parameters

value

A string specifying the text.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.setTopMargin Method

Grid.setTopMargin Method
[image]

Sets the offset of the lane grid from the top side of the document bounds.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Grid.js

Syntax

JavaScript [image] Copy Code

function setTopMargin (value)

Parameters

value

A number representing the top margin.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header Class

Header Class
[image]

Represents a header in a lane grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Header.js

Syntax

JavaScript [image] Copy Code

// class
Header.prototype = {}

Inheritance Hierarchy

See Also

Header Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header Members

Header Members
Constructors Methods
[image]

Represents a header in a lane grid.

The following tables list the members exposed by the Header type.

Public Constructors

Name | Description
Header | Initializes a new instance of the Header class.

Public Methods

Name | Description
getHeight | Gets the height of this header.
getResizeType | Gets how a row or a column is resized relatively to its parent.
getRotateTitle | Gets a value indicating whether to rotate the header caption at 90 degree.
getStyle | Gets the style of this header.
getSubHeaders | Gets a collection of the subheaders of this header.
getTitle | Gets the header caption.
getWidth | Gets the width of this header.
isColumnHeader | Gets a value indicating whether this header is a column header.
isRowHeader | Gets a value indicating whether this header is a row header.
setHeight | Sets the height of this header.
setResizeType | Sets how a row or a column is resized relatively to its parent.
setRotateTitle | Sets a value indicating whether to rotate the header caption at 90 degree.
setStyle | Gets the style of this header.
setTitle | Sets the header caption.
setWidth | Sets the width of this header.

See Also

Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header Constructor

Header Constructor
[image]

Initializes a new instance of the Header class.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Header.js

Syntax

JavaScript [image] Copy Code

function Header ()

See Also

Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header Methods

Header Methods
[image]

Public Methods

Name | Description
getHeight | Gets the height of this header.
getResizeType | Gets how a row or a column is resized relatively to its parent.
getRotateTitle | Gets a value indicating whether to rotate the header caption at 90 degree.
getStyle | Gets the style of this header.
getSubHeaders | Gets a collection of the subheaders of this header.
getTitle | Gets the header caption.
getWidth | Gets the width of this header.
isColumnHeader | Gets a value indicating whether this header is a column header.
isRowHeader | Gets a value indicating whether this header is a row header.
setHeight | Sets the height of this header.
setResizeType | Sets how a row or a column is resized relatively to its parent.
setRotateTitle | Sets a value indicating whether to rotate the header caption at 90 degree.
setStyle | Gets the style of this header.
setTitle | Sets the header caption.
setWidth | Sets the width of this header.

See Also

Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.getHeight Method

Header.getHeight Method
[image]

Gets the height of this header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Header.js

Syntax

JavaScript [image] Copy Code

function getHeight ()

Return Value

A number specifying the header height.

Remarks

If this is a row header, the property specifies the height of the whole row.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.getResizeType Method

Header.getResizeType Method
[image]

Gets how a row or a column is resized relatively to its parent.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Header.js

Syntax

JavaScript [image] Copy Code

function getResizeType ()

Return Value

One of the ResizeType enumeration values.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.getRotateTitle Method

Header.getRotateTitle Method
[image]

Gets a value indicating whether to rotate the header caption at 90 degree.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Header.js

Syntax

JavaScript [image] Copy Code

function getRotateTitle ()

Return Value

true if the title should be rotated; otherwise, false.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.getStyle Method

Header.getStyle Method
[image]

Gets the style of this header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Header.js

Syntax

JavaScript [image] Copy Code

function getStyle ()

Return Value

A Style object that specifies the appearance of the header.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.getSubHeaders Method

Header.getSubHeaders Method
[image]

Gets a collection of the subheaders of this header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Header.js

Syntax

JavaScript [image] Copy Code

function getSubHeaders ()

Return Value

An array containing the subheaders.

Remarks

The returned array should not be modified directly. To add and remove subheaders, use the addColumnHeader, addRowHeader, removeColumnHeader and removeRowHeader methods of the Grid respectively.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.getTitle Method

Header.getTitle Method
[image]

Gets the header caption.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Header.js

Syntax

JavaScript [image] Copy Code

function getTitle ()

Return Value

A string containing the caption text.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.getWidth Method

Header.getWidth Method
[image]

Gets the width of this header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Header.js

Syntax

JavaScript [image] Copy Code

function getWidth ()

Return Value

A number specifying the header width.

Remarks

If this is a column header, the property specifies the width of the whole column.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.isColumnHeader Method

Header.isColumnHeader Method
[image]

Gets a value indicating whether this header is a column header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Header.js

Syntax

JavaScript [image] Copy Code

function isColumnHeader ()

Return Value

true if the header is a column header; otherwise, false.

Remarks

Both isColumnHeader and isRowHeader return false if the header is not attached to a lane grid.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.isRowHeader Method

Header.isRowHeader Method
[image]

Gets a value indicating whether this header is a row header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Header.js

Syntax

JavaScript [image] Copy Code

function isRowHeader ()

Return Value

true if the header is a row header; otherwise, false.

Remarks

Both isColumnHeader and isRowHeader return false if the header is not attached to a lane grid.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.setHeight Method

Header.setHeight Method
[image]

Sets the height of this header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Header.js

Syntax

JavaScript [image] Copy Code

function setHeight (value)

Parameters

value

A number specifying the header height.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.setResizeType Method

Header.setResizeType Method
[image]

Sets how a row or a column is resized relatively to its parent.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Header.js

Syntax

JavaScript [image] Copy Code

function setResizeType (value)

Parameters

value

One of the ResizeType enumeration values.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.setRotateTitle Method

Header.setRotateTitle Method
[image]

Sets a value indicating whether to rotate the header caption at 90 degree.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Header.js

Syntax

JavaScript [image] Copy Code

function setRotateTitle (value)

Parameters

value

true if the title should be rotated; otherwise, false.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.setStyle Method

Header.setStyle Method
[image]

Gets the style of this header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Header.js

Syntax

JavaScript [image] Copy Code

function setStyle (value)

Parameters

value

A Style object that specifies the appearance of the header.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.setTitle Method

Header.setTitle Method
[image]

Sets the header caption.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Header.js

Syntax

JavaScript [image] Copy Code

function setTitle (value)

Parameters

value

A string containing the caption text.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.setWidth Method

Header.setWidth Method
[image]

Sets the width of this header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Header.js

Syntax

JavaScript [image] Copy Code

function setWidth (value)

Parameters

value

A number specifying the header width.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.ResizeType Enumeration

ResizeType Enumeration
[image]

Specifies how to resize child columns and rows in the lanes grid when their parent column or row is resized.

Namespace: MindFusion.Diagramming.Lanes
Assembly: ResizeType.js

Syntax

JavaScript [image] Copy Code

// enum
ResizeType = {}

Members

Member name | Description
Fixed | The header's size (width or height) is fixed and does not change when its parent header is being resized unless all its siblings have fixed size too.
Proportional | The header resizes in proportion to its parent header.

See Also

MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style Class

Style Class
[image]

Encapsulates the appearance properties of an element in a lane grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

// class
Style.prototype = {}

Inheritance Hierarchy

See Also

Style Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style Members

Style Members
Constructors Methods
[image]

Encapsulates the appearance properties of an element in a lane grid.

The following tables list the members exposed by the Style type.

Public Constructors

Name | Description
Style | Initializes a new instance of the Style class.

Public Methods

Name | Description
getBackgroundBrush | Gets the background brush of this style.
getBottomBorderPen | Gets the color used to stoke the bottom border of elements with this style.
getBottomBorderThickness | Gets the width of the bottom border of elements with this style.
getFontName | Gets the name of the font used to draw texts with this style.
getFontSize | Gets the size of the font used to draw texts with this style.
getLeftBorderPen | Gets the color used to stoke the left border of elements with this style.
getLeftBorderThickness | Gets the width of the left border of elements with this style.
getLineAlignment | Gets a value indicating how to vertically align texts drawn with this style.
getRightBorderPen | Gets the color used to stoke the right border of elements with this style.
getRightBorderThickness | Gets the width of the right border of elements with this style.
getTextAlignment | Gets a value indicating how to horizontally align texts drawn with this style.
getTextColor | Gets the color used to draw texts with this style.
getTopBorderPen | Gets the color used to stoke the top border of elements with this style.
getTopBorderThickness | Gets the width of the top border of elements with this style.
setBackgroundBrush | Sets the background brush of this style.
setBottomBorderPen | Sets the color used to stoke the bottom border of elements with this style.
setBottomBorderThickness | Sets the width of the bottom border of elements with this style.
setFontName | Sets the name of the font used to draw texts with this style.
setFontSize | Sets the size of the font used to draw texts with this style.
setLeftBorderPen | Sets the color used to stoke the left border of elements with this style.
setLeftBorderThickness | Sets the width of the left border of elements with this style.
setLineAlignment | Sets a value indicating how to vertically align texts drawn with this style.
setRightBorderPen | Sets the color used to stoke the right border of elements with this style.
setRightBorderThickness | Sets the width of the right border of elements with this style.
setTextAlignment | Sets a value indicating how to horizontally align texts drawn with this style.
setTextColor | Sets the color used to draw texts with this style.
setTopBorderPen | Sets the color used to stoke the top border of elements with this style.
setTopBorderThickness | Sets the width of the top border of elements with this style.

See Also

Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style Constructor

Style Constructor
[image]

Initializes a new instance of the Style class.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function Style ()

See Also

Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style Methods

Style Methods
[image]

Public Methods

Name | Description
getBackgroundBrush | Gets the background brush of this style.
getBottomBorderPen | Gets the color used to stoke the bottom border of elements with this style.
getBottomBorderThickness | Gets the width of the bottom border of elements with this style.
getFontName | Gets the name of the font used to draw texts with this style.
getFontSize | Gets the size of the font used to draw texts with this style.
getLeftBorderPen | Gets the color used to stoke the left border of elements with this style.
getLeftBorderThickness | Gets the width of the left border of elements with this style.
getLineAlignment | Gets a value indicating how to vertically align texts drawn with this style.
getRightBorderPen | Gets the color used to stoke the right border of elements with this style.
getRightBorderThickness | Gets the width of the right border of elements with this style.
getTextAlignment | Gets a value indicating how to horizontally align texts drawn with this style.
getTextColor | Gets the color used to draw texts with this style.
getTopBorderPen | Gets the color used to stoke the top border of elements with this style.
getTopBorderThickness | Gets the width of the top border of elements with this style.
setBackgroundBrush | Sets the background brush of this style.
setBottomBorderPen | Sets the color used to stoke the bottom border of elements with this style.
setBottomBorderThickness | Sets the width of the bottom border of elements with this style.
setFontName | Sets the name of the font used to draw texts with this style.
setFontSize | Sets the size of the font used to draw texts with this style.
setLeftBorderPen | Sets the color used to stoke the left border of elements with this style.
setLeftBorderThickness | Sets the width of the left border of elements with this style.
setLineAlignment | Sets a value indicating how to vertically align texts drawn with this style.
setRightBorderPen | Sets the color used to stoke the right border of elements with this style.
setRightBorderThickness | Sets the width of the right border of elements with this style.
setTextAlignment | Sets a value indicating how to horizontally align texts drawn with this style.
setTextColor | Sets the color used to draw texts with this style.
setTopBorderPen | Sets the color used to stoke the top border of elements with this style.
setTopBorderThickness | Sets the width of the top border of elements with this style.

See Also

Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.getBackgroundBrush Method

Style.getBackgroundBrush Method
[image]

Gets the background brush of this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function getBackgroundBrush ()

Return Value

A brush object specifying the background brush.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.getBottomBorderPen Method

Style.getBottomBorderPen Method
[image]

Gets the color used to stoke the bottom border of elements with this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function getBottomBorderPen ()

Return Value

A string value identifying the color.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.getBottomBorderThickness Method

Style.getBottomBorderThickness Method
[image]

Gets the width of the bottom border of elements with this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function getBottomBorderThickness ()

Return Value

A number identifying the width.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.getFontName Method

Style.getFontName Method
[image]

Gets the name of the font used to draw texts with this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function getFontName ()

Return Value

A string value identifying the font name.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.getFontSize Method

Style.getFontSize Method
[image]

Gets the size of the font used to draw texts with this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function getFontSize ()

Return Value

A number identifying the font size.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.getLeftBorderPen Method

Style.getLeftBorderPen Method
[image]

Gets the color used to stoke the left border of elements with this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function getLeftBorderPen ()

Return Value

A string value identifying the color.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.getLeftBorderThickness Method

Style.getLeftBorderThickness Method
[image]

Gets the width of the left border of elements with this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function getLeftBorderThickness ()

Return Value

A number identifying the width.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.getLineAlignment Method

Style.getLineAlignment Method
[image]

Gets a value indicating how to vertically align texts drawn with this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function getLineAlignment ()

Return Value

One of the Alignment enumeration values.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.getRightBorderPen Method

Style.getRightBorderPen Method
[image]

Gets the color used to stoke the right border of elements with this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function getRightBorderPen ()

Return Value

A string value identifying the color.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.getRightBorderThickness Method

Style.getRightBorderThickness Method
[image]

Gets the width of the right border of elements with this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function getRightBorderThickness ()

Return Value

A number identifying the width.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.getTextAlignment Method

Style.getTextAlignment Method
[image]

Gets a value indicating how to horizontally align texts drawn with this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function getTextAlignment ()

Return Value

One of the Alignment enumeration values.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.getTextColor Method

Style.getTextColor Method
[image]

Gets the color used to draw texts with this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function getTextColor ()

Return Value

A string value identifying the text color.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.getTopBorderPen Method

Style.getTopBorderPen Method
[image]

Gets the color used to stoke the top border of elements with this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function getTopBorderPen ()

Return Value

A string value identifying the color.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.getTopBorderThickness Method

Style.getTopBorderThickness Method
[image]

Gets the width of the top border of elements with this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function getTopBorderThickness ()

Return Value

A number identifying the width.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.setBackgroundBrush Method

Style.setBackgroundBrush Method
[image]

Sets the background brush of this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function setBackgroundBrush (value)

Parameters

value

A brush object specifying the background brush.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.setBottomBorderPen Method

Style.setBottomBorderPen Method
[image]

Sets the color used to stoke the bottom border of elements with this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function setBottomBorderPen (value)

Parameters

value

A string value identifying the color.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.setBottomBorderThickness Method

Style.setBottomBorderThickness Method
[image]

Sets the width of the bottom border of elements with this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function setBottomBorderThickness (value)

Parameters

value

A number identifying the width.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.setFontName Method

Style.setFontName Method
[image]

Sets the name of the font used to draw texts with this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function setFontName (value)

Parameters

value

A string value identifying the font name.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.setFontSize Method

Style.setFontSize Method
[image]

Sets the size of the font used to draw texts with this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function setFontSize (value)

Parameters

value

A number identifying the font size.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.setLeftBorderPen Method

Style.setLeftBorderPen Method
[image]

Sets the color used to stoke the left border of elements with this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function setLeftBorderPen (value)

Parameters

value

A string value identifying the color.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.setLeftBorderThickness Method

Style.setLeftBorderThickness Method
[image]

Sets the width of the left border of elements with this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function setLeftBorderThickness (value)

Parameters

value

A number identifying the width.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.setLineAlignment Method

Style.setLineAlignment Method
[image]

Sets a value indicating how to vertically align texts drawn with this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function setLineAlignment (value)

Parameters

value

One of the Alignment enumeration values.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.setRightBorderPen Method

Style.setRightBorderPen Method
[image]

Sets the color used to stoke the right border of elements with this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function setRightBorderPen (value)

Parameters

value

A string value identifying the color.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.setRightBorderThickness Method

Style.setRightBorderThickness Method
[image]

Sets the width of the right border of elements with this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function setRightBorderThickness (value)

Parameters

value

A number identifying the width.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.setTextAlignment Method

Style.setTextAlignment Method
[image]

Sets a value indicating how to horizontally align texts drawn with this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function setTextAlignment (value)

Parameters

value

One of the Alignment enumeration values.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.setTextColor Method

Style.setTextColor Method
[image]

Sets the color used to draw texts with this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function setTextColor (value)

Parameters

value

A string value identifying the text color.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.setTopBorderPen Method

Style.setTopBorderPen Method
[image]

Sets the color used to stoke the top border of elements with this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function setTopBorderPen (value)

Parameters

value

A string value identifying the color.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.setTopBorderThickness Method

Style.setTopBorderThickness Method
[image]

Sets the width of the top border of elements with this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: Style.js

Syntax

JavaScript [image] Copy Code

function setTopBorderThickness (value)

Parameters

value

A number identifying the width.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Drawing Namespace

MindFusion.Drawing Namespace
Classes Enumerations

Classes

Class | Description
Canvas | The Canvas class represents a wrapper class for the HTML5 Canvas element.
Ellipse | Represents an Ellipse.
Font | Represents a font.
Image | Represents an image.
Path | Represents a path.
Point | Represents a point.
Rect | Represents a rectangle.
Size | Represents the size of 2D object.
Text | Represents a text container.
Thickness | Describes the thickness of a rectangular frame.
Vector | Represents displacement in 2D space.

Enumerations

Enumeration | Description
DashStyle | Specifies the dash pattern of lines.
FontStyle | Specifies font style attributes.


MindFusion.Drawing.Canvas Class

Canvas Class
[image]

The Canvas class represents a wrapper class for the HTML5 Canvas element.

Namespace: MindFusion.Drawing
Assembly: Canvas.js

Syntax

JavaScript [image] Copy Code

// class
Canvas.prototype = {}

Inheritance Hierarchy

See Also

Canvas Members
MindFusion.Drawing Namespace


MindFusion.Drawing.Canvas Members

Canvas Members
Constructors Fields Methods
[image]

The Canvas class represents a wrapper class for the HTML5 Canvas element.

The following tables list the members exposed by the Canvas type.

Public Constructors

Name | Description
Canvas | Initializes a new instance of the Canvas class.

Public Fields

Name | Description
bounds | The object's bounds.
measureUnit | The unit of measure used for logical coordinates.
zoomFactor | The zoom factor used to scale up or down the drawing.

Public Methods

Name | Description
clientToDoc | Transforms a point from client to document coordinates.
docToClient | Transforms a point from document to client coordinates.
getBounds | Gets the underlying Canvas element's bounds.
getMeasureUnit | Gets the unit of measure used for logical coordinates.
getZoomFactor | Gets the zoom factor.
setBounds | Sets the underlying Canvas element's bounds.
setMeasureUnit | Sets the unit of measure used for logical coordinates.
setZoomFactor | Sets the zoom factor.

See Also

Canvas Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Canvas Fields

Canvas Fields
[image]

Public Fields

Name | Description
bounds | The object's bounds.
measureUnit | The unit of measure used for logical coordinates.
zoomFactor | The zoom factor used to scale up or down the drawing.

See Also

Canvas Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Canvas.bounds Field

Canvas.bounds Field
[image]

The object's bounds.

Namespace: MindFusion.Drawing
Assembly: Canvas.js

Syntax

JavaScript [image] Copy Code

var bounds

See Also

Canvas Members
Canvas Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Canvas.measureUnit Field

Canvas.measureUnit Field
[image]

The unit of measure used for logical coordinates.

Namespace: MindFusion.Drawing
Assembly: Canvas.js

Syntax

JavaScript [image] Copy Code

var measureUnit

See Also

Canvas Members
Canvas Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Canvas.zoomFactor Field

Canvas.zoomFactor Field
[image]

The zoom factor used to scale up or down the drawing.

Namespace: MindFusion.Drawing
Assembly: Canvas.js

Syntax

JavaScript [image] Copy Code

var zoomFactor

See Also

Canvas Members
Canvas Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Canvas Constructor

Canvas Constructor
[image]

Initializes a new instance of the Canvas class.

Namespace: MindFusion.Drawing
Assembly: Canvas.js

Syntax

JavaScript [image] Copy Code

function Canvas (element)

Parameters

element

The Canvas DOM Element this Canvas is associated with.

See Also

Canvas Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Canvas Methods

Canvas Methods
[image]

Public Methods

Name | Description
clientToDoc | Transforms a point from client to document coordinates.
docToClient | Transforms a point from document to client coordinates.
getBounds | Gets the underlying Canvas element's bounds.
getMeasureUnit | Gets the unit of measure used for logical coordinates.
getZoomFactor | Gets the zoom factor.
setBounds | Sets the underlying Canvas element's bounds.
setMeasureUnit | Sets the unit of measure used for logical coordinates.
setZoomFactor | Sets the zoom factor.

See Also

Canvas Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Canvas.clientToDoc Method

Canvas.clientToDoc Method
[image]

Transforms a point from client to document coordinates.

Namespace: MindFusion.Drawing
Assembly: Canvas.js

Syntax

JavaScript [image] Copy Code

function clientToDoc (point)

Parameters

point

The point to transform.

Return Value

The transformed point.

See Also

Canvas Members
Canvas Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Canvas.docToClient Method

Canvas.docToClient Method
[image]

Transforms a point from document to client coordinates.

Namespace: MindFusion.Drawing
Assembly: Canvas.js

Syntax

JavaScript [image] Copy Code

function docToClient (point)

Parameters

point

The point to transform.

Return Value

The transformed point.

See Also

Canvas Members
Canvas Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Canvas.getBounds Method

Canvas.getBounds Method
[image]

Gets the underlying Canvas element's bounds.

Namespace: MindFusion.Drawing
Assembly: Canvas.js

Syntax

JavaScript [image] Copy Code

function getBounds ()

Return Value

A Rect instance.

See Also

Canvas Members
Canvas Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Canvas.getMeasureUnit Method

Canvas.getMeasureUnit Method
[image]

Gets the unit of measure used for logical coordinates.

Namespace: MindFusion.Drawing
Assembly: Canvas.js

Syntax

JavaScript [image] Copy Code

function getMeasureUnit ()

Return Value

The current measure unit.

See Also

Canvas Members
Canvas Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Canvas.getZoomFactor Method

Canvas.getZoomFactor Method
[image]

Gets the zoom factor.

Namespace: MindFusion.Drawing
Assembly: Canvas.js

Syntax

JavaScript [image] Copy Code

function getZoomFactor ()

Return Value

The current zoom factor.

See Also

Canvas Members
Canvas Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Canvas.setBounds Method

Canvas.setBounds Method
[image]

Sets the underlying Canvas element's bounds.

Namespace: MindFusion.Drawing
Assembly: Canvas.js

Syntax

JavaScript [image] Copy Code

function setBounds (bounds)

Parameters

bounds

A Rect instance.

See Also

Canvas Members
Canvas Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Canvas.setMeasureUnit Method

Canvas.setMeasureUnit Method
[image]

Sets the unit of measure used for logical coordinates.

Namespace: MindFusion.Drawing
Assembly: Canvas.js

Syntax

JavaScript [image] Copy Code

function setMeasureUnit (value)

Parameters

value

A GraphicsUnit instance.

See Also

Canvas Members
Canvas Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Canvas.setZoomFactor Method

Canvas.setZoomFactor Method
[image]

Sets the zoom factor.

Namespace: MindFusion.Drawing
Assembly: Canvas.js

Syntax

JavaScript [image] Copy Code

function setZoomFactor (value)

Parameters

value

The zoom factor.

See Also

Canvas Members
Canvas Class
MindFusion.Drawing Namespace


MindFusion.Drawing.DashStyle Enumeration

DashStyle Enumeration
[image]

Specifies the dash pattern of lines.

Namespace: MindFusion.Drawing
Assembly: Line.js

Syntax

JavaScript [image] Copy Code

// enum
DashStyle = {}

Members

Member name | Description
Dash | Specifies a line consisting of dashes.
DashDot | Specifies a dash-dot pattern.
DashDotDot | Specifies a dash-dot-dot pattern.
Dot | Specifies a line consisting of dots.
Solid | Specifies a solid line.

See Also

MindFusion.Drawing Namespace


MindFusion.Drawing.Ellipse Class

Ellipse Class
[image]

Represents an Ellipse.

Namespace: MindFusion.Drawing
Assembly: Ellipse.js

Syntax

JavaScript [image] Copy Code

// class
Ellipse.prototype = {}

Inheritance Hierarchy

See Also

Ellipse Members
MindFusion.Drawing Namespace


MindFusion.Drawing.Ellipse Members

Ellipse Members
Constructors Fields Methods
[image]

Represents an Ellipse.

The following tables list the members exposed by the Ellipse type.

Public Constructors

Name | Description
Ellipse | Initializes a new instance of the Ellipse class.

Public Fields

Name | Description
height | The height of the Ellipse.
width | The width of the Ellipse.
x | The x-coordinate of the upper-left corner of the Ellipse.
y | The y-coordinate of the upper-left corner of the Ellipse.

Public Methods

Name | Description
clone | Creates a Ellipse object identical to the current object.

See Also

Ellipse Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Ellipse Fields

Ellipse Fields
[image]

Public Fields

Name | Description
height | The height of the Ellipse.
width | The width of the Ellipse.
x | The x-coordinate of the upper-left corner of the Ellipse.
y | The y-coordinate of the upper-left corner of the Ellipse.

See Also

Ellipse Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Ellipse.height Field

Ellipse.height Field
[image]

The height of the Ellipse.

Namespace: MindFusion.Drawing
Assembly: Ellipse.js

Syntax

JavaScript [image] Copy Code

var height

See Also

Ellipse Members
Ellipse Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Ellipse.width Field

Ellipse.width Field
[image]

The width of the Ellipse.

Namespace: MindFusion.Drawing
Assembly: Ellipse.js

Syntax

JavaScript [image] Copy Code

var width

See Also

Ellipse Members
Ellipse Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Ellipse.x Field

Ellipse.x Field
[image]

The x-coordinate of the upper-left corner of the Ellipse.

Namespace: MindFusion.Drawing
Assembly: Ellipse.js

Syntax

JavaScript [image] Copy Code

var x

See Also

Ellipse Members
Ellipse Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Ellipse.y Field

Ellipse.y Field
[image]

The y-coordinate of the upper-left corner of the Ellipse.

Namespace: MindFusion.Drawing
Assembly: Ellipse.js

Syntax

JavaScript [image] Copy Code

var y

See Also

Ellipse Members
Ellipse Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Ellipse Constructor

Ellipse Constructor
[image]

Initializes a new instance of the Ellipse class.

Namespace: MindFusion.Drawing
Assembly: Ellipse.js

Syntax

JavaScript [image] Copy Code

function Ellipse (x, y, width, height)

Parameters

x

The X-coordinate of the top left corner of the Ellipse.

y

The Y-coordinate of the top left corner of the Ellipse.

width

The width of the Ellipse.

height

The height of the Ellipse.

See Also

Ellipse Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Ellipse Methods

Ellipse Methods
[image]

Public Methods

Name | Description
clone | Creates a Ellipse object identical to the current object.

See Also

Ellipse Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Ellipse.clone Method

Ellipse.clone Method
[image]

Creates a Ellipse object identical to the current object.

Namespace: MindFusion.Drawing
Assembly: Ellipse.js

Syntax

JavaScript [image] Copy Code

function clone ()

Return Value

The newly created Ellipse object.

See Also

Ellipse Members
Ellipse Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Font Class

Font Class
[image]

Represents a font.

Namespace: MindFusion.Drawing
Assembly: Font.js

Syntax

JavaScript [image] Copy Code

// class
Font.prototype = {}

Inheritance Hierarchy

See Also

Font Members
MindFusion.Drawing Namespace


MindFusion.Drawing.Font Members

Font Members
Constructors Fields
[image]

Represents a font.

The following tables list the members exposed by the Font type.

Public Constructors

Name | Description
Font | Overloaded.

Public Fields

Name | Description
bold | true if this font is bold, otherwise false.
italic | true if this font is italic, otherwise false.
name | The font name.
size | The font size.
underline | true if this font is underlined, otherwise false.

See Also

Font Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Font Fields

Font Fields
[image]

Public Fields

Name | Description
bold | true if this font is bold, otherwise false.
italic | true if this font is italic, otherwise false.
name | The font name.
size | The font size.
underline | true if this font is underlined, otherwise false.

See Also

Font Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Font.bold Field

Font.bold Field
[image]

true if this font is bold, otherwise false.

Namespace: MindFusion.Drawing
Assembly: Font.js

Syntax

JavaScript [image] Copy Code

var bold

See Also

Font Members
Font Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Font.italic Field

Font.italic Field
[image]

true if this font is italic, otherwise false.

Namespace: MindFusion.Drawing
Assembly: Font.js

Syntax

JavaScript [image] Copy Code

var italic

See Also

Font Members
Font Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Font.name Field

Font.name Field
[image]

The font name.

Namespace: MindFusion.Drawing
Assembly: Font.js

Syntax

JavaScript [image] Copy Code

var name

See Also

Font Members
Font Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Font.size Field

Font.size Field
[image]

The font size.

Namespace: MindFusion.Drawing
Assembly: Font.js

Syntax

JavaScript [image] Copy Code

var size

See Also

Font Members
Font Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Font.underline Field

Font.underline Field
[image]

true if this font is underlined, otherwise false.

Namespace: MindFusion.Drawing
Assembly: Font.js

Syntax

JavaScript [image] Copy Code

var underline

See Also

Font Members
Font Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Font Constructor

Font Constructor
[image]

Overload List

Name | Description
Font (String, Number, Boolean, Boolean) | Initializes a new instance of the Font class with the specified attributes.
Font (String, Number, Boolean, Boolean, Boolean) | Initializes a new instance of the Font class with the specified attributes.

See Also

Font Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Font Constructor (String, Number, Boolean, Boolean)

Font Constructor (String, Number, Boolean, Boolean)
See Also
[image]

Initializes a new instance of the Font class with the specified attributes.

Namespace: MindFusion.Drawing
Assembly: Font.js

Syntax

JavaScript [image] Copy Code

function Font (name, size, bold, italic)

Parameters

name

The font name.

size

The font size.

bold

true if this font is bold, otherwise false.

italic

true if this font is italic, otherwise false.

See Also

Font Constructor Overload List
Font Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Font Constructor (String, Number, Boolean, Boolean, Boolean)

Font Constructor (String, Number, Boolean, Boolean, Boolean)
See Also
[image]

Initializes a new instance of the Font class with the specified attributes.

Namespace: MindFusion.Drawing
Assembly: Font.js

Syntax

JavaScript [image] Copy Code

function Font (name, size, bold, italic, underline)

Parameters

name

The font name.

size

The font size.

bold

true if this font is bold, otherwise false.

italic

true if this font is italic, otherwise false.

underline

true if this font is underlined, otherwise false.

See Also

Font Constructor Overload List
Font Class
MindFusion.Drawing Namespace


MindFusion.Drawing.FontStyle Enumeration

FontStyle Enumeration
[image]

Specifies font style attributes.

Namespace: MindFusion.Drawing
Assembly: Font.js

Syntax

JavaScript [image] Copy Code

// enum
FontStyle = {}

Members

Member name | Description
Bold | Bold text.
Italic | Italic text.
Regular | Normal text.
Underline | Underlined text.

See Also

MindFusion.Drawing Namespace


MindFusion.Drawing.Image Class

Image Class
[image]

Represents an image.

Namespace: MindFusion.Drawing
Assembly: Image.js

Syntax

JavaScript [image] Copy Code

// class
Image.prototype = {}

Inheritance Hierarchy

See Also

Image Members
MindFusion.Drawing Namespace


MindFusion.Drawing.Image Members

Image Members
Constructors Fields
[image]

Represents an image.

The following tables list the members exposed by the Image type.

Public Constructors

Name | Description
Image | Initializes a new instance of the Image class.

Public Fields

Name | Description
bounds | The object's bounds.
image | The image to be displayed.

See Also

Image Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Image Fields

Image Fields
[image]

Public Fields

Name | Description
bounds | The object's bounds.
image | The image to be displayed.

See Also

Image Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Image.bounds Field

Image.bounds Field
[image]

The object's bounds.

Namespace: MindFusion.Drawing
Assembly: Image.js

Syntax

JavaScript [image] Copy Code

var bounds

See Also

Image Members
Image Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Image.image Field

Image.image Field
[image]

The image to be displayed.

Namespace: MindFusion.Drawing
Assembly: Image.js

Syntax

JavaScript [image] Copy Code

var image

See Also

Image Members
Image Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Image Constructor

Image Constructor
[image]

Initializes a new instance of the Image class.

Namespace: MindFusion.Drawing
Assembly: Image.js

Syntax

JavaScript [image] Copy Code

function Image (bounds)

Parameters

bounds

The bounds of the image.

See Also

Image Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Path Class

Path Class
[image]

Represents a path.

Namespace: MindFusion.Drawing
Assembly: Path.js

Syntax

JavaScript [image] Copy Code

// class
Path.prototype = {}

Inheritance Hierarchy

See Also

Path Members
MindFusion.Drawing Namespace


MindFusion.Drawing.Path Members

Path Members
Constructors Methods
[image]

Represents a path.

The following tables list the members exposed by the Path type.

Public Constructors

Name | Description
Path | Initializes a new instance of the Path class.

Public Methods

Name | Description
addEllipse | Adds an ellipse figure to the path.
addRect | Adds a rectangle figure to the path.
arcTo | Draws an arc.
bezierTo | Draws a cubic bezier curve.
clone | Creates a Path object identical to the current object.
close | Closes the path.
done | Ends the path definition.
empty | Gets a value indicating whether this Path is empty.
getBounds | Gets the bounding rect of the path.
init | Begins a path or resets the current path.
lineTo | Draws a line from the current point to the specified location.
moveTo | Moves the path to the specified location.
quadraticCurveTo | Draws a quadratic bezier curve.
setBrush | Sets the brush used to fill a closed path.
setPen | Sets the pen used to draw the path.
setText | Sets the text displayed inside this path.

See Also

Path Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Path Constructor

Path Constructor
[image]

Initializes a new instance of the Path class.

Namespace: MindFusion.Drawing
Assembly: Path.js

Syntax

JavaScript [image] Copy Code

function Path (pathString)

Parameters

pathString

A string representing the path figures.

See Also

Path Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Path Methods

Path Methods
[image]

Public Methods

Name | Description
addEllipse | Adds an ellipse figure to the path.
addRect | Adds a rectangle figure to the path.
arcTo | Draws an arc.
bezierTo | Draws a cubic bezier curve.
clone | Creates a Path object identical to the current object.
close | Closes the path.
done | Ends the path definition.
empty | Gets a value indicating whether this Path is empty.
getBounds | Gets the bounding rect of the path.
init | Begins a path or resets the current path.
lineTo | Draws a line from the current point to the specified location.
moveTo | Moves the path to the specified location.
quadraticCurveTo | Draws a quadratic bezier curve.
setBrush | Sets the brush used to fill a closed path.
setPen | Sets the pen used to draw the path.
setText | Sets the text displayed inside this path.

See Also

Path Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Path.addEllipse Method

Path.addEllipse Method
[image]

Adds an ellipse figure to the path.

Namespace: MindFusion.Drawing
Assembly: Path.js

Syntax

JavaScript [image] Copy Code

function addEllipse (x, y, width, height)

Parameters

x

The x-coordinate of the center of the ellipse.

y

The y-coordinate of the center of the ellipse.

width

The width of the ellipse.

height

The height of the ellipse.

See Also

Path Members
Path Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Path.addRect Method

Path.addRect Method
[image]

Adds a rectangle figure to the path.

Namespace: MindFusion.Drawing
Assembly: Path.js

Syntax

JavaScript [image] Copy Code

function addRect (x, y, width, height)

Parameters

x

The x-coordinate of the rectangle.

y

The y-coordinate of the rectangle.

width

The width of the rectangle.

height

The height of the rectangle.

See Also

Path Members
Path Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Path.arcTo Method

Path.arcTo Method
[image]

Draws an arc.

Namespace: MindFusion.Drawing
Assembly: Path.js

Syntax

JavaScript [image] Copy Code

function arcTo (x, y, radius, startAngle, endAngle, anticlockwise)

Parameters

x

The x-coordinate of the center of the circle.

y

The y-coordinate of the center of the circle.

radius

The radius of the circle

startAngle

The starting angle in radians.

endAngle

The ending angle in radians.

anticlockwise

Specifies whether the drawing should be counterclockwise or clockwise.

See Also

Path Members
Path Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Path.bezierTo Method

Path.bezierTo Method
[image]

Draws a cubic bezier curve.

Namespace: MindFusion.Drawing
Assembly: Path.js

Syntax

JavaScript [image] Copy Code

function bezierTo (x1, y1, x2, y2, x3, y3)

Parameters

x1

The x-coordinate of the first bezier control point.

y1

The y-coordinate of the first bezier control point.

x2

The x-coordinate of the second bezier control point.

y2

The y-coordinate of the second bezier control point.

x3

The x-coordinate of the ending point.

y3

The y-coordinate of the ending point.

See Also

Path Members
Path Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Path.clone Method

Path.clone Method
[image]

Creates a Path object identical to the current object.

Namespace: MindFusion.Drawing
Assembly: Path.js

Syntax

JavaScript [image] Copy Code

function clone ()

Return Value

The newly created Path object.

See Also

Path Members
Path Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Path.close Method

Path.close Method
[image]

Closes the path.

Namespace: MindFusion.Drawing
Assembly: Path.js

Syntax

JavaScript [image] Copy Code

function close ()

See Also

Path Members
Path Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Path.done Method

Path.done Method
[image]

Ends the path definition.

Namespace: MindFusion.Drawing
Assembly: Path.js

Syntax

JavaScript [image] Copy Code

function done ()

See Also

Path Members
Path Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Path.empty Method

Path.empty Method
[image]

Gets a value indicating whether this Path is empty.

Namespace: MindFusion.Drawing
Assembly: Path.js

Syntax

JavaScript [image] Copy Code

function empty ()

Return Value

true if the path does not contain any figures; otherwise, false.

See Also

Path Members
Path Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Path.getBounds Method

Path.getBounds Method
[image]

Gets the bounding rect of the path.

Namespace: MindFusion.Drawing
Assembly: Path.js

Syntax

JavaScript [image] Copy Code

function getBounds ()

Return Value

The bounding rect.

See Also

Path Members
Path Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Path.init Method

Path.init Method
[image]

Begins a path or resets the current path.

Namespace: MindFusion.Drawing
Assembly: Path.js

Syntax

JavaScript [image] Copy Code

function init ()

See Also

Path Members
Path Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Path.lineTo Method

Path.lineTo Method
[image]

Draws a line from the current point to the specified location.

Namespace: MindFusion.Drawing
Assembly: Path.js

Syntax

JavaScript [image] Copy Code

function lineTo (x, y)

Parameters

x

The x-coordinate of the point.

y

The y-coordinate of the point.

See Also

Path Members
Path Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Path.moveTo Method

Path.moveTo Method
[image]

Moves the path to the specified location.

Namespace: MindFusion.Drawing
Assembly: Path.js

Syntax

JavaScript [image] Copy Code

function moveTo (x, y)

Parameters

x

The x-coordinate of the point.

y

The y-coordinate of the point.

See Also

Path Members
Path Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Path.quadraticCurveTo Method

Path.quadraticCurveTo Method
[image]

Draws a quadratic bezier curve.

Namespace: MindFusion.Drawing
Assembly: Path.js

Syntax

JavaScript [image] Copy Code

function quadraticCurveTo (x1, y1, x, y)

Parameters

x1

The x-coordinate of the bezier control point.

y1

The y-coordinate of the bezier control point.

x

The x-coordinate of the ending point.

y

The y-coordinate of the ending point.

See Also

Path Members
Path Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Path.setBrush Method

Path.setBrush Method
[image]

Sets the brush used to fill a closed path.

Namespace: MindFusion.Drawing
Assembly: Path.js

Syntax

JavaScript [image] Copy Code

function setBrush (brush)

Parameters

brush

The brush.

See Also

Path Members
Path Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Path.setPen Method

Path.setPen Method
[image]

Sets the pen used to draw the path.

Namespace: MindFusion.Drawing
Assembly: Path.js

Syntax

JavaScript [image] Copy Code

function setPen (pen)

Parameters

pen

The pen.

See Also

Path Members
Path Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Path.setText Method

Path.setText Method
[image]

Sets the text displayed inside this path.

Namespace: MindFusion.Drawing
Assembly: Path.js

Syntax

JavaScript [image] Copy Code

function setText (text)

Parameters

text

The text.

See Also

Path Members
Path Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Point Class

Point Class
[image]

Represents a point.

Namespace: MindFusion.Drawing
Assembly: Point.js

Syntax

JavaScript [image] Copy Code

// class
Point.prototype = {}

Inheritance Hierarchy

See Also

Point Members
MindFusion.Drawing Namespace


MindFusion.Drawing.Point Members

Point Members
Constructors Fields Methods
[image]

Represents a point.

The following tables list the members exposed by the Point type.

Public Constructors

Name | Description
Point | Initializes a new instance of the Point class with the specified X and Y coordinates.

Public Fields

Name | Description
x | The x-coordinate of the point.
y | The y-coordinate of the point.

Public Methods

Name | Description
empty | Gets a value indicating whether this Point is empty.
equals | Specifies whether this Point contains the same coordinates as the specified point.

See Also

Point Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Point Fields

Point Fields
[image]

Public Fields

Name | Description
x | The x-coordinate of the point.
y | The y-coordinate of the point.

See Also

Point Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Point.x Field

Point.x Field
[image]

The x-coordinate of the point.

Namespace: MindFusion.Drawing
Assembly: Point.js

Syntax

JavaScript [image] Copy Code

var x

See Also

Point Members
Point Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Point.y Field

Point.y Field
[image]

The y-coordinate of the point.

Namespace: MindFusion.Drawing
Assembly: Point.js

Syntax

JavaScript [image] Copy Code

var y

See Also

Point Members
Point Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Point Constructor

Point Constructor
[image]

Initializes a new instance of the Point class with the specified X and Y coordinates.

Namespace: MindFusion.Drawing
Assembly: Point.js

Syntax

JavaScript [image] Copy Code

function Point (x, y)

Parameters

x
The X-coordinate of the Point.
y
The Y-coordinate of the Point.

See Also

Point Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Point Methods

Point Methods
[image]

Public Methods

Name | Description
empty | Gets a value indicating whether this Point is empty.
equals | Specifies whether this Point contains the same coordinates as the specified point.

See Also

Point Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Point.empty Method

Point.empty Method
[image]

Gets a value indicating whether this Point is empty.

Namespace: MindFusion.Drawing
Assembly: Point.js

Syntax

JavaScript [image] Copy Code

function empty ()

Return Value

true if both x and y are 0; otherwise, false.

See Also

Point Members
Point Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Point.equals Method

Point.equals Method
[image]

Specifies whether this Point contains the same coordinates as the specified point.

Namespace: MindFusion.Drawing
Assembly: Point.js

Syntax

JavaScript [image] Copy Code

function equals ([point])

Parameters

point
Optional. The Point to test.

Return Value

true if point is a Point and has the same coordinates as this Point.

See Also

Point Members
Point Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect Class

Rect Class
[image]

Represents a rectangle.

Namespace: MindFusion.Drawing
Assembly: Rect.js

Syntax

JavaScript [image] Copy Code

// class
Rect.prototype = {}

Inheritance Hierarchy

See Also

Rect Members
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect Members

Rect Members
Constructors Fields Methods
[image]

Represents a rectangle.

The following tables list the members exposed by the Rect type.

Public Constructors

Name | Description
Rect | Initializes a new instance of the Rect class.

Public Fields

Name | Description
height | The height of the rectangle.
width | The width of the rectangle.
x | The x-coordinate of the upper-left corner of the rectangle.
y | The y-coordinate of the upper-left corner of the rectangle.

Public Methods

Name | Description
bottom | Gets the y-coordinate that is the sum of the y and height values of this Rect object.
bottomLeft | Gets the bottom-left edge of this Rect object.
bottomRight | Gets the bottom-right edge of this Rect object.
center | Gets the center of this Rect object.
clone | Creates a Rect object identical to the current object.
contains | Determines if the rectangular region represented by rect is entirely contained within this Rect object.
containsPoint | Determines if the specified point is contained within this Rect object.
fromLTRB | Creates a Rect object with the specified edge locations.
intersect | Returns a Rect object representing the intersection of the current rectangle with the specified rectangle.
intersectsWith | Checks if this Rect intersects with the specified rect.
isEmpty | Gets a value indicating whether this Rect is empty.
left | Gets the x-coordinate of the left edge of this Rect object.
right | Gets the x-coordinate that is the sum of x and width values of this Rect.
setCenter | Sets the center of this Rect object.
setLocation | Sets the top-left edge of this Rect object.
top | Gets the y-coordinate of the top edge of this Rect object.
topLeft | Gets the top-left edge of this Rect.
topMiddle | Gets the top-middle of this Rect object.
topRight | Gets the top-right edge of this Rect object.
union | Returns a Rect object representing the union of the current rectangle with the specified rectangle.

See Also

Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect Fields

Rect Fields
[image]

Public Fields

Name | Description
height | The height of the rectangle.
width | The width of the rectangle.
x | The x-coordinate of the upper-left corner of the rectangle.
y | The y-coordinate of the upper-left corner of the rectangle.

See Also

Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect.height Field

Rect.height Field
[image]

The height of the rectangle.

Namespace: MindFusion.Drawing
Assembly: Rect.js

Syntax

JavaScript [image] Copy Code

var height

See Also

Rect Members
Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect.width Field

Rect.width Field
[image]

The width of the rectangle.

Namespace: MindFusion.Drawing
Assembly: Rect.js

Syntax

JavaScript [image] Copy Code

var width

See Also

Rect Members
Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect.x Field

Rect.x Field
[image]

The x-coordinate of the upper-left corner of the rectangle.

Namespace: MindFusion.Drawing
Assembly: Rect.js

Syntax

JavaScript [image] Copy Code

var x

See Also

Rect Members
Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect.y Field

Rect.y Field
[image]

The y-coordinate of the upper-left corner of the rectangle.

Namespace: MindFusion.Drawing
Assembly: Rect.js

Syntax

JavaScript [image] Copy Code

var y

See Also

Rect Members
Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect Constructor

Rect Constructor
[image]

Initializes a new instance of the Rect class.

Namespace: MindFusion.Drawing
Assembly: Rect.js

Syntax

JavaScript [image] Copy Code

function Rect (x, y, width, height)

Parameters

x

The X-coordinate of the top left corner of the rectangle.

y

The Y-coordinate of the top left corner of the rectangle.

width

The width of the rectangle.

height

The height of the rectangle.

See Also

Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect Methods

Rect Methods
[image]

Public Methods

Name | Description
bottom | Gets the y-coordinate that is the sum of the y and height values of this Rect object.
bottomLeft | Gets the bottom-left edge of this Rect object.
bottomRight | Gets the bottom-right edge of this Rect object.
center | Gets the center of this Rect object.
clone | Creates a Rect object identical to the current object.
contains | Determines if the rectangular region represented by rect is entirely contained within this Rect object.
containsPoint | Determines if the specified point is contained within this Rect object.
fromLTRB | Creates a Rect object with the specified edge locations.
intersect | Returns a Rect object representing the intersection of the current rectangle with the specified rectangle.
intersectsWith | Checks if this Rect intersects with the specified rect.
isEmpty | Gets a value indicating whether this Rect is empty.
left | Gets the x-coordinate of the left edge of this Rect object.
right | Gets the x-coordinate that is the sum of x and width values of this Rect.
setCenter | Sets the center of this Rect object.
setLocation | Sets the top-left edge of this Rect object.
top | Gets the y-coordinate of the top edge of this Rect object.
topLeft | Gets the top-left edge of this Rect.
topMiddle | Gets the top-middle of this Rect object.
topRight | Gets the top-right edge of this Rect object.
union | Returns a Rect object representing the union of the current rectangle with the specified rectangle.

See Also

Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect.bottom Method

Rect.bottom Method
[image]

Gets the y-coordinate that is the sum of the y and height values of this Rect object.

Namespace: MindFusion.Drawing
Assembly: Rect.js

Syntax

JavaScript [image] Copy Code

function bottom ()

Return Value

The y-coordinate that is the sum of y and height of this Rect.

See Also

Rect Members
Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect.bottomLeft Method

Rect.bottomLeft Method
[image]

Gets the bottom-left edge of this Rect object.

Namespace: MindFusion.Drawing
Assembly: Rect.js

Syntax

JavaScript [image] Copy Code

function bottomLeft ()

Return Value

The bottom-left edge, which is a Point with x that is equal to x and with y that is the sum of y and height.

See Also

Rect Members
Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect.bottomRight Method

Rect.bottomRight Method
[image]

Gets the bottom-right edge of this Rect object.

Namespace: MindFusion.Drawing
Assembly: Rect.js

Syntax

JavaScript [image] Copy Code

function bottomRight ()

Return Value

The bottom-right edge, which is a Point with x that is the sum of x and width and with y that is the sum of y and height.

See Also

Rect Members
Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect.center Method

Rect.center Method
[image]

Gets the center of this Rect object.

Namespace: MindFusion.Drawing
Assembly: Rect.js

Syntax

JavaScript [image] Copy Code

function center ()

Return Value

The center, which is a Point with x that is the sum of x and half of width and with y that is the sum of y and half of height.

See Also

Rect Members
Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect.clone Method

Rect.clone Method
[image]

Creates a Rect object identical to the current object.

Namespace: MindFusion.Drawing
Assembly: Rect.js

Syntax

JavaScript [image] Copy Code

function clone ()

Return Value

The newly created Rect object.

See Also

Rect Members
Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect.contains Method

Rect.contains Method
[image]

Determines if the rectangular region represented by rect is entirely contained within this Rect object.

Namespace: MindFusion.Drawing
Assembly: Rect.js

Syntax

JavaScript [image] Copy Code

function contains (rect)

Parameters

rect
The Rect to test.

Return Value

true if the rectangular region represented by rect is entirely contained within this Rect; otherwise, false.

See Also

Rect Members
Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect.containsPoint Method

Rect.containsPoint Method
[image]

Determines if the specified point is contained within this Rect object.

Namespace: MindFusion.Drawing
Assembly: Rect.js

Syntax

JavaScript [image] Copy Code

function containsPoint (point)

Parameters

point

The point to check.

Return Value

true if point is contained within the Rect; otherwise, false.

See Also

Rect Members
Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect.fromLTRB Method

Rect.fromLTRB Method
[image]

Creates a Rect object with the specified edge locations.

Namespace: MindFusion.Drawing
Assembly: Rect.js

Syntax

JavaScript [image] Copy Code

function fromLTRB (l, t, r, b)

Parameters

l

The x-coordinate of the upper-left corner of this Rect.

t

The y-coordinate of the upper-left corner of this Rect.

r

The x-coordinate of the lower-right corner of this Rect.

b

The y-coordinate of the lower-right corner of this Rect.

Return Value

A rectangle with the specified coordinates.

See Also

Rect Members
Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect.intersect Method

Rect.intersect Method
[image]

Returns a Rect object representing the intersection of the current rectangle with the specified rectangle.

Namespace: MindFusion.Drawing
Assembly: Rect.js

Syntax

JavaScript [image] Copy Code

function intersect (rect)

Parameters

rect

The rectangle to intersect.

Return Value

A Rect object representing the intersection of the two rectangles.

See Also

Rect Members
Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect.intersectsWith Method

Rect.intersectsWith Method
[image]

Checks if this Rect intersects with the specified rect.

Namespace: MindFusion.Drawing
Assembly: Rect.js

Syntax

JavaScript [image] Copy Code

function intersectsWith (rect)

Parameters

rect
The other Rect.

Return Value

true if this Rect and the specified Rect intersect; otherwise, false.

See Also

Rect Members
Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect.isEmpty Method

Rect.isEmpty Method
[image]

Gets a value indicating whether this Rect is empty.

Namespace: MindFusion.Drawing
Assembly: Rect.js

Syntax

JavaScript [image] Copy Code

function isEmpty ()

Return Value

true if both width and height are 0; otherwise, false.

See Also

Rect Members
Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect.left Method

Rect.left Method
[image]

Gets the x-coordinate of the left edge of this Rect object.

Namespace: MindFusion.Drawing
Assembly: Rect.js

Syntax

JavaScript [image] Copy Code

function left ()

Return Value

The x-coordinate of the left edge of this Rect object.

See Also

Rect Members
Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect.right Method

Rect.right Method
[image]

Gets the x-coordinate that is the sum of x and width values of this Rect.

Namespace: MindFusion.Drawing
Assembly: Rect.js

Syntax

JavaScript [image] Copy Code

function right ()

Return Value

The x-coordinate that is the sum of x and width of this rectangle.

See Also

Rect Members
Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect.setCenter Method

Rect.setCenter Method
[image]

Sets the center of this Rect object.

Namespace: MindFusion.Drawing
Assembly: Rect.js

Syntax

JavaScript [image] Copy Code

function setCenter (point)

Parameters

point
The center of this Rect.

See Also

Rect Members
Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect.setLocation Method

Rect.setLocation Method
[image]

Sets the top-left edge of this Rect object.

Namespace: MindFusion.Drawing
Assembly: Rect.js

Syntax

JavaScript [image] Copy Code

function setLocation (point)

Parameters

point
The top-left edge of the Rect.

See Also

Rect Members
Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect.top Method

Rect.top Method
[image]

Gets the y-coordinate of the top edge of this Rect object.

Namespace: MindFusion.Drawing
Assembly: Rect.js

Syntax

JavaScript [image] Copy Code

function top ()

See Also

Rect Members
Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect.topLeft Method

Rect.topLeft Method
[image]

Gets the top-left edge of this Rect.

Namespace: MindFusion.Drawing
Assembly: Rect.js

Syntax

JavaScript [image] Copy Code

function topLeft ()

Return Value

The top-left edge of this Rect.

See Also

Rect Members
Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect.topMiddle Method

Rect.topMiddle Method
[image]

Gets the top-middle of this Rect object.

Namespace: MindFusion.Drawing
Assembly: Rect.js

Syntax

JavaScript [image] Copy Code

function topMiddle ()

Return Value

The top-middle coordinate, which is a Point with x that is the sum of x and half of width and with y equal to y.

See Also

Rect Members
Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect.topRight Method

Rect.topRight Method
[image]

Gets the top-right edge of this Rect object.

Namespace: MindFusion.Drawing
Assembly: Rect.js

Syntax

JavaScript [image] Copy Code

function topRight ()

Return Value

The top-right edge, which is a Point with x that is the sum of x and width and with y equal to y.

See Also

Rect Members
Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Rect.union Method

Rect.union Method
[image]

Returns a Rect object representing the union of the current rectangle with the specified rectangle.

Namespace: MindFusion.Drawing
Assembly: Rect.js

Syntax

JavaScript [image] Copy Code

function union (rect)

Parameters

rect

The rectangle to union.

Return Value

A Rect object that bounds the union of the two rectangles.

See Also

Rect Members
Rect Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Size Class

Size Class
[image]

Represents the size of 2D object.

Namespace: MindFusion.Drawing
Assembly: Size.js

Syntax

JavaScript [image] Copy Code

// class
Size.prototype = {}

Inheritance Hierarchy

See Also

Size Members
MindFusion.Drawing Namespace


MindFusion.Drawing.Size Members

Size Members
Constructors Fields
[image]

Represents the size of 2D object.

The following tables list the members exposed by the Size type.

Public Constructors

Name | Description
Size | Initializes a new instance of the Size class with the specified width and height.

Public Fields

Name | Description
height | The object's height.
width | The object's width.

See Also

Size Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Size Fields

Size Fields
[image]

Public Fields

Name | Description
height | The object's height.
width | The object's width.

See Also

Size Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Size.height Field

Size.height Field
[image]

The object's height.

Namespace: MindFusion.Drawing
Assembly: Size.js

Syntax

JavaScript [image] Copy Code

var height

See Also

Size Members
Size Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Size.width Field

Size.width Field
[image]

The object's width.

Namespace: MindFusion.Drawing
Assembly: Size.js

Syntax

JavaScript [image] Copy Code

var width

See Also

Size Members
Size Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Size Constructor

Size Constructor
[image]

Initializes a new instance of the Size class with the specified width and height.

Namespace: MindFusion.Drawing
Assembly: Size.js

Syntax

JavaScript [image] Copy Code

function Size (width, height)

Parameters

width

Specifies width.

height

Specifies height.

See Also

Size Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Text Class

Text Class
[image]

Represents a text container.

Namespace: MindFusion.Drawing
Assembly: Text.js

Syntax

JavaScript [image] Copy Code

// class
Text.prototype = {}

Inheritance Hierarchy

See Also

Text Members
MindFusion.Drawing Namespace


MindFusion.Drawing.Text Members

Text Members
Constructors Fields Methods
[image]

Represents a text container.

The following tables list the members exposed by the Text type.

Public Constructors

Name | Description
Text | Initializes a new instance of the Text class.

Public Fields

Name | Description
bounds | The object's bounds.
text | The text to be displayed.

Public Methods

Name | Description
clone | Creates a Text object identical to the current object.

See Also

Text Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Text Fields

Text Fields
[image]

Public Fields

Name | Description
bounds | The object's bounds.
text | The text to be displayed.

See Also

Text Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Text.bounds Field

Text.bounds Field
[image]

The object's bounds.

Namespace: MindFusion.Drawing
Assembly: Text.js

Syntax

JavaScript [image] Copy Code

var bounds

See Also

Text Members
Text Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Text.text Field

Text.text Field
[image]

The text to be displayed.

Namespace: MindFusion.Drawing
Assembly: Text.js

Syntax

JavaScript [image] Copy Code

var text

See Also

Text Members
Text Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Text Constructor

Text Constructor
[image]

Initializes a new instance of the Text class.

Namespace: MindFusion.Drawing
Assembly: Text.js

Syntax

JavaScript [image] Copy Code

function Text (text, bounds)

Parameters

text

The text to be displayed in the container.

bounds

The bounds of the container.

See Also

Text Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Text Methods

Text Methods
[image]

Public Methods

Name | Description
clone | Creates a Text object identical to the current object.

See Also

Text Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Text.clone Method

Text.clone Method
[image]

Creates a Text object identical to the current object.

Namespace: MindFusion.Drawing
Assembly: Text.js

Syntax

JavaScript [image] Copy Code

function clone ()

Return Value

The newly created Text object.

See Also

Text Members
Text Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Thickness Class

Thickness Class
[image]

Describes the thickness of a rectangular frame.

Namespace: MindFusion.Drawing
Assembly: Thickness.js

Syntax

JavaScript [image] Copy Code

// class
Thickness.prototype = {}

Inheritance Hierarchy

See Also

Thickness Members
MindFusion.Drawing Namespace


MindFusion.Drawing.Thickness Members

Thickness Members
Constructors Fields
[image]

Describes the thickness of a rectangular frame.

The following tables list the members exposed by the Thickness type.

Public Constructors

Name | Description
Thickness | Initializes a new instance of the Thickness class with the specified widths.

Public Fields

Name | Description
bottom | The bottom of the left side of the frame.
left | The width of the left side of the frame.
right | The width of the right side of the frame.
top | The width of the top side of the frame.

See Also

Thickness Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Thickness Fields

Thickness Fields
[image]

Public Fields

Name | Description
bottom | The bottom of the left side of the frame.
left | The width of the left side of the frame.
right | The width of the right side of the frame.
top | The width of the top side of the frame.

See Also

Thickness Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Thickness.bottom Field

Thickness.bottom Field
[image]

The bottom of the left side of the frame.

Namespace: MindFusion.Drawing
Assembly: Thickness.js

Syntax

JavaScript [image] Copy Code

var bottom

See Also

Thickness Members
Thickness Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Thickness.left Field

Thickness.left Field
[image]

The width of the left side of the frame.

Namespace: MindFusion.Drawing
Assembly: Thickness.js

Syntax

JavaScript [image] Copy Code

var left

See Also

Thickness Members
Thickness Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Thickness.right Field

Thickness.right Field
[image]

The width of the right side of the frame.

Namespace: MindFusion.Drawing
Assembly: Thickness.js

Syntax

JavaScript [image] Copy Code

var right

See Also

Thickness Members
Thickness Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Thickness.top Field

Thickness.top Field
[image]

The width of the top side of the frame.

Namespace: MindFusion.Drawing
Assembly: Thickness.js

Syntax

JavaScript [image] Copy Code

var top

See Also

Thickness Members
Thickness Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Thickness Constructor

Thickness Constructor
[image]

Initializes a new instance of the Thickness class with the specified widths.

Namespace: MindFusion.Drawing
Assembly: Thickness.js

Syntax

JavaScript [image] Copy Code

function Thickness (left, top, right, bottom)

Parameters

left

Specifies the width of the left side of the frame.

top

Specifies the width of the top side of the frame.

right

Specifies the width of the right side of the frame.

bottom

Specifies the width of the bottom side of the frame.

See Also

Thickness Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Vector Class

Vector Class
[image]

Represents displacement in 2D space.

Namespace: MindFusion.Drawing
Assembly: Vector.js

Syntax

JavaScript [image] Copy Code

// class
Vector.prototype = {}

Inheritance Hierarchy

See Also

Vector Members
MindFusion.Drawing Namespace


MindFusion.Drawing.Vector Members

Vector Members
Constructors Fields
[image]

Represents displacement in 2D space.

The following tables list the members exposed by the Vector type.

Public Constructors

Name | Description
Vector | Initializes a new instance of the Vector class with the specified X and Y coordinates.

Public Fields

Name | Description
x | The x-coordinate of the vector.
y | The y-coordinate of the vector.

See Also

Vector Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Vector Fields

Vector Fields
[image]

Public Fields

Name | Description
x | The x-coordinate of the vector.
y | The y-coordinate of the vector.

See Also

Vector Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Vector.x Field

Vector.x Field
[image]

The x-coordinate of the vector.

Namespace: MindFusion.Drawing
Assembly: Vector.js

Syntax

JavaScript [image] Copy Code

var x

See Also

Vector Members
Vector Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Vector.y Field

Vector.y Field
[image]

The y-coordinate of the vector.

Namespace: MindFusion.Drawing
Assembly: Vector.js

Syntax

JavaScript [image] Copy Code

var y

See Also

Vector Members
Vector Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Vector Constructor

Vector Constructor
[image]

Initializes a new instance of the Vector class with the specified X and Y coordinates.

Namespace: MindFusion.Drawing
Assembly: Vector.js

Syntax

JavaScript [image] Copy Code

function Vector (x, y)

Parameters

x

The X-coordinate of the Vector.

y

The Y-coordinate of the Vector.

See Also

Vector Class
MindFusion.Drawing Namespace


MindFusion.Graphs Namespace

MindFusion.Graphs Namespace
Classes Enumerations

Classes

Class | Description
BorderedTreeLayout | Implements algorithms for arranging tree structures.
Edge | Represents an edge connecting two vertices in a graph.
FractalLayout | The FractalLayout tree layout algorithm places child nodes symmetrically around their parent node. Nodes at the lowest level are arranged directly in a circle around their parent. At the upper level, the already arranged nodes form branches that are arranged in a circle around the new parent node. The algorithm is recursively repeated till the highest level is reached.
Graph | Represents a graph.
LayeredLayout | Implements a layered graph layout algorithm.
SpringLayout | Implements the Spring-Embedder graph layout algorithm.
TreeLayout | Implements algorithms for arranging tree structures.
Vertex | Represents a vertex in a graph.

Enumerations

Enumeration | Description
Anchoring | Defines values that specify how automatic layout algorithms align links to anchor points.
AssistantType | Indicates the type of an assistant node in a tree.
LayoutDirection | Specifies the shape of the diagram links after they are laid out.
MultipleGraphsPlacement | Specifies placement of graph connected components relatively to each other.
TreeLayoutLinkType | Specifies the shape of the diagram links after they are laid out.


MindFusion.Graphs.Anchoring Enumeration

Anchoring Enumeration
[image]

Defines values that specify how automatic layout algorithms align links to anchor points.

Namespace: MindFusion.Graphs
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
Anchoring = {}

Members

Member name | Description
Ignore | Value: 0. Anchor points are ignored.
Keep | Value: 1. Links are aligned to their original anchor points.
Reassign | Value: 2. Links are aligned to new anchor points, depending on

See Also

MindFusion.Graphs Namespace


MindFusion.Graphs.AssistantType Enumeration

AssistantType Enumeration
[image]

Indicates the type of an assistant node in a tree.

Namespace: MindFusion.Graphs
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
AssistantType = {}

Members

Member name | Description
Left | Value: 2. The node is an assistant and it is always positioned to the left of its parent.
Normal | Value: 1. The node is an assistant and its relative position is determinedautomatically by the layout.
Right | Value: 3. The node is an assistant and it is always positioned to the right of its parent.

See Also

MindFusion.Graphs Namespace


MindFusion.Graphs.BorderedTreeLayout Class

BorderedTreeLayout Class
Remarks See Also
[image]

Implements algorithms for arranging tree structures.

Namespace: MindFusion.Graphs
Assembly: BorderedTreeLayout.js

Syntax

JavaScript [image] Copy Code

// class
BorderedTreeLayout.prototype = {}

Remarks

To apply this layout to a diagram, create a BorderedTreeLayout instance, set its members and invoke the arrange method of the Diagram class. The method lays out all subtrees in a diagram.

As long as the graph is a tree, the algorithm can find the root node automatically. The distance between the root and the second level and between all subsequent levels can be set through the levelDistance field. The distance between adjacent nodes in the same level is set through nodeDistance.

In addition to arranging the tree nodes, BorderedTreeLayout also sets the shape of links as set through its linkType field.

Inheritance Hierarchy

See Also

BorderedTreeLayout Members
MindFusion.Graphs Namespace


MindFusion.Graphs.BorderedTreeLayout Members

BorderedTreeLayout Members
Constructors Fields Methods
[image]

Implements algorithms for arranging tree structures.

The following tables list the members exposed by the BorderedTreeLayout type.

Public Constructors

Name | Description
BorderedTreeLayout | Initializes a new instance of the BorderedTreeLayout class.

Public Fields

Name | Description
anchoring | Indicates how to align links to the anchor points of nodes.
direction | The orientation of the arranged graph.
keepGroupLayout | Indicates whether to treat each Group of nodes as a single vertex in the arranged graph.
keepRootPosition | Indicates whether to keep the root node at its original position.
levelDistance | The space to leave between adjacent levels of the tree.
linkType | The type of the links in the arranged tree.
multipleGraphsPlacement | Indicates how multiple independent graphs in the diagram should be positioned relatively to each other.
nodeDistance | The space to leave between adjacent nodes on the same level.

Public Methods

Name | Description
arrange | Applies the layout to the specified graph.

See Also

BorderedTreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.BorderedTreeLayout Fields

BorderedTreeLayout Fields
[image]

Public Fields

Name | Description
anchoring | Indicates how to align links to the anchor points of nodes.
direction | The orientation of the arranged graph.
keepGroupLayout | Indicates whether to treat each Group of nodes as a single vertex in the arranged graph.
keepRootPosition | Indicates whether to keep the root node at its original position.
levelDistance | The space to leave between adjacent levels of the tree.
linkType | The type of the links in the arranged tree.
multipleGraphsPlacement | Indicates how multiple independent graphs in the diagram should be positioned relatively to each other.
nodeDistance | The space to leave between adjacent nodes on the same level.

See Also

BorderedTreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.BorderedTreeLayout.anchoring Field

BorderedTreeLayout.anchoring Field
[image]

Indicates how to align links to the anchor points of nodes.

Namespace: MindFusion.Graphs
Assembly: BorderedTreeLayout.js

Syntax

JavaScript [image] Copy Code

var anchoring

Remarks

A member of the Anchoring enumeration. The default value is Ignore.

See Also

BorderedTreeLayout Members
BorderedTreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.BorderedTreeLayout.direction Field

BorderedTreeLayout.direction Field
[image]

The orientation of the arranged graph.

Namespace: MindFusion.Graphs
Assembly: BorderedTreeLayout.js

Syntax

JavaScript [image] Copy Code

var direction

Remarks

A member of the LayoutDirection enumeration. The default value is TopToBottom.

See Also

BorderedTreeLayout Members
BorderedTreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.BorderedTreeLayout.keepGroupLayout Field

BorderedTreeLayout.keepGroupLayout Field
[image]

Indicates whether to treat each Group of nodes as a single vertex in the arranged graph.

Namespace: MindFusion.Graphs
Assembly: BorderedTreeLayout.js

Syntax

JavaScript [image] Copy Code

var keepGroupLayout

See Also

BorderedTreeLayout Members
BorderedTreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.BorderedTreeLayout.keepRootPosition Field

BorderedTreeLayout.keepRootPosition Field
[image]

Indicates whether to keep the root node at its original position.

Namespace: MindFusion.Graphs
Assembly: BorderedTreeLayout.js

Syntax

JavaScript [image] Copy Code

var keepRootPosition

See Also

BorderedTreeLayout Members
BorderedTreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.BorderedTreeLayout.levelDistance Field

BorderedTreeLayout.levelDistance Field
[image]

The space to leave between adjacent levels of the tree.

Namespace: MindFusion.Graphs
Assembly: BorderedTreeLayout.js

Syntax

JavaScript [image] Copy Code

var levelDistance

See Also

BorderedTreeLayout Members
BorderedTreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.BorderedTreeLayout.linkType Field

BorderedTreeLayout.linkType Field
[image]

The type of the links in the arranged tree.

Namespace: MindFusion.Graphs
Assembly: BorderedTreeLayout.js

Syntax

JavaScript [image] Copy Code

var linkType

Remarks

A member of the TreeLayoutLinkType enumeration. The default value is Default.

See Also

BorderedTreeLayout Members
BorderedTreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.BorderedTreeLayout.multipleGraphsPlacement Field

BorderedTreeLayout.multipleGraphsPlacement Field
[image]

Indicates how multiple independent graphs in the diagram should be positioned relatively to each other.

Namespace: MindFusion.Graphs
Assembly: BorderedTreeLayout.js

Syntax

JavaScript [image] Copy Code

var multipleGraphsPlacement

Remarks

A member of the MultipleGraphsPlacement enumeration. The default value is Horizontal.

See Also

BorderedTreeLayout Members
BorderedTreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.BorderedTreeLayout.nodeDistance Field

BorderedTreeLayout.nodeDistance Field
[image]

The space to leave between adjacent nodes on the same level.

Namespace: MindFusion.Graphs
Assembly: BorderedTreeLayout.js

Syntax

JavaScript [image] Copy Code

var nodeDistance

See Also

BorderedTreeLayout Members
BorderedTreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.BorderedTreeLayout Constructor

BorderedTreeLayout Constructor
[image]

Initializes a new instance of the BorderedTreeLayout class.

Namespace: MindFusion.Graphs
Assembly: BorderedTreeLayout.js

Syntax

JavaScript [image] Copy Code

function BorderedTreeLayout ()

See Also

BorderedTreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.BorderedTreeLayout Methods

BorderedTreeLayout Methods
[image]

Public Methods

Name | Description
arrange | Applies the layout to the specified graph.

See Also

BorderedTreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.BorderedTreeLayout.arrange Method

BorderedTreeLayout.arrange Method
[image]

Applies the layout to the specified graph.

Namespace: MindFusion.Graphs
Assembly: BorderedTreeLayout.js

Syntax

JavaScript [image] Copy Code

function arrange (graph)

Parameters

graph

The graph to arrange.

See Also

BorderedTreeLayout Members
BorderedTreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Edge Class

Edge Class
[image]

Represents an edge connecting two vertices in a graph.

Namespace: MindFusion.Graphs
Assembly: Edge.js

Syntax

JavaScript [image] Copy Code

// class
Edge.prototype = {}

Inheritance Hierarchy

See Also

Edge Members
MindFusion.Graphs Namespace


MindFusion.Graphs.Edge Members

Edge Members
Constructors Fields Methods
[image]

Represents an edge connecting two vertices in a graph.

The following tables list the members exposed by the Edge type.

Public Constructors

Name | Description
Edge | Initializes a new instance of the Edge class.

Public Fields

Name | Description
destination | The destination vertex.
origin | The origin vertex.

Public Methods

Name | Description
adjacentTo | Checks if the current edge is adjacent to the specified edge, that is, they have common vertex.
changeDestination | Changes the destination of the current edge to the specified vertex.
changeOrigin | Changes the origin of the current edge to the specified vertex.
createReverseEdge | Creates a new edge similar to the current edge but with reversed direction.
getCommonVertex | Returns a common vertex for the current edge and the specified edge.
getEnds | Returns an array containing the origin and destination vertices of this edge.
getOtherEnd | Returns the vertex connected by this edge that is not the specified vertex.
incidentWith | Checks if the current edge is incident with the specified vertex.
joins | Checks if the current edge connects the specified vertices.
reverse | Reverses this edge.

See Also

Edge Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Edge Fields

Edge Fields
[image]

Public Fields

Name | Description
destination | The destination vertex.
origin | The origin vertex.

See Also

Edge Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Edge.destination Field

Edge.destination Field
[image]

The destination vertex.

Namespace: MindFusion.Graphs
Assembly: Edge.js

Syntax

JavaScript [image] Copy Code

var destination

See Also

Edge Members
Edge Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Edge.origin Field

Edge.origin Field
[image]

The origin vertex.

Namespace: MindFusion.Graphs
Assembly: Edge.js

Syntax

JavaScript [image] Copy Code

var origin

See Also

Edge Members
Edge Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Edge Constructor

Edge Constructor
[image]

Initializes a new instance of the Edge class.

Namespace: MindFusion.Graphs
Assembly: Edge.js

Syntax

JavaScript [image] Copy Code

function Edge (origin, destination)

Parameters

origin

The origin vertex.

destination

The destination vertex.

See Also

Edge Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Edge Methods

Edge Methods
[image]

Public Methods

Name | Description
adjacentTo | Checks if the current edge is adjacent to the specified edge, that is, they have common vertex.
changeDestination | Changes the destination of the current edge to the specified vertex.
changeOrigin | Changes the origin of the current edge to the specified vertex.
createReverseEdge | Creates a new edge similar to the current edge but with reversed direction.
getCommonVertex | Returns a common vertex for the current edge and the specified edge.
getEnds | Returns an array containing the origin and destination vertices of this edge.
getOtherEnd | Returns the vertex connected by this edge that is not the specified vertex.
incidentWith | Checks if the current edge is incident with the specified vertex.
joins | Checks if the current edge connects the specified vertices.
reverse | Reverses this edge.

See Also

Edge Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Edge.adjacentTo Method

Edge.adjacentTo Method
[image]

Checks if the current edge is adjacent to the specified edge, that is, they have common vertex.

Namespace: MindFusion.Graphs
Assembly: Edge.js

Syntax

JavaScript [image] Copy Code

function adjacentTo (edge)

Parameters

edge

The edge to check.

Return Value

true if the current edge is adjacent to the specified edge; otherwise, false.

See Also

Edge Members
Edge Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Edge.changeDestination Method

Edge.changeDestination Method
[image]

Changes the destination of the current edge to the specified vertex.

Namespace: MindFusion.Graphs
Assembly: Edge.js

Syntax

JavaScript [image] Copy Code

function changeDestination (vertex)

Parameters

vertex

The new destination of the edge.

See Also

Edge Members
Edge Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Edge.changeOrigin Method

Edge.changeOrigin Method
[image]

Changes the origin of the current edge to the specified vertex.

Namespace: MindFusion.Graphs
Assembly: Edge.js

Syntax

JavaScript [image] Copy Code

function changeOrigin (vertex)

Parameters

vertex

The new origin of the edge.

See Also

Edge Members
Edge Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Edge.createReverseEdge Method

Edge.createReverseEdge Method
[image]

Creates a new edge similar to the current edge but with reversed direction.

Namespace: MindFusion.Graphs
Assembly: Edge.js

Syntax

JavaScript [image] Copy Code

function createReverseEdge ()

Return Value

See Also

Edge Members
Edge Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Edge.getCommonVertex Method

Edge.getCommonVertex Method
[image]

Returns a common vertex for the current edge and the specified edge.

Namespace: MindFusion.Graphs
Assembly: Edge.js

Syntax

JavaScript [image] Copy Code

function getCommonVertex (edge)

Parameters

edge

The edge for which to find common vertex.

Return Value

The common vertex if it exists, otherwise null.

See Also

Edge Members
Edge Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Edge.getEnds Method

Edge.getEnds Method
[image]

Returns an array containing the origin and destination vertices of this edge.

Namespace: MindFusion.Graphs
Assembly: Edge.js

Syntax

JavaScript [image] Copy Code

function getEnds ()

Return Value

An array containing the related vertices.

See Also

Edge Members
Edge Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Edge.getOtherEnd Method

Edge.getOtherEnd Method
[image]

Returns the vertex connected by this edge that is not the specified vertex.

Namespace: MindFusion.Graphs
Assembly: Edge.js

Syntax

JavaScript [image] Copy Code

function getOtherEnd (vertex)

Parameters

vertex

One of the vertices connected by this edge.

Return Value

The other vertex connected by this edge.

See Also

Edge Members
Edge Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Edge.incidentWith Method

Edge.incidentWith Method
[image]

Checks if the current edge is incident with the specified vertex.

Namespace: MindFusion.Graphs
Assembly: Edge.js

Syntax

JavaScript [image] Copy Code

function incidentWith (vertex)

Parameters

vertex

The vertex to check.

Return Value

true if the edge is incident with the vertex; otherwise, false.

See Also

Edge Members
Edge Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Edge.joins Method

Edge.joins Method
[image]

Checks if the current edge connects the specified vertices.

Namespace: MindFusion.Graphs
Assembly: Edge.js

Syntax

JavaScript [image] Copy Code

function joins (v1, v2)

Parameters

v1

The first vertex.

v2

The second vertex.

Return Value

true if the current edge connects the specified vertices; otherwise, false.

See Also

Edge Members
Edge Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Edge.reverse Method

Edge.reverse Method
[image]

Reverses this edge.

Namespace: MindFusion.Graphs
Assembly: Edge.js

Syntax

JavaScript [image] Copy Code

function reverse ()

See Also

Edge Members
Edge Class
MindFusion.Graphs Namespace


MindFusion.Graphs.FractalLayout Class

FractalLayout Class
[image]

The FractalLayout tree layout algorithm places child nodes symmetrically around their parent node. Nodes at the lowest level are arranged directly in a circle around their parent. At the upper level, the already arranged nodes form branches that are arranged in a circle around the new parent node. The algorithm is recursively repeated till the highest level is reached.

Namespace: MindFusion.Graphs
Assembly: FractalLayout.js

Syntax

JavaScript [image] Copy Code

// class
FractalLayout.prototype = {}

Inheritance Hierarchy

See Also

FractalLayout Members
MindFusion.Graphs Namespace


MindFusion.Graphs.FractalLayout Members

FractalLayout Members
Constructors Fields
[image]

The FractalLayout tree layout algorithm places child nodes symmetrically around their parent node. Nodes at the lowest level are arranged directly in a circle around their parent. At the upper level, the already arranged nodes form branches that are arranged in a circle around the new parent node. The algorithm is recursively repeated till the highest level is reached.

The following tables list the members exposed by the FractalLayout type.

Public Constructors

Name | Description
FractalLayout | Initializes a new instance of the FractalLayout class.

Public Fields

Name | Description
anchoring | Indicates how to align links to the anchor points of nodes.
keepGroupLayout | Indicates whether to treat each Group of nodes as a single vertex in the arranged graph.
multipleGraphsPlacement | Indicates how multiple independent graphs in the diagram should be positioned relatively to each other.
root | Specifies the node that should be placed at the center of the tree.

See Also

FractalLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.FractalLayout Fields

FractalLayout Fields
[image]

Public Fields

Name | Description
anchoring | Indicates how to align links to the anchor points of nodes.
keepGroupLayout | Indicates whether to treat each Group of nodes as a single vertex in the arranged graph.
multipleGraphsPlacement | Indicates how multiple independent graphs in the diagram should be positioned relatively to each other.
root | Specifies the node that should be placed at the center of the tree.

See Also

FractalLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.FractalLayout.anchoring Field

FractalLayout.anchoring Field
[image]

Indicates how to align links to the anchor points of nodes.

Namespace: MindFusion.Graphs
Assembly: FractalLayout.js

Syntax

JavaScript [image] Copy Code

var anchoring

Remarks

A member of the Anchoring enumeration. The default value is Ignore.

See Also

FractalLayout Members
FractalLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.FractalLayout.keepGroupLayout Field

FractalLayout.keepGroupLayout Field
[image]

Indicates whether to treat each Group of nodes as a single vertex in the arranged graph.

Namespace: MindFusion.Graphs
Assembly: FractalLayout.js

Syntax

JavaScript [image] Copy Code

var keepGroupLayout

See Also

FractalLayout Members
FractalLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.FractalLayout.multipleGraphsPlacement Field

FractalLayout.multipleGraphsPlacement Field
[image]

Indicates how multiple independent graphs in the diagram should be positioned relatively to each other.

Namespace: MindFusion.Graphs
Assembly: FractalLayout.js

Syntax

JavaScript [image] Copy Code

var multipleGraphsPlacement

Remarks

A member of the MultipleGraphsPlacement enumeration. The default value is Horizontal.

See Also

FractalLayout Members
FractalLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.FractalLayout.root Field

FractalLayout.root Field
[image]

Specifies the node that should be placed at the center of the tree.

Namespace: MindFusion.Graphs
Assembly: FractalLayout.js

Syntax

JavaScript [image] Copy Code

var root

See Also

FractalLayout Members
FractalLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.FractalLayout Constructor

FractalLayout Constructor
[image]

Initializes a new instance of the FractalLayout class.

Namespace: MindFusion.Graphs
Assembly: FractalLayout.js

Syntax

JavaScript [image] Copy Code

function FractalLayout ()

See Also

FractalLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Graph Class

Graph Class
[image]

Represents a graph.

Namespace: MindFusion.Graphs
Assembly: Graph.js

Syntax

JavaScript [image] Copy Code

// class
Graph.prototype = {}

Inheritance Hierarchy

See Also

Graph Members
MindFusion.Graphs Namespace


MindFusion.Graphs.Graph Members

Graph Members
Constructors Fields Methods
[image]

Represents a graph.

The following tables list the members exposed by the Graph type.

Public Constructors

Name | Description
Graph | Initializes a new instance of the Graph class.

Public Fields

Name | Description
edges | A list containing all edges in the graph.
vertices | A list containing all vertices in the graph.

Public Methods

Name | Description
addEdge | Adds an existing edge to the graph.
clone | Creates an exact copy of the current graph.
createEdge | Creates a new edge connecting the specified vertices and adds it to the graph.
createVertex | Creates a new vertex with the specified position and size and adds it to the graph.
getConnectedComponents | Returns a list with the connected subgraphs in the current graph.
makeAcyclic | Makes the graph acyclic by reversing the direction of selected edges.
removeEdge | Removes an edge from the graph.
tree | Returns a new graph object containing a subset of the vertices and edges of the original graph, such that the new graph is a tree.

See Also

Graph Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Graph Fields

Graph Fields
[image]

Public Fields

Name | Description
edges | A list containing all edges in the graph.
vertices | A list containing all vertices in the graph.

See Also

Graph Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Graph.edges Field

Graph.edges Field
[image]

A list containing all edges in the graph.

Namespace: MindFusion.Graphs
Assembly: Graph.js

Syntax

JavaScript [image] Copy Code

var edges

See Also

Graph Members
Graph Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Graph.vertices Field

Graph.vertices Field
[image]

A list containing all vertices in the graph.

Namespace: MindFusion.Graphs
Assembly: Graph.js

Syntax

JavaScript [image] Copy Code

var vertices

See Also

Graph Members
Graph Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Graph Constructor

Graph Constructor
[image]

Initializes a new instance of the Graph class.

Namespace: MindFusion.Graphs
Assembly: Graph.js

Syntax

JavaScript [image] Copy Code

function Graph ()

See Also

Graph Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Graph Methods

Graph Methods
[image]

Public Methods

Name | Description
addEdge | Adds an existing edge to the graph.
clone | Creates an exact copy of the current graph.
createEdge | Creates a new edge connecting the specified vertices and adds it to the graph.
createVertex | Creates a new vertex with the specified position and size and adds it to the graph.
getConnectedComponents | Returns a list with the connected subgraphs in the current graph.
makeAcyclic | Makes the graph acyclic by reversing the direction of selected edges.
removeEdge | Removes an edge from the graph.
tree | Returns a new graph object containing a subset of the vertices and edges of the original graph, such that the new graph is a tree.

See Also

Graph Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Graph.addEdge Method

Graph.addEdge Method
[image]

Adds an existing edge to the graph.

Namespace: MindFusion.Graphs
Assembly: Graph.js

Syntax

JavaScript [image] Copy Code

function addEdge (edge)

Parameters

edge

The edge to add.

See Also

Graph Members
Graph Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Graph.clone Method

Graph.clone Method
[image]

Creates an exact copy of the current graph.

Namespace: MindFusion.Graphs
Assembly: Graph.js

Syntax

JavaScript [image] Copy Code

function clone ([saveMapping])

Parameters

saveMapping
Optional.

Indicates whether to store vertex and edge mapping information in the copy.

Return Value

The newly created copy.

See Also

Graph Members
Graph Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Graph.createEdge Method

Graph.createEdge Method
[image]

Creates a new edge connecting the specified vertices and adds it to the graph.

Namespace: MindFusion.Graphs
Assembly: Graph.js

Syntax

JavaScript [image] Copy Code

function createEdge (origin, destination, [owner])

Parameters

origin

The origin vertex.

destination

The destination vertex.

owner
Optional.

The owner of the new edge.

Return Value

The newly created edge.

See Also

Graph Members
Graph Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Graph.createVertex Method

Graph.createVertex Method
[image]

Creates a new vertex with the specified position and size and adds it to the graph.

Namespace: MindFusion.Graphs
Assembly: Graph.js

Syntax

JavaScript [image] Copy Code

function createVertex (layoutRect, [owner])

Parameters

layoutRect

A rectangle specifying the position and size of the vertex.

owner
Optional.

The owner of the new vertex.

Return Value

The newly created vertex.

See Also

Graph Members
Graph Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Graph.getConnectedComponents Method

Graph.getConnectedComponents Method
[image]

Returns a list with the connected subgraphs in the current graph.

Namespace: MindFusion.Graphs
Assembly: Graph.js

Syntax

JavaScript [image] Copy Code

function getConnectedComponents ()

Return Value

An array with connected Graph objects.

See Also

Graph Members
Graph Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Graph.makeAcyclic Method

Graph.makeAcyclic Method
[image]

Makes the graph acyclic by reversing the direction of selected edges.

Namespace: MindFusion.Graphs
Assembly: Graph.js

Syntax

JavaScript [image] Copy Code

function makeAcyclic ()

Return Value

A list with all edges that were reversed in order to make the graph acyclic.

Remarks

Must be called on a simple connected graph.

See Also

Graph Members
Graph Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Graph.removeEdge Method

Graph.removeEdge Method
[image]

Removes an edge from the graph.

Namespace: MindFusion.Graphs
Assembly: Graph.js

Syntax

JavaScript [image] Copy Code

function removeEdge (edge)

Parameters

edge

The edge to remove.

See Also

Graph Members
Graph Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Graph.tree Method

Graph.tree Method
[image]

Returns a new graph object containing a subset of the vertices and edges of the original graph, such that the new graph is a tree.

Namespace: MindFusion.Graphs
Assembly: Graph.js

Syntax

JavaScript [image] Copy Code

function tree (root)

Parameters

root

The desired root vertex of the tree.

Return Value

The newly created tree.

See Also

Graph Members
Graph Class
MindFusion.Graphs Namespace


MindFusion.Graphs.LayeredLayout Class

LayeredLayout Class
Remarks See Also
[image]

Implements a layered graph layout algorithm.

Namespace: MindFusion.Graphs
Assembly: LayeredLayout.js

Syntax

JavaScript [image] Copy Code

// class
LayeredLayout.prototype = {}

Remarks

This algorithm assigns diagram nodes to distinct horizontal or vertical layers. While arranging the layers, the layout routine seeks to meet the following criteria:

  • connected nodes must be placed close together;
  • links must flow in one direction if possible;
  • links must cross as few layers as possible;
  • links must not cross other links;

To apply this layout to a diagram, create a LayeredLayout instance, set its members and invoke the arrange method of the Diagram class. The method lays out all subgraphs in a diagram.

The final appearance of arranged graphs depends mostly on the direction value, which defines the overall orientation of the layout. The layerDistance and nodeDistance values specify how much space to leave between adjacent layers and adjacent nodes in a layer.

Example

The following example applies a LayeredLayout to a diagram:

JavaScript [image] Copy Code
var layout = new MindFusion.Graphs.LayeredLayout();
layout.direction = MindFusion.Graphs.LayoutDirection.TopToBottom;
layout.siftingRounds = 3;
diagram.arrange(layout);

Inheritance Hierarchy

See Also

LayeredLayout Members
MindFusion.Graphs Namespace


MindFusion.Graphs.LayeredLayout Members

LayeredLayout Members
Constructors Fields Methods
[image]

Implements a layered graph layout algorithm.

The following tables list the members exposed by the LayeredLayout type.

Public Constructors

Name | Description
LayeredLayout | Initializes a new instance of the LayeredLayout class.

Public Fields

Name | Description
anchoring | Indicates how to align links to the anchor points of nodes.
direction | The orientation of the arranged graph.
keepGroupLayout | Indicates whether to treat each Group of nodes as a single vertex in the arranged graph.
layerDistance | The desired distance between layer axis lines.
multipleGraphsPlacement | Indicates how multiple independent graphs in the diagram should be positioned relatively to each other.
nodeDistance | The desired distance between adjacent nodes in a layer.
siftingRounds | The number of iterations to perform when untwining the layout.

Public Methods

Name | Description
arrange | Applies the layout to the specified graph.

See Also

LayeredLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.LayeredLayout Fields

LayeredLayout Fields
[image]

Public Fields

Name | Description
anchoring | Indicates how to align links to the anchor points of nodes.
direction | The orientation of the arranged graph.
keepGroupLayout | Indicates whether to treat each Group of nodes as a single vertex in the arranged graph.
layerDistance | The desired distance between layer axis lines.
multipleGraphsPlacement | Indicates how multiple independent graphs in the diagram should be positioned relatively to each other.
nodeDistance | The desired distance between adjacent nodes in a layer.
siftingRounds | The number of iterations to perform when untwining the layout.

See Also

LayeredLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.LayeredLayout.anchoring Field

LayeredLayout.anchoring Field
[image]

Indicates how to align links to the anchor points of nodes.

Namespace: MindFusion.Graphs
Assembly: LayeredLayout.js

Syntax

JavaScript [image] Copy Code

var anchoring

Remarks

A member of the Anchoring enumeration. The default value is Ignore.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.LayeredLayout.direction Field

LayeredLayout.direction Field
[image]

The orientation of the arranged graph.

Namespace: MindFusion.Graphs
Assembly: LayeredLayout.js

Syntax

JavaScript [image] Copy Code

var direction

Remarks

A member of the LayoutDirection enumeration. The default value is TopToBottom.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.LayeredLayout.keepGroupLayout Field

LayeredLayout.keepGroupLayout Field
[image]

Indicates whether to treat each Group of nodes as a single vertex in the arranged graph.

Namespace: MindFusion.Graphs
Assembly: LayeredLayout.js

Syntax

JavaScript [image] Copy Code

var keepGroupLayout

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.LayeredLayout.layerDistance Field

LayeredLayout.layerDistance Field
[image]

The desired distance between layer axis lines.

Namespace: MindFusion.Graphs
Assembly: LayeredLayout.js

Syntax

JavaScript [image] Copy Code

var layerDistance

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.LayeredLayout.multipleGraphsPlacement Field

LayeredLayout.multipleGraphsPlacement Field
[image]

Indicates how multiple independent graphs in the diagram should be positioned relatively to each other.

Namespace: MindFusion.Graphs
Assembly: LayeredLayout.js

Syntax

JavaScript [image] Copy Code

var multipleGraphsPlacement

Remarks

A member of the MultipleGraphsPlacement enumeration. The default value is Horizontal.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.LayeredLayout.nodeDistance Field

LayeredLayout.nodeDistance Field
[image]

The desired distance between adjacent nodes in a layer.

Namespace: MindFusion.Graphs
Assembly: LayeredLayout.js

Syntax

JavaScript [image] Copy Code

var nodeDistance

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.LayeredLayout.siftingRounds Field

LayeredLayout.siftingRounds Field
[image]

The number of iterations to perform when untwining the layout.

Namespace: MindFusion.Graphs
Assembly: LayeredLayout.js

Syntax

JavaScript [image] Copy Code

var siftingRounds

Remarks

The algorithm swaps node pairs on each layer aiming to decrease the number of crossing links. Setting a higher value to this property helps to decrease the number of crossings.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.LayeredLayout Constructor

LayeredLayout Constructor
[image]

Initializes a new instance of the LayeredLayout class.

Namespace: MindFusion.Graphs
Assembly: LayeredLayout.js

Syntax

JavaScript [image] Copy Code

function LayeredLayout ()

See Also

LayeredLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.LayeredLayout Methods

LayeredLayout Methods
[image]

Public Methods

Name | Description
arrange | Applies the layout to the specified graph.

See Also

LayeredLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.LayeredLayout.arrange Method

LayeredLayout.arrange Method
[image]

Applies the layout to the specified graph.

Namespace: MindFusion.Graphs
Assembly: LayeredLayout.js

Syntax

JavaScript [image] Copy Code

function arrange (graph)

Parameters

graph

The graph to arrange.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.LayoutDirection Enumeration

LayoutDirection Enumeration
[image]

Specifies the shape of the diagram links after they are laid out.

Namespace: MindFusion.Graphs
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
LayoutDirection = {}

Members

Member name | Description
BottomToTop | Value: 2. Indicates a bottom-to-top layout direction.
LeftToRight | Value: 1. Indicates a left-to-right layout direction.
RightToLeft | Value: 3. Indicates a right-to-left layout direction.
TopToBottom | Value: 0. Indicates a top-to-bottom layout direction.

See Also

MindFusion.Graphs Namespace


MindFusion.Graphs.MultipleGraphsPlacement Enumeration

MultipleGraphsPlacement Enumeration
[image]

Specifies placement of graph connected components relatively to each other.

Namespace: MindFusion.Graphs
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
MultipleGraphsPlacement = {}

Members

Member name | Description
Horizontal | Value: 1. Indicates that subgraphs should be placed in a row.
Vertical | Value: 0. Indicates that subgraphs should be placed in a column.

See Also

MindFusion.Graphs Namespace


MindFusion.Graphs.SpringLayout Class

SpringLayout Class
Remarks See Also
[image]

Implements the Spring-Embedder graph layout algorithm.

Namespace: MindFusion.Graphs
Assembly: SpringLayout.js

Syntax

JavaScript [image] Copy Code

// class
SpringLayout.prototype = {}

Remarks

To apply this layout to a diagram, create a SpringLayout instance, set its members and invoke the arrange method of the Diagram class. The method lays out all subgraphs in the diagram.

Spring-Embedder produces layouts having uniform distribution of nodes by simulating a physical system in which nodes repulse each other and the links between them act as confining springs. Nodes are moved around in an iterative process. The forces that act on a node are calculated, taking in account the positions of surrounding nodes and links from the previous iteration.

The final appearance of arranged graphs depends on the nodeDistance value that specifies how nodes are distributed by the layout routine. The layout routine runs as much iterations as set in iterations, calculating better node positions at each step.

Example

The following example applies a SpringLayout to a diagram:

JavaScript [image] Copy Code
var layout = new MindFusion.Graphs.SpringLayout();
layout.iterations = 100;
diagram.arrange(layout);

Inheritance Hierarchy

See Also

SpringLayout Members
MindFusion.Graphs Namespace


MindFusion.Graphs.SpringLayout Members

SpringLayout Members
Constructors Fields Methods
[image]

Implements the Spring-Embedder graph layout algorithm.

The following tables list the members exposed by the SpringLayout type.

Public Constructors

Name | Description
SpringLayout | Initializes a new instance of the SpringLayout class.

Public Fields

Name | Description
anchoring | Indicates how to align links to the anchor points of nodes.
iterations | The number of iterations to run the layout routine.
keepGroupLayout | Indicates whether to treat each Group of nodes as a single vertex in the arranged graph.
multipleGraphsPlacement | Indicates how multiple independent graphs in the diagram should be positioned relatively to each other.
nodeDistance | The desired distance between nodes.

Public Methods

Name | Description
arrange | Applies the layout to the specified graph.

See Also

SpringLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.SpringLayout Fields

SpringLayout Fields
[image]

Public Fields

Name | Description
anchoring | Indicates how to align links to the anchor points of nodes.
iterations | The number of iterations to run the layout routine.
keepGroupLayout | Indicates whether to treat each Group of nodes as a single vertex in the arranged graph.
multipleGraphsPlacement | Indicates how multiple independent graphs in the diagram should be positioned relatively to each other.
nodeDistance | The desired distance between nodes.

See Also

SpringLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.SpringLayout.anchoring Field

SpringLayout.anchoring Field
[image]

Indicates how to align links to the anchor points of nodes.

Namespace: MindFusion.Graphs
Assembly: SpringLayout.js

Syntax

JavaScript [image] Copy Code

var anchoring

Remarks

A member of the Anchoring enumeration. The default value is Ignore.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.SpringLayout.iterations Field

SpringLayout.iterations Field
[image]

The number of iterations to run the layout routine.

Namespace: MindFusion.Graphs
Assembly: SpringLayout.js

Syntax

JavaScript [image] Copy Code

var iterations

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.SpringLayout.keepGroupLayout Field

SpringLayout.keepGroupLayout Field
[image]

Indicates whether to treat each Group of nodes as a single vertex in the arranged graph.

Namespace: MindFusion.Graphs
Assembly: SpringLayout.js

Syntax

JavaScript [image] Copy Code

var keepGroupLayout

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.SpringLayout.multipleGraphsPlacement Field

SpringLayout.multipleGraphsPlacement Field
[image]

Indicates how multiple independent graphs in the diagram should be positioned relatively to each other.

Namespace: MindFusion.Graphs
Assembly: SpringLayout.js

Syntax

JavaScript [image] Copy Code

var multipleGraphsPlacement

Remarks

A member of the MultipleGraphsPlacement enumeration. The default value is Horizontal.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.SpringLayout.nodeDistance Field

SpringLayout.nodeDistance Field
[image]

The desired distance between nodes.

Namespace: MindFusion.Graphs
Assembly: SpringLayout.js

Syntax

JavaScript [image] Copy Code

var nodeDistance

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.SpringLayout Constructor

SpringLayout Constructor
[image]

Initializes a new instance of the SpringLayout class.

Namespace: MindFusion.Graphs
Assembly: SpringLayout.js

Syntax

JavaScript [image] Copy Code

function SpringLayout ()

See Also

SpringLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.SpringLayout Methods

SpringLayout Methods
[image]

Public Methods

Name | Description
arrange | Applies the layout to the specified graph.

See Also

SpringLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.SpringLayout.arrange Method

SpringLayout.arrange Method
[image]

Applies the layout to the specified graph.

Namespace: MindFusion.Graphs
Assembly: SpringLayout.js

Syntax

JavaScript [image] Copy Code

function arrange (graph)

Parameters

graph

The graph to arrange.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.TreeLayout Class

TreeLayout Class
Remarks See Also
[image]

Implements algorithms for arranging tree structures.

Namespace: MindFusion.Graphs
Assembly: TreeLayout.js

Syntax

JavaScript [image] Copy Code

// class
TreeLayout.prototype = {}

Remarks

To apply this layout to a diagram, create a TreeLayout instance, set its members and invoke the arrange method of the Diagram class. The method lays out all subtrees in a diagram.

As long as the graph is a tree, the algorithm can find the root node automatically. The distance between the root and the second level and between all subsequent levels can be set through the levelDistance field. The distance between adjacent nodes in the same level is set through nodeDistance.

In addition to arranging the tree nodes, TreeLayout also sets the shape of links as set through its linkType field.

Example

The following example applies a TreeLayout to a diagram:

JavaScript [image] Copy Code

var layout = new MindFusion.Graphs.TreeLayout();
layout.direction = MindFusion.Graphs.LayoutDirection.TopToBottom;
linkType = MindFusion.Graphs.TreeLayoutLinkType.Cascading;
diagram.arrange(layout);

Inheritance Hierarchy

See Also

TreeLayout Members
MindFusion.Graphs Namespace


MindFusion.Graphs.TreeLayout Members

TreeLayout Members
Constructors Fields Methods
[image]

Implements algorithms for arranging tree structures.

The following tables list the members exposed by the TreeLayout type.

Public Constructors

Name | Description
TreeLayout | Initializes a new instance of the TreeLayout class.

Public Fields

Name | Description
anchoring | Indicates how to align links to the anchor points of nodes.
compactAssistants | A Boolean value indicating whether the "assistant" nodes on the same side of a single parent are arranged as close to each other as possible. Turning this off will force the nodes on one side to be aligned with their counterparts in the other and occasionally leaving space between adjacent branches.
direction | The orientation of the arranged graph.
enableAssistants | A Boolean value indicating whether the "assistant" trait is regarded when applying the layout.
keepGroupLayout | Indicates whether to treat each Group of nodes as a single vertex in the arranged graph.
keepRootPosition | Indicates whether to keep the root node at its original position.
levelDistance | The space to leave between adjacent levels of the tree.
linkType | The type of the links in the arranged tree.
multipleGraphsPlacement | Indicates how multiple independent graphs in the diagram should be positioned relatively to each other.
nodeDistance | The space to leave between adjacent nodes on the same level.

Public Methods

Name | Description
arrange | Applies the layout to the specified graph.

See Also

TreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.TreeLayout Fields

TreeLayout Fields
[image]

Public Fields

Name | Description
anchoring | Indicates how to align links to the anchor points of nodes.
compactAssistants | A Boolean value indicating whether the "assistant" nodes on the same side of a single parent are arranged as close to each other as possible. Turning this off will force the nodes on one side to be aligned with their counterparts in the other and occasionally leaving space between adjacent branches.
direction | The orientation of the arranged graph.
enableAssistants | A Boolean value indicating whether the "assistant" trait is regarded when applying the layout.
keepGroupLayout | Indicates whether to treat each Group of nodes as a single vertex in the arranged graph.
keepRootPosition | Indicates whether to keep the root node at its original position.
levelDistance | The space to leave between adjacent levels of the tree.
linkType | The type of the links in the arranged tree.
multipleGraphsPlacement | Indicates how multiple independent graphs in the diagram should be positioned relatively to each other.
nodeDistance | The space to leave between adjacent nodes on the same level.

See Also

TreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.TreeLayout.anchoring Field

TreeLayout.anchoring Field
[image]

Indicates how to align links to the anchor points of nodes.

Namespace: MindFusion.Graphs
Assembly: TreeLayout.js

Syntax

JavaScript [image] Copy Code

var anchoring

Remarks

A member of the Anchoring enumeration. The default value is Ignore.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.TreeLayout.compactAssistants Field

TreeLayout.compactAssistants Field
[image]

A Boolean value indicating whether the "assistant" nodes on the same side of a single parent are arranged as close to each other as possible. Turning this off will force the nodes on one side to be aligned with their counterparts in the other and occasionally leaving space between adjacent branches.

Namespace: MindFusion.Graphs
Assembly: TreeLayout.js

Syntax

JavaScript [image] Copy Code

var compactAssistants

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.TreeLayout.direction Field

TreeLayout.direction Field
[image]

The orientation of the arranged graph.

Namespace: MindFusion.Graphs
Assembly: TreeLayout.js

Syntax

JavaScript [image] Copy Code

var direction

Remarks

A member of the LayoutDirection enumeration. The default value is TopToBottom.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.TreeLayout.enableAssistants Field

TreeLayout.enableAssistants Field
[image]

A Boolean value indicating whether the "assistant" trait is regarded when applying the layout.

Namespace: MindFusion.Graphs
Assembly: TreeLayout.js

Syntax

JavaScript [image] Copy Code

var enableAssistants

Remarks

true to enable assistant nodes, otherwise false; the default value is false.

Enabling this property lets you create organizational charts as in MS office. To designate some nodes as assistants, assign true as a value for the treeLayoutAssistant key in the node's LayoutTraits.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.TreeLayout.keepGroupLayout Field

TreeLayout.keepGroupLayout Field
[image]

Indicates whether to treat each Group of nodes as a single vertex in the arranged graph.

Namespace: MindFusion.Graphs
Assembly: TreeLayout.js

Syntax

JavaScript [image] Copy Code

var keepGroupLayout

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.TreeLayout.keepRootPosition Field

TreeLayout.keepRootPosition Field
[image]

Indicates whether to keep the root node at its original position.

Namespace: MindFusion.Graphs
Assembly: TreeLayout.js

Syntax

JavaScript [image] Copy Code

var keepRootPosition

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.TreeLayout.levelDistance Field

TreeLayout.levelDistance Field
[image]

The space to leave between adjacent levels of the tree.

Namespace: MindFusion.Graphs
Assembly: TreeLayout.js

Syntax

JavaScript [image] Copy Code

var levelDistance

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.TreeLayout.linkType Field

TreeLayout.linkType Field
[image]

The type of the links in the arranged tree.

Namespace: MindFusion.Graphs
Assembly: TreeLayout.js

Syntax

JavaScript [image] Copy Code

var linkType

Remarks

A member of the TreeLayoutLinkType enumeration. The default value is Default.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.TreeLayout.multipleGraphsPlacement Field

TreeLayout.multipleGraphsPlacement Field
[image]

Indicates how multiple independent graphs in the diagram should be positioned relatively to each other.

Namespace: MindFusion.Graphs
Assembly: TreeLayout.js

Syntax

JavaScript [image] Copy Code

var multipleGraphsPlacement

Remarks

A member of the MultipleGraphsPlacement enumeration. The default value is Horizontal.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.TreeLayout.nodeDistance Field

TreeLayout.nodeDistance Field
[image]

The space to leave between adjacent nodes on the same level.

Namespace: MindFusion.Graphs
Assembly: TreeLayout.js

Syntax

JavaScript [image] Copy Code

var nodeDistance

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.TreeLayout Constructor

TreeLayout Constructor
[image]

Initializes a new instance of the TreeLayout class.

Namespace: MindFusion.Graphs
Assembly: TreeLayout.js

Syntax

JavaScript [image] Copy Code

function TreeLayout ()

See Also

TreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.TreeLayout Methods

TreeLayout Methods
[image]

Public Methods

Name | Description
arrange | Applies the layout to the specified graph.

See Also

TreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.TreeLayout.arrange Method

TreeLayout.arrange Method
[image]

Applies the layout to the specified graph.

Namespace: MindFusion.Graphs
Assembly: TreeLayout.js

Syntax

JavaScript [image] Copy Code

function arrange (graph)

Parameters

graph

The graph to arrange.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Graphs Namespace


MindFusion.Graphs.TreeLayoutLinkType Enumeration

TreeLayoutLinkType Enumeration
[image]

Specifies the shape of the diagram links after they are laid out.

Namespace: MindFusion.Graphs
Assembly: Enum.js

Syntax

JavaScript [image] Copy Code

// enum
TreeLayoutLinkType = {}

Members

Member name | Description
Cascading | Value: 2. Indicates that links will be arranged as cascading and attached to the middles of the adjoining node sides.
Default | Value: 0. Indicates that links will be arranged to point to the centers of the related nodes.
Straight | Value: 1. Indicates that links will be attached to the middles of the adjoining node sides.

See Also

MindFusion.Graphs Namespace


MindFusion.Graphs.Vertex Class

Vertex Class
[image]

Represents a vertex in a graph.

Namespace: MindFusion.Graphs
Assembly: Vertex.js

Syntax

JavaScript [image] Copy Code

// class
Vertex.prototype = {}

Inheritance Hierarchy

See Also

Vertex Members
MindFusion.Graphs Namespace


MindFusion.Graphs.Vertex Members

Vertex Members
Constructors Fields Methods
[image]

Represents a vertex in a graph.

The following tables list the members exposed by the Vertex type.

Public Constructors

Name | Description
Vertex | Initializes a new instance of the Vertex class.

Public Fields

Name | Description
edges | A list containing all edges incident with this vertex.
inEdges | A list containing all incoming edges.
outEdges | A list containing all outgoing edges.
weight | The relative weight of this vertex.

Public Methods

Name | Description
adjacentTo | Checks if there is an edge connecting this vertex with the specified vertex.
degree | Returns the number of incident edges.
getCommonEdge | Finds the edge connecting the current vertex with the specified vertex.
getNeighbors | Returns an array containing all vertices adjacent to the current vertex.
incidentWith | Checks if the current vertex is incident with the specified edge.

See Also

Vertex Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Vertex Fields

Vertex Fields
[image]

Public Fields

Name | Description
edges | A list containing all edges incident with this vertex.
inEdges | A list containing all incoming edges.
outEdges | A list containing all outgoing edges.
weight | The relative weight of this vertex.

See Also

Vertex Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Vertex.edges Field

Vertex.edges Field
[image]

A list containing all edges incident with this vertex.

Namespace: MindFusion.Graphs
Assembly: Vertex.js

Syntax

JavaScript [image] Copy Code

var edges

See Also

Vertex Members
Vertex Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Vertex.inEdges Field

Vertex.inEdges Field
[image]

A list containing all incoming edges.

Namespace: MindFusion.Graphs
Assembly: Vertex.js

Syntax

JavaScript [image] Copy Code

var inEdges

See Also

Vertex Members
Vertex Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Vertex.outEdges Field

Vertex.outEdges Field
[image]

A list containing all outgoing edges.

Namespace: MindFusion.Graphs
Assembly: Vertex.js

Syntax

JavaScript [image] Copy Code

var outEdges

See Also

Vertex Members
Vertex Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Vertex.weight Field

Vertex.weight Field
[image]

The relative weight of this vertex.

Namespace: MindFusion.Graphs
Assembly: Vertex.js

Syntax

JavaScript [image] Copy Code

var weight

See Also

Vertex Members
Vertex Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Vertex Constructor

Vertex Constructor
[image]

Initializes a new instance of the Vertex class.

Namespace: MindFusion.Graphs
Assembly: Vertex.js

Syntax

JavaScript [image] Copy Code

function Vertex ()

See Also

Vertex Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Vertex Methods

Vertex Methods
[image]

Public Methods

Name | Description
adjacentTo | Checks if there is an edge connecting this vertex with the specified vertex.
degree | Returns the number of incident edges.
getCommonEdge | Finds the edge connecting the current vertex with the specified vertex.
getNeighbors | Returns an array containing all vertices adjacent to the current vertex.
incidentWith | Checks if the current vertex is incident with the specified edge.

See Also

Vertex Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Vertex.adjacentTo Method

Vertex.adjacentTo Method
[image]

Checks if there is an edge connecting this vertex with the specified vertex.

Namespace: MindFusion.Graphs
Assembly: Vertex.js

Syntax

JavaScript [image] Copy Code

function adjacentTo (vertex)

Parameters

vertex

The vertex to check.

Return Value

true if the vertices are connected; otherwise, false.

See Also

Vertex Members
Vertex Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Vertex.degree Method

Vertex.degree Method
[image]

Returns the number of incident edges.

Namespace: MindFusion.Graphs
Assembly: Vertex.js

Syntax

JavaScript [image] Copy Code

function degree ()

Return Value

The number of incident edges.

See Also

Vertex Members
Vertex Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Vertex.getCommonEdge Method

Vertex.getCommonEdge Method
[image]

Finds the edge connecting the current vertex with the specified vertex.

Namespace: MindFusion.Graphs
Assembly: Vertex.js

Syntax

JavaScript [image] Copy Code

function getCommonEdge (vertex)

Parameters

vertex

The vertex to find an edge for.

Return Value

The edge connecting the vertices or null.

See Also

Vertex Members
Vertex Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Vertex.getNeighbors Method

Vertex.getNeighbors Method
[image]

Returns an array containing all vertices adjacent to the current vertex.

Namespace: MindFusion.Graphs
Assembly: Vertex.js

Syntax

JavaScript [image] Copy Code

function getNeighbors ()

Return Value

A list with all neighbors.

See Also

Vertex Members
Vertex Class
MindFusion.Graphs Namespace


MindFusion.Graphs.Vertex.incidentWith Method

Vertex.incidentWith Method
[image]

Checks if the current vertex is incident with the specified edge.

Namespace: MindFusion.Graphs
Assembly: Vertex.js

Syntax

JavaScript [image] Copy Code

function incidentWith (edge)

Parameters

edge

The edge to check.

Return Value

true if the vertex is incident with the edge; otherwise, false.

See Also

Vertex Members
Vertex Class
MindFusion.Graphs Namespace


Server Side Reference

Server Side Reference


MindFusion.Diagramming Namespace

MindFusion.Diagramming Namespace
Classes Interfaces Structures Delegates Enumerations

Classes

Class | Description
AdjustmentHandle | Represents an adjustment handle used to move or modify diagram items.
AeroEffect | Represents an effect that adds semitransparency to the node and emphasizes its outline by adding a shade and an inner stroke.
AnchorPattern | Represents a set of anchor points, which specify the exact locations where links are allowed to connect to nodes.
AnchorPoint | Specify the locations in a node, to which the user is allowed to connect links.
AnchorPointCollection | Represents a strongly typed collection of anchor points.
AnchorPointEventArgs | Contains the arguments passed to the anchor point-related events, such as OriginAnchorChanged and DestinationAnchorChanged.
ArcTemplate | Represents an arc in a shape definition.
AreaEventArgs | Contains arguments passed to handlers of the CreatingArea event of the HtmlBuilder class.
ArrowHeads | Contains predefined arrowhead shapes.
BarcodeNode | Represents nodes that can encode and render barcodes.
BarcodeNodeProperties | Stores the values of BarcodeNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from BarcodeNode, do so by deriving from BarcodeNodeProperties and overriding the BarcodeNode.SaveProperties, BarcodeNode.RestoreProperties, and BarcodeNode.CreateProperties methods.
BarcodeNodeStyle | Represents a reusable set of properties that define the appearance of barcode nodes.
BezierTemplate | Represents a Bйzier curve in a shape definition.
CellEventArgs | Contains the arguments passed to event handlers, such as CellClicked.
CellValidationEventArgs | Contains the arguments passed to event handlers, such as CellTextEditing.
ClipboardEventArgs | Contains the arguments passed to the RequestClipboard event handlers.
CollectionBase(T) | An implementation of the IList<T> interface.
CommandHistory | Maintains a queue of Command records used to undo or redo actions.
CompositeNode | Represents a node, which can hold components.
CompositeNodeStyle | Represents a reusable set of properties that define the appearance of composite nodes.
ConnectionPoint | This class represents a connection between an edge and a node in a graph. It decouples the DiagramLink class from the DiagramNode class, allowing edges to connect different types of nodes without knowing anything of their implementation details. Each DiagramLink object contains two ConnectionPoint instances describing the connections at both ends of the link.
Constants | Contains various global constants, also provides measure unit independent constants.
ContainerChildEventArgs | Contains arguments passed to events related to container children.
ContainerNode | Represents a diagram node that can contain other nodes.
ContainerNodeProperties | Stores the values of ContainerNode properties during undo / redo operations.
ContainerNodeStyle | Represents a reusable set of properties that define the appearance of container nodes.
ControlPointEventArgs | Contains arguments passed to handlers of the ShapeModified event.
Converter | Provides capabilities to convert various types to and from strings in a culture-independent way.
Diagram | Represents a flow diagram.
DiagramBase | The base class of the Diagram and DiagramDocument classes.
DiagramDocument | Represents a collection of diagram pages.
DiagramEventArgs | Contains the arguments passed to event handlers, such as Clicked and DoubleClicked.
DiagramItem | Represents an item in the diagram document. All classes representing diagram elements derive from DiagramItem.
DiagramItemCollection | Represents a strongly typed collection of DiagramItem objects.
DiagramItemProperties | The base type for classes that store diagram item properties during undo / redo operations.
DiagramItemState | Contains a snapshot of the internal state of a diagram item. Instances of this class are used to store the state of items for later undo or redo operations.
DiagramItemStyle | Represents a reusable set of properties that define the appearance of diagram items.
DiagramLink | Represents a link between two diagram nodes.
DiagramLinkCollection | Represents a strongly typed collection of DiagramLink objects.
DiagramLinkProperties | Stores the values of DiagramLink properties during undo / redo operations.
DiagramLinkState | Contains a snapshot of the internal state of a DiagramLink.
DiagramLinkStyle | Represents a reusable set of properties that define the appearance of diagram links.
DiagramNode | Represents a diagram node.
DiagramNodeCollection | Represents a strongly typed collection of diagram nodes.
DiagramNodeEventArgs | Contains the arguments passed to the NodeSelected and NodeRemoved event handlers.
DiagramNodeProperties | The base class for classes that store the properties for a DiagramNode-derived items during undo / redo operations.
DiagramNodeState | Contains a snapshot of the internal state of a DiagramNode.
DiagramNodeStyle | Represents a reusable set of properties that define the appearance of diagram nodes.
DiagramPage | Represents a single page in a DiagramDocument object.
DiagramPageEventArgs | Contains the arguments passed to DiagramPage-related event handlers.
DiagramPageValidationEventArgs | Contains the arguments passed to handlers of DiagramPage validation events.
DiagramStyle | Represents a reusable set of properties that define the appearance of diagrams.
DraggedNode | Class used to hold the DiagramNode instance during drag and drop. It is used for easier detection of the dragged content as DragEventArgs.Data.GetData does not check super classes.
DraggedShape | Contains drag-and-drop information for a shape being dragged from ShapeToolBar and ShapeListBox.
DrawAnchorPointEventArgs | Contains the arguments passed to the DrawAnchorPoint event handlers.
DrawCellEventArgs | Contains the arguments passed to the DrawCell event handlers.
DrawItemEventArgs | Contains the arguments passed to the DrawAdjustmentHandles event handlers.
DrawLinkEventArgs | Contains the arguments passed to the DrawLink event handlers.
DrawNodeEventArgs | Contains the arguments passed to the DrawNode event handlers.
DummyNode | Represents virtual nodes used for disconnected links.
EditCellTextEventArgs | Contains the arguments passed to the CellTextEdited event handlers.
EditLinkTextEventArgs | Contains the arguments passed to the EditLinkTextEventHandler event handlers.
EditNodeTextEventArgs | Contains the arguments passed to the NodeTextEdited event handlers.
EffectsProvider | Provides smooth shadow and emboss effects for MvcDiagram nodes.
ElementTemplate | Represents an element of a shape definition. This is the parent class of specific element types, such as ArcTemplate, LineTemplate and BezierTemplate.
EmbossEffect | Represents an emboss effect.
Factory | Provides shortcut methods for creating and adding instances of the standard MvcDiagram item types. Call the class methods through the Factory property of the Diagram class.
GlassEffect | Represents a glass-like visual effect.
GridRouter | Implements a link routing algorithm that uses a grid to represent the free and occupied regions in the diagram.
Group | Represents a group of items in the diagram document.
Group.Attachment | Encapsulates attachment information.
GroupCollection | Represents a strongly typed collection of Group objects.
GroupEventArgs | Contains the arguments passed to handlers of group-related events, such as GroupDestroyed.
HandlesVisualStyle | Defines the Pen and Brush objects used to draw items' adjustment handles.
HitTestEventArgs | Contains the arguments passed to the HitTestAdjustmentHandles event handlers.
HtmlBuilder | Provides methods to create and use HTML client side image maps.
InstantiateItemEventArgs | Contains the arguments passed to the InstantiateItem event handlers.
InteractionState | Encapsulates the current state of user interaction with the control.
InternalUtils | Contains common helper methods, specific to MvcDiagram.
ItemCollectionBase(T) | A base collection class for the diagram item collections.
ItemEventArgs | Contains the arguments passed to item instantiation event handlers.
Layer | Represents a layer in a Diagram object.
LayerEventArgs | Contains the arguments passed to the LayerVisibilityChanged event handler.
LineTemplate | Represents a line segment in a shape definition.
LinkAdjustmentHandle | Represents an adjustment handle used to modify the position of a link's control point.
LinkEventArgs | Contains the arguments passed to handlers of link related events, such as LinkCreated and LinkDeleted.
LinkLabel | Represents a label displayed by a DiagramLink. New labels can be added to a link by calling the DiagramLink.AddLabel method.
LinkShapeEventArgs | Contains the arguments passed to the SetSelfLoopShape event handler.
LinkValidationEventArgs | Contains the arguments passed to handlers of link validation events.
MapContent | Represents the content of a map file.
MapNode | Represents nodes that can render geographical maps.
MapNodeProperties | Stores the values of MapNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from MapNode, do so by deriving from MapNodeProperties and overriding the MapNode.SaveProperties, MapNode.RestoreProperties, and MapNode.CreateProperties methods.
MeasureUnit | Represents a unit of measure.
NodeAdjustmentHandle | Represents an adjustment handle used to move, resize or rotate a node.
NodeConstraints | Defines specific constraints that can be applied to the size and location of nodes.
NodeEffect | Represents the base class of all visual effects that can be applied to the nodes in a Diagram.
NodeEventArgs | Contains the arguments passed to handlers of node-related events, such as TreeCollapsed and TreeExpanded.
NodeValidationEventArgs | Contains the arguments passed to handlers of node validation events.
NotATreeException | An exception raised by the TreeEnumerator class if the specified node does not represent a root of a tree.
NotifyCollectionChangedEventArgs(T) | Provides data for the ObservableCollection<T>.CollectionChanged event.
ObservableCollection(T) | Represents a dynamic data collection that provides notifications when items get added, removed, or when the whole list is refreshed.
Path | Represents a sequence of connected DiagramNode and DiagramLink elements.
PathCollection | Represents a strongly typed collection of Path objects.
PathFinder | Provides methods that help you find paths and cycles in a graph.
PersistableCollection(T) | A base collection class for persistable collections.
PersistContext | Contains methods that help serializing and deserializing complex MvcDiagram object to and from binary streams.
PointCollection | Represents a strongly typed collection of points.
QuickRouter | Implements a very fast link routing algorithm that uses a tree to represent the free and occupied regions in the diagram.
ReadOnlyCollection(T) | Represents a read-only wrapper of a collection.
ReadOnlyDiagramItemCollection | Represents a read-only collection of items.
ReadOnlyDiagramLinkCollection | Represents a read-only collection of links.
ReadOnlyDiagramNodeCollection | Represents a read-only collection of nodes.
RectangleFConverter | Converts from RectangleF to other data types.
RenderOptions | Provides properties that allow customization of various aspects of printing and print-preview.
RepaintEventArgs | Specifies the coordinates of the area that should be repainted by views when the Repaint event is raised.
RoundRectangleTemplate | Represents an ElementTemplate that draws round rectangle. This class ensures that the round corners do not change during resizing which is visually better. The drawback is that the radius appears to be specified in DiagramView Measure units and therefore a given shape instance will look bad when the measure unit is not the one for which the shape was designed.
RoutingOptions | Allows customization of various aspects of the link routing algorithm.
RowEventArgs | Contains the arguments passed to handlers of table row-related events, such as TableSectionCollapsed and TableSectionExpanded.
ScriptHelper | Allows calling some static MvcDiagram methods from JavaScript and VBScript. It seems the script languages do not allow calling class static methods, so a ScriptHelper instance property is provided by the Diagram class.
Selection | Represents a set of items selected in the diagram document.
SelectionCopy | Used internally in the implementation of copy/paste functions.
SelectionEventArgs | Contains the arguments passed to the SelectionModified event handler.
SelectionValidationEventArgs | Contains the arguments passed to the SelectionModifying event handler.
SerializeTagEventArgs | Contains the arguments passed to the SerializeTag and DeserializeTag event handlers.
Shape | An instance of this class represents a shape defined through a series of arc, line and Bйzier segments. The segments can be a part of the shape outline, in which case they define the part of the shape is filled, used for hit-testing and for aligning links to the node edges. Segments can also be added as decoration elements, in which case they only affect the appearance of a ShapeNode.
ShapeAdjustmentHandle | Represents an adjustment handle used to modify the Shape of a ShapeNode.
ShapeCollection | Represents a read-only collection of shapes.
ShapeControlPoint | Represents a control point that can be used to adjust the shape of a ShapeNode. Control point positions are passed as parameters to shape formulas, whose code can alter the coordinates of the shape's graphic primitives based on the parameter values.
ShapeConverter | Converts from Shape to other data types.
ShapeData | Contains the cached coordinates of the key points of a shape when the shape is applied to a specific ShapeNode. This class also stores additional data passed to custom shape-generation callbacks and to shape formula scripts.
ShapeDecoration | Defines decoration elements that are displayed as filled shapes.
ShapeEventArgs | Contains the arguments passed to the ShapeSelected and ShapeRenamed event handlers.
ShapeFormulaParam | Represents the position of a ShapeControlPoint, passed as parameter to shape formulas.
ShapeLibrary | The ShapeLibrary class represents a collection of shape definitions stored together.
ShapeNode | ShapeNode instances are diagram nodes that represent geometric shapes.
ShapeNodeProperties | Stores the values of ShapeNode properties during undo / redo operations.
ShapeNodeState | Contains a snapshot of the internal state of a ShapeNode. Instances of this class are used to store the state of nodes for later undo or redo operations. If you derive from ShapeNode and need to implement undo support for the additional internal state defined by your class, do so by deriving from ShapeNodeState and overriding the ShapeNode.CreateState, ShapeNode.SaveState and ShapeNode.RestoreState methods.
ShapeNodeStyle | Represents a reusable set of properties that define the appearance of shape nodes.
Shapes | Provides alternative method of access to the MvcDiagram predefined shapes, that allows code completion and IntelliSense support, which is not available when using Shape.FromId.
SizeFConverter | Converts from SizeF to other data types.
SmoothShadowEffect | Represents an effect that smooths the shadow of nodes. This effect does nothing if shadows are not visible.
Style | Represents an unordered dynamic collection of properties that can be identified by name.
StylePropertyChangedEventArgs | Contains the arguments passed to handlers of the PropertyChanged event.
SvgNode | Represents nodes that can render SVG drawings.
SvgNodeProperties | Stores the values of SvgNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from SvgNode, do so by deriving from SvgNodeProperties and overriding the SvgNode.SaveProperties, SvgNode.RestoreProperties, and SvgNode.CreateProperties methods.
SvgNodeStyle | Represents a reusable set of properties that define the appearance of SVG nodes.
TableNode | Tables are diagram nodes that can contain multiple cells and can be related to other nodes through their rows.
TableNode.Cell | Represents a cell in a TableNode instance.
TableNode.CellCollection | Represents a strongly-typed collection of TableNode.Cell objects.
TableNode.Column | Represents a column of a TableNode.
TableNode.ColumnCollection | Represents a strongly-typed collection of TableNode.Column objects.
TableNode.Row | Represents a row in TableNode node.
TableNode.RowCollection | Represents a strongly-typed collection of TableNode.Row objects.
TableNodeProperties | Stores the values of TableNode properties during undo / redo operations.
TableNodeStyle | Represents a reusable set of properties that define the appearance of table nodes.
Theme | Represents a set of Style objects for different diagram item types.
ThicknessConverter | The TypeConverter of the Thickness structure.
TimerEventArgs | Contains the arguments passed to timer-related event handlers.
TreeEnumerator | Enables an easy standard method to iterate over the elements of a tree-like structure of objects.
TreeItemEventArgs | Contains the arguments passed to handlers of TreeViewItem-related events.
TreeItemValidationEventArgs | Contains the arguments passed to event handlers, such as TreeItemTextEditing.
TreeViewConnectionPoint | Represents a connection between a link and a TreeViewNode.
TreeViewItem | Represents a constituent item of the hierarchy displayed inside a TreeViewNode.
TreeViewNode | Represents nodes that can draw hierarchical data.
TreeViewNodeStyle | Represents a reusable set of properties that define the appearance of tree view nodes.
UndoEventArgs | Contains the arguments passed to the ActionRecorded, ActionUndone and ActionRedone event handlers.
UndoManager | Implements undo/redo functionality in MvcDiagram.
UndoValidationEventArgs | Contains the arguments passed to the ActionRecording event handlers.
VisioContent | Represents the content of a VisioNode.
VisioNode | Represents a node that can display shapes from Visio stencils.
VisioNodeProperties | Stores the values of VisioNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from VisioNode, do so by deriving from VisioNodeProperties and overriding the VisioNode.SaveProperties, VisioNode.RestoreProperties, and VisioNode.CreateProperties methods.
VisioNodeStyle | Represents a reusable set of properties that define the appearance of Visio nodes.
VisioStencil | Represents a Visio stencil.
XmlPersistContext | Contains methods that can help you serialize and deserialize MvcDiagram items to end from XML documents.

Interfaces

Interface | Description
IDiagramView | Controls that display Diagram objects must implement this interface to provide screen resolution information to drawing methods.
IEffectsProvider | Visual effects provider.
IItemFactory | Defines an interface for constructing IPersists objects.
ILinkRouter | Defines methods that should be implemented by a link-router component. The control calls them when a new link path should be set in response to changes in the diagram, such as adding or modifying nodes.
IMeasureUnitConverter | Provides means to convert between cross-type measure units.
InplaceEditable | Represents an in-place editable object.
IPersists | Base interface for serializable MvcDiagram objects.
IProperty | Represents a property that can have an undefined value.
IResolution | Provides information about device resolution.

Structures

Structure | Description
Thickness | Describes the thickness of a rectangular frame.
Vector | Represents a two-dimensional vector.

Delegates

Delegate | Description
CreatePathDelegate | Specifies the signature of callback functions used to generate dynamic node shapes.
VisitNode | Defines the prototype for methods called by VisitNodes.

Enumerations

Enumeration | Description
Action | Defines values that identify the possible actions a user can carry out on diagram items.
AdjustmentHandles | Identifies the distinct selection handles of a node.
Anchoring | Defines values that specify how automatic layout algorithms align links to anchor points.
AttachTo | Specifies the type of attachment in a group.
AttachToLink | Defines values specifying the possible ways to attach a node to a link.
AttachToNode | Defines values specifying the possible ways to attach a node to another node.
AutoResize | Defines in which directions automatic resizing can enlarge the diagram scrollable area.
Axis | Specifies a coordinate axis.
Behavior | Defines values that specify how the component responds to actions performed by the user.
CellFrameStyle | Specifies the style of the cells' frame lines.
ColumnStyle | Specifies how table columns' width is set.
ContainmentKeys | For internal use.
ControlMouseAction | Specifies available ways to handle mouse clicks on .NET controls hosted in a ControlNode.
CursorHint | Specifies what mouse cursor to display while a user interacts with the diagram.
CustomDraw | Specifies what kind of custom painting to perform on diagram elements.
DelKeyAction | Specifies the type of action performed when the user presses the DEL key.
DirectionConstraint | Defines values that specify in what direction to constrain node movement.
ExpandButtonAction | Specifies what action is triggered by the [±] buttons that are displayed near expandable nodes.
ExpandButtonPosition | Defines values that specify possible locations for expand/collapse buttons.
FitSize | Specifies how the ResizeToFitText method should resize a node.
GlassEffectType | Specifies the type of a GlassEffect node effect.
Granularity | Specifies the granularity of the obstacles map generated by QuickRouter.
GridStyle | Defines values that specify the visual style of the alignment grid.
GroupAnchorStyles | Specifies the master node edges to which a subordinate node can be anchored.
GroupRotation | Defines values that indicate how rotation of a group's master node affects the nodes attached to that group.
HandlesStyle | Enumerates possible visual styles for frames that are drawn around selected nodes.
HitTestPriority | Defines values that specify the order of item hit-testing.
HitTestResult | Represents the return value from a hit test.
HyperLinkStyle | Specifies how various export components should treat the HyperLink property of items.
Key | A copy of the System.Windows.Forms.Key enumeration used to propagate input information to manipulators and components.
LinkCrossings | Defines values that indicate how to render link intersection points.
LinkShape | Specifies available styles for the segments of links.
LinkTextStyle | Specifies the position and alignment of links' labels.
MarkStyle | Specifies the visual style of anchor point marks.
MeasureUnitType | Specifies the type of a unit of measure.
ModificationStart | Specifies how the user can start modifying an item.
ModifierKeyAction | Defines the actions that can be assigned to a modifier key such as CTRL or ALT.
MouseButton | Specifies constants that define which mouse button was pressed.
MouseButtonActions | Specifies what actions can be associated with the middle and right mouse buttons.
NodeHandleType | Identifies the types of selection handles of a node.
NotifyCollectionChangedAction | Describes the action that caused a CollectionChanged event.
Orientation | Defines values that specify the orientation of the first segment of cascading links.
Relationship | Specifies the type of relationship between two tables.
RelativeToLink | Specifies how the link labels are positioned.
RenderTarget | Specifies where the diagram is being rendered.
RerouteLinks | Provides values indicating in what circumstances links must be rerouted automatically.
RestrictToBounds | Specifies a restriction of the position of items relatively to the diagram bounds.
SaveToStringFormat | Specifies in what format to save the diagram when generating a string using the SaveToString method.
SelectionStyle | Defines values that specify how multiple selected items are indicated visually.
ShadowsStyle | Enumerates possible shadows-drawing styles.
ShowAnchors | Specifies when anchors points should be displayed.
SimpleShape | Defines the possible values for Shape property of tables.
SnapToAnchor | Specifies when link ends are snapped to nearest anchor points.
TableConnectionStyle | Specifies the possible values for the ConnectionStyle property of tables.
TreeViewConnectionStyle | Specifies the possible values for the ConnectionStyle property of TreeViewNode objects.
UnitType | Defines values that indicate whether point positions are specified in percentage, or in absolute units relative to the node's top-left corner.
View3D | Defines keys used to associate 3D position data with a node through the LayoutTraits property.


MindFusion.Diagramming.Action Enumeration

Action Enumeration
[image]

Defines values that identify the possible actions a user can carry out on diagram items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum Action

Visual Basic [image] Copy Code

Public Enum Action

Members

Member name | Description
None | Do not perform any action.
Create | Draw a new item.
Modify | Modify an existing item.
Split | Split a link's segment.

Remarks

Members of this enumeration are used as parameters of the InteractionState constructor.

See Also


MindFusion.Diagramming.AdjustmentHandle Class

AdjustmentHandle Class
[image]

Represents an adjustment handle used to move or modify diagram items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class AdjustmentHandle

Visual Basic [image] Copy Code

Public Class AdjustmentHandle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.AdjustmentHandle
MindFusion.Diagramming.LinkAdjustmentHandle
MindFusion.Diagramming.NodeAdjustmentHandle
MindFusion.Diagramming.ShapeAdjustmentHandle

See Also

AdjustmentHandle Members


MindFusion.Diagramming.AdjustmentHandle Members

AdjustmentHandle Members
Constructors Methods
[image]

Represents an adjustment handle used to move or modify diagram items.

The following tables list the members exposed by the AdjustmentHandle type.

Public Constructors

Name | Description
AdjustmentHandle | Initializes a new instance of the AdjustmentHandle class.

Public Methods

Name | Description
IsMoveHandle | Returns a value indicating whether this handle is used to move items.

See Also

AdjustmentHandle Class


MindFusion.Diagramming.AdjustmentHandle Constructor

AdjustmentHandle Constructor
[image]

Initializes a new instance of the AdjustmentHandle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AdjustmentHandle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AdjustmentHandle Class


MindFusion.Diagramming.AdjustmentHandle Methods

AdjustmentHandle Methods
[image]

Public Methods

Name | Description
IsMoveHandle | Returns a value indicating whether this handle is used to move items.

See Also

AdjustmentHandle Class


MindFusion.Diagramming.AdjustmentHandle.IsMoveHandle Method

AdjustmentHandle.IsMoveHandle Method
[image]

Returns a value indicating whether this handle is used to move items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool IsMoveHandle ()

Visual Basic [image] Copy Code

Public Overridable Function IsMoveHandle () As Boolean

Return Value

true if this is a move handle, or false otherwise.

See Also

AdjustmentHandle Members
AdjustmentHandle Class


MindFusion.Diagramming.AdjustmentHandles Enumeration

AdjustmentHandles Enumeration
[image]

Identifies the distinct selection handles of a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum AdjustmentHandles

Visual Basic [image] Copy Code

Public Enum AdjustmentHandles

Members

Member name | Description
None | Specifies that none of the selection handles can be used to modify the node.
ResizeTopLeft | The top-left handle is enabled and can be used to resize the node.
ResizeTopRight | The top-right handle is enabled and can be used to resize the node.
ResizeBottomRight | The bottom-right handle is enabled and can be used to resize the node.
ResizeBottomLeft | The bottom-left handle is enabled and can be used to resize the node.
ResizeTopCenter | The top-center handle is enabled and can be used to resize the node vertically.
TopHandles | The top-left, top-center and top-right handles are enabled.
ResizeMiddleRight | The middle-right handle is enabled and can be used to resize the node horizontally.
RightHandles | The top-right, bottom-right and middle-right handles are enabled.
ResizeBottomCenter | The bottom-center handle is enabled and can be used to resize the node vertically.
BottomHandles | The bottom-left, bottom-center and bottom-right handles are enabled.
ResizeMiddleLeft | The middle-left handle is enabled and can be used to resize the node horizontally.
LeftHandles | The top-left, middle-left and bottom-left handles are enabled.
Move | The center selection handle is enabled and can be used to move the node.
Rotate | The rotation handle is enabled and can be used to rotate the node.
All | All selection handles are enabled and can be used to modify the node.

Remarks

A combination of these flags can be assigned to the EnabledHandles property of nodes.

See Also


MindFusion.Diagramming.AeroEffect Class

AeroEffect Class
Remarks See Also
[image]

Represents an effect that adds semitransparency to the node and emphasizes its outline by adding a shade and an inner stroke.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class AeroEffect : NodeEffect

Visual Basic [image] Copy Code

Public NotInheritable Class AeroEffect
Inherits NodeEffect

Remarks

This effect can be applied to the nodes in a Diagram by adding an instance of this class to the NodeEffects collection.

The following image illustrates the Aero effect applied to a rectangular node as well as how the different properties affect the output:

Example

The following example demonstrates how to apply aero effect to the nodes of an existing diagram.

C# [image] Copy Code

diagram.NodeEffects.Add(new AeroEffect());

Visual Basic [image] Copy Code

diagram.NodeEffects.Add(New AeroEffect())

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.NodeEffect
MindFusion.Diagramming.AeroEffect

See Also

AeroEffect Members


MindFusion.Diagramming.AeroEffect Members

AeroEffect Members
Constructors Properties Methods Events
[image]

Represents an effect that adds semitransparency to the node and emphasizes its outline by adding a shade and an inner stroke.

The following tables list the members exposed by the AeroEffect type.

Public Constructors

Name | Description
AeroEffect | Initializes a new instance of the AeroEffect class.

Public Properties

Name | Description
InnerOutlineColor | Gets or sets the color of the inner outline.
Opacity | Gets or sets the opacity to apply to the node's background.
ShadeColor | Gets or sets the color of the shade.

Public Methods

Name | Description
Clone | NodeEffect.Clone override.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation. (Inherited from NodeEffect.)

See Also

AeroEffect Class


MindFusion.Diagramming.AeroEffect Constructor

AeroEffect Constructor
[image]

Initializes a new instance of the AeroEffect class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AeroEffect ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AeroEffect Class


MindFusion.Diagramming.AeroEffect Methods

AeroEffect Methods
[image]

Public Methods

Name | Description
Clone | NodeEffect.Clone override.

See Also

AeroEffect Class


MindFusion.Diagramming.AeroEffect.Clone Method

AeroEffect.Clone Method
[image]

NodeEffect.Clone override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

The copy of this effect.

See Also

AeroEffect Members
AeroEffect Class


MindFusion.Diagramming.AeroEffect Properties

AeroEffect Properties
[image]

Public Properties

Name | Description
InnerOutlineColor | Gets or sets the color of the inner outline.
Opacity | Gets or sets the opacity to apply to the node's background.
ShadeColor | Gets or sets the color of the shade.

See Also

AeroEffect Class


MindFusion.Diagramming.AeroEffect.InnerOutlineColor Property

AeroEffect.InnerOutlineColor Property
[image]

Gets or sets the color of the inner outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color InnerOutlineColor { get; set; }

Visual Basic [image] Copy Code

Public Property InnerOutlineColor As Color

Property Value

A .NET Color object. The default is White.

See Also

AeroEffect Members
AeroEffect Class


MindFusion.Diagramming.AeroEffect.Opacity Property

AeroEffect.Opacity Property
[image]

Gets or sets the opacity to apply to the node's background.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Opacity { get; set; }

Visual Basic [image] Copy Code

Public Property Opacity As Single

Property Value

A float value.

Remarks

Opacity varies in the range [0..1] where 0 indicates full transparency and 1 indicates the original transparency. Opacity has no effect on image backgrounds.

See Also

AeroEffect Members
AeroEffect Class


MindFusion.Diagramming.AeroEffect.ShadeColor Property

AeroEffect.ShadeColor Property
[image]

Gets or sets the color of the shade.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color ShadeColor { get; set; }

Visual Basic [image] Copy Code

Public Property ShadeColor As Color

Property Value

A .NET Color object. The default is Black.

See Also

AeroEffect Members
AeroEffect Class


MindFusion.Diagramming.AeroEffect Events

AeroEffect Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation. (Inherited from NodeEffect.)

See Also

AeroEffect Class


MindFusion.Diagramming.NodeEffect.PropertyChanged Event

NodeEffect.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

See Also

NodeEffect Members
NodeEffect Class


MindFusion.Diagramming.Anchoring Enumeration

Anchoring Enumeration
[image]

Defines values that specify how automatic layout algorithms align links to anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum Anchoring

Visual Basic [image] Copy Code

Public Enum Anchoring

Members

Member name | Description
Ignore | Anchor points are ignored.
Keep | Links are aligned to their original anchor points.
Reassign | Links are aligned to new anchor points, depending on the positions of graph nodes after a layout is applied.

Remarks

Assign values of this enumeration to the Anchoring property of layout algorithms. Most algorithms produce best results if they can place link ends at arbitrary positions over nodes' outlines, that is, when using the Ignore value. If your application logic requires links to be always attached to anchor points, use the other two values. In such cases Reassign would yield better results.

See Also

MindFusion.Diagramming Namespace
AnchorPattern Class
TreeLayout Class
GridLayout Class
LayeredLayout Class
SpringLayout Class


MindFusion.Diagramming.AnchorPattern Class

AnchorPattern Class
Remarks See Also
[image]

Represents a set of anchor points, which specify the exact locations where links are allowed to connect to nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class AnchorPattern : ICloneable, IPersists

Visual Basic [image] Copy Code

Public Class AnchorPattern
Implements ICloneable, IPersists

Remarks

A pattern can be assigned as an integral entity to the AnchorPattern property of nodes. By default, when assigning a pattern to a node, a new copy of the pattern is created. Thus you can modify nodes' anchor patterns independently at runtime. However, if your anchor patterns won't change while the application executes, you can register them as shared to save storage space for the diagram. To do so, use AnchorPattern constructors that take a string id parameter. The AnchorPattern class exposes several predefined patterns as static properties; all of them are considered shared.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.AnchorPattern

See Also

AnchorPattern Members


MindFusion.Diagramming.AnchorPattern Members

AnchorPattern Members
Constructors Properties Methods
[image]

Represents a set of anchor points, which specify the exact locations where links are allowed to connect to nodes.

The following tables list the members exposed by the AnchorPattern type.

Public Constructors

Name | Description
AnchorPattern | Overloaded. Initializes a new instance of the AnchorPattern class.

Public Properties

Name | Description
Decision1In3Out | Gets the predefined anchor pattern Decision1In3Out.
Decision2In2Out | Gets the predefined anchor pattern Decision2In2Out.
Id | Gets the AnchorPattern unique identifier.
LeftInRightOut | Gets the predefined anchor pattern LeftInRightOut.
Points | Gets a collection of the anchor points in this pattern.
TopInBottomOut | Gets the predefined anchor pattern TopInBottomOut.

Public Methods

Name | Description
Clone | Creates an exact clone of this AnchorPattern object.
FromId | Returns a reference to the anchor pattern with the specified string identifier.
Register | Registers an anchor pattern as shared.

See Also

AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Constructor

AnchorPattern Constructor
[image]

Initializes a new instance of the AnchorPattern class.

Overload List

Name | Description
AnchorPattern () | Initializes a new empty instance of the AnchorPattern class.
AnchorPattern (AnchorPoint[]) | Initializes a new instance of the AnchorPattern class with the specified anchor points.
AnchorPattern (AnchorPoint[], String) | Initializes a new instance of the AnchorPattern class with the specified anchor points.
AnchorPattern (AnchorPointCollection) | Initializes a new instance of the AnchorPattern class with the specified anchor points.
AnchorPattern (AnchorPointCollection, String) | Initializes a new instance of the AnchorPattern class with the specified anchor points.
AnchorPattern (String) | Initializes a new empty instance of the AnchorPattern class.

See Also

AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Constructor ()

AnchorPattern Constructor ()
See Also
[image]

Initializes a new empty instance of the AnchorPattern class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Constructor (AnchorPoint[])

AnchorPattern Constructor (AnchorPoint[])
See Also
[image]

Initializes a new instance of the AnchorPattern class with the specified anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern (
AnchorPoint[] points
)

Visual Basic [image] Copy Code

Public Sub AnchorPattern ( _
points As AnchorPoint() _
)

Parameters

points
Contains the initial set of AnchorPoint instances for the new pattern.

Example

The following code creates a decision node with two incoming anchors at the top and the left, and two outgoing at the bottom and the right vertices.

C# [image] Copy Code

AnchorPattern decision2In2Out =
new AnchorPattern(new AnchorPoint[] {
new AnchorPoint(50, 0, true, false, MarkStyle.Circle, Color.Blue),
new AnchorPoint(0, 50, true, false, MarkStyle.Circle, Color.Blue),
new AnchorPoint(50, 100, false, true, MarkStyle.Rectangle, Color.Green),
new AnchorPoint(100, 50, false, true, MarkStyle.Rectangle, Color.Red)
});

ShapeNode decisionNode = diagram.Factory.CreateShapeNode(10, 10, 50, 35);
decisionNode.AnchorPattern = decision2In2Out;

Visual Basic [image] Copy Code

Dim decision2In2Out As AnchorPattern = _
New AnchorPattern(New AnchorPoint() { _
New AnchorPoint(50, 0, True, False, MarkStyle.Circle, Color.Blue), _
New AnchorPoint(0, 50, True, False, MarkStyle.Circle, Color.Blue), _
New AnchorPoint(50, 100, False, True, MarkStyle.Rectangle, Color.Green), _
New AnchorPoint(100, 50, False, True, MarkStyle.Rectangle, Color.Red) _
})

Dim decisionNode As ShapeNode = Diagram.Factory.CreateShapeNode(10, 10, 50, 35)
decisionNode.AnchorPattern = decision2In2Out

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Constructor (AnchorPoint[], String)

AnchorPattern Constructor (AnchorPoint[], String)
See Also
[image]

Initializes a new instance of the AnchorPattern class with the specified anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern (
AnchorPoint[] points,
string id
)

Visual Basic [image] Copy Code

Public Sub AnchorPattern ( _
points As AnchorPoint(), _
id As String _
)

Parameters

points
Contains the initial set of AnchorPoint instances for the new pattern.
id

An unique identifier for this anchor pattern.

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Constructor (AnchorPointCollection)

AnchorPattern Constructor (AnchorPointCollection)
See Also
[image]

Initializes a new instance of the AnchorPattern class with the specified anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern (
AnchorPointCollection points
)

Visual Basic [image] Copy Code

Public Sub AnchorPattern ( _
points As AnchorPointCollection _
)

Parameters

points
A collection of AnchorPoint objects.

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Constructor (AnchorPointCollection, String)

AnchorPattern Constructor (AnchorPointCollection, String)
See Also
[image]

Initializes a new instance of the AnchorPattern class with the specified anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern (
AnchorPointCollection points,
string id
)

Visual Basic [image] Copy Code

Public Sub AnchorPattern ( _
points As AnchorPointCollection, _
id As String _
)

Parameters

points
A collection of AnchorPoint objects.
id

An unique identifier for this anchor pattern.

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Constructor (String)

AnchorPattern Constructor (String)
See Also
[image]

Initializes a new empty instance of the AnchorPattern class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern (
string id
)

Visual Basic [image] Copy Code

Public New ( _
id As String _
)

Parameters

id

An unique identifier for this anchor pattern.

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Methods

AnchorPattern Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact clone of this AnchorPattern object.
FromId | Returns a reference to the anchor pattern with the specified string identifier.
Register | Registers an anchor pattern as shared.

See Also

AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.Clone Method

AnchorPattern.Clone Method
[image]

Creates an exact clone of this AnchorPattern object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

An instance of the AnchorPattern class.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.FromId Method

AnchorPattern.FromId Method
[image]

Returns a reference to the anchor pattern with the specified string identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static AnchorPattern FromId (
string id
)

Visual Basic [image] Copy Code

Public Shared Function FromId ( _
id As String _
) As AnchorPattern

Parameters

id
A string identifying an AnchorPattern instance.

Return Value

The AnchorPattern object whose Id is equal to the id parameter, or null (Nothing in Visual Basic) if no such object exists.

Remarks

The id argument should match an identifier passed to the constructor of an existing AnchorPattern object.

See Also

AnchorPattern Members
AnchorPattern Class
MindFusion.Diagramming Namespace
Shape Property
Shapes Property


MindFusion.Diagramming.AnchorPattern.Register Method

AnchorPattern.Register Method
[image]

Registers an anchor pattern as shared.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void Register (
AnchorPattern pattern
)

Visual Basic [image] Copy Code

Public Shared Sub Register ( _
pattern As AnchorPattern _
)

Parameters

pattern

The AnchorPattern to register.

Remarks

This method is obsolete. Please use the Id property to create shared anchor patterns.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Properties

AnchorPattern Properties
[image]

Public Properties

Name | Description
Decision1In3Out | Gets the predefined anchor pattern Decision1In3Out.
Decision2In2Out | Gets the predefined anchor pattern Decision2In2Out.
Id | Gets the AnchorPattern unique identifier.
LeftInRightOut | Gets the predefined anchor pattern LeftInRightOut.
Points | Gets a collection of the anchor points in this pattern.
TopInBottomOut | Gets the predefined anchor pattern TopInBottomOut.

See Also

AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.Decision1In3Out Property

AnchorPattern.Decision1In3Out Property
[image]

Gets the predefined anchor pattern Decision1In3Out.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static AnchorPattern Decision1In3Out { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Decision1In3Out As AnchorPattern

Property Value

An instance of the AnchorPattern class.

Remarks

Incoming links connect to the top vertex; outgoing links can start from the other vertices.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.Decision2In2Out Property

AnchorPattern.Decision2In2Out Property
[image]

Gets the predefined anchor pattern Decision2In2Out.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static AnchorPattern Decision2In2Out { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Decision2In2Out As AnchorPattern

Property Value

An instance of the AnchorPattern class.

Remarks

Incoming links can connect with the top and left vertices; outgoing links can start from the right and bottom vertices.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.Id Property

AnchorPattern.Id Property
[image]

Gets the AnchorPattern unique identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Id { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Id As String

Property Value

The string id that was passed as an argument to the AnchorPattern constructor. The default is an empty string.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.LeftInRightOut Property

AnchorPattern.LeftInRightOut Property
[image]

Gets the predefined anchor pattern LeftInRightOut.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static AnchorPattern LeftInRightOut { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property LeftInRightOut As AnchorPattern

Property Value

An instance of the AnchorPattern class.

Remarks

The middle point of a node's bounding rectangle left side is anchor for incoming links; that on the right side - for outgoing.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.Points Property

AnchorPattern.Points Property
[image]

Gets a collection of the anchor points in this pattern.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPointCollection Points { get; set; }

Visual Basic [image] Copy Code

Public Property Points As AnchorPointCollection

Property Value

The string id that was passed as an argument to the AnchorPattern constructor. The default is an empty string.

Remarks

To find an anchor pattern by its id, call the static FromId method.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.TopInBottomOut Property

AnchorPattern.TopInBottomOut Property
[image]

Gets the predefined anchor pattern TopInBottomOut.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static AnchorPattern TopInBottomOut { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property TopInBottomOut As AnchorPattern

Property Value

An instance of the AnchorPattern class.

Remarks

The middle point of a node's bounding rectangle top side is anchor for incoming links; that on the bottom - for outgoing.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPoint Class

AnchorPoint Class
Remarks See Also
[image]

Specify the locations in a node, to which the user is allowed to connect links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class AnchorPoint : ICloneable, IPersists

Visual Basic [image] Copy Code

Public NotInheritable Class AnchorPoint
Implements ICloneable, IPersists

Remarks

An anchor point can accept incoming or outgoing links, or both, as specified by the AllowIncoming and AllowOutgoing properties. The position of the anchor point inside a node's bounding rectangle is set through the X and Y properties, expressed as percent of the rectangle width and height.

How anchor points are marked on the display can be set using MarkStyle and Color properties. Custom painting can be done by setting MarkStyle to Custom and handling the DrawAnchorPoint event.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.AnchorPoint

See Also

AnchorPoint Members


MindFusion.Diagramming.AnchorPoint Members

AnchorPoint Members
Constructors Properties Methods
[image]

Specify the locations in a node, to which the user is allowed to connect links.

The following tables list the members exposed by the AnchorPoint type.

Public Constructors

Name | Description
AnchorPoint | Overloaded. The following constructors are provided for creating new AnchorPoint objects.

Public Properties

Name | Description
AllowIncoming | Gets or sets a value indicating whether incoming links can be connected to this anchor.
AllowOutgoing | Gets or sets a value indicating whether the anchor point accepts outgoing connections.
Color | Gets or sets the color of the anchor point mark.
Column | Gets or sets the column index of a cell with which the anchor point is associated.
MarkStyle | Gets or sets the appearance of the anchor point mark.
Tag | Gets or sets a user-defined data associated with the anchor point.
ToolTip | Gets or sets a tooltip text that should be displayed when the mouse hovers over an anchor point mark.
X | Gets or sets the horizontal position of the anchor point expressed as percent of a node's width.
XUnit | Gets or sets whether the point's X position is specified as percentage of node's size or fixed offset from the node's left side.
Y | Gets or sets the vertical position of the anchor point expressed as percent of a node's height.
YUnit | Gets or sets whether the point's Y position is specified as percentage of node's size or fixed offset from the node's top side.

Public Methods

Name | Description
Clone | Creates an exact clone of this AnchorPoint object.

See Also

AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Constructor

AnchorPoint Constructor
[image]

The following constructors are provided for creating new AnchorPoint objects.

Overload List

Name | Description
AnchorPoint (Single, Single) | Initializes a new instance of the AnchorPoint class with the specified coordinates.
AnchorPoint (Single, Single, Boolean, Boolean) | Initializes a new instance of the AnchorPoint class with the specified coordinates and restrictions.
AnchorPoint (Single, Single, Boolean, Boolean, Color, Int32) | Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions and color.
AnchorPoint (Single, Single, Boolean, Boolean, Color, Int32, Object) | Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions, color and tag.
AnchorPoint (Single, Single, Boolean, Boolean, MarkStyle) | Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions and style.
AnchorPoint (Single, Single, Boolean, Boolean, MarkStyle, Color) | Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions, style and color.

See Also

AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Constructor (Single, Single)

AnchorPoint Constructor (Single, Single)
See Also
[image]

Initializes a new instance of the AnchorPoint class with the specified coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPoint (
float x,
float y
)

Visual Basic [image] Copy Code

Public New ( _
x As Single, _
y As Single _
)

Parameters

x
The horizontal position of the anchor expressed as percent of the width of a node.
y
The vertical position of the anchor expressed as percent of the height of a node.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Constructor (Single, Single, Boolean, Boolean)

AnchorPoint Constructor (Single, Single, Boolean, Boolean)
See Also
[image]

Initializes a new instance of the AnchorPoint class with the specified coordinates and restrictions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPoint (
float x,
float y,
bool allowIncoming,
bool allowOutgoing
)

Visual Basic [image] Copy Code

Public New ( _
x As Single, _
y As Single, _
allowIncoming As Boolean, _
allowOutgoing As Boolean _
)

Parameters

x
The horizontal position of the anchor expressed as percent of the width of a node.
y
The vertical position of the anchor expressed as percent of the height of a node.
allowIncoming
Specifies whether incoming links can connect to this anchor.
allowOutgoing
Specifies whether outgoing links can connect to this anchor.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Constructor (Single, Single, Boolean, Boolean, Color, Int32)

AnchorPoint Constructor (Single, Single, Boolean, Boolean, Color, Int32)
See Also
[image]

Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions and color.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPoint (
float x,
float y,
bool allowIncoming,
bool allowOutgoing,
Color color,
int col
)

Visual Basic [image] Copy Code

Public New ( _
x As Single, _
y As Single, _
allowIncoming As Boolean, _
allowOutgoing As Boolean, _
color As Color, _
col As Integer _
)

Parameters

x
The horizontal position of the anchor expressed as percent of the width of a node.
y
The vertical position of the anchor expressed as percent of the height of a node.
allowIncoming
Specifies whether incoming links can connect to this anchor.
allowOutgoing
Specifies whether outgoing links can connect to this anchor.
color
The color with which the anchor mark is painted.
col
Specifies a table's column, with which an anchor point is associated.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Constructor (Single, Single, Boolean, Boolean, Color, Int32, Object)

AnchorPoint Constructor (Single, Single, Boolean, Boolean, Color, Int32, Object)
See Also
[image]

Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions, color and tag.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPoint (
float x,
float y,
bool allowIncoming,
bool allowOutgoing,
Color color,
int col,
Object tag
)

Visual Basic [image] Copy Code

Public New ( _
x As Single, _
y As Single, _
allowIncoming As Boolean, _
allowOutgoing As Boolean, _
color As Color, _
col As Integer, _
tag As Object _
)

Parameters

x
The horizontal position of the anchor expressed as percent of the width of a node.
y
The vertical position of the anchor expressed as percent of the height of a node.
allowIncoming
Specifies whether incoming links can connect to this anchor.
allowOutgoing
Specifies whether outgoing links can connect to this anchor.
color
The color with which the anchor mark is painted.
col
The table's column, with which an anchor point is associated.
tag
User-defined data associated with the anchor point.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Constructor (Single, Single, Boolean, Boolean, MarkStyle)

AnchorPoint Constructor (Single, Single, Boolean, Boolean, MarkStyle)
See Also
[image]

Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions and style.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPoint (
float x,
float y,
bool allowIncoming,
bool allowOutgoing,
MarkStyle markStyle
)

Visual Basic [image] Copy Code

Public Sub AnchorPoint ( _
x As Single, _
y As Single, _
allowIncoming As Boolean, _
allowOutgoing As Boolean, _
markStyle As MarkStyle _
)

Parameters

x
The horizontal position of the anchor expressed as percent of the width of a node.
y
The vertical position of the anchor expressed as percent of the height of a node.
allowIncoming
Specifies whether incoming links can connect to this anchor.
allowOutgoing
Specifies whether outgoing links can connect to this anchor.
markStyle
Defines how the anchor point is marked visually.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Constructor (Single, Single, Boolean, Boolean, MarkStyle, Color)

AnchorPoint Constructor (Single, Single, Boolean, Boolean, MarkStyle, Color)
See Also
[image]

Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions, style and color.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPoint (
float x,
float y,
bool allowIncoming,
bool allowOutgoing,
MarkStyle markStyle,
Color color
)

Visual Basic [image] Copy Code

Public Sub AnchorPoint ( _
x As Single, _
y As Single, _
allowIncoming As Boolean, _
allowOutgoing As Boolean, _
markStyle As MarkStyle, _
color As Color _
)

Parameters

x
The horizontal position of the anchor expressed as percent of the width of a node.
y
The vertical position of the anchor expressed as percent of the height of a node.
allowIncoming
Specifies whether incoming links can connect to this anchor.
allowOutgoing
Specifies whether outgoing links can connect to this anchor.
markStyle
Defines how the anchor point is marked visually.
color
The color with which the anchor mark is painted.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Methods

AnchorPoint Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact clone of this AnchorPoint object.

See Also

AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.Clone Method

AnchorPoint.Clone Method
[image]

Creates an exact clone of this AnchorPoint object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

An instance of the AnchorPoint class.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Properties

AnchorPoint Properties
[image]

Public Properties

Name | Description
AllowIncoming | Gets or sets a value indicating whether incoming links can be connected to this anchor.
AllowOutgoing | Gets or sets a value indicating whether the anchor point accepts outgoing connections.
Color | Gets or sets the color of the anchor point mark.
Column | Gets or sets the column index of a cell with which the anchor point is associated.
MarkStyle | Gets or sets the appearance of the anchor point mark.
Tag | Gets or sets a user-defined data associated with the anchor point.
ToolTip | Gets or sets a tooltip text that should be displayed when the mouse hovers over an anchor point mark.
X | Gets or sets the horizontal position of the anchor point expressed as percent of a node's width.
XUnit | Gets or sets whether the point's X position is specified as percentage of node's size or fixed offset from the node's left side.
Y | Gets or sets the vertical position of the anchor point expressed as percent of a node's height.
YUnit | Gets or sets whether the point's Y position is specified as percentage of node's size or fixed offset from the node's top side.

See Also

AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.AllowIncoming Property

AnchorPoint.AllowIncoming Property
[image]

Gets or sets a value indicating whether incoming links can be connected to this anchor.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowIncoming { get; set; }

Visual Basic [image] Copy Code

Public Property AllowIncoming As Boolean

Property Value

true to allow incoming links connect to the anchor; false to forbid that. The default is true.

Remarks

If no incoming anchors are defined for a node, links end points can be placed anywhere inside that node, unless AllowUnanchoredLinks is disabled.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming Namespace
AllowOutgoing Property
ValidateAnchorPoint Event


MindFusion.Diagramming.AnchorPoint.AllowOutgoing Property

AnchorPoint.AllowOutgoing Property
[image]

Gets or sets a value indicating whether the anchor point accepts outgoing connections.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowOutgoing { get; set; }

Visual Basic [image] Copy Code

Public Property AllowOutgoing As Boolean

Property Value

true to allow outgoing links connect to the anchor; false to forbid that. The default is true.

Remarks

If no outgoing anchors are defined for a node, links start points can be placed anywhere inside that node, unless AllowUnanchoredLinks is disabled.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming Namespace
AllowIncoming Property
ValidateAnchorPoint Event


MindFusion.Diagramming.AnchorPoint.Color Property

AnchorPoint.Color Property
[image]

Gets or sets the color of the anchor point mark.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color Color { get; set; }

Visual Basic [image] Copy Code

Public Property Color As Color

Property Value

An instance of the .NET Color structure. The default is Color.Black.

Remarks

The anchor mark shape specified by MarkStyle is painted with this color.

See Also

AnchorPoint Members
AnchorPoint Class
MarkStyle Property


MindFusion.Diagramming.AnchorPoint.Column Property

AnchorPoint.Column Property
[image]

Gets or sets the column index of a cell with which the anchor point is associated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Column { get; set; }

Visual Basic [image] Copy Code

Public Property Column As Integer

Property Value

An integer value specifying the zero-based index of a table's column. The default is -1.

Remarks

This property is useful when the anchor point is included in table row's AnchorPattern. It defines whether the anchor point is relative to a cell or to a whole row. If Column is set to -1, the point relative coordinates specify percents of row's extents. Otherwise the point coordinates specify percents of cell's extents.

See Also

AnchorPoint Members
AnchorPoint Class
Row.AnchorPattern Property


MindFusion.Diagramming.AnchorPoint.MarkStyle Property

AnchorPoint.MarkStyle Property
[image]

Gets or sets the appearance of the anchor point mark.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MarkStyle MarkStyle { get; set; }

Visual Basic [image] Copy Code

Public Property MarkStyle As MarkStyle

Property Value

A member of the MarkStyle enumeration. The default is MarkStyle.X.

Remarks

Specifies how anchor points are marked visually on the display. Custom code can be used to draw the marks by setting the property value to MarkStyle.Custom and handling the DrawAnchorPoint event.

See Also

AnchorPoint Members
AnchorPoint Class
Color Property


MindFusion.Diagramming.AnchorPoint.Tag Property

AnchorPoint.Tag Property
[image]

Gets or sets a user-defined data associated with the anchor point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An instance of any class derived from System.Object. The default is null (Nothing in Visual Basic).

Remarks

This property holds data that you define. MvcDiagram does not use it in any way. You might associate with the anchor point any value of primitive data types. The tag also might be a complex object from the .NET class library or a class defined by you. If the tag is an instance of value type, it will be serialized together with the object containing it when saving / loading a diagram. Reference types are serialized if marked with the [Serializable] attribute or if they implement the ISerializable interface.

See Also

AnchorPoint Members
AnchorPoint Class
SerializeTag Event


MindFusion.Diagramming.AnchorPoint.ToolTip Property

AnchorPoint.ToolTip Property
[image]

Gets or sets a tooltip text that should be displayed when the mouse hovers over an anchor point mark.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ToolTip { get; set; }

Visual Basic [image] Copy Code

Public Property ToolTip As String

Property Value

A string specifying the tool-tip text displayed for this anchor point. The default is an empty string.

Remarks

When the mouse rests for a while over an anchor point, the tool-tip text is displayed in a small popup window near the mouse cursor. If the anchor point tooltip is an empty string, the ToolTip of the node to which the anchor point is assigned is displayed instead.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.X Property

AnchorPoint.X Property
[image]

Gets or sets the horizontal position of the anchor point expressed as percent of a node's width.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float X { get; set; }

Visual Basic [image] Copy Code

Public Property X As Single

Property Value

A float value specifying the location of the anchor point, expressed in percent.

Remarks

Set the property value to a number from 0 to 100, otherwise you might get unexpected behavior.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming Namespace
Y Property
XUnit Property


MindFusion.Diagramming.AnchorPoint.XUnit Property

AnchorPoint.XUnit Property
[image]

Gets or sets whether the point's X position is specified as percentage of node's size or fixed offset from the node's left side.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public UnitType XUnit { get; set; }

Visual Basic [image] Copy Code

Public Property XUnit As UnitType

Property Value

A member of the UnitType enumeration. The default value is Percentage.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming Namespace
X Property
YUnit Property


MindFusion.Diagramming.AnchorPoint.Y Property

AnchorPoint.Y Property
[image]

Gets or sets the vertical position of the anchor point expressed as percent of a node's height.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Y { get; set; }

Visual Basic [image] Copy Code

Public Property Y As Single

Property Value

A float value specifying the location of the anchor point, expressed in percent.

Remarks

Set the property value to a number from 0 to 100, otherwise you might get unexpected behavior.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming Namespace
X Property
YUnit Property


MindFusion.Diagramming.AnchorPoint.YUnit Property

AnchorPoint.YUnit Property
[image]

Gets or sets whether the point's Y position is specified as percentage of node's size or fixed offset from the node's top side.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public UnitType YUnit { get; set; }

Visual Basic [image] Copy Code

Public Property YUnit As UnitType

Property Value

A member of the UnitType enumeration. The default value is Percentage.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming Namespace
Y Property
XUnit Property


MindFusion.Diagramming.AnchorPointCollection Class

AnchorPointCollection Class
[image]

Represents a strongly typed collection of anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class AnchorPointCollection : PersistableCollection<AnchorPoint>

Visual Basic [image] Copy Code

Public Class AnchorPointCollection
Inherits PersistableCollection(Of AnchorPoint)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.CollectionBase(AnchorPoint)
MindFusion.Diagramming.PersistableCollection(AnchorPoint)
MindFusion.Diagramming.AnchorPointCollection

See Also

AnchorPointCollection Members


MindFusion.Diagramming.AnchorPointCollection Members

AnchorPointCollection Members
Constructors Fields Properties Methods
[image]

Represents a strongly typed collection of anchor points.

The following tables list the members exposed by the AnchorPointCollection type.

Public Constructors

Name | Description
AnchorPointCollection | Overloaded.

Protected Fields

Name | Description
InnerList | Gets a List<T> containing the list of elements in the collection instance. (Inherited from CollectionBase.)

Public Properties

Name | Description
Count | Gets the number of elements actually contained in the collection. (Inherited from CollectionBase.)
IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index. (Inherited from CollectionBase.)

Public Methods

Name | Description
Add | Adds the specified anchor point to the collection.
Add | Adds an object to the end of the collection. (Inherited from CollectionBase.)
Clear | Removes all anchor points from the collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from CollectionBase.)
GetAt | Gets the anchor point at the specified position.
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified anchor point in the collection at the specified position.
Insert | Inserts an element into the collection at the specified index. (Inherited from CollectionBase.)
Remove | Removes the specified anchor point from the collection.
Remove | Removes the first occurrence of a specific object from the collection. (Inherited from CollectionBase.)
RemoveAt | Removes the anchor point at the specified index of the collection.
Sort | Overloaded. (Inherited from CollectionBase.)

See Also

AnchorPointCollection Class


MindFusion.Diagramming.AnchorPointCollection Constructor

AnchorPointCollection Constructor
[image]

Overload List

Name | Description
AnchorPointCollection () | Initializes a new instance of the AnchorPointCollection class.
AnchorPointCollection (AnchorPoint[]) | Initializes a new instance of the AnchorPointCollection class.

See Also

AnchorPointCollection Class


MindFusion.Diagramming.AnchorPointCollection Constructor ()

AnchorPointCollection Constructor ()
See Also
[image]

Initializes a new instance of the AnchorPointCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPointCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AnchorPointCollection Constructor Overload List
AnchorPointCollection Class


MindFusion.Diagramming.AnchorPointCollection Constructor (AnchorPoint[])

AnchorPointCollection Constructor (AnchorPoint[])
See Also
[image]

Initializes a new instance of the AnchorPointCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPointCollection (
AnchorPoint[] array
)

Visual Basic [image] Copy Code

Public Sub AnchorPointCollection ( _
array As AnchorPoint() _
)

Parameters

array

See Also

AnchorPointCollection Constructor Overload List
AnchorPointCollection Class


MindFusion.Diagramming.AnchorPointCollection Methods

AnchorPointCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified anchor point to the collection.
Add | Adds an object to the end of the collection. (Inherited from CollectionBase.)
Clear | Removes all anchor points from the collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from CollectionBase.)
GetAt | Gets the anchor point at the specified position.
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified anchor point in the collection at the specified position.
Insert | Inserts an element into the collection at the specified index. (Inherited from CollectionBase.)
Remove | Removes the specified anchor point from the collection.
Remove | Removes the first occurrence of a specific object from the collection. (Inherited from CollectionBase.)
RemoveAt | Removes the anchor point at the specified index of the collection.
Sort | Overloaded. (Inherited from CollectionBase.)

See Also

AnchorPointCollection Class


MindFusion.Diagramming.AnchorPointCollection.Add Method

AnchorPointCollection.Add Method
[image]

Adds the specified anchor point to the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Add (
AnchorPoint point
)

Visual Basic [image] Copy Code

Public Overrides Sub Add( _
point As AnchorPoint _
)

Parameters

point

See Also

AnchorPointCollection Members
AnchorPointCollection Class


MindFusion.Diagramming.AnchorPointCollection.Clear Method

AnchorPointCollection.Clear Method
[image]

Removes all anchor points from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Clear ()

Visual Basic [image] Copy Code

Public Overrides Sub Clear ()

See Also

AnchorPointCollection Members
AnchorPointCollection Class


MindFusion.Diagramming.AnchorPointCollection.GetAt Method

AnchorPointCollection.GetAt Method
[image]

Gets the anchor point at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPoint GetAt (
int index
)

Visual Basic [image] Copy Code

Public Function GetAt ( _
index As Integer _
) As AnchorPoint

Parameters

index

Return Value

See Also

AnchorPointCollection Members
AnchorPointCollection Class


MindFusion.Diagramming.AnchorPointCollection.Insert Method

AnchorPointCollection.Insert Method
[image]

Inserts the specified anchor point in the collection at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Insert (
int index,
AnchorPoint point
)

Visual Basic [image] Copy Code

Public Overrides Sub Insert( _
index As Integer, _
point As AnchorPoint _
)

Parameters

index

point

See Also

AnchorPointCollection Members
AnchorPointCollection Class


MindFusion.Diagramming.AnchorPointCollection.Remove Method

AnchorPointCollection.Remove Method
[image]

Removes the specified anchor point from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool Remove (
AnchorPoint point
)

Visual Basic [image] Copy Code

Public Overrides Function Remove( _
point As AnchorPoint _
) As Boolean

Parameters

point

Return Value

See Also

AnchorPointCollection Members
AnchorPointCollection Class


MindFusion.Diagramming.AnchorPointCollection.RemoveAt Method

AnchorPointCollection.RemoveAt Method
[image]

Removes the anchor point at the specified index of the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void RemoveAt (
int index
)

Visual Basic [image] Copy Code

Public Overrides Sub RemoveAt( _
index As Integer _
)

Parameters

index

See Also

AnchorPointCollection Members
AnchorPointCollection Class


MindFusion.Diagramming.AnchorPointEventArgs Class

AnchorPointEventArgs Class
[image]

Contains the arguments passed to the anchor point-related events, such as OriginAnchorChanged and DestinationAnchorChanged.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class AnchorPointEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class AnchorPointEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.AnchorPointEventArgs

See Also

AnchorPointEventArgs Members


MindFusion.Diagramming.AnchorPointEventArgs Members

AnchorPointEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the anchor point-related events, such as OriginAnchorChanged and DestinationAnchorChanged.

The following tables list the members exposed by the AnchorPointEventArgs type.

Public Constructors

Name | Description
AnchorPointEventArgs | Initializes a new instance of the AnchorPointEventArgs class.

Public Properties

Name | Description
Link | Gets the link whose anchor point index has been changed.
NewAnchorIndex | Gets the index of the new anchor point.
OldAnchorIndex | Gets the index of the old anchor point.

See Also

AnchorPointEventArgs Class


MindFusion.Diagramming.AnchorPointEventArgs Constructor

AnchorPointEventArgs Constructor
[image]

Initializes a new instance of the AnchorPointEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPointEventArgs (
DiagramLink link,
int oldAnchorIndex,
int newAnchorIndex
)

Visual Basic [image] Copy Code

Public Sub AnchorPointEventArgs ( _
link As DiagramLink, _
oldAnchorIndex As Integer, _
newAnchorIndex As Integer _
)

Parameters

link

The link whose end has been attached to a different anchor point.

oldAnchorIndex
The index of the old anchor point.
newAnchorIndex
The index of the new anchor point.

See Also

AnchorPointEventArgs Class


MindFusion.Diagramming.AnchorPointEventArgs Properties

AnchorPointEventArgs Properties
[image]

Public Properties

Name | Description
Link | Gets the link whose anchor point index has been changed.
NewAnchorIndex | Gets the index of the new anchor point.
OldAnchorIndex | Gets the index of the old anchor point.

See Also

AnchorPointEventArgs Class


MindFusion.Diagramming.AnchorPointEventArgs.Link Property

AnchorPointEventArgs.Link Property
[image]

Gets the link whose anchor point index has been changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink Link { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Link As DiagramLink

Property Value

An instance of the DiagramLink class.

See Also

AnchorPointEventArgs Members
AnchorPointEventArgs Class


MindFusion.Diagramming.AnchorPointEventArgs.NewAnchorIndex Property

AnchorPointEventArgs.NewAnchorIndex Property
[image]

Gets the index of the new anchor point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int NewAnchorIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewAnchorIndex As Integer

Property Value

An integer value that represents the index of the anchor point within its containing AnchorPattern class.

See Also

AnchorPointEventArgs Members
AnchorPointEventArgs Class


MindFusion.Diagramming.AnchorPointEventArgs.OldAnchorIndex Property

AnchorPointEventArgs.OldAnchorIndex Property
[image]

Gets the index of the old anchor point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int OldAnchorIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldAnchorIndex As Integer

Property Value

An integer value that represents the index of the anchor point within its containing AnchorPattern class.

See Also

AnchorPointEventArgs Members
AnchorPointEventArgs Class


MindFusion.Diagramming.ArcTemplate Class

ArcTemplate Class
[image]

Represents an arc in a shape definition.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ArcTemplate : ElementTemplate

Visual Basic [image] Copy Code

Public Class ArcTemplate
Inherits ElementTemplate

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ElementTemplate
MindFusion.Diagramming.ArcTemplate

See Also

ArcTemplate Members


MindFusion.Diagramming.ArcTemplate Members

ArcTemplate Members
Constructors Properties Methods
[image]

Represents an arc in a shape definition.

The following tables list the members exposed by the ArcTemplate type.

Public Constructors

Name | Description
ArcTemplate | Overloaded. Initializes a new instance of the ArcTemplate class.

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of this element.
Color | Gets or sets the outline color of this element. (Inherited from ElementTemplate.)
DashStyle | Gets or sets the dash style of the outline of this element. (Inherited from ElementTemplate.)
StartAngle | Gets the start angle of this arc element.
SweepAngle | Gets the sweep angle of this arc element.
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

Public Methods

Name | Description
Clone | Creates an exact copy of this ArcTemplate element.
SameAs | ElementTemplate.SameAs override.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument. (Inherited from ElementTemplate.)

See Also

ArcTemplate Class


MindFusion.Diagramming.ArcTemplate Constructor

ArcTemplate Constructor
[image]

Initializes a new instance of the ArcTemplate class.

Overload List

Name | Description
ArcTemplate (Single, Single, Single, Single, Single, Single) | Initializes a new instance of the ArcTemplate class with the specified coordinates.
ArcTemplate (Single, Single, Single, Single, Single, Single, Color, DashStyle, Single) | Initializes a new instance of the ArcTemplate class with the specified coordinates and visualization settings.

See Also

ArcTemplate Class


MindFusion.Diagramming.ArcTemplate Constructor (Single, Single, Single, Single, Single, Single)

ArcTemplate Constructor (Single, Single, Single, Single, Single, Single)
See Also
[image]

Initializes a new instance of the ArcTemplate class with the specified coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ArcTemplate (
float x,
float y,
float w,
float h,
float a,
float s
)

Visual Basic [image] Copy Code

Public New ( _
x As Single, _
y As Single, _
w As Single, _
h As Single, _
a As Single, _
s As Single _
)

Parameters

x
The x-coordinate of the upper left corner of the ellipse's bounding rectangle.
y
The y-coordinate of the upper left corner of the ellipse's bounding rectangle.
w
The width of the ellipse's bounding rectangle.
h
The height of the ellipse's bounding rectangle.
a
The clockwise angle, in degrees, between the horizontal axis of the ellipse and the starting point of the arc.
s
The clockwise angle, in degrees, between the starting point and the ending point of the arc.

Remarks

An arc template is defined by an ellipse and starting and sweeping angles.

See Also

ArcTemplate Constructor Overload List
ArcTemplate Class


MindFusion.Diagramming.ArcTemplate Constructor (Single, Single, Single, Single, Single, Single, Color, DashStyle, Single)

ArcTemplate Constructor (Single, Single, Single, Single, Single, Single, Color, DashStyle, Single)
See Also
[image]

Initializes a new instance of the ArcTemplate class with the specified coordinates and visualization settings.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ArcTemplate (
float x,
float y,
float w,
float h,
float a,
float s,
Color color,
DashStyle dashStyle,
float width
)

Visual Basic [image] Copy Code

Public New ( _
x As Single, _
y As Single, _
w As Single, _
h As Single, _
a As Single, _
s As Single, _
color As Color, _
dashStyle As DashStyle, _
width As Single _
)

Parameters

x
The x-coordinate of the upper left corner of the ellipse's bounding rectangle.
y
The y-coordinate of the upper left corner of the ellipse's bounding rectangle.
w
The width of the ellipse's bounding rectangle.
h
The height of the ellipse's bounding rectangle.
a
The clockwise angle, in degrees, between the horizontal axis of the ellipse and the starting point of the arc.
s
The clockwise angle, in degrees, between the starting point and the ending point of the arc.
color
The color of this segment.
dashStyle
The dash style of this segment.
width
The width of this segment.

Remarks

An arc template is defined by an ellipse and starting and sweeping angles.

See Also

ArcTemplate Constructor Overload List
ArcTemplate Class


MindFusion.Diagramming.ArcTemplate Methods

ArcTemplate Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this ArcTemplate element.
SameAs | ElementTemplate.SameAs override.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument. (Inherited from ElementTemplate.)

See Also

ArcTemplate Class


MindFusion.Diagramming.ArcTemplate.Clone Method

ArcTemplate.Clone Method
[image]

Creates an exact copy of this ArcTemplate element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

An instance of the ArcTemplate class.

See Also

ArcTemplate Members
ArcTemplate Class


MindFusion.Diagramming.ArcTemplate.SameAs Method

ArcTemplate.SameAs Method
[image]

ElementTemplate.SameAs override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool SameAs (
ElementTemplate obj
)

Visual Basic [image] Copy Code

Public Overrides Function SameAs ( _
obj As ElementTemplate _
) As Boolean

Parameters

obj

The ElementTemplate to compare to this template.

Return Value

true if the specified object is an ArcTemplate closely approximating this template; otherwise, false.

See Also

ArcTemplate Members
ArcTemplate Class


MindFusion.Diagramming.ArcTemplate Properties

ArcTemplate Properties
[image]

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of this element.
Color | Gets or sets the outline color of this element. (Inherited from ElementTemplate.)
DashStyle | Gets or sets the dash style of the outline of this element. (Inherited from ElementTemplate.)
StartAngle | Gets the start angle of this arc element.
SweepAngle | Gets the sweep angle of this arc element.
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

See Also

ArcTemplate Class


MindFusion.Diagramming.ArcTemplate.Bounds Property

ArcTemplate.Bounds Property
[image]

Gets the bounding rectangle of this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As RectangleF

Property Value

An instance of the .NET RectangleF structure.

See Also

ArcTemplate Members
ArcTemplate Class


MindFusion.Diagramming.ArcTemplate.StartAngle Property

ArcTemplate.StartAngle Property
[image]

Gets the start angle of this arc element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float StartAngle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StartAngle As Single

Property Value

A float value specifying the start angle of the arc, in degrees.

See Also

ArcTemplate Members
ArcTemplate Class


MindFusion.Diagramming.ArcTemplate.SweepAngle Property

ArcTemplate.SweepAngle Property
[image]

Gets the sweep angle of this arc element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float SweepAngle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SweepAngle As Single

Property Value

A float value specifying the sweep angle of the arc, in degrees.

See Also

ArcTemplate Members
ArcTemplate Class


MindFusion.Diagramming.AreaEventArgs Class

AreaEventArgs Class
[image]

Contains arguments passed to handlers of the CreatingArea event of the HtmlBuilder class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class AreaEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class AreaEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.AreaEventArgs

See Also

AreaEventArgs Members


MindFusion.Diagramming.AreaEventArgs Members

AreaEventArgs Members
Properties
[image]

Contains arguments passed to handlers of the CreatingArea event of the HtmlBuilder class.

The following tables list the members exposed by the AreaEventArgs type.

Public Properties

Name | Description
AreaTag | Gets or sets the HTML AREA tag created by HtmlBuilder. You can insert additional attributes or JavaScript event handlers into that string.
Column | Gets the index of a column if the event is raised for a table cell.
Item | Gets the diagram element represented by AreaTag in the image map.
Row | Gets the index of a row if the event is raised for a table cell.

See Also

AreaEventArgs Class


MindFusion.Diagramming.AreaEventArgs Properties

AreaEventArgs Properties
[image]

Public Properties

Name | Description
AreaTag | Gets or sets the HTML AREA tag created by HtmlBuilder. You can insert additional attributes or JavaScript event handlers into that string.
Column | Gets the index of a column if the event is raised for a table cell.
Item | Gets the diagram element represented by AreaTag in the image map.
Row | Gets the index of a row if the event is raised for a table cell.

See Also

AreaEventArgs Class


MindFusion.Diagramming.AreaEventArgs.AreaTag Property

AreaEventArgs.AreaTag Property
[image]

Gets or sets the HTML AREA tag created by HtmlBuilder. You can insert additional attributes or JavaScript event handlers into that string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string AreaTag { get; set; }

Visual Basic [image] Copy Code

Public Property AreaTag As String

Property Value

A string value that represents the AREA tag, including the opening and closing brackets.

See Also

AreaEventArgs Members
AreaEventArgs Class


MindFusion.Diagramming.AreaEventArgs.Column Property

AreaEventArgs.Column Property
[image]

Gets the index of a column if the event is raised for a table cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Column { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Column As Integer

Property Value

An integer value specifying the zero-based index of the related column.

See Also

AreaEventArgs Members
AreaEventArgs Class


MindFusion.Diagramming.AreaEventArgs.Item Property

AreaEventArgs.Item Property
[image]

Gets the diagram element represented by AreaTag in the image map.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As DiagramItem

Property Value

An instance of the DiagramItem class.

See Also

AreaEventArgs Members
AreaEventArgs Class


MindFusion.Diagramming.AreaEventArgs.Row Property

AreaEventArgs.Row Property
[image]

Gets the index of a row if the event is raised for a table cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Row { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Row As Integer

Property Value

An integer value specifying the zero-based index of the related row.

See Also

AreaEventArgs Members
AreaEventArgs Class


MindFusion.Diagramming.ArrowHeads Class

ArrowHeads Class
Remarks See Also
[image]

Contains predefined arrowhead shapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class ArrowHeads

Visual Basic [image] Copy Code

Public NotInheritable Class ArrowHeads

Remarks

Shape objects exposed as properties of this class can be assigned to the HeadShape, BaseShape and IntermediateShape properties of links.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ArrowHeads

See Also

ArrowHeads Members


MindFusion.Diagramming.ArrowHeads Members

ArrowHeads Members
Fields
[image]

Contains predefined arrowhead shapes.

The following tables list the members exposed by the ArrowHeads type.

Public Fields

Name | Description
Arrow | Display an arrow-like shape.
BackSlash | Display a back slash.
BowArrow | Display a bow arrow.
Circle | Display a circle.
DefaultFlow | "Default flow" in BPMN diagrams.
DoubleArrow | Display a double arrow.
None | Do not display an arrowhead shape.
Pentagon | Display a pentagon.
PointerArrow | Display a pointer arrow.
Quill | Display a quill.
Reversed | Reversed arrowhead.
RevTriangle | Display a reversed triangle.
RevWithCirc | Reversed arrowhead with a circle.
RevWithLine | Reversed arrowhead with intersecting line.
Rhombus | Display a rhombus.
Slash | Display a slash.
Tetragon | Display a tetragon.
Triangle | Display a triangle.

See Also

ArrowHeads Class


MindFusion.Diagramming.ArrowHeads Fields

ArrowHeads Fields
[image]

Public Fields

Name | Description
Arrow | Display an arrow-like shape.
BackSlash | Display a back slash.
BowArrow | Display a bow arrow.
Circle | Display a circle.
DefaultFlow | "Default flow" in BPMN diagrams.
DoubleArrow | Display a double arrow.
None | Do not display an arrowhead shape.
Pentagon | Display a pentagon.
PointerArrow | Display a pointer arrow.
Quill | Display a quill.
Reversed | Reversed arrowhead.
RevTriangle | Display a reversed triangle.
RevWithCirc | Reversed arrowhead with a circle.
RevWithLine | Reversed arrowhead with intersecting line.
Rhombus | Display a rhombus.
Slash | Display a slash.
Tetragon | Display a tetragon.
Triangle | Display a triangle.

See Also

ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.Arrow Field

ArrowHeads.Arrow Field
[image]

Display an arrow-like shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow

Visual Basic [image] Copy Code

Public Shared Arrow As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.BackSlash Field

ArrowHeads.BackSlash Field
[image]

Display a back slash.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BackSlash

Visual Basic [image] Copy Code

Public Shared BackSlash As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.BowArrow Field

ArrowHeads.BowArrow Field
[image]

Display a bow arrow.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BowArrow

Visual Basic [image] Copy Code

Public Shared BowArrow As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.Circle Field

ArrowHeads.Circle Field
[image]

Display a circle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Circle

Visual Basic [image] Copy Code

Public Shared Circle As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.DefaultFlow Field

ArrowHeads.DefaultFlow Field
[image]

"Default flow" in BPMN diagrams.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DefaultFlow

Visual Basic [image] Copy Code

Public Shared DefaultFlow As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.DoubleArrow Field

ArrowHeads.DoubleArrow Field
[image]

Display a double arrow.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DoubleArrow

Visual Basic [image] Copy Code

Public Shared DoubleArrow As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.None Field

ArrowHeads.None Field
[image]

Do not display an arrowhead shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape None

Visual Basic [image] Copy Code

Public Shared None As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.Pentagon Field

ArrowHeads.Pentagon Field
[image]

Display a pentagon.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Pentagon

Visual Basic [image] Copy Code

Public Shared Pentagon As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.PointerArrow Field

ArrowHeads.PointerArrow Field
[image]

Display a pointer arrow.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape PointerArrow

Visual Basic [image] Copy Code

Public Shared PointerArrow As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.Quill Field

ArrowHeads.Quill Field
[image]

Display a quill.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Quill

Visual Basic [image] Copy Code

Public Shared Quill As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.Reversed Field

ArrowHeads.Reversed Field
[image]

Reversed arrowhead.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Reversed

Visual Basic [image] Copy Code

Public Shared Reversed As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.RevTriangle Field

ArrowHeads.RevTriangle Field
[image]

Display a reversed triangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape RevTriangle

Visual Basic [image] Copy Code

Public Shared RevTriangle As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.RevWithCirc Field

ArrowHeads.RevWithCirc Field
[image]

Reversed arrowhead with a circle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape RevWithCirc

Visual Basic [image] Copy Code

Public Shared RevWithCirc As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.RevWithLine Field

ArrowHeads.RevWithLine Field
[image]

Reversed arrowhead with intersecting line.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape RevWithLine

Visual Basic [image] Copy Code

Public Shared RevWithLine As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.Rhombus Field

ArrowHeads.Rhombus Field
[image]

Display a rhombus.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Rhombus

Visual Basic [image] Copy Code

Public Shared Rhombus As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.Slash Field

ArrowHeads.Slash Field
[image]

Display a slash.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Slash

Visual Basic [image] Copy Code

Public Shared Slash As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.Tetragon Field

ArrowHeads.Tetragon Field
[image]

Display a tetragon.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Tetragon

Visual Basic [image] Copy Code

Public Shared Tetragon As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.Triangle Field

ArrowHeads.Triangle Field
[image]

Display a triangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Triangle

Visual Basic [image] Copy Code

Public Shared Triangle As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.AttachTo Enumeration

AttachTo Enumeration
[image]

Specifies the type of attachment in a group.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum AttachTo

Visual Basic [image] Copy Code

Public Enum AttachTo

Members

Member name | Description
FixedCorner | Indicates attachment to a fixed corner of a node.
Proportional | Indicates proportional attachment to a node.
LinkPoint | Indicates attachment to an link's control point.
LinkSegment | Indicates attachment to an link's segment.
LongestHSegment | Indicates attachment to the longest horizontal segment of a link.
SideMiddle | Indicates attachment to the middle of a side of a node's bounding rectangle.
AnchorToEdges | Indicates attachment that is anchored to one or more sides of a node.
ControlledByMaster | The virtual UpdateGroup method of master items is called to update subordinates.
DistanceAlongLink | Preserves the absolute distance from a node to link's start or end point.
ProportionalToLength | Preserves the relative distance from a node to link's start point.

See Also


MindFusion.Diagramming.AttachToLink Enumeration

AttachToLink Enumeration
[image]

Defines values specifying the possible ways to attach a node to a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum AttachToLink

Visual Basic [image] Copy Code

Public Enum AttachToLink

Members

Member name | Description
Point | The node is attached to a fixed control point of the link.
Segment | The node is attached to a fixed segment of the link.
LongestHSegment | The node stays attached to the longest horizontal segment of the link.
FixedDistance | Preserves the absolute distance from a node to link's start or end point.
RelativeDistance | Preserves the relative distance from a node to link's start point.

Remarks

Members of this enumeration are used as values for the attType argument of the AttachTo method of the DiagramNode class.

See Also


MindFusion.Diagramming.AttachToNode Enumeration

AttachToNode Enumeration
[image]

Defines values specifying the possible ways to attach a node to another node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum AttachToNode

Visual Basic [image] Copy Code

Public Enum AttachToNode

Members

Member name | Description
TopLeft | The node follows the top-left corner of the master node.
TopRight | The node follows the top-right corner of the master node.
BottomLeft | The node follows the bottom-left corner of the master node.
BottomRight | The node follows the bottom-right corner of the master node.
TopCenter | The node follows the top-center point of the master node.
MiddleRight | The node follows the middle-right point of the master node.
BottomCenter | The node follows the bottom-center point of the master node.
MiddleLeft | The node follows the middle-left point of the master node.

Remarks

Members of this enumeration are used as values for the attType argument of the AttachTo method of the DiagramNode class.

See Also


MindFusion.Diagramming.AutoResize Enumeration

AutoResize Enumeration
[image]

Defines in which directions automatic resizing can enlarge the diagram scrollable area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum AutoResize

Visual Basic [image] Copy Code

Public Enum AutoResize

Members

Member name | Description
None | Do not enlarge the diagram area automatically.
RightAndDown | Enlarge the diagram area to the right and down if an item is moved outside the boundaries in these directions.
AllDirections | Enlarge the diagram area in any direction if an item is moved outside the boundaries.

Remarks

Values from this enumeration can be assigned to the AutoResize property.

See Also


MindFusion.Diagramming.Axis Enumeration

Axis Enumeration
[image]

Specifies a coordinate axis.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum Axis

Visual Basic [image] Copy Code

Public Enum Axis

Members

Member name | Description
X | Indicates the X coordinate axis.
Y | Indicates the Y coordinate axis.

See Also


MindFusion.Diagramming.BarcodeNode Class

BarcodeNode Class
Remarks See Also
[image]

Represents nodes that can encode and render barcodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class BarcodeNode : DiagramNode, InplaceEditable

Visual Basic [image] Copy Code

Public Class BarcodeNode
Inherits DiagramNode
Implements InplaceEditable

Remarks

The BarcodeNode class displays EAN, UPC or QR barcodes as node's content. In-place edit operations let users enter new numeric codes for 1D codes or text strings for QR codes. The barcode format is specified via the Format property, the encoded number or text is set via Content, and color of 1D bars / 2D modules via BarColor.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.BarcodeNode

See Also

BarcodeNode Members


MindFusion.Diagramming.BarcodeNode Members

BarcodeNode Members
Constructors Fields Properties Methods
[image]

Represents nodes that can encode and render barcodes.

The following tables list the members exposed by the BarcodeNode type.

Public Constructors

Name | Description
BarcodeNode | Overloaded. Initializes a new instance of the BarcodeNode class.

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
BarColor | Gets or sets the color of barcode modules.
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Content | Gets or sets the text or numeric code that should be represented as barcode symbol.
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
Format | Gets or sets the barcode format.
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
QRCorrectionLevel | Gets or sets the correction level of QR barcodes.
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | Determines whether the node supports connections to its constituent elements. (Inherited from DiagramNode.)
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
DoModify | For internal use. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. Renders the adjustment handles of this item. (Inherited from DiagramNode.)
DrawLocal | DiagramNode.DrawLocal override.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | Override in a derived class to provide implementation specific drawing for the shadow of the node. (Inherited from DiagramNode.)
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item. (Inherited from DiagramItem.)
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item. (Inherited from DiagramItem.)
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item. (Inherited from DiagramItem.)
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item. (Inherited from DiagramItem.)
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point. (Inherited from DiagramNode.)
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Intersects | Determines whether the node intersects another one, taking into account the outlines of node shapes. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetPos | Sets the bounding rectangle of this node without updating connected arrows. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
CancelModify | DiagramItem.CancelModify override. Invoked when the interactive modification of this object has been canceled. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Checks whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
Finalize | DiagramItem finalizer. (Inherited from DiagramItem.)
FreeResources | Called when the node is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from DiagramNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the item content from an XML element.
LoadObsolete | For internal use. (Inherited from DiagramItem.)
OnAdd | DiagramItem.OnAdd override. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnClick | Invoked when the user clicks this item. (Inherited from DiagramItem.)
OnDoubleClick | Invoked when the user double-clicks this item. (Inherited from DiagramItem.)
OnMeasureUnitChanged | DiagramItem.OnMeasureUnitChanged override. (Inherited from DiagramNode.)
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | Overloaded. (Inherited from DiagramNode.)
OnZoomChanged | DiagramItem.OnZoomChanged override. (Inherited from DiagramNode.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReference | Called during deserialization, after all objects have been instantiated, in order to update the references between them. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. Invoked when the user starts modifying this item interactively. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster. (Inherited from DiagramItem.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. Invoked during interactive modification of this item. (Inherited from DiagramNode.)

See Also

BarcodeNode Class


MindFusion.Diagramming.BarcodeNode Constructor

BarcodeNode Constructor
[image]

Initializes a new instance of the BarcodeNode class.

Overload List

Name | Description
BarcodeNode () | Initializes a new instance of the BarcodeNode class.
BarcodeNode (BarcodeNode) | Initializes a new instance of the BarcodeNode class.
BarcodeNode (Diagram) | Initializes a new instance of the BarcodeNode class.

See Also

BarcodeNode Class


MindFusion.Diagramming.BarcodeNode Constructor ()

BarcodeNode Constructor ()
See Also
[image]

Initializes a new instance of the BarcodeNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public BarcodeNode ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

BarcodeNode Constructor Overload List
BarcodeNode Class


MindFusion.Diagramming.BarcodeNode Constructor (BarcodeNode)

BarcodeNode Constructor (BarcodeNode)
See Also
[image]

Initializes a new instance of the BarcodeNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public BarcodeNode (
BarcodeNode prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As BarcodeNode _
)

Parameters

prototype
The node to use as a prototype. The properties of the new node are initialized from the property values of this node.

See Also

BarcodeNode Constructor Overload List
BarcodeNode Class


MindFusion.Diagramming.BarcodeNode Constructor (Diagram)

BarcodeNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the BarcodeNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public BarcodeNode (
Diagram parent
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram _
)

Parameters

parent

The Diagram from which to obtain default values for the node properties.

See Also

BarcodeNode Constructor Overload List
BarcodeNode Class


MindFusion.Diagramming.BarcodeNode Methods

BarcodeNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
DoModify | For internal use. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. Renders the adjustment handles of this item. (Inherited from DiagramNode.)
DrawLocal | DiagramNode.DrawLocal override.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | Override in a derived class to provide implementation specific drawing for the shadow of the node. (Inherited from DiagramNode.)
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item. (Inherited from DiagramItem.)
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item. (Inherited from DiagramItem.)
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item. (Inherited from DiagramItem.)
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item. (Inherited from DiagramItem.)
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point. (Inherited from DiagramNode.)
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Intersects | Determines whether the node intersects another one, taking into account the outlines of node shapes. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetPos | Sets the bounding rectangle of this node without updating connected arrows. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
CancelModify | DiagramItem.CancelModify override. Invoked when the interactive modification of this object has been canceled. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Checks whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
Finalize | DiagramItem finalizer. (Inherited from DiagramItem.)
FreeResources | Called when the node is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from DiagramNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the item content from an XML element.
LoadObsolete | For internal use. (Inherited from DiagramItem.)
OnAdd | DiagramItem.OnAdd override. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnClick | Invoked when the user clicks this item. (Inherited from DiagramItem.)
OnDoubleClick | Invoked when the user double-clicks this item. (Inherited from DiagramItem.)
OnMeasureUnitChanged | DiagramItem.OnMeasureUnitChanged override. (Inherited from DiagramNode.)
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | Overloaded. (Inherited from DiagramNode.)
OnZoomChanged | DiagramItem.OnZoomChanged override. (Inherited from DiagramNode.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReference | Called during deserialization, after all objects have been instantiated, in order to update the references between them. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. Invoked when the user starts modifying this item interactively. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster. (Inherited from DiagramItem.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. Invoked during interactive modification of this item. (Inherited from DiagramNode.)

See Also

BarcodeNode Class


MindFusion.Diagramming.BarcodeNode.CreateProperties Method

BarcodeNode.CreateProperties Method
[image]

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override DiagramItemProperties CreateProperties ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateProperties () As DiagramItemProperties

Return Value

A BarcodeNodeProperties instance containing a snapshot of the item's properties.

See Also

BarcodeNode Members
BarcodeNode Class


MindFusion.Diagramming.BarcodeNode.DrawLocal Method

BarcodeNode.DrawLocal Method
[image]

DiagramNode.DrawLocal override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawLocal (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawLocal( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

An IGraphics object where the node should be rendered.

options

Provides options for the drawing operation.

See Also

BarcodeNode Members
BarcodeNode Class


MindFusion.Diagramming.BarcodeNode.LoadFrom Method

BarcodeNode.LoadFrom Method
[image]

Deserializes the object from the specified reader.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void LoadFrom (
BinaryReader reader,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFrom( _
reader As BinaryReader, _
context As PersistContext _
)

Parameters

reader

A BinaryReader object from which to read the item's data.

context

A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

BarcodeNode Members
BarcodeNode Class


MindFusion.Diagramming.BarcodeNode.LoadFromXml Method

BarcodeNode.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement containing the item's data.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

BarcodeNode Members
BarcodeNode Class


MindFusion.Diagramming.BarcodeNode.RestoreProperties Method

BarcodeNode.RestoreProperties Method
[image]

DiagramNode.RestoreProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub RestoreProperties( _
props As DiagramItemProperties _
)

Parameters

props

A BarcodeNodeProperties object containing a snapshot of the item's properties.

See Also

BarcodeNode Members
BarcodeNode Class


MindFusion.Diagramming.BarcodeNode.SaveProperties Method

BarcodeNode.SaveProperties Method
[image]

DiagramNode.SaveProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveProperties( _
props As DiagramItemProperties _
)

Parameters

props

A BarcodeNodeProperties object where the item's properties should be saved.

See Also

BarcodeNode Members
BarcodeNode Class


MindFusion.Diagramming.BarcodeNode.SaveTo Method

BarcodeNode.SaveTo Method
[image]

Serializes the object to the specified writer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SaveTo (
BinaryWriter writer,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveTo( _
writer As BinaryWriter, _
context As PersistContext _
)

Parameters

writer

A BinaryWriter object the item's data should be written to.

context

A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

BarcodeNode Members
BarcodeNode Class


MindFusion.Diagramming.BarcodeNode.SaveToXml Method

BarcodeNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement the item's data should be stored into.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

BarcodeNode Members
BarcodeNode Class


MindFusion.Diagramming.BarcodeNode Properties

BarcodeNode Properties
[image]

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
BarColor | Gets or sets the color of barcode modules.
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Content | Gets or sets the text or numeric code that should be represented as barcode symbol.
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
Format | Gets or sets the barcode format.
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
QRCorrectionLevel | Gets or sets the correction level of QR barcodes.
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | Determines whether the node supports connections to its constituent elements. (Inherited from DiagramNode.)
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

See Also

BarcodeNode Class


MindFusion.Diagramming.BarcodeNode.BarColor Property

BarcodeNode.BarColor Property
[image]

Gets or sets the color of barcode modules.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color BarColor { get; set; }

Visual Basic [image] Copy Code

Public Property BarColor As Color

Property Value

A System.Drawing.Color instance. The default value is Black.

See Also

BarcodeNode Members
BarcodeNode Class


MindFusion.Diagramming.BarcodeNode.Content Property

BarcodeNode.Content Property
[image]

Gets or sets the text or numeric code that should be represented as barcode symbol.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Content { get; set; }

Visual Basic [image] Copy Code

Public Property Content As String

Property Value

A string containing the barcode's content.

Remarks

For 1D code formats, the string should contain only digits representing the code's numerical value. The control will automatically calculate the last check-digit if it's not set. If the string contains a check-digit at expected position, the control will consider its value to be valid without verifying it.

See Also

BarcodeNode Members
BarcodeNode Class


MindFusion.Diagramming.BarcodeNode.Format Property

BarcodeNode.Format Property
[image]

Gets or sets the barcode format.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public BarcodeFormat Format { get; set; }

Visual Basic [image] Copy Code

Public Property Format As BarcodeFormat

Property Value

A member of the BarcodeFormat enumeration. The default value is QR.

See Also

BarcodeNode Members
BarcodeNode Class


MindFusion.Diagramming.BarcodeNode.QRCorrectionLevel Property

BarcodeNode.QRCorrectionLevel Property
[image]

Gets or sets the correction level of QR barcodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CorrectionLevel QRCorrectionLevel { get; set; }

Visual Basic [image] Copy Code

Public Property QRCorrectionLevel As CorrectionLevel

Property Value

A member of the CorrectionLevel enumeration. The default value is M.

See Also

BarcodeNode Members
BarcodeNode Class


MindFusion.Diagramming.BarcodeNodeProperties Class

BarcodeNodeProperties Class
[image]

Stores the values of BarcodeNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from BarcodeNode, do so by deriving from BarcodeNodeProperties and overriding the BarcodeNode.SaveProperties, BarcodeNode.RestoreProperties, and BarcodeNode.CreateProperties methods.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class BarcodeNodeProperties : DiagramNodeProperties

Visual Basic [image] Copy Code

Public Class BarcodeNodeProperties
Inherits DiagramNodeProperties

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemProperties
MindFusion.Diagramming.DiagramNodeProperties
MindFusion.Diagramming.BarcodeNodeProperties

See Also

BarcodeNodeProperties Members


MindFusion.Diagramming.BarcodeNodeProperties Members

BarcodeNodeProperties Members
Constructors Fields Methods
[image]

Stores the values of BarcodeNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from BarcodeNode, do so by deriving from BarcodeNodeProperties and overriding the BarcodeNode.SaveProperties, BarcodeNode.RestoreProperties, and BarcodeNode.CreateProperties methods.

The following tables list the members exposed by the BarcodeNodeProperties type.

Public Constructors

Name | Description
BarcodeNodeProperties |

Public Fields

Name | Description
ItemClass | For internal use. (Inherited from DiagramItemProperties.)
Selected | For internal use. (Inherited from DiagramItemProperties.)
TextPadding | For internal use. (Inherited from DiagramItemProperties.)
ZIndex | For internal use. (Inherited from DiagramItemProperties.)

Public Methods

Name | Description
FreeResources | Frees stored resources which will no longer be used. (Inherited from DiagramItemProperties.)

See Also

BarcodeNodeProperties Class


MindFusion.Diagramming.BarcodeNodeProperties Constructor

BarcodeNodeProperties Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public BarcodeNodeProperties ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

BarcodeNodeProperties Class


MindFusion.Diagramming.BarcodeNodeStyle Class

BarcodeNodeStyle Class
[image]

Represents a reusable set of properties that define the appearance of barcode nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class BarcodeNodeStyle : DiagramNodeStyle

Visual Basic [image] Copy Code

Public Class BarcodeNodeStyle
Inherits DiagramNodeStyle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Style
MindFusion.Diagramming.DiagramItemStyle
MindFusion.Diagramming.DiagramNodeStyle
MindFusion.Diagramming.BarcodeNodeStyle

See Also

BarcodeNodeStyle Members


MindFusion.Diagramming.BarcodeNodeStyle Members

BarcodeNodeStyle Members
Constructors Properties Methods Events
[image]

Represents a reusable set of properties that define the appearance of barcode nodes.

The following tables list the members exposed by the BarcodeNodeStyle type.

Public Constructors

Name | Description
BarcodeNodeStyle | Initializes a new instance of the BarcodeNodeStyle class.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of the item. (Inherited from DiagramItemStyle.)
Effects | Gets a list of the effects applied to the node. (Inherited from DiagramNodeStyle.)
FontFamily | Gets or sets the font family of the item text. (Inherited from DiagramItemStyle.)
FontSize | Gets or sets the font size of the item text. (Inherited from DiagramItemStyle.)
FontStyle | Gets or sets the font style of the item text. (Inherited from DiagramItemStyle.)
FontUnit | Gets or sets the font unit of the item text. (Inherited from DiagramItemStyle.)
ShadowBrush | Gets or sets the brush used to paint the shadow of the item. (Inherited from DiagramItemStyle.)
Stroke | Gets or sets the brush used to paint the outline of the item. (Inherited from DiagramItemStyle.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItemStyle.)
StrokeThickness | Gets or sets the thickness of the item's outline, expressed in the current units of measure. (Inherited from DiagramItemStyle.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItemStyle.)

Public Methods

Name | Description
GetProperties | Gets all properties in the style. (Inherited from Style.)
GetProperty | Returns the property with the specified name, if any. (Inherited from Style.)
RegisterType | Associates a type with an alias. (Inherited from Style.)

Protected Methods

Name | Description
GetValue | Gets the value of the specified property. (Inherited from Style.)
IsPropertySet | Checks whether the specified property has a value. (Inherited from Style.)
LoadFrom | Deserializes the item from the specified reader. (Inherited from Style.)
LoadFromXml | Loads the style content from an XML element. (Inherited from Style.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Style.)
RegisterProperty | Registers a new property with the specified name and type. (Inherited from Style.)
SaveTo | Serializes the style to the specified writer. (Inherited from Style.)
SaveToXml | Saves the style content into an XML element. (Inherited from Style.)
SetValue | Sets the value of the specified property. (Inherited from Style.)
UnsetValue | Clears the value of the specified property. (Inherited from Style.)

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

BarcodeNodeStyle Class


MindFusion.Diagramming.BarcodeNodeStyle Constructor

BarcodeNodeStyle Constructor
[image]

Initializes a new instance of the BarcodeNodeStyle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public BarcodeNodeStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

BarcodeNodeStyle Class


MindFusion.Diagramming.BarcodeNodeStyle Events

BarcodeNodeStyle Events
[image]

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

BarcodeNodeStyle Class


MindFusion.Diagramming.Style.PropertyChanged Event

Style.PropertyChanged Event
[image]

Raised when any of the registered style properties has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<StylePropertyChangedEventArgs> PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As EventHandler(Of StylePropertyChangedEventArgs)

Event Data

PropertyChanged event handlers receive an argument of type StylePropertyChangedEventArgs.

See Also

Style Members
Style Class


MindFusion.Diagramming.Behavior Enumeration

Behavior Enumeration
[image]

Defines values that specify how the component responds to actions performed by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum Behavior

Visual Basic [image] Copy Code

Public Enum Behavior

Members

Member name | Description
Modify | Items can be selected and modified. New items cannot be created.
DrawShapes | Drawing with the mouse creates ShapeNode instances.
DrawLinks | Drawing started over a node creates a DiagramLink. Otherwise a lasso rectangle is displayed allowing the selection of items.
LinkShapes | A mode that is suitable for creating flowcharts and process diagrams. Drawing over empty document area creates a ShapeNode instance. Drawing started over a node creates a DiagramLink.
LinkTables | A mode that is suitable for creating entity-relationship diagrams. Drawing over empty document area creates a TableNode instance. Drawing started over a node creates a DiagramLink.
DrawTables | Drawing with the mouse creates TableNode instances.
DrawControls | Drawing with the mouse creates ControlNode instances.
LinkControls | Drawing over empty document area creates a ControlNode instance. Drawing started over a node creates a DiagramLink.
DoNothing | The control ignores users actions with the mouse, but raises the appropriate mouse events. This mode allows applications to implement their own mouse-drawing behavior, disabling the MvcDiagram default response to users actions.
Custom | Specifies that user input will be handled by the BehaviorBase-derived object assigned to CustomBehavior.
DrawContainers | Drawing with the mouse creates ContainerNode instances.
LinkContainers | Drawing over empty document area creates a ContainerNode instance. Drawing started over a node creates a DiagramLink.
Pan | Dragging with the mouse pans the view.
DrawTreeViews | Drawing with the mouse creates TreeViewNode instances.
LinkTreeViews | Drawing over empty document area creates a TreeViewNode instance. Drawing started over a node creates a DiagramLink.
DrawSvgNodes | Drawing with the mouse creates SvgNode instances.
LinkSvgNodes | Drawing over empty document area creates an SvgNode instance. Drawing started over a node creates a DiagramLink.
SelectOnly | Allow only selection of existing items. Modifying them or drawing new ones is disabled.
Magnify | Dragging the mouse magnifies the view. Interactive creation or modification of items is disabled.
DrawVisioNodes | Drawing with the mouse creates VisioNode instances.
LinkVisioNodes | Drawing over empty document area creates a VisioNode instance. Drawing started over a node creates a DiagramLink.
DrawBarcodes | Drawing with the mouse creates BarcodeNode instances.
LinkBarcodes | Drawing over empty document area creates a BarcodeNode instance. Drawing started over a node creates a DiagramLink.

Remarks

Set the Behavior property to specify how MvcDiagram interprets user's actions. In all modes:

  • single clicking selects the item under the mouse pointer and make it the ActiveItem;
  • dragging while CTRL is pressed creates multiple selection;
  • dragging while ALT is pressed pans the view;

See Also

Behavior Property


MindFusion.Diagramming.BezierTemplate Class

BezierTemplate Class
[image]

Represents a Bйzier curve in a shape definition.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class BezierTemplate : ElementTemplate

Visual Basic [image] Copy Code

Public Class BezierTemplate
Inherits ElementTemplate

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ElementTemplate
MindFusion.Diagramming.BezierTemplate

See Also

BezierTemplate Members


MindFusion.Diagramming.BezierTemplate Members

BezierTemplate Members
Constructors Properties Methods
[image]

Represents a Bйzier curve in a shape definition.

The following tables list the members exposed by the BezierTemplate type.

Public Constructors

Name | Description
BezierTemplate | Overloaded. Initializes a new instance of the BezierTemplate class.

Public Properties

Name | Description
Color | Gets or sets the outline color of this element. (Inherited from ElementTemplate.)
Coordinates | Gets a float array containing the coordinates of the points defining the Bйzier curve represented by this element.
DashStyle | Gets or sets the dash style of the outline of this element. (Inherited from ElementTemplate.)
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

Public Methods

Name | Description
Clone | Creates an exact copy of this BezierTemplate element.
SameAs | ElementTemplate.SameAs override.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument. (Inherited from ElementTemplate.)

See Also

BezierTemplate Class


MindFusion.Diagramming.BezierTemplate Constructor

BezierTemplate Constructor
[image]

Initializes a new instance of the BezierTemplate class.

Overload List

Name | Description
BezierTemplate (Single, Single, Single, Single, Single, Single, Single, Single) | Initializes a new instance of the BezierTemplate class with the specified coordinates.
BezierTemplate (Single, Single, Single, Single, Single, Single, Single, Single, Color, DashStyle, Single) | Initializes a new instance of the BezierTemplate class with the specified coordinates and visualization settings.

See Also

BezierTemplate Class


MindFusion.Diagramming.BezierTemplate Constructor (Single, Single, Single, Single, Single, Single, Single, Single)

BezierTemplate Constructor (Single, Single, Single, Single, Single, Single, Single, Single)
See Also
[image]

Initializes a new instance of the BezierTemplate class with the specified coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public BezierTemplate (
float x1,
float y1,
float x2,
float y2,
float x3,
float y3,
float x4,
float y4
)

Visual Basic [image] Copy Code

Public New ( _
x1 As Single, _
y1 As Single, _
x2 As Single, _
y2 As Single, _
x3 As Single, _
y3 As Single, _
x4 As Single, _
y4 As Single _
)

Parameters

x1
The x-coordinate of the first control point of the curve.
y1
The y-coordinate of the first control point of the curve.
x2
The x-coordinate of the second control point of the curve.
y2
The y-coordinate of the second control point of the curve.
x3
The x-coordinate of the third control point of the curve.
y3
The y-coordinate of the third control point of the curve.
x4

The x-coordinate of the fourth control point of the curve.

y4
The y-coordinate of the fourth control point of the curve.

Remarks

A Bйzier spline is defined by four control points. The spline goes through the first and last points, and the other two define the tension of the spline.

See Also

BezierTemplate Constructor Overload List
BezierTemplate Class


MindFusion.Diagramming.BezierTemplate Constructor (Single, Single, Single, Single, Single, Single, Single, Single, Color, DashStyle, Single)

BezierTemplate Constructor (Single, Single, Single, Single, Single, Single, Single, Single, Color, DashStyle, Single)
See Also
[image]

Initializes a new instance of the BezierTemplate class with the specified coordinates and visualization settings.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public BezierTemplate (
float x1,
float y1,
float x2,
float y2,
float x3,
float y3,
float x4,
float y4,
Color color,
DashStyle dashStyle,
float width
)

Visual Basic [image] Copy Code

Public New ( _
x1 As Single, _
y1 As Single, _
x2 As Single, _
y2 As Single, _
x3 As Single, _
y3 As Single, _
x4 As Single, _
y4 As Single, _
color As Color, _
dashStyle As DashStyle, _
width As Single _
)

Parameters

x1
The x-coordinate of the first control point of the curve.
y1
The y-coordinate of the first control point of the curve.
x2
The x-coordinate of the second control point of the curve.
y2
The y-coordinate of the second control point of the curve.
x3
The x-coordinate of the third control point of the curve.
y3
The y-coordinate of the third control point of the curve.
x4
The x-coordinate of the fourth control point of the curve
y4
The y-coordinate of the fourth control point of the curve.
color
The color of this segment.
dashStyle

The dash style of this segment.

width
The width of this segment.

Remarks

A Bйzier spline is defined by four control points. The spline goes through the first and last points, and the other two define the tension of the spline.

See Also

BezierTemplate Constructor Overload List
BezierTemplate Class


MindFusion.Diagramming.BezierTemplate Methods

BezierTemplate Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this BezierTemplate element.
SameAs | ElementTemplate.SameAs override.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument. (Inherited from ElementTemplate.)

See Also

BezierTemplate Class


MindFusion.Diagramming.BezierTemplate.Clone Method

BezierTemplate.Clone Method
[image]

Creates an exact copy of this BezierTemplate element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

An instance of the BezierTemplate class.

See Also

BezierTemplate Members
BezierTemplate Class


MindFusion.Diagramming.BezierTemplate.SameAs Method

BezierTemplate.SameAs Method
[image]

ElementTemplate.SameAs override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool SameAs (
ElementTemplate obj
)

Visual Basic [image] Copy Code

Public Overrides Function SameAs ( _
obj As ElementTemplate _
) As Boolean

Parameters

obj

The ElementTemplate to compare to this template.

Return Value

true if the specified object is a BezierTemplate closely approximating this template; otherwise, false.

See Also

BezierTemplate Members
BezierTemplate Class


MindFusion.Diagramming.BezierTemplate Properties

BezierTemplate Properties
[image]

Public Properties

Name | Description
Color | Gets or sets the outline color of this element. (Inherited from ElementTemplate.)
Coordinates | Gets a float array containing the coordinates of the points defining the Bйzier curve represented by this element.
DashStyle | Gets or sets the dash style of the outline of this element. (Inherited from ElementTemplate.)
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

See Also

BezierTemplate Class


MindFusion.Diagramming.BezierTemplate.Coordinates Property

BezierTemplate.Coordinates Property
[image]

Gets a float array containing the coordinates of the points defining the Bйzier curve represented by this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float[] Coordinates { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Coordinates As Single()

Property Value

An array of float values containing the coordinates of the points composing this element.

See Also

BezierTemplate Members
BezierTemplate Class


MindFusion.Diagramming.CellEventArgs Class

CellEventArgs Class
[image]

Contains the arguments passed to event handlers, such as CellClicked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class CellEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class CellEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.CellEventArgs
MindFusion.Diagramming.CellValidationEventArgs

See Also

CellEventArgs Members


MindFusion.Diagramming.CellEventArgs Members

CellEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to event handlers, such as CellClicked.

The following tables list the members exposed by the CellEventArgs type.

Public Constructors

Name | Description
CellEventArgs | Initializes a new instance of the CellEventArgs class.

Public Properties

Name | Description
Cell | Get the cell for which the event is raised.
Column | Gets the index of the table's column that contains Cell.
MouseButton | Gets which mouse button has been pressed.
MousePosition | Gets the current mouse pointer position.
Row | Gets the index of the table's row that contains Cell.
Table | Get the table that contains Cell.

See Also

CellEventArgs Class


MindFusion.Diagramming.CellEventArgs Constructor

CellEventArgs Constructor
[image]

Initializes a new instance of the CellEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CellEventArgs (
TableNode.Cell cell,
MouseButton mouseButton,
PointF mousePosition,
int column,
int row
)

Visual Basic [image] Copy Code

Public Sub CellEventArgs ( _
cell As TableNode.Cell, _
mouseButton As MouseButton, _
mousePosition As PointF, _
column As Integer, _
row As Integer _
)

Parameters

cell

The TableNode.Cell related to the event.

mouseButton

The mouse button related to the event.

mousePosition

The position of the mouse at the time the event was raised.

column

The zero-based index of the column related to the event.

row

The zero-based index of the row related to the event.

See Also

CellEventArgs Class


MindFusion.Diagramming.CellEventArgs Properties

CellEventArgs Properties
[image]

Public Properties

Name | Description
Cell | Get the cell for which the event is raised.
Column | Gets the index of the table's column that contains Cell.
MouseButton | Gets which mouse button has been pressed.
MousePosition | Gets the current mouse pointer position.
Row | Gets the index of the table's row that contains Cell.
Table | Get the table that contains Cell.

See Also

CellEventArgs Class


MindFusion.Diagramming.CellEventArgs.Cell Property

CellEventArgs.Cell Property
[image]

Get the cell for which the event is raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.Cell Cell { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Cell As TableNode.Cell

Property Value

An instance of the TableNode.Cell class specifying the cell related to the event.

See Also

CellEventArgs Members
CellEventArgs Class


MindFusion.Diagramming.CellEventArgs.Column Property

CellEventArgs.Column Property
[image]

Gets the index of the table's column that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Column { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Column As Integer

Property Value

An integer value specifying the zero-based index of the table column related to the event.

See Also

CellEventArgs Members
CellEventArgs Class


MindFusion.Diagramming.CellEventArgs.MouseButton Property

CellEventArgs.MouseButton Property
[image]

Gets which mouse button has been pressed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MouseButton MouseButton { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MouseButton As MouseButton

Property Value

A member of the MouseButton enumeration specifying the currently pressed mouse button.

See Also

CellEventArgs Members
CellEventArgs Class


MindFusion.Diagramming.CellEventArgs.MousePosition Property

CellEventArgs.MousePosition Property
[image]

Gets the current mouse pointer position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointF MousePosition { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MousePosition As PointF

Property Value

A PointF value specifying the current mouse position.

See Also

CellEventArgs Members
CellEventArgs Class


MindFusion.Diagramming.CellEventArgs.Row Property

CellEventArgs.Row Property
[image]

Gets the index of the table's row that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Row { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Row As Integer

Property Value

An integer value specifying the zero-based index of the table row related to the event.

See Also

CellEventArgs Members
CellEventArgs Class


MindFusion.Diagramming.CellEventArgs.Table Property

CellEventArgs.Table Property
[image]

Get the table that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode Table { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Table As TableNode

Property Value

An instance of the TableNode class specifying the table related to the event.

See Also

CellEventArgs Members
CellEventArgs Class


MindFusion.Diagramming.CellFrameStyle Enumeration

CellFrameStyle Enumeration
[image]

Specifies the style of the cells' frame lines.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum CellFrameStyle

Visual Basic [image] Copy Code

Public Enum CellFrameStyle

Members

Member name | Description
None | Table cells have no border.
Simple | The border of table cells is simple line.
System3D | The border has 3D look.

Remarks

The enumeration values are used when customizing table cells.

See Also

CellFrameStyle Property


MindFusion.Diagramming.CellValidationEventArgs Class

CellValidationEventArgs Class
[image]

Contains the arguments passed to event handlers, such as CellTextEditing.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class CellValidationEventArgs : CellEventArgs

Visual Basic [image] Copy Code

Public Class CellValidationEventArgs
Inherits CellEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.CellEventArgs
MindFusion.Diagramming.CellValidationEventArgs

See Also

CellValidationEventArgs Members


MindFusion.Diagramming.CellValidationEventArgs Members

CellValidationEventArgs Members
Constructors Properties Methods
[image]

Contains the arguments passed to event handlers, such as CellTextEditing.

The following tables list the members exposed by the CellValidationEventArgs type.

Public Constructors

Name | Description
CellValidationEventArgs | Initializes a new instance of the CellValidationEventArgs class.

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to prevent the user from completing the operation.
Cell | Get the cell for which the event is raised. (Inherited from CellEventArgs.)
Column | Gets the index of the table's column that contains Cell. (Inherited from CellEventArgs.)
MouseButton | Gets which mouse button has been pressed. (Inherited from CellEventArgs.)
MousePosition | Gets the current mouse pointer position. (Inherited from CellEventArgs.)
Row | Gets the index of the table's row that contains Cell. (Inherited from CellEventArgs.)
Table | Get the table that contains Cell. (Inherited from CellEventArgs.)

Public Methods

Name | Description
CancelDrag | Cancels the resize of the node's row or column.

See Also

CellValidationEventArgs Class


MindFusion.Diagramming.CellValidationEventArgs Constructor

CellValidationEventArgs Constructor
[image]

Initializes a new instance of the CellValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CellValidationEventArgs (
TableNode.Cell cell,
MouseButton mouseButton,
PointF mousePosition,
int column,
int row
)

Visual Basic [image] Copy Code

Public Sub CellValidationEventArgs ( _
cell As TableNode.Cell, _
mouseButton As MouseButton, _
mousePosition As PointF, _
column As Integer, _
row As Integer _
)

Parameters

cell

The TableNode.Cell related to the event.

mouseButton

The mouse button related to the event.

mousePosition

The position of the mouse at the time the event was raised.

column

The zero-based index of the column related to the event.

row

The zero-based index of the row related to the event.

See Also

CellValidationEventArgs Class


MindFusion.Diagramming.CellValidationEventArgs Methods

CellValidationEventArgs Methods
[image]

Public Methods

Name | Description
CancelDrag | Cancels the resize of the node's row or column.

See Also

CellValidationEventArgs Class


MindFusion.Diagramming.CellValidationEventArgs.CancelDrag Method

CellValidationEventArgs.CancelDrag Method
[image]

Cancels the resize of the node's row or column.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void CancelDrag ()

Visual Basic [image] Copy Code

Public Sub CancelDrag ()

Remarks

Calling this method immediately stops the operation.

See Also

CellValidationEventArgs Members
CellValidationEventArgs Class


MindFusion.Diagramming.CellValidationEventArgs Properties

CellValidationEventArgs Properties
[image]

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to prevent the user from completing the operation.
Cell | Get the cell for which the event is raised. (Inherited from CellEventArgs.)
Column | Gets the index of the table's column that contains Cell. (Inherited from CellEventArgs.)
MouseButton | Gets which mouse button has been pressed. (Inherited from CellEventArgs.)
MousePosition | Gets the current mouse pointer position. (Inherited from CellEventArgs.)
Row | Gets the index of the table's row that contains Cell. (Inherited from CellEventArgs.)
Table | Get the table that contains Cell. (Inherited from CellEventArgs.)

See Also

CellValidationEventArgs Class


MindFusion.Diagramming.CellValidationEventArgs.Cancel Property

CellValidationEventArgs.Cancel Property
[image]

Gets or sets a value indicating whether to prevent the user from completing the operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

true to cancel the operation; false to approve it.

See Also

CellValidationEventArgs Members
CellValidationEventArgs Class


MindFusion.Diagramming.ClipboardEventArgs Class

ClipboardEventArgs Class
[image]

Contains the arguments passed to the RequestClipboard event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ClipboardEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ClipboardEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.ClipboardEventArgs

See Also

ClipboardEventArgs Members


MindFusion.Diagramming.ClipboardEventArgs Members

ClipboardEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the RequestClipboard event handlers.

The following tables list the members exposed by the ClipboardEventArgs type.

Public Constructors

Name | Description
ClipboardEventArgs | Overloaded.

Public Properties

Name | Description
Data | Gets or sets the clipboard data.
DataType | Gets or sets the type of the data to get or set from the clipboard. This should be null (Nothing in Visual Basic) for clipboard set operations.
IsGetOperation | Gets a value indicating whether getting or setting the clipboard.
IsHandled | Gets or sets a value indicating whether the event is handled.
Source | Gets the object, which initiated the event.

See Also

ClipboardEventArgs Class


MindFusion.Diagramming.ClipboardEventArgs Constructor

ClipboardEventArgs Constructor
[image]

Overload List

Name | Description
ClipboardEventArgs (Object) | Initializes a new instance of the ClipboardEventArgs class for a Clipboard get operation.
ClipboardEventArgs (Object, Object) | Initializes a new instance of the ClipboardEventArgs class for a Clipboard set operation.

See Also

ClipboardEventArgs Class


MindFusion.Diagramming.ClipboardEventArgs Constructor (Object)

ClipboardEventArgs Constructor (Object)
See Also
[image]

Initializes a new instance of the ClipboardEventArgs class for a Clipboard get operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ClipboardEventArgs (
Object source
)

Visual Basic [image] Copy Code

Public New ( _
source As Object _
)

Parameters

source
The object requesting the Clipboard contents.

See Also

ClipboardEventArgs Constructor Overload List
ClipboardEventArgs Class


MindFusion.Diagramming.ClipboardEventArgs Constructor (Object, Object)

ClipboardEventArgs Constructor (Object, Object)
See Also
[image]

Initializes a new instance of the ClipboardEventArgs class for a Clipboard set operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ClipboardEventArgs (
Object source,
Object value
)

Visual Basic [image] Copy Code

Public New ( _
source As Object, _
value As Object _
)

Parameters

source

The object requesting to set the Clipboard contents.

value
The new contents for the Clipboard.

See Also

ClipboardEventArgs Constructor Overload List
ClipboardEventArgs Class


MindFusion.Diagramming.ClipboardEventArgs Properties

ClipboardEventArgs Properties
[image]

Public Properties

Name | Description
Data | Gets or sets the clipboard data.
DataType | Gets or sets the type of the data to get or set from the clipboard. This should be null (Nothing in Visual Basic) for clipboard set operations.
IsGetOperation | Gets a value indicating whether getting or setting the clipboard.
IsHandled | Gets or sets a value indicating whether the event is handled.
Source | Gets the object, which initiated the event.

See Also

ClipboardEventArgs Class


MindFusion.Diagramming.ClipboardEventArgs.Data Property

ClipboardEventArgs.Data Property
[image]

Gets or sets the clipboard data.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Data { get; set; }

Visual Basic [image] Copy Code

Public Property Data As Object

Property Value

An object representing the Clipboard contents.

Remarks

The purpose of this property depends on the type of the Clipboard operation, as specified by IsGetOperation. During get operations the property will contain the contents of the Clipboard after the event is handled. For set operations the property specifies the new contents of the Clipboard.

See Also

ClipboardEventArgs Members
ClipboardEventArgs Class


MindFusion.Diagramming.ClipboardEventArgs.DataType Property

ClipboardEventArgs.DataType Property
[image]

Gets or sets the type of the data to get or set from the clipboard. This should be null (Nothing in Visual Basic) for clipboard set operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Type DataType { get; set; }

Visual Basic [image] Copy Code

Public Property DataType As Type

Property Value

A Type instance.

See Also

ClipboardEventArgs Members
ClipboardEventArgs Class


MindFusion.Diagramming.ClipboardEventArgs.IsGetOperation Property

ClipboardEventArgs.IsGetOperation Property
[image]

Gets a value indicating whether getting or setting the clipboard.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsGetOperation { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsGetOperation As Boolean

Property Value

true if the request is to get the Clipboard contents; false if the request is to set Clipboard contents.

Remarks

The value of this property is inferred by the constructor used to create the event argument and cannot be subsequently changed.

See Also

ClipboardEventArgs Members
ClipboardEventArgs Class


MindFusion.Diagramming.ClipboardEventArgs.IsHandled Property

ClipboardEventArgs.IsHandled Property
[image]

Gets or sets a value indicating whether the event is handled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsHandled { get; set; }

Visual Basic [image] Copy Code

Public Property IsHandled As Boolean

Property Value

See Also

ClipboardEventArgs Members
ClipboardEventArgs Class


MindFusion.Diagramming.ClipboardEventArgs.Source Property

ClipboardEventArgs.Source Property
[image]

Gets the object, which initiated the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Source { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Source As Object

Property Value

The object requesting the Clipboard.

See Also

ClipboardEventArgs Members
ClipboardEventArgs Class


MindFusion.Diagramming.CollectionBase(T) Class

CollectionBase(T) Class
[image]

An implementation of the IList<T> interface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class CollectionBase<T> : IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable

Visual Basic [image] Copy Code

Public MustInherit Class CollectionBase(Of T)
Implements IList(Of T), ICollection(Of T), IEnumerable(Of T), IEnumerable

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.CollectionBase(T)
MindFusion.Diagramming.PersistableCollection(T)

See Also

CollectionBase(T) Members


MindFusion.Diagramming.CollectionBase(T) Members

CollectionBase(T) Members
Constructors Fields Properties Methods
[image]

An implementation of the IList<T> interface.

The following tables list the members exposed by the CollectionBase(T) type.

Protected Constructors

Name | Description
CollectionBase | Initializes a new instance of the CollectionBase<T> class.

Protected Fields

Name | Description
InnerList | Gets a List<T> containing the list of elements in the collection instance.

Public Properties

Name | Description
Count | Gets the number of elements actually contained in the collection.
IsReadOnly | Gets a value indicating whether the collection is read-only.
Item | Gets or sets the element at the specified index.

Public Methods

Name | Description
Add | Adds an object to the end of the collection.
Clear | Removes all elements from the collection.
Contains | Determines whether an element is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
GetEnumerator | Returns an enumerator that iterates through the collection.
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection.
Insert | Inserts an element into the collection at the specified index.
Remove | Removes the first occurrence of a specific object from the collection.
RemoveAt | Removes the element at the specified index of the collection.
Sort | Overloaded.

See Also

CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T) Fields

CollectionBase(T) Fields
[image]

Protected Fields

Name | Description
InnerList | Gets a List<T> containing the list of elements in the collection instance.

See Also

CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).InnerList Field

CollectionBase(T).InnerList Field
[image]

Gets a List<T> containing the list of elements in the collection instance.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected List<T> InnerList

Visual Basic [image] Copy Code

Protected InnerList As List(Of T)

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T) Constructor

CollectionBase(T) Constructor
[image]

Initializes a new instance of the CollectionBase<T> class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected CollectionBase<T> ()

Visual Basic [image] Copy Code

Protected Sub New(Of T) ()

See Also

CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T) Methods

CollectionBase(T) Methods
[image]

Public Methods

Name | Description
Add | Adds an object to the end of the collection.
Clear | Removes all elements from the collection.
Contains | Determines whether an element is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
GetEnumerator | Returns an enumerator that iterates through the collection.
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection.
Insert | Inserts an element into the collection at the specified index.
Remove | Removes the first occurrence of a specific object from the collection.
RemoveAt | Removes the element at the specified index of the collection.
Sort | Overloaded.

See Also

CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).Add Method

CollectionBase(T).Add Method
[image]

Adds an object to the end of the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract void Add (
T item
)

Visual Basic [image] Copy Code

Public MustOverride Sub Add( _
item As T _
)

Parameters

item

The object to be added to the end of the collection.

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).Clear Method

CollectionBase(T).Clear Method
[image]

Removes all elements from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract void Clear ()

Visual Basic [image] Copy Code

Public MustOverride Sub Clear ()

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).Contains Method

CollectionBase(T).Contains Method
[image]

Determines whether an element is in the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Contains (
T item
)

Visual Basic [image] Copy Code

Public Function Contains( _
item As T _
) As Boolean

Parameters

item

The object to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).CopyTo Method

CollectionBase(T).CopyTo Method
[image]

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void CopyTo (
T[] array,
int arrayIndex
)

Visual Basic [image] Copy Code

Public Sub CopyTo( _
array() As T, _
arrayIndex As Integer _
)

Parameters

array

The one-dimensional array that is the destination of the elements copied from collection.

arrayIndex

The zero-based index in array at which copying begins.

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).GetEnumerator Method

CollectionBase(T).GetEnumerator Method
[image]

Returns an enumerator that iterates through the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IEnumerator<T> GetEnumerator ()

Visual Basic [image] Copy Code

Public Function GetEnumerator () As IEnumerator(Of T)

Return Value

An IEnumerator<T> for the collection.

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).IndexOf Method

CollectionBase(T).IndexOf Method
[image]

Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int IndexOf (
T item
)

Visual Basic [image] Copy Code

Public Function IndexOf( _
item As T _
) As Integer

Parameters

item

The object to locate in the collection.

Return Value

The zero-based index of the first occurrence of item within the entire collection, if found; otherwise, –1.

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).Insert Method

CollectionBase(T).Insert Method
[image]

Inserts an element into the collection at the specified index.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract void Insert (
int index,
T item
)

Visual Basic [image] Copy Code

Public MustOverride Sub Insert( _
index As Integer, _
item As T _
)

Parameters

index

The zero-based index at which item should be inserted.

item

The object to insert.

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).Remove Method

CollectionBase(T).Remove Method
[image]

Removes the first occurrence of a specific object from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract bool Remove (
T item
)

Visual Basic [image] Copy Code

Public MustOverride Function Remove( _
item As T _
) As Boolean

Parameters

item

The object to remove from the collection.

Return Value

true if item is successfully removed; otherwise, false.

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).RemoveAt Method

CollectionBase(T).RemoveAt Method
[image]

Removes the element at the specified index of the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract void RemoveAt (
int index
)

Visual Basic [image] Copy Code

Public MustOverride Sub RemoveAt( _
index As Integer _
)

Parameters

index

The zero-based index of the element to remove.

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).Sort Method

CollectionBase(T).Sort Method
[image]

Overload List

Name | Description
CollectionBase(T).Sort (Comparison(T)) | Sorts the elements in this collection using the specified comparison.
CollectionBase(T).Sort (IComparer(T)) | Sorts the elements in this collection using the specified comparer.

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).Sort Method (Comparison(T))

CollectionBase(T).Sort Method (Comparison(T))
See Also
[image]

Sorts the elements in this collection using the specified comparison.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Sort (
Comparison<T> comparison
)

Visual Basic [image] Copy Code

Public Sub Sort( _
comparison As Comparison(Of T) _
)

Parameters

comparison

The System.Comparison to use when comparing elements.

See Also

Sort Method Overload List
CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).Sort Method (IComparer(T))

CollectionBase(T).Sort Method (IComparer(T))
See Also
[image]

Sorts the elements in this collection using the specified comparer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Sort (
IComparer<T> comparer
)

Visual Basic [image] Copy Code

Public Sub Sort( _
comparer As IComparer(Of T) _
)

Parameters

comparer

The IComparer implementation to use when comparing elements.

See Also

Sort Method Overload List
CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T) Properties

CollectionBase(T) Properties
[image]

Public Properties

Name | Description
Count | Gets the number of elements actually contained in the collection.
IsReadOnly | Gets a value indicating whether the collection is read-only.
Item | Gets or sets the element at the specified index.

See Also

CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).Count Property

CollectionBase(T).Count Property
[image]

Gets the number of elements actually contained in the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Count { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Count As Integer

Property Value

An integer value.

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).IsReadOnly Property

CollectionBase(T).IsReadOnly Property
[image]

Gets a value indicating whether the collection is read-only.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsReadOnly { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsReadOnly As Boolean

Property Value

true if the collection is read-only; otherwise, false.

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).Item Property

CollectionBase(T).Item Property
[image]

Gets or sets the element at the specified index.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public T Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Property Item( _
index As Integer _
) As T

Parameters

index

The zero-based index of the element to get or set.

Property Value

The element at the specified index.

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.ColumnStyle Enumeration

ColumnStyle Enumeration
[image]

Specifies how table columns' width is set.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum ColumnStyle

Visual Basic [image] Copy Code

Public Enum ColumnStyle

Members

Member name | Description
FixedWidth | The columns has fixed, unchangeable width.
AutoWidth | The columns' width changes when the table is resized.

Remarks

Use the enumeration values to set the behavior of table columns, when the user resizes the table.

See Also

ColumnStyle Property


MindFusion.Diagramming.CommandHistory Class

CommandHistory Class
Remarks See Also
[image]

Maintains a queue of Command records used to undo or redo actions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class CommandHistory

Visual Basic [image] Copy Code

Public Class CommandHistory

Remarks

The only instance of CommandHistory can be accessed through the History property of UndoManager.

The Capacity property specifies how many Command instances can be stored in the history queue. If the queue is full and a new action is recorded, the oldest one will be removed and made unavailable for undo/redo. A read-only access to the command queue is provided by the Commands property.

The CommandHistory instance maintains an internal record pointer. The pointer is decreased or increased by one when an action is respectively undone or redone through the undo manager. The pointer actually refers to two adjacent action records - the older one to be used when undoing, the newer one when redoing commands. Those two records can be accessed by NextUndo and NextRedo properties. When no action has been undone, the pointer refers to the end of the queue and NextRedo returns null (Nothing in Visual Basic). When all actions have been undone, the pointer refers to the start of the queue and NextUndo returns null.

Call Clear to remove all action records that are currently in the history queue, making those actions unavailable for undo or redo anymore. That won't disable adding new records to the queue, so it will be possible to undo/redo any actions executed after Clear.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.CommandHistory

See Also

CommandHistory Members


MindFusion.Diagramming.CommandHistory Members

CommandHistory Members
Properties Methods
[image]

Maintains a queue of Command records used to undo or redo actions.

The following tables list the members exposed by the CommandHistory type.

Public Properties

Name | Description
Capacity | Gets or sets the maximum number of records to keep in the history queue.
Commands | Gets the commands saved in the undo / redo history queue.
NextRedo | Gets a reference to the command that would be redone if Redo is invoked.
NextUndo | Gets a reference to the command that would be undone if Undo is invoked.

Public Methods

Name | Description
Clear | Removes all records from the history queue.
MergeUndoRecords | Merges several undo records into a single composite record.

See Also

CommandHistory Class


MindFusion.Diagramming.CommandHistory Methods

CommandHistory Methods
[image]

Public Methods

Name | Description
Clear | Removes all records from the history queue.
MergeUndoRecords | Merges several undo records into a single composite record.

See Also

CommandHistory Class


MindFusion.Diagramming.CommandHistory.Clear Method

CommandHistory.Clear Method
[image]

Removes all records from the history queue.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Clear ()

Visual Basic [image] Copy Code

Public Sub Clear ()

Remarks

Call Clear to remove all action records that are currently in the history queue, making those actions unavailable for undo or redo anymore. That won't disable adding new records to the queue, so it will be possible to undo/redo any actions executed after the call.

See Also

CommandHistory Members
CommandHistory Class
UndoEnabled Property


MindFusion.Diagramming.CommandHistory.MergeUndoRecords Method

CommandHistory.MergeUndoRecords Method
[image]

Merges several undo records into a single composite record.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool MergeUndoRecords (
int numRecords,
string title
)

Visual Basic [image] Copy Code

Public Function MergeUndoRecords( _
numRecords As Integer, _
title As String _
) As Boolean

Parameters

numRecords
Specifies how many records at the end of the command list should be merged.
title
Specifies the title of the new command.

Return Value

false if the commands saved in the history are less than numRecords; otherwise, true.

See Also

CommandHistory Members
CommandHistory Class
StartComposite Method


MindFusion.Diagramming.CommandHistory Properties

CommandHistory Properties
[image]

Public Properties

Name | Description
Capacity | Gets or sets the maximum number of records to keep in the history queue.
Commands | Gets the commands saved in the undo / redo history queue.
NextRedo | Gets a reference to the command that would be redone if Redo is invoked.
NextUndo | Gets a reference to the command that would be undone if Undo is invoked.

See Also

CommandHistory Class


MindFusion.Diagramming.CommandHistory.Capacity Property

CommandHistory.Capacity Property
[image]

Gets or sets the maximum number of records to keep in the history queue.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Capacity { get; set; }

Visual Basic [image] Copy Code

Public Property Capacity As Integer

Property Value

An integer value specifying the number of records to keep in the queue; cannot be less than 1. The default is 10.

Remarks

If the history queue is full, the oldest command records are removed from the beginning when new ones are added. The queue is cleared when you change Capacity, so better do this at application's startup phase.

See Also

CommandHistory Members
CommandHistory Class


MindFusion.Diagramming.CommandHistory.Commands Property

CommandHistory.Commands Property
[image]

Gets the commands saved in the undo / redo history queue.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CommandList Commands { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Commands As CommandList

Property Value

An instance of the CommandList class representing a read-only collection of Command objects.

See Also

CommandHistory Members
CommandHistory Class
MindFusion.Diagramming Namespace
NextUndo Property
NextRedo Property


MindFusion.Diagramming.CommandHistory.NextRedo Property

CommandHistory.NextRedo Property
[image]

Gets a reference to the command that would be redone if Redo is invoked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Command NextRedo { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NextRedo As Command

Property Value

An instance of the Command class.

Remarks

When no action has been undone, the current action pointer refers to the end of the history queue and NextRedo returns null (Nothing in Visual Basic).

See Also

CommandHistory Members
CommandHistory Class
MindFusion.Diagramming Namespace
Redo Method
NextUndo Property


MindFusion.Diagramming.CommandHistory.NextUndo Property

CommandHistory.NextUndo Property
[image]

Gets a reference to the command that would be undone if Undo is invoked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Command NextUndo { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NextUndo As Command

Property Value

An instance of the Command class.

Remarks

When all actions have been undone, the current action pointer refers to the start of the history queue and NextUndo returns null (Nothing in Visual Basic).

See Also

CommandHistory Members
CommandHistory Class
MindFusion.Diagramming Namespace
Undo Method
NextRedo Property


MindFusion.Diagramming.CompositeNode Class

CompositeNode Class
Remarks See Also
[image]

Represents a node, which can hold components.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class CompositeNode : DiagramNode, IComponentHost

Visual Basic [image] Copy Code

Public Class CompositeNode
Inherits DiagramNode
Implements IComponentHost

Remarks

Use the Components property to add components to the node. The components are arranged on top of each other by default. To apply custom arrangement logic either parent the components in a ContainerComponent, such as GridPanel, and add this ContainerComponent to the CompositeNode or override the ArrangeComponents method to apply custom arrangement logic.

To search for a component given its name, use the FindComponent method. To get a component at a specific position, use GetComponentAt.

For additional information about components, check the Components topic.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.CompositeNode

See Also

CompositeNode Members


MindFusion.Diagramming.CompositeNode Members

CompositeNode Members
Constructors Fields Properties Methods
[image]

Represents a node, which can hold components.

The following tables list the members exposed by the CompositeNode type.

Public Constructors

Name | Description
CompositeNode | Overloaded. Initializes a new instance of the CompositeNode class.

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Components | Gets a list with the root components contained in the node.
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | Determines whether the node supports connections to its constituent elements. (Inherited from DiagramNode.)
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
ArrangeComponents | Invokes when the components within this node are being arranged.
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsComponent | Checks whether the specified component is contained in this node.
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
DocToComponent | Converts a point from document coordinates to the local coordinate space of a component inside this node.
DoModify | For internal use. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. Renders the adjustment handles of this item. (Inherited from DiagramNode.)
DrawLocal | Draws the node on the specified IGraphics surface.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | Draws the shadow of this node on the specified IGraphics surface.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
FindComponent | Returns the child component with the specified name or null (Nothing in Visual Basic), if the component was not found.
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetComponentAt | Returns the component at the specified point, expressed in document coordinates.
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item. (Inherited from DiagramItem.)
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item. (Inherited from DiagramItem.)
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item. (Inherited from DiagramItem.)
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item. (Inherited from DiagramItem.)
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point. (Inherited from DiagramNode.)
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Intersects | Determines whether the node intersects another one, taking into account the outlines of node shapes. (Inherited from DiagramNode.)
InvalidateLayout | Invalidates the component layout, causing rearrangement of content.
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
PointToComponent | For internal use.
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetPos | Sets the bounding rectangle of this node without updating connected arrows. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
CancelModify | DiagramItem.CancelModify override. Invoked when the interactive modification of this object has been canceled. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Checks whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateProperties | DiagramItem.CreateProperties override. (Inherited from DiagramNode.)
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
Finalize | DiagramItem finalizer. (Inherited from DiagramItem.)
FreeResources | Called when the node is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle.
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFrom | DiagramItem.LoadFrom override.
LoadFromXml | DiagramItem.LoadFromXml override.
LoadObsolete | For internal use. (Inherited from DiagramItem.)
OnAdd | DiagramItem.OnAdd override. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnClick | Invoked when the user clicks this item. (Inherited from DiagramItem.)
OnDoubleClick | Invoked when the user double-clicks this item. (Inherited from DiagramItem.)
OnMeasureUnitChanged | DiagramItem.OnMeasureUnitChanged override.
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramNode.OnRemove override.
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | DiagramItem.OnZoomChanged override.
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override. (Inherited from DiagramNode.)
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramItem.SaveProperties override. (Inherited from DiagramNode.)
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveTo | DiagramItem.SaveTo override.
SaveToXml | DiagramItem.SaveToXml override.
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SerializeComponents | Invoked to query whether the underlying component structure should be automatically serialized.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReference | Called during deserialization, after all objects have been instantiated, in order to update the references between them. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. Invoked when the user starts modifying this item interactively. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster. (Inherited from DiagramItem.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. Invoked during interactive modification of this item. (Inherited from DiagramNode.)

See Also

CompositeNode Class


MindFusion.Diagramming.CompositeNode Constructor

CompositeNode Constructor
[image]

Initializes a new instance of the CompositeNode class.

Overload List

Name | Description
CompositeNode () | Initializes a new instance of the CompositeNode class.
CompositeNode (CompositeNode) | Initializes a new instance of the CompositeNode class using the specified diagram item as a prototype.
CompositeNode (Diagram) | Initializes a new instance of the CompositeNode class with default values supplied form the specified Diagram.

See Also

CompositeNode Class


MindFusion.Diagramming.CompositeNode Constructor ()

CompositeNode Constructor ()
See Also
[image]

Initializes a new instance of the CompositeNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CompositeNode ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CompositeNode Constructor Overload List
CompositeNode Class


MindFusion.Diagramming.CompositeNode Constructor (CompositeNode)

CompositeNode Constructor (CompositeNode)
See Also
[image]

Initializes a new instance of the CompositeNode class using the specified diagram item as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CompositeNode (
CompositeNode prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As CompositeNode _
)

Parameters

prototype

The item to use as a prototype. The properties of the new item are initialized from the property values of this item.

Remarks

This constructor copies the DiagramNode property values from the specified prototype node.

See Also

CompositeNode Constructor Overload List
CompositeNode Class


MindFusion.Diagramming.CompositeNode Constructor (Diagram)

CompositeNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the CompositeNode class with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CompositeNode (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram from which to obtain default values for the node properties.

Remarks

This constructor initializes the CompositeNode properties with the values specified in the respective default-value properties of the Diagram object.

See Also

CompositeNode Constructor Overload List
CompositeNode Class


MindFusion.Diagramming.CompositeNode Methods

CompositeNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
ArrangeComponents | Invokes when the components within this node are being arranged.
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsComponent | Checks whether the specified component is contained in this node.
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
DocToComponent | Converts a point from document coordinates to the local coordinate space of a component inside this node.
DoModify | For internal use. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. Renders the adjustment handles of this item. (Inherited from DiagramNode.)
DrawLocal | Draws the node on the specified IGraphics surface.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | Draws the shadow of this node on the specified IGraphics surface.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
FindComponent | Returns the child component with the specified name or null (Nothing in Visual Basic), if the component was not found.
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetComponentAt | Returns the component at the specified point, expressed in document coordinates.
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item. (Inherited from DiagramItem.)
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item. (Inherited from DiagramItem.)
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item. (Inherited from DiagramItem.)
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item. (Inherited from DiagramItem.)
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point. (Inherited from DiagramNode.)
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Intersects | Determines whether the node intersects another one, taking into account the outlines of node shapes. (Inherited from DiagramNode.)
InvalidateLayout | Invalidates the component layout, causing rearrangement of content.
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
PointToComponent | For internal use.
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetPos | Sets the bounding rectangle of this node without updating connected arrows. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
CancelModify | DiagramItem.CancelModify override. Invoked when the interactive modification of this object has been canceled. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Checks whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateProperties | DiagramItem.CreateProperties override. (Inherited from DiagramNode.)
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
Finalize | DiagramItem finalizer. (Inherited from DiagramItem.)
FreeResources | Called when the node is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle.
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFrom | DiagramItem.LoadFrom override.
LoadFromXml | DiagramItem.LoadFromXml override.
LoadObsolete | For internal use. (Inherited from DiagramItem.)
OnAdd | DiagramItem.OnAdd override. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnClick | Invoked when the user clicks this item. (Inherited from DiagramItem.)
OnDoubleClick | Invoked when the user double-clicks this item. (Inherited from DiagramItem.)
OnMeasureUnitChanged | DiagramItem.OnMeasureUnitChanged override.
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramNode.OnRemove override.
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | DiagramItem.OnZoomChanged override.
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override. (Inherited from DiagramNode.)
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramItem.SaveProperties override. (Inherited from DiagramNode.)
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveTo | DiagramItem.SaveTo override.
SaveToXml | DiagramItem.SaveToXml override.
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SerializeComponents | Invoked to query whether the underlying component structure should be automatically serialized.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReference | Called during deserialization, after all objects have been instantiated, in order to update the references between them. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. Invoked when the user starts modifying this item interactively. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster. (Inherited from DiagramItem.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. Invoked during interactive modification of this item. (Inherited from DiagramNode.)

See Also

CompositeNode Class


MindFusion.Diagramming.CompositeNode.ArrangeComponents Method

CompositeNode.ArrangeComponents Method
[image]

Invokes when the components within this node are being arranged.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void ArrangeComponents (
RectangleF availableSpace,
IGraphics graphics
)

Visual Basic [image] Copy Code

Public Overridable Sub ArrangeComponents ( _
availableSpace As RectangleF, _
graphics As IGraphics _
)

Parameters

availableSpace

The available space.

graphics
An IGraphics object that can be used for text measurement.

Remarks

By default components are arranged on top of each other, in the order they were added to the Components collection. To apply more specialized arrangement add the components to a ContainerComponent (such as SimplePanel, StackPanel or GridPanel) then add this ContainerComponent as a child of the CompositeNode. The component system allows you to implement additional ContainerComponent-derived classes to apply custom arrangement logic.

Another way to apply custom arrangement is to derive from CompositeNode and override the ArrangeComponents method. Then position the components by setting their Bounds property.

See Also

CompositeNode Members
CompositeNode Class


MindFusion.Diagramming.CompositeNode.ContainsComponent Method

CompositeNode.ContainsComponent Method
[image]

Checks whether the specified component is contained in this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ContainsComponent (
ComponentBase component
)

Visual Basic [image] Copy Code

Public Function ContainsComponent( _
component As ComponentBase _
) As Boolean

Parameters

component

The component to check.

Return Value

true if the component is contained in the node; otherwise, false.

See Also

CompositeNode Members
CompositeNode Class


MindFusion.Diagramming.CompositeNode.DocToComponent Method

CompositeNode.DocToComponent Method
[image]

Converts a point from document coordinates to the local coordinate space of a component inside this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointF DocToComponent (
PointF docPoint,
ComponentBase component
)

Visual Basic [image] Copy Code

Public Function DocToComponent( _
docPoint As PointF, _
component As ComponentBase _
) As PointF

Parameters

docPoint

The point to convert.

component

The target component.

Return Value

A PointF object representing the point in local coordinates.

See Also

CompositeNode Members
CompositeNode Class


MindFusion.Diagramming.CompositeNode.DrawLocal Method

CompositeNode.DrawLocal Method
[image]

Draws the node on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawLocal (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawLocal( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

The IGraphics surface to draw the node on.

options

Provides options for the drawing operation.

See Also

CompositeNode Members
CompositeNode Class


MindFusion.Diagramming.CompositeNode.DrawShadowLocal Method

CompositeNode.DrawShadowLocal Method
[image]

Draws the shadow of this node on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawShadowLocal (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawShadowLocal( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

An IGraphics object where the shadow should be rendered.

options

Provides options for the drawing operation.

See Also

CompositeNode Members
CompositeNode Class


MindFusion.Diagramming.CompositeNode.FindComponent Method

CompositeNode.FindComponent Method
[image]

Returns the child component with the specified name or null (Nothing in Visual Basic), if the component was not found.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ComponentBase FindComponent (
string name
)

Visual Basic [image] Copy Code

Public Function FindComponent ( _
name As String _
) As ComponentBase

Parameters

name
The name of the component to search for.

Return Value

An instance of the ComponentBase class identifying the found component or null (Nothing in Visual Basic).

Remarks

This method is useful for obtaining a references to components defined in XML.

See Also

CompositeNode Members
CompositeNode Class


MindFusion.Diagramming.CompositeNode.GetComponentAt Method

CompositeNode.GetComponentAt Method
[image]

Returns the component at the specified point, expressed in document coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual ComponentBase GetComponentAt (
PointF point
)

Visual Basic [image] Copy Code

Public Overridable Function GetComponentAt ( _
point As PointF _
) As ComponentBase

Parameters

point
A PointF specifying the point to test, expressed in document coordinates.

Return Value

An instance of the ComponentBase class identifying the topmost component at the specified point or null (Nothing in Visual Basic).

Remarks

This method ignores components with any of the following properties set to false: IsEnabled, IsHitTestVisible, IsInteractive.

See Also

CompositeNode Members
CompositeNode Class


MindFusion.Diagramming.CompositeNode.GetRgnInRect Method

CompositeNode.GetRgnInRect Method
[image]

Creates and returns a Region object for this node as though it is contained in the specified rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Region GetRgnInRect (
RectangleF rc,
bool inLocal
)

Visual Basic [image] Copy Code

Protected Overrides Function GetRgnInRect( _
rc As RectangleF, _
inLocal As Boolean _
) As Region

Parameters

rc

inLocal

Return Value

See Also

CompositeNode Members
CompositeNode Class


MindFusion.Diagramming.CompositeNode.InvalidateLayout Method

CompositeNode.InvalidateLayout Method
[image]

Invalidates the component layout, causing rearrangement of content.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void InvalidateLayout ()

Visual Basic [image] Copy Code

Public Sub InvalidateLayout ()

Remarks

Calling this method will cause ArrangeComponents to be invoked before the next drawing pass.

See Also

CompositeNode Members
CompositeNode Class


MindFusion.Diagramming.CompositeNode.LoadFrom Method

CompositeNode.LoadFrom Method
[image]

DiagramItem.LoadFrom override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFrom (
BinaryReader reader,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFrom ( _
reader As BinaryReader, _
context As PersistContext _
)

Parameters

reader
A BinaryReader object from which to read the item's data.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

By default, all components of a CompositeNode are saved in the stream along with their associated data. This will lead to wasted space if the instances of a derived class are built upon the same hierarchy of components and expose only a few properties that expose component attributes. The recommended approach of serializing such classes is to override SerializeComponents and return false to stop the built-in serialization of components, and save / load the node properties from the SaveTo / LoadFrom overrides. This is demonstrated in EmployeeNode.cs in the Demo sample project.

See Also

CompositeNode Members
CompositeNode Class


MindFusion.Diagramming.CompositeNode.LoadFromXml Method

CompositeNode.LoadFromXml Method
[image]

DiagramItem.LoadFromXml override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFromXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement containing the item's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

By default, all components of a CompositeNode are saved in the XML document along with their associated data. This will lead to wasted space if the instances of a derived class are built upon the same hierarchy of components and expose only a few properties that expose component attributes. The recommended approach of serializing such classes is to override SerializeComponents and return false to stop the built-in serialization of components, and save / load the node properties from the SaveToXml / LoadFromXml overrides. This is demonstrated in the Scripting sample project.

See Also

CompositeNode Members
CompositeNode Class


MindFusion.Diagramming.CompositeNode.OnMeasureUnitChanged Method

CompositeNode.OnMeasureUnitChanged Method
[image]

DiagramItem.OnMeasureUnitChanged override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnMeasureUnitChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnMeasureUnitChanged ()

See Also

CompositeNode Members
CompositeNode Class


MindFusion.Diagramming.CompositeNode.OnRemove Method

CompositeNode.OnRemove Method
[image]

DiagramNode.OnRemove override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnRemove ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnRemove ()

See Also

CompositeNode Members
CompositeNode Class


MindFusion.Diagramming.CompositeNode.OnUpdateBounds Method

CompositeNode.OnUpdateBounds Method
[image]

DiagramNode.OnUpdateBounds override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnUpdateBounds (
bool sizeChanged
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnUpdateBounds( _
sizeChanged As Boolean _
)

Parameters

sizeChanged

true if the size has changed; false if only the position has changed.

See Also

CompositeNode Members
CompositeNode Class


MindFusion.Diagramming.CompositeNode.OnZoomChanged Method

CompositeNode.OnZoomChanged Method
[image]

DiagramItem.OnZoomChanged override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnZoomChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnZoomChanged ()

See Also

CompositeNode Members
CompositeNode Class


MindFusion.Diagramming.CompositeNode.PointToComponent Method

CompositeNode.PointToComponent Method
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointF PointToComponent (
PointF point
)

Visual Basic [image] Copy Code

Public Function PointToComponent( _
point As PointF _
) As PointF

Parameters

point

Return Value

See Also

CompositeNode Members
CompositeNode Class


MindFusion.Diagramming.CompositeNode.SaveTo Method

CompositeNode.SaveTo Method
[image]

DiagramItem.SaveTo override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveTo (
BinaryWriter writer,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveTo ( _
writer As BinaryWriter, _
context As PersistContext _
)

Parameters

writer
A BinaryWriter object the item's data should be written to.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

By default, all components of a CompositeNode are saved in the stream along with their associated data. This will lead to wasted space if the instances of a derived class are built upon the same hierarchy of components and expose only a few properties that expose component attributes. The recommended approach of serializing such classes is to override SerializeComponents and return false to stop the built-in serialization of components, and save / load the node properties from the SaveTo / LoadFrom overrides. This is demonstrated in EmployeeNode.cs in the Demo sample project.

See Also

CompositeNode Members
CompositeNode Class


MindFusion.Diagramming.CompositeNode.SaveToXml Method

CompositeNode.SaveToXml Method
[image]

DiagramItem.SaveToXml override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveToXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement the item's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

By default, all components of a CompositeNode are saved in the XML document along with their associated data. This will lead to wasted space if the instances of a derived class are built upon the same hierarchy of components and expose only a few properties that expose component attributes. The recommended approach of serializing such classes is to override SerializeComponents and return false to stop the built-in serialization of components, and save / load the node properties from the SaveToXml / LoadFromXml overrides. This is demonstrated in the Scripting sample project.

See Also

CompositeNode Members
CompositeNode Class


MindFusion.Diagramming.CompositeNode.SerializeComponents Method

CompositeNode.SerializeComponents Method
[image]

Invoked to query whether the underlying component structure should be automatically serialized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual bool SerializeComponents ()

Visual Basic [image] Copy Code

Protected Overridable Function SerializeComponents () As Boolean

Return Value

true to automatically serialize the component tree; false to skip the automatic component serialization.

Remarks

By default, all components of a CompositeNode are saved along with their associated data. This will lead to wasted space if the instances of a derived class are built upon the same hierarchy of components and expose only a few properties that expose component attributes. The recommended approach of serializing such classes is to override SerializeComponents and return false to stop the built-in serialization of components. Then you can save or load only the necessary node properties from the SaveTo / LoadFrom overrides for binary format, or SaveToXml / LoadFromXml for XML format. This is demonstrated in EmployeeNode.cs in the Demo sample project.

See Also

CompositeNode Members
CompositeNode Class


MindFusion.Diagramming.CompositeNode Properties

CompositeNode Properties
[image]

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Components | Gets a list with the root components contained in the node.
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | Determines whether the node supports connections to its constituent elements. (Inherited from DiagramNode.)
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

See Also

CompositeNode Class


MindFusion.Diagramming.CompositeNode.Components Property

CompositeNode.Components Property
[image]

Gets a list with the root components contained in the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IList<ComponentBase> Components { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Components As IList(Of ComponentBase)

Property Value

A list with the components contained in this node.

See Also

CompositeNode Members
CompositeNode Class


MindFusion.Diagramming.CompositeNodeStyle Class

CompositeNodeStyle Class
[image]

Represents a reusable set of properties that define the appearance of composite nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class CompositeNodeStyle : DiagramNodeStyle

Visual Basic [image] Copy Code

Public Class CompositeNodeStyle
Inherits DiagramNodeStyle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Style
MindFusion.Diagramming.DiagramItemStyle
MindFusion.Diagramming.DiagramNodeStyle
MindFusion.Diagramming.CompositeNodeStyle

See Also

CompositeNodeStyle Members


MindFusion.Diagramming.CompositeNodeStyle Members

CompositeNodeStyle Members
Constructors Properties Methods Events
[image]

Represents a reusable set of properties that define the appearance of composite nodes.

The following tables list the members exposed by the CompositeNodeStyle type.

Public Constructors

Name | Description
CompositeNodeStyle | Initializes a new instance of the CompositeNodeStyle class.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of the item. (Inherited from DiagramItemStyle.)
Effects | Gets a list of the effects applied to the node. (Inherited from DiagramNodeStyle.)
FontFamily | Gets or sets the font family of the item text. (Inherited from DiagramItemStyle.)
FontSize | Gets or sets the font size of the item text. (Inherited from DiagramItemStyle.)
FontStyle | Gets or sets the font style of the item text. (Inherited from DiagramItemStyle.)
FontUnit | Gets or sets the font unit of the item text. (Inherited from DiagramItemStyle.)
ShadowBrush | Gets or sets the brush used to paint the shadow of the item. (Inherited from DiagramItemStyle.)
Stroke | Gets or sets the brush used to paint the outline of the item. (Inherited from DiagramItemStyle.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItemStyle.)
StrokeThickness | Gets or sets the thickness of the item's outline, expressed in the current units of measure. (Inherited from DiagramItemStyle.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItemStyle.)

Public Methods

Name | Description
GetProperties | Gets all properties in the style. (Inherited from Style.)
GetProperty | Returns the property with the specified name, if any. (Inherited from Style.)
RegisterType | Associates a type with an alias. (Inherited from Style.)

Protected Methods

Name | Description
GetValue | Gets the value of the specified property. (Inherited from Style.)
IsPropertySet | Checks whether the specified property has a value. (Inherited from Style.)
LoadFrom | Deserializes the item from the specified reader. (Inherited from Style.)
LoadFromXml | Loads the style content from an XML element. (Inherited from Style.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Style.)
RegisterProperty | Registers a new property with the specified name and type. (Inherited from Style.)
SaveTo | Serializes the style to the specified writer. (Inherited from Style.)
SaveToXml | Saves the style content into an XML element. (Inherited from Style.)
SetValue | Sets the value of the specified property. (Inherited from Style.)
UnsetValue | Clears the value of the specified property. (Inherited from Style.)

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

CompositeNodeStyle Class


MindFusion.Diagramming.CompositeNodeStyle Constructor

CompositeNodeStyle Constructor
[image]

Initializes a new instance of the CompositeNodeStyle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CompositeNodeStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CompositeNodeStyle Class


MindFusion.Diagramming.CompositeNodeStyle Events

CompositeNodeStyle Events
[image]

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

CompositeNodeStyle Class


MindFusion.Diagramming.ConnectionPoint Class

ConnectionPoint Class
Remarks See Also
[image]

This class represents a connection between an edge and a node in a graph. It decouples the DiagramLink class from the DiagramNode class, allowing edges to connect different types of nodes without knowing anything of their implementation details. Each DiagramLink object contains two ConnectionPoint instances describing the connections at both ends of the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ConnectionPoint : IPersists

Visual Basic [image] Copy Code

Public Class ConnectionPoint
Implements IPersists

Remarks

If custom nodes should store additional information about their connections, inherit the ConnectionPoint class, add the necessary members and return an instance of this class from the CreateConnectionPoint override. For example, TreeViewNode uses TreeViewConnectionPoint objects to store reference to the item associated with the connection.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ConnectionPoint
MindFusion.Diagramming.TreeViewConnectionPoint

See Also

ConnectionPoint Members


MindFusion.Diagramming.ConnectionPoint Members

ConnectionPoint Members
Constructors Properties Methods
[image]

This class represents a connection between an edge and a node in a graph. It decouples the DiagramLink class from the DiagramNode class, allowing edges to connect different types of nodes without knowing anything of their implementation details. Each DiagramLink object contains two ConnectionPoint instances describing the connections at both ends of the link.

The following tables list the members exposed by the ConnectionPoint type.

Public Constructors

Name | Description
ConnectionPoint | Overloaded. Initializes a new instance of the ConnectionPoint class.

Public Properties

Name | Description
RelativePosition | Gets or sets the position of this connection point, relative to the associated node's bounding rectangle, expressed in percents.
Row | Gets the index of a constituent item within the associated node where the link represented by this connection point is connected, or -1, if the link is connected to the node itself.

Protected Properties

Name | Description
Incoming | Gets a flag indicating whether this connection point is at the origin or the destination of the associated link.
Link | Gets the link associated with this connection point.
Node | Gets the node associated with this connection point.

Public Methods

Name | Description
AddLinkToNode | Adds the link associated with this connection point to the associated node.
CalculateIntersections | Determines whether the end of a link should be aligned to the point where the node contour is intersected by the line connecting the centers of the connected nodes.
CanMoveLink | Checks whether the specified point, expressed in document coordinates, is a valid location for this connection point.
GetAnchorPos | Overloaded.
GetEndPoint | Calculates the coordinates of the this connection point expressed in document coordinates.
GetInitialPoint | Returns a point (usually the center of the bounding rectangle) contained within the associated node.
GetIntersection | Calculates the intersection point between the specified line segment and the contour of the node associated with this connection point.
GetNodeRect | Returns the bounding rectangle of the node associated with this connection point.
LinkChanges | Checks whether the relationship represented by the associated link would change if the link is attached to the specified node at the specified point.
NearestAnchorPoint | Returns the anchor point closest to the specified point from the node's associated anchor pattern.
NodesIntersect | Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect.
RemoveLinkFromNode | Removes the link associated with this connection point from the associated node.
SameNode | Checks whether the current connection point and the specified connection point are associated with the same node.
SaveEndRelative | Updates the coordinates of the connection point represented by this link, relative to the bounding rectangle of the associated node.

Protected Methods

Name | Description
GetClassId | Returns unique id number for this class.
GetNearestBorderPoint | Returns the nearest point lying on the node border.
LoadFrom | Deserializes the object from the specified reader.
SaveTo | Serializes the object to the specified writer.
SetReference | Updates the reference to the specified object.
UpdateFromPoint | Updates the connection state according to the specified point, without changing the related node.

See Also

ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint Constructor

ConnectionPoint Constructor
[image]

Initializes a new instance of the ConnectionPoint class.

Overload List

Name | Description
ConnectionPoint () | Initializes a new instance of the ConnectionPoint class.
ConnectionPoint (DiagramNode, DiagramLink, Boolean) | Initializes a new instance of the ConnectionPoint class between the specified node and link.

See Also

ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint Constructor ()

ConnectionPoint Constructor ()
See Also
[image]

Initializes a new instance of the ConnectionPoint class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected ConnectionPoint ()

Visual Basic [image] Copy Code

Protected Sub New ()

Remarks

This constructor is used only during deserialization.

See Also

ConnectionPoint Constructor Overload List
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint Constructor (DiagramNode, DiagramLink, Boolean)

ConnectionPoint Constructor (DiagramNode, DiagramLink, Boolean)
See Also
[image]

Initializes a new instance of the ConnectionPoint class between the specified node and link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ConnectionPoint (
DiagramNode node,
DiagramLink link,
bool incoming
)

Visual Basic [image] Copy Code

Public Sub ConnectionPoint ( _
node As DiagramNode, _
link As DiagramLink, _
incoming As Boolean _
)

Parameters

node
The node whose connection to a link is managed by this ConnectionPoint.
link
The link whose connection to a node is managed by this ConnectionPoint.
incoming
Specifies which end of the link is represented by this ConnectionPoint.

See Also

ConnectionPoint Constructor Overload List
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint Methods

ConnectionPoint Methods
[image]

Public Methods

Name | Description
AddLinkToNode | Adds the link associated with this connection point to the associated node.
CalculateIntersections | Determines whether the end of a link should be aligned to the point where the node contour is intersected by the line connecting the centers of the connected nodes.
CanMoveLink | Checks whether the specified point, expressed in document coordinates, is a valid location for this connection point.
GetAnchorPos | Overloaded.
GetEndPoint | Calculates the coordinates of the this connection point expressed in document coordinates.
GetInitialPoint | Returns a point (usually the center of the bounding rectangle) contained within the associated node.
GetIntersection | Calculates the intersection point between the specified line segment and the contour of the node associated with this connection point.
GetNodeRect | Returns the bounding rectangle of the node associated with this connection point.
LinkChanges | Checks whether the relationship represented by the associated link would change if the link is attached to the specified node at the specified point.
NearestAnchorPoint | Returns the anchor point closest to the specified point from the node's associated anchor pattern.
NodesIntersect | Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect.
RemoveLinkFromNode | Removes the link associated with this connection point from the associated node.
SameNode | Checks whether the current connection point and the specified connection point are associated with the same node.
SaveEndRelative | Updates the coordinates of the connection point represented by this link, relative to the bounding rectangle of the associated node.

Protected Methods

Name | Description
GetClassId | Returns unique id number for this class.
GetNearestBorderPoint | Returns the nearest point lying on the node border.
LoadFrom | Deserializes the object from the specified reader.
SaveTo | Serializes the object to the specified writer.
SetReference | Updates the reference to the specified object.
UpdateFromPoint | Updates the connection state according to the specified point, without changing the related node.

See Also

ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.AddLinkToNode Method

ConnectionPoint.AddLinkToNode Method
[image]

Adds the link associated with this connection point to the associated node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void AddLinkToNode ()

Visual Basic [image] Copy Code

Public Overridable Sub AddLinkToNode ()

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.CalculateIntersections Method

ConnectionPoint.CalculateIntersections Method
[image]

Determines whether the end of a link should be aligned to the point where the node contour is intersected by the line connecting the centers of the connected nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool CalculateIntersections ()

Visual Basic [image] Copy Code

Public Overridable Function CalculateIntersections () As Boolean

Return Value

true to align the link end; otherwise, false.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.CanMoveLink Method

ConnectionPoint.CanMoveLink Method
[image]

Checks whether the specified point, expressed in document coordinates, is a valid location for this connection point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool CanMoveLink (
PointF pt
)

Visual Basic [image] Copy Code

Public Overridable Function CanMoveLink( _
pt As PointF _
) As Boolean

Parameters

pt
The PointF to check for validity.

Return Value

true if the specified point represents a valid location for the connection point; otherwise, false.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.GetAnchorPos Method

ConnectionPoint.GetAnchorPos Method
[image]

Overload List

Name | Description
ConnectionPoint.GetAnchorPos (Int32) | Returns the point from the node's associated anchor pattern (if any) with the specified index or the link's initial point.
ConnectionPoint.GetAnchorPos (Int32, PointF@) | Retrieves the point from the node's associated anchor pattern (if any) with the specified index.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.GetAnchorPos Method (Int32)

ConnectionPoint.GetAnchorPos Method (Int32)
See Also
[image]

Returns the point from the node's associated anchor pattern (if any) with the specified index or the link's initial point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual PointF GetAnchorPos (
int anchorIdx
)

Visual Basic [image] Copy Code

Public Overridable Function GetAnchorPos( _
anchorIdx As Integer _
) As PointF

Parameters

anchorIdx

Return Value

See Also

GetAnchorPos Method Overload List
ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.GetAnchorPos Method (Int32, PointF@)

ConnectionPoint.GetAnchorPos Method (Int32, PointF@)
See Also
[image]

Retrieves the point from the node's associated anchor pattern (if any) with the specified index.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool GetAnchorPos (
int anchorIdx,
ref PointF point
)

Visual Basic [image] Copy Code

Public Overridable Function GetAnchorPos( _
anchorIdx As Integer, _
ByRef point As PointF _
) As Boolean

Parameters

anchorIdx

point

Return Value

See Also

GetAnchorPos Method Overload List
ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.GetClassId Method

ConnectionPoint.GetClassId Method
[image]

Returns unique id number for this class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual int GetClassId ()

Visual Basic [image] Copy Code

Protected Overridable Function GetClassId () As Integer

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.GetEndPoint Method

ConnectionPoint.GetEndPoint Method
[image]

Calculates the coordinates of the this connection point expressed in document coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual PointF GetEndPoint ()

Visual Basic [image] Copy Code

Public Overridable Function GetEndPoint () As PointF

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.GetInitialPoint Method

ConnectionPoint.GetInitialPoint Method
[image]

Returns a point (usually the center of the bounding rectangle) contained within the associated node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual PointF GetInitialPoint ()

Visual Basic [image] Copy Code

Public Overridable Function GetInitialPoint () As PointF

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.GetIntersection Method

ConnectionPoint.GetIntersection Method
[image]

Calculates the intersection point between the specified line segment and the contour of the node associated with this connection point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual PointF GetIntersection (
PointF pt1,
PointF pt2
)

Visual Basic [image] Copy Code

Public Overridable Function GetIntersection( _
pt1 As PointF, _
pt2 As PointF _
) As PointF

Parameters

pt1

pt2

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.GetNearestBorderPoint Method

ConnectionPoint.GetNearestBorderPoint Method
[image]

Returns the nearest point lying on the node border.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual PointF GetNearestBorderPoint (
PointF point
)

Visual Basic [image] Copy Code

Protected Overridable Function GetNearestBorderPoint( _
point As PointF _
) As PointF

Parameters

point

A PointF instance specifying the point to align to node's borders.

Return Value

A PointF instance containing coordinates of nearest border point.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.GetNodeRect Method

ConnectionPoint.GetNodeRect Method
[image]

Returns the bounding rectangle of the node associated with this connection point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual RectangleF GetNodeRect (
bool rotated
)

Visual Basic [image] Copy Code

Public Overridable Function GetNodeRect( _
rotated As Boolean _
) As RectangleF

Parameters

rotated

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.LinkChanges Method

ConnectionPoint.LinkChanges Method
[image]

Checks whether the relationship represented by the associated link would change if the link is attached to the specified node at the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool LinkChanges (
DiagramItem item,
PointF point
)

Visual Basic [image] Copy Code

Public Overridable Function LinkChanges ( _
item As DiagramItem, _
point As PointF _
) As Boolean

Parameters

item
The item under the mouse pointer.
point
The current mouse pointer position.

Return Value

true if the node should create a new ConnectionPoint instance, otherwise false.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.LoadFrom Method

ConnectionPoint.LoadFrom Method
[image]

Deserializes the object from the specified reader.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFrom (
BinaryReader reader,
PersistContext ctx
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFrom ( _
reader As BinaryReader, _
ctx As PersistContext _
)

Parameters

reader

ctx

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.NearestAnchorPoint Method

ConnectionPoint.NearestAnchorPoint Method
[image]

Returns the anchor point closest to the specified point from the node's associated anchor pattern.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual PointF NearestAnchorPoint (
PointF point,
ref int idx
)

Visual Basic [image] Copy Code

Public Overridable Function NearestAnchorPoint( _
point As PointF, _
ByRef idx As Integer _
) As PointF

Parameters

point

A PointF that should be aligned to anchor point.

idx

An integer variable that receives the anchor point index within AnchorPattern.

Return Value

A PointF containing anchor point coordinates.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.NodesIntersect Method

ConnectionPoint.NodesIntersect Method
[image]

Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool NodesIntersect (
ConnectionPoint connectionPoint
)

Visual Basic [image] Copy Code

Public Function NodesIntersect ( _
connectionPoint As ConnectionPoint _
) As Boolean

Parameters

connectionPoint

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.RemoveLinkFromNode Method

ConnectionPoint.RemoveLinkFromNode Method
[image]

Removes the link associated with this connection point from the associated node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void RemoveLinkFromNode ()

Visual Basic [image] Copy Code

Public Overridable Sub RemoveLinkFromNode ()

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.SameNode Method

ConnectionPoint.SameNode Method
[image]

Checks whether the current connection point and the specified connection point are associated with the same node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool SameNode (
ConnectionPoint otherConnectionPoint
)

Visual Basic [image] Copy Code

Public Overridable Function SameNode ( _
otherConnectionPoint As ConnectionPoint _
) As Boolean

Parameters

otherConnectionPoint

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.SaveEndRelative Method

ConnectionPoint.SaveEndRelative Method
[image]

Updates the coordinates of the connection point represented by this link, relative to the bounding rectangle of the associated node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void SaveEndRelative ()

Visual Basic [image] Copy Code

Public Overridable Sub SaveEndRelative ()

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.SaveTo Method

ConnectionPoint.SaveTo Method
[image]

Serializes the object to the specified writer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveTo (
BinaryWriter writer,
PersistContext ctx
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveTo ( _
writer As BinaryWriter, _
ctx As PersistContext _
)

Parameters

writer

ctx

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.SetReference Method

ConnectionPoint.SetReference Method
[image]

Updates the reference to the specified object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SetReference (
int refId,
Object obj
)

Visual Basic [image] Copy Code

Protected Overridable Sub SetReference( _
refId As Integer, _
obj As Object _
)

Parameters

refId

obj

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.UpdateFromPoint Method

ConnectionPoint.UpdateFromPoint Method
[image]

Updates the connection state according to the specified point, without changing the related node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void UpdateFromPoint (
PointF point
)

Visual Basic [image] Copy Code

Protected Overridable Sub UpdateFromPoint( _
point As PointF _
)

Parameters

point
The current mouse pointer position.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint Properties

ConnectionPoint Properties
[image]

Public Properties

Name | Description
RelativePosition | Gets or sets the position of this connection point, relative to the associated node's bounding rectangle, expressed in percents.
Row | Gets the index of a constituent item within the associated node where the link represented by this connection point is connected, or -1, if the link is connected to the node itself.

Protected Properties

Name | Description
Incoming | Gets a flag indicating whether this connection point is at the origin or the destination of the associated link.
Link | Gets the link associated with this connection point.
Node | Gets the node associated with this connection point.

See Also

ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.Incoming Property

ConnectionPoint.Incoming Property
[image]

Gets a flag indicating whether this connection point is at the origin or the destination of the associated link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected bool Incoming { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property Incoming As Boolean

Property Value

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.Link Property

ConnectionPoint.Link Property
[image]

Gets the link associated with this connection point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DiagramLink Link { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property Link As DiagramLink

Property Value

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.Node Property

ConnectionPoint.Node Property
[image]

Gets the node associated with this connection point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramNode Node { get; }

Visual Basic [image] Copy Code

Protected Overridable ReadOnly Property Node As DiagramNode

Property Value

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.RelativePosition Property

ConnectionPoint.RelativePosition Property
[image]

Gets or sets the position of this connection point, relative to the associated node's bounding rectangle, expressed in percents.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointF RelativePosition { get; set; }

Visual Basic [image] Copy Code

Public Property RelativePosition As PointF

Property Value

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.Row Property

ConnectionPoint.Row Property
[image]

Gets the index of a constituent item within the associated node where the link represented by this connection point is connected, or -1, if the link is connected to the node itself.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual int Row { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Row As Integer

Property Value

An integer ID of the related item, or -1 if the link connects to the node as integral entity.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.Constants Class

Constants Class
[image]

Contains various global constants, also provides measure unit independent constants.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class Constants

Visual Basic [image] Copy Code

Public NotInheritable Class Constants

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Constants

See Also

Constants Members


MindFusion.Diagramming.Constants Members

Constants Members
Fields Methods
[image]

Contains various global constants, also provides measure unit independent constants.

The following tables list the members exposed by the Constants type.

Public Fields

Name | Description
E | A very small positive real number (0.01).
IdentityMatrix | The identity matrix.
NoAnchorPattern | A constant indicating no anchor pattern during binary serialization.

Public Methods

Name | Description
GetAutoScroll | Gets the number of units to scroll the control during auto-scroll operation.
GetContainerFolderPadding | Gets the padding around the fold button of a container node.
GetExpandIconSize | Gets the size of the expand/collapse manipulator icon.
GetFitTextStep | Gets a value used when fitting the size of a node to its contained text.
GetHalfInch | Gets the size of a half inch.
GetHScrollButtonSize | Gets the size of horizontal scrollbar arrow buttons.
GetInch | Gets the size of one inch.
GetInflation | Gets a relax value used when testing object intersections.
GetLineHitTest | Gets a value specifying relative distance from an arrow used during hit-testing operations.
GetMarkSize | Gets the size of an anchor point mark.
GetMillimeter | Gets the size of one millimeter.
GetMinArrowheadSize | Gets the minimum allowed size of an arrowhead.
GetMinItemSize | Gets the minimum size for a diagram node that can be achieved interactively.
GetPixel | Gets the size of one pixel.
GetReflHth | Gets the initial distance between adjacent control points of a reflexive arrow along the Y-axis.
GetReflWth2 | Gets the initial distance between adjacent control points of a reflexive link along the X-axis.
GetRoundRectArc | Gets the radius of the arc of the rounded rectangle node shape.
GetRouteGridSize | Gets the default size of the link routing grid.
GetScrollerWdt | Gets the width of the scroller manipulator icon.
GetSelPtTest | Gets a relax value used during selection handles hit-testing.
GetTableHeaderOffset | Gets the width of a header row icon.
GetVScrollButtonSize | Gets the size of vertical scrollbar arrow buttons.

See Also

Constants Class


MindFusion.Diagramming.Constants Fields

Constants Fields
[image]

Public Fields

Name | Description
E | A very small positive real number (0.01).
IdentityMatrix | The identity matrix.
NoAnchorPattern | A constant indicating no anchor pattern during binary serialization.

See Also

Constants Class


MindFusion.Diagramming.Constants.E Field

Constants.E Field
[image]

A very small positive real number (0.01).

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float E

Visual Basic [image] Copy Code

Public Shared E As Single

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.IdentityMatrix Field

Constants.IdentityMatrix Field
[image]

The identity matrix.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Matrix IdentityMatrix

Visual Basic [image] Copy Code

Public Shared IdentityMatrix As Matrix

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.NoAnchorPattern Field

Constants.NoAnchorPattern Field
[image]

A constant indicating no anchor pattern during binary serialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static int NoAnchorPattern

Visual Basic [image] Copy Code

Public Shared NoAnchorPattern As Integer

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants Methods

Constants Methods
[image]

Public Methods

Name | Description
GetAutoScroll | Gets the number of units to scroll the control during auto-scroll operation.
GetContainerFolderPadding | Gets the padding around the fold button of a container node.
GetExpandIconSize | Gets the size of the expand/collapse manipulator icon.
GetFitTextStep | Gets a value used when fitting the size of a node to its contained text.
GetHalfInch | Gets the size of a half inch.
GetHScrollButtonSize | Gets the size of horizontal scrollbar arrow buttons.
GetInch | Gets the size of one inch.
GetInflation | Gets a relax value used when testing object intersections.
GetLineHitTest | Gets a value specifying relative distance from an arrow used during hit-testing operations.
GetMarkSize | Gets the size of an anchor point mark.
GetMillimeter | Gets the size of one millimeter.
GetMinArrowheadSize | Gets the minimum allowed size of an arrowhead.
GetMinItemSize | Gets the minimum size for a diagram node that can be achieved interactively.
GetPixel | Gets the size of one pixel.
GetReflHth | Gets the initial distance between adjacent control points of a reflexive arrow along the Y-axis.
GetReflWth2 | Gets the initial distance between adjacent control points of a reflexive link along the X-axis.
GetRoundRectArc | Gets the radius of the arc of the rounded rectangle node shape.
GetRouteGridSize | Gets the default size of the link routing grid.
GetScrollerWdt | Gets the width of the scroller manipulator icon.
GetSelPtTest | Gets a relax value used during selection handles hit-testing.
GetTableHeaderOffset | Gets the width of a header row icon.
GetVScrollButtonSize | Gets the size of vertical scrollbar arrow buttons.

See Also

Constants Class


MindFusion.Diagramming.Constants.GetAutoScroll Method

Constants.GetAutoScroll Method
[image]

Gets the number of units to scroll the control during auto-scroll operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float GetAutoScroll (
MeasureUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetAutoScroll( _
currUnit As MeasureUnit _
) As Single

Parameters

currUnit

A MeasureUnit instance.

Return Value

The number of units to add to or remove from the scroll position.

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetContainerFolderPadding Method

Constants.GetContainerFolderPadding Method
[image]

Gets the padding around the fold button of a container node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float GetContainerFolderPadding (
MeasureUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetContainerFolderPadding( _
currUnit As MeasureUnit _
) As Single

Parameters

currUnit

A MeasureUnit instance.

Return Value

The padding space to leave around fold buttons, expressed in the specified unit.

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetExpandIconSize Method

Constants.GetExpandIconSize Method
[image]

Gets the size of the expand/collapse manipulator icon.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float GetExpandIconSize (
MeasureUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetExpandIconSize( _
currUnit As MeasureUnit _
) As Single

Parameters

currUnit

A MeasureUnit instance.

Return Value

The +/- icon size, expressed in the specified unit.

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetFitTextStep Method

Constants.GetFitTextStep Method
[image]

Gets a value used when fitting the size of a node to its contained text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float GetFitTextStep (
MeasureUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetFitTextStep( _
currUnit As MeasureUnit _
) As Single

Parameters

currUnit

A MeasureUnit instance.

Return Value

The step size, expressed in the specified unit.

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetHalfInch Method

Constants.GetHalfInch Method
[image]

Gets the size of a half inch.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float GetHalfInch (
MeasureUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetHalfInch( _
currUnit As MeasureUnit _
) As Single

Parameters

currUnit

A MeasureUnit instance.

Return Value

Half of an inch in the specified unit.

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetHScrollButtonSize Method

Constants.GetHScrollButtonSize Method
[image]

Gets the size of horizontal scrollbar arrow buttons.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static SizeF GetHScrollButtonSize (
MeasureUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetHScrollButtonSize( _
currUnit As MeasureUnit _
) As SizeF

Parameters

currUnit

A MeasureUnit instance.

Return Value

The size of scrollbar left and right arrow buttons, expressed in the specified unit.

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetInch Method

Constants.GetInch Method
[image]

Gets the size of one inch.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float GetInch (
MeasureUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetInch( _
currUnit As MeasureUnit _
) As Single

Parameters

currUnit

A MeasureUnit instance.

Return Value

The size of an inch measured in the specified unit.

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetInflation Method

Constants.GetInflation Method
[image]

Gets a relax value used when testing object intersections.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float GetInflation (
MeasureUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetInflation( _
currUnit As MeasureUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetLineHitTest Method

Constants.GetLineHitTest Method
[image]

Gets a value specifying relative distance from an arrow used during hit-testing operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float GetLineHitTest (
MeasureUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetLineHitTest( _
currUnit As MeasureUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetMarkSize Method

Constants.GetMarkSize Method
[image]

Gets the size of an anchor point mark.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float GetMarkSize (
MeasureUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetMarkSize( _
currUnit As MeasureUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetMillimeter Method

Constants.GetMillimeter Method
[image]

Gets the size of one millimeter.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float GetMillimeter (
MeasureUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetMillimeter( _
currUnit As MeasureUnit _
) As Single

Parameters

currUnit

A MeasureUnit instance.

Return Value

The size of a millimeter measured in the specified unit.

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetMinArrowheadSize Method

Constants.GetMinArrowheadSize Method
[image]

Gets the minimum allowed size of an arrowhead.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float GetMinArrowheadSize (
MeasureUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetMinArrowheadSize( _
currUnit As MeasureUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetMinItemSize Method

Constants.GetMinItemSize Method
[image]

Gets the minimum size for a diagram node that can be achieved interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float GetMinItemSize (
MeasureUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetMinItemSize( _
currUnit As MeasureUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetPixel Method

Constants.GetPixel Method
[image]

Gets the size of one pixel.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float GetPixel (
MeasureUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetPixel( _
currUnit As MeasureUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetReflHth Method

Constants.GetReflHth Method
[image]

Gets the initial distance between adjacent control points of a reflexive arrow along the Y-axis.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float GetReflHth (
MeasureUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetReflHth( _
currUnit As MeasureUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetReflWth2 Method

Constants.GetReflWth2 Method
[image]

Gets the initial distance between adjacent control points of a reflexive link along the X-axis.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float GetReflWth2 (
MeasureUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetReflWth2( _
currUnit As MeasureUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetRoundRectArc Method

Constants.GetRoundRectArc Method
[image]

Gets the radius of the arc of the rounded rectangle node shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float GetRoundRectArc (
MeasureUnit currUnit,
float factor
)

Visual Basic [image] Copy Code

Public Shared Function GetRoundRectArc( _
currUnit As MeasureUnit, _
factor As Single _
) As Single

Parameters

currUnit

factor

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetRouteGridSize Method

Constants.GetRouteGridSize Method
[image]

Gets the default size of the link routing grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float GetRouteGridSize (
MeasureUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetRouteGridSize( _
currUnit As MeasureUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetScrollerWdt Method

Constants.GetScrollerWdt Method
[image]

Gets the width of the scroller manipulator icon.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float GetScrollerWdt (
MeasureUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetScrollerWdt( _
currUnit As MeasureUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetSelPtTest Method

Constants.GetSelPtTest Method
[image]

Gets a relax value used during selection handles hit-testing.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float GetSelPtTest (
MeasureUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetSelPtTest( _
currUnit As MeasureUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetTableHeaderOffset Method

Constants.GetTableHeaderOffset Method
[image]

Gets the width of a header row icon.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float GetTableHeaderOffset (
MeasureUnit unit
)

Visual Basic [image] Copy Code

Public Shared Function GetTableHeaderOffset( _
unit As MeasureUnit _
) As Single

Parameters

unit

A MeasureUnit instance.

Return Value

The offset of header rows, expressed in the specified unit.

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetVScrollButtonSize Method

Constants.GetVScrollButtonSize Method
[image]

Gets the size of vertical scrollbar arrow buttons.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static SizeF GetVScrollButtonSize (
MeasureUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetVScrollButtonSize( _
currUnit As MeasureUnit _
) As SizeF

Parameters

currUnit

A MeasureUnit instance.

Return Value

The size of scrollbar top and bottom arrow buttons, expressed in the specified unit.

See Also

Constants Members
Constants Class


MindFusion.Diagramming.ContainerChildEventArgs Class

ContainerChildEventArgs Class
[image]

Contains arguments passed to events related to container children.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ContainerChildEventArgs : NodeEventArgs

Visual Basic [image] Copy Code

Public Class ContainerChildEventArgs
Inherits NodeEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.NodeEventArgs
MindFusion.Diagramming.ContainerChildEventArgs

See Also

ContainerChildEventArgs Members


MindFusion.Diagramming.ContainerChildEventArgs Members

ContainerChildEventArgs Members
Constructors Properties Methods
[image]

Contains arguments passed to events related to container children.

The following tables list the members exposed by the ContainerChildEventArgs type.

Public Constructors

Name | Description
ContainerChildEventArgs | Initializes a new instance of the ContainerChildEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from NodeEventArgs.)
Container | Refers to the container related to the event.
MouseButton | Gets which mouse button has been pressed. (Inherited from NodeEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from NodeEventArgs.)
Node | Gets the node for which the event was raised. (Inherited from NodeEventArgs.)

Public Methods

Name | Description
ToString | NodeEventArgs.ToString override.

See Also

ContainerChildEventArgs Class


MindFusion.Diagramming.ContainerChildEventArgs Constructor

ContainerChildEventArgs Constructor
[image]

Initializes a new instance of the ContainerChildEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerChildEventArgs (
ContainerNode container,
DiagramNode node
)

Visual Basic [image] Copy Code

Public Sub ContainerChildEventArgs ( _
container As ContainerNode, _
node As DiagramNode _
)

Parameters

container
A ContainerNode object related to the event.
node
A DiagramNode added to or removed from the container.

See Also

ContainerChildEventArgs Class


MindFusion.Diagramming.ContainerChildEventArgs Methods

ContainerChildEventArgs Methods
[image]

Public Methods

Name | Description
ToString | NodeEventArgs.ToString override.

See Also

ContainerChildEventArgs Class


MindFusion.Diagramming.ContainerChildEventArgs.ToString Method

ContainerChildEventArgs.ToString Method
[image]

NodeEventArgs.ToString override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

See Also

ContainerChildEventArgs Members
ContainerChildEventArgs Class


MindFusion.Diagramming.ContainerChildEventArgs Properties

ContainerChildEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from NodeEventArgs.)
Container | Refers to the container related to the event.
MouseButton | Gets which mouse button has been pressed. (Inherited from NodeEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from NodeEventArgs.)
Node | Gets the node for which the event was raised. (Inherited from NodeEventArgs.)

See Also

ContainerChildEventArgs Class


MindFusion.Diagramming.ContainerChildEventArgs.Container Property

ContainerChildEventArgs.Container Property
[image]

Refers to the container related to the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode Container { get; set; }

Visual Basic [image] Copy Code

Public Property Container As ContainerNode

Property Value

An instance of the ContainerNode class.

See Also

ContainerChildEventArgs Members
ContainerChildEventArgs Class


MindFusion.Diagramming.ContainerNode Class

ContainerNode Class
Remarks See Also
[image]

Represents a diagram node that can contain other nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ContainerNode : DiagramNode, InplaceEditable

Visual Basic [image] Copy Code

Public Class ContainerNode
Inherits DiagramNode
Implements InplaceEditable

Remarks

Users can drag nodes into a container interactively. When a dragged node is over a container, the container frame is painted using the HighlightPen property to indicate that the node would be added to the container.

Use the Add method to add a node to container programmatically. Use the Remove method to remove a node from the container. The GetContainer static method returns the container that contains a node.

AutoShrink specifies whether the size of a container should shrink when a node is removed from it. The container node will not shrink to a size smaller than MinimumSize, even if it does not contain any items.

A container node can be folded and unfolded, either interactively or programmatically, as specified through the Foldable and Folded properties. When a container is folded, it occupies a minimal area and its child nodes are hidden. You can get the original size of a folded container using the UnfoldedSize property.

The Caption property specifies the caption text of a container node, and CaptionBrush specifies its color. Use the CaptionFormat property to define the alignment and position of the caption text. The height of the caption area of a container can be set using the CaptionHeight property.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.ContainerNode

See Also

ContainerNode Members


MindFusion.Diagramming.ContainerNode Members

ContainerNode Members
Constructors Fields Properties Methods
[image]

Represents a diagram node that can contain other nodes.

The following tables list the members exposed by the ContainerNode type.

Public Constructors

Name | Description
ContainerNode | Overloaded. Initializes a new instance of the ContainerNode class.

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

Public Properties

Name | Description
AllowAddChildren | Gets or sets a value indicating whether child nodes can be added interactively to this container.
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AllowRemoveChildren | Gets or sets a value indicating whether child nodes can be removed interactively from this container.
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
AutoGrow | Gets or sets a value indicating whether the container should grow in size when nodes are added to it.
AutoShrink | Gets or sets a value indicating whether the container should shrink in size when nodes are removed from it.
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Caption | Gets or sets the container caption text.
CaptionBrush | Gets or sets the brush used to paint the container caption.
CaptionFormat | Gets or sets the caption alignment and format.
CaptionHeight | Gets or sets the height of the container's caption area.
ClipChildren | Gets or sets a value indicating whether child items should be clipped by container boundaries.
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveCaptionBrush | Gets the effective caption brush of the container.
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Foldable | Gets or sets a value indicating whether the user is allowed to fold this container.
Folded | Gets or sets a value indicating whether this container is folded.
FoldedSize | Gets or sets the size of the container when folded.
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HighlightPen | Gets or sets the pen used to draw the container frame lines when an item is dragged over the container.
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Margin | Gets or sets how much space should be left between contained nodes and the container borders.
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
MinimumSize | Gets or sets the minimum size of the container.
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Shape | Gets or sets the shape of the container's outline.
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
UnfoldedSize | Returns the original size of a folded container.
Visible | Gets or sets a value indicating whether the container is visible.
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | Determines whether the node supports connections to its constituent elements. (Inherited from DiagramNode.)
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
Add | Adds a node to this container.
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
ContainsRecursively | Determines whether this container contains the specified node, either directly or recursively through other containers.
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
DoModify | For internal use. (Inherited from DiagramItem.)
Draw | DiagramNode.Draw override. Draws the container on the specified IGraphics surface.
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. Renders the adjustment handles of this item. (Inherited from DiagramNode.)
DrawLocal | DiagramNode.DrawLocal override. Draws the container on the specified IGraphics surface.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | Override in a derived class to provide implementation specific drawing for the shadow of the node. (Inherited from DiagramNode.)
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetContainer | Retrieves the container node (if any) the specified node belongs to.
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item. (Inherited from DiagramItem.)
GetEffectiveCaptionBrush | Creates a System.Drawing.Brush object representing the currently effective caption brush of the container.
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item. (Inherited from DiagramItem.)
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item. (Inherited from DiagramItem.)
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item. (Inherited from DiagramItem.)
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | DiagramItem.HitTest override.
HitTestHandle | DiagramNode.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point.
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Intersects | Determines whether the node intersects another one, taking into account the outlines of node shapes. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node.
OnDragOver | Invoked when a diagram item is being dragged over this node.
OnDropOver | Invoked when a diagram item is dropped over this node.
OnLoad | DiagramItem.OnLoad override.
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Remove | Removes a node from this container.
Resize | Resizes the node. (Inherited from DiagramNode.)
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetPos | Sets the bounding rectangle of this node without updating connected arrows. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
UpdateBounds | Overloaded.
VisitNodes | Visits the diagram nodes in reverse Z order.
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
CancelModify | DiagramItem.CancelModify override. Invoked when the interactive modification of this object has been canceled. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Checks whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
Finalize | DiagramItem finalizer. (Inherited from DiagramItem.)
FreeResources | Called when the node is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from DiagramNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the item content from an XML element.
LoadObsolete | For internal use. (Inherited from DiagramItem.)
OnAdd | DiagramItem.OnAdd override. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified.
OnClick | Invoked when the user clicks this item. (Inherited from DiagramItem.)
OnDoubleClick | Invoked when the user double-clicks this item. (Inherited from DiagramItem.)
OnMeasureUnitChanged | DiagramItem.OnMeasureUnitChanged override. (Inherited from DiagramNode.)
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramNode.OnRemove override.
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | Overloaded. (Inherited from DiagramNode.)
OnZoomChanged | DiagramItem.OnZoomChanged override. (Inherited from DiagramNode.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
ScaleElements | DiagramNode.ScaleElements override.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReference | DiagramNode.SetReference override.
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. Invoked when the user starts modifying this item interactively. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster. (Inherited from DiagramItem.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. Invoked during interactive modification of this item. (Inherited from DiagramNode.)

See Also

ContainerNode Class


MindFusion.Diagramming.ContainerNode Constructor

ContainerNode Constructor
[image]

Initializes a new instance of the ContainerNode class.

Overload List

Name | Description
ContainerNode () | Initializes a new instance of the ContainerNode class.
ContainerNode (ContainerNode) | Initializes a new instance of the ContainerNode class using the specified node as a prototype.
ContainerNode (Diagram) | Initializes a new instance of the ContainerNode class with the default values of the specified diagram.

See Also

ContainerNode Class


MindFusion.Diagramming.ContainerNode Constructor ()

ContainerNode Constructor ()
See Also
[image]

Initializes a new instance of the ContainerNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ContainerNode Constructor Overload List
ContainerNode Class


MindFusion.Diagramming.ContainerNode Constructor (ContainerNode)

ContainerNode Constructor (ContainerNode)
See Also
[image]

Initializes a new instance of the ContainerNode class using the specified node as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode (
ContainerNode prototype
)

Visual Basic [image] Copy Code

Public Sub ContainerNode ( _
prototype As ContainerNode _
)

Parameters

prototype

See Also

ContainerNode Constructor Overload List
ContainerNode Class


MindFusion.Diagramming.ContainerNode Constructor (Diagram)

ContainerNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the ContainerNode class with the default values of the specified diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode (
Diagram parent
)

Visual Basic [image] Copy Code

Public Sub ContainerNode ( _
parent As Diagram _
)

Parameters

parent

See Also

ContainerNode Constructor Overload List
ContainerNode Class


MindFusion.Diagramming.ContainerNode Methods

ContainerNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
Add | Adds a node to this container.
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
ContainsRecursively | Determines whether this container contains the specified node, either directly or recursively through other containers.
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
DoModify | For internal use. (Inherited from DiagramItem.)
Draw | DiagramNode.Draw override. Draws the container on the specified IGraphics surface.
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. Renders the adjustment handles of this item. (Inherited from DiagramNode.)
DrawLocal | DiagramNode.DrawLocal override. Draws the container on the specified IGraphics surface.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | Override in a derived class to provide implementation specific drawing for the shadow of the node. (Inherited from DiagramNode.)
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetContainer | Retrieves the container node (if any) the specified node belongs to.
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item. (Inherited from DiagramItem.)
GetEffectiveCaptionBrush | Creates a System.Drawing.Brush object representing the currently effective caption brush of the container.
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item. (Inherited from DiagramItem.)
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item. (Inherited from DiagramItem.)
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item. (Inherited from DiagramItem.)
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | DiagramItem.HitTest override.
HitTestHandle | DiagramNode.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point.
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Intersects | Determines whether the node intersects another one, taking into account the outlines of node shapes. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node.
OnDragOver | Invoked when a diagram item is being dragged over this node.
OnDropOver | Invoked when a diagram item is dropped over this node.
OnLoad | DiagramItem.OnLoad override.
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Remove | Removes a node from this container.
Resize | Resizes the node. (Inherited from DiagramNode.)
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetPos | Sets the bounding rectangle of this node without updating connected arrows. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
UpdateBounds | Overloaded.
VisitNodes | Visits the diagram nodes in reverse Z order.
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
CancelModify | DiagramItem.CancelModify override. Invoked when the interactive modification of this object has been canceled. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Checks whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
Finalize | DiagramItem finalizer. (Inherited from DiagramItem.)
FreeResources | Called when the node is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from DiagramNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the item content from an XML element.
LoadObsolete | For internal use. (Inherited from DiagramItem.)
OnAdd | DiagramItem.OnAdd override. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified.
OnClick | Invoked when the user clicks this item. (Inherited from DiagramItem.)
OnDoubleClick | Invoked when the user double-clicks this item. (Inherited from DiagramItem.)
OnMeasureUnitChanged | DiagramItem.OnMeasureUnitChanged override. (Inherited from DiagramNode.)
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramNode.OnRemove override.
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | Overloaded. (Inherited from DiagramNode.)
OnZoomChanged | DiagramItem.OnZoomChanged override. (Inherited from DiagramNode.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
ScaleElements | DiagramNode.ScaleElements override.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReference | DiagramNode.SetReference override.
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. Invoked when the user starts modifying this item interactively. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster. (Inherited from DiagramItem.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. Invoked during interactive modification of this item. (Inherited from DiagramNode.)

See Also

ContainerNode Class


MindFusion.Diagramming.ContainerNode.Add Method

ContainerNode.Add Method
[image]

Adds a node to this container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Add (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Sub Add ( _
node As DiagramNode _
)

Parameters

node
The DiagramNode that will be added to the container.

Remarks

If the container bounds do not include the specified node bounds, the container will grow automatically to accommodate the new node.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace
Remove Method
ClipChildren Property


MindFusion.Diagramming.ContainerNode.ContainsRecursively Method

ContainerNode.ContainsRecursively Method
[image]

Determines whether this container contains the specified node, either directly or recursively through other containers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ContainsRecursively (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Function ContainsRecursively ( _
node As DiagramNode _
) As Boolean

Parameters

node
The DiagramNode to check.

Return Value

true if this container contains the node; otherwise, false.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.CreateProperties Method

ContainerNode.CreateProperties Method
[image]

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramItemProperties CreateProperties ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateProperties () As DiagramItemProperties

Return Value

An instance of the DiagramItemProperties class.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.Draw Method

ContainerNode.Draw Method
[image]

DiagramNode.Draw override. Draws the container on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Draw (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

The IGraphics surface to draw the node on.

options

Provides options for the drawing operation.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.DrawLocal Method

ContainerNode.DrawLocal Method
[image]

DiagramNode.DrawLocal override. Draws the container on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawLocal (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawLocal( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

An IGraphics object where the node should be rendered.

options

Provides options for the drawing operation.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.GetContainer Method

ContainerNode.GetContainer Method
[image]

Retrieves the container node (if any) the specified node belongs to.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static ContainerNode GetContainer (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Shared Function GetContainer ( _
node As DiagramNode _
) As ContainerNode

Parameters

node
The DiagramNode whose container you need to find.

Return Value

A ContainerNode that contains the specified node, or null (Nothing in Visual Basic) if the node is not contained.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.GetEffectiveCaptionBrush Method

ContainerNode.GetEffectiveCaptionBrush Method
[image]

Creates a System.Drawing.Brush object representing the currently effective caption brush of the container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush GetEffectiveCaptionBrush ()

Visual Basic [image] Copy Code

Public Function GetEffectiveCaptionBrush () As Brush

Return Value

A .NET Brush object.

Remarks

This method returns a system brush corresponding to the container's CaptionBrush if the container's CaptionBrush is not null, or a system brush corresponding to the TextBrush property of the container's style. The returned object must be disposed by the caller.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.HitTest Method

ContainerNode.HitTest Method
[image]

DiagramItem.HitTest override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override DiagramItem HitTest (
PointF point,
float threshold,
bool onlyNodes,
bool onlyInteractive
)

Visual Basic [image] Copy Code

Public Overrides Function HitTest( _
point As PointF, _
threshold As Single, _
onlyNodes As Boolean, _
onlyInteractive As Boolean _
) As DiagramItem

Parameters

point

A PointF value specifying the logical coordinates of a diagram point.

threshold

Specifies the size of the area around the item outlines where the point is still considered inside the item.

onlyNodes

true to exclude child links from the search.

onlyInteractive

true to exclude locked items from the search.

Return Value

The item that contains the specified point.

Remarks

This method performs recursive search if items contain child items.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.HitTestHandle Method

ContainerNode.HitTestHandle Method
[image]

DiagramNode.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override AdjustmentHandle HitTestHandle (
PointF point
)

Visual Basic [image] Copy Code

Public Overrides Function HitTestHandle( _
point As PointF _
) As AdjustmentHandle

Parameters

point

A PointF value specifying where to look for a selection handle.

Return Value

An AdjustmentHandle instance representing the adjustment handle found at the specified location, or null if there is none.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.LoadFrom Method

ContainerNode.LoadFrom Method
[image]

Deserializes the object from the specified reader.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFrom (
BinaryReader reader,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFrom ( _
reader As BinaryReader, _
context As PersistContext _
)

Parameters

reader
A BinaryReader object from which to read the item's data.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.LoadFromXml Method

ContainerNode.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFromXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement containing the item's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.OnChildModified Method

ContainerNode.OnChildModified Method
[image]

Called when a group child node has been modified.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnChildModified (
DiagramNode node,
AdjustmentHandles handle
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnChildModified ( _
node As DiagramNode, _
handle As AdjustmentHandles _
)

Parameters

node
The DiagramNode that has been moved or resized.
handle
The adjustment handle used to modify the node.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.OnDragOut Method

ContainerNode.OnDragOut Method
[image]

Invoked when a diagram item is being dragged out of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void OnDragOut (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Overrides Sub OnDragOut ( _
item As DiagramItem _
)

Parameters

item

The DiagramItem being dragged.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.OnDragOver Method

ContainerNode.OnDragOver Method
[image]

Invoked when a diagram item is being dragged over this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool OnDragOver (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Overrides Function OnDragOver ( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem being dragged.

Return Value

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.OnDropOver Method

ContainerNode.OnDropOver Method
[image]

Invoked when a diagram item is dropped over this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool OnDropOver (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Overrides Function OnDropOver ( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem being dragged.

Return Value

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.OnLoad Method

ContainerNode.OnLoad Method
[image]

DiagramItem.OnLoad override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void OnLoad ()

Visual Basic [image] Copy Code

Public Overrides Sub OnLoad ()

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.OnRemove Method

ContainerNode.OnRemove Method
[image]

DiagramNode.OnRemove override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnRemove ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnRemove ()

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.Remove Method

ContainerNode.Remove Method
[image]

Removes a node from this container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Remove (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Sub Remove ( _
node As DiagramNode _
)

Parameters

node
The DiagramNode that should be removed from the container.

See Also

ContainerNode Members
ContainerNode Class
Add Method


MindFusion.Diagramming.ContainerNode.RestoreProperties Method

ContainerNode.RestoreProperties Method
[image]

DiagramNode.RestoreProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overridable Sub RestoreProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties -derived object containing a snapshot of the item's properties.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.SaveProperties Method

ContainerNode.SaveProperties Method
[image]

DiagramNode.SaveProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties -derived object where the item's properties should be saved.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.SaveTo Method

ContainerNode.SaveTo Method
[image]

Serializes the object to the specified writer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveTo (
BinaryWriter writer,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveTo ( _
writer As BinaryWriter, _
context As PersistContext _
)

Parameters

writer
A BinaryWriter object the item's data should be written to.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.SaveToXml Method

ContainerNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveToXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement the item's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.ScaleElements Method

ContainerNode.ScaleElements Method
[image]

DiagramNode.ScaleElements override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void ScaleElements (
float scale
)

Visual Basic [image] Copy Code

Protected Overrides Sub ScaleElements( _
scale As Single _
)

Parameters

scale

The value by which to multiply node elements' sizes.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.SetReference Method

ContainerNode.SetReference Method
[image]

DiagramNode.SetReference override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SetReference (
int refId,
Object obj,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub SetReference( _
refId As Integer, _
obj As Object, _
context As PersistContext _
)

Parameters

refId

obj

context

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.UpdateBounds Method

ContainerNode.UpdateBounds Method
[image]

Overload List

Name | Description
ContainerNode.UpdateBounds () | Updates the container bounds to fit its contents.
ContainerNode.UpdateBounds (Boolean) | Updates the container bounds to fit its contents.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.UpdateBounds Method ()

ContainerNode.UpdateBounds Method ()
See Also
[image]

Updates the container bounds to fit its contents.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void UpdateBounds ()

Visual Basic [image] Copy Code

Public Sub UpdateBounds ()

See Also

UpdateBounds Method Overload List
ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.UpdateBounds Method (Boolean)

ContainerNode.UpdateBounds Method (Boolean)
See Also
[image]

Updates the container bounds to fit its contents.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void UpdateBounds (
bool includeLinks
)

Visual Basic [image] Copy Code

Public Sub UpdateBounds( _
includeLinks As Boolean _
)

Parameters

includeLinks
Specifies whether the bounding rectangle should contain the control points of links whose ends are both child nodes of this container.

See Also

UpdateBounds Method Overload List
ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.VisitNodes Method

ContainerNode.VisitNodes Method
[image]

Visits the diagram nodes in reverse Z order.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool VisitNodes (
PointF point,
VisitNode visitNode,
DiagramItem relatedItem
)

Visual Basic [image] Copy Code

Public Function VisitNodes( _
point As PointF, _
visitNode As VisitNode, _
relatedItem As DiagramItem _
) As Boolean

Parameters

point

Location of the nodes that should be visited.

visitNode

An operation to be performed on the nodes.

relatedItem

Parameter to pass to the visitNode operation.

Return Value

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode Properties

ContainerNode Properties
[image]

Public Properties

Name | Description
AllowAddChildren | Gets or sets a value indicating whether child nodes can be added interactively to this container.
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AllowRemoveChildren | Gets or sets a value indicating whether child nodes can be removed interactively from this container.
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
AutoGrow | Gets or sets a value indicating whether the container should grow in size when nodes are added to it.
AutoShrink | Gets or sets a value indicating whether the container should shrink in size when nodes are removed from it.
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Caption | Gets or sets the container caption text.
CaptionBrush | Gets or sets the brush used to paint the container caption.
CaptionFormat | Gets or sets the caption alignment and format.
CaptionHeight | Gets or sets the height of the container's caption area.
ClipChildren | Gets or sets a value indicating whether child items should be clipped by container boundaries.
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveCaptionBrush | Gets the effective caption brush of the container.
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Foldable | Gets or sets a value indicating whether the user is allowed to fold this container.
Folded | Gets or sets a value indicating whether this container is folded.
FoldedSize | Gets or sets the size of the container when folded.
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HighlightPen | Gets or sets the pen used to draw the container frame lines when an item is dragged over the container.
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Margin | Gets or sets how much space should be left between contained nodes and the container borders.
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
MinimumSize | Gets or sets the minimum size of the container.
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Shape | Gets or sets the shape of the container's outline.
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
UnfoldedSize | Returns the original size of a folded container.
Visible | Gets or sets a value indicating whether the container is visible.
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | Determines whether the node supports connections to its constituent elements. (Inherited from DiagramNode.)
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

See Also

ContainerNode Class


MindFusion.Diagramming.ContainerNode.AllowAddChildren Property

ContainerNode.AllowAddChildren Property
[image]

Gets or sets a value indicating whether child nodes can be added interactively to this container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowAddChildren { get; set; }

Visual Basic [image] Copy Code

Public Property AllowAddChildren As Boolean

Property Value

true to allow adding child nodes, otherwise false. The default value is true.

See Also

ContainerNode Members
ContainerNode Class
AllowRemoveChildren Property


MindFusion.Diagramming.ContainerNode.AllowRemoveChildren Property

ContainerNode.AllowRemoveChildren Property
[image]

Gets or sets a value indicating whether child nodes can be removed interactively from this container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowRemoveChildren { get; set; }

Visual Basic [image] Copy Code

Public Property AllowRemoveChildren As Boolean

Property Value

true to allow removing child nodes, otherwise false. The default value is true.

See Also

ContainerNode Members
ContainerNode Class
AllowAddChildren Property


MindFusion.Diagramming.ContainerNode.AutoGrow Property

ContainerNode.AutoGrow Property
[image]

Gets or sets a value indicating whether the container should grow in size when nodes are added to it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoGrow { get; set; }

Visual Basic [image] Copy Code

Public Property AutoGrow As Boolean

Property Value

true to grow container's size automatically, or false otherwise. The default value is true.

Remarks

When AutoGrow is enabled, the container size will grow to include newly added nodes when they wouldn't fit in its current size. The new Bounds of the container is set to the union of bounding rectangles of all child nodes inflated by Margin.

See Also

ContainerNode Members
ContainerNode Class
AutoShrink Property


MindFusion.Diagramming.ContainerNode.AutoShrink Property

ContainerNode.AutoShrink Property
[image]

Gets or sets a value indicating whether the container should shrink in size when nodes are removed from it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoShrink { get; set; }

Visual Basic [image] Copy Code

Public Property AutoShrink As Boolean

Property Value

true if the container should shrink automatically; otherwise, false. The default is false.

Remarks

The container won't shrink to a size smaller than MinimumSize.

See Also

ContainerNode Members
ContainerNode Class
AutoGrow Property


MindFusion.Diagramming.ContainerNode.Caption Property

ContainerNode.Caption Property
[image]

Gets or sets the container caption text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Caption { get; set; }

Visual Basic [image] Copy Code

Public Property Caption As String

Property Value

A string containing the container's caption text.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace
CaptionBrush Property
CaptionFormat Property
CaptionHeight Property


MindFusion.Diagramming.ContainerNode.CaptionBrush Property

ContainerNode.CaptionBrush Property
[image]

Gets or sets the brush used to paint the container caption.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush CaptionBrush { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace
Caption Property
CaptionHeight Property
CaptionFormat Property


MindFusion.Diagramming.ContainerNode.CaptionFormat Property

ContainerNode.CaptionFormat Property
[image]

Gets or sets the caption alignment and format.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringFormat CaptionFormat { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionFormat As StringFormat

Property Value

An instance of the .NET StringFormat class.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace
Caption Property
CaptionHeight Property


MindFusion.Diagramming.ContainerNode.CaptionHeight Property

ContainerNode.CaptionHeight Property
[image]

Gets or sets the height of the container's caption area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float CaptionHeight { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionHeight As Single

Property Value

A string value specifying the container's caption text. Initialized with the value of ContainerCaptionHeight.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace
CaptionFormat Property
Caption Property


MindFusion.Diagramming.ContainerNode.ClipChildren Property

ContainerNode.ClipChildren Property
[image]

Gets or sets a value indicating whether child items should be clipped by container boundaries.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ClipChildren { get; set; }

Visual Basic [image] Copy Code

Public Property ClipChildren As Boolean

Property Value

true to clip child items; otherwise, false. The default value is true.

See Also

ContainerNode Members
ContainerNode Class
Shape Property


MindFusion.Diagramming.ContainerNode.EffectiveCaptionBrush Property

ContainerNode.EffectiveCaptionBrush Property
[image]

Gets the effective caption brush of the container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush EffectiveCaptionBrush { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EffectiveCaptionBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.Foldable Property

ContainerNode.Foldable Property
[image]

Gets or sets a value indicating whether the user is allowed to fold this container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Foldable { get; set; }

Visual Basic [image] Copy Code

Public Property Foldable As Boolean

Property Value

true if the container can be folded; otherwise, false. Initialized with the value of ContainersFoldable.

Remarks

A foldable container can be folded and unfolded by clicking the up/down arrow displayed in the caption area.

See Also

ContainerNode Members
ContainerNode Class
Folded Property


MindFusion.Diagramming.ContainerNode.Folded Property

ContainerNode.Folded Property
[image]

Gets or sets a value indicating whether this container is folded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Folded { get; set; }

Visual Basic [image] Copy Code

Public Property Folded As Boolean

Property Value

true if the container is folded; otherwise, false. The default is false.

Remarks

When folded, the container children are not visible, and only its caption bar is displayed.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace
Foldable Property
Diagram.FoldedContainerSize Property


MindFusion.Diagramming.ContainerNode.FoldedSize Property

ContainerNode.FoldedSize Property
[image]

Gets or sets the size of the container when folded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SizeF FoldedSize { get; set; }

Visual Basic [image] Copy Code

Public Property FoldedSize As SizeF

Property Value

A SizeF instance specifying the folded size of a container. The default is SizeF.Empty.

Remarks

If this property is not set, the width of the folded container is set to its MinimumSize.Width, and the height to CaptionHeight.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.HighlightPen Property

ContainerNode.HighlightPen Property
[image]

Gets or sets the pen used to draw the container frame lines when an item is dragged over the container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen HighlightPen { get; set; }

Visual Basic [image] Copy Code

Public Property HighlightPen As Pen

Property Value

An instance of the Pen class. Initialized with the value of ContainerHighlightPen.

Remarks

The highlight rectangle is not drawn when AllowAddChildren is disabled.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.Margin Property

ContainerNode.Margin Property
[image]

Gets or sets how much space should be left between contained nodes and the container borders.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Margin { get; set; }

Visual Basic [image] Copy Code

Public Property Margin As Single

Property Value

A float value specifying the margin size. Initialized with the value of ContainerMargin.

See Also

ContainerNode Members
ContainerNode Class
AutoShrink Property


MindFusion.Diagramming.ContainerNode.MinimumSize Property

ContainerNode.MinimumSize Property
[image]

Gets or sets the minimum size of the container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SizeF MinimumSize { get; set; }

Visual Basic [image] Copy Code

Public Property MinimumSize As SizeF

Property Value

A .NET SizeF object specifying the minimum size. Initialized with the value of ContainerMinimumSize.

Remarks

The container won't shrink smaller than that size, even if it does not contain any items.

See Also

ContainerNode Members
ContainerNode Class
AutoShrink Property


MindFusion.Diagramming.ContainerNode.Shape Property

ContainerNode.Shape Property
[image]

Gets or sets the shape of the container's outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SimpleShape Shape { get; set; }

Visual Basic [image] Copy Code

Public Property Shape As SimpleShape

Property Value

A member of the SimpleShape enumeration.

See Also

ContainerNode Members
ContainerNode Class
ClipChildren Property


MindFusion.Diagramming.ContainerNode.UnfoldedSize Property

ContainerNode.UnfoldedSize Property
[image]

Returns the original size of a folded container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SizeF UnfoldedSize { get; set; }

Visual Basic [image] Copy Code

Public Property UnfoldedSize As SizeF

Property Value

A SizeF instance containing the original size of the container.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.Visible Property

ContainerNode.Visible Property
[image]

Gets or sets a value indicating whether the container is visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Visible As Boolean

Property Value

true if the item is visible; otherwise, false.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNodeProperties Class

ContainerNodeProperties Class
Remarks See Also
[image]

Stores the values of ContainerNode properties during undo / redo operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ContainerNodeProperties : DiagramNodeProperties

Visual Basic [image] Copy Code

Public Class ContainerNodeProperties
Inherits DiagramNodeProperties

Remarks

If you need to implement undo support for the additional properties defined by a class derived from ContainerNode, do so by deriving from ContainerNodeProperties and overriding the SaveProperties, RestoreProperties, and CreateProperties methods of ContainerNode.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemProperties
MindFusion.Diagramming.DiagramNodeProperties
MindFusion.Diagramming.ContainerNodeProperties

See Also

ContainerNodeProperties Members


MindFusion.Diagramming.ContainerNodeProperties Members

ContainerNodeProperties Members
Constructors Fields Methods
[image]

Stores the values of ContainerNode properties during undo / redo operations.

The following tables list the members exposed by the ContainerNodeProperties type.

Public Constructors

Name | Description
ContainerNodeProperties | Initializes a new instance of the ContainerNodeProperties class.

Public Fields

Name | Description
Caption | For internal use.
CaptionHeight | For internal use.
ItemClass | For internal use. (Inherited from DiagramItemProperties.)
Margin | For internal use.
Selected | For internal use. (Inherited from DiagramItemProperties.)
Shape | For internal use.
TextPadding | For internal use. (Inherited from DiagramItemProperties.)
ZIndex | For internal use. (Inherited from DiagramItemProperties.)

Public Methods

Name | Description
FreeResources | Frees stored resources which will no longer be used. (Inherited from DiagramItemProperties.)

See Also

ContainerNodeProperties Class


MindFusion.Diagramming.ContainerNodeProperties Fields

ContainerNodeProperties Fields
[image]

Public Fields

Name | Description
Caption | For internal use.
CaptionHeight | For internal use.
ItemClass | For internal use. (Inherited from DiagramItemProperties.)
Margin | For internal use.
Selected | For internal use. (Inherited from DiagramItemProperties.)
Shape | For internal use.
TextPadding | For internal use. (Inherited from DiagramItemProperties.)
ZIndex | For internal use. (Inherited from DiagramItemProperties.)

See Also

ContainerNodeProperties Class


MindFusion.Diagramming.ContainerNodeProperties.Caption Field

ContainerNodeProperties.Caption Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Caption

Visual Basic [image] Copy Code

Public Caption As String

See Also

ContainerNodeProperties Members
ContainerNodeProperties Class


MindFusion.Diagramming.ContainerNodeProperties.CaptionHeight Field

ContainerNodeProperties.CaptionHeight Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float CaptionHeight

Visual Basic [image] Copy Code

Public CaptionHeight As Single

See Also

ContainerNodeProperties Members
ContainerNodeProperties Class


MindFusion.Diagramming.ContainerNodeProperties.Margin Field

ContainerNodeProperties.Margin Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Margin

Visual Basic [image] Copy Code

Public Margin As Single

See Also

ContainerNodeProperties Members
ContainerNodeProperties Class


MindFusion.Diagramming.ContainerNodeProperties.Shape Field

ContainerNodeProperties.Shape Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SimpleShape Shape

Visual Basic [image] Copy Code

Public Shape As SimpleShape

See Also

ContainerNodeProperties Members
ContainerNodeProperties Class


MindFusion.Diagramming.ContainerNodeProperties Constructor

ContainerNodeProperties Constructor
[image]

Initializes a new instance of the ContainerNodeProperties class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNodeProperties ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ContainerNodeProperties Class


MindFusion.Diagramming.ContainerNodeStyle Class

ContainerNodeStyle Class
[image]

Represents a reusable set of properties that define the appearance of container nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ContainerNodeStyle : DiagramNodeStyle

Visual Basic [image] Copy Code

Public Class ContainerNodeStyle
Inherits DiagramNodeStyle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Style
MindFusion.Diagramming.DiagramItemStyle
MindFusion.Diagramming.DiagramNodeStyle
MindFusion.Diagramming.ContainerNodeStyle

See Also

ContainerNodeStyle Members


MindFusion.Diagramming.ContainerNodeStyle Members

ContainerNodeStyle Members
Constructors Properties Methods Events
[image]

Represents a reusable set of properties that define the appearance of container nodes.

The following tables list the members exposed by the ContainerNodeStyle type.

Public Constructors

Name | Description
ContainerNodeStyle | Initializes a new instance of the ContainerNodeStyle class.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of the item. (Inherited from DiagramItemStyle.)
Effects | Gets a list of the effects applied to the node. (Inherited from DiagramNodeStyle.)
FontFamily | Gets or sets the font family of the item text. (Inherited from DiagramItemStyle.)
FontSize | Gets or sets the font size of the item text. (Inherited from DiagramItemStyle.)
FontStyle | Gets or sets the font style of the item text. (Inherited from DiagramItemStyle.)
FontUnit | Gets or sets the font unit of the item text. (Inherited from DiagramItemStyle.)
ShadowBrush | Gets or sets the brush used to paint the shadow of the item. (Inherited from DiagramItemStyle.)
Stroke | Gets or sets the brush used to paint the outline of the item. (Inherited from DiagramItemStyle.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItemStyle.)
StrokeThickness | Gets or sets the thickness of the item's outline, expressed in the current units of measure. (Inherited from DiagramItemStyle.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItemStyle.)

Public Methods

Name | Description
GetProperties | Gets all properties in the style. (Inherited from Style.)
GetProperty | Returns the property with the specified name, if any. (Inherited from Style.)
RegisterType | Associates a type with an alias. (Inherited from Style.)

Protected Methods

Name | Description
GetValue | Gets the value of the specified property. (Inherited from Style.)
IsPropertySet | Checks whether the specified property has a value. (Inherited from Style.)
LoadFrom | Deserializes the item from the specified reader. (Inherited from Style.)
LoadFromXml | Loads the style content from an XML element. (Inherited from Style.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Style.)
RegisterProperty | Registers a new property with the specified name and type. (Inherited from Style.)
SaveTo | Serializes the style to the specified writer. (Inherited from Style.)
SaveToXml | Saves the style content into an XML element. (Inherited from Style.)
SetValue | Sets the value of the specified property. (Inherited from Style.)
UnsetValue | Clears the value of the specified property. (Inherited from Style.)

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

ContainerNodeStyle Class


MindFusion.Diagramming.ContainerNodeStyle Constructor

ContainerNodeStyle Constructor
[image]

Initializes a new instance of the ContainerNodeStyle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNodeStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ContainerNodeStyle Class


MindFusion.Diagramming.ContainerNodeStyle Events

ContainerNodeStyle Events
[image]

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

ContainerNodeStyle Class


MindFusion.Diagramming.ContainmentKeys Enumeration

ContainmentKeys Enumeration
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum ContainmentKeys

Visual Basic [image] Copy Code

Public Enum ContainmentKeys

Members

Member name | Description
InContainer | Set for Group.Attachment objects for nodes in a container.

See Also


MindFusion.Diagramming.ControlMouseAction Enumeration

ControlMouseAction Enumeration
[image]

Specifies available ways to handle mouse clicks on .NET controls hosted in a ControlNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum ControlMouseAction

Visual Basic [image] Copy Code

Public Enum ControlMouseAction

Members

Member name | Description
PassToControl | Let the control handle the mouse click. Do not select the host node.
SelectNode | The host node gets selected when the control is clicked. The control is left to handle the mouse click too.
IgnoreControl | MvcDiagram tries to intercept the mouse message and not pass it to the control. That allows drawing links from anywhere within the control.

Remarks

IgnoreControl works only with controls that do not capture the mouse.

See Also


MindFusion.Diagramming.ControlPointEventArgs Class

ControlPointEventArgs Class
[image]

Contains arguments passed to handlers of the ShapeModified event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ControlPointEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ControlPointEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.ControlPointEventArgs

See Also

ControlPointEventArgs Members


MindFusion.Diagramming.ControlPointEventArgs Members

ControlPointEventArgs Members
Constructors Properties
[image]

Contains arguments passed to handlers of the ShapeModified event.

The following tables list the members exposed by the ControlPointEventArgs type.

Public Constructors

Name | Description
ControlPointEventArgs | Initializes a new instance of the ControlPointEventArgs class.

Public Properties

Name | Description
ControlPoint | Gets or sets the ShapeControlPoint used to modify the node's shape.
NewValue | Gets or sets the new position of the control point.
Node | Gets or sets the ShapeNode whose Shape has been modified.
OldValue | Gets or sets the original position of the control point.

See Also

ControlPointEventArgs Class


MindFusion.Diagramming.ControlPointEventArgs Constructor

ControlPointEventArgs Constructor
[image]

Initializes a new instance of the ControlPointEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ControlPointEventArgs (
ShapeControlPoint controlPoint,
ShapeNode node,
ShapeFormulaParam oldValue,
ShapeFormulaParam newValue
)

Visual Basic [image] Copy Code

Public New ( _
controlPoint As ShapeControlPoint, _
node As ShapeNode, _
oldValue As ShapeFormulaParam, _
newValue As ShapeFormulaParam _
)

Parameters

controlPoint

The ShapeControlPoint used to modify the node's shape.

node

The ShapeNode whose Shape has been modified.

oldValue

A ShapeFormulaParam specifying the original position of the control point.

newValue

A ShapeFormulaParam specifying the new position of the control point.

See Also

ControlPointEventArgs Class


MindFusion.Diagramming.ControlPointEventArgs Properties

ControlPointEventArgs Properties
[image]

Public Properties

Name | Description
ControlPoint | Gets or sets the ShapeControlPoint used to modify the node's shape.
NewValue | Gets or sets the new position of the control point.
Node | Gets or sets the ShapeNode whose Shape has been modified.
OldValue | Gets or sets the original position of the control point.

See Also

ControlPointEventArgs Class


MindFusion.Diagramming.ControlPointEventArgs.ControlPoint Property

ControlPointEventArgs.ControlPoint Property
[image]

Gets or sets the ShapeControlPoint used to modify the node's shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeControlPoint ControlPoint { get; set; }

Visual Basic [image] Copy Code

Public Property ControlPoint As ShapeControlPoint

Property Value

An instance of the ShapeControlPoint class.

See Also

ControlPointEventArgs Members
ControlPointEventArgs Class


MindFusion.Diagramming.ControlPointEventArgs.NewValue Property

ControlPointEventArgs.NewValue Property
[image]

Gets or sets the new position of the control point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeFormulaParam NewValue { get; set; }

Visual Basic [image] Copy Code

Public Property NewValue As ShapeFormulaParam

Property Value

A ShapeFormulaParam instance specifying the new position of the shape control point.

See Also

ControlPointEventArgs Members
ControlPointEventArgs Class


MindFusion.Diagramming.ControlPointEventArgs.Node Property

ControlPointEventArgs.Node Property
[image]

Gets or sets the ShapeNode whose Shape has been modified.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode Node { get; set; }

Visual Basic [image] Copy Code

Public Property Node As ShapeNode

Property Value

An instance of the ShapeNode class.

See Also

ControlPointEventArgs Members
ControlPointEventArgs Class


MindFusion.Diagramming.ControlPointEventArgs.OldValue Property

ControlPointEventArgs.OldValue Property
[image]

Gets or sets the original position of the control point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeFormulaParam OldValue { get; set; }

Visual Basic [image] Copy Code

Public Property OldValue As ShapeFormulaParam

Property Value

A ShapeFormulaParam instance specifying the original position of the shape control point.

See Also

ControlPointEventArgs Members
ControlPointEventArgs Class


MindFusion.Diagramming.Converter Class

Converter Class
[image]

Provides capabilities to convert various types to and from strings in a culture-independent way.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class Converter

Visual Basic [image] Copy Code

Public NotInheritable Class Converter

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Converter

See Also

Converter Members


MindFusion.Diagramming.Converter Members

Converter Members
Methods
[image]

Provides capabilities to convert various types to and from strings in a culture-independent way.

The following tables list the members exposed by the Converter type.

Public Methods

Name | Description
FromBoolean | Converts the specified bool value to string.
FromByte | Converts the specified byte value to string.
FromChar | Converts the specified char value to string.
FromColor | Converts the specified color value to string in the format #AARRGGBB.
FromDecimal | Converts the specified decimal to string.
FromDouble | Converts the specified double value to string.
FromEnum | Converts the specified enum value to a string.
FromImage | Converts the specified image to string.
FromImageV4 | Converts the specified image to string.
FromInt16 | Converts the specified 16-bit integer value to string.
FromInt32 | Converts the specified 32-bit integer value to string.
FromInt64 | Converts the specified 64-bit integer to string.
FromSByte | Converts the specified 8-bit signed integer to string.
FromSingle | Converts the specified float value to string.
FromStream | Converts the specified stream to string.
FromStreamV4 | Converts the specified memory stream to string.
FromUInt16 | Converts the specified unsigned 16-bit integer value to string.
FromUInt32 | Converts the specified unsigned 32-bit integer value to string.
FromUInt64 | Converts the specified unsigned 64-bit integer value to string.
ImageFromString | Converts the specified string value to image.
ToBoolean | Converts the specified string value to bool.
ToByte | Converts the specified string value to byte value.
ToChar | Converts the specified string value to char.
ToColor | Converts the specified string value to Color.
ToDecimal | Converts the specified string value to decimal.
ToDouble | Converts the specified string value to double.
ToEnum | Converts the specified string value to its corresponding enumeration member of the specified type.
ToImage | Converts the specified string value to image.
ToImageV4 | Converts the specified string value to image.
ToInt16 | Converts the specified string value to 16-bit integer.
ToInt32 | Overloaded. Converts a string value to 32-bit integer.
ToInt64 | Converts the specified string value to 64-bit integer.
ToSByte | Converts the specified string value to 8-bit signed integer.
ToSingle | Converts the specified string value to float.
ToStream | Converts the specified string value to stream.
ToStreamV4 | Converts the specified string value to stream.
ToUint16 | Converts the specified string value to unsigned 16-bit integer.
ToUint32 | Converts the specified string value to unsigned 32-bit integer.
ToUint64 | Converts the specified string value to unsigned 64-bit integer.

See Also

Converter Class


MindFusion.Diagramming.Converter Methods

Converter Methods
[image]

Public Methods

Name | Description
FromBoolean | Converts the specified bool value to string.
FromByte | Converts the specified byte value to string.
FromChar | Converts the specified char value to string.
FromColor | Converts the specified color value to string in the format #AARRGGBB.
FromDecimal | Converts the specified decimal to string.
FromDouble | Converts the specified double value to string.
FromEnum | Converts the specified enum value to a string.
FromImage | Converts the specified image to string.
FromImageV4 | Converts the specified image to string.
FromInt16 | Converts the specified 16-bit integer value to string.
FromInt32 | Converts the specified 32-bit integer value to string.
FromInt64 | Converts the specified 64-bit integer to string.
FromSByte | Converts the specified 8-bit signed integer to string.
FromSingle | Converts the specified float value to string.
FromStream | Converts the specified stream to string.
FromStreamV4 | Converts the specified memory stream to string.
FromUInt16 | Converts the specified unsigned 16-bit integer value to string.
FromUInt32 | Converts the specified unsigned 32-bit integer value to string.
FromUInt64 | Converts the specified unsigned 64-bit integer value to string.
ImageFromString | Converts the specified string value to image.
ToBoolean | Converts the specified string value to bool.
ToByte | Converts the specified string value to byte value.
ToChar | Converts the specified string value to char.
ToColor | Converts the specified string value to Color.
ToDecimal | Converts the specified string value to decimal.
ToDouble | Converts the specified string value to double.
ToEnum | Converts the specified string value to its corresponding enumeration member of the specified type.
ToImage | Converts the specified string value to image.
ToImageV4 | Converts the specified string value to image.
ToInt16 | Converts the specified string value to 16-bit integer.
ToInt32 | Overloaded. Converts a string value to 32-bit integer.
ToInt64 | Converts the specified string value to 64-bit integer.
ToSByte | Converts the specified string value to 8-bit signed integer.
ToSingle | Converts the specified string value to float.
ToStream | Converts the specified string value to stream.
ToStreamV4 | Converts the specified string value to stream.
ToUint16 | Converts the specified string value to unsigned 16-bit integer.
ToUint32 | Converts the specified string value to unsigned 32-bit integer.
ToUint64 | Converts the specified string value to unsigned 64-bit integer.

See Also

Converter Class


MindFusion.Diagramming.Converter.FromBoolean Method

Converter.FromBoolean Method
[image]

Converts the specified bool value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromBoolean (
bool val
)

Visual Basic [image] Copy Code

Public Shared Function FromBoolean( _
val As Boolean _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromByte Method

Converter.FromByte Method
[image]

Converts the specified byte value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromByte (
byte val
)

Visual Basic [image] Copy Code

Public Shared Function FromByte( _
val As Byte _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromChar Method

Converter.FromChar Method
[image]

Converts the specified char value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromChar (
char val
)

Visual Basic [image] Copy Code

Public Shared Function FromChar( _
val As Char _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromColor Method

Converter.FromColor Method
[image]

Converts the specified color value to string in the format #AARRGGBB.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromColor (
Color val
)

Visual Basic [image] Copy Code

Public Shared Function FromColor( _
val As Color _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromDecimal Method

Converter.FromDecimal Method
[image]

Converts the specified decimal to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromDecimal (
decimal val
)

Visual Basic [image] Copy Code

Public Shared Function FromDecimal( _
val As Decimal _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromDouble Method

Converter.FromDouble Method
[image]

Converts the specified double value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromDouble (
double val
)

Visual Basic [image] Copy Code

Public Shared Function FromDouble( _
val As Double _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromEnum Method

Converter.FromEnum Method
[image]

Converts the specified enum value to a string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromEnum (
Object val
)

Visual Basic [image] Copy Code

Public Shared Function FromEnum( _
val As Object _
) As String

Parameters

val
The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromImage Method

Converter.FromImage Method
[image]

Converts the specified image to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromImage (
Image val
)

Visual Basic [image] Copy Code

Public Shared Function FromImage( _
val As Image _
) As String

Parameters

val

The Image object to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromImageV4 Method

Converter.FromImageV4 Method
[image]

Converts the specified image to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromImageV4 (
Image val
)

Visual Basic [image] Copy Code

Public Shared Function FromImageV4( _
val As Image _
) As String

Parameters

val

The Image object to convert.

Return Value

A string representing the specified value.

Remarks

This method is used in XML file format 4 and earlier.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromInt16 Method

Converter.FromInt16 Method
[image]

Converts the specified 16-bit integer value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromInt16 (
short val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt16( _
val As Short _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromInt32 Method

Converter.FromInt32 Method
[image]

Converts the specified 32-bit integer value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromInt32 (
int val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt32( _
val As Integer _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromInt64 Method

Converter.FromInt64 Method
[image]

Converts the specified 64-bit integer to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromInt64 (
long val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt64( _
val As Long _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromSByte Method

Converter.FromSByte Method
[image]

Converts the specified 8-bit signed integer to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromSByte (
sbyte val
)

Visual Basic [image] Copy Code

Public Shared Function FromSByte( _
val As SByte _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromSingle Method

Converter.FromSingle Method
[image]

Converts the specified float value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromSingle (
float val
)

Visual Basic [image] Copy Code

Public Shared Function FromSingle( _
val As Single _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromStream Method

Converter.FromStream Method
[image]

Converts the specified stream to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromStream (
Stream val
)

Visual Basic [image] Copy Code

Public Shared Function FromStream( _
val As Stream _
) As String

Parameters

val
The Stream object to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromStreamV4 Method

Converter.FromStreamV4 Method
[image]

Converts the specified memory stream to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromStreamV4 (
MemoryStream val
)

Visual Basic [image] Copy Code

Public Shared Function FromStreamV4( _
val As MemoryStream _
) As String

Parameters

val

The Stream object to convert.

Return Value

A string representing the specified value.

Remarks

This method is used in XML file format 4 and earlier.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromUInt16 Method

Converter.FromUInt16 Method
[image]

Converts the specified unsigned 16-bit integer value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromUInt16 (
ushort val
)

Visual Basic [image] Copy Code

Public Shared Function FromUInt16( _
val As UShort _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromUInt32 Method

Converter.FromUInt32 Method
[image]

Converts the specified unsigned 32-bit integer value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromUInt32 (
uint val
)

Visual Basic [image] Copy Code

Public Shared Function FromUInt32( _
val As UInteger _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromUInt64 Method

Converter.FromUInt64 Method
[image]

Converts the specified unsigned 64-bit integer value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromUInt64 (
ulong val
)

Visual Basic [image] Copy Code

Public Shared Function FromUInt64( _
val As ULong _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ImageFromString Method

Converter.ImageFromString Method
[image]

Converts the specified string value to image.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Image ImageFromString (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ImageFromString( _
s As String _
) As Image

Parameters

s

The string value to convert from.

Return Value

An instance of the .NET Image class that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToBoolean Method

Converter.ToBoolean Method
[image]

Converts the specified string value to bool.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static bool ToBoolean (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToBoolean( _
s As String _
) As Boolean

Parameters

s

The string value to convert from.

Return Value

A boolean value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToByte Method

Converter.ToByte Method
[image]

Converts the specified string value to byte value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static byte ToByte (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToByte( _
s As String _
) As Byte

Parameters

s

The string value to convert from.

Return Value

A byte value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToChar Method

Converter.ToChar Method
[image]

Converts the specified string value to char.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static char ToChar (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToChar( _
s As String _
) As Char

Parameters

s

The string value to convert from.

Return Value

A char value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToColor Method

Converter.ToColor Method
[image]

Converts the specified string value to Color.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Color ToColor (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToColor( _
s As String _
) As Color

Parameters

s

The string value to convert from.

Return Value

A Color value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToDecimal Method

Converter.ToDecimal Method
[image]

Converts the specified string value to decimal.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static decimal ToDecimal (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToDecimal( _
s As String _
) As Decimal

Parameters

s

The string value to convert from.

Return Value

A decimal value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToDouble Method

Converter.ToDouble Method
[image]

Converts the specified string value to double.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double ToDouble (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToDouble( _
s As String _
) As Double

Parameters

s

The string value to convert from.

Return Value

A double value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToEnum Method

Converter.ToEnum Method
[image]

Converts the specified string value to its corresponding enumeration member of the specified type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Object ToEnum (
Type type,
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToEnum( _
type As Type, _
s As String _
) As Object

Parameters

type

The type of the enumeration to convert to.

s

The string value to convert from.

Return Value

A member of the specified enumeration that is deserialized from the specified string, possibly a null reference (Nothing in Visual Basic) if the deserialization failed.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToImage Method

Converter.ToImage Method
[image]

Converts the specified string value to image.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Image ToImage (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToImage( _
s As String _
) As Image

Parameters

s

The string value to convert from.

Return Value

A .NET Image object that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToImageV4 Method

Converter.ToImageV4 Method
[image]

Converts the specified string value to image.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Image ToImageV4 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToImageV4( _
s As String _
) As Image

Parameters

s

The string value to convert from.

Return Value

A .NET Image object that is deserialized from the specified string.

Remarks

This method is used in XML file format 4 and earlier.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToInt16 Method

Converter.ToInt16 Method
[image]

Converts the specified string value to 16-bit integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static short ToInt16 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt16( _
s As String _
) As Short

Parameters

s

The string value to convert from.

Return Value

A 16-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToInt32 Method

Converter.ToInt32 Method
[image]

Converts a string value to 32-bit integer.

Overload List

Name | Description
Converter.ToInt32 (String) | Converts the specified string value to 32-bit integer.
Converter.ToInt32 (String, Int32) | Converts the specified string value to 32-bit integer without throwing exceptions. In case the specified string cannot be converted, the specified default value is returned.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToInt32 Method (String)

Converter.ToInt32 Method (String)
See Also
[image]

Converts the specified string value to 32-bit integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static int ToInt32 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt32( _
s As String _
) As Integer

Parameters

s

The string value to convert from.

Return Value

A 32-bit integer value that is deserialized from the specified string.

See Also

ToInt32 Method Overload List
Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToInt32 Method (String, Int32)

Converter.ToInt32 Method (String, Int32)
See Also
[image]

Converts the specified string value to 32-bit integer without throwing exceptions. In case the specified string cannot be converted, the specified default value is returned.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static int ToInt32 (
string s,
int defaultValue
)

Visual Basic [image] Copy Code

Public Shared Function ToInt32( _
s As String, _
defaultValue As Integer _
) As Integer

Parameters

s

The string value to convert from.

defaultValue

The default value to return if s cannot be deserialized.

Return Value

A 32-bit integer value that is deserialized from the specified string.

See Also

ToInt32 Method Overload List
Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToInt64 Method

Converter.ToInt64 Method
[image]

Converts the specified string value to 64-bit integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static long ToInt64 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt64( _
s As String _
) As Long

Parameters

s

The string value to convert from.

Return Value

A 64-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToSByte Method

Converter.ToSByte Method
[image]

Converts the specified string value to 8-bit signed integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static sbyte ToSByte (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToSByte( _
s As String _
) As SByte

Parameters

s

The string value to convert from.

Return Value

An 8-bit signed integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToSingle Method

Converter.ToSingle Method
[image]

Converts the specified string value to float.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float ToSingle (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToSingle( _
s As String _
) As Single

Parameters

s

The string value to convert from.

Return Value

A float value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToStream Method

Converter.ToStream Method
[image]

Converts the specified string value to stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Stream ToStream (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToStream( _
s As String _
) As Stream

Parameters

s

The string value to convert from.

Return Value

A .NET Stream object that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToStreamV4 Method

Converter.ToStreamV4 Method
[image]

Converts the specified string value to stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Stream ToStreamV4 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToStreamV4( _
s As String _
) As Stream

Parameters

s

The string value to convert from.

Return Value

A .NET Stream object that is deserialized from the specified string.

Remarks

This method is used in XML file format 4 and earlier.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToUint16 Method

Converter.ToUint16 Method
[image]

Converts the specified string value to unsigned 16-bit integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static ushort ToUint16 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToUint16( _
s As String _
) As UShort

Parameters

s

The string value to convert from.

Return Value

An unsigned 16-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToUint32 Method

Converter.ToUint32 Method
[image]

Converts the specified string value to unsigned 32-bit integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static uint ToUint32 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToUint32( _
s As String _
) As UInteger

Parameters

s

The string value to convert from.

Return Value

An unsigned 32-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToUint64 Method

Converter.ToUint64 Method
[image]

Converts the specified string value to unsigned 64-bit integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static ulong ToUint64 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToUint64( _
s As String _
) As ULong

Parameters

s

The string value to convert from.

Return Value

An unsigned 64-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.CreatePathDelegate Delegate

CreatePathDelegate Delegate
[image]

Specifies the signature of callback functions used to generate dynamic node shapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate GraphicsPath CreatePathDelegate (
RectangleF nodeBounds
)

Visual Basic [image] Copy Code

Public Delegate Function CreatePathDelegate( _
nodeBounds As RectangleF _
) As GraphicsPath

Parameters

nodeBounds

A RectangleF object.

Return Value

A GraphicsPath specifying the shape outline or decorations.

See Also


MindFusion.Diagramming.CursorHint Enumeration

CursorHint Enumeration
[image]

Specifies what mouse cursor to display while a user interacts with the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum CursorHint

Visual Basic [image] Copy Code

Public Enum CursorHint

Members

Member name | Description
Move | Indicates the cursor specified by the MoveCursor property.
Rotate | Indicates the cursor specified by the RotateCursor property.
HorizontalResize | Indicates the cursor specified by the HorizontalResizeCursor property.
VerticalResize | Indicates the cursor specified by the VerticalResizeCursor property.
DiagonalResize | Indicates the cursor specified by the DiagonalResizeCursor property.
CounterDiagonalResize | Indicates the cursor specified by the CounterDiagonalResizeCursor property.
DrawLink | Indicates the cursor specified by the DrawLinkCursor property.
Pointer | Indicates the cursor specified by the PointerCursor property.
AllowLink | Indicates the cursor specified by the AllowLinkCursor property.
DisallowLink | Indicates the cursor specified by the DisallowLinkCursor property.
Disallow | Indicates the cursor specified by the DisallowCursor property.
DontChange | Indicates the cursor specified by the Cursor property.
EditText | Indicates the cursor specified by the EditTextCursor property.

See Also


MindFusion.Diagramming.CustomDraw Enumeration

CustomDraw Enumeration
[image]

Specifies what kind of custom painting to perform on diagram elements.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum CustomDraw

Visual Basic [image] Copy Code

Public Enum CustomDraw

Members

Member name | Description
None | Do not perform custom drawing, let all painting be done by MvcDiagram.
Additional | The custom painting code executes after item's interior and frame are painted by MvcDiagram, but before text is rendered. In this mode, the Graphics instance passed to the custom drawing event handler has a clipping region applied to it.
Full | The component does not do any standard drawing, the entire painting of an item is done by the application.
ShadowOnly | Only the shadow of an item is painted by custom code, the item itself is drawn by the component.
Additional2 | The custom painting code executes after all parts of an item are painted by MvcDiagram. In this mode, the Graphics instance passed to the custom drawing event handler doesn't have a clipping region applied to it.

Remarks

These values can be assigned to the CustomDraw property of shapes, tables and links.

See Also


MindFusion.Diagramming.DelKeyAction Enumeration

DelKeyAction Enumeration
[image]

Specifies the type of action performed when the user presses the DEL key.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum DelKeyAction

Visual Basic [image] Copy Code

Public Enum DelKeyAction

Members

Member name | Description
None | Indicates that nothing happens.
DeleteActiveItem | Indicates that only the ActiveItem is deleted.
DeleteSelectedItems | Indicates that all selected items are deleted.

See Also


MindFusion.Diagramming.Diagram Class

Diagram Class
Remarks See Also
[image]

Represents a flow diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Diagram : DiagramBase, IItemFactory, IPersists

Visual Basic [image] Copy Code

Public Class Diagram
Inherits DiagramBase
Implements IItemFactory, IPersists

Remarks

An instance of the Diagram class represents a diagram document. A Diagram instance does not provide its own user interface. To display a diagram on a form, add a DiagramView instance to the form and set the view's Diagram property. A diagram can be displayed in more than one view.

A diagram can contain connected nodes and links. Nodes are instances of DiagramNode-derived classes. Nodes are stored in the Nodes collection. Links in MvcDiagram are instances of the DiagramLink class and are stored in the Links collection. Diagram items can be grouped in hierarchical structures and the so formed groups can be accessed by means of the Groups collection.

Managing Items

Items can be created by using the new operator and added to the diagram by means of the Add method of the Nodes or Links collection. Items are deleted by using the Remove method of the respective collection. There are shortcut methods provided by the diagram's Factory object that can be used to create an item and add it to the diagram with just one method call. Use the CreateTableNode, CreateShapeNode and CreateDiagramLink factory methods to create new items of the respective type.

Hierarchical groups of items are created by adding a Group instance to the diagram's Groups collection. The Factory object provides a shortcut CreateGroup method to do that with a single method call. Use the Remove method of the Groups collection to destroy a group.

Searching for a particular kind of items is done with the FindLink, FindNode and FindGroup methods, which look for an item that has a particular Tag, or FindLinkById and FindNodeById to find items by their Id. To get the item placed at a certain location, use the GetItemAt method.

Serialization

Binary serialization of diagrams is provided by the SaveToStream and LoadFromStream methods which serialize diagrams to / from .NET streams. SaveToFile and LoadFromFile wrap their stream counterparts to implement easy serialization to disk files. SaveToString and LoadFromString store or load diagrams to/from ASCII strings, allowing easy storage of whole diagrams in a database or their transfer between a web-server and a browser through a hidden html element.

Use the SaveToXml and LoadFromXml methods to serialize a diagram into/from XML documents.

Controlling Users' Actions

Most aspects of user interaction are controlled by the DiagramView class.

Users actions can be validated by handling various events, fired while items are being created, modified or deleted.

The following properties control what kind of links users can create: AllowLinksRepeat, AllowSelfLoops, AllowUnanchoredLinks, AllowUnconnectedLinks.

The order in which items are hit-tested when clicking on them depends on the value of HitTestPriority. The LinkHitDistance property specifies the furthest distance from a link that a click would be still considered a hit.

Alignment

Items are aligned to a grid when AlignToGrid is enabled. To display the grid, set ShowGrid to true. The grid size and appearance can be customized via the GridSizeX, GridSizeY, GridColor and GridStyle properties.

If AutoAlignNodes is enabled, nodes are aligned to other nodes so that a pair of their vertical or horizontal sides become collinear. To specify the maximal distance at which nodes are aligned, set the AutoAlignDistance property. The pair of aligned nodes is indicated visually by drawing an alignment guide using the pen assigned to AlignmentGuidePen.

Links can also automatically snap to nodes when AutoSnapLinks is set. The maximal distance at which links will connect to a nearby node is set via AutoSnapDistance.

Appearance

The Diagram background area can be painted using a solid, gradient, texture or color brush, by setting the BackBrush property, and/or using an image specified by BackgroundImage and BackgroundImageAlign. Some more elaborate visual effects can be applied by means of the EffectsProvider, EnableEmbossEffects and EnableShadowEffects properties.

To further customize the diagram appearance, handle the DrawBackground event to render custom background graphics, or the DrawForeground event to render custom foreground graphics.

Lanes

The lane grid lets you emphasize the relationship between a group of diagram items by displaying them in a distinct lane or cell within the grid. Use the EnableLanes property to display a background grid of lanes, optionally divided into cells. The grid can be set up using the LaneGrid property.

Text Formatting

Use TextFormat and TextColor to specify alignment and color of the text for all diagram items. EnableStyledText allows using HTML-like tags to format item's text. PolygonalTextLayout allows laying text out inside non-rectangular node shapes.

Tweaks

  • While moving grouped items, they are drawn in depth conforming to either their z-order or their group hierarchy, as set in SortGroupsByZ.
  • SelectionOnTop specifies whether selected items should be painted on top of other items.
  • MergeThreshold specifies how closely one to another adjacent link points should be placed in order to merge link segments.

Default Item Properties

Many properties of the Diagram class provide initial values for the properties of new items.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.DiagramBase
MindFusion.Diagramming.Diagram
MindFusion.Diagramming.DiagramPage

See Also

Diagram Members


MindFusion.Diagramming.Diagram Members

Diagram Members
Constructors Fields Properties Methods Events
[image]

Represents a flow diagram.

The following tables list the members exposed by the Diagram type.

Public Constructors

Name | Description
Diagram | The Diagram class represents a flow diagram.

Public Fields

Name | Description
Dummy | A shared DummyNode instance.

Public Properties

Name | Description
ActiveItem | Gets or sets the active diagram element.
ActiveItemHandlesStyle | Gets the visual style of adjustment handles of the active item.
ActiveLayer | Gets or sets the zero-based index of the active layer.
AdjustmentHandlesSize | Gets or sets the size of the handles, which appear around selected objects.
AlignmentGuidePen | Gets or sets the pen used to draw alignment guides.
AlignToGrid | Gets or sets a value indicating whether the diagram items is aligned to a grid.
AllowLinksRepeat | Gets or sets a value indicating whether more than one link can connect the same origin and destination diagram nodes.
AllowMultipleResize | Gets or sets whether multiple selected nodes can be resized simultaneously.
AllowSelfLoops | Gets or sets a value indicating whether self-loops are allowed.
AllowSplitLinks | Gets or sets a value indicating whether link segments can be added and removed interactively.
AllowUnanchoredLinks | Gets or sets a value indicating whether links can be connected to nodes to which there aren't anchor points assigned.
AllowUnconnectedLinks | Gets or sets a value indicating whether users are allowed to draw links that are not connected to any node.
AutoAlignDistance | Gets or sets the maximal horizontal or vertical distance at which a node aligns to the borders of other nodes.
AutoAlignNodes | Gets or sets whether nodes should automatically align to the borders of other nodes during user interaction.
AutoHighlightRows | Gets or sets whether a table row should be highlighted when the user clicks on it.
AutoResize | Gets or sets a value indicating whether the document area must be resized automatically so it fits the diagram contents.
AutoSnapDistance | Specifies the maximum distance at which links auto-snap to nodes.
AutoSnapLinks | Gets or sets the default value for the AutoSnapToNode property of new links.
BackBrush | Gets or sets the brush used for painting the diagram background.
BackgroundImage | Gets or sets the image displayed as background of this diagram.
BackgroundImageAlign | Gets or sets a value indicating how the background image is positioned, relatively to the scrollable document area.
BackgroundImageUrl | URL of the image painted as diagram's background.
BarcodeNodeStyle | Gets the theme-level style for barcode nodes.
Bounds | Gets or sets a value representing the size of the diagram's scrollable area.
BoundsPen | The pen with which the document bounds should be drawn.
CellCustomDraw | Gets or sets the default type of custom painting done on the cells of tables.
CellFrameStyle | Gets or sets the default cell border style of new tables.
CompositeNodeStyle | Gets the theme-level style for composite nodes.
ContainerCaption | Gets or sets the default value for the Caption property of containers.
ContainerCaptionHeight | Gets or sets the default value for the CaptionHeight property of containers.
ContainerHighlightPen | Gets or sets the default value for the HighlightPen property of containers.
ContainerMargin | Gets or sets the default value for the Margin property of containers.
ContainerMinimumSize | Gets or sets the default value for the MinimumSize property of containers.
ContainerNodeStyle | Gets the theme-level style for container nodes.
ContainersFoldable | Gets or sets the default value for the Foldable property of containers.
CrossingRadius | Gets or sets the radius length of decorations displayed at link intersection points.
DefaultShape | Gets or sets the default shape of shape nodes.
DiagramLinkStyle | Gets the theme-level style for diagram links.
DiagramStyle | Gets the theme-level style for the diagram.
Dirty | Gets or sets a value indicating whether the diagram has changed since the last save.
DisabledHandlesStyle | Gets the visual style of disabled adjustment handles.
DynamicLinks | Gets or sets the default value for the Dynamic property of new links.
EffectiveBackBrush | Gets the currently effective background brush of the diagram.
EffectsProvider | Gets or sets an object used to generate visual effects for shape nodes such as embossment and shadow dispersion.
EnableEmbossEffects | Gets or sets a value indicating whether emboss effect for shape nodes is enabled.
EnableLanes | Gets or sets whether lanes are enabled.
EnableShadowEffects | Gets or sets a value indicating whether the shadow dispersion effect for nodes is enabled.
EnableStyledText | Gets or sets the default value for the EnableStyledText property of new nodes.
ExpandButtonAction | Gets or sets a value indicating what should happen when a user clicks the [±] button that is displayed near expandable nodes.
ExpandButtonPosition | Gets or sets where expand/collapse buttons are located relatively to their nodes.
ExpandOnIncoming | Gets or sets a value, indicating in which direction object hierarchies are expanded.
ExteriorBrush | Gets or sets the brush used for painting the area outside Bounds.
Factory | Gets a Factory instance that lets you add programmatically new items to the diagram.
FocusedComponent | Gets or sets the component within this diagram which currently has the input focus.
FoldedContainerSize | Gets or sets the size of folded containers.
Font | Gets or sets the default font for new diagram items.
GridColor | Gets or sets the color of the grid points.
GridOffsetX | Gets or sets the horizontal offset of the first point of the alignment grid.
GridOffsetY | Gets or sets the vertical offset of the first point of the alignment grid.
GridSizeX | Gets or sets the horizontal distance between adjacent grid points.
GridSizeY | Gets or sets the vertical distance between adjacent grid points.
GridStyle | Gets or sets the visual style of the alignment grid.
Groups | Gets a collection of all groups in the diagram.
HitTestPriority | Gets or sets a value indicating the order in which items are hit-tested.
Interaction | Gets an InteractionState instance representing the current action being carried out by the user.
IsProEdition | Gets a value indicating whether the currently loaded MvcDiagram is a professional version of the control.
Items | Gets a collection of all items in this diagram.
LaneGrid | Gets the Grid instance that represents the lane grid.
Layers | Gets a list of the layers in the current diagram.
LinkBaseShape | Gets or sets the shape displayed at the base of new links.
LinkBaseShapeSize | Gets or sets the default size of the base of new links.
LinkBrush | Gets or sets the default value for the Brush property of links.
LinkCascadeOrientation | Gets or sets the initial orientation of the first segment of new cascading links.
LinkCrossings | Gets or sets how to render the intersection points where links cross their paths.
LinkCustomDraw | Gets or sets the default type of custom painting done on links.
LinkEndsMovable | Gets or sets a value indicating whether link ends can be moved by users after the link is created.
LinkHandlesStyle | Gets or sets the default value for the HandlesStyle property of new links.
LinkHeadShape | Gets or sets the shape displayed as head of new links.
LinkHeadShapeSize | Gets or sets the default size of arrowheads.
LinkHitDistance | Gets or sets a value specifying how far from a link a click is still considered a hit.
LinkIntermediateShape | Gets or sets the default shape to be displayed in the middle of each segment of links.
LinkIntermediateShapeSize | Gets or sets the default size of the shapes at middles of link segments.
LinkPen | Gets or sets the default value for the Pen and HeadPen properties of links.
LinkRouter | Gets or sets the component used to find paths for auto-routed links when diagram nodes are added or their positions change.
Links | Gets a collection of all DiagramLink objects in the diagram.
LinkSegments | Gets or sets the default number of link segments.
LinkShape | Gets or sets the default value of the Shape property of new links.
LinksRetainForm | Gets or sets whether links should maintain their forms if the nodes linked with those links are moved around.
LinkText | Gets or sets the default text of links.
LinkTextStyle | Gets or sets default placement and orientation for links' text.
MeasureTextRenderingHint | Gets or sets the TextRenderingHint to use when measuring texts. This should be effectively set to the value of DiagramView.TextRenderingHint.
MeasureUnit | Gets or sets the unit of measure used for logical coordinates in this diagram.
MergeThreshold | Gets or sets the maximum distance between adjacent control points of a link at which the respective segments can be merged.
MinimumNodeSize | Gets or sets the minimum node size that the user is allowed to set.
NodeEffects | Gets a collection with all effects applied to the nodes of this diagram.
Nodes | Gets a collection of all DiagramNode objects in the diagram.
NodesExpandable | Gets or sets a value indicating whether newly created nodes can be expanded.
NowLoading | Gets a value indicating whether the diagram data is now being loaded from a file.
PolygonalTextLayout | Gets or sets a value indicating whether to enable the formatting of text inside non-rectangular shape node outlines.
RecursiveExpand | Gets or sets value indicating how a tree is expanded.
RestrictItemsToBounds | Gets or sets a value indicating whether users are allowed to place items outside the scrollable area of the diagram.
RoundedLinks | Gets or sets a value indicating whether the joins between segments of Polyline and Cascading links should be rounded.
RoundedLinksRadius | Gets or sets the radius of arc joins of rounded links' segments.
RoundRectFactor | Gets or sets the relative size of arcs displayed at the corners of rounded rectangles.
RouteLinks | Gets or sets a value indicating whether links should avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes.
RoutingOptions | Gets an object, which allows customizing various parameters of the link routing algorithm.
RowHighlightBrush | Gets or sets the Brush used to fill highlighted table rows.
ScriptHelper | Gets a ScriptHelper object which can be used in html scripts to instantiate various objects and to call static methods.
SelectAfterCreate | Gets or sets a value indicating whether newly created objects are automatically selected.
SelectedItemHandlesStyle | Gets the visual style of adjustment handles of selected items.
Selection | Gets a Selection instance that represents the selection of items in this diagram.
SelectionOnTop | Gets or sets a value indicating whether selected items should be painted on top of other items.
SerializationBinder | Gets or sets a SerializationBinder object used to control class loading.
ShadowBrush | Gets or sets the default brush used to paint the shadows cast by diagram items.
ShadowOffsetX | Gets or sets the horizontal offset of item shadows.
ShadowOffsetY | Gets or sets the vertical offset of item shadows.
ShadowsStyle | Gets or sets the style for rendering shadows.
ShapeBrush | Gets or sets the default value for the Brush property of shape nodes.
ShapeCustomDraw | Gets or sets the default type of custom painting done for shape nodes.
ShapeHandlesStyle | Gets or sets the default value for the HandlesStyle property of new shape nodes.
ShapeNodeStyle | Gets the theme-level style for shape nodes.
ShapeOrientation | Gets or sets the default value for the ShapeOrientation property of shape nodes.
ShapePen | Gets or sets the default value for the Pen property of shape nodes.
ShapeText | Gets or sets the default text of shape nodes.
ShowAnchors | Gets or sets a value indicating whether and when node anchor points should be displayed.
ShowDisabledHandles | Gets or sets a value indicating whether manipulation handles are painted when they are disabled.
ShowGrid | Gets or sets a value indicating whether the alignment grid is visible.
ShowHandlesOnDrag | Gets or sets a value indicating whether to display selection handles of objects under the mouse while another object is being modified.
SnapToAnchor | Gets or sets when link end points should be aligned to the nearest anchor points.
SortGroupsByZ | Gets or sets a value indicating whether grouped items should be drawn sorted by their z-order while the whole group is being moved.
Style | Gets or sets the style associated with the diagram.
SvgNodeStyle | Gets the theme-level style for SVG nodes.
TableBrush | Gets or sets the default value for the Brush property of tables.
TableCaption | Gets or sets the default text for tables' captions.
TableCaptionHeight | Gets or sets the default height of table captions.
TableColumnCount | Gets or sets the default number of table columns.
TableColumnWidth | Gets or sets the default width of tables' columns.
TableConnectionStyle | Gets or sets a value indicating whether drawing a link between tables should connect the rows of those tables, or the tables as whole entities.
TableCustomDraw | Gets or sets the default type of custom painting done on tables.
TableHandlesStyle | Gets or sets the default value for the HandlesStyle property of new tables.
TableNodeStyle | Gets the theme-level style for table nodes.
TablePen | Gets or sets the default value for the Pen property of tables.
TableRowCount | Gets or sets the default number of table rows.
TableRowHeight | Gets or sets the default height of tables' rows.
TableShape | Gets or sets the default value of the Shape property of new tables.
TablesScrollable | Gets or sets the default value for the Scrollable property of new tables.
Tag | Gets or sets custom data associated with this diagram.
TextColor | Gets or sets the default color of text displayed inside diagram items.
TextFormat | Gets or sets the default alignment and formatting style for text displayed inside nodes and table cells.
Theme | Gets or sets the theme associated with the diagram.
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram.
TreeViewNodeStyle | Gets the theme-level style for tree view nodes.
UndoManager | Gets a reference to the diagram's UndoManager instance.
ValidityChecks | Gets or sets a value indicating whether validity checks are performed each time an item is added to the diagram.
VisioNodeStyle | Gets the theme-level style for Visio nodes.

Public Methods

Name | Description
AlignPointToGrid | Returns a point of the alignment grid nearest to the one passed as an argument.
ArrangeLinkLabels | Rearranges link labels whose AutoArrange property is enabled.
ChangeUnit | Sets new MeasureUnit value and scales the coordinates of diagram items so that their absolute size remains unchanged.
ClearAll | Removes all items from the diagram.
CopySelection | Creates a copy of the currently selected objects and groups.
CreateImage | Overloaded. Creates a bitmap containing an image of the diagram.
CreateMeasureGraphics | Creates an IGraphics object that can be used to obtain various string size measurements.
CreateThemeFromDefaults | Creates a Theme object representing the default properties of the diagram.
Draw | Renders the diagram on the specified IGraphics object.
DrawAlignmentGuides | Draws the current alignment guides.
DrawInteraction | Draws the items that the user is currently modifying.
DrawLayer | Renders all diagram items to the specified graphics.
DrawStyledText | Draws a formatted text string, the same way text is drawn in shape nodes whose EnableStyledText property is set to true. This method lets you display styled text in custom-drawn nodes or links.
ExecuteCommand | Executes the specified command on this diagram.
FindGroup | Finds the group that has the specified tag value.
FindLink | Finds the link that has the specified tag value.
FindLinkById | Finds the link that has the specified id value.
FindNode | Finds the node that has the specified tag value.
FindNodeById | Finds the node that has the specified id value.
GetContentBounds | Returns the smallest rectangle that bounds all diagram objects.
GetItemAt | Finds and returns the top-most diagram item that lies at the specified location.
GetLinkAt | Overloaded. Finds and returns the link that lies at the specified location.
GetLinksAt | Returns the links that contain the specified point.
GetNearestNode | Returns the node nearest to the specified point.
GetNodeAt | Overloaded. Gets the node that lies at the specified location.
GetNodesAt | Returns the nodes that contain the specified point.
HandleKeyDown | Propagates keyboard input to interested manipulators and components.
HandleKeyPress | Propagates keyboard input to interested manipulators.
HandleKeyUp | Propagates keyboard input to interested components.
HandleMouseMove | Propagates mouse input to interested manipulators.
HitTestComponents | Tests whether the specified point is within a component of a diagram item and returns this component.
HitTestManipulators | Tests whether the specified point is within the manipulator of a diagram object and triggers the manipulator.
Invalidate | Overloaded. Invalidates the diagram or a region of the diagram, causing it to be repainted.
InvalidateZOrder | Forces a new sort of the Z order list before next redraw.
IsItemInteractive | Checks if the specified item can be modified interactively.
IsItemLocked | Checks if the specified item is locked.
IsItemVisible | Checks if the specified item is currently visible.
LoadFromFile | Loads the contents of an existing diagram file into the control.
LoadFromStream | Loads a diagram from the specified stream.
LoadFromString | Decodes diagram contents from a string that was created with SaveToString.
LoadFromXml | Overloaded. Loads the contents of an XML diagram document into the control.
MeasureString | Overloaded. Measures a text taking into consideration the current affine transform of the diagram.
Navigate | Selects the nearest item in the specified direction.
NewInstance | Custom Diagram classes must override this method to return an instance of their type.
PasteSelection | Adds the specified items and groups to the specified diagram document.
PixelToUnit | Converts the specified point from client to document coordinates ignoring the current scale transformation.
RaiseCellTextEdited | Raises the CellTextEdited event .
RaiseCellTextEditing | Raises the CellTextEditing event to validate entering in-place editing mode.
RaiseClicked | Overloaded. Raises the Clicked event of the diagram or one of the *Clicked events related to diagram items.
RaiseCreated | Raises the appropriate *Created event according to the type of the specified item.
RaiseDeleting | Raises the appropriate *Deleting event according to the type of the specified item.
RaiseDoubleClicked | Overloaded. Raises the DoubleClicked event of the diagram or one of the *DoubleClicked events related to diagram items.
RaiseLinkTextEdited | Raises the LinkTextEdited event.
RaiseLinkTextEditing | Raises the LinkTextEditing event to validate entering in-place editing mode.
RaiseMouseHover | Raises the appropriate Pointed event.
RaiseNodeTextEdited | Raises the NodeTextEdited event.
RaiseNodeTextEditing | Raises the NodeTextEditing event to validate entering in-place editing mode.
RaisePasted | Raises the appropriate Pasted event.
RaiseSelecting | Raises the appropriate Selecting event.
RaiseTreeItemTextEditing | Raises the TreeItemTextEditing event to validate entering inplace edit mode.
RaiseViewRemoved | Raises the ViewRemoved event.
RegisterClass | Registers a diagram item or lane header class for serialization support.
RegisterDefaultStyle | Registers a default style for the objects of the specified type.
RegisterItemClass | Registers a diagram item class for serialization support.
ResetAlignmentGuides | For internal use.
ResizeToFitItem | Resizes the document extents so that the specified item is contained within.
ResizeToFitItems | Overloaded. Resizes the document scrollable area so it fits all diagram items.
RouteAllLinks | Routes all links in the diagram in a way they do not cross nodes.
SaveToFile | Overloaded. Saves the binary contents of the diagram to a disk file.
SaveToStream | Overloaded. Saves the binary contents of the diagram to a .NET stream.
SaveToString | Overloaded. Encodes the diagram contents into an ASCII string.
SaveToXml | Overloaded. Saves the diagram to an XML document.
SetShadowOffset | Sets the default offset at which items shadows are drawn.
TrackMouseHover | Specifies whether the diagram view should track mouse hover events. (Inherited from DiagramBase.)
UnitToPixel | Converts the specified point from document to client coordinates ignoring the current scale transformation.
UpdateMeasureTextScale | Gets or sets the scale to use when measuring texts. This should be effectively set to the value of DiagramView.Zoom / 100.
UpdateRuntimeIndices | For internal use.
UpdateZOrder | Immediately sorts the Z-order list if Z-order has been invalidated. Otherwise it will be sorted next time the diagram draws its contents.

Protected Methods

Name | Description
AddItem | Invoked by the AddItemCmd and RemoveItemCmd classes to effectively add the specified item to the diagram.
CreateAddItemCmd | Creates an AddItemCmd instance that implements undo/redo of adding an item to the diagram.
CreateItem | Creates an instance of the specified class.
CreateModifyItemCmd | Creates a ModifyItemCmd instance that implements undo/redo of item move and resize operations.
CreateRemoveItemCmd | Creates a RemoveItemCmd instance that implements undo/redo of removing an item from the diagram.
DeleteGroup | Removes the specified group from the group collection.
Dispose | Clean up any resources being used.
GetValue | Gets the effective value of the style property with the specified name.
OnActionRecorded | Raises the ActionRecorded event. (Inherited from DiagramBase.)
OnActionRecording | Raises the ActionRecording event. (Inherited from DiagramBase.)
OnActionRedone | Raises the ActionRedone event. (Inherited from DiagramBase.)
OnActionUndone | Raises the ActionUndone event. (Inherited from DiagramBase.)
OnBeginLoad | Raises the BeginLoad event. (Inherited from DiagramBase.)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramBase.)
OnCellClicked | Raises the CellClicked event. (Inherited from DiagramBase.)
OnCellDoubleClicked | Raises the CellDoubleClicked event. (Inherited from DiagramBase.)
OnCellTextEdited | Raises the CellTextEdited event. (Inherited from DiagramBase.)
OnCellTextEditing | Raises the CellTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnClicked | Raises the Clicked event. (Inherited from DiagramBase.)
OnContainerChildAdded | Raises the ContainerChildAdded event. (Inherited from DiagramBase.)
OnContainerChildRemoved | Raises the ContainerChildRemoved event. (Inherited from DiagramBase.)
OnContainerFolded | Raises the ContainerFolded event. (Inherited from DiagramBase.)
OnContainerUnfolded | Raises the ContainerUnfolded event. (Inherited from DiagramBase.)
OnContentVisibilityChanged | Raises the ContentVisibilityChanged event. (Inherited from DiagramBase.)
OnDefaultShapeChanged | Raises the DefaultShapeChanged event. (Inherited from DiagramBase.)
OnDeserializeTag | Raises the DeserializeTag event. (Inherited from DiagramBase.)
OnDestinationAnchorChanged | Raises the DestinationAnchorChanged event. (Inherited from DiagramBase.)
OnDirtyChanged | Raises the DirtyChanged event. (Inherited from DiagramBase.)
OnDoubleClicked | Raises the DoubleClicked event. (Inherited from DiagramBase.)
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event. (Inherited from DiagramBase.)
OnDrawAnchorPoint | Raises the DrawAnchorPoint event. (Inherited from DiagramBase.)
OnDrawBackground | Raises the DrawBackground event. (Inherited from DiagramBase.)
OnDrawCell | Raises the DrawCell event. (Inherited from DiagramBase.)
OnDrawForeground | Raises the DrawForeground event. (Inherited from DiagramBase.)
OnDrawLink | Raises the DrawLink event. (Inherited from DiagramBase.)
OnDrawNode | Raises the DrawNode event. (Inherited from DiagramBase.)
OnEndLoad | Raises the EndLoad event. (Inherited from DiagramBase.)
OnExpandButtonClicked | Raises the ExpandButtonClicked event. (Inherited from DiagramBase.)
OnGroupDestroyed | Raises the GroupDestroyed event. (Inherited from DiagramBase.)
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event. (Inherited from DiagramBase.)
OnInitializeLink | Raises the InitializeLink event. (Inherited from DiagramBase.)
OnInitializeNode | Raises the InitializeNode event. (Inherited from DiagramBase.)
OnItemAdded | Raises the ItemAdded event. (Inherited from DiagramBase.)
OnItemRemoved | Raises the ItemRemoved event. (Inherited from DiagramBase.)
OnLayerVisibilityChanged | Raises the LayerVisibilityChanged event. (Inherited from DiagramBase.)
OnLinkActivated | Raises the LinkActivated event. (Inherited from DiagramBase.)
OnLinkClicked | Raises the LinkClicked event. (Inherited from DiagramBase.)
OnLinkCreateCancelled | Raises the LinkCreateCancelled event. (Inherited from DiagramBase.)
OnLinkCreated | Raises the LinkCreated event. (Inherited from DiagramBase.)
OnLinkCreating | Raises the LinkCreating event. (Inherited from DiagramBase.)
OnLinkDeactivated | Raises the LinkDeactivated event. (Inherited from DiagramBase.)
OnLinkDeleted | Raises the LinkDeleted event. (Inherited from DiagramBase.)
OnLinkDeleting | Raises the LinkDeleting event. (Inherited from DiagramBase.)
OnLinkDeselected | Raises the LinkDeselected event. (Inherited from DiagramBase.)
OnLinkDoubleClicked | Raises the LinkDoubleClicked event. (Inherited from DiagramBase.)
OnLinkModified | Raises the LinkModified event. (Inherited from DiagramBase.)
OnLinkModifyCancelled | Raises the LinkModifyCancelled event. (Inherited from DiagramBase.)
OnLinkModifying | Raises the LinkModifying event. (Inherited from DiagramBase.)
OnLinkPasted | Raises the LinkPasted event. (Inherited from DiagramBase.)
OnLinkPointed | Raises the LinkPointed event. (Inherited from DiagramBase.)
OnLinkRouted | Raises the LinkRouted event. (Inherited from DiagramBase.)
OnLinkSelected | Raises the LinkSelected event. (Inherited from DiagramBase.)
OnLinkSelecting | Raises the LinkSelecting event. (Inherited from DiagramBase.)
OnLinkSplit | Raises the LinkSplit event. (Inherited from DiagramBase.)
OnLinkStartModifying | Raises the LinkStartModifying event. (Inherited from DiagramBase.)
OnLinkTextEdited | Raises the LinkTextEdited event. (Inherited from DiagramBase.)
OnLinkTextEditing | Raises the LinkTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnMeasureUnitChanged | Raises the MeasureUnitChanged event. (Inherited from DiagramBase.)
OnNodeActivated | Raises the NodeActivated event. (Inherited from DiagramBase.)
OnNodeClicked | Raises the NodeClicked event. (Inherited from DiagramBase.)
OnNodeCreateCancelled | Raises the NodeCreateCancelled event. (Inherited from DiagramBase.)
OnNodeCreated | Raises the NodeCreated event. (Inherited from DiagramBase.)
OnNodeCreating | Raises the NodeCreating event. (Inherited from DiagramBase.)
OnNodeDeactivated | Raises the NodeDeactivated event. (Inherited from DiagramBase.)
OnNodeDeleted | Raises the NodeDeleted event. (Inherited from DiagramBase.)
OnNodeDeleting | Raises the NodeDeleting event. (Inherited from DiagramBase.)
OnNodeDeselected | Raises the NodeDeselected event. (Inherited from DiagramBase.)
OnNodeDoubleClicked | Raises the NodeDoubleClicked event. (Inherited from DiagramBase.)
OnNodeModified | Raises the NodeModified event. (Inherited from DiagramBase.)
OnNodeModifyCancelled | Raises the NodeModifyCancelled event. (Inherited from DiagramBase.)
OnNodeModifying | Raises the NodeModifying event. (Inherited from DiagramBase.)
OnNodePasted | Raises the NodePasted event. (Inherited from DiagramBase.)
OnNodePointed | Raises the NodePointed event. (Inherited from DiagramBase.)
OnNodeSelected | Raises the NodeSelected event. (Inherited from DiagramBase.)
OnNodeSelecting | Raises the NodeSelecting event. (Inherited from DiagramBase.)
OnNodeStartModifying | Raises the NodeStartModifying event. (Inherited from DiagramBase.)
OnNodeTextEdited | Raises the NodeTextEdited event. (Inherited from DiagramBase.)
OnNodeTextEditing | Raises the NodeTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnOriginAnchorChanged | Raises the OriginAnchorChanged event. (Inherited from DiagramBase.)
OnQueryAlignTarget | Raises the QueryAlignTarget event. (Inherited from DiagramBase.)
OnRepaint | Raises the Repaint event. (Inherited from DiagramBase.)
OnRequestClipboard | Raises the RequestClipboard event. (Inherited from DiagramBase.)
OnRequestTimer | Raises the RequestTimer event. (Inherited from DiagramBase.)
OnSelectionChanged | Raises the SelectionChanged event. (Inherited from DiagramBase.)
OnSelectionModified | Raises the SelectionModified event. (Inherited from DiagramBase.)
OnSelectionModifying | Raises the SelectionModifying event. (Inherited from DiagramBase.)
OnSerializeTag | Raises the SerializeTag event. (Inherited from DiagramBase.)
OnSetSelfLoopShape | Raises the SetSelfLoopShape event. (Inherited from DiagramBase.)
OnShapeModified | Raises the ShapeModified event. (Inherited from DiagramBase.)
OnTableColumnResized | Raises the TableColumnResized event. (Inherited from DiagramBase.)
OnTableColumnResizing | Raises the TableColumnResizing event. (Inherited from DiagramBase.)
OnTableRowResized | Raises the TableRowResized event. (Inherited from DiagramBase.)
OnTableRowResizing | Raises the TableRowResizing event. (Inherited from DiagramBase.)
OnTableSectionCollapsed | Raises the TableSectionCollapsed event. (Inherited from DiagramBase.)
OnTableSectionExpanded | Raises the TableSectionExpanded event. (Inherited from DiagramBase.)
OnTreeCollapsed | Raises the TreeCollapsed event. (Inherited from DiagramBase.)
OnTreeExpanded | Raises the TreeExpanded event. (Inherited from DiagramBase.)
OnTreeItemTextEditing | Raises the TreeItemTextEditing event. (Inherited from DiagramBase.)
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event. (Inherited from DiagramBase.)
OnViewRemoved | Raises the ViewRemoved event. (Inherited from DiagramBase.)
RemoveItem | Invoked by the AddItemCmd and RemoveItemCmd classes to effectively remove the specified item from the diagram.

Public Events

Name | Description
ActionRecorded | Raised when an action is recorded in the undo buffer. (Inherited from DiagramBase.)
ActionRecording | A validation event raised before an action is recorded in the undo buffer. (Inherited from DiagramBase.)
ActionRedone | Raised when an action is redone. (Inherited from DiagramBase.)
ActionUndone | Raised when an action is undone. (Inherited from DiagramBase.)
ActiveLayerChanged | Raised when the diagram's active layer has changed. (Inherited from DiagramBase.)
BeginLoad | Raised when the component starts loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
BoundsChanged | Raised when the Bounds property value has changed. (Inherited from DiagramBase.)
CellClicked | Raised when the user clicks a table’s cell. (Inherited from DiagramBase.)
CellDoubleClicked | Raised when the user double-clicks a table’s cell. (Inherited from DiagramBase.)
CellTextEdited | Raised when the user edits the text of a table’s cell. (Inherited from DiagramBase.)
CellTextEditing | A validation event that lets you approve or reject changes made to the text of a table’s cell. (Inherited from DiagramBase.)
Clicked | Raised when the user clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area. (Inherited from DiagramBase.)
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area. (Inherited from DiagramBase.)
ContentVisibilityChanged | Raised when the visibility of container's content changes. (Inherited from DiagramBase.)
DefaultShapeChanged | Raised when the DefaultShape property value has changed. (Inherited from DiagramBase.)
DeserializeTag | Raised when the Tag of a diagram item must be deserialized from XML format. (Inherited from DiagramBase.)
DestinationAnchorChanged | Raised when the DestinationAnchor property value of a link has changed. (Inherited from DiagramBase.)
DirtyChanged | Raised when the Dirty property value has changed. (Inherited from DiagramBase.)
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
DrawAdjustmentHandles | Raised when item’s adjustment handles must be custom drawn. (Inherited from DiagramBase.)
DrawAnchorPoint | Raised when an anchor point must be custom drawn. (Inherited from DiagramBase.)
DrawBackground | Raised to let you custom draw the diagram background. (Inherited from DiagramBase.)
DrawCell | Raised when a table’s cell must be custom drawn. (Inherited from DiagramBase.)
DrawForeground | Raised to let you custom draw the diagram foreground. (Inherited from DiagramBase.)
DrawLink | Raised when a diagram link must be custom drawn. (Inherited from DiagramBase.)
DrawNode | Raised when a diagram node must be custom drawn. (Inherited from DiagramBase.)
EndLoad | Raised when the component ends loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
ExpandButtonClicked | Raised when the user clicks the [±] button of an Expandable node. (Inherited from DiagramBase.)
GroupDestroyed | Raised when a Group object is destroyed. (Inherited from DiagramBase.)
HitTestAdjustmentHandles | Raised when custom hit testing of item’s adjustment handles must be performed. (Inherited from DiagramBase.)
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created. (Inherited from DiagramBase.)
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created. (Inherited from DiagramBase.)
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
LayerVisibilityChanged | Raised when the visibility of a Layer changes. (Inherited from DiagramBase.)
LinkActivated | Raised when a link becomes the ActiveItem. (Inherited from DiagramBase.)
LinkClicked | Raised when the user clicks a link. (Inherited from DiagramBase.)
LinkCreateCancelled | Raised when the user cancels link creation. (Inherited from DiagramBase.)
LinkCreated | Raised when the user draws a new link. (Inherited from DiagramBase.)
LinkCreating | A validation event raised while the user is drawing a new link. (Inherited from DiagramBase.)
LinkDeactivated | Raised when a link is no longer the ActiveItem. (Inherited from DiagramBase.)
LinkDeleted | Raised when a link is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkDeselected | Raised when a link is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDoubleClicked | Raised when the user double-clicks a link. (Inherited from DiagramBase.)
LinkModified | Raised when the user moves any control point of a link. (Inherited from DiagramBase.)
LinkModifyCancelled | Raised when the user cancels move or resize operation being done on a link. (Inherited from DiagramBase.)
LinkModifying | A validation event raised while the user is modifying a link. (Inherited from DiagramBase.)
LinkPasted | Raised when a link has been pasted from the clipboard. (Inherited from DiagramBase.)
LinkPointed | Raised when the mouse pointer hovers over a link. (Inherited from DiagramBase.)
LinkRouted | Raised when a link is routed by the auto-routing algorithm. (Inherited from DiagramBase.)
LinkSelected | Raised when a link is selected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkSelecting | Raised when the user tries to select a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkSplit | Raised when the user splits a link interactively. (Inherited from DiagramBase.)
LinkStartModifying | A validation event raised when the user starts modifying a link. (Inherited from DiagramBase.)
LinkTextEdited | Raised when the user edits the text of a link. (Inherited from DiagramBase.)
LinkTextEditing | A validation event that lets you approve or reject changes made to the text of a link. (Inherited from DiagramBase.)
MeasureUnitChanged | Raised when the MeasureUnit property value has changed. (Inherited from DiagramBase.)
NodeActivated | Raised when a node becomes the ActiveItem. (Inherited from DiagramBase.)
NodeClicked | Raised when the user clicks a node. (Inherited from DiagramBase.)
NodeCreateCancelled | Raised when the user cancels node creation. (Inherited from DiagramBase.)
NodeCreated | Raised when the user draws a new node. (Inherited from DiagramBase.)
NodeCreating | A validation event raised while the user is drawing a new node. (Inherited from DiagramBase.)
NodeDeactivated | Raised when a node is no longer the ActiveItem. (Inherited from DiagramBase.)
NodeDeleted | Raised when a node is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeDeselected | Raised when a node is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDoubleClicked | Raised when the user double-clicks a node. (Inherited from DiagramBase.)
NodeModified | Raised when the user moves or resizes a node. (Inherited from DiagramBase.)
NodeModifyCancelled | Raised when the user cancels move or resize operation being done on a node. (Inherited from DiagramBase.)
NodeModifying | A validation event raised while the user is moving or resizing a node. (Inherited from DiagramBase.)
NodePasted | Raised when a node has been pasted from the clipboard. (Inherited from DiagramBase.)
NodePointed | Raised when the mouse pointer hovers over a node. (Inherited from DiagramBase.)
NodeSelected | Raised when a node is selected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeSelecting | Raised when the user tries to select a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeStartModifying | A validation event raised when the user starts modifying a node. (Inherited from DiagramBase.)
NodeTextEdited | Raised when the user edits the text of a node. (Inherited from DiagramBase.)
NodeTextEditing | A validation event that lets you approve or reject changes made to the text of a node. (Inherited from DiagramBase.)
OriginAnchorChanged | Raised when the OriginAnchor property value of a link has changed. (Inherited from DiagramBase.)
QueryAlignTarget | Raised to validate a node as target for alignment guides when AutoAlignNodes is enabled. (Inherited from DiagramBase.)
Repaint | Raised when the diagram views should be repainted. (Inherited from DiagramBase.)
RequestCacheReset | Raised when an object within the diagram requests a reset of the cached bitmap. (Inherited from DiagramBase.)
RequestClipboard | Raised when an object within the diagram requests an operation with the clipboard. (Inherited from DiagramBase.)
RequestTimer | Raised when an object within the diagram needs to start or stop a timer. (Inherited from DiagramBase.)
SelectionChanged | Raised when an item is added to or removed from the selection (Inherited from DiagramBase.)
SelectionModified | Raised when the user moves multiple selected items. (Inherited from DiagramBase.)
SelectionModifying | Raised while the user is moving multiple selected items, this event lets you cancel the modification. (Inherited from DiagramBase.)
SerializeTag | Raised when the Tag of a diagram item must be serialized into an XML document. (Inherited from DiagramBase.)
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape. (Inherited from DiagramBase.)
ShapeModified | Raised when the user modifies the shape of a ShapeNode by moving one of the control points corresponding to shape formula parameters. (Inherited from DiagramBase.)
TableColumnResized | Raised when the user finishes resizing a column in a table. (Inherited from DiagramBase.)
TableColumnResizing | Raised when the user resizes a column in a table interactively. (Inherited from DiagramBase.)
TableRowResized | Raised when the user finishes resizing a row in a table. (Inherited from DiagramBase.)
TableRowResizing | Raised when the user resizes a row in a table interactively. (Inherited from DiagramBase.)
TableSectionCollapsed | Raised when the user collapses the rows of a table’s section by clicking the [-] button in the section's header row. (Inherited from DiagramBase.)
TableSectionExpanded | Raised when the user expands the rows of a table's section by clicking the [+] button in the section’s header row. (Inherited from DiagramBase.)
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node. (Inherited from DiagramBase.)
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node. (Inherited from DiagramBase.)
TreeItemTextEditing | A validation event that lets you approve or reject changes made to the text of a TreeViewNode's item. (Inherited from DiagramBase.)
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point. (Inherited from DiagramBase.)
ViewRemoved | Raised when a DiagramView is detached from this diagram. (Inherited from DiagramBase.)

See Also

Diagram Class


MindFusion.Diagramming.Diagram Fields

Diagram Fields
[image]

Public Fields

Name | Description
Dummy | A shared DummyNode instance.

See Also

Diagram Class


MindFusion.Diagramming.Diagram.Dummy Field

Diagram.Dummy Field
[image]

A shared DummyNode instance.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DummyNode Dummy

Visual Basic [image] Copy Code

Public Dummy As DummyNode

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram Constructor

Diagram Constructor
[image]

The Diagram class represents a flow diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Diagram ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Diagram Class


MindFusion.Diagramming.Diagram Methods

Diagram Methods
[image]

Public Methods

Name | Description
AlignPointToGrid | Returns a point of the alignment grid nearest to the one passed as an argument.
ArrangeLinkLabels | Rearranges link labels whose AutoArrange property is enabled.
ChangeUnit | Sets new MeasureUnit value and scales the coordinates of diagram items so that their absolute size remains unchanged.
ClearAll | Removes all items from the diagram.
CopySelection | Creates a copy of the currently selected objects and groups.
CreateImage | Overloaded. Creates a bitmap containing an image of the diagram.
CreateMeasureGraphics | Creates an IGraphics object that can be used to obtain various string size measurements.
CreateThemeFromDefaults | Creates a Theme object representing the default properties of the diagram.
Draw | Renders the diagram on the specified IGraphics object.
DrawAlignmentGuides | Draws the current alignment guides.
DrawInteraction | Draws the items that the user is currently modifying.
DrawLayer | Renders all diagram items to the specified graphics.
DrawStyledText | Draws a formatted text string, the same way text is drawn in shape nodes whose EnableStyledText property is set to true. This method lets you display styled text in custom-drawn nodes or links.
ExecuteCommand | Executes the specified command on this diagram.
FindGroup | Finds the group that has the specified tag value.
FindLink | Finds the link that has the specified tag value.
FindLinkById | Finds the link that has the specified id value.
FindNode | Finds the node that has the specified tag value.
FindNodeById | Finds the node that has the specified id value.
GetContentBounds | Returns the smallest rectangle that bounds all diagram objects.
GetItemAt | Finds and returns the top-most diagram item that lies at the specified location.
GetLinkAt | Overloaded. Finds and returns the link that lies at the specified location.
GetLinksAt | Returns the links that contain the specified point.
GetNearestNode | Returns the node nearest to the specified point.
GetNodeAt | Overloaded. Gets the node that lies at the specified location.
GetNodesAt | Returns the nodes that contain the specified point.
HandleKeyDown | Propagates keyboard input to interested manipulators and components.
HandleKeyPress | Propagates keyboard input to interested manipulators.
HandleKeyUp | Propagates keyboard input to interested components.
HandleMouseMove | Propagates mouse input to interested manipulators.
HitTestComponents | Tests whether the specified point is within a component of a diagram item and returns this component.
HitTestManipulators | Tests whether the specified point is within the manipulator of a diagram object and triggers the manipulator.
Invalidate | Overloaded. Invalidates the diagram or a region of the diagram, causing it to be repainted.
InvalidateZOrder | Forces a new sort of the Z order list before next redraw.
IsItemInteractive | Checks if the specified item can be modified interactively.
IsItemLocked | Checks if the specified item is locked.
IsItemVisible | Checks if the specified item is currently visible.
LoadFromFile | Loads the contents of an existing diagram file into the control.
LoadFromStream | Loads a diagram from the specified stream.
LoadFromString | Decodes diagram contents from a string that was created with SaveToString.
LoadFromXml | Overloaded. Loads the contents of an XML diagram document into the control.
MeasureString | Overloaded. Measures a text taking into consideration the current affine transform of the diagram.
Navigate | Selects the nearest item in the specified direction.
NewInstance | Custom Diagram classes must override this method to return an instance of their type.
PasteSelection | Adds the specified items and groups to the specified diagram document.
PixelToUnit | Converts the specified point from client to document coordinates ignoring the current scale transformation.
RaiseCellTextEdited | Raises the CellTextEdited event .
RaiseCellTextEditing | Raises the CellTextEditing event to validate entering in-place editing mode.
RaiseClicked | Overloaded. Raises the Clicked event of the diagram or one of the *Clicked events related to diagram items.
RaiseCreated | Raises the appropriate *Created event according to the type of the specified item.
RaiseDeleting | Raises the appropriate *Deleting event according to the type of the specified item.
RaiseDoubleClicked | Overloaded. Raises the DoubleClicked event of the diagram or one of the *DoubleClicked events related to diagram items.
RaiseLinkTextEdited | Raises the LinkTextEdited event.
RaiseLinkTextEditing | Raises the LinkTextEditing event to validate entering in-place editing mode.
RaiseMouseHover | Raises the appropriate Pointed event.
RaiseNodeTextEdited | Raises the NodeTextEdited event.
RaiseNodeTextEditing | Raises the NodeTextEditing event to validate entering in-place editing mode.
RaisePasted | Raises the appropriate Pasted event.
RaiseSelecting | Raises the appropriate Selecting event.
RaiseTreeItemTextEditing | Raises the TreeItemTextEditing event to validate entering inplace edit mode.
RaiseViewRemoved | Raises the ViewRemoved event.
RegisterClass | Registers a diagram item or lane header class for serialization support.
RegisterDefaultStyle | Registers a default style for the objects of the specified type.
RegisterItemClass | Registers a diagram item class for serialization support.
ResetAlignmentGuides | For internal use.
ResizeToFitItem | Resizes the document extents so that the specified item is contained within.
ResizeToFitItems | Overloaded. Resizes the document scrollable area so it fits all diagram items.
RouteAllLinks | Routes all links in the diagram in a way they do not cross nodes.
SaveToFile | Overloaded. Saves the binary contents of the diagram to a disk file.
SaveToStream | Overloaded. Saves the binary contents of the diagram to a .NET stream.
SaveToString | Overloaded. Encodes the diagram contents into an ASCII string.
SaveToXml | Overloaded. Saves the diagram to an XML document.
SetShadowOffset | Sets the default offset at which items shadows are drawn.
TrackMouseHover | Specifies whether the diagram view should track mouse hover events. (Inherited from DiagramBase.)
UnitToPixel | Converts the specified point from document to client coordinates ignoring the current scale transformation.
UpdateMeasureTextScale | Gets or sets the scale to use when measuring texts. This should be effectively set to the value of DiagramView.Zoom / 100.
UpdateRuntimeIndices | For internal use.
UpdateZOrder | Immediately sorts the Z-order list if Z-order has been invalidated. Otherwise it will be sorted next time the diagram draws its contents.

Protected Methods

Name | Description
AddItem | Invoked by the AddItemCmd and RemoveItemCmd classes to effectively add the specified item to the diagram.
CreateAddItemCmd | Creates an AddItemCmd instance that implements undo/redo of adding an item to the diagram.
CreateItem | Creates an instance of the specified class.
CreateModifyItemCmd | Creates a ModifyItemCmd instance that implements undo/redo of item move and resize operations.
CreateRemoveItemCmd | Creates a RemoveItemCmd instance that implements undo/redo of removing an item from the diagram.
DeleteGroup | Removes the specified group from the group collection.
Dispose | Clean up any resources being used.
GetValue | Gets the effective value of the style property with the specified name.
OnActionRecorded | Raises the ActionRecorded event. (Inherited from DiagramBase.)
OnActionRecording | Raises the ActionRecording event. (Inherited from DiagramBase.)
OnActionRedone | Raises the ActionRedone event. (Inherited from DiagramBase.)
OnActionUndone | Raises the ActionUndone event. (Inherited from DiagramBase.)
OnBeginLoad | Raises the BeginLoad event. (Inherited from DiagramBase.)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramBase.)
OnCellClicked | Raises the CellClicked event. (Inherited from DiagramBase.)
OnCellDoubleClicked | Raises the CellDoubleClicked event. (Inherited from DiagramBase.)
OnCellTextEdited | Raises the CellTextEdited event. (Inherited from DiagramBase.)
OnCellTextEditing | Raises the CellTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnClicked | Raises the Clicked event. (Inherited from DiagramBase.)
OnContainerChildAdded | Raises the ContainerChildAdded event. (Inherited from DiagramBase.)
OnContainerChildRemoved | Raises the ContainerChildRemoved event. (Inherited from DiagramBase.)
OnContainerFolded | Raises the ContainerFolded event. (Inherited from DiagramBase.)
OnContainerUnfolded | Raises the ContainerUnfolded event. (Inherited from DiagramBase.)
OnContentVisibilityChanged | Raises the ContentVisibilityChanged event. (Inherited from DiagramBase.)
OnDefaultShapeChanged | Raises the DefaultShapeChanged event. (Inherited from DiagramBase.)
OnDeserializeTag | Raises the DeserializeTag event. (Inherited from DiagramBase.)
OnDestinationAnchorChanged | Raises the DestinationAnchorChanged event. (Inherited from DiagramBase.)
OnDirtyChanged | Raises the DirtyChanged event. (Inherited from DiagramBase.)
OnDoubleClicked | Raises the DoubleClicked event. (Inherited from DiagramBase.)
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event. (Inherited from DiagramBase.)
OnDrawAnchorPoint | Raises the DrawAnchorPoint event. (Inherited from DiagramBase.)
OnDrawBackground | Raises the DrawBackground event. (Inherited from DiagramBase.)
OnDrawCell | Raises the DrawCell event. (Inherited from DiagramBase.)
OnDrawForeground | Raises the DrawForeground event. (Inherited from DiagramBase.)
OnDrawLink | Raises the DrawLink event. (Inherited from DiagramBase.)
OnDrawNode | Raises the DrawNode event. (Inherited from DiagramBase.)
OnEndLoad | Raises the EndLoad event. (Inherited from DiagramBase.)
OnExpandButtonClicked | Raises the ExpandButtonClicked event. (Inherited from DiagramBase.)
OnGroupDestroyed | Raises the GroupDestroyed event. (Inherited from DiagramBase.)
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event. (Inherited from DiagramBase.)
OnInitializeLink | Raises the InitializeLink event. (Inherited from DiagramBase.)
OnInitializeNode | Raises the InitializeNode event. (Inherited from DiagramBase.)
OnItemAdded | Raises the ItemAdded event. (Inherited from DiagramBase.)
OnItemRemoved | Raises the ItemRemoved event. (Inherited from DiagramBase.)
OnLayerVisibilityChanged | Raises the LayerVisibilityChanged event. (Inherited from DiagramBase.)
OnLinkActivated | Raises the LinkActivated event. (Inherited from DiagramBase.)
OnLinkClicked | Raises the LinkClicked event. (Inherited from DiagramBase.)
OnLinkCreateCancelled | Raises the LinkCreateCancelled event. (Inherited from DiagramBase.)
OnLinkCreated | Raises the LinkCreated event. (Inherited from DiagramBase.)
OnLinkCreating | Raises the LinkCreating event. (Inherited from DiagramBase.)
OnLinkDeactivated | Raises the LinkDeactivated event. (Inherited from DiagramBase.)
OnLinkDeleted | Raises the LinkDeleted event. (Inherited from DiagramBase.)
OnLinkDeleting | Raises the LinkDeleting event. (Inherited from DiagramBase.)
OnLinkDeselected | Raises the LinkDeselected event. (Inherited from DiagramBase.)
OnLinkDoubleClicked | Raises the LinkDoubleClicked event. (Inherited from DiagramBase.)
OnLinkModified | Raises the LinkModified event. (Inherited from DiagramBase.)
OnLinkModifyCancelled | Raises the LinkModifyCancelled event. (Inherited from DiagramBase.)
OnLinkModifying | Raises the LinkModifying event. (Inherited from DiagramBase.)
OnLinkPasted | Raises the LinkPasted event. (Inherited from DiagramBase.)
OnLinkPointed | Raises the LinkPointed event. (Inherited from DiagramBase.)
OnLinkRouted | Raises the LinkRouted event. (Inherited from DiagramBase.)
OnLinkSelected | Raises the LinkSelected event. (Inherited from DiagramBase.)
OnLinkSelecting | Raises the LinkSelecting event. (Inherited from DiagramBase.)
OnLinkSplit | Raises the LinkSplit event. (Inherited from DiagramBase.)
OnLinkStartModifying | Raises the LinkStartModifying event. (Inherited from DiagramBase.)
OnLinkTextEdited | Raises the LinkTextEdited event. (Inherited from DiagramBase.)
OnLinkTextEditing | Raises the LinkTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnMeasureUnitChanged | Raises the MeasureUnitChanged event. (Inherited from DiagramBase.)
OnNodeActivated | Raises the NodeActivated event. (Inherited from DiagramBase.)
OnNodeClicked | Raises the NodeClicked event. (Inherited from DiagramBase.)
OnNodeCreateCancelled | Raises the NodeCreateCancelled event. (Inherited from DiagramBase.)
OnNodeCreated | Raises the NodeCreated event. (Inherited from DiagramBase.)
OnNodeCreating | Raises the NodeCreating event. (Inherited from DiagramBase.)
OnNodeDeactivated | Raises the NodeDeactivated event. (Inherited from DiagramBase.)
OnNodeDeleted | Raises the NodeDeleted event. (Inherited from DiagramBase.)
OnNodeDeleting | Raises the NodeDeleting event. (Inherited from DiagramBase.)
OnNodeDeselected | Raises the NodeDeselected event. (Inherited from DiagramBase.)
OnNodeDoubleClicked | Raises the NodeDoubleClicked event. (Inherited from DiagramBase.)
OnNodeModified | Raises the NodeModified event. (Inherited from DiagramBase.)
OnNodeModifyCancelled | Raises the NodeModifyCancelled event. (Inherited from DiagramBase.)
OnNodeModifying | Raises the NodeModifying event. (Inherited from DiagramBase.)
OnNodePasted | Raises the NodePasted event. (Inherited from DiagramBase.)
OnNodePointed | Raises the NodePointed event. (Inherited from DiagramBase.)
OnNodeSelected | Raises the NodeSelected event. (Inherited from DiagramBase.)
OnNodeSelecting | Raises the NodeSelecting event. (Inherited from DiagramBase.)
OnNodeStartModifying | Raises the NodeStartModifying event. (Inherited from DiagramBase.)
OnNodeTextEdited | Raises the NodeTextEdited event. (Inherited from DiagramBase.)
OnNodeTextEditing | Raises the NodeTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnOriginAnchorChanged | Raises the OriginAnchorChanged event. (Inherited from DiagramBase.)
OnQueryAlignTarget | Raises the QueryAlignTarget event. (Inherited from DiagramBase.)
OnRepaint | Raises the Repaint event. (Inherited from DiagramBase.)
OnRequestClipboard | Raises the RequestClipboard event. (Inherited from DiagramBase.)
OnRequestTimer | Raises the RequestTimer event. (Inherited from DiagramBase.)
OnSelectionChanged | Raises the SelectionChanged event. (Inherited from DiagramBase.)
OnSelectionModified | Raises the SelectionModified event. (Inherited from DiagramBase.)
OnSelectionModifying | Raises the SelectionModifying event. (Inherited from DiagramBase.)
OnSerializeTag | Raises the SerializeTag event. (Inherited from DiagramBase.)
OnSetSelfLoopShape | Raises the SetSelfLoopShape event. (Inherited from DiagramBase.)
OnShapeModified | Raises the ShapeModified event. (Inherited from DiagramBase.)
OnTableColumnResized | Raises the TableColumnResized event. (Inherited from DiagramBase.)
OnTableColumnResizing | Raises the TableColumnResizing event. (Inherited from DiagramBase.)
OnTableRowResized | Raises the TableRowResized event. (Inherited from DiagramBase.)
OnTableRowResizing | Raises the TableRowResizing event. (Inherited from DiagramBase.)
OnTableSectionCollapsed | Raises the TableSectionCollapsed event. (Inherited from DiagramBase.)
OnTableSectionExpanded | Raises the TableSectionExpanded event. (Inherited from DiagramBase.)
OnTreeCollapsed | Raises the TreeCollapsed event. (Inherited from DiagramBase.)
OnTreeExpanded | Raises the TreeExpanded event. (Inherited from DiagramBase.)
OnTreeItemTextEditing | Raises the TreeItemTextEditing event. (Inherited from DiagramBase.)
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event. (Inherited from DiagramBase.)
OnViewRemoved | Raises the ViewRemoved event. (Inherited from DiagramBase.)
RemoveItem | Invoked by the AddItemCmd and RemoveItemCmd classes to effectively remove the specified item from the diagram.

See Also

Diagram Class


MindFusion.Diagramming.Diagram.AddItem Method

Diagram.AddItem Method
[image]

Invoked by the AddItemCmd and RemoveItemCmd classes to effectively add the specified item to the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void AddItem (
DiagramItem item
)

Visual Basic [image] Copy Code

Protected Sub AddItem ( _
item As DiagramItem _
)

Parameters

item

The DiagramItem being added to the diagram.

See Also

Diagram Members
Diagram Class
RemoveItem Method


MindFusion.Diagramming.Diagram.AlignPointToGrid Method

Diagram.AlignPointToGrid Method
[image]

Returns a point of the alignment grid nearest to the one passed as an argument.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointF AlignPointToGrid (
PointF point
)

Visual Basic [image] Copy Code

Public Function AlignPointToGrid( _
point As PointF _
) As PointF

Parameters

point
A point specified in diagram coordinates.

Return Value

A point from the alignment grid.

Remarks

Items created or moved by a user are automatically aligned to the grid. However, if items are placed in the diagram programmatically, their coordinates are set to the specified positions without aligning. In such cases use AlignPointToGrid if items must be placed exactly at grid points.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
AlignToGrid Property
GridSizeX Property
GridSizeY Property


MindFusion.Diagramming.Diagram.ArrangeLinkLabels Method

Diagram.ArrangeLinkLabels Method
[image]

Rearranges link labels whose AutoArrange property is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ArrangeLinkLabels ()

Visual Basic [image] Copy Code

Public Sub ArrangeLinkLabels ()

See Also

Diagram Members
Diagram Class
LinkLabel Class


MindFusion.Diagramming.Diagram.ChangeUnit Method

Diagram.ChangeUnit Method
[image]

Sets new MeasureUnit value and scales the coordinates of diagram items so that their absolute size remains unchanged.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ChangeUnit (
MeasureUnit newUnit
)

Visual Basic [image] Copy Code

Public Sub ChangeUnit( _
newUnit As MeasureUnit _
)

Parameters

newUnit

A MeasureUnit instance specifying the new unit.

Remarks

This method scales the coordinates of nodes' Bounds values and links' ControlPoints to preserve their size when measured in the new unit. In addition, it scales values of some size and distance -related properties such as ShadowOffsetX and HeadShapeSize.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ClearAll Method

Diagram.ClearAll Method
[image]

Removes all items from the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ClearAll ()

Visual Basic [image] Copy Code

Public Sub ClearAll ()

Remarks

Use this method to clear all Groups, Links and Nodes in the diagram.

See Also

Diagram Members
Diagram Class
Items Property


MindFusion.Diagramming.Diagram.CopySelection Method

Diagram.CopySelection Method
[image]

Creates a copy of the currently selected objects and groups.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SelectionCopy CopySelection (
Diagram source,
bool unconnectedLinks,
bool copyGroups
)

Visual Basic [image] Copy Code

Public Function CopySelection ( _
source As Diagram, _
unconnectedLinks As Boolean, _
copyGroups As Boolean _
) As SelectionCopy

Parameters

source
The source diagram.
unconnectedLinks
true to allow copying unconnected links; otherwise, false.
copyGroups
true to copy group information; otherwise, false.

Return Value

An instance of the SelectionCopy class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.CreateAddItemCmd Method

Diagram.CreateAddItemCmd Method
[image]

Creates an AddItemCmd instance that implements undo/redo of adding an item to the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual AddItemCmd CreateAddItemCmd (
DiagramItem item
)

Visual Basic [image] Copy Code

Protected Overridable Function CreateAddItemCmd ( _
item As DiagramItem _
) As AddItemCmd

Parameters

item

The item being added to the diagram.

Return Value

An instance of AddItemCmd or derived class.

Remarks

You can override this method to return a custom command that stores additional information about the added item, or handles the addition of more than one items.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
AddItem Method
RemoveItem Method
CreateRemoveItemCmd Method


MindFusion.Diagramming.Diagram.CreateImage Method

Diagram.CreateImage Method
[image]

Creates a bitmap containing an image of the diagram.

Overload List

Name | Description
Diagram.CreateImage () | Creates a bitmap image representing this diagram.
Diagram.CreateImage (RectangleF, Rectangle, Single) | Creates a bitmap image representing this diagram using the specified scale factor.
Diagram.CreateImage (RectangleF, Rectangle, Single, String) | Creates a bitmap containing an image of the diagram.
Diagram.CreateImage (RectangleF, Single) | Creates a bitmap image representing this diagram using the specified scale factor.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.CreateImage Method ()

Diagram.CreateImage Method ()
See Also
[image]

Creates a bitmap image representing this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Bitmap CreateImage ()

Visual Basic [image] Copy Code

Public Function CreateImage () As Bitmap

Return Value

An instance of the .NET System.Drawing.Bitmap class.

Remarks

The method creates a new bitmap instance as big as the current document extents and paints the diagram in it. The Save method of the Bitmap class can be used to save the image in a jpeg, gif or bmp file.

See Also

CreateImage Method Overload List
Diagram Members
Diagram Class
HtmlBuilder Class


MindFusion.Diagramming.Diagram.CreateImage Method (RectangleF, Rectangle, Single)

Diagram.CreateImage Method (RectangleF, Rectangle, Single)
See Also
[image]

Creates a bitmap image representing this diagram using the specified scale factor.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Bitmap CreateImage (
RectangleF viewport,
Rectangle viewportDev,
float scale
)

Visual Basic [image] Copy Code

Public Function CreateImage( _
viewport As RectangleF, _
viewportDev As Rectangle, _
scale As Single _
) As Bitmap

Parameters

viewport
Specifies what region of the diagram to export, in logical coordinates.
viewportDev
Specifies what region of the diagram to export, in device coordinates.
scale
Specifies the scale factor as percents of the original size.

Return Value

An instance of the .NET Bitmap class containing the diagram image.

See Also

CreateImage Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.CreateImage Method (RectangleF, Rectangle, Single, String)

Diagram.CreateImage Method (RectangleF, Rectangle, Single, String)
See Also
[image]

Creates a bitmap containing an image of the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Bitmap CreateImage (
RectangleF viewport,
Rectangle viewportDev,
float scale,
string message
)

Visual Basic [image] Copy Code

Public Function CreateImage( _
viewport As RectangleF, _
viewportDev As Rectangle, _
scale As Single, _
message As String _
) As Bitmap

Parameters

viewport
Specifies what region of the diagram to export, in logical coordinates.
viewportDev

Specifies what region of the diagram to export, in device coordinates.

scale

Specifies the scale factor as percents of the original size.

message

A watermark message to display.

Return Value

A Bitmap instance containing the diagram image.

See Also

CreateImage Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.CreateImage Method (RectangleF, Single)

Diagram.CreateImage Method (RectangleF, Single)
See Also
[image]

Creates a bitmap image representing this diagram using the specified scale factor.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Bitmap CreateImage (
RectangleF viewport,
float scale
)

Visual Basic [image] Copy Code

Public Function CreateImage( _
viewport As RectangleF, _
scale As Single _
) As Bitmap

Parameters

viewport
Specifies what region of the diagram to export.
scale
Specifies the scale factor as percents of the original size.

Return Value

An instance of the .NET Bitmap class containing the diagram image.

Remarks

The method creates a new bitmap instance as big as the current document extents and paints the diagram in it. The Save method of the Bitmap class can be used to save the image in a jpeg, gif or bmp file.

See Also

CreateImage Method Overload List
Diagram Members
Diagram Class
HtmlBuilder Class


MindFusion.Diagramming.Diagram.CreateItem Method

Diagram.CreateItem Method
[image]

Creates an instance of the specified class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual IPersists CreateItem (
string itemClass
)

Visual Basic [image] Copy Code

Protected Overridable Function CreateItem( _
itemClass As String _
) As IPersists

Parameters

itemClass

A string identifying class registered via the RegisterClass method.

Return Value

An instance of the class.

Remarks

By default, deserialized objects are instantiated via reflection if their class provides constructor without arguments. This method lets you create objects using a custom constructor.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.CreateMeasureGraphics Method

Diagram.CreateMeasureGraphics Method
[image]

Creates an IGraphics object that can be used to obtain various string size measurements.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IGraphics CreateMeasureGraphics ()

Visual Basic [image] Copy Code

Public Function CreateMeasureGraphics () As IGraphics

Return Value

An object implementing the IGraphics interface.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.CreateModifyItemCmd Method

Diagram.CreateModifyItemCmd Method
[image]

Creates a ModifyItemCmd instance that implements undo/redo of item move and resize operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual ModifyItemCmd CreateModifyItemCmd (
DiagramItem item
)

Visual Basic [image] Copy Code

Protected Overridable Function CreateModifyItemCmd ( _
item As DiagramItem _
) As ModifyItemCmd

Parameters

item

The item being modified.

Return Value

An instance of ModifyItemCmd or derived class.

Remarks

By overriding this method, you can use custom ModifyItemCmd objects to store additional information about the modified item, or handle the modification of additional items.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.CreateRemoveItemCmd Method

Diagram.CreateRemoveItemCmd Method
[image]

Creates a RemoveItemCmd instance that implements undo/redo of removing an item from the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual RemoveItemCmd CreateRemoveItemCmd (
DiagramItem item
)

Visual Basic [image] Copy Code

Protected Overridable Function CreateRemoveItemCmd ( _
item As DiagramItem _
) As RemoveItemCmd

Parameters

item

The item being removed from the diagram.

Return Value

An instance of RemoveItemCmd or derived class.

Remarks

You can override this method to return a custom command that stores additional information about the removed item, or handles the removal of more than one items.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
AddItem Method
RemoveItem Method
CreateAddItemCmd Method


MindFusion.Diagramming.Diagram.CreateThemeFromDefaults Method

Diagram.CreateThemeFromDefaults Method
[image]

Creates a Theme object representing the default properties of the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Theme CreateThemeFromDefaults ()

Visual Basic [image] Copy Code

Public Function CreateThemeFromDefaults () As Theme

Return Value

An instance of the Theme class.

Remarks

This method is only for compatibility with files saved with versions earlier than 6.0.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.DeleteGroup Method

Diagram.DeleteGroup Method
[image]

Removes the specified group from the group collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void DeleteGroup (
Group group
)

Visual Basic [image] Copy Code

Protected Sub DeleteGroup ( _
group As Group _
)

Parameters

group

The Group to be removed.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Dispose Method

Diagram.Dispose Method
[image]

Clean up any resources being used.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Dispose (
bool disposing
)

Visual Basic [image] Copy Code

Protected Overrides Sub Dispose( _
disposing As Boolean _
)

Parameters

disposing

true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Draw Method

Diagram.Draw Method
[image]

Renders the diagram on the specified IGraphics object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void Draw (
IGraphics graphics,
RenderOptions options,
RectangleF clipRect,
bool noModifiedItems
)

Visual Basic [image] Copy Code

Public Overridable Sub Draw ( _
graphics As IGraphics, _
options As RenderOptions, _
clipRect As RectangleF, _
noModifiedItems As Boolean _
)

Parameters

graphics
The IGraphics surface to draw the diagram on.
options
A RenderOptions object specifying options for the drawing operation.
clipRect
A RectangleF specifying the current clipping rectangle.
noModifiedItems

true to skip rendering the items currently being modified; otherwise, false.

Remarks

MvcDiagram calls this method to draw a representation of the diagram onto the specified graphics surface. You can override Draw if you need to render additional elements over what's already drawn by the Diagram object.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.DrawAlignmentGuides Method

Diagram.DrawAlignmentGuides Method
[image]

Draws the current alignment guides.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void DrawAlignmentGuides (
IGraphics graphics
)

Visual Basic [image] Copy Code

Public Sub DrawAlignmentGuides ( _
graphics As IGraphics _
)

Parameters

graphics

An IGraphics drawing surface.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.DrawInteraction Method

Diagram.DrawInteraction Method
[image]

Draws the items that the user is currently modifying.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void DrawInteraction (
IGraphics graphics,
RenderOptions options,
RectangleF clipRect
)

Visual Basic [image] Copy Code

Public Sub DrawInteraction ( _
graphics As IGraphics, _
options As RenderOptions, _
clipRect As RectangleF _
)

Parameters

graphics
The IGraphics surface to draw the items on.
options
A RenderOptions object specifying options for the drawing operation.
clipRect
A RectangleF specifying the current clipping rectangle.

Remarks

This method draws the items that are currently being modified by the user.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.DrawLayer Method

Diagram.DrawLayer Method
[image]

Renders all diagram items to the specified graphics.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void DrawLayer (
IGraphics graphics,
RectangleF backgroundRect,
int layerIndex,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Sub DrawLayer( _
graphics As IGraphics, _
backgroundRect As RectangleF, _
layerIndex As Integer, _
options As RenderOptions _
)

Parameters

graphics

backgroundRect

layerIndex

options

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.DrawStyledText Method

Diagram.DrawStyledText Method
[image]

Draws a formatted text string, the same way text is drawn in shape nodes whose EnableStyledText property is set to true. This method lets you display styled text in custom-drawn nodes or links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void DrawStyledText (
IGraphics graphics,
string text,
Font font,
Brush textBrush,
RectangleF textBounds,
StringFormat format
)

Visual Basic [image] Copy Code

Public Shared Sub DrawStyledText( _
graphics As IGraphics, _
text As String, _
font As Font, _
textBrush As Brush, _
textBounds As RectangleF, _
format As StringFormat _
)

Parameters

graphics
The IGraphics canvas on which to draw.
text

The text that should be drawn, including formatting tags.

font

The font used to draw the text.

textBrush

The brush used to draw the text.

textBounds

The bounds of the text layout rectangle.

format

Specifies the text alignment.

Remarks

You might use this method when you custom-draw shape nodes and still need to use the EnableStyledText rendering functionality of MvcDiagram.

Example

The following sample code illustrates how to manually render styled text.

C# [image] Copy Code

private void diagram_DrawNode(object sender, DrawNodeEventArgs e)
{
Diagram.DrawStyledText(e.Graphics, "<b>test</b> <i>test</i>",
diagram.Font, Brushes.Black, e.Node.Bounds, StringFormat.GenericDefault);
}

Visual Basic [image] Copy Code

Private Sub diagram_DrawNode(ByVal sender As Object, ByVal e As DrawNodeEventArgs) Handles diagram.DrawNode

Diagram.DrawStyledText(e.Graphics, "<b>test</b> <i>test</i>", _
diagram.Font, Brushes.Black, e.Node.Bounds, StringFormat.GenericDefault)

End Sub

See Also

Diagram Members
Diagram Class
DrawNode Event


MindFusion.Diagramming.Diagram.ExecuteCommand Method

Diagram.ExecuteCommand Method
[image]

Executes the specified command on this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ExecuteCommand (
Command cmd
)

Visual Basic [image] Copy Code

Public Sub ExecuteCommand ( _
cmd As Command _
)

Parameters

cmd

The Command to execute.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.FindGroup Method

Diagram.FindGroup Method
[image]

Finds the group that has the specified tag value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Group FindGroup (
Object tagValue
)

Visual Basic [image] Copy Code

Public Function FindGroup ( _
tagValue As Object _
) As Group

Parameters

tagValue
A .NET object assigned as a tag and characterizing the group to be searched for.

Return Value

The Group instance if found; otherwise, null (Nothing in Visual Basic).

Remarks

Use this method to find a group that has been marked earlier with the specified tag.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
FindLink Method
FindNode Method


MindFusion.Diagramming.Diagram.FindLink Method

Diagram.FindLink Method
[image]

Finds the link that has the specified tag value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink FindLink (
Object tagValue
)

Visual Basic [image] Copy Code

Public Function FindLink ( _
tagValue As Object _
) As DiagramLink

Parameters

tagValue
A .NET object assigned as a tag and characterizing the link to be searched for.

Return Value

The DiagramLink instance if found; otherwise, null (Nothing in Visual Basic).

Remarks

Use this method to find a link that has been marked earlier with the specified tag.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
FindNode Method
FindGroup Method
FindLinkById Method


MindFusion.Diagramming.Diagram.FindLinkById Method

Diagram.FindLinkById Method
[image]

Finds the link that has the specified id value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink FindLinkById (
Object id
)

Visual Basic [image] Copy Code

Public Function FindLinkById( _
id As Object _
) As DiagramLink

Parameters

id
A .NET object used as a link id.

Return Value

A DiagramLink whose Id equals to the specified value if such link exists; otherwise, null (Nothing in Visual Basic).

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
FindNodeById Method
FindLink Method


MindFusion.Diagramming.Diagram.FindNode Method

Diagram.FindNode Method
[image]

Finds the node that has the specified tag value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode FindNode (
Object tagValue
)

Visual Basic [image] Copy Code

Public Function FindNode ( _
tagValue As Object _
) As DiagramNode

Parameters

tagValue
A .NET object assigned as a tag and characterizing the node to be searched for.

Return Value

The DiagramNode instance if found; otherwise, null (Nothing in Visual Basic).

Remarks

Use this method to find a node that has been marked earlier with the specified tag.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
FindLink Method
FindGroup Method
FindNodeById Method


MindFusion.Diagramming.Diagram.FindNodeById Method

Diagram.FindNodeById Method
[image]

Finds the node that has the specified id value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode FindNodeById (
Object id
)

Visual Basic [image] Copy Code

Public Function FindNodeById( _
id As Object _
) As DiagramNode

Parameters

id
A .NET object used as a node id.

Return Value

A DiagramNode whose Id equals to the specified value if such node exists; otherwise, null (Nothing in Visual Basic).

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
FindLinkById Method
FindNode Method


MindFusion.Diagramming.Diagram.GetContentBounds Method

Diagram.GetContentBounds Method
[image]

Returns the smallest rectangle that bounds all diagram objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF GetContentBounds (
bool forPrint,
bool onlyVisible
)

Visual Basic [image] Copy Code

Public Function GetContentBounds( _
forPrint As Boolean, _
onlyVisible As Boolean _
) As RectangleF

Parameters

forPrint

Specifies whether only printable items should be considered.

onlyVisible

Specifies whether only visible items should be considered.

Return Value

The smallest rectangle that bounds all diagram items.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetItemAt Method

Diagram.GetItemAt Method
[image]

Finds and returns the top-most diagram item that lies at the specified location.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem GetItemAt (
PointF pt,
bool exclLocked
)

Visual Basic [image] Copy Code

Public Function GetItemAt ( _
pt As PointF, _
exclLocked As Boolean _
) As DiagramItem

Parameters

pt

A PointF instance identifying a diagram location.

exclLocked

Specifies whether to ignore locked items.

Return Value

The DiagramItem found or null (Nothing in Visual Basic) if no item has been found.

Remarks

Call the method to get the item at a certain location in the diagram. The method searches starting from the top of z-order and returns the first item found.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
GetNodeAt Method
GetLinkAt Method
LinkHitDistance Property


MindFusion.Diagramming.Diagram.GetLinkAt Method

Diagram.GetLinkAt Method
[image]

Finds and returns the link that lies at the specified location.

Overload List

Name | Description
Diagram.GetLinkAt (PointF, Single) | Finds and returns the top-most link that lies at the specified location.
Diagram.GetLinkAt (PointF, Single, Boolean) | Finds and returns the top-most link that lies at the specified location, optionally excluding locked links from the search.
Diagram.GetLinkAt (PointF, Single, Boolean, Int32@) | Finds and returns the top-most link that lies at the specified location, optionally excluding locked links from the search. The zero-based index of the exact link segment at the specified position is also returned.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
GetNodeAt Method
GetItemAt Method


MindFusion.Diagramming.Diagram.GetLinkAt Method (PointF, Single)

Diagram.GetLinkAt Method (PointF, Single)
See Also
[image]

Finds and returns the top-most link that lies at the specified location.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink GetLinkAt (
PointF pt,
float maxDist
)

Visual Basic [image] Copy Code

Public Function GetLinkAt ( _
pt As PointF, _
maxDist As Single _
) As DiagramLink

Parameters

pt
A PointF instance identifying a diagram location.
maxDist
The maximal distance between the point and a link, within which to consider the point as lying on the link.

Return Value

The DiagramLink found or a null reference (Nothing in Visual Basic) if no item has been found.

Remarks

Call the method to get the link at a certain place in the document. The method searches starting from the top of z-order and returns the first link found. The specified point might not be laying exactly on the link, but within a certain threshold distance from it. This threshold is specified through the second parameter.

See Also

GetLinkAt Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
GetNodeAt Method
GetItemAt Method
GetLinksAt Method


MindFusion.Diagramming.Diagram.GetLinkAt Method (PointF, Single, Boolean)

Diagram.GetLinkAt Method (PointF, Single, Boolean)
See Also
[image]

Finds and returns the top-most link that lies at the specified location, optionally excluding locked links from the search.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink GetLinkAt (
PointF pt,
float maxDist,
bool exclLocked
)

Visual Basic [image] Copy Code

Public Function GetLinkAt ( _
pt As PointF, _
maxDist As Single, _
exclLocked As Boolean _
) As DiagramLink

Parameters

pt
A PointF instance identifying a diagram location.
maxDist
The maximal distance between the point and a link, within which to consider the point as lying on the link.
exclLocked

Specifies that locked links should be ignored by the search.

Return Value

The DiagramLink found or a null reference (Nothing in Visual Basic) if no item has been found.

Remarks

Call the method to get the link at a certain place in the document. The method searches starting from the top of z-order and returns the first link found. The specified point might not be laying exactly on the link, but within a certain threshold distance from it. This threshold is specified through the second parameter. Locked and invisible links can be skipped from the search by setting the third parameter to true.

See Also

GetLinkAt Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
GetItemAt Method
GetNodeAt Method


MindFusion.Diagramming.Diagram.GetLinkAt Method (PointF, Single, Boolean, Int32@)

Diagram.GetLinkAt Method (PointF, Single, Boolean, Int32@)
See Also
[image]

Finds and returns the top-most link that lies at the specified location, optionally excluding locked links from the search. The zero-based index of the exact link segment at the specified position is also returned.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink GetLinkAt (
PointF pt,
float maxDist,
bool exclLocked,
ref int segmNum
)

Visual Basic [image] Copy Code

Public Function GetLinkAt ( _
pt As PointF, _
maxDist As Single, _
exclLocked As Boolean, _
ByRef segmNum As Integer _
) As DiagramLink

Parameters

pt
A PointF instance identifying a diagram location.
maxDist
The maximal distance between the point and a link, within which to consider the point as lying on the link.
exclLocked

Specifies that locked links should be ignored by the search.

segmNum
Returns the index of the link segment that lies at the specified point.

Return Value

The DiagramLink found or a null reference (Nothing in Visual Basic) if no item has been found.

Remarks

Call the method to get the link at a certain place in the document. The method searches starting from the top of z-order and returns the first link found. The specified point might not be laying exactly on the link, but within a certain threshold distance from it. This threshold is specified through the second parameter. Locked and invisible links can be skipped from the search by setting the third parameter to true. The link's segment closest to the point is returned through the fourth parameter.

See Also

GetLinkAt Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
GetNodeAt Method
GetItemAt Method


MindFusion.Diagramming.Diagram.GetLinksAt Method

Diagram.GetLinksAt Method
[image]

Returns the links that contain the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection GetLinksAt (
PointF point
)

Visual Basic [image] Copy Code

Public Function GetLinksAt ( _
point As PointF _
) As DiagramLinkCollection

Parameters

point

A PointF structure specifying the location at which to look for links.

Return Value

A DiagramLinkCollection instance containing the links lying at the specified location.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
GetLinkAt Method
GetNodesAt Method


MindFusion.Diagramming.Diagram.GetNearestNode Method

Diagram.GetNearestNode Method
[image]

Returns the node nearest to the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode GetNearestNode (
PointF pt,
float maxDistance,
DiagramNode ignored
)

Visual Basic [image] Copy Code

Public Function GetNearestNode ( _
pt As PointF, _
maxDistance As Single, _
ignored As DiagramNode _
) As DiagramNode

Parameters

point

maxDistance
The maximum distance from the point at which to look for nodes.
ignored
A node that should be ignored.

Return Value

The DiagramNode nearest to the specified point.

Remarks

The last argument is useful when calling this method from NodeCreated and NodeModified handlers and the affected node should not be included in the search.

See Also

Diagram Members
Diagram Class
GetNodeAt Method


MindFusion.Diagramming.Diagram.GetNodeAt Method

Diagram.GetNodeAt Method
[image]

Gets the node that lies at the specified location.

Overload List

Name | Description
Diagram.GetNodeAt (PointF) | Returns the topmost node that lies at the specified position.
Diagram.GetNodeAt (PointF, Boolean) | Returns the topmost node that lies at the specified position.
Diagram.GetNodeAt (PointF, Boolean, Boolean) | Finds and returns the top-most node that lies at the specified location, optionally excluding locked and/or selected nodes from the search.
Diagram.GetNodeAt (PointF, Boolean, Boolean, Single) | Finds and returns the top-most node that lies within the specified threshold from the specified location, optionally excluding locked and/or selected nodes from the search.
Diagram.GetNodeAt (PointF, Single) | Finds and returns the top-most node that lies within the specified threshold from the specified location.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
GetItemAt Method
GetLinkAt Method


MindFusion.Diagramming.Diagram.GetNodeAt Method (PointF)

Diagram.GetNodeAt Method (PointF)
See Also
[image]

Returns the topmost node that lies at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode GetNodeAt (
PointF point
)

Visual Basic [image] Copy Code

Public Function GetNodeAt ( _
point As PointF _
) As DiagramNode

Parameters

point
A PointF instance identifying a diagram location.

Return Value

The DiagramNode found or a null reference (Nothing in Visual Basic) if no item has been found.

Remarks

The method starts searching from the top of the z-order and returns the first node that contains the specified point.

See Also

GetNodeAt Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
GetLinkAt Method
GetItemAt Method
GetNearestNode Method


MindFusion.Diagramming.Diagram.GetNodeAt Method (PointF, Boolean)

Diagram.GetNodeAt Method (PointF, Boolean)
See Also
[image]

Returns the topmost node that lies at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode GetNodeAt (
PointF point,
bool excludeLocked
)

Visual Basic [image] Copy Code

Public Function GetNodeAt( _
point As PointF, _
excludeLocked As Boolean _
) As DiagramNode

Parameters

point

A PointF specifying a diagram point in logical coordinates.

excludeLocked

Specifies whether locked nodes should be excluded from the search.

Return Value

A DiagramNode instance if a node lies at the specified location, otherwise null.

See Also

GetNodeAt Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetNodeAt Method (PointF, Boolean, Boolean)

Diagram.GetNodeAt Method (PointF, Boolean, Boolean)
See Also
[image]

Finds and returns the top-most node that lies at the specified location, optionally excluding locked and/or selected nodes from the search.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode GetNodeAt (
PointF point,
bool excludeLocked,
bool excludeSelected
)

Visual Basic [image] Copy Code

Public Function GetNodeAt ( _
point As PointF, _
excludeLocked As Boolean, _
excludeSelected As Boolean _
) As DiagramNode

Parameters

point
A PointF instance identifying a diagram location.
excludeLocked
true if nodes that are locked should be omitted by searching; otherwise, false.
excludeSelected
true if nodes that are selected should be omitted by searching; otherwise, false.

Return Value

The DiagramNode found or a null reference (Nothing in Visual Basic) if no node has been found.

Remarks

This method gives you the possibility to specify search options when looking for a node occupying some location in the diagram document. The method searches starting from the top of z-order and returns the first object found.

See Also

GetNodeAt Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
GetItemAt Method
GetLinkAt Method
GetNearestNode Method


MindFusion.Diagramming.Diagram.GetNodeAt Method (PointF, Boolean, Boolean, Single)

Diagram.GetNodeAt Method (PointF, Boolean, Boolean, Single)
See Also
[image]

Finds and returns the top-most node that lies within the specified threshold from the specified location, optionally excluding locked and/or selected nodes from the search.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode GetNodeAt (
PointF point,
bool excludeLocked,
bool excludeSelected,
float threshold
)

Visual Basic [image] Copy Code

Public Function GetNodeAt ( _
point As PointF, _
excludeLocked As Boolean, _
excludeSelected As Boolean, _
threshold As Single _
) As DiagramNode

Parameters

point
A PointF instance identifying a diagram location.
excludeLocked
true if nodes that are locked should be omitted by searching; otherwise, false.
excludeSelected
true if nodes that are selected should be omitted by searching; otherwise, false.
threshold

Allowed distance from the node.

Return Value

The DiagramNode found or a null reference (Nothing in Visual Basic) if no node has been found.

Remarks

This method gives you the possibility to specify search options when looking for a node occupying some location in the diagram document. The method searches starting from the top of z-order and returns the first object found.

See Also

GetNodeAt Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
GetLinkAt Method
GetItemAt Method
GetNearestNode Method


MindFusion.Diagramming.Diagram.GetNodeAt Method (PointF, Single)

Diagram.GetNodeAt Method (PointF, Single)
See Also
[image]

Finds and returns the top-most node that lies within the specified threshold from the specified location.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode GetNodeAt (
PointF point,
float threshold
)

Visual Basic [image] Copy Code

Public Function GetNodeAt ( _
point As PointF, _
threshold As Single _
) As DiagramNode

Parameters

point
A PointF instance identifying a diagram location.
threshold

Allowed distance from the node.

Return Value

The DiagramNode found or a null reference (Nothing in Visual Basic) if no node has been found.

Remarks

This method gives you the possibility to specify search options when looking for a node occupying some location in the diagram document. The method searches starting from the top of z-order and returns the first object found.

See Also

GetNodeAt Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
GetItemAt Method
GetLinkAt Method
GetNearestNode Method


MindFusion.Diagramming.Diagram.GetNodesAt Method

Diagram.GetNodesAt Method
[image]

Returns the nodes that contain the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeCollection GetNodesAt (
PointF point
)

Visual Basic [image] Copy Code

Public Function GetNodesAt ( _
point As PointF _
) As DiagramNodeCollection

Parameters

point
A PointF instance identifying a diagram location.

Return Value

An instance of the DiagramNodeCollection class containing all found nodes; null (Nothing in Visual Basic) if no node has been found.

Remarks

This method gives you the possibility to specify search options when looking for the nodes occupying some location in the diagram document.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
GetItemAt Method
GetLinksAt Method


MindFusion.Diagramming.Diagram.GetValue Method

Diagram.GetValue Method
[image]

Gets the effective value of the style property with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Object GetValue (
string name
)

Visual Basic [image] Copy Code

Protected Function GetValue( _
name As String _
) As Object

Parameters

name

The name of the property to get.

Return Value

An object representing the effective property value.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.HandleKeyDown Method

Diagram.HandleKeyDown Method
[image]

Propagates keyboard input to interested manipulators and components.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool HandleKeyDown (
int keyCode,
int modifiers
)

Visual Basic [image] Copy Code

Public Function HandleKeyDown( _
keyCode As Integer, _
modifiers As Integer _
) As Boolean

Parameters

keyCode
An integer value representing the key that was pressed.
modifiers
An integer value representing the modifier keys that were pressed.

Return Value

true if a component or manipulator handled the event; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.HandleKeyPress Method

Diagram.HandleKeyPress Method
[image]

Propagates keyboard input to interested manipulators.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void HandleKeyPress (
char keyChar
)

Visual Basic [image] Copy Code

Public Sub HandleKeyPress( _
keyChar As Char _
)

Parameters

keyChar
The character representation of the pressed key.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.HandleKeyUp Method

Diagram.HandleKeyUp Method
[image]

Propagates keyboard input to interested components.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void HandleKeyUp (
int keyCode,
int modifiers
)

Visual Basic [image] Copy Code

Public Sub HandleKeyUp( _
keyCode As Integer, _
modifiers As Integer _
)

Parameters

keyCode
An integer value representing the key that was pressed.
modifiers
An integer value representing the modifier keys that were pressed.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.HandleMouseMove Method

Diagram.HandleMouseMove Method
[image]

Propagates mouse input to interested manipulators.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CursorHint HandleMouseMove (
PointF pt
)

Visual Basic [image] Copy Code

Public Function HandleMouseMove ( _
pt As PointF _
) As CursorHint

Parameters

pt
The position of the mouse, expressed in document coordinates.

Return Value

A member of the CursorHint enumeration specifying the cursor to display at the specified point.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.HitTestComponents Method

Diagram.HitTestComponents Method
[image]

Tests whether the specified point is within a component of a diagram item and returns this component.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ComponentBase HitTestComponents (
PointF point
)

Visual Basic [image] Copy Code

Public Function HitTestComponents ( _
point As PointF _
) As ComponentBase

Parameters

point
A PointF representing the point to test, expressed in document coordinates.

Return Value

A ComponentBase instance representing the topmost component at the specified point.

Remarks

This method ignores components with any of the following properties set to false: IsHitTestVisible, IsEnabled, IsInteractive.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.HitTestManipulators Method

Diagram.HitTestManipulators Method
[image]

Tests whether the specified point is within the manipulator of a diagram object and triggers the manipulator.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Manipulator HitTestManipulators (
PointF pt
)

Visual Basic [image] Copy Code

Public Function HitTestManipulators( _
pt As PointF _
) As Manipulator

Parameters

pt

A PointF instance specifying the point to test.

Return Value

true to indicate whether there is a manipulator at the specified location; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Invalidate Method

Diagram.Invalidate Method
[image]

Invalidates the diagram or a region of the diagram, causing it to be repainted.

Overload List

Name | Description
Diagram.Invalidate () | Invalidates the entire diagram.
Diagram.Invalidate (Boolean) | Invalidates the entire diagram and optionally repaints the back-buffer image.
Diagram.Invalidate (Object, RectangleF) | Invalidates the specified rectangle of the diagram, causing it to be repainted.
Diagram.Invalidate (RectangleF) | Invalidates the specified rectangle of the diagram, causing it to be repainted.

See Also

Diagram Members
Diagram Class
DiagramView.RecreateCacheImage Method


MindFusion.Diagramming.Diagram.Invalidate Method ()

Diagram.Invalidate Method ()
See Also
[image]

Invalidates the entire diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Invalidate ()

Visual Basic [image] Copy Code

Public Sub Invalidate ()

Remarks

This method raises the Repaint event. DiagramView objects handle Repaint by redrawing the specified diagram region.

See Also

Invalidate Method Overload List
Diagram Members
Diagram Class
DiagramView.RecreateCacheImage Method


MindFusion.Diagramming.Diagram.Invalidate Method (Boolean)

Diagram.Invalidate Method (Boolean)
See Also
[image]

Invalidates the entire diagram and optionally repaints the back-buffer image.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Invalidate (
bool redrawCacheImage
)

Visual Basic [image] Copy Code

Public Sub Invalidate( _
redrawCacheImage As Boolean _
)

Parameters

redrawCacheImage
A boolean value specifying whether the diagram cache image used during modification should be re-created.

Remarks

This method raises the Repaint event. DiagramView objects handle Repaint by redrawing the specified diagram region.

See Also

Invalidate Method Overload List
Diagram Members
Diagram Class
DiagramView.RecreateCacheImage Method


MindFusion.Diagramming.Diagram.Invalidate Method (Object, RectangleF)

Diagram.Invalidate Method (Object, RectangleF)
See Also
[image]

Invalidates the specified rectangle of the diagram, causing it to be repainted.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Invalidate (
Object sender,
RectangleF invalidRect
)

Visual Basic [image] Copy Code

Public Sub Invalidate( _
sender As Object, _
invalidRect As RectangleF _
)

Parameters

sender
The object that causes the diagram invalidation.
invalidRect
A RectangleF instance specifying the region that should be repainted. If not specified, the whole diagram will be repainted.

Remarks

This method raises the Repaint event. DiagramView objects handle Repaint by redrawing the specified diagram region.

See Also

Invalidate Method Overload List
Diagram Members
Diagram Class
DiagramView.RecreateCacheImage Method


MindFusion.Diagramming.Diagram.Invalidate Method (RectangleF)

Diagram.Invalidate Method (RectangleF)
See Also
[image]

Invalidates the specified rectangle of the diagram, causing it to be repainted.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Invalidate (
RectangleF invalidRect
)

Visual Basic [image] Copy Code

Public Sub Invalidate( _
invalidRect As RectangleF _
)

Parameters

invalidRect
A RectangleF instance specifying the region that should be repainted. If not specified, the whole diagram will be repainted.

Remarks

This method raises the Repaint event. DiagramView objects handle Repaint by redrawing the specified diagram region.

See Also

Invalidate Method Overload List
Diagram Members
Diagram Class
DiagramView.RecreateCacheImage Method


MindFusion.Diagramming.Diagram.InvalidateZOrder Method

Diagram.InvalidateZOrder Method
[image]

Forces a new sort of the Z order list before next redraw.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void InvalidateZOrder ()

Visual Basic [image] Copy Code

Public Sub InvalidateZOrder ()

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.IsItemInteractive Method

Diagram.IsItemInteractive Method
[image]

Checks if the specified item can be modified interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsItemInteractive (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function IsItemInteractive( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem to check.

Return Value

true, if the item is currently visible and unlocked and it is not associated with a hidden or locked layer; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.IsItemLocked Method

Diagram.IsItemLocked Method
[image]

Checks if the specified item is locked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsItemLocked (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function IsItemLocked( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem to check.

Return Value

true, if the item's Locked property is set to true or if the item is associated with a locked layer; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.IsItemVisible Method

Diagram.IsItemVisible Method
[image]

Checks if the specified item is currently visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsItemVisible (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function IsItemVisible( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem to check.

Return Value

true if the item's Visible property is set to true and the item is not associated with a hidden layer; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LoadFromFile Method

Diagram.LoadFromFile Method
[image]

Loads the contents of an existing diagram file into the control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromFile (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFromFile( _
fileName As String _
)

Parameters

fileName
The name of the file the data shall be read from.

Remarks

The method reads previously saved diagram. It is implemented by creating a stream on the input file, then invoking the LoadFromStream method. It throws a FileLoadException if the file given as argument does not adhere to the proper format. Diagrams can be saved in a file using the SaveToFile method.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LoadFromStream
LoadFromXml
SerializationBinder Property


MindFusion.Diagramming.Diagram.LoadFromStream Method

Diagram.LoadFromStream Method
[image]

Loads a diagram from the specified stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromStream (
Stream stream
)

Visual Basic [image] Copy Code

Public Sub LoadFromStream( _
stream As Stream _
)

Parameters

stream
An instance of a Stream-derived class.

Remarks

The method loads previously saved diagram from a stream. Stream wraps sequences of bytes, such as files, memory buffers, TCP sockets and more. The method throws exception if the stream given as argument does not contain data of the proper format. Diagrams can be saved in a stream using the SaveToStream method.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SaveToStream
LoadFromFile
LoadFromXml
SerializationBinder Property


MindFusion.Diagramming.Diagram.LoadFromString Method

Diagram.LoadFromString Method
[image]

Decodes diagram contents from a string that was created with SaveToString.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromString (
string str
)

Visual Basic [image] Copy Code

Public Sub LoadFromString( _
str As String _
)

Parameters

str

A string containing the serialized diagram contents.

Remarks

Loads a diagram document from a string. The string must have been created by the SaveToString method.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SaveToStream
LoadFromFile
SerializationBinder Property


MindFusion.Diagramming.Diagram.LoadFromXml Method

Diagram.LoadFromXml Method
[image]

Loads the contents of an XML diagram document into the control.

Overload List

Name | Description
Diagram.LoadFromXml (String) | Loads the contents of the XML diagram document from the specified file into the control.
Diagram.LoadFromXml (String, Boolean) | Loads the diagram from an XML file.
Diagram.LoadFromXml (XmlDocument) | Loads the contents of the XML diagram document represented by the specified XmlDocument into the control.
Diagram.LoadFromXml (XmlDocument, Boolean) | Loads the diagram from an XML document.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LoadFromFile Method
SaveToXml Method


MindFusion.Diagramming.Diagram.LoadFromXml Method (String)

Diagram.LoadFromXml Method (String)
See Also
[image]

Loads the contents of the XML diagram document from the specified file into the control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
fileName As String _
)

Parameters

fileName
The name of the XML file the data should be read from.

Remarks

The method reads a diagram previously saved via the SaveToXml method. This method is implemented by loading an XmlDocument from the specified file and calling the LoadFromXml overload.

See Also

LoadFromXml Method Overload List
Diagram Members
Diagram Class
SaveToXml Method


MindFusion.Diagramming.Diagram.LoadFromXml Method (String, Boolean)

Diagram.LoadFromXml Method (String, Boolean)
See Also
[image]

Loads the diagram from an XML file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
string fileName,
bool loadDiagramProperties
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
fileName As String, _
loadDiagramProperties As Boolean _
)

Parameters

fileName
The name of the XML file the data should be read from.
loadDiagramProperties
true to load values of the diagram properties; false to load only the diagram items.

Remarks

The method reads a diagram previously saved via the SaveToXml method. This method is implemented by loading an XmlDocument from the specified file and calling the LoadFromXml overload.

See Also

LoadFromXml Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LoadFromXml Method (XmlDocument)

Diagram.LoadFromXml Method (XmlDocument)
See Also
[image]

Loads the contents of the XML diagram document represented by the specified XmlDocument into the control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void LoadFromXml (
XmlDocument document
)

Visual Basic [image] Copy Code

Public Overridable Sub LoadFromXml( _
document As XmlDocument _
)

Parameters

document
A .NET XmlDocument object from which to load the diagram data.

Remarks

The method reads a diagram previously saved via the SaveToXml method.

See Also

LoadFromXml Method Overload List
Diagram Members
Diagram Class
SaveToXml Method


MindFusion.Diagramming.Diagram.LoadFromXml Method (XmlDocument, Boolean)

Diagram.LoadFromXml Method (XmlDocument, Boolean)
See Also
[image]

Loads the diagram from an XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void LoadFromXml (
XmlDocument document,
bool loadDiagramProperties
)

Visual Basic [image] Copy Code

Public Overridable Sub LoadFromXml( _
document As XmlDocument, _
loadDiagramProperties As Boolean _
)

Parameters

document
A .NET XmlDocument object from which to load the diagram data.
loadDiagramProperties
true to load values of the diagram properties; false to load only the diagram items.

Remarks

The method reads a diagram previously saved via the SaveToXml method.

See Also

LoadFromXml Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.MeasureString Method

Diagram.MeasureString Method
[image]

Measures a text taking into consideration the current affine transform of the diagram.

Overload List

Name | Description
Diagram.MeasureString (String, Font, Int32, StringFormat) | Measures the specified text when drawn with the specified font in an area with the specified width taking into consideration the current affine transform of the diagram.
Diagram.MeasureString (String, Font, RectangleF, StringFormat, Int32@, Int32@) | Measures the specified text when drawn with the specified font in the specified rectangle area taking into consideration the current affine transform of the diagram.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.MeasureString Method (String, Font, Int32, StringFormat)

Diagram.MeasureString Method (String, Font, Int32, StringFormat)
See Also
[image]

Measures the specified text when drawn with the specified font in an area with the specified width taking into consideration the current affine transform of the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SizeF MeasureString (
string text,
Font font,
int maxWidth,
StringFormat textFormat
)

Visual Basic [image] Copy Code

Public Function MeasureString( _
text As String, _
font As Font, _
maxWidth As Integer, _
textFormat As StringFormat _
) As SizeF

Parameters

text
The string to measure.
font
The font of the string.
maxWidth
The maximum width of the string.
textFormat
A StringFormat object that represents formatting information, such as line spacing, for the string.

Return Value

This method returns a SizeF structure that represents the size of the string text when drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.MeasureString Method (String, Font, RectangleF, StringFormat, Int32@, Int32@)

Diagram.MeasureString Method (String, Font, RectangleF, StringFormat, Int32@, Int32@)
See Also
[image]

Measures the specified text when drawn with the specified font in the specified rectangle area taking into consideration the current affine transform of the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SizeF MeasureString (
string text,
Font font,
RectangleF layoutArea,
StringFormat stringFormat,
out int charactersFitted,
out int linesFilled
)

Visual Basic [image] Copy Code

Public Function MeasureString( _
text As String, _
font As Font, _
layoutArea As RectangleF, _
stringFormat As StringFormat, _
<System.Runtime.InteropServices.Out()> ByRef charactersFitted As Integer, _
<System.Runtime.InteropServices.Out()> ByRef linesFilled As Integer _
) As SizeF

Parameters

text
The string to measure.
font
The font of the string.
layoutArea
A RectangleF structure that specifies the maximum layout area for the text.
stringFormat
A StringFormat object that represents formatting information, such as line spacing, for the string.
charactersFitted

linesFilled

Return Value

This method returns a RectangleF structure that represents the size of the string text when drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Navigate Method

Diagram.Navigate Method
[image]

Selects the nearest item in the specified direction.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Navigate (
PointF directionVector
)

Visual Basic [image] Copy Code

Public Sub Navigate( _
directionVector As PointF _
)

Parameters

directionVector
A PointF object specifying the direction vector.

Remarks

This method can be used to let users navigate through the diagram using the keyboard keys.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.NewInstance Method

Diagram.NewInstance Method
[image]

Custom Diagram classes must override this method to return an instance of their type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Diagram NewInstance ()

Visual Basic [image] Copy Code

Public Overridable Function NewInstance () As Diagram

Return Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.PasteSelection Method

Diagram.PasteSelection Method
[image]

Adds the specified items and groups to the specified diagram document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool PasteSelection (
Diagram doc,
SelectionCopy data,
CompositeCmd cmd,
float dx,
float dy
)

Visual Basic [image] Copy Code

Public Function PasteSelection ( _
doc As Diagram, _
data As SelectionCopy, _
cmd As CompositeCmd, _
dx As Single, _
dy As Single _
) As Boolean

Parameters

doc
A Diagram object to which the items should be added.
data
A SelectionCopy object returned by a previous call to CopySelection.
cmd
A CompositeCmd object where the items state should be recorded for later undo or redo.
dx
Horizontal offset of pasted items from their original positions.
dy
Vertical offset of pasted items from their original positions.

Return Value

true if data contains any items; otherwise, false.

Remarks

This method can be used in conjunction with CopySelection to copy selected items from one Diagram instance to another.

See Also

Diagram Members
Diagram Class
CopySelection


MindFusion.Diagramming.Diagram.PixelToUnit Method

Diagram.PixelToUnit Method
[image]

Converts the specified point from client to document coordinates ignoring the current scale transformation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointF PixelToUnit (
Point point
)

Visual Basic [image] Copy Code

Public Function PixelToUnit( _
point As Point _
) As PointF

Parameters

point

The Point instance to convert.

Return Value

A PointF representing the diagram coordinates of the client point specified as an argument.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseCellTextEdited Method

Diagram.RaiseCellTextEdited Method
[image]

Raises the CellTextEdited event .

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseCellTextEdited (
TableNode.Cell cell,
string oldText,
string newText,
int column,
int row
)

Visual Basic [image] Copy Code

Public Sub RaiseCellTextEdited ( _
cell As TableNode.Cell, _
oldText As String, _
newText As String, _
column As Integer, _
row As Integer _
)

Parameters

cell

The TableNode.Cell related to the event.

oldText

The old text of the cell.

newText

The new text of the cell.

column

The zero-based index of the table column related to the event.

row

The zero-based index of the table row related to the event.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseCellTextEditing Method

Diagram.RaiseCellTextEditing Method
[image]

Raises the CellTextEditing event to validate entering in-place editing mode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RaiseCellTextEditing (
TableNode table,
int column,
int row
)

Visual Basic [image] Copy Code

Public Function RaiseCellTextEditing ( _
table As TableNode, _
column As Integer, _
row As Integer _
) As Boolean

Parameters

table

The TableNode related to the event.

column

The zero-based index of the table column related to the event.

row

The zero-based index of the table row related to the event.

Return Value

true if the in-place editing operation has been confirmed; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseClicked Method

Diagram.RaiseClicked Method
[image]

Raises the Clicked event of the diagram or one of the *Clicked events related to diagram items.

Overload List

Name | Description
Diagram.RaiseClicked (DiagramItem, PointF, MouseButton) | Raises the appropriate *Clicked event according to the type of the specified item.
Diagram.RaiseClicked (MouseButton, PointF) | Raises the Clicked event of the Diagram class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseClicked Method (DiagramItem, PointF, MouseButton)

Diagram.RaiseClicked Method (DiagramItem, PointF, MouseButton)
See Also
[image]

Raises the appropriate *Clicked event according to the type of the specified item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseClicked (
DiagramItem item,
PointF mousePosition,
MouseButton mouseButton
)

Visual Basic [image] Copy Code

Public Sub RaiseClicked ( _
item As DiagramItem, _
mousePosition As PointF, _
mouseButton As MouseButton _
)

Parameters

item

The DiagramItem related to the event.

mousePosition

The current mouse position, in document coordinates.

mouseButton

The mouse button related to the event.

See Also

RaiseClicked Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseClicked Method (MouseButton, PointF)

Diagram.RaiseClicked Method (MouseButton, PointF)
See Also
[image]

Raises the Clicked event of the Diagram class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseClicked (
MouseButton mouseButton,
PointF mousePosition
)

Visual Basic [image] Copy Code

Public Sub RaiseClicked ( _
mouseButton As MouseButton, _
mousePosition As PointF _
)

Parameters

mouseButton
The mouse button related to the event.
mousePosition

The current cursor position, in document coordinates.

See Also

RaiseClicked Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseCreated Method

Diagram.RaiseCreated Method
[image]

Raises the appropriate *Created event according to the type of the specified item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseCreated (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Sub RaiseCreated ( _
item As DiagramItem _
)

Parameters

item

The DiagramItem related to the event.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseDeleting Method

Diagram.RaiseDeleting Method
[image]

Raises the appropriate *Deleting event according to the type of the specified item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RaiseDeleting (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function RaiseDeleting ( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem related to the event.

Return Value

true if the operation has been confirmed; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseDoubleClicked Method

Diagram.RaiseDoubleClicked Method
[image]

Raises the DoubleClicked event of the diagram or one of the *DoubleClicked events related to diagram items.

Overload List

Name | Description
Diagram.RaiseDoubleClicked (DiagramItem, PointF, MouseButton) | Raises the appropriate *DoubleClicked event according to the type of the specified item.
Diagram.RaiseDoubleClicked (MouseButton, PointF) | Raises the DoubleClicked event of the Diagram class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseDoubleClicked Method (DiagramItem, PointF, MouseButton)

Diagram.RaiseDoubleClicked Method (DiagramItem, PointF, MouseButton)
See Also
[image]

Raises the appropriate *DoubleClicked event according to the type of the specified item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseDoubleClicked (
DiagramItem item,
PointF mousePosition,
MouseButton mouseButton
)

Visual Basic [image] Copy Code

Public Sub RaiseDoubleClicked ( _
item As DiagramItem, _
mousePosition As PointF, _
mouseButton As MouseButton _
)

Parameters

item

The DiagramItem related to the event.

mousePosition

The current cursor position, in document coordinates.

mouseButton

The mouse button related to the event.

See Also

RaiseDoubleClicked Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseDoubleClicked Method (MouseButton, PointF)

Diagram.RaiseDoubleClicked Method (MouseButton, PointF)
See Also
[image]

Raises the DoubleClicked event of the Diagram class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseDoubleClicked (
MouseButton mouseButton,
PointF mousePosition
)

Visual Basic [image] Copy Code

Public Sub RaiseDoubleClicked ( _
mouseButton As MouseButton, _
mousePosition As PointF _
)

Parameters

mouseButton

The mouse button related to the event.

mousePosition

The current cursor position, in document coordinates.

See Also

RaiseDoubleClicked Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseLinkTextEdited Method

Diagram.RaiseLinkTextEdited Method
[image]

Raises the LinkTextEdited event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseLinkTextEdited (
DiagramLink link,
string oldText,
string newText
)

Visual Basic [image] Copy Code

Public Sub RaiseLinkTextEdited ( _
link As DiagramLink, _
oldText As String, _
newText As String _
)

Parameters

link
The DiagramLink related to the event.
oldText

The old text of the link.

newText

The new text of the link.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseLinkTextEditing Method

Diagram.RaiseLinkTextEditing Method
[image]

Raises the LinkTextEditing event to validate entering in-place editing mode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RaiseLinkTextEditing (
DiagramLink link
)

Visual Basic [image] Copy Code

Public Function RaiseLinkTextEditing ( _
link As DiagramLink _
) As Boolean

Parameters

link

The DiagramLink related to the event.

Return Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseMouseHover Method

Diagram.RaiseMouseHover Method
[image]

Raises the appropriate Pointed event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void RaiseMouseHover (
DiagramItem item,
PointF mousePosition
)

Visual Basic [image] Copy Code

Public Overridable Sub RaiseMouseHover( _
item As DiagramItem, _
mousePosition As PointF _
)

Parameters

item

mousePosition

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseNodeTextEdited Method

Diagram.RaiseNodeTextEdited Method
[image]

Raises the NodeTextEdited event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseNodeTextEdited (
DiagramNode node,
string oldText,
string newText
)

Visual Basic [image] Copy Code

Public Sub RaiseNodeTextEdited ( _
node As DiagramNode, _
oldText As String, _
newText As String _
)

Parameters

node

The DiagramNode related to the event.

oldText

The old text of the node.

newText

The new text of the node.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseNodeTextEditing Method

Diagram.RaiseNodeTextEditing Method
[image]

Raises the NodeTextEditing event to validate entering in-place editing mode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RaiseNodeTextEditing (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Function RaiseNodeTextEditing ( _
node As DiagramNode _
) As Boolean

Parameters

node

The DiagramNode related to the event.

Return Value

true if the in-place editing operation has been confirmed; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaisePasted Method

Diagram.RaisePasted Method
[image]

Raises the appropriate Pasted event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaisePasted (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Sub RaisePasted ( _
item As DiagramItem _
)

Parameters

item

The DiagramItem related to the event.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseSelecting Method

Diagram.RaiseSelecting Method
[image]

Raises the appropriate Selecting event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RaiseSelecting (
DiagramItem item,
PointF mousePosition
)

Visual Basic [image] Copy Code

Public Function RaiseSelecting ( _
item As DiagramItem, _
mousePosition As PointF _
) As Boolean

Parameters

item

The DiagramItem related to the event.

mousePosition

The current mouse position, in document coordinates.

Return Value

true if the operation has been confirmed; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseTreeItemTextEditing Method

Diagram.RaiseTreeItemTextEditing Method
[image]

Raises the TreeItemTextEditing event to validate entering inplace edit mode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RaiseTreeItemTextEditing (
TreeViewItem item
)

Visual Basic [image] Copy Code

Public Function RaiseTreeItemTextEditing ( _
item As TreeViewItem _
) As Boolean

Parameters

item
The TreeViewItem instance related to the event.

Return Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseViewRemoved Method

Diagram.RaiseViewRemoved Method
[image]

Raises the ViewRemoved event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseViewRemoved ()

Visual Basic [image] Copy Code

Public Sub RaiseViewRemoved ()

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RegisterClass Method

Diagram.RegisterClass Method
[image]

Registers a diagram item or lane header class for serialization support.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void RegisterClass (
Type classType,
string classId,
int classVersion
)

Visual Basic [image] Copy Code

Public Shared Sub RegisterClass( _
classType As Type, _
classId As String, _
classVersion As Integer _
)

Parameters

classType

A Type instance identifying the class.

classId

A class identifier to use when saving and loading objects of the specified type.

classVersion

A revision number of the serialization format.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RegisterDefaultStyle Method

Diagram.RegisterDefaultStyle Method
[image]

Registers a default style for the objects of the specified type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void RegisterDefaultStyle (
Type type,
Style style
)

Visual Basic [image] Copy Code

Public Shared Sub RegisterDefaultStyle( _
type As Type, _
style As Style _
)

Parameters

type

A System.Type specifying the type of diagram items to which the style applies.

style

The Style to apply to the specified type of items.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RegisterItemClass Method

Diagram.RegisterItemClass Method
[image]

Registers a diagram item class for serialization support.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void RegisterItemClass (
Type itemClass,
string classId,
int classVersion
)

Visual Basic [image] Copy Code

Public Shared Sub RegisterItemClass( _
itemClass As Type, _
classId As String, _
classVersion As Integer _
)

Parameters

itemClass

A Type instance identifying the item class.

classId

A class identifier to use when saving and loading items of the specified type.

classVersion

A revision number of the item's class serialization format.

Remarks

When using custom item types, use this method to enable saving and loading the custom item instances to/from XML or binary files. The class id string is written before each item's data, and when loading items later that string indicates what class instance to create and let it load the subsequent data. The following class identifiers are reserved and should not be used by your application: "std:DiagramLink", "std:ShapeNode", "std:TableNode", "std:ContainerNode" and "std:ControlNode".

The version identifier must be increased when the format in which items are saved changes. It can be used when loading files to let your application load items data from an older format.

Note

All custom item classes must provide a parameterless constructor, or one that takes a Diagram argument. Failing to do so would result in exceptions during the load process, since the diagram will be unable to create items from the custom type.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RemoveItem Method

Diagram.RemoveItem Method
[image]

Invoked by the AddItemCmd and RemoveItemCmd classes to effectively remove the specified item from the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void RemoveItem (
DiagramItem item
)

Visual Basic [image] Copy Code

Protected Sub RemoveItem ( _
item As DiagramItem _
)

Parameters

item

The item being removed from the diagram.

See Also

Diagram Members
Diagram Class
AddItem Method


MindFusion.Diagramming.Diagram.ResetAlignmentGuides Method

Diagram.ResetAlignmentGuides Method
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ResetAlignmentGuides ()

Visual Basic [image] Copy Code

Public Sub ResetAlignmentGuides ()

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ResizeToFitItem Method

Diagram.ResizeToFitItem Method
[image]

Resizes the document extents so that the specified item is contained within.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ResizeToFitItem (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Sub ResizeToFitItem ( _
item As DiagramItem _
)

Parameters

item

The diagram item contained in the document area.

Remarks

Resizes the document area to fit the specified diagram item.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ResizeToFitItems Method
AutoResize Property


MindFusion.Diagramming.Diagram.ResizeToFitItems Method

Diagram.ResizeToFitItems Method
[image]

Resizes the document scrollable area so it fits all diagram items.

Overload List

Name | Description
Diagram.ResizeToFitItems (Single) | Resizes the document scrollable area so it fits all diagram items.
Diagram.ResizeToFitItems (Single, Boolean) | Resizes the document scrollable area so it fits all diagram items, optionally considering only the visible items.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
AutoResize Property
Bounds Property


MindFusion.Diagramming.Diagram.ResizeToFitItems Method (Single)

Diagram.ResizeToFitItems Method (Single)
See Also
[image]

Resizes the document scrollable area so it fits all diagram items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ResizeToFitItems (
float borderGap
)

Visual Basic [image] Copy Code

Public Sub ResizeToFitItems( _
borderGap As Single _
)

Parameters

borderGap
A gap that should be left as a border around the diagram.

Remarks

Resizes the document area to be just as big as needed, for example, the smallest rectangle containing all diagram items. For aesthetic reasons, additional space can be left around the outmost items as a margin. Invoking the method on an empty document produces no result.

See Also

ResizeToFitItems Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
AutoResize Method
Bounds Property


MindFusion.Diagramming.Diagram.ResizeToFitItems Method (Single, Boolean)

Diagram.ResizeToFitItems Method (Single, Boolean)
See Also
[image]

Resizes the document scrollable area so it fits all diagram items, optionally considering only the visible items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ResizeToFitItems (
float borderGap,
bool onlyVisible
)

Visual Basic [image] Copy Code

Public Sub ResizeToFitItems( _
borderGap As Single, _
onlyVisible As Boolean _
)

Parameters

borderGap

A gap that should be left as a border around the diagram.

onlyVisible
Specifies whether only the bounds of the Visible items should be included in the new document area.

Remarks

Resizes the document area to be just as big as needed, for example the smallest rectangle containing all diagram items. For aesthetic reasons, additional space can be left around the outmost items as a margin. Invoking the method on an empty document produces no result.

See Also

ResizeToFitItems Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
AutoResize Method
Bounds Property


MindFusion.Diagramming.Diagram.RouteAllLinks Method

Diagram.RouteAllLinks Method
[image]

Routes all links in the diagram in a way they do not cross nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RouteAllLinks ()

Visual Basic [image] Copy Code

Public Sub RouteAllLinks ()

Remarks

Each link is routed so that it goes the shortest possible way between the nodes it links without crossing any other nodes. To do so, this method might modify the number of link segments. The value of AutoRoute is not considered when RouteAllLinks executes.

RoutingOptions allows tuning the routing algorithm. The most important options are the cost values exposed as LengthCost, TurnCost and CrossingCost properties. They greatly influence the shape of the generated route.

See Also

Diagram Members
Diagram Class
RouteLinks Property


MindFusion.Diagramming.Diagram.SaveToFile Method

Diagram.SaveToFile Method
[image]

Saves the binary contents of the diagram to a disk file.

Overload List

Name | Description
Diagram.SaveToFile (String) | Saves the binary contents of a diagram to the specified file.
Diagram.SaveToFile (String, Boolean) | Saves the binary contents of a diagram to the specified file, optionally clearing the Dirty flag.

See Also

Diagram Members
Diagram Class
SaveToXml Method


MindFusion.Diagramming.Diagram.SaveToFile Method (String)

Diagram.SaveToFile Method (String)
See Also
[image]

Saves the binary contents of a diagram to the specified file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToFile (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveToFile( _
fileName As String _
)

Parameters

fileName
The full path and name of the disk file where the diagram should be saved.

Remarks

SaveToFile creates a file stream and invokes the SaveToStream method on it. The file contents can be loaded later using the LoadFromFile method.

See Also

SaveToFile Method Overload List
Diagram Members
Diagram Class
SaveToXml Method


MindFusion.Diagramming.Diagram.SaveToFile Method (String, Boolean)

Diagram.SaveToFile Method (String, Boolean)
See Also
[image]

Saves the binary contents of a diagram to the specified file, optionally clearing the Dirty flag.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToFile (
string fileName,
bool clearDirty
)

Visual Basic [image] Copy Code

Public Sub SaveToFile( _
fileName As String, _
clearDirty As Boolean _
)

Parameters

fileName
The full path and name of the disk file where the diagram should be saved.
clearDirty
Indicates whether the Dirty flag should be cleared.

Remarks

SaveToFile creates a file stream and invokes the SaveToStream method on it. The file contents can be loaded later using the LoadFromFile method.

See Also

SaveToFile Method Overload List
Diagram Members
Diagram Class
SaveToXml Method


MindFusion.Diagramming.Diagram.SaveToStream Method

Diagram.SaveToStream Method
[image]

Saves the binary contents of the diagram to a .NET stream.

Overload List

Name | Description
Diagram.SaveToStream (Stream) | Saves the binary contents of the diagram to the specified .NET stream.
Diagram.SaveToStream (Stream, Boolean) | Saves the binary contents of a diagram to the specified .NET stream, optionally clearing the Dirty flag.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SaveToFile Method
SaveToXml Method


MindFusion.Diagramming.Diagram.SaveToStream Method (Stream)

Diagram.SaveToStream Method (Stream)
See Also
[image]

Saves the binary contents of the diagram to the specified .NET stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToStream (
Stream stream
)

Visual Basic [image] Copy Code

Public Sub SaveToStream( _
stream As Stream _
)

Parameters

stream
An instance of a System.IO.Stream-derived class.

Remarks

Serializes the current diagram as a sequence of bytes represented by stream. The stream may wrap a file, a memory buffer, a TCP socket, and more. The stream contents can be loaded later using the LoadFromStream method.

See Also

SaveToStream Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SaveToFile Method
SaveToXml Method


MindFusion.Diagramming.Diagram.SaveToStream Method (Stream, Boolean)

Diagram.SaveToStream Method (Stream, Boolean)
See Also
[image]

Saves the binary contents of a diagram to the specified .NET stream, optionally clearing the Dirty flag.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToStream (
Stream stream,
bool clearDirty
)

Visual Basic [image] Copy Code

Public Sub SaveToStream( _
stream As Stream, _
clearDirty As Boolean _
)

Parameters

stream
An instance of a System.IO.Stream-derived class.
clearDirty
Indicates whether the Dirty flag should be cleared.

Remarks

Serializes the current diagram as a sequence of bytes represented by stream. The stream may wrap a file, a memory buffer, a TCP socket, and more. The stream contents can be loaded later using the LoadFromStream method.

See Also

SaveToStream Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SaveToFile Method
SaveToXml Method


MindFusion.Diagramming.Diagram.SaveToString Method

Diagram.SaveToString Method
[image]

Encodes the diagram contents into an ASCII string.

Overload List

Name | Description
Diagram.SaveToString () | Encodes the diagram contents into an ASCII string.
Diagram.SaveToString (SaveToStringFormat, Boolean) | Encodes the diagram contents into an ASCII string using the specified format and optionally clearing the Dirty flag.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LoadFromString Method
SaveToFile Method


MindFusion.Diagramming.Diagram.SaveToString Method ()

Diagram.SaveToString Method ()
See Also
[image]

Encodes the diagram contents into an ASCII string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string SaveToString ()

Visual Basic [image] Copy Code

Public Function SaveToString () As String

Return Value

A string containing the encoded diagram data.

Remarks

The Base16 and Base64 formats represent the data returned by SaveToStream as an ASCII string. There are no special characters in the returned string, so the result can be easily stored in a database field or embedded into an XML document. That might be used also for transferring a diagram between a web page with embedded MvcDiagram and a web server, passing the string as a value of a hidden HTML field.

When using Xml or CompressedXml as the first argument, the diagram is saved in XML format. The same format is supported by the SaveToXml and LoadFromXml methods. CompressedXml specifies that the XML document should be further compressed in ZIP format and base-64 encoded.

See Also

SaveToString Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LoadFromString Method
SaveToFile Method


MindFusion.Diagramming.Diagram.SaveToString Method (SaveToStringFormat, Boolean)

Diagram.SaveToString Method (SaveToStringFormat, Boolean)
See Also
[image]

Encodes the diagram contents into an ASCII string using the specified format and optionally clearing the Dirty flag.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string SaveToString (
SaveToStringFormat format,
bool clearDirty
)

Visual Basic [image] Copy Code

Public Function SaveToString ( _
format As SaveToStringFormat, _
clearDirty As Boolean _
) As String

Parameters

format
A member of the SaveToStringFormat enumeration.
clearDirty

Indicates whether the Dirty flag should be cleared.

Return Value

A string containing the encoded diagram data.

Remarks

The Base16 and Base64 formats represent the data returned by SaveToStream as an ASCII string. There are no special characters in the returned string, so the result can be easily stored in a database field or embedded into an XML document. That might be used also for transferring a diagram between a web page with embedded MvcDiagram and a web server, passing the string as a value of a hidden HTML field.

When using Xml or CompressedXml as the first argument, the diagram is saved in XML format. The same format is supported by the SaveToXml and LoadFromXml methods. CompressedXml specifies that the XML document should be further compressed in ZIP format and base-64 encoded.

Exceptions

Exception type | Condition
NotImplementedException | When saving the diagram using the CompressedXml flag under .NET Framework 1.1 or earlier.

See Also

SaveToString Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LoadFromString Method
SaveToFile Method


MindFusion.Diagramming.Diagram.SaveToXml Method

Diagram.SaveToXml Method
[image]

Saves the diagram to an XML document.

Overload List

Name | Description
Diagram.SaveToXml (String) | Saves the diagram to the specified file as an XML document.
Diagram.SaveToXml (XmlDocument) | Saves the diagram to the specified XML document.
Diagram.SaveToXml (XmlDocument, Boolean) | Saves the diagram to the specified XML document.

See Also

Diagram Members
Diagram Class
SaveToFile Method


MindFusion.Diagramming.Diagram.SaveToXml Method (String)

Diagram.SaveToXml Method (String)
See Also
[image]

Saves the diagram to the specified file as an XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
fileName As String _
)

Parameters

fileName
The full path and name of the disk file where the diagram should be saved.

Remarks

The first overloaded SaveToXml method works by creating an XmlDocument instance, calling the second overloaded method, and writing the document content to a file.

Diagram data can be loaded from an XML file or document using the LoadFromXml method.

See Also

SaveToXml Method Overload List
Diagram Members
Diagram Class
SaveToFile Method


MindFusion.Diagramming.Diagram.SaveToXml Method (XmlDocument)

Diagram.SaveToXml Method (XmlDocument)
See Also
[image]

Saves the diagram to the specified XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void SaveToXml (
XmlDocument document
)

Visual Basic [image] Copy Code

Public Overridable Sub SaveToXml( _
document As XmlDocument _
)

Parameters

document
A .NET XmlDocument object where the diagram should be saved.

Remarks

Diagram data can be loaded from an XML file or document using the LoadFromXml method.

See Also

SaveToXml Method Overload List
Diagram Members
Diagram Class
SaveToFile Method


MindFusion.Diagramming.Diagram.SaveToXml Method (XmlDocument, Boolean)

Diagram.SaveToXml Method (XmlDocument, Boolean)
See Also
[image]

Saves the diagram to the specified XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void SaveToXml (
XmlDocument document,
bool includeUnalteredProperties
)

Visual Basic [image] Copy Code

Public Overridable Sub SaveToXml( _
document As XmlDocument, _
includeUnalteredProperties As Boolean _
)

Parameters

document
A .NET XmlDocument object where the diagram should be saved.
includeUnalteredProperties
true if properties that have their default value should be saved; otherwise, false.

Remarks

Diagram data can be loaded from an XML file or document using the LoadFromXml method.

See Also

SaveToXml Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.SetShadowOffset Method

Diagram.SetShadowOffset Method
[image]

Sets the default offset at which items shadows are drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetShadowOffset (
float x,
float y
)

Visual Basic [image] Copy Code

Public Sub SetShadowOffset( _
x As Single, _
y As Single _
)

Parameters

x

The horizontal offset of the item shadow.

y
The vertical offset of the item shadow.

Remarks

Use the method to draw shadows that are closer or further to the item they belong to. The values are applied respectively to the ShadowOffsetX and ShadowOffsetY properties.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ShadowOffsetX Property
ShadowOffsetY Property
ShadowBrush


MindFusion.Diagramming.Diagram.UnitToPixel Method

Diagram.UnitToPixel Method
[image]

Converts the specified point from document to client coordinates ignoring the current scale transformation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point UnitToPixel (
PointF point
)

Visual Basic [image] Copy Code

Public Function UnitToPixel( _
point As PointF _
) As Point

Parameters

point
The PointF instance to convert.

Return Value

A Point representing the client coordinates of the diagram point specified as an argument.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.UpdateMeasureTextScale Method

Diagram.UpdateMeasureTextScale Method
[image]

Gets or sets the scale to use when measuring texts. This should be effectively set to the value of DiagramView.Zoom / 100.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void UpdateMeasureTextScale (
float measureTextScale
)

Visual Basic [image] Copy Code

Public Sub UpdateMeasureTextScale( _
measureTextScale As Single _
)

Parameters

measureTextScale

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.UpdateRuntimeIndices Method

Diagram.UpdateRuntimeIndices Method
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void UpdateRuntimeIndices ()

Visual Basic [image] Copy Code

Public Sub UpdateRuntimeIndices ()

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.UpdateZOrder Method

Diagram.UpdateZOrder Method
[image]

Immediately sorts the Z-order list if Z-order has been invalidated. Otherwise it will be sorted next time the diagram draws its contents.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void UpdateZOrder ()

Visual Basic [image] Copy Code

Public Sub UpdateZOrder ()

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram Properties

Diagram Properties
[image]

Public Properties

Name | Description
ActiveItem | Gets or sets the active diagram element.
ActiveItemHandlesStyle | Gets the visual style of adjustment handles of the active item.
ActiveLayer | Gets or sets the zero-based index of the active layer.
AdjustmentHandlesSize | Gets or sets the size of the handles, which appear around selected objects.
AlignmentGuidePen | Gets or sets the pen used to draw alignment guides.
AlignToGrid | Gets or sets a value indicating whether the diagram items is aligned to a grid.
AllowLinksRepeat | Gets or sets a value indicating whether more than one link can connect the same origin and destination diagram nodes.
AllowMultipleResize | Gets or sets whether multiple selected nodes can be resized simultaneously.
AllowSelfLoops | Gets or sets a value indicating whether self-loops are allowed.
AllowSplitLinks | Gets or sets a value indicating whether link segments can be added and removed interactively.
AllowUnanchoredLinks | Gets or sets a value indicating whether links can be connected to nodes to which there aren't anchor points assigned.
AllowUnconnectedLinks | Gets or sets a value indicating whether users are allowed to draw links that are not connected to any node.
AutoAlignDistance | Gets or sets the maximal horizontal or vertical distance at which a node aligns to the borders of other nodes.
AutoAlignNodes | Gets or sets whether nodes should automatically align to the borders of other nodes during user interaction.
AutoHighlightRows | Gets or sets whether a table row should be highlighted when the user clicks on it.
AutoResize | Gets or sets a value indicating whether the document area must be resized automatically so it fits the diagram contents.
AutoSnapDistance | Specifies the maximum distance at which links auto-snap to nodes.
AutoSnapLinks | Gets or sets the default value for the AutoSnapToNode property of new links.
BackBrush | Gets or sets the brush used for painting the diagram background.
BackgroundImage | Gets or sets the image displayed as background of this diagram.
BackgroundImageAlign | Gets or sets a value indicating how the background image is positioned, relatively to the scrollable document area.
BackgroundImageUrl | URL of the image painted as diagram's background.
BarcodeNodeStyle | Gets the theme-level style for barcode nodes.
Bounds | Gets or sets a value representing the size of the diagram's scrollable area.
BoundsPen | The pen with which the document bounds should be drawn.
CellCustomDraw | Gets or sets the default type of custom painting done on the cells of tables.
CellFrameStyle | Gets or sets the default cell border style of new tables.
CompositeNodeStyle | Gets the theme-level style for composite nodes.
ContainerCaption | Gets or sets the default value for the Caption property of containers.
ContainerCaptionHeight | Gets or sets the default value for the CaptionHeight property of containers.
ContainerHighlightPen | Gets or sets the default value for the HighlightPen property of containers.
ContainerMargin | Gets or sets the default value for the Margin property of containers.
ContainerMinimumSize | Gets or sets the default value for the MinimumSize property of containers.
ContainerNodeStyle | Gets the theme-level style for container nodes.
ContainersFoldable | Gets or sets the default value for the Foldable property of containers.
CrossingRadius | Gets or sets the radius length of decorations displayed at link intersection points.
DefaultShape | Gets or sets the default shape of shape nodes.
DiagramLinkStyle | Gets the theme-level style for diagram links.
DiagramStyle | Gets the theme-level style for the diagram.
Dirty | Gets or sets a value indicating whether the diagram has changed since the last save.
DisabledHandlesStyle | Gets the visual style of disabled adjustment handles.
DynamicLinks | Gets or sets the default value for the Dynamic property of new links.
EffectiveBackBrush | Gets the currently effective background brush of the diagram.
EffectsProvider | Gets or sets an object used to generate visual effects for shape nodes such as embossment and shadow dispersion.
EnableEmbossEffects | Gets or sets a value indicating whether emboss effect for shape nodes is enabled.
EnableLanes | Gets or sets whether lanes are enabled.
EnableShadowEffects | Gets or sets a value indicating whether the shadow dispersion effect for nodes is enabled.
EnableStyledText | Gets or sets the default value for the EnableStyledText property of new nodes.
ExpandButtonAction | Gets or sets a value indicating what should happen when a user clicks the [±] button that is displayed near expandable nodes.
ExpandButtonPosition | Gets or sets where expand/collapse buttons are located relatively to their nodes.
ExpandOnIncoming | Gets or sets a value, indicating in which direction object hierarchies are expanded.
ExteriorBrush | Gets or sets the brush used for painting the area outside Bounds.
Factory | Gets a Factory instance that lets you add programmatically new items to the diagram.
FocusedComponent | Gets or sets the component within this diagram which currently has the input focus.
FoldedContainerSize | Gets or sets the size of folded containers.
Font | Gets or sets the default font for new diagram items.
GridColor | Gets or sets the color of the grid points.
GridOffsetX | Gets or sets the horizontal offset of the first point of the alignment grid.
GridOffsetY | Gets or sets the vertical offset of the first point of the alignment grid.
GridSizeX | Gets or sets the horizontal distance between adjacent grid points.
GridSizeY | Gets or sets the vertical distance between adjacent grid points.
GridStyle | Gets or sets the visual style of the alignment grid.
Groups | Gets a collection of all groups in the diagram.
HitTestPriority | Gets or sets a value indicating the order in which items are hit-tested.
Interaction | Gets an InteractionState instance representing the current action being carried out by the user.
IsProEdition | Gets a value indicating whether the currently loaded MvcDiagram is a professional version of the control.
Items | Gets a collection of all items in this diagram.
LaneGrid | Gets the Grid instance that represents the lane grid.
Layers | Gets a list of the layers in the current diagram.
LinkBaseShape | Gets or sets the shape displayed at the base of new links.
LinkBaseShapeSize | Gets or sets the default size of the base of new links.
LinkBrush | Gets or sets the default value for the Brush property of links.
LinkCascadeOrientation | Gets or sets the initial orientation of the first segment of new cascading links.
LinkCrossings | Gets or sets how to render the intersection points where links cross their paths.
LinkCustomDraw | Gets or sets the default type of custom painting done on links.
LinkEndsMovable | Gets or sets a value indicating whether link ends can be moved by users after the link is created.
LinkHandlesStyle | Gets or sets the default value for the HandlesStyle property of new links.
LinkHeadShape | Gets or sets the shape displayed as head of new links.
LinkHeadShapeSize | Gets or sets the default size of arrowheads.
LinkHitDistance | Gets or sets a value specifying how far from a link a click is still considered a hit.
LinkIntermediateShape | Gets or sets the default shape to be displayed in the middle of each segment of links.
LinkIntermediateShapeSize | Gets or sets the default size of the shapes at middles of link segments.
LinkPen | Gets or sets the default value for the Pen and HeadPen properties of links.
LinkRouter | Gets or sets the component used to find paths for auto-routed links when diagram nodes are added or their positions change.
Links | Gets a collection of all DiagramLink objects in the diagram.
LinkSegments | Gets or sets the default number of link segments.
LinkShape | Gets or sets the default value of the Shape property of new links.
LinksRetainForm | Gets or sets whether links should maintain their forms if the nodes linked with those links are moved around.
LinkText | Gets or sets the default text of links.
LinkTextStyle | Gets or sets default placement and orientation for links' text.
MeasureTextRenderingHint | Gets or sets the TextRenderingHint to use when measuring texts. This should be effectively set to the value of DiagramView.TextRenderingHint.
MeasureUnit | Gets or sets the unit of measure used for logical coordinates in this diagram.
MergeThreshold | Gets or sets the maximum distance between adjacent control points of a link at which the respective segments can be merged.
MinimumNodeSize | Gets or sets the minimum node size that the user is allowed to set.
NodeEffects | Gets a collection with all effects applied to the nodes of this diagram.
Nodes | Gets a collection of all DiagramNode objects in the diagram.
NodesExpandable | Gets or sets a value indicating whether newly created nodes can be expanded.
NowLoading | Gets a value indicating whether the diagram data is now being loaded from a file.
PolygonalTextLayout | Gets or sets a value indicating whether to enable the formatting of text inside non-rectangular shape node outlines.
RecursiveExpand | Gets or sets value indicating how a tree is expanded.
RestrictItemsToBounds | Gets or sets a value indicating whether users are allowed to place items outside the scrollable area of the diagram.
RoundedLinks | Gets or sets a value indicating whether the joins between segments of Polyline and Cascading links should be rounded.
RoundedLinksRadius | Gets or sets the radius of arc joins of rounded links' segments.
RoundRectFactor | Gets or sets the relative size of arcs displayed at the corners of rounded rectangles.
RouteLinks | Gets or sets a value indicating whether links should avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes.
RoutingOptions | Gets an object, which allows customizing various parameters of the link routing algorithm.
RowHighlightBrush | Gets or sets the Brush used to fill highlighted table rows.
ScriptHelper | Gets a ScriptHelper object which can be used in html scripts to instantiate various objects and to call static methods.
SelectAfterCreate | Gets or sets a value indicating whether newly created objects are automatically selected.
SelectedItemHandlesStyle | Gets the visual style of adjustment handles of selected items.
Selection | Gets a Selection instance that represents the selection of items in this diagram.
SelectionOnTop | Gets or sets a value indicating whether selected items should be painted on top of other items.
SerializationBinder | Gets or sets a SerializationBinder object used to control class loading.
ShadowBrush | Gets or sets the default brush used to paint the shadows cast by diagram items.
ShadowOffsetX | Gets or sets the horizontal offset of item shadows.
ShadowOffsetY | Gets or sets the vertical offset of item shadows.
ShadowsStyle | Gets or sets the style for rendering shadows.
ShapeBrush | Gets or sets the default value for the Brush property of shape nodes.
ShapeCustomDraw | Gets or sets the default type of custom painting done for shape nodes.
ShapeHandlesStyle | Gets or sets the default value for the HandlesStyle property of new shape nodes.
ShapeNodeStyle | Gets the theme-level style for shape nodes.
ShapeOrientation | Gets or sets the default value for the ShapeOrientation property of shape nodes.
ShapePen | Gets or sets the default value for the Pen property of shape nodes.
ShapeText | Gets or sets the default text of shape nodes.
ShowAnchors | Gets or sets a value indicating whether and when node anchor points should be displayed.
ShowDisabledHandles | Gets or sets a value indicating whether manipulation handles are painted when they are disabled.
ShowGrid | Gets or sets a value indicating whether the alignment grid is visible.
ShowHandlesOnDrag | Gets or sets a value indicating whether to display selection handles of objects under the mouse while another object is being modified.
SnapToAnchor | Gets or sets when link end points should be aligned to the nearest anchor points.
SortGroupsByZ | Gets or sets a value indicating whether grouped items should be drawn sorted by their z-order while the whole group is being moved.
Style | Gets or sets the style associated with the diagram.
SvgNodeStyle | Gets the theme-level style for SVG nodes.
TableBrush | Gets or sets the default value for the Brush property of tables.
TableCaption | Gets or sets the default text for tables' captions.
TableCaptionHeight | Gets or sets the default height of table captions.
TableColumnCount | Gets or sets the default number of table columns.
TableColumnWidth | Gets or sets the default width of tables' columns.
TableConnectionStyle | Gets or sets a value indicating whether drawing a link between tables should connect the rows of those tables, or the tables as whole entities.
TableCustomDraw | Gets or sets the default type of custom painting done on tables.
TableHandlesStyle | Gets or sets the default value for the HandlesStyle property of new tables.
TableNodeStyle | Gets the theme-level style for table nodes.
TablePen | Gets or sets the default value for the Pen property of tables.
TableRowCount | Gets or sets the default number of table rows.
TableRowHeight | Gets or sets the default height of tables' rows.
TableShape | Gets or sets the default value of the Shape property of new tables.
TablesScrollable | Gets or sets the default value for the Scrollable property of new tables.
Tag | Gets or sets custom data associated with this diagram.
TextColor | Gets or sets the default color of text displayed inside diagram items.
TextFormat | Gets or sets the default alignment and formatting style for text displayed inside nodes and table cells.
Theme | Gets or sets the theme associated with the diagram.
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram.
TreeViewNodeStyle | Gets the theme-level style for tree view nodes.
UndoManager | Gets a reference to the diagram's UndoManager instance.
ValidityChecks | Gets or sets a value indicating whether validity checks are performed each time an item is added to the diagram.
VisioNodeStyle | Gets the theme-level style for Visio nodes.

See Also

Diagram Class


MindFusion.Diagramming.Diagram.ActiveItem Property

Diagram.ActiveItem Property
[image]

Gets or sets the active diagram element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem ActiveItem { get; set; }

Visual Basic [image] Copy Code

Public Property ActiveItem As DiagramItem

Property Value

A reference to the DiagramItem instance that is currently active.

Remarks

Use this property to get the active item - the one selected by the user or the last put in a multiple Selection. It is shown with white selection handles by default.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ActiveItemHandlesColor Property
SelectionOnTop Property


MindFusion.Diagramming.Diagram.ActiveItemHandlesStyle Property

Diagram.ActiveItemHandlesStyle Property
[image]

Gets the visual style of adjustment handles of the active item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HandlesVisualStyle ActiveItemHandlesStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ActiveItemHandlesStyle As HandlesVisualStyle

Property Value

An instance of the HandlesVisualStyle class.

Remarks

This style object provides Pen and Brush attributes that let you customize the appearance of adjustment handles drawn around the active item.

See Also

Diagram Members
Diagram Class
ActiveItem Property


MindFusion.Diagramming.Diagram.ActiveLayer Property

Diagram.ActiveLayer Property
[image]

Gets or sets the zero-based index of the active layer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ActiveLayer { get; set; }

Visual Basic [image] Copy Code

Public Property ActiveLayer As Integer

Property Value

An integer value that specifies the index of the active layer.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AdjustmentHandlesSize Property

Diagram.AdjustmentHandlesSize Property
[image]

Gets or sets the size of the handles, which appear around selected objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float AdjustmentHandlesSize { get; set; }

Visual Basic [image] Copy Code

Public Property AdjustmentHandlesSize As Single

Property Value

A float value specifying the height of the selection handles. The default is 2.

Remarks

Use the property to set the size of the manipulation handles, which appear around selected items.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ModificationStart Property
SelectedItemHandlesColor Property


MindFusion.Diagramming.Diagram.AlignmentGuidePen Property

Diagram.AlignmentGuidePen Property
[image]

Gets or sets the pen used to draw alignment guides.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen AlignmentGuidePen { get; set; }

Visual Basic [image] Copy Code

Public Property AlignmentGuidePen As Pen

Property Value

An instance of the Pen class.

Remarks

This pen is used to draw alignment guides shown when AutoAlignNodes is enabled.

See Also

Diagram Members
Diagram Class
AutoAlignDistance Property


MindFusion.Diagramming.Diagram.AlignToGrid Property

Diagram.AlignToGrid Property
[image]

Gets or sets a value indicating whether the diagram items is aligned to a grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AlignToGrid { get; set; }

Visual Basic [image] Copy Code

Public Property AlignToGrid As Boolean

Property Value

true if the grid is activated; otherwise, false. The default is true.

Remarks

When the property is set to true, the sides of every newly created diagram item are aligned to the nearest grid points.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ShowGrid Property
GridColor Property
GridSizeX Property
GridSizeY Property
AlignPointToGrid Method
AutoAlignNodes Property


MindFusion.Diagramming.Diagram.AllowLinksRepeat Property

Diagram.AllowLinksRepeat Property
[image]

Gets or sets a value indicating whether more than one link can connect the same origin and destination diagram nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowLinksRepeat { get; set; }

Visual Basic [image] Copy Code

Public Property AllowLinksRepeat As Boolean

Property Value

true if repeated links are allowed; otherwise, false. The default is true.

Remarks

Specifies whether more than one link can connect the same origin and destination diagram nodes. If set to false, two diagram nodes can be connected with at most one link in a single direction.

See Also

Diagram Members
Diagram Class
AllowSelfLoops Property


MindFusion.Diagramming.Diagram.AllowMultipleResize Property

Diagram.AllowMultipleResize Property
[image]

Gets or sets whether multiple selected nodes can be resized simultaneously.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowMultipleResize { get; set; }

Visual Basic [image] Copy Code

Public Property AllowMultipleResize As Boolean

Property Value

true to let the user resize multiple selected nodes; otherwise, false. The default value is false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AllowSelfLoops Property

Diagram.AllowSelfLoops Property
[image]

Gets or sets a value indicating whether self-loops are allowed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowSelfLoops { get; set; }

Visual Basic [image] Copy Code

Public Property AllowSelfLoops As Boolean

Property Value

true if self loops are allowed; otherwise, false. The default is true.

Remarks

Use the property to specify whether the user is allowed to draw self loops - links that connect a node to itself.

See Also

Diagram Members
Diagram Class
AllowLinksRepeat Property


MindFusion.Diagramming.Diagram.AllowSplitLinks Property

Diagram.AllowSplitLinks Property
[image]

Gets or sets a value indicating whether link segments can be added and removed interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowSplitLinks { get; set; }

Visual Basic [image] Copy Code

Public Property AllowSplitLinks As Boolean

Property Value

true if interactive adding/removing of link segments allowed; false if not.

Remarks

Allows users insert new link segments interactively by clicking and dragging a point of a link's segment. For polyline-style link this creates one additional segment by splitting the existing one into two parts. For cascading links there are two segments inserted, keeping intact the alternating pattern of horizontal and vertical segments, each orthogonal to its neighbors. Bйzier-style links cannot be split in the current MvcDiagram version.

Segments can be merged by moving their joining point until the angle between reaches certain threshold value. In case of cascading-style links, segments can be merged by placing adjacent control points close one to the other, as set in MergeThreshold.

This property also affects how users can change the orientation of cascading links. For more details see CascadeOrientation.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LinkSegments Property
LinkShape Property


MindFusion.Diagramming.Diagram.AllowUnanchoredLinks Property

Diagram.AllowUnanchoredLinks Property
[image]

Gets or sets a value indicating whether links can be connected to nodes to which there aren't anchor points assigned.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowUnanchoredLinks { get; set; }

Visual Basic [image] Copy Code

Public Property AllowUnanchoredLinks As Boolean

Property Value

true to let links connect to nodes without anchor points; otherwise, false. The default is true.

Remarks

AllowUnanchoredLinks applies to nodes whose AnchorPattern is not set or does not contain incoming or outgoing anchor points available. If the property is enabled, users can connect links to any point of such nodes. If disabled, users cannot connect links to such nodes.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
AnchorPoint.AllowIncoming Property
AnchorPoint.AllowOutgoing Property


MindFusion.Diagramming.Diagram.AllowUnconnectedLinks Property

Diagram.AllowUnconnectedLinks Property
[image]

Gets or sets a value indicating whether users are allowed to draw links that are not connected to any node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowUnconnectedLinks { get; set; }

Visual Basic [image] Copy Code

Public Property AllowUnconnectedLinks As Boolean

Property Value

true to allow drawing unconnected links; otherwise, false. The default is false.

Remarks

If the property is set to true, users will be able to draw links from or to any point of the document. Depending on which end of a link is unconnected, its Origin or Destination nodes might be of type DummyNode.

See Also

Diagram Members
Diagram Class
AllowUnanchoredLinks Property


MindFusion.Diagramming.Diagram.AutoAlignDistance Property

Diagram.AutoAlignDistance Property
[image]

Gets or sets the maximal horizontal or vertical distance at which a node aligns to the borders of other nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float AutoAlignDistance { get; set; }

Visual Basic [image] Copy Code

Public Property AutoAlignDistance As Single

Property Value

A float value specifying the maximal alignment distance. The default value is 3.

Remarks

To enable node alignment, set AutoAlignNodes to true. When either the horizontal or vertical borders of the dragged node are within the specified distance from the respective borders of a nearby node, the dragged node snaps to a position where the borders are aligned.

See Also

Diagram Members
Diagram Class
AlignmentGuidePen Property


MindFusion.Diagramming.Diagram.AutoAlignNodes Property

Diagram.AutoAlignNodes Property
[image]

Gets or sets whether nodes should automatically align to the borders of other nodes during user interaction.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoAlignNodes { get; set; }

Visual Basic [image] Copy Code

Public Property AutoAlignNodes As Boolean

Property Value

true to align nodes, otherwise false. The default value is false.

Remarks

When either the horizontal or vertical borders of the dragged node are within AutoAlignDistance from the respective borders of a nearby node, the dragged node snaps to a position where the borders are aligned. In addition, an alignment guide that indicates which borders are aligned is drawn using the pen specified through AlignmentGuidePen.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
AlignToGrid Property
AutoSnapLinks Property
QueryAlignTarget Event


MindFusion.Diagramming.Diagram.AutoHighlightRows Property

Diagram.AutoHighlightRows Property
[image]

Gets or sets whether a table row should be highlighted when the user clicks on it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoHighlightRows { get; set; }

Visual Basic [image] Copy Code

Public Property AutoHighlightRows As Boolean

Property Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AutoResize Property

Diagram.AutoResize Property
[image]

Gets or sets a value indicating whether the document area must be resized automatically so it fits the diagram contents.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AutoResize AutoResize { get; set; }

Visual Basic [image] Copy Code

Public Property AutoResize As AutoResize

Property Value

A member of the AutoResize enumeration. The default is AutoResize.RightAndDown.

Remarks

If automatic resizing is enabled, the size of the document scrollable area is updated each time an item is created, deleted or moved, either by end-users or by calling of methods. The following AutoResize values specify in what directions the diagram area is allowed to grow:

Member name | Description
None | Do not enlarge the diagram area automatically.
RightAndDown | Enlarge the diagram area to the right and down if an item is moved outside the boundaries in these directions.
AllDirections | Enlarge the diagram area in any direction if an item is moved outside the boundaries.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Bounds Property
ResizeToFitItems Method


MindFusion.Diagramming.Diagram.AutoSnapDistance Property

Diagram.AutoSnapDistance Property
[image]

Specifies the maximum distance at which links auto-snap to nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float AutoSnapDistance { get; set; }

Visual Basic [image] Copy Code

Public Property AutoSnapDistance As Single

Property Value

A float value specifying the maximum auto-snap distance. The default value is 16.

See Also

Diagram Members
Diagram Class
AutoSnapLinks Property


MindFusion.Diagramming.Diagram.AutoSnapLinks Property

Diagram.AutoSnapLinks Property
[image]

Gets or sets the default value for the AutoSnapToNode property of new links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoSnapLinks { get; set; }

Visual Basic [image] Copy Code

Public Property AutoSnapLinks As Boolean

Property Value

true to snap links to nearest node, otherwise false; the default value is false.

Remarks

Only nodes at a distance smaller than AutoSnapDistance are considered. A link does not snap to its current origin or destination nodes if that would create a self-loop.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DynamicLinks Property
AutoAlignNodes Property


MindFusion.Diagramming.Diagram.BackBrush Property

Diagram.BackBrush Property
[image]

Gets or sets the brush used for painting the diagram background.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush BackBrush { get; set; }

Visual Basic [image] Copy Code

Public Property BackBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class. The default is a solid brush initialized with Color.FromArgb(170, 170, 200).

Remarks

This property enables more spectacular background painting with effects such as gradients, textures and color patterns.

Example

The following sample paints the diagram background with a gradient brush:

C# [image] Copy Code

private void Form1_Load(object sender, System.EventArgs e)
{
diagram.BackBrush = new MindFusion.Drawing.LinearGradientBrush(
Color.LightBlue, Color.LightCyan, 30);
}

Visual Basic [image] Copy Code

Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

diagram.BackBrush = New MindFusion.Drawing.LinearGradientBrush( _
Color.LightBlue, Color.LightCyan, 30)

End Sub

See Also

Diagram Members
Diagram Class
Brush and Pen Classes


MindFusion.Diagramming.Diagram.BackgroundImage Property

Diagram.BackgroundImage Property
[image]

Gets or sets the image displayed as background of this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Image BackgroundImage { get; set; }

Visual Basic [image] Copy Code

Public Property BackgroundImage As Image

Property Value

An instance of the .NET Image class.

Remarks

This image is painted as a background of the diagram, behind the alignment grid and all items. Its position is controlled by the BackgroundImageAlign property. To have the background image appear on printed pages, set the EnableBackgroundImage property of DiagramView.PrintOptions to true.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
BackgroundImageAlign Property
BackBrush Property


MindFusion.Diagramming.Diagram.BackgroundImageAlign Property

Diagram.BackgroundImageAlign Property
[image]

Gets or sets a value indicating how the background image is positioned, relatively to the scrollable document area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ImageAlign BackgroundImageAlign { get; set; }

Visual Basic [image] Copy Code

Public Property BackgroundImageAlign As ImageAlign

Property Value

A member of the ImageAlign enumeration. The default is ImageAlign.TopLeft.

Remarks

The background image can be aligned to a corner, stretched, centered, or tiled to cover the control's area.

Example

To have a background image stretched along the drawing surface, use code like the following:

C# [image] Copy Code

diagram.BackgroundImage = Image.FromFile("back.jpg");
diagram.BackgroundImageAlign = ImageAlign.Stretch;

Visual Basic [image] Copy Code

diagram.BackgroundImage = Image.FromFile("back.jpg")
Diagram.BackgroundImageAlign = ImageAlign.Stretch

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ImageAlign Enumeration
BackgroundImage Property


MindFusion.Diagramming.Diagram.BackgroundImageUrl Property

Diagram.BackgroundImageUrl Property
[image]

URL of the image painted as diagram's background.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string BackgroundImageUrl { get; set; }

Visual Basic [image] Copy Code

Public Property BackgroundImageUrl As String

Property Value

A string specifying the location of the image file.

Remarks

This property is used in the WebForms version of the control. Its advantage is that it allows for the diagram items to be loaded faster on the client side, while the background image is loaded asynchronously.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.BarcodeNodeStyle Property

Diagram.BarcodeNodeStyle Property
[image]

Gets the theme-level style for barcode nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public BarcodeNodeStyle BarcodeNodeStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property BarcodeNodeStyle As BarcodeNodeStyle

Property Value

A BarcodeNodeStyle instance that defines the default appearance of BarcodeNodes.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Bounds Property

Diagram.Bounds Property
[image]

Gets or sets a value representing the size of the diagram's scrollable area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF Bounds { get; set; }

Visual Basic [image] Copy Code

Public Property Bounds As RectangleF

Property Value

An instance of the .NET RectangleF structure. The default size of the document is the standard A4 size, that is 210x297.

Remarks

Use this property to specify how large a document should be, that is, how far it can be scrolled. If ShowScrollbars is enabled, setting the document extents also updates the scrollbar ranges. After creating a diagram programmatically, you might wish to call ResizeToFitItems to make the scrollable area just big enough to contain all diagram elements.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
MeasureUnit Property
RestrictItemsToBounds Property
AutoResize Property


MindFusion.Diagramming.Diagram.BoundsPen Property

Diagram.BoundsPen Property
[image]

The pen with which the document bounds should be drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen BoundsPen { get; set; }

Visual Basic [image] Copy Code

Public Property BoundsPen As Pen

Property Value

A Pen instance. The default value is null.

Remarks

This pen is used to draw borders around the diagram bounding rectangle, which could be useful when the DiagramView is larger than the diagram.

See Also

Diagram Members
Diagram Class
ExteriorBrush Property


MindFusion.Diagramming.Diagram.CellCustomDraw Property

Diagram.CellCustomDraw Property
[image]

Gets or sets the default type of custom painting done on the cells of tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CustomDraw CellCustomDraw { get; set; }

Visual Basic [image] Copy Code

Public Property CellCustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. The default is CustomDraw.None.

Remarks

The CellCustomDraw member of new tables is initialized from this property.

See Also

Diagram Members
Diagram Class
TableCustomDraw Property


MindFusion.Diagramming.Diagram.CellFrameStyle Property

Diagram.CellFrameStyle Property
[image]

Gets or sets the default cell border style of new tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CellFrameStyle CellFrameStyle { get; set; }

Visual Basic [image] Copy Code

Public Property CellFrameStyle As CellFrameStyle

Property Value

A member of the CellFrameStyle enumeration. The default is CellFrameStyle.System3D.

Remarks

Use this property to specify the default border style of cells in new tables. See CellFrameStyle enumeration for more details.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.CompositeNodeStyle Property

Diagram.CompositeNodeStyle Property
[image]

Gets the theme-level style for composite nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CompositeNodeStyle CompositeNodeStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CompositeNodeStyle As CompositeNodeStyle

Property Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ContainerCaption Property

Diagram.ContainerCaption Property
[image]

Gets or sets the default value for the Caption property of containers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ContainerCaption { get; set; }

Visual Basic [image] Copy Code

Public Property ContainerCaption As String

Property Value

A string specifying the initial caption text of containers. The default is "Container".

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ContainerCaptionHeight Property

Diagram.ContainerCaptionHeight Property
[image]

Gets or sets the default value for the CaptionHeight property of containers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float ContainerCaptionHeight { get; set; }

Visual Basic [image] Copy Code

Public Property ContainerCaptionHeight As Single

Property Value

A float value specifying the initial height of containers' caption bars. The default is 5.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ContainerHighlightPen Property

Diagram.ContainerHighlightPen Property
[image]

Gets or sets the default value for the HighlightPen property of containers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen ContainerHighlightPen { get; set; }

Visual Basic [image] Copy Code

Public Property ContainerHighlightPen As Pen

Property Value

A Pen instance specifying the initial highlight pen of containers. The default is a pen with Color.LightSkyBlue color and width 0.5.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ContainerMargin Property

Diagram.ContainerMargin Property
[image]

Gets or sets the default value for the Margin property of containers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float ContainerMargin { get; set; }

Visual Basic [image] Copy Code

Public Property ContainerMargin As Single

Property Value

A float value specifying the initial margin size of containers. The default is 10.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ContainerMinimumSize Property

Diagram.ContainerMinimumSize Property
[image]

Gets or sets the default value for the MinimumSize property of containers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SizeF ContainerMinimumSize { get; set; }

Visual Basic [image] Copy Code

Public Property ContainerMinimumSize As SizeF

Property Value

A SizeF value specifying the initial minimum size of containers. The default is 50x40.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ContainerNodeStyle Property

Diagram.ContainerNodeStyle Property
[image]

Gets the theme-level style for container nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNodeStyle ContainerNodeStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ContainerNodeStyle As ContainerNodeStyle

Property Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ContainersFoldable Property

Diagram.ContainersFoldable Property
[image]

Gets or sets the default value for the Foldable property of containers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ContainersFoldable { get; set; }

Visual Basic [image] Copy Code

Public Property ContainersFoldable As Boolean

Property Value

A boolean value specifying whether containers are initially foldable. The default is true.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.CrossingRadius Property

Diagram.CrossingRadius Property
[image]

Gets or sets the radius length of decorations displayed at link intersection points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float CrossingRadius { get; set; }

Visual Basic [image] Copy Code

Public Property CrossingRadius As Single

Property Value

A float value specifying the radius of the arcs drawn at link intersection points.

Remarks

If LinkCrossings is set to Cut, link segments are cut at intersection points and this property defines the length of the break left between adjacent cut points. If LinkCrossings is set to Arcs, this property defines the radius of the arcs drawn over intersection points.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
RoundedLinksRadius Property
DiagramLink.CrossingRadius Property


MindFusion.Diagramming.Diagram.DefaultShape Property

Diagram.DefaultShape Property
[image]

Gets or sets the default shape of shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape DefaultShape { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultShape As Shape

Property Value

An instance of the Shape class. The default is the RoundRect shape.

Remarks

The Shape property of newly created shape nodes is initialized with the value of this property. It defines a series of lines, arcs and curves composed in a complex shape. There are 87 predefined shapes exposed as static members of the Shape class. You can also define your own shapes as shown below.

Example

The following example demonstrates how to create a custom shape and set it as a default in the diagram:

C# [image] Copy Code

private void example_Click(object sender, System.EventArgs e)
{
// Define a custom shape
// this is the same as: fc.DefaultShape = Shape.FromId("Tape");
diagram.DefaultShape = new Shape(
new ElementTemplate[] {
new LineTemplate(50, 100, 85, 100),
new LineTemplate(85, 100, 85, 90),
new LineTemplate(85, 90, 70, 90),
new BezierTemplate(70, 90, 85, 90, 100, 75, 100, 50),
new BezierTemplate(100, 50, 100, 25, 75, 0, 50, 0),
new BezierTemplate(50, 0, 25, 0, 0, 25, 0, 50),
new BezierTemplate(0, 50, 0, 75, 25, 100, 50, 100) },
FillMode.Winding);
}

Visual Basic [image] Copy Code

Private Sub example_Click(ByVal sender As Object, ByVal e As System.EventArgs)

' Define a custom shape
' this is the same as: fc.DefaultShape = Shape.FromId("Tape")
Diagram.DefaultShape = New Shape( _
New ElementTemplate() { _
New LineTemplate(50, 100, 85, 100), _
New LineTemplate(85, 100, 85, 90), _
New LineTemplate(85, 90, 70, 90), _
New BezierTemplate(70, 90, 85, 90, 100, 75, 100, 50), _
New BezierTemplate(100, 50, 100, 25, 75, 0, 50, 0), _
New BezierTemplate(50, 0, 25, 0, 0, 25, 0, 50), _
New BezierTemplate(0, 50, 0, 75, 25, 100, 50, 100)}, _
FillMode.Winding)

End Sub

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ShapeNode.Shape Property
Shape.FromId Method
Shape.Shapes Property
ShapeOrientation Property


MindFusion.Diagramming.Diagram.DiagramLinkStyle Property

Diagram.DiagramLinkStyle Property
[image]

Gets the theme-level style for diagram links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkStyle DiagramLinkStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DiagramLinkStyle As DiagramLinkStyle

Property Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.DiagramStyle Property

Diagram.DiagramStyle Property
[image]

Gets the theme-level style for the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramStyle DiagramStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DiagramStyle As DiagramStyle

Property Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Dirty Property

Diagram.Dirty Property
[image]

Gets or sets a value indicating whether the diagram has changed since the last save.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Dirty { get; set; }

Visual Basic [image] Copy Code

Public Property Dirty As Boolean

Property Value

A boolean value that indicates whether the diagram has changed.

Remarks

MvcDiagram tracks all changes that are done on the diagram contents, either programmatically or by users. If there are changes that are still not saved, the property has value of true. The Dirty flag is cleared automatically when a document is loaded from file or stream. When a document is saved, the Dirty flag can be cleared as specified by an argument of the Save* methods.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DirtyChanged Event
SaveToStream Method
LoadFromStream Method
SaveToFile Method
LoadFromFile Method


MindFusion.Diagramming.Diagram.DisabledHandlesStyle Property

Diagram.DisabledHandlesStyle Property
[image]

Gets the visual style of disabled adjustment handles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HandlesVisualStyle DisabledHandlesStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DisabledHandlesStyle As HandlesVisualStyle

Property Value

An instance of the HandlesVisualStyle class.

Remarks

This style object provides Pen and Brush attributes that let you customize the appearance of disabled adjustment handles.

See Also

Diagram Members
Diagram Class
DiagramNode.EnabledHandles Property


MindFusion.Diagramming.Diagram.DynamicLinks Property

Diagram.DynamicLinks Property
[image]

Gets or sets the default value for the Dynamic property of new links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool DynamicLinks { get; set; }

Visual Basic [image] Copy Code

Public Property DynamicLinks As Boolean

Property Value

true if dynamic links are enabled; otherwise, false. The default is false.

Remarks

Use the property to specify whether links automatically reposition their end segments, so they keep pointing to the centers of connected nodes. If enabled, moving a connected node recalculates the position of link's end point, placing it at appropriate location of the node outline. If the node has anchor points assigned to it, the end point is attached to one of them.

If the value is false, links do not look for the center of the origin and destination node, but keep their relative position as set when they were created - from the left corner of the first node to the top of the other node for instance.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramLink.Dynamic Property
AllowSplitLinks Property


MindFusion.Diagramming.Diagram.EffectiveBackBrush Property

Diagram.EffectiveBackBrush Property
[image]

Gets the currently effective background brush of the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush EffectiveBackBrush { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EffectiveBackBrush As Brush

Property Value

Remarks

This property returns Brush if it is not null, or the brush from the associated style or theme otherwise.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.EffectsProvider Property

Diagram.EffectsProvider Property
[image]

Gets or sets an object used to generate visual effects for shape nodes such as embossment and shadow dispersion.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IEffectsProvider EffectsProvider { get; set; }

Visual Basic [image] Copy Code

Public Property EffectsProvider As IEffectsProvider

Property Value

An object that implements the IEffectsProvider interface. The default is null (Nothing in Visual Basic).

Remarks

For performance reasons, embossment and shadow dispersion effects are implemented through code that processes large amounts of image data by directly accessing the memory allocated to the image. The .NET runtime considers such code unsafe, and the default CAS settings prevent assemblies that contain unsafe code from being loaded in Internet Explorer or IIS. In order to keep the MvcDiagram CAS requirements low, the unsafe code resides in a separate assembly - MindFusion.Diagramming.EffectsProvider.dll. If you wish to use the EnableEmbossEffects and EnableShadowEffects properties, you must add to your project a reference to that assembly, instantiate an EffectsProvider object, and assign it to the EffectsProvider property.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.EnableEmbossEffects Property

Diagram.EnableEmbossEffects Property
[image]

Gets or sets a value indicating whether emboss effect for shape nodes is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableEmbossEffects { get; set; }

Visual Basic [image] Copy Code

Public Property EnableEmbossEffects As Boolean

Property Value

true to enable embossment of shape nodes; otherwise, false. The default is false.

Remarks

In order to use the shape embossment effect, you must also set the EffectsProvider property.

See Also

Diagram Members
Diagram Class
EnableShadowEffects Property


MindFusion.Diagramming.Diagram.EnableLanes Property

Diagram.EnableLanes Property
[image]

Gets or sets whether lanes are enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableLanes { get; set; }

Visual Basic [image] Copy Code

Public Property EnableLanes As Boolean

Property Value

true if lanes are enabled; otherwise, false. The default is false.

Remarks

You can customize the lane grid through the LaneGrid property.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.EnableShadowEffects Property

Diagram.EnableShadowEffects Property
[image]

Gets or sets a value indicating whether the shadow dispersion effect for nodes is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableShadowEffects { get; set; }

Visual Basic [image] Copy Code

Public Property EnableShadowEffects As Boolean

Property Value

true to enable shadow dispersion; otherwise, false. The default is false.

Remarks

In order to use the shadow dispersion effect, you must also set the EffectsProvider property.

See Also

Diagram Members
Diagram Class
EnableEmbossEffects Property


MindFusion.Diagramming.Diagram.EnableStyledText Property

Diagram.EnableStyledText Property
[image]

Gets or sets the default value for the EnableStyledText property of new nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableStyledText { get; set; }

Visual Basic [image] Copy Code

Public Property EnableStyledText As Boolean

Property Value

true to parse the text of items in order to find formatting tags; otherwise, false. The default is false.

Remarks

Styled text allows applying various attributes to the characters it contains. Attributes are specified using HTML-like formatting tags embedded in the raw text. Formatting tags are listed and described in the Text Attributes and Formatting section of this help file.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ExpandButtonAction Property

Diagram.ExpandButtonAction Property
[image]

Gets or sets a value indicating what should happen when a user clicks the [±] button that is displayed near expandable nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ExpandButtonAction ExpandButtonAction { get; set; }

Visual Basic [image] Copy Code

Public Property ExpandButtonAction As ExpandButtonAction

Property Value

A member of the ExpandButtonAction enumeration. The default is ExpandTreeBranch.

Remarks

The default behavior of a [±] button displayed nearby an Expandable node is to hide or show the children of that node. In that case, the children of a node are all nodes that can be reached from it by following recursively the OutgoingLinks or IncomingLinks, as defined by the ExpandOnIncoming property.

To implement custom expand/collapse functionality, set ExpandButtonAction to RaiseEvents and handle the ExpandButtonClicked event. That lets you use other criteria for what nodes should be shown or hidden, for example, containment or hierarchical grouping.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ExpandButtonPosition Property
TreeCollapsed Event
TreeExpanded Event


MindFusion.Diagramming.Diagram.ExpandButtonPosition Property

Diagram.ExpandButtonPosition Property
[image]

Gets or sets where expand/collapse buttons are located relatively to their nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ExpandButtonPosition ExpandButtonPosition { get; set; }

Visual Basic [image] Copy Code

Public Property ExpandButtonPosition As ExpandButtonPosition

Property Value

A member of the ExpandButtonPosition enumeration. The default is OuterRight.

Remarks

If diagram links tend to flow vertically, it would be useful to have the expand/collapse buttons stay at the left- or right-hand side of nodes. If diagram links tend to flow horizontally, choose position for expand buttons such that they stay above or below nodes. That will prevent button icons from being overlapped by links.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
NodesExpandable Property
ExpandButtonAction Property


MindFusion.Diagramming.Diagram.ExpandOnIncoming Property

Diagram.ExpandOnIncoming Property
[image]

Gets or sets a value, indicating in which direction object hierarchies are expanded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ExpandOnIncoming { get; set; }

Visual Basic [image] Copy Code

Public Property ExpandOnIncoming As Boolean

Property Value

true if trees are expanded in the direction of the links, which come into nodes; otherwise, false. The default is false.

Remarks

Use this property when presenting tree structures with enabled collapse/expand. If the property is set to false, a clicked expand button of a node expands in the direction of the node's outgoing links. That is, the nodes pointed by links going out of a node are considered children of that node.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
RecursiveExpand Property
NodesExpandable Property


MindFusion.Diagramming.Diagram.ExteriorBrush Property

Diagram.ExteriorBrush Property
[image]

Gets or sets the brush used for painting the area outside Bounds.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush ExteriorBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ExteriorBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class. Default value is null (Nothing in Visual Basic).

Remarks

If ExteriorBrush is set to null, the BackBrush is used to paint the areas both inside and outside Bounds. In order to scroll the exterior filling and the background image consistently, ExteriorBrush can be used only with document-relative BackgroundImageAlign.

See Also

Diagram Members
Diagram Class
Brush and Pen Classes


MindFusion.Diagramming.Diagram.Factory Property

Diagram.Factory Property
[image]

Gets a Factory instance that lets you add programmatically new items to the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Factory Factory { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Factory As Factory

Property Value

An instance of the Factory class.

Remarks

You can add a new node or link to the diagram by creating an instance of the item class by using the new operator and adding it to the Nodes or Links collection. This works the same way for adding both items from your custom class or ones from the MvcDiagram predefined types. The Factory class methods are just shortcuts that let you do that with a single method call, and they work only for the predefined item classes.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.FocusedComponent Property

Diagram.FocusedComponent Property
[image]

Gets or sets the component within this diagram which currently has the input focus.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ComponentBase FocusedComponent { get; set; }

Visual Basic [image] Copy Code

Public Property FocusedComponent As ComponentBase

Property Value

An instance of a ComponentBase -derived class.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Components
ComponentBase.GotFocus Event


MindFusion.Diagramming.Diagram.FoldedContainerSize Property

Diagram.FoldedContainerSize Property
[image]

Gets or sets the size of folded containers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SizeF FoldedContainerSize { get; set; }

Visual Basic [image] Copy Code

Public Property FoldedContainerSize As SizeF

Property Value

A SizeF instance specifying the size of folded containers. The default value is SizeF.Empty.

Remarks

If this property is not set, the width of folded containers is set to their MinimumSize and the height to their CaptionHeight.

See Also

Diagram Members
Diagram Class
ContainerNode.Folded Property


MindFusion.Diagramming.Diagram.Font Property

Diagram.Font Property
[image]

Gets or sets the default font for new diagram items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Font Font { get; set; }

Visual Basic [image] Copy Code

Public Property Font As Font

Property Value

An instance of the .NET Font class. The default is Microsoft Sans Serif, 9pt.

Remarks

The Font of new nodes and links is initialized with the value of this property.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramItem.Font Property
 DiagramView.TextRenderingHint Property


MindFusion.Diagramming.Diagram.GridColor Property

Diagram.GridColor Property
[image]

Gets or sets the color of the grid points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color GridColor { get; set; }

Visual Basic [image] Copy Code

Public Property GridColor As Color

Property Value

An instance of the .NET Color structure. The default is Color.FromArgb(140, 140, 150).

Remarks

Use the property to specify the color of grid points and lines.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ShowGrid Property
GridSizeX Property
GridSizeY Property
GridStyle Property


MindFusion.Diagramming.Diagram.GridOffsetX Property

Diagram.GridOffsetX Property
[image]

Gets or sets the horizontal offset of the first point of the alignment grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float GridOffsetX { get; set; }

Visual Basic [image] Copy Code

Public Property GridOffsetX As Single

Property Value

A float value that specifies the horizontal grid offset. The default is Single.NaN.

Remarks

The property specifies the offset of the first point of the alignment grid. The default value NaN makes the grid start at offset GridSizeX / 2.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ShowGrid Property
GridOffsetY Property
MeasureUnit Property


MindFusion.Diagramming.Diagram.GridOffsetY Property

Diagram.GridOffsetY Property
[image]

Gets or sets the vertical offset of the first point of the alignment grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float GridOffsetY { get; set; }

Visual Basic [image] Copy Code

Public Property GridOffsetY As Single

Property Value

A float value that specifies the vertical grid offset. The default is Single.NaN.

Remarks

The property specifies the offset of the first point of the alignment grid. The default value NaN makes the grid start at offset GridSizeY / 2.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ShowGrid Property
GridOffsetX Property
MeasureUnit Property


MindFusion.Diagramming.Diagram.GridSizeX Property

Diagram.GridSizeX Property
[image]

Gets or sets the horizontal distance between adjacent grid points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float GridSizeX { get; set; }

Visual Basic [image] Copy Code

Public Property GridSizeX As Single

Property Value

A float number specifying the horizontal distance between grid points. The default is 4.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ShowGrid Property
AlignToGrid Property
AlignPointToGrid Method
MeasureUnit Property


MindFusion.Diagramming.Diagram.GridSizeY Property

Diagram.GridSizeY Property
[image]

Gets or sets the vertical distance between adjacent grid points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float GridSizeY { get; set; }

Visual Basic [image] Copy Code

Public Property GridSizeY As Single

Property Value

A float number specifying the vertical distance between grid points. The default is 4.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ShowGrid Property
AlignToGrid Property
AlignPointToGrid Method
MeasureUnit Property


MindFusion.Diagramming.Diagram.GridStyle Property

Diagram.GridStyle Property
[image]

Gets or sets the visual style of the alignment grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GridStyle GridStyle { get; set; }

Visual Basic [image] Copy Code

Public Property GridStyle As GridStyle

Property Value

A member of the GridStyle enumeration. The default is Points.

Remarks

Specifies how the alignment grid is drawn. If the property value is set to Points, the grid is painted as a matrix of points. If set to Lines, the grid is represented as a series of crossing horizontal and vertical lines. Grid points or lines are painted with the color set in GridColor; the distance between them is specified by the GridSizeX and GridSizeY properties.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ShowGrid Property
AlignToGrid Property


MindFusion.Diagramming.Diagram.Groups Property

Diagram.Groups Property
[image]

Gets a collection of all groups in the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GroupCollection Groups { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Groups As GroupCollection

Property Value

An instance of the GroupCollection class.

Remarks

Groups provides access to all groups defined in the current diagram.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Items Property
Factory.CreateGroup Method


MindFusion.Diagramming.Diagram.HitTestPriority Property

Diagram.HitTestPriority Property
[image]

Gets or sets a value indicating the order in which items are hit-tested.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HitTestPriority HitTestPriority { get; set; }

Visual Basic [image] Copy Code

Public Property HitTestPriority As HitTestPriority

Property Value

A member of the HitTestPriority enumeration. The default value is NodesBeforeLinks.

Remarks

For easier selection, links have a hit-detection area several pixels wider than their visible segment lines. However, if several links with higher z-index cross a node, it would be difficult to select it. The HitTestPriority property allows altering hit-test results in such situations. If set to NodesBeforeLinks, nodes are hit-tested before all links. ZOrder makes all items tested in decreasing z-order, independently of their type.

See Also

Diagram Members
Diagram Class
LinkHitDistance Property


MindFusion.Diagramming.Diagram.Interaction Property

Diagram.Interaction Property
[image]

Gets an InteractionState instance representing the current action being carried out by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public InteractionState Interaction { get; set; }

Visual Basic [image] Copy Code

Public Property Interaction As InteractionState

Property Value

An instance of the InteractionState class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.IsProEdition Property

Diagram.IsProEdition Property
[image]

Gets a value indicating whether the currently loaded MvcDiagram is a professional version of the control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsProEdition { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsProEdition As Boolean

Property Value

true if the currently loaded MvcDiagram control is a professional version; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Items Property

Diagram.Items Property
[image]

Gets a collection of all items in this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemCollection Items { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Items As DiagramItemCollection

Property Value

An instance of the DiagramItemCollection class.

Remarks

This collection gives you access to all items contained in this document. You can also use it to add new items to the diagram.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Nodes Property
Links Property


MindFusion.Diagramming.Diagram.LaneGrid Property

Diagram.LaneGrid Property
[image]

Gets the Grid instance that represents the lane grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Grid LaneGrid { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LaneGrid As Grid

Property Value

An instance of the Grid class.

Remarks

The Grid object gives you full control over the lane grid. For example, it lets you set the number of rows and columns in the grid, add headers, customize the appearance, subscribe to events and so on.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Layers Property

Diagram.Layers Property
[image]

Gets a list of the layers in the current diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IList<Layer> Layers { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Layers As IList(Of Layer)

Property Value

A list with all diagram layers.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkBaseShape Property

Diagram.LinkBaseShape Property
[image]

Gets or sets the shape displayed at the base of new links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape LinkBaseShape { get; set; }

Visual Basic [image] Copy Code

Public Property LinkBaseShape As Shape

Property Value

A Shape instance that represents an arrowhead shape. The default is None.

Remarks

This property specifies the default shape displayed as arrowhead at the links' origin points. The ArrowHeads class exposes several predefined shapes as static properties.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramLink.BaseShape Property
LinkBaseShapeSize Property
LinkHeadShape Property
LinkIntermediateShape Property


MindFusion.Diagramming.Diagram.LinkBaseShapeSize Property

Diagram.LinkBaseShapeSize Property
[image]

Gets or sets the default size of the base of new links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float LinkBaseShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property LinkBaseShapeSize As Single

Property Value

A float value that specifies the size. The default is 5.

Remarks

The property specifies the size of the graphical shapes that are displayed at the start of new diagram links, for example, at the beginning of the links.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramLink.BaseShapeSize Property
LinkBaseShape Property


MindFusion.Diagramming.Diagram.LinkBrush Property

Diagram.LinkBrush Property
[image]

Gets or sets the default value for the Brush property of links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush LinkBrush { get; set; }

Visual Basic [image] Copy Code

Public Property LinkBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

Remarks

The property provides a default value for the brush, with which an arrowhead's interior is filled. The Brush property of new links is initialized with a clone of LinkBrush, but after link creation the properties are independent - changing one of them does not change the other.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Brush and Pen Classes
LinkPen Property


MindFusion.Diagramming.Diagram.LinkCascadeOrientation Property

Diagram.LinkCascadeOrientation Property
[image]

Gets or sets the initial orientation of the first segment of new cascading links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation LinkCascadeOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property LinkCascadeOrientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Auto.

Remarks

Use this property to specify the default orientation of the first segment of DiagramLink objects whose Shape is set to LinkShape.Cascading. The default value, Auto, lets the component decide whether to draw the first segment horizontally or vertically. See Orientation for more details.

See Also

Diagram Members
Diagram Class
DiagramLink.CascadeOrientation Property


MindFusion.Diagramming.Diagram.LinkCrossings Property

Diagram.LinkCrossings Property
[image]

Gets or sets how to render the intersection points where links cross their paths.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkCrossings LinkCrossings { get; set; }

Visual Basic [image] Copy Code

Public Property LinkCrossings As LinkCrossings

Property Value

A member of the LinkCrossings enumeration. The default is Straight.

Remarks

Intersection points where links cross each other's paths can be rendered as arcs or breaks, depending on the value of this property. The z-order defines which links jump over the others or which links are cut by the others. If LinkCrossings is set to Arcs, links with higher ZIndex jump over those with lower ZIndex. If set to Cut, segments of links at lower z-position are cut by links at higher z-position. Radius of arcs and breaks can be set by the CrossingRadius property.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramLink.DrawCrossings Property
RouteLinks Property
RoundedLinks Property


MindFusion.Diagramming.Diagram.LinkCustomDraw Property

Diagram.LinkCustomDraw Property
[image]

Gets or sets the default type of custom painting done on links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CustomDraw LinkCustomDraw { get; set; }

Visual Basic [image] Copy Code

Public Property LinkCustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. The default is None.

Remarks

This property specifies whether and how custom painting of links is performed. Its value is assigned to the CustomDraw property of new links.

See Also

Diagram Members
Diagram Class
DrawLink Event


MindFusion.Diagramming.Diagram.LinkEndsMovable Property

Diagram.LinkEndsMovable Property
[image]

Gets or sets a value indicating whether link ends can be moved by users after the link is created.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool LinkEndsMovable { get; set; }

Visual Basic [image] Copy Code

Public Property LinkEndsMovable As Boolean

Property Value

true if moving link ends is allowed; false, if not.

Remarks

When the property is set to true, users cannot move the ends of a link after the link is created. This prevents them from connecting the links to other origin and destination nodes.

See Also

Diagram Members
Diagram Class
LinkModifying Event


MindFusion.Diagramming.Diagram.LinkHandlesStyle Property

Diagram.LinkHandlesStyle Property
[image]

Gets or sets the default value for the HandlesStyle property of new links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HandlesStyle LinkHandlesStyle { get; set; }

Visual Basic [image] Copy Code

Public Property LinkHandlesStyle As HandlesStyle

Property Value

A member of the HandlesStyle enumeration. The default is SquareHandles.

Remarks

Default value for the HandlesStyle property of new links, created either programmatically or by a user. That property specifies how links' selection status is indicated visually.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkHeadShape Property

Diagram.LinkHeadShape Property
[image]

Gets or sets the shape displayed as head of new links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape LinkHeadShape { get; set; }

Visual Basic [image] Copy Code

Public Property LinkHeadShape As Shape

Property Value

A Shape instance that represents an arrowhead shape. The default is Arrow.

Remarks

This property specifies the default shape displayed as arrowhead at the links' end points. The ArrowHeads class exposes several predefined shapes as static properties.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramLink.HeadShape Property
LinkHeadShapeSize Property
LinkBaseShape Property
LinkIntermediateShape Property


MindFusion.Diagramming.Diagram.LinkHeadShapeSize Property

Diagram.LinkHeadShapeSize Property
[image]

Gets or sets the default size of arrowheads.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float LinkHeadShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property LinkHeadShapeSize As Single

Property Value

A float value that measures the size. The default is 5.

Remarks

The property specifies how big the shapes of new arrowheads are.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramLink.HeadShapeSize Property
LinkHeadShape Property


MindFusion.Diagramming.Diagram.LinkHitDistance Property

Diagram.LinkHitDistance Property
[image]

Gets or sets a value specifying how far from a link a click is still considered a hit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float LinkHitDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LinkHitDistance As Single

Property Value

A float value specifying the distance in MeasureUnit units. The default value is 0.

Remarks

If this property is set to 0, the control considers it a hit when a link is no further than five millimeters from the mouse position. This LinkHitDistance value is also used when hit-testing programmatically, e.g. by calling the GetItemAt method.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
HitTestPriority Property
AutoSnapDistance Property


MindFusion.Diagramming.Diagram.LinkIntermediateShape Property

Diagram.LinkIntermediateShape Property
[image]

Gets or sets the default shape to be displayed in the middle of each segment of links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape LinkIntermediateShape { get; set; }

Visual Basic [image] Copy Code

Public Property LinkIntermediateShape As Shape

Property Value

A Shape instance that represents an arrowhead shape. The default is None.

Remarks

The property specifies default shape to be displayed at the middle of each segment of new links. It facilitates users by following the path of a link across the diagram, especially for longer links in large documents. The ArrowHeads class exposes several predefined shapes as static properties.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramLink.IntermediateShape Property
LinkIntermediateShapeSize Property
LinkHeadShape Property
LinkBaseShape Property


MindFusion.Diagramming.Diagram.LinkIntermediateShapeSize Property

Diagram.LinkIntermediateShapeSize Property
[image]

Gets or sets the default size of the shapes at middles of link segments.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float LinkIntermediateShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property LinkIntermediateShapeSize As Single

Property Value

A float value that measures the size. The default is 5.

Remarks

Specifies default value for the IntermediateShapeSize property of new links.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramLink.IntermediateShapeSize Property
LinkIntermediateShape Property


MindFusion.Diagramming.Diagram.LinkPen Property

Diagram.LinkPen Property
[image]

Gets or sets the default value for the Pen and HeadPen properties of links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen LinkPen { get; set; }

Visual Basic [image] Copy Code

Public Property LinkPen As Pen

Property Value

An instance of the MindFusion.Drawing.Pen class.

Remarks

The property provides a default value for the pens, with which link's segments and arrowhead lines are painted. The Pen and HeadPen properties of new links are initialized with clones of LinkPen, but after link creation the properties are independent - changing one of them does not change the others.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Brush and Pen Classes
LinkBrush Property


MindFusion.Diagramming.Diagram.LinkRouter Property

Diagram.LinkRouter Property
[image]

Gets or sets the component used to find paths for auto-routed links when diagram nodes are added or their positions change.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ILinkRouter LinkRouter { get; set; }

Visual Basic [image] Copy Code

Public Property LinkRouter As ILinkRouter

Property Value

An instance of a class implementing the ILinkRouter interface. The currently available implementations include GridRouter and QuickRouter.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Links Property

Diagram.Links Property
[image]

Gets a collection of all DiagramLink objects in the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection Links { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Links As DiagramLinkCollection

Property Value

An instance of the DiagramLinkCollection class.

Remarks

Links provides type-safe access to all links in the current diagram. Any diagram element can be accessed also via the Items collection.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Items Property
Nodes Property
Groups Property
Factory.CreateDiagramLink Method


MindFusion.Diagramming.Diagram.LinkSegments Property

Diagram.LinkSegments Property
[image]

Gets or sets the default number of link segments.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public short LinkSegments { get; set; }

Visual Basic [image] Copy Code

Public Property LinkSegments As Short

Property Value

An integer value specifying how many segments links consists of. The default is 1.

Remarks

Use the property to create more indented links, when necessary.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramLink.SegmentCount Property
LinkShape Property


MindFusion.Diagramming.Diagram.LinkShape Property

Diagram.LinkShape Property
[image]

Gets or sets the default value of the Shape property of new links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkShape LinkShape { get; set; }

Visual Basic [image] Copy Code

Public Property LinkShape As LinkShape

Property Value

A member of the LinkShape enumeration. The default value is Polyline.

Remarks

Use the property to specify how new links are composed and what they look like. The segments of a link could be curves or straight lines, and they might be restricted to be horizontal / vertical only.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramLink.Shape Property
RoundedLinks Property


MindFusion.Diagramming.Diagram.LinksRetainForm Property

Diagram.LinksRetainForm Property
[image]

Gets or sets whether links should maintain their forms if the nodes linked with those links are moved around.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool LinksRetainForm { get; set; }

Visual Basic [image] Copy Code

Public Property LinksRetainForm As Boolean

Property Value

true to retain links' forms; otherwise, false. The default is false.

Remarks

LinksRetainForm value is used to initialize the RetainForm property of new links. It has effect on links that have more than two control points. If the nodes that a link connects are moved around, usually only the segments at the ends of that link are updated, so that they stay connected to their respective nodes. In that case all intermediate control points stay where they are. However, if RetainForm is enabled, all control points will move simultaneously in a way they preserve their relative position one to another, and thus preserving the overall form of the link.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
RouteLinks Property
DynamicLinks Property


MindFusion.Diagramming.Diagram.LinkText Property

Diagram.LinkText Property
[image]

Gets or sets the default text of links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string LinkText { get; set; }

Visual Basic [image] Copy Code

Public Property LinkText As String

Property Value

A string specifying the initial text of links. The default is an empty string.

Remarks

The value of this property is assigned to the Text property of new links.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramLink.TextColor Property
TextFormat Property


MindFusion.Diagramming.Diagram.LinkTextStyle Property

Diagram.LinkTextStyle Property
[image]

Gets or sets default placement and orientation for links' text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkTextStyle LinkTextStyle { get; set; }

Visual Basic [image] Copy Code

Public Property LinkTextStyle As LinkTextStyle

Property Value

A member of the LinkTextStyle enumeration. The default value is Center.

Remarks

The value of this property is used to initialize the TextStyle property of new links.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.MeasureTextRenderingHint Property

Diagram.MeasureTextRenderingHint Property
[image]

Gets or sets the TextRenderingHint to use when measuring texts. This should be effectively set to the value of DiagramView.TextRenderingHint.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static TextRenderingHint MeasureTextRenderingHint { get; set; }

Visual Basic [image] Copy Code

Public Shared Property MeasureTextRenderingHint As TextRenderingHint

Property Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.MeasureUnit Property

Diagram.MeasureUnit Property
[image]

Gets or sets the unit of measure used for logical coordinates in this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MeasureUnit MeasureUnit { get; set; }

Visual Basic [image] Copy Code

Public Property MeasureUnit As MeasureUnit

Property Value

An instance of the MeasureUnit class. The default value is Millimeter.

Remarks

Many properties in the MvcDiagram API are used to specify the dimensions of diagram items or the size of various visual elements, for example, selection handles, arrowhead shapes, frame widths, and so on. MeasureUnit specifies the measure of length in which these size values are defined.

Changing the measure unit does not automatically rescale the size-related property values. Your application must set appropriate values to: Bounds, GridSizeX, GridSizeY, GridOffsetX, GridOffsetY, AdjustmentHandlesSize, LinkBaseShapeSize, LinkHeadShapeSize, LinkIntermediateShapeSize, TableCaptionHeight, TableColumnWidth, TableRowHeight, CrossingRadius, ShadowOffsetX, ShadowOffsetY and to the size-related members of RoutingOptions.

Changing the measure unit resets RoutingOptions to default values for the new unit, because performance might suffer greatly if the routing algorithm uses too big or too small GridSize.

The arguments passed to some methods depend on the measure unit too, for example, CreateShapeNode, CreateTableNode, ClientToDoc and DocToClient, GetNodeAt, GetLinkAt, ZoomToRect.

The following MeasureUnit members provide ready-to-use measure units:

Member name | Description
Centimeter | Specifies centimeters as the unit of measure.
Document | Specifies the document unit (1/300 inch) as the unit of measure.
Inch | Specifies the inch as the unit of measure.
Millimeter | Specifies the millimeter as the unit of measure.
Pixel | Specifies a device pixel as the unit of measure. Note that print and on-screen output will differ greatly in size when using pixels because printer pixels are much smaller than screen ones.
Point | Specifies a printer's point (1/72 inch) as the unit of measure.
WpfPoint | Specifies device-independent pixels (1/96 inch) as the unit of measure.

See Also

Diagram Members
Diagram Class
ChangeUnit Method


MindFusion.Diagramming.Diagram.MergeThreshold Property

Diagram.MergeThreshold Property
[image]

Gets or sets the maximum distance between adjacent control points of a link at which the respective segments can be merged.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float MergeThreshold { get; set; }

Visual Basic [image] Copy Code

Public Property MergeThreshold As Single

Property Value

A float value Specifying the maximum distance in the current MeasureUnit. The default is 0.

Remarks

An user may add or remove links' segments interactively when the AllowSplitLinks property is enabled. They can drag a link's control point over the next one in order to merge two adjacent segments. Usually the two points must be placed exactly at the same coordinates in order to merge the respective segments of the link. Assign a larger value to this property if you wish to make it easier for users to merge segments by just moving link's control point close one to another.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.MinimumNodeSize Property

Diagram.MinimumNodeSize Property
[image]

Gets or sets the minimum node size that the user is allowed to set.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SizeF MinimumNodeSize { get; set; }

Visual Basic [image] Copy Code

Public Property MinimumNodeSize As SizeF

Property Value

A SizeF instance specifying the minimum size allowed for nodes.

Remarks

If the user releases the mouse button while creating or modifying a node and the node size is smaller than this value, the operation is cancelled.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.NodeEffects Property

Diagram.NodeEffects Property
[image]

Gets a collection with all effects applied to the nodes of this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IList<NodeEffect> NodeEffects { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NodeEffects As IList(Of NodeEffect)

Property Value

A list with all currently active node effects.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Nodes Property

Diagram.Nodes Property
[image]

Gets a collection of all DiagramNode objects in the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeCollection Nodes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Nodes As DiagramNodeCollection

Property Value

An instance of the DiagramNodeCollection class.

Remarks

Nodes provides type-safe access to all nodes in the current diagram. Any diagram element can be accessed also by using the Items collection.

Example

The following code adds a new ControlNode to the diagram:

C# [image] Copy Code

ControlNode controlNode = new ControlNode(diagramView);
controlNode.Bounds = new RectangleF(10, 10, 30, 30);
controlNode.Control = new DataGrid();
diagram.Nodes.Add(controlNode);

Visual Basic [image] Copy Code

Dim controlNode As New ControlNode(diagramView)
controlNode.Bounds = New RectangleF(10, 10, 30, 30)
controlNode.Control = New DataGrid
diagram.Nodes.Add(controlNode)

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Items Property
Links Property
Groups Property
Factory.CreateShapeNode Method


MindFusion.Diagramming.Diagram.NodesExpandable Property

Diagram.NodesExpandable Property
[image]

Gets or sets a value indicating whether newly created nodes can be expanded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool NodesExpandable { get; set; }

Visual Basic [image] Copy Code

Public Property NodesExpandable As Boolean

Property Value

true if new nodes can be expanded; otherwise, false. The default is false.

Remarks

If using MvcDiagram to present tree/hierarchical diagrams, you might set NodesExpandable to true. If enabled, the property makes each newly created node appear with a [±] sign next to it, which expands or collapses the node's descendants.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ExpandButtonPosition Property
RecursiveExpand Property
ExpandOnIncoming Property
TreeCollapsed Event
TreeExpanded Event
DiagramNode.Expandable Property


MindFusion.Diagramming.Diagram.NowLoading Property

Diagram.NowLoading Property
[image]

Gets a value indicating whether the diagram data is now being loaded from a file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool NowLoading { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NowLoading As Boolean

Property Value

true if the diagram is currently in a loading state; otherwise, false.

See Also

Diagram Members
Diagram Class
LoadFromFile Method


MindFusion.Diagramming.Diagram.PolygonalTextLayout Property

Diagram.PolygonalTextLayout Property
[image]

Gets or sets a value indicating whether to enable the formatting of text inside non-rectangular shape node outlines.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool PolygonalTextLayout { get; set; }

Visual Basic [image] Copy Code

Public Property PolygonalTextLayout As Boolean

Property Value

true to enable polygonal formatting; false to disable it.

Remarks

Specifies a default value for the PolygonalTextLayout property of shape nodes.

See Also

Diagram Members
Diagram Class
DefaultShape Property


MindFusion.Diagramming.Diagram.RecursiveExpand Property

Diagram.RecursiveExpand Property
[image]

Gets or sets value indicating how a tree is expanded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RecursiveExpand { get; set; }

Visual Basic [image] Copy Code

Public Property RecursiveExpand As Boolean

Property Value

true if a tree is recursively expanded; otherwise, false. The default is false.

Remarks

Use the property when representing tree structures, which hide some of their elements. When the property is set to true, clicking on a certain node in the tree, expands not only its descendants, but all descendants of the descendants, and so on, till the whole tree is expanded.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ExpandOnIncoming Property
NodesExpandable Property


MindFusion.Diagramming.Diagram.RestrictItemsToBounds Property

Diagram.RestrictItemsToBounds Property
[image]

Gets or sets a value indicating whether users are allowed to place items outside the scrollable area of the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RestrictToBounds RestrictItemsToBounds { get; set; }

Visual Basic [image] Copy Code

Public Property RestrictItemsToBounds As RestrictToBounds

Property Value

A member of the RestrictToBounds enumeration. The default is Intersection.

Remarks

Use this property to specify whether diagram elements can be drawn or moved outside the document area. It is possible to specify that items have to be entirely inside, partly outside or there is no restriction.

If there is no restriction and AutoResize is disabled, users could place an item to a position where they cannot reach it by scrolling. That might be interpreted as an item deletion operation by handling the NodeModified event and deleting the item if it is outside the document boundaries.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Bounds Property
AutoResize Property


MindFusion.Diagramming.Diagram.RoundedLinks Property

Diagram.RoundedLinks Property
[image]

Gets or sets a value indicating whether the joins between segments of Polyline and Cascading links should be rounded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RoundedLinks { get; set; }

Visual Basic [image] Copy Code

Public Property RoundedLinks As Boolean

Property Value

true to use rounded segment joins; otherwise, false. The default is false.

Remarks

The value of this property is considered when drawing links whose Shape is set to Polyline or Cascading. If the property is enabled, the joins between the segments of all such links are drawn as arcs, whose radius equals the value of RoundedLinksRadius.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramLink.Shape Property
LinkCrossings Property


MindFusion.Diagramming.Diagram.RoundedLinksRadius Property

Diagram.RoundedLinksRadius Property
[image]

Gets or sets the radius of arc joins of rounded links' segments.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float RoundedLinksRadius { get; set; }

Visual Basic [image] Copy Code

Public Property RoundedLinksRadius As Single

Property Value

A float value specifying the radius length. The default is 2.

Remarks

The value of this property is used when RoundedLinks is enabled. It specifies the radius of the arcs drawn as joins between link segments.

See Also

Diagram Members
Diagram Class
CrossingRadius Property


MindFusion.Diagramming.Diagram.RoundRectFactor Property

Diagram.RoundRectFactor Property
[image]

Gets or sets the relative size of arcs displayed at the corners of rounded rectangles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float RoundRectFactor { get; set; }

Visual Basic [image] Copy Code

Public Property RoundRectFactor As Single

Property Value

A float multiplier applied to the radius of the arcs used as corners of rounded rectangles. The default is 1.

Remarks

The default length of the radius of rounded-corner arcs is 7. This property lets you increase or decrease that value by multiplying it by the specified factor.

See Also

Diagram Members
Diagram Class
TableShape Property


MindFusion.Diagramming.Diagram.RouteLinks Property

Diagram.RouteLinks Property
[image]

Gets or sets a value indicating whether links should avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RouteLinks { get; set; }

Visual Basic [image] Copy Code

Public Property RouteLinks As Boolean

Property Value

true to route links; otherwise, false. The default is false.

Remarks

The value of RouteLinks is used to initialize the AutoRoute property of new links. If a node is moved or resized, all links that intersect with its new position and have AutoRoute enabled are rerouted. Keep in mind that number of link segments will probably change when routing is enabled.

RoutingOptions allows tuning the routing algorithm. The most important options are the cost values exposed as LengthCost, TurnCost and CrossingCost properties. They greatly influence the shape of the generated route.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
RouteAllLinks Method
DynamicLinks Property
LinkCrossings Property


MindFusion.Diagramming.Diagram.RoutingOptions Property

Diagram.RoutingOptions Property
[image]

Gets an object, which allows customizing various parameters of the link routing algorithm.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RoutingOptions RoutingOptions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RoutingOptions As RoutingOptions

Property Value

An instance of the RoutingOptions class.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
RouteLinks Property
RouteAllLinks Method


MindFusion.Diagramming.Diagram.RowHighlightBrush Property

Diagram.RowHighlightBrush Property
[image]

Gets or sets the Brush used to fill highlighted table rows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush RowHighlightBrush { get; set; }

Visual Basic [image] Copy Code

Public Property RowHighlightBrush As Brush

Property Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ScriptHelper Property

Diagram.ScriptHelper Property
[image]

Gets a ScriptHelper object which can be used in html scripts to instantiate various objects and to call static methods.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ScriptHelper ScriptHelper { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ScriptHelper As ScriptHelper

Property Value

An instance of the ScriptHelper class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.SelectAfterCreate Property

Diagram.SelectAfterCreate Property
[image]

Gets or sets a value indicating whether newly created objects are automatically selected.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SelectAfterCreate { get; set; }

Visual Basic [image] Copy Code

Public Property SelectAfterCreate As Boolean

Property Value

true if items are selected after being created; otherwise, false. The default is true.

Remarks

Use the property to specify if the items that are drawn are selecting, which allows immediate modification actions to be performed over them.

See Also

Diagram Members
Diagram Class
Selection Property


MindFusion.Diagramming.Diagram.SelectedItemHandlesStyle Property

Diagram.SelectedItemHandlesStyle Property
[image]

Gets the visual style of adjustment handles of selected items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HandlesVisualStyle SelectedItemHandlesStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SelectedItemHandlesStyle As HandlesVisualStyle

Property Value

An instance of the HandlesVisualStyle class.

Remarks

This style object provides Pen and Brush attributes that let you customize the appearance of adjustment handles drawn around selected items.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Selection Property
ActiveItemHandlesStyle Property


MindFusion.Diagramming.Diagram.Selection Property

Diagram.Selection Property
[image]

Gets a Selection instance that represents the selection of items in this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Selection Selection { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Selection As Selection

Property Value

An instance of the Selection class representing the current selection.

Remarks

Use this property to get the items currently selected by a user. Items can be enumerated by the Items member of the Selection class. An item from the selection is considered the active one and can be accessed by using ActiveItem. To prevent users from selecting multiple items, set AllowMultipleSelection to false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramView.ModificationStart Property
AdjustmentHandlesSize Property
HitTestPriority Property


MindFusion.Diagramming.Diagram.SelectionOnTop Property

Diagram.SelectionOnTop Property
[image]

Gets or sets a value indicating whether selected items should be painted on top of other items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SelectionOnTop { get; set; }

Visual Basic [image] Copy Code

Public Property SelectionOnTop As Boolean

Property Value

true if selected items should be painted on top; otherwise, false. The default is true.

Remarks

If SelectionOnTop is enabled, selected items are painted over non-selected ones, ignoring the z-order position specified in ZIndex. If disabled, the items are painted as set in the z-order.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Selection Class
ActiveItem Property
SortGroupsByZ Property


MindFusion.Diagramming.Diagram.SerializationBinder Property

Diagram.SerializationBinder Property
[image]

Gets or sets a SerializationBinder object used to control class loading.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SerializationBinder SerializationBinder { get; set; }

Visual Basic [image] Copy Code

Public Property SerializationBinder As SerializationBinder

Property Value

An instance of System.Runtime.Serialization.SerializationBinder -derived class. The default value is null (Nothing in VB.NET).

Remarks

You can use a custom serialization binder when serializable classes used in your application have been renamed or moved to a different namespace. Objects from such classes cannot be deserialized, unless the BindToType method of SerializationBinder maps the old class names to their corresponding types. Return null from your BindToType implementation for types you don't recognize, to let the diagram control process its own obsolete types.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ShadowBrush Property

Diagram.ShadowBrush Property
[image]

Gets or sets the default brush used to paint the shadows cast by diagram items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush ShadowBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ShadowBrush As Brush

Property Value

An instance of a Brush -derived class. The default is SolidBrush(Color.FromArgb(150, Color.DarkGray)).

Remarks

Use the property to specify an initial value for the ShadowBrush property of new diagram elements.

See Also

Diagram Members
Diagram Class
ShadowsStyle Property


MindFusion.Diagramming.Diagram.ShadowOffsetX Property

Diagram.ShadowOffsetX Property
[image]

Gets or sets the horizontal offset of item shadows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float ShadowOffsetX { get; set; }

Visual Basic [image] Copy Code

Public Property ShadowOffsetX As Single

Property Value

A float value that specifies the X shadow offset.

Remarks

Use the property to specify how distant the shadow of the item should be drawing as to the x-coordinate axis. You can set both X and Y offset values with the SetShadowOffset method.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SetShadowOffset Method
DiagramItem.ShadowOffsetY Property


MindFusion.Diagramming.Diagram.ShadowOffsetY Property

Diagram.ShadowOffsetY Property
[image]

Gets or sets the vertical offset of item shadows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float ShadowOffsetY { get; set; }

Visual Basic [image] Copy Code

Public Property ShadowOffsetY As Single

Property Value

A float value that specifies the Y shadow offset.

Remarks

Use the property to specify how distant the shadow of the item should be drawing as to the y-coordinate axis. You can set both X and Y offset values with the SetShadowOffset method.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SetShadowOffset Method
DiagramItem.ShadowOffsetX Property


MindFusion.Diagramming.Diagram.ShadowsStyle Property

Diagram.ShadowsStyle Property
[image]

Gets or sets the style for rendering shadows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShadowsStyle ShadowsStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ShadowsStyle As ShadowsStyle

Property Value

A member of the ShadowsStyle enumeration.

Remarks

This property specifies how the shadows of diagram items are drawn. If its value is None no shadows are painted. OneLevel makes all shadows paint on the lowest z-level, not covering any items. Thus the diagram items will seem to appear on the same z-level. ZOrder makes the shadow paint immediately under their items, possibly covering other items. This style gives more 3D-like outlook to the diagram.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramItem.ShadowOffsetX Property
DiagramItem.ShadowOffsetY Property
EnableShadowEffects Property


MindFusion.Diagramming.Diagram.ShapeBrush Property

Diagram.ShapeBrush Property
[image]

Gets or sets the default value for the Brush property of shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush ShapeBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

Remarks

The property provides a default value for the brush, with which a node' interior is filled. The Brush property of new shape nodes is initialized with a clone of ShapeBrush, but after the node creation the properties are independent - changing one of them does not change the other.

In ImageMap mode of NetDiagram, this property also specifies the color that fills the DIV element representing the new node being drawn.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Brush and Pen Classes
ShapePen Property


MindFusion.Diagramming.Diagram.ShapeCustomDraw Property

Diagram.ShapeCustomDraw Property
[image]

Gets or sets the default type of custom painting done for shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CustomDraw ShapeCustomDraw { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeCustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. The default is None.

Remarks

This property specifies whether and how custom painting of shape nodes is performed. Its value is assigned to the CustomDraw property of new shape nodes.

See Also

Diagram Members
Diagram Class
DrawNode Event


MindFusion.Diagramming.Diagram.ShapeHandlesStyle Property

Diagram.ShapeHandlesStyle Property
[image]

Gets or sets the default value for the HandlesStyle property of new shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HandlesStyle ShapeHandlesStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeHandlesStyle As HandlesStyle

Property Value

A member of the HandlesStyle enumeration.

Remarks

This property provides default value for the HandlesStyle property of new shape nodes, created either programmatically or by the user. That property specifies how selected nodes are indicated visually, and how they can be moved, resized or connected to other objects.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ShapeNodeStyle Property

Diagram.ShapeNodeStyle Property
[image]

Gets the theme-level style for shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNodeStyle ShapeNodeStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ShapeNodeStyle As ShapeNodeStyle

Property Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ShapeOrientation Property

Diagram.ShapeOrientation Property
[image]

Gets or sets the default value for the ShapeOrientation property of shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float ShapeOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeOrientation As Single

Property Value

A float value specifying an angle in degrees. Allowed values are 0, 90, 180 and 270.

Remarks

Use this property in conjunction with DefaultShape to define what shape will be assigned to new nodes that end-users draw.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ShapeNode.ShapeOrientation Property
DefaultShape Property


MindFusion.Diagramming.Diagram.ShapePen Property

Diagram.ShapePen Property
[image]

Gets or sets the default value for the Pen property of shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen ShapePen { get; set; }

Visual Basic [image] Copy Code

Public Property ShapePen As Pen

Property Value

An instance of the MindFusion.Drawing.Pen class.

Remarks

The property provides a default value for the pen, with which a shape node's frame is painted. The Pen property of new shape nodes is initialized with a clone of ShapePen, but after the node creation the properties are independent - changing one of them does not change the other.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Brush and Pen Classes
ShapeBrush Property


MindFusion.Diagramming.Diagram.ShapeText Property

Diagram.ShapeText Property
[image]

Gets or sets the default text of shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ShapeText { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeText As String

Property Value

A string specifying the initial text of shape nodes. The default is an empty string.

Remarks

The value of this property is assigned to the Text property of new nodes.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
TextColor Property
TextFormat Property


MindFusion.Diagramming.Diagram.ShowAnchors Property

Diagram.ShowAnchors Property
[image]

Gets or sets a value indicating whether and when node anchor points should be displayed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShowAnchors ShowAnchors { get; set; }

Visual Basic [image] Copy Code

Public Property ShowAnchors As ShowAnchors

Property Value

A member of the ShowAnchors enumeration. The default value is Auto.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SnapToAnchor Property
Anchor Points and Patterns


MindFusion.Diagramming.Diagram.ShowDisabledHandles Property

Diagram.ShowDisabledHandles Property
[image]

Gets or sets a value indicating whether manipulation handles are painted when they are disabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ShowDisabledHandles { get; set; }

Visual Basic [image] Copy Code

Public Property ShowDisabledHandles As Boolean

Property Value

true to display disabled manipulation handles; otherwise, false. The default is true.

Remarks

Individual handles can be disabled or enabled by clearing or setting their correspondent bits in node's EnabledHandles. If disabled handles are displayed, they are painted using the HandleBrush specified through DisabledHandlesStyle.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ShowGrid Property

Diagram.ShowGrid Property
[image]

Gets or sets a value indicating whether the alignment grid is visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ShowGrid { get; set; }

Visual Basic [image] Copy Code

Public Property ShowGrid As Boolean

Property Value

true if the grid is visible; otherwise, false. The default is false.

Remarks

If it is visible, the grid is painted as either a matrix of points or crossing horizontal and vertical lines. That depends on the value of GridStyle.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
AlignToGrid Property
GridColor Property
GridSizeX Property
GridSizeY Property


MindFusion.Diagramming.Diagram.ShowHandlesOnDrag Property

Diagram.ShowHandlesOnDrag Property
[image]

Gets or sets a value indicating whether to display selection handles of objects under the mouse while another object is being modified.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ShowHandlesOnDrag { get; set; }

Visual Basic [image] Copy Code

Public Property ShowHandlesOnDrag As Boolean

Property Value

true to display the selection handles of an item while it is being modified; false to hide them.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.SnapToAnchor Property

Diagram.SnapToAnchor Property
[image]

Gets or sets when link end points should be aligned to the nearest anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SnapToAnchor SnapToAnchor { get; set; }

Visual Basic [image] Copy Code

Public Property SnapToAnchor As SnapToAnchor

Property Value

A member of the SnapToAnchor enumeration. The default is OnCreate.

Remarks

The default value OnCreate, specifies that links are snapped to anchor points when they are created, but allows the user to move the link ends to different locations of a node. The OnCreateOrModify value makes link ends points connect to node anchors both if links are created or modified.

See Also

Diagram Members
Diagram Class
ShowAnchors Property


MindFusion.Diagramming.Diagram.SortGroupsByZ Property

Diagram.SortGroupsByZ Property
[image]

Gets or sets a value indicating whether grouped items should be drawn sorted by their z-order while the whole group is being moved.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SortGroupsByZ { get; set; }

Visual Basic [image] Copy Code

Public Property SortGroupsByZ As Boolean

Property Value

true if grouped items should be painted according to their z-order; otherwise, false. The default is false.

Remarks

By default, while a group of nodes is being modified with the mouse, the grouped items are drawn in the order defined by the group hierarchy. For example, the group MainItem is drawn bellow all attached items, and if an attached item is the main item in another group, it is drawn below the next groups in the hierarchy. During this process, the ZIndex of items is ignored and the group appearance while it is being modified might differ from how it looks usually. The SortGroupsByZ property lets you override the default behavior and display items sorted by their z-order. Take heed if your application creates large hierarchies of groups - enabling that property might slow down the modification process.

See Also

Diagram Members
Diagram Class
SelectionOnTop Property


MindFusion.Diagramming.Diagram.Style Property

Diagram.Style Property
[image]

Gets or sets the style associated with the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramStyle Style { get; set; }

Visual Basic [image] Copy Code

Public Property Style As DiagramStyle

Property Value

An instance of the DiagramStyle class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.SvgNodeStyle Property

Diagram.SvgNodeStyle Property
[image]

Gets the theme-level style for SVG nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SvgNodeStyle SvgNodeStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SvgNodeStyle As SvgNodeStyle

Property Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TableBrush Property

Diagram.TableBrush Property
[image]

Gets or sets the default value for the Brush property of tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush TableBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TableBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

Remarks

The property provides a default value for the brush, with which a table' interior is filled. The Brush property of new tables is initialized with a clone of TableBrush, but after table creation the properties are independent - changing one of them does not change the other.

In ImageMap mode, this property also specifies the color that fills the DIV element representing the new node being drawn.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Brush and Pen Classes
TablePen Property


MindFusion.Diagramming.Diagram.TableCaption Property

Diagram.TableCaption Property
[image]

Gets or sets the default text for tables' captions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string TableCaption { get; set; }

Visual Basic [image] Copy Code

Public Property TableCaption As String

Property Value

A string specifying the initial text of table captions. The default is "Table".

Remarks

The Caption property of new tables is initialized with the value of TableCaption.

See Also

Diagram Members
Diagram Class
TableCaptionHeight Property


MindFusion.Diagramming.Diagram.TableCaptionHeight Property

Diagram.TableCaptionHeight Property
[image]

Gets or sets the default height of table captions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float TableCaptionHeight { get; set; }

Visual Basic [image] Copy Code

Public Property TableCaptionHeight As Single

Property Value

A float value, which indicates the height of table caption. Default value is 5.

Remarks

The value of this property is used to initialize the CaptionHeight property of new tables.

See Also

Diagram Members
Diagram Class
TableCaption Property


MindFusion.Diagramming.Diagram.TableColumnCount Property

Diagram.TableColumnCount Property
[image]

Gets or sets the default number of table columns.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int TableColumnCount { get; set; }

Visual Basic [image] Copy Code

Public Property TableColumnCount As Integer

Property Value

An integer value, which specifies the number of columns in new tables. The default is 2.

Remarks

This value is used to initialize the ColumnCount property of new tables.

See Also

Diagram Members
Diagram Class
TableRowCount Property


MindFusion.Diagramming.Diagram.TableColumnWidth Property

Diagram.TableColumnWidth Property
[image]

Gets or sets the default width of tables' columns.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float TableColumnWidth { get; set; }

Visual Basic [image] Copy Code

Public Property TableColumnWidth As Single

Property Value

A float value, which specifies the width of table columns measured. The default is 18.

Remarks

This property is used to initialize the ColumnWidth property of new tables.

See Also

Diagram Members
Diagram Class
TableRowHeight Property


MindFusion.Diagramming.Diagram.TableConnectionStyle Property

Diagram.TableConnectionStyle Property
[image]

Gets or sets a value indicating whether drawing a link between tables should connect the rows of those tables, or the tables as whole entities.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableConnectionStyle TableConnectionStyle { get; set; }

Visual Basic [image] Copy Code

Public Property TableConnectionStyle As TableConnectionStyle

Property Value

A member of the TableConnectionStyle enumeration. The default is Rows.

Remarks

The value of TableConnectionStyle is used to initialize the ConnectionStyle property of new tables. There are three possible ways to relate tables to other nodes. This property specifies how users are allowed to create such relations:

  • Rows - relation ends are the rows of a table. A link connected to the table is connected to a particular row. This mode is convenient for database diagrams.
  • Table - relations target tables as whole entities, and not any particular row. This mode is convenient for class diagrams.
  • Both - a mixed mode where links can target either a row of a table or the table itself.

Programmatically, links can be connected to a table in any way, regardless of the table's ConnectionStyle. The value of ConnectionStyle is considered only when end-users draw links to or from a table. To link to a table as an entity and not to a specific row, pass -1 as row argument of the CreateDiagramLink method.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TableCustomDraw Property

Diagram.TableCustomDraw Property
[image]

Gets or sets the default type of custom painting done on tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CustomDraw TableCustomDraw { get; set; }

Visual Basic [image] Copy Code

Public Property TableCustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. The default is None.

Remarks

The CustomDraw member of tables is initialized from this property.

See Also

Diagram Members
Diagram Class
CellCustomDraw Property


MindFusion.Diagramming.Diagram.TableHandlesStyle Property

Diagram.TableHandlesStyle Property
[image]

Gets or sets the default value for the HandlesStyle property of new tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HandlesStyle TableHandlesStyle { get; set; }

Visual Basic [image] Copy Code

Public Property TableHandlesStyle As HandlesStyle

Property Value

One of the HandlesStyle enumeration values.

Remarks

Default value for the HandlesStyle property of new tables, created either programmatically or by the user. That property specifies how selected tables are indicated visually, and how they can be moved, resized or connected to other objects.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TableNodeStyle Property

Diagram.TableNodeStyle Property
[image]

Gets the theme-level style for table nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNodeStyle TableNodeStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TableNodeStyle As TableNodeStyle

Property Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TablePen Property

Diagram.TablePen Property
[image]

Gets or sets the default value for the Pen property of tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen TablePen { get; set; }

Visual Basic [image] Copy Code

Public Property TablePen As Pen

Property Value

An instance of the MindFusion.Drawing.Pen class.

Remarks

The property provides a default value for the pen, with which a table's frame is painted. The Pen property of new tables is initialized with a clone of TablePen, but after table creation the properties are independent - changing one of them does not change the other.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Brush and Pen Classes
TableBrush Property


MindFusion.Diagramming.Diagram.TableRowCount Property

Diagram.TableRowCount Property
[image]

Gets or sets the default number of table rows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int TableRowCount { get; set; }

Visual Basic [image] Copy Code

Public Property TableRowCount As Integer

Property Value

An integer value specifying the number of rows.

Remarks

Use the property to set the initial number of rows for newly created tables. Further customization of table nodes can be done through TableNode class properties and methods.

See Also

Diagram Members
Diagram Class
TableColumnCount Property


MindFusion.Diagramming.Diagram.TableRowHeight Property

Diagram.TableRowHeight Property
[image]

Gets or sets the default height of tables' rows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float TableRowHeight { get; set; }

Visual Basic [image] Copy Code

Public Property TableRowHeight As Single

Property Value

A float value specifying the height of table rows. The default is 5.

Remarks

TableRowHeight is used to initialize the RowHeight property of new tables.

See Also

Diagram Members
Diagram Class
TableColumnWidth Property


MindFusion.Diagramming.Diagram.TableShape Property

Diagram.TableShape Property
[image]

Gets or sets the default value of the Shape property of new tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SimpleShape TableShape { get; set; }

Visual Basic [image] Copy Code

Public Property TableShape As SimpleShape

Property Value

A member of the SimpleShape enumeration. The default value is Rectangle.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TablesScrollable Property

Diagram.TablesScrollable Property
[image]

Gets or sets the default value for the Scrollable property of new tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool TablesScrollable { get; set; }

Visual Basic [image] Copy Code

Public Property TablesScrollable As Boolean

Property Value

true if the scrolling is possible; otherwise, false. The default is false.

Remarks

The Scrollable property of each new table is initialized with the value of TablesScrollable. Small up/down scroll buttons appear in the caption of scrollable tables. With the help of the buttons users can scroll table rows.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
TableRowCount Property
TableNode.Scrollable Property


MindFusion.Diagramming.Diagram.Tag Property

Diagram.Tag Property
[image]

Gets or sets custom data associated with this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An instance of any class derived from System.Object.

Remarks

Any type derived from the Object class can be assigned to this property. If the Tag property is set through the Windows Forms designer, only text can be assigned. A common use for the Tag property is to store data that is closely associated with diagrams and often must be accessed when processing a diagram instance.

If the tag is an instance of a value type, it will be serialized together with the diagram when saving or loading the diagram document. Reference types are serialized if marked with the [Serializable] attribute and implement the ISerializable interface.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TextColor Property

Diagram.TextColor Property
[image]

Gets or sets the default color of text displayed inside diagram items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color TextColor { get; set; }

Visual Basic [image] Copy Code

Public Property TextColor As Color

Property Value

An instance of the .NET Color structure. The default is Color.Black.

Remarks

Use the property to specify the default color of the text of diagram items.

See Also

Diagram Members
Diagram Class
TextFormat Property


MindFusion.Diagramming.Diagram.TextFormat Property

Diagram.TextFormat Property
[image]

Gets or sets the default alignment and formatting style for text displayed inside nodes and table cells.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringFormat TextFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TextFormat As StringFormat

Property Value

An instance of the .NET StringFormat class. The default value for both Alignment and LineAlignment properties is StringAlignment.Center.

Remarks

When a new node is created, its TextFormat is initialized with the value of this property. The same applies for the TextFormat of the cells of a new table.

See Also

Diagram Members
Diagram Class
TextColor Property


MindFusion.Diagramming.Diagram.Theme Property

Diagram.Theme Property
[image]

Gets or sets the theme associated with the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Theme Theme { get; set; }

Visual Basic [image] Copy Code

Public Property Theme As Theme

Property Value

An instance of the Theme class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ToolTip Property

Diagram.ToolTip Property
[image]

Gets or sets a short text message displayed when the mouse pointer rests over the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ToolTip { get; set; }

Visual Basic [image] Copy Code

Public Property ToolTip As String

Property Value

The tool-tip text displayed for this diagram. The default is an empty string.

Remarks

This tool-tip is displayed when the mouse rests over an unoccupied document area. If the mouse points to an item, the ToolTip of that item will appear. Tool-tips can be enabled or disabled using the ShowToolTips property.

See Also

Diagram Members
Diagram Class
DiagramView.ToolTipDelay Property


MindFusion.Diagramming.Diagram.TreeViewNodeStyle Property

Diagram.TreeViewNodeStyle Property
[image]

Gets the theme-level style for tree view nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewNodeStyle TreeViewNodeStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TreeViewNodeStyle As TreeViewNodeStyle

Property Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.UndoManager Property

Diagram.UndoManager Property
[image]

Gets a reference to the diagram's UndoManager instance.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public UndoManager UndoManager { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property UndoManager As UndoManager

Property Value

A reference to UndoManager instance.

Remarks

Use this property to control the undo manager operations, Undo or Redo commands, and access the command History.

See Also

Diagram Members
Diagram Class
Undo Manager


MindFusion.Diagramming.Diagram.ValidityChecks Property

Diagram.ValidityChecks Property
[image]

Gets or sets a value indicating whether validity checks are performed each time an item is added to the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ValidityChecks { get; set; }

Visual Basic [image] Copy Code

Public Property ValidityChecks As Boolean

Property Value

true to perform validity checks; otherwise, false. The default is true.

Remarks

If enabled, validity checks are performed each time an item is added to the diagram. That involves enumerating the Items collection and can slow up the process considerably for large diagrams. You can disable this property in order to skip the validity checks, however be sure that you don't add an item twice to the diagram and that links are created only between items in the same diagram.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Factory.CreateShapeNode Method
Factory.CreateDiagramLink Method


MindFusion.Diagramming.Diagram.VisioNodeStyle Property

Diagram.VisioNodeStyle Property
[image]

Gets the theme-level style for Visio nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public VisioNodeStyle VisioNodeStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property VisioNodeStyle As VisioNodeStyle

Property Value

An instance of the VisioNodeStyle class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram Events

Diagram Events
[image]

Public Events

Name | Description
ActionRecorded | Raised when an action is recorded in the undo buffer. (Inherited from DiagramBase.)
ActionRecording | A validation event raised before an action is recorded in the undo buffer. (Inherited from DiagramBase.)
ActionRedone | Raised when an action is redone. (Inherited from DiagramBase.)
ActionUndone | Raised when an action is undone. (Inherited from DiagramBase.)
ActiveLayerChanged | Raised when the diagram's active layer has changed. (Inherited from DiagramBase.)
BeginLoad | Raised when the component starts loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
BoundsChanged | Raised when the Bounds property value has changed. (Inherited from DiagramBase.)
CellClicked | Raised when the user clicks a table’s cell. (Inherited from DiagramBase.)
CellDoubleClicked | Raised when the user double-clicks a table’s cell. (Inherited from DiagramBase.)
CellTextEdited | Raised when the user edits the text of a table’s cell. (Inherited from DiagramBase.)
CellTextEditing | A validation event that lets you approve or reject changes made to the text of a table’s cell. (Inherited from DiagramBase.)
Clicked | Raised when the user clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area. (Inherited from DiagramBase.)
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area. (Inherited from DiagramBase.)
ContentVisibilityChanged | Raised when the visibility of container's content changes. (Inherited from DiagramBase.)
DefaultShapeChanged | Raised when the DefaultShape property value has changed. (Inherited from DiagramBase.)
DeserializeTag | Raised when the Tag of a diagram item must be deserialized from XML format. (Inherited from DiagramBase.)
DestinationAnchorChanged | Raised when the DestinationAnchor property value of a link has changed. (Inherited from DiagramBase.)
DirtyChanged | Raised when the Dirty property value has changed. (Inherited from DiagramBase.)
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
DrawAdjustmentHandles | Raised when item’s adjustment handles must be custom drawn. (Inherited from DiagramBase.)
DrawAnchorPoint | Raised when an anchor point must be custom drawn. (Inherited from DiagramBase.)
DrawBackground | Raised to let you custom draw the diagram background. (Inherited from DiagramBase.)
DrawCell | Raised when a table’s cell must be custom drawn. (Inherited from DiagramBase.)
DrawForeground | Raised to let you custom draw the diagram foreground. (Inherited from DiagramBase.)
DrawLink | Raised when a diagram link must be custom drawn. (Inherited from DiagramBase.)
DrawNode | Raised when a diagram node must be custom drawn. (Inherited from DiagramBase.)
EndLoad | Raised when the component ends loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
ExpandButtonClicked | Raised when the user clicks the [±] button of an Expandable node. (Inherited from DiagramBase.)
GroupDestroyed | Raised when a Group object is destroyed. (Inherited from DiagramBase.)
HitTestAdjustmentHandles | Raised when custom hit testing of item’s adjustment handles must be performed. (Inherited from DiagramBase.)
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created. (Inherited from DiagramBase.)
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created. (Inherited from DiagramBase.)
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
LayerVisibilityChanged | Raised when the visibility of a Layer changes. (Inherited from DiagramBase.)
LinkActivated | Raised when a link becomes the ActiveItem. (Inherited from DiagramBase.)
LinkClicked | Raised when the user clicks a link. (Inherited from DiagramBase.)
LinkCreateCancelled | Raised when the user cancels link creation. (Inherited from DiagramBase.)
LinkCreated | Raised when the user draws a new link. (Inherited from DiagramBase.)
LinkCreating | A validation event raised while the user is drawing a new link. (Inherited from DiagramBase.)
LinkDeactivated | Raised when a link is no longer the ActiveItem. (Inherited from DiagramBase.)
LinkDeleted | Raised when a link is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkDeselected | Raised when a link is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDoubleClicked | Raised when the user double-clicks a link. (Inherited from DiagramBase.)
LinkModified | Raised when the user moves any control point of a link. (Inherited from DiagramBase.)
LinkModifyCancelled | Raised when the user cancels move or resize operation being done on a link. (Inherited from DiagramBase.)
LinkModifying | A validation event raised while the user is modifying a link. (Inherited from DiagramBase.)
LinkPasted | Raised when a link has been pasted from the clipboard. (Inherited from DiagramBase.)
LinkPointed | Raised when the mouse pointer hovers over a link. (Inherited from DiagramBase.)
LinkRouted | Raised when a link is routed by the auto-routing algorithm. (Inherited from DiagramBase.)
LinkSelected | Raised when a link is selected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkSelecting | Raised when the user tries to select a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkSplit | Raised when the user splits a link interactively. (Inherited from DiagramBase.)
LinkStartModifying | A validation event raised when the user starts modifying a link. (Inherited from DiagramBase.)
LinkTextEdited | Raised when the user edits the text of a link. (Inherited from DiagramBase.)
LinkTextEditing | A validation event that lets you approve or reject changes made to the text of a link. (Inherited from DiagramBase.)
MeasureUnitChanged | Raised when the MeasureUnit property value has changed. (Inherited from DiagramBase.)
NodeActivated | Raised when a node becomes the ActiveItem. (Inherited from DiagramBase.)
NodeClicked | Raised when the user clicks a node. (Inherited from DiagramBase.)
NodeCreateCancelled | Raised when the user cancels node creation. (Inherited from DiagramBase.)
NodeCreated | Raised when the user draws a new node. (Inherited from DiagramBase.)
NodeCreating | A validation event raised while the user is drawing a new node. (Inherited from DiagramBase.)
NodeDeactivated | Raised when a node is no longer the ActiveItem. (Inherited from DiagramBase.)
NodeDeleted | Raised when a node is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeDeselected | Raised when a node is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDoubleClicked | Raised when the user double-clicks a node. (Inherited from DiagramBase.)
NodeModified | Raised when the user moves or resizes a node. (Inherited from DiagramBase.)
NodeModifyCancelled | Raised when the user cancels move or resize operation being done on a node. (Inherited from DiagramBase.)
NodeModifying | A validation event raised while the user is moving or resizing a node. (Inherited from DiagramBase.)
NodePasted | Raised when a node has been pasted from the clipboard. (Inherited from DiagramBase.)
NodePointed | Raised when the mouse pointer hovers over a node. (Inherited from DiagramBase.)
NodeSelected | Raised when a node is selected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeSelecting | Raised when the user tries to select a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeStartModifying | A validation event raised when the user starts modifying a node. (Inherited from DiagramBase.)
NodeTextEdited | Raised when the user edits the text of a node. (Inherited from DiagramBase.)
NodeTextEditing | A validation event that lets you approve or reject changes made to the text of a node. (Inherited from DiagramBase.)
OriginAnchorChanged | Raised when the OriginAnchor property value of a link has changed. (Inherited from DiagramBase.)
QueryAlignTarget | Raised to validate a node as target for alignment guides when AutoAlignNodes is enabled. (Inherited from DiagramBase.)
Repaint | Raised when the diagram views should be repainted. (Inherited from DiagramBase.)
RequestCacheReset | Raised when an object within the diagram requests a reset of the cached bitmap. (Inherited from DiagramBase.)
RequestClipboard | Raised when an object within the diagram requests an operation with the clipboard. (Inherited from DiagramBase.)
RequestTimer | Raised when an object within the diagram needs to start or stop a timer. (Inherited from DiagramBase.)
SelectionChanged | Raised when an item is added to or removed from the selection (Inherited from DiagramBase.)
SelectionModified | Raised when the user moves multiple selected items. (Inherited from DiagramBase.)
SelectionModifying | Raised while the user is moving multiple selected items, this event lets you cancel the modification. (Inherited from DiagramBase.)
SerializeTag | Raised when the Tag of a diagram item must be serialized into an XML document. (Inherited from DiagramBase.)
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape. (Inherited from DiagramBase.)
ShapeModified | Raised when the user modifies the shape of a ShapeNode by moving one of the control points corresponding to shape formula parameters. (Inherited from DiagramBase.)
TableColumnResized | Raised when the user finishes resizing a column in a table. (Inherited from DiagramBase.)
TableColumnResizing | Raised when the user resizes a column in a table interactively. (Inherited from DiagramBase.)
TableRowResized | Raised when the user finishes resizing a row in a table. (Inherited from DiagramBase.)
TableRowResizing | Raised when the user resizes a row in a table interactively. (Inherited from DiagramBase.)
TableSectionCollapsed | Raised when the user collapses the rows of a table’s section by clicking the [-] button in the section's header row. (Inherited from DiagramBase.)
TableSectionExpanded | Raised when the user expands the rows of a table's section by clicking the [+] button in the section’s header row. (Inherited from DiagramBase.)
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node. (Inherited from DiagramBase.)
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node. (Inherited from DiagramBase.)
TreeItemTextEditing | A validation event that lets you approve or reject changes made to the text of a TreeViewNode's item. (Inherited from DiagramBase.)
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point. (Inherited from DiagramBase.)
ViewRemoved | Raised when a DiagramView is detached from this diagram. (Inherited from DiagramBase.)

See Also

Diagram Class


MindFusion.Diagramming.DiagramBase.ActionRecorded Event

DiagramBase.ActionRecorded Event
[image]

Raised when an action is recorded in the undo buffer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<UndoEventArgs> ActionRecorded

Visual Basic [image] Copy Code

Public Event ActionRecorded As EventHandler(Of UndoEventArgs)

Event Data

ActionRecorded event handlers receive an argument of type UndoEventArgs. The following UndoEventArgs members provide information relevant to the event:

Member name | Description
Command | Refers to the Command instance that identifies the recorded action.

Remarks

This event is raised only for top-level commands. For example, it isn't raised for the constituent actions of a CompositeCmd.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
ActionRedone Event
ActionUndone Event


MindFusion.Diagramming.DiagramBase.ActionRecording Event

DiagramBase.ActionRecording Event
[image]

A validation event raised before an action is recorded in the undo buffer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<UndoValidationEventArgs> ActionRecording

Visual Basic [image] Copy Code

Public Event ActionRecording As EventHandler(Of UndoValidationEventArgs)

Event Data

ActionRecording event handlers receive an argument of type UndoValidationEventArgs. The following UndoValidationEventArgs members provide information relevant to the event:

Member name | Description
Command | Refers to the Command instance that identifies the action being recorded.
Cancel | Set this property to true to prevent the action from being recorded in the undo buffer.

Remarks

Do not filter commands that create or delete items and groups. Otherwise, redoing or undoing recorded commands related to the items whose create/delete command is filtered will cause various exceptions. We recommend to filter commands that modify an item, change its selection state, scroll a table, and so on.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
ActionRecorded Event
ActionRedone Event


MindFusion.Diagramming.DiagramBase.ActionRedone Event

DiagramBase.ActionRedone Event
[image]

Raised when an action is redone.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<UndoEventArgs> ActionRedone

Visual Basic [image] Copy Code

Public Event ActionRedone As EventHandler(Of UndoEventArgs)

Event Data

ActionRedone event handlers receive an argument of type UndoEventArgs. The following UndoEventArgs members provide information relevant to the event:

Member name | Description
Command | Refers to the Command instance that identifies the recorded action.

Remarks

This event is raised during calls to Redo. It is raised both for top-level commands and for the constituent actions of composite commands.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
ActionRecorded Event
ActionUndone Event


MindFusion.Diagramming.DiagramBase.ActionUndone Event

DiagramBase.ActionUndone Event
[image]

Raised when an action is undone.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<UndoEventArgs> ActionUndone

Visual Basic [image] Copy Code

Public Event ActionUndone As EventHandler(Of UndoEventArgs)

Event Data

ActionUndone event handlers receive an argument of type UndoEventArgs. The following UndoEventArgs members provide information relevant to the event:

Member name | Description
Command | Refers to the Command instance that identifies the recorded action.

Remarks

This event is raised during calls to Undo. It is raised both for top-level commands and for the constituent actions of composite commands.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
ActionRecorded Event
ActionRedone Event


MindFusion.Diagramming.DiagramBase.ActiveLayerChanged Event

DiagramBase.ActiveLayerChanged Event
[image]

Raised when the diagram's active layer has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler ActiveLayerChanged

Visual Basic [image] Copy Code

Public Event ActiveLayerChanged As EventHandler

Event Data

ActiveLayerChanged event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.BeginLoad Event

DiagramBase.BeginLoad Event
[image]

Raised when the component starts loading diagram data from a file or memory stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler BeginLoad

Visual Basic [image] Copy Code

Public Event BeginLoad As EventHandler

Event Data

BeginLoad event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class
EndLoad Event


MindFusion.Diagramming.DiagramBase.BoundsChanged Event

DiagramBase.BoundsChanged Event
[image]

Raised when the Bounds property value has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler BoundsChanged

Visual Basic [image] Copy Code

Public Event BoundsChanged As EventHandler

Event Data

BoundsChanged event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
MeasureUnitChanged Event
ActionRedone Event


MindFusion.Diagramming.DiagramBase.CellClicked Event

DiagramBase.CellClicked Event
[image]

Raised when the user clicks a table’s cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<CellEventArgs> CellClicked

Visual Basic [image] Copy Code

Public Event CellClicked As EventHandler(Of CellEventArgs)

Event Data

CellClicked event handlers receive an argument of type CellEventArgs. The following CellEventArgs members provide information relevant to the event:

Member name | Description
Table | The TableNode that contains the clicked cell.
Cell | The Cell that has been clicked.
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A PointF specifying the mouse cursor position.
Column | Index of the column containing the clicked cell.
Row | Index of the row containing the clicked cell.

Remarks

If there is some handler attached to this event, NodeClicked won't be raised for the table that contains the clicked cell, but only CellClicked.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
CellDoubleClicked Event
ActionRedone Event


MindFusion.Diagramming.DiagramBase.CellDoubleClicked Event

DiagramBase.CellDoubleClicked Event
[image]

Raised when the user double-clicks a table’s cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<CellEventArgs> CellDoubleClicked

Visual Basic [image] Copy Code

Public Event CellDoubleClicked As EventHandler(Of CellEventArgs)

Event Data

CellDoubleClicked event handlers receive an argument of type CellEventArgs. The following CellEventArgs members provide information relevant to the event:

Member name | Description
Table | The TableNode that contains the clicked cell.
Cell | The Cell that has been double-clicked.
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A PointF specifying the mouse cursor position.
Column | Index of the column containing the clicked cell.
Row | Index of the row containing the clicked cell.

Remarks

If there is some handler attached to this event, NodeDoubleClicked won't be raised for the table that contains the clicked cell, but only CellDoubleClicked.

See Also

DiagramBase Members
DiagramBase Class
CellClicked Event


MindFusion.Diagramming.DiagramBase.CellTextEdited Event

DiagramBase.CellTextEdited Event
[image]

Raised when the user edits the text of a table’s cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<EditCellTextEventArgs> CellTextEdited

Visual Basic [image] Copy Code

Public Event CellTextEdited As EventHandler(Of EditCellTextEventArgs)

Event Data

CellTextEdited event handlers receive an argument of type EditCellTextEventArgs. The following EditCellTextEventArgs members provide information relevant to the event:

Member name | Description
Table | The TableNode that contains the edited cell.
Cell | The Cell whose text has been edited.
NewText | The cell's new text.
OldText | The cell's old text.
Column | Index of the column containing the edited cell.
Row | Index of the row containing the edited cell.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
CellTextEditing Event
ActionRedone Event


MindFusion.Diagramming.DiagramBase.CellTextEditing Event

DiagramBase.CellTextEditing Event
[image]

A validation event that lets you approve or reject changes made to the text of a table’s cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<CellValidationEventArgs> CellTextEditing

Visual Basic [image] Copy Code

Public Event CellTextEditing As EventHandler(Of CellValidationEventArgs)

Event Data

CellTextEditing event handlers receive an argument of type CellValidationEventArgs. The following CellValidationEventArgs members provide information relevant to the event:

Member name | Description
Table | The TableNode containing the cell that the user is trying to edit.
Cell | The Cell that the user is trying to edit.
Column | Index of the column containing the cell.
Row | Index of the row containing the cell.
Cancel | Set this property to true to prevent the user from editing the cell's text.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
NodeTextEditing Event
CellTextEdited Event
ActionRedone Event


MindFusion.Diagramming.DiagramBase.Clicked Event

DiagramBase.Clicked Event
[image]

Raised when the user clicks the diagram at a point where no items are located.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<DiagramEventArgs> Clicked

Visual Basic [image] Copy Code

Public Event Clicked As EventHandler(Of DiagramEventArgs)

Event Data

Clicked event handlers receive an argument of type DiagramEventArgs. The following DiagramEventArgs members provide information relevant to the event:

Member name | Description
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A PointF specifying the mouse cursor position.

Remarks

This event is raised only if the user clicks an unoccupied point of the diagram. If the user clicks a diagram item, one of the following events is raised: NodeClicked, CellClicked or LinkClicked.

See Also

DiagramBase Members
DiagramBase Class
CellDoubleClicked Event


MindFusion.Diagramming.DiagramBase.ContainerChildAdded Event

DiagramBase.ContainerChildAdded Event
[image]

Raised when a node is added to a ContainerNode, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<ContainerChildEventArgs> ContainerChildAdded

Visual Basic [image] Copy Code

Public Event ContainerChildAdded As EventHandler(Of ContainerChildEventArgs)

Event Data

ContainerChildAdded event handlers receive an argument of type ContainerChildEventArgs.

See Also

DiagramBase Members
DiagramBase Class
ContainerChildRemoved Event


MindFusion.Diagramming.DiagramBase.ContainerChildRemoved Event

DiagramBase.ContainerChildRemoved Event
[image]

Raised when a node is removed from a ContainerNode, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<ContainerChildEventArgs> ContainerChildRemoved

Visual Basic [image] Copy Code

Public Event ContainerChildRemoved As EventHandler(Of ContainerChildEventArgs)

Event Data

ContainerChildRemoved event handlers receive an argument of type ContainerChildEventArgs.

See Also

DiagramBase Members
DiagramBase Class
ContainerChildAdded Event


MindFusion.Diagramming.DiagramBase.ContainerFolded Event

DiagramBase.ContainerFolded Event
[image]

Raised when the user folds a container by clicking the arrow-up button in the container's caption area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> ContainerFolded

Visual Basic [image] Copy Code

Public Event ContainerFolded As EventHandler(Of NodeEventArgs)

Event Data

ContainerFolded event handlers receive an argument of type NodeEventArgs.

See Also

DiagramBase Members
DiagramBase Class
ContainerUnfolded Event


MindFusion.Diagramming.DiagramBase.ContainerUnfolded Event

DiagramBase.ContainerUnfolded Event
[image]

Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> ContainerUnfolded

Visual Basic [image] Copy Code

Public Event ContainerUnfolded As EventHandler(Of NodeEventArgs)

Event Data

ContainerUnfolded event handlers receive an argument of type NodeEventArgs.

See Also

DiagramBase Members
DiagramBase Class
ContainerFolded Event


MindFusion.Diagramming.DiagramBase.ContentVisibilityChanged Event

DiagramBase.ContentVisibilityChanged Event
[image]

Raised when the visibility of container's content changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> ContentVisibilityChanged

Visual Basic [image] Copy Code

Public Event ContentVisibilityChanged As EventHandler(Of NodeEventArgs)

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.DefaultShapeChanged Event

DiagramBase.DefaultShapeChanged Event
[image]

Raised when the DefaultShape property value has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler DefaultShapeChanged

Visual Basic [image] Copy Code

Public Event DefaultShapeChanged As EventHandler

Event Data

DefaultShapeChanged event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.DeserializeTag Event

DiagramBase.DeserializeTag Event
[image]

Raised when the Tag of a diagram item must be deserialized from XML format.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<SerializeTagEventArgs> DeserializeTag

Visual Basic [image] Copy Code

Public Event DeserializeTag As EventHandler(Of SerializeTagEventArgs)

Event Data

DeserializeTag event handlers receive an argument of type SerializeTagEventArgs. The following SerializeTagEventArgs members provide information relevant to the event:

Member name | Description
Object | The object whose Tag is being deserialized. This object can be either a diagram item, group, cell or anchor point.
Tag | Set this property to the object that has been deserialized.
Representation | An XmlElement instance that contains the XML representation of a Tag value.
Context | An XmlPersistContext object providing information about the document being deserialized, along with methods that help you deserialize data from XML.
Handled | Set this flag to true if you perform custom tag deserialization.

Remarks

Only tags of simple value types can be saved and loaded automatically to/from the XML document. You must provide your own serialization for complex types by implementing this event and SerializeTag.

Example

The following example demonstrates how to deserialize a complex tag value using the DeserializeTag event.

C# [image] Copy Code

private void Read(string fileName)
{
diagram.DeserializeTag += new SerializeTagEventHandler(DeserializeTag);
diagram.LoadFromXml(fileName);
}

private void DeserializeTag(object sender, SerializeTagEventArgs e)
{
e.Handled = true;
string type, val;

XmlText textNode = e.Representation.LastChild as XmlText;
string stringRep = textNode.Value;
int pos = stringRep.IndexOf(";");

if (pos == -1)
return;

type = stringRep.Substring(0, pos);
val = stringRep.Substring(pos + 1);

Type t = Type.GetType(type);

object tag = null;
if (t == typeof(string))
tag = val;
else if (t == typeof(int))
tag = XmlConvert.ToInt32(val);

e.Tag = tag;
}

Visual Basic [image] Copy Code

Private Sub Read(ByVal fileName As String)

AddHandler diagram.DeserializeTag, New SerializeTagEventHandler(AddressOf DeserializeTag)
diagram.LoadFromXml(fileName)

End Sub

Private Sub DeserializeTag(ByVal sender As Object, ByVal e As SerializeTagEventArgs)

e.Handled = True

Dim type As String
Dim val As String

Dim textNode As XmlText = CType(e.Representation.LastChild, XmlText)
Dim stringRep As String = textNode.Value
Dim pos As Integer = stringRep.IndexOf(";")

If pos = -1 Then
Return
End If

type = stringRep.Substring(0, pos)
val = stringRep.Substring(pos + 1)

Dim t As Type = System.Type.GetType(type)

Dim tag As Object = Nothing
If t Is GetType(String) Then
tag = val
ElseIf t Is GetType(Integer) Then
tag = XmlConvert.ToInt32(val)
End If

e.Tag = tag

End Sub

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
SerializeTag Event
Diagram.LoadFromXml Method


MindFusion.Diagramming.DiagramBase.DestinationAnchorChanged Event

DiagramBase.DestinationAnchorChanged Event
[image]

Raised when the DestinationAnchor property value of a link has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<AnchorPointEventArgs> DestinationAnchorChanged

Visual Basic [image] Copy Code

Public Event DestinationAnchorChanged As EventHandler(Of AnchorPointEventArgs)

Event Data

DestinationAnchorChanged event handlers receive an argument of type AnchorPointEventArgs. The following AnchorPointEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink whose DestinationAnchor has changed.
OldAnchorIndex | Index of the old anchor point.
NewAnchorIndex | Index of the new anchor point.

Remarks

This event is raised every time the DestinationAnchor property of a link changes, either because a user connects the link end to a different anchor point, or because an application sets it programmatically.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
OriginAnchorChanged Event
ActionRedone Event


MindFusion.Diagramming.DiagramBase.DirtyChanged Event

DiagramBase.DirtyChanged Event
[image]

Raised when the Dirty property value has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler DirtyChanged

Visual Basic [image] Copy Code

Public Event DirtyChanged As EventHandler

Event Data

DirtyChanged event handlers receive an argument of type EventArgs.

Remarks

Dirty is set to true every time the diagram or the diagram document is modified, but this event is raised only if the flag value changes, either from false to true or from true to false. So the event occurs only when a diagram or a diagram document is modified for the first time, but not when subsequent modifications are done.

See Also

DiagramBase Members
DiagramBase Class
ActionRecorded Event


MindFusion.Diagramming.DiagramBase.DoubleClicked Event

DiagramBase.DoubleClicked Event
[image]

Raised when the user double-clicks the diagram at a point where no items are located.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<DiagramEventArgs> DoubleClicked

Visual Basic [image] Copy Code

Public Event DoubleClicked As EventHandler(Of DiagramEventArgs)

Event Data

DoubleClicked event handlers receive an argument of type DiagramEventArgs. The following DiagramEventArgs members provide information relevant to the event:

Member name | Description
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A PointF specifying the mouse cursor position.

Remarks

This event is raised only if the user double-clicks an unoccupied point of the diagram. If the user double-clicks a diagram item, one of the following events is raised: NodeDoubleClicked, CellDoubleClicked or LinkDoubleClicked.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
ActionRedone Event
Clicked Event


MindFusion.Diagramming.DiagramBase.DrawAdjustmentHandles Event

DiagramBase.DrawAdjustmentHandles Event
[image]

Raised when item’s adjustment handles must be custom drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<DrawItemEventArgs> DrawAdjustmentHandles

Visual Basic [image] Copy Code

Public Event DrawAdjustmentHandles As EventHandler(Of DrawItemEventArgs)

Event Data

DrawAdjustmentHandles event handlers receive an argument of type DrawItemEventArgs. The following DrawItemEventArgs members provide information relevant to the event:

Member name | Description
Item | The DiagramItem whose adjustment handles should be drawn.
Graphics | An object implementing the IGraphics interface whose methods should be used to draw the item's handles.

Remarks

DrawAdjustmentHandles is raised for selected items whose HandlesStyle is set to Custom.

Example

The following example illustrates how to draw a red frame around a node as a visualization of its adjustment handles.

C# [image] Copy Code

void diagram_DrawAdjustmentHandles(object sender, MindFusion.Diagramming.DrawItemEventArgs e)
{
System.Drawing.Pen pen = new System.Drawing.Pen(Color.Red, 0);

if (e.Item is ShapeNode)
{
ShapeNode shapeNode = e.Item as ShapeNode;
RectangleF r = shapeNode.Bounds;
e.Graphics.DrawRectangle(pen, r.X, r.Y, r.Width, r.Height);
}

if (e.Item is DiagramLink)
{
DiagramLink link = e.Item as DiagramLink;
e.Graphics.DrawLines(pen, link.ControlPoints.GetArray());
}

pen.Dispose();
}

Visual Basic [image] Copy Code

Sub diagram_DrawAdjustmentHandles(ByVal sender As Object, ByVal e As MindFusion.Diagramming.DrawItemEventArgs)

Dim Pen As System.Drawing.Pen = New System.Drawing.Pen(Color.Red, 0)
If TypeOf e.Item Is ShapeNode Then

Dim shapeNode As ShapeNode = CType(e.Item, ShapeNode)
Dim r As RectangleF = shapeNode.Bounds
e.Graphics.DrawRectangle(Pen, r.X, r.Y, r.Width, r.Height)

End If
If TypeOf e.Item Is DiagramLink Then

Dim link As DiagramLink = CType(e.Item, DiagramLink)
e.Graphics.DrawLines(Pen, link.ControlPoints.GetArray())

End If
Pen.Dispose()

End Sub

See Also

DiagramBase Members
DiagramBase Class
HitTestAdjustmentHandles Event


MindFusion.Diagramming.DiagramBase.DrawAnchorPoint Event

DiagramBase.DrawAnchorPoint Event
[image]

Raised when an anchor point must be custom drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<DrawAnchorPointEventArgs> DrawAnchorPoint

Visual Basic [image] Copy Code

Public Event DrawAnchorPoint As EventHandler(Of DrawAnchorPointEventArgs)

Event Data

DrawAnchorPoint event handlers receive an argument of type DrawAnchorPointEventArgs. The following DrawAnchorPointEventArgs members provide information relevant to the event:

Member name | Description
Node | A DiagramNode containing the anchor point that is being painted.
AnchorIndex | Index of the anchor point within the node's AnchorPattern.
AnchorPattern | An AnchorPattern instance that contains the anchor point definition.
Location | A PointF specifying the location of the anchor point.
Graphics | An object implementing the IGraphics interface whose methods should be used to draw the anchor point mark.

Remarks

DrawAnchorPoint is raised for an AnchorPoint if the point's MarkStyle is set to Custom.

Example

The following example demonstrates how to draw images for anchor points:

C# [image] Copy Code

void diagram_DrawAnchorPoint(object sender, DrawAnchorPointEventArgs e)
{
PointF imgPos = e.Location;
imgPos.Y -= 1.8f;

e.Graphics.DrawImage(icon, imgPos);
}

Visual Basic [image] Copy Code

Sub diagram_DrawAnchorPoint(ByVal sender As Object, ByVal e As DrawAnchorPointEventArgs) Handles diagram.DrawAnchorPoint

Dim imgPos As PointF = e.Location
imgPos.Y -= 1.8F

e.Graphics.DrawImage(icon, imgPos)

End Sub

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.DrawBackground Event

DiagramBase.DrawBackground Event
[image]

Raised to let you custom draw the diagram background.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<DiagramEventArgs> DrawBackground

Visual Basic [image] Copy Code

Public Event DrawBackground As EventHandler(Of DiagramEventArgs)

Event Data

DrawBackground event handlers receive an argument of type DiagramEventArgs. The following DiagramEventArgs members provide information relevant to the event:

Member name | Description
Graphics | Gets an object implementing the IGraphics interface whose methods should be used to draw the custom graphics.
VisibleRect | Specifies what part of the diagram is currently visible.
ClipRect | Gets the current clipping rectangle.

Remarks

This event is raised just after drawing the BackgroundImage and before drawing the alignment grid.

See Also

DiagramBase Members
DiagramBase Class
DrawForeground Event


MindFusion.Diagramming.DiagramBase.DrawCell Event

DiagramBase.DrawCell Event
[image]

Raised when a table’s cell must be custom drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<DrawCellEventArgs> DrawCell

Visual Basic [image] Copy Code

Public Event DrawCell As EventHandler(Of DrawCellEventArgs)

Event Data

DrawCell event handlers receive an argument of type DrawCellEventArgs. The following DrawCellEventArgs members provide information relevant to the event:

Member name | Description
Table | The TableNode containing the cell that should be custom drawn.
Cell | The Cell that should be custom drawn.
Column | Index of the column containing the cell.
Row | Index of the row containing the cell.
Bounds | Gets the bounding rectangle of the cell being drawn.
Graphics | An object implementing the IGraphics interface whose methods should be used to draw the cell contents.

Remarks

This event is raised for tables whose CellCustomDraw property is enabled.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
DrawNode Event
ActionRedone Event


MindFusion.Diagramming.DiagramBase.DrawForeground Event

DiagramBase.DrawForeground Event
[image]

Raised to let you custom draw the diagram foreground.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<DiagramEventArgs> DrawForeground

Visual Basic [image] Copy Code

Public Event DrawForeground As EventHandler(Of DiagramEventArgs)

Event Data

DrawForeground event handlers receive an argument of type DiagramEventArgs. The following DiagramEventArgs members provide information relevant to the event:

Member name | Description
Graphics | Gets an object implementing the IGraphics interface whose methods should be used to draw the custom graphics.
VisibleRect | Specifies what part of the diagram is currently visible.
ClipRect | Gets the current clipping rectangle.

Remarks

This event is raised after all diagram elements has been rendered, but before drawing the diagram boundaries with BoundsPen.

See Also

DiagramBase Members
DiagramBase Class
DrawBackground Event


MindFusion.Diagramming.DiagramBase.DrawLink Event

DiagramBase.DrawLink Event
[image]

Raised when a diagram link must be custom drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<DrawLinkEventArgs> DrawLink

Visual Basic [image] Copy Code

Public Event DrawLink As EventHandler(Of DrawLinkEventArgs)

Event Data

DrawLink event handlers receive an argument of type DrawLinkEventArgs. The following DrawLinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that should be custom drawn.
Points | Gets a collection of the link's control points. When drawing shadows, the points are offset as necessary.
Shadow | true if now drawing the link's shadow, otherwise false.
Graphics | An object implementing the IGraphics interface whose methods should be used to draw the link.

Remarks

This event is raised for links whose CustomDraw property is enabled.

See Also

DiagramBase Members
DiagramBase Class
DrawNode Event


MindFusion.Diagramming.DiagramBase.DrawNode Event

DiagramBase.DrawNode Event
[image]

Raised when a diagram node must be custom drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<DrawNodeEventArgs> DrawNode

Visual Basic [image] Copy Code

Public Event DrawNode As EventHandler(Of DrawNodeEventArgs)

Event Data

DrawNode event handlers receive an argument of type DrawNodeEventArgs. The following DrawNodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that should be custom drawn.
Bounds | The bounding rectangle of the node being drawn.
Shadow | true if now drawing the node's shadow, otherwise false.
Graphics | An object implementing the IGraphics interface whose methods should be used to draw the node.

Remarks

This event is raised for nodes whose CustomDraw property is enabled.

See Also

DiagramBase Members
DiagramBase Class
DrawLink Event


MindFusion.Diagramming.DiagramBase.EndLoad Event

DiagramBase.EndLoad Event
[image]

Raised when the component ends loading diagram data from a file or memory stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler EndLoad

Visual Basic [image] Copy Code

Public Event EndLoad As EventHandler

Event Data

EndLoad event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
BeginLoad Event
ActionRedone Event


MindFusion.Diagramming.DiagramBase.ExpandButtonClicked Event

DiagramBase.ExpandButtonClicked Event
[image]

Raised when the user clicks the [±] button of an Expandable node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> ExpandButtonClicked

Visual Basic [image] Copy Code

Public Event ExpandButtonClicked As EventHandler(Of NodeEventArgs)

Event Data

ExpandButtonClicked event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode whose [±] button has been clicked.

Remarks

This event is raised only if ExpandButtonAction is set to RaiseEvents. Otherwise either the TreeCollapsed or TreeExpanded event is raised, depending on the state of the node.

Example

The following sample code hides or shows all subordinated nodes in a group when the master node's [±] button is clicked:

C# [image] Copy Code
void diagram_ExpandButtonClicked(object sender, NodeEventArgs e)
{
if (e.Node.SubordinateGroup != null)
{
foreach (DiagramItem item in e.Node.SubordinateGroup.AttachedNodes)
item.Visible = e.Node.Expanded;
}
}
Visual Basic [image] Copy Code

Sub diagram_ExpandButtonClicked(ByVal sender As Object, ByVal e As NodeEventArgs) Handles diagram.ExpandButtonClicked

If Not e.Node.SubordinateGroup Is Nothing Then

Dim item As DiagramItem
For Each item In e.Node.SubordinateGroup.AttachedNodes
item.Visible = e.Node.Expanded
Next

End If

End Sub

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.GroupDestroyed Event

DiagramBase.GroupDestroyed Event
[image]

Raised when a Group object is destroyed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<GroupEventArgs> GroupDestroyed

Visual Basic [image] Copy Code

Public Event GroupDestroyed As EventHandler(Of GroupEventArgs)

Event Data

GroupDestroyed event handlers receive an argument of type GroupEventArgs. The following GroupEventArgs members provide information relevant to the event:

Member name | Description
Group | The Group that has been destroyed.

Remarks

A group can be destroyed in several ways:

  • by removing it from the diagram's Groups collection.
  • by deleting the group's MainItem.
  • in case the main item is a link, if the control point or segment to which subordinated items are attached is removed. That could happen if link's Shape or SegmentCount properties change.

When a group is destroyed, by default the group items are not deleted automatically. You could delete such items from the GroupDestroyed handler, or enable AutoDeleteItems to delete them automatically when the group is destroyed.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.HitTestAdjustmentHandles Event

DiagramBase.HitTestAdjustmentHandles Event
[image]

Raised when custom hit testing of item’s adjustment handles must be performed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<HitTestEventArgs> HitTestAdjustmentHandles

Visual Basic [image] Copy Code

Public Event HitTestAdjustmentHandles As EventHandler(Of HitTestEventArgs)

Event Data

HitTestAdjustmentHandles event handlers receive an argument of type HitTestEventArgs. The following HitTestEventArgs members provide information relevant to the event:

Member name | Description
Item | A DiagramItem whose adjustment handles should be hit tested.
MousePosition | A PointF specifying the mouse cursor position.
HitResult | Set this property to an AdjustmentHandle instance representing the handle that has been hit.

Remarks

For links, set the result to a LinkAdjustmentHandle initialized with the index of the link's control point that has been hit. For nodes, set the result to a NodeAdjustmentHandle initialized with a NodeHandleType enumeration member.

Example

C# [image] Copy Code
void diagram_HitTestAdjustmentHandles(object sender, HitTestEventArgs e)
{
ShapeNode shapeNode = e.Item as ShapeNode;
if (shapeNode != null)
{
if (shapeNode.Bounds.Contains(e.MousePosition))
{
// Always move
e.HitResult = new NodeAdjustmentHandle(NodeHandleType.Move);
}
}
}
Visual Basic [image] Copy Code

Private Sub diagram_HitTestAdjustmentHandles(ByVal sender As Object, ByVal e As HitTestEventArgs) Handles diagram.HitTestAdjustmentHandles

Dim shapeNode As ShapeNode = CType(e.Item, ShapeNode)

If Not shapeNode Is Nothing Then

If (shapeNode.Bounds.Contains(e.MousePosition)) Then

' Always move
e.HitResult = New NodeAdjustmentHandle(NodeHandleType.Move)

End If

End If

End Sub

See Also

DiagramBase Members
DiagramBase Class
DrawAdjustmentHandles Event


MindFusion.Diagramming.DiagramBase.InitializeLink Event

DiagramBase.InitializeLink Event
[image]

Raised when the user starts drawing a new link, just after the DiagramLink instance is created.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> InitializeLink

Visual Basic [image] Copy Code

Public Event InitializeLink As EventHandler(Of LinkEventArgs)

Event Data

InitializeLink event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The new DiagramLink instance.

Remarks

This event is raised immediately after the user starts drawing a new link. It lets you set the appearance properties of the link if you need their values to be different from the default ones defined in the Diagram object, or if they don't have correspondent properties in the Diagram class. The Initialize* events are intended only for initializing the appearance of items. Do not alter the structure of the diagram from their handlers, that is, do not create new items nor delete existing ones; if you do that, the control will be in an undefined state and will likely throw an exception at some point.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
LinkCreating Event
LinkCreated Event
ActionRedone Event


MindFusion.Diagramming.DiagramBase.InitializeNode Event

DiagramBase.InitializeNode Event
[image]

Raised when the user starts drawing a new node, just after the DiagramNode instance is created.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> InitializeNode

Visual Basic [image] Copy Code

Public Event InitializeNode As EventHandler(Of NodeEventArgs)

Event Data

InitializeNode event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The new DiagramNode instance.

Remarks

This event is raised immediately after the user starts drawing a new node. It lets you set the appearance properties of the node if you need their values to be different from the default ones defined in the Diagram object, or if they don't have correspondent properties in the Diagram class. The Initialize* events are intended only for initializing the appearance of items. Do not alter the structure of the diagram from their handlers, that is, do not create new items nor delete existing ones; if you do that, the control will be in an undefined state and will likely throw an exception at some point.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
NodeCreating Event
NodeCreated Event
ActionRedone Event


MindFusion.Diagramming.DiagramBase.ItemAdded Event

DiagramBase.ItemAdded Event
[image]

Raised when an item is added to the diagram, either programmatically or interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemAdded

Visual Basic [image] Copy Code

Public Event ItemAdded As EventHandler(Of ItemEventArgs)

Event Data

ItemAdded event handlers receive an argument of type ItemEventArgs. The following ItemEventArgs members provide information relevant to the event:

Member name | Description
Item | The DiagramItem that has been added to the diagram.

See Also

DiagramBase Members
DiagramBase Class
ItemRemoved Event


MindFusion.Diagramming.DiagramBase.ItemRemoved Event

DiagramBase.ItemRemoved Event
[image]

Raised when an item is removed from the diagram, either programmatically or interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemRemoved

Visual Basic [image] Copy Code

Public Event ItemRemoved As EventHandler(Of ItemEventArgs)

Event Data

ItemRemoved event handlers receive an argument of type ItemEventArgs. The following ItemEventArgs members provide information relevant to the event:

Member name | Description
Item | The DiagramItem that has been removed from the diagram.

See Also

DiagramBase Members
DiagramBase Class
ItemAdded Event


MindFusion.Diagramming.DiagramBase.LayerVisibilityChanged Event

DiagramBase.LayerVisibilityChanged Event
[image]

Raised when the visibility of a Layer changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LayerEventArgs> LayerVisibilityChanged

Visual Basic [image] Copy Code

Public Event LayerVisibilityChanged As EventHandler(Of LayerEventArgs)

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LinkActivated Event

DiagramBase.LinkActivated Event
[image]

Raised when a link becomes the ActiveItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkActivated

Visual Basic [image] Copy Code

Public Event LinkActivated As EventHandler(Of LinkEventArgs)

Event Data

LinkActivated event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has become the ActiveItem.

Remarks

When the event is raised, ActiveItem already refers to the activated link. If multiple selection is disabled, the active item is the only item selected by the user; otherwise it is usually the one added last to the selection.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
LinkDeactivated Event
LinkDeselected Event


MindFusion.Diagramming.DiagramBase.LinkClicked Event

DiagramBase.LinkClicked Event
[image]

Raised when the user clicks a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkClicked

Visual Basic [image] Copy Code

Public Event LinkClicked As EventHandler(Of LinkEventArgs)

Event Data

LinkClicked event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been clicked.
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A PointF specifying the mouse cursor position.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
LinkPointed Event
LinkDoubleClicked Event


MindFusion.Diagramming.DiagramBase.LinkCreateCancelled Event

DiagramBase.LinkCreateCancelled Event
[image]

Raised when the user cancels link creation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkCreateCancelled

Visual Basic [image] Copy Code

Public Event LinkCreateCancelled As EventHandler(Of LinkEventArgs)

Event Data

LinkCreateCancelled event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | Gets the link for which the event raised.
MousePosition | Gets or sets the current mouse pointer position.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LinkCreated Event

DiagramBase.LinkCreated Event
[image]

Raised when the user draws a new link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkCreated

Visual Basic [image] Copy Code

Public Event LinkCreated As EventHandler(Of LinkEventArgs)

Event Data

LinkCreated event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been created.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
InitializeLink Event
LinkCreating Event


MindFusion.Diagramming.DiagramBase.LinkCreating Event

DiagramBase.LinkCreating Event
[image]

A validation event raised while the user is drawing a new link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkValidationEventArgs> LinkCreating

Visual Basic [image] Copy Code

Public Event LinkCreating As EventHandler(Of LinkValidationEventArgs)

Event Data

LinkCreating event handlers receive an argument of type LinkValidationEventArgs. The following LinkValidationEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that is being created.
MousePosition | A PointF specifying the mouse cursor position.
Destination | The DiagramNode that will be set as the link's Destination if this event is validated.
AnchorIndex | Index of the anchor point to which the link will be connected if this event is validated.
TableRow | Index of the table row to which the link will be connected if this event is validated.
Cancel | Set this property to true to prevent the user from creating the link at the current location. That displays the Stop mouse cursor and releasing the button will cancel the operation.
CancelDrag | Call this method to immediately stop the link creation.

Remarks

LinkCreating is raised after each mouse movement while drawing a new link. Setting Cancel to true will change the mouse cursor to DisallowCursor (a Stop icon by default). The event is raised once again when the mouse button is released. Setting Cancel to true in that case will cancel the link creation.

See Also

DiagramBase Members
DiagramBase Class
LinkCreated Event


MindFusion.Diagramming.DiagramBase.LinkDeactivated Event

DiagramBase.LinkDeactivated Event
[image]

Raised when a link is no longer the ActiveItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkDeactivated

Visual Basic [image] Copy Code

Public Event LinkDeactivated As EventHandler(Of LinkEventArgs)

Event Data

LinkDeactivated event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | A DiagramLink that was the ActiveItem.

Remarks

LinkDeactivated is raised when the ActiveItem changes and before that it referred to a link.

See Also

DiagramBase Members
DiagramBase Class
LinkActivated Event


MindFusion.Diagramming.DiagramBase.LinkDeleted Event

DiagramBase.LinkDeleted Event
[image]

Raised when a link is deleted, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkDeleted

Visual Basic [image] Copy Code

Public Event LinkDeleted As EventHandler(Of LinkEventArgs)

Event Data

LinkDeleted event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been deleted.

Remarks

The link is removed from the Items and Links collections before the event is raised. From within an event handler you can still check the values of simple properties such as Text or Tag. Before deleting a node, all links that link to it are deleted too. So there might be several LinkDeleted events raised before NodeDeleted is raised.

To prevent users from deleting a link by pressing the DEL key, handle the LinkDeleting event.

See Also

DiagramBase Members
DiagramBase Class
LinkCreated Event


MindFusion.Diagramming.DiagramBase.LinkDeleting Event

DiagramBase.LinkDeleting Event
[image]

Raised when the user tries to delete a link, this event lets you cancel the operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkValidationEventArgs> LinkDeleting

Visual Basic [image] Copy Code

Public Event LinkDeleting As EventHandler(Of LinkValidationEventArgs)

Event Data

LinkDeleting event handlers receive an argument of type LinkValidationEventArgs. The following LinkValidationEventArgs members provide information relevant to the event:

Member name | Description
Link | A DiagramLink that the user is trying to delete by pressing the DEL key.
Cancel | Set this property to true to prevent the user from deleting the link.

Remarks

When users delete a node, its connecting links are deleted too. However, in that case LinkDeleting validation events are not raised, but just NodeDeleting.

See Also

DiagramBase Members
DiagramBase Class
LinkDeleted Event


MindFusion.Diagramming.DiagramBase.LinkDeselected Event

DiagramBase.LinkDeselected Event
[image]

Raised when a link is deselected, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkDeselected

Visual Basic [image] Copy Code

Public Event LinkDeselected As EventHandler(Of LinkEventArgs)

Event Data

LinkDeselected event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been deselected.

See Also

DiagramBase Members
DiagramBase Class
LinkSelected Event


MindFusion.Diagramming.DiagramBase.LinkDoubleClicked Event

DiagramBase.LinkDoubleClicked Event
[image]

Raised when the user double-clicks a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkDoubleClicked

Visual Basic [image] Copy Code

Public Event LinkDoubleClicked As EventHandler(Of LinkEventArgs)

Event Data

LinkDoubleClicked event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been double-clicked.
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A PointF specifying the mouse cursor position.

See Also

DiagramBase Members
DiagramBase Class
LinkClicked Event


MindFusion.Diagramming.DiagramBase.LinkModified Event

DiagramBase.LinkModified Event
[image]

Raised when the user moves any control point of a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkModified

Visual Basic [image] Copy Code

Public Event LinkModified As EventHandler(Of LinkEventArgs)

Event Data

LinkModified event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been modified.
MousePosition | A PointF specifying the mouse cursor position.
AdjustmentHandle | Index of the adjustment handle that has been moved.

See Also

DiagramBase Members
DiagramBase Class
LinkModifying Event


MindFusion.Diagramming.DiagramBase.LinkModifyCancelled Event

DiagramBase.LinkModifyCancelled Event
[image]

Raised when the user cancels move or resize operation being done on a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkModifyCancelled

Visual Basic [image] Copy Code

Public Event LinkModifyCancelled As EventHandler(Of LinkEventArgs)

Event Data

LinkModifyCancelled event handlers receive an argument of type LinkEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LinkModifying Event

DiagramBase.LinkModifying Event
[image]

A validation event raised while the user is modifying a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkValidationEventArgs> LinkModifying

Visual Basic [image] Copy Code

Public Event LinkModifying As EventHandler(Of LinkValidationEventArgs)

Event Data

LinkModifying event handlers receive an argument of type LinkValidationEventArgs. The following LinkValidationEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that is being modified.
MousePosition | A PointF specifying the mouse cursor position.
AdjustmentHandle | Index of the adjustment handle that is being moved.
ChangingOrigin | A value indicating whether the operation changes the origin of the link.
Origin | The DiagramNode that will be set as the link's Origin if this event is validated.
ChangingDestination | A value indicating whether the operation changes the destination of the link.
Destination | The DiagramNode that will be set as the link's Destination if this event is validated.
AnchorIndex | Index of the anchor point to which the link will be connected if this event is validated.
TableRow | Index of the table row to which the link will be connected if this event is validated.
Cancel | Set this property to true to prevent the user from ending the modification at the current location. That displays the Stop mouse cursor and releasing the button will cancel the operation.
CancelDrag | Call this method to immediately stop the link modification.

Remarks

This event is raised after each mouse movement while modifying a link. Setting Cancel to true will change the mouse cursor to DisallowCursor (a Stop icon by default). The event is raised once again when the mouse button is released. Setting Cancel to true in that case will cancel the modification and return the link to its original state.

The AdjustmentHandle index corresponds to the link's control point that is being dragged.

See Also

DiagramBase Members
DiagramBase Class
LinkModified Event


MindFusion.Diagramming.DiagramBase.LinkPasted Event

DiagramBase.LinkPasted Event
[image]

Raised when a link has been pasted from the clipboard.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkPasted

Visual Basic [image] Copy Code

Public Event LinkPasted As EventHandler(Of LinkEventArgs)

Event Data

LinkPasted event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been pasted from the clipboard.

See Also

DiagramBase Members
DiagramBase Class
DiagramView.PasteFromClipboard Method


MindFusion.Diagramming.DiagramBase.LinkPointed Event

DiagramBase.LinkPointed Event
[image]

Raised when the mouse pointer hovers over a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkPointed

Visual Basic [image] Copy Code

Public Event LinkPointed As EventHandler(Of LinkEventArgs)

Event Data

LinkPointed event handlers receive an argument of type LinkEventArgs.

See Also

DiagramBase Members
DiagramBase Class
LinkClicked Event


MindFusion.Diagramming.DiagramBase.LinkRouted Event

DiagramBase.LinkRouted Event
[image]

Raised when a link is routed by the auto-routing algorithm.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkRouted

Visual Basic [image] Copy Code

Public Event LinkRouted As EventHandler(Of LinkEventArgs)

Event Data

LinkRouted event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been routed.

See Also

DiagramBase Members
DiagramBase Class
DiagramLink.AutoRoute Property


MindFusion.Diagramming.DiagramBase.LinkSelected Event

DiagramBase.LinkSelected Event
[image]

Raised when a link is selected, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkSelected

Visual Basic [image] Copy Code

Public Event LinkSelected As EventHandler(Of LinkEventArgs)

Event Data

LinkSelected event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been selected.

See Also

DiagramBase Members
DiagramBase Class
LinkDeselected Event


MindFusion.Diagramming.DiagramBase.LinkSelecting Event

DiagramBase.LinkSelecting Event
[image]

Raised when the user tries to select a link, this event lets you cancel the operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkValidationEventArgs> LinkSelecting

Visual Basic [image] Copy Code

Public Event LinkSelecting As EventHandler(Of LinkValidationEventArgs)

Event Data

LinkSelecting event handlers receive an argument of type LinkValidationEventArgs. The following LinkValidationEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that the user is trying to select.
MousePosition | A PointF specifying the mouse cursor position.
SelectionRectangle | The current selection rectangle.

Remarks

LinkSelecting is raised in two distinct cases - when the user clicks a link, or while the user is drawing a selection rectangle. When raised because of a mouse click, the MousePosition argument is set to a valid point and the SelectionRectangle argument equals to RectangleF.Empty. While the user is drawing a selection rectangle, the event is raised for each mouse movement, the SelectionRectangle contains the selection coordinates and the MousePosition parameter equals to PointF.Empty.

LinkSelecting is raised while enumerating all items in the z-order collection, so you cannot change the link's ZIndex while handling this event. A selection-related event suitable for changing the z-order of items is SelectionChanged.

See Also

DiagramBase Members
DiagramBase Class
LinkSelected Event


MindFusion.Diagramming.DiagramBase.LinkSplit Event

DiagramBase.LinkSplit Event
[image]

Raised when the user splits a link interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkSplit

Visual Basic [image] Copy Code

Public Event LinkSplit As EventHandler(Of LinkEventArgs)

Event Data

LinkSplit event handlers receive an argument of type LinkEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LinkStartModifying Event

DiagramBase.LinkStartModifying Event
[image]

A validation event raised when the user starts modifying a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkValidationEventArgs> LinkStartModifying

Visual Basic [image] Copy Code

Public Event LinkStartModifying As EventHandler(Of LinkValidationEventArgs)

Event Data

LinkStartModifying event handlers receive an argument of type LinkValidationEventArgs. The following LinkValidationEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that the user is starting to modify.
MousePosition | A PointF specifying the mouse cursor position.
AdjustmentHandle | Index of the adjustment handle that is going to be moved.
Cancel | Set this property to true to prevent the user from starting the link modification.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
LinkModifying Event
ActionRedone Event


MindFusion.Diagramming.DiagramBase.LinkTextEdited Event

DiagramBase.LinkTextEdited Event
[image]

Raised when the user edits the text of a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<EditLinkTextEventArgs> LinkTextEdited

Visual Basic [image] Copy Code

Public Event LinkTextEdited As EventHandler(Of EditLinkTextEventArgs)

Event Data

LinkTextEdited event handlers receive an argument of type EditLinkTextEventArgs.

See Also

DiagramBase Members
DiagramBase Class
LinkTextEditing Event


MindFusion.Diagramming.DiagramBase.LinkTextEditing Event

DiagramBase.LinkTextEditing Event
[image]

A validation event that lets you approve or reject changes made to the text of a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkValidationEventArgs> LinkTextEditing

Visual Basic [image] Copy Code

Public Event LinkTextEditing As EventHandler(Of LinkValidationEventArgs)

Event Data

LinkTextEditing event handlers receive an argument of type LinkValidationEventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
NodeTextEditing Event
CellTextEditing Event
LinkTextEdited Event


MindFusion.Diagramming.DiagramBase.MeasureUnitChanged Event

DiagramBase.MeasureUnitChanged Event
[image]

Raised when the MeasureUnit property value has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler MeasureUnitChanged

Visual Basic [image] Copy Code

Public Event MeasureUnitChanged As EventHandler

Event Data

MeasureUnitChanged event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
BoundsChanged Event
ActionRedone Event


MindFusion.Diagramming.DiagramBase.NodeActivated Event

DiagramBase.NodeActivated Event
[image]

Raised when a node becomes the ActiveItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeActivated

Visual Basic [image] Copy Code

Public Event NodeActivated As EventHandler(Of NodeEventArgs)

Event Data

NodeActivated event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has become the ActiveItem.

Remarks

When this event is raised, ActiveItem already refers to the activated node. If multiple selection is disabled, the active item is the only item selected by the user; otherwise usually it is the one added last to the selection.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
NodeDeactivated Event
NodeSelected Event


MindFusion.Diagramming.DiagramBase.NodeClicked Event

DiagramBase.NodeClicked Event
[image]

Raised when the user clicks a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeClicked

Visual Basic [image] Copy Code

Public Event NodeClicked As EventHandler(Of NodeEventArgs)

Event Data

NodeClicked event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been clicked.
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A PointF specifying the mouse cursor position.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
NodeDoubleClicked Event
CellClicked Event
NodePointed Event


MindFusion.Diagramming.DiagramBase.NodeCreateCancelled Event

DiagramBase.NodeCreateCancelled Event
[image]

Raised when the user cancels node creation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeCreateCancelled

Visual Basic [image] Copy Code

Public Event NodeCreateCancelled As EventHandler(Of NodeEventArgs)

Event Data

NodeCreateCancelled event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
MousePosition | Gets or sets the current mouse pointer position.
Node | Gets the node for which the event was raised.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.NodeCreated Event

DiagramBase.NodeCreated Event
[image]

Raised when the user draws a new node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeCreated

Visual Basic [image] Copy Code

Public Event NodeCreated As EventHandler(Of NodeEventArgs)

Event Data

NodeCreated event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been created.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
InitializeNode Event
NodeCreating Event
ActionRedone Event


MindFusion.Diagramming.DiagramBase.NodeCreating Event

DiagramBase.NodeCreating Event
[image]

A validation event raised while the user is drawing a new node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeValidationEventArgs> NodeCreating

Visual Basic [image] Copy Code

Public Event NodeCreating As EventHandler(Of NodeValidationEventArgs)

Event Data

NodeCreating event handlers receive an argument of type NodeValidationEventArgs. The following NodeValidationEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that is being created.
MousePosition | A PointF specifying the mouse cursor position.
Cancel | Set this property to true to prevent the user from creating the node at the current location. That displays the Stop mouse cursor and releasing the button will cancel the operation.
CancelDrag | Call this method to immediately stop the node creation.

Remarks

NodeCreating is raised after each mouse movement while drawing a new node. Setting Cancel to true will change the mouse cursor to DisallowCursor (a Stop icon by default). The event is raised once again when the mouse button is released. Setting Cancel to true in that case will cancel the node creation.

See Also

DiagramBase Members
DiagramBase Class
NodeCreated Event


MindFusion.Diagramming.DiagramBase.NodeDeactivated Event

DiagramBase.NodeDeactivated Event
[image]

Raised when a node is no longer the ActiveItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeDeactivated

Visual Basic [image] Copy Code

Public Event NodeDeactivated As EventHandler(Of NodeEventArgs)

Event Data

NodeDeactivated event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that was the ActiveItem.

Remarks

NodeDeactivated is raised when the ActiveItem changes and before that it referred to a node.

See Also

DiagramBase Members
DiagramBase Class
NodeActivated Event


MindFusion.Diagramming.DiagramBase.NodeDeleted Event

DiagramBase.NodeDeleted Event
[image]

Raised when a node is deleted, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeDeleted

Visual Basic [image] Copy Code

Public Event NodeDeleted As EventHandler(Of NodeEventArgs)

Event Data

NodeDeleted event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been deleted.

Remarks

When the event is raised, the node is already removed from the Items and Nodes collections and all links connected to the node are deleted. From within an event handler you can still check the values of simple properties of the node such as Text or Tag.

To prevent users from deleting a node by pressing the DEL key, handle the NodeCreating event.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
NodeDeleting Event
NodeCreated Event


MindFusion.Diagramming.DiagramBase.NodeDeleting Event

DiagramBase.NodeDeleting Event
[image]

Raised when the user tries to delete a node, this event lets you cancel the operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeValidationEventArgs> NodeDeleting

Visual Basic [image] Copy Code

Public Event NodeDeleting As EventHandler(Of NodeValidationEventArgs)

Event Data

NodeDeleting event handlers receive an argument of type NodeValidationEventArgs. The following NodeValidationEventArgs members provide information relevant to the event:

Member name | Description
Node | A DiagramNode that the user is trying to delete by pressing the DEL key.
Cancel | Set this property to true to prevent the user from deleting the node.

Remarks

When the user deletes a node, the links connected to it are deleted too. However, the LinkDeleting validation event is not raised in that case.

See Also

DiagramBase Members
DiagramBase Class
NodeDeleted Event


MindFusion.Diagramming.DiagramBase.NodeDeselected Event

DiagramBase.NodeDeselected Event
[image]

Raised when a node is deselected, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeDeselected

Visual Basic [image] Copy Code

Public Event NodeDeselected As EventHandler(Of NodeEventArgs)

Event Data

NodeDeselected event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been deselected.

See Also

DiagramBase Members
DiagramBase Class
NodeSelected Event


MindFusion.Diagramming.DiagramBase.NodeDoubleClicked Event

DiagramBase.NodeDoubleClicked Event
[image]

Raised when the user double-clicks a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeDoubleClicked

Visual Basic [image] Copy Code

Public Event NodeDoubleClicked As EventHandler(Of NodeEventArgs)

Event Data

NodeDoubleClicked event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been double-clicked.
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A PointF specifying the mouse cursor position.

See Also

DiagramBase Members
DiagramBase Class
NodeClicked Event


MindFusion.Diagramming.DiagramBase.NodeModified Event

DiagramBase.NodeModified Event
[image]

Raised when the user moves or resizes a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeModified

Visual Basic [image] Copy Code

Public Event NodeModified As EventHandler(Of NodeEventArgs)

Event Data

NodeModified event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been modified.
MousePosition | A PointF specifying the mouse cursor position.
AdjustmentHandle | The adjustment handle that has been moved.

Remarks

NodeModified is not raised if the node position is changed programmatically. The event occurs only when the user has dragged an adjustment handle to a new position.

See Also

DiagramBase Members
DiagramBase Class
NodeModifying Event


MindFusion.Diagramming.DiagramBase.NodeModifyCancelled Event

DiagramBase.NodeModifyCancelled Event
[image]

Raised when the user cancels move or resize operation being done on a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeModifyCancelled

Visual Basic [image] Copy Code

Public Event NodeModifyCancelled As EventHandler(Of NodeEventArgs)

Event Data

NodeModifyCancelled event handlers receive an argument of type NodeEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.NodeModifying Event

DiagramBase.NodeModifying Event
[image]

A validation event raised while the user is moving or resizing a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeValidationEventArgs> NodeModifying

Visual Basic [image] Copy Code

Public Event NodeModifying As EventHandler(Of NodeValidationEventArgs)

Event Data

NodeModifying event handlers receive an argument of type NodeValidationEventArgs. The following NodeValidationEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that is being modified.
MousePosition | A PointF specifying the mouse cursor position.
AdjustmentHandle | The adjustment handle that is being moved.
Cancel | Set this property to true to prevent the user from ending the modification at the current location. That displays the Stop mouse cursor and releasing the button will cancel the operation.
CancelDrag | Call this method to immediately stop the node modification.

Remarks

This event is raised after each mouse movement while modifying a node. Setting Cancel to true will change the mouse cursor to DisallowCursor (a Stop icon by default). The event is raised once again when the mouse button is released. Setting Cancel to true in that case will cancel the modification and return the node to its original location.

See Also

DiagramBase Members
DiagramBase Class
NodeModified Event


MindFusion.Diagramming.DiagramBase.NodePasted Event

DiagramBase.NodePasted Event
[image]

Raised when a node has been pasted from the clipboard.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodePasted

Visual Basic [image] Copy Code

Public Event NodePasted As EventHandler(Of NodeEventArgs)

Event Data

NodePasted event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been pasted from the clipboard.

See Also

DiagramBase Members
DiagramBase Class
DiagramView.PasteFromClipboard Method


MindFusion.Diagramming.DiagramBase.NodePointed Event

DiagramBase.NodePointed Event
[image]

Raised when the mouse pointer hovers over a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodePointed

Visual Basic [image] Copy Code

Public Event NodePointed As EventHandler(Of NodeEventArgs)

Event Data

NodePointed event handlers receive an argument of type NodeEventArgs.

See Also

DiagramBase Members
DiagramBase Class
NodeClicked Event


MindFusion.Diagramming.DiagramBase.NodeSelected Event

DiagramBase.NodeSelected Event
[image]

Raised when a node is selected, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeSelected

Visual Basic [image] Copy Code

Public Event NodeSelected As EventHandler(Of NodeEventArgs)

Event Data

NodeSelected event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been selected.

See Also

DiagramBase Members
DiagramBase Class
NodeDeselected Event


MindFusion.Diagramming.DiagramBase.NodeSelecting Event

DiagramBase.NodeSelecting Event
[image]

Raised when the user tries to select a node, this event lets you cancel the operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeValidationEventArgs> NodeSelecting

Visual Basic [image] Copy Code

Public Event NodeSelecting As EventHandler(Of NodeValidationEventArgs)

Event Data

NodeSelecting event handlers receive an argument of type NodeValidationEventArgs. The following NodeValidationEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that the user is trying to select.
MousePosition | A PointF specifying the mouse cursor position.
SelectionRectangle | The current selection rectangle.

Remarks

NodeSelecting is raised in two distinct cases - when the user clicks a node, or while the user is drawing a selection rectangle. When raised because of a mouse click, the MousePosition argument is set to a valid point and the SelectionRectangle argument equals to RectangleF.Empty. While the user is drawing a selection rectangle, the event is raised for each mouse movement, the SelectionRectangle contains the selection coordinates and the MousePosition parameter equals to PointF.Empty.

NodeSelecting is raised while enumerating all items in the z-order collection, so you cannot change the node's ZIndex while handling this event. A selection-related event suitable for changing the z-order of items is SelectionChanged.

See Also

DiagramBase Members
DiagramBase Class
NodeSelected Event


MindFusion.Diagramming.DiagramBase.NodeStartModifying Event

DiagramBase.NodeStartModifying Event
[image]

A validation event raised when the user starts modifying a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeValidationEventArgs> NodeStartModifying

Visual Basic [image] Copy Code

Public Event NodeStartModifying As EventHandler(Of NodeValidationEventArgs)

Event Data

NodeStartModifying event handlers receive an argument of type NodeValidationEventArgs. The following NodeValidationEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that the user is starting to modify.
MousePosition | A PointF specifying the mouse cursor position.
AdjustmentHandle | The adjustment handle that is going to be moved.
Cancel | Set this property to true to prevent the user from starting the node modification.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
NodeModifying Event
ActionRedone Event


MindFusion.Diagramming.DiagramBase.NodeTextEdited Event

DiagramBase.NodeTextEdited Event
[image]

Raised when the user edits the text of a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<EditNodeTextEventArgs> NodeTextEdited

Visual Basic [image] Copy Code

Public Event NodeTextEdited As EventHandler(Of EditNodeTextEventArgs)

Event Data

NodeTextEdited event handlers receive an argument of type EditNodeTextEventArgs. The following EditNodeTextEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode whose text has been edited.
NewText | The node's new text.
OldText | The node's old text.

See Also

DiagramBase Members
DiagramBase Class
NodeTextEditing Event


MindFusion.Diagramming.DiagramBase.NodeTextEditing Event

DiagramBase.NodeTextEditing Event
[image]

A validation event that lets you approve or reject changes made to the text of a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeValidationEventArgs> NodeTextEditing

Visual Basic [image] Copy Code

Public Event NodeTextEditing As EventHandler(Of NodeValidationEventArgs)

Event Data

NodeTextEditing event handlers receive an argument of type NodeValidationEventArgs. The following NodeValidationEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that the user is trying to edit.
Cancel | Set this property to true to prevent the user from editing the node's text.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
NodeTextEdited Event
LinkTextEditing Event


MindFusion.Diagramming.DiagramBase.OriginAnchorChanged Event

DiagramBase.OriginAnchorChanged Event
[image]

Raised when the OriginAnchor property value of a link has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<AnchorPointEventArgs> OriginAnchorChanged

Visual Basic [image] Copy Code

Public Event OriginAnchorChanged As EventHandler(Of AnchorPointEventArgs)

Event Data

OriginAnchorChanged event handlers receive an argument of type AnchorPointEventArgs. The following AnchorPointEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink whose OriginAnchor has changed.
OldAnchorIndex | Index of the old anchor point.
NewAnchorIndex | Index of the new anchor point.

Remarks

This event is raised every time the OriginAnchor property of a link changes, either because an user connects the link end to a different anchor point, or because an application sets it programmatically.

See Also

DiagramBase Members
DiagramBase Class
DestinationAnchorChanged Event


MindFusion.Diagramming.DiagramBase.QueryAlignTarget Event

DiagramBase.QueryAlignTarget Event
[image]

Raised to validate a node as target for alignment guides when AutoAlignNodes is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeValidationEventArgs> QueryAlignTarget

Visual Basic [image] Copy Code

Public Event QueryAlignTarget As EventHandler(Of NodeValidationEventArgs)

Event Data

Member name | Description
Cancel | Set it to true to prevent a node from being used as alignment target.
Node | The DiagramNode that would be used as alignment target.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.Repaint Event

DiagramBase.Repaint Event
[image]

Raised when the diagram views should be repainted.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<RepaintEventArgs> Repaint

Visual Basic [image] Copy Code

Public Event Repaint As EventHandler(Of RepaintEventArgs)

Event Data

Repaint event handlers receive an argument of type RepaintEventArgs. The following RepaintEventArgs members provide information relevant to the event:

Member name | Description
InvalidRect | A RectangleF specifying which part of the diagram should be repainted.

Remarks

If InvalidRect equals to RectangleF.Empty, the whole diagram should be repainted.

See Also

DiagramBase Members
DiagramBase Class
Invalidate Method


MindFusion.Diagramming.DiagramBase.RequestCacheReset Event

DiagramBase.RequestCacheReset Event
[image]

Raised when an object within the diagram requests a reset of the cached bitmap.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler RequestCacheReset

Visual Basic [image] Copy Code

Public Event RequestCacheReset As EventHandler

Event Data

RequestCacheReset event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.RequestClipboard Event

DiagramBase.RequestClipboard Event
[image]

Raised when an object within the diagram requests an operation with the clipboard.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<ClipboardEventArgs> RequestClipboard

Visual Basic [image] Copy Code

Public Event RequestClipboard As EventHandler(Of ClipboardEventArgs)

Event Data

RequestClipboard event handlers receive an argument of type ClipboardEventArgs. The following ClipboardEventArgs members provide information relevant to the event:

Member name | Description
IsGetOperation | Indicates whether getting or setting the clipboard.
Source | The object, which initiated the operation.
Data | The clipboard data.
DataType | The type of the clipboard data. This is relevant during Clipboard get operations.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.RequestTimer Event

DiagramBase.RequestTimer Event
[image]

Raised when an object within the diagram needs to start or stop a timer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<TimerEventArgs> RequestTimer

Visual Basic [image] Copy Code

Public Event RequestTimer As EventHandler(Of TimerEventArgs)

Event Data

RequestTimer event handlers receive an argument of type TimerEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.SelectionChanged Event

DiagramBase.SelectionChanged Event
[image]

Raised when an item is added to or removed from the selection

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler SelectionChanged

Visual Basic [image] Copy Code

Public Event SelectionChanged As EventHandler

Event Data

SelectionChanged event handlers receive an argument of type EventArgs.

Remarks

Use the Nodes and Links properties of the diagram's Selection to find out which items are currently selected.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.SelectionModified Event

DiagramBase.SelectionModified Event
[image]

Raised when the user moves multiple selected items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<SelectionEventArgs> SelectionModified

Visual Basic [image] Copy Code

Public Event SelectionModified As EventHandler(Of SelectionEventArgs)

Event Data

SelectionModified event handlers receive an argument of type SelectionEventArgs.

Remarks

Use the Nodes and Links properties of the diagram's Selection to find out which items have been moved.

See Also

DiagramBase Members
DiagramBase Class
SelectionModifying Event


MindFusion.Diagramming.DiagramBase.SelectionModifying Event

DiagramBase.SelectionModifying Event
[image]

Raised while the user is moving multiple selected items, this event lets you cancel the modification.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<SelectionValidationEventArgs> SelectionModifying

Visual Basic [image] Copy Code

Public Event SelectionModifying As EventHandler(Of SelectionValidationEventArgs)

Event Data

SelectionModifying event handlers receive an argument of type SelectionValidationEventArgs. The following SelectionValidationEventArgs members provide information relevant to the event:

Member name | Description
Cancel | Set this property to true to prevent the user from placing the selected items at the current location. That displays the Stop mouse cursor and releasing the button will cancel the operation.
CancelDrag | Call this method to immediately stop the modification.

Remarks

This event is raised after each mouse movement while modifying a selection of items. Setting Cancel to true will change the mouse cursor to DisallowCursor (a Stop icon by default). The event is raised once again when the mouse button is released. Setting Cancel to true in that case will cancel the modification and return the items to their original position.

Use the Selection property of the Diagram class to access the selected items.

See Also

DiagramBase Members
DiagramBase Class
SelectionModified Event


MindFusion.Diagramming.DiagramBase.SerializeTag Event

DiagramBase.SerializeTag Event
[image]

Raised when the Tag of a diagram item must be serialized into an XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<SerializeTagEventArgs> SerializeTag

Visual Basic [image] Copy Code

Public Event SerializeTag As EventHandler(Of SerializeTagEventArgs)

Event Data

SerializeTag event handlers receive an argument of type SerializeTagEventArgs. The following SerializeTagEventArgs members provide information relevant to the event:

Member name | Description
Object | The object whose Tag is being serialized. This object can be either a diagram item, group, cell or anchor point.
Tag | The Tag object being serialized.
Representation | An XmlElement instance where the XML representation of the Tag should be saved.
Context | An XmlPersistContext object providing information about the document being serialized, along with methods that help you serialize data to XML.
Handled | Set this flag to true if you perform custom tag serialization.

Remarks

Only tags of simple value types can be saved and loaded automatically to/from the XML document. You must provide your own serialization for complex types by implementing this event and DeserializeTag.

Example

C# [image] Copy Code

private void Write(string fileName)
{
diagram.SerializeTag += new SerializeTagEventHandler(SerializeTag);
diagram.SaveToXml(fileName);
}

void SerializeTag(object sender, SerializeTagEventArgs e)
{
e.Handled = true;
object tag = e.Tag;
string stringRepresentation = "";

if (tag != null)
{
stringRepresentation = tag.GetType().ToString();
stringRepresentation += ";";
stringRepresentation += tag.ToString();
}

XmlNode repNode =
e.Context.XmlDocument.CreateTextNode(stringRepresentation);
e.Representation.AppendChild(repNode);
}

Visual Basic [image] Copy Code

Private Sub Write(ByVal fileName As String)

AddHandler diagram.SerializeTag, New SerializeTagEventHandler(AddressOf SerializeTag)
diagram.SaveToXml(fileName)

End Sub

Sub SerializeTag(ByVal sender As Object, ByVal e As SerializeTagEventArgs)

e.Handled = True

Dim tag As Object = e.Tag
Dim stringRepresentation As String = ""

If Not Tag Is Nothing Then

stringRepresentation = Tag.GetType().ToString()
stringRepresentation += ";"
stringRepresentation += Tag.ToString()

End If

Dim repNode As XmlNode = _
e.Context.XmlDocument.CreateTextNode(stringRepresentation)
e.Representation.AppendChild(repNode)

End Sub

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
DeserializeTag Event
Diagram.SaveToXml Method


MindFusion.Diagramming.DiagramBase.SetSelfLoopShape Event

DiagramBase.SetSelfLoopShape Event
[image]

Raised when a link becomes a self-loop, giving you a chance to override the default look shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkShapeEventArgs> SetSelfLoopShape

Visual Basic [image] Copy Code

Public Event SetSelfLoopShape As EventHandler(Of LinkShapeEventArgs)

Event Data

SetSelfLoopShape event handlers receive an argument of type LinkShapeEventArgs. The following LinkShapeEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that becomes a self-loop.
Handled | Indicates whether the event handler has set a custom loop shape.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.ShapeModified Event

DiagramBase.ShapeModified Event
[image]

Raised when the user modifies the shape of a ShapeNode by moving one of the control points corresponding to shape formula parameters.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<ControlPointEventArgs> ShapeModified

Visual Basic [image] Copy Code

Public Event ShapeModified As EventHandler(Of ControlPointEventArgs)

Event Data

ShapeModified event handlers receive an argument of type ControlPointEventArgs. The following ControlPointEventArgs members provide information relevant to the event:

Member name | Description
ControlPoint | Gets the ShapeControlPoint used to modify the node's shape.
NewValue | Gets the new position of the control point.
Node | Gets the ShapeNode whose Shape has been modified.
OldValue | Gets the original position of the control point.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.TableColumnResized Event

DiagramBase.TableColumnResized Event
[image]

Raised when the user finishes resizing a column in a table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<CellEventArgs> TableColumnResized

Visual Basic [image] Copy Code

Public Event TableColumnResized As EventHandler(Of CellEventArgs)

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.TableColumnResizing Event

DiagramBase.TableColumnResizing Event
[image]

Raised when the user resizes a column in a table interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<CellValidationEventArgs> TableColumnResizing

Visual Basic [image] Copy Code

Public Event TableColumnResizing As EventHandler(Of CellValidationEventArgs)

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.TableRowResized Event

DiagramBase.TableRowResized Event
[image]

Raised when the user finishes resizing a row in a table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<CellEventArgs> TableRowResized

Visual Basic [image] Copy Code

Public Event TableRowResized As EventHandler(Of CellEventArgs)

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.TableRowResizing Event

DiagramBase.TableRowResizing Event
[image]

Raised when the user resizes a row in a table interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<CellValidationEventArgs> TableRowResizing

Visual Basic [image] Copy Code

Public Event TableRowResizing As EventHandler(Of CellValidationEventArgs)

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.TableSectionCollapsed Event

DiagramBase.TableSectionCollapsed Event
[image]

Raised when the user collapses the rows of a table’s section by clicking the [-] button in the section's header row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<RowEventArgs> TableSectionCollapsed

Visual Basic [image] Copy Code

Public Event TableSectionCollapsed As EventHandler(Of RowEventArgs)

Event Data

TableSectionCollapsed event handlers receive an argument of type RowEventArgs. The following RowEventArgs members provide information relevant to the event:

Member name | Description
Table | The TableNode that contains the collapsed rows.
RowIndex | Index of the header row of the collapsed section.

Remarks

A header row is a row whose Header property is enabled. Such rows display a [±] button which can be used to expand or collapse all rows below a header up to the next header. TableSectionCollapsed is raised when a user clicks the [-] button, but not when Expanded is set to false programmatically.

See Also

DiagramBase Members
DiagramBase Class
TableSectionExpanded Event


MindFusion.Diagramming.DiagramBase.TableSectionExpanded Event

DiagramBase.TableSectionExpanded Event
[image]

Raised when the user expands the rows of a table's section by clicking the [+] button in the section’s header row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<RowEventArgs> TableSectionExpanded

Visual Basic [image] Copy Code

Public Event TableSectionExpanded As EventHandler(Of RowEventArgs)

Event Data

TableSectionExpanded event handlers receive an argument of type RowEventArgs. The following RowEventArgs members provide information relevant to the event:

Member name | Description
Table | The TableNode that contains the expanded rows.
RowIndex | Index of the header row of the expanded section.

Remarks

A header row is a row whose Header property is enabled. Such rows display a [±] button which can be used to expand or collapse all rows below a header up to the next header. TableSectionExpanded is raised when a user clicks the [+] button, but not when Expanded is set to true programmatically.

Example

The code below changes the color of the first cell of a header row when the table section defined via that row is expanded:

C# [image] Copy Code
void diagram_TableSectionExpanded(object sender, RowEventArgs e)
{
e.Table[0, e.RowIndex].Brush = new MindFusion.Drawing.SolidBrush(Color.Blue);
}
Visual Basic [image] Copy Code
Private Sub Diagram_TableSectionExpanded(ByVal sender As Object, ByVal e As MindFusion.Diagramming.RowEventArgs)Handles Diagram.TableSectionExpanded
e.Table(0, e.RowIndex).Brush = New MindFusion.Drawing.SolidBrush(Color.Blue)
End Sub

See Also

DiagramBase Members
DiagramBase Class
TableSectionCollapsed Event


MindFusion.Diagramming.DiagramBase.TreeCollapsed Event

DiagramBase.TreeCollapsed Event
[image]

Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> TreeCollapsed

Visual Basic [image] Copy Code

Public Event TreeCollapsed As EventHandler(Of NodeEventArgs)

Event Data

TreeCollapsed event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The root DiagramNode of the collapsed tree branch.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
TreeExpanded Event
ActionRedone Event


MindFusion.Diagramming.DiagramBase.TreeExpanded Event

DiagramBase.TreeExpanded Event
[image]

Raised when a user expands a tree branch by clicking the [+] button of an Expandable node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> TreeExpanded

Visual Basic [image] Copy Code

Public Event TreeExpanded As EventHandler(Of NodeEventArgs)

Event Data

TreeExpanded event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The root DiagramNode of the expanded tree branch.

See Also

DiagramBase Members
DiagramBase Class
TreeCollapsed Event


MindFusion.Diagramming.DiagramBase.TreeItemTextEditing Event

DiagramBase.TreeItemTextEditing Event
[image]

A validation event that lets you approve or reject changes made to the text of a TreeViewNode's item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<TreeItemValidationEventArgs> TreeItemTextEditing

Visual Basic [image] Copy Code

Public Event TreeItemTextEditing As EventHandler(Of TreeItemValidationEventArgs)

Event Data

TreeItemTextEditing event handlers receive an argument of type TreeItemValidationEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.ValidateAnchorPoint Event

DiagramBase.ValidateAnchorPoint Event
[image]

A validation event that lets you approve or reject connecting a link to an anchor point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkValidationEventArgs> ValidateAnchorPoint

Visual Basic [image] Copy Code

Public Event ValidateAnchorPoint As EventHandler(Of LinkValidationEventArgs)

Event Data

ValidateAnchorPoint event handlers receive an argument of type LinkValidationEventArgs. The following LinkValidationEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that will be connected to the anchor point.
MousePosition | A PointF specifying the mouse cursor position.
AdjustmentHandle | Index of the adjustment handle that is being moved.
ChangingOrigin | A value indicating whether the operation changes the origin of the link.
ChangingDestination | A value indicating whether the operation changes the destination of the link.
Node | The DiagramNode to which the link will be connected.
AnchorIndex | Index of an anchor point to which the link will be connected if this event is validated.
Cancel | Set this property to true to prevent connecting the link to specified point.

Remarks

This event is raised for each point of an AnchorPattern while a link's end point is being moved over a node. If none of the anchor points are validated, the mouse cursor icon changes to DisallowLinkCursor, indicating that the link cannot be connected to that node.

When the mouse button is released over a node, the event is raised again for the node's anchor points. From all validated anchor points, the one nearest to the dragged link end point is used to dock the link.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.ViewRemoved Event

DiagramBase.ViewRemoved Event
[image]

Raised when a DiagramView is detached from this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<CancelEventArgs> ViewRemoved

Visual Basic [image] Copy Code

Public Event ViewRemoved As EventHandler(Of CancelEventArgs)

Event Data

ViewRemoved event handlers receive an argument of type CancelEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase Class

DiagramBase Class
[image]

The base class of the Diagram and DiagramDocument classes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class DiagramBase : Component

Visual Basic [image] Copy Code

Public MustInherit Class DiagramBase
Inherits Component

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.DiagramBase
MindFusion.Diagramming.Diagram
MindFusion.Diagramming.DiagramDocument

See Also

DiagramBase Members


MindFusion.Diagramming.DiagramBase Members

DiagramBase Members
Constructors Methods Events
[image]

The base class of the Diagram and DiagramDocument classes.

The following tables list the members exposed by the DiagramBase type.

Protected Constructors

Name | Description
DiagramBase | Initializes a new instance of the DiagramBase class.

Public Methods

Name | Description
TrackMouseHover | Specifies whether the diagram view should track mouse hover events.

Protected Methods

Name | Description
OnActionRecorded | Raises the ActionRecorded event.
OnActionRecording | Raises the ActionRecording event.
OnActionRedone | Raises the ActionRedone event.
OnActionUndone | Raises the ActionUndone event.
OnBeginLoad | Raises the BeginLoad event.
OnBoundsChanged | Raises the BoundsChanged event.
OnCellClicked | Raises the CellClicked event.
OnCellDoubleClicked | Raises the CellDoubleClicked event.
OnCellTextEdited | Raises the CellTextEdited event.
OnCellTextEditing | Raises the CellTextEditing event to validate entering inplace edit mode.
OnClicked | Raises the Clicked event.
OnContainerChildAdded | Raises the ContainerChildAdded event.
OnContainerChildRemoved | Raises the ContainerChildRemoved event.
OnContainerFolded | Raises the ContainerFolded event.
OnContainerUnfolded | Raises the ContainerUnfolded event.
OnContentVisibilityChanged | Raises the ContentVisibilityChanged event.
OnDefaultShapeChanged | Raises the DefaultShapeChanged event.
OnDeserializeTag | Raises the DeserializeTag event.
OnDestinationAnchorChanged | Raises the DestinationAnchorChanged event.
OnDirtyChanged | Raises the DirtyChanged event.
OnDoubleClicked | Raises the DoubleClicked event.
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event.
OnDrawAnchorPoint | Raises the DrawAnchorPoint event.
OnDrawBackground | Raises the DrawBackground event.
OnDrawCell | Raises the DrawCell event.
OnDrawForeground | Raises the DrawForeground event.
OnDrawLink | Raises the DrawLink event.
OnDrawNode | Raises the DrawNode event.
OnEndLoad | Raises the EndLoad event.
OnExpandButtonClicked | Raises the ExpandButtonClicked event.
OnGroupDestroyed | Raises the GroupDestroyed event.
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event.
OnInitializeLink | Raises the InitializeLink event.
OnInitializeNode | Raises the InitializeNode event.
OnItemAdded | Raises the ItemAdded event.
OnItemRemoved | Raises the ItemRemoved event.
OnLayerVisibilityChanged | Raises the LayerVisibilityChanged event.
OnLinkActivated | Raises the LinkActivated event.
OnLinkClicked | Raises the LinkClicked event.
OnLinkCreateCancelled | Raises the LinkCreateCancelled event.
OnLinkCreated | Raises the LinkCreated event.
OnLinkCreating | Raises the LinkCreating event.
OnLinkDeactivated | Raises the LinkDeactivated event.
OnLinkDeleted | Raises the LinkDeleted event.
OnLinkDeleting | Raises the LinkDeleting event.
OnLinkDeselected | Raises the LinkDeselected event.
OnLinkDoubleClicked | Raises the LinkDoubleClicked event.
OnLinkModified | Raises the LinkModified event.
OnLinkModifyCancelled | Raises the LinkModifyCancelled event.
OnLinkModifying | Raises the LinkModifying event.
OnLinkPasted | Raises the LinkPasted event.
OnLinkPointed | Raises the LinkPointed event.
OnLinkRouted | Raises the LinkRouted event.
OnLinkSelected | Raises the LinkSelected event.
OnLinkSelecting | Raises the LinkSelecting event.
OnLinkSplit | Raises the LinkSplit event.
OnLinkStartModifying | Raises the LinkStartModifying event.
OnLinkTextEdited | Raises the LinkTextEdited event.
OnLinkTextEditing | Raises the LinkTextEditing event to validate entering inplace edit mode.
OnMeasureUnitChanged | Raises the MeasureUnitChanged event.
OnNodeActivated | Raises the NodeActivated event.
OnNodeClicked | Raises the NodeClicked event.
OnNodeCreateCancelled | Raises the NodeCreateCancelled event.
OnNodeCreated | Raises the NodeCreated event.
OnNodeCreating | Raises the NodeCreating event.
OnNodeDeactivated | Raises the NodeDeactivated event.
OnNodeDeleted | Raises the NodeDeleted event.
OnNodeDeleting | Raises the NodeDeleting event.
OnNodeDeselected | Raises the NodeDeselected event.
OnNodeDoubleClicked | Raises the NodeDoubleClicked event.
OnNodeModified | Raises the NodeModified event.
OnNodeModifyCancelled | Raises the NodeModifyCancelled event.
OnNodeModifying | Raises the NodeModifying event.
OnNodePasted | Raises the NodePasted event.
OnNodePointed | Raises the NodePointed event.
OnNodeSelected | Raises the NodeSelected event.
OnNodeSelecting | Raises the NodeSelecting event.
OnNodeStartModifying | Raises the NodeStartModifying event.
OnNodeTextEdited | Raises the NodeTextEdited event.
OnNodeTextEditing | Raises the NodeTextEditing event to validate entering inplace edit mode.
OnOriginAnchorChanged | Raises the OriginAnchorChanged event.
OnQueryAlignTarget | Raises the QueryAlignTarget event.
OnRepaint | Raises the Repaint event.
OnRequestClipboard | Raises the RequestClipboard event.
OnRequestTimer | Raises the RequestTimer event.
OnSelectionChanged | Raises the SelectionChanged event.
OnSelectionModified | Raises the SelectionModified event.
OnSelectionModifying | Raises the SelectionModifying event.
OnSerializeTag | Raises the SerializeTag event.
OnSetSelfLoopShape | Raises the SetSelfLoopShape event.
OnShapeModified | Raises the ShapeModified event.
OnTableColumnResized | Raises the TableColumnResized event.
OnTableColumnResizing | Raises the TableColumnResizing event.
OnTableRowResized | Raises the TableRowResized event.
OnTableRowResizing | Raises the TableRowResizing event.
OnTableSectionCollapsed | Raises the TableSectionCollapsed event.
OnTableSectionExpanded | Raises the TableSectionExpanded event.
OnTreeCollapsed | Raises the TreeCollapsed event.
OnTreeExpanded | Raises the TreeExpanded event.
OnTreeItemTextEditing | Raises the TreeItemTextEditing event.
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event.
OnViewRemoved | Raises the ViewRemoved event.

Public Events

Name | Description
ActionRecorded | Raised when an action is recorded in the undo buffer.
ActionRecording | A validation event raised before an action is recorded in the undo buffer.
ActionRedone | Raised when an action is redone.
ActionUndone | Raised when an action is undone.
ActiveLayerChanged | Raised when the diagram's active layer has changed.
BeginLoad | Raised when the component starts loading diagram data from a file or memory stream.
BoundsChanged | Raised when the Bounds property value has changed.
CellClicked | Raised when the user clicks a table’s cell.
CellDoubleClicked | Raised when the user double-clicks a table’s cell.
CellTextEdited | Raised when the user edits the text of a table’s cell.
CellTextEditing | A validation event that lets you approve or reject changes made to the text of a table’s cell.
Clicked | Raised when the user clicks the diagram at a point where no items are located.
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user.
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user.
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area.
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area.
ContentVisibilityChanged | Raised when the visibility of container's content changes.
DefaultShapeChanged | Raised when the DefaultShape property value has changed.
DeserializeTag | Raised when the Tag of a diagram item must be deserialized from XML format.
DestinationAnchorChanged | Raised when the DestinationAnchor property value of a link has changed.
DirtyChanged | Raised when the Dirty property value has changed.
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located.
DrawAdjustmentHandles | Raised when item’s adjustment handles must be custom drawn.
DrawAnchorPoint | Raised when an anchor point must be custom drawn.
DrawBackground | Raised to let you custom draw the diagram background.
DrawCell | Raised when a table’s cell must be custom drawn.
DrawForeground | Raised to let you custom draw the diagram foreground.
DrawLink | Raised when a diagram link must be custom drawn.
DrawNode | Raised when a diagram node must be custom drawn.
EndLoad | Raised when the component ends loading diagram data from a file or memory stream.
ExpandButtonClicked | Raised when the user clicks the [±] button of an Expandable node.
GroupDestroyed | Raised when a Group object is destroyed.
HitTestAdjustmentHandles | Raised when custom hit testing of item’s adjustment handles must be performed.
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created.
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created.
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively.
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively.
LayerVisibilityChanged | Raised when the visibility of a Layer changes.
LinkActivated | Raised when a link becomes the ActiveItem.
LinkClicked | Raised when the user clicks a link.
LinkCreateCancelled | Raised when the user cancels link creation.
LinkCreated | Raised when the user draws a new link.
LinkCreating | A validation event raised while the user is drawing a new link.
LinkDeactivated | Raised when a link is no longer the ActiveItem.
LinkDeleted | Raised when a link is deleted, either programmatically or by the user.
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation.
LinkDeselected | Raised when a link is deselected, either programmatically or by the user.
LinkDoubleClicked | Raised when the user double-clicks a link.
LinkModified | Raised when the user moves any control point of a link.
LinkModifyCancelled | Raised when the user cancels move or resize operation being done on a link.
LinkModifying | A validation event raised while the user is modifying a link.
LinkPasted | Raised when a link has been pasted from the clipboard.
LinkPointed | Raised when the mouse pointer hovers over a link.
LinkRouted | Raised when a link is routed by the auto-routing algorithm.
LinkSelected | Raised when a link is selected, either programmatically or by the user.
LinkSelecting | Raised when the user tries to select a link, this event lets you cancel the operation.
LinkSplit | Raised when the user splits a link interactively.
LinkStartModifying | A validation event raised when the user starts modifying a link.
LinkTextEdited | Raised when the user edits the text of a link.
LinkTextEditing | A validation event that lets you approve or reject changes made to the text of a link.
MeasureUnitChanged | Raised when the MeasureUnit property value has changed.
NodeActivated | Raised when a node becomes the ActiveItem.
NodeClicked | Raised when the user clicks a node.
NodeCreateCancelled | Raised when the user cancels node creation.
NodeCreated | Raised when the user draws a new node.
NodeCreating | A validation event raised while the user is drawing a new node.
NodeDeactivated | Raised when a node is no longer the ActiveItem.
NodeDeleted | Raised when a node is deleted, either programmatically or by the user.
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation.
NodeDeselected | Raised when a node is deselected, either programmatically or by the user.
NodeDoubleClicked | Raised when the user double-clicks a node.
NodeModified | Raised when the user moves or resizes a node.
NodeModifyCancelled | Raised when the user cancels move or resize operation being done on a node.
NodeModifying | A validation event raised while the user is moving or resizing a node.
NodePasted | Raised when a node has been pasted from the clipboard.
NodePointed | Raised when the mouse pointer hovers over a node.
NodeSelected | Raised when a node is selected, either programmatically or by the user.
NodeSelecting | Raised when the user tries to select a node, this event lets you cancel the operation.
NodeStartModifying | A validation event raised when the user starts modifying a node.
NodeTextEdited | Raised when the user edits the text of a node.
NodeTextEditing | A validation event that lets you approve or reject changes made to the text of a node.
OriginAnchorChanged | Raised when the OriginAnchor property value of a link has changed.
QueryAlignTarget | Raised to validate a node as target for alignment guides when AutoAlignNodes is enabled.
Repaint | Raised when the diagram views should be repainted.
RequestCacheReset | Raised when an object within the diagram requests a reset of the cached bitmap.
RequestClipboard | Raised when an object within the diagram requests an operation with the clipboard.
RequestTimer | Raised when an object within the diagram needs to start or stop a timer.
SelectionChanged | Raised when an item is added to or removed from the selection
SelectionModified | Raised when the user moves multiple selected items.
SelectionModifying | Raised while the user is moving multiple selected items, this event lets you cancel the modification.
SerializeTag | Raised when the Tag of a diagram item must be serialized into an XML document.
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape.
ShapeModified | Raised when the user modifies the shape of a ShapeNode by moving one of the control points corresponding to shape formula parameters.
TableColumnResized | Raised when the user finishes resizing a column in a table.
TableColumnResizing | Raised when the user resizes a column in a table interactively.
TableRowResized | Raised when the user finishes resizing a row in a table.
TableRowResizing | Raised when the user resizes a row in a table interactively.
TableSectionCollapsed | Raised when the user collapses the rows of a table’s section by clicking the [-] button in the section's header row.
TableSectionExpanded | Raised when the user expands the rows of a table's section by clicking the [+] button in the section’s header row.
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node.
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node.
TreeItemTextEditing | A validation event that lets you approve or reject changes made to the text of a TreeViewNode's item.
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point.
ViewRemoved | Raised when a DiagramView is detached from this diagram.

See Also

DiagramBase Class


MindFusion.Diagramming.DiagramBase Constructor

DiagramBase Constructor
[image]

Initializes a new instance of the DiagramBase class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DiagramBase ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

DiagramBase Class


MindFusion.Diagramming.DiagramBase Methods

DiagramBase Methods
[image]

Public Methods

Name | Description
TrackMouseHover | Specifies whether the diagram view should track mouse hover events.

Protected Methods

Name | Description
OnActionRecorded | Raises the ActionRecorded event.
OnActionRecording | Raises the ActionRecording event.
OnActionRedone | Raises the ActionRedone event.
OnActionUndone | Raises the ActionUndone event.
OnBeginLoad | Raises the BeginLoad event.
OnBoundsChanged | Raises the BoundsChanged event.
OnCellClicked | Raises the CellClicked event.
OnCellDoubleClicked | Raises the CellDoubleClicked event.
OnCellTextEdited | Raises the CellTextEdited event.
OnCellTextEditing | Raises the CellTextEditing event to validate entering inplace edit mode.
OnClicked | Raises the Clicked event.
OnContainerChildAdded | Raises the ContainerChildAdded event.
OnContainerChildRemoved | Raises the ContainerChildRemoved event.
OnContainerFolded | Raises the ContainerFolded event.
OnContainerUnfolded | Raises the ContainerUnfolded event.
OnContentVisibilityChanged | Raises the ContentVisibilityChanged event.
OnDefaultShapeChanged | Raises the DefaultShapeChanged event.
OnDeserializeTag | Raises the DeserializeTag event.
OnDestinationAnchorChanged | Raises the DestinationAnchorChanged event.
OnDirtyChanged | Raises the DirtyChanged event.
OnDoubleClicked | Raises the DoubleClicked event.
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event.
OnDrawAnchorPoint | Raises the DrawAnchorPoint event.
OnDrawBackground | Raises the DrawBackground event.
OnDrawCell | Raises the DrawCell event.
OnDrawForeground | Raises the DrawForeground event.
OnDrawLink | Raises the DrawLink event.
OnDrawNode | Raises the DrawNode event.
OnEndLoad | Raises the EndLoad event.
OnExpandButtonClicked | Raises the ExpandButtonClicked event.
OnGroupDestroyed | Raises the GroupDestroyed event.
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event.
OnInitializeLink | Raises the InitializeLink event.
OnInitializeNode | Raises the InitializeNode event.
OnItemAdded | Raises the ItemAdded event.
OnItemRemoved | Raises the ItemRemoved event.
OnLayerVisibilityChanged | Raises the LayerVisibilityChanged event.
OnLinkActivated | Raises the LinkActivated event.
OnLinkClicked | Raises the LinkClicked event.
OnLinkCreateCancelled | Raises the LinkCreateCancelled event.
OnLinkCreated | Raises the LinkCreated event.
OnLinkCreating | Raises the LinkCreating event.
OnLinkDeactivated | Raises the LinkDeactivated event.
OnLinkDeleted | Raises the LinkDeleted event.
OnLinkDeleting | Raises the LinkDeleting event.
OnLinkDeselected | Raises the LinkDeselected event.
OnLinkDoubleClicked | Raises the LinkDoubleClicked event.
OnLinkModified | Raises the LinkModified event.
OnLinkModifyCancelled | Raises the LinkModifyCancelled event.
OnLinkModifying | Raises the LinkModifying event.
OnLinkPasted | Raises the LinkPasted event.
OnLinkPointed | Raises the LinkPointed event.
OnLinkRouted | Raises the LinkRouted event.
OnLinkSelected | Raises the LinkSelected event.
OnLinkSelecting | Raises the LinkSelecting event.
OnLinkSplit | Raises the LinkSplit event.
OnLinkStartModifying | Raises the LinkStartModifying event.
OnLinkTextEdited | Raises the LinkTextEdited event.
OnLinkTextEditing | Raises the LinkTextEditing event to validate entering inplace edit mode.
OnMeasureUnitChanged | Raises the MeasureUnitChanged event.
OnNodeActivated | Raises the NodeActivated event.
OnNodeClicked | Raises the NodeClicked event.
OnNodeCreateCancelled | Raises the NodeCreateCancelled event.
OnNodeCreated | Raises the NodeCreated event.
OnNodeCreating | Raises the NodeCreating event.
OnNodeDeactivated | Raises the NodeDeactivated event.
OnNodeDeleted | Raises the NodeDeleted event.
OnNodeDeleting | Raises the NodeDeleting event.
OnNodeDeselected | Raises the NodeDeselected event.
OnNodeDoubleClicked | Raises the NodeDoubleClicked event.
OnNodeModified | Raises the NodeModified event.
OnNodeModifyCancelled | Raises the NodeModifyCancelled event.
OnNodeModifying | Raises the NodeModifying event.
OnNodePasted | Raises the NodePasted event.
OnNodePointed | Raises the NodePointed event.
OnNodeSelected | Raises the NodeSelected event.
OnNodeSelecting | Raises the NodeSelecting event.
OnNodeStartModifying | Raises the NodeStartModifying event.
OnNodeTextEdited | Raises the NodeTextEdited event.
OnNodeTextEditing | Raises the NodeTextEditing event to validate entering inplace edit mode.
OnOriginAnchorChanged | Raises the OriginAnchorChanged event.
OnQueryAlignTarget | Raises the QueryAlignTarget event.
OnRepaint | Raises the Repaint event.
OnRequestClipboard | Raises the RequestClipboard event.
OnRequestTimer | Raises the RequestTimer event.
OnSelectionChanged | Raises the SelectionChanged event.
OnSelectionModified | Raises the SelectionModified event.
OnSelectionModifying | Raises the SelectionModifying event.
OnSerializeTag | Raises the SerializeTag event.
OnSetSelfLoopShape | Raises the SetSelfLoopShape event.
OnShapeModified | Raises the ShapeModified event.
OnTableColumnResized | Raises the TableColumnResized event.
OnTableColumnResizing | Raises the TableColumnResizing event.
OnTableRowResized | Raises the TableRowResized event.
OnTableRowResizing | Raises the TableRowResizing event.
OnTableSectionCollapsed | Raises the TableSectionCollapsed event.
OnTableSectionExpanded | Raises the TableSectionExpanded event.
OnTreeCollapsed | Raises the TreeCollapsed event.
OnTreeExpanded | Raises the TreeExpanded event.
OnTreeItemTextEditing | Raises the TreeItemTextEditing event.
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event.
OnViewRemoved | Raises the ViewRemoved event.

See Also

DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnActionRecorded Method

DiagramBase.OnActionRecorded Method
[image]

Raises the ActionRecorded event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnActionRecorded (
UndoEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnActionRecorded( _
e As UndoEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnActionRecording Method

DiagramBase.OnActionRecording Method
[image]

Raises the ActionRecording event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnActionRecording (
UndoValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnActionRecording( _
e As UndoValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnActionRedone Method

DiagramBase.OnActionRedone Method
[image]

Raises the ActionRedone event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnActionRedone (
UndoEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnActionRedone( _
e As UndoEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnActionUndone Method

DiagramBase.OnActionUndone Method
[image]

Raises the ActionUndone event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnActionUndone (
UndoEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnActionUndone( _
e As UndoEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnBeginLoad Method

DiagramBase.OnBeginLoad Method
[image]

Raises the BeginLoad event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnBeginLoad (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnBeginLoad( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnBoundsChanged Method

DiagramBase.OnBoundsChanged Method
[image]

Raises the BoundsChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnBoundsChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnBoundsChanged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnCellClicked Method

DiagramBase.OnCellClicked Method
[image]

Raises the CellClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnCellClicked (
CellEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCellClicked( _
e As CellEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnCellDoubleClicked Method

DiagramBase.OnCellDoubleClicked Method
[image]

Raises the CellDoubleClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnCellDoubleClicked (
CellEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCellDoubleClicked( _
e As CellEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnCellTextEdited Method

DiagramBase.OnCellTextEdited Method
[image]

Raises the CellTextEdited event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnCellTextEdited (
EditCellTextEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCellTextEdited( _
e As EditCellTextEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnCellTextEditing Method

DiagramBase.OnCellTextEditing Method
[image]

Raises the CellTextEditing event to validate entering inplace edit mode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnCellTextEditing (
CellValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCellTextEditing( _
e As CellValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnClicked Method

DiagramBase.OnClicked Method
[image]

Raises the Clicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnClicked (
DiagramEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnClicked( _
e As DiagramEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnContainerChildAdded Method

DiagramBase.OnContainerChildAdded Method
[image]

Raises the ContainerChildAdded event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnContainerChildAdded (
ContainerChildEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnContainerChildAdded( _
e As ContainerChildEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnContainerChildRemoved Method

DiagramBase.OnContainerChildRemoved Method
[image]

Raises the ContainerChildRemoved event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnContainerChildRemoved (
ContainerChildEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnContainerChildRemoved( _
e As ContainerChildEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnContainerFolded Method

DiagramBase.OnContainerFolded Method
[image]

Raises the ContainerFolded event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnContainerFolded (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnContainerFolded( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnContainerUnfolded Method

DiagramBase.OnContainerUnfolded Method
[image]

Raises the ContainerUnfolded event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnContainerUnfolded (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnContainerUnfolded( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnContentVisibilityChanged Method

DiagramBase.OnContentVisibilityChanged Method
[image]

Raises the ContentVisibilityChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnContentVisibilityChanged (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnContentVisibilityChanged( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnDefaultShapeChanged Method

DiagramBase.OnDefaultShapeChanged Method
[image]

Raises the DefaultShapeChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDefaultShapeChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDefaultShapeChanged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnDeserializeTag Method

DiagramBase.OnDeserializeTag Method
[image]

Raises the DeserializeTag event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDeserializeTag (
SerializeTagEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDeserializeTag( _
e As SerializeTagEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnDestinationAnchorChanged Method

DiagramBase.OnDestinationAnchorChanged Method
[image]

Raises the DestinationAnchorChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDestinationAnchorChanged (
AnchorPointEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDestinationAnchorChanged( _
e As AnchorPointEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnDirtyChanged Method

DiagramBase.OnDirtyChanged Method
[image]

Raises the DirtyChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDirtyChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDirtyChanged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnDoubleClicked Method

DiagramBase.OnDoubleClicked Method
[image]

Raises the DoubleClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDoubleClicked (
DiagramEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDoubleClicked( _
e As DiagramEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnDrawAdjustmentHandles Method

DiagramBase.OnDrawAdjustmentHandles Method
[image]

Raises the DrawAdjustmentHandles event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDrawAdjustmentHandles (
DrawItemEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrawAdjustmentHandles( _
e As DrawItemEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnDrawAnchorPoint Method

DiagramBase.OnDrawAnchorPoint Method
[image]

Raises the DrawAnchorPoint event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDrawAnchorPoint (
DrawAnchorPointEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrawAnchorPoint( _
e As DrawAnchorPointEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnDrawBackground Method

DiagramBase.OnDrawBackground Method
[image]

Raises the DrawBackground event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDrawBackground (
DiagramEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrawBackground( _
e As DiagramEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnDrawCell Method

DiagramBase.OnDrawCell Method
[image]

Raises the DrawCell event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDrawCell (
DrawCellEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrawCell( _
e As DrawCellEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnDrawForeground Method

DiagramBase.OnDrawForeground Method
[image]

Raises the DrawForeground event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDrawForeground (
DiagramEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrawForeground( _
e As DiagramEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnDrawLink Method

DiagramBase.OnDrawLink Method
[image]

Raises the DrawLink event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDrawLink (
DrawLinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrawLink( _
e As DrawLinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnDrawNode Method

DiagramBase.OnDrawNode Method
[image]

Raises the DrawNode event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDrawNode (
DrawNodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrawNode( _
e As DrawNodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnEndLoad Method

DiagramBase.OnEndLoad Method
[image]

Raises the EndLoad event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnEndLoad (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnEndLoad( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnExpandButtonClicked Method

DiagramBase.OnExpandButtonClicked Method
[image]

Raises the ExpandButtonClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnExpandButtonClicked (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnExpandButtonClicked( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnGroupDestroyed Method

DiagramBase.OnGroupDestroyed Method
[image]

Raises the GroupDestroyed event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnGroupDestroyed (
GroupEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnGroupDestroyed( _
e As GroupEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnHitTestAdjustmentHandles Method

DiagramBase.OnHitTestAdjustmentHandles Method
[image]

Raises the HitTestAdjustmentHandles event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnHitTestAdjustmentHandles (
HitTestEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnHitTestAdjustmentHandles( _
e As HitTestEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnInitializeLink Method

DiagramBase.OnInitializeLink Method
[image]

Raises the InitializeLink event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnInitializeLink (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnInitializeLink( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnInitializeNode Method

DiagramBase.OnInitializeNode Method
[image]

Raises the InitializeNode event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnInitializeNode (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnInitializeNode( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnItemAdded Method

DiagramBase.OnItemAdded Method
[image]

Raises the ItemAdded event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnItemAdded (
ItemEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemAdded( _
e As ItemEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnItemRemoved Method

DiagramBase.OnItemRemoved Method
[image]

Raises the ItemRemoved event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnItemRemoved (
ItemEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemRemoved( _
e As ItemEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLayerVisibilityChanged Method

DiagramBase.OnLayerVisibilityChanged Method
[image]

Raises the LayerVisibilityChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLayerVisibilityChanged (
LayerEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLayerVisibilityChanged( _
e As LayerEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkActivated Method

DiagramBase.OnLinkActivated Method
[image]

Raises the LinkActivated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkActivated (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkActivated( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkClicked Method

DiagramBase.OnLinkClicked Method
[image]

Raises the LinkClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkClicked (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkClicked( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkCreateCancelled Method

DiagramBase.OnLinkCreateCancelled Method
[image]

Raises the LinkCreateCancelled event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkCreateCancelled (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkCreateCancelled( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkCreated Method

DiagramBase.OnLinkCreated Method
[image]

Raises the LinkCreated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkCreated (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkCreated( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkCreating Method

DiagramBase.OnLinkCreating Method
[image]

Raises the LinkCreating event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkCreating (
LinkValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkCreating( _
e As LinkValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkDeactivated Method

DiagramBase.OnLinkDeactivated Method
[image]

Raises the LinkDeactivated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkDeactivated (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkDeactivated( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkDeleted Method

DiagramBase.OnLinkDeleted Method
[image]

Raises the LinkDeleted event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkDeleted (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkDeleted( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkDeleting Method

DiagramBase.OnLinkDeleting Method
[image]

Raises the LinkDeleting event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkDeleting (
LinkValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkDeleting( _
e As LinkValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkDeselected Method

DiagramBase.OnLinkDeselected Method
[image]

Raises the LinkDeselected event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkDeselected (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkDeselected( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkDoubleClicked Method

DiagramBase.OnLinkDoubleClicked Method
[image]

Raises the LinkDoubleClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkDoubleClicked (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkDoubleClicked( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkModified Method

DiagramBase.OnLinkModified Method
[image]

Raises the LinkModified event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkModified (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkModified( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkModifyCancelled Method

DiagramBase.OnLinkModifyCancelled Method
[image]

Raises the LinkModifyCancelled event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkModifyCancelled (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkModifyCancelled( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkModifying Method

DiagramBase.OnLinkModifying Method
[image]

Raises the LinkModifying event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkModifying (
LinkValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkModifying( _
e As LinkValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkPasted Method

DiagramBase.OnLinkPasted Method
[image]

Raises the LinkPasted event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkPasted (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkPasted( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkPointed Method

DiagramBase.OnLinkPointed Method
[image]

Raises the LinkPointed event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkPointed (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkPointed( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkRouted Method

DiagramBase.OnLinkRouted Method
[image]

Raises the LinkRouted event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkRouted (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkRouted( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkSelected Method

DiagramBase.OnLinkSelected Method
[image]

Raises the LinkSelected event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkSelected (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkSelected( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkSelecting Method

DiagramBase.OnLinkSelecting Method
[image]

Raises the LinkSelecting event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkSelecting (
LinkValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkSelecting( _
e As LinkValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkSplit Method

DiagramBase.OnLinkSplit Method
[image]

Raises the LinkSplit event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkSplit (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkSplit( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkStartModifying Method

DiagramBase.OnLinkStartModifying Method
[image]

Raises the LinkStartModifying event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkStartModifying (
LinkValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkStartModifying( _
e As LinkValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkTextEdited Method

DiagramBase.OnLinkTextEdited Method
[image]

Raises the LinkTextEdited event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkTextEdited (
EditLinkTextEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkTextEdited( _
e As EditLinkTextEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkTextEditing Method

DiagramBase.OnLinkTextEditing Method
[image]

Raises the LinkTextEditing event to validate entering inplace edit mode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkTextEditing (
LinkValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkTextEditing( _
e As LinkValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnMeasureUnitChanged Method

DiagramBase.OnMeasureUnitChanged Method
[image]

Raises the MeasureUnitChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnMeasureUnitChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMeasureUnitChanged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeActivated Method

DiagramBase.OnNodeActivated Method
[image]

Raises the NodeActivated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeActivated (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeActivated( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeClicked Method

DiagramBase.OnNodeClicked Method
[image]

Raises the NodeClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeClicked (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeClicked( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeCreateCancelled Method

DiagramBase.OnNodeCreateCancelled Method
[image]

Raises the NodeCreateCancelled event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeCreateCancelled (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeCreateCancelled( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeCreated Method

DiagramBase.OnNodeCreated Method
[image]

Raises the NodeCreated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeCreated (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeCreated( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeCreating Method

DiagramBase.OnNodeCreating Method
[image]

Raises the NodeCreating event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeCreating (
NodeValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeCreating( _
e As NodeValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeDeactivated Method

DiagramBase.OnNodeDeactivated Method
[image]

Raises the NodeDeactivated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeDeactivated (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeDeactivated( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeDeleted Method

DiagramBase.OnNodeDeleted Method
[image]

Raises the NodeDeleted event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeDeleted (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeDeleted( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeDeleting Method

DiagramBase.OnNodeDeleting Method
[image]

Raises the NodeDeleting event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeDeleting (
NodeValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeDeleting( _
e As NodeValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeDeselected Method

DiagramBase.OnNodeDeselected Method
[image]

Raises the NodeDeselected event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeDeselected (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeDeselected( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeDoubleClicked Method

DiagramBase.OnNodeDoubleClicked Method
[image]

Raises the NodeDoubleClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeDoubleClicked (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeDoubleClicked( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeModified Method

DiagramBase.OnNodeModified Method
[image]

Raises the NodeModified event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeModified (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeModified( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeModifyCancelled Method

DiagramBase.OnNodeModifyCancelled Method
[image]

Raises the NodeModifyCancelled event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeModifyCancelled (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeModifyCancelled( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeModifying Method

DiagramBase.OnNodeModifying Method
[image]

Raises the NodeModifying event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeModifying (
NodeValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeModifying( _
e As NodeValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodePasted Method

DiagramBase.OnNodePasted Method
[image]

Raises the NodePasted event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodePasted (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodePasted( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodePointed Method

DiagramBase.OnNodePointed Method
[image]

Raises the NodePointed event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodePointed (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodePointed( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeSelected Method

DiagramBase.OnNodeSelected Method
[image]

Raises the NodeSelected event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeSelected (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeSelected( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeSelecting Method

DiagramBase.OnNodeSelecting Method
[image]

Raises the NodeSelecting event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeSelecting (
NodeValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeSelecting( _
e As NodeValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeStartModifying Method

DiagramBase.OnNodeStartModifying Method
[image]

Raises the NodeStartModifying event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeStartModifying (
NodeValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeStartModifying( _
e As NodeValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeTextEdited Method

DiagramBase.OnNodeTextEdited Method
[image]

Raises the NodeTextEdited event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeTextEdited (
EditNodeTextEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeTextEdited( _
e As EditNodeTextEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeTextEditing Method

DiagramBase.OnNodeTextEditing Method
[image]

Raises the NodeTextEditing event to validate entering inplace edit mode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeTextEditing (
NodeValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeTextEditing( _
e As NodeValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnOriginAnchorChanged Method

DiagramBase.OnOriginAnchorChanged Method
[image]

Raises the OriginAnchorChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnOriginAnchorChanged (
AnchorPointEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnOriginAnchorChanged( _
e As AnchorPointEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnQueryAlignTarget Method

DiagramBase.OnQueryAlignTarget Method
[image]

Raises the QueryAlignTarget event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnQueryAlignTarget (
NodeValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnQueryAlignTarget( _
e As NodeValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnRepaint Method

DiagramBase.OnRepaint Method
[image]

Raises the Repaint event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnRepaint (
RepaintEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRepaint( _
e As RepaintEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnRequestClipboard Method

DiagramBase.OnRequestClipboard Method
[image]

Raises the RequestClipboard event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnRequestClipboard (
ClipboardEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRequestClipboard( _
e As ClipboardEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnRequestTimer Method

DiagramBase.OnRequestTimer Method
[image]

Raises the RequestTimer event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnRequestTimer (
TimerEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRequestTimer( _
e As TimerEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnSelectionChanged Method

DiagramBase.OnSelectionChanged Method
[image]

Raises the SelectionChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnSelectionChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSelectionChanged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnSelectionModified Method

DiagramBase.OnSelectionModified Method
[image]

Raises the SelectionModified event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnSelectionModified (
SelectionEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSelectionModified( _
e As SelectionEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnSelectionModifying Method

DiagramBase.OnSelectionModifying Method
[image]

Raises the SelectionModifying event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnSelectionModifying (
SelectionValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSelectionModifying( _
e As SelectionValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnSerializeTag Method

DiagramBase.OnSerializeTag Method
[image]

Raises the SerializeTag event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnSerializeTag (
SerializeTagEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSerializeTag( _
e As SerializeTagEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnSetSelfLoopShape Method

DiagramBase.OnSetSelfLoopShape Method
[image]

Raises the SetSelfLoopShape event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnSetSelfLoopShape (
LinkShapeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSetSelfLoopShape( _
e As LinkShapeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnShapeModified Method

DiagramBase.OnShapeModified Method
[image]

Raises the ShapeModified event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnShapeModified (
ControlPointEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnShapeModified( _
e As ControlPointEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnTableColumnResized Method

DiagramBase.OnTableColumnResized Method
[image]

Raises the TableColumnResized event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnTableColumnResized (
CellEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTableColumnResized( _
e As CellEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnTableColumnResizing Method

DiagramBase.OnTableColumnResizing Method
[image]

Raises the TableColumnResizing event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnTableColumnResizing (
CellValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTableColumnResizing( _
e As CellValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnTableRowResized Method

DiagramBase.OnTableRowResized Method
[image]

Raises the TableRowResized event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnTableRowResized (
CellEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTableRowResized( _
e As CellEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnTableRowResizing Method

DiagramBase.OnTableRowResizing Method
[image]

Raises the TableRowResizing event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnTableRowResizing (
CellValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTableRowResizing( _
e As CellValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnTableSectionCollapsed Method

DiagramBase.OnTableSectionCollapsed Method
[image]

Raises the TableSectionCollapsed event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnTableSectionCollapsed (
RowEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTableSectionCollapsed( _
e As RowEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnTableSectionExpanded Method

DiagramBase.OnTableSectionExpanded Method
[image]

Raises the TableSectionExpanded event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnTableSectionExpanded (
RowEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTableSectionExpanded( _
e As RowEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnTreeCollapsed Method

DiagramBase.OnTreeCollapsed Method
[image]

Raises the TreeCollapsed event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnTreeCollapsed (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTreeCollapsed( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnTreeExpanded Method

DiagramBase.OnTreeExpanded Method
[image]

Raises the TreeExpanded event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnTreeExpanded (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTreeExpanded( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnTreeItemTextEditing Method

DiagramBase.OnTreeItemTextEditing Method
[image]

Raises the TreeItemTextEditing event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnTreeItemTextEditing (
TreeItemValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTreeItemTextEditing( _
e As TreeItemValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnValidateAnchorPoint Method

DiagramBase.OnValidateAnchorPoint Method
[image]

Raises the ValidateAnchorPoint event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnValidateAnchorPoint (
LinkValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnValidateAnchorPoint( _
e As LinkValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnViewRemoved Method

DiagramBase.OnViewRemoved Method
[image]

Raises the ViewRemoved event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnViewRemoved (
CancelEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnViewRemoved( _
e As CancelEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.TrackMouseHover Method

DiagramBase.TrackMouseHover Method
[image]

Specifies whether the diagram view should track mouse hover events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool TrackMouseHover ()

Visual Basic [image] Copy Code

Public Overridable Function TrackMouseHover () As Boolean

Return Value

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase Events

DiagramBase Events
[image]

Public Events

Name | Description
ActionRecorded | Raised when an action is recorded in the undo buffer.
ActionRecording | A validation event raised before an action is recorded in the undo buffer.
ActionRedone | Raised when an action is redone.
ActionUndone | Raised when an action is undone.
ActiveLayerChanged | Raised when the diagram's active layer has changed.
BeginLoad | Raised when the component starts loading diagram data from a file or memory stream.
BoundsChanged | Raised when the Bounds property value has changed.
CellClicked | Raised when the user clicks a table’s cell.
CellDoubleClicked | Raised when the user double-clicks a table’s cell.
CellTextEdited | Raised when the user edits the text of a table’s cell.
CellTextEditing | A validation event that lets you approve or reject changes made to the text of a table’s cell.
Clicked | Raised when the user clicks the diagram at a point where no items are located.
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user.
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user.
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area.
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area.
ContentVisibilityChanged | Raised when the visibility of container's content changes.
DefaultShapeChanged | Raised when the DefaultShape property value has changed.
DeserializeTag | Raised when the Tag of a diagram item must be deserialized from XML format.
DestinationAnchorChanged | Raised when the DestinationAnchor property value of a link has changed.
DirtyChanged | Raised when the Dirty property value has changed.
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located.
DrawAdjustmentHandles | Raised when item’s adjustment handles must be custom drawn.
DrawAnchorPoint | Raised when an anchor point must be custom drawn.
DrawBackground | Raised to let you custom draw the diagram background.
DrawCell | Raised when a table’s cell must be custom drawn.
DrawForeground | Raised to let you custom draw the diagram foreground.
DrawLink | Raised when a diagram link must be custom drawn.
DrawNode | Raised when a diagram node must be custom drawn.
EndLoad | Raised when the component ends loading diagram data from a file or memory stream.
ExpandButtonClicked | Raised when the user clicks the [±] button of an Expandable node.
GroupDestroyed | Raised when a Group object is destroyed.
HitTestAdjustmentHandles | Raised when custom hit testing of item’s adjustment handles must be performed.
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created.
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created.
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively.
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively.
LayerVisibilityChanged | Raised when the visibility of a Layer changes.
LinkActivated | Raised when a link becomes the ActiveItem.
LinkClicked | Raised when the user clicks a link.
LinkCreateCancelled | Raised when the user cancels link creation.
LinkCreated | Raised when the user draws a new link.
LinkCreating | A validation event raised while the user is drawing a new link.
LinkDeactivated | Raised when a link is no longer the ActiveItem.
LinkDeleted | Raised when a link is deleted, either programmatically or by the user.
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation.
LinkDeselected | Raised when a link is deselected, either programmatically or by the user.
LinkDoubleClicked | Raised when the user double-clicks a link.
LinkModified | Raised when the user moves any control point of a link.
LinkModifyCancelled | Raised when the user cancels move or resize operation being done on a link.
LinkModifying | A validation event raised while the user is modifying a link.
LinkPasted | Raised when a link has been pasted from the clipboard.
LinkPointed | Raised when the mouse pointer hovers over a link.
LinkRouted | Raised when a link is routed by the auto-routing algorithm.
LinkSelected | Raised when a link is selected, either programmatically or by the user.
LinkSelecting | Raised when the user tries to select a link, this event lets you cancel the operation.
LinkSplit | Raised when the user splits a link interactively.
LinkStartModifying | A validation event raised when the user starts modifying a link.
LinkTextEdited | Raised when the user edits the text of a link.
LinkTextEditing | A validation event that lets you approve or reject changes made to the text of a link.
MeasureUnitChanged | Raised when the MeasureUnit property value has changed.
NodeActivated | Raised when a node becomes the ActiveItem.
NodeClicked | Raised when the user clicks a node.
NodeCreateCancelled | Raised when the user cancels node creation.
NodeCreated | Raised when the user draws a new node.
NodeCreating | A validation event raised while the user is drawing a new node.
NodeDeactivated | Raised when a node is no longer the ActiveItem.
NodeDeleted | Raised when a node is deleted, either programmatically or by the user.
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation.
NodeDeselected | Raised when a node is deselected, either programmatically or by the user.
NodeDoubleClicked | Raised when the user double-clicks a node.
NodeModified | Raised when the user moves or resizes a node.
NodeModifyCancelled | Raised when the user cancels move or resize operation being done on a node.
NodeModifying | A validation event raised while the user is moving or resizing a node.
NodePasted | Raised when a node has been pasted from the clipboard.
NodePointed | Raised when the mouse pointer hovers over a node.
NodeSelected | Raised when a node is selected, either programmatically or by the user.
NodeSelecting | Raised when the user tries to select a node, this event lets you cancel the operation.
NodeStartModifying | A validation event raised when the user starts modifying a node.
NodeTextEdited | Raised when the user edits the text of a node.
NodeTextEditing | A validation event that lets you approve or reject changes made to the text of a node.
OriginAnchorChanged | Raised when the OriginAnchor property value of a link has changed.
QueryAlignTarget | Raised to validate a node as target for alignment guides when AutoAlignNodes is enabled.
Repaint | Raised when the diagram views should be repainted.
RequestCacheReset | Raised when an object within the diagram requests a reset of the cached bitmap.
RequestClipboard | Raised when an object within the diagram requests an operation with the clipboard.
RequestTimer | Raised when an object within the diagram needs to start or stop a timer.
SelectionChanged | Raised when an item is added to or removed from the selection
SelectionModified | Raised when the user moves multiple selected items.
SelectionModifying | Raised while the user is moving multiple selected items, this event lets you cancel the modification.
SerializeTag | Raised when the Tag of a diagram item must be serialized into an XML document.
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape.
ShapeModified | Raised when the user modifies the shape of a ShapeNode by moving one of the control points corresponding to shape formula parameters.
TableColumnResized | Raised when the user finishes resizing a column in a table.
TableColumnResizing | Raised when the user resizes a column in a table interactively.
TableRowResized | Raised when the user finishes resizing a row in a table.
TableRowResizing | Raised when the user resizes a row in a table interactively.
TableSectionCollapsed | Raised when the user collapses the rows of a table’s section by clicking the [-] button in the section's header row.
TableSectionExpanded | Raised when the user expands the rows of a table's section by clicking the [+] button in the section’s header row.
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node.
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node.
TreeItemTextEditing | A validation event that lets you approve or reject changes made to the text of a TreeViewNode's item.
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point.
ViewRemoved | Raised when a DiagramView is detached from this diagram.

See Also

DiagramBase Class


MindFusion.Diagramming.DiagramDocument Class

DiagramDocument Class
[image]

Represents a collection of diagram pages.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramDocument : DiagramBase

Visual Basic [image] Copy Code

Public Class DiagramDocument
Inherits DiagramBase

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.DiagramBase
MindFusion.Diagramming.DiagramDocument

See Also

DiagramDocument Members


MindFusion.Diagramming.DiagramDocument Members

DiagramDocument Members
Constructors Properties Methods Events
[image]

Represents a collection of diagram pages.

The following tables list the members exposed by the DiagramDocument type.

Public Constructors

Name | Description
DiagramDocument | Initializes a new instance of the DiagramDocument class.

Public Properties

Name | Description
Dirty | Gets a value indicating whether the document has changed since the last save.
Pages | Gets a list of the diagram pages contained in this document.

Public Methods

Name | Description
LoadFromFile | Loads the document from the specified file.
LoadFromStream | Loads the document from the specified stream.
LoadFromString | Loads the document from the specified string.
LoadFromXml | Overloaded. Loads the document from an XML document or file.
SaveToFile | Overloaded. Saves the document to a binary file.
SaveToStream | Overloaded. Saves the document into a stream.
SaveToString | Overloaded. Saves the document as an ASCII string.
SaveToXml | Overloaded. Saves the document to an XML document or file.
TrackMouseHover | Specifies whether the diagram view should track mouse hover events. (Inherited from DiagramBase.)

Protected Methods

Name | Description
OnActionRecorded | Raises the ActionRecorded event. (Inherited from DiagramBase.)
OnActionRecording | Raises the ActionRecording event. (Inherited from DiagramBase.)
OnActionRedone | Raises the ActionRedone event. (Inherited from DiagramBase.)
OnActionUndone | Raises the ActionUndone event. (Inherited from DiagramBase.)
OnBeginLoad | Raises the BeginLoad event. (Inherited from DiagramBase.)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramBase.)
OnCellClicked | Raises the CellClicked event. (Inherited from DiagramBase.)
OnCellDoubleClicked | Raises the CellDoubleClicked event. (Inherited from DiagramBase.)
OnCellTextEdited | Raises the CellTextEdited event. (Inherited from DiagramBase.)
OnCellTextEditing | Raises the CellTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnClicked | Raises the Clicked event. (Inherited from DiagramBase.)
OnContainerChildAdded | Raises the ContainerChildAdded event. (Inherited from DiagramBase.)
OnContainerChildRemoved | Raises the ContainerChildRemoved event. (Inherited from DiagramBase.)
OnContainerFolded | Raises the ContainerFolded event. (Inherited from DiagramBase.)
OnContainerUnfolded | Raises the ContainerUnfolded event. (Inherited from DiagramBase.)
OnContentVisibilityChanged | Raises the ContentVisibilityChanged event. (Inherited from DiagramBase.)
OnDefaultShapeChanged | Raises the DefaultShapeChanged event. (Inherited from DiagramBase.)
OnDeserializeTag | Raises the DeserializeTag event. (Inherited from DiagramBase.)
OnDestinationAnchorChanged | Raises the DestinationAnchorChanged event. (Inherited from DiagramBase.)
OnDirtyChanged | Raises the DirtyChanged event. (Inherited from DiagramBase.)
OnDoubleClicked | Raises the DoubleClicked event. (Inherited from DiagramBase.)
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event. (Inherited from DiagramBase.)
OnDrawAnchorPoint | Raises the DrawAnchorPoint event. (Inherited from DiagramBase.)
OnDrawBackground | Raises the DrawBackground event. (Inherited from DiagramBase.)
OnDrawCell | Raises the DrawCell event. (Inherited from DiagramBase.)
OnDrawForeground | Raises the DrawForeground event. (Inherited from DiagramBase.)
OnDrawLink | Raises the DrawLink event. (Inherited from DiagramBase.)
OnDrawNode | Raises the DrawNode event. (Inherited from DiagramBase.)
OnEndLoad | Raises the EndLoad event. (Inherited from DiagramBase.)
OnExpandButtonClicked | Raises the ExpandButtonClicked event. (Inherited from DiagramBase.)
OnGroupDestroyed | Raises the GroupDestroyed event. (Inherited from DiagramBase.)
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event. (Inherited from DiagramBase.)
OnInitializeLink | Raises the InitializeLink event. (Inherited from DiagramBase.)
OnInitializeNode | Raises the InitializeNode event. (Inherited from DiagramBase.)
OnItemAdded | Raises the ItemAdded event. (Inherited from DiagramBase.)
OnItemRemoved | Raises the ItemRemoved event. (Inherited from DiagramBase.)
OnLayerVisibilityChanged | Raises the LayerVisibilityChanged event. (Inherited from DiagramBase.)
OnLinkActivated | Raises the LinkActivated event. (Inherited from DiagramBase.)
OnLinkClicked | Raises the LinkClicked event. (Inherited from DiagramBase.)
OnLinkCreateCancelled | Raises the LinkCreateCancelled event. (Inherited from DiagramBase.)
OnLinkCreated | Raises the LinkCreated event. (Inherited from DiagramBase.)
OnLinkCreating | Raises the LinkCreating event. (Inherited from DiagramBase.)
OnLinkDeactivated | Raises the LinkDeactivated event. (Inherited from DiagramBase.)
OnLinkDeleted | Raises the LinkDeleted event. (Inherited from DiagramBase.)
OnLinkDeleting | Raises the LinkDeleting event. (Inherited from DiagramBase.)
OnLinkDeselected | Raises the LinkDeselected event. (Inherited from DiagramBase.)
OnLinkDoubleClicked | Raises the LinkDoubleClicked event. (Inherited from DiagramBase.)
OnLinkModified | Raises the LinkModified event. (Inherited from DiagramBase.)
OnLinkModifyCancelled | Raises the LinkModifyCancelled event. (Inherited from DiagramBase.)
OnLinkModifying | Raises the LinkModifying event. (Inherited from DiagramBase.)
OnLinkPasted | Raises the LinkPasted event. (Inherited from DiagramBase.)
OnLinkPointed | Raises the LinkPointed event. (Inherited from DiagramBase.)
OnLinkRouted | Raises the LinkRouted event. (Inherited from DiagramBase.)
OnLinkSelected | Raises the LinkSelected event. (Inherited from DiagramBase.)
OnLinkSelecting | Raises the LinkSelecting event. (Inherited from DiagramBase.)
OnLinkSplit | Raises the LinkSplit event. (Inherited from DiagramBase.)
OnLinkStartModifying | Raises the LinkStartModifying event. (Inherited from DiagramBase.)
OnLinkTextEdited | Raises the LinkTextEdited event. (Inherited from DiagramBase.)
OnLinkTextEditing | Raises the LinkTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnMeasureUnitChanged | Raises the MeasureUnitChanged event. (Inherited from DiagramBase.)
OnNodeActivated | Raises the NodeActivated event. (Inherited from DiagramBase.)
OnNodeClicked | Raises the NodeClicked event. (Inherited from DiagramBase.)
OnNodeCreateCancelled | Raises the NodeCreateCancelled event. (Inherited from DiagramBase.)
OnNodeCreated | Raises the NodeCreated event. (Inherited from DiagramBase.)
OnNodeCreating | Raises the NodeCreating event. (Inherited from DiagramBase.)
OnNodeDeactivated | Raises the NodeDeactivated event. (Inherited from DiagramBase.)
OnNodeDeleted | Raises the NodeDeleted event. (Inherited from DiagramBase.)
OnNodeDeleting | Raises the NodeDeleting event. (Inherited from DiagramBase.)
OnNodeDeselected | Raises the NodeDeselected event. (Inherited from DiagramBase.)
OnNodeDoubleClicked | Raises the NodeDoubleClicked event. (Inherited from DiagramBase.)
OnNodeModified | Raises the NodeModified event. (Inherited from DiagramBase.)
OnNodeModifyCancelled | Raises the NodeModifyCancelled event. (Inherited from DiagramBase.)
OnNodeModifying | Raises the NodeModifying event. (Inherited from DiagramBase.)
OnNodePasted | Raises the NodePasted event. (Inherited from DiagramBase.)
OnNodePointed | Raises the NodePointed event. (Inherited from DiagramBase.)
OnNodeSelected | Raises the NodeSelected event. (Inherited from DiagramBase.)
OnNodeSelecting | Raises the NodeSelecting event. (Inherited from DiagramBase.)
OnNodeStartModifying | Raises the NodeStartModifying event. (Inherited from DiagramBase.)
OnNodeTextEdited | Raises the NodeTextEdited event. (Inherited from DiagramBase.)
OnNodeTextEditing | Raises the NodeTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnOriginAnchorChanged | Raises the OriginAnchorChanged event. (Inherited from DiagramBase.)
OnQueryAlignTarget | Raises the QueryAlignTarget event. (Inherited from DiagramBase.)
OnRepaint | Raises the Repaint event. (Inherited from DiagramBase.)
OnRequestClipboard | Raises the RequestClipboard event. (Inherited from DiagramBase.)
OnRequestTimer | Raises the RequestTimer event. (Inherited from DiagramBase.)
OnSelectionChanged | Raises the SelectionChanged event. (Inherited from DiagramBase.)
OnSelectionModified | Raises the SelectionModified event. (Inherited from DiagramBase.)
OnSelectionModifying | Raises the SelectionModifying event. (Inherited from DiagramBase.)
OnSerializeTag | Raises the SerializeTag event. (Inherited from DiagramBase.)
OnSetSelfLoopShape | Raises the SetSelfLoopShape event. (Inherited from DiagramBase.)
OnShapeModified | Raises the ShapeModified event. (Inherited from DiagramBase.)
OnTableColumnResized | Raises the TableColumnResized event. (Inherited from DiagramBase.)
OnTableColumnResizing | Raises the TableColumnResizing event. (Inherited from DiagramBase.)
OnTableRowResized | Raises the TableRowResized event. (Inherited from DiagramBase.)
OnTableRowResizing | Raises the TableRowResizing event. (Inherited from DiagramBase.)
OnTableSectionCollapsed | Raises the TableSectionCollapsed event. (Inherited from DiagramBase.)
OnTableSectionExpanded | Raises the TableSectionExpanded event. (Inherited from DiagramBase.)
OnTreeCollapsed | Raises the TreeCollapsed event. (Inherited from DiagramBase.)
OnTreeExpanded | Raises the TreeExpanded event. (Inherited from DiagramBase.)
OnTreeItemTextEditing | Raises the TreeItemTextEditing event. (Inherited from DiagramBase.)
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event. (Inherited from DiagramBase.)
OnViewRemoved | Raises the ViewRemoved event. (Inherited from DiagramBase.)

Public Events

Name | Description
ActionRecorded | Raised when an action is recorded in the undo buffer. (Inherited from DiagramBase.)
ActionRecording | A validation event raised before an action is recorded in the undo buffer. (Inherited from DiagramBase.)
ActionRedone | Raised when an action is redone. (Inherited from DiagramBase.)
ActionUndone | Raised when an action is undone. (Inherited from DiagramBase.)
ActiveLayerChanged | Raised when the diagram's active layer has changed. (Inherited from DiagramBase.)
BeginLoad | Raised when the component starts loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
BoundsChanged | Raised when the Bounds property value has changed. (Inherited from DiagramBase.)
CellClicked | Raised when the user clicks a table’s cell. (Inherited from DiagramBase.)
CellDoubleClicked | Raised when the user double-clicks a table’s cell. (Inherited from DiagramBase.)
CellTextEdited | Raised when the user edits the text of a table’s cell. (Inherited from DiagramBase.)
CellTextEditing | A validation event that lets you approve or reject changes made to the text of a table’s cell. (Inherited from DiagramBase.)
Clicked | Raised when the user clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area. (Inherited from DiagramBase.)
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area. (Inherited from DiagramBase.)
ContentVisibilityChanged | Raised when the visibility of container's content changes. (Inherited from DiagramBase.)
DefaultShapeChanged | Raised when the DefaultShape property value has changed. (Inherited from DiagramBase.)
DeserializeTag | Raised when the Tag of a diagram item must be deserialized from XML format. (Inherited from DiagramBase.)
DestinationAnchorChanged | Raised when the DestinationAnchor property value of a link has changed. (Inherited from DiagramBase.)
DirtyChanged | Raised when the Dirty property value has changed. (Inherited from DiagramBase.)
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
DrawAdjustmentHandles | Raised when item’s adjustment handles must be custom drawn. (Inherited from DiagramBase.)
DrawAnchorPoint | Raised when an anchor point must be custom drawn. (Inherited from DiagramBase.)
DrawBackground | Raised to let you custom draw the diagram background. (Inherited from DiagramBase.)
DrawCell | Raised when a table’s cell must be custom drawn. (Inherited from DiagramBase.)
DrawForeground | Raised to let you custom draw the diagram foreground. (Inherited from DiagramBase.)
DrawLink | Raised when a diagram link must be custom drawn. (Inherited from DiagramBase.)
DrawNode | Raised when a diagram node must be custom drawn. (Inherited from DiagramBase.)
EndLoad | Raised when the component ends loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
ExpandButtonClicked | Raised when the user clicks the [±] button of an Expandable node. (Inherited from DiagramBase.)
GroupDestroyed | Raised when a Group object is destroyed. (Inherited from DiagramBase.)
HitTestAdjustmentHandles | Raised when custom hit testing of item’s adjustment handles must be performed. (Inherited from DiagramBase.)
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created. (Inherited from DiagramBase.)
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created. (Inherited from DiagramBase.)
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
LayerVisibilityChanged | Raised when the visibility of a Layer changes. (Inherited from DiagramBase.)
LinkActivated | Raised when a link becomes the ActiveItem. (Inherited from DiagramBase.)
LinkClicked | Raised when the user clicks a link. (Inherited from DiagramBase.)
LinkCreateCancelled | Raised when the user cancels link creation. (Inherited from DiagramBase.)
LinkCreated | Raised when the user draws a new link. (Inherited from DiagramBase.)
LinkCreating | A validation event raised while the user is drawing a new link. (Inherited from DiagramBase.)
LinkDeactivated | Raised when a link is no longer the ActiveItem. (Inherited from DiagramBase.)
LinkDeleted | Raised when a link is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkDeselected | Raised when a link is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDoubleClicked | Raised when the user double-clicks a link. (Inherited from DiagramBase.)
LinkModified | Raised when the user moves any control point of a link. (Inherited from DiagramBase.)
LinkModifyCancelled | Raised when the user cancels move or resize operation being done on a link. (Inherited from DiagramBase.)
LinkModifying | A validation event raised while the user is modifying a link. (Inherited from DiagramBase.)
LinkPasted | Raised when a link has been pasted from the clipboard. (Inherited from DiagramBase.)
LinkPointed | Raised when the mouse pointer hovers over a link. (Inherited from DiagramBase.)
LinkRouted | Raised when a link is routed by the auto-routing algorithm. (Inherited from DiagramBase.)
LinkSelected | Raised when a link is selected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkSelecting | Raised when the user tries to select a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkSplit | Raised when the user splits a link interactively. (Inherited from DiagramBase.)
LinkStartModifying | A validation event raised when the user starts modifying a link. (Inherited from DiagramBase.)
LinkTextEdited | Raised when the user edits the text of a link. (Inherited from DiagramBase.)
LinkTextEditing | A validation event that lets you approve or reject changes made to the text of a link. (Inherited from DiagramBase.)
MeasureUnitChanged | Raised when the MeasureUnit property value has changed. (Inherited from DiagramBase.)
NodeActivated | Raised when a node becomes the ActiveItem. (Inherited from DiagramBase.)
NodeClicked | Raised when the user clicks a node. (Inherited from DiagramBase.)
NodeCreateCancelled | Raised when the user cancels node creation. (Inherited from DiagramBase.)
NodeCreated | Raised when the user draws a new node. (Inherited from DiagramBase.)
NodeCreating | A validation event raised while the user is drawing a new node. (Inherited from DiagramBase.)
NodeDeactivated | Raised when a node is no longer the ActiveItem. (Inherited from DiagramBase.)
NodeDeleted | Raised when a node is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeDeselected | Raised when a node is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDoubleClicked | Raised when the user double-clicks a node. (Inherited from DiagramBase.)
NodeModified | Raised when the user moves or resizes a node. (Inherited from DiagramBase.)
NodeModifyCancelled | Raised when the user cancels move or resize operation being done on a node. (Inherited from DiagramBase.)
NodeModifying | A validation event raised while the user is moving or resizing a node. (Inherited from DiagramBase.)
NodePasted | Raised when a node has been pasted from the clipboard. (Inherited from DiagramBase.)
NodePointed | Raised when the mouse pointer hovers over a node. (Inherited from DiagramBase.)
NodeSelected | Raised when a node is selected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeSelecting | Raised when the user tries to select a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeStartModifying | A validation event raised when the user starts modifying a node. (Inherited from DiagramBase.)
NodeTextEdited | Raised when the user edits the text of a node. (Inherited from DiagramBase.)
NodeTextEditing | A validation event that lets you approve or reject changes made to the text of a node. (Inherited from DiagramBase.)
OriginAnchorChanged | Raised when the OriginAnchor property value of a link has changed. (Inherited from DiagramBase.)
QueryAlignTarget | Raised to validate a node as target for alignment guides when AutoAlignNodes is enabled. (Inherited from DiagramBase.)
Repaint | Raised when the diagram views should be repainted. (Inherited from DiagramBase.)
RequestCacheReset | Raised when an object within the diagram requests a reset of the cached bitmap. (Inherited from DiagramBase.)
RequestClipboard | Raised when an object within the diagram requests an operation with the clipboard. (Inherited from DiagramBase.)
RequestTimer | Raised when an object within the diagram needs to start or stop a timer. (Inherited from DiagramBase.)
SelectionChanged | Raised when an item is added to or removed from the selection (Inherited from DiagramBase.)
SelectionModified | Raised when the user moves multiple selected items. (Inherited from DiagramBase.)
SelectionModifying | Raised while the user is moving multiple selected items, this event lets you cancel the modification. (Inherited from DiagramBase.)
SerializeTag | Raised when the Tag of a diagram item must be serialized into an XML document. (Inherited from DiagramBase.)
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape. (Inherited from DiagramBase.)
ShapeModified | Raised when the user modifies the shape of a ShapeNode by moving one of the control points corresponding to shape formula parameters. (Inherited from DiagramBase.)
TableColumnResized | Raised when the user finishes resizing a column in a table. (Inherited from DiagramBase.)
TableColumnResizing | Raised when the user resizes a column in a table interactively. (Inherited from DiagramBase.)
TableRowResized | Raised when the user finishes resizing a row in a table. (Inherited from DiagramBase.)
TableRowResizing | Raised when the user resizes a row in a table interactively. (Inherited from DiagramBase.)
TableSectionCollapsed | Raised when the user collapses the rows of a table’s section by clicking the [-] button in the section's header row. (Inherited from DiagramBase.)
TableSectionExpanded | Raised when the user expands the rows of a table's section by clicking the [+] button in the section’s header row. (Inherited from DiagramBase.)
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node. (Inherited from DiagramBase.)
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node. (Inherited from DiagramBase.)
TreeItemTextEditing | A validation event that lets you approve or reject changes made to the text of a TreeViewNode's item. (Inherited from DiagramBase.)
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point. (Inherited from DiagramBase.)
ViewRemoved | Raised when a DiagramView is detached from this diagram. (Inherited from DiagramBase.)

See Also

DiagramDocument Class


MindFusion.Diagramming.DiagramDocument Constructor

DiagramDocument Constructor
[image]

Initializes a new instance of the DiagramDocument class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramDocument ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramDocument Class


MindFusion.Diagramming.DiagramDocument Methods

DiagramDocument Methods
[image]

Public Methods

Name | Description
LoadFromFile | Loads the document from the specified file.
LoadFromStream | Loads the document from the specified stream.
LoadFromString | Loads the document from the specified string.
LoadFromXml | Overloaded. Loads the document from an XML document or file.
SaveToFile | Overloaded. Saves the document to a binary file.
SaveToStream | Overloaded. Saves the document into a stream.
SaveToString | Overloaded. Saves the document as an ASCII string.
SaveToXml | Overloaded. Saves the document to an XML document or file.
TrackMouseHover | Specifies whether the diagram view should track mouse hover events. (Inherited from DiagramBase.)

Protected Methods

Name | Description
OnActionRecorded | Raises the ActionRecorded event. (Inherited from DiagramBase.)
OnActionRecording | Raises the ActionRecording event. (Inherited from DiagramBase.)
OnActionRedone | Raises the ActionRedone event. (Inherited from DiagramBase.)
OnActionUndone | Raises the ActionUndone event. (Inherited from DiagramBase.)
OnBeginLoad | Raises the BeginLoad event. (Inherited from DiagramBase.)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramBase.)
OnCellClicked | Raises the CellClicked event. (Inherited from DiagramBase.)
OnCellDoubleClicked | Raises the CellDoubleClicked event. (Inherited from DiagramBase.)
OnCellTextEdited | Raises the CellTextEdited event. (Inherited from DiagramBase.)
OnCellTextEditing | Raises the CellTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnClicked | Raises the Clicked event. (Inherited from DiagramBase.)
OnContainerChildAdded | Raises the ContainerChildAdded event. (Inherited from DiagramBase.)
OnContainerChildRemoved | Raises the ContainerChildRemoved event. (Inherited from DiagramBase.)
OnContainerFolded | Raises the ContainerFolded event. (Inherited from DiagramBase.)
OnContainerUnfolded | Raises the ContainerUnfolded event. (Inherited from DiagramBase.)
OnContentVisibilityChanged | Raises the ContentVisibilityChanged event. (Inherited from DiagramBase.)
OnDefaultShapeChanged | Raises the DefaultShapeChanged event. (Inherited from DiagramBase.)
OnDeserializeTag | Raises the DeserializeTag event. (Inherited from DiagramBase.)
OnDestinationAnchorChanged | Raises the DestinationAnchorChanged event. (Inherited from DiagramBase.)
OnDirtyChanged | Raises the DirtyChanged event. (Inherited from DiagramBase.)
OnDoubleClicked | Raises the DoubleClicked event. (Inherited from DiagramBase.)
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event. (Inherited from DiagramBase.)
OnDrawAnchorPoint | Raises the DrawAnchorPoint event. (Inherited from DiagramBase.)
OnDrawBackground | Raises the DrawBackground event. (Inherited from DiagramBase.)
OnDrawCell | Raises the DrawCell event. (Inherited from DiagramBase.)
OnDrawForeground | Raises the DrawForeground event. (Inherited from DiagramBase.)
OnDrawLink | Raises the DrawLink event. (Inherited from DiagramBase.)
OnDrawNode | Raises the DrawNode event. (Inherited from DiagramBase.)
OnEndLoad | Raises the EndLoad event. (Inherited from DiagramBase.)
OnExpandButtonClicked | Raises the ExpandButtonClicked event. (Inherited from DiagramBase.)
OnGroupDestroyed | Raises the GroupDestroyed event. (Inherited from DiagramBase.)
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event. (Inherited from DiagramBase.)
OnInitializeLink | Raises the InitializeLink event. (Inherited from DiagramBase.)
OnInitializeNode | Raises the InitializeNode event. (Inherited from DiagramBase.)
OnItemAdded | Raises the ItemAdded event. (Inherited from DiagramBase.)
OnItemRemoved | Raises the ItemRemoved event. (Inherited from DiagramBase.)
OnLayerVisibilityChanged | Raises the LayerVisibilityChanged event. (Inherited from DiagramBase.)
OnLinkActivated | Raises the LinkActivated event. (Inherited from DiagramBase.)
OnLinkClicked | Raises the LinkClicked event. (Inherited from DiagramBase.)
OnLinkCreateCancelled | Raises the LinkCreateCancelled event. (Inherited from DiagramBase.)
OnLinkCreated | Raises the LinkCreated event. (Inherited from DiagramBase.)
OnLinkCreating | Raises the LinkCreating event. (Inherited from DiagramBase.)
OnLinkDeactivated | Raises the LinkDeactivated event. (Inherited from DiagramBase.)
OnLinkDeleted | Raises the LinkDeleted event. (Inherited from DiagramBase.)
OnLinkDeleting | Raises the LinkDeleting event. (Inherited from DiagramBase.)
OnLinkDeselected | Raises the LinkDeselected event. (Inherited from DiagramBase.)
OnLinkDoubleClicked | Raises the LinkDoubleClicked event. (Inherited from DiagramBase.)
OnLinkModified | Raises the LinkModified event. (Inherited from DiagramBase.)
OnLinkModifyCancelled | Raises the LinkModifyCancelled event. (Inherited from DiagramBase.)
OnLinkModifying | Raises the LinkModifying event. (Inherited from DiagramBase.)
OnLinkPasted | Raises the LinkPasted event. (Inherited from DiagramBase.)
OnLinkPointed | Raises the LinkPointed event. (Inherited from DiagramBase.)
OnLinkRouted | Raises the LinkRouted event. (Inherited from DiagramBase.)
OnLinkSelected | Raises the LinkSelected event. (Inherited from DiagramBase.)
OnLinkSelecting | Raises the LinkSelecting event. (Inherited from DiagramBase.)
OnLinkSplit | Raises the LinkSplit event. (Inherited from DiagramBase.)
OnLinkStartModifying | Raises the LinkStartModifying event. (Inherited from DiagramBase.)
OnLinkTextEdited | Raises the LinkTextEdited event. (Inherited from DiagramBase.)
OnLinkTextEditing | Raises the LinkTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnMeasureUnitChanged | Raises the MeasureUnitChanged event. (Inherited from DiagramBase.)
OnNodeActivated | Raises the NodeActivated event. (Inherited from DiagramBase.)
OnNodeClicked | Raises the NodeClicked event. (Inherited from DiagramBase.)
OnNodeCreateCancelled | Raises the NodeCreateCancelled event. (Inherited from DiagramBase.)
OnNodeCreated | Raises the NodeCreated event. (Inherited from DiagramBase.)
OnNodeCreating | Raises the NodeCreating event. (Inherited from DiagramBase.)
OnNodeDeactivated | Raises the NodeDeactivated event. (Inherited from DiagramBase.)
OnNodeDeleted | Raises the NodeDeleted event. (Inherited from DiagramBase.)
OnNodeDeleting | Raises the NodeDeleting event. (Inherited from DiagramBase.)
OnNodeDeselected | Raises the NodeDeselected event. (Inherited from DiagramBase.)
OnNodeDoubleClicked | Raises the NodeDoubleClicked event. (Inherited from DiagramBase.)
OnNodeModified | Raises the NodeModified event. (Inherited from DiagramBase.)
OnNodeModifyCancelled | Raises the NodeModifyCancelled event. (Inherited from DiagramBase.)
OnNodeModifying | Raises the NodeModifying event. (Inherited from DiagramBase.)
OnNodePasted | Raises the NodePasted event. (Inherited from DiagramBase.)
OnNodePointed | Raises the NodePointed event. (Inherited from DiagramBase.)
OnNodeSelected | Raises the NodeSelected event. (Inherited from DiagramBase.)
OnNodeSelecting | Raises the NodeSelecting event. (Inherited from DiagramBase.)
OnNodeStartModifying | Raises the NodeStartModifying event. (Inherited from DiagramBase.)
OnNodeTextEdited | Raises the NodeTextEdited event. (Inherited from DiagramBase.)
OnNodeTextEditing | Raises the NodeTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnOriginAnchorChanged | Raises the OriginAnchorChanged event. (Inherited from DiagramBase.)
OnQueryAlignTarget | Raises the QueryAlignTarget event. (Inherited from DiagramBase.)
OnRepaint | Raises the Repaint event. (Inherited from DiagramBase.)
OnRequestClipboard | Raises the RequestClipboard event. (Inherited from DiagramBase.)
OnRequestTimer | Raises the RequestTimer event. (Inherited from DiagramBase.)
OnSelectionChanged | Raises the SelectionChanged event. (Inherited from DiagramBase.)
OnSelectionModified | Raises the SelectionModified event. (Inherited from DiagramBase.)
OnSelectionModifying | Raises the SelectionModifying event. (Inherited from DiagramBase.)
OnSerializeTag | Raises the SerializeTag event. (Inherited from DiagramBase.)
OnSetSelfLoopShape | Raises the SetSelfLoopShape event. (Inherited from DiagramBase.)
OnShapeModified | Raises the ShapeModified event. (Inherited from DiagramBase.)
OnTableColumnResized | Raises the TableColumnResized event. (Inherited from DiagramBase.)
OnTableColumnResizing | Raises the TableColumnResizing event. (Inherited from DiagramBase.)
OnTableRowResized | Raises the TableRowResized event. (Inherited from DiagramBase.)
OnTableRowResizing | Raises the TableRowResizing event. (Inherited from DiagramBase.)
OnTableSectionCollapsed | Raises the TableSectionCollapsed event. (Inherited from DiagramBase.)
OnTableSectionExpanded | Raises the TableSectionExpanded event. (Inherited from DiagramBase.)
OnTreeCollapsed | Raises the TreeCollapsed event. (Inherited from DiagramBase.)
OnTreeExpanded | Raises the TreeExpanded event. (Inherited from DiagramBase.)
OnTreeItemTextEditing | Raises the TreeItemTextEditing event. (Inherited from DiagramBase.)
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event. (Inherited from DiagramBase.)
OnViewRemoved | Raises the ViewRemoved event. (Inherited from DiagramBase.)

See Also

DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.LoadFromFile Method

DiagramDocument.LoadFromFile Method
[image]

Loads the document from the specified file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromFile (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFromFile( _
fileName As String _
)

Parameters

fileName

The name of the file to load from.

See Also

DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.LoadFromStream Method

DiagramDocument.LoadFromStream Method
[image]

Loads the document from the specified stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromStream (
Stream stream
)

Visual Basic [image] Copy Code

Public Sub LoadFromStream( _
stream As Stream _
)

Parameters

stream

An instance of a Stream-derived class.

See Also

DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.LoadFromString Method

DiagramDocument.LoadFromString Method
[image]

Loads the document from the specified string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromString (
string str
)

Visual Basic [image] Copy Code

Public Sub LoadFromString( _
str As String _
)

Parameters

str

The string to load from.

See Also

DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.LoadFromXml Method

DiagramDocument.LoadFromXml Method
[image]

Loads the document from an XML document or file.

Overload List

Name | Description
DiagramDocument.LoadFromXml (String) | Loads the document from the specified XML file.
DiagramDocument.LoadFromXml (String, Boolean) | Loads the document from the specified XML file.
DiagramDocument.LoadFromXml (XmlDocument) | Loads the document from the specified XmlDocument object.
DiagramDocument.LoadFromXml (XmlDocument, Boolean) | Loads the document from the specified XmlDocument object.

See Also

DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.LoadFromXml Method (String)

DiagramDocument.LoadFromXml Method (String)
See Also
[image]

Loads the document from the specified XML file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
fileName As String _
)

Parameters

fileName

The name of the XML file the data should be read from.

See Also

LoadFromXml Method Overload List
DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.LoadFromXml Method (String, Boolean)

DiagramDocument.LoadFromXml Method (String, Boolean)
See Also
[image]

Loads the document from the specified XML file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
string fileName,
bool loadDiagramProperties
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
fileName As String, _
loadDiagramProperties As Boolean _
)

Parameters

fileName

The name of the XML file the data should be read from.

loadDiagramProperties

true to load values of diagram properties; false to load only diagram items.

See Also

LoadFromXml Method Overload List
DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.LoadFromXml Method (XmlDocument)

DiagramDocument.LoadFromXml Method (XmlDocument)
See Also
[image]

Loads the document from the specified XmlDocument object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
XmlDocument document
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
document As XmlDocument _
)

Parameters

document

A .NET XmlDocument object from which to load the diagram data.

See Also

LoadFromXml Method Overload List
DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.LoadFromXml Method (XmlDocument, Boolean)

DiagramDocument.LoadFromXml Method (XmlDocument, Boolean)
See Also
[image]

Loads the document from the specified XmlDocument object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
XmlDocument document,
bool loadDiagramProperties
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
document As XmlDocument, _
loadDiagramProperties As Boolean _
)

Parameters

document

A .NET XmlDocument object from which to load the diagram data.

loadDiagramProperties

true to load values of diagram properties; false to load only diagram items.

See Also

LoadFromXml Method Overload List
DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.SaveToFile Method

DiagramDocument.SaveToFile Method
[image]

Saves the document to a binary file.

Overload List

Name | Description
DiagramDocument.SaveToFile (String) | Saves the document to the specified file in a binary format.
DiagramDocument.SaveToFile (String, Boolean) | Saves the document to the specified file in a binary format.

See Also

DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.SaveToFile Method (String)

DiagramDocument.SaveToFile Method (String)
See Also
[image]

Saves the document to the specified file in a binary format.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToFile (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveToFile( _
fileName As String _
)

Parameters

fileName

The full path and name of the disk file where the document should be saved.

See Also

SaveToFile Method Overload List
DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.SaveToFile Method (String, Boolean)

DiagramDocument.SaveToFile Method (String, Boolean)
See Also
[image]

Saves the document to the specified file in a binary format.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToFile (
string fileName,
bool clearDirty
)

Visual Basic [image] Copy Code

Public Sub SaveToFile( _
fileName As String, _
clearDirty As Boolean _
)

Parameters

fileName

The full path and name of the disk file where the document should be saved.

clearDirty

Indicates whether the 'dirty' flag should be cleared.

See Also

SaveToFile Method Overload List
DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.SaveToStream Method

DiagramDocument.SaveToStream Method
[image]

Saves the document into a stream.

Overload List

Name | Description
DiagramDocument.SaveToStream (Stream) | Saves the document into the specified stream.
DiagramDocument.SaveToStream (Stream, Boolean) | Saves the document into the specified stream.

See Also

DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.SaveToStream Method (Stream)

DiagramDocument.SaveToStream Method (Stream)
See Also
[image]

Saves the document into the specified stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToStream (
Stream stream
)

Visual Basic [image] Copy Code

Public Sub SaveToStream( _
stream As Stream _
)

Parameters

stream

An instance of a Stream-derived class.

See Also

SaveToStream Method Overload List
DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.SaveToStream Method (Stream, Boolean)

DiagramDocument.SaveToStream Method (Stream, Boolean)
See Also
[image]

Saves the document into the specified stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToStream (
Stream stream,
bool clearDirty
)

Visual Basic [image] Copy Code

Public Sub SaveToStream( _
stream As Stream, _
clearDirty As Boolean _
)

Parameters

stream

An instance of a Stream-derived class.

clearDirty

Indicates whether the 'dirty' flag should be cleared.

See Also

SaveToStream Method Overload List
DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.SaveToString Method

DiagramDocument.SaveToString Method
[image]

Saves the document as an ASCII string.

Overload List

Name | Description
DiagramDocument.SaveToString () | Saves the document as an ASCII string.
DiagramDocument.SaveToString (SaveToStringFormat, Boolean) | Saves the document as an ASCII string.

See Also

DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.SaveToString Method ()

DiagramDocument.SaveToString Method ()
See Also
[image]

Saves the document as an ASCII string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string SaveToString ()

Visual Basic [image] Copy Code

Public Function SaveToString () As String

Return Value

A string value.

See Also

SaveToString Method Overload List
DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.SaveToString Method (SaveToStringFormat, Boolean)

DiagramDocument.SaveToString Method (SaveToStringFormat, Boolean)
See Also
[image]

Saves the document as an ASCII string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string SaveToString (
SaveToStringFormat format,
bool clearDirty
)

Visual Basic [image] Copy Code

Public Function SaveToString( _
format As SaveToStringFormat, _
clearDirty As Boolean _
) As String

Parameters

format

One of the SaveToStringFormat values.

clearDirty

Indicates whether the 'dirty' flag should be cleared.

Return Value

A string value.

See Also

SaveToString Method Overload List
DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.SaveToXml Method

DiagramDocument.SaveToXml Method
[image]

Saves the document to an XML document or file.

Overload List

Name | Description
DiagramDocument.SaveToXml (String) | Saves the document to the specified file in an XML format.
DiagramDocument.SaveToXml (XmlDocument) | Saves the document to the specified XmlDocument object.
DiagramDocument.SaveToXml (XmlDocument, Boolean) | Saves the document to the specified XmlDocument object.

See Also

DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.SaveToXml Method (String)

DiagramDocument.SaveToXml Method (String)
See Also
[image]

Saves the document to the specified file in an XML format.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
fileName As String _
)

Parameters

fileName

The full path and name of the disk file where the document should be saved.

See Also

SaveToXml Method Overload List
DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.SaveToXml Method (XmlDocument)

DiagramDocument.SaveToXml Method (XmlDocument)
See Also
[image]

Saves the document to the specified XmlDocument object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
XmlDocument document
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
document As XmlDocument _
)

Parameters

document

A .NET XmlDocument object where the document should be saved.

See Also

SaveToXml Method Overload List
DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.SaveToXml Method (XmlDocument, Boolean)

DiagramDocument.SaveToXml Method (XmlDocument, Boolean)
See Also
[image]

Saves the document to the specified XmlDocument object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
XmlDocument document,
bool includeUnalteredProperties
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
document As XmlDocument, _
includeUnalteredProperties As Boolean _
)

Parameters

document

A .NET XmlDocument object where the document should be saved.

includeUnalteredProperties

true if properties that have their default value should be saved; otherwise, false.

See Also

SaveToXml Method Overload List
DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument Properties

DiagramDocument Properties
[image]

Public Properties

Name | Description
Dirty | Gets a value indicating whether the document has changed since the last save.
Pages | Gets a list of the diagram pages contained in this document.

See Also

DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.Dirty Property

DiagramDocument.Dirty Property
[image]

Gets a value indicating whether the document has changed since the last save.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Dirty { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Dirty As Boolean

Property Value

true if the document has changed; otherwise, false.

See Also

DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.Pages Property

DiagramDocument.Pages Property
[image]

Gets a list of the diagram pages contained in this document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ObservableCollection<DiagramPage> Pages { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Pages As ObservableCollection(Of DiagramPage)

Property Value

A list with all document pages.

See Also

DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument Events

DiagramDocument Events
[image]

Public Events

Name | Description
ActionRecorded | Raised when an action is recorded in the undo buffer. (Inherited from DiagramBase.)
ActionRecording | A validation event raised before an action is recorded in the undo buffer. (Inherited from DiagramBase.)
ActionRedone | Raised when an action is redone. (Inherited from DiagramBase.)
ActionUndone | Raised when an action is undone. (Inherited from DiagramBase.)
ActiveLayerChanged | Raised when the diagram's active layer has changed. (Inherited from DiagramBase.)
BeginLoad | Raised when the component starts loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
BoundsChanged | Raised when the Bounds property value has changed. (Inherited from DiagramBase.)
CellClicked | Raised when the user clicks a table’s cell. (Inherited from DiagramBase.)
CellDoubleClicked | Raised when the user double-clicks a table’s cell. (Inherited from DiagramBase.)
CellTextEdited | Raised when the user edits the text of a table’s cell. (Inherited from DiagramBase.)
CellTextEditing | A validation event that lets you approve or reject changes made to the text of a table’s cell. (Inherited from DiagramBase.)
Clicked | Raised when the user clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area. (Inherited from DiagramBase.)
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area. (Inherited from DiagramBase.)
ContentVisibilityChanged | Raised when the visibility of container's content changes. (Inherited from DiagramBase.)
DefaultShapeChanged | Raised when the DefaultShape property value has changed. (Inherited from DiagramBase.)
DeserializeTag | Raised when the Tag of a diagram item must be deserialized from XML format. (Inherited from DiagramBase.)
DestinationAnchorChanged | Raised when the DestinationAnchor property value of a link has changed. (Inherited from DiagramBase.)
DirtyChanged | Raised when the Dirty property value has changed. (Inherited from DiagramBase.)
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
DrawAdjustmentHandles | Raised when item’s adjustment handles must be custom drawn. (Inherited from DiagramBase.)
DrawAnchorPoint | Raised when an anchor point must be custom drawn. (Inherited from DiagramBase.)
DrawBackground | Raised to let you custom draw the diagram background. (Inherited from DiagramBase.)
DrawCell | Raised when a table’s cell must be custom drawn. (Inherited from DiagramBase.)
DrawForeground | Raised to let you custom draw the diagram foreground. (Inherited from DiagramBase.)
DrawLink | Raised when a diagram link must be custom drawn. (Inherited from DiagramBase.)
DrawNode | Raised when a diagram node must be custom drawn. (Inherited from DiagramBase.)
EndLoad | Raised when the component ends loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
ExpandButtonClicked | Raised when the user clicks the [±] button of an Expandable node. (Inherited from DiagramBase.)
GroupDestroyed | Raised when a Group object is destroyed. (Inherited from DiagramBase.)
HitTestAdjustmentHandles | Raised when custom hit testing of item’s adjustment handles must be performed. (Inherited from DiagramBase.)
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created. (Inherited from DiagramBase.)
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created. (Inherited from DiagramBase.)
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
LayerVisibilityChanged | Raised when the visibility of a Layer changes. (Inherited from DiagramBase.)
LinkActivated | Raised when a link becomes the ActiveItem. (Inherited from DiagramBase.)
LinkClicked | Raised when the user clicks a link. (Inherited from DiagramBase.)
LinkCreateCancelled | Raised when the user cancels link creation. (Inherited from DiagramBase.)
LinkCreated | Raised when the user draws a new link. (Inherited from DiagramBase.)
LinkCreating | A validation event raised while the user is drawing a new link. (Inherited from DiagramBase.)
LinkDeactivated | Raised when a link is no longer the ActiveItem. (Inherited from DiagramBase.)
LinkDeleted | Raised when a link is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkDeselected | Raised when a link is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDoubleClicked | Raised when the user double-clicks a link. (Inherited from DiagramBase.)
LinkModified | Raised when the user moves any control point of a link. (Inherited from DiagramBase.)
LinkModifyCancelled | Raised when the user cancels move or resize operation being done on a link. (Inherited from DiagramBase.)
LinkModifying | A validation event raised while the user is modifying a link. (Inherited from DiagramBase.)
LinkPasted | Raised when a link has been pasted from the clipboard. (Inherited from DiagramBase.)
LinkPointed | Raised when the mouse pointer hovers over a link. (Inherited from DiagramBase.)
LinkRouted | Raised when a link is routed by the auto-routing algorithm. (Inherited from DiagramBase.)
LinkSelected | Raised when a link is selected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkSelecting | Raised when the user tries to select a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkSplit | Raised when the user splits a link interactively. (Inherited from DiagramBase.)
LinkStartModifying | A validation event raised when the user starts modifying a link. (Inherited from DiagramBase.)
LinkTextEdited | Raised when the user edits the text of a link. (Inherited from DiagramBase.)
LinkTextEditing | A validation event that lets you approve or reject changes made to the text of a link. (Inherited from DiagramBase.)
MeasureUnitChanged | Raised when the MeasureUnit property value has changed. (Inherited from DiagramBase.)
NodeActivated | Raised when a node becomes the ActiveItem. (Inherited from DiagramBase.)
NodeClicked | Raised when the user clicks a node. (Inherited from DiagramBase.)
NodeCreateCancelled | Raised when the user cancels node creation. (Inherited from DiagramBase.)
NodeCreated | Raised when the user draws a new node. (Inherited from DiagramBase.)
NodeCreating | A validation event raised while the user is drawing a new node. (Inherited from DiagramBase.)
NodeDeactivated | Raised when a node is no longer the ActiveItem. (Inherited from DiagramBase.)
NodeDeleted | Raised when a node is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeDeselected | Raised when a node is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDoubleClicked | Raised when the user double-clicks a node. (Inherited from DiagramBase.)
NodeModified | Raised when the user moves or resizes a node. (Inherited from DiagramBase.)
NodeModifyCancelled | Raised when the user cancels move or resize operation being done on a node. (Inherited from DiagramBase.)
NodeModifying | A validation event raised while the user is moving or resizing a node. (Inherited from DiagramBase.)
NodePasted | Raised when a node has been pasted from the clipboard. (Inherited from DiagramBase.)
NodePointed | Raised when the mouse pointer hovers over a node. (Inherited from DiagramBase.)
NodeSelected | Raised when a node is selected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeSelecting | Raised when the user tries to select a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeStartModifying | A validation event raised when the user starts modifying a node. (Inherited from DiagramBase.)
NodeTextEdited | Raised when the user edits the text of a node. (Inherited from DiagramBase.)
NodeTextEditing | A validation event that lets you approve or reject changes made to the text of a node. (Inherited from DiagramBase.)
OriginAnchorChanged | Raised when the OriginAnchor property value of a link has changed. (Inherited from DiagramBase.)
QueryAlignTarget | Raised to validate a node as target for alignment guides when AutoAlignNodes is enabled. (Inherited from DiagramBase.)
Repaint | Raised when the diagram views should be repainted. (Inherited from DiagramBase.)
RequestCacheReset | Raised when an object within the diagram requests a reset of the cached bitmap. (Inherited from DiagramBase.)
RequestClipboard | Raised when an object within the diagram requests an operation with the clipboard. (Inherited from DiagramBase.)
RequestTimer | Raised when an object within the diagram needs to start or stop a timer. (Inherited from DiagramBase.)
SelectionChanged | Raised when an item is added to or removed from the selection (Inherited from DiagramBase.)
SelectionModified | Raised when the user moves multiple selected items. (Inherited from DiagramBase.)
SelectionModifying | Raised while the user is moving multiple selected items, this event lets you cancel the modification. (Inherited from DiagramBase.)
SerializeTag | Raised when the Tag of a diagram item must be serialized into an XML document. (Inherited from DiagramBase.)
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape. (Inherited from DiagramBase.)
ShapeModified | Raised when the user modifies the shape of a ShapeNode by moving one of the control points corresponding to shape formula parameters. (Inherited from DiagramBase.)
TableColumnResized | Raised when the user finishes resizing a column in a table. (Inherited from DiagramBase.)
TableColumnResizing | Raised when the user resizes a column in a table interactively. (Inherited from DiagramBase.)
TableRowResized | Raised when the user finishes resizing a row in a table. (Inherited from DiagramBase.)
TableRowResizing | Raised when the user resizes a row in a table interactively. (Inherited from DiagramBase.)
TableSectionCollapsed | Raised when the user collapses the rows of a table’s section by clicking the [-] button in the section's header row. (Inherited from DiagramBase.)
TableSectionExpanded | Raised when the user expands the rows of a table's section by clicking the [+] button in the section’s header row. (Inherited from DiagramBase.)
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node. (Inherited from DiagramBase.)
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node. (Inherited from DiagramBase.)
TreeItemTextEditing | A validation event that lets you approve or reject changes made to the text of a TreeViewNode's item. (Inherited from DiagramBase.)
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point. (Inherited from DiagramBase.)
ViewRemoved | Raised when a DiagramView is detached from this diagram. (Inherited from DiagramBase.)

See Also

DiagramDocument Class


MindFusion.Diagramming.DiagramEventArgs Class

DiagramEventArgs Class
[image]

Contains the arguments passed to event handlers, such as Clicked and DoubleClicked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DiagramEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.DiagramEventArgs

See Also

DiagramEventArgs Members


MindFusion.Diagramming.DiagramEventArgs Members

DiagramEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to event handlers, such as Clicked and DoubleClicked.

The following tables list the members exposed by the DiagramEventArgs type.

Public Constructors

Name | Description
DiagramEventArgs | Overloaded.

Public Properties

Name | Description
ClipRect | Gets the current clipping rectangle.
Graphics | Gets an object implementing the IGraphics interface whose methods should be used to draw the custom graphics.
MouseButton | Gets or sets which mouse button has been pressed.
MousePosition | Gets or sets the current mouse pointer position.
VisibleRect | Specifies what part of the diagram is currently visible.

See Also

DiagramEventArgs Class


MindFusion.Diagramming.DiagramEventArgs Constructor

DiagramEventArgs Constructor
[image]

Overload List

Name | Description
DiagramEventArgs (IGraphics, RectangleF, RectangleF) | Initializes a new instance of the DiagramEventArgs class.
DiagramEventArgs (MouseButton, PointF) | Initializes a new instance of the DiagramEventArgs class.

See Also

DiagramEventArgs Class


MindFusion.Diagramming.DiagramEventArgs Constructor (IGraphics, RectangleF, RectangleF)

DiagramEventArgs Constructor (IGraphics, RectangleF, RectangleF)
See Also
[image]

Initializes a new instance of the DiagramEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramEventArgs (
IGraphics graphics,
RectangleF visibleRect,
RectangleF clipRect
)

Visual Basic [image] Copy Code

Public Sub DiagramEventArgs ( _
graphics As IGraphics, _
visibleRect As RectangleF, _
clipRect As RectangleF _
)

Parameters

graphics

visibleRect

clipRect
A RectangleF specifying the current clipping rectangle.

See Also

DiagramEventArgs Constructor Overload List
DiagramEventArgs Class


MindFusion.Diagramming.DiagramEventArgs Constructor (MouseButton, PointF)

DiagramEventArgs Constructor (MouseButton, PointF)
See Also
[image]

Initializes a new instance of the DiagramEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramEventArgs (
MouseButton mouseButton,
PointF mousePosition
)

Visual Basic [image] Copy Code

Public Sub DiagramEventArgs ( _
mouseButton As MouseButton, _
mousePosition As PointF _
)

Parameters

mouseButton

The mouse button related to the event.

mousePosition

The cursor location at the time the event is raised, expressed in document coordinates.

See Also

DiagramEventArgs Constructor Overload List
DiagramEventArgs Class


MindFusion.Diagramming.DiagramEventArgs Properties

DiagramEventArgs Properties
[image]

Public Properties

Name | Description
ClipRect | Gets the current clipping rectangle.
Graphics | Gets an object implementing the IGraphics interface whose methods should be used to draw the custom graphics.
MouseButton | Gets or sets which mouse button has been pressed.
MousePosition | Gets or sets the current mouse pointer position.
VisibleRect | Specifies what part of the diagram is currently visible.

See Also

DiagramEventArgs Class


MindFusion.Diagramming.DiagramEventArgs.ClipRect Property

DiagramEventArgs.ClipRect Property
[image]

Gets the current clipping rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF ClipRect { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ClipRect As RectangleF

Property Value

A RectangleF instance.

Remarks

This property is used as an argument to DrawBackground event handlers.

See Also

DiagramEventArgs Members
DiagramEventArgs Class


MindFusion.Diagramming.DiagramEventArgs.Graphics Property

DiagramEventArgs.Graphics Property
[image]

Gets an object implementing the IGraphics interface whose methods should be used to draw the custom graphics.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IGraphics Graphics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Graphics As IGraphics

Property Value

An instance of a class implementing the IGraphics interface.

Remarks

This property is used as an argument to DrawBackground event handlers.

See Also

DiagramEventArgs Members
DiagramEventArgs Class


MindFusion.Diagramming.DiagramEventArgs.MouseButton Property

DiagramEventArgs.MouseButton Property
[image]

Gets or sets which mouse button has been pressed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MouseButton MouseButton { get; set; }

Visual Basic [image] Copy Code

Public Property MouseButton As MouseButton

Property Value

A member of the MouseButton enumeration specifying the currently pressed mouse button.

See Also

DiagramEventArgs Members
DiagramEventArgs Class


MindFusion.Diagramming.DiagramEventArgs.MousePosition Property

DiagramEventArgs.MousePosition Property
[image]

Gets or sets the current mouse pointer position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointF MousePosition { get; set; }

Visual Basic [image] Copy Code

Public Property MousePosition As PointF

Property Value

A PointF value specifying the current mouse position.

See Also

DiagramEventArgs Members
DiagramEventArgs Class


MindFusion.Diagramming.DiagramEventArgs.VisibleRect Property

DiagramEventArgs.VisibleRect Property
[image]

Specifies what part of the diagram is currently visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF VisibleRect { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property VisibleRect As RectangleF

Property Value

A RectangleF instance.

Remarks

This property is used as an argument to DrawBackground event handlers.

See Also

DiagramEventArgs Members
DiagramEventArgs Class


MindFusion.Diagramming.DiagramItem Class

DiagramItem Class
Remarks See Also
[image]

Represents an item in the diagram document. All classes representing diagram elements derive from DiagramItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class DiagramItem : IPersists, IDisposable

Visual Basic [image] Copy Code

Public MustInherit Class DiagramItem
Implements IPersists, IDisposable

Remarks

All items in the diagram document - links and nodes - share common base class called DiagramItem. Its main function is to provide interface for the most common methods and properties of every diagram element.

MvcDiagram invokes the Draw method when an item must be drawn on screen. You can call Draw if you need to draw an item on your own graphics surface. Override the method when implementing custom item types to provide your own rendering functionality. The standard item types draw their interior and borders using the objects assigned to the Brush and Pen properties. The font of the item's text is set by the Font property.

The order in which items are painted from bottom to top is called the z-order. Moving items up or down the z-order can be done by means of the ZBottom, ZTop, ZLevelUp and ZLevelDown methods. Accessing and setting the index of an item in the z-order can be done using the ZIndex property.

A hierarchy of items can be built, so that moving an item that is higher in the hierarchy moves all subordinated items too. The immediate subordinates of an item are represented by a Group instance. The group of items attached to another item is accessed through the SubordinateGroup property of the latter. MasterGroup gets the group in which an item is subordinate.

Every item can cast a shadow, whose offset from the item is specified by the ShadowOffsetX and ShadowOffsetY properties. The shadow is painted using the color set in ShadowBrush.

An application can associate custom data with an item by means of the Tag property. The tags are only meant to hold data related to the entities represented by the chart items. They are not used or modified by MvcDiagram in any way. The tags are saved and loaded together with the diagram elements when serializing the document to a disk file or a stream.

Items can be locked for interactive modification through the Locked property. Locked items can still be modified programmatically. Items can also be marked as locked for automatic layout methods through the IgnoreLayout property.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramLink
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.Selection

See Also

DiagramItem Members


MindFusion.Diagramming.DiagramItem Members

DiagramItem Members
Constructors Fields Properties Methods
[image]

Represents an item in the diagram document. All classes representing diagram elements derive from DiagramItem.

The following tables list the members exposed by the DiagramItem type.

Protected Constructors

Name | Description
DiagramItem | Overloaded. Initializes a new instance of the DiagramItem class.

Protected Fields

Name | Description
disposed | For internal use.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of this item.
EffectiveBrush | Gets the effective brush of the item.
EffectiveFont | Gets the currently effective font of the item.
EffectivePen | Gets the effective pen of the item.
EffectiveShadowBrush | Gets the effective shadow brush of the item.
EffectiveTextBrush | Gets the effective text brush of the item.
Font | Gets or sets the font used to render the item's text.
HyperLink | Gets or sets the hyperlink associated with this diagram item.
Id | Gets or sets user-defined identifier associated with this item.
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer.
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D.
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item.
Parent | Gets the diagram that contains this item.
Pen | Gets or sets the pen used to paint the frame of the item.
Printable | Gets or sets a value indicating whether to print the item.
RuntimeIndex | For internal use.
Selected | Gets or sets a value indicating whether a diagram item is selected.
ShadowBrush | Gets or sets the brush used to paint the item's shadow.
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item.
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item.
Style | Gets or sets the style associated with the item.
SubordinateGroup | Gets a reference to the group of items that are attached to this one.
Tag | Gets or sets user-defined data associated with this item.
TextBrush | Gets or sets the brush used to paint texts inside the item.
TextPadding | Gets or sets the spacing between the item boundaries and its text.
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element.
TopLevel | True if this is a top-level item in the diagram, or false if it is inside a container.
Visible | Gets or sets a value indicating whether this item is visible.
Weight | Gets or sets a weight value used in layout and path-finding algorithms.
ZIndex | Gets or sets the z-order position of this item.

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit.

Public Methods

Name | Description
Clone | Creates a copy of this item.
ContainsPoint | Overloaded. Determines whether this item contains the specified point.
Dispose | Overloaded.
DoModify | For internal use.
Draw | Draws the item on the specified IGraphics surface.
DrawHandles | Renders the adjustment handles of this item.
DrawShadow | Draws the shadow of this item on the specified IGraphics surface.
GetBounds | Gets the bounding rectangle of this item.
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item.
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item.
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item.
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item.
GetOutlinePoly | Gets a polygon approximating the outline of this object.
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow.
GetRotatedBounds | Gets the bounding rectangle of this item when it is rotated.
GetToolTip | Gets the tooltip that should be displayed for this item at the specified point.
HitTest | Returns the diagram item that contains the specified point.
HitTestHandle | Determines whether a selection handle of this item is located at the specified point.
HitTestManipulators | Triggers the manipulator located at the specified point.
NotInteractive | Gets whether the user is prevented from manipulating this item.
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user.
OnLoad | Called after successful deserialization.
Query | Returns the items that can be reached from this item by following the path specified in the given query expression.
RestoreItemProperties | For internal use.
SaveItemProperties | For internal use.
ZBottom | Moves the item to the bottom of the z-order.
ZLevelDown | Moves the item one level down in the z-order.
ZLevelUp | Moves the item one level up in the z-order.
ZTop | Moves the item to the top of the z-order.

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object.
AllowCreate | Invoked during interactive creation of items to test whether the operation can be completed in the current context.
AllowModify | Invoked during interactive modification of items to test whether the operation can be completed in the current context.
CancelModify | Invoked when the interactive modification of this object has been canceled.
CompleteCreate | Invoked when the item creation has been completed.
CompleteModify | Invoked when the item modification has been completed.
CreateProperties | Creates an item property set corresponding to the type of this diagram item.
CreateState | Creates an item state corresponding to the type of this diagram item.
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics.
Finalize | DiagramItem finalizer.
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history.
GetValue | Gets the effective value of the style property with the specified name.
LoadFrom | Deserializes the item from the specified reader.
LoadFromXml | Loads the item content from an XML element.
LoadObsolete | For internal use.
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo.
OnChildModified | Called when a group child node has been modified.
OnClick | Invoked when the user clicks this item.
OnDoubleClick | Invoked when the user double-clicks this item.
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes.
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo.
OnStyleChanged | Invoked when the associated style or theme have changed.
OnZoomChanged | Called when the diagram's ZoomFactor changes.
RemoveManipulator | Removes the specified manipulator from the object.
Repaint | Overloaded.
RestoreProperties | Restores the properties of this diagram item.
RestoreState | Restores the state of this diagram item.
SaveProperties | Saves the properties of this diagram item.
SaveState | Saves the state of this diagram item.
SaveTo | Serializes the item to the specified writer.
SaveToXml | Saves the item content into an XML element.
SetDiagramDirty | Marks the diagram as changed.
SetExpanded | Sets whether the item is in expanded or collapsed state.
SetReference | Called during deserialization, after all objects have been instantiated, in order to update the references between them.
ShouldRender | Determines whether the item should be rendered in the current context.
StartCreate | Invoked once when the user starts creating a new item interactively.
StartModify | Invoked when the user starts modifying this item interactively.
UpdateCreate | Invoked during interactive creation of this item.
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster.
UpdateModify | Invoked during interactive modification of this item.

See Also

DiagramItem Class


MindFusion.Diagramming.DiagramItem Fields

DiagramItem Fields
[image]

Protected Fields

Name | Description
disposed | For internal use.

See Also

DiagramItem Class


MindFusion.Diagramming.DiagramItem.disposed Field

DiagramItem.disposed Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected bool disposed

Visual Basic [image] Copy Code

Protected disposed As Boolean

Remarks

This field is used in the implementation of the IDisposable pattern.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem Constructor

DiagramItem Constructor
[image]

Initializes a new instance of the DiagramItem class.

Overload List

Name | Description
DiagramItem () | Initializes a new instance of the DiagramItem class.
DiagramItem (Diagram) | Initializes a new instance of the DiagramItem class with default values supplied form the specified Diagram.
DiagramItem (DiagramItem) | Initializes a new instance of the DiagramItem class using the specified diagram item as a prototype.

See Also

DiagramItem Class


MindFusion.Diagramming.DiagramItem Constructor ()

DiagramItem Constructor ()
See Also
[image]

Initializes a new instance of the DiagramItem class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DiagramItem ()

Visual Basic [image] Copy Code

Protected Sub New ()

Remarks

This constructor sets the DiagramItem properties to their default values.

See Also

DiagramItem Constructor Overload List
DiagramItem Class


MindFusion.Diagramming.DiagramItem Constructor (Diagram)

DiagramItem Constructor (Diagram)
See Also
[image]

Initializes a new instance of the DiagramItem class with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DiagramItem (
Diagram parent
)

Visual Basic [image] Copy Code

Protected Sub DiagramItem ( _
parent As Diagram _
)

Parameters

parent

The Diagram from which to obtain default values for the item properties.

Remarks

This constructor initializes the DiagramItem properties with the values specified in the respective default-value properties of the Diagram object. For more information see Initial Values of Item Properties.

See Also

DiagramItem Constructor Overload List
DiagramItem Class


MindFusion.Diagramming.DiagramItem Constructor (DiagramItem)

DiagramItem Constructor (DiagramItem)
See Also
[image]

Initializes a new instance of the DiagramItem class using the specified diagram item as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DiagramItem (
DiagramItem prototype
)

Visual Basic [image] Copy Code

Protected Sub DiagramItem ( _
prototype As DiagramItem _
)

Parameters

prototype
The item to use as a prototype. The properties of the new item are initialized from the property values of this item.

Remarks

This constructor copies the DiagramItem property values from the specified prototype item.

See Also

DiagramItem Constructor Overload List
DiagramItem Class


MindFusion.Diagramming.DiagramItem Methods

DiagramItem Methods
[image]

Public Methods

Name | Description
Clone | Creates a copy of this item.
ContainsPoint | Overloaded. Determines whether this item contains the specified point.
Dispose | Overloaded.
DoModify | For internal use.
Draw | Draws the item on the specified IGraphics surface.
DrawHandles | Renders the adjustment handles of this item.
DrawShadow | Draws the shadow of this item on the specified IGraphics surface.
GetBounds | Gets the bounding rectangle of this item.
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item.
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item.
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item.
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item.
GetOutlinePoly | Gets a polygon approximating the outline of this object.
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow.
GetRotatedBounds | Gets the bounding rectangle of this item when it is rotated.
GetToolTip | Gets the tooltip that should be displayed for this item at the specified point.
HitTest | Returns the diagram item that contains the specified point.
HitTestHandle | Determines whether a selection handle of this item is located at the specified point.
HitTestManipulators | Triggers the manipulator located at the specified point.
NotInteractive | Gets whether the user is prevented from manipulating this item.
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user.
OnLoad | Called after successful deserialization.
Query | Returns the items that can be reached from this item by following the path specified in the given query expression.
RestoreItemProperties | For internal use.
SaveItemProperties | For internal use.
ZBottom | Moves the item to the bottom of the z-order.
ZLevelDown | Moves the item one level down in the z-order.
ZLevelUp | Moves the item one level up in the z-order.
ZTop | Moves the item to the top of the z-order.

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object.
AllowCreate | Invoked during interactive creation of items to test whether the operation can be completed in the current context.
AllowModify | Invoked during interactive modification of items to test whether the operation can be completed in the current context.
CancelModify | Invoked when the interactive modification of this object has been canceled.
CompleteCreate | Invoked when the item creation has been completed.
CompleteModify | Invoked when the item modification has been completed.
CreateProperties | Creates an item property set corresponding to the type of this diagram item.
CreateState | Creates an item state corresponding to the type of this diagram item.
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics.
Finalize | DiagramItem finalizer.
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history.
GetValue | Gets the effective value of the style property with the specified name.
LoadFrom | Deserializes the item from the specified reader.
LoadFromXml | Loads the item content from an XML element.
LoadObsolete | For internal use.
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo.
OnChildModified | Called when a group child node has been modified.
OnClick | Invoked when the user clicks this item.
OnDoubleClick | Invoked when the user double-clicks this item.
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes.
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo.
OnStyleChanged | Invoked when the associated style or theme have changed.
OnZoomChanged | Called when the diagram's ZoomFactor changes.
RemoveManipulator | Removes the specified manipulator from the object.
Repaint | Overloaded.
RestoreProperties | Restores the properties of this diagram item.
RestoreState | Restores the state of this diagram item.
SaveProperties | Saves the properties of this diagram item.
SaveState | Saves the state of this diagram item.
SaveTo | Serializes the item to the specified writer.
SaveToXml | Saves the item content into an XML element.
SetDiagramDirty | Marks the diagram as changed.
SetExpanded | Sets whether the item is in expanded or collapsed state.
SetReference | Called during deserialization, after all objects have been instantiated, in order to update the references between them.
ShouldRender | Determines whether the item should be rendered in the current context.
StartCreate | Invoked once when the user starts creating a new item interactively.
StartModify | Invoked when the user starts modifying this item interactively.
UpdateCreate | Invoked during interactive creation of this item.
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster.
UpdateModify | Invoked during interactive modification of this item.

See Also

DiagramItem Class


MindFusion.Diagramming.DiagramItem.AddManipulator Method

DiagramItem.AddManipulator Method
[image]

Adds the specified manipulator to this object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void AddManipulator (
Manipulator mnp
)

Visual Basic [image] Copy Code

Protected Sub AddManipulator ( _
mnp As Manipulator _
)

Parameters

mnp
An instance of Manipulator -derived class.

Remarks

Use this method to add custom manipulators to diagram elements. Manipulators are interactive widgets associated with an item that let users change aspects of the item different from its position and size. Some built-in manipulators are the +/- icons displayed for Expandable nodes and the scrollbar of a TreeViewNode.

See Also

DiagramItem Members
DiagramItem Class
RemoveManipulator Method


MindFusion.Diagramming.DiagramItem.AllowCreate Method

DiagramItem.AllowCreate Method
[image]

Invoked during interactive creation of items to test whether the operation can be completed in the current context.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected abstract bool AllowCreate (
PointF current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected MustOverride Function AllowCreate ( _
current As PointF, _
ist As InteractionState _
) As Boolean

Parameters

current
The current mouse pointer position.
ist
An InteractionState object containing more information about the current state of the operation.

Return Value

true to allow the creation of this item; otherwise, false.

Remarks

This method is invoked after each mouse movement in order to update the mouse pointer icon, so do not perform any time-consuming operations in its implementation.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.AllowModify Method

DiagramItem.AllowModify Method
[image]

Invoked during interactive modification of items to test whether the operation can be completed in the current context.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected abstract bool AllowModify (
PointF current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected MustOverride Function AllowModify ( _
current As PointF, _
ist As InteractionState _
) As Boolean

Parameters

current
The current mouse pointer position.
ist

An InteractionState object containing more information about the current state of the operation.

Return Value

true to allow the modification of this item; otherwise, false.

Remarks

This method is invoked after each mouse movement in order to update the mouse pointer icon, so do not perform any time-consuming operations in its implementation.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.CancelModify Method

DiagramItem.CancelModify Method
[image]

Invoked when the interactive modification of this object has been canceled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void CancelModify (
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overridable Sub CancelModify( _
ist As InteractionState _
)

Parameters

ist

An InteractionState object containing more information about the current state of the operation.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Clone Method

DiagramItem.Clone Method
[image]

Creates a copy of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual DiagramItem Clone (
bool clipboard
)

Visual Basic [image] Copy Code

Public Overridable Function Clone ( _
clipboard As Boolean _
) As DiagramItem

Parameters

clipboard
true if the copy will be stored in the Windows clipboard; otherwise, false.

Return Value

The copy of this item.

Remarks

The default implementation of this item invokes the item's class copy constructor through reflection. If your custom type does not provide a copy constructor, you must implement this method to provide for clipboard operations support.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.CompleteCreate Method

DiagramItem.CompleteCreate Method
[image]

Invoked when the item creation has been completed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void CompleteCreate (
PointF end
)

Visual Basic [image] Copy Code

Protected Overridable Sub CompleteCreate( _
end As PointF _
)

Parameters

end
The mouse pointer position.

Remarks

This method is invoked when the user releases the mouse button while drawing a new item.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.CompleteModify Method

DiagramItem.CompleteModify Method
[image]

Invoked when the item modification has been completed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void CompleteModify (
PointF end,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overridable Sub CompleteModify ( _
end As PointF, _
ist As InteractionState _
)

Parameters

end
The mouse pointer position.
ist
An InteractionState object containing more information about the current state of the operation.

Remarks

This method is invoked when the user releases the mouse button while modifying an item.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ContainsPoint Method

DiagramItem.ContainsPoint Method
[image]

Determines whether this item contains the specified point.

Overload List

Name | Description
DiagramItem.ContainsPoint (PointF) | Determines whether this item contains the specified point.
DiagramItem.ContainsPoint (PointF, Single) | Determines whether this item contains the specified point.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ContainsPoint Method (PointF)

DiagramItem.ContainsPoint Method (PointF)
See Also
[image]

Determines whether this item contains the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract bool ContainsPoint (
PointF point
)

Visual Basic [image] Copy Code

Public MustOverride Function ContainsPoint( _
point As PointF _
) As Boolean

Parameters

point
A PointF value specifying the logical coordinates of a diagram point.

Return Value

true it this item contains the specified point; otherwise, false.

Remarks

This method is used during hit-testing to see if the mouse is inside the item.

See Also

ContainsPoint Method Overload List
DiagramItem Members
DiagramItem Class
HitTest Method


MindFusion.Diagramming.DiagramItem.ContainsPoint Method (PointF, Single)

DiagramItem.ContainsPoint Method (PointF, Single)
See Also
[image]

Determines whether this item contains the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract bool ContainsPoint (
PointF point,
float threshold
)

Visual Basic [image] Copy Code

Public MustOverride Function ContainsPoint( _
point As PointF, _
threshold As Single _
) As Boolean

Parameters

point

A PointF value specifying the logical coordinates of a diagram point.

threshold

Specifies the size of the area around the item outlines where the point is still considered inside the item.

Return Value

true it this item contains the specified point; otherwise, false.

See Also

ContainsPoint Method Overload List
DiagramItem Members
DiagramItem Class
HitTest Method


MindFusion.Diagramming.DiagramItem.CreateProperties Method

DiagramItem.CreateProperties Method
[image]

Creates an item property set corresponding to the type of this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramItemProperties CreateProperties ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateProperties () As DiagramItemProperties

Return Value

A DiagramItemProperties -derived object containing a snapshot of the item's properties.

Remarks

This method is invoked by the undo/redo subsystem when creating a ChangeItemCmd instance.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.CreateState Method

DiagramItem.CreateState Method
[image]

Creates an item state corresponding to the type of this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramItemState CreateState ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateState () As DiagramItemState

Return Value

An instance of a class derived from DiagramItemState.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
SaveState Method
RestoreState Method


MindFusion.Diagramming.DiagramItem.Dispose Method

DiagramItem.Dispose Method
[image]

Overload List

Name | Description
DiagramItem.Dispose () | Disposes the resources managed by this item.
DiagramItem.Dispose (Boolean) | Disposes any disposable resources managed by this item.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Dispose Method ()

DiagramItem.Dispose Method ()
See Also
[image]

Disposes the resources managed by this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Dispose ()

Visual Basic [image] Copy Code

Public Sub Dispose ()

Remarks

This method is used in the implementation of the IDisposable pattern.

See Also

Dispose Method Overload List
DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Dispose Method (Boolean)

DiagramItem.Dispose Method (Boolean)
See Also
[image]

Disposes any disposable resources managed by this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void Dispose (
bool disposing
)

Visual Basic [image] Copy Code

Protected Overridable Sub Dispose( _
disposing As Boolean _
)

Parameters

disposing

Specifies whether the method is called explicitly or from the garbage collector.

Remarks

This method is used in the implementation of the IDisposable pattern.

See Also

Dispose Method Overload List
DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.DoModify Method

DiagramItem.DoModify Method
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool DoModify (
PointF start,
PointF end,
AdjustmentHandle handle
)

Visual Basic [image] Copy Code

Public Function DoModify( _
start As PointF, _
end As PointF, _
handle As AdjustmentHandle _
) As Boolean

Parameters

start

end

handle

Return Value

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Draw Method

DiagramItem.Draw Method
[image]

Draws the item on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract void Draw (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public MustOverride Sub Draw ( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics
The IGraphics surface to draw the item on.
options
A RenderOptions object specifying options for the drawing operation.

Remarks

MvcDiagram calls this method to draw a representation of the diagram item onto the specified graphics surface. Implement this method in custom node or link types if you need to provide your own drawing functionality. The method is called when rendering the diagram on screen, or exporting it to PDF or SVG files. The IGraphics methods call the respective GDI+ Graphics methods when drawing on screen, or generate PDF of SVG tags when using PdfExporter and SvgExporter to export diagram files.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.DrawHandles Method

DiagramItem.DrawHandles Method
[image]

Renders the adjustment handles of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract void DrawHandles (
IGraphics graphics,
HandlesVisualStyle style,
RenderOptions options
)

Visual Basic [image] Copy Code

Public MustOverride Sub DrawHandles( _
graphics As IGraphics, _
style As HandlesVisualStyle, _
options As RenderOptions _
)

Parameters

graphics

The IGraphics surface on which the handles should be drawn.

style

A HandlesVisualStyle instance containing brush and pen objects that should be used when drawing handles.

options

Provides options for the drawing operation.

Remarks

This method is invoked when the item's adjustment handles must be rendered.

See Also

DiagramItem Members
DiagramItem Class
HitTestHandle Method


MindFusion.Diagramming.DiagramItem.DrawManipulators Method

DiagramItem.DrawManipulators Method
[image]

Draws the associated manipulators on a specified graphics.

Overload List

Name | Description
DiagramItem.DrawManipulators (IGraphics, Boolean) | Draws the associated manipulators on the specified graphics.
DiagramItem.DrawManipulators (IGraphics, Boolean, Boolean) | Draws the associated manipulators in the specified graphics.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.DrawManipulators Method (IGraphics, Boolean)

DiagramItem.DrawManipulators Method (IGraphics, Boolean)
See Also
[image]

Draws the associated manipulators on the specified graphics.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void DrawManipulators (
IGraphics graphics,
bool clip
)

Visual Basic [image] Copy Code

Protected Sub DrawManipulators ( _
graphics As IGraphics, _
clip As Boolean _
)

Parameters

graphics
The IGraphics surface to draw the manipulators on.
clip
true to render only inside the item's bounds; otherwise, false.

Remarks

This method is invoked to render the item's manipulators, for example, collapse/expand buttons, scrollbars, and so on.

See Also

DrawManipulators Method Overload List
DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.DrawManipulators Method (IGraphics, Boolean, Boolean)

DiagramItem.DrawManipulators Method (IGraphics, Boolean, Boolean)
See Also
[image]

Draws the associated manipulators in the specified graphics.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void DrawManipulators (
IGraphics graphics,
bool clip,
bool inLocal
)

Visual Basic [image] Copy Code

Protected Sub DrawManipulators( _
graphics As IGraphics, _
clip As Boolean, _
inLocal As Boolean _
)

Parameters

graphics

The IGraphics surface to draw the manipulators on.

clip

true to render only inside the item's bounds; otherwise, false.

inLocal

true if current graphics are in local coordinates; otherwise, false.

Remarks

This method is invoked to render the item's manipulators, for example, collapse/expand buttons, scrollbars, and so on.

See Also

DrawManipulators Method Overload List
DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.DrawShadow Method

DiagramItem.DrawShadow Method
[image]

Draws the shadow of this item on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract void DrawShadow (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public MustOverride Sub DrawShadow ( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics
The IGraphics surface to draw the shadow on.
options
A RenderOptions object specifying options for the drawing operation.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Finalize Method

DiagramItem.Finalize Method
[image]

DiagramItem finalizer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Finalize ()

Visual Basic [image] Copy Code

Protected Overrides Sub Finalize ()

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.FreeResources Method

DiagramItem.FreeResources Method
[image]

Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void FreeResources ()

Visual Basic [image] Copy Code

Protected Overridable Sub FreeResources ()

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.GetBounds Method

DiagramItem.GetBounds Method
[image]

Gets the bounding rectangle of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual RectangleF GetBounds ()

Visual Basic [image] Copy Code

Public Overridable Function GetBounds () As RectangleF

Return Value

The rectangle that bounds this item.

Remarks

The Bounds property getter returns the result of this method. MvcDiagram treats the returned value as the logical coordinates of the item and uses it in many situations when comparing items geometrically, when looking for items intersections, and so on.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.GetEffectiveBrush Method

DiagramItem.GetEffectiveBrush Method
[image]

Creates a System.Drawing.Brush object representing the currently effective brush of the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush GetEffectiveBrush ()

Visual Basic [image] Copy Code

Public Function GetEffectiveBrush () As Brush

Return Value

A .NET Brush object.

Remarks

This method returns a system brush corresponding to the item's Brush if the item's Brush is not null, or a system brush corresponding to the Brush property of the item's style. The returned object must be disposed by the caller.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.GetEffectivePen Method

DiagramItem.GetEffectivePen Method
[image]

Creates a System.Drawing.Pen object representing the currently effective pen of the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen GetEffectivePen ()

Visual Basic [image] Copy Code

Public Function GetEffectivePen () As Pen

Return Value

A .NET Pen object.

Remarks

This method returns a system pen corresponding to the item's Pen if the item's Pen is not null, or a system pen with the Stroke and StrokeThickness properties of the item's style. The returned object must be disposed by the caller.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.GetEffectiveShadowBrush Method

DiagramItem.GetEffectiveShadowBrush Method
[image]

Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush GetEffectiveShadowBrush ()

Visual Basic [image] Copy Code

Public Function GetEffectiveShadowBrush () As Brush

Return Value

A .NET Brush object.

Remarks

This method returns a system brush corresponding to the item's ShadowBrush if the item's ShadowBrush is not null, or a system brush corresponding to the ShadowBrush property of the item's style. The returned object must be disposed by the caller.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.GetEffectiveTextBrush Method

DiagramItem.GetEffectiveTextBrush Method
[image]

Creates a System.Drawing.Brush object representing the currently effective text brush of the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush GetEffectiveTextBrush ()

Visual Basic [image] Copy Code

Public Function GetEffectiveTextBrush () As Brush

Return Value

A .NET Brush object.

Remarks

This method returns a system brush corresponding to the item's TextBrush if the item's TextBrush is not null, or a system brush corresponding to the TextBrush property of the item's style. The returned object must be disposed by the caller.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.GetOutlinePoly Method

DiagramItem.GetOutlinePoly Method
[image]

Gets a polygon approximating the outline of this object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual PointCollection GetOutlinePoly (
bool rendering
)

Visual Basic [image] Copy Code

Public Overridable Function GetOutlinePoly( _
rendering As Boolean _
) As PointCollection

Parameters

rendering

Specifies whether the outline will be used for rendering (true) or hit-testing (false).

Return Value

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.GetRepaintRect Method

DiagramItem.GetRepaintRect Method
[image]

Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual RectangleF GetRepaintRect (
bool includeConnected
)

Visual Basic [image] Copy Code

Public Overridable Function GetRepaintRect( _
includeConnected As Boolean _
) As RectangleF

Parameters

includeConnected
true if related items should be considered too; otherwise, false.

Return Value

A rectangular region that should be repainted when this item is modified.

Remarks

This method is invoked when an item is modified by the user, or when an appearance property of the item changes. The returned region is invalidated and redrawn at the next paint operation.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.GetRotatedBounds Method

DiagramItem.GetRotatedBounds Method
[image]

Gets the bounding rectangle of this item when it is rotated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual RectangleF GetRotatedBounds ()

Visual Basic [image] Copy Code

Public Overridable Function GetRotatedBounds () As RectangleF

Return Value

A rectangle that bounds the rotated shape of the item.

Remarks

This method is invoked during hit-testing to do a quick test whether a point is within the item's bounds, before calling the possibly more time-consuming ContainsPoint method.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.GetToolTip Method

DiagramItem.GetToolTip Method
[image]

Gets the tooltip that should be displayed for this item at the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual string GetToolTip (
PointF point
)

Visual Basic [image] Copy Code

Public Overridable Function GetToolTip( _
point As PointF _
) As String

Parameters

point
The mouse pointer position.

Return Value

A string specifying the tooltip text.

Remarks

You can override this method to return different tooltips for different regions of the item.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.GetValue Method

DiagramItem.GetValue Method
[image]

Gets the effective value of the style property with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Object GetValue (
string name
)

Visual Basic [image] Copy Code

Protected Function GetValue( _
name As String _
) As Object

Parameters

name

The name of the property to get.

Return Value

An object representing the effective property value.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.HitTest Method

DiagramItem.HitTest Method
[image]

Returns the diagram item that contains the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual DiagramItem HitTest (
PointF point,
float threshold,
bool onlyNodes,
bool onlyInteractive
)

Visual Basic [image] Copy Code

Public Overridable Function HitTest( _
point As PointF, _
threshold As Single, _
onlyNodes As Boolean, _
onlyInteractive As Boolean _
) As DiagramItem

Parameters

point

A PointF value specifying the logical coordinates of a diagram point.

threshold

Specifies the size of the area around the item outlines where the point is still considered inside the item.

onlyNodes

true to exclude child links from the search.

onlyInteractive

true to exclude locked items from the search.

Return Value

The item that contains the specified point.

Remarks

This method performs recursive search if items contain child items.

See Also

DiagramItem Members
DiagramItem Class
ContainsPoint Method


MindFusion.Diagramming.DiagramItem.HitTestHandle Method

DiagramItem.HitTestHandle Method
[image]

Determines whether a selection handle of this item is located at the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract AdjustmentHandle HitTestHandle (
PointF point
)

Visual Basic [image] Copy Code

Public MustOverride Function HitTestHandle( _
point As PointF _
) As AdjustmentHandle

Parameters

point

A PointF value specifying where to look for a selection handle.

Return Value

Returns an AdjustmentHandle instance representing the adjustment handle found at the specified location, or null if there is none.

See Also

DiagramItem Members
DiagramItem Class
DrawHandles Method


MindFusion.Diagramming.DiagramItem.HitTestManipulators Method

DiagramItem.HitTestManipulators Method
[image]

Triggers the manipulator located at the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Manipulator HitTestManipulators (
PointF pt
)

Visual Basic [image] Copy Code

Public Overridable Function HitTestManipulators( _
pt As PointF _
) As Manipulator

Parameters

pt

Return Value

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.LoadFrom Method

DiagramItem.LoadFrom Method
[image]

Deserializes the item from the specified reader.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFrom (
BinaryReader reader,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFrom ( _
reader As BinaryReader, _
context As PersistContext _
)

Parameters

reader
A BinaryReader object from which to read the item's data.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

This method is invoked when an item is being deserialized from a diagram file saved in a binary format.

Example

The following example shows how to implement this method in a derived class.

C# [image] Copy Code

protected override void LoadFrom(System.IO.BinaryReader reader, PersistContext ctx)
{
base.LoadFrom(reader, ctx);

label = reader.ReadString();
icon = ctx.LoadImage();
}

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFrom(ByVal reader As System.IO.BinaryReader, ByVal ctx As PersistContext)

MyBase.LoadFrom(reader, ctx)

title = reader.ReadString()
imgIcon = ctx.LoadImage()

End Sub

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.LoadFromXml Method

DiagramItem.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFromXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement containing the item's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

This method is invoked when an item is being deserialized from a diagram file saved in XML format.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.LoadObsolete Method

DiagramItem.LoadObsolete Method
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadObsolete (
XmlReader reader,
SortedList brushes,
Object extra
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadObsolete( _
reader As XmlReader, _
brushes As SortedList, _
extra As Object _
)

Parameters

reader

brushes

extra

Remarks

Invoked for control hosts when they are loaded from a pre-5.0 Xml file.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.NotInteractive Method

DiagramItem.NotInteractive Method
[image]

Gets whether the user is prevented from manipulating this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool NotInteractive ()

Visual Basic [image] Copy Code

Public Overridable Function NotInteractive () As Boolean

Return Value

true to prevent user interaction with this item; otherwise, false.

Remarks

The default implementation prevents manipulation of invisible or locked items.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.NowModifying Method

DiagramItem.NowModifying Method
[image]

Gets a flag indicating whether this object is being currently modified interactively by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool NowModifying ()

Visual Basic [image] Copy Code

Public Function NowModifying () As Boolean

Return Value

true is the item is being modified; otherwise, false.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.OnAdd Method

DiagramItem.OnAdd Method
[image]

Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnAdd ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnAdd ()

See Also

DiagramItem Members
DiagramItem Class
OnLoad Method


MindFusion.Diagramming.DiagramItem.OnChildModified Method

DiagramItem.OnChildModified Method
[image]

Called when a group child node has been modified.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnChildModified (
DiagramNode node,
AdjustmentHandles handle
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnChildModified ( _
node As DiagramNode, _
handle As AdjustmentHandles _
)

Parameters

node
The node that has been modified.
handle
The adjustment handle used to modify the node.

Remarks

Override this method if you need to know when a node from the SubordinateGroup is modified.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.OnClick Method

DiagramItem.OnClick Method
[image]

Invoked when the user clicks this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnClick (
MouseButton mouseButton,
PointF mousePosition
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnClick ( _
mouseButton As MouseButton, _
mousePosition As PointF _
)

Parameters

mouseButton

Specifies the mouse button used to click the item.

mousePosition

Specifies the mouse position.

Remarks

Implement this method in a custom item class if you need to detect clicks without handling events of the Diagram class.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.OnDoubleClick Method

DiagramItem.OnDoubleClick Method
[image]

Invoked when the user double-clicks this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDoubleClick (
MouseButton mouseButton,
PointF mousePosition
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDoubleClick ( _
mouseButton As MouseButton, _
mousePosition As PointF _
)

Parameters

mouseButton

Specifies the mouse button used to click the item.

mousePosition

Specifies the mouse position.

Remarks

Implement this method in a custom item class if you need to detect double-clicks without handling events of the Diagram class.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.OnLoad Method

DiagramItem.OnLoad Method
[image]

Called after successful deserialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void OnLoad ()

Visual Basic [image] Copy Code

Public Overridable Sub OnLoad ()

Remarks

Override this method if you need to update the state of items after successfully loading a diagram.

See Also

DiagramItem Members
DiagramItem Class
OnAdd Method


MindFusion.Diagramming.DiagramItem.OnMeasureUnitChanged Method

DiagramItem.OnMeasureUnitChanged Method
[image]

Called when the diagram's MeasureUnit changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnMeasureUnitChanged ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnMeasureUnitChanged ()

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.OnRemove Method

DiagramItem.OnRemove Method
[image]

Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnRemove ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnRemove ()

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.OnStyleChanged Method

DiagramItem.OnStyleChanged Method
[image]

Invoked when the associated style or theme have changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnStyleChanged ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnStyleChanged ()

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.OnZoomChanged Method

DiagramItem.OnZoomChanged Method
[image]

Called when the diagram's ZoomFactor changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnZoomChanged ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnZoomChanged ()

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Query Method

DiagramItem.Query Method
[image]

Returns the items that can be reached from this item by following the path specified in the given query expression.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemCollection Query (
string query
)

Visual Basic [image] Copy Code

Public Function Query( _
query As String _
) As DiagramItemCollection

Parameters

query

A query expression consisting of selectors and boolean predicates.

Return Value

A collection of the found items.

Remarks

The query string consists of selectors, where each selector specifies the next items that should be selected starting from the current one.

The following selectors can be applied to a node:

links | Selects all links connected to the current node
inlinks | Selects the incoming links of the current node
outlinks | Selects the outgoing links of the current node
parent | Selects the parent item of the current node if it is in a group
children | Selects the child nodes of the current node if it is in a group

The following selectors can be applied to a link:

nodes | Selects the two nodes connected by the current link
origin | Selects the Origin node of the current link
destination | Selects the Destination node of the current link
children | Selects the child nodes of the current link if it is in a group.

Selectors must be separated by the / character. The results returned by a selector can be also filtered using a predicate expression, enclosed in square brackets after the selector name. The predicate expression can include C# like boolean and arithmetic operators, and one of the following property identifiers:

tag | Returns the value of the Tag property.
text | Returns the value of the Text property.
weight | Returns the value of the Weight property.

Example

The following code selects nodes two levels below the current one in a tree or layered graph.

C# [image] Copy Code

DiagramItemCollection items = diagram.ActiveItem.Query(
"outlinks/destination/outlinks/destination");
diagram.Selection.Clear();
foreach (DiagramItem item in items)
item.Selected = true;

The following code finds the neighbors of the currently selected node that can be reached from it by following links with Weight greater than 3.

C# [image] Copy Code

DiagramItemCollection items = diagram.ActiveItem.Query(
"outlinks[weight>3]/destination");

The following example finds the destination nodes of links labeled "exception" going out of children of the current node's group.

C# [image] Copy Code
DiagramItemCollection items = diagram.ActiveItem.Query(
"children/outlinks[text==\"exception\"]/destination");

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
IncomingLinks Property
OutgoingLinks Property
MasterGroup Property
SubordinateGroup Property


MindFusion.Diagramming.DiagramItem.RemoveManipulator Method

DiagramItem.RemoveManipulator Method
[image]

Removes the specified manipulator from the object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void RemoveManipulator (
Manipulator manipulator
)

Visual Basic [image] Copy Code

Protected Sub RemoveManipulator ( _
manipulator As Manipulator _
)

Parameters

manipulator
An instance of Manipulator -derived class.

Remarks

Invoke this method to remove manipulators previously added using AddManipulator.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Repaint Method

DiagramItem.Repaint Method
[image]

Overload List

Name | Description
DiagramItem.Repaint () | Repaints the region of the diagram where this item is located.
DiagramItem.Repaint (Boolean) | Repaints the specified region of the diagram.
DiagramItem.Repaint (RectangleF) | Repaints the specified region of the diagram.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Repaint Method ()

DiagramItem.Repaint Method ()
See Also
[image]

Repaints the region of the diagram where this item is located.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void Repaint ()

Visual Basic [image] Copy Code

Protected Sub Repaint ()

Remarks

Call this method to repaint the diagram after changing appearance attributes of this item.

See Also

Repaint Method Overload List
DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Repaint Method (Boolean)

DiagramItem.Repaint Method (Boolean)
See Also
[image]

Repaints the specified region of the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void Repaint (
bool includeConnected
)

Visual Basic [image] Copy Code

Protected Sub Repaint( _
includeConnected As Boolean _
)

Parameters

includeConnected
true if related items should be considered too; otherwise, false.

See Also

Repaint Method Overload List
DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Repaint Method (RectangleF)

DiagramItem.Repaint Method (RectangleF)
See Also
[image]

Repaints the specified region of the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void Repaint (
RectangleF invalidRect
)

Visual Basic [image] Copy Code

Protected Sub Repaint( _
invalidRect As RectangleF _
)

Parameters

invalidRect
The region to repaint.

Remarks

Call this method to repaint a part of the item after changing its appearance attributes.

See Also

Repaint Method Overload List
DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.RestoreItemProperties Method

DiagramItem.RestoreItemProperties Method
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RestoreItemProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Public Sub RestoreItemProperties( _
props As DiagramItemProperties _
)

Parameters

props

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.RestoreProperties Method

DiagramItem.RestoreProperties Method
[image]

Restores the properties of this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overridable Sub RestoreProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties -derived object containing a snapshot of the item's properties.

Remarks

This method is invoked by the undo/redo subsystem when undoing or redoing a ChangeItemCmd instance.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.RestoreState Method

DiagramItem.RestoreState Method
[image]

Restores the state of this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected new virtual void RestoreState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Shadows Overridable Sub RestoreState ( _
state As DiagramItemState _
)

Parameters

state
A DiagramItemState object.

Remarks

This method is called when an item should be restored to the state it had before user interaction.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
CreateState Method
SaveState Method


MindFusion.Diagramming.DiagramItem.SaveItemProperties Method

DiagramItem.SaveItemProperties Method
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveItemProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Public Sub SaveItemProperties( _
props As DiagramItemProperties _
)

Parameters

props

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.SaveProperties Method

DiagramItem.SaveProperties Method
[image]

Saves the properties of this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties -derived object where the item's properties should be saved.

Remarks

This method is invoked by the undo/redo subsystem when saving a ChangeItemCmd instance.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.SaveState Method

DiagramItem.SaveState Method
[image]

Saves the state of this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected new virtual void SaveState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Shadows Overridable Sub SaveState ( _
state As DiagramItemState _
)

Parameters

state
A DiagramItemState object.

Remarks

This method is called to save undo information when the users starts modifying an item.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
CreateState Method
RestoreState Method


MindFusion.Diagramming.DiagramItem.SaveTo Method

DiagramItem.SaveTo Method
[image]

Serializes the item to the specified writer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveTo (
BinaryWriter writer,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveTo ( _
writer As BinaryWriter, _
context As PersistContext _
)

Parameters

writer
A BinaryWriter object the item's data should be written to.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

This method is invoked when an item is being serialized to a binary-format diagram file.

Example

The following example shows how to implement this method in a derived class.

C# [image] Copy Code

protected override void SaveTo(System.IO.BinaryWriter writer, PersistContext ctx)
{
base.SaveTo(writer, ctx);

// Save the label using the standard .NET BinaryWriter
writer.Write(label);

// Save the image using the built-in image saving code,
// which stores the contents of shared images only once.
ctx.SaveImage(icon);
}

Visual Basic [image] Copy Code

Protected Overrides Sub SaveTo(ByVal writer As System.IO.BinaryWriter, ByVal ctx As PersistContext)

MyBase.SaveTo(writer, ctx)

' Save the label using the standard .NET BinaryWriter
writer.Write(title)

' Save the image using the built-in image saving code,
' which stores the contents of shared images only once.
ctx.SaveImage(imgIcon)

End Sub

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.SaveToXml Method

DiagramItem.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveToXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement the item's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

This method is invoked when an item is being serialized into an XML-format diagram file.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.SetDiagramDirty Method

DiagramItem.SetDiagramDirty Method
[image]

Marks the diagram as changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void SetDiagramDirty ()

Visual Basic [image] Copy Code

Protected Sub SetDiagramDirty ()

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.SetExpanded Method

DiagramItem.SetExpanded Method
[image]

Sets whether the item is in expanded or collapsed state.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SetExpanded (
bool e
)

Visual Basic [image] Copy Code

Protected Overridable Sub SetExpanded( _
e As Boolean _
)

Parameters

e
Specifies the new state of the item.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.SetReference Method

DiagramItem.SetReference Method
[image]

Called during deserialization, after all objects have been instantiated, in order to update the references between them.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SetReference (
int refId,
Object obj,
PersistContext ctx
)

Visual Basic [image] Copy Code

Protected Overridable Sub SetReference ( _
refId As Integer, _
obj As Object, _
ctx As PersistContext _
)

Parameters

refId
Reference identifier.
obj
The newly loaded object.
context

A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

This method is called for references that had been saved using the SaveReference method.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ShouldRender Method

DiagramItem.ShouldRender Method
[image]

Determines whether the item should be rendered in the current context.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected bool ShouldRender ()

Visual Basic [image] Copy Code

Protected Function ShouldRender () As Boolean

Return Value

true to draw the item; otherwise, false.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.StartCreate Method

DiagramItem.StartCreate Method
[image]

Invoked once when the user starts creating a new item interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void StartCreate (
PointF org
)

Visual Basic [image] Copy Code

Protected Overridable Sub StartCreate( _
org As PointF _
)

Parameters

org
Position of the mouse pointer.

Remarks

This method is invoked in response to the MouseDown event, just after an item has been instantiated.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.StartModify Method

DiagramItem.StartModify Method
[image]

Invoked when the user starts modifying this item interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void StartModify (
PointF org,
AdjustmentHandle handle,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overridable Sub StartModify( _
org As PointF, _
handle As AdjustmentHandle, _
ist As InteractionState _
)

Parameters

org

Position of the mouse pointer.

handle

The adjustment handle used to modify this item.

ist

An InteractionState object containing more information about the current state of the operation.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.UpdateCreate Method

DiagramItem.UpdateCreate Method
[image]

Invoked during interactive creation of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void UpdateCreate (
PointF current
)

Visual Basic [image] Copy Code

Protected Overridable Sub UpdateCreate( _
current As PointF _
)

Parameters

current

Position of the mouse pointer.

Remarks

This methods is invoked after each mouse movement in order to update the item's state in accordance with the new mouse position.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.UpdateGroup Method

DiagramItem.UpdateGroup Method
[image]

Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void UpdateGroup ()

Visual Basic [image] Copy Code

Protected Overridable Sub UpdateGroup ()

See Also

DiagramItem Members
DiagramItem Class
Group.AttachCustom Method


MindFusion.Diagramming.DiagramItem.UpdateModify Method

DiagramItem.UpdateModify Method
[image]

Invoked during interactive modification of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void UpdateModify (
PointF current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overridable Sub UpdateModify ( _
current As PointF, _
ist As InteractionState _
)

Parameters

current
Position of the mouse pointer.
ist
An InteractionState object containing more information about the current state of the operation.

Remarks

This methods is invoked after each mouse movement in order to update the item's state in accordance with the new mouse position.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ZBottom Method

DiagramItem.ZBottom Method
[image]

Moves the item to the bottom of the z-order.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ZBottom (
bool keepInLayer
)

Visual Basic [image] Copy Code

Public Sub ZBottom( _
keepInLayer As Boolean _
)

Parameters

keepInLayer

Remarks

Call the method to move the item to the bottom of the z-order.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
ZTop Method
ZIndex Property


MindFusion.Diagramming.DiagramItem.ZLevelDown Method

DiagramItem.ZLevelDown Method
[image]

Moves the item one level down in the z-order.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ZLevelDown (
bool keepInLayer
)

Visual Basic [image] Copy Code

Public Sub ZLevelDown( _
keepInLayer As Boolean _
)

Parameters

keepInLayer

Remarks

Call the method to change the item's position in z-order with one level down.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
ZLevelUp Method
ZIndex Property


MindFusion.Diagramming.DiagramItem.ZLevelUp Method

DiagramItem.ZLevelUp Method
[image]

Moves the item one level up in the z-order.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ZLevelUp (
bool keepInLayer
)

Visual Basic [image] Copy Code

Public Sub ZLevelUp( _
keepInLayer As Boolean _
)

Parameters

keepInLayer

Remarks

Call the method to change the item's position in z-order with one level up.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
ZLevelDown Method
ZIndex Property


MindFusion.Diagramming.DiagramItem.ZTop Method

DiagramItem.ZTop Method
[image]

Moves the item to the top of the z-order.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ZTop (
bool keepInLayer
)

Visual Basic [image] Copy Code

Public Sub ZTop( _
keepInLayer As Boolean _
)

Parameters

keepInLayer

Remarks

Call the method to move the item to the top of the z-order.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
ZBottom Method
ZIndex Property


MindFusion.Diagramming.DiagramItem Properties

DiagramItem Properties
[image]

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of this item.
EffectiveBrush | Gets the effective brush of the item.
EffectiveFont | Gets the currently effective font of the item.
EffectivePen | Gets the effective pen of the item.
EffectiveShadowBrush | Gets the effective shadow brush of the item.
EffectiveTextBrush | Gets the effective text brush of the item.
Font | Gets or sets the font used to render the item's text.
HyperLink | Gets or sets the hyperlink associated with this diagram item.
Id | Gets or sets user-defined identifier associated with this item.
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer.
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D.
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item.
Parent | Gets the diagram that contains this item.
Pen | Gets or sets the pen used to paint the frame of the item.
Printable | Gets or sets a value indicating whether to print the item.
RuntimeIndex | For internal use.
Selected | Gets or sets a value indicating whether a diagram item is selected.
ShadowBrush | Gets or sets the brush used to paint the item's shadow.
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item.
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item.
Style | Gets or sets the style associated with the item.
SubordinateGroup | Gets a reference to the group of items that are attached to this one.
Tag | Gets or sets user-defined data associated with this item.
TextBrush | Gets or sets the brush used to paint texts inside the item.
TextPadding | Gets or sets the spacing between the item boundaries and its text.
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element.
TopLevel | True if this is a top-level item in the diagram, or false if it is inside a container.
Visible | Gets or sets a value indicating whether this item is visible.
Weight | Gets or sets a weight value used in layout and path-finding algorithms.
ZIndex | Gets or sets the z-order position of this item.

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit.

See Also

DiagramItem Class


MindFusion.Diagramming.DiagramItem.Brush Property

DiagramItem.Brush Property
[image]

Gets or sets the brush used to fill the interior of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class. The default value is null.

Remarks

This property refers to a brush with which an item is painted. You can assign to it an instance of one of the following classes: HatchBrush, LinearGradientBrush, PathGradientBrush, SolidBrush or TextureBrush, located in the MindFusion.Drawing namespace. When applied to links, the property defines how arrowheads interior is painted.

When set to null, the brush object used to paint this item is derived from the item's Style, or from the diagram's Theme.

Example

The following example demonstrates how to create a LinearGradientBrush and assign it to the first node of a diagram:

C# [image] Copy Code

diagram.Nodes[0].Brush = new MindFusion.Drawing.LinearGradientBrush(
Color.Yellow, Color.BurlyWood, 20);

Visual Basic [image] Copy Code

Diagram.Nodes(0).Brush = New MindFusion.Drawing.LinearGradientBrush( _
Color.Yellow, Color.BurlyWood, 20)

See Also

DiagramItem Members
DiagramItem Class
EffectiveBrush Property


MindFusion.Diagramming.DiagramItem.EffectiveBrush Property

DiagramItem.EffectiveBrush Property
[image]

Gets the effective brush of the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush EffectiveBrush { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EffectiveBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

Remarks

Returns a Brush instance used to paint this item. This value comes from the Brush property if it is set, or is derived from either the item's Style or the current diagram Theme.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.EffectiveFont Property

DiagramItem.EffectiveFont Property
[image]

Gets the currently effective font of the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Font EffectiveFont { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EffectiveFont As Font

Property Value

A .NET Font object.

Remarks

This property returns Font if it is not null, or a font with the FontFamily, FontSize, FontStyle and FontUnit properties of the item's style.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.EffectivePen Property

DiagramItem.EffectivePen Property
[image]

Gets the effective pen of the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen EffectivePen { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EffectivePen As Pen

Property Value

An instance of the MindFusion.Drawing.Pen class.

Remarks

Returns a Pen instance used to draw this item's border or segment lines. This value comes from the Pen property if it is set, or is derived from either the item's Style or the current diagram Theme.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.EffectiveShadowBrush Property

DiagramItem.EffectiveShadowBrush Property
[image]

Gets the effective shadow brush of the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush EffectiveShadowBrush { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EffectiveShadowBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

Remarks

Returns a Brush instance used to paint the item's shadow. This value comes from the ShadowBrush property if it is set, or is derived from either the item's Style or the current diagram Theme.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.EffectiveTextBrush Property

DiagramItem.EffectiveTextBrush Property
[image]

Gets the effective text brush of the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush EffectiveTextBrush { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EffectiveTextBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

Remarks

Returns a Brush instance used to paint the item's text. This value comes from the TextBrush property if it is set, or is derived from either the item's Style or the current diagram Theme.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Font Property

DiagramItem.Font Property
[image]

Gets or sets the font used to render the item's text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Font Font { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Font As Font

Property Value

An instance of the System.Drawing.Font class. The default value is null.

Remarks

Items derived from DiagramItem use this font to draw their text. Tables for example render their captions and text in cells using this font. Initially the font is set to the value of Font.

When set to null, the font object used to render the item's text is derived from the item's Style, or from the diagram's current Theme.

See Also

DiagramItem Members
DiagramItem Class
EffectiveFont Property


MindFusion.Diagramming.DiagramItem.HyperLink Property

DiagramItem.HyperLink Property
[image]

Gets or sets the hyperlink associated with this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string HyperLink { get; set; }

Visual Basic [image] Copy Code

Public Property HyperLink As String

Property Value

A string value containing the hyperlink URL.

Remarks

This property is used by the CreateImageMap method of the HtmlBuilder class. Its value is assigned to the HREF attribute of the <AREA> tag that corresponds to the diagram item.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Id Property

DiagramItem.Id Property
[image]

Gets or sets user-defined identifier associated with this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Id { get; set; }

Visual Basic [image] Copy Code

Public Property Id As Object

Property Value

An instance of any class derived from System.Object.

Remarks

This property contains data that you define and is not used by the control in any way. You can associate with the item any value of a primitive data type, an object from the .NET class library or a custom class. If the id is an instance of value type it will be serialized together with the item containing it when saving / loading the diagram. Reference types are serialized if marked with the [Serializable] attribute or if they implement the ISerializable interface.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
Diagram.FindNodeById Method
Diagram.FindLinkById Method
Diagram.SerializeTag Event
Tag Property


MindFusion.Diagramming.DiagramItem.IgnoreLayout Property

DiagramItem.IgnoreLayout Property
[image]

Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IgnoreLayout { get; set; }

Visual Basic [image] Copy Code

Public Property IgnoreLayout As Boolean

Property Value

true if the item must stay at its place nevertheless an automatic layout is performed; otherwise, false. The default is false.

Remarks

Enable IgnoreLayout to specify that the Arrange method of layout classes should ignore an item. If enabled, the position of an item won't be changed. This property applies to visible nodes. Invisible nodes are always ignored by automatic layout methods.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
Locked Property
Visible Property


MindFusion.Diagramming.DiagramItem.LayerIndex Property

DiagramItem.LayerIndex Property
[image]

Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int LayerIndex { get; set; }

Visual Basic [image] Copy Code

Public Property LayerIndex As Integer

Property Value

An integer value that specifies the index of the layer.

Remarks

This property specifies the index of a Layer instance within the Layers collection of the Diagram.

See Also

DiagramItem Members
DiagramItem Class
ZIndex Property


MindFusion.Diagramming.DiagramItem.LayoutTraits Property

DiagramItem.LayoutTraits Property
[image]

Contains layout properties of the node, used by some layout algorithms and by DiagramView3D.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IDictionary LayoutTraits { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LayoutTraits As IDictionary

Property Value

A hashtable of key-value pairs that define layout-specific properties for this item.

Remarks

This property is used by some Layout classes and the DiagramView3D class:

  • FlowLayout looks for values assigned to keys from the FlowLayoutTraits enumeration.
  • SpringLayout looks for values associated with SpringLayoutTraits members.
  • TreeLayout looks for values associated with TreeLayoutTraits members.
  • SwimlaneLayout looks for values associated with SwimlaneLayoutTraits members.
  • LayeredLayout looks for values associated with LayeredLayoutTraits members.
  • HierarchicalLayout looks for values associated with HierarchicalLayoutTraits members.
  • The DiagramView3D class seeks keys values from the View3D enumeration.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Locked Property

DiagramItem.Locked Property
[image]

Gets or sets a value indicating whether users are allowed to edit the diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Locked { get; set; }

Visual Basic [image] Copy Code

Public Property Locked As Boolean

Property Value

true to prevent users from editing a diagram element; otherwise, false. The default is false.

Remarks

A locked item cannot be selected, moved or resized interactively. Additionally, its text cannot be edited in-place.

Locked nodes still can be moved or resized programmatically through the Bounds property and the Move / Resize methods. Positions of locked links' control points can be changed programmatically too - through their ControlPoints collections.

Locked items positions can be changed also by the automatic layout algorithms. To prevent automatic layout methods from changing positions of individual items, set the IgnoreLayout property of DiagramItem to false.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
Visible Property
DiagramView.Enabled Property


MindFusion.Diagramming.DiagramItem.MeasureUnit Property

DiagramItem.MeasureUnit Property
[image]

Returns the diagram measure unit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected MeasureUnit MeasureUnit { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property MeasureUnit As MeasureUnit

Property Value

An instance of the MeasureUnit class.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Parent Property

DiagramItem.Parent Property
[image]

Gets the diagram that contains this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Diagram Parent { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Parent As Diagram

Property Value

A reference to a Diagram instance.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Pen Property

DiagramItem.Pen Property
[image]

Gets or sets the pen used to paint the frame of the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen Pen { get; set; }

Visual Basic [image] Copy Code

Public Property Pen As Pen

Property Value

An instance of the MindFusion.Drawing.Pen class. The default value is null.

Remarks

The property refers to a pen, with which the item frame is painted. When applied to links, the property specifies how their segments are painted.

When set to null, the pen object used to draw the item borders is derived from the item's Style, or from the diagram's current Theme.

Example

The following example demonstrates how to create a pen with a linear gradient and assign it to the first node of a diagram:

C# [image] Copy Code

MindFusion.Drawing.Brush penBrush = new MindFusion.Drawing.LinearGradientBrush(
Color.Bisque, Color.Blue, 0);
diagram.Nodes[0].Pen = new MindFusion.Drawing.Pen(penBrush);

Visual Basic [image] Copy Code

Dim penBrush As New MindFusion.Drawing.LinearGradientBrush( _
Color.Bisque, Color.Blue, 0)
diagram.Nodes(0).Pen = New MindFusion.Drawing.Pen(penBrush)

See Also

DiagramItem Members
DiagramItem Class
EffectivePen Property


MindFusion.Diagramming.DiagramItem.Printable Property

DiagramItem.Printable Property
[image]

Gets or sets a value indicating whether to print the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Printable { get; set; }

Visual Basic [image] Copy Code

Public Property Printable As Boolean

Property Value

true to print this item; otherwise, false.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
Visible Property
Diagram.Print Method


MindFusion.Diagramming.DiagramItem.RuntimeIndex Property

DiagramItem.RuntimeIndex Property
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int RuntimeIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RuntimeIndex As Integer

Property Value

A sequential integer id for this item.

Remarks

Valid only after calling UpdateRuntimeIndices.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Selected Property

DiagramItem.Selected Property
[image]

Gets or sets a value indicating whether a diagram item is selected.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Selected { get; set; }

Visual Basic [image] Copy Code

Public Property Selected As Boolean

Property Value

true if the item is selected; otherwise, false.

Remarks

Use the property to check which items are selected by the user, or to programmatically select items if needed. Selected items adjustment handles are painted using the pen and brush specified through the SelectedItemHandlesStyle property. You can specify if users first have to select items in order to modify them with the ModificationStart property.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
Selection Class
Diagram.Selection Property


MindFusion.Diagramming.DiagramItem.ShadowBrush Property

DiagramItem.ShadowBrush Property
[image]

Gets or sets the brush used to paint the item's shadow.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush ShadowBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ShadowBrush As Brush

Property Value

An instance of a Brush -derived class. The default value is null.

Remarks

The shadow of an item has the same shape as the item, but is painted with a different brush and with some offset from the item position. This property specifies the brush used to paint the item's shadow.

When set to null, the brush object used to paint the shadow is derived from the item's Style, or from the current diagram Theme.

Example

The following code creates a shadow with fuzzy edges for the newly created node.

C# [image] Copy Code

private void diagram_InitializeNode(object sender, NodeEventArgs e)
{
ColorBlend blend = new ColorBlend(3);
blend.Colors = new Color[] {
Color.Transparent,
Color.FromArgb(128, Color.Black),
Color.FromArgb(128, Color.Black) };
blend.Positions = new float[] { 0f, 0.1f, 1f };

PathGradientBrush brush = new PathGradientBrush(Color.White, Color.White);
brush.InterpolationColors = blend;

e.Node.ShadowBrush = brush;
e.Node.ShadowOffsetY = 2;
e.Node.ShadowOffsetX = 1.5f;
}

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
Diagram.ShadowsStyle Property
EffectiveShadowBrush Property


MindFusion.Diagramming.DiagramItem.ShadowOffsetX Property

DiagramItem.ShadowOffsetX Property
[image]

Gets or sets the horizontal offset of the shadow of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float ShadowOffsetX { get; set; }

Visual Basic [image] Copy Code

Public Property ShadowOffsetX As Single

Property Value

A float value specifying the horizontal offset of this item's shadow. Initialized with the value of ShadowOffsetX.

Remarks

The shadow of an item has the same shape as the item itself, but with a different color and with some offset from the item position. This property specifies the horizontal offset of the shadow.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
ShadowOffsetY Property
Diagram.ShadowsStyle Property


MindFusion.Diagramming.DiagramItem.ShadowOffsetY Property

DiagramItem.ShadowOffsetY Property
[image]

Gets or sets the vertical offset of the shadow of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float ShadowOffsetY { get; set; }

Visual Basic [image] Copy Code

Public Property ShadowOffsetY As Single

Property Value

A float value specifying the vertical offset of this item's shadow. Initialized with the value of ShadowOffsetY.

Remarks

The shadow of an item has the same shape as the item itself, but with a different color and with some offset from the item position. This property specifies the vertical offset of the shadow.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
ShadowOffsetX Property
Diagram.ShadowsStyle Property


MindFusion.Diagramming.DiagramItem.Style Property

DiagramItem.Style Property
[image]

Gets or sets the style associated with the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemStyle Style { get; set; }

Visual Basic [image] Copy Code

Public Property Style As DiagramItemStyle

Property Value

An instance of a DiagramItemStyle-derived class.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.SubordinateGroup Property

DiagramItem.SubordinateGroup Property
[image]

Gets a reference to the group of items that are attached to this one.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Group SubordinateGroup { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SubordinateGroup As Group

Property Value

A reference to a Group object or null (Nothing in Visual Basic) if the item is not master of a group.

Remarks

Diagram items can be grouped hierarchically in such a manner, that if an item is moved all of its subordinated items in the hierarchy move too. The immediate subordinates of an item are contained and represented by a Group instance. SubordinateGroup provides access to the group of items that are attached to this one. If there are no attached items, the property returns null (Nothing in Visual Basic).

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
MasterGroup Property
Factory.CreateGroup Method
Query Method


MindFusion.Diagramming.DiagramItem.Tag Property

DiagramItem.Tag Property
[image]

Gets or sets user-defined data associated with this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An instance of any class derived from System.Object.

Remarks

This property contains data that you define and is not used by the control in any way. You can associate with the item any value of a primitive data type, an object from the .NET class library or a custom class. If the tag is an instance of value type it will be serialized together with the item containing it when saving / loading the diagram. Reference types are serialized if marked with the [Serializable] attribute or if they implement the ISerializable interface.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
Diagram.FindNode Method
Diagram.FindLink Method
Diagram.SerializeTag Event
Id Property


MindFusion.Diagramming.DiagramItem.TextBrush Property

DiagramItem.TextBrush Property
[image]

Gets or sets the brush used to paint texts inside the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush TextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TextBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class. The default value is null.

Remarks

When set to null, the brush object used to draw text is derived from either the item's Style or the current diagram Theme.

See Also

DiagramItem Members
DiagramItem Class
EffectiveTextBrush Property


MindFusion.Diagramming.DiagramItem.TextPadding Property

DiagramItem.TextPadding Property
[image]

Gets or sets the spacing between the item boundaries and its text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Thickness TextPadding { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property TextPadding As Thickness

Property Value

A Thickness instance specifying the size of the padding space left around the text.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ToolTip Property

DiagramItem.ToolTip Property
[image]

Gets or sets a short text message displayed when the mouse pointer rests over the diagram element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ToolTip { get; set; }

Visual Basic [image] Copy Code

Public Property ToolTip As String

Property Value

The tool-tip text displayed for this item. The default value is an empty string.

Remarks

When the mouse rests for a while over an item, the item's tool-tip text is displayed. If it is an empty string, the diagram's ToolTip is displayed instead.

The tool-tip text is also used as a value of the ALT attribute of the image map AREA corresponding to the item; see HtmlBuilder for further information.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
DiagramView.ShowToolTips Property
DiagramView.ToolTipDelay Property


MindFusion.Diagramming.DiagramItem.TopLevel Property

DiagramItem.TopLevel Property
[image]

True if this is a top-level item in the diagram, or false if it is inside a container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool TopLevel { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property TopLevel As Boolean

Property Value

true if this is a top-level item in the diagram; false otherwise.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Visible Property

DiagramItem.Visible Property
[image]

Gets or sets a value indicating whether this item is visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Visible As Boolean

Property Value

true if the item is visible; otherwise, false.

Remarks

Invisible items are not drawn at all. You might use the property to hide or show items temporarily, or to construct complex group hierarchies in which intermediate helper items are invisible.

Invisible nodes are ignored by automatic layout methods. The position of such nodes won't change when the Arrange method of a layout class is called. Visible items can be ignored too by enabling their IgnoreLayout property.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
Printable Property
Locked Property


MindFusion.Diagramming.DiagramItem.Weight Property

DiagramItem.Weight Property
[image]

Gets or sets a weight value used in layout and path-finding algorithms.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Weight { get; set; }

Visual Basic [image] Copy Code

Public Property Weight As Single

Property Value

A float value specifying the weight of this item. The default value is 1.

Remarks

Currently Weight is used in the implementations of:

  • The SpringLayout class: the weight of a link connecting two nodes is multiplied by the desired NodeDistance to determine the final distance between the nodes.
  • The PathFinder class: an override of the FindShortestPath method uses the Weight values of nodes and/or links to find the path with smallest total weight.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ZIndex Property

DiagramItem.ZIndex Property
[image]

Gets or sets the z-order position of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ZIndex { get; set; }

Visual Basic [image] Copy Code

Public Property ZIndex As Integer

Property Value

An integer value specifying the position of the diagram item within the z-order. The default value is -1.

Remarks

Use this property to arrange items in z-order. Items with lower ZIndex appear behind items with higher ZIndex.

If the ZIndex property of newly added items is equal to -1, the control will automatically assign consecutively increasing values to it. If you set ZIndex to a value greater then -1 before adding an item, the control will preserve it.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
ZLevelDown Method
ZBottom Method
ZLevelUp Method
ZTop Method
LayerIndex Property


MindFusion.Diagramming.DiagramItemCollection Class

DiagramItemCollection Class
[image]

Represents a strongly typed collection of DiagramItem objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramItemCollection : ItemCollectionBase<DiagramItem>

Visual Basic [image] Copy Code

Public Class DiagramItemCollection
Inherits ItemCollectionBase(Of DiagramItem)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.CollectionBase(DiagramItem)
MindFusion.Diagramming.PersistableCollection(DiagramItem)
MindFusion.Diagramming.ItemCollectionBase(DiagramItem)
MindFusion.Diagramming.DiagramItemCollection

See Also

DiagramItemCollection Members


MindFusion.Diagramming.DiagramItemCollection Members

DiagramItemCollection Members
Constructors Fields Properties Methods
[image]

Represents a strongly typed collection of DiagramItem objects.

The following tables list the members exposed by the DiagramItemCollection type.

Public Constructors

Name | Description
DiagramItemCollection | Initializes a new instance of the DiagramItemCollection class.

Protected Fields

Name | Description
InnerList | Gets a List<T> containing the list of elements in the collection instance. (Inherited from CollectionBase.)
itemEventArgs | A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector. (Inherited from ItemCollectionBase.)
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items. (Inherited from ItemCollectionBase.)

Public Properties

Name | Description
Count | Gets the number of elements actually contained in the collection. (Inherited from CollectionBase.)
IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index. (Inherited from CollectionBase.)

Public Methods

Name | Description
Add | Adds the specified diagram item to the collection. (Inherited from ItemCollectionBase.)
Clear | Removes all diagram items from the collection. (Inherited from ItemCollectionBase.)
Clone | Creates a shallow copy of this collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from CollectionBase.)
GetAt | Gets the diagram item at the specified position. (Inherited from ItemCollectionBase.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified diagram item into the collection at the specified position. (Inherited from ItemCollectionBase.)
Remove | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
RemoveAt | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
Sort | Overloaded. (Inherited from CollectionBase.)

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event. (Inherited from ItemCollectionBase.)
RaiseInserting | Raises the Inserting event. (Inherited from ItemCollectionBase.)
RaiseRemoving | Raises the Removing event. (Inherited from ItemCollectionBase.)

See Also

DiagramItemCollection Class


MindFusion.Diagramming.DiagramItemCollection Constructor

DiagramItemCollection Constructor
[image]

Initializes a new instance of the DiagramItemCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramItemCollection Class


MindFusion.Diagramming.DiagramItemCollection Methods

DiagramItemCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified diagram item to the collection. (Inherited from ItemCollectionBase.)
Clear | Removes all diagram items from the collection. (Inherited from ItemCollectionBase.)
Clone | Creates a shallow copy of this collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from CollectionBase.)
GetAt | Gets the diagram item at the specified position. (Inherited from ItemCollectionBase.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified diagram item into the collection at the specified position. (Inherited from ItemCollectionBase.)
Remove | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
RemoveAt | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
Sort | Overloaded. (Inherited from CollectionBase.)

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event. (Inherited from ItemCollectionBase.)
RaiseInserting | Raises the Inserting event. (Inherited from ItemCollectionBase.)
RaiseRemoving | Raises the Removing event. (Inherited from ItemCollectionBase.)

See Also

DiagramItemCollection Class


MindFusion.Diagramming.DiagramItemCollection.Clone Method

DiagramItemCollection.Clone Method
[image]

Creates a shallow copy of this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemCollection Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As DiagramItemCollection

Return Value

An instance of the DiagramItemCollection class.

See Also

DiagramItemCollection Members
DiagramItemCollection Class


MindFusion.Diagramming.DiagramItemProperties Class

DiagramItemProperties Class
[image]

The base type for classes that store diagram item properties during undo / redo operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramItemProperties

Visual Basic [image] Copy Code

Public Class DiagramItemProperties

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemProperties
MindFusion.Diagramming.DiagramLinkProperties
MindFusion.Diagramming.DiagramNodeProperties

See Also

DiagramItemProperties Members


MindFusion.Diagramming.DiagramItemProperties Members

DiagramItemProperties Members
Constructors Fields Methods
[image]

The base type for classes that store diagram item properties during undo / redo operations.

The following tables list the members exposed by the DiagramItemProperties type.

Public Constructors

Name | Description
DiagramItemProperties |

Public Fields

Name | Description
ItemClass | For internal use.
Selected | For internal use.
TextPadding | For internal use.
ZIndex | For internal use.

Public Methods

Name | Description
FreeResources | Frees stored resources which will no longer be used.

See Also

DiagramItemProperties Class


MindFusion.Diagramming.DiagramItemProperties Fields

DiagramItemProperties Fields
[image]

Public Fields

Name | Description
ItemClass | For internal use.
Selected | For internal use.
TextPadding | For internal use.
ZIndex | For internal use.

See Also

DiagramItemProperties Class


MindFusion.Diagramming.DiagramItemProperties.ItemClass Field

DiagramItemProperties.ItemClass Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ItemClass

Visual Basic [image] Copy Code

Public ItemClass As String

See Also

DiagramItemProperties Members
DiagramItemProperties Class


MindFusion.Diagramming.DiagramItemProperties.Selected Field

DiagramItemProperties.Selected Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Selected

Visual Basic [image] Copy Code

Public Selected As Boolean

See Also

DiagramItemProperties Members
DiagramItemProperties Class


MindFusion.Diagramming.DiagramItemProperties.TextPadding Field

DiagramItemProperties.TextPadding Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Thickness TextPadding

Visual Basic [image] Copy Code

Public TextPadding As Thickness

See Also

DiagramItemProperties Members
DiagramItemProperties Class


MindFusion.Diagramming.DiagramItemProperties.ZIndex Field

DiagramItemProperties.ZIndex Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ZIndex

Visual Basic [image] Copy Code

Public ZIndex As Integer

See Also

DiagramItemProperties Members
DiagramItemProperties Class


MindFusion.Diagramming.DiagramItemProperties Constructor

DiagramItemProperties Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemProperties ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramItemProperties Class


MindFusion.Diagramming.DiagramItemProperties Methods

DiagramItemProperties Methods
[image]

Public Methods

Name | Description
FreeResources | Frees stored resources which will no longer be used.

See Also

DiagramItemProperties Class


MindFusion.Diagramming.DiagramItemProperties.FreeResources Method

DiagramItemProperties.FreeResources Method
[image]

Frees stored resources which will no longer be used.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void FreeResources ()

Visual Basic [image] Copy Code

Public Overridable Sub FreeResources ()

See Also

DiagramItemProperties Members
DiagramItemProperties Class


MindFusion.Diagramming.DiagramItemState Class

DiagramItemState Class
[image]

Contains a snapshot of the internal state of a diagram item. Instances of this class are used to store the state of items for later undo or redo operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramItemState

Visual Basic [image] Copy Code

Public Class DiagramItemState

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemState
MindFusion.Diagramming.DiagramLinkState
MindFusion.Diagramming.DiagramNodeState

See Also

DiagramItemState Members


MindFusion.Diagramming.DiagramItemState Members

DiagramItemState Members
Constructors
[image]

Contains a snapshot of the internal state of a diagram item. Instances of this class are used to store the state of items for later undo or redo operations.

The following tables list the members exposed by the DiagramItemState type.

Public Constructors

Name | Description
DiagramItemState | Initializes a new instance of the DiagramItemState class.

See Also

DiagramItemState Class


MindFusion.Diagramming.DiagramItemState Constructor

DiagramItemState Constructor
[image]

Initializes a new instance of the DiagramItemState class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemState ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramItemState Class


MindFusion.Diagramming.DiagramItemStyle Class

DiagramItemStyle Class
[image]

Represents a reusable set of properties that define the appearance of diagram items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class DiagramItemStyle : Style

Visual Basic [image] Copy Code

Public MustInherit Class DiagramItemStyle
Inherits Style

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Style
MindFusion.Diagramming.DiagramItemStyle
MindFusion.Diagramming.DiagramLinkStyle
MindFusion.Diagramming.DiagramNodeStyle

See Also

DiagramItemStyle Members


MindFusion.Diagramming.DiagramItemStyle Members

DiagramItemStyle Members
Constructors Properties Methods Events
[image]

Represents a reusable set of properties that define the appearance of diagram items.

The following tables list the members exposed by the DiagramItemStyle type.

Protected Constructors

Name | Description
DiagramItemStyle | Initializes a new instance of the DiagramItemStyle class.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of the item.
FontFamily | Gets or sets the font family of the item text.
FontSize | Gets or sets the font size of the item text.
FontStyle | Gets or sets the font style of the item text.
FontUnit | Gets or sets the font unit of the item text.
ShadowBrush | Gets or sets the brush used to paint the shadow of the item.
Stroke | Gets or sets the brush used to paint the outline of the item.
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items.
StrokeThickness | Gets or sets the thickness of the item's outline, expressed in the current units of measure.
TextBrush | Gets or sets the brush used to paint texts inside the item.

Public Methods

Name | Description
GetProperties | Gets all properties in the style. (Inherited from Style.)
GetProperty | Returns the property with the specified name, if any. (Inherited from Style.)
RegisterType | Associates a type with an alias. (Inherited from Style.)

Protected Methods

Name | Description
GetValue | Gets the value of the specified property. (Inherited from Style.)
IsPropertySet | Checks whether the specified property has a value. (Inherited from Style.)
LoadFrom | Deserializes the item from the specified reader. (Inherited from Style.)
LoadFromXml | Loads the style content from an XML element. (Inherited from Style.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Style.)
RegisterProperty | Registers a new property with the specified name and type. (Inherited from Style.)
SaveTo | Serializes the style to the specified writer. (Inherited from Style.)
SaveToXml | Saves the style content into an XML element. (Inherited from Style.)
SetValue | Sets the value of the specified property. (Inherited from Style.)
UnsetValue | Clears the value of the specified property. (Inherited from Style.)

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

DiagramItemStyle Class


MindFusion.Diagramming.DiagramItemStyle Constructor

DiagramItemStyle Constructor
[image]

Initializes a new instance of the DiagramItemStyle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DiagramItemStyle ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

DiagramItemStyle Class


MindFusion.Diagramming.DiagramItemStyle Properties

DiagramItemStyle Properties
[image]

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of the item.
FontFamily | Gets or sets the font family of the item text.
FontSize | Gets or sets the font size of the item text.
FontStyle | Gets or sets the font style of the item text.
FontUnit | Gets or sets the font unit of the item text.
ShadowBrush | Gets or sets the brush used to paint the shadow of the item.
Stroke | Gets or sets the brush used to paint the outline of the item.
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items.
StrokeThickness | Gets or sets the thickness of the item's outline, expressed in the current units of measure.
TextBrush | Gets or sets the brush used to paint texts inside the item.

See Also

DiagramItemStyle Class


MindFusion.Diagramming.DiagramItemStyle.Brush Property

DiagramItemStyle.Brush Property
[image]

Gets or sets the brush used to fill the interior of the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

See Also

DiagramItemStyle Members
DiagramItemStyle Class


MindFusion.Diagramming.DiagramItemStyle.FontFamily Property

DiagramItemStyle.FontFamily Property
[image]

Gets or sets the font family of the item text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string FontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property FontFamily As String

Property Value

A string value.

See Also

DiagramItemStyle Members
DiagramItemStyle Class


MindFusion.Diagramming.DiagramItemStyle.FontSize Property

DiagramItemStyle.FontSize Property
[image]

Gets or sets the font size of the item text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float FontSize { get; set; }

Visual Basic [image] Copy Code

Public Property FontSize As Single

Property Value

A float value.

See Also

DiagramItemStyle Members
DiagramItemStyle Class


MindFusion.Diagramming.DiagramItemStyle.FontStyle Property

DiagramItemStyle.FontStyle Property
[image]

Gets or sets the font style of the item text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FontStyle FontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property FontStyle As FontStyle

Property Value

One or more of the members of the FontStyle enumeration.

See Also

DiagramItemStyle Members
DiagramItemStyle Class


MindFusion.Diagramming.DiagramItemStyle.FontUnit Property

DiagramItemStyle.FontUnit Property
[image]

Gets or sets the font unit of the item text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GraphicsUnit FontUnit { get; set; }

Visual Basic [image] Copy Code

Public Property FontUnit As GraphicsUnit

Property Value

A member of the GraphicsUnit enumeration.

See Also

DiagramItemStyle Members
DiagramItemStyle Class


MindFusion.Diagramming.DiagramItemStyle.ShadowBrush Property

DiagramItemStyle.ShadowBrush Property
[image]

Gets or sets the brush used to paint the shadow of the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush ShadowBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ShadowBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

See Also

DiagramItemStyle Members
DiagramItemStyle Class


MindFusion.Diagramming.DiagramItemStyle.Stroke Property

DiagramItemStyle.Stroke Property
[image]

Gets or sets the brush used to paint the outline of the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush Stroke { get; set; }

Visual Basic [image] Copy Code

Public Property Stroke As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

See Also

DiagramItemStyle Members
DiagramItemStyle Class


MindFusion.Diagramming.DiagramItemStyle.StrokeDashStyle Property

DiagramItemStyle.StrokeDashStyle Property
[image]

Gets or sets the pattern of dashes and gaps used to outline items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DashStyle StrokeDashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeDashStyle As DashStyle

Property Value

A member of the DashStyle enumeration.

See Also

DiagramItemStyle Members
DiagramItemStyle Class


MindFusion.Diagramming.DiagramItemStyle.StrokeThickness Property

DiagramItemStyle.StrokeThickness Property
[image]

Gets or sets the thickness of the item's outline, expressed in the current units of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double StrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThickness As Double

Property Value

A double value.

See Also

DiagramItemStyle Members
DiagramItemStyle Class


MindFusion.Diagramming.DiagramItemStyle.TextBrush Property

DiagramItemStyle.TextBrush Property
[image]

Gets or sets the brush used to paint texts inside the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush TextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TextBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

See Also

DiagramItemStyle Members
DiagramItemStyle Class


MindFusion.Diagramming.DiagramItemStyle Events

DiagramItemStyle Events
[image]

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

DiagramItemStyle Class


MindFusion.Diagramming.DiagramLink Class

DiagramLink Class
Remarks See Also
[image]

Represents a link between two diagram nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramLink : DiagramItem

Visual Basic [image] Copy Code

Public Class DiagramLink
Inherits DiagramItem

Remarks

Links between nodes in MvcDiagram diagrams are represented by instances of the DiagramLink class. Links connect at most two nodes, which can be accessed with the Origin and Destination properties. If connected to node anchor points, the point indices can be accessed using the OriginAnchor and DestinationAnchor properties. To control whether users are allowed to move link end points, set AllowMoveStart and AllowMoveEnd.

Links are built of smaller parts called segments, which can be straight lines, cascading orthogonal lines or Bйzier curves. The type of segments is set through the Shape property. The number of link's segments is specified by the SegmentCount property. Access to control point locations is provided by the ControlPoints collection.

Usually only the starting and ending segments of a link are updated if the nodes it connects are moved around. Number, orientation and/or position of link segments can change dynamically in various ways depending on the values of AutoRoute, Dynamic and RetainForm. For links of style Cascading, the CascadeOrientation property specifies the orientation of their first segments.

If AutoSnapToNode is enabled, a link automatically aligns its end points to the border of the origin or destination nodes when a user moves the first or last control points. This has a higher priority than aligning to the grid, but a lower priority than aligning to an anchor point.

Links can display distinct arrowhead shapes at their ends. These shapes can be set with the HeadShape and BaseShape properties. The size of the base and arrowhead images is specified through the HeadShapeSize and BaseShapeSize properties. Arrowhead shapes can be displayed in the middle of each segment to facilitate users by distinguishing different links. The type and size of these shapes is set with the IntermediateShape and IntermediateShapeSize properties. The lines of arowhead shapes are painted using the HeadPen pen.

The color of link segments can be specified by the Pen property and the fill color of its base and head shapes with the BaseBrush and HeadBrush properties. The appearance of link's selection handles can be changed using HandlesStyle.

Links can have some text associated with them, displayed as specified via the Text, TextBrush and TextStyle properties. The AddLabel method allows displaying multiple labels per link. Labels can automatically avoid overlapping nodes or other labels when their AutoArrange property is set.

Bounds and Length are informative properties returning respectively link's location and total length.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramLink

See Also

DiagramLink Members


MindFusion.Diagramming.DiagramLink Members

DiagramLink Members
Constructors Fields Properties Methods
[image]

Represents a link between two diagram nodes.

The following tables list the members exposed by the DiagramLink type.

Public Constructors

Name | Description
DiagramLink | Overloaded. Initializes a new instance of the DiagramLink class.

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

Public Properties

Name | Description
AllowMoveEnd | Gets or sets a value indicating whether the user is allowed to move the end point of a link.
AllowMoveStart | Gets or sets a value indicating whether the user is allowed to move the first control point of a link.
AutoRoute | Gets or sets a value indicating whether a link should avoid nodes by going the shortest path from its origin to its destination without crossing any other nodes.
AutoSnapToNode | Specifies whether a link end point should automatically snap to the nearest diagram node while the user moves the point's adjustment handle.
BaseBrush | Gets or sets a brush used to fill the arrowhead drawn at the link base.
BaseShape | Gets or sets what shape to display at the beginning of a link.
BaseShapeSize | Gets or sets the size of the BaseShape shape.
Bounds | Gets the size of the rectangle that bounds this link.
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
CascadeOrientation | Gets or sets the orientation of the first segment of a cascading link.
ControlPoints | Gets a collection of the control points of this link.
CrossingRadius | Gets or sets the radius length of decorations displayed at intersection points of this link.
CustomDraw | Gets or sets the type of custom drawing performed on this link.
Destination | Gets or sets the destination node of this link.
DestinationAnchor | Gets or sets the index of the destination anchor point within the AnchorPattern that contains it.
DestinationConnection | Gets or sets the ConnectionPoint object representing the link connection to its destination node. This allows connecting the link to a constituent part of a node, such as a TableNode row or a TreeViewItem.
DestinationIndex | Gets or sets the index of link's destination anchor point or table row.
DrawCrossings | Gets or sets a value indicating whether the points where this link crosses other links should be drawn as arcs or dashes.
Dynamic | Gets or sets a value indicating whether a link automatically adjusts its end points positions in order to keep pointing to the centers of nodes that it connects.
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectiveHeadPen | Gets the effective head pen of the link.
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
EndPoint | Gets or sets the last control point of a link.
Font | DiagramItem.Font override.
HandlesStyle | Gets or sets the appearance of the link's selection handles.
HeadBrush | Gets or sets a brush used to fill the arrowhead drawn at the link's destination.
HeadPen | Gets or sets the pen to use when painting arrowheads lines.
HeadShape | Gets or sets the shape of this link's arrowhead.
HeadShapeSize | Gets or sets the size of the arrowhead shape.
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IntermediateBrush | Gets or sets a brush used to fill the arrowheads drawn at the middle of link segments.
IntermediateShape | Gets or sets the shape displayed at the middle of each segment of the link.
IntermediateShapeSize | Gets or sets the size of the IntermediateShape shape.
IsConnected | Gets a value indicating whether the link is connected to nodes at both its ends.
Labels | Returns the list of all labels displayed by this link.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D. (Inherited from DiagramItem.)
Length | Gets the length of the link.
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Origin | Gets or sets the origin node of the link.
OriginAnchor | Gets or sets the index of the origin anchor point within the AnchorPattern that contains it.
OriginConnection | Gets or sets the ConnectionPoint object representing the link connection to its origin node. This allows connecting the link to a constituent part of a node, such as a TableNode row or a TreeViewItem.
OriginIndex | Gets or sets the index of link's origin anchor point or table row.
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RetainForm | Gets or sets a value indicating whether a link should maintain its form if the nodes connected with that link are moved around.
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
SegmentCount | Gets or sets the number of segments of this link.
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Shape | Gets or sets the type of link segments and how they are positioned one relatively to another.
StartPoint | Gets or sets the first control point of a link.
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
Text | Gets or sets the text displayed over a link.
TextAlignment | Gets or sets the link's text placement and orientation.
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
TextStyle | Gets or sets the link's text placement and orientation.
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override.
Visible | DiagramItem.Visible override.
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

Public Methods

Name | Description
AddLabel | Overloaded. Adds a label to this link.
Clone | Creates a copy of this link.
ContainsPoint | Overloaded.
Dispose | Overloaded. (Inherited from DiagramItem.)
DoModify | For internal use. (Inherited from DiagramItem.)
Draw | Draws the link on the specified IGraphics surface.
DrawArrowhead | Draws an arrowhead shape.
DrawHandles | DiagramItem.DrawHandles override. Renders the adjustment handles of this item.
DrawShadow | Draws the shadow of this link on the specified IGraphics surface.
GetBounds | DiagramItem.GetBounds override.
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item. (Inherited from DiagramItem.)
GetEffectiveHeadPen | Creates a System.Drawing.Pen object representing the currently effective head pen of the link.
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item. (Inherited from DiagramItem.)
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item. (Inherited from DiagramItem.)
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item. (Inherited from DiagramItem.)
GetLongestHSegment | Returns the index of the longest horizontal segment of this link.
GetOutlinePoly | DiagramItem.GetOutlinePoly override.
GetRepaintRect | DiagramItem.GetRepaintRect override.
GetRotatedBounds | DiagramItem.GetRotatedBounds override.
GetToolTip | Gets the tooltip that should be displayed for this item at the specified point. (Inherited from DiagramItem.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point.
HitTestManipulators | Triggers the manipulator located at the specified point. (Inherited from DiagramItem.)
Intersects | Overloaded.
LabelFromPoint | Returns the label whose layout rectangle contains the specified point.
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnLoad | DiagramItem.OnLoad override.
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Attaches the link end points to the anchor points defined for the link's origin and destination nodes.
RemoveLabel | Removes the specified label from this link.
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
Route | Routes this link, regardless of whether the link's AutoRoute flag is enabled.
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetOrgAndDest | Sets the origin and destination links of this link.
UpdateFromPoints | Overloaded. Updates the link's internal state after the link's control points have been changed.
UpdateIntersections | Aligns the link ends to the contour of the nodes it connects.
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
AllowCreate | DiagramItem.AllowCreate override.
AllowModify | DiagramItem.AllowModify override.
CancelModify | DiagramItem.CancelModify override.
CompleteCreate | DiagramItem.CompleteCreate override.
CompleteModify | DiagramItem.CompleteModify override.
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override.
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
Finalize | DiagramItem finalizer. (Inherited from DiagramItem.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the link content from an XML element.
LoadObsolete | For internal use. (Inherited from DiagramItem.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnClick | Invoked when the user clicks this item. (Inherited from DiagramItem.)
OnDoubleClick | Invoked when the user double-clicks this item. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes.
OnModify | Invoked when the user moves any control point of the link.
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnStyleChanged | Diagramitem.OnStyleChanged override.
OnZoomChanged | Called when the diagram's ZoomFactor changes. (Inherited from DiagramItem.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override.
SaveProperties | DiagramItem.SaveProperties override.
SaveState | DiagramItem.SaveState override.
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the link content into an XML element.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpanded | Sets whether the item is in expanded or collapsed state. (Inherited from DiagramItem.)
SetReference | Updates the reference to the specified object.
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
StartCreate | DiagramItem.StartCreate override.
StartModify | DiagramItem.StartModify override. Invoked when the user starts modifying this item interactively.
UpdateCreate | DiagramItem.UpdateCreate override.
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster. (Inherited from DiagramItem.)
UpdateModify | DiagramItem.UpdateModify override.

See Also

DiagramLink Class


MindFusion.Diagramming.DiagramLink Constructor

DiagramLink Constructor
[image]

Initializes a new instance of the DiagramLink class.

Overload List

Name | Description
DiagramLink (Diagram) | Initializes a new instance of the DiagramLink class with default values supplied form the specified Diagram.
DiagramLink (Diagram, DiagramNode, DiagramNode) | Initializes a new instance of the DiagramLink class between the specified node with default values supplied form the specified Diagram.
DiagramLink (Diagram, DiagramNode, PointF) | Initializes a new instance of the DiagramLink class between the specified node and the specified point with default values supplied form the specified Diagram.
DiagramLink (Diagram, PointF, DiagramNode) | Initializes a new instance of the DiagramLink class between the specified point and the specified node with default values supplied form the specified Diagram.
DiagramLink (Diagram, PointF, PointF) | Initializes a new instance of the DiagramLink class between the specified points with default values supplied form the specified Diagram.
DiagramLink (DiagramLink, DiagramNode, DiagramNode) | Initializes a new instance of the DiagramLink class between the specified nodes using the specified diagram link as a prototype.

See Also

DiagramLink Class


MindFusion.Diagramming.DiagramLink Constructor (Diagram)

DiagramLink Constructor (Diagram)
See Also
[image]

Initializes a new instance of the DiagramLink class with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink (
Diagram parent
)

Visual Basic [image] Copy Code

Public Sub DiagramLink ( _
parent As Diagram _
)

Parameters

parent

The Diagram from which to obtain default values for the link properties.

See Also

DiagramLink Constructor Overload List
DiagramLink Class


MindFusion.Diagramming.DiagramLink Constructor (Diagram, DiagramNode, DiagramNode)

DiagramLink Constructor (Diagram, DiagramNode, DiagramNode)
See Also
[image]

Initializes a new instance of the DiagramLink class between the specified node with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink (
Diagram parent,
DiagramNode origin,
DiagramNode destination
)

Visual Basic [image] Copy Code

Public Sub DiagramLink ( _
parent As Diagram, _
origin As DiagramNode, _
destination As DiagramNode _
)

Parameters

parent

The Diagram from which to obtain default values for the link properties.

origin

The origin node of the new link.

destination

The destination node of the new link.

See Also

DiagramLink Constructor Overload List
DiagramLink Class


MindFusion.Diagramming.DiagramLink Constructor (Diagram, DiagramNode, PointF)

DiagramLink Constructor (Diagram, DiagramNode, PointF)
See Also
[image]

Initializes a new instance of the DiagramLink class between the specified node and the specified point with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink (
Diagram parent,
DiagramNode origin,
PointF destination
)

Visual Basic [image] Copy Code

Public Sub DiagramLink ( _
parent As Diagram, _
origin As DiagramNode, _
destination As PointF _
)

Parameters

parent

The Diagram from which to obtain default values for the link properties.

origin

The origin node of the new link.

destination

The destination point of the new link.

See Also

DiagramLink Constructor Overload List
DiagramLink Class


MindFusion.Diagramming.DiagramLink Constructor (Diagram, PointF, DiagramNode)

DiagramLink Constructor (Diagram, PointF, DiagramNode)
See Also
[image]

Initializes a new instance of the DiagramLink class between the specified point and the specified node with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink (
Diagram parent,
PointF src,
DiagramNode dest
)

Visual Basic [image] Copy Code

Public Sub DiagramLink ( _
parent As Diagram, _
src As PointF, _
dest As DiagramNode _
)

Parameters

parent

The Diagram from which to obtain default values for the link properties.

src

The origin point of the new link.

dest

The destination node of the new link.

See Also

DiagramLink Constructor Overload List
DiagramLink Class


MindFusion.Diagramming.DiagramLink Constructor (Diagram, PointF, PointF)

DiagramLink Constructor (Diagram, PointF, PointF)
See Also
[image]

Initializes a new instance of the DiagramLink class between the specified points with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink (
Diagram parent,
PointF src,
PointF dest
)

Visual Basic [image] Copy Code

Public Sub DiagramLink ( _
parent As Diagram, _
src As PointF, _
dest As PointF _
)

Parameters

parent

The Diagram from which to obtain default values for the link properties.

src

The origin point of the new link.

dest

The destination point of the new link.

See Also

DiagramLink Constructor Overload List
DiagramLink Class


MindFusion.Diagramming.DiagramLink Constructor (DiagramLink, DiagramNode, DiagramNode)

DiagramLink Constructor (DiagramLink, DiagramNode, DiagramNode)
See Also
[image]

Initializes a new instance of the DiagramLink class between the specified nodes using the specified diagram link as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink (
DiagramLink prototype,
DiagramNode src,
DiagramNode dest
)

Visual Basic [image] Copy Code

Public Sub DiagramLink ( _
prototype As DiagramLink, _
src As DiagramNode, _
dest As DiagramNode _
)

Parameters

prototype

The link to use as a prototype. The properties of the new link are initialized from the property values of this link.

src

The origin node of the new link.

dest

The destination node of the new link.

See Also

DiagramLink Constructor Overload List
DiagramLink Class


MindFusion.Diagramming.DiagramLink Methods

DiagramLink Methods
[image]

Public Methods

Name | Description
AddLabel | Overloaded. Adds a label to this link.
Clone | Creates a copy of this link.
ContainsPoint | Overloaded.
Dispose | Overloaded. (Inherited from DiagramItem.)
DoModify | For internal use. (Inherited from DiagramItem.)
Draw | Draws the link on the specified IGraphics surface.
DrawArrowhead | Draws an arrowhead shape.
DrawHandles | DiagramItem.DrawHandles override. Renders the adjustment handles of this item.
DrawShadow | Draws the shadow of this link on the specified IGraphics surface.
GetBounds | DiagramItem.GetBounds override.
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item. (Inherited from DiagramItem.)
GetEffectiveHeadPen | Creates a System.Drawing.Pen object representing the currently effective head pen of the link.
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item. (Inherited from DiagramItem.)
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item. (Inherited from DiagramItem.)
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item. (Inherited from DiagramItem.)
GetLongestHSegment | Returns the index of the longest horizontal segment of this link.
GetOutlinePoly | DiagramItem.GetOutlinePoly override.
GetRepaintRect | DiagramItem.GetRepaintRect override.
GetRotatedBounds | DiagramItem.GetRotatedBounds override.
GetToolTip | Gets the tooltip that should be displayed for this item at the specified point. (Inherited from DiagramItem.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point.
HitTestManipulators | Triggers the manipulator located at the specified point. (Inherited from DiagramItem.)
Intersects | Overloaded.
LabelFromPoint | Returns the label whose layout rectangle contains the specified point.
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnLoad | DiagramItem.OnLoad override.
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Attaches the link end points to the anchor points defined for the link's origin and destination nodes.
RemoveLabel | Removes the specified label from this link.
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
Route | Routes this link, regardless of whether the link's AutoRoute flag is enabled.
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetOrgAndDest | Sets the origin and destination links of this link.
UpdateFromPoints | Overloaded. Updates the link's internal state after the link's control points have been changed.
UpdateIntersections | Aligns the link ends to the contour of the nodes it connects.
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
AllowCreate | DiagramItem.AllowCreate override.
AllowModify | DiagramItem.AllowModify override.
CancelModify | DiagramItem.CancelModify override.
CompleteCreate | DiagramItem.CompleteCreate override.
CompleteModify | DiagramItem.CompleteModify override.
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override.
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
Finalize | DiagramItem finalizer. (Inherited from DiagramItem.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the link content from an XML element.
LoadObsolete | For internal use. (Inherited from DiagramItem.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnClick | Invoked when the user clicks this item. (Inherited from DiagramItem.)
OnDoubleClick | Invoked when the user double-clicks this item. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes.
OnModify | Invoked when the user moves any control point of the link.
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnStyleChanged | Diagramitem.OnStyleChanged override.
OnZoomChanged | Called when the diagram's ZoomFactor changes. (Inherited from DiagramItem.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override.
SaveProperties | DiagramItem.SaveProperties override.
SaveState | DiagramItem.SaveState override.
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the link content into an XML element.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpanded | Sets whether the item is in expanded or collapsed state. (Inherited from DiagramItem.)
SetReference | Updates the reference to the specified object.
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
StartCreate | DiagramItem.StartCreate override.
StartModify | DiagramItem.StartModify override. Invoked when the user starts modifying this item interactively.
UpdateCreate | DiagramItem.UpdateCreate override.
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster. (Inherited from DiagramItem.)
UpdateModify | DiagramItem.UpdateModify override.

See Also

DiagramLink Class


MindFusion.Diagramming.DiagramLink.AddLabel Method

DiagramLink.AddLabel Method
[image]

Adds a label to this link.

Overload List

Name | Description
DiagramLink.AddLabel (LinkLabel) | Adds the specified label to this link.
DiagramLink.AddLabel (String) | Adds a new label to this link.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.AddLabel Method (LinkLabel)

DiagramLink.AddLabel Method (LinkLabel)
See Also
[image]

Adds the specified label to this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AddLabel (
LinkLabel label
)

Visual Basic [image] Copy Code

Public Sub AddLabel( _
label As LinkLabel _
)

Parameters

label

A LinkLabel instance.

See Also

AddLabel Method Overload List
DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.AddLabel Method (String)

DiagramLink.AddLabel Method (String)
See Also
[image]

Adds a new label to this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkLabel AddLabel (
string text
)

Visual Basic [image] Copy Code

Public Function AddLabel( _
text As String _
) As LinkLabel

Parameters

text

The label's text.

Return Value

A LinkLabel instance.

See Also

AddLabel Method Overload List
DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.AllowCreate Method

DiagramLink.AllowCreate Method
[image]

DiagramItem.AllowCreate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual bool AllowCreate (
PointF current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overridable Function AllowCreate ( _
current As PointF, _
ist As InteractionState _
) As Boolean

Parameters

current
The current mouse pointer position.
ist
An InteractionState object containing more information about the current state of the operation.

Return Value

true to allow the creation of this link; otherwise, false.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.AllowModify Method

DiagramLink.AllowModify Method
[image]

DiagramItem.AllowModify override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual bool AllowModify (
PointF current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overridable Function AllowModify ( _
current As PointF, _
ist As InteractionState _
) As Boolean

Parameters

current
The current mouse pointer position.
ist
An InteractionState object containing more information about the current state of the operation.

Return Value

true to allow the modification of this link; otherwise, false.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.CancelModify Method

DiagramLink.CancelModify Method
[image]

DiagramItem.CancelModify override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void CancelModify (
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub CancelModify( _
ist As InteractionState _
)

Parameters

ist

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Clone Method

DiagramLink.Clone Method
[image]

Creates a copy of this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override DiagramItem Clone (
bool clipboard
)

Visual Basic [image] Copy Code

Public Overrides Function Clone( _
clipboard As Boolean _
) As DiagramItem

Parameters

clipboard
true if the copy will be stored in the Windows clipboard; otherwise, false.

Return Value

An instance of the DiagramItem class.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.CompleteCreate Method

DiagramLink.CompleteCreate Method
[image]

DiagramItem.CompleteCreate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void CompleteCreate (
PointF end
)

Visual Basic [image] Copy Code

Protected Overrides Sub CompleteCreate( _
end As PointF _
)

Parameters

end
The mouse pointer position.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.CompleteModify Method

DiagramLink.CompleteModify Method
[image]

DiagramItem.CompleteModify override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void CompleteModify (
PointF end,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overridable Sub CompleteModify ( _
end As PointF, _
ist As InteractionState _
)

Parameters

end
The mouse pointer position.
ist
An InteractionState object containing more information about the current state of the operation.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.ContainsPoint Method

DiagramLink.ContainsPoint Method
[image]

Overload List

Name | Description
DiagramLink.ContainsPoint (PointF) | DiagramItem.ContainsPoint override.
DiagramLink.ContainsPoint (PointF, Single) | DiagramItem.ContainsPoint override.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.ContainsPoint Method (PointF)

DiagramLink.ContainsPoint Method (PointF)
See Also
[image]

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
PointF point
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
point As PointF _
) As Boolean

Parameters

point
The point to check.

Return Value

true it this link contains the specified point; otherwise, false.

See Also

ContainsPoint Method Overload List
DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.ContainsPoint Method (PointF, Single)

DiagramLink.ContainsPoint Method (PointF, Single)
See Also
[image]

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
PointF point,
float threshold
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
point As PointF, _
threshold As Single _
) As Boolean

Parameters

point

A PointF value specifying the logical coordinates of a diagram point.

threshold

Specifies the size of the area around the item outlines where the point is still considered inside the item.

Return Value

true it this item contains the specified point; otherwise, false.

See Also

ContainsPoint Method Overload List
DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.CreateProperties Method

DiagramLink.CreateProperties Method
[image]

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramItemProperties CreateProperties ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateProperties () As DiagramItemProperties

Return Value

A DiagramItemProperties -derived object containing a snapshot of the item's properties.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.CreateState Method

DiagramLink.CreateState Method
[image]

DiagramItem.CreateState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramItemState CreateState ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateState () As DiagramItemState

Return Value

A DiagramLinkState instance.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Draw Method

DiagramLink.Draw Method
[image]

Draws the link on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Draw (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw ( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics
An IGraphics object where the link should be rendered.
options

Provides options for the drawing operation.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.DrawArrowhead Method

DiagramLink.DrawArrowhead Method
[image]

Draws an arrowhead shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void DrawArrowhead (
IGraphics graphics,
Pen pen,
Brush brush,
Shape shape,
PointF pivot,
PointF position,
PointF segmentStart,
float size,
bool shadow
)

Visual Basic [image] Copy Code

Public Shared Sub DrawArrowhead( _
graphics As IGraphics, _
pen As Pen, _
brush As Brush, _
shape As Shape, _
pivot As PointF, _
position As PointF, _
segmentStart As PointF, _
size As Single, _
shadow As Boolean _
)

Parameters

graphics

The graphics surface to draw the shape on.

pen
A Pen instance used to draw the shape outline.
brush
A Brush instance used to fill the shape.
shape
A Shape instance that defines the arrowhead geometry.
pivot
A PointF specified in percents that corresponds to the arrowhead tip position within the Shape geometry.
position

A point on the drawing surface where the arrowhead tip should be located.

segmentStart

A point specifying the arrowhead direction.

size

A double value that specifies the arrowhead size.

shadow

A bool value that specifies if drawing shadow, which causes the passed brush and pen to be used instead of those provided by the shape.

Remarks

This method lets you draw any Shape object at arbitrary position and angle, and is useful for rendering arrowhead shapes when custom-drawing links.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
CustomDraw Property
Diagram.DrawLink Event


MindFusion.Diagramming.DiagramLink.DrawHandles Method

DiagramLink.DrawHandles Method
[image]

DiagramItem.DrawHandles override. Renders the adjustment handles of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawHandles (
IGraphics graphics,
HandlesVisualStyle style,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawHandles( _
graphics As IGraphics, _
style As HandlesVisualStyle, _
options As RenderOptions _
)

Parameters

graphics

The IGraphics surface on which the handles should be drawn.

style

A HandlesVisualStyle instance containing brush and pen objects that should be used when drawing handles.

options

Provides options for the drawing operation.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
HitTestHandle Method
HandlesStyle Property


MindFusion.Diagramming.DiagramLink.DrawShadow Method

DiagramLink.DrawShadow Method
[image]

Draws the shadow of this link on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawShadow (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawShadow ( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics
An IGraphics object where the shadow should be rendered.
options
A RenderOptions object specifying options for the drawing operation.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.GetBounds Method

DiagramLink.GetBounds Method
[image]

DiagramItem.GetBounds override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override RectangleF GetBounds ()

Visual Basic [image] Copy Code

Public Overrides Function GetBounds () As RectangleF

Return Value

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.GetEffectiveHeadPen Method

DiagramLink.GetEffectiveHeadPen Method
[image]

Creates a System.Drawing.Pen object representing the currently effective head pen of the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen GetEffectiveHeadPen ()

Visual Basic [image] Copy Code

Public Function GetEffectiveHeadPen () As Pen

Return Value

A .NET Pen object.

Remarks

This method returns a pen corresponding to the link's HeadPen if the link's HeadPen is not null, or a pen with the HeadStroke and HeadStrokeThickness properties of the link's style. The returned object must be disposed by the caller.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.GetLongestHSegment Method

DiagramLink.GetLongestHSegment Method
[image]

Returns the index of the longest horizontal segment of this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int GetLongestHSegment ()

Visual Basic [image] Copy Code

Public Function GetLongestHSegment () As Integer

Return Value

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.GetOutlinePoly Method

DiagramLink.GetOutlinePoly Method
[image]

DiagramItem.GetOutlinePoly override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override PointCollection GetOutlinePoly (
bool rendering
)

Visual Basic [image] Copy Code

Public Overrides Function GetOutlinePoly( _
rendering As Boolean _
) As PointCollection

Parameters

rendering

Return Value

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.GetRepaintRect Method

DiagramLink.GetRepaintRect Method
[image]

DiagramItem.GetRepaintRect override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override RectangleF GetRepaintRect (
bool includeConnected
)

Visual Basic [image] Copy Code

Public Overrides Function GetRepaintRect( _
includeConnected As Boolean _
) As RectangleF

Parameters

includeConnected
true if related items should be considered too; otherwise, false.

Return Value

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.GetRotatedBounds Method

DiagramLink.GetRotatedBounds Method
[image]

DiagramItem.GetRotatedBounds override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override RectangleF GetRotatedBounds ()

Visual Basic [image] Copy Code

Public Overrides Function GetRotatedBounds () As RectangleF

Return Value

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.HitTestHandle Method

DiagramLink.HitTestHandle Method
[image]

DiagramItem.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override AdjustmentHandle HitTestHandle (
PointF point
)

Visual Basic [image] Copy Code

Public Overrides Function HitTestHandle( _
point As PointF _
) As AdjustmentHandle

Parameters

point

A PointF value specifying where to look for a selection handle.

Return Value

A LinkAdjustmentHandle instance if there is a control point at the specified location, otherwise null.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
DrawHandles Method
HandlesStyle Property


MindFusion.Diagramming.DiagramLink.Intersects Method

DiagramLink.Intersects Method
[image]

Overload List

Name | Description
DiagramLink.Intersects (DiagramLink) | Checks whether this link intersects with the specified link.
DiagramLink.Intersects (DiagramNode) | Checks whether the link contour intersects with the outline of the specified node.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Intersects Method (DiagramLink)

DiagramLink.Intersects Method (DiagramLink)
See Also
[image]

Checks whether this link intersects with the specified link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Intersects (
DiagramLink link
)

Visual Basic [image] Copy Code

Public Function Intersects( _
link As DiagramLink _
) As Boolean

Parameters

link

Return Value

See Also

Intersects Method Overload List
DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Intersects Method (DiagramNode)

DiagramLink.Intersects Method (DiagramNode)
See Also
[image]

Checks whether the link contour intersects with the outline of the specified node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Intersects (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Function Intersects ( _
node As DiagramNode _
) As Boolean

Parameters

node
A DiagramNode object for which to determine whether the link intersects it.

Return Value

true if the link intersects the node; otherwise, false.

See Also

Intersects Method Overload List
DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.LabelFromPoint Method

DiagramLink.LabelFromPoint Method
[image]

Returns the label whose layout rectangle contains the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkLabel LabelFromPoint (
PointF point
)

Visual Basic [image] Copy Code

Public Function LabelFromPoint( _
point As PointF _
) As LinkLabel

Parameters

point

A PointF instance.

Return Value

The LinkLabel that contains the specified point.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.LoadFrom Method

DiagramLink.LoadFrom Method
[image]

Deserializes the object from the specified reader.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFrom (
BinaryReader reader,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFrom ( _
reader As BinaryReader, _
context As PersistContext _
)

Parameters

reader
A BinaryReader object from which to read the link's data.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.LoadFromXml Method

DiagramLink.LoadFromXml Method
[image]

Loads the link content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFromXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement containing the item's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.OnLoad Method

DiagramLink.OnLoad Method
[image]

DiagramItem.OnLoad override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void OnLoad ()

Visual Basic [image] Copy Code

Public Overrides Sub OnLoad ()

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.OnMeasureUnitChanged Method

DiagramLink.OnMeasureUnitChanged Method
[image]

Called when the Diagram's MeasureUnit changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnMeasureUnitChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnMeasureUnitChanged ()

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.OnModify Method

DiagramLink.OnModify Method
[image]

Invoked when the user moves any control point of the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnModify (
PointF mousePosition,
int adjustmentHandle
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnModify( _
mousePosition As PointF, _
adjustmentHandle As Integer _
)

Parameters

mousePosition

Specifies the mouse position.

adjustmentHandle

Specifies the adjustment handle used to modify the link.

Remarks

Implement this method in a custom link class if you need to detect modifications done by the user without handling events of the Diagram class.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.OnStyleChanged Method

DiagramLink.OnStyleChanged Method
[image]

Diagramitem.OnStyleChanged override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnStyleChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnStyleChanged ()

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.ReassignAnchorPoints Method

DiagramLink.ReassignAnchorPoints Method
[image]

Attaches the link end points to the anchor points defined for the link's origin and destination nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ReassignAnchorPoints ()

Visual Basic [image] Copy Code

Public Sub ReassignAnchorPoints ()

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.RemoveLabel Method

DiagramLink.RemoveLabel Method
[image]

Removes the specified label from this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RemoveLabel (
LinkLabel label
)

Visual Basic [image] Copy Code

Public Sub RemoveLabel( _
label As LinkLabel _
)

Parameters

label

A LinkLabel instance.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.RestoreProperties Method

DiagramLink.RestoreProperties Method
[image]

DiagramItem.RestoreProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overridable Sub RestoreProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties -derived object containing a snapshot of the item's properties.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.RestoreState Method

DiagramLink.RestoreState Method
[image]

DiagramItem.RestoreState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void RestoreState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Overridable Sub RestoreState ( _
state As DiagramItemState _
)

Parameters

state
A DiagramLinkState instance.

Remarks

This method is called when a link should be restored to the state it had before user interaction.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Route Method

DiagramLink.Route Method
[image]

Routes this link, regardless of whether the link's AutoRoute flag is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Route ()

Visual Basic [image] Copy Code

Public Function Route () As Boolean

Return Value

true is a route has been successfully found; otherwise, false.

Remarks

Routing may fail if there is a large background node whose Obstacle property is enabled, or if the value of RoutingOptions.GridSize is too big for the average distance between adjacent nodes in the diagram.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.SaveProperties Method

DiagramLink.SaveProperties Method
[image]

DiagramItem.SaveProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties -derived object containing a snapshot of the item's properties.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.SaveState Method

DiagramLink.SaveState Method
[image]

DiagramItem.SaveState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveState ( _
state As DiagramItemState _
)

Parameters

state
A DiagramLinkState instance.

Remarks

This method is called to save undo information when the users starts modifying a link.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.SaveTo Method

DiagramLink.SaveTo Method
[image]

Serializes the object to the specified writer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveTo (
BinaryWriter writer,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveTo ( _
writer As BinaryWriter, _
context As PersistContext _
)

Parameters

writer
A BinaryWriter object the link's data should be written to.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.SaveToXml Method

DiagramLink.SaveToXml Method
[image]

Saves the link content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveToXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement the link's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.SetOrgAndDest Method

DiagramLink.SetOrgAndDest Method
[image]

Sets the origin and destination links of this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetOrgAndDest (
ConnectionPoint orgConnectionPoint,
ConnectionPoint trgConnectionPoint
)

Visual Basic [image] Copy Code

Public Sub SetOrgAndDest( _
orgConnectionPoint As ConnectionPoint, _
trgConnectionPoint As ConnectionPoint _
)

Parameters

orgConnectionPoint

trgConnectionPoint

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.SetReference Method

DiagramLink.SetReference Method
[image]

Updates the reference to the specified object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SetReference (
int refId,
Object obj,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub SetReference( _
refId As Integer, _
obj As Object, _
context As PersistContext _
)

Parameters

refId
Reference identifier.
obj
The newly loaded object.
context

A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

This method is called for references that had been saved using the SaveReference method.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.StartCreate Method

DiagramLink.StartCreate Method
[image]

DiagramItem.StartCreate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void StartCreate (
PointF org
)

Visual Basic [image] Copy Code

Protected Overrides Sub StartCreate( _
org As PointF _
)

Parameters

org
Position of the mouse pointer.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.StartModify Method

DiagramLink.StartModify Method
[image]

DiagramItem.StartModify override. Invoked when the user starts modifying this item interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void StartModify (
PointF org,
AdjustmentHandle handle,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub StartModify( _
org As PointF, _
handle As AdjustmentHandle, _
ist As InteractionState _
)

Parameters

org

Position of the mouse pointer.

handle

The adjustment handle used to modify this link.

ist

An InteractionState object containing more information about the current state of the operation.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.UpdateCreate Method

DiagramLink.UpdateCreate Method
[image]

DiagramItem.UpdateCreate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void UpdateCreate (
PointF current
)

Visual Basic [image] Copy Code

Protected Overrides Sub UpdateCreate( _
current As PointF _
)

Parameters

current
Position of the mouse pointer.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.UpdateFromPoints Method

DiagramLink.UpdateFromPoints Method
[image]

Updates the link's internal state after the link's control points have been changed.

Overload List

Name | Description
DiagramLink.UpdateFromPoints () | Updates the link's internal state after the link's control points have been changed.
DiagramLink.UpdateFromPoints (Boolean) | Updates the link's internal state after the link's control points have been changed.
DiagramLink.UpdateFromPoints (Boolean, Boolean) | Updates the link's internal state after the link's control points have been changed.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.UpdateFromPoints Method ()

DiagramLink.UpdateFromPoints Method ()
See Also
[image]

Updates the link's internal state after the link's control points have been changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void UpdateFromPoints ()

Visual Basic [image] Copy Code

Public Sub UpdateFromPoints ()

See Also

UpdateFromPoints Method Overload List
DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.UpdateFromPoints Method (Boolean)

DiagramLink.UpdateFromPoints Method (Boolean)
See Also
[image]

Updates the link's internal state after the link's control points have been changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void UpdateFromPoints (
bool updateGroups
)

Visual Basic [image] Copy Code

Public Sub UpdateFromPoints( _
updateGroups As Boolean _
)

Parameters

updateGroups

true to update the positions of nodes attached to the link; otherwise, false.

See Also

UpdateFromPoints Method Overload List
DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.UpdateFromPoints Method (Boolean, Boolean)

DiagramLink.UpdateFromPoints Method (Boolean, Boolean)
See Also
[image]

Updates the link's internal state after the link's control points have been changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void UpdateFromPoints (
bool updateGroups,
bool updateSegmentCount
)

Visual Basic [image] Copy Code

Public Sub UpdateFromPoints( _
updateGroups As Boolean, _
updateSegmentCount As Boolean _
)

Parameters

updateGroups

true to update the positions of nodes attached to the link; otherwise, false.

updateSegmentCount

true to update the SegmentCount property based on the number of points in the collection.

See Also

UpdateFromPoints Method Overload List
DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.UpdateIntersections Method

DiagramLink.UpdateIntersections Method
[image]

Aligns the link ends to the contour of the nodes it connects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void UpdateIntersections ()

Visual Basic [image] Copy Code

Public Sub UpdateIntersections ()

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.UpdateModify Method

DiagramLink.UpdateModify Method
[image]

DiagramItem.UpdateModify override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void UpdateModify (
PointF current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overridable Sub UpdateModify ( _
current As PointF, _
ist As InteractionState _
)

Parameters

current
Position of the mouse pointer.
ist
An InteractionState object containing more information about the current state of the operation.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink Properties

DiagramLink Properties
[image]

Public Properties

Name | Description
AllowMoveEnd | Gets or sets a value indicating whether the user is allowed to move the end point of a link.
AllowMoveStart | Gets or sets a value indicating whether the user is allowed to move the first control point of a link.
AutoRoute | Gets or sets a value indicating whether a link should avoid nodes by going the shortest path from its origin to its destination without crossing any other nodes.
AutoSnapToNode | Specifies whether a link end point should automatically snap to the nearest diagram node while the user moves the point's adjustment handle.
BaseBrush | Gets or sets a brush used to fill the arrowhead drawn at the link base.
BaseShape | Gets or sets what shape to display at the beginning of a link.
BaseShapeSize | Gets or sets the size of the BaseShape shape.
Bounds | Gets the size of the rectangle that bounds this link.
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
CascadeOrientation | Gets or sets the orientation of the first segment of a cascading link.
ControlPoints | Gets a collection of the control points of this link.
CrossingRadius | Gets or sets the radius length of decorations displayed at intersection points of this link.
CustomDraw | Gets or sets the type of custom drawing performed on this link.
Destination | Gets or sets the destination node of this link.
DestinationAnchor | Gets or sets the index of the destination anchor point within the AnchorPattern that contains it.
DestinationConnection | Gets or sets the ConnectionPoint object representing the link connection to its destination node. This allows connecting the link to a constituent part of a node, such as a TableNode row or a TreeViewItem.
DestinationIndex | Gets or sets the index of link's destination anchor point or table row.
DrawCrossings | Gets or sets a value indicating whether the points where this link crosses other links should be drawn as arcs or dashes.
Dynamic | Gets or sets a value indicating whether a link automatically adjusts its end points positions in order to keep pointing to the centers of nodes that it connects.
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectiveHeadPen | Gets the effective head pen of the link.
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
EndPoint | Gets or sets the last control point of a link.
Font | DiagramItem.Font override.
HandlesStyle | Gets or sets the appearance of the link's selection handles.
HeadBrush | Gets or sets a brush used to fill the arrowhead drawn at the link's destination.
HeadPen | Gets or sets the pen to use when painting arrowheads lines.
HeadShape | Gets or sets the shape of this link's arrowhead.
HeadShapeSize | Gets or sets the size of the arrowhead shape.
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IntermediateBrush | Gets or sets a brush used to fill the arrowheads drawn at the middle of link segments.
IntermediateShape | Gets or sets the shape displayed at the middle of each segment of the link.
IntermediateShapeSize | Gets or sets the size of the IntermediateShape shape.
IsConnected | Gets a value indicating whether the link is connected to nodes at both its ends.
Labels | Returns the list of all labels displayed by this link.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D. (Inherited from DiagramItem.)
Length | Gets the length of the link.
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Origin | Gets or sets the origin node of the link.
OriginAnchor | Gets or sets the index of the origin anchor point within the AnchorPattern that contains it.
OriginConnection | Gets or sets the ConnectionPoint object representing the link connection to its origin node. This allows connecting the link to a constituent part of a node, such as a TableNode row or a TreeViewItem.
OriginIndex | Gets or sets the index of link's origin anchor point or table row.
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RetainForm | Gets or sets a value indicating whether a link should maintain its form if the nodes connected with that link are moved around.
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
SegmentCount | Gets or sets the number of segments of this link.
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Shape | Gets or sets the type of link segments and how they are positioned one relatively to another.
StartPoint | Gets or sets the first control point of a link.
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
Text | Gets or sets the text displayed over a link.
TextAlignment | Gets or sets the link's text placement and orientation.
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
TextStyle | Gets or sets the link's text placement and orientation.
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override.
Visible | DiagramItem.Visible override.
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

See Also

DiagramLink Class


MindFusion.Diagramming.DiagramLink.AllowMoveEnd Property

DiagramLink.AllowMoveEnd Property
[image]

Gets or sets a value indicating whether the user is allowed to move the end point of a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowMoveEnd { get; set; }

Visual Basic [image] Copy Code

Public Property AllowMoveEnd As Boolean

Property Value

true to enable users to move the end point of the link; otherwise, false. Initialized with the value of LinkEndsMovable.

Remarks

Set the property to false to prevent the link destination to be changed interactively. Alternatively, you might handle the LinkModifying event to implement selective validation of attaching a link to different diagram nodes.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
AllowMoveStart Property
Diagram.LinkEndsMovable Property


MindFusion.Diagramming.DiagramLink.AllowMoveStart Property

DiagramLink.AllowMoveStart Property
[image]

Gets or sets a value indicating whether the user is allowed to move the first control point of a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowMoveStart { get; set; }

Visual Basic [image] Copy Code

Public Property AllowMoveStart As Boolean

Property Value

true to enable users to move the start point of the link; otherwise false. Initialized with the value of LinkEndsMovable.

Remarks

Set the property to false to prevent the link origin to be changed interactively. Alternatively, you might handle the LinkModifying event to implement selective validation of attaching a link to different diagram nodes.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
AllowMoveEnd Property
Diagram.LinkEndsMovable Property


MindFusion.Diagramming.DiagramLink.AutoRoute Property

DiagramLink.AutoRoute Property
[image]

Gets or sets a value indicating whether a link should avoid nodes by going the shortest path from its origin to its destination without crossing any other nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoRoute { get; set; }

Visual Basic [image] Copy Code

Public Property AutoRoute As Boolean

Property Value

true to route this link; otherwise, false. Initialized with the value of RouteLinks.

Remarks

If AutoRoute is enabled, a link automatically finds the shortest possible path between its origin and destination that doesn't intersect Obstacle nodes. The number and orientation of the link's segments are updated when the nodes it links are moved around. The positions of end points of a routed link are not changed, unless the link is also set to Dynamic.

It is best to use AutoRoute with links of the Cascading style. Note that automatic routing overrides the RetainForm behavior.

Performance note

Links whose AutoRoute property is enabled are re-routed if they intersect with newly created nodes. Thus when constructing a large diagram programmatically, each link might be re-routed many times, once for each newly added node whose location arguments collide with link's bounding rectangle. That might slow down diagram creation a lot. To avoid it, first create all nodes, and afterwards the link; that requires a single calculation for each link's route.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
RoutingOptions Class
Dynamic Property
SegmentCount Property


MindFusion.Diagramming.DiagramLink.AutoSnapToNode Property

DiagramLink.AutoSnapToNode Property
[image]

Specifies whether a link end point should automatically snap to the nearest diagram node while the user moves the point's adjustment handle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoSnapToNode { get; set; }

Visual Basic [image] Copy Code

Public Property AutoSnapToNode As Boolean

Property Value

true to snap links to nearest node; otherwise, false. Initialized with the value of AutoSnapLinks.

Remarks

Only nodes at a distance smaller than AutoSnapDistance are considered. A link does not snap to its current origin or destination nodes if that would create a self-loop. If there is an AnchorPattern assigned to a node, the link snaps to an anchor point instead of a border point.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
Dynamic Property
RetainForm Property


MindFusion.Diagramming.DiagramLink.BaseBrush Property

DiagramLink.BaseBrush Property
[image]

Gets or sets a brush used to fill the arrowhead drawn at the link base.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush BaseBrush { get; set; }

Visual Basic [image] Copy Code

Public Property BaseBrush As Brush

Property Value

An instance of a Brush -derived class. The default value is null (Nothing in Visual Basic).

Remarks

If this property is not set, the arrowhead is filled using the link's Brush.

See Also

DiagramLink Members
DiagramLink Class
BaseShape Property


MindFusion.Diagramming.DiagramLink.BaseShape Property

DiagramLink.BaseShape Property
[image]

Gets or sets what shape to display at the beginning of a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape BaseShape { get; set; }

Visual Basic [image] Copy Code

Public Property BaseShape As Shape

Property Value

A Shape instance that represents an arrowhead shape. Initialized with the value of LinkBaseShape.

Remarks

The property specifies the shape that is displayed at the beginning of a link, that is, the point where it is connected with its Origin node. This shape is rotated simultaneously with the first segment of the link so that it follows the overall link direction.

The ArrowHeads class exposes several predefined shapes as static properties.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
HeadShape Property
IntermediateShape Property
BaseBrush Property
BaseShapeSize Property


MindFusion.Diagramming.DiagramLink.BaseShapeSize Property

DiagramLink.BaseShapeSize Property
[image]

Gets or sets the size of the BaseShape shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float BaseShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property BaseShapeSize As Single

Property Value

A float value that specifies the shape size. Initialized with the value of LinkBaseShapeSize.

Remarks

The property specifies how big is the shape that is displayed at the origin of a link.

See Also

DiagramLink Members
DiagramLink Class
BaseShape Property


MindFusion.Diagramming.DiagramLink.Bounds Property

DiagramLink.Bounds Property
[image]

Gets the size of the rectangle that bounds this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As RectangleF

Property Value

A .NET RectangleF that represents the bounding rectangle.

Remarks

Use the property to get the smallest rectangle that bounds all link points.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.CascadeOrientation Property

DiagramLink.CascadeOrientation Property
[image]

Gets or sets the orientation of the first segment of a cascading link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation CascadeOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property CascadeOrientation As Orientation

Property Value

A member of the Orientation enumeration.

Remarks

Use this property to specify the orientation of the first segment of a link whose Shape is set to Cascading. See Orientation for more details. The orientation of the first segment defines the orientation of all other segments in the cascade, because each next segment changes its orientation alternately to the previous one.

If the property is set to Auto, users may change the orientation of a cascading link interactively. That can be done by dragging the control point next to the first or last one to its opposite corner in the rectangle defined by its two adjacent segments. Depending on the value of AllowSplitLinks, the link orientation is changed by either inserting a new segment and changing only the orientation of the first or last segment (AllowSplitLinks is true), or by changing the orientation of all segments of the link (AllowSplitLinks is false).

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
Diagram.LinkCascadeOrientation Property
Shape Property


MindFusion.Diagramming.DiagramLink.ControlPoints Property

DiagramLink.ControlPoints Property
[image]

Gets a collection of the control points of this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointCollection ControlPoints { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ControlPoints As PointCollection

Property Value

A collection of control points that specify the link's shape.

Remarks

You can specify new positions of a link's points through that property. The number of points in the collection depends on the Shape and SegmentCount of the link. Links made of Bйzier-splines has four control points for each segment. Links of the other styles have two control points per segment. Adjacent segments share a common control point. Check the Count property of the collection to get the number of points. After setting new positions of control points you must call the UpdateFromPoints method.

Example

The following example demonstrates how to programmatically setup the control points of a link:

C# [image] Copy Code

DiagramLink link;
PointF cpt;

link = Diagram.Links[0];

// Move the second and the third points
cpt = link.ControlPoints[1];
link.ControlPoints[1] = new PointF(cpt.X + 5, cpt.Y);
link.ControlPoints[2] = new PointF(22.2f, 33.3f);

// Update state and redraw
link.UpdateFromPoints();

Visual Basic [image] Copy Code

Dim link As DiagramLink
Dim cpt As PointF

link = diagram.Links(0)

' Move the second and the third points
cpt = link.ControlPoints(1)
link.ControlPoints(1) = New PointF(cpt.X + 5, cpt.Y)
link.ControlPoints(2) = New PointF(22.2, 33.3)

' Update state and redraw
link.UpdateFromPoints()

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
UpdateFromPoints Method
StartPoint Property
EndPoint Property


MindFusion.Diagramming.DiagramLink.CrossingRadius Property

DiagramLink.CrossingRadius Property
[image]

Gets or sets the radius length of decorations displayed at intersection points of this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float CrossingRadius { get; set; }

Visual Basic [image] Copy Code

Public Property CrossingRadius As Single

Property Value

A float value specifying the radius of arcs or cuts displayed at the intersection points of this link. The default is 0.

Remarks

If this property is set to 0, the control uses the value of the Diagram.CrossingRadius property.

See Also

DiagramLink Members
DiagramLink Class
DrawCrossings Property


MindFusion.Diagramming.DiagramLink.CustomDraw Property

DiagramLink.CustomDraw Property
[image]

Gets or sets the type of custom drawing performed on this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CustomDraw CustomDraw { get; set; }

Visual Basic [image] Copy Code

Public Property CustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. Initialized with the value of LinkCustomDraw.

Remarks

This property allows invoking custom painting code for a link. That code must execute in response to the DrawLink event. There are several modes of custom painting, allowing the custom code to paint the link entirely, or do that in addition to what MvcDiagram paints by default. The following CustomDraw members can be assigned to this property to specify the custom painting mode:

Member name | Description
None | Do not perform custom drawing, let all painting be done by MvcDiagram.
Additional | The custom painting code executes after the link segments and arrowhead shapes are painted by MvcDiagram, but before text is rendered.
Full | The component does not do any standard drawing, the entire painting of the link is done by the application.
ShadowOnly | Only the shadow of the link is painted by custom code, the link itself is drawn by the component.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Destination Property

DiagramLink.Destination Property
[image]

Gets or sets the destination node of this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Destination { get; set; }

Visual Basic [image] Copy Code

Public Property Destination As DiagramNode

Property Value

A reference to the destination DiagramNode of the link.

Remarks

The link's destination can be changed programmatically with this property. If any of the connected nodes has an AnchorPattern defined, links ends are placed at the nearest anchor points of the two nodes. If AutoRoute is enabled, the link is routed when changing its origin or destination.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
Origin Property
DestinationAnchor Property
Query Method


MindFusion.Diagramming.DiagramLink.DestinationAnchor Property

DiagramLink.DestinationAnchor Property
[image]

Gets or sets the index of the destination anchor point within the AnchorPattern that contains it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int DestinationAnchor { get; set; }

Visual Basic [image] Copy Code

Public Property DestinationAnchor As Integer

Property Value

An integer index of an anchor point within the AnchorPattern containing it.

Remarks

Specifies the index of an anchor point contained within the Destination anchor pattern. The link is docked and stay connected to that point if the node is moved or resized.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
OriginAnchor Property
Diagram.DestinationAnchorChanged Event


MindFusion.Diagramming.DiagramLink.DestinationConnection Property

DiagramLink.DestinationConnection Property
[image]

Gets or sets the ConnectionPoint object representing the link connection to its destination node. This allows connecting the link to a constituent part of a node, such as a TableNode row or a TreeViewItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ConnectionPoint DestinationConnection { get; set; }

Visual Basic [image] Copy Code

Public Property DestinationConnection As ConnectionPoint

Property Value

An instance of ConnectionPoint or a derived class.

See Also

DiagramLink Members
DiagramLink Class
Destination Property


MindFusion.Diagramming.DiagramLink.DestinationIndex Property

DiagramLink.DestinationIndex Property
[image]

Gets or sets the index of link's destination anchor point or table row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int DestinationIndex { get; set; }

Visual Basic [image] Copy Code

Public Property DestinationIndex As Integer

Property Value

An integer value specifying the index of table's row or the index of an anchor point within its containing AnchorPattern.

Remarks

If a link's destination is a shape node, this property lets you get or set the index of an anchor point at which the link docks to the node. If there is no AnchorPattern defined for the destination node, the property returns -1. If the link is connected to a table, the property returns or changes the related row of that table.

See Also

DiagramLink Members
DiagramLink Class
OriginIndex Property


MindFusion.Diagramming.DiagramLink.DrawCrossings Property

DiagramLink.DrawCrossings Property
[image]

Gets or sets a value indicating whether the points where this link crosses other links should be drawn as arcs or dashes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool DrawCrossings { get; set; }

Visual Basic [image] Copy Code

Public Property DrawCrossings As Boolean

Property Value

true if crossing points should be drawn as arcs or dashes; otherwise, false. The default is true.

Remarks

The LinkCrossings property of the Diagram class specifies what shapes are drawn at link crossing points. Individual links cannot display shapes different from the ones drawn for other links, but the crossing points shapes can be shown or hidden for a link through this property.

See Also

DiagramLink Members
DiagramLink Class
CrossingRadius Property


MindFusion.Diagramming.DiagramLink.Dynamic Property

DiagramLink.Dynamic Property
[image]

Gets or sets a value indicating whether a link automatically adjusts its end points positions in order to keep pointing to the centers of nodes that it connects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Dynamic { get; set; }

Visual Basic [image] Copy Code

Public Property Dynamic As Boolean

Property Value

true to make the link automatically adjust its end points; otherwise, false. Initialized with the value of DynamicLinks.

Remarks

Use the property to specify whether a link automatically repositions its end segments, so they keep pointing to the centers of nodes connected by that link. If enabled, moving a connected node recalculates the position of link's end point, placing it at appropriate location of the node outline. If the node has anchor points assigned to it, the end point is attached to one of them. End points are realigned also when moving the points next to them.

See Also

DiagramLink Members
DiagramLink Class
RetainForm Property


MindFusion.Diagramming.DiagramLink.EffectiveHeadPen Property

DiagramLink.EffectiveHeadPen Property
[image]

Gets the effective head pen of the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen EffectiveHeadPen { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EffectiveHeadPen As Pen

Property Value

An instance of the MindFusion.Drawing.Pen class.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.EndPoint Property

DiagramLink.EndPoint Property
[image]

Gets or sets the last control point of a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointF EndPoint { get; set; }

Visual Basic [image] Copy Code

Public Property EndPoint As PointF

Property Value

A .NET PointF object.

Remarks

This property is a shortcut for getting or setting the last element of ControlPoints.

See Also

DiagramLink Members
DiagramLink Class
StartPoint Property


MindFusion.Diagramming.DiagramLink.Font Property

DiagramLink.Font Property
[image]

DiagramItem.Font override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Font Font { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Font As Font

Property Value

The .NET Font to use when drawing the link's text.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.HandlesStyle Property

DiagramLink.HandlesStyle Property
[image]

Gets or sets the appearance of the link's selection handles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HandlesStyle HandlesStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HandlesStyle As HandlesStyle

Property Value

A member of the HandlesStyle enumeration. Initialized with the value of LinkHandlesStyle.

Remarks

Specifies how link's selection status is indicated visually. You can choose between the following styles:

Member name | Description
SquareHandles | The selection is indicated by drawing square handles at the position of each control point.
DashFrame | The selection is indicated by drawing dashed line segments along the link's segments. In addition, there are square selection handles drawn at the location of each control point of the link.
Custom | MvcDiagram raises the DrawAdjustmentHandles events to let your application perform custom drawing of link's selection handles.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
DrawHandles Method
HitTestHandle Method


MindFusion.Diagramming.DiagramLink.HeadBrush Property

DiagramLink.HeadBrush Property
[image]

Gets or sets a brush used to fill the arrowhead drawn at the link's destination.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush HeadBrush { get; set; }

Visual Basic [image] Copy Code

Public Property HeadBrush As Brush

Property Value

An instance of a Brush -derived class. The default value is null (Nothing in Visual Basic).

Remarks

If this property is not set, the arrowhead is filled using the link's Brush.

See Also

DiagramLink Members
DiagramLink Class
HeadShape Property


MindFusion.Diagramming.DiagramLink.HeadPen Property

DiagramLink.HeadPen Property
[image]

Gets or sets the pen to use when painting arrowheads lines.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen HeadPen { get; set; }

Visual Basic [image] Copy Code

Public Property HeadPen As Pen

Property Value

An instance of the MindFusion.Drawing.Pen class. Initialized with a clone of LinkPen.

Remarks

This property refers to a pen used to paint arrowhead lines. To change how segment lines are painted, use the Pen property.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
Brush and Pen Classes
Brush Property


MindFusion.Diagramming.DiagramLink.HeadShape Property

DiagramLink.HeadShape Property
[image]

Gets or sets the shape of this link's arrowhead.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape HeadShape { get; set; }

Visual Basic [image] Copy Code

Public Property HeadShape As Shape

Property Value

A Shape instance that represents an arrowhead shape. Initialized with the value of LinkHeadShape.

Remarks

The property specifies what shape is displayed as an arrowhead. This shape is rotated simultaneously with the last segment of the link so that it follows the overall link direction.

The ArrowHeads class exposes several predefined shapes as static properties.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
BaseShape Property
IntermediateShape Property
HeadBrush Property
HeadShapeSize Property


MindFusion.Diagramming.DiagramLink.HeadShapeSize Property

DiagramLink.HeadShapeSize Property
[image]

Gets or sets the size of the arrowhead shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float HeadShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property HeadShapeSize As Single

Property Value

A float value that measures the size. Initialized with the value of LinkHeadShapeSize.

Remarks

The property specifies how big the shape of the arrowhead is.

See Also

DiagramLink Members
DiagramLink Class
HeadShape Property


MindFusion.Diagramming.DiagramLink.IntermediateBrush Property

DiagramLink.IntermediateBrush Property
[image]

Gets or sets a brush used to fill the arrowheads drawn at the middle of link segments.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush IntermediateBrush { get; set; }

Visual Basic [image] Copy Code

Public Property IntermediateBrush As Brush

Property Value

An instance of a Brush -derived class. The default value is null (Nothing in Visual Basic).

Remarks

If this property is not set, the arrowheads are filled using the link's Brush.

See Also

DiagramLink Members
DiagramLink Class
IntermediateShape Property


MindFusion.Diagramming.DiagramLink.IntermediateShape Property

DiagramLink.IntermediateShape Property
[image]

Gets or sets the shape displayed at the middle of each segment of the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape IntermediateShape { get; set; }

Visual Basic [image] Copy Code

Public Property IntermediateShape As Shape

Property Value

A Shape instance that represents an arrowhead shape. Initialized with the value of LinkIntermediateShape.

Remarks

The property specifies what shape to display at the middle of each segment of a link. This could help users to see more easily the direction of long links. The ArrowHeads class exposes several predefined shapes as static properties.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
HeadShape Property
BaseShape Property
IntermediateBrush Property
IntermediateShapeSize Property


MindFusion.Diagramming.DiagramLink.IntermediateShapeSize Property

DiagramLink.IntermediateShapeSize Property
[image]

Gets or sets the size of the IntermediateShape shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float IntermediateShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property IntermediateShapeSize As Single

Property Value

A float value that measures the size. Initialized with the value of LinkIntermediateShapeSize.

Remarks

The property specifies how big are the shapes that are displayed in the middle of link segments.

See Also

DiagramLink Members
DiagramLink Class
IntermediateShape Property


MindFusion.Diagramming.DiagramLink.IsConnected Property

DiagramLink.IsConnected Property
[image]

Gets a value indicating whether the link is connected to nodes at both its ends.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsConnected { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsConnected As Boolean

Property Value

true to indicate that both ends of the link are connected to nodes; otherwise, false.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Labels Property

DiagramLink.Labels Property
[image]

Returns the list of all labels displayed by this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<LinkLabel> Labels { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Labels As List(Of LinkLabel)

Property Value

A list with all link labels.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Length Property

DiagramLink.Length Property
[image]

Gets the length of the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Length { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Length As Single

Property Value

A float value that represents the total length of the link, sum of the lengths of all its segments.

Remarks

If the link's Shape is set to Bezier, an approximate length is calculated. In that case, the approximate value is almost always slightly smaller than the real length of Bйzier segments.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
Shape Property
SegmentCount Property


MindFusion.Diagramming.DiagramLink.Origin Property

DiagramLink.Origin Property
[image]

Gets or sets the origin node of the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Origin { get; set; }

Visual Basic [image] Copy Code

Public Property Origin As DiagramNode

Property Value

A reference to the origin DiagramNode of the link.

Remarks

The link's origin can be changed programmatically with this property. If any of the connected nodes has an AnchorPattern defined, links ends are placed at the nearest anchor points of the two nodes. If AutoRoute is enabled, the link is routed when changing its origin or destination.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
Destination Property
OriginAnchor Property
Query Method


MindFusion.Diagramming.DiagramLink.OriginAnchor Property

DiagramLink.OriginAnchor Property
[image]

Gets or sets the index of the origin anchor point within the AnchorPattern that contains it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int OriginAnchor { get; set; }

Visual Basic [image] Copy Code

Public Property OriginAnchor As Integer

Property Value

An integer index of an anchor point within its the AnchorPattern containing it.

Remarks

Specifies the index of an anchor point contained within the Origin anchor pattern. The link is docked and stay connected to that point if the node is moved or resized.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
DestinationAnchor Property
Diagram.OriginAnchorChanged Event


MindFusion.Diagramming.DiagramLink.OriginConnection Property

DiagramLink.OriginConnection Property
[image]

Gets or sets the ConnectionPoint object representing the link connection to its origin node. This allows connecting the link to a constituent part of a node, such as a TableNode row or a TreeViewItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ConnectionPoint OriginConnection { get; set; }

Visual Basic [image] Copy Code

Public Property OriginConnection As ConnectionPoint

Property Value

An instance of ConnectionPoint or derived class.

See Also

DiagramLink Members
DiagramLink Class
Origin Property


MindFusion.Diagramming.DiagramLink.OriginIndex Property

DiagramLink.OriginIndex Property
[image]

Gets or sets the index of link's origin anchor point or table row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int OriginIndex { get; set; }

Visual Basic [image] Copy Code

Public Property OriginIndex As Integer

Property Value

An integer value specifying the index of table's row or index of an anchor point within its containing AnchorPattern.

Remarks

If a link's origin is a shape node, this property lets you get or set the index of an anchor point at which the link docks to the node. If there is no AnchorPattern defined for the origin node, the property returns -1. If the link is connected to a table, the property returns or changes the related row of that table.

See Also

DiagramLink Members
DiagramLink Class
DestinationIndex Property


MindFusion.Diagramming.DiagramLink.RetainForm Property

DiagramLink.RetainForm Property
[image]

Gets or sets a value indicating whether a link should maintain its form if the nodes connected with that link are moved around.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RetainForm { get; set; }

Visual Basic [image] Copy Code

Public Property RetainForm As Boolean

Property Value

true to retain the form of this link; otherwise, false. Initialized with the value of LinksRetainForm.

Remarks

RetainForm is useful for links that have more than two control points. If the nodes that a link connects are moved around, usually only the segments at the ends of that link are updated, so that they stay connected to their respective nodes. In that case all intermediate control points stay where they are. However, if RetainForm is enabled, all control points will move simultaneously in a way they preserve their relative position one to another, and thus preserving the overall form of the link.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
AutoRoute Property
Dynamic Property


MindFusion.Diagramming.DiagramLink.SegmentCount Property

DiagramLink.SegmentCount Property
[image]

Gets or sets the number of segments of this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public short SegmentCount { get; set; }

Visual Basic [image] Copy Code

Public Property SegmentCount As Short

Property Value

An integer value specifying how many segments the link consists of. Initialized with the value of LinkSegments.

Remarks

Use this property to make a link more indented, when necessary.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
ControlPoints Property
Length Property


MindFusion.Diagramming.DiagramLink.Shape Property

DiagramLink.Shape Property
[image]

Gets or sets the type of link segments and how they are positioned one relatively to another.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkShape Shape { get; set; }

Visual Basic [image] Copy Code

Public Property Shape As LinkShape

Property Value

A member of the LinkShape enumeration. Initialized with the value of LinkShape.

Remarks

This property specifies whether the segments of a link are straight lines or curves. In case of straight lines, they can be set all horizontal and vertical, each segment orthogonal to its neighbor, by using the Cascading shape. Use the SegmentCount property to set the number of segments of the link.

The orientation of the first segment of a cascading link depends on the value of CascadeOrientation. If that property is set to Auto, users may change the cascade orientation interactively.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
ControlPoints Property
AutoRoute Property


MindFusion.Diagramming.DiagramLink.StartPoint Property

DiagramLink.StartPoint Property
[image]

Gets or sets the first control point of a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointF StartPoint { get; set; }

Visual Basic [image] Copy Code

Public Property StartPoint As PointF

Property Value

A .NET PointF object.

Remarks

This property is a shortcut for getting or setting ControlPoints[0].

See Also

DiagramLink Members
DiagramLink Class
EndPoint Property


MindFusion.Diagramming.DiagramLink.Text Property

DiagramLink.Text Property
[image]

Gets or sets the text displayed over a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Text { get; set; }

Visual Basic [image] Copy Code

Public Property Text As String

Property Value

A string containing the text. Initialized with the value of LinkText.

Remarks

Gets or sets the text that should be drawn over a link. Use this to provide to end-users a short description of the relation's purpose. The text appearance can be customized through the TextBrush and TextStyle properties.

Version 6 of the control adds the capability to display multiple labels per link via the LinkLabel class. Labels can automatically avoid overlapping nodes or other labels when their AutoArrange property is set.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
ToolTip Property
AddLabel Method


MindFusion.Diagramming.DiagramLink.TextAlignment Property

DiagramLink.TextAlignment Property
[image]

Gets or sets the link's text placement and orientation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringAlignment TextAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property TextAlignment As StringAlignment

Property Value

A member of the StringAlignment enumeration. The default value is Center.

Remarks

Currently this property is considered only when TextStyle is set to OverLongestSegment.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.TextStyle Property

DiagramLink.TextStyle Property
[image]

Gets or sets the link's text placement and orientation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkTextStyle TextStyle { get; set; }

Visual Basic [image] Copy Code

Public Property TextStyle As LinkTextStyle

Property Value

A member of the LinkTextStyle enumeration. Initialized with the value of LinkTextStyle.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
Text Property
TextColor Property


MindFusion.Diagramming.DiagramLink.TopLevel Property

DiagramLink.TopLevel Property
[image]

DiagramItem.TopLevel override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool TopLevel { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property TopLevel As Boolean

Property Value

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Visible Property

DiagramLink.Visible Property
[image]

DiagramItem.Visible override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Visible As Boolean

Property Value

true if the item is visible; otherwise, false.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLinkCollection Class

DiagramLinkCollection Class
[image]

Represents a strongly typed collection of DiagramLink objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramLinkCollection : ItemCollectionBase<DiagramLink>

Visual Basic [image] Copy Code

Public Class DiagramLinkCollection
Inherits ItemCollectionBase(Of DiagramLink)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.CollectionBase(DiagramLink)
MindFusion.Diagramming.PersistableCollection(DiagramLink)
MindFusion.Diagramming.ItemCollectionBase(DiagramLink)
MindFusion.Diagramming.DiagramLinkCollection

See Also

DiagramLinkCollection Members


MindFusion.Diagramming.DiagramLinkCollection Members

DiagramLinkCollection Members
Constructors Fields Properties Methods
[image]

Represents a strongly typed collection of DiagramLink objects.

The following tables list the members exposed by the DiagramLinkCollection type.

Public Constructors

Name | Description
DiagramLinkCollection | Initializes a new instance of the DiagramLinkCollection class.

Protected Fields

Name | Description
InnerList | Gets a List<T> containing the list of elements in the collection instance. (Inherited from CollectionBase.)
itemEventArgs | A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector. (Inherited from ItemCollectionBase.)
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items. (Inherited from ItemCollectionBase.)

Public Properties

Name | Description
Count | Gets the number of elements actually contained in the collection. (Inherited from CollectionBase.)
IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index. (Inherited from CollectionBase.)

Public Methods

Name | Description
Add | Adds the specified diagram item to the collection. (Inherited from ItemCollectionBase.)
Clear | Removes all diagram items from the collection. (Inherited from ItemCollectionBase.)
Clone | Creates a shallow copy of this collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from CollectionBase.)
GetAt | Gets the diagram item at the specified position. (Inherited from ItemCollectionBase.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified diagram item into the collection at the specified position. (Inherited from ItemCollectionBase.)
Remove | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
RemoveAt | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
Sort | Overloaded. (Inherited from CollectionBase.)

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event. (Inherited from ItemCollectionBase.)
RaiseInserting | Raises the Inserting event. (Inherited from ItemCollectionBase.)
RaiseRemoving | Raises the Removing event. (Inherited from ItemCollectionBase.)

See Also

DiagramLinkCollection Class


MindFusion.Diagramming.DiagramLinkCollection Constructor

DiagramLinkCollection Constructor
[image]

Initializes a new instance of the DiagramLinkCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramLinkCollection Class


MindFusion.Diagramming.DiagramLinkCollection Methods

DiagramLinkCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified diagram item to the collection. (Inherited from ItemCollectionBase.)
Clear | Removes all diagram items from the collection. (Inherited from ItemCollectionBase.)
Clone | Creates a shallow copy of this collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from CollectionBase.)
GetAt | Gets the diagram item at the specified position. (Inherited from ItemCollectionBase.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified diagram item into the collection at the specified position. (Inherited from ItemCollectionBase.)
Remove | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
RemoveAt | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
Sort | Overloaded. (Inherited from CollectionBase.)

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event. (Inherited from ItemCollectionBase.)
RaiseInserting | Raises the Inserting event. (Inherited from ItemCollectionBase.)
RaiseRemoving | Raises the Removing event. (Inherited from ItemCollectionBase.)

See Also

DiagramLinkCollection Class


MindFusion.Diagramming.DiagramLinkCollection.Clone Method

DiagramLinkCollection.Clone Method
[image]

Creates a shallow copy of this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As DiagramLinkCollection

Return Value

An instance of the DiagramLinkCollection class.

See Also

DiagramLinkCollection Members
DiagramLinkCollection Class


MindFusion.Diagramming.DiagramLinkProperties Class

DiagramLinkProperties Class
Remarks See Also
[image]

Stores the values of DiagramLink properties during undo / redo operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramLinkProperties : DiagramItemProperties

Visual Basic [image] Copy Code

Public Class DiagramLinkProperties
Inherits DiagramItemProperties

Remarks

If you need to implement undo support for the additional properties defined by a class derived from DiagramLink, do so by deriving from DiagramLinkProperties and overriding the SaveProperties, RestoreProperties and CreateProperties methods of DiagramLink.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemProperties
MindFusion.Diagramming.DiagramLinkProperties

See Also

DiagramLinkProperties Members


MindFusion.Diagramming.DiagramLinkProperties Members

DiagramLinkProperties Members
Constructors Fields Methods
[image]

Stores the values of DiagramLink properties during undo / redo operations.

The following tables list the members exposed by the DiagramLinkProperties type.

Public Constructors

Name | Description
DiagramLinkProperties | Initializes a new instance of the DiagramLinkProperties class.

Public Fields

Name | Description
AllowMoveEnd | For internal use.
AllowMoveStart | For internal use.
AutoRoute | For internal use.
AutoSnapToNode | For internal use.
BaseShape | For internal use.
BaseShapeSize | For internal use.
CascadeOrientation | For internal use.
CrossingRadius | For internal use.
DrawCrossings | For internal use.
Dynamic | For internal use.
HeadShape | For internal use.
HeadShapeSize | For internal use.
IntermediateShape | For internal use.
IntermediateShapeSize | For internal use.
ItemClass | For internal use. (Inherited from DiagramItemProperties.)
labels | For internal use.
RetainForm | For internal use.
Selected | For internal use. (Inherited from DiagramItemProperties.)
Text | For internal use.
TextPadding | For internal use. (Inherited from DiagramItemProperties.)
ZIndex | For internal use. (Inherited from DiagramItemProperties.)

Public Methods

Name | Description
FreeResources | Frees stored resources which will no longer be used. (Inherited from DiagramItemProperties.)

See Also

DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties Fields

DiagramLinkProperties Fields
[image]

Public Fields

Name | Description
AllowMoveEnd | For internal use.
AllowMoveStart | For internal use.
AutoRoute | For internal use.
AutoSnapToNode | For internal use.
BaseShape | For internal use.
BaseShapeSize | For internal use.
CascadeOrientation | For internal use.
CrossingRadius | For internal use.
DrawCrossings | For internal use.
Dynamic | For internal use.
HeadShape | For internal use.
HeadShapeSize | For internal use.
IntermediateShape | For internal use.
IntermediateShapeSize | For internal use.
ItemClass | For internal use. (Inherited from DiagramItemProperties.)
labels | For internal use.
RetainForm | For internal use.
Selected | For internal use. (Inherited from DiagramItemProperties.)
Text | For internal use.
TextPadding | For internal use. (Inherited from DiagramItemProperties.)
ZIndex | For internal use. (Inherited from DiagramItemProperties.)

See Also

DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.AllowMoveEnd Field

DiagramLinkProperties.AllowMoveEnd Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowMoveEnd

Visual Basic [image] Copy Code

Public AllowMoveEnd As Boolean

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.AllowMoveStart Field

DiagramLinkProperties.AllowMoveStart Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowMoveStart

Visual Basic [image] Copy Code

Public AllowMoveStart As Boolean

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.AutoRoute Field

DiagramLinkProperties.AutoRoute Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoRoute

Visual Basic [image] Copy Code

Public AutoRoute As Boolean

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.AutoSnapToNode Field

DiagramLinkProperties.AutoSnapToNode Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoSnapToNode

Visual Basic [image] Copy Code

Public AutoSnapToNode As Boolean

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.BaseShape Field

DiagramLinkProperties.BaseShape Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape BaseShape

Visual Basic [image] Copy Code

Public BaseShape As Shape

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.BaseShapeSize Field

DiagramLinkProperties.BaseShapeSize Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float BaseShapeSize

Visual Basic [image] Copy Code

Public BaseShapeSize As Single

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.CascadeOrientation Field

DiagramLinkProperties.CascadeOrientation Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation CascadeOrientation

Visual Basic [image] Copy Code

Public CascadeOrientation As Orientation

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.CrossingRadius Field

DiagramLinkProperties.CrossingRadius Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float CrossingRadius

Visual Basic [image] Copy Code

Public CrossingRadius As Single

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.DrawCrossings Field

DiagramLinkProperties.DrawCrossings Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool DrawCrossings

Visual Basic [image] Copy Code

Public DrawCrossings As Boolean

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.Dynamic Field

DiagramLinkProperties.Dynamic Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Dynamic

Visual Basic [image] Copy Code

Public Dynamic As Boolean

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.HeadShape Field

DiagramLinkProperties.HeadShape Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape HeadShape

Visual Basic [image] Copy Code

Public HeadShape As Shape

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.HeadShapeSize Field

DiagramLinkProperties.HeadShapeSize Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float HeadShapeSize

Visual Basic [image] Copy Code

Public HeadShapeSize As Single

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.IntermediateShape Field

DiagramLinkProperties.IntermediateShape Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape IntermediateShape

Visual Basic [image] Copy Code

Public IntermediateShape As Shape

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.IntermediateShapeSize Field

DiagramLinkProperties.IntermediateShapeSize Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float IntermediateShapeSize

Visual Basic [image] Copy Code

Public IntermediateShapeSize As Single

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.labels Field

DiagramLinkProperties.labels Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<LinkLabel> labels

Visual Basic [image] Copy Code

Public labels As List(Of LinkLabel)

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.RetainForm Field

DiagramLinkProperties.RetainForm Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RetainForm

Visual Basic [image] Copy Code

Public RetainForm As Boolean

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.Text Field

DiagramLinkProperties.Text Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Text

Visual Basic [image] Copy Code

Public Text As String

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties Constructor

DiagramLinkProperties Constructor
[image]

Initializes a new instance of the DiagramLinkProperties class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkProperties ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkState Class

DiagramLinkState Class
Remarks See Also
[image]

Contains a snapshot of the internal state of a DiagramLink.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramLinkState : DiagramItemState

Visual Basic [image] Copy Code

Public Class DiagramLinkState
Inherits DiagramItemState

Remarks

Instances of this class are used to store the state of links for later undo or redo operations. If you derive from DiagramLink and need to implement undo support for the additional internal state defined by your class, do so by deriving from DiagramLinkState and overriding the CreateState, SaveState and RestoreState methods of DiagramLink.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemState
MindFusion.Diagramming.DiagramLinkState

See Also

DiagramLinkState Members


MindFusion.Diagramming.DiagramLinkState Members

DiagramLinkState Members
Constructors
[image]

Contains a snapshot of the internal state of a DiagramLink.

The following tables list the members exposed by the DiagramLinkState type.

Public Constructors

Name | Description
DiagramLinkState | Initializes a new instance of the DiagramLinkState class.

See Also

DiagramLinkState Class


MindFusion.Diagramming.DiagramLinkState Constructor

DiagramLinkState Constructor
[image]

Initializes a new instance of the DiagramLinkState class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkState ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramLinkState Class


MindFusion.Diagramming.DiagramLinkStyle Class

DiagramLinkStyle Class
[image]

Represents a reusable set of properties that define the appearance of diagram links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramLinkStyle : DiagramItemStyle

Visual Basic [image] Copy Code

Public Class DiagramLinkStyle
Inherits DiagramItemStyle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Style
MindFusion.Diagramming.DiagramItemStyle
MindFusion.Diagramming.DiagramLinkStyle

See Also

DiagramLinkStyle Members


MindFusion.Diagramming.DiagramLinkStyle Members

DiagramLinkStyle Members
Constructors Properties Methods Events
[image]

Represents a reusable set of properties that define the appearance of diagram links.

The following tables list the members exposed by the DiagramLinkStyle type.

Public Constructors

Name | Description
DiagramLinkStyle | Initializes a new instance of the DiagramLinkStyle class.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of the item. (Inherited from DiagramItemStyle.)
FontFamily | Gets or sets the font family of the item text. (Inherited from DiagramItemStyle.)
FontSize | Gets or sets the font size of the item text. (Inherited from DiagramItemStyle.)
FontStyle | Gets or sets the font style of the item text. (Inherited from DiagramItemStyle.)
FontUnit | Gets or sets the font unit of the item text. (Inherited from DiagramItemStyle.)
HeadStroke | Gets or sets the brush used to paint the arrowhead outlines of this brush.
HeadStrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline arrowheads.
HeadStrokeThickness | Gets or sets the outline thickness of the arrowheads of this brush, expressed in the current units of measure.
ShadowBrush | Gets or sets the brush used to paint the shadow of the item. (Inherited from DiagramItemStyle.)
Stroke | Gets or sets the brush used to paint the outline of the item. (Inherited from DiagramItemStyle.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItemStyle.)
StrokeThickness | Gets or sets the thickness of the item's outline, expressed in the current units of measure. (Inherited from DiagramItemStyle.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItemStyle.)

Public Methods

Name | Description
GetProperties | Gets all properties in the style. (Inherited from Style.)
GetProperty | Returns the property with the specified name, if any. (Inherited from Style.)
RegisterType | Associates a type with an alias. (Inherited from Style.)

Protected Methods

Name | Description
GetValue | Gets the value of the specified property. (Inherited from Style.)
IsPropertySet | Checks whether the specified property has a value. (Inherited from Style.)
LoadFrom | Deserializes the item from the specified reader. (Inherited from Style.)
LoadFromXml | Loads the style content from an XML element. (Inherited from Style.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Style.)
RegisterProperty | Registers a new property with the specified name and type. (Inherited from Style.)
SaveTo | Serializes the style to the specified writer. (Inherited from Style.)
SaveToXml | Saves the style content into an XML element. (Inherited from Style.)
SetValue | Sets the value of the specified property. (Inherited from Style.)
UnsetValue | Clears the value of the specified property. (Inherited from Style.)

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

DiagramLinkStyle Class


MindFusion.Diagramming.DiagramLinkStyle Constructor

DiagramLinkStyle Constructor
[image]

Initializes a new instance of the DiagramLinkStyle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramLinkStyle Class


MindFusion.Diagramming.DiagramLinkStyle Properties

DiagramLinkStyle Properties
[image]

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of the item. (Inherited from DiagramItemStyle.)
FontFamily | Gets or sets the font family of the item text. (Inherited from DiagramItemStyle.)
FontSize | Gets or sets the font size of the item text. (Inherited from DiagramItemStyle.)
FontStyle | Gets or sets the font style of the item text. (Inherited from DiagramItemStyle.)
FontUnit | Gets or sets the font unit of the item text. (Inherited from DiagramItemStyle.)
HeadStroke | Gets or sets the brush used to paint the arrowhead outlines of this brush.
HeadStrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline arrowheads.
HeadStrokeThickness | Gets or sets the outline thickness of the arrowheads of this brush, expressed in the current units of measure.
ShadowBrush | Gets or sets the brush used to paint the shadow of the item. (Inherited from DiagramItemStyle.)
Stroke | Gets or sets the brush used to paint the outline of the item. (Inherited from DiagramItemStyle.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItemStyle.)
StrokeThickness | Gets or sets the thickness of the item's outline, expressed in the current units of measure. (Inherited from DiagramItemStyle.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItemStyle.)

See Also

DiagramLinkStyle Class


MindFusion.Diagramming.DiagramLinkStyle.HeadStroke Property

DiagramLinkStyle.HeadStroke Property
[image]

Gets or sets the brush used to paint the arrowhead outlines of this brush.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush HeadStroke { get; set; }

Visual Basic [image] Copy Code

Public Property HeadStroke As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

See Also

DiagramLinkStyle Members
DiagramLinkStyle Class


MindFusion.Diagramming.DiagramLinkStyle.HeadStrokeDashStyle Property

DiagramLinkStyle.HeadStrokeDashStyle Property
[image]

Gets or sets the pattern of dashes and gaps used to outline arrowheads.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DashStyle HeadStrokeDashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HeadStrokeDashStyle As DashStyle

Property Value

A member of the DashStyle enumeration.

See Also

DiagramLinkStyle Members
DiagramLinkStyle Class


MindFusion.Diagramming.DiagramLinkStyle.HeadStrokeThickness Property

DiagramLinkStyle.HeadStrokeThickness Property
[image]

Gets or sets the outline thickness of the arrowheads of this brush, expressed in the current units of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double HeadStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property HeadStrokeThickness As Double

Property Value

A double value.

See Also

DiagramLinkStyle Members
DiagramLinkStyle Class


MindFusion.Diagramming.DiagramLinkStyle Events

DiagramLinkStyle Events
[image]

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

DiagramLinkStyle Class


MindFusion.Diagramming.DiagramNode Class

DiagramNode Class
Remarks See Also
[image]

Represents a diagram node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class DiagramNode : DiagramItem

Visual Basic [image] Copy Code

Public MustInherit Class DiagramNode
Inherits DiagramItem

Remarks

DiagramNode instances can represent graph vertices, nodes in organizational or flow diagrams, entities in ER diagrams, and so on. DiagramNode is an abstract class. You cannot use it directly, but instead use objects from the ShapeNode, TableNode, ContainerNode and ControlNode specific classes. You can also create your own node class by deriving from DiagramNode or its descendants.

Use the Bounds property to get or change the location and size of a node. To move a node without changing its size, call the Move method. To change only the size of a node, invoke the Resize method.

Constraints upon how users are allowed to modify a node are set through the Constraints and EnabledHandles properties. The former specifies constraints on move direction and node size. The latter enables or disables specific manipulation handles of a node.

Relations between nodes are indicated by connecting the nodes with DiagramLink instances. Links are considered directed graph edges, so each node has two collections referring to links: IncomingLinks and OutgoingLinks. AnchorPattern defines to which points of a node incoming or outgoing links can be connected. The AllowIncomingLinks property lets you specify whether incoming links can be drawn to a node. The AllowOutgoingLinks property lets you do that for outgoing links.

A user is allowed to expand or collapse the tree starting from a node if Expandable is set to true. The Expanded property gets or sets whether the subtree starting from a node is expanded or not.

Nodes can be attached to other items, and be used as simple labels, image-holders or other kinds of UI elements. The AttachTo method creates a Group instance if necessary, and calls the group's appropriate AttachTo* method.

Nodes can be rotated, either interactively using the rotation handle above the node, or programmatically using the RotationAngle property.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.BarcodeNode
MindFusion.Diagramming.CompositeNode
MindFusion.Diagramming.ContainerNode
MindFusion.Diagramming.DummyNode
MindFusion.Diagramming.MapNode
MindFusion.Diagramming.ShapeNode
MindFusion.Diagramming.TableNode
MindFusion.Diagramming.TreeViewNode
MindFusion.Diagramming.VisioNode

See Also

DiagramNode Members


MindFusion.Diagramming.DiagramNode Members

DiagramNode Members
Constructors Fields Properties Methods
[image]

Represents a diagram node.

The following tables list the members exposed by the DiagramNode type.

Protected Constructors

Name | Description
DiagramNode | Overloaded. Initializes a new instance of the DiagramNode class.

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node.
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node.
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node.
Bounds | Gets or sets the rectangle that defines the position of the diagram node.
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node.
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node.
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node.
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node.
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded.
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like.
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached.
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm.
OutgoingLinks | Gets a collection of links that start from this node.
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node.
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override.
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | Determines whether the node supports connections to its constituent elements.
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type.
AttachManipulator | Adds the specified manipulator to this node.
AttachTo | Overloaded. Attaches this node to another diagram item.
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node.
ContainsPoint | Overloaded.
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point.
Detach | Detaches this node from its master item.
DetachManipulator | Removes the specified manipulator from this node.
Dispose | Overloaded. (Inherited from DiagramItem.)
DoModify | For internal use. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface.
DrawAnchors | Draws the anchor points of this node.
DrawHandles | DiagramItem.DrawHandles override. Renders the adjustment handles of this item.
DrawLocal | Override in a derived class to provide implementation specific drawing for the node.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface.
DrawShadowLocal | Override in a derived class to provide implementation specific drawing for the shadow of the node.
Expand | Shows all nodes and links in the subtree starting from this node.
GetAllIncomingLinks | Overloaded.
GetAllLinks | Gets all links connected to this node.
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle.
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point.
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item. (Inherited from DiagramItem.)
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item. (Inherited from DiagramItem.)
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item. (Inherited from DiagramItem.)
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item. (Inherited from DiagramItem.)
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point.
GetOutlinePoly | DiagramItem.GetOutlinePoly override.
GetRepaintRect | DiagramItem.GetRepaintRect override.
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point.
GetRotationAngle | Gets the rotation angle of this node.
GetToolTip | DiagramItem.GetToolTip override.
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point.
HitTestManipulators | DiagramItem.HitTestManipulators override.
Intersects | Determines whether the node intersects another one, taking into account the outlines of node shapes.
Move | Moves the node to the specified location.
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node.
OnDragOver | Invoked when a diagram item is being dragged over this node.
OnDropOver | Invoked when a diagram item is dropped over this node.
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed.
ReassignUnanchoredLinks | Reassigns unanchored links
Resize | Resizes the node.
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetBounds | Sets the location and size of this node.
SetExpandedFlag | Sets the 'expanded' flag, repainting the node.
SetPos | Sets the bounding rectangle of this node without updating connected arrows.
SetRect | This method is used internally by the Ruler control to align nodes.
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
AllowCreate | DiagramItem.AllowCreate override.
AllowModify | DiagramItem.AllowModify override.
CancelModify | DiagramItem.CancelModify override. Invoked when the interactive modification of this object has been canceled.
CompleteCreate | DiagramItem.CompleteCreate override.
CompleteModify | DiagramItem.CompleteModify override.
ConstraintsInfringed | Checks whether the KeepInsideParent constrained is being violated.
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override.
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
Finalize | DiagramItem finalizer. (Inherited from DiagramItem.)
FreeResources | Called when the node is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history.
GetAllOutgoingLinks | Overloaded.
GetLocalBounds | Gets this node's bounding rectangle in local coordinates.
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle.
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy.
LoadFrom | DiagramItem.LoadFrom override.
LoadFromXml | DiagramItem.LoadFromXml override.
LoadObsolete | For internal use. (Inherited from DiagramItem.)
OnAdd | DiagramItem.OnAdd override.
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnClick | Invoked when the user clicks this item. (Inherited from DiagramItem.)
OnDoubleClick | Invoked when the user double-clicks this item. (Inherited from DiagramItem.)
OnMeasureUnitChanged | DiagramItem.OnMeasureUnitChanged override.
OnModify | Invoked when the user moves or resizes this node.
OnRemove | DiagramItem.OnRemove override.
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively.
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | Overloaded.
OnZoomChanged | DiagramItem.OnZoomChanged override.
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override.
SaveProperties | DiagramItem.SaveProperties override.
SaveState | DiagramItem.SaveState override.
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary.
SetExpanded | DiagramItem.SetExpanded override.
SetIncomingLinks | Sets the incoming links collection of this node.
SetOutgoingLinks | Sets the outgoing links collection of this node.
SetReference | Called during deserialization, after all objects have been instantiated, in order to update the references between them.
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it.
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points.
StartCreate | DiagramItem.StartCreate override.
StartModify | DiagramItem.StartModify override. Invoked when the user starts modifying this item interactively.
UpdateCreate | DiagramItem.UpdateCreate override.
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster. (Inherited from DiagramItem.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape.
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape.
UpdateModify | DiagramItem.UpdateModify override. Invoked during interactive modification of this item.

See Also

DiagramNode Class


MindFusion.Diagramming.DiagramNode Constructor

DiagramNode Constructor
[image]

Initializes a new instance of the DiagramNode class.

Overload List

Name | Description
DiagramNode () | Initializes a new instance of the DiagramNode class.
DiagramNode (Diagram) | Initializes a new instance of the DiagramNode class with default values supplied form the specified Diagram.
DiagramNode (DiagramNode) | Initializes a new instance of the DiagramNode class using the specified diagram item as a prototype.

See Also

DiagramNode Class


MindFusion.Diagramming.DiagramNode Constructor ()

DiagramNode Constructor ()
See Also
[image]

Initializes a new instance of the DiagramNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DiagramNode ()

Visual Basic [image] Copy Code

Protected Sub New ()

Remarks

This constructor sets the DiagramNode properties to their default values.

See Also

DiagramNode Constructor Overload List
DiagramNode Class


MindFusion.Diagramming.DiagramNode Constructor (Diagram)

DiagramNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the DiagramNode class with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DiagramNode (
Diagram parent
)

Visual Basic [image] Copy Code

Protected Sub DiagramNode ( _
parent As Diagram _
)

Parameters

parent

The Diagram from which to obtain default values for the item properties.

Remarks

This constructor initializes the DiagramNode properties with the values specified in the respective default-value properties of the Diagram object. For more information see Initial Values of Item Properties.

See Also

DiagramNode Constructor Overload List
DiagramNode Class


MindFusion.Diagramming.DiagramNode Constructor (DiagramNode)

DiagramNode Constructor (DiagramNode)
See Also
[image]

Initializes a new instance of the DiagramNode class using the specified diagram item as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DiagramNode (
DiagramNode prototype
)

Visual Basic [image] Copy Code

Protected Sub DiagramNode ( _
prototype As DiagramNode _
)

Parameters

prototype

The item to use as a prototype. The properties of the new item are initialized from the property values of this item.

Remarks

This constructor copies the DiagramNode property values from the specified prototype node.

See Also

DiagramNode Constructor Overload List
DiagramNode Class


MindFusion.Diagramming.DiagramNode Methods

DiagramNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type.
AttachManipulator | Adds the specified manipulator to this node.
AttachTo | Overloaded. Attaches this node to another diagram item.
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node.
ContainsPoint | Overloaded.
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point.
Detach | Detaches this node from its master item.
DetachManipulator | Removes the specified manipulator from this node.
Dispose | Overloaded. (Inherited from DiagramItem.)
DoModify | For internal use. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface.
DrawAnchors | Draws the anchor points of this node.
DrawHandles | DiagramItem.DrawHandles override. Renders the adjustment handles of this item.
DrawLocal | Override in a derived class to provide implementation specific drawing for the node.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface.
DrawShadowLocal | Override in a derived class to provide implementation specific drawing for the shadow of the node.
Expand | Shows all nodes and links in the subtree starting from this node.
GetAllIncomingLinks | Overloaded.
GetAllLinks | Gets all links connected to this node.
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle.
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point.
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item. (Inherited from DiagramItem.)
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item. (Inherited from DiagramItem.)
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item. (Inherited from DiagramItem.)
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item. (Inherited from DiagramItem.)
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point.
GetOutlinePoly | DiagramItem.GetOutlinePoly override.
GetRepaintRect | DiagramItem.GetRepaintRect override.
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point.
GetRotationAngle | Gets the rotation angle of this node.
GetToolTip | DiagramItem.GetToolTip override.
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point.
HitTestManipulators | DiagramItem.HitTestManipulators override.
Intersects | Determines whether the node intersects another one, taking into account the outlines of node shapes.
Move | Moves the node to the specified location.
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node.
OnDragOver | Invoked when a diagram item is being dragged over this node.
OnDropOver | Invoked when a diagram item is dropped over this node.
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed.
ReassignUnanchoredLinks | Reassigns unanchored links
Resize | Resizes the node.
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetBounds | Sets the location and size of this node.
SetExpandedFlag | Sets the 'expanded' flag, repainting the node.
SetPos | Sets the bounding rectangle of this node without updating connected arrows.
SetRect | This method is used internally by the Ruler control to align nodes.
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
AllowCreate | DiagramItem.AllowCreate override.
AllowModify | DiagramItem.AllowModify override.
CancelModify | DiagramItem.CancelModify override. Invoked when the interactive modification of this object has been canceled.
CompleteCreate | DiagramItem.CompleteCreate override.
CompleteModify | DiagramItem.CompleteModify override.
ConstraintsInfringed | Checks whether the KeepInsideParent constrained is being violated.
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override.
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
Finalize | DiagramItem finalizer. (Inherited from DiagramItem.)
FreeResources | Called when the node is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history.
GetAllOutgoingLinks | Overloaded.
GetLocalBounds | Gets this node's bounding rectangle in local coordinates.
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle.
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy.
LoadFrom | DiagramItem.LoadFrom override.
LoadFromXml | DiagramItem.LoadFromXml override.
LoadObsolete | For internal use. (Inherited from DiagramItem.)
OnAdd | DiagramItem.OnAdd override.
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnClick | Invoked when the user clicks this item. (Inherited from DiagramItem.)
OnDoubleClick | Invoked when the user double-clicks this item. (Inherited from DiagramItem.)
OnMeasureUnitChanged | DiagramItem.OnMeasureUnitChanged override.
OnModify | Invoked when the user moves or resizes this node.
OnRemove | DiagramItem.OnRemove override.
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively.
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | Overloaded.
OnZoomChanged | DiagramItem.OnZoomChanged override.
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override.
SaveProperties | DiagramItem.SaveProperties override.
SaveState | DiagramItem.SaveState override.
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary.
SetExpanded | DiagramItem.SetExpanded override.
SetIncomingLinks | Sets the incoming links collection of this node.
SetOutgoingLinks | Sets the outgoing links collection of this node.
SetReference | Called during deserialization, after all objects have been instantiated, in order to update the references between them.
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it.
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points.
StartCreate | DiagramItem.StartCreate override.
StartModify | DiagramItem.StartModify override. Invoked when the user starts modifying this item interactively.
UpdateCreate | DiagramItem.UpdateCreate override.
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster. (Inherited from DiagramItem.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape.
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape.
UpdateModify | DiagramItem.UpdateModify override. Invoked during interactive modification of this item.

See Also

DiagramNode Class


MindFusion.Diagramming.DiagramNode.AcceptLinks Method

DiagramNode.AcceptLinks Method
[image]

Determines whether the node can be connected with links of the specified type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool AcceptLinks (
bool outgoing
)

Visual Basic [image] Copy Code

Public Overridable Function AcceptLinks( _
outgoing As Boolean _
) As Boolean

Parameters

outgoing
true to check for outgoing links; otherwise, false.

Return Value

true if the node accepts connections of the specified type; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.AllowCreate Method

DiagramNode.AllowCreate Method
[image]

DiagramItem.AllowCreate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual bool AllowCreate (
PointF current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overridable Function AllowCreate ( _
current As PointF, _
ist As InteractionState _
) As Boolean

Parameters

current
The current mouse pointer position.
ist
An InteractionState object containing more information about the current state of the operation.

Return Value

true to allow the creation of this node; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.AllowModify Method

DiagramNode.AllowModify Method
[image]

DiagramItem.AllowModify override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual bool AllowModify (
PointF current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overridable Function AllowModify ( _
current As PointF, _
ist As InteractionState _
) As Boolean

Parameters

current
The current mouse pointer position.
ist
An InteractionState object containing more information about the current state of the operation.

Return Value

true to allow the modification of this node; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.AttachManipulator Method

DiagramNode.AttachManipulator Method
[image]

Adds the specified manipulator to this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AttachManipulator (
Manipulator manipulator
)

Visual Basic [image] Copy Code

Public Sub AttachManipulator ( _
manipulator As Manipulator _
)

Parameters

manipulator
A Manipulator object representing the manipulator to add.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.AttachTo Method

DiagramNode.AttachTo Method
[image]

Attaches this node to another diagram item.

Overload List

Name | Description
DiagramNode.AttachTo (DiagramLink, AttachToLink, Int32) | Attaches this node to the specified link using the specified attaching type.
DiagramNode.AttachTo (DiagramNode, AttachToNode) | Attaches this node to the specified node using the specified attaching type.
DiagramNode.AttachTo (DiagramNode, GroupAnchorStyles) | Attaches this node to one or more edges of the specified node.
DiagramNode.AttachTo (DiagramNode, Single, Single, Single, Single) | Proportionally attaches this node to the specified node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.AttachTo Method (DiagramLink, AttachToLink, Int32)

DiagramNode.AttachTo Method (DiagramLink, AttachToLink, Int32)
See Also
[image]

Attaches this node to the specified link using the specified attaching type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AttachTo (
DiagramLink link,
AttachToLink attType,
int index
)

Visual Basic [image] Copy Code

Public Sub AttachTo ( _
link As DiagramLink, _
attType As AttachToLink, _
index As Integer _
)

Parameters

link
A DiagramLink to whose control point or segment to attach this node.
attType
A value of the AttachToLink enumeration specifying whether to attach the node to a segment or to a control point of the link.
index
An index of link's control point or segment, depending on the attType value.

Remarks

This method attaches the node to a control point or segment of the specified link. If there isn't a Group instance already associated with the master item, one is created automatically by this method. The group is then accessible through the master's SubordinateGroup property, or this node's MasterGroup property.

The node is attached by calling the AttachToLinkPoint or AttachToLinkSegment methods of Group, depending on the value of the attType argument. The attached node then maintains its original offset from a link's point or segment when link's shape changes.

See Also

AttachTo Method Overload List
DiagramNode Members
DiagramNode Class
Detach Method


MindFusion.Diagramming.DiagramNode.AttachTo Method (DiagramNode, AttachToNode)

DiagramNode.AttachTo Method (DiagramNode, AttachToNode)
See Also
[image]

Attaches this node to the specified node using the specified attaching type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AttachTo (
DiagramNode node,
AttachToNode attType
)

Visual Basic [image] Copy Code

Public Sub AttachTo ( _
node As DiagramNode, _
attType As AttachToNode _
)

Parameters

node
A reference to the node to whose corner to attach this node.
attType
A member of the AttachToNode enumeration specifying to which corner of a node to attach this node.

Remarks

This method attaches the current node to the corner of another node. If there isn't a Group instance already associated with the master item, one is created automatically by this method. The group is then accessible by the master's SubordinateGroup property, or this node's MasterGroup property.

The node is attached by calling the AttachToCorner method of Group. The attached node then maintains its original offset from another node's corner point.

See Also

AttachTo Method Overload List
DiagramNode Members
DiagramNode Class
Detach Method


MindFusion.Diagramming.DiagramNode.AttachTo Method (DiagramNode, GroupAnchorStyles)

DiagramNode.AttachTo Method (DiagramNode, GroupAnchorStyles)
See Also
[image]

Attaches this node to one or more edges of the specified node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AttachTo (
DiagramNode node,
GroupAnchorStyles anchorStyles
)

Visual Basic [image] Copy Code

Public Sub AttachTo ( _
node As DiagramNode, _
anchorStyles As GroupAnchorStyles _
)

Parameters

node
A reference to the node to which to attach this node.
anchorStyles
A member of the GroupAnchorStyles enumeration specifying the master node's edges to which this node must be anchored.

Remarks

This method attaches the current node to the corner of another node. If there isn't a Group instance already associated with the master item, one is created automatically by this method. The group is then accessible by the master's SubordinateGroup property, or this node's MasterGroup property.

The node is attached by calling the AttachToEdges method of Group, which mimics the anchoring of child controls in a form to the form edges, as implemented in Windows Forms.

See Also

AttachTo Method Overload List
DiagramNode Members
DiagramNode Class
Detach Method


MindFusion.Diagramming.DiagramNode.AttachTo Method (DiagramNode, Single, Single, Single, Single)

DiagramNode.AttachTo Method (DiagramNode, Single, Single, Single, Single)
See Also
[image]

Proportionally attaches this node to the specified node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AttachTo (
DiagramNode node,
float percentX1,
float percentY1,
float percentX2,
float percentY2
)

Visual Basic [image] Copy Code

Public Sub AttachTo ( _
node As DiagramNode, _
percentX1 As Single, _
percentY1 As Single, _
percentX2 As Single, _
percentY2 As Single _
)

Parameters

node
A reference to the node to which to attach this node.
percentX1
Left-hand side coordinate of the node, expressed as percent of main node's width.
percentY1
Top side coordinate of the node, expressed as percent of main node's height.
percentX2
Right-hand side coordinate of the node, expressed as percent of main node's width.
percentY2
Bottom side coordinate of the node, expressed as percent of main node's height.

Remarks

This method attaches proportionally the current node to another node. If there isn't a Group instance already associated with the master item, one is created automatically by this method. The group is then accessible through the master's SubordinateGroup property, or this node's MasterGroup property.

The node is attached by calling the AttachProportional method of Group. The attached node maintains its size and position so that it always covers the specified rectangular area of the master node.

See Also

AttachTo Method Overload List
DiagramNode Members
DiagramNode Class
Detach Method


MindFusion.Diagramming.DiagramNode.CancelModify Method

DiagramNode.CancelModify Method
[image]

DiagramItem.CancelModify override. Invoked when the interactive modification of this object has been canceled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void CancelModify (
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub CancelModify( _
ist As InteractionState _
)

Parameters

ist

An InteractionState object containing more information about the current state of the operation.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Collapse Method

DiagramNode.Collapse Method
[image]

Hides all nodes and links in the subtree starting from this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Collapse ()

Visual Basic [image] Copy Code

Public Sub Collapse ()

Remarks

This method is useful mostly when nodes form a tree-like hierarchical structure. Invoking Collapse on a node makes all its children in the tree invisible. It depends on the diagram's ExpandOnIncoming property which items connected to the node are considered its children.

Collapse is meant for use with tree structures and it is your responsibility to ensure that your chart is really a tree. A graph is a tree if every node has no more than one parent and there's one root node that can be reached from all nodes going in child-to-parent direction. The tree can be expanded again by calling the Expand method.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
Expand Method
Expanded Property


MindFusion.Diagramming.DiagramNode.CompleteCreate Method

DiagramNode.CompleteCreate Method
[image]

DiagramItem.CompleteCreate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void CompleteCreate (
PointF end
)

Visual Basic [image] Copy Code

Protected Overrides Sub CompleteCreate( _
end As PointF _
)

Parameters

end
The mouse pointer position.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.CompleteModify Method

DiagramNode.CompleteModify Method
[image]

DiagramItem.CompleteModify override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void CompleteModify (
PointF end,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overridable Sub CompleteModify ( _
end As PointF, _
ist As InteractionState _
)

Parameters

end
The mouse pointer position.
ist
An InteractionState object containing more information about the current state of the operation.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.ConstraintsInfringed Method

DiagramNode.ConstraintsInfringed Method
[image]

Checks whether the KeepInsideParent constrained is being violated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected bool ConstraintsInfringed ()

Visual Basic [image] Copy Code

Protected Function ConstraintsInfringed () As Boolean

Return Value

true if the current node coordinates violate the KeepInsideParent constraint; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.ContainsPoint Method

DiagramNode.ContainsPoint Method
[image]

Overload List

Name | Description
DiagramNode.ContainsPoint (PointF) | DiagramItem.ContainsPoint override.
DiagramNode.ContainsPoint (PointF, Single) | Tests whether the specified point is contained within the outline of this node, relaxed with the specified threshold.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.ContainsPoint Method (PointF)

DiagramNode.ContainsPoint Method (PointF)
See Also
[image]

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
PointF point
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
point As PointF _
) As Boolean

Parameters

point
A PointF value specifying the logical coordinates of a diagram point.

Return Value

true if this node contains the specified point; otherwise, false.

See Also

ContainsPoint Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.ContainsPoint Method (PointF, Single)

DiagramNode.ContainsPoint Method (PointF, Single)
See Also
[image]

Tests whether the specified point is contained within the outline of this node, relaxed with the specified threshold.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
PointF point,
float threshold
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
point As PointF, _
threshold As Single _
) As Boolean

Parameters

point
The point to check.
threshold

Specifies the size of the area around the node outlines where the point is still considered inside the node.

Return Value

true if this node contains the specified point; otherwise, false.

See Also

ContainsPoint Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.CreateConnectionPoint Method

DiagramNode.CreateConnectionPoint Method
[image]

Creates a connection point between this node and the specified link at the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual ConnectionPoint CreateConnectionPoint (
DiagramLink link,
PointF pt,
bool incoming
)

Visual Basic [image] Copy Code

Protected Overridable Function CreateConnectionPoint ( _
link As DiagramLink, _
pt As PointF, _
incoming As Boolean _
) As ConnectionPoint

Parameters

link
A DiagramLink that should be connected to this node.
pt
The point at which the link should be connected.
incoming
true if link is an incoming link, otherwise, false.

Return Value

A ConnectionPoint instance representing the connection.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.CreateProperties Method

DiagramNode.CreateProperties Method
[image]

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramItemProperties CreateProperties ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateProperties () As DiagramItemProperties

Return Value

A DiagramNodeProperties object that will be used to store the properties of this node.

Remarks

This method is invoked by the undo/redo subsystem when creating a ChangeItemCmd instance.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
SaveProperties Method
RestoreProperties Method


MindFusion.Diagramming.DiagramNode.CreateState Method

DiagramNode.CreateState Method
[image]

DiagramItem.CreateState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override DiagramItemState CreateState ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateState () As DiagramItemState

Return Value

A DiagramNodeState instance.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Detach Method

DiagramNode.Detach Method
[image]

Detaches this node from its master item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Detach ()

Visual Basic [image] Copy Code

Public Sub Detach ()

Remarks

The node should be previously attached using AttachTo.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.DetachManipulator Method

DiagramNode.DetachManipulator Method
[image]

Removes the specified manipulator from this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void DetachManipulator (
Manipulator manipulator
)

Visual Basic [image] Copy Code

Public Sub DetachManipulator ( _
manipulator As Manipulator _
)

Parameters

manipulator
A Manipulator object representing the manipulator to remove.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Draw Method

DiagramNode.Draw Method
[image]

DiagramItem.Draw override. Draws the item on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Draw (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

The IGraphics surface to draw the node on.

options

Provides options for the drawing operation.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.DrawAnchors Method

DiagramNode.DrawAnchors Method
[image]

Draws the anchor points of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void DrawAnchors (
IGraphics graphics
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawAnchors ( _
graphics As IGraphics _
)

Parameters

graphics
The IGraphics surface to draw the anchor points on.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.DrawHandles Method

DiagramNode.DrawHandles Method
[image]

DiagramItem.DrawHandles override. Renders the adjustment handles of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawHandles (
IGraphics graphics,
HandlesVisualStyle style,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawHandles( _
graphics As IGraphics, _
style As HandlesVisualStyle, _
options As RenderOptions _
)

Parameters

graphics

The IGraphics surface on which the handles should be drawn.

style

A HandlesVisualStyle instance containing brush and pen objects that should be used when drawing handles.

options

Provides options for the drawing operation.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
HitTestHandle Method
HandlesStyle Property


MindFusion.Diagramming.DiagramNode.DrawLocal Method

DiagramNode.DrawLocal Method
[image]

Override in a derived class to provide implementation specific drawing for the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void DrawLocal (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawLocal( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

The IGraphics surface to draw the node on.

options

Provides options for the drawing operation.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.DrawShadow Method

DiagramNode.DrawShadow Method
[image]

DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawShadow (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawShadow( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

An IGraphics object where the shadow should be rendered.

options

Provides options for the drawing operation.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.DrawShadowLocal Method

DiagramNode.DrawShadowLocal Method
[image]

Override in a derived class to provide implementation specific drawing for the shadow of the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void DrawShadowLocal (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawShadowLocal( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

An IGraphics object where the shadow should be rendered.

options

Provides options for the drawing operation.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Expand Method

DiagramNode.Expand Method
[image]

Shows all nodes and links in the subtree starting from this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Expand ()

Visual Basic [image] Copy Code

Public Sub Expand ()

Remarks

This method is useful mostly when nodes form a tree-like hierarchical structure. Use Expand to show a subtree of nodes that was previously collapsed, either interactively or by calling Collapse. If the RecursiveExpand property is enabled, all tree levels are expanded recursively.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
Collapse Method
Expanded Property


MindFusion.Diagramming.DiagramNode.FreeResources Method

DiagramNode.FreeResources Method
[image]

Called when the node is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void FreeResources ()

Visual Basic [image] Copy Code

Protected Overrides Sub FreeResources ()

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetAllIncomingLinks Method

DiagramNode.GetAllIncomingLinks Method
[image]

Overload List

Name | Description
DiagramNode.GetAllIncomingLinks () | Gets a collection of all links entering this node.
DiagramNode.GetAllIncomingLinks (DiagramLinkCollection) | Adds all links going in this node to the specified collection.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetAllIncomingLinks Method ()

DiagramNode.GetAllIncomingLinks Method ()
See Also
[image]

Gets a collection of all links entering this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection GetAllIncomingLinks ()

Visual Basic [image] Copy Code

Public Function GetAllIncomingLinks () As DiagramLinkCollection

Return Value

See Also

GetAllIncomingLinks Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetAllIncomingLinks Method (DiagramLinkCollection)

DiagramNode.GetAllIncomingLinks Method (DiagramLinkCollection)
See Also
[image]

Adds all links going in this node to the specified collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void GetAllIncomingLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Protected Overridable Sub GetAllIncomingLinks( _
links As DiagramLinkCollection _
)

Parameters

links

See Also

GetAllIncomingLinks Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetAllLinks Method

DiagramNode.GetAllLinks Method
[image]

Gets all links connected to this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection GetAllLinks ()

Visual Basic [image] Copy Code

Public Function GetAllLinks () As DiagramLinkCollection

Return Value

A DiagramLinkCollection containing the links connected to this node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetAllOutgoingLinks Method

DiagramNode.GetAllOutgoingLinks Method
[image]

Overload List

Name | Description
DiagramNode.GetAllOutgoingLinks () | Gets a collection of all links going out of this node.
DiagramNode.GetAllOutgoingLinks (DiagramLinkCollection) | Adds all links going out of this node to the specified collection.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetAllOutgoingLinks Method ()

DiagramNode.GetAllOutgoingLinks Method ()
See Also
[image]

Gets a collection of all links going out of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection GetAllOutgoingLinks ()

Visual Basic [image] Copy Code

Public Function GetAllOutgoingLinks () As DiagramLinkCollection

Return Value

See Also

GetAllOutgoingLinks Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetAllOutgoingLinks Method (DiagramLinkCollection)

DiagramNode.GetAllOutgoingLinks Method (DiagramLinkCollection)
See Also
[image]

Adds all links going out of this node to the specified collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void GetAllOutgoingLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Protected Overridable Sub GetAllOutgoingLinks( _
links As DiagramLinkCollection _
)

Parameters

links

See Also

GetAllOutgoingLinks Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetCenter Method

DiagramNode.GetCenter Method
[image]

Gets the center of this node's bounding rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointF GetCenter ()

Visual Basic [image] Copy Code

Public Function GetCenter () As PointF

Return Value

A PointF object representing the center point of this node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetClosestAnchorPoint Method

DiagramNode.GetClosestAnchorPoint Method
[image]

Returns the index of the anchor point that lies at the shortest distance from the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int GetClosestAnchorPoint (
PointF point,
bool incoming
)

Visual Basic [image] Copy Code

Public Function GetClosestAnchorPoint( _
point As PointF, _
incoming As Boolean _
) As Integer

Parameters

point

A PointF object specifying a location in the diagram.

incoming

true to look for anchor points that allow incoming links; false to look for ones that allow outgoing links.

Return Value

The index of the found point within the AnchorPattern definition.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetIntersection Method

DiagramNode.GetIntersection Method
[image]

Calculates the intersection point between the segment defined by the specified point pair and the node's outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual PointF GetIntersection (
PointF segmentStart,
PointF segmentEnd
)

Visual Basic [image] Copy Code

Public Overridable Function GetIntersection( _
segmentStart As PointF, _
segmentEnd As PointF _
) As PointF

Parameters

segmentStart
The first point of the segment.
segmentEnd
The second point of the segment.

Return Value

A PointF object representing the intersection point.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetLocalBounds Method

DiagramNode.GetLocalBounds Method
[image]

Gets this node's bounding rectangle in local coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected RectangleF GetLocalBounds ()

Visual Basic [image] Copy Code

Protected Function GetLocalBounds () As RectangleF

Return Value

A RectangleF object representing the bounding rectangle of this node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetNearestBorderPoint Method

DiagramNode.GetNearestBorderPoint Method
[image]

Returns a point that lies on the outline of this node, at the shortest distance from the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual PointF GetNearestBorderPoint (
PointF point
)

Visual Basic [image] Copy Code

Public Overridable Function GetNearestBorderPoint( _
point As PointF _
) As PointF

Parameters

point

A PointF instance specifying a point in the diagram.

Return Value

A PointF specifying the point from the node's outline closest to the point specified as argument.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetOutlinePoly Method

DiagramNode.GetOutlinePoly Method
[image]

DiagramItem.GetOutlinePoly override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override PointCollection GetOutlinePoly (
bool rendering
)

Visual Basic [image] Copy Code

Public Overrides Function GetOutlinePoly( _
rendering As Boolean _
) As PointCollection

Parameters

rendering

Return Value

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetRepaintRect Method

DiagramNode.GetRepaintRect Method
[image]

DiagramItem.GetRepaintRect override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override RectangleF GetRepaintRect (
bool includeConnected
)

Visual Basic [image] Copy Code

Public Overrides Function GetRepaintRect( _
includeConnected As Boolean _
) As RectangleF

Parameters

includeConnected
true if related items should be considered too; otherwise, false.

Return Value

A rectangular region that should be repainted when this node is modified.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetRgnInRect Method

DiagramNode.GetRgnInRect Method
[image]

Creates and returns a Region object for this node as though it is contained in the specified rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual Region GetRgnInRect (
RectangleF rc,
bool inLocal
)

Visual Basic [image] Copy Code

Protected Overridable Function GetRgnInRect( _
rc As RectangleF, _
inLocal As Boolean _
) As Region

Parameters

rc

inLocal

Return Value

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetRotatedBounds Method

DiagramNode.GetRotatedBounds Method
[image]

Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point.

Overload List

Name | Description
DiagramNode.GetRotatedBounds () | DiagramItem.GetRotatedBounds override.
DiagramNode.GetRotatedBounds (RectangleF, PointF, Single) | Gets the bounding rectangle of this node, when it is rotated at the specified angle around the specified pivot.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetRotatedBounds Method ()

DiagramNode.GetRotatedBounds Method ()
See Also
[image]

DiagramItem.GetRotatedBounds override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override RectangleF GetRotatedBounds ()

Visual Basic [image] Copy Code

Public Overrides Function GetRotatedBounds () As RectangleF

Return Value

A rectangle that bounds the rotated shape of the item.

See Also

GetRotatedBounds Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetRotatedBounds Method (RectangleF, PointF, Single)

DiagramNode.GetRotatedBounds Method (RectangleF, PointF, Single)
See Also
[image]

Gets the bounding rectangle of this node, when it is rotated at the specified angle around the specified pivot.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected static RectangleF GetRotatedBounds (
RectangleF rect,
PointF center,
float angle
)

Visual Basic [image] Copy Code

Protected Shared Function GetRotatedBounds( _
rect As RectangleF, _
center As PointF, _
angle As Single _
) As RectangleF

Parameters

rect
The rectangle that will be rotated.
center
The pivot point.
angle
The rotation angle.

Return Value

A RectangleF representing the new bounding rectangle.

See Also

GetRotatedBounds Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetRotationAngle Method

DiagramNode.GetRotationAngle Method
[image]

Gets the rotation angle of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual float GetRotationAngle ()

Visual Basic [image] Copy Code

Public Overridable Function GetRotationAngle () As Single

Return Value

A float value specifying the rotation angle.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetToolTip Method

DiagramNode.GetToolTip Method
[image]

DiagramItem.GetToolTip override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string GetToolTip (
PointF point
)

Visual Basic [image] Copy Code

Public Overrides Function GetToolTip( _
point As PointF _
) As String

Parameters

point
The mouse pointer position.

Return Value

A string specifying the tooltip text.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GroupContains Method

DiagramNode.GroupContains Method
[image]

Determines whether this node is a predecessor of the specified node in the group hierarchy.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected bool GroupContains (
DiagramNode node
)

Visual Basic [image] Copy Code

Protected Function GroupContains ( _
node As DiagramNode _
) As Boolean

Parameters

node
The node to check.

Return Value

true if the specified node is subordinate to this one; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.HitTestHandle Method

DiagramNode.HitTestHandle Method
[image]

DiagramItem.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override AdjustmentHandle HitTestHandle (
PointF point
)

Visual Basic [image] Copy Code

Public Overrides Function HitTestHandle( _
point As PointF _
) As AdjustmentHandle

Parameters

point

A PointF value specifying where to look for a selection handle.

Return Value

Returns an AdjustmentHandle instance representing the adjustment handle found at the specified location, or null if there is none.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
DrawHandles Method
HandlesStyle Property


MindFusion.Diagramming.DiagramNode.HitTestManipulators Method

DiagramNode.HitTestManipulators Method
[image]

DiagramItem.HitTestManipulators override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Manipulator HitTestManipulators (
PointF pt
)

Visual Basic [image] Copy Code

Public Overrides Function HitTestManipulators( _
pt As PointF _
) As Manipulator

Parameters

pt

Return Value

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Intersects Method

DiagramNode.Intersects Method
[image]

Determines whether the node intersects another one, taking into account the outlines of node shapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Intersects (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Function Intersects ( _
node As DiagramNode _
) As Boolean

Parameters

node
A reference to the node to test for intersections with this one.

Return Value

true if the current node intersects with the specified node; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class
Bounds Property


MindFusion.Diagramming.DiagramNode.LoadFrom Method

DiagramNode.LoadFrom Method
[image]

DiagramItem.LoadFrom override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFrom (
BinaryReader reader,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFrom ( _
reader As BinaryReader, _
context As PersistContext _
)

Parameters

reader
A BinaryReader object from which to read the item's data.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.LoadFromXml Method

DiagramNode.LoadFromXml Method
[image]

DiagramItem.LoadFromXml override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFromXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement containing the item's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Move Method

DiagramNode.Move Method
[image]

Moves the node to the specified location.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Move (
float x,
float y
)

Visual Basic [image] Copy Code

Public Sub Move( _
x As Single, _
y As Single _
)

Parameters

x
A float value specifying the new X-coordinate of node's location.
y
A float value specifying the new Y-coordinate of node's location.

Remarks

This method moves a node to the specified position, without changing the node's size. Moving a node also updates the control points coordinates of all links connected to the node.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
Bounds Property
Resize Method


MindFusion.Diagramming.DiagramNode.OnAdd Method

DiagramNode.OnAdd Method
[image]

DiagramItem.OnAdd override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnAdd ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnAdd ()

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnDragOut Method

DiagramNode.OnDragOut Method
[image]

Invoked when a diagram item is being dragged out of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void OnDragOut (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Overridable Sub OnDragOut ( _
item As DiagramItem _
)

Parameters

item
The DiagramItem that is dragged out of the node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnDragOver Method

DiagramNode.OnDragOver Method
[image]

Invoked when a diagram item is being dragged over this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool OnDragOver (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Overridable Function OnDragOver ( _
item As DiagramItem _
) As Boolean

Parameters

item
The DiagramItem that is dragged over the node.

Return Value

false if the diagram should notify nodes below this one; otherwise, true.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnDropOver Method

DiagramNode.OnDropOver Method
[image]

Invoked when a diagram item is dropped over this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool OnDropOver (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Overridable Function OnDropOver ( _
item As DiagramItem _
) As Boolean

Parameters

item
The DiagramItem that is dropped over the node.

Return Value

false if the diagram should notify nodes below this one; otherwise, true.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnMeasureUnitChanged Method

DiagramNode.OnMeasureUnitChanged Method
[image]

DiagramItem.OnMeasureUnitChanged override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnMeasureUnitChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnMeasureUnitChanged ()

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnModify Method

DiagramNode.OnModify Method
[image]

Invoked when the user moves or resizes this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnModify (
PointF mousePosition,
AdjustmentHandles adjustmentHandle
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnModify ( _
mousePosition As PointF, _
adjustmentHandle As AdjustmentHandles _
)

Parameters

mousePosition

Specifies the mouse position.

adjustmentHandle

Specifies the adjustment handle used to modify the node.

Remarks

Implement this method in a custom node class if you need to detect modifications done by the user without handling events of the Diagram class.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnRemove Method

DiagramNode.OnRemove Method
[image]

DiagramItem.OnRemove override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnRemove ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnRemove ()

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnRotationAngleChanged Method

DiagramNode.OnRotationAngleChanged Method
[image]

Invoked when the rotation angle of this node has been changed, either programmatically or interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnRotationAngleChanged ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnRotationAngleChanged ()

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnUpdateBounds Method

DiagramNode.OnUpdateBounds Method
[image]

Overload List

Name | Description
DiagramNode.OnUpdateBounds () | Invoked when the bounding rectangle of the node has changed.
DiagramNode.OnUpdateBounds (Boolean) | Invoked when the bounding rectangle of the node has changed.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnUpdateBounds Method ()

DiagramNode.OnUpdateBounds Method ()
See Also
[image]

Invoked when the bounding rectangle of the node has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnUpdateBounds ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnUpdateBounds ()

See Also

OnUpdateBounds Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnUpdateBounds Method (Boolean)

DiagramNode.OnUpdateBounds Method (Boolean)
See Also
[image]

Invoked when the bounding rectangle of the node has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnUpdateBounds (
bool sizeChanged
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnUpdateBounds( _
sizeChanged As Boolean _
)

Parameters

sizeChanged

true if the size has changed; false if only the position has changed.

See Also

OnUpdateBounds Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnZoomChanged Method

DiagramNode.OnZoomChanged Method
[image]

DiagramItem.OnZoomChanged override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnZoomChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnZoomChanged ()

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.ReassignAnchorPoints Method

DiagramNode.ReassignAnchorPoints Method
[image]

Reassigns links to anchor points so that they are evenly distributed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ReassignAnchorPoints ()

Visual Basic [image] Copy Code

Public Sub ReassignAnchorPoints ()

Remarks

If there are more anchor points defined for this node than links connected to it, this method ensures that each point has at most one link attached to it. ReassignAnchorPoints also tries to assign links to points that are close to their opposite end points.

See Also

DiagramNode Members
DiagramNode Class
AnchorPattern Property


MindFusion.Diagramming.DiagramNode.ReassignUnanchoredLinks Method

DiagramNode.ReassignUnanchoredLinks Method
[image]

Reassigns unanchored links

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ReassignUnanchoredLinks ()

Visual Basic [image] Copy Code

Public Sub ReassignUnanchoredLinks ()

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Resize Method

DiagramNode.Resize Method
[image]

Resizes the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Resize (
float width,
float height
)

Visual Basic [image] Copy Code

Public Sub Resize( _
width As Single, _
height As Single _
)

Parameters

width
A float value specifying new width of the node.
height
A float value specifying new height of the node.

Remarks

This method resizes a node, without changing the node's top-left corner location. Resizing a node also updates the control points coordinates of all links connected to the node.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
Bounds Property
Move Method


MindFusion.Diagramming.DiagramNode.RestoreProperties Method

DiagramNode.RestoreProperties Method
[image]

DiagramItem.RestoreProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overridable Sub RestoreProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties -derived object containing a snapshot of the item's properties.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.RestoreState Method

DiagramNode.RestoreState Method
[image]

DiagramItem.RestoreState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void RestoreState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Overridable Sub RestoreState ( _
state As DiagramItemState _
)

Parameters

state
A DiagramItemState -derived object.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SaveProperties Method

DiagramNode.SaveProperties Method
[image]

DiagramItem.SaveProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties -derived object where the item's properties should be saved.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SaveState Method

DiagramNode.SaveState Method
[image]

DiagramItem.SaveState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SaveState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveState( _
state As DiagramItemState _
)

Parameters

state
A DiagramItemState-derived object.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SaveTo Method

DiagramNode.SaveTo Method
[image]

Serializes the object to the specified writer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveTo (
BinaryWriter writer,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveTo ( _
writer As BinaryWriter, _
context As PersistContext _
)

Parameters

writer
A BinaryWriter object the item's data should be written to.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SaveToXml Method

DiagramNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveToXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement the item's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.ScaleElements Method

DiagramNode.ScaleElements Method
[image]

Scales the node's elements by specified amount.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void ScaleElements (
float scale
)

Visual Basic [image] Copy Code

Protected Overridable Sub ScaleElements( _
scale As Single _
)

Parameters

scale

The value by which to multiply node elements' sizes.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SetBounds Method

DiagramNode.SetBounds Method
[image]

Sets the location and size of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetBounds (
RectangleF rect,
bool updateGroups,
bool updateLinks
)

Visual Basic [image] Copy Code

Public Sub SetBounds( _
rect As RectangleF, _
updateGroups As Boolean, _
updateLinks As Boolean _
)

Parameters

rect
A RectangleF specifying the node position.
updateGroups

Specifies whether the position of child nodes attached to this one should be updated too.

updateLinks

Specifies whether the position of links connected to this node should be updated too.

Remarks

This method lets you set the position of a node without affecting items related to it, such as its incoming and outgoing links, or nodes set as its children using AttachTo. Assigning to the Bounds property or calling the Move and Resize methods always updates the related items.

See Also

DiagramNode Members
DiagramNode Class
Bounds Property


MindFusion.Diagramming.DiagramNode.SetExpandable Method

DiagramNode.SetExpandable Method
[image]

Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void SetExpandable (
bool exp
)

Visual Basic [image] Copy Code

Protected Sub SetExpandable( _
exp As Boolean _
)

Parameters

exp
true if a collapse/expand button should be added to this node; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SetExpanded Method

DiagramNode.SetExpanded Method
[image]

DiagramItem.SetExpanded override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SetExpanded (
bool e
)

Visual Basic [image] Copy Code

Protected Overrides Sub SetExpanded( _
e As Boolean _
)

Parameters

e
Specifies the new state of the node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SetExpandedFlag Method

DiagramNode.SetExpandedFlag Method
[image]

Sets the 'expanded' flag, repainting the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetExpandedFlag (
bool newState
)

Visual Basic [image] Copy Code

Public Sub SetExpandedFlag( _
newState As Boolean _
)

Parameters

newState
Specifies the new state of the node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SetIncomingLinks Method

DiagramNode.SetIncomingLinks Method
[image]

Sets the incoming links collection of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void SetIncomingLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Protected Sub SetIncomingLinks ( _
links As DiagramLinkCollection _
)

Parameters

links
A DiagramLinkCollection containing the node's incoming links.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SetOutgoingLinks Method

DiagramNode.SetOutgoingLinks Method
[image]

Sets the outgoing links collection of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void SetOutgoingLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Protected Sub SetOutgoingLinks ( _
links As DiagramLinkCollection _
)

Parameters

links
A DiagramLinkCollection containing the node's outgoing links.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SetPos Method

DiagramNode.SetPos Method
[image]

Sets the bounding rectangle of this node without updating connected arrows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void SetPos (
Nullable<Single> x,
Nullable<Single> y,
Nullable<Single> w,
Nullable<Single> h
)

Visual Basic [image] Copy Code

Public Overridable Sub SetPos( _
x As Nullable(Of Single), _
y As Nullable(Of Single), _
w As Nullable(Of Single), _
h As Nullable(Of Single) _
)

Parameters

x

y

w

h

Remarks

For internal use.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SetRect Method

DiagramNode.SetRect Method
[image]

This method is used internally by the Ruler control to align nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetRect (
RectangleF rect,
bool raiseModfEvent
)

Visual Basic [image] Copy Code

Public Sub SetRect( _
rect As RectangleF, _
raiseModfEvent As Boolean _
)

Parameters

rect

The new location of the node.

raiseModfEvent
A flag specifying whether to raise the NodeModified event.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SetReference Method

DiagramNode.SetReference Method
[image]

Called during deserialization, after all objects have been instantiated, in order to update the references between them.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SetReference (
int refId,
Object obj,
PersistContext ctx
)

Visual Basic [image] Copy Code

Protected Overridable Sub SetReference ( _
refId As Integer, _
obj As Object, _
ctx As PersistContext _
)

Parameters

refId
Reference identifier.
obj
The newly loaded object.
context

A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

This method is called for references that had been saved using the SaveReference method.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SetReflexive Method

DiagramNode.SetReflexive Method
[image]

Invoked to let a node set the shape of a reflexive link connected to it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SetReflexive (
DiagramLink link
)

Visual Basic [image] Copy Code

Protected Overridable Sub SetReflexive ( _
link As DiagramLink _
)

Parameters

link

Reference to the link.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.ShouldRenderAnchors Method

DiagramNode.ShouldRenderAnchors Method
[image]

Determines whether the node should render its anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected bool ShouldRenderAnchors (
RenderOptions options
)

Visual Basic [image] Copy Code

Protected Function ShouldRenderAnchors ( _
options As RenderOptions _
) As Boolean

Parameters

options
A RenderOptions object providing more information about the current drawing context.

Return Value

true if anchor points should be rendered; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.StartCreate Method

DiagramNode.StartCreate Method
[image]

DiagramItem.StartCreate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void StartCreate (
PointF org
)

Visual Basic [image] Copy Code

Protected Overrides Sub StartCreate( _
org As PointF _
)

Parameters

org
Position of the mouse pointer.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.StartModify Method

DiagramNode.StartModify Method
[image]

DiagramItem.StartModify override. Invoked when the user starts modifying this item interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void StartModify (
PointF org,
AdjustmentHandle handle,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub StartModify( _
org As PointF, _
handle As AdjustmentHandle, _
ist As InteractionState _
)

Parameters

org

Position of the mouse pointer.

handle

The adjustment handle used to modify this node.

ist

An InteractionState object containing more information about the current state of the operation.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.UpdateCreate Method

DiagramNode.UpdateCreate Method
[image]

DiagramItem.UpdateCreate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void UpdateCreate (
PointF current
)

Visual Basic [image] Copy Code

Protected Overrides Sub UpdateCreate( _
current As PointF _
)

Parameters

current
Position of the mouse pointer.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.UpdateLinkIntersections Method

DiagramNode.UpdateLinkIntersections Method
[image]

Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void UpdateLinkIntersections ()

Visual Basic [image] Copy Code

Protected Sub UpdateLinkIntersections ()

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.UpdateLinkPositions Method

DiagramNode.UpdateLinkPositions Method
[image]

Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void UpdateLinkPositions ()

Visual Basic [image] Copy Code

Protected Sub UpdateLinkPositions ()

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.UpdateModify Method

DiagramNode.UpdateModify Method
[image]

DiagramItem.UpdateModify override. Invoked during interactive modification of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void UpdateModify (
PointF current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overridable Sub UpdateModify ( _
current As PointF, _
ist As InteractionState _
)

Parameters

current
Position of the mouse pointer.
ist
An InteractionState object containing more information about the current state of the operation.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode Properties

DiagramNode Properties
[image]

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node.
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node.
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node.
Bounds | Gets or sets the rectangle that defines the position of the diagram node.
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node.
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node.
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node.
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node.
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded.
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like.
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached.
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm.
OutgoingLinks | Gets a collection of links that start from this node.
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node.
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override.
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | Determines whether the node supports connections to its constituent elements.
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

See Also

DiagramNode Class


MindFusion.Diagramming.DiagramNode.AllowIncomingLinks Property

DiagramNode.AllowIncomingLinks Property
[image]

Gets or sets a value indicating whether users are allowed to draw incoming links to this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowIncomingLinks { get; set; }

Visual Basic [image] Copy Code

Public Property AllowIncomingLinks As Boolean

Property Value

true to let users draw incoming links to this node; otherwise, false. The default is true.

Remarks

Links to a node can be created programmatically regardless of the value of this property.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
IncomingLinks Property
AllowOutgoingLinks Property


MindFusion.Diagramming.DiagramNode.AllowOutgoingLinks Property

DiagramNode.AllowOutgoingLinks Property
[image]

Gets or sets a value indicating whether users are allowed to draw outgoing links from this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowOutgoingLinks { get; set; }

Visual Basic [image] Copy Code

Public Property AllowOutgoingLinks As Boolean

Property Value

true to let users draw outgoing links from this node; otherwise, false. The default is true.

Remarks

Links from a node can be created programmatically regardless of the value of this property.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
OutgoingLinks Property
AllowIncomingLinks Property


MindFusion.Diagramming.DiagramNode.AnchorPattern Property

DiagramNode.AnchorPattern Property
[image]

Gets or sets the anchor points to which links are attached when connected to the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern AnchorPattern { get; set; }

Visual Basic [image] Copy Code

Public Property AnchorPattern As AnchorPattern

Property Value

An instance of the AnchorPattern class.

Remarks

This property specifies a set of points to which links can be attached. Each anchor point can accept either incoming links, outgoing links or both. If a node does not have any anchor points defined, links can be connected to any part of the node.

A ShapeNode whose AnchorPattern is not explicitly set uses the AnchorPattern from the Shape definition.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
Diagram.SnapToAnchor Property
ReassignAnchorPoints Method


MindFusion.Diagramming.DiagramNode.Bounds Property

DiagramNode.Bounds Property
[image]

Gets or sets the rectangle that defines the position of the diagram node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF Bounds { get; set; }

Visual Basic [image] Copy Code

Public Property Bounds As RectangleF

Property Value

An instance of the.NET RectangleF structure.

Remarks

Use this property to set or get the size and/or location of a node. Moving a node also updates the control points coordinates of all links connected to the node. If there are subordinate items attached to it, they are moved too by the translation vector defined by the Bounds change. To change the bounding rectangle of a node without affecting related items, call the SetBounds method.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
Move Method
Resize Method
Intersects Method


MindFusion.Diagramming.DiagramNode.Constraints Property

DiagramNode.Constraints Property
[image]

Allows applying constraints to the location and size of the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeConstraints Constraints { get; set; }

Visual Basic [image] Copy Code

Public Property Constraints As NodeConstraints

Property Value

An instance of the NodeConstraints class.

Remarks

These constraints are considered when a user modifies the node interactively. They are ignored if node placement is changed programmatically by using methods and properties.

Example

This sample code disables moving or resizing a node vertically:

C# [image] Copy Code

DiagramNode node = diagram.ActiveItem as DiagramNode;

// Allow moving the node only horizontally
node.Constraints.MoveDirection = DirectionConstraint.Horizontal;

// Disable handles that can be used to resize the node vertically
node.EnabledHandles = AdjustmentHandles.Move |
AdjustmentHandles.ResizeMiddleLeft | AdjustmentHandles.ResizeMiddleRight;

Visual Basic [image] Copy Code

Dim node As DiagramNode = diagram.ActiveItem

' Allow moving the node only horizontally
node.Constraints.MoveDirection = DirectionConstraint.Horizontal

' Disable handles that can be used to resize the node vertically
node.EnabledHandles = AdjustmentHandles.Move + _
AdjustmentHandles.ResizeMiddleLeft + AdjustmentHandles.ResizeMiddleRight

See Also

DiagramNode Members
DiagramNode Class
EnabledHandles Property


MindFusion.Diagramming.DiagramNode.Effects Property

DiagramNode.Effects Property
[image]

Gets a collection with all effects applied to this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IList<NodeEffect> Effects { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Effects As IList(Of NodeEffect)

Property Value

A list with all node effects.

Remarks

The local node effects are applied after the diagram-wide node effects defined in NodeEffects. However, if the first effect in this list is null (Nothing in Visual Basic), the diagram effects are ignored.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.EnabledHandles Property

DiagramNode.EnabledHandles Property
[image]

Gets or sets the kinds of modifications that end-users are permitted to perform on the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AdjustmentHandles EnabledHandles { get; set; }

Visual Basic [image] Copy Code

Public Property EnabledHandles As AdjustmentHandles

Property Value

A combination of the AdjustmentHandles enumeration members. The default is AdjustmentHandles.All.

Remarks

Disabling some selection handles allows restricting the types of modifications that users can perform on a node. Each manipulation handle can be enabled or disabled by setting or clearing the respective flag in the combination.

For example, to make a node resizable only horizontally, set this property to a combination of the Move, ResizeMiddleLeft and ResizeMiddleRight flags. That will disable all manipulation handles, except the left and right ones, which allow horizontal resizing, and the central one allowing movement of the node.

Example

The following code disables the rotation handle of a shape node:

C# [image] Copy Code

node.EnabledHandles = AdjustmentHandles.All & ~ AdjustmentHandles.Rotate;

Visual Basic [image] Copy Code

node.EnabledHandles = AdjustmentHandles.All And Not AdjustmentHandles.Rotate

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
Constraints Property
DiagramView.ModificationStart Property
Diagram.DisabledHandlesColor Property
Diagram.ShowDisabledHandles Property


MindFusion.Diagramming.DiagramNode.Expandable Property

DiagramNode.Expandable Property
[image]

Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Expandable { get; set; }

Visual Basic [image] Copy Code

Public Property Expandable As Boolean

Property Value

true if users are allowed to expand / collapse the tree starting from this node; otherwise, false. The default is false.

Remarks

This property is useful mostly when nodes form a tree-like hierarchical structure. If it is enabled, a small [±] button is drawn beside the node. Clicking that button either shows or hides all children of this node in the tree. It depends on the diagram's ExpandOnIncoming property which items connected to a node are considered its children. The tree expansion continues recursively down the child nodes if the RecursiveExpand property is enabled.

A tree can be collapsed or expanded programmatically by invoking the Collapse or Expand methods on the tree root node.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
Expanded Property
Diagram.NodesExpandable Property
HtmlBuilder.ExpandBtnHyperLink Property


MindFusion.Diagramming.DiagramNode.Expanded Property

DiagramNode.Expanded Property
[image]

Gets or sets a value indicating whether the subtree starting from this node is expanded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool Expanded { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Expanded As Boolean

Property Value

true if the tree starting from this node is expanded; otherwise, false.

Remarks

This property is useful mostly when nodes form a tree-like hierarchical structure. Set it to false to make the subtree starting from a node collapse, with all its child nodes and links becoming invisible. Set it to true to show the child nodes and links again.

A user is allowed to expand or collapse the tree that starts from a node interactively if the Expandable property of that node is enabled.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
Expandable Property
Expand Method


MindFusion.Diagramming.DiagramNode.HandlesStyle Property

DiagramNode.HandlesStyle Property
[image]

Gets or sets a value indicating how the node adjustment handles behave and what do they look like.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HandlesStyle HandlesStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HandlesStyle As HandlesStyle

Property Value

A member of the HandlesStyle enumeration.

Remarks

Specifies how node selection status is indicated visually. In addition, this property defines how manipulation of the node can be done, that is, how to move it, resize it or link it to other nodes. You can assign any of the HandlesStyle values to this property.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
ShapeHandlesStyle Property
DrawHandles Method
HitTestHandle Method


MindFusion.Diagramming.DiagramNode.HasItems Property

DiagramNode.HasItems Property
[image]

Determines whether the node supports connections to its constituent elements.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual bool HasItems { get; }

Visual Basic [image] Copy Code

Protected Overridable ReadOnly Property HasItems As Boolean

Property Value

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.IncomingLinks Property

DiagramNode.IncomingLinks Property
[image]

Gets a collection of links that point to the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection IncomingLinks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IncomingLinks As DiagramLinkCollection

Property Value

A reference to a DiagramLinkCollection object.

Remarks

Use this collection to get access to every link pointing to the node, as well as get the number of such links. If the node is a table, links that connect to it as a whole entity are included in the collection, and links that connect to particular row of the table are included in IncomingLinks.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
AllowIncomingLinks Property
OutgoingLinks Property
TableNode.ConnectionStyle Property
Query Method


MindFusion.Diagramming.DiagramNode.MasterGroup Property

DiagramNode.MasterGroup Property
[image]

Gets a reference to the group to which this node is attached.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Group MasterGroup { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MasterGroup As Group

Property Value

A reference to a Group object or null (Nothing in Visual Basic) if the node is not attached to a group.

Remarks

Diagram items can be grouped hierarchically in such a manner, that if an item is moved all of its subordinated items in the hierarchy move too. The immediate subordinates of an item are contained and represented by a Group instance. This property provides access to the group that contains the item as a subordinate. If the item is not a subordinate of another, the property returns null (Nothing in Visual Basic).

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
SubordinateGroup Property
Factory.CreateGroup Method
Query Method


MindFusion.Diagramming.DiagramNode.Obstacle Property

DiagramNode.Obstacle Property
[image]

Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Obstacle { get; set; }

Visual Basic [image] Copy Code

Public Property Obstacle As Boolean

Property Value

true makes routed links look for a path going around this node; false lets links cross the node. The default is true.

Remarks

It is useful to set this property to false for nodes used as decorative containers or labels.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
DiagramLink.AutoRoute Property
Diagram.RouteAllLinks Method


MindFusion.Diagramming.DiagramNode.OutgoingLinks Property

DiagramNode.OutgoingLinks Property
[image]

Gets a collection of links that start from this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection OutgoingLinks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OutgoingLinks As DiagramLinkCollection

Property Value

A reference to a DiagramLinkCollection object.

Remarks

Use this collection to get access to every link starting from the node, as well as get the number of such links. If the node is a table, links that connect to it as a whole entity are included in the collection, and links that connect to particular row of the table are included in OutgoingLinks.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
AllowOutgoingLinks Property
IncomingLinks Property
TableNode.ConnectionStyle Property
Query Method


MindFusion.Diagramming.DiagramNode.RotationAngle Property

DiagramNode.RotationAngle Property
[image]

Gets or sets the rotation angle of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float RotationAngle { get; set; }

Visual Basic [image] Copy Code

Public Property RotationAngle As Single

Property Value

A float value specifying the rotation angle in degrees.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.TopLevel Property

DiagramNode.TopLevel Property
[image]

DiagramItem.TopLevel override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool TopLevel { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property TopLevel As Boolean

Property Value

true if this is a top-level item in the diagram; false otherwise.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNodeCollection Class

DiagramNodeCollection Class
[image]

Represents a strongly typed collection of diagram nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramNodeCollection : ItemCollectionBase<DiagramNode>

Visual Basic [image] Copy Code

Public Class DiagramNodeCollection
Inherits ItemCollectionBase(Of DiagramNode)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.CollectionBase(DiagramNode)
MindFusion.Diagramming.PersistableCollection(DiagramNode)
MindFusion.Diagramming.ItemCollectionBase(DiagramNode)
MindFusion.Diagramming.DiagramNodeCollection

See Also

DiagramNodeCollection Members


MindFusion.Diagramming.DiagramNodeCollection Members

DiagramNodeCollection Members
Constructors Fields Properties Methods
[image]

Represents a strongly typed collection of diagram nodes.

The following tables list the members exposed by the DiagramNodeCollection type.

Public Constructors

Name | Description
DiagramNodeCollection | Initializes a new instance of the DiagramNodeCollection class.

Protected Fields

Name | Description
InnerList | Gets a List<T> containing the list of elements in the collection instance. (Inherited from CollectionBase.)
itemEventArgs | A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector. (Inherited from ItemCollectionBase.)
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items. (Inherited from ItemCollectionBase.)

Public Properties

Name | Description
Count | Gets the number of elements actually contained in the collection. (Inherited from CollectionBase.)
IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index. (Inherited from CollectionBase.)

Public Methods

Name | Description
Add | Adds the specified diagram item to the collection. (Inherited from ItemCollectionBase.)
Clear | Removes all diagram items from the collection. (Inherited from ItemCollectionBase.)
Clone | Creates a shallow copy of this collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from CollectionBase.)
GetAt | Gets the diagram item at the specified position. (Inherited from ItemCollectionBase.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified diagram item into the collection at the specified position. (Inherited from ItemCollectionBase.)
Remove | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
RemoveAt | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
Sort | Overloaded. (Inherited from CollectionBase.)

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event. (Inherited from ItemCollectionBase.)
RaiseInserting | Raises the Inserting event. (Inherited from ItemCollectionBase.)
RaiseRemoving | Raises the Removing event. (Inherited from ItemCollectionBase.)

See Also

DiagramNodeCollection Class


MindFusion.Diagramming.DiagramNodeCollection Constructor

DiagramNodeCollection Constructor
[image]

Initializes a new instance of the DiagramNodeCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramNodeCollection Class


MindFusion.Diagramming.DiagramNodeCollection Methods

DiagramNodeCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified diagram item to the collection. (Inherited from ItemCollectionBase.)
Clear | Removes all diagram items from the collection. (Inherited from ItemCollectionBase.)
Clone | Creates a shallow copy of this collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from CollectionBase.)
GetAt | Gets the diagram item at the specified position. (Inherited from ItemCollectionBase.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified diagram item into the collection at the specified position. (Inherited from ItemCollectionBase.)
Remove | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
RemoveAt | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
Sort | Overloaded. (Inherited from CollectionBase.)

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event. (Inherited from ItemCollectionBase.)
RaiseInserting | Raises the Inserting event. (Inherited from ItemCollectionBase.)
RaiseRemoving | Raises the Removing event. (Inherited from ItemCollectionBase.)

See Also

DiagramNodeCollection Class


MindFusion.Diagramming.DiagramNodeCollection.Clone Method

DiagramNodeCollection.Clone Method
[image]

Creates a shallow copy of this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeCollection Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As DiagramNodeCollection

Return Value

An instance of the DiagramNodeCollection class.

See Also

DiagramNodeCollection Members
DiagramNodeCollection Class


MindFusion.Diagramming.DiagramNodeEventArgs Class

DiagramNodeEventArgs Class
[image]

Contains the arguments passed to the NodeSelected and NodeRemoved event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramNodeEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DiagramNodeEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.DiagramNodeEventArgs

See Also

DiagramNodeEventArgs Members


MindFusion.Diagramming.DiagramNodeEventArgs Members

DiagramNodeEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the NodeSelected and NodeRemoved event handlers.

The following tables list the members exposed by the DiagramNodeEventArgs type.

Public Constructors

Name | Description
DiagramNodeEventArgs | Overloaded. Initializes a new instance of the DiagramNodeEventArgs class.

Public Properties

Name | Description
Index | Gets or sets the index of the node within its containing collection.
Node | Gets the node related to the event.

See Also

DiagramNodeEventArgs Class


MindFusion.Diagramming.DiagramNodeEventArgs Constructor

DiagramNodeEventArgs Constructor
[image]

Initializes a new instance of the DiagramNodeEventArgs class.

Overload List

Name | Description
DiagramNodeEventArgs (DiagramNode) | Initializes a new instance of the DiagramNodeEventArgs class.
DiagramNodeEventArgs (DiagramNode, Int32) | Initializes a new instance of the DiagramNodeEventArgs class.

See Also

DiagramNodeEventArgs Class


MindFusion.Diagramming.DiagramNodeEventArgs Constructor (DiagramNode)

DiagramNodeEventArgs Constructor (DiagramNode)
See Also
[image]

Initializes a new instance of the DiagramNodeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeEventArgs (
DiagramNode node
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode _
)

Parameters

node

The node related to the event.

See Also

DiagramNodeEventArgs Constructor Overload List
DiagramNodeEventArgs Class


MindFusion.Diagramming.DiagramNodeEventArgs Constructor (DiagramNode, Int32)

DiagramNodeEventArgs Constructor (DiagramNode, Int32)
See Also
[image]

Initializes a new instance of the DiagramNodeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeEventArgs (
DiagramNode node,
int index
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode, _
index As Integer _
)

Parameters

node

The node related to the event.

index

The zero-based index of the node within its containing collection.

See Also

DiagramNodeEventArgs Constructor Overload List
DiagramNodeEventArgs Class


MindFusion.Diagramming.DiagramNodeEventArgs Properties

DiagramNodeEventArgs Properties
[image]

Public Properties

Name | Description
Index | Gets or sets the index of the node within its containing collection.
Node | Gets the node related to the event.

See Also

DiagramNodeEventArgs Class


MindFusion.Diagramming.DiagramNodeEventArgs.Index Property

DiagramNodeEventArgs.Index Property
[image]

Gets or sets the index of the node within its containing collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Index { get; set; }

Visual Basic [image] Copy Code

Public Property Index As Integer

Property Value

An integer value.

See Also

DiagramNodeEventArgs Members
DiagramNodeEventArgs Class


MindFusion.Diagramming.DiagramNodeEventArgs.Node Property

DiagramNodeEventArgs.Node Property
[image]

Gets the node related to the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Node { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Node As DiagramNode

Property Value

A DiagramNode object.

See Also

DiagramNodeEventArgs Members
DiagramNodeEventArgs Class


MindFusion.Diagramming.DiagramNodeProperties Class

DiagramNodeProperties Class
[image]

The base class for classes that store the properties for a DiagramNode-derived items during undo / redo operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramNodeProperties : DiagramItemProperties

Visual Basic [image] Copy Code

Public Class DiagramNodeProperties
Inherits DiagramItemProperties

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemProperties
MindFusion.Diagramming.DiagramNodeProperties
MindFusion.Diagramming.BarcodeNodeProperties
MindFusion.Diagramming.ContainerNodeProperties
MindFusion.Diagramming.MapNodeProperties
MindFusion.Diagramming.ShapeNodeProperties
MindFusion.Diagramming.TableNodeProperties
MindFusion.Diagramming.VisioNodeProperties

See Also

DiagramNodeProperties Members


MindFusion.Diagramming.DiagramNodeProperties Members

DiagramNodeProperties Members
Constructors Fields Methods
[image]

The base class for classes that store the properties for a DiagramNode-derived items during undo / redo operations.

The following tables list the members exposed by the DiagramNodeProperties type.

Public Constructors

Name | Description
DiagramNodeProperties | Initializes a new instance of the DiagramNodeProperties class.

Public Fields

Name | Description
ItemClass | For internal use. (Inherited from DiagramItemProperties.)
Selected | For internal use. (Inherited from DiagramItemProperties.)
TextPadding | For internal use. (Inherited from DiagramItemProperties.)
ZIndex | For internal use. (Inherited from DiagramItemProperties.)

Public Methods

Name | Description
FreeResources | Frees stored resources which will no longer be used. (Inherited from DiagramItemProperties.)

See Also

DiagramNodeProperties Class


MindFusion.Diagramming.DiagramNodeProperties Constructor

DiagramNodeProperties Constructor
[image]

Initializes a new instance of the DiagramNodeProperties class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeProperties ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramNodeProperties Class


MindFusion.Diagramming.DiagramNodeState Class

DiagramNodeState Class
Remarks See Also
[image]

Contains a snapshot of the internal state of a DiagramNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramNodeState : DiagramItemState

Visual Basic [image] Copy Code

Public Class DiagramNodeState
Inherits DiagramItemState

Remarks

Instances of this class are used to store the state of nodes for later undo or redo operations. If you derive from DiagramNode and need to implement undo support for the additional internal state defined by your class, do so by deriving from DiagramNodeState and overriding the DiagramNode.CreateState, DiagramNode.SaveState and DiagramNode.RestoreState methods.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemState
MindFusion.Diagramming.DiagramNodeState
MindFusion.Diagramming.ShapeNodeState

See Also

DiagramNodeState Members


MindFusion.Diagramming.DiagramNodeState Members

DiagramNodeState Members
Constructors
[image]

Contains a snapshot of the internal state of a DiagramNode.

The following tables list the members exposed by the DiagramNodeState type.

Public Constructors

Name | Description
DiagramNodeState | Initializes a new instance of the DiagramNodeState class.

See Also

DiagramNodeState Class


MindFusion.Diagramming.DiagramNodeState Constructor

DiagramNodeState Constructor
[image]

Initializes a new instance of the DiagramNodeState class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeState ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramNodeState Class


MindFusion.Diagramming.DiagramNodeStyle Class

DiagramNodeStyle Class
[image]

Represents a reusable set of properties that define the appearance of diagram nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class DiagramNodeStyle : DiagramItemStyle

Visual Basic [image] Copy Code

Public MustInherit Class DiagramNodeStyle
Inherits DiagramItemStyle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Style
MindFusion.Diagramming.DiagramItemStyle
MindFusion.Diagramming.DiagramNodeStyle
MindFusion.Diagramming.BarcodeNodeStyle
MindFusion.Diagramming.CompositeNodeStyle
MindFusion.Diagramming.ContainerNodeStyle
MindFusion.Diagramming.ShapeNodeStyle
MindFusion.Diagramming.SvgNodeStyle
MindFusion.Diagramming.TableNodeStyle
MindFusion.Diagramming.TreeViewNodeStyle
MindFusion.Diagramming.VisioNodeStyle

See Also

DiagramNodeStyle Members


MindFusion.Diagramming.DiagramNodeStyle Members

DiagramNodeStyle Members
Constructors Properties Methods Events
[image]

Represents a reusable set of properties that define the appearance of diagram nodes.

The following tables list the members exposed by the DiagramNodeStyle type.

Protected Constructors

Name | Description
DiagramNodeStyle | Initializes a new instance of the DiagramNodeStyle class.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of the item. (Inherited from DiagramItemStyle.)
Effects | Gets a list of the effects applied to the node.
FontFamily | Gets or sets the font family of the item text. (Inherited from DiagramItemStyle.)
FontSize | Gets or sets the font size of the item text. (Inherited from DiagramItemStyle.)
FontStyle | Gets or sets the font style of the item text. (Inherited from DiagramItemStyle.)
FontUnit | Gets or sets the font unit of the item text. (Inherited from DiagramItemStyle.)
ShadowBrush | Gets or sets the brush used to paint the shadow of the item. (Inherited from DiagramItemStyle.)
Stroke | Gets or sets the brush used to paint the outline of the item. (Inherited from DiagramItemStyle.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItemStyle.)
StrokeThickness | Gets or sets the thickness of the item's outline, expressed in the current units of measure. (Inherited from DiagramItemStyle.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItemStyle.)

Public Methods

Name | Description
GetProperties | Gets all properties in the style. (Inherited from Style.)
GetProperty | Returns the property with the specified name, if any. (Inherited from Style.)
RegisterType | Associates a type with an alias. (Inherited from Style.)

Protected Methods

Name | Description
GetValue | Gets the value of the specified property. (Inherited from Style.)
IsPropertySet | Checks whether the specified property has a value. (Inherited from Style.)
LoadFrom | Deserializes the item from the specified reader. (Inherited from Style.)
LoadFromXml | Loads the style content from an XML element. (Inherited from Style.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Style.)
RegisterProperty | Registers a new property with the specified name and type. (Inherited from Style.)
SaveTo | Serializes the style to the specified writer. (Inherited from Style.)
SaveToXml | Saves the style content into an XML element. (Inherited from Style.)
SetValue | Sets the value of the specified property. (Inherited from Style.)
UnsetValue | Clears the value of the specified property. (Inherited from Style.)

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

DiagramNodeStyle Class


MindFusion.Diagramming.DiagramNodeStyle Constructor

DiagramNodeStyle Constructor
[image]

Initializes a new instance of the DiagramNodeStyle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DiagramNodeStyle ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

DiagramNodeStyle Class


MindFusion.Diagramming.DiagramNodeStyle Properties

DiagramNodeStyle Properties
[image]

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of the item. (Inherited from DiagramItemStyle.)
Effects | Gets a list of the effects applied to the node.
FontFamily | Gets or sets the font family of the item text. (Inherited from DiagramItemStyle.)
FontSize | Gets or sets the font size of the item text. (Inherited from DiagramItemStyle.)
FontStyle | Gets or sets the font style of the item text. (Inherited from DiagramItemStyle.)
FontUnit | Gets or sets the font unit of the item text. (Inherited from DiagramItemStyle.)
ShadowBrush | Gets or sets the brush used to paint the shadow of the item. (Inherited from DiagramItemStyle.)
Stroke | Gets or sets the brush used to paint the outline of the item. (Inherited from DiagramItemStyle.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItemStyle.)
StrokeThickness | Gets or sets the thickness of the item's outline, expressed in the current units of measure. (Inherited from DiagramItemStyle.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItemStyle.)

See Also

DiagramNodeStyle Class


MindFusion.Diagramming.DiagramNodeStyle.Effects Property

DiagramNodeStyle.Effects Property
[image]

Gets a list of the effects applied to the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IList<NodeEffect> Effects { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Effects As IList(Of NodeEffect)

Property Value

A list of NodeEffect objects.

See Also

DiagramNodeStyle Members
DiagramNodeStyle Class


MindFusion.Diagramming.DiagramNodeStyle Events

DiagramNodeStyle Events
[image]

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

DiagramNodeStyle Class


MindFusion.Diagramming.DiagramPage Class

DiagramPage Class
[image]

Represents a single page in a DiagramDocument object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramPage : Diagram, INotifyPropertyChanged

Visual Basic [image] Copy Code

Public Class DiagramPage
Inherits Diagram
Implements INotifyPropertyChanged

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.DiagramBase
MindFusion.Diagramming.Diagram
MindFusion.Diagramming.DiagramPage

See Also

DiagramPage Members


MindFusion.Diagramming.DiagramPage Members

DiagramPage Members
Constructors Fields Properties Methods Events
[image]

Represents a single page in a DiagramDocument object.

The following tables list the members exposed by the DiagramPage type.

Public Constructors

Name | Description
DiagramPage | Initializes a new instance of the DiagramPage class.

Public Fields

Name | Description
Dummy | A shared DummyNode instance. (Inherited from Diagram.)

Public Properties

Name | Description
ActiveItem | Gets or sets the active diagram element. (Inherited from Diagram.)
ActiveItemHandlesStyle | Gets the visual style of adjustment handles of the active item. (Inherited from Diagram.)
ActiveLayer | Gets or sets the zero-based index of the active layer. (Inherited from Diagram.)
AdjustmentHandlesSize | Gets or sets the size of the handles, which appear around selected objects. (Inherited from Diagram.)
AlignmentGuidePen | Gets or sets the pen used to draw alignment guides. (Inherited from Diagram.)
AlignToGrid | Gets or sets a value indicating whether the diagram items is aligned to a grid. (Inherited from Diagram.)
AllowLinksRepeat | Gets or sets a value indicating whether more than one link can connect the same origin and destination diagram nodes. (Inherited from Diagram.)
AllowMultipleResize | Gets or sets whether multiple selected nodes can be resized simultaneously. (Inherited from Diagram.)
AllowSelfLoops | Gets or sets a value indicating whether self-loops are allowed. (Inherited from Diagram.)
AllowSplitLinks | Gets or sets a value indicating whether link segments can be added and removed interactively. (Inherited from Diagram.)
AllowUnanchoredLinks | Gets or sets a value indicating whether links can be connected to nodes to which there aren't anchor points assigned. (Inherited from Diagram.)
AllowUnconnectedLinks | Gets or sets a value indicating whether users are allowed to draw links that are not connected to any node. (Inherited from Diagram.)
AutoAlignDistance | Gets or sets the maximal horizontal or vertical distance at which a node aligns to the borders of other nodes. (Inherited from Diagram.)
AutoAlignNodes | Gets or sets whether nodes should automatically align to the borders of other nodes during user interaction. (Inherited from Diagram.)
AutoHighlightRows | Gets or sets whether a table row should be highlighted when the user clicks on it. (Inherited from Diagram.)
AutoResize | Gets or sets a value indicating whether the document area must be resized automatically so it fits the diagram contents. (Inherited from Diagram.)
AutoSnapDistance | Specifies the maximum distance at which links auto-snap to nodes. (Inherited from Diagram.)
AutoSnapLinks | Gets or sets the default value for the AutoSnapToNode property of new links. (Inherited from Diagram.)
BackBrush | Gets or sets the brush used for painting the diagram background. (Inherited from Diagram.)
BackgroundImage | Gets or sets the image displayed as background of this diagram. (Inherited from Diagram.)
BackgroundImageAlign | Gets or sets a value indicating how the background image is positioned, relatively to the scrollable document area. (Inherited from Diagram.)
BackgroundImageUrl | URL of the image painted as diagram's background. (Inherited from Diagram.)
BarcodeNodeStyle | Gets the theme-level style for barcode nodes. (Inherited from Diagram.)
Bounds | Gets or sets a value representing the size of the diagram's scrollable area. (Inherited from Diagram.)
BoundsPen | The pen with which the document bounds should be drawn. (Inherited from Diagram.)
CellCustomDraw | Gets or sets the default type of custom painting done on the cells of tables. (Inherited from Diagram.)
CellFrameStyle | Gets or sets the default cell border style of new tables. (Inherited from Diagram.)
CompositeNodeStyle | Gets the theme-level style for composite nodes. (Inherited from Diagram.)
ContainerCaption | Gets or sets the default value for the Caption property of containers. (Inherited from Diagram.)
ContainerCaptionHeight | Gets or sets the default value for the CaptionHeight property of containers. (Inherited from Diagram.)
ContainerHighlightPen | Gets or sets the default value for the HighlightPen property of containers. (Inherited from Diagram.)
ContainerMargin | Gets or sets the default value for the Margin property of containers. (Inherited from Diagram.)
ContainerMinimumSize | Gets or sets the default value for the MinimumSize property of containers. (Inherited from Diagram.)
ContainerNodeStyle | Gets the theme-level style for container nodes. (Inherited from Diagram.)
ContainersFoldable | Gets or sets the default value for the Foldable property of containers. (Inherited from Diagram.)
CrossingRadius | Gets or sets the radius length of decorations displayed at link intersection points. (Inherited from Diagram.)
DefaultShape | Gets or sets the default shape of shape nodes. (Inherited from Diagram.)
DiagramLinkStyle | Gets the theme-level style for diagram links. (Inherited from Diagram.)
DiagramStyle | Gets the theme-level style for the diagram. (Inherited from Diagram.)
Dirty | Gets or sets a value indicating whether the diagram has changed since the last save. (Inherited from Diagram.)
DisabledHandlesStyle | Gets the visual style of disabled adjustment handles. (Inherited from Diagram.)
DynamicLinks | Gets or sets the default value for the Dynamic property of new links. (Inherited from Diagram.)
EffectiveBackBrush | Gets the currently effective background brush of the diagram. (Inherited from Diagram.)
EffectsProvider | Gets or sets an object used to generate visual effects for shape nodes such as embossment and shadow dispersion. (Inherited from Diagram.)
EnableEmbossEffects | Gets or sets a value indicating whether emboss effect for shape nodes is enabled. (Inherited from Diagram.)
EnableLanes | Gets or sets whether lanes are enabled. (Inherited from Diagram.)
EnableShadowEffects | Gets or sets a value indicating whether the shadow dispersion effect for nodes is enabled. (Inherited from Diagram.)
EnableStyledText | Gets or sets the default value for the EnableStyledText property of new nodes. (Inherited from Diagram.)
ExpandButtonAction | Gets or sets a value indicating what should happen when a user clicks the [±] button that is displayed near expandable nodes. (Inherited from Diagram.)
ExpandButtonPosition | Gets or sets where expand/collapse buttons are located relatively to their nodes. (Inherited from Diagram.)
ExpandOnIncoming | Gets or sets a value, indicating in which direction object hierarchies are expanded. (Inherited from Diagram.)
ExteriorBrush | Gets or sets the brush used for painting the area outside Bounds. (Inherited from Diagram.)
Factory | Gets a Factory instance that lets you add programmatically new items to the diagram. (Inherited from Diagram.)
FocusedComponent | Gets or sets the component within this diagram which currently has the input focus. (Inherited from Diagram.)
FoldedContainerSize | Gets or sets the size of folded containers. (Inherited from Diagram.)
Font | Gets or sets the default font for new diagram items. (Inherited from Diagram.)
GridColor | Gets or sets the color of the grid points. (Inherited from Diagram.)
GridOffsetX | Gets or sets the horizontal offset of the first point of the alignment grid. (Inherited from Diagram.)
GridOffsetY | Gets or sets the vertical offset of the first point of the alignment grid. (Inherited from Diagram.)
GridSizeX | Gets or sets the horizontal distance between adjacent grid points. (Inherited from Diagram.)
GridSizeY | Gets or sets the vertical distance between adjacent grid points. (Inherited from Diagram.)
GridStyle | Gets or sets the visual style of the alignment grid. (Inherited from Diagram.)
Groups | Gets a collection of all groups in the diagram. (Inherited from Diagram.)
HitTestPriority | Gets or sets a value indicating the order in which items are hit-tested. (Inherited from Diagram.)
Icon | Gets or sets an image associated with the page.
Interaction | Gets an InteractionState instance representing the current action being carried out by the user. (Inherited from Diagram.)
IsProEdition | Gets a value indicating whether the currently loaded MvcDiagram is a professional version of the control. (Inherited from Diagram.)
Items | Gets a collection of all items in this diagram. (Inherited from Diagram.)
LaneGrid | Gets the Grid instance that represents the lane grid. (Inherited from Diagram.)
Layers | Gets a list of the layers in the current diagram. (Inherited from Diagram.)
LinkBaseShape | Gets or sets the shape displayed at the base of new links. (Inherited from Diagram.)
LinkBaseShapeSize | Gets or sets the default size of the base of new links. (Inherited from Diagram.)
LinkBrush | Gets or sets the default value for the Brush property of links. (Inherited from Diagram.)
LinkCascadeOrientation | Gets or sets the initial orientation of the first segment of new cascading links. (Inherited from Diagram.)
LinkCrossings | Gets or sets how to render the intersection points where links cross their paths. (Inherited from Diagram.)
LinkCustomDraw | Gets or sets the default type of custom painting done on links. (Inherited from Diagram.)
LinkEndsMovable | Gets or sets a value indicating whether link ends can be moved by users after the link is created. (Inherited from Diagram.)
LinkHandlesStyle | Gets or sets the default value for the HandlesStyle property of new links. (Inherited from Diagram.)
LinkHeadShape | Gets or sets the shape displayed as head of new links. (Inherited from Diagram.)
LinkHeadShapeSize | Gets or sets the default size of arrowheads. (Inherited from Diagram.)
LinkHitDistance | Gets or sets a value specifying how far from a link a click is still considered a hit. (Inherited from Diagram.)
LinkIntermediateShape | Gets or sets the default shape to be displayed in the middle of each segment of links. (Inherited from Diagram.)
LinkIntermediateShapeSize | Gets or sets the default size of the shapes at middles of link segments. (Inherited from Diagram.)
LinkPen | Gets or sets the default value for the Pen and HeadPen properties of links. (Inherited from Diagram.)
LinkRouter | Gets or sets the component used to find paths for auto-routed links when diagram nodes are added or their positions change. (Inherited from Diagram.)
Links | Gets a collection of all DiagramLink objects in the diagram. (Inherited from Diagram.)
LinkSegments | Gets or sets the default number of link segments. (Inherited from Diagram.)
LinkShape | Gets or sets the default value of the Shape property of new links. (Inherited from Diagram.)
LinksRetainForm | Gets or sets whether links should maintain their forms if the nodes linked with those links are moved around. (Inherited from Diagram.)
LinkText | Gets or sets the default text of links. (Inherited from Diagram.)
LinkTextStyle | Gets or sets default placement and orientation for links' text. (Inherited from Diagram.)
MeasureTextRenderingHint | Gets or sets the TextRenderingHint to use when measuring texts. This should be effectively set to the value of DiagramView.TextRenderingHint. (Inherited from Diagram.)
MeasureUnit | Gets or sets the unit of measure used for logical coordinates in this diagram. (Inherited from Diagram.)
MergeThreshold | Gets or sets the maximum distance between adjacent control points of a link at which the respective segments can be merged. (Inherited from Diagram.)
MinimumNodeSize | Gets or sets the minimum node size that the user is allowed to set. (Inherited from Diagram.)
NodeEffects | Gets a collection with all effects applied to the nodes of this diagram. (Inherited from Diagram.)
Nodes | Gets a collection of all DiagramNode objects in the diagram. (Inherited from Diagram.)
NodesExpandable | Gets or sets a value indicating whether newly created nodes can be expanded. (Inherited from Diagram.)
NowLoading | Gets a value indicating whether the diagram data is now being loaded from a file. (Inherited from Diagram.)
PolygonalTextLayout | Gets or sets a value indicating whether to enable the formatting of text inside non-rectangular shape node outlines. (Inherited from Diagram.)
RecursiveExpand | Gets or sets value indicating how a tree is expanded. (Inherited from Diagram.)
RestrictItemsToBounds | Gets or sets a value indicating whether users are allowed to place items outside the scrollable area of the diagram. (Inherited from Diagram.)
RoundedLinks | Gets or sets a value indicating whether the joins between segments of Polyline and Cascading links should be rounded. (Inherited from Diagram.)
RoundedLinksRadius | Gets or sets the radius of arc joins of rounded links' segments. (Inherited from Diagram.)
RoundRectFactor | Gets or sets the relative size of arcs displayed at the corners of rounded rectangles. (Inherited from Diagram.)
RouteLinks | Gets or sets a value indicating whether links should avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes. (Inherited from Diagram.)
RoutingOptions | Gets an object, which allows customizing various parameters of the link routing algorithm. (Inherited from Diagram.)
RowHighlightBrush | Gets or sets the Brush used to fill highlighted table rows. (Inherited from Diagram.)
ScriptHelper | Gets a ScriptHelper object which can be used in html scripts to instantiate various objects and to call static methods. (Inherited from Diagram.)
SelectAfterCreate | Gets or sets a value indicating whether newly created objects are automatically selected. (Inherited from Diagram.)
SelectedItemHandlesStyle | Gets the visual style of adjustment handles of selected items. (Inherited from Diagram.)
Selection | Gets a Selection instance that represents the selection of items in this diagram. (Inherited from Diagram.)
SelectionOnTop | Gets or sets a value indicating whether selected items should be painted on top of other items. (Inherited from Diagram.)
SerializationBinder | Gets or sets a SerializationBinder object used to control class loading. (Inherited from Diagram.)
ShadowBrush | Gets or sets the default brush used to paint the shadows cast by diagram items. (Inherited from Diagram.)
ShadowOffsetX | Gets or sets the horizontal offset of item shadows. (Inherited from Diagram.)
ShadowOffsetY | Gets or sets the vertical offset of item shadows. (Inherited from Diagram.)
ShadowsStyle | Gets or sets the style for rendering shadows. (Inherited from Diagram.)
ShapeBrush | Gets or sets the default value for the Brush property of shape nodes. (Inherited from Diagram.)
ShapeCustomDraw | Gets or sets the default type of custom painting done for shape nodes. (Inherited from Diagram.)
ShapeHandlesStyle | Gets or sets the default value for the HandlesStyle property of new shape nodes. (Inherited from Diagram.)
ShapeNodeStyle | Gets the theme-level style for shape nodes. (Inherited from Diagram.)
ShapeOrientation | Gets or sets the default value for the ShapeOrientation property of shape nodes. (Inherited from Diagram.)
ShapePen | Gets or sets the default value for the Pen property of shape nodes. (Inherited from Diagram.)
ShapeText | Gets or sets the default text of shape nodes. (Inherited from Diagram.)
ShowAnchors | Gets or sets a value indicating whether and when node anchor points should be displayed. (Inherited from Diagram.)
ShowDisabledHandles | Gets or sets a value indicating whether manipulation handles are painted when they are disabled. (Inherited from Diagram.)
ShowGrid | Gets or sets a value indicating whether the alignment grid is visible. (Inherited from Diagram.)
ShowHandlesOnDrag | Gets or sets a value indicating whether to display selection handles of objects under the mouse while another object is being modified. (Inherited from Diagram.)
SnapToAnchor | Gets or sets when link end points should be aligned to the nearest anchor points. (Inherited from Diagram.)
SortGroupsByZ | Gets or sets a value indicating whether grouped items should be drawn sorted by their z-order while the whole group is being moved. (Inherited from Diagram.)
Style | Gets or sets the style associated with the diagram. (Inherited from Diagram.)
SvgNodeStyle | Gets the theme-level style for SVG nodes. (Inherited from Diagram.)
TableBrush | Gets or sets the default value for the Brush property of tables. (Inherited from Diagram.)
TableCaption | Gets or sets the default text for tables' captions. (Inherited from Diagram.)
TableCaptionHeight | Gets or sets the default height of table captions. (Inherited from Diagram.)
TableColumnCount | Gets or sets the default number of table columns. (Inherited from Diagram.)
TableColumnWidth | Gets or sets the default width of tables' columns. (Inherited from Diagram.)
TableConnectionStyle | Gets or sets a value indicating whether drawing a link between tables should connect the rows of those tables, or the tables as whole entities. (Inherited from Diagram.)
TableCustomDraw | Gets or sets the default type of custom painting done on tables. (Inherited from Diagram.)
TableHandlesStyle | Gets or sets the default value for the HandlesStyle property of new tables. (Inherited from Diagram.)
TableNodeStyle | Gets the theme-level style for table nodes. (Inherited from Diagram.)
TablePen | Gets or sets the default value for the Pen property of tables. (Inherited from Diagram.)
TableRowCount | Gets or sets the default number of table rows. (Inherited from Diagram.)
TableRowHeight | Gets or sets the default height of tables' rows. (Inherited from Diagram.)
TableShape | Gets or sets the default value of the Shape property of new tables. (Inherited from Diagram.)
TablesScrollable | Gets or sets the default value for the Scrollable property of new tables. (Inherited from Diagram.)
Tag | Gets or sets custom data associated with this diagram. (Inherited from Diagram.)
TextColor | Gets or sets the default color of text displayed inside diagram items. (Inherited from Diagram.)
TextFormat | Gets or sets the default alignment and formatting style for text displayed inside nodes and table cells. (Inherited from Diagram.)
Theme | Gets or sets the theme associated with the diagram. (Inherited from Diagram.)
Title | Gets or sets the page title.
TitleColor | Gets or sets the color of the title when the title is displayed.
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram. (Inherited from Diagram.)
TreeViewNodeStyle | Gets the theme-level style for tree view nodes. (Inherited from Diagram.)
UndoManager | Gets a reference to the diagram's UndoManager instance. (Inherited from Diagram.)
ValidityChecks | Gets or sets a value indicating whether validity checks are performed each time an item is added to the diagram. (Inherited from Diagram.)
VisioNodeStyle | Gets the theme-level style for Visio nodes. (Inherited from Diagram.)

Public Methods

Name | Description
AlignPointToGrid | Returns a point of the alignment grid nearest to the one passed as an argument. (Inherited from Diagram.)
ArrangeLinkLabels | Rearranges link labels whose AutoArrange property is enabled. (Inherited from Diagram.)
ChangeUnit | Sets new MeasureUnit value and scales the coordinates of diagram items so that their absolute size remains unchanged. (Inherited from Diagram.)
ClearAll | Removes all items from the diagram. (Inherited from Diagram.)
CopySelection | Creates a copy of the currently selected objects and groups. (Inherited from Diagram.)
CreateImage | Overloaded. Creates a bitmap containing an image of the diagram. (Inherited from Diagram.)
CreateMeasureGraphics | Creates an IGraphics object that can be used to obtain various string size measurements. (Inherited from Diagram.)
CreateThemeFromDefaults | Creates a Theme object representing the default properties of the diagram. (Inherited from Diagram.)
Draw | Renders the diagram on the specified IGraphics object. (Inherited from Diagram.)
DrawAlignmentGuides | Draws the current alignment guides. (Inherited from Diagram.)
DrawInteraction | Draws the items that the user is currently modifying. (Inherited from Diagram.)
DrawLayer | Renders all diagram items to the specified graphics. (Inherited from Diagram.)
DrawStyledText | Draws a formatted text string, the same way text is drawn in shape nodes whose EnableStyledText property is set to true. This method lets you display styled text in custom-drawn nodes or links. (Inherited from Diagram.)
ExecuteCommand | Executes the specified command on this diagram. (Inherited from Diagram.)
FindGroup | Finds the group that has the specified tag value. (Inherited from Diagram.)
FindLink | Finds the link that has the specified tag value. (Inherited from Diagram.)
FindLinkById | Finds the link that has the specified id value. (Inherited from Diagram.)
FindNode | Finds the node that has the specified tag value. (Inherited from Diagram.)
FindNodeById | Finds the node that has the specified id value. (Inherited from Diagram.)
GetContentBounds | Returns the smallest rectangle that bounds all diagram objects. (Inherited from Diagram.)
GetItemAt | Finds and returns the top-most diagram item that lies at the specified location. (Inherited from Diagram.)
GetLinkAt | Overloaded. Finds and returns the link that lies at the specified location. (Inherited from Diagram.)
GetLinksAt | Returns the links that contain the specified point. (Inherited from Diagram.)
GetNearestNode | Returns the node nearest to the specified point. (Inherited from Diagram.)
GetNodeAt | Overloaded. Gets the node that lies at the specified location. (Inherited from Diagram.)
GetNodesAt | Returns the nodes that contain the specified point. (Inherited from Diagram.)
HandleKeyDown | Propagates keyboard input to interested manipulators and components. (Inherited from Diagram.)
HandleKeyPress | Propagates keyboard input to interested manipulators. (Inherited from Diagram.)
HandleKeyUp | Propagates keyboard input to interested components. (Inherited from Diagram.)
HandleMouseMove | Propagates mouse input to interested manipulators. (Inherited from Diagram.)
HitTestComponents | Tests whether the specified point is within a component of a diagram item and returns this component. (Inherited from Diagram.)
HitTestManipulators | Tests whether the specified point is within the manipulator of a diagram object and triggers the manipulator. (Inherited from Diagram.)
Invalidate | Overloaded. Invalidates the diagram or a region of the diagram, causing it to be repainted. (Inherited from Diagram.)
InvalidateZOrder | Forces a new sort of the Z order list before next redraw. (Inherited from Diagram.)
IsItemInteractive | Checks if the specified item can be modified interactively. (Inherited from Diagram.)
IsItemLocked | Checks if the specified item is locked. (Inherited from Diagram.)
IsItemVisible | Checks if the specified item is currently visible. (Inherited from Diagram.)
LoadFromFile | Loads the contents of an existing diagram file into the control. (Inherited from Diagram.)
LoadFromStream | Loads a diagram from the specified stream. (Inherited from Diagram.)
LoadFromString | Decodes diagram contents from a string that was created with SaveToString. (Inherited from Diagram.)
LoadFromXml | Overloaded. Loads the contents of an XML diagram document into the control. (Inherited from Diagram.)
MeasureString | Overloaded. Measures a text taking into consideration the current affine transform of the diagram. (Inherited from Diagram.)
Navigate | Selects the nearest item in the specified direction. (Inherited from Diagram.)
NewInstance | Custom Diagram classes must override this method to return an instance of their type. (Inherited from Diagram.)
PasteSelection | Adds the specified items and groups to the specified diagram document. (Inherited from Diagram.)
PixelToUnit | Converts the specified point from client to document coordinates ignoring the current scale transformation. (Inherited from Diagram.)
RaiseCellTextEdited | Raises the CellTextEdited event . (Inherited from Diagram.)
RaiseCellTextEditing | Raises the CellTextEditing event to validate entering in-place editing mode. (Inherited from Diagram.)
RaiseClicked | Overloaded. Raises the Clicked event of the diagram or one of the *Clicked events related to diagram items. (Inherited from Diagram.)
RaiseCreated | Raises the appropriate *Created event according to the type of the specified item. (Inherited from Diagram.)
RaiseDeleting | Raises the appropriate *Deleting event according to the type of the specified item. (Inherited from Diagram.)
RaiseDoubleClicked | Overloaded. Raises the DoubleClicked event of the diagram or one of the *DoubleClicked events related to diagram items. (Inherited from Diagram.)
RaiseLinkTextEdited | Raises the LinkTextEdited event. (Inherited from Diagram.)
RaiseLinkTextEditing | Raises the LinkTextEditing event to validate entering in-place editing mode. (Inherited from Diagram.)
RaiseMouseHover | Raises the appropriate Pointed event. (Inherited from Diagram.)
RaiseNodeTextEdited | Raises the NodeTextEdited event. (Inherited from Diagram.)
RaiseNodeTextEditing | Raises the NodeTextEditing event to validate entering in-place editing mode. (Inherited from Diagram.)
RaisePasted | Raises the appropriate Pasted event. (Inherited from Diagram.)
RaiseSelecting | Raises the appropriate Selecting event. (Inherited from Diagram.)
RaiseTreeItemTextEditing | Raises the TreeItemTextEditing event to validate entering inplace edit mode. (Inherited from Diagram.)
RaiseViewRemoved | Raises the ViewRemoved event. (Inherited from Diagram.)
RegisterClass | Registers a diagram item or lane header class for serialization support. (Inherited from Diagram.)
RegisterDefaultStyle | Registers a default style for the objects of the specified type. (Inherited from Diagram.)
RegisterItemClass | Registers a diagram item class for serialization support. (Inherited from Diagram.)
ResetAlignmentGuides | For internal use. (Inherited from Diagram.)
ResizeToFitItem | Resizes the document extents so that the specified item is contained within. (Inherited from Diagram.)
ResizeToFitItems | Overloaded. Resizes the document scrollable area so it fits all diagram items. (Inherited from Diagram.)
RouteAllLinks | Routes all links in the diagram in a way they do not cross nodes. (Inherited from Diagram.)
SaveToFile | Overloaded. Saves the binary contents of the diagram to a disk file. (Inherited from Diagram.)
SaveToStream | Overloaded. Saves the binary contents of the diagram to a .NET stream. (Inherited from Diagram.)
SaveToString | Overloaded. Encodes the diagram contents into an ASCII string. (Inherited from Diagram.)
SaveToXml | Overloaded. Saves the diagram to an XML document. (Inherited from Diagram.)
SetShadowOffset | Sets the default offset at which items shadows are drawn. (Inherited from Diagram.)
TrackMouseHover | Specifies whether the diagram view should track mouse hover events. (Inherited from DiagramBase.)
UnitToPixel | Converts the specified point from document to client coordinates ignoring the current scale transformation. (Inherited from Diagram.)
UpdateMeasureTextScale | Gets or sets the scale to use when measuring texts. This should be effectively set to the value of DiagramView.Zoom / 100. (Inherited from Diagram.)
UpdateRuntimeIndices | For internal use. (Inherited from Diagram.)
UpdateZOrder | Immediately sorts the Z-order list if Z-order has been invalidated. Otherwise it will be sorted next time the diagram draws its contents. (Inherited from Diagram.)

Protected Methods

Name | Description
AddItem | Invoked by the AddItemCmd and RemoveItemCmd classes to effectively add the specified item to the diagram. (Inherited from Diagram.)
CreateAddItemCmd | Creates an AddItemCmd instance that implements undo/redo of adding an item to the diagram. (Inherited from Diagram.)
CreateItem | Creates an instance of the specified class. (Inherited from Diagram.)
CreateModifyItemCmd | Creates a ModifyItemCmd instance that implements undo/redo of item move and resize operations. (Inherited from Diagram.)
CreateRemoveItemCmd | Creates a RemoveItemCmd instance that implements undo/redo of removing an item from the diagram. (Inherited from Diagram.)
DeleteGroup | Removes the specified group from the group collection. (Inherited from Diagram.)
Dispose | Clean up any resources being used. (Inherited from Diagram.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from Diagram.)
OnActionRecorded | Raises the ActionRecorded event. (Inherited from DiagramBase.)
OnActionRecording | Raises the ActionRecording event. (Inherited from DiagramBase.)
OnActionRedone | Raises the ActionRedone event. (Inherited from DiagramBase.)
OnActionUndone | Raises the ActionUndone event. (Inherited from DiagramBase.)
OnBeginLoad | Raises the BeginLoad event. (Inherited from DiagramBase.)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramBase.)
OnCellClicked | Raises the CellClicked event. (Inherited from DiagramBase.)
OnCellDoubleClicked | Raises the CellDoubleClicked event. (Inherited from DiagramBase.)
OnCellTextEdited | Raises the CellTextEdited event. (Inherited from DiagramBase.)
OnCellTextEditing | Raises the CellTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnClicked | Raises the Clicked event. (Inherited from DiagramBase.)
OnContainerChildAdded | Raises the ContainerChildAdded event. (Inherited from DiagramBase.)
OnContainerChildRemoved | Raises the ContainerChildRemoved event. (Inherited from DiagramBase.)
OnContainerFolded | Raises the ContainerFolded event. (Inherited from DiagramBase.)
OnContainerUnfolded | Raises the ContainerUnfolded event. (Inherited from DiagramBase.)
OnContentVisibilityChanged | Raises the ContentVisibilityChanged event. (Inherited from DiagramBase.)
OnDefaultShapeChanged | Raises the DefaultShapeChanged event. (Inherited from DiagramBase.)
OnDeserializeTag | Raises the DeserializeTag event. (Inherited from DiagramBase.)
OnDestinationAnchorChanged | Raises the DestinationAnchorChanged event. (Inherited from DiagramBase.)
OnDirtyChanged | Raises the DirtyChanged event. (Inherited from DiagramBase.)
OnDoubleClicked | Raises the DoubleClicked event. (Inherited from DiagramBase.)
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event. (Inherited from DiagramBase.)
OnDrawAnchorPoint | Raises the DrawAnchorPoint event. (Inherited from DiagramBase.)
OnDrawBackground | Raises the DrawBackground event. (Inherited from DiagramBase.)
OnDrawCell | Raises the DrawCell event. (Inherited from DiagramBase.)
OnDrawForeground | Raises the DrawForeground event. (Inherited from DiagramBase.)
OnDrawLink | Raises the DrawLink event. (Inherited from DiagramBase.)
OnDrawNode | Raises the DrawNode event. (Inherited from DiagramBase.)
OnEndLoad | Raises the EndLoad event. (Inherited from DiagramBase.)
OnExpandButtonClicked | Raises the ExpandButtonClicked event. (Inherited from DiagramBase.)
OnGroupDestroyed | Raises the GroupDestroyed event. (Inherited from DiagramBase.)
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event. (Inherited from DiagramBase.)
OnInitializeLink | Raises the InitializeLink event. (Inherited from DiagramBase.)
OnInitializeNode | Raises the InitializeNode event. (Inherited from DiagramBase.)
OnItemAdded | Raises the ItemAdded event. (Inherited from DiagramBase.)
OnItemRemoved | Raises the ItemRemoved event. (Inherited from DiagramBase.)
OnLayerVisibilityChanged | Raises the LayerVisibilityChanged event. (Inherited from DiagramBase.)
OnLinkActivated | Raises the LinkActivated event. (Inherited from DiagramBase.)
OnLinkClicked | Raises the LinkClicked event. (Inherited from DiagramBase.)
OnLinkCreateCancelled | Raises the LinkCreateCancelled event. (Inherited from DiagramBase.)
OnLinkCreated | Raises the LinkCreated event. (Inherited from DiagramBase.)
OnLinkCreating | Raises the LinkCreating event. (Inherited from DiagramBase.)
OnLinkDeactivated | Raises the LinkDeactivated event. (Inherited from DiagramBase.)
OnLinkDeleted | Raises the LinkDeleted event. (Inherited from DiagramBase.)
OnLinkDeleting | Raises the LinkDeleting event. (Inherited from DiagramBase.)
OnLinkDeselected | Raises the LinkDeselected event. (Inherited from DiagramBase.)
OnLinkDoubleClicked | Raises the LinkDoubleClicked event. (Inherited from DiagramBase.)
OnLinkModified | Raises the LinkModified event. (Inherited from DiagramBase.)
OnLinkModifyCancelled | Raises the LinkModifyCancelled event. (Inherited from DiagramBase.)
OnLinkModifying | Raises the LinkModifying event. (Inherited from DiagramBase.)
OnLinkPasted | Raises the LinkPasted event. (Inherited from DiagramBase.)
OnLinkPointed | Raises the LinkPointed event. (Inherited from DiagramBase.)
OnLinkRouted | Raises the LinkRouted event. (Inherited from DiagramBase.)
OnLinkSelected | Raises the LinkSelected event. (Inherited from DiagramBase.)
OnLinkSelecting | Raises the LinkSelecting event. (Inherited from DiagramBase.)
OnLinkSplit | Raises the LinkSplit event. (Inherited from DiagramBase.)
OnLinkStartModifying | Raises the LinkStartModifying event. (Inherited from DiagramBase.)
OnLinkTextEdited | Raises the LinkTextEdited event. (Inherited from DiagramBase.)
OnLinkTextEditing | Raises the LinkTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnMeasureUnitChanged | Raises the MeasureUnitChanged event. (Inherited from DiagramBase.)
OnNodeActivated | Raises the NodeActivated event. (Inherited from DiagramBase.)
OnNodeClicked | Raises the NodeClicked event. (Inherited from DiagramBase.)
OnNodeCreateCancelled | Raises the NodeCreateCancelled event. (Inherited from DiagramBase.)
OnNodeCreated | Raises the NodeCreated event. (Inherited from DiagramBase.)
OnNodeCreating | Raises the NodeCreating event. (Inherited from DiagramBase.)
OnNodeDeactivated | Raises the NodeDeactivated event. (Inherited from DiagramBase.)
OnNodeDeleted | Raises the NodeDeleted event. (Inherited from DiagramBase.)
OnNodeDeleting | Raises the NodeDeleting event. (Inherited from DiagramBase.)
OnNodeDeselected | Raises the NodeDeselected event. (Inherited from DiagramBase.)
OnNodeDoubleClicked | Raises the NodeDoubleClicked event. (Inherited from DiagramBase.)
OnNodeModified | Raises the NodeModified event. (Inherited from DiagramBase.)
OnNodeModifyCancelled | Raises the NodeModifyCancelled event. (Inherited from DiagramBase.)
OnNodeModifying | Raises the NodeModifying event. (Inherited from DiagramBase.)
OnNodePasted | Raises the NodePasted event. (Inherited from DiagramBase.)
OnNodePointed | Raises the NodePointed event. (Inherited from DiagramBase.)
OnNodeSelected | Raises the NodeSelected event. (Inherited from DiagramBase.)
OnNodeSelecting | Raises the NodeSelecting event. (Inherited from DiagramBase.)
OnNodeStartModifying | Raises the NodeStartModifying event. (Inherited from DiagramBase.)
OnNodeTextEdited | Raises the NodeTextEdited event. (Inherited from DiagramBase.)
OnNodeTextEditing | Raises the NodeTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnOriginAnchorChanged | Raises the OriginAnchorChanged event. (Inherited from DiagramBase.)
OnPropertyChanged | Raises the PropertyChanged event.
OnQueryAlignTarget | Raises the QueryAlignTarget event. (Inherited from DiagramBase.)
OnRepaint | Raises the Repaint event. (Inherited from DiagramBase.)
OnRequestClipboard | Raises the RequestClipboard event. (Inherited from DiagramBase.)
OnRequestTimer | Raises the RequestTimer event. (Inherited from DiagramBase.)
OnSelectionChanged | Raises the SelectionChanged event. (Inherited from DiagramBase.)
OnSelectionModified | Raises the SelectionModified event. (Inherited from DiagramBase.)
OnSelectionModifying | Raises the SelectionModifying event. (Inherited from DiagramBase.)
OnSerializeTag | Raises the SerializeTag event. (Inherited from DiagramBase.)
OnSetSelfLoopShape | Raises the SetSelfLoopShape event. (Inherited from DiagramBase.)
OnShapeModified | Raises the ShapeModified event. (Inherited from DiagramBase.)
OnTableColumnResized | Raises the TableColumnResized event. (Inherited from DiagramBase.)
OnTableColumnResizing | Raises the TableColumnResizing event. (Inherited from DiagramBase.)
OnTableRowResized | Raises the TableRowResized event. (Inherited from DiagramBase.)
OnTableRowResizing | Raises the TableRowResizing event. (Inherited from DiagramBase.)
OnTableSectionCollapsed | Raises the TableSectionCollapsed event. (Inherited from DiagramBase.)
OnTableSectionExpanded | Raises the TableSectionExpanded event. (Inherited from DiagramBase.)
OnTreeCollapsed | Raises the TreeCollapsed event. (Inherited from DiagramBase.)
OnTreeExpanded | Raises the TreeExpanded event. (Inherited from DiagramBase.)
OnTreeItemTextEditing | Raises the TreeItemTextEditing event. (Inherited from DiagramBase.)
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event. (Inherited from DiagramBase.)
OnViewRemoved | Raises the ViewRemoved event. (Inherited from DiagramBase.)
RemoveItem | Invoked by the AddItemCmd and RemoveItemCmd classes to effectively remove the specified item from the diagram. (Inherited from Diagram.)

Public Events

Name | Description
ActionRecorded | Raised when an action is recorded in the undo buffer. (Inherited from DiagramBase.)
ActionRecording | A validation event raised before an action is recorded in the undo buffer. (Inherited from DiagramBase.)
ActionRedone | Raised when an action is redone. (Inherited from DiagramBase.)
ActionUndone | Raised when an action is undone. (Inherited from DiagramBase.)
ActiveLayerChanged | Raised when the diagram's active layer has changed. (Inherited from DiagramBase.)
BeginLoad | Raised when the component starts loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
BoundsChanged | Raised when the Bounds property value has changed. (Inherited from DiagramBase.)
CellClicked | Raised when the user clicks a table’s cell. (Inherited from DiagramBase.)
CellDoubleClicked | Raised when the user double-clicks a table’s cell. (Inherited from DiagramBase.)
CellTextEdited | Raised when the user edits the text of a table’s cell. (Inherited from DiagramBase.)
CellTextEditing | A validation event that lets you approve or reject changes made to the text of a table’s cell. (Inherited from DiagramBase.)
Clicked | Raised when the user clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area. (Inherited from DiagramBase.)
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area. (Inherited from DiagramBase.)
ContentVisibilityChanged | Raised when the visibility of container's content changes. (Inherited from DiagramBase.)
DefaultShapeChanged | Raised when the DefaultShape property value has changed. (Inherited from DiagramBase.)
DeserializeTag | Raised when the Tag of a diagram item must be deserialized from XML format. (Inherited from DiagramBase.)
DestinationAnchorChanged | Raised when the DestinationAnchor property value of a link has changed. (Inherited from DiagramBase.)
DirtyChanged | Raised when the Dirty property value has changed. (Inherited from DiagramBase.)
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
DrawAdjustmentHandles | Raised when item’s adjustment handles must be custom drawn. (Inherited from DiagramBase.)
DrawAnchorPoint | Raised when an anchor point must be custom drawn. (Inherited from DiagramBase.)
DrawBackground | Raised to let you custom draw the diagram background. (Inherited from DiagramBase.)
DrawCell | Raised when a table’s cell must be custom drawn. (Inherited from DiagramBase.)
DrawForeground | Raised to let you custom draw the diagram foreground. (Inherited from DiagramBase.)
DrawLink | Raised when a diagram link must be custom drawn. (Inherited from DiagramBase.)
DrawNode | Raised when a diagram node must be custom drawn. (Inherited from DiagramBase.)
EndLoad | Raised when the component ends loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
ExpandButtonClicked | Raised when the user clicks the [±] button of an Expandable node. (Inherited from DiagramBase.)
GroupDestroyed | Raised when a Group object is destroyed. (Inherited from DiagramBase.)
HitTestAdjustmentHandles | Raised when custom hit testing of item’s adjustment handles must be performed. (Inherited from DiagramBase.)
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created. (Inherited from DiagramBase.)
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created. (Inherited from DiagramBase.)
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
LayerVisibilityChanged | Raised when the visibility of a Layer changes. (Inherited from DiagramBase.)
LinkActivated | Raised when a link becomes the ActiveItem. (Inherited from DiagramBase.)
LinkClicked | Raised when the user clicks a link. (Inherited from DiagramBase.)
LinkCreateCancelled | Raised when the user cancels link creation. (Inherited from DiagramBase.)
LinkCreated | Raised when the user draws a new link. (Inherited from DiagramBase.)
LinkCreating | A validation event raised while the user is drawing a new link. (Inherited from DiagramBase.)
LinkDeactivated | Raised when a link is no longer the ActiveItem. (Inherited from DiagramBase.)
LinkDeleted | Raised when a link is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkDeselected | Raised when a link is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDoubleClicked | Raised when the user double-clicks a link. (Inherited from DiagramBase.)
LinkModified | Raised when the user moves any control point of a link. (Inherited from DiagramBase.)
LinkModifyCancelled | Raised when the user cancels move or resize operation being done on a link. (Inherited from DiagramBase.)
LinkModifying | A validation event raised while the user is modifying a link. (Inherited from DiagramBase.)
LinkPasted | Raised when a link has been pasted from the clipboard. (Inherited from DiagramBase.)
LinkPointed | Raised when the mouse pointer hovers over a link. (Inherited from DiagramBase.)
LinkRouted | Raised when a link is routed by the auto-routing algorithm. (Inherited from DiagramBase.)
LinkSelected | Raised when a link is selected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkSelecting | Raised when the user tries to select a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkSplit | Raised when the user splits a link interactively. (Inherited from DiagramBase.)
LinkStartModifying | A validation event raised when the user starts modifying a link. (Inherited from DiagramBase.)
LinkTextEdited | Raised when the user edits the text of a link. (Inherited from DiagramBase.)
LinkTextEditing | A validation event that lets you approve or reject changes made to the text of a link. (Inherited from DiagramBase.)
MeasureUnitChanged | Raised when the MeasureUnit property value has changed. (Inherited from DiagramBase.)
NodeActivated | Raised when a node becomes the ActiveItem. (Inherited from DiagramBase.)
NodeClicked | Raised when the user clicks a node. (Inherited from DiagramBase.)
NodeCreateCancelled | Raised when the user cancels node creation. (Inherited from DiagramBase.)
NodeCreated | Raised when the user draws a new node. (Inherited from DiagramBase.)
NodeCreating | A validation event raised while the user is drawing a new node. (Inherited from DiagramBase.)
NodeDeactivated | Raised when a node is no longer the ActiveItem. (Inherited from DiagramBase.)
NodeDeleted | Raised when a node is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeDeselected | Raised when a node is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDoubleClicked | Raised when the user double-clicks a node. (Inherited from DiagramBase.)
NodeModified | Raised when the user moves or resizes a node. (Inherited from DiagramBase.)
NodeModifyCancelled | Raised when the user cancels move or resize operation being done on a node. (Inherited from DiagramBase.)
NodeModifying | A validation event raised while the user is moving or resizing a node. (Inherited from DiagramBase.)
NodePasted | Raised when a node has been pasted from the clipboard. (Inherited from DiagramBase.)
NodePointed | Raised when the mouse pointer hovers over a node. (Inherited from DiagramBase.)
NodeSelected | Raised when a node is selected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeSelecting | Raised when the user tries to select a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeStartModifying | A validation event raised when the user starts modifying a node. (Inherited from DiagramBase.)
NodeTextEdited | Raised when the user edits the text of a node. (Inherited from DiagramBase.)
NodeTextEditing | A validation event that lets you approve or reject changes made to the text of a node. (Inherited from DiagramBase.)
OriginAnchorChanged | Raised when the OriginAnchor property value of a link has changed. (Inherited from DiagramBase.)
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.
QueryAlignTarget | Raised to validate a node as target for alignment guides when AutoAlignNodes is enabled. (Inherited from DiagramBase.)
Repaint | Raised when the diagram views should be repainted. (Inherited from DiagramBase.)
RequestCacheReset | Raised when an object within the diagram requests a reset of the cached bitmap. (Inherited from DiagramBase.)
RequestClipboard | Raised when an object within the diagram requests an operation with the clipboard. (Inherited from DiagramBase.)
RequestTimer | Raised when an object within the diagram needs to start or stop a timer. (Inherited from DiagramBase.)
SelectionChanged | Raised when an item is added to or removed from the selection (Inherited from DiagramBase.)
SelectionModified | Raised when the user moves multiple selected items. (Inherited from DiagramBase.)
SelectionModifying | Raised while the user is moving multiple selected items, this event lets you cancel the modification. (Inherited from DiagramBase.)
SerializeTag | Raised when the Tag of a diagram item must be serialized into an XML document. (Inherited from DiagramBase.)
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape. (Inherited from DiagramBase.)
ShapeModified | Raised when the user modifies the shape of a ShapeNode by moving one of the control points corresponding to shape formula parameters. (Inherited from DiagramBase.)
TableColumnResized | Raised when the user finishes resizing a column in a table. (Inherited from DiagramBase.)
TableColumnResizing | Raised when the user resizes a column in a table interactively. (Inherited from DiagramBase.)
TableRowResized | Raised when the user finishes resizing a row in a table. (Inherited from DiagramBase.)
TableRowResizing | Raised when the user resizes a row in a table interactively. (Inherited from DiagramBase.)
TableSectionCollapsed | Raised when the user collapses the rows of a table’s section by clicking the [-] button in the section's header row. (Inherited from DiagramBase.)
TableSectionExpanded | Raised when the user expands the rows of a table's section by clicking the [+] button in the section’s header row. (Inherited from DiagramBase.)
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node. (Inherited from DiagramBase.)
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node. (Inherited from DiagramBase.)
TreeItemTextEditing | A validation event that lets you approve or reject changes made to the text of a TreeViewNode's item. (Inherited from DiagramBase.)
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point. (Inherited from DiagramBase.)
ViewRemoved | Raised when a DiagramView is detached from this diagram. (Inherited from DiagramBase.)

See Also

DiagramPage Class


MindFusion.Diagramming.DiagramPage Constructor

DiagramPage Constructor
[image]

Initializes a new instance of the DiagramPage class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramPage ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramPage Class


MindFusion.Diagramming.DiagramPage Methods

DiagramPage Methods
[image]

Public Methods

Name | Description
AlignPointToGrid | Returns a point of the alignment grid nearest to the one passed as an argument. (Inherited from Diagram.)
ArrangeLinkLabels | Rearranges link labels whose AutoArrange property is enabled. (Inherited from Diagram.)
ChangeUnit | Sets new MeasureUnit value and scales the coordinates of diagram items so that their absolute size remains unchanged. (Inherited from Diagram.)
ClearAll | Removes all items from the diagram. (Inherited from Diagram.)
CopySelection | Creates a copy of the currently selected objects and groups. (Inherited from Diagram.)
CreateImage | Overloaded. Creates a bitmap containing an image of the diagram. (Inherited from Diagram.)
CreateMeasureGraphics | Creates an IGraphics object that can be used to obtain various string size measurements. (Inherited from Diagram.)
CreateThemeFromDefaults | Creates a Theme object representing the default properties of the diagram. (Inherited from Diagram.)
Draw | Renders the diagram on the specified IGraphics object. (Inherited from Diagram.)
DrawAlignmentGuides | Draws the current alignment guides. (Inherited from Diagram.)
DrawInteraction | Draws the items that the user is currently modifying. (Inherited from Diagram.)
DrawLayer | Renders all diagram items to the specified graphics. (Inherited from Diagram.)
DrawStyledText | Draws a formatted text string, the same way text is drawn in shape nodes whose EnableStyledText property is set to true. This method lets you display styled text in custom-drawn nodes or links. (Inherited from Diagram.)
ExecuteCommand | Executes the specified command on this diagram. (Inherited from Diagram.)
FindGroup | Finds the group that has the specified tag value. (Inherited from Diagram.)
FindLink | Finds the link that has the specified tag value. (Inherited from Diagram.)
FindLinkById | Finds the link that has the specified id value. (Inherited from Diagram.)
FindNode | Finds the node that has the specified tag value. (Inherited from Diagram.)
FindNodeById | Finds the node that has the specified id value. (Inherited from Diagram.)
GetContentBounds | Returns the smallest rectangle that bounds all diagram objects. (Inherited from Diagram.)
GetItemAt | Finds and returns the top-most diagram item that lies at the specified location. (Inherited from Diagram.)
GetLinkAt | Overloaded. Finds and returns the link that lies at the specified location. (Inherited from Diagram.)
GetLinksAt | Returns the links that contain the specified point. (Inherited from Diagram.)
GetNearestNode | Returns the node nearest to the specified point. (Inherited from Diagram.)
GetNodeAt | Overloaded. Gets the node that lies at the specified location. (Inherited from Diagram.)
GetNodesAt | Returns the nodes that contain the specified point. (Inherited from Diagram.)
HandleKeyDown | Propagates keyboard input to interested manipulators and components. (Inherited from Diagram.)
HandleKeyPress | Propagates keyboard input to interested manipulators. (Inherited from Diagram.)
HandleKeyUp | Propagates keyboard input to interested components. (Inherited from Diagram.)
HandleMouseMove | Propagates mouse input to interested manipulators. (Inherited from Diagram.)
HitTestComponents | Tests whether the specified point is within a component of a diagram item and returns this component. (Inherited from Diagram.)
HitTestManipulators | Tests whether the specified point is within the manipulator of a diagram object and triggers the manipulator. (Inherited from Diagram.)
Invalidate | Overloaded. Invalidates the diagram or a region of the diagram, causing it to be repainted. (Inherited from Diagram.)
InvalidateZOrder | Forces a new sort of the Z order list before next redraw. (Inherited from Diagram.)
IsItemInteractive | Checks if the specified item can be modified interactively. (Inherited from Diagram.)
IsItemLocked | Checks if the specified item is locked. (Inherited from Diagram.)
IsItemVisible | Checks if the specified item is currently visible. (Inherited from Diagram.)
LoadFromFile | Loads the contents of an existing diagram file into the control. (Inherited from Diagram.)
LoadFromStream | Loads a diagram from the specified stream. (Inherited from Diagram.)
LoadFromString | Decodes diagram contents from a string that was created with SaveToString. (Inherited from Diagram.)
LoadFromXml | Overloaded. Loads the contents of an XML diagram document into the control. (Inherited from Diagram.)
MeasureString | Overloaded. Measures a text taking into consideration the current affine transform of the diagram. (Inherited from Diagram.)
Navigate | Selects the nearest item in the specified direction. (Inherited from Diagram.)
NewInstance | Custom Diagram classes must override this method to return an instance of their type. (Inherited from Diagram.)
PasteSelection | Adds the specified items and groups to the specified diagram document. (Inherited from Diagram.)
PixelToUnit | Converts the specified point from client to document coordinates ignoring the current scale transformation. (Inherited from Diagram.)
RaiseCellTextEdited | Raises the CellTextEdited event . (Inherited from Diagram.)
RaiseCellTextEditing | Raises the CellTextEditing event to validate entering in-place editing mode. (Inherited from Diagram.)
RaiseClicked | Overloaded. Raises the Clicked event of the diagram or one of the *Clicked events related to diagram items. (Inherited from Diagram.)
RaiseCreated | Raises the appropriate *Created event according to the type of the specified item. (Inherited from Diagram.)
RaiseDeleting | Raises the appropriate *Deleting event according to the type of the specified item. (Inherited from Diagram.)
RaiseDoubleClicked | Overloaded. Raises the DoubleClicked event of the diagram or one of the *DoubleClicked events related to diagram items. (Inherited from Diagram.)
RaiseLinkTextEdited | Raises the LinkTextEdited event. (Inherited from Diagram.)
RaiseLinkTextEditing | Raises the LinkTextEditing event to validate entering in-place editing mode. (Inherited from Diagram.)
RaiseMouseHover | Raises the appropriate Pointed event. (Inherited from Diagram.)
RaiseNodeTextEdited | Raises the NodeTextEdited event. (Inherited from Diagram.)
RaiseNodeTextEditing | Raises the NodeTextEditing event to validate entering in-place editing mode. (Inherited from Diagram.)
RaisePasted | Raises the appropriate Pasted event. (Inherited from Diagram.)
RaiseSelecting | Raises the appropriate Selecting event. (Inherited from Diagram.)
RaiseTreeItemTextEditing | Raises the TreeItemTextEditing event to validate entering inplace edit mode. (Inherited from Diagram.)
RaiseViewRemoved | Raises the ViewRemoved event. (Inherited from Diagram.)
RegisterClass | Registers a diagram item or lane header class for serialization support. (Inherited from Diagram.)
RegisterDefaultStyle | Registers a default style for the objects of the specified type. (Inherited from Diagram.)
RegisterItemClass | Registers a diagram item class for serialization support. (Inherited from Diagram.)
ResetAlignmentGuides | For internal use. (Inherited from Diagram.)
ResizeToFitItem | Resizes the document extents so that the specified item is contained within. (Inherited from Diagram.)
ResizeToFitItems | Overloaded. Resizes the document scrollable area so it fits all diagram items. (Inherited from Diagram.)
RouteAllLinks | Routes all links in the diagram in a way they do not cross nodes. (Inherited from Diagram.)
SaveToFile | Overloaded. Saves the binary contents of the diagram to a disk file. (Inherited from Diagram.)
SaveToStream | Overloaded. Saves the binary contents of the diagram to a .NET stream. (Inherited from Diagram.)
SaveToString | Overloaded. Encodes the diagram contents into an ASCII string. (Inherited from Diagram.)
SaveToXml | Overloaded. Saves the diagram to an XML document. (Inherited from Diagram.)
SetShadowOffset | Sets the default offset at which items shadows are drawn. (Inherited from Diagram.)
TrackMouseHover | Specifies whether the diagram view should track mouse hover events. (Inherited from DiagramBase.)
UnitToPixel | Converts the specified point from document to client coordinates ignoring the current scale transformation. (Inherited from Diagram.)
UpdateMeasureTextScale | Gets or sets the scale to use when measuring texts. This should be effectively set to the value of DiagramView.Zoom / 100. (Inherited from Diagram.)
UpdateRuntimeIndices | For internal use. (Inherited from Diagram.)
UpdateZOrder | Immediately sorts the Z-order list if Z-order has been invalidated. Otherwise it will be sorted next time the diagram draws its contents. (Inherited from Diagram.)

Protected Methods

Name | Description
AddItem | Invoked by the AddItemCmd and RemoveItemCmd classes to effectively add the specified item to the diagram. (Inherited from Diagram.)
CreateAddItemCmd | Creates an AddItemCmd instance that implements undo/redo of adding an item to the diagram. (Inherited from Diagram.)
CreateItem | Creates an instance of the specified class. (Inherited from Diagram.)
CreateModifyItemCmd | Creates a ModifyItemCmd instance that implements undo/redo of item move and resize operations. (Inherited from Diagram.)
CreateRemoveItemCmd | Creates a RemoveItemCmd instance that implements undo/redo of removing an item from the diagram. (Inherited from Diagram.)
DeleteGroup | Removes the specified group from the group collection. (Inherited from Diagram.)
Dispose | Clean up any resources being used. (Inherited from Diagram.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from Diagram.)
OnActionRecorded | Raises the ActionRecorded event. (Inherited from DiagramBase.)
OnActionRecording | Raises the ActionRecording event. (Inherited from DiagramBase.)
OnActionRedone | Raises the ActionRedone event. (Inherited from DiagramBase.)
OnActionUndone | Raises the ActionUndone event. (Inherited from DiagramBase.)
OnBeginLoad | Raises the BeginLoad event. (Inherited from DiagramBase.)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramBase.)
OnCellClicked | Raises the CellClicked event. (Inherited from DiagramBase.)
OnCellDoubleClicked | Raises the CellDoubleClicked event. (Inherited from DiagramBase.)
OnCellTextEdited | Raises the CellTextEdited event. (Inherited from DiagramBase.)
OnCellTextEditing | Raises the CellTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnClicked | Raises the Clicked event. (Inherited from DiagramBase.)
OnContainerChildAdded | Raises the ContainerChildAdded event. (Inherited from DiagramBase.)
OnContainerChildRemoved | Raises the ContainerChildRemoved event. (Inherited from DiagramBase.)
OnContainerFolded | Raises the ContainerFolded event. (Inherited from DiagramBase.)
OnContainerUnfolded | Raises the ContainerUnfolded event. (Inherited from DiagramBase.)
OnContentVisibilityChanged | Raises the ContentVisibilityChanged event. (Inherited from DiagramBase.)
OnDefaultShapeChanged | Raises the DefaultShapeChanged event. (Inherited from DiagramBase.)
OnDeserializeTag | Raises the DeserializeTag event. (Inherited from DiagramBase.)
OnDestinationAnchorChanged | Raises the DestinationAnchorChanged event. (Inherited from DiagramBase.)
OnDirtyChanged | Raises the DirtyChanged event. (Inherited from DiagramBase.)
OnDoubleClicked | Raises the DoubleClicked event. (Inherited from DiagramBase.)
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event. (Inherited from DiagramBase.)
OnDrawAnchorPoint | Raises the DrawAnchorPoint event. (Inherited from DiagramBase.)
OnDrawBackground | Raises the DrawBackground event. (Inherited from DiagramBase.)
OnDrawCell | Raises the DrawCell event. (Inherited from DiagramBase.)
OnDrawForeground | Raises the DrawForeground event. (Inherited from DiagramBase.)
OnDrawLink | Raises the DrawLink event. (Inherited from DiagramBase.)
OnDrawNode | Raises the DrawNode event. (Inherited from DiagramBase.)
OnEndLoad | Raises the EndLoad event. (Inherited from DiagramBase.)
OnExpandButtonClicked | Raises the ExpandButtonClicked event. (Inherited from DiagramBase.)
OnGroupDestroyed | Raises the GroupDestroyed event. (Inherited from DiagramBase.)
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event. (Inherited from DiagramBase.)
OnInitializeLink | Raises the InitializeLink event. (Inherited from DiagramBase.)
OnInitializeNode | Raises the InitializeNode event. (Inherited from DiagramBase.)
OnItemAdded | Raises the ItemAdded event. (Inherited from DiagramBase.)
OnItemRemoved | Raises the ItemRemoved event. (Inherited from DiagramBase.)
OnLayerVisibilityChanged | Raises the LayerVisibilityChanged event. (Inherited from DiagramBase.)
OnLinkActivated | Raises the LinkActivated event. (Inherited from DiagramBase.)
OnLinkClicked | Raises the LinkClicked event. (Inherited from DiagramBase.)
OnLinkCreateCancelled | Raises the LinkCreateCancelled event. (Inherited from DiagramBase.)
OnLinkCreated | Raises the LinkCreated event. (Inherited from DiagramBase.)
OnLinkCreating | Raises the LinkCreating event. (Inherited from DiagramBase.)
OnLinkDeactivated | Raises the LinkDeactivated event. (Inherited from DiagramBase.)
OnLinkDeleted | Raises the LinkDeleted event. (Inherited from DiagramBase.)
OnLinkDeleting | Raises the LinkDeleting event. (Inherited from DiagramBase.)
OnLinkDeselected | Raises the LinkDeselected event. (Inherited from DiagramBase.)
OnLinkDoubleClicked | Raises the LinkDoubleClicked event. (Inherited from DiagramBase.)
OnLinkModified | Raises the LinkModified event. (Inherited from DiagramBase.)
OnLinkModifyCancelled | Raises the LinkModifyCancelled event. (Inherited from DiagramBase.)
OnLinkModifying | Raises the LinkModifying event. (Inherited from DiagramBase.)
OnLinkPasted | Raises the LinkPasted event. (Inherited from DiagramBase.)
OnLinkPointed | Raises the LinkPointed event. (Inherited from DiagramBase.)
OnLinkRouted | Raises the LinkRouted event. (Inherited from DiagramBase.)
OnLinkSelected | Raises the LinkSelected event. (Inherited from DiagramBase.)
OnLinkSelecting | Raises the LinkSelecting event. (Inherited from DiagramBase.)
OnLinkSplit | Raises the LinkSplit event. (Inherited from DiagramBase.)
OnLinkStartModifying | Raises the LinkStartModifying event. (Inherited from DiagramBase.)
OnLinkTextEdited | Raises the LinkTextEdited event. (Inherited from DiagramBase.)
OnLinkTextEditing | Raises the LinkTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnMeasureUnitChanged | Raises the MeasureUnitChanged event. (Inherited from DiagramBase.)
OnNodeActivated | Raises the NodeActivated event. (Inherited from DiagramBase.)
OnNodeClicked | Raises the NodeClicked event. (Inherited from DiagramBase.)
OnNodeCreateCancelled | Raises the NodeCreateCancelled event. (Inherited from DiagramBase.)
OnNodeCreated | Raises the NodeCreated event. (Inherited from DiagramBase.)
OnNodeCreating | Raises the NodeCreating event. (Inherited from DiagramBase.)
OnNodeDeactivated | Raises the NodeDeactivated event. (Inherited from DiagramBase.)
OnNodeDeleted | Raises the NodeDeleted event. (Inherited from DiagramBase.)
OnNodeDeleting | Raises the NodeDeleting event. (Inherited from DiagramBase.)
OnNodeDeselected | Raises the NodeDeselected event. (Inherited from DiagramBase.)
OnNodeDoubleClicked | Raises the NodeDoubleClicked event. (Inherited from DiagramBase.)
OnNodeModified | Raises the NodeModified event. (Inherited from DiagramBase.)
OnNodeModifyCancelled | Raises the NodeModifyCancelled event. (Inherited from DiagramBase.)
OnNodeModifying | Raises the NodeModifying event. (Inherited from DiagramBase.)
OnNodePasted | Raises the NodePasted event. (Inherited from DiagramBase.)
OnNodePointed | Raises the NodePointed event. (Inherited from DiagramBase.)
OnNodeSelected | Raises the NodeSelected event. (Inherited from DiagramBase.)
OnNodeSelecting | Raises the NodeSelecting event. (Inherited from DiagramBase.)
OnNodeStartModifying | Raises the NodeStartModifying event. (Inherited from DiagramBase.)
OnNodeTextEdited | Raises the NodeTextEdited event. (Inherited from DiagramBase.)
OnNodeTextEditing | Raises the NodeTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnOriginAnchorChanged | Raises the OriginAnchorChanged event. (Inherited from DiagramBase.)
OnPropertyChanged | Raises the PropertyChanged event.
OnQueryAlignTarget | Raises the QueryAlignTarget event. (Inherited from DiagramBase.)
OnRepaint | Raises the Repaint event. (Inherited from DiagramBase.)
OnRequestClipboard | Raises the RequestClipboard event. (Inherited from DiagramBase.)
OnRequestTimer | Raises the RequestTimer event. (Inherited from DiagramBase.)
OnSelectionChanged | Raises the SelectionChanged event. (Inherited from DiagramBase.)
OnSelectionModified | Raises the SelectionModified event. (Inherited from DiagramBase.)
OnSelectionModifying | Raises the SelectionModifying event. (Inherited from DiagramBase.)
OnSerializeTag | Raises the SerializeTag event. (Inherited from DiagramBase.)
OnSetSelfLoopShape | Raises the SetSelfLoopShape event. (Inherited from DiagramBase.)
OnShapeModified | Raises the ShapeModified event. (Inherited from DiagramBase.)
OnTableColumnResized | Raises the TableColumnResized event. (Inherited from DiagramBase.)
OnTableColumnResizing | Raises the TableColumnResizing event. (Inherited from DiagramBase.)
OnTableRowResized | Raises the TableRowResized event. (Inherited from DiagramBase.)
OnTableRowResizing | Raises the TableRowResizing event. (Inherited from DiagramBase.)
OnTableSectionCollapsed | Raises the TableSectionCollapsed event. (Inherited from DiagramBase.)
OnTableSectionExpanded | Raises the TableSectionExpanded event. (Inherited from DiagramBase.)
OnTreeCollapsed | Raises the TreeCollapsed event. (Inherited from DiagramBase.)
OnTreeExpanded | Raises the TreeExpanded event. (Inherited from DiagramBase.)
OnTreeItemTextEditing | Raises the TreeItemTextEditing event. (Inherited from DiagramBase.)
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event. (Inherited from DiagramBase.)
OnViewRemoved | Raises the ViewRemoved event. (Inherited from DiagramBase.)
RemoveItem | Invoked by the AddItemCmd and RemoveItemCmd classes to effectively remove the specified item from the diagram. (Inherited from Diagram.)

See Also

DiagramPage Class


MindFusion.Diagramming.DiagramPage.OnPropertyChanged Method

DiagramPage.OnPropertyChanged Method
[image]

Raises the PropertyChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnPropertyChanged (
PropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPropertyChanged( _
e As PropertyChangedEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramPage Members
DiagramPage Class


MindFusion.Diagramming.DiagramPage Properties

DiagramPage Properties
[image]

Public Properties

Name | Description
ActiveItem | Gets or sets the active diagram element. (Inherited from Diagram.)
ActiveItemHandlesStyle | Gets the visual style of adjustment handles of the active item. (Inherited from Diagram.)
ActiveLayer | Gets or sets the zero-based index of the active layer. (Inherited from Diagram.)
AdjustmentHandlesSize | Gets or sets the size of the handles, which appear around selected objects. (Inherited from Diagram.)
AlignmentGuidePen | Gets or sets the pen used to draw alignment guides. (Inherited from Diagram.)
AlignToGrid | Gets or sets a value indicating whether the diagram items is aligned to a grid. (Inherited from Diagram.)
AllowLinksRepeat | Gets or sets a value indicating whether more than one link can connect the same origin and destination diagram nodes. (Inherited from Diagram.)
AllowMultipleResize | Gets or sets whether multiple selected nodes can be resized simultaneously. (Inherited from Diagram.)
AllowSelfLoops | Gets or sets a value indicating whether self-loops are allowed. (Inherited from Diagram.)
AllowSplitLinks | Gets or sets a value indicating whether link segments can be added and removed interactively. (Inherited from Diagram.)
AllowUnanchoredLinks | Gets or sets a value indicating whether links can be connected to nodes to which there aren't anchor points assigned. (Inherited from Diagram.)
AllowUnconnectedLinks | Gets or sets a value indicating whether users are allowed to draw links that are not connected to any node. (Inherited from Diagram.)
AutoAlignDistance | Gets or sets the maximal horizontal or vertical distance at which a node aligns to the borders of other nodes. (Inherited from Diagram.)
AutoAlignNodes | Gets or sets whether nodes should automatically align to the borders of other nodes during user interaction. (Inherited from Diagram.)
AutoHighlightRows | Gets or sets whether a table row should be highlighted when the user clicks on it. (Inherited from Diagram.)
AutoResize | Gets or sets a value indicating whether the document area must be resized automatically so it fits the diagram contents. (Inherited from Diagram.)
AutoSnapDistance | Specifies the maximum distance at which links auto-snap to nodes. (Inherited from Diagram.)
AutoSnapLinks | Gets or sets the default value for the AutoSnapToNode property of new links. (Inherited from Diagram.)
BackBrush | Gets or sets the brush used for painting the diagram background. (Inherited from Diagram.)
BackgroundImage | Gets or sets the image displayed as background of this diagram. (Inherited from Diagram.)
BackgroundImageAlign | Gets or sets a value indicating how the background image is positioned, relatively to the scrollable document area. (Inherited from Diagram.)
BackgroundImageUrl | URL of the image painted as diagram's background. (Inherited from Diagram.)
BarcodeNodeStyle | Gets the theme-level style for barcode nodes. (Inherited from Diagram.)
Bounds | Gets or sets a value representing the size of the diagram's scrollable area. (Inherited from Diagram.)
BoundsPen | The pen with which the document bounds should be drawn. (Inherited from Diagram.)
CellCustomDraw | Gets or sets the default type of custom painting done on the cells of tables. (Inherited from Diagram.)
CellFrameStyle | Gets or sets the default cell border style of new tables. (Inherited from Diagram.)
CompositeNodeStyle | Gets the theme-level style for composite nodes. (Inherited from Diagram.)
ContainerCaption | Gets or sets the default value for the Caption property of containers. (Inherited from Diagram.)
ContainerCaptionHeight | Gets or sets the default value for the CaptionHeight property of containers. (Inherited from Diagram.)
ContainerHighlightPen | Gets or sets the default value for the HighlightPen property of containers. (Inherited from Diagram.)
ContainerMargin | Gets or sets the default value for the Margin property of containers. (Inherited from Diagram.)
ContainerMinimumSize | Gets or sets the default value for the MinimumSize property of containers. (Inherited from Diagram.)
ContainerNodeStyle | Gets the theme-level style for container nodes. (Inherited from Diagram.)
ContainersFoldable | Gets or sets the default value for the Foldable property of containers. (Inherited from Diagram.)
CrossingRadius | Gets or sets the radius length of decorations displayed at link intersection points. (Inherited from Diagram.)
DefaultShape | Gets or sets the default shape of shape nodes. (Inherited from Diagram.)
DiagramLinkStyle | Gets the theme-level style for diagram links. (Inherited from Diagram.)
DiagramStyle | Gets the theme-level style for the diagram. (Inherited from Diagram.)
Dirty | Gets or sets a value indicating whether the diagram has changed since the last save. (Inherited from Diagram.)
DisabledHandlesStyle | Gets the visual style of disabled adjustment handles. (Inherited from Diagram.)
DynamicLinks | Gets or sets the default value for the Dynamic property of new links. (Inherited from Diagram.)
EffectiveBackBrush | Gets the currently effective background brush of the diagram. (Inherited from Diagram.)
EffectsProvider | Gets or sets an object used to generate visual effects for shape nodes such as embossment and shadow dispersion. (Inherited from Diagram.)
EnableEmbossEffects | Gets or sets a value indicating whether emboss effect for shape nodes is enabled. (Inherited from Diagram.)
EnableLanes | Gets or sets whether lanes are enabled. (Inherited from Diagram.)
EnableShadowEffects | Gets or sets a value indicating whether the shadow dispersion effect for nodes is enabled. (Inherited from Diagram.)
EnableStyledText | Gets or sets the default value for the EnableStyledText property of new nodes. (Inherited from Diagram.)
ExpandButtonAction | Gets or sets a value indicating what should happen when a user clicks the [±] button that is displayed near expandable nodes. (Inherited from Diagram.)
ExpandButtonPosition | Gets or sets where expand/collapse buttons are located relatively to their nodes. (Inherited from Diagram.)
ExpandOnIncoming | Gets or sets a value, indicating in which direction object hierarchies are expanded. (Inherited from Diagram.)
ExteriorBrush | Gets or sets the brush used for painting the area outside Bounds. (Inherited from Diagram.)
Factory | Gets a Factory instance that lets you add programmatically new items to the diagram. (Inherited from Diagram.)
FocusedComponent | Gets or sets the component within this diagram which currently has the input focus. (Inherited from Diagram.)
FoldedContainerSize | Gets or sets the size of folded containers. (Inherited from Diagram.)
Font | Gets or sets the default font for new diagram items. (Inherited from Diagram.)
GridColor | Gets or sets the color of the grid points. (Inherited from Diagram.)
GridOffsetX | Gets or sets the horizontal offset of the first point of the alignment grid. (Inherited from Diagram.)
GridOffsetY | Gets or sets the vertical offset of the first point of the alignment grid. (Inherited from Diagram.)
GridSizeX | Gets or sets the horizontal distance between adjacent grid points. (Inherited from Diagram.)
GridSizeY | Gets or sets the vertical distance between adjacent grid points. (Inherited from Diagram.)
GridStyle | Gets or sets the visual style of the alignment grid. (Inherited from Diagram.)
Groups | Gets a collection of all groups in the diagram. (Inherited from Diagram.)
HitTestPriority | Gets or sets a value indicating the order in which items are hit-tested. (Inherited from Diagram.)
Icon | Gets or sets an image associated with the page.
Interaction | Gets an InteractionState instance representing the current action being carried out by the user. (Inherited from Diagram.)
IsProEdition | Gets a value indicating whether the currently loaded MvcDiagram is a professional version of the control. (Inherited from Diagram.)
Items | Gets a collection of all items in this diagram. (Inherited from Diagram.)
LaneGrid | Gets the Grid instance that represents the lane grid. (Inherited from Diagram.)
Layers | Gets a list of the layers in the current diagram. (Inherited from Diagram.)
LinkBaseShape | Gets or sets the shape displayed at the base of new links. (Inherited from Diagram.)
LinkBaseShapeSize | Gets or sets the default size of the base of new links. (Inherited from Diagram.)
LinkBrush | Gets or sets the default value for the Brush property of links. (Inherited from Diagram.)
LinkCascadeOrientation | Gets or sets the initial orientation of the first segment of new cascading links. (Inherited from Diagram.)
LinkCrossings | Gets or sets how to render the intersection points where links cross their paths. (Inherited from Diagram.)
LinkCustomDraw | Gets or sets the default type of custom painting done on links. (Inherited from Diagram.)
LinkEndsMovable | Gets or sets a value indicating whether link ends can be moved by users after the link is created. (Inherited from Diagram.)
LinkHandlesStyle | Gets or sets the default value for the HandlesStyle property of new links. (Inherited from Diagram.)
LinkHeadShape | Gets or sets the shape displayed as head of new links. (Inherited from Diagram.)
LinkHeadShapeSize | Gets or sets the default size of arrowheads. (Inherited from Diagram.)
LinkHitDistance | Gets or sets a value specifying how far from a link a click is still considered a hit. (Inherited from Diagram.)
LinkIntermediateShape | Gets or sets the default shape to be displayed in the middle of each segment of links. (Inherited from Diagram.)
LinkIntermediateShapeSize | Gets or sets the default size of the shapes at middles of link segments. (Inherited from Diagram.)
LinkPen | Gets or sets the default value for the Pen and HeadPen properties of links. (Inherited from Diagram.)
LinkRouter | Gets or sets the component used to find paths for auto-routed links when diagram nodes are added or their positions change. (Inherited from Diagram.)
Links | Gets a collection of all DiagramLink objects in the diagram. (Inherited from Diagram.)
LinkSegments | Gets or sets the default number of link segments. (Inherited from Diagram.)
LinkShape | Gets or sets the default value of the Shape property of new links. (Inherited from Diagram.)
LinksRetainForm | Gets or sets whether links should maintain their forms if the nodes linked with those links are moved around. (Inherited from Diagram.)
LinkText | Gets or sets the default text of links. (Inherited from Diagram.)
LinkTextStyle | Gets or sets default placement and orientation for links' text. (Inherited from Diagram.)
MeasureTextRenderingHint | Gets or sets the TextRenderingHint to use when measuring texts. This should be effectively set to the value of DiagramView.TextRenderingHint. (Inherited from Diagram.)
MeasureUnit | Gets or sets the unit of measure used for logical coordinates in this diagram. (Inherited from Diagram.)
MergeThreshold | Gets or sets the maximum distance between adjacent control points of a link at which the respective segments can be merged. (Inherited from Diagram.)
MinimumNodeSize | Gets or sets the minimum node size that the user is allowed to set. (Inherited from Diagram.)
NodeEffects | Gets a collection with all effects applied to the nodes of this diagram. (Inherited from Diagram.)
Nodes | Gets a collection of all DiagramNode objects in the diagram. (Inherited from Diagram.)
NodesExpandable | Gets or sets a value indicating whether newly created nodes can be expanded. (Inherited from Diagram.)
NowLoading | Gets a value indicating whether the diagram data is now being loaded from a file. (Inherited from Diagram.)
PolygonalTextLayout | Gets or sets a value indicating whether to enable the formatting of text inside non-rectangular shape node outlines. (Inherited from Diagram.)
RecursiveExpand | Gets or sets value indicating how a tree is expanded. (Inherited from Diagram.)
RestrictItemsToBounds | Gets or sets a value indicating whether users are allowed to place items outside the scrollable area of the diagram. (Inherited from Diagram.)
RoundedLinks | Gets or sets a value indicating whether the joins between segments of Polyline and Cascading links should be rounded. (Inherited from Diagram.)
RoundedLinksRadius | Gets or sets the radius of arc joins of rounded links' segments. (Inherited from Diagram.)
RoundRectFactor | Gets or sets the relative size of arcs displayed at the corners of rounded rectangles. (Inherited from Diagram.)
RouteLinks | Gets or sets a value indicating whether links should avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes. (Inherited from Diagram.)
RoutingOptions | Gets an object, which allows customizing various parameters of the link routing algorithm. (Inherited from Diagram.)
RowHighlightBrush | Gets or sets the Brush used to fill highlighted table rows. (Inherited from Diagram.)
ScriptHelper | Gets a ScriptHelper object which can be used in html scripts to instantiate various objects and to call static methods. (Inherited from Diagram.)
SelectAfterCreate | Gets or sets a value indicating whether newly created objects are automatically selected. (Inherited from Diagram.)
SelectedItemHandlesStyle | Gets the visual style of adjustment handles of selected items. (Inherited from Diagram.)
Selection | Gets a Selection instance that represents the selection of items in this diagram. (Inherited from Diagram.)
SelectionOnTop | Gets or sets a value indicating whether selected items should be painted on top of other items. (Inherited from Diagram.)
SerializationBinder | Gets or sets a SerializationBinder object used to control class loading. (Inherited from Diagram.)
ShadowBrush | Gets or sets the default brush used to paint the shadows cast by diagram items. (Inherited from Diagram.)
ShadowOffsetX | Gets or sets the horizontal offset of item shadows. (Inherited from Diagram.)
ShadowOffsetY | Gets or sets the vertical offset of item shadows. (Inherited from Diagram.)
ShadowsStyle | Gets or sets the style for rendering shadows. (Inherited from Diagram.)
ShapeBrush | Gets or sets the default value for the Brush property of shape nodes. (Inherited from Diagram.)
ShapeCustomDraw | Gets or sets the default type of custom painting done for shape nodes. (Inherited from Diagram.)
ShapeHandlesStyle | Gets or sets the default value for the HandlesStyle property of new shape nodes. (Inherited from Diagram.)
ShapeNodeStyle | Gets the theme-level style for shape nodes. (Inherited from Diagram.)
ShapeOrientation | Gets or sets the default value for the ShapeOrientation property of shape nodes. (Inherited from Diagram.)
ShapePen | Gets or sets the default value for the Pen property of shape nodes. (Inherited from Diagram.)
ShapeText | Gets or sets the default text of shape nodes. (Inherited from Diagram.)
ShowAnchors | Gets or sets a value indicating whether and when node anchor points should be displayed. (Inherited from Diagram.)
ShowDisabledHandles | Gets or sets a value indicating whether manipulation handles are painted when they are disabled. (Inherited from Diagram.)
ShowGrid | Gets or sets a value indicating whether the alignment grid is visible. (Inherited from Diagram.)
ShowHandlesOnDrag | Gets or sets a value indicating whether to display selection handles of objects under the mouse while another object is being modified. (Inherited from Diagram.)
SnapToAnchor | Gets or sets when link end points should be aligned to the nearest anchor points. (Inherited from Diagram.)
SortGroupsByZ | Gets or sets a value indicating whether grouped items should be drawn sorted by their z-order while the whole group is being moved. (Inherited from Diagram.)
Style | Gets or sets the style associated with the diagram. (Inherited from Diagram.)
SvgNodeStyle | Gets the theme-level style for SVG nodes. (Inherited from Diagram.)
TableBrush | Gets or sets the default value for the Brush property of tables. (Inherited from Diagram.)
TableCaption | Gets or sets the default text for tables' captions. (Inherited from Diagram.)
TableCaptionHeight | Gets or sets the default height of table captions. (Inherited from Diagram.)
TableColumnCount | Gets or sets the default number of table columns. (Inherited from Diagram.)
TableColumnWidth | Gets or sets the default width of tables' columns. (Inherited from Diagram.)
TableConnectionStyle | Gets or sets a value indicating whether drawing a link between tables should connect the rows of those tables, or the tables as whole entities. (Inherited from Diagram.)
TableCustomDraw | Gets or sets the default type of custom painting done on tables. (Inherited from Diagram.)
TableHandlesStyle | Gets or sets the default value for the HandlesStyle property of new tables. (Inherited from Diagram.)
TableNodeStyle | Gets the theme-level style for table nodes. (Inherited from Diagram.)
TablePen | Gets or sets the default value for the Pen property of tables. (Inherited from Diagram.)
TableRowCount | Gets or sets the default number of table rows. (Inherited from Diagram.)
TableRowHeight | Gets or sets the default height of tables' rows. (Inherited from Diagram.)
TableShape | Gets or sets the default value of the Shape property of new tables. (Inherited from Diagram.)
TablesScrollable | Gets or sets the default value for the Scrollable property of new tables. (Inherited from Diagram.)
Tag | Gets or sets custom data associated with this diagram. (Inherited from Diagram.)
TextColor | Gets or sets the default color of text displayed inside diagram items. (Inherited from Diagram.)
TextFormat | Gets or sets the default alignment and formatting style for text displayed inside nodes and table cells. (Inherited from Diagram.)
Theme | Gets or sets the theme associated with the diagram. (Inherited from Diagram.)
Title | Gets or sets the page title.
TitleColor | Gets or sets the color of the title when the title is displayed.
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram. (Inherited from Diagram.)
TreeViewNodeStyle | Gets the theme-level style for tree view nodes. (Inherited from Diagram.)
UndoManager | Gets a reference to the diagram's UndoManager instance. (Inherited from Diagram.)
ValidityChecks | Gets or sets a value indicating whether validity checks are performed each time an item is added to the diagram. (Inherited from Diagram.)
VisioNodeStyle | Gets the theme-level style for Visio nodes. (Inherited from Diagram.)

See Also

DiagramPage Class


MindFusion.Diagramming.DiagramPage.Icon Property

DiagramPage.Icon Property
[image]

Gets or sets an image associated with the page.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Image Icon { get; set; }

Visual Basic [image] Copy Code

Public Property Icon As Image

Property Value

A .NET Image object.

See Also

DiagramPage Members
DiagramPage Class


MindFusion.Diagramming.DiagramPage.Title Property

DiagramPage.Title Property
[image]

Gets or sets the page title.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

A string value.

See Also

DiagramPage Members
DiagramPage Class


MindFusion.Diagramming.DiagramPage.TitleColor Property

DiagramPage.TitleColor Property
[image]

Gets or sets the color of the title when the title is displayed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color TitleColor { get; set; }

Visual Basic [image] Copy Code

Public Property TitleColor As Color

Property Value

A .NET Color object.

See Also

DiagramPage Members
DiagramPage Class


MindFusion.Diagramming.DiagramPage Events

DiagramPage Events
[image]

Public Events

Name | Description
ActionRecorded | Raised when an action is recorded in the undo buffer. (Inherited from DiagramBase.)
ActionRecording | A validation event raised before an action is recorded in the undo buffer. (Inherited from DiagramBase.)
ActionRedone | Raised when an action is redone. (Inherited from DiagramBase.)
ActionUndone | Raised when an action is undone. (Inherited from DiagramBase.)
ActiveLayerChanged | Raised when the diagram's active layer has changed. (Inherited from DiagramBase.)
BeginLoad | Raised when the component starts loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
BoundsChanged | Raised when the Bounds property value has changed. (Inherited from DiagramBase.)
CellClicked | Raised when the user clicks a table’s cell. (Inherited from DiagramBase.)
CellDoubleClicked | Raised when the user double-clicks a table’s cell. (Inherited from DiagramBase.)
CellTextEdited | Raised when the user edits the text of a table’s cell. (Inherited from DiagramBase.)
CellTextEditing | A validation event that lets you approve or reject changes made to the text of a table’s cell. (Inherited from DiagramBase.)
Clicked | Raised when the user clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area. (Inherited from DiagramBase.)
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area. (Inherited from DiagramBase.)
ContentVisibilityChanged | Raised when the visibility of container's content changes. (Inherited from DiagramBase.)
DefaultShapeChanged | Raised when the DefaultShape property value has changed. (Inherited from DiagramBase.)
DeserializeTag | Raised when the Tag of a diagram item must be deserialized from XML format. (Inherited from DiagramBase.)
DestinationAnchorChanged | Raised when the DestinationAnchor property value of a link has changed. (Inherited from DiagramBase.)
DirtyChanged | Raised when the Dirty property value has changed. (Inherited from DiagramBase.)
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
DrawAdjustmentHandles | Raised when item’s adjustment handles must be custom drawn. (Inherited from DiagramBase.)
DrawAnchorPoint | Raised when an anchor point must be custom drawn. (Inherited from DiagramBase.)
DrawBackground | Raised to let you custom draw the diagram background. (Inherited from DiagramBase.)
DrawCell | Raised when a table’s cell must be custom drawn. (Inherited from DiagramBase.)
DrawForeground | Raised to let you custom draw the diagram foreground. (Inherited from DiagramBase.)
DrawLink | Raised when a diagram link must be custom drawn. (Inherited from DiagramBase.)
DrawNode | Raised when a diagram node must be custom drawn. (Inherited from DiagramBase.)
EndLoad | Raised when the component ends loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
ExpandButtonClicked | Raised when the user clicks the [±] button of an Expandable node. (Inherited from DiagramBase.)
GroupDestroyed | Raised when a Group object is destroyed. (Inherited from DiagramBase.)
HitTestAdjustmentHandles | Raised when custom hit testing of item’s adjustment handles must be performed. (Inherited from DiagramBase.)
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created. (Inherited from DiagramBase.)
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created. (Inherited from DiagramBase.)
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
LayerVisibilityChanged | Raised when the visibility of a Layer changes. (Inherited from DiagramBase.)
LinkActivated | Raised when a link becomes the ActiveItem. (Inherited from DiagramBase.)
LinkClicked | Raised when the user clicks a link. (Inherited from DiagramBase.)
LinkCreateCancelled | Raised when the user cancels link creation. (Inherited from DiagramBase.)
LinkCreated | Raised when the user draws a new link. (Inherited from DiagramBase.)
LinkCreating | A validation event raised while the user is drawing a new link. (Inherited from DiagramBase.)
LinkDeactivated | Raised when a link is no longer the ActiveItem. (Inherited from DiagramBase.)
LinkDeleted | Raised when a link is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkDeselected | Raised when a link is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDoubleClicked | Raised when the user double-clicks a link. (Inherited from DiagramBase.)
LinkModified | Raised when the user moves any control point of a link. (Inherited from DiagramBase.)
LinkModifyCancelled | Raised when the user cancels move or resize operation being done on a link. (Inherited from DiagramBase.)
LinkModifying | A validation event raised while the user is modifying a link. (Inherited from DiagramBase.)
LinkPasted | Raised when a link has been pasted from the clipboard. (Inherited from DiagramBase.)
LinkPointed | Raised when the mouse pointer hovers over a link. (Inherited from DiagramBase.)
LinkRouted | Raised when a link is routed by the auto-routing algorithm. (Inherited from DiagramBase.)
LinkSelected | Raised when a link is selected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkSelecting | Raised when the user tries to select a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkSplit | Raised when the user splits a link interactively. (Inherited from DiagramBase.)
LinkStartModifying | A validation event raised when the user starts modifying a link. (Inherited from DiagramBase.)
LinkTextEdited | Raised when the user edits the text of a link. (Inherited from DiagramBase.)
LinkTextEditing | A validation event that lets you approve or reject changes made to the text of a link. (Inherited from DiagramBase.)
MeasureUnitChanged | Raised when the MeasureUnit property value has changed. (Inherited from DiagramBase.)
NodeActivated | Raised when a node becomes the ActiveItem. (Inherited from DiagramBase.)
NodeClicked | Raised when the user clicks a node. (Inherited from DiagramBase.)
NodeCreateCancelled | Raised when the user cancels node creation. (Inherited from DiagramBase.)
NodeCreated | Raised when the user draws a new node. (Inherited from DiagramBase.)
NodeCreating | A validation event raised while the user is drawing a new node. (Inherited from DiagramBase.)
NodeDeactivated | Raised when a node is no longer the ActiveItem. (Inherited from DiagramBase.)
NodeDeleted | Raised when a node is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeDeselected | Raised when a node is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDoubleClicked | Raised when the user double-clicks a node. (Inherited from DiagramBase.)
NodeModified | Raised when the user moves or resizes a node. (Inherited from DiagramBase.)
NodeModifyCancelled | Raised when the user cancels move or resize operation being done on a node. (Inherited from DiagramBase.)
NodeModifying | A validation event raised while the user is moving or resizing a node. (Inherited from DiagramBase.)
NodePasted | Raised when a node has been pasted from the clipboard. (Inherited from DiagramBase.)
NodePointed | Raised when the mouse pointer hovers over a node. (Inherited from DiagramBase.)
NodeSelected | Raised when a node is selected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeSelecting | Raised when the user tries to select a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeStartModifying | A validation event raised when the user starts modifying a node. (Inherited from DiagramBase.)
NodeTextEdited | Raised when the user edits the text of a node. (Inherited from DiagramBase.)
NodeTextEditing | A validation event that lets you approve or reject changes made to the text of a node. (Inherited from DiagramBase.)
OriginAnchorChanged | Raised when the OriginAnchor property value of a link has changed. (Inherited from DiagramBase.)
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.
QueryAlignTarget | Raised to validate a node as target for alignment guides when AutoAlignNodes is enabled. (Inherited from DiagramBase.)
Repaint | Raised when the diagram views should be repainted. (Inherited from DiagramBase.)
RequestCacheReset | Raised when an object within the diagram requests a reset of the cached bitmap. (Inherited from DiagramBase.)
RequestClipboard | Raised when an object within the diagram requests an operation with the clipboard. (Inherited from DiagramBase.)
RequestTimer | Raised when an object within the diagram needs to start or stop a timer. (Inherited from DiagramBase.)
SelectionChanged | Raised when an item is added to or removed from the selection (Inherited from DiagramBase.)
SelectionModified | Raised when the user moves multiple selected items. (Inherited from DiagramBase.)
SelectionModifying | Raised while the user is moving multiple selected items, this event lets you cancel the modification. (Inherited from DiagramBase.)
SerializeTag | Raised when the Tag of a diagram item must be serialized into an XML document. (Inherited from DiagramBase.)
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape. (Inherited from DiagramBase.)
ShapeModified | Raised when the user modifies the shape of a ShapeNode by moving one of the control points corresponding to shape formula parameters. (Inherited from DiagramBase.)
TableColumnResized | Raised when the user finishes resizing a column in a table. (Inherited from DiagramBase.)
TableColumnResizing | Raised when the user resizes a column in a table interactively. (Inherited from DiagramBase.)
TableRowResized | Raised when the user finishes resizing a row in a table. (Inherited from DiagramBase.)
TableRowResizing | Raised when the user resizes a row in a table interactively. (Inherited from DiagramBase.)
TableSectionCollapsed | Raised when the user collapses the rows of a table’s section by clicking the [-] button in the section's header row. (Inherited from DiagramBase.)
TableSectionExpanded | Raised when the user expands the rows of a table's section by clicking the [+] button in the section’s header row. (Inherited from DiagramBase.)
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node. (Inherited from DiagramBase.)
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node. (Inherited from DiagramBase.)
TreeItemTextEditing | A validation event that lets you approve or reject changes made to the text of a TreeViewNode's item. (Inherited from DiagramBase.)
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point. (Inherited from DiagramBase.)
ViewRemoved | Raised when a DiagramView is detached from this diagram. (Inherited from DiagramBase.)

See Also

DiagramPage Class


MindFusion.Diagramming.DiagramPage.PropertyChanged Event

DiagramPage.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

DiagramPage Members
DiagramPage Class


MindFusion.Diagramming.DiagramPageEventArgs Class

DiagramPageEventArgs Class
[image]

Contains the arguments passed to DiagramPage-related event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramPageEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DiagramPageEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.DiagramPageEventArgs
MindFusion.Diagramming.DiagramPageValidationEventArgs

See Also

DiagramPageEventArgs Members


MindFusion.Diagramming.DiagramPageEventArgs Members

DiagramPageEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to DiagramPage-related event handlers.

The following tables list the members exposed by the DiagramPageEventArgs type.

Public Constructors

Name | Description
DiagramPageEventArgs | Initializes a new instance of the DiagramPageEventArgs class.

Public Properties

Name | Description
DiagramPage | Gets the DiagramPage related to the event.

See Also

DiagramPageEventArgs Class


MindFusion.Diagramming.DiagramPageEventArgs Constructor

DiagramPageEventArgs Constructor
[image]

Initializes a new instance of the DiagramPageEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramPageEventArgs (
DiagramPage diagramPage
)

Visual Basic [image] Copy Code

Public New ( _
diagramPage As DiagramPage _
)

Parameters

diagramPage

The DiagramPage related to the event.

See Also

DiagramPageEventArgs Class


MindFusion.Diagramming.DiagramPageEventArgs Properties

DiagramPageEventArgs Properties
[image]

Public Properties

Name | Description
DiagramPage | Gets the DiagramPage related to the event.

See Also

DiagramPageEventArgs Class


MindFusion.Diagramming.DiagramPageEventArgs.DiagramPage Property

DiagramPageEventArgs.DiagramPage Property
[image]

Gets the DiagramPage related to the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramPage DiagramPage { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DiagramPage As DiagramPage

Property Value

A DiagramPage object.

See Also

DiagramPageEventArgs Members
DiagramPageEventArgs Class


MindFusion.Diagramming.DiagramPageValidationEventArgs Class

DiagramPageValidationEventArgs Class
[image]

Contains the arguments passed to handlers of DiagramPage validation events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramPageValidationEventArgs : DiagramPageEventArgs

Visual Basic [image] Copy Code

Public Class DiagramPageValidationEventArgs
Inherits DiagramPageEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.DiagramPageEventArgs
MindFusion.Diagramming.DiagramPageValidationEventArgs

See Also

DiagramPageValidationEventArgs Members


MindFusion.Diagramming.DiagramPageValidationEventArgs Members

DiagramPageValidationEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to handlers of DiagramPage validation events.

The following tables list the members exposed by the DiagramPageValidationEventArgs type.

Public Constructors

Name | Description
DiagramPageValidationEventArgs | Initializes a new instance of the DiagramPageValidationEventArgs class.

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to cancel the current operation.
DiagramPage | Gets the DiagramPage related to the event. (Inherited from DiagramPageEventArgs.)

See Also

DiagramPageValidationEventArgs Class


MindFusion.Diagramming.DiagramPageValidationEventArgs Constructor

DiagramPageValidationEventArgs Constructor
[image]

Initializes a new instance of the DiagramPageValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramPageValidationEventArgs (
DiagramPage diagramPage
)

Visual Basic [image] Copy Code

Public New ( _
diagramPage As DiagramPage _
)

Parameters

diagramPage

The DiagramPage related to the event.

See Also

DiagramPageValidationEventArgs Class


MindFusion.Diagramming.DiagramPageValidationEventArgs Properties

DiagramPageValidationEventArgs Properties
[image]

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to cancel the current operation.
DiagramPage | Gets the DiagramPage related to the event. (Inherited from DiagramPageEventArgs.)

See Also

DiagramPageValidationEventArgs Class


MindFusion.Diagramming.DiagramPageValidationEventArgs.Cancel Property

DiagramPageValidationEventArgs.Cancel Property
[image]

Gets or sets a value indicating whether to cancel the current operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

true to cancel the operation; false to confirm it.

Remarks

Set this property to true to prevent the user from completing the operation.

See Also

DiagramPageValidationEventArgs Members
DiagramPageValidationEventArgs Class


MindFusion.Diagramming.DiagramStyle Class

DiagramStyle Class
[image]

Represents a reusable set of properties that define the appearance of diagrams.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramStyle : Style

Visual Basic [image] Copy Code

Public Class DiagramStyle
Inherits Style

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Style
MindFusion.Diagramming.DiagramStyle

See Also

DiagramStyle Members


MindFusion.Diagramming.DiagramStyle Members

DiagramStyle Members
Constructors Properties Methods Events
[image]

Represents a reusable set of properties that define the appearance of diagrams.

The following tables list the members exposed by the DiagramStyle type.

Public Constructors

Name | Description
DiagramStyle | Initializes a new instance of the DiagramStyle class.

Public Properties

Name | Description
BackBrush | Gets or sets the brush used for painting the diagram background.
Brush | Gets or sets the brush used to fill the interior of items.
FontFamily | Gets or sets the font family of the item texts.
FontSize | Gets or sets the font size of the item texts.
FontStyle | Gets or sets the font style of the item texts.
FontUnit | Gets or sets the font unit of the item texts.
NodeEffects | Gets a list with all effects applied to the nodes of this diagram.
ShadowBrush | Gets or sets the brush used to paint the shadow of the items.
Stroke | Gets or sets the brush used to paint the outline of the items.
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items.
StrokeThickness | Gets or sets the thickness of the items' outline, expressed in the current units of measure.
TextBrush | Gets or sets the brush used to paint texts inside the items.

Public Methods

Name | Description
GetProperties | Gets all properties in the style. (Inherited from Style.)
GetProperty | Returns the property with the specified name, if any. (Inherited from Style.)
RegisterType | Associates a type with an alias. (Inherited from Style.)

Protected Methods

Name | Description
GetValue | Gets the value of the specified property. (Inherited from Style.)
IsPropertySet | Checks whether the specified property has a value. (Inherited from Style.)
LoadFrom | Deserializes the item from the specified reader. (Inherited from Style.)
LoadFromXml | Loads the style content from an XML element. (Inherited from Style.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Style.)
RegisterProperty | Registers a new property with the specified name and type. (Inherited from Style.)
SaveTo | Serializes the style to the specified writer. (Inherited from Style.)
SaveToXml | Saves the style content into an XML element. (Inherited from Style.)
SetValue | Sets the value of the specified property. (Inherited from Style.)
UnsetValue | Clears the value of the specified property. (Inherited from Style.)

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

DiagramStyle Class


MindFusion.Diagramming.DiagramStyle Constructor

DiagramStyle Constructor
[image]

Initializes a new instance of the DiagramStyle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramStyle Class


MindFusion.Diagramming.DiagramStyle Properties

DiagramStyle Properties
[image]

Public Properties

Name | Description
BackBrush | Gets or sets the brush used for painting the diagram background.
Brush | Gets or sets the brush used to fill the interior of items.
FontFamily | Gets or sets the font family of the item texts.
FontSize | Gets or sets the font size of the item texts.
FontStyle | Gets or sets the font style of the item texts.
FontUnit | Gets or sets the font unit of the item texts.
NodeEffects | Gets a list with all effects applied to the nodes of this diagram.
ShadowBrush | Gets or sets the brush used to paint the shadow of the items.
Stroke | Gets or sets the brush used to paint the outline of the items.
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items.
StrokeThickness | Gets or sets the thickness of the items' outline, expressed in the current units of measure.
TextBrush | Gets or sets the brush used to paint texts inside the items.

See Also

DiagramStyle Class


MindFusion.Diagramming.DiagramStyle.BackBrush Property

DiagramStyle.BackBrush Property
[image]

Gets or sets the brush used for painting the diagram background.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush BackBrush { get; set; }

Visual Basic [image] Copy Code

Public Property BackBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

See Also

DiagramStyle Members
DiagramStyle Class


MindFusion.Diagramming.DiagramStyle.Brush Property

DiagramStyle.Brush Property
[image]

Gets or sets the brush used to fill the interior of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

See Also

DiagramStyle Members
DiagramStyle Class


MindFusion.Diagramming.DiagramStyle.FontFamily Property

DiagramStyle.FontFamily Property
[image]

Gets or sets the font family of the item texts.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string FontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property FontFamily As String

Property Value

A string value.

See Also

DiagramStyle Members
DiagramStyle Class


MindFusion.Diagramming.DiagramStyle.FontSize Property

DiagramStyle.FontSize Property
[image]

Gets or sets the font size of the item texts.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float FontSize { get; set; }

Visual Basic [image] Copy Code

Public Property FontSize As Single

Property Value

A float value.

See Also

DiagramStyle Members
DiagramStyle Class


MindFusion.Diagramming.DiagramStyle.FontStyle Property

DiagramStyle.FontStyle Property
[image]

Gets or sets the font style of the item texts.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FontStyle FontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property FontStyle As FontStyle

Property Value

One or more of the members of the FontStyle enumeration.

See Also

DiagramStyle Members
DiagramStyle Class


MindFusion.Diagramming.DiagramStyle.FontUnit Property

DiagramStyle.FontUnit Property
[image]

Gets or sets the font unit of the item texts.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GraphicsUnit FontUnit { get; set; }

Visual Basic [image] Copy Code

Public Property FontUnit As GraphicsUnit

Property Value

A member of the GraphicsUnit enumeration.

See Also

DiagramStyle Members
DiagramStyle Class


MindFusion.Diagramming.DiagramStyle.NodeEffects Property

DiagramStyle.NodeEffects Property
[image]

Gets a list with all effects applied to the nodes of this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IList<NodeEffect> NodeEffects { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NodeEffects As IList(Of NodeEffect)

Property Value

A list of NodeEffect objects.

See Also

DiagramStyle Members
DiagramStyle Class


MindFusion.Diagramming.DiagramStyle.ShadowBrush Property

DiagramStyle.ShadowBrush Property
[image]

Gets or sets the brush used to paint the shadow of the items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush ShadowBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ShadowBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

See Also

DiagramStyle Members
DiagramStyle Class


MindFusion.Diagramming.DiagramStyle.Stroke Property

DiagramStyle.Stroke Property
[image]

Gets or sets the brush used to paint the outline of the items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush Stroke { get; set; }

Visual Basic [image] Copy Code

Public Property Stroke As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

See Also

DiagramStyle Members
DiagramStyle Class


MindFusion.Diagramming.DiagramStyle.StrokeDashStyle Property

DiagramStyle.StrokeDashStyle Property
[image]

Gets or sets the pattern of dashes and gaps used to outline items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DashStyle StrokeDashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeDashStyle As DashStyle

Property Value

A member of the DashStyle enumeration.

See Also

DiagramStyle Members
DiagramStyle Class


MindFusion.Diagramming.DiagramStyle.StrokeThickness Property

DiagramStyle.StrokeThickness Property
[image]

Gets or sets the thickness of the items' outline, expressed in the current units of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double StrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThickness As Double

Property Value

A double value.

See Also

DiagramStyle Members
DiagramStyle Class


MindFusion.Diagramming.DiagramStyle.TextBrush Property

DiagramStyle.TextBrush Property
[image]

Gets or sets the brush used to paint texts inside the items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush TextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TextBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

See Also

DiagramStyle Members
DiagramStyle Class


MindFusion.Diagramming.DiagramStyle Events

DiagramStyle Events
[image]

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

DiagramStyle Class


MindFusion.Diagramming.DirectionConstraint Enumeration

DirectionConstraint Enumeration
[image]

Defines values that specify in what direction to constrain node movement.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum DirectionConstraint

Visual Basic [image] Copy Code

Public Enum DirectionConstraint

Members

Member name | Description
None | No restrictions.
Horizontal | Users are allowed to move the node horizontally.
Vertical | Users are allowed to move the node vertically.

Remarks

Values from this enumeration can be assigned to the MoveDirection property of the NodeConstraints class.

See Also


MindFusion.Diagramming.DraggedNode Class

DraggedNode Class
[image]

Class used to hold the DiagramNode instance during drag and drop. It is used for easier detection of the dragged content as DragEventArgs.Data.GetData does not check super classes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DraggedNode

Visual Basic [image] Copy Code

Public Class DraggedNode

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DraggedNode

See Also

DraggedNode Members


MindFusion.Diagramming.DraggedNode Members

DraggedNode Members
Constructors Properties
[image]

Class used to hold the DiagramNode instance during drag and drop. It is used for easier detection of the dragged content as DragEventArgs.Data.GetData does not check super classes.

The following tables list the members exposed by the DraggedNode type.

Public Constructors

Name | Description
DraggedNode | Overloaded. Initializes a new instance of the DraggedNode class.

Public Properties

Name | Description
Label | The text to be displayed for the node.
Node | Holds the dragged DiagramNode.
Size | The size of the node.

See Also

DraggedNode Class


MindFusion.Diagramming.DraggedNode Constructor

DraggedNode Constructor
[image]

Initializes a new instance of the DraggedNode class.

Overload List

Name | Description
DraggedNode (DiagramNode, SizeF) | Initializes a new instance of the DraggedNode class.
DraggedNode (DiagramNode, SizeF, String) | Initializes a new instance of the DraggedNode class.

See Also

DraggedNode Class


MindFusion.Diagramming.DraggedNode Constructor (DiagramNode, SizeF)

DraggedNode Constructor (DiagramNode, SizeF)
See Also
[image]

Initializes a new instance of the DraggedNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DraggedNode (
DiagramNode node,
SizeF size
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode, _
size As SizeF _
)

Parameters

node

The dragged DiagramNode.

size

The size of the node.

See Also

DraggedNode Constructor Overload List
DraggedNode Class


MindFusion.Diagramming.DraggedNode Constructor (DiagramNode, SizeF, String)

DraggedNode Constructor (DiagramNode, SizeF, String)
See Also
[image]

Initializes a new instance of the DraggedNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DraggedNode (
DiagramNode node,
SizeF size,
string label
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode, _
size As SizeF, _
label As String _
)

Parameters

node

The dragged DiagramNode.

size

The size of the node.

label

The text to be displayed for the node.

See Also

DraggedNode Constructor Overload List
DraggedNode Class


MindFusion.Diagramming.DraggedNode Properties

DraggedNode Properties
[image]

Public Properties

Name | Description
Label | The text to be displayed for the node.
Node | Holds the dragged DiagramNode.
Size | The size of the node.

See Also

DraggedNode Class


MindFusion.Diagramming.DraggedNode.Label Property

DraggedNode.Label Property
[image]

The text to be displayed for the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Label { get; set; }

Visual Basic [image] Copy Code

Public Property Label As String

Property Value

A string value.

See Also

DraggedNode Members
DraggedNode Class


MindFusion.Diagramming.DraggedNode.Node Property

DraggedNode.Node Property
[image]

Holds the dragged DiagramNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Node { get; set; }

Visual Basic [image] Copy Code

Public Property Node As DiagramNode

Property Value

A DiagramNode object.

See Also

DraggedNode Members
DraggedNode Class


MindFusion.Diagramming.DraggedNode.Size Property

DraggedNode.Size Property
[image]

The size of the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SizeF Size { get; set; }

Visual Basic [image] Copy Code

Public Property Size As SizeF

Property Value

A .NET SizeF object.

See Also

DraggedNode Members
DraggedNode Class


MindFusion.Diagramming.DraggedShape Class

DraggedShape Class
[image]

Contains drag-and-drop information for a shape being dragged from ShapeToolBar and ShapeListBox.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DraggedShape

Visual Basic [image] Copy Code

Public Class DraggedShape

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DraggedShape

See Also

DraggedShape Members


MindFusion.Diagramming.DraggedShape Members

DraggedShape Members
Constructors Properties
[image]

Contains drag-and-drop information for a shape being dragged from ShapeToolBar and ShapeListBox.

The following tables list the members exposed by the DraggedShape type.

Public Constructors

Name | Description
DraggedShape | Initializes a new instance of the DraggedShape class.

Public Properties

Name | Description
Id | Gets the Id of the dragged shape.
Size | Gets the recommended size of the dragged shape.

See Also

DraggedShape Class


MindFusion.Diagramming.DraggedShape Constructor

DraggedShape Constructor
[image]

Initializes a new instance of the DraggedShape class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DraggedShape (
string id,
SizeF size
)

Visual Basic [image] Copy Code

Public New ( _
id As String, _
size As SizeF _
)

Parameters

id

The Id of the dragged shape.

size
The recommended size of the dragged shape.

See Also

DraggedShape Class


MindFusion.Diagramming.DraggedShape Properties

DraggedShape Properties
[image]

Public Properties

Name | Description
Id | Gets the Id of the dragged shape.
Size | Gets the recommended size of the dragged shape.

See Also

DraggedShape Class


MindFusion.Diagramming.DraggedShape.Id Property

DraggedShape.Id Property
[image]

Gets the Id of the dragged shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Id { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Id As String

Property Value

A string specifying the identifier of the dragged shape.

See Also

DraggedShape Members
DraggedShape Class


MindFusion.Diagramming.DraggedShape.Size Property

DraggedShape.Size Property
[image]

Gets the recommended size of the dragged shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SizeF Size { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Size As SizeF

Property Value

A .NET SizeF object specifying the recommended size for the shape.

See Also

DraggedShape Members
DraggedShape Class


MindFusion.Diagramming.DrawAnchorPointEventArgs Class

DrawAnchorPointEventArgs Class
[image]

Contains the arguments passed to the DrawAnchorPoint event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DrawAnchorPointEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DrawAnchorPointEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.DrawAnchorPointEventArgs

See Also

DrawAnchorPointEventArgs Members


MindFusion.Diagramming.DrawAnchorPointEventArgs Members

DrawAnchorPointEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the DrawAnchorPoint event handlers.

The following tables list the members exposed by the DrawAnchorPointEventArgs type.

Public Constructors

Name | Description
DrawAnchorPointEventArgs | Initializes a new instance of the DrawAnchorPointEventArgs class.

Public Properties

Name | Description
AnchorIndex | Gets the index of the anchor point within its containing pattern.
AnchorPattern | Gets the anchor pattern containing the anchor point being drawn.
Graphics | Gets an object implementing the IGraphics interface whose methods should be used to draw the anchor point mark.
Location | Gets the location of the anchor point being drawn.
Node | Gets the node whose anchor point is being drawn.

See Also

DrawAnchorPointEventArgs Class


MindFusion.Diagramming.DrawAnchorPointEventArgs Constructor

DrawAnchorPointEventArgs Constructor
[image]

Initializes a new instance of the DrawAnchorPointEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DrawAnchorPointEventArgs (
IGraphics graphics,
PointF location,
DiagramNode node,
AnchorPattern anchorPattern,
int anchorIndex
)

Visual Basic [image] Copy Code

Public Sub DrawAnchorPointEventArgs ( _
graphics As IGraphics, _
location As PointF, _
node As DiagramNode, _
anchorPattern As AnchorPattern, _
anchorIndex As Integer _
)

Parameters

graphics

The IGraphics object that represents the target of the drawing operation.

location

The position of the anchor point, expressed in document coordinates.

node

The DiagramNode related to the event.

anchorPattern

The AnchorPattern object whose point is being drawn.

anchorIndex

The zero-based index of the anchor point being drawn within its anchor pattern.

See Also

DrawAnchorPointEventArgs Class


MindFusion.Diagramming.DrawAnchorPointEventArgs Properties

DrawAnchorPointEventArgs Properties
[image]

Public Properties

Name | Description
AnchorIndex | Gets the index of the anchor point within its containing pattern.
AnchorPattern | Gets the anchor pattern containing the anchor point being drawn.
Graphics | Gets an object implementing the IGraphics interface whose methods should be used to draw the anchor point mark.
Location | Gets the location of the anchor point being drawn.
Node | Gets the node whose anchor point is being drawn.

See Also

DrawAnchorPointEventArgs Class


MindFusion.Diagramming.DrawAnchorPointEventArgs.AnchorIndex Property

DrawAnchorPointEventArgs.AnchorIndex Property
[image]

Gets the index of the anchor point within its containing pattern.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int AnchorIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AnchorIndex As Integer

Property Value

An integer value specifying the zero-based index of the anchor point within its AnchorPattern.

See Also

DrawAnchorPointEventArgs Members
DrawAnchorPointEventArgs Class


MindFusion.Diagramming.DrawAnchorPointEventArgs.AnchorPattern Property

DrawAnchorPointEventArgs.AnchorPattern Property
[image]

Gets the anchor pattern containing the anchor point being drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern AnchorPattern { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AnchorPattern As AnchorPattern

Property Value

An instance of the AnchorPattern class.

See Also

DrawAnchorPointEventArgs Members
DrawAnchorPointEventArgs Class


MindFusion.Diagramming.DrawAnchorPointEventArgs.Graphics Property

DrawAnchorPointEventArgs.Graphics Property
[image]

Gets an object implementing the IGraphics interface whose methods should be used to draw the anchor point mark.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IGraphics Graphics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Graphics As IGraphics

Property Value

An instance of a class implementing the IGraphics interface.

See Also

DrawAnchorPointEventArgs Members
DrawAnchorPointEventArgs Class


MindFusion.Diagramming.DrawAnchorPointEventArgs.Location Property

DrawAnchorPointEventArgs.Location Property
[image]

Gets the location of the anchor point being drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointF Location { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Location As PointF

Property Value

A .NET PointF specifying the location of the anchor point.

See Also

DrawAnchorPointEventArgs Members
DrawAnchorPointEventArgs Class


MindFusion.Diagramming.DrawAnchorPointEventArgs.Node Property

DrawAnchorPointEventArgs.Node Property
[image]

Gets the node whose anchor point is being drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Node { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Node As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

DrawAnchorPointEventArgs Members
DrawAnchorPointEventArgs Class


MindFusion.Diagramming.DrawCellEventArgs Class

DrawCellEventArgs Class
[image]

Contains the arguments passed to the DrawCell event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DrawCellEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DrawCellEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.DrawCellEventArgs

See Also

DrawCellEventArgs Members


MindFusion.Diagramming.DrawCellEventArgs Members

DrawCellEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the DrawCell event handlers.

The following tables list the members exposed by the DrawCellEventArgs type.

Public Constructors

Name | Description
DrawCellEventArgs | Initializes a new instance of the DrawCellEventArgs class.

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the cell being drawn.
Cell | Gets the cell that should be custom drawn.
Column | Gets the index of the table's column that contains Cell.
Graphics | An object implementing the IGraphics interface whose methods should be used to draw the cell.
Row | Gets the index of the table's row that contains Cell.
Table | Get the table that contains Cell.

See Also

DrawCellEventArgs Class


MindFusion.Diagramming.DrawCellEventArgs Constructor

DrawCellEventArgs Constructor
[image]

Initializes a new instance of the DrawCellEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DrawCellEventArgs (
IGraphics graphics,
TableNode table,
int column,
int row,
RectangleF bounds
)

Visual Basic [image] Copy Code

Public Sub DrawCellEventArgs ( _
graphics As IGraphics, _
table As TableNode, _
column As Integer, _
row As Integer, _
bounds As RectangleF _
)

Parameters

graphics

The IGraphics object that represents the target of the drawing operation.

table

The TableNode related to the event.

column

The zero-based index of the table column related to the event.

row

The zero-based index of the table row related to the event.

bounds

The bounding rectangle of the cell being drawn.

See Also

DrawCellEventArgs Class


MindFusion.Diagramming.DrawCellEventArgs Properties

DrawCellEventArgs Properties
[image]

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the cell being drawn.
Cell | Gets the cell that should be custom drawn.
Column | Gets the index of the table's column that contains Cell.
Graphics | An object implementing the IGraphics interface whose methods should be used to draw the cell.
Row | Gets the index of the table's row that contains Cell.
Table | Get the table that contains Cell.

See Also

DrawCellEventArgs Class


MindFusion.Diagramming.DrawCellEventArgs.Bounds Property

DrawCellEventArgs.Bounds Property
[image]

Gets the bounding rectangle of the cell being drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As RectangleF

Property Value

A .NET RectangleF specifying the bounding rectangle of the cell.

See Also

DrawCellEventArgs Members
DrawCellEventArgs Class


MindFusion.Diagramming.DrawCellEventArgs.Cell Property

DrawCellEventArgs.Cell Property
[image]

Gets the cell that should be custom drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.Cell Cell { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Cell As TableNode.Cell

Property Value

An instance of the TableNode.Cell class.

See Also

DrawCellEventArgs Members
DrawCellEventArgs Class


MindFusion.Diagramming.DrawCellEventArgs.Column Property

DrawCellEventArgs.Column Property
[image]

Gets the index of the table's column that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Column { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Column As Integer

Property Value

An integer value specifying the zero-based index of the column.

See Also

DrawCellEventArgs Members
DrawCellEventArgs Class


MindFusion.Diagramming.DrawCellEventArgs.Graphics Property

DrawCellEventArgs.Graphics Property
[image]

An object implementing the IGraphics interface whose methods should be used to draw the cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IGraphics Graphics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Graphics As IGraphics

Property Value

An instance of a class implementing the IGraphics interface.

See Also

DrawCellEventArgs Members
DrawCellEventArgs Class


MindFusion.Diagramming.DrawCellEventArgs.Row Property

DrawCellEventArgs.Row Property
[image]

Gets the index of the table's row that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Row { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Row As Integer

Property Value

An integer value specifying the zero-based index of the row.

See Also

DrawCellEventArgs Members
DrawCellEventArgs Class


MindFusion.Diagramming.DrawCellEventArgs.Table Property

DrawCellEventArgs.Table Property
[image]

Get the table that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode Table { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Table As TableNode

Property Value

An instance of the TableNode class.

See Also

DrawCellEventArgs Members
DrawCellEventArgs Class


MindFusion.Diagramming.DrawItemEventArgs Class

DrawItemEventArgs Class
[image]

Contains the arguments passed to the DrawAdjustmentHandles event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DrawItemEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DrawItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.DrawItemEventArgs

See Also

DrawItemEventArgs Members


MindFusion.Diagramming.DrawItemEventArgs Members

DrawItemEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the DrawAdjustmentHandles event handlers.

The following tables list the members exposed by the DrawItemEventArgs type.

Public Constructors

Name | Description
DrawItemEventArgs | Initializes a new instance of the DrawItemEventArgs class.

Public Properties

Name | Description
Graphics | Gets an object implementing the IGraphics interface whose methods should be used to draw the adjustment handles.
Item | Gets the item whose selection handles are being drawn.

See Also

DrawItemEventArgs Class


MindFusion.Diagramming.DrawItemEventArgs Constructor

DrawItemEventArgs Constructor
[image]

Initializes a new instance of the DrawItemEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DrawItemEventArgs (
IGraphics graphics,
DiagramItem item
)

Visual Basic [image] Copy Code

Public Sub DrawItemEventArgs ( _
graphics As IGraphics, _
item As DiagramItem _
)

Parameters

graphics

The IGraphics object that represents the target of the drawing operation.

item

The DiagramItem related to the event.

See Also

DrawItemEventArgs Class


MindFusion.Diagramming.DrawItemEventArgs Properties

DrawItemEventArgs Properties
[image]

Public Properties

Name | Description
Graphics | Gets an object implementing the IGraphics interface whose methods should be used to draw the adjustment handles.
Item | Gets the item whose selection handles are being drawn.

See Also

DrawItemEventArgs Class


MindFusion.Diagramming.DrawItemEventArgs.Graphics Property

DrawItemEventArgs.Graphics Property
[image]

Gets an object implementing the IGraphics interface whose methods should be used to draw the adjustment handles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IGraphics Graphics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Graphics As IGraphics

Property Value

An instance of a class implementing the IGraphics interface.

See Also

DrawItemEventArgs Members
DrawItemEventArgs Class


MindFusion.Diagramming.DrawItemEventArgs.Item Property

DrawItemEventArgs.Item Property
[image]

Gets the item whose selection handles are being drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As DiagramItem

Property Value

An instance of the DiagramItem class.

See Also

DrawItemEventArgs Members
DrawItemEventArgs Class


MindFusion.Diagramming.DrawLinkEventArgs Class

DrawLinkEventArgs Class
[image]

Contains the arguments passed to the DrawLink event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DrawLinkEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DrawLinkEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.DrawLinkEventArgs

See Also

DrawLinkEventArgs Members


MindFusion.Diagramming.DrawLinkEventArgs Members

DrawLinkEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the DrawLink event handlers.

The following tables list the members exposed by the DrawLinkEventArgs type.

Public Constructors

Name | Description
DrawLinkEventArgs | Initializes a new instance of the DrawLinkEventArgs class.

Public Properties

Name | Description
Graphics | Gets an object implementing the IGraphics interface whose methods should be used to draw the link.
Link | Gets the DiagramLink object that should be custom drawn.
Points | Gets a collection of the link's control points.
Shadow | Gets a value indicating whether the event is raised to draw the link's shadow.

See Also

DrawLinkEventArgs Class


MindFusion.Diagramming.DrawLinkEventArgs Constructor

DrawLinkEventArgs Constructor
[image]

Initializes a new instance of the DrawLinkEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DrawLinkEventArgs (
IGraphics graphics,
DiagramLink link,
bool shadow,
PointCollection points
)

Visual Basic [image] Copy Code

Public Sub DrawLinkEventArgs ( _
graphics As IGraphics, _
link As DiagramLink, _
shadow As Boolean, _
points As PointCollection _
)

Parameters

graphics

The IGraphics object that represents the target of the drawing operation.

link

The DiagramLink related to the event.

shadow

Specifies whether to draw the link's shadow or the link itself.

points

The collection containing the coordinates of the link control points, pretranslated depending on whether drawing the shadow or not.

See Also

DrawLinkEventArgs Class


MindFusion.Diagramming.DrawLinkEventArgs Properties

DrawLinkEventArgs Properties
[image]

Public Properties

Name | Description
Graphics | Gets an object implementing the IGraphics interface whose methods should be used to draw the link.
Link | Gets the DiagramLink object that should be custom drawn.
Points | Gets a collection of the link's control points.
Shadow | Gets a value indicating whether the event is raised to draw the link's shadow.

See Also

DrawLinkEventArgs Class


MindFusion.Diagramming.DrawLinkEventArgs.Graphics Property

DrawLinkEventArgs.Graphics Property
[image]

Gets an object implementing the IGraphics interface whose methods should be used to draw the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IGraphics Graphics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Graphics As IGraphics

Property Value

An instance of a class implementing the IGraphics interface.

See Also

DrawLinkEventArgs Members
DrawLinkEventArgs Class


MindFusion.Diagramming.DrawLinkEventArgs.Link Property

DrawLinkEventArgs.Link Property
[image]

Gets the DiagramLink object that should be custom drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink Link { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Link As DiagramLink

Property Value

An instance of the DiagramLink class.

See Also

DrawLinkEventArgs Members
DrawLinkEventArgs Class


MindFusion.Diagramming.DrawLinkEventArgs.Points Property

DrawLinkEventArgs.Points Property
[image]

Gets a collection of the link's control points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointCollection Points { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Points As PointCollection

Property Value

An instance of the PointCollection class.

Remarks

When drawing shadows, the points are offset as necessary.

See Also

DrawLinkEventArgs Members
DrawLinkEventArgs Class


MindFusion.Diagramming.DrawLinkEventArgs.Shadow Property

DrawLinkEventArgs.Shadow Property
[image]

Gets a value indicating whether the event is raised to draw the link's shadow.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Shadow { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Shadow As Boolean

Property Value

true if now drawing the link's shadow; otherwise, false.

See Also

DrawLinkEventArgs Members
DrawLinkEventArgs Class


MindFusion.Diagramming.DrawNodeEventArgs Class

DrawNodeEventArgs Class
[image]

Contains the arguments passed to the DrawNode event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DrawNodeEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DrawNodeEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.DrawNodeEventArgs

See Also

DrawNodeEventArgs Members


MindFusion.Diagramming.DrawNodeEventArgs Members

DrawNodeEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the DrawNode event handlers.

The following tables list the members exposed by the DrawNodeEventArgs type.

Public Constructors

Name | Description
DrawNodeEventArgs | Initializes a new instance of the DrawNodeEventArgs class.

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the node being drawn.
Graphics | Gets an object implementing the IGraphics interface whose methods should be used to draw the node.
Node | Gets the DiagramNode object that should be custom drawn.
Shadow | Gets a value indicating whether the event is raised to draw the node's shadow.

See Also

DrawNodeEventArgs Class


MindFusion.Diagramming.DrawNodeEventArgs Constructor

DrawNodeEventArgs Constructor
[image]

Initializes a new instance of the DrawNodeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DrawNodeEventArgs (
IGraphics graphics,
DiagramNode node,
bool shadow,
RectangleF bounds
)

Visual Basic [image] Copy Code

Public Sub DrawNodeEventArgs ( _
graphics As IGraphics, _
node As DiagramNode, _
shadow As Boolean, _
bounds As RectangleF _
)

Parameters

graphics

The IGraphics object that represents the target of the drawing operation.

node

The DiagramNode related to the event.

shadow

Specifies whether to draw the node's shadow or the node itself.

bounds

The bounding rectangle of the node being drawn.

See Also

DrawNodeEventArgs Class


MindFusion.Diagramming.DrawNodeEventArgs Properties

DrawNodeEventArgs Properties
[image]

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the node being drawn.
Graphics | Gets an object implementing the IGraphics interface whose methods should be used to draw the node.
Node | Gets the DiagramNode object that should be custom drawn.
Shadow | Gets a value indicating whether the event is raised to draw the node's shadow.

See Also

DrawNodeEventArgs Class


MindFusion.Diagramming.DrawNodeEventArgs.Bounds Property

DrawNodeEventArgs.Bounds Property
[image]

Gets the bounding rectangle of the node being drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As RectangleF

Property Value

A .NET RectangleF instance specifying the bounding rectangle of the node being drawn.

Remarks

When drawing shadows, the rectangle is offset as necessary.

See Also

DrawNodeEventArgs Members
DrawNodeEventArgs Class


MindFusion.Diagramming.DrawNodeEventArgs.Graphics Property

DrawNodeEventArgs.Graphics Property
[image]

Gets an object implementing the IGraphics interface whose methods should be used to draw the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IGraphics Graphics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Graphics As IGraphics

Property Value

An instance of a class implementing the IGraphics interface.

See Also

DrawNodeEventArgs Members
DrawNodeEventArgs Class


MindFusion.Diagramming.DrawNodeEventArgs.Node Property

DrawNodeEventArgs.Node Property
[image]

Gets the DiagramNode object that should be custom drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Node { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Node As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

DrawNodeEventArgs Members
DrawNodeEventArgs Class


MindFusion.Diagramming.DrawNodeEventArgs.Shadow Property

DrawNodeEventArgs.Shadow Property
[image]

Gets a value indicating whether the event is raised to draw the node's shadow.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Shadow { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Shadow As Boolean

Property Value

true if now drawing the node's shadow; otherwise, false.

See Also

DrawNodeEventArgs Members
DrawNodeEventArgs Class


MindFusion.Diagramming.DummyNode Class

DummyNode Class
[image]

Represents virtual nodes used for disconnected links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DummyNode : DiagramNode

Visual Basic [image] Copy Code

Public Class DummyNode
Inherits DiagramNode

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.DummyNode

See Also

DummyNode Members


MindFusion.Diagramming.DummyNode Members

DummyNode Members
Constructors Fields Properties Methods
[image]

Represents virtual nodes used for disconnected links.

The following tables list the members exposed by the DummyNode type.

Public Constructors

Name | Description
DummyNode | Initializes a new instance of the DummyNode class.

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | Determines whether the node supports connections to its constituent elements. (Inherited from DiagramNode.)
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | DiagramItem.ContainsPoint override.
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
DoModify | For internal use. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override.
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override.
DrawLocal | Override in a derived class to provide implementation specific drawing for the node. (Inherited from DiagramNode.)
DrawShadow | DiagramItem.DrawShadow override.
DrawShadowLocal | Override in a derived class to provide implementation specific drawing for the shadow of the node. (Inherited from DiagramNode.)
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item. (Inherited from DiagramItem.)
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item. (Inherited from DiagramItem.)
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item. (Inherited from DiagramItem.)
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item. (Inherited from DiagramItem.)
GetIntersection | DiagramNode.GetIntersection override.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the smallest distance from the specified point.
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override.
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Intersects | Determines whether the node intersects another one, taking into account the outlines of node shapes. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetPos | Sets the bounding rectangle of this node without updating connected arrows. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
CancelModify | DiagramItem.CancelModify override. Invoked when the interactive modification of this object has been canceled. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Checks whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateProperties | DiagramItem.CreateProperties override. (Inherited from DiagramNode.)
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
Finalize | DiagramItem finalizer. (Inherited from DiagramItem.)
FreeResources | Called when the node is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from DiagramNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFrom | DiagramItem.LoadFrom override. (Inherited from DiagramNode.)
LoadFromXml | DiagramItem.LoadFromXml override. (Inherited from DiagramNode.)
LoadObsolete | For internal use. (Inherited from DiagramItem.)
OnAdd | DiagramItem.OnAdd override. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnClick | Invoked when the user clicks this item. (Inherited from DiagramItem.)
OnDoubleClick | Invoked when the user double-clicks this item. (Inherited from DiagramItem.)
OnMeasureUnitChanged | DiagramItem.OnMeasureUnitChanged override. (Inherited from DiagramNode.)
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | Overloaded. (Inherited from DiagramNode.)
OnZoomChanged | DiagramItem.OnZoomChanged override. (Inherited from DiagramNode.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override. (Inherited from DiagramNode.)
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramItem.SaveProperties override. (Inherited from DiagramNode.)
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveTo | Serializes the object to the specified writer. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramNode.)
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReference | Called during deserialization, after all objects have been instantiated, in order to update the references between them. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. Invoked when the user starts modifying this item interactively. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster. (Inherited from DiagramItem.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. Invoked during interactive modification of this item. (Inherited from DiagramNode.)

See Also

DummyNode Class


MindFusion.Diagramming.DummyNode Constructor

DummyNode Constructor
[image]

Initializes a new instance of the DummyNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DummyNode (
Diagram parent
)

Visual Basic [image] Copy Code

Public Sub DummyNode ( _
parent As Diagram _
)

Parameters

parent

The Diagram this node will be associated with.

See Also

DummyNode Class


MindFusion.Diagramming.DummyNode Methods

DummyNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | DiagramItem.ContainsPoint override.
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
DoModify | For internal use. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override.
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override.
DrawLocal | Override in a derived class to provide implementation specific drawing for the node. (Inherited from DiagramNode.)
DrawShadow | DiagramItem.DrawShadow override.
DrawShadowLocal | Override in a derived class to provide implementation specific drawing for the shadow of the node. (Inherited from DiagramNode.)
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item. (Inherited from DiagramItem.)
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item. (Inherited from DiagramItem.)
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item. (Inherited from DiagramItem.)
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item. (Inherited from DiagramItem.)
GetIntersection | DiagramNode.GetIntersection override.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the smallest distance from the specified point.
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override.
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Intersects | Determines whether the node intersects another one, taking into account the outlines of node shapes. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetPos | Sets the bounding rectangle of this node without updating connected arrows. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
CancelModify | DiagramItem.CancelModify override. Invoked when the interactive modification of this object has been canceled. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Checks whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateProperties | DiagramItem.CreateProperties override. (Inherited from DiagramNode.)
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
Finalize | DiagramItem finalizer. (Inherited from DiagramItem.)
FreeResources | Called when the node is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from DiagramNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFrom | DiagramItem.LoadFrom override. (Inherited from DiagramNode.)
LoadFromXml | DiagramItem.LoadFromXml override. (Inherited from DiagramNode.)
LoadObsolete | For internal use. (Inherited from DiagramItem.)
OnAdd | DiagramItem.OnAdd override. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnClick | Invoked when the user clicks this item. (Inherited from DiagramItem.)
OnDoubleClick | Invoked when the user double-clicks this item. (Inherited from DiagramItem.)
OnMeasureUnitChanged | DiagramItem.OnMeasureUnitChanged override. (Inherited from DiagramNode.)
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | Overloaded. (Inherited from DiagramNode.)
OnZoomChanged | DiagramItem.OnZoomChanged override. (Inherited from DiagramNode.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override. (Inherited from DiagramNode.)
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramItem.SaveProperties override. (Inherited from DiagramNode.)
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveTo | Serializes the object to the specified writer. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramNode.)
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReference | Called during deserialization, after all objects have been instantiated, in order to update the references between them. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. Invoked when the user starts modifying this item interactively. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster. (Inherited from DiagramItem.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. Invoked during interactive modification of this item. (Inherited from DiagramNode.)

See Also

DummyNode Class


MindFusion.Diagramming.DummyNode.ContainsPoint Method

DummyNode.ContainsPoint Method
[image]

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
PointF point
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
point As PointF _
) As Boolean

Parameters

point
The point to check.

Return Value

See Also

DummyNode Members
DummyNode Class


MindFusion.Diagramming.DummyNode.CreateConnectionPoint Method

DummyNode.CreateConnectionPoint Method
[image]

DiagramNode.CreateConnectionPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual ConnectionPoint CreateConnectionPoint (
DiagramLink link,
PointF pt,
bool incoming
)

Visual Basic [image] Copy Code

Protected Overridable Function CreateConnectionPoint ( _
link As DiagramLink, _
pt As PointF, _
incoming As Boolean _
) As ConnectionPoint

Parameters

link

pt

incoming

Return Value

See Also

DummyNode Members
DummyNode Class


MindFusion.Diagramming.DummyNode.Draw Method

DummyNode.Draw Method
[image]

DiagramItem.Draw override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Draw (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw ( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics
The IGraphics surface to draw the item on.
options
A RenderOptions object specifying options for the drawing operation.

See Also

DummyNode Members
DummyNode Class


MindFusion.Diagramming.DummyNode.DrawHandles Method

DummyNode.DrawHandles Method
[image]

DiagramItem.DrawHandles override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawHandles (
IGraphics graphics,
HandlesVisualStyle style,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawHandles( _
graphics As IGraphics, _
style As HandlesVisualStyle, _
options As RenderOptions _
)

Parameters

graphics

style

options

See Also

DummyNode Members
DummyNode Class


MindFusion.Diagramming.DummyNode.DrawShadow Method

DummyNode.DrawShadow Method
[image]

DiagramItem.DrawShadow override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawShadow (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawShadow ( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics
The IGraphics surface to draw the shadow on.
options
A RenderOptions object specifying options for the drawing operation.

See Also

DummyNode Members
DummyNode Class


MindFusion.Diagramming.DummyNode.GetIntersection Method

DummyNode.GetIntersection Method
[image]

DiagramNode.GetIntersection override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override PointF GetIntersection (
PointF segmentStart,
PointF segmentEnd
)

Visual Basic [image] Copy Code

Public Overrides Function GetIntersection( _
segmentStart As PointF, _
segmentEnd As PointF _
) As PointF

Parameters

segmentStart

segmentEnd

Return Value

See Also

DummyNode Members
DummyNode Class


MindFusion.Diagramming.DummyNode.GetNearestBorderPoint Method

DummyNode.GetNearestBorderPoint Method
[image]

Returns a point that lies on the outline of this node, at the smallest distance from the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override PointF GetNearestBorderPoint (
PointF point
)

Visual Basic [image] Copy Code

Public Overrides Function GetNearestBorderPoint( _
point As PointF _
) As PointF

Parameters

point

Return Value

See Also

DummyNode Members
DummyNode Class


MindFusion.Diagramming.DummyNode.HitTestHandle Method

DummyNode.HitTestHandle Method
[image]

DiagramItem.HitTestHandle override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override AdjustmentHandle HitTestHandle (
PointF point
)

Visual Basic [image] Copy Code

Public Overrides Function HitTestHandle( _
point As PointF _
) As AdjustmentHandle

Parameters

point

Return Value

See Also

DummyNode Members
DummyNode Class


MindFusion.Diagramming.EditCellTextEventArgs Class

EditCellTextEventArgs Class
[image]

Contains the arguments passed to the CellTextEdited event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class EditCellTextEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class EditCellTextEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.EditCellTextEventArgs

See Also

EditCellTextEventArgs Members


MindFusion.Diagramming.EditCellTextEventArgs Members

EditCellTextEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the CellTextEdited event handlers.

The following tables list the members exposed by the EditCellTextEventArgs type.

Public Constructors

Name | Description
EditCellTextEventArgs | Initializes a new instance of the EditCellTextEventArgs class.

Public Properties

Name | Description
Cell | Get the cell whose text has been edited.
Column | Gets the index of the table's column that contains Cell.
NewText | Gets the text that has just been entered by the user.
OldText | Gets the text that had been displayed in the cell before the user edited it.
Row | Gets the index of the table's row that contains Cell.
Table | Get the table that contains Cell.

See Also

EditCellTextEventArgs Class


MindFusion.Diagramming.EditCellTextEventArgs Constructor

EditCellTextEventArgs Constructor
[image]

Initializes a new instance of the EditCellTextEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public EditCellTextEventArgs (
TableNode.Cell cell,
string oldText,
string newText,
int column,
int row
)

Visual Basic [image] Copy Code

Public Sub EditCellTextEventArgs ( _
cell As TableNode.Cell, _
oldText As String, _
newText As String, _
column As Integer, _
row As Integer _
)

Parameters

cell

The TableNode.Cell related to the event.

oldText

The old text of the cell.

newText

The new text of the cell.

column

The zero-based index of the table column related to the event.

row

The zero-based index of the table row related to the event.

See Also

EditCellTextEventArgs Class


MindFusion.Diagramming.EditCellTextEventArgs Properties

EditCellTextEventArgs Properties
[image]

Public Properties

Name | Description
Cell | Get the cell whose text has been edited.
Column | Gets the index of the table's column that contains Cell.
NewText | Gets the text that has just been entered by the user.
OldText | Gets the text that had been displayed in the cell before the user edited it.
Row | Gets the index of the table's row that contains Cell.
Table | Get the table that contains Cell.

See Also

EditCellTextEventArgs Class


MindFusion.Diagramming.EditCellTextEventArgs.Cell Property

EditCellTextEventArgs.Cell Property
[image]

Get the cell whose text has been edited.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.Cell Cell { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Cell As TableNode.Cell

Property Value

An instance of the TableNode.Cell class.

See Also

EditCellTextEventArgs Members
EditCellTextEventArgs Class


MindFusion.Diagramming.EditCellTextEventArgs.Column Property

EditCellTextEventArgs.Column Property
[image]

Gets the index of the table's column that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Column { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Column As Integer

Property Value

An integer value specifying the zero-based index of the column.

See Also

EditCellTextEventArgs Members
EditCellTextEventArgs Class


MindFusion.Diagramming.EditCellTextEventArgs.NewText Property

EditCellTextEventArgs.NewText Property
[image]

Gets the text that has just been entered by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string NewText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewText As String

Property Value

A string specifying the new text of the cell.

See Also

EditCellTextEventArgs Members
EditCellTextEventArgs Class


MindFusion.Diagramming.EditCellTextEventArgs.OldText Property

EditCellTextEventArgs.OldText Property
[image]

Gets the text that had been displayed in the cell before the user edited it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string OldText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldText As String

Property Value

A string specifying the old text of the cell.

See Also

EditCellTextEventArgs Members
EditCellTextEventArgs Class


MindFusion.Diagramming.EditCellTextEventArgs.Row Property

EditCellTextEventArgs.Row Property
[image]

Gets the index of the table's row that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Row { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Row As Integer

Property Value

An integer value specifying the zero-based index of the row.

See Also

EditCellTextEventArgs Members
EditCellTextEventArgs Class


MindFusion.Diagramming.EditCellTextEventArgs.Table Property

EditCellTextEventArgs.Table Property
[image]

Get the table that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode Table { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Table As TableNode

Property Value

An instance of the TableNode class.

See Also

EditCellTextEventArgs Members
EditCellTextEventArgs Class


MindFusion.Diagramming.EditLinkTextEventArgs Class

EditLinkTextEventArgs Class
[image]

Contains the arguments passed to the EditLinkTextEventHandler event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class EditLinkTextEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class EditLinkTextEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.EditLinkTextEventArgs

See Also

EditLinkTextEventArgs Members


MindFusion.Diagramming.EditLinkTextEventArgs Members

EditLinkTextEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the EditLinkTextEventHandler event handlers.

The following tables list the members exposed by the EditLinkTextEventArgs type.

Public Constructors

Name | Description
EditLinkTextEventArgs | Initializes a new instance of the EditLinkTextEventArgs class.

Public Properties

Name | Description
Link | Gets the link whose text was edited.
NewText | Gets the new text.
OldText | Gets the text before in-place editing.

See Also

EditLinkTextEventArgs Class


MindFusion.Diagramming.EditLinkTextEventArgs Constructor

EditLinkTextEventArgs Constructor
[image]

Initializes a new instance of the EditLinkTextEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public EditLinkTextEventArgs (
DiagramLink link,
string oldText,
string newText
)

Visual Basic [image] Copy Code

Public Sub EditLinkTextEventArgs ( _
link As DiagramLink, _
oldText As String, _
newText As String _
)

Parameters

link
The link whose text is edited.
oldText
The old value of the link's Text.
newText
The new value of the link's Text.

See Also

EditLinkTextEventArgs Class


MindFusion.Diagramming.EditLinkTextEventArgs Properties

EditLinkTextEventArgs Properties
[image]

Public Properties

Name | Description
Link | Gets the link whose text was edited.
NewText | Gets the new text.
OldText | Gets the text before in-place editing.

See Also

EditLinkTextEventArgs Class


MindFusion.Diagramming.EditLinkTextEventArgs.Link Property

EditLinkTextEventArgs.Link Property
[image]

Gets the link whose text was edited.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink Link { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Link As DiagramLink

Property Value

See Also

EditLinkTextEventArgs Members
EditLinkTextEventArgs Class


MindFusion.Diagramming.EditLinkTextEventArgs.NewText Property

EditLinkTextEventArgs.NewText Property
[image]

Gets the new text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string NewText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewText As String

Property Value

The new value of the link's Text property.

See Also

EditLinkTextEventArgs Members
EditLinkTextEventArgs Class
OldText Property


MindFusion.Diagramming.EditLinkTextEventArgs.OldText Property

EditLinkTextEventArgs.OldText Property
[image]

Gets the text before in-place editing.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string OldText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldText As String

Property Value

The original value of the Text property of the edited link.

See Also

EditLinkTextEventArgs Members
EditLinkTextEventArgs Class
NewText Property


MindFusion.Diagramming.EditNodeTextEventArgs Class

EditNodeTextEventArgs Class
[image]

Contains the arguments passed to the NodeTextEdited event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class EditNodeTextEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class EditNodeTextEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.EditNodeTextEventArgs

See Also

EditNodeTextEventArgs Members


MindFusion.Diagramming.EditNodeTextEventArgs Members

EditNodeTextEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the NodeTextEdited event handlers.

The following tables list the members exposed by the EditNodeTextEventArgs type.

Public Constructors

Name | Description
EditNodeTextEventArgs | Initializes a new instance of the EditNodeTextEventArgs class.

Public Properties

Name | Description
NewText | Gets the text that has just been entered by the user.
Node | Gets the node whose text has been edited.
OldText | Gets the text that had been displayed in the node before the user edited it.

See Also

EditNodeTextEventArgs Class


MindFusion.Diagramming.EditNodeTextEventArgs Constructor

EditNodeTextEventArgs Constructor
[image]

Initializes a new instance of the EditNodeTextEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public EditNodeTextEventArgs (
DiagramNode node,
string oldText,
string newText
)

Visual Basic [image] Copy Code

Public Sub EditNodeTextEventArgs ( _
node As DiagramNode, _
oldText As String, _
newText As String _
)

Parameters

node

The DiagramNode related to the event.

oldText

The old text of the node.

newText

The new text of the node.

See Also

EditNodeTextEventArgs Class


MindFusion.Diagramming.EditNodeTextEventArgs Properties

EditNodeTextEventArgs Properties
[image]

Public Properties

Name | Description
NewText | Gets the text that has just been entered by the user.
Node | Gets the node whose text has been edited.
OldText | Gets the text that had been displayed in the node before the user edited it.

See Also

EditNodeTextEventArgs Class


MindFusion.Diagramming.EditNodeTextEventArgs.NewText Property

EditNodeTextEventArgs.NewText Property
[image]

Gets the text that has just been entered by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string NewText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewText As String

Property Value

A string specifying the new text of the node.

See Also

EditNodeTextEventArgs Members
EditNodeTextEventArgs Class


MindFusion.Diagramming.EditNodeTextEventArgs.Node Property

EditNodeTextEventArgs.Node Property
[image]

Gets the node whose text has been edited.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Node { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Node As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

EditNodeTextEventArgs Members
EditNodeTextEventArgs Class


MindFusion.Diagramming.EditNodeTextEventArgs.OldText Property

EditNodeTextEventArgs.OldText Property
[image]

Gets the text that had been displayed in the node before the user edited it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string OldText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldText As String

Property Value

A string specifying the old text of the node.

See Also

EditNodeTextEventArgs Members
EditNodeTextEventArgs Class


MindFusion.Diagramming.EffectsProvider Class

EffectsProvider Class
Remarks See Also
[image]

Provides smooth shadow and emboss effects for MvcDiagram nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.EffectsProvider

Syntax

C# [image] Copy Code

public sealed class EffectsProvider : IEffectsProvider

Visual Basic [image] Copy Code

Public NotInheritable Class EffectsProvider
Implements IEffectsProvider

Remarks

You can assign an instance of this class to the EffectsProvider property of the Diagram class.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.EffectsProvider

See Also

EffectsProvider Members


MindFusion.Diagramming.EffectsProvider Members

EffectsProvider Members
Constructors
[image]

Provides smooth shadow and emboss effects for MvcDiagram nodes.

The following tables list the members exposed by the EffectsProvider type.

Public Constructors

Name | Description
EffectsProvider | Initializes a new instance of the EffectsProvider class.

See Also

EffectsProvider Class


MindFusion.Diagramming.EffectsProvider Constructor

EffectsProvider Constructor
[image]

Initializes a new instance of the EffectsProvider class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.EffectsProvider

Syntax

C# [image] Copy Code

public EffectsProvider ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

EffectsProvider Class


MindFusion.Diagramming.ElementTemplate Class

ElementTemplate Class
[image]

Represents an element of a shape definition. This is the parent class of specific element types, such as ArcTemplate, LineTemplate and BezierTemplate.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class ElementTemplate : ICloneable, IPersists

Visual Basic [image] Copy Code

Public MustInherit Class ElementTemplate
Implements ICloneable, IPersists

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ElementTemplate
MindFusion.Diagramming.ArcTemplate
MindFusion.Diagramming.BezierTemplate
MindFusion.Diagramming.LineTemplate
MindFusion.Diagramming.RoundRectangleTemplate

See Also

ElementTemplate Members
DefaultShape


MindFusion.Diagramming.ElementTemplate Members

ElementTemplate Members
Constructors Properties Methods
[image]

Represents an element of a shape definition. This is the parent class of specific element types, such as ArcTemplate, LineTemplate and BezierTemplate.

The following tables list the members exposed by the ElementTemplate type.

Protected Constructors

Name | Description
ElementTemplate | Initializes a new instance of the ElementTemplate class.

Public Properties

Name | Description
Color | Gets or sets the outline color of this element.
DashStyle | Gets or sets the dash style of the outline of this element.
Width | Gets or sets the outline width of this element.

Public Methods

Name | Description
Clone | Creates an exact copy of this element.
SameAs | Checks whether the current element and the specified element resemble each other closely enough to be considered identical.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument.

See Also

ElementTemplate Class


MindFusion.Diagramming.ElementTemplate Constructor

ElementTemplate Constructor
[image]

Initializes a new instance of the ElementTemplate class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected ElementTemplate ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

ElementTemplate Class


MindFusion.Diagramming.ElementTemplate Methods

ElementTemplate Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this element.
SameAs | Checks whether the current element and the specified element resemble each other closely enough to be considered identical.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument.

See Also

ElementTemplate Class


MindFusion.Diagramming.ElementTemplate.Clone Method

ElementTemplate.Clone Method
[image]

Creates an exact copy of this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract Object Clone ()

Visual Basic [image] Copy Code

Public MustOverride Function Clone () As Object

Return Value

An instance of the appropriate type that represents the element clone.

See Also

ElementTemplate Members
ElementTemplate Class


MindFusion.Diagramming.ElementTemplate.GetElementPen Method

ElementTemplate.GetElementPen Method
[image]

Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Pen GetElementPen (
Pen pen
)

Visual Basic [image] Copy Code

Protected Function GetElementPen ( _
pen As Pen _
) As Pen

Parameters

pen

The Pen object specifying the base pen.

Return Value

See Also

ElementTemplate Members
ElementTemplate Class


MindFusion.Diagramming.ElementTemplate.SameAs Method

ElementTemplate.SameAs Method
[image]

Checks whether the current element and the specified element resemble each other closely enough to be considered identical.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract bool SameAs (
ElementTemplate obj
)

Visual Basic [image] Copy Code

Public MustOverride Function SameAs ( _
obj As ElementTemplate _
) As Boolean

Parameters

obj

The ElementTemplate to compare to this element.

Return Value

true if the specified object closely approximates this element; otherwise, false.

See Also

ElementTemplate Members
ElementTemplate Class


MindFusion.Diagramming.ElementTemplate Properties

ElementTemplate Properties
[image]

Public Properties

Name | Description
Color | Gets or sets the outline color of this element.
DashStyle | Gets or sets the dash style of the outline of this element.
Width | Gets or sets the outline width of this element.

See Also

ElementTemplate Class


MindFusion.Diagramming.ElementTemplate.Color Property

ElementTemplate.Color Property
[image]

Gets or sets the outline color of this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color Color { get; set; }

Visual Basic [image] Copy Code

Public Property Color As Color

Property Value

A .NET Color instance specifying the color of the outline.

See Also

ElementTemplate Members
ElementTemplate Class


MindFusion.Diagramming.ElementTemplate.DashStyle Property

ElementTemplate.DashStyle Property
[image]

Gets or sets the dash style of the outline of this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DashStyle DashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property DashStyle As DashStyle

Property Value

A member of the .NET DashStyle enumeration specifying the style of the outline.

See Also

ElementTemplate Members
ElementTemplate Class


MindFusion.Diagramming.ElementTemplate.Width Property

ElementTemplate.Width Property
[image]

Gets or sets the outline width of this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Single

Property Value

A float value specifying the width of the outline.

See Also

ElementTemplate Members
ElementTemplate Class


MindFusion.Diagramming.EmbossEffect Class

EmbossEffect Class
Remarks See Also
[image]

Represents an emboss effect.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class EmbossEffect : NodeEffect

Visual Basic [image] Copy Code

Public NotInheritable Class EmbossEffect
Inherits NodeEffect

Remarks

This effect can be applied to the nodes in a Diagram by adding an instance of this class to the NodeEffects collection. In addition, this effect will be active only when the Diagram.EffectsProvider property is set to an object implementing the GenerateEmboss method of the IEffectsProvider interface.

The following image illustrates the Emboss effect applied to a rectangular node:

Example

The following example demonstrates how to apply emboss effect to the nodes of an existing diagram.

C# [image] Copy Code

diagram.NodeEffects.Add(new EmbossEffect());

Visual Basic [image] Copy Code

diagram.NodeEffects.Add(New EmbossEffect())

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.NodeEffect
MindFusion.Diagramming.EmbossEffect

See Also

EmbossEffect Members


MindFusion.Diagramming.EmbossEffect Members

EmbossEffect Members
Constructors Methods Events
[image]

Represents an emboss effect.

The following tables list the members exposed by the EmbossEffect type.

Public Constructors

Name | Description
EmbossEffect | Initializes a new instance of the EmbossEffect class.

Public Methods

Name | Description
Clone | NodeEffect.Clone override.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation. (Inherited from NodeEffect.)

See Also

EmbossEffect Class


MindFusion.Diagramming.EmbossEffect Constructor

EmbossEffect Constructor
[image]

Initializes a new instance of the EmbossEffect class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public EmbossEffect ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

EmbossEffect Class


MindFusion.Diagramming.EmbossEffect Methods

EmbossEffect Methods
[image]

Public Methods

Name | Description
Clone | NodeEffect.Clone override.

See Also

EmbossEffect Class


MindFusion.Diagramming.EmbossEffect.Clone Method

EmbossEffect.Clone Method
[image]

NodeEffect.Clone override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

The copy of this effect.

See Also

EmbossEffect Members
EmbossEffect Class


MindFusion.Diagramming.EmbossEffect Events

EmbossEffect Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation. (Inherited from NodeEffect.)

See Also

EmbossEffect Class


MindFusion.Diagramming.ExpandButtonAction Enumeration

ExpandButtonAction Enumeration
[image]

Specifies what action is triggered by the [±] buttons that are displayed near expandable nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum ExpandButtonAction

Visual Basic [image] Copy Code

Public Enum ExpandButtonAction

Members

Member name | Description
ExpandTreeBranch | Expands or collapses the children of a node in a tree-like diagram and raises the TreeExpanded or TreeCollapsed event.
RaiseEvents | Raises the ExpandButtonClicked event.

Remarks

The members of this enumeration can be assigned to the ExpandButtonAction property of the Diagram class.

See Also


MindFusion.Diagramming.ExpandButtonPosition Enumeration

ExpandButtonPosition Enumeration
[image]

Defines values that specify possible locations for expand/collapse buttons.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum ExpandButtonPosition

Visual Basic [image] Copy Code

Public Enum ExpandButtonPosition

Members

Member name | Description
OuterRight | Place expand/collapse buttons at the right-hand side of their nodes.
OuterLowerRight | Place expand/collapse buttons at the lower-right corner of their nodes.
OuterUpperRight | Place expand/collapse buttons at the upper-right corner of their nodes.
OuterBottom | Place expand/collapse buttons at the bottom side of their nodes.
OuterLeft | Place expand/collapse buttons at the left-hand side of their nodes.
OuterLowerLeft | Place expand/collapse buttons at the lower-left corner of their nodes.
OuterUpperLeft | Place expand/collapse buttons at the upper-left corner of their nodes.
OuterTop | Place expand/collapse buttons at the top side of their nodes.

Remarks

Assign values from this enumeration to the ExpandButtonPosition property of the Diagram class.

See Also


MindFusion.Diagramming.Factory Class

Factory Class
[image]

Provides shortcut methods for creating and adding instances of the standard MvcDiagram item types. Call the class methods through the Factory property of the Diagram class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Factory

Visual Basic [image] Copy Code

Public Class Factory

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Factory

See Also

Factory Members


MindFusion.Diagramming.Factory Members

Factory Members
Constructors Methods
[image]

Provides shortcut methods for creating and adding instances of the standard MvcDiagram item types. Call the class methods through the Factory property of the Diagram class.

The following tables list the members exposed by the Factory type.

Public Constructors

Name | Description
Factory | Initializes a new instance of the Factory class over the specified Diagram.

Public Methods

Name | Description
CreateBarcodeNode | Overloaded.
CreateContainerNode | Overloaded. Creates a new ContainerNode instance and adds it to the Nodes collection of the underlying diagram.
CreateDiagramLink | Overloaded. Creates a new DiagramLink instance and adds it to the Links collection of the underlying diagram.
CreateGroup | Creates a new hierarchical Group with the specified main item.
CreateMapNode | Overloaded.
CreateShapeNode | Overloaded. Creates a new ShapeNode instance and adds it to the Nodes collection of the underlying diagram.
CreateSvgNode | Overloaded. Creates a new SvgNode instance.
CreateTableNode | Overloaded. Creates a new TableNode instance and adds it to the Nodes collection of the underlying diagram.
CreateTreeViewNode | Overloaded. Creates a new TreeViewNode instance.
CreateVisioNode | Overloaded. Creates a new VisioNode instance.

See Also

Factory Class


MindFusion.Diagramming.Factory Constructor

Factory Constructor
[image]

Initializes a new instance of the Factory class over the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Factory (
Diagram diagram
)

Visual Basic [image] Copy Code

Public Sub Factory ( _
diagram As Diagram _
)

Parameters

diagram

The Diagram object for which to create the new factory.

See Also

Factory Class


MindFusion.Diagramming.Factory Methods

Factory Methods
[image]

Public Methods

Name | Description
CreateBarcodeNode | Overloaded.
CreateContainerNode | Overloaded. Creates a new ContainerNode instance and adds it to the Nodes collection of the underlying diagram.
CreateDiagramLink | Overloaded. Creates a new DiagramLink instance and adds it to the Links collection of the underlying diagram.
CreateGroup | Creates a new hierarchical Group with the specified main item.
CreateMapNode | Overloaded.
CreateShapeNode | Overloaded. Creates a new ShapeNode instance and adds it to the Nodes collection of the underlying diagram.
CreateSvgNode | Overloaded. Creates a new SvgNode instance.
CreateTableNode | Overloaded. Creates a new TableNode instance and adds it to the Nodes collection of the underlying diagram.
CreateTreeViewNode | Overloaded. Creates a new TreeViewNode instance.
CreateVisioNode | Overloaded. Creates a new VisioNode instance.

See Also

Factory Class


MindFusion.Diagramming.Factory.CreateBarcodeNode Method

Factory.CreateBarcodeNode Method
[image]

Overload List

Name | Description
Factory.CreateBarcodeNode (PointF, SizeF) | Creates a new BarcodeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateBarcodeNode (PointF, SizeF, BarcodeFormat, String) | Creates a new BarcodeNode instance at the specified position with the specified size and shape, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateBarcodeNode (RectangleF) | Creates a new BarcodeNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.
Factory.CreateBarcodeNode (RectangleF, BarcodeFormat, String) | Creates a new BarcodeNode instance with the specified dimensions and shape, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateBarcodeNode (Single, Single, Single, Single) | Creates a new BarcodeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateBarcodeNode (Single, Single, Single, Single, BarcodeFormat, String) | Creates a new BarcodeNode instance at the specified position with the specified size and content, and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateBarcodeNode Method (PointF, SizeF)

Factory.CreateBarcodeNode Method (PointF, SizeF)
See Also
[image]

Creates a new BarcodeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public BarcodeNode CreateBarcodeNode (
PointF location,
SizeF size
)

Visual Basic [image] Copy Code

Public Function CreateBarcodeNode( _
location As PointF, _
size As SizeF _
) As BarcodeNode

Parameters

location

The position of the new node.

size

The size of the new node.

Return Value

The newly created BarcodeNode instance.

Remarks

The method creates a shape node at the position specified by location. The size of the node is set by size.

See Also

CreateBarcodeNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateBarcodeNode Method (PointF, SizeF, BarcodeFormat, String)

Factory.CreateBarcodeNode Method (PointF, SizeF, BarcodeFormat, String)
See Also
[image]

Creates a new BarcodeNode instance at the specified position with the specified size and shape, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public BarcodeNode CreateBarcodeNode (
PointF location,
SizeF size,
BarcodeFormat format,
string content
)

Visual Basic [image] Copy Code

Public Function CreateBarcodeNode( _
location As PointF, _
size As SizeF, _
format As BarcodeFormat, _
content As String _
) As BarcodeNode

Parameters

location

The position of the new node.

size

The size of the new node.

format

Specifies the barcode format.

content

Specifies the barcode content.

Return Value

The newly created BarcodeNode instance.

Remarks

The method creates a shape node at the position specified by location. The size of the node is set by size. The barcode content and format are specified via respective parameters.

See Also

CreateBarcodeNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateBarcodeNode Method (RectangleF)

Factory.CreateBarcodeNode Method (RectangleF)
See Also
[image]

Creates a new BarcodeNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public BarcodeNode CreateBarcodeNode (
RectangleF bounds
)

Visual Basic [image] Copy Code

Public Function CreateBarcodeNode( _
bounds As RectangleF _
) As BarcodeNode

Parameters

bounds

The bounding rectangle of the new node.

Return Value

The newly created BarcodeNode instance.

Remarks

The method creates a shape node with dimensions specified by bounds.

See Also

CreateBarcodeNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateBarcodeNode Method (RectangleF, BarcodeFormat, String)

Factory.CreateBarcodeNode Method (RectangleF, BarcodeFormat, String)
See Also
[image]

Creates a new BarcodeNode instance with the specified dimensions and shape, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public BarcodeNode CreateBarcodeNode (
RectangleF bounds,
BarcodeFormat format,
string content
)

Visual Basic [image] Copy Code

Public Function CreateBarcodeNode( _
bounds As RectangleF, _
format As BarcodeFormat, _
content As String _
) As BarcodeNode

Parameters

bounds

The bounding rectangle of the new node.

format

Specifies the barcode format.

content

Specifies the barcode content.

Return Value

The newly created BarcodeNode instance.

Remarks

The method creates a shape node with dimensions specified by bounds. The barcode content and format are specified via respective parameters.

See Also

CreateBarcodeNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateBarcodeNode Method (Single, Single, Single, Single)

Factory.CreateBarcodeNode Method (Single, Single, Single, Single)
See Also
[image]

Creates a new BarcodeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public BarcodeNode CreateBarcodeNode (
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Public Function CreateBarcodeNode( _
x As Single, _
y As Single, _
width As Single, _
height As Single _
) As BarcodeNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

Return Value

The newly created BarcodeNode instance.

Remarks

The method creates a shape node at the position specified by x and y. The size of the node is set by width and height.

See Also

CreateBarcodeNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateBarcodeNode Method (Single, Single, Single, Single, BarcodeFormat, String)

Factory.CreateBarcodeNode Method (Single, Single, Single, Single, BarcodeFormat, String)
See Also
[image]

Creates a new BarcodeNode instance at the specified position with the specified size and content, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public BarcodeNode CreateBarcodeNode (
float x,
float y,
float width,
float height,
BarcodeFormat format,
string content
)

Visual Basic [image] Copy Code

Public Function CreateBarcodeNode( _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
format As BarcodeFormat, _
content As String _
) As BarcodeNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

format

Specifies the barcode format.

content

Specifies the barcode content.

Return Value

The newly created BarcodeNode instance.

Remarks

The method creates a barcode node at the position specified by x and y. The size of the node is set by width and height. The barcode content and format are specified via respective parameters.

See Also

CreateBarcodeNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateContainerNode Method

Factory.CreateContainerNode Method
[image]

Creates a new ContainerNode instance and adds it to the Nodes collection of the underlying diagram.

Overload List

Name | Description
Factory.CreateContainerNode (PointF, SizeF) | Creates a new ContainerNode instance at the specified location with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateContainerNode (PointF, SizeF, Boolean) | Creates a new ContainerNode instance at the specified location with the specified size, optionally foldable, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateContainerNode (RectangleF) | Creates a new ContainerNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.
Factory.CreateContainerNode (RectangleF, Boolean) | Creates a new ContainerNode instance with the specified dimensions, optionally foldable, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateContainerNode (Single, Single, Single, Single) | Creates a new ContainerNode instance at the specified location with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateContainerNode (Single, Single, Single, Single, Boolean) | Creates a new ContainerNode instance at the specified location with the specified size, optionally foldable, and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateContainerNode Method (PointF, SizeF)

Factory.CreateContainerNode Method (PointF, SizeF)
See Also
[image]

Creates a new ContainerNode instance at the specified location with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode CreateContainerNode (
PointF location,
SizeF size
)

Visual Basic [image] Copy Code

Public Function CreateContainerNode ( _
location As PointF, _
size As SizeF _
) As ContainerNode

Parameters

location
The location of the ContainerNode object.
size
The size of the ContainerNode object.

Return Value

The newly created ContainerNode instance.

Remarks

The method creates a container node at the position specified by location. The size of the container is set by size. For further customization of the node, use the properties and methods of the ContainerNode class.

See Also

CreateContainerNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateContainerNode Method (PointF, SizeF, Boolean)

Factory.CreateContainerNode Method (PointF, SizeF, Boolean)
See Also
[image]

Creates a new ContainerNode instance at the specified location with the specified size, optionally foldable, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode CreateContainerNode (
PointF location,
SizeF size,
bool foldable
)

Visual Basic [image] Copy Code

Public Function CreateContainerNode ( _
location As PointF, _
size As SizeF, _
foldable As Boolean _
) As ContainerNode

Parameters

location
The location of the ContainerNode object.
size
The newly created ContainerNode instance.
foldable
true if the container can be folded; otherwise, false.

Return Value

The newly created ContainerNode instance.

Remarks

The method creates a container node at the position specified by location. The size of the container is set by size. The parameter foldable specifies whether the container node is initially foldable. For further customization of the node, use the properties and methods of the ContainerNode class.

See Also

CreateContainerNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateContainerNode Method (RectangleF)

Factory.CreateContainerNode Method (RectangleF)
See Also
[image]

Creates a new ContainerNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode CreateContainerNode (
RectangleF bounds
)

Visual Basic [image] Copy Code

Public Function CreateContainerNode ( _
bounds As RectangleF _
) As ContainerNode

Parameters

bounds

The initial bounding rectangle of the new node.

Return Value

The newly created ContainerNode instance.

Remarks

The method creates a container node with the position and size specified by bounds. For further customization of the node, use the properties and methods of the ContainerNode class.

See Also

CreateContainerNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateContainerNode Method (RectangleF, Boolean)

Factory.CreateContainerNode Method (RectangleF, Boolean)
See Also
[image]

Creates a new ContainerNode instance with the specified dimensions, optionally foldable, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode CreateContainerNode (
RectangleF bounds,
bool foldable
)

Visual Basic [image] Copy Code

Public Function CreateContainerNode ( _
bounds As RectangleF, _
foldable As Boolean _
) As ContainerNode

Parameters

bounds

The initial bounding rectangle of the new node.

foldable

true if the container can be folded; otherwise, false.

Return Value

The newly created ContainerNode instance.

Remarks

The method creates a container node with the position and size specified by bounds. The parameter foldable specifies whether the container node is initially foldable. For further customization of the node, use the properties and methods of the ContainerNode class.

See Also

CreateContainerNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateContainerNode Method (Single, Single, Single, Single)

Factory.CreateContainerNode Method (Single, Single, Single, Single)
See Also
[image]

Creates a new ContainerNode instance at the specified location with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode CreateContainerNode (
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Public Function CreateContainerNode ( _
x As Single, _
y As Single, _
width As Single, _
height As Single _
) As ContainerNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y
The y-coordinate of the upper-left corner of the new node.
width
The width of the new node.
height
The height of the new node.

Return Value

The newly created ContainerNode instance.

Remarks

The method creates a container node at the position specified by x and y. The size of the container is set by width and height. For further customization of the node, use the properties and methods of the ContainerNode class.

See Also

CreateContainerNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateContainerNode Method (Single, Single, Single, Single, Boolean)

Factory.CreateContainerNode Method (Single, Single, Single, Single, Boolean)
See Also
[image]

Creates a new ContainerNode instance at the specified location with the specified size, optionally foldable, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode CreateContainerNode (
float x,
float y,
float width,
float height,
bool foldable
)

Visual Basic [image] Copy Code

Public Function CreateContainerNode ( _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
foldable As Boolean _
) As ContainerNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

foldable

true if the container can be folded; otherwise, false.

Return Value

The newly created ContainerNode instance.

Remarks

The method creates a container node at the position specified by x and y. The size of the container is set by width and height. The parameter foldable specifies whether the container node is initially foldable. For further customization of the node, use the properties and methods of the ContainerNode class.

See Also

CreateContainerNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateDiagramLink Method

Factory.CreateDiagramLink Method
[image]

Creates a new DiagramLink instance and adds it to the Links collection of the underlying diagram.

Overload List

Name | Description
Factory.CreateDiagramLink (DiagramNode, DiagramNode) | Creates a new DiagramLink instance between the specified nodes and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (DiagramNode, PointF) | Creates a new DiagramLink instance between the specified node and the specified point, and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (DiagramNode, TableNode, Int32) | Creates a new DiagramLink instance between the specified nodes and the specified table, and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (PointF, DiagramNode) | Creates a new DiagramLink instance between the specified point and the specified node, and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (PointF, PointF) | Creates a new DiagramLink instance between the specified points and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (ShapeNode, Int32, ShapeNode, Int32) | Creates a new DiagramLink instance between the specified nodes and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (TableNode, Int32, DiagramNode) | Creates a new DiagramLink instance between the specified table and the specified node, and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (TableNode, Int32, TableNode, Int32) | Creates a new DiagramLink instance between the specified tables and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (TableNode, TableNode) | Creates a new DiagramLink instance between the specified tables and adds it to the Links collection of the underlying diagram.

See Also

Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateDiagramLink Method (DiagramNode, DiagramNode)

Factory.CreateDiagramLink Method (DiagramNode, DiagramNode)
See Also
[image]

Creates a new DiagramLink instance between the specified nodes and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
DiagramNode origin,
DiagramNode destination
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink ( _
origin As DiagramNode, _
destination As DiagramNode _
) As DiagramLink

Parameters

origin
The origin node.
destination
The destination node.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the nodes specified by origin and destination. For further customization of the link, use the properties and methods of the DiagramLink class.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateTableNode Method
CreateShapeNode Method
Diagram.Links Property


MindFusion.Diagramming.Factory.CreateDiagramLink Method (DiagramNode, PointF)

Factory.CreateDiagramLink Method (DiagramNode, PointF)
See Also
[image]

Creates a new DiagramLink instance between the specified node and the specified point, and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
DiagramNode origin,
PointF destination
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink ( _
origin As DiagramNode, _
destination As PointF _
) As DiagramLink

Parameters

origin
The origin node.
destination
The destination point.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the node specified by origin and the point specified by destination. For further customization of the link, use the properties and methods of the DiagramLink class.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateTableNode Method
Diagram.Links Property


MindFusion.Diagramming.Factory.CreateDiagramLink Method (DiagramNode, TableNode, Int32)

Factory.CreateDiagramLink Method (DiagramNode, TableNode, Int32)
See Also
[image]

Creates a new DiagramLink instance between the specified nodes and the specified table, and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
DiagramNode origin,
TableNode destination,
int destRow
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink ( _
origin As DiagramNode, _
destination As TableNode, _
destRow As Integer _
) As DiagramLink

Parameters

origin
The origin node.
destination

The destination node.

destRow
The zero-based index of the destination table row of the new link.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the node specified by origin and the table specified by destination. For further customization of the link, use the properties and methods of the DiagramLink class.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateTableNode Method
Diagram.Links Property


MindFusion.Diagramming.Factory.CreateDiagramLink Method (PointF, DiagramNode)

Factory.CreateDiagramLink Method (PointF, DiagramNode)
See Also
[image]

Creates a new DiagramLink instance between the specified point and the specified node, and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
PointF origin,
DiagramNode destination
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink ( _
origin As PointF, _
destination As DiagramNode _
) As DiagramLink

Parameters

origin
The origin point.
destination

The destination node.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the point specified by origin and the node specified by destination. For further customization of the link, use the properties and methods of the DiagramLink class.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateTableNode Method
Diagram.Links Property


MindFusion.Diagramming.Factory.CreateDiagramLink Method (PointF, PointF)

Factory.CreateDiagramLink Method (PointF, PointF)
See Also
[image]

Creates a new DiagramLink instance between the specified points and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
PointF origin,
PointF destination
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink ( _
origin As PointF, _
destination As PointF _
) As DiagramLink

Parameters

origin
The origin point.
destination
The destination point.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the points specified by origin and destination. For further customization of the link, use the properties and methods of the DiagramLink class.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateTableNode Method
Diagram.Links Property


MindFusion.Diagramming.Factory.CreateDiagramLink Method (ShapeNode, Int32, ShapeNode, Int32)

Factory.CreateDiagramLink Method (ShapeNode, Int32, ShapeNode, Int32)
See Also
[image]

Creates a new DiagramLink instance between the specified nodes and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
ShapeNode origin,
int originAnchor,
ShapeNode destination,
int destAnchor
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink ( _
origin As ShapeNode, _
originAnchor As Integer, _
destination As ShapeNode, _
destAnchor As Integer _
) As DiagramLink

Parameters

origin
The origin node.
originAnchor

The index of an anchor point within the origin node's AnchorPattern.

destination

The destination node.

destAnchor
The index of an anchor point within the destination node's AnchorPattern.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the shape nodes specified by origin and destination. For further customization of the link, use the properties and methods of the DiagramLink class.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateTableNode Method
Links Property


MindFusion.Diagramming.Factory.CreateDiagramLink Method (TableNode, Int32, DiagramNode)

Factory.CreateDiagramLink Method (TableNode, Int32, DiagramNode)
See Also
[image]

Creates a new DiagramLink instance between the specified table and the specified node, and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
TableNode origin,
int originRow,
DiagramNode destination
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink ( _
origin As TableNode, _
originRow As Integer, _
destination As DiagramNode _
) As DiagramLink

Parameters

origin
The origin node.
originRow

The zero-based index of the destination table row of the new link.

destination
The destination node.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the table specified by origin and the node specified by destination. For further customization of the link, use the properties and methods of the DiagramLink class.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateTableNode Method
Diagram.Links Property


MindFusion.Diagramming.Factory.CreateDiagramLink Method (TableNode, Int32, TableNode, Int32)

Factory.CreateDiagramLink Method (TableNode, Int32, TableNode, Int32)
See Also
[image]

Creates a new DiagramLink instance between the specified tables and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
TableNode origin,
int originRow,
TableNode destination,
int destRow
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink ( _
origin As TableNode, _
originRow As Integer, _
destination As TableNode, _
destRow As Integer _
) As DiagramLink

Parameters

origin
The origin node.
originRow

The zero-based index of the origin table row of the new link.

destination
The destination node.
destRow
The zero-based index of the destination table row of the new link.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the tables specified by origin and destination. For further customization of the link, use the properties and methods of the DiagramLink class.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateTableNode Method
Diagram.Links Property


MindFusion.Diagramming.Factory.CreateDiagramLink Method (TableNode, TableNode)

Factory.CreateDiagramLink Method (TableNode, TableNode)
See Also
[image]

Creates a new DiagramLink instance between the specified tables and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
TableNode origin,
TableNode destination
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink ( _
origin As TableNode, _
destination As TableNode _
) As DiagramLink

Parameters

origin
The origin node.
destination
The destination node.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the tables specified by origin and destination. For further customization of the link, use the properties and methods of the DiagramLink class.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateTableNode Method
Diagram.Links Property


MindFusion.Diagramming.Factory.CreateGroup Method

Factory.CreateGroup Method
[image]

Creates a new hierarchical Group with the specified main item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Group CreateGroup (
DiagramItem mainItem
)

Visual Basic [image] Copy Code

Public Function CreateGroup ( _
mainItem As DiagramItem _
) As Group

Parameters

mainItem
The DiagramItem around which the group would be built.

Return Value

The newly created Group instance if successfully created; otherwise null (Nothing in Visual Basic).

Remarks

Use this method to create an hierarchical group of items. Attach subordinated items by using the various Group members.

See Also

Factory Members
Factory Class
Diagram.GroupDestroyed Event


MindFusion.Diagramming.Factory.CreateMapNode Method

Factory.CreateMapNode Method
[image]

Overload List

Name | Description
Factory.CreateMapNode (PointF, SizeF) | Creates a new MapNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateMapNode (PointF, SizeF, MapContent) | Creates a new MapNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateMapNode (RectangleF) | Creates a new MapNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.
Factory.CreateMapNode (RectangleF, MapContent) | Creates a new MapNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.
Factory.CreateMapNode (Single, Single, Single, Single) | Creates a new MapNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateMapNode (Single, Single, Single, Single, MapContent) | Creates a new MapNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateMapNode Method (PointF, SizeF)

Factory.CreateMapNode Method (PointF, SizeF)
See Also
[image]

Creates a new MapNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MapNode CreateMapNode (
PointF location,
SizeF size
)

Visual Basic [image] Copy Code

Public Function CreateMapNode( _
location As PointF, _
size As SizeF _
) As MapNode

Parameters

location

The position of the new node.

size

The size of the new node.

Return Value

The newly created MapNode instance.

Remarks

The method creates a MapNode at the position specified by location. The size of the node is set by size.

See Also

CreateMapNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateMapNode Method (PointF, SizeF, MapContent)

Factory.CreateMapNode Method (PointF, SizeF, MapContent)
See Also
[image]

Creates a new MapNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MapNode CreateMapNode (
PointF location,
SizeF size,
MapContent content
)

Visual Basic [image] Copy Code

Public Function CreateMapNode( _
location As PointF, _
size As SizeF, _
content As MapContent _
) As MapNode

Parameters

location

The position of the new node.

size

The size of the new node.

content

The content of the new node.

Return Value

The newly created MapNode instance.

Remarks

The method creates a MapNode at the position specified by location. The size of the node is set by size.

See Also

CreateMapNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateMapNode Method (RectangleF)

Factory.CreateMapNode Method (RectangleF)
See Also
[image]

Creates a new MapNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MapNode CreateMapNode (
RectangleF bounds
)

Visual Basic [image] Copy Code

Public Function CreateMapNode( _
bounds As RectangleF _
) As MapNode

Parameters

bounds

The bounding rectangle of the new node.

Return Value

The newly created MapNode instance.

Remarks

The method creates a MapNode with dimensions specified by bounds.

See Also

CreateMapNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateMapNode Method (RectangleF, MapContent)

Factory.CreateMapNode Method (RectangleF, MapContent)
See Also
[image]

Creates a new MapNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MapNode CreateMapNode (
RectangleF bounds,
MapContent content
)

Visual Basic [image] Copy Code

Public Function CreateMapNode( _
bounds As RectangleF, _
content As MapContent _
) As MapNode

Parameters

bounds

The bounding rectangle of the new node.

content

The content of the new node.

Return Value

The newly created MapNode instance.

Remarks

The method creates a MapNode with dimensions specified by bounds.

See Also

CreateMapNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateMapNode Method (Single, Single, Single, Single)

Factory.CreateMapNode Method (Single, Single, Single, Single)
See Also
[image]

Creates a new MapNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MapNode CreateMapNode (
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Public Function CreateMapNode( _
x As Single, _
y As Single, _
width As Single, _
height As Single _
) As MapNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

Return Value

The newly created MapNode instance.

Remarks

The method creates a MapNode at the position specified by x and y. The size of the node is set by width and height.

See Also

CreateMapNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateMapNode Method (Single, Single, Single, Single, MapContent)

Factory.CreateMapNode Method (Single, Single, Single, Single, MapContent)
See Also
[image]

Creates a new MapNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MapNode CreateMapNode (
float x,
float y,
float width,
float height,
MapContent content
)

Visual Basic [image] Copy Code

Public Function CreateMapNode( _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
content As MapContent _
) As MapNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

content

The content of the new node.

Return Value

The newly created MapNode instance.

Remarks

The method creates a MapNode at the position specified by x and y. The size of the node is set by width and height.

See Also

CreateMapNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateShapeNode Method

Factory.CreateShapeNode Method
[image]

Creates a new ShapeNode instance and adds it to the Nodes collection of the underlying diagram.

Overload List

Name | Description
Factory.CreateShapeNode (PointF, SizeF) | Creates a new ShapeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateShapeNode (PointF, SizeF, Shape) | Creates a new ShapeNode instance at the specified position with the specified size and shape, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateShapeNode (RectangleF) | Creates a new ShapeNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.
Factory.CreateShapeNode (RectangleF, Shape) | Creates a new ShapeNode instance with the specified dimensions and shape, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateShapeNode (Single, Single, Single, Single) | Creates a new ShapeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateShapeNode (Single, Single, Single, Single, Shape) | Creates a new ShapeNode instance at the specified position with the specified size and shape, and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateShapeNode Method (PointF, SizeF)

Factory.CreateShapeNode Method (PointF, SizeF)
See Also
[image]

Creates a new ShapeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode CreateShapeNode (
PointF location,
SizeF size
)

Visual Basic [image] Copy Code

Public Function CreateShapeNode ( _
location As PointF, _
size As SizeF _
) As ShapeNode

Parameters

location

The position of the new node.

size

The size of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node at the position specified by location. The size of the node is set by size. For further customization of the node, use the properties and methods of the ShapeNode class.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateShapeNode Method (PointF, SizeF, Shape)

Factory.CreateShapeNode Method (PointF, SizeF, Shape)
See Also
[image]

Creates a new ShapeNode instance at the specified position with the specified size and shape, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode CreateShapeNode (
PointF location,
SizeF size,
Shape shape
)

Visual Basic [image] Copy Code

Public Function CreateShapeNode ( _
location As PointF, _
size As SizeF, _
shape As Shape _
) As ShapeNode

Parameters

location

The position of the new node.

size

The size of the new node.

shape

The shape of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node at the position specified by location. The size of the node is set by size. The shape of the new node is specified by shape. For further customization of the node, use the properties and methods of the ShapeNode class.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateShapeNode Method (RectangleF)

Factory.CreateShapeNode Method (RectangleF)
See Also
[image]

Creates a new ShapeNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode CreateShapeNode (
RectangleF bounds
)

Visual Basic [image] Copy Code

Public Function CreateShapeNode ( _
bounds As RectangleF _
) As ShapeNode

Parameters

bounds

The bounding rectangle of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node with dimensions specified by bounds. For further customization of the node, use the properties and methods of the ShapeNode class.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateShapeNode Method (RectangleF, Shape)

Factory.CreateShapeNode Method (RectangleF, Shape)
See Also
[image]

Creates a new ShapeNode instance with the specified dimensions and shape, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode CreateShapeNode (
RectangleF bounds,
Shape shape
)

Visual Basic [image] Copy Code

Public Function CreateShapeNode ( _
bounds As RectangleF, _
shape As Shape _
) As ShapeNode

Parameters

bounds

The bounding rectangle of the new node.

shape

The shape of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node with dimensions specified by bounds. The shape of the new node is specified by shape. For further customization of the node, use the properties and methods of the ShapeNode class.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateShapeNode Method (Single, Single, Single, Single)

Factory.CreateShapeNode Method (Single, Single, Single, Single)
See Also
[image]

Creates a new ShapeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode CreateShapeNode (
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Public Function CreateShapeNode ( _
x As Single, _
y As Single, _
width As Single, _
height As Single _
) As ShapeNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y
The y-coordinate of the upper-left corner of the new node.
width

The width of the new node.

height
The height of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node at the position specified by x and y. The size of the node is set by width and height. For further customization of the node, use the properties and methods of the ShapeNode class.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateShapeNode Method (Single, Single, Single, Single, Shape)

Factory.CreateShapeNode Method (Single, Single, Single, Single, Shape)
See Also
[image]

Creates a new ShapeNode instance at the specified position with the specified size and shape, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode CreateShapeNode (
float x,
float y,
float width,
float height,
Shape shape
)

Visual Basic [image] Copy Code

Public Function CreateShapeNode ( _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
shape As Shape _
) As ShapeNode

Parameters

x
The x-coordinate of the upper-left corner of the new node.
y
The y-coordinate of the upper-left corner of the new node.
width
The width of the new node.
height
The height of the new node.
shape

The shape of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node at the position specified by x and y. The size of the node is set by width and height. The shape of the new node is specified by shape. For further customization of the node, use the properties and methods of the ShapeNode class.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateSvgNode Method

Factory.CreateSvgNode Method
[image]

Creates a new SvgNode instance.

Overload List

Name | Description
Factory.CreateSvgNode (PointF, SizeF) | Creates a new SvgNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateSvgNode (PointF, SizeF, SvgContent) | Creates a new SvgNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateSvgNode (RectangleF) | Creates a new SvgNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.
Factory.CreateSvgNode (RectangleF, SvgContent) | Creates a new SvgNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.
Factory.CreateSvgNode (Single, Single, Single, Single) | Creates a new SvgNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateSvgNode (Single, Single, Single, Single, SvgContent) | Creates a new SvgNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateSvgNode Method (PointF, SizeF)

Factory.CreateSvgNode Method (PointF, SizeF)
See Also
[image]

Creates a new SvgNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SvgNode CreateSvgNode (
PointF location,
SizeF size
)

Visual Basic [image] Copy Code

Public Function CreateSvgNode ( _
location As PointF, _
size As SizeF _
) As SvgNode

Parameters

location

The position of the new node.

size

The size of the new node.

Return Value

The newly created SvgNode instance.

Remarks

The method creates an SVG node at the position specified by location. The size of the node is set by size.

See Also

CreateSvgNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateSvgNode Method (PointF, SizeF, SvgContent)

Factory.CreateSvgNode Method (PointF, SizeF, SvgContent)
See Also
[image]

Creates a new SvgNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SvgNode CreateSvgNode (
PointF location,
SizeF size,
SvgContent content
)

Visual Basic [image] Copy Code

Public Function CreateSvgNode ( _
location As PointF, _
size As SizeF, _
content As SvgContent _
) As SvgNode

Parameters

location

The position of the new node.

size

The size of the new node.

content

The content of the new node.

Return Value

The newly created SvgNode instance.

Remarks

The method creates an SVG node at the position specified by location. The size of the node is set by size.

Example

The following example illustrates how to create new SvgContent from an SVG file and how to create an SvgNode based on this content. The variable diagram references an existing Diagram object and fileName contains the name of the SVG file to load.

C# [image] Copy Code

SvgNode node = diagram.Factory.CreateSvgNode(0, 0, 20, 20);

SvgContent content = new SvgContent();
content.Parse(fileName);

node.Content = content;

Visual Basic [image] Copy Code

Dim node As SvgNode = diagram.Factory.CreateSvgNode(0, 0, 20, 20)

Dim content As New SvgContent()
content.Parse(fileName)

node.Content = content

See Also

CreateSvgNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateSvgNode Method (RectangleF)

Factory.CreateSvgNode Method (RectangleF)
See Also
[image]

Creates a new SvgNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SvgNode CreateSvgNode (
RectangleF bounds
)

Visual Basic [image] Copy Code

Public Function CreateSvgNode ( _
bounds As RectangleF _
) As SvgNode

Parameters

bounds

The bounding rectangle of the new node.

Return Value

The newly created SvgNode instance.

Remarks

The method creates an SVG node with dimensions specified by bounds.

See Also

CreateSvgNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateSvgNode Method (RectangleF, SvgContent)

Factory.CreateSvgNode Method (RectangleF, SvgContent)
See Also
[image]

Creates a new SvgNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SvgNode CreateSvgNode (
RectangleF bounds,
SvgContent content
)

Visual Basic [image] Copy Code

Public Function CreateSvgNode ( _
bounds As RectangleF, _
content As SvgContent _
) As SvgNode

Parameters

bounds

The bounding rectangle of the new node.

content

The content of the new node.

Return Value

The newly created SvgNode instance.

Remarks

The method creates an SVG node with dimensions specified by bounds.

See Also

CreateSvgNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateSvgNode Method (Single, Single, Single, Single)

Factory.CreateSvgNode Method (Single, Single, Single, Single)
See Also
[image]

Creates a new SvgNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SvgNode CreateSvgNode (
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Public Function CreateSvgNode ( _
x As Single, _
y As Single, _
width As Single, _
height As Single _
) As SvgNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

Return Value

The newly created SvgNode instance.

Remarks

The method creates an SVG node at the position specified by x and y. The size of the node is set by width and height.

See Also

CreateSvgNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateSvgNode Method (Single, Single, Single, Single, SvgContent)

Factory.CreateSvgNode Method (Single, Single, Single, Single, SvgContent)
See Also
[image]

Creates a new SvgNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SvgNode CreateSvgNode (
float x,
float y,
float width,
float height,
SvgContent content
)

Visual Basic [image] Copy Code

Public Function CreateSvgNode ( _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
content As SvgContent _
) As SvgNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

content

The content of the new node.

Return Value

The newly created SvgNode instance.

Remarks

The method creates an SVG node at the position specified by x and y. The size of the node is set by width and height.

See Also

CreateSvgNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateTableNode Method

Factory.CreateTableNode Method
[image]

Creates a new TableNode instance and adds it to the Nodes collection of the underlying diagram.

Overload List

Name | Description
Factory.CreateTableNode (PointF, SizeF) | Creates a new TableNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTableNode (PointF, SizeF, Int32, Int32) | Creates a new TableNode instance at the specified position with the specified size and with the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTableNode (RectangleF) | Creates a new TableNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTableNode (RectangleF, Int32, Int32) | Creates a new TableNode instance with the specified dimensions and with the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTableNode (Single, Single, Single, Single) | Creates a new TableNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTableNode (Single, Single, Single, Single, Int32, Int32) | Creates a new TableNode instance at the specified position with the specified size and the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateTableNode Method (PointF, SizeF)

Factory.CreateTableNode Method (PointF, SizeF)
See Also
[image]

Creates a new TableNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode CreateTableNode (
PointF location,
SizeF size
)

Visual Basic [image] Copy Code

Public Function CreateTableNode ( _
location As PointF, _
size As SizeF _
) As TableNode

Parameters

location

The position of the new table.

size

The size of the new table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node at the position specified by location. The size of the node is set by size. For further customization of the node, use the properties and methods of the TableNode class.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateDiagramLink Method
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateTableNode Method (PointF, SizeF, Int32, Int32)

Factory.CreateTableNode Method (PointF, SizeF, Int32, Int32)
See Also
[image]

Creates a new TableNode instance at the specified position with the specified size and with the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode CreateTableNode (
PointF location,
SizeF size,
int columns,
int rows
)

Visual Basic [image] Copy Code

Public Function CreateTableNode ( _
location As PointF, _
size As SizeF, _
columns As Integer, _
rows As Integer _
) As TableNode

Parameters

location

The position of the new table.

size

The size of the new table.

columns

The initial number of columns in the table.

rows

The initial number of rows in the table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node at the position specified by location. The size of the node is set by size. The initial number of columns and rows in the table is specified by columns and rows respectively. For further customization of the node, use the properties and methods of the TableNode class.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateDiagramLink Method
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateTableNode Method (RectangleF)

Factory.CreateTableNode Method (RectangleF)
See Also
[image]

Creates a new TableNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode CreateTableNode (
RectangleF bounds
)

Visual Basic [image] Copy Code

Public Function CreateTableNode ( _
bounds As RectangleF _
) As TableNode

Parameters

bounds

The bounding rectangle of the new table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node with dimensions specified by bounds. For further customization of the node, use the properties and methods of the TableNode class.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateDiagramLink Method
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateTableNode Method (RectangleF, Int32, Int32)

Factory.CreateTableNode Method (RectangleF, Int32, Int32)
See Also
[image]

Creates a new TableNode instance with the specified dimensions and with the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode CreateTableNode (
RectangleF bounds,
int columns,
int rows
)

Visual Basic [image] Copy Code

Public Function CreateTableNode ( _
bounds As RectangleF, _
columns As Integer, _
rows As Integer _
) As TableNode

Parameters

bounds

The bounding rectangle of the new table.

columns

The initial number of columns in the table.

rows

The initial number of rows in the table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node with dimensions specified by bounds. The initial number of columns and rows in the table is specified by columns and rows respectively. For further customization of the node, use the properties and methods of the TableNode class.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateDiagramLink Method
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateTableNode Method (Single, Single, Single, Single)

Factory.CreateTableNode Method (Single, Single, Single, Single)
See Also
[image]

Creates a new TableNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode CreateTableNode (
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Public Function CreateTableNode ( _
x As Single, _
y As Single, _
width As Single, _
height As Single _
) As TableNode

Parameters

x

The x-coordinate of the upper-left corner of the new table.

y

The y-coordinate of the upper-left corner of the new table.

width

The width of the new table.

height

The height of the new table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node at the position specified by x and y. The size of the node is set by width and height. For further customization of the node, use the properties and methods of the TableNode class.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateDiagramLink Method
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateTableNode Method (Single, Single, Single, Single, Int32, Int32)

Factory.CreateTableNode Method (Single, Single, Single, Single, Int32, Int32)
See Also
[image]

Creates a new TableNode instance at the specified position with the specified size and the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode CreateTableNode (
float x,
float y,
float width,
float height,
int columns,
int rows
)

Visual Basic [image] Copy Code

Public Function CreateTableNode ( _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
columns As Integer, _
rows As Integer _
) As TableNode

Parameters

x

The x-coordinate of the upper-left corner of the new table.

y

The y-coordinate of the upper-left corner of the new table.

width
The width if the new table.
height

The height of the new table.

columns

The initial number of columns in the table.

rows

The initial number of rows in the table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node at the position specified by x and y. The size of the node is set by width and height. The initial number of columns and rows in the table is specified by columns and rows respectively. For further customization of the node, use the properties and methods of the TableNode class.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateDiagramLink Method
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateTreeViewNode Method

Factory.CreateTreeViewNode Method
[image]

Creates a new TreeViewNode instance.

Overload List

Name | Description
Factory.CreateTreeViewNode (PointF, SizeF) | Creates a new TreeViewNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTreeViewNode (RectangleF) | Creates a new TreeViewNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTreeViewNode (Single, Single, Single, Single) | Creates a new TreeViewNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateTreeViewNode Method (PointF, SizeF)

Factory.CreateTreeViewNode Method (PointF, SizeF)
See Also
[image]

Creates a new TreeViewNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewNode CreateTreeViewNode (
PointF location,
SizeF size
)

Visual Basic [image] Copy Code

Public Function CreateTreeViewNode ( _
location As PointF, _
size As SizeF _
) As TreeViewNode

Parameters

location

The position of the new node.

size

The size of the new node.

Return Value

The newly created TreeViewNode instance.

Remarks

The method creates a treeview node at the position specified by location. The size of the node is set by size.

See Also

CreateTreeViewNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateTreeViewNode Method (RectangleF)

Factory.CreateTreeViewNode Method (RectangleF)
See Also
[image]

Creates a new TreeViewNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewNode CreateTreeViewNode (
RectangleF bounds
)

Visual Basic [image] Copy Code

Public Function CreateTreeViewNode ( _
bounds As RectangleF _
) As TreeViewNode

Parameters

bounds

The bounding rectangle of the new node.

Return Value

The newly created TreeViewNode instance.

Remarks

The method creates a treeview node with dimensions specified by bounds.

See Also

CreateTreeViewNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateTreeViewNode Method (Single, Single, Single, Single)

Factory.CreateTreeViewNode Method (Single, Single, Single, Single)
See Also
[image]

Creates a new TreeViewNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewNode CreateTreeViewNode (
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Public Function CreateTreeViewNode ( _
x As Single, _
y As Single, _
width As Single, _
height As Single _
) As TreeViewNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

Return Value

The newly created TreeViewNode instance.

Remarks

The method creates a treeview node at the position specified by x and y. The size of the node is set by width and height.

See Also

CreateTreeViewNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateVisioNode Method

Factory.CreateVisioNode Method
[image]

Creates a new VisioNode instance.

Overload List

Name | Description
Factory.CreateVisioNode (PointF, SizeF) | Creates a new VisioNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateVisioNode (PointF, SizeF, VisioContent) | Creates a new VisioNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateVisioNode (RectangleF) | Creates a new VisioNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.
Factory.CreateVisioNode (RectangleF, VisioContent) | Creates a new VisioNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.
Factory.CreateVisioNode (Single, Single, Single, Single) | Creates a new VisioNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateVisioNode (Single, Single, Single, Single, VisioContent) | Creates a new VisioNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateVisioNode Method (PointF, SizeF)

Factory.CreateVisioNode Method (PointF, SizeF)
See Also
[image]

Creates a new VisioNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public VisioNode CreateVisioNode (
PointF location,
SizeF size
)

Visual Basic [image] Copy Code

Public Function CreateVisioNode( _
location As PointF, _
size As SizeF _
) As VisioNode

Parameters

location

The position of the new node.

size

The size of the new node.

Return Value

The newly created VisioNode instance.

Remarks

The method creates a Visio node at the position specified by location. The size of the node is set by size.

See Also

CreateVisioNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateVisioNode Method (PointF, SizeF, VisioContent)

Factory.CreateVisioNode Method (PointF, SizeF, VisioContent)
See Also
[image]

Creates a new VisioNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public VisioNode CreateVisioNode (
PointF location,
SizeF size,
VisioContent content
)

Visual Basic [image] Copy Code

Public Function CreateVisioNode( _
location As PointF, _
size As SizeF, _
content As VisioContent _
) As VisioNode

Parameters

location

The position of the new node.

size

The size of the new node.

content

The content of the new node.

Return Value

The newly created VisioNode instance.

Remarks

The method creates a Visio node at the position specified by location. The size of the node is set by size.

See Also

CreateVisioNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateVisioNode Method (RectangleF)

Factory.CreateVisioNode Method (RectangleF)
See Also
[image]

Creates a new VisioNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public VisioNode CreateVisioNode (
RectangleF bounds
)

Visual Basic [image] Copy Code

Public Function CreateVisioNode( _
bounds As RectangleF _
) As VisioNode

Parameters

bounds

The bounding rectangle of the new node.

Return Value

The newly created VisioNode instance.

Remarks

The method creates a VisioNode with dimensions specified by bounds.

See Also

CreateVisioNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateVisioNode Method (RectangleF, VisioContent)

Factory.CreateVisioNode Method (RectangleF, VisioContent)
See Also
[image]

Creates a new VisioNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public VisioNode CreateVisioNode (
RectangleF bounds,
VisioContent content
)

Visual Basic [image] Copy Code

Public Function CreateVisioNode( _
bounds As RectangleF, _
content As VisioContent _
) As VisioNode

Parameters

bounds

The bounding rectangle of the new node.

content

The content of the new node.

Return Value

The newly created VisioNode instance.

Remarks

The method creates a VisioNode with dimensions specified by bounds.

See Also

CreateVisioNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateVisioNode Method (Single, Single, Single, Single)

Factory.CreateVisioNode Method (Single, Single, Single, Single)
See Also
[image]

Creates a new VisioNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public VisioNode CreateVisioNode (
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Public Function CreateVisioNode( _
x As Single, _
y As Single, _
width As Single, _
height As Single _
) As VisioNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

Return Value

The newly created VisioNode instance.

Remarks

The method creates a Visio node at the position specified by x and y. The size of the node is set by width and height.

See Also

CreateVisioNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateVisioNode Method (Single, Single, Single, Single, VisioContent)

Factory.CreateVisioNode Method (Single, Single, Single, Single, VisioContent)
See Also
[image]

Creates a new VisioNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public VisioNode CreateVisioNode (
float x,
float y,
float width,
float height,
VisioContent content
)

Visual Basic [image] Copy Code

Public Function CreateVisioNode( _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
content As VisioContent _
) As VisioNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

content

The content of the new node.

Return Value

The newly created VisioNode instance.

Remarks

The method creates a Visio node at the position specified by x and y. The size of the node is set by width and height.

See Also

CreateVisioNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.FitSize Enumeration

FitSize Enumeration
[image]

Specifies how the ResizeToFitText method should resize a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum FitSize

Visual Basic [image] Copy Code

Public Enum FitSize

Members

Member name | Description
KeepWidth | Specifies that the original node width should remain intact.
KeepHeight | Specifies that the original node height should remain intact.
KeepRatio | Allows changing both the width and height of a node, but keep the original width/height ratio if possible.

See Also


MindFusion.Diagramming.GlassEffect Class

GlassEffect Class
Remarks See Also
[image]

Represents a glass-like visual effect.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class GlassEffect : NodeEffect

Visual Basic [image] Copy Code

Public NotInheritable Class GlassEffect
Inherits NodeEffect

Remarks

This effect can be applied to the nodes in a Diagram by adding an instance of this class to the NodeEffects collection.

The following image illustrates the Glass effect applied to an item as well as how the different properties affect the output:

Example

The following example demonstrates how to apply glass effect to the nodes of an existing diagram.

C# [image] Copy Code

diagram.NodeEffects.Add(new GlassEffect());

Visual Basic [image] Copy Code

diagram.NodeEffects.Add(New GlassEffect())

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.NodeEffect
MindFusion.Diagramming.GlassEffect

See Also

GlassEffect Members


MindFusion.Diagramming.GlassEffect Members

GlassEffect Members
Constructors Properties Methods Events
[image]

Represents a glass-like visual effect.

The following tables list the members exposed by the GlassEffect type.

Public Constructors

Name | Description
GlassEffect | Initializes a new instance of the GlassEffect class.

Public Properties

Name | Description
GlowColor | Gets or sets the color of the glow portion of the effect.
ReflectionColor | Gets or sets the color of the reflection portion of the effect.
Type | Gets or sets the type of the glass effect.
UsePenAsGlow | Gets or sets a value indicating whether the glow portion of the effect should be painted with the Pen color of the respective node.

Public Methods

Name | Description
Clone | NodeEffect.Clone override.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation. (Inherited from NodeEffect.)

See Also

GlassEffect Class


MindFusion.Diagramming.GlassEffect Constructor

GlassEffect Constructor
[image]

Initializes a new instance of the GlassEffect class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GlassEffect ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

GlassEffect Class


MindFusion.Diagramming.GlassEffect Methods

GlassEffect Methods
[image]

Public Methods

Name | Description
Clone | NodeEffect.Clone override.

See Also

GlassEffect Class


MindFusion.Diagramming.GlassEffect.Clone Method

GlassEffect.Clone Method
[image]

NodeEffect.Clone override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

The copy of this effect.

See Also

GlassEffect Members
GlassEffect Class


MindFusion.Diagramming.GlassEffect Properties

GlassEffect Properties
[image]

Public Properties

Name | Description
GlowColor | Gets or sets the color of the glow portion of the effect.
ReflectionColor | Gets or sets the color of the reflection portion of the effect.
Type | Gets or sets the type of the glass effect.
UsePenAsGlow | Gets or sets a value indicating whether the glow portion of the effect should be painted with the Pen color of the respective node.

See Also

GlassEffect Class


MindFusion.Diagramming.GlassEffect.GlowColor Property

GlassEffect.GlowColor Property
[image]

Gets or sets the color of the glow portion of the effect.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color GlowColor { get; set; }

Visual Basic [image] Copy Code

Public Property GlowColor As Color

Property Value

A .NET Color object. The default is White.

Remarks

The recommended value for this property is Black (or other dark color) for Type4 glass effects.

See Also

GlassEffect Members
GlassEffect Class


MindFusion.Diagramming.GlassEffect.ReflectionColor Property

GlassEffect.ReflectionColor Property
[image]

Gets or sets the color of the reflection portion of the effect.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color ReflectionColor { get; set; }

Visual Basic [image] Copy Code

Public Property ReflectionColor As Color

Property Value

A .NET Color object. The default is White.

See Also

GlassEffect Members
GlassEffect Class


MindFusion.Diagramming.GlassEffect.Type Property

GlassEffect.Type Property
[image]

Gets or sets the type of the glass effect.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GlassEffectType Type { get; set; }

Visual Basic [image] Copy Code

Public Property Type As GlassEffectType

Property Value

A member of the GlassEffectType enumeration. The default is Type1.

See Also

GlassEffect Members
GlassEffect Class


MindFusion.Diagramming.GlassEffect.UsePenAsGlow Property

GlassEffect.UsePenAsGlow Property
[image]

Gets or sets a value indicating whether the glow portion of the effect should be painted with the Pen color of the respective node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool UsePenAsGlow { get; set; }

Visual Basic [image] Copy Code

Public Property UsePenAsGlow As Boolean

Property Value

true to ignore GlowColor and use the color of the pen for the effect glow; otherwise, false.

See Also

GlassEffect Members
GlassEffect Class


MindFusion.Diagramming.GlassEffect Events

GlassEffect Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation. (Inherited from NodeEffect.)

See Also

GlassEffect Class


MindFusion.Diagramming.GlassEffectType Enumeration

GlassEffectType Enumeration
[image]

Specifies the type of a GlassEffect node effect.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum GlassEffectType

Visual Basic [image] Copy Code

Public Enum GlassEffectType

Members

Member name | Description
Type1 | Indicates a glass effect with soft radial glow at the bottom and a sharp reflection at the top.
Type2 | Indicates a glass effect with linear glow at the bottom and sharp reflection at the top.
Type3 | Indicates a glass effect with radial glow at the bottom and smooth reflection and emphasized outline at the top.
Type4 | Indicates a glass effect with sharp reflection at the top and soft glow at the left and right sides.

See Also


MindFusion.Diagramming.Granularity Enumeration

Granularity Enumeration
[image]

Specifies the granularity of the obstacles map generated by QuickRouter.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum Granularity

Visual Basic [image] Copy Code

Public Enum Granularity

Members

Member name | Description
CoarseGrained | Merge map tiles if possible to create a coarse-grained map. The fewer tiles in the map lead to faster path-finding.
Normal | Use the map tiles found by the initial division algorithm.
FineGrained | Reserved for future use.

Remarks

Members of this enumeration can be assigned to the Granularity property of QuickRouter.

See Also


MindFusion.Diagramming.GridRouter Class

GridRouter Class
Remarks See Also
[image]

Implements a link routing algorithm that uses a grid to represent the free and occupied regions in the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class GridRouter : ILinkRouter

Visual Basic [image] Copy Code

Public Class GridRouter
Implements ILinkRouter

Remarks

To use this class for link routing simply assign its instance to the LinkRouter property of the Diagram class.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.GridRouter

See Also

GridRouter Members


MindFusion.Diagramming.GridRouter Members

GridRouter Members
Constructors Properties Methods
[image]

Implements a link routing algorithm that uses a grid to represent the free and occupied regions in the diagram.

The following tables list the members exposed by the GridRouter type.

Public Constructors

Name | Description
GridRouter | Initializes a new instance of the GridRouter class.

Public Properties

Name | Description
Diagram | Gets or sets the diagram this router is associated with.

Public Methods

Name | Description
Resume | Implements ILinkRouter.Resume.
RouteLink | Implements ILinkRouter.RouteLink.
RouteLinks | Implements ILinkRouter.RouteLinks.
Suspend | Implements ILinkRouter.Suspend.

See Also

GridRouter Class


MindFusion.Diagramming.GridRouter Constructor

GridRouter Constructor
[image]

Initializes a new instance of the GridRouter class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GridRouter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

GridRouter Class


MindFusion.Diagramming.GridRouter Methods

GridRouter Methods
[image]

Public Methods

Name | Description
Resume | Implements ILinkRouter.Resume.
RouteLink | Implements ILinkRouter.RouteLink.
RouteLinks | Implements ILinkRouter.RouteLinks.
Suspend | Implements ILinkRouter.Suspend.

See Also

GridRouter Class


MindFusion.Diagramming.GridRouter.Resume Method

GridRouter.Resume Method
[image]

Implements ILinkRouter.Resume.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Resume (
bool routeDeferredLinks
)

Visual Basic [image] Copy Code

Public Sub Resume( _
routeDeferredLinks As Boolean _
)

Parameters

routeDeferredLinks
true if the links should be routed, otherwise false.

See Also

GridRouter Members
GridRouter Class


MindFusion.Diagramming.GridRouter.RouteLink Method

GridRouter.RouteLink Method
[image]

Implements ILinkRouter.RouteLink.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool RouteLink (
DiagramLink link
)

Visual Basic [image] Copy Code

Public Overridable Function RouteLink ( _
link As DiagramLink _
) As Boolean

Parameters

link
The DiagramLink to route.

Return Value

true if a path has been found successfully, otherwise false.

See Also

GridRouter Members
GridRouter Class


MindFusion.Diagramming.GridRouter.RouteLinks Method

GridRouter.RouteLinks Method
[image]

Implements ILinkRouter.RouteLinks.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void RouteLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Public Overridable Sub RouteLinks ( _
links As DiagramLinkCollection _
)

Parameters

links
A list of DiagramLink objects that should be routed.

See Also

GridRouter Members
GridRouter Class


MindFusion.Diagramming.GridRouter.Suspend Method

GridRouter.Suspend Method
[image]

Implements ILinkRouter.Suspend.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Suspend ()

Visual Basic [image] Copy Code

Public Sub Suspend ()

See Also

GridRouter Members
GridRouter Class


MindFusion.Diagramming.GridRouter Properties

GridRouter Properties
[image]

Public Properties

Name | Description
Diagram | Gets or sets the diagram this router is associated with.

See Also

GridRouter Class


MindFusion.Diagramming.GridRouter.Diagram Property

GridRouter.Diagram Property
[image]

Gets or sets the diagram this router is associated with.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Diagram Diagram { get; set; }

Visual Basic [image] Copy Code

Public Property Diagram As Diagram

Property Value

See Also

GridRouter Members
GridRouter Class


MindFusion.Diagramming.GridStyle Enumeration

GridStyle Enumeration
[image]

Defines values that specify the visual style of the alignment grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum GridStyle

Visual Basic [image] Copy Code

Public Enum GridStyle

Members

Member name | Description
Points | The grid is painted as a matrix of points.
Lines | The grid is represented as a series of crossing horizontal and vertical lines.

See Also

GridStyle Property


MindFusion.Diagramming.Group Class

Group Class
Remarks See Also
[image]

Represents a group of items in the diagram document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Group : IPersists

Visual Basic [image] Copy Code

Public Class Group
Implements IPersists

Remarks

An hierarchy of items can be built, so that moving an item that is higher in the hierarchy moves all subordinated items too. The immediate subordinates of an item are represented by a Group instance. Every group should have a single master item, to which all group members are attached. The master item can be accessed from the MainItem property. The group of items attached to an item is accessed through the SubordinateGroup property of the latter. MasterGroup gets the group in which an item is subordinate.

To create a group, instantiate a Group object and add it to the diagram's Groups collection, or call the CreateGroup method passing the master item as argument. A group is automatically destroyed when its master item is deleted.

To destroy a group programmatically, call the Remove method of the Groups collection. If AutoDeleteItems is enabled, subordinated items in the group are deleted too. If AutoDeleteItems is disabled, subordinated items are just detached from their master and remain intact.

Nodes can be attached to a group in several ways, depending on the type of the master item. If the master is a node, other nodes can be attached by calling the AttachProportional or AttachToCorner methods. If the master is a link, nodes can be attached to it using the AttachToLinkSegment or AttachToLinkPoint methods. The DiagramNode class provides a shortcut AttachTo method, which creates a group if necessary and calls the group's appropriate AttachTo* method. Items can be detached from a group by calling the Detach method.

The Expandable property specifies whether expanding or collapsing a tree should propagate from the master node through the subordinated nodes. FollowMasterRotation can be used when the master node is a shape node. If it is enabled, the positions of the subordinated nodes are updated to reflect the RotationAngle of the shape node while it is rotated.

The Tag property allows attaching custom data to any group. The FindGroup methods looks for a groups having a specific tag.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Group

See Also

Group Members


MindFusion.Diagramming.Group Members

Group Members
Constructors Properties Methods
[image]

Represents a group of items in the diagram document.

The following tables list the members exposed by the Group type.

Public Constructors

Name | Description
Group | Overloaded. Initializes a new instance of the Group class.

Public Properties

Name | Description
AttachedNodes | Gets a collection of the nodes attached to this group.
AutoDeleteItems | Gets or sets a value indicating whether the subordinated items in a group are automatically deleted if the group is destroyed.
Expandable | Gets or sets a value indicating whether expanding/collapsing a tree branch propagates through this group.
FollowMasterContainment | Gets or sets a value indicating whether the subordinated items should be considered by a ContainerNode when the master item is added to the container.
FollowMasterRotation | Gets or sets a value indicating whether attached nodes position should follow the RotationAngle of a master node.
MainItem | Gets or sets the main item of this group.
Tag | Gets or sets a custom data associated with the group.
Visible | Gets or sets a value indicating whether the group is visible.

Public Methods

Name | Description
AttachAlongLinkLength | Attaches a node to a link and keeps the initial distance between the node and the link origin when the latter is modified. The distance is measured along the link length, regardless of the number and shape of its segments.
AttachCustom | Attaches a new node to the group.
AttachProportional | Attaches a new node to the group, in such a way that its area is always occupying certain percentage of the main item's area.
AttachToCorner | Attaches a node to the specified corner of the main node.
AttachToEdges | Anchors a node to the specified edges of the master node.
AttachToLinkPoint | Attaches a node to the specified control point of the link that is MainItem.
AttachToLinkSegment | Attaches a node to the specified segment of the link that is MainItem.
AttachToLongestHSegment | Adds an item to the group, maintaining its relative position to the longest horizontal segment of the master link.
AttachToSideMiddle | Adds an item to the group, attaching it to the middle point of a side of the master node.
Detach | Detaches the specified item from this group.
GetRepaintRect | Gets a rectangle containing the repaint rectangle of the group's master and all attached objects.

See Also

Group Class


MindFusion.Diagramming.Group Constructor

Group Constructor
[image]

Initializes a new instance of the Group class.

Overload List

Name | Description
Group (Diagram) | Initializes a new instance of the Group class with the specified Diagram as parent.
Group (Group) | Initializes a new instance of the Group class using the specified group as a prototype.

See Also

Group Class


MindFusion.Diagramming.Group Constructor (Diagram)

Group Constructor (Diagram)
See Also
[image]

Initializes a new instance of the Group class with the specified Diagram as parent.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Group (
Diagram parent
)

Visual Basic [image] Copy Code

Public Sub Group ( _
parent As Diagram _
)

Parameters

parent

The Diagram the new group will belong to.

See Also

Group Constructor Overload List
Group Class


MindFusion.Diagramming.Group Constructor (Group)

Group Constructor (Group)
See Also
[image]

Initializes a new instance of the Group class using the specified group as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Group (
Group prototype
)

Visual Basic [image] Copy Code

Public Sub Group ( _
prototype As Group _
)

Parameters

prototype
The group to use as a prototype.

Remarks

This constructor supports the MvcDiagram infrastructure and is not intended to be used directly from your code. Instead use the other constructor or the CreateGroup method of the Factory class.

See Also

Group Constructor Overload List
Group Class


MindFusion.Diagramming.Group Methods

Group Methods
[image]

Public Methods

Name | Description
AttachAlongLinkLength | Attaches a node to a link and keeps the initial distance between the node and the link origin when the latter is modified. The distance is measured along the link length, regardless of the number and shape of its segments.
AttachCustom | Attaches a new node to the group.
AttachProportional | Attaches a new node to the group, in such a way that its area is always occupying certain percentage of the main item's area.
AttachToCorner | Attaches a node to the specified corner of the main node.
AttachToEdges | Anchors a node to the specified edges of the master node.
AttachToLinkPoint | Attaches a node to the specified control point of the link that is MainItem.
AttachToLinkSegment | Attaches a node to the specified segment of the link that is MainItem.
AttachToLongestHSegment | Adds an item to the group, maintaining its relative position to the longest horizontal segment of the master link.
AttachToSideMiddle | Adds an item to the group, attaching it to the middle point of a side of the master node.
Detach | Detaches the specified item from this group.
GetRepaintRect | Gets a rectangle containing the repaint rectangle of the group's master and all attached objects.

See Also

Group Class


MindFusion.Diagramming.Group.AttachAlongLinkLength Method

Group.AttachAlongLinkLength Method
[image]

Attaches a node to a link and keeps the initial distance between the node and the link origin when the latter is modified. The distance is measured along the link length, regardless of the number and shape of its segments.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AttachAlongLinkLength (
DiagramNode node,
bool relativeDistance
)

Visual Basic [image] Copy Code

Public Function AttachAlongLinkLength( _
node As DiagramNode, _
relativeDistance As Boolean _
) As Boolean

Parameters

node

The DiagramNode to be attached.

relativeDistance

true to preserve the absolute distance, false to preserve relative distance.

Return Value

false if the node could not be attached; otherwise, true.

See Also

Group Members
Group Class


MindFusion.Diagramming.Group.AttachCustom Method

Group.AttachCustom Method
[image]

Attaches a new node to the group.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AttachCustom (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Function AttachCustom ( _
node As DiagramNode _
) As Boolean

Parameters

node
A subordinate node whose position depends on the position of the group master item.

Return Value

true if the node has been attached to this group successfully.

Remarks

This method is used in conjunction with an UpdateGroup override defined in derived item types. The UpdateGroup override must set the position of attached nodes by calling their SetBounds method.

See Also

Group Members
Group Class


MindFusion.Diagramming.Group.AttachProportional Method

Group.AttachProportional Method
[image]

Attaches a new node to the group, in such a way that its area is always occupying certain percentage of the main item's area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AttachProportional (
DiagramNode node,
float left,
float top,
float right,
float bottom
)

Visual Basic [image] Copy Code

Public Function AttachProportional ( _
node As DiagramNode, _
left As Single, _
top As Single, _
right As Single, _
bottom As Single _
) As Boolean

Parameters

node

The DiagramNode to be attached.

left
The left side of the node's bounding rectangle, expressed as percent of the main node width.
top
The top side of the node's bounding rectangle, expressed as percent of the main node height.
right
The right side of the node's bounding rectangle, expressed as percent of the main node width.
bottom
The bottom side of the node's bounding rectangle, expressed as percent of the main node height.

Return Value

false if the node could not be attached; otherwise, true.

Remarks

You can use this method when the main item of the group is a node. Use the left, top, right and bottom arguments to specify the position and size of the attached node relative to that of the main item. When moving or resizing the main node, the specified ratio between it and the attached node is preserved.

See Also

Group Members
Group Class
AttachToCorner Method


MindFusion.Diagramming.Group.AttachToCorner Method

Group.AttachToCorner Method
[image]

Attaches a node to the specified corner of the main node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AttachToCorner (
DiagramNode node,
int corner
)

Visual Basic [image] Copy Code

Public Function AttachToCorner ( _
node As DiagramNode, _
corner As Integer _
) As Boolean

Parameters

node
The DiagramNode to be attached.
corner
The zero-based index of the main node's corner.

Return Value

false if the node could not be attached; otherwise, true.

Remarks

You can use this method if the main item of the group is a node. When the specified corner position of the main node's bounding rectangle is changed, the position of the attached node is also changed and the distance between them is preserved.

See Also

Group Members
Group Class
AttachProportional Method


MindFusion.Diagramming.Group.AttachToEdges Method

Group.AttachToEdges Method
[image]

Anchors a node to the specified edges of the master node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AttachToEdges (
DiagramNode node,
GroupAnchorStyles anchorStyles
)

Visual Basic [image] Copy Code

Public Function AttachToEdges ( _
node As DiagramNode, _
anchorStyles As GroupAnchorStyles _
) As Boolean

Parameters

node

The DiagramNode to be attached.

anchorStyles
A member of the GroupAnchorStyles enumeration.

Return Value

false if the node could not be attached; otherwise, true.

Remarks

This method can be used only if the master item in the group is a node. Anchoring works in a manner similar to how child controls in a form can be anchored to the form edges. When the master node position changes, the position of the attached node is also changed so that the initial distance between the specified edges is preserved.

See Also

Group Members
Group Class
AttachProportional Method


MindFusion.Diagramming.Group.AttachToLinkPoint Method

Group.AttachToLinkPoint Method
[image]

Attaches a node to the specified control point of the link that is MainItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AttachToLinkPoint (
DiagramNode node,
int point
)

Visual Basic [image] Copy Code

Public Function AttachToLinkPoint ( _
node As DiagramNode, _
point As Integer _
) As Boolean

Parameters

node

The DiagramNode to be attached.

point
The link point to which the node should be attached.

Return Value

false if the node could not be attached; otherwise, true.

Remarks

You can use this method when the main item of the group is a link. When the user moves the link control point whose index is passed as argument, the attached node is also moved with the same translation vector as that of the control point.

See Also

Group Members
Group Class
AttachToLinkSegment Method


MindFusion.Diagramming.Group.AttachToLinkSegment Method

Group.AttachToLinkSegment Method
[image]

Attaches a node to the specified segment of the link that is MainItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AttachToLinkSegment (
DiagramNode node,
int segment
)

Visual Basic [image] Copy Code

Public Function AttachToLinkSegment ( _
node As DiagramNode, _
segment As Integer _
) As Boolean

Parameters

node

The DiagramNode to be attached.

segment
The link segment to which the node will be attached.

Return Value

false if the node could not be attached; otherwise, true.

Remarks

Call this method when the main item of the group is a link. When the specified link segment changes its position, the position of the attached node is also changed, so their mutual distance and orientation are preserved.

See Also

Group Members
Group Class
AttachToLinkPoint Method


MindFusion.Diagramming.Group.AttachToLongestHSegment Method

Group.AttachToLongestHSegment Method
[image]

Adds an item to the group, maintaining its relative position to the longest horizontal segment of the master link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AttachToLongestHSegment (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Function AttachToLongestHSegment ( _
node As DiagramNode _
) As Boolean

Parameters

node

The object to attach to the current group.

Return Value

false if the node could not be attached; otherwise, true.

See Also

Group Members
Group Class


MindFusion.Diagramming.Group.AttachToSideMiddle Method

Group.AttachToSideMiddle Method
[image]

Adds an item to the group, attaching it to the middle point of a side of the master node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AttachToSideMiddle (
DiagramNode node,
int side
)

Visual Basic [image] Copy Code

Public Function AttachToSideMiddle ( _
node As DiagramNode, _
side As Integer _
) As Boolean

Parameters

node

The object to attach to the current group.

side

The corner to attach to.

Return Value

false if the node could not be attached; otherwise, true.

See Also

Group Members
Group Class


MindFusion.Diagramming.Group.Detach Method

Group.Detach Method
[image]

Detaches the specified item from this group.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Detach (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function Detach ( _
item As DiagramItem _
) As Boolean

Parameters

item
The DiagramItem to be detached.

Return Value

false if the item could not be detached; otherwise, true.

Remarks

Call this method to remove a item from this group. Note that this method does not delete the item, but just detaches it.

See Also

Group Members
Group Class
MindFusion.Diagramming Namespace
AttachToLinkSegment Method
AttachToLinkPoint Method
AttachProportional Method
AttachToCorner Method


MindFusion.Diagramming.Group.GetRepaintRect Method

Group.GetRepaintRect Method
[image]

Gets a rectangle containing the repaint rectangle of the group's master and all attached objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF GetRepaintRect ()

Visual Basic [image] Copy Code

Public Function GetRepaintRect () As RectangleF

Return Value

A .NET RectangleF instance that represents the smallest rectangle containing all diagram items related directly or indirectly to this group.

See Also

Group Members
Group Class


MindFusion.Diagramming.Group Properties

Group Properties
[image]

Public Properties

Name | Description
AttachedNodes | Gets a collection of the nodes attached to this group.
AutoDeleteItems | Gets or sets a value indicating whether the subordinated items in a group are automatically deleted if the group is destroyed.
Expandable | Gets or sets a value indicating whether expanding/collapsing a tree branch propagates through this group.
FollowMasterContainment | Gets or sets a value indicating whether the subordinated items should be considered by a ContainerNode when the master item is added to the container.
FollowMasterRotation | Gets or sets a value indicating whether attached nodes position should follow the RotationAngle of a master node.
MainItem | Gets or sets the main item of this group.
Tag | Gets or sets a custom data associated with the group.
Visible | Gets or sets a value indicating whether the group is visible.

See Also

Group Class


MindFusion.Diagramming.Group.AttachedNodes Property

Group.AttachedNodes Property
[image]

Gets a collection of the nodes attached to this group.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ReadOnlyDiagramNodeCollection AttachedNodes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AttachedNodes As ReadOnlyDiagramNodeCollection

Property Value

A collection that references all nodes attached to the group.

Remarks

The MainItem is not included in this collection.

See Also

Group Members
Group Class
MainItem Property


MindFusion.Diagramming.Group.AutoDeleteItems Property

Group.AutoDeleteItems Property
[image]

Gets or sets a value indicating whether the subordinated items in a group are automatically deleted if the group is destroyed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoDeleteItems { get; set; }

Visual Basic [image] Copy Code

Public Property AutoDeleteItems As Boolean

Property Value

true to delete subordinated items automatically; otherwise, false. The default is false.

Remarks

A group is destroyed explicitly by calling the Remove method of the Groups collection. A group is destroyed implicitly when its MainItem is deleted.

If a group is destroyed and this property is disabled, all subordinated items remain intact in the diagram, however they are no longer grouped. If a group is destroyed and this property is enabled, all subordinated items are deleted.

See Also

Group Members
Group Class


MindFusion.Diagramming.Group.Expandable Property

Group.Expandable Property
[image]

Gets or sets a value indicating whether expanding/collapsing a tree branch propagates through this group.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Expandable { get; set; }

Visual Basic [image] Copy Code

Public Property Expandable As Boolean

Property Value

true if expanding or collapsing of a tree branch should propagate through the group members; otherwise, false. The default is false.

Remarks

By default expanding or collapsing tree branches is done by following the links between the branch nodes. If there are not links going out from a node, the expanding or collapsing stops there. However, if a node has a group of subordinated nodes, it could be desirable to continue expanding through them. To enable that, set the group's Expandable property to true.

See Also

Group Members
Group Class
MindFusion.Diagramming Namespace
Diagram.RecursiveExpand Property
Diagram.NodesExpandable Property


MindFusion.Diagramming.Group.FollowMasterContainment Property

Group.FollowMasterContainment Property
[image]

Gets or sets a value indicating whether the subordinated items should be considered by a ContainerNode when the master item is added to the container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool FollowMasterContainment { get; set; }

Visual Basic [image] Copy Code

Public Property FollowMasterContainment As Boolean

Property Value

true if the whole group is contained in the ContainerNode; otherwise, false. The default is false.

See Also

Group Members
Group Class


MindFusion.Diagramming.Group.FollowMasterRotation Property

Group.FollowMasterRotation Property
[image]

Gets or sets a value indicating whether attached nodes position should follow the RotationAngle of a master node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GroupRotation FollowMasterRotation { get; set; }

Visual Basic [image] Copy Code

Public Property FollowMasterRotation As GroupRotation

Property Value

A member of the GroupRotation enumeration. The default is IgnoreRotation.

See Also

Group Members
Group Class


MindFusion.Diagramming.Group.MainItem Property

Group.MainItem Property
[image]

Gets or sets the main item of this group.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem MainItem { get; set; }

Visual Basic [image] Copy Code

Public Property MainItem As DiagramItem

Property Value

An instance of the DiagramItem class that represents the main item.

Remarks

Each group has an item which the subordinated items follow when it is moved. This main item can be a node or a link. The main item is passed as argument to the CreateGroup method.

See Also

Group Members
Group Class
AttachedNodes Property


MindFusion.Diagramming.Group.Tag Property

Group.Tag Property
[image]

Gets or sets a custom data associated with the group.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An instance of a System.Object-derived class that represents the tag.

Remarks

This property holds data that you define. MvcDiagram does not use it in any way. Possible usage might be to store an integer identifier or a reference to a larger structure.

See Also

Group Members
Group Class
MindFusion.Diagramming Namespace
Diagram.FindGroup Method
Diagram.SerializeTag Event


MindFusion.Diagramming.Group.Visible Property

Group.Visible Property
[image]

Gets or sets a value indicating whether the group is visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Property Visible As Boolean

Property Value

true if the group is visible; otherwise, false.

Remarks

Assigning a value to this property sets the Visible property of all items in the group.

See Also

Group Members
Group Class


MindFusion.Diagramming.Group.Attachment Class

Group.Attachment Class
[image]

Encapsulates attachment information.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Group.Attachment : IPersists

Visual Basic [image] Copy Code

Public Class Group.Attachment
Implements IPersists

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Group.Attachment

See Also

Group.Attachment Members


MindFusion.Diagramming.Group.Attachment Members

Group.Attachment Members
Constructors Properties Methods
[image]

Encapsulates attachment information.

The following tables list the members exposed by the Group.Attachment type.

Public Constructors

Name | Description
Group.Attachment | Initializes a new instance of the Attachment class.

Public Properties

Name | Description
Data | Gets or sets the attachment data.
Node | Gets or sets the attached node.
Percents | Gets a sets percent information for proportional attachments.
Traits | Contains properties specific to each layout algorithm.
Type | Gets or sets the attachment type.

Public Methods

Name | Description
Clone | Creates an exact copy of this attachment.

See Also

Group.Attachment Class


MindFusion.Diagramming.Group.Attachment Constructor

Group.Attachment Constructor
[image]

Initializes a new instance of the Attachment class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Group.Attachment ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Group.Attachment Class


MindFusion.Diagramming.Group.Attachment Methods

Group.Attachment Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this attachment.

See Also

Group.Attachment Class


MindFusion.Diagramming.Group.Attachment.Clone Method

Group.Attachment.Clone Method
[image]

Creates an exact copy of this attachment.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Group.Attachment Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Group.Attachment

Return Value

See Also

Group.Attachment Members
Group.Attachment Class


MindFusion.Diagramming.Group.Attachment Properties

Group.Attachment Properties
[image]

Public Properties

Name | Description
Data | Gets or sets the attachment data.
Node | Gets or sets the attached node.
Percents | Gets a sets percent information for proportional attachments.
Traits | Contains properties specific to each layout algorithm.
Type | Gets or sets the attachment type.

See Also

Group.Attachment Class


MindFusion.Diagramming.Group.Attachment.Data Property

Group.Attachment.Data Property
[image]

Gets or sets the attachment data.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Data { get; set; }

Visual Basic [image] Copy Code

Public Property Data As Integer

Property Value

Remarks

The interpretation of this value depends on the type of the attachment.

See Also

Group.Attachment Members
Group.Attachment Class


MindFusion.Diagramming.Group.Attachment.Node Property

Group.Attachment.Node Property
[image]

Gets or sets the attached node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Node { get; set; }

Visual Basic [image] Copy Code

Public Property Node As DiagramNode

Property Value

See Also

Group.Attachment Members
Group.Attachment Class


MindFusion.Diagramming.Group.Attachment.Percents Property

Group.Attachment.Percents Property
[image]

Gets a sets percent information for proportional attachments.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF Percents { get; set; }

Visual Basic [image] Copy Code

Public Property Percents As RectangleF

Property Value

See Also

Group.Attachment Members
Group.Attachment Class


MindFusion.Diagramming.Group.Attachment.Traits Property

Group.Attachment.Traits Property
[image]

Contains properties specific to each layout algorithm.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IDictionary Traits { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Traits As IDictionary

Property Value

See Also

Group.Attachment Members
Group.Attachment Class


MindFusion.Diagramming.Group.Attachment.Type Property

Group.Attachment.Type Property
[image]

Gets or sets the attachment type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AttachTo Type { get; set; }

Visual Basic [image] Copy Code

Public Property Type As AttachTo

Property Value

See Also

Group.Attachment Members
Group.Attachment Class


MindFusion.Diagramming.GroupAnchorStyles Enumeration

GroupAnchorStyles Enumeration
[image]

Specifies the master node edges to which a subordinate node can be anchored.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum GroupAnchorStyles

Visual Basic [image] Copy Code

Public Enum GroupAnchorStyles

Members

Member name | Description
Left | Specifies the left edge.
Top | Specifies the top edge.
Right | Specifies the right edge.
Bottom | Specifies the bottom edge.

See Also


MindFusion.Diagramming.GroupCollection Class

GroupCollection Class
[image]

Represents a strongly typed collection of Group objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class GroupCollection : PersistableCollection<Group>

Visual Basic [image] Copy Code

Public Class GroupCollection
Inherits PersistableCollection(Of Group)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.CollectionBase(Group)
MindFusion.Diagramming.PersistableCollection(Group)
MindFusion.Diagramming.GroupCollection

See Also

GroupCollection Members


MindFusion.Diagramming.GroupCollection Members

GroupCollection Members
Constructors Fields Properties Methods
[image]

Represents a strongly typed collection of Group objects.

The following tables list the members exposed by the GroupCollection type.

Public Constructors

Name | Description
GroupCollection | Initializes a new instance of the GroupCollection class.

Protected Fields

Name | Description
groupEventArgs | A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector.
InnerList | Gets a List<T> containing the list of elements in the collection instance. (Inherited from CollectionBase.)
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items.

Public Properties

Name | Description
Count | Gets the number of elements actually contained in the collection. (Inherited from CollectionBase.)
IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index. (Inherited from CollectionBase.)

Public Methods

Name | Description
Add | Adds the specified group to the collection.
Add | Adds an object to the end of the collection. (Inherited from CollectionBase.)
Clear | Removes all groups from the collection.
Clone | Creates a shallow copy of this collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from CollectionBase.)
GetAt | The zero-based index of the group to retrieve.
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified group in the collection at the specified position.
Insert | Inserts an element into the collection at the specified index. (Inherited from CollectionBase.)
Remove | Removes the specified group from the collection.
Remove | Removes the first occurrence of a specific object from the collection. (Inherited from CollectionBase.)
RemoveAt | Removes the diagram item from the collection.
Sort | Overloaded. (Inherited from CollectionBase.)

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event.
RaiseInserting | Raises the Inserting event.
RaiseRemoving | Raises the Removing event.

See Also

GroupCollection Class


MindFusion.Diagramming.GroupCollection Fields

GroupCollection Fields
[image]

Protected Fields

Name | Description
groupEventArgs | A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector.
InnerList | Gets a List<T> containing the list of elements in the collection instance. (Inherited from CollectionBase.)
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items.

See Also

GroupCollection Class


MindFusion.Diagramming.GroupCollection.groupEventArgs Field

GroupCollection.groupEventArgs Field
[image]

A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected GroupEventArgs groupEventArgs

Visual Basic [image] Copy Code

Protected groupEventArgs As GroupEventArgs

See Also

GroupCollection Members
GroupCollection Class


MindFusion.Diagramming.GroupCollection.notifyParent Field

GroupCollection.notifyParent Field
[image]

If enabled, the collection raises events to let their containing objects handle the addition or removal of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected bool notifyParent

Visual Basic [image] Copy Code

Protected notifyParent As Boolean

See Also

GroupCollection Members
GroupCollection Class


MindFusion.Diagramming.GroupCollection Constructor

GroupCollection Constructor
[image]

Initializes a new instance of the GroupCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GroupCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

GroupCollection Class


MindFusion.Diagramming.GroupCollection Methods

GroupCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified group to the collection.
Add | Adds an object to the end of the collection. (Inherited from CollectionBase.)
Clear | Removes all groups from the collection.
Clone | Creates a shallow copy of this collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from CollectionBase.)
GetAt | The zero-based index of the group to retrieve.
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified group in the collection at the specified position.
Insert | Inserts an element into the collection at the specified index. (Inherited from CollectionBase.)
Remove | Removes the specified group from the collection.
Remove | Removes the first occurrence of a specific object from the collection. (Inherited from CollectionBase.)
RemoveAt | Removes the diagram item from the collection.
Sort | Overloaded. (Inherited from CollectionBase.)

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event.
RaiseInserting | Raises the Inserting event.
RaiseRemoving | Raises the Removing event.

See Also

GroupCollection Class


MindFusion.Diagramming.GroupCollection.Add Method

GroupCollection.Add Method
[image]

Adds the specified group to the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Add (
Group group
)

Visual Basic [image] Copy Code

Public Overrides Sub Add( _
group As Group _
)

Parameters

group

The Group object to add to the collection.

See Also

GroupCollection Members
GroupCollection Class


MindFusion.Diagramming.GroupCollection.Clear Method

GroupCollection.Clear Method
[image]

Removes all groups from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Clear ()

Visual Basic [image] Copy Code

Public Overrides Sub Clear ()

See Also

GroupCollection Members
GroupCollection Class


MindFusion.Diagramming.GroupCollection.Clone Method

GroupCollection.Clone Method
[image]

Creates a shallow copy of this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GroupCollection Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As GroupCollection

Return Value

An instance of the GroupCollection class.

See Also

GroupCollection Members
GroupCollection Class


MindFusion.Diagramming.GroupCollection.GetAt Method

GroupCollection.GetAt Method
[image]

The zero-based index of the group to retrieve.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Group GetAt (
int index
)

Visual Basic [image] Copy Code

Public Function GetAt ( _
index As Integer _
) As Group

Parameters

index

The zero-based index of the group to retrieve.

Return Value

An instance of the Group class that represents the node at the specified position.

See Also

GroupCollection Members
GroupCollection Class


MindFusion.Diagramming.GroupCollection.Insert Method

GroupCollection.Insert Method
[image]

Inserts the specified group in the collection at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Insert (
int index,
Group group
)

Visual Basic [image] Copy Code

Public Overrides Sub Insert( _
index As Integer, _
group As Group _
)

Parameters

index

The zero-based index at which to insert the group.

group

The Group object to add to the collection.

See Also

GroupCollection Members
GroupCollection Class


MindFusion.Diagramming.GroupCollection.RaiseAdding Method

GroupCollection.RaiseAdding Method
[image]

Raises the Adding event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void RaiseAdding (
Group group
)

Visual Basic [image] Copy Code

Protected Sub RaiseAdding ( _
group As Group _
)

Parameters

group

The group that is being added.

See Also

GroupCollection Members
GroupCollection Class


MindFusion.Diagramming.GroupCollection.RaiseInserting Method

GroupCollection.RaiseInserting Method
[image]

Raises the Inserting event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void RaiseInserting (
Group group,
int index
)

Visual Basic [image] Copy Code

Protected Sub RaiseInserting ( _
group As Group, _
index As Integer _
)

Parameters

group

The group that is being added.

index

Index of the new group.

See Also

GroupCollection Members
GroupCollection Class


MindFusion.Diagramming.GroupCollection.RaiseRemoving Method

GroupCollection.RaiseRemoving Method
[image]

Raises the Removing event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void RaiseRemoving (
Group group
)

Visual Basic [image] Copy Code

Protected Sub RaiseRemoving ( _
group As Group _
)

Parameters

group

The group that is being removed.

See Also

GroupCollection Members
GroupCollection Class


MindFusion.Diagramming.GroupCollection.Remove Method

GroupCollection.Remove Method
[image]

Removes the specified group from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool Remove (
Group group
)

Visual Basic [image] Copy Code

Public Overrides Function Remove( _
group As Group _
) As Boolean

Parameters

group

The Group object to remove from the collection.

Return Value

See Also

GroupCollection Members
GroupCollection Class


MindFusion.Diagramming.GroupCollection.RemoveAt Method

GroupCollection.RemoveAt Method
[image]

Removes the diagram item from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void RemoveAt (
int index
)

Visual Basic [image] Copy Code

Public Overrides Sub RemoveAt( _
index As Integer _
)

Parameters

index

Index of the object that should be removed from this collection.

See Also

GroupCollection Members
GroupCollection Class


MindFusion.Diagramming.GroupEventArgs Class

GroupEventArgs Class
[image]

Contains the arguments passed to handlers of group-related events, such as GroupDestroyed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class GroupEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class GroupEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.GroupEventArgs

See Also

GroupEventArgs Members


MindFusion.Diagramming.GroupEventArgs Members

GroupEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to handlers of group-related events, such as GroupDestroyed.

The following tables list the members exposed by the GroupEventArgs type.

Public Constructors

Name | Description
GroupEventArgs | Initializes a new instance of the GroupEventArgs class.

Public Properties

Name | Description
Group | Gets the group for which the event was raised.
Index | Gets an integer index related to the event.

See Also

GroupEventArgs Class


MindFusion.Diagramming.GroupEventArgs Constructor

GroupEventArgs Constructor
[image]

Initializes a new instance of the GroupEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GroupEventArgs (
Group group
)

Visual Basic [image] Copy Code

Public Sub GroupEventArgs ( _
group As Group _
)

Parameters

group

The Group related to the event.

See Also

GroupEventArgs Class


MindFusion.Diagramming.GroupEventArgs Properties

GroupEventArgs Properties
[image]

Public Properties

Name | Description
Group | Gets the group for which the event was raised.
Index | Gets an integer index related to the event.

See Also

GroupEventArgs Class


MindFusion.Diagramming.GroupEventArgs.Group Property

GroupEventArgs.Group Property
[image]

Gets the group for which the event was raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Group Group { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Group As Group

Property Value

An instance of the Group class.

See Also

GroupEventArgs Members
GroupEventArgs Class


MindFusion.Diagramming.GroupEventArgs.Index Property

GroupEventArgs.Index Property
[image]

Gets an integer index related to the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Index { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Index As Integer

Property Value

An integer value.

See Also

GroupEventArgs Members
GroupEventArgs Class


MindFusion.Diagramming.GroupRotation Enumeration

GroupRotation Enumeration
[image]

Defines values that indicate how rotation of a group's master node affects the nodes attached to that group.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum GroupRotation

Visual Basic [image] Copy Code

Public Enum GroupRotation

Members

Member name | Description
IgnoreRotation | Attached nodes ignore the rotation angle applied to the master node.
FerrisWheel | Attached nodes are moved to a position corresponding to the master node's rotation angle, but they are node rotated.
RotateChildren | Attached nodes are rotated by the RotationAngle of the group's master node and around its center.

See Also


MindFusion.Diagramming.HandlesStyle Enumeration

HandlesStyle Enumeration
[image]

Enumerates possible visual styles for frames that are drawn around selected nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum HandlesStyle

Visual Basic [image] Copy Code

Public Enum HandlesStyle

Members

Member name | Description
Invisible | There is no visible difference between selected and unselected node.
SquareHandles | If selected, the node is drawn with square modification handles.
DashFrame | If selected, a node is drawn with a dashed frame. The frame enables resizing the node. The center of the node allows moving it and the edge area enables creating links.
HatchFrame | If selected, the item is drawn with hatched frame. Modifications can be done as with DashFrame.
HatchHandles | If selected, a node is drawn with both hatched frame and modification handles. The frame enable moving the node, and the handles enable resizing. Links are created from any point of the interior.
HatchHandles2 | Looks like HatchHandles, but allows moving the node from the interior area. Links are created from the points near the edge.
HatchHandles3 | Behaves like HatchHandles2, but paints the selection frame using a denser brush pattern.
MoveOnly | If a node is selected, it can be only moved. Best used with ModificationStart set to AutoHandles.
EasyMove | Any point of the interior of a node enables moving the node, except a small area in the center that allows creating links. Best used with ModificationStart set to AutoHandles.
SquareHandles2 | Square resize handles are drawn around a selected node. There isn't a move handle in the center as with the SquareHandles style, but nodes can be moved by dragging their interior or caption areas. Links can be created by drawing from near the edges of a node.
Custom | MvcDiagram raises the DrawAdjustmentHandles and HitTestAdjustmentHandles events to let your application perform custom drawing and hit testing of selection handles.
InvisibleMove | There aren't any selection handles displayed. The selected node can be only moved, but not resized.
RoundAndSquare | Corner resize handles are round, remaining handles are square.
RoundAndSquare2 | Corner resize handles are round, remaining handles are square. In addition, there is a dashed frame drawn around selected nodes.

Remarks

The selection style can be set independently for individual nodes and links through their DiagramNode.HandlesStyle and DiagramLink.HandlesStyle properties. For most of these styles, it is recommended to set ModificationStart to AutoHandles.

See Also


MindFusion.Diagramming.HandlesVisualStyle Class

HandlesVisualStyle Class
Remarks See Also
[image]

Defines the Pen and Brush objects used to draw items' adjustment handles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class HandlesVisualStyle : IPersists

Visual Basic [image] Copy Code

Public Class HandlesVisualStyle
Implements IPersists

Remarks

The component uses several different HandlesVisualStyle objects depending on the context. They can be accessed through the ActiveItemHandlesStyle, SelectedItemHandlesStyle and DisabledHandlesStyle properties of Diagram.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.HandlesVisualStyle

See Also

HandlesVisualStyle Members


MindFusion.Diagramming.HandlesVisualStyle Members

HandlesVisualStyle Members
Constructors Properties Methods
[image]

Defines the Pen and Brush objects used to draw items' adjustment handles.

The following tables list the members exposed by the HandlesVisualStyle type.

Public Constructors

Name | Description
HandlesVisualStyle | Initializes a new instance of the HandlesVisualStyle class.

Public Properties

Name | Description
ControlPointBrush | Gets or sets a Brush used to fill the interior of shape control points.
DashPen | Gets or sets a Pen used to draw dashed selection frames.
HandleBrush | Gets or sets a Brush used to fill the interior of selection handles.
HandlePen | Gets or sets a Pen used to draw the border of selection handles.
HatchBrush | Gets or sets a Brush used to draw hatch frames.
PatternBrush | Gets or sets a Brush used to draw selection frames for the MoveOnly style.
RotationHandleBrush | Gets or sets a Brush used to fill the interior of the rotation handle.

Public Methods

Name | Description
LoadFromXml | Loads the style from XML.
SaveToXml | Saves the style to XML.

See Also

HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle Constructor

HandlesVisualStyle Constructor
[image]

Initializes a new instance of the HandlesVisualStyle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HandlesVisualStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle Methods

HandlesVisualStyle Methods
[image]

Public Methods

Name | Description
LoadFromXml | Loads the style from XML.
SaveToXml | Saves the style to XML.

See Also

HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle.LoadFromXml Method

HandlesVisualStyle.LoadFromXml Method
[image]

Loads the style from XML.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
string elementName,
string colorElementName,
XmlElement parentElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml ( _
elementName As String, _
colorElementName As String, _
parentElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

elementName

The name of the element that describes the style.

colorElementName

The name of an element that contains a fallback color.

parentElement

The parent XML element.

context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle.SaveToXml Method

HandlesVisualStyle.SaveToXml Method
[image]

Saves the style to XML.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
string elementName,
XmlElement parentElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub SaveToXml ( _
elementName As String, _
parentElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

elementName

The name of the element that describes the style.

parentElement

The parent XML element.

context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle Properties

HandlesVisualStyle Properties
[image]

Public Properties

Name | Description
ControlPointBrush | Gets or sets a Brush used to fill the interior of shape control points.
DashPen | Gets or sets a Pen used to draw dashed selection frames.
HandleBrush | Gets or sets a Brush used to fill the interior of selection handles.
HandlePen | Gets or sets a Pen used to draw the border of selection handles.
HatchBrush | Gets or sets a Brush used to draw hatch frames.
PatternBrush | Gets or sets a Brush used to draw selection frames for the MoveOnly style.
RotationHandleBrush | Gets or sets a Brush used to fill the interior of the rotation handle.

See Also

HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle.ControlPointBrush Property

HandlesVisualStyle.ControlPointBrush Property
[image]

Gets or sets a Brush used to fill the interior of shape control points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush ControlPointBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ControlPointBrush As Brush

Property Value

An instance of a Brush -derived class. The default is solid-color yellow brush.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle.DashPen Property

HandlesVisualStyle.DashPen Property
[image]

Gets or sets a Pen used to draw dashed selection frames.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen DashPen { get; set; }

Visual Basic [image] Copy Code

Public Property DashPen As Pen

Property Value

An instance of the Pen class.

Remarks

This pen is used to draw selection frame around items whose HandlesStyle property is set to DashFrame.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle.HandleBrush Property

HandlesVisualStyle.HandleBrush Property
[image]

Gets or sets a Brush used to fill the interior of selection handles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush HandleBrush { get; set; }

Visual Basic [image] Copy Code

Public Property HandleBrush As Brush

Property Value

An instance of a Brush -derived class.

Remarks

This brush is used to fill the interior of adjustment handles rendered for most of the HandlesStyle types.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle.HandlePen Property

HandlesVisualStyle.HandlePen Property
[image]

Gets or sets a Pen used to draw the border of selection handles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen HandlePen { get; set; }

Visual Basic [image] Copy Code

Public Property HandlePen As Pen

Property Value

An instance of the Pen class.

Remarks

This pen is used to draw the borders of adjustment handles rendered for most of the HandlesStyle types.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle.HatchBrush Property

HandlesVisualStyle.HatchBrush Property
[image]

Gets or sets a Brush used to draw hatch frames.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush HatchBrush { get; set; }

Visual Basic [image] Copy Code

Public Property HatchBrush As Brush

Property Value

An instance of a Brush -derived class.

Remarks

This brush is used to draw the hatch pattern for HandlesStyle types that display hatch frames.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle.PatternBrush Property

HandlesVisualStyle.PatternBrush Property
[image]

Gets or sets a Brush used to draw selection frames for the MoveOnly style.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush PatternBrush { get; set; }

Visual Basic [image] Copy Code

Public Property PatternBrush As Brush

Property Value

An instance of a Brush -derived class.

Remarks

This brush is used to render the dot pattern for the HatchHandles3 and MoveOnly HandlesStyle types.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle.RotationHandleBrush Property

HandlesVisualStyle.RotationHandleBrush Property
[image]

Gets or sets a Brush used to fill the interior of the rotation handle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush RotationHandleBrush { get; set; }

Visual Basic [image] Copy Code

Public Property RotationHandleBrush As Brush

Property Value

A Brush instance. The default value is null.

Remarks

If this property is set to null, the rotation brush is painted using HandleBrush.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class


MindFusion.Diagramming.HitTestEventArgs Class

HitTestEventArgs Class
[image]

Contains the arguments passed to the HitTestAdjustmentHandles event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class HitTestEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class HitTestEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.HitTestEventArgs

See Also

HitTestEventArgs Members


MindFusion.Diagramming.HitTestEventArgs Members

HitTestEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the HitTestAdjustmentHandles event handlers.

The following tables list the members exposed by the HitTestEventArgs type.

Public Constructors

Name | Description
HitTestEventArgs | Initializes a new instance of the HitTestEventArgs class.

Public Properties

Name | Description
HitResult | Gets or sets the adjustment handle that has been hit.
Item | Gets the item whose adjustment handles are being hit-tested.
MousePosition | Gets the current cursor position, expressed in document coordinates.

See Also

HitTestEventArgs Class


MindFusion.Diagramming.HitTestEventArgs Constructor

HitTestEventArgs Constructor
[image]

Initializes a new instance of the HitTestEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HitTestEventArgs (
DiagramItem item,
PointF mousePosition
)

Visual Basic [image] Copy Code

Public Sub HitTestEventArgs ( _
item As DiagramItem, _
mousePosition As PointF _
)

Parameters

item

The DiagramItem related to the event.

mousePosition
The cursor location at the time the event is raised, expressed in document coordinates.

See Also

HitTestEventArgs Class


MindFusion.Diagramming.HitTestEventArgs Properties

HitTestEventArgs Properties
[image]

Public Properties

Name | Description
HitResult | Gets or sets the adjustment handle that has been hit.
Item | Gets the item whose adjustment handles are being hit-tested.
MousePosition | Gets the current cursor position, expressed in document coordinates.

See Also

HitTestEventArgs Class


MindFusion.Diagramming.HitTestEventArgs.HitResult Property

HitTestEventArgs.HitResult Property
[image]

Gets or sets the adjustment handle that has been hit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AdjustmentHandle HitResult { get; set; }

Visual Basic [image] Copy Code

Public Property HitResult As AdjustmentHandle

Property Value

An instance of AdjustmentHandle -derived class, or null if there is no handle located at the specified position.

See Also

HitTestEventArgs Members
HitTestEventArgs Class


MindFusion.Diagramming.HitTestEventArgs.Item Property

HitTestEventArgs.Item Property
[image]

Gets the item whose adjustment handles are being hit-tested.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As DiagramItem

Property Value

An instance of the DiagramItem class.

See Also

HitTestEventArgs Members
HitTestEventArgs Class


MindFusion.Diagramming.HitTestEventArgs.MousePosition Property

HitTestEventArgs.MousePosition Property
[image]

Gets the current cursor position, expressed in document coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointF MousePosition { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MousePosition As PointF

Property Value

A PointF value specifying the current mouse position.

See Also

HitTestEventArgs Members
HitTestEventArgs Class


MindFusion.Diagramming.HitTestPriority Enumeration

HitTestPriority Enumeration
[image]

Defines values that specify the order of item hit-testing.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum HitTestPriority

Visual Basic [image] Copy Code

Public Enum HitTestPriority

Members

Member name | Description
ZOrder | Test items in decreasing z-order, independently of their types.
NodesBeforeLinks | Test nodes first, then links.

See Also

HitTestPriority Property


MindFusion.Diagramming.HitTestResult Enumeration

HitTestResult Enumeration
[image]

Represents the return value from a hit test.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum HitTestResult

Visual Basic [image] Copy Code

Public Enum HitTestResult

Members

Member name | Description
Nothing | No recognizable element of the item has been hit.
ScrollBar | A scrollbar has been hit.
CollapseButton | A collapse/expand button has been hit.

See Also


MindFusion.Diagramming.HtmlBuilder Class

HtmlBuilder Class
Remarks See Also
[image]

Provides methods to create and use HTML client side image maps.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class HtmlBuilder

Visual Basic [image] Copy Code

Public Class HtmlBuilder

Remarks

If an exported diagram image is displayed in an HTML page, it is helpful to create an image map whose areas correspond to the items visible in the image. The CreateImageMap method generates a full <MAP> tag, including its <AREA> elements. CreateUseMapAttr method creates the code to reference a map from within an <IMG> tag, and also adds a WIDTH and HEIGHT attributes that define to the width and height of the exported image, measured in pixels.

Each <AREA> tag in the image map has its attributes set as follows:

  • HREF is set to the HyperLink value of the diagram item or table's cell corresponding to the area;
  • ALT is set to the ToolTip value of the node or table's cell corresponding to the area;
  • TARGET is set to the value of HtmlBuilder's LinkTarget property.

Image map areas can be also generated for the [±] buttons displayed beside Expandable nodes. To enable that, assign an URL to the ExpandBtnHyperLink property. That URL can contain some format specifiers which are automatically replaced with the values of nodes' Tag or ZIndex properties. That lets you identify on the server side the node whose [±] button is clicked.

HtmlBuilder is most useful when it is used in conjunction with the WebChart library to create diagram images on the server, though it is available in the Windows Forms MvcDiagram control too.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.HtmlBuilder

See Also

HtmlBuilder Members


MindFusion.Diagramming.HtmlBuilder Members

HtmlBuilder Members
Constructors Properties Methods Events
[image]

Provides methods to create and use HTML client side image maps.

The following tables list the members exposed by the HtmlBuilder type.

Public Constructors

Name | Description
HtmlBuilder | Initializes a new instance of the HtmlBuilder class.

Public Properties

Name | Description
AreasForTableCells | Gets or sets a value indicating whether AREA tags are generated for table cells.
AreasForTreeViewItems | Gets or sets a value indicating whether AREA tags are generated for TreeViewNode items.
ExpandBtnHyperLink | Gets or sets the hyperlink assigned to AREA tags generated for the [±] buttons of Expandable nodes.
LinkTarget | Gets or sets the value of the TARGET attribute of AREA tags.
Scale | Gets or sets the scale factor for the generated image.
ScrollDownHyperLink | Gets or sets the hyperlink assigned to AREA tags generated for the lower scroll arrow of tables.
ScrollUpHyperLink | Gets or sets the hyperlink assigned to AREA tags generated for the upper scroll arrow of tables.

Public Methods

Name | Description
CreateImageHtml | Generates an image map HTML code.
CreateImageMap | Overloaded.
CreateUseMapAttr | Generates a USEMAP attribute to be used within an <IMG> tag.

Public Events

Name | Description
CreatingArea | Raised just before a new AREA tag is added to the image map.

See Also

HtmlBuilder Class


MindFusion.Diagramming.HtmlBuilder Constructor

HtmlBuilder Constructor
[image]

Initializes a new instance of the HtmlBuilder class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HtmlBuilder (
Diagram diagram
)

Visual Basic [image] Copy Code

Public Sub HtmlBuilder ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram object whose contents will generate the image map.

See Also

HtmlBuilder Class


MindFusion.Diagramming.HtmlBuilder Methods

HtmlBuilder Methods
[image]

Public Methods

Name | Description
CreateImageHtml | Generates an image map HTML code.
CreateImageMap | Overloaded.
CreateUseMapAttr | Generates a USEMAP attribute to be used within an <IMG> tag.

See Also

HtmlBuilder Class


MindFusion.Diagramming.HtmlBuilder.CreateImageHtml Method

HtmlBuilder.CreateImageHtml Method
[image]

Generates an image map HTML code.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string CreateImageHtml (
string htmlFileName,
string htmlTitle,
string imgLocalPath,
string imgURL,
ImageFormat imgFormat
)

Visual Basic [image] Copy Code

Public Function CreateImageHtml( _
htmlFileName As String, _
htmlTitle As String, _
imgLocalPath As String, _
imgURL As String, _
imgFormat As ImageFormat _
) As String

Parameters

htmlFileName

A string that represents the full name of the HTML file that is created.

htmlTitle
A string that represents the <TITLE> of the HTML file created.
imgLocalPath
A string that specifies the location of the image.
imgURL
A string that specifies the URL of the image at the server.
imgFormat

The image format.

Return Value

A string with the HTML code of the created HTML file.

Remarks

The method also creates an HTML file with attributes specified as parameters.

See Also

HtmlBuilder Members
HtmlBuilder Class


MindFusion.Diagramming.HtmlBuilder.CreateImageMap Method

HtmlBuilder.CreateImageMap Method
[image]

Overload List

Name | Description
HtmlBuilder.CreateImageMap (String) | Creates an HTML code for a MAP tag.
HtmlBuilder.CreateImageMap (String, RectangleF) | Creates an HTML code for a MAP tag.

See Also

HtmlBuilder Members
HtmlBuilder Class


MindFusion.Diagramming.HtmlBuilder.CreateImageMap Method (String)

HtmlBuilder.CreateImageMap Method (String)
See Also
[image]

Creates an HTML code for a MAP tag.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string CreateImageMap (
string mapName
)

Visual Basic [image] Copy Code

Public Function CreateImageMap( _
mapName As String _
) As String

Parameters

mapName
A string that represents the NAME attribute in the <MAP> tag.

Return Value

A string value containing the generated HTML code.

Remarks

There are <AREA> tags generated for each node or link whose HyperLink is not an empty string. Outlines of items that cannot be represented exactly with standard <AREA> shapes are approximated to polygons. The HREF attribute of the area is set to the value of item's HyperLink property. The ALT attribute is set to the value of item's ToolTip property.

Example

The following HTML code:

HTML [image] Copy Code

<MAP NAME="diagram1">
<AREA SHAPE ="RECT" COORDS="15,3,650,774" HREF="http://mindfusion.eu" ALT="">
<AREA SHAPE ="POLY" COORDS="198,43,195,48,185,52,170,55,151,57,130,58,109,57,90,55,75,52,65,48,62,43,65,38,75,34,90,31,109,29,130,28,151,29,170,31,185,34,195,38,198,43" HREF="" ALT="">
<AREA SHAPE ="POLY" COORDS="96,85,164,85,198,96,198,119,164,130,96,130,62,119,62,96" HREF="http://mindfusion.eu" ALT="">
<AREA SHAPE ="RECT" COORDS="60,151,196,196" HREF="" ALT="">
<AREA SHAPE ="RECT" COORDS="60,230,196,287" HREF="" ALT="">
</MAP>

is generated from the following code:

C# [image] Copy Code

HtmlBuilder hb = new HtmlBuilder(diagram);
string htmlCode = hb.CreateImageMap("diagram1");

Visual Basic [image] Copy Code

Dim hb As HtmlBuilder = New HtmlBuilder(Diagram)
Dim htmlCode As String = hb.CreateImageMap("diagram1")

See Also

CreateImageMap Method Overload List
HtmlBuilder Members
HtmlBuilder Class


MindFusion.Diagramming.HtmlBuilder.CreateImageMap Method (String, RectangleF)

HtmlBuilder.CreateImageMap Method (String, RectangleF)
See Also
[image]

Creates an HTML code for a MAP tag.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string CreateImageMap (
string mapName,
RectangleF viewport
)

Visual Basic [image] Copy Code

Public Function CreateImageMap( _
mapName As String, _
viewport As RectangleF _
) As String

Parameters

mapName

A string that represents the NAME attribute in the <MAP> tag.

viewport

Specifies the diagram region for which to generate an image map.

Return Value

A string value containing the generated HTML code.

See Also

CreateImageMap Method Overload List
HtmlBuilder Members
HtmlBuilder Class


MindFusion.Diagramming.HtmlBuilder.CreateUseMapAttr Method

HtmlBuilder.CreateUseMapAttr Method
[image]

Generates a USEMAP attribute to be used within an <IMG> tag.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string CreateUseMapAttr (
string mapID
)

Visual Basic [image] Copy Code

Public Function CreateUseMapAttr( _
mapID As String _
) As String

Parameters

mapID
A string that represents the ID in the USEMAP attribute of the <IMG> HTML tag.

Return Value

A string that contains the generated HTML code for the USEMAP attribute.

Remarks

Use the same mapID as the one you have passed to CreateImageMap. The method generates also WIDTH and HEIGHT attributes, converting the diagram's MeasureUnit values to pixel values.

Example

The result of this method looks like:

HTML [image] Copy Code

USEMAP="#diagram1" WIDTH="672" HEIGHT="808"

and is ready to be inserted in your <IMG> tag.

See Also

HtmlBuilder Members
HtmlBuilder Class


MindFusion.Diagramming.HtmlBuilder Properties

HtmlBuilder Properties
[image]

Public Properties

Name | Description
AreasForTableCells | Gets or sets a value indicating whether AREA tags are generated for table cells.
AreasForTreeViewItems | Gets or sets a value indicating whether AREA tags are generated for TreeViewNode items.
ExpandBtnHyperLink | Gets or sets the hyperlink assigned to AREA tags generated for the [±] buttons of Expandable nodes.
LinkTarget | Gets or sets the value of the TARGET attribute of AREA tags.
Scale | Gets or sets the scale factor for the generated image.
ScrollDownHyperLink | Gets or sets the hyperlink assigned to AREA tags generated for the lower scroll arrow of tables.
ScrollUpHyperLink | Gets or sets the hyperlink assigned to AREA tags generated for the upper scroll arrow of tables.

See Also

HtmlBuilder Class


MindFusion.Diagramming.HtmlBuilder.AreasForTableCells Property

HtmlBuilder.AreasForTableCells Property
[image]

Gets or sets a value indicating whether AREA tags are generated for table cells.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AreasForTableCells { get; set; }

Visual Basic [image] Copy Code

Public Property AreasForTableCells As Boolean

Property Value

true to create AREA tags for table cells; otherwise, false. The default is false.

Remarks

If disabled, there is a single <AREA> created for each table, corresponding to the table's bounding rectangle. If enabled, each cell of a table has a corresponding <AREA> tag created and one <AREA> is created for the table's caption bar rectangle.

See Also

HtmlBuilder Members
HtmlBuilder Class
Table.Cell.HyperLink Property


MindFusion.Diagramming.HtmlBuilder.AreasForTreeViewItems Property

HtmlBuilder.AreasForTreeViewItems Property
[image]

Gets or sets a value indicating whether AREA tags are generated for TreeViewNode items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AreasForTreeViewItems { get; set; }

Visual Basic [image] Copy Code

Public Property AreasForTreeViewItems As Boolean

Property Value

true to create AREA tags for TreeViewNode items; otherwise, false. The default is false.

See Also

HtmlBuilder Members
HtmlBuilder Class


MindFusion.Diagramming.HtmlBuilder.ExpandBtnHyperLink Property

HtmlBuilder.ExpandBtnHyperLink Property
[image]

Gets or sets the hyperlink assigned to AREA tags generated for the [±] buttons of Expandable nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ExpandBtnHyperLink { get; set; }

Visual Basic [image] Copy Code

Public Property ExpandBtnHyperLink As String

Property Value

A string value containing an URL. The default is an empty string.

Remarks

If the value of this property is not an empty string, the HtmlBuilder creates <AREA> tags for the expand/collapse buttons displayed besides nodes. That lets you process requests to expand or collapse a tree branch on the server, or just use the [±] button as additional hot spots in the image map. The hyperlink string can contain any of the following format specifiers:

Specifier | Description
{0} | Replaced with the ZIndex of the node associated with the [±] button.
{1} | Replaced with the Tag of the node associated with the [±] button.

The ZIndex of a node can be used to directly access the node within the Items collection, it has the same value as the index of an item within that collection. The Tag can be used to find a node by calling the FindNode method.

Example

To have a JavaScript method called with node's Tag passed as parameter when a [±] button area is clicked, setup an HtmlBuilder instance as shown below:

C# [image] Copy Code

HtmlBuilder hb = new HtmlBuilder(diagram);
hb.ExpandBtnHyperLink = "javascript: void processExpand({1})";
...

Visual Basic [image] Copy Code

Dim hb As New HtmlBuilder(diagram)
hb.ExpandBtnHyperLink = "javascript: void processExpand({1})"
...

See Also

HtmlBuilder Members
HtmlBuilder Class


MindFusion.Diagramming.HtmlBuilder.LinkTarget Property

HtmlBuilder.LinkTarget Property
[image]

Gets or sets the value of the TARGET attribute of AREA tags.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string LinkTarget { get; set; }

Visual Basic [image] Copy Code

Public Property LinkTarget As String

Property Value

A string containing the target frame name. The default is "_self".

Remarks

This property provides a value for the TARGET attribute of each <AREA> tag included in the image map. TARGET indicates the target window or frame where image area hyperlinks are opened. The target could be either a named frame or one of the following special values:

Value | Description
_blank | Loads the linked document into a new blank window.
_parent | Loads the linked document into current document's parent.
_self | Loads the linked document into the same window.
_top | Loads the linked document into the topmost browser window.

See Also

HtmlBuilder Members
HtmlBuilder Class


MindFusion.Diagramming.HtmlBuilder.Scale Property

HtmlBuilder.Scale Property
[image]

Gets or sets the scale factor for the generated image.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Scale { get; set; }

Visual Basic [image] Copy Code

Public Property Scale As Single

Property Value

A float value that specifies the scale factor for the generated diagram image. The default is 100 (indicating no scale transformation).

See Also

HtmlBuilder Members
HtmlBuilder Class


MindFusion.Diagramming.HtmlBuilder.ScrollDownHyperLink Property

HtmlBuilder.ScrollDownHyperLink Property
[image]

Gets or sets the hyperlink assigned to AREA tags generated for the lower scroll arrow of tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ScrollDownHyperLink { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollDownHyperLink As String

Property Value

A string value containing an URL. The default is an empty string.

Remarks

If the value of this property is not an empty string, the HtmlBuilder creates <AREA> tags for the scroll-down button displayed for Scrollable tables. That lets you process requests to scroll the table rows on the server, or just use the scroll buttons as additional hot spots in the image map. If the URL contains the {0} format specifier, it is replaced with the ZIndex of the clicked table.

See Also

HtmlBuilder Members
HtmlBuilder Class


MindFusion.Diagramming.HtmlBuilder.ScrollUpHyperLink Property

HtmlBuilder.ScrollUpHyperLink Property
[image]

Gets or sets the hyperlink assigned to AREA tags generated for the upper scroll arrow of tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ScrollUpHyperLink { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollUpHyperLink As String

Property Value

A string value containing an URL. The default is an empty string.

Remarks

If the value of this property is not an empty string, the HtmlBuilder creates <AREA> tags for the scroll-down button displayed for Scrollable tables. That lets you process requests to scroll the table rows on the server, or just use the scroll buttons as additional hot spots in the image map. If the URL contains the {0} format specifier, it is replaced with the ZIndex of the clicked table.

See Also

HtmlBuilder Members
HtmlBuilder Class


MindFusion.Diagramming.HtmlBuilder Events

HtmlBuilder Events
[image]

Public Events

Name | Description
CreatingArea | Raised just before a new AREA tag is added to the image map.

See Also

HtmlBuilder Class


MindFusion.Diagramming.HtmlBuilder.CreatingArea Event

HtmlBuilder.CreatingArea Event
[image]

Raised just before a new AREA tag is added to the image map.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<AreaEventArgs> CreatingArea

Visual Basic [image] Copy Code

Public Event CreatingArea As EventHandler(Of AreaEventArgs)

Event Data

CreatingArea event handlers receive an argument of type AreaEventArgs. The following AreaEventArgs members provide information relevant to the event:

Member name | Description
AreaTag | The HTML AREA tag created by HtmlBuilder.
Item | The diagram element represented by AreaTag in the image map.
Column | Contains the index of a column if the event is raised for a table cell.
Row | Contains the index of a row if the event is raised for a table cell.

Remarks

You could handle this event in order to insert additional attributes or JavaScript event handlers into the AREA tag. The tag string already ends with a closing ">" when the event is raised, so you must insert any additional attributes one character before the end of the tag string.

Example

The following code adds a JavaScript onClick event handler to the area tag:

C# [image] Copy Code

private void htb_CreatingArea(object sender, AreaEventArgs e)
{
string script = " onClick=\"alert('click click')\"";
e.AreaTag = e.AreaTag.Insert(e.AreaTag.Length - 1, script);
}

Visual Basic [image] Copy Code

Private Sub htb_CreatingArea(ByVal sender As Object, ByVal e As AreaEventArgs)

Dim script As String = " onClick=" + Chr(34) + "alert('click click')" + Chr(34)
e.AreaTag = e.AreaTag.Insert(e.AreaTag.Length - 1, script)

End Sub

See Also

HtmlBuilder Members
HtmlBuilder Class


MindFusion.Diagramming.HyperLinkStyle Enumeration

HyperLinkStyle Enumeration
[image]

Specifies how various export components should treat the HyperLink property of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum HyperLinkStyle

Visual Basic [image] Copy Code

Public Enum HyperLinkStyle

Members

Member name | Description
None | Do not generate hyperlinks.
Text | Generate hyperlinks for the text bounding rectangle.
Shape | Generate hyperlinks that correspond to the item's shape.

Remarks

At this time, members of this enumeration can be assigned to the HyperLinkStyle property of SvgExporter and PdfExporter.

See Also


MindFusion.Diagramming.IDiagramView Interface

IDiagramView Interface
[image]

Controls that display Diagram objects must implement this interface to provide screen resolution information to drawing methods.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface IDiagramView : IResolution

Visual Basic [image] Copy Code

Public Interface IDiagramView
Implements IResolution

See Also

IDiagramView Members


MindFusion.Diagramming.IDiagramView Members

IDiagramView Members
Properties
[image]

Controls that display Diagram objects must implement this interface to provide screen resolution information to drawing methods.

The following tables list the members exposed by the IDiagramView type.

Public Properties

Name | Description
Diagram | Gets the Diagram instance displayed by this control.

See Also

IDiagramView Interface


MindFusion.Diagramming.IDiagramView Properties

IDiagramView Properties
[image]

Public Properties

Name | Description
Diagram | Gets the Diagram instance displayed by this control.

See Also

IDiagramView Interface


MindFusion.Diagramming.IDiagramView.Diagram Property

IDiagramView.Diagram Property
[image]

Gets the Diagram instance displayed by this control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

Diagram Diagram { get; }

Visual Basic [image] Copy Code

ReadOnly Property Diagram As Diagram

Property Value

An instance of the Diagram class.

See Also

IDiagramView Members
IDiagramView Interface


MindFusion.Diagramming.IEffectsProvider Interface

IEffectsProvider Interface
[image]

Visual effects provider.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface IEffectsProvider

Visual Basic [image] Copy Code

Public Interface IEffectsProvider

Inheritors

MindFusion.Diagramming.EffectsProvider

See Also

IEffectsProvider Members


MindFusion.Diagramming.IEffectsProvider Members

IEffectsProvider Members
Methods
[image]

Visual effects provider.

The following tables list the members exposed by the IEffectsProvider type.

Public Methods

Name | Description
GenerateEmboss | Generates an emboss mask for the shape defined by the specified path.
GenerateShadow | Generates a shadow for the shape defined by the specified path.

See Also

IEffectsProvider Interface


MindFusion.Diagramming.IEffectsProvider Methods

IEffectsProvider Methods
[image]

Public Methods

Name | Description
GenerateEmboss | Generates an emboss mask for the shape defined by the specified path.
GenerateShadow | Generates a shadow for the shape defined by the specified path.

See Also

IEffectsProvider Interface


MindFusion.Diagramming.IEffectsProvider.GenerateEmboss Method

IEffectsProvider.GenerateEmboss Method
[image]

Generates an emboss mask for the shape defined by the specified path.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract Bitmap GenerateEmboss (
Diagram diagram,
GraphicsPath path
)

Visual Basic [image] Copy Code

Public MustOverride Function GenerateEmboss ( _
diagram As Diagram, _
path As GraphicsPath _
) As Bitmap

Parameters

diagram

A reference to a Diagram object containing the shape whose emboss mask is being generated.

path

A GraphicsPath that represents of the shape outline.

Return Value

An instance of the .NET Bitmap class containing the generated emboss mask.

See Also

IEffectsProvider Members
IEffectsProvider Interface


MindFusion.Diagramming.IEffectsProvider.GenerateShadow Method

IEffectsProvider.GenerateShadow Method
[image]

Generates a shadow for the shape defined by the specified path.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

Bitmap GenerateShadow (
Diagram diagram,
GraphicsPath path,
int dispersion,
Brush brush
)

Visual Basic [image] Copy Code

Function GenerateShadow( _
diagram As Diagram, _
path As GraphicsPath, _
dispersion As Integer, _
brush As Brush _
) As Bitmap

Parameters

diagram

path

dispersion

brush

Return Value

See Also

IEffectsProvider Members
IEffectsProvider Interface


MindFusion.Diagramming.IItemFactory Interface

IItemFactory Interface
[image]

Defines an interface for constructing IPersists objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface IItemFactory

Visual Basic [image] Copy Code

Public Interface IItemFactory

Inheritors

MindFusion.Diagramming.Diagram

See Also

IItemFactory Members


MindFusion.Diagramming.IItemFactory Members

IItemFactory Members
Properties Methods Events
[image]

Defines an interface for constructing IPersists objects.

The following tables list the members exposed by the IItemFactory type.

Public Properties

Name | Description
ClsidTable | Gets the table with all registered classes.
TypeTable | Gets the table with all registered classes.

Public Methods

Name | Description
CreateItem | Overloaded. Creates a new object given its class or string identifier.

Public Events

Name | Description
InstantiateItem | Lets external classes handle item instantiation.

See Also

IItemFactory Interface


MindFusion.Diagramming.IItemFactory Methods

IItemFactory Methods
[image]

Public Methods

Name | Description
CreateItem | Overloaded. Creates a new object given its class or string identifier.

See Also

IItemFactory Interface


MindFusion.Diagramming.IItemFactory.CreateItem Method

IItemFactory.CreateItem Method
[image]

Creates a new object given its class or string identifier.

Overload List

Name | Description
IItemFactory.CreateItem (Int32) | Creates a new object given its class id.
IItemFactory.CreateItem (String) | Creates a new object given its item class string identifier.

See Also

IItemFactory Members
IItemFactory Interface


MindFusion.Diagramming.IItemFactory.CreateItem Method (Int32)

IItemFactory.CreateItem Method (Int32)
See Also
[image]

Creates a new object given its class id.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract IPersists CreateItem (
int clsId
)

Visual Basic [image] Copy Code

Public MustOverride Function CreateItem ( _
clsId As Integer _
) As IPersists

Parameters

clsId

The class id of the item to create.

Return Value

An instance of a class implementing the IPersists interface corresponding to the class with the specified id.

See Also

CreateItem Method Overload List
IItemFactory Members
IItemFactory Interface


MindFusion.Diagramming.IItemFactory.CreateItem Method (String)

IItemFactory.CreateItem Method (String)
See Also
[image]

Creates a new object given its item class string identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract IPersists CreateItem (
string itemClass
)

Visual Basic [image] Copy Code

Public MustOverride Function CreateItem ( _
itemClass As String _
) As IPersists

Parameters

itemClass

The class string id of the item to create.

Return Value

An instance of a class implementing the IPersists interface corresponding to the class with the specified id.

See Also

CreateItem Method Overload List
IItemFactory Members
IItemFactory Interface


MindFusion.Diagramming.IItemFactory Properties

IItemFactory Properties
[image]

Public Properties

Name | Description
ClsidTable | Gets the table with all registered classes.
TypeTable | Gets the table with all registered classes.

See Also

IItemFactory Interface


MindFusion.Diagramming.IItemFactory.ClsidTable Property

IItemFactory.ClsidTable Property
[image]

Gets the table with all registered classes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

Hashtable ClsidTable { get; }

Visual Basic [image] Copy Code

ReadOnly Property ClsidTable As Hashtable

Property Value

An instance of the .NET Hashtable class that represents a map between the class types and the corresponding registered classes.

See Also

IItemFactory Members
IItemFactory Interface


MindFusion.Diagramming.IItemFactory.TypeTable Property

IItemFactory.TypeTable Property
[image]

Gets the table with all registered classes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

Hashtable TypeTable { get; }

Visual Basic [image] Copy Code

ReadOnly Property TypeTable As Hashtable

Property Value

An instance of the .NET Hashtable class that represents a map between the class string identifiers and the corresponding registered classes.

See Also

IItemFactory Members
IItemFactory Interface


MindFusion.Diagramming.IItemFactory Events

IItemFactory Events
[image]

Public Events

Name | Description
InstantiateItem | Lets external classes handle item instantiation.

See Also

IItemFactory Interface


MindFusion.Diagramming.IItemFactory.InstantiateItem Event

IItemFactory.InstantiateItem Event
[image]

Lets external classes handle item instantiation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

event EventHandler<InstantiateItemEventArgs> InstantiateItem

Visual Basic [image] Copy Code

Event InstantiateItem As EventHandler(Of InstantiateItemEventArgs)

See Also

IItemFactory Members
IItemFactory Interface


MindFusion.Diagramming.ILinkRouter Interface

ILinkRouter Interface
[image]

Defines methods that should be implemented by a link-router component. The control calls them when a new link path should be set in response to changes in the diagram, such as adding or modifying nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface ILinkRouter

Visual Basic [image] Copy Code

Public Interface ILinkRouter

Inheritors

MindFusion.Diagramming.GridRouter
MindFusion.Diagramming.QuickRouter

See Also

ILinkRouter Members


MindFusion.Diagramming.ILinkRouter Members

ILinkRouter Members
Properties Methods
[image]

Defines methods that should be implemented by a link-router component. The control calls them when a new link path should be set in response to changes in the diagram, such as adding or modifying nodes.

The following tables list the members exposed by the ILinkRouter type.

Public Properties

Name | Description
Diagram | Gets or sets the diagram this router is associated with.

Public Methods

Name | Description
Resume | Called when the control ends a batch update operation that might affect many links.
RouteLink | Called when a single link must be routed.
RouteLinks | Called when more than one link must be routed.
Suspend | Called when the control starts a batch update operation that might affect many links. Implementations might collect the links specified through RouteLink and RouteLinks calls and defer finding their paths for when Resume is called.

See Also

ILinkRouter Interface


MindFusion.Diagramming.ILinkRouter Methods

ILinkRouter Methods
[image]

Public Methods

Name | Description
Resume | Called when the control ends a batch update operation that might affect many links.
RouteLink | Called when a single link must be routed.
RouteLinks | Called when more than one link must be routed.
Suspend | Called when the control starts a batch update operation that might affect many links. Implementations might collect the links specified through RouteLink and RouteLinks calls and defer finding their paths for when Resume is called.

See Also

ILinkRouter Interface


MindFusion.Diagramming.ILinkRouter.Resume Method

ILinkRouter.Resume Method
[image]

Called when the control ends a batch update operation that might affect many links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void Resume (
bool routeDeferredLinks
)

Visual Basic [image] Copy Code

Sub Resume( _
routeDeferredLinks As Boolean _
)

Parameters

routeDeferredLinks
true if the links should be routed, otherwise false.

See Also

ILinkRouter Members
ILinkRouter Interface


MindFusion.Diagramming.ILinkRouter.RouteLink Method

ILinkRouter.RouteLink Method
[image]

Called when a single link must be routed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract bool RouteLink (
DiagramLink link
)

Visual Basic [image] Copy Code

Public MustOverride Function RouteLink ( _
link As DiagramLink _
) As Boolean

Parameters

link
A DiagramLink object representing the link.

Return Value

true if a path has been found, otherwise false.

See Also

ILinkRouter Members
ILinkRouter Interface


MindFusion.Diagramming.ILinkRouter.RouteLinks Method

ILinkRouter.RouteLinks Method
[image]

Called when more than one link must be routed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract void RouteLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Public MustOverride Sub RouteLinks ( _
links As DiagramLinkCollection _
)

Parameters

links
A DiagramLinkCollection containing the links that should be routed.

See Also

ILinkRouter Members
ILinkRouter Interface


MindFusion.Diagramming.ILinkRouter.Suspend Method

ILinkRouter.Suspend Method
[image]

Called when the control starts a batch update operation that might affect many links. Implementations might collect the links specified through RouteLink and RouteLinks calls and defer finding their paths for when Resume is called.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void Suspend ()

Visual Basic [image] Copy Code

Sub Suspend ()

See Also

ILinkRouter Members
ILinkRouter Interface


MindFusion.Diagramming.ILinkRouter Properties

ILinkRouter Properties
[image]

Public Properties

Name | Description
Diagram | Gets or sets the diagram this router is associated with.

See Also

ILinkRouter Interface


MindFusion.Diagramming.ILinkRouter.Diagram Property

ILinkRouter.Diagram Property
[image]

Gets or sets the diagram this router is associated with.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

Diagram Diagram { get; set; }

Visual Basic [image] Copy Code

Property Diagram As Diagram

Property Value

See Also

ILinkRouter Members
ILinkRouter Interface


MindFusion.Diagramming.IMeasureUnitConverter Interface

IMeasureUnitConverter Interface
[image]

Provides means to convert between cross-type measure units.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface IMeasureUnitConverter

Visual Basic [image] Copy Code

Public Interface IMeasureUnitConverter

See Also

IMeasureUnitConverter Members


MindFusion.Diagramming.IMeasureUnitConverter Members

IMeasureUnitConverter Members
Methods
[image]

Provides means to convert between cross-type measure units.

The following tables list the members exposed by the IMeasureUnitConverter type.

Public Methods

Name | Description
CanConvertFrom | Returns a value indicating whether this converter can convert from the specified target unit to the specified source unit.
CanConvertTo | Returns a value indicating whether this converter can convert from the specified source unit to the specified target unit.
ConvertFrom | Converts a value from the specified source unit to the specified target unit.
ConvertTo | Converts a value from the specified source unit to the specified target unit.

See Also

IMeasureUnitConverter Interface


MindFusion.Diagramming.IMeasureUnitConverter Methods

IMeasureUnitConverter Methods
[image]

Public Methods

Name | Description
CanConvertFrom | Returns a value indicating whether this converter can convert from the specified target unit to the specified source unit.
CanConvertTo | Returns a value indicating whether this converter can convert from the specified source unit to the specified target unit.
ConvertFrom | Converts a value from the specified source unit to the specified target unit.
ConvertTo | Converts a value from the specified source unit to the specified target unit.

See Also

IMeasureUnitConverter Interface


MindFusion.Diagramming.IMeasureUnitConverter.CanConvertFrom Method

IMeasureUnitConverter.CanConvertFrom Method
[image]

Returns a value indicating whether this converter can convert from the specified target unit to the specified source unit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

bool CanConvertFrom (
MeasureUnit targetUnit,
MeasureUnit sourceUnit
)

Visual Basic [image] Copy Code

Function CanConvertFrom( _
targetUnit As MeasureUnit, _
sourceUnit As MeasureUnit _
) As Boolean

Parameters

targetUnit

The target MeasureUnit instance.

sourceUnit

The source MeasureUnit instance.

Return Value

true if conversion between the specified units is supported, or false otherwise.

See Also

IMeasureUnitConverter Members
IMeasureUnitConverter Interface


MindFusion.Diagramming.IMeasureUnitConverter.CanConvertTo Method

IMeasureUnitConverter.CanConvertTo Method
[image]

Returns a value indicating whether this converter can convert from the specified source unit to the specified target unit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

bool CanConvertTo (
MeasureUnit sourceUnit,
MeasureUnit targetUnit
)

Visual Basic [image] Copy Code

Function CanConvertTo( _
sourceUnit As MeasureUnit, _
targetUnit As MeasureUnit _
) As Boolean

Parameters

sourceUnit

The source MeasureUnit instance.

targetUnit

The target MeasureUnit instance.

Return Value

true if conversion between the specified units is supported, or false otherwise.

See Also

IMeasureUnitConverter Members
IMeasureUnitConverter Interface


MindFusion.Diagramming.IMeasureUnitConverter.ConvertFrom Method

IMeasureUnitConverter.ConvertFrom Method
[image]

Converts a value from the specified source unit to the specified target unit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

double ConvertFrom (
MeasureUnit targetUnit,
MeasureUnit sourceUnit,
double value,
Axis axis,
Object param
)

Visual Basic [image] Copy Code

Function ConvertFrom( _
targetUnit As MeasureUnit, _
sourceUnit As MeasureUnit, _
value As Double, _
axis As Axis, _
param As Object _
) As Double

Parameters

targetUnit

The target MeasureUnit instance.

sourceUnit

The source MeasureUnit instance.

value

A double value that should be converted.

axis

A member of the Axis enumeration specifying whether the value represents a horizontal or a vertical dimension.

param

An object providing device resolution information.

Return Value

The converted value.

Remarks

param can be set to either Graphics, IGraphics, DiagramView or IResolution object.

See Also

IMeasureUnitConverter Members
IMeasureUnitConverter Interface


MindFusion.Diagramming.IMeasureUnitConverter.ConvertTo Method

IMeasureUnitConverter.ConvertTo Method
[image]

Converts a value from the specified source unit to the specified target unit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

double ConvertTo (
MeasureUnit sourceUnit,
MeasureUnit targetUnit,
double value,
Axis axis,
Object param
)

Visual Basic [image] Copy Code

Function ConvertTo( _
sourceUnit As MeasureUnit, _
targetUnit As MeasureUnit, _
value As Double, _
axis As Axis, _
param As Object _
) As Double

Parameters

sourceUnit

The source MeasureUnit instance.

targetUnit

The target MeasureUnit instance.

value

A double value that should be converted.

axis

A member of the Axis enumeration specifying whether the value represents a horizontal or a vertical dimension.

param

An object providing device resolution information.

Return Value

The converted value.

Remarks

param can be set to either Graphics, IGraphics, DiagramView or IResolution object.

See Also

IMeasureUnitConverter Members
IMeasureUnitConverter Interface


MindFusion.Diagramming.InplaceEditable Interface

InplaceEditable Interface
[image]

Represents an in-place editable object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface InplaceEditable

Visual Basic [image] Copy Code

Public Interface InplaceEditable

Inheritors

MindFusion.Diagramming.BarcodeNode
MindFusion.Diagramming.ContainerNode
MindFusion.Diagramming.DiagramLink
MindFusion.Diagramming.LinkLabel
MindFusion.Diagramming.ShapeNode
MindFusion.Diagramming.TableNode
MindFusion.Diagramming.TableNode.Cell
MindFusion.Diagramming.TreeViewItem
MindFusion.Diagramming.TreeViewNode

See Also

InplaceEditable Members


MindFusion.Diagramming.InplaceEditable Members

InplaceEditable Members
Methods
[image]

Represents an in-place editable object.

The following tables list the members exposed by the InplaceEditable type.

Public Methods

Name | Description
GetEditRect | Returns the rectangle where the in-place editing control appears (in document coordinates).
GetTextToEdit | Returns the text of the object which should be displayed initially when the object is in-place edited.
SetEditedText | Sets the edited text to the object after the in-place editing operation has been completed successfully.

See Also

InplaceEditable Interface


MindFusion.Diagramming.InplaceEditable Methods

InplaceEditable Methods
[image]

Public Methods

Name | Description
GetEditRect | Returns the rectangle where the in-place editing control appears (in document coordinates).
GetTextToEdit | Returns the text of the object which should be displayed initially when the object is in-place edited.
SetEditedText | Sets the edited text to the object after the in-place editing operation has been completed successfully.

See Also

InplaceEditable Interface


MindFusion.Diagramming.InplaceEditable.GetEditRect Method

InplaceEditable.GetEditRect Method
[image]

Returns the rectangle where the in-place editing control appears (in document coordinates).

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

RectangleF GetEditRect (
DiagramItem item,
PointF mousePosition
)

Visual Basic [image] Copy Code

Function GetEditRect( _
item As DiagramItem, _
mousePosition As PointF _
) As RectangleF

Parameters

item

The item being edited.

mousePosition
A PointF instance specifying the mouse position.

Return Value

A .NET RectangleF instance that represents the destination rectangle of the in-place editing control.

See Also

InplaceEditable Members
InplaceEditable Interface


MindFusion.Diagramming.InplaceEditable.GetTextToEdit Method

InplaceEditable.GetTextToEdit Method
[image]

Returns the text of the object which should be displayed initially when the object is in-place edited.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

string GetTextToEdit ()

Visual Basic [image] Copy Code

Function GetTextToEdit () As String

Return Value

A string value that represents the initial contents of the in-place editing box.

See Also

InplaceEditable Members
InplaceEditable Interface


MindFusion.Diagramming.InplaceEditable.SetEditedText Method

InplaceEditable.SetEditedText Method
[image]

Sets the edited text to the object after the in-place editing operation has been completed successfully.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void SetEditedText (
string newText
)

Visual Basic [image] Copy Code

Sub SetEditedText( _
newText As String _
)

Parameters

newText

The new text of the in-place edited object.

See Also

InplaceEditable Members
InplaceEditable Interface


MindFusion.Diagramming.InstantiateItemEventArgs Class

InstantiateItemEventArgs Class
[image]

Contains the arguments passed to the InstantiateItem event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class InstantiateItemEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class InstantiateItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.InstantiateItemEventArgs

See Also

InstantiateItemEventArgs Members


MindFusion.Diagramming.InstantiateItemEventArgs Members

InstantiateItemEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the InstantiateItem event handlers.

The following tables list the members exposed by the InstantiateItemEventArgs type.

Public Constructors

Name | Description
InstantiateItemEventArgs | Initializes a new instance of the InstantiateItemEventArgs class.

Public Properties

Name | Description
Item | Gets or sets a reference to the created diagram item.
ItemClass | Gets the item class identifier.

See Also

InstantiateItemEventArgs Class


MindFusion.Diagramming.InstantiateItemEventArgs Constructor

InstantiateItemEventArgs Constructor
[image]

Initializes a new instance of the InstantiateItemEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public InstantiateItemEventArgs (
string itemClass
)

Visual Basic [image] Copy Code

Public New ( _
itemClass As String _
)

Parameters

itemClass

The class string identifier specifying the type of the new item.

See Also

InstantiateItemEventArgs Class


MindFusion.Diagramming.InstantiateItemEventArgs Properties

InstantiateItemEventArgs Properties
[image]

Public Properties

Name | Description
Item | Gets or sets a reference to the created diagram item.
ItemClass | Gets the item class identifier.

See Also

InstantiateItemEventArgs Class


MindFusion.Diagramming.InstantiateItemEventArgs.Item Property

InstantiateItemEventArgs.Item Property
[image]

Gets or sets a reference to the created diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem Item { get; set; }

Visual Basic [image] Copy Code

Public Property Item As DiagramItem

Property Value

An instance of the DiagramItem class.

See Also

InstantiateItemEventArgs Members
InstantiateItemEventArgs Class


MindFusion.Diagramming.InstantiateItemEventArgs.ItemClass Property

InstantiateItemEventArgs.ItemClass Property
[image]

Gets the item class identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ItemClass { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ItemClass As String

Property Value

A string value specifying the item class identifier.

See Also

InstantiateItemEventArgs Members
InstantiateItemEventArgs Class


MindFusion.Diagramming.InteractionState Class

InteractionState Class
Remarks See Also
[image]

Encapsulates the current state of user interaction with the control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class InteractionState

Visual Basic [image] Copy Code

Public Class InteractionState

Remarks

Return an instance of this class from the StartDraw method of a custom Behavior class.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.InteractionState

See Also

InteractionState Members


MindFusion.Diagramming.InteractionState Members

InteractionState Members
Constructors Properties Methods
[image]

Encapsulates the current state of user interaction with the control.

The following tables list the members exposed by the InteractionState type.

Public Constructors

Name | Description
InteractionState | Initializes a new instance of the InteractionState class.

Public Properties

Name | Description
Action | Gets the type of Action currently performed by the user in the Diagram.
AdjustmentHandle | Gets the adjustment handle being dragged by the user.
CurrentItem | Gets a reference to the DiagramItem to be created or modified.
CurrentPoint | Gets the current location of the mouse pointer.
Diagram | Gets the current Diagram instance.
InvalidRect | Gets or sets the area that should be repainted.
LinkTarget | Gets or sets the current target node when a link is being modified.
MouseMoved | Gets or sets a value indicating whether the mouse pointer has moved since the user pressed down the mouse button.
SkipSavingState | Gets a value indicating whether diagram items should skip storing their state for subsequent cancel.
StartPoint | Gets the mouse position where the interaction started.

Public Methods

Name | Description
Cancel | Cancels the user interaction.
CancelNow | Instruct the interaction to terminate on the next pass.
Complete | This method is invoked to complete the interaction, usually when the user releases the left mouse button.
IsAllowed | Checks whether the current interaction can be completed at the specified point.
IsCompleting | Returns whether the interaction has been completed successfully.
SetHandleIndex | Sets the adjustment handle tracked by this object to the specified handle.
SetItemDeleted | Notifies the interaction that its associated diagram item has been deleted.
ShouldCancelDrag | Gets a value indicating whether the interaction should terminate on the next pass.
Start | This method is invoked in the beginning of the interaction, usually when the user presses the left mouse button over a modification handle.
Update | This method is invoked to update the interaction state, usually in response to the user moving the mouse after the modification has started.
ValidateAndSetCursor | Sets the cursor depending on whether the interaction can be completed at the specified point or not.

See Also

InteractionState Class


MindFusion.Diagramming.InteractionState Constructor

InteractionState Constructor
[image]

Initializes a new instance of the InteractionState class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public InteractionState (
DiagramItem currentItem,
AdjustmentHandle adjustmentHandle,
Action action
)

Visual Basic [image] Copy Code

Public New ( _
currentItem As DiagramItem, _
adjustmentHandle As AdjustmentHandle, _
action As Action _
)

Parameters

currentItem

The DiagramItem to be created or modified.

adjustmentHandle

The selection handle to be dragged with the mouse, defines what kind of modification to perform.

action

One of the Action enumeration values, specifying what kind of action to perform.

See Also

InteractionState Class


MindFusion.Diagramming.InteractionState Methods

InteractionState Methods
[image]

Public Methods

Name | Description
Cancel | Cancels the user interaction.
CancelNow | Instruct the interaction to terminate on the next pass.
Complete | This method is invoked to complete the interaction, usually when the user releases the left mouse button.
IsAllowed | Checks whether the current interaction can be completed at the specified point.
IsCompleting | Returns whether the interaction has been completed successfully.
SetHandleIndex | Sets the adjustment handle tracked by this object to the specified handle.
SetItemDeleted | Notifies the interaction that its associated diagram item has been deleted.
ShouldCancelDrag | Gets a value indicating whether the interaction should terminate on the next pass.
Start | This method is invoked in the beginning of the interaction, usually when the user presses the left mouse button over a modification handle.
Update | This method is invoked to update the interaction state, usually in response to the user moving the mouse after the modification has started.
ValidateAndSetCursor | Sets the cursor depending on whether the interaction can be completed at the specified point or not.

See Also

InteractionState Class


MindFusion.Diagramming.InteractionState.Cancel Method

InteractionState.Cancel Method
[image]

Cancels the user interaction.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Cancel (
Diagram diagram
)

Visual Basic [image] Copy Code

Public Sub Cancel ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram, at which the action is performed.

Remarks

Call this method to cancel interaction, usually in response to the user clicking the right mouse button while dragging.

See Also

InteractionState Members
InteractionState Class
CancelNow


MindFusion.Diagramming.InteractionState.CancelNow Method

InteractionState.CancelNow Method
[image]

Instruct the interaction to terminate on the next pass.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void CancelNow ()

Visual Basic [image] Copy Code

Public Sub CancelNow ()

See Also

InteractionState Members
InteractionState Class
Cancel


MindFusion.Diagramming.InteractionState.Complete Method

InteractionState.Complete Method
[image]

This method is invoked to complete the interaction, usually when the user releases the left mouse button.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Complete (
PointF point,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Sub Complete ( _
point As PointF, _
diagram As Diagram _
)

Parameters

point

A .NET PointF instance indicating the location of the cursor, in document coordinates.

diagram
The Diagram, at which the action is performed.

See Also

InteractionState Members
InteractionState Class
IsCompleting


MindFusion.Diagramming.InteractionState.IsAllowed Method

InteractionState.IsAllowed Method
[image]

Checks whether the current interaction can be completed at the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsAllowed (
PointF point
)

Visual Basic [image] Copy Code

Public Function IsAllowed( _
point As PointF _
) As Boolean

Parameters

point

A .NET PointF instance indicating the location of the cursor, in document coordinates.

Return Value

true if the action can be completed at point; otherwise, false.

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.IsCompleting Method

InteractionState.IsCompleting Method
[image]

Returns whether the interaction has been completed successfully.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsCompleting ()

Visual Basic [image] Copy Code

Public Function IsCompleting () As Boolean

Return Value

true if the interaction has been completed successfully; otherwise, false.

See Also

InteractionState Members
InteractionState Class
Complete


MindFusion.Diagramming.InteractionState.SetHandleIndex Method

InteractionState.SetHandleIndex Method
[image]

Sets the adjustment handle tracked by this object to the specified handle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetHandleIndex (
AdjustmentHandle newHandle
)

Visual Basic [image] Copy Code

Public Sub SetHandleIndex( _
newHandle As AdjustmentHandle _
)

Parameters

newHandle

An AdjustmentHandle instance representing the modified handle.

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.SetItemDeleted Method

InteractionState.SetItemDeleted Method
[image]

Notifies the interaction that its associated diagram item has been deleted.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetItemDeleted ()

Visual Basic [image] Copy Code

Public Sub SetItemDeleted ()

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.ShouldCancelDrag Method

InteractionState.ShouldCancelDrag Method
[image]

Gets a value indicating whether the interaction should terminate on the next pass.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ShouldCancelDrag ()

Visual Basic [image] Copy Code

Public Function ShouldCancelDrag () As Boolean

Return Value

true if the interaction should terminate; otherwise, false.

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.Start Method

InteractionState.Start Method
[image]

This method is invoked in the beginning of the interaction, usually when the user presses the left mouse button over a modification handle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Start (
PointF point,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Sub Start ( _
point As PointF, _
diagram As Diagram _
)

Parameters

point

A .NET PointF instance indicating the location of the cursor, in document coordinates.

diagram
The Diagram, at which the interaction is performed.

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.Update Method

InteractionState.Update Method
[image]

This method is invoked to update the interaction state, usually in response to the user moving the mouse after the modification has started.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Update (
PointF point,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Function Update ( _
point As PointF, _
diagram As Diagram _
) As Boolean

Parameters

point

A .NET PointF instance indicating the location of the cursor, in document coordinates.

diagram
The Diagram, at which the interaction is performed.

Return Value

true if the update has been successful; otherwise, false.

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.ValidateAndSetCursor Method

InteractionState.ValidateAndSetCursor Method
[image]

Sets the cursor depending on whether the interaction can be completed at the specified point or not.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CursorHint ValidateAndSetCursor (
PointF point,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Function ValidateAndSetCursor ( _
point As PointF, _
diagram As Diagram _
) As CursorHint

Parameters

point

A .NET PointF instance indicating the location of the cursor, in document coordinates.

diagram

The Diagram, at which the interaction is performed.

Return Value

One of the CursorHint enumeration values, which is used by DiagramView to set its Cursor property. The method might return CursorHint.DontChange and the cursor will be left as it is.

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState Properties

InteractionState Properties
[image]

Public Properties

Name | Description
Action | Gets the type of Action currently performed by the user in the Diagram.
AdjustmentHandle | Gets the adjustment handle being dragged by the user.
CurrentItem | Gets a reference to the DiagramItem to be created or modified.
CurrentPoint | Gets the current location of the mouse pointer.
Diagram | Gets the current Diagram instance.
InvalidRect | Gets or sets the area that should be repainted.
LinkTarget | Gets or sets the current target node when a link is being modified.
MouseMoved | Gets or sets a value indicating whether the mouse pointer has moved since the user pressed down the mouse button.
SkipSavingState | Gets a value indicating whether diagram items should skip storing their state for subsequent cancel.
StartPoint | Gets the mouse position where the interaction started.

See Also

InteractionState Class


MindFusion.Diagramming.InteractionState.Action Property

InteractionState.Action Property
[image]

Gets the type of Action currently performed by the user in the Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Action Action { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Action As Action

Property Value

A member of the Action enumeration that specifies what kind of action the user currently performs on the Diagram.

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.AdjustmentHandle Property

InteractionState.AdjustmentHandle Property
[image]

Gets the adjustment handle being dragged by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AdjustmentHandle AdjustmentHandle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AdjustmentHandle As AdjustmentHandle

Property Value

An AdjustmentHandle object representing the dragged handle.

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.CurrentItem Property

InteractionState.CurrentItem Property
[image]

Gets a reference to the DiagramItem to be created or modified.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem CurrentItem { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CurrentItem As DiagramItem

Property Value

An instance of the DiagramItem class.

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.CurrentPoint Property

InteractionState.CurrentPoint Property
[image]

Gets the current location of the mouse pointer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointF CurrentPoint { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CurrentPoint As PointF

Property Value

A .NET PointF instance that specifies the current location of the cursor, in document coordinates.

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.Diagram Property

InteractionState.Diagram Property
[image]

Gets the current Diagram instance.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Diagram Diagram { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Diagram As Diagram

Property Value

An instance of the Diagram class.

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.InvalidRect Property

InteractionState.InvalidRect Property
[image]

Gets or sets the area that should be repainted.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF InvalidRect { get; set; }

Visual Basic [image] Copy Code

Public Property InvalidRect As RectangleF

Property Value

A RectangleF specifying a rectangular region of the diagram that should be repainted.

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.LinkTarget Property

InteractionState.LinkTarget Property
[image]

Gets or sets the current target node when a link is being modified.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode LinkTarget { get; set; }

Visual Basic [image] Copy Code

Public Property LinkTarget As DiagramNode

Property Value

A DiagramNode that the currently modified DiagramLink should connect to if the interaction completes at the current mouse position.

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.MouseMoved Property

InteractionState.MouseMoved Property
[image]

Gets or sets a value indicating whether the mouse pointer has moved since the user pressed down the mouse button.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool MouseMoved { get; set; }

Visual Basic [image] Copy Code

Public Property MouseMoved As Boolean

Property Value

true is the mouse has moved; otherwise, false.

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.SkipSavingState Property

InteractionState.SkipSavingState Property
[image]

Gets a value indicating whether diagram items should skip storing their state for subsequent cancel.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SkipSavingState { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SkipSavingState As Boolean

Property Value

A boolean value.

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.StartPoint Property

InteractionState.StartPoint Property
[image]

Gets the mouse position where the interaction started.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointF StartPoint { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StartPoint As PointF

Property Value

A PointF specifying the mouse position where the user started to draw or modify an item.

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InternalUtils Class

InternalUtils Class
Remarks See Also
[image]

Contains common helper methods, specific to MvcDiagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class InternalUtils

Visual Basic [image] Copy Code

Public NotInheritable Class InternalUtils

Remarks

This class supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.InternalUtils

See Also

InternalUtils Members


MindFusion.Diagramming.InternalUtils Members

InternalUtils Members
Methods
[image]

Contains common helper methods, specific to MvcDiagram.

The following tables list the members exposed by the InternalUtils type.

Public Methods

Name | Description
AddToRect | Inflate/deflate the specified rectangle with the specified values.
ApproxBezier | Approximates the specified Bйzier curve with a polyline. The specified quality parameter varies in the interval [1, ...) and is proportional to the number of points in the resulting polyline.
ApproxEllipse | Approximates the ellipse contained in the specified rectangle with a polyline. The specified quality parameter varies in the interval [1, ...) and is proportional to the number of points in the resulting polyline.
Blend | Creates a normalized [0..1] color blend out of the specified colors and positions.
CheckIntersect | Checks if the specified rectangle and circle intersect.
ConvertUnits | Converts a value between different measure units.
CreateEllipticRgn | Creates an elliptic region.
CreatePolygonRgn | Creates a polygonal region.
CreateRoundRectRgn | Creates a round rectangle region.
Distance | Calculates the distance between the specified points.
DistanceAlongLength | Returns the distance from the specified point to the start of the specified path along the path's length.
DistanceSq | Calculates the square of the distance between the specified points.
DistToPolyline | Overloaded.
DistToRectPoint | Returns the nearest to pt point that lies on the outline of rectangle.
DrawExpandButton | Renders an expand/collapse button on the specified IGraphics canvas.
DrawRect | Draws the specified rectangle using the specified pen for stroking and the specified brush for filling.
DrawSelHandles | Draws adjustment handles.
GetEllipseIntr | Calculate the intersection point between the ellipse with the specified bounds and the line segment defined by the specified points.
GetLoadedAssembly | Gets the specified assembly.
GetLoadedType | Overloaded.
GetRoundRect | Creates a graphics path of a rounded rectangle with the specified dimensions and round radius.
LinearGradient | Overloaded. Creates a linear gradient brush with the specified settings.
MatchPointsMinLength | Returns an array of node anchor points which match current node links anchor point
MidPoint | Returns the middle point of the segment defined by the specified points.
MinDistToRect | Calculates the minimum distance between a given point and a given rectangle.
NormalizeRect | Overloaded. Normalizes the specified rectangle.
OffsetPath | Moves a path by the specified offset.
PointAlongLength | Returns a point lying at the specified distance from the start point along the path specified via the collection of points.
PointInRect | Overloaded. Checks whether the specified rectangle contains the specified point.
RectangleToPoints | Returns the points of the specified rectangle as an array.
SetBrushAlpha | Sets the alpha channel value for all color properties of the specified brush.
UnionNonEmptyRects | Returns the smallest possible rectangle containing both of the specified rectangles, but only if the rectangles are non-empty.
UnionRects | Returns the smallest possible rectangle containing both of the specified rectangles.

See Also

InternalUtils Class


MindFusion.Diagramming.InternalUtils Methods

InternalUtils Methods
[image]

Public Methods

Name | Description
AddToRect | Inflate/deflate the specified rectangle with the specified values.
ApproxBezier | Approximates the specified Bйzier curve with a polyline. The specified quality parameter varies in the interval [1, ...) and is proportional to the number of points in the resulting polyline.
ApproxEllipse | Approximates the ellipse contained in the specified rectangle with a polyline. The specified quality parameter varies in the interval [1, ...) and is proportional to the number of points in the resulting polyline.
Blend | Creates a normalized [0..1] color blend out of the specified colors and positions.
CheckIntersect | Checks if the specified rectangle and circle intersect.
ConvertUnits | Converts a value between different measure units.
CreateEllipticRgn | Creates an elliptic region.
CreatePolygonRgn | Creates a polygonal region.
CreateRoundRectRgn | Creates a round rectangle region.
Distance | Calculates the distance between the specified points.
DistanceAlongLength | Returns the distance from the specified point to the start of the specified path along the path's length.
DistanceSq | Calculates the square of the distance between the specified points.
DistToPolyline | Overloaded.
DistToRectPoint | Returns the nearest to pt point that lies on the outline of rectangle.
DrawExpandButton | Renders an expand/collapse button on the specified IGraphics canvas.
DrawRect | Draws the specified rectangle using the specified pen for stroking and the specified brush for filling.
DrawSelHandles | Draws adjustment handles.
GetEllipseIntr | Calculate the intersection point between the ellipse with the specified bounds and the line segment defined by the specified points.
GetLoadedAssembly | Gets the specified assembly.
GetLoadedType | Overloaded.
GetRoundRect | Creates a graphics path of a rounded rectangle with the specified dimensions and round radius.
LinearGradient | Overloaded. Creates a linear gradient brush with the specified settings.
MatchPointsMinLength | Returns an array of node anchor points which match current node links anchor point
MidPoint | Returns the middle point of the segment defined by the specified points.
MinDistToRect | Calculates the minimum distance between a given point and a given rectangle.
NormalizeRect | Overloaded. Normalizes the specified rectangle.
OffsetPath | Moves a path by the specified offset.
PointAlongLength | Returns a point lying at the specified distance from the start point along the path specified via the collection of points.
PointInRect | Overloaded. Checks whether the specified rectangle contains the specified point.
RectangleToPoints | Returns the points of the specified rectangle as an array.
SetBrushAlpha | Sets the alpha channel value for all color properties of the specified brush.
UnionNonEmptyRects | Returns the smallest possible rectangle containing both of the specified rectangles, but only if the rectangles are non-empty.
UnionRects | Returns the smallest possible rectangle containing both of the specified rectangles.

See Also

InternalUtils Class


MindFusion.Diagramming.InternalUtils.AddToRect Method

InternalUtils.AddToRect Method
[image]

Inflate/deflate the specified rectangle with the specified values.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void AddToRect (
ref RectangleF rect,
float w,
float h
)

Visual Basic [image] Copy Code

Public Shared Sub AddToRect( _
ByRef rect As RectangleF, _
w As Single, _
h As Single _
)

Parameters

rect

The .NET RectangleF instance that must be modified.

w

The increment/decrement of the rectangle width.

h

The increment/decrement of the rectangle height.

Remarks

This method supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.ApproxBezier Method

InternalUtils.ApproxBezier Method
[image]

Approximates the specified Bйzier curve with a polyline. The specified quality parameter varies in the interval [1, ...) and is proportional to the number of points in the resulting polyline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static PointCollection ApproxBezier (
PointF[] points,
int startIdx,
int quality
)

Visual Basic [image] Copy Code

Public Shared Function ApproxBezier ( _
points As PointF(), _
startIdx As Integer, _
quality As Integer _
) As PointCollection

Parameters

points

An array of PointF objects, which defines the Bйzier curve.

startIdx
The index of the first point to be processed in points.
quality

The quality of the produced approximation.

Return Value

An instance of the PointCollection class containing the points of the calculated approximation.

Remarks

This method supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.ApproxEllipse Method

InternalUtils.ApproxEllipse Method
[image]

Approximates the ellipse contained in the specified rectangle with a polyline. The specified quality parameter varies in the interval [1, ...) and is proportional to the number of points in the resulting polyline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static PointCollection ApproxEllipse (
RectangleF rect,
int quality
)

Visual Basic [image] Copy Code

Public Shared Function ApproxEllipse ( _
rect As RectangleF, _
quality As Integer _
) As PointCollection

Parameters

rect

A RectangleF instance, which defines the source ellipse.

quality

The quality of the produced approximation.

Return Value

An instance of the PointCollection class containing the points of the calculated approximation.

Remarks

This method supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.Blend Method

InternalUtils.Blend Method
[image]

Creates a normalized [0..1] color blend out of the specified colors and positions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static ColorBlend Blend (
Object[] positionsAndColors
)

Visual Basic [image] Copy Code

Public Shared Function Blend( _
positionsAndColors() As Object _
) As ColorBlend

Parameters

positionsAndColors
An alternating sequence of float and Color pairs where each pair defines a gradient stop. The positions in the sequence need to be in ascending order.

Return Value

A ColorBlend instance corresponding to the specified colors and positions.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.CheckIntersect Method

InternalUtils.CheckIntersect Method
[image]

Checks if the specified rectangle and circle intersect.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static bool CheckIntersect (
PointF pt,
RectangleF rc,
float rad
)

Visual Basic [image] Copy Code

Public Shared Function CheckIntersect( _
pt As PointF, _
rc As RectangleF, _
rad As Single _
) As Boolean

Parameters

pt

rc

rad

Return Value

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.ConvertUnits Method

InternalUtils.ConvertUnits Method
[image]

Converts a value between different measure units.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float ConvertUnits (
float value,
MeasureUnit srcUnit,
MeasureUnit targetUnit
)

Visual Basic [image] Copy Code

Public Shared Function ConvertUnits( _
value As Single, _
srcUnit As MeasureUnit, _
targetUnit As MeasureUnit _
) As Single

Parameters

value

srcUnit

targetUnit

Return Value

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.CreateEllipticRgn Method

InternalUtils.CreateEllipticRgn Method
[image]

Creates an elliptic region.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Region CreateEllipticRgn (
RectangleF rc
)

Visual Basic [image] Copy Code

Public Shared Function CreateEllipticRgn( _
rc As RectangleF _
) As Region

Parameters

rc

A RectangleF instance, which defines the source ellipse.

Return Value

An instance of the .NET Region class.

Remarks

This method supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.CreatePolygonRgn Method

InternalUtils.CreatePolygonRgn Method
[image]

Creates a polygonal region.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Region CreatePolygonRgn (
PointF[] poly
)

Visual Basic [image] Copy Code

Public Shared Function CreatePolygonRgn( _
poly() As PointF _
) As Region

Parameters

poly
An array of PointF objects, which defines the source polygon.

Return Value

An instance of the .NET Region class.

Remarks

This method supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.CreateRoundRectRgn Method

InternalUtils.CreateRoundRectRgn Method
[image]

Creates a round rectangle region.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Region CreateRoundRectRgn (
RectangleF rc,
float r
)

Visual Basic [image] Copy Code

Public Shared Function CreateRoundRectRgn( _
rc As RectangleF, _
r As Single _
) As Region

Parameters

rc
A RectangleF instance, which defines the rounded rectangle bounds.
r

The radius of the rectangle corners.

Return Value

An instance of the .NET Region class.

Remarks

This method supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.Distance Method

InternalUtils.Distance Method
[image]

Calculates the distance between the specified points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static int Distance (
Point point1,
Point point2
)

Visual Basic [image] Copy Code

Public Shared Function Distance( _
point1 As Point, _
point2 As Point _
) As Integer

Parameters

point1

A Point instance.

point2

A Point instance.

Return Value

An int value representing the distance between the specified points.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.DistanceAlongLength Method

InternalUtils.DistanceAlongLength Method
[image]

Returns the distance from the specified point to the start of the specified path along the path's length.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float DistanceAlongLength (
PointF point,
PointCollection segments
)

Visual Basic [image] Copy Code

Public Shared Function DistanceAlongLength( _
point As PointF, _
segments As PointCollection _
) As Single

Parameters

point

A PointF whose distance to the path start to calculate.

segments

A PointCollection specifying the path.

Return Value

A float value specifying distance from the point to the path origin.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.DistanceSq Method

InternalUtils.DistanceSq Method
[image]

Calculates the square of the distance between the specified points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float DistanceSq (
PointF pt1,
PointF pt2
)

Visual Basic [image] Copy Code

Public Shared Function DistanceSq( _
pt1 As PointF, _
pt2 As PointF _
) As Single

Parameters

pt1

pt2

Return Value

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.DistToPolyline Method

InternalUtils.DistToPolyline Method
[image]

Overload List

Name | Description
InternalUtils.DistToPolyline (PointF, IList, Int32) | Calculates the shortest distance from the specified point to the specified polyline.
InternalUtils.DistToPolyline (PointF, IList, Int32, Int32@) | Calculates the shortest distance from the specified point to the specified polyline, also returning the index of the segment the point is closest to.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.DistToPolyline Method (PointF, IList, Int32)

InternalUtils.DistToPolyline Method (PointF, IList, Int32)
See Also
[image]

Calculates the shortest distance from the specified point to the specified polyline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float DistToPolyline (
PointF pt,
IList line_pts,
int nPoints
)

Visual Basic [image] Copy Code

Public Shared Function DistToPolyline( _
pt As PointF, _
line_pts As IList, _
nPoints As Integer _
) As Single

Parameters

pt

line_pts

nPoints

Return Value

See Also

DistToPolyline Method Overload List
InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.DistToPolyline Method (PointF, IList, Int32, Int32@)

InternalUtils.DistToPolyline Method (PointF, IList, Int32, Int32@)
See Also
[image]

Calculates the shortest distance from the specified point to the specified polyline, also returning the index of the segment the point is closest to.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float DistToPolyline (
PointF pt,
IList line_pts,
int nPoints,
ref int segmNum
)

Visual Basic [image] Copy Code

Public Shared Function DistToPolyline( _
pt As PointF, _
line_pts As IList, _
nPoints As Integer, _
ByRef segmNum As Integer _
) As Single

Parameters

pt

line_pts

nPoints

segmNum

Return Value

See Also

DistToPolyline Method Overload List
InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.DistToRectPoint Method

InternalUtils.DistToRectPoint Method
[image]

Returns the nearest to pt point that lies on the outline of rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static PointF DistToRectPoint (
PointF pt,
RectangleF r
)

Visual Basic [image] Copy Code

Public Shared Function DistToRectPoint( _
pt As PointF, _
r As RectangleF _
) As PointF

Parameters

pt

r

Return Value

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.DrawExpandButton Method

InternalUtils.DrawExpandButton Method
[image]

Renders an expand/collapse button on the specified IGraphics canvas.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void DrawExpandButton (
IGraphics graphics,
bool expanded,
RectangleF bounds,
MeasureUnit measureUnit,
Brush shadowBrush
)

Visual Basic [image] Copy Code

Public Shared Sub DrawExpandButton( _
graphics As IGraphics, _
expanded As Boolean, _
bounds As RectangleF, _
measureUnit As MeasureUnit, _
shadowBrush As Brush _
)

Parameters

graphics

expanded

bounds

measureUnit

shadowBrush

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.DrawRect Method

InternalUtils.DrawRect Method
[image]

Draws the specified rectangle using the specified pen for stroking and the specified brush for filling.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void DrawRect (
IGraphics graphics,
Pen p,
Brush b,
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Public Shared Sub DrawRect ( _
graphics As IGraphics, _
p As Pen, _
b As Brush, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

graphics

The IGraphics object that represents the target of the drawing operation.

p

The System.Drawing.Pen to use when drawing the outline.

b

The System.Drawing.Brush to use when filling the contents.

x

The x-coordinate of the top-left corner of the drawn rectangle.

y

The y-coordinate of the top-left corner of the drawn rectangle.

width

The width of the drawn rectangle.

height

The height of the drawn rectangle.

Remarks

This method supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.DrawSelHandles Method

InternalUtils.DrawSelHandles Method
[image]

Draws adjustment handles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void DrawSelHandles (
IGraphics graphics,
HandlesVisualStyle enabledStyle,
HandlesVisualStyle disabledStyle,
RectangleF rc,
float rotationAngle,
AdjustmentHandles mask,
bool showDsbl,
HandlesStyle st,
float size,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Shared Sub DrawSelHandles( _
graphics As IGraphics, _
enabledStyle As HandlesVisualStyle, _
disabledStyle As HandlesVisualStyle, _
rc As RectangleF, _
rotationAngle As Single, _
mask As AdjustmentHandles, _
showDsbl As Boolean, _
st As HandlesStyle, _
size As Single, _
options As RenderOptions _
)

Parameters

graphics

enabledStyle

disabledStyle

rc

rotationAngle

mask

showDsbl

st

size

options

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.GetEllipseIntr Method

InternalUtils.GetEllipseIntr Method
[image]

Calculate the intersection point between the ellipse with the specified bounds and the line segment defined by the specified points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void GetEllipseIntr (
RectangleF rcBox,
PointF pt1,
PointF pt2,
ref PointF pt
)

Visual Basic [image] Copy Code

Public Shared Sub GetEllipseIntr( _
rcBox As RectangleF, _
pt1 As PointF, _
pt2 As PointF, _
ByRef pt As PointF _
)

Parameters

rcBox

pt1

pt2

pt

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.GetLoadedAssembly Method

InternalUtils.GetLoadedAssembly Method
[image]

Gets the specified assembly.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Assembly GetLoadedAssembly (
string asmName
)

Visual Basic [image] Copy Code

Public Shared Function GetLoadedAssembly( _
asmName As String _
) As Assembly

Parameters

asmName

The full name of the assembly.

Return Value

An instance of the .NET Assembly class.

Remarks

This method supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.GetLoadedType Method

InternalUtils.GetLoadedType Method
[image]

Overload List

Name | Description
InternalUtils.GetLoadedType (String) | Searches for the type with the specified name in all loaded assemblies.
InternalUtils.GetLoadedType (String, String) | Gets the type with the specified name from the specified assembly.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.GetLoadedType Method (String)

InternalUtils.GetLoadedType Method (String)
See Also
[image]

Searches for the type with the specified name in all loaded assemblies.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Type GetLoadedType (
string typeName
)

Visual Basic [image] Copy Code

Public Shared Function GetLoadedType( _
typeName As String _
) As Type

Parameters

typeName

Return Value

See Also

GetLoadedType Method Overload List
InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.GetLoadedType Method (String, String)

InternalUtils.GetLoadedType Method (String, String)
See Also
[image]

Gets the type with the specified name from the specified assembly.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Type GetLoadedType (
string typeName,
string asmName
)

Visual Basic [image] Copy Code

Public Shared Function GetLoadedType( _
typeName As String, _
asmName As String _
) As Type

Parameters

typeName

The full name of the type.

asmName

The full name of the containing assembly.

Return Value

An instance of the .NET Type class.

Remarks

This method supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

GetLoadedType Method Overload List
InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.GetRoundRect Method

InternalUtils.GetRoundRect Method
[image]

Creates a graphics path of a rounded rectangle with the specified dimensions and round radius.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static GraphicsPath GetRoundRect (
float x,
float y,
float width,
float height,
float r
)

Visual Basic [image] Copy Code

Public Shared Function GetRoundRect( _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
r As Single _
) As GraphicsPath

Parameters

x
The x-coordinate of the top-left corner of the rectangle.
y

The y-coordinate of the top-left corner of the rectangle.

width

The width of the rectangle.

height

The height of the rectangle.

r

The radius of the rectangle corners.

Return Value

Remarks

This method supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.LinearGradient Method

InternalUtils.LinearGradient Method
[image]

Creates a linear gradient brush with the specified settings.

Overload List

Name | Description
InternalUtils.LinearGradient (Object[]) | Creates a linear gradient brush with the specified blend.
InternalUtils.LinearGradient (PointF, PointF, Object[]) | Creates a linear gradient brush with the specified blend and orientation.
InternalUtils.LinearGradient (Single, Object[]) | Creates a linear gradient brush with the specified blend and orientation angle.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.LinearGradient Method (Object[])

InternalUtils.LinearGradient Method (Object[])
See Also
[image]

Creates a linear gradient brush with the specified blend.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static LinearGradientBrush LinearGradient (
Object[] positionsAndColors
)

Visual Basic [image] Copy Code

Public Shared Function LinearGradient ( _
positionsAndColors() As Object _
) As LinearGradientBrush

Parameters

positionsAndColors
An alternating sequence of float and Color pairs where each pair defines a gradient stop. The positions in the sequence need to be in ascending order.

Return Value

An instance of the LinearGradientBrush class corresponding to the specified settings.

See Also

LinearGradient Method Overload List
InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.LinearGradient Method (PointF, PointF, Object[])

InternalUtils.LinearGradient Method (PointF, PointF, Object[])
See Also
[image]

Creates a linear gradient brush with the specified blend and orientation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static LinearGradientBrush LinearGradient (
PointF a,
PointF b,
Object[] positionsAndColors
)

Visual Basic [image] Copy Code

Public Shared Function LinearGradient ( _
a As PointF, _
b As PointF, _
positionsAndColors() As Object _
) As LinearGradientBrush

Parameters

a
The start point of the linear gradient.
b
The end point of the linear gradient.
positionsAndColors
An alternating sequence of float and Color pairs where each pair defines a gradient stop. The positions in the sequence need to be in ascending order.

Return Value

An instance of the LinearGradientBrush class corresponding to the specified settings.

See Also

LinearGradient Method Overload List
InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.LinearGradient Method (Single, Object[])

InternalUtils.LinearGradient Method (Single, Object[])
See Also
[image]

Creates a linear gradient brush with the specified blend and orientation angle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static LinearGradientBrush LinearGradient (
float angle,
Object[] positionsAndColors
)

Visual Basic [image] Copy Code

Public Shared Function LinearGradient ( _
angle As Single, _
positionsAndColors() As Object _
) As LinearGradientBrush

Parameters

angle
The angle of the linear gradient.
positionsAndColors
An alternating sequence of float and Color pairs where each pair defines a gradient stop. The positions in the sequence need to be in ascending order.

Return Value

An instance of the LinearGradientBrush class corresponding to the specified settings.

See Also

LinearGradient Method Overload List
InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.MatchPointsMinLength Method

InternalUtils.MatchPointsMinLength Method
[image]

Returns an array of node anchor points which match current node links anchor point

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static int[] MatchPointsMinLength (
PointF[] nodeAnchorPoints,
int[] pointRealIndexes,
PointF[] fixedLinksAnchorPoints,
List<Int32> usedAnchorPointIndexes
)

Visual Basic [image] Copy Code

Public Shared Function MatchPointsMinLength( _
nodeAnchorPoints() As PointF, _
pointRealIndexes() As Integer, _
fixedLinksAnchorPoints() As PointF, _
usedAnchorPointIndexes As List(Of Int32) _
) As Integer()

Parameters

nodeAnchorPoints

pointRealIndexes

fixedLinksAnchorPoints

usedAnchorPointIndexes

Return Value

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.MidPoint Method

InternalUtils.MidPoint Method
[image]

Returns the middle point of the segment defined by the specified points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static PointF MidPoint (
PointF pt1,
PointF pt2
)

Visual Basic [image] Copy Code

Public Shared Function MidPoint( _
pt1 As PointF, _
pt2 As PointF _
) As PointF

Parameters

pt1

The first point.

pt2

The second point.

Return Value

A .NET PointF instance that represents the middle point.

Remarks

This method supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.MinDistToRect Method

InternalUtils.MinDistToRect Method
[image]

Calculates the minimum distance between a given point and a given rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float MinDistToRect (
PointF pt,
RectangleF rc
)

Visual Basic [image] Copy Code

Public Shared Function MinDistToRect( _
pt As PointF, _
rc As RectangleF _
) As Single

Parameters

pt

rc

Return Value

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.NormalizeRect Method

InternalUtils.NormalizeRect Method
[image]

Normalizes the specified rectangle.

Overload List

Name | Description
InternalUtils.NormalizeRect (Rectangle) | Normalizes the specified rectangle ensuring its height and width are non-negative numbers.
InternalUtils.NormalizeRect (RectangleF) | Normalizes the specified rectangle ensuring its height and width are non-negative numbers.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.NormalizeRect Method (Rectangle)

InternalUtils.NormalizeRect Method (Rectangle)
See Also
[image]

Normalizes the specified rectangle ensuring its height and width are non-negative numbers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Rectangle NormalizeRect (
Rectangle rc
)

Visual Basic [image] Copy Code

Public Shared Function NormalizeRect( _
rc As Rectangle _
) As Rectangle

Parameters

rc
The .NET Rectangle to be normalized.

Return Value

A .NET Rectangle instance that represents the normalized rectangle.

Remarks

This method supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

NormalizeRect Method Overload List
InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.NormalizeRect Method (RectangleF)

InternalUtils.NormalizeRect Method (RectangleF)
See Also
[image]

Normalizes the specified rectangle ensuring its height and width are non-negative numbers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static RectangleF NormalizeRect (
RectangleF rc
)

Visual Basic [image] Copy Code

Public Shared Function NormalizeRect( _
rc As RectangleF _
) As RectangleF

Parameters

rc

The .NET RectangleF to be normalized.

Return Value

A .NET RectangleF instance that represents the normalized rectangle.

Remarks

This method supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

NormalizeRect Method Overload List
InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.OffsetPath Method

InternalUtils.OffsetPath Method
[image]

Moves a path by the specified offset.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void OffsetPath (
GraphicsPath path,
float dx,
float dy
)

Visual Basic [image] Copy Code

Public Shared Sub OffsetPath( _
path As GraphicsPath, _
dx As Single, _
dy As Single _
)

Parameters

path

dx

dy

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.PointAlongLength Method

InternalUtils.PointAlongLength Method
[image]

Returns a point lying at the specified distance from the start point along the path specified via the collection of points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static PointF PointAlongLength (
float distance,
PointCollection segments
)

Visual Basic [image] Copy Code

Public Shared Function PointAlongLength( _
distance As Single, _
segments As PointCollection _
) As PointF

Parameters

distance

A float value specifying the desired distance.

segments

A PointCollection specifying the path.

Return Value

A PointF structure specifying the point coordinates.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.PointInRect Method

InternalUtils.PointInRect Method
[image]

Checks whether the specified rectangle contains the specified point.

Overload List

Name | Description
InternalUtils.PointInRect (Point, Rectangle) | Checks whether the specified rectangle contains the specified point.
InternalUtils.PointInRect (PointF, RectangleF) | Checks whether the specified rectangle contains the specified point.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.PointInRect Method (Point, Rectangle)

InternalUtils.PointInRect Method (Point, Rectangle)
See Also
[image]

Checks whether the specified rectangle contains the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static bool PointInRect (
Point pt,
Rectangle rc
)

Visual Basic [image] Copy Code

Public Shared Function PointInRect( _
pt As Point, _
rc As Rectangle _
) As Boolean

Parameters

pt

The point to be checked.

rc

The rectangle to be checked.

Return Value

true if the specified rectangle contains the specified point; otherwise, false.

Remarks

This method supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

PointInRect Method Overload List
InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.PointInRect Method (PointF, RectangleF)

InternalUtils.PointInRect Method (PointF, RectangleF)
See Also
[image]

Checks whether the specified rectangle contains the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static bool PointInRect (
PointF pt,
RectangleF rc
)

Visual Basic [image] Copy Code

Public Shared Function PointInRect( _
pt As PointF, _
rc As RectangleF _
) As Boolean

Parameters

pt

The point to be checked.

rc

The rectangle to be checked.

Return Value

true if the specified rectangle contains the specified point; otherwise, false.

Remarks

This method supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

PointInRect Method Overload List
InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.RectangleToPoints Method

InternalUtils.RectangleToPoints Method
[image]

Returns the points of the specified rectangle as an array.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static PointF[] RectangleToPoints (
RectangleF r
)

Visual Basic [image] Copy Code

Public Shared Function RectangleToPoints( _
r As RectangleF _
) As PointF()

Parameters

r

The source rectangle.

Return Value

An array of PointF objects, which contains the vertices of the rectangle.

Remarks

This method supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.SetBrushAlpha Method

InternalUtils.SetBrushAlpha Method
[image]

Sets the alpha channel value for all color properties of the specified brush.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Brush SetBrushAlpha (
Brush brush,
int alpha
)

Visual Basic [image] Copy Code

Public Shared Function SetBrushAlpha( _
brush As Brush, _
alpha As Integer _
) As Brush

Parameters

brush
A Brush instance.
alpha
An int value in the range 0-255 specifying color transparency.

Return Value

A copy of the specified brush with its colors' transparency set to the specified alpha value.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.UnionNonEmptyRects Method

InternalUtils.UnionNonEmptyRects Method
[image]

Returns the smallest possible rectangle containing both of the specified rectangles, but only if the rectangles are non-empty.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static RectangleF UnionNonEmptyRects (
RectangleF rc1,
RectangleF rc2
)

Visual Basic [image] Copy Code

Public Shared Function UnionNonEmptyRects( _
rc1 As RectangleF, _
rc2 As RectangleF _
) As RectangleF

Parameters

rc1

The first rectangle.

rc2

The second rectangle.

Return Value

A .NET RectangleF instance that represents the union of the specified arguments.

Remarks

This method supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.UnionRects Method

InternalUtils.UnionRects Method
[image]

Returns the smallest possible rectangle containing both of the specified rectangles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static RectangleF UnionRects (
RectangleF a,
RectangleF b
)

Visual Basic [image] Copy Code

Public Shared Function UnionRects( _
a As RectangleF, _
b As RectangleF _
) As RectangleF

Parameters

a

The first rectangle.

b

The second rectangle.

Return Value

A .NET RectangleF instance that represents the union of the specified arguments.

Remarks

This method supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.IPersists Interface

IPersists Interface
Remarks See Also
[image]

Base interface for serializable MvcDiagram objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface IPersists

Visual Basic [image] Copy Code

Public Interface IPersists

Remarks

Serializable MvcDiagram classes implement explicitly this interface to hide it from the public. Explicit implementation however has the restrictions that the implemented methods are private and non-polymorphic. To avoid these limitations each implementing class provides another set of methods corresponding to the IPersists methods, which are declared as internal and retain polymorphism.

Example

The following sample class illustrates this technique:

C# [image] Copy Code

class PersistingItem : IPersists
{
int IPersists.GetClassId()
{
return GetClassIdInternal();
}

void IPersists.SaveTo(BinaryWriter writer, PersistContext ctx)
{
SaveToInternal(writer, ctx);
}

void IPersists.LoadFrom(BinaryReader reader, PersistContext ctx)
{
LoadFromInternal(reader, ctx);
}

void IPersists.SetReference(int refId, object obj)
{
SetReferenceInternal(refId, obj);
}

internal virtual int GetClassId()
{
return ClassId;
}

internal virtual void SaveTo(BinaryWriter writer, PersistContext ctx)
{
}

internal virtual void LoadFrom(BinaryReader reader, PersistContext ctx)
{
}

internal virtual void SetReference(int refId, object obj)
{
}
}

Inheritors

MindFusion.Diagramming.AnchorPattern
MindFusion.Diagramming.AnchorPoint
MindFusion.Diagramming.ConnectionPoint
MindFusion.Diagramming.Diagram
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.ElementTemplate
MindFusion.Diagramming.Group
MindFusion.Diagramming.Group.Attachment
MindFusion.Diagramming.HandlesVisualStyle
MindFusion.Diagramming.MapContent
MindFusion.Diagramming.NodeConstraints
MindFusion.Diagramming.NodeEffect
MindFusion.Diagramming.PersistableCollection(T)
MindFusion.Diagramming.PointCollection
MindFusion.Diagramming.Shape
MindFusion.Diagramming.ShapeData
MindFusion.Diagramming.Style
MindFusion.Diagramming.TableNode.Cell
MindFusion.Diagramming.TableNode.CellCollection
MindFusion.Diagramming.TableNode.Column
MindFusion.Diagramming.TableNode.ColumnCollection
MindFusion.Diagramming.TableNode.Row
MindFusion.Diagramming.TableNode.RowCollection
MindFusion.Diagramming.TreeViewItem

See Also

IPersists Members


MindFusion.Diagramming.IPersists Members

IPersists Members
Methods
[image]

Base interface for serializable MvcDiagram objects.

The following tables list the members exposed by the IPersists type.

Public Methods

Name | Description
GetClassId | Returns the id of the implementing class.
LoadFrom | Deserializes the object from the specified binary reader.
SaveTo | Serializes the object to the specified binary writer.
SetReference | Updates the reference to the specified object.

See Also

IPersists Interface


MindFusion.Diagramming.IPersists Methods

IPersists Methods
[image]

Public Methods

Name | Description
GetClassId | Returns the id of the implementing class.
LoadFrom | Deserializes the object from the specified binary reader.
SaveTo | Serializes the object to the specified binary writer.
SetReference | Updates the reference to the specified object.

See Also

IPersists Interface


MindFusion.Diagramming.IPersists.GetClassId Method

IPersists.GetClassId Method
[image]

Returns the id of the implementing class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

int GetClassId ()

Visual Basic [image] Copy Code

Function GetClassId () As Integer

Return Value

An integer value specifying a unique id for the implementing class.

See Also

IPersists Members
IPersists Interface


MindFusion.Diagramming.IPersists.LoadFrom Method

IPersists.LoadFrom Method
[image]

Deserializes the object from the specified binary reader.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract void LoadFrom (
BinaryReader reader,
PersistContext ctx
)

Visual Basic [image] Copy Code

Public MustOverride Sub LoadFrom ( _
reader As BinaryReader, _
ctx As PersistContext _
)

Parameters

reader

The .NET BinaryReader object to read from.

ctx

A PersistContext object supplying all necessary information during deserialization.

See Also

IPersists Members
IPersists Interface


MindFusion.Diagramming.IPersists.SaveTo Method

IPersists.SaveTo Method
[image]

Serializes the object to the specified binary writer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract void SaveTo (
BinaryWriter writer,
PersistContext ctx
)

Visual Basic [image] Copy Code

Public MustOverride Sub SaveTo ( _
writer As BinaryWriter, _
ctx As PersistContext _
)

Parameters

writer

The .NET BinaryWriter object to write to.

ctx

A PersistContext object supplying all necessary information during serialization.

See Also

IPersists Members
IPersists Interface


MindFusion.Diagramming.IPersists.SetReference Method

IPersists.SetReference Method
[image]

Updates the reference to the specified object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract void SetReference (
int refId,
Object obj,
PersistContext ctx
)

Visual Basic [image] Copy Code

Public MustOverride Sub SetReference ( _
refId As Integer, _
obj As Object, _
ctx As PersistContext _
)

Parameters

refId

The local identifier of the referenced object.

obj

The referenced object.

ctx
A PersistContext object supplying all necessary information during deserialization.

See Also

IPersists Members
IPersists Interface


MindFusion.Diagramming.IProperty Interface

IProperty Interface
[image]

Represents a property that can have an undefined value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface IProperty

Visual Basic [image] Copy Code

Public Interface IProperty

See Also

IProperty Members


MindFusion.Diagramming.IProperty Members

IProperty Members
Properties Methods
[image]

Represents a property that can have an undefined value.

The following tables list the members exposed by the IProperty type.

Public Properties

Name | Description
HasValue | Gets a value indicating whether the property has a value.
Name | Gets the name of the property.

Public Methods

Name | Description
GetValue | Gets the value of the property.
SetValue | Sets the value of the property.
Unset | Clears the value of the property.

See Also

IProperty Interface


MindFusion.Diagramming.IProperty Methods

IProperty Methods
[image]

Public Methods

Name | Description
GetValue | Gets the value of the property.
SetValue | Sets the value of the property.
Unset | Clears the value of the property.

See Also

IProperty Interface


MindFusion.Diagramming.IProperty.GetValue Method

IProperty.GetValue Method
[image]

Gets the value of the property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

Object GetValue ()

Visual Basic [image] Copy Code

Function GetValue () As Object

Return Value

See Also

IProperty Members
IProperty Interface


MindFusion.Diagramming.IProperty.SetValue Method

IProperty.SetValue Method
[image]

Sets the value of the property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void SetValue (
Object value
)

Visual Basic [image] Copy Code

Sub SetValue( _
value As Object _
)

Parameters

value

See Also

IProperty Members
IProperty Interface


MindFusion.Diagramming.IProperty.Unset Method

IProperty.Unset Method
[image]

Clears the value of the property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void Unset ()

Visual Basic [image] Copy Code

Sub Unset ()

See Also

IProperty Members
IProperty Interface


MindFusion.Diagramming.IProperty Properties

IProperty Properties
[image]

Public Properties

Name | Description
HasValue | Gets a value indicating whether the property has a value.
Name | Gets the name of the property.

See Also

IProperty Interface


MindFusion.Diagramming.IProperty.HasValue Property

IProperty.HasValue Property
[image]

Gets a value indicating whether the property has a value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

bool HasValue { get; }

Visual Basic [image] Copy Code

ReadOnly Property HasValue As Boolean

Property Value

See Also

IProperty Members
IProperty Interface


MindFusion.Diagramming.IProperty.Name Property

IProperty.Name Property
[image]

Gets the name of the property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

string Name { get; }

Visual Basic [image] Copy Code

ReadOnly Property Name As String

Property Value

See Also

IProperty Members
IProperty Interface


MindFusion.Diagramming.IResolution Interface

IResolution Interface
[image]

Provides information about device resolution.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface IResolution

Visual Basic [image] Copy Code

Public Interface IResolution

Inheritors

MindFusion.Diagramming.IDiagramView

See Also

IResolution Members


MindFusion.Diagramming.IResolution Members

IResolution Members
Properties
[image]

Provides information about device resolution.

The following tables list the members exposed by the IResolution type.

Public Properties

Name | Description
DpiX | Gets the horizontal resolution of the device.
DpiY | Gets the vertical resolution of the device.

See Also

IResolution Interface


MindFusion.Diagramming.IResolution Properties

IResolution Properties
[image]

Public Properties

Name | Description
DpiX | Gets the horizontal resolution of the device.
DpiY | Gets the vertical resolution of the device.

See Also

IResolution Interface


MindFusion.Diagramming.IResolution.DpiX Property

IResolution.DpiX Property
[image]

Gets the horizontal resolution of the device.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

double DpiX { get; }

Visual Basic [image] Copy Code

ReadOnly Property DpiX As Double

Property Value

A double value specifying horizontal dots-per-inch resolution.

See Also

IResolution Members
IResolution Interface


MindFusion.Diagramming.IResolution.DpiY Property

IResolution.DpiY Property
[image]

Gets the vertical resolution of the device.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

double DpiY { get; }

Visual Basic [image] Copy Code

ReadOnly Property DpiY As Double

Property Value

A double value specifying vertical dots-per-inch resolution.

See Also

IResolution Members
IResolution Interface


MindFusion.Diagramming.ItemCollectionBase(T) Class

ItemCollectionBase(T) Class
[image]

A base collection class for the diagram item collections.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class ItemCollectionBase<T> : PersistableCollection<T> where T : DiagramItem

Visual Basic [image] Copy Code

Public MustInherit Class ItemCollectionBase(Of T As DiagramItem)
Inherits PersistableCollection(Of T)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.CollectionBase(T)
MindFusion.Diagramming.PersistableCollection(T)
MindFusion.Diagramming.ItemCollectionBase(T)
MindFusion.Diagramming.DiagramItemCollection
MindFusion.Diagramming.DiagramLinkCollection
MindFusion.Diagramming.DiagramNodeCollection

See Also

ItemCollectionBase(T) Members


MindFusion.Diagramming.ItemCollectionBase(T) Members

ItemCollectionBase(T) Members
Fields Properties Methods
[image]

A base collection class for the diagram item collections.

The following tables list the members exposed by the ItemCollectionBase(T) type.

Protected Fields

Name | Description
InnerList | Gets a List<T> containing the list of elements in the collection instance. (Inherited from CollectionBase.)
itemEventArgs | A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector.
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items.

Public Properties

Name | Description
Count | Gets the number of elements actually contained in the collection. (Inherited from CollectionBase.)
IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index. (Inherited from CollectionBase.)

Public Methods

Name | Description
Add | Adds the specified diagram item to the collection.
Clear | Removes all diagram items from the collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from CollectionBase.)
GetAt | Gets the diagram item at the specified position.
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified diagram item into the collection at the specified position.
Remove | Removes the diagram item from the collection.
RemoveAt | Removes the diagram item from the collection.
Sort | Overloaded. (Inherited from CollectionBase.)

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event.
RaiseInserting | Raises the Inserting event.
RaiseRemoving | Raises the Removing event.

See Also

ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T) Fields

ItemCollectionBase(T) Fields
[image]

Protected Fields

Name | Description
InnerList | Gets a List<T> containing the list of elements in the collection instance. (Inherited from CollectionBase.)
itemEventArgs | A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector.
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items.

See Also

ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T).itemEventArgs Field

ItemCollectionBase(T).itemEventArgs Field
[image]

A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected ItemEventArgs itemEventArgs

Visual Basic [image] Copy Code

Protected itemEventArgs As ItemEventArgs

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T).notifyParent Field

ItemCollectionBase(T).notifyParent Field
[image]

If enabled, the collection raises events to let their containing objects handle the addition or removal of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected bool notifyParent

Visual Basic [image] Copy Code

Protected notifyParent As Boolean

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T) Methods

ItemCollectionBase(T) Methods
[image]

Public Methods

Name | Description
Add | Adds the specified diagram item to the collection.
Clear | Removes all diagram items from the collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from CollectionBase.)
GetAt | Gets the diagram item at the specified position.
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified diagram item into the collection at the specified position.
Remove | Removes the diagram item from the collection.
RemoveAt | Removes the diagram item from the collection.
Sort | Overloaded. (Inherited from CollectionBase.)

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event.
RaiseInserting | Raises the Inserting event.
RaiseRemoving | Raises the Removing event.

See Also

ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T).Add Method

ItemCollectionBase(T).Add Method
[image]

Adds the specified diagram item to the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Add (
T item
)

Visual Basic [image] Copy Code

Public Overrides Sub Add( _
item As T _
)

Parameters

item

The DiagramItem object to add to the collection.

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T).Clear Method

ItemCollectionBase(T).Clear Method
[image]

Removes all diagram items from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Clear ()

Visual Basic [image] Copy Code

Public Overrides Sub Clear ()

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T).GetAt Method

ItemCollectionBase(T).GetAt Method
[image]

Gets the diagram item at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem GetAt (
int index
)

Visual Basic [image] Copy Code

Public Function GetAt( _
index As Integer _
) As DiagramItem

Parameters

index

The zero-based index of the item to retrieve.

Return Value

An instance of the DiagramItem class that represents the item at the specified position.

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T).Insert Method

ItemCollectionBase(T).Insert Method
[image]

Inserts the specified diagram item into the collection at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Insert (
int index,
T item
)

Visual Basic [image] Copy Code

Public Overrides Sub Insert( _
index As Integer, _
item As T _
)

Parameters

index

The zero-based index at which to insert the item.

item

The DiagramItem object to add to the collection.

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T).RaiseAdding Method

ItemCollectionBase(T).RaiseAdding Method
[image]

Raises the Adding event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void RaiseAdding (
DiagramItem item
)

Visual Basic [image] Copy Code

Protected Sub RaiseAdding( _
item As DiagramItem _
)

Parameters

item

The diagram item that is being added.

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T).RaiseInserting Method

ItemCollectionBase(T).RaiseInserting Method
[image]

Raises the Inserting event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void RaiseInserting (
DiagramItem item,
int index
)

Visual Basic [image] Copy Code

Protected Sub RaiseInserting( _
item As DiagramItem, _
index As Integer _
)

Parameters

item

The diagram item that is being inserted.

index

Index of the new item.

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T).RaiseRemoving Method

ItemCollectionBase(T).RaiseRemoving Method
[image]

Raises the Removing event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void RaiseRemoving (
DiagramItem item
)

Visual Basic [image] Copy Code

Protected Sub RaiseRemoving( _
item As DiagramItem _
)

Parameters

item

The diagram item that is being removed.

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T).Remove Method

ItemCollectionBase(T).Remove Method
[image]

Removes the diagram item from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool Remove (
T item
)

Visual Basic [image] Copy Code

Public Overrides Function Remove( _
item As T _
) As Boolean

Parameters

item

The DiagramItem object to remove from the collection.

Return Value

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T).RemoveAt Method

ItemCollectionBase(T).RemoveAt Method
[image]

Removes the diagram item from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void RemoveAt (
int index
)

Visual Basic [image] Copy Code

Public Overrides Sub RemoveAt( _
index As Integer _
)

Parameters

index

Index of the object that should be removed from this collection.

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemEventArgs Class

ItemEventArgs Class
[image]

Contains the arguments passed to item instantiation event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ItemEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.ItemEventArgs

See Also

ItemEventArgs Members


MindFusion.Diagramming.ItemEventArgs Members

ItemEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to item instantiation event handlers.

The following tables list the members exposed by the ItemEventArgs type.

Public Constructors

Name | Description
ItemEventArgs | Initializes a new instance of the ItemEventArgs class.

Public Properties

Name | Description
Index | Gets an integer index related to the event.
Item | Gets the item for which the event is raised.

See Also

ItemEventArgs Class


MindFusion.Diagramming.ItemEventArgs Constructor

ItemEventArgs Constructor
[image]

Initializes a new instance of the ItemEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ItemEventArgs (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Sub ItemEventArgs ( _
item As DiagramItem _
)

Parameters

item

The DiagramItem related to the event.

See Also

ItemEventArgs Class


MindFusion.Diagramming.ItemEventArgs Properties

ItemEventArgs Properties
[image]

Public Properties

Name | Description
Index | Gets an integer index related to the event.
Item | Gets the item for which the event is raised.

See Also

ItemEventArgs Class


MindFusion.Diagramming.ItemEventArgs.Index Property

ItemEventArgs.Index Property
[image]

Gets an integer index related to the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Index { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Index As Integer

Property Value

An integer value specifying the item's position within its containing collection.

See Also

ItemEventArgs Members
ItemEventArgs Class


MindFusion.Diagramming.ItemEventArgs.Item Property

ItemEventArgs.Item Property
[image]

Gets the item for which the event is raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As DiagramItem

Property Value

An instance of the DiagramItem class.

See Also

ItemEventArgs Members
ItemEventArgs Class


MindFusion.Diagramming.Key Enumeration

Key Enumeration
[image]

A copy of the System.Windows.Forms.Key enumeration used to propagate input information to manipulators and components.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum Key

Visual Basic [image] Copy Code

Public Enum Key

Members

Member name | Description
Modifiers | The bitmask to extract modifiers from a key value.
None | No key pressed.
LButton | The left mouse button.
RButton | The right mouse button.
Cancel | The CANCEL key.
MButton | The middle mouse button (three-button mouse).
XButton1 | The first x mouse button (five-button mouse).
XButton2 | The second x mouse button (five-button mouse).
Back | The BACKSPACE key.
Tab | The TAB key.
LineFeed | The LINEFEED key.
Clear | The CLEAR key.
Enter | The ENTER key.
Return | The RETURN key.
ShiftKey | The SHIFT key.
ControlKey | The CTRL key.
Menu | The ALT key.
Pause | The PAUSE key.
CapsLock | The CAPS LOCK key.
Capital | The CAPS LOCK key.
KanaMode | The IME Kana mode key.
HangulMode | The IME Hangul mode key.
HanguelMode | The IME Hanguel mode key. (maintained for compatibility; use HangulMode)
JunjaMode | The IME Junja mode key.
FinalMode | The IME final mode key.
KanjiMode | The IME Kanji mode key.
HanjaMode | The IME Hanja mode key.
Escape | The ESC key.
IMEConvert | The IME convert key.
IMENonconvert | The IME nonconvert key.
IMEAceept | The IME accept key. Obsolete, use System.Windows.Forms.Keys.IMEAccept instead.
IMEAccept | The IME accept key, replaces System.Windows.Forms.Keys.IMEAceept.
IMEModeChange | The IME mode change key.
Space | The SPACEBAR key.
Prior | The PAGE UP key.
PageUp | The PAGE UP key.
Next | The PAGE DOWN key.
PageDown | The PAGE DOWN key.
End | The END key.
Home | The HOME key.
Left | The LEFT ARROW key.
Up | The UP ARROW key.
Right | The RIGHT ARROW key.
Down | The DOWN ARROW key.
Select | The SELECT key.
Print | The PRINT key.
Execute | The EXECUTE key.
PrintScreen | The PRINT SCREEN key.
Snapshot | The PRINT SCREEN key.
Insert | The INS key.
Delete | The DEL key.
Help | The HELP key.
D0 | The 0 key.
D1 | The 1 key.
D2 | The 2 key.
D3 | The 3 key.
D4 | The 4 key.
D5 | The 5 key.
D6 | The 6 key.
D7 | The 7 key.
D8 | The 8 key.
D9 | The 9 key.
A | The A key.
B | The B key.
C | The C key.
D | The D key.
E | The E key.
F | The F key.
G | The G key.
H | The H key.
I | The I key.
J | The J key.
K | The K key.
L | The L key.
M | The M key.
N | The N key.
O | The O key.
P | The P key.
Q | The Q key.
R | The R key.
S | The S key.
T | The T key.
U | The U key.
V | The V key.
W | The W key.
X | The X key.
Y | The Y key.
Z | The Z key.
LWin | The left Windows logo key (Microsoft Natural Keyboard).
RWin | The right Windows logo key (Microsoft Natural Keyboard).
Apps | The application key (Microsoft Natural Keyboard).
Sleep | The computer sleep key.
NumPad0 | The 0 key on the numeric keypad.
NumPad1 | The 1 key on the numeric keypad.
NumPad2 | The 2 key on the numeric keypad.
NumPad3 | The 3 key on the numeric keypad.
NumPad4 | The 4 key on the numeric keypad.
NumPad5 | The 5 key on the numeric keypad.
NumPad6 | The 6 key on the numeric keypad.
NumPad7 | The 7 key on the numeric keypad.
NumPad8 | The 8 key on the numeric keypad.
NumPad9 | The 9 key on the numeric keypad.
Multiply | The multiply key.
Add | The add key.
Separator | The separator key.
Subtract | The subtract key.
Decimal | The decimal key.
Divide | The divide key.
F1 | The F1 key.
F2 | The F2 key.
F3 | The F3 key.
F4 | The F4 key.
F5 | The F5 key.
F6 | The F6 key.
F7 | The F7 key.
F8 | The F8 key.
F9 | The F9 key.
F10 | The F10 key.
F11 | The F11 key.
F12 | The F12 key.
F13 | The F13 key.
F14 | The F14 key.
F15 | The F15 key.
F16 | The F16 key.
F17 | The F17 key.
F18 | The F18 key.
F19 | The F19 key.
F20 | The F20 key.
F21 | The F21 key.
F22 | The F22 key.
F23 | The F23 key.
F24 | The F24 key.
NumLock | The NUM LOCK key.
Scroll | The SCROLL LOCK key.
LShiftKey | The left SHIFT key.
RShiftKey | The right SHIFT key.
LControlKey | The left CTRL key.
RControlKey | The right CTRL key.
LMenu | The left ALT key.
RMenu | The right ALT key.
BrowserBack | The browser back key (Windows 2000 or later).
BrowserForward | The browser forward key (Windows 2000 or later).
BrowserRefresh | The browser refresh key (Windows 2000 or later).
BrowserStop | The browser stop key (Windows 2000 or later).
BrowserSearch | The browser search key (Windows 2000 or later).
BrowserFavorites | The browser favorites key (Windows 2000 or later).
BrowserHome | The browser home key (Windows 2000 or later).
VolumeMute | The volume mute key (Windows 2000 or later).
VolumeDown | The volume down key (Windows 2000 or later).
VolumeUp | The volume up key (Windows 2000 or later).
MediaNextTrack | The media next track key (Windows 2000 or later).
MediaPreviousTrack | The media previous track key (Windows 2000 or later).
MediaStop | The media Stop key (Windows 2000 or later).
MediaPlayPause | The media play pause key (Windows 2000 or later).
LaunchMail | The launch mail key (Windows 2000 or later).
SelectMedia | The select media key (Windows 2000 or later).
LaunchApplication1 | The start application one key (Windows 2000 or later).
LaunchApplication2 | The start application two key (Windows 2000 or later).
OemSemicolon | The OEM Semicolon key on a US standard keyboard (Windows 2000 or later).
Oem1 | The OEM 1 key.
Oemplus | The OEM plus key on any country/region keyboard (Windows 2000 or later).
Oemcomma | The OEM comma key on any country/region keyboard (Windows 2000 or later).
OemMinus | The OEM minus key on any country/region keyboard (Windows 2000 or later).
OemPeriod | The OEM period key on any country/region keyboard (Windows 2000 or later).
Oem2 | The OEM 2 key.
OemQuestion | The OEM question mark key on a US standard keyboard (Windows 2000 or later).
Oemtilde | The OEM tilde key on a US standard keyboard (Windows 2000 or later).
Oem3 | The OEM 3 key.
OemOpenBrackets | The OEM open bracket key on a US standard keyboard (Windows 2000 or later).
Oem4 | The OEM 4 key.
OemPipe | The OEM pipe key on a US standard keyboard (Windows 2000 or later).
Oem5 | The OEM 5 key.
Oem6 | The OEM 6 key.
OemCloseBrackets | The OEM close bracket key on a US standard keyboard (Windows 2000 or later).
OemQuotes | The OEM singled/double quote key on a US standard keyboard (Windows 2000 or later).
Oem7 | The OEM 7 key.
Oem8 | The OEM 8 key.
OemBackslash | The OEM angle bracket or backslash key on the RT 102 key keyboard (Windows 2000 or later).
Oem102 | The OEM 102 key.
ProcessKey | The PROCESS KEY key.
Packet | Used to pass Unicode characters as if they were keystrokes. The Packet key value is the low word of a 32-bit virtual-key value used for non-keyboard input methods.
Attn | The ATTN key.
Crsel | The CRSEL key.
Exsel | The EXSEL key.
EraseEof | The ERASE EOF key.
Play | The PLAY key.
Zoom | The ZOOM key.
NoName | A constant reserved for future use.
Pa1 | The PA1 key.
OemClear | The CLEAR key.
KeyCode | The bitmask to extract a key code from a key value.
Shift | The SHIFT modifier key.
Control | The CTRL modifier key.
Alt | The ALT modifier key.

See Also


MindFusion.Diagramming.Layer Class

Layer Class
[image]

Represents a layer in a Diagram object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Layer : INotifyPropertyChanged

Visual Basic [image] Copy Code

Public Class Layer
Implements INotifyPropertyChanged

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layer

See Also

Layer Members


MindFusion.Diagramming.Layer Members

Layer Members
Constructors Properties Methods Events
[image]

Represents a layer in a Diagram object.

The following tables list the members exposed by the Layer type.

Public Constructors

Name | Description
Layer | Initializes a new instance of the Layer class.

Public Properties

Name | Description
Locked | Gets or sets a value indicating whether the layer is locked.
Title | Gets or sets a title associated with the layer.
Visible | Gets or sets a value indicating whether the layer is visible.
ZIndex | Gets or sets the z-index of the layer.

Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

Layer Class


MindFusion.Diagramming.Layer Constructor

Layer Constructor
[image]

Initializes a new instance of the Layer class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Layer ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Layer Class


MindFusion.Diagramming.Layer Methods

Layer Methods
[image]

Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event.

See Also

Layer Class


MindFusion.Diagramming.Layer.OnPropertyChanged Method

Layer.OnPropertyChanged Method
[image]

Raises the PropertyChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnPropertyChanged (
PropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPropertyChanged( _
e As PropertyChangedEventArgs _
)

Parameters

e

An object providing the event data.

See Also

Layer Members
Layer Class


MindFusion.Diagramming.Layer Properties

Layer Properties
[image]

Public Properties

Name | Description
Locked | Gets or sets a value indicating whether the layer is locked.
Title | Gets or sets a title associated with the layer.
Visible | Gets or sets a value indicating whether the layer is visible.
ZIndex | Gets or sets the z-index of the layer.

See Also

Layer Class


MindFusion.Diagramming.Layer.Locked Property

Layer.Locked Property
[image]

Gets or sets a value indicating whether the layer is locked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Locked { get; set; }

Visual Basic [image] Copy Code

Public Property Locked As Boolean

Property Value

true if the layer is locked; otherwise, false.

Remarks

Items associated with locked layers cannot be modified interactively, regardless of their own Locked property.

See Also

Layer Members
Layer Class


MindFusion.Diagramming.Layer.Title Property

Layer.Title Property
[image]

Gets or sets a title associated with the layer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

A string value.

See Also

Layer Members
Layer Class


MindFusion.Diagramming.Layer.Visible Property

Layer.Visible Property
[image]

Gets or sets a value indicating whether the layer is visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Property Visible As Boolean

Property Value

true if the layer is visible; otherwise, false.

Remarks

Items associated with hidden layers are not displayed, regardless of their own Visible property.

See Also

Layer Members
Layer Class


MindFusion.Diagramming.Layer.ZIndex Property

Layer.ZIndex Property
[image]

Gets or sets the z-index of the layer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ZIndex { get; set; }

Visual Basic [image] Copy Code

Public Property ZIndex As Integer

Property Value

An integer value.

See Also

Layer Members
Layer Class


MindFusion.Diagramming.Layer Events

Layer Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

Layer Class


MindFusion.Diagramming.Layer.PropertyChanged Event

Layer.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

Layer Members
Layer Class


MindFusion.Diagramming.LayerEventArgs Class

LayerEventArgs Class
[image]

Contains the arguments passed to the LayerVisibilityChanged event handler.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LayerEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class LayerEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.LayerEventArgs

See Also

LayerEventArgs Members


MindFusion.Diagramming.LayerEventArgs Members

LayerEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the LayerVisibilityChanged event handler.

The following tables list the members exposed by the LayerEventArgs type.

Public Constructors

Name | Description
LayerEventArgs | Initializes a new instance of the LayerEventArgs class.

Public Properties

Name | Description
Index | Gets or sets the layer index related to the current event.
Layer | Gets or sets the Layer related to the current event.

See Also

LayerEventArgs Class


MindFusion.Diagramming.LayerEventArgs Constructor

LayerEventArgs Constructor
[image]

Initializes a new instance of the LayerEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LayerEventArgs (
Layer layer,
int index
)

Visual Basic [image] Copy Code

Public New ( _
layer As Layer, _
index As Integer _
)

Parameters

layer

index

See Also

LayerEventArgs Class


MindFusion.Diagramming.LayerEventArgs Properties

LayerEventArgs Properties
[image]

Public Properties

Name | Description
Index | Gets or sets the layer index related to the current event.
Layer | Gets or sets the Layer related to the current event.

See Also

LayerEventArgs Class


MindFusion.Diagramming.LayerEventArgs.Index Property

LayerEventArgs.Index Property
[image]

Gets or sets the layer index related to the current event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Index { get; set; }

Visual Basic [image] Copy Code

Public Property Index As Integer

Property Value

See Also

LayerEventArgs Members
LayerEventArgs Class


MindFusion.Diagramming.LayerEventArgs.Layer Property

LayerEventArgs.Layer Property
[image]

Gets or sets the Layer related to the current event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Layer Layer { get; set; }

Visual Basic [image] Copy Code

Public Property Layer As Layer

Property Value

See Also

LayerEventArgs Members
LayerEventArgs Class


MindFusion.Diagramming.LineTemplate Class

LineTemplate Class
[image]

Represents a line segment in a shape definition.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LineTemplate : ElementTemplate

Visual Basic [image] Copy Code

Public Class LineTemplate
Inherits ElementTemplate

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ElementTemplate
MindFusion.Diagramming.LineTemplate

See Also

LineTemplate Members


MindFusion.Diagramming.LineTemplate Members

LineTemplate Members
Constructors Properties Methods
[image]

Represents a line segment in a shape definition.

The following tables list the members exposed by the LineTemplate type.

Public Constructors

Name | Description
LineTemplate | Overloaded. Initializes a new instance of the LineTemplate class.

Public Properties

Name | Description
Color | Gets or sets the outline color of this element. (Inherited from ElementTemplate.)
Coordinates | Gets a float array containing the coordinates of the end points of this line segment.
DashStyle | Gets or sets the dash style of the outline of this element. (Inherited from ElementTemplate.)
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

Public Methods

Name | Description
Clone | Create an exact copy of this LineTemplate element.
SameAs | ElementTemplate.SameAs override.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument. (Inherited from ElementTemplate.)

See Also

LineTemplate Class


MindFusion.Diagramming.LineTemplate Constructor

LineTemplate Constructor
[image]

Initializes a new instance of the LineTemplate class.

Overload List

Name | Description
LineTemplate (Single, Single, Single, Single) | Initializes a new instance of the LineTemplate class with the specified start and end point.
LineTemplate (Single, Single, Single, Single, Color, DashStyle, Single) | Initializes a new instance of the LineTemplate class with the specified start and end points, and the specified color and style.

See Also

LineTemplate Class


MindFusion.Diagramming.LineTemplate Constructor (Single, Single, Single, Single)

LineTemplate Constructor (Single, Single, Single, Single)
See Also
[image]

Initializes a new instance of the LineTemplate class with the specified start and end point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LineTemplate (
float x1,
float y1,
float x2,
float y2
)

Visual Basic [image] Copy Code

Public New ( _
x1 As Single, _
y1 As Single, _
x2 As Single, _
y2 As Single _
)

Parameters

x1
The x-coordinate of the first point, expressed in percents of a shape node's bounding rectangle.
y1
The y-coordinate of the first point, expressed in percents of a shape node's bounding rectangle.
x2
The x-coordinate of the second point, expressed in percents of a shape node's bounding rectangle.
y2
The y-coordinate of the second point, expressed in percents of a shape node's bounding rectangle.

Remarks

A line template is defined by two points whose coordinates are passed as arguments.

See Also

LineTemplate Constructor Overload List
LineTemplate Class


MindFusion.Diagramming.LineTemplate Constructor (Single, Single, Single, Single, Color, DashStyle, Single)

LineTemplate Constructor (Single, Single, Single, Single, Color, DashStyle, Single)
See Also
[image]

Initializes a new instance of the LineTemplate class with the specified start and end points, and the specified color and style.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LineTemplate (
float x1,
float y1,
float x2,
float y2,
Color color,
DashStyle dashStyle,
float width
)

Visual Basic [image] Copy Code

Public New ( _
x1 As Single, _
y1 As Single, _
x2 As Single, _
y2 As Single, _
color As Color, _
dashStyle As DashStyle, _
width As Single _
)

Parameters

x1
The x-coordinate of the first point, expressed in percents of a shape node's bounding rectangle.
y1
The y-coordinate of the first point, expressed in percents of a shape node's bounding rectangle.
x2
The x-coordinate of the second point, expressed in percents of a shape node's bounding rectangle.
y2
The y-coordinate of the second point, expressed in percents of a shape node's bounding rectangle.
color
The color of this segment.
dashStyle
The dash style of this segment.
width
The width of this segment.

Remarks

A line template is defined by two points whose coordinates are passed as arguments.

See Also

LineTemplate Constructor Overload List
LineTemplate Class


MindFusion.Diagramming.LineTemplate Methods

LineTemplate Methods
[image]

Public Methods

Name | Description
Clone | Create an exact copy of this LineTemplate element.
SameAs | ElementTemplate.SameAs override.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument. (Inherited from ElementTemplate.)

See Also

LineTemplate Class


MindFusion.Diagramming.LineTemplate.Clone Method

LineTemplate.Clone Method
[image]

Create an exact copy of this LineTemplate element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

An instance of the LineTemplate class.

Remarks

An instance of the LineTemplate class.

See Also

LineTemplate Members
LineTemplate Class


MindFusion.Diagramming.LineTemplate.SameAs Method

LineTemplate.SameAs Method
[image]

ElementTemplate.SameAs override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool SameAs (
ElementTemplate obj
)

Visual Basic [image] Copy Code

Public Overrides Function SameAs ( _
obj As ElementTemplate _
) As Boolean

Parameters

obj

The ElementTemplate to compare to this template.

Return Value

true if the specified object is a LineTemplate closely approximating this template; otherwise, false.

See Also

LineTemplate Members
LineTemplate Class


MindFusion.Diagramming.LineTemplate Properties

LineTemplate Properties
[image]

Public Properties

Name | Description
Color | Gets or sets the outline color of this element. (Inherited from ElementTemplate.)
Coordinates | Gets a float array containing the coordinates of the end points of this line segment.
DashStyle | Gets or sets the dash style of the outline of this element. (Inherited from ElementTemplate.)
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

See Also

LineTemplate Class


MindFusion.Diagramming.LineTemplate.Coordinates Property

LineTemplate.Coordinates Property
[image]

Gets a float array containing the coordinates of the end points of this line segment.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float[] Coordinates { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Coordinates As Single()

Property Value

An array of float values containing the coordinates of the points composing this element.

See Also

LineTemplate Members
LineTemplate Class


MindFusion.Diagramming.LinkAdjustmentHandle Class

LinkAdjustmentHandle Class
[image]

Represents an adjustment handle used to modify the position of a link's control point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LinkAdjustmentHandle : AdjustmentHandle

Visual Basic [image] Copy Code

Public Class LinkAdjustmentHandle
Inherits AdjustmentHandle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.AdjustmentHandle
MindFusion.Diagramming.LinkAdjustmentHandle

See Also

LinkAdjustmentHandle Members


MindFusion.Diagramming.LinkAdjustmentHandle Members

LinkAdjustmentHandle Members
Constructors Properties Methods
[image]

Represents an adjustment handle used to modify the position of a link's control point.

The following tables list the members exposed by the LinkAdjustmentHandle type.

Public Constructors

Name | Description
LinkAdjustmentHandle | Initializes a new instance of the LinkAdjustmentHandle class.

Public Properties

Name | Description
PointIndex | Gets or sets the index of a link's control point that will be adjusted by this handle.

Public Methods

Name | Description
IsMoveHandle | Returns a value indicating whether this handle is used to move items. (Inherited from AdjustmentHandle.)

See Also

LinkAdjustmentHandle Class


MindFusion.Diagramming.LinkAdjustmentHandle Constructor

LinkAdjustmentHandle Constructor
[image]

Initializes a new instance of the LinkAdjustmentHandle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkAdjustmentHandle (
int pointIndex
)

Visual Basic [image] Copy Code

Public New ( _
pointIndex As Integer _
)

Parameters

pointIndex

An integer value specifying the index of a link's control point that will be adjusted by this handle.

Remarks

When the user moves this handle, the respective element in link's ControlPoints collection is set to the handle's position.

See Also

LinkAdjustmentHandle Class


MindFusion.Diagramming.LinkAdjustmentHandle Properties

LinkAdjustmentHandle Properties
[image]

Public Properties

Name | Description
PointIndex | Gets or sets the index of a link's control point that will be adjusted by this handle.

See Also

LinkAdjustmentHandle Class


MindFusion.Diagramming.LinkAdjustmentHandle.PointIndex Property

LinkAdjustmentHandle.PointIndex Property
[image]

Gets or sets the index of a link's control point that will be adjusted by this handle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int PointIndex { get; set; }

Visual Basic [image] Copy Code

Public Property PointIndex As Integer

Property Value

An integer index specifying which element of link's ControlPoints collection is updated by this handle.

See Also

LinkAdjustmentHandle Members
LinkAdjustmentHandle Class


MindFusion.Diagramming.LinkCrossings Enumeration

LinkCrossings Enumeration
[image]

Defines values that indicate how to render link intersection points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum LinkCrossings

Visual Basic [image] Copy Code

Public Enum LinkCrossings

Members

Member name | Description
Straight | No special indication for link intersection points.
Arcs | An arc is drawn at the intersection point of two links. It connects the segments of the link at higher Z position and goes over the link at lower Z.
Cut | The intersection segments of links at lower Z position are cut by links at higher Z position.

Remarks

Values from this enumeration can be assigned to LinkCrossings.

See Also


MindFusion.Diagramming.LinkEventArgs Class

LinkEventArgs Class
[image]

Contains the arguments passed to handlers of link related events, such as LinkCreated and LinkDeleted.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LinkEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class LinkEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.LinkEventArgs
MindFusion.Diagramming.LinkShapeEventArgs
MindFusion.Diagramming.LinkValidationEventArgs

See Also

LinkEventArgs Members


MindFusion.Diagramming.LinkEventArgs Members

LinkEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to handlers of link related events, such as LinkCreated and LinkDeleted.

The following tables list the members exposed by the LinkEventArgs type.

Public Constructors

Name | Description
LinkEventArgs | Overloaded. Initializes a new instance of the LinkEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user.
Link | Gets the link for which the event raised.
MouseButton | Gets which mouse button has been pressed.
MousePosition | Gets or sets the current mouse pointer position.

See Also

LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs Constructor

LinkEventArgs Constructor
[image]

Initializes a new instance of the LinkEventArgs class.

Overload List

Name | Description
LinkEventArgs (DiagramLink) | Initializes a new instance of the LinkEventArgs class.
LinkEventArgs (DiagramLink, MouseButton, PointF) | Initializes a new instance of the LinkEventArgs class.
LinkEventArgs (DiagramLink, PointF, Int32) | Initializes a new instance of the LinkEventArgs class.

See Also

LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs Constructor (DiagramLink)

LinkEventArgs Constructor (DiagramLink)
See Also
[image]

Initializes a new instance of the LinkEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkEventArgs (
DiagramLink link
)

Visual Basic [image] Copy Code

Public Sub LinkEventArgs ( _
link As DiagramLink _
)

Parameters

link

The DiagramLink related to the event.

See Also

LinkEventArgs Constructor Overload List
LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs Constructor (DiagramLink, MouseButton, PointF)

LinkEventArgs Constructor (DiagramLink, MouseButton, PointF)
See Also
[image]

Initializes a new instance of the LinkEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkEventArgs (
DiagramLink link,
MouseButton mouseButton,
PointF mousePosition
)

Visual Basic [image] Copy Code

Public Sub LinkEventArgs ( _
link As DiagramLink, _
mouseButton As MouseButton, _
mousePosition As PointF _
)

Parameters

link

The DiagramLink related to the event.

mouseButton

The mouse button related to the event.

mousePosition

The position of the mouse cursor, in document coordinates.

See Also

LinkEventArgs Constructor Overload List
LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs Constructor (DiagramLink, PointF, Int32)

LinkEventArgs Constructor (DiagramLink, PointF, Int32)
See Also
[image]

Initializes a new instance of the LinkEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkEventArgs (
DiagramLink link,
PointF mousePosition,
int adjustmentHandle
)

Visual Basic [image] Copy Code

Public Sub LinkEventArgs ( _
link As DiagramLink, _
mousePosition As PointF, _
adjustmentHandle As Integer _
)

Parameters

link

The DiagramLink related to the event.

mousePosition

The position of the mouse cursor, in document coordinates.

adjustmentHandle

The zero-based index of the control point related to the event.

See Also

LinkEventArgs Constructor Overload List
LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs Properties

LinkEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user.
Link | Gets the link for which the event raised.
MouseButton | Gets which mouse button has been pressed.
MousePosition | Gets or sets the current mouse pointer position.

See Also

LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs.AdjustmentHandle Property

LinkEventArgs.AdjustmentHandle Property
[image]

Gets or sets the adjustment handle being moved by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int AdjustmentHandle { get; set; }

Visual Basic [image] Copy Code

Public Property AdjustmentHandle As Integer

Property Value

An integer that represents the index of the link's control point being moved.

See Also

LinkEventArgs Members
LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs.Link Property

LinkEventArgs.Link Property
[image]

Gets the link for which the event raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink Link { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Link As DiagramLink

Property Value

A DiagramLink instance.

See Also

LinkEventArgs Members
LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs.MouseButton Property

LinkEventArgs.MouseButton Property
[image]

Gets which mouse button has been pressed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MouseButton MouseButton { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MouseButton As MouseButton

Property Value

A member of the MouseButton enumeration specifying the currently pressed mouse button.

See Also

LinkEventArgs Members
LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs.MousePosition Property

LinkEventArgs.MousePosition Property
[image]

Gets or sets the current mouse pointer position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointF MousePosition { get; set; }

Visual Basic [image] Copy Code

Public Property MousePosition As PointF

Property Value

A .NET PointF object specifying the current mouse position.

See Also

LinkEventArgs Members
LinkEventArgs Class


MindFusion.Diagramming.LinkLabel Class

LinkLabel Class
Remarks See Also
[image]

Represents a label displayed by a DiagramLink. New labels can be added to a link by calling the DiagramLink.AddLabel method.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LinkLabel : InplaceEditable

Visual Basic [image] Copy Code

Public Class LinkLabel
Implements InplaceEditable

Remarks

The text displayed by a LinkLabel is set via the Text property, and its attributes are specified via Font. The label's foreground and background can be set via TextBrush and Brush properties.

The target position of a label along link segments is specified through RelativeTo and Index, and offset from that position via HorizontalOffset and VerticalOffset properties. Instead of using fixed offsets, enable the AutoArrange property to let links automatically choose positions of their labels that won't intersect nodes or other labels.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.LinkLabel

See Also

LinkLabel Members


MindFusion.Diagramming.LinkLabel Members

LinkLabel Members
Constructors Properties Methods
[image]

Represents a label displayed by a DiagramLink. New labels can be added to a link by calling the DiagramLink.AddLabel method.

The following tables list the members exposed by the LinkLabel type.

Public Constructors

Name | Description
LinkLabel | Overloaded. Initializes a new instance of the LinkLabel class.

Public Properties

Name | Description
AutoArrange | Gets or sets a value indicating whether the label can be auto arranged.
Brush | Gets or sets the brush used to draw the label's background.
EnableWrap | Gets or sets a value indicating whether the label's text can be wrapped.
Font | Gets or sets the label's font.
HorizontalAlign | Gets or sets the label's horizontal alignment.
HorizontalOffset | Gets or sets the label's horizontal offset.
Index | Gets or sets the index of the segment or control point this label is relative to.
Link | Gets or sets the DiagramLink that displays this label.
Margin | Gets or sets the label's margin size.
MaxWidth | Gets or sets the maximum width of the label.
RelativeTo | Gets or sets the label's relative positioning.
Text | Gets or sets the label's text.
TextBrush | Gets or sets the brush used to draw the label's text.
VerticalAlign | Gets or sets the label's vertical alignment.
VerticalOffset | Gets or sets the label's vertical offset.

Public Methods

Name | Description
Clone | Creates a clone of this label.
Draw | Draws the link label on the specified IGraphics surface.
GetEditRect | InplaceEditable.GetEditRect implementation.
GetTextToEdit | InplaceEditable.GetTextToEdit implementation.
LoadFromXml | Loads the label from the specified XML element.
SaveToXml | Saves the label into the specified XML element.
SetControlPointPosition | Positions this label relatively to the specified control point.
SetEditedText | InplaceEditable.SetEditedText implementation.
SetLinkLengthPosition | Positions this label relatively to the link length.
SetSegmentPosition | Positions this label relatively to the specified link segment.

Protected Methods

Name | Description
PointAlongLength | Returns a point lying on a polyline that is positioned at a relative position along the polyline's length.

See Also

LinkLabel Class


MindFusion.Diagramming.LinkLabel Constructor

LinkLabel Constructor
[image]

Initializes a new instance of the LinkLabel class.

Overload List

Name | Description
LinkLabel () | Initializes a new instance of the LinkLabel class.
LinkLabel (DiagramLink) | Initializes a new instance of the LinkLabel class.
LinkLabel (DiagramLink, String) | Initializes a new instance of the LinkLabel class.

See Also

LinkLabel Class


MindFusion.Diagramming.LinkLabel Constructor ()

LinkLabel Constructor ()
See Also
[image]

Initializes a new instance of the LinkLabel class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkLabel ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LinkLabel Constructor Overload List
LinkLabel Class


MindFusion.Diagramming.LinkLabel Constructor (DiagramLink)

LinkLabel Constructor (DiagramLink)
See Also
[image]

Initializes a new instance of the LinkLabel class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkLabel (
DiagramLink link
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink _
)

Parameters

link

The DiagramLink that displays the label.

See Also

LinkLabel Constructor Overload List
LinkLabel Class


MindFusion.Diagramming.LinkLabel Constructor (DiagramLink, String)

LinkLabel Constructor (DiagramLink, String)
See Also
[image]

Initializes a new instance of the LinkLabel class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkLabel (
DiagramLink link,
string text
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink, _
text As String _
)

Parameters

link

The DiagramLink that displays the label.

text

The label's text.

See Also

LinkLabel Constructor Overload List
LinkLabel Class


MindFusion.Diagramming.LinkLabel Methods

LinkLabel Methods
[image]

Public Methods

Name | Description
Clone | Creates a clone of this label.
Draw | Draws the link label on the specified IGraphics surface.
GetEditRect | InplaceEditable.GetEditRect implementation.
GetTextToEdit | InplaceEditable.GetTextToEdit implementation.
LoadFromXml | Loads the label from the specified XML element.
SaveToXml | Saves the label into the specified XML element.
SetControlPointPosition | Positions this label relatively to the specified control point.
SetEditedText | InplaceEditable.SetEditedText implementation.
SetLinkLengthPosition | Positions this label relatively to the link length.
SetSegmentPosition | Positions this label relatively to the specified link segment.

Protected Methods

Name | Description
PointAlongLength | Returns a point lying on a polyline that is positioned at a relative position along the polyline's length.

See Also

LinkLabel Class


MindFusion.Diagramming.LinkLabel.Clone Method

LinkLabel.Clone Method
[image]

Creates a clone of this label.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkLabel Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As LinkLabel

Return Value

A new LinkLabel instance that is an exact copy of this label.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.Draw Method

LinkLabel.Draw Method
[image]

Draws the link label on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void Draw (
IGraphics graphics
)

Visual Basic [image] Copy Code

Public Overridable Sub Draw( _
graphics As IGraphics _
)

Parameters

graphics

An IGraphics object where the link label should be rendered.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.GetEditRect Method

LinkLabel.GetEditRect Method
[image]

InplaceEditable.GetEditRect implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF GetEditRect (
DiagramItem item,
PointF mousePosition
)

Visual Basic [image] Copy Code

Public Function GetEditRect( _
item As DiagramItem, _
mousePosition As PointF _
) As RectangleF

Parameters

item

The item being edited.

mousePosition
A PointF instance specifying the mouse position.

Return Value

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.GetTextToEdit Method

LinkLabel.GetTextToEdit Method
[image]

InplaceEditable.GetTextToEdit implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string GetTextToEdit ()

Visual Basic [image] Copy Code

Public Function GetTextToEdit () As String

Return Value

A string value.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.LoadFromXml Method

LinkLabel.LoadFromXml Method
[image]

Loads the label from the specified XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

A XmlElement instance.

context

A XmlPersistContext instance.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.PointAlongLength Method

LinkLabel.PointAlongLength Method
[image]

Returns a point lying on a polyline that is positioned at a relative position along the polyline's length.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected PointF PointAlongLength (
float lengthFactor,
PointCollection segments
)

Visual Basic [image] Copy Code

Protected Function PointAlongLength( _
lengthFactor As Single, _
segments As PointCollection _
) As PointF

Parameters

lengthFactor

A value from 0 to 1 specifying a portion of link's length.

segments

A list of points specifying the polyline segments.

Return Value

A PointF instance.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.SaveToXml Method

LinkLabel.SaveToXml Method
[image]

Saves the label into the specified XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

A XmlElement instance.

context

A XmlPersistContext instance.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.SetControlPointPosition Method

LinkLabel.SetControlPointPosition Method
[image]

Positions this label relatively to the specified control point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetControlPointPosition (
int controlPoint,
float dx,
float dy
)

Visual Basic [image] Copy Code

Public Sub SetControlPointPosition( _
controlPoint As Integer, _
dx As Single, _
dy As Single _
)

Parameters

controlPoint

The control point index.

dx

Horizontal offset from the point.

dy

Vertical offset from the point.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.SetEditedText Method

LinkLabel.SetEditedText Method
[image]

InplaceEditable.SetEditedText implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetEditedText (
string newText
)

Visual Basic [image] Copy Code

Public Sub SetEditedText( _
newText As String _
)

Parameters

newText

The new text of the in-place edited object.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.SetLinkLengthPosition Method

LinkLabel.SetLinkLengthPosition Method
[image]

Positions this label relatively to the link length.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetLinkLengthPosition (
float lengthFactor
)

Visual Basic [image] Copy Code

Public Sub SetLinkLengthPosition( _
lengthFactor As Single _
)

Parameters

lengthFactor

A value between 0 and 1 specifying the position of the label relatively to the link's length.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.SetSegmentPosition Method

LinkLabel.SetSegmentPosition Method
[image]

Positions this label relatively to the specified link segment.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetSegmentPosition (
int segment,
float dx,
float dy
)

Visual Basic [image] Copy Code

Public Sub SetSegmentPosition( _
segment As Integer, _
dx As Single, _
dy As Single _
)

Parameters

segment

The segment index.

dx

Horizontal offset from the segment center.

dy

Vertical offset from the segment center.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel Properties

LinkLabel Properties
[image]

Public Properties

Name | Description
AutoArrange | Gets or sets a value indicating whether the label can be auto arranged.
Brush | Gets or sets the brush used to draw the label's background.
EnableWrap | Gets or sets a value indicating whether the label's text can be wrapped.
Font | Gets or sets the label's font.
HorizontalAlign | Gets or sets the label's horizontal alignment.
HorizontalOffset | Gets or sets the label's horizontal offset.
Index | Gets or sets the index of the segment or control point this label is relative to.
Link | Gets or sets the DiagramLink that displays this label.
Margin | Gets or sets the label's margin size.
MaxWidth | Gets or sets the maximum width of the label.
RelativeTo | Gets or sets the label's relative positioning.
Text | Gets or sets the label's text.
TextBrush | Gets or sets the brush used to draw the label's text.
VerticalAlign | Gets or sets the label's vertical alignment.
VerticalOffset | Gets or sets the label's vertical offset.

See Also

LinkLabel Class


MindFusion.Diagramming.LinkLabel.AutoArrange Property

LinkLabel.AutoArrange Property
[image]

Gets or sets a value indicating whether the label can be auto arranged.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoArrange { get; set; }

Visual Basic [image] Copy Code

Public Property AutoArrange As Boolean

Property Value

true to automatically place the label; otherwise, false.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.Brush Property

LinkLabel.Brush Property
[image]

Gets or sets the brush used to draw the label's background.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

A Brush used to paint the label's background. The default value is null.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.EnableWrap Property

LinkLabel.EnableWrap Property
[image]

Gets or sets a value indicating whether the label's text can be wrapped.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableWrap { get; set; }

Visual Basic [image] Copy Code

Public Property EnableWrap As Boolean

Property Value

true to enable text wrapping; otherwise, false.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.Font Property

LinkLabel.Font Property
[image]

Gets or sets the label's font.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Font Font { get; set; }

Visual Basic [image] Copy Code

Public Property Font As Font

Property Value

A .NET Font object.

Remarks

This property can be null (Nothing in Visual Basic) in which case the label will use the Font of its parent link.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.HorizontalAlign Property

LinkLabel.HorizontalAlign Property
[image]

Gets or sets the label's horizontal alignment.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringAlignment HorizontalAlign { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalAlign As StringAlignment

Property Value

A member of the StringAlignment enumeration. The default is Center.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.HorizontalOffset Property

LinkLabel.HorizontalOffset Property
[image]

Gets or sets the label's horizontal offset.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float HorizontalOffset { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalOffset As Single

Property Value

A float value.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.Index Property

LinkLabel.Index Property
[image]

Gets or sets the index of the segment or control point this label is relative to.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Index { get; set; }

Visual Basic [image] Copy Code

Public Property Index As Integer

Property Value

An integer value.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.Link Property

LinkLabel.Link Property
[image]

Gets or sets the DiagramLink that displays this label.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink Link { get; set; }

Visual Basic [image] Copy Code

Public Property Link As DiagramLink

Property Value

A DiagramLink object.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.Margin Property

LinkLabel.Margin Property
[image]

Gets or sets the label's margin size.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Thickness Margin { get; set; }

Visual Basic [image] Copy Code

Public Property Margin As Thickness

Property Value

A Thickness instance specifying the size of text margins.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.MaxWidth Property

LinkLabel.MaxWidth Property
[image]

Gets or sets the maximum width of the label.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float MaxWidth { get; set; }

Visual Basic [image] Copy Code

Public Property MaxWidth As Single

Property Value

A float value.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.RelativeTo Property

LinkLabel.RelativeTo Property
[image]

Gets or sets the label's relative positioning.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RelativeToLink RelativeTo { get; set; }

Visual Basic [image] Copy Code

Public Property RelativeTo As RelativeToLink

Property Value

A member of the RelativeToLink enumeration. The default is LinkLength.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.Text Property

LinkLabel.Text Property
[image]

Gets or sets the label's text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Text { get; set; }

Visual Basic [image] Copy Code

Public Property Text As String

Property Value

A string value.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.TextBrush Property

LinkLabel.TextBrush Property
[image]

Gets or sets the brush used to draw the label's text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush TextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TextBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.VerticalAlign Property

LinkLabel.VerticalAlign Property
[image]

Gets or sets the label's vertical alignment.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringAlignment VerticalAlign { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalAlign As StringAlignment

Property Value

A member of the StringAlignment enumeration. The default is Far.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.VerticalOffset Property

LinkLabel.VerticalOffset Property
[image]

Gets or sets the label's vertical offset.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float VerticalOffset { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalOffset As Single

Property Value

A float value.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkShape Enumeration

LinkShape Enumeration
[image]

Specifies available styles for the segments of links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum LinkShape

Visual Basic [image] Copy Code

Public Enumeration LinkShape

Members

Member name | Description
Bezier | The segments of a link are Bйzier curves.
Polyline | The segments of the link are straight lines.
Cascading | The segments of a link are horizontal and vertical lines, each one orthogonal to each adjacent segment.

Remarks

Values from this enumeration can be assigned to the Shape property of links or to the LinkShape property of the diagram.

See Also


MindFusion.Diagramming.LinkShapeEventArgs Class

LinkShapeEventArgs Class
[image]

Contains the arguments passed to the SetSelfLoopShape event handler.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LinkShapeEventArgs : LinkEventArgs

Visual Basic [image] Copy Code

Public Class LinkShapeEventArgs
Inherits LinkEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.LinkEventArgs
MindFusion.Diagramming.LinkShapeEventArgs

See Also

LinkShapeEventArgs Members


MindFusion.Diagramming.LinkShapeEventArgs Members

LinkShapeEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the SetSelfLoopShape event handler.

The following tables list the members exposed by the LinkShapeEventArgs type.

Public Constructors

Name | Description
LinkShapeEventArgs | Initializes a new instance of the LinkShapeEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from LinkEventArgs.)
Handled | Indicates whether the event handler has set a custom loop shape.
Link | Gets the link for which the event raised. (Inherited from LinkEventArgs.)
MouseButton | Gets which mouse button has been pressed. (Inherited from LinkEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from LinkEventArgs.)

See Also

LinkShapeEventArgs Class


MindFusion.Diagramming.LinkShapeEventArgs Constructor

LinkShapeEventArgs Constructor
[image]

Initializes a new instance of the LinkShapeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkShapeEventArgs (
DiagramLink link
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink _
)

Parameters

link

The DiagramLink that becomes a self-loop.

See Also

LinkShapeEventArgs Class


MindFusion.Diagramming.LinkShapeEventArgs Properties

LinkShapeEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from LinkEventArgs.)
Handled | Indicates whether the event handler has set a custom loop shape.
Link | Gets the link for which the event raised. (Inherited from LinkEventArgs.)
MouseButton | Gets which mouse button has been pressed. (Inherited from LinkEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from LinkEventArgs.)

See Also

LinkShapeEventArgs Class


MindFusion.Diagramming.LinkShapeEventArgs.Handled Property

LinkShapeEventArgs.Handled Property
[image]

Indicates whether the event handler has set a custom loop shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Handled { get; set; }

Visual Basic [image] Copy Code

Public Property Handled As Boolean

Property Value

true if a custom shape is specified and the control should not set the standard loop shape; otherwise, false. The default value is false.

See Also

LinkShapeEventArgs Members
LinkShapeEventArgs Class


MindFusion.Diagramming.LinkTextStyle Enumeration

LinkTextStyle Enumeration
[image]

Specifies the position and alignment of links' labels.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum LinkTextStyle

Visual Basic [image] Copy Code

Public Enum LinkTextStyle

Members

Member name | Description
Center | The text is displayed horizontally above the middle link segment or control point, depending on whether there are an odd or even number of segments.
Rotate | The text is displayed rotated at the same angle as the segment where the text is placed. A long enough segment from the middle link segments is chosen for that purpose.
OverLongestSegment | The text follows the longest link segment and is displayed centered at the segment's middle point.
Follow | The label text starts from the first point of the link and follows the path defined by the link segments. This style is useful for displaying long text.
MiddleSegment | The text is displayed horizontally above the middle link segment. If there are an even number of segments, the label is drawn over the longer from the two segments adjacent to the middle control point.
MiddleSegmentRotated | The text is displayed rotated at the same angle as the segment where the text is placed. A long enough segment from the middle link segments is chosen for that purpose.

Remarks

Values from this enumeration can be assigned to the TextStyle property of links or the LinkTextStyle property of the diagram.

See Also


MindFusion.Diagramming.LinkValidationEventArgs Class

LinkValidationEventArgs Class
[image]

Contains the arguments passed to handlers of link validation events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LinkValidationEventArgs : LinkEventArgs

Visual Basic [image] Copy Code

Public Class LinkValidationEventArgs
Inherits LinkEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.LinkEventArgs
MindFusion.Diagramming.LinkValidationEventArgs

See Also

LinkValidationEventArgs Members


MindFusion.Diagramming.LinkValidationEventArgs Members

LinkValidationEventArgs Members
Constructors Properties Methods
[image]

Contains the arguments passed to handlers of link validation events.

The following tables list the members exposed by the LinkValidationEventArgs type.

Public Constructors

Name | Description
LinkValidationEventArgs | Overloaded. Initializes a new instance of the LinkValidationEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from LinkEventArgs.)
AnchorIndex | Gets the anchor point related to a link validation event.
Cancel | Gets or sets a value indicating whether to cancel the current operation.
ChangingDestination | Gets a value indicating whether the user modifies the link's destination end point.
ChangingOrigin | Gets a value indicating whether the user modifies the link's origin end point.
Destination | Gets the node that will become the link's destination if the event is validated.
Link | Gets the link for which the event raised. (Inherited from LinkEventArgs.)
MouseButton | Gets which mouse button has been pressed. (Inherited from LinkEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from LinkEventArgs.)
Node | Gets the node to which the link will be connected.
Origin | Gets the node that would become the link's origin if the event is validated.
SelectionRectangle | Gets the current selection rectangle.
TableRow | Gets the table row related to a link validation event.

Public Methods

Name | Description
CancelDrag | Cancels the creation or modification of the link.

See Also

LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs Constructor

LinkValidationEventArgs Constructor
[image]

Initializes a new instance of the LinkValidationEventArgs class.

Overload List

Name | Description
LinkValidationEventArgs (DiagramLink) | Initializes a new instance of the LinkValidationEventArgs class.
LinkValidationEventArgs (DiagramLink, PointF, Int32, DiagramNode, Int32, Int32) | Initializes a new instance of the LinkValidationEventArgs class.
LinkValidationEventArgs (DiagramLink, RectangleF) | Initializes a new instance of the LinkValidationEventArgs class.

See Also

LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs Constructor (DiagramLink)

LinkValidationEventArgs Constructor (DiagramLink)
See Also
[image]

Initializes a new instance of the LinkValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkValidationEventArgs (
DiagramLink link
)

Visual Basic [image] Copy Code

Public Sub LinkValidationEventArgs ( _
link As DiagramLink _
)

Parameters

link

The DiagramLink related to the event.

See Also

LinkValidationEventArgs Constructor Overload List
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs Constructor (DiagramLink, PointF, Int32, DiagramNode, Int32, Int32)

LinkValidationEventArgs Constructor (DiagramLink, PointF, Int32, DiagramNode, Int32, Int32)
See Also
[image]

Initializes a new instance of the LinkValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkValidationEventArgs (
DiagramLink link,
PointF mousePosition,
int adjustmentHandle,
DiagramNode node,
int anchorIndex,
int tableRow
)

Visual Basic [image] Copy Code

Public Sub LinkValidationEventArgs ( _
link As DiagramLink, _
mousePosition As PointF, _
adjustmentHandle As Integer, _
node As DiagramNode, _
anchorIndex As Integer, _
tableRow As Integer _
)

Parameters

link

The DiagramLink related to the event.

mousePosition

The position of the mouse cursor, in document coordinates.

adjustmentHandle

The zero-based index of the control point related to the event.

node

The DiagramNode related to the event.

anchorIndex

The zero-based index of the anchor point related to the event.

tableRow

The zero-based index of the table row related to the event.

See Also

LinkValidationEventArgs Constructor Overload List
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs Constructor (DiagramLink, RectangleF)

LinkValidationEventArgs Constructor (DiagramLink, RectangleF)
See Also
[image]

Initializes a new instance of the LinkValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkValidationEventArgs (
DiagramLink link,
RectangleF selectionRectangle
)

Visual Basic [image] Copy Code

Public Sub LinkValidationEventArgs ( _
link As DiagramLink, _
selectionRectangle As RectangleF _
)

Parameters

link

The DiagramLink related to the event.

selectionRectangle

A .NET RectangleF object that represents the current selection rectangle.

See Also

LinkValidationEventArgs Constructor Overload List
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs Methods

LinkValidationEventArgs Methods
[image]

Public Methods

Name | Description
CancelDrag | Cancels the creation or modification of the link.

See Also

LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.CancelDrag Method

LinkValidationEventArgs.CancelDrag Method
[image]

Cancels the creation or modification of the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void CancelDrag ()

Visual Basic [image] Copy Code

Public Sub CancelDrag ()

Remarks

Calling this method immediately stops the operation. On the other hand, setting Cancel to true only changes the mouse cursor to a Stop icon and the operation is cancelled when the user releases the mouse button.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs Properties

LinkValidationEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from LinkEventArgs.)
AnchorIndex | Gets the anchor point related to a link validation event.
Cancel | Gets or sets a value indicating whether to cancel the current operation.
ChangingDestination | Gets a value indicating whether the user modifies the link's destination end point.
ChangingOrigin | Gets a value indicating whether the user modifies the link's origin end point.
Destination | Gets the node that will become the link's destination if the event is validated.
Link | Gets the link for which the event raised. (Inherited from LinkEventArgs.)
MouseButton | Gets which mouse button has been pressed. (Inherited from LinkEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from LinkEventArgs.)
Node | Gets the node to which the link will be connected.
Origin | Gets the node that would become the link's origin if the event is validated.
SelectionRectangle | Gets the current selection rectangle.
TableRow | Gets the table row related to a link validation event.

See Also

LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.AnchorIndex Property

LinkValidationEventArgs.AnchorIndex Property
[image]

Gets the anchor point related to a link validation event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int AnchorIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AnchorIndex As Integer

Property Value

An integer value specifying the index of an anchor point within an AnchorPattern.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.Cancel Property

LinkValidationEventArgs.Cancel Property
[image]

Gets or sets a value indicating whether to cancel the current operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

true to cancel the operation; false to approve it.

Remarks

Set this property to true to prevent the user from completing the operation.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.ChangingDestination Property

LinkValidationEventArgs.ChangingDestination Property
[image]

Gets a value indicating whether the user modifies the link's destination end point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ChangingDestination { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ChangingDestination As Boolean

Property Value

true if the user is changing the destination point; otherwise, false.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.ChangingOrigin Property

LinkValidationEventArgs.ChangingOrigin Property
[image]

Gets a value indicating whether the user modifies the link's origin end point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ChangingOrigin { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ChangingOrigin As Boolean

Property Value

true if the user is changing the origin point; otherwise, false.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.Destination Property

LinkValidationEventArgs.Destination Property
[image]

Gets the node that will become the link's destination if the event is validated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Destination { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Destination As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.Node Property

LinkValidationEventArgs.Node Property
[image]

Gets the node to which the link will be connected.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Node { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Node As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.Origin Property

LinkValidationEventArgs.Origin Property
[image]

Gets the node that would become the link's origin if the event is validated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Origin { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Origin As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.SelectionRectangle Property

LinkValidationEventArgs.SelectionRectangle Property
[image]

Gets the current selection rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF SelectionRectangle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SelectionRectangle As RectangleF

Property Value

A .NET RectangleF instance representing the selection rectangle.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.TableRow Property

LinkValidationEventArgs.TableRow Property
[image]

Gets the table row related to a link validation event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int TableRow { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TableRow As Integer

Property Value

An integer value specifying the zero-based index of a TableNode's row.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.MapContent Class

MapContent Class
Remarks See Also
[image]

Represents the content of a map file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class MapContent : IPersists

Visual Basic [image] Copy Code

Public Class MapContent
Implements IPersists

Remarks

At this time the control can load maps from files in Esri Shapefile format. To load a map, call the static FromFile method. Optional parameters let you load the DBF database associated with the map file. Once loaded, the MapContent object can be assigned to the Content property of a MapNode.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.MapContent

See Also

MapContent Members


MindFusion.Diagramming.MapContent Members

MapContent Members
Properties Methods
[image]

Represents the content of a map file.

The following tables list the members exposed by the MapContent type.

Public Properties

Name | Description
Map | Gets or sets the Map wrapped by this MapContent.

Public Methods

Name | Description
AddBrush | Adds a brush to the list of brushes used for shapes rendering.
AddPen | Adds a pen to the list of pens used for shapes rendering.
AssignColors | Assigns colors to polygon shapes in the map in such a way that no two adjacent polygons are painted in the same color.
Draw | Draws this MapContent on the specified graphics surface.
FromFile | Overloaded. Creates a MapContent object from the specified map file.
FromXml | Creates a MapContent object from the specified OSM file.
Transform | Gets a matrix representing the transformation from layer to screen coordinates.

See Also

MapContent Class


MindFusion.Diagramming.MapContent Methods

MapContent Methods
[image]

Public Methods

Name | Description
AddBrush | Adds a brush to the list of brushes used for shapes rendering.
AddPen | Adds a pen to the list of pens used for shapes rendering.
AssignColors | Assigns colors to polygon shapes in the map in such a way that no two adjacent polygons are painted in the same color.
Draw | Draws this MapContent on the specified graphics surface.
FromFile | Overloaded. Creates a MapContent object from the specified map file.
FromXml | Creates a MapContent object from the specified OSM file.
Transform | Gets a matrix representing the transformation from layer to screen coordinates.

See Also

MapContent Class


MindFusion.Diagramming.MapContent.AddBrush Method

MapContent.AddBrush Method
[image]

Adds a brush to the list of brushes used for shapes rendering.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AddBrush (
string tagKey,
string tagValue,
SolidBrush brush
)

Visual Basic [image] Copy Code

Public Sub AddBrush( _
tagKey As String, _
tagValue As String, _
brush As SolidBrush _
)

Parameters

tagKey

The key of the tag, specifying the map feature.

tagValue

The value of the tag, specifying the map feature.

brush

The SolidBrush object to add.

See Also

MapContent Members
MapContent Class


MindFusion.Diagramming.MapContent.AddPen Method

MapContent.AddPen Method
[image]

Adds a pen to the list of pens used for shapes rendering.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AddPen (
string tagKey,
string tagValue,
Pen pen
)

Visual Basic [image] Copy Code

Public Sub AddPen( _
tagKey As String, _
tagValue As String, _
pen As Pen _
)

Parameters

tagKey

The key of the tag, specifying the map feature.

tagValue

The value of the tag, specifying the map feature.

pen

The Pen object to add.

See Also

MapContent Members
MapContent Class


MindFusion.Diagramming.MapContent.AssignColors Method

MapContent.AssignColors Method
[image]

Assigns colors to polygon shapes in the map in such a way that no two adjacent polygons are painted in the same color.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AssignColors ()

Visual Basic [image] Copy Code

Public Sub AssignColors ()

Remarks

Colors are associated with map regions by integer index. To set the actual colors, set the FillColors property of MapNode.

See Also

MapContent Members
MapContent Class


MindFusion.Diagramming.MapContent.Draw Method

MapContent.Draw Method
[image]

Draws this MapContent on the specified graphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Draw (
IGraphics graphics,
RectangleF bounds,
Brush overrideBrush,
Color lineColor,
Color[] fillColors,
bool drawLabels,
Font labelFont,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Sub Draw( _
graphics As IGraphics, _
bounds As RectangleF, _
overrideBrush As Brush, _
lineColor As Color, _
fillColors() As Color, _
drawLabels As Boolean, _
labelFont As Font, _
options As RenderOptions _
)

Parameters

graphics

bounds

overrideBrush

lineColor

fillColors

drawLabels

labelFont

options

See Also

MapContent Members
MapContent Class


MindFusion.Diagramming.MapContent.FromFile Method

MapContent.FromFile Method
[image]

Creates a MapContent object from the specified map file.

Overload List

Name | Description
MapContent.FromFile (String) | Creates a MapContent object from the specified map file.
MapContent.FromFile (String, Boolean, String) | Creates a MapContent object from the specified map file.

See Also

MapContent Members
MapContent Class


MindFusion.Diagramming.MapContent.FromFile Method (String)

MapContent.FromFile Method (String)
See Also
[image]

Creates a MapContent object from the specified map file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static MapContent FromFile (
string fileName
)

Visual Basic [image] Copy Code

Public Shared Function FromFile( _
fileName As String _
) As MapContent

Parameters

fileName

A string containing the path of an Esri shapefile.

Return Value

A MapContent instance.

See Also

FromFile Method Overload List
MapContent Members
MapContent Class


MindFusion.Diagramming.MapContent.FromFile Method (String, Boolean, String)

MapContent.FromFile Method (String, Boolean, String)
See Also
[image]

Creates a MapContent object from the specified map file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static MapContent FromFile (
string fileName,
bool loadDatabase,
string labelField
)

Visual Basic [image] Copy Code

Public Shared Function FromFile( _
fileName As String, _
loadDatabase As Boolean, _
labelField As String _
) As MapContent

Parameters

fileName

A string containing the path to an Esri shapefile.

loadDatabase

true to load the database associated with specified map, or false otherwise.

labelField

Name of the database column containing region labels.

Return Value

A MapContent instance.

See Also

FromFile Method Overload List
MapContent Members
MapContent Class


MindFusion.Diagramming.MapContent.FromXml Method

MapContent.FromXml Method
[image]

Creates a MapContent object from the specified OSM file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static MapContent FromXml (
string fileName
)

Visual Basic [image] Copy Code

Public Shared Function FromXml( _
fileName As String _
) As MapContent

Parameters

fileName

A string containing the file path.

Return Value

A MapContent instance.

See Also

MapContent Members
MapContent Class


MindFusion.Diagramming.MapContent.Transform Method

MapContent.Transform Method
[image]

Gets a matrix representing the transformation from layer to screen coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Matrix Transform (
RectangleF targetRect
)

Visual Basic [image] Copy Code

Public Function Transform( _
targetRect As RectangleF _
) As Matrix

Parameters

targetRect

The target rectangle to which to map the map's bounding box.

Return Value

A Matrix instance.

See Also

MapContent Members
MapContent Class


MindFusion.Diagramming.MapContent Properties

MapContent Properties
[image]

Public Properties

Name | Description
Map | Gets or sets the Map wrapped by this MapContent.

See Also

MapContent Class


MindFusion.Diagramming.MapContent.Map Property

MapContent.Map Property
[image]

Gets or sets the Map wrapped by this MapContent.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Map Map { get; set; }

Visual Basic [image] Copy Code

Public Property Map As Map

Property Value

A MindFusion.Mapping.Map instance.

See Also

MapContent Members
MapContent Class


MindFusion.Diagramming.MapNode Class

MapNode Class
Remarks See Also
[image]

Represents nodes that can render geographical maps.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class MapNode : DiagramNode

Visual Basic [image] Copy Code

Public Class MapNode
Inherits DiagramNode

Remarks

At this time map nodes can display the content of Esri shapefile files. The content of a map file is represented by an instance of the MapContent class that should be assigned to the Content property of a MapNode. When the map comes with associated DBF database file, map regions can display labels if the labelField argument of FromFile is specified and DrawLabels is enabled. The color of a map region can be set via an integer index assigned to a map's Shape object, which identifies the element of FillColors that should be used to paint the shape.

Example

The following example shows how to load map content and assign it to a node.

C# [image] Copy Code
var content = MapContent.FromFile(
"United Kingdom.shp", true, "NAME_1");

var mapNode = new MapNode();
mapNode.Bounds = new RectangleF(0, 0, 400, 400);
mapNode.Content = content;
mapNode.DrawLabels = true;
content.AssignColors();
diagram.Nodes.Add(mapNode);

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.MapNode

See Also

MapNode Members


MindFusion.Diagramming.MapNode Members

MapNode Members
Constructors Fields Properties Methods
[image]

Represents nodes that can render geographical maps.

The following tables list the members exposed by the MapNode type.

Public Constructors

Name | Description
MapNode | Overloaded.

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Content | Gets or set a MapContent instance representing the map rendered in this node.
DrawLabels | Gets or sets whether to draw labels of map regions.
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
FillColors | Gets or sets the fill colors of map regions.
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | Determines whether the node supports connections to its constituent elements. (Inherited from DiagramNode.)
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
DiagramToMap | Converts a point from diagram's logical coordinates to map coordinates.
Dispose | Overloaded. (Inherited from DiagramItem.)
DoModify | For internal use. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. Renders the adjustment handles of this item. (Inherited from DiagramNode.)
DrawLocal | DiagramNode.DrawLocal override.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | DiagramNode.DrawShadowLocal override.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item. (Inherited from DiagramItem.)
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item. (Inherited from DiagramItem.)
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item. (Inherited from DiagramItem.)
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item. (Inherited from DiagramItem.)
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point. (Inherited from DiagramNode.)
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Intersects | Determines whether the node intersects another one, taking into account the outlines of node shapes. (Inherited from DiagramNode.)
MapToDiagram | Converts a point from map coordinates to diagram's logical coordinates.
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
ResizeToFitMap | Sets the node's height to the current width multiplied by the ratio of map's intrinsic bounding box.
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetPos | Sets the bounding rectangle of this node without updating connected arrows. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
CancelModify | DiagramItem.CancelModify override. Invoked when the interactive modification of this object has been canceled. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Checks whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
Finalize | DiagramItem finalizer. (Inherited from DiagramItem.)
FreeResources | Called when the node is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from DiagramNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the item content from an XML element.
LoadObsolete | For internal use. (Inherited from DiagramItem.)
OnAdd | DiagramItem.OnAdd override. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnClick | Invoked when the user clicks this item. (Inherited from DiagramItem.)
OnDoubleClick | Invoked when the user double-clicks this item. (Inherited from DiagramItem.)
OnMeasureUnitChanged | DiagramItem.OnMeasureUnitChanged override. (Inherited from DiagramNode.)
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | Overloaded. (Inherited from DiagramNode.)
OnZoomChanged | DiagramItem.OnZoomChanged override. (Inherited from DiagramNode.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReference | DiagramNode.SetReference override.
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. Invoked when the user starts modifying this item interactively. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster. (Inherited from DiagramItem.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. Invoked during interactive modification of this item. (Inherited from DiagramNode.)

See Also

MapNode Class


MindFusion.Diagramming.MapNode Constructor

MapNode Constructor
[image]

Overload List

Name | Description
MapNode () | Initializes a new instance of the MapNode class.
MapNode (Diagram) | Initializes a new instance of the MapNode class.
MapNode (MapNode) | Initializes a new instance of the MapNode class.

See Also

MapNode Class


MindFusion.Diagramming.MapNode Constructor ()

MapNode Constructor ()
See Also
[image]

Initializes a new instance of the MapNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MapNode ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

MapNode Constructor Overload List
MapNode Class


MindFusion.Diagramming.MapNode Constructor (Diagram)

MapNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the MapNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MapNode (
Diagram parent
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram _
)

Parameters

parent

See Also

MapNode Constructor Overload List
MapNode Class


MindFusion.Diagramming.MapNode Constructor (MapNode)

MapNode Constructor (MapNode)
See Also
[image]

Initializes a new instance of the MapNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MapNode (
MapNode prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As MapNode _
)

Parameters

prototype

See Also

MapNode Constructor Overload List
MapNode Class


MindFusion.Diagramming.MapNode Methods

MapNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
DiagramToMap | Converts a point from diagram's logical coordinates to map coordinates.
Dispose | Overloaded. (Inherited from DiagramItem.)
DoModify | For internal use. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. Renders the adjustment handles of this item. (Inherited from DiagramNode.)
DrawLocal | DiagramNode.DrawLocal override.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | DiagramNode.DrawShadowLocal override.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item. (Inherited from DiagramItem.)
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item. (Inherited from DiagramItem.)
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item. (Inherited from DiagramItem.)
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item. (Inherited from DiagramItem.)
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point. (Inherited from DiagramNode.)
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Intersects | Determines whether the node intersects another one, taking into account the outlines of node shapes. (Inherited from DiagramNode.)
MapToDiagram | Converts a point from map coordinates to diagram's logical coordinates.
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
ResizeToFitMap | Sets the node's height to the current width multiplied by the ratio of map's intrinsic bounding box.
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetPos | Sets the bounding rectangle of this node without updating connected arrows. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
CancelModify | DiagramItem.CancelModify override. Invoked when the interactive modification of this object has been canceled. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Checks whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
Finalize | DiagramItem finalizer. (Inherited from DiagramItem.)
FreeResources | Called when the node is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from DiagramNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the item content from an XML element.
LoadObsolete | For internal use. (Inherited from DiagramItem.)
OnAdd | DiagramItem.OnAdd override. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnClick | Invoked when the user clicks this item. (Inherited from DiagramItem.)
OnDoubleClick | Invoked when the user double-clicks this item. (Inherited from DiagramItem.)
OnMeasureUnitChanged | DiagramItem.OnMeasureUnitChanged override. (Inherited from DiagramNode.)
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | Overloaded. (Inherited from DiagramNode.)
OnZoomChanged | DiagramItem.OnZoomChanged override. (Inherited from DiagramNode.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReference | DiagramNode.SetReference override.
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. Invoked when the user starts modifying this item interactively. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster. (Inherited from DiagramItem.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. Invoked during interactive modification of this item. (Inherited from DiagramNode.)

See Also

MapNode Class


MindFusion.Diagramming.MapNode.CreateProperties Method

MapNode.CreateProperties Method
[image]

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override DiagramItemProperties CreateProperties ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateProperties () As DiagramItemProperties

Return Value

A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

MapNode Members
MapNode Class


MindFusion.Diagramming.MapNode.DiagramToMap Method

MapNode.DiagramToMap Method
[image]

Converts a point from diagram's logical coordinates to map coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point DiagramToMap (
PointF point
)

Visual Basic [image] Copy Code

Public Function DiagramToMap( _
point As PointF _
) As Point

Parameters

point

A System.Drawing.Point instance.

Return Value

A MindFusion.Mapping.Point instance.

See Also

MapNode Members
MapNode Class
MapToDiagram Method


MindFusion.Diagramming.MapNode.DrawLocal Method

MapNode.DrawLocal Method
[image]

DiagramNode.DrawLocal override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawLocal (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawLocal( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

An IGraphics object where the node should be rendered.

options

Provides options for the drawing operation.

See Also

MapNode Members
MapNode Class


MindFusion.Diagramming.MapNode.DrawShadowLocal Method

MapNode.DrawShadowLocal Method
[image]

DiagramNode.DrawShadowLocal override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawShadowLocal (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawShadowLocal( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

An IGraphics object where the shadow should be rendered.

options

Provides options for the drawing operation.

See Also

MapNode Members
MapNode Class


MindFusion.Diagramming.MapNode.LoadFrom Method

MapNode.LoadFrom Method
[image]

Deserializes the object from the specified reader.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void LoadFrom (
BinaryReader reader,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFrom( _
reader As BinaryReader, _
context As PersistContext _
)

Parameters

reader

A BinaryReader object from which to read the item's data.

context

A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

MapNode Members
MapNode Class


MindFusion.Diagramming.MapNode.LoadFromXml Method

MapNode.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement containing the item's data.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

MapNode Members
MapNode Class


MindFusion.Diagramming.MapNode.MapToDiagram Method

MapNode.MapToDiagram Method
[image]

Converts a point from map coordinates to diagram's logical coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointF MapToDiagram (
Point point
)

Visual Basic [image] Copy Code

Public Function MapToDiagram( _
point As Point _
) As PointF

Parameters

point

A MindFusion.Mapping.Point instance.

Return Value

A System.Drawing.Point instance.

See Also

MapNode Members
MapNode Class
DiagramToMap Method


MindFusion.Diagramming.MapNode.ResizeToFitMap Method

MapNode.ResizeToFitMap Method
[image]

Sets the node's height to the current width multiplied by the ratio of map's intrinsic bounding box.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ResizeToFitMap ()

Visual Basic [image] Copy Code

Public Sub ResizeToFitMap ()

See Also

MapNode Members
MapNode Class


MindFusion.Diagramming.MapNode.RestoreProperties Method

MapNode.RestoreProperties Method
[image]

DiagramNode.RestoreProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub RestoreProperties( _
props As DiagramItemProperties _
)

Parameters

props

A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

MapNode Members
MapNode Class


MindFusion.Diagramming.MapNode.SaveProperties Method

MapNode.SaveProperties Method
[image]

DiagramNode.SaveProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveProperties( _
props As DiagramItemProperties _
)

Parameters

props

A DiagramItemProperties-derived object where the item's properties should be saved.

See Also

MapNode Members
MapNode Class


MindFusion.Diagramming.MapNode.SaveTo Method

MapNode.SaveTo Method
[image]

Serializes the object to the specified writer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SaveTo (
BinaryWriter writer,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveTo( _
writer As BinaryWriter, _
context As PersistContext _
)

Parameters

writer

A BinaryWriter object the item's data should be written to.

context

A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

MapNode Members
MapNode Class


MindFusion.Diagramming.MapNode.SaveToXml Method

MapNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement the item's data should be stored into.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

MapNode Members
MapNode Class


MindFusion.Diagramming.MapNode.SetReference Method

MapNode.SetReference Method
[image]

DiagramNode.SetReference override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SetReference (
int refId,
Object obj,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub SetReference( _
refId As Integer, _
obj As Object, _
context As PersistContext _
)

Parameters

refId

obj

context

See Also

MapNode Members
MapNode Class


MindFusion.Diagramming.MapNode Properties

MapNode Properties
[image]

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Content | Gets or set a MapContent instance representing the map rendered in this node.
DrawLabels | Gets or sets whether to draw labels of map regions.
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
FillColors | Gets or sets the fill colors of map regions.
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | Determines whether the node supports connections to its constituent elements. (Inherited from DiagramNode.)
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

See Also

MapNode Class


MindFusion.Diagramming.MapNode.Content Property

MapNode.Content Property
[image]

Gets or set a MapContent instance representing the map rendered in this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MapContent Content { get; set; }

Visual Basic [image] Copy Code

Public Property Content As MapContent

Property Value

See Also

MapNode Members
MapNode Class


MindFusion.Diagramming.MapNode.DrawLabels Property

MapNode.DrawLabels Property
[image]

Gets or sets whether to draw labels of map regions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool DrawLabels { get; set; }

Visual Basic [image] Copy Code

Public Property DrawLabels As Boolean

Property Value

true to draw region labels, or false otherwise. The default value is false.

Remarks

To enable labels, you must also specify the name of a database column whose values to show as region names, calling the respective FromFile overload.

See Also

MapNode Members
MapNode Class


MindFusion.Diagramming.MapNode.FillColors Property

MapNode.FillColors Property
[image]

Gets or sets the fill colors of map regions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color[] FillColors { get; set; }

Visual Basic [image] Copy Code

Public Property FillColors As Color()

Property Value

An array of Color objects.

See Also

MapNode Members
MapNode Class


MindFusion.Diagramming.MapNodeProperties Class

MapNodeProperties Class
[image]

Stores the values of MapNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from MapNode, do so by deriving from MapNodeProperties and overriding the MapNode.SaveProperties, MapNode.RestoreProperties, and MapNode.CreateProperties methods.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class MapNodeProperties : DiagramNodeProperties

Visual Basic [image] Copy Code

Public Class MapNodeProperties
Inherits DiagramNodeProperties

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemProperties
MindFusion.Diagramming.DiagramNodeProperties
MindFusion.Diagramming.MapNodeProperties

See Also

MapNodeProperties Members


MindFusion.Diagramming.MapNodeProperties Members

MapNodeProperties Members
Constructors Fields Methods
[image]

Stores the values of MapNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from MapNode, do so by deriving from MapNodeProperties and overriding the MapNode.SaveProperties, MapNode.RestoreProperties, and MapNode.CreateProperties methods.

The following tables list the members exposed by the MapNodeProperties type.

Public Constructors

Name | Description
MapNodeProperties |

Public Fields

Name | Description
ItemClass | For internal use. (Inherited from DiagramItemProperties.)
Selected | For internal use. (Inherited from DiagramItemProperties.)
TextPadding | For internal use. (Inherited from DiagramItemProperties.)
ZIndex | For internal use. (Inherited from DiagramItemProperties.)

Public Methods

Name | Description
FreeResources | Frees stored resources which will no longer be used. (Inherited from DiagramItemProperties.)

See Also

MapNodeProperties Class


MindFusion.Diagramming.MapNodeProperties Constructor

MapNodeProperties Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MapNodeProperties ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

MapNodeProperties Class


MindFusion.Diagramming.MarkStyle Enumeration

MarkStyle Enumeration
[image]

Specifies the visual style of anchor point marks.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum MarkStyle

Visual Basic [image] Copy Code

Public Enum MarkStyle

Members

Member name | Description
None | No visual indication for the anchor point.
Cross | Anchor point marked with a cross.
X | Anchor point marked with an 'X'.
Circle | Anchor point marked with a circle.
Rectangle | Anchor point marked with a rectangle.
Custom | A DrawAnchorPoint event is fired, allowing custom painting of anchor points.

Remarks

Members of this enumeration are used as values of the MarkStyle property of the AnchorPoint class.

See Also

MindFusion.Diagramming Namespace
AnchorPoint Class
MarkStyle Property
DrawAnchorPoint Event


MindFusion.Diagramming.MeasureUnit Class

MeasureUnit Class
Remarks See Also
[image]

Represents a unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class MeasureUnit

Visual Basic [image] Copy Code

Public Class MeasureUnit

Remarks

Instances of this class can be assigned to the MeasureUnit property of the Diagram class to indicate how size and length property values should be mapped to device pixels.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.MeasureUnit

See Also

MeasureUnit Members


MindFusion.Diagramming.MeasureUnit Members

MeasureUnit Members
Constructors Fields Properties Methods
[image]

Represents a unit of measure.

The following tables list the members exposed by the MeasureUnit type.

Public Constructors

Name | Description
MeasureUnit | Overloaded.

Public Fields

Name | Description
Centimeter | Specifies centimeters as the unit of measure.
Document | Specifies document units (1/300 inch) as the unit of measure.
Inch | Specifies inches as the unit of measure.
Millimeter | Specifies millimeters as the unit of measure.
Percent | Specifies percents as the unit of measure.
Pixel | Specifies device pixels as the unit of measure.
Point | Specifies printer's points (1/72 inch) as the unit of measure.
WpfPoint | Specifies device-independent pixels (1/96 inch) as the unit of measure.

Public Properties

Name | Description
Amount | Gets the unit's size in inches.
Id | Gets the unit identifier.
Name | Gets the name of the unit.
StandardDivisions | Gets the number of subunits that measures of this unit type are commonly divided to.

Public Methods

Name | Description
ApplyTo | Overloaded.
Convert | Overloaded.
Equals | Overloaded.
FromGraphicsUnit | Returns the measure unit corresponding to the specified graphics unit.
FromId | Returns a MeasureUnit from its integer identifier.
GetHashCode | Object.GetHashCode override.
ToGraphicsUnit | Returns the GraphicsUnit corresponding to this MeasureUnit.
ToString | Object.ToString override.

See Also

MeasureUnit Class


MindFusion.Diagramming.MeasureUnit Fields

MeasureUnit Fields
[image]

Public Fields

Name | Description
Centimeter | Specifies centimeters as the unit of measure.
Document | Specifies document units (1/300 inch) as the unit of measure.
Inch | Specifies inches as the unit of measure.
Millimeter | Specifies millimeters as the unit of measure.
Percent | Specifies percents as the unit of measure.
Pixel | Specifies device pixels as the unit of measure.
Point | Specifies printer's points (1/72 inch) as the unit of measure.
WpfPoint | Specifies device-independent pixels (1/96 inch) as the unit of measure.

See Also

MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Centimeter Field

MeasureUnit.Centimeter Field
[image]

Specifies centimeters as the unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly MeasureUnit Centimeter

Visual Basic [image] Copy Code

Public Shared ReadOnly Centimeter As MeasureUnit

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Document Field

MeasureUnit.Document Field
[image]

Specifies document units (1/300 inch) as the unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly MeasureUnit Document

Visual Basic [image] Copy Code

Public Shared ReadOnly Document As MeasureUnit

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Inch Field

MeasureUnit.Inch Field
[image]

Specifies inches as the unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly MeasureUnit Inch

Visual Basic [image] Copy Code

Public Shared ReadOnly Inch As MeasureUnit

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Millimeter Field

MeasureUnit.Millimeter Field
[image]

Specifies millimeters as the unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly MeasureUnit Millimeter

Visual Basic [image] Copy Code

Public Shared ReadOnly Millimeter As MeasureUnit

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Percent Field

MeasureUnit.Percent Field
[image]

Specifies percents as the unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly MeasureUnit Percent

Visual Basic [image] Copy Code

Public Shared ReadOnly Percent As MeasureUnit

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Pixel Field

MeasureUnit.Pixel Field
[image]

Specifies device pixels as the unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly MeasureUnit Pixel

Visual Basic [image] Copy Code

Public Shared ReadOnly Pixel As MeasureUnit

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Point Field

MeasureUnit.Point Field
[image]

Specifies printer's points (1/72 inch) as the unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly MeasureUnit Point

Visual Basic [image] Copy Code

Public Shared ReadOnly Point As MeasureUnit

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.WpfPoint Field

MeasureUnit.WpfPoint Field
[image]

Specifies device-independent pixels (1/96 inch) as the unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly MeasureUnit WpfPoint

Visual Basic [image] Copy Code

Public Shared ReadOnly WpfPoint As MeasureUnit

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit Constructor

MeasureUnit Constructor
[image]

Overload List

Name | Description
MeasureUnit (Int32, String, MeasureUnitType, Double, Int32) | Initializes one of the built-in units of measure.
MeasureUnit (Int32, String, MeasureUnitType, Double, Int32, IMeasureUnitConverter) | Initializes one of the built-in units of measure.
MeasureUnit (String, Double) | Initializes a new instance of the MeasureUnit class with the specified resolution.
MeasureUnit (String, Double, Int32) | Initializes a new instance of the MeasureUnit class with the specified amount.
MeasureUnit (String, MeasureUnit, Double) | Initializes a new instance of the MeasureUnit class with the specified unit of measure as a base.
MeasureUnit (String, MeasureUnit, Double, Int32) | Initializes a new instance of the MeasureUnit class with the specified unit of measure as a base.

See Also

MeasureUnit Class


MindFusion.Diagramming.MeasureUnit Constructor (Int32, String, MeasureUnitType, Double, Int32)

MeasureUnit Constructor (Int32, String, MeasureUnitType, Double, Int32)
See Also
[image]

Initializes one of the built-in units of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MeasureUnit (
int id,
string name,
MeasureUnitType type,
double unitsPerInch,
int standardDivisions
)

Visual Basic [image] Copy Code

Public New ( _
id As Integer, _
name As String, _
type As MeasureUnitType, _
unitsPerInch As Double, _
standardDivisions As Integer _
)

Parameters

id

An integer identifier used to represent this unit in saved diagram files.

name

The display name of this unit.

type

A MeasureUnitType enumeration member specifying how unit size should be calculated.

unitsPerInch

A double value specifying how many units of this type fit within an inch.

standardDivisions

An integer value specifying how many standard divisions should be displayed for this unit in the scales of the Ruler control.

See Also

MeasureUnit Constructor Overload List
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit Constructor (Int32, String, MeasureUnitType, Double, Int32, IMeasureUnitConverter)

MeasureUnit Constructor (Int32, String, MeasureUnitType, Double, Int32, IMeasureUnitConverter)
See Also
[image]

Initializes one of the built-in units of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MeasureUnit (
int id,
string name,
MeasureUnitType type,
double unitsPerInch,
int standardDivisions,
IMeasureUnitConverter converter
)

Visual Basic [image] Copy Code

Public New ( _
id As Integer, _
name As String, _
type As MeasureUnitType, _
unitsPerInch As Double, _
standardDivisions As Integer, _
converter As IMeasureUnitConverter _
)

Parameters

id

An integer identifier used to represent this unit in saved diagram files.

name

The display name of this unit.

type

A MeasureUnitType enumeration member specifying how unit size should be calculated.

unitsPerInch

A double value specifying how many units of this type fit within an inch.

standardDivisions

An integer value specifying how many standard divisions should be displayed for this unit in the scales of the Ruler control.

converter

An IMeasureUnitConverter object used to convert values from this unit to device pixels or other logical units.

See Also

MeasureUnit Constructor Overload List
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit Constructor (String, Double)

MeasureUnit Constructor (String, Double)
See Also
[image]

Initializes a new instance of the MeasureUnit class with the specified resolution.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MeasureUnit (
string name,
double unitsPerInch
)

Visual Basic [image] Copy Code

Public New ( _
name As String, _
unitsPerInch As Double _
)

Parameters

name

The name of the new unit.

unitsPerInch

The amount of the new unit that is equal to one inch.

See Also

MeasureUnit Constructor Overload List
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit Constructor (String, Double, Int32)

MeasureUnit Constructor (String, Double, Int32)
See Also
[image]

Initializes a new instance of the MeasureUnit class with the specified amount.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MeasureUnit (
string name,
double unitsPerInch,
int standardDivisions
)

Visual Basic [image] Copy Code

Public New ( _
name As String, _
unitsPerInch As Double, _
standardDivisions As Integer _
)

Parameters

name

The name of the new unit.

unitsPerInch

The amount of the new unit that is equal to one inch.

standardDivisions

The number of divisions of the new unit.

See Also

MeasureUnit Constructor Overload List
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit Constructor (String, MeasureUnit, Double)

MeasureUnit Constructor (String, MeasureUnit, Double)
See Also
[image]

Initializes a new instance of the MeasureUnit class with the specified unit of measure as a base.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MeasureUnit (
string name,
MeasureUnit baseUnit,
double scale
)

Visual Basic [image] Copy Code

Public New ( _
name As String, _
baseUnit As MeasureUnit, _
scale As Double _
)

Parameters

name

The name of the new unit.

baseUnit

The base of the new unit.

scale

The scale of the new unit, relatively to the base.

See Also

MeasureUnit Constructor Overload List
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit Constructor (String, MeasureUnit, Double, Int32)

MeasureUnit Constructor (String, MeasureUnit, Double, Int32)
See Also
[image]

Initializes a new instance of the MeasureUnit class with the specified unit of measure as a base.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MeasureUnit (
string name,
MeasureUnit baseUnit,
double scale,
int standardDivisions
)

Visual Basic [image] Copy Code

Public New ( _
name As String, _
baseUnit As MeasureUnit, _
scale As Double, _
standardDivisions As Integer _
)

Parameters

name

The name of the new unit.

baseUnit

The base of the new unit.

scale

The scale of the new unit, relatively to the base.

standardDivisions

The number of divisions of the new unit.

See Also

MeasureUnit Constructor Overload List
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit Methods

MeasureUnit Methods
[image]

Public Methods

Name | Description
ApplyTo | Overloaded.
Convert | Overloaded.
Equals | Overloaded.
FromGraphicsUnit | Returns the measure unit corresponding to the specified graphics unit.
FromId | Returns a MeasureUnit from its integer identifier.
GetHashCode | Object.GetHashCode override.
ToGraphicsUnit | Returns the GraphicsUnit corresponding to this MeasureUnit.
ToString | Object.ToString override.

See Also

MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.ApplyTo Method

MeasureUnit.ApplyTo Method
[image]

Overload List

Name | Description
MeasureUnit.ApplyTo (Graphics) | Applies this unit to the specified Graphics drawing surface.
MeasureUnit.ApplyTo (IGraphics) | Applies this unit to the specified IGraphics drawing surface.

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.ApplyTo Method (Graphics)

MeasureUnit.ApplyTo Method (Graphics)
See Also
[image]

Applies this unit to the specified Graphics drawing surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ApplyTo (
Graphics graphics
)

Visual Basic [image] Copy Code

Public Sub ApplyTo( _
graphics As Graphics _
)

Parameters

graphics

A Graphics instance whose PageUnit and PageScale are set to match the resolution of this unit.

See Also

ApplyTo Method Overload List
MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.ApplyTo Method (IGraphics)

MeasureUnit.ApplyTo Method (IGraphics)
See Also
[image]

Applies this unit to the specified IGraphics drawing surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ApplyTo (
IGraphics graphics
)

Visual Basic [image] Copy Code

Public Sub ApplyTo( _
graphics As IGraphics _
)

Parameters

graphics

An IGraphics instance whose PageUnit and PageScale are set to match the resolution of this unit.

See Also

ApplyTo Method Overload List
MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Convert Method

MeasureUnit.Convert Method
[image]

Overload List

Name | Description
MeasureUnit.Convert (Double, MeasureUnit, Object) | Converts the specified value from this unit to the specified unit.
MeasureUnit.Convert (Double, MeasureUnit, Object, Axis) | Converts the specified value from this unit to the specified unit.
MeasureUnit.Convert (PointF, MeasureUnit, Object) | Converts the specified point from this unit to the specified unit.
MeasureUnit.Convert (RectangleF, MeasureUnit, Object) | Converts the specified rectangle from this unit to the specified unit.

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Convert Method (Double, MeasureUnit, Object)

MeasureUnit.Convert Method (Double, MeasureUnit, Object)
See Also
[image]

Converts the specified value from this unit to the specified unit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Convert (
double value,
MeasureUnit targetUnit,
Object context
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Double, _
targetUnit As MeasureUnit, _
context As Object _
) As Double

Parameters

value

The value to convert, expressed in the current measure unit.

targetUnit

The target measure unit.

context

A parameter that is used when converting from logical units (such as inches and millimeters) to device units (such as pixels) or special units. This can be either Graphics, IGraphics, or IResolution.

Return Value

The converted value.

Remarks

If the target represents logical unit (such as millimeter, inch, point) or a unit derived from a logical unit, and the current unit is not logical (for example pixel), the third parameter is required to perform the conversion.

See Also

Convert Method Overload List
MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Convert Method (Double, MeasureUnit, Object, Axis)

MeasureUnit.Convert Method (Double, MeasureUnit, Object, Axis)
See Also
[image]

Converts the specified value from this unit to the specified unit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Convert (
double value,
MeasureUnit targetUnit,
Object context,
Axis axis
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Double, _
targetUnit As MeasureUnit, _
context As Object, _
axis As Axis _
) As Double

Parameters

value

The value to convert, expressed in the current measure unit.

targetUnit

The target measure unit.

context

A parameter that is used when converting from logical units (such as inches and millimeters) to device units (such as pixels) or special units. This can be either Graphics, IGraphics, or IResolution.

axis

One of the coordinate axes.

Return Value

The converted value.

Remarks

If the target represents logical unit (such as millimeter, inch, point) or a unit derived from a logical unit, and the current unit is not logical (for example pixel), the third parameter is required to perform the conversion.

See Also

Convert Method Overload List
MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Convert Method (PointF, MeasureUnit, Object)

MeasureUnit.Convert Method (PointF, MeasureUnit, Object)
See Also
[image]

Converts the specified point from this unit to the specified unit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointF Convert (
PointF p,
MeasureUnit targetUnit,
Object context
)

Visual Basic [image] Copy Code

Public Function Convert( _
p As PointF, _
targetUnit As MeasureUnit, _
context As Object _
) As PointF

Parameters

p

The point to convert, expressed in the current measure unit.

targetUnit

The target measure unit.

context

A parameter that is used when converting from logical units (such as inches and millimeters) to device units (such as pixels) or special units. This can be either Graphics, IGraphics, or IResolution.

Return Value

The converted point.

Remarks

If the target represents logical unit (such as millimeter, inch, point) or a unit derived from a logical unit, and the current unit is not logical (for example pixel), the third parameter is required to perform the conversion. If both units are of the same generic type, graphics is ignored.

See Also

Convert Method Overload List
MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Convert Method (RectangleF, MeasureUnit, Object)

MeasureUnit.Convert Method (RectangleF, MeasureUnit, Object)
See Also
[image]

Converts the specified rectangle from this unit to the specified unit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF Convert (
RectangleF r,
MeasureUnit targetUnit,
Object context
)

Visual Basic [image] Copy Code

Public Function Convert( _
r As RectangleF, _
targetUnit As MeasureUnit, _
context As Object _
) As RectangleF

Parameters

r

The rectangle to convert, expressed in the current measure unit.

targetUnit

The target measure unit.

context

A parameter that is used when converting from logical units (such as inches and millimeters) to device units (such as pixels) or special units. This can be either Graphics, IGraphics, or IResolution.

Return Value

The converted rectangle.

Remarks

If the target represents logical unit (such as mm, inch, point) or a unit derived from a logical unit, and the current unit is not logical (for example pixel), the third parameter is required to perform the conversion. If both units are of the same generic type, graphics is ignored.

See Also

Convert Method Overload List
MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Equals Method

MeasureUnit.Equals Method
[image]

Overload List

Name | Description
MeasureUnit.Equals (MeasureUnit) | Determines whether the specified measure unit is equal to the current measure unit.
MeasureUnit.Equals (Object) | Object.Equals override.

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Equals Method (MeasureUnit)

MeasureUnit.Equals Method (MeasureUnit)
See Also
[image]

Determines whether the specified measure unit is equal to the current measure unit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public new bool Equals (
MeasureUnit unit
)

Visual Basic [image] Copy Code

Public Shadows Function Equals( _
unit As MeasureUnit _
) As Boolean

Parameters

unit

The object to compare to this measure unit.

Return Value

true if the specified measure unit is equal to this object; otherwise, false.

See Also

Equals Method Overload List
MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Equals Method (Object)

MeasureUnit.Equals Method (Object)
See Also
[image]

Object.Equals override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

The object to compare with the current unit.

Return Value

true if the specified object is the same as or is equal to the current unit; otherwise, false.

See Also

Equals Method Overload List
MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.FromGraphicsUnit Method

MeasureUnit.FromGraphicsUnit Method
[image]

Returns the measure unit corresponding to the specified graphics unit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static MeasureUnit FromGraphicsUnit (
GraphicsUnit unit
)

Visual Basic [image] Copy Code

Public Shared Function FromGraphicsUnit( _
unit As GraphicsUnit _
) As MeasureUnit

Parameters

unit

One of the GraphicsUnit values.

Return Value

The built-in MeasureUnit corresponding to the specified graphics unit. If unit is World, this method returns null. If unit is Display, this method returns Pixel.

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.FromId Method

MeasureUnit.FromId Method
[image]

Returns a MeasureUnit from its integer identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static MeasureUnit FromId (
int id
)

Visual Basic [image] Copy Code

Public Shared Function FromId( _
id As Integer _
) As MeasureUnit

Parameters

id

The identifier of one of the built-in measure units.

Return Value

The built-in MeasureUnit corresponding to the specified identifier.

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.GetHashCode Method

MeasureUnit.GetHashCode Method
[image]

Object.GetHashCode override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

A hash code for the current unit.

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.ToGraphicsUnit Method

MeasureUnit.ToGraphicsUnit Method
[image]

Returns the GraphicsUnit corresponding to this MeasureUnit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GraphicsUnit ToGraphicsUnit ()

Visual Basic [image] Copy Code

Public Function ToGraphicsUnit () As GraphicsUnit

Return Value

A member of the GraphicsUnit enumeration if there is one corresponding to this unit, or otherwise null.

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.ToString Method

MeasureUnit.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

The name of the unit.

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit Properties

MeasureUnit Properties
[image]

Public Properties

Name | Description
Amount | Gets the unit's size in inches.
Id | Gets the unit identifier.
Name | Gets the name of the unit.
StandardDivisions | Gets the number of subunits that measures of this unit type are commonly divided to.

See Also

MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Amount Property

MeasureUnit.Amount Property
[image]

Gets the unit's size in inches.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Amount { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Amount As Double

Property Value

A double value specifying the size in inches of a single unit of this type.

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Id Property

MeasureUnit.Id Property
[image]

Gets the unit identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Id { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Id As Integer

Property Value

Remarks

This property returns the integer identifier passed to MeasureUnit constructors.

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Name Property

MeasureUnit.Name Property
[image]

Gets the name of the unit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Name { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Name As String

Property Value

The name passed to MeasureUnit constructors.

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.StandardDivisions Property

MeasureUnit.StandardDivisions Property
[image]

Gets the number of subunits that measures of this unit type are commonly divided to.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int StandardDivisions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StandardDivisions As Integer

Property Value

The standardDivisions value passed to MeasureUnit constructors.

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnitType Enumeration

MeasureUnitType Enumeration
[image]

Specifies the type of a unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum MeasureUnitType

Visual Basic [image] Copy Code

Public Enum MeasureUnitType

Members

Member name | Description
Logical | Indicates logical unit of measure, expressed as units-per-inch.
Device | Indicates device-dependent unit of measure, expressed in device pixels.
Special | Indicates special unit of measure, such as percent.

See Also


MindFusion.Diagramming.ModificationStart Enumeration

ModificationStart Enumeration
[image]

Specifies how the user can start modifying an item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum ModificationStart

Visual Basic [image] Copy Code

Public Enum ModificationStart

Members

Member name | Description
SelectedOnly | Only selected items can be modified.
AutoHandles | Adjustment handles appear automatically around the item under the mouse; it can be modified without selecting it first.

Remarks

This enumeration specifies the possible values of the ModificationStart property.

See Also

ModificationStart Property


MindFusion.Diagramming.ModifierKeyAction Enumeration

ModifierKeyAction Enumeration
[image]

Defines the actions that can be assigned to a modifier key such as CTRL or ALT.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum ModifierKeyAction

Visual Basic [image] Copy Code

Public Enum ModifierKeyAction

Members

Member name | Description
None | Specifies that a modifier key does not have any specific function assigned to it.
Pan | Pan the view if the mouse is dragged while the modifier key is pressed down.
Select | Start drawing a selection rectangle if the mouse is dragged while a modifier key is pressed down. Toggle the selection if an item is clicked while the key is down.
OverrideBehavior | While the modifier key is pressed down, dragging the mouse starts creating a new item or drawing a selection rectangle instead of modifying a selected item. Otherwise, dragging the mouse could start modification of the selected item.
Magnify | Magnifies the diagram objects under the mouse while the modifier key is pressed down.

Remarks

The values from this enumeration can be assigned to the members of the diagram view's ModifierKeyActions.

See Also

ModifierKeyActions Class


MindFusion.Diagramming.MouseButton Enumeration

MouseButton Enumeration
[image]

Specifies constants that define which mouse button was pressed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum MouseButton

Visual Basic [image] Copy Code

Public Enum MouseButton

Members

Member name | Description
None | No mouse button was pressed.
Left | The left mouse button was pressed.
Right | The right mouse button was pressed.
Middle | The middle mouse button was pressed.
XButton1 | The first XButton was pressed.
XButton2 | The second XButton was pressed.

See Also


MindFusion.Diagramming.MouseButtonActions Enumeration

MouseButtonActions Enumeration
[image]

Specifies what actions can be associated with the middle and right mouse buttons.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum MouseButtonActions

Visual Basic [image] Copy Code

Public Enum MouseButtonActions

Members

Member name | Description
None | Do not associate any action with the button.
Pan | Pans the view if the mouse is dragged while the button is pressed down.
Cancel | Cancels the current drawing operation.
Select | Starts a multiple selection operation.
Draw | Draw new items or modify existing items.
Magnify | Magnifies the items under the mouse while the button is pressed down.

Remarks

The Cancel value can be combined with Pan or Select. Thus if a user presses the mouse button while drawing an item, the operation will be cancelled; otherwise dragging with the specified button will start panning or drawing a selection rectangle.

See Also

MindFusion.Diagramming Namespace
MiddleButtonActions Property
RightButtonActions Property


MindFusion.Diagramming.NodeAdjustmentHandle Class

NodeAdjustmentHandle Class
[image]

Represents an adjustment handle used to move, resize or rotate a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class NodeAdjustmentHandle : AdjustmentHandle

Visual Basic [image] Copy Code

Public Class NodeAdjustmentHandle
Inherits AdjustmentHandle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.AdjustmentHandle
MindFusion.Diagramming.NodeAdjustmentHandle

See Also

NodeAdjustmentHandle Members


MindFusion.Diagramming.NodeAdjustmentHandle Members

NodeAdjustmentHandle Members
Constructors Fields Properties Methods
[image]

Represents an adjustment handle used to move, resize or rotate a node.

The following tables list the members exposed by the NodeAdjustmentHandle type.

Public Constructors

Name | Description
NodeAdjustmentHandle | Initializes a new instance of the NodeAdjustmentHandle class.

Public Fields

Name | Description
Move | A NodeAdjustmentHandle used to move nodes.
ResizeBottomRight | A NodeAdjustmentHandle used to resize nodes from bottom-right corner.

Public Properties

Name | Description
HandleType | Gets or sets the type of this adjustment handle.

Public Methods

Name | Description
IsMoveHandle | Returns a value indicating whether this handle is used to move nodes.

See Also

NodeAdjustmentHandle Class


MindFusion.Diagramming.NodeAdjustmentHandle Fields

NodeAdjustmentHandle Fields
[image]

Public Fields

Name | Description
Move | A NodeAdjustmentHandle used to move nodes.
ResizeBottomRight | A NodeAdjustmentHandle used to resize nodes from bottom-right corner.

See Also

NodeAdjustmentHandle Class


MindFusion.Diagramming.NodeAdjustmentHandle.Move Field

NodeAdjustmentHandle.Move Field
[image]

A NodeAdjustmentHandle used to move nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static NodeAdjustmentHandle Move

Visual Basic [image] Copy Code

Public Shared Move As NodeAdjustmentHandle

See Also

NodeAdjustmentHandle Members
NodeAdjustmentHandle Class


MindFusion.Diagramming.NodeAdjustmentHandle.ResizeBottomRight Field

NodeAdjustmentHandle.ResizeBottomRight Field
[image]

A NodeAdjustmentHandle used to resize nodes from bottom-right corner.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static NodeAdjustmentHandle ResizeBottomRight

Visual Basic [image] Copy Code

Public Shared ResizeBottomRight As NodeAdjustmentHandle

See Also

NodeAdjustmentHandle Members
NodeAdjustmentHandle Class


MindFusion.Diagramming.NodeAdjustmentHandle Constructor

NodeAdjustmentHandle Constructor
[image]

Initializes a new instance of the NodeAdjustmentHandle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeAdjustmentHandle (
NodeHandleType handleType
)

Visual Basic [image] Copy Code

Public New ( _
handleType As NodeHandleType _
)

Parameters

handleType

A member of the NodeHandleType enumeration identifying the handle type.

See Also

NodeAdjustmentHandle Class


MindFusion.Diagramming.NodeAdjustmentHandle Methods

NodeAdjustmentHandle Methods
[image]

Public Methods

Name | Description
IsMoveHandle | Returns a value indicating whether this handle is used to move nodes.

See Also

NodeAdjustmentHandle Class


MindFusion.Diagramming.NodeAdjustmentHandle.IsMoveHandle Method

NodeAdjustmentHandle.IsMoveHandle Method
[image]

Returns a value indicating whether this handle is used to move nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool IsMoveHandle ()

Visual Basic [image] Copy Code

Public Overrides Function IsMoveHandle () As Boolean

Return Value

true if this is a move handle, or false otherwise.

See Also

NodeAdjustmentHandle Members
NodeAdjustmentHandle Class


MindFusion.Diagramming.NodeAdjustmentHandle Properties

NodeAdjustmentHandle Properties
[image]

Public Properties

Name | Description
HandleType | Gets or sets the type of this adjustment handle.

See Also

NodeAdjustmentHandle Class


MindFusion.Diagramming.NodeAdjustmentHandle.HandleType Property

NodeAdjustmentHandle.HandleType Property
[image]

Gets or sets the type of this adjustment handle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeHandleType HandleType { get; set; }

Visual Basic [image] Copy Code

Public Property HandleType As NodeHandleType

Property Value

A member of the NodeHandleType enumeration specifying the type of this handle.

See Also

NodeAdjustmentHandle Members
NodeAdjustmentHandle Class


MindFusion.Diagramming.NodeConstraints Class

NodeConstraints Class
Remarks See Also
[image]

Defines specific constraints that can be applied to the size and location of nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class NodeConstraints : IPersists, ICloneable

Visual Basic [image] Copy Code

Public Class NodeConstraints
Implements IPersists, ICloneable

Remarks

Instances of this class can be assigned to the Constraints property of nodes.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.NodeConstraints

See Also

NodeConstraints Members


MindFusion.Diagramming.NodeConstraints Members

NodeConstraints Members
Constructors Properties Methods
[image]

Defines specific constraints that can be applied to the size and location of nodes.

The following tables list the members exposed by the NodeConstraints type.

Public Constructors

Name | Description
NodeConstraints | Initializes a new instance of the NodeConstraints class.

Public Properties

Name | Description
DisableMirroring | Gets or sets a value indicating whether the user can drag a side of the node past its opposite side, so that they switch positions.
KeepInsideDiagram | Gets or sets a value indicating whether a node should always stay inside the boundaries of the diagram that contains it.
KeepInsideParent | Gets or sets a value indicating whether a node must always stay in the boundaries of its group master node.
KeepRatio | Gets or sets a value indicating whether the initial width/height ratio of a node must be preserved.
MaxHeight | Gets or sets the maximal node height allowed.
MaxWidth | Gets or sets the maximal node width allowed.
MinHeight | Gets or sets the minimal node height allowed.
MinWidth | Gets or sets the minimal node width allowed.
MoveDirection | Gets or sets constraints on movement direction.

Public Methods

Name | Description
Clone | Creates a copy of this object.
LoadFromXml | Loads the label from the specified XML element.
SaveToXml | Saves the label into the specified XML element.

See Also

NodeConstraints Class


MindFusion.Diagramming.NodeConstraints Constructor

NodeConstraints Constructor
[image]

Initializes a new instance of the NodeConstraints class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeConstraints ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

NodeConstraints Class


MindFusion.Diagramming.NodeConstraints Methods

NodeConstraints Methods
[image]

Public Methods

Name | Description
Clone | Creates a copy of this object.
LoadFromXml | Loads the label from the specified XML element.
SaveToXml | Saves the label into the specified XML element.

See Also

NodeConstraints Class


MindFusion.Diagramming.NodeConstraints.Clone Method

NodeConstraints.Clone Method
[image]

Creates a copy of this object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

An Object instance that is a copy of the current NodeConstraints instance.

See Also

NodeConstraints Members
NodeConstraints Class


MindFusion.Diagramming.NodeConstraints.LoadFromXml Method

NodeConstraints.LoadFromXml Method
[image]

Loads the label from the specified XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

A XmlElement instance.

context

A XmlPersistContext instance.

See Also

NodeConstraints Members
NodeConstraints Class


MindFusion.Diagramming.NodeConstraints.SaveToXml Method

NodeConstraints.SaveToXml Method
[image]

Saves the label into the specified XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

A XmlElement instance.

context

A XmlPersistContext instance.

See Also

NodeConstraints Members
NodeConstraints Class


MindFusion.Diagramming.NodeConstraints Properties

NodeConstraints Properties
[image]

Public Properties

Name | Description
DisableMirroring | Gets or sets a value indicating whether the user can drag a side of the node past its opposite side, so that they switch positions.
KeepInsideDiagram | Gets or sets a value indicating whether a node should always stay inside the boundaries of the diagram that contains it.
KeepInsideParent | Gets or sets a value indicating whether a node must always stay in the boundaries of its group master node.
KeepRatio | Gets or sets a value indicating whether the initial width/height ratio of a node must be preserved.
MaxHeight | Gets or sets the maximal node height allowed.
MaxWidth | Gets or sets the maximal node width allowed.
MinHeight | Gets or sets the minimal node height allowed.
MinWidth | Gets or sets the minimal node width allowed.
MoveDirection | Gets or sets constraints on movement direction.

See Also

NodeConstraints Class


MindFusion.Diagramming.NodeConstraints.DisableMirroring Property

NodeConstraints.DisableMirroring Property
[image]

Gets or sets a value indicating whether the user can drag a side of the node past its opposite side, so that they switch positions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool DisableMirroring { get; set; }

Visual Basic [image] Copy Code

Public Property DisableMirroring As Boolean

Property Value

true to disable mirroring; otherwise false. The default value is false.

See Also

NodeConstraints Members
NodeConstraints Class


MindFusion.Diagramming.NodeConstraints.KeepInsideDiagram Property

NodeConstraints.KeepInsideDiagram Property
[image]

Gets or sets a value indicating whether a node should always stay inside the boundaries of the diagram that contains it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool KeepInsideDiagram { get; set; }

Visual Basic [image] Copy Code

Public Property KeepInsideDiagram As Boolean

Property Value

See Also

NodeConstraints Members
NodeConstraints Class


MindFusion.Diagramming.NodeConstraints.KeepInsideParent Property

NodeConstraints.KeepInsideParent Property
[image]

Gets or sets a value indicating whether a node must always stay in the boundaries of its group master node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool KeepInsideParent { get; set; }

Visual Basic [image] Copy Code

Public Property KeepInsideParent As Boolean

Property Value

true if users should be prevented from moving the node out of its parent; otherwise, false. The default is false.

Remarks

This property lets you restrict nodes attached to another node by calling the AttachTo method so that users cannot move the attached nodes out of the bounds of their parent.

See Also

NodeConstraints Members
NodeConstraints Class


MindFusion.Diagramming.NodeConstraints.KeepRatio Property

NodeConstraints.KeepRatio Property
[image]

Gets or sets a value indicating whether the initial width/height ratio of a node must be preserved.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool KeepRatio { get; set; }

Visual Basic [image] Copy Code

Public Property KeepRatio As Boolean

Property Value

true if the node width to height ratio should be preserved; otherwise, false. The default is false.

Remarks

If you enable this property in an initialization-event handler, the node will have an aspect ratio of 1:1. In order to let users draw perfect square or circle shapes, set KeepRatio to true in the InitializeNode handler.

See Also

NodeConstraints Members
NodeConstraints Class


MindFusion.Diagramming.NodeConstraints.MaxHeight Property

NodeConstraints.MaxHeight Property
[image]

Gets or sets the maximal node height allowed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float MaxHeight { get; set; }

Visual Basic [image] Copy Code

Public Property MaxHeight As Single

Property Value

0 = no height constraints; any other value specifies the maximal node height allowed.

See Also

NodeConstraints Members
NodeConstraints Class


MindFusion.Diagramming.NodeConstraints.MaxWidth Property

NodeConstraints.MaxWidth Property
[image]

Gets or sets the maximal node width allowed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float MaxWidth { get; set; }

Visual Basic [image] Copy Code

Public Property MaxWidth As Single

Property Value

0 = no width constraints; any other value specifies the maximal node width allowed.

See Also

NodeConstraints Members
NodeConstraints Class


MindFusion.Diagramming.NodeConstraints.MinHeight Property

NodeConstraints.MinHeight Property
[image]

Gets or sets the minimal node height allowed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float MinHeight { get; set; }

Visual Basic [image] Copy Code

Public Property MinHeight As Single

Property Value

0 = no height constraints; any other value specifies the minimal node height allowed.

See Also

NodeConstraints Members
NodeConstraints Class


MindFusion.Diagramming.NodeConstraints.MinWidth Property

NodeConstraints.MinWidth Property
[image]

Gets or sets the minimal node width allowed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float MinWidth { get; set; }

Visual Basic [image] Copy Code

Public Property MinWidth As Single

Property Value

0 = no width constraints; any other value specifies the minimal node width allowed.

See Also

NodeConstraints Members
NodeConstraints Class


MindFusion.Diagramming.NodeConstraints.MoveDirection Property

NodeConstraints.MoveDirection Property
[image]

Gets or sets constraints on movement direction.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DirectionConstraint MoveDirection { get; set; }

Visual Basic [image] Copy Code

Public Property MoveDirection As DirectionConstraint

Property Value

One of the DirectionConstraint enumeration values; the default is None.

See Also

NodeConstraints Members
NodeConstraints Class


MindFusion.Diagramming.NodeEffect Class

NodeEffect Class
Remarks See Also
[image]

Represents the base class of all visual effects that can be applied to the nodes in a Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class NodeEffect : INotifyPropertyChanged, IPersists, ICloneable

Visual Basic [image] Copy Code

Public MustInherit Class NodeEffect
Implements INotifyPropertyChanged, IPersists, ICloneable

Remarks

Effects can be applied by adding instances of the concrete effect classes to the NodeEffects collection of the Diagram.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.NodeEffect
MindFusion.Diagramming.AeroEffect
MindFusion.Diagramming.EmbossEffect
MindFusion.Diagramming.GlassEffect
MindFusion.Diagramming.SmoothShadowEffect

See Also

NodeEffect Members


MindFusion.Diagramming.NodeEffect Members

NodeEffect Members
Constructors Methods Events
[image]

Represents the base class of all visual effects that can be applied to the nodes in a Diagram.

The following tables list the members exposed by the NodeEffect type.

Protected Constructors

Name | Description
NodeEffect | Initializes a new instance of the NodeEffect class.

Public Methods

Name | Description
Clone | ICloneable.Clone implementation.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

NodeEffect Class


MindFusion.Diagramming.NodeEffect Constructor

NodeEffect Constructor
[image]

Initializes a new instance of the NodeEffect class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected NodeEffect ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

NodeEffect Class


MindFusion.Diagramming.NodeEffect Methods

NodeEffect Methods
[image]

Public Methods

Name | Description
Clone | ICloneable.Clone implementation.

See Also

NodeEffect Class


MindFusion.Diagramming.NodeEffect.Clone Method

NodeEffect.Clone Method
[image]

ICloneable.Clone implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract Object Clone ()

Visual Basic [image] Copy Code

Public MustOverride Function Clone () As Object

Return Value

A new effect that is a copy of this effect.

See Also

NodeEffect Members
NodeEffect Class


MindFusion.Diagramming.NodeEffect Events

NodeEffect Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

NodeEffect Class


MindFusion.Diagramming.NodeEventArgs Class

NodeEventArgs Class
[image]

Contains the arguments passed to handlers of node-related events, such as TreeCollapsed and TreeExpanded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class NodeEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class NodeEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.NodeEventArgs
MindFusion.Diagramming.ContainerChildEventArgs
MindFusion.Diagramming.NodeValidationEventArgs

See Also

NodeEventArgs Members


MindFusion.Diagramming.NodeEventArgs Members

NodeEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to handlers of node-related events, such as TreeCollapsed and TreeExpanded.

The following tables list the members exposed by the NodeEventArgs type.

Public Constructors

Name | Description
NodeEventArgs | Overloaded. Initializes a new instance of the NodeEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user.
MouseButton | Gets which mouse button has been pressed.
MousePosition | Gets or sets the current mouse pointer position.
Node | Gets the node for which the event was raised.

See Also

NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs Constructor

NodeEventArgs Constructor
[image]

Initializes a new instance of the NodeEventArgs class.

Overload List

Name | Description
NodeEventArgs (DiagramNode) | Initializes a new instance of the NodeEventArgs class.
NodeEventArgs (DiagramNode, MouseButton, PointF) | Initializes a new instance of the NodeEventArgs class.
NodeEventArgs (DiagramNode, PointF, AdjustmentHandles) | Initializes a new instance of the NodeEventArgs class.

See Also

NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs Constructor (DiagramNode)

NodeEventArgs Constructor (DiagramNode)
See Also
[image]

Initializes a new instance of the NodeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeEventArgs (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Sub NodeEventArgs ( _
node As DiagramNode _
)

Parameters

node

The DiagramNode related to the event.

See Also

NodeEventArgs Constructor Overload List
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs Constructor (DiagramNode, MouseButton, PointF)

NodeEventArgs Constructor (DiagramNode, MouseButton, PointF)
See Also
[image]

Initializes a new instance of the NodeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeEventArgs (
DiagramNode node,
MouseButton mouseButton,
PointF mousePosition
)

Visual Basic [image] Copy Code

Public Sub NodeEventArgs ( _
node As DiagramNode, _
mouseButton As MouseButton, _
mousePosition As PointF _
)

Parameters

node

The DiagramNode related to the event.

mouseButton

The mouse button related to the event.

mousePosition

The position of the mouse cursor, in document coordinates.

See Also

NodeEventArgs Constructor Overload List
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs Constructor (DiagramNode, PointF, AdjustmentHandles)

NodeEventArgs Constructor (DiagramNode, PointF, AdjustmentHandles)
See Also
[image]

Initializes a new instance of the NodeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeEventArgs (
DiagramNode node,
PointF mousePosition,
AdjustmentHandles adjustmentHandle
)

Visual Basic [image] Copy Code

Public Sub NodeEventArgs ( _
node As DiagramNode, _
mousePosition As PointF, _
adjustmentHandle As AdjustmentHandles _
)

Parameters

node

The DiagramNode related to the event.

mousePosition

The position of the mouse cursor, in document coordinates.

adjustmentHandle

The zero-based index of the adjustment handle related to the event.

See Also

NodeEventArgs Constructor Overload List
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs Properties

NodeEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user.
MouseButton | Gets which mouse button has been pressed.
MousePosition | Gets or sets the current mouse pointer position.
Node | Gets the node for which the event was raised.

See Also

NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs.AdjustmentHandle Property

NodeEventArgs.AdjustmentHandle Property
[image]

Gets or sets the adjustment handle being moved by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AdjustmentHandles AdjustmentHandle { get; set; }

Visual Basic [image] Copy Code

Public Property AdjustmentHandle As AdjustmentHandles

Property Value

A member of the AdjustmentHandles enumeration specifying what handle has been used.

See Also

NodeEventArgs Members
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs.MouseButton Property

NodeEventArgs.MouseButton Property
[image]

Gets which mouse button has been pressed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MouseButton MouseButton { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MouseButton As MouseButton

Property Value

A member of the MouseButton enumeration specifying the currently pressed mouse button.

See Also

NodeEventArgs Members
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs.MousePosition Property

NodeEventArgs.MousePosition Property
[image]

Gets or sets the current mouse pointer position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointF MousePosition { get; set; }

Visual Basic [image] Copy Code

Public Property MousePosition As PointF

Property Value

A .NET PointF object specifying the current mouse position.

See Also

NodeEventArgs Members
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs.Node Property

NodeEventArgs.Node Property
[image]

Gets the node for which the event was raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Node { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Node As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

NodeEventArgs Members
NodeEventArgs Class


MindFusion.Diagramming.NodeHandleType Enumeration

NodeHandleType Enumeration
[image]

Identifies the types of selection handles of a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum NodeHandleType

Visual Basic [image] Copy Code

Public Enum NodeHandleType

Members

Member name | Description
ResizeTopLeft | A top-left handle that can be used to resize the node.
ResizeTopRight | A top-right handle that can be used to resize the node.
ResizeBottomRight | A bottom-right handle that can be used to resize the node.
ResizeBottomLeft | A bottom-left handle that can be used to resize the node.
ResizeTopCenter | A top-center handle that can be used to resize the node vertically.
ResizeMiddleRight | A middle-right handle that can be used to resize the node horizontally.
ResizeBottomCenter | A bottom-center handle that can be used to resize the node vertically.
ResizeMiddleLeft | A middle-left handle that can be used to resize the node horizontally.
Move | A central selection handle that can be used to move the node.
Rotate | A rotation handle that can be used to rotate the node.

See Also


MindFusion.Diagramming.NodeValidationEventArgs Class

NodeValidationEventArgs Class
[image]

Contains the arguments passed to handlers of node validation events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class NodeValidationEventArgs : NodeEventArgs

Visual Basic [image] Copy Code

Public Class NodeValidationEventArgs
Inherits NodeEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.NodeEventArgs
MindFusion.Diagramming.NodeValidationEventArgs

See Also

NodeValidationEventArgs Members


MindFusion.Diagramming.NodeValidationEventArgs Members

NodeValidationEventArgs Members
Constructors Properties Methods
[image]

Contains the arguments passed to handlers of node validation events.

The following tables list the members exposed by the NodeValidationEventArgs type.

Public Constructors

Name | Description
NodeValidationEventArgs | Overloaded. Initializes a new instance of the NodeValidationEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from NodeEventArgs.)
Cancel | Gets or sets a value indicating whether to cancel the current operation.
MouseButton | Gets which mouse button has been pressed. (Inherited from NodeEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from NodeEventArgs.)
Node | Gets the node for which the event was raised. (Inherited from NodeEventArgs.)
OverrideBounds | Gets or sets a rectangle that should be assigned to the Bounds property of nodes after NodeModifying event is raised.
SelectionRectangle | Gets the current selection rectangle.

Public Methods

Name | Description
CancelDrag | Cancels the creation or modification of the node.

See Also

NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs Constructor

NodeValidationEventArgs Constructor
[image]

Initializes a new instance of the NodeValidationEventArgs class.

Overload List

Name | Description
NodeValidationEventArgs (DiagramNode) | Initializes a new instance of the NodeValidationEventArgs class.
NodeValidationEventArgs (DiagramNode, PointF, AdjustmentHandles) | Initializes a new instance of the NodeValidationEventArgs class.
NodeValidationEventArgs (DiagramNode, RectangleF) | Initializes a new instance of the NodeValidationEventArgs class.

See Also

NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs Constructor (DiagramNode)

NodeValidationEventArgs Constructor (DiagramNode)
See Also
[image]

Initializes a new instance of the NodeValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeValidationEventArgs (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Sub NodeValidationEventArgs ( _
node As DiagramNode _
)

Parameters

node

The DiagramNode related to the event.

See Also

NodeValidationEventArgs Constructor Overload List
NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs Constructor (DiagramNode, PointF, AdjustmentHandles)

NodeValidationEventArgs Constructor (DiagramNode, PointF, AdjustmentHandles)
See Also
[image]

Initializes a new instance of the NodeValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeValidationEventArgs (
DiagramNode node,
PointF mousePosition,
AdjustmentHandles adjustmentHandle
)

Visual Basic [image] Copy Code

Public Sub NodeValidationEventArgs ( _
node As DiagramNode, _
mousePosition As PointF, _
adjustmentHandle As AdjustmentHandles _
)

Parameters

node

The DiagramNode related to the event.

mousePosition

The position of the mouse cursor, in document coordinates.

adjustmentHandle

The zero-based index of the adjustment handle related to the event.

See Also

NodeValidationEventArgs Constructor Overload List
NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs Constructor (DiagramNode, RectangleF)

NodeValidationEventArgs Constructor (DiagramNode, RectangleF)
See Also
[image]

Initializes a new instance of the NodeValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeValidationEventArgs (
DiagramNode node,
RectangleF selectionRectangle
)

Visual Basic [image] Copy Code

Public Sub NodeValidationEventArgs ( _
node As DiagramNode, _
selectionRectangle As RectangleF _
)

Parameters

node

The DiagramNode related to the event.

selectionRectangle

A .NET RectangeF object representing the selection rectangle.

See Also

NodeValidationEventArgs Constructor Overload List
NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs Methods

NodeValidationEventArgs Methods
[image]

Public Methods

Name | Description
CancelDrag | Cancels the creation or modification of the node.

See Also

NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs.CancelDrag Method

NodeValidationEventArgs.CancelDrag Method
[image]

Cancels the creation or modification of the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void CancelDrag ()

Visual Basic [image] Copy Code

Public Sub CancelDrag ()

Remarks

Calling this method immediately stops the operation. On the other hand, setting Cancel to true only changes the mouse cursor to a Stop icon and the operation is cancelled when the user releases the mouse button.

See Also

NodeValidationEventArgs Members
NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs Properties

NodeValidationEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from NodeEventArgs.)
Cancel | Gets or sets a value indicating whether to cancel the current operation.
MouseButton | Gets which mouse button has been pressed. (Inherited from NodeEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from NodeEventArgs.)
Node | Gets the node for which the event was raised. (Inherited from NodeEventArgs.)
OverrideBounds | Gets or sets a rectangle that should be assigned to the Bounds property of nodes after NodeModifying event is raised.
SelectionRectangle | Gets the current selection rectangle.

See Also

NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs.Cancel Property

NodeValidationEventArgs.Cancel Property
[image]

Gets or sets a value indicating whether to cancel the current operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

true to cancel the operation; false to approve it.

Remarks

Set this property to true to prevent the user from completing the operation.

See Also

NodeValidationEventArgs Members
NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs.OverrideBounds Property

NodeValidationEventArgs.OverrideBounds Property
[image]

Gets or sets a rectangle that should be assigned to the Bounds property of nodes after NodeModifying event is raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF OverrideBounds { get; set; }

Visual Basic [image] Copy Code

Public Property OverrideBounds As RectangleF

Property Value

A RectangleF instance. The default value is Empty, signifying that the control should apply standard interaction logic when calculating new coordinates.

See Also

NodeValidationEventArgs Members
NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs.SelectionRectangle Property

NodeValidationEventArgs.SelectionRectangle Property
[image]

Gets the current selection rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF SelectionRectangle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SelectionRectangle As RectangleF

Property Value

A RectangleF instance representing the selection rectangle.

See Also

NodeValidationEventArgs Members
NodeValidationEventArgs Class


MindFusion.Diagramming.NotATreeException Class

NotATreeException Class
[image]

An exception raised by the TreeEnumerator class if the specified node does not represent a root of a tree.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class NotATreeException : Exception

Visual Basic [image] Copy Code

Public Class NotATreeException
Inherits Exception

Inheritance Hierarchy

System.Object
System.Exception
MindFusion.Diagramming.NotATreeException

See Also

NotATreeException Members


MindFusion.Diagramming.NotATreeException Members

NotATreeException Members
Constructors
[image]

An exception raised by the TreeEnumerator class if the specified node does not represent a root of a tree.

The following tables list the members exposed by the NotATreeException type.

Public Constructors

Name | Description
NotATreeException | Initializes a new instance of the NotATreeException class.

See Also

NotATreeException Class


MindFusion.Diagramming.NotATreeException Constructor

NotATreeException Constructor
[image]

Initializes a new instance of the NotATreeException class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NotATreeException ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

NotATreeException Class


MindFusion.Diagramming.NotifyCollectionChangedAction Enumeration

NotifyCollectionChangedAction Enumeration
[image]

Describes the action that caused a CollectionChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum NotifyCollectionChangedAction

Visual Basic [image] Copy Code

Public Enum NotifyCollectionChangedAction

Members

Member name | Description
Add | One or more items were added to the collection.
Remove | One or more items were removed from the collection.
Replace | One or more items were replaced in the collection.
Reset | The content of the collection changed dramatically.

See Also


MindFusion.Diagramming.NotifyCollectionChangedEventArgs(T) Class

NotifyCollectionChangedEventArgs(T) Class
[image]

Provides data for the ObservableCollection<T>.CollectionChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class NotifyCollectionChangedEventArgs<T> : EventArgs

Visual Basic [image] Copy Code

Public Class NotifyCollectionChangedEventArgs(Of T)
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.NotifyCollectionChangedEventArgs(T)

See Also

NotifyCollectionChangedEventArgs(T) Members


MindFusion.Diagramming.NotifyCollectionChangedEventArgs(T) Members

NotifyCollectionChangedEventArgs(T) Members
Constructors Properties
[image]

Provides data for the ObservableCollection<T>.CollectionChanged event.

The following tables list the members exposed by the NotifyCollectionChangedEventArgs(T) type.

Public Constructors

Name | Description
NotifyCollectionChangedEventArgs | Initializes a new instance of the NotifyCollectionChangedEventArgs class.

Public Properties

Name | Description
Action | Gets or sets the action that caused the event.
NewItems | Gets the list of new items involved in the change.
OldItems | Gets the list of items affected by a Replace, Remove, or Reset action.

See Also

NotifyCollectionChangedEventArgs(T) Class


MindFusion.Diagramming.NotifyCollectionChangedEventArgs(T) Constructor

NotifyCollectionChangedEventArgs(T) Constructor
[image]

Initializes a new instance of the NotifyCollectionChangedEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NotifyCollectionChangedEventArgs<T> ()

Visual Basic [image] Copy Code

Public Sub New(Of T) ()

See Also

NotifyCollectionChangedEventArgs(T) Class


MindFusion.Diagramming.NotifyCollectionChangedEventArgs(T) Properties

NotifyCollectionChangedEventArgs(T) Properties
[image]

Public Properties

Name | Description
Action | Gets or sets the action that caused the event.
NewItems | Gets the list of new items involved in the change.
OldItems | Gets the list of items affected by a Replace, Remove, or Reset action.

See Also

NotifyCollectionChangedEventArgs(T) Class


MindFusion.Diagramming.NotifyCollectionChangedEventArgs(T).Action Property

NotifyCollectionChangedEventArgs(T).Action Property
[image]

Gets or sets the action that caused the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NotifyCollectionChangedAction Action { get; set; }

Visual Basic [image] Copy Code

Public Property Action As NotifyCollectionChangedAction

Property Value

A member of the NotifyCollectionChangedAction enumeration.

See Also

NotifyCollectionChangedEventArgs(T) Members
NotifyCollectionChangedEventArgs(T) Class


MindFusion.Diagramming.NotifyCollectionChangedEventArgs(T).NewItems Property

NotifyCollectionChangedEventArgs(T).NewItems Property
[image]

Gets the list of new items involved in the change.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public T[] NewItems { get; set; }

Visual Basic [image] Copy Code

Public Property NewItems As T()

Property Value

A list with the new items added to the collection. This can be null (Nothing in Visual Basic).

See Also

NotifyCollectionChangedEventArgs(T) Members
NotifyCollectionChangedEventArgs(T) Class


MindFusion.Diagramming.NotifyCollectionChangedEventArgs(T).OldItems Property

NotifyCollectionChangedEventArgs(T).OldItems Property
[image]

Gets the list of items affected by a Replace, Remove, or Reset action.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public T[] OldItems { get; set; }

Visual Basic [image] Copy Code

Public Property OldItems As T()

Property Value

A list with the items removed from the collection. This can be null (Nothing in Visual Basic).

See Also

NotifyCollectionChangedEventArgs(T) Members
NotifyCollectionChangedEventArgs(T) Class


MindFusion.Diagramming.ObservableCollection(T) Class

ObservableCollection(T) Class
[image]

Represents a dynamic data collection that provides notifications when items get added, removed, or when the whole list is refreshed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ObservableCollection<T> : Collection<T>, INotifyCollectionChanged

Visual Basic [image] Copy Code

Public Class ObservableCollection(Of T)
Inherits Collection(Of T)
Implements INotifyCollectionChanged

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(T)
MindFusion.Diagramming.ObservableCollection(T)

See Also

ObservableCollection(T) Members


MindFusion.Diagramming.ObservableCollection(T) Members

ObservableCollection(T) Members
Constructors Methods Events
[image]

Represents a dynamic data collection that provides notifications when items get added, removed, or when the whole list is refreshed.

The following tables list the members exposed by the ObservableCollection(T) type.

Public Constructors

Name | Description
ObservableCollection | Overloaded. Initializes a new instance of the ObservableCollection<T> class.

Public Methods

Name | Description
AddRange | Adds the specified objects to the end of the collection.

Protected Methods

Name | Description
ClearItems | Collection<T>.ClearItems override.
InsertItem | Collection<T>.InsertItem override.
OnCollectionChanged | Raises the CollectionChanged event.
RemoveItem | Collection<T>.RemoveItem override.
SetItem | Collection<T>.SetItem override.

Public Events

Name | Description
CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed.

See Also

ObservableCollection(T) Class


MindFusion.Diagramming.ObservableCollection(T) Constructor

ObservableCollection(T) Constructor
[image]

Initializes a new instance of the ObservableCollection<T> class.

Overload List

Name | Description
ObservableCollection(T) () | Initializes a new instance of the ObservableCollection<T> class.
ObservableCollection(T) (ICollection(T)) | Initializes a new instance of the ObservableCollection<T> class.

See Also

ObservableCollection(T) Class


MindFusion.Diagramming.ObservableCollection(T) Constructor ()

ObservableCollection(T) Constructor ()
See Also
[image]

Initializes a new instance of the ObservableCollection<T> class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ObservableCollection<T> ()

Visual Basic [image] Copy Code

Public Sub New(Of T) ()

See Also

ObservableCollection(T) Constructor Overload List
ObservableCollection(T) Class


MindFusion.Diagramming.ObservableCollection(T) Constructor (ICollection(T))

ObservableCollection(T) Constructor (ICollection(T))
See Also
[image]

Initializes a new instance of the ObservableCollection<T> class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ObservableCollection<T> (
ICollection<T> items
)

Visual Basic [image] Copy Code

Public New (Of T) ( _
items As ICollection(Of T) _
)

Parameters

items
The initial contents of the collection.

See Also

ObservableCollection(T) Constructor Overload List
ObservableCollection(T) Class


MindFusion.Diagramming.ObservableCollection(T) Methods

ObservableCollection(T) Methods
[image]

Public Methods

Name | Description
AddRange | Adds the specified objects to the end of the collection.

Protected Methods

Name | Description
ClearItems | Collection<T>.ClearItems override.
InsertItem | Collection<T>.InsertItem override.
OnCollectionChanged | Raises the CollectionChanged event.
RemoveItem | Collection<T>.RemoveItem override.
SetItem | Collection<T>.SetItem override.

See Also

ObservableCollection(T) Class


MindFusion.Diagramming.ObservableCollection(T).AddRange Method

ObservableCollection(T).AddRange Method
[image]

Adds the specified objects to the end of the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AddRange (
ICollection<T> items
)

Visual Basic [image] Copy Code

Public Sub AddRange( _
items As ICollection(Of T) _
)

Parameters

items

The objects to add.

See Also

ObservableCollection(T) Members
ObservableCollection(T) Class


MindFusion.Diagramming.ObservableCollection(T).ClearItems Method

ObservableCollection(T).ClearItems Method
[image]

Collection<T>.ClearItems override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void ClearItems ()

Visual Basic [image] Copy Code

Protected Overrides Sub ClearItems ()

See Also

ObservableCollection(T) Members
ObservableCollection(T) Class


MindFusion.Diagramming.ObservableCollection(T).InsertItem Method

ObservableCollection(T).InsertItem Method
[image]

Collection<T>.InsertItem override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void InsertItem (
int index,
T item
)

Visual Basic [image] Copy Code

Protected Overrides Sub InsertItem( _
index As Integer, _
item As T _
)

Parameters

index

The zero-based index at which item should be inserted.

item
The object to insert. The value can be null (Nothing in Visual Basic) for reference types.

See Also

ObservableCollection(T) Members
ObservableCollection(T) Class


MindFusion.Diagramming.ObservableCollection(T).OnCollectionChanged Method

ObservableCollection(T).OnCollectionChanged Method
[image]

Raises the CollectionChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnCollectionChanged (
NotifyCollectionChangedEventArgs<T> e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCollectionChanged ( _
e As NotifyCollectionChangedEventArgs(Of T) _
)

Parameters

e

An object, containing the event data.

See Also

ObservableCollection(T) Members
ObservableCollection(T) Class


MindFusion.Diagramming.ObservableCollection(T).RemoveItem Method

ObservableCollection(T).RemoveItem Method
[image]

Collection<T>.RemoveItem override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void RemoveItem (
int index
)

Visual Basic [image] Copy Code

Protected Overrides Sub RemoveItem( _
index As Integer _
)

Parameters

index

The zero-based index of the element to remove.

See Also

ObservableCollection(T) Members
ObservableCollection(T) Class


MindFusion.Diagramming.ObservableCollection(T).SetItem Method

ObservableCollection(T).SetItem Method
[image]

Collection<T>.SetItem override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SetItem (
int index,
T item
)

Visual Basic [image] Copy Code

Protected Overrides Sub SetItem( _
index As Integer, _
item As T _
)

Parameters

index

The zero-based index of the element to replace.

item
The new value for the element at the specified index. The value can be null (Nothing in Visual Basic) for reference types.

See Also

ObservableCollection(T) Members
ObservableCollection(T) Class


MindFusion.Diagramming.ObservableCollection(T) Events

ObservableCollection(T) Events
[image]

Public Events

Name | Description
CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed.

See Also

ObservableCollection(T) Class


MindFusion.Diagramming.ObservableCollection(T).CollectionChanged Event

ObservableCollection(T).CollectionChanged Event
[image]

Occurs when an item is added, removed, changed, moved, or the entire list is refreshed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NotifyCollectionChangedEventArgs<T>> CollectionChanged

Visual Basic [image] Copy Code

Public Event CollectionChanged As EventHandler(Of NotifyCollectionChangedEventArgs(Of T))

Event Data

CollectionChanged event handlers receive an argument of type NotifyCollectionChangedEventArgs<T>.

See Also

ObservableCollection(T) Members
ObservableCollection(T) Class


MindFusion.Diagramming.Orientation Enumeration

Orientation Enumeration
[image]

Defines values that specify the orientation of the first segment of cascading links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum Orientation

Visual Basic [image] Copy Code

Public Enum Orientation

Members

Member name | Description
Auto | MvcDiagram determines automatically the initial direction of link's first segment.
Horizontal | The first segment of the link is always horizontal.
Vertical | The first segment of the link is always vertical.

See Also

CascadeOrientation Property


MindFusion.Diagramming.Path Class

Path Class
Remarks See Also
[image]

Represents a sequence of connected DiagramNode and DiagramLink elements.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class Path

Visual Basic [image] Copy Code

Public NotInheritable Class Path

Remarks

Path instances are returned by methods of the PathFinder class.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Path

See Also

Path Members


MindFusion.Diagramming.Path Members

Path Members
Properties Methods
[image]

Represents a sequence of connected DiagramNode and DiagramLink elements.

The following tables list the members exposed by the Path type.

Public Properties

Name | Description
Items | Gets a collection of all DiagramNode and DiagramLink elements in the path.
Length | Gets the length of the Path expressed as the number of Links participating in it.
Links | Gets a collection of all DiagramLink elements participating in the path.
Nodes | Gets a collection of all DiagramNode elements participating in the path.

Public Methods

Name | Description
GetWeight | Calculates the weight of this Path by accumulating the Weight of all participating Diagram elements.

See Also

Path Class


MindFusion.Diagramming.Path Methods

Path Methods
[image]

Public Methods

Name | Description
GetWeight | Calculates the weight of this Path by accumulating the Weight of all participating Diagram elements.

See Also

Path Class


MindFusion.Diagramming.Path.GetWeight Method

Path.GetWeight Method
[image]

Calculates the weight of this Path by accumulating the Weight of all participating Diagram elements.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float GetWeight (
bool incNodes,
bool incLinks
)

Visual Basic [image] Copy Code

Public Function GetWeight( _
incNodes As Boolean, _
incLinks As Boolean _
) As Single

Parameters

incNodes

A boolean value, which specifies whether the Weight of DiagramNode elements should be considered.

incLinks

A boolean value, which specifies whether the Weight of DiagramLink elements should be considered.

Return Value

A float value that represents the total weight of the elements in this Path according to the incNodes and incLinks parameters.

See Also

Path Members
Path Class


MindFusion.Diagramming.Path Properties

Path Properties
[image]

Public Properties

Name | Description
Items | Gets a collection of all DiagramNode and DiagramLink elements in the path.
Length | Gets the length of the Path expressed as the number of Links participating in it.
Links | Gets a collection of all DiagramLink elements participating in the path.
Nodes | Gets a collection of all DiagramNode elements participating in the path.

See Also

Path Class


MindFusion.Diagramming.Path.Items Property

Path.Items Property
[image]

Gets a collection of all DiagramNode and DiagramLink elements in the path.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemCollection Items { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Items As DiagramItemCollection

Property Value

An instance of the DiagramItemCollection class.

Remarks

The collection contains consecutive DiagramNode and DiagramLink objects.

See Also

Path Members
Path Class


MindFusion.Diagramming.Path.Length Property

Path.Length Property
[image]

Gets the length of the Path expressed as the number of Links participating in it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Length { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Length As Integer

Property Value

An integer value that represents the number of edges (links) in the path.

See Also

Path Members
Path Class


MindFusion.Diagramming.Path.Links Property

Path.Links Property
[image]

Gets a collection of all DiagramLink elements participating in the path.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection Links { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Links As DiagramLinkCollection

Property Value

An instance of the DiagramLinkCollection class.

Remarks

Use Nodes to get all DiagramNode elements in the Path.

See Also

Path Members
Path Class


MindFusion.Diagramming.Path.Nodes Property

Path.Nodes Property
[image]

Gets a collection of all DiagramNode elements participating in the path.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeCollection Nodes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Nodes As DiagramNodeCollection

Property Value

An instance of the DiagramNodeCollection class.

Remarks

Use Links to get all DiagramLinks elements in the Path.

See Also

Path Members
Path Class


MindFusion.Diagramming.PathCollection Class

PathCollection Class
[image]

Represents a strongly typed collection of Path objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class PathCollection : CollectionBase

Visual Basic [image] Copy Code

Public NotInheritable Class PathCollection
Inherits CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Diagramming.PathCollection

See Also

PathCollection Members


MindFusion.Diagramming.PathCollection Members

PathCollection Members
Constructors Properties Methods
[image]

Represents a strongly typed collection of Path objects.

The following tables list the members exposed by the PathCollection type.

Public Constructors

Name | Description
PathCollection | Initializes a new instance of the PathCollection class.

Public Properties

Name | Description
Item | Gets or sets the Path at the specified position.

Public Methods

Name | Description
Add | Adds the specified Path to the collection.
Clear | Removes all Path elements from the PathCollection.
GetAt | Gets the Path at the specified position.
Insert | Inserts the specified Path to the PathCollection at the specified index.
Remove | Removes the specified Path element from the PathCollection.

See Also

PathCollection Class


MindFusion.Diagramming.PathCollection Constructor

PathCollection Constructor
[image]

Initializes a new instance of the PathCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PathCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PathCollection Class


MindFusion.Diagramming.PathCollection Methods

PathCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified Path to the collection.
Clear | Removes all Path elements from the PathCollection.
GetAt | Gets the Path at the specified position.
Insert | Inserts the specified Path to the PathCollection at the specified index.
Remove | Removes the specified Path element from the PathCollection.

See Also

PathCollection Class


MindFusion.Diagramming.PathCollection.Add Method

PathCollection.Add Method
[image]

Adds the specified Path to the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Add (
Path path
)

Visual Basic [image] Copy Code

Public Sub Add ( _
path As Path _
)

Parameters

path
The Path object to add.

Remarks

The Path object is added at the end of the PathCollection. Use Insert to specify the place of the new element.

See Also

PathCollection Members
PathCollection Class


MindFusion.Diagramming.PathCollection.Clear Method

PathCollection.Clear Method
[image]

Removes all Path elements from the PathCollection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public new void Clear ()

Visual Basic [image] Copy Code

Public Shadows Sub Clear ()

Remarks

The method removes all Path elements in the collection. If you want to delete a specific element use Remove.

See Also

PathCollection Members
PathCollection Class


MindFusion.Diagramming.PathCollection.GetAt Method

PathCollection.GetAt Method
[image]

Gets the Path at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Path GetAt (
int index
)

Visual Basic [image] Copy Code

Public Function GetAt ( _
index As Integer _
) As Path

Parameters

index
The zero-based index of the Path element to get.

Return Value

The Path at the specified position in the PathCollection.

See Also

PathCollection Members
PathCollection Class


MindFusion.Diagramming.PathCollection.Insert Method

PathCollection.Insert Method
[image]

Inserts the specified Path to the PathCollection at the specified index.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Insert (
int index,
Path path
)

Visual Basic [image] Copy Code

Public Sub Insert ( _
index As Integer, _
path As Path _
)

Parameters

index
The zero-based index at which the new Path element should be inserted.
path
The Path element to insert.

Remarks

The method inserts a new element at a given position in the PathCollection. Use Add to add a new element to the end of the collection.

See Also

PathCollection Members
PathCollection Class


MindFusion.Diagramming.PathCollection.Remove Method

PathCollection.Remove Method
[image]

Removes the specified Path element from the PathCollection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Remove (
Path path
)

Visual Basic [image] Copy Code

Public Sub Remove ( _
path As Path _
)

Parameters

path
The Path element to remove.

Remarks

The size of the PathCollection is corrected. Indexes of the elements after path are updated too.

See Also

PathCollection Members
PathCollection Class


MindFusion.Diagramming.PathCollection Properties

PathCollection Properties
[image]

Public Properties

Name | Description
Item | Gets or sets the Path at the specified position.

See Also

PathCollection Class


MindFusion.Diagramming.PathCollection.Item Property

PathCollection.Item Property
[image]

Gets or sets the Path at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Path Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Property Item ( _
index As Integer _
) As Path

Parameters

index
The zero-based index of the Path element to access.

Property Value

An instance of the Path class that represents the path at the specified position.

See Also

PathCollection Members
PathCollection Class


MindFusion.Diagramming.PathFinder Class

PathFinder Class
Remarks See Also
[image]

Provides methods that help you find paths and cycles in a graph.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class PathFinder

Visual Basic [image] Copy Code

Public NotInheritable Class PathFinder

Remarks

By default the direction of links is taken into account when looking for paths or cycles. In that case the direction of a path is considered to be the direction defined by the outgoing links of nodes. Use the second constructor override to specify that link direction should be ignored when looking for paths.

A path-finder object caches graph information between method calls in order to achieve better performance when path and cycle -finding methods are called on the same diagram more than once. However if the diagram structure changes, you must create a new PathFinder instance in order to use the new structure of the diagram graph.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.PathFinder

See Also

PathFinder Members


MindFusion.Diagramming.PathFinder Members

PathFinder Members
Constructors Methods
[image]

Provides methods that help you find paths and cycles in a graph.

The following tables list the members exposed by the PathFinder type.

Public Constructors

Name | Description
PathFinder | Overloaded. Initializes a new instance of the PathFinder class.

Public Methods

Name | Description
EnumAllCycles | Enumerates all cycles in the underlying diagram.
FindAllCycles | Finds all cycles in the underlying diagram.
FindAllPaths | Overloaded.
FindCycle | Overloaded. Finds a cycle in the underlying diagram.
FindLongestPath | Overloaded. Finds the longest path in the underlying diagram.
FindShortestPath | Overloaded. Finds the shortest path in the underlying diagram.

See Also

PathFinder Class


MindFusion.Diagramming.PathFinder Constructor

PathFinder Constructor
[image]

Initializes a new instance of the PathFinder class.

Overload List

Name | Description
PathFinder (Diagram) | Initializes a new instance of the PathFinder class. Path-finding will depend on the direction of links.
PathFinder (Diagram, Boolean) | Initializes a new instance of the PathFinder class, optionally ignoring the link direction.

See Also

PathFinder Class


MindFusion.Diagramming.PathFinder Constructor (Diagram)

PathFinder Constructor (Diagram)
See Also
[image]

Initializes a new instance of the PathFinder class. Path-finding will depend on the direction of links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PathFinder (
Diagram diagram
)

Visual Basic [image] Copy Code

Public Sub PathFinder ( _
diagram As Diagram _
)

Parameters

diagram
An instance of the Diagram class in which to look for paths or cycles.

Remarks

The PathFinder methods look for paths and cycles in the Diagram instance specified through the argument. The diagram is treated as a directed graph and the direction of links is considered when looking for a path, that is, a path continues from a node only through its OutgoingLinks.

See Also

PathFinder Constructor Overload List
PathFinder Class


MindFusion.Diagramming.PathFinder Constructor (Diagram, Boolean)

PathFinder Constructor (Diagram, Boolean)
See Also
[image]

Initializes a new instance of the PathFinder class, optionally ignoring the link direction.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PathFinder (
Diagram diagram,
bool ignoreDirection
)

Visual Basic [image] Copy Code

Public Sub PathFinder ( _
diagram As Diagram, _
ignoreDirection As Boolean _
)

Parameters

diagram
A Diagram instance in which to look for paths or cycles.
ignoreDirection
Specifies whether the direction of links should be considered when looking for paths or cycles.

Remarks

The PathFinder methods look for paths and cycles in the Diagram instance specified with the first argument. By default, the diagram is treated as a directed graph and the direction of links is considered when looking for a path, that is, a path continues from a node only through its OutgoingLinks.

To ignore the direction of links, pass true as a value of the ignoreDirection argument; then the path-finding algorithm will look for paths both through the OutgoingLinks and IncomingLinks collections of nodes. If you do not want to ignore the direction of links you can use the alternative constructor.

See Also

PathFinder Constructor Overload List
PathFinder Class


MindFusion.Diagramming.PathFinder Methods

PathFinder Methods
[image]

Public Methods

Name | Description
EnumAllCycles | Enumerates all cycles in the underlying diagram.
FindAllCycles | Finds all cycles in the underlying diagram.
FindAllPaths | Overloaded.
FindCycle | Overloaded. Finds a cycle in the underlying diagram.
FindLongestPath | Overloaded. Finds the longest path in the underlying diagram.
FindShortestPath | Overloaded. Finds the shortest path in the underlying diagram.

See Also

PathFinder Class


MindFusion.Diagramming.PathFinder.EnumAllCycles Method

PathFinder.EnumAllCycles Method
[image]

Enumerates all cycles in the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IEnumerable<Path> EnumAllCycles ()

Visual Basic [image] Copy Code

Public Function EnumAllCycles () As IEnumerable(Of Path)

Return Value

A collection of Path objects; if no cycles are detected, the collection is empty.

See Also

PathFinder Members
PathFinder Class


MindFusion.Diagramming.PathFinder.FindAllCycles Method

PathFinder.FindAllCycles Method
[image]

Finds all cycles in the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PathCollection FindAllCycles ()

Visual Basic [image] Copy Code

Public Function FindAllCycles () As PathCollection

Return Value

A collection of Path objects; if no cycles are detected, the collection is empty.

See Also

PathFinder Members
PathFinder Class
FindCycle Method


MindFusion.Diagramming.PathFinder.FindAllPaths Method

PathFinder.FindAllPaths Method
[image]

Overload List

Name | Description
PathFinder.FindAllPaths (DiagramNode, DiagramNode) | Finds and returns all paths that exist between two DiagramNode objects.
PathFinder.FindAllPaths (DiagramNode, DiagramNode, Int32) | Finds and returns all paths that exist between two DiagramNode objects.

See Also

PathFinder Members
PathFinder Class


MindFusion.Diagramming.PathFinder.FindAllPaths Method (DiagramNode, DiagramNode)

PathFinder.FindAllPaths Method (DiagramNode, DiagramNode)
See Also
[image]

Finds and returns all paths that exist between two DiagramNode objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PathCollection FindAllPaths (
DiagramNode from,
DiagramNode to
)

Visual Basic [image] Copy Code

Public Function FindAllPaths ( _
from As DiagramNode, _
to As DiagramNode _
) As PathCollection

Parameters

from
The first DiagramNode in the Path.
to
The last DiagramNode in the Path.

Return Value

A collection of Path objects; if no paths are found, the collection is empty.

Remarks

The returned Path instances include the from an to nodes.

See Also

PathFinder Members
PathFinder Class
FindShortestPath Method


MindFusion.Diagramming.PathFinder.FindAllPaths Method (DiagramNode, DiagramNode, Int32)

PathFinder.FindAllPaths Method (DiagramNode, DiagramNode, Int32)
See Also
[image]

Finds and returns all paths that exist between two DiagramNode objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PathCollection FindAllPaths (
DiagramNode from,
DiagramNode to,
int maxPaths
)

Visual Basic [image] Copy Code

Public Function FindAllPaths( _
from As DiagramNode, _
to As DiagramNode, _
maxPaths As Integer _
) As PathCollection

Parameters

from

The first DiagramNode in the Path.

to

The last DiagramNode in the Path.

maxPaths

The maximum number of paths to find.

Return Value

A collection of Path objects; if no paths are found, the collection is empty.

Remarks

The returned Path instances include the from an to nodes.

See Also

FindAllPaths Method Overload List
PathFinder Members
PathFinder Class


MindFusion.Diagramming.PathFinder.FindCycle Method

PathFinder.FindCycle Method
[image]

Finds a cycle in the underlying diagram.

Overload List

Name | Description
PathFinder.FindCycle () | Finds a cycle in the Diagram.
PathFinder.FindCycle (DiagramNode) | Detects whether the specified DiagramNode participates in a cycle.

See Also

PathFinder Members
PathFinder Class


MindFusion.Diagramming.PathFinder.FindCycle Method ()

PathFinder.FindCycle Method ()
See Also
[image]

Finds a cycle in the Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Path FindCycle ()

Visual Basic [image] Copy Code

Public Function FindCycle () As Path

Return Value

A Path instance that represents the found cycle; null (Nothing in Visual Basic) if no cycle is detected.

See Also

FindCycle Method Overload List
PathFinder Members
PathFinder Class
FindShortestPath Method


MindFusion.Diagramming.PathFinder.FindCycle Method (DiagramNode)

PathFinder.FindCycle Method (DiagramNode)
See Also
[image]

Detects whether the specified DiagramNode participates in a cycle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Path FindCycle (
DiagramNode participant
)

Visual Basic [image] Copy Code

Public Function FindCycle ( _
participant As DiagramNode _
) As Path

Parameters

participant
A DiagramNode element which should participate in the found cycle.

Return Value

A Path instance that represents the found cycle; null (Nothing in Visual Basic) if no cycle is detected.

See Also

FindCycle Method Overload List
PathFinder Members
PathFinder Class
FindAllCycles Method


MindFusion.Diagramming.PathFinder.FindLongestPath Method

PathFinder.FindLongestPath Method
[image]

Finds the longest path in the underlying diagram.

Overload List

Name | Description
PathFinder.FindLongestPath () | Finds the longest path in the graph.
PathFinder.FindLongestPath (DiagramNode, DiagramNode) | Finds the longest path between the specified DiagramNode objects.
PathFinder.FindLongestPath (Int64) | Finds the longest path in the diagram.

See Also

PathFinder Members
PathFinder Class


MindFusion.Diagramming.PathFinder.FindLongestPath Method ()

PathFinder.FindLongestPath Method ()
See Also
[image]

Finds the longest path in the graph.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Path FindLongestPath ()

Visual Basic [image] Copy Code

Public Function FindLongestPath () As Path

Return Value

A Path instance that represents the longest path found; null (Nothing in Visual Basic) if there are no DiagramNode elements in the graph.

See Also

FindLongestPath Method Overload List
PathFinder Members
PathFinder Class
FindAllPaths Method


MindFusion.Diagramming.PathFinder.FindLongestPath Method (DiagramNode, DiagramNode)

PathFinder.FindLongestPath Method (DiagramNode, DiagramNode)
See Also
[image]

Finds the longest path between the specified DiagramNode objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Path FindLongestPath (
DiagramNode from,
DiagramNode to
)

Visual Basic [image] Copy Code

Public Function FindLongestPath ( _
from As DiagramNode, _
to As DiagramNode _
) As Path

Parameters

from
The first DiagramNode element in the Path.
to
The last DiagramNode element in the Path.

Return Value

A Path instance that represents the longest path found; null (Nothing in Visual Basic) if there is no Path connecting from and to.

See Also

FindLongestPath Method Overload List
PathFinder Members
PathFinder Class
FindAllPaths Method


MindFusion.Diagramming.PathFinder.FindLongestPath Method (Int64)

PathFinder.FindLongestPath Method (Int64)
See Also
[image]

Finds the longest path in the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Path FindLongestPath (
long timeLimit
)

Visual Basic [image] Copy Code

Public Function FindLongestPath ( _
timeLimit As Long _
) As Path

Parameters

timeLimit
The maximum duration of the search process, in milliseconds.

Return Value

The longest Path found; null (Nothing in Visual Basic) if no Path has been detected.

See Also

FindLongestPath Method Overload List
PathFinder Members
PathFinder Class
FindAllPaths Method


MindFusion.Diagramming.PathFinder.FindShortestPath Method

PathFinder.FindShortestPath Method
[image]

Finds the shortest path in the underlying diagram.

Overload List

Name | Description
PathFinder.FindShortestPath (DiagramNode, DiagramNode) | Finds and returns the shortest Path between the specified DiagramNode objects.
PathFinder.FindShortestPath (DiagramNode, DiagramNode, Boolean, Boolean) | Finds and returns the shortest path between two DiagramNode elements, considering the Weight of the nodes, the Weight of the links or both.

See Also

PathFinder Members
PathFinder Class


MindFusion.Diagramming.PathFinder.FindShortestPath Method (DiagramNode, DiagramNode)

PathFinder.FindShortestPath Method (DiagramNode, DiagramNode)
See Also
[image]

Finds and returns the shortest Path between the specified DiagramNode objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Path FindShortestPath (
DiagramNode from,
DiagramNode to
)

Visual Basic [image] Copy Code

Public Function FindShortestPath ( _
from As DiagramNode, _
to As DiagramNode _
) As Path

Parameters

from
The first DiagramNode in the Path.
to
The last DiagramNode in the Path.

Return Value

A Path instance that represents the shortest path found; null (Nothing in Visual Basic) if there is no path connecting from and to.

See Also

FindShortestPath Method Overload List
PathFinder Members
PathFinder Class
FindAllPaths Method


MindFusion.Diagramming.PathFinder.FindShortestPath Method (DiagramNode, DiagramNode, Boolean, Boolean)

PathFinder.FindShortestPath Method (DiagramNode, DiagramNode, Boolean, Boolean)
See Also
[image]

Finds and returns the shortest path between two DiagramNode elements, considering the Weight of the nodes, the Weight of the links or both.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Path FindShortestPath (
DiagramNode from,
DiagramNode to,
bool useNodeWeights,
bool useLinkWeights
)

Visual Basic [image] Copy Code

Public Function FindShortestPath ( _
from As DiagramNode, _
to As DiagramNode, _
useNodeWeights As Boolean, _
useLinkWeights As Boolean _
) As Path

Parameters

from
The first DiagramNode in the Path.
to
The last DiagramNode in the Path.
useNodeWeights
If true, the Path with minimal total weight is found, summing the Weight of nodes in the Path.
useLinkWeights
If true, the Path with minimal total weight is found, summing the Weight of links in the Path.

Return Value

A Path instance that represents the shortest Path found or null (Nothing in Visual Basic) if there is no Path connecting from and to.

See Also

FindShortestPath Method Overload List
PathFinder Members
PathFinder Class
FindAllPaths Method


MindFusion.Diagramming.PersistableCollection(T) Class

PersistableCollection(T) Class
[image]

A base collection class for persistable collections.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class PersistableCollection<T> : CollectionBase<T>, IPersists

Visual Basic [image] Copy Code

Public MustInherit Class PersistableCollection(Of T)
Inherits CollectionBase(Of T)
Implements IPersists

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.CollectionBase(T)
MindFusion.Diagramming.PersistableCollection(T)
MindFusion.Diagramming.AnchorPointCollection
MindFusion.Diagramming.GroupCollection
MindFusion.Diagramming.ItemCollectionBase(T)

See Also

PersistableCollection(T) Members


MindFusion.Diagramming.PersistableCollection(T) Members

PersistableCollection(T) Members
Constructors Fields Properties Methods
[image]

A base collection class for persistable collections.

The following tables list the members exposed by the PersistableCollection(T) type.

Protected Constructors

Name | Description
PersistableCollection | Initializes a new instance of the PersistableCollection class.

Protected Fields

Name | Description
InnerList | Gets a List<T> containing the list of elements in the collection instance. (Inherited from CollectionBase.)

Public Properties

Name | Description
Count | Gets the number of elements actually contained in the collection. (Inherited from CollectionBase.)
IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index. (Inherited from CollectionBase.)

Public Methods

Name | Description
Add | Adds an object to the end of the collection. (Inherited from CollectionBase.)
Clear | Removes all elements from the collection. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from CollectionBase.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts an element into the collection at the specified index. (Inherited from CollectionBase.)
Remove | Removes the first occurrence of a specific object from the collection. (Inherited from CollectionBase.)
RemoveAt | Removes the element at the specified index of the collection. (Inherited from CollectionBase.)
Sort | Overloaded. (Inherited from CollectionBase.)

See Also

PersistableCollection(T) Class


MindFusion.Diagramming.PersistableCollection(T) Constructor

PersistableCollection(T) Constructor
[image]

Initializes a new instance of the PersistableCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected PersistableCollection<T> ()

Visual Basic [image] Copy Code

Protected Sub New(Of T) ()

See Also

PersistableCollection(T) Class


MindFusion.Diagramming.PersistContext Class

PersistContext Class
[image]

Contains methods that help serializing and deserializing complex MvcDiagram object to and from binary streams.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class PersistContext

Visual Basic [image] Copy Code

Public Class PersistContext

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.PersistContext

See Also

PersistContext Members


MindFusion.Diagramming.PersistContext Members

PersistContext Members
Properties Methods
[image]

Contains methods that help serializing and deserializing complex MvcDiagram object to and from binary streams.

The following tables list the members exposed by the PersistContext type.

Public Properties

Name | Description
FileVersion | Gets the version of the diagram currently being loaded.
Reader | Gets the binary reader used for deserialization.
VersionTable | Gets the table of item class format revision numbers.
Writer | Gets the binary writer used for serialization.

Public Methods

Name | Description
GetObsoleteValue | This method supports the MvcDiagram infrastructure and is not intended to be used directly from your code.
LoadAnchorPattern | Loads an anchor pattern from the underlying stream.
LoadBrush | Loads a Brush from the underlying stream.
LoadColor | Loads a color from the underlying stream.
LoadColorArray | Loads a color array from the underlying stream.
LoadFloatArray | Loads a float array from the underlying stream.
LoadFont | Loads a font from the underlying stream.
LoadHashtable | Loads a hashtable from the underlying stream.
LoadImage | Loads an image from the underlying stream.
LoadObject | Loads an IPersists object from the underlying stream.
LoadPen | Loads a pen from the underlying stream.
loadPtfArray | Loads a PointF array from the underlying stream.
LoadRect | Loads a rectangle from the underlying stream.
LoadRectF | Loads a rectangle from the underlying stream.
LoadReference | Loads a reference for the specified referer.
LoadRemainingObjects | Loads the remaining referenced objects from the underlying stream.
LoadShape | Loads a shape from the underlying stream.
LoadSizeF | Loads a SizeF object from the underlying stream.
LoadStringFormat | Loads a string format from the underlying stream.
LoadSvg | Loads an SvgContent object from the underlying stream.
LoadTag | Loads an object from the underlying stream.
LoadTheme | Loads a Theme object from the underlying stream.
LoadThickness | Loads a Thickness object from the underlying stream.
LoadVisioContent | Loads a VisioContent object from the underlying stream.
ReadHeader | Reads the binary file format header from the underlying stream and throws an exception if the header is not recognized.
SaveAnchorPattern | Saves the specified anchor pattern to the underlying stream.
SaveBrush | Saves the specified Brush to the underlying stream.
SaveColor | Saves the specified color to the underlying stream.
SaveColorArray | Saves the specified color array to the underlying stream.
SaveFloatArray | Saves the specified float array to the underlying stream.
SaveFont | Saves the specified font to the underlying stream.
SaveHashtable | Saves the specified hashtable to the underlying stream.
SaveImage | Saves the specified image to the underlying stream.
SaveObject | Writes the specified IPersists object to the underlying stream.
SavePen | Saves the specified pen to the underlying stream.
SavePtfArray | Saves the specified PointF array to the underlying stream.
SaveRect | Saves the specified rectangle to the underlying stream.
SaveRectF | Saves the specified rectangle to the underlying stream.
SaveReference | Saves the specified reference for the specified referer.
SaveShape | Saves the specified shape to the underlying stream.
SaveSizeF | Saves the specified SizeF to the underlying stream.
SaveStringFormat | Saves the specified string format to the underlying stream.
SaveSvg | Saves the specified SvgContent in the underlying stream.
SaveTag | Saves the specified object to the underlying stream.
SaveTheme | Saves the specified Theme in the underlying stream.
SaveThickness | Saves the specified Thickness to the underlying stream.
SaveVisioContent | Saves the specified VisioContent in the underlying stream.
SetReferences | Updates all references among loaded objects.
WriteHeader | Writes the binary file format header to the underlying stream.
WriteReferencedObjects | Writes all referenced objects to the underlying stream.

See Also

PersistContext Class


MindFusion.Diagramming.PersistContext Methods

PersistContext Methods
[image]

Public Methods

Name | Description
GetObsoleteValue | This method supports the MvcDiagram infrastructure and is not intended to be used directly from your code.
LoadAnchorPattern | Loads an anchor pattern from the underlying stream.
LoadBrush | Loads a Brush from the underlying stream.
LoadColor | Loads a color from the underlying stream.
LoadColorArray | Loads a color array from the underlying stream.
LoadFloatArray | Loads a float array from the underlying stream.
LoadFont | Loads a font from the underlying stream.
LoadHashtable | Loads a hashtable from the underlying stream.
LoadImage | Loads an image from the underlying stream.
LoadObject | Loads an IPersists object from the underlying stream.
LoadPen | Loads a pen from the underlying stream.
loadPtfArray | Loads a PointF array from the underlying stream.
LoadRect | Loads a rectangle from the underlying stream.
LoadRectF | Loads a rectangle from the underlying stream.
LoadReference | Loads a reference for the specified referer.
LoadRemainingObjects | Loads the remaining referenced objects from the underlying stream.
LoadShape | Loads a shape from the underlying stream.
LoadSizeF | Loads a SizeF object from the underlying stream.
LoadStringFormat | Loads a string format from the underlying stream.
LoadSvg | Loads an SvgContent object from the underlying stream.
LoadTag | Loads an object from the underlying stream.
LoadTheme | Loads a Theme object from the underlying stream.
LoadThickness | Loads a Thickness object from the underlying stream.
LoadVisioContent | Loads a VisioContent object from the underlying stream.
ReadHeader | Reads the binary file format header from the underlying stream and throws an exception if the header is not recognized.
SaveAnchorPattern | Saves the specified anchor pattern to the underlying stream.
SaveBrush | Saves the specified Brush to the underlying stream.
SaveColor | Saves the specified color to the underlying stream.
SaveColorArray | Saves the specified color array to the underlying stream.
SaveFloatArray | Saves the specified float array to the underlying stream.
SaveFont | Saves the specified font to the underlying stream.
SaveHashtable | Saves the specified hashtable to the underlying stream.
SaveImage | Saves the specified image to the underlying stream.
SaveObject | Writes the specified IPersists object to the underlying stream.
SavePen | Saves the specified pen to the underlying stream.
SavePtfArray | Saves the specified PointF array to the underlying stream.
SaveRect | Saves the specified rectangle to the underlying stream.
SaveRectF | Saves the specified rectangle to the underlying stream.
SaveReference | Saves the specified reference for the specified referer.
SaveShape | Saves the specified shape to the underlying stream.
SaveSizeF | Saves the specified SizeF to the underlying stream.
SaveStringFormat | Saves the specified string format to the underlying stream.
SaveSvg | Saves the specified SvgContent in the underlying stream.
SaveTag | Saves the specified object to the underlying stream.
SaveTheme | Saves the specified Theme in the underlying stream.
SaveThickness | Saves the specified Thickness to the underlying stream.
SaveVisioContent | Saves the specified VisioContent in the underlying stream.
SetReferences | Updates all references among loaded objects.
WriteHeader | Writes the binary file format header to the underlying stream.
WriteReferencedObjects | Writes all referenced objects to the underlying stream.

See Also

PersistContext Class


MindFusion.Diagramming.PersistContext.GetObsoleteValue Method

PersistContext.GetObsoleteValue Method
[image]

This method supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Object GetObsoleteValue (
string id
)

Visual Basic [image] Copy Code

Public Shared Function GetObsoleteValue( _
id As String _
) As Object

Parameters

id

Return Value

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.LoadAnchorPattern Method

PersistContext.LoadAnchorPattern Method
[image]

Loads an anchor pattern from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern LoadAnchorPattern ()

Visual Basic [image] Copy Code

Public Function LoadAnchorPattern () As AnchorPattern

Return Value

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.LoadBrush Method

PersistContext.LoadBrush Method
[image]

Loads a Brush from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush LoadBrush ()

Visual Basic [image] Copy Code

Public Function LoadBrush () As Brush

Return Value

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.LoadColor Method

PersistContext.LoadColor Method
[image]

Loads a color from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color LoadColor ()

Visual Basic [image] Copy Code

Public Function LoadColor () As Color

Return Value

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.LoadColorArray Method

PersistContext.LoadColorArray Method
[image]

Loads a color array from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color[] LoadColorArray ()

Visual Basic [image] Copy Code

Public Function LoadColorArray () As Color()

Return Value

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.LoadFloatArray Method

PersistContext.LoadFloatArray Method
[image]

Loads a float array from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float[] LoadFloatArray ()

Visual Basic [image] Copy Code

Public Function LoadFloatArray () As Single()

Return Value

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.LoadFont Method

PersistContext.LoadFont Method
[image]

Loads a font from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Font LoadFont ()

Visual Basic [image] Copy Code

Public Function LoadFont () As Font

Return Value

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.LoadHashtable Method

PersistContext.LoadHashtable Method
[image]

Loads a hashtable from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Hashtable LoadHashtable ()

Visual Basic [image] Copy Code

Public Function LoadHashtable () As Hashtable

Return Value

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.LoadImage Method

PersistContext.LoadImage Method
[image]

Loads an image from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Image LoadImage ()

Visual Basic [image] Copy Code

Public Function LoadImage () As Image

Return Value

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.LoadObject Method

PersistContext.LoadObject Method
[image]

Loads an IPersists object from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object LoadObject ()

Visual Basic [image] Copy Code

Public Function LoadObject () As Object

Return Value

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.LoadPen Method

PersistContext.LoadPen Method
[image]

Loads a pen from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen LoadPen ()

Visual Basic [image] Copy Code

Public Function LoadPen () As Pen

Return Value

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.loadPtfArray Method

PersistContext.loadPtfArray Method
[image]

Loads a PointF array from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointF[] loadPtfArray ()

Visual Basic [image] Copy Code

Public Function loadPtfArray () As PointF()

Return Value

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.LoadRect Method

PersistContext.LoadRect Method
[image]

Loads a rectangle from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rectangle LoadRect ()

Visual Basic [image] Copy Code

Public Function LoadRect () As Rectangle

Return Value

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.LoadRectF Method

PersistContext.LoadRectF Method
[image]

Loads a rectangle from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF LoadRectF ()

Visual Basic [image] Copy Code

Public Function LoadRectF () As RectangleF

Return Value

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.LoadReference Method

PersistContext.LoadReference Method
[image]

Loads a reference for the specified referer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadReference (
IPersists referer
)

Visual Basic [image] Copy Code

Public Sub LoadReference( _
referer As IPersists _
)

Parameters

referer

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.LoadRemainingObjects Method

PersistContext.LoadRemainingObjects Method
[image]

Loads the remaining referenced objects from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadRemainingObjects ()

Visual Basic [image] Copy Code

Public Sub LoadRemainingObjects ()

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.LoadShape Method

PersistContext.LoadShape Method
[image]

Loads a shape from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape LoadShape ()

Visual Basic [image] Copy Code

Public Function LoadShape () As Shape

Return Value

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.LoadSizeF Method

PersistContext.LoadSizeF Method
[image]

Loads a SizeF object from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SizeF LoadSizeF ()

Visual Basic [image] Copy Code

Public Function LoadSizeF () As SizeF

Return Value

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.LoadStringFormat Method

PersistContext.LoadStringFormat Method
[image]

Loads a string format from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringFormat LoadStringFormat ()

Visual Basic [image] Copy Code

Public Function LoadStringFormat () As StringFormat

Return Value

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.LoadSvg Method

PersistContext.LoadSvg Method
[image]

Loads an SvgContent object from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SvgContent LoadSvg ()

Visual Basic [image] Copy Code

Public Function LoadSvg () As SvgContent

Return Value

An instance of the MindFusion.Svg.SvgContent class.

See Also

PersistContext Members
PersistContext Class
SaveSvg Method


MindFusion.Diagramming.PersistContext.LoadTag Method

PersistContext.LoadTag Method
[image]

Loads an object from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object LoadTag ()

Visual Basic [image] Copy Code

Public Function LoadTag () As Object

Return Value

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.LoadTheme Method

PersistContext.LoadTheme Method
[image]

Loads a Theme object from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Theme LoadTheme ()

Visual Basic [image] Copy Code

Public Function LoadTheme () As Theme

Return Value

A Theme object.

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.LoadThickness Method

PersistContext.LoadThickness Method
[image]

Loads a Thickness object from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Thickness LoadThickness ()

Visual Basic [image] Copy Code

Public Function LoadThickness () As Thickness

Return Value

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.LoadVisioContent Method

PersistContext.LoadVisioContent Method
[image]

Loads a VisioContent object from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public VisioContent LoadVisioContent ()

Visual Basic [image] Copy Code

Public Function LoadVisioContent () As VisioContent

Return Value

The loaded VisioContent object.

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.ReadHeader Method

PersistContext.ReadHeader Method
[image]

Reads the binary file format header from the underlying stream and throws an exception if the header is not recognized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ReadHeader ()

Visual Basic [image] Copy Code

Public Sub ReadHeader ()

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.SaveAnchorPattern Method

PersistContext.SaveAnchorPattern Method
[image]

Saves the specified anchor pattern to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveAnchorPattern (
AnchorPattern ap
)

Visual Basic [image] Copy Code

Public Sub SaveAnchorPattern( _
ap As AnchorPattern _
)

Parameters

ap

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.SaveBrush Method

PersistContext.SaveBrush Method
[image]

Saves the specified Brush to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveBrush (
Brush brush
)

Visual Basic [image] Copy Code

Public Sub SaveBrush( _
brush As Brush _
)

Parameters

brush

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.SaveColor Method

PersistContext.SaveColor Method
[image]

Saves the specified color to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveColor (
Color clr
)

Visual Basic [image] Copy Code

Public Sub SaveColor( _
clr As Color _
)

Parameters

clr

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.SaveColorArray Method

PersistContext.SaveColorArray Method
[image]

Saves the specified color array to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveColorArray (
Color[] arr
)

Visual Basic [image] Copy Code

Public Sub SaveColorArray( _
arr() As Color _
)

Parameters

arr

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.SaveFloatArray Method

PersistContext.SaveFloatArray Method
[image]

Saves the specified float array to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveFloatArray (
float[] arr
)

Visual Basic [image] Copy Code

Public Sub SaveFloatArray( _
arr() As Single _
)

Parameters

arr

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.SaveFont Method

PersistContext.SaveFont Method
[image]

Saves the specified font to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveFont (
Font font
)

Visual Basic [image] Copy Code

Public Sub SaveFont( _
font As Font _
)

Parameters

font

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.SaveHashtable Method

PersistContext.SaveHashtable Method
[image]

Saves the specified hashtable to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveHashtable (
Hashtable hashtable
)

Visual Basic [image] Copy Code

Public Sub SaveHashtable( _
hashtable As Hashtable _
)

Parameters

hashtable

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.SaveImage Method

PersistContext.SaveImage Method
[image]

Saves the specified image to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveImage (
Image image
)

Visual Basic [image] Copy Code

Public Sub SaveImage( _
image As Image _
)

Parameters

image

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.SaveObject Method

PersistContext.SaveObject Method
[image]

Writes the specified IPersists object to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveObject (
IPersists obj
)

Visual Basic [image] Copy Code

Public Sub SaveObject( _
obj As IPersists _
)

Parameters

obj

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.SavePen Method

PersistContext.SavePen Method
[image]

Saves the specified pen to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SavePen (
Pen pen
)

Visual Basic [image] Copy Code

Public Sub SavePen( _
pen As Pen _
)

Parameters

pen

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.SavePtfArray Method

PersistContext.SavePtfArray Method
[image]

Saves the specified PointF array to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SavePtfArray (
PointF[] pts
)

Visual Basic [image] Copy Code

Public Sub SavePtfArray( _
pts() As PointF _
)

Parameters

pts

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.SaveRect Method

PersistContext.SaveRect Method
[image]

Saves the specified rectangle to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveRect (
Rectangle rect
)

Visual Basic [image] Copy Code

Public Sub SaveRect( _
rect As Rectangle _
)

Parameters

rect

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.SaveRectF Method

PersistContext.SaveRectF Method
[image]

Saves the specified rectangle to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveRectF (
RectangleF rect
)

Visual Basic [image] Copy Code

Public Sub SaveRectF( _
rect As RectangleF _
)

Parameters

rect

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.SaveReference Method

PersistContext.SaveReference Method
[image]

Saves the specified reference for the specified referer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveReference (
IPersists referer,
IPersists pobj,
int refId
)

Visual Basic [image] Copy Code

Public Sub SaveReference ( _
referer As IPersists, _
pobj As IPersists, _
refId As Integer _
)

Parameters

referer

pobj

refId

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.SaveShape Method

PersistContext.SaveShape Method
[image]

Saves the specified shape to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveShape (
Shape shape
)

Visual Basic [image] Copy Code

Public Sub SaveShape( _
shape As Shape _
)

Parameters

shape

A Shape to be serialized.

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.SaveSizeF Method

PersistContext.SaveSizeF Method
[image]

Saves the specified SizeF to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveSizeF (
SizeF size
)

Visual Basic [image] Copy Code

Public Sub SaveSizeF( _
size As SizeF _
)

Parameters

size

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.SaveStringFormat Method

PersistContext.SaveStringFormat Method
[image]

Saves the specified string format to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveStringFormat (
StringFormat sf
)

Visual Basic [image] Copy Code

Public Sub SaveStringFormat( _
sf As StringFormat _
)

Parameters

sf

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.SaveSvg Method

PersistContext.SaveSvg Method
[image]

Saves the specified SvgContent in the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveSvg (
SvgContent svg
)

Visual Basic [image] Copy Code

Public Sub SaveSvg( _
svg As SvgContent _
)

Parameters

svg
An instance of the MindFusion.Svg.SvgContent class.

See Also

PersistContext Members
PersistContext Class
LoadSvg Method


MindFusion.Diagramming.PersistContext.SaveTag Method

PersistContext.SaveTag Method
[image]

Saves the specified object to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveTag (
Object obj
)

Visual Basic [image] Copy Code

Public Sub SaveTag( _
obj As Object _
)

Parameters

obj

Remarks

The objects is serialized if it is one of the .NET core types or if it is marked as Serializable.

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.SaveTheme Method

PersistContext.SaveTheme Method
[image]

Saves the specified Theme in the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveTheme (
Theme theme
)

Visual Basic [image] Copy Code

Public Sub SaveTheme( _
theme As Theme _
)

Parameters

theme

The Theme to save.

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.SaveThickness Method

PersistContext.SaveThickness Method
[image]

Saves the specified Thickness to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveThickness (
Thickness thickness
)

Visual Basic [image] Copy Code

Public Sub SaveThickness( _
thickness As Thickness _
)

Parameters

thickness

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.SaveVisioContent Method

PersistContext.SaveVisioContent Method
[image]

Saves the specified VisioContent in the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveVisioContent (
VisioContent content
)

Visual Basic [image] Copy Code

Public Sub SaveVisioContent( _
content As VisioContent _
)

Parameters

content

The VisioContent object to save.

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.SetReferences Method

PersistContext.SetReferences Method
[image]

Updates all references among loaded objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetReferences ()

Visual Basic [image] Copy Code

Public Sub SetReferences ()

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.WriteHeader Method

PersistContext.WriteHeader Method
[image]

Writes the binary file format header to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void WriteHeader ()

Visual Basic [image] Copy Code

Public Sub WriteHeader ()

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.WriteReferencedObjects Method

PersistContext.WriteReferencedObjects Method
[image]

Writes all referenced objects to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void WriteReferencedObjects ()

Visual Basic [image] Copy Code

Public Sub WriteReferencedObjects ()

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext Properties

PersistContext Properties
[image]

Public Properties

Name | Description
FileVersion | Gets the version of the diagram currently being loaded.
Reader | Gets the binary reader used for deserialization.
VersionTable | Gets the table of item class format revision numbers.
Writer | Gets the binary writer used for serialization.

See Also

PersistContext Class


MindFusion.Diagramming.PersistContext.FileVersion Property

PersistContext.FileVersion Property
[image]

Gets the version of the diagram currently being loaded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int FileVersion { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property FileVersion As Integer

Property Value

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.Reader Property

PersistContext.Reader Property
[image]

Gets the binary reader used for deserialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public BinaryReader Reader { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Reader As BinaryReader

Property Value

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.VersionTable Property

PersistContext.VersionTable Property
[image]

Gets the table of item class format revision numbers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Hashtable VersionTable { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property VersionTable As Hashtable

Property Value

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PersistContext.Writer Property

PersistContext.Writer Property
[image]

Gets the binary writer used for serialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public BinaryWriter Writer { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Writer As BinaryWriter

Property Value

See Also

PersistContext Members
PersistContext Class


MindFusion.Diagramming.PointCollection Class

PointCollection Class
[image]

Represents a strongly typed collection of points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class PointCollection : CollectionBase, IPersists

Visual Basic [image] Copy Code

Public Class PointCollection
Inherits CollectionBase
Implements IPersists

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Diagramming.PointCollection

See Also

PointCollection Members


MindFusion.Diagramming.PointCollection Members

PointCollection Members
Constructors Properties Methods
[image]

Represents a strongly typed collection of points.

The following tables list the members exposed by the PointCollection type.

Public Constructors

Name | Description
PointCollection | Overloaded. Initializes a new instance of the PointCollection class.

Public Properties

Name | Description
Item | Gets or sets the point at the specified position.

Public Methods

Name | Description
Add | Adds the specified point to the collection.
AddRange | Adds the points in the specified collection to this collection.
Clear | Removes all points from the collection.
Clone | Creates a shallow copy of this collection.
GetArray | Gets a PointF array containing the points in this collection.
GetAt | Gets the point at the specified position.
Insert | Inserts the specified point in the collection at the specified position.
Remove | Removes the specified point from the collection.
Reverse | Returns a copy of this collection with reversed order of elements.
SetAt | Sets the specified point at the specified position within the collection.

See Also

PointCollection Class


MindFusion.Diagramming.PointCollection Constructor

PointCollection Constructor
[image]

Initializes a new instance of the PointCollection class.

Overload List

Name | Description
PointCollection (Int32) | Initializes a new instance of the PointCollection class with the specified initial size.
PointCollection (PointF[]) | Initializes a new instance of the PointCollection class with the specified point values.

See Also

PointCollection Class


MindFusion.Diagramming.PointCollection Constructor (Int32)

PointCollection Constructor (Int32)
See Also
[image]

Initializes a new instance of the PointCollection class with the specified initial size.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointCollection (
int size
)

Visual Basic [image] Copy Code

Public New ( _
size As Integer _
)

Parameters

size

The initial size of the collection.

See Also

PointCollection Constructor Overload List
PointCollection Class


MindFusion.Diagramming.PointCollection Constructor (PointF[])

PointCollection Constructor (PointF[])
See Also
[image]

Initializes a new instance of the PointCollection class with the specified point values.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointCollection (
PointF[] points
)

Visual Basic [image] Copy Code

Public New ( _
points() As PointF _
)

Parameters

points

An array of PointF values that supplies the elements initially contained in the collection.

See Also

PointCollection Constructor Overload List
PointCollection Class


MindFusion.Diagramming.PointCollection Methods

PointCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified point to the collection.
AddRange | Adds the points in the specified collection to this collection.
Clear | Removes all points from the collection.
Clone | Creates a shallow copy of this collection.
GetArray | Gets a PointF array containing the points in this collection.
GetAt | Gets the point at the specified position.
Insert | Inserts the specified point in the collection at the specified position.
Remove | Removes the specified point from the collection.
Reverse | Returns a copy of this collection with reversed order of elements.
SetAt | Sets the specified point at the specified position within the collection.

See Also

PointCollection Class


MindFusion.Diagramming.PointCollection.Add Method

PointCollection.Add Method
[image]

Adds the specified point to the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Add (
PointF point
)

Visual Basic [image] Copy Code

Public Sub Add( _
point As PointF _
)

Parameters

point

The .NET PointF object to add to the collection.

See Also

PointCollection Members
PointCollection Class


MindFusion.Diagramming.PointCollection.AddRange Method

PointCollection.AddRange Method
[image]

Adds the points in the specified collection to this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AddRange (
ICollection c
)

Visual Basic [image] Copy Code

Public Sub AddRange( _
c As ICollection _
)

Parameters

c

The .NET ICollection object that contains the points to add to this collection.

See Also

PointCollection Members
PointCollection Class


MindFusion.Diagramming.PointCollection.Clear Method

PointCollection.Clear Method
[image]

Removes all points from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public new void Clear ()

Visual Basic [image] Copy Code

Public Shadows Sub Clear ()

See Also

PointCollection Members
PointCollection Class


MindFusion.Diagramming.PointCollection.Clone Method

PointCollection.Clone Method
[image]

Creates a shallow copy of this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointCollection Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As PointCollection

Return Value

An instance of the PointCollection class.

See Also

PointCollection Members
PointCollection Class


MindFusion.Diagramming.PointCollection.GetArray Method

PointCollection.GetArray Method
[image]

Gets a PointF array containing the points in this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointF[] GetArray ()

Visual Basic [image] Copy Code

Public Function GetArray () As PointF()

Return Value

An array of PointF objects containing all points in the collection.

See Also

PointCollection Members
PointCollection Class


MindFusion.Diagramming.PointCollection.GetAt Method

PointCollection.GetAt Method
[image]

Gets the point at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointF GetAt (
int index
)

Visual Basic [image] Copy Code

Public Function GetAt( _
index As Integer _
) As PointF

Parameters

index

The zero-based index of the point to retrieve.

Return Value

The PointF object at the specified index.

See Also

PointCollection Members
PointCollection Class


MindFusion.Diagramming.PointCollection.Insert Method

PointCollection.Insert Method
[image]

Inserts the specified point in the collection at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Insert (
int index,
PointF point
)

Visual Basic [image] Copy Code

Public Sub Insert( _
index As Integer, _
point As PointF _
)

Parameters

index
The zero-based index at which to insert the point.
point
The PointF object to add to the collection.

See Also

PointCollection Members
PointCollection Class


MindFusion.Diagramming.PointCollection.Remove Method

PointCollection.Remove Method
[image]

Removes the specified point from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Remove (
PointF point
)

Visual Basic [image] Copy Code

Public Sub Remove( _
point As PointF _
)

Parameters

point

The PointF object to remove.

See Also

PointCollection Members
PointCollection Class


MindFusion.Diagramming.PointCollection.Reverse Method

PointCollection.Reverse Method
[image]

Returns a copy of this collection with reversed order of elements.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointCollection Reverse ()

Visual Basic [image] Copy Code

Public Function Reverse () As PointCollection

Return Value

The reverse collection.

See Also

PointCollection Members
PointCollection Class


MindFusion.Diagramming.PointCollection.SetAt Method

PointCollection.SetAt Method
[image]

Sets the specified point at the specified position within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetAt (
int index,
PointF point
)

Visual Basic [image] Copy Code

Public Sub SetAt( _
index As Integer, _
point As PointF _
)

Parameters

index

The zero-based index of the point to set.

point

The PointF object to set at the specified position.

See Also

PointCollection Members
PointCollection Class


MindFusion.Diagramming.PointCollection Properties

PointCollection Properties
[image]

Public Properties

Name | Description
Item | Gets or sets the point at the specified position.

See Also

PointCollection Class


MindFusion.Diagramming.PointCollection.Item Property

PointCollection.Item Property
[image]

Gets or sets the point at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointF Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Property Item( _
index As Integer _
) As PointF

Parameters

index

The zero-based index of the point to set or retrieve.

Property Value

The PointF object at the specified index.

See Also

PointCollection Members
PointCollection Class


MindFusion.Diagramming.QuickRouter Class

QuickRouter Class
Remarks See Also
[image]

Implements a very fast link routing algorithm that uses a tree to represent the free and occupied regions in the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class QuickRouter : ILinkRouter

Visual Basic [image] Copy Code

Public Class QuickRouter
Implements ILinkRouter

Remarks

To use this class for link routing simply assign its instance to the LinkRouter property of the Diagram class.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.QuickRouter

See Also

QuickRouter Members


MindFusion.Diagramming.QuickRouter Members

QuickRouter Members
Constructors Properties Methods
[image]

Implements a very fast link routing algorithm that uses a tree to represent the free and occupied regions in the diagram.

The following tables list the members exposed by the QuickRouter type.

Public Constructors

Name | Description
QuickRouter | Overloaded.

Public Properties

Name | Description
Diagram | Gets or sets the diagram this router is associated with.
Granularity | Gets or sets the granularity of the obstacles map generated by QuickRouter.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.
UBendMaxLen | Gets or sets the maximum U-bend length.

Public Methods

Name | Description
Resume | Implements ILinkRouter.Resume.
RouteAllLinks | Routes all links in the diagram.
RouteLink | Implements ILinkRouter.RouteLink.
RouteLinks | Implements ILinkRouter.RouteLinks.
Suspend | Implements ILinkRouter.Suspend.

See Also

QuickRouter Class


MindFusion.Diagramming.QuickRouter Constructor

QuickRouter Constructor
[image]

Overload List

Name | Description
QuickRouter () | Initializes a new instance of the QuickRouter class.
QuickRouter (Diagram) | Initializes a new instance of the QuickRouter class.

See Also

QuickRouter Class


MindFusion.Diagramming.QuickRouter Constructor ()

QuickRouter Constructor ()
See Also
[image]

Initializes a new instance of the QuickRouter class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public QuickRouter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

QuickRouter Constructor Overload List
QuickRouter Class


MindFusion.Diagramming.QuickRouter Constructor (Diagram)

QuickRouter Constructor (Diagram)
See Also
[image]

Initializes a new instance of the QuickRouter class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public QuickRouter (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram this router will operate on.

See Also

QuickRouter Constructor Overload List
QuickRouter Class


MindFusion.Diagramming.QuickRouter Methods

QuickRouter Methods
[image]

Public Methods

Name | Description
Resume | Implements ILinkRouter.Resume.
RouteAllLinks | Routes all links in the diagram.
RouteLink | Implements ILinkRouter.RouteLink.
RouteLinks | Implements ILinkRouter.RouteLinks.
Suspend | Implements ILinkRouter.Suspend.

See Also

QuickRouter Class


MindFusion.Diagramming.QuickRouter.Resume Method

QuickRouter.Resume Method
[image]

Implements ILinkRouter.Resume.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Resume (
bool routeDeferredLinks
)

Visual Basic [image] Copy Code

Public Sub Resume( _
routeDeferredLinks As Boolean _
)

Parameters

routeDeferredLinks
true if the links should be routed, otherwise false.

See Also

QuickRouter Members
QuickRouter Class


MindFusion.Diagramming.QuickRouter.RouteAllLinks Method

QuickRouter.RouteAllLinks Method
[image]

Routes all links in the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RouteAllLinks ()

Visual Basic [image] Copy Code

Public Sub RouteAllLinks ()

See Also

QuickRouter Members
QuickRouter Class


MindFusion.Diagramming.QuickRouter.RouteLink Method

QuickRouter.RouteLink Method
[image]

Implements ILinkRouter.RouteLink.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool RouteLink (
DiagramLink link
)

Visual Basic [image] Copy Code

Public Overridable Function RouteLink ( _
link As DiagramLink _
) As Boolean

Parameters

link
The DiagramLink to route.

Return Value

true if a path has been found successfully, otherwise false.

See Also

QuickRouter Members
QuickRouter Class


MindFusion.Diagramming.QuickRouter.RouteLinks Method

QuickRouter.RouteLinks Method
[image]

Implements ILinkRouter.RouteLinks.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void RouteLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Public Overridable Sub RouteLinks ( _
links As DiagramLinkCollection _
)

Parameters

links
A list of DiagramLink objects that should be routed.

See Also

QuickRouter Members
QuickRouter Class


MindFusion.Diagramming.QuickRouter.Suspend Method

QuickRouter.Suspend Method
[image]

Implements ILinkRouter.Suspend.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Suspend ()

Visual Basic [image] Copy Code

Public Sub Suspend ()

See Also

QuickRouter Members
QuickRouter Class


MindFusion.Diagramming.QuickRouter Properties

QuickRouter Properties
[image]

Public Properties

Name | Description
Diagram | Gets or sets the diagram this router is associated with.
Granularity | Gets or sets the granularity of the obstacles map generated by QuickRouter.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.
UBendMaxLen | Gets or sets the maximum U-bend length.

See Also

QuickRouter Class


MindFusion.Diagramming.QuickRouter.Diagram Property

QuickRouter.Diagram Property
[image]

Gets or sets the diagram this router is associated with.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Diagram Diagram { get; set; }

Visual Basic [image] Copy Code

Public Property Diagram As Diagram

Property Value

See Also

QuickRouter Members
QuickRouter Class


MindFusion.Diagramming.QuickRouter.Granularity Property

QuickRouter.Granularity Property
[image]

Gets or sets the granularity of the obstacles map generated by QuickRouter.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Granularity Granularity { get; set; }

Visual Basic [image] Copy Code

Public Property Granularity As Granularity

Property Value

A member of the Granularity enumeration. The default value is CoarseGrained.

Remarks

A CoarseGrained obstacle map leads to faster path finding, however the found paths might be longer than necessary in a small percent of the cases. The coarse-grained map also takes slightly more time to build, so you might disable it if there are aren't many links in the diagram.

See Also

QuickRouter Members
QuickRouter Class


MindFusion.Diagramming.QuickRouter.TurnCost Property

QuickRouter.TurnCost Property
[image]

Gets or sets a value added to the total cost of a route if it makes a turn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float TurnCost { get; set; }

Visual Basic [image] Copy Code

Public Property TurnCost As Single

Property Value

See Also

QuickRouter Members
QuickRouter Class


MindFusion.Diagramming.QuickRouter.UBendMaxLen Property

QuickRouter.UBendMaxLen Property
[image]

Gets or sets the maximum U-bend length.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float UBendMaxLen { get; set; }

Visual Basic [image] Copy Code

Public Property UBendMaxLen As Single

Property Value

A float value specifying the maximum length of U-bends. The default is 30.

See Also

QuickRouter Members
QuickRouter Class


MindFusion.Diagramming.ReadOnlyCollection(T) Class

ReadOnlyCollection(T) Class
[image]

Represents a read-only wrapper of a collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ReadOnlyCollection<T> : ICollection, IEnumerable

Visual Basic [image] Copy Code

Public Class ReadOnlyCollection(Of T)
Implements ICollection, IEnumerable

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ReadOnlyCollection(T)
MindFusion.Diagramming.ReadOnlyDiagramItemCollection
MindFusion.Diagramming.ReadOnlyDiagramLinkCollection
MindFusion.Diagramming.ReadOnlyDiagramNodeCollection

See Also

ReadOnlyCollection(T) Members


MindFusion.Diagramming.ReadOnlyCollection(T) Members

ReadOnlyCollection(T) Members
Constructors Properties Methods
[image]

Represents a read-only wrapper of a collection.

The following tables list the members exposed by the ReadOnlyCollection(T) type.

Public Constructors

Name | Description
ReadOnlyCollection | Initializes a new instance of the ReadonlyCollection class.

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

Name | Description
CopyTo | Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array.
GetEnumerator | Returns an enumerator that can iterate through the collection.

See Also

ReadOnlyCollection(T) Class


MindFusion.Diagramming.ReadOnlyCollection(T) Constructor

ReadOnlyCollection(T) Constructor
[image]

Initializes a new instance of the ReadonlyCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ReadOnlyCollection<T> (
ICollection<T> innerCollection
)

Visual Basic [image] Copy Code

Public New (Of T) ( _
innerCollection As ICollection(Of T) _
)

Parameters

innerCollection

A .NET ICollection that represents the collection to wrap.

See Also

ReadOnlyCollection(T) Class


MindFusion.Diagramming.ReadOnlyCollection(T) Methods

ReadOnlyCollection(T) Methods
[image]

Public Methods

Name | Description
CopyTo | Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array.
GetEnumerator | Returns an enumerator that can iterate through the collection.

See Also

ReadOnlyCollection(T) Class


MindFusion.Diagramming.ReadOnlyCollection(T).CopyTo Method

ReadOnlyCollection(T).CopyTo Method
[image]

Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void CopyTo (
Array array,
int index
)

Visual Basic [image] Copy Code

Public Sub CopyTo( _
array As Array, _
index As Integer _
)

Parameters

array

The one-dimensional Array that is the destination of the elements copied from the current collection.

index

A 32-bit integer that represents the index in array at which copying begins.

See Also

ReadOnlyCollection(T) Members
ReadOnlyCollection(T) Class


MindFusion.Diagramming.ReadOnlyCollection(T).GetEnumerator Method

ReadOnlyCollection(T).GetEnumerator Method
[image]

Returns an enumerator that can iterate through the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IEnumerator GetEnumerator ()

Visual Basic [image] Copy Code

Public Function GetEnumerator () As IEnumerator

Return Value

An .NET IEnumerator for the collection.

See Also

ReadOnlyCollection(T) Members
ReadOnlyCollection(T) Class


MindFusion.Diagramming.ReadOnlyCollection(T) Properties

ReadOnlyCollection(T) Properties
[image]

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

ReadOnlyCollection(T) Class


MindFusion.Diagramming.ReadOnlyCollection(T).Count Property

ReadOnlyCollection(T).Count Property
[image]

Gets the number of elements contained in the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Count { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Count As Integer

Property Value

The number of elements actually contained in the collection.

See Also

ReadOnlyCollection(T) Members
ReadOnlyCollection(T) Class


MindFusion.Diagramming.ReadOnlyCollection(T).IsSynchronized Property

ReadOnlyCollection(T).IsSynchronized Property
[image]

Gets a value indicating whether the access to the collection is synchronized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsSynchronized { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsSynchronized As Boolean

Property Value

true if access to the collection is synchronized (thread safe); otherwise, false.

See Also

ReadOnlyCollection(T) Members
ReadOnlyCollection(T) Class


MindFusion.Diagramming.ReadOnlyCollection(T).SyncRoot Property

ReadOnlyCollection(T).SyncRoot Property
[image]

Gets an object that can be used to synchronize access to the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object SyncRoot { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SyncRoot As Object

Property Value

An object that can be used to synchronize access to the collection.

See Also

ReadOnlyCollection(T) Members
ReadOnlyCollection(T) Class


MindFusion.Diagramming.ReadOnlyDiagramItemCollection Class

ReadOnlyDiagramItemCollection Class
[image]

Represents a read-only collection of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ReadOnlyDiagramItemCollection : ReadOnlyCollection<DiagramItem>

Visual Basic [image] Copy Code

Public Class ReadOnlyDiagramItemCollection
Inherits ReadOnlyCollection(Of DiagramItem)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ReadOnlyCollection(DiagramItem)
MindFusion.Diagramming.ReadOnlyDiagramItemCollection

See Also

ReadOnlyDiagramItemCollection Members


MindFusion.Diagramming.ReadOnlyDiagramItemCollection Members

ReadOnlyDiagramItemCollection Members
Constructors Properties Methods
[image]

Represents a read-only collection of items.

The following tables list the members exposed by the ReadOnlyDiagramItemCollection type.

Public Constructors

Name | Description
ReadOnlyDiagramItemCollection | Initializes a new instance of the ReadOnlyDiagramItemCollection class.

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection. (Inherited from ReadOnlyCollection.)
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized. (Inherited from ReadOnlyCollection.)
Item | Gets the DiagramItem at the specified position.
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from ReadOnlyCollection.)

Public Methods

Name | Description
Contains | Checks whether the specified DiagramItem is contained within the collection.
CopyTo | Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.)
GetEnumerator | Returns an enumerator that can iterate through the collection. (Inherited from ReadOnlyCollection.)
IndexOf | Searches for the specified DiagramItem and returns the 0-based index of the first occurrence within the entire collection.

See Also

ReadOnlyDiagramItemCollection Class


MindFusion.Diagramming.ReadOnlyDiagramItemCollection Constructor

ReadOnlyDiagramItemCollection Constructor
[image]

Initializes a new instance of the ReadOnlyDiagramItemCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ReadOnlyDiagramItemCollection (
DiagramItemCollection innerCollection
)

Visual Basic [image] Copy Code

Public Sub ReadOnlyDiagramItemCollection ( _
innerCollection As DiagramItemCollection _
)

Parameters

innerCollection

A DiagramItemCollection object that represents the collection to wrap.

Remarks

A DiagramItemCollection object that represents the collection to wrap.

See Also

ReadOnlyDiagramItemCollection Class


MindFusion.Diagramming.ReadOnlyDiagramItemCollection Methods

ReadOnlyDiagramItemCollection Methods
[image]

Public Methods

Name | Description
Contains | Checks whether the specified DiagramItem is contained within the collection.
CopyTo | Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.)
GetEnumerator | Returns an enumerator that can iterate through the collection. (Inherited from ReadOnlyCollection.)
IndexOf | Searches for the specified DiagramItem and returns the 0-based index of the first occurrence within the entire collection.

See Also

ReadOnlyDiagramItemCollection Class


MindFusion.Diagramming.ReadOnlyDiagramItemCollection.Contains Method

ReadOnlyDiagramItemCollection.Contains Method
[image]

Checks whether the specified DiagramItem is contained within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Contains (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function Contains ( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem to search for in the collection.

Return Value

true if the specified item is contained in the collection; otherwise, false.

See Also

ReadOnlyDiagramItemCollection Members
ReadOnlyDiagramItemCollection Class


MindFusion.Diagramming.ReadOnlyDiagramItemCollection.IndexOf Method

ReadOnlyDiagramItemCollection.IndexOf Method
[image]

Searches for the specified DiagramItem and returns the 0-based index of the first occurrence within the entire collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int IndexOf (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function IndexOf ( _
item As DiagramItem _
) As Integer

Parameters

item

The DiagramItem whose index to retrieve from the collection.

Return Value

The zero-based index of the specified item within the collection; or -1 if the item is not found.

See Also

ReadOnlyDiagramItemCollection Members
ReadOnlyDiagramItemCollection Class


MindFusion.Diagramming.ReadOnlyDiagramItemCollection Properties

ReadOnlyDiagramItemCollection Properties
[image]

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection. (Inherited from ReadOnlyCollection.)
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized. (Inherited from ReadOnlyCollection.)
Item | Gets the DiagramItem at the specified position.
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from ReadOnlyCollection.)

See Also

ReadOnlyDiagramItemCollection Class


MindFusion.Diagramming.ReadOnlyDiagramItemCollection.Item Property

ReadOnlyDiagramItemCollection.Item Property
[image]

Gets the DiagramItem at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem Item [
int index
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item ( _
index As Integer _
) As DiagramItem

Parameters

index

The zero-based index of the item to get.

Property Value

An instance of the DiagramItem class that represents the item at the specified position.

See Also

ReadOnlyDiagramItemCollection Members
ReadOnlyDiagramItemCollection Class


MindFusion.Diagramming.ReadOnlyDiagramLinkCollection Class

ReadOnlyDiagramLinkCollection Class
[image]

Represents a read-only collection of links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ReadOnlyDiagramLinkCollection : ReadOnlyCollection<DiagramLink>

Visual Basic [image] Copy Code

Public Class ReadOnlyDiagramLinkCollection
Inherits ReadOnlyCollection(Of DiagramLink)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ReadOnlyCollection(DiagramLink)
MindFusion.Diagramming.ReadOnlyDiagramLinkCollection

See Also

ReadOnlyDiagramLinkCollection Members


MindFusion.Diagramming.ReadOnlyDiagramLinkCollection Members

ReadOnlyDiagramLinkCollection Members
Constructors Properties Methods
[image]

Represents a read-only collection of links.

The following tables list the members exposed by the ReadOnlyDiagramLinkCollection type.

Public Constructors

Name | Description
ReadOnlyDiagramLinkCollection | Initializes a new instance of the ReadOnlyDiagramLinkCollection class.

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection. (Inherited from ReadOnlyCollection.)
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized. (Inherited from ReadOnlyCollection.)
Item | Gets the DiagramLink at the specified position.
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from ReadOnlyCollection.)

Public Methods

Name | Description
Contains | Checks whether the specified DiagramLink is contained within the collection.
CopyTo | Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.)
GetEnumerator | Returns an enumerator that can iterate through the collection. (Inherited from ReadOnlyCollection.)
IndexOf | Searches for the specified DiagramLink and returns the 0-based index of the first occurrence within the entire collection.

See Also

ReadOnlyDiagramLinkCollection Class


MindFusion.Diagramming.ReadOnlyDiagramLinkCollection Constructor

ReadOnlyDiagramLinkCollection Constructor
[image]

Initializes a new instance of the ReadOnlyDiagramLinkCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ReadOnlyDiagramLinkCollection (
DiagramLinkCollection innerCollection
)

Visual Basic [image] Copy Code

Public Sub ReadOnlyDiagramLinkCollection ( _
innerCollection As DiagramLinkCollection _
)

Parameters

innerCollection

A DiagramLinkCollection object that represents the collection to wrap.

See Also

ReadOnlyDiagramLinkCollection Class


MindFusion.Diagramming.ReadOnlyDiagramLinkCollection Methods

ReadOnlyDiagramLinkCollection Methods
[image]

Public Methods

Name | Description
Contains | Checks whether the specified DiagramLink is contained within the collection.
CopyTo | Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.)
GetEnumerator | Returns an enumerator that can iterate through the collection. (Inherited from ReadOnlyCollection.)
IndexOf | Searches for the specified DiagramLink and returns the 0-based index of the first occurrence within the entire collection.

See Also

ReadOnlyDiagramLinkCollection Class


MindFusion.Diagramming.ReadOnlyDiagramLinkCollection.Contains Method

ReadOnlyDiagramLinkCollection.Contains Method
[image]

Checks whether the specified DiagramLink is contained within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Contains (
DiagramLink link
)

Visual Basic [image] Copy Code

Public Function Contains ( _
link As DiagramLink _
) As Boolean

Parameters

link

The DiagramLink to search for in the collection.

Return Value

true if the specified link is contained in the collection; otherwise, false.

See Also

ReadOnlyDiagramLinkCollection Members
ReadOnlyDiagramLinkCollection Class


MindFusion.Diagramming.ReadOnlyDiagramLinkCollection.IndexOf Method

ReadOnlyDiagramLinkCollection.IndexOf Method
[image]

Searches for the specified DiagramLink and returns the 0-based index of the first occurrence within the entire collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int IndexOf (
DiagramLink link
)

Visual Basic [image] Copy Code

Public Function IndexOf ( _
link As DiagramLink _
) As Integer

Parameters

link

The DiagramLink whose index to retrieve from the collection.

Return Value

The zero-based index of the specified link within the collection; or -1 if the link is not found.

See Also

ReadOnlyDiagramLinkCollection Members
ReadOnlyDiagramLinkCollection Class


MindFusion.Diagramming.ReadOnlyDiagramLinkCollection Properties

ReadOnlyDiagramLinkCollection Properties
[image]

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection. (Inherited from ReadOnlyCollection.)
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized. (Inherited from ReadOnlyCollection.)
Item | Gets the DiagramLink at the specified position.
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from ReadOnlyCollection.)

See Also

ReadOnlyDiagramLinkCollection Class


MindFusion.Diagramming.ReadOnlyDiagramLinkCollection.Item Property

ReadOnlyDiagramLinkCollection.Item Property
[image]

Gets the DiagramLink at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink Item [
int index
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item ( _
index As Integer _
) As DiagramLink

Parameters

index

The zero-based index of the link to get.

Property Value

An instance of the DiagramLink class that represents the link at the specified position.

See Also

ReadOnlyDiagramLinkCollection Members
ReadOnlyDiagramLinkCollection Class


MindFusion.Diagramming.ReadOnlyDiagramNodeCollection Class

ReadOnlyDiagramNodeCollection Class
[image]

Represents a read-only collection of nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ReadOnlyDiagramNodeCollection : ReadOnlyCollection<DiagramNode>

Visual Basic [image] Copy Code

Public Class ReadOnlyDiagramNodeCollection
Inherits ReadOnlyCollection(Of DiagramNode)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ReadOnlyCollection(DiagramNode)
MindFusion.Diagramming.ReadOnlyDiagramNodeCollection

See Also

ReadOnlyDiagramNodeCollection Members


MindFusion.Diagramming.ReadOnlyDiagramNodeCollection Members

ReadOnlyDiagramNodeCollection Members
Constructors Properties Methods
[image]

Represents a read-only collection of nodes.

The following tables list the members exposed by the ReadOnlyDiagramNodeCollection type.

Public Constructors

Name | Description
ReadOnlyDiagramNodeCollection | Initializes a new instance of the ReadOnlyDiagramNodeCollection class.

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection. (Inherited from ReadOnlyCollection.)
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized. (Inherited from ReadOnlyCollection.)
Item | Gets the DiagramNode at the specified position.
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from ReadOnlyCollection.)

Public Methods

Name | Description
Contains | Checks whether the specified DiagramNode is contained within the collection.
CopyTo | Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.)
GetEnumerator | Returns an enumerator that can iterate through the collection. (Inherited from ReadOnlyCollection.)
IndexOf | Searches for the specified DiagramNode and returns the 0-based index of the first occurrence within the entire collection.

See Also

ReadOnlyDiagramNodeCollection Class


MindFusion.Diagramming.ReadOnlyDiagramNodeCollection Constructor

ReadOnlyDiagramNodeCollection Constructor
[image]

Initializes a new instance of the ReadOnlyDiagramNodeCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ReadOnlyDiagramNodeCollection (
DiagramNodeCollection innerCollection
)

Visual Basic [image] Copy Code

Public Sub ReadOnlyDiagramNodeCollection ( _
innerCollection As DiagramNodeCollection _
)

Parameters

innerCollection

A DiagramNodeCollection object that represents the collection to wrap.

See Also

ReadOnlyDiagramNodeCollection Class


MindFusion.Diagramming.ReadOnlyDiagramNodeCollection Methods

ReadOnlyDiagramNodeCollection Methods
[image]

Public Methods

Name | Description
Contains | Checks whether the specified DiagramNode is contained within the collection.
CopyTo | Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.)
GetEnumerator | Returns an enumerator that can iterate through the collection. (Inherited from ReadOnlyCollection.)
IndexOf | Searches for the specified DiagramNode and returns the 0-based index of the first occurrence within the entire collection.

See Also

ReadOnlyDiagramNodeCollection Class


MindFusion.Diagramming.ReadOnlyDiagramNodeCollection.Contains Method

ReadOnlyDiagramNodeCollection.Contains Method
[image]

Checks whether the specified DiagramNode is contained within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Contains (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Function Contains ( _
node As DiagramNode _
) As Boolean

Parameters

node

The DiagramNode to search for in the collection.

Return Value

true if the specified node is contained in the collection; otherwise, false.

See Also

ReadOnlyDiagramNodeCollection Members
ReadOnlyDiagramNodeCollection Class


MindFusion.Diagramming.ReadOnlyDiagramNodeCollection.IndexOf Method

ReadOnlyDiagramNodeCollection.IndexOf Method
[image]

Searches for the specified DiagramNode and returns the 0-based index of the first occurrence within the entire collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int IndexOf (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Function IndexOf ( _
node As DiagramNode _
) As Integer

Parameters

node

The DiagramNode whose index to retrieve from the collection.

Return Value

The zero-based index of the specified node within the collection; or -1 if the node is not found.

See Also

ReadOnlyDiagramNodeCollection Members
ReadOnlyDiagramNodeCollection Class


MindFusion.Diagramming.ReadOnlyDiagramNodeCollection Properties

ReadOnlyDiagramNodeCollection Properties
[image]

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection. (Inherited from ReadOnlyCollection.)
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized. (Inherited from ReadOnlyCollection.)
Item | Gets the DiagramNode at the specified position.
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from ReadOnlyCollection.)

See Also

ReadOnlyDiagramNodeCollection Class


MindFusion.Diagramming.ReadOnlyDiagramNodeCollection.Item Property

ReadOnlyDiagramNodeCollection.Item Property
[image]

Gets the DiagramNode at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Item [
int index
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item ( _
index As Integer _
) As DiagramNode

Parameters

index

The zero-based index of the node to get.

Property Value

An instance of the DiagramNode class that represents the node at the specified position.

See Also

ReadOnlyDiagramNodeCollection Members
ReadOnlyDiagramNodeCollection Class


MindFusion.Diagramming.RectangleFConverter Class

RectangleFConverter Class
[image]

Converts from RectangleF to other data types.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class RectangleFConverter : ExpandableObjectConverter

Visual Basic [image] Copy Code

Public Class RectangleFConverter
Inherits ExpandableObjectConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
System.ComponentModel.ExpandableObjectConverter
MindFusion.Diagramming.RectangleFConverter

See Also

RectangleFConverter Members


MindFusion.Diagramming.RectangleFConverter Members

RectangleFConverter Members
Constructors Methods
[image]

Converts from RectangleF to other data types.

The following tables list the members exposed by the RectangleFConverter type.

Public Constructors

Name | Description
RectangleFConverter | Initializes a new instance of the RectangleFConverter class.

Public Methods

Name | Description
CanConvertFrom | ExpandableObjectConverter.CanConvertFrom override.
CanConvertTo | ExpandableObjectConverter.CanConvertTo override.
ConvertFrom | ExpandableObjectConverter.ConvertFrom override.
ConvertTo | ExpandableObjectConverter.ConvertTo override.
CreateInstance | ExpandableObjectConverter.CreateInstance override.
GetCreateInstanceSupported | ExpandableObjectConverter.GetCreateInstanceSupported override.
GetProperties | ExpandableObjectConverter.GetProperties override.
GetPropertiesSupported | ExpandableObjectConverter.GetPropertiesSupported override.

See Also

RectangleFConverter Class


MindFusion.Diagramming.RectangleFConverter Constructor

RectangleFConverter Constructor
[image]

Initializes a new instance of the RectangleFConverter class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleFConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RectangleFConverter Class


MindFusion.Diagramming.RectangleFConverter Methods

RectangleFConverter Methods
[image]

Public Methods

Name | Description
CanConvertFrom | ExpandableObjectConverter.CanConvertFrom override.
CanConvertTo | ExpandableObjectConverter.CanConvertTo override.
ConvertFrom | ExpandableObjectConverter.ConvertFrom override.
ConvertTo | ExpandableObjectConverter.ConvertTo override.
CreateInstance | ExpandableObjectConverter.CreateInstance override.
GetCreateInstanceSupported | ExpandableObjectConverter.GetCreateInstanceSupported override.
GetProperties | ExpandableObjectConverter.GetProperties override.
GetPropertiesSupported | ExpandableObjectConverter.GetPropertiesSupported override.

See Also

RectangleFConverter Class


MindFusion.Diagramming.RectangleFConverter.CanConvertFrom Method

RectangleFConverter.CanConvertFrom Method
[image]

ExpandableObjectConverter.CanConvertFrom override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool CanConvertFrom (
ITypeDescriptorContext context,
Type sourceType
)

Visual Basic [image] Copy Code

Public Overrides Function CanConvertFrom( _
context As ITypeDescriptorContext, _
sourceType As Type _
) As Boolean

Parameters

context

sourceType

Return Value

See Also

RectangleFConverter Members
RectangleFConverter Class


MindFusion.Diagramming.RectangleFConverter.CanConvertTo Method

RectangleFConverter.CanConvertTo Method
[image]

ExpandableObjectConverter.CanConvertTo override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool CanConvertTo (
ITypeDescriptorContext context,
Type destinationType
)

Visual Basic [image] Copy Code

Public Overrides Function CanConvertTo( _
context As ITypeDescriptorContext, _
destinationType As Type _
) As Boolean

Parameters

context

destinationType

Return Value

See Also

RectangleFConverter Members
RectangleFConverter Class


MindFusion.Diagramming.RectangleFConverter.ConvertFrom Method

RectangleFConverter.ConvertFrom Method
[image]

ExpandableObjectConverter.ConvertFrom override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Object ConvertFrom (
ITypeDescriptorContext context,
CultureInfo culture,
Object value
)

Visual Basic [image] Copy Code

Public Overrides Function ConvertFrom( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object _
) As Object

Parameters

context

culture

value

Return Value

See Also

RectangleFConverter Members
RectangleFConverter Class


MindFusion.Diagramming.RectangleFConverter.ConvertTo Method

RectangleFConverter.ConvertTo Method
[image]

ExpandableObjectConverter.ConvertTo override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Object ConvertTo (
ITypeDescriptorContext context,
CultureInfo culture,
Object value,
Type destinationType
)

Visual Basic [image] Copy Code

Public Overrides Function ConvertTo( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object, _
destinationType As Type _
) As Object

Parameters

context

culture

value

destinationType

Return Value

See Also

RectangleFConverter Members
RectangleFConverter Class


MindFusion.Diagramming.RectangleFConverter.CreateInstance Method

RectangleFConverter.CreateInstance Method
[image]

ExpandableObjectConverter.CreateInstance override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Object CreateInstance (
ITypeDescriptorContext context,
IDictionary propertyValues
)

Visual Basic [image] Copy Code

Public Overrides Function CreateInstance( _
context As ITypeDescriptorContext, _
propertyValues As IDictionary _
) As Object

Parameters

context

propertyValues

Return Value

See Also

RectangleFConverter Members
RectangleFConverter Class


MindFusion.Diagramming.RectangleFConverter.GetCreateInstanceSupported Method

RectangleFConverter.GetCreateInstanceSupported Method
[image]

ExpandableObjectConverter.GetCreateInstanceSupported override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool GetCreateInstanceSupported (
ITypeDescriptorContext context
)

Visual Basic [image] Copy Code

Public Overrides Function GetCreateInstanceSupported( _
context As ITypeDescriptorContext _
) As Boolean

Parameters

context

Return Value

See Also

RectangleFConverter Members
RectangleFConverter Class


MindFusion.Diagramming.RectangleFConverter.GetProperties Method

RectangleFConverter.GetProperties Method
[image]

ExpandableObjectConverter.GetProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override PropertyDescriptorCollection GetProperties (
ITypeDescriptorContext context,
Object value,
Attribute[] attributes
)

Visual Basic [image] Copy Code

Public Overrides Function GetProperties( _
context As ITypeDescriptorContext, _
value As Object, _
attributes() As Attribute _
) As PropertyDescriptorCollection

Parameters

context

value

attributes

Return Value

See Also

RectangleFConverter Members
RectangleFConverter Class


MindFusion.Diagramming.RectangleFConverter.GetPropertiesSupported Method

RectangleFConverter.GetPropertiesSupported Method
[image]

ExpandableObjectConverter.GetPropertiesSupported override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool GetPropertiesSupported (
ITypeDescriptorContext context
)

Visual Basic [image] Copy Code

Public Overrides Function GetPropertiesSupported( _
context As ITypeDescriptorContext _
) As Boolean

Parameters

context

Return Value

See Also

RectangleFConverter Members
RectangleFConverter Class


MindFusion.Diagramming.Relationship Enumeration

Relationship Enumeration
[image]

Specifies the type of relationship between two tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum Relationship

Visual Basic [image] Copy Code

Public Enum Relationship

Members

Member name | Description
OneToMany | The relationship is of type 1:M, that is, one to many.
ManyToOne | The relationship is of type M:1, that is, many to one.

Remarks

Use the enumeration values when drawing database diagrams. It helps you specify how database tables' fields are related.

See Also

AddRelation Method


MindFusion.Diagramming.RelativeToLink Enumeration

RelativeToLink Enumeration
[image]

Specifies how the link labels are positioned.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum RelativeToLink

Visual Basic [image] Copy Code

Public Enum RelativeToLink

Members

Member name | Description
Segment | Indicates that the link labels are positioned relative to a specified segment.
ControlPoint | Indicates that the link labels are positioned relative to a specified control point.
LinkLength | Indicates that the link labels are positioned relative to the link.

See Also

LinkLabel.RelativeTo Property


MindFusion.Diagramming.RenderOptions Class

RenderOptions Class
[image]

Provides properties that allow customization of various aspects of printing and print-preview.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class RenderOptions

Visual Basic [image] Copy Code

Public Class RenderOptions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.RenderOptions

See Also

RenderOptions Members


MindFusion.Diagramming.RenderOptions Members

RenderOptions Members
Constructors Properties
[image]

Provides properties that allow customization of various aspects of printing and print-preview.

The following tables list the members exposed by the RenderOptions type.

Public Constructors

Name | Description
RenderOptions | Initializes a new instance of the RenderOptions class.

Public Properties

Name | Description
CatchGdiPlusExceptions | Specifies whether to catch GDI+ exceptions.
EnableAnchors | Gets or sets a value indicating whether the printing of anchor point marks is enabled.
EnableBackground | Gets or sets a value indicating whether the printing of the background color is enabled.
EnableBackgroundImage | Gets or sets a value indicating whether the printing of the background image is enabled.
EnableEffects | Enables or disables special effects, such as emboss.
EnableGrid | Gets or sets a value indicating whether the alignment grid is rendered.
EnableImages | Gets or sets a value indicating whether the printing of images that are displayed in nodes is enabled.
EnableInterior | Gets or sets a value indicating whether the printing of node interiors is enabled.
EnableShadows | Gets or sets a value indicating whether the printing of the shadows of diagram items is enabled.
EnableText | Gets or sets a value indicating whether the printing of the text of diagram items is enabled.
HyperLinkStyle | Specifies how various export components should treat the HyperLink property of items.
HyperLinkTarget | Specify the value of the target attribute generated by various export components for the HyperLink property of items.
InternalMsg | For internal use.
MeasureUnit | Specifies the diagram's unit of measure.
PaintControls | Gets or sets a value indicating whether to execute custom painting code for ControlNode items when printing.
RenderTarget | Gets or sets the rendering target.
Scale | Gets or sets the scale of the print output relatively to the original on-screen size of the diagram.
ScrollX | Gets or sets the document's X scroll position.
ScrollY | Gets or sets the document's Y scroll position.
TargetView | Gets or sets the object that currently displays the Diagram.
VisibleRect | Specifies which part of the diagram is currently visible.

See Also

RenderOptions Class


MindFusion.Diagramming.RenderOptions Constructor

RenderOptions Constructor
[image]

Initializes a new instance of the RenderOptions class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RenderOptions ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RenderOptions Class


MindFusion.Diagramming.RenderOptions Properties

RenderOptions Properties
[image]

Public Properties

Name | Description
CatchGdiPlusExceptions | Specifies whether to catch GDI+ exceptions.
EnableAnchors | Gets or sets a value indicating whether the printing of anchor point marks is enabled.
EnableBackground | Gets or sets a value indicating whether the printing of the background color is enabled.
EnableBackgroundImage | Gets or sets a value indicating whether the printing of the background image is enabled.
EnableEffects | Enables or disables special effects, such as emboss.
EnableGrid | Gets or sets a value indicating whether the alignment grid is rendered.
EnableImages | Gets or sets a value indicating whether the printing of images that are displayed in nodes is enabled.
EnableInterior | Gets or sets a value indicating whether the printing of node interiors is enabled.
EnableShadows | Gets or sets a value indicating whether the printing of the shadows of diagram items is enabled.
EnableText | Gets or sets a value indicating whether the printing of the text of diagram items is enabled.
HyperLinkStyle | Specifies how various export components should treat the HyperLink property of items.
HyperLinkTarget | Specify the value of the target attribute generated by various export components for the HyperLink property of items.
InternalMsg | For internal use.
MeasureUnit | Specifies the diagram's unit of measure.
PaintControls | Gets or sets a value indicating whether to execute custom painting code for ControlNode items when printing.
RenderTarget | Gets or sets the rendering target.
Scale | Gets or sets the scale of the print output relatively to the original on-screen size of the diagram.
ScrollX | Gets or sets the document's X scroll position.
ScrollY | Gets or sets the document's Y scroll position.
TargetView | Gets or sets the object that currently displays the Diagram.
VisibleRect | Specifies which part of the diagram is currently visible.

See Also

RenderOptions Class


MindFusion.Diagramming.RenderOptions.CatchGdiPlusExceptions Property

RenderOptions.CatchGdiPlusExceptions Property
[image]

Specifies whether to catch GDI+ exceptions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool CatchGdiPlusExceptions { get; set; }

Visual Basic [image] Copy Code

Public Property CatchGdiPlusExceptions As Boolean

Property Value

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.EnableAnchors Property

RenderOptions.EnableAnchors Property
[image]

Gets or sets a value indicating whether the printing of anchor point marks is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableAnchors { get; set; }

Visual Basic [image] Copy Code

Public Property EnableAnchors As Boolean

Property Value

true if anchor point marks should be printed; otherwise, false. The default is false.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.EnableBackground Property

RenderOptions.EnableBackground Property
[image]

Gets or sets a value indicating whether the printing of the background color is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableBackground { get; set; }

Visual Basic [image] Copy Code

Public Property EnableBackground As Boolean

Property Value

true if the diagram background should be printed; otherwise, false. The default is false.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.EnableBackgroundImage Property

RenderOptions.EnableBackgroundImage Property
[image]

Gets or sets a value indicating whether the printing of the background image is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableBackgroundImage { get; set; }

Visual Basic [image] Copy Code

Public Property EnableBackgroundImage As Boolean

Property Value

true if the background image should be printed; otherwise, false. The default is false.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.EnableEffects Property

RenderOptions.EnableEffects Property
[image]

Enables or disables special effects, such as emboss.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableEffects { get; set; }

Visual Basic [image] Copy Code

Public Property EnableEffects As Boolean

Property Value

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.EnableGrid Property

RenderOptions.EnableGrid Property
[image]

Gets or sets a value indicating whether the alignment grid is rendered.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableGrid { get; set; }

Visual Basic [image] Copy Code

Public Property EnableGrid As Boolean

Property Value

true to render the alignment grid, if visible; otherwise, false.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.EnableImages Property

RenderOptions.EnableImages Property
[image]

Gets or sets a value indicating whether the printing of images that are displayed in nodes is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableImages { get; set; }

Visual Basic [image] Copy Code

Public Property EnableImages As Boolean

Property Value

true to print node images; otherwise, false.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.EnableInterior Property

RenderOptions.EnableInterior Property
[image]

Gets or sets a value indicating whether the printing of node interiors is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableInterior { get; set; }

Visual Basic [image] Copy Code

Public Property EnableInterior As Boolean

Property Value

true to print node interiors; otherwise, false.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.EnableShadows Property

RenderOptions.EnableShadows Property
[image]

Gets or sets a value indicating whether the printing of the shadows of diagram items is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableShadows { get; set; }

Visual Basic [image] Copy Code

Public Property EnableShadows As Boolean

Property Value

true to print item shadows; otherwise, false.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.EnableText Property

RenderOptions.EnableText Property
[image]

Gets or sets a value indicating whether the printing of the text of diagram items is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableText { get; set; }

Visual Basic [image] Copy Code

Public Property EnableText As Boolean

Property Value

true to print item texts; otherwise, false.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.HyperLinkStyle Property

RenderOptions.HyperLinkStyle Property
[image]

Specifies how various export components should treat the HyperLink property of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HyperLinkStyle HyperLinkStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HyperLinkStyle As HyperLinkStyle

Property Value

A member of the HyperLinkStyle enumeration.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.HyperLinkTarget Property

RenderOptions.HyperLinkTarget Property
[image]

Specify the value of the target attribute generated by various export components for the HyperLink property of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string HyperLinkTarget { get; set; }

Visual Basic [image] Copy Code

Public Property HyperLinkTarget As String

Property Value

The default value is "_self".

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.InternalMsg Property

RenderOptions.InternalMsg Property
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string InternalMsg { get; set; }

Visual Basic [image] Copy Code

Public Shared Property InternalMsg As String

Property Value

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.MeasureUnit Property

RenderOptions.MeasureUnit Property
[image]

Specifies the diagram's unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MeasureUnit MeasureUnit { get; set; }

Visual Basic [image] Copy Code

Public Property MeasureUnit As MeasureUnit

Property Value

An instance of the MeasureUnit class specifying the diagram's unit of measure.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.PaintControls Property

RenderOptions.PaintControls Property
[image]

Gets or sets a value indicating whether to execute custom painting code for ControlNode items when printing.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool PaintControls { get; set; }

Visual Basic [image] Copy Code

Public Property PaintControls As Boolean

Property Value

true to raise the appropriate event when printing controls; otherwise, false.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.RenderTarget Property

RenderOptions.RenderTarget Property
[image]

Gets or sets the rendering target.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RenderTarget RenderTarget { get; set; }

Visual Basic [image] Copy Code

Public Property RenderTarget As RenderTarget

Property Value

A value from the RenderTarget enumeration specifying whether rendering is done on the screen or on a printer.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.Scale Property

RenderOptions.Scale Property
[image]

Gets or sets the scale of the print output relatively to the original on-screen size of the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Scale { get; set; }

Visual Basic [image] Copy Code

Public Property Scale As Single

Property Value

A float value specifying the scale of the print output as percentage of original size.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.ScrollX Property

RenderOptions.ScrollX Property
[image]

Gets or sets the document's X scroll position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float ScrollX { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollX As Single

Property Value

A float value specifying the X scroll position.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.ScrollY Property

RenderOptions.ScrollY Property
[image]

Gets or sets the document's Y scroll position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float ScrollY { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollY As Single

Property Value

A float value specifying the Y scroll position.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.TargetView Property

RenderOptions.TargetView Property
[image]

Gets or sets the object that currently displays the Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object TargetView { get; set; }

Visual Basic [image] Copy Code

Public Property TargetView As Object

Property Value

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.VisibleRect Property

RenderOptions.VisibleRect Property
[image]

Specifies which part of the diagram is currently visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF VisibleRect { get; set; }

Visual Basic [image] Copy Code

Public Property VisibleRect As RectangleF

Property Value

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderTarget Enumeration

RenderTarget Enumeration
[image]

Specifies where the diagram is being rendered.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum RenderTarget

Visual Basic [image] Copy Code

Public Enum RenderTarget

Members

Member name | Description
Display | The diagram is rendered on the screen.
Printer | The diagram is rendered on a printer.

See Also


MindFusion.Diagramming.RepaintEventArgs Class

RepaintEventArgs Class
[image]

Specifies the coordinates of the area that should be repainted by views when the Repaint event is raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class RepaintEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class RepaintEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.RepaintEventArgs

See Also

RepaintEventArgs Members


MindFusion.Diagramming.RepaintEventArgs Members

RepaintEventArgs Members
Constructors Properties
[image]

Specifies the coordinates of the area that should be repainted by views when the Repaint event is raised.

The following tables list the members exposed by the RepaintEventArgs type.

Public Constructors

Name | Description
RepaintEventArgs | Overloaded. Initializes a new instance of the RepaintEventArgs class.

Public Properties

Name | Description
InvalidRect | Gets the rectangular area in the diagram document that should be repainted.
RedrawCacheImage | Gets a value indicating whether the back-buffer cache image should be repainted as well.
SourceView | Gets the view object that raised the event.

See Also

RepaintEventArgs Class


MindFusion.Diagramming.RepaintEventArgs Constructor

RepaintEventArgs Constructor
[image]

Initializes a new instance of the RepaintEventArgs class.

Overload List

Name | Description
RepaintEventArgs (RectangleF) | Initializes a new instance of the RepaintEventArgs class.
RepaintEventArgs (RectangleF, Boolean) | Initializes a new instance of the RepaintEventArgs class.
RepaintEventArgs (RectangleF, Object) | Initializes a new instance of the RepaintEventArgs class.

See Also

RepaintEventArgs Class


MindFusion.Diagramming.RepaintEventArgs Constructor (RectangleF)

RepaintEventArgs Constructor (RectangleF)
See Also
[image]

Initializes a new instance of the RepaintEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RepaintEventArgs (
RectangleF invalidRect
)

Visual Basic [image] Copy Code

Public New ( _
invalidRect As RectangleF _
)

Parameters

invalidRect

A RectangleF object representing the rectangle that should be repainted.

See Also

RepaintEventArgs Constructor Overload List
RepaintEventArgs Class


MindFusion.Diagramming.RepaintEventArgs Constructor (RectangleF, Boolean)

RepaintEventArgs Constructor (RectangleF, Boolean)
See Also
[image]

Initializes a new instance of the RepaintEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RepaintEventArgs (
RectangleF invalidRect,
bool redrawCacheImage
)

Visual Basic [image] Copy Code

Public New ( _
invalidRect As RectangleF, _
redrawCacheImage As Boolean _
)

Parameters

invalidRect

A RectangleF object representing the rectangle that should be repainted.

redrawCacheImage

A boolean value specifying whether the diagram cache image used during modification should be re-created.

See Also

RepaintEventArgs Constructor Overload List
RepaintEventArgs Class


MindFusion.Diagramming.RepaintEventArgs Constructor (RectangleF, Object)

RepaintEventArgs Constructor (RectangleF, Object)
See Also
[image]

Initializes a new instance of the RepaintEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RepaintEventArgs (
RectangleF invalidRect,
Object sourceView
)

Visual Basic [image] Copy Code

Public New ( _
invalidRect As RectangleF, _
sourceView As Object _
)

Parameters

invalidRect

A RectangleF object representing the rectangle that should be repainted.

sourceView

The view object that raised the event.

See Also

RepaintEventArgs Constructor Overload List
RepaintEventArgs Class


MindFusion.Diagramming.RepaintEventArgs Properties

RepaintEventArgs Properties
[image]

Public Properties

Name | Description
InvalidRect | Gets the rectangular area in the diagram document that should be repainted.
RedrawCacheImage | Gets a value indicating whether the back-buffer cache image should be repainted as well.
SourceView | Gets the view object that raised the event.

See Also

RepaintEventArgs Class


MindFusion.Diagramming.RepaintEventArgs.InvalidRect Property

RepaintEventArgs.InvalidRect Property
[image]

Gets the rectangular area in the diagram document that should be repainted.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF InvalidRect { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property InvalidRect As RectangleF

Property Value

A RectangleF instance specifying the invalid rectangle. The value of RectangleF.Empty indicates that the whole view should be repainted.

See Also

RepaintEventArgs Members
RepaintEventArgs Class


MindFusion.Diagramming.RepaintEventArgs.RedrawCacheImage Property

RepaintEventArgs.RedrawCacheImage Property
[image]

Gets a value indicating whether the back-buffer cache image should be repainted as well.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RedrawCacheImage { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RedrawCacheImage As Boolean

Property Value

true to redraw the back-buffer image; otherwise, false.

See Also

RepaintEventArgs Members
RepaintEventArgs Class


MindFusion.Diagramming.RepaintEventArgs.SourceView Property

RepaintEventArgs.SourceView Property
[image]

Gets the view object that raised the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object SourceView { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SourceView As Object

Property Value

An object identifying the view that raised the event.

See Also

RepaintEventArgs Members
RepaintEventArgs Class


MindFusion.Diagramming.RerouteLinks Enumeration

RerouteLinks Enumeration
[image]

Provides values indicating in what circumstances links must be rerouted automatically.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum RerouteLinks

Visual Basic [image] Copy Code

Public Enum RerouteLinks

Members

Member name | Description
Never | Do not reroute links automatically.
WhenModified | Reroute a link if its end points are moved around.
WhenIntersectNode | Reroute a link if it intersects a node.
WhileCreating | Route new links while users draw them. This flag can be combined with any of the previous two flags.
WhileModifying | Route links while the user modifies them or drags their incident nodes.

Remarks

These values can be assigned to the TriggerRerouting property of RoutingOptions.

See Also


MindFusion.Diagramming.RestrictToBounds Enumeration

RestrictToBounds Enumeration
[image]

Specifies a restriction of the position of items relatively to the diagram bounds.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum RestrictToBounds

Visual Basic [image] Copy Code

Public Enum RestrictToBounds

Members

Member name | Description
NoRestriction | No restriction on the position of items.
Intersection | Items must be located at least partially inside the document extents.
InsideOnly | Items must be located entirely inside the document extents.

Remarks

This enumeration specifies the possible values of the RestrictItemsToBounds property.

See Also

RestrictItemsToBounds Property


MindFusion.Diagramming.RoundRectangleTemplate Class

RoundRectangleTemplate Class
Remarks See Also
[image]

Represents an ElementTemplate that draws round rectangle. This class ensures that the round corners do not change during resizing which is visually better. The drawback is that the radius appears to be specified in DiagramView Measure units and therefore a given shape instance will look bad when the measure unit is not the one for which the shape was designed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class RoundRectangleTemplate : ElementTemplate

Visual Basic [image] Copy Code

Public Class RoundRectangleTemplate
Inherits ElementTemplate

Remarks

This class ensures that the round corners do not change during resizing which is visually better. The drawback is that the radius appears to be specified in DiagramView Measure units and therefore a given shape instance will look bad when the measure unit is not the one for which the shape was designed.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ElementTemplate
MindFusion.Diagramming.RoundRectangleTemplate

See Also

RoundRectangleTemplate Members


MindFusion.Diagramming.RoundRectangleTemplate Members

RoundRectangleTemplate Members
Constructors Properties Methods
[image]

Represents an ElementTemplate that draws round rectangle. This class ensures that the round corners do not change during resizing which is visually better. The drawback is that the radius appears to be specified in DiagramView Measure units and therefore a given shape instance will look bad when the measure unit is not the one for which the shape was designed.

The following tables list the members exposed by the RoundRectangleTemplate type.

Public Constructors

Name | Description
RoundRectangleTemplate | Overloaded. Initializes a new instance of the RoundRectangleTemplate class.

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of this element.
Color | Gets or sets the outline color of this element. (Inherited from ElementTemplate.)
DashStyle | Gets or sets the dash style of the outline of this element. (Inherited from ElementTemplate.)
Radius | Gets or sets the round radius of this element.
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

Public Methods

Name | Description
Clone | Creates an exact copy of this RoundRectangleTemplate element.
SameAs | ElementTemplate.SameAs override.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument. (Inherited from ElementTemplate.)

See Also

RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate Constructor

RoundRectangleTemplate Constructor
[image]

Initializes a new instance of the RoundRectangleTemplate class.

Overload List

Name | Description
RoundRectangleTemplate () | Initializes a new instance of the RoundRectangleTemplate class.
RoundRectangleTemplate (Single, Single, Single, Single, Single) | Initializes a new instance of the RoundRectangleTemplate class with the specified settings.
RoundRectangleTemplate (Single, Single, Single, Single, Single, Color, DashStyle, Single) | Initializes a new instance of the RoundRectangleTemplate class with the specified settings.

See Also

RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate Constructor ()

RoundRectangleTemplate Constructor ()
See Also
[image]

Initializes a new instance of the RoundRectangleTemplate class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RoundRectangleTemplate ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RoundRectangleTemplate Constructor Overload List
RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate Constructor (Single, Single, Single, Single, Single)

RoundRectangleTemplate Constructor (Single, Single, Single, Single, Single)
See Also
[image]

Initializes a new instance of the RoundRectangleTemplate class with the specified settings.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RoundRectangleTemplate (
float x,
float y,
float w,
float h,
float r
)

Visual Basic [image] Copy Code

Public New ( _
x As Single, _
y As Single, _
w As Single, _
h As Single, _
r As Single _
)

Parameters

x
The x-coordinate of the top-left corner of the rectangle, expressed in percents of a shape node's bounding rectangle.
y

The y-coordinate of the top-left corner of the rectangle, expressed in percents of a shape node's bounding rectangle.

w
The width of the rectangle, expressed in percents of a shape node's bounding rectangle.
h

The height of the rectangle, expressed in percents of a shape node's bounding rectangle.

r

The round radius of the rectangle.

See Also

RoundRectangleTemplate Constructor Overload List
RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate Constructor (Single, Single, Single, Single, Single, Color, DashStyle, Single)

RoundRectangleTemplate Constructor (Single, Single, Single, Single, Single, Color, DashStyle, Single)
See Also
[image]

Initializes a new instance of the RoundRectangleTemplate class with the specified settings.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RoundRectangleTemplate (
float x,
float y,
float w,
float h,
float r,
Color color,
DashStyle dashStyle,
float width
)

Visual Basic [image] Copy Code

Public New ( _
x As Single, _
y As Single, _
w As Single, _
h As Single, _
r As Single, _
color As Color, _
dashStyle As DashStyle, _
width As Single _
)

Parameters

x

The x-coordinate of the top-left corner of the rectangle, expressed in percents of a shape node's bounding rectangle.

y

The y-coordinate of the top-left corner of the rectangle, expressed in percents of a shape node's bounding rectangle.

w

The width of the rectangle, expressed in percents of a shape node's bounding rectangle.

h

The height of the rectangle, expressed in percents of a shape node's bounding rectangle.

r

The round radius of the rectangle.

color

The color of this segment.

dashStyle

The dash style of this segment.

width

The width of this segment.

See Also

RoundRectangleTemplate Constructor Overload List
RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate Methods

RoundRectangleTemplate Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this RoundRectangleTemplate element.
SameAs | ElementTemplate.SameAs override.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument. (Inherited from ElementTemplate.)

See Also

RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate.Clone Method

RoundRectangleTemplate.Clone Method
[image]

Creates an exact copy of this RoundRectangleTemplate element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

An instance of the RoundRectangleTemplate class.

See Also

RoundRectangleTemplate Members
RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate.SameAs Method

RoundRectangleTemplate.SameAs Method
[image]

ElementTemplate.SameAs override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool SameAs (
ElementTemplate obj
)

Visual Basic [image] Copy Code

Public Overrides Function SameAs ( _
obj As ElementTemplate _
) As Boolean

Parameters

obj

The ElementTemplate to compare to this template.

Return Value

true if the specified object is a RoundRectangleTemplate closely approximating this template; otherwise, false.

See Also

RoundRectangleTemplate Members
RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate Properties

RoundRectangleTemplate Properties
[image]

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of this element.
Color | Gets or sets the outline color of this element. (Inherited from ElementTemplate.)
DashStyle | Gets or sets the dash style of the outline of this element. (Inherited from ElementTemplate.)
Radius | Gets or sets the round radius of this element.
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

See Also

RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate.Bounds Property

RoundRectangleTemplate.Bounds Property
[image]

Gets the bounding rectangle of this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As RectangleF

Property Value

A RectangleF object that represents the bounding rectangle of this element.

See Also

RoundRectangleTemplate Members
RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate.Radius Property

RoundRectangleTemplate.Radius Property
[image]

Gets or sets the round radius of this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Radius { get; set; }

Visual Basic [image] Copy Code

Public Property Radius As Single

Property Value

A float value specifying the round radius of this element.

See Also

RoundRectangleTemplate Members
RoundRectangleTemplate Class


MindFusion.Diagramming.RoutingOptions Class

RoutingOptions Class
Remarks See Also
[image]

Allows customization of various aspects of the link routing algorithm.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class RoutingOptions : RoutingOptions

Visual Basic [image] Copy Code

Public Class RoutingOptions
Implements RoutingOptions

Remarks

Use the RoutingOptions member of the Diagram class to access the sole instance of this class.

MvcDiagram uses a cost minimization algorithm to route links between nodes. For each link, there is a routing grid built for the area that encloses the link and its origin and destination nodes. The size of the grid pieces is set via GridSize. Each piece of the grid is marked as an obstacle if it intersects an Obstacle node. Some cost values are assigned to the remaining pieces, depending on how distant they are from nodes and other links.

That algorithm evaluates possible paths across the routing grid aiming to find one that has a minimal cost. The values of LengthCost, TurnCost, CrossingCost and NodeVicinityCost are added to the total cost of a route and have a great influence over the shape of the chosen path.

The StartOrientation and EndOrientation properties specify the orientation of the first and last segments of routed links, and Anchoring specifies whether link ends should be aligned to the anchor points defined for nodes.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.RoutingOptions

See Also

RoutingOptions Members


MindFusion.Diagramming.RoutingOptions Members

RoutingOptions Members
Properties Methods
[image]

Allows customization of various aspects of the link routing algorithm.

The following tables list the members exposed by the RoutingOptions type.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating whether to align link ends to the anchor points of nodes.
CrossingCost | Gets or sets a value added to the total cost of a route which causes a link to cross another link.
Distance | Gets a heuristic delegate function that returns the real distance sqrt(dx^2 + dy^2) between two pieces of the routing grid.
DistSquare | Gets a heuristic delegate function that returns the square distance dx^2 + dy^2 as a cost evaluation of the distance between two pieces of the routing grid.
DontOptimizeLongRoutes | Gets or sets a value indicating whether long routes don't have their number of segments minimized in order to save up processing time.
EndOrientation | Gets or sets the desired orientation of the last segments of routed links.
EndPointsOffset | Gets or sets the minimum number of routing grid cells the end segments of links should occupy before they are allowed to bend.
GridSize | Gets or sets the size of the pieces of the routing grid.
IgnoreAnchoring | For internal use.
LengthCost | Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.
MaxAbs | Gets a heuristic delegate function that returns max(dx, dy) as a cost evaluation of the distance between two pieces of the routing grid.
NodeVicinityCost | Gets or sets a value added to the total cost of a route if the route passes too close to a node.
NodeVicinitySize | Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.
RouteHeuristics | Gets or sets a heuristic function used to evaluate the distance between two pieces of the routing grid.
SmartPolylineEnds | Gets or sets a value indicating whether the end segments of polyline links should be oriented orthogonally to the node bounds.
StartOrientation | Gets or sets the desired orientation of the first segments of routed links.
TriggerRerouting | Gets or sets a value indicating under what circumstances links are rerouted automatically.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.

Public Methods

Name | Description
SetDefaultMode | Resets all routing properties to their default values.
SetMinSegmentsMode | Assigns to the routing properties a predefined set of values which allow finding paths that have a small number of segments.
SetQuickMode | Assigns to the routing properties a predefined set of values which allow finding paths quickly but the found paths are of low quality.

See Also

RoutingOptions Class


MindFusion.Diagramming.RoutingOptions Methods

RoutingOptions Methods
[image]

Public Methods

Name | Description
SetDefaultMode | Resets all routing properties to their default values.
SetMinSegmentsMode | Assigns to the routing properties a predefined set of values which allow finding paths that have a small number of segments.
SetQuickMode | Assigns to the routing properties a predefined set of values which allow finding paths quickly but the found paths are of low quality.

See Also

RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.SetDefaultMode Method

RoutingOptions.SetDefaultMode Method
[image]

Resets all routing properties to their default values.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetDefaultMode ()

Visual Basic [image] Copy Code

Public Sub SetDefaultMode ()

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace
SetMinSegmentsMode Method
SetQuickMode Method


MindFusion.Diagramming.RoutingOptions.SetMinSegmentsMode Method

RoutingOptions.SetMinSegmentsMode Method
[image]

Assigns to the routing properties a predefined set of values which allow finding paths that have a small number of segments.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetMinSegmentsMode ()

Visual Basic [image] Copy Code

Public Sub SetMinSegmentsMode ()

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace
SetDefaultMode Method
SetQuickMode Method


MindFusion.Diagramming.RoutingOptions.SetQuickMode Method

RoutingOptions.SetQuickMode Method
[image]

Assigns to the routing properties a predefined set of values which allow finding paths quickly but the found paths are of low quality.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetQuickMode ()

Visual Basic [image] Copy Code

Public Sub SetQuickMode ()

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace
SetDefaultMode Method
SetMinSegmentsMode Method


MindFusion.Diagramming.RoutingOptions Properties

RoutingOptions Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating whether to align link ends to the anchor points of nodes.
CrossingCost | Gets or sets a value added to the total cost of a route which causes a link to cross another link.
Distance | Gets a heuristic delegate function that returns the real distance sqrt(dx^2 + dy^2) between two pieces of the routing grid.
DistSquare | Gets a heuristic delegate function that returns the square distance dx^2 + dy^2 as a cost evaluation of the distance between two pieces of the routing grid.
DontOptimizeLongRoutes | Gets or sets a value indicating whether long routes don't have their number of segments minimized in order to save up processing time.
EndOrientation | Gets or sets the desired orientation of the last segments of routed links.
EndPointsOffset | Gets or sets the minimum number of routing grid cells the end segments of links should occupy before they are allowed to bend.
GridSize | Gets or sets the size of the pieces of the routing grid.
IgnoreAnchoring | For internal use.
LengthCost | Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.
MaxAbs | Gets a heuristic delegate function that returns max(dx, dy) as a cost evaluation of the distance between two pieces of the routing grid.
NodeVicinityCost | Gets or sets a value added to the total cost of a route if the route passes too close to a node.
NodeVicinitySize | Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.
RouteHeuristics | Gets or sets a heuristic function used to evaluate the distance between two pieces of the routing grid.
SmartPolylineEnds | Gets or sets a value indicating whether the end segments of polyline links should be oriented orthogonally to the node bounds.
StartOrientation | Gets or sets the desired orientation of the first segments of routed links.
TriggerRerouting | Gets or sets a value indicating under what circumstances links are rerouted automatically.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.

See Also

RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.Anchoring Property

RoutingOptions.Anchoring Property
[image]

Gets or sets a value indicating whether to align link ends to the anchor points of nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Anchoring Anchoring { get; set; }

Visual Basic [image] Copy Code

Public Property Anchoring As Anchoring

Property Value

A member of the Anchoring enumeration. The default is Ignore.

Remarks

By default, the routing algorithm ignores anchor points. To make it align link ends to the points specified in the AnchorPattern property of nodes, set Anchoring to Keep or Reassign. Keep specifies that the routing algorithm does not change the positions of link end points. Reassign lets the routing algorithm choose new end points for a link from the ones specified in the AnchorPattern of its origin and destination nodes.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.CrossingCost Property

RoutingOptions.CrossingCost Property
[image]

Gets or sets a value added to the total cost of a route which causes a link to cross another link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public byte CrossingCost { get; set; }

Visual Basic [image] Copy Code

Public Property CrossingCost As Byte

Property Value

A byte value specifying the crossing cost. The default is 4.

Remarks

This is a penalty value added to the total cost of an evaluated link route if it crosses another link. The routing algorithm aims to find paths that have a minimal cost, so assigning a greater value to CrossingCost leads to fewer link intersections. At this time CrossingCost processing is implemented only for links with Shape set to Cascading.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace
LengthCost Property
NodeVicinityCost Property
TurnCost Property


MindFusion.Diagramming.RoutingOptions.Distance Property

RoutingOptions.Distance Property
[image]

Gets a heuristic delegate function that returns the real distance sqrt(dx^2 + dy^2) between two pieces of the routing grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static RouteHeuristics Distance { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Distance As RouteHeuristics

Property Value

A predefined RouteHeuristics delegate instance.

Remarks

While generating a path, the routing algorithm evaluates pieces of the routing grid adjacent to the current one. It takes into account the cost for passing trough a piece and adds to that cost a heuristic value calculated by a RouteHeuristics delegate. So the smaller heuristic value a piece has, the greater the chance the found route to go through that piece.

Distance is a predefined delegate that assigns to pieces a heuristic value equaling the piece distance to the target. Thus of the four pieces adjacent to the current one, the piece closest to the target has the smallest value and the route generation continues through it. Distance is the default value of the RouteHeuristics property.

Example

The following sample demonstrates how to use this property:

C# [image] Copy Code

diagram.RoutingOptions.RouteHeuristics = RoutingOptions.Distance;

Visual Basic [image] Copy Code
Diagram.RoutingOptions.RouteHeuristics = RoutingOptions.Distance

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace
DistSquare Property
MaxAbs Property


MindFusion.Diagramming.RoutingOptions.DistSquare Property

RoutingOptions.DistSquare Property
[image]

Gets a heuristic delegate function that returns the square distance dx^2 + dy^2 as a cost evaluation of the distance between two pieces of the routing grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static RouteHeuristics DistSquare { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DistSquare As RouteHeuristics

Property Value

A predefined RouteHeuristics delegate instance.

Remarks

While generating a path, the routing algorithm evaluates pieces of the routing grid adjacent to the current one. It takes into account the cost for passing trough a piece and adds to that cost a heuristic value calculated by a RouteHeuristics delegate. So the smaller heuristic value a piece has, the greater the chance the found route to go through that piece.

DistSquare is a predefined delegate that assigns to pieces a heuristic value equaling the piece distance to the target raised to the second power. DistSquare can be assigned to the RouteHeuristics property. By returning larger values than the default heuristic function Distance, it makes the prediction part of the routing algorithm have greater impact on the evaluated routes.That would lead to faster path-finding, but the real cost functions might have less impact and thus the quality of the found routes could be low.

Example

The following sample demonstrates how to use this property:

C# [image] Copy Code

diagram.RoutingOptions.RouteHeuristics = RoutingOptions.DistSquare;

Visual Basic [image] Copy Code
Diagram.RoutingOptions.RouteHeuristics = RoutingOptions.DistSquare

See Also

RoutingOptions Members
RoutingOptions Class
MaxAbs Property


MindFusion.Diagramming.RoutingOptions.DontOptimizeLongRoutes Property

RoutingOptions.DontOptimizeLongRoutes Property
[image]

Gets or sets a value indicating whether long routes don't have their number of segments minimized in order to save up processing time.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool DontOptimizeLongRoutes { get; set; }

Visual Basic [image] Copy Code

Public Property DontOptimizeLongRoutes As Boolean

Property Value

true to disable route optimization for long links; otherwise, false. The default is false.

Remarks

Segment optimization done on routed links might need much processing time. The control allows disabling that optimization for long links. That would make the found routes have a "staircase" pattern when they run diagonally.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.EndOrientation Property

RoutingOptions.EndOrientation Property
[image]

Gets or sets the desired orientation of the last segments of routed links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation EndOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property EndOrientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Auto.

Remarks

For some diagrams it might be desirable that first and last segments of links always have a specific direction. For example, in database ER diagrams links usually connect to table rows on the left- or right-hand sides of tables; in that case their end segments must be horizontal. EndOrientation specifies what orientation of links' last segments to be applied by the routing algorithm.

See Also

RoutingOptions Members
RoutingOptions Class
StartOrientation Property


MindFusion.Diagramming.RoutingOptions.EndPointsOffset Property

RoutingOptions.EndPointsOffset Property
[image]

Gets or sets the minimum number of routing grid cells the end segments of links should occupy before they are allowed to bend.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int EndPointsOffset { get; set; }

Visual Basic [image] Copy Code

Public Property EndPointsOffset As Integer

Property Value

Number of routing grid cells the end segments of links should occupy before a bend is allowed. The default value is 0.

Remarks

Set this property to a value greater than 0 to ensure the first bend the link makes is not too close to the node boundaries.

See Also

RoutingOptions Members
RoutingOptions Class
GridSize Property


MindFusion.Diagramming.RoutingOptions.GridSize Property

RoutingOptions.GridSize Property
[image]

Gets or sets the size of the pieces of the routing grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float GridSize { get; set; }

Visual Basic [image] Copy Code

Public Property GridSize As Single

Property Value

A float value specifying the size of the pieces of the routing grid. The default is 4.

Remarks

A smaller size of routing grid pieces helps finding more precise paths, however since the number of pieces increases, there would be more time needed to find a path.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.IgnoreAnchoring Property

RoutingOptions.IgnoreAnchoring Property
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IgnoreAnchoring { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IgnoreAnchoring As Boolean

Property Value

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.LengthCost Property

RoutingOptions.LengthCost Property
[image]

Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public byte LengthCost { get; set; }

Visual Basic [image] Copy Code

Public Property LengthCost As Byte

Property Value

A byte value specifying the length cost. The default is 2.

Remarks

This is a penalty value added to the total cost of an evaluated link route for each piece of the routing grid it occupies. The routing algorithm aims to find paths that have a minimal cost, so assigning a greater value to LengthCost leads to generating shorter paths.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace
CrossingCost Property
NodeVicinityCost Property
TurnCost Property


MindFusion.Diagramming.RoutingOptions.MaxAbs Property

RoutingOptions.MaxAbs Property
[image]

Gets a heuristic delegate function that returns max(dx, dy) as a cost evaluation of the distance between two pieces of the routing grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static RouteHeuristics MaxAbs { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MaxAbs As RouteHeuristics

Property Value

A predefined RouteHeuristics delegate instance.

Remarks

While generating a path, the routing algorithm evaluates pieces of the routing grid adjacent to the current one. It takes into account the cost for passing trough a piece and adds to that cost a heuristic value calculated by a RouteHeuristics delegate function. So the smaller heuristic value a piece has, the greater the chance the found route to go through that piece.

MaxAbs is a predefined delegate that assigns to pieces the higher value from the horizontal or vertical -only distances between a piece and the target. MaxAbs can be assigned to the RouteHeuristics property. By returning smaller values than the default heuristic function Distance, it makes the prediction part of the routing algorithm have less impact on the evaluated routes. That might lead to slower path-finding, but the real cost functions would have greater impact and thus the quality of the found routes could be higher.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.NodeVicinityCost Property

RoutingOptions.NodeVicinityCost Property
[image]

Gets or sets a value added to the total cost of a route if the route passes too close to a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public byte NodeVicinityCost { get; set; }

Visual Basic [image] Copy Code

Public Property NodeVicinityCost As Byte

Property Value

A byte value specifying the node vicinity cost. The default is 2.

Remarks

This is a penalty value added to the total cost of an evaluated link route if it passes too close to a node. The routing algorithm aims to find paths that have a minimal cost, so assigning a greater value to NodeVicinityCost makes links avoid passing close to nodes. The size of the buffer area around nodes in which passing links get a penalty cost is set via NodeVicinitySize.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace
CrossingCost Property
LengthCost Property
TurnCost Property


MindFusion.Diagramming.RoutingOptions.NodeVicinitySize Property

RoutingOptions.NodeVicinitySize Property
[image]

Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float NodeVicinitySize { get; set; }

Visual Basic [image] Copy Code

Public Property NodeVicinitySize As Single

Property Value

A float value specifying the size of the buffer area in which passing routes receive a penalty cost. The default is 12.

Remarks

The pieces of the routing grid that are closest to a node have the value of NodeVicinityCost assigned as their cost. The outer pieces of the buffer zone are assigned a portion of NodeVicinityCost proportional to their distance to the node.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.RouteHeuristics Property

RoutingOptions.RouteHeuristics Property
[image]

Gets or sets a heuristic function used to evaluate the distance between two pieces of the routing grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RouteHeuristics RouteHeuristics { get; set; }

Visual Basic [image] Copy Code

Public Property RouteHeuristics As RouteHeuristics

Property Value

A RouteHeuristics delegate used to evaluate the distance from a current routing grid piece to the target one. The default is Distance.

Remarks

While generating a path, the routing algorithm evaluates pieces of the routing grid adjacent to the current one. It takes into account the cost for passing trough a piece and adds to that cost a heuristic value calculated by RouteHeuristics. So the smaller heuristic value a piece has, the greater the chance the found route to go through that piece.

There are three predefined heuristic functions that can be assigned to RouteHeuristics: Distance, DistSquare and MaxAbs. All of them assign to pieces heuristic values that are larger for larger distances to the target. Thus of the four pieces adjacent to the current one, the piece closest to the target has the smallest value and the route generation continues through it.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.SmartPolylineEnds Property

RoutingOptions.SmartPolylineEnds Property
[image]

Gets or sets a value indicating whether the end segments of polyline links should be oriented orthogonally to the node bounds.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SmartPolylineEnds { get; set; }

Visual Basic [image] Copy Code

Public Property SmartPolylineEnds As Boolean

Property Value

true to orient the end segments orthogonally to the node bounds; otherwise, false.

Remarks

This property is valid only for links of style Polyline.

See Also

RoutingOptions Members
RoutingOptions Class
EndOrientation Property


MindFusion.Diagramming.RoutingOptions.StartOrientation Property

RoutingOptions.StartOrientation Property
[image]

Gets or sets the desired orientation of the first segments of routed links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation StartOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property StartOrientation As Orientation

Property Value

A member of the Orientation enumeration. The default is Auto.

Remarks

For some diagrams it might be desirable that first and last segments of links always have a specific direction. For example, in database ER diagrams links usually connect to table rows on the left- or right-hand sides of tables; in that case their end segments must be horizontal. StartOrientation specifies what orientation of links' first segments to be applied by the routing algorithm.

See Also

RoutingOptions Members
RoutingOptions Class
EndOrientation Property


MindFusion.Diagramming.RoutingOptions.TriggerRerouting Property

RoutingOptions.TriggerRerouting Property
[image]

Gets or sets a value indicating under what circumstances links are rerouted automatically.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RerouteLinks TriggerRerouting { get; set; }

Visual Basic [image] Copy Code

Public Property TriggerRerouting As RerouteLinks

Property Value

A member of the RerouteLinks enumeration. The default is WhenModified.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.TurnCost Property

RoutingOptions.TurnCost Property
[image]

Gets or sets a value added to the total cost of a route if it makes a turn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public byte TurnCost { get; set; }

Visual Basic [image] Copy Code

Public Property TurnCost As Byte

Property Value

A byte value specifying the turn cost. The default is 4.

Remarks

This is a penalty value added to the total cost of an evaluated link route for each turn it makes. The routing algorithm aims to find paths that have a minimal cost, so assigning a greater value to TurnCost leads paths that make less turns (hence they have less segments).

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace
CrossingCost Property
LengthCost Property
NodeVicinityCost Property


MindFusion.Diagramming.RowEventArgs Class

RowEventArgs Class
[image]

Contains the arguments passed to handlers of table row-related events, such as TableSectionCollapsed and TableSectionExpanded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class RowEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class RowEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.RowEventArgs

See Also

RowEventArgs Members


MindFusion.Diagramming.RowEventArgs Members

RowEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to handlers of table row-related events, such as TableSectionCollapsed and TableSectionExpanded.

The following tables list the members exposed by the RowEventArgs type.

Public Constructors

Name | Description
RowEventArgs | Initializes a new instance of the RowEventArgs class.

Public Properties

Name | Description
RowIndex | Gets the index of the table row for which the event has been raised.
Table | Get the table for which the event has been raised.

See Also

RowEventArgs Class


MindFusion.Diagramming.RowEventArgs Constructor

RowEventArgs Constructor
[image]

Initializes a new instance of the RowEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RowEventArgs (
TableNode table,
int rowIndex
)

Visual Basic [image] Copy Code

Public Sub RowEventArgs ( _
table As TableNode, _
rowIndex As Integer _
)

Parameters

table

The TableNode related to the event.

rowIndex

The zero-based index of the table row related to the event.

See Also

RowEventArgs Class


MindFusion.Diagramming.RowEventArgs Properties

RowEventArgs Properties
[image]

Public Properties

Name | Description
RowIndex | Gets the index of the table row for which the event has been raised.
Table | Get the table for which the event has been raised.

See Also

RowEventArgs Class


MindFusion.Diagramming.RowEventArgs.RowIndex Property

RowEventArgs.RowIndex Property
[image]

Gets the index of the table row for which the event has been raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int RowIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RowIndex As Integer

Property Value

An integer value specifying the row's index.

See Also

RowEventArgs Members
RowEventArgs Class


MindFusion.Diagramming.RowEventArgs.Table Property

RowEventArgs.Table Property
[image]

Get the table for which the event has been raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode Table { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Table As TableNode

Property Value

An instance of the TableNode class.

See Also

RowEventArgs Members
RowEventArgs Class


MindFusion.Diagramming.SaveToStringFormat Enumeration

SaveToStringFormat Enumeration
[image]

Specifies in what format to save the diagram when generating a string using the SaveToString method.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum SaveToStringFormat

Visual Basic [image] Copy Code

Public Enum SaveToStringFormat

Members

Member name | Description
Base16 | Indicates a Base16 ASCII encoding.
Base64 | Indicates a Base64 ASCII encoding.
Xml | Indicates a non-compressed XML output.
CompressedXml | Indicates a compressed XML output.

See Also


MindFusion.Diagramming.ScriptHelper Class

ScriptHelper Class
[image]

Allows calling some static MvcDiagram methods from JavaScript and VBScript. It seems the script languages do not allow calling class static methods, so a ScriptHelper instance property is provided by the Diagram class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ScriptHelper

Visual Basic [image] Copy Code

Public Class ScriptHelper

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ScriptHelper

See Also

ScriptHelper Members


MindFusion.Diagramming.ScriptHelper Members

ScriptHelper Members
Constructors Methods
[image]

Allows calling some static MvcDiagram methods from JavaScript and VBScript. It seems the script languages do not allow calling class static methods, so a ScriptHelper instance property is provided by the Diagram class.

The following tables list the members exposed by the ScriptHelper type.

Public Constructors

Name | Description
ScriptHelper | Initializes a new instance of the ScriptHelper class.

Public Methods

Name | Description
ApplyLayout | Applies the specified layout to the underlying diagram.
CreateObject | Creates a MvcDiagram object given its class name.
CreateSolidBrush | Creates a solid brush with the specified color components.
NodesIntersect | Calculates whether the specified nodes' outlines intersect.
ShapeTemplateFromId | Returns the Shape having the specified identifier.

See Also

ScriptHelper Class


MindFusion.Diagramming.ScriptHelper Constructor

ScriptHelper Constructor
[image]

Initializes a new instance of the ScriptHelper class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ScriptHelper (
Diagram diagram
)

Visual Basic [image] Copy Code

Public Sub ScriptHelper ( _
diagram As Diagram _
)

Parameters

diagram

The Diagram the helper methods will work on.

See Also

ScriptHelper Class


MindFusion.Diagramming.ScriptHelper Methods

ScriptHelper Methods
[image]

Public Methods

Name | Description
ApplyLayout | Applies the specified layout to the underlying diagram.
CreateObject | Creates a MvcDiagram object given its class name.
CreateSolidBrush | Creates a solid brush with the specified color components.
NodesIntersect | Calculates whether the specified nodes' outlines intersect.
ShapeTemplateFromId | Returns the Shape having the specified identifier.

See Also

ScriptHelper Class


MindFusion.Diagramming.ScriptHelper.ApplyLayout Method

ScriptHelper.ApplyLayout Method
[image]

Applies the specified layout to the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ApplyLayout (
Object layout
)

Visual Basic [image] Copy Code

Public Sub ApplyLayout( _
layout As Object _
)

Parameters

layout

An instance of one of the layout classes that represents the layout to perform on the underlying diagram.

See Also

ScriptHelper Members
ScriptHelper Class


MindFusion.Diagramming.ScriptHelper.CreateObject Method

ScriptHelper.CreateObject Method
[image]

Creates a MvcDiagram object given its class name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object CreateObject (
string className
)

Visual Basic [image] Copy Code

Public Function CreateObject( _
className As String _
) As Object

Parameters

className

The class name of the object to create.

Return Value

A reference to the MvcDiagram object of the specified class.

See Also

ScriptHelper Members
ScriptHelper Class


MindFusion.Diagramming.ScriptHelper.CreateSolidBrush Method

ScriptHelper.CreateSolidBrush Method
[image]

Creates a solid brush with the specified color components.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush CreateSolidBrush (
int alpha,
int red,
int green,
int blue
)

Visual Basic [image] Copy Code

Public Function CreateSolidBrush ( _
alpha As Integer, _
red As Integer, _
green As Integer, _
blue As Integer _
) As Brush

Parameters

alpha

The alpha factor of the solid brush color.

red

The red component of the solid brush color.

green

The green component of the solid brush color.

blue
The blue component of the solid brush color.

Return Value

An instance of the MindFusion.Drawing.SolidBrush that represents the newly created brush.

See Also

ScriptHelper Members
ScriptHelper Class


MindFusion.Diagramming.ScriptHelper.NodesIntersect Method

ScriptHelper.NodesIntersect Method
[image]

Calculates whether the specified nodes' outlines intersect.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool NodesIntersect (
DiagramNode n1,
DiagramNode n2
)

Visual Basic [image] Copy Code

Public Function NodesIntersect ( _
n1 As DiagramNode, _
n2 As DiagramNode _
) As Boolean

Parameters

n1

The first DiagramNode to check.

n2

The second DiagramNode to check.

Return Value

true if the outlines of the specified nodes intersect; otherwise, false.

See Also

ScriptHelper Members
ScriptHelper Class


MindFusion.Diagramming.ScriptHelper.ShapeTemplateFromId Method

ScriptHelper.ShapeTemplateFromId Method
[image]

Returns the Shape having the specified identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape ShapeTemplateFromId (
string shapeId
)

Visual Basic [image] Copy Code

Public Function ShapeTemplateFromId ( _
shapeId As String _
) As Shape

Parameters

shapeId

The id of the shape to create.

Return Value

An instance of the Shape class.

See Also

ScriptHelper Members
ScriptHelper Class


MindFusion.Diagramming.Selection Class

Selection Class
Remarks See Also
[image]

Represents a set of items selected in the diagram document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class Selection : DiagramItem

Visual Basic [image] Copy Code

Public NotInheritable Class Selection
Inherits DiagramItem

Remarks

In a diagram document, several items can be selected simultaneously. If more than one item is selected, the compound set of selected items is handled by an instance of the Selection class.

Items in the selection can be of any element type. The Items property gives a collection of all the items in the selection. You can get type-safe access to items of specific class by using the Links and Nodes collections properties.

Users can select multiple items by drawing a selection rectangle. Depending on the DiagramView's Behavior, this is done either by simply dragging the mouse, or by holding CTRL down while dragging the mouse. Depending on the IncludeItemsIfIntersect value, items are selected if they are entirely inside the drawn selection rectangle, or if at least a part of them is inside the rectangle. It is possible to prevent users from selecting more than one items at the same time by setting AllowMultipleSelection to false.

Items can be always added or removed programmatically to selection by calling the AddItem and RemoveItem methods. Selection state of an item can be toggled, getting deselected from selected and vice versa, by calling the Toggle method. All items in the selection are deselected if Clear is invoked.

Use the Selected property of the DiagramItem class to determine whether a particular item is selected. The Selection's GetSize method returns how many items are selected. Bounds returns the rectangle that bounds all selected items.

The visual style of multiple selection is defined by the Style property. For example selection might be painted as a dashed rectangle or a semi-transparent filled rectangle.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.Selection

See Also

Selection Members


MindFusion.Diagramming.Selection Members

Selection Members
Fields Properties Methods
[image]

Represents a set of items selected in the diagram document.

The following tables list the members exposed by the Selection type.

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

Public Properties

Name | Description
AllowMultipleSelection | Gets or sets a value indicating whether more than one items can be selected simultaneously.
Bounds | Gets the rectangle that bounds all selected items.
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncludeItemsIfIntersect | Gets or sets a value indicating which items are selected when drawing a selection rectangle.
Items | Gets a collection of all selected items.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D. (Inherited from DiagramItem.)
Links | Gets the collection of all links in the selection.
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Nodes | Gets a collection of all selected nodes.
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
SetsDirtyFlag | Gets or sets a value indicating whether the diagram's Dirty flag should be set when selection changes.
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Style | Gets or sets a value indicating how to display multiple selection of items.
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
TopLevel | True if this is a top-level item in the diagram, or false if it is inside a container. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

Public Methods

Name | Description
AddItem | Adds a new item to the current selection.
Change | Selects an item and deselects all others.
Clear | Removes all items from the selection.
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
ContainsPoint | Overloaded.
Dispose | Overloaded. (Inherited from DiagramItem.)
DoModify | For internal use. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override.
DrawHandles | DiagramItem.DrawHandles override.
DrawShadow | DiagramItem.DrawShadow override.
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item. (Inherited from DiagramItem.)
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item. (Inherited from DiagramItem.)
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item. (Inherited from DiagramItem.)
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item. (Inherited from DiagramItem.)
GetOutlinePoly | Gets a polygon approximating the outline of this object. (Inherited from DiagramItem.)
GetRepaintRect | DiagramItem.GetRepaintRect override.
GetRotatedBounds | Gets the bounding rectangle of this item when it is rotated. (Inherited from DiagramItem.)
GetSize | Gets the number of selected items.
GetToolTip | Gets the tooltip that should be displayed for this item at the specified point. (Inherited from DiagramItem.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override.
HitTestManipulators | Triggers the manipulator located at the specified point. (Inherited from DiagramItem.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
RemoveItem | Removes an item from the selection.
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
Toggle | Toggles the selection state of an item.
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
AllowCreate | DiagramItem.AllowCreate override.
AllowModify | DiagramItem.AllowModify override.
CancelModify | DiagramItem.CancelModify override.
CompleteCreate | DiagramItem.CompleteCreate override.
CompleteModify | DiagramItem.CompleteModify override.
CreateProperties | Creates an item property set corresponding to the type of this diagram item. (Inherited from DiagramItem.)
CreateState | Creates an item state corresponding to the type of this diagram item. (Inherited from DiagramItem.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
Finalize | DiagramItem finalizer. (Inherited from DiagramItem.)
FreeResources | DiagramItem.FreeResources override.
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the item content from an XML element. (Inherited from DiagramItem.)
LoadObsolete | For internal use. (Inherited from DiagramItem.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnClick | Invoked when the user clicks this item. (Inherited from DiagramItem.)
OnDoubleClick | Invoked when the user double-clicks this item. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnZoomChanged | Called when the diagram's ZoomFactor changes. (Inherited from DiagramItem.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. (Inherited from DiagramItem.)
RestoreProperties | Restores the properties of this diagram item. (Inherited from DiagramItem.)
RestoreState | Restores the state of this diagram item. (Inherited from DiagramItem.)
SaveProperties | Saves the properties of this diagram item. (Inherited from DiagramItem.)
SaveState | Saves the state of this diagram item. (Inherited from DiagramItem.)
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramItem.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpanded | Sets whether the item is in expanded or collapsed state. (Inherited from DiagramItem.)
SetReference | Updates the reference to the specified object.
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
StartCreate | DiagramItem.StartCreate override.
StartModify | DiagramItem.StartModify override.
UpdateCreate | Invoked during interactive creation of this item. (Inherited from DiagramItem.)
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster. (Inherited from DiagramItem.)
UpdateModify | DiagramItem.UpdateModify override.

See Also

Selection Class


MindFusion.Diagramming.Selection Methods

Selection Methods
[image]

Public Methods

Name | Description
AddItem | Adds a new item to the current selection.
Change | Selects an item and deselects all others.
Clear | Removes all items from the selection.
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
ContainsPoint | Overloaded.
Dispose | Overloaded. (Inherited from DiagramItem.)
DoModify | For internal use. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override.
DrawHandles | DiagramItem.DrawHandles override.
DrawShadow | DiagramItem.DrawShadow override.
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item. (Inherited from DiagramItem.)
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item. (Inherited from DiagramItem.)
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item. (Inherited from DiagramItem.)
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item. (Inherited from DiagramItem.)
GetOutlinePoly | Gets a polygon approximating the outline of this object. (Inherited from DiagramItem.)
GetRepaintRect | DiagramItem.GetRepaintRect override.
GetRotatedBounds | Gets the bounding rectangle of this item when it is rotated. (Inherited from DiagramItem.)
GetSize | Gets the number of selected items.
GetToolTip | Gets the tooltip that should be displayed for this item at the specified point. (Inherited from DiagramItem.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override.
HitTestManipulators | Triggers the manipulator located at the specified point. (Inherited from DiagramItem.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
RemoveItem | Removes an item from the selection.
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
Toggle | Toggles the selection state of an item.
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
AllowCreate | DiagramItem.AllowCreate override.
AllowModify | DiagramItem.AllowModify override.
CancelModify | DiagramItem.CancelModify override.
CompleteCreate | DiagramItem.CompleteCreate override.
CompleteModify | DiagramItem.CompleteModify override.
CreateProperties | Creates an item property set corresponding to the type of this diagram item. (Inherited from DiagramItem.)
CreateState | Creates an item state corresponding to the type of this diagram item. (Inherited from DiagramItem.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
Finalize | DiagramItem finalizer. (Inherited from DiagramItem.)
FreeResources | DiagramItem.FreeResources override.
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the item content from an XML element. (Inherited from DiagramItem.)
LoadObsolete | For internal use. (Inherited from DiagramItem.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnClick | Invoked when the user clicks this item. (Inherited from DiagramItem.)
OnDoubleClick | Invoked when the user double-clicks this item. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnZoomChanged | Called when the diagram's ZoomFactor changes. (Inherited from DiagramItem.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. (Inherited from DiagramItem.)
RestoreProperties | Restores the properties of this diagram item. (Inherited from DiagramItem.)
RestoreState | Restores the state of this diagram item. (Inherited from DiagramItem.)
SaveProperties | Saves the properties of this diagram item. (Inherited from DiagramItem.)
SaveState | Saves the state of this diagram item. (Inherited from DiagramItem.)
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramItem.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpanded | Sets whether the item is in expanded or collapsed state. (Inherited from DiagramItem.)
SetReference | Updates the reference to the specified object.
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
StartCreate | DiagramItem.StartCreate override.
StartModify | DiagramItem.StartModify override.
UpdateCreate | Invoked during interactive creation of this item. (Inherited from DiagramItem.)
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster. (Inherited from DiagramItem.)
UpdateModify | DiagramItem.UpdateModify override.

See Also

Selection Class


MindFusion.Diagramming.Selection.AddItem Method

Selection.AddItem Method
[image]

Adds a new item to the current selection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AddItem (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Sub AddItem ( _
item As DiagramItem _
)

Parameters

item
The DiagramItem to be added to the selection.

Remarks

This method adds a new item to the selection. It also deactivates the ActiveItem, if any, and makes the newly added item the active one.

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace
Change Method
RemoveItem Method
Clear Method


MindFusion.Diagramming.Selection.AllowCreate Method

Selection.AllowCreate Method
[image]

DiagramItem.AllowCreate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual bool AllowCreate (
PointF current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overridable Function AllowCreate ( _
current As PointF, _
ist As InteractionState _
) As Boolean

Parameters

current

ist

Return Value

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.AllowModify Method

Selection.AllowModify Method
[image]

DiagramItem.AllowModify override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual bool AllowModify (
PointF current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overridable Function AllowModify ( _
current As PointF, _
ist As InteractionState _
) As Boolean

Parameters

current

ist

Return Value

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.CancelModify Method

Selection.CancelModify Method
[image]

DiagramItem.CancelModify override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void CancelModify (
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub CancelModify( _
ist As InteractionState _
)

Parameters

ist

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.Change Method

Selection.Change Method
[image]

Selects an item and deselects all others.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Change (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Sub Change ( _
item As DiagramItem _
)

Parameters

item
The DiagramItem which should be made active.

Remarks

Call this method to select an item and make it the ActiveItem. The method doesn't let you select locked items.

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace
AddItem Method
RemoveItem Method
Clear Method


MindFusion.Diagramming.Selection.Clear Method

Selection.Clear Method
[image]

Removes all items from the selection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Clear ()

Visual Basic [image] Copy Code

Public Sub Clear ()

Remarks

Call Clear to deselect all items. The items are not deleted. The method also sets the diagram's ActiveItem to null (Nothing in Visual Basic).

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace
AddItem Method
RemoveItem Method


MindFusion.Diagramming.Selection.CompleteCreate Method

Selection.CompleteCreate Method
[image]

DiagramItem.CompleteCreate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void CompleteCreate (
PointF end
)

Visual Basic [image] Copy Code

Protected Overrides Sub CompleteCreate( _
end As PointF _
)

Parameters

end

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.CompleteModify Method

Selection.CompleteModify Method
[image]

DiagramItem.CompleteModify override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void CompleteModify (
PointF end,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overridable Sub CompleteModify ( _
end As PointF, _
ist As InteractionState _
)

Parameters

end

ist

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.ContainsPoint Method

Selection.ContainsPoint Method
[image]

Overload List

Name | Description
Selection.ContainsPoint (PointF) | DiagramItem.ContainsPoint override.
Selection.ContainsPoint (PointF, Single) | DiagramItem.ContainsPoint override.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.ContainsPoint Method (PointF)

Selection.ContainsPoint Method (PointF)
See Also
[image]

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
PointF point
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
point As PointF _
) As Boolean

Parameters

point
The point to check.

Return Value

See Also

ContainsPoint Method Overload List
Selection Members
Selection Class


MindFusion.Diagramming.Selection.ContainsPoint Method (PointF, Single)

Selection.ContainsPoint Method (PointF, Single)
See Also
[image]

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
PointF point,
float threshold
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
point As PointF, _
threshold As Single _
) As Boolean

Parameters

point

A PointF value specifying the logical coordinates of a diagram point.

threshold

Specifies the size of the area around the item outlines where the point is still considered inside the item.

Return Value

true it this item contains the specified point; otherwise, false.

See Also

ContainsPoint Method Overload List
Selection Members
Selection Class


MindFusion.Diagramming.Selection.Draw Method

Selection.Draw Method
[image]

DiagramItem.Draw override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Draw (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw ( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

options

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.DrawHandles Method

Selection.DrawHandles Method
[image]

DiagramItem.DrawHandles override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawHandles (
IGraphics graphics,
HandlesVisualStyle style1,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawHandles( _
graphics As IGraphics, _
style1 As HandlesVisualStyle, _
options As RenderOptions _
)

Parameters

graphics

style1

options

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.DrawShadow Method

Selection.DrawShadow Method
[image]

DiagramItem.DrawShadow override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawShadow (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawShadow ( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics
An IGraphics object where the shadow should be rendered.
options
A RenderOptions object specifying options for the drawing operation.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.FreeResources Method

Selection.FreeResources Method
[image]

DiagramItem.FreeResources override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void FreeResources ()

Visual Basic [image] Copy Code

Protected Overrides Sub FreeResources ()

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.GetRepaintRect Method

Selection.GetRepaintRect Method
[image]

DiagramItem.GetRepaintRect override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override RectangleF GetRepaintRect (
bool connected
)

Visual Basic [image] Copy Code

Public Overrides Function GetRepaintRect( _
connected As Boolean _
) As RectangleF

Parameters

connected

Return Value

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.GetSize Method

Selection.GetSize Method
[image]

Gets the number of selected items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int GetSize ()

Visual Basic [image] Copy Code

Public Function GetSize () As Integer

Return Value

An integer value indicating the size of the collection.

Remarks

Call this method to get the number of selected items, including both nodes and links.

See Also

Selection Members
Selection Class
Items Property


MindFusion.Diagramming.Selection.HitTestHandle Method

Selection.HitTestHandle Method
[image]

DiagramItem.HitTestHandle override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override AdjustmentHandle HitTestHandle (
PointF point
)

Visual Basic [image] Copy Code

Public Overrides Function HitTestHandle( _
point As PointF _
) As AdjustmentHandle

Parameters

point

Return Value

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.LoadFrom Method

Selection.LoadFrom Method
[image]

Deserializes the object from the specified reader.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFrom (
BinaryReader reader,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFrom ( _
reader As BinaryReader, _
context As PersistContext _
)

Parameters

reader

context

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.RemoveItem Method

Selection.RemoveItem Method
[image]

Removes an item from the selection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RemoveItem (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function RemoveItem ( _
item As DiagramItem _
) As Boolean

Parameters

item
The DiagramItem to be removed from the selection.

Return Value

true if the item has been successfully removed; otherwise, false.

Remarks

Call this method to deselect an item. Note that the item is not deleted, but just removed from the selection.

See Also

Selection Members
Selection Class
AddItem Method


MindFusion.Diagramming.Selection.SaveTo Method

Selection.SaveTo Method
[image]

Serializes the object to the specified writer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveTo (
BinaryWriter writer,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveTo ( _
writer As BinaryWriter, _
context As PersistContext _
)

Parameters

writer

context

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.SetReference Method

Selection.SetReference Method
[image]

Updates the reference to the specified object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SetReference (
int refId,
Object obj,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub SetReference( _
refId As Integer, _
obj As Object, _
context As PersistContext _
)

Parameters

refId

obj

context

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.StartCreate Method

Selection.StartCreate Method
[image]

DiagramItem.StartCreate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void StartCreate (
PointF org
)

Visual Basic [image] Copy Code

Protected Overrides Sub StartCreate( _
org As PointF _
)

Parameters

org

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.StartModify Method

Selection.StartModify Method
[image]

DiagramItem.StartModify override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void StartModify (
PointF org,
AdjustmentHandle handle,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub StartModify( _
org As PointF, _
handle As AdjustmentHandle, _
ist As InteractionState _
)

Parameters

org

handle

ist

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.Toggle Method

Selection.Toggle Method
[image]

Toggles the selection state of an item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Toggle (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Sub Toggle ( _
item As DiagramItem _
)

Parameters

item
The DiagramItem whose selection state should be changed.

Remarks

Call this method to toggle an item's selection state. The method selects the diagram item passed as argument if previously it was deselected. If the item was selected, the method deselects it.

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace
Change Method
AddItem Method
RemoveItem Method


MindFusion.Diagramming.Selection.UpdateModify Method

Selection.UpdateModify Method
[image]

DiagramItem.UpdateModify override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void UpdateModify (
PointF current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overridable Sub UpdateModify ( _
current As PointF, _
ist As InteractionState _
)

Parameters

current

ist

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection Properties

Selection Properties
[image]

Public Properties

Name | Description
AllowMultipleSelection | Gets or sets a value indicating whether more than one items can be selected simultaneously.
Bounds | Gets the rectangle that bounds all selected items.
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncludeItemsIfIntersect | Gets or sets a value indicating which items are selected when drawing a selection rectangle.
Items | Gets a collection of all selected items.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D. (Inherited from DiagramItem.)
Links | Gets the collection of all links in the selection.
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Nodes | Gets a collection of all selected nodes.
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
SetsDirtyFlag | Gets or sets a value indicating whether the diagram's Dirty flag should be set when selection changes.
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Style | Gets or sets a value indicating how to display multiple selection of items.
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
TopLevel | True if this is a top-level item in the diagram, or false if it is inside a container. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

See Also

Selection Class


MindFusion.Diagramming.Selection.AllowMultipleSelection Property

Selection.AllowMultipleSelection Property
[image]

Gets or sets a value indicating whether more than one items can be selected simultaneously.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowMultipleSelection { get; set; }

Visual Basic [image] Copy Code

Public Property AllowMultipleSelection As Boolean

Property Value

A boolean flag indicating whether multiple items can be selected simultaneously by the user.

Remarks

The property controls whether multiple items can be selected interactively. If it is disabled, multiple items can still be selected programmatically.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.Bounds Property

Selection.Bounds Property
[image]

Gets the rectangle that bounds all selected items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As RectangleF

Property Value

An instance of the.NET RectangleF structure.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.IncludeItemsIfIntersect Property

Selection.IncludeItemsIfIntersect Property
[image]

Gets or sets a value indicating which items are selected when drawing a selection rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IncludeItemsIfIntersect { get; set; }

Visual Basic [image] Copy Code

Public Property IncludeItemsIfIntersect As Boolean

Property Value

true to select items that intersect the drawn selection rectangle; false to select items only if they are entirely inside the selection rectangle. The default is true.

Remarks

The value of this property is considered when users draw a selection rectangle using a pointing device. By default, all items inside the drawn rectangle and the ones that are only partially inside it are selected. Set the property to false to let users select items only when the items are entirely inside the selection rectangle.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.Items Property

Selection.Items Property
[image]

Gets a collection of all selected items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemCollection Items { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Items As DiagramItemCollection

Property Value

An instance of the DiagramItemCollection class that represents the selected diagram items.

Remarks

You can select items programmatically by adding them to this collection.

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace
Nodes Property
Links Property


MindFusion.Diagramming.Selection.Links Property

Selection.Links Property
[image]

Gets the collection of all links in the selection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection Links { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Links As DiagramLinkCollection

Property Value

An instance of the DiagramLinkCollection class that represents the selected diagram items.

Remarks

You can select links programmatically by adding them to this collection.

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace
Items Property
Nodes Property


MindFusion.Diagramming.Selection.Nodes Property

Selection.Nodes Property
[image]

Gets a collection of all selected nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeCollection Nodes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Nodes As DiagramNodeCollection

Property Value

An instance of the DiagramNodeCollection class that represents the nodes in the selection.

Remarks

You can select nodes programmatically by adding them to this collection.

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace
Items Property
Links Property


MindFusion.Diagramming.Selection.SetsDirtyFlag Property

Selection.SetsDirtyFlag Property
[image]

Gets or sets a value indicating whether the diagram's Dirty flag should be set when selection changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SetsDirtyFlag { get; set; }

Visual Basic [image] Copy Code

Public Property SetsDirtyFlag As Boolean

Property Value

true to set the flag when selection changes, otherwise false. The default value is true.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.Style Property

Selection.Style Property
[image]

Gets or sets a value indicating how to display multiple selection of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public new SelectionStyle Style { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property Style As SelectionStyle

Property Value

A member of the SelectionStyle enumeration. The default is SelectionHandles.

Remarks

The property specifies how multiple selection is presented visually to users - with manipulation handles painted around each item or with a rectangle painted around all items.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.SelectionCopy Class

SelectionCopy Class
Remarks See Also
[image]

Used internally in the implementation of copy/paste functions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class SelectionCopy

Visual Basic [image] Copy Code

Public NotInheritable Class SelectionCopy

Remarks

This class supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.SelectionCopy

See Also

SelectionCopy Members


MindFusion.Diagramming.SelectionCopy Members

SelectionCopy Members
Constructors Properties
[image]

Used internally in the implementation of copy/paste functions.

The following tables list the members exposed by the SelectionCopy type.

Public Constructors

Name | Description
SelectionCopy | Initializes a new instance of the SelectionCopy class.

Public Properties

Name | Description
Groups | Gets the underlying collection of groups.
Items | Gets the underlying collection of items.
OriginalItems | Gets a collection of the original items.

See Also

SelectionCopy Class


MindFusion.Diagramming.SelectionCopy Constructor

SelectionCopy Constructor
[image]

Initializes a new instance of the SelectionCopy class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SelectionCopy (
DiagramItemCollection items,
DiagramItemCollection originalItems,
GroupCollection groups
)

Visual Basic [image] Copy Code

Public Sub SelectionCopy ( _
items As DiagramItemCollection, _
originalItems As DiagramItemCollection, _
groups As GroupCollection _
)

Parameters

items
A collection containing the item copies.
originalItems
A collection containing the original items.
groups
A collection containing the group copies.

Remarks

This constructor supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

SelectionCopy Class


MindFusion.Diagramming.SelectionCopy Properties

SelectionCopy Properties
[image]

Public Properties

Name | Description
Groups | Gets the underlying collection of groups.
Items | Gets the underlying collection of items.
OriginalItems | Gets a collection of the original items.

See Also

SelectionCopy Class


MindFusion.Diagramming.SelectionCopy.Groups Property

SelectionCopy.Groups Property
[image]

Gets the underlying collection of groups.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GroupCollection Groups { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Groups As GroupCollection

Property Value

An instance of the GroupCollection class.

Remarks

This property supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

SelectionCopy Members
SelectionCopy Class


MindFusion.Diagramming.SelectionCopy.Items Property

SelectionCopy.Items Property
[image]

Gets the underlying collection of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemCollection Items { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Items As DiagramItemCollection

Property Value

An instance of the DiagramItemCollection class.

Remarks

This property supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

SelectionCopy Members
SelectionCopy Class


MindFusion.Diagramming.SelectionCopy.OriginalItems Property

SelectionCopy.OriginalItems Property
[image]

Gets a collection of the original items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemCollection OriginalItems { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OriginalItems As DiagramItemCollection

Property Value

An instance of the DiagramItemCollection class.

Remarks

This property supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

SelectionCopy Members
SelectionCopy Class


MindFusion.Diagramming.SelectionEventArgs Class

SelectionEventArgs Class
[image]

Contains the arguments passed to the SelectionModified event handler.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class SelectionEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class SelectionEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.SelectionEventArgs
MindFusion.Diagramming.SelectionValidationEventArgs

See Also

SelectionEventArgs Members


MindFusion.Diagramming.SelectionEventArgs Members

SelectionEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the SelectionModified event handler.

The following tables list the members exposed by the SelectionEventArgs type.

Public Constructors

Name | Description
SelectionEventArgs | Initializes a new instance of the SelectionEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets the adjustment handle being moved by the user.
MousePosition | Gets the current mouse pointer position.

See Also

SelectionEventArgs Class


MindFusion.Diagramming.SelectionEventArgs Constructor

SelectionEventArgs Constructor
[image]

Initializes a new instance of the SelectionEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SelectionEventArgs (
PointF mousePosition,
AdjustmentHandle adjustmentHandle
)

Visual Basic [image] Copy Code

Public New ( _
mousePosition As PointF, _
adjustmentHandle As AdjustmentHandle _
)

Parameters

mousePosition

adjustmentHandle

See Also

SelectionEventArgs Class


MindFusion.Diagramming.SelectionEventArgs Properties

SelectionEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets the adjustment handle being moved by the user.
MousePosition | Gets the current mouse pointer position.

See Also

SelectionEventArgs Class


MindFusion.Diagramming.SelectionEventArgs.AdjustmentHandle Property

SelectionEventArgs.AdjustmentHandle Property
[image]

Gets the adjustment handle being moved by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AdjustmentHandle AdjustmentHandle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AdjustmentHandle As AdjustmentHandle

Property Value

See Also

SelectionEventArgs Members
SelectionEventArgs Class


MindFusion.Diagramming.SelectionEventArgs.MousePosition Property

SelectionEventArgs.MousePosition Property
[image]

Gets the current mouse pointer position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointF MousePosition { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MousePosition As PointF

Property Value

See Also

SelectionEventArgs Members
SelectionEventArgs Class


MindFusion.Diagramming.SelectionStyle Enumeration

SelectionStyle Enumeration
[image]

Defines values that specify how multiple selected items are indicated visually.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum SelectionStyle

Visual Basic [image] Copy Code

Public Enum SelectionStyle

Members

Member name | Description
SelectionHandles | Rectangular manipulation handles are painted over selected items.
Frame | A dashed rectangle is drawn around selected items.

Remarks

These values affect multiple selection of items. If only a single item is selected, it is drawn with manipulation handles around it.

See Also


MindFusion.Diagramming.SelectionValidationEventArgs Class

SelectionValidationEventArgs Class
[image]

Contains the arguments passed to the SelectionModifying event handler.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class SelectionValidationEventArgs : SelectionEventArgs

Visual Basic [image] Copy Code

Public Class SelectionValidationEventArgs
Inherits SelectionEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.SelectionEventArgs
MindFusion.Diagramming.SelectionValidationEventArgs

See Also

SelectionValidationEventArgs Members


MindFusion.Diagramming.SelectionValidationEventArgs Members

SelectionValidationEventArgs Members
Constructors Properties Methods
[image]

Contains the arguments passed to the SelectionModifying event handler.

The following tables list the members exposed by the SelectionValidationEventArgs type.

Public Constructors

Name | Description
SelectionValidationEventArgs | Initializes a new instance of the SelectionValidationEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets the adjustment handle being moved by the user. (Inherited from SelectionEventArgs.)
Cancel | Gets or sets a value indicating whether to prevent the user from completing the operation.
MousePosition | Gets the current mouse pointer position. (Inherited from SelectionEventArgs.)

Public Methods

Name | Description
CancelDrag | Cancels the modification of the selected items.

See Also

SelectionValidationEventArgs Class


MindFusion.Diagramming.SelectionValidationEventArgs Constructor

SelectionValidationEventArgs Constructor
[image]

Initializes a new instance of the SelectionValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SelectionValidationEventArgs (
PointF mousePosition,
AdjustmentHandle adjustmentHandle
)

Visual Basic [image] Copy Code

Public New ( _
mousePosition As PointF, _
adjustmentHandle As AdjustmentHandle _
)

Parameters

mousePosition

adjustmentHandle

See Also

SelectionValidationEventArgs Class


MindFusion.Diagramming.SelectionValidationEventArgs Methods

SelectionValidationEventArgs Methods
[image]

Public Methods

Name | Description
CancelDrag | Cancels the modification of the selected items.

See Also

SelectionValidationEventArgs Class


MindFusion.Diagramming.SelectionValidationEventArgs.CancelDrag Method

SelectionValidationEventArgs.CancelDrag Method
[image]

Cancels the modification of the selected items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void CancelDrag ()

Visual Basic [image] Copy Code

Public Sub CancelDrag ()

See Also

SelectionValidationEventArgs Members
SelectionValidationEventArgs Class


MindFusion.Diagramming.SelectionValidationEventArgs Properties

SelectionValidationEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets the adjustment handle being moved by the user. (Inherited from SelectionEventArgs.)
Cancel | Gets or sets a value indicating whether to prevent the user from completing the operation.
MousePosition | Gets the current mouse pointer position. (Inherited from SelectionEventArgs.)

See Also

SelectionValidationEventArgs Class


MindFusion.Diagramming.SelectionValidationEventArgs.Cancel Property

SelectionValidationEventArgs.Cancel Property
[image]

Gets or sets a value indicating whether to prevent the user from completing the operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

See Also

SelectionValidationEventArgs Members
SelectionValidationEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs Class

SerializeTagEventArgs Class
[image]

Contains the arguments passed to the SerializeTag and DeserializeTag event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class SerializeTagEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class SerializeTagEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.SerializeTagEventArgs

See Also

SerializeTagEventArgs Members


MindFusion.Diagramming.SerializeTagEventArgs Members

SerializeTagEventArgs Members
Properties
[image]

Contains the arguments passed to the SerializeTag and DeserializeTag event handlers.

The following tables list the members exposed by the SerializeTagEventArgs type.

Public Properties

Name | Description
Context | Gets a context object that can help you write and read various values.
Handled | Gets or sets a value indicating whether the event is handled.
Object | Gets the diagram element whose tag is being serialized/deserialized.
PropertyName | Gets the name of the property being serialized.
Representation | Gets or sets an XmlElement object where the tag should be serialized/deserialized.
Tag | Gets or sets the tag object being serialized/deserialized.

See Also

SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs Properties

SerializeTagEventArgs Properties
[image]

Public Properties

Name | Description
Context | Gets a context object that can help you write and read various values.
Handled | Gets or sets a value indicating whether the event is handled.
Object | Gets the diagram element whose tag is being serialized/deserialized.
PropertyName | Gets the name of the property being serialized.
Representation | Gets or sets an XmlElement object where the tag should be serialized/deserialized.
Tag | Gets or sets the tag object being serialized/deserialized.

See Also

SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs.Context Property

SerializeTagEventArgs.Context Property
[image]

Gets a context object that can help you write and read various values.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlPersistContext Context { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Context As XmlPersistContext

Property Value

An instance of the XmlPersistContext class.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs.Handled Property

SerializeTagEventArgs.Handled Property
[image]

Gets or sets a value indicating whether the event is handled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Handled { get; set; }

Visual Basic [image] Copy Code

Public Property Handled As Boolean

Property Value

true if you have serialized/deserialized the tag object; otherwise, false.

Remarks

Always set this flag to true if you perform custom tag serialization.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs.Object Property

SerializeTagEventArgs.Object Property
[image]

Gets the diagram element whose tag is being serialized/deserialized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Object { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Object As Object

Property Value

A diagram item, group, cell or anchor point.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs.PropertyName Property

SerializeTagEventArgs.PropertyName Property
[image]

Gets the name of the property being serialized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string PropertyName { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PropertyName As String

Property Value

Either "Id" or "Tag", indicating which property is being serialized.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs.Representation Property

SerializeTagEventArgs.Representation Property
[image]

Gets or sets an XmlElement object where the tag should be serialized/deserialized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement Representation { get; set; }

Visual Basic [image] Copy Code

Public Property Representation As XmlElement

Property Value

An instance of the .NET XmlElement class that represents the root of the XML branch where the tag is / should be stored.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs.Tag Property

SerializeTagEventArgs.Tag Property
[image]

Gets or sets the tag object being serialized/deserialized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An object containing the custom tag data.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Diagramming.ShadowsStyle Enumeration

ShadowsStyle Enumeration
[image]

Enumerates possible shadows-drawing styles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum ShadowsStyle

Visual Basic [image] Copy Code

Public Enum ShadowsStyle

Members

Member name | Description
None | No shadows are drawn.
OneLevel | All shadows are drawn at the lowest z-level, and appear to be on one level.
ZOrder | Every shadows is drawn just below its item, possibly covering other items.

Remarks

This enumeration provides the possible values for the ShadowsStyle property of the Diagram class.

See Also

ShadowsStyle Property


MindFusion.Diagramming.Shape Class

Shape Class
Remarks See Also
[image]

An instance of this class represents a shape defined through a series of arc, line and Bйzier segments. The segments can be a part of the shape outline, in which case they define the part of the shape is filled, used for hit-testing and for aligning links to the node edges. Segments can also be added as decoration elements, in which case they only affect the appearance of a ShapeNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Shape : ICloneable, IPersists

Visual Basic [image] Copy Code

Public Class Shape
Implements ICloneable, IPersists

Remarks

Shape Definitions

The Shape class provides the means for defining complex node shapes. With its help you can design any shape composed of lines, arcs and Bйzier-curves. A shape template should contain an outline to be used for hit testing, clipping and finding intersections with other items. If the outline is not defined, the rectangle specified by the Bounds property of nodes is used for hit-testing. Optionally, shapes can contain decoration elements and text region definitions. Decorations are visual elements that do not take part in clipping, and are used for hit-testing only if DecorationHitTesting is enabled. Text regions are the parts of shapes in which node's text is laid out and rendered.

Predefined Shapes

MvcDiagram provides a set of about 100 predefined shape templates accessible through the static Shapes collection and the FromId method of Shape. A shape template can be applied to a node by assigning it to the Shape property of shape nodes. The predefined shapes are also exposed as properties of the Shapes class.

Custom Shapes

There are several Shape constructor overrides you might choose from, depending on the complexity of the shapes you want to create. They take arrays of ElementTemplate objects as arguments, which define the outline, decorations and text region definitions. Templates are described with coordinates expressed as percents of a shape node's area. It is also possible to associate an image with a shape definition by means of the Image property and to define the area in which the image is displayed by ImageRectangle.

Dynamic Shapes

Shapes defined via ElementTemplate objects are scaled proportionally to the size of nodes. If shape elements should scale non-uniformly, use the Shape(formula) constructor to define shapes through Visio-like formulas that take into consideration the current width and height of nodes. Another constructor takes a CreatePathDelegate parameter that can be used to define shapes via .NET functions.

A formula shape can be parameterized by adding ShapeControlPoint objects to the shape's ControlPoints collection. The control point positions are passed as arguments to the shape scripts, where they can be used to modify the node's appearance. For example, the following code defines a rounded rectangle shape, whose corner radius can be modified by users via the control point.

C# [image] Copy Code

// a rounded rectangle shape, with an arc at each corner
string roundRect = @"
r = Min(Width / 2, radius.X);
MoveTo(r, 0);
LineTo(Width - r, 0);
ArcTo(Width, r, false, false, r, r);
LineTo(Width, Height - r);
ArcTo(Width - r, Height, false, false, r, r);
LineTo(r, Height);
ArcTo(0, Height - r, false, false, r, r);
LineTo(0, r);
ArcTo(r, 0, false, false, r, r);
";

var myRect = new Shape(roundRect, "MyRect");

// add a control point for the 'radius' parameter
myRect.ControlPoints.Add(new ShapeControlPoint(
"radius", 5, 1, 15, UnitType.Fixed, 0, 0, 0, UnitType.Fixed));

Shape Libraries

The ShapeDesigner tool included in the MvcDiagram suite lets you draw custom shapes and store them in shape libraries. A library file can be loaded into your application using the ShapeLibrary class. The definitions loaded from a shape library are automatically added to the Shapes collection and can be accessed through the FromId method, just as the predefined shapes.

Link Arrowheads

A Shape instance can be assigned to the HeadShape, BaseShape or IntermediateShape properties of a DiagramLink. When used for arrowheads, position (50, 0) in the shape definition corresponds to the arrowhead's tip point. Several predefined arrowhead shapes are provided as static properties of the ArrowHeads class.

Example

Here is how the DirectAccessStorage shape is defined in the MvcDiagram source code:

C# [image] Copy Code

new Shape(

// Outlines
new ElementTemplate[]
{
new LineTemplate(10, 0, 90, 0),
new ArcTemplate(80, 0, 20, 100, -90, 180),
new LineTemplate(90, 100, 10, 100),
new ArcTemplate(0, 0, 20, 100, 90, 180)
},

// Decorations
new ElementTemplate[]
{
new ArcTemplate(0, 0, 20, 100, -90, 180)
},

// Text area
new ElementTemplate[]
{
new LineTemplate(10, 0, 90, 0),
new ArcTemplate(80, 0, 20, 100, -90, 180),
new LineTemplate(90, 100, 10, 100),
new BezierTemplate(10, 100, 35, 66, 35, 33, 10, 0)
},

FillMode.Winding, "DirectAccessStorage");

Visual Basic [image] Copy Code

New Shape( _
New ElementTemplate() _
{ _
New LineTemplate(10, 0, 90, 0), _
New ArcTemplate(80, 0, 20, 100, -90, 180), _
New LineTemplate(90, 100, 10, 100), _
New ArcTemplate(0, 0, 20, 100, 90, 180) _
}, _
New ElementTemplate() _
{ _
New ArcTemplate(0, 0, 20, 100, -90, 180) _
}, _
New ElementTemplate() _
{ _
New LineTemplate(10, 0, 90, 0), _
New ArcTemplate(80, 0, 20, 100, -90, 180), _
New LineTemplate(90, 100, 10, 100), _
New BezierTemplate(10, 100, 35, 66, 35, 33, 10, 0) _
}, _
FillMode.Winding, "DirectAccessStorage")

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Shape

See Also

Shape Members


MindFusion.Diagramming.Shape Members

Shape Members
Constructors Properties Methods
[image]

An instance of this class represents a shape defined through a series of arc, line and Bйzier segments. The segments can be a part of the shape outline, in which case they define the part of the shape is filled, used for hit-testing and for aligning links to the node edges. Segments can also be added as decoration elements, in which case they only affect the appearance of a ShapeNode.

The following tables list the members exposed by the Shape type.

Public Constructors

Name | Description
Shape | Overloaded. Initializes a new instance of the Shape class.

Public Properties

Name | Description
AnchorPattern | Gets or sets the default anchor pattern for nodes that use this shape.
ControlPoints | A list of ShapeControlPoint objects that let users adjust a node's shape.
DecorationHitTesting | Gets or sets a value indicating whether decoration lines should be considered when hit-testing.
Decorations | Gets or sets a list with all decorations of this shape.
DecorationsFormula | Gets or sets a formula describing the shape decorations depending on the current width and height of the node.
DisplayName | Specifies the name that should be displayed for this shape in user interface objects, for example the ShapeListBox or ShapeToolBar.
EnableOutline | Gets or sets a value indicating whether to enable the shape's outline.
FillMode | Gets or sets a value indicating how areas are filled if the outline path of the shape intersects itself.
Id | Gets or sets the shape identifier.
Image | Gets or sets the image displayed in all instances of this shape.
ImageLocation | Gets or sets the path to the file that contains the image displayed in this shape.
ImageRectangle | Gets or sets the position of the images displayed in instances of this shape.
IsArrowhead | Specifies if this shape is used as arrowhead.
LinkSegmentInset | Specifies what length of link's line segment is drawn inside the arrowhead shape, expressed as percents of arrowhead size.
Outline | Gets or sets the outline of this shape.
OutlineFormula | Gets or sets a formula describing the shape outline depending on the current width and height of the node.
ShapeDecorations | Gets or sets the ShapeDecoration objects associated with this shape.
Shapes | Gets a read-only collection of all named shapes.
TextArea | Gets or sets the outline of the text area of this shape.

Public Methods

Name | Description
Clone | Creates an exact copy of this shape.
Draw | Overloaded. Draws this shape on an IGraphics surface.
Equals | Checks whether this shape template is equivalent to the specified shape.
FromId | Returns a reference to the shape with the specified string identifier.
FromSvg | Overloaded. Creates a Shape from the outline of an SVG drawing.
GetHitPath | Overloaded.
GetRenderingPath | Overloaded.
LoadFromXml | Loads the shape content from an XML element.
SaveToXml | Saves the shape content into an XML element.
ToString | Returns the identifier of this shape template.

See Also

Shape Class


MindFusion.Diagramming.Shape Constructor

Shape Constructor
[image]

Initializes a new instance of the Shape class.

Overload List

Name | Description
Shape (Byte[]) | Initializes a new instance of the Shape class with the specified outline.
Shape (Byte[], String) | Initializes a new instance of the Shape class with the specified outline and id.
Shape (CreatePathDelegate, CreatePathDelegate, String) | Initializes a new instance of the Shape class with the specified outline and decorations callbacks and id.
Shape (CreatePathDelegate, String) | Initializes a new instance of the Shape class with the specified outline delegate and id.
Shape (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillMode) | Initializes a new instance of the Shape class with the specified outline, decorations and text area.
Shape (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillMode, String) | Initializes a new instance of the Shape class with the specified outline, decorations, text area and id.
Shape (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillMode, String, ShapeDecoration[]) | Initializes a new instance of the Shape class with the specified outline, decorations, text area and id.
Shape (ElementTemplate[], FillMode) | Initializes a new instance of the Shape class with the specified outline.
Shape (ElementTemplate[], FillMode, String) | Initializes a new instance of the Shape class with the specified outline and id.
Shape (String, String) | Initializes a new instance of the Shape class with the specified outline formula and id.
Shape (String, String, List(ShapeControlPoint), String) | Initializes a new instance of the Shape class with the specified outline and decorations formulas, control points and id.
Shape (String, String, String) | Initializes a new instance of the Shape class with the specified outline and decorations formulas and id.

See Also

Shape Class


MindFusion.Diagramming.Shape Constructor (Byte[])

Shape Constructor (Byte[])
See Also
[image]

Initializes a new instance of the Shape class with the specified outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
byte[] outline
)

Visual Basic [image] Copy Code

Public New ( _
outline() As Byte _
)

Parameters

outline
An array containing even number of coordinate values, which define the points of the shape outline.

Remarks

The specified array should contain even number of values. Each odd value represents the X-coordinate and each even value represents the Y-coordinate of the corresponding point in the shape outline. The point coordinates are expressed in numbers in the interval [0..100] indicating the position of this point relative to the node's bounding rectangle.

Exceptions

Exception Type | Condition
ArgumentException | The specified array is a null reference (Nothing in Visual Basic), does not contain even number of elements or contains less than six arguments.

See Also

Shape Constructor Overload List
Shape Class


MindFusion.Diagramming.Shape Constructor (Byte[], String)

Shape Constructor (Byte[], String)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline and id.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
byte[] outline,
string id
)

Visual Basic [image] Copy Code

Public New ( _
outline() As Byte, _
id As String _
)

Parameters

outline
An array containing even number of coordinate values, which define the points of the shape outline.
id
The string identifier of the new shape.

Remarks

The specified array should contain even number of values. Each odd value represents the X-coordinate and each even value represents the Y-coordinate of the corresponding point in the shape outline. The point coordinates are expressed in numbers in the interval [0..100] indicating the position of this point relative to the node's bounding rectangle.

Exceptions

Exception Type | Condition
ArgumentException | The specified array is a null reference (Nothing in Visual Basic), does not contain even number of elements or contains less than six arguments.

See Also

Shape Constructor Overload List
Shape Class


MindFusion.Diagramming.Shape Constructor (CreatePathDelegate, CreatePathDelegate, String)

Shape Constructor (CreatePathDelegate, CreatePathDelegate, String)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline and decorations callbacks and id.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
CreatePathDelegate outlineDelegate,
CreatePathDelegate decorationsDelegate,
string id
)

Visual Basic [image] Copy Code

Public New ( _
outlineDelegate As CreatePathDelegate, _
decorationsDelegate As CreatePathDelegate, _
id As String _
)

Parameters

outlineDelegate
A delegate called to generate GraphicsPath objects representing the shape outline.
decorationsDelegate
A delegate called to generate GraphicsPath objects representing the shape decorations.
id

The string identifier of the new shape.

See Also

Shape Constructor Overload List
Shape Class
ShapeData Class


MindFusion.Diagramming.Shape Constructor (CreatePathDelegate, String)

Shape Constructor (CreatePathDelegate, String)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline delegate and id.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
CreatePathDelegate outlineDelegate,
string id
)

Visual Basic [image] Copy Code

Public New ( _
outlineDelegate As CreatePathDelegate, _
id As String _
)

Parameters

outlineDelegate
A delegate called to generate GraphicsPath objects representing the shape outline.
id

The string identifier of the new shape.

Example

This example creates a triangular shape:

C# [image] Copy Code

Shape shape = new Shape(CreatePath, "my shape");

GraphicsPath CreatePath(RectangleF shapeData)
{
GraphicsPath path = new GraphicsPath();
path.AddLine(10, 0, shapeData.Width, 10);
path.AddLine(shapeData.Width, 10, shapeData.Width / 2, shapeData.Height);
path.CloseAllFigures();
return path;
}

See Also

Shape Constructor Overload List
Shape Class
ShapeData Class


MindFusion.Diagramming.Shape Constructor (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillMode)

Shape Constructor (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillMode)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline, decorations and text area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
ElementTemplate[] elements,
ElementTemplate[] decorations,
ElementTemplate[] textArea,
FillMode fillMode
)

Visual Basic [image] Copy Code

Public Sub Shape ( _
elements As ElementTemplate(), _
decorations As ElementTemplate(), _
textArea As ElementTemplate(), _
fillMode As FillMode _
)

Parameters

elements
An array of shape template elements that define the outline of a shape. Can contain lines, arcs and Bйzier curves.
decorations
An array of shape template elements that define shape decorations. Can contain lines, arcs and Bйzier curves. Decorations are visual elements that do not take part in hit testing and clipping.
textArea
An array of shape template elements that define the region of a node in which text is laid out and rendered. Can contain lines, arcs and Bйzier curves. Latter two are approximated to polygons by the text-formatting algorithm.
fillMode
Specifies how areas are filled if the outline path intersects itself.

See Also

Shape Constructor Overload List
Shape Class


MindFusion.Diagramming.Shape Constructor (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillMode, String)

Shape Constructor (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillMode, String)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline, decorations, text area and id.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
ElementTemplate[] elements,
ElementTemplate[] decorations,
ElementTemplate[] textArea,
FillMode fillMode,
string id
)

Visual Basic [image] Copy Code

Public Sub Shape ( _
elements As ElementTemplate(), _
decorations As ElementTemplate(), _
textArea As ElementTemplate(), _
fillMode As FillMode, _
id As String _
)

Parameters

elements
An array of shape template elements that define the outline of a shape. Can contain lines, arcs and Bйzier curves.
decorations
An array of shape template elements that define shape decorations. Can contain lines, arcs and Bйzier curves. Decorations are visual elements that do not take part in hit testing and clipping.
textArea

An array of shape template elements that define the region of a node in which text is laid out and rendered. Can contain lines, arcs and Bйzier curves. Latter two are approximated to polygons by the text-formatting algorithm.

fillMode
Specifies how areas are filled if the outline path intersects itself.
id
The string identifier of the new shape.

See Also

Shape Constructor Overload List
Shape Class


MindFusion.Diagramming.Shape Constructor (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillMode, String, ShapeDecoration[])

Shape Constructor (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillMode, String, ShapeDecoration[])
See Also
[image]

Initializes a new instance of the Shape class with the specified outline, decorations, text area and id.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
ElementTemplate[] elements,
ElementTemplate[] decorations,
ElementTemplate[] textArea,
FillMode fillMode,
string id,
ShapeDecoration[] closedDecorations
)

Visual Basic [image] Copy Code

Public New ( _
elements() As ElementTemplate, _
decorations() As ElementTemplate, _
textArea() As ElementTemplate, _
fillMode As FillMode, _
id As String, _
closedDecorations() As ShapeDecoration _
)

Parameters

elements

An array of shape template elements that define the outline of a shape. Can contain lines, arcs and Bйzier curves.

decorations

An array of shape template elements that define shape decorations. Can contain lines, arcs and Bйzier curves. Decorations are visual elements that do not take part in hit testing and clipping.

textArea

An array of shape template elements that define the region of a node in which text is laid out and rendered. Can contain lines, arcs and Bйzier curves. Latter two are approximated to polygons by the text-formatting algorithm.

fillMode

Specifies how areas are filled if the outline path intersects itself.

id

The string identifier of the new shape.

closedDecorations

An array of ShapeDecoration objects.

See Also

Shape Constructor Overload List
Shape Class


MindFusion.Diagramming.Shape Constructor (ElementTemplate[], FillMode)

Shape Constructor (ElementTemplate[], FillMode)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
ElementTemplate[] elements,
FillMode fillMode
)

Visual Basic [image] Copy Code

Public Sub Shape ( _
elements As ElementTemplate(), _
fillMode As FillMode _
)

Parameters

elements
An array of shape template elements that define the outline of a shape. Can contain lines, arcs and Bйzier curves.
fillMode
Specifies how areas are filled if the outline path intersects itself.

Example

C# [image] Copy Code

diagram.DefaultShape = new Shape(
new ElementTemplate[] {
new LineTemplate(0, 100, 35, 0),
new LineTemplate(35, 0, 100, 0),
new LineTemplate(100, 0, 65, 100),
new LineTemplate(65, 100, 0, 100) },
FillMode.Winding);

Visual Basic [image] Copy Code

diagram.DefaultShape = new Shape( _
new ElementTemplate() { _
new LineTemplate(0, 100, 35, 0), _
new LineTemplate(35, 0, 100, 0), _
new LineTemplate(100, 0, 65, 100), _
new LineTemplate(65, 100, 0, 100) }, _
FillMode.Winding)

See Also

Shape Constructor Overload List
Shape Class


MindFusion.Diagramming.Shape Constructor (ElementTemplate[], FillMode, String)

Shape Constructor (ElementTemplate[], FillMode, String)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline and id.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
ElementTemplate[] elements,
FillMode fillMode,
string id
)

Visual Basic [image] Copy Code

Public Sub Shape ( _
elements As ElementTemplate(), _
fillMode As FillMode, _
id As String _
)

Parameters

elements
Refers to an array of shape template elements that define the outline of a shape. Can contain lines, arcs and Bйzier curves.
fillMode
Specifies how areas are filled if the outline path intersects itself.
id
The string identifier of the new shape.

See Also

Shape Constructor Overload List
Shape Class


MindFusion.Diagramming.Shape Constructor (String, String)

Shape Constructor (String, String)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline formula and id.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
string outlineFormula,
string id
)

Visual Basic [image] Copy Code

Public New ( _
outlineFormula As String, _
id As String _
)

Parameters

outlineFormula

A string containing the formula that defines the shape.

id

The string identifier of the new shape.

Remarks

Shape formulas are small scripts that call one of the following functions to add graphics to the shape:

Function | Description
MoveTo (x,y) | Moves the current position to the specified point without drawing.
LineTo (x,y) | Draws a line from the current position to the specified point.
BezierTo (x1,y1,x2,y2,x3,y3) | Draws a Bezier curve from the current position to (x3,y3) using (x1,y1) and (x2,y2) as control points.
ArcTo (x,y,largeArc,clockwiseArc,rx,ry) | Draws an arc from the specified point to (x,y) where rx and ry are the ellipse radiuses and the arc flags are boolean values specifying which of the four possible arcs to draw.

Each of them starts drawing from the current position and changes the current position to their point argument after drawing. In addition, the scripts can access the current size of the node through the Width and Height variables.

Example

This sample creates an arrow shape with fixed shaft width and arrowhead length, which will still shrink when the node gets small due to the Min calls.

C# [image] Copy Code
string outline = @"
my = Height / 2;
ah = Min(10, Height / 4);
aw = Min(20, Width / 2);
MoveTo(0, my - ah);
LineTo(Width - aw, my - ah);
LineTo(Width - aw, 0);
LineTo(Width, my);
LineTo(Width - aw, Height);
LineTo(Width - aw, my + ah);
LineTo(0, my + ah);
";
Shape shape = new Shape(outline, "my shape");

See Also

Shape Constructor Overload List
Shape Class
OutlineFormula Property


MindFusion.Diagramming.Shape Constructor (String, String, List(ShapeControlPoint), String)

Shape Constructor (String, String, List(ShapeControlPoint), String)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline and decorations formulas, control points and id.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
string outlineFormula,
string decorationsFormula,
List<ShapeControlPoint> controlPoints,
string id
)

Visual Basic [image] Copy Code

Public New ( _
outlineFormula As String, _
decorationsFormula As String, _
controlPoints As List(Of ShapeControlPoint), _
id As String _
)

Parameters

outlineFormula

A string containing the formula that defines the shape.

decorationsFormula

A string containing the formula that defines the shape.

controlPoints

A list of ShapeControlPoint objects that let users adjust the shape.

id

The string identifier of the new shape.

Remarks

Shape formulas are small scripts that call one of the following functions to add graphics to the shape:

Function | Description
MoveTo (x,y) | Moves the current position to the specified point without drawing.
LineTo (x,y) | Draws a line from the current position to the specified point.
BezierTo (x1,y1,x2,y2,x3,y3) | Draws a Bezier curve from the current position to (x3,y3) using (x1,y1) and (x2,y2) as control points.
ArcTo (x,y,largeArc,clockwiseArc,rx,ry) | Draws an arc from the specified point to (x,y) where rx and ry are the ellipse radiuses and the arc flags are boolean values specifying which of the four possible arcs to draw.

Each of them starts drawing from the current position and changes the current position to their point argument after drawing. In addition, the scripts can access the current size of the node through the Width and Height variables.

See Also

Shape Constructor Overload List
Shape Class
MindFusion.Diagramming Namespace
OutlineFormula Property
DecorationsFormula Property
ControlPoints Property


MindFusion.Diagramming.Shape Constructor (String, String, String)

Shape Constructor (String, String, String)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline and decorations formulas and id.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
string outlineFormula,
string decorationsFormula,
string id
)

Visual Basic [image] Copy Code

Public New ( _
outlineFormula As String, _
decorationsFormula As String, _
id As String _
)

Parameters

outlineFormula
A string containing the formula that defines the shape outline.
decorationsFormula
A string containing the formula that defines the shape decorations.
id

The string identifier of the new shape.

Remarks

Shape formulas are small scripts that call one of the following functions to add graphics to the shape:

Function | Description
MoveTo (x,y) | Moves the current position to the specified point without drawing.
LineTo (x,y) | Draws a line from the current position to the specified point.
BezierTo (x1,y1,x2,y2,x3,y3) | Draws a Bezier curve from the current position to (x3,y3) using (x1,y1) and (x2,y2) as control points.
ArcTo (x,y,largeArc,clockwiseArc,rx,ry) | Draws an arc from the specified point to (x,y) where rx and ry are the ellipse radiuses and the arc flags are boolean values specifying which of the four possible arcs to draw.

Each of them starts drawing from the current position and changes the current position to their point argument after drawing. In addition, the scripts can access the current size of the node through the Width and Height variables.

See Also

Shape Constructor Overload List
Shape Class
MindFusion.Diagramming Namespace
OutlineFormula Property
DecorationsFormula Property


MindFusion.Diagramming.Shape Methods

Shape Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this shape.
Draw | Overloaded. Draws this shape on an IGraphics surface.
Equals | Checks whether this shape template is equivalent to the specified shape.
FromId | Returns a reference to the shape with the specified string identifier.
FromSvg | Overloaded. Creates a Shape from the outline of an SVG drawing.
GetHitPath | Overloaded.
GetRenderingPath | Overloaded.
LoadFromXml | Loads the shape content from an XML element.
SaveToXml | Saves the shape content into an XML element.
ToString | Returns the identifier of this shape template.

See Also

Shape Class


MindFusion.Diagramming.Shape.Clone Method

Shape.Clone Method
[image]

Creates an exact copy of this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

An instance of the Shape class representing the newly created clone.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.Draw Method

Shape.Draw Method
[image]

Draws this shape on an IGraphics surface.

Overload List

Name | Description
Shape.Draw (IGraphics, Brush, Pen, Boolean) | Draws this shape on the specified IGraphics surface.
Shape.Draw (IGraphics, Brush, Pen, Boolean, RectangleF, Single) | Draws this shape on the specified IGraphics surface.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.Draw Method (IGraphics, Brush, Pen, Boolean)

Shape.Draw Method (IGraphics, Brush, Pen, Boolean)
See Also
[image]

Draws this shape on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Draw (
IGraphics drawingContext,
Brush brush,
Pen pen,
bool shadow
)

Visual Basic [image] Copy Code

Public Sub Draw( _
drawingContext As IGraphics, _
brush As Brush, _
pen As Pen, _
shadow As Boolean _
)

Parameters

drawingContext

The IGraphics to draw the shape on.

brush

A Brush used to fill the shape.

pen

A Pen used to draw the shape outline.

shadow

When shadow is true the brush and pen parameters have higher priority over shape's brush and pen.

See Also

Draw Method Overload List
Shape Members
Shape Class


MindFusion.Diagramming.Shape.Draw Method (IGraphics, Brush, Pen, Boolean, RectangleF, Single)

Shape.Draw Method (IGraphics, Brush, Pen, Boolean, RectangleF, Single)
See Also
[image]

Draws this shape on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Draw (
IGraphics drawingContext,
Brush brush,
Pen pen,
bool shadow,
RectangleF rc,
float orientation
)

Visual Basic [image] Copy Code

Public Sub Draw( _
drawingContext As IGraphics, _
brush As Brush, _
pen As Pen, _
shadow As Boolean, _
rc As RectangleF, _
orientation As Single _
)

Parameters

drawingContext

The IGraphics to draw the shape on.

brush

A Brush used to fill the shape.

pen

A Pen used to draw the shape outline.

shadow

When shadow is true the brush and pen parameters have higher priority over shape's brush and pen.

rc

The bounding rectangle.

orientation

Orientation of the shape.

See Also

Draw Method Overload List
Shape Members
Shape Class


MindFusion.Diagramming.Shape.Equals Method

Shape.Equals Method
[image]

Checks whether this shape template is equivalent to the specified shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public new bool Equals (
Shape shape
)

Visual Basic [image] Copy Code

Public Shadows Function Equals ( _
shape As Shape _
) As Boolean

Parameters

shape
The shape to check for equality with the current shape.

Return Value

true if the current shape is equivalent to the specified shape; otherwise, false.

Remarks

Two shapes are considered equivalent if they have the same fill type, the same number and type of segments and if the points of those segments are close enough to each other.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.FromId Method

Shape.FromId Method
[image]

Returns a reference to the shape with the specified string identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape FromId (
string id
)

Visual Basic [image] Copy Code

Public Shared Function FromId ( _
id As String _
) As Shape

Parameters

id
The identifier of the shape of interest.

Return Value

A reference to the Shape with the specified identifier or a null reference (Nothing in Visual Basic) if there is no such shape.

Remarks

The id argument should match an identifier passed to a constructor of the existing shape templates.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.FromSvg Method

Shape.FromSvg Method
[image]

Creates a Shape from the outline of an SVG drawing.

Overload List

Name | Description
Shape.FromSvg (SvgContent) | Creates a Shape from the outline of an SVG drawing.
Shape.FromSvg (SvgContent, Boolean) | Creates a Shape from the outline of an SVG drawing.
Shape.FromSvg (SvgContent, Boolean, Boolean) | Creates a Shape from the outline of an SVG drawing.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.FromSvg Method (SvgContent)

Shape.FromSvg Method (SvgContent)
See Also
[image]

Creates a Shape from the outline of an SVG drawing.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape FromSvg (
SvgContent svgContent
)

Visual Basic [image] Copy Code

Public Shared Function FromSvg ( _
svgContent As SvgContent _
) As Shape

Parameters

svgContent

An SvgContent object representing the SVG drawing.

Return Value

A Shape generated from the specified SVG drawing.

Remarks

SVG drawings do not contain intrinsic semantic information about which elements of a drawing should be considered its outline. However the Shape class is primarily concerned with the outlines of nodes, for drawing, hit-testing and link alignment purposes. If you need the filled interior of nodes and the positions of links connected to them to match the SVG content, call this method to generate a shape outline from SVG, and assign the result to the nodes' Shape property. The shape outline is generated using a convex-hull algorithm.

See Also

FromSvg Method Overload List
Shape Members
Shape Class


MindFusion.Diagramming.Shape.FromSvg Method (SvgContent, Boolean)

Shape.FromSvg Method (SvgContent, Boolean)
See Also
[image]

Creates a Shape from the outline of an SVG drawing.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape FromSvg (
SvgContent svgContent,
bool stretch
)

Visual Basic [image] Copy Code

Public Shared Function FromSvg ( _
svgContent As SvgContent, _
stretch As Boolean _
) As Shape

Parameters

svgContent

An SvgContent object representing the SVG drawing.

stretch
Sets whether the Shape outline generated from SVG should be stretched to fill the entire shape definition range [0-100, 0-100], or should be scaled uniformly to preserve the original aspect ratio of the drawing. In effect, this specifies whether the shape will match the SVG drawing when ContentAlign is set to Stretch or Fit.

Return Value

A Shape generated from the specified SVG drawing.

Remarks

SVG drawings do not contain intrinsic semantic information about which elements of a drawing should be considered its outline. However the Shape class is primarily concerned with the outlines of nodes, for drawing, hit-testing and link alignment purposes. If you need the filled interior of nodes and the positions of links connected to them to match the SVG content, call this method to generate a shape outline from SVG, and assign the result to the nodes' Shape property. The shape outline is generated using a convex-hull algorithm.

See Also

FromSvg Method Overload List
Shape Members
Shape Class


MindFusion.Diagramming.Shape.FromSvg Method (SvgContent, Boolean, Boolean)

Shape.FromSvg Method (SvgContent, Boolean, Boolean)
See Also
[image]

Creates a Shape from the outline of an SVG drawing.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape FromSvg (
SvgContent svgContent,
bool stretch,
bool concave
)

Visual Basic [image] Copy Code

Public Shared Function FromSvg( _
svgContent As SvgContent, _
stretch As Boolean, _
concave As Boolean _
) As Shape

Parameters

svgContent

An SvgContent object representing the SVG drawing.

stretch

Specifies whether the Shape outline should match the SVG drawing when ContentAlign is set to Stretch.

concave

Specifies whether the Shape outline should be defined by a concave hull.

Return Value

A Shape generated from the specified SVG drawing.

See Also

FromSvg Method Overload List
Shape Members
Shape Class


MindFusion.Diagramming.Shape.GetHitPath Method

Shape.GetHitPath Method
[image]

Overload List

Name | Description
Shape.GetHitPath (RectangleF, Single, Single) | Returns a GraphicsPath object corresponding to the outline of the specified shape when rotated at the specified angle. This GraphicsPath can be used for hit-testing and intersection checks.
Shape.GetHitPath (RectangleF, Single, Single, Dictionary(String, ShapeFormulaParam)) | Returns a GraphicsPath object corresponding to the outline of the specified shape when rotated at the specified angle. That GraphicsPath can be used for hit-testing and intersection checks.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.GetHitPath Method (RectangleF, Single, Single)

Shape.GetHitPath Method (RectangleF, Single, Single)
See Also
[image]

Returns a GraphicsPath object corresponding to the outline of the specified shape when rotated at the specified angle. This GraphicsPath can be used for hit-testing and intersection checks.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GraphicsPath GetHitPath (
RectangleF nodeBounds,
float rotationAngle,
float orientation
)

Visual Basic [image] Copy Code

Public Function GetHitPath( _
nodeBounds As RectangleF, _
rotationAngle As Single, _
orientation As Single _
) As GraphicsPath

Parameters

nodeBounds

rotationAngle

orientation

Return Value

See Also

GetHitPath Method Overload List
Shape Members
Shape Class


MindFusion.Diagramming.Shape.GetHitPath Method (RectangleF, Single, Single, Dictionary(String, ShapeFormulaParam))

Shape.GetHitPath Method (RectangleF, Single, Single, Dictionary(String, ShapeFormulaParam))
See Also
[image]

Returns a GraphicsPath object corresponding to the outline of the specified shape when rotated at the specified angle. That GraphicsPath can be used for hit-testing and intersection checks.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GraphicsPath GetHitPath (
RectangleF nodeBounds,
float rotationAngle,
float orientation,
Dictionary<string, ShapeFormulaParam> formulaParams
)

Visual Basic [image] Copy Code

Public Function GetHitPath( _
nodeBounds As RectangleF, _
rotationAngle As Single, _
orientation As Single, _
formulaParams As Dictionary(Of String, ShapeFormulaParam) _
) As GraphicsPath

Parameters

nodeBounds

The bounding rectangle of the ShapeNode.

rotationAngle

The node's rotation angle.

orientation

The shape's orientation angle.

formulaParams

A list of ShapeFormulaParam objects specifying the current positions of shape control points.

Return Value

A GraphicsPath representing the shape's outline.

See Also

GetHitPath Method Overload List
Shape Members
Shape Class


MindFusion.Diagramming.Shape.GetRenderingPath Method

Shape.GetRenderingPath Method
[image]

Overload List

Name | Description
Shape.GetRenderingPath (RectangleF, Single, Single) | Returns a GraphicsPath object corresponding to the outline of the shape when rotated at the specified angle. This GraphicsPath can (and should) be used when drawing the shape's outline.
Shape.GetRenderingPath (RectangleF, Single, Single, Dictionary(String, ShapeFormulaParam)) | Returns a GraphicsPath object corresponding to the outline of the shape when rotated at the specified angle. That GraphicsPath can be used when drawing the shape's outline.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.GetRenderingPath Method (RectangleF, Single, Single)

Shape.GetRenderingPath Method (RectangleF, Single, Single)
See Also
[image]

Returns a GraphicsPath object corresponding to the outline of the shape when rotated at the specified angle. This GraphicsPath can (and should) be used when drawing the shape's outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GraphicsPath GetRenderingPath (
RectangleF nodeBounds,
float rotationAngle,
float orientation
)

Visual Basic [image] Copy Code

Public Function GetRenderingPath( _
nodeBounds As RectangleF, _
rotationAngle As Single, _
orientation As Single _
) As GraphicsPath

Parameters

nodeBounds

rotationAngle

orientation

Return Value

Remarks

This method returns an empty GraphicsPath when EnableOutline is set to false regardless of the contents of the Outline property.

See Also

GetRenderingPath Method Overload List
Shape Members
Shape Class


MindFusion.Diagramming.Shape.GetRenderingPath Method (RectangleF, Single, Single, Dictionary(String, ShapeFormulaParam))

Shape.GetRenderingPath Method (RectangleF, Single, Single, Dictionary(String, ShapeFormulaParam))
See Also
[image]

Returns a GraphicsPath object corresponding to the outline of the shape when rotated at the specified angle. That GraphicsPath can be used when drawing the shape's outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GraphicsPath GetRenderingPath (
RectangleF nodeBounds,
float rotationAngle,
float orientation,
Dictionary<string, ShapeFormulaParam> formulaParams
)

Visual Basic [image] Copy Code

Public Function GetRenderingPath( _
nodeBounds As RectangleF, _
rotationAngle As Single, _
orientation As Single, _
formulaParams As Dictionary(Of String, ShapeFormulaParam) _
) As GraphicsPath

Parameters

nodeBounds

The bounding rectangle of the ShapeNode.

rotationAngle

The node's rotation angle.

orientation

The shape's orientation angle.

formulaParams

A list of ShapeFormulaParam objects specifying the current positions of shape control points.

Return Value

A GraphicsPath representing the shape's outline.

See Also

GetRenderingPath Method Overload List
Shape Members
Shape Class


MindFusion.Diagramming.Shape.LoadFromXml Method

Shape.LoadFromXml Method
[image]

Loads the shape content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
The XmlElement containing the shape's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

Shape Members
Shape Class
SaveToXml Method


MindFusion.Diagramming.Shape.SaveToXml Method

Shape.SaveToXml Method
[image]

Saves the shape content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub SaveToXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
The XmlElement the shape's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

Shape Members
Shape Class
LoadFromXml Method


MindFusion.Diagramming.Shape.ToString Method

Shape.ToString Method
[image]

Returns the identifier of this shape template.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string value representing the shape identifier.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape Properties

Shape Properties
[image]

Public Properties

Name | Description
AnchorPattern | Gets or sets the default anchor pattern for nodes that use this shape.
ControlPoints | A list of ShapeControlPoint objects that let users adjust a node's shape.
DecorationHitTesting | Gets or sets a value indicating whether decoration lines should be considered when hit-testing.
Decorations | Gets or sets a list with all decorations of this shape.
DecorationsFormula | Gets or sets a formula describing the shape decorations depending on the current width and height of the node.
DisplayName | Specifies the name that should be displayed for this shape in user interface objects, for example the ShapeListBox or ShapeToolBar.
EnableOutline | Gets or sets a value indicating whether to enable the shape's outline.
FillMode | Gets or sets a value indicating how areas are filled if the outline path of the shape intersects itself.
Id | Gets or sets the shape identifier.
Image | Gets or sets the image displayed in all instances of this shape.
ImageLocation | Gets or sets the path to the file that contains the image displayed in this shape.
ImageRectangle | Gets or sets the position of the images displayed in instances of this shape.
IsArrowhead | Specifies if this shape is used as arrowhead.
LinkSegmentInset | Specifies what length of link's line segment is drawn inside the arrowhead shape, expressed as percents of arrowhead size.
Outline | Gets or sets the outline of this shape.
OutlineFormula | Gets or sets a formula describing the shape outline depending on the current width and height of the node.
ShapeDecorations | Gets or sets the ShapeDecoration objects associated with this shape.
Shapes | Gets a read-only collection of all named shapes.
TextArea | Gets or sets the outline of the text area of this shape.

See Also

Shape Class


MindFusion.Diagramming.Shape.AnchorPattern Property

Shape.AnchorPattern Property
[image]

Gets or sets the default anchor pattern for nodes that use this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern AnchorPattern { get; set; }

Visual Basic [image] Copy Code

Public Property AnchorPattern As AnchorPattern

Property Value

An AnchorPattern instance. The default value is null (Nothing in Visual Basic).

Remarks

If the AnchorPattern of a ShapeNode is set, it overrides the one associated with the Shape definition.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.ControlPoints Property

Shape.ControlPoints Property
[image]

A list of ShapeControlPoint objects that let users adjust a node's shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<ShapeControlPoint> ControlPoints { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ControlPoints As List(Of ShapeControlPoint)

Property Value

A List<ShapeControlPoint> instance.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.DecorationHitTesting Property

Shape.DecorationHitTesting Property
[image]

Gets or sets a value indicating whether decoration lines should be considered when hit-testing.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool DecorationHitTesting { get; set; }

Visual Basic [image] Copy Code

Public Property DecorationHitTesting As Boolean

Property Value

true if decoration lines should be considered for hit-testing; otherwise, false. The default is false.

Remarks

If this property is enabled, users are able to select shape nodes of such shape by clicking near a decoration line or curve, even if it lies outside the shape outlines.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.Decorations Property

Shape.Decorations Property
[image]

Gets or sets a list with all decorations of this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ElementTemplate[] Decorations { get; set; }

Visual Basic [image] Copy Code

Public Property Decorations As ElementTemplate()

Property Value

An array of ElementTemplate objects specifying the decorations of this shape.

See Also

Shape Members
Shape Class
MindFusion.Diagramming Namespace
Outline Property
DecorationsFormula Property


MindFusion.Diagramming.Shape.DecorationsFormula Property

Shape.DecorationsFormula Property
[image]

Gets or sets a formula describing the shape decorations depending on the current width and height of the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string DecorationsFormula { get; set; }

Visual Basic [image] Copy Code

Public Property DecorationsFormula As String

Property Value

A string containing the script that defines the shape decorations.

Remarks

Shape formulas are small scripts that call one of the following functions to add graphics to the shape:

Function | Description
MoveTo (x,y) | Moves the current position to the specified point without drawing.
LineTo (x,y) | Draws a line from the current position to the specified point.
BezierTo (x1,y1,x2,y2,x3,y3) | Draws a Bezier curve from the current position to (x3,y3) using (x1,y1) and (x2,y2) as control points.
ArcTo (x,y,largeArc,clockwiseArc,rx,ry) | Draws an arc from the specified point to (x,y) where rx and ry are the ellipse radiuses and the arc flags are boolean values specifying which of the four possible arcs to draw.

Each of them starts drawing from the current position and changes the current position to their point argument after drawing. In addition, the scripts can access the current size of the node through the Width and Height variables.

See Also

Shape Members
Shape Class
MindFusion.Diagramming Namespace
Decorations Property
OutlineFormula Property


MindFusion.Diagramming.Shape.DisplayName Property

Shape.DisplayName Property
[image]

Specifies the name that should be displayed for this shape in user interface objects, for example the ShapeListBox or ShapeToolBar.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string DisplayName { get; set; }

Visual Basic [image] Copy Code

Public Property DisplayName As String

Property Value

The DisplayName of all predefined shapes is set to the value of their Id property.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.EnableOutline Property

Shape.EnableOutline Property
[image]

Gets or sets a value indicating whether to enable the shape's outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableOutline { get; set; }

Visual Basic [image] Copy Code

Public Property EnableOutline As Boolean

Property Value

Remarks

When

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.FillMode Property

Shape.FillMode Property
[image]

Gets or sets a value indicating how areas are filled if the outline path of the shape intersects itself.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FillMode FillMode { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property FillMode As FillMode

Property Value

A member of the .NET FillMode enumeration specifying the fill type of the shape.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.Id Property

Shape.Id Property
[image]

Gets or sets the shape identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Id { get; set; }

Visual Basic [image] Copy Code

Public Property Id As String

Property Value

A string id that has been passed as an argument of the Shape constructor.

Remarks

Once assigned through the constructor, the shape identifier should not be changed, that is, do not use the set accessor of this property. To get the shape with a specified id, call the static FromId method.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.Image Property

Shape.Image Property
[image]

Gets or sets the image displayed in all instances of this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Image Image { get; set; }

Visual Basic [image] Copy Code

Public Property Image As Image

Property Value

An instance of the .NET Image class. The default is null (Nothing in Visual Basic).

Remarks

Assigning an image object to this property sets the ImageLocation to null (Nothing in Visual Basic). The image is displayed in the rectangle specified in ImageRectangle. If the Image property of a shape node is set, it overrides the image specified in the shape definition.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.ImageLocation Property

Shape.ImageLocation Property
[image]

Gets or sets the path to the file that contains the image displayed in this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ImageLocation { get; set; }

Visual Basic [image] Copy Code

Public Property ImageLocation As String

Property Value

A string containing the file path. The default is null (Nothing in Visual Basic).

Remarks

Assigning a valid file path to this property will automatically load the image. When adding a shape to a ShapeLibrary, if the Image property is set and the image location is not specified, the image bitmap contents is stored in the library file. If the image location is specified, only the path to the image file is saved in the shape library.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.ImageRectangle Property

Shape.ImageRectangle Property
[image]

Gets or sets the position of the images displayed in instances of this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF ImageRectangle { get; set; }

Visual Basic [image] Copy Code

Public Property ImageRectangle As RectangleF

Property Value

A .NET RectangleF object specifying the location of an image relatively to the shape node that displays the image.

Remarks

The coordinates of the image location are specified in percent, relatively to the rectangular bounds of shape nodes. The default value (0, 0, 100, 100) makes the image displayed in the whole area of that node.

Example

The following code defines a shape, which displays an image in the lower-right quarter of shape nodes and lays out text in the other three quarters.

C# [image] Copy Code

Shape myShape = new Shape(

// Outlines: reuse the rectangle definition
Shape.FromId("Rectangle").Outline,

// Decorations: draw frame lines around the image
new ElementTemplate[] {
new LineTemplate(100, 50, 50, 50),
new LineTemplate(50, 50, 50, 100),
},

// Text area: the area not covered by the image rectangle
new ElementTemplate[] {
new LineTemplate(0, 0, 100, 0),
new LineTemplate(100, 0, 100, 50),
new LineTemplate(100, 50, 50, 50),
new LineTemplate(50, 50, 50, 100),
new LineTemplate(50, 100, 0, 100),
new LineTemplate(0, 100, 0, 0)
},

// The fill type
FillMode.Winding,

// The id
"MyShape");

// Image area: the lower right corner of boxes
myShape.ImageRectangle = new RectangleF(50, 50, 50, 50);

// Use the shape defined above
diagram.DefaultShape = myShape;

// Use polygonal text layout
diagram.EnableStyledText = true;
diagram.PolygonalTextLayout = true;

Visual Basic [image] Copy Code

Dim myShape As New Shape( _
Shape.FromId("Rectangle").Outline, _
New ElementTemplate() { _
New LineTemplate(100, 50, 50, 50), _
New LineTemplate(50, 50, 50, 100) _
}, _
New ElementTemplate() { _
New LineTemplate(0, 0, 100, 0), _
New LineTemplate(100, 0, 100, 50), _
New LineTemplate(100, 50, 50, 50), _
New LineTemplate(50, 50, 50, 100), _
New LineTemplate(50, 100, 0, 100), _
New LineTemplate(0, 100, 0, 0) _
}, _
FillMode.Winding, _
"MyShape")

' Image area: the lower right corner of boxes
myShape.ImageRectangle = New RectangleF(50, 50, 50, 50)

' Use the shape defined above
diagram.DefaultShape = myShape

' Use polygonal text layout
diagram.EnableStyledText = True
diagram.PolygonalTextLayout = True

See Also

Shape Members
Shape Class
MindFusion.Diagramming Namespace
Image Property
Image Property


MindFusion.Diagramming.Shape.IsArrowhead Property

Shape.IsArrowhead Property
[image]

Specifies if this shape is used as arrowhead.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsArrowhead { get; set; }

Visual Basic [image] Copy Code

Public Property IsArrowhead As Boolean

Property Value

true if this shape is designated as arrowhead; otherwise false.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.LinkSegmentInset Property

Shape.LinkSegmentInset Property
[image]

Specifies what length of link's line segment is drawn inside the arrowhead shape, expressed as percents of arrowhead size.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float LinkSegmentInset { get; set; }

Visual Basic [image] Copy Code

Public Property LinkSegmentInset As Single

Property Value

A float value specifying percents of arrowhead size. The default value is 100.

Remarks

The inset value matters when using transparent or semi-transparent arrowhead brush, or when the link's Pen is thicker than one pixel and its cap might extend beyond the arrowhead outline. LinkSegmentInset is set to appropriate values for all shapes from the ArrowHeads class. You might want to set it when using custom arrowhead shapes for which the link's end segment should not reach all the way to the arrowhead tip.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.Outline Property

Shape.Outline Property
[image]

Gets or sets the outline of this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ElementTemplate[] Outline { get; set; }

Visual Basic [image] Copy Code

Public Property Outline As ElementTemplate()

Property Value

An array of ElementTemplate objects specifying the outline of the shape.

See Also

Shape Members
Shape Class
MindFusion.Diagramming Namespace
Decorations Property
OutlineFormula Property


MindFusion.Diagramming.Shape.OutlineFormula Property

Shape.OutlineFormula Property
[image]

Gets or sets a formula describing the shape outline depending on the current width and height of the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string OutlineFormula { get; set; }

Visual Basic [image] Copy Code

Public Property OutlineFormula As String

Property Value

A string containing the script that defines the shape outline.

Remarks

Shape formulas are small scripts that call one of the following functions to add graphics to the shape:

Function | Description
MoveTo (x,y) | Moves the current position to the specified point without drawing.
LineTo (x,y) | Draws a line from the current position to the specified point.
BezierTo (x1,y1,x2,y2,x3,y3) | Draws a Bezier curve from the current position to (x3,y3) using (x1,y1) and (x2,y2) as control points.
ArcTo (x,y,largeArc,clockwiseArc,rx,ry) | Draws an arc from the specified point to (x,y) where rx and ry are the ellipse radiuses and the arc flags are boolean values specifying which of the four possible arcs to draw.

Each of them starts drawing from the current position and changes the current position to their point argument after drawing. In addition, the scripts can access the current size of the node through the Width and Height variables.

See Also

Shape Members
Shape Class
MindFusion.Diagramming Namespace
Outline Property
DecorationsFormula Property


MindFusion.Diagramming.Shape.ShapeDecorations Property

Shape.ShapeDecorations Property
[image]

Gets or sets the ShapeDecoration objects associated with this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeDecoration[] ShapeDecorations { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeDecorations As ShapeDecoration()

Property Value

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.Shapes Property

Shape.Shapes Property
[image]

Gets a read-only collection of all named shapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static ShapeCollection Shapes { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Shapes As ShapeCollection

Property Value

An instance of the ShapeCollection class.

Remarks

Initially the collection contains only the predefined shapes. Any new shape you create is added automatically to Shapes if an identifier has been specified via the Shape constructor.

See Also

Shape Members
Shape Class
FromId Method


MindFusion.Diagramming.Shape.TextArea Property

Shape.TextArea Property
[image]

Gets or sets the outline of the text area of this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ElementTemplate[] TextArea { get; set; }

Visual Basic [image] Copy Code

Public Property TextArea As ElementTemplate()

Property Value

An array of ElementTemplate objects specifying the text area of this shape.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.ShapeAdjustmentHandle Class

ShapeAdjustmentHandle Class
Remarks See Also
[image]

Represents an adjustment handle used to modify the Shape of a ShapeNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ShapeAdjustmentHandle : AdjustmentHandle

Visual Basic [image] Copy Code

Public Class ShapeAdjustmentHandle
Inherits AdjustmentHandle

Remarks

Adjustment handles of this type are used to modify the ControlPoints of a formula shape.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.AdjustmentHandle
MindFusion.Diagramming.ShapeAdjustmentHandle

See Also

ShapeAdjustmentHandle Members


MindFusion.Diagramming.ShapeAdjustmentHandle Members

ShapeAdjustmentHandle Members
Constructors Properties Methods
[image]

Represents an adjustment handle used to modify the Shape of a ShapeNode.

The following tables list the members exposed by the ShapeAdjustmentHandle type.

Public Constructors

Name | Description
ShapeAdjustmentHandle | Initializes a new instance of the ShapeAdjustmentHandle class.

Public Properties

Name | Description
ControlPoint | Gets or sets the ShapeControlPoint that will be modified by this adjustment handle.
FormulaParam | Gets or sets the ShapeFormulaParam whose values will be updated by this handle.

Public Methods

Name | Description
IsMoveHandle | Returns a value indicating whether this handle is used to move items. (Inherited from AdjustmentHandle.)

See Also

ShapeAdjustmentHandle Class


MindFusion.Diagramming.ShapeAdjustmentHandle Constructor

ShapeAdjustmentHandle Constructor
[image]

Initializes a new instance of the ShapeAdjustmentHandle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeAdjustmentHandle (
ShapeControlPoint controlPoint,
ShapeFormulaParam formulaParam
)

Visual Basic [image] Copy Code

Public New ( _
controlPoint As ShapeControlPoint, _
formulaParam As ShapeFormulaParam _
)

Parameters

controlPoint

A ShapeControlPoint representing the shape's control point that will be modified by this adjustment handle.

formulaParam

A ShapeFormulaParam whose values will be updated by this handle.

See Also

ShapeAdjustmentHandle Class


MindFusion.Diagramming.ShapeAdjustmentHandle Properties

ShapeAdjustmentHandle Properties
[image]

Public Properties

Name | Description
ControlPoint | Gets or sets the ShapeControlPoint that will be modified by this adjustment handle.
FormulaParam | Gets or sets the ShapeFormulaParam whose values will be updated by this handle.

See Also

ShapeAdjustmentHandle Class


MindFusion.Diagramming.ShapeAdjustmentHandle.ControlPoint Property

ShapeAdjustmentHandle.ControlPoint Property
[image]

Gets or sets the ShapeControlPoint that will be modified by this adjustment handle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeControlPoint ControlPoint { get; set; }

Visual Basic [image] Copy Code

Public Property ControlPoint As ShapeControlPoint

Property Value

A ShapeControlPoint instance.

See Also

ShapeAdjustmentHandle Members
ShapeAdjustmentHandle Class


MindFusion.Diagramming.ShapeAdjustmentHandle.FormulaParam Property

ShapeAdjustmentHandle.FormulaParam Property
[image]

Gets or sets the ShapeFormulaParam whose values will be updated by this handle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeFormulaParam FormulaParam { get; set; }

Visual Basic [image] Copy Code

Public Property FormulaParam As ShapeFormulaParam

Property Value

A ShapeFormulaParam instance.

See Also

ShapeAdjustmentHandle Members
ShapeAdjustmentHandle Class


MindFusion.Diagramming.ShapeCollection Class

ShapeCollection Class
[image]

Represents a read-only collection of shapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ShapeCollection : ICollection, IEnumerable

Visual Basic [image] Copy Code

Public Class ShapeCollection
Implements ICollection, IEnumerable

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ShapeCollection

See Also

ShapeCollection Members


MindFusion.Diagramming.ShapeCollection Members

ShapeCollection Members
Properties Methods
[image]

Represents a read-only collection of shapes.

The following tables list the members exposed by the ShapeCollection type.

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether the access to this collection is synchronized.
Item | Gets or sets the diagram item at the specified position.
SyncRoot | Gets an object that can be used to synchronize access to this collection.

Public Methods

Name | Description
Contains | Checks whether the specified shape is contained in the collection.
CopyTo | Copies a range of shapes from this collection to the specified one-dimensional array starting at the specified index of the target array.
GetAt | Gets the shape at the specified position.
GetEnumerator | Returns an enumerator for this collection.

See Also

ShapeCollection Class


MindFusion.Diagramming.ShapeCollection Methods

ShapeCollection Methods
[image]

Public Methods

Name | Description
Contains | Checks whether the specified shape is contained in the collection.
CopyTo | Copies a range of shapes from this collection to the specified one-dimensional array starting at the specified index of the target array.
GetAt | Gets the shape at the specified position.
GetEnumerator | Returns an enumerator for this collection.

See Also

ShapeCollection Class


MindFusion.Diagramming.ShapeCollection.Contains Method

ShapeCollection.Contains Method
[image]

Checks whether the specified shape is contained in the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Contains (
Shape shape
)

Visual Basic [image] Copy Code

Public Function Contains ( _
shape As Shape _
) As Boolean

Parameters

shape

The Shape object to search for in the collection.

Return Value

true if the specified item was found in the collection; otherwise, false.

See Also

ShapeCollection Members
ShapeCollection Class


MindFusion.Diagramming.ShapeCollection.CopyTo Method

ShapeCollection.CopyTo Method
[image]

Copies a range of shapes from this collection to the specified one-dimensional array starting at the specified index of the target array.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void CopyTo (
Array array,
int index
)

Visual Basic [image] Copy Code

Public Sub CopyTo( _
array As Array, _
index As Integer _
)

Parameters

array
The one-dimensional Array that is the destination of the elements copied from the current collection.
index

A 32-bit integer that represents the index in array at which copying begins.

See Also

ShapeCollection Members
ShapeCollection Class


MindFusion.Diagramming.ShapeCollection.GetAt Method

ShapeCollection.GetAt Method
[image]

Gets the shape at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape GetAt (
int index
)

Visual Basic [image] Copy Code

Public Function GetAt ( _
index As Integer _
) As Shape

Parameters

index

The zero-based index of the shape to retrieve.

Return Value

An instance of the Shape class that represents the shape at the specified position.

See Also

ShapeCollection Members
ShapeCollection Class


MindFusion.Diagramming.ShapeCollection.GetEnumerator Method

ShapeCollection.GetEnumerator Method
[image]

Returns an enumerator for this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IEnumerator GetEnumerator ()

Visual Basic [image] Copy Code

Public Function GetEnumerator () As IEnumerator

Return Value

An .NET IEnumerator for the collection.

See Also

ShapeCollection Members
ShapeCollection Class


MindFusion.Diagramming.ShapeCollection Properties

ShapeCollection Properties
[image]

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether the access to this collection is synchronized.
Item | Gets or sets the diagram item at the specified position.
SyncRoot | Gets an object that can be used to synchronize access to this collection.

See Also

ShapeCollection Class


MindFusion.Diagramming.ShapeCollection.Count Property

ShapeCollection.Count Property
[image]

Gets the number of elements contained in the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Count { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Count As Integer

Property Value

An integer value specifying the size of the collection.

See Also

ShapeCollection Members
ShapeCollection Class


MindFusion.Diagramming.ShapeCollection.IsSynchronized Property

ShapeCollection.IsSynchronized Property
[image]

Gets a value indicating whether the access to this collection is synchronized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsSynchronized { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsSynchronized As Boolean

Property Value

true if access to the collection is synchronized (thread safe); otherwise, false. The default is false.

See Also

ShapeCollection Members
ShapeCollection Class


MindFusion.Diagramming.ShapeCollection.Item Property

ShapeCollection.Item Property
[image]

Gets or sets the diagram item at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape Item [
int index
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item ( _
index As Integer _
) As Shape

Parameters

index

The zero-based index of the shape to retrieve.

Property Value

An instance of the Shape class that represents the shape at the specified position.

See Also

ShapeCollection Members
ShapeCollection Class


MindFusion.Diagramming.ShapeCollection.SyncRoot Property

ShapeCollection.SyncRoot Property
[image]

Gets an object that can be used to synchronize access to this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object SyncRoot { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SyncRoot As Object

Property Value

An object that can be used to synchronize access to the collection.

See Also

ShapeCollection Members
ShapeCollection Class


MindFusion.Diagramming.ShapeControlPoint Class

ShapeControlPoint Class
Remarks See Also
[image]

Represents a control point that can be used to adjust the shape of a ShapeNode. Control point positions are passed as parameters to shape formulas, whose code can alter the coordinates of the shape's graphic primitives based on the parameter values.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ShapeControlPoint

Visual Basic [image] Copy Code

Public Class ShapeControlPoint

Remarks

The component raises the ShapeModified event when users drag a shape control point.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ShapeControlPoint

See Also

ShapeControlPoint Members


MindFusion.Diagramming.ShapeControlPoint Members

ShapeControlPoint Members
Constructors Properties Methods
[image]

Represents a control point that can be used to adjust the shape of a ShapeNode. Control point positions are passed as parameters to shape formulas, whose code can alter the coordinates of the shape's graphic primitives based on the parameter values.

The following tables list the members exposed by the ShapeControlPoint type.

Public Constructors

Name | Description
ShapeControlPoint | Initializes a new instance of the ShapeControlPoint class.

Public Properties

Name | Description
MaxXRelativeToWidth | Gets or sets a value indicating whether the maximum horizontal position is specified relatively to the node's right side.
MaxYRelativeToHeight | Gets or sets a value indicating whether the maximum vertical position is specified relatively to the node's bottom side.
ParamName | Gets or sets the name of the formula parameter corresponding to this control point.

Public Methods

Name | Description
Clone | Creates a copy of this control point.

See Also

ShapeControlPoint Class


MindFusion.Diagramming.ShapeControlPoint Constructor

ShapeControlPoint Constructor
[image]

Initializes a new instance of the ShapeControlPoint class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeControlPoint (
string paramName,
float defaultX,
float minX,
float maxX,
UnitType xUnit,
float defaultY,
float minY,
float maxY,
UnitType yUnit
)

Visual Basic [image] Copy Code

Public New ( _
paramName As String, _
defaultX As Single, _
minX As Single, _
maxX As Single, _
xUnit As UnitType, _
defaultY As Single, _
minY As Single, _
maxY As Single, _
yUnit As UnitType _
)

Parameters

paramName

Specifies the name of the shape formula parameter corresponding to this control point.

defaultX

The initial horizontal position of this control point.

minX

The minimum horizontal position that is allowed for this control point.

maxX

The maximum horizontal position that is allowed for this control point.

xUnit

The unit used to specify the horizontal position of this control point.

defaultY

The initial vertical position of this control point.

minY

The minimum vertical position that is allowed for this control point.

maxY

The maximum vertical position that is allowed for this control point.

yUnit

The unit used to specify the vertical position of this control point.

See Also

ShapeControlPoint Class


MindFusion.Diagramming.ShapeControlPoint Methods

ShapeControlPoint Methods
[image]

Public Methods

Name | Description
Clone | Creates a copy of this control point.

See Also

ShapeControlPoint Class


MindFusion.Diagramming.ShapeControlPoint.Clone Method

ShapeControlPoint.Clone Method
[image]

Creates a copy of this control point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeControlPoint Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As ShapeControlPoint

Return Value

A new ShapeControlPoint that is a copy of the current instance.

See Also

ShapeControlPoint Members
ShapeControlPoint Class


MindFusion.Diagramming.ShapeControlPoint Properties

ShapeControlPoint Properties
[image]

Public Properties

Name | Description
MaxXRelativeToWidth | Gets or sets a value indicating whether the maximum horizontal position is specified relatively to the node's right side.
MaxYRelativeToHeight | Gets or sets a value indicating whether the maximum vertical position is specified relatively to the node's bottom side.
ParamName | Gets or sets the name of the formula parameter corresponding to this control point.

See Also

ShapeControlPoint Class


MindFusion.Diagramming.ShapeControlPoint.MaxXRelativeToWidth Property

ShapeControlPoint.MaxXRelativeToWidth Property
[image]

Gets or sets a value indicating whether the maximum horizontal position is specified relatively to the node's right side.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool MaxXRelativeToWidth { get; set; }

Visual Basic [image] Copy Code

Public Property MaxXRelativeToWidth As Boolean

Property Value

true if the maxX value is relative to the node's right side, false if it's relative to the left side.

See Also

ShapeControlPoint Members
ShapeControlPoint Class


MindFusion.Diagramming.ShapeControlPoint.MaxYRelativeToHeight Property

ShapeControlPoint.MaxYRelativeToHeight Property
[image]

Gets or sets a value indicating whether the maximum vertical position is specified relatively to the node's bottom side.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool MaxYRelativeToHeight { get; set; }

Visual Basic [image] Copy Code

Public Property MaxYRelativeToHeight As Boolean

Property Value

true if the maxY value is relative to the node's bottom side, false if it's relative to the top side.

See Also

ShapeControlPoint Members
ShapeControlPoint Class


MindFusion.Diagramming.ShapeControlPoint.ParamName Property

ShapeControlPoint.ParamName Property
[image]

Gets or sets the name of the formula parameter corresponding to this control point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ParamName { get; set; }

Visual Basic [image] Copy Code

Public Property ParamName As String

Property Value

A string specifying the name of the shape formula parameter.

See Also

ShapeControlPoint Members
ShapeControlPoint Class


MindFusion.Diagramming.ShapeConverter Class

ShapeConverter Class
[image]

Converts from Shape to other data types.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ShapeConverter : TypeConverter

Visual Basic [image] Copy Code

Public Class ShapeConverter
Inherits TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
MindFusion.Diagramming.ShapeConverter

See Also

ShapeConverter Members


MindFusion.Diagramming.ShapeConverter Members

ShapeConverter Members
Constructors Methods
[image]

Converts from Shape to other data types.

The following tables list the members exposed by the ShapeConverter type.

Public Constructors

Name | Description
ShapeConverter | Initializes a new instance of the ShapeConverter class.

Public Methods

Name | Description
CanConvertFrom | TypeConverter.CanConvertFrom override.
CanConvertTo | TypeConverter.CanConvertTo override.
ConvertFrom | TypeConverter.ConvertFrom override.
ConvertTo | TypeConverter.ConvertTo override.
GetStandardValues | TypeConverter.GetStandardValues override.
GetStandardValuesExclusive | TypeConverter.GetStandardValuesExclusive override.
GetStandardValuesSupported | TypeConverter.GetStandardValuesSupported override.

See Also

ShapeConverter Class


MindFusion.Diagramming.ShapeConverter Constructor

ShapeConverter Constructor
[image]

Initializes a new instance of the ShapeConverter class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ShapeConverter Class


MindFusion.Diagramming.ShapeConverter Methods

ShapeConverter Methods
[image]

Public Methods

Name | Description
CanConvertFrom | TypeConverter.CanConvertFrom override.
CanConvertTo | TypeConverter.CanConvertTo override.
ConvertFrom | TypeConverter.ConvertFrom override.
ConvertTo | TypeConverter.ConvertTo override.
GetStandardValues | TypeConverter.GetStandardValues override.
GetStandardValuesExclusive | TypeConverter.GetStandardValuesExclusive override.
GetStandardValuesSupported | TypeConverter.GetStandardValuesSupported override.

See Also

ShapeConverter Class


MindFusion.Diagramming.ShapeConverter.CanConvertFrom Method

ShapeConverter.CanConvertFrom Method
[image]

TypeConverter.CanConvertFrom override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool CanConvertFrom (
ITypeDescriptorContext context,
Type sourceType
)

Visual Basic [image] Copy Code

Public Overrides Function CanConvertFrom( _
context As ITypeDescriptorContext, _
sourceType As Type _
) As Boolean

Parameters

context
An ITypeDescriptorContext that provides a format context.
sourceType
A Type that represents the type you want to convert from.

Return Value

true if this converter can perform the conversion; otherwise, false.

See Also

ShapeConverter Members
ShapeConverter Class


MindFusion.Diagramming.ShapeConverter.CanConvertTo Method

ShapeConverter.CanConvertTo Method
[image]

TypeConverter.CanConvertTo override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool CanConvertTo (
ITypeDescriptorContext context,
Type destinationType
)

Visual Basic [image] Copy Code

Public Overrides Function CanConvertTo( _
context As ITypeDescriptorContext, _
destinationType As Type _
) As Boolean

Parameters

context
An ITypeDescriptorContext that provides a format context.
destinationType
A Type that represents the type you want to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

See Also

ShapeConverter Members
ShapeConverter Class


MindFusion.Diagramming.ShapeConverter.ConvertFrom Method

ShapeConverter.ConvertFrom Method
[image]

TypeConverter.ConvertFrom override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Object ConvertFrom (
ITypeDescriptorContext context,
CultureInfo culture,
Object value
)

Visual Basic [image] Copy Code

Public Overrides Function ConvertFrom( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object _
) As Object

Parameters

context
An ITypeDescriptorContext that provides a format context.
culture
The CultureInfo to use as the current culture.
value
The Object to convert.

Return Value

An Object that represents the converted value.

See Also

ShapeConverter Members
ShapeConverter Class


MindFusion.Diagramming.ShapeConverter.ConvertTo Method

ShapeConverter.ConvertTo Method
[image]

TypeConverter.ConvertTo override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Object ConvertTo (
ITypeDescriptorContext context,
CultureInfo culture,
Object value,
Type destinationType
)

Visual Basic [image] Copy Code

Public Overrides Function ConvertTo( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object, _
destinationType As Type _
) As Object

Parameters

context
An ITypeDescriptorContext that provides a format context.
culture
A CultureInfo. If null is passed, the current culture is assumed.
value
The Object to convert.
destinationType
An Object that represents the converted value.

Return Value

An Object that represents the converted value.

See Also

ShapeConverter Members
ShapeConverter Class


MindFusion.Diagramming.ShapeConverter.GetStandardValues Method

ShapeConverter.GetStandardValues Method
[image]

TypeConverter.GetStandardValues override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override TypeConverter.StandardValuesCollection GetStandardValues (
ITypeDescriptorContext context
)

Visual Basic [image] Copy Code

Public Overrides Function GetStandardValues( _
context As ITypeDescriptorContext _
) As TypeConverter.StandardValuesCollection

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context that can be used to extract additional information about the environment from which this converter is invoked. This parameter or properties of this parameter can be null.

Return Value

A System.ComponentModel.TypeConverter.StandardValuesCollection that holds a standard set of valid values.

See Also

ShapeConverter Members
ShapeConverter Class


MindFusion.Diagramming.ShapeConverter.GetStandardValuesExclusive Method

ShapeConverter.GetStandardValuesExclusive Method
[image]

TypeConverter.GetStandardValuesExclusive override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool GetStandardValuesExclusive (
ITypeDescriptorContext context
)

Visual Basic [image] Copy Code

Public Overrides Function GetStandardValuesExclusive( _
context As ITypeDescriptorContext _
) As Boolean

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.

Return Value

Always returns true.

See Also

ShapeConverter Members
ShapeConverter Class


MindFusion.Diagramming.ShapeConverter.GetStandardValuesSupported Method

ShapeConverter.GetStandardValuesSupported Method
[image]

TypeConverter.GetStandardValuesSupported override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool GetStandardValuesSupported (
ITypeDescriptorContext context
)

Visual Basic [image] Copy Code

Public Overrides Function GetStandardValuesSupported( _
context As ITypeDescriptorContext _
) As Boolean

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.

Return Value

Always returns true.

See Also

ShapeConverter Members
ShapeConverter Class


MindFusion.Diagramming.ShapeData Class

ShapeData Class
[image]

Contains the cached coordinates of the key points of a shape when the shape is applied to a specific ShapeNode. This class also stores additional data passed to custom shape-generation callbacks and to shape formula scripts.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ShapeData : ICloneable, IPersists

Visual Basic [image] Copy Code

Public Class ShapeData
Implements ICloneable, IPersists

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ShapeData

See Also

ShapeData Members


MindFusion.Diagramming.ShapeData Members

ShapeData Members
Constructors Properties Methods
[image]

Contains the cached coordinates of the key points of a shape when the shape is applied to a specific ShapeNode. This class also stores additional data passed to custom shape-generation callbacks and to shape formula scripts.

The following tables list the members exposed by the ShapeData type.

Public Constructors

Name | Description
ShapeData | Initializes a new instance of the ShapeData class.

Public Properties

Name | Description
Height | Gets the height of the node that displays this shape.
Width | Gets the width of the node that displays this shape.

Public Methods

Name | Description
Clone | Creates an exact copy of this ShapeData object.

See Also

ShapeData Class


MindFusion.Diagramming.ShapeData Constructor

ShapeData Constructor
[image]

Initializes a new instance of the ShapeData class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeData (
int numElements
)

Visual Basic [image] Copy Code

Public New ( _
numElements As Integer _
)

Parameters

numElements
Specifies the length of the coordinate cache array.

See Also

ShapeData Class


MindFusion.Diagramming.ShapeData Methods

ShapeData Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this ShapeData object.

See Also

ShapeData Class


MindFusion.Diagramming.ShapeData.Clone Method

ShapeData.Clone Method
[image]

Creates an exact copy of this ShapeData object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

A ShapeData instance.

See Also

ShapeData Members
ShapeData Class


MindFusion.Diagramming.ShapeData Properties

ShapeData Properties
[image]

Public Properties

Name | Description
Height | Gets the height of the node that displays this shape.
Width | Gets the width of the node that displays this shape.

See Also

ShapeData Class


MindFusion.Diagramming.ShapeData.Height Property

ShapeData.Height Property
[image]

Gets the height of the node that displays this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Height { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Height As Single

Property Value

A float value specifying the node's height.

See Also

ShapeData Members
ShapeData Class


MindFusion.Diagramming.ShapeData.Width Property

ShapeData.Width Property
[image]

Gets the width of the node that displays this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Width { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Width As Single

Property Value

A float value specifying the node's width.

See Also

ShapeData Members
ShapeData Class


MindFusion.Diagramming.ShapeDecoration Class

ShapeDecoration Class
[image]

Defines decoration elements that are displayed as filled shapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ShapeDecoration

Visual Basic [image] Copy Code

Public Class ShapeDecoration

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ShapeDecoration

See Also

ShapeDecoration Members


MindFusion.Diagramming.ShapeDecoration Members

ShapeDecoration Members
Constructors Properties Methods
[image]

Defines decoration elements that are displayed as filled shapes.

The following tables list the members exposed by the ShapeDecoration type.

Public Constructors

Name | Description
ShapeDecoration | Initializes a new instance of the ShapeDecoration class.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the decoration shape interior.
Elements | Gets the elements that define the decoration's shape.
FillMode | Gets or sets how areas are filled if the outline path intersects itself.
Pen | Gets or sets the brush used to draw the decoration shape outline.

Public Methods

Name | Description
Clone | Clones this ShapeDecoration object.
LoadFromXml | Loads the ShapeDecoration definition from an XML document.
SaveToXml | Saves the ShapeDecoration definition in an XML document.

See Also

ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration Constructor

ShapeDecoration Constructor
[image]

Initializes a new instance of the ShapeDecoration class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeDecoration (
ElementTemplate[] elements,
Brush brush,
FillMode fillMode,
Pen pen
)

Visual Basic [image] Copy Code

Public New ( _
elements() As ElementTemplate, _
brush As Brush, _
fillMode As FillMode, _
pen As Pen _
)

Parameters

elements

An array of ElementTemplate objects that define the decoration shape outline.

brush

A Brush object used to fill the decoration shape interior.

fillMode

Specifies how areas are filled if the outline path intersects itself.

pen

A Pen object used to draw the decoration shape outline.

See Also

ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration Methods

ShapeDecoration Methods
[image]

Public Methods

Name | Description
Clone | Clones this ShapeDecoration object.
LoadFromXml | Loads the ShapeDecoration definition from an XML document.
SaveToXml | Saves the ShapeDecoration definition in an XML document.

See Also

ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration.Clone Method

ShapeDecoration.Clone Method
[image]

Clones this ShapeDecoration object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

A copy of the ShapeDecoration.

See Also

ShapeDecoration Members
ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration.LoadFromXml Method

ShapeDecoration.LoadFromXml Method
[image]

Loads the ShapeDecoration definition from an XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

The parent XmlElement object.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ShapeDecoration Members
ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration.SaveToXml Method

ShapeDecoration.SaveToXml Method
[image]

Saves the ShapeDecoration definition in an XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

The parent XmlElement object.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ShapeDecoration Members
ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration Properties

ShapeDecoration Properties
[image]

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the decoration shape interior.
Elements | Gets the elements that define the decoration's shape.
FillMode | Gets or sets how areas are filled if the outline path intersects itself.
Pen | Gets or sets the brush used to draw the decoration shape outline.

See Also

ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration.Brush Property

ShapeDecoration.Brush Property
[image]

Gets or sets the brush used to fill the decoration shape interior.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

See Also

ShapeDecoration Members
ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration.Elements Property

ShapeDecoration.Elements Property
[image]

Gets the elements that define the decoration's shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ElementTemplate[] Elements { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Elements As ElementTemplate()

Property Value

See Also

ShapeDecoration Members
ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration.FillMode Property

ShapeDecoration.FillMode Property
[image]

Gets or sets how areas are filled if the outline path intersects itself.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FillMode FillMode { get; set; }

Visual Basic [image] Copy Code

Public Property FillMode As FillMode

Property Value

See Also

ShapeDecoration Members
ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration.Pen Property

ShapeDecoration.Pen Property
[image]

Gets or sets the brush used to draw the decoration shape outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen Pen { get; set; }

Visual Basic [image] Copy Code

Public Property Pen As Pen

Property Value

See Also

ShapeDecoration Members
ShapeDecoration Class


MindFusion.Diagramming.ShapeEventArgs Class

ShapeEventArgs Class
[image]

Contains the arguments passed to the ShapeSelected and ShapeRenamed event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ShapeEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ShapeEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.ShapeEventArgs

See Also

ShapeEventArgs Members


MindFusion.Diagramming.ShapeEventArgs Members

ShapeEventArgs Members
Constructors Properties Methods
[image]

Contains the arguments passed to the ShapeSelected and ShapeRenamed event handlers.

The following tables list the members exposed by the ShapeEventArgs type.

Public Constructors

Name | Description
ShapeEventArgs | Overloaded. Initializes a new instance of the ShapeEventArgs class.

Public Properties

Name | Description
Index | Gets or sets the index of the Shape item within its containing collection.
OldName | Gets or sets the name of the shape before renaming.
Shape | Gets the shape related to the event.

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

ShapeEventArgs Class


MindFusion.Diagramming.ShapeEventArgs Constructor

ShapeEventArgs Constructor
[image]

Initializes a new instance of the ShapeEventArgs class.

Overload List

Name | Description
ShapeEventArgs (Shape) | Initializes a new instance of the ShapeEventArgs class.
ShapeEventArgs (Shape, Int32) | Initializes a new instance of the ShapeEventArgs class.
ShapeEventArgs (Shape, Int32, String) | Initializes a new instance of the ShapeEventArgs class.

See Also

ShapeEventArgs Class


MindFusion.Diagramming.ShapeEventArgs Constructor (Shape)

ShapeEventArgs Constructor (Shape)
See Also
[image]

Initializes a new instance of the ShapeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeEventArgs (
Shape shapeTemplate
)

Visual Basic [image] Copy Code

Public Sub ShapeEventArgs ( _
shapeTemplate As Shape _
)

Parameters

shapeTemplate

The Shape related to the event.

See Also

ShapeEventArgs Constructor Overload List
ShapeEventArgs Class


MindFusion.Diagramming.ShapeEventArgs Constructor (Shape, Int32)

ShapeEventArgs Constructor (Shape, Int32)
See Also
[image]

Initializes a new instance of the ShapeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeEventArgs (
Shape shapeTemplate,
int index
)

Visual Basic [image] Copy Code

Public Sub ShapeEventArgs ( _
shapeTemplate As Shape, _
index As Integer _
)

Parameters

shapeTemplate

The Shape related to the event.

index

The zero-based index of the shape within its containing collection.

See Also

ShapeEventArgs Constructor Overload List
ShapeEventArgs Class


MindFusion.Diagramming.ShapeEventArgs Constructor (Shape, Int32, String)

ShapeEventArgs Constructor (Shape, Int32, String)
See Also
[image]

Initializes a new instance of the ShapeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeEventArgs (
Shape shapeTemplate,
int index,
string oldId
)

Visual Basic [image] Copy Code

Public Sub ShapeEventArgs ( _
shapeTemplate As Shape, _
index As Integer, _
oldId As String _
)

Parameters

shapeTemplate

The Shape related to the event.

index

The zero-based index of the shape within its containing collection.

oldName

The old DisplayName of the shape.

See Also

ShapeEventArgs Constructor Overload List
ShapeEventArgs Class


MindFusion.Diagramming.ShapeEventArgs Methods

ShapeEventArgs Methods
[image]

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

ShapeEventArgs Class


MindFusion.Diagramming.ShapeEventArgs.ToString Method

ShapeEventArgs.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string that represents the object.

See Also

ShapeEventArgs Members
ShapeEventArgs Class


MindFusion.Diagramming.ShapeEventArgs Properties

ShapeEventArgs Properties
[image]

Public Properties

Name | Description
Index | Gets or sets the index of the Shape item within its containing collection.
OldName | Gets or sets the name of the shape before renaming.
Shape | Gets the shape related to the event.

See Also

ShapeEventArgs Class


MindFusion.Diagramming.ShapeEventArgs.Index Property

ShapeEventArgs.Index Property
[image]

Gets or sets the index of the Shape item within its containing collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Index { get; set; }

Visual Basic [image] Copy Code

Public Property Index As Integer

Property Value

An integer value specifying the zero-based index of the shape.

See Also

ShapeEventArgs Members
ShapeEventArgs Class


MindFusion.Diagramming.ShapeEventArgs.OldName Property

ShapeEventArgs.OldName Property
[image]

Gets or sets the name of the shape before renaming.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string OldName { get; set; }

Visual Basic [image] Copy Code

Public Property OldName As String

Property Value

A string specifying the old value of the shape's DisplayName property.

Remarks

This property is relevant only for the ShapeRenamed event.

See Also

ShapeEventArgs Members
ShapeEventArgs Class


MindFusion.Diagramming.ShapeEventArgs.Shape Property

ShapeEventArgs.Shape Property
[image]

Gets the shape related to the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape Shape { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Shape As Shape

Property Value

An instance of the Shape class.

See Also

ShapeEventArgs Members
ShapeEventArgs Class


MindFusion.Diagramming.ShapeFormulaParam Class

ShapeFormulaParam Class
[image]

Represents the position of a ShapeControlPoint, passed as parameter to shape formulas.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ShapeFormulaParam

Visual Basic [image] Copy Code

Public Class ShapeFormulaParam

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ShapeFormulaParam

See Also

ShapeFormulaParam Members


MindFusion.Diagramming.ShapeFormulaParam Members

ShapeFormulaParam Members
Constructors Properties Methods
[image]

Represents the position of a ShapeControlPoint, passed as parameter to shape formulas.

The following tables list the members exposed by the ShapeFormulaParam type.

Public Constructors

Name | Description
ShapeFormulaParam | Overloaded.

Public Properties

Name | Description
X | Gets or sets the horizontal position of the control point.
Y | Gets or sets the vertical position of the control point.

Public Methods

Name | Description
Clone | Creates a copy of this ShapeFormulaParam.
LoadFromXml | Loads the formula parameter from the specified XML element.
SaveToXml | Saves the formula parameter into the specified XML element.

See Also

ShapeFormulaParam Class


MindFusion.Diagramming.ShapeFormulaParam Constructor

ShapeFormulaParam Constructor
[image]

Overload List

Name | Description
ShapeFormulaParam () | Initializes a new instance of the ShapeFormulaParam class.
ShapeFormulaParam (Single, Single) | Initializes a new instance of the ShapeFormulaParam class.

See Also

ShapeFormulaParam Class


MindFusion.Diagramming.ShapeFormulaParam Constructor ()

ShapeFormulaParam Constructor ()
See Also
[image]

Initializes a new instance of the ShapeFormulaParam class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeFormulaParam ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ShapeFormulaParam Constructor Overload List
ShapeFormulaParam Class


MindFusion.Diagramming.ShapeFormulaParam Constructor (Single, Single)

ShapeFormulaParam Constructor (Single, Single)
See Also
[image]

Initializes a new instance of the ShapeFormulaParam class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeFormulaParam (
float x,
float y
)

Visual Basic [image] Copy Code

Public New ( _
x As Single, _
y As Single _
)

Parameters

x

Horizontal position of the control point.

y

Vertical position of the control point.

See Also

ShapeFormulaParam Constructor Overload List
ShapeFormulaParam Class


MindFusion.Diagramming.ShapeFormulaParam Methods

ShapeFormulaParam Methods
[image]

Public Methods

Name | Description
Clone | Creates a copy of this ShapeFormulaParam.
LoadFromXml | Loads the formula parameter from the specified XML element.
SaveToXml | Saves the formula parameter into the specified XML element.

See Also

ShapeFormulaParam Class


MindFusion.Diagramming.ShapeFormulaParam.Clone Method

ShapeFormulaParam.Clone Method
[image]

Creates a copy of this ShapeFormulaParam.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeFormulaParam Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As ShapeFormulaParam

Return Value

A new ShapeFormulaParam object that is a copy of the current instance.

See Also

ShapeFormulaParam Members
ShapeFormulaParam Class


MindFusion.Diagramming.ShapeFormulaParam.LoadFromXml Method

ShapeFormulaParam.LoadFromXml Method
[image]

Loads the formula parameter from the specified XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement instance.

context

An XmlPersistContext instance.

See Also

ShapeFormulaParam Members
ShapeFormulaParam Class


MindFusion.Diagramming.ShapeFormulaParam.SaveToXml Method

ShapeFormulaParam.SaveToXml Method
[image]

Saves the formula parameter into the specified XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement instance.

context

An XmlPersistContext instance.

See Also

ShapeFormulaParam Members
ShapeFormulaParam Class


MindFusion.Diagramming.ShapeFormulaParam Properties

ShapeFormulaParam Properties
[image]

Public Properties

Name | Description
X | Gets or sets the horizontal position of the control point.
Y | Gets or sets the vertical position of the control point.

See Also

ShapeFormulaParam Class


MindFusion.Diagramming.ShapeFormulaParam.X Property

ShapeFormulaParam.X Property
[image]

Gets or sets the horizontal position of the control point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float X { get; set; }

Visual Basic [image] Copy Code

Public Property X As Single

Property Value

A float value specifying the horizontal position of the shape control point.

See Also

ShapeFormulaParam Members
ShapeFormulaParam Class


MindFusion.Diagramming.ShapeFormulaParam.Y Property

ShapeFormulaParam.Y Property
[image]

Gets or sets the vertical position of the control point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Y { get; set; }

Visual Basic [image] Copy Code

Public Property Y As Single

Property Value

A float value specifying the vertical position of the shape control point.

See Also

ShapeFormulaParam Members
ShapeFormulaParam Class


MindFusion.Diagramming.ShapeLibrary Class

ShapeLibrary Class
Remarks See Also
[image]

The ShapeLibrary class represents a collection of shape definitions stored together.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ShapeLibrary

Visual Basic [image] Copy Code

Public Class ShapeLibrary

Remarks

Shape libraries can be created using the ShapeDesigner tool that comes with MvcDiagram. Use the LoadFrom method to load a shape library from a file. The loaded shapes can be accessed through the Shapes property. They will be automatically added to the shared list of shapes kept in the Shape class, which lets you access them through the FromId method. A shape library can be saved into a file in XML based format using the SaveToXml method.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ShapeLibrary

See Also

ShapeLibrary Members


MindFusion.Diagramming.ShapeLibrary Members

ShapeLibrary Members
Constructors Properties Methods
[image]

The ShapeLibrary class represents a collection of shape definitions stored together.

The following tables list the members exposed by the ShapeLibrary type.

Public Constructors

Name | Description
ShapeLibrary | Overloaded.

Public Properties

Name | Description
Shapes | Gets or sets the array of all shapes in the library.

Public Methods

Name | Description
LoadFrom | Loads a shape library from the specified file.
LoadFromXml | Overloaded.
SaveToXml | Overloaded.

See Also

ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary Constructor

ShapeLibrary Constructor
[image]

Overload List

Name | Description
ShapeLibrary () | Initializes a new empty instance of the ShapeLibrary class.
ShapeLibrary (Shape[]) | Initializes a new instance of the ShapeLibrary class.

See Also

ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary Constructor ()

ShapeLibrary Constructor ()
See Also
[image]

Initializes a new empty instance of the ShapeLibrary class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeLibrary ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ShapeLibrary Constructor Overload List
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary Constructor (Shape[])

ShapeLibrary Constructor (Shape[])
See Also
[image]

Initializes a new instance of the ShapeLibrary class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeLibrary (
Shape[] shapes
)

Visual Basic [image] Copy Code

Public Sub ShapeLibrary ( _
shapes As Shape() _
)

Parameters

shapes

An array of Shape object to initialize the library with.

See Also

ShapeLibrary Constructor Overload List
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary Methods

ShapeLibrary Methods
[image]

Public Methods

Name | Description
LoadFrom | Loads a shape library from the specified file.
LoadFromXml | Overloaded.
SaveToXml | Overloaded.

See Also

ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.LoadFrom Method

ShapeLibrary.LoadFrom Method
[image]

Loads a shape library from the specified file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static ShapeLibrary LoadFrom (
string fileName
)

Visual Basic [image] Copy Code

Public Shared Function LoadFrom ( _
fileName As String _
) As ShapeLibrary

Parameters

fileName

The name of the file that contains the shape library.

Return Value

An instance of the ShapeLibrary class whose Shapes array contains the loaded shape definitions.

See Also

ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.LoadFromXml Method

ShapeLibrary.LoadFromXml Method
[image]

Overload List

Name | Description
ShapeLibrary.LoadFromXml (String) | Loads this library from the specified file.
ShapeLibrary.LoadFromXml (XmlDocument) | Loads the shape library from the specified XML document.
ShapeLibrary.LoadFromXml (XmlDocument, String) | Loads the library from the specified XML document. All locations of images associated with shapes in the library are loaded relative to the specified library path.

See Also

ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.LoadFromXml Method (String)

ShapeLibrary.LoadFromXml Method (String)
See Also
[image]

Loads this library from the specified file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
fileName As String _
)

Parameters

fileName

The name of the file from which to load the shape library.

See Also

LoadFromXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.LoadFromXml Method (XmlDocument)

ShapeLibrary.LoadFromXml Method (XmlDocument)
See Also
[image]

Loads the shape library from the specified XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
XmlDocument document
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
document As XmlDocument _
)

Parameters

document

The document to load the library from.

See Also

LoadFromXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.LoadFromXml Method (XmlDocument, String)

ShapeLibrary.LoadFromXml Method (XmlDocument, String)
See Also
[image]

Loads the library from the specified XML document. All locations of images associated with shapes in the library are loaded relative to the specified library path.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
XmlDocument document,
string libraryPath
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
document As XmlDocument, _
libraryPath As String _
)

Parameters

document

libraryPath

Remarks

If the path is an empty string or null, image locations are loaded relative to the BaseURI of the specified document.

See Also

LoadFromXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.SaveToXml Method

ShapeLibrary.SaveToXml Method
[image]

Overload List

Name | Description
ShapeLibrary.SaveToXml (String) | Saves this library to the specified file.
ShapeLibrary.SaveToXml (XmlDocument) | Saves the shape library into the specified XML document.
ShapeLibrary.SaveToXml (XmlDocument, String) | Saves the shape library into the specified XML document. All locations of images associated with shapes in the library are saved relative to the specified destination path.

See Also

ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.SaveToXml Method (String)

ShapeLibrary.SaveToXml Method (String)
See Also
[image]

Saves this library to the specified file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
fileName As String _
)

Parameters

fileName

The name of the file where to save the shape library.

See Also

SaveToXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.SaveToXml Method (XmlDocument)

ShapeLibrary.SaveToXml Method (XmlDocument)
See Also
[image]

Saves the shape library into the specified XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
XmlDocument document
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
document As XmlDocument _
)

Parameters

document

See Also

SaveToXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.SaveToXml Method (XmlDocument, String)

ShapeLibrary.SaveToXml Method (XmlDocument, String)
See Also
[image]

Saves the shape library into the specified XML document. All locations of images associated with shapes in the library are saved relative to the specified destination path.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
XmlDocument document,
string libraryFileName
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
document As XmlDocument, _
libraryFileName As String _
)

Parameters

document

libraryFileName

Remarks

If the path is an empty string or null, image locations are written as absolute.

See Also

SaveToXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary Properties

ShapeLibrary Properties
[image]

Public Properties

Name | Description
Shapes | Gets or sets the array of all shapes in the library.

See Also

ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.Shapes Property

ShapeLibrary.Shapes Property
[image]

Gets or sets the array of all shapes in the library.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape[] Shapes { get; set; }

Visual Basic [image] Copy Code

Public Property Shapes As Shape()

Property Value

An array of Shape objects containing the shape definitions.

See Also

ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeNode Class

ShapeNode Class
Remarks See Also
[image]

ShapeNode instances are diagram nodes that represent geometric shapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ShapeNode : DiagramNode, InplaceEditable

Visual Basic [image] Copy Code

Public Class ShapeNode
Inherits DiagramNode
Implements InplaceEditable

Remarks

A ShapeNode instance represents nodes in graphs, tree, process diagrams, and so on.

The shape of a node is specified through the Shape property. Shapes can be rotated, either interactively using the rotation handle above the node, or programmatically using the RotationAngle property.

Shape nodes can display images and text. Set an image to be painted inside a node by assigning it to the Image property. The position of the image within the node and its alignment are set by the ImageAlign property. To make a node as big as its image, call ResizeToFitImage.

Text inside a shape node is represented by the Text property. Its attributes can be changed by the TextBrush and TextFormat properties. To get even richer text formatting, set EnableStyledText to true and embed HTML-like formatting tags in the raw text. Text can be laid out inside arbitrary polygonal shapes by enabling PolygonalTextLayout. To make a node big enough to display its text without clipping, call ResizeToFitText.

To let users edit a node's text inline, call the BeginEdit method of DiagramView. Call EndEdit to exit in-place editing mode.

Fill and border colors can be specified by setting the Pen and Brush properties. Shape nodes can be transparent as set through the Transparent property.

Shape nodes can have incoming and outgoing DiagramLink objects accessible through the IncomingLinks and OutgoingLinks properties defined in the DiagramNode class.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.ShapeNode
MindFusion.Diagramming.SvgNode

See Also

ShapeNode Members


MindFusion.Diagramming.ShapeNode Members

ShapeNode Members
Constructors Fields Properties Methods
[image]

ShapeNode instances are diagram nodes that represent geometric shapes.

The following tables list the members exposed by the ShapeNode type.

Public Constructors

Name | Description
ShapeNode | Overloaded. Initializes a new instance of the ShapeNode class.

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
CustomDraw | Gets or sets the type of custom drawing performed on this shape node.
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
EnableStyledText | Gets or sets a value indicating whether styled text rendering is enabled.
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Font | Gets or sets the font used to render the node's text.
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
Image | Gets or sets the image that is displayed in this shape node.
ImageAlign | Gets or sets the alignment of the image displayed in this shape node.
ImageUrl | Gets or sets a URL used to load an image into this node.
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
PlainText | Gets the plain text of this shape node.
PolygonalTextLayout | Gets or sets a value indicating whether the node's Text is formatted inside non-rectangular outline.
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotateImage | Gets or sets a value indicating whether the Image should be rotated when the shape node is rotated.
RotateText | Gets or sets a value indicating whether the Text should be rotated when the shape node is rotated.
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Shape | Gets or sets a reference to the node's geometric shape definition.
ShapeOrientation | Gets or sets the angle specifying the orientation with which a shape template is applied to the node bounds.
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
Text | Gets or sets the text displayed inside the shape node.
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextFormat | Gets or sets the alignment of the text that is displayed inside shape nodes.
TextPadding | Gets or sets the spacing between the item boundaries and its text.
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Transparent | Gets or sets a value indicating whether this shape node is transparent.
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | Determines whether the node supports connections to its constituent elements. (Inherited from DiagramNode.)
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded.
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
DoModify | For internal use. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramNode.DrawHandles override. Renders the adjustment handles of this item.
DrawLocal | Draws the node on the specified IGraphics surface.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | Draws the shadow of this node on the specified IGraphics surface.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item. (Inherited from DiagramItem.)
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item. (Inherited from DiagramItem.)
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item. (Inherited from DiagramItem.)
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item. (Inherited from DiagramItem.)
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | Node.GetOutlinePoly override.
GetRepaintRect | DiagramNode.GetRepaintRect override.
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramNode.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point.
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Intersects | Determines whether the node intersects another one, taking into account the outlines of node shapes. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | DiagramItem.OnLoad override.
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
ResizeToFitImage | Makes the shape node as big as the image it displays.
ResizeToFitText | Makes the shape node big enough to display its text without clipping.
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetPos | Sets the bounding rectangle of this node without updating connected arrows. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramNode.AllowModify override. Invoked during interactive modification of items to test whether the operation can be completed in the current context.
CancelModify | DiagramNode.CancelModify override. Invoked when the interactive modification of this object has been canceled.
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramNode.CompleteModify override. Invoked when the item modification has been completed.
ConstraintsInfringed | Checks whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramNode.CreateState override; creates a ShapeNodeState instance.
Dispose | Disposes any disposable resources managed by this shape.
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
Finalize | DiagramItem finalizer. (Inherited from DiagramItem.)
FreeResources | Called when the node is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetImageRect | Overloaded. Gets the destination rectangle of the node's image.
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle.
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the item content from an XML element.
LoadObsolete | For internal use. (Inherited from DiagramItem.)
OnAdd | Called when the item is added to a Diagram, either by users, programmatically or via undo / redo.
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnClick | Invoked when the user clicks this item. (Inherited from DiagramItem.)
OnDoubleClick | Invoked when the user double-clicks this item. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes.
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | DiagramNode.OnRotationAngleChanged override.
OnStyleChanged | DiagramItem.OnStyleChanged override.
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the Diagram's ZoomFactor changes.
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramNode.RestoreState override. Restores the state of this diagram item.
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramNode.SaveState override. Saves the state of this diagram item.
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReference | Updates the reference to the specified object.
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramNode.StartModify override. Invoked when the user starts modifying this item interactively.
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster. (Inherited from DiagramItem.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramNode.UpdateModify override. Invoked during interactive modification of this item.

See Also

ShapeNode Class


MindFusion.Diagramming.ShapeNode Constructor

ShapeNode Constructor
[image]

Initializes a new instance of the ShapeNode class.

Overload List

Name | Description
ShapeNode () | Initializes a new instance of the ShapeNode class.
ShapeNode (Diagram) | Initializes a new instance of the ShapeNode class with default values supplied form the specified Diagram.
ShapeNode (ShapeNode) | Initializes a new instance of the ShapeNode class using the specified node as a prototype.

See Also

ShapeNode Class


MindFusion.Diagramming.ShapeNode Constructor ()

ShapeNode Constructor ()
See Also
[image]

Initializes a new instance of the ShapeNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ShapeNode Constructor Overload List
ShapeNode Class


MindFusion.Diagramming.ShapeNode Constructor (Diagram)

ShapeNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the ShapeNode class with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode (
Diagram parent
)

Visual Basic [image] Copy Code

Public Sub ShapeNode ( _
parent As Diagram _
)

Parameters

parent

The Diagram from which to obtain default values for the node properties.

Remarks

This constructor initializes the ShapeNode properties with the values specified in the respective default-value properties of the Diagram object. For more information see Initial Values of Item Properties.

See Also

ShapeNode Constructor Overload List
ShapeNode Class


MindFusion.Diagramming.ShapeNode Constructor (ShapeNode)

ShapeNode Constructor (ShapeNode)
See Also
[image]

Initializes a new instance of the ShapeNode class using the specified node as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode (
ShapeNode prototype
)

Visual Basic [image] Copy Code

Public Sub ShapeNode ( _
prototype As ShapeNode _
)

Parameters

prototype
The node to use as a prototype. The properties of the new node are initialized from the property values of this node.

Remarks

This constructor copies the ShapeNode property values from the specified prototype node.

See Also

ShapeNode Constructor Overload List
ShapeNode Class


MindFusion.Diagramming.ShapeNode Methods

ShapeNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded.
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
DoModify | For internal use. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramNode.DrawHandles override. Renders the adjustment handles of this item.
DrawLocal | Draws the node on the specified IGraphics surface.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | Draws the shadow of this node on the specified IGraphics surface.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item. (Inherited from DiagramItem.)
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item. (Inherited from DiagramItem.)
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item. (Inherited from DiagramItem.)
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item. (Inherited from DiagramItem.)
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | Node.GetOutlinePoly override.
GetRepaintRect | DiagramNode.GetRepaintRect override.
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramNode.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point.
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Intersects | Determines whether the node intersects another one, taking into account the outlines of node shapes. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | DiagramItem.OnLoad override.
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
ResizeToFitImage | Makes the shape node as big as the image it displays.
ResizeToFitText | Makes the shape node big enough to display its text without clipping.
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetPos | Sets the bounding rectangle of this node without updating connected arrows. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramNode.AllowModify override. Invoked during interactive modification of items to test whether the operation can be completed in the current context.
CancelModify | DiagramNode.CancelModify override. Invoked when the interactive modification of this object has been canceled.
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramNode.CompleteModify override. Invoked when the item modification has been completed.
ConstraintsInfringed | Checks whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramNode.CreateState override; creates a ShapeNodeState instance.
Dispose | Disposes any disposable resources managed by this shape.
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
Finalize | DiagramItem finalizer. (Inherited from DiagramItem.)
FreeResources | Called when the node is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetImageRect | Overloaded. Gets the destination rectangle of the node's image.
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle.
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the item content from an XML element.
LoadObsolete | For internal use. (Inherited from DiagramItem.)
OnAdd | Called when the item is added to a Diagram, either by users, programmatically or via undo / redo.
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnClick | Invoked when the user clicks this item. (Inherited from DiagramItem.)
OnDoubleClick | Invoked when the user double-clicks this item. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes.
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | DiagramNode.OnRotationAngleChanged override.
OnStyleChanged | DiagramItem.OnStyleChanged override.
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the Diagram's ZoomFactor changes.
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramNode.RestoreState override. Restores the state of this diagram item.
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramNode.SaveState override. Saves the state of this diagram item.
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReference | Updates the reference to the specified object.
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramNode.StartModify override. Invoked when the user starts modifying this item interactively.
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster. (Inherited from DiagramItem.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramNode.UpdateModify override. Invoked during interactive modification of this item.

See Also

ShapeNode Class


MindFusion.Diagramming.ShapeNode.AllowModify Method

ShapeNode.AllowModify Method
[image]

DiagramNode.AllowModify override. Invoked during interactive modification of items to test whether the operation can be completed in the current context.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override bool AllowModify (
PointF current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Function AllowModify( _
current As PointF, _
ist As InteractionState _
) As Boolean

Parameters

current

The current mouse pointer position.

ist

An InteractionState object containing more information about the current state of the operation.

Return Value

true to allow the modification of this node; otherwise, false.

Remarks

This method is invoked after each mouse movement in order to update the mouse pointer icon, so do not perform any time-consuming operations in its implementation.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.CancelModify Method

ShapeNode.CancelModify Method
[image]

DiagramNode.CancelModify override. Invoked when the interactive modification of this object has been canceled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void CancelModify (
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub CancelModify( _
ist As InteractionState _
)

Parameters

ist

An InteractionState object containing more information about the current state of the operation.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.CompleteModify Method

ShapeNode.CompleteModify Method
[image]

DiagramNode.CompleteModify override. Invoked when the item modification has been completed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void CompleteModify (
PointF end,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub CompleteModify( _
end As PointF, _
ist As InteractionState _
)

Parameters

end

The mouse pointer position.

ist

An InteractionState object containing more information about the current state of the operation.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.ContainsPoint Method

ShapeNode.ContainsPoint Method
[image]

Overload List

Name | Description
ShapeNode.ContainsPoint (PointF) | DiagramItem.ContainsPoint override.
ShapeNode.ContainsPoint (PointF, Single) | Tests whether the specified point is contained within the outline of this node, relaxed with the specified threshold.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.ContainsPoint Method (PointF)

ShapeNode.ContainsPoint Method (PointF)
See Also
[image]

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
PointF diagramPoint
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
diagramPoint As PointF _
) As Boolean

Parameters

diagramPoint

Return Value

See Also

ContainsPoint Method Overload List
ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.ContainsPoint Method (PointF, Single)

ShapeNode.ContainsPoint Method (PointF, Single)
See Also
[image]

Tests whether the specified point is contained within the outline of this node, relaxed with the specified threshold.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
PointF point,
float threshold
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
point As PointF, _
threshold As Single _
) As Boolean

Parameters

point

threshold

Return Value

See Also

ContainsPoint Method Overload List
ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.CreateConnectionPoint Method

ShapeNode.CreateConnectionPoint Method
[image]

DiagramNode.CreateConnectionPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual ConnectionPoint CreateConnectionPoint (
DiagramLink link,
PointF pt,
bool incoming
)

Visual Basic [image] Copy Code

Protected Overridable Function CreateConnectionPoint ( _
link As DiagramLink, _
pt As PointF, _
incoming As Boolean _
) As ConnectionPoint

Parameters

link
A DiagramLink that should be connected to this node.
pt
The point at which the link should be connected.
incoming
true if link is an incoming link; otherwise, false.

Return Value

A ConnectionPoint instance representing the connection.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.CreateProperties Method

ShapeNode.CreateProperties Method
[image]

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramItemProperties CreateProperties ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateProperties () As DiagramItemProperties

Return Value

A DiagramItemProperties -derived object containing a snapshot of the item's properties.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.CreateState Method

ShapeNode.CreateState Method
[image]

DiagramNode.CreateState override; creates a ShapeNodeState instance.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override DiagramItemState CreateState ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateState () As DiagramItemState

Return Value

A ShapeNodeState instance.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.Dispose Method

ShapeNode.Dispose Method
[image]

Disposes any disposable resources managed by this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Dispose (
bool disposing
)

Visual Basic [image] Copy Code

Protected Overrides Sub Dispose( _
disposing As Boolean _
)

Parameters

disposing

Specifies whether the method is called explicitly or from the garbage collector.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.DrawHandles Method

ShapeNode.DrawHandles Method
[image]

DiagramNode.DrawHandles override. Renders the adjustment handles of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawHandles (
IGraphics graphics,
HandlesVisualStyle style,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawHandles( _
graphics As IGraphics, _
style As HandlesVisualStyle, _
options As RenderOptions _
)

Parameters

graphics

The IGraphics surface on which the handles should be drawn.

style

A HandlesVisualStyle instance containing brush and pen objects that should be used when drawing handles.

options

Provides options for the drawing operation.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.DrawLocal Method

ShapeNode.DrawLocal Method
[image]

Draws the node on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawLocal (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawLocal( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

An IGraphics object where the node should be rendered.

options

Provides options for the drawing operation.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.DrawShadowLocal Method

ShapeNode.DrawShadowLocal Method
[image]

Draws the shadow of this node on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawShadowLocal (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawShadowLocal( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

An IGraphics object where the shadow should be rendered.

options

Provides options for the drawing operation.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.GetImageRect Method

ShapeNode.GetImageRect Method
[image]

Gets the destination rectangle of the node's image.

Overload List

Name | Description
ShapeNode.GetImageRect () | Gets the image rectangle from the associated Shape template, or the node's bounding rectangle if there is no associated shape template.
ShapeNode.GetImageRect (Boolean) | Gets the image rectangle from the associated shape template or the node's bounding rectangle if there is no associated shape template.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.GetImageRect Method ()

ShapeNode.GetImageRect Method ()
See Also
[image]

Gets the image rectangle from the associated Shape template, or the node's bounding rectangle if there is no associated shape template.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected RectangleF GetImageRect ()

Visual Basic [image] Copy Code

Protected Function GetImageRect () As RectangleF

Return Value

A RectangleF specifying the region inside this node where its associated Image will be rendered.

See Also

GetImageRect Method Overload List
ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.GetImageRect Method (Boolean)

ShapeNode.GetImageRect Method (Boolean)
See Also
[image]

Gets the image rectangle from the associated shape template or the node's bounding rectangle if there is no associated shape template.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected RectangleF GetImageRect (
bool inLocal
)

Visual Basic [image] Copy Code

Protected Function GetImageRect( _
inLocal As Boolean _
) As RectangleF

Parameters

inLocal

Return Value

A RectangleF specifying the region inside this node where its associated Image will be rendered.

See Also

GetImageRect Method Overload List
ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.GetIntersection Method

ShapeNode.GetIntersection Method
[image]

Calculates the intersection point between the segment defined by the specified point pair and the node's outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override PointF GetIntersection (
PointF segmentStart,
PointF segmentEnd
)

Visual Basic [image] Copy Code

Public Overrides Function GetIntersection( _
segmentStart As PointF, _
segmentEnd As PointF _
) As PointF

Parameters

segmentStart
The first point of the segment.
segmentEnd
The second point of the segment.

Return Value

A PointF object representing the intersection point.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.GetOutlinePoly Method

ShapeNode.GetOutlinePoly Method
[image]

Node.GetOutlinePoly override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override PointCollection GetOutlinePoly (
bool rendering
)

Visual Basic [image] Copy Code

Public Overrides Function GetOutlinePoly( _
rendering As Boolean _
) As PointCollection

Parameters

rendering

Return Value

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.GetRepaintRect Method

ShapeNode.GetRepaintRect Method
[image]

DiagramNode.GetRepaintRect override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override RectangleF GetRepaintRect (
bool includeConnected
)

Visual Basic [image] Copy Code

Public Overrides Function GetRepaintRect( _
includeConnected As Boolean _
) As RectangleF

Parameters

includeConnected
true if related items should be considered too; otherwise, false.

Return Value

A rectangular region that should be repainted when this node is modified.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.GetRgnInRect Method

ShapeNode.GetRgnInRect Method
[image]

Creates and returns a Region object for this node as though it is contained in the specified rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Region GetRgnInRect (
RectangleF rc,
bool inLocal
)

Visual Basic [image] Copy Code

Protected Overrides Function GetRgnInRect( _
rc As RectangleF, _
inLocal As Boolean _
) As Region

Parameters

rc

inLocal

Return Value

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.HitTestHandle Method

ShapeNode.HitTestHandle Method
[image]

DiagramNode.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override AdjustmentHandle HitTestHandle (
PointF point
)

Visual Basic [image] Copy Code

Public Overrides Function HitTestHandle( _
point As PointF _
) As AdjustmentHandle

Parameters

point

A PointF value specifying where to look for a selection handle.

Return Value

Returns an AdjustmentHandle instance representing the adjustment handle found at the specified location, or null if there is none.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.LoadFrom Method

ShapeNode.LoadFrom Method
[image]

Deserializes the object from the specified reader.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFrom (
BinaryReader reader,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFrom ( _
reader As BinaryReader, _
context As PersistContext _
)

Parameters

reader
A BinaryReader object from which to read the item's data.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.LoadFromXml Method

ShapeNode.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFromXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement containing the item's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.OnAdd Method

ShapeNode.OnAdd Method
[image]

Called when the item is added to a Diagram, either by users, programmatically or via undo / redo.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnAdd ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnAdd ()

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.OnLoad Method

ShapeNode.OnLoad Method
[image]

DiagramItem.OnLoad override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void OnLoad ()

Visual Basic [image] Copy Code

Public Overrides Sub OnLoad ()

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.OnMeasureUnitChanged Method

ShapeNode.OnMeasureUnitChanged Method
[image]

Called when the Diagram's MeasureUnit changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnMeasureUnitChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnMeasureUnitChanged ()

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.OnRotationAngleChanged Method

ShapeNode.OnRotationAngleChanged Method
[image]

DiagramNode.OnRotationAngleChanged override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnRotationAngleChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnRotationAngleChanged ()

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.OnStyleChanged Method

ShapeNode.OnStyleChanged Method
[image]

DiagramItem.OnStyleChanged override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnStyleChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnStyleChanged ()

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.OnUpdateBounds Method

ShapeNode.OnUpdateBounds Method
[image]

DiagramNode.OnUpdateBounds override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnUpdateBounds (
bool sizeChanged
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnUpdateBounds( _
sizeChanged As Boolean _
)

Parameters

sizeChanged

true if the size has changed; false if only the position has changed.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.OnZoomChanged Method

ShapeNode.OnZoomChanged Method
[image]

Called when the Diagram's ZoomFactor changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnZoomChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnZoomChanged ()

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.ResizeToFitImage Method

ShapeNode.ResizeToFitImage Method
[image]

Makes the shape node as big as the image it displays.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ResizeToFitImage ()

Visual Basic [image] Copy Code

Public Sub ResizeToFitImage ()

Remarks

Call this method to make a shape node exactly the same size as the image it contains. The dots-per-inch resolution of the image is considered too when calculating the new node size. Use the Image property to assign an image to a node and ImageAlign to specify position of the image within the node.

See Also

ShapeNode Members
ShapeNode Class
ResizeToFitText Method


MindFusion.Diagramming.ShapeNode.ResizeToFitText Method

ShapeNode.ResizeToFitText Method
[image]

Makes the shape node big enough to display its text without clipping.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ResizeToFitText (
FitSize fit
)

Visual Basic [image] Copy Code

Public Function ResizeToFitText ( _
fit As FitSize _
) As Boolean

Parameters

fit
A member of the FitSize enumeration specifying whether the width or height of the node should remain unchanged.

Return Value

true if the node is resized successfully; otherwise, false.

Example

The following sample resizes a node to fit its text, using 1:1 width to height ratio.

C# [image] Copy Code

r = new RectangleF(shapeNode.Bounds.Left, shapeNode.Bounds.Top, 10, 10);

shapeNode.PolygonalTextLayout = true;
shapeNode.Bounds = r;
shapeNode.Text = "the method changes both the box' width" +
"and height, maintaining their original ratio.";
shapeNode.ResizeToFitText(FitSize.KeepRatio);

Visual Basic [image] Copy Code

r = New RectangleF(shapeNode.Bounds.Left, shapeNode.Bounds.Top, 10, 10)

shapeNode.PolygonalTextLayout = True
shapeNode.Bounds = r
shapeNode.Text = "the method changes both the box' width" + _
"and height, maintaining their original ratio."
shapeNode.ResizeToFitText(FitSize.KeepRatio)

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
Text Property
ResizeToFitImage Method


MindFusion.Diagramming.ShapeNode.RestoreProperties Method

ShapeNode.RestoreProperties Method
[image]

DiagramNode.RestoreProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overridable Sub RestoreProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties -derived object containing a snapshot of the item's properties.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.RestoreState Method

ShapeNode.RestoreState Method
[image]

DiagramNode.RestoreState override. Restores the state of this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void RestoreState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Overrides Sub RestoreState( _
state As DiagramItemState _
)

Parameters

state

A ShapeNodeState instance, previously created by CreateState.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.SaveProperties Method

ShapeNode.SaveProperties Method
[image]

DiagramNode.SaveProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties -derived object where the item's properties should be saved.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.SaveState Method

ShapeNode.SaveState Method
[image]

DiagramNode.SaveState override. Saves the state of this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SaveState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveState( _
state As DiagramItemState _
)

Parameters

state

A ShapeNodeState instance previously created by CreateState.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.SaveTo Method

ShapeNode.SaveTo Method
[image]

Serializes the object to the specified writer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveTo (
BinaryWriter writer,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveTo ( _
writer As BinaryWriter, _
context As PersistContext _
)

Parameters

writer
A BinaryWriter object the item's data should be written to.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.SaveToXml Method

ShapeNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveToXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement the item's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.SetReference Method

ShapeNode.SetReference Method
[image]

Updates the reference to the specified object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SetReference (
int refId,
Object obj,
PersistContext ctx
)

Visual Basic [image] Copy Code

Protected Overridable Sub SetReference ( _
refId As Integer, _
obj As Object, _
ctx As PersistContext _
)

Parameters

refId
Reference identifier.
obj
The newly loaded object.
context

A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

This method is called for references that had been saved using the SaveReference method.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.StartModify Method

ShapeNode.StartModify Method
[image]

DiagramNode.StartModify override. Invoked when the user starts modifying this item interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void StartModify (
PointF org,
AdjustmentHandle handle,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub StartModify( _
org As PointF, _
handle As AdjustmentHandle, _
ist As InteractionState _
)

Parameters

org

Position of the mouse pointer.

handle

The adjustment handle used to modify this node.

ist

An InteractionState object containing more information about the current state of the operation.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.UpdateModify Method

ShapeNode.UpdateModify Method
[image]

DiagramNode.UpdateModify override. Invoked during interactive modification of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void UpdateModify (
PointF current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub UpdateModify( _
current As PointF, _
ist As InteractionState _
)

Parameters

current

Position of the mouse pointer.

ist

An InteractionState object containing more information about the current state of the operation.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode Properties

ShapeNode Properties
[image]

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
CustomDraw | Gets or sets the type of custom drawing performed on this shape node.
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
EnableStyledText | Gets or sets a value indicating whether styled text rendering is enabled.
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Font | Gets or sets the font used to render the node's text.
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
Image | Gets or sets the image that is displayed in this shape node.
ImageAlign | Gets or sets the alignment of the image displayed in this shape node.
ImageUrl | Gets or sets a URL used to load an image into this node.
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
PlainText | Gets the plain text of this shape node.
PolygonalTextLayout | Gets or sets a value indicating whether the node's Text is formatted inside non-rectangular outline.
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotateImage | Gets or sets a value indicating whether the Image should be rotated when the shape node is rotated.
RotateText | Gets or sets a value indicating whether the Text should be rotated when the shape node is rotated.
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Shape | Gets or sets a reference to the node's geometric shape definition.
ShapeOrientation | Gets or sets the angle specifying the orientation with which a shape template is applied to the node bounds.
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
Text | Gets or sets the text displayed inside the shape node.
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextFormat | Gets or sets the alignment of the text that is displayed inside shape nodes.
TextPadding | Gets or sets the spacing between the item boundaries and its text.
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Transparent | Gets or sets a value indicating whether this shape node is transparent.
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | Determines whether the node supports connections to its constituent elements. (Inherited from DiagramNode.)
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

See Also

ShapeNode Class


MindFusion.Diagramming.ShapeNode.CustomDraw Property

ShapeNode.CustomDraw Property
[image]

Gets or sets the type of custom drawing performed on this shape node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CustomDraw CustomDraw { get; set; }

Visual Basic [image] Copy Code

Public Property CustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. Initialized with the value of ShapeCustomDraw.

Remarks

This property allows invoking custom painting code for a shape node. That code must execute in response to the DrawNode event. There are several modes of custom painting, allowing the custom code to paint the shape node entirely, or do that in addition to what MvcDiagram paints by default. The following CustomDraw members can be assigned to this property to specify the custom painting mode:

Member Name | Description
None | Do not perform custom drawing, let all painting be done by MvcDiagram.
Additional | The custom painting code executes after the node interior and frame are painted by MvcDiagram, but before text is rendered. In this mode, the Graphics instance passed to the custom drawing event handler has a clipping region applied to it.
Full | The component does not do any standard drawing, the entire painting of the node is done by the application.
ShadowOnly | Only the shadow of the node is painted by custom code, the node itself is drawn by the component.
Additional2 | The custom painting code executes after all parts of the node are painted by MvcDiagram. In this mode, the Graphics instance passed to the custom drawing event handler doesn't have a clipping region applied to it.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.EnableStyledText Property

ShapeNode.EnableStyledText Property
[image]

Gets or sets a value indicating whether styled text rendering is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableStyledText { get; set; }

Visual Basic [image] Copy Code

Public Property EnableStyledText As Boolean

Property Value

true to parse the node's text in order to find formatting tags; otherwise, false. Initialized with the value of EnableStyledText.

Remarks

Styled text allows applying various attributes to the characters it contains. Attributes are specified using HTML-like formatting tags embedded in the raw text. Formatting tags are listed and described in the Text Attributes and Formatting section of this help file.

Styled text can be enabled only if PolygonalTextLayout is set to true. If enabled, Text is parsed and analyzed each time it is changed. Parsing determines what formatting tags are used and adds the corresponding attribute records to MvcDiagram's internal representation of styled text. If the property value is false, the text is not processed in any way and is displayed without formatting.

Example

The following sample code demonstrates how to use styled text:

C# [image] Copy Code

shapeNode.PolygonalTextLayout = true;
shapeNode.EnableStyledText = true;
shapeNode.Text = "CH<sub>2</sub>CL<sub>2</sub> " + "\n" +
"<b><color=#0088FF>methylene-chloride</b>";

Visual Basic [image] Copy Code

shapeNode.PolygonalTextLayout = True
shapeNode.EnableStyledText = True
shapeNode.Text = "CH<sub>2</sub>CL<sub>2</sub> " + vbNewLine + _
"<b><color=#0088FF>methylene-chloride</b>"

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
TextFormat Property
Text Attributes and Formatting


MindFusion.Diagramming.ShapeNode.Font Property

ShapeNode.Font Property
[image]

Gets or sets the font used to render the node's text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Font Font { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Font As Font

Property Value

A .NET Font instance specifying the font attributes.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.Image Property

ShapeNode.Image Property
[image]

Gets or sets the image that is displayed in this shape node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Image Image { get; set; }

Visual Basic [image] Copy Code

Public Property Image As Image

Property Value

An instance of the .NET Image class. The default value is null (Nothing in Visual Basic).

Remarks

This property lets you display an image inside the node. The ImageRectangle attribute of the shape definition specifies a rectangular area inside the node in which the image is displayed. Use the ImageAlign property to specify how the image is aligned to that area. By default, the image is displayed in the center of the bounding rectangle of the node.

If there isn't any image assigned to this property, the shape node displays the Image specified in its Shape template.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
RotateImage Property
ResizeToFitImage Method


MindFusion.Diagramming.ShapeNode.ImageAlign Property

ShapeNode.ImageAlign Property
[image]

Gets or sets the alignment of the image displayed in this shape node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ImageAlign ImageAlign { get; set; }

Visual Basic [image] Copy Code

Public Property ImageAlign As ImageAlign

Property Value

A member of the ImageAlign enumeration. The default is Center.

Remarks

This property specifies how the Image is aligned to the bounding rectangle of this node. The image is aligned relatively to the rectangle specified in the ImageRectangle attribute of the Shape definition.

See Also

ShapeNode Members
ShapeNode Class
Image Property


MindFusion.Diagramming.ShapeNode.ImageUrl Property

ShapeNode.ImageUrl Property
[image]

Gets or sets a URL used to load an image into this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ImageUrl { get; set; }

Visual Basic [image] Copy Code

Public Property ImageUrl As String

Property Value

A string specifying the image location.

Remarks

This property is used in MindFusion Web components. If it is set, the image data is not transferred to the client-side together with the diagram but only the URL string. Such images are downloaded asynchronously after all other diagram elements load on the client.

See Also

ShapeNode Members
ShapeNode Class
Image Property


MindFusion.Diagramming.ShapeNode.PlainText Property

ShapeNode.PlainText Property
[image]

Gets the plain text of this shape node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string PlainText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PlainText As String

Property Value

A string containing the plain text of the shape node.

Remarks

This property removes any formatting tags from the node's Text and returns the plain human-readable text. That is useful when styled text formatting is enabled and you need to display the node's text outside of MvcDiagram, for example in a message box or a dialog box.

See Also

ShapeNode Members
ShapeNode Class
EnableStyledText Property


MindFusion.Diagramming.ShapeNode.PolygonalTextLayout Property

ShapeNode.PolygonalTextLayout Property
[image]

Gets or sets a value indicating whether the node's Text is formatted inside non-rectangular outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool PolygonalTextLayout { get; set; }

Visual Basic [image] Copy Code

Public Property PolygonalTextLayout As Boolean

Property Value

true to enable polygonal formatting; false to disable it.

Remarks

The node's area in which text is rendered can be explicitly defined for each Shape definition, and if it is not specified, the shape outline is used implicitly. The formatting algorithm is designed to layout text inside polygonal outlines. A polygonal approximation is created for outlines that have curved segments, so text can be laid out in shapes that consist of Bйzier curves too.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
Text Property
EnableStyledText Property
Shape Property


MindFusion.Diagramming.ShapeNode.RotateImage Property

ShapeNode.RotateImage Property
[image]

Gets or sets a value indicating whether the Image should be rotated when the shape node is rotated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RotateImage { get; set; }

Visual Basic [image] Copy Code

Public Property RotateImage As Boolean

Property Value

true to rotate the node's image; otherwise, false. The default is true.

Remarks

The image is clipped by the rotated shape outline, even if this property is set to false.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
RotationAngle Property
RotateText Property


MindFusion.Diagramming.ShapeNode.RotateText Property

ShapeNode.RotateText Property
[image]

Gets or sets a value indicating whether the Text should be rotated when the shape node is rotated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RotateText { get; set; }

Visual Basic [image] Copy Code

Public Property RotateText As Boolean

Property Value

true to rotate the node's text; otherwise, false. The default is false.

Remarks

If the property is set to false and PolygonalTextLayout is enabled, the text stays horizontal but it adapts to the rotated outline of the shape node.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
RotationAngle Property
RotateImage Property


MindFusion.Diagramming.ShapeNode.Shape Property

ShapeNode.Shape Property
[image]

Gets or sets a reference to the node's geometric shape definition.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape Shape { get; set; }

Visual Basic [image] Copy Code

Public Property Shape As Shape

Property Value

An instance of the Shape class.

Remarks

Use this property to assign a complex shape to a node. Complex shapes consist of outlines, decorations and text-region definitions that can be defined as series of lines, arcs and curves. To define a custom shape, create an instance of the Shape class. That class also provides 87 predefined shapes exposed by the Shapes collection.

Example

The following sample code illustrates how to use the predefined shapes and how to create your own custom shapes.

C# [image] Copy Code

private void example_Click(object sender, System.EventArgs e)
{
ShapeNode shapeNode0 = diagram.Nodes[0] as ShapeNode;
ShapeNode shapeNode1 = diagram.Nodes[1] as ShapeNode;

// Use one of the predefined shapes
shapeNode0.Shape = Shape.FromId("MultiDocument");

// Create a custom shape
shapeNode1.Shape = new Shape(
new ElementTemplate[] {
new LineTemplate(0, 100, 60, 100),
new BezierTemplate(60, 100, 80, 100, 100, 75, 100, 50),
new BezierTemplate(100, 50, 100, 25, 80, 0, 60, 0),
new LineTemplate(60, 0, 0, 0),
new LineTemplate(0, 0, 0, 100) },
FillMode.Winding);
}

Visual Basic [image] Copy Code

Private Sub example_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles example.Click

Dim shapeNode0 As ShapeNode = CType(diagram.Nodes(0), ShapeNode)
Dim shapeNode1 As ShapeNode = CType(diagram.Nodes(1), ShapeNode)

' Use one of the predefined shapes
shapeNode0.Shape = Shape.FromId("MultiDocument")

' Create a custom shape
shapeNode1.Shape = New Shape( _
New ElementTemplate() { _
New LineTemplate(0, 100, 60, 100), _
New BezierTemplate(60, 100, 80, 100, 100, 75, 100, 50), _
New BezierTemplate(100, 50, 100, 25, 80, 0, 60, 0), _
New LineTemplate(60, 0, 0, 0), _
New LineTemplate(0, 0, 0, 100)}, _
FillMode.Winding)

End Sub

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
Shape.FromId Method
Shape.Shapes Property
PolygonalTextLayout Property
ShapeOrientation Property


MindFusion.Diagramming.ShapeNode.ShapeOrientation Property

ShapeNode.ShapeOrientation Property
[image]

Gets or sets the angle specifying the orientation with which a shape template is applied to the node bounds.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float ShapeOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeOrientation As Single

Property Value

A float value specifying the orientation angle in degrees. Initialized with the value of ShapeOrientation.

Remarks

That property does not rotate the node, that is, does not rotate the bounding rectangle of the node around its center. It specifies a rotation transformation to be performed on the definition of the Shape when it is applied to a node; the node's bounding rectangle (location, width and height) remain intact. In the current MvcDiagram version, only 0, 90, 180 or 270 can be set as value of ShapeOrientation.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
Shape Property
RotationAngle Property


MindFusion.Diagramming.ShapeNode.Text Property

ShapeNode.Text Property
[image]

Gets or sets the text displayed inside the shape node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Text { get; set; }

Visual Basic [image] Copy Code

Public Property Text As String

Property Value

A string containing the node's text. Initialized with the value of ShapeText.

Remarks

This property specifies the text that should be drawn inside the shape. The text appearance can be customized through the TextBrush and TextFormat properties.

Styled text allows applying various attributes to the text characters. Attributes are specified by embedding HTML-like formatting tags within the raw text. Styled text is enabled by setting EnableStyledText to true.

See Also

ShapeNode Members
ShapeNode Class
ToolTip Property


MindFusion.Diagramming.ShapeNode.TextFormat Property

ShapeNode.TextFormat Property
[image]

Gets or sets the alignment of the text that is displayed inside shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringFormat TextFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TextFormat As StringFormat

Property Value

An instance of the .NET StringFormat class. Initialized with the value of TextFormat.

Remarks

Use this property to specify the wrapping mode and alignment of the text that is contained in nodes.

If there isn't enough space available to fit a whole line of text, MvcDiagram wraps the text to a new line when it reaches the edge of the node. You can specify that the text should be wrapped only at word boundaries by setting the Trimming member of TextFormat to StringTrimming.Word. The default is to split words into multiple parts if there is not enough space to fit a whole word.

If you prefer to use your own line-breaks, you can disable the automatic text wrapping by enabling the NoWrap flag in the FormatFlags member of TextFormat. If automatic wrapping is disabled and there isn't enough space to fit the whole line, the text is clipped at the node boundaries.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
Text Property
TextColor Property
Diagram.TextFormat Property


MindFusion.Diagramming.ShapeNode.TextPadding Property

ShapeNode.TextPadding Property
[image]

Gets or sets the spacing between the item boundaries and its text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Thickness TextPadding { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property TextPadding As Thickness

Property Value

A Thickness instance specifying the size of the padding space left around the text.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.Transparent Property

ShapeNode.Transparent Property
[image]

Gets or sets a value indicating whether this shape node is transparent.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Transparent { get; set; }

Visual Basic [image] Copy Code

Public Property Transparent As Boolean

Property Value

true if the shape node is transparent; otherwise, false. The default is false.

Remarks

If a node is transparent, only its image and text are drawn. Shape, filling and frames are not painted.

See Also

ShapeNode Members
ShapeNode Class
Visible Property


MindFusion.Diagramming.ShapeNodeProperties Class

ShapeNodeProperties Class
Remarks See Also
[image]

Stores the values of ShapeNode properties during undo / redo operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ShapeNodeProperties : DiagramNodeProperties

Visual Basic [image] Copy Code

Public Class ShapeNodeProperties
Inherits DiagramNodeProperties

Remarks

If you need to implement undo support for the additional properties defined by a class derived from ShapeNode, do so by deriving from ShapeNodeProperties and overriding the SaveProperties, RestoreProperties, and CreateProperties methods of ShapeNode.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemProperties
MindFusion.Diagramming.DiagramNodeProperties
MindFusion.Diagramming.ShapeNodeProperties
MindFusion.Diagramming.SvgNodeProperties

See Also

ShapeNodeProperties Members


MindFusion.Diagramming.ShapeNodeProperties Members

ShapeNodeProperties Members
Constructors Fields Methods
[image]

Stores the values of ShapeNode properties during undo / redo operations.

The following tables list the members exposed by the ShapeNodeProperties type.

Public Constructors

Name | Description
ShapeNodeProperties | Initializes a new instance of the ShapeNodeProperties class.

Public Fields

Name | Description
ItemClass | For internal use. (Inherited from DiagramItemProperties.)
RotateText | For internal use.
Selected | For internal use. (Inherited from DiagramItemProperties.)
Shape | For internal use.
ShapeOrientation | For internal use.
Text | For internal use.
TextPadding | For internal use. (Inherited from DiagramItemProperties.)
Transparent | For internal use.
UsePolyTextLt | For internal use.
ZIndex | For internal use. (Inherited from DiagramItemProperties.)

Public Methods

Name | Description
FreeResources | DiagramItemProperties.FreeResources override.

See Also

ShapeNodeProperties Class


MindFusion.Diagramming.ShapeNodeProperties Fields

ShapeNodeProperties Fields
[image]

Public Fields

Name | Description
ItemClass | For internal use. (Inherited from DiagramItemProperties.)
RotateText | For internal use.
Selected | For internal use. (Inherited from DiagramItemProperties.)
Shape | For internal use.
ShapeOrientation | For internal use.
Text | For internal use.
TextPadding | For internal use. (Inherited from DiagramItemProperties.)
Transparent | For internal use.
UsePolyTextLt | For internal use.
ZIndex | For internal use. (Inherited from DiagramItemProperties.)

See Also

ShapeNodeProperties Class


MindFusion.Diagramming.ShapeNodeProperties.RotateText Field

ShapeNodeProperties.RotateText Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RotateText

Visual Basic [image] Copy Code

Public RotateText As Boolean

See Also

ShapeNodeProperties Members
ShapeNodeProperties Class


MindFusion.Diagramming.ShapeNodeProperties.Shape Field

ShapeNodeProperties.Shape Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape Shape

Visual Basic [image] Copy Code

Public Shape As Shape

See Also

ShapeNodeProperties Members
ShapeNodeProperties Class


MindFusion.Diagramming.ShapeNodeProperties.ShapeOrientation Field

ShapeNodeProperties.ShapeOrientation Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float ShapeOrientation

Visual Basic [image] Copy Code

Public ShapeOrientation As Single

See Also

ShapeNodeProperties Members
ShapeNodeProperties Class


MindFusion.Diagramming.ShapeNodeProperties.Text Field

ShapeNodeProperties.Text Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Text

Visual Basic [image] Copy Code

Public Text As String

See Also

ShapeNodeProperties Members
ShapeNodeProperties Class


MindFusion.Diagramming.ShapeNodeProperties.Transparent Field

ShapeNodeProperties.Transparent Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Transparent

Visual Basic [image] Copy Code

Public Transparent As Boolean

See Also

ShapeNodeProperties Members
ShapeNodeProperties Class


MindFusion.Diagramming.ShapeNodeProperties.UsePolyTextLt Field

ShapeNodeProperties.UsePolyTextLt Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool UsePolyTextLt

Visual Basic [image] Copy Code

Public UsePolyTextLt As Boolean

See Also

ShapeNodeProperties Members
ShapeNodeProperties Class


MindFusion.Diagramming.ShapeNodeProperties Constructor

ShapeNodeProperties Constructor
[image]

Initializes a new instance of the ShapeNodeProperties class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNodeProperties ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ShapeNodeProperties Class


MindFusion.Diagramming.ShapeNodeProperties Methods

ShapeNodeProperties Methods
[image]

Public Methods

Name | Description
FreeResources | DiagramItemProperties.FreeResources override.

See Also

ShapeNodeProperties Class


MindFusion.Diagramming.ShapeNodeProperties.FreeResources Method

ShapeNodeProperties.FreeResources Method
[image]

DiagramItemProperties.FreeResources override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void FreeResources ()

Visual Basic [image] Copy Code

Public Overrides Sub FreeResources ()

See Also

ShapeNodeProperties Members
ShapeNodeProperties Class


MindFusion.Diagramming.ShapeNodeState Class

ShapeNodeState Class
[image]

Contains a snapshot of the internal state of a ShapeNode. Instances of this class are used to store the state of nodes for later undo or redo operations. If you derive from ShapeNode and need to implement undo support for the additional internal state defined by your class, do so by deriving from ShapeNodeState and overriding the ShapeNode.CreateState, ShapeNode.SaveState and ShapeNode.RestoreState methods.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ShapeNodeState : DiagramNodeState

Visual Basic [image] Copy Code

Public Class ShapeNodeState
Inherits DiagramNodeState

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemState
MindFusion.Diagramming.DiagramNodeState
MindFusion.Diagramming.ShapeNodeState

See Also

ShapeNodeState Members


MindFusion.Diagramming.ShapeNodeState Members

ShapeNodeState Members
Constructors
[image]

Contains a snapshot of the internal state of a ShapeNode. Instances of this class are used to store the state of nodes for later undo or redo operations. If you derive from ShapeNode and need to implement undo support for the additional internal state defined by your class, do so by deriving from ShapeNodeState and overriding the ShapeNode.CreateState, ShapeNode.SaveState and ShapeNode.RestoreState methods.

The following tables list the members exposed by the ShapeNodeState type.

Public Constructors

Name | Description
ShapeNodeState | Initializes a new instance of the ShapeNodeState class.

See Also

ShapeNodeState Class


MindFusion.Diagramming.ShapeNodeState Constructor

ShapeNodeState Constructor
[image]

Initializes a new instance of the ShapeNodeState class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNodeState ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ShapeNodeState Class


MindFusion.Diagramming.ShapeNodeStyle Class

ShapeNodeStyle Class
[image]

Represents a reusable set of properties that define the appearance of shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ShapeNodeStyle : DiagramNodeStyle

Visual Basic [image] Copy Code

Public Class ShapeNodeStyle
Inherits DiagramNodeStyle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Style
MindFusion.Diagramming.DiagramItemStyle
MindFusion.Diagramming.DiagramNodeStyle
MindFusion.Diagramming.ShapeNodeStyle

See Also

ShapeNodeStyle Members


MindFusion.Diagramming.ShapeNodeStyle Members

ShapeNodeStyle Members
Constructors Properties Methods Events
[image]

Represents a reusable set of properties that define the appearance of shape nodes.

The following tables list the members exposed by the ShapeNodeStyle type.

Public Constructors

Name | Description
ShapeNodeStyle | Initializes a new instance of the ShapeNodeStyle class.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of the item. (Inherited from DiagramItemStyle.)
Effects | Gets a list of the effects applied to the node. (Inherited from DiagramNodeStyle.)
FontFamily | Gets or sets the font family of the item text. (Inherited from DiagramItemStyle.)
FontSize | Gets or sets the font size of the item text. (Inherited from DiagramItemStyle.)
FontStyle | Gets or sets the font style of the item text. (Inherited from DiagramItemStyle.)
FontUnit | Gets or sets the font unit of the item text. (Inherited from DiagramItemStyle.)
ShadowBrush | Gets or sets the brush used to paint the shadow of the item. (Inherited from DiagramItemStyle.)
Stroke | Gets or sets the brush used to paint the outline of the item. (Inherited from DiagramItemStyle.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItemStyle.)
StrokeThickness | Gets or sets the thickness of the item's outline, expressed in the current units of measure. (Inherited from DiagramItemStyle.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItemStyle.)

Public Methods

Name | Description
GetProperties | Gets all properties in the style. (Inherited from Style.)
GetProperty | Returns the property with the specified name, if any. (Inherited from Style.)
RegisterType | Associates a type with an alias. (Inherited from Style.)

Protected Methods

Name | Description
GetValue | Gets the value of the specified property. (Inherited from Style.)
IsPropertySet | Checks whether the specified property has a value. (Inherited from Style.)
LoadFrom | Deserializes the item from the specified reader. (Inherited from Style.)
LoadFromXml | Loads the style content from an XML element. (Inherited from Style.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Style.)
RegisterProperty | Registers a new property with the specified name and type. (Inherited from Style.)
SaveTo | Serializes the style to the specified writer. (Inherited from Style.)
SaveToXml | Saves the style content into an XML element. (Inherited from Style.)
SetValue | Sets the value of the specified property. (Inherited from Style.)
UnsetValue | Clears the value of the specified property. (Inherited from Style.)

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

ShapeNodeStyle Class


MindFusion.Diagramming.ShapeNodeStyle Constructor

ShapeNodeStyle Constructor
[image]

Initializes a new instance of the ShapeNodeStyle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNodeStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ShapeNodeStyle Class


MindFusion.Diagramming.ShapeNodeStyle Events

ShapeNodeStyle Events
[image]

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

ShapeNodeStyle Class


MindFusion.Diagramming.Shapes Class

Shapes Class
Remarks See Also
[image]

Provides alternative method of access to the MvcDiagram predefined shapes, that allows code completion and IntelliSense support, which is not available when using Shape.FromId.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Shapes

Visual Basic [image] Copy Code

Public Class Shapes

Remarks

The accessor properties are generating using the following code:

C# [image] Copy Code

TextWriter writer = new StreamWriter(@"D:\shapes.txt");
foreach (Shape shape in Shape.Shapes)
{
writer.WriteLine("static public Shape " + shape.Id);
writer.WriteLine("{");
writer.WriteLine("\tget { return Shape.FromId(\"" + shape.Id + "\"); }");
writer.WriteLine("}");
writer.WriteLine();
writer.Flush();
}

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Shapes

See Also

Shapes Members
Table of Predefined Shapes


MindFusion.Diagramming.Shapes Members

Shapes Members
Properties
[image]

Provides alternative method of access to the MvcDiagram predefined shapes, that allows code completion and IntelliSense support, which is not available when using Shape.FromId.

The following tables list the members exposed by the Shapes type.

Public Properties

Name | Description
Actor | Gets the Actor predefined shape.
Alternative | Gets the Alternative predefined shape.
Arrow1 | Gets the Arrow1 predefined shape.
Arrow2 | Gets the Arrow2 predefined shape.
Arrow3 | Gets the Arrow3 predefined shape.
Arrow4 | Gets the Arrow4 predefined shape.
Arrow5 | Gets the Arrow5 predefined shape.
Arrow6 | Gets the Arrow6 predefined shape.
Arrow7 | Gets the Arrow7 predefined shape.
Arrow8 | Gets the Arrow8 predefined shape.
Arrow9 | Gets the Arrow9 predefined shape.
BeginLoop | Gets the BeginLoop predefined shape.
BpmnComplex | Gets the BpmnComplex predefined shape.
BpmnDataBasedXor | Gets the BpmnDataBasedXor predefined shape.
BpmnEndCancel | Gets the BpmnEndCancel predefined shape.
BpmnEndCompensation | Gets the BpmnEndCompensation predefined shape.
BpmnEndError | Gets the BpmnEndError predefined shape.
BpmnEndLink | Gets the BpmnEndLink predefined shape.
BpmnEndMessage | Gets the BpmnEndMessage predefined shape.
BpmnEndMultiple | Gets the BpmnEndMultiple predefined shape.
BpmnEndTerminate | Gets the BpmnEndTerminate predefined shape.
BpmnEventBasedXor | Gets the BpmnEventBasedXor predefined shape.
BpmnInclusive | Gets the BpmnInclusive predefined shape.
BpmnIntermediateCancel | Gets the BpmnIntermediateCancel predefined shape.
BpmnIntermediateCompensation | Gets the BpmnIntermediateCompensation predefined shape.
BpmnIntermediateError | Gets the BpmnIntermediateError predefined shape.
BpmnIntermediateLink | Gets the BpmnIntermediateLink predefined shape.
BpmnIntermediateMessage | Gets the BpmnIntermediateMessage predefined shape.
BpmnIntermediateMultiple | Gets the BpmnIntermediateMultiple predefined shape.
BpmnIntermediateRule | Gets the BpmnIntermediateRule predefined shape.
BpmnIntermediateTimer | Gets the BpmnIntermediateTimer predefined shape.
BpmnParallelFork | Gets the BpmnParallelFork predefined shape.
BpmnStartLink | Gets the BpmnStartLink predefined shape.
BpmnStartMessage | Gets the BpmnStartMessage predefined shape.
BpmnStartMultiple | Gets the BpmnStartMultiple predefined shape.
BpmnStartRule | Gets the BpmnStartRule predefined shape.
BpmnStartTimer | Gets the BpmnStartTimer predefined shape.
Cloud | Gets the Cloud predefined shape.
Collate | Gets the Collate predefined shape.
ConeDown | Gets the ConeDown predefined shape.
ConeUp | Gets the ConeUp predefined shape.
ConnectedIssues | Gets the ConnectedIssues predefined shape.
CreateRequest | Gets the CreateRequest predefined shape.
Cross | Gets the Cross predefined shape.
Cube | Gets the Cube predefined shape.
Cylinder | Gets the Cylinder predefined shape.
Database | Gets the Database predefined shape.
DataTransmition | Gets the DataTransmition predefined shape.
DDelay | Gets the DDelay predefined shape.
Decagon | Gets the Decagon predefined shape.
Decision | Gets the Decision predefined shape.
Decision2 | Gets the Decision2 predefined shape.
Delay | Gets the Delay predefined shape.
DInDelay | Gets the DInDelay predefined shape.
DirectAccessStorage | Gets the DirectAccessStorage predefined shape.
DiskStorage | Gets the DiskStorage predefined shape.
Display | Gets the Display predefined shape.
DividedEvent | Gets the DividedEvent predefined shape.
DividedProcess | Gets the DividedProcess predefined shape.
Document | Gets the Document predefined shape.
Donut | Gets the Donut predefined shape.
DOutDelay | Gets the DOutDelay predefined shape.
Ellipse | Gets the Ellipse predefined shape.
EndLoop | Gets the EndLoop predefined shape.
ExternalOrganization | Gets the ExternalOrganization predefined shape.
ExternalProcess | Gets the ExternalProcess predefined shape.
File | Gets the File predefined shape.
FramedRectangle | Gets the FramedRectangle predefined shape.
Gate | Gets the Gate predefined shape.
Heart | Gets the Heart predefined shape.
Heptagon | Gets the Heptagon predefined shape.
Hourglass | Gets the Hourglass predefined shape.
Input | Gets the Input predefined shape.
InternalStorage | Gets the InternalStorage predefined shape.
Interrupt | Gets the Interrupt predefined shape.
Interrupt2 | Gets the Interrupt2 predefined shape.
IsoProcess | Gets the IsoProcess predefined shape.
Junction | Gets the Junction predefined shape.
Lightning | Gets the Lightning predefined shape.
LinedDocument | Gets the LinedDocument predefined shape.
ManualOperation | Gets the ManualOperation predefined shape.
Merge | Gets the Merge predefined shape.
MessageFromUser | Gets the MessageFromUser predefined shape.
MessageToUser | Gets the MessageToUser predefined shape.
Microform | Gets the Microform predefined shape.
MicroformProcessing | Gets the MicroformProcessing predefined shape.
MicroformRecording | Gets the MicroformRecording predefined shape.
MultiDocument | Gets the MultiDocument predefined shape.
MultiProc | Gets the MultiProc predefined shape.
Octagon | Gets the Octagon predefined shape.
OfflineStorage | Gets the OfflineStorage predefined shape.
OffpageConnection | Gets the OffpageConnection predefined shape.
OffpageReference | Gets the OffpageReference predefined shape.
Or | Gets the Or predefined shape.
Pentagon | Gets the Pentagon predefined shape.
Plaque | Gets the Plaque predefined shape.
PrimitiveFromCall | Gets the PrimitiveFromCall predefined shape.
PrimitiveToCall | Gets the PrimitiveToCall predefined shape.
Procedure | Gets the Procedure predefined shape.
Process | Gets the Process predefined shape.
Prysm | Gets the Prysm predefined shape.
PunchedCard | Gets the PunchedCard predefined shape.
PyramidDown | Gets the PyramidDown predefined shape.
PyramidUp | Gets the PyramidUp predefined shape.
Rectangle | Gets the Rectangle predefined shape.
RightTriangle | Gets the RightTriangle predefined shape.
RoundRect | Gets the RoundRect predefined shape.
RSave | Gets the RSave predefined shape.
Save | Gets the Save predefined shape.
Sort | Gets the Sort predefined shape.
Sphere | Gets the Sphere predefined shape.
Star | Gets the Star predefined shape.
Star16Pointed | Gets the Star16Pointed predefined shape.
Star24Pointed | Gets the Star24Pointed predefined shape.
Star32Pointed | Gets the Star32Pointed predefined shape.
Star4Pointed | Gets the Star4Pointed predefined shape.
Star5Pointed | Gets the Star5Pointed predefined shape.
Star6Pointed | Gets the Star6Pointed predefined shape.
Star7Pointed | Gets the Star7Pointed predefined shape.
Start | Gets the Start predefined shape.
Tape | Gets the Tape predefined shape.
Terminator | Gets the Terminator predefined shape.
TransmittalTape | Gets the TransmittalTape predefined shape.
Trapezoid | Gets the Trapezoid predefined shape.

See Also

Shapes Class


MindFusion.Diagramming.Shapes Properties

Shapes Properties
[image]

Public Properties

Name | Description
Actor | Gets the Actor predefined shape.
Alternative | Gets the Alternative predefined shape.
Arrow1 | Gets the Arrow1 predefined shape.
Arrow2 | Gets the Arrow2 predefined shape.
Arrow3 | Gets the Arrow3 predefined shape.
Arrow4 | Gets the Arrow4 predefined shape.
Arrow5 | Gets the Arrow5 predefined shape.
Arrow6 | Gets the Arrow6 predefined shape.
Arrow7 | Gets the Arrow7 predefined shape.
Arrow8 | Gets the Arrow8 predefined shape.
Arrow9 | Gets the Arrow9 predefined shape.
BeginLoop | Gets the BeginLoop predefined shape.
BpmnComplex | Gets the BpmnComplex predefined shape.
BpmnDataBasedXor | Gets the BpmnDataBasedXor predefined shape.
BpmnEndCancel | Gets the BpmnEndCancel predefined shape.
BpmnEndCompensation | Gets the BpmnEndCompensation predefined shape.
BpmnEndError | Gets the BpmnEndError predefined shape.
BpmnEndLink | Gets the BpmnEndLink predefined shape.
BpmnEndMessage | Gets the BpmnEndMessage predefined shape.
BpmnEndMultiple | Gets the BpmnEndMultiple predefined shape.
BpmnEndTerminate | Gets the BpmnEndTerminate predefined shape.
BpmnEventBasedXor | Gets the BpmnEventBasedXor predefined shape.
BpmnInclusive | Gets the BpmnInclusive predefined shape.
BpmnIntermediateCancel | Gets the BpmnIntermediateCancel predefined shape.
BpmnIntermediateCompensation | Gets the BpmnIntermediateCompensation predefined shape.
BpmnIntermediateError | Gets the BpmnIntermediateError predefined shape.
BpmnIntermediateLink | Gets the BpmnIntermediateLink predefined shape.
BpmnIntermediateMessage | Gets the BpmnIntermediateMessage predefined shape.
BpmnIntermediateMultiple | Gets the BpmnIntermediateMultiple predefined shape.
BpmnIntermediateRule | Gets the BpmnIntermediateRule predefined shape.
BpmnIntermediateTimer | Gets the BpmnIntermediateTimer predefined shape.
BpmnParallelFork | Gets the BpmnParallelFork predefined shape.
BpmnStartLink | Gets the BpmnStartLink predefined shape.
BpmnStartMessage | Gets the BpmnStartMessage predefined shape.
BpmnStartMultiple | Gets the BpmnStartMultiple predefined shape.
BpmnStartRule | Gets the BpmnStartRule predefined shape.
BpmnStartTimer | Gets the BpmnStartTimer predefined shape.
Cloud | Gets the Cloud predefined shape.
Collate | Gets the Collate predefined shape.
ConeDown | Gets the ConeDown predefined shape.
ConeUp | Gets the ConeUp predefined shape.
ConnectedIssues | Gets the ConnectedIssues predefined shape.
CreateRequest | Gets the CreateRequest predefined shape.
Cross | Gets the Cross predefined shape.
Cube | Gets the Cube predefined shape.
Cylinder | Gets the Cylinder predefined shape.
Database | Gets the Database predefined shape.
DataTransmition | Gets the DataTransmition predefined shape.
DDelay | Gets the DDelay predefined shape.
Decagon | Gets the Decagon predefined shape.
Decision | Gets the Decision predefined shape.
Decision2 | Gets the Decision2 predefined shape.
Delay | Gets the Delay predefined shape.
DInDelay | Gets the DInDelay predefined shape.
DirectAccessStorage | Gets the DirectAccessStorage predefined shape.
DiskStorage | Gets the DiskStorage predefined shape.
Display | Gets the Display predefined shape.
DividedEvent | Gets the DividedEvent predefined shape.
DividedProcess | Gets the DividedProcess predefined shape.
Document | Gets the Document predefined shape.
Donut | Gets the Donut predefined shape.
DOutDelay | Gets the DOutDelay predefined shape.
Ellipse | Gets the Ellipse predefined shape.
EndLoop | Gets the EndLoop predefined shape.
ExternalOrganization | Gets the ExternalOrganization predefined shape.
ExternalProcess | Gets the ExternalProcess predefined shape.
File | Gets the File predefined shape.
FramedRectangle | Gets the FramedRectangle predefined shape.
Gate | Gets the Gate predefined shape.
Heart | Gets the Heart predefined shape.
Heptagon | Gets the Heptagon predefined shape.
Hourglass | Gets the Hourglass predefined shape.
Input | Gets the Input predefined shape.
InternalStorage | Gets the InternalStorage predefined shape.
Interrupt | Gets the Interrupt predefined shape.
Interrupt2 | Gets the Interrupt2 predefined shape.
IsoProcess | Gets the IsoProcess predefined shape.
Junction | Gets the Junction predefined shape.
Lightning | Gets the Lightning predefined shape.
LinedDocument | Gets the LinedDocument predefined shape.
ManualOperation | Gets the ManualOperation predefined shape.
Merge | Gets the Merge predefined shape.
MessageFromUser | Gets the MessageFromUser predefined shape.
MessageToUser | Gets the MessageToUser predefined shape.
Microform | Gets the Microform predefined shape.
MicroformProcessing | Gets the MicroformProcessing predefined shape.
MicroformRecording | Gets the MicroformRecording predefined shape.
MultiDocument | Gets the MultiDocument predefined shape.
MultiProc | Gets the MultiProc predefined shape.
Octagon | Gets the Octagon predefined shape.
OfflineStorage | Gets the OfflineStorage predefined shape.
OffpageConnection | Gets the OffpageConnection predefined shape.
OffpageReference | Gets the OffpageReference predefined shape.
Or | Gets the Or predefined shape.
Pentagon | Gets the Pentagon predefined shape.
Plaque | Gets the Plaque predefined shape.
PrimitiveFromCall | Gets the PrimitiveFromCall predefined shape.
PrimitiveToCall | Gets the PrimitiveToCall predefined shape.
Procedure | Gets the Procedure predefined shape.
Process | Gets the Process predefined shape.
Prysm | Gets the Prysm predefined shape.
PunchedCard | Gets the PunchedCard predefined shape.
PyramidDown | Gets the PyramidDown predefined shape.
PyramidUp | Gets the PyramidUp predefined shape.
Rectangle | Gets the Rectangle predefined shape.
RightTriangle | Gets the RightTriangle predefined shape.
RoundRect | Gets the RoundRect predefined shape.
RSave | Gets the RSave predefined shape.
Save | Gets the Save predefined shape.
Sort | Gets the Sort predefined shape.
Sphere | Gets the Sphere predefined shape.
Star | Gets the Star predefined shape.
Star16Pointed | Gets the Star16Pointed predefined shape.
Star24Pointed | Gets the Star24Pointed predefined shape.
Star32Pointed | Gets the Star32Pointed predefined shape.
Star4Pointed | Gets the Star4Pointed predefined shape.
Star5Pointed | Gets the Star5Pointed predefined shape.
Star6Pointed | Gets the Star6Pointed predefined shape.
Star7Pointed | Gets the Star7Pointed predefined shape.
Start | Gets the Start predefined shape.
Tape | Gets the Tape predefined shape.
Terminator | Gets the Terminator predefined shape.
TransmittalTape | Gets the TransmittalTape predefined shape.
Trapezoid | Gets the Trapezoid predefined shape.

See Also

Shapes Class


MindFusion.Diagramming.Shapes.Actor Property

Shapes.Actor Property
[image]

Gets the Actor predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Actor { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Actor As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Alternative Property

Shapes.Alternative Property
[image]

Gets the Alternative predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Alternative { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Alternative As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow1 Property

Shapes.Arrow1 Property
[image]

Gets the Arrow1 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow1 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow1 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
Table of Predefined Shapes


MindFusion.Diagramming.Shapes.Arrow2 Property

Shapes.Arrow2 Property
[image]

Gets the Arrow2 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow2 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow2 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow3 Property

Shapes.Arrow3 Property
[image]

Gets the Arrow3 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow3 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow3 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow4 Property

Shapes.Arrow4 Property
[image]

Gets the Arrow4 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow4 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow4 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow5 Property

Shapes.Arrow5 Property
[image]

Gets the Arrow5 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow5 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow5 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow6 Property

Shapes.Arrow6 Property
[image]

Gets the Arrow6 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow6 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow6 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow7 Property

Shapes.Arrow7 Property
[image]

Gets the Arrow7 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow7 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow7 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow8 Property

Shapes.Arrow8 Property
[image]

Gets the Arrow8 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow8 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow8 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow9 Property

Shapes.Arrow9 Property
[image]

Gets the Arrow9 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow9 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow9 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BeginLoop Property

Shapes.BeginLoop Property
[image]

Gets the BeginLoop predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BeginLoop { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BeginLoop As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnComplex Property

Shapes.BpmnComplex Property
[image]

Gets the BpmnComplex predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnComplex { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnComplex As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnDataBasedXor Property

Shapes.BpmnDataBasedXor Property
[image]

Gets the BpmnDataBasedXor predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnDataBasedXor { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnDataBasedXor As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndCancel Property

Shapes.BpmnEndCancel Property
[image]

Gets the BpmnEndCancel predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnEndCancel { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndCancel As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndCompensation Property

Shapes.BpmnEndCompensation Property
[image]

Gets the BpmnEndCompensation predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnEndCompensation { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndCompensation As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndError Property

Shapes.BpmnEndError Property
[image]

Gets the BpmnEndError predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnEndError { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndError As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndLink Property

Shapes.BpmnEndLink Property
[image]

Gets the BpmnEndLink predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnEndLink { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndLink As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndMessage Property

Shapes.BpmnEndMessage Property
[image]

Gets the BpmnEndMessage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnEndMessage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndMessage As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndMultiple Property

Shapes.BpmnEndMultiple Property
[image]

Gets the BpmnEndMultiple predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnEndMultiple { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndMultiple As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndTerminate Property

Shapes.BpmnEndTerminate Property
[image]

Gets the BpmnEndTerminate predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnEndTerminate { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndTerminate As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEventBasedXor Property

Shapes.BpmnEventBasedXor Property
[image]

Gets the BpmnEventBasedXor predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnEventBasedXor { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEventBasedXor As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnInclusive Property

Shapes.BpmnInclusive Property
[image]

Gets the BpmnInclusive predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnInclusive { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnInclusive As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateCancel Property

Shapes.BpmnIntermediateCancel Property
[image]

Gets the BpmnIntermediateCancel predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateCancel { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateCancel As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateCompensation Property

Shapes.BpmnIntermediateCompensation Property
[image]

Gets the BpmnIntermediateCompensation predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateCompensation { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateCompensation As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateError Property

Shapes.BpmnIntermediateError Property
[image]

Gets the BpmnIntermediateError predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateError { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateError As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateLink Property

Shapes.BpmnIntermediateLink Property
[image]

Gets the BpmnIntermediateLink predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateLink { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateLink As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateMessage Property

Shapes.BpmnIntermediateMessage Property
[image]

Gets the BpmnIntermediateMessage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateMessage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateMessage As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateMultiple Property

Shapes.BpmnIntermediateMultiple Property
[image]

Gets the BpmnIntermediateMultiple predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateMultiple { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateMultiple As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateRule Property

Shapes.BpmnIntermediateRule Property
[image]

Gets the BpmnIntermediateRule predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateRule { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateRule As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateTimer Property

Shapes.BpmnIntermediateTimer Property
[image]

Gets the BpmnIntermediateTimer predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateTimer { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateTimer As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnParallelFork Property

Shapes.BpmnParallelFork Property
[image]

Gets the BpmnParallelFork predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnParallelFork { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnParallelFork As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnStartLink Property

Shapes.BpmnStartLink Property
[image]

Gets the BpmnStartLink predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnStartLink { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnStartLink As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnStartMessage Property

Shapes.BpmnStartMessage Property
[image]

Gets the BpmnStartMessage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnStartMessage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnStartMessage As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnStartMultiple Property

Shapes.BpmnStartMultiple Property
[image]

Gets the BpmnStartMultiple predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnStartMultiple { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnStartMultiple As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnStartRule Property

Shapes.BpmnStartRule Property
[image]

Gets the BpmnStartRule predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnStartRule { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnStartRule As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnStartTimer Property

Shapes.BpmnStartTimer Property
[image]

Gets the BpmnStartTimer predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnStartTimer { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnStartTimer As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Cloud Property

Shapes.Cloud Property
[image]

Gets the Cloud predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Cloud { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Cloud As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
Table of Predefined Shapes


MindFusion.Diagramming.Shapes.Collate Property

Shapes.Collate Property
[image]

Gets the Collate predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Collate { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Collate As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.ConeDown Property

Shapes.ConeDown Property
[image]

Gets the ConeDown predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape ConeDown { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ConeDown As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.ConeUp Property

Shapes.ConeUp Property
[image]

Gets the ConeUp predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape ConeUp { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ConeUp As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.ConnectedIssues Property

Shapes.ConnectedIssues Property
[image]

Gets the ConnectedIssues predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape ConnectedIssues { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ConnectedIssues As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.CreateRequest Property

Shapes.CreateRequest Property
[image]

Gets the CreateRequest predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape CreateRequest { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property CreateRequest As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Cross Property

Shapes.Cross Property
[image]

Gets the Cross predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Cross { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Cross As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Cube Property

Shapes.Cube Property
[image]

Gets the Cube predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Cube { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Cube As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Cylinder Property

Shapes.Cylinder Property
[image]

Gets the Cylinder predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Cylinder { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Cylinder As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Database Property

Shapes.Database Property
[image]

Gets the Database predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Database { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Database As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DataTransmition Property

Shapes.DataTransmition Property
[image]

Gets the DataTransmition predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DataTransmition { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DataTransmition As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DDelay Property

Shapes.DDelay Property
[image]

Gets the DDelay predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DDelay { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DDelay As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Decagon Property

Shapes.Decagon Property
[image]

Gets the Decagon predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Decagon { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Decagon As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Decision Property

Shapes.Decision Property
[image]

Gets the Decision predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Decision { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Decision As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Decision2 Property

Shapes.Decision2 Property
[image]

Gets the Decision2 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Decision2 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Decision2 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Delay Property

Shapes.Delay Property
[image]

Gets the Delay predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Delay { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Delay As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DInDelay Property

Shapes.DInDelay Property
[image]

Gets the DInDelay predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DInDelay { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DInDelay As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DirectAccessStorage Property

Shapes.DirectAccessStorage Property
[image]

Gets the DirectAccessStorage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DirectAccessStorage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DirectAccessStorage As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DiskStorage Property

Shapes.DiskStorage Property
[image]

Gets the DiskStorage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DiskStorage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DiskStorage As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Display Property

Shapes.Display Property
[image]

Gets the Display predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Display { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Display As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DividedEvent Property

Shapes.DividedEvent Property
[image]

Gets the DividedEvent predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DividedEvent { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DividedEvent As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DividedProcess Property

Shapes.DividedProcess Property
[image]

Gets the DividedProcess predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DividedProcess { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DividedProcess As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Document Property

Shapes.Document Property
[image]

Gets the Document predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Document { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Document As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Donut Property

Shapes.Donut Property
[image]

Gets the Donut predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Donut { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Donut As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DOutDelay Property

Shapes.DOutDelay Property
[image]

Gets the DOutDelay predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DOutDelay { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DOutDelay As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Ellipse Property

Shapes.Ellipse Property
[image]

Gets the Ellipse predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Ellipse { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Ellipse As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.EndLoop Property

Shapes.EndLoop Property
[image]

Gets the EndLoop predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape EndLoop { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property EndLoop As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.ExternalOrganization Property

Shapes.ExternalOrganization Property
[image]

Gets the ExternalOrganization predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape ExternalOrganization { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ExternalOrganization As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.ExternalProcess Property

Shapes.ExternalProcess Property
[image]

Gets the ExternalProcess predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape ExternalProcess { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ExternalProcess As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.File Property

Shapes.File Property
[image]

Gets the File predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape File { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property File As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.FramedRectangle Property

Shapes.FramedRectangle Property
[image]

Gets the FramedRectangle predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape FramedRectangle { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property FramedRectangle As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Gate Property

Shapes.Gate Property
[image]

Gets the Gate predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Gate { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Gate As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Heart Property

Shapes.Heart Property
[image]

Gets the Heart predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Heart { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Heart As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Heptagon Property

Shapes.Heptagon Property
[image]

Gets the Heptagon predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Heptagon { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Heptagon As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Hourglass Property

Shapes.Hourglass Property
[image]

Gets the Hourglass predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Hourglass { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Hourglass As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Input Property

Shapes.Input Property
[image]

Gets the Input predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Input { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Input As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.InternalStorage Property

Shapes.InternalStorage Property
[image]

Gets the InternalStorage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape InternalStorage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property InternalStorage As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Interrupt Property

Shapes.Interrupt Property
[image]

Gets the Interrupt predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Interrupt { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Interrupt As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Interrupt2 Property

Shapes.Interrupt2 Property
[image]

Gets the Interrupt2 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Interrupt2 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Interrupt2 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.IsoProcess Property

Shapes.IsoProcess Property
[image]

Gets the IsoProcess predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape IsoProcess { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property IsoProcess As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Junction Property

Shapes.Junction Property
[image]

Gets the Junction predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Junction { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Junction As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Lightning Property

Shapes.Lightning Property
[image]

Gets the Lightning predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Lightning { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Lightning As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.LinedDocument Property

Shapes.LinedDocument Property
[image]

Gets the LinedDocument predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape LinedDocument { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property LinedDocument As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.ManualOperation Property

Shapes.ManualOperation Property
[image]

Gets the ManualOperation predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape ManualOperation { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ManualOperation As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Merge Property

Shapes.Merge Property
[image]

Gets the Merge predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Merge { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Merge As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.MessageFromUser Property

Shapes.MessageFromUser Property
[image]

Gets the MessageFromUser predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape MessageFromUser { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MessageFromUser As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.MessageToUser Property

Shapes.MessageToUser Property
[image]

Gets the MessageToUser predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape MessageToUser { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MessageToUser As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Microform Property

Shapes.Microform Property
[image]

Gets the Microform predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Microform { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Microform As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.MicroformProcessing Property

Shapes.MicroformProcessing Property
[image]

Gets the MicroformProcessing predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape MicroformProcessing { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MicroformProcessing As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.MicroformRecording Property

Shapes.MicroformRecording Property
[image]

Gets the MicroformRecording predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape MicroformRecording { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MicroformRecording As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.MultiDocument Property

Shapes.MultiDocument Property
[image]

Gets the MultiDocument predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape MultiDocument { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MultiDocument As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.MultiProc Property

Shapes.MultiProc Property
[image]

Gets the MultiProc predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape MultiProc { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MultiProc As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Octagon Property

Shapes.Octagon Property
[image]

Gets the Octagon predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Octagon { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Octagon As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.OfflineStorage Property

Shapes.OfflineStorage Property
[image]

Gets the OfflineStorage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape OfflineStorage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property OfflineStorage As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.OffpageConnection Property

Shapes.OffpageConnection Property
[image]

Gets the OffpageConnection predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape OffpageConnection { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property OffpageConnection As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.OffpageReference Property

Shapes.OffpageReference Property
[image]

Gets the OffpageReference predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape OffpageReference { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property OffpageReference As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Or Property

Shapes.Or Property
[image]

Gets the Or predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Or { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Or As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Pentagon Property

Shapes.Pentagon Property
[image]

Gets the Pentagon predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Pentagon { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Pentagon As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Plaque Property

Shapes.Plaque Property
[image]

Gets the Plaque predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Plaque { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Plaque As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.PrimitiveFromCall Property

Shapes.PrimitiveFromCall Property
[image]

Gets the PrimitiveFromCall predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape PrimitiveFromCall { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PrimitiveFromCall As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.PrimitiveToCall Property

Shapes.PrimitiveToCall Property
[image]

Gets the PrimitiveToCall predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape PrimitiveToCall { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PrimitiveToCall As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Procedure Property

Shapes.Procedure Property
[image]

Gets the Procedure predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Procedure { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Procedure As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Process Property

Shapes.Process Property
[image]

Gets the Process predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Process { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Process As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Prysm Property

Shapes.Prysm Property
[image]

Gets the Prysm predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Prysm { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Prysm As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.PunchedCard Property

Shapes.PunchedCard Property
[image]

Gets the PunchedCard predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape PunchedCard { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PunchedCard As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.PyramidDown Property

Shapes.PyramidDown Property
[image]

Gets the PyramidDown predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape PyramidDown { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PyramidDown As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.PyramidUp Property

Shapes.PyramidUp Property
[image]

Gets the PyramidUp predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape PyramidUp { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PyramidUp As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Rectangle Property

Shapes.Rectangle Property
[image]

Gets the Rectangle predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Rectangle { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Rectangle As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.RightTriangle Property

Shapes.RightTriangle Property
[image]

Gets the RightTriangle predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape RightTriangle { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property RightTriangle As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.RoundRect Property

Shapes.RoundRect Property
[image]

Gets the RoundRect predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape RoundRect { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property RoundRect As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.RSave Property

Shapes.RSave Property
[image]

Gets the RSave predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape RSave { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property RSave As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Save Property

Shapes.Save Property
[image]

Gets the Save predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Save { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Save As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Sort Property

Shapes.Sort Property
[image]

Gets the Sort predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Sort { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Sort As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Sphere Property

Shapes.Sphere Property
[image]

Gets the Sphere predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Sphere { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Sphere As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star Property

Shapes.Star Property
[image]

Gets the Star predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Star { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star16Pointed Property

Shapes.Star16Pointed Property
[image]

Gets the Star16Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Star16Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star16Pointed As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star24Pointed Property

Shapes.Star24Pointed Property
[image]

Gets the Star24Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Star24Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star24Pointed As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star32Pointed Property

Shapes.Star32Pointed Property
[image]

Gets the Star32Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Star32Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star32Pointed As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star4Pointed Property

Shapes.Star4Pointed Property
[image]

Gets the Star4Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Star4Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star4Pointed As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star5Pointed Property

Shapes.Star5Pointed Property
[image]

Gets the Star5Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Star5Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star5Pointed As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star6Pointed Property

Shapes.Star6Pointed Property
[image]

Gets the Star6Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Star6Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star6Pointed As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star7Pointed Property

Shapes.Star7Pointed Property
[image]

Gets the Star7Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Star7Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star7Pointed As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Start Property

Shapes.Start Property
[image]

Gets the Start predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Start { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Start As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Tape Property

Shapes.Tape Property
[image]

Gets the Tape predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Tape { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Tape As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Terminator Property

Shapes.Terminator Property
[image]

Gets the Terminator predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Terminator { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Terminator As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.TransmittalTape Property

Shapes.TransmittalTape Property
[image]

Gets the TransmittalTape predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape TransmittalTape { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property TransmittalTape As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Trapezoid Property

Shapes.Trapezoid Property
[image]

Gets the Trapezoid predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Trapezoid { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Trapezoid As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.ShowAnchors Enumeration

ShowAnchors Enumeration
[image]

Specifies when anchors points should be displayed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum ShowAnchors

Visual Basic [image] Copy Code

Public Enum ShowAnchors

Members

Member name | Description
Always | Anchor point marks are always painted.
Never | Anchor point marks are never painted.
Auto | Anchor point marks are shown for the node under the mouse cursor.
Selected | Anchor point marks are painted for the selected node.

Remarks

Members of this enumeration are used as values of the ShowAnchors property of the Diagram class. Auto and Selected can be combined using the bitwise or operator.

See Also

MindFusion.Diagramming Namespace
ShowAnchors Property
MarkStyle Enumeration


MindFusion.Diagramming.SimpleShape Enumeration

SimpleShape Enumeration
[image]

Defines the possible values for Shape property of tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum SimpleShape

Visual Basic [image] Copy Code

Public Enum SimpleShape

Members

Member name | Description
Rectangle | Sets table's shape to rectangle.
RoundedRectangle | Sets table's shape to rounded rectangle.

See Also


MindFusion.Diagramming.SizeFConverter Class

SizeFConverter Class
[image]

Converts from SizeF to other data types.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class SizeFConverter : TypeConverter

Visual Basic [image] Copy Code

Public Class SizeFConverter
Inherits TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
MindFusion.Diagramming.SizeFConverter

See Also

SizeFConverter Members


MindFusion.Diagramming.SizeFConverter Members

SizeFConverter Members
Constructors Methods
[image]

Converts from SizeF to other data types.

The following tables list the members exposed by the SizeFConverter type.

Public Constructors

Name | Description
SizeFConverter | Initializes a new instance of the SizeFConverter class.

Public Methods

Name | Description
CanConvertFrom | TypeConverter.CanConvertFrom override.
CanConvertTo | TypeConverter.CanConvertTo override.
ConvertFrom | TypeConverter.ConvertFrom override.
ConvertTo | TypeConverter.ConvertTo override.
CreateInstance | TypeConverter.CreateInstance override.
GetCreateInstanceSupported | TypeConverter.GetCreateInstanceSupported override.
GetProperties | TypeConverter.GetProperties override.
GetPropertiesSupported | TypeConverter.GetPropertiesSupported override.

See Also

SizeFConverter Class


MindFusion.Diagramming.SizeFConverter Constructor

SizeFConverter Constructor
[image]

Initializes a new instance of the SizeFConverter class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SizeFConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SizeFConverter Class


MindFusion.Diagramming.SizeFConverter Methods

SizeFConverter Methods
[image]

Public Methods

Name | Description
CanConvertFrom | TypeConverter.CanConvertFrom override.
CanConvertTo | TypeConverter.CanConvertTo override.
ConvertFrom | TypeConverter.ConvertFrom override.
ConvertTo | TypeConverter.ConvertTo override.
CreateInstance | TypeConverter.CreateInstance override.
GetCreateInstanceSupported | TypeConverter.GetCreateInstanceSupported override.
GetProperties | TypeConverter.GetProperties override.
GetPropertiesSupported | TypeConverter.GetPropertiesSupported override.

See Also

SizeFConverter Class


MindFusion.Diagramming.SizeFConverter.CanConvertFrom Method

SizeFConverter.CanConvertFrom Method
[image]

TypeConverter.CanConvertFrom override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool CanConvertFrom (
ITypeDescriptorContext context,
Type sourceType
)

Visual Basic [image] Copy Code

Public Overrides Function CanConvertFrom( _
context As ITypeDescriptorContext, _
sourceType As Type _
) As Boolean

Parameters

context

sourceType

Return Value

See Also

SizeFConverter Members
SizeFConverter Class


MindFusion.Diagramming.SizeFConverter.CanConvertTo Method

SizeFConverter.CanConvertTo Method
[image]

TypeConverter.CanConvertTo override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool CanConvertTo (
ITypeDescriptorContext context,
Type destinationType
)

Visual Basic [image] Copy Code

Public Overrides Function CanConvertTo( _
context As ITypeDescriptorContext, _
destinationType As Type _
) As Boolean

Parameters

context

destinationType

Return Value

See Also

SizeFConverter Members
SizeFConverter Class


MindFusion.Diagramming.SizeFConverter.ConvertFrom Method

SizeFConverter.ConvertFrom Method
[image]

TypeConverter.ConvertFrom override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Object ConvertFrom (
ITypeDescriptorContext context,
CultureInfo culture,
Object value
)

Visual Basic [image] Copy Code

Public Overrides Function ConvertFrom( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object _
) As Object

Parameters

context

culture

value

Return Value

See Also

SizeFConverter Members
SizeFConverter Class


MindFusion.Diagramming.SizeFConverter.ConvertTo Method

SizeFConverter.ConvertTo Method
[image]

TypeConverter.ConvertTo override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Object ConvertTo (
ITypeDescriptorContext context,
CultureInfo culture,
Object value,
Type destinationType
)

Visual Basic [image] Copy Code

Public Overrides Function ConvertTo( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object, _
destinationType As Type _
) As Object

Parameters

context

culture

value

destinationType

Return Value

See Also

SizeFConverter Members
SizeFConverter Class


MindFusion.Diagramming.SizeFConverter.CreateInstance Method

SizeFConverter.CreateInstance Method
[image]

TypeConverter.CreateInstance override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Object CreateInstance (
ITypeDescriptorContext context,
IDictionary propertyValues
)

Visual Basic [image] Copy Code

Public Overrides Function CreateInstance( _
context As ITypeDescriptorContext, _
propertyValues As IDictionary _
) As Object

Parameters

context

propertyValues

Return Value

See Also

SizeFConverter Members
SizeFConverter Class


MindFusion.Diagramming.SizeFConverter.GetCreateInstanceSupported Method

SizeFConverter.GetCreateInstanceSupported Method
[image]

TypeConverter.GetCreateInstanceSupported override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool GetCreateInstanceSupported (
ITypeDescriptorContext context
)

Visual Basic [image] Copy Code

Public Overrides Function GetCreateInstanceSupported( _
context As ITypeDescriptorContext _
) As Boolean

Parameters

context

Return Value

See Also

SizeFConverter Members
SizeFConverter Class


MindFusion.Diagramming.SizeFConverter.GetProperties Method

SizeFConverter.GetProperties Method
[image]

TypeConverter.GetProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override PropertyDescriptorCollection GetProperties (
ITypeDescriptorContext context,
Object value,
Attribute[] attributes
)

Visual Basic [image] Copy Code

Public Overrides Function GetProperties( _
context As ITypeDescriptorContext, _
value As Object, _
attributes() As Attribute _
) As PropertyDescriptorCollection

Parameters

context

value

attributes

Return Value

See Also

SizeFConverter Members
SizeFConverter Class


MindFusion.Diagramming.SizeFConverter.GetPropertiesSupported Method

SizeFConverter.GetPropertiesSupported Method
[image]

TypeConverter.GetPropertiesSupported override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool GetPropertiesSupported (
ITypeDescriptorContext context
)

Visual Basic [image] Copy Code

Public Overrides Function GetPropertiesSupported( _
context As ITypeDescriptorContext _
) As Boolean

Parameters

context

Return Value

See Also

SizeFConverter Members
SizeFConverter Class


MindFusion.Diagramming.SmoothShadowEffect Class

SmoothShadowEffect Class
Remarks See Also
[image]

Represents an effect that smooths the shadow of nodes. This effect does nothing if shadows are not visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class SmoothShadowEffect : NodeEffect

Visual Basic [image] Copy Code

Public NotInheritable Class SmoothShadowEffect
Inherits NodeEffect

Remarks

This effect can be applied to the nodes in a Diagram by adding an instance of this class to the NodeEffects collection. In addition, this effect will be active only when the Diagram.EffectsProvider property is set to an object implementing the GenerateShadow method of the IEffectsProvider interface.

The following image illustrates the Shadow effect applied to a rectangular node:

Example

The following example demonstrates how to apply smooth shadow effect to the nodes of an existing diagram.

C# [image] Copy Code

diagram.NodeEffects.Add(new SmoothShadowEffect());

Visual Basic [image] Copy Code

diagram.NodeEffects.Add(New SmoothShadowEffect())

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.NodeEffect
MindFusion.Diagramming.SmoothShadowEffect

See Also

SmoothShadowEffect Members


MindFusion.Diagramming.SmoothShadowEffect Members

SmoothShadowEffect Members
Constructors Properties Methods Events
[image]

Represents an effect that smooths the shadow of nodes. This effect does nothing if shadows are not visible.

The following tables list the members exposed by the SmoothShadowEffect type.

Public Constructors

Name | Description
SmoothShadowEffect | Initializes a new instance of the SmoothShadowEffect class.

Public Properties

Name | Description
Dispersion | Gets or sets the shadow dispersion.

Public Methods

Name | Description
Clone | NodeEffect.Clone override.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation. (Inherited from NodeEffect.)

See Also

SmoothShadowEffect Class


MindFusion.Diagramming.SmoothShadowEffect Constructor

SmoothShadowEffect Constructor
[image]

Initializes a new instance of the SmoothShadowEffect class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SmoothShadowEffect ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SmoothShadowEffect Class


MindFusion.Diagramming.SmoothShadowEffect Methods

SmoothShadowEffect Methods
[image]

Public Methods

Name | Description
Clone | NodeEffect.Clone override.

See Also

SmoothShadowEffect Class


MindFusion.Diagramming.SmoothShadowEffect.Clone Method

SmoothShadowEffect.Clone Method
[image]

NodeEffect.Clone override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

See Also

SmoothShadowEffect Members
SmoothShadowEffect Class


MindFusion.Diagramming.SmoothShadowEffect Properties

SmoothShadowEffect Properties
[image]

Public Properties

Name | Description
Dispersion | Gets or sets the shadow dispersion.

See Also

SmoothShadowEffect Class


MindFusion.Diagramming.SmoothShadowEffect.Dispersion Property

SmoothShadowEffect.Dispersion Property
[image]

Gets or sets the shadow dispersion.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Dispersion { get; set; }

Visual Basic [image] Copy Code

Public Property Dispersion As Integer

Property Value

Remarks

This property is hidden because it slows down performance with bigger values.

See Also

SmoothShadowEffect Members
SmoothShadowEffect Class


MindFusion.Diagramming.SmoothShadowEffect Events

SmoothShadowEffect Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation. (Inherited from NodeEffect.)

See Also

SmoothShadowEffect Class


MindFusion.Diagramming.SnapToAnchor Enumeration

SnapToAnchor Enumeration
[image]

Specifies when link ends are snapped to nearest anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum SnapToAnchor

Visual Basic [image] Copy Code

Public Enum SnapToAnchor

Members

Member name | Description
OnCreate | Snap to anchor point when creating a new link.
OnCreateOrModify | Snap to anchor point when creating or modifying a link.

Remarks

Members of this enumeration are used as values of the SnapToAnchor property of the Diagram class.

See Also

MindFusion.Diagramming Namespace
SnapToAnchor Property
ShowAnchors Enumeration


MindFusion.Diagramming.Style Class

Style Class
[image]

Represents an unordered dynamic collection of properties that can be identified by name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Style : IPersists

Visual Basic [image] Copy Code

Public Class Style
Implements IPersists

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Style
MindFusion.Diagramming.DiagramItemStyle
MindFusion.Diagramming.DiagramStyle

See Also

Style Members


MindFusion.Diagramming.Style Members

Style Members
Constructors Methods Events
[image]

Represents an unordered dynamic collection of properties that can be identified by name.

The following tables list the members exposed by the Style type.

Public Constructors

Name | Description
Style | Initializes a new instance of the Style class.

Public Methods

Name | Description
GetProperties | Gets all properties in the style.
GetProperty | Returns the property with the specified name, if any.
RegisterType | Associates a type with an alias.

Protected Methods

Name | Description
GetValue | Gets the value of the specified property.
IsPropertySet | Checks whether the specified property has a value.
LoadFrom | Deserializes the item from the specified reader.
LoadFromXml | Loads the style content from an XML element.
OnPropertyChanged | Raises the PropertyChanged event.
RegisterProperty | Registers a new property with the specified name and type.
SaveTo | Serializes the style to the specified writer.
SaveToXml | Saves the style content into an XML element.
SetValue | Sets the value of the specified property.
UnsetValue | Clears the value of the specified property.

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed.

See Also

Style Class


MindFusion.Diagramming.Style Constructor

Style Constructor
[image]

Initializes a new instance of the Style class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Style ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Style Class


MindFusion.Diagramming.Style Methods

Style Methods
[image]

Public Methods

Name | Description
GetProperties | Gets all properties in the style.
GetProperty | Returns the property with the specified name, if any.
RegisterType | Associates a type with an alias.

Protected Methods

Name | Description
GetValue | Gets the value of the specified property.
IsPropertySet | Checks whether the specified property has a value.
LoadFrom | Deserializes the item from the specified reader.
LoadFromXml | Loads the style content from an XML element.
OnPropertyChanged | Raises the PropertyChanged event.
RegisterProperty | Registers a new property with the specified name and type.
SaveTo | Serializes the style to the specified writer.
SaveToXml | Saves the style content into an XML element.
SetValue | Sets the value of the specified property.
UnsetValue | Clears the value of the specified property.

See Also

Style Class


MindFusion.Diagramming.Style.GetProperties Method

Style.GetProperties Method
[image]

Gets all properties in the style.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IEnumerable<IProperty> GetProperties ()

Visual Basic [image] Copy Code

Public Function GetProperties () As IEnumerable(Of IProperty)

Return Value

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.GetProperty Method

Style.GetProperty Method
[image]

Returns the property with the specified name, if any.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IProperty GetProperty (
string name
)

Visual Basic [image] Copy Code

Public Function GetProperty( _
name As String _
) As IProperty

Parameters

name

Return Value

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.GetValue Method

Style.GetValue Method
[image]

Gets the value of the specified property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Object GetValue (
Object property
)

Visual Basic [image] Copy Code

Protected Function GetValue( _
property As Object _
) As Object

Parameters

property

The property to get.

Return Value

The value of the property or null (Nothing in Visual Basic) if the property is not defined.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.IsPropertySet Method

Style.IsPropertySet Method
[image]

Checks whether the specified property has a value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected bool IsPropertySet (
Object property
)

Visual Basic [image] Copy Code

Protected Function IsPropertySet( _
property As Object _
) As Boolean

Parameters

property

The property to check.

Return Value

true if the property has a local value; otherwise, false.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.LoadFrom Method

Style.LoadFrom Method
[image]

Deserializes the item from the specified reader.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFrom (
BinaryReader reader,
PersistContext ctx
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFrom( _
reader As BinaryReader, _
ctx As PersistContext _
)

Parameters

reader

A BinaryReader object from which to read the item's data.

ctx

A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.LoadFromXml Method

Style.LoadFromXml Method
[image]

Loads the style content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement containing the style's data.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.OnPropertyChanged Method

Style.OnPropertyChanged Method
[image]

Raises the PropertyChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnPropertyChanged (
StylePropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPropertyChanged( _
e As StylePropertyChangedEventArgs _
)

Parameters

e

An object providing the event data.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.RegisterProperty Method

Style.RegisterProperty Method
[image]

Registers a new property with the specified name and type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Object RegisterProperty (
string name
)

Visual Basic [image] Copy Code

Protected Function RegisterProperty( _
name As String _
) As Object

Parameters

name

The name of the property.

Return Value

An object that can be used to identify the property in subsequent calls to methods like SetValue and GetValue.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.RegisterType Method

Style.RegisterType Method
[image]

Associates a type with an alias.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void RegisterType (
Type type,
string alias
)

Visual Basic [image] Copy Code

Public Shared Sub RegisterType( _
type As Type, _
alias As String _
)

Parameters

type

The type to associate.

alias

The unique alias for the type.

Remarks

The alias is used when saving and loading objects of the specified type during style serialization and deserialization.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.SaveTo Method

Style.SaveTo Method
[image]

Serializes the style to the specified writer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveTo (
BinaryWriter writer,
PersistContext ctx
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveTo( _
writer As BinaryWriter, _
ctx As PersistContext _
)

Parameters

writer

A BinaryWriter object the style data should be written to.

ctx

A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.SaveToXml Method

Style.SaveToXml Method
[image]

Saves the style content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement the style's data should be stored into.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.SetValue Method

Style.SetValue Method
[image]

Sets the value of the specified property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void SetValue (
Object property,
Object value
)

Visual Basic [image] Copy Code

Protected Sub SetValue( _
property As Object, _
value As Object _
)

Parameters

property

The property to set.

value

The new property value.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.UnsetValue Method

Style.UnsetValue Method
[image]

Clears the value of the specified property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void UnsetValue (
Object property
)

Visual Basic [image] Copy Code

Protected Sub UnsetValue( _
property As Object _
)

Parameters

property

The property to clear.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style Events

Style Events
[image]

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed.

See Also

Style Class


MindFusion.Diagramming.StylePropertyChangedEventArgs Class

StylePropertyChangedEventArgs Class
[image]

Contains the arguments passed to handlers of the PropertyChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class StylePropertyChangedEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class StylePropertyChangedEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.StylePropertyChangedEventArgs

See Also

StylePropertyChangedEventArgs Members


MindFusion.Diagramming.StylePropertyChangedEventArgs Members

StylePropertyChangedEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the PropertyChanged event.

The following tables list the members exposed by the StylePropertyChangedEventArgs type.

Public Properties

Name | Description
NewValue | Gets the new (current) value of the changed property.
OldValue | Gets the previous value of the changed property.
Property | Gets the property that has changed.

See Also

StylePropertyChangedEventArgs Class


MindFusion.Diagramming.StylePropertyChangedEventArgs Properties

StylePropertyChangedEventArgs Properties
[image]

Public Properties

Name | Description
NewValue | Gets the new (current) value of the changed property.
OldValue | Gets the previous value of the changed property.
Property | Gets the property that has changed.

See Also

StylePropertyChangedEventArgs Class


MindFusion.Diagramming.StylePropertyChangedEventArgs.NewValue Property

StylePropertyChangedEventArgs.NewValue Property
[image]

Gets the new (current) value of the changed property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object NewValue { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewValue As Object

Property Value

An object representing the new property value.

See Also

StylePropertyChangedEventArgs Members
StylePropertyChangedEventArgs Class


MindFusion.Diagramming.StylePropertyChangedEventArgs.OldValue Property

StylePropertyChangedEventArgs.OldValue Property
[image]

Gets the previous value of the changed property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object OldValue { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldValue As Object

Property Value

An object representing the old property value.

See Also

StylePropertyChangedEventArgs Members
StylePropertyChangedEventArgs Class


MindFusion.Diagramming.StylePropertyChangedEventArgs.Property Property

StylePropertyChangedEventArgs.Property Property
[image]

Gets the property that has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Property { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Property As Object

Property Value

An object identifying the changed property.

See Also

StylePropertyChangedEventArgs Members
StylePropertyChangedEventArgs Class


MindFusion.Diagramming.SvgNode Class

SvgNode Class
Remarks See Also
[image]

Represents nodes that can render SVG drawings.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class SvgNode : ShapeNode

Visual Basic [image] Copy Code

Public Class SvgNode
Inherits ShapeNode

Remarks

An SvgNode instance represents nodes that can display SVG drawings in addition to the rendering provided by the base ShapeNode class. The SVG drawing is rendered after the associated Image and just before the DrawNode event is raised with CustomDraw.Additional.

The SVG drawing of the node is specified through its Content property. The SVG graphics is loaded and associated with the node through an SvgContent object, which should be initialized and then assigned to this property.

The following code illustrates how to load an SVG graphics from a local file and associate it with an existing SvgNode (referenced by the svgNode variable):

C# [image] Copy Code

SvgContent content = new SvgContent();
content.Parse(@"c:\image.svg");
svgNode.Content = content;

VB.NET [image] Copy Code

Dim content As New SvgContent()
content.Parse("c:\image.svg")
svgNode.Content = content

Note

The SvgContent class is defined in the MindFusion.Svg.dll assembly. You need to add a reference to this assembly in the target project and import the necessary namespaces.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.ShapeNode
MindFusion.Diagramming.SvgNode

See Also

SvgNode Members


MindFusion.Diagramming.SvgNode Members

SvgNode Members
Constructors Fields Properties Methods
[image]

Represents nodes that can render SVG drawings.

The following tables list the members exposed by the SvgNode type.

Public Constructors

Name | Description
SvgNode | Overloaded. Initializes a new instance of the SvgNode class.

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Content | Gets or set an SvgContent instance representing the SVG drawing rendered in this node.
ContentAlign | Gets or sets the alignment of the SvgContent displayed in this node.
CustomDraw | Gets or sets the type of custom drawing performed on this shape node. (Inherited from ShapeNode.)
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
EnableStyledText | Gets or sets a value indicating whether styled text rendering is enabled. (Inherited from ShapeNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Font | Gets or sets the font used to render the node's text. (Inherited from ShapeNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
Image | Gets or sets the image that is displayed in this shape node. (Inherited from ShapeNode.)
ImageAlign | Gets or sets the alignment of the image displayed in this shape node. (Inherited from ShapeNode.)
ImageUrl | Gets or sets a URL used to load an image into this node. (Inherited from ShapeNode.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
PlainText | Gets the plain text of this shape node. (Inherited from ShapeNode.)
PolygonalTextLayout | Gets or sets a value indicating whether the node's Text is formatted inside non-rectangular outline. (Inherited from ShapeNode.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotateImage | Gets or sets a value indicating whether the Image should be rotated when the shape node is rotated. (Inherited from ShapeNode.)
RotateText | Gets or sets a value indicating whether the Text should be rotated when the shape node is rotated. (Inherited from ShapeNode.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Shape | Gets or sets a reference to the node's geometric shape definition. (Inherited from ShapeNode.)
ShapeOrientation | Gets or sets the angle specifying the orientation with which a shape template is applied to the node bounds. (Inherited from ShapeNode.)
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
SvgUrl | Gets or sets a URL used to load an SVG file into this node.
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
Text | Gets or sets the text displayed inside the shape node. (Inherited from ShapeNode.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextFormat | Gets or sets the alignment of the text that is displayed inside shape nodes. (Inherited from ShapeNode.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from ShapeNode.)
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Transparent | Gets or sets a value indicating whether this shape node is transparent. (Inherited from ShapeNode.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | Determines whether the node supports connections to its constituent elements. (Inherited from DiagramNode.)
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from ShapeNode.)
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override. (Inherited from ShapeNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
DoModify | For internal use. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramNode.DrawHandles override. Renders the adjustment handles of this item. (Inherited from ShapeNode.)
DrawLocal | Draws the node on the specified IGraphics surface. (Inherited from ShapeNode.)
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | Draws the shadow of this node on the specified IGraphics surface. (Inherited from ShapeNode.)
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item. (Inherited from DiagramItem.)
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item. (Inherited from DiagramItem.)
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item. (Inherited from DiagramItem.)
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item. (Inherited from DiagramItem.)
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline. (Inherited from ShapeNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | Node.GetOutlinePoly override. (Inherited from ShapeNode.)
GetRepaintRect | DiagramNode.GetRepaintRect override. (Inherited from ShapeNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramNode.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point. (Inherited from ShapeNode.)
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Intersects | Determines whether the node intersects another one, taking into account the outlines of node shapes. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | DiagramItem.OnLoad override. (Inherited from ShapeNode.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
ResizeToFitImage | Makes the shape node as big as the image it displays. (Inherited from ShapeNode.)
ResizeToFitText | Makes the shape node big enough to display its text without clipping. (Inherited from ShapeNode.)
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetPos | Sets the bounding rectangle of this node without updating connected arrows. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramNode.AllowModify override. Invoked during interactive modification of items to test whether the operation can be completed in the current context. (Inherited from ShapeNode.)
CancelModify | DiagramNode.CancelModify override. Invoked when the interactive modification of this object has been canceled. (Inherited from ShapeNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramNode.CompleteModify override. Invoked when the item modification has been completed. (Inherited from ShapeNode.)
ConstraintsInfringed | Checks whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramNode.CreateState override; creates a ShapeNodeState instance. (Inherited from ShapeNode.)
Dispose | Disposes any disposable resources managed by this shape. (Inherited from ShapeNode.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
Finalize | DiagramItem finalizer. (Inherited from DiagramItem.)
FreeResources | Called when the node is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetImageRect | Overloaded. Gets the destination rectangle of the node's image. (Inherited from ShapeNode.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from ShapeNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the item content from an XML element.
LoadObsolete | For internal use. (Inherited from DiagramItem.)
OnAdd | Called when the item is added to a Diagram, either by users, programmatically or via undo / redo. (Inherited from ShapeNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnClick | Invoked when the user clicks this item. (Inherited from DiagramItem.)
OnDoubleClick | Invoked when the user double-clicks this item. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes. (Inherited from ShapeNode.)
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | DiagramNode.OnRotationAngleChanged override. (Inherited from ShapeNode.)
OnStyleChanged | DiagramItem.OnStyleChanged override. (Inherited from ShapeNode.)
OnUpdateBounds | DiagramNode.OnUpdateBounds override. (Inherited from ShapeNode.)
OnZoomChanged | Called when the Diagram's ZoomFactor changes. (Inherited from ShapeNode.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramNode.RestoreState override. Restores the state of this diagram item. (Inherited from ShapeNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramNode.SaveState override. Saves the state of this diagram item. (Inherited from ShapeNode.)
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReference | Updates the reference to the specified object. (Inherited from ShapeNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramNode.StartModify override. Invoked when the user starts modifying this item interactively. (Inherited from ShapeNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster. (Inherited from DiagramItem.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramNode.UpdateModify override. Invoked during interactive modification of this item. (Inherited from ShapeNode.)

See Also

SvgNode Class


MindFusion.Diagramming.SvgNode Constructor

SvgNode Constructor
[image]

Initializes a new instance of the SvgNode class.

Overload List

Name | Description
SvgNode () | Initializes a new instance of the SvgNode class.
SvgNode (Diagram) | Initializes a new instance of the SvgNode class with default values supplied form the specified Diagram.
SvgNode (SvgNode) | Initializes a new instance of the SvgNode class using the specified node as a prototype.

See Also

SvgNode Class


MindFusion.Diagramming.SvgNode Constructor ()

SvgNode Constructor ()
See Also
[image]

Initializes a new instance of the SvgNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SvgNode ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SvgNode Constructor Overload List
SvgNode Class


MindFusion.Diagramming.SvgNode Constructor (Diagram)

SvgNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the SvgNode class with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SvgNode (
Diagram parent
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram _
)

Parameters

parent
The Diagram from which to obtain default values for the node properties.

See Also

SvgNode Constructor Overload List
SvgNode Class


MindFusion.Diagramming.SvgNode Constructor (SvgNode)

SvgNode Constructor (SvgNode)
See Also
[image]

Initializes a new instance of the SvgNode class using the specified node as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SvgNode (
SvgNode prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As SvgNode _
)

Parameters

prototype

The node to use as a prototype. The properties of the new node are initialized from the property values of this node.

See Also

SvgNode Constructor Overload List
SvgNode Class


MindFusion.Diagramming.SvgNode Methods

SvgNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from ShapeNode.)
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override. (Inherited from ShapeNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
DoModify | For internal use. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramNode.DrawHandles override. Renders the adjustment handles of this item. (Inherited from ShapeNode.)
DrawLocal | Draws the node on the specified IGraphics surface. (Inherited from ShapeNode.)
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | Draws the shadow of this node on the specified IGraphics surface. (Inherited from ShapeNode.)
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item. (Inherited from DiagramItem.)
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item. (Inherited from DiagramItem.)
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item. (Inherited from DiagramItem.)
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item. (Inherited from DiagramItem.)
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline. (Inherited from ShapeNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | Node.GetOutlinePoly override. (Inherited from ShapeNode.)
GetRepaintRect | DiagramNode.GetRepaintRect override. (Inherited from ShapeNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramNode.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point. (Inherited from ShapeNode.)
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Intersects | Determines whether the node intersects another one, taking into account the outlines of node shapes. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | DiagramItem.OnLoad override. (Inherited from ShapeNode.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
ResizeToFitImage | Makes the shape node as big as the image it displays. (Inherited from ShapeNode.)
ResizeToFitText | Makes the shape node big enough to display its text without clipping. (Inherited from ShapeNode.)
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetPos | Sets the bounding rectangle of this node without updating connected arrows. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramNode.AllowModify override. Invoked during interactive modification of items to test whether the operation can be completed in the current context. (Inherited from ShapeNode.)
CancelModify | DiagramNode.CancelModify override. Invoked when the interactive modification of this object has been canceled. (Inherited from ShapeNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramNode.CompleteModify override. Invoked when the item modification has been completed. (Inherited from ShapeNode.)
ConstraintsInfringed | Checks whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramNode.CreateState override; creates a ShapeNodeState instance. (Inherited from ShapeNode.)
Dispose | Disposes any disposable resources managed by this shape. (Inherited from ShapeNode.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
Finalize | DiagramItem finalizer. (Inherited from DiagramItem.)
FreeResources | Called when the node is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetImageRect | Overloaded. Gets the destination rectangle of the node's image. (Inherited from ShapeNode.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from ShapeNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the item content from an XML element.
LoadObsolete | For internal use. (Inherited from DiagramItem.)
OnAdd | Called when the item is added to a Diagram, either by users, programmatically or via undo / redo. (Inherited from ShapeNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnClick | Invoked when the user clicks this item. (Inherited from DiagramItem.)
OnDoubleClick | Invoked when the user double-clicks this item. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes. (Inherited from ShapeNode.)
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | DiagramNode.OnRotationAngleChanged override. (Inherited from ShapeNode.)
OnStyleChanged | DiagramItem.OnStyleChanged override. (Inherited from ShapeNode.)
OnUpdateBounds | DiagramNode.OnUpdateBounds override. (Inherited from ShapeNode.)
OnZoomChanged | Called when the Diagram's ZoomFactor changes. (Inherited from ShapeNode.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramNode.RestoreState override. Restores the state of this diagram item. (Inherited from ShapeNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramNode.SaveState override. Saves the state of this diagram item. (Inherited from ShapeNode.)
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReference | Updates the reference to the specified object. (Inherited from ShapeNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramNode.StartModify override. Invoked when the user starts modifying this item interactively. (Inherited from ShapeNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster. (Inherited from DiagramItem.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramNode.UpdateModify override. Invoked during interactive modification of this item. (Inherited from ShapeNode.)

See Also

SvgNode Class


MindFusion.Diagramming.SvgNode.CreateProperties Method

SvgNode.CreateProperties Method
[image]

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramItemProperties CreateProperties ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateProperties () As DiagramItemProperties

Return Value

A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

SvgNode Members
SvgNode Class


MindFusion.Diagramming.SvgNode.LoadFrom Method

SvgNode.LoadFrom Method
[image]

Deserializes the object from the specified reader.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFrom (
BinaryReader reader,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFrom ( _
reader As BinaryReader, _
context As PersistContext _
)

Parameters

reader
A BinaryReader object from which to read the item's data.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

SvgNode Members
SvgNode Class


MindFusion.Diagramming.SvgNode.LoadFromXml Method

SvgNode.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFromXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement containing the item's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

SvgNode Members
SvgNode Class


MindFusion.Diagramming.SvgNode.RestoreProperties Method

SvgNode.RestoreProperties Method
[image]

DiagramNode.RestoreProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overridable Sub RestoreProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

SvgNode Members
SvgNode Class


MindFusion.Diagramming.SvgNode.SaveProperties Method

SvgNode.SaveProperties Method
[image]

DiagramNode.SaveProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties-derived object where the item's properties should be saved.

See Also

SvgNode Members
SvgNode Class


MindFusion.Diagramming.SvgNode.SaveTo Method

SvgNode.SaveTo Method
[image]

Serializes the object to the specified writer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveTo (
BinaryWriter writer,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveTo ( _
writer As BinaryWriter, _
context As PersistContext _
)

Parameters

writer
A BinaryWriter object the item's data should be written to.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

SvgNode Members
SvgNode Class


MindFusion.Diagramming.SvgNode.SaveToXml Method

SvgNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveToXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement the item's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

SvgNode Members
SvgNode Class


MindFusion.Diagramming.SvgNode Properties

SvgNode Properties
[image]

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Content | Gets or set an SvgContent instance representing the SVG drawing rendered in this node.
ContentAlign | Gets or sets the alignment of the SvgContent displayed in this node.
CustomDraw | Gets or sets the type of custom drawing performed on this shape node. (Inherited from ShapeNode.)
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
EnableStyledText | Gets or sets a value indicating whether styled text rendering is enabled. (Inherited from ShapeNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Font | Gets or sets the font used to render the node's text. (Inherited from ShapeNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
Image | Gets or sets the image that is displayed in this shape node. (Inherited from ShapeNode.)
ImageAlign | Gets or sets the alignment of the image displayed in this shape node. (Inherited from ShapeNode.)
ImageUrl | Gets or sets a URL used to load an image into this node. (Inherited from ShapeNode.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
PlainText | Gets the plain text of this shape node. (Inherited from ShapeNode.)
PolygonalTextLayout | Gets or sets a value indicating whether the node's Text is formatted inside non-rectangular outline. (Inherited from ShapeNode.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotateImage | Gets or sets a value indicating whether the Image should be rotated when the shape node is rotated. (Inherited from ShapeNode.)
RotateText | Gets or sets a value indicating whether the Text should be rotated when the shape node is rotated. (Inherited from ShapeNode.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Shape | Gets or sets a reference to the node's geometric shape definition. (Inherited from ShapeNode.)
ShapeOrientation | Gets or sets the angle specifying the orientation with which a shape template is applied to the node bounds. (Inherited from ShapeNode.)
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
SvgUrl | Gets or sets a URL used to load an SVG file into this node.
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
Text | Gets or sets the text displayed inside the shape node. (Inherited from ShapeNode.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextFormat | Gets or sets the alignment of the text that is displayed inside shape nodes. (Inherited from ShapeNode.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from ShapeNode.)
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Transparent | Gets or sets a value indicating whether this shape node is transparent. (Inherited from ShapeNode.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | Determines whether the node supports connections to its constituent elements. (Inherited from DiagramNode.)
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

See Also

SvgNode Class


MindFusion.Diagramming.SvgNode.Content Property

SvgNode.Content Property
[image]

Gets or set an SvgContent instance representing the SVG drawing rendered in this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SvgContent Content { get; set; }

Visual Basic [image] Copy Code

Public Property Content As SvgContent

Property Value

An instance of the MindFusion.Svg.SvgContent class representing the SVG drawing.

Remarks

The SvgContent class is defined in the MindFusion.Svg.dll file. You must add a reference to this assembly to the target project.

Example

The following example illustrates how to create an SvgContent object from a local SVG file and associate it with an existing SvgNode object. The SvgNode object is referenced by the node variable.

C# [image] Copy Code
SvgContent content = new SvgContent();
content.Parse(@"c:\image.svg");
node.Content = content;
Visual Basic [image] Copy Code
Dim content As New SvgContent()
content.Parse("c:\image.svg")
node.Content = content

See Also

SvgNode Members
SvgNode Class


MindFusion.Diagramming.SvgNode.ContentAlign Property

SvgNode.ContentAlign Property
[image]

Gets or sets the alignment of the SvgContent displayed in this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ImageAlign ContentAlign { get; set; }

Visual Basic [image] Copy Code

Public Property ContentAlign As ImageAlign

Property Value

A member of the ImageAlign enumeration. The default is Fit.

See Also

SvgNode Members
SvgNode Class


MindFusion.Diagramming.SvgNode.SvgUrl Property

SvgNode.SvgUrl Property
[image]

Gets or sets a URL used to load an SVG file into this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string SvgUrl { get; set; }

Visual Basic [image] Copy Code

Public Property SvgUrl As String

Property Value

A string specifying the SVG file location.

Remarks

At this time this property is used only in web versions of the component (ASP.NET and ASP.NET MVC). Note that the MIME type of .svg files on server should be set to image/svg+xml.

See Also

SvgNode Members
SvgNode Class


MindFusion.Diagramming.SvgNodeProperties Class

SvgNodeProperties Class
[image]

Stores the values of SvgNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from SvgNode, do so by deriving from SvgNodeProperties and overriding the SvgNode.SaveProperties, SvgNode.RestoreProperties, and SvgNode.CreateProperties methods.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class SvgNodeProperties : ShapeNodeProperties

Visual Basic [image] Copy Code

Public Class SvgNodeProperties
Inherits ShapeNodeProperties

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemProperties
MindFusion.Diagramming.DiagramNodeProperties
MindFusion.Diagramming.ShapeNodeProperties
MindFusion.Diagramming.SvgNodeProperties

See Also

SvgNodeProperties Members


MindFusion.Diagramming.SvgNodeProperties Members

SvgNodeProperties Members
Constructors Fields Methods
[image]

Stores the values of SvgNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from SvgNode, do so by deriving from SvgNodeProperties and overriding the SvgNode.SaveProperties, SvgNode.RestoreProperties, and SvgNode.CreateProperties methods.

The following tables list the members exposed by the SvgNodeProperties type.

Public Constructors

Name | Description
SvgNodeProperties | Initializes a new instance of the SvgNodeProperties class.

Public Fields

Name | Description
ItemClass | For internal use. (Inherited from DiagramItemProperties.)
RotateText | For internal use. (Inherited from ShapeNodeProperties.)
Selected | For internal use. (Inherited from DiagramItemProperties.)
Shape | For internal use. (Inherited from ShapeNodeProperties.)
ShapeOrientation | For internal use. (Inherited from ShapeNodeProperties.)
Text | For internal use. (Inherited from ShapeNodeProperties.)
TextPadding | For internal use. (Inherited from DiagramItemProperties.)
Transparent | For internal use. (Inherited from ShapeNodeProperties.)
UsePolyTextLt | For internal use. (Inherited from ShapeNodeProperties.)
ZIndex | For internal use. (Inherited from DiagramItemProperties.)

Public Methods

Name | Description
FreeResources | DiagramItemProperties.FreeResources override. (Inherited from ShapeNodeProperties.)

See Also

SvgNodeProperties Class


MindFusion.Diagramming.SvgNodeProperties Constructor

SvgNodeProperties Constructor
[image]

Initializes a new instance of the SvgNodeProperties class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SvgNodeProperties ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SvgNodeProperties Class


MindFusion.Diagramming.SvgNodeStyle Class

SvgNodeStyle Class
[image]

Represents a reusable set of properties that define the appearance of SVG nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class SvgNodeStyle : DiagramNodeStyle

Visual Basic [image] Copy Code

Public Class SvgNodeStyle
Inherits DiagramNodeStyle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Style
MindFusion.Diagramming.DiagramItemStyle
MindFusion.Diagramming.DiagramNodeStyle
MindFusion.Diagramming.SvgNodeStyle

See Also

SvgNodeStyle Members


MindFusion.Diagramming.SvgNodeStyle Members

SvgNodeStyle Members
Constructors Properties Methods Events
[image]

Represents a reusable set of properties that define the appearance of SVG nodes.

The following tables list the members exposed by the SvgNodeStyle type.

Public Constructors

Name | Description
SvgNodeStyle | Initializes a new instance of the SvgNodeStyle class.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of the item. (Inherited from DiagramItemStyle.)
Effects | Gets a list of the effects applied to the node. (Inherited from DiagramNodeStyle.)
FontFamily | Gets or sets the font family of the item text. (Inherited from DiagramItemStyle.)
FontSize | Gets or sets the font size of the item text. (Inherited from DiagramItemStyle.)
FontStyle | Gets or sets the font style of the item text. (Inherited from DiagramItemStyle.)
FontUnit | Gets or sets the font unit of the item text. (Inherited from DiagramItemStyle.)
ShadowBrush | Gets or sets the brush used to paint the shadow of the item. (Inherited from DiagramItemStyle.)
Stroke | Gets or sets the brush used to paint the outline of the item. (Inherited from DiagramItemStyle.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItemStyle.)
StrokeThickness | Gets or sets the thickness of the item's outline, expressed in the current units of measure. (Inherited from DiagramItemStyle.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItemStyle.)

Public Methods

Name | Description
GetProperties | Gets all properties in the style. (Inherited from Style.)
GetProperty | Returns the property with the specified name, if any. (Inherited from Style.)
RegisterType | Associates a type with an alias. (Inherited from Style.)

Protected Methods

Name | Description
GetValue | Gets the value of the specified property. (Inherited from Style.)
IsPropertySet | Checks whether the specified property has a value. (Inherited from Style.)
LoadFrom | Deserializes the item from the specified reader. (Inherited from Style.)
LoadFromXml | Loads the style content from an XML element. (Inherited from Style.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Style.)
RegisterProperty | Registers a new property with the specified name and type. (Inherited from Style.)
SaveTo | Serializes the style to the specified writer. (Inherited from Style.)
SaveToXml | Saves the style content into an XML element. (Inherited from Style.)
SetValue | Sets the value of the specified property. (Inherited from Style.)
UnsetValue | Clears the value of the specified property. (Inherited from Style.)

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

SvgNodeStyle Class


MindFusion.Diagramming.SvgNodeStyle Constructor

SvgNodeStyle Constructor
[image]

Initializes a new instance of the SvgNodeStyle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SvgNodeStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SvgNodeStyle Class


MindFusion.Diagramming.SvgNodeStyle Events

SvgNodeStyle Events
[image]

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

SvgNodeStyle Class


MindFusion.Diagramming.TableConnectionStyle Enumeration

TableConnectionStyle Enumeration
[image]

Specifies the possible values for the ConnectionStyle property of tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum TableConnectionStyle

Visual Basic [image] Copy Code

Public Enum TableConnectionStyle

Members

Member name | Description
Table | Users are allowed to create relations to a table as whole entity.
Rows | Users are allowed to create relations to the rows of a table.
Both | Users are allowed to create relations both to the rows of a table or the the table as a whole.

Remarks

The enumeration provides possible values for the ConnectionStyle property, which specifies whether relation ends are the rows of a table or the table as a whole entity.

See Also


MindFusion.Diagramming.TableNode Class

TableNode Class
Remarks See Also
[image]

Tables are diagram nodes that can contain multiple cells and can be related to other nodes through their rows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TableNode : DiagramNode, InplaceEditable

Visual Basic [image] Copy Code

Public Class TableNode
Inherits DiagramNode
Implements InplaceEditable

Remarks

Tables in flow diagrams are represented by instances of the TableNode class. Probably the most important property of tables is ConnectionStyle, which specifies whether users are allowed to draw links to the rows of a table, to the table as an integral entity, or both.

Tables consist of Cell instances distributed across rows and columns. Number of rows and columns can be set with the RowCount and ColumnCount properties. The width of the columns is set with ColumnWidth property and the height of the rows with the RowHeight property. Cells can be made to span several rows and columns by setting their RowSpan and ColumnSpan properties to values larger than one.

Rows can be assigned to distinct sections of the table. Each section can be collapsed or expanded, hiding or showing all rows in the section except the header one. To define a section, set a Header row. A section consists of all rows after a header row and spans to the next header. Each header row displays a [±] button that allows expanding or collapsing the section interactively. The button appears either on the left of the first cell of a header row or in a separate column, as set in OffsetHeaderRows. Clicking that button raises the TableSectionCollapsed and TableSectionExpanded events. Sections can be collapsed or expanded programmatically using the Expanded property of their header rows.

The structure of a table can be dynamically changed by adding and deleting rows and columns. This can be done with the AddColumn and AddRow methods as well as with the InsertColumn, InsertRow and RedimTable methods. DeleteRow and DeleteColumn methods delete existing rows and columns.

Table cells contain Text, displayed as specified through TextBrush and TextFormat. A table can also have a caption, whose text is set by the Caption property. The height of the caption and the alignment of the text are specified by CaptionHeight and CaptionFormat properties. To get even richer text formatting, set EnableStyledText to true and embed HTML-like formatting tags in the caption and cell texts. The ResizeToFitText method resizes all columns and rows so that each table cell fits its text on a single line without clipping it.

To display a text box that lets users edit the table caption or the text of a cell, call the BeginEdit method of DiagramView. Call EndEdit to exit the in-place editing mode. If the view's AllowInplaceEdit property is enabled, users can double-click the table caption bar or a cell in order to edit their text.

The interior of tables is filled using their Brush property. The color of the table and cell borders can be set by using the Pen property. The table caption area is painted using the CaptionBackBrush brush.

In order to set an image as table's background use the Image property. The alignment of the image in relation to the table's rectangle is set through the ImageAlign property. The table can be resized to fit the size of its image by calling the ResizeToFitImage method.

The rectangle, which a table occupies, is accessible with the Bounds property. Rows and columns that build the table are stored and accessed by means of the Rows and Columns collections.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.TableNode

See Also

TableNode Members


MindFusion.Diagramming.TableNode Members

TableNode Members
Constructors Fields Properties Methods
[image]

Tables are diagram nodes that can contain multiple cells and can be related to other nodes through their rows.

The following tables list the members exposed by the TableNode type.

Public Constructors

Name | Description
TableNode | Overloaded. Initializes a new instance of the TableNode class.

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AllowResizeColumns | Gets or sets a value indicating whether users are allowed to resize table columns.
AllowResizeRows | Gets or sets a value indicating whether users are allowed to resize table rows.
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Caption | Gets or sets the text displayed as caption of the table.
CaptionBackBrush | Gets or sets the brush used to paint the caption area of this table.
CaptionBrush | Gets or sets the brush used to paint the table caption.
CaptionFormat | Gets or sets the alignment and line position of the text used as table caption.
CaptionHeight | Gets or sets the height of the table's caption area.
CaptionPlainText | Gets the plain text of the table's caption.
CellCustomDraw | Gets or sets the type of custom drawing performed on the table cells.
CellFrameStyle | Gets or sets the style of the table cells.
CellTextBrush | Gets or sets the brush used to paint texts inside table cells.
ColumnCount | Gets or sets the number of columns in the table.
Columns | Gets a list of all columns in the table.
ColumnWidth | Gets or sets the default width of the table columns.
ConnectionStyle | Gets or sets a value indicating whether drawing a link from/to this table, should connect a row of the table, or the whole table as single entity.
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
CurrentScrollRow | Gets or sets the index of the first visible row in the table.
CustomDraw | Gets or sets the type of custom drawing performed on this table.
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveCaptionBackBrush | Gets the effective caption back brush of the table.
EffectiveCaptionBrush | Gets the effective caption brush of the table.
EffectiveCellTextBrush | Gets the effective text brush of the table cells.
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
EnableStyledText | Gets or sets a value indicating whether styled text rendering is enabled.
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Font | Gets or sets the font used when rendering the table's texts.
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HighlightedRow | Gets or sets the highlighted row.
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
Image | Gets or sets the image that is displayed in this table.
ImageAlign | Gets or sets the alignment of the image displayed in this table.
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
Item | Gets the Cell instance at the specified position.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OffsetHeaderRows | Gets or sets a value indicating whether the table cells are offset to the right to accommodate for the expand buttons of Header rows.
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RowAnchorPattern | Gets or sets a default anchor pattern for the rows of this table.
RowCount | Gets or sets the number of rows in the table.
RowHeight | Gets or sets the default height of table rows.
Rows | Gets a list of all rows in the table.
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Scrollable | Gets or sets a value indicating whether users are allowed to scroll table rows.
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Shape | Gets or sets the shape of the table's outline.
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text.
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | DiagramNode.HasItems override.
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

Public Methods

Name | Description
AcceptLinks | DiagramNode.AcceptLinks override.
AddColumn | Adds new empty column at the right end of the table.
AddRelation | Creates a relation with the specified table.
AddRow | Adds new empty row at the bottom of the table.
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
BreakRelation | Breaks the relation with the specified table.
CellFromPoint | Returns the row and column indices of the cell located at the specified point, taking into consideration the cells span.
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
DeleteColumn | Deletes the column with the specified index within the table.
DeleteRow | Deletes the row at the specified position within the table.
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
DoModify | For internal use. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawAnchors | DiagramNode.DrawAnchors override.
DrawHandles | DiagramItem.DrawHandles override. Renders the adjustment handles of this item. (Inherited from DiagramNode.)
DrawLocal | Draws the node on the specified IGraphics surface.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | Draws the shadow of this node on the specified IGraphics surface.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item. (Inherited from DiagramItem.)
GetEffectiveCaptionBackBrush | Creates a System.Drawing.Brush object representing the currently effective caption back brush of the table.
GetEffectiveCaptionBrush | Creates a System.Drawing.Brush object representing the currently effective caption brush of the table.
GetEffectiveCellTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the table cells.
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item. (Inherited from DiagramItem.)
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item. (Inherited from DiagramItem.)
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item. (Inherited from DiagramItem.)
GetIntersection | DiagramNode.GetIntersection override.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetSpannedCellRect | Overloaded. Calculates the bounding rectangle of the specified cell, taking in consideration the cell's row and column spans.
GetToolTip | DiagramNode.GetToolTip override.
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point. (Inherited from DiagramNode.)
HitTestManipulators | DiagramItem.HitTestManipulators override.
InsertColumn | Inserts new empty column at the specified position within the table.
InsertRow | Inserts new empty row at the specified position within the table.
Intersects | Determines whether the node intersects another one, taking into account the outlines of node shapes. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | DiagramItem.OnLoad override.
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RedimTable | Sets new number of rows and columns for this table.
Resize | Resizes the node. (Inherited from DiagramNode.)
ResizeToFitImage | Makes a table as big as the image it displays.
ResizeToFitText | Overloaded.
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
ScrollDown | Scrolls the table rows downwards.
ScrollUp | Scrolls the table rows upwards.
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetPos | Sets the bounding rectangle of this node without updating connected arrows. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
CancelModify | DiagramItem.CancelModify override. Invoked when the interactive modification of this object has been canceled. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Checks whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
Dispose | Disposes any disposable resources managed by this table.
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
Finalize | DiagramItem finalizer. (Inherited from DiagramItem.)
FreeResources | Called when the node is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramNode.)
GetAllIncomingLinks | Node.GetAllIncomingLinks override.
GetAllOutgoingLinks | Node.GetAllOutgoingLinks override.
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from DiagramNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the item content from an XML element.
LoadObsolete | For internal use. (Inherited from DiagramItem.)
OnAdd | DiagramItem.OnAdd override. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnClick | Invoked when the user clicks this item. (Inherited from DiagramItem.)
OnDoubleClick | Invoked when the user double-clicks this item. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes.
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | DiagramItem.OnStyleChanged override.
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the DiagramView.ZoomFactor changes.
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
ScaleElements | DiagramNode.ScaleElements override.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReference | Updates the reference to the specified object.
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it.
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. Invoked when the user starts modifying this item interactively. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster. (Inherited from DiagramItem.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. Invoked during interactive modification of this item. (Inherited from DiagramNode.)

See Also

TableNode Class


MindFusion.Diagramming.TableNode Constructor

TableNode Constructor
[image]

Initializes a new instance of the TableNode class.

Overload List

Name | Description
TableNode () | Initializes a new instance of the TableNode class.
TableNode (Diagram) | Initializes a new instance of the TableNode class.
TableNode (TableNode) | Initializes a new instance of the TableNode class using the specified node as a prototype.

See Also

TableNode Class


MindFusion.Diagramming.TableNode Constructor ()

TableNode Constructor ()
See Also
[image]

Initializes a new instance of the TableNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TableNode Constructor Overload List
TableNode Class


MindFusion.Diagramming.TableNode Constructor (Diagram)

TableNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the TableNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode (
Diagram parent
)

Visual Basic [image] Copy Code

Public Sub TableNode ( _
parent As Diagram _
)

Parameters

parent

The Diagram from which to obtain default values for the node properties.

Remarks

This constructor initializes the TableNode properties with the values specified in the respective default-value properties of the Diagram object. For more information see Initial Values of Item Properties.

See Also

TableNode Constructor Overload List
TableNode Class


MindFusion.Diagramming.TableNode Constructor (TableNode)

TableNode Constructor (TableNode)
See Also
[image]

Initializes a new instance of the TableNode class using the specified node as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode (
TableNode prototype
)

Visual Basic [image] Copy Code

Public Sub TableNode ( _
prototype As TableNode _
)

Parameters

prototype

The table node to use as a prototype. The properties of the new table are initialized from the property values of prototype.

Remarks

This constructor copies the TableNode property values from the specified prototype node.

See Also

TableNode Constructor Overload List
TableNode Class


MindFusion.Diagramming.TableNode Methods

TableNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | DiagramNode.AcceptLinks override.
AddColumn | Adds new empty column at the right end of the table.
AddRelation | Creates a relation with the specified table.
AddRow | Adds new empty row at the bottom of the table.
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
BreakRelation | Breaks the relation with the specified table.
CellFromPoint | Returns the row and column indices of the cell located at the specified point, taking into consideration the cells span.
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
DeleteColumn | Deletes the column with the specified index within the table.
DeleteRow | Deletes the row at the specified position within the table.
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
DoModify | For internal use. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawAnchors | DiagramNode.DrawAnchors override.
DrawHandles | DiagramItem.DrawHandles override. Renders the adjustment handles of this item. (Inherited from DiagramNode.)
DrawLocal | Draws the node on the specified IGraphics surface.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | Draws the shadow of this node on the specified IGraphics surface.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item. (Inherited from DiagramItem.)
GetEffectiveCaptionBackBrush | Creates a System.Drawing.Brush object representing the currently effective caption back brush of the table.
GetEffectiveCaptionBrush | Creates a System.Drawing.Brush object representing the currently effective caption brush of the table.
GetEffectiveCellTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the table cells.
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item. (Inherited from DiagramItem.)
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item. (Inherited from DiagramItem.)
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item. (Inherited from DiagramItem.)
GetIntersection | DiagramNode.GetIntersection override.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetSpannedCellRect | Overloaded. Calculates the bounding rectangle of the specified cell, taking in consideration the cell's row and column spans.
GetToolTip | DiagramNode.GetToolTip override.
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point. (Inherited from DiagramNode.)
HitTestManipulators | DiagramItem.HitTestManipulators override.
InsertColumn | Inserts new empty column at the specified position within the table.
InsertRow | Inserts new empty row at the specified position within the table.
Intersects | Determines whether the node intersects another one, taking into account the outlines of node shapes. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | DiagramItem.OnLoad override.
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RedimTable | Sets new number of rows and columns for this table.
Resize | Resizes the node. (Inherited from DiagramNode.)
ResizeToFitImage | Makes a table as big as the image it displays.
ResizeToFitText | Overloaded.
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
ScrollDown | Scrolls the table rows downwards.
ScrollUp | Scrolls the table rows upwards.
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetPos | Sets the bounding rectangle of this node without updating connected arrows. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
CancelModify | DiagramItem.CancelModify override. Invoked when the interactive modification of this object has been canceled. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Checks whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
Dispose | Disposes any disposable resources managed by this table.
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
Finalize | DiagramItem finalizer. (Inherited from DiagramItem.)
FreeResources | Called when the node is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramNode.)
GetAllIncomingLinks | Node.GetAllIncomingLinks override.
GetAllOutgoingLinks | Node.GetAllOutgoingLinks override.
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from DiagramNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the item content from an XML element.
LoadObsolete | For internal use. (Inherited from DiagramItem.)
OnAdd | DiagramItem.OnAdd override. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnClick | Invoked when the user clicks this item. (Inherited from DiagramItem.)
OnDoubleClick | Invoked when the user double-clicks this item. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes.
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | DiagramItem.OnStyleChanged override.
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the DiagramView.ZoomFactor changes.
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
ScaleElements | DiagramNode.ScaleElements override.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReference | Updates the reference to the specified object.
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it.
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. Invoked when the user starts modifying this item interactively. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster. (Inherited from DiagramItem.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. Invoked during interactive modification of this item. (Inherited from DiagramNode.)

See Also

TableNode Class


MindFusion.Diagramming.TableNode.AcceptLinks Method

TableNode.AcceptLinks Method
[image]

DiagramNode.AcceptLinks override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool AcceptLinks (
bool outgoing
)

Visual Basic [image] Copy Code

Public Overrides Function AcceptLinks( _
outgoing As Boolean _
) As Boolean

Parameters

outgoing
true to check for outgoing links; otherwise, false.

Return Value

true if the node accepts connections of the specified type; otherwise, false.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.AddColumn Method

TableNode.AddColumn Method
[image]

Adds new empty column at the right end of the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int AddColumn ()

Visual Basic [image] Copy Code

Public Function AddColumn () As Integer

Return Value

Returns the index of the newly added column within the Columns collection.

Remarks

Call the method to add new columns at the end of the table. The size of the table is automatically updated and the columns are added to the column collection.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
InsertColumn Method
DeleteColumn Method
RedimTable Method
Columns Property


MindFusion.Diagramming.TableNode.AddRelation Method

TableNode.AddRelation Method
[image]

Creates a relation with the specified table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink AddRelation (
int row,
Relationship rel,
TableNode tableNode,
int relRow
)

Visual Basic [image] Copy Code

Public Function AddRelation ( _
row As Integer, _
rel As Relationship, _
tableNode As TableNode, _
relRow As Integer _
) As DiagramLink

Parameters

row
Zero-based index of a row in this table to be related.
rel
The type of the relation (and the direction of the link).
tableNode
The other table in the relation.
relRow
Zero-based index of the row in the other table.

Return Value

A DiagramLink object representing the relation.

Remarks

Call this method to link rows of two tables.

See Also

TableNode Members
TableNode Class
BreakRelation Method


MindFusion.Diagramming.TableNode.AddRow Method

TableNode.AddRow Method
[image]

Adds new empty row at the bottom of the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int AddRow ()

Visual Basic [image] Copy Code

Public Function AddRow () As Integer

Return Value

Returns the index of the newly added row within the Rows collection.

Remarks

Call the method to add new rows at the end of the table. The size of the table is automatically updated and the rows are added to the row collection.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
InsertRow Method
DeleteRow Method
RedimTable Method
Rows Property


MindFusion.Diagramming.TableNode.BreakRelation Method

TableNode.BreakRelation Method
[image]

Breaks the relation with the specified table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void BreakRelation (
int row,
Relationship rel,
TableNode tableNode
)

Visual Basic [image] Copy Code

Public Sub BreakRelation ( _
row As Integer, _
rel As Relationship, _
tableNode As TableNode _
)

Parameters

row
Zero-based index of a row in this table that is related to a row in another.
rel
The type of the relation (and the direction of the link).
tableNode
The other table in the relation.

Remarks

Call this method to break the link between two tables.

See Also

TableNode Members
TableNode Class
AddRelation Method


MindFusion.Diagramming.TableNode.CellFromPoint Method

TableNode.CellFromPoint Method
[image]

Returns the row and column indices of the cell located at the specified point, taking into consideration the cells span.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool CellFromPoint (
PointF point,
ref int row,
ref int col
)

Visual Basic [image] Copy Code

Public Function CellFromPoint( _
point As PointF, _
ByRef row As Integer, _
ByRef col As Integer _
) As Boolean

Parameters

point

The point to check.

row

Receives the row index if a cell is found at the specified position.

col

Receives the column index if a cell is found at the specified position.

Return Value

true if a cell of this table contains the specified point; otherwise, false.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.CreateConnectionPoint Method

TableNode.CreateConnectionPoint Method
[image]

DiagramNode.CreateConnectionPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual ConnectionPoint CreateConnectionPoint (
DiagramLink link,
PointF pt,
bool incoming
)

Visual Basic [image] Copy Code

Protected Overridable Function CreateConnectionPoint ( _
link As DiagramLink, _
pt As PointF, _
incoming As Boolean _
) As ConnectionPoint

Parameters

link
A DiagramLink that should be connected to this node.
pt
The point at which the link should be connected.
incoming
true if link is an incoming link; otherwise, false.

Return Value

A ConnectionPoint instance representing the connection.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.CreateProperties Method

TableNode.CreateProperties Method
[image]

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramItemProperties CreateProperties ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateProperties () As DiagramItemProperties

Return Value

A DiagramItemProperties -derived object containing a snapshot of the item's properties.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.DeleteColumn Method

TableNode.DeleteColumn Method
[image]

Deletes the column with the specified index within the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void DeleteColumn (
int col
)

Visual Basic [image] Copy Code

Public Sub DeleteColumn( _
col As Integer _
)

Parameters

col
The zero-based index of the column to be deleted.

Remarks

Call the method to delete a column from the table. The size of the table is automatically updated and the columns are removed from the column collection.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
DeleteRow Method
AddColumn Method
InsertColumn Method
RedimTable Method


MindFusion.Diagramming.TableNode.DeleteRow Method

TableNode.DeleteRow Method
[image]

Deletes the row at the specified position within the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void DeleteRow (
int row
)

Visual Basic [image] Copy Code

Public Sub DeleteRow( _
row As Integer _
)

Parameters

row
The zero-based index of the row to be deleted.

Remarks

Call the method to delete a row from the table. The size of the table is automatically updated and the rows are removed from the row collection.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
DeleteColumn Method
AddRow Method
InsertRow Method
RedimTable Method


MindFusion.Diagramming.TableNode.Dispose Method

TableNode.Dispose Method
[image]

Disposes any disposable resources managed by this table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Dispose (
bool disposing
)

Visual Basic [image] Copy Code

Protected Overrides Sub Dispose( _
disposing As Boolean _
)

Parameters

disposing

Specifies whether the method is called explicitly or from the garbage collector.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.DrawAnchors Method

TableNode.DrawAnchors Method
[image]

DiagramNode.DrawAnchors override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawAnchors (
IGraphics graphics
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawAnchors ( _
graphics As IGraphics _
)

Parameters

graphics
The IGraphics surface to draw the anchor points on.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.DrawLocal Method

TableNode.DrawLocal Method
[image]

Draws the node on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawLocal (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawLocal( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

An IGraphics object where the node should be rendered.

options

Provides options for the drawing operation.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.DrawShadowLocal Method

TableNode.DrawShadowLocal Method
[image]

Draws the shadow of this node on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawShadowLocal (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawShadowLocal( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

An IGraphics object where the shadow should be rendered.

options

Provides options for the drawing operation.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.GetAllIncomingLinks Method

TableNode.GetAllIncomingLinks Method
[image]

Node.GetAllIncomingLinks override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void GetAllIncomingLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Protected Overrides Sub GetAllIncomingLinks( _
links As DiagramLinkCollection _
)

Parameters

links

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.GetAllOutgoingLinks Method

TableNode.GetAllOutgoingLinks Method
[image]

Node.GetAllOutgoingLinks override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void GetAllOutgoingLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Protected Overrides Sub GetAllOutgoingLinks( _
links As DiagramLinkCollection _
)

Parameters

links

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.GetEffectiveCaptionBackBrush Method

TableNode.GetEffectiveCaptionBackBrush Method
[image]

Creates a System.Drawing.Brush object representing the currently effective caption back brush of the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush GetEffectiveCaptionBackBrush (
RectangleF bounds,
float dx,
float dy
)

Visual Basic [image] Copy Code

Public Function GetEffectiveCaptionBackBrush( _
bounds As RectangleF, _
dx As Single, _
dy As Single _
) As Brush

Parameters

bounds

The bounds of the new brush.

dx

The horizontal translation of the new brush.

dy

The vertical translation of the new brush.

Return Value

A .NET Brush object.

Remarks

This method returns a system brush corresponding to the table's CaptionBackBrush if the table's CaptionBackBrush is not null, or a system brush corresponding to the CaptionBackBrush property of the table's style. This method can return null. The returned object (if any) must be disposed by the caller.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.GetEffectiveCaptionBrush Method

TableNode.GetEffectiveCaptionBrush Method
[image]

Creates a System.Drawing.Brush object representing the currently effective caption brush of the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush GetEffectiveCaptionBrush ()

Visual Basic [image] Copy Code

Public Function GetEffectiveCaptionBrush () As Brush

Return Value

A .NET Brush object.

Remarks

This method returns a system brush corresponding to the table's CaptionBrush if the table's CaptionBrush is not null, or a system brush corresponding to the TextBrush property of the table's style. The returned object must be disposed by the caller.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.GetEffectiveCellTextBrush Method

TableNode.GetEffectiveCellTextBrush Method
[image]

Creates a System.Drawing.Brush object representing the currently effective text brush of the table cells.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush GetEffectiveCellTextBrush ()

Visual Basic [image] Copy Code

Public Function GetEffectiveCellTextBrush () As Brush

Return Value

A .NET Brush object.

Remarks

This method returns a system brush corresponding to the table's CellTextBrush if the table's CellTextBrush is not null, or a system brush corresponding to the CellTextBrush property of the table's style. The returned object must be disposed by the caller.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.GetIntersection Method

TableNode.GetIntersection Method
[image]

DiagramNode.GetIntersection override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override PointF GetIntersection (
PointF segmentStart,
PointF segmentEnd
)

Visual Basic [image] Copy Code

Public Overrides Function GetIntersection( _
segmentStart As PointF, _
segmentEnd As PointF _
) As PointF

Parameters

segmentStart
The first point of the segment.
segmentEnd
The second point of the segment.

Return Value

A PointF object representing the intersection point.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.GetSpannedCellRect Method

TableNode.GetSpannedCellRect Method
[image]

Calculates the bounding rectangle of the specified cell, taking in consideration the cell's row and column spans.

Overload List

Name | Description
TableNode.GetSpannedCellRect (Int32, Int32) | Calculates the bounding rectangle of the cell in the specified row and column also taking in consideration the cell row and column spanning.
TableNode.GetSpannedCellRect (TableNode.Cell) | Calculates the bounding rectangle of the specified cell also taking in consideration the cell row and column spanning.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.GetSpannedCellRect Method (Int32, Int32)

TableNode.GetSpannedCellRect Method (Int32, Int32)
See Also
[image]

Calculates the bounding rectangle of the cell in the specified row and column also taking in consideration the cell row and column spanning.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF GetSpannedCellRect (
int row,
int col
)

Visual Basic [image] Copy Code

Public Function GetSpannedCellRect( _
row As Integer, _
col As Integer _
) As RectangleF

Parameters

row

An integer value specifying the cell's row.

col

An integer value specifying the cell's column.

Return Value

A RectangleF instance representing the cell's bounding rectangle.

See Also

GetSpannedCellRect Method Overload List
TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.GetSpannedCellRect Method (TableNode.Cell)

TableNode.GetSpannedCellRect Method (TableNode.Cell)
See Also
[image]

Calculates the bounding rectangle of the specified cell also taking in consideration the cell row and column spanning.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF GetSpannedCellRect (
TableNode.Cell cell
)

Visual Basic [image] Copy Code

Public Function GetSpannedCellRect( _
cell As TableNode.Cell _
) As RectangleF

Parameters

cell

A Cell instance.

Return Value

A RectangleF instance representing the cell's bounding rectangle.

See Also

GetSpannedCellRect Method Overload List
TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.GetToolTip Method

TableNode.GetToolTip Method
[image]

DiagramNode.GetToolTip override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string GetToolTip (
PointF point
)

Visual Basic [image] Copy Code

Public Overrides Function GetToolTip( _
point As PointF _
) As String

Parameters

point
The mouse pointer position.

Return Value

A string specifying the tooltip text.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.HitTestManipulators Method

TableNode.HitTestManipulators Method
[image]

DiagramItem.HitTestManipulators override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Manipulator HitTestManipulators (
PointF pt
)

Visual Basic [image] Copy Code

Public Overrides Function HitTestManipulators( _
pt As PointF _
) As Manipulator

Parameters

pt

Return Value

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.InsertColumn Method

TableNode.InsertColumn Method
[image]

Inserts new empty column at the specified position within the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void InsertColumn (
int col
)

Visual Basic [image] Copy Code

Public Sub InsertColumn( _
col As Integer _
)

Parameters

col
The zero-based index of the column to be inserted.

Remarks

Call the method to add new column at a particular position in the table. The size of the table is automatically updated and the columns are added to the column collection.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
AddColumn Method
DeleteColumn Method
RedimTable Method


MindFusion.Diagramming.TableNode.InsertRow Method

TableNode.InsertRow Method
[image]

Inserts new empty row at the specified position within the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void InsertRow (
int row
)

Visual Basic [image] Copy Code

Public Sub InsertRow( _
row As Integer _
)

Parameters

row
The zero-based index of the row to be inserted.

Remarks

Call the method to add new row at a particular position in the table. The size of the table is automatically updated and the rows are added to the row collection.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
AddRow Method
DeleteRow Method
RedimTable Method


MindFusion.Diagramming.TableNode.LoadFrom Method

TableNode.LoadFrom Method
[image]

Deserializes the object from the specified reader.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFrom (
BinaryReader reader,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFrom ( _
reader As BinaryReader, _
context As PersistContext _
)

Parameters

reader
A BinaryReader object from which to read the item's data.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.LoadFromXml Method

TableNode.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFromXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement containing the item's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.OnLoad Method

TableNode.OnLoad Method
[image]

DiagramItem.OnLoad override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void OnLoad ()

Visual Basic [image] Copy Code

Public Overrides Sub OnLoad ()

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.OnMeasureUnitChanged Method

TableNode.OnMeasureUnitChanged Method
[image]

Called when the Diagram's MeasureUnit changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnMeasureUnitChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnMeasureUnitChanged ()

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.OnStyleChanged Method

TableNode.OnStyleChanged Method
[image]

DiagramItem.OnStyleChanged override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnStyleChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnStyleChanged ()

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.OnUpdateBounds Method

TableNode.OnUpdateBounds Method
[image]

DiagramNode.OnUpdateBounds override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnUpdateBounds (
bool sizeChanged
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnUpdateBounds( _
sizeChanged As Boolean _
)

Parameters

sizeChanged

true if the size has changed; false if only the position has changed.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.OnZoomChanged Method

TableNode.OnZoomChanged Method
[image]

Called when the DiagramView.ZoomFactor changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnZoomChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnZoomChanged ()

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.RedimTable Method

TableNode.RedimTable Method
[image]

Sets new number of rows and columns for this table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RedimTable (
int cols,
int rows
)

Visual Basic [image] Copy Code

Public Sub RedimTable( _
cols As Integer, _
rows As Integer _
)

Parameters

cols
The new number of columns.
rows
The new number of rows.

Remarks

This method does not preserve the old contents of table cells. After its invocation all cells are empty and columns and rows are with default sizes.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
AddColumn Method
AddRow Method
DeleteColumn Method
DeleteRow Method


MindFusion.Diagramming.TableNode.ResizeToFitImage Method

TableNode.ResizeToFitImage Method
[image]

Makes a table as big as the image it displays.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ResizeToFitImage ()

Visual Basic [image] Copy Code

Public Sub ResizeToFitImage ()

Remarks

Call this method to make a table exactly the same size as the image it contains. The dots-per-inch resolution of the image is considered too when calculating the new table size. You can use ImageAlign to specify position of the picture and Image to set the picture itself.

See Also

TableNode Members
TableNode Class
Image Property


MindFusion.Diagramming.TableNode.ResizeToFitText Method

TableNode.ResizeToFitText Method
[image]

Overload List

Name | Description
TableNode.ResizeToFitText (Boolean) | Resizes the columns and rows so that the cells are large enough to fit their text.
TableNode.ResizeToFitText (Boolean, Boolean) | Resizes the columns and rows so that the cells are large enough to fit their text.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.ResizeToFitText Method (Boolean)

TableNode.ResizeToFitText Method (Boolean)
See Also
[image]

Resizes the columns and rows so that the cells are large enough to fit their text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ResizeToFitText (
bool ignoreCaption
)

Visual Basic [image] Copy Code

Public Sub ResizeToFitText( _
ignoreCaption As Boolean _
)

Parameters

ignoreCaption

false if the caption bar too should be resized to fit the caption text; otherwise, true.

Remarks

This method resizes the cells so they fit their Text on a single line, as long as the text does not contain new-line characters. The Width of each column is set to the width of its widest cell, and the Height of each row is set to the height of its highest cell. In the end, the table size is set to the sum of the extents of all rows and columns.

If ignoreCaption is false, the caption bar too will be resized, by setting CaptionHeight and the table width, so that it fits the Caption text.

See Also

TableNode Members
TableNode Class
ResizeToFitImage Method


MindFusion.Diagramming.TableNode.ResizeToFitText Method (Boolean, Boolean)

TableNode.ResizeToFitText Method (Boolean, Boolean)
See Also
[image]

Resizes the columns and rows so that the cells are large enough to fit their text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ResizeToFitText (
bool ignoreCaption,
bool keepCellWidth
)

Visual Basic [image] Copy Code

Public Sub ResizeToFitText( _
ignoreCaption As Boolean, _
keepCellWidth As Boolean _
)

Parameters

ignoreCaption
false if the caption bar too should be resized to fit the caption text; otherwise, true.
keepCellWidth
true if column widths should stay unchanged; otherwise, false.

Remarks

This method resizes the cells so they fit their Text on a single line, as long as the text does not contain new-line characters. The Width of each column is set to the width of its widest cell, and the Height of each row is set to the height of its highest cell. In the end, the table size is set to the sum of the extents of all rows and columns.

If ignoreCaption is false, the caption bar too will be resized, by setting CaptionHeight and the table width, so that it fits the Caption text.

If keepCellWidth is true, the cell width is preserved unchanged.

See Also

ResizeToFitText Method Overload List
TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.RestoreProperties Method

TableNode.RestoreProperties Method
[image]

DiagramNode.RestoreProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overridable Sub RestoreProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties -derived object containing a snapshot of the item's properties.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.SaveProperties Method

TableNode.SaveProperties Method
[image]

DiagramNode.SaveProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties -derived object where the item's properties should be saved.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.SaveTo Method

TableNode.SaveTo Method
[image]

Serializes the object to the specified writer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveTo (
BinaryWriter writer,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveTo ( _
writer As BinaryWriter, _
context As PersistContext _
)

Parameters

writer
A BinaryWriter object the item's data should be written to.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.SaveToXml Method

TableNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveToXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement the item's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.ScaleElements Method

TableNode.ScaleElements Method
[image]

DiagramNode.ScaleElements override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void ScaleElements (
float scale
)

Visual Basic [image] Copy Code

Protected Overrides Sub ScaleElements( _
scale As Single _
)

Parameters

scale

The value by which to multiply node elements' sizes.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.ScrollDown Method

TableNode.ScrollDown Method
[image]

Scrolls the table rows downwards.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ScrollDown ()

Visual Basic [image] Copy Code

Public Sub ScrollDown ()

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.ScrollUp Method

TableNode.ScrollUp Method
[image]

Scrolls the table rows upwards.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ScrollUp ()

Visual Basic [image] Copy Code

Public Sub ScrollUp ()

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.SetReference Method

TableNode.SetReference Method
[image]

Updates the reference to the specified object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SetReference (
int refId,
Object obj,
PersistContext ctx
)

Visual Basic [image] Copy Code

Protected Overridable Sub SetReference ( _
refId As Integer, _
obj As Object, _
ctx As PersistContext _
)

Parameters

refId
Reference identifier.
obj
The newly loaded object.
context

A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

This method is called for references that had been saved using the SaveReference method.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.SetReflexive Method

TableNode.SetReflexive Method
[image]

Invoked to let a node set the shape of a reflexive link connected to it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SetReflexive (
DiagramLink link
)

Visual Basic [image] Copy Code

Protected Overrides Sub SetReflexive( _
link As DiagramLink _
)

Parameters

link

Reference to the link.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode Properties

TableNode Properties
[image]

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AllowResizeColumns | Gets or sets a value indicating whether users are allowed to resize table columns.
AllowResizeRows | Gets or sets a value indicating whether users are allowed to resize table rows.
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Caption | Gets or sets the text displayed as caption of the table.
CaptionBackBrush | Gets or sets the brush used to paint the caption area of this table.
CaptionBrush | Gets or sets the brush used to paint the table caption.
CaptionFormat | Gets or sets the alignment and line position of the text used as table caption.
CaptionHeight | Gets or sets the height of the table's caption area.
CaptionPlainText | Gets the plain text of the table's caption.
CellCustomDraw | Gets or sets the type of custom drawing performed on the table cells.
CellFrameStyle | Gets or sets the style of the table cells.
CellTextBrush | Gets or sets the brush used to paint texts inside table cells.
ColumnCount | Gets or sets the number of columns in the table.
Columns | Gets a list of all columns in the table.
ColumnWidth | Gets or sets the default width of the table columns.
ConnectionStyle | Gets or sets a value indicating whether drawing a link from/to this table, should connect a row of the table, or the whole table as single entity.
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
CurrentScrollRow | Gets or sets the index of the first visible row in the table.
CustomDraw | Gets or sets the type of custom drawing performed on this table.
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveCaptionBackBrush | Gets the effective caption back brush of the table.
EffectiveCaptionBrush | Gets the effective caption brush of the table.
EffectiveCellTextBrush | Gets the effective text brush of the table cells.
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
EnableStyledText | Gets or sets a value indicating whether styled text rendering is enabled.
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Font | Gets or sets the font used when rendering the table's texts.
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HighlightedRow | Gets or sets the highlighted row.
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
Image | Gets or sets the image that is displayed in this table.
ImageAlign | Gets or sets the alignment of the image displayed in this table.
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
Item | Gets the Cell instance at the specified position.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OffsetHeaderRows | Gets or sets a value indicating whether the table cells are offset to the right to accommodate for the expand buttons of Header rows.
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RowAnchorPattern | Gets or sets a default anchor pattern for the rows of this table.
RowCount | Gets or sets the number of rows in the table.
RowHeight | Gets or sets the default height of table rows.
Rows | Gets a list of all rows in the table.
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Scrollable | Gets or sets a value indicating whether users are allowed to scroll table rows.
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Shape | Gets or sets the shape of the table's outline.
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text.
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | DiagramNode.HasItems override.
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

See Also

TableNode Class


MindFusion.Diagramming.TableNode.AllowResizeColumns Property

TableNode.AllowResizeColumns Property
[image]

Gets or sets a value indicating whether users are allowed to resize table columns.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowResizeColumns { get; set; }

Visual Basic [image] Copy Code

Public Property AllowResizeColumns As Boolean

Property Value

true to let users resize columns, or false otherwise. The default value is false.

Remarks

A column can be resized by dragging its right border. If the ColumnStyle property of a column is set to AutoWidth, it is automatically reset to FixedWidth when the column is resized. Rightmost columns always fill all remaining space in their tables and cannot be resized.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.AllowResizeRows Property

TableNode.AllowResizeRows Property
[image]

Gets or sets a value indicating whether users are allowed to resize table rows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowResizeRows { get; set; }

Visual Basic [image] Copy Code

Public Property AllowResizeRows As Boolean

Property Value

true to let users resize rows, or false otherwise. The default value is false.

Remarks

A row can be resized by dragging its bottom border.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.Caption Property

TableNode.Caption Property
[image]

Gets or sets the text displayed as caption of the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Caption { get; set; }

Visual Basic [image] Copy Code

Public Property Caption As String

Property Value

A string containing the text of the caption. Initialized with the value of TableCaption.

Remarks

Text color and alignment can be customized by using the CaptionBrush and CaptionFormat properties.

Styled text allows applying various attributes to the text characters. Attributes are specified by embedding HTML-like formatting tags within the raw text. Styled text is enabled by setting EnableStyledText to true.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
CaptionHeight Property
CaptionBackBrush Property
Diagram.TableCaption Property


MindFusion.Diagramming.TableNode.CaptionBackBrush Property

TableNode.CaptionBackBrush Property
[image]

Gets or sets the brush used to paint the caption area of this table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush CaptionBackBrush { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionBackBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class. The default is null (Nothing in Visual Basic).

Remarks

This property refers to a brush object used to paint the interior of the caption area. An instance of one of the following classes can be assigned to it: HatchBrush, LinearGradientBrush, PathGradientBrush, SolidBrush or TextureBrush, all located in the MindFusion.Drawing namespace. If there is no brush assigned to this property, the caption area is painted using the Brush property of the TableNode class.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
CaptionHeight Property
Caption Property


MindFusion.Diagramming.TableNode.CaptionBrush Property

TableNode.CaptionBrush Property
[image]

Gets or sets the brush used to paint the table caption.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush CaptionBrush { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
CaptionHeight Property
CaptionFormat Property
Caption Property


MindFusion.Diagramming.TableNode.CaptionFormat Property

TableNode.CaptionFormat Property
[image]

Gets or sets the alignment and line position of the text used as table caption.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringFormat CaptionFormat { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionFormat As StringFormat

Property Value

An instance of the .NET StringFormat class.

Remarks

Use this property to change the alignment of text or its position inside the caption area.

If there isn't enough space available to fit a whole line of text, MvcDiagram wraps the text to a new line when it reaches the edge of the table. You can specify that the text should be wrapped only at word boundaries by setting the Trimming member of CaptionFormat to StringTrimming.Word. The default is to split words into multiple parts if there is not enough space to fit a whole word.

If you prefer to use your own line-breaks, you can disable the automatic text wrapping by enabling the NoWrap flag in the FormatFlags member of CaptionFormat. If automatic wrapping is disabled and there isn't enough space to fit the whole line, the text is clipped at the table boundaries.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
CaptionHeight Property
CaptionBrush Property
Caption Property


MindFusion.Diagramming.TableNode.CaptionHeight Property

TableNode.CaptionHeight Property
[image]

Gets or sets the height of the table's caption area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float CaptionHeight { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionHeight As Single

Property Value

A float value specifying the height of the table caption. Initialized with the value of TableCaptionHeight.

Remarks

Keep in mind that tables are moved by clicking their captions and dragging. Don't make captions too narrow or they would become harder to move.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
CaptionFormat Property
CaptionBrush Property
Caption Property
Diagram.TableCaptionHeight Property


MindFusion.Diagramming.TableNode.CaptionPlainText Property

TableNode.CaptionPlainText Property
[image]

Gets the plain text of the table's caption.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string CaptionPlainText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CaptionPlainText As String

Property Value

A string containing the plain text of the caption.

Remarks

This property removes any formatting tags from Caption and returns the plain human-readable text. That is useful when styled text is enabled and you need to display caption's content outside of MvcDiagram, that is, in a message box or a dialog box.

Example

The following sample code demonstrates how CaptionPlainText can be used.

C# [image] Copy Code

t.EnableStyledText = true;
t.Caption = "<b>interface</b> <i><u>IMouseListener</u></i>";
MessageBox.Show(t.CaptionPlainText);

Visual Basic [image] Copy Code

t.EnableStyledText = True
t.Caption = "<b>interface</b> <i><u>IMouseListener</u></i>"
MessageBox.Show(t.CaptionPlainText)

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
CaptionFormat Property
EnableStyledText Property


MindFusion.Diagramming.TableNode.CellCustomDraw Property

TableNode.CellCustomDraw Property
[image]

Gets or sets the type of custom drawing performed on the table cells.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CustomDraw CellCustomDraw { get; set; }

Visual Basic [image] Copy Code

Public Property CellCustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. Initialized with the value of CellCustomDraw.

Remarks

This property allows invoking custom painting code for the cells of a table. That code must execute in response to the DrawCell event. There are several modes of custom painting, allowing the custom code to paint the cell entirely, or do that in addition to what MvcDiagram paints by default. The following CustomDraw members can be assigned to this property to specify the custom painting mode:

Member Name | Description
None | Do not perform custom drawing, let all painting be done by MvcDiagram.
Additional | The custom painting code executes after the cell interior is painted by MvcDiagram, but before the cell's text is rendered.
Full | The component does not do any standard drawing of the cell, the entire painting is left for the application.
Additional2 | The custom painting code executes after all parts of the cell, including its text, are painted by MvcDiagram.

See Also

TableNode Members
TableNode Class
TableNode.CustomDraw Property


MindFusion.Diagramming.TableNode.CellFrameStyle Property

TableNode.CellFrameStyle Property
[image]

Gets or sets the style of the table cells.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CellFrameStyle CellFrameStyle { get; set; }

Visual Basic [image] Copy Code

Public Property CellFrameStyle As CellFrameStyle

Property Value

A member of the CellFrameStyle enumeration. Initialized with the value of CellFrameStyle.

Remarks

This property specifies whether there are borders drawn around table cells, and if yes, their appearance.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
CellFrameStyle Enumeration
Diagram.CellFrameStyle Property


MindFusion.Diagramming.TableNode.CellTextBrush Property

TableNode.CellTextBrush Property
[image]

Gets or sets the brush used to paint texts inside table cells.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush CellTextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property CellTextBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.ColumnCount Property

TableNode.ColumnCount Property
[image]

Gets or sets the number of columns in the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ColumnCount { get; set; }

Visual Basic [image] Copy Code

Public Property ColumnCount As Integer

Property Value

An integer value indicating the number of columns in the table.

Remarks

If you increase the number of columns the contents of the old columns will remain intact. If you decrease the number, the last columns are removed and the other remain unchanged.

See Also

TableNode Members
TableNode Class
Columns Property


MindFusion.Diagramming.TableNode.Columns Property

TableNode.Columns Property
[image]

Gets a list of all columns in the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.ColumnCollection Columns { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Columns As TableNode.ColumnCollection

Property Value

An instance of the ColumnCollection class.

See Also

TableNode Members
TableNode Class
Rows Property


MindFusion.Diagramming.TableNode.ColumnWidth Property

TableNode.ColumnWidth Property
[image]

Gets or sets the default width of the table columns.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float ColumnWidth { get; set; }

Visual Basic [image] Copy Code

Public Property ColumnWidth As Single

Property Value

A float value specifying the width of the table columns. Initialized with the value of TableColumnWidth.

Remarks

The value of this property is used to initialize the width of new columns when they are created.

See Also

TableNode Members
TableNode Class
RowHeight Property


MindFusion.Diagramming.TableNode.ConnectionStyle Property

TableNode.ConnectionStyle Property
[image]

Gets or sets a value indicating whether drawing a link from/to this table, should connect a row of the table, or the whole table as single entity.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableConnectionStyle ConnectionStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ConnectionStyle As TableConnectionStyle

Property Value

A member of the TableConnectionStyle enumeration. Initialized with the value of TableConnectionStyle.

Remarks

There are three possible ways to relate tables to other nodes. This property specifies how users are allowed to create such relations:

  • Rows - relation ends are the rows of a table. A link connected to the table is connected to a particular row. This mode is convenient for database diagrams.
  • Table - relations target the table as a whole entity, and not any particular row. This mode is convenient for class diagrams.
  • Both - a mixed mode where links can target either a row of the table or the table itself.
Programmatically, links can be connected to a table in any way, regardless of the ConnectionStyle. ConnectionStyle value is considered only when end-users draw links to or from a table. To link to a table as an entity and not to a specific row, pass -1 as row argument of the CreateDiagramLink method.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.CurrentScrollRow Property

TableNode.CurrentScrollRow Property
[image]

Gets or sets the index of the first visible row in the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int CurrentScrollRow { get; set; }

Visual Basic [image] Copy Code

Public Property CurrentScrollRow As Integer

Property Value

An integer value indicating the index of the first visible row.

Remarks

To allow users to scroll the table interactively, enable the Scrollable property.

See Also

TableNode Members
TableNode Class
Rows Property


MindFusion.Diagramming.TableNode.CustomDraw Property

TableNode.CustomDraw Property
[image]

Gets or sets the type of custom drawing performed on this table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CustomDraw CustomDraw { get; set; }

Visual Basic [image] Copy Code

Public Property CustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. Initialized with the value of TableCustomDraw.

Remarks

This property allows invoking custom painting code for a table. That code must execute in response to the DrawNode event. There are several modes of custom painting, allowing the custom code to paint the table entirely, or do that in addition to what MvcDiagram paints by default. The following CustomDraw members can be assigned to this property to specify the custom painting mode:

Member Name | Description
None | Do not perform custom drawing, let all painting be done by MvcDiagram.
Additional | The custom painting code executes after the table interior and frame are painted by MvcDiagram, but before cells are rendered.
Full | The component does not do any standard drawing of the table frame, whose painting is left for the application. Cells are painted independently, as set in CellCustomDraw.
ShadowOnly | Only the shadow of the table is painted by custom code, the table itself is drawn by the component.
Additional2 | The custom painting code executes after all parts of the table, including its cells, are painted by MvcDiagram.

This property doesn't affect the painting of table cells. Table cells can be custom painted in the DrawCell event as set in CellCustomDraw.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.EffectiveCaptionBackBrush Property

TableNode.EffectiveCaptionBackBrush Property
[image]

Gets the effective caption back brush of the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush EffectiveCaptionBackBrush { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EffectiveCaptionBackBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.EffectiveCaptionBrush Property

TableNode.EffectiveCaptionBrush Property
[image]

Gets the effective caption brush of the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush EffectiveCaptionBrush { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EffectiveCaptionBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.EffectiveCellTextBrush Property

TableNode.EffectiveCellTextBrush Property
[image]

Gets the effective text brush of the table cells.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush EffectiveCellTextBrush { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EffectiveCellTextBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.EnableStyledText Property

TableNode.EnableStyledText Property
[image]

Gets or sets a value indicating whether styled text rendering is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableStyledText { get; set; }

Visual Basic [image] Copy Code

Public Property EnableStyledText As Boolean

Property Value

true to parse the text of table's caption and cells in order to find formatting tags; otherwise false. Initialized with the value of EnableStyledText.

Remarks

Styled text allows applying various attributes to the characters it contains. Attributes are specified using HTML-like formatting tags embedded in the raw text. Formatting tags are listed and described in the Text Attributes and Formatting section of this help file.

If EnableStyledText is set to true, table's Caption and cells' Text are parsed and analyzed each time they change. Parsing determines what formatting tags are used and adds the corresponding attribute records to MvcDiagram's internal representation of styled text. If the property value is false, the text is not processed in any way and is displayed without formatting.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
ResizeToFitText Method
CaptionPlainText Property


MindFusion.Diagramming.TableNode.Font Property

TableNode.Font Property
[image]

Gets or sets the font used when rendering the table's texts.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Font Font { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Font As Font

Property Value

A .NET Font instance specifying the font attributes.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.HasItems Property

TableNode.HasItems Property
[image]

DiagramNode.HasItems override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override bool HasItems { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property HasItems As Boolean

Property Value

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.HighlightedRow Property

TableNode.HighlightedRow Property
[image]

Gets or sets the highlighted row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int HighlightedRow { get; set; }

Visual Basic [image] Copy Code

Public Property HighlightedRow As Integer

Property Value

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.Image Property

TableNode.Image Property
[image]

Gets or sets the image that is displayed in this table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Image Image { get; set; }

Visual Basic [image] Copy Code

Public Property Image As Image

Property Value

An instance of the .NET Image class.

Remarks

Use the property to customize your table's background. Further customization can be done with the ImageAlign property.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
ImageAlign Property
ResizeToFitImage Method
Cell.Image Property


MindFusion.Diagramming.TableNode.ImageAlign Property

TableNode.ImageAlign Property
[image]

Gets or sets the alignment of the image displayed in this table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ImageAlign ImageAlign { get; set; }

Visual Basic [image] Copy Code

Public Property ImageAlign As ImageAlign

Property Value

A member of the ImageAlign enumeration. The default value is Fit.

Remarks

This property specifies how images are positioned inside tables.

See Also

TableNode Members
TableNode Class
Image Property


MindFusion.Diagramming.TableNode.Item Property

TableNode.Item Property
[image]

Gets the Cell instance at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.Cell Item [
int col,
int row
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item ( _
col As Integer, _
row As Integer _
) As TableNode.Cell

Parameters

col
The zero-based index of the cell's column.
row
The zero-based index of the cell's row.

Property Value

An instance of the Cell class that represents the cell of the table at the specified position.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
ColumnCount Property
RowCount Property
RedimTable Method


MindFusion.Diagramming.TableNode.OffsetHeaderRows Property

TableNode.OffsetHeaderRows Property
[image]

Gets or sets a value indicating whether the table cells are offset to the right to accommodate for the expand buttons of Header rows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool OffsetHeaderRows { get; set; }

Visual Basic [image] Copy Code

Public Property OffsetHeaderRows As Boolean

Property Value

true to offset table cells when there are header rows defined; otherwise, false. The default is false.

Remarks

If this property is set to false, the [±] buttons used to expand or collapse table sections are drawn inside the first cell of each header row. Otherwise, the buttons are drawn in their own column in front of the table's first column of cells.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.RowAnchorPattern Property

TableNode.RowAnchorPattern Property
[image]

Gets or sets a default anchor pattern for the rows of this table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern RowAnchorPattern { get; set; }

Visual Basic [image] Copy Code

Public Property RowAnchorPattern As AnchorPattern

Property Value

An instance of the AnchorPattern class. The default is null (Nothing in Visual Basic).

Remarks

Defines a default value for the AnchorPattern property of the rows of a table.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
AnchorPoint.Column Property
Row.AnchorPattern Property


MindFusion.Diagramming.TableNode.RowCount Property

TableNode.RowCount Property
[image]

Gets or sets the number of rows in the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int RowCount { get; set; }

Visual Basic [image] Copy Code

Public Property RowCount As Integer

Property Value

An integer value specifying the number of rows in the table.

Remarks

If you increase the number of rows the content of the initial rows will remain intact. If you decrease the number, the last rows are removed and the other remain unchanged.

See Also

TableNode Members
TableNode Class
Rows Property


MindFusion.Diagramming.TableNode.RowHeight Property

TableNode.RowHeight Property
[image]

Gets or sets the default height of table rows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float RowHeight { get; set; }

Visual Basic [image] Copy Code

Public Property RowHeight As Single

Property Value

A float value specifying the height of the table rows. Initialized with the value of TableRowHeight.

Remarks

The value of this property is used to initialize the height of new rows when they are created.

See Also

TableNode Members
TableNode Class
ColumnWidth Property


MindFusion.Diagramming.TableNode.Rows Property

TableNode.Rows Property
[image]

Gets a list of all rows in the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.RowCollection Rows { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Rows As TableNode.RowCollection

Property Value

An instance of the RowCollection class.

Remarks

The property refers to the collection of all rows that compose the table. Do not add or remove rows through this collection, but use the table's AddRow, InsertRow or DeleteRow methods.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
Columns Property
CurrentScrollRow Property
Row.Table Property


MindFusion.Diagramming.TableNode.Scrollable Property

TableNode.Scrollable Property
[image]

Gets or sets a value indicating whether users are allowed to scroll table rows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Scrollable { get; set; }

Visual Basic [image] Copy Code

Public Property Scrollable As Boolean

Property Value

true to allow scrolling the table up or down; otherwise, false. Initialized with the value of TablesScrollable.

Remarks

A button containing up and down arrows appears in the caption area of a table for which scrolling is enabled. If a user clicks these arrows, table rows scroll up or down. The table can always be scrolled programmatically using the CurrentScrollRow property.

See Also

TableNode Members
TableNode Class
Rows Property


MindFusion.Diagramming.TableNode.Shape Property

TableNode.Shape Property
[image]

Gets or sets the shape of the table's outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SimpleShape Shape { get; set; }

Visual Basic [image] Copy Code

Public Property Shape As SimpleShape

Property Value

A member of the SimpleShape enumeration. Initialized with the value of TableShape.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.TextPadding Property

TableNode.TextPadding Property
[image]

Gets or sets the spacing between the item boundaries and its text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Thickness TextPadding { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property TextPadding As Thickness

Property Value

A Thickness instance specifying the size of the padding space left around the text.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.Cell Class

TableNode.Cell Class
Remarks See Also
[image]

Represents a cell in a TableNode instance.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TableNode.Cell : InplaceEditable, IPersists

Visual Basic [image] Copy Code

Public Class TableNode.Cell
Implements InplaceEditable, IPersists

Remarks

Cells are the building blocks of tables. They get their height and width indirectly, from the width of table columns and the height of table rows as set by the ColumnWidth and RowHeight properties. Cells can be made to span several rows and columns by setting their RowSpan and ColumnSpan properties to values larger than 1.

Cells can hold text, which is set by their Text property. The text can be aligned and this is set by the TextFormat property. Color of the text in the cells is set with the TextBrush property.

Appearance of a cell can be customized further by the Brush and Image properties.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.TableNode.Cell

See Also

TableNode.Cell Members


MindFusion.Diagramming.TableNode.Cell Members

TableNode.Cell Members
Constructors Properties Methods
[image]

Represents a cell in a TableNode instance.

The following tables list the members exposed by the TableNode.Cell type.

Public Constructors

Name | Description
TableNode.Cell | Initializes a new instance of the TableNode.Cell class.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill this cell.
ColumnSpan | Gets or sets how many columns the cell should span.
Font | Gets or sets the font used to draw text inside this cell.
HyperLink | Gets or sets the hyperlink associated with the cell.
Image | Gets or sets the image that is displayed in this cell.
ImageAlign | Gets or sets the alignment of the image displayed in this cell.
ImageUrl | Gets or sets a URL used to load an image into this cell.
PlainText | Gets the plain text of the cell.
RowSpan | Gets or sets how many rows the cell should span.
Table | Gets a reference to the TableNode containing this cell.
Tag | Gets or sets custom data associated with this cell.
Text | Gets or sets text displayed inside the cell.
TextBrush | Gets or sets the brush used to paint the text of the cell.
TextFormat | Gets or sets the alignment of the text that is displayed inside the cell.
ToolTip | Gets or sets the tooltip text associated with the cell.

Public Methods

Name | Description
Clone | Creates a copy of this cell.

Protected Methods

Name | Description
LoadFromXml | Loads the cell content from an XML element.
SaveToXml | Saves the cell content into an XML element.

See Also

TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell Constructor

TableNode.Cell Constructor
[image]

Initializes a new instance of the TableNode.Cell class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.Cell (
TableNode table
)

Visual Basic [image] Copy Code

Public Sub TableNode.Cell ( _
table As TableNode _
)

Parameters

table

The TableNode this cell belongs to.

See Also

TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell Methods

TableNode.Cell Methods
[image]

Public Methods

Name | Description
Clone | Creates a copy of this cell.

Protected Methods

Name | Description
LoadFromXml | Loads the cell content from an XML element.
SaveToXml | Saves the cell content into an XML element.

See Also

TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.Clone Method

TableNode.Cell.Clone Method
[image]

Creates a copy of this cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.Cell Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As TableNode.Cell

Return Value

An instance of the TableNode.Cell class.

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.LoadFromXml Method

TableNode.Cell.LoadFromXml Method
[image]

Loads the cell content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub LoadFromXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement containing the cell's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.SaveToXml Method

TableNode.Cell.SaveToXml Method
[image]

Saves the cell content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub SaveToXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement the cell's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell Properties

TableNode.Cell Properties
[image]

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill this cell.
ColumnSpan | Gets or sets how many columns the cell should span.
Font | Gets or sets the font used to draw text inside this cell.
HyperLink | Gets or sets the hyperlink associated with the cell.
Image | Gets or sets the image that is displayed in this cell.
ImageAlign | Gets or sets the alignment of the image displayed in this cell.
ImageUrl | Gets or sets a URL used to load an image into this cell.
PlainText | Gets the plain text of the cell.
RowSpan | Gets or sets how many rows the cell should span.
Table | Gets a reference to the TableNode containing this cell.
Tag | Gets or sets custom data associated with this cell.
Text | Gets or sets text displayed inside the cell.
TextBrush | Gets or sets the brush used to paint the text of the cell.
TextFormat | Gets or sets the alignment of the text that is displayed inside the cell.
ToolTip | Gets or sets the tooltip text associated with the cell.

See Also

TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.Brush Property

TableNode.Cell.Brush Property
[image]

Gets or sets the brush used to fill this cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class. The default is null (Nothing in Visual Basic).

Remarks

This property refers to a brush used to paint the cell's interior. You can assign to it an instance of one of the following classes: HatchBrush, LinearGradientBrush, PathGradientBrush, SolidBrush or TextureBrush, located in the MindFusion.Drawing namespace. If the default null value is used, the cell's interior is painted with the table's Brush instead of cell's one.

See Also

TableNode.Cell Members
TableNode.Cell Class
Image Property


MindFusion.Diagramming.TableNode.Cell.ColumnSpan Property

TableNode.Cell.ColumnSpan Property
[image]

Gets or sets how many columns the cell should span.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ColumnSpan { get; set; }

Visual Basic [image] Copy Code

Public Property ColumnSpan As Integer

Property Value

A positive integer value specifying how many columns the cell spans to the right. The default is 1.

Remarks

Use this property and RowSpan to define a cell that overlaps several columns and rows of the table's grid. The spanning cell covers any non-spanning cells to the right or below it, as far as the spanned columns and rows go. The Image and Text of spanning cells are aligned and laid out inside the enlarged bounding rectangles of the cells. That allows composing nodes with a very elaborate structure using spanning cells, as alternative to attaching ShapeNode objects to a container/master node.

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.Font Property

TableNode.Cell.Font Property
[image]

Gets or sets the font used to draw text inside this cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Font Font { get; set; }

Visual Basic [image] Copy Code

Public Property Font As Font

Property Value

A .NET Font used to render the cell's Text, or null (Nothing in Visual Basic) if the text should be rendered using the table's Font.

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.HyperLink Property

TableNode.Cell.HyperLink Property
[image]

Gets or sets the hyperlink associated with the cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string HyperLink { get; set; }

Visual Basic [image] Copy Code

Public Property HyperLink As String

Property Value

A string value containing the hyperlink URL.

Remarks

This property is used by the CreateImageMap method of the HtmlBuilder class. Its value is assigned to the HREF attribute of the <AREA> tag that corresponds to the cell. Map areas are defined for table cells only if the AreasForTableCells property is enabled.

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.Image Property

TableNode.Cell.Image Property
[image]

Gets or sets the image that is displayed in this cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Image Image { get; set; }

Visual Basic [image] Copy Code

Public Property Image As Image

Property Value

An instance of the .NET Image class. The default is null (Nothing in Visual Basic).

Remarks

Use this property to set an image to be displayed in the cell. Use the ImageAlign property to specify how the image is placed.

See Also

TableNode.Cell Members
TableNode.Cell Class
ImageAlign Property


MindFusion.Diagramming.TableNode.Cell.ImageAlign Property

TableNode.Cell.ImageAlign Property
[image]

Gets or sets the alignment of the image displayed in this cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ImageAlign ImageAlign { get; set; }

Visual Basic [image] Copy Code

Public Property ImageAlign As ImageAlign

Property Value

A member of the ImageAlign enumeration.

See Also

TableNode.Cell Members
TableNode.Cell Class
Image Property


MindFusion.Diagramming.TableNode.Cell.ImageUrl Property

TableNode.Cell.ImageUrl Property
[image]

Gets or sets a URL used to load an image into this cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ImageUrl { get; set; }

Visual Basic [image] Copy Code

Public Property ImageUrl As String

Property Value

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.PlainText Property

TableNode.Cell.PlainText Property
[image]

Gets the plain text of the cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string PlainText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PlainText As String

Property Value

A string containing the plain text of the cell.

Remarks

This property removes any formatting tags from cell's Text and returns the plain human-readable text. That is useful when styled text is enabled and you need to display cell's content outside of MvcDiagram, that is, in a message or a dialog box.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming Namespace
TextFormat Property
TableNode.EnableStyledText Property


MindFusion.Diagramming.TableNode.Cell.RowSpan Property

TableNode.Cell.RowSpan Property
[image]

Gets or sets how many rows the cell should span.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int RowSpan { get; set; }

Visual Basic [image] Copy Code

Public Property RowSpan As Integer

Property Value

A positive integer value specifying how many rows the cell spans downwards. The default is 1.

Remarks

Use this property and ColumnSpan to define a cell that overlaps several columns and rows of the table's grid. The spanning cell covers any non-spanning cells to the right or below it, as far as the spanned columns and rows go. The Image and Text displayed in spanning cells are aligned and laid out inside the enlarged bounding rectangles of the cells. That allows composing nodes with a very elaborate structure using spanning cells, as an alternative to attaching ShapeNode objects to a container/master node.

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.Table Property

TableNode.Cell.Table Property
[image]

Gets a reference to the TableNode containing this cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode Table { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Table As TableNode

Property Value

An instance of the TableNode class representing the table containing this cell.

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.Tag Property

TableNode.Cell.Tag Property
[image]

Gets or sets custom data associated with this cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An instance of any class derived from System.Object. The default value is null (Nothing in Visual Basic).

Remarks

This property holds data that you define and is not used by MvcDiagram in any way. The tag could be any value of a primitive data type or a complex object from the .NET class library or a class defined by you. If the tag is an instance of a value type, it will be serialized together with the cell containing it when saving/loading the diagram. Reference types are serialized if marked with the [Serializable] attribute or if they implement the ISerializable interface.

See Also

TableNode.Cell Members
TableNode.Cell Class
Diagram.SerializeTag Event


MindFusion.Diagramming.TableNode.Cell.Text Property

TableNode.Cell.Text Property
[image]

Gets or sets text displayed inside the cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Text { get; set; }

Visual Basic [image] Copy Code

Public Property Text As String

Property Value

A string value containing the text. The default is an empty string.

Remarks

The property specifies text that appears inside a cell. Text can be customized via the TextBrush and TextFormat properties.

Styled text allows applying various attributes to the text characters. Attributes are specified by embedding HTML-like formatting tags within the raw text. Styled text is enabled by setting EnableStyledText to true.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming Namespace
Image Property
TableNode.ResizeToFitText Method


MindFusion.Diagramming.TableNode.Cell.TextBrush Property

TableNode.Cell.TextBrush Property
[image]

Gets or sets the brush used to paint the text of the cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush TextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TextBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class. The default is null (Nothing in Visual Basic).

Remarks

The Text of the cell is painted with this brush. However, if the property is set to the default null value, the table's CellTextBrush property is used instead of the cell's one.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming Namespace
Font Property
TextFormat Property


MindFusion.Diagramming.TableNode.Cell.TextFormat Property

TableNode.Cell.TextFormat Property
[image]

Gets or sets the alignment of the text that is displayed inside the cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringFormat TextFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TextFormat As StringFormat

Property Value

An instance of the .NET StringFormat class. The default alignment is StringAlignment.Center for lines and StringAlignment.Near for the written text.

Remarks

Use this property to specify the alignment of the text that is contained in cells.

If there isn't enough space available to fit a whole line of text, MvcDiagram wraps the text to a new line when it reaches the edge of the cell. You can specify that the text should be wrapped only at word boundaries by setting the Trimming member of TextFormat to StringTrimming.Word. The default is to split words into multiple parts if there is not enough space to fit a whole word.

If you prefer to use your own line-breaks, disable the automatic text wrapping by enabling the NoWrap flag in the FormatFlags member of TextFormat. If automatic wrapping is disabled and there isn't enough space to fit the whole line, the text is clipped at the cell boundaries.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming Namespace
Font Property
Text Property


MindFusion.Diagramming.TableNode.Cell.ToolTip Property

TableNode.Cell.ToolTip Property
[image]

Gets or sets the tooltip text associated with the cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ToolTip { get; set; }

Visual Basic [image] Copy Code

Public Property ToolTip As String

Property Value

The tool-tip text displayed for this cell. The default is an empty string.

Remarks

For more information, see the DiagramItem.ToolTip property.

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.CellCollection Class

TableNode.CellCollection Class
Remarks See Also
[image]

Represents a strongly-typed collection of TableNode.Cell objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TableNode.CellCollection : CollectionBase, IPersists

Visual Basic [image] Copy Code

Public Class TableNode.CellCollection
Inherits CollectionBase
Implements IPersists

Remarks

Do not use the methods and properties of this class to modify the contents of this collection directly. If you want to add or remove cells from a table, use the AddRow, AddColumn, InsertRow, InsertColumn, DeleteRow, DeleteColumn and RedimTable methods of the TableNode class instead.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Diagramming.TableNode.CellCollection

See Also

TableNode.CellCollection Members


MindFusion.Diagramming.TableNode.CellCollection Members

TableNode.CellCollection Members
Constructors Properties Methods
[image]

Represents a strongly-typed collection of TableNode.Cell objects.

The following tables list the members exposed by the TableNode.CellCollection type.

Public Constructors

Name | Description
TableNode.CellCollection | Initializes a new instance of the TableNode.CellCollection class.

Public Properties

Name | Description
Item | Gets or sets the cell at the specified position within the collection.

Public Methods

Name | Description
Add | Adds the specified cell to the collection.
Clone | Creates a deep copy of this collection.
GetAt | Returns the cell at the specified position.
Insert | Inserts the specified cell at the specified index within the collection.
Remove | Removes the specified cell from the collection.

See Also

TableNode.CellCollection Class


MindFusion.Diagramming.TableNode.CellCollection Constructor

TableNode.CellCollection Constructor
[image]

Initializes a new instance of the TableNode.CellCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.CellCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

Remarks

This constructor supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

TableNode.CellCollection Class


MindFusion.Diagramming.TableNode.CellCollection Methods

TableNode.CellCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified cell to the collection.
Clone | Creates a deep copy of this collection.
GetAt | Returns the cell at the specified position.
Insert | Inserts the specified cell at the specified index within the collection.
Remove | Removes the specified cell from the collection.

See Also

TableNode.CellCollection Class


MindFusion.Diagramming.TableNode.CellCollection.Add Method

TableNode.CellCollection.Add Method
[image]

Adds the specified cell to the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Add (
TableNode.Cell cell
)

Visual Basic [image] Copy Code

Public Sub Add ( _
cell As TableNode.Cell _
)

Parameters

cell
The TableNode.Cell object to add to the collection.

Remarks

Do not use this method directly. Use the methods of the TableNode class instead.

See Also

TableNode.CellCollection Members
TableNode.CellCollection Class


MindFusion.Diagramming.TableNode.CellCollection.Clone Method

TableNode.CellCollection.Clone Method
[image]

Creates a deep copy of this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.CellCollection Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As TableNode.CellCollection

Return Value

An instance of the TableNode.CellCollection class.

Remarks

This method supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

TableNode.CellCollection Members
TableNode.CellCollection Class


MindFusion.Diagramming.TableNode.CellCollection.GetAt Method

TableNode.CellCollection.GetAt Method
[image]

Returns the cell at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.Cell GetAt (
int index
)

Visual Basic [image] Copy Code

Public Function GetAt ( _
index As Integer _
) As TableNode.Cell

Parameters

index

The zero-based index of the cell to retrieve.

Return Value

A reference to the TableNode.Cell object at the specified position.

See Also

TableNode.CellCollection Members
TableNode.CellCollection Class


MindFusion.Diagramming.TableNode.CellCollection.Insert Method

TableNode.CellCollection.Insert Method
[image]

Inserts the specified cell at the specified index within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Insert (
int index,
TableNode.Cell cell
)

Visual Basic [image] Copy Code

Public Sub Insert ( _
index As Integer, _
cell As TableNode.Cell _
)

Parameters

index

The zero-based index at which to insert the cell.

cell

The TableNode.Cell object to add to the collection.

Remarks

Do not use this method directly. Use the methods of the TableNode class instead.

See Also

TableNode.CellCollection Members
TableNode.CellCollection Class


MindFusion.Diagramming.TableNode.CellCollection.Remove Method

TableNode.CellCollection.Remove Method
[image]

Removes the specified cell from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Remove (
TableNode.Cell cell
)

Visual Basic [image] Copy Code

Public Sub Remove ( _
cell As TableNode.Cell _
)

Parameters

cell

The TableNode.Cell object to add to the collection.

Remarks

Do not use this method directly. Use the methods of the TableNode class instead.

See Also

TableNode.CellCollection Members
TableNode.CellCollection Class


MindFusion.Diagramming.TableNode.CellCollection Properties

TableNode.CellCollection Properties
[image]

Public Properties

Name | Description
Item | Gets or sets the cell at the specified position within the collection.

See Also

TableNode.CellCollection Class


MindFusion.Diagramming.TableNode.CellCollection.Item Property

TableNode.CellCollection.Item Property
[image]

Gets or sets the cell at the specified position within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.Cell Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Property Item ( _
index As Integer _
) As TableNode.Cell

Parameters

index

The zero-based index of the item which should be get or set.

Property Value

A reference to the TableNode.Cell object at the specified index.

Remarks

Do not use the set accessor of this property. It supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

TableNode.CellCollection Members
TableNode.CellCollection Class


MindFusion.Diagramming.TableNode.Column Class

TableNode.Column Class
Remarks See Also
[image]

Represents a column of a TableNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TableNode.Column : IPersists

Visual Basic [image] Copy Code

Public Class TableNode.Column
Implements IPersists

Remarks

The width of a column can be set via its Width property. The width of a column determines the width of all cells contained within the column.

When resizing a table, its columns can be resized too. That depends on the value of ColumnStyle, which specifies whether columns are with fixed width or they resize to keep column-to-table width ratio.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.TableNode.Column

See Also

TableNode.Column Members


MindFusion.Diagramming.TableNode.Column Members

TableNode.Column Members
Constructors Properties Methods
[image]

Represents a column of a TableNode.

The following tables list the members exposed by the TableNode.Column type.

Public Constructors

Name | Description
TableNode.Column | Initializes a new instance of the TableNode.Column class.

Public Properties

Name | Description
ColumnStyle | Gets or sets the manner in which column's width is set.
Width | Gets or sets the width of the table column.

Public Methods

Name | Description
Clone | Creates a copy of this column.

Protected Methods

Name | Description
LoadFromXml | Loads the column properties from an XML element.
SaveToXml | Saves the column properties into an XML element.

See Also

TableNode.Column Class


MindFusion.Diagramming.TableNode.Column Constructor

TableNode.Column Constructor
[image]

Initializes a new instance of the TableNode.Column class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.Column (
TableNode tableNode
)

Visual Basic [image] Copy Code

Public Sub TableNode.Column ( _
tableNode As TableNode _
)

Parameters

tableNode
The TableNode this column belongs to.

See Also

TableNode.Column Class


MindFusion.Diagramming.TableNode.Column Methods

TableNode.Column Methods
[image]

Public Methods

Name | Description
Clone | Creates a copy of this column.

Protected Methods

Name | Description
LoadFromXml | Loads the column properties from an XML element.
SaveToXml | Saves the column properties into an XML element.

See Also

TableNode.Column Class


MindFusion.Diagramming.TableNode.Column.Clone Method

TableNode.Column.Clone Method
[image]

Creates a copy of this column.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.Column Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As TableNode.Column

Return Value

An instance of the TableNode.Column class.

See Also

TableNode.Column Members
TableNode.Column Class


MindFusion.Diagramming.TableNode.Column.LoadFromXml Method

TableNode.Column.LoadFromXml Method
[image]

Loads the column properties from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub LoadFromXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement containing the column's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Column Members
TableNode.Column Class


MindFusion.Diagramming.TableNode.Column.SaveToXml Method

TableNode.Column.SaveToXml Method
[image]

Saves the column properties into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub SaveToXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement the column's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Column Members
TableNode.Column Class


MindFusion.Diagramming.TableNode.Column Properties

TableNode.Column Properties
[image]

Public Properties

Name | Description
ColumnStyle | Gets or sets the manner in which column's width is set.
Width | Gets or sets the width of the table column.

See Also

TableNode.Column Class


MindFusion.Diagramming.TableNode.Column.ColumnStyle Property

TableNode.Column.ColumnStyle Property
[image]

Gets or sets the manner in which column's width is set.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ColumnStyle ColumnStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ColumnStyle As ColumnStyle

Property Value

A member of the ColumnStyle enumeration. The default is ColumnStyle.FixedWidth.

Remarks

This property is used for calculating the width of a table column. The column can have either a fixed width set through the Width property, or can be resized proportionally to the table width.

See Also

TableNode.Column Members
TableNode.Column Class


MindFusion.Diagramming.TableNode.Column.Width Property

TableNode.Column.Width Property
[image]

Gets or sets the width of the table column.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Single

Property Value

A float value indicating the width of the column. The default is 50.

See Also

TableNode.Column Members
TableNode.Column Class
TableNode.ColumnWidth Property


MindFusion.Diagramming.TableNode.ColumnCollection Class

TableNode.ColumnCollection Class
Remarks See Also
[image]

Represents a strongly-typed collection of TableNode.Column objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TableNode.ColumnCollection : CollectionBase, IPersists

Visual Basic [image] Copy Code

Public Class TableNode.ColumnCollection
Inherits CollectionBase
Implements IPersists

Remarks

Do not use the methods and properties of this class to modify the contents of this collection directly. If you want to add or remove columns from a table, use the AddColumn, InsertColumn, DeleteColumn and RedimTable methods of the TableNode class instead.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Diagramming.TableNode.ColumnCollection

See Also

TableNode.ColumnCollection Members


MindFusion.Diagramming.TableNode.ColumnCollection Members

TableNode.ColumnCollection Members
Constructors Properties Methods
[image]

Represents a strongly-typed collection of TableNode.Column objects.

The following tables list the members exposed by the TableNode.ColumnCollection type.

Public Constructors

Name | Description
TableNode.ColumnCollection | Initializes a new instance of the TableNode.ColumnCollection class.

Public Properties

Name | Description
Item | Gets or sets the column at the specified position within the collection.

Public Methods

Name | Description
Add | Adds the specified column to the collection.
Clone | Creates a deep copy of this collection.
GetAt | Returns the column at the specified position.
Insert | Inserts the specified column at the specified index within the collection.
Remove | Removes the specified column from the collection.

See Also

TableNode.ColumnCollection Class


MindFusion.Diagramming.TableNode.ColumnCollection Constructor

TableNode.ColumnCollection Constructor
[image]

Initializes a new instance of the TableNode.ColumnCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.ColumnCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

Remarks

This constructor supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

TableNode.ColumnCollection Class


MindFusion.Diagramming.TableNode.ColumnCollection Methods

TableNode.ColumnCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified column to the collection.
Clone | Creates a deep copy of this collection.
GetAt | Returns the column at the specified position.
Insert | Inserts the specified column at the specified index within the collection.
Remove | Removes the specified column from the collection.

See Also

TableNode.ColumnCollection Class


MindFusion.Diagramming.TableNode.ColumnCollection.Add Method

TableNode.ColumnCollection.Add Method
[image]

Adds the specified column to the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Add (
TableNode.Column column
)

Visual Basic [image] Copy Code

Public Sub Add ( _
column As TableNode.Column _
)

Parameters

column
The TableNode.Column object to add to the collection.

Remarks

Do not use this method directly. Use the AddColumn method of the TableNode class instead.

See Also

TableNode.ColumnCollection Members
TableNode.ColumnCollection Class


MindFusion.Diagramming.TableNode.ColumnCollection.Clone Method

TableNode.ColumnCollection.Clone Method
[image]

Creates a deep copy of this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.ColumnCollection Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As TableNode.ColumnCollection

Return Value

An instance of the TableNode.ColumnCollection class.

Remarks

This method supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

TableNode.ColumnCollection Members
TableNode.ColumnCollection Class


MindFusion.Diagramming.TableNode.ColumnCollection.GetAt Method

TableNode.ColumnCollection.GetAt Method
[image]

Returns the column at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.Column GetAt (
int index
)

Visual Basic [image] Copy Code

Public Function GetAt ( _
index As Integer _
) As TableNode.Column

Parameters

index
The zero-based index of the column to retrieve.

Return Value

A reference to the TableNode.Column object at the specified position.

See Also

TableNode.ColumnCollection Members
TableNode.ColumnCollection Class


MindFusion.Diagramming.TableNode.ColumnCollection.Insert Method

TableNode.ColumnCollection.Insert Method
[image]

Inserts the specified column at the specified index within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Insert (
int index,
TableNode.Column column
)

Visual Basic [image] Copy Code

Public Sub Insert ( _
index As Integer, _
column As TableNode.Column _
)

Parameters

index
The zero-based index at which to insert the column.
column
The TableNode.Column object to add to the collection.

Remarks

Do not use this method directly. Use the InsertColumn method of the TableNode class instead.

See Also

TableNode.ColumnCollection Members
TableNode.ColumnCollection Class


MindFusion.Diagramming.TableNode.ColumnCollection.Remove Method

TableNode.ColumnCollection.Remove Method
[image]

Removes the specified column from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Remove (
TableNode.Column column
)

Visual Basic [image] Copy Code

Public Sub Remove ( _
column As TableNode.Column _
)

Parameters

column
The TableNode.Column object to add to the collection.

Remarks

Do not use this method directly. Use the DeleteColumn method of the TableNode class instead.

See Also

TableNode.ColumnCollection Members
TableNode.ColumnCollection Class


MindFusion.Diagramming.TableNode.ColumnCollection Properties

TableNode.ColumnCollection Properties
[image]

Public Properties

Name | Description
Item | Gets or sets the column at the specified position within the collection.

See Also

TableNode.ColumnCollection Class


MindFusion.Diagramming.TableNode.ColumnCollection.Item Property

TableNode.ColumnCollection.Item Property
[image]

Gets or sets the column at the specified position within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.Column Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Property Item ( _
index As Integer _
) As TableNode.Column

Parameters

index
The zero-based index of the item which should be get or set.

Property Value

A reference to the TableNode.Column object at the specified index.

Remarks

Do not use the set accessor of this property. It supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

TableNode.ColumnCollection Members
TableNode.ColumnCollection Class


MindFusion.Diagramming.TableNode.Row Class

TableNode.Row Class
Remarks See Also
[image]

Represents a row in TableNode node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TableNode.Row : IPersists

Visual Basic [image] Copy Code

Public Class TableNode.Row
Implements IPersists

Remarks

Table rows can be assigned to distinct sections of a table. For example, sections could contain rows representing different types of class members in class diagrams, there could be one section displaying the methods, another one for the events and one more for the properties of a class. Each section can be collapsed or expanded, hiding or showing all rows in the section except the header one. To define a section, set a Header row. A section consists of all rows after a header row and spans to the next header. Each header row displays a [±] button that allows expanding or collapsing the section interactively. Sections can be collapsed and expanded programmatically using the Expanded property of the header row.

The height of a row is set via the Height property. That determines the height of all non-spanning cells contained within the row. Cells can be made to span several rows by setting their RowSpan property.

Rows can be bound together to represent relationship between database tables. The relationship can be one to many and many to one. The tables that stay on the left side of M:1 relationships are stored in the RelatedManyToOne collection; the tables in 1:M relationship with the row are stored in the RelatedOneToMany collection.

The relationship between tables is shown with links. You can access the DiagramLink elements that go out of a table row via the OutgoingLinks property. Links that come into a given row can be accessed with the IncomingLinks property.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.TableNode.Row

See Also

TableNode.Row Members


MindFusion.Diagramming.TableNode.Row Members

TableNode.Row Members
Constructors Properties Methods
[image]

Represents a row in TableNode node.

The following tables list the members exposed by the TableNode.Row type.

Public Constructors

Name | Description
TableNode.Row | Initializes a new instance of the TableNode.Row class.

Public Properties

Name | Description
AnchorPattern | Gets or sets a set of anchor points to which links can dock when connected to this row.
Expanded | Gets or sets a value indicating whether the table section starting from this Header row is collapsed or expanded.
Header | Gets or sets a value indicating whether this row is a section header.
Height | Gets or sets the height of the table row.
IncomingLinks | Gets a collection of all links that point to this table row.
OutgoingLinks | Gets a collection of all links that go out of this table row.
RelatedManyToOne | Gets a collection of all tables that are in many-to-one relation with this table row.
RelatedOneToMany | Gets a collection of all tables that are in one-to-many relation with this table row.
Table | Gets the TableNode that contains this row.

Public Methods

Name | Description
Clone | Creates a copy of this row.

Protected Methods

Name | Description
LoadFromXml | Loads the row properties from an XML element.
SaveToXml | Saves the row properties into an XML element.

See Also

TableNode.Row Class


MindFusion.Diagramming.TableNode.Row Constructor

TableNode.Row Constructor
[image]

Initializes a new instance of the TableNode.Row class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.Row (
TableNode tableNode
)

Visual Basic [image] Copy Code

Public Sub TableNode.Row ( _
tableNode As TableNode _
)

Parameters

table

The TableNode this row belongs to.

See Also

TableNode.Row Class


MindFusion.Diagramming.TableNode.Row Methods

TableNode.Row Methods
[image]

Public Methods

Name | Description
Clone | Creates a copy of this row.

Protected Methods

Name | Description
LoadFromXml | Loads the row properties from an XML element.
SaveToXml | Saves the row properties into an XML element.

See Also

TableNode.Row Class


MindFusion.Diagramming.TableNode.Row.Clone Method

TableNode.Row.Clone Method
[image]

Creates a copy of this row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.Row Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As TableNode.Row

Return Value

An instance of the TableNode.Row class.

See Also

TableNode.Row Members
TableNode.Row Class


MindFusion.Diagramming.TableNode.Row.LoadFromXml Method

TableNode.Row.LoadFromXml Method
[image]

Loads the row properties from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub LoadFromXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement containing the row's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Row Members
TableNode.Row Class


MindFusion.Diagramming.TableNode.Row.SaveToXml Method

TableNode.Row.SaveToXml Method
[image]

Saves the row properties into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub SaveToXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement the row's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Row Members
TableNode.Row Class


MindFusion.Diagramming.TableNode.Row Properties

TableNode.Row Properties
[image]

Public Properties

Name | Description
AnchorPattern | Gets or sets a set of anchor points to which links can dock when connected to this row.
Expanded | Gets or sets a value indicating whether the table section starting from this Header row is collapsed or expanded.
Header | Gets or sets a value indicating whether this row is a section header.
Height | Gets or sets the height of the table row.
IncomingLinks | Gets a collection of all links that point to this table row.
OutgoingLinks | Gets a collection of all links that go out of this table row.
RelatedManyToOne | Gets a collection of all tables that are in many-to-one relation with this table row.
RelatedOneToMany | Gets a collection of all tables that are in one-to-many relation with this table row.
Table | Gets the TableNode that contains this row.

See Also

TableNode.Row Class


MindFusion.Diagramming.TableNode.Row.AnchorPattern Property

TableNode.Row.AnchorPattern Property
[image]

Gets or sets a set of anchor points to which links can dock when connected to this row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern AnchorPattern { get; set; }

Visual Basic [image] Copy Code

Public Property AnchorPattern As AnchorPattern

Property Value

An instance of the AnchorPattern class.

Remarks

AnchorPattern defines a set of locations where links connected to a row are allowed to connect. When a link is connected to a row, the respective end of the link is aligned to the nearest AnchorPoint assigned to that row. If a row does not have associated anchor points of the appropriate type (incoming/outgoing), the link will be connected to the nearest row that has such anchors defined. If none of the rows of a table has an associated anchor pattern, links are connected to the middle of the left or right side of the pointed row.

See Also

TableNode.Row Members
TableNode.Row Class
MindFusion.Diagramming Namespace
TableNode.RowAnchorPattern Property
AnchorPoint.Column Property


MindFusion.Diagramming.TableNode.Row.Expanded Property

TableNode.Row.Expanded Property
[image]

Gets or sets a value indicating whether the table section starting from this Header row is collapsed or expanded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Expanded { get; set; }

Visual Basic [image] Copy Code

Public Property Expanded As Boolean

Property Value

true if the table section that starts from this row is expanded; otherwise, false. The default is true.

Remarks

This property can be set only if the row is a Header. Links connected to the rows of a collapsed table section appear to be connected to the section header row.

See Also

TableNode.Row Members
TableNode.Row Class


MindFusion.Diagramming.TableNode.Row.Header Property

TableNode.Row.Header Property
[image]

Gets or sets a value indicating whether this row is a section header.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Header { get; set; }

Visual Basic [image] Copy Code

Public Property Header As Boolean

Property Value

true if this is the header row of a table section, otherwise false. The default is false.

Remarks

Each header row defines a section of the table that includes all non-header rows after the header. Such sections can be expanded or collapsed, that is, the rows included in them can be shown or hidden. This can be done interactively by pressing the [±] button displayed in header rows, or programmatically by setting the Expanded property. The TableSectionCollapsed and TableSectionExpanded events are raised when a user clicks the [±] button.

See Also

TableNode.Row Members
TableNode.Row Class
OffsetHeaderRows Property


MindFusion.Diagramming.TableNode.Row.Height Property

TableNode.Row.Height Property
[image]

Gets or sets the height of the table row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Single

Property Value

A float value indicating the height of the row. The default is 22.

See Also

TableNode.Row Members
TableNode.Row Class
TableNode.RowHeight Property


MindFusion.Diagramming.TableNode.Row.IncomingLinks Property

TableNode.Row.IncomingLinks Property
[image]

Gets a collection of all links that point to this table row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection IncomingLinks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IncomingLinks As DiagramLinkCollection

Property Value

A DiagramLinkCollection containing references to the incoming links.

Remarks

The property returns a collection of all links that point to this table row. Use it to access the links or get their number.

See Also

TableNode.Row Members
TableNode.Row Class
OutgoingLinks Property


MindFusion.Diagramming.TableNode.Row.OutgoingLinks Property

TableNode.Row.OutgoingLinks Property
[image]

Gets a collection of all links that go out of this table row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection OutgoingLinks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OutgoingLinks As DiagramLinkCollection

Property Value

A DiagramLinkCollection containing references to the outgoing links.

Remarks

The property returns a collection of all links that start from this table row. Use it to access the links or get their number.

See Also

TableNode.Row Members
TableNode.Row Class
IncomingLinks Property


MindFusion.Diagramming.TableNode.Row.RelatedManyToOne Property

TableNode.Row.RelatedManyToOne Property
[image]

Gets a collection of all tables that are in many-to-one relation with this table row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeCollection RelatedManyToOne { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RelatedManyToOne As DiagramNodeCollection

Property Value

A DiagramNodeCollection containing references to the TableNode objects, which are in relation M:1 with this row.

Remarks

When working with database diagrams, use this property to find all tables which are in M:1 relation with this row.

See Also

TableNode.Row Members
TableNode.Row Class
RelatedOneToMany Property


MindFusion.Diagramming.TableNode.Row.RelatedOneToMany Property

TableNode.Row.RelatedOneToMany Property
[image]

Gets a collection of all tables that are in one-to-many relation with this table row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeCollection RelatedOneToMany { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RelatedOneToMany As DiagramNodeCollection

Property Value

A DiagramNodeCollection containing references to the TableNode objects, which are in relation 1:M with this row.

Remarks

When working with database diagrams, use this property to find all tables which are in 1:M relation with this row.

See Also

TableNode.Row Members
TableNode.Row Class


MindFusion.Diagramming.TableNode.Row.Table Property

TableNode.Row.Table Property
[image]

Gets the TableNode that contains this row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode Table { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Table As TableNode

Property Value

A TableNode instance.

See Also

TableNode.Row Members
TableNode.Row Class


MindFusion.Diagramming.TableNode.RowCollection Class

TableNode.RowCollection Class
Remarks See Also
[image]

Represents a strongly-typed collection of TableNode.Row objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TableNode.RowCollection : CollectionBase, IPersists

Visual Basic [image] Copy Code

Public Class TableNode.RowCollection
Inherits CollectionBase
Implements IPersists

Remarks

Do not use the methods and properties of this class to modify the contents of this collection directly. If you want to add or remove rows from a table, use the AddRow, InsertRow, DeleteRow and RedimTable methods of the TableNode class instead.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Diagramming.TableNode.RowCollection

See Also

TableNode.RowCollection Members


MindFusion.Diagramming.TableNode.RowCollection Members

TableNode.RowCollection Members
Constructors Properties Methods
[image]

Represents a strongly-typed collection of TableNode.Row objects.

The following tables list the members exposed by the TableNode.RowCollection type.

Public Constructors

Name | Description
TableNode.RowCollection | Initializes a new instance of the TableNode.RowCollection class.

Public Properties

Name | Description
Item | Gets or sets the row at the specified position within the collection.

Public Methods

Name | Description
Add | Adds the specified row to the collection.
Clone | Creates a deep copy of this collection.
GetAt | Returns the row at the specified position.
IndexOf | Returns the index of the specified row within the collection.
Insert | Inserts the specified row at the specified index within the collection.
Remove | Removes the specified row from the collection.

See Also

TableNode.RowCollection Class


MindFusion.Diagramming.TableNode.RowCollection Constructor

TableNode.RowCollection Constructor
[image]

Initializes a new instance of the TableNode.RowCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.RowCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

Remarks

This constructor supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

TableNode.RowCollection Class


MindFusion.Diagramming.TableNode.RowCollection Methods

TableNode.RowCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified row to the collection.
Clone | Creates a deep copy of this collection.
GetAt | Returns the row at the specified position.
IndexOf | Returns the index of the specified row within the collection.
Insert | Inserts the specified row at the specified index within the collection.
Remove | Removes the specified row from the collection.

See Also

TableNode.RowCollection Class


MindFusion.Diagramming.TableNode.RowCollection.Add Method

TableNode.RowCollection.Add Method
[image]

Adds the specified row to the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Add (
TableNode.Row r
)

Visual Basic [image] Copy Code

Public Sub Add ( _
r As TableNode.Row _
)

Parameters

r
The TableNode.Row object to add to the collection.

Remarks

Do not use this method directly. Use the AddRow method of the TableNode class instead.

See Also

TableNode.RowCollection Members
TableNode.RowCollection Class


MindFusion.Diagramming.TableNode.RowCollection.Clone Method

TableNode.RowCollection.Clone Method
[image]

Creates a deep copy of this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.RowCollection Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As TableNode.RowCollection

Return Value

An instance of the TableNode.RowCollection class.

Remarks

This method supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

TableNode.RowCollection Members
TableNode.RowCollection Class


MindFusion.Diagramming.TableNode.RowCollection.GetAt Method

TableNode.RowCollection.GetAt Method
[image]

Returns the row at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.Row GetAt (
int index
)

Visual Basic [image] Copy Code

Public Function GetAt ( _
index As Integer _
) As TableNode.Row

Parameters

index
The zero-based index of the row to retrieve.

Return Value

A reference to the TableNode.Row object at the specified position.

Remarks

A reference to the TableNode.Row object at the specified position.

See Also

TableNode.RowCollection Members
TableNode.RowCollection Class


MindFusion.Diagramming.TableNode.RowCollection.IndexOf Method

TableNode.RowCollection.IndexOf Method
[image]

Returns the index of the specified row within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int IndexOf (
TableNode.Row row
)

Visual Basic [image] Copy Code

Public Function IndexOf ( _
row As TableNode.Row _
) As Integer

Parameters

row
The TableNode.Row object whose index to search for in the collection.

Return Value

An integer value specifying the index of the row within the collection or -1, if the row was not found.

See Also

TableNode.RowCollection Members
TableNode.RowCollection Class


MindFusion.Diagramming.TableNode.RowCollection.Insert Method

TableNode.RowCollection.Insert Method
[image]

Inserts the specified row at the specified index within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Insert (
int index,
TableNode.Row row
)

Visual Basic [image] Copy Code

Public Sub Insert ( _
index As Integer, _
row As TableNode.Row _
)

Parameters

index

The zero-based index at which to insert the row.

row

The TableNode.Row object to add to the collection.

Remarks

Do not use this method directly. Use the InsertRow method of the TableNode class instead.

See Also

TableNode.RowCollection Members
TableNode.RowCollection Class


MindFusion.Diagramming.TableNode.RowCollection.Remove Method

TableNode.RowCollection.Remove Method
[image]

Removes the specified row from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Remove (
TableNode.Row row
)

Visual Basic [image] Copy Code

Public Sub Remove ( _
row As TableNode.Row _
)

Parameters

row

The TableNode.Row object to add to the collection.

Remarks

Do not use this method directly. Use the DeleteRow method of the TableNode class instead.

See Also

TableNode.RowCollection Members
TableNode.RowCollection Class


MindFusion.Diagramming.TableNode.RowCollection Properties

TableNode.RowCollection Properties
[image]

Public Properties

Name | Description
Item | Gets or sets the row at the specified position within the collection.

See Also

TableNode.RowCollection Class


MindFusion.Diagramming.TableNode.RowCollection.Item Property

TableNode.RowCollection.Item Property
[image]

Gets or sets the row at the specified position within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.Row Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Property Item ( _
index As Integer _
) As TableNode.Row

Parameters

index

Property Value

A reference to the TableNode.Row object at the specified index.

Remarks

Do not use the set accessor of this property. It supports the MvcDiagram infrastructure and is not intended to be used directly from your code.

See Also

TableNode.RowCollection Members
TableNode.RowCollection Class


MindFusion.Diagramming.TableNodeProperties Class

TableNodeProperties Class
Remarks See Also
[image]

Stores the values of TableNode properties during undo / redo operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TableNodeProperties : DiagramNodeProperties

Visual Basic [image] Copy Code

Public Class TableNodeProperties
Inherits DiagramNodeProperties

Remarks

If you need to implement undo support for the additional properties defined by a class derived from TableNode, do so by deriving from TableNodeProperties and overriding the SaveProperties, RestoreProperties, and CreateProperties methods of TableNode.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemProperties
MindFusion.Diagramming.DiagramNodeProperties
MindFusion.Diagramming.TableNodeProperties

See Also

TableNodeProperties Members


MindFusion.Diagramming.TableNodeProperties Members

TableNodeProperties Members
Constructors Fields Methods
[image]

Stores the values of TableNode properties during undo / redo operations.

The following tables list the members exposed by the TableNodeProperties type.

Public Constructors

Name | Description
TableNodeProperties | Initializes a new instance of the TableNodeProperties class.

Public Fields

Name | Description
Caption | For internal use.
CaptionHeight | For internal use.
CellTextBrush | For internal use.
ColumnWidth | For internal use.
CurrScrollRow | For internal use.
ItemClass | For internal use. (Inherited from DiagramItemProperties.)
RowHeight | For internal use.
Scrollable | For internal use.
Selected | For internal use. (Inherited from DiagramItemProperties.)
TextPadding | For internal use. (Inherited from DiagramItemProperties.)
ZIndex | For internal use. (Inherited from DiagramItemProperties.)

Public Methods

Name | Description
FreeResources | DiagramItemProperties.FreeResources override.

See Also

TableNodeProperties Class


MindFusion.Diagramming.TableNodeProperties Fields

TableNodeProperties Fields
[image]

Public Fields

Name | Description
Caption | For internal use.
CaptionHeight | For internal use.
CellTextBrush | For internal use.
ColumnWidth | For internal use.
CurrScrollRow | For internal use.
ItemClass | For internal use. (Inherited from DiagramItemProperties.)
RowHeight | For internal use.
Scrollable | For internal use.
Selected | For internal use. (Inherited from DiagramItemProperties.)
TextPadding | For internal use. (Inherited from DiagramItemProperties.)
ZIndex | For internal use. (Inherited from DiagramItemProperties.)

See Also

TableNodeProperties Class


MindFusion.Diagramming.TableNodeProperties.Caption Field

TableNodeProperties.Caption Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Caption

Visual Basic [image] Copy Code

Public Caption As String

See Also

TableNodeProperties Members
TableNodeProperties Class


MindFusion.Diagramming.TableNodeProperties.CaptionHeight Field

TableNodeProperties.CaptionHeight Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float CaptionHeight

Visual Basic [image] Copy Code

Public CaptionHeight As Single

See Also

TableNodeProperties Members
TableNodeProperties Class


MindFusion.Diagramming.TableNodeProperties.CellTextBrush Field

TableNodeProperties.CellTextBrush Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush CellTextBrush

Visual Basic [image] Copy Code

Public CellTextBrush As Brush

See Also

TableNodeProperties Members
TableNodeProperties Class


MindFusion.Diagramming.TableNodeProperties.ColumnWidth Field

TableNodeProperties.ColumnWidth Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float ColumnWidth

Visual Basic [image] Copy Code

Public ColumnWidth As Single

See Also

TableNodeProperties Members
TableNodeProperties Class


MindFusion.Diagramming.TableNodeProperties.CurrScrollRow Field

TableNodeProperties.CurrScrollRow Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int CurrScrollRow

Visual Basic [image] Copy Code

Public CurrScrollRow As Integer

See Also

TableNodeProperties Members
TableNodeProperties Class


MindFusion.Diagramming.TableNodeProperties.RowHeight Field

TableNodeProperties.RowHeight Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float RowHeight

Visual Basic [image] Copy Code

Public RowHeight As Single

See Also

TableNodeProperties Members
TableNodeProperties Class


MindFusion.Diagramming.TableNodeProperties.Scrollable Field

TableNodeProperties.Scrollable Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Scrollable

Visual Basic [image] Copy Code

Public Scrollable As Boolean

See Also

TableNodeProperties Members
TableNodeProperties Class


MindFusion.Diagramming.TableNodeProperties Constructor

TableNodeProperties Constructor
[image]

Initializes a new instance of the TableNodeProperties class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNodeProperties ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TableNodeProperties Class


MindFusion.Diagramming.TableNodeProperties Methods

TableNodeProperties Methods
[image]

Public Methods

Name | Description
FreeResources | DiagramItemProperties.FreeResources override.

See Also

TableNodeProperties Class


MindFusion.Diagramming.TableNodeProperties.FreeResources Method

TableNodeProperties.FreeResources Method
[image]

DiagramItemProperties.FreeResources override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void FreeResources ()

Visual Basic [image] Copy Code

Public Overrides Sub FreeResources ()

See Also

TableNodeProperties Members
TableNodeProperties Class


MindFusion.Diagramming.TableNodeStyle Class

TableNodeStyle Class
[image]

Represents a reusable set of properties that define the appearance of table nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TableNodeStyle : DiagramNodeStyle

Visual Basic [image] Copy Code

Public Class TableNodeStyle
Inherits DiagramNodeStyle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Style
MindFusion.Diagramming.DiagramItemStyle
MindFusion.Diagramming.DiagramNodeStyle
MindFusion.Diagramming.TableNodeStyle

See Also

TableNodeStyle Members


MindFusion.Diagramming.TableNodeStyle Members

TableNodeStyle Members
Constructors Properties Methods Events
[image]

Represents a reusable set of properties that define the appearance of table nodes.

The following tables list the members exposed by the TableNodeStyle type.

Public Constructors

Name | Description
TableNodeStyle | Initializes a new instance of the TableNodeStyle class.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of the item. (Inherited from DiagramItemStyle.)
CaptionBackBrush | Gets or sets the brush used to paint the caption area of this table.
CellTextBrush | Gets or sets the brush used to paint texts inside table cells.
Effects | Gets a list of the effects applied to the node. (Inherited from DiagramNodeStyle.)
FontFamily | Gets or sets the font family of the item text. (Inherited from DiagramItemStyle.)
FontSize | Gets or sets the font size of the item text. (Inherited from DiagramItemStyle.)
FontStyle | Gets or sets the font style of the item text. (Inherited from DiagramItemStyle.)
FontUnit | Gets or sets the font unit of the item text. (Inherited from DiagramItemStyle.)
ShadowBrush | Gets or sets the brush used to paint the shadow of the item. (Inherited from DiagramItemStyle.)
Stroke | Gets or sets the brush used to paint the outline of the item. (Inherited from DiagramItemStyle.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItemStyle.)
StrokeThickness | Gets or sets the thickness of the item's outline, expressed in the current units of measure. (Inherited from DiagramItemStyle.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItemStyle.)

Public Methods

Name | Description
GetProperties | Gets all properties in the style. (Inherited from Style.)
GetProperty | Returns the property with the specified name, if any. (Inherited from Style.)
RegisterType | Associates a type with an alias. (Inherited from Style.)

Protected Methods

Name | Description
GetValue | Gets the value of the specified property. (Inherited from Style.)
IsPropertySet | Checks whether the specified property has a value. (Inherited from Style.)
LoadFrom | Deserializes the item from the specified reader. (Inherited from Style.)
LoadFromXml | Loads the style content from an XML element. (Inherited from Style.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Style.)
RegisterProperty | Registers a new property with the specified name and type. (Inherited from Style.)
SaveTo | Serializes the style to the specified writer. (Inherited from Style.)
SaveToXml | Saves the style content into an XML element. (Inherited from Style.)
SetValue | Sets the value of the specified property. (Inherited from Style.)
UnsetValue | Clears the value of the specified property. (Inherited from Style.)

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

TableNodeStyle Class


MindFusion.Diagramming.TableNodeStyle Constructor

TableNodeStyle Constructor
[image]

Initializes a new instance of the TableNodeStyle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNodeStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TableNodeStyle Class


MindFusion.Diagramming.TableNodeStyle Properties

TableNodeStyle Properties
[image]

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of the item. (Inherited from DiagramItemStyle.)
CaptionBackBrush | Gets or sets the brush used to paint the caption area of this table.
CellTextBrush | Gets or sets the brush used to paint texts inside table cells.
Effects | Gets a list of the effects applied to the node. (Inherited from DiagramNodeStyle.)
FontFamily | Gets or sets the font family of the item text. (Inherited from DiagramItemStyle.)
FontSize | Gets or sets the font size of the item text. (Inherited from DiagramItemStyle.)
FontStyle | Gets or sets the font style of the item text. (Inherited from DiagramItemStyle.)
FontUnit | Gets or sets the font unit of the item text. (Inherited from DiagramItemStyle.)
ShadowBrush | Gets or sets the brush used to paint the shadow of the item. (Inherited from DiagramItemStyle.)
Stroke | Gets or sets the brush used to paint the outline of the item. (Inherited from DiagramItemStyle.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItemStyle.)
StrokeThickness | Gets or sets the thickness of the item's outline, expressed in the current units of measure. (Inherited from DiagramItemStyle.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItemStyle.)

See Also

TableNodeStyle Class


MindFusion.Diagramming.TableNodeStyle.CaptionBackBrush Property

TableNodeStyle.CaptionBackBrush Property
[image]

Gets or sets the brush used to paint the caption area of this table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush CaptionBackBrush { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionBackBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

See Also

TableNodeStyle Members
TableNodeStyle Class


MindFusion.Diagramming.TableNodeStyle.CellTextBrush Property

TableNodeStyle.CellTextBrush Property
[image]

Gets or sets the brush used to paint texts inside table cells.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush CellTextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property CellTextBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

See Also

TableNodeStyle Members
TableNodeStyle Class


MindFusion.Diagramming.TableNodeStyle Events

TableNodeStyle Events
[image]

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

TableNodeStyle Class


MindFusion.Diagramming.Theme Class

Theme Class
[image]

Represents a set of Style objects for different diagram item types.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Theme

Visual Basic [image] Copy Code

Public Class Theme

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Theme

See Also

Theme Members


MindFusion.Diagramming.Theme Members

Theme Members
Constructors Methods
[image]

Represents a set of Style objects for different diagram item types.

The following tables list the members exposed by the Theme type.

Public Constructors

Name | Description
Theme | Initializes a new instance of the Theme class.

Public Methods

Name | Description
GetStyle | Gets the Style object, if any, associated with the specified type.
LoadFromString | Loads the theme from an XML string.
LoadFromXml | Loads the theme from an XML file.
RegisterStyle | Registers the specified Style object for the items of the specified type.
SaveToString | Saves the theme into an XML string.
SaveToXml | Saves the theme to an XML file.
UnregisterStyle | Unregisters the Style object associated with the specified type.

See Also

Theme Class


MindFusion.Diagramming.Theme Constructor

Theme Constructor
[image]

Initializes a new instance of the Theme class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Theme ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Theme Class


MindFusion.Diagramming.Theme Methods

Theme Methods
[image]

Public Methods

Name | Description
GetStyle | Gets the Style object, if any, associated with the specified type.
LoadFromString | Loads the theme from an XML string.
LoadFromXml | Loads the theme from an XML file.
RegisterStyle | Registers the specified Style object for the items of the specified type.
SaveToString | Saves the theme into an XML string.
SaveToXml | Saves the theme to an XML file.
UnregisterStyle | Unregisters the Style object associated with the specified type.

See Also

Theme Class


MindFusion.Diagramming.Theme.GetStyle Method

Theme.GetStyle Method
[image]

Gets the Style object, if any, associated with the specified type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Style GetStyle (
Type type
)

Visual Basic [image] Copy Code

Public Function GetStyle( _
type As Type _
) As Style

Parameters

type

The runtime type whose style to retrieve.

Return Value

The Style associated with the type, or null.

See Also

Theme Members
Theme Class


MindFusion.Diagramming.Theme.LoadFromString Method

Theme.LoadFromString Method
[image]

Loads the theme from an XML string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromString (
string xml
)

Visual Basic [image] Copy Code

Public Sub LoadFromString( _
xml As String _
)

Parameters

xml

The string to load from.

See Also

Theme Members
Theme Class


MindFusion.Diagramming.Theme.LoadFromXml Method

Theme.LoadFromXml Method
[image]

Loads the theme from an XML file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
fileName As String _
)

Parameters

fileName

The name of the file to load from.

See Also

Theme Members
Theme Class


MindFusion.Diagramming.Theme.RegisterStyle Method

Theme.RegisterStyle Method
[image]

Registers the specified Style object for the items of the specified type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RegisterStyle (
Type type,
Style style
)

Visual Basic [image] Copy Code

Public Sub RegisterStyle( _
type As Type, _
style As Style _
)

Parameters

type

The runtime type to register.

style

The style to associate with the specified type. The previously associated style, if any, is discarded.

See Also

Theme Members
Theme Class


MindFusion.Diagramming.Theme.SaveToString Method

Theme.SaveToString Method
[image]

Saves the theme into an XML string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string SaveToString ()

Visual Basic [image] Copy Code

Public Function SaveToString () As String

Return Value

The serialized string.

See Also

Theme Members
Theme Class


MindFusion.Diagramming.Theme.SaveToXml Method

Theme.SaveToXml Method
[image]

Saves the theme to an XML file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
fileName As String _
)

Parameters

fileName

The name of the file to save to.

See Also

Theme Members
Theme Class


MindFusion.Diagramming.Theme.UnregisterStyle Method

Theme.UnregisterStyle Method
[image]

Unregisters the Style object associated with the specified type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void UnregisterStyle (
Type type
)

Visual Basic [image] Copy Code

Public Sub UnregisterStyle( _
type As Type _
)

Parameters

type

The runtime type to unregister.

See Also

Theme Members
Theme Class


MindFusion.Diagramming.Thickness Structure

Thickness Structure
[image]

Describes the thickness of a rectangular frame.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public struct Thickness

Visual Basic [image] Copy Code

Public Structure Thickness

See Also

Thickness Members


MindFusion.Diagramming.Thickness Members

Thickness Members
Constructors Properties
[image]

Describes the thickness of a rectangular frame.

The following tables list the members exposed by the Thickness type.

Public Constructors

Name | Description
Thickness | Overloaded.

Public Properties

Name | Description
Bottom | Gets or sets the width of the bottom side of the frame.
Height | Returns the sum of Top and Bottom margins.
Left | Gets or sets the width of the left side of the frame.
Right | Gets or sets the width of the right side of the frame.
Top | Gets or sets the width of the top side of the frame.
Width | Returns the sum of Left and Right margins.

See Also

Thickness Structure


MindFusion.Diagramming.Thickness Constructor

Thickness Constructor
[image]

Overload List

Name | Description
Thickness (Single) | Initializes a new instance of the Thickness structure.
Thickness (Single, Single, Single, Single) | Initializes a new instance of the Thickness structure.

See Also

Thickness Structure


MindFusion.Diagramming.Thickness Constructor (Single)

Thickness Constructor (Single)
See Also
[image]

Initializes a new instance of the Thickness structure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Thickness (
float uniformLength
)

Visual Basic [image] Copy Code

Public New ( _
uniformLength As Single _
)

Parameters

uniformLength

See Also

Thickness Constructor Overload List
Thickness Structure


MindFusion.Diagramming.Thickness Constructor (Single, Single, Single, Single)

Thickness Constructor (Single, Single, Single, Single)
See Also
[image]

Initializes a new instance of the Thickness structure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Thickness (
float left,
float top,
float right,
float bottom
)

Visual Basic [image] Copy Code

Public New ( _
left As Single, _
top As Single, _
right As Single, _
bottom As Single _
)

Parameters

left

top

right

bottom

See Also

Thickness Constructor Overload List
Thickness Structure


MindFusion.Diagramming.Thickness Properties

Thickness Properties
[image]

Public Properties

Name | Description
Bottom | Gets or sets the width of the bottom side of the frame.
Height | Returns the sum of Top and Bottom margins.
Left | Gets or sets the width of the left side of the frame.
Right | Gets or sets the width of the right side of the frame.
Top | Gets or sets the width of the top side of the frame.
Width | Returns the sum of Left and Right margins.

See Also

Thickness Structure


MindFusion.Diagramming.Thickness.Bottom Property

Thickness.Bottom Property
[image]

Gets or sets the width of the bottom side of the frame.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Bottom { get; set; }

Visual Basic [image] Copy Code

Public Property Bottom As Single

Property Value

See Also

Thickness Members
Thickness Structure


MindFusion.Diagramming.Thickness.Height Property

Thickness.Height Property
[image]

Returns the sum of Top and Bottom margins.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Height { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Height As Single

Property Value

See Also

Thickness Members
Thickness Structure


MindFusion.Diagramming.Thickness.Left Property

Thickness.Left Property
[image]

Gets or sets the width of the left side of the frame.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Left { get; set; }

Visual Basic [image] Copy Code

Public Property Left As Single

Property Value

See Also

Thickness Members
Thickness Structure


MindFusion.Diagramming.Thickness.Right Property

Thickness.Right Property
[image]

Gets or sets the width of the right side of the frame.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Right { get; set; }

Visual Basic [image] Copy Code

Public Property Right As Single

Property Value

See Also

Thickness Members
Thickness Structure


MindFusion.Diagramming.Thickness.Top Property

Thickness.Top Property
[image]

Gets or sets the width of the top side of the frame.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Top { get; set; }

Visual Basic [image] Copy Code

Public Property Top As Single

Property Value

See Also

Thickness Members
Thickness Structure


MindFusion.Diagramming.Thickness.Width Property

Thickness.Width Property
[image]

Returns the sum of Left and Right margins.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Width { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Width As Single

Property Value

See Also

Thickness Members
Thickness Structure


MindFusion.Diagramming.ThicknessConverter Class

ThicknessConverter Class
[image]

The TypeConverter of the Thickness structure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ThicknessConverter : TypeConverter

Visual Basic [image] Copy Code

Public Class ThicknessConverter
Inherits TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
MindFusion.Diagramming.ThicknessConverter

See Also

ThicknessConverter Members


MindFusion.Diagramming.ThicknessConverter Members

ThicknessConverter Members
Constructors Methods
[image]

The TypeConverter of the Thickness structure.

The following tables list the members exposed by the ThicknessConverter type.

Public Constructors

Name | Description
ThicknessConverter | Initializes a new instance of the ThicknessConverter class.

Public Methods

Name | Description
CanConvertFrom | TypeConverter.CanConvertFrom override.
CanConvertTo | TypeConverter.CanConvertTo override.
ConvertFrom | TypeConverter.ConvertFrom override.
ConvertTo | TypeConverter.ConvertTo override.

See Also

ThicknessConverter Class


MindFusion.Diagramming.ThicknessConverter Constructor

ThicknessConverter Constructor
[image]

Initializes a new instance of the ThicknessConverter class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ThicknessConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ThicknessConverter Class


MindFusion.Diagramming.ThicknessConverter Methods

ThicknessConverter Methods
[image]

Public Methods

Name | Description
CanConvertFrom | TypeConverter.CanConvertFrom override.
CanConvertTo | TypeConverter.CanConvertTo override.
ConvertFrom | TypeConverter.ConvertFrom override.
ConvertTo | TypeConverter.ConvertTo override.

See Also

ThicknessConverter Class


MindFusion.Diagramming.ThicknessConverter.CanConvertFrom Method

ThicknessConverter.CanConvertFrom Method
[image]

TypeConverter.CanConvertFrom override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool CanConvertFrom (
ITypeDescriptorContext context,
Type sourceType
)

Visual Basic [image] Copy Code

Public Overrides Function CanConvertFrom( _
context As ITypeDescriptorContext, _
sourceType As Type _
) As Boolean

Parameters

context
An ITypeDescriptorContext that provides a format context.
sourceType
A Type that represents the type you want to convert from.

Return Value

See Also

ThicknessConverter Members
ThicknessConverter Class


MindFusion.Diagramming.ThicknessConverter.CanConvertTo Method

ThicknessConverter.CanConvertTo Method
[image]

TypeConverter.CanConvertTo override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool CanConvertTo (
ITypeDescriptorContext context,
Type destinationType
)

Visual Basic [image] Copy Code

Public Overrides Function CanConvertTo( _
context As ITypeDescriptorContext, _
destinationType As Type _
) As Boolean

Parameters

context
An ITypeDescriptorContext that provides a format context.
destinationType
A Type that represents the type you want to convert to.

Return Value

See Also

ThicknessConverter Members
ThicknessConverter Class


MindFusion.Diagramming.ThicknessConverter.ConvertFrom Method

ThicknessConverter.ConvertFrom Method
[image]

TypeConverter.ConvertFrom override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Object ConvertFrom (
ITypeDescriptorContext context,
CultureInfo culture,
Object value
)

Visual Basic [image] Copy Code

Public Overrides Function ConvertFrom( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object _
) As Object

Parameters

context
An ITypeDescriptorContext that provides a format context.
culture
The CultureInfo to use as the current culture.
value
The Object to convert.

Return Value

See Also

ThicknessConverter Members
ThicknessConverter Class


MindFusion.Diagramming.ThicknessConverter.ConvertTo Method

ThicknessConverter.ConvertTo Method
[image]

TypeConverter.ConvertTo override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Object ConvertTo (
ITypeDescriptorContext context,
CultureInfo culture,
Object value,
Type destinationType
)

Visual Basic [image] Copy Code

Public Overrides Function ConvertTo( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object, _
destinationType As Type _
) As Object

Parameters

context
An ITypeDescriptorContext that provides a format context.
culture
A CultureInfo. If null is passed, the current culture is assumed.
value
The Object to convert.
destinationType
An Object that represents the converted value.

Return Value

See Also

ThicknessConverter Members
ThicknessConverter Class


MindFusion.Diagramming.TimerEventArgs Class

TimerEventArgs Class
[image]

Contains the arguments passed to timer-related event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TimerEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class TimerEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.TimerEventArgs

See Also

TimerEventArgs Members


MindFusion.Diagramming.TimerEventArgs Members

TimerEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to timer-related event handlers.

The following tables list the members exposed by the TimerEventArgs type.

Public Constructors

Name | Description
TimerEventArgs | Overloaded.

Public Properties

Name | Description
Handler | Gets the tick handler of the timer when a new timer is requested.
Interval | Gets the timer interval when a new timer is requested.
IsHandled | Gets or sets a value indicating whether the event is handled.
IsStart | Gets a value indicating whether a new timer is being created or an existing timer is being stopped.
Timer | Gets or sets the timer related to the operation.

See Also

TimerEventArgs Class


MindFusion.Diagramming.TimerEventArgs Constructor

TimerEventArgs Constructor
[image]

Overload List

Name | Description
TimerEventArgs (Int32, EventHandler) | Initializes a new instance of the TimerEventArgs class.
TimerEventArgs (Object) | Initializes a new instance of the TimerEventArgs class.

See Also

TimerEventArgs Class


MindFusion.Diagramming.TimerEventArgs Constructor (Int32, EventHandler)

TimerEventArgs Constructor (Int32, EventHandler)
See Also
[image]

Initializes a new instance of the TimerEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TimerEventArgs (
int interval,
EventHandler handler
)

Visual Basic [image] Copy Code

Public New ( _
interval As Integer, _
handler As EventHandler _
)

Parameters

interval

handler

See Also

TimerEventArgs Constructor Overload List
TimerEventArgs Class


MindFusion.Diagramming.TimerEventArgs Constructor (Object)

TimerEventArgs Constructor (Object)
See Also
[image]

Initializes a new instance of the TimerEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TimerEventArgs (
Object timer
)

Visual Basic [image] Copy Code

Public New ( _
timer As Object _
)

Parameters

timer

See Also

TimerEventArgs Constructor Overload List
TimerEventArgs Class


MindFusion.Diagramming.TimerEventArgs Properties

TimerEventArgs Properties
[image]

Public Properties

Name | Description
Handler | Gets the tick handler of the timer when a new timer is requested.
Interval | Gets the timer interval when a new timer is requested.
IsHandled | Gets or sets a value indicating whether the event is handled.
IsStart | Gets a value indicating whether a new timer is being created or an existing timer is being stopped.
Timer | Gets or sets the timer related to the operation.

See Also

TimerEventArgs Class


MindFusion.Diagramming.TimerEventArgs.Handler Property

TimerEventArgs.Handler Property
[image]

Gets the tick handler of the timer when a new timer is requested.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public EventHandler Handler { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Handler As EventHandler

Property Value

See Also

TimerEventArgs Members
TimerEventArgs Class


MindFusion.Diagramming.TimerEventArgs.Interval Property

TimerEventArgs.Interval Property
[image]

Gets the timer interval when a new timer is requested.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Interval { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Interval As Integer

Property Value

See Also

TimerEventArgs Members
TimerEventArgs Class


MindFusion.Diagramming.TimerEventArgs.IsHandled Property

TimerEventArgs.IsHandled Property
[image]

Gets or sets a value indicating whether the event is handled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsHandled { get; set; }

Visual Basic [image] Copy Code

Public Property IsHandled As Boolean

Property Value

See Also

TimerEventArgs Members
TimerEventArgs Class


MindFusion.Diagramming.TimerEventArgs.IsStart Property

TimerEventArgs.IsStart Property
[image]

Gets a value indicating whether a new timer is being created or an existing timer is being stopped.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsStart { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsStart As Boolean

Property Value

See Also

TimerEventArgs Members
TimerEventArgs Class


MindFusion.Diagramming.TimerEventArgs.Timer Property

TimerEventArgs.Timer Property
[image]

Gets or sets the timer related to the operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Timer { get; set; }

Visual Basic [image] Copy Code

Public Property Timer As Object

Property Value

See Also

TimerEventArgs Members
TimerEventArgs Class


MindFusion.Diagramming.TreeEnumerator Class

TreeEnumerator Class
Remarks See Also
[image]

Enables an easy standard method to iterate over the elements of a tree-like structure of objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TreeEnumerator : IEnumerator

Visual Basic [image] Copy Code

Public Class TreeEnumerator
Implements IEnumerator

Remarks

The TreeEnumerator class implements the standard .NET IEnumerator interface. It provides an easy method to iterate over the elements of a tree-like structure of diagram items.

Example

The following example demonstrates how to use the TreeEnumerator:

C# [image] Copy Code

TreeEnumerator te = new TreeEnumerator(
rootObj, false, false);

while (te.MoveNext())
{
ShapeNode node = (ShapeNode)te.Current;
node.Brush = new SolidBrush(Color.Blue);
}

Visual Basic [image] Copy Code

Dim te As MindFusion.Diagramming.TreeEnumerator = New MindFusion.Diagramming.TreeEnumerator( _
rootObj, False, False)

While te.MoveNext()
Dim node As ShapeNode = CType(te.Current, ShapeNode)
Node.Brush = New SolidBrush(Color.Blue)
End While

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.TreeEnumerator

See Also

TreeEnumerator Members


MindFusion.Diagramming.TreeEnumerator Members

TreeEnumerator Members
Constructors Properties Methods
[image]

Enables an easy standard method to iterate over the elements of a tree-like structure of objects.

The following tables list the members exposed by the TreeEnumerator type.

Public Constructors

Name | Description
TreeEnumerator | Initializes a new instance of the TreeEnumerator class.

Public Properties

Name | Description
Current | Gets the current element of the iteration.

Public Methods

Name | Description
MoveNext | Advances the enumerator to the next element of the tree.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.

See Also

TreeEnumerator Class


MindFusion.Diagramming.TreeEnumerator Constructor

TreeEnumerator Constructor
[image]

Initializes a new instance of the TreeEnumerator class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeEnumerator (
DiagramNode root,
bool enumLinks,
bool strict
)

Visual Basic [image] Copy Code

Public Sub TreeEnumerator ( _
root As DiagramNode, _
enumLinks As Boolean, _
strict As Boolean _
)

Parameters

root
The root of the tree or subtree to be enumerated.
enumLinks
Specifies whether to enumerate links.
strict

Specifies whether to check strictly if the passed structure is a tree. If this option is enabled, NotATreeException will be thrown if a cycle or multiple links to a node are encountered. If the option is disabled, the enumerator will ignore any cycles or multiple links found and continue the iteration.

See Also

TreeEnumerator Class


MindFusion.Diagramming.TreeEnumerator Methods

TreeEnumerator Methods
[image]

Public Methods

Name | Description
MoveNext | Advances the enumerator to the next element of the tree.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.

See Also

TreeEnumerator Class


MindFusion.Diagramming.TreeEnumerator.MoveNext Method

TreeEnumerator.MoveNext Method
[image]

Advances the enumerator to the next element of the tree.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool MoveNext ()

Visual Basic [image] Copy Code

Public Function MoveNext () As Boolean

Return Value

true if the enumerator has successfully passed to the next DiagramItem in the collection; false if there are no more elements available to enumerate.

Remarks

Initially an enumerator is positioned before the first element of the tree (the root), and the first call to MoveNext moves the enumerator over that first element.

See Also

TreeEnumerator Members
TreeEnumerator Class


MindFusion.Diagramming.TreeEnumerator.Reset Method

TreeEnumerator.Reset Method
[image]

Sets the enumerator to its initial position, which is before the first element in the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Reset ()

Visual Basic [image] Copy Code

Public Sub Reset ()

See Also

TreeEnumerator Members
TreeEnumerator Class


MindFusion.Diagramming.TreeEnumerator Properties

TreeEnumerator Properties
[image]

Public Properties

Name | Description
Current | Gets the current element of the iteration.

See Also

TreeEnumerator Class


MindFusion.Diagramming.TreeEnumerator.Current Property

TreeEnumerator.Current Property
[image]

Gets the current element of the iteration.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Current { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Current As Object

Property Value

The DiagramItem that is current in the enumeration.

Remarks

If the enumLinks constructor argument is set to false, only nodes are enumerated. After an enumerator is created or after a Reset, MoveNext must be called to advance the enumerator to the first element before reading the value of Current; otherwise, Current is undefined.

See Also

TreeEnumerator Members
TreeEnumerator Class


MindFusion.Diagramming.TreeItemEventArgs Class

TreeItemEventArgs Class
[image]

Contains the arguments passed to handlers of TreeViewItem-related events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TreeItemEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class TreeItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.TreeItemEventArgs
MindFusion.Diagramming.TreeItemValidationEventArgs

See Also

TreeItemEventArgs Members


MindFusion.Diagramming.TreeItemEventArgs Members

TreeItemEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to handlers of TreeViewItem-related events.

The following tables list the members exposed by the TreeItemEventArgs type.

Public Constructors

Name | Description
TreeItemEventArgs | Initializes a new instance of the TreeItemEventArgs class.

Public Properties

Name | Description
Item | Get the item for which the event is raised.
MouseButton | Gets which mouse button has been pressed.
MousePosition | Gets the current mouse pointer position.

See Also

TreeItemEventArgs Class


MindFusion.Diagramming.TreeItemEventArgs Constructor

TreeItemEventArgs Constructor
[image]

Initializes a new instance of the TreeItemEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeItemEventArgs (
TreeViewItem item,
MouseButton mouseButton,
PointF mousePosition
)

Visual Basic [image] Copy Code

Public New ( _
item As TreeViewItem, _
mouseButton As MouseButton, _
mousePosition As PointF _
)

Parameters

item
The TreeViewItem related to the event.
mouseButton

The mouse button related to the event.

mousePosition

The position of the mouse at the time the event was raised.

See Also

TreeItemEventArgs Class


MindFusion.Diagramming.TreeItemEventArgs Properties

TreeItemEventArgs Properties
[image]

Public Properties

Name | Description
Item | Get the item for which the event is raised.
MouseButton | Gets which mouse button has been pressed.
MousePosition | Gets the current mouse pointer position.

See Also

TreeItemEventArgs Class


MindFusion.Diagramming.TreeItemEventArgs.Item Property

TreeItemEventArgs.Item Property
[image]

Get the item for which the event is raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As TreeViewItem

Property Value

See Also

TreeItemEventArgs Members
TreeItemEventArgs Class


MindFusion.Diagramming.TreeItemEventArgs.MouseButton Property

TreeItemEventArgs.MouseButton Property
[image]

Gets which mouse button has been pressed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MouseButton MouseButton { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MouseButton As MouseButton

Property Value

See Also

TreeItemEventArgs Members
TreeItemEventArgs Class


MindFusion.Diagramming.TreeItemEventArgs.MousePosition Property

TreeItemEventArgs.MousePosition Property
[image]

Gets the current mouse pointer position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointF MousePosition { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MousePosition As PointF

Property Value

See Also

TreeItemEventArgs Members
TreeItemEventArgs Class


MindFusion.Diagramming.TreeItemValidationEventArgs Class

TreeItemValidationEventArgs Class
[image]

Contains the arguments passed to event handlers, such as TreeItemTextEditing.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TreeItemValidationEventArgs : TreeItemEventArgs

Visual Basic [image] Copy Code

Public Class TreeItemValidationEventArgs
Inherits TreeItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.TreeItemEventArgs
MindFusion.Diagramming.TreeItemValidationEventArgs

See Also

TreeItemValidationEventArgs Members


MindFusion.Diagramming.TreeItemValidationEventArgs Members

TreeItemValidationEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to event handlers, such as TreeItemTextEditing.

The following tables list the members exposed by the TreeItemValidationEventArgs type.

Public Constructors

Name | Description
TreeItemValidationEventArgs | Initializes a new instance of the TreeItemValidationEventArgs class.

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to prevent the user from completing the operation.
Item | Get the item for which the event is raised. (Inherited from TreeItemEventArgs.)
MouseButton | Gets which mouse button has been pressed. (Inherited from TreeItemEventArgs.)
MousePosition | Gets the current mouse pointer position. (Inherited from TreeItemEventArgs.)

See Also

TreeItemValidationEventArgs Class


MindFusion.Diagramming.TreeItemValidationEventArgs Constructor

TreeItemValidationEventArgs Constructor
[image]

Initializes a new instance of the TreeItemValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeItemValidationEventArgs (
TreeViewItem item,
MouseButton mouseButton,
PointF mousePosition
)

Visual Basic [image] Copy Code

Public New ( _
item As TreeViewItem, _
mouseButton As MouseButton, _
mousePosition As PointF _
)

Parameters

item
The TreeViewItem related to the event.
mouseButton

The mouse button related to the event.

mousePosition

The position of the mouse at the time the event was raised.

See Also

TreeItemValidationEventArgs Class


MindFusion.Diagramming.TreeItemValidationEventArgs Properties

TreeItemValidationEventArgs Properties
[image]

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to prevent the user from completing the operation.
Item | Get the item for which the event is raised. (Inherited from TreeItemEventArgs.)
MouseButton | Gets which mouse button has been pressed. (Inherited from TreeItemEventArgs.)
MousePosition | Gets the current mouse pointer position. (Inherited from TreeItemEventArgs.)

See Also

TreeItemValidationEventArgs Class


MindFusion.Diagramming.TreeItemValidationEventArgs.Cancel Property

TreeItemValidationEventArgs.Cancel Property
[image]

Gets or sets a value indicating whether to prevent the user from completing the operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

See Also

TreeItemValidationEventArgs Members
TreeItemValidationEventArgs Class


MindFusion.Diagramming.TreeViewConnectionPoint Class

TreeViewConnectionPoint Class
[image]

Represents a connection between a link and a TreeViewNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TreeViewConnectionPoint : ConnectionPoint

Visual Basic [image] Copy Code

Public Class TreeViewConnectionPoint
Inherits ConnectionPoint

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ConnectionPoint
MindFusion.Diagramming.TreeViewConnectionPoint

See Also

TreeViewConnectionPoint Members


MindFusion.Diagramming.TreeViewConnectionPoint Members

TreeViewConnectionPoint Members
Constructors Properties Methods
[image]

Represents a connection between a link and a TreeViewNode.

The following tables list the members exposed by the TreeViewConnectionPoint type.

Public Constructors

Name | Description
TreeViewConnectionPoint | Overloaded.

Public Properties

Name | Description
RelativePosition | Gets or sets the position of this connection point, relative to the associated node's bounding rectangle, expressed in percents. (Inherited from ConnectionPoint.)
Row | ConnectionPoint.Row override.

Protected Properties

Name | Description
Incoming | Gets a flag indicating whether this connection point is at the origin or the destination of the associated link. (Inherited from ConnectionPoint.)
Link | Gets the link associated with this connection point. (Inherited from ConnectionPoint.)
Node | Gets the node associated with this connection point. (Inherited from ConnectionPoint.)

Public Methods

Name | Description
AddLinkToNode | ConnectionPoint.AddLinkToNode override.
CalculateIntersections | Determines whether the end of a link should be aligned to the point where the node contour is intersected by the line connecting the centers of the connected nodes. (Inherited from ConnectionPoint.)
CanMoveLink | Checks whether the specified point, expressed in document coordinates, is a valid location for this connection point. (Inherited from ConnectionPoint.)
GetAnchorPos | Overloaded. (Inherited from ConnectionPoint.)
GetEndPoint | ConnectionPoint.GetEndPoint override.
GetInitialPoint | ConnectionPoint.GetInitialPoint override.
GetIntersection | ConnectionPoint.GetIntersection override.
GetNodeRect | Returns the bounding rectangle of the node associated with this connection point. (Inherited from ConnectionPoint.)
LinkChanges | ConnectionPoint.LinkChanges override.
NearestAnchorPoint | Returns the anchor point closest to the specified point from the node's associated anchor pattern. (Inherited from ConnectionPoint.)
NodesIntersect | Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect. (Inherited from ConnectionPoint.)
RemoveLinkFromNode | ConnectionPoint.RemoveLinkFromNode override.
SameNode | Checks whether the current connection point and the specified connection point are associated with the same node. (Inherited from ConnectionPoint.)
SaveEndRelative | ConnectionPoint.SaveEndRelative override.

Protected Methods

Name | Description
GetClassId | Returns unique id number for this class.
GetNearestBorderPoint | ConnectionPoint.GetNearestBorderPoint override.
LoadFrom | Deserializes the object from the specified reader.
SaveTo | Serializes the object to the specified writer.
SetReference | ConnectionPoint.SetReference override.
UpdateFromPoint | Updates the connection stated according to the specified point, without changing the related node.

See Also

TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint Constructor

TreeViewConnectionPoint Constructor
[image]

Overload List

Name | Description
TreeViewConnectionPoint () | Initializes a new instance of the TreeViewConnectionPoint class.
TreeViewConnectionPoint (TreeViewNode, DiagramLink, Boolean, TreeViewItem) | Initializes a new instance of the TreeViewConnectionPoint class.

See Also

TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint Constructor ()

TreeViewConnectionPoint Constructor ()
See Also
[image]

Initializes a new instance of the TreeViewConnectionPoint class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewConnectionPoint ()

Visual Basic [image] Copy Code

Public Sub New ()

Remarks

This constructor is used only during deserialization.

See Also

TreeViewConnectionPoint Constructor Overload List
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint Constructor (TreeViewNode, DiagramLink, Boolean, TreeViewItem)

TreeViewConnectionPoint Constructor (TreeViewNode, DiagramLink, Boolean, TreeViewItem)
See Also
[image]

Initializes a new instance of the TreeViewConnectionPoint class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewConnectionPoint (
TreeViewNode node,
DiagramLink link,
bool incoming,
TreeViewItem item
)

Visual Basic [image] Copy Code

Public New ( _
node As TreeViewNode, _
link As DiagramLink, _
incoming As Boolean, _
item As TreeViewItem _
)

Parameters

node
A TreeViewNode instance.
link
A DiagramLink instance.
incoming
Specifies which end of the link is represented by this TreeViewConnectionPoint.
item
The TreeViewItem to which the link connects.

See Also

TreeViewConnectionPoint Constructor Overload List
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint Methods

TreeViewConnectionPoint Methods
[image]

Public Methods

Name | Description
AddLinkToNode | ConnectionPoint.AddLinkToNode override.
CalculateIntersections | Determines whether the end of a link should be aligned to the point where the node contour is intersected by the line connecting the centers of the connected nodes. (Inherited from ConnectionPoint.)
CanMoveLink | Checks whether the specified point, expressed in document coordinates, is a valid location for this connection point. (Inherited from ConnectionPoint.)
GetAnchorPos | Overloaded. (Inherited from ConnectionPoint.)
GetEndPoint | ConnectionPoint.GetEndPoint override.
GetInitialPoint | ConnectionPoint.GetInitialPoint override.
GetIntersection | ConnectionPoint.GetIntersection override.
GetNodeRect | Returns the bounding rectangle of the node associated with this connection point. (Inherited from ConnectionPoint.)
LinkChanges | ConnectionPoint.LinkChanges override.
NearestAnchorPoint | Returns the anchor point closest to the specified point from the node's associated anchor pattern. (Inherited from ConnectionPoint.)
NodesIntersect | Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect. (Inherited from ConnectionPoint.)
RemoveLinkFromNode | ConnectionPoint.RemoveLinkFromNode override.
SameNode | Checks whether the current connection point and the specified connection point are associated with the same node. (Inherited from ConnectionPoint.)
SaveEndRelative | ConnectionPoint.SaveEndRelative override.

Protected Methods

Name | Description
GetClassId | Returns unique id number for this class.
GetNearestBorderPoint | ConnectionPoint.GetNearestBorderPoint override.
LoadFrom | Deserializes the object from the specified reader.
SaveTo | Serializes the object to the specified writer.
SetReference | ConnectionPoint.SetReference override.
UpdateFromPoint | Updates the connection stated according to the specified point, without changing the related node.

See Also

TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.AddLinkToNode Method

TreeViewConnectionPoint.AddLinkToNode Method
[image]

ConnectionPoint.AddLinkToNode override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void AddLinkToNode ()

Visual Basic [image] Copy Code

Public Overrides Sub AddLinkToNode ()

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.GetClassId Method

TreeViewConnectionPoint.GetClassId Method
[image]

Returns unique id number for this class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override int GetClassId ()

Visual Basic [image] Copy Code

Protected Overrides Function GetClassId () As Integer

Return Value

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.GetEndPoint Method

TreeViewConnectionPoint.GetEndPoint Method
[image]

ConnectionPoint.GetEndPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override PointF GetEndPoint ()

Visual Basic [image] Copy Code

Public Overrides Function GetEndPoint () As PointF

Return Value

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.GetInitialPoint Method

TreeViewConnectionPoint.GetInitialPoint Method
[image]

ConnectionPoint.GetInitialPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override PointF GetInitialPoint ()

Visual Basic [image] Copy Code

Public Overrides Function GetInitialPoint () As PointF

Return Value

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.GetIntersection Method

TreeViewConnectionPoint.GetIntersection Method
[image]

ConnectionPoint.GetIntersection override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override PointF GetIntersection (
PointF pt1,
PointF pt2
)

Visual Basic [image] Copy Code

Public Overrides Function GetIntersection( _
pt1 As PointF, _
pt2 As PointF _
) As PointF

Parameters

pt1

pt2

Return Value

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.GetNearestBorderPoint Method

TreeViewConnectionPoint.GetNearestBorderPoint Method
[image]

ConnectionPoint.GetNearestBorderPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override PointF GetNearestBorderPoint (
PointF point
)

Visual Basic [image] Copy Code

Protected Overrides Function GetNearestBorderPoint( _
point As PointF _
) As PointF

Parameters

point

Return Value

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.LinkChanges Method

TreeViewConnectionPoint.LinkChanges Method
[image]

ConnectionPoint.LinkChanges override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool LinkChanges (
DiagramItem item,
PointF point
)

Visual Basic [image] Copy Code

Public Overrides Function LinkChanges ( _
item As DiagramItem, _
point As PointF _
) As Boolean

Parameters

item

point

Return Value

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.LoadFrom Method

TreeViewConnectionPoint.LoadFrom Method
[image]

Deserializes the object from the specified reader.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFrom (
BinaryReader reader,
PersistContext ctx
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFrom ( _
reader As BinaryReader, _
ctx As PersistContext _
)

Parameters

reader

ctx

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.RemoveLinkFromNode Method

TreeViewConnectionPoint.RemoveLinkFromNode Method
[image]

ConnectionPoint.RemoveLinkFromNode override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void RemoveLinkFromNode ()

Visual Basic [image] Copy Code

Public Overrides Sub RemoveLinkFromNode ()

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.SaveEndRelative Method

TreeViewConnectionPoint.SaveEndRelative Method
[image]

ConnectionPoint.SaveEndRelative override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void SaveEndRelative ()

Visual Basic [image] Copy Code

Public Overrides Sub SaveEndRelative ()

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.SaveTo Method

TreeViewConnectionPoint.SaveTo Method
[image]

Serializes the object to the specified writer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveTo (
BinaryWriter writer,
PersistContext ctx
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveTo ( _
writer As BinaryWriter, _
ctx As PersistContext _
)

Parameters

writer

ctx

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.SetReference Method

TreeViewConnectionPoint.SetReference Method
[image]

ConnectionPoint.SetReference override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SetReference (
int refId,
Object obj
)

Visual Basic [image] Copy Code

Protected Overrides Sub SetReference( _
refId As Integer, _
obj As Object _
)

Parameters

refId

obj

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.UpdateFromPoint Method

TreeViewConnectionPoint.UpdateFromPoint Method
[image]

Updates the connection stated according to the specified point, without changing the related node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void UpdateFromPoint (
PointF point
)

Visual Basic [image] Copy Code

Protected Overrides Sub UpdateFromPoint( _
point As PointF _
)

Parameters

point

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint Properties

TreeViewConnectionPoint Properties
[image]

Public Properties

Name | Description
RelativePosition | Gets or sets the position of this connection point, relative to the associated node's bounding rectangle, expressed in percents. (Inherited from ConnectionPoint.)
Row | ConnectionPoint.Row override.

Protected Properties

Name | Description
Incoming | Gets a flag indicating whether this connection point is at the origin or the destination of the associated link. (Inherited from ConnectionPoint.)
Link | Gets the link associated with this connection point. (Inherited from ConnectionPoint.)
Node | Gets the node associated with this connection point. (Inherited from ConnectionPoint.)

See Also

TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.Row Property

TreeViewConnectionPoint.Row Property
[image]

ConnectionPoint.Row override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override int Row { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Row As Integer

Property Value

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionStyle Enumeration

TreeViewConnectionStyle Enumeration
[image]

Specifies the possible values for the ConnectionStyle property of TreeViewNode objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum TreeViewConnectionStyle

Visual Basic [image] Copy Code

Public Enum TreeViewConnectionStyle

Members

Member name | Description
Node | Users are allowed to create relations to the TreeViewNode as an integral entity.
Items | Users are allowed to create relations to the items of a TreeViewNode.

See Also


MindFusion.Diagramming.TreeViewItem Class

TreeViewItem Class
Remarks See Also
[image]

Represents a constituent item of the hierarchy displayed inside a TreeViewNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TreeViewItem : INotifyPropertyChanged, IPersists, InplaceEditable

Visual Basic [image] Copy Code

Public Class TreeViewItem
Implements INotifyPropertyChanged, IPersists, InplaceEditable

Remarks

The items of a TreeViewNode can be traversed recursively starting from the node's RootItems. Given an item, you can find its parent and child items by means of the Parent and Children properties.

If the ConnectionStyle of a node is set to Items, links connect to specific items of the node. Such links can be accessed by means of the IncomingLinks and OutgoingLinks collections.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.TreeViewItem

See Also

TreeViewItem Members


MindFusion.Diagramming.TreeViewItem Members

TreeViewItem Members
Constructors Properties Events
[image]

Represents a constituent item of the hierarchy displayed inside a TreeViewNode.

The following tables list the members exposed by the TreeViewItem type.

Public Constructors

Name | Description
TreeViewItem | Overloaded. Initializes a new instance of the TreeViewItem class.

Public Properties

Name | Description
Children | Gets a list of this item's children in the hierarchy.
Expanded | Gets or sets whether this item is expanded to show its children.
Height | Gets or sets the height of this item.
Image | Gets or sets the image that is displayed in this treeview item.
IncomingLinks | Gets a collection of all links that point to this item.
Label | Gets or sets the label of this item.
LabelBrush | Gets or sets the brush used to draw the label of this item.
LabelFont | Gets or sets the label font of this item.
OutgoingLinks | Gets a collection of all links that go out of this item.
Parent | Gets the parent item of this item.
Tag | Gets or sets custom data associated with this item.

Public Events

Name | Description
PropertyChanged | Implements INotifyPropertyChanged.PropertyChanged.

See Also

TreeViewItem Class


MindFusion.Diagramming.TreeViewItem Constructor

TreeViewItem Constructor
[image]

Initializes a new instance of the TreeViewItem class.

Overload List

Name | Description
TreeViewItem () | Initializes a new instance of the TreeViewItem class.
TreeViewItem (String) | Initializes a new instance of the TreeViewItem class.
TreeViewItem (TreeViewItem) | Initializes a new instance of the TreeViewItem class using the specified item as a prototype.

See Also

TreeViewItem Class


MindFusion.Diagramming.TreeViewItem Constructor ()

TreeViewItem Constructor ()
See Also
[image]

Initializes a new instance of the TreeViewItem class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewItem ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TreeViewItem Constructor Overload List
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem Constructor (String)

TreeViewItem Constructor (String)
See Also
[image]

Initializes a new instance of the TreeViewItem class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewItem (
string label
)

Visual Basic [image] Copy Code

Public New ( _
label As String _
)

Parameters

label
The text initially displayed by the item.

See Also

TreeViewItem Constructor Overload List
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem Constructor (TreeViewItem)

TreeViewItem Constructor (TreeViewItem)
See Also
[image]

Initializes a new instance of the TreeViewItem class using the specified item as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewItem (
TreeViewItem prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As TreeViewItem _
)

Parameters

prototype

The treeview item to use as a prototype. The properties of the new treeview are initialized from the property values of prototype.

Remarks

This constructor copies the TreeViewItem property values from the specified prototype item.

See Also

TreeViewItem Constructor Overload List
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem Properties

TreeViewItem Properties
[image]

Public Properties

Name | Description
Children | Gets a list of this item's children in the hierarchy.
Expanded | Gets or sets whether this item is expanded to show its children.
Height | Gets or sets the height of this item.
Image | Gets or sets the image that is displayed in this treeview item.
IncomingLinks | Gets a collection of all links that point to this item.
Label | Gets or sets the label of this item.
LabelBrush | Gets or sets the brush used to draw the label of this item.
LabelFont | Gets or sets the label font of this item.
OutgoingLinks | Gets a collection of all links that go out of this item.
Parent | Gets the parent item of this item.
Tag | Gets or sets custom data associated with this item.

See Also

TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.Children Property

TreeViewItem.Children Property
[image]

Gets a list of this item's children in the hierarchy.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IList<TreeViewItem> Children { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Children As IList(Of TreeViewItem)

Property Value

A list of child TreeViewItem objects.

See Also

TreeViewItem Members
TreeViewItem Class
Parent Property


MindFusion.Diagramming.TreeViewItem.Expanded Property

TreeViewItem.Expanded Property
[image]

Gets or sets whether this item is expanded to show its children.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Expanded { get; set; }

Visual Basic [image] Copy Code

Public Property Expanded As Boolean

Property Value

true to show the children of this item, otherwise false; the default value is true.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.Height Property

TreeViewItem.Height Property
[image]

Gets or sets the height of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Single

Property Value

A float value specifying the item's height. The default value is 5.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.Image Property

TreeViewItem.Image Property
[image]

Gets or sets the image that is displayed in this treeview item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Image Image { get; set; }

Visual Basic [image] Copy Code

Public Property Image As Image

Property Value

An instance of the System.Drawing.Image class.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.IncomingLinks Property

TreeViewItem.IncomingLinks Property
[image]

Gets a collection of all links that point to this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection IncomingLinks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IncomingLinks As DiagramLinkCollection

Property Value

An instance of the DiagramLinkCollection class.

Remarks

The property returns a collection of all links that point to this item. Use it to access the links or get their number.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.Label Property

TreeViewItem.Label Property
[image]

Gets or sets the label of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Label { get; set; }

Visual Basic [image] Copy Code

Public Property Label As String

Property Value

A string specifying the item's label.

See Also

TreeViewItem Members
TreeViewItem Class
MindFusion.Diagramming Namespace
LabelBrush Property
LabelFont Property
TreeViewNode.ResizeToFitText Method


MindFusion.Diagramming.TreeViewItem.LabelBrush Property

TreeViewItem.LabelBrush Property
[image]

Gets or sets the brush used to draw the label of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush LabelBrush { get; set; }

Visual Basic [image] Copy Code

Public Property LabelBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class. The default value is null (Nothing in Visual Basic).

Remarks

It this property is set to null, the label is rendered using the TextBrush value of the parent node.

See Also

TreeViewItem Members
TreeViewItem Class
MindFusion.Diagramming Namespace
Label Property
LabelFont Property


MindFusion.Diagramming.TreeViewItem.LabelFont Property

TreeViewItem.LabelFont Property
[image]

Gets or sets the label font of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Font LabelFont { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFont As Font

Property Value

An instance of the .NET Font class. The default value is null (Nothing in Visual Basic).

Remarks

It this property is set to null, the label is rendered using the Font of the parent node.

See Also

TreeViewItem Members
TreeViewItem Class
MindFusion.Diagramming Namespace
Label Property
LabelBrush Property


MindFusion.Diagramming.TreeViewItem.OutgoingLinks Property

TreeViewItem.OutgoingLinks Property
[image]

Gets a collection of all links that go out of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection OutgoingLinks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OutgoingLinks As DiagramLinkCollection

Property Value

An instance of the DiagramLinkCollection class.

Remarks

The property returns a collection of all links that start from this item. Use it to access the links or get their number.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.Parent Property

TreeViewItem.Parent Property
[image]

Gets the parent item of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewItem Parent { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Parent As TreeViewItem

Property Value

A TreeViewItem instance.

See Also

TreeViewItem Members
TreeViewItem Class
Children Property


MindFusion.Diagramming.TreeViewItem.Tag Property

TreeViewItem.Tag Property
[image]

Gets or sets custom data associated with this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An instance of any class derived from System.Object. The default value is null (Nothing in Visual Basic).

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem Events

TreeViewItem Events
[image]

Public Events

Name | Description
PropertyChanged | Implements INotifyPropertyChanged.PropertyChanged.

See Also

TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.PropertyChanged Event

TreeViewItem.PropertyChanged Event
[image]

Implements INotifyPropertyChanged.PropertyChanged.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewNode Class

TreeViewNode Class
Remarks See Also
[image]

Represents nodes that can draw hierarchical data.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TreeViewNode : DiagramNode, InplaceEditable

Visual Basic [image] Copy Code

Public Class TreeViewNode
Inherits DiagramNode
Implements InplaceEditable

Remarks

The root items displayed in the node can be accessed through the RootItems property. New items can be added to and removed from the returned collection. The root items can have child items on their own and so on. For more information, refer to the TreeViewItem class.

The text and image displayed in the node caption can be customized through the Caption and CaptionImage properties respectively. The scroll position can be manipulated through ScrollPosition.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.TreeViewNode

See Also

TreeViewNode Members


MindFusion.Diagramming.TreeViewNode Members

TreeViewNode Members
Constructors Fields Properties Methods
[image]

Represents nodes that can draw hierarchical data.

The following tables list the members exposed by the TreeViewNode type.

Public Constructors

Name | Description
TreeViewNode | Overloaded. Initializes a new instance of the TreeViewNode class.

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Caption | Gets or sets the text displayed as caption of the node.
CaptionHeight | Gets or sets the height of the node's caption area.
CaptionImage | Gets or sets the image that is displayed in the caption.
ConnectionStyle | Gets or sets a value indicating whether drawing a link from/to this node should connect an item or the whole node as an integral entity.
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
EnableStyledText | Gets or sets a value indicating whether styled text rendering is enabled.
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Font | Gets or sets the font used to render the node's caption.
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RootItems | Gets a list of the root TreeViewItem objects displayed in this node.
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
ScrollPosition | Gets or sets the current scroll position.
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Shape | Gets or sets the shape of the table's outline.
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextFormat | Gets or sets the alignment of texts displayed inside this shape node.
TextPadding | Gets or sets the spacing between the item boundaries and its text.
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | DiagramNode.HasItems override.
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

Public Methods

Name | Description
AcceptLinks | DiagramNode.AcceptLinks override.
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
DoModify | For internal use. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. Renders the adjustment handles of this item. (Inherited from DiagramNode.)
DrawLocal | Draws the node on the specified IGraphics surface.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | Override in a derived class to provide implementation specific drawing for the shadow of the node. (Inherited from DiagramNode.)
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item. (Inherited from DiagramItem.)
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item. (Inherited from DiagramItem.)
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item. (Inherited from DiagramItem.)
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item. (Inherited from DiagramItem.)
GetFlatItemList | Gets a list with all items of this node.
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetItemRect | Gets the location and size of the specified TreeViewItem.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTest | Returns the type of graphics element at the specified coordinates.
HitTestExpander | Gets whether there is a collapse/expand button located at the specified position.
HitTestHandle | DiagramItem.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point. (Inherited from DiagramNode.)
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Intersects | Determines whether the node intersects another one, taking into account the outlines of node shapes. (Inherited from DiagramNode.)
ItemFromPoint | Returns the item at the specified location.
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | DiagramItem.OnLoad override.
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RemoveItem | Removes the specified item from the node.
Resize | Resizes the node. (Inherited from DiagramNode.)
ResizeToFitText | Resizes the tree view so that it is large enough to fit the text of its items.
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetPos | Sets the bounding rectangle of this node without updating connected arrows. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
CancelModify | DiagramItem.CancelModify override. Invoked when the interactive modification of this object has been canceled. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Checks whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
Finalize | DiagramItem finalizer. (Inherited from DiagramItem.)
FreeResources | Called when the node is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramNode.)
GetAllIncomingLinks | DiagramNode.GetAllIncomingLinks override.
GetAllOutgoingLinks | DiagramNode.GetAllOutgoingLinks override.
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from DiagramNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the item content from an XML element.
LoadObsolete | For internal use. (Inherited from DiagramItem.)
OnAdd | DiagramItem.OnAdd override. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnClick | DiagramNode.OnClick override.
OnDoubleClick | Invoked when the user double-clicks this item. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes.
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | DiagramItem.OnStyleChanged override.
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the Diagram's ZoomFactor changes.
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
ScaleElements | DiagramNode.ScaleElements override.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReference | Called during deserialization, after all objects have been instantiated, in order to update the references between them. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it.
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. Invoked when the user starts modifying this item interactively. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster. (Inherited from DiagramItem.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. Invoked during interactive modification of this item. (Inherited from DiagramNode.)

See Also

TreeViewNode Class


MindFusion.Diagramming.TreeViewNode Constructor

TreeViewNode Constructor
[image]

Initializes a new instance of the TreeViewNode class.

Overload List

Name | Description
TreeViewNode () | Initializes a new instance of the TreeViewNode class.
TreeViewNode (Diagram) | Initializes a new instance of the TreeViewNode class.
TreeViewNode (TreeViewNode) | Initializes a new instance of the TreeViewNode class using the specified node as a prototype.

See Also

TreeViewNode Class


MindFusion.Diagramming.TreeViewNode Constructor ()

TreeViewNode Constructor ()
See Also
[image]

Initializes a new instance of the TreeViewNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewNode ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TreeViewNode Constructor Overload List
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode Constructor (Diagram)

TreeViewNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the TreeViewNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewNode (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram from which to obtain default values for the node properties.

Remarks

This constructor initializes the TreeViewNode properties with the values specified in the respective default-value properties of the Diagram object.

See Also

TreeViewNode Constructor Overload List
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode Constructor (TreeViewNode)

TreeViewNode Constructor (TreeViewNode)
See Also
[image]

Initializes a new instance of the TreeViewNode class using the specified node as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewNode (
TreeViewNode prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As TreeViewNode _
)

Parameters

prototype

The treeview node to use as a prototype. The properties of the new treeview are initialized from the property values of prototype.

Remarks

This constructor copies the TreeViewNode property values from the specified prototype node.

See Also

TreeViewNode Constructor Overload List
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode Methods

TreeViewNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | DiagramNode.AcceptLinks override.
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
DoModify | For internal use. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. Renders the adjustment handles of this item. (Inherited from DiagramNode.)
DrawLocal | Draws the node on the specified IGraphics surface.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | Override in a derived class to provide implementation specific drawing for the shadow of the node. (Inherited from DiagramNode.)
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item. (Inherited from DiagramItem.)
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item. (Inherited from DiagramItem.)
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item. (Inherited from DiagramItem.)
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item. (Inherited from DiagramItem.)
GetFlatItemList | Gets a list with all items of this node.
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetItemRect | Gets the location and size of the specified TreeViewItem.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTest | Returns the type of graphics element at the specified coordinates.
HitTestExpander | Gets whether there is a collapse/expand button located at the specified position.
HitTestHandle | DiagramItem.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point. (Inherited from DiagramNode.)
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Intersects | Determines whether the node intersects another one, taking into account the outlines of node shapes. (Inherited from DiagramNode.)
ItemFromPoint | Returns the item at the specified location.
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | DiagramItem.OnLoad override.
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RemoveItem | Removes the specified item from the node.
Resize | Resizes the node. (Inherited from DiagramNode.)
ResizeToFitText | Resizes the tree view so that it is large enough to fit the text of its items.
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetPos | Sets the bounding rectangle of this node without updating connected arrows. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
CancelModify | DiagramItem.CancelModify override. Invoked when the interactive modification of this object has been canceled. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Checks whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
Finalize | DiagramItem finalizer. (Inherited from DiagramItem.)
FreeResources | Called when the node is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramNode.)
GetAllIncomingLinks | DiagramNode.GetAllIncomingLinks override.
GetAllOutgoingLinks | DiagramNode.GetAllOutgoingLinks override.
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from DiagramNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the item content from an XML element.
LoadObsolete | For internal use. (Inherited from DiagramItem.)
OnAdd | DiagramItem.OnAdd override. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnClick | DiagramNode.OnClick override.
OnDoubleClick | Invoked when the user double-clicks this item. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes.
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | DiagramItem.OnStyleChanged override.
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the Diagram's ZoomFactor changes.
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
ScaleElements | DiagramNode.ScaleElements override.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReference | Called during deserialization, after all objects have been instantiated, in order to update the references between them. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it.
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. Invoked when the user starts modifying this item interactively. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster. (Inherited from DiagramItem.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. Invoked during interactive modification of this item. (Inherited from DiagramNode.)

See Also

TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.AcceptLinks Method

TreeViewNode.AcceptLinks Method
[image]

DiagramNode.AcceptLinks override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool AcceptLinks (
bool outgoing
)

Visual Basic [image] Copy Code

Public Overrides Function AcceptLinks( _
outgoing As Boolean _
) As Boolean

Parameters

outgoing
true to check for outgoing links; otherwise, false.

Return Value

true if the node accepts connections of the specified type; otherwise, false.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.CreateConnectionPoint Method

TreeViewNode.CreateConnectionPoint Method
[image]

DiagramNode.CreateConnectionPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override ConnectionPoint CreateConnectionPoint (
DiagramLink link,
PointF pt,
bool incoming
)

Visual Basic [image] Copy Code

Public Overrides Function CreateConnectionPoint ( _
link As DiagramLink, _
pt As PointF, _
incoming As Boolean _
) As ConnectionPoint

Parameters

link
A DiagramLink that should be connected to this node.
pt

The point at which the link should be connected.

incoming
true if link is an incoming link; otherwise, false.

Return Value

A ConnectionPoint instance representing the connection.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.CreateProperties Method

TreeViewNode.CreateProperties Method
[image]

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramItemProperties CreateProperties ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateProperties () As DiagramItemProperties

Return Value

A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.DrawLocal Method

TreeViewNode.DrawLocal Method
[image]

Draws the node on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawLocal (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawLocal( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

An IGraphics object where the node should be rendered.

options

Provides options for the drawing operation.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.GetAllIncomingLinks Method

TreeViewNode.GetAllIncomingLinks Method
[image]

DiagramNode.GetAllIncomingLinks override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void GetAllIncomingLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Protected Overridable Sub GetAllIncomingLinks ( _
links As DiagramLinkCollection _
)

Parameters

links
A DiagramLinkCollection the links should be added to.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.GetAllOutgoingLinks Method

TreeViewNode.GetAllOutgoingLinks Method
[image]

DiagramNode.GetAllOutgoingLinks override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void GetAllOutgoingLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Protected Overridable Sub GetAllOutgoingLinks ( _
links As DiagramLinkCollection _
)

Parameters

links
A DiagramLinkCollection the links should be added to.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.GetFlatItemList Method

TreeViewNode.GetFlatItemList Method
[image]

Gets a list with all items of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<TreeViewItem> GetFlatItemList ()

Visual Basic [image] Copy Code

Public Function GetFlatItemList () As List(Of TreeViewItem)

Return Value

A list of TreeViewItem objects.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.GetItemRect Method

TreeViewNode.GetItemRect Method
[image]

Gets the location and size of the specified TreeViewItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF GetItemRect (
TreeViewItem treeItem
)

Visual Basic [image] Copy Code

Public Function GetItemRect ( _
treeItem As TreeViewItem _
) As RectangleF

Parameters

treeItem
A TreeViewItem instance.

Return Value

A .NET RectangleF specifying the item's position and size.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.HitTest Method

TreeViewNode.HitTest Method
[image]

Returns the type of graphics element at the specified coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HitTestResult HitTest (
PointF point
)

Visual Basic [image] Copy Code

Public Function HitTest( _
point As PointF _
) As HitTestResult

Parameters

point
A point in the diagram.

Return Value

A member of the HitTestResult enumeration.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.HitTestExpander Method

TreeViewNode.HitTestExpander Method
[image]

Gets whether there is a collapse/expand button located at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool HitTestExpander (
PointF point
)

Visual Basic [image] Copy Code

Public Function HitTestExpander( _
point As PointF _
) As Boolean

Parameters

point

The point to check.

Return Value

true if there is +/- icon at the specified position, otherwise false.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.ItemFromPoint Method

TreeViewNode.ItemFromPoint Method
[image]

Returns the item at the specified location.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewItem ItemFromPoint (
PointF point
)

Visual Basic [image] Copy Code

Public Function ItemFromPoint ( _
point As PointF _
) As TreeViewItem

Parameters

point

The point to check.

Return Value

The TreeViewItem instance that contains the specified point.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.LoadFrom Method

TreeViewNode.LoadFrom Method
[image]

Deserializes the object from the specified reader.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFrom (
BinaryReader reader,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFrom ( _
reader As BinaryReader, _
context As PersistContext _
)

Parameters

reader
A BinaryReader object from which to read the item's data.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.LoadFromXml Method

TreeViewNode.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFromXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement containing the item's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.OnClick Method

TreeViewNode.OnClick Method
[image]

DiagramNode.OnClick override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnClick (
MouseButton mouseButton,
PointF mousePosition
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnClick ( _
mouseButton As MouseButton, _
mousePosition As PointF _
)

Parameters

mouseButton

mousePosition

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.OnLoad Method

TreeViewNode.OnLoad Method
[image]

DiagramItem.OnLoad override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void OnLoad ()

Visual Basic [image] Copy Code

Public Overrides Sub OnLoad ()

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.OnMeasureUnitChanged Method

TreeViewNode.OnMeasureUnitChanged Method
[image]

Called when the Diagram's MeasureUnit changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnMeasureUnitChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnMeasureUnitChanged ()

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.OnStyleChanged Method

TreeViewNode.OnStyleChanged Method
[image]

DiagramItem.OnStyleChanged override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnStyleChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnStyleChanged ()

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.OnUpdateBounds Method

TreeViewNode.OnUpdateBounds Method
[image]

DiagramNode.OnUpdateBounds override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnUpdateBounds (
bool sizeChanged
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnUpdateBounds( _
sizeChanged As Boolean _
)

Parameters

sizeChanged

true if the size has changed; false if only the position has changed.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.OnZoomChanged Method

TreeViewNode.OnZoomChanged Method
[image]

Called when the Diagram's ZoomFactor changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnZoomChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnZoomChanged ()

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.RemoveItem Method

TreeViewNode.RemoveItem Method
[image]

Removes the specified item from the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RemoveItem (
TreeViewItem item
)

Visual Basic [image] Copy Code

Public Sub RemoveItem ( _
item As TreeViewItem _
)

Parameters

item
The TreeViewItem to remove.

Remarks

The method removes the specified item and all its direct or indirect children, as well as the links connecting to them.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.ResizeToFitText Method

TreeViewNode.ResizeToFitText Method
[image]

Resizes the tree view so that it is large enough to fit the text of its items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ResizeToFitText ()

Visual Basic [image] Copy Code

Public Sub ResizeToFitText ()

Remarks

This method also resizes the node vertically so that its height fits all items.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming Namespace
Caption Property
TreeViewItem.Label Property


MindFusion.Diagramming.TreeViewNode.RestoreProperties Method

TreeViewNode.RestoreProperties Method
[image]

DiagramNode.RestoreProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overridable Sub RestoreProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.SaveProperties Method

TreeViewNode.SaveProperties Method
[image]

DiagramNode.SaveProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties-derived object where the item's properties should be saved.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.SaveTo Method

TreeViewNode.SaveTo Method
[image]

Serializes the object to the specified writer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveTo (
BinaryWriter writer,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveTo ( _
writer As BinaryWriter, _
context As PersistContext _
)

Parameters

writer
A BinaryWriter object the item's data should be written to.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.SaveToXml Method

TreeViewNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveToXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement the item's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.ScaleElements Method

TreeViewNode.ScaleElements Method
[image]

DiagramNode.ScaleElements override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void ScaleElements (
float scale
)

Visual Basic [image] Copy Code

Protected Overrides Sub ScaleElements( _
scale As Single _
)

Parameters

scale

The value by which to multiply node elements' sizes.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.SetReflexive Method

TreeViewNode.SetReflexive Method
[image]

Invoked to let a node set the shape of a reflexive link connected to it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SetReflexive (
DiagramLink link
)

Visual Basic [image] Copy Code

Protected Overridable Sub SetReflexive ( _
link As DiagramLink _
)

Parameters

link

Reference to the link.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode Properties

TreeViewNode Properties
[image]

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Caption | Gets or sets the text displayed as caption of the node.
CaptionHeight | Gets or sets the height of the node's caption area.
CaptionImage | Gets or sets the image that is displayed in the caption.
ConnectionStyle | Gets or sets a value indicating whether drawing a link from/to this node should connect an item or the whole node as an integral entity.
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
EnableStyledText | Gets or sets a value indicating whether styled text rendering is enabled.
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Font | Gets or sets the font used to render the node's caption.
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RootItems | Gets a list of the root TreeViewItem objects displayed in this node.
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
ScrollPosition | Gets or sets the current scroll position.
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Shape | Gets or sets the shape of the table's outline.
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextFormat | Gets or sets the alignment of texts displayed inside this shape node.
TextPadding | Gets or sets the spacing between the item boundaries and its text.
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | DiagramNode.HasItems override.
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

See Also

TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.Caption Property

TreeViewNode.Caption Property
[image]

Gets or sets the text displayed as caption of the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Caption { get; set; }

Visual Basic [image] Copy Code

Public Property Caption As String

Property Value

A string specifying the caption text.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.CaptionHeight Property

TreeViewNode.CaptionHeight Property
[image]

Gets or sets the height of the node's caption area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float CaptionHeight { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionHeight As Single

Property Value

A float value specifying the caption area height. The default value is 8.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.CaptionImage Property

TreeViewNode.CaptionImage Property
[image]

Gets or sets the image that is displayed in the caption.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Image CaptionImage { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionImage As Image

Property Value

An instance of the System.Drawing.Image class.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.ConnectionStyle Property

TreeViewNode.ConnectionStyle Property
[image]

Gets or sets a value indicating whether drawing a link from/to this node should connect an item or the whole node as an integral entity.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewConnectionStyle ConnectionStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ConnectionStyle As TreeViewConnectionStyle

Property Value

A member of the TreeViewConnectionStyle enumeration. The default value is Items.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.EnableStyledText Property

TreeViewNode.EnableStyledText Property
[image]

Gets or sets a value indicating whether styled text rendering is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableStyledText { get; set; }

Visual Basic [image] Copy Code

Public Property EnableStyledText As Boolean

Property Value

true to parse the text of the node's caption and items in order to find formatting tags; otherwise false. Initialized with the value of EnableStyledText.

Remarks

Styled text allows applying various attributes to the characters it contains. Attributes are specified using HTML-like formatting tags embedded in the raw text. Formatting tags are listed and described in the Text Attributes and Formatting section of this help file.

If EnableStyledText is set to true, the node's Caption and the items' Label are parsed and analyzed each time they change. Parsing determines what formatting tags are used and adds the corresponding attribute records to MvcDiagram internal representation of styled text. If the property value is false, the text is not processed in any way and is displayed without formatting.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.Font Property

TreeViewNode.Font Property
[image]

Gets or sets the font used to render the node's caption.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Font Font { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Font As Font

Property Value

A .NET Font instance specifying the font attributes.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.HasItems Property

TreeViewNode.HasItems Property
[image]

DiagramNode.HasItems override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override bool HasItems { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property HasItems As Boolean

Property Value

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.RootItems Property

TreeViewNode.RootItems Property
[image]

Gets a list of the root TreeViewItem objects displayed in this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IList<TreeViewItem> RootItems { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RootItems As IList(Of TreeViewItem)

Property Value

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.ScrollPosition Property

TreeViewNode.ScrollPosition Property
[image]

Gets or sets the current scroll position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float ScrollPosition { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollPosition As Single

Property Value

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.Shape Property

TreeViewNode.Shape Property
[image]

Gets or sets the shape of the table's outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SimpleShape Shape { get; set; }

Visual Basic [image] Copy Code

Public Property Shape As SimpleShape

Property Value

A member of the SimpleShape enumeration. The default is Rectangle.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.TextFormat Property

TreeViewNode.TextFormat Property
[image]

Gets or sets the alignment of texts displayed inside this shape node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringFormat TextFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TextFormat As StringFormat

Property Value

An instance of the .NET StringFormat class.

Remarks

Use this property to specify the wrapping mode and alignment of the caption text.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.TextPadding Property

TreeViewNode.TextPadding Property
[image]

Gets or sets the spacing between the item boundaries and its text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Thickness TextPadding { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property TextPadding As Thickness

Property Value

A Thickness instance specifying the size of the padding space left around the text.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNodeStyle Class

TreeViewNodeStyle Class
[image]

Represents a reusable set of properties that define the appearance of tree view nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TreeViewNodeStyle : DiagramNodeStyle

Visual Basic [image] Copy Code

Public Class TreeViewNodeStyle
Inherits DiagramNodeStyle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Style
MindFusion.Diagramming.DiagramItemStyle
MindFusion.Diagramming.DiagramNodeStyle
MindFusion.Diagramming.TreeViewNodeStyle

See Also

TreeViewNodeStyle Members


MindFusion.Diagramming.TreeViewNodeStyle Members

TreeViewNodeStyle Members
Constructors Properties Methods Events
[image]

Represents a reusable set of properties that define the appearance of tree view nodes.

The following tables list the members exposed by the TreeViewNodeStyle type.

Public Constructors

Name | Description
TreeViewNodeStyle | Initializes a new instance of the TreeViewNodeStyle class.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of the item. (Inherited from DiagramItemStyle.)
Effects | Gets a list of the effects applied to the node. (Inherited from DiagramNodeStyle.)
FontFamily | Gets or sets the font family of the item text. (Inherited from DiagramItemStyle.)
FontSize | Gets or sets the font size of the item text. (Inherited from DiagramItemStyle.)
FontStyle | Gets or sets the font style of the item text. (Inherited from DiagramItemStyle.)
FontUnit | Gets or sets the font unit of the item text. (Inherited from DiagramItemStyle.)
ShadowBrush | Gets or sets the brush used to paint the shadow of the item. (Inherited from DiagramItemStyle.)
Stroke | Gets or sets the brush used to paint the outline of the item. (Inherited from DiagramItemStyle.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItemStyle.)
StrokeThickness | Gets or sets the thickness of the item's outline, expressed in the current units of measure. (Inherited from DiagramItemStyle.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItemStyle.)

Public Methods

Name | Description
GetProperties | Gets all properties in the style. (Inherited from Style.)
GetProperty | Returns the property with the specified name, if any. (Inherited from Style.)
RegisterType | Associates a type with an alias. (Inherited from Style.)

Protected Methods

Name | Description
GetValue | Gets the value of the specified property. (Inherited from Style.)
IsPropertySet | Checks whether the specified property has a value. (Inherited from Style.)
LoadFrom | Deserializes the item from the specified reader. (Inherited from Style.)
LoadFromXml | Loads the style content from an XML element. (Inherited from Style.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Style.)
RegisterProperty | Registers a new property with the specified name and type. (Inherited from Style.)
SaveTo | Serializes the style to the specified writer. (Inherited from Style.)
SaveToXml | Saves the style content into an XML element. (Inherited from Style.)
SetValue | Sets the value of the specified property. (Inherited from Style.)
UnsetValue | Clears the value of the specified property. (Inherited from Style.)

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

TreeViewNodeStyle Class


MindFusion.Diagramming.TreeViewNodeStyle Constructor

TreeViewNodeStyle Constructor
[image]

Initializes a new instance of the TreeViewNodeStyle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewNodeStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TreeViewNodeStyle Class


MindFusion.Diagramming.TreeViewNodeStyle Events

TreeViewNodeStyle Events
[image]

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

TreeViewNodeStyle Class


MindFusion.Diagramming.UndoEventArgs Class

UndoEventArgs Class
[image]

Contains the arguments passed to the ActionRecorded, ActionUndone and ActionRedone event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class UndoEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class UndoEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.UndoEventArgs
MindFusion.Diagramming.UndoValidationEventArgs

See Also

UndoEventArgs Members


MindFusion.Diagramming.UndoEventArgs Members

UndoEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the ActionRecorded, ActionUndone and ActionRedone event handlers.

The following tables list the members exposed by the UndoEventArgs type.

Public Constructors

Name | Description
UndoEventArgs | Initializes a new instance of the UndoEventArgs class.

Public Properties

Name | Description
Command | Gets a reference to the Command instance related to the event being handled.

See Also

UndoEventArgs Class


MindFusion.Diagramming.UndoEventArgs Constructor

UndoEventArgs Constructor
[image]

Initializes a new instance of the UndoEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public UndoEventArgs (
Command command
)

Visual Basic [image] Copy Code

Public Sub UndoEventArgs ( _
command As Command _
)

Parameters

command

The Command related to the event.

See Also

UndoEventArgs Class


MindFusion.Diagramming.UndoEventArgs Properties

UndoEventArgs Properties
[image]

Public Properties

Name | Description
Command | Gets a reference to the Command instance related to the event being handled.

See Also

UndoEventArgs Class


MindFusion.Diagramming.UndoEventArgs.Command Property

UndoEventArgs.Command Property
[image]

Gets a reference to the Command instance related to the event being handled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Command Command { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Command As Command

Property Value

An instance of the Command class.

See Also

UndoEventArgs Members
UndoEventArgs Class


MindFusion.Diagramming.UndoManager Class

UndoManager Class
Remarks See Also
[image]

Implements undo/redo functionality in MvcDiagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class UndoManager

Visual Basic [image] Copy Code

Public Class UndoManager

Remarks

The only instance of UndoManager can be accessed through the UndoManager property of Diagram.

Use the UndoEnabled property to enable or disable saving action records for later undo. You might need to disable undo before performing actions that must not be undoable by end-users, such as creating special start/end nodes.

MvcDiagram does not provide shortcuts to undo or redo an action. An application must provide the user interface means for undo/redo and call the Undo or Redo methods when necessary. Undoing or redoing an action updates the current record pointer of the undo-history queue. To get access to that queue, use the History property.

Sometimes several actions must be represented as a single atomic operation. That can be achieved by using composites, represented by the CompositeCmd class. However actions records that are implicitly created by MvcDiagram as a response to users actions or method calls cannot be added directly to a composite. Instead you must use the StartComposite method to create an 'active' composite, to which implicitly created records are added automatically.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.UndoManager

See Also

UndoManager Members


MindFusion.Diagramming.UndoManager Members

UndoManager Members
Properties Methods
[image]

Implements undo/redo functionality in MvcDiagram.

The following tables list the members exposed by the UndoManager type.

Public Properties

Name | Description
History | Gets a reference to the undo manager's CommandHistory instance.
UndoEnabled | Gets or sets a value indicating whether saving action records for later undo is enabled.

Public Methods

Name | Description
Redo | Executes again an action saved in the command history.
StartComposite | Overloaded. Creates an 'active' composite record to store records of actions that are implicitly created by MvcDiagram.
Undo | Undoes an action saved in the command history.

See Also

UndoManager Class


MindFusion.Diagramming.UndoManager Methods

UndoManager Methods
[image]

Public Methods

Name | Description
Redo | Executes again an action saved in the command history.
StartComposite | Overloaded. Creates an 'active' composite record to store records of actions that are implicitly created by MvcDiagram.
Undo | Undoes an action saved in the command history.

See Also

UndoManager Class


MindFusion.Diagramming.UndoManager.Redo Method

UndoManager.Redo Method
[image]

Executes again an action saved in the command history.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Redo ()

Visual Basic [image] Copy Code

Public Sub Redo ()

Remarks

Executes again a command from the command history. The action that would be redone by calling this method is pointed by NextRedo property of the CommandHistory class.

See Also

UndoManager Members
UndoManager Class
Undo Method


MindFusion.Diagramming.UndoManager.StartComposite Method

UndoManager.StartComposite Method
[image]

Creates an 'active' composite record to store records of actions that are implicitly created by MvcDiagram.

Overload List

Name | Description
UndoManager.StartComposite (String) | Creates an 'active' composite record with the specified title.
UndoManager.StartComposite (String, Boolean) | Creates an 'active' composite record with the specified settings.

See Also

UndoManager Members
UndoManager Class


MindFusion.Diagramming.UndoManager.StartComposite Method (String)

UndoManager.StartComposite Method (String)
See Also
[image]

Creates an 'active' composite record with the specified title.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CompositeCmd StartComposite (
string title
)

Visual Basic [image] Copy Code

Public Function StartComposite ( _
title As String _
) As CompositeCmd

Parameters

title
A string to be associated with the composite record. It can be used later to give more information to users what exactly will be undone or redone. Use the Title property of the command class to get the title of an action record.

Return Value

An instance of the CompositeCmd class which represents the active composite record. Call its Execute method when done with recording actions in the composite.

Remarks

Sometimes several actions must be represented as a single atomic operation. That can be achieved by using composites, represented by the CompositeCmd class. However actions records that are implicitly created by MvcDiagram as a response to users actions or method calls cannot be added directly to a composite. The StartComposite method creates an 'active' composite, to which implicitly created records are added automatically. Call the composite's Execute method to stop adding action records to it and save it in the command history. Calling Undo or Redo for the composite record, undoes or redoes all actions contained within it.

See Also

StartComposite Method Overload List
UndoManager Members
UndoManager Class


MindFusion.Diagramming.UndoManager.StartComposite Method (String, Boolean)

UndoManager.StartComposite Method (String, Boolean)
See Also
[image]

Creates an 'active' composite record with the specified settings.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CompositeCmd StartComposite (
string title,
bool saveZOrder
)

Visual Basic [image] Copy Code

Public Function StartComposite ( _
title As String, _
saveZOrder As Boolean _
) As CompositeCmd

Parameters

title
A string to be associated with the composite record. It can be used later to give more information to users what exactly will be undone or redone. Use the Title property of the command class to get the title of an action record.
saveZOrder
Set this parameter to true to save the whole z-order array before executing the composite command, and to restore it back when the command is undone. Use that when there will be create or delete commands added to the composite one, because they do not guarantee restoring the items in the same z-order when the commands are undone or redone.

Return Value

An instance of the CompositeCmd class which represents the active composite record. Call its Execute method when done with recording actions in the composite.

Remarks

Sometimes several actions must be represented as a single atomic operation. That can be achieved by using composites, represented by the CompositeCmd class. However actions records that are implicitly created by MvcDiagram as a response to users actions or method calls cannot be added directly to a composite. The StartComposite method creates an 'active' composite, to which implicitly created records are added automatically. Call the composite's Execute method to stop adding action records to it and save it in the command history. Calling Undo or Redo for the composite record, undoes or redoes all actions contained within it.

Example

The following example illustrates how to create composite commands:

C# [image] Copy Code

// Implicitly created undo records will be saved here
CompositeCmd composite = diagram.UndoManager.StartComposite("Create group");

// Call methods that create undo records
ShapeNode node1 = diagram.Factory.CreateShapeNode(0, 0, 30, 30);
ShapeNode node2 = diagram.Factory.CreateShapeNode(0, 0, 15, 15);
Group g = diagram.Factory.CreateGroup(node1);
g.AttachToCorner(node2, 0);

// This goes to the active composite too
ChangeItemCmd change = new ChangeItemCmd(node2, "");
node2.Locked = true;
change.Execute();

// Save the active composite in history
composite.Execute();

Visual Basic [image] Copy Code

' Implicitly created undo records will be saved here
Dim composite As CompositeCmd = diagram.UndoManager.StartComposite("Create group")

' Call methods that create undo records
Dim node1 As ShapeNode = diagram.Factory.CreateShapeNode(0, 0, 30, 30)
Dim node2 As ShapeNode = diagram.Factory.CreateShapeNode(0, 0, 15, 15)
Dim g As Group = diagram.Factory.CreateGroup(node1)
g.AttachToCorner(node2, 0)

' This goes to the active composite too
Dim change As ChangeItemCmd = New ChangeItemCmd(node2, "")
node2.Locked = True
change.Execute()

' Save the active composite in history
composite.Execute()

See Also

StartComposite Method Overload List
UndoManager Members
UndoManager Class


MindFusion.Diagramming.UndoManager.Undo Method

UndoManager.Undo Method
[image]

Undoes an action saved in the command history.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Undo ()

Visual Basic [image] Copy Code

Public Sub Undo ()

Remarks

Undoes a command from the command history. The action that would be undone by calling this method is pointed by NextUndo property of the CommandHistory class.

See Also

UndoManager Members
UndoManager Class
Redo Method


MindFusion.Diagramming.UndoManager Properties

UndoManager Properties
[image]

Public Properties

Name | Description
History | Gets a reference to the undo manager's CommandHistory instance.
UndoEnabled | Gets or sets a value indicating whether saving action records for later undo is enabled.

See Also

UndoManager Class


MindFusion.Diagramming.UndoManager.History Property

UndoManager.History Property
[image]

Gets a reference to the undo manager's CommandHistory instance.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CommandHistory History { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property History As CommandHistory

Property Value

An instance of the CommandHistory class.

Remarks

History represents the undo manager's queue of action records. This queue provides access to the NextUndo and NextRedo records. You could set the queue's Capacity, specifying how many records can be added to the queue before the oldest ones start to drop off its end.

See Also

UndoManager Members
UndoManager Class
Command class


MindFusion.Diagramming.UndoManager.UndoEnabled Property

UndoManager.UndoEnabled Property
[image]

Gets or sets a value indicating whether saving action records for later undo is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool UndoEnabled { get; set; }

Visual Basic [image] Copy Code

Public Property UndoEnabled As Boolean

Property Value

true to save actions for later undo; otherwise false. The default is false.

Remarks

You might need to disable undo:

  • before executing actions you don't want end-users to undo, for example creating special start/end nodes.
  • before creating programmatically a lot of new diagram items - say hundreds or thousands. MvcDiagram creates an undo record for each item creation; if the Capacity of the command history is smaller than the number of items created, most of the records will drop from the history queue while adding new ones. That would waste processing power and memory for creating undo records that won't be used.

See Also

UndoManager Members
UndoManager Class


MindFusion.Diagramming.UndoValidationEventArgs Class

UndoValidationEventArgs Class
[image]

Contains the arguments passed to the ActionRecording event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class UndoValidationEventArgs : UndoEventArgs

Visual Basic [image] Copy Code

Public Class UndoValidationEventArgs
Inherits UndoEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.UndoEventArgs
MindFusion.Diagramming.UndoValidationEventArgs

See Also

UndoValidationEventArgs Members


MindFusion.Diagramming.UndoValidationEventArgs Members

UndoValidationEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the ActionRecording event handlers.

The following tables list the members exposed by the UndoValidationEventArgs type.

Public Constructors

Name | Description
UndoValidationEventArgs | Initializes a new instance of the UndoValidationEventArgs class.

Public Properties

Name | Description
Cancel | Gets or sets a value value indicating whether the operation should be canceled.
Command | Gets a reference to the Command instance related to the event being handled. (Inherited from UndoEventArgs.)

See Also

UndoValidationEventArgs Class


MindFusion.Diagramming.UndoValidationEventArgs Constructor

UndoValidationEventArgs Constructor
[image]

Initializes a new instance of the UndoValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public UndoValidationEventArgs (
Command command
)

Visual Basic [image] Copy Code

Public Sub UndoValidationEventArgs ( _
command As Command _
)

Parameters

command

The Command related to the event.

See Also

UndoValidationEventArgs Class


MindFusion.Diagramming.UndoValidationEventArgs Properties

UndoValidationEventArgs Properties
[image]

Public Properties

Name | Description
Cancel | Gets or sets a value value indicating whether the operation should be canceled.
Command | Gets a reference to the Command instance related to the event being handled. (Inherited from UndoEventArgs.)

See Also

UndoValidationEventArgs Class


MindFusion.Diagramming.UndoValidationEventArgs.Cancel Property

UndoValidationEventArgs.Cancel Property
[image]

Gets or sets a value value indicating whether the operation should be canceled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

true to cancel the operation; false to approve it.

See Also

UndoValidationEventArgs Members
UndoValidationEventArgs Class


MindFusion.Diagramming.UnitType Enumeration

UnitType Enumeration
[image]

Defines values that indicate whether point positions are specified in percentage, or in absolute units relative to the node's top-left corner.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum UnitType

Visual Basic [image] Copy Code

Public Enum UnitType

Members

Member name | Description
Percentage | Point coordinates are specified as percentage of the node's size.
Fixed | Point coordinates designate fixed offset from the node's top-left corner.

See Also

MindFusion.Diagramming Namespace
XUnit Property
YUnit Property


MindFusion.Diagramming.Vector Structure

Vector Structure
[image]

Represents a two-dimensional vector.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public struct Vector

Visual Basic [image] Copy Code

Public Structure Vector

See Also

Vector Members


MindFusion.Diagramming.Vector Members

Vector Members
Constructors Properties Methods
[image]

Represents a two-dimensional vector.

The following tables list the members exposed by the Vector type.

Public Constructors

Name | Description
Vector | Overloaded.

Public Properties

Name | Description
Length | Returns the vector length.
LengthSquared | Returns the squared length.
X | X coordinate of the vector.
Y | Y coordinate of the vector.

Public Methods

Name | Description
Add | Overloaded.
AngleBetween | Returns the angle between two vectors.
Divide | Divides a vector by a scalar value.
Equals | Overloaded.
GetHashCode | Object.GetHashCode override.
Left | Returns the left vector.
Multiply | Overloaded.
Negate | Reverses this vector's direction.
Normalize | Normalizes this vector.
Right | Returns the right vector.
Subtract | Subtracts two vectors.
ToString | Overloaded.

See Also

Vector Structure


MindFusion.Diagramming.Vector Constructor

Vector Constructor
[image]

Overload List

Name | Description
Vector (PointF, PointF) | Initializes a new instance of the Vector structure from the specified points.
Vector (Single, Single) | Initializes a new instance of the Vector structure with specified coordinates.

See Also

Vector Structure


MindFusion.Diagramming.Vector Constructor (PointF, PointF)

Vector Constructor (PointF, PointF)
See Also
[image]

Initializes a new instance of the Vector structure from the specified points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Vector (
PointF p1,
PointF p2
)

Visual Basic [image] Copy Code

Public New ( _
p1 As PointF, _
p2 As PointF _
)

Parameters

p1

Origin point of the vector.

p2

End point of the vector.

See Also

Vector Constructor Overload List
Vector Structure


MindFusion.Diagramming.Vector Constructor (Single, Single)

Vector Constructor (Single, Single)
See Also
[image]

Initializes a new instance of the Vector structure with specified coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Vector (
float x,
float y
)

Visual Basic [image] Copy Code

Public New ( _
x As Single, _
y As Single _
)

Parameters

x

X coordinate of the vector.

y

Y coordinate of the vector.

See Also

Vector Constructor Overload List
Vector Structure


MindFusion.Diagramming.Vector Methods

Vector Methods
[image]

Public Methods

Name | Description
Add | Overloaded.
AngleBetween | Returns the angle between two vectors.
Divide | Divides a vector by a scalar value.
Equals | Overloaded.
GetHashCode | Object.GetHashCode override.
Left | Returns the left vector.
Multiply | Overloaded.
Negate | Reverses this vector's direction.
Normalize | Normalizes this vector.
Right | Returns the right vector.
Subtract | Subtracts two vectors.
ToString | Overloaded.

See Also

Vector Structure


MindFusion.Diagramming.Vector.Add Method

Vector.Add Method
[image]

Overload List

Name | Description
Vector.Add (Vector, PointF) | Adds vector to a point.
Vector.Add (Vector, Vector) | Adds two vectors.

See Also

Vector Members
Vector Structure


MindFusion.Diagramming.Vector.Add Method (Vector, PointF)

Vector.Add Method (Vector, PointF)
See Also
[image]

Adds vector to a point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static PointF Add (
Vector vector,
PointF point
)

Visual Basic [image] Copy Code

Public Shared Function Add( _
vector As Vector, _
point As PointF _
) As PointF

Parameters

vector

A Vector instance.

point

A PointF instance.

Return Value

A point offset from the specified point by adding specified vector.

See Also

Add Method Overload List
Vector Members
Vector Structure


MindFusion.Diagramming.Vector.Add Method (Vector, Vector)

Vector.Add Method (Vector, Vector)
See Also
[image]

Adds two vectors.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Vector Add (
Vector vector1,
Vector vector2
)

Visual Basic [image] Copy Code

Public Shared Function Add( _
vector1 As Vector, _
vector2 As Vector _
) As Vector

Parameters

vector1

vector2

Return Value

See Also

Add Method Overload List
Vector Members
Vector Structure


MindFusion.Diagramming.Vector.AngleBetween Method

Vector.AngleBetween Method
[image]

Returns the angle between two vectors.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float AngleBetween (
Vector vector1,
Vector vector2
)

Visual Basic [image] Copy Code

Public Shared Function AngleBetween( _
vector1 As Vector, _
vector2 As Vector _
) As Single

Parameters

vector1

A Vector instance.

vector2

A Vector instance.

Return Value

The angle between specified vectors.

See Also

Vector Members
Vector Structure


MindFusion.Diagramming.Vector.Divide Method

Vector.Divide Method
[image]

Divides a vector by a scalar value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Vector Divide (
Vector vector,
float scalar
)

Visual Basic [image] Copy Code

Public Shared Function Divide( _
vector As Vector, _
scalar As Single _
) As Vector

Parameters

vector

A Vector instance.

scalar

A float value.

Return Value

A Vector with same direction and divided length.

See Also

Vector Members
Vector Structure


MindFusion.Diagramming.Vector.Equals Method

Vector.Equals Method
[image]

Overload List

Name | Description
Vector.Equals (Object) | Object.Equals override.
Vector.Equals (Vector) | Compare this vector with the specified vector for equality.
Vector.Equals (Vector, Vector) | Compares two vectors for equality.

See Also

Vector Members
Vector Structure


MindFusion.Diagramming.Vector.Equals Method (Object)

Vector.Equals Method (Object)
See Also
[image]

Object.Equals override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool Equals (
Object o
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
o As Object _
) As Boolean

Parameters

o

The object to compare this vector with.

Return Value

true if the objects are equal, or otherwise false.

See Also

Equals Method Overload List
Vector Members
Vector Structure


MindFusion.Diagramming.Vector.Equals Method (Vector)

Vector.Equals Method (Vector)
See Also
[image]

Compare this vector with the specified vector for equality.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public new bool Equals (
Vector value
)

Visual Basic [image] Copy Code

Public Shadows Function Equals( _
value As Vector _
) As Boolean

Parameters

value

The vector to compare with.

Return Value

true if the vectors are equal, or otherwise false.

See Also

Equals Method Overload List
Vector Members
Vector Structure


MindFusion.Diagramming.Vector.Equals Method (Vector, Vector)

Vector.Equals Method (Vector, Vector)
See Also
[image]

Compares two vectors for equality.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public new static bool Equals (
Vector vector1,
Vector vector2
)

Visual Basic [image] Copy Code

Public Shadows Shared Function Equals( _
vector1 As Vector, _
vector2 As Vector _
) As Boolean

Parameters

vector1

The first vector to compare.

vector2

The second vector to compare.

Return Value

true if the vectors are equal, or otherwise false.

See Also

Equals Method Overload List
Vector Members
Vector Structure


MindFusion.Diagramming.Vector.GetHashCode Method

Vector.GetHashCode Method
[image]

Object.GetHashCode override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

The vector's hash code.

See Also

Vector Members
Vector Structure


MindFusion.Diagramming.Vector.Left Method

Vector.Left Method
[image]

Returns the left vector.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Vector Left (
Vector v
)

Visual Basic [image] Copy Code

Public Shared Function Left( _
v As Vector _
) As Vector

Parameters

v

Return Value

See Also

Vector Members
Vector Structure


MindFusion.Diagramming.Vector.Multiply Method

Vector.Multiply Method
[image]

Overload List

Name | Description
Vector.Multiply (Single, Vector) | Multiplies a vector by a scalar value.
Vector.Multiply (Vector, Single) | Multiplies a vector by a scalar value.
Vector.Multiply (Vector, Vector) | Multiplies two vectors.

See Also

Vector Members
Vector Structure


MindFusion.Diagramming.Vector.Multiply Method (Single, Vector)

Vector.Multiply Method (Single, Vector)
See Also
[image]

Multiplies a vector by a scalar value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Vector Multiply (
float scalar,
Vector vector
)

Visual Basic [image] Copy Code

Public Shared Function Multiply( _
scalar As Single, _
vector As Vector _
) As Vector

Parameters

scalar

A float value.

vector

A Vector instance.

Return Value

A Vector with same direction and multiplied length.

See Also

Multiply Method Overload List
Vector Members
Vector Structure


MindFusion.Diagramming.Vector.Multiply Method (Vector, Single)

Vector.Multiply Method (Vector, Single)
See Also
[image]

Multiplies a vector by a scalar value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Vector Multiply (
Vector vector,
float scalar
)

Visual Basic [image] Copy Code

Public Shared Function Multiply( _
vector As Vector, _
scalar As Single _
) As Vector

Parameters

vector

A Vector instance.

scalar

A float value.

Return Value

A Vector with same direction and multiplied length.

See Also

Multiply Method Overload List
Vector Members
Vector Structure


MindFusion.Diagramming.Vector.Multiply Method (Vector, Vector)

Vector.Multiply Method (Vector, Vector)
See Also
[image]

Multiplies two vectors.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float Multiply (
Vector vector1,
Vector vector2
)

Visual Basic [image] Copy Code

Public Shared Function Multiply( _
vector1 As Vector, _
vector2 As Vector _
) As Single

Parameters

vector1

A Vector instance.

vector2

A Vector instance.

Return Value

The dot product of specified vectors.

See Also

Multiply Method Overload List
Vector Members
Vector Structure


MindFusion.Diagramming.Vector.Negate Method

Vector.Negate Method
[image]

Reverses this vector's direction.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Negate ()

Visual Basic [image] Copy Code

Public Sub Negate ()

See Also

Vector Members
Vector Structure


MindFusion.Diagramming.Vector.Normalize Method

Vector.Normalize Method
[image]

Normalizes this vector.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Normalize ()

Visual Basic [image] Copy Code

Public Sub Normalize ()

See Also

Vector Members
Vector Structure


MindFusion.Diagramming.Vector.Right Method

Vector.Right Method
[image]

Returns the right vector.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Vector Right (
Vector v
)

Visual Basic [image] Copy Code

Public Shared Function Right( _
v As Vector _
) As Vector

Parameters

v

Return Value

See Also

Vector Members
Vector Structure


MindFusion.Diagramming.Vector.Subtract Method

Vector.Subtract Method
[image]

Subtracts two vectors.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Vector Subtract (
Vector vector1,
Vector vector2
)

Visual Basic [image] Copy Code

Public Shared Function Subtract( _
vector1 As Vector, _
vector2 As Vector _
) As Vector

Parameters

vector1

A Vector instance.

vector2

A Vector instance.

Return Value

The difference between specified vectors.

See Also

Vector Members
Vector Structure


MindFusion.Diagramming.Vector.ToString Method

Vector.ToString Method
[image]

Overload List

Name | Description
Vector.ToString () | Object.ToString override.
Vector.ToString (IFormatProvider) | Returns the vector's string representation in specified culture.

See Also

Vector Members
Vector Structure


MindFusion.Diagramming.Vector.ToString Method ()

Vector.ToString Method ()
See Also
[image]

Object.ToString override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

The vector's string representation.

See Also

ToString Method Overload List
Vector Members
Vector Structure


MindFusion.Diagramming.Vector.ToString Method (IFormatProvider)

Vector.ToString Method (IFormatProvider)
See Also
[image]

Returns the vector's string representation in specified culture.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ToString (
IFormatProvider provider
)

Visual Basic [image] Copy Code

Public Function ToString( _
provider As IFormatProvider _
) As String

Parameters

provider

An IFormatProvider (e.g. CultureInfo) specifying number format.

Return Value

The vector's string representation.

See Also

ToString Method Overload List
Vector Members
Vector Structure


MindFusion.Diagramming.Vector Properties

Vector Properties
[image]

Public Properties

Name | Description
Length | Returns the vector length.
LengthSquared | Returns the squared length.
X | X coordinate of the vector.
Y | Y coordinate of the vector.

See Also

Vector Structure


MindFusion.Diagramming.Vector.Length Property

Vector.Length Property
[image]

Returns the vector length.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Length { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Length As Single

Property Value

See Also

Vector Members
Vector Structure


MindFusion.Diagramming.Vector.LengthSquared Property

Vector.LengthSquared Property
[image]

Returns the squared length.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float LengthSquared { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LengthSquared As Single

Property Value

See Also

Vector Members
Vector Structure


MindFusion.Diagramming.Vector.X Property

Vector.X Property
[image]

X coordinate of the vector.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float X { get; set; }

Visual Basic [image] Copy Code

Public Property X As Single

Property Value

See Also

Vector Members
Vector Structure


MindFusion.Diagramming.Vector.Y Property

Vector.Y Property
[image]

Y coordinate of the vector.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Y { get; set; }

Visual Basic [image] Copy Code

Public Property Y As Single

Property Value

See Also

Vector Members
Vector Structure


MindFusion.Diagramming.View3D Enumeration

View3D Enumeration
[image]

Defines keys used to associate 3D position data with a node through the LayoutTraits property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum View3D

Visual Basic [image] Copy Code

Public Enum View3D

Members

Member name | Description
Position | Specifies the position of a node in 3D coordinate space. The value associated with this key should be a Point3D object.

See Also


MindFusion.Diagramming.VisioContent Class

VisioContent Class
[image]

Represents the content of a VisioNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class VisioContent

Visual Basic [image] Copy Code

Public Class VisioContent

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.VisioContent

See Also

VisioContent Members


MindFusion.Diagramming.VisioContent Members

VisioContent Members
Properties Methods
[image]

Represents the content of a VisioNode.

The following tables list the members exposed by the VisioContent type.

Public Properties

Name | Description
Master | Gets the underlying Visio master.

Public Methods

Name | Description
Create | Overloaded. Creates an instance of the VisioContent class.

See Also

VisioContent Class


MindFusion.Diagramming.VisioContent Methods

VisioContent Methods
[image]

Public Methods

Name | Description
Create | Overloaded. Creates an instance of the VisioContent class.

See Also

VisioContent Class


MindFusion.Diagramming.VisioContent.Create Method

VisioContent.Create Method
[image]

Creates an instance of the VisioContent class.

Overload List

Name | Description
VisioContent.Create (VisioStencil, Int32) | Creates an instance of the VisioContent class representing the Visio master with the specified identifier from the specified Visio stencil.
VisioContent.Create (VisioStencil, String) | Creates an instance of the VisioContent class representing the Visio master with the specified name from the specified Visio stencil.

See Also

VisioContent Members
VisioContent Class


MindFusion.Diagramming.VisioContent.Create Method (VisioStencil, Int32)

VisioContent.Create Method (VisioStencil, Int32)
See Also
[image]

Creates an instance of the VisioContent class representing the Visio master with the specified identifier from the specified Visio stencil.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static VisioContent Create (
VisioStencil stencil,
int masterId
)

Visual Basic [image] Copy Code

Public Shared Function Create( _
stencil As VisioStencil, _
masterId As Integer _
) As VisioContent

Parameters

stencil

The Visio stencil.

masterId

The master identifier.

Return Value

An instance of the VisioContent class representing the specified master.

See Also

Create Method Overload List
VisioContent Members
VisioContent Class


MindFusion.Diagramming.VisioContent.Create Method (VisioStencil, String)

VisioContent.Create Method (VisioStencil, String)
See Also
[image]

Creates an instance of the VisioContent class representing the Visio master with the specified name from the specified Visio stencil.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static VisioContent Create (
VisioStencil stencil,
string masterName
)

Visual Basic [image] Copy Code

Public Shared Function Create( _
stencil As VisioStencil, _
masterName As String _
) As VisioContent

Parameters

stencil

The Visio stencil.

masterName

The master name.

Return Value

An instance of the VisioContent class representing the specified master.

See Also

Create Method Overload List
VisioContent Members
VisioContent Class


MindFusion.Diagramming.VisioContent Properties

VisioContent Properties
[image]

Public Properties

Name | Description
Master | Gets the underlying Visio master.

See Also

VisioContent Class


MindFusion.Diagramming.VisioContent.Master Property

VisioContent.Master Property
[image]

Gets the underlying Visio master.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Master<Color, Image> Master { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Master As Master(Of Color, Image)

Property Value

An instance of the Master(TColor, TImage) class.

See Also

VisioContent Members
VisioContent Class


MindFusion.Diagramming.VisioNode Class

VisioNode Class
Remarks See Also
[image]

Represents a node that can display shapes from Visio stencils.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class VisioNode : DiagramNode

Visual Basic [image] Copy Code

Public Class VisioNode
Inherits DiagramNode

Remarks

The shape displayed by the node is specified through its Content property. To create the content, load a Visio stencil file (*.vsx) using an instance of the VisioStencil class, then use the static VisioContent.Create method. A reference to the master shape of the content can be obtained through the Master property.

Important

The standard stencils installed with Visio are copyrighted by Microsoft, and you should not use them in your application. This feature is intended to let you use public domain stencils, or commercial ones you have purchased a license for.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.VisioNode

See Also

VisioNode Members


MindFusion.Diagramming.VisioNode Members

VisioNode Members
Constructors Fields Properties Methods
[image]

Represents a node that can display shapes from Visio stencils.

The following tables list the members exposed by the VisioNode type.

Public Constructors

Name | Description
VisioNode | Overloaded. Initializes a new instance of the VisioNode class.

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Content | Gets or sets the content of the node.
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | Determines whether the node supports connections to its constituent elements. (Inherited from DiagramNode.)
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
DoModify | For internal use. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. Renders the adjustment handles of this item. (Inherited from DiagramNode.)
DrawLocal | DiagramNode.DrawLocal override.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | DiagramNode.DrawShadowLocal override.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item. (Inherited from DiagramItem.)
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item. (Inherited from DiagramItem.)
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item. (Inherited from DiagramItem.)
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item. (Inherited from DiagramItem.)
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point. (Inherited from DiagramNode.)
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Intersects | Determines whether the node intersects another one, taking into account the outlines of node shapes. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetPos | Sets the bounding rectangle of this node without updating connected arrows. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
CancelModify | DiagramItem.CancelModify override. Invoked when the interactive modification of this object has been canceled. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Checks whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateProperties | DiagramNode.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
Finalize | DiagramItem finalizer. (Inherited from DiagramItem.)
FreeResources | Called when the node is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from DiagramNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the item content from an XML element.
LoadObsolete | For internal use. (Inherited from DiagramItem.)
OnAdd | DiagramItem.OnAdd override. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnClick | Invoked when the user clicks this item. (Inherited from DiagramItem.)
OnDoubleClick | Invoked when the user double-clicks this item. (Inherited from DiagramItem.)
OnMeasureUnitChanged | DiagramItem.OnMeasureUnitChanged override. (Inherited from DiagramNode.)
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | DiagramItem.OnZoomChanged override. (Inherited from DiagramNode.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReference | Called during deserialization, after all objects have been instantiated, in order to update the references between them. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. Invoked when the user starts modifying this item interactively. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster. (Inherited from DiagramItem.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. Invoked during interactive modification of this item. (Inherited from DiagramNode.)

See Also

VisioNode Class


MindFusion.Diagramming.VisioNode Constructor

VisioNode Constructor
[image]

Initializes a new instance of the VisioNode class.

Overload List

Name | Description
VisioNode () | Initializes a new instance of the VisioNode class.
VisioNode (Diagram) | Initializes a new instance of the VisioNode class with default values supplied form the specified Diagram.
VisioNode (VisioNode) | Initializes a new instance of the VisioNode class using the specified node as a prototype.

See Also

VisioNode Class


MindFusion.Diagramming.VisioNode Constructor ()

VisioNode Constructor ()
See Also
[image]

Initializes a new instance of the VisioNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public VisioNode ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

VisioNode Constructor Overload List
VisioNode Class


MindFusion.Diagramming.VisioNode Constructor (Diagram)

VisioNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the VisioNode class with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public VisioNode (
Diagram parent
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram _
)

Parameters

parent

The Diagram from which to obtain default values for the node properties.

See Also

VisioNode Constructor Overload List
VisioNode Class


MindFusion.Diagramming.VisioNode Constructor (VisioNode)

VisioNode Constructor (VisioNode)
See Also
[image]

Initializes a new instance of the VisioNode class using the specified node as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public VisioNode (
VisioNode prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As VisioNode _
)

Parameters

prototype

The node to use as a prototype. The properties of the new node are initialized from the property values of this node.

See Also

VisioNode Constructor Overload List
VisioNode Class


MindFusion.Diagramming.VisioNode Methods

VisioNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
DoModify | For internal use. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. Renders the adjustment handles of this item. (Inherited from DiagramNode.)
DrawLocal | DiagramNode.DrawLocal override.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | DiagramNode.DrawShadowLocal override.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetEffectiveBrush | Creates a System.Drawing.Brush object representing the currently effective brush of the item. (Inherited from DiagramItem.)
GetEffectivePen | Creates a System.Drawing.Pen object representing the currently effective pen of the item. (Inherited from DiagramItem.)
GetEffectiveShadowBrush | Creates a System.Drawing.Brush object representing the currently effective shadow brush of the item. (Inherited from DiagramItem.)
GetEffectiveTextBrush | Creates a System.Drawing.Brush object representing the currently effective text brush of the item. (Inherited from DiagramItem.)
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point. (Inherited from DiagramNode.)
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Intersects | Determines whether the node intersects another one, taking into account the outlines of node shapes. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetPos | Sets the bounding rectangle of this node without updating connected arrows. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
CancelModify | DiagramItem.CancelModify override. Invoked when the interactive modification of this object has been canceled. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Checks whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateProperties | DiagramNode.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
Finalize | DiagramItem finalizer. (Inherited from DiagramItem.)
FreeResources | Called when the node is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from DiagramNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the item content from an XML element.
LoadObsolete | For internal use. (Inherited from DiagramItem.)
OnAdd | DiagramItem.OnAdd override. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnClick | Invoked when the user clicks this item. (Inherited from DiagramItem.)
OnDoubleClick | Invoked when the user double-clicks this item. (Inherited from DiagramItem.)
OnMeasureUnitChanged | DiagramItem.OnMeasureUnitChanged override. (Inherited from DiagramNode.)
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | DiagramItem.OnZoomChanged override. (Inherited from DiagramNode.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReference | Called during deserialization, after all objects have been instantiated, in order to update the references between them. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. Invoked when the user starts modifying this item interactively. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateGroup | Called to update the positions of subordinate nodes attached to this item when the attachment style is set to ControlledByMaster. (Inherited from DiagramItem.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. Invoked during interactive modification of this item. (Inherited from DiagramNode.)

See Also

VisioNode Class


MindFusion.Diagramming.VisioNode.CreateProperties Method

VisioNode.CreateProperties Method
[image]

DiagramNode.CreateProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override DiagramItemProperties CreateProperties ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateProperties () As DiagramItemProperties

Return Value

A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

VisioNode Members
VisioNode Class


MindFusion.Diagramming.VisioNode.DrawLocal Method

VisioNode.DrawLocal Method
[image]

DiagramNode.DrawLocal override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawLocal (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawLocal( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

The IGraphics surface to draw the node on.

options

Provides options for the drawing operation.

See Also

VisioNode Members
VisioNode Class


MindFusion.Diagramming.VisioNode.DrawShadowLocal Method

VisioNode.DrawShadowLocal Method
[image]

DiagramNode.DrawShadowLocal override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawShadowLocal (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawShadowLocal( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

An IGraphics object where the shadow should be rendered.

options

Provides options for the drawing operation.

See Also

VisioNode Members
VisioNode Class


MindFusion.Diagramming.VisioNode.LoadFrom Method

VisioNode.LoadFrom Method
[image]

Deserializes the object from the specified reader.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void LoadFrom (
BinaryReader reader,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFrom( _
reader As BinaryReader, _
context As PersistContext _
)

Parameters

reader

A BinaryReader object from which to read the item's data.

context

A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

VisioNode Members
VisioNode Class


MindFusion.Diagramming.VisioNode.LoadFromXml Method

VisioNode.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement containing the item's data.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

VisioNode Members
VisioNode Class


MindFusion.Diagramming.VisioNode.OnUpdateBounds Method

VisioNode.OnUpdateBounds Method
[image]

DiagramNode.OnUpdateBounds override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnUpdateBounds (
bool sizeChanged
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnUpdateBounds( _
sizeChanged As Boolean _
)

Parameters

sizeChanged

true if the size has changed; false if only the position has changed.

See Also

VisioNode Members
VisioNode Class


MindFusion.Diagramming.VisioNode.RestoreProperties Method

VisioNode.RestoreProperties Method
[image]

DiagramNode.RestoreProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub RestoreProperties( _
props As DiagramItemProperties _
)

Parameters

props

A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

VisioNode Members
VisioNode Class


MindFusion.Diagramming.VisioNode.SaveProperties Method

VisioNode.SaveProperties Method
[image]

DiagramNode.SaveProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveProperties( _
props As DiagramItemProperties _
)

Parameters

props

A DiagramItemProperties-derived object where the item's properties should be saved.

See Also

VisioNode Members
VisioNode Class


MindFusion.Diagramming.VisioNode.SaveTo Method

VisioNode.SaveTo Method
[image]

Serializes the object to the specified writer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SaveTo (
BinaryWriter writer,
PersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveTo( _
writer As BinaryWriter, _
context As PersistContext _
)

Parameters

writer

A BinaryWriter object the item's data should be written to.

context

A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

VisioNode Members
VisioNode Class


MindFusion.Diagramming.VisioNode.SaveToXml Method

VisioNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement the item's data should be stored into.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

VisioNode Members
VisioNode Class


MindFusion.Diagramming.VisioNode Properties

VisioNode Properties
[image]

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Content | Gets or sets the content of the node.
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | Determines whether the node supports connections to its constituent elements. (Inherited from DiagramNode.)
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

See Also

VisioNode Class


MindFusion.Diagramming.VisioNode.Content Property

VisioNode.Content Property
[image]

Gets or sets the content of the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public VisioContent Content { get; set; }

Visual Basic [image] Copy Code

Public Property Content As VisioContent

Property Value

An instance of the VisioContent class.

Remarks

To create a VisioContent instance, load a Visio stencil, then use one of the VisioContent.Create overloads.

See Also

VisioNode Members
VisioNode Class


MindFusion.Diagramming.VisioNodeProperties Class

VisioNodeProperties Class
[image]

Stores the values of VisioNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from VisioNode, do so by deriving from VisioNodeProperties and overriding the VisioNode.SaveProperties, VisioNode.RestoreProperties, and VisioNode.CreateProperties methods.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class VisioNodeProperties : DiagramNodeProperties

Visual Basic [image] Copy Code

Public Class VisioNodeProperties
Inherits DiagramNodeProperties

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemProperties
MindFusion.Diagramming.DiagramNodeProperties
MindFusion.Diagramming.VisioNodeProperties

See Also

VisioNodeProperties Members


MindFusion.Diagramming.VisioNodeProperties Members

VisioNodeProperties Members
Constructors Fields Methods
[image]

Stores the values of VisioNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from VisioNode, do so by deriving from VisioNodeProperties and overriding the VisioNode.SaveProperties, VisioNode.RestoreProperties, and VisioNode.CreateProperties methods.

The following tables list the members exposed by the VisioNodeProperties type.

Public Constructors

Name | Description
VisioNodeProperties | Initializes a new instance of the VisioNodeProperties class.

Public Fields

Name | Description
ItemClass | For internal use. (Inherited from DiagramItemProperties.)
Selected | For internal use. (Inherited from DiagramItemProperties.)
TextPadding | For internal use. (Inherited from DiagramItemProperties.)
ZIndex | For internal use. (Inherited from DiagramItemProperties.)

Public Methods

Name | Description
FreeResources | Frees stored resources which will no longer be used. (Inherited from DiagramItemProperties.)

See Also

VisioNodeProperties Class


MindFusion.Diagramming.VisioNodeProperties Constructor

VisioNodeProperties Constructor
[image]

Initializes a new instance of the VisioNodeProperties class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public VisioNodeProperties ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

VisioNodeProperties Class


MindFusion.Diagramming.VisioNodeStyle Class

VisioNodeStyle Class
[image]

Represents a reusable set of properties that define the appearance of Visio nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class VisioNodeStyle : DiagramNodeStyle

Visual Basic [image] Copy Code

Public Class VisioNodeStyle
Inherits DiagramNodeStyle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Style
MindFusion.Diagramming.DiagramItemStyle
MindFusion.Diagramming.DiagramNodeStyle
MindFusion.Diagramming.VisioNodeStyle

See Also

VisioNodeStyle Members


MindFusion.Diagramming.VisioNodeStyle Members

VisioNodeStyle Members
Constructors Properties Methods Events
[image]

Represents a reusable set of properties that define the appearance of Visio nodes.

The following tables list the members exposed by the VisioNodeStyle type.

Public Constructors

Name | Description
VisioNodeStyle | Initializes a new instance of the VisioNodeStyle class.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of the item. (Inherited from DiagramItemStyle.)
Effects | Gets a list of the effects applied to the node. (Inherited from DiagramNodeStyle.)
FontFamily | Gets or sets the font family of the item text. (Inherited from DiagramItemStyle.)
FontSize | Gets or sets the font size of the item text. (Inherited from DiagramItemStyle.)
FontStyle | Gets or sets the font style of the item text. (Inherited from DiagramItemStyle.)
FontUnit | Gets or sets the font unit of the item text. (Inherited from DiagramItemStyle.)
ShadowBrush | Gets or sets the brush used to paint the shadow of the item. (Inherited from DiagramItemStyle.)
Stroke | Gets or sets the brush used to paint the outline of the item. (Inherited from DiagramItemStyle.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItemStyle.)
StrokeThickness | Gets or sets the thickness of the item's outline, expressed in the current units of measure. (Inherited from DiagramItemStyle.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItemStyle.)

Public Methods

Name | Description
GetProperties | Gets all properties in the style. (Inherited from Style.)
GetProperty | Returns the property with the specified name, if any. (Inherited from Style.)
RegisterType | Associates a type with an alias. (Inherited from Style.)

Protected Methods

Name | Description
GetValue | Gets the value of the specified property. (Inherited from Style.)
IsPropertySet | Checks whether the specified property has a value. (Inherited from Style.)
LoadFrom | Deserializes the item from the specified reader. (Inherited from Style.)
LoadFromXml | Loads the style content from an XML element. (Inherited from Style.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Style.)
RegisterProperty | Registers a new property with the specified name and type. (Inherited from Style.)
SaveTo | Serializes the style to the specified writer. (Inherited from Style.)
SaveToXml | Saves the style content into an XML element. (Inherited from Style.)
SetValue | Sets the value of the specified property. (Inherited from Style.)
UnsetValue | Clears the value of the specified property. (Inherited from Style.)

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

VisioNodeStyle Class


MindFusion.Diagramming.VisioNodeStyle Constructor

VisioNodeStyle Constructor
[image]

Initializes a new instance of the VisioNodeStyle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public VisioNodeStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

VisioNodeStyle Class


MindFusion.Diagramming.VisioNodeStyle Events

VisioNodeStyle Events
[image]

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

VisioNodeStyle Class


MindFusion.Diagramming.VisioStencil Class

VisioStencil Class
[image]

Represents a Visio stencil.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class VisioStencil

Visual Basic [image] Copy Code

Public Class VisioStencil

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.VisioStencil

See Also

VisioStencil Members


MindFusion.Diagramming.VisioStencil Members

VisioStencil Members
Properties Methods
[image]

Represents a Visio stencil.

The following tables list the members exposed by the VisioStencil type.

Public Properties

Name | Description
Masters | Gets a list with all masters in this stencil.

Public Methods

Name | Description
LoadFromXml | Creates a new VisioStencil instance from the specified Visio stencil file (*.vsx).

See Also

VisioStencil Class


MindFusion.Diagramming.VisioStencil Methods

VisioStencil Methods
[image]

Public Methods

Name | Description
LoadFromXml | Creates a new VisioStencil instance from the specified Visio stencil file (*.vsx).

See Also

VisioStencil Class


MindFusion.Diagramming.VisioStencil.LoadFromXml Method

VisioStencil.LoadFromXml Method
[image]

Creates a new VisioStencil instance from the specified Visio stencil file (*.vsx).

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static VisioStencil LoadFromXml (
string fileName
)

Visual Basic [image] Copy Code

Public Shared Function LoadFromXml( _
fileName As String _
) As VisioStencil

Parameters

fileName

The file to load from.

Return Value

The newly created VisioStencil object.

See Also

VisioStencil Members
VisioStencil Class


MindFusion.Diagramming.VisioStencil Properties

VisioStencil Properties
[image]

Public Properties

Name | Description
Masters | Gets a list with all masters in this stencil.

See Also

VisioStencil Class


MindFusion.Diagramming.VisioStencil.Masters Property

VisioStencil.Masters Property
[image]

Gets a list with all masters in this stencil.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IList<Master<Color, Image>> Masters { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Masters As IList(Of Master(Of Color, Image))

Property Value

A list of Master(Color, Image) objects.

See Also

VisioStencil Members
VisioStencil Class


MindFusion.Diagramming.VisitNode Delegate

VisitNode Delegate
[image]

Defines the prototype for methods called by VisitNodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate bool VisitNode (
DiagramNode node,
DiagramItem relatedItem
)

Visual Basic [image] Copy Code

Public Delegate Function VisitNode( _
node As DiagramNode, _
relatedItem As DiagramItem _
) As Boolean

Parameters

node

relatedItem

Return Value

See Also


MindFusion.Diagramming.XmlPersistContext Class

XmlPersistContext Class
[image]

Contains methods that can help you serialize and deserialize MvcDiagram items to end from XML documents.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class XmlPersistContext

Visual Basic [image] Copy Code

Public Class XmlPersistContext

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.XmlPersistContext

See Also

XmlPersistContext Members


MindFusion.Diagramming.XmlPersistContext Members

XmlPersistContext Members
Constructors Fields Properties Methods
[image]

Contains methods that can help you serialize and deserialize MvcDiagram items to end from XML documents.

The following tables list the members exposed by the XmlPersistContext type.

Public Constructors

Name | Description
XmlPersistContext | Initializes a new instance of the XmlPersistContext class.

Public Fields

Name | Description
LatestFormat | Specifies the latest file format revision number.

Public Properties

Name | Description
BaseURI | Gets or sets the base URI of the XML document being loaded or saved. When not specified, the BaseURI of the underlying XmlDocument is used.
ClassVersion | Gets the class version of the currently deserialized item.
Diagram | Gets the underlying diagram object.
FileVersion | Gets the format revision number for the file being currently serialized.
IncludeUnalteredProperties | Gets or sets a value specifies whether properties that have their default value should be serialized to XML.
XmlDocument | Gets the underlying XML document.

Public Methods

Name | Description
AddChildElement | Overloaded.
FromRelativePath | Converts the specified path from relative to the BaseURI to an absolute path.
ReadAnchorPattern | Reads an AnchorPattern with the specified name.
ReadBool | Overloaded.
ReadBrush | Overloaded.
ReadByte | Reads a byte value with the specified name.
ReadChar | Reads a char value with the specified name.
ReadColor | Overloaded.
ReadColorArray | Reads a color array with the specified name.
ReadDecimal | Reads a decimal value with the specified name.
ReadDouble | Reads a double value with the specified name.
ReadEffect | Overloaded. Reads a NodeEffect object.
ReadEnum | Overloaded.
ReadFloat | Overloaded.
ReadFloatArray | Reads a float array with the specified name.
ReadFont | Overloaded.
ReadGroup | Reads a group object with the specified name.
ReadHashtable | Reads a hash or traits table object with the specified name.
ReadImage | Reads an Image object with the specified name.
ReadInt | Overloaded.
ReadItemReference | Overloaded.
ReadLong | Reads a long value with the specified name.
ReadMap | Reads a MapContent object with the specified name.
ReadNodeConstraints | Reads a NodeConstraints object with the specified name.
ReadObject | Reads an object with the specified name.
ReadPen | Overloaded. Reads a MindFusion.Drawing.Pen object with the specified name.
ReadPointCollection | Reads a PointCollection object with the specified name.
ReadPointF | Overloaded.
ReadRectangleF | Reads a RectangleF object with the specified name.
ReadSByte | Reads a 8-bit signed integer value with the specified name.
ReadShape | Reads a Shape object with the specified name.
ReadShort | Overloaded.
ReadSizeF | Reads a Size object with the specified name.
ReadStream | Reads a stream with the specified name.
ReadString | Overloaded.
ReadStringFormat | Overloaded.
ReadStyle | Reads a Style object with the specified name.
ReadSvg | Reads a SVG object with the specified name.
ReadTag | Reads the specified tag for the specified object.
ReadTheme | Reads a Theme object with the specified name.
ReadThickness | Reads a Thickness object with the specified name.
ReadUInt | Reads an unsigned integer value with the specified name.
ReadULong | Reads an unsigned long value with the specified name.
ReadUShort | Reads an unsigned short value with the specified name.
ReadVisioContent | Reads a Visio content with the specified name.
SelectNode | Returns the child node with the specified name.
SelectNodes | Returns the child nodes with the specified name.
ToRelativePath | Converts the specified absolute path to a path relative to the BaseURI.
WriteAnchorPattern | Writes the specified anchor pattern.
WriteBool | Writes a boolean value with the specified name.
WriteBrush | Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.
WriteByte | Write a byte value with the specified name.
WriteChar | Write a char value with the specified name.
WriteColor | Writes the specified color.
WriteColorArray | Writes the specified array.
WriteDecimal | Write a decimal value with the specified name.
WriteDouble | Writes a double value with the specified name.
WriteEffect | Writes a reference to the specified effect. The effect is registered within the internal hashtable for subsequent serialization.
WriteEnum | Writes the specified enum value.
WriteFloat | Writes a float value with the specified name.
WriteFloatArray | Writes the specified array.
WriteFont | Writes the specified font.
WriteGroup | Writes the specified group object.
WriteHashtable | Writes the specified hashtable.
WriteImage | Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.
WriteInt | Writes an integer value with the specified name.
WriteItemReference | Writes a reference to the specified item with the specified name.
WriteLong | Writes a long value with the specified name.
WriteMap | Writes a reference to the specified MapContent. The map is registered within the internal hashtable for subsequent serialization.
WriteObject | Writes the specified object under the specified name.
WritePen | Writes the specified pen.
WritePointCollection | Writes the specified point collection.
WritePointF | Overloaded.
WriteRectangleF | Writes a RectangleF with the specified name.
WriteSByte | Write a 8-bit signed integer value with the specified name.
WriteShape | Writes the specified shape with the specified name.
WriteShort | Writes a short value with the specified name.
WriteSizeF | Writes a Size with the specified name.
WriteStream | Writes the specified stream.
WriteString | Writes a string value with the specified name.
WriteStringFormat | Writes the specified StringFormat object.
WriteStyle | Writes a reference to the specified style. The style is registered within the internal hashtable for subsequent serialization.
WriteSvg | Writes a reference to the specified SVG. The SVG is registered within the internal hashtable for subsequent serialization.
WriteTag | Writes the specified tag of the specified object.
WriteTheme | Writes the specified Theme object.
WriteThickness | Writes a Thickness with the specified name.
WriteTraits | Writes the specified traits hashtable.
WriteUInt | Writes an unsigned integer value with the specified name.
WriteULong | Writes an unsigned long value with the specified name.
WriteUShort | Writes an unsigned short value with the specified name.
WriteVisioContent | Writes a reference to the specified Visio content. The content is registered within the internal hashtable for subsequent serialization.

See Also

XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext Fields

XmlPersistContext Fields
[image]

Public Fields

Name | Description
LatestFormat | Specifies the latest file format revision number.

See Also

XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.LatestFormat Field

XmlPersistContext.LatestFormat Field
[image]

Specifies the latest file format revision number.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static int LatestFormat

Visual Basic [image] Copy Code

Public Shared LatestFormat As Integer

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext Constructor

XmlPersistContext Constructor
[image]

Initializes a new instance of the XmlPersistContext class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlPersistContext (
Diagram diagram,
XmlDocument document,
int fileVersion
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram, _
document As XmlDocument, _
fileVersion As Integer _
)

Parameters

diagram
The Diagram that will be serialized or deserialized.
document

An XmlDocument instance representing the XML file.

fileVersion
Specifies the current file format number.

See Also

XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext Methods

XmlPersistContext Methods
[image]

Public Methods

Name | Description
AddChildElement | Overloaded.
FromRelativePath | Converts the specified path from relative to the BaseURI to an absolute path.
ReadAnchorPattern | Reads an AnchorPattern with the specified name.
ReadBool | Overloaded.
ReadBrush | Overloaded.
ReadByte | Reads a byte value with the specified name.
ReadChar | Reads a char value with the specified name.
ReadColor | Overloaded.
ReadColorArray | Reads a color array with the specified name.
ReadDecimal | Reads a decimal value with the specified name.
ReadDouble | Reads a double value with the specified name.
ReadEffect | Overloaded. Reads a NodeEffect object.
ReadEnum | Overloaded.
ReadFloat | Overloaded.
ReadFloatArray | Reads a float array with the specified name.
ReadFont | Overloaded.
ReadGroup | Reads a group object with the specified name.
ReadHashtable | Reads a hash or traits table object with the specified name.
ReadImage | Reads an Image object with the specified name.
ReadInt | Overloaded.
ReadItemReference | Overloaded.
ReadLong | Reads a long value with the specified name.
ReadMap | Reads a MapContent object with the specified name.
ReadNodeConstraints | Reads a NodeConstraints object with the specified name.
ReadObject | Reads an object with the specified name.
ReadPen | Overloaded. Reads a MindFusion.Drawing.Pen object with the specified name.
ReadPointCollection | Reads a PointCollection object with the specified name.
ReadPointF | Overloaded.
ReadRectangleF | Reads a RectangleF object with the specified name.
ReadSByte | Reads a 8-bit signed integer value with the specified name.
ReadShape | Reads a Shape object with the specified name.
ReadShort | Overloaded.
ReadSizeF | Reads a Size object with the specified name.
ReadStream | Reads a stream with the specified name.
ReadString | Overloaded.
ReadStringFormat | Overloaded.
ReadStyle | Reads a Style object with the specified name.
ReadSvg | Reads a SVG object with the specified name.
ReadTag | Reads the specified tag for the specified object.
ReadTheme | Reads a Theme object with the specified name.
ReadThickness | Reads a Thickness object with the specified name.
ReadUInt | Reads an unsigned integer value with the specified name.
ReadULong | Reads an unsigned long value with the specified name.
ReadUShort | Reads an unsigned short value with the specified name.
ReadVisioContent | Reads a Visio content with the specified name.
SelectNode | Returns the child node with the specified name.
SelectNodes | Returns the child nodes with the specified name.
ToRelativePath | Converts the specified absolute path to a path relative to the BaseURI.
WriteAnchorPattern | Writes the specified anchor pattern.
WriteBool | Writes a boolean value with the specified name.
WriteBrush | Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.
WriteByte | Write a byte value with the specified name.
WriteChar | Write a char value with the specified name.
WriteColor | Writes the specified color.
WriteColorArray | Writes the specified array.
WriteDecimal | Write a decimal value with the specified name.
WriteDouble | Writes a double value with the specified name.
WriteEffect | Writes a reference to the specified effect. The effect is registered within the internal hashtable for subsequent serialization.
WriteEnum | Writes the specified enum value.
WriteFloat | Writes a float value with the specified name.
WriteFloatArray | Writes the specified array.
WriteFont | Writes the specified font.
WriteGroup | Writes the specified group object.
WriteHashtable | Writes the specified hashtable.
WriteImage | Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.
WriteInt | Writes an integer value with the specified name.
WriteItemReference | Writes a reference to the specified item with the specified name.
WriteLong | Writes a long value with the specified name.
WriteMap | Writes a reference to the specified MapContent. The map is registered within the internal hashtable for subsequent serialization.
WriteObject | Writes the specified object under the specified name.
WritePen | Writes the specified pen.
WritePointCollection | Writes the specified point collection.
WritePointF | Overloaded.
WriteRectangleF | Writes a RectangleF with the specified name.
WriteSByte | Write a 8-bit signed integer value with the specified name.
WriteShape | Writes the specified shape with the specified name.
WriteShort | Writes a short value with the specified name.
WriteSizeF | Writes a Size with the specified name.
WriteStream | Writes the specified stream.
WriteString | Writes a string value with the specified name.
WriteStringFormat | Writes the specified StringFormat object.
WriteStyle | Writes a reference to the specified style. The style is registered within the internal hashtable for subsequent serialization.
WriteSvg | Writes a reference to the specified SVG. The SVG is registered within the internal hashtable for subsequent serialization.
WriteTag | Writes the specified tag of the specified object.
WriteTheme | Writes the specified Theme object.
WriteThickness | Writes a Thickness with the specified name.
WriteTraits | Writes the specified traits hashtable.
WriteUInt | Writes an unsigned integer value with the specified name.
WriteULong | Writes an unsigned long value with the specified name.
WriteUShort | Writes an unsigned short value with the specified name.
WriteVisioContent | Writes a reference to the specified Visio content. The content is registered within the internal hashtable for subsequent serialization.

See Also

XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.AddChildElement Method

XmlPersistContext.AddChildElement Method
[image]

Overload List

Name | Description
XmlPersistContext.AddChildElement (String, XmlElement) | Adds a new child node with the specified name to the specified parent node.
XmlPersistContext.AddChildElement (String, XmlElement, String) | Adds a new child node with the specified name and value to the specified parent node.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.AddChildElement Method (String, XmlElement)

XmlPersistContext.AddChildElement Method (String, XmlElement)
See Also
[image]

Adds a new child node with the specified name to the specified parent node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement AddChildElement (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function AddChildElement( _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

elementName

parentElement

Return Value

See Also

AddChildElement Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.AddChildElement Method (String, XmlElement, String)

XmlPersistContext.AddChildElement Method (String, XmlElement, String)
See Also
[image]

Adds a new child node with the specified name and value to the specified parent node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement AddChildElement (
string elementName,
XmlElement parentElement,
string innerText
)

Visual Basic [image] Copy Code

Public Function AddChildElement( _
elementName As String, _
parentElement As XmlElement, _
innerText As String _
) As XmlElement

Parameters

elementName

parentElement

innerText

Return Value

See Also

AddChildElement Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.FromRelativePath Method

XmlPersistContext.FromRelativePath Method
[image]

Converts the specified path from relative to the BaseURI to an absolute path.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string FromRelativePath (
string path
)

Visual Basic [image] Copy Code

Public Function FromRelativePath( _
path As String _
) As String

Parameters

path

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadAnchorPattern Method

XmlPersistContext.ReadAnchorPattern Method
[image]

Reads an AnchorPattern with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern ReadAnchorPattern (
string elementName,
XmlElement parentElement,
bool standalone
)

Visual Basic [image] Copy Code

Public Function ReadAnchorPattern( _
elementName As String, _
parentElement As XmlElement, _
standalone As Boolean _
) As AnchorPattern

Parameters

elementName

parentElement

standalone

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadBool Method

XmlPersistContext.ReadBool Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadBool (String, XmlElement) | Reads a boolean value with the specified name.
XmlPersistContext.ReadBool (String, XmlElement, Boolean) | Reads a boolean value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadBool Method (String, XmlElement)

XmlPersistContext.ReadBool Method (String, XmlElement)
See Also
[image]

Reads a boolean value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ReadBool (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadBool( _
elementName As String, _
parentElement As XmlElement _
) As Boolean

Parameters

elementName

parentElement

Return Value

See Also

ReadBool Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadBool Method (String, XmlElement, Boolean)

XmlPersistContext.ReadBool Method (String, XmlElement, Boolean)
See Also
[image]

Reads a boolean value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ReadBool (
string elementName,
XmlElement parentElement,
bool defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadBool( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As Boolean _
) As Boolean

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadBool Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadBrush Method

XmlPersistContext.ReadBrush Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadBrush (String, XmlElement) | Reads a MindFusion.Drawing.Brush object with the specified name.
XmlPersistContext.ReadBrush (String, XmlElement, Brush) | Reads a MindFusion.Drawing.Brush object with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadBrush Method (String, XmlElement)

XmlPersistContext.ReadBrush Method (String, XmlElement)
See Also
[image]

Reads a MindFusion.Drawing.Brush object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush ReadBrush (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadBrush ( _
elementName As String, _
parentElement As XmlElement _
) As Brush

Parameters

elementName

parentElement

Return Value

See Also

ReadBrush Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadBrush Method (String, XmlElement, Brush)

XmlPersistContext.ReadBrush Method (String, XmlElement, Brush)
See Also
[image]

Reads a MindFusion.Drawing.Brush object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush ReadBrush (
string elementName,
XmlElement parentElement,
Brush defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadBrush( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As Brush _
) As Brush

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadBrush Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadByte Method

XmlPersistContext.ReadByte Method
[image]

Reads a byte value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public byte ReadByte (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadByte( _
elementName As String, _
parentElement As XmlElement _
) As Byte

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadChar Method

XmlPersistContext.ReadChar Method
[image]

Reads a char value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public char ReadChar (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadChar( _
elementName As String, _
parentElement As XmlElement _
) As Char

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadColor Method

XmlPersistContext.ReadColor Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadColor (String, XmlElement) | Reads a color with the specified name.
XmlPersistContext.ReadColor (String, XmlElement, Color) | Reads a color with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadColor Method (String, XmlElement)

XmlPersistContext.ReadColor Method (String, XmlElement)
See Also
[image]

Reads a color with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color ReadColor (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadColor( _
elementName As String, _
parentElement As XmlElement _
) As Color

Parameters

elementName

parentElement

Return Value

See Also

ReadColor Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadColor Method (String, XmlElement, Color)

XmlPersistContext.ReadColor Method (String, XmlElement, Color)
See Also
[image]

Reads a color with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color ReadColor (
string elementName,
XmlElement parentElement,
Color defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadColor( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As Color _
) As Color

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadColor Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadColorArray Method

XmlPersistContext.ReadColorArray Method
[image]

Reads a color array with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color[] ReadColorArray (
string elementName,
string subElementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadColorArray( _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As Color()

Parameters

elementName

subElementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadDecimal Method

XmlPersistContext.ReadDecimal Method
[image]

Reads a decimal value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public decimal ReadDecimal (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDecimal( _
elementName As String, _
parentElement As XmlElement _
) As Decimal

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadDouble Method

XmlPersistContext.ReadDouble Method
[image]

Reads a double value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ReadDouble (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDouble( _
elementName As String, _
parentElement As XmlElement _
) As Double

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadEffect Method

XmlPersistContext.ReadEffect Method
[image]

Reads a NodeEffect object.

Overload List

Name | Description
XmlPersistContext.ReadEffect (String, XmlElement) | Reads a NodeEffect object with the specified name.
XmlPersistContext.ReadEffect (XmlElement) | Reads a NodeEffect object from the specified element.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadEffect Method (String, XmlElement)

XmlPersistContext.ReadEffect Method (String, XmlElement)
See Also
[image]

Reads a NodeEffect object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeEffect ReadEffect (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadEffect( _
elementName As String, _
parentElement As XmlElement _
) As NodeEffect

Parameters

elementName

parentElement

Return Value

See Also

ReadEffect Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadEffect Method (XmlElement)

XmlPersistContext.ReadEffect Method (XmlElement)
See Also
[image]

Reads a NodeEffect object from the specified element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeEffect ReadEffect (
XmlElement element
)

Visual Basic [image] Copy Code

Public Function ReadEffect( _
element As XmlElement _
) As NodeEffect

Parameters

element

Return Value

See Also

ReadEffect Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadEnum Method

XmlPersistContext.ReadEnum Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadEnum (String, XmlElement) | Reads an enum value with the specified name.
XmlPersistContext.ReadEnum (String, XmlElement, Object) | Reads an enum value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadEnum Method (String, XmlElement)

XmlPersistContext.ReadEnum Method (String, XmlElement)
See Also
[image]

Reads an enum value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object ReadEnum (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadEnum( _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

elementName

parentElement

Return Value

See Also

ReadEnum Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadEnum Method (String, XmlElement, Object)

XmlPersistContext.ReadEnum Method (String, XmlElement, Object)
See Also
[image]

Reads an enum value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object ReadEnum (
string elementName,
XmlElement parentElement,
Object defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadEnum( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As Object _
) As Object

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadEnum Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadFloat Method

XmlPersistContext.ReadFloat Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadFloat (String, XmlElement) | Reads a float value with the specified name.
XmlPersistContext.ReadFloat (String, XmlElement, Single) | Reads a float value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadFloat Method (String, XmlElement)

XmlPersistContext.ReadFloat Method (String, XmlElement)
See Also
[image]

Reads a float value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float ReadFloat (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFloat( _
elementName As String, _
parentElement As XmlElement _
) As Single

Parameters

elementName

parentElement

Return Value

See Also

ReadFloat Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadFloat Method (String, XmlElement, Single)

XmlPersistContext.ReadFloat Method (String, XmlElement, Single)
See Also
[image]

Reads a float value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float ReadFloat (
string elementName,
XmlElement parentElement,
float defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadFloat( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As Single _
) As Single

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadFloat Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadFloatArray Method

XmlPersistContext.ReadFloatArray Method
[image]

Reads a float array with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float[] ReadFloatArray (
string elementName,
string subElementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFloatArray( _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As Single()

Parameters

elementName

subElementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadFont Method

XmlPersistContext.ReadFont Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadFont (String, XmlElement) | Reads a Font object with the specified name.
XmlPersistContext.ReadFont (String, XmlElement, Font) | Reads a Font object with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadFont Method (String, XmlElement)

XmlPersistContext.ReadFont Method (String, XmlElement)
See Also
[image]

Reads a Font object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Font ReadFont (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFont( _
elementName As String, _
parentElement As XmlElement _
) As Font

Parameters

elementName

parentElement

Return Value

See Also

ReadFont Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadFont Method (String, XmlElement, Font)

XmlPersistContext.ReadFont Method (String, XmlElement, Font)
See Also
[image]

Reads a Font object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Font ReadFont (
string elementName,
XmlElement parentElement,
Font defaultFont
)

Visual Basic [image] Copy Code

Public Function ReadFont( _
elementName As String, _
parentElement As XmlElement, _
defaultFont As Font _
) As Font

Parameters

elementName

parentElement

defaultFont

Return Value

See Also

ReadFont Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadGroup Method

XmlPersistContext.ReadGroup Method
[image]

Reads a group object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Group ReadGroup (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadGroup ( _
elementName As String, _
parentElement As XmlElement _
) As Group

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadHashtable Method

XmlPersistContext.ReadHashtable Method
[image]

Reads a hash or traits table object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Hashtable ReadHashtable (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadHashtable( _
elementName As String, _
parentElement As XmlElement _
) As Hashtable

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadImage Method

XmlPersistContext.ReadImage Method
[image]

Reads an Image object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Image ReadImage (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadImage( _
elementName As String, _
parentElement As XmlElement _
) As Image

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadInt Method

XmlPersistContext.ReadInt Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadInt (String, XmlElement) | Reads an integer value with the specified name.
XmlPersistContext.ReadInt (String, XmlElement, Int32) | Reads an integer value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadInt Method (String, XmlElement)

XmlPersistContext.ReadInt Method (String, XmlElement)
See Also
[image]

Reads an integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ReadInt (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadInt( _
elementName As String, _
parentElement As XmlElement _
) As Integer

Parameters

elementName

parentElement

Return Value

See Also

ReadInt Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadInt Method (String, XmlElement, Int32)

XmlPersistContext.ReadInt Method (String, XmlElement, Int32)
See Also
[image]

Reads an integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ReadInt (
string elementName,
XmlElement parentElement,
int defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadInt( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As Integer _
) As Integer

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadInt Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadItemReference Method

XmlPersistContext.ReadItemReference Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadItemReference (String, XmlElement) | Reads a reference to the item with the specified name.
XmlPersistContext.ReadItemReference (XmlElement) | Reads an item reference from the specified element.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadItemReference Method (String, XmlElement)

XmlPersistContext.ReadItemReference Method (String, XmlElement)
See Also
[image]

Reads a reference to the item with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem ReadItemReference (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadItemReference ( _
elementName As String, _
parentElement As XmlElement _
) As DiagramItem

Parameters

elementName

parentElement

Return Value

See Also

ReadItemReference Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadItemReference Method (XmlElement)

XmlPersistContext.ReadItemReference Method (XmlElement)
See Also
[image]

Reads an item reference from the specified element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem ReadItemReference (
XmlElement itemElement
)

Visual Basic [image] Copy Code

Public Function ReadItemReference ( _
itemElement As XmlElement _
) As DiagramItem

Parameters

itemElement

Return Value

See Also

ReadItemReference Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadLong Method

XmlPersistContext.ReadLong Method
[image]

Reads a long value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public long ReadLong (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadLong( _
elementName As String, _
parentElement As XmlElement _
) As Long

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadMap Method

XmlPersistContext.ReadMap Method
[image]

Reads a MapContent object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MapContent ReadMap (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadMap( _
elementName As String, _
parentElement As XmlElement _
) As MapContent

Parameters

elementName

A string specifying the XML element name.

parentElement

An XmlElement instance specifying the parent element.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadNodeConstraints Method

XmlPersistContext.ReadNodeConstraints Method
[image]

Reads a NodeConstraints object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeConstraints ReadNodeConstraints (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadNodeConstraints ( _
elementName As String, _
parentElement As XmlElement _
) As NodeConstraints

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadObject Method

XmlPersistContext.ReadObject Method
[image]

Reads an object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object ReadObject (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadObject( _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadPen Method

XmlPersistContext.ReadPen Method
[image]

Reads a MindFusion.Drawing.Pen object with the specified name.

Overload List

Name | Description
XmlPersistContext.ReadPen (String, XmlElement) | Reads a MindFusion.Drawing.Pen object with the specified name.
XmlPersistContext.ReadPen (String, XmlElement, Pen) | Reads a MindFusion.Drawing.Pen object with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadPen Method (String, XmlElement)

XmlPersistContext.ReadPen Method (String, XmlElement)
See Also
[image]

Reads a MindFusion.Drawing.Pen object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen ReadPen (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadPen ( _
elementName As String, _
parentElement As XmlElement _
) As Pen

Parameters

elementName

parentElement

Return Value

See Also

ReadPen Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadPen Method (String, XmlElement, Pen)

XmlPersistContext.ReadPen Method (String, XmlElement, Pen)
See Also
[image]

Reads a MindFusion.Drawing.Pen object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen ReadPen (
string elementName,
XmlElement parentElement,
Pen defaultPen
)

Visual Basic [image] Copy Code

Public Function ReadPen( _
elementName As String, _
parentElement As XmlElement, _
defaultPen As Pen _
) As Pen

Parameters

elementName

parentElement

defaultPen

Return Value

See Also

ReadPen Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadPointCollection Method

XmlPersistContext.ReadPointCollection Method
[image]

Reads a PointCollection object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointCollection ReadPointCollection (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadPointCollection ( _
elementName As String, _
parentElement As XmlElement _
) As PointCollection

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadPointF Method

XmlPersistContext.ReadPointF Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadPointF (String, XmlElement) | Reads a PointF object with the specified name.
XmlPersistContext.ReadPointF (XmlElement) | Reads a PointF object from the specified element.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadPointF Method (String, XmlElement)

XmlPersistContext.ReadPointF Method (String, XmlElement)
See Also
[image]

Reads a PointF object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointF ReadPointF (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadPointF( _
elementName As String, _
parentElement As XmlElement _
) As PointF

Parameters

elementName

parentElement

Return Value

See Also

ReadPointF Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadPointF Method (XmlElement)

XmlPersistContext.ReadPointF Method (XmlElement)
See Also
[image]

Reads a PointF object from the specified element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointF ReadPointF (
XmlElement element
)

Visual Basic [image] Copy Code

Public Function ReadPointF( _
element As XmlElement _
) As PointF

Parameters

element

Return Value

See Also

ReadPointF Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadRectangleF Method

XmlPersistContext.ReadRectangleF Method
[image]

Reads a RectangleF object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF ReadRectangleF (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadRectangleF( _
elementName As String, _
parentElement As XmlElement _
) As RectangleF

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadSByte Method

XmlPersistContext.ReadSByte Method
[image]

Reads a 8-bit signed integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sbyte ReadSByte (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadSByte( _
elementName As String, _
parentElement As XmlElement _
) As SByte

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadShape Method

XmlPersistContext.ReadShape Method
[image]

Reads a Shape object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape ReadShape (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadShape ( _
elementName As String, _
parentElement As XmlElement _
) As Shape

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadShort Method

XmlPersistContext.ReadShort Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadShort (String, XmlElement) | Reads a short value with the specified name.
XmlPersistContext.ReadShort (String, XmlElement, Int16) | Reads a short value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadShort Method (String, XmlElement)

XmlPersistContext.ReadShort Method (String, XmlElement)
See Also
[image]

Reads a short value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public short ReadShort (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadShort( _
elementName As String, _
parentElement As XmlElement _
) As Short

Parameters

elementName

parentElement

Return Value

See Also

ReadShort Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadShort Method (String, XmlElement, Int16)

XmlPersistContext.ReadShort Method (String, XmlElement, Int16)
See Also
[image]

Reads a short value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public short ReadShort (
string elementName,
XmlElement parentElement,
short defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadShort( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As Short _
) As Short

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadShort Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadSizeF Method

XmlPersistContext.ReadSizeF Method
[image]

Reads a Size object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SizeF ReadSizeF (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadSizeF( _
elementName As String, _
parentElement As XmlElement _
) As SizeF

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadStream Method

XmlPersistContext.ReadStream Method
[image]

Reads a stream with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Stream ReadStream (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadStream( _
elementName As String, _
parentElement As XmlElement _
) As Stream

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadString Method

XmlPersistContext.ReadString Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadString (String, XmlElement) | Reads a string value with the specified name.
XmlPersistContext.ReadString (String, XmlElement, String) | Reads a string value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadString Method (String, XmlElement)

XmlPersistContext.ReadString Method (String, XmlElement)
See Also
[image]

Reads a string value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ReadString (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadString( _
elementName As String, _
parentElement As XmlElement _
) As String

Parameters

elementName

parentElement

Return Value

See Also

ReadString Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadString Method (String, XmlElement, String)

XmlPersistContext.ReadString Method (String, XmlElement, String)
See Also
[image]

Reads a string value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ReadString (
string elementName,
XmlElement parentElement,
string defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadString( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As String _
) As String

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadString Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadStringFormat Method

XmlPersistContext.ReadStringFormat Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadStringFormat (String, XmlElement) | Reads a StringFormat object with the specified name.
XmlPersistContext.ReadStringFormat (String, XmlElement, StringFormat) | Reads a StringFormat object with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadStringFormat Method (String, XmlElement)

XmlPersistContext.ReadStringFormat Method (String, XmlElement)
See Also
[image]

Reads a StringFormat object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringFormat ReadStringFormat (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadStringFormat( _
elementName As String, _
parentElement As XmlElement _
) As StringFormat

Parameters

elementName

parentElement

Return Value

See Also

ReadStringFormat Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadStringFormat Method (String, XmlElement, StringFormat)

XmlPersistContext.ReadStringFormat Method (String, XmlElement, StringFormat)
See Also
[image]

Reads a StringFormat object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringFormat ReadStringFormat (
string elementName,
XmlElement parentElement,
StringFormat defultFormat
)

Visual Basic [image] Copy Code

Public Function ReadStringFormat( _
elementName As String, _
parentElement As XmlElement, _
defultFormat As StringFormat _
) As StringFormat

Parameters

elementName

parentElement

defultFormat

Return Value

See Also

ReadStringFormat Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadStyle Method

XmlPersistContext.ReadStyle Method
[image]

Reads a Style object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Style ReadStyle (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadStyle( _
elementName As String, _
parentElement As XmlElement _
) As Style

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadSvg Method

XmlPersistContext.ReadSvg Method
[image]

Reads a SVG object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SvgContent ReadSvg (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadSvg( _
elementName As String, _
parentElement As XmlElement _
) As SvgContent

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadTag Method

XmlPersistContext.ReadTag Method
[image]

Reads the specified tag for the specified object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object ReadTag (
Object item,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadTag( _
item As Object, _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

item

elementName

parentElement

Return Value

Remarks

Tags are read similarly to arbitrary objects except that the client of the diagram is given a chance to perform custom deserialization through event handling.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadTheme Method

XmlPersistContext.ReadTheme Method
[image]

Reads a Theme object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Theme ReadTheme (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadTheme( _
elementName As String, _
parentElement As XmlElement _
) As Theme

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadThickness Method

XmlPersistContext.ReadThickness Method
[image]

Reads a Thickness object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Thickness ReadThickness (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadThickness( _
elementName As String, _
parentElement As XmlElement _
) As Thickness

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadUInt Method

XmlPersistContext.ReadUInt Method
[image]

Reads an unsigned integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public uint ReadUInt (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadUInt( _
elementName As String, _
parentElement As XmlElement _
) As UInteger

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadULong Method

XmlPersistContext.ReadULong Method
[image]

Reads an unsigned long value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ulong ReadULong (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadULong( _
elementName As String, _
parentElement As XmlElement _
) As ULong

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadUShort Method

XmlPersistContext.ReadUShort Method
[image]

Reads an unsigned short value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ushort ReadUShort (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadUShort( _
elementName As String, _
parentElement As XmlElement _
) As UShort

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadVisioContent Method

XmlPersistContext.ReadVisioContent Method
[image]

Reads a Visio content with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public VisioContent ReadVisioContent (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadVisioContent( _
elementName As String, _
parentElement As XmlElement _
) As VisioContent

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.SelectNode Method

XmlPersistContext.SelectNode Method
[image]

Returns the child node with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement SelectNode (
XmlElement parentElement,
string name
)

Visual Basic [image] Copy Code

Public Function SelectNode( _
parentElement As XmlElement, _
name As String _
) As XmlElement

Parameters

parentElement

The parent XML element.

name

A string specifying the name of the child node.

Return Value

An XmlElement corresponding to the child node.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.SelectNodes Method

XmlPersistContext.SelectNodes Method
[image]

Returns the child nodes with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlNodeList SelectNodes (
XmlElement parentElement,
string name
)

Visual Basic [image] Copy Code

Public Function SelectNodes( _
parentElement As XmlElement, _
name As String _
) As XmlNodeList

Parameters

parentElement

The parent XML element.

name

A string specifying the name of the child nodes.

Return Value

An XmlNodeList containing the found child nodes.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ToRelativePath Method

XmlPersistContext.ToRelativePath Method
[image]

Converts the specified absolute path to a path relative to the BaseURI.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ToRelativePath (
string path
)

Visual Basic [image] Copy Code

Public Function ToRelativePath( _
path As String _
) As String

Parameters

path

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteAnchorPattern Method

XmlPersistContext.WriteAnchorPattern Method
[image]

Writes the specified anchor pattern.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteAnchorPattern (
AnchorPattern anchorPattern,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteAnchorPattern ( _
anchorPattern As AnchorPattern, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

anchorPattern

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteBool Method

XmlPersistContext.WriteBool Method
[image]

Writes a boolean value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteBool (
bool boolValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteBool( _
boolValue As Boolean, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

boolValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteBrush Method

XmlPersistContext.WriteBrush Method
[image]

Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteBrush (
Brush brush,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteBrush ( _
brush As Brush, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

brush

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteByte Method

XmlPersistContext.WriteByte Method
[image]

Write a byte value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteByte (
byte byteValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteByte( _
byteValue As Byte, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

byteValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteChar Method

XmlPersistContext.WriteChar Method
[image]

Write a char value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteChar (
char charValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteChar( _
charValue As Char, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

charValue

elementName

parentElement

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteColor Method

XmlPersistContext.WriteColor Method
[image]

Writes the specified color.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteColor (
Color color,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteColor( _
color As Color, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

color

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteColorArray Method

XmlPersistContext.WriteColorArray Method
[image]

Writes the specified array.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteColorArray (
Color[] array,
string elementName,
string subElementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteColorArray( _
array() As Color, _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

array

elementName

subElementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteDecimal Method

XmlPersistContext.WriteDecimal Method
[image]

Write a decimal value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteDecimal (
decimal decimalValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDecimal( _
decimalValue As Decimal, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

decimalValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteDouble Method

XmlPersistContext.WriteDouble Method
[image]

Writes a double value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteDouble (
double doubleValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDouble( _
doubleValue As Double, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

doubleValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteEffect Method

XmlPersistContext.WriteEffect Method
[image]

Writes a reference to the specified effect. The effect is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteEffect (
NodeEffect effect,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteEffect( _
effect As NodeEffect, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

effect

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteEnum Method

XmlPersistContext.WriteEnum Method
[image]

Writes the specified enum value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteEnum (
Object enumValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteEnum( _
enumValue As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

enumValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteFloat Method

XmlPersistContext.WriteFloat Method
[image]

Writes a float value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteFloat (
float floatValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFloat( _
floatValue As Single, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

floatValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteFloatArray Method

XmlPersistContext.WriteFloatArray Method
[image]

Writes the specified array.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteFloatArray (
float[] array,
string elementName,
string subElementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFloatArray( _
array() As Single, _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

array

elementName

subElementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteFont Method

XmlPersistContext.WriteFont Method
[image]

Writes the specified font.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteFont (
Font font,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFont( _
font As Font, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

font

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteGroup Method

XmlPersistContext.WriteGroup Method
[image]

Writes the specified group object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteGroup (
Group group,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteGroup ( _
group As Group, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

group

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteHashtable Method

XmlPersistContext.WriteHashtable Method
[image]

Writes the specified hashtable.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteHashtable (
Hashtable hashtable,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteHashtable( _
hashtable As Hashtable, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

hashtable

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteImage Method

XmlPersistContext.WriteImage Method
[image]

Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteImage (
Image image,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteImage( _
image As Image, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

image

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteInt Method

XmlPersistContext.WriteInt Method
[image]

Writes an integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteInt (
int intValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteInt( _
intValue As Integer, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

intValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteItemReference Method

XmlPersistContext.WriteItemReference Method
[image]

Writes a reference to the specified item with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteItemReference (
DiagramItem item,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteItemReference ( _
item As DiagramItem, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

item

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteLong Method

XmlPersistContext.WriteLong Method
[image]

Writes a long value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteLong (
long longValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteLong( _
longValue As Long, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

longValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteMap Method

XmlPersistContext.WriteMap Method
[image]

Writes a reference to the specified MapContent. The map is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteMap (
MapContent map,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteMap( _
map As MapContent, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

map

The MapContent object to be serialized.

elementName

A string specifying the XML element name.

parentElement

An XmlElement instance specifying the parent element.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteObject Method

XmlPersistContext.WriteObject Method
[image]

Writes the specified object under the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteObject (
Object objectValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteObject( _
objectValue As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

objectValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WritePen Method

XmlPersistContext.WritePen Method
[image]

Writes the specified pen.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WritePen (
Pen pen,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePen ( _
pen As Pen, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

pen

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WritePointCollection Method

XmlPersistContext.WritePointCollection Method
[image]

Writes the specified point collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WritePointCollection (
PointCollection points,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePointCollection ( _
points As PointCollection, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

points

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WritePointF Method

XmlPersistContext.WritePointF Method
[image]

Overload List

Name | Description
XmlPersistContext.WritePointF (PointF, String, XmlElement) | Writes a PointF with the specified name.
XmlPersistContext.WritePointF (Single, Single, String, XmlElement) | Writes the specified PointF under the specified name. The x and y components of the point are written as attributes.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WritePointF Method (PointF, String, XmlElement)

XmlPersistContext.WritePointF Method (PointF, String, XmlElement)
See Also
[image]

Writes a PointF with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WritePointF (
PointF point,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePointF( _
point As PointF, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

point

elementName

parentElement

Return Value

See Also

WritePointF Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WritePointF Method (Single, Single, String, XmlElement)

XmlPersistContext.WritePointF Method (Single, Single, String, XmlElement)
See Also
[image]

Writes the specified PointF under the specified name. The x and y components of the point are written as attributes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WritePointF (
float x,
float y,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePointF( _
x As Single, _
y As Single, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

x

y

elementName

parentElement

Return Value

See Also

WritePointF Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteRectangleF Method

XmlPersistContext.WriteRectangleF Method
[image]

Writes a RectangleF with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteRectangleF (
RectangleF rectangle,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteRectangleF( _
rectangle As RectangleF, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

rectangle

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteSByte Method

XmlPersistContext.WriteSByte Method
[image]

Write a 8-bit signed integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteSByte (
sbyte byteValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteSByte( _
byteValue As SByte, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

byteValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteShape Method

XmlPersistContext.WriteShape Method
[image]

Writes the specified shape with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteShape (
Shape shape,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteShape ( _
shape As Shape, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

shape

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteShort Method

XmlPersistContext.WriteShort Method
[image]

Writes a short value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteShort (
short shortValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteShort( _
shortValue As Short, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

shortValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteSizeF Method

XmlPersistContext.WriteSizeF Method
[image]

Writes a Size with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteSizeF (
SizeF size,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteSizeF( _
size As SizeF, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

size

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteStream Method

XmlPersistContext.WriteStream Method
[image]

Writes the specified stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteStream (
Stream stream,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteStream( _
stream As Stream, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

stream

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteString Method

XmlPersistContext.WriteString Method
[image]

Writes a string value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteString (
string stringValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteString( _
stringValue As String, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

stringValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteStringFormat Method

XmlPersistContext.WriteStringFormat Method
[image]

Writes the specified StringFormat object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteStringFormat (
StringFormat stringFormat,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteStringFormat( _
stringFormat As StringFormat, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

stringFormat

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteStyle Method

XmlPersistContext.WriteStyle Method
[image]

Writes a reference to the specified style. The style is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteStyle (
Style style,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteStyle( _
style As Style, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

style

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteSvg Method

XmlPersistContext.WriteSvg Method
[image]

Writes a reference to the specified SVG. The SVG is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteSvg (
SvgContent svg,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteSvg( _
svg As SvgContent, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

svg

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteTag Method

XmlPersistContext.WriteTag Method
[image]

Writes the specified tag of the specified object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteTag (
Object item,
Object tagValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteTag( _
item As Object, _
tagValue As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

item

tagValue

elementName

parentElement

Return Value

Remarks

Tags are written similarly to arbitrary objects except that the client of the diagram is given a chance to perform custom serialization through event handling.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteTheme Method

XmlPersistContext.WriteTheme Method
[image]

Writes the specified Theme object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteTheme (
Theme theme,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteTheme( _
theme As Theme, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

theme

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteThickness Method

XmlPersistContext.WriteThickness Method
[image]

Writes a Thickness with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteThickness (
Thickness thickness,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteThickness( _
thickness As Thickness, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

thickness

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteTraits Method

XmlPersistContext.WriteTraits Method
[image]

Writes the specified traits hashtable.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteTraits (
Hashtable traits,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteTraits( _
traits As Hashtable, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

traits

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteUInt Method

XmlPersistContext.WriteUInt Method
[image]

Writes an unsigned integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteUInt (
uint uintValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteUInt( _
uintValue As UInteger, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

uintValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteULong Method

XmlPersistContext.WriteULong Method
[image]

Writes an unsigned long value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteULong (
ulong ulongValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteULong( _
ulongValue As ULong, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

ulongValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteUShort Method

XmlPersistContext.WriteUShort Method
[image]

Writes an unsigned short value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteUShort (
ushort ushortValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteUShort( _
ushortValue As UShort, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

ushortValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteVisioContent Method

XmlPersistContext.WriteVisioContent Method
[image]

Writes a reference to the specified Visio content. The content is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlElement WriteVisioContent (
VisioContent content,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteVisioContent( _
content As VisioContent, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

content

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext Properties

XmlPersistContext Properties
[image]

Public Properties

Name | Description
BaseURI | Gets or sets the base URI of the XML document being loaded or saved. When not specified, the BaseURI of the underlying XmlDocument is used.
ClassVersion | Gets the class version of the currently deserialized item.
Diagram | Gets the underlying diagram object.
FileVersion | Gets the format revision number for the file being currently serialized.
IncludeUnalteredProperties | Gets or sets a value specifies whether properties that have their default value should be serialized to XML.
XmlDocument | Gets the underlying XML document.

See Also

XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.BaseURI Property

XmlPersistContext.BaseURI Property
[image]

Gets or sets the base URI of the XML document being loaded or saved. When not specified, the BaseURI of the underlying XmlDocument is used.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string BaseURI { get; set; }

Visual Basic [image] Copy Code

Public Property BaseURI As String

Property Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ClassVersion Property

XmlPersistContext.ClassVersion Property
[image]

Gets the class version of the currently deserialized item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ClassVersion { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ClassVersion As Integer

Property Value

An integer value specifying the class version.

Remarks

This property is only useful when deserializing items.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.Diagram Property

XmlPersistContext.Diagram Property
[image]

Gets the underlying diagram object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Diagram Diagram { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Diagram As Diagram

Property Value

An instance of the Diagram class.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.FileVersion Property

XmlPersistContext.FileVersion Property
[image]

Gets the format revision number for the file being currently serialized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int FileVersion { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property FileVersion As Integer

Property Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.IncludeUnalteredProperties Property

XmlPersistContext.IncludeUnalteredProperties Property
[image]

Gets or sets a value specifies whether properties that have their default value should be serialized to XML.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IncludeUnalteredProperties { get; set; }

Visual Basic [image] Copy Code

Public Property IncludeUnalteredProperties As Boolean

Property Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.XmlDocument Property

XmlPersistContext.XmlDocument Property
[image]

Gets the underlying XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlDocument XmlDocument { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property XmlDocument As XmlDocument

Property Value

An instance of the .NET XmlDocument class.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.Export Namespace

MindFusion.Diagramming.Export Namespace
Classes Enumerations

Classes

Class | Description
DxfExporter | Exports diagrams to AutoDesk Drawing Exchange Format (DXF) files.
PdfExporter | Exports diagrams to Adobe Portable Document Format (PDF) files.
SvgExporter | Creates SVG (Scalable Vector Graphics) drawings from the content of Diagram objects.
SwfExporter | Creates Adobe Flash files representing the content of a diagram.
Visio2013Exporter | Exports the contents of Diagram or DiagramDocument objects to Visio 2013 XML drawing files (*.vsdx).
VisioExporter | Exports diagrams to Visio 2003 XML Drawing files (*.vdx).
WmfExporter | Creates WMF (Windows MetaFile) images from the content of Diagram objects.

Enumerations

Enumeration | Description
AutoScale | Specifies the auto-scale mode when exporting to a PDF document.
ExportLanes | Defines values that indicate how the LaneGrid should be exported to Visio.


MindFusion.Diagramming.Export.AutoScale Enumeration

AutoScale Enumeration
[image]

Specifies the auto-scale mode when exporting to a PDF document.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C# [image] Copy Code

public enum AutoScale

Visual Basic [image] Copy Code

Public Enum AutoScale

Members

Member name | Description
None | No automatic scaling.
FitToPage | Scales the chart (aspect ratio is preserved) to fit the page bounds if the document is too large.
FitToPageNoUpScale | Scales down the chart (aspect ratio is preserved) to fit the page bounds if the document is too large. Otherwise chart's size is left untouched.
FitToWidth | Scales down the chart (aspect ratio is preserved) to make sure that the width of the chart is less than the width of the PDF page.

See Also

MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.DxfExporter Class

DxfExporter Class
Remarks See Also
[image]

Exports diagrams to AutoDesk Drawing Exchange Format (DXF) files.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Dxf

Syntax

C# [image] Copy Code

public class DxfExporter

Visual Basic [image] Copy Code

Public Class DxfExporter

Remarks

In order to use this component, add a reference to the MindFusion.Diagramming.Export.Dxf.dll to your project.

AutoCAD DXF (Drawing Exchange Format) is a file format developed by Autodesk to enable interoperability between AutoCAD and other programs. Now virtually every CAD application and most graphics programs can import DXF files.

To create a DXF file from a MvcDiagram diagram, create a DxfExporter instance and call its Export method, specifying a Diagram object and a file path as arguments.

Raster images can be used in DXF by referencing external image files. To avoid creating extraneous files, DxfExporter does not export images by default. To export the images displayed in diagram elements, enable the ExportImages property.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Export.DxfExporter

See Also

DxfExporter Members
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.DxfExporter Members

DxfExporter Members
Constructors Properties Methods
[image]

Exports diagrams to AutoDesk Drawing Exchange Format (DXF) files.

The following tables list the members exposed by the DxfExporter type.

Public Constructors

Name | Description
DxfExporter | Initializes a new instance of the DxfExporter class.

Public Properties

Name | Description
ExportImages | Gets or sets a value indicating whether the images that are displayed inside diagram nodes should be exported.
ExportTextAsMultiline | Gets or sets a value indicating whether item labels should be exported to DXF MTEXT entities.

Public Methods

Name | Description
Export | Creates a DXF file representing the specified MvcDiagram diagram.

See Also

DxfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.DxfExporter Constructor

DxfExporter Constructor
[image]

Initializes a new instance of the DxfExporter class.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Dxf

Syntax

C# [image] Copy Code

public DxfExporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DxfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.DxfExporter Methods

DxfExporter Methods
[image]

Public Methods

Name | Description
Export | Creates a DXF file representing the specified MvcDiagram diagram.

See Also

DxfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.DxfExporter.Export Method

DxfExporter.Export Method
[image]

Creates a DXF file representing the specified MvcDiagram diagram.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Dxf

Syntax

C# [image] Copy Code

public void Export (
Diagram diagram,
string filePath
)

Visual Basic [image] Copy Code

Public Sub Export ( _
diagram As Diagram, _
filePath As String _
)

Parameters

diagram

A reference to the diagram to be exported.

filePath

The full path to the .dxf file.

Remarks

Each MvcDiagram node or link is exported as a group of graphic primitives, such as lines and arcs, defined as DXF entities. DxfExporter uses the entities defined in version 14 of the DXF format.

See Also

DxfExporter Members
DxfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.DxfExporter Properties

DxfExporter Properties
[image]

Public Properties

Name | Description
ExportImages | Gets or sets a value indicating whether the images that are displayed inside diagram nodes should be exported.
ExportTextAsMultiline | Gets or sets a value indicating whether item labels should be exported to DXF MTEXT entities.

See Also

DxfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.DxfExporter.ExportImages Property

DxfExporter.ExportImages Property
[image]

Gets or sets a value indicating whether the images that are displayed inside diagram nodes should be exported.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Dxf

Syntax

C# [image] Copy Code

public bool ExportImages { get; set; }

Visual Basic [image] Copy Code

Public Property ExportImages As Boolean

Property Value

true to export images; otherwise, false. The default is false.

Remarks

If this property is enabled, images displayed in MvcDiagram nodes are saved into external files and references to these files are placed inside the generated DXF code. The image files have the same base name as the specified DXF name, followed by an underscore symbol and a sequential number.

See Also

DxfExporter Members
DxfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.DxfExporter.ExportTextAsMultiline Property

DxfExporter.ExportTextAsMultiline Property
[image]

Gets or sets a value indicating whether item labels should be exported to DXF MTEXT entities.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Dxf

Syntax

C# [image] Copy Code

public bool ExportTextAsMultiline { get; set; }

Visual Basic [image] Copy Code

Public Property ExportTextAsMultiline As Boolean

Property Value

true to create multiple-line text entities, otherwise, false. The default is true.

Remarks

Some applications do not support the multiple-line text DXF entity - MTEXT. If you notice that the application you target does not display the labels of diagram items, set this property to false.

See Also

DxfExporter Members
DxfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.ExportLanes Enumeration

ExportLanes Enumeration
[image]

Defines values that indicate how the LaneGrid should be exported to Visio.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C# [image] Copy Code

public enum ExportLanes

Visual Basic [image] Copy Code

Public Enum ExportLanes

Members

Member name | Description
None | Do not export the swimlane grid.
Horizontal | Export the grid as horizontal functional band shapes.
Vertical | Export the grid as vertical functional band shapes.

See Also

MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter Class

PdfExporter Class
Remarks See Also
[image]

Exports diagrams to Adobe Portable Document Format (PDF) files.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C# [image] Copy Code

public class PdfExporter

Visual Basic [image] Copy Code

Public Class PdfExporter

Remarks

In order to use this component, add references to the MindFusion.Diagramming.Export.Pdf.dll and MindFusion.Pdf.dll assemblies to your project.

The Adobe Portable Document Format (PDF) is the most popular open format for representing textual and graphic information in resolution independent manner. In addition, PDF is a multiplatform format, viewable and printable on all popular operating systems. These features, along with its ability to describe complex documents that use a variety of graphics, images and fonts, make PDF a good choice when it comes to distributing your flowcharts and diagrams to others.

The PdfExporter class lets you create PDF files that represent MvcDiagram diagrams. In order to do that, create a PdfExporter instance and call its Export method. If you need to set the page size and orientation, use the PageSize, and PageOrientation properties. Margins specifies the page margins for all pages in the document. The AutoScale property lets you scale the diagram so it fits in one or more PDF pages.

Pages can display optional headers and footers. Set the HeaderFormat and HeaderFont properties to customize headers, and the FooterFormat and FooterFont properties to customize footers.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Export.PdfExporter

See Also

PdfExporter Members
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter Members

PdfExporter Members
Constructors Properties Methods
[image]

Exports diagrams to Adobe Portable Document Format (PDF) files.

The following tables list the members exposed by the PdfExporter type.

Public Constructors

Name | Description
PdfExporter | Initializes a new instance of the PdfExporter class.

Public Properties

Name | Description
AutoDetectEncoding | Specifies whether character encoding should be detected automatically.
AutoScale | Gets or sets a value indicating whether the diagram should be scaled to fit one or more pages of the PDF document.
DefaultEncoding | Specifies what encoding to use if the encoding for a string cannot be recognized automatically.
DisableTextClipping | A work-around for Adobe Reader V9 issue when printing to Postscript printers.
EnableBackground | Specifies whether to fill the background with color.
EnableGrid | Gets or sets a value indicating whether the alignment grid is rendered.
FontCachePath | Specifies the path to a file that contains font metrics records.
FooterFont | Gets or sets the font used to draw page footers.
FooterFormat | Gets or sets a string specifying the content of page footers.
HeaderFont | Gets or sets the font used to draw page headers.
HeaderFormat | Gets or sets a string specifying the content of page headers.
HyperLinkStyle | Specifies what kind of hyperlinks should be generated for the HyperLink property of items.
InvisibleItems | Gets or sets a value indicating whether invisible items should be exported.
JpegImageEncoding | Specifies whether images embedded in PDF should be encoded in Jpeg format.
JpegImageQuality | Specifies the image quality of Jpeg images.
Margins | Gets or sets the margins for the PDF pages.
PageOrientation | Gets or sets the orientation of the PDF pages.
PageSize | Gets or sets the size of the PDF pages.
RenderOptions | Gets a RenderOptions instance that provides various settings for configuring the appearance of exported diagrams.
Scale | Gets or sets the scale of the PDF output relatively to the original on-screen size of the diagram.
SuppressUnmanagedCode | Suppress usage of unmanaged code.

Public Methods

Name | Description
Export | Overloaded.

See Also

PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter Constructor

PdfExporter Constructor
[image]

Initializes a new instance of the PdfExporter class.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C# [image] Copy Code

public PdfExporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter Methods

PdfExporter Methods
[image]

Public Methods

Name | Description
Export | Overloaded.

See Also

PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter.Export Method

PdfExporter.Export Method
[image]

Overload List

Name | Description
PdfExporter.Export (Diagram, String) | Creates a PDF file representing the specified MvcDiagram diagram.
PdfExporter.Export (DiagramDocument, String) | Creates a PDF file representing the specified DiagramDocument.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter.Export Method (Diagram, String)

PdfExporter.Export Method (Diagram, String)
See Also
[image]

Creates a PDF file representing the specified MvcDiagram diagram.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C# [image] Copy Code

public void Export (
Diagram diagram,
string filePath
)

Visual Basic [image] Copy Code

Public Sub Export ( _
diagram As Diagram, _
filePath As String _
)

Parameters

diagram

A reference to the diagram that will be exported.

filePath

The full path to the PDF file.

Remarks

By default, PdfExporter preserves the original scale of the diagram. If Bounds can not fit in a single page of size PageSize, the exported diagram is divided into multiple pages. The AutoScale property allows scaling the diagram so that it exactly fits in one or more pages.

See Also

Export Method Overload List
PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter.Export Method (DiagramDocument, String)

PdfExporter.Export Method (DiagramDocument, String)
See Also
[image]

Creates a PDF file representing the specified DiagramDocument.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C# [image] Copy Code

public void Export (
DiagramDocument diagramDoc,
string filePath
)

Visual Basic [image] Copy Code

Public Sub Export( _
diagramDoc As DiagramDocument, _
filePath As String _
)

Parameters

diagramDoc

A reference to the DiagramDocument that will be exported.

filePath

The full path to the PDF file.

Remarks

If PdfExporter.Size is set to DiagramSize, the number of pages in the output PDF is equal to DiagramDocument.Pages.Count and each PDF page is as large as the respective DiagramPage.Bounds. Otherwise, all diagram pages are paginated using the specified PDF page size (A4 etc).

See Also

Export Method Overload List
PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter Properties

PdfExporter Properties
[image]

Public Properties

Name | Description
AutoDetectEncoding | Specifies whether character encoding should be detected automatically.
AutoScale | Gets or sets a value indicating whether the diagram should be scaled to fit one or more pages of the PDF document.
DefaultEncoding | Specifies what encoding to use if the encoding for a string cannot be recognized automatically.
DisableTextClipping | A work-around for Adobe Reader V9 issue when printing to Postscript printers.
EnableBackground | Specifies whether to fill the background with color.
EnableGrid | Gets or sets a value indicating whether the alignment grid is rendered.
FontCachePath | Specifies the path to a file that contains font metrics records.
FooterFont | Gets or sets the font used to draw page footers.
FooterFormat | Gets or sets a string specifying the content of page footers.
HeaderFont | Gets or sets the font used to draw page headers.
HeaderFormat | Gets or sets a string specifying the content of page headers.
HyperLinkStyle | Specifies what kind of hyperlinks should be generated for the HyperLink property of items.
InvisibleItems | Gets or sets a value indicating whether invisible items should be exported.
JpegImageEncoding | Specifies whether images embedded in PDF should be encoded in Jpeg format.
JpegImageQuality | Specifies the image quality of Jpeg images.
Margins | Gets or sets the margins for the PDF pages.
PageOrientation | Gets or sets the orientation of the PDF pages.
PageSize | Gets or sets the size of the PDF pages.
RenderOptions | Gets a RenderOptions instance that provides various settings for configuring the appearance of exported diagrams.
Scale | Gets or sets the scale of the PDF output relatively to the original on-screen size of the diagram.
SuppressUnmanagedCode | Suppress usage of unmanaged code.

See Also

PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter.AutoDetectEncoding Property

PdfExporter.AutoDetectEncoding Property
[image]

Specifies whether character encoding should be detected automatically.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C# [image] Copy Code

public bool AutoDetectEncoding { get; set; }

Visual Basic [image] Copy Code

Public Property AutoDetectEncoding As Boolean

Property Value

true to detect character encoding automatically, otherwise false. The default value is true.

Remarks

If this property is disabled, the PDF encoding is always set to the DefaultEncoding value.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter.AutoScale Property

PdfExporter.AutoScale Property
[image]

Gets or sets a value indicating whether the diagram should be scaled to fit one or more pages of the PDF document.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C# [image] Copy Code

public AutoScale AutoScale { get; set; }

Visual Basic [image] Copy Code

Public Property AutoScale As AutoScale

Property Value

A member of the AutoScale enumeration. The default is None.

Remarks

By default, the original scale of the diagram is preserved and the diagram is divided into multiple pages if needed. This property lets you scale the diagram so that it exactly fits in one or more pages.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace
PageSize Property
Scale Property


MindFusion.Diagramming.Export.PdfExporter.DefaultEncoding Property

PdfExporter.DefaultEncoding Property
[image]

Specifies what encoding to use if the encoding for a string cannot be recognized automatically.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C# [image] Copy Code

public Encoding DefaultEncoding { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultEncoding As Encoding

Property Value

An instance of the System.Text.Encoding class.

Remarks

PDF text encoding is set to this value if automatic encoding detection fails or when any of the AutoDetectEncoding and SuppressUnmanagedCode properties are disabled.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter.DisableTextClipping Property

PdfExporter.DisableTextClipping Property
[image]

A work-around for Adobe Reader V9 issue when printing to Postscript printers.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C# [image] Copy Code

public bool DisableTextClipping { get; set; }

Visual Basic [image] Copy Code

Public Property DisableTextClipping As Boolean

Property Value

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter.EnableBackground Property

PdfExporter.EnableBackground Property
[image]

Specifies whether to fill the background with color.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C# [image] Copy Code

public bool EnableBackground { get; set; }

Visual Basic [image] Copy Code

Public Property EnableBackground As Boolean

Property Value

true to paint the page background with the diagram's BackBrush, otherwise false. The default value is true.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter.EnableGrid Property

PdfExporter.EnableGrid Property
[image]

Gets or sets a value indicating whether the alignment grid is rendered.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C# [image] Copy Code

public bool EnableGrid { get; set; }

Visual Basic [image] Copy Code

Public Property EnableGrid As Boolean

Property Value

true to render the alignment grid, if visible; otherwise, false.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter.FontCachePath Property

PdfExporter.FontCachePath Property
[image]

Specifies the path to a file that contains font metrics records.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C# [image] Copy Code

public string FontCachePath { get; set; }

Visual Basic [image] Copy Code

Public Property FontCachePath As String

Property Value

A string specifying the full path to pdflib-fontrecords.xml.

Remarks

This property must be set if SuppressUnmanagedCode is disabled.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter.FooterFont Property

PdfExporter.FooterFont Property
[image]

Gets or sets the font used to draw page footers.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C# [image] Copy Code

public Font FooterFont { get; set; }

Visual Basic [image] Copy Code

Public Property FooterFont As Font

Property Value

A System.Drawing.Font instance.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter.FooterFormat Property

PdfExporter.FooterFormat Property
[image]

Gets or sets a string specifying the content of page footers.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C# [image] Copy Code

public string FooterFormat { get; set; }

Visual Basic [image] Copy Code

Public Property FooterFormat As String

Property Value

A string specifying the footer content. The default value is null.

Remarks

A %P placeholder in this string is replaced with the current page number.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter.HeaderFont Property

PdfExporter.HeaderFont Property
[image]

Gets or sets the font used to draw page headers.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C# [image] Copy Code

public Font HeaderFont { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderFont As Font

Property Value

A System.Drawing.Font instance.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter.HeaderFormat Property

PdfExporter.HeaderFormat Property
[image]

Gets or sets a string specifying the content of page headers.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C# [image] Copy Code

public string HeaderFormat { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderFormat As String

Property Value

A string specifying the header content. The default value is null.

Remarks

A %P placeholder in this string is replaced with the current page number.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter.HyperLinkStyle Property

PdfExporter.HyperLinkStyle Property
[image]

Specifies what kind of hyperlinks should be generated for the HyperLink property of items.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C# [image] Copy Code

public HyperLinkStyle HyperLinkStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HyperLinkStyle As HyperLinkStyle

Property Value

A member of the HyperLinkStyle enumeration. The default is Text.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter.InvisibleItems Property

PdfExporter.InvisibleItems Property
[image]

Gets or sets a value indicating whether invisible items should be exported.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C# [image] Copy Code

public bool InvisibleItems { get; set; }

Visual Basic [image] Copy Code

Public Property InvisibleItems As Boolean

Property Value

true if invisible items should be displayed in the PDF; otherwise, false. The default is false.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter.JpegImageEncoding Property

PdfExporter.JpegImageEncoding Property
[image]

Specifies whether images embedded in PDF should be encoded in Jpeg format.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C# [image] Copy Code

public bool JpegImageEncoding { get; set; }

Visual Basic [image] Copy Code

Public Property JpegImageEncoding As Boolean

Property Value

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter.JpegImageQuality Property

PdfExporter.JpegImageQuality Property
[image]

Specifies the image quality of Jpeg images.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C# [image] Copy Code

public int JpegImageQuality { get; set; }

Visual Basic [image] Copy Code

Public Property JpegImageQuality As Integer

Property Value

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter.Margins Property

PdfExporter.Margins Property
[image]

Gets or sets the margins for the PDF pages.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C# [image] Copy Code

public Margins Margins { get; set; }

Visual Basic [image] Copy Code

Public Property Margins As Margins

Property Value

An instance of the .NET Margins class that represents the margins in hundredths of an inch. The default is half-inch margins on all sides.

Example

The following C# code creates a PDF file with one-inch page margins:

C# [image] Copy Code

PdfExporter exp = new PdfExporter();
exp.Margins = new System.Drawing.Printing.Margins(100, 100, 100, 100);
exp.Export(diagram, @"D:\diagram.pdf");

Visual Basic [image] Copy Code

Dim exp As New PdfExporter
exp.Margins = New System.Drawing.Printing.Margins(100, 100, 100, 100)
exp.Export(diagram, "D:\diagram.pdf")

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace
PageSize Property


MindFusion.Diagramming.Export.PdfExporter.PageOrientation Property

PdfExporter.PageOrientation Property
[image]

Gets or sets the orientation of the PDF pages.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C# [image] Copy Code

public PageOrientation PageOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property PageOrientation As PageOrientation

Property Value

A member of the PageOrientation enumeration. The default is Portrait. The members of the PageOrientation enumeration are: Landscape, Portrait or Auto.

Remarks

If the Auto value is set, PdfExporter will choose the appropriate orientation according to the proportion of width to height of the diagram.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace
PageSize Property


MindFusion.Diagramming.Export.PdfExporter.PageSize Property

PdfExporter.PageSize Property
[image]

Gets or sets the size of the PDF pages.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C# [image] Copy Code

public PageSize PageSize { get; set; }

Visual Basic [image] Copy Code

Public Property PageSize As PageSize

Property Value

A member of the PageSize enumeration. The default is A4.

Remarks

The diagram is divided into multiple pages of the specified size, as long as AutoScale is not set to FitToPage.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace
PageOrientation Property
Margins Property


MindFusion.Diagramming.Export.PdfExporter.RenderOptions Property

PdfExporter.RenderOptions Property
[image]

Gets a RenderOptions instance that provides various settings for configuring the appearance of exported diagrams.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C# [image] Copy Code

public RenderOptions RenderOptions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RenderOptions As RenderOptions

Property Value

A RenderOptions reference.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter.Scale Property

PdfExporter.Scale Property
[image]

Gets or sets the scale of the PDF output relatively to the original on-screen size of the diagram.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C# [image] Copy Code

public float Scale { get; set; }

Visual Basic [image] Copy Code

Public Property Scale As Single

Property Value

A float value specifying the scale as percent of the original size. The default is 100.

Remarks

This value is used only if AutoScale is disabled.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter.SuppressUnmanagedCode Property

PdfExporter.SuppressUnmanagedCode Property
[image]

Suppress usage of unmanaged code.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C# [image] Copy Code

public bool SuppressUnmanagedCode { get; set; }

Visual Basic [image] Copy Code

Public Property SuppressUnmanagedCode As Boolean

Property Value

true to prevent the component from using unmanaged code; false to allow it. The default value is false.

Remarks

Unmanaged code is not allowed to run when the ASP.NET security level is set to Medium Trust. However PdfExporter relies on native Win32 calls to get some precise font metrics which are otherwise inaccessible through the .NET base class library. To work around this, the component now comes with a "pdflib-fontrecords.xml" file that contains cached information about fonts. The FontCachePath property must point to the location of this file when SuppressUnmanagedCode is enabled.

Unmanaged code is also used to detect character encoding automatically. When it is suppressed, PDF encoding is always set to the value of DefaultEncoding.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SvgExporter Class

SvgExporter Class
Remarks See Also
[image]

Creates SVG (Scalable Vector Graphics) drawings from the content of Diagram objects.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Svg

Syntax

C# [image] Copy Code

public class SvgExporter

Visual Basic [image] Copy Code

Public Class SvgExporter

Remarks

In order to use this component, add references to the MindFusion.Diagramming.Export.Svg.dll and MindFusion.Svg.dll assemblies to your project.

Scalable Vector Graphics is an XML-based graphics language that describes images with vector shapes, text, and embedded raster graphics. SVG files can be displayed in a browser using the Adobe SVG Viewer. The most popular vector graphics editing applications provide support for SVG too.

In order to create an SVG file from a MvcDiagram diagram, create an SvgExporter instance and call its Export method, passing a Diagram object as parameter.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Export.SvgExporter

See Also

SvgExporter Members
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SvgExporter Members

SvgExporter Members
Constructors Properties Methods
[image]

Creates SVG (Scalable Vector Graphics) drawings from the content of Diagram objects.

The following tables list the members exposed by the SvgExporter type.

Public Constructors

Name | Description
SvgExporter | Initializes a new instance of the SvgExporter class.

Public Properties

Name | Description
ExternalImages | Specifies whether images displayed by diagram items should be exported to external files.
GZipCompression | Specifies whether to create GZip compressed SVG.
HyperLinkStyle | Specifies what kind of hyperlinks should be generated for the HyperLink property of items.
HyperLinkTarget | Specify the value of the target attribute generated for the HyperLink property of items.
RenderOptions | Gets a RenderOptions instance that provides various settings for configuring the appearance of exported diagrams.

Public Methods

Name | Description
Export | Creates an SVG file representing the specified diagram.

See Also

SvgExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SvgExporter Constructor

SvgExporter Constructor
[image]

Initializes a new instance of the SvgExporter class.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Svg

Syntax

C# [image] Copy Code

public SvgExporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SvgExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SvgExporter Methods

SvgExporter Methods
[image]

Public Methods

Name | Description
Export | Creates an SVG file representing the specified diagram.

See Also

SvgExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SvgExporter.Export Method

SvgExporter.Export Method
[image]

Creates an SVG file representing the specified diagram.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Svg

Syntax

C# [image] Copy Code

public void Export (
Diagram diagram,
string filePath
)

Visual Basic [image] Copy Code

Public Sub Export ( _
diagram As Diagram, _
filePath As String _
)

Parameters

diagram

A reference to the diagram to be exported.

filePath

A full path to the .svg file.

See Also

SvgExporter Members
SvgExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SvgExporter Properties

SvgExporter Properties
[image]

Public Properties

Name | Description
ExternalImages | Specifies whether images displayed by diagram items should be exported to external files.
GZipCompression | Specifies whether to create GZip compressed SVG.
HyperLinkStyle | Specifies what kind of hyperlinks should be generated for the HyperLink property of items.
HyperLinkTarget | Specify the value of the target attribute generated for the HyperLink property of items.
RenderOptions | Gets a RenderOptions instance that provides various settings for configuring the appearance of exported diagrams.

See Also

SvgExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SvgExporter.ExternalImages Property

SvgExporter.ExternalImages Property
[image]

Specifies whether images displayed by diagram items should be exported to external files.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Svg

Syntax

C# [image] Copy Code

public bool ExternalImages { get; set; }

Visual Basic [image] Copy Code

Public Property ExternalImages As Boolean

Property Value

true to export images to external files; false to keep them as inline binary data in the SVG file. The default is false.

See Also

SvgExporter Members
SvgExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SvgExporter.GZipCompression Property

SvgExporter.GZipCompression Property
[image]

Specifies whether to create GZip compressed SVG.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Svg

Syntax

C# [image] Copy Code

public bool GZipCompression { get; set; }

Visual Basic [image] Copy Code

Public Property GZipCompression As Boolean

Property Value

See Also

SvgExporter Members
SvgExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SvgExporter.HyperLinkStyle Property

SvgExporter.HyperLinkStyle Property
[image]

Specifies what kind of hyperlinks should be generated for the HyperLink property of items.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Svg

Syntax

C# [image] Copy Code

public HyperLinkStyle HyperLinkStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HyperLinkStyle As HyperLinkStyle

Property Value

A member of the HyperLinkStyle enumeration. The default is Text.

See Also

SvgExporter Members
SvgExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SvgExporter.HyperLinkTarget Property

SvgExporter.HyperLinkTarget Property
[image]

Specify the value of the target attribute generated for the HyperLink property of items.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Svg

Syntax

C# [image] Copy Code

public string HyperLinkTarget { get; set; }

Visual Basic [image] Copy Code

Public Property HyperLinkTarget As String

Property Value

The default is "_self".

See Also

SvgExporter Members
SvgExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SvgExporter.RenderOptions Property

SvgExporter.RenderOptions Property
[image]

Gets a RenderOptions instance that provides various settings for configuring the appearance of exported diagrams.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Svg

Syntax

C# [image] Copy Code

public RenderOptions RenderOptions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RenderOptions As RenderOptions

Property Value

A RenderOptions reference.

See Also

SvgExporter Members
SvgExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SwfExporter Class

SwfExporter Class
Remarks See Also
[image]

Creates Adobe Flash files representing the content of a diagram.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Swf

Syntax

C# [image] Copy Code

public class SwfExporter

Visual Basic [image] Copy Code

Public Class SwfExporter

Remarks

In order to use this component, add references to the MindFusion.Diagramming.Export.Swf.dll and MindFusion.Swf.dll assemblies to your project.

In order to create an SWF file from a diagram, create an SwfExporter instance and call its Export method, passing a Diagram object as parameter. At the time of writing this, the diagram is exported as static image; interactivity is planned for next releases.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Export.SwfExporter

See Also

SwfExporter Members
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SwfExporter Members

SwfExporter Members
Constructors Properties Methods
[image]

Creates Adobe Flash files representing the content of a diagram.

The following tables list the members exposed by the SwfExporter type.

Public Constructors

Name | Description
SwfExporter | Initializes a new instance of the SwfExporter class.

Public Properties

Name | Description
CreateHtmlPage | Specifies whether to create an html page to host the SWF file.
TextTransformsAsImages | Specify whether to use bitmap images to render text with unsupported text transforms.

Public Methods

Name | Description
Export | Creates an SWF file representing the specified diagram.

See Also

SwfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SwfExporter Constructor

SwfExporter Constructor
[image]

Initializes a new instance of the SwfExporter class.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Swf

Syntax

C# [image] Copy Code

public SwfExporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SwfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SwfExporter Methods

SwfExporter Methods
[image]

Public Methods

Name | Description
Export | Creates an SWF file representing the specified diagram.

See Also

SwfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SwfExporter.Export Method

SwfExporter.Export Method
[image]

Creates an SWF file representing the specified diagram.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Swf

Syntax

C# [image] Copy Code

public void Export (
Diagram diagram,
string filePath
)

Visual Basic [image] Copy Code

Public Sub Export( _
diagram As Diagram, _
filePath As String _
)

Parameters

diagram

A reference to the diagram that will be exported.

filePath

The full path to the SWF file.

See Also

SwfExporter Members
SwfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SwfExporter Properties

SwfExporter Properties
[image]

Public Properties

Name | Description
CreateHtmlPage | Specifies whether to create an html page to host the SWF file.
TextTransformsAsImages | Specify whether to use bitmap images to render text with unsupported text transforms.

See Also

SwfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SwfExporter.CreateHtmlPage Property

SwfExporter.CreateHtmlPage Property
[image]

Specifies whether to create an html page to host the SWF file.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Swf

Syntax

C# [image] Copy Code

public bool CreateHtmlPage { get; set; }

Visual Basic [image] Copy Code

Public Property CreateHtmlPage As Boolean

Property Value

true to create an accompanying HTML page, otherwise false. The default value is false.

Remarks

If this property is enabled, the component creates an HTML page that loads the Flash Player plugin and sets the exported file as its content. The page has the same name as the SWF file, but with its extension changed to "html".

See Also

SwfExporter Members
SwfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SwfExporter.TextTransformsAsImages Property

SwfExporter.TextTransformsAsImages Property
[image]

Specify whether to use bitmap images to render text with unsupported text transforms.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Swf

Syntax

C# [image] Copy Code

public bool TextTransformsAsImages { get; set; }

Visual Basic [image] Copy Code

Public Property TextTransformsAsImages As Boolean

Property Value

true to display transformed text using bitmap images, otherwise false. The default value is false.

Remarks

Adobe Flash cannot transform text rendered using external (non-embedded) fonts. Enable this property to create images in place of transformed text, e.g. one displayed in rotated nodes when their RotateText property is set to true.

See Also

SwfExporter Members
SwfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.Visio2013Exporter Class

Visio2013Exporter Class
Remarks See Also
[image]

Exports the contents of Diagram or DiagramDocument objects to Visio 2013 XML drawing files (*.vsdx).

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C# [image] Copy Code

public class Visio2013Exporter

Visual Basic [image] Copy Code

Public Class Visio2013Exporter

Remarks

Add a reference to the MindFusion.Diagramming.Export.Visio.dll to your project in order to use this component.

The component allows exporting Visio 2003 XML Drawing files from MindFusion.Diagramming. ShapeNode objects are mapped to their closest Visio counterparts and DiagramLink instances are exported as Visio connectors of a similar style. In addition, most of the attributes of diagram items such as text, text formatting, fill and line colors and styles are preserved.

To function properly, the exporter object requires the Visio2013.vxt file to be present in the application's directory, or its location specified in TemplatePath. This file contains an XML template data used by the component to generate Visio documents.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Export.Visio2013Exporter

See Also

Visio2013Exporter Members
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.Visio2013Exporter Members

Visio2013Exporter Members
Constructors Properties Methods
[image]

Exports the contents of Diagram or DiagramDocument objects to Visio 2013 XML drawing files (*.vsdx).

The following tables list the members exposed by the Visio2013Exporter type.

Public Constructors

Name | Description
Visio2013Exporter | Initializes a new instance of the Visio2013Exporter class.

Public Properties

Name | Description
TemplatePath | Gets or sets the full path to the 'Visio2013.vxt' template file.

Public Methods

Name | Description
Export | Overloaded.

See Also

Visio2013Exporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.Visio2013Exporter Constructor

Visio2013Exporter Constructor
[image]

Initializes a new instance of the Visio2013Exporter class.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C# [image] Copy Code

public Visio2013Exporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Visio2013Exporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.Visio2013Exporter Methods

Visio2013Exporter Methods
[image]

Public Methods

Name | Description
Export | Overloaded.

See Also

Visio2013Exporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.Visio2013Exporter.Export Method

Visio2013Exporter.Export Method
[image]

Overload List

Name | Description
Visio2013Exporter.Export (Diagram, String) | Creates a Visio .vsdx file representing the specified Diagram.
Visio2013Exporter.Export (DiagramDocument, String) | Creates a Visio .vsdx file representing the specified DiagramDocument.

See Also

Visio2013Exporter Members
Visio2013Exporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.Visio2013Exporter.Export Method (Diagram, String)

Visio2013Exporter.Export Method (Diagram, String)
See Also
[image]

Creates a Visio .vsdx file representing the specified Diagram.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C# [image] Copy Code

public void Export (
Diagram diagram,
string filePath
)

Visual Basic [image] Copy Code

Public Sub Export( _
diagram As Diagram, _
filePath As String _
)

Parameters

diagram

A Diagram instance.

filePath

The full path to the exported Visio .vsdx file.

Remarks

The exported document contains a single page, as big as the scrollable diagram area set in Bounds.

To run properly, this method requires the Visio2013.vxt file to be present in the application's directory, or its full path to be assigned to TemplatePath. That file contains an XML template data used by the component to construct Visio documents.

See Also

Export Method Overload List
Visio2013Exporter Members
Visio2013Exporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.Visio2013Exporter.Export Method (DiagramDocument, String)

Visio2013Exporter.Export Method (DiagramDocument, String)
See Also
[image]

Creates a Visio .vsdx file representing the specified DiagramDocument.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C# [image] Copy Code

public void Export (
DiagramDocument doc,
string filePath
)

Visual Basic [image] Copy Code

Public Sub Export( _
doc As DiagramDocument, _
filePath As String _
)

Parameters

doc

A DiagramDocument instance.

filePath

The full path to the exported Visio .vsdx file.

Remarks

Each DiagramPage in the document is exported to an individual Visio page. The title of the Visio page is set to DiagramPage.Title.

See Also

Export Method Overload List
Visio2013Exporter Members
Visio2013Exporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.Visio2013Exporter Properties

Visio2013Exporter Properties
[image]

Public Properties

Name | Description
TemplatePath | Gets or sets the full path to the 'Visio2013.vxt' template file.

See Also

Visio2013Exporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.Visio2013Exporter.TemplatePath Property

Visio2013Exporter.TemplatePath Property
[image]

Gets or sets the full path to the 'Visio2013.vxt' template file.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C# [image] Copy Code

public string TemplatePath { get; set; }

Visual Basic [image] Copy Code

Public Property TemplatePath As String

Property Value

A string specifying the template file location.

See Also

Visio2013Exporter Members
Visio2013Exporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.VisioExporter Class

VisioExporter Class
Remarks See Also
[image]

Exports diagrams to Visio 2003 XML Drawing files (*.vdx).

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C# [image] Copy Code

public class VisioExporter

Visual Basic [image] Copy Code

Public Class VisioExporter

Remarks

Add a reference to the MindFusion.Diagramming.Export.Visio.dll to your project in order to use this component.

The component allows exporting Visio 2003 XML Drawing files from MvcDiagram. The MvcDiagram ShapeNode objects are mapped to their closest Visio counterparts and TableNode objects are exported as groups of Visio shapes. MvcDiagram DiagramLink instances are exported as Visio connectors of a similar style. In addition, most of the attributes of diagram items such as text, text formatting, fill and line colors and styles are preserved.

To function properly, the exporter object requires the VisioExport.vxt file to be present in the application's directory. This file contains an XML template data used by the component to generate Visio documents.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Export.VisioExporter

See Also

VisioExporter Members
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.VisioExporter Members

VisioExporter Members
Constructors Properties Methods
[image]

Exports diagrams to Visio 2003 XML Drawing files (*.vdx).

The following tables list the members exposed by the VisioExporter type.

Public Constructors

Name | Description
VisioExporter | Initializes a new instance of the VisioExporter class.

Public Properties

Name | Description
CreateVisioGroups | Gets or sets a value indicating whether Visio groups are created from the MvcDiagram groups.
DynamicsOff | Gets or sets whether Visio connector rerouting should be disabled.
ExportImagesAsGroups | Specifies whether a shape node that contains an image should be exported as a Visio group of a shape, picture and text objects.
ExportInvisibleItems | Gets or sets a value indicating whether to export invisible items.
ExportLanes | Gets or sets a value specifying whether the LaneGrid should be exported to Visio.
ExportTablesAsGroups | Gets or sets a value indicating whether MvcDiagram TableNode objects should be exported as groups of Visio rectangular shapes.
LaneGridTitle | Gets or sets the title of the functional band container created when exporting the diagram's swimlane grid.
TemplatePath | Gets or sets the full path to the VisioExport.vxt template file.

Public Methods

Name | Description
ApproxColors | Approximate two color of gradient to get corresponded ACI.
Export | Overloaded.

See Also

VisioExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.VisioExporter Constructor

VisioExporter Constructor
[image]

Initializes a new instance of the VisioExporter class.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C# [image] Copy Code

public VisioExporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

VisioExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.VisioExporter Methods

VisioExporter Methods
[image]

Public Methods

Name | Description
ApproxColors | Approximate two color of gradient to get corresponded ACI.
Export | Overloaded.

See Also

VisioExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.VisioExporter.ApproxColors Method

VisioExporter.ApproxColors Method
[image]

Approximate two color of gradient to get corresponded ACI.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C# [image] Copy Code

public static Color ApproxColors (
Color cr1,
Color cr2
)

Visual Basic [image] Copy Code

Public Shared Function ApproxColors( _
cr1 As Color, _
cr2 As Color _
) As Color

Parameters

cr1

Color 1 of gradient

cr2

Color 2 of gradient

Return Value

See Also

VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.VisioExporter.Export Method

VisioExporter.Export Method
[image]

Overload List

Name | Description
VisioExporter.Export (Diagram, String) | Creates a Visio XML Drawing file representing the specified MvcDiagram diagram.
VisioExporter.Export (DiagramDocument, String) | Creates a Visio XML Drawing file representing the specified DiagramDocument object.

See Also

VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.VisioExporter.Export Method (Diagram, String)

VisioExporter.Export Method (Diagram, String)
See Also
[image]

Creates a Visio XML Drawing file representing the specified MvcDiagram diagram.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C# [image] Copy Code

public void Export (
Diagram diagram,
string vdxPathName
)

Visual Basic [image] Copy Code

Public Sub Export ( _
diagram As Diagram, _
vdxPathName As String _
)

Parameters

diagram

A reference to the diagram to be exported.

vdxPathName
The full path to the exported Visio .vdx file.

Remarks

The exported document contains a single page, as big as the MvcDiagram scrollable diagram area. The Visio page dimension and items size measure unit is set to the diagram's MeasureUnit.

To run properly, this method requires the VisioExport.vxt file to be present in the application's directory. That file contains an XML template data used by the component to construct Visio documents.

See Also

Export Method Overload List
VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.VisioExporter.Export Method (DiagramDocument, String)

VisioExporter.Export Method (DiagramDocument, String)
See Also
[image]

Creates a Visio XML Drawing file representing the specified DiagramDocument object.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C# [image] Copy Code

public void Export (
DiagramDocument diagramDoc,
string vdxPathName
)

Visual Basic [image] Copy Code

Public Sub Export( _
diagramDoc As DiagramDocument, _
vdxPathName As String _
)

Parameters

diagramDoc

A reference to the document to be exported.

vdxPathName

Full path to the exported Visio .vdx file.

Remarks

Each DiagramPage in the document is exported to an individual Visio page. The title of the Visio page is set to DiagramPage.Title.

See Also

Export Method Overload List
VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.VisioExporter Properties

VisioExporter Properties
[image]

Public Properties

Name | Description
CreateVisioGroups | Gets or sets a value indicating whether Visio groups are created from the MvcDiagram groups.
DynamicsOff | Gets or sets whether Visio connector rerouting should be disabled.
ExportImagesAsGroups | Specifies whether a shape node that contains an image should be exported as a Visio group of a shape, picture and text objects.
ExportInvisibleItems | Gets or sets a value indicating whether to export invisible items.
ExportLanes | Gets or sets a value specifying whether the LaneGrid should be exported to Visio.
ExportTablesAsGroups | Gets or sets a value indicating whether MvcDiagram TableNode objects should be exported as groups of Visio rectangular shapes.
LaneGridTitle | Gets or sets the title of the functional band container created when exporting the diagram's swimlane grid.
TemplatePath | Gets or sets the full path to the VisioExport.vxt template file.

See Also

VisioExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.VisioExporter.CreateVisioGroups Property

VisioExporter.CreateVisioGroups Property
[image]

Gets or sets a value indicating whether Visio groups are created from the MvcDiagram groups.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C# [image] Copy Code

public bool CreateVisioGroups { get; set; }

Visual Basic [image] Copy Code

Public Property CreateVisioGroups As Boolean

Property Value

true to create Visio groups when possible; otherwise, false. The default is false.

Remarks

It is not always possible to create a Visio group corresponding to a MvcDiagram one. If the structure of your diagram seems incorrect when imported in Visio, disable this property.

See Also

VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Export Namespace
ExportTablesAsGroups Property


MindFusion.Diagramming.Export.VisioExporter.DynamicsOff Property

VisioExporter.DynamicsOff Property
[image]

Gets or sets whether Visio connector rerouting should be disabled.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C# [image] Copy Code

public bool DynamicsOff { get; set; }

Visual Basic [image] Copy Code

Public Property DynamicsOff As Boolean

Property Value

See Also

VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.VisioExporter.ExportImagesAsGroups Property

VisioExporter.ExportImagesAsGroups Property
[image]

Specifies whether a shape node that contains an image should be exported as a Visio group of a shape, picture and text objects.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C# [image] Copy Code

public bool ExportImagesAsGroups { get; set; }

Visual Basic [image] Copy Code

Public Property ExportImagesAsGroups As Boolean

Property Value

true to export nodes with images as groups; otherwise, false. The default is true.

Remarks

Visio shapes cannot contain images inside them, and by default a MvcDiagram shape node that contains an image s exported as a Visio Picture object. Unfortunately, that leads to losing the node shape and the image alignment. Setting this property to true lets you export a shape node with an image as a group of several Visio objects that will preserve the appearance of the original MvcDiagram node as closely as possible.

See Also

VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Export Namespace
ExportTablesAsGroups Property


MindFusion.Diagramming.Export.VisioExporter.ExportInvisibleItems Property

VisioExporter.ExportInvisibleItems Property
[image]

Gets or sets a value indicating whether to export invisible items.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C# [image] Copy Code

public bool ExportInvisibleItems { get; set; }

Visual Basic [image] Copy Code

Public Property ExportInvisibleItems As Boolean

Property Value

true to export invisible items; otherwise, false.

See Also

VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.VisioExporter.ExportLanes Property

VisioExporter.ExportLanes Property
[image]

Gets or sets a value specifying whether the LaneGrid should be exported to Visio.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C# [image] Copy Code

public ExportLanes ExportLanes { get; set; }

Visual Basic [image] Copy Code

Public Property ExportLanes As ExportLanes

Property Value

A member of the ExportLanes enumeration. The default value is None.

Remarks

If export of swimlanes is enabled, they are exported as Visio Functional Band shapes.

See Also

VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.VisioExporter.ExportTablesAsGroups Property

VisioExporter.ExportTablesAsGroups Property
[image]

Gets or sets a value indicating whether MvcDiagram TableNode objects should be exported as groups of Visio rectangular shapes.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C# [image] Copy Code

public bool ExportTablesAsGroups { get; set; }

Visual Basic [image] Copy Code

Public Property ExportTablesAsGroups As Boolean

Property Value

true to export tables as groups; otherwise, false. The default is false.

Remarks

Visio table entities cannot display cells in multiple columns. If your MvcDiagram diagrams contains tables having more than two columns, consider enabling this property. Then the VisioExporter would create a rectangular shape for each cell, and group the cells of each table into a Visio compound shape corresponding to the table.

See Also

VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Export Namespace
ExportImagesAsGroups Property


MindFusion.Diagramming.Export.VisioExporter.LaneGridTitle Property

VisioExporter.LaneGridTitle Property
[image]

Gets or sets the title of the functional band container created when exporting the diagram's swimlane grid.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C# [image] Copy Code

public string LaneGridTitle { get; set; }

Visual Basic [image] Copy Code

Public Property LaneGridTitle As String

Property Value

A string specifying the title of the Functional Band container shape. The default value is empty string.

Remarks

When ExportLanes is enabled, VisioExporter create a Functional Band shape for each swimlane and a container shape for the whole grid. This property specifies the container's title.

See Also

VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.VisioExporter.TemplatePath Property

VisioExporter.TemplatePath Property
[image]

Gets or sets the full path to the VisioExport.vxt template file.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C# [image] Copy Code

public string TemplatePath { get; set; }

Visual Basic [image] Copy Code

Public Property TemplatePath As String

Property Value

A string specifying the location of the template file. The default is an empty string.

Remarks

If you do not specify the path to the template file, VisioExporter looks for the file in the same folder where the MindFusion.Diagramming.Export.Visio.dll assembly is, in the folder of the application executable file, and in the current folder. However that might not work under restricted security permissions, for example when running in a browser or in an IIS process.

See Also

VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.WmfExporter Class

WmfExporter Class
Remarks See Also
[image]

Creates WMF (Windows MetaFile) images from the content of Diagram objects.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Wmf

Syntax

C# [image] Copy Code

public class WmfExporter

Visual Basic [image] Copy Code

Public Class WmfExporter

Remarks

In order to use this component, add a reference to the MindFusion.Diagramming.Export.Wmf.dll assembly to your project. To create a WMF file from a diagram, create a WmfExporter instance and call its Export method, passing a Diagram object as parameter.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Export.WmfExporter

See Also

WmfExporter Members
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.WmfExporter Members

WmfExporter Members
Constructors Properties Methods
[image]

Creates WMF (Windows MetaFile) images from the content of Diagram objects.

The following tables list the members exposed by the WmfExporter type.

Public Constructors

Name | Description
WmfExporter | Initializes a new instance of the WmfExporter class.

Public Properties

Name | Description
Description | Gets or sets a description string associated with the metafile.
RenderOptions | Gets a RenderOptions instance that provides various settings for configuring the appearance of exported diagrams.

Public Methods

Name | Description
Export | Creates a WMF file representing the specified diagram.

See Also

WmfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.WmfExporter Constructor

WmfExporter Constructor
[image]

Initializes a new instance of the WmfExporter class.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Wmf

Syntax

C# [image] Copy Code

public WmfExporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

WmfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.WmfExporter Methods

WmfExporter Methods
[image]

Public Methods

Name | Description
Export | Creates a WMF file representing the specified diagram.

See Also

WmfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.WmfExporter.Export Method

WmfExporter.Export Method
[image]

Creates a WMF file representing the specified diagram.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Wmf

Syntax

C# [image] Copy Code

public void Export (
Diagram diagram,
string filePath
)

Visual Basic [image] Copy Code

Public Sub Export( _
diagram As Diagram, _
filePath As String _
)

Parameters

diagram

A reference to the diagram that will be exported.

filePath

The full path to the WMF file.

See Also

WmfExporter Members
WmfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.WmfExporter Properties

WmfExporter Properties
[image]

Public Properties

Name | Description
Description | Gets or sets a description string associated with the metafile.
RenderOptions | Gets a RenderOptions instance that provides various settings for configuring the appearance of exported diagrams.

See Also

WmfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.WmfExporter.Description Property

WmfExporter.Description Property
[image]

Gets or sets a description string associated with the metafile.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Wmf

Syntax

C# [image] Copy Code

public string Description { get; set; }

Visual Basic [image] Copy Code

Public Property Description As String

Property Value

A string specifying the metafile description. The default is an empty string.

See Also

WmfExporter Members
WmfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.WmfExporter.RenderOptions Property

WmfExporter.RenderOptions Property
[image]

Gets a RenderOptions instance that provides various settings for configuring the appearance of exported diagrams.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Wmf

Syntax

C# [image] Copy Code

public RenderOptions RenderOptions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RenderOptions As RenderOptions

Property Value

A RenderOptions reference.

See Also

WmfExporter Members
WmfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Import Namespace

MindFusion.Diagramming.Import Namespace
Classes

Classes

Class | Description
ConnectorImportedEventArgs | Contains the arguments passed to handlers of the ConnectorImported event.
DrawImporter | DrawImporter lets you import an OpenOffice Draw document into a Diagram or DiagramDocument object.
GroupImportedEventArgs | Contains the arguments passed to handlers of the GroupImported event.
ImportItemEventArgs | Contains the arguments passed to handlers of the ImportItem event.
ShapeImportedEventArgs | Contains the arguments passed to handlers of the ShapeImported event.
SvgImporter | SvgImporter lets you import the contents of an SVG file into a Diagram object.
Visio2013Importer | Imports Visio 2013 XML Drawing files (*.vsdx) into Diagram or DiagramDocument objects.
VisioImporter | Imports Visio 2003 XML Drawing files (*.vdx) into MvcDiagram.


MindFusion.Diagramming.Import.ConnectorImportedEventArgs Class

ConnectorImportedEventArgs Class
[image]

Contains the arguments passed to handlers of the ConnectorImported event.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public class ConnectorImportedEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ConnectorImportedEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Import.ConnectorImportedEventArgs

See Also

ConnectorImportedEventArgs Members
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ConnectorImportedEventArgs Members

ConnectorImportedEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the ConnectorImported event.

The following tables list the members exposed by the ConnectorImportedEventArgs type.

Public Properties

Name | Description
ConnectorXml | Gets the XML DOM element corresponding to the Visio document's XML code that describes the imported connector.
Link | Gets a reference to the imported diagram link.
ShapeName | Gets the Visio name of the connector shape.

See Also

ConnectorImportedEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ConnectorImportedEventArgs Properties

ConnectorImportedEventArgs Properties
[image]

Public Properties

Name | Description
ConnectorXml | Gets the XML DOM element corresponding to the Visio document's XML code that describes the imported connector.
Link | Gets a reference to the imported diagram link.
ShapeName | Gets the Visio name of the connector shape.

See Also

ConnectorImportedEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ConnectorImportedEventArgs.ConnectorXml Property

ConnectorImportedEventArgs.ConnectorXml Property
[image]

Gets the XML DOM element corresponding to the Visio document's XML code that describes the imported connector.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public XmlNode ConnectorXml { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ConnectorXml As XmlNode

Property Value

An XmlNode object corresponding to the section of the VDX document which describes the imported connector.

See Also

ConnectorImportedEventArgs Members
ConnectorImportedEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ConnectorImportedEventArgs.Link Property

ConnectorImportedEventArgs.Link Property
[image]

Gets a reference to the imported diagram link.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public DiagramLink Link { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Link As DiagramLink

Property Value

An instance of the DiagramLink class.

See Also

ConnectorImportedEventArgs Members
ConnectorImportedEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ConnectorImportedEventArgs.ShapeName Property

ConnectorImportedEventArgs.ShapeName Property
[image]

Gets the Visio name of the connector shape.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public string ShapeName { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ShapeName As String

Property Value

A string specifying the Visio name of the connector.

See Also

ConnectorImportedEventArgs Members
ConnectorImportedEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.DrawImporter Class

DrawImporter Class
Remarks See Also
[image]

DrawImporter lets you import an OpenOffice Draw document into a Diagram or DiagramDocument object.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Draw

Syntax

C# [image] Copy Code

public class DrawImporter

Visual Basic [image] Copy Code

Public Class DrawImporter

Remarks

The DrawImporter class can import .odg files, created by the OpenOffice Draw vector graphics editor. In order to use it, you must add a reference to the MindFusion.Diagramming.Import.Draw.dll assembly.

Various overloads of the Import method can be used to import the OpenOffice drawing into a DiagramDocument whose pages correspond to the Draw pages, or into a single Diagram whose content is merged from all imported pages. When merging multiple pages, their positions in the diagram depend on the PagesPerRow value.

DrawImporter supports shapes from the General and Flowchart shape palettes in Draw. For each node shape from the .odg file, the importer creates a ShapeNode object whose Shape, Text, Brush and Pen properties are set to values corresponding to the imported OpenOffice shape. For each connector shape, the importer creates a DiagramLink object whose Origin and Destination are set to the corresponding imported nodes, and whose ControlPoints reflect the geometry of the connector.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Import.DrawImporter

See Also

DrawImporter Members
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.DrawImporter Members

DrawImporter Members
Constructors Properties Methods
[image]

DrawImporter lets you import an OpenOffice Draw document into a Diagram or DiagramDocument object.

The following tables list the members exposed by the DrawImporter type.

Public Constructors

Name | Description
DrawImporter | Initializes a new instance of the DrawImporter class.

Public Properties

Name | Description
PagesPerRow | Gets or sets how many Draw pages to import on a row before offsetting the import location vertically.

Public Methods

Name | Description
Import | Overloaded.

See Also

DrawImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.DrawImporter Constructor

DrawImporter Constructor
[image]

Initializes a new instance of the DrawImporter class.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Draw

Syntax

C# [image] Copy Code

public DrawImporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DrawImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.DrawImporter Methods

DrawImporter Methods
[image]

Public Methods

Name | Description
Import | Overloaded.

See Also

DrawImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.DrawImporter.Import Method

DrawImporter.Import Method
[image]

Overload List

Name | Description
DrawImporter.Import (String) | Imports the specified OpenOffice Draw document into a new DiagramDocument, where each Draw page is imported into a separate DiagramPage of the DiagramDocument.
DrawImporter.Import (String, Diagram) | Imports the specified OpenOffice Draw document into the specified Diagram.
DrawImporter.Import (String, DiagramDocument) | Imports the specified OpenOffice Draw document into an existing DiagramDocument, where each Draw page is imported into a separate DiagramPage of the DiagramDocument.

See Also

DrawImporter Members
DrawImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.DrawImporter.Import Method (String)

DrawImporter.Import Method (String)
See Also
[image]

Imports the specified OpenOffice Draw document into a new DiagramDocument, where each Draw page is imported into a separate DiagramPage of the DiagramDocument.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Draw

Syntax

C# [image] Copy Code

public DiagramDocument Import (
string filePath
)

Visual Basic [image] Copy Code

Public Function Import( _
filePath As String _
) As DiagramDocument

Parameters

filePath

A string specifying the path to the .odg file.

Return Value

A DiagramDocument containing the imported OpenOffice drawing.

See Also

Import Method Overload List
DrawImporter Members
DrawImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.DrawImporter.Import Method (String, Diagram)

DrawImporter.Import Method (String, Diagram)
See Also
[image]

Imports the specified OpenOffice Draw document into the specified Diagram.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Draw

Syntax

C# [image] Copy Code

public void Import (
string filePath,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Sub Import( _
filePath As String, _
diagram As Diagram _
)

Parameters

filePath

A string specifying the path to the .odg file.

diagram

A Diagram into which to import the OpenOffice drawing.

Remarks

Objects from each subsequent Draw page are imported in the same Diagram, at an offset depending on the page size and the value of the PagesPerRow property.

See Also

Import Method Overload List
DrawImporter Members
DrawImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.DrawImporter.Import Method (String, DiagramDocument)

DrawImporter.Import Method (String, DiagramDocument)
See Also
[image]

Imports the specified OpenOffice Draw document into an existing DiagramDocument, where each Draw page is imported into a separate DiagramPage of the DiagramDocument.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Draw

Syntax

C# [image] Copy Code

public void Import (
string filePath,
DiagramDocument document
)

Visual Basic [image] Copy Code

Public Sub Import( _
filePath As String, _
document As DiagramDocument _
)

Parameters

filePath

A string specifying the path to the .odg file.

document

A DiagramDocument into which to import the OpenOffice drawing.

See Also

Import Method Overload List
DrawImporter Members
DrawImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.DrawImporter Properties

DrawImporter Properties
[image]

Public Properties

Name | Description
PagesPerRow | Gets or sets how many Draw pages to import on a row before offsetting the import location vertically.

See Also

DrawImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.DrawImporter.PagesPerRow Property

DrawImporter.PagesPerRow Property
[image]

Gets or sets how many Draw pages to import on a row before offsetting the import location vertically.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Draw

Syntax

C# [image] Copy Code

public int PagesPerRow { get; set; }

Visual Basic [image] Copy Code

Public Property PagesPerRow As Integer

Property Value

An integer value specifying how many pages to fit horizontally. The default value is 1.

Remarks

This property is considered by the Import overload that imports all pages into a single diagram.

See Also

DrawImporter Members
DrawImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.GroupImportedEventArgs Class

GroupImportedEventArgs Class
[image]

Contains the arguments passed to handlers of the GroupImported event.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public class GroupImportedEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class GroupImportedEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Import.GroupImportedEventArgs

See Also

GroupImportedEventArgs Members
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.GroupImportedEventArgs Members

GroupImportedEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the GroupImported event.

The following tables list the members exposed by the GroupImportedEventArgs type.

Public Properties

Name | Description
Group | Gets a reference to the imported group.

See Also

GroupImportedEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.GroupImportedEventArgs Properties

GroupImportedEventArgs Properties
[image]

Public Properties

Name | Description
Group | Gets a reference to the imported group.

See Also

GroupImportedEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.GroupImportedEventArgs.Group Property

GroupImportedEventArgs.Group Property
[image]

Gets a reference to the imported group.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public Group Group { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Group As Group

Property Value

An instance of the Group class.

See Also

GroupImportedEventArgs Members
GroupImportedEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ImportItemEventArgs Class

ImportItemEventArgs Class
[image]

Contains the arguments passed to handlers of the ImportItem event.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public class ImportItemEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ImportItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Import.ImportItemEventArgs

See Also

ImportItemEventArgs Members
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ImportItemEventArgs Members

ImportItemEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the ImportItem event.

The following tables list the members exposed by the ImportItemEventArgs type.

Public Properties

Name | Description
Item | Gets or sets the item that should represent the Visio shape specified by ShapeXml in the imported diagram.
MasterName | Gets the name associated with shape's master.
MasterXml | Gets the XML DOM element corresponding to the Visio document's XML code that describes the shape master.
NamespaceManager | Gets an XmlNamespaceManager instance with preloaded Visio namespaces that can be used when querying the XML elements provided by this ImportItemEventArgs instance.
ShapeXml | Gets the XML DOM element corresponding to the Visio document's XML code that describes the imported shape.

See Also

ImportItemEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ImportItemEventArgs Properties

ImportItemEventArgs Properties
[image]

Public Properties

Name | Description
Item | Gets or sets the item that should represent the Visio shape specified by ShapeXml in the imported diagram.
MasterName | Gets the name associated with shape's master.
MasterXml | Gets the XML DOM element corresponding to the Visio document's XML code that describes the shape master.
NamespaceManager | Gets an XmlNamespaceManager instance with preloaded Visio namespaces that can be used when querying the XML elements provided by this ImportItemEventArgs instance.
ShapeXml | Gets the XML DOM element corresponding to the Visio document's XML code that describes the imported shape.

See Also

ImportItemEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ImportItemEventArgs.Item Property

ImportItemEventArgs.Item Property
[image]

Gets or sets the item that should represent the Visio shape specified by ShapeXml in the imported diagram.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public DiagramItem Item { get; set; }

Visual Basic [image] Copy Code

Public Property Item As DiagramItem

Property Value

A DiagramItem instance representing the Visio shape currently being imported.

See Also

ImportItemEventArgs Members
ImportItemEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ImportItemEventArgs.MasterName Property

ImportItemEventArgs.MasterName Property
[image]

Gets the name associated with shape's master.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public string MasterName { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MasterName As String

Property Value

A string specifying the name of the shape master.

See Also

ImportItemEventArgs Members
ImportItemEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ImportItemEventArgs.MasterXml Property

ImportItemEventArgs.MasterXml Property
[image]

Gets the XML DOM element corresponding to the Visio document's XML code that describes the shape master.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public XmlNode MasterXml { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MasterXml As XmlNode

Property Value

A System.Xml.XmlNode instance.

See Also

ImportItemEventArgs Members
ImportItemEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ImportItemEventArgs.NamespaceManager Property

ImportItemEventArgs.NamespaceManager Property
[image]

Gets an XmlNamespaceManager instance with preloaded Visio namespaces that can be used when querying the XML elements provided by this ImportItemEventArgs instance.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public XmlNamespaceManager NamespaceManager { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NamespaceManager As XmlNamespaceManager

Property Value

A System.Xml.XmlNamespaceManager instance.

See Also

ImportItemEventArgs Members
ImportItemEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ImportItemEventArgs.ShapeXml Property

ImportItemEventArgs.ShapeXml Property
[image]

Gets the XML DOM element corresponding to the Visio document's XML code that describes the imported shape.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public XmlNode ShapeXml { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ShapeXml As XmlNode

Property Value

A System.Xml.XmlNode instance.

See Also

ImportItemEventArgs Members
ImportItemEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ShapeImportedEventArgs Class

ShapeImportedEventArgs Class
[image]

Contains the arguments passed to handlers of the ShapeImported event.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public class ShapeImportedEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ShapeImportedEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Import.ShapeImportedEventArgs

See Also

ShapeImportedEventArgs Members
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ShapeImportedEventArgs Members

ShapeImportedEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the ShapeImported event.

The following tables list the members exposed by the ShapeImportedEventArgs type.

Public Properties

Name | Description
Shape | Gets a reference to the imported diagram shape.
ShapeName | Gets the Visio name of the node shape.
ShapeXml | Gets the XML DOM element corresponding to the Visio document's XML code that describes the imported shape.

See Also

ShapeImportedEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ShapeImportedEventArgs Properties

ShapeImportedEventArgs Properties
[image]

Public Properties

Name | Description
Shape | Gets a reference to the imported diagram shape.
ShapeName | Gets the Visio name of the node shape.
ShapeXml | Gets the XML DOM element corresponding to the Visio document's XML code that describes the imported shape.

See Also

ShapeImportedEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ShapeImportedEventArgs.Shape Property

ShapeImportedEventArgs.Shape Property
[image]

Gets a reference to the imported diagram shape.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public ShapeNode Shape { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Shape As ShapeNode

Property Value

An instance of the ShapeNode class.

See Also

ShapeImportedEventArgs Members
ShapeImportedEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ShapeImportedEventArgs.ShapeName Property

ShapeImportedEventArgs.ShapeName Property
[image]

Gets the Visio name of the node shape.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public string ShapeName { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ShapeName As String

Property Value

A string specifying the Visio name of the shape.

See Also

ShapeImportedEventArgs Members
ShapeImportedEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ShapeImportedEventArgs.ShapeXml Property

ShapeImportedEventArgs.ShapeXml Property
[image]

Gets the XML DOM element corresponding to the Visio document's XML code that describes the imported shape.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public XmlNode ShapeXml { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ShapeXml As XmlNode

Property Value

An XmlNode object corresponding to the section of the VDX document which describes the imported shape.

Example

The following sample shows how to read a custom property value defined in Visio by handling the ShapeImported event.

C# [image] Copy Code

private void ShapeImported(object sender, ShapeImportedEventArgs e)
{
XmlNode vdxCode = e.ShapeXml;
try
{
XmlNamespaceManager ns = new XmlNamespaceManager(e.ShapeXml.OwnerDocument.NameTable);
ns.AddNamespace("vdx", "http://schemas.microsoft.com/visio/2003/core");

XmlNode myPropVal = vdxCode.SelectSingleNode("vdx:Prop[vdx:Label='MyProperty']/vdx:Value", ns);
if (myPropVal != null)
e.Shape.Tag = myPropVal.InnerText;
}
catch (Exception ex)
{
MessageBox.Show(ex.Message);
}
}

See Also

ShapeImportedEventArgs Members
ShapeImportedEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.SvgImporter Class

SvgImporter Class
Remarks See Also
[image]

SvgImporter lets you import the contents of an SVG file into a Diagram object.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Svg

Syntax

C# [image] Copy Code

public class SvgImporter

Visual Basic [image] Copy Code

Public Class SvgImporter

Remarks

Add a reference to the MindFusion.Diagramming.Import.Svg.dll to your project in order to use this component.

The component allows importing Scalable Vector Graphics files (*.svg) into MindFusion.Diagramming. Each top-level SVG group element is imported as a separate SvgNode, whose Content is set to the group's child elements. If the SVG file was exported from Visio or OpenOffice Draw, SvgImporter will create DiagramLink objects for groups it recognizes as connectors in order to recreate the original diagram model, though in this case it will not preserve fully the original appearance of connectors in SVG.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Import.SvgImporter

See Also

SvgImporter Members
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.SvgImporter Members

SvgImporter Members
Constructors Properties Methods
[image]

SvgImporter lets you import the contents of an SVG file into a Diagram object.

The following tables list the members exposed by the SvgImporter type.

Public Constructors

Name | Description
SvgImporter | Initializes a new instance of the SvgImporter class.

Public Properties

Name | Description
TopLevelGroupIsPage | Gets or sets whether top-level SVG groups should be treated as page content.

Public Methods

Name | Description
Import | Imports the specified SVG file into the specified Diagram.

See Also

SvgImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.SvgImporter Constructor

SvgImporter Constructor
[image]

Initializes a new instance of the SvgImporter class.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Svg

Syntax

C# [image] Copy Code

public SvgImporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SvgImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.SvgImporter Methods

SvgImporter Methods
[image]

Public Methods

Name | Description
Import | Imports the specified SVG file into the specified Diagram.

See Also

SvgImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.SvgImporter.Import Method

SvgImporter.Import Method
[image]

Imports the specified SVG file into the specified Diagram.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Svg

Syntax

C# [image] Copy Code

public void Import (
string filePath,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Sub Import( _
filePath As String, _
diagram As Diagram _
)

Parameters

filePath

A string specifying the path to the .svg file.

diagram

A Diagram into which to import the SVG drawing.

See Also

SvgImporter Members
SvgImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.SvgImporter Properties

SvgImporter Properties
[image]

Public Properties

Name | Description
TopLevelGroupIsPage | Gets or sets whether top-level SVG groups should be treated as page content.

See Also

SvgImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.SvgImporter.TopLevelGroupIsPage Property

SvgImporter.TopLevelGroupIsPage Property
[image]

Gets or sets whether top-level SVG groups should be treated as page content.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Svg

Syntax

C# [image] Copy Code

public bool TopLevelGroupIsPage { get; set; }

Visual Basic [image] Copy Code

Public Property TopLevelGroupIsPage As Boolean

Property Value

See Also

SvgImporter Members
SvgImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.Visio2013Importer Class

Visio2013Importer Class
Remarks See Also
[image]

Imports Visio 2013 XML Drawing files (*.vsdx) into Diagram or DiagramDocument objects.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public class Visio2013Importer

Visual Basic [image] Copy Code

Public Class Visio2013Importer

Remarks

The Visio2013Importer class can import .vsdx files, created by version 2013 of Microsoft Visio. In order to use it, you must add a reference to the MindFusion.Diagramming.Import.Visio.dll assembly.

Various overloads of the Import method can be used to import the Visio drawing into a DiagramDocument whose pages correspond to the Visio pages, or into a single Diagram whose content is merged from all imported pages. When merging multiple pages, their positions in the diagram depend on the PagesPerRow value.

Visio2013Importer supports Visio's basic flowchart and data flow stencils. For each node shape from the .vsdx file, the importer creates a ShapeNode object whose Shape, Text, Brush and Pen properties are set to values corresponding to the imported Visio shape. For each connector shape, the importer creates a DiagramLink object whose Origin and Destination are set to the corresponding imported nodes, and whose ControlPoints reflect the geometry of the connector.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Import.Visio2013Importer

See Also

Visio2013Importer Members
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.Visio2013Importer Members

Visio2013Importer Members
Constructors Properties Methods Events
[image]

Imports Visio 2013 XML Drawing files (*.vsdx) into Diagram or DiagramDocument objects.

The following tables list the members exposed by the Visio2013Importer type.

Public Constructors

Name | Description
Visio2013Importer | Initializes a new instance of the Visio2013Importer class.

Public Properties

Name | Description
PagesPerRow | Gets or sets how many Visio pages to import on a row before offsetting the import location vertically.

Public Methods

Name | Description
Import | Overloaded.

Protected Methods

Name | Description
OnImportItem | Raises the ImportItem event.

Public Events

Name | Description
ImportItem | Raised for each shape's XML element in the imported VSDX drawing to let you create a custom diagram item representing the Visio shape.

See Also

Visio2013Importer Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.Visio2013Importer Constructor

Visio2013Importer Constructor
[image]

Initializes a new instance of the Visio2013Importer class.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public Visio2013Importer ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Visio2013Importer Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.Visio2013Importer Methods

Visio2013Importer Methods
[image]

Public Methods

Name | Description
Import | Overloaded.

Protected Methods

Name | Description
OnImportItem | Raises the ImportItem event.

See Also

Visio2013Importer Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.Visio2013Importer.Import Method

Visio2013Importer.Import Method
[image]

Overload List

Name | Description
Visio2013Importer.Import (String) | Imports the specified Visio Graphics Service VSDX file into a new DiagramDocument, where each Visio page is imported into a separate DiagramPage of the DiagramDocument.
Visio2013Importer.Import (String, Diagram) | Imports the specified Visio Graphics Service VSDX file into the specified Diagram.
Visio2013Importer.Import (String, DiagramDocument) | Imports the specified Visio Graphics Service VSDX file into an existing DiagramDocument, where each Visio page is imported into a separate DiagramPage of the DiagramDocument.

See Also

Visio2013Importer Members
Visio2013Importer Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.Visio2013Importer.Import Method (String)

Visio2013Importer.Import Method (String)
See Also
[image]

Imports the specified Visio Graphics Service VSDX file into a new DiagramDocument, where each Visio page is imported into a separate DiagramPage of the DiagramDocument.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public DiagramDocument Import (
string filePath
)

Visual Basic [image] Copy Code

Public Function Import( _
filePath As String _
) As DiagramDocument

Parameters

filePath

A string specifying the path to the .vsdx file.

Return Value

A DiagramDocument containing the imported Visio drawing.

See Also

Import Method Overload List
Visio2013Importer Members
Visio2013Importer Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.Visio2013Importer.Import Method (String, Diagram)

Visio2013Importer.Import Method (String, Diagram)
See Also
[image]

Imports the specified Visio Graphics Service VSDX file into the specified Diagram.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public void Import (
string filePath,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Sub Import( _
filePath As String, _
diagram As Diagram _
)

Parameters

filePath

A string specifying the path to the .vsdx file.

diagram

A Diagram into which to import the Visio drawing.

See Also

Import Method Overload List
Visio2013Importer Members
Visio2013Importer Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.Visio2013Importer.Import Method (String, DiagramDocument)

Visio2013Importer.Import Method (String, DiagramDocument)
See Also
[image]

Imports the specified Visio Graphics Service VSDX file into an existing DiagramDocument, where each Visio page is imported into a separate DiagramPage of the DiagramDocument.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public void Import (
string filePath,
DiagramDocument document
)

Visual Basic [image] Copy Code

Public Sub Import( _
filePath As String, _
document As DiagramDocument _
)

Parameters

filePath

A string specifying the path to the .vsdx file.

document

A DiagramDocument into which to import the Visio drawing.

See Also

Import Method Overload List
Visio2013Importer Members
Visio2013Importer Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.Visio2013Importer.OnImportItem Method

Visio2013Importer.OnImportItem Method
[image]

Raises the ImportItem event.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

protected virtual void OnImportItem (
Object sender,
ImportItemEventArgs args
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnImportItem( _
sender As Object, _
args As ImportItemEventArgs _
)

Parameters

sender

args

See Also

Visio2013Importer Members
Visio2013Importer Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.Visio2013Importer Properties

Visio2013Importer Properties
[image]

Public Properties

Name | Description
PagesPerRow | Gets or sets how many Visio pages to import on a row before offsetting the import location vertically.

See Also

Visio2013Importer Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.Visio2013Importer.PagesPerRow Property

Visio2013Importer.PagesPerRow Property
[image]

Gets or sets how many Visio pages to import on a row before offsetting the import location vertically.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public int PagesPerRow { get; set; }

Visual Basic [image] Copy Code

Public Property PagesPerRow As Integer

Property Value

See Also

Visio2013Importer Members
Visio2013Importer Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.Visio2013Importer Events

Visio2013Importer Events
[image]

Public Events

Name | Description
ImportItem | Raised for each shape's XML element in the imported VSDX drawing to let you create a custom diagram item representing the Visio shape.

See Also

Visio2013Importer Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.Visio2013Importer.ImportItem Event

Visio2013Importer.ImportItem Event
[image]

Raised for each shape's XML element in the imported VSDX drawing to let you create a custom diagram item representing the Visio shape.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public event EventHandler<ImportItemEventArgs> ImportItem

Visual Basic [image] Copy Code

Public Event ImportItem As EventHandler(Of ImportItemEventArgs)

See Also

Visio2013Importer Members
Visio2013Importer Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter Class

VisioImporter Class
Remarks See Also
[image]

Imports Visio 2003 XML Drawing files (*.vdx) into MvcDiagram.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public class VisioImporter

Visual Basic [image] Copy Code

Public Class VisioImporter

Remarks

Add a reference to the MindFusion.Diagramming.Import.Visio.dll to your project in order to use this component.

The component allows importing Visio 2003 XML Drawing files (*.vdx) into MvcDiagram. The standard Visio flowchart shapes, as well as most of the UML and Database entity shapes are imported to their closest representation in MvcDiagram. The Visio connectors are imported as MvcDiagram DiagramLink objects, preserving the relationship between the connected nodes. In addition, most of the attributes of Visio objects such as text, text formatting, fill and line colors and styles are preserved. The component raises an event for each imported node to let you set the node shape if it is not recognized by MvcDiagram or if you need to set a different shape.

To determine how many pages contains the Visio document and import only a single page, call the GetPageCount and ImportPage methods. All pages of a Visio diagram can be imported at once by calling the ImportAllPages method, which lays out the pages as set in PagesPerRow. More properties and events provided by the class are listed below.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Import.VisioImporter

See Also

VisioImporter Members
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter Members

VisioImporter Members
Constructors Properties Methods Events
[image]

Imports Visio 2003 XML Drawing files (*.vdx) into MvcDiagram.

The following tables list the members exposed by the VisioImporter type.

Public Constructors

Name | Description
VisioImporter | Initializes a new instance of the VisioImporter class.

Public Properties

Name | Description
ApplyVisioUnit | Gets or sets a value indicating whether the diagram's MeasureUnit should be set to the one read from the imported Visio file.
ImportEntitiesAsTables | Gets or sets a value indicating whether Visio UML and DB entities are imported as MvcDiagram tables.
PagesPerRow | Gets or sets how many Visio pages to import on a row before offsetting the import location vertically.
SuppressUnmanagedCode | Suppress usage of unmanaged code.

Public Methods

Name | Description
GetPageCount | Determines how many pages are there in a Visio diagram.
Import | Imports all pages from the specified Visio document into a single DiagramDocument object.
ImportAllPages | Imports all pages from the specified Visio document.
ImportPage | Imports a single page from the specified Visio document.

Protected Methods

Name | Description
OnConnectorImported | Raises the ConnectorImported event.
OnGroupImported | Raises the GroupImported event.
OnShapeImported | Raises the ShapeImported event.

Public Events

Name | Description
ConnectorImported | Raised when a Visio connector is imported as a MvcDiagram link.
GroupImported | Raised when a Visio group is imported as a MvcDiagram group.
ShapeImported | Raised when a Visio shape is imported into MvcDiagram as a ShapeNode.

See Also

VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter Constructor

VisioImporter Constructor
[image]

Initializes a new instance of the VisioImporter class.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public VisioImporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter Methods

VisioImporter Methods
[image]

Public Methods

Name | Description
GetPageCount | Determines how many pages are there in a Visio diagram.
Import | Imports all pages from the specified Visio document into a single DiagramDocument object.
ImportAllPages | Imports all pages from the specified Visio document.
ImportPage | Imports a single page from the specified Visio document.

Protected Methods

Name | Description
OnConnectorImported | Raises the ConnectorImported event.
OnGroupImported | Raises the GroupImported event.
OnShapeImported | Raises the ShapeImported event.

See Also

VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter.GetPageCount Method

VisioImporter.GetPageCount Method
[image]

Determines how many pages are there in a Visio diagram.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public long GetPageCount (
string vdxPathName
)

Visual Basic [image] Copy Code

Public Function GetPageCount( _
vdxPathName As String _
) As Long

Parameters

vdxPathName

A full path to the Visio VDX file.

Return Value

An integer value specifying the number of pages in the Visio diagram.

Remarks

Use this method to determine the valid range of pages for ImportPage.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter.Import Method

VisioImporter.Import Method
[image]

Imports all pages from the specified Visio document into a single DiagramDocument object.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public DiagramDocument Import (
string vdxPathName
)

Visual Basic [image] Copy Code

Public Function Import( _
vdxPathName As String _
) As DiagramDocument

Parameters

vdxPathName

A full path to the Visio VDX file.

Return Value

The newly crated DiagramDocument object.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter.ImportAllPages Method

VisioImporter.ImportAllPages Method
[image]

Imports all pages from the specified Visio document.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public void ImportAllPages (
string vdxPathName,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Sub ImportAllPages ( _
vdxPathName As String, _
diagram As Diagram _
)

Parameters

vdxPathName

A full path to the Visio VDX file.

diagram

Reference to the diagram where the Visio drawing is imported.

Remarks

The pages are imported starting from the top-left point of the MvcDiagram diagram area. The current import location is moved one page-width to the right with each new page imported, until PagesPerRow pages are imported on the same y-coordinate. When that happens, the current location moves to the left-most x-coordinate and one page-height down. If there are more pages to import, the process continues as above.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter.ImportPage Method

VisioImporter.ImportPage Method
[image]

Imports a single page from the specified Visio document.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public void ImportPage (
string vdxPathName,
Diagram diagram,
int PageIndex
)

Visual Basic [image] Copy Code

Public Sub ImportPage ( _
vdxPathName As String, _
diagram As Diagram, _
PageIndex As Integer _
)

Parameters

vdxPathName

A full path to the Visio VDX file.

diagram
Reference to the Diagram document into which the Visio data is imported.
pageIndex

Specifies which page of the Visio document to import.

Remarks

The page index is zero based. Use GetPageCount to determine how many pages are there in the Visio diagram.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter.OnConnectorImported Method

VisioImporter.OnConnectorImported Method
[image]

Raises the ConnectorImported event.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

protected virtual void OnConnectorImported (
ConnectorImportedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnConnectorImported ( _
e As ConnectorImportedEventArgs _
)

Parameters

e
An ConnectorImportedEventArgs that contains the event data.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter.OnGroupImported Method

VisioImporter.OnGroupImported Method
[image]

Raises the GroupImported event.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

protected virtual void OnGroupImported (
GroupImportedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnGroupImported ( _
e As GroupImportedEventArgs _
)

Parameters

e
An GroupImportedEventArgs that contains the event data.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter.OnShapeImported Method

VisioImporter.OnShapeImported Method
[image]

Raises the ShapeImported event.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

protected virtual void OnShapeImported (
ShapeImportedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnShapeImported ( _
e As ShapeImportedEventArgs _
)

Parameters

e
An ShapeImportedEventArgs that contains the event data.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter Properties

VisioImporter Properties
[image]

Public Properties

Name | Description
ApplyVisioUnit | Gets or sets a value indicating whether the diagram's MeasureUnit should be set to the one read from the imported Visio file.
ImportEntitiesAsTables | Gets or sets a value indicating whether Visio UML and DB entities are imported as MvcDiagram tables.
PagesPerRow | Gets or sets how many Visio pages to import on a row before offsetting the import location vertically.
SuppressUnmanagedCode | Suppress usage of unmanaged code.

See Also

VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter.ApplyVisioUnit Property

VisioImporter.ApplyVisioUnit Property
[image]

Gets or sets a value indicating whether the diagram's MeasureUnit should be set to the one read from the imported Visio file.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public bool ApplyVisioUnit { get; set; }

Visual Basic [image] Copy Code

Public Property ApplyVisioUnit As Boolean

Property Value

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter.ImportEntitiesAsTables Property

VisioImporter.ImportEntitiesAsTables Property
[image]

Gets or sets a value indicating whether Visio UML and DB entities are imported as MvcDiagram tables.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public bool ImportEntitiesAsTables { get; set; }

Visual Basic [image] Copy Code

Public Property ImportEntitiesAsTables As Boolean

Property Value

true to import Visio entity nodes as tables; otherwise, false. The default is false.

Remarks

If this property is disabled, Visio entity objects are imported as MvcDiagram groups of rectangular nodes; if it is enabled, entities are imported as tables.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter.PagesPerRow Property

VisioImporter.PagesPerRow Property
[image]

Gets or sets how many Visio pages to import on a row before offsetting the import location vertically.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public long PagesPerRow { get; set; }

Visual Basic [image] Copy Code

Public Property PagesPerRow As Long

Property Value

An integer value specifying how many pages to import in a row. The default is 1.

Remarks

MvcDiagram does not support stacked pages as Visio does, so the ImportAllPages method imports all pages from a Visio document in a grid that prevents items from one page to overlap with items from another page. This property specifies the width of the page grid.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter.SuppressUnmanagedCode Property

VisioImporter.SuppressUnmanagedCode Property
[image]

Suppress usage of unmanaged code.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public bool SuppressUnmanagedCode { get; set; }

Visual Basic [image] Copy Code

Public Property SuppressUnmanagedCode As Boolean

Property Value

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter Events

VisioImporter Events
[image]

Public Events

Name | Description
ConnectorImported | Raised when a Visio connector is imported as a MvcDiagram link.
GroupImported | Raised when a Visio group is imported as a MvcDiagram group.
ShapeImported | Raised when a Visio shape is imported into MvcDiagram as a ShapeNode.

See Also

VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter.ConnectorImported Event

VisioImporter.ConnectorImported Event
[image]

Raised when a Visio connector is imported as a MvcDiagram link.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public event EventHandler<ConnectorImportedEventArgs> ConnectorImported

Visual Basic [image] Copy Code

Public Event ConnectorImported As EventHandler(Of ConnectorImportedEventArgs)

Event Data

ConnectorImported event handlers receive an argument of type ConnectorImportedEventArgs. The following ConnectorImportedEventArgs members provide information relevant to the event:

Member Name | Description
Link | Refers to the imported DiagramLink instance.
ShapeName | The name of the Visio connector shape.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter.GroupImported Event

VisioImporter.GroupImported Event
[image]

Raised when a Visio group is imported as a MvcDiagram group.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public event EventHandler<GroupImportedEventArgs> GroupImported

Visual Basic [image] Copy Code

Public Event GroupImported As EventHandler(Of GroupImportedEventArgs)

Event Data

GroupImported event handlers receive an argument of type GroupImportedEventArgs. The following GroupImportedEventArgs members provide information relevant to the event:

Member name | Description
Group | Refers to the imported Group instance.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter.ShapeImported Event

VisioImporter.ShapeImported Event
[image]

Raised when a Visio shape is imported into MvcDiagram as a ShapeNode.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C# [image] Copy Code

public event EventHandler<ShapeImportedEventArgs> ShapeImported

Visual Basic [image] Copy Code

Public Event ShapeImported As EventHandler(Of ShapeImportedEventArgs)

Event Data

ShapeImported event handlers receive an argument of type ShapeImportedEventArgs. The following ShapeImportedEventArgs members provide information relevant to the event:

Member name | Description
Shape | Refers to the imported ShapeNode instance.
ShapeName | The name of the Visio node shape.

Remarks

The basic Visio flowchart shapes are mapped to the MvcDiagram predefined shape templates. If the importer does not recognize a specific Visio shape, the node created for it is set to a simple rectangle. You can handle this event in order to set the shape of a node whose Visio counterpart is not recognized, or whose default value set by the importer is not appropriate for your application.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Layout Namespace

MindFusion.Diagramming.Layout Namespace
Classes Interfaces Delegates Enumerations

Classes

Class | Description
AnnealLayout | Implements a simulated annealing graph layout algorithm.
CascadeLayout | Performs cascading layout on simple, connected graphs.
CircularLayout | Implements a circular graph layout algorithm. Nodes are distributed evenly on the circumference of a circle at positions that result in as few link crossing as possible.
CompositeLayout | Implements a multi-level graph layout algorithm.
DecisionLayout | Implements a flowchart layout algorithm.
FlowchartLayout | FlowchartLayout can be used to arrange flowcharts representing program source code.
FlowLayout | Implements a flowchart, workflow and process diagrams layout algorithm.
FractalLayout | A tree layout algorithm that places child nodes symmetrically around their parent node.
GridLayout | Implements a grid graph layout algorithm.
HierarchicalLayout | Performs hierarchical layout on simple, connected, level-planar graphs.
LaneGrid | Represents an ISwimlaneGrid which operates on a MindFusion.Diagramming.Lanes.Grid object.
LayeredLayout | Implements a layered graph layout algorithm.
LayeredLayoutStatistics | Encapsulates information about a layered layout which has already complete.
Layout | The base class for all layout classes.
OneWayLayout | Implements a one-way graph layout algorithm.
OrthogonalLayout | Implements an orthogonal graph layout algorithm. Each link is drawn as a chain of alternating horizontal and vertical segments. Nodes are placed in a way that facilitates few links bends and crossings.
OrthogonalRouter | Implements an orthogonal link routing algorithm.
SolarLayout | A tree layout algorithm that places child nodes around their parents, such, that the child nodes do not overlap. The algorithm optionally bends the links to prevent them from crossing nodes.
SpringLayout | Implements the Spring-Embedder graph layout algorithm.
SwimlaneLayout | Implements an algorithm which arranges nodes in lanes.
TopologicalLayout | Implements a topological ordering.
TreeLayout | Implements several algorithms for arranging tree structures.
TreeMapLayout | Implements a tree map layout algorithm.
TriangularLayout | Performs triangular layout on simple, connected graphs.

Interfaces

Interface | Description
ILayout | Common interface for all MvcDiagram layout classes.
ISwimlaneGrid | Represents an object which can be used by a SwimlaneLayout to adjust the corresponding swimlane grid.

Delegates

Delegate | Description
LayoutLink | Represents methods that are called by the layout algorithms when the position of a link changes.
LayoutNode | Represents methods that are called by the layout algorithms when the position of a node changes.
LayoutProgress | Represents methods that are called to report on progress of layout algorithms.
LayoutSubgraph | Represents methods that are called by the layout algorithms in order to perform custom arrangement of a subgraph.

Enumerations

Enumeration | Description
Direction | Specifies a layout direction.
LaneType | Specifies where FlowLayout gets the swimlane dimensions from.
LayeredLayoutLinkType | Specifies the style of the links after they are laid out.
MultipleGraphsPlacement | Specifies graph orientation.
Orientation | Specifies axial orientation.
SpringLayoutLinkType | Specifies the style of the diagram links after they are laid out.
TreeLayoutBalance | Specifies how to order child nodes in order to produce tree layouts with custom balance.
TreeLayoutDirections | Specifies the direction of a tree layout.
TreeLayoutLinkType | Specifies the style of the diagram links after they are laid out.
TreeLayoutType | Specifies the type of a tree layout.


MindFusion.Diagramming.Layout.AnnealLayout Class

AnnealLayout Class
Remarks See Also
[image]

Implements a simulated annealing graph layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class AnnealLayout : Layout

Visual Basic [image] Copy Code

Public Class AnnealLayout
Inherits Layout

Remarks

Simulated Annealing is a general-purpose optimization method used to solve large-scale combinatorial problems by simulating the process of heating and cooling of metal to achieve freedom from defects. Finding a nice arrangement of a graph is a combinatorial problem that can be reduced to assigning costs to graph configurations and finding the minimum cost configuration. In that case, a cost is assigned to a graph configuration by evaluating different aesthetic criteria such as distance between nodes, length of links and the number of link crossings.

The AnnealLayout class implements a Simulated Annealing graph layout algorithm that can be used to arrange MvcDiagram diagrams. To arrange a diagram, create an AnnealLayout instance, set its properties and call the Arrange method.

The algorithm starts the simulation with the temperature set in InitialTemperature, and runs several cooling Stages. At each stage the algorithm evaluates several graph configurations for each node, as set in IterationsPerStage. At the end of each stage, the algorithm selects the configuration that has a minimum cost and decreases the temperature by multiplying it by TemperatureScale. The relative weight of an aesthetic criterion relative to the other criteria is set by the DistributionFactor, LinkLengthFactor, BoundaryFactor and CrossingLinksCost properties.

Anchoring specifies whether the layout algorithm must attach links to the anchor points of graphs nodes. The layout algorithm produces best results if it can place link ends at arbitrary positions over the nodes outlines, that is, when using the Ignore value. If your application logic requires links to be always attached to anchor points, use the other two values. In such cases Reassign would yield better results.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.AnnealLayout

See Also

AnnealLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout Members

AnnealLayout Members
Constructors Properties Methods
[image]

Implements a simulated annealing graph layout algorithm.

The following tables list the members exposed by the AnnealLayout type.

Public Constructors

Name | Description
AnnealLayout | Initializes a new instance of the AnnealLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
ApproximateLinkLength | Gets or sets a value indicating whether the layout should approximate the length of graph links by calculating the distance between the centers of their incident nodes.
BoundaryFactor | Gets or sets a value indicating the importance of the distance between nodes and the layout area boundaries, relative to the other criteria considered by the algorithm.
CrossingLinksCost | Gets or sets a value indicating the importance of the low number of link crossings, relative to the other criteria considered by the algorithm.
DistributionFactor | Gets or sets a value indicating the importance of the node distribution, relative to the other criteria considered by the algorithm.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GatherStatistics |
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
InitialTemperature | Gets or sets the initial temperature of the simulated annealing process.
IterationsPerStage | Gets or sets how many node shift iterations to perform at each stage of the algorithm.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutArea | Gets or sets the size of the layout area.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinkLengthFactor | Gets or sets a value indicating the importance of the short length of links, relative to the other criteria considered by the algorithm.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeLinkCrossingCost | Gets or sets a value indicating the importance of low number of overlaps between links and nodes relative to the other criteria considered by the algorithm.
NodeLinkDistFactor | Gets or sets a value indicating the importance of the distance between nodes and links, relative to the other criteria considered by the algorithm.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
Randomize | Gets or sets a value indicating whether the nodes should be placed at random positions when the layout routine starts.
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
Root | Gets or sets a node indicating which subgraph of the diagram should be laid out.
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.
Stages | Gets or sets how many cool-down stages the algorithm should simulate.
Statistics |
TemperatureScale | Gets or sets how much the simulated temperature is decreased at each stage of the algorithm.
WidthHeightRatio | Gets or sets what width/height ratio the layout area should have.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)
BeginArrange | Initializes the layout object for a step-by-step execution.
EndArrange | Completes the step-by-step execution started with a call to BeginArrange.
Iterate | Runs one or more layout iterations.

See Also

AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout Constructor

AnnealLayout Constructor
[image]

Initializes a new instance of the AnnealLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnnealLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout Methods

AnnealLayout Methods
[image]

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)
BeginArrange | Initializes the layout object for a step-by-step execution.
EndArrange | Completes the step-by-step execution started with a call to BeginArrange.
Iterate | Runs one or more layout iterations.

See Also

AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.BeginArrange Method

AnnealLayout.BeginArrange Method
[image]

Initializes the layout object for a step-by-step execution.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool BeginArrange (
Diagram diagram,
DiagramItemCollection items
)

Visual Basic [image] Copy Code

Public Function BeginArrange ( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram
The Diagram that will be arranged.
items
A collection of nodes and links from diagram that define the subgraph to arrange.

Return Value

true if the layout object has been initialized successfully; otherwise, false.

Remarks

You can use this method together with Iterate and EndArrange to display an animation of the layout process. To run all iterations of the process at once and display just the end result, call Arrange.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.EndArrange Method

AnnealLayout.EndArrange Method
[image]

Completes the step-by-step execution started with a call to BeginArrange.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void EndArrange ()

Visual Basic [image] Copy Code

Public Sub EndArrange ()

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.Iterate Method

AnnealLayout.Iterate Method
[image]

Runs one or more layout iterations.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Iterate (
int iterationFrom,
int iterationTo
)

Visual Basic [image] Copy Code

Public Sub Iterate ( _
iterationFrom As Integer, _
iterationTo As Integer _
)

Parameters

iterationFrom
Specifies from which iteration to start.
iterationTo
Specifies at which iteration to stop.

Remarks

Use this method to create an animation of the layout process, for example, by calling it from a timer. Call BeginArrange to prepare the layout object for use of Iterate, and call EndArrange when done. Each call to Iterate should start from the iteration next to the one where the previous call has stopped.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout Properties

AnnealLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
ApproximateLinkLength | Gets or sets a value indicating whether the layout should approximate the length of graph links by calculating the distance between the centers of their incident nodes.
BoundaryFactor | Gets or sets a value indicating the importance of the distance between nodes and the layout area boundaries, relative to the other criteria considered by the algorithm.
CrossingLinksCost | Gets or sets a value indicating the importance of the low number of link crossings, relative to the other criteria considered by the algorithm.
DistributionFactor | Gets or sets a value indicating the importance of the node distribution, relative to the other criteria considered by the algorithm.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GatherStatistics |
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
InitialTemperature | Gets or sets the initial temperature of the simulated annealing process.
IterationsPerStage | Gets or sets how many node shift iterations to perform at each stage of the algorithm.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutArea | Gets or sets the size of the layout area.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinkLengthFactor | Gets or sets a value indicating the importance of the short length of links, relative to the other criteria considered by the algorithm.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeLinkCrossingCost | Gets or sets a value indicating the importance of low number of overlaps between links and nodes relative to the other criteria considered by the algorithm.
NodeLinkDistFactor | Gets or sets a value indicating the importance of the distance between nodes and links, relative to the other criteria considered by the algorithm.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
Randomize | Gets or sets a value indicating whether the nodes should be placed at random positions when the layout routine starts.
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
Root | Gets or sets a node indicating which subgraph of the diagram should be laid out.
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.
Stages | Gets or sets how many cool-down stages the algorithm should simulate.
Statistics |
TemperatureScale | Gets or sets how much the simulated temperature is decreased at each stage of the algorithm.
WidthHeightRatio | Gets or sets what width/height ratio the layout area should have.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.ApproximateLinkLength Property

AnnealLayout.ApproximateLinkLength Property
[image]

Gets or sets a value indicating whether the layout should approximate the length of graph links by calculating the distance between the centers of their incident nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ApproximateLinkLength { get; set; }

Visual Basic [image] Copy Code

Public Property ApproximateLinkLength As Boolean

Property Value

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.BoundaryFactor Property

AnnealLayout.BoundaryFactor Property
[image]

Gets or sets a value indicating the importance of the distance between nodes and the layout area boundaries, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double BoundaryFactor { get; set; }

Visual Basic [image] Copy Code

Public Property BoundaryFactor As Double

Property Value

A double multiplier applied to the node-to-boundary distance cost when evaluating the total cost of a graph configuration. The default is 3000.

Remarks

Assigning a larger value to this property will make the algorithm choose graph configurations in which nodes are placed farther from the layout area bounds, that is, nodes will tend to gather in the center of the layout area.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace
LinkLengthFactor Property
DistributionFactor Property


MindFusion.Diagramming.Layout.AnnealLayout.CrossingLinksCost Property

AnnealLayout.CrossingLinksCost Property
[image]

Gets or sets a value indicating the importance of the low number of link crossings, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double CrossingLinksCost { get; set; }

Visual Basic [image] Copy Code

Public Property CrossingLinksCost As Double

Property Value

A double value added to the total cost of a graph configuration for each pair of crossing links. The default is 120000.

Remarks

Assigning a larger value to this property will make the algorithm choose graph configurations with fewer link crossings.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace
LinkLengthFactor Property


MindFusion.Diagramming.Layout.AnnealLayout.DefaultMarginValue Property

AnnealLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override SizeF DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As SizeF

Property Value

Returns new SizeF(5, 5).

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.DistributionFactor Property

AnnealLayout.DistributionFactor Property
[image]

Gets or sets a value indicating the importance of the node distribution, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double DistributionFactor { get; set; }

Visual Basic [image] Copy Code

Public Property DistributionFactor As Double

Property Value

A double multiplier applied to the node distribution cost when evaluating the total cost of a graph configuration. The default is 40000.

Remarks

Assigning a larger value to this property will make the algorithm choose graph configurations in which the nodes are placed farther one from another.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace
LinkLengthFactor Property
BoundaryFactor Property


MindFusion.Diagramming.Layout.AnnealLayout.GatherStatistics Property

AnnealLayout.GatherStatistics Property
[image]

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool GatherStatistics { get; set; }

Visual Basic [image] Copy Code

Public Property GatherStatistics As Boolean

Property Value

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.InitialTemperature Property

AnnealLayout.InitialTemperature Property
[image]

Gets or sets the initial temperature of the simulated annealing process.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double InitialTemperature { get; set; }

Visual Basic [image] Copy Code

Public Property InitialTemperature As Double

Property Value

A double value specifying the initial temperature of the simulation. The default is 40.

Remarks

A low initial temperature prevents nodes from moving far from their initial position. If you need the final arrangement to have resemblance to the initial formation of the graph elements, set a lower initial temperature and disable Randomize.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace
TemperatureScale Property


MindFusion.Diagramming.Layout.AnnealLayout.IterationsPerStage Property

AnnealLayout.IterationsPerStage Property
[image]

Gets or sets how many node shift iterations to perform at each stage of the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int IterationsPerStage { get; set; }

Visual Basic [image] Copy Code

Public Property IterationsPerStage As Integer

Property Value

An integer value specifying the number of node shift iterations. The default is 50.

Remarks

IterationsPerStage specifies how many node configurations to evaluate at each stage of the temperature cool-down simulation. More iterations will yield better layouts but require more time to complete.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace
Progress Property
Stages Property


MindFusion.Diagramming.Layout.AnnealLayout.LayoutArea Property

AnnealLayout.LayoutArea Property
[image]

Gets or sets the size of the layout area.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF LayoutArea { get; set; }

Visual Basic [image] Copy Code

Public Property LayoutArea As RectangleF

Property Value

A .NET RectangleF representing the boundaries of the layout area. The default is RectangleF.Empty.

Remarks

If the layout area is not explicitly set, the algorithm will choose one suitable for the graph size. In that case the WidthHeightRatio property specifies how much larger the layout area width should be than its height.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.LinkLengthFactor Property

AnnealLayout.LinkLengthFactor Property
[image]

Gets or sets a value indicating the importance of the short length of links, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LinkLengthFactor { get; set; }

Visual Basic [image] Copy Code

Public Property LinkLengthFactor As Double

Property Value

A double multiplier applied to the link length cost when evaluating the total cost of a graph configuration. The default is 0.25.

Remarks

Assigning a larger value to this property will make the algorithm choose graph configurations in which links are shorter.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace
CrossingLinksCost Property
DistributionFactor Property


MindFusion.Diagramming.Layout.AnnealLayout.Name Property

AnnealLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Anneal layout".

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.NodeLinkCrossingCost Property

AnnealLayout.NodeLinkCrossingCost Property
[image]

Gets or sets a value indicating the importance of low number of overlaps between links and nodes relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeLinkCrossingCost { get; set; }

Visual Basic [image] Copy Code

Public Property NodeLinkCrossingCost As Double

Property Value

A double value added to the total cost of a graph configuration when a link crosses a node. The default is 15000.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.NodeLinkDistFactor Property

AnnealLayout.NodeLinkDistFactor Property
[image]

Gets or sets a value indicating the importance of the distance between nodes and links, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeLinkDistFactor { get; set; }

Visual Basic [image] Copy Code

Public Property NodeLinkDistFactor As Double

Property Value

A double value specifying the distance factor.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.Randomize Property

AnnealLayout.Randomize Property
[image]

Gets or sets a value indicating whether the nodes should be placed at random positions when the layout routine starts.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Randomize { get; set; }

Visual Basic [image] Copy Code

Public Property Randomize As Boolean

Property Value

true to start the simulation with random node positions; false to start it with the original node positions. The default is true.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.Root Property

AnnealLayout.Root Property
[image]

Gets or sets a node indicating which subgraph of the diagram should be laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As DiagramNode

Property Value

A DiagramNode whose containing graph should be arranged. The default is null (Nothing in Visual Basic).

Remarks

If a root nodes is specified and SplitGraph is enabled, only the graph that contains the root node is laid out by Arrange.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.SplitGraph Property

AnnealLayout.SplitGraph Property
[image]

Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SplitGraph { get; set; }

Visual Basic [image] Copy Code

Public Property SplitGraph As Boolean

Property Value

true if unconnected graphs in the diagram should be laid out independently; otherwise, false. The default is false.

Remarks

If this property is set to true, each independent graph in the diagram is laid out in its own layout area. Otherwise all subgraphs are arranged in the same layout area. If a Root node is specified and SplitGraph is true, only the graph that contains the root node will be arranged.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.Stages Property

AnnealLayout.Stages Property
[image]

Gets or sets how many cool-down stages the algorithm should simulate.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Stages { get; set; }

Visual Basic [image] Copy Code

Public Property Stages As Integer

Property Value

An integer value specifying the number of temperature decreases the simulation should run. The default is 15.

Remarks

At each stage the algorithm evaluates different graph arrangements produced by modifying the best configuration from the previous stage. The modifications are done by shifting nodes by a distance that depends on the current temperature. The TemperatureScale property specifies how much the temperature decreases at each stage. IterationsPerStage specifies how many configurations are evaluated at each stage.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace
Progress Property


MindFusion.Diagramming.Layout.AnnealLayout.Statistics Property

AnnealLayout.Statistics Property
[image]

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnnealLayoutStatistics Statistics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Statistics As AnnealLayoutStatistics

Property Value

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.TemperatureScale Property

AnnealLayout.TemperatureScale Property
[image]

Gets or sets how much the simulated temperature is decreased at each stage of the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double TemperatureScale { get; set; }

Visual Basic [image] Copy Code

Public Property TemperatureScale As Double

Property Value

A double multiplier applied to the simulated temperature at each stage of the algorithm. The default is 0.75.

Remarks

This value should be in the interval (0,1). The algorithm produces better results when running for many Stages with a gradual temperature decrease, that is, a TemperatureScale closer to 1.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace
InitialTemperature Property


MindFusion.Diagramming.Layout.AnnealLayout.WidthHeightRatio Property

AnnealLayout.WidthHeightRatio Property
[image]

Gets or sets what width/height ratio the layout area should have.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float WidthHeightRatio { get; set; }

Visual Basic [image] Copy Code

Public Property WidthHeightRatio As Single

Property Value

A float value specifying the layout area width to height ratio. The default is 1.

Remarks

If the LayoutArea is not explicitly set, the algorithm will choose one suitable for the graph size. In that case the WidthHeightRatio property specifies how much larger the layout area width should be than its height.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CascadeLayout Class

CascadeLayout Class
Remarks See Also
[image]

Performs cascading layout on simple, connected graphs.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class CascadeLayout : Layout

Visual Basic [image] Copy Code

Public Class CascadeLayout
Inherits Layout

Remarks

CascadeLayout places nodes on a virtual grid and arranges links orthogonally, such that if the source graph is planar all links are guaranteed to have no more than two bends and will not intersect. By default the layout method arranges nodes in rows and link segments in columns; this can be changed by setting the Orientation property.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.CascadeLayout

See Also

CascadeLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CascadeLayout Members

CascadeLayout Members
Constructors Properties Methods
[image]

Performs cascading layout on simple, connected graphs.

The following tables list the members exposed by the CascadeLayout type.

Public Constructors

Name | Description
CascadeLayout | Initializes a new instance of the CascadeLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged graph.
Padding | Gets or sets the spacing between nodes in adjacent layers.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

CascadeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CascadeLayout Constructor

CascadeLayout Constructor
[image]

Initializes a new instance of the CascadeLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CascadeLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CascadeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CascadeLayout Properties

CascadeLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged graph.
Padding | Gets or sets the spacing between nodes in adjacent layers.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

CascadeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CascadeLayout.DefaultMarginValue Property

CascadeLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override SizeF DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As SizeF

Property Value

Returns new SizeF(5, 5).

See Also

CascadeLayout Members
CascadeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CascadeLayout.Name Property

CascadeLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Cascade layout".

See Also

CascadeLayout Members
CascadeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CascadeLayout.Orientation Property

CascadeLayout.Orientation Property
[image]

Gets or sets the orientation of the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Vertical.

See Also

CascadeLayout Members
CascadeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CascadeLayout.Padding Property

CascadeLayout.Padding Property
[image]

Gets or sets the spacing between nodes in adjacent layers.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Padding { get; set; }

Visual Basic [image] Copy Code

Public Property Padding As Single

Property Value

The default value is 15.

See Also

CascadeLayout Members
CascadeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout Class

CircularLayout Class
[image]

Implements a circular graph layout algorithm. Nodes are distributed evenly on the circumference of a circle at positions that result in as few link crossing as possible.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class CircularLayout : Layout

Visual Basic [image] Copy Code

Public Class CircularLayout
Inherits Layout

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.CircularLayout

See Also

CircularLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout Members

CircularLayout Members
Constructors Properties Methods
[image]

Implements a circular graph layout algorithm. Nodes are distributed evenly on the circumference of a circle at positions that result in as few link crossing as possible.

The following tables list the members exposed by the CircularLayout type.

Public Constructors

Name | Description
CircularLayout | Initializes a new instance of the CircularLayout class with the default settings.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
AutoRadiusFactor | Gets or sets a multiplier for the automatically calculated radius when Radius is set to 0.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
Radius | Gets or sets the radius of the layout circle.
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
SiftingRounds | Gets or sets the number of sifts to perform during the layout.
SplitGraph | Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout Constructor

CircularLayout Constructor
[image]

Initializes a new instance of the CircularLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CircularLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout Properties

CircularLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
AutoRadiusFactor | Gets or sets a multiplier for the automatically calculated radius when Radius is set to 0.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
Radius | Gets or sets the radius of the layout circle.
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
SiftingRounds | Gets or sets the number of sifts to perform during the layout.
SplitGraph | Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout.AutoRadiusFactor Property

CircularLayout.AutoRadiusFactor Property
[image]

Gets or sets a multiplier for the automatically calculated radius when Radius is set to 0.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float AutoRadiusFactor { get; set; }

Visual Basic [image] Copy Code

Public Property AutoRadiusFactor As Single

Property Value

See Also

CircularLayout Members
CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout.DefaultMarginValue Property

CircularLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override SizeF DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As SizeF

Property Value

Returns new SizeF(5, 5).

See Also

CircularLayout Members
CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout.Name Property

CircularLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Circular layout".

See Also

CircularLayout Members
CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout.Radius Property

CircularLayout.Radius Property
[image]

Gets or sets the radius of the layout circle.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Radius { get; set; }

Visual Basic [image] Copy Code

Public Property Radius As Single

Property Value

A float value specifying the radius. The default value is 60.

Remarks

If this property is set to 0, the layout will try to find an appropriate radius depending on the number and size of the participating nodes.

See Also

CircularLayout Members
CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout.SiftingRounds Property

CircularLayout.SiftingRounds Property
[image]

Gets or sets the number of sifts to perform during the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int SiftingRounds { get; set; }

Visual Basic [image] Copy Code

Public Property SiftingRounds As Integer

Property Value

An integer value specifying the number of sifting rounds. The default value is 1.

Remarks

After calculating the initial placement of nodes using a fast but inaccurate layout function, the algorithm can run a few sifting rounds to reduce the link crossings, as set in this property.

See Also

CircularLayout Members
CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout.SplitGraph Property

CircularLayout.SplitGraph Property
[image]

Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SplitGraph { get; set; }

Visual Basic [image] Copy Code

Public Property SplitGraph As Boolean

Property Value

true if unconnected graphs in the diagram should be laid out independently; otherwise, false. The default is true.

See Also

CircularLayout Members
CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout Class

CompositeLayout Class
Remarks See Also
[image]

Implements a multi-level graph layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class CompositeLayout : Layout

Visual Basic [image] Copy Code

Public Class CompositeLayout
Inherits Layout

Remarks

CompositeLayout partitions the diagram into several subgraphs and applies the algorithm specified via the SubgraphLayout property on each part. If the part is a tree, it is arranged using the algorithm specified via the SubtreeLayout property, which is set to a radial TreeLayout instance by default. Finally the algorithm specified via MasterLayout is applied on the graph that represents the overall partition. By running the polynomial-complexity layout algorithms on small subgraphs, CompositeLayout is able to process a large graph much faster than if a layout algorithm is applied on the whole graph.

CompositeLayout can run on custom partitions specified as lists of nodes, or automatically partition the diagram via two automatic methods based on graph connectivity and graph path lengths. Set the PartitionMethod and CustomPartition properties to specify how the diagram should be partitioned.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.CompositeLayout

See Also

CompositeLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout Members

CompositeLayout Members
Constructors Properties Methods
[image]

Implements a multi-level graph layout algorithm.

The following tables list the members exposed by the CompositeLayout type.

Public Constructors

Name | Description
CompositeLayout | Initializes a new instance of the CompositeLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
BendLinks | Gets or sets a value indicating whether the links in the trees from the additional partitioning pass will bend to avoid crossing leaves in the same tree.
CustomLayout | Gets or sets a custom layout method that should be invoked to arrange subgraphs.
CustomPartition | Gets or sets the custom partition to use when PartitionMethod is set to Custom.
DesiredSubgraphSize | Gets or sets the preferred number of nodes in the subgraphs allocated by the layout algorithm.
EmphasizeTrees | Gets or sets a value indicating whether a cut-vertex between tree and non-tree subgraphs should be considered part of the tree.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
KeepVirtualItems | Gets or sets a value indicating whether to keep the intermediate virtual nodes and links.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MasterLayout | Gets or sets a layout that should be applied globally to the diagram.
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
PartitionMethod | Gets or sets the partitioning method used to decompose the diagram into subgraphs.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
RotateSubgraphs | Gets or sets a value indicating whether subgraphs are rotated to minimize intersections with cross-partition links.
SubgraphLayout | Gets or sets a layout that should be applied to general subgraphs.
SubtreeLayout | Gets or sets a layout that should be applied to subgraphs representing trees.
Tolerance | A multiplier applied to DesiredSubgraphSize to define the allowed subgraph size range.
UseAdditionalPartitioning | Gets or sets a value indicating whether to use an additional partitioning pass on the result of the initial partitioning. This additional partitioning is simplified - it only looks for trees with depth 2.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout Constructor

CompositeLayout Constructor
[image]

Initializes a new instance of the CompositeLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CompositeLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout Properties

CompositeLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
BendLinks | Gets or sets a value indicating whether the links in the trees from the additional partitioning pass will bend to avoid crossing leaves in the same tree.
CustomLayout | Gets or sets a custom layout method that should be invoked to arrange subgraphs.
CustomPartition | Gets or sets the custom partition to use when PartitionMethod is set to Custom.
DesiredSubgraphSize | Gets or sets the preferred number of nodes in the subgraphs allocated by the layout algorithm.
EmphasizeTrees | Gets or sets a value indicating whether a cut-vertex between tree and non-tree subgraphs should be considered part of the tree.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
KeepVirtualItems | Gets or sets a value indicating whether to keep the intermediate virtual nodes and links.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MasterLayout | Gets or sets a layout that should be applied globally to the diagram.
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
PartitionMethod | Gets or sets the partitioning method used to decompose the diagram into subgraphs.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
RotateSubgraphs | Gets or sets a value indicating whether subgraphs are rotated to minimize intersections with cross-partition links.
SubgraphLayout | Gets or sets a layout that should be applied to general subgraphs.
SubtreeLayout | Gets or sets a layout that should be applied to subgraphs representing trees.
Tolerance | A multiplier applied to DesiredSubgraphSize to define the allowed subgraph size range.
UseAdditionalPartitioning | Gets or sets a value indicating whether to use an additional partitioning pass on the result of the initial partitioning. This additional partitioning is simplified - it only looks for trees with depth 2.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout.BendLinks Property

CompositeLayout.BendLinks Property
[image]

Gets or sets a value indicating whether the links in the trees from the additional partitioning pass will bend to avoid crossing leaves in the same tree.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool BendLinks { get; set; }

Visual Basic [image] Copy Code

Public Property BendLinks As Boolean

Property Value

true to bend links in the additional partitioning pass; otherwise, false. The default is false.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout.CustomLayout Property

CompositeLayout.CustomLayout Property
[image]

Gets or sets a custom layout method that should be invoked to arrange subgraphs.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LayoutSubgraph CustomLayout { get; set; }

Visual Basic [image] Copy Code

Public Property CustomLayout As LayoutSubgraph

Property Value

A LayoutSubgraph delegate object.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout.CustomPartition Property

CompositeLayout.CustomPartition Property
[image]

Gets or sets the custom partition to use when PartitionMethod is set to Custom.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<DiagramNodeCollection> CustomPartition { get; set; }

Visual Basic [image] Copy Code

Public Property CustomPartition As List(Of DiagramNodeCollection)

Property Value

A list of DiagramNodeCollection objects that partitions the diagram into subgraphs.

Remarks

This value is used if PartitionMethod is set to Custom.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout.DefaultMarginValue Property

CompositeLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override SizeF DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As SizeF

Property Value

Returns new SizeF(5, 5).

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout.DesiredSubgraphSize Property

CompositeLayout.DesiredSubgraphSize Property
[image]

Gets or sets the preferred number of nodes in the subgraphs allocated by the layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int DesiredSubgraphSize { get; set; }

Visual Basic [image] Copy Code

Public Property DesiredSubgraphSize As Integer

Property Value

An integer value specifying the desired number of nodes in each subgraph.

Remarks

This property is considered by the automatic partitioning algorithm when generating subgraphs. Usually the subgraphs won't contain exactly as many nodes, but are within the Tolerance range around the property value.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout.EmphasizeTrees Property

CompositeLayout.EmphasizeTrees Property
[image]

Gets or sets a value indicating whether a cut-vertex between tree and non-tree subgraphs should be considered part of the tree.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EmphasizeTrees { get; set; }

Visual Basic [image] Copy Code

Public Property EmphasizeTrees As Boolean

Property Value

true to add cut-vertices to trees, otherwise false. The default value is true.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace
SubtreeLayout Property


MindFusion.Diagramming.Layout.CompositeLayout.KeepVirtualItems Property

CompositeLayout.KeepVirtualItems Property
[image]

Gets or sets a value indicating whether to keep the intermediate virtual nodes and links.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool KeepVirtualItems { get; set; }

Visual Basic [image] Copy Code

Public Property KeepVirtualItems As Boolean

Property Value

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout.MasterLayout Property

CompositeLayout.MasterLayout Property
[image]

Gets or sets a layout that should be applied globally to the diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Layout MasterLayout { get; set; }

Visual Basic [image] Copy Code

Public Property MasterLayout As Layout

Property Value

An instance of Layout-derived class. The default is AnnealLayout.

Remarks

Each subset in the layout partition is considered a node in a graph representing the diagram. MasterLayout is used to arrange that graph, while SubgraphLayout and SubtreeLayout are applied on the partition subsets. Since in the general case subsets will occupy areas of varying size, MasterLayout should be set to an instance of a layout class that can handle nodes of non-uniform dimensions.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout.Name Property

CompositeLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Composite layout".

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout.PartitionMethod Property

CompositeLayout.PartitionMethod Property
[image]

Gets or sets the partitioning method used to decompose the diagram into subgraphs.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PartitionMethod PartitionMethod { get; set; }

Visual Basic [image] Copy Code

Public Property PartitionMethod As PartitionMethod

Property Value

A member of the PartitionMethod enumeration. The default value is BiconnectedComponents.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout.RotateSubgraphs Property

CompositeLayout.RotateSubgraphs Property
[image]

Gets or sets a value indicating whether subgraphs are rotated to minimize intersections with cross-partition links.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RotateSubgraphs { get; set; }

Visual Basic [image] Copy Code

Public Property RotateSubgraphs As Boolean

Property Value

true to rotate subgraphs, otherwise false. The default value is false.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout.SubgraphLayout Property

CompositeLayout.SubgraphLayout Property
[image]

Gets or sets a layout that should be applied to general subgraphs.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Layout SubgraphLayout { get; set; }

Visual Basic [image] Copy Code

Public Property SubgraphLayout As Layout

Property Value

An instance of Layout-derived class. The default is CircularLayout.

Remarks

If the subgraph is a tree, CompositeLayout uses SubtreeLayout to arrange it.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace
MasterLayout Property


MindFusion.Diagramming.Layout.CompositeLayout.SubtreeLayout Property

CompositeLayout.SubtreeLayout Property
[image]

Gets or sets a layout that should be applied to subgraphs representing trees.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Layout SubtreeLayout { get; set; }

Visual Basic [image] Copy Code

Public Property SubtreeLayout As Layout

Property Value

An instance of Layout-derived class. The default is radial TreeLayout.

Remarks

The trees isolated by the automatic partitioning methods are undirected, hence when using a custom tree layout you should use settings that ignore the direction of links. Alternatively, use custom partitioning to ensure subgraphs are directed trees, i.e. the links in paths from the root to each node follow the same direction.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace
MasterLayout Property
SubgraphLayout Property
PartitionMethod Property


MindFusion.Diagramming.Layout.CompositeLayout.Tolerance Property

CompositeLayout.Tolerance Property
[image]

A multiplier applied to DesiredSubgraphSize to define the allowed subgraph size range.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Tolerance { get; set; }

Visual Basic [image] Copy Code

Public Property Tolerance As Single

Property Value

A float value specifying the tolerance range. The default is 0.2.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout.UseAdditionalPartitioning Property

CompositeLayout.UseAdditionalPartitioning Property
[image]

Gets or sets a value indicating whether to use an additional partitioning pass on the result of the initial partitioning. This additional partitioning is simplified - it only looks for trees with depth 2.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool UseAdditionalPartitioning { get; set; }

Visual Basic [image] Copy Code

Public Property UseAdditionalPartitioning As Boolean

Property Value

true to use second partitioning pass; otherwise, false. The default is false.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout Class

DecisionLayout Class
Remarks See Also
[image]

Implements a flowchart layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DecisionLayout : Layout

Visual Basic [image] Copy Code

Public Class DecisionLayout
Inherits Layout

Remarks

This algorithm arranges simple flowcharts consisting of decision boxes with up to three outgoing links per node and activity boxes with a single outgoing link per node. The nodes are arranged in columns and rows, whose distance depends on the HorizontalPadding and VerticalPadding property values. When links share the same row or column, they are placed at a distance specified via LinkPadding.

The layout arranges nodes recursively starting from StartNode. If StartNode is not specified, the algorithm selects the root of the deepest branch of the graph's spanning tree as start node.

The overall orientation of the layout can be set via the Orientation property. There is no distinction made between yes/no links, and the node sides by which links are aligned depend only on the order of links in OutgoingLinks collection. If you have a preferred position for links depending on their yes/no type, make sure the OutgoingLinks collections of nodes are sorted by links' logical values.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.DecisionLayout

See Also

DecisionLayout Members
MindFusion.Diagramming.Layout Namespace
FlowchartLayout Class


MindFusion.Diagramming.Layout.DecisionLayout Members

DecisionLayout Members
Constructors Properties Methods
[image]

Implements a flowchart layout algorithm.

The following tables list the members exposed by the DecisionLayout type.

Public Constructors

Name | Description
DecisionLayout | Initializes a new instance of the DecisionLayout class with the default settings.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
HorizontalPadding | Gets or sets the horizontal distance between adjacent nodes.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinkPadding | Gets or sets the distance between parallel links.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged diagram.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
StartNode | Gets or sets the initial (top-left) node in the arranged diagram.
VerticalPadding | Gets or sets the vertical distance between adjacent nodes.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout Constructor

DecisionLayout Constructor
[image]

Initializes a new instance of the DecisionLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DecisionLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout Properties

DecisionLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
HorizontalPadding | Gets or sets the horizontal distance between adjacent nodes.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinkPadding | Gets or sets the distance between parallel links.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged diagram.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
StartNode | Gets or sets the initial (top-left) node in the arranged diagram.
VerticalPadding | Gets or sets the vertical distance between adjacent nodes.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout.DefaultMarginValue Property

DecisionLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override SizeF DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As SizeF

Property Value

Returns new SizeF(5, 5).

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout.HorizontalPadding Property

DecisionLayout.HorizontalPadding Property
[image]

Gets or sets the horizontal distance between adjacent nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float HorizontalPadding { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalPadding As Single

Property Value

A float value specifying the distance between adjacent nodes in same row. The default value is 15.

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout.LinkPadding Property

DecisionLayout.LinkPadding Property
[image]

Gets or sets the distance between parallel links.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float LinkPadding { get; set; }

Visual Basic [image] Copy Code

Public Property LinkPadding As Single

Property Value

A float value specifying the distance between links that share the same row or column. The default value is 2.

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout.Name Property

DecisionLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Decision layout".

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout.Orientation Property

DecisionLayout.Orientation Property
[image]

Gets or sets the orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration specifying the overall layout orientation. The default value is Vertical.

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout.StartNode Property

DecisionLayout.StartNode Property
[image]

Gets or sets the initial (top-left) node in the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode StartNode { get; set; }

Visual Basic [image] Copy Code

Public Property StartNode As DiagramNode

Property Value

A DiagramNode instance specifying the start node.

Remarks

If this property is null, the layout will pick-up a start node automatically.

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout.VerticalPadding Property

DecisionLayout.VerticalPadding Property
[image]

Gets or sets the vertical distance between adjacent nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float VerticalPadding { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalPadding As Single

Property Value

A float value specifying the distance between adjacent nodes in same column. The default value is 15.

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Direction Enumeration

Direction Enumeration
[image]

Specifies a layout direction.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum Direction

Visual Basic [image] Copy Code

Public Enum Direction

Members

Member name | Description
Straight | Indicates either left-to-right or top-to-bottom direction.
Reversed | Indicates either right-to-left or bottom-to-top direction.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout Class

FlowchartLayout Class
Remarks See Also
[image]

FlowchartLayout can be used to arrange flowcharts representing program source code.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class FlowchartLayout : Layout

Visual Basic [image] Copy Code

Public Class FlowchartLayout
Inherits Layout

Remarks

The algorithm recognizes program code -like patterns in the graph, such as loops, sequences and if/switch branchings, and arranges them recursively. FlowchartLayout could be used to arrange other types of graphs as well, though with some restrictions. For example it treats all back links as loops in the code, and expects that they are nested - loop links starting closer to the stop node should end closer to the start node. Another similar restriction is that there shouldn't be any cross-links that connect different branches of a decision sub-graph.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.FlowchartLayout

See Also

FlowchartLayout Members
MindFusion.Diagramming.Layout Namespace
DecisionLayout Class


MindFusion.Diagramming.Layout.FlowchartLayout Members

FlowchartLayout Members
Constructors Properties Methods
[image]

FlowchartLayout can be used to arrange flowcharts representing program source code.

The following tables list the members exposed by the FlowchartLayout type.

Public Constructors

Name | Description
FlowchartLayout | Initializes a new instance of the FlowchartLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
BranchPadding | Gets or sets how much space to leave between adjacent decision branches in the flowchart.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
IgnoreRepeatingLinks | Gets or sets a value indicating whether to ignore repeating links.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinkPadding | Gets or sets how much space to leave between adjacent back links designating nested loops.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the distance between consecutive nodes in the flowchart.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout Constructor

FlowchartLayout Constructor
[image]

Initializes a new instance of the FlowchartLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FlowchartLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout Properties

FlowchartLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
BranchPadding | Gets or sets how much space to leave between adjacent decision branches in the flowchart.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
IgnoreRepeatingLinks | Gets or sets a value indicating whether to ignore repeating links.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinkPadding | Gets or sets how much space to leave between adjacent back links designating nested loops.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the distance between consecutive nodes in the flowchart.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout.BranchPadding Property

FlowchartLayout.BranchPadding Property
[image]

Gets or sets how much space to leave between adjacent decision branches in the flowchart.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float BranchPadding { get; set; }

Visual Basic [image] Copy Code

Public Property BranchPadding As Single

Property Value

A float value specifying the distance between adjacent branches.

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout.DefaultMarginValue Property

FlowchartLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override SizeF DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As SizeF

Property Value

Returns new SizeF(5, 5).

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout.IgnoreRepeatingLinks Property

FlowchartLayout.IgnoreRepeatingLinks Property
[image]

Gets or sets a value indicating whether to ignore repeating links.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IgnoreRepeatingLinks { get; set; }

Visual Basic [image] Copy Code

Public Property IgnoreRepeatingLinks As Boolean

Property Value

true to ignore repeating links, otherwise false. The default value is false.

Remarks

If there are many links connecting the same pair of nodes in the same direction, the analysis of the inherent flowchart structure might fail. In such cases, set this property to true.

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout.LinkPadding Property

FlowchartLayout.LinkPadding Property
[image]

Gets or sets how much space to leave between adjacent back links designating nested loops.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float LinkPadding { get; set; }

Visual Basic [image] Copy Code

Public Property LinkPadding As Single

Property Value

A float value specifying the distance between adjacent back links.

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout.Name Property

FlowchartLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Flowchart layout".

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout.NodeDistance Property

FlowchartLayout.NodeDistance Property
[image]

Gets or sets the distance between consecutive nodes in the flowchart.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Single

Property Value

A float value specifying the distance between neighbor nodes in the same sequence.

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout.Orientation Property

FlowchartLayout.Orientation Property
[image]

Gets or sets the overall orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Vertical.

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout.SplitGraph Property

FlowchartLayout.SplitGraph Property
[image]

Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SplitGraph { get; set; }

Visual Basic [image] Copy Code

Public Property SplitGraph As Boolean

Property Value

true to arrange each subgraph on its own, otherwise false. The default value is true.

Remarks

If this property is set to true, each independent graph in the diagram is laid out in its own layout area. Otherwise all subgraphs are arranged in the same layout area.

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout Class

FlowLayout Class
Remarks See Also
[image]

Implements a flowchart, workflow and process diagrams layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class FlowLayout : Layout

Visual Basic [image] Copy Code

Public Class FlowLayout
Inherits Layout

Remarks

The FlowLayout algorithm can be used to lay out flowcharts, workflow and process diagrams. It works by applying a customizable set of rules for local positioning of connected nodes relatively to each other. On a larger scale, the algorithm keeps groups of nodes separate and prevents links between the groups from crossing nodes. The FlowLayout and ProcessLayout examples included in the MvcDiagram package demonstrate two sample sets of layout rules.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.FlowLayout

See Also

FlowLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout Members

FlowLayout Members
Constructors Properties Methods
[image]

Implements a flowchart, workflow and process diagrams layout algorithm.

The following tables list the members exposed by the FlowLayout type.

Public Constructors

Name | Description
FlowLayout | Initializes a new instance of the FlowLayout class.

Public Properties

Name | Description
Anchoring | Not supported by FlowLayout.
AutoRoute | Gets or sets a value indicating whether longer links should be routed to avoid crossing the diagram nodes.
ChangeLaneDimensions | Gets or sets a value indicating whether the layout algorithm is allowed to change the initial Lane dimensions.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
HorizontalGroupOffset | Gets or sets the horizontal subgroup offset.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LaneBoundaries | Gets or sets the array of custom lane borders.
LaneDistance | Gets or sets the desired distance between adjacent lanes.
LaneType | Gets or sets a value indicating how process diagram swimlanes are defined in the current Diagram.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LayoutRules | Gets or sets the rules used to infer the node positions from their logic identifiers and the connections in the graph.
LevelOffset | Gets or sets the lane border offset.
LinksBend | Specifies whether links between non-adjacent nodes should bend.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Not supported by FlowLayout.
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the desired distance between adjacent nodes in a layer.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
RecreateGraph | Gets or sets a value indicating whether the layout algorithm should recreate its internal graph representation for the MvcDiagram diagram.
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
Root | Gets or sets the node specifying which subgraph of the diagram should be laid out.
VerticalGroupOffset | Gets or sets the vertical subgroup offset.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
AddNode | Adds the specified node to the already arranged diagram.
Arrange | Applies the layout to the specified Diagram instance and an array of rectangles defining custom lane borders.
ArrangeCore | Applies the layout to the specified subset of items from the specified Diagram instance and an array of rectangles defining custom lane borders.
BendLinks | Bends all links in an already arranged diagram.
InsertNode | Inserts the specified node between two nodes connected by the by specified link.
RemoveNode | Removes the specified node from an existing diagram.

See Also

FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout Constructor

FlowLayout Constructor
[image]

Initializes a new instance of the FlowLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FlowLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout Methods

FlowLayout Methods
[image]

Public Methods

Name | Description
AddNode | Adds the specified node to the already arranged diagram.
Arrange | Applies the layout to the specified Diagram instance and an array of rectangles defining custom lane borders.
ArrangeCore | Applies the layout to the specified subset of items from the specified Diagram instance and an array of rectangles defining custom lane borders.
BendLinks | Bends all links in an already arranged diagram.
InsertNode | Inserts the specified node between two nodes connected by the by specified link.
RemoveNode | Removes the specified node from an existing diagram.

See Also

FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.AddNode Method

FlowLayout.AddNode Method
[image]

Adds the specified node to the already arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddNode (
DiagramNode node,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Function AddNode ( _
node As DiagramNode, _
diagram As Diagram _
) As Boolean

Parameters

node
A DiagramNode instance.
diagram
A Diagram instance.

Return Value

true if the node has been added successfully; otherwise, false.

Remarks

You can use AddNode to implement incremental layout of a diagram, for example, by adding new nodes drawn by the user or added by a context menu command. For this method to work correctly, RecreateGraph must be disabled.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.Arrange Method

FlowLayout.Arrange Method
[image]

Applies the layout to the specified Diagram instance and an array of rectangles defining custom lane borders.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool Arrange (
Diagram diagram,
RectangleF[] laneBorders
)

Visual Basic [image] Copy Code

Public Overridable Function Arrange ( _
diagram As Diagram, _
laneBorders As RectangleF() _
) As Boolean

Parameters

diagram
The Diagram to arrange.
laneBorders
An array of rectangles defining custom lane borders.

Return Value

true if the diagram has been arranged successfully; otherwise, false.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.ArrangeCore Method

FlowLayout.ArrangeCore Method
[image]

Applies the layout to the specified subset of items from the specified Diagram instance and an array of rectangles defining custom lane borders.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ArrangeCore (
Diagram diagram,
DiagramItemCollection items,
RectangleF[] laneBorders
)

Visual Basic [image] Copy Code

Public Function ArrangeCore( _
diagram As Diagram, _
items As DiagramItemCollection, _
laneBorders() As RectangleF _
) As Boolean

Parameters

diagram

The Diagram to arrange.

items

Specifies a subset of diagram items to arrange.

laneBorders

An array of rectangles defining custom lane borders.

Return Value

true if the diagram has been arranged successfully; otherwise, false.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.BendLinks Method

FlowLayout.BendLinks Method
[image]

Bends all links in an already arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void BendLinks (
Diagram diagram
)

Visual Basic [image] Copy Code

Public Sub BendLinks ( _
diagram As Diagram _
)

Parameters

diagram
A Diagram instance.

Remarks

You can use BendLinks to implement incremental layout of a diagram, for example, by calling it after the user draws a new link, or after several new links are added programmatically. For this method to work correctly, RecreateGraph must be disabled.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.InsertNode Method

FlowLayout.InsertNode Method
[image]

Inserts the specified node between two nodes connected by the by specified link.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool InsertNode (
DiagramNode node,
DiagramLink linkToSplit,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Function InsertNode ( _
node As DiagramNode, _
linkToSplit As DiagramLink, _
diagram As Diagram _
) As Boolean

Parameters

node
The DiagramNode to insert.
linkToSplit
The DiagramLink to split.
diagram
A Diagram instance.

Return Value

true if the node has been added successfully; otherwise, false.

Remarks

You can use InsertNode to implement incremental layout of a diagram, for example, by adding new nodes drawn by the user or added through a context menu command. For this method to work correctly, RecreateGraph must be disabled.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.RemoveNode Method

FlowLayout.RemoveNode Method
[image]

Removes the specified node from an existing diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RemoveNode (
DiagramNode node,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Function RemoveNode ( _
node As DiagramNode, _
diagram As Diagram _
) As Boolean

Parameters

node
The DiagramNode to remove.
diagram
An already arranged Diagram.

Return Value

true if the node has been removed successfully; otherwise, false.

Remarks

You can use RemoveNode to implement incremental layout of a diagram, for example, by removing nodes deleted by the user or removed via a context menu command. For this method to work correctly, RecreateGraph must be disabled.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout Properties

FlowLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Not supported by FlowLayout.
AutoRoute | Gets or sets a value indicating whether longer links should be routed to avoid crossing the diagram nodes.
ChangeLaneDimensions | Gets or sets a value indicating whether the layout algorithm is allowed to change the initial Lane dimensions.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
HorizontalGroupOffset | Gets or sets the horizontal subgroup offset.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LaneBoundaries | Gets or sets the array of custom lane borders.
LaneDistance | Gets or sets the desired distance between adjacent lanes.
LaneType | Gets or sets a value indicating how process diagram swimlanes are defined in the current Diagram.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LayoutRules | Gets or sets the rules used to infer the node positions from their logic identifiers and the connections in the graph.
LevelOffset | Gets or sets the lane border offset.
LinksBend | Specifies whether links between non-adjacent nodes should bend.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Not supported by FlowLayout.
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the desired distance between adjacent nodes in a layer.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
RecreateGraph | Gets or sets a value indicating whether the layout algorithm should recreate its internal graph representation for the MvcDiagram diagram.
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
Root | Gets or sets the node specifying which subgraph of the diagram should be laid out.
VerticalGroupOffset | Gets or sets the vertical subgroup offset.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.Anchoring Property

FlowLayout.Anchoring Property
[image]

Not supported by FlowLayout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public new Anchoring Anchoring { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property Anchoring As Anchoring

Property Value

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.AutoRoute Property

FlowLayout.AutoRoute Property
[image]

Gets or sets a value indicating whether longer links should be routed to avoid crossing the diagram nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoRoute { get; set; }

Visual Basic [image] Copy Code

Public Property AutoRoute As Boolean

Property Value

true to look for link routes that do not cross nodes; otherwise, false. The default is false.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.ChangeLaneDimensions Property

FlowLayout.ChangeLaneDimensions Property
[image]

Gets or sets a value indicating whether the layout algorithm is allowed to change the initial Lane dimensions.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ChangeLaneDimensions { get; set; }

Visual Basic [image] Copy Code

Public Property ChangeLaneDimensions As Boolean

Property Value

true if the algorithm is allowed to change the lane dimensions; otherwise, false. The default is true.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.DefaultMarginValue Property

FlowLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override SizeF DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As SizeF

Property Value

Returns new SizeF(10, 10).

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.HorizontalGroupOffset Property

FlowLayout.HorizontalGroupOffset Property
[image]

Gets or sets the horizontal subgroup offset.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float HorizontalGroupOffset { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalGroupOffset As Single

Property Value

A value specifying the horizontal distance between groups of nodes. The default is 25.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.LaneBoundaries Property

FlowLayout.LaneBoundaries Property
[image]

Gets or sets the array of custom lane borders.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF[] LaneBoundaries { get; set; }

Visual Basic [image] Copy Code

Public Property LaneBoundaries As RectangleF()

Property Value

An array of rectangles specifying custom lane borders.

Remarks

This array is used when LaneType is set to Custom.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.LaneDistance Property

FlowLayout.LaneDistance Property
[image]

Gets or sets the desired distance between adjacent lanes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float LaneDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LaneDistance As Single

Property Value

Remarks

The lanes are placed at the specified distance from each other only if ChangeLaneDimensions is enabled.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.LaneType Property

FlowLayout.LaneType Property
[image]

Gets or sets a value indicating how process diagram swimlanes are defined in the current Diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LaneType LaneType { get; set; }

Visual Basic [image] Copy Code

Public Property LaneType As LaneType

Property Value

A member of the LaneType enumeration. The default is LaneBoxes.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.LayoutRules Property

FlowLayout.LayoutRules Property
[image]

Gets or sets the rules used to infer the node positions from their logic identifiers and the connections in the graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FlowLayoutRules LayoutRules { get; set; }

Visual Basic [image] Copy Code

Public Property LayoutRules As FlowLayoutRules

Property Value

An instance of the FlowLayoutRules class.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.LevelOffset Property

FlowLayout.LevelOffset Property
[image]

Gets or sets the lane border offset.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float LevelOffset { get; set; }

Visual Basic [image] Copy Code

Public Property LevelOffset As Single

Property Value

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.LinksBend Property

FlowLayout.LinksBend Property
[image]

Specifies whether links between non-adjacent nodes should bend.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool LinksBend { get; set; }

Visual Basic [image] Copy Code

Public Property LinksBend As Boolean

Property Value

true if links should bend; otherwise, false. The default is true.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.MultipleGraphsPlacement Property

FlowLayout.MultipleGraphsPlacement Property
[image]

Not supported by FlowLayout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public new MultipleGraphsPlacement MultipleGraphsPlacement { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property MultipleGraphsPlacement As MultipleGraphsPlacement

Property Value

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.Name Property

FlowLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Flow layout".

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.NodeDistance Property

FlowLayout.NodeDistance Property
[image]

Gets or sets the desired distance between adjacent nodes in a layer.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Single

Property Value

A float value specifying the desired distance between nodes. The default is 4.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.RandomSeed Property

FlowLayout.RandomSeed Property
[image]

Gets or sets the randomization seed to use for generating random node positions.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int RandomSeed { get; set; }

Visual Basic [image] Copy Code

Public Property RandomSeed As Integer

Property Value

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.RecreateGraph Property

FlowLayout.RecreateGraph Property
[image]

Gets or sets a value indicating whether the layout algorithm should recreate its internal graph representation for the MvcDiagram diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RecreateGraph { get; set; }

Visual Basic [image] Copy Code

Public Property RecreateGraph As Boolean

Property Value

true if the graph representation should be recreated when Arrange is executed, otherwise, false. The default is false.

Remarks

Keep this property set to false if you wish to use the AddNode and InsertNode methods to implement incremental layout.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.Root Property

FlowLayout.Root Property
[image]

Gets or sets the node specifying which subgraph of the diagram should be laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As DiagramNode

Property Value

An instance of the DiagramNode class. The default is a null reference (Nothing in Visual Basic).

Remarks

All links and nodes that can be reached from the root by following recursively its links form a graph. If the root is specified, only the graph which it defines is laid out by Arrange.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.VerticalGroupOffset Property

FlowLayout.VerticalGroupOffset Property
[image]

Gets or sets the vertical subgroup offset.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float VerticalGroupOffset { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalGroupOffset As Single

Property Value

A value specifying the vertical distance between groups of nodes. The default is 70.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FractalLayout Class

FractalLayout Class
Remarks See Also
[image]

A tree layout algorithm that places child nodes symmetrically around their parent node.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class FractalLayout : Layout

Visual Basic [image] Copy Code

Public Class FractalLayout
Inherits Layout

Remarks

Nodes at the lowest level are arranged directly in a circle around their parent. At the upper level, the already arranged nodes form branches that are arranged in a circle around the new parent node. The algorithm is recursively repeated till the highest level is reached. If nodes in the tree have uniform number of children, the end result has fractal-like appearance (subsets of the graph look like scaled-down copies of the whole graph).

You can choose which node should be displayed at the center of the topmost circle by setting the Root property. If it is not specified, the algorithm automatically selects a root that leads to more balanced distribution of nodes.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.FractalLayout

See Also

FractalLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FractalLayout Members

FractalLayout Members
Constructors Properties Methods
[image]

A tree layout algorithm that places child nodes symmetrically around their parent node.

The following tables list the members exposed by the FractalLayout type.

Public Constructors

Name | Description
FractalLayout | Initializes a new instance of the FractalLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
Root | Gets or sets the tree root.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

FractalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FractalLayout Constructor

FractalLayout Constructor
[image]

Initializes a new instance of the FractalLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FractalLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

FractalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FractalLayout Properties

FractalLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
Root | Gets or sets the tree root.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

FractalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FractalLayout.DefaultMarginValue Property

FractalLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override SizeF DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As SizeF

Property Value

See Also

FractalLayout Members
FractalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FractalLayout.Name Property

FractalLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Fractal layout".

See Also

FractalLayout Members
FractalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FractalLayout.Root Property

FractalLayout.Root Property
[image]

Gets or sets the tree root.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As DiagramNode

Property Value

A DiagramNode that should be placed at the center of the arranged tree. The default value is null.

Remarks

If there is no root specified, the algorithm automatically selects one that will lead to more balanced branch sizes.

See Also

FractalLayout Members
FractalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout Class

GridLayout Class
Remarks See Also
[image]

Implements a grid graph layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class GridLayout : Layout

Visual Basic [image] Copy Code

Public Class GridLayout
Inherits Layout

Remarks

GridLayout arranges diagram nodes in a grid, keeping connected nodes close together. The algorithm strives to achieve a small number of link crossings. It is based on an iterative process whose initial steps shuffle the grid nodes randomly. That can lead to very different results each time the algorithm is run.

To apply the layout to a diagram, create a GridLayout instance, set its members and invoke the Arrange method. Arrange lays out all subgraphs in a diagram, unless the Root property is set.

The distance between points in the layout grid can be changed through GridSize. Nodes to be placed at the upper-left and lower-right corners of the grid can be assigned to StartNode and EndNode.

Anchoring specifies whether the layout algorithm must attach links to the anchor points of graphs nodes. The grid layout algorithm produces best results if it can place link ends at arbitrary positions over nodes' outlines, that is, when using the Ignore value. If your application logic requires links to be always attached to anchor points, use the other two values. In such cases Reassign would yield better results.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.GridLayout

See Also

GridLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout Members

GridLayout Members
Constructors Properties Methods
[image]

Implements a grid graph layout algorithm.

The following tables list the members exposed by the GridLayout type.

Public Constructors

Name | Description
GridLayout | Initializes a new instance of the GridLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
EndNode | Gets or sets the node that is placed at the lower right corner of the grid.
GridSize | Gets or sets the desired distance between adjacent grid points.
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
Iterations | Gets or sets for how many iterations to run the grid layout algorithm.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
Root | Gets or sets a node indicating which subgraph of the diagram should be laid out.
SplitGraph | Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.
StartNode | Gets or sets the node that is placed at the upper left corner of the grid.
TimeLimit | Gets or sets a time-out value for the path-finding part of the grid layout algorithm.
UseLongestPath | Gets or sets a value indicating whether the algorithm should arrange nodes around the longest path in the graph.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout Constructor

GridLayout Constructor
[image]

Initializes a new instance of the GridLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GridLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout Properties

GridLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
EndNode | Gets or sets the node that is placed at the lower right corner of the grid.
GridSize | Gets or sets the desired distance between adjacent grid points.
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
Iterations | Gets or sets for how many iterations to run the grid layout algorithm.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
Root | Gets or sets a node indicating which subgraph of the diagram should be laid out.
SplitGraph | Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.
StartNode | Gets or sets the node that is placed at the upper left corner of the grid.
TimeLimit | Gets or sets a time-out value for the path-finding part of the grid layout algorithm.
UseLongestPath | Gets or sets a value indicating whether the algorithm should arrange nodes around the longest path in the graph.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.DefaultMarginValue Property

GridLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override SizeF DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As SizeF

Property Value

Returns new SizeF(10, 10).

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.EndNode Property

GridLayout.EndNode Property
[image]

Gets or sets the node that is placed at the lower right corner of the grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode EndNode { get; set; }

Visual Basic [image] Copy Code

Public Property EndNode As DiagramNode

Property Value

An instance of the DiagramNode class. Default value is null (Nothing in Visual Basic).

Remarks

If you assign a node to that property, then StartNode cannot be null and must be set too. GridLayout usually produces better layouts if both StartNode and EndNode are null references; in such a case the algorithm automatically selects suitable nodes.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.GridSize Property

GridLayout.GridSize Property
[image]

Gets or sets the desired distance between adjacent grid points.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float GridSize { get; set; }

Visual Basic [image] Copy Code

Public Property GridSize As Single

Property Value

A float number specifying the grid size. The default is 25.

Remarks

When placing a node at a grid position, the node center point is aligned to the grid point at that position.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.Iterations Property

GridLayout.Iterations Property
[image]

Gets or sets for how many iterations to run the grid layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Iterations { get; set; }

Visual Basic [image] Copy Code

Public Property Iterations As Integer

Property Value

An integer number specifying the number of iterations. The default is 3000.

Remarks

More iterations would yield better layouts but require more time to complete.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace
Progress Property


MindFusion.Diagramming.Layout.GridLayout.Name Property

GridLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Grid layout".

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.RandomSeed Property

GridLayout.RandomSeed Property
[image]

Gets or sets the randomization seed to use for generating random node positions.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int RandomSeed { get; set; }

Visual Basic [image] Copy Code

Public Property RandomSeed As Integer

Property Value

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.Root Property

GridLayout.Root Property
[image]

Gets or sets a node indicating which subgraph of the diagram should be laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As DiagramNode

Property Value

An instance of the DiagramNode class. The default is a null reference (Nothing in Visual Basic).

Remarks

All links and nodes that can be reached from the root by following recursively its links form a graph. If the root is specified, only the graph which it defines is laid out by Arrange.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.SplitGraph Property

GridLayout.SplitGraph Property
[image]

Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SplitGraph { get; set; }

Visual Basic [image] Copy Code

Public Property SplitGraph As Boolean

Property Value

true to split the graph; otherwise, false.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.StartNode Property

GridLayout.StartNode Property
[image]

Gets or sets the node that is placed at the upper left corner of the grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode StartNode { get; set; }

Visual Basic [image] Copy Code

Public Property StartNode As DiagramNode

Property Value

An instance of the DiagramNode class. The default is null (Nothing in Visual Basic).

Remarks

If you assign a node to that property, then EndNode cannot be null and must be set too. GridLayout usually produces better layouts if both StartNode and EndNode are null references; in such a case the algorithm automatically selects suitable nodes.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.TimeLimit Property

GridLayout.TimeLimit Property
[image]

Gets or sets a time-out value for the path-finding part of the grid layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public long TimeLimit { get; set; }

Visual Basic [image] Copy Code

Public Property TimeLimit As Long

Property Value

An integer value specifying time-out in milliseconds. The default is 10000 (10 seconds).

Remarks

The grid layout algorithm arranges graph nodes and links along the longest path in the graph. Large graphs with many links could contain hundreds of thousands of possible paths, so finding the longest one would be very time-consuming. When the time-out set with this property occurs, the path-finding routine stops and the layout algorithm uses the longest path known at that moment. Usually, for graphs containing several hundreds of nodes, 1-2 seconds are enough to find a path long enough to produce a nice layout.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.UseLongestPath Property

GridLayout.UseLongestPath Property
[image]

Gets or sets a value indicating whether the algorithm should arrange nodes around the longest path in the graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool UseLongestPath { get; set; }

Visual Basic [image] Copy Code

Public Property UseLongestPath As Boolean

Property Value

true to look for the longest path in the graph and arrange nodes around it; otherwise, false.

Remarks

Initially, the algorithm places nodes and links from the longest path in the graph at the grid diagonal, and arranges the rest of the nodes around the diagonal. Large graphs with many links could contain hundreds of thousands of possible paths, so finding the longest one would be very time-consuming. Disabling this property will let you skip the path-finding part of the algorithm, which will make it work much faster.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.HierarchicalLayout Class

HierarchicalLayout Class
Remarks See Also
[image]

Performs hierarchical layout on simple, connected, level-planar graphs.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class HierarchicalLayout : Layout

Visual Basic [image] Copy Code

Public Class HierarchicalLayout
Inherits Layout

Remarks

HierarchicalLayout places nodes on user-defined levels, such that if the source graph is level-planar, all links are guaranteed to have a single segment and will not intersect. A graph is considered level-planar if it is possible to draw it without link intersections when its nodes are positioned on predefined levels. The layout method requires that for each node LayoutTraits contains a HierarchicalLayoutTraits.Level entry specifying the level, and no two connected nodes must be on the same level.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.HierarchicalLayout

See Also

HierarchicalLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.HierarchicalLayout Members

HierarchicalLayout Members
Constructors Properties Methods
[image]

Performs hierarchical layout on simple, connected, level-planar graphs.

The following tables list the members exposed by the HierarchicalLayout type.

Public Constructors

Name | Description
HierarchicalLayout | Initializes a new instance of the HierarchicalLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LevelDistance | Gets or sets the distance between adjacent levels in the hierarchical layout.
LinkBendFactor | Gets or sets the bending factor of links.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged graph.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

HierarchicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.HierarchicalLayout Constructor

HierarchicalLayout Constructor
[image]

Initializes a new instance of the HierarchicalLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HierarchicalLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

HierarchicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.HierarchicalLayout Properties

HierarchicalLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LevelDistance | Gets or sets the distance between adjacent levels in the hierarchical layout.
LinkBendFactor | Gets or sets the bending factor of links.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged graph.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

HierarchicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.HierarchicalLayout.DefaultMarginValue Property

HierarchicalLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override SizeF DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As SizeF

Property Value

Returns new SizeF(5, 5).

See Also

HierarchicalLayout Members
HierarchicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.HierarchicalLayout.LevelDistance Property

HierarchicalLayout.LevelDistance Property
[image]

Gets or sets the distance between adjacent levels in the hierarchical layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float LevelDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LevelDistance As Single

Property Value

The default value is 40.

See Also

HierarchicalLayout Members
HierarchicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.HierarchicalLayout.LinkBendFactor Property

HierarchicalLayout.LinkBendFactor Property
[image]

Gets or sets the bending factor of links.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float LinkBendFactor { get; set; }

Visual Basic [image] Copy Code

Public Property LinkBendFactor As Single

Property Value

The default value is 1.

Remarks

A value of 1 indicates that the links should not bend. A value less than 1 indicates that the links should bend towards the geometric center of the graph. A value greater than 1 indicates that the links should bend outwards.

See Also

HierarchicalLayout Members
HierarchicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.HierarchicalLayout.Name Property

HierarchicalLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Hierarchical layout".

See Also

HierarchicalLayout Members
HierarchicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.HierarchicalLayout.Orientation Property

HierarchicalLayout.Orientation Property
[image]

Gets or sets the orientation of the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Vertical.

See Also

HierarchicalLayout Members
HierarchicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout Interface

ILayout Interface
[image]

Common interface for all MvcDiagram layout classes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface ILayout

Visual Basic [image] Copy Code

Public Interface ILayout

Inheritors

MindFusion.Diagramming.Layout.Layout

See Also

ILayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout Members

ILayout Members
Properties Methods
[image]

Common interface for all MvcDiagram layout classes.

The following tables list the members exposed by the ILayout type.

Public Properties

Name | Description
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.

Public Methods

Name | Description
Arrange | Applies the layout to the specified Diagram instance.

See Also

ILayout Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout Methods

ILayout Methods
[image]

Public Methods

Name | Description
Arrange | Applies the layout to the specified Diagram instance.

See Also

ILayout Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout.Arrange Method

ILayout.Arrange Method
[image]

Applies the layout to the specified Diagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract bool Arrange (
Diagram diagram
)

Visual Basic [image] Copy Code

Public MustOverride Function Arrange ( _
diagram As Diagram _
) As Boolean

Parameters

diagram

The Diagram that will be arranged.

Return Value

Returns whether the arrangement was successful.

See Also

ILayout Members
ILayout Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout Properties

ILayout Properties
[image]

Public Properties

Name | Description
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.

See Also

ILayout Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout.LayoutLink Property

ILayout.LayoutLink Property
[image]

Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract LayoutLink LayoutLink { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property LayoutLink As LayoutLink

Property Value

An instance of the LayoutLink delegate.

See Also

ILayout Members
ILayout Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout.LayoutNode Property

ILayout.LayoutNode Property
[image]

Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract LayoutNode LayoutNode { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property LayoutNode As LayoutNode

Property Value

An instance of the LayoutNode delegate.

See Also

ILayout Members
ILayout Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid Interface

ISwimlaneGrid Interface
[image]

Represents an object which can be used by a SwimlaneLayout to adjust the corresponding swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface ISwimlaneGrid

Visual Basic [image] Copy Code

Public Interface ISwimlaneGrid

Inheritors

MindFusion.Diagramming.Layout.LaneGrid

See Also

ISwimlaneGrid Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid Members

ISwimlaneGrid Members
Methods
[image]

Represents an object which can be used by a SwimlaneLayout to adjust the corresponding swimlane grid.

The following tables list the members exposed by the ISwimlaneGrid type.

Public Methods

Name | Description
GetColumnCount | Gets the number of columns in the grid.
GetColumnWidth | Gets the the width of the specified column in the swimlane grid.
GetRowCount | Gets the number of rows in the swimlane grid.
GetRowHeight | Gets the the height of the specified row in the swimlane grid.
SetColumnCount | Sets the number of columns in the swimlane grid.
SetColumnWidth | Sets the the width of the specified column in the swimlane grid.
SetLeftMargin | Sets the left margin of the swimlane grid.
SetRowCount | Sets the number of rows in the swimlane grid.
SetRowHeight | Sets the the height of the specified row in the swimlane grid.
SetTopMargin | Sets the top margin of the swimlane grid.

See Also

ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid Methods

ISwimlaneGrid Methods
[image]

Public Methods

Name | Description
GetColumnCount | Gets the number of columns in the grid.
GetColumnWidth | Gets the the width of the specified column in the swimlane grid.
GetRowCount | Gets the number of rows in the swimlane grid.
GetRowHeight | Gets the the height of the specified row in the swimlane grid.
SetColumnCount | Sets the number of columns in the swimlane grid.
SetColumnWidth | Sets the the width of the specified column in the swimlane grid.
SetLeftMargin | Sets the left margin of the swimlane grid.
SetRowCount | Sets the number of rows in the swimlane grid.
SetRowHeight | Sets the the height of the specified row in the swimlane grid.
SetTopMargin | Sets the top margin of the swimlane grid.

See Also

ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.GetColumnCount Method

ISwimlaneGrid.GetColumnCount Method
[image]

Gets the number of columns in the grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

int GetColumnCount ()

Visual Basic [image] Copy Code

Function GetColumnCount () As Integer

Return Value

The number of columns in the grid.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.GetColumnWidth Method

ISwimlaneGrid.GetColumnWidth Method
[image]

Gets the the width of the specified column in the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

float GetColumnWidth (
int index
)

Visual Basic [image] Copy Code

Function GetColumnWidth( _
index As Integer _
) As Single

Parameters

index

The zero-based index of the column.

Return Value

The width of the column.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.GetRowCount Method

ISwimlaneGrid.GetRowCount Method
[image]

Gets the number of rows in the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

int GetRowCount ()

Visual Basic [image] Copy Code

Function GetRowCount () As Integer

Return Value

The number of rows in the grid.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.GetRowHeight Method

ISwimlaneGrid.GetRowHeight Method
[image]

Gets the the height of the specified row in the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

float GetRowHeight (
int index
)

Visual Basic [image] Copy Code

Function GetRowHeight( _
index As Integer _
) As Single

Parameters

index

The zero-based index of the row.

Return Value

The height of the row.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.SetColumnCount Method

ISwimlaneGrid.SetColumnCount Method
[image]

Sets the number of columns in the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void SetColumnCount (
int value
)

Visual Basic [image] Copy Code

Sub SetColumnCount( _
value As Integer _
)

Parameters

value

A non-negative integer value specifying the number of columns.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.SetColumnWidth Method

ISwimlaneGrid.SetColumnWidth Method
[image]

Sets the the width of the specified column in the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void SetColumnWidth (
int index,
float value
)

Visual Basic [image] Copy Code

Sub SetColumnWidth( _
index As Integer, _
value As Single _
)

Parameters

index

The zero-based index of the column.

value

The new width of the column.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.SetLeftMargin Method

ISwimlaneGrid.SetLeftMargin Method
[image]

Sets the left margin of the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void SetLeftMargin (
float value
)

Visual Basic [image] Copy Code

Sub SetLeftMargin( _
value As Single _
)

Parameters

value

The distance between the left side of the grid and the diagram bounds.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.SetRowCount Method

ISwimlaneGrid.SetRowCount Method
[image]

Sets the number of rows in the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void SetRowCount (
int value
)

Visual Basic [image] Copy Code

Sub SetRowCount( _
value As Integer _
)

Parameters

value

A non-negative integer value specifying the number of rows.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.SetRowHeight Method

ISwimlaneGrid.SetRowHeight Method
[image]

Sets the the height of the specified row in the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void SetRowHeight (
int index,
float value
)

Visual Basic [image] Copy Code

Sub SetRowHeight( _
index As Integer, _
value As Single _
)

Parameters

index

The zero-based index of the row.

value

The new height of the row.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.SetTopMargin Method

ISwimlaneGrid.SetTopMargin Method
[image]

Sets the top margin of the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void SetTopMargin (
float value
)

Visual Basic [image] Copy Code

Sub SetTopMargin( _
value As Single _
)

Parameters

value

The distance between the top side of the grid and the diagram bounds.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid Class

LaneGrid Class
[image]

Represents an ISwimlaneGrid which operates on a MindFusion.Diagramming.Lanes.Grid object.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LaneGrid : ISwimlaneGrid

Visual Basic [image] Copy Code

Public Class LaneGrid
Implements ISwimlaneGrid

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.LaneGrid

See Also

LaneGrid Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid Members

LaneGrid Members
Constructors Methods
[image]

Represents an ISwimlaneGrid which operates on a MindFusion.Diagramming.Lanes.Grid object.

The following tables list the members exposed by the LaneGrid type.

Public Constructors

Name | Description
LaneGrid | Initializes a new instance of the LaneGrid class.

Public Methods

Name | Description
GetColumnCount | ISwimlaneGrid.GetColumnCount implementation.
GetColumnWidth | ISwimlaneGrid.GetColumnCount implementation.
GetRowCount | ISwimlaneGrid.GetRowCount implementation.
GetRowHeight | ISwimlaneGrid.GetRowHeight implementation.
SetColumnCount | ISwimlaneGrid.SetColumnCount implementation.
SetColumnWidth | ISwimlaneGrid.SetColumnCount implementation.
SetLeftMargin | ISwimlaneGrid.SetLeftMargin implementation.
SetRowCount | ISwimlaneGrid.SetRowCount implementation.
SetRowHeight | ISwimlaneGrid.SetRowHeight implementation.
SetTopMargin | ISwimlaneGrid.SetTopMargin implementation.

See Also

LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid Constructor

LaneGrid Constructor
[image]

Initializes a new instance of the LaneGrid class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LaneGrid (
Grid grid
)

Visual Basic [image] Copy Code

Public New ( _
grid As Grid _
)

Parameters

grid

See Also

LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid Methods

LaneGrid Methods
[image]

Public Methods

Name | Description
GetColumnCount | ISwimlaneGrid.GetColumnCount implementation.
GetColumnWidth | ISwimlaneGrid.GetColumnCount implementation.
GetRowCount | ISwimlaneGrid.GetRowCount implementation.
GetRowHeight | ISwimlaneGrid.GetRowHeight implementation.
SetColumnCount | ISwimlaneGrid.SetColumnCount implementation.
SetColumnWidth | ISwimlaneGrid.SetColumnCount implementation.
SetLeftMargin | ISwimlaneGrid.SetLeftMargin implementation.
SetRowCount | ISwimlaneGrid.SetRowCount implementation.
SetRowHeight | ISwimlaneGrid.SetRowHeight implementation.
SetTopMargin | ISwimlaneGrid.SetTopMargin implementation.

See Also

LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.GetColumnCount Method

LaneGrid.GetColumnCount Method
[image]

ISwimlaneGrid.GetColumnCount implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int GetColumnCount ()

Visual Basic [image] Copy Code

Public Function GetColumnCount () As Integer

Return Value

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.GetColumnWidth Method

LaneGrid.GetColumnWidth Method
[image]

ISwimlaneGrid.GetColumnCount implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float GetColumnWidth (
int index
)

Visual Basic [image] Copy Code

Public Function GetColumnWidth( _
index As Integer _
) As Single

Parameters

index

Return Value

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.GetRowCount Method

LaneGrid.GetRowCount Method
[image]

ISwimlaneGrid.GetRowCount implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int GetRowCount ()

Visual Basic [image] Copy Code

Public Function GetRowCount () As Integer

Return Value

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.GetRowHeight Method

LaneGrid.GetRowHeight Method
[image]

ISwimlaneGrid.GetRowHeight implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float GetRowHeight (
int index
)

Visual Basic [image] Copy Code

Public Function GetRowHeight( _
index As Integer _
) As Single

Parameters

index

Return Value

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.SetColumnCount Method

LaneGrid.SetColumnCount Method
[image]

ISwimlaneGrid.SetColumnCount implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetColumnCount (
int value
)

Visual Basic [image] Copy Code

Public Sub SetColumnCount( _
value As Integer _
)

Parameters

value

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.SetColumnWidth Method

LaneGrid.SetColumnWidth Method
[image]

ISwimlaneGrid.SetColumnCount implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetColumnWidth (
int index,
float value
)

Visual Basic [image] Copy Code

Public Sub SetColumnWidth( _
index As Integer, _
value As Single _
)

Parameters

index

value

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.SetLeftMargin Method

LaneGrid.SetLeftMargin Method
[image]

ISwimlaneGrid.SetLeftMargin implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetLeftMargin (
float value
)

Visual Basic [image] Copy Code

Public Sub SetLeftMargin( _
value As Single _
)

Parameters

value

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.SetRowCount Method

LaneGrid.SetRowCount Method
[image]

ISwimlaneGrid.SetRowCount implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetRowCount (
int value
)

Visual Basic [image] Copy Code

Public Sub SetRowCount( _
value As Integer _
)

Parameters

value

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.SetRowHeight Method

LaneGrid.SetRowHeight Method
[image]

ISwimlaneGrid.SetRowHeight implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetRowHeight (
int index,
float value
)

Visual Basic [image] Copy Code

Public Sub SetRowHeight( _
index As Integer, _
value As Single _
)

Parameters

index

value

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.SetTopMargin Method

LaneGrid.SetTopMargin Method
[image]

ISwimlaneGrid.SetTopMargin implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetTopMargin (
float value
)

Visual Basic [image] Copy Code

Public Sub SetTopMargin( _
value As Single _
)

Parameters

value

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneType Enumeration

LaneType Enumeration
[image]

Specifies where FlowLayout gets the swimlane dimensions from.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum LaneType

Visual Basic [image] Copy Code

Public Enum LaneType

Members

Member name | Description
LaneGrid | FlowLayout gets the swimlane dimensions from Diagram.LaneGrid.
LaneNodes | FlowLayout interprets locked background nodes as swimlanes.
Custom | FlowLayout should get the swimlane dimensions from the array of rectangles passed as an argument to Arrange.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout Class

LayeredLayout Class
Remarks See Also
[image]

Implements a layered graph layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LayeredLayout : Layout

Visual Basic [image] Copy Code

Public Class LayeredLayout
Inherits Layout

Remarks

This algorithm assigns diagram nodes to distinct horizontal or vertical layers. While arranging the layers, the layout routine seeks to meet the following criteria:

  • connected nodes must be placed close together;
  • links must flow in one direction if possible;
  • links must cross as few layers as possible;
  • links must not cross other links;

To apply this layout to a diagram, create a LayeredLayout instance, set its members and invoke the Arrange method. Arrange lays out all subgraphs in a diagram, unless the Root property is set.

The final appearance of arranged graphs depends mostly on the Orientation and Direction properties which define the overall orientation of the layout. The LayerDistance and NodeDistance properties specify how much space to leave between adjacent layers and adjacent nodes in a layer.

The performance of LayeredLayout is dependent on the number of links in the diagram. At its first stage, the algorithm looks for the longest sequence of links in the graph and builds the node layers along it. That stage can be the most time consuming if there are a lot of links in a graph, so there is the TimeLimit property provided to control how much time the layout routine is allowed to spend on path-finding. Next, if there are layers much longer than the other ones and SplitLayers is enabled, nodes from these layers are moved to new ones so the graph width is uniformly distributed.

The layout routine continues by shuffling nodes and link points across their layers, so the criteria mentioned above are approximated. Finally, link ends are aligned to anchor points if Anchoring is enabled and the distance between outermost links is decreased as set in LinksCompactFactor.

The layered graph layout algorithm produces best results if it can place link ends at arbitrary positions over nodes' outlines, that is, when using the Ignore value. If your application logic requires links to be always attached to anchor points, use the other two values. In such cases Reassign would yield better results.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.LayeredLayout

See Also

LayeredLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout Members

LayeredLayout Members
Constructors Properties Methods
[image]

Implements a layered graph layout algorithm.

The following tables list the members exposed by the LayeredLayout type.

Public Constructors

Name | Description
LayeredLayout | Overloaded. Initializes a new instance of the LayeredLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
Direction | Gets or sets the direction of the arranged diagram.
EnableCustomLayers | Gets or sets a value indicating whether to indicating whether the layered layout will honor the LayeredLayoutTraits.Layer flags.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
EndNode | Gets or sets the node that should be placed in the last layer of the arranged graph.
EnforceLinkFlow | Gets or sets a value indicating whether to attempt to force all links to point to the same direction. If the graph being arranged contains cycles, some of the links will still point backwards.
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
IgnoreNodeSize | Gets or sets a value indicating whether the distance between adjacent nodes in the final layout should be independent of the nodes' size.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
KeepRootPosition | Gets or sets a value indicating whether to preserve the position of the root node.
LayerDistance | Gets or sets the desired distance between layer axis lines.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinksCompactFactor | Gets or sets a value indicating how much to compact the outermost links.
LinkType | Gets or sets the appearance of the links in the final layout.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the desired distance between adjacent nodes in a layer.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
Root | Gets or sets a node indicating which subgraph of the diagram must be laid out.
SplitLayers | Gets or sets a value indicating whether to split layers that are much wider than the other layers.
StableSort | Gets or sets a value indicating whether to apply stable sorting during the layout algorithm.
StartNode | Gets or sets the node that should be placed in the first layer of the arranged graph.
Statistics | Gets layout-specific information about the nodes and links participating in the layout.
StraightenLongLinks | Gets or sets whether the layout algorithm should strive to straighten links that cross more than one layer of the graph.
SwapPairsIterations | Gets or sets how many times to perform pair-swapping iterations on each layer.
TimeLimit | Gets or sets a time-out value for the path-finding part of the layered layout algorithm.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout Constructor

LayeredLayout Constructor
[image]

Initializes a new instance of the LayeredLayout class.

Overload List

Name | Description
LayeredLayout () | Initializes a new instance of the LayeredLayout class with the default settings.
LayeredLayout (Orientation, Single, Single, SizeF) | Initializes a new instance of the LayeredLayout class with the specified settings.

See Also

LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout Constructor ()

LayeredLayout Constructor ()
See Also
[image]

Initializes a new instance of the LayeredLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LayeredLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LayeredLayout Constructor Overload List
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout Constructor (Orientation, Single, Single, SizeF)

LayeredLayout Constructor (Orientation, Single, Single, SizeF)
See Also
[image]

Initializes a new instance of the LayeredLayout class with the specified settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LayeredLayout (
Orientation orientation,
float layerDistance,
float nodeDistance,
SizeF margins
)

Visual Basic [image] Copy Code

Public Sub LayeredLayout ( _
orientation As Orientation, _
layerDistance As Single, _
nodeDistance As Single, _
margins As SizeF _
)

Parameters

orientation

The orientation of the layout.

layerDistance

The distance between adjacent layers.

nodeDistance

The distance between adjacent nodes within the same layer.

margins

The margin between the produced graph and the left side of the diagram bounding rectangle.

See Also

LayeredLayout Constructor Overload List
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout Properties

LayeredLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
Direction | Gets or sets the direction of the arranged diagram.
EnableCustomLayers | Gets or sets a value indicating whether to indicating whether the layered layout will honor the LayeredLayoutTraits.Layer flags.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
EndNode | Gets or sets the node that should be placed in the last layer of the arranged graph.
EnforceLinkFlow | Gets or sets a value indicating whether to attempt to force all links to point to the same direction. If the graph being arranged contains cycles, some of the links will still point backwards.
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
IgnoreNodeSize | Gets or sets a value indicating whether the distance between adjacent nodes in the final layout should be independent of the nodes' size.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
KeepRootPosition | Gets or sets a value indicating whether to preserve the position of the root node.
LayerDistance | Gets or sets the desired distance between layer axis lines.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinksCompactFactor | Gets or sets a value indicating how much to compact the outermost links.
LinkType | Gets or sets the appearance of the links in the final layout.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the desired distance between adjacent nodes in a layer.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
Root | Gets or sets a node indicating which subgraph of the diagram must be laid out.
SplitLayers | Gets or sets a value indicating whether to split layers that are much wider than the other layers.
StableSort | Gets or sets a value indicating whether to apply stable sorting during the layout algorithm.
StartNode | Gets or sets the node that should be placed in the first layer of the arranged graph.
Statistics | Gets layout-specific information about the nodes and links participating in the layout.
StraightenLongLinks | Gets or sets whether the layout algorithm should strive to straighten links that cross more than one layer of the graph.
SwapPairsIterations | Gets or sets how many times to perform pair-swapping iterations on each layer.
TimeLimit | Gets or sets a time-out value for the path-finding part of the layered layout algorithm.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.DefaultMarginValue Property

LayeredLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override SizeF DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As SizeF

Property Value

Returns new SizeF(5, 5).

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.Direction Property

LayeredLayout.Direction Property
[image]

Gets or sets the direction of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Direction Direction { get; set; }

Visual Basic [image] Copy Code

Public Property Direction As Direction

Property Value

A member of the Direction enumeration. The default is Straight.

Remarks

If Orientation is set to Horizontal, Direction.Straight stands for "left to right" and Direction.Reversed for "right to left". If Orientation is set to Vertical, Direction.Straight stands for "top to bottom" and Direction.Reversed for "bottom to top".

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.EnableCustomLayers Property

LayeredLayout.EnableCustomLayers Property
[image]

Gets or sets a value indicating whether to indicating whether the layered layout will honor the LayeredLayoutTraits.Layer flags.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableCustomLayers { get; set; }

Visual Basic [image] Copy Code

Public Property EnableCustomLayers As Boolean

Property Value

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.EndNode Property

LayeredLayout.EndNode Property
[image]

Gets or sets the node that should be placed in the last layer of the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode EndNode { get; set; }

Visual Basic [image] Copy Code

Public Property EndNode As DiagramNode

Property Value

A DiagramNode object representing the end node.

Remarks

This value is honored only if StartNode is specified too.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.EnforceLinkFlow Property

LayeredLayout.EnforceLinkFlow Property
[image]

Gets or sets a value indicating whether to attempt to force all links to point to the same direction. If the graph being arranged contains cycles, some of the links will still point backwards.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnforceLinkFlow { get; set; }

Visual Basic [image] Copy Code

Public Property EnforceLinkFlow As Boolean

Property Value

Remarks

EnableCustomLayers and SplitLayers are ignored if this property is set to true.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace
StraightenLongLinks Property
OneWayLayout Class


MindFusion.Diagramming.Layout.LayeredLayout.IgnoreNodeSize Property

LayeredLayout.IgnoreNodeSize Property
[image]

Gets or sets a value indicating whether the distance between adjacent nodes in the final layout should be independent of the nodes' size.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IgnoreNodeSize { get; set; }

Visual Basic [image] Copy Code

Public Property IgnoreNodeSize As Boolean

Property Value

true to ignore the node size; otherwise, false. The default is true.

Remarks

At this time, considering the size of nodes deteriorates the performance of the algorithm, so that's disabled by default.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.KeepRootPosition Property

LayeredLayout.KeepRootPosition Property
[image]

Gets or sets a value indicating whether to preserve the position of the root node.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool KeepRootPosition { get; set; }

Visual Basic [image] Copy Code

Public Property KeepRootPosition As Boolean

Property Value

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.LayerDistance Property

LayeredLayout.LayerDistance Property
[image]

Gets or sets the desired distance between layer axis lines.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float LayerDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LayerDistance As Single

Property Value

A float value specifying the distance between layers. The default is 25.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.LinksCompactFactor Property

LayeredLayout.LinksCompactFactor Property
[image]

Gets or sets a value indicating how much to compact the outermost links.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float LinksCompactFactor { get; set; }

Visual Basic [image] Copy Code

Public Property LinksCompactFactor As Single

Property Value

A float number in the interval [0, 1]. The default is 1.

Remarks

Links and nodes on the same graph layer are distributed uniformly as specified via the NodeDistance value. However, if there are more than 2-3 outermost links on a layer, they usually take up too much space without improving the visual quality of the diagram layout. This property allows compacting such links to save space. The factor specifies roughly a fraction of NodeDistance to leave between outer links.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.LinkType Property

LayeredLayout.LinkType Property
[image]

Gets or sets the appearance of the links in the final layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LayeredLayoutLinkType LinkType { get; set; }

Visual Basic [image] Copy Code

Public Property LinkType As LayeredLayoutLinkType

Property Value

A member of the LayeredLayoutLinkType enumeration. The default is Straight.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace
StraightenLongLinks Property


MindFusion.Diagramming.Layout.LayeredLayout.Name Property

LayeredLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Layered layout".

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.NodeDistance Property

LayeredLayout.NodeDistance Property
[image]

Gets or sets the desired distance between adjacent nodes in a layer.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Single

Property Value

A float value specifying the distance between adjacent nodes. The default is 20.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.Orientation Property

LayeredLayout.Orientation Property
[image]

Gets or sets the overall orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default is Vertical.

Remarks

Specify Orientation.Vertical to have links flow in vertical direction and Orientation.Horizontal to have links flow in horizontal direction. The orientation of the resulting layers is opposite to that of the links. Thus, if the link tends to go in a vertical direction, the nodes are distributed in horizontal layers.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace
Direction Property


MindFusion.Diagramming.Layout.LayeredLayout.Root Property

LayeredLayout.Root Property
[image]

Gets or sets a node indicating which subgraph of the diagram must be laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As DiagramNode

Property Value

An instance of the DiagramNode class. The default is a null reference (Nothing in Visual Basic).

Remarks

All links and nodes that can be reached from the root by following recursively its links form a graph. If the root is specified, only the graph containing it is laid out by Arrange.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.SplitLayers Property

LayeredLayout.SplitLayers Property
[image]

Gets or sets a value indicating whether to split layers that are much wider than the other layers.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SplitLayers { get; set; }

Visual Basic [image] Copy Code

Public Property SplitLayers As Boolean

Property Value

true to split wide layers; otherwise, false. The default is false.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.StableSort Property

LayeredLayout.StableSort Property
[image]

Gets or sets a value indicating whether to apply stable sorting during the layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool StableSort { get; set; }

Visual Basic [image] Copy Code

Public Property StableSort As Boolean

Property Value

true to apply stable sorting algorithm, otherwise false. The default value is false.

Remarks

By default .NET sorts arrays using unstable sort, where if two elements have equal values, their order might not be the same between different runs of the sort method. This could lead to LayeredLayout not preserving the order of some nodes in a layer between different runs if there are more than one candidates for the same position. If you need the same order to be reproduced consistently, set StableSort to true.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.StartNode Property

LayeredLayout.StartNode Property
[image]

Gets or sets the node that should be placed in the first layer of the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode StartNode { get; set; }

Visual Basic [image] Copy Code

Public Property StartNode As DiagramNode

Property Value

A DiagramNode object representing the start node.

Remarks

If there is no start node specified, the algorithm automatically selects one based on other LayeredLayout properties, such as EnforceLinkFlow.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace
EndNode Property


MindFusion.Diagramming.Layout.LayeredLayout.Statistics Property

LayeredLayout.Statistics Property
[image]

Gets layout-specific information about the nodes and links participating in the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LayeredLayoutStatistics Statistics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Statistics As LayeredLayoutStatistics

Property Value

An instance of the LayeredLayoutStatistics class containing detailed information about the performed layout, such as the layers individual nodes were assigned to.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.StraightenLongLinks Property

LayeredLayout.StraightenLongLinks Property
[image]

Gets or sets whether the layout algorithm should strive to straighten links that cross more than one layer of the graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool StraightenLongLinks { get; set; }

Visual Basic [image] Copy Code

Public Property StraightenLongLinks As Boolean

Property Value

true to straighten long links; otherwise false. The default value is false.

Remarks

If this property is enabled, links that cross multiple layers have at most two bends. Because of the additional horizontal alignment constraints, the arranged graph usually occupies a larger area than when not using StraightenLongLinks.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace
LinkType Property
EnforceLinkFlow Property


MindFusion.Diagramming.Layout.LayeredLayout.SwapPairsIterations Property

LayeredLayout.SwapPairsIterations Property
[image]

Gets or sets how many times to perform pair-swapping iterations on each layer.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int SwapPairsIterations { get; set; }

Visual Basic [image] Copy Code

Public Property SwapPairsIterations As Integer

Property Value

An integer value specifying how many pair-swapping iterations to perform. The default is 5.

Remarks

The algorithm swaps node pairs on each layer aiming to decrease the number of crossing links. Setting a higher value to this property helps to decrease the number of crossings.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.TimeLimit Property

LayeredLayout.TimeLimit Property
[image]

Gets or sets a time-out value for the path-finding part of the layered layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public long TimeLimit { get; set; }

Visual Basic [image] Copy Code

Public Property TimeLimit As Long

Property Value

An integer value specifying time-out in milliseconds. The default is 10000 (10 seconds).

Remarks

The layered layout algorithm arranges graph nodes and links along the longest path in the graph. Large graphs with many links could contain hundreds of thousands of possible paths, so finding the longest one would be very time-consuming. When the time-out set with this property occurs, the path-finding routine stops and the layout algorithm uses the longest path known at that moment. Usually, for graphs containing several hundreds of nodes, 1-2 seconds are enough to find a long-enough path to produce nice layered layout.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayoutLinkType Enumeration

LayeredLayoutLinkType Enumeration
[image]

Specifies the style of the links after they are laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum LayeredLayoutLinkType

Visual Basic [image] Copy Code

Public Enum LayeredLayoutLinkType

Members

Member name | Description
Straight | Indicates straight links.
Cascading | Indicates cascading links.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayoutStatistics Class

LayeredLayoutStatistics Class
[image]

Encapsulates information about a layered layout which has already complete.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class LayeredLayoutStatistics

Visual Basic [image] Copy Code

Public NotInheritable Class LayeredLayoutStatistics

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.LayeredLayoutStatistics

See Also

LayeredLayoutStatistics Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayoutStatistics Members

LayeredLayoutStatistics Members
Properties
[image]

Encapsulates information about a layered layout which has already complete.

The following tables list the members exposed by the LayeredLayoutStatistics type.

Public Properties

Name | Description
LayerCount | Gets the total number of layers in the layout. If more than one subgraph is laid out, this property returns the number of layers in the last subgraph.
LinkLayerCount | Gets a mapping between links and the number of layers they run through.
NodeGridPositions | Gets a mapping between nodes and their assigned grid positions.
NodeLayerIndices | Gets a mapping between nodes and their assigned layers.

See Also

LayeredLayoutStatistics Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayoutStatistics Properties

LayeredLayoutStatistics Properties
[image]

Public Properties

Name | Description
LayerCount | Gets the total number of layers in the layout. If more than one subgraph is laid out, this property returns the number of layers in the last subgraph.
LinkLayerCount | Gets a mapping between links and the number of layers they run through.
NodeGridPositions | Gets a mapping between nodes and their assigned grid positions.
NodeLayerIndices | Gets a mapping between nodes and their assigned layers.

See Also

LayeredLayoutStatistics Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayoutStatistics.LayerCount Property

LayeredLayoutStatistics.LayerCount Property
[image]

Gets the total number of layers in the layout. If more than one subgraph is laid out, this property returns the number of layers in the last subgraph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int LayerCount { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LayerCount As Integer

Property Value

See Also

LayeredLayoutStatistics Members
LayeredLayoutStatistics Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayoutStatistics.LinkLayerCount Property

LayeredLayoutStatistics.LinkLayerCount Property
[image]

Gets a mapping between links and the number of layers they run through.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Dictionary<DiagramLink, Int32> LinkLayerCount { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LinkLayerCount As Dictionary(Of DiagramLink, Int32)

Property Value

See Also

LayeredLayoutStatistics Members
LayeredLayoutStatistics Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayoutStatistics.NodeGridPositions Property

LayeredLayoutStatistics.NodeGridPositions Property
[image]

Gets a mapping between nodes and their assigned grid positions.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Dictionary<DiagramNode, Double> NodeGridPositions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NodeGridPositions As Dictionary(Of DiagramNode, Double)

Property Value

See Also

LayeredLayoutStatistics Members
LayeredLayoutStatistics Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayoutStatistics.NodeLayerIndices Property

LayeredLayoutStatistics.NodeLayerIndices Property
[image]

Gets a mapping between nodes and their assigned layers.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Dictionary<DiagramNode, Int32> NodeLayerIndices { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NodeLayerIndices As Dictionary(Of DiagramNode, Int32)

Property Value

See Also

LayeredLayoutStatistics Members
LayeredLayoutStatistics Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout Class

Layout Class
[image]

The base class for all layout classes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class Layout : Component, ILayout

Visual Basic [image] Copy Code

Public MustInherit Class Layout
Inherits Component
Implements ILayout

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.AnnealLayout
MindFusion.Diagramming.Layout.CascadeLayout
MindFusion.Diagramming.Layout.CircularLayout
MindFusion.Diagramming.Layout.CompositeLayout
MindFusion.Diagramming.Layout.DecisionLayout
MindFusion.Diagramming.Layout.FlowchartLayout
MindFusion.Diagramming.Layout.FlowLayout
MindFusion.Diagramming.Layout.FractalLayout
MindFusion.Diagramming.Layout.GridLayout
MindFusion.Diagramming.Layout.HierarchicalLayout
MindFusion.Diagramming.Layout.LayeredLayout
MindFusion.Diagramming.Layout.OneWayLayout
MindFusion.Diagramming.Layout.OrthogonalLayout
MindFusion.Diagramming.Layout.OrthogonalRouter
MindFusion.Diagramming.Layout.SolarLayout
MindFusion.Diagramming.Layout.SpringLayout
MindFusion.Diagramming.Layout.SwimlaneLayout
MindFusion.Diagramming.Layout.TopologicalLayout
MindFusion.Diagramming.Layout.TreeLayout
MindFusion.Diagramming.Layout.TreeMapLayout
MindFusion.Diagramming.Layout.TriangularLayout

See Also

Layout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout Members

Layout Members
Constructors Properties Methods
[image]

The base class for all layout classes.

The following tables list the members exposed by the Layout type.

Protected Constructors

Name | Description
Layout | Initializes a new instance of the Layout class.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads.
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds.
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.
Name | Gets a user-friendly name of the layout.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress.
RepeatingLinksPadding | Specifies the padding distance between repeating links.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance.

See Also

Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout Constructor

Layout Constructor
[image]

Initializes a new instance of the Layout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Layout ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout Methods

Layout Methods
[image]

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance.

See Also

Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Arrange Method

Layout.Arrange Method
[image]

Applies the layout to a Diagram instance.

Overload List

Name | Description
Layout.Arrange (Diagram) | Applies the layout to the specified Diagram instance.
Layout.Arrange (Diagram, DiagramItemCollection) | Applies the layout on the specified subset of objects from the specified Diagram instance.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Arrange Method (Diagram)

Layout.Arrange Method (Diagram)
See Also
[image]

Applies the layout to the specified Diagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool Arrange (
Diagram diagram
)

Visual Basic [image] Copy Code

Public Overridable Function Arrange ( _
diagram As Diagram _
) As Boolean

Parameters

diagram
The Diagram that must be arranged.

Return Value

true if the diagram has been arranged successfully; otherwise, false.

See Also

Arrange Method Overload List
Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Arrange Method (Diagram, DiagramItemCollection)

Layout.Arrange Method (Diagram, DiagramItemCollection)
See Also
[image]

Applies the layout on the specified subset of objects from the specified Diagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool Arrange (
Diagram diagram,
DiagramItemCollection items
)

Visual Basic [image] Copy Code

Public Overridable Function Arrange( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram
The Diagram that must be arranged.
items
A collection of nodes and links from diagram that define the subgraph to arrange.

Return Value

true if the diagram has been arranged successfully; otherwise, false.

See Also

Arrange Method Overload List
Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout Properties

Layout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads.
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds.
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.
Name | Gets a user-friendly name of the layout.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress.
RepeatingLinksPadding | Specifies the padding distance between repeating links.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts.

See Also

Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Anchoring Property

Layout.Anchoring Property
[image]

Gets or sets a value indicating how to align links to the anchor points of graph nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Anchoring Anchoring { get; set; }

Visual Basic [image] Copy Code

Public Property Anchoring As Anchoring

Property Value

A member of the Anchoring enumeration. The default is Ignore.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.DefaultMarginValue Property

Layout.DefaultMarginValue Property
[image]

Gets the default value for the Margins property, which may vary accross different layouts.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected abstract SizeF DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected MustOverride ReadOnly Property DefaultMarginValue As SizeF

Property Value

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.EnableParallelism Property

Layout.EnableParallelism Property
[image]

Gets or sets a value indicating whether to arrange subgraphs on separate threads.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool EnableParallelism { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property EnableParallelism As Boolean

Property Value

true to enable parallelism; otherwise, false.

Remarks

Available only in .NET 4.0 versions and later.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.GrowToFit Property

Layout.GrowToFit Property
[image]

Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool GrowToFit { get; set; }

Visual Basic [image] Copy Code

Public Property GrowToFit As Boolean

Property Value

true to grow diagram's Bounds if the arranged items would not fit, or false otherwise. The default value is true.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.KeepGroupLayout Property

Layout.KeepGroupLayout Property
[image]

Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool KeepGroupLayout { get; set; }

Visual Basic [image] Copy Code

Public Property KeepGroupLayout As Boolean

Property Value

true if each Group should be processed as an integral graph node; otherwise, false. The default is false.

Remarks

Enabling this property has an effect similar to setting the IgnoreLayout property of group's subordinated nodes to true. The two methods differ in how the size of the graph node corresponding to a group is calculated. If KeepGroupLayout is enabled, the union of all bounding rectangles of grouped items is used to determine the size of the graph node. When the IgnoreLayout property of subordinated items is enabled, the bounding rectangle of the main node defines the size of the graph node corresponding to the group.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.LayoutLink Property

Layout.LayoutLink Property
[image]

Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual LayoutLink LayoutLink { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property LayoutLink As LayoutLink

Property Value

An instance of the LayoutLink delegate.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.LayoutNode Property

Layout.LayoutNode Property
[image]

Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual LayoutNode LayoutNode { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property LayoutNode As LayoutNode

Property Value

An instance of the LayoutNode delegate.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Margins Property

Layout.Margins Property
[image]

Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SizeF Margins { get; set; }

Visual Basic [image] Copy Code

Public Property Margins As SizeF

Property Value

Remarks

This value is also set as the distance between unconnected sub-graphs when they are placed as specified via MultipleGraphsPlacement.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.MaxDegreeOfParallelism Property

Layout.MaxDegreeOfParallelism Property
[image]

Gets or sets the maximum degree of parallelism.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual int MaxDegreeOfParallelism { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property MaxDegreeOfParallelism As Integer

Property Value

An integer value specifying the degree.

Remarks

Applicable only if EnableParallelization is set to true. Available only in .NET 4.0 versions and later.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.MultipleGraphsPlacement Property

Layout.MultipleGraphsPlacement Property
[image]

Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MultipleGraphsPlacement MultipleGraphsPlacement { get; set; }

Visual Basic [image] Copy Code

Public Property MultipleGraphsPlacement As MultipleGraphsPlacement

Property Value

A member of the MultipleGraphsPlacement enumeration. The default value is Horizontal.

Remarks

If the diagram contains several unconnected subgraphs, each of them is processed by the algorithm independently from the others. This property specifies how such subgraphs should be placed one relatively to another. The possible options are to arrange them in a row, in a column, or in such a way that the diagram covers a minimal area.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Name Property

Layout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract string Name { get; }

Visual Basic [image] Copy Code

Public MustOverride ReadOnly Property Name As String

Property Value

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Progress Property

Layout.Progress Property
[image]

Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual LayoutProgress Progress { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Progress As LayoutProgress

Property Value

A LayoutProgress delegate method to call while the algorithm proceeds.

Remarks

It might take a lot of time to arrange large diagrams or run more iterations of the algorithm to get better results. In such situations an application can be notified about the progress of the layout routine by assigning a delegate method to this property. On its turn the application could update the UI to indicate the current progress to the users.

Example

The following example updates a label text to indicate the progress of a layout algorithm. The CreateLayout method instantiates a layout object from a concrete class.

C# [image] Copy Code

Layout layout = CreateLayout();
layout.Progress = new LayoutProgress(onProgress);
layout.Arrange(diagram);

// ...

void onProgress(int c, int n)
{
label1.Text = (100*c/n).ToString() + "% complete";
label1.Refresh();
}

Visual Basic [image] Copy Code

Dim layout As Layout = CreateLayout()
layout.Progress = New LayoutProgress(AddressOf onProgress)
layout.Arrange(diagram)

' ...

Sub onProgress(ByVal c As Integer, ByVal n As Integer)

label1.Text = (100 * c / n).ToString() + "% complete"
label1.Refresh()

End Sub

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.RepeatingLinksPadding Property

Layout.RepeatingLinksPadding Property
[image]

Specifies the padding distance between repeating links.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float RepeatingLinksPadding { get; set; }

Visual Basic [image] Copy Code

Public Property RepeatingLinksPadding As Single

Property Value

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayoutLink Delegate

LayoutLink Delegate
[image]

Represents methods that are called by the layout algorithms when the position of a link changes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate void LayoutLink (
DiagramLink link
)

Visual Basic [image] Copy Code

Public Delegate Sub LayoutLink ( _
link As DiagramLink _
)

Parameters

link

A reference to the link being laid out.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayoutNode Delegate

LayoutNode Delegate
[image]

Represents methods that are called by the layout algorithms when the position of a node changes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate void LayoutNode (
DiagramNode node,
RectangleF oldBounds
)

Visual Basic [image] Copy Code

Public Delegate Sub LayoutNode ( _
node As DiagramNode, _
oldBounds As RectangleF _
)

Parameters

node

A reference to the node being laid out.

oldBounds

The bounding rectangle of the node before it was repositioned by the layouting algorithm.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayoutProgress Delegate

LayoutProgress Delegate
[image]

Represents methods that are called to report on progress of layout algorithms.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate void LayoutProgress (
int current,
int total
)

Visual Basic [image] Copy Code

Public Delegate Sub LayoutProgress( _
current As Integer, _
total As Integer _
)

Parameters

current

An integer value specifying the current relative progress of the layout algorithm.

total

An integer value specifying the total number of steps required by the layouting algorithm in order to finish.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayoutSubgraph Delegate

LayoutSubgraph Delegate
[image]

Represents methods that are called by the layout algorithms in order to perform custom arrangement of a subgraph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate bool LayoutSubgraph (
Diagram diagram,
DiagramItemCollection items
)

Visual Basic [image] Copy Code

Public Delegate Function LayoutSubgraph ( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram

The diagram being arranged.

items

The subset of items to arrange.

Return Value

true if the items were arranged; otherwise, false.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.MultipleGraphsPlacement Enumeration

MultipleGraphsPlacement Enumeration
[image]

Specifies graph orientation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum MultipleGraphsPlacement

Visual Basic [image] Copy Code

Public Enum MultipleGraphsPlacement

Members

Member name | Description
Vertical | Indicates that graphs should be placed in a column.
Horizontal | Indicates that graphs should be placed in a row.
MinimalArea | Indicates that graphs should be placed so that they cover minimal area.
VerticalSortDescending | Indicates that graphs should be placed in a column and sorted by the number of vertices they contain in a descending order.
VerticalSortAscending | Indicates that graphs should be placed in a column and sorted by the number of vertices they contain in an ascending order.
HorizontalSortDescending | Indicates that graphs should be placed in a row and sorted by the number of vertices they contain in a descending order.
HorizontalSortAscending | Indicates that graphs should be placed in a row and sorted by the number of vertices they contain in an ascending order.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OneWayLayout Class

OneWayLayout Class
Remarks See Also
[image]

Implements a one-way graph layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class OneWayLayout : Layout

Visual Basic [image] Copy Code

Public Class OneWayLayout
Inherits Layout

Remarks

The one-way layout ensures that links enter into nodes from the same general direction and exit them from the opposite side. If the graph contains cycles, some links bend around the nodes to keep the enter/exit direction consistent. The algorithm aims to minimize the number of such links.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.OneWayLayout

See Also

OneWayLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OneWayLayout Members

OneWayLayout Members
Constructors Properties Methods
[image]

Implements a one-way graph layout algorithm.

The following tables list the members exposed by the OneWayLayout type.

Public Constructors

Name | Description
OneWayLayout | Initializes a new instance of the OneWayLayout class with the default settings.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the minimum spacing between adjacent nodes in the final layout.
Orientation | Gets or sets the orientation of the arranged graph.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
RoundedLinks | Gets or sets a value indicating whether the layout should smooth link bends.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

OneWayLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OneWayLayout Constructor

OneWayLayout Constructor
[image]

Initializes a new instance of the OneWayLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public OneWayLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

OneWayLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OneWayLayout Properties

OneWayLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the minimum spacing between adjacent nodes in the final layout.
Orientation | Gets or sets the orientation of the arranged graph.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
RoundedLinks | Gets or sets a value indicating whether the layout should smooth link bends.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

OneWayLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OneWayLayout.DefaultMarginValue Property

OneWayLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override SizeF DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As SizeF

Property Value

Returns new SizeF(5, 5).

See Also

OneWayLayout Members
OneWayLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OneWayLayout.Name Property

OneWayLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "One-way layout".

See Also

OneWayLayout Members
OneWayLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OneWayLayout.NodeDistance Property

OneWayLayout.NodeDistance Property
[image]

Gets or sets the minimum spacing between adjacent nodes in the final layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Single

Property Value

A float number specifying the distance. The default is 20.

See Also

OneWayLayout Members
OneWayLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OneWayLayout.Orientation Property

OneWayLayout.Orientation Property
[image]

Gets or sets the orientation of the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default is Vertical.

See Also

OneWayLayout Members
OneWayLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OneWayLayout.RoundedLinks Property

OneWayLayout.RoundedLinks Property
[image]

Gets or sets a value indicating whether the layout should smooth link bends.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RoundedLinks { get; set; }

Visual Basic [image] Copy Code

Public Property RoundedLinks As Boolean

Property Value

true to smooth link bends; otherwise, false.

See Also

OneWayLayout Members
OneWayLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Orientation Enumeration

Orientation Enumeration
[image]

Specifies axial orientation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum Orientation

Visual Basic [image] Copy Code

Public Enum Orientation

Members

Member name | Description
Vertical | Indicates vertical orientation.
Horizontal | Indicates horizontal orientation.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout Class

OrthogonalLayout Class
Remarks See Also
[image]

Implements an orthogonal graph layout algorithm. Each link is drawn as a chain of alternating horizontal and vertical segments. Nodes are placed in a way that facilitates few links bends and crossings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class OrthogonalLayout : Layout

Visual Basic [image] Copy Code

Public Class OrthogonalLayout
Inherits Layout

Remarks

This algorithm was designed for planar graphs where the nodes have at most four incident links, and produces best results with such graphs as input. It can arrange any arbitrary graph as well, by adding some dummy nodes and links to planarize the graph and reduce its vertex degree, and removing them after the layout. However this might lead to using larger area than necessary, due to the space occupied by dummy elements.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.OrthogonalLayout

See Also

OrthogonalLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout Members

OrthogonalLayout Members
Constructors Properties Methods
[image]

Implements an orthogonal graph layout algorithm. Each link is drawn as a chain of alternating horizontal and vertical segments. Nodes are placed in a way that facilitates few links bends and crossings.

The following tables list the members exposed by the OrthogonalLayout type.

Public Constructors

Name | Description
OrthogonalLayout | Initializes a new instance of the OrthogonalLayout class with the default settings.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
Directed | Gets or sets a value indicating whether the graph being laid out is directed.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MinimizeLinkBends | Gets or sets a value indicating whether the layout should minimize link bends.
MinLaneSize | Gets or sets a value indicating the minimum size of a lane.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Padding | Gets or sets a value indicating how much space to leave between nodes in adjacent lanes.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
Refine | Gets or sets a value indicating whether to refine the layout.
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout Constructor

OrthogonalLayout Constructor
[image]

Initializes a new instance of the OrthogonalLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public OrthogonalLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout Properties

OrthogonalLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
Directed | Gets or sets a value indicating whether the graph being laid out is directed.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MinimizeLinkBends | Gets or sets a value indicating whether the layout should minimize link bends.
MinLaneSize | Gets or sets a value indicating the minimum size of a lane.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Padding | Gets or sets a value indicating how much space to leave between nodes in adjacent lanes.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
Refine | Gets or sets a value indicating whether to refine the layout.
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout.DefaultMarginValue Property

OrthogonalLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override SizeF DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As SizeF

Property Value

Returns new SizeF(5, 5).

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout.Directed Property

OrthogonalLayout.Directed Property
[image]

Gets or sets a value indicating whether the graph being laid out is directed.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Directed { get; set; }

Visual Basic [image] Copy Code

Public Property Directed As Boolean

Property Value

true to consider the direction of graph edges, false to ignore it; the default value is false.

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout.MinimizeLinkBends Property

OrthogonalLayout.MinimizeLinkBends Property
[image]

Gets or sets a value indicating whether the layout should minimize link bends.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool MinimizeLinkBends { get; set; }

Visual Basic [image] Copy Code

Public Property MinimizeLinkBends As Boolean

Property Value

true to minimize link bends, otherwise false. The default value is true.

Remarks

If this option is disabled, the layout class applies a fast linear time algorithm, however the layouts produced usually contain more bending links and occupy more space. If enabled, the layout class applies an algorithm of polynomial complexity and runs much slower.

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout.MinLaneSize Property

OrthogonalLayout.MinLaneSize Property
[image]

Gets or sets a value indicating the minimum size of a lane.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float MinLaneSize { get; set; }

Visual Basic [image] Copy Code

Public Property MinLaneSize As Single

Property Value

A float value specifying the minimum lane size. The default value is 10.

Remarks

The result of the layout's Arrange is a grid that contains the diagram's nodes and links. This property specifies the size of lanes which does not contain nodes, but only links.

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout.Name Property

OrthogonalLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Orthogonal layout".

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout.Padding Property

OrthogonalLayout.Padding Property
[image]

Gets or sets a value indicating how much space to leave between nodes in adjacent lanes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Padding { get; set; }

Visual Basic [image] Copy Code

Public Property Padding As Single

Property Value

A float value specifying the padding. The default is 15.

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout.Refine Property

OrthogonalLayout.Refine Property
[image]

Gets or sets a value indicating whether to refine the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Refine { get; set; }

Visual Basic [image] Copy Code

Public Property Refine As Boolean

Property Value

true to run a refinement pass, otherwise false. The default value is true.

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter Class

OrthogonalRouter Class
Remarks See Also
[image]

Implements an orthogonal link routing algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class OrthogonalRouter : Layout

Visual Basic [image] Copy Code

Public Class OrthogonalRouter
Inherits Layout

Remarks

OrthogonalRouter is a secondary layout algorithm that can be used to arrange links after an initial node arrangement has already been applied. The orthogonal layout is useful when there are much more links than nodes in a graph. The algorithm strives to achieve the following criteria, while preserving as much of the initial node configuration as possible.

  • links must not overlap;
  • only vertical and horizontal routing lines are used;
  • graph routing is performed with respect to the specified main layout direction;
  • links crossings are minimized;
  • bends are minimized;

To arrange a diagram, create an OrthogonalRouter instance, set its properties and call the Arrange method.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.OrthogonalRouter

See Also

OrthogonalRouter Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter Members

OrthogonalRouter Members
Constructors Properties Methods
[image]

Implements an orthogonal link routing algorithm.

The following tables list the members exposed by the OrthogonalRouter type.

Public Constructors

Name | Description
OrthogonalRouter | Initializes a new instance of the OrthogonalRouter class.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
BendDistance | Gets or sets how far from its adjacent node a link should bend.
Direction | Gets or sets the direction of the arranged diagram when BaseLayout is set to Layered.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
EndOrientation | Gets or sets the desired orientation of the last segments of routed links.
GridSize | Gets or sets the distance between adjacent grid points when BaseLayout is set to Grid.
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayerDistance | Gets or sets the desired distance between layer axis lines.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the desired distance between adjacent nodes in a layer.
Orientation | Gets or sets the overall orientation of the arranged diagram when BaseLayout is set to Layered.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
PutEndPointsAtNodeBorders | Gets or sets a value indicating whether the end points of a link should be placed at the outlines of the nodes connected by that link.
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
StartOrientation | Gets or sets the desired orientation of the first segments of routed links.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter Constructor

OrthogonalRouter Constructor
[image]

Initializes a new instance of the OrthogonalRouter class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public OrthogonalRouter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter Properties

OrthogonalRouter Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
BendDistance | Gets or sets how far from its adjacent node a link should bend.
Direction | Gets or sets the direction of the arranged diagram when BaseLayout is set to Layered.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
EndOrientation | Gets or sets the desired orientation of the last segments of routed links.
GridSize | Gets or sets the distance between adjacent grid points when BaseLayout is set to Grid.
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayerDistance | Gets or sets the desired distance between layer axis lines.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the desired distance between adjacent nodes in a layer.
Orientation | Gets or sets the overall orientation of the arranged diagram when BaseLayout is set to Layered.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
PutEndPointsAtNodeBorders | Gets or sets a value indicating whether the end points of a link should be placed at the outlines of the nodes connected by that link.
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
StartOrientation | Gets or sets the desired orientation of the first segments of routed links.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.BendDistance Property

OrthogonalRouter.BendDistance Property
[image]

Gets or sets how far from its adjacent node a link should bend.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float BendDistance { get; set; }

Visual Basic [image] Copy Code

Public Property BendDistance As Single

Property Value

A float value specifying the distance from a link's first bend to its adjacent node. The default is 0, specifying that the algorithm should automatically choose a value for this parameter.

Remarks

This should be a value between 0 and 1, specifying a distance proportional to the node size.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.DefaultMarginValue Property

OrthogonalRouter.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override SizeF DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As SizeF

Property Value

Returns new SizeF(10, 10).

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.Direction Property

OrthogonalRouter.Direction Property
[image]

Gets or sets the direction of the arranged diagram when BaseLayout is set to Layered.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Direction Direction { get; set; }

Visual Basic [image] Copy Code

Public Property Direction As Direction

Property Value

Remarks

This value is assigned to the Direction property of the base LayeredLayout.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.EndOrientation Property

OrthogonalRouter.EndOrientation Property
[image]

Gets or sets the desired orientation of the last segments of routed links.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation EndOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property EndOrientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Auto.

Remarks

If this property is set to Horizontal, links will end at the left or right sides of nodes. If set to Vertical, links will end at the top or bottom sides.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace
StartOrientation Property


MindFusion.Diagramming.Layout.OrthogonalRouter.GridSize Property

OrthogonalRouter.GridSize Property
[image]

Gets or sets the distance between adjacent grid points when BaseLayout is set to Grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float GridSize { get; set; }

Visual Basic [image] Copy Code

Public Property GridSize As Single

Property Value

Remarks

This value is assigned to the GridSize property of the base GridLayout.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.LayerDistance Property

OrthogonalRouter.LayerDistance Property
[image]

Gets or sets the desired distance between layer axis lines.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float LayerDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LayerDistance As Single

Property Value

Remarks

Gets or sets the distance between layers when BaseLayout is set to Layered or Cascading.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.Name Property

OrthogonalRouter.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.NodeDistance Property

OrthogonalRouter.NodeDistance Property
[image]

Gets or sets the desired distance between adjacent nodes in a layer.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Single

Property Value

Remarks

Gets or sets the distance between nodes in the same layer when BaseLayout is set to Layered or Cascading.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.Orientation Property

OrthogonalRouter.Orientation Property
[image]

Gets or sets the overall orientation of the arranged diagram when BaseLayout is set to Layered.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

Remarks

This value is assigned to the Orientation property of the base LayeredLayout.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.PutEndPointsAtNodeBorders Property

OrthogonalRouter.PutEndPointsAtNodeBorders Property
[image]

Gets or sets a value indicating whether the end points of a link should be placed at the outlines of the nodes connected by that link.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool PutEndPointsAtNodeBorders { get; set; }

Visual Basic [image] Copy Code

Public Property PutEndPointsAtNodeBorders As Boolean

Property Value

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.RandomSeed Property

OrthogonalRouter.RandomSeed Property
[image]

Gets or sets the randomization seed to use for generating random node positions.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int RandomSeed { get; set; }

Visual Basic [image] Copy Code

Public Property RandomSeed As Integer

Property Value

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.StartOrientation Property

OrthogonalRouter.StartOrientation Property
[image]

Gets or sets the desired orientation of the first segments of routed links.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation StartOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property StartOrientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Auto.

Remarks

If this property is set to Horizontal, links will end at the left or right sides of nodes. If set to Vertical, links will end at the top or bottom sides.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace
EndOrientation Property


MindFusion.Diagramming.Layout.SolarLayout Class

SolarLayout Class
Remarks See Also
[image]

A tree layout algorithm that places child nodes around their parents, such, that the child nodes do not overlap. The algorithm optionally bends the links to prevent them from crossing nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class SolarLayout : Layout

Visual Basic [image] Copy Code

Public Class SolarLayout
Inherits Layout

Remarks

This layout takes into consideration the size of the nodes and tries to arrange them around their parents to minimize occupied space.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.SolarLayout

See Also

SolarLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SolarLayout Members

SolarLayout Members
Constructors Properties Methods
[image]

A tree layout algorithm that places child nodes around their parents, such, that the child nodes do not overlap. The algorithm optionally bends the links to prevent them from crossing nodes.

The following tables list the members exposed by the SolarLayout type.

Public Constructors

Name | Description
SolarLayout | Initializes a new instance of the SolarLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
BendLinks | Gets or sets a value indicating whether links are bend to prevent them from crossing nodes.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
HonorInitialNodeDisposition | Gets or sets a value indicating whether the initial position of a child node relative to its parent node is preserved in the final layout.
IgnoreLinkDirection | Gets or sets a value indicating whether the tree layout algorithm should ignore the direction of links when arranging a tree.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
KeepRootPosition | Gets or sets a value indicating whether to keep the root node at its original position.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LevelDistance | Gets or sets the minimal distance between a parent node and its children.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the minimal distance between siblings.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
ReversedLinks | Gets or sets a value indicating the link direction that relates parent nodes to child nodes.
Root | Gets or sets the tree root.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

SolarLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SolarLayout Constructor

SolarLayout Constructor
[image]

Initializes a new instance of the SolarLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SolarLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SolarLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SolarLayout Properties

SolarLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
BendLinks | Gets or sets a value indicating whether links are bend to prevent them from crossing nodes.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
HonorInitialNodeDisposition | Gets or sets a value indicating whether the initial position of a child node relative to its parent node is preserved in the final layout.
IgnoreLinkDirection | Gets or sets a value indicating whether the tree layout algorithm should ignore the direction of links when arranging a tree.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
KeepRootPosition | Gets or sets a value indicating whether to keep the root node at its original position.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LevelDistance | Gets or sets the minimal distance between a parent node and its children.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the minimal distance between siblings.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
ReversedLinks | Gets or sets a value indicating the link direction that relates parent nodes to child nodes.
Root | Gets or sets the tree root.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

SolarLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SolarLayout.BendLinks Property

SolarLayout.BendLinks Property
[image]

Gets or sets a value indicating whether links are bend to prevent them from crossing nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool BendLinks { get; set; }

Visual Basic [image] Copy Code

Public Property BendLinks As Boolean

Property Value

true to bend the links to try to prevent crossings; otherwise, false. The default is true.

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SolarLayout.DefaultMarginValue Property

SolarLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override SizeF DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As SizeF

Property Value

Returns new SizeF(5, 5).

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SolarLayout.HonorInitialNodeDisposition Property

SolarLayout.HonorInitialNodeDisposition Property
[image]

Gets or sets a value indicating whether the initial position of a child node relative to its parent node is preserved in the final layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool HonorInitialNodeDisposition { get; set; }

Visual Basic [image] Copy Code

Public Property HonorInitialNodeDisposition As Boolean

Property Value

true to keep the initial position of child nodes relative to their parent nodes; otherwise, false. The default is false.

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SolarLayout.IgnoreLinkDirection Property

SolarLayout.IgnoreLinkDirection Property
[image]

Gets or sets a value indicating whether the tree layout algorithm should ignore the direction of links when arranging a tree.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IgnoreLinkDirection { get; set; }

Visual Basic [image] Copy Code

Public Property IgnoreLinkDirection As Boolean

Property Value

true to ignore link direction; otherwise, false. The default is false.

Remarks

Parent-child direction is considered the one in which nodes go further from the root, instead that of the links.

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SolarLayout.KeepRootPosition Property

SolarLayout.KeepRootPosition Property
[image]

Gets or sets a value indicating whether to keep the root node at its original position.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool KeepRootPosition { get; set; }

Visual Basic [image] Copy Code

Public Property KeepRootPosition As Boolean

Property Value

true to keep the root position; otherwise, false. The default is false.

Remarks

If the root position is not kept, that is, the value of this property is false, the entire tree is dispositioned after the layout is complete, according to the values of Margins.

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SolarLayout.LevelDistance Property

SolarLayout.LevelDistance Property
[image]

Gets or sets the minimal distance between a parent node and its children.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float LevelDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LevelDistance As Single

Property Value

A float value specifying the minimal distance between parent node and its children. The default is 10.

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SolarLayout.Name Property

SolarLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Solar layout".

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SolarLayout.NodeDistance Property

SolarLayout.NodeDistance Property
[image]

Gets or sets the minimal distance between siblings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Single

Property Value

A float value specifying the minimaldistance between siblings. The default is 10.

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SolarLayout.ReversedLinks Property

SolarLayout.ReversedLinks Property
[image]

Gets or sets a value indicating the link direction that relates parent nodes to child nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ReversedLinks { get; set; }

Visual Basic [image] Copy Code

Public Property ReversedLinks As Boolean

Property Value

true to indicate reversed direction, that is, the parent node is the one the link points to; otherwise, false. The default is false.

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SolarLayout.Root Property

SolarLayout.Root Property
[image]

Gets or sets the tree root.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As DiagramNode

Property Value

An instance of the DiagramNode class that represents the root node.

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Class

SpringLayout Class
Remarks See Also
[image]

Implements the Spring-Embedder graph layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class SpringLayout : Layout

Visual Basic [image] Copy Code

Public Class SpringLayout
Inherits Layout

Remarks

Spring-Embedder produces layouts having uniform distribution of nodes by simulating a physical system in which nodes repulse each other and the links between them act as confining springs. Nodes are moved around in an iterative process. The forces that act on a node are calculated, taking in account the positions of surrounding nodes and links from the previous iteration.

To apply this layout to a diagram, call the Arrange method of a SpringLayout instance. Arrange lays out all subgraphs in a diagram, unless the Root property is set.

If the LayoutTraits value associated with a node through SpringLayoutTraits.Frozen is true, SpringLayout considers the repulsion forces exerted by the node on other nodes, but ignores forces acting on the node and keeps it in place.

The final appearance of arranged graphs depends mostly on the values of EnableClusters and NodeDistance properties that specify how nodes are distributed by the layout routine. Enabling the MinimizeCrossings property helps to decrease the number of link crossings, though that makes the algorithm run somewhat slower.

The layout routine runs as much iterations as set in IterationCount, calculating better node positions at each step. When that stage of the algorithm completes, if Anchoring is enabled, link ends are aligned to nodes' anchor points.

The Spring-Embedder layout algorithm produces best results if it can place link ends at arbitrary positions over nodes' outlines, that is, when using the Ignore value. If your application logic requires links to be always attached to anchor points, use the other two values. In such cases Reassign would yield better results.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.SpringLayout

See Also

SpringLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Members

SpringLayout Members
Constructors Properties Methods
[image]

Implements the Spring-Embedder graph layout algorithm.

The following tables list the members exposed by the SpringLayout type.

Public Constructors

Name | Description
SpringLayout | Overloaded. Initializes a new instance of the SpringLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
EnableClusters | Gets or sets a value indicating whether to enable allocation of nodes to distinct clusters.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
IterationCount | Gets or sets for how many iterations to run the layout routine.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
Layout3D | Specifies whether the layout should set the 3D coordinates of nodes for display inside DiagramView3D.
LayoutArea | Gets or sets the size of the layout area.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutMethod | Specifies what energy model to use for the simulation.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinkType | Gets or sets the appearance of the links in the final layout.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MinimizeCrossings | Gets or sets a value indicating whether crossing minimization mode is enabled.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the desired distance between nodes.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
Randomize | Gets or sets a value indicating whether nodes should be placed at random positions when the layout routine starts.
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
RepulsionFactor | Gets or sets the multiplier applied to repulsion forces between nodes.
Root | Gets or sets a node indicating which subgraph of the diagram must be laid out.
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.
Stretch | Gets or sets the stretch factor.
Surface | Specifies on what surface the nodes should be placed initially.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)
BeginArrange | Initializes the layout object for a step-by-step execution.
EndArrange | Completes the step-by-step execution started with a call to BeginArrange.
Iterate | Runs one or more layout iterations.

See Also

SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Constructor

SpringLayout Constructor
[image]

Initializes a new instance of the SpringLayout class.

Overload List

Name | Description
SpringLayout () | Initializes a new instance of the SpringLayout class with the default settings.
SpringLayout (Int32, Single, Boolean) | Initializes a new instance of the SpringLayout class with the specified settings.
SpringLayout (Int32, Single, Boolean, Boolean) | Initializes a new instance of the SpringLayout class with the specified settings.

See Also

SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Constructor ()

SpringLayout Constructor ()
See Also
[image]

Initializes a new instance of the SpringLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SpringLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SpringLayout Constructor Overload List
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Constructor (Int32, Single, Boolean)

SpringLayout Constructor (Int32, Single, Boolean)
See Also
[image]

Initializes a new instance of the SpringLayout class with the specified settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SpringLayout (
int iterationCount,
float nodeDistance,
bool minimizeCrossings
)

Visual Basic [image] Copy Code

Public New ( _
iterationCount As Integer, _
nodeDistance As Single, _
minimizeCrossings As Boolean _
)

Parameters

iterationCount

The number of iterations to perform.

nodeDistance

The distance between nodes.

minimizeCrossings

Specifies whether to try to minimize crossings while layouting.

See Also

SpringLayout Constructor Overload List
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Constructor (Int32, Single, Boolean, Boolean)

SpringLayout Constructor (Int32, Single, Boolean, Boolean)
See Also
[image]

Initializes a new instance of the SpringLayout class with the specified settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SpringLayout (
int iterationCount,
float nodeDistance,
bool minimizeCrossings,
bool keepGroupLayout
)

Visual Basic [image] Copy Code

Public New ( _
iterationCount As Integer, _
nodeDistance As Single, _
minimizeCrossings As Boolean, _
keepGroupLayout As Boolean _
)

Parameters

iterationCount

The number of iterations to perform.

nodeDistance

The distance between nodes.

minimizeCrossings

Specifies whether to try to minimize crossings while layouting.

keepGroupLayout

Specifies whether to keep the relative position of grouped items.

See Also

SpringLayout Constructor Overload List
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Methods

SpringLayout Methods
[image]

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)
BeginArrange | Initializes the layout object for a step-by-step execution.
EndArrange | Completes the step-by-step execution started with a call to BeginArrange.
Iterate | Runs one or more layout iterations.

See Also

SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.BeginArrange Method

SpringLayout.BeginArrange Method
[image]

Initializes the layout object for a step-by-step execution.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool BeginArrange (
Diagram diagram,
DiagramItemCollection items
)

Visual Basic [image] Copy Code

Public Function BeginArrange ( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram
The Diagram that should be arranged.
items
A collection of nodes and links from diagram that define the subgraph to arrange.

Return Value

true if the layout object has been initialized successfully; otherwise, false.

Remarks

You can use this method together with Iterate and EndArrange to display an animation of the layout process. To run all iterations of the process at once and display just the end result, call Arrange.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.EndArrange Method

SpringLayout.EndArrange Method
[image]

Completes the step-by-step execution started with a call to BeginArrange.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void EndArrange ()

Visual Basic [image] Copy Code

Public Sub EndArrange ()

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.Iterate Method

SpringLayout.Iterate Method
[image]

Runs one or more layout iterations.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Iterate (
int iterationFrom,
int iterationTo
)

Visual Basic [image] Copy Code

Public Sub Iterate ( _
iterationFrom As Integer, _
iterationTo As Integer _
)

Parameters

iterationFrom
Specifies from which iteration to start.
iterationTo
Specifies at which iteration to stop.

Remarks

Use this method to create an animation of the layout process, for example, by calling it from a timer. Call BeginArrange to prepare the layout object for use of Iterate, and call EndArrange when done. Each call to Iterate should start from the iteration next to the one where the previous call has stopped.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Properties

SpringLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
EnableClusters | Gets or sets a value indicating whether to enable allocation of nodes to distinct clusters.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
IterationCount | Gets or sets for how many iterations to run the layout routine.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
Layout3D | Specifies whether the layout should set the 3D coordinates of nodes for display inside DiagramView3D.
LayoutArea | Gets or sets the size of the layout area.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutMethod | Specifies what energy model to use for the simulation.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinkType | Gets or sets the appearance of the links in the final layout.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MinimizeCrossings | Gets or sets a value indicating whether crossing minimization mode is enabled.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the desired distance between nodes.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
Randomize | Gets or sets a value indicating whether nodes should be placed at random positions when the layout routine starts.
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
RepulsionFactor | Gets or sets the multiplier applied to repulsion forces between nodes.
Root | Gets or sets a node indicating which subgraph of the diagram must be laid out.
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.
Stretch | Gets or sets the stretch factor.
Surface | Specifies on what surface the nodes should be placed initially.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.DefaultMarginValue Property

SpringLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override SizeF DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As SizeF

Property Value

Returns new SizeF(5, 5).

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.EnableClusters Property

SpringLayout.EnableClusters Property
[image]

Gets or sets a value indicating whether to enable allocation of nodes to distinct clusters.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableClusters { get; set; }

Visual Basic [image] Copy Code

Public Property EnableClusters As Boolean

Property Value

true to detect and process node clusters; otherwise, false. The default is false.

Remarks

If enabled, the SpringLayout algorithm detects node clusters and places them at distinct positions. Each cluster consists of a center node surrounded by several local nodes. Clusters might be connected with other clusters by their center nodes. Best-looking results are achieved when there aren't links between the local nodes in a cluster.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.IterationCount Property

SpringLayout.IterationCount Property
[image]

Gets or sets for how many iterations to run the layout routine.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int IterationCount { get; set; }

Visual Basic [image] Copy Code

Public Property IterationCount As Integer

Property Value

An integer value specifying the number of iterations. The default is 200.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.Layout3D Property

SpringLayout.Layout3D Property
[image]

Specifies whether the layout should set the 3D coordinates of nodes for display inside DiagramView3D.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Layout3D { get; set; }

Visual Basic [image] Copy Code

Public Property Layout3D As Boolean

Property Value

Remarks

true to set the 3D coordinates of nodes; otherwise, false. The default value is false.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace
Surface Property


MindFusion.Diagramming.Layout.SpringLayout.LayoutArea Property

SpringLayout.LayoutArea Property
[image]

Gets or sets the size of the layout area.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleF LayoutArea { get; set; }

Visual Basic [image] Copy Code

Public Property LayoutArea As RectangleF

Property Value

A .NET RectangleF representing the boundaries of the layout area. The default is RectangleF.Empty.

Remarks

If the layout area is not explicitly set, the algorithm will choose one suitable for the graph size.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.LayoutMethod Property

SpringLayout.LayoutMethod Property
[image]

Specifies what energy model to use for the simulation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SpringLayoutMethod LayoutMethod { get; set; }

Visual Basic [image] Copy Code

Public Property LayoutMethod As SpringLayoutMethod

Property Value

A member of the SpringLayoutMethod enumeration. The default value is FruchtermanReingold.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.LinkType Property

SpringLayout.LinkType Property
[image]

Gets or sets the appearance of the links in the final layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SpringLayoutLinkType LinkType { get; set; }

Visual Basic [image] Copy Code

Public Property LinkType As SpringLayoutLinkType

Property Value

A member of the SpringLayoutLinkType enumeration. The default value is Straight.

Remarks

If this property is set to Rounded, the layout method sets the links' Shape to Bezier and simulates repulsion forces exerted by their intermediate control points. The Rounded option produces better results when LayoutMethod is set to Classic.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.MinimizeCrossings Property

SpringLayout.MinimizeCrossings Property
[image]

Gets or sets a value indicating whether crossing minimization mode is enabled.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool MinimizeCrossings { get; set; }

Visual Basic [image] Copy Code

Public Property MinimizeCrossings As Boolean

Property Value

true to attempt crossing minimization; otherwise, false. The default is true.

Remarks

If enabled, SpringLayout tries to decrease number of crossing links. However this could lead to poor symmetry and node distribution. For better results, use greater IterationCount.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.Name Property

SpringLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Spring layout".

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.NodeDistance Property

SpringLayout.NodeDistance Property
[image]

Gets or sets the desired distance between nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Single

Property Value

A float value specifying the distance between nodes. The default is 30.

Remarks

The final distance between connected nodes is determined by multiplying the Weight of the link that connects them by the value of NodeDistance.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.Randomize Property

SpringLayout.Randomize Property
[image]

Gets or sets a value indicating whether nodes should be placed at random positions when the layout routine starts.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Randomize { get; set; }

Visual Basic [image] Copy Code

Public Property Randomize As Boolean

Property Value

true to start with random node positions, otherwise false. The default value is false.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace
RandomSeed Property


MindFusion.Diagramming.Layout.SpringLayout.RandomSeed Property

SpringLayout.RandomSeed Property
[image]

Gets or sets the randomization seed to use for generating random node positions.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int RandomSeed { get; set; }

Visual Basic [image] Copy Code

Public Property RandomSeed As Integer

Property Value

An integer value passed as a seed to the random number generator. The default value is 0.

Remarks

If set to 0, SpringLayout uses the current time as a seed value. Set a value greater than 0 to use a fixed seed. Random numbers are generated when nodes are at the same initial position or when Randomize is enabled. Using a fixed seed helps producing consistent layouts at each run of the Arrange method.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.RepulsionFactor Property

SpringLayout.RepulsionFactor Property
[image]

Gets or sets the multiplier applied to repulsion forces between nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double RepulsionFactor { get; set; }

Visual Basic [image] Copy Code

Public Property RepulsionFactor As Double

Property Value

A double value specifying the repulsion factor. The default value is 150.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.Root Property

SpringLayout.Root Property
[image]

Gets or sets a node indicating which subgraph of the diagram must be laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As DiagramNode

Property Value

An instance of the DiagramNode class. The default is a null reference (Nothing in Visual Basic).

Remarks

All links and nodes that can be reached from the root by following recursively its links from a graph. If the root is specified, only the graph which it defines is laid out by Arrange.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.SplitGraph Property

SpringLayout.SplitGraph Property
[image]

Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SplitGraph { get; set; }

Visual Basic [image] Copy Code

Public Property SplitGraph As Boolean

Property Value

true if unconnected graphs in the diagram should be laid out independently; otherwise, false. The default is false.

Remarks

If this property is set to true, each independent graph in the diagram is laid out in its own layout area. Otherwise all subgraphs are arranged in the same layout area. If a Root node is specified and SplitGraph is true, only the graph that contains the root node will be arranged.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.Stretch Property

SpringLayout.Stretch Property
[image]

Gets or sets the stretch factor.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Stretch { get; set; }

Visual Basic [image] Copy Code

Public Property Stretch As Double

Property Value

A double value specifying the stretch factor used by the spring layout.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.Surface Property

SpringLayout.Surface Property
[image]

Specifies on what surface the nodes should be placed initially.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public new Surface Surface { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property Surface As Surface

Property Value

A member of the Surface enumeration. The default value is Sphere.

Remarks

Specifies on what surface the graph nodes should be placed initially, when Layout3D is enabled.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayoutLinkType Enumeration

SpringLayoutLinkType Enumeration
[image]

Specifies the style of the diagram links after they are laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum SpringLayoutLinkType

Visual Basic [image] Copy Code

Public Enum SpringLayoutLinkType

Members

Member name | Description
Straight | Indicates straight links with a single segment.
Rounded | Indicates Bйzier links with a single segment.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout Class

SwimlaneLayout Class
Remarks See Also
[image]

Implements an algorithm which arranges nodes in lanes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class SwimlaneLayout : Layout

Visual Basic [image] Copy Code

Public Class SwimlaneLayout
Inherits Layout

Remarks

This layout algorithm can be used to arrange process diagrams in which nodes representing activities are placed in swimlanes representing resources. The index of the resource allocated to an activity should be assigned to the corresponding node's LayoutTraits[SwimlaneLayoutTraits.Lane].

By default, the algorithm works with the diagram's LaneGrid, but its SwimlaneGrid property can be set to any class that implements ISwimlaneGrid. This allows applying the layout to a custom-drawn grid rendered through the DrawBackground event, or one composed of locked background nodes.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.SwimlaneLayout

See Also

SwimlaneLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout Members

SwimlaneLayout Members
Constructors Properties Methods
[image]

Implements an algorithm which arranges nodes in lanes.

The following tables list the members exposed by the SwimlaneLayout type.

Public Constructors

Name | Description
SwimlaneLayout | Initializes a new instance of the SwimlaneLayout class with the default settings.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
CollapseEmptyLanes | Get or sets a value indicating whether lanes without associated nodes will shrink to zero size. By default, empty lanes will have size equal to LaneDistance.
CompactNodes | Gets or sets a value indicating whether the nodes within individual lanes are compacted.
CustomSortOrder | Gets or sets a value indicating whether the nodes in a lane should be arranged according to the custom sort order specified through LayoutTraits.
Direction | Gets or sets the direction of the arranged diagram.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
KeepLaneSizes | Gets or sets a value indicating whether the layout will attempt to preserve the original sizes of the lanes in the supplied grid.
LaneDistance | Gets or sets the spacing between adjacent lanes in the final layout.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the spacing between adjacent nodes within a lane in the final layout.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
SwimlaneGrid | Gets or sets the object through which the layout can manipulate the swimlane grid.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout Constructor

SwimlaneLayout Constructor
[image]

Initializes a new instance of the SwimlaneLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SwimlaneLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout Properties

SwimlaneLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
CollapseEmptyLanes | Get or sets a value indicating whether lanes without associated nodes will shrink to zero size. By default, empty lanes will have size equal to LaneDistance.
CompactNodes | Gets or sets a value indicating whether the nodes within individual lanes are compacted.
CustomSortOrder | Gets or sets a value indicating whether the nodes in a lane should be arranged according to the custom sort order specified through LayoutTraits.
Direction | Gets or sets the direction of the arranged diagram.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
KeepLaneSizes | Gets or sets a value indicating whether the layout will attempt to preserve the original sizes of the lanes in the supplied grid.
LaneDistance | Gets or sets the spacing between adjacent lanes in the final layout.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the spacing between adjacent nodes within a lane in the final layout.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
SwimlaneGrid | Gets or sets the object through which the layout can manipulate the swimlane grid.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.CollapseEmptyLanes Property

SwimlaneLayout.CollapseEmptyLanes Property
[image]

Get or sets a value indicating whether lanes without associated nodes will shrink to zero size. By default, empty lanes will have size equal to LaneDistance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool CollapseEmptyLanes { get; set; }

Visual Basic [image] Copy Code

Public Property CollapseEmptyLanes As Boolean

Property Value

true to collapse empty lanes, otherwise false. The default value is false.

Remarks

To be able to shrink the lanes of a LaneGrid to zero size, the MinHeaderSize property of the lane grid must be set to an appropriate value.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.CompactNodes Property

SwimlaneLayout.CompactNodes Property
[image]

Gets or sets a value indicating whether the nodes within individual lanes are compacted.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool CompactNodes { get; set; }

Visual Basic [image] Copy Code

Public Property CompactNodes As Boolean

Property Value

true to compact nodes, otherwise false. The default value is true.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.CustomSortOrder Property

SwimlaneLayout.CustomSortOrder Property
[image]

Gets or sets a value indicating whether the nodes in a lane should be arranged according to the custom sort order specified through LayoutTraits.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool CustomSortOrder { get; set; }

Visual Basic [image] Copy Code

Public Property CustomSortOrder As Boolean

Property Value

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.DefaultMarginValue Property

SwimlaneLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override SizeF DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As SizeF

Property Value

Returns new SizeF(20, 20).

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.Direction Property

SwimlaneLayout.Direction Property
[image]

Gets or sets the direction of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Direction Direction { get; set; }

Visual Basic [image] Copy Code

Public Property Direction As Direction

Property Value

A member of the Direction enumeration. The default value is Straight.

Remarks

If Orientation is set to Horizontal, Direction.Straight stands for "left to right" and Direction.Reversed for "right to left". If Orientation is set to Vertical, Direction.Straight stands for "top to bottom" and Direction.Reversed for "bottom to top".

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.KeepLaneSizes Property

SwimlaneLayout.KeepLaneSizes Property
[image]

Gets or sets a value indicating whether the layout will attempt to preserve the original sizes of the lanes in the supplied grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool KeepLaneSizes { get; set; }

Visual Basic [image] Copy Code

Public Property KeepLaneSizes As Boolean

Property Value

true to preserve lane sizes, otherwise false. The default value is false.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.LaneDistance Property

SwimlaneLayout.LaneDistance Property
[image]

Gets or sets the spacing between adjacent lanes in the final layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float LaneDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LaneDistance As Single

Property Value

A float value specifying the distance between swimlanes. The default value is 20.

Remarks

For each pair of swimlanes, this value specifies the distance between the bottommost node border from the upper swimlane and the topmost node border from the lower swimlane.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.Name Property

SwimlaneLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Swimlane layout".

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.NodeDistance Property

SwimlaneLayout.NodeDistance Property
[image]

Gets or sets the spacing between adjacent nodes within a lane in the final layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Single

Property Value

A float value specifying the distance between adjacent nodes in the same swimlane. The default is 25.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.Orientation Property

SwimlaneLayout.Orientation Property
[image]

Gets or sets the overall orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Horizontal.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.SwimlaneGrid Property

SwimlaneLayout.SwimlaneGrid Property
[image]

Gets or sets the object through which the layout can manipulate the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ISwimlaneGrid SwimlaneGrid { get; set; }

Visual Basic [image] Copy Code

Public Property SwimlaneGrid As ISwimlaneGrid

Property Value

An instance of a class that implements the ISwimlaneGrid interface. The default is null (Nothing in VB.NET).

Remarks

If this property is set to null, the layout will operate on the diagram's LaneGrid.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout Class

TopologicalLayout Class
Remarks See Also
[image]

Implements a topological ordering.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TopologicalLayout : Layout

Visual Basic [image] Copy Code

Public Class TopologicalLayout
Inherits Layout

Remarks

The algorithm arranges nodes in a row or a column (depending on the value of the Orientation property) in such a way that there are as fewer back links as possible. The links connecting nonadjacent nodes are rendered as arcs. The links connecting adjacent nodes are rendered either as arcs or as straight lines, depending on the BendAdjacentLinks property. The amplitude of the link arcs is proportional to the distance between the connected nodes.

All forward links are rendered at one side of the nodes and all back links are rendered at the opposite side. Thus, all bent links follow the same rotation direction.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.TopologicalLayout

See Also

TopologicalLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout Members

TopologicalLayout Members
Constructors Properties Methods
[image]

Implements a topological ordering.

The following tables list the members exposed by the TopologicalLayout type.

Public Constructors

Name | Description
TopologicalLayout | Initializes a new instance of the TopologicalLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
BendAdjacentLinks | Gets or sets a value indicating whether to bend links connecting adjacent nodes or draw them as straight lines.
Direction | Gets or sets the direction of the arranged diagram.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the distance between adjacent nodes in the diagram.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout Constructor

TopologicalLayout Constructor
[image]

Initializes a new instance of the TopologicalLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TopologicalLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout Properties

TopologicalLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
BendAdjacentLinks | Gets or sets a value indicating whether to bend links connecting adjacent nodes or draw them as straight lines.
Direction | Gets or sets the direction of the arranged diagram.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the distance between adjacent nodes in the diagram.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout.BendAdjacentLinks Property

TopologicalLayout.BendAdjacentLinks Property
[image]

Gets or sets a value indicating whether to bend links connecting adjacent nodes or draw them as straight lines.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool BendAdjacentLinks { get; set; }

Visual Basic [image] Copy Code

Public Property BendAdjacentLinks As Boolean

Property Value

true to bend links connecting adjacent nodes; false, to draw them as straight lines. The default is false.

Remarks

This property applies only to forward link. Back links connecting adjacent nodes are always rendered as bent.

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout.DefaultMarginValue Property

TopologicalLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override SizeF DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As SizeF

Property Value

Returns new SizeF(5, 5).

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout.Direction Property

TopologicalLayout.Direction Property
[image]

Gets or sets the direction of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Direction Direction { get; set; }

Visual Basic [image] Copy Code

Public Property Direction As Direction

Property Value

A member of the Direction enumeration. The default is Straight.

Remarks

If Orientation is set to Horizontal, Direction.Straight stands for "left to right" and Direction.Reversed for "right to left". If Orientation is set to Vertical, Direction.Straight stands for "top to bottom" and Direction.Reversed for "bottom to top".

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout.MultipleGraphsPlacement Property

TopologicalLayout.MultipleGraphsPlacement Property
[image]

Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MultipleGraphsPlacement MultipleGraphsPlacement { get; set; }

Visual Basic [image] Copy Code

Public Property MultipleGraphsPlacement As MultipleGraphsPlacement

Property Value

A member of the MultipleGraphsPlacement enumeration. The default value is Vertical.

Remarks

If the diagram contains several unconnected subgraphs and SplitGraph is set to true, each of them is processed by the algorithm independently from the others. This property specifies how such subgraphs should be placed one relatively to another. The possible options are to arrange them in a row, in a column, or in such a way that the diagram covers a minimal area.

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout.Name Property

TopologicalLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Topological layout".

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout.NodeDistance Property

TopologicalLayout.NodeDistance Property
[image]

Gets or sets the distance between adjacent nodes in the diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Single

Property Value

A float value specifying the distance between adjacent nodes. The default is 20.

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout.Orientation Property

TopologicalLayout.Orientation Property
[image]

Gets or sets the overall orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default is Horizontal.

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout.SplitGraph Property

TopologicalLayout.SplitGraph Property
[image]

Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SplitGraph { get; set; }

Visual Basic [image] Copy Code

Public Property SplitGraph As Boolean

Property Value

true if unconnected graphs in the diagram should be laid out independently; otherwise, false. The default is true.

Remarks

If this property is set to true, each independent graph in the diagram is laid out in its own layout area. Otherwise all subgraphs are arranged in the same layout area.

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Class

TreeLayout Class
Remarks See Also
[image]

Implements several algorithms for arranging tree structures.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TreeLayout : Layout

Visual Basic [image] Copy Code

Public Class TreeLayout
Inherits Layout

Remarks

Set the Type property of a TreeLayout instance to select which tree layout algorithm to run, and call the Arrange method to apply the layout on a tree/subtree in the current diagram.

As long as the graph is a tree, the algorithm can find the root node automatically. You can override it by setting the Root property, e.g. in order to arrange only a selected branch of the tree. The distance between the root and the second level and between all subsequent levels can be set through the LevelDistance property. The distance between adjacent nodes in the same level is set through NodeDistance.

In addition to arranging the tree nodes, TreeLayout also sets the shape of links as set through its LinkStyle property. Anchoring specifies whether the links should be attached to the anchor points of tree nodes. Note that links that are not part of the tree are ignored, e.g. graph links that go in opposite direction of the general parent-to-child flow or cross-links that connect different tree branches. The tree layout algorithm produces best results if it can place link ends at arbitrary positions over nodes' outlines, that is, when using the Ignore value. If your application logic requires links to be always attached to anchor points, use the other two values. In such cases Reassign would yield better results. You can post-process such links after calling Arrange, for example by setting their ControlPoints coordinates or by calling their Route method.

By default, the order of child nodes arranged under a parent corresponds to the order of links in the parent's OutgoingLinks collection. The Balance property can be set to Preserve to keep the original geometric order of child nodes when arranging them under their parent. This can be used to arrange tree branches in a specific order by first placing them in increasing horizontal or vertical positions. Another possibility is to apply TreeLayout from NodeModified handler to let users rearrange the tree branches by dragging and dropping a node.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.TreeLayout

See Also

TreeLayout Members
MindFusion.Diagramming.Layout Namespace
TreeMapLayout Class


MindFusion.Diagramming.Layout.TreeLayout Members

TreeLayout Members
Constructors Properties Methods
[image]

Implements several algorithms for arranging tree structures.

The following tables list the members exposed by the TreeLayout type.

Public Constructors

Name | Description
TreeLayout | Overloaded. Initializes a new instance of the TreeLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
Balance | Gets or sets a value indicating the ordering of the child nodes in order to produce layouts with custom balance.
CompactAssistants | Gets or sets a value indicating whether the "assistant" nodes on the same side of a single parent are arranged as close enough to each other as possible. Turning this off will force the nodes on one side to be aligned with their counterparts in the other and occasionally leaving space between adjacent branches.
Direction | Gets or sets the tree direction.
EnableAssistants | Gets or sets a value indicating whether the "assistant" trait is regarded when performing the layout.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
IgnoreLinkDirection | Gets or sets a value indicating whether the tree layout algorithm should ignore the direction of links when arranging a tree.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
KeepRootPosition | Gets or sets a value indicating whether to keep the root node at its original position.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LevelDistance | Gets or sets how much space to leave between levels of the tree.
LinkOffset | Gets or sets the links' offset from the centers of the nodes. This property is applicable only for Centered tree layouts.
LinkStyle | Gets or sets a value indicating how links in the arranged tree should look.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets how much space to leave between nodes on the same level.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
ReversedLinks | Gets or sets a value indicating the link direction that relates parent nodes to child nodes.
Root | Gets or sets the root node of the tree.
StretchFactor | Gets or sets the stretch factor applied on Radial tree layouts.
Type | Gets or sets what type of tree layout to apply to the diagram.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)
UpdateLink | Updates the style and position of the specified link.

See Also

TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor

TreeLayout Constructor
[image]

Initializes a new instance of the TreeLayout class.

Overload List

Name | Description
TreeLayout () | Initializes a new instance of the TreeLayout class with the default settings.
TreeLayout (DiagramNode) | Initializes a new instance of the TreeLayout class with the specified node as root.
TreeLayout (DiagramNode, TreeLayoutType) | Initializes a new instance of the TreeLayout class with the specified node as root and the specified type.
TreeLayout (DiagramNode, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Single, Single, Boolean, SizeF) | Initializes a new instance of the TreeLayout class with the specified settings.
TreeLayout (DiagramNode, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Single, Single, Boolean, SizeF, Boolean) | Initializes a new instance of the TreeLayout class with the specified settings.
TreeLayout (TreeLayoutType) | Initializes a new instance of the TreeLayout class with the specified type.

See Also

TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor ()

TreeLayout Constructor ()
See Also
[image]

Initializes a new instance of the TreeLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor (DiagramNode)

TreeLayout Constructor (DiagramNode)
See Also
[image]

Initializes a new instance of the TreeLayout class with the specified node as root.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayout (
DiagramNode root
)

Visual Basic [image] Copy Code

Public Sub TreeLayout ( _
root As DiagramNode _
)

Parameters

root

The root of the arranged tree.

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor (DiagramNode, TreeLayoutType)

TreeLayout Constructor (DiagramNode, TreeLayoutType)
See Also
[image]

Initializes a new instance of the TreeLayout class with the specified node as root and the specified type.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayout (
DiagramNode root,
TreeLayoutType type
)

Visual Basic [image] Copy Code

Public Sub TreeLayout ( _
root As DiagramNode, _
type As TreeLayoutType _
)

Parameters

root

The root of the arranged tree.

type
The type of the tree layout.

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor (DiagramNode, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Single, Single, Boolean, SizeF)

TreeLayout Constructor (DiagramNode, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Single, Single, Boolean, SizeF)
See Also
[image]

Initializes a new instance of the TreeLayout class with the specified settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayout (
DiagramNode root,
TreeLayoutType type,
bool reversedLinks,
TreeLayoutLinkType linkStyle,
TreeLayoutDirections direction,
float levelDistance,
float nodeDistance,
bool keepRootPosition,
SizeF margins
)

Visual Basic [image] Copy Code

Public Sub TreeLayout ( _
root As DiagramNode, _
type As TreeLayoutType, _
reversedLinks As Boolean, _
linkStyle As TreeLayoutLinkType, _
direction As TreeLayoutDirections, _
levelDistance As Single, _
nodeDistance As Single, _
keepRootPosition As Boolean, _
margins as SizeF _
)

Parameters

root

The root of the arranged tree.

type

The type of the tree layout.

reversedLinks

Specifies whether the parent-to-child direction in the tree is reversed, that is, from the end of the link towards its beginning.

linkStyle

The style of the links in the produced layout.

direction

The layout direction.

levelDistance

The distance between adjacent levels.

nodeDistance

The distance between adjacent nodes.

keepRootPosition

Specifies whether to keep the position of the tree root.

margins

The margin between the produced tree and the left side of the diagram bounding rectangle.

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor (DiagramNode, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Single, Single, Boolean, SizeF, Boolean)

TreeLayout Constructor (DiagramNode, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Single, Single, Boolean, SizeF, Boolean)
See Also
[image]

Initializes a new instance of the TreeLayout class with the specified settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayout (
DiagramNode root,
TreeLayoutType type,
bool reversedLinks,
TreeLayoutLinkType linkStyle,
TreeLayoutDirections direction,
float levelDistance,
float nodeDistance,
bool keepRootPosition,
SizeF margins,
bool keepGroupLayout
)

Visual Basic [image] Copy Code

Public Sub TreeLayout ( _
root As DiagramNode, _
type As TreeLayoutType, _
reversedLinks As Boolean, _
linkStyle As TreeLayoutLinkType, _
direction As TreeLayoutDirections, _
levelDistance As Single, _
nodeDistance As Single, _
keepRootPosition As Boolean, _
margins as SizeF, _
keepGroupLayout As Boolean _
)

Parameters

root

The root of the arranged tree.

type

The type of the tree layout.

reversedLinks

Specifies whether the parent-to-child direction in the tree should be reversed, that is, from the end of the link towards its beginning.

linkStyle

The style of the links in the produced layout.

direction

The layout direction.

levelDistance

The distance between adjacent levels.

nodeDistance

The distance between adjacent nodes.

keepRootPosition

Specifies whether to keep the position of the tree root.

margins

The margin between the produced tree and the left side of the diagram bounding rectangle.

keepGroupLayout

Specifies whether to keep the relative position of grouped items.

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor (TreeLayoutType)

TreeLayout Constructor (TreeLayoutType)
See Also
[image]

Initializes a new instance of the TreeLayout class with the specified type.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayout (
TreeLayoutType type
)

Visual Basic [image] Copy Code

Public Sub TreeLayout ( _
type As TreeLayoutType _
)

Parameters

type

The type of the tree layout.

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Methods

TreeLayout Methods
[image]

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)
UpdateLink | Updates the style and position of the specified link.

See Also

TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.UpdateLink Method

TreeLayout.UpdateLink Method
[image]

Updates the style and position of the specified link.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void UpdateLink (
DiagramLink a,
bool ignoredDirection
)

Visual Basic [image] Copy Code

Public Sub UpdateLink ( _
a As DiagramLink, _
ignoredDirection As Boolean _
)

Parameters

a
A DiagramLink that will be updated.
ignoredDirection

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Properties

TreeLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
Balance | Gets or sets a value indicating the ordering of the child nodes in order to produce layouts with custom balance.
CompactAssistants | Gets or sets a value indicating whether the "assistant" nodes on the same side of a single parent are arranged as close enough to each other as possible. Turning this off will force the nodes on one side to be aligned with their counterparts in the other and occasionally leaving space between adjacent branches.
Direction | Gets or sets the tree direction.
EnableAssistants | Gets or sets a value indicating whether the "assistant" trait is regarded when performing the layout.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
IgnoreLinkDirection | Gets or sets a value indicating whether the tree layout algorithm should ignore the direction of links when arranging a tree.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
KeepRootPosition | Gets or sets a value indicating whether to keep the root node at its original position.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LevelDistance | Gets or sets how much space to leave between levels of the tree.
LinkOffset | Gets or sets the links' offset from the centers of the nodes. This property is applicable only for Centered tree layouts.
LinkStyle | Gets or sets a value indicating how links in the arranged tree should look.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets how much space to leave between nodes on the same level.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
ReversedLinks | Gets or sets a value indicating the link direction that relates parent nodes to child nodes.
Root | Gets or sets the root node of the tree.
StretchFactor | Gets or sets the stretch factor applied on Radial tree layouts.
Type | Gets or sets what type of tree layout to apply to the diagram.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.Balance Property

TreeLayout.Balance Property
[image]

Gets or sets a value indicating the ordering of the child nodes in order to produce layouts with custom balance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayoutBalance Balance { get; set; }

Visual Basic [image] Copy Code

Public Property Balance As TreeLayoutBalance

Property Value

A member of the TreeLayoutBalance enumeration. The default value is Original.

Remarks

The LeftHeavy, Original and RightHeavy values are considered when Type is set to HorizontalVertical. The Preserve and Reversed values are considered by all other tree layout types, and will lead to sorting tree branches by the original horizontal, vertical or angular positions of nodes.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.CompactAssistants Property

TreeLayout.CompactAssistants Property
[image]

Gets or sets a value indicating whether the "assistant" nodes on the same side of a single parent are arranged as close enough to each other as possible. Turning this off will force the nodes on one side to be aligned with their counterparts in the other and occasionally leaving space between adjacent branches.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool CompactAssistants { get; set; }

Visual Basic [image] Copy Code

Public Property CompactAssistants As Boolean

Property Value

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.DefaultMarginValue Property

TreeLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override SizeF DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As SizeF

Property Value

Returns new SizeF(5, 5).

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.Direction Property

TreeLayout.Direction Property
[image]

Gets or sets the tree direction.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayoutDirections Direction { get; set; }

Visual Basic [image] Copy Code

Public Property Direction As TreeLayoutDirections

Property Value

A member of the TreeLayoutDirections enumeration.

Remarks

This property must be set to a combination of two TreeLayoutDirections members when using Type is HorizontalVertical.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.EnableAssistants Property

TreeLayout.EnableAssistants Property
[image]

Gets or sets a value indicating whether the "assistant" trait is regarded when performing the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableAssistants { get; set; }

Visual Basic [image] Copy Code

Public Property EnableAssistants As Boolean

Property Value

true to enable assistant nodes, otherwise false; the default value is false.

Remarks

Enabling this property lets you create organizational charts as in MS office. To designate some nodes as assistants, assign true as a value for the TreeLayoutTraits.Assistant key in the node's LayoutTraits.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.IgnoreLinkDirection Property

TreeLayout.IgnoreLinkDirection Property
[image]

Gets or sets a value indicating whether the tree layout algorithm should ignore the direction of links when arranging a tree.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IgnoreLinkDirection { get; set; }

Visual Basic [image] Copy Code

Public Property IgnoreLinkDirection As Boolean

Property Value

true to ignore link direction; otherwise, false. The default is false.

Remarks

Parent-child direction is considered the one in which nodes go further from the root, instead that of the links. If IgnoreLinkDirection is set to true, you must explicitly specify the tree Root.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.KeepRootPosition Property

TreeLayout.KeepRootPosition Property
[image]

Gets or sets a value indicating whether to keep the root node at its original position.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool KeepRootPosition { get; set; }

Visual Basic [image] Copy Code

Public Property KeepRootPosition As Boolean

Property Value

true to keep the root position; otherwise, false.

Remarks

If the root position is not kept, that is, the value of this property is false, the entire tree is dispositioned after the layout is complete, according to the values of Margins.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.LevelDistance Property

TreeLayout.LevelDistance Property
[image]

Gets or sets how much space to leave between levels of the tree.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float LevelDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LevelDistance As Single

Property Value

A float value specifying the distance between adjacent levels in the tree.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.LinkOffset Property

TreeLayout.LinkOffset Property
[image]

Gets or sets the links' offset from the centers of the nodes. This property is applicable only for Centered tree layouts.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float LinkOffset { get; set; }

Visual Basic [image] Copy Code

Public Property LinkOffset As Single

Property Value

A float value specifying offset of links from the parent node's center. The default value is 0.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.LinkStyle Property

TreeLayout.LinkStyle Property
[image]

Gets or sets a value indicating how links in the arranged tree should look.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayoutLinkType LinkStyle { get; set; }

Visual Basic [image] Copy Code

Public Property LinkStyle As TreeLayoutLinkType

Property Value

A member of the TreeLayoutLinkType enumeration.

Remarks

This property is ignored if Type is set to Radial.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.Name Property

TreeLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Tree layout".

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.NodeDistance Property

TreeLayout.NodeDistance Property
[image]

Gets or sets how much space to leave between nodes on the same level.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Single

Property Value

A float value specifying the distance between adjacent nodes.

Remarks

This property is ignored if Type is set to Radial.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.ReversedLinks Property

TreeLayout.ReversedLinks Property
[image]

Gets or sets a value indicating the link direction that relates parent nodes to child nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ReversedLinks { get; set; }

Visual Basic [image] Copy Code

Public Property ReversedLinks As Boolean

Property Value

true to indicate reversed direction, that is, the parent node is the one the link points to; otherwise, false.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.Root Property

TreeLayout.Root Property
[image]

Gets or sets the root node of the tree.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As DiagramNode

Property Value

An instance of the DiagramNode class that represents the root node.

Remarks

If not set, MvcDiagram will try to find the root automatically. This root must be specified if IgnoreLinkDirection is set to true.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.StretchFactor Property

TreeLayout.StretchFactor Property
[image]

Gets or sets the stretch factor applied on Radial tree layouts.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float StretchFactor { get; set; }

Visual Basic [image] Copy Code

Public Property StretchFactor As Single

Property Value

A real number specifying the ratio between the horizontal and vertical radii of radial layout outlines. The default is 1.

Remarks

When applying a radial layout, node layers are laid out in concentric circles around the Root node. Stretching them by changing this property makes layers laid out in elliptic outlines.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.Type Property

TreeLayout.Type Property
[image]

Gets or sets what type of tree layout to apply to the diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayoutType Type { get; set; }

Visual Basic [image] Copy Code

Public Property Type As TreeLayoutType

Property Value

A member of the TreeLayoutType enumeration.

Remarks

The available tree layout types include the following:

Layout type | Appearance
Cascading |
Centered |
Radial |
HorizontalVertical |

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayoutBalance Enumeration

TreeLayoutBalance Enumeration
[image]

Specifies how to order child nodes in order to produce tree layouts with custom balance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum TreeLayoutBalance

Visual Basic [image] Copy Code

Public Enum TreeLayoutBalance

Members

Member name | Description
Original | Indicates that the child order should not be changed.
Reversed | Indicates that the child order should be reversed.
LeftHeavy | Indicates that the child nodes with most total children will be processed first, thus producing a left-heavy layout.
RightHeavy | Indicates that the child nodes with least total children will be processed first, thus producing a right-heavy layout.
Preserve | Indicates that the layout will attempt to preserve the initial relative ordering of nodes.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayoutDirections Enumeration

TreeLayoutDirections Enumeration
[image]

Specifies the direction of a tree layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum TreeLayoutDirections

Visual Basic [image] Copy Code

Public Enumeration TreeLayoutDirections

Members

Member name | Description
TopToBottom | Indicates a top-to-bottom direction.
BottomToTop | Indicates a bottom-to-top direction.
LeftToRight | Indicates a left-to-right direction.
RightToLeft | Indicates a right-to-left direction.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayoutLinkType Enumeration

TreeLayoutLinkType Enumeration
[image]

Specifies the style of the diagram links after they are laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum TreeLayoutLinkType

Visual Basic [image] Copy Code

Public Enum TreeLayoutLinkType

Members

Member name | Description
Straight | Indicates straight links with a single segment.
Cascading2 | Indicates cascading links with two segments.
Cascading3 | Indicates cascading links with three segments.
Rounded | Indicates Bйzier links with a single segment.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayoutType Enumeration

TreeLayoutType Enumeration
[image]

Specifies the type of a tree layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum TreeLayoutType

Visual Basic [image] Copy Code

Public Enum TreeLayoutType

Members

Member name | Description
Cascading | Indicates cascading tree layout.
Centered | Indicates centered tree layout.
Radial | Indicates radial tree layout.
HorizontalVertical | Indicates the Horizontal-Vertical layout algorithm, used to arrange full binary trees.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout Class

TreeMapLayout Class
Remarks See Also
[image]

Implements a tree map layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TreeMapLayout : Layout

Visual Basic [image] Copy Code

Public Class TreeMapLayout
Inherits Layout

Remarks

Tree maps represent hierarchies by nesting child nodes within their parents, where the areas of leaf nodes are proportional to their Weight values. Unlike other layout algorithms, TreeMapLayout expects hierarchies to be defined via grouping or containment (see AttachTo method and ContainerNode class), and will ignore any links in the diagram.

The diagram area covered by the topmost nodes in a hierarchy is specified via the LayoutArea property. By default, the layout tries to keep the ratio of node sides as close as possible to one. However this could make it hard to distinguish separate levels of the hierarchy. To alleviate that, set Squarify to false, and child nodes will be arranged either as a row or a column inside their parent node, alternating directions for each level. The drawback is that when Weight ratios differ greatly or nodes contain many children, some nodes could end up with very narrow rectangles.

The padding size between parent nodes and their outermost children is specified via the ContainerPadding property. The padding size between child nodes is specified via Padding.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.TreeMapLayout

See Also

TreeMapLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout Members

TreeMapLayout Members
Constructors Properties Methods
[image]

Implements a tree map layout algorithm.

The following tables list the members exposed by the TreeMapLayout type.

Public Constructors

Name | Description
TreeMapLayout | Initializes a new instance of the TreeMapLayout class with the default settings.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
ContainerPadding | Gets or sets the padding inside containers.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutArea | Gets or sets the rectangle in which the layout will try to arrange the nodes, or null, to use the diagram bounds.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged diagram.
Padding | Gets or sets the distance between adjacent nodes.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
Squarify | Gets or sets a value indicating whether the layout should attempt to keep the dimension ratio of the nodes closer to 1.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout Constructor

TreeMapLayout Constructor
[image]

Initializes a new instance of the TreeMapLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeMapLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout Properties

TreeMapLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
ContainerPadding | Gets or sets the padding inside containers.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutArea | Gets or sets the rectangle in which the layout will try to arrange the nodes, or null, to use the diagram bounds.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged diagram.
Padding | Gets or sets the distance between adjacent nodes.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
Squarify | Gets or sets a value indicating whether the layout should attempt to keep the dimension ratio of the nodes closer to 1.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout.ContainerPadding Property

TreeMapLayout.ContainerPadding Property
[image]

Gets or sets the padding inside containers.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float ContainerPadding { get; set; }

Visual Basic [image] Copy Code

Public Property ContainerPadding As Single

Property Value

A float value specifying the padding size between parent nodes and their outermost children. The default value is 0.

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace
Padding Property


MindFusion.Diagramming.Layout.TreeMapLayout.DefaultMarginValue Property

TreeMapLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override SizeF DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As SizeF

Property Value

Returns new SizeF(5, 5).

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout.LayoutArea Property

TreeMapLayout.LayoutArea Property
[image]

Gets or sets the rectangle in which the layout will try to arrange the nodes, or null, to use the diagram bounds.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Nullable<RectangleF> LayoutArea { get; set; }

Visual Basic [image] Copy Code

Public Property LayoutArea As Nullable(Of RectangleF)

Property Value

A RectangleF? specifying the area where topmost nodes in the hierarchy are laid out. The default value is null.

Remarks

If this property is not set, the algorithm uses the value of diagram's Bounds property as target layout rectangle.

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout.Name Property

TreeMapLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Tree map layout".

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout.Orientation Property

TreeMapLayout.Orientation Property
[image]

Gets or sets the orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Vertical.

Remarks

This value is used only when Squarify is set to false, and specifies the orientation of the topmost level of the hierarchy. The algorithm alternates the orientation of each subsequent level, arranging its nodes either in rows or columns.

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout.Padding Property

TreeMapLayout.Padding Property
[image]

Gets or sets the distance between adjacent nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Padding { get; set; }

Visual Basic [image] Copy Code

Public Property Padding As Single

Property Value

A float value specifying the padding size between sibling nodes. The default value is 1.

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace
ContainerPadding Property


MindFusion.Diagramming.Layout.TreeMapLayout.Squarify Property

TreeMapLayout.Squarify Property
[image]

Gets or sets a value indicating whether the layout should attempt to keep the dimension ratio of the nodes closer to 1.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Squarify { get; set; }

Visual Basic [image] Copy Code

Public Property Squarify As Boolean

Property Value

true to keep the ratio of node sides as close as possible to one, or false otherwise. The default value is true.

Remarks

If set to false, each level of the hierarchy is arranged in rows or columns with same height/width, which might create very narrow rectangles when Weight values differ greatly or nodes have many children. The alternating orientation between levels however helps to distinguish between different levels in the hierarchy. The initial direction of nodes (in topmost level) depends on the value of Orientation.

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TriangularLayout Class

TriangularLayout Class
Remarks See Also
[image]

Performs triangular layout on simple, connected graphs.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TriangularLayout : Layout

Visual Basic [image] Copy Code

Public Class TriangularLayout
Inherits Layout

Remarks

TriangularLayout places nodes on a virtual grid, such that if the source graph is planar, all links are guaranteed to have a single segment and not intersect. If the graph is not planar, its intersecting links can be optionally segmented and bended in order to improve readability. The layout method places the nodes from the external face on a triangle and recursively adds the rest of the nodes as vertices of internal triangles. As a result, it is very effective for near maximal-planar (a.k.a. triangular) graphs.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.TriangularLayout

See Also

TriangularLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TriangularLayout Members

TriangularLayout Members
Constructors Properties Methods
[image]

Performs triangular layout on simple, connected graphs.

The following tables list the members exposed by the TriangularLayout type.

Public Constructors

Name | Description
TriangularLayout | Initializes a new instance of the TriangularLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
BendNonplanarLinks | Gets or sets a value indicating whether the intersecting links in a non-planar graphs will be segmented and bended to improve presentation.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GridSize | Gets or sets the size of the virtual grid the layout will place vertices on.
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged graph.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

TriangularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TriangularLayout Constructor

TriangularLayout Constructor
[image]

Initializes a new instance of the TriangularLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TriangularLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TriangularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TriangularLayout Properties

TriangularLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes. (Inherited from Layout.)
BendNonplanarLinks | Gets or sets a value indicating whether the intersecting links in a non-planar graphs will be segmented and bended to improve presentation.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GridSize | Gets or sets the size of the virtual grid the layout will place vertices on.
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged graph.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

TriangularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TriangularLayout.BendNonplanarLinks Property

TriangularLayout.BendNonplanarLinks Property
[image]

Gets or sets a value indicating whether the intersecting links in a non-planar graphs will be segmented and bended to improve presentation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool BendNonplanarLinks { get; set; }

Visual Basic [image] Copy Code

Public Property BendNonplanarLinks As Boolean

Property Value

true to bend links, otherwise false. The default value is false.

See Also

TriangularLayout Members
TriangularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TriangularLayout.DefaultMarginValue Property

TriangularLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override SizeF DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As SizeF

Property Value

Returns new SizeF(5, 5).

See Also

TriangularLayout Members
TriangularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TriangularLayout.GridSize Property

TriangularLayout.GridSize Property
[image]

Gets or sets the size of the virtual grid the layout will place vertices on.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float GridSize { get; set; }

Visual Basic [image] Copy Code

Public Property GridSize As Single

Property Value

The default value is 20.

See Also

TriangularLayout Members
TriangularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TriangularLayout.Name Property

TriangularLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Triangular layout".

See Also

TriangularLayout Members
TriangularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TriangularLayout.Orientation Property

TriangularLayout.Orientation Property
[image]

Gets or sets the orientation of the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Vertical.

See Also

TriangularLayout Members
TriangularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Mvc Namespace

MindFusion.Diagramming.Mvc Namespace
Classes Enumerations

Classes

Class | Description
ContainerNodeConverter | Serializes ContainerNode instances.
DiagramItemConverter | Serializes DiagramItem instances.
DiagramLinkConverter | Serializes DiagramLink instances.
DiagramNodeConverter | Serializes DiagramNode instances.
DiagramView | A control that displays the contents of a Diagram on a web page.
DiagramViewConverter | Serializes DiagramView instances.
DiagramViewExtensions | Contains extension methods of DiagramView.
ItemTypeResolver | Provides a type resolver for DiagramItem classes.
LaneGridConverter | Serializes DiagramView instances in Canvas and ImageMap mode.
LaneHeaderCollectionConverter | Serializes HeaderCollection instances in Canvas mode.
LaneHeaderConverter | Serializes Header instances in Canvas mode.
LaneStyleConverter | Serializes Lanes.Style instances in Canvas mode.
NodeListView | ListBox control with support for hosting Diagram nodes and dragging them to the Diagram control.
NodeListViewExtensions | Contains extension methods of NodeListView
Overview | Provides a scaled-down view of a DiagramView contents and lets the user scroll the bound view.
OverviewExtensions | Contains extension methods of Overview.
ShapeNodeConverter | Serializes ShapeNode instances.
SvgNodeConverter | Serializes SvgNode instances.
TableNodeConverter | Serializes TableNode instances.
ZoomControl | ZoomControl lets users zoom and pan a target DiagramView interactively.
ZoomControlExtensions | Contains extension methods of ZoomControl.

Enumerations

Enumeration | Description
ClientSideMode | Specifies the implementation used in the control's client-side scripts.
TickPosition | Specifies the position of trackbar ticks.


MindFusion.Diagramming.Mvc.ClientSideMode Enumeration

ClientSideMode Enumeration
[image]

Specifies the implementation used in the control's client-side scripts.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public enum ClientSideMode

Visual Basic [image] Copy Code

Public Enum ClientSideMode

Members

Member name | Description
MsAjax | Indicates that MicrosoftAjax script will be used.
JQuery | Indicates that JQuery script will be used.

See Also

MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ContainerNodeConverter Class

ContainerNodeConverter Class
[image]

Serializes ContainerNode instances.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public class ContainerNodeConverter : DiagramNodeConverter

Visual Basic [image] Copy Code

Public Class ContainerNodeConverter
Inherits DiagramNodeConverter

Inheritance Hierarchy

System.Object
System.Web.Script.Serialization.JavaScriptConverter
MindFusion.Diagramming.Mvc.DiagramItemConverter
MindFusion.Diagramming.Mvc.DiagramNodeConverter
MindFusion.Diagramming.Mvc.ContainerNodeConverter

See Also

ContainerNodeConverter Members
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ContainerNodeConverter Members

ContainerNodeConverter Members
Constructors Properties Methods
[image]

Serializes ContainerNode instances.

The following tables list the members exposed by the ContainerNodeConverter type.

Public Constructors

Name | Description
ContainerNodeConverter | Creates a new instance of the ContainerNodeConverter class.

Public Properties

Name | Description
SupportedTypes | SupportedTypes override.

Public Methods

Name | Description
Deserialize | Deserialize override.
Serialize | Serialize override.

See Also

ContainerNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ContainerNodeConverter Constructor

ContainerNodeConverter Constructor
[image]

Creates a new instance of the ContainerNodeConverter class.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ContainerNodeConverter (
DiagramView view
)

Visual Basic [image] Copy Code

Public New ( _
view As DiagramView _
)

Parameters

view

See Also

ContainerNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ContainerNodeConverter Methods

ContainerNodeConverter Methods
[image]

Public Methods

Name | Description
Deserialize | Deserialize override.
Serialize | Serialize override.

See Also

ContainerNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ContainerNodeConverter.Deserialize Method

ContainerNodeConverter.Deserialize Method
[image]

Deserialize override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override Object Deserialize (
IDictionary<string, Object> dictionary,
Type type,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Deserialize( _
dictionary As IDictionary(Of String, Object), _
type As Type, _
serializer As JavaScriptSerializer _
) As Object

Parameters

dictionary

type

serializer

Return Value

See Also

ContainerNodeConverter Members
ContainerNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ContainerNodeConverter.Serialize Method

ContainerNodeConverter.Serialize Method
[image]

Serialize override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override IDictionary<string, Object> Serialize (
Object obj,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Serialize( _
obj As Object, _
serializer As JavaScriptSerializer _
) As IDictionary(Of String, Object)

Parameters

obj

serializer

Return Value

See Also

ContainerNodeConverter Members
ContainerNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ContainerNodeConverter Properties

ContainerNodeConverter Properties
[image]

Public Properties

Name | Description
SupportedTypes | SupportedTypes override.

See Also

ContainerNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ContainerNodeConverter.SupportedTypes Property

ContainerNodeConverter.SupportedTypes Property
[image]

SupportedTypes override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override IEnumerable<Type> SupportedTypes { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property SupportedTypes As IEnumerable(Of Type)

Property Value

See Also

ContainerNodeConverter Members
ContainerNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramItemConverter Class

DiagramItemConverter Class
[image]

Serializes DiagramItem instances.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public class DiagramItemConverter : JavaScriptConverter

Visual Basic [image] Copy Code

Public Class DiagramItemConverter
Inherits JavaScriptConverter

Inheritance Hierarchy

System.Object
System.Web.Script.Serialization.JavaScriptConverter
MindFusion.Diagramming.Mvc.DiagramItemConverter
MindFusion.Diagramming.Mvc.DiagramLinkConverter
MindFusion.Diagramming.Mvc.DiagramNodeConverter

See Also

DiagramItemConverter Members
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramItemConverter Members

DiagramItemConverter Members
Constructors Properties Methods
[image]

Serializes DiagramItem instances.

The following tables list the members exposed by the DiagramItemConverter type.

Public Constructors

Name | Description
DiagramItemConverter | Creates a new instance of the DiagramItemConverter class.

Public Properties

Name | Description
SupportedTypes | SupportedTypes override.

Public Methods

Name | Description
Deserialize | Deserialize override.
Serialize | Serialize override.

See Also

DiagramItemConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramItemConverter Constructor

DiagramItemConverter Constructor
[image]

Creates a new instance of the DiagramItemConverter class.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramItemConverter (
DiagramView view
)

Visual Basic [image] Copy Code

Public New ( _
view As DiagramView _
)

Parameters

view

See Also

DiagramItemConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramItemConverter Methods

DiagramItemConverter Methods
[image]

Public Methods

Name | Description
Deserialize | Deserialize override.
Serialize | Serialize override.

See Also

DiagramItemConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramItemConverter.Deserialize Method

DiagramItemConverter.Deserialize Method
[image]

Deserialize override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override Object Deserialize (
IDictionary<string, Object> dictionary,
Type type,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Deserialize( _
dictionary As IDictionary(Of String, Object), _
type As Type, _
serializer As JavaScriptSerializer _
) As Object

Parameters

dictionary

type

serializer

Return Value

See Also

DiagramItemConverter Members
DiagramItemConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramItemConverter.Serialize Method

DiagramItemConverter.Serialize Method
[image]

Serialize override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override IDictionary<string, Object> Serialize (
Object obj,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Serialize( _
obj As Object, _
serializer As JavaScriptSerializer _
) As IDictionary(Of String, Object)

Parameters

obj

serializer

Return Value

See Also

DiagramItemConverter Members
DiagramItemConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramItemConverter Properties

DiagramItemConverter Properties
[image]

Public Properties

Name | Description
SupportedTypes | SupportedTypes override.

See Also

DiagramItemConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramItemConverter.SupportedTypes Property

DiagramItemConverter.SupportedTypes Property
[image]

SupportedTypes override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override IEnumerable<Type> SupportedTypes { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property SupportedTypes As IEnumerable(Of Type)

Property Value

See Also

DiagramItemConverter Members
DiagramItemConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramLinkConverter Class

DiagramLinkConverter Class
[image]

Serializes DiagramLink instances.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public class DiagramLinkConverter : DiagramItemConverter

Visual Basic [image] Copy Code

Public Class DiagramLinkConverter
Inherits DiagramItemConverter

Inheritance Hierarchy

System.Object
System.Web.Script.Serialization.JavaScriptConverter
MindFusion.Diagramming.Mvc.DiagramItemConverter
MindFusion.Diagramming.Mvc.DiagramLinkConverter

See Also

DiagramLinkConverter Members
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramLinkConverter Members

DiagramLinkConverter Members
Constructors Properties Methods
[image]

Serializes DiagramLink instances.

The following tables list the members exposed by the DiagramLinkConverter type.

Public Constructors

Name | Description
DiagramLinkConverter | Creates a new instance of the DiagramLinkConverter class.

Public Properties

Name | Description
SupportedTypes | SupportedTypes override.

Public Methods

Name | Description
Deserialize | Deserialize override.
Serialize | Serialize override.

See Also

DiagramLinkConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramLinkConverter Constructor

DiagramLinkConverter Constructor
[image]

Creates a new instance of the DiagramLinkConverter class.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramLinkConverter (
DiagramView view
)

Visual Basic [image] Copy Code

Public New ( _
view As DiagramView _
)

Parameters

view

See Also

DiagramLinkConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramLinkConverter Methods

DiagramLinkConverter Methods
[image]

Public Methods

Name | Description
Deserialize | Deserialize override.
Serialize | Serialize override.

See Also

DiagramLinkConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramLinkConverter.Deserialize Method

DiagramLinkConverter.Deserialize Method
[image]

Deserialize override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override Object Deserialize (
IDictionary<string, Object> dictionary,
Type type,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Deserialize( _
dictionary As IDictionary(Of String, Object), _
type As Type, _
serializer As JavaScriptSerializer _
) As Object

Parameters

dictionary

type

serializer

Return Value

See Also

DiagramLinkConverter Members
DiagramLinkConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramLinkConverter.Serialize Method

DiagramLinkConverter.Serialize Method
[image]

Serialize override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override IDictionary<string, Object> Serialize (
Object obj,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Serialize( _
obj As Object, _
serializer As JavaScriptSerializer _
) As IDictionary(Of String, Object)

Parameters

obj

serializer

Return Value

See Also

DiagramLinkConverter Members
DiagramLinkConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramLinkConverter Properties

DiagramLinkConverter Properties
[image]

Public Properties

Name | Description
SupportedTypes | SupportedTypes override.

See Also

DiagramLinkConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramLinkConverter.SupportedTypes Property

DiagramLinkConverter.SupportedTypes Property
[image]

SupportedTypes override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override IEnumerable<Type> SupportedTypes { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property SupportedTypes As IEnumerable(Of Type)

Property Value

See Also

DiagramLinkConverter Members
DiagramLinkConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramNodeConverter Class

DiagramNodeConverter Class
[image]

Serializes DiagramNode instances.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public class DiagramNodeConverter : DiagramItemConverter

Visual Basic [image] Copy Code

Public Class DiagramNodeConverter
Inherits DiagramItemConverter

Inheritance Hierarchy

System.Object
System.Web.Script.Serialization.JavaScriptConverter
MindFusion.Diagramming.Mvc.DiagramItemConverter
MindFusion.Diagramming.Mvc.DiagramNodeConverter
MindFusion.Diagramming.Mvc.ContainerNodeConverter
MindFusion.Diagramming.Mvc.ShapeNodeConverter
MindFusion.Diagramming.Mvc.SvgNodeConverter
MindFusion.Diagramming.Mvc.TableNodeConverter

See Also

DiagramNodeConverter Members
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramNodeConverter Members

DiagramNodeConverter Members
Constructors Properties Methods
[image]

Serializes DiagramNode instances.

The following tables list the members exposed by the DiagramNodeConverter type.

Public Constructors

Name | Description
DiagramNodeConverter | Creates a new instance of the DiagramNodeConverter class.

Public Properties

Name | Description
SupportedTypes | SupportedTypes override.

Public Methods

Name | Description
Deserialize | Deserialize override.
Serialize | Serialize override.

See Also

DiagramNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramNodeConverter Constructor

DiagramNodeConverter Constructor
[image]

Creates a new instance of the DiagramNodeConverter class.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramNodeConverter (
DiagramView view
)

Visual Basic [image] Copy Code

Public New ( _
view As DiagramView _
)

Parameters

view

See Also

DiagramNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramNodeConverter Methods

DiagramNodeConverter Methods
[image]

Public Methods

Name | Description
Deserialize | Deserialize override.
Serialize | Serialize override.

See Also

DiagramNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramNodeConverter.Deserialize Method

DiagramNodeConverter.Deserialize Method
[image]

Deserialize override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override Object Deserialize (
IDictionary<string, Object> dictionary,
Type type,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Deserialize( _
dictionary As IDictionary(Of String, Object), _
type As Type, _
serializer As JavaScriptSerializer _
) As Object

Parameters

dictionary

type

serializer

Return Value

See Also

DiagramNodeConverter Members
DiagramNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramNodeConverter.Serialize Method

DiagramNodeConverter.Serialize Method
[image]

Serialize override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override IDictionary<string, Object> Serialize (
Object obj,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Serialize( _
obj As Object, _
serializer As JavaScriptSerializer _
) As IDictionary(Of String, Object)

Parameters

obj

serializer

Return Value

See Also

DiagramNodeConverter Members
DiagramNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramNodeConverter Properties

DiagramNodeConverter Properties
[image]

Public Properties

Name | Description
SupportedTypes | SupportedTypes override.

See Also

DiagramNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramNodeConverter.SupportedTypes Property

DiagramNodeConverter.SupportedTypes Property
[image]

SupportedTypes override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override IEnumerable<Type> SupportedTypes { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property SupportedTypes As IEnumerable(Of Type)

Property Value

See Also

DiagramNodeConverter Members
DiagramNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView Class

DiagramView Class
[image]

A control that displays the contents of a Diagram on a web page.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public class DiagramView

Visual Basic [image] Copy Code

Public Class DiagramView

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Mvc.DiagramView

See Also

DiagramView Members
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView Members

DiagramView Members
Constructors Properties Methods
[image]

A control that displays the contents of a Diagram on a web page.

The following tables list the members exposed by the DiagramView type.

Public Constructors

Name | Description
DiagramView | Overloaded. Creates an instance of DiagramView.

Public Properties

Name | Description
AddScriptReferences | Gets or sets a value indicating whether the control should render references to the client scripts.
AllowInplaceEdit | Gets or sets a value indicating whether in-place editing of the text of objects is enabled.
AutoScroll | Gets or sets a value indicating whether auto scrolling of the document area is enabled.
Behavior | Gets or sets a value indicating how the control responds to user actions.
ClientScriptLocation | Gets or sets the URL to the MindFusion.Diagramming.js file.
ClientSideMode | Gets or sets a value indicating which library will be used in the control's client-side scripts.
Converters | Gets the registered custom converters.
CustomLinkType | Gets the type of a MindFusion.Diagramming.DiagramLink derived class whose instance should be created when a user starts drawing.
CustomNodeType | Gets the type of a MindFusion.Diagramming.DiagramNode derived class whose instance should be created when a user starts drawing.
DelKeyAction | Gets or sets a value indicating the action that should be performed when the user hits the DELETE key.
Diagram | Gets or sets the Diagram object displayed by this view.
Enabled | Gets or sets a value indicating whether handling of mouse events is enabled.
FallbackContent | Gets or sets the HTML to be rendered as the canvas' fallback content.
Height | Gets or sets the height of the view.
Id | Gets or sets the id of the view.
ItemTypes | Gets the registered item types.
JQueryLocation | Gets or sets the URL to the JQuery script file.
LicenseKey | Gets or sets the license key of the control.
MagnifierEnabled | Gets or sets a value indicating whether the magnifier tool is currently enabled.
MagnifierFactor | Gets or sets the zoom factor of the magnifier tool.
MagnifierFrameColor | Gets or sets the color of the magnifier frame.
MagnifierFrameThickness | Gets or sets the thickness of the magnifier frame, expressed in pixels.
MagnifierHeight | Gets or sets the height of the magnifier tool, expressed in pixels.
MagnifierSecondaryFrameColor | Gets or sets the secondary color of the magnifier frame.
MagnifierShading | Gets or sets a value indicating whether to enhance the effect of a magnifier lense by using a gradient shading.
MagnifierShape | Gets or sets the shape of the magnifier tool.
MagnifierWidth | Gets or sets the width of the magnifier tool, expressed in pixels.
ModificationStart | Gets or sets how users can start modifying diagram items.
ScrollLeft | Gets or sets the view's X scroll position.
ScrollTop | Gets or sets the view's Y scroll position.
ShapeLibraryLocation | The location of a shape library file containing custom shape definitions. It can be set to a full URL of the file, or a relative file path.
ShowScrollbars | Gets or sets a value indicating whether scrollbars should be displayed.
TooltipDelay | Gets or sets the delay before a tooltip is shown.
VirtualScroll | Gets or sets a value indicating whether virtual scroll mode is enabled.
Width | Gets or sets the width of the view.
ZoomFactor | Gets or sets the zoom of the view.

Public Methods

Name | Description
ClickedScript | Sets the name of a JavaScript function that should be invoked when the user clicks the diagram at a point where no items are located.
ClientToDoc | Overloaded.
ContainerChildAddedScript | Sets the name of a JavaScript function that should be invoked when a child node is added to a container.
ContainerChildAddingScript | Sets the name of a JavaScript function that should be invoked before a child node is added to a container.
ContainerChildRemovedScript | Sets the name of a JavaScript function that should be invoked when a child node is removed from a container.
ContainerChildRemovingScript | Sets the name of a JavaScript function that should be invoked before a child node is removed from a container.
ContainerFoldedScript | Sets the name of a JavaScript function that should be invoked when the user folds a container by clicking the arrow-up button in the container's caption area.
ContainerUnfoldedScript | Sets the name of a JavaScript function that should be invoked when the user unfolds a container by clicking the arrow-down button in the container's caption area.
ControlLoadedScript | Sets the name of a JavaScript function that should be invoked when the control is loaded on the client side.
DocToClient | Overloaded. Transforms points from the document coordinate space to the client coordinate space.
DrawAdjustmentHandlesScript | Sets the name of a JavaScript function that should be invoked when item’s adjustment handles must be custom drawn.
EnterInplaceEditScript | Sets the name of a JavaScript function that should be invoked when when entering inplace-edit mode.
FromJson | Creates a DiagramView object from JSON.
FromRequest | Creates an instance of DiagramView.
HitTestAdjustmentHandlesScript | Sets the name of a JavaScript function that should be invoked when custom hit testing of item’s adjustment handles must be performed.
Init | Renders the DiagramView's initializing scripts on a web page under the specified function name.
InitializeLinkScript | Sets the name of a JavaScript function that should be invoked when the user starts drawing a new link, just after the DiagramLink instance is created.
InitializeNodeScript | Sets the name of a JavaScript function that should be invoked when the user starts drawing a new node, just after the DiagramNode instance is created.
LeaveInplaceEditScript | Sets the name of a JavaScript function that should be invoked when when leaving inplace-edit mode.
LinkClickedScript | Sets the name of a JavaScript function that should be invoked when the users clicks a link.
LinkCreatedScript | Sets the name of a JavaScript function that should be invoked when the user draws a new link.
LinkCreatingScript | Sets the name of a JavaScript function that should be invoked while the user is drawing a new link.
LinkDeletedScript | Sets the name of a JavaScript function that should be invoked when a link is deleted, either programmatically or by the user.
LinkDeletingScript | Sets the name of a JavaScript function that should be invoked when the user tries to delete a link.
LinkDeselectedScript | Sets the name of a JavaScript function that should be invoked when a link is deselected, either programmatically or by the user.
LinkDoubleClickedScript | Sets the name of a JavaScript function that should be invoked when the users double-clicks a link.
LinkModifiedScript | Sets the name of a JavaScript function that should be invoked when the user moves any control point of a link.
LinkModifyingScript | Sets the name of a JavaScript function that should be invoked while the user is modifying a link.
LinkSelectedScript | Sets the name of a JavaScript function that should be invoked when a link is selected, either programmatically or by the user.
LinkTextEditedScript | Sets the name of a JavaScript function that should be invoked when the user edits the text of a link.
LoadFromJson | Loads the specified JSON data.
NodeClickedScript | Sets the name of a JavaScript function that should be invoked when the users clicks a node.
NodeCreatedScript | Sets the name of a JavaScript function that should be invoked when the user draws a new node.
NodeCreatingScript | Sets the name of a JavaScript function that should be invoked while the user is drawing a new node.
NodeDeletedScript | Sets the name of a JavaScript function that should be invoked when a node is deleted, either programmatically or by the user.
NodeDeletingScript | Sets the name of a JavaScript function that should be invoked when the user tries to delete a node.
NodeDeselectedScript | Sets the name of a JavaScript function that should be invoked when a node is deselected, either programmatically or by the user.
NodeDoubleClickedScript | Sets the name of a JavaScript function that should be invoked when the users double-clicks a node.
NodeModifiedScript | Sets the name of a JavaScript function that should be invoked when the user moves or resizes a node.
NodeModifyingScript | Sets the name of a JavaScript function that should be invoked while the user is moving or resizing a node.
NodeSelectedScript | Sets the name of a JavaScript function that should be invoked when a node is selected, either programmatically or by the user.
NodeTextEditedScript | Sets the name of a JavaScript function that should be invoked when the user edits the text of a node.
RegisterConverters | Registers custom converters used for custom item types serialization.
RegisterItemType | Registers a custom item class for serialization support.
Render | Renders the DiagramView on a web page.
RepaintScript | Sets the name of a JavaScript function that should be invoked when the diagram has been repainted.
SaveToJson | Serializes the DiagramView's data to JSON.
SelectionModifyingScript | Sets the name of a JavaScript function that should be invoked while the user is moving or resizing multiple items.
SetAddScriptReferences | Sets a value indicating whether the control should render references to the client scripts.
SetAllowInplaceEdit | Sets a value indicating whether in-place editing of the text of objects is enabled.
SetAutoScroll | Sets a value indicating whether auto scrolling of the document area is enabled.
SetBehavior | Sets a value indicating how the control responds to user actions.
SetClientSideMode | Sets a value indicating which library will be used in the control's client-side scripts.
SetCustomLinkType | Sets the type of a MindFusion.Diagramming.DiagramLink derived class whose instance should be created when a user starts drawing.
SetCustomNodeType | Sets the type of a MindFusion.Diagramming.DiagramNode derived class whose instance should be created when a user starts drawing.
SetDelKeyAction | Sets a value indicating the action that should be performed when the user hits the Del key.
SetEnabled | Sets a value indicating whether handling of mouse events is enabled.
SetFallbackContent | Sets the HTML to be rendered as the canvas' fallback content.
SetHeight | Sets the height of the view.
SetMagnifierEnabled | Sets a value indicating whether the magnifier tool is currently enabled.
SetMagnifierFactor | Sets the zoom factor of the magnifier tool.
SetMagnifierFrameColor | Sets the color of the magnifier frame.
SetMagnifierFrameThickness | Sets the thickness of the magnifier frame, expressed in pixels.
SetMagnifierHeight | Sets the height of the magnifier tool, expressed in pixels.
SetMagnifierSecondaryFrameColor | Sets the secondary color of the magnifier frame.
SetMagnifierShading | Sets a value indicating whether to enhance the effect of a magnifier lense by using a gradient shading.
SetMagnifierShape | Sets the shape of the magnifier tool.
SetMagnifierWidth | Sets the width of the magnifier tool, expressed in pixels.
SetModificationStart | Sets how users can start modifying diagram items.
SetScrollLeft | Sets the view's X scroll position.
SetScrollTop | Sets the view's Y scroll position.
SetShowScrolbars | Sets a value indicating whether the scrollbars are visible.
SetTooltipDelay | Sets the delay before a tooltip is shown.
SetVirtualScroll | Sets a value indicating whether virtual scroll mode is enabled.
SetWidth | Sets the width of the view.
SetZoomFactor | Sets the zoom of the view.
SizeChangedScript | Sets the name of a JavaScript function that should be invoked when the size of the diagram canvas has changed.
TableColumnResizedScript | Sets the name of a JavaScript function that should be invoked when the user finishes resizing a column in a table interactively.
TableColumnResizingScript | Sets the name of a JavaScript function that should be invoked when the user resizes a column in a table interactively.
TableRowResizedScript | Sets the name of a JavaScript function that should be invoked when the user finishes resizing a row in a table interactively.
TableRowResizingScript | Sets the name of a JavaScript function that should be invoked when the user resizes a row in a table interactively.
ToJson | Serializes the DiagramView's data to JSON.
TreeCollapsedScript | Sets the name of a JavaScript function that should be invoked when a user collapses a tree branch by clicking the [+] button of an Expandable node.
TreeExpandedScript | Sets the name of a JavaScript function that should be invoked when a user expands a tree branch by clicking the [+] button of an Expandable node.

See Also

DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView Constructor

DiagramView Constructor
[image]

Creates an instance of DiagramView.

Overload List

Name | Description
DiagramView () | Creates an instance of DiagramView.
DiagramView (String) | Creates an instance of DiagramView.
DiagramView (String, Diagram) | Creates an instance of DiagramView.

See Also

DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView Constructor ()

DiagramView Constructor ()
See Also
[image]

Creates an instance of DiagramView.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramView Constructor Overload List
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView Constructor (String)

DiagramView Constructor (String)
See Also
[image]

Creates an instance of DiagramView.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView (
string id
)

Visual Basic [image] Copy Code

Public New ( _
id As String _
)

Parameters

id

The Id of the DiagramView.

See Also

DiagramView Constructor Overload List
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView Constructor (String, Diagram)

DiagramView Constructor (String, Diagram)
See Also
[image]

Creates an instance of DiagramView.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView (
string id,
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
id As String, _
diagram As Diagram _
)

Parameters

id

The Id of the DiagramView.

diagram

The Diagram displayed by the view.

See Also

DiagramView Constructor Overload List
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView Methods

DiagramView Methods
[image]

Public Methods

Name | Description
ClickedScript | Sets the name of a JavaScript function that should be invoked when the user clicks the diagram at a point where no items are located.
ClientToDoc | Overloaded.
ContainerChildAddedScript | Sets the name of a JavaScript function that should be invoked when a child node is added to a container.
ContainerChildAddingScript | Sets the name of a JavaScript function that should be invoked before a child node is added to a container.
ContainerChildRemovedScript | Sets the name of a JavaScript function that should be invoked when a child node is removed from a container.
ContainerChildRemovingScript | Sets the name of a JavaScript function that should be invoked before a child node is removed from a container.
ContainerFoldedScript | Sets the name of a JavaScript function that should be invoked when the user folds a container by clicking the arrow-up button in the container's caption area.
ContainerUnfoldedScript | Sets the name of a JavaScript function that should be invoked when the user unfolds a container by clicking the arrow-down button in the container's caption area.
ControlLoadedScript | Sets the name of a JavaScript function that should be invoked when the control is loaded on the client side.
DocToClient | Overloaded. Transforms points from the document coordinate space to the client coordinate space.
DrawAdjustmentHandlesScript | Sets the name of a JavaScript function that should be invoked when item’s adjustment handles must be custom drawn.
EnterInplaceEditScript | Sets the name of a JavaScript function that should be invoked when when entering inplace-edit mode.
FromJson | Creates a DiagramView object from JSON.
FromRequest | Creates an instance of DiagramView.
HitTestAdjustmentHandlesScript | Sets the name of a JavaScript function that should be invoked when custom hit testing of item’s adjustment handles must be performed.
Init | Renders the DiagramView's initializing scripts on a web page under the specified function name.
InitializeLinkScript | Sets the name of a JavaScript function that should be invoked when the user starts drawing a new link, just after the DiagramLink instance is created.
InitializeNodeScript | Sets the name of a JavaScript function that should be invoked when the user starts drawing a new node, just after the DiagramNode instance is created.
LeaveInplaceEditScript | Sets the name of a JavaScript function that should be invoked when when leaving inplace-edit mode.
LinkClickedScript | Sets the name of a JavaScript function that should be invoked when the users clicks a link.
LinkCreatedScript | Sets the name of a JavaScript function that should be invoked when the user draws a new link.
LinkCreatingScript | Sets the name of a JavaScript function that should be invoked while the user is drawing a new link.
LinkDeletedScript | Sets the name of a JavaScript function that should be invoked when a link is deleted, either programmatically or by the user.
LinkDeletingScript | Sets the name of a JavaScript function that should be invoked when the user tries to delete a link.
LinkDeselectedScript | Sets the name of a JavaScript function that should be invoked when a link is deselected, either programmatically or by the user.
LinkDoubleClickedScript | Sets the name of a JavaScript function that should be invoked when the users double-clicks a link.
LinkModifiedScript | Sets the name of a JavaScript function that should be invoked when the user moves any control point of a link.
LinkModifyingScript | Sets the name of a JavaScript function that should be invoked while the user is modifying a link.
LinkSelectedScript | Sets the name of a JavaScript function that should be invoked when a link is selected, either programmatically or by the user.
LinkTextEditedScript | Sets the name of a JavaScript function that should be invoked when the user edits the text of a link.
LoadFromJson | Loads the specified JSON data.
NodeClickedScript | Sets the name of a JavaScript function that should be invoked when the users clicks a node.
NodeCreatedScript | Sets the name of a JavaScript function that should be invoked when the user draws a new node.
NodeCreatingScript | Sets the name of a JavaScript function that should be invoked while the user is drawing a new node.
NodeDeletedScript | Sets the name of a JavaScript function that should be invoked when a node is deleted, either programmatically or by the user.
NodeDeletingScript | Sets the name of a JavaScript function that should be invoked when the user tries to delete a node.
NodeDeselectedScript | Sets the name of a JavaScript function that should be invoked when a node is deselected, either programmatically or by the user.
NodeDoubleClickedScript | Sets the name of a JavaScript function that should be invoked when the users double-clicks a node.
NodeModifiedScript | Sets the name of a JavaScript function that should be invoked when the user moves or resizes a node.
NodeModifyingScript | Sets the name of a JavaScript function that should be invoked while the user is moving or resizing a node.
NodeSelectedScript | Sets the name of a JavaScript function that should be invoked when a node is selected, either programmatically or by the user.
NodeTextEditedScript | Sets the name of a JavaScript function that should be invoked when the user edits the text of a node.
RegisterConverters | Registers custom converters used for custom item types serialization.
RegisterItemType | Registers a custom item class for serialization support.
Render | Renders the DiagramView on a web page.
RepaintScript | Sets the name of a JavaScript function that should be invoked when the diagram has been repainted.
SaveToJson | Serializes the DiagramView's data to JSON.
SelectionModifyingScript | Sets the name of a JavaScript function that should be invoked while the user is moving or resizing multiple items.
SetAddScriptReferences | Sets a value indicating whether the control should render references to the client scripts.
SetAllowInplaceEdit | Sets a value indicating whether in-place editing of the text of objects is enabled.
SetAutoScroll | Sets a value indicating whether auto scrolling of the document area is enabled.
SetBehavior | Sets a value indicating how the control responds to user actions.
SetClientSideMode | Sets a value indicating which library will be used in the control's client-side scripts.
SetCustomLinkType | Sets the type of a MindFusion.Diagramming.DiagramLink derived class whose instance should be created when a user starts drawing.
SetCustomNodeType | Sets the type of a MindFusion.Diagramming.DiagramNode derived class whose instance should be created when a user starts drawing.
SetDelKeyAction | Sets a value indicating the action that should be performed when the user hits the Del key.
SetEnabled | Sets a value indicating whether handling of mouse events is enabled.
SetFallbackContent | Sets the HTML to be rendered as the canvas' fallback content.
SetHeight | Sets the height of the view.
SetMagnifierEnabled | Sets a value indicating whether the magnifier tool is currently enabled.
SetMagnifierFactor | Sets the zoom factor of the magnifier tool.
SetMagnifierFrameColor | Sets the color of the magnifier frame.
SetMagnifierFrameThickness | Sets the thickness of the magnifier frame, expressed in pixels.
SetMagnifierHeight | Sets the height of the magnifier tool, expressed in pixels.
SetMagnifierSecondaryFrameColor | Sets the secondary color of the magnifier frame.
SetMagnifierShading | Sets a value indicating whether to enhance the effect of a magnifier lense by using a gradient shading.
SetMagnifierShape | Sets the shape of the magnifier tool.
SetMagnifierWidth | Sets the width of the magnifier tool, expressed in pixels.
SetModificationStart | Sets how users can start modifying diagram items.
SetScrollLeft | Sets the view's X scroll position.
SetScrollTop | Sets the view's Y scroll position.
SetShowScrolbars | Sets a value indicating whether the scrollbars are visible.
SetTooltipDelay | Sets the delay before a tooltip is shown.
SetVirtualScroll | Sets a value indicating whether virtual scroll mode is enabled.
SetWidth | Sets the width of the view.
SetZoomFactor | Sets the zoom of the view.
SizeChangedScript | Sets the name of a JavaScript function that should be invoked when the size of the diagram canvas has changed.
TableColumnResizedScript | Sets the name of a JavaScript function that should be invoked when the user finishes resizing a column in a table interactively.
TableColumnResizingScript | Sets the name of a JavaScript function that should be invoked when the user resizes a column in a table interactively.
TableRowResizedScript | Sets the name of a JavaScript function that should be invoked when the user finishes resizing a row in a table interactively.
TableRowResizingScript | Sets the name of a JavaScript function that should be invoked when the user resizes a row in a table interactively.
ToJson | Serializes the DiagramView's data to JSON.
TreeCollapsedScript | Sets the name of a JavaScript function that should be invoked when a user collapses a tree branch by clicking the [+] button of an Expandable node.
TreeExpandedScript | Sets the name of a JavaScript function that should be invoked when a user expands a tree branch by clicking the [+] button of an Expandable node.

See Also

DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.ClickedScript Method

DiagramView.ClickedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when the user clicks the diagram at a point where no items are located.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView ClickedScript (
string value
)

Visual Basic [image] Copy Code

Public Function ClickedScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.ClientToDoc Method

DiagramView.ClientToDoc Method
[image]

Overload List

Name | Description
DiagramView.ClientToDoc (Int32) | Converts the specified value from client to document coordinates.
DiagramView.ClientToDoc (PointF) | Converts the specified point from client to document coordinates.
DiagramView.ClientToDoc (Rectangle) | Converts the specified rectangle from client to document coordinates.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.ClientToDoc Method (Int32)

DiagramView.ClientToDoc Method (Int32)
See Also
[image]

Converts the specified value from client to document coordinates.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public float ClientToDoc (
int value
)

Visual Basic [image] Copy Code

Public Function ClientToDoc( _
value As Integer _
) As Single

Parameters

value

Return Value

See Also

ClientToDoc Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.ClientToDoc Method (PointF)

DiagramView.ClientToDoc Method (PointF)
See Also
[image]

Converts the specified point from client to document coordinates.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public PointF ClientToDoc (
PointF clientPoint
)

Visual Basic [image] Copy Code

Public Function ClientToDoc( _
clientPoint As PointF _
) As PointF

Parameters

clientPoint

Return Value

See Also

ClientToDoc Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.ClientToDoc Method (Rectangle)

DiagramView.ClientToDoc Method (Rectangle)
See Also
[image]

Converts the specified rectangle from client to document coordinates.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public RectangleF ClientToDoc (
Rectangle clientRect
)

Visual Basic [image] Copy Code

Public Function ClientToDoc( _
clientRect As Rectangle _
) As RectangleF

Parameters

clientRect

Return Value

See Also

ClientToDoc Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.ContainerChildAddedScript Method

DiagramView.ContainerChildAddedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when a child node is added to a container.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView ContainerChildAddedScript (
string value
)

Visual Basic [image] Copy Code

Public Function ContainerChildAddedScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.ContainerChildAddingScript Method

DiagramView.ContainerChildAddingScript Method
[image]

Sets the name of a JavaScript function that should be invoked before a child node is added to a container.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView ContainerChildAddingScript (
string value
)

Visual Basic [image] Copy Code

Public Function ContainerChildAddingScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.ContainerChildRemovedScript Method

DiagramView.ContainerChildRemovedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when a child node is removed from a container.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView ContainerChildRemovedScript (
string value
)

Visual Basic [image] Copy Code

Public Function ContainerChildRemovedScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.ContainerChildRemovingScript Method

DiagramView.ContainerChildRemovingScript Method
[image]

Sets the name of a JavaScript function that should be invoked before a child node is removed from a container.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView ContainerChildRemovingScript (
string value
)

Visual Basic [image] Copy Code

Public Function ContainerChildRemovingScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.ContainerFoldedScript Method

DiagramView.ContainerFoldedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when the user folds a container by clicking the arrow-up button in the container's caption area.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView ContainerFoldedScript (
string value
)

Visual Basic [image] Copy Code

Public Function ContainerFoldedScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.ContainerUnfoldedScript Method

DiagramView.ContainerUnfoldedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when the user unfolds a container by clicking the arrow-down button in the container's caption area.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView ContainerUnfoldedScript (
string value
)

Visual Basic [image] Copy Code

Public Function ContainerUnfoldedScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.ControlLoadedScript Method

DiagramView.ControlLoadedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when the control is loaded on the client side.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView ControlLoadedScript (
string value
)

Visual Basic [image] Copy Code

Public Function ControlLoadedScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.DocToClient Method

DiagramView.DocToClient Method
[image]

Transforms points from the document coordinate space to the client coordinate space.

Overload List

Name | Description
DiagramView.DocToClient (PointF) | Converts the specified point from document to client coordinates.
DiagramView.DocToClient (RectangleF) | Converts the specified rectangle from document to client coordinates.
DiagramView.DocToClient (Single) | Converts the specified value from document to client coordinates.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.DocToClient Method (PointF)

DiagramView.DocToClient Method (PointF)
See Also
[image]

Converts the specified point from document to client coordinates.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public PointF DocToClient (
PointF docPoint
)

Visual Basic [image] Copy Code

Public Function DocToClient( _
docPoint As PointF _
) As PointF

Parameters

docPoint

The PointF to convert.

Return Value

The converted point

See Also

DocToClient Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.DocToClient Method (RectangleF)

DiagramView.DocToClient Method (RectangleF)
See Also
[image]

Converts the specified rectangle from document to client coordinates.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public RectangleF DocToClient (
RectangleF docRect
)

Visual Basic [image] Copy Code

Public Function DocToClient( _
docRect As RectangleF _
) As RectangleF

Parameters

docRect

The RectangleF to convert.

Return Value

The converted rectangle

See Also

DocToClient Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.DocToClient Method (Single)

DiagramView.DocToClient Method (Single)
See Also
[image]

Converts the specified value from document to client coordinates.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public int DocToClient (
float value
)

Visual Basic [image] Copy Code

Public Function DocToClient( _
value As Single _
) As Integer

Parameters

value

Return Value

See Also

DocToClient Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.DrawAdjustmentHandlesScript Method

DiagramView.DrawAdjustmentHandlesScript Method
[image]

Sets the name of a JavaScript function that should be invoked when item’s adjustment handles must be custom drawn.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView DrawAdjustmentHandlesScript (
string value
)

Visual Basic [image] Copy Code

Public Function DrawAdjustmentHandlesScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.EnterInplaceEditScript Method

DiagramView.EnterInplaceEditScript Method
[image]

Sets the name of a JavaScript function that should be invoked when when entering inplace-edit mode.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView EnterInplaceEditScript (
string value
)

Visual Basic [image] Copy Code

Public Function EnterInplaceEditScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.FromJson Method

DiagramView.FromJson Method
[image]

Creates a DiagramView object from JSON.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static DiagramView FromJson (
string json
)

Visual Basic [image] Copy Code

Public Shared Function FromJson( _
json As String _
) As DiagramView

Parameters

json

The JSON string

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.FromRequest Method

DiagramView.FromRequest Method
[image]

Creates an instance of DiagramView.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static DiagramView FromRequest (
string id,
HttpRequestBase request
)

Visual Basic [image] Copy Code

Public Shared Function FromRequest( _
id As String, _
request As HttpRequestBase _
) As DiagramView

Parameters

id

The Id of the DiagramView

request

An HttpRequest object that contains the json data for the view.

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.HitTestAdjustmentHandlesScript Method

DiagramView.HitTestAdjustmentHandlesScript Method
[image]

Sets the name of a JavaScript function that should be invoked when custom hit testing of item’s adjustment handles must be performed.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView HitTestAdjustmentHandlesScript (
string value
)

Visual Basic [image] Copy Code

Public Function HitTestAdjustmentHandlesScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.Init Method

DiagramView.Init Method
[image]

Renders the DiagramView's initializing scripts on a web page under the specified function name.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string Init (
string functionName
)

Visual Basic [image] Copy Code

Public Function Init( _
functionName As String _
) As String

Parameters

functionName

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.InitializeLinkScript Method

DiagramView.InitializeLinkScript Method
[image]

Sets the name of a JavaScript function that should be invoked when the user starts drawing a new link, just after the DiagramLink instance is created.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView InitializeLinkScript (
string value
)

Visual Basic [image] Copy Code

Public Function InitializeLinkScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.InitializeNodeScript Method

DiagramView.InitializeNodeScript Method
[image]

Sets the name of a JavaScript function that should be invoked when the user starts drawing a new node, just after the DiagramNode instance is created.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView InitializeNodeScript (
string value
)

Visual Basic [image] Copy Code

Public Function InitializeNodeScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.LeaveInplaceEditScript Method

DiagramView.LeaveInplaceEditScript Method
[image]

Sets the name of a JavaScript function that should be invoked when when leaving inplace-edit mode.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView LeaveInplaceEditScript (
string value
)

Visual Basic [image] Copy Code

Public Function LeaveInplaceEditScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.LinkClickedScript Method

DiagramView.LinkClickedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when the users clicks a link.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView LinkClickedScript (
string value
)

Visual Basic [image] Copy Code

Public Function LinkClickedScript( _
value As String _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.LinkCreatedScript Method

DiagramView.LinkCreatedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when the user draws a new link.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView LinkCreatedScript (
string value
)

Visual Basic [image] Copy Code

Public Function LinkCreatedScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.LinkCreatingScript Method

DiagramView.LinkCreatingScript Method
[image]

Sets the name of a JavaScript function that should be invoked while the user is drawing a new link.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView LinkCreatingScript (
string value
)

Visual Basic [image] Copy Code

Public Function LinkCreatingScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.LinkDeletedScript Method

DiagramView.LinkDeletedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when a link is deleted, either programmatically or by the user.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView LinkDeletedScript (
string value
)

Visual Basic [image] Copy Code

Public Function LinkDeletedScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.LinkDeletingScript Method

DiagramView.LinkDeletingScript Method
[image]

Sets the name of a JavaScript function that should be invoked when the user tries to delete a link.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView LinkDeletingScript (
string value
)

Visual Basic [image] Copy Code

Public Function LinkDeletingScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.LinkDeselectedScript Method

DiagramView.LinkDeselectedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when a link is deselected, either programmatically or by the user.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView LinkDeselectedScript (
string value
)

Visual Basic [image] Copy Code

Public Function LinkDeselectedScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.LinkDoubleClickedScript Method

DiagramView.LinkDoubleClickedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when the users double-clicks a link.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView LinkDoubleClickedScript (
string value
)

Visual Basic [image] Copy Code

Public Function LinkDoubleClickedScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.LinkModifiedScript Method

DiagramView.LinkModifiedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when the user moves any control point of a link.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView LinkModifiedScript (
string value
)

Visual Basic [image] Copy Code

Public Function LinkModifiedScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.LinkModifyingScript Method

DiagramView.LinkModifyingScript Method
[image]

Sets the name of a JavaScript function that should be invoked while the user is modifying a link.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView LinkModifyingScript (
string value
)

Visual Basic [image] Copy Code

Public Function LinkModifyingScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.LinkSelectedScript Method

DiagramView.LinkSelectedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when a link is selected, either programmatically or by the user.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView LinkSelectedScript (
string value
)

Visual Basic [image] Copy Code

Public Function LinkSelectedScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.LinkTextEditedScript Method

DiagramView.LinkTextEditedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when the user edits the text of a link.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView LinkTextEditedScript (
string value
)

Visual Basic [image] Copy Code

Public Function LinkTextEditedScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.LoadFromJson Method

DiagramView.LoadFromJson Method
[image]

Loads the specified JSON data.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public void LoadFromJson (
string json
)

Visual Basic [image] Copy Code

Public Sub LoadFromJson( _
json As String _
)

Parameters

json

The JSON string

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.NodeClickedScript Method

DiagramView.NodeClickedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when the users clicks a node.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView NodeClickedScript (
string value
)

Visual Basic [image] Copy Code

Public Function NodeClickedScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.NodeCreatedScript Method

DiagramView.NodeCreatedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when the user draws a new node.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView NodeCreatedScript (
string value
)

Visual Basic [image] Copy Code

Public Function NodeCreatedScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.NodeCreatingScript Method

DiagramView.NodeCreatingScript Method
[image]

Sets the name of a JavaScript function that should be invoked while the user is drawing a new node.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView NodeCreatingScript (
string value
)

Visual Basic [image] Copy Code

Public Function NodeCreatingScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.NodeDeletedScript Method

DiagramView.NodeDeletedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when a node is deleted, either programmatically or by the user.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView NodeDeletedScript (
string value
)

Visual Basic [image] Copy Code

Public Function NodeDeletedScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.NodeDeletingScript Method

DiagramView.NodeDeletingScript Method
[image]

Sets the name of a JavaScript function that should be invoked when the user tries to delete a node.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView NodeDeletingScript (
string value
)

Visual Basic [image] Copy Code

Public Function NodeDeletingScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.NodeDeselectedScript Method

DiagramView.NodeDeselectedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when a node is deselected, either programmatically or by the user.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView NodeDeselectedScript (
string value
)

Visual Basic [image] Copy Code

Public Function NodeDeselectedScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.NodeDoubleClickedScript Method

DiagramView.NodeDoubleClickedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when the users double-clicks a node.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView NodeDoubleClickedScript (
string value
)

Visual Basic [image] Copy Code

Public Function NodeDoubleClickedScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.NodeModifiedScript Method

DiagramView.NodeModifiedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when the user moves or resizes a node.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView NodeModifiedScript (
string value
)

Visual Basic [image] Copy Code

Public Function NodeModifiedScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.NodeModifyingScript Method

DiagramView.NodeModifyingScript Method
[image]

Sets the name of a JavaScript function that should be invoked while the user is moving or resizing a node.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView NodeModifyingScript (
string value
)

Visual Basic [image] Copy Code

Public Function NodeModifyingScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.NodeSelectedScript Method

DiagramView.NodeSelectedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when a node is selected, either programmatically or by the user.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView NodeSelectedScript (
string value
)

Visual Basic [image] Copy Code

Public Function NodeSelectedScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.NodeTextEditedScript Method

DiagramView.NodeTextEditedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when the user edits the text of a node.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView NodeTextEditedScript (
string value
)

Visual Basic [image] Copy Code

Public Function NodeTextEditedScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.RegisterConverters Method

DiagramView.RegisterConverters Method
[image]

Registers custom converters used for custom item types serialization.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView RegisterConverters (
JavaScriptConverter[] converters
)

Visual Basic [image] Copy Code

Public Function RegisterConverters( _
converters() As JavaScriptConverter _
) As DiagramView

Parameters

converters

The converters to register.

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.RegisterItemType Method

DiagramView.RegisterItemType Method
[image]

Registers a custom item class for serialization support.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView RegisterItemType (
Type itemClass,
string classId,
string clientClassId,
int classVersion
)

Visual Basic [image] Copy Code

Public Function RegisterItemType( _
itemClass As Type, _
classId As String, _
clientClassId As String, _
classVersion As Integer _
) As DiagramView

Parameters

itemClass

A Type instance identifying the item class.

classId

A class identifier to use when serializing, saving and loading items of the specified type.

clientClassId

A class identifier to use when serializing items of the specified type on the client side.

classVersion

A revision number of the item's class serialization format.

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.Render Method

DiagramView.Render Method
[image]

Renders the DiagramView on a web page.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string Render ()

Visual Basic [image] Copy Code

Public Function Render () As String

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.RepaintScript Method

DiagramView.RepaintScript Method
[image]

Sets the name of a JavaScript function that should be invoked when the diagram has been repainted.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView RepaintScript (
string value
)

Visual Basic [image] Copy Code

Public Function RepaintScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SaveToJson Method

DiagramView.SaveToJson Method
[image]

Serializes the DiagramView's data to JSON.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string SaveToJson ()

Visual Basic [image] Copy Code

Public Function SaveToJson () As String

Return Value

The JSON string.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SelectionModifyingScript Method

DiagramView.SelectionModifyingScript Method
[image]

Sets the name of a JavaScript function that should be invoked while the user is moving or resizing multiple items.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SelectionModifyingScript (
string value
)

Visual Basic [image] Copy Code

Public Function SelectionModifyingScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetAddScriptReferences Method

DiagramView.SetAddScriptReferences Method
[image]

Sets a value indicating whether the control should render references to the client scripts.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetAddScriptReferences (
bool value
)

Visual Basic [image] Copy Code

Public Function SetAddScriptReferences( _
value As Boolean _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetAllowInplaceEdit Method

DiagramView.SetAllowInplaceEdit Method
[image]

Sets a value indicating whether in-place editing of the text of objects is enabled.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetAllowInplaceEdit (
bool value
)

Visual Basic [image] Copy Code

Public Function SetAllowInplaceEdit( _
value As Boolean _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetAutoScroll Method

DiagramView.SetAutoScroll Method
[image]

Sets a value indicating whether auto scrolling of the document area is enabled.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetAutoScroll (
bool value
)

Visual Basic [image] Copy Code

Public Function SetAutoScroll( _
value As Boolean _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetBehavior Method

DiagramView.SetBehavior Method
[image]

Sets a value indicating how the control responds to user actions.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetBehavior (
Behavior value
)

Visual Basic [image] Copy Code

Public Function SetBehavior( _
value As Behavior _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetClientSideMode Method

DiagramView.SetClientSideMode Method
[image]

Sets a value indicating which library will be used in the control's client-side scripts.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetClientSideMode (
ClientSideMode value
)

Visual Basic [image] Copy Code

Public Function SetClientSideMode( _
value As ClientSideMode _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetCustomLinkType Method

DiagramView.SetCustomLinkType Method
[image]

Sets the type of a MindFusion.Diagramming.DiagramLink derived class whose instance should be created when a user starts drawing.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetCustomLinkType (
Type value
)

Visual Basic [image] Copy Code

Public Function SetCustomLinkType( _
value As Type _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetCustomNodeType Method

DiagramView.SetCustomNodeType Method
[image]

Sets the type of a MindFusion.Diagramming.DiagramNode derived class whose instance should be created when a user starts drawing.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetCustomNodeType (
Type value
)

Visual Basic [image] Copy Code

Public Function SetCustomNodeType( _
value As Type _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetDelKeyAction Method

DiagramView.SetDelKeyAction Method
[image]

Sets a value indicating the action that should be performed when the user hits the Del key.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetDelKeyAction (
DelKeyAction value
)

Visual Basic [image] Copy Code

Public Function SetDelKeyAction( _
value As DelKeyAction _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetEnabled Method

DiagramView.SetEnabled Method
[image]

Sets a value indicating whether handling of mouse events is enabled.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetEnabled (
bool value
)

Visual Basic [image] Copy Code

Public Function SetEnabled( _
value As Boolean _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetFallbackContent Method

DiagramView.SetFallbackContent Method
[image]

Sets the HTML to be rendered as the canvas' fallback content.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetFallbackContent (
string value
)

Visual Basic [image] Copy Code

Public Function SetFallbackContent( _
value As String _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetHeight Method

DiagramView.SetHeight Method
[image]

Sets the height of the view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetHeight (
int value
)

Visual Basic [image] Copy Code

Public Function SetHeight( _
value As Integer _
) As DiagramView

Parameters

value

The height of the view in pixels.

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetMagnifierEnabled Method

DiagramView.SetMagnifierEnabled Method
[image]

Sets a value indicating whether the magnifier tool is currently enabled.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetMagnifierEnabled (
bool value
)

Visual Basic [image] Copy Code

Public Function SetMagnifierEnabled( _
value As Boolean _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetMagnifierFactor Method

DiagramView.SetMagnifierFactor Method
[image]

Sets the zoom factor of the magnifier tool.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetMagnifierFactor (
float value
)

Visual Basic [image] Copy Code

Public Function SetMagnifierFactor( _
value As Single _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetMagnifierFrameColor Method

DiagramView.SetMagnifierFrameColor Method
[image]

Sets the color of the magnifier frame.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetMagnifierFrameColor (
Color value
)

Visual Basic [image] Copy Code

Public Function SetMagnifierFrameColor( _
value As Color _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetMagnifierFrameThickness Method

DiagramView.SetMagnifierFrameThickness Method
[image]

Sets the thickness of the magnifier frame, expressed in pixels.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetMagnifierFrameThickness (
int value
)

Visual Basic [image] Copy Code

Public Function SetMagnifierFrameThickness( _
value As Integer _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetMagnifierHeight Method

DiagramView.SetMagnifierHeight Method
[image]

Sets the height of the magnifier tool, expressed in pixels.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetMagnifierHeight (
int value
)

Visual Basic [image] Copy Code

Public Function SetMagnifierHeight( _
value As Integer _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetMagnifierSecondaryFrameColor Method

DiagramView.SetMagnifierSecondaryFrameColor Method
[image]

Sets the secondary color of the magnifier frame.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetMagnifierSecondaryFrameColor (
Color value
)

Visual Basic [image] Copy Code

Public Function SetMagnifierSecondaryFrameColor( _
value As Color _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetMagnifierShading Method

DiagramView.SetMagnifierShading Method
[image]

Sets a value indicating whether to enhance the effect of a magnifier lense by using a gradient shading.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetMagnifierShading (
bool value
)

Visual Basic [image] Copy Code

Public Function SetMagnifierShading( _
value As Boolean _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetMagnifierShape Method

DiagramView.SetMagnifierShape Method
[image]

Sets the shape of the magnifier tool.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetMagnifierShape (
Shape value
)

Visual Basic [image] Copy Code

Public Function SetMagnifierShape( _
value As Shape _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetMagnifierWidth Method

DiagramView.SetMagnifierWidth Method
[image]

Sets the width of the magnifier tool, expressed in pixels.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetMagnifierWidth (
int value
)

Visual Basic [image] Copy Code

Public Function SetMagnifierWidth( _
value As Integer _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetModificationStart Method

DiagramView.SetModificationStart Method
[image]

Sets how users can start modifying diagram items.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetModificationStart (
ModificationStart value
)

Visual Basic [image] Copy Code

Public Function SetModificationStart( _
value As ModificationStart _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetScrollLeft Method

DiagramView.SetScrollLeft Method
[image]

Sets the view's X scroll position.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetScrollLeft (
float value
)

Visual Basic [image] Copy Code

Public Function SetScrollLeft( _
value As Single _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetScrollTop Method

DiagramView.SetScrollTop Method
[image]

Sets the view's Y scroll position.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetScrollTop (
float value
)

Visual Basic [image] Copy Code

Public Function SetScrollTop( _
value As Single _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetShowScrolbars Method

DiagramView.SetShowScrolbars Method
[image]

Sets a value indicating whether the scrollbars are visible.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetShowScrolbars (
bool value
)

Visual Basic [image] Copy Code

Public Function SetShowScrolbars( _
value As Boolean _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetTooltipDelay Method

DiagramView.SetTooltipDelay Method
[image]

Sets the delay before a tooltip is shown.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetTooltipDelay (
int value
)

Visual Basic [image] Copy Code

Public Function SetTooltipDelay( _
value As Integer _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetVirtualScroll Method

DiagramView.SetVirtualScroll Method
[image]

Sets a value indicating whether virtual scroll mode is enabled.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetVirtualScroll (
bool value
)

Visual Basic [image] Copy Code

Public Function SetVirtualScroll( _
value As Boolean _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetWidth Method

DiagramView.SetWidth Method
[image]

Sets the width of the view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetWidth (
int value
)

Visual Basic [image] Copy Code

Public Function SetWidth( _
value As Integer _
) As DiagramView

Parameters

value

The width of the view in pixels.

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SetZoomFactor Method

DiagramView.SetZoomFactor Method
[image]

Sets the zoom of the view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SetZoomFactor (
float value
)

Visual Basic [image] Copy Code

Public Function SetZoomFactor( _
value As Single _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.SizeChangedScript Method

DiagramView.SizeChangedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when the size of the diagram canvas has changed.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView SizeChangedScript (
string value
)

Visual Basic [image] Copy Code

Public Function SizeChangedScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.TableColumnResizedScript Method

DiagramView.TableColumnResizedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when the user finishes resizing a column in a table interactively.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView TableColumnResizedScript (
string value
)

Visual Basic [image] Copy Code

Public Function TableColumnResizedScript( _
value As String _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.TableColumnResizingScript Method

DiagramView.TableColumnResizingScript Method
[image]

Sets the name of a JavaScript function that should be invoked when the user resizes a column in a table interactively.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView TableColumnResizingScript (
string value
)

Visual Basic [image] Copy Code

Public Function TableColumnResizingScript( _
value As String _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.TableRowResizedScript Method

DiagramView.TableRowResizedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when the user finishes resizing a row in a table interactively.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView TableRowResizedScript (
string value
)

Visual Basic [image] Copy Code

Public Function TableRowResizedScript( _
value As String _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.TableRowResizingScript Method

DiagramView.TableRowResizingScript Method
[image]

Sets the name of a JavaScript function that should be invoked when the user resizes a row in a table interactively.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView TableRowResizingScript (
string value
)

Visual Basic [image] Copy Code

Public Function TableRowResizingScript( _
value As String _
) As DiagramView

Parameters

value

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.ToJson Method

DiagramView.ToJson Method
[image]

Serializes the DiagramView's data to JSON.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static string ToJson (
DiagramView view
)

Visual Basic [image] Copy Code

Public Shared Function ToJson( _
view As DiagramView _
) As String

Parameters

view

An instance of the DiagramView class.

Return Value

The JSON string.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.TreeCollapsedScript Method

DiagramView.TreeCollapsedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when a user collapses a tree branch by clicking the [+] button of an Expandable node.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView TreeCollapsedScript (
string value
)

Visual Basic [image] Copy Code

Public Function TreeCollapsedScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.TreeExpandedScript Method

DiagramView.TreeExpandedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when a user expands a tree branch by clicking the [+] button of an Expandable node.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramView TreeExpandedScript (
string value
)

Visual Basic [image] Copy Code

Public Function TreeExpandedScript( _
value As String _
) As DiagramView

Parameters

value

The name of the function

Return Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView Properties

DiagramView Properties
[image]

Public Properties

Name | Description
AddScriptReferences | Gets or sets a value indicating whether the control should render references to the client scripts.
AllowInplaceEdit | Gets or sets a value indicating whether in-place editing of the text of objects is enabled.
AutoScroll | Gets or sets a value indicating whether auto scrolling of the document area is enabled.
Behavior | Gets or sets a value indicating how the control responds to user actions.
ClientScriptLocation | Gets or sets the URL to the MindFusion.Diagramming.js file.
ClientSideMode | Gets or sets a value indicating which library will be used in the control's client-side scripts.
Converters | Gets the registered custom converters.
CustomLinkType | Gets the type of a MindFusion.Diagramming.DiagramLink derived class whose instance should be created when a user starts drawing.
CustomNodeType | Gets the type of a MindFusion.Diagramming.DiagramNode derived class whose instance should be created when a user starts drawing.
DelKeyAction | Gets or sets a value indicating the action that should be performed when the user hits the DELETE key.
Diagram | Gets or sets the Diagram object displayed by this view.
Enabled | Gets or sets a value indicating whether handling of mouse events is enabled.
FallbackContent | Gets or sets the HTML to be rendered as the canvas' fallback content.
Height | Gets or sets the height of the view.
Id | Gets or sets the id of the view.
ItemTypes | Gets the registered item types.
JQueryLocation | Gets or sets the URL to the JQuery script file.
LicenseKey | Gets or sets the license key of the control.
MagnifierEnabled | Gets or sets a value indicating whether the magnifier tool is currently enabled.
MagnifierFactor | Gets or sets the zoom factor of the magnifier tool.
MagnifierFrameColor | Gets or sets the color of the magnifier frame.
MagnifierFrameThickness | Gets or sets the thickness of the magnifier frame, expressed in pixels.
MagnifierHeight | Gets or sets the height of the magnifier tool, expressed in pixels.
MagnifierSecondaryFrameColor | Gets or sets the secondary color of the magnifier frame.
MagnifierShading | Gets or sets a value indicating whether to enhance the effect of a magnifier lense by using a gradient shading.
MagnifierShape | Gets or sets the shape of the magnifier tool.
MagnifierWidth | Gets or sets the width of the magnifier tool, expressed in pixels.
ModificationStart | Gets or sets how users can start modifying diagram items.
ScrollLeft | Gets or sets the view's X scroll position.
ScrollTop | Gets or sets the view's Y scroll position.
ShapeLibraryLocation | The location of a shape library file containing custom shape definitions. It can be set to a full URL of the file, or a relative file path.
ShowScrollbars | Gets or sets a value indicating whether scrollbars should be displayed.
TooltipDelay | Gets or sets the delay before a tooltip is shown.
VirtualScroll | Gets or sets a value indicating whether virtual scroll mode is enabled.
Width | Gets or sets the width of the view.
ZoomFactor | Gets or sets the zoom of the view.

See Also

DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.AddScriptReferences Property

DiagramView.AddScriptReferences Property
[image]

Gets or sets a value indicating whether the control should render references to the client scripts.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public bool AddScriptReferences { get; set; }

Visual Basic [image] Copy Code

Public Property AddScriptReferences As Boolean

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.AllowInplaceEdit Property

DiagramView.AllowInplaceEdit Property
[image]

Gets or sets a value indicating whether in-place editing of the text of objects is enabled.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public bool AllowInplaceEdit { get; set; }

Visual Basic [image] Copy Code

Public Property AllowInplaceEdit As Boolean

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.AutoScroll Property

DiagramView.AutoScroll Property
[image]

Gets or sets a value indicating whether auto scrolling of the document area is enabled.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public bool AutoScroll { get; set; }

Visual Basic [image] Copy Code

Public Property AutoScroll As Boolean

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.Behavior Property

DiagramView.Behavior Property
[image]

Gets or sets a value indicating how the control responds to user actions.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Behavior Behavior { get; set; }

Visual Basic [image] Copy Code

Public Property Behavior As Behavior

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.ClientScriptLocation Property

DiagramView.ClientScriptLocation Property
[image]

Gets or sets the URL to the MindFusion.Diagramming.js file.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string ClientScriptLocation { get; set; }

Visual Basic [image] Copy Code

Public Property ClientScriptLocation As String

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.ClientSideMode Property

DiagramView.ClientSideMode Property
[image]

Gets or sets a value indicating which library will be used in the control's client-side scripts.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ClientSideMode ClientSideMode { get; set; }

Visual Basic [image] Copy Code

Public Property ClientSideMode As ClientSideMode

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.Converters Property

DiagramView.Converters Property
[image]

Gets the registered custom converters.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public JavaScriptConverter[] Converters { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Converters As JavaScriptConverter()

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.CustomLinkType Property

DiagramView.CustomLinkType Property
[image]

Gets the type of a MindFusion.Diagramming.DiagramLink derived class whose instance should be created when a user starts drawing.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Type CustomLinkType { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CustomLinkType As Type

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.CustomNodeType Property

DiagramView.CustomNodeType Property
[image]

Gets the type of a MindFusion.Diagramming.DiagramNode derived class whose instance should be created when a user starts drawing.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Type CustomNodeType { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CustomNodeType As Type

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.DelKeyAction Property

DiagramView.DelKeyAction Property
[image]

Gets or sets a value indicating the action that should be performed when the user hits the DELETE key.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DelKeyAction DelKeyAction { get; set; }

Visual Basic [image] Copy Code

Public Property DelKeyAction As DelKeyAction

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.Diagram Property

DiagramView.Diagram Property
[image]

Gets or sets the Diagram object displayed by this view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Diagram Diagram { get; set; }

Visual Basic [image] Copy Code

Public Property Diagram As Diagram

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.Enabled Property

DiagramView.Enabled Property
[image]

Gets or sets a value indicating whether handling of mouse events is enabled.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public bool Enabled { get; set; }

Visual Basic [image] Copy Code

Public Property Enabled As Boolean

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.FallbackContent Property

DiagramView.FallbackContent Property
[image]

Gets or sets the HTML to be rendered as the canvas' fallback content.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string FallbackContent { get; set; }

Visual Basic [image] Copy Code

Public Property FallbackContent As String

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.Height Property

DiagramView.Height Property
[image]

Gets or sets the height of the view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public int Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Integer

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.Id Property

DiagramView.Id Property
[image]

Gets or sets the id of the view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string Id { get; set; }

Visual Basic [image] Copy Code

Public Property Id As String

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.ItemTypes Property

DiagramView.ItemTypes Property
[image]

Gets the registered item types.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Dictionary<Type, string> ItemTypes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ItemTypes As Dictionary(Of Type, String)

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.JQueryLocation Property

DiagramView.JQueryLocation Property
[image]

Gets or sets the URL to the JQuery script file.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string JQueryLocation { get; set; }

Visual Basic [image] Copy Code

Public Property JQueryLocation As String

Property Value

Remarks

This property is used only if ClientSideMode is set to ClientSideMode.JQuery.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.LicenseKey Property

DiagramView.LicenseKey Property
[image]

Gets or sets the license key of the control.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string LicenseKey { get; set; }

Visual Basic [image] Copy Code

Public Property LicenseKey As String

Property Value

A string containing the license key.

Remarks

Set this property to disable the component's evaluation mode and stop displaying trial messages. If your application contains more than one Diagram instance or other controls by MindFusion, you could call the MindFusion.Licensing.LicenseManager.AddLicense method to specify the key once instead of setting it per each control.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.MagnifierEnabled Property

DiagramView.MagnifierEnabled Property
[image]

Gets or sets a value indicating whether the magnifier tool is currently enabled.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public bool MagnifierEnabled { get; set; }

Visual Basic [image] Copy Code

Public Property MagnifierEnabled As Boolean

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.MagnifierFactor Property

DiagramView.MagnifierFactor Property
[image]

Gets or sets the zoom factor of the magnifier tool.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public float MagnifierFactor { get; set; }

Visual Basic [image] Copy Code

Public Property MagnifierFactor As Single

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.MagnifierFrameColor Property

DiagramView.MagnifierFrameColor Property
[image]

Gets or sets the color of the magnifier frame.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Color MagnifierFrameColor { get; set; }

Visual Basic [image] Copy Code

Public Property MagnifierFrameColor As Color

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.MagnifierFrameThickness Property

DiagramView.MagnifierFrameThickness Property
[image]

Gets or sets the thickness of the magnifier frame, expressed in pixels.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public int MagnifierFrameThickness { get; set; }

Visual Basic [image] Copy Code

Public Property MagnifierFrameThickness As Integer

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.MagnifierHeight Property

DiagramView.MagnifierHeight Property
[image]

Gets or sets the height of the magnifier tool, expressed in pixels.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public int MagnifierHeight { get; set; }

Visual Basic [image] Copy Code

Public Property MagnifierHeight As Integer

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.MagnifierSecondaryFrameColor Property

DiagramView.MagnifierSecondaryFrameColor Property
[image]

Gets or sets the secondary color of the magnifier frame.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Color MagnifierSecondaryFrameColor { get; set; }

Visual Basic [image] Copy Code

Public Property MagnifierSecondaryFrameColor As Color

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.MagnifierShading Property

DiagramView.MagnifierShading Property
[image]

Gets or sets a value indicating whether to enhance the effect of a magnifier lense by using a gradient shading.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public bool MagnifierShading { get; set; }

Visual Basic [image] Copy Code

Public Property MagnifierShading As Boolean

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.MagnifierShape Property

DiagramView.MagnifierShape Property
[image]

Gets or sets the shape of the magnifier tool.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Shape MagnifierShape { get; set; }

Visual Basic [image] Copy Code

Public Property MagnifierShape As Shape

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.MagnifierWidth Property

DiagramView.MagnifierWidth Property
[image]

Gets or sets the width of the magnifier tool, expressed in pixels.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public int MagnifierWidth { get; set; }

Visual Basic [image] Copy Code

Public Property MagnifierWidth As Integer

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.ModificationStart Property

DiagramView.ModificationStart Property
[image]

Gets or sets how users can start modifying diagram items.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ModificationStart ModificationStart { get; set; }

Visual Basic [image] Copy Code

Public Property ModificationStart As ModificationStart

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.ScrollLeft Property

DiagramView.ScrollLeft Property
[image]

Gets or sets the view's X scroll position.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public float ScrollLeft { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollLeft As Single

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.ScrollTop Property

DiagramView.ScrollTop Property
[image]

Gets or sets the view's Y scroll position.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public float ScrollTop { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollTop As Single

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.ShapeLibraryLocation Property

DiagramView.ShapeLibraryLocation Property
[image]

The location of a shape library file containing custom shape definitions. It can be set to a full URL of the file, or a relative file path.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string ShapeLibraryLocation { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeLibraryLocation As String

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.ShowScrollbars Property

DiagramView.ShowScrollbars Property
[image]

Gets or sets a value indicating whether scrollbars should be displayed.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public bool ShowScrollbars { get; set; }

Visual Basic [image] Copy Code

Public Property ShowScrollbars As Boolean

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.TooltipDelay Property

DiagramView.TooltipDelay Property
[image]

Gets or sets the delay before a tooltip is shown.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public int TooltipDelay { get; set; }

Visual Basic [image] Copy Code

Public Property TooltipDelay As Integer

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.VirtualScroll Property

DiagramView.VirtualScroll Property
[image]

Gets or sets a value indicating whether virtual scroll mode is enabled.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public bool VirtualScroll { get; set; }

Visual Basic [image] Copy Code

Public Property VirtualScroll As Boolean

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.Width Property

DiagramView.Width Property
[image]

Gets or sets the width of the view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public int Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Integer

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramView.ZoomFactor Property

DiagramView.ZoomFactor Property
[image]

Gets or sets the zoom of the view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public float ZoomFactor { get; set; }

Visual Basic [image] Copy Code

Public Property ZoomFactor As Single

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramViewConverter Class

DiagramViewConverter Class
[image]

Serializes DiagramView instances.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public class DiagramViewConverter : JavaScriptConverter

Visual Basic [image] Copy Code

Public Class DiagramViewConverter
Inherits JavaScriptConverter

Inheritance Hierarchy

System.Object
System.Web.Script.Serialization.JavaScriptConverter
MindFusion.Diagramming.Mvc.DiagramViewConverter

See Also

DiagramViewConverter Members
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramViewConverter Members

DiagramViewConverter Members
Constructors Properties Methods
[image]

Serializes DiagramView instances.

The following tables list the members exposed by the DiagramViewConverter type.

Public Constructors

Name | Description
DiagramViewConverter |

Public Properties

Name | Description
SupportedTypes | SupportedTypes override.

Public Methods

Name | Description
Deserialize | Deserialize override.
Serialize | Serialize override.

See Also

DiagramViewConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramViewConverter Constructor

DiagramViewConverter Constructor
[image]

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramViewConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramViewConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramViewConverter Methods

DiagramViewConverter Methods
[image]

Public Methods

Name | Description
Deserialize | Deserialize override.
Serialize | Serialize override.

See Also

DiagramViewConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramViewConverter.Deserialize Method

DiagramViewConverter.Deserialize Method
[image]

Deserialize override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override Object Deserialize (
IDictionary<string, Object> dictionary,
Type type,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Deserialize( _
dictionary As IDictionary(Of String, Object), _
type As Type, _
serializer As JavaScriptSerializer _
) As Object

Parameters

dictionary

type

serializer

Return Value

See Also

DiagramViewConverter Members
DiagramViewConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramViewConverter.Serialize Method

DiagramViewConverter.Serialize Method
[image]

Serialize override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override IDictionary<string, Object> Serialize (
Object obj,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Serialize( _
obj As Object, _
serializer As JavaScriptSerializer _
) As IDictionary(Of String, Object)

Parameters

obj

serializer

Return Value

See Also

DiagramViewConverter Members
DiagramViewConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramViewConverter Properties

DiagramViewConverter Properties
[image]

Public Properties

Name | Description
SupportedTypes | SupportedTypes override.

See Also

DiagramViewConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramViewConverter.SupportedTypes Property

DiagramViewConverter.SupportedTypes Property
[image]

SupportedTypes override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override IEnumerable<Type> SupportedTypes { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property SupportedTypes As IEnumerable(Of Type)

Property Value

See Also

DiagramViewConverter Members
DiagramViewConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramViewExtensions Class

DiagramViewExtensions Class
[image]

Contains extension methods of DiagramView.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public sealed class DiagramViewExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class DiagramViewExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Mvc.DiagramViewExtensions

See Also

DiagramViewExtensions Members
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramViewExtensions Members

DiagramViewExtensions Members
Methods
[image]

Contains extension methods of DiagramView.

The following tables list the members exposed by the DiagramViewExtensions type.

Public Methods

Name | Description
DiagramView | Overloaded. Returns a DiagramView by using the specified HTML helper.

See Also

DiagramViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramViewExtensions Methods

DiagramViewExtensions Methods
[image]

Public Methods

Name | Description
DiagramView | Overloaded. Returns a DiagramView by using the specified HTML helper.

See Also

DiagramViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramViewExtensions.DiagramView Method

DiagramViewExtensions.DiagramView Method
[image]

Returns a DiagramView by using the specified HTML helper.

Overload List

Name | Description
DiagramViewExtensions.DiagramView (HtmlHelper, DiagramView) | Returns a DiagramView by using the specified HTML helper.
DiagramViewExtensions.DiagramView (HtmlHelper, DiagramView, IDictionary(String, Object)) | Returns a DiagramView by using the specified HTML helper.
DiagramViewExtensions.DiagramView (HtmlHelper, DiagramView, Object) | Returns a DiagramView by using the specified HTML helper.
DiagramViewExtensions.DiagramView (HtmlHelper, DiagramView, String) | Returns a DiagramView by using the specified HTML helper.
DiagramViewExtensions.DiagramView (HtmlHelper, DiagramView, String, IDictionary(String, Object)) | Returns a DiagramView by using the specified HTML helper.
DiagramViewExtensions.DiagramView (HtmlHelper, DiagramView, String, Object) | Returns a DiagramView by using the specified HTML helper.
DiagramViewExtensions.DiagramView (HtmlHelper, String, Diagram) | Returns a DiagramView by using the specified HTML helper.
DiagramViewExtensions.DiagramView (HtmlHelper, String, Diagram, IDictionary(String, Object)) | Returns a DiagramView by using the specified HTML helper.
DiagramViewExtensions.DiagramView (HtmlHelper, String, Diagram, Object) | Returns a DiagramView by using the specified HTML helper.
DiagramViewExtensions.DiagramView (HtmlHelper, String, Diagram, String) | Returns a DiagramView by using the specified HTML helper.
DiagramViewExtensions.DiagramView (HtmlHelper, String, Diagram, String, IDictionary(String, Object)) | Returns a DiagramView by using the specified HTML helper.
DiagramViewExtensions.DiagramView (HtmlHelper, String, Diagram, String, Object) | Returns a DiagramView by using the specified HTML helper.

See Also

DiagramViewExtensions Members
DiagramViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramViewExtensions.DiagramView Method (HtmlHelper, DiagramView)

DiagramViewExtensions.DiagramView Method (HtmlHelper, DiagramView)
See Also
[image]

Returns a DiagramView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString DiagramView (
HtmlHelper helper,
DiagramView diagramView
)

Visual Basic [image] Copy Code

Public Shared Function DiagramView( _
helper As HtmlHelper, _
diagramView As DiagramView _
) As MvcHtmlString

Parameters

helper

The HTML helper

diagramView

The DiagramView.

Return Value

See Also

DiagramView Method Overload List
DiagramViewExtensions Members
DiagramViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramViewExtensions.DiagramView Method (HtmlHelper, DiagramView, IDictionary(String, Object))

DiagramViewExtensions.DiagramView Method (HtmlHelper, DiagramView, IDictionary(String, Object))
See Also
[image]

Returns a DiagramView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString DiagramView (
HtmlHelper helper,
DiagramView diagramView,
IDictionary<string, Object> htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function DiagramView( _
helper As HtmlHelper, _
diagramView As DiagramView, _
htmlAttributes As IDictionary(Of String, Object) _
) As MvcHtmlString

Parameters

helper

The HTML helper

diagramView

The DiagramView

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

Remarks

Use the htmlAttributes parameter to pass style data to the control's outer div element. The following example sets the control's width and height properties and hides the scrollbars.

Example

HTML [image] Copy Code

@Html.DiagramView(
((DiagramView)ViewBag.DiagramView),
new { style = "width:500px;height:500px;overflow:hidden;"})

See Also

DiagramView Method Overload List
DiagramViewExtensions Members
DiagramViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramViewExtensions.DiagramView Method (HtmlHelper, DiagramView, Object)

DiagramViewExtensions.DiagramView Method (HtmlHelper, DiagramView, Object)
See Also
[image]

Returns a DiagramView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString DiagramView (
HtmlHelper helper,
DiagramView diagramView,
Object htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function DiagramView( _
helper As HtmlHelper, _
diagramView As DiagramView, _
htmlAttributes As Object _
) As MvcHtmlString

Parameters

helper

The HTML helper

diagramView

The DiagramView

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

Remarks

Use the htmlAttributes parameter to pass style data to the control's outer div element. The following example sets the control's width and height properties and hides the scrollbars.

Example

HTML [image] Copy Code

@Html.DiagramView(
((DiagramView)ViewBag.DiagramView),
new { style = "width:500px;height:500px;overflow:hidden;"})

See Also

DiagramView Method Overload List
DiagramViewExtensions Members
DiagramViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramViewExtensions.DiagramView Method (HtmlHelper, DiagramView, String)

DiagramViewExtensions.DiagramView Method (HtmlHelper, DiagramView, String)
See Also
[image]

Returns a DiagramView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString DiagramView (
HtmlHelper helper,
DiagramView diagramView,
string initFunction
)

Visual Basic [image] Copy Code

Public Shared Function DiagramView( _
helper As HtmlHelper, _
diagramView As DiagramView, _
initFunction As String _
) As MvcHtmlString

Parameters

helper

The HTML helper

diagramView

The DiagramView

initFunction

The name of the function that will contain the initializing scripts for the view.

Return Value

See Also

DiagramView Method Overload List
DiagramViewExtensions Members
DiagramViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramViewExtensions.DiagramView Method (HtmlHelper, DiagramView, String, IDictionary(String, Object))

DiagramViewExtensions.DiagramView Method (HtmlHelper, DiagramView, String, IDictionary(String, Object))
See Also
[image]

Returns a DiagramView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString DiagramView (
HtmlHelper helper,
DiagramView diagramView,
string initFunction,
IDictionary<string, Object> htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function DiagramView( _
helper As HtmlHelper, _
diagramView As DiagramView, _
initFunction As String, _
htmlAttributes As IDictionary(Of String, Object) _
) As MvcHtmlString

Parameters

helper

The HTML helper

diagramView

The DiagramView

initFunction

The name of the function that will contain the initializing scripts for the view.

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

DiagramView Method Overload List
DiagramViewExtensions Members
DiagramViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramViewExtensions.DiagramView Method (HtmlHelper, DiagramView, String, Object)

DiagramViewExtensions.DiagramView Method (HtmlHelper, DiagramView, String, Object)
See Also
[image]

Returns a DiagramView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString DiagramView (
HtmlHelper helper,
DiagramView diagramView,
string initFunction,
Object htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function DiagramView( _
helper As HtmlHelper, _
diagramView As DiagramView, _
initFunction As String, _
htmlAttributes As Object _
) As MvcHtmlString

Parameters

helper

The HTML helper

diagramView

The DiagramView

initFunction

The name of the function that will contain the initializing scripts for the view.

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

DiagramView Method Overload List
DiagramViewExtensions Members
DiagramViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramViewExtensions.DiagramView Method (HtmlHelper, String, Diagram)

DiagramViewExtensions.DiagramView Method (HtmlHelper, String, Diagram)
See Also
[image]

Returns a DiagramView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString DiagramView (
HtmlHelper helper,
string id,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Shared Function DiagramView( _
helper As HtmlHelper, _
id As String, _
diagram As Diagram _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the DiagramView.

diagram

The Diagram displayed by the view.

Return Value

See Also

DiagramView Method Overload List
DiagramViewExtensions Members
DiagramViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramViewExtensions.DiagramView Method (HtmlHelper, String, Diagram, IDictionary(String, Object))

DiagramViewExtensions.DiagramView Method (HtmlHelper, String, Diagram, IDictionary(String, Object))
See Also
[image]

Returns a DiagramView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString DiagramView (
HtmlHelper helper,
string id,
Diagram diagram,
IDictionary<string, Object> htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function DiagramView( _
helper As HtmlHelper, _
id As String, _
diagram As Diagram, _
htmlAttributes As IDictionary(Of String, Object) _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the DiagramView

diagram

The Diagram displayed by the view

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

DiagramView Method Overload List
DiagramViewExtensions Members
DiagramViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramViewExtensions.DiagramView Method (HtmlHelper, String, Diagram, Object)

DiagramViewExtensions.DiagramView Method (HtmlHelper, String, Diagram, Object)
See Also
[image]

Returns a DiagramView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString DiagramView (
HtmlHelper helper,
string id,
Diagram diagram,
Object htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function DiagramView( _
helper As HtmlHelper, _
id As String, _
diagram As Diagram, _
htmlAttributes As Object _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the DiagramView

diagram

The Diagram displayed by the view

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

DiagramView Method Overload List
DiagramViewExtensions Members
DiagramViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramViewExtensions.DiagramView Method (HtmlHelper, String, Diagram, String)

DiagramViewExtensions.DiagramView Method (HtmlHelper, String, Diagram, String)
See Also
[image]

Returns a DiagramView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString DiagramView (
HtmlHelper helper,
string id,
Diagram diagram,
string initFunction
)

Visual Basic [image] Copy Code

Public Shared Function DiagramView( _
helper As HtmlHelper, _
id As String, _
diagram As Diagram, _
initFunction As String _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the DiagramView

diagram

The Diagram displayed by the view

initFunction

The name of the function that will contain the initializing scripts for the view.

Return Value

See Also

DiagramView Method Overload List
DiagramViewExtensions Members
DiagramViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramViewExtensions.DiagramView Method (HtmlHelper, String, Diagram, String, IDictionary(String, Object))

DiagramViewExtensions.DiagramView Method (HtmlHelper, String, Diagram, String, IDictionary(String, Object))
See Also
[image]

Returns a DiagramView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString DiagramView (
HtmlHelper helper,
string id,
Diagram diagram,
string initFunction,
IDictionary<string, Object> htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function DiagramView( _
helper As HtmlHelper, _
id As String, _
diagram As Diagram, _
initFunction As String, _
htmlAttributes As IDictionary(Of String, Object) _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the DiagramView

diagram

The Diagram displayed by the view

initFunction

The name of the function that will contain the initializing scripts for the view.

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

DiagramView Method Overload List
DiagramViewExtensions Members
DiagramViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.DiagramViewExtensions.DiagramView Method (HtmlHelper, String, Diagram, String, Object)

DiagramViewExtensions.DiagramView Method (HtmlHelper, String, Diagram, String, Object)
See Also
[image]

Returns a DiagramView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString DiagramView (
HtmlHelper helper,
string id,
Diagram diagram,
string initFunction,
Object htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function DiagramView( _
helper As HtmlHelper, _
id As String, _
diagram As Diagram, _
initFunction As String, _
htmlAttributes As Object _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the DiagramView

diagram

The Diagram displayed by the view

initFunction

The name of the function that will contain the initializing scripts for the view.

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

DiagramView Method Overload List
DiagramViewExtensions Members
DiagramViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ItemTypeResolver Class

ItemTypeResolver Class
[image]

Provides a type resolver for DiagramItem classes.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public class ItemTypeResolver : SimpleTypeResolver

Visual Basic [image] Copy Code

Public Class ItemTypeResolver
Inherits SimpleTypeResolver

Inheritance Hierarchy

System.Object
System.Web.Script.Serialization.JavaScriptTypeResolver
System.Web.Script.Serialization.SimpleTypeResolver
MindFusion.Diagramming.Mvc.ItemTypeResolver

See Also

ItemTypeResolver Members
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ItemTypeResolver Members

ItemTypeResolver Members
Constructors Methods
[image]

Provides a type resolver for DiagramItem classes.

The following tables list the members exposed by the ItemTypeResolver type.

Public Constructors

Name | Description
ItemTypeResolver | Creates a new instance of the ItemTypeResolver class.

Public Methods

Name | Description
ResolveType | Returns the Type of the specified id.
ResolveTypeId | Returns the id of the specified Type.

See Also

ItemTypeResolver Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ItemTypeResolver Constructor

ItemTypeResolver Constructor
[image]

Creates a new instance of the ItemTypeResolver class.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ItemTypeResolver (
DiagramView view
)

Visual Basic [image] Copy Code

Public New ( _
view As DiagramView _
)

Parameters

view

See Also

ItemTypeResolver Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ItemTypeResolver Methods

ItemTypeResolver Methods
[image]

Public Methods

Name | Description
ResolveType | Returns the Type of the specified id.
ResolveTypeId | Returns the id of the specified Type.

See Also

ItemTypeResolver Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ItemTypeResolver.ResolveType Method

ItemTypeResolver.ResolveType Method
[image]

Returns the Type of the specified id.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override Type ResolveType (
string id
)

Visual Basic [image] Copy Code

Public Overrides Function ResolveType( _
id As String _
) As Type

Parameters

id

Return Value

See Also

ItemTypeResolver Members
ItemTypeResolver Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ItemTypeResolver.ResolveTypeId Method

ItemTypeResolver.ResolveTypeId Method
[image]

Returns the id of the specified Type.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override string ResolveTypeId (
Type type
)

Visual Basic [image] Copy Code

Public Overrides Function ResolveTypeId( _
type As Type _
) As String

Parameters

type

Return Value

See Also

ItemTypeResolver Members
ItemTypeResolver Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneGridConverter Class

LaneGridConverter Class
[image]

Serializes DiagramView instances in Canvas and ImageMap mode.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public class LaneGridConverter : JavaScriptConverter

Visual Basic [image] Copy Code

Public Class LaneGridConverter
Inherits JavaScriptConverter

Inheritance Hierarchy

System.Object
System.Web.Script.Serialization.JavaScriptConverter
MindFusion.Diagramming.Mvc.LaneGridConverter

See Also

LaneGridConverter Members
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneGridConverter Members

LaneGridConverter Members
Constructors Fields Properties Methods
[image]

Serializes DiagramView instances in Canvas and ImageMap mode.

The following tables list the members exposed by the LaneGridConverter type.

Public Constructors

Name | Description
LaneGridConverter | Creates a new instance of the LaneGridConverter class.

Protected Fields

Name | Description
view | A reference to the current DiagramView control.

Public Properties

Name | Description
SupportedTypes | SupportedTypes override.

Public Methods

Name | Description
Deserialize | Deserialize override.
Serialize | Serialize override.

See Also

LaneGridConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneGridConverter Fields

LaneGridConverter Fields
[image]

Protected Fields

Name | Description
view | A reference to the current DiagramView control.

See Also

LaneGridConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneGridConverter.view Field

LaneGridConverter.view Field
[image]

A reference to the current DiagramView control.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

protected DiagramView view

Visual Basic [image] Copy Code

Protected view As DiagramView

See Also

LaneGridConverter Members
LaneGridConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneGridConverter Constructor

LaneGridConverter Constructor
[image]

Creates a new instance of the LaneGridConverter class.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public LaneGridConverter (
DiagramView view
)

Visual Basic [image] Copy Code

Public New ( _
view As DiagramView _
)

Parameters

view

See Also

LaneGridConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneGridConverter Methods

LaneGridConverter Methods
[image]

Public Methods

Name | Description
Deserialize | Deserialize override.
Serialize | Serialize override.

See Also

LaneGridConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneGridConverter.Deserialize Method

LaneGridConverter.Deserialize Method
[image]

Deserialize override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override Object Deserialize (
IDictionary<string, Object> dictionary,
Type type,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Deserialize( _
dictionary As IDictionary(Of String, Object), _
type As Type, _
serializer As JavaScriptSerializer _
) As Object

Parameters

dictionary

type

serializer

Return Value

See Also

LaneGridConverter Members
LaneGridConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneGridConverter.Serialize Method

LaneGridConverter.Serialize Method
[image]

Serialize override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override IDictionary<string, Object> Serialize (
Object obj,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Serialize( _
obj As Object, _
serializer As JavaScriptSerializer _
) As IDictionary(Of String, Object)

Parameters

obj

serializer

Return Value

See Also

LaneGridConverter Members
LaneGridConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneGridConverter Properties

LaneGridConverter Properties
[image]

Public Properties

Name | Description
SupportedTypes | SupportedTypes override.

See Also

LaneGridConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneGridConverter.SupportedTypes Property

LaneGridConverter.SupportedTypes Property
[image]

SupportedTypes override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override IEnumerable<Type> SupportedTypes { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property SupportedTypes As IEnumerable(Of Type)

Property Value

See Also

LaneGridConverter Members
LaneGridConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneHeaderCollectionConverter Class

LaneHeaderCollectionConverter Class
[image]

Serializes HeaderCollection instances in Canvas mode.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public class LaneHeaderCollectionConverter : JavaScriptConverter

Visual Basic [image] Copy Code

Public Class LaneHeaderCollectionConverter
Inherits JavaScriptConverter

Inheritance Hierarchy

System.Object
System.Web.Script.Serialization.JavaScriptConverter
MindFusion.Diagramming.Mvc.LaneHeaderCollectionConverter

See Also

LaneHeaderCollectionConverter Members
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneHeaderCollectionConverter Members

LaneHeaderCollectionConverter Members
Constructors Properties Methods
[image]

Serializes HeaderCollection instances in Canvas mode.

The following tables list the members exposed by the LaneHeaderCollectionConverter type.

Public Constructors

Name | Description
LaneHeaderCollectionConverter |

Public Properties

Name | Description
SupportedTypes | SupportedTypes override.

Public Methods

Name | Description
Deserialize | Deserialize override.
Serialize | Serialize override.

See Also

LaneHeaderCollectionConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneHeaderCollectionConverter Constructor

LaneHeaderCollectionConverter Constructor
[image]

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public LaneHeaderCollectionConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LaneHeaderCollectionConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneHeaderCollectionConverter Methods

LaneHeaderCollectionConverter Methods
[image]

Public Methods

Name | Description
Deserialize | Deserialize override.
Serialize | Serialize override.

See Also

LaneHeaderCollectionConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneHeaderCollectionConverter.Deserialize Method

LaneHeaderCollectionConverter.Deserialize Method
[image]

Deserialize override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override Object Deserialize (
IDictionary<string, Object> dictionary,
Type type,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Deserialize( _
dictionary As IDictionary(Of String, Object), _
type As Type, _
serializer As JavaScriptSerializer _
) As Object

Parameters

dictionary

type

serializer

Return Value

See Also

LaneHeaderCollectionConverter Members
LaneHeaderCollectionConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneHeaderCollectionConverter.Serialize Method

LaneHeaderCollectionConverter.Serialize Method
[image]

Serialize override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override IDictionary<string, Object> Serialize (
Object obj,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Serialize( _
obj As Object, _
serializer As JavaScriptSerializer _
) As IDictionary(Of String, Object)

Parameters

obj

serializer

Return Value

See Also

LaneHeaderCollectionConverter Members
LaneHeaderCollectionConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneHeaderCollectionConverter Properties

LaneHeaderCollectionConverter Properties
[image]

Public Properties

Name | Description
SupportedTypes | SupportedTypes override.

See Also

LaneHeaderCollectionConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneHeaderCollectionConverter.SupportedTypes Property

LaneHeaderCollectionConverter.SupportedTypes Property
[image]

SupportedTypes override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override IEnumerable<Type> SupportedTypes { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property SupportedTypes As IEnumerable(Of Type)

Property Value

See Also

LaneHeaderCollectionConverter Members
LaneHeaderCollectionConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneHeaderConverter Class

LaneHeaderConverter Class
[image]

Serializes Header instances in Canvas mode.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public class LaneHeaderConverter : JavaScriptConverter

Visual Basic [image] Copy Code

Public Class LaneHeaderConverter
Inherits JavaScriptConverter

Inheritance Hierarchy

System.Object
System.Web.Script.Serialization.JavaScriptConverter
MindFusion.Diagramming.Mvc.LaneHeaderConverter

See Also

LaneHeaderConverter Members
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneHeaderConverter Members

LaneHeaderConverter Members
Constructors Properties Methods
[image]

Serializes Header instances in Canvas mode.

The following tables list the members exposed by the LaneHeaderConverter type.

Public Constructors

Name | Description
LaneHeaderConverter |

Public Properties

Name | Description
SupportedTypes | SupportedTypes override.

Public Methods

Name | Description
Deserialize | Deserialize override.
Serialize | Serialize override.

See Also

LaneHeaderConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneHeaderConverter Constructor

LaneHeaderConverter Constructor
[image]

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public LaneHeaderConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LaneHeaderConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneHeaderConverter Methods

LaneHeaderConverter Methods
[image]

Public Methods

Name | Description
Deserialize | Deserialize override.
Serialize | Serialize override.

See Also

LaneHeaderConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneHeaderConverter.Deserialize Method

LaneHeaderConverter.Deserialize Method
[image]

Deserialize override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override Object Deserialize (
IDictionary<string, Object> dictionary,
Type type,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Deserialize( _
dictionary As IDictionary(Of String, Object), _
type As Type, _
serializer As JavaScriptSerializer _
) As Object

Parameters

dictionary

type

serializer

Return Value

See Also

LaneHeaderConverter Members
LaneHeaderConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneHeaderConverter.Serialize Method

LaneHeaderConverter.Serialize Method
[image]

Serialize override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override IDictionary<string, Object> Serialize (
Object obj,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Serialize( _
obj As Object, _
serializer As JavaScriptSerializer _
) As IDictionary(Of String, Object)

Parameters

obj

serializer

Return Value

See Also

LaneHeaderConverter Members
LaneHeaderConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneHeaderConverter Properties

LaneHeaderConverter Properties
[image]

Public Properties

Name | Description
SupportedTypes | SupportedTypes override.

See Also

LaneHeaderConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneHeaderConverter.SupportedTypes Property

LaneHeaderConverter.SupportedTypes Property
[image]

SupportedTypes override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override IEnumerable<Type> SupportedTypes { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property SupportedTypes As IEnumerable(Of Type)

Property Value

See Also

LaneHeaderConverter Members
LaneHeaderConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneStyleConverter Class

LaneStyleConverter Class
[image]

Serializes Lanes.Style instances in Canvas mode.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public class LaneStyleConverter : JavaScriptConverter

Visual Basic [image] Copy Code

Public Class LaneStyleConverter
Inherits JavaScriptConverter

Inheritance Hierarchy

System.Object
System.Web.Script.Serialization.JavaScriptConverter
MindFusion.Diagramming.Mvc.LaneStyleConverter

See Also

LaneStyleConverter Members
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneStyleConverter Members

LaneStyleConverter Members
Constructors Properties Methods
[image]

Serializes Lanes.Style instances in Canvas mode.

The following tables list the members exposed by the LaneStyleConverter type.

Public Constructors

Name | Description
LaneStyleConverter |

Public Properties

Name | Description
SupportedTypes | SupportedTypes override.

Public Methods

Name | Description
Deserialize | Deserialize override.
Serialize | Serialize override.

See Also

LaneStyleConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneStyleConverter Constructor

LaneStyleConverter Constructor
[image]

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public LaneStyleConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LaneStyleConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneStyleConverter Methods

LaneStyleConverter Methods
[image]

Public Methods

Name | Description
Deserialize | Deserialize override.
Serialize | Serialize override.

See Also

LaneStyleConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneStyleConverter.Deserialize Method

LaneStyleConverter.Deserialize Method
[image]

Deserialize override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override Object Deserialize (
IDictionary<string, Object> dictionary,
Type type,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Deserialize( _
dictionary As IDictionary(Of String, Object), _
type As Type, _
serializer As JavaScriptSerializer _
) As Object

Parameters

dictionary

type

serializer

Return Value

See Also

LaneStyleConverter Members
LaneStyleConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneStyleConverter.Serialize Method

LaneStyleConverter.Serialize Method
[image]

Serialize override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override IDictionary<string, Object> Serialize (
Object obj,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Serialize( _
obj As Object, _
serializer As JavaScriptSerializer _
) As IDictionary(Of String, Object)

Parameters

obj

serializer

Return Value

See Also

LaneStyleConverter Members
LaneStyleConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneStyleConverter Properties

LaneStyleConverter Properties
[image]

Public Properties

Name | Description
SupportedTypes | SupportedTypes override.

See Also

LaneStyleConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.LaneStyleConverter.SupportedTypes Property

LaneStyleConverter.SupportedTypes Property
[image]

SupportedTypes override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override IEnumerable<Type> SupportedTypes { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property SupportedTypes As IEnumerable(Of Type)

Property Value

See Also

LaneStyleConverter Members
LaneStyleConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView Class

NodeListView Class
[image]

ListBox control with support for hosting Diagram nodes and dragging them to the Diagram control.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public class NodeListView

Visual Basic [image] Copy Code

Public Class NodeListView

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Mvc.NodeListView

See Also

NodeListView Members
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView Members

NodeListView Members
Constructors Properties Methods
[image]

ListBox control with support for hosting Diagram nodes and dragging them to the Diagram control.

The following tables list the members exposed by the NodeListView type.

Public Constructors

Name | Description
NodeListView | Overloaded. Creates an instance of NodeListView.

Public Properties

Name | Description
AddScriptReferences | Gets or sets a value indicating whether the control should render references to the client scripts.
BoxPadding | Gets or sets the padding
ClientScriptLocation | Gets or sets the URL to the MindFusion.Diagramming.js file.
ClientSideMode | Gets or sets a value indicating which library will be used in the control's client-side scripts.
Converters | Gets the registered custom converters.
DefaultNodeSize | Gets or sets the default size with which nodes dragged onto a diagram will be created.
Enabled | Gets or sets a value indicating whether handling of mouse events is enabled.
Height | Gets or sets the height of the view.
Id | Gets or sets the id of the view.
Items | Gets or sets the collection of nodes displayed in the view.
ItemTypes | Gets the registered item types.
JQueryLocation | Gets or sets the URL to the JQuery script file.
MeasureUnit | Gets or sets the measure unit.
NodeSize | Gets or sets the size of the nodes displayed in the view.
Orientation | Gets or sets the layout orientation of the control.
Padding | Gets or sets the padding.
Width | Gets or sets the width of the view.

Public Methods

Name | Description
AddNode | Overloaded. Adds a DiagramNode to the displayed nodes collection.
ControlLoadedScript | Sets the name of a JavaScript function that should be invoked when the control is loaded on the client side.
FromJson | Creates a NodeListView object from JSON.
FromRequest | Creates an instance of NodeListView.
Init | Renders the NodeListView's initializing scripts on a web page under the specified function name.
LoadFromJson | Loads the specified JSON data.
RegisterConverters | Registers custom converters used for custom item types serialization.
RegisterItemType | Registers a custom item class for serialization support.
RemoveNode | Removes a DiagramNode from the displayed nodes collection.
Render | Renders the NodeListView on a web page.
SaveToJson | Serializes the NodeListView's data to JSON.
SetAddScriptReferences | Sets a value indicating whether the control should render references to the client scripts.
SetClientSideMode | Sets a value indicating which library will be used in the control's client-side scripts.
SetDefaultNodeSize | Sets the default size with which nodes dragged onto a diagram will be created.
SetEnabled | Sets a value indicating whether handling of mouse events is enabled.
SetHeight | Sets the height of the view.
SetNodeSize | Sets the size of the nodes displayed in the view.
SetOrientation | Sets the layout orientation of the control.
SetWidth | Sets the width of the view.
ToJson | Serializes the NodeListView's data to JSON.

See Also

NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView Constructor

NodeListView Constructor
[image]

Creates an instance of NodeListView.

Overload List

Name | Description
NodeListView () | Creates an instance of NodeListView.
NodeListView (String) | Creates an instance of NodeListView.
NodeListView (String, DiagramNodeCollection) | Creates an instance of NodeListView.

See Also

NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView Constructor ()

NodeListView Constructor ()
See Also
[image]

Creates an instance of NodeListView.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public NodeListView ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

NodeListView Constructor Overload List
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView Constructor (String)

NodeListView Constructor (String)
See Also
[image]

Creates an instance of NodeListView.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public NodeListView (
string id
)

Visual Basic [image] Copy Code

Public New ( _
id As String _
)

Parameters

id

The Id of the NodeListView.

See Also

NodeListView Constructor Overload List
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView Constructor (String, DiagramNodeCollection)

NodeListView Constructor (String, DiagramNodeCollection)
See Also
[image]

Creates an instance of NodeListView.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public NodeListView (
string id,
DiagramNodeCollection items
)

Visual Basic [image] Copy Code

Public New ( _
id As String, _
items As DiagramNodeCollection _
)

Parameters

id

The Id of the NodeListView.

items

The collection of nodes to be displayed in the NodeListView.

See Also

NodeListView Constructor Overload List
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView Methods

NodeListView Methods
[image]

Public Methods

Name | Description
AddNode | Overloaded. Adds a DiagramNode to the displayed nodes collection.
ControlLoadedScript | Sets the name of a JavaScript function that should be invoked when the control is loaded on the client side.
FromJson | Creates a NodeListView object from JSON.
FromRequest | Creates an instance of NodeListView.
Init | Renders the NodeListView's initializing scripts on a web page under the specified function name.
LoadFromJson | Loads the specified JSON data.
RegisterConverters | Registers custom converters used for custom item types serialization.
RegisterItemType | Registers a custom item class for serialization support.
RemoveNode | Removes a DiagramNode from the displayed nodes collection.
Render | Renders the NodeListView on a web page.
SaveToJson | Serializes the NodeListView's data to JSON.
SetAddScriptReferences | Sets a value indicating whether the control should render references to the client scripts.
SetClientSideMode | Sets a value indicating which library will be used in the control's client-side scripts.
SetDefaultNodeSize | Sets the default size with which nodes dragged onto a diagram will be created.
SetEnabled | Sets a value indicating whether handling of mouse events is enabled.
SetHeight | Sets the height of the view.
SetNodeSize | Sets the size of the nodes displayed in the view.
SetOrientation | Sets the layout orientation of the control.
SetWidth | Sets the width of the view.
ToJson | Serializes the NodeListView's data to JSON.

See Also

NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.AddNode Method

NodeListView.AddNode Method
[image]

Adds a DiagramNode to the displayed nodes collection.

Overload List

Name | Description
NodeListView.AddNode (DiagramNode) | Adds a DiagramNode to the displayed nodes collection.
NodeListView.AddNode (DiagramNode, String) | Adds a DiagramNode to the displayed nodes collection.

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.AddNode Method (DiagramNode)

NodeListView.AddNode Method (DiagramNode)
See Also
[image]

Adds a DiagramNode to the displayed nodes collection.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public NodeListView AddNode (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Function AddNode( _
node As DiagramNode _
) As NodeListView

Parameters

node

The DiagramNode instance to add.

Return Value

See Also

AddNode Method Overload List
NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.AddNode Method (DiagramNode, String)

NodeListView.AddNode Method (DiagramNode, String)
See Also
[image]

Adds a DiagramNode to the displayed nodes collection.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public NodeListView AddNode (
DiagramNode node,
string caption
)

Visual Basic [image] Copy Code

Public Function AddNode( _
node As DiagramNode, _
caption As String _
) As NodeListView

Parameters

node

The DiagramNode instance to add.

caption

The caption to display for the node.

Return Value

See Also

AddNode Method Overload List
NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.ControlLoadedScript Method

NodeListView.ControlLoadedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when the control is loaded on the client side.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public NodeListView ControlLoadedScript (
string value
)

Visual Basic [image] Copy Code

Public Function ControlLoadedScript( _
value As String _
) As NodeListView

Parameters

value

The name of the function

Return Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.FromJson Method

NodeListView.FromJson Method
[image]

Creates a NodeListView object from JSON.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static NodeListView FromJson (
string json
)

Visual Basic [image] Copy Code

Public Shared Function FromJson( _
json As String _
) As NodeListView

Parameters

json

The JSON string

Return Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.FromRequest Method

NodeListView.FromRequest Method
[image]

Creates an instance of NodeListView.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static NodeListView FromRequest (
string id,
HttpRequestBase request
)

Visual Basic [image] Copy Code

Public Shared Function FromRequest( _
id As String, _
request As HttpRequestBase _
) As NodeListView

Parameters

id

The Id of the NodeListView

request

An HttpRequest object that contains the json data for the view.

Return Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.Init Method

NodeListView.Init Method
[image]

Renders the NodeListView's initializing scripts on a web page under the specified function name.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string Init (
string functionName
)

Visual Basic [image] Copy Code

Public Function Init( _
functionName As String _
) As String

Parameters

functionName

Return Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.LoadFromJson Method

NodeListView.LoadFromJson Method
[image]

Loads the specified JSON data.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public void LoadFromJson (
string json
)

Visual Basic [image] Copy Code

Public Sub LoadFromJson( _
json As String _
)

Parameters

json

The JSON string

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.RegisterConverters Method

NodeListView.RegisterConverters Method
[image]

Registers custom converters used for custom item types serialization.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public NodeListView RegisterConverters (
JavaScriptConverter[] converters
)

Visual Basic [image] Copy Code

Public Function RegisterConverters( _
converters() As JavaScriptConverter _
) As NodeListView

Parameters

converters

The converters to register.

Return Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.RegisterItemType Method

NodeListView.RegisterItemType Method
[image]

Registers a custom item class for serialization support.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public NodeListView RegisterItemType (
Type itemClass,
string classId,
string clientClassId,
int classVersion
)

Visual Basic [image] Copy Code

Public Function RegisterItemType( _
itemClass As Type, _
classId As String, _
clientClassId As String, _
classVersion As Integer _
) As NodeListView

Parameters

itemClass

A Type instance identifying the item class.

classId

A class identifier to use when serializing, saving and loading items of the specified type.

clientClassId

A class identifier to use when serializing items of the specified type on the client side.

classVersion

A revision number of the item's class serialization format.

Return Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.RemoveNode Method

NodeListView.RemoveNode Method
[image]

Removes a DiagramNode from the displayed nodes collection.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public NodeListView RemoveNode (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Function RemoveNode( _
node As DiagramNode _
) As NodeListView

Parameters

node

The DiagramNode instance to remove.

Return Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.Render Method

NodeListView.Render Method
[image]

Renders the NodeListView on a web page.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string Render ()

Visual Basic [image] Copy Code

Public Function Render () As String

Return Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.SaveToJson Method

NodeListView.SaveToJson Method
[image]

Serializes the NodeListView's data to JSON.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string SaveToJson ()

Visual Basic [image] Copy Code

Public Function SaveToJson () As String

Return Value

The JSON string.

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.SetAddScriptReferences Method

NodeListView.SetAddScriptReferences Method
[image]

Sets a value indicating whether the control should render references to the client scripts.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public NodeListView SetAddScriptReferences (
bool value
)

Visual Basic [image] Copy Code

Public Function SetAddScriptReferences( _
value As Boolean _
) As NodeListView

Parameters

value

Return Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.SetClientSideMode Method

NodeListView.SetClientSideMode Method
[image]

Sets a value indicating which library will be used in the control's client-side scripts.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public NodeListView SetClientSideMode (
ClientSideMode value
)

Visual Basic [image] Copy Code

Public Function SetClientSideMode( _
value As ClientSideMode _
) As NodeListView

Parameters

value

Return Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.SetDefaultNodeSize Method

NodeListView.SetDefaultNodeSize Method
[image]

Sets the default size with which nodes dragged onto a diagram will be created.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public NodeListView SetDefaultNodeSize (
SizeF value
)

Visual Basic [image] Copy Code

Public Function SetDefaultNodeSize( _
value As SizeF _
) As NodeListView

Parameters

value

The size of the nodes

Return Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.SetEnabled Method

NodeListView.SetEnabled Method
[image]

Sets a value indicating whether handling of mouse events is enabled.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public NodeListView SetEnabled (
bool value
)

Visual Basic [image] Copy Code

Public Function SetEnabled( _
value As Boolean _
) As NodeListView

Parameters

value

Return Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.SetHeight Method

NodeListView.SetHeight Method
[image]

Sets the height of the view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public NodeListView SetHeight (
int value
)

Visual Basic [image] Copy Code

Public Function SetHeight( _
value As Integer _
) As NodeListView

Parameters

value

The height of the view in pixels

Return Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.SetNodeSize Method

NodeListView.SetNodeSize Method
[image]

Sets the size of the nodes displayed in the view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public NodeListView SetNodeSize (
SizeF value
)

Visual Basic [image] Copy Code

Public Function SetNodeSize( _
value As SizeF _
) As NodeListView

Parameters

value

The size of the nodes

Return Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.SetOrientation Method

NodeListView.SetOrientation Method
[image]

Sets the layout orientation of the control.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public NodeListView SetOrientation (
Orientation value
)

Visual Basic [image] Copy Code

Public Function SetOrientation( _
value As Orientation _
) As NodeListView

Parameters

value

Return Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.SetWidth Method

NodeListView.SetWidth Method
[image]

Sets the width of the view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public NodeListView SetWidth (
int value
)

Visual Basic [image] Copy Code

Public Function SetWidth( _
value As Integer _
) As NodeListView

Parameters

value

The width of the view in pixels

Return Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.ToJson Method

NodeListView.ToJson Method
[image]

Serializes the NodeListView's data to JSON.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static string ToJson (
NodeListView view
)

Visual Basic [image] Copy Code

Public Shared Function ToJson( _
view As NodeListView _
) As String

Parameters

view

Return Value

The JSON string.

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView Properties

NodeListView Properties
[image]

Public Properties

Name | Description
AddScriptReferences | Gets or sets a value indicating whether the control should render references to the client scripts.
BoxPadding | Gets or sets the padding
ClientScriptLocation | Gets or sets the URL to the MindFusion.Diagramming.js file.
ClientSideMode | Gets or sets a value indicating which library will be used in the control's client-side scripts.
Converters | Gets the registered custom converters.
DefaultNodeSize | Gets or sets the default size with which nodes dragged onto a diagram will be created.
Enabled | Gets or sets a value indicating whether handling of mouse events is enabled.
Height | Gets or sets the height of the view.
Id | Gets or sets the id of the view.
Items | Gets or sets the collection of nodes displayed in the view.
ItemTypes | Gets the registered item types.
JQueryLocation | Gets or sets the URL to the JQuery script file.
MeasureUnit | Gets or sets the measure unit.
NodeSize | Gets or sets the size of the nodes displayed in the view.
Orientation | Gets or sets the layout orientation of the control.
Padding | Gets or sets the padding.
Width | Gets or sets the width of the view.

See Also

NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.AddScriptReferences Property

NodeListView.AddScriptReferences Property
[image]

Gets or sets a value indicating whether the control should render references to the client scripts.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public bool AddScriptReferences { get; set; }

Visual Basic [image] Copy Code

Public Property AddScriptReferences As Boolean

Property Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.BoxPadding Property

NodeListView.BoxPadding Property
[image]

Gets or sets the padding

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public int BoxPadding { get; set; }

Visual Basic [image] Copy Code

Public Property BoxPadding As Integer

Property Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.ClientScriptLocation Property

NodeListView.ClientScriptLocation Property
[image]

Gets or sets the URL to the MindFusion.Diagramming.js file.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string ClientScriptLocation { get; set; }

Visual Basic [image] Copy Code

Public Property ClientScriptLocation As String

Property Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.ClientSideMode Property

NodeListView.ClientSideMode Property
[image]

Gets or sets a value indicating which library will be used in the control's client-side scripts.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ClientSideMode ClientSideMode { get; set; }

Visual Basic [image] Copy Code

Public Property ClientSideMode As ClientSideMode

Property Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.Converters Property

NodeListView.Converters Property
[image]

Gets the registered custom converters.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public JavaScriptConverter[] Converters { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Converters As JavaScriptConverter()

Property Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.DefaultNodeSize Property

NodeListView.DefaultNodeSize Property
[image]

Gets or sets the default size with which nodes dragged onto a diagram will be created.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public SizeF DefaultNodeSize { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultNodeSize As SizeF

Property Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.Enabled Property

NodeListView.Enabled Property
[image]

Gets or sets a value indicating whether handling of mouse events is enabled.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public bool Enabled { get; set; }

Visual Basic [image] Copy Code

Public Property Enabled As Boolean

Property Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.Height Property

NodeListView.Height Property
[image]

Gets or sets the height of the view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public int Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Integer

Property Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.Id Property

NodeListView.Id Property
[image]

Gets or sets the id of the view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string Id { get; set; }

Visual Basic [image] Copy Code

Public Property Id As String

Property Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.Items Property

NodeListView.Items Property
[image]

Gets or sets the collection of nodes displayed in the view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public DiagramNodeCollection Items { get; set; }

Visual Basic [image] Copy Code

Public Property Items As DiagramNodeCollection

Property Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.ItemTypes Property

NodeListView.ItemTypes Property
[image]

Gets the registered item types.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Dictionary<Type, string> ItemTypes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ItemTypes As Dictionary(Of Type, String)

Property Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.JQueryLocation Property

NodeListView.JQueryLocation Property
[image]

Gets or sets the URL to the JQuery script file.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string JQueryLocation { get; set; }

Visual Basic [image] Copy Code

Public Property JQueryLocation As String

Property Value

Remarks

This property is used only if ClientSideMode is set to ClientSideMode.JQuery.

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.MeasureUnit Property

NodeListView.MeasureUnit Property
[image]

Gets or sets the measure unit.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public MeasureUnit MeasureUnit { get; set; }

Visual Basic [image] Copy Code

Public Property MeasureUnit As MeasureUnit

Property Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.NodeSize Property

NodeListView.NodeSize Property
[image]

Gets or sets the size of the nodes displayed in the view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public SizeF NodeSize { get; set; }

Visual Basic [image] Copy Code

Public Property NodeSize As SizeF

Property Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.Orientation Property

NodeListView.Orientation Property
[image]

Gets or sets the layout orientation of the control.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.Padding Property

NodeListView.Padding Property
[image]

Gets or sets the padding.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public int Padding { get; set; }

Visual Basic [image] Copy Code

Public Property Padding As Integer

Property Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListView.Width Property

NodeListView.Width Property
[image]

Gets or sets the width of the view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public int Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Integer

Property Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListViewExtensions Class

NodeListViewExtensions Class
[image]

Contains extension methods of NodeListView

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public sealed class NodeListViewExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class NodeListViewExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Mvc.NodeListViewExtensions

See Also

NodeListViewExtensions Members
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListViewExtensions Members

NodeListViewExtensions Members
Methods
[image]

Contains extension methods of NodeListView

The following tables list the members exposed by the NodeListViewExtensions type.

Public Methods

Name | Description
NodeListView | Overloaded. Returns a NodeListView by using the specified HTML helper.

See Also

NodeListViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListViewExtensions Methods

NodeListViewExtensions Methods
[image]

Public Methods

Name | Description
NodeListView | Overloaded. Returns a NodeListView by using the specified HTML helper.

See Also

NodeListViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListViewExtensions.NodeListView Method

NodeListViewExtensions.NodeListView Method
[image]

Returns a NodeListView by using the specified HTML helper.

Overload List

Name | Description
NodeListViewExtensions.NodeListView (HtmlHelper, NodeListView) | Returns a NodeListView by using the specified HTML helper.
NodeListViewExtensions.NodeListView (HtmlHelper, NodeListView, IDictionary(String, Object)) | Returns a NodeListView by using the specified HTML helper.
NodeListViewExtensions.NodeListView (HtmlHelper, NodeListView, Object) | Returns a NodeListView by using the specified HTML helper.
NodeListViewExtensions.NodeListView (HtmlHelper, NodeListView, String) | Returns a NodeListView by using the specified HTML helper.
NodeListViewExtensions.NodeListView (HtmlHelper, NodeListView, String, IDictionary(String, Object)) | Returns a NodeListView by using the specified HTML helper.
NodeListViewExtensions.NodeListView (HtmlHelper, NodeListView, String, Object) | Returns a NodeListView by using the specified HTML helper.
NodeListViewExtensions.NodeListView (HtmlHelper, String) | Returns a NodeListView by using the specified HTML helper.
NodeListViewExtensions.NodeListView (HtmlHelper, String, DiagramNodeCollection) | Returns a NodeListView by using the specified HTML helper.
NodeListViewExtensions.NodeListView (HtmlHelper, String, DiagramNodeCollection, IDictionary(String, Object)) | Returns a NodeListView by using the specified HTML helper.
NodeListViewExtensions.NodeListView (HtmlHelper, String, DiagramNodeCollection, Object) | Returns a NodeListView by using the specified HTML helper.
NodeListViewExtensions.NodeListView (HtmlHelper, String, DiagramNodeCollection, String) | Returns a NodeListView by using the specified HTML helper.
NodeListViewExtensions.NodeListView (HtmlHelper, String, IDictionary(String, Object)) | Returns a NodeListView by using the specified HTML helper.
NodeListViewExtensions.NodeListView (HtmlHelper, String, Object) | Returns a NodeListView by using the specified HTML helper.
NodeListViewExtensions.NodeListView (HtmlHelper, String, String) | Returns a NodeListView by using the specified HTML helper.
NodeListViewExtensions.NodeListView (HtmlHelper, String, String, IDictionary(String, Object)) | Returns a NodeListView by using the specified HTML helper.
NodeListViewExtensions.NodeListView (HtmlHelper, String, String, Object) | Returns a NodeListView by using the specified HTML helper.

See Also

NodeListViewExtensions Members
NodeListViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListViewExtensions.NodeListView Method (HtmlHelper, NodeListView)

NodeListViewExtensions.NodeListView Method (HtmlHelper, NodeListView)
See Also
[image]

Returns a NodeListView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString NodeListView (
HtmlHelper helper,
NodeListView view
)

Visual Basic [image] Copy Code

Public Shared Function NodeListView( _
helper As HtmlHelper, _
view As NodeListView _
) As MvcHtmlString

Parameters

helper

The HTML helper

view

The NodeListView.

Return Value

See Also

NodeListView Method Overload List
NodeListViewExtensions Members
NodeListViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListViewExtensions.NodeListView Method (HtmlHelper, NodeListView, IDictionary(String, Object))

NodeListViewExtensions.NodeListView Method (HtmlHelper, NodeListView, IDictionary(String, Object))
See Also
[image]

Returns a NodeListView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString NodeListView (
HtmlHelper helper,
NodeListView view,
IDictionary<string, Object> htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function NodeListView( _
helper As HtmlHelper, _
view As NodeListView, _
htmlAttributes As IDictionary(Of String, Object) _
) As MvcHtmlString

Parameters

helper

The HTML helper

view

The NodeListView

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

NodeListView Method Overload List
NodeListViewExtensions Members
NodeListViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListViewExtensions.NodeListView Method (HtmlHelper, NodeListView, Object)

NodeListViewExtensions.NodeListView Method (HtmlHelper, NodeListView, Object)
See Also
[image]

Returns a NodeListView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString NodeListView (
HtmlHelper helper,
NodeListView view,
Object htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function NodeListView( _
helper As HtmlHelper, _
view As NodeListView, _
htmlAttributes As Object _
) As MvcHtmlString

Parameters

helper

The HTML helper

view

The NodeListView

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

NodeListView Method Overload List
NodeListViewExtensions Members
NodeListViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListViewExtensions.NodeListView Method (HtmlHelper, NodeListView, String)

NodeListViewExtensions.NodeListView Method (HtmlHelper, NodeListView, String)
See Also
[image]

Returns a NodeListView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString NodeListView (
HtmlHelper helper,
NodeListView view,
string initFunction
)

Visual Basic [image] Copy Code

Public Shared Function NodeListView( _
helper As HtmlHelper, _
view As NodeListView, _
initFunction As String _
) As MvcHtmlString

Parameters

helper

The HTML helper

view

The NodeListView

initFunction

The name of the function that will contain the initializing scripts for the view.

Return Value

See Also

NodeListView Method Overload List
NodeListViewExtensions Members
NodeListViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListViewExtensions.NodeListView Method (HtmlHelper, NodeListView, String, IDictionary(String, Object))

NodeListViewExtensions.NodeListView Method (HtmlHelper, NodeListView, String, IDictionary(String, Object))
See Also
[image]

Returns a NodeListView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString NodeListView (
HtmlHelper helper,
NodeListView view,
string initFunction,
IDictionary<string, Object> htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function NodeListView( _
helper As HtmlHelper, _
view As NodeListView, _
initFunction As String, _
htmlAttributes As IDictionary(Of String, Object) _
) As MvcHtmlString

Parameters

helper

The HTML helper

view

The NodeListView

initFunction

The name of the function that will contain the initializing scripts for the view.

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

NodeListView Method Overload List
NodeListViewExtensions Members
NodeListViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListViewExtensions.NodeListView Method (HtmlHelper, NodeListView, String, Object)

NodeListViewExtensions.NodeListView Method (HtmlHelper, NodeListView, String, Object)
See Also
[image]

Returns a NodeListView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString NodeListView (
HtmlHelper helper,
NodeListView view,
string initFunction,
Object htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function NodeListView( _
helper As HtmlHelper, _
view As NodeListView, _
initFunction As String, _
htmlAttributes As Object _
) As MvcHtmlString

Parameters

helper

The HTML helper

view

The NodeListView

initFunction

The name of the function that will contain the initializing scripts for the view.

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

NodeListView Method Overload List
NodeListViewExtensions Members
NodeListViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListViewExtensions.NodeListView Method (HtmlHelper, String)

NodeListViewExtensions.NodeListView Method (HtmlHelper, String)
See Also
[image]

Returns a NodeListView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString NodeListView (
HtmlHelper helper,
string id
)

Visual Basic [image] Copy Code

Public Shared Function NodeListView( _
helper As HtmlHelper, _
id As String _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the NodeListView.

Return Value

See Also

NodeListView Method Overload List
NodeListViewExtensions Members
NodeListViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListViewExtensions.NodeListView Method (HtmlHelper, String, DiagramNodeCollection)

NodeListViewExtensions.NodeListView Method (HtmlHelper, String, DiagramNodeCollection)
See Also
[image]

Returns a NodeListView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString NodeListView (
HtmlHelper helper,
string id,
DiagramNodeCollection items
)

Visual Basic [image] Copy Code

Public Shared Function NodeListView( _
helper As HtmlHelper, _
id As String, _
items As DiagramNodeCollection _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the NodeListView.

items

The items to be displayed

Return Value

See Also

NodeListView Method Overload List
NodeListViewExtensions Members
NodeListViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListViewExtensions.NodeListView Method (HtmlHelper, String, DiagramNodeCollection, IDictionary(String, Object))

NodeListViewExtensions.NodeListView Method (HtmlHelper, String, DiagramNodeCollection, IDictionary(String, Object))
See Also
[image]

Returns a NodeListView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString NodeListView (
HtmlHelper helper,
string id,
DiagramNodeCollection items,
IDictionary<string, Object> htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function NodeListView( _
helper As HtmlHelper, _
id As String, _
items As DiagramNodeCollection, _
htmlAttributes As IDictionary(Of String, Object) _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the NodeListView

items

The items to be displayed

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

NodeListView Method Overload List
NodeListViewExtensions Members
NodeListViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListViewExtensions.NodeListView Method (HtmlHelper, String, DiagramNodeCollection, Object)

NodeListViewExtensions.NodeListView Method (HtmlHelper, String, DiagramNodeCollection, Object)
See Also
[image]

Returns a NodeListView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString NodeListView (
HtmlHelper helper,
string id,
DiagramNodeCollection items,
Object htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function NodeListView( _
helper As HtmlHelper, _
id As String, _
items As DiagramNodeCollection, _
htmlAttributes As Object _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the NodeListView

items

The items to be displayed

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

NodeListView Method Overload List
NodeListViewExtensions Members
NodeListViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListViewExtensions.NodeListView Method (HtmlHelper, String, DiagramNodeCollection, String)

NodeListViewExtensions.NodeListView Method (HtmlHelper, String, DiagramNodeCollection, String)
See Also
[image]

Returns a NodeListView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString NodeListView (
HtmlHelper helper,
string id,
DiagramNodeCollection items,
string initFunction
)

Visual Basic [image] Copy Code

Public Shared Function NodeListView( _
helper As HtmlHelper, _
id As String, _
items As DiagramNodeCollection, _
initFunction As String _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the NodeListView

items

The items to be displayed

initFunction

The name of the function that will contain the initializing scripts for the view.

Return Value

See Also

NodeListView Method Overload List
NodeListViewExtensions Members
NodeListViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListViewExtensions.NodeListView Method (HtmlHelper, String, IDictionary(String, Object))

NodeListViewExtensions.NodeListView Method (HtmlHelper, String, IDictionary(String, Object))
See Also
[image]

Returns a NodeListView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString NodeListView (
HtmlHelper helper,
string id,
IDictionary<string, Object> htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function NodeListView( _
helper As HtmlHelper, _
id As String, _
htmlAttributes As IDictionary(Of String, Object) _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the NodeListView

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

NodeListView Method Overload List
NodeListViewExtensions Members
NodeListViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListViewExtensions.NodeListView Method (HtmlHelper, String, Object)

NodeListViewExtensions.NodeListView Method (HtmlHelper, String, Object)
See Also
[image]

Returns a NodeListView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString NodeListView (
HtmlHelper helper,
string id,
Object htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function NodeListView( _
helper As HtmlHelper, _
id As String, _
htmlAttributes As Object _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the NodeListView

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

NodeListView Method Overload List
NodeListViewExtensions Members
NodeListViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListViewExtensions.NodeListView Method (HtmlHelper, String, String)

NodeListViewExtensions.NodeListView Method (HtmlHelper, String, String)
See Also
[image]

Returns a NodeListView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString NodeListView (
HtmlHelper helper,
string id,
string initFunction
)

Visual Basic [image] Copy Code

Public Shared Function NodeListView( _
helper As HtmlHelper, _
id As String, _
initFunction As String _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the NodeListView

initFunction

The name of the function that will contain the initializing scripts for the view.

Return Value

See Also

NodeListView Method Overload List
NodeListViewExtensions Members
NodeListViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListViewExtensions.NodeListView Method (HtmlHelper, String, String, IDictionary(String, Object))

NodeListViewExtensions.NodeListView Method (HtmlHelper, String, String, IDictionary(String, Object))
See Also
[image]

Returns a NodeListView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString NodeListView (
HtmlHelper helper,
string id,
string initFunction,
IDictionary<string, Object> htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function NodeListView( _
helper As HtmlHelper, _
id As String, _
initFunction As String, _
htmlAttributes As IDictionary(Of String, Object) _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the NodeListView

initFunction

The name of the function that will contain the initializing scripts for the view.

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

NodeListView Method Overload List
NodeListViewExtensions Members
NodeListViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.NodeListViewExtensions.NodeListView Method (HtmlHelper, String, String, Object)

NodeListViewExtensions.NodeListView Method (HtmlHelper, String, String, Object)
See Also
[image]

Returns a NodeListView by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString NodeListView (
HtmlHelper helper,
string id,
string initFunction,
Object htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function NodeListView( _
helper As HtmlHelper, _
id As String, _
initFunction As String, _
htmlAttributes As Object _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the NodeListView

initFunction

The name of the function that will contain the initializing scripts for the view.

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

NodeListView Method Overload List
NodeListViewExtensions Members
NodeListViewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview Class

Overview Class
[image]

Provides a scaled-down view of a DiagramView contents and lets the user scroll the bound view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public class Overview

Visual Basic [image] Copy Code

Public Class Overview

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Mvc.Overview

See Also

Overview Members
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview Members

Overview Members
Constructors Properties Methods
[image]

Provides a scaled-down view of a DiagramView contents and lets the user scroll the bound view.

The following tables list the members exposed by the Overview type.

Public Constructors

Name | Description
Overview | Overloaded.

Public Properties

Name | Description
AddScriptReferences | Gets or sets a value indicating whether the control should render references to the client scripts.
BackColor | Gets or sets the background color of the overview control.
ClientScriptLocation | Gets or sets the URL to the MindFusion.Diagramming.js file.
ClientSideMode | Gets or sets a value indicating which library will be used in the control's client-side scripts.
DiagramView | Gets or sets the id of the DiagramView.
DimColor | Gets or sets a color of the displayed diagram.
Enabled | Gets or sets a value indicating whether handling of mouse events is enabled.
Height | Gets or sets the height of the view.
Id | Gets or sets the id of the view.
JQueryLocation | Gets or sets the URL to the JQuery script file.
Width | Gets or sets the width of the view.

Public Methods

Name | Description
ControlLoadedScript | Sets the name of a JavaScript function that should be invoked when the control is loaded on the client side.
FromJson | Creates a Overview object from JSON.
FromRequest | Creates an instance of Overview.
Init | Renders the Overview's initializing scripts on a web page under the specified function name.
LoadFromJson | Loads the specified JSON data.
Render | Renders the Overview on a web page.
SaveToJson | Serializes the Overview's data to JSON.
SetAddScriptReferences | Sets a value indicating whether the control should render references to the client scripts.
SetClientSideMode | Sets a value indicating which library will be used in the control's client-side scripts.
SetEnabled | Sets a value indicating whether handling of mouse events is enabled.
SetHeight | Sets the height of the view.
SetWidth | Sets the width of the view.
ToJson | Serializes the Overview's data to JSON.
ToJSON | Serializes the Overview's data to JSON

See Also

Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview Constructor

Overview Constructor
[image]

Overload List

Name | Description
Overview () | Creates an instance of Overview.
Overview (String) | Creates an instance of Overview.
Overview (String, String) | Creates an instance of Overview for a DiagramView.

See Also

Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview Constructor ()

Overview Constructor ()
See Also
[image]

Creates an instance of Overview.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Overview ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Overview Constructor Overload List
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview Constructor (String)

Overview Constructor (String)
See Also
[image]

Creates an instance of Overview.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Overview (
string id
)

Visual Basic [image] Copy Code

Public New ( _
id As String _
)

Parameters

id

See Also

Overview Constructor Overload List
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview Constructor (String, String)

Overview Constructor (String, String)
See Also
[image]

Creates an instance of Overview for a DiagramView.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Overview (
string id,
string diagramViewId
)

Visual Basic [image] Copy Code

Public New ( _
id As String, _
diagramViewId As String _
)

Parameters

id

The Id of the Overview.

diagramViewId

The Id of the DiagramView

See Also

Overview Constructor Overload List
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview Methods

Overview Methods
[image]

Public Methods

Name | Description
ControlLoadedScript | Sets the name of a JavaScript function that should be invoked when the control is loaded on the client side.
FromJson | Creates a Overview object from JSON.
FromRequest | Creates an instance of Overview.
Init | Renders the Overview's initializing scripts on a web page under the specified function name.
LoadFromJson | Loads the specified JSON data.
Render | Renders the Overview on a web page.
SaveToJson | Serializes the Overview's data to JSON.
SetAddScriptReferences | Sets a value indicating whether the control should render references to the client scripts.
SetClientSideMode | Sets a value indicating which library will be used in the control's client-side scripts.
SetEnabled | Sets a value indicating whether handling of mouse events is enabled.
SetHeight | Sets the height of the view.
SetWidth | Sets the width of the view.
ToJson | Serializes the Overview's data to JSON.
ToJSON | Serializes the Overview's data to JSON

See Also

Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview.ControlLoadedScript Method

Overview.ControlLoadedScript Method
[image]

Sets the name of a JavaScript function that should be invoked when the control is loaded on the client side.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Overview ControlLoadedScript (
string value
)

Visual Basic [image] Copy Code

Public Function ControlLoadedScript( _
value As String _
) As Overview

Parameters

value

The name of the function

Return Value

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview.FromJson Method

Overview.FromJson Method
[image]

Creates a Overview object from JSON.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static Overview FromJson (
string json
)

Visual Basic [image] Copy Code

Public Shared Function FromJson( _
json As String _
) As Overview

Parameters

json

The JSON string

Return Value

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview.FromRequest Method

Overview.FromRequest Method
[image]

Creates an instance of Overview.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static Overview FromRequest (
string id,
HttpRequestBase request
)

Visual Basic [image] Copy Code

Public Shared Function FromRequest( _
id As String, _
request As HttpRequestBase _
) As Overview

Parameters

id

The Id of the Overview

request

An HttpRequest object that contains the json data for the view.

Return Value

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview.Init Method

Overview.Init Method
[image]

Renders the Overview's initializing scripts on a web page under the specified function name.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string Init (
string functionName
)

Visual Basic [image] Copy Code

Public Function Init( _
functionName As String _
) As String

Parameters

functionName

Return Value

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview.LoadFromJson Method

Overview.LoadFromJson Method
[image]

Loads the specified JSON data.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public void LoadFromJson (
string json
)

Visual Basic [image] Copy Code

Public Sub LoadFromJson( _
json As String _
)

Parameters

json

The JSON string

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview.Render Method

Overview.Render Method
[image]

Renders the Overview on a web page.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string Render ()

Visual Basic [image] Copy Code

Public Function Render () As String

Return Value

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview.SaveToJson Method

Overview.SaveToJson Method
[image]

Serializes the Overview's data to JSON.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string SaveToJson ()

Visual Basic [image] Copy Code

Public Function SaveToJson () As String

Return Value

The JSON string.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview.SetAddScriptReferences Method

Overview.SetAddScriptReferences Method
[image]

Sets a value indicating whether the control should render references to the client scripts.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Overview SetAddScriptReferences (
bool value
)

Visual Basic [image] Copy Code

Public Function SetAddScriptReferences( _
value As Boolean _
) As Overview

Parameters

value

Return Value

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview.SetClientSideMode Method

Overview.SetClientSideMode Method
[image]

Sets a value indicating which library will be used in the control's client-side scripts.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Overview SetClientSideMode (
ClientSideMode value
)

Visual Basic [image] Copy Code

Public Function SetClientSideMode( _
value As ClientSideMode _
) As Overview

Parameters

value

Return Value

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview.SetEnabled Method

Overview.SetEnabled Method
[image]

Sets a value indicating whether handling of mouse events is enabled.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Overview SetEnabled (
bool value
)

Visual Basic [image] Copy Code

Public Function SetEnabled( _
value As Boolean _
) As Overview

Parameters

value

Return Value

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview.SetHeight Method

Overview.SetHeight Method
[image]

Sets the height of the view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Overview SetHeight (
int value
)

Visual Basic [image] Copy Code

Public Function SetHeight( _
value As Integer _
) As Overview

Parameters

value

The height of the view in pixels

Return Value

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview.SetWidth Method

Overview.SetWidth Method
[image]

Sets the width of the view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Overview SetWidth (
int value
)

Visual Basic [image] Copy Code

Public Function SetWidth( _
value As Integer _
) As Overview

Parameters

value

The width of the view in pixels

Return Value

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview.ToJson Method

Overview.ToJson Method
[image]

Serializes the Overview's data to JSON.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static string ToJson (
Overview view
)

Visual Basic [image] Copy Code

Public Shared Function ToJson( _
view As Overview _
) As String

Parameters

view

Return Value

The JSON string.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview.ToJSON Method

Overview.ToJSON Method
[image]

Serializes the Overview's data to JSON

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string ToJSON ()

Visual Basic [image] Copy Code

Public Function ToJSON () As String

Return Value

The JSON string

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview Properties

Overview Properties
[image]

Public Properties

Name | Description
AddScriptReferences | Gets or sets a value indicating whether the control should render references to the client scripts.
BackColor | Gets or sets the background color of the overview control.
ClientScriptLocation | Gets or sets the URL to the MindFusion.Diagramming.js file.
ClientSideMode | Gets or sets a value indicating which library will be used in the control's client-side scripts.
DiagramView | Gets or sets the id of the DiagramView.
DimColor | Gets or sets a color of the displayed diagram.
Enabled | Gets or sets a value indicating whether handling of mouse events is enabled.
Height | Gets or sets the height of the view.
Id | Gets or sets the id of the view.
JQueryLocation | Gets or sets the URL to the JQuery script file.
Width | Gets or sets the width of the view.

See Also

Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview.AddScriptReferences Property

Overview.AddScriptReferences Property
[image]

Gets or sets a value indicating whether the control should render references to the client scripts.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public bool AddScriptReferences { get; set; }

Visual Basic [image] Copy Code

Public Property AddScriptReferences As Boolean

Property Value

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview.BackColor Property

Overview.BackColor Property
[image]

Gets or sets the background color of the overview control.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Color BackColor { get; set; }

Visual Basic [image] Copy Code

Public Property BackColor As Color

Property Value

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview.ClientScriptLocation Property

Overview.ClientScriptLocation Property
[image]

Gets or sets the URL to the MindFusion.Diagramming.js file.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string ClientScriptLocation { get; set; }

Visual Basic [image] Copy Code

Public Property ClientScriptLocation As String

Property Value

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview.ClientSideMode Property

Overview.ClientSideMode Property
[image]

Gets or sets a value indicating which library will be used in the control's client-side scripts.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ClientSideMode ClientSideMode { get; set; }

Visual Basic [image] Copy Code

Public Property ClientSideMode As ClientSideMode

Property Value

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview.DiagramView Property

Overview.DiagramView Property
[image]

Gets or sets the id of the DiagramView.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string DiagramView { get; set; }

Visual Basic [image] Copy Code

Public Property DiagramView As String

Property Value

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview.DimColor Property

Overview.DimColor Property
[image]

Gets or sets a color of the displayed diagram.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Brush DimColor { get; set; }

Visual Basic [image] Copy Code

Public Property DimColor As Brush

Property Value

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview.Enabled Property

Overview.Enabled Property
[image]

Gets or sets a value indicating whether handling of mouse events is enabled.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public bool Enabled { get; set; }

Visual Basic [image] Copy Code

Public Property Enabled As Boolean

Property Value

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview.Height Property

Overview.Height Property
[image]

Gets or sets the height of the view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public int Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Integer

Property Value

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview.Id Property

Overview.Id Property
[image]

Gets or sets the id of the view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string Id { get; set; }

Visual Basic [image] Copy Code

Public Property Id As String

Property Value

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview.JQueryLocation Property

Overview.JQueryLocation Property
[image]

Gets or sets the URL to the JQuery script file.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string JQueryLocation { get; set; }

Visual Basic [image] Copy Code

Public Property JQueryLocation As String

Property Value

Remarks

This property is used only if ClientSideMode is set to ClientSideMode.JQuery.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.Overview.Width Property

Overview.Width Property
[image]

Gets or sets the width of the view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public int Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Integer

Property Value

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.OverviewExtensions Class

OverviewExtensions Class
[image]

Contains extension methods of Overview.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public sealed class OverviewExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class OverviewExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Mvc.OverviewExtensions

See Also

OverviewExtensions Members
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.OverviewExtensions Members

OverviewExtensions Members
Methods
[image]

Contains extension methods of Overview.

The following tables list the members exposed by the OverviewExtensions type.

Public Methods

Name | Description
Overview | Overloaded. Returns a Overview by using the specified HTML helper.

See Also

OverviewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.OverviewExtensions Methods

OverviewExtensions Methods
[image]

Public Methods

Name | Description
Overview | Overloaded. Returns a Overview by using the specified HTML helper.

See Also

OverviewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.OverviewExtensions.Overview Method

OverviewExtensions.Overview Method
[image]

Returns a Overview by using the specified HTML helper.

Overload List

Name | Description
OverviewExtensions.Overview (HtmlHelper, Overview) | Returns a Overview by using the specified HTML helper.
OverviewExtensions.Overview (HtmlHelper, Overview, IDictionary(String, Object)) | Returns a Overview by using the specified HTML helper.
OverviewExtensions.Overview (HtmlHelper, Overview, Object) | Returns a Overview by using the specified HTML helper.
OverviewExtensions.Overview (HtmlHelper, Overview, String) | Returns a Overview by using the specified HTML helper.
OverviewExtensions.Overview (HtmlHelper, Overview, String, IDictionary(String, Object)) | Returns a Overview by using the specified HTML helper.
OverviewExtensions.Overview (HtmlHelper, Overview, String, Object) | Returns a Overview by using the specified HTML helper.
OverviewExtensions.Overview (HtmlHelper, String, String) | Returns a Overview by using the specified HTML helper.
OverviewExtensions.Overview (HtmlHelper, String, String, IDictionary(String, Object)) | Returns a Overview by using the specified HTML helper.
OverviewExtensions.Overview (HtmlHelper, String, String, Object) | Returns a Overview by using the specified HTML helper.
OverviewExtensions.Overview (HtmlHelper, String, String, String) | Returns a Overview by using the specified HTML helper.
OverviewExtensions.Overview (HtmlHelper, String, String, String, IDictionary(String, Object)) | Returns a Overview by using the specified HTML helper.
OverviewExtensions.Overview (HtmlHelper, String, String, String, Object) | Returns a Overview by using the specified HTML helper.

See Also

OverviewExtensions Members
OverviewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.OverviewExtensions.Overview Method (HtmlHelper, Overview)

OverviewExtensions.Overview Method (HtmlHelper, Overview)
See Also
[image]

Returns a Overview by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString Overview (
HtmlHelper helper,
Overview view
)

Visual Basic [image] Copy Code

Public Shared Function Overview( _
helper As HtmlHelper, _
view As Overview _
) As MvcHtmlString

Parameters

helper

The HTML helper

view

The Overview.

Return Value

See Also

Overview Method Overload List
OverviewExtensions Members
OverviewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.OverviewExtensions.Overview Method (HtmlHelper, Overview, IDictionary(String, Object))

OverviewExtensions.Overview Method (HtmlHelper, Overview, IDictionary(String, Object))
See Also
[image]

Returns a Overview by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString Overview (
HtmlHelper helper,
Overview view,
IDictionary<string, Object> htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function Overview( _
helper As HtmlHelper, _
view As Overview, _
htmlAttributes As IDictionary(Of String, Object) _
) As MvcHtmlString

Parameters

helper

The HTML helper

view

The Overview

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

Overview Method Overload List
OverviewExtensions Members
OverviewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.OverviewExtensions.Overview Method (HtmlHelper, Overview, Object)

OverviewExtensions.Overview Method (HtmlHelper, Overview, Object)
See Also
[image]

Returns a Overview by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString Overview (
HtmlHelper helper,
Overview view,
Object htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function Overview( _
helper As HtmlHelper, _
view As Overview, _
htmlAttributes As Object _
) As MvcHtmlString

Parameters

helper

The HTML helper

view

The Overview

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

Overview Method Overload List
OverviewExtensions Members
OverviewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.OverviewExtensions.Overview Method (HtmlHelper, Overview, String)

OverviewExtensions.Overview Method (HtmlHelper, Overview, String)
See Also
[image]

Returns a Overview by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString Overview (
HtmlHelper helper,
Overview view,
string initFunction
)

Visual Basic [image] Copy Code

Public Shared Function Overview( _
helper As HtmlHelper, _
view As Overview, _
initFunction As String _
) As MvcHtmlString

Parameters

helper

The HTML helper

view

The Overview

initFunction

The name of the function that will contain the initializing scripts for the view.

Return Value

See Also

Overview Method Overload List
OverviewExtensions Members
OverviewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.OverviewExtensions.Overview Method (HtmlHelper, Overview, String, IDictionary(String, Object))

OverviewExtensions.Overview Method (HtmlHelper, Overview, String, IDictionary(String, Object))
See Also
[image]

Returns a Overview by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString Overview (
HtmlHelper helper,
Overview view,
string initFunction,
IDictionary<string, Object> htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function Overview( _
helper As HtmlHelper, _
view As Overview, _
initFunction As String, _
htmlAttributes As IDictionary(Of String, Object) _
) As MvcHtmlString

Parameters

helper

The HTML helper

view

The Overview

initFunction

The name of the function that will contain the initializing scripts for the view.

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

Overview Method Overload List
OverviewExtensions Members
OverviewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.OverviewExtensions.Overview Method (HtmlHelper, Overview, String, Object)

OverviewExtensions.Overview Method (HtmlHelper, Overview, String, Object)
See Also
[image]

Returns a Overview by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString Overview (
HtmlHelper helper,
Overview view,
string initFunction,
Object htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function Overview( _
helper As HtmlHelper, _
view As Overview, _
initFunction As String, _
htmlAttributes As Object _
) As MvcHtmlString

Parameters

helper

The HTML helper

view

The Overview

initFunction

The name of the function that will contain the initializing scripts for the view.

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

Overview Method Overload List
OverviewExtensions Members
OverviewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.OverviewExtensions.Overview Method (HtmlHelper, String, String)

OverviewExtensions.Overview Method (HtmlHelper, String, String)
See Also
[image]

Returns a Overview by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString Overview (
HtmlHelper helper,
string id,
string diagramViewId
)

Visual Basic [image] Copy Code

Public Shared Function Overview( _
helper As HtmlHelper, _
id As String, _
diagramViewId As String _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the Overview.

diagramViewId

The Id of the DiagramView

Return Value

See Also

Overview Method Overload List
OverviewExtensions Members
OverviewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.OverviewExtensions.Overview Method (HtmlHelper, String, String, IDictionary(String, Object))

OverviewExtensions.Overview Method (HtmlHelper, String, String, IDictionary(String, Object))
See Also
[image]

Returns a Overview by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString Overview (
HtmlHelper helper,
string id,
string diagramViewId,
IDictionary<string, Object> htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function Overview( _
helper As HtmlHelper, _
id As String, _
diagramViewId As String, _
htmlAttributes As IDictionary(Of String, Object) _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the Overview

diagramViewId

The Id of the DiagramView

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

Overview Method Overload List
OverviewExtensions Members
OverviewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.OverviewExtensions.Overview Method (HtmlHelper, String, String, Object)

OverviewExtensions.Overview Method (HtmlHelper, String, String, Object)
See Also
[image]

Returns a Overview by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString Overview (
HtmlHelper helper,
string id,
string diagramViewId,
Object htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function Overview( _
helper As HtmlHelper, _
id As String, _
diagramViewId As String, _
htmlAttributes As Object _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the Overview

diagramViewId

The Id of the DiagramView

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

Overview Method Overload List
OverviewExtensions Members
OverviewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.OverviewExtensions.Overview Method (HtmlHelper, String, String, String)

OverviewExtensions.Overview Method (HtmlHelper, String, String, String)
See Also
[image]

Returns a Overview by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString Overview (
HtmlHelper helper,
string id,
string diagramViewId,
string initFunction
)

Visual Basic [image] Copy Code

Public Shared Function Overview( _
helper As HtmlHelper, _
id As String, _
diagramViewId As String, _
initFunction As String _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the Overview

diagramViewId

The Id of the DiagramView

initFunction

The name of the function that will contain the initializing scripts for the view.

Return Value

See Also

Overview Method Overload List
OverviewExtensions Members
OverviewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.OverviewExtensions.Overview Method (HtmlHelper, String, String, String, IDictionary(String, Object))

OverviewExtensions.Overview Method (HtmlHelper, String, String, String, IDictionary(String, Object))
See Also
[image]

Returns a Overview by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString Overview (
HtmlHelper helper,
string id,
string diagramViewId,
string initFunction,
IDictionary<string, Object> htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function Overview( _
helper As HtmlHelper, _
id As String, _
diagramViewId As String, _
initFunction As String, _
htmlAttributes As IDictionary(Of String, Object) _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the Overview

diagramViewId

The Id of the DiagramView

initFunction

The name of the function that will contain the initializing scripts for the view.

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

Overview Method Overload List
OverviewExtensions Members
OverviewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.OverviewExtensions.Overview Method (HtmlHelper, String, String, String, Object)

OverviewExtensions.Overview Method (HtmlHelper, String, String, String, Object)
See Also
[image]

Returns a Overview by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString Overview (
HtmlHelper helper,
string id,
string diagramViewId,
string initFunction,
Object htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function Overview( _
helper As HtmlHelper, _
id As String, _
diagramViewId As String, _
initFunction As String, _
htmlAttributes As Object _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the Overview

diagramViewId

The Id of the DiagramView

initFunction

The name of the function that will contain the initializing scripts for the view.

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

Overview Method Overload List
OverviewExtensions Members
OverviewExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ShapeNodeConverter Class

ShapeNodeConverter Class
[image]

Serializes ShapeNode instances.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public class ShapeNodeConverter : DiagramNodeConverter

Visual Basic [image] Copy Code

Public Class ShapeNodeConverter
Inherits DiagramNodeConverter

Inheritance Hierarchy

System.Object
System.Web.Script.Serialization.JavaScriptConverter
MindFusion.Diagramming.Mvc.DiagramItemConverter
MindFusion.Diagramming.Mvc.DiagramNodeConverter
MindFusion.Diagramming.Mvc.ShapeNodeConverter

See Also

ShapeNodeConverter Members
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ShapeNodeConverter Members

ShapeNodeConverter Members
Constructors Properties Methods
[image]

Serializes ShapeNode instances.

The following tables list the members exposed by the ShapeNodeConverter type.

Public Constructors

Name | Description
ShapeNodeConverter | Creates a new instance of the ShapeNodeConverter class.

Public Properties

Name | Description
SupportedTypes | SupportedTypes override.

Public Methods

Name | Description
Deserialize | Deserialize override.
Serialize | Serialize override.

See Also

ShapeNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ShapeNodeConverter Constructor

ShapeNodeConverter Constructor
[image]

Creates a new instance of the ShapeNodeConverter class.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ShapeNodeConverter (
DiagramView view
)

Visual Basic [image] Copy Code

Public New ( _
view As DiagramView _
)

Parameters

view

See Also

ShapeNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ShapeNodeConverter Methods

ShapeNodeConverter Methods
[image]

Public Methods

Name | Description
Deserialize | Deserialize override.
Serialize | Serialize override.

See Also

ShapeNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ShapeNodeConverter.Deserialize Method

ShapeNodeConverter.Deserialize Method
[image]

Deserialize override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override Object Deserialize (
IDictionary<string, Object> dictionary,
Type type,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Deserialize( _
dictionary As IDictionary(Of String, Object), _
type As Type, _
serializer As JavaScriptSerializer _
) As Object

Parameters

dictionary

type

serializer

Return Value

See Also

ShapeNodeConverter Members
ShapeNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ShapeNodeConverter.Serialize Method

ShapeNodeConverter.Serialize Method
[image]

Serialize override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override IDictionary<string, Object> Serialize (
Object obj,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Serialize( _
obj As Object, _
serializer As JavaScriptSerializer _
) As IDictionary(Of String, Object)

Parameters

obj

serializer

Return Value

See Also

ShapeNodeConverter Members
ShapeNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ShapeNodeConverter Properties

ShapeNodeConverter Properties
[image]

Public Properties

Name | Description
SupportedTypes | SupportedTypes override.

See Also

ShapeNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ShapeNodeConverter.SupportedTypes Property

ShapeNodeConverter.SupportedTypes Property
[image]

SupportedTypes override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override IEnumerable<Type> SupportedTypes { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property SupportedTypes As IEnumerable(Of Type)

Property Value

See Also

ShapeNodeConverter Members
ShapeNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.SvgNodeConverter Class

SvgNodeConverter Class
[image]

Serializes SvgNode instances.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public class SvgNodeConverter : DiagramNodeConverter

Visual Basic [image] Copy Code

Public Class SvgNodeConverter
Inherits DiagramNodeConverter

Inheritance Hierarchy

System.Object
System.Web.Script.Serialization.JavaScriptConverter
MindFusion.Diagramming.Mvc.DiagramItemConverter
MindFusion.Diagramming.Mvc.DiagramNodeConverter
MindFusion.Diagramming.Mvc.SvgNodeConverter

See Also

SvgNodeConverter Members
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.SvgNodeConverter Members

SvgNodeConverter Members
Constructors Properties Methods
[image]

Serializes SvgNode instances.

The following tables list the members exposed by the SvgNodeConverter type.

Public Constructors

Name | Description
SvgNodeConverter | Creates a new instance of the SvgNodeConverter class.

Public Properties

Name | Description
SupportedTypes | SupportedTypes override.

Public Methods

Name | Description
Deserialize | Deserialize override.
Serialize | Serialize override.

See Also

SvgNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.SvgNodeConverter Constructor

SvgNodeConverter Constructor
[image]

Creates a new instance of the SvgNodeConverter class.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public SvgNodeConverter (
DiagramView view
)

Visual Basic [image] Copy Code

Public New ( _
view As DiagramView _
)

Parameters

view

See Also

SvgNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.SvgNodeConverter Methods

SvgNodeConverter Methods
[image]

Public Methods

Name | Description
Deserialize | Deserialize override.
Serialize | Serialize override.

See Also

SvgNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.SvgNodeConverter.Deserialize Method

SvgNodeConverter.Deserialize Method
[image]

Deserialize override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override Object Deserialize (
IDictionary<string, Object> dictionary,
Type type,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Deserialize( _
dictionary As IDictionary(Of String, Object), _
type As Type, _
serializer As JavaScriptSerializer _
) As Object

Parameters

dictionary

type

serializer

Return Value

See Also

SvgNodeConverter Members
SvgNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.SvgNodeConverter.Serialize Method

SvgNodeConverter.Serialize Method
[image]

Serialize override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override IDictionary<string, Object> Serialize (
Object obj,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Serialize( _
obj As Object, _
serializer As JavaScriptSerializer _
) As IDictionary(Of String, Object)

Parameters

obj

serializer

Return Value

See Also

SvgNodeConverter Members
SvgNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.SvgNodeConverter Properties

SvgNodeConverter Properties
[image]

Public Properties

Name | Description
SupportedTypes | SupportedTypes override.

See Also

SvgNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.SvgNodeConverter.SupportedTypes Property

SvgNodeConverter.SupportedTypes Property
[image]

SupportedTypes override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override IEnumerable<Type> SupportedTypes { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property SupportedTypes As IEnumerable(Of Type)

Property Value

See Also

SvgNodeConverter Members
SvgNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.TableNodeConverter Class

TableNodeConverter Class
[image]

Serializes TableNode instances.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public class TableNodeConverter : DiagramNodeConverter

Visual Basic [image] Copy Code

Public Class TableNodeConverter
Inherits DiagramNodeConverter

Inheritance Hierarchy

System.Object
System.Web.Script.Serialization.JavaScriptConverter
MindFusion.Diagramming.Mvc.DiagramItemConverter
MindFusion.Diagramming.Mvc.DiagramNodeConverter
MindFusion.Diagramming.Mvc.TableNodeConverter

See Also

TableNodeConverter Members
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.TableNodeConverter Members

TableNodeConverter Members
Constructors Properties Methods
[image]

Serializes TableNode instances.

The following tables list the members exposed by the TableNodeConverter type.

Public Constructors

Name | Description
TableNodeConverter | Creates a new instance of the TableNodeConverter class.

Public Properties

Name | Description
SupportedTypes | SupportedTypes override.

Public Methods

Name | Description
Deserialize | Deserialize override.
Serialize | Serialize override.

See Also

TableNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.TableNodeConverter Constructor

TableNodeConverter Constructor
[image]

Creates a new instance of the TableNodeConverter class.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public TableNodeConverter (
DiagramView view
)

Visual Basic [image] Copy Code

Public New ( _
view As DiagramView _
)

Parameters

view

See Also

TableNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.TableNodeConverter Methods

TableNodeConverter Methods
[image]

Public Methods

Name | Description
Deserialize | Deserialize override.
Serialize | Serialize override.

See Also

TableNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.TableNodeConverter.Deserialize Method

TableNodeConverter.Deserialize Method
[image]

Deserialize override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override Object Deserialize (
IDictionary<string, Object> dictionary,
Type type,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Deserialize( _
dictionary As IDictionary(Of String, Object), _
type As Type, _
serializer As JavaScriptSerializer _
) As Object

Parameters

dictionary

type

serializer

Return Value

See Also

TableNodeConverter Members
TableNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.TableNodeConverter.Serialize Method

TableNodeConverter.Serialize Method
[image]

Serialize override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override IDictionary<string, Object> Serialize (
Object obj,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Serialize( _
obj As Object, _
serializer As JavaScriptSerializer _
) As IDictionary(Of String, Object)

Parameters

obj

serializer

Return Value

See Also

TableNodeConverter Members
TableNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.TableNodeConverter Properties

TableNodeConverter Properties
[image]

Public Properties

Name | Description
SupportedTypes | SupportedTypes override.

See Also

TableNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.TableNodeConverter.SupportedTypes Property

TableNodeConverter.SupportedTypes Property
[image]

SupportedTypes override.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public override IEnumerable<Type> SupportedTypes { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property SupportedTypes As IEnumerable(Of Type)

Property Value

See Also

TableNodeConverter Members
TableNodeConverter Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.TickPosition Enumeration

TickPosition Enumeration
[image]

Specifies the position of trackbar ticks.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public enum TickPosition

Visual Basic [image] Copy Code

Public Enum TickPosition

Members

Member name | Description
None | There are no ticks rendered.
Left | Ticks are rendered on the left side of the trackbar.
Right | Ticks are rendered on the right side of the trackbar.
Both | Ticks are rendered on both sides of the trackbar.

See Also

MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl Class

ZoomControl Class
[image]

ZoomControl lets users zoom and pan a target DiagramView interactively.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public class ZoomControl

Visual Basic [image] Copy Code

Public Class ZoomControl

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Mvc.ZoomControl

See Also

ZoomControl Members
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl Members

ZoomControl Members
Constructors Properties Methods
[image]

ZoomControl lets users zoom and pan a target DiagramView interactively.

The following tables list the members exposed by the ZoomControl type.

Public Constructors

Name | Description
ZoomControl | Overloaded.

Public Properties

Name | Description
ActiveColor | Gets or sets the color used to render depressed buttons.
AddScriptReferences | Gets or sets a value indicating whether the control should render references to the client scripts.
BackColor | Gets or sets the background color of the control.
BorderColor | Gets or sets the color of ZoomControl elements' borders.
ClientScriptLocation | Gets or sets the URL to the MindFusion.Diagramming.js file.
ClientSideMode | Gets or sets a value indicating which library will be used in the control's client-side scripts.
CornerRadius | Gets or sets the corner radius of rounded child elements.
Enabled | Gets or sets a value indicating whether handling of mouse events is enabled.
Fill | Gets or sets the brush used to fill the ZoomControl elements.
Height | Gets or sets the height of the control.
Id | Gets or sets the id of the view.
InnerColor | Gets or sets the color of plus, minus and arrow icons.
JQueryLocation | Gets or sets the URL to the JQuery script file.
MaxZoomFactor | The maximum zoom level allowed to set through this control.
MinZoomFactor | The minimum zoom level allowed to set through this control.
Padding | Gets or sets the padding of the control's contents.
ScrollStep | Gets or sets the scroll offset added when users click the pan arrows.
ShadowColor | Gets or sets the shadow color.
ShowLabel | Gets or sets a value indicating whether the label that shows the current zoom level should be visible.
SnapToZoomStep | Gets or sets a value indicating whether the trackbar should snap to ZoomStep values when dragged.
TargetId | Gets or sets the id of the target view.
TextColor | Gets or sets the brush of the the label that shows the current zoom level.
TickPosition | Gets or sets the current tick position of the trackbar.
Width | Gets or sets the width of the control.
ZoomFactor | Gets or sets the current zoom level.
ZoomStep | Gets or sets the amount by which to change zoom level when + and - buttons are clicked.

Public Methods

Name | Description
FromJson | Creates a ZoomControl object from JSON.
FromRequest | Creates an instance of ZoomControl.
Init | Renders the ZoomControl's initializing scripts on a web page under the specified function name.
LoadFromJson | Loads the specified JSON data.
Render | Renders the ZoomControl on a web page.
SaveToJson | Serializes the ZoomControl's data to JSON.
SetActiveColor | Sets the color used to render depressed buttons.
SetAddScriptReferences | Sets a value indicating whether the control should render references to the client scripts.
SetBackColor | Sets the background color of the control.
SetBorderColor | Sets the color of ZoomControl elements' borders.
SetClientSideMode | Sets a value indicating which library will be used in the control's client-side scripts.
SetCornerRadius | Sets the corner radius of rounded child elements.
SetEnabled | Sets a value indicating whether handling of mouse events is enabled.
SetFill | Sets the brush used to fill the ZoomControl elements.
SetHeight | Sets the height of the view.
SetInnerColor | Sets the color of plus, minus and arrow icons.
SetMaxZoomFactor | Sets the maximum zoom level allowed to set through this control.
SetMinZoomFactor | Sets the minimum zoom level allowed to set through this control.
SetPadding | Sets the padding of the control's contents.
SetScrollStep | Sets the scroll offset added when users click the pan arrows.
SetShadowColor | Sets the shadow color.
SetShowLabel | Sets a value indicating whether the label that shows the current zoom level should be visible.
SetSnapToZoomStep | Sets a value indicating whether the trackbar should snap to ZoomStep values when dragged.
SetTargetId | Sets the id of the target view.
SetTextColor | Sets the brush of the the label that shows the current zoom level.
SetTickPosition | Sets the current tick position of the trackbar.
SetWidth | Sets the width of the view.
SetZoomFactor | Sets the id of the target view.
SetZoomStep | Sets the amount by which to change zoom level when + and - buttons are clicked.
ToJson | Serializes the ZoomControl's data to JSON.

See Also

ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl Constructor

ZoomControl Constructor
[image]

Overload List

Name | Description
ZoomControl () | Creates an instance of ZoomControl.
ZoomControl (String) | Creates an instance of ZoomControl.
ZoomControl (String, String) | Creates an instance of ZoomControl for a target view.

See Also

ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl Constructor ()

ZoomControl Constructor ()
See Also
[image]

Creates an instance of ZoomControl.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ZoomControl ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ZoomControl Constructor Overload List
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl Constructor (String)

ZoomControl Constructor (String)
See Also
[image]

Creates an instance of ZoomControl.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ZoomControl (
string id
)

Visual Basic [image] Copy Code

Public New ( _
id As String _
)

Parameters

id

See Also

ZoomControl Constructor Overload List
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl Constructor (String, String)

ZoomControl Constructor (String, String)
See Also
[image]

Creates an instance of ZoomControl for a target view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ZoomControl (
string id,
string targetId
)

Visual Basic [image] Copy Code

Public New ( _
id As String, _
targetId As String _
)

Parameters

id

The Id of the ZoomControl

targetId

The Id of the target DiagramView

See Also

ZoomControl Constructor Overload List
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl Methods

ZoomControl Methods
[image]

Public Methods

Name | Description
FromJson | Creates a ZoomControl object from JSON.
FromRequest | Creates an instance of ZoomControl.
Init | Renders the ZoomControl's initializing scripts on a web page under the specified function name.
LoadFromJson | Loads the specified JSON data.
Render | Renders the ZoomControl on a web page.
SaveToJson | Serializes the ZoomControl's data to JSON.
SetActiveColor | Sets the color used to render depressed buttons.
SetAddScriptReferences | Sets a value indicating whether the control should render references to the client scripts.
SetBackColor | Sets the background color of the control.
SetBorderColor | Sets the color of ZoomControl elements' borders.
SetClientSideMode | Sets a value indicating which library will be used in the control's client-side scripts.
SetCornerRadius | Sets the corner radius of rounded child elements.
SetEnabled | Sets a value indicating whether handling of mouse events is enabled.
SetFill | Sets the brush used to fill the ZoomControl elements.
SetHeight | Sets the height of the view.
SetInnerColor | Sets the color of plus, minus and arrow icons.
SetMaxZoomFactor | Sets the maximum zoom level allowed to set through this control.
SetMinZoomFactor | Sets the minimum zoom level allowed to set through this control.
SetPadding | Sets the padding of the control's contents.
SetScrollStep | Sets the scroll offset added when users click the pan arrows.
SetShadowColor | Sets the shadow color.
SetShowLabel | Sets a value indicating whether the label that shows the current zoom level should be visible.
SetSnapToZoomStep | Sets a value indicating whether the trackbar should snap to ZoomStep values when dragged.
SetTargetId | Sets the id of the target view.
SetTextColor | Sets the brush of the the label that shows the current zoom level.
SetTickPosition | Sets the current tick position of the trackbar.
SetWidth | Sets the width of the view.
SetZoomFactor | Sets the id of the target view.
SetZoomStep | Sets the amount by which to change zoom level when + and - buttons are clicked.
ToJson | Serializes the ZoomControl's data to JSON.

See Also

ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.FromJson Method

ZoomControl.FromJson Method
[image]

Creates a ZoomControl object from JSON.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static ZoomControl FromJson (
string json
)

Visual Basic [image] Copy Code

Public Shared Function FromJson( _
json As String _
) As ZoomControl

Parameters

json

The JSON string

Return Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.FromRequest Method

ZoomControl.FromRequest Method
[image]

Creates an instance of ZoomControl.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static ZoomControl FromRequest (
string id,
HttpRequestBase request
)

Visual Basic [image] Copy Code

Public Shared Function FromRequest( _
id As String, _
request As HttpRequestBase _
) As ZoomControl

Parameters

id

The Id of the ZoomControl

request

An HttpRequest object that contains the json data for the view.

Return Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.Init Method

ZoomControl.Init Method
[image]

Renders the ZoomControl's initializing scripts on a web page under the specified function name.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string Init (
string functionName
)

Visual Basic [image] Copy Code

Public Function Init( _
functionName As String _
) As String

Parameters

functionName

Return Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.LoadFromJson Method

ZoomControl.LoadFromJson Method
[image]

Loads the specified JSON data.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public void LoadFromJson (
string json
)

Visual Basic [image] Copy Code

Public Sub LoadFromJson( _
json As String _
)

Parameters

json

The JSON string

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.Render Method

ZoomControl.Render Method
[image]

Renders the ZoomControl on a web page.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string Render ()

Visual Basic [image] Copy Code

Public Function Render () As String

Return Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.SaveToJson Method

ZoomControl.SaveToJson Method
[image]

Serializes the ZoomControl's data to JSON.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string SaveToJson ()

Visual Basic [image] Copy Code

Public Function SaveToJson () As String

Return Value

The JSON string.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.SetActiveColor Method

ZoomControl.SetActiveColor Method
[image]

Sets the color used to render depressed buttons.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ZoomControl SetActiveColor (
Color value
)

Visual Basic [image] Copy Code

Public Function SetActiveColor( _
value As Color _
) As ZoomControl

Parameters

value

Return Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.SetAddScriptReferences Method

ZoomControl.SetAddScriptReferences Method
[image]

Sets a value indicating whether the control should render references to the client scripts.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ZoomControl SetAddScriptReferences (
bool value
)

Visual Basic [image] Copy Code

Public Function SetAddScriptReferences( _
value As Boolean _
) As ZoomControl

Parameters

value

Return Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.SetBackColor Method

ZoomControl.SetBackColor Method
[image]

Sets the background color of the control.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ZoomControl SetBackColor (
Color value
)

Visual Basic [image] Copy Code

Public Function SetBackColor( _
value As Color _
) As ZoomControl

Parameters

value

Return Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.SetBorderColor Method

ZoomControl.SetBorderColor Method
[image]

Sets the color of ZoomControl elements' borders.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ZoomControl SetBorderColor (
Color value
)

Visual Basic [image] Copy Code

Public Function SetBorderColor( _
value As Color _
) As ZoomControl

Parameters

value

Return Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.SetClientSideMode Method

ZoomControl.SetClientSideMode Method
[image]

Sets a value indicating which library will be used in the control's client-side scripts.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ZoomControl SetClientSideMode (
ClientSideMode value
)

Visual Basic [image] Copy Code

Public Function SetClientSideMode( _
value As ClientSideMode _
) As ZoomControl

Parameters

value

Return Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.SetCornerRadius Method

ZoomControl.SetCornerRadius Method
[image]

Sets the corner radius of rounded child elements.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ZoomControl SetCornerRadius (
int value
)

Visual Basic [image] Copy Code

Public Function SetCornerRadius( _
value As Integer _
) As ZoomControl

Parameters

value

Return Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.SetEnabled Method

ZoomControl.SetEnabled Method
[image]

Sets a value indicating whether handling of mouse events is enabled.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ZoomControl SetEnabled (
bool value
)

Visual Basic [image] Copy Code

Public Function SetEnabled( _
value As Boolean _
) As ZoomControl

Parameters

value

Return Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.SetFill Method

ZoomControl.SetFill Method
[image]

Sets the brush used to fill the ZoomControl elements.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ZoomControl SetFill (
Brush value
)

Visual Basic [image] Copy Code

Public Function SetFill( _
value As Brush _
) As ZoomControl

Parameters

value

Return Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.SetHeight Method

ZoomControl.SetHeight Method
[image]

Sets the height of the view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ZoomControl SetHeight (
int value
)

Visual Basic [image] Copy Code

Public Function SetHeight( _
value As Integer _
) As ZoomControl

Parameters

value

The height of the view in pixels

Return Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.SetInnerColor Method

ZoomControl.SetInnerColor Method
[image]

Sets the color of plus, minus and arrow icons.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ZoomControl SetInnerColor (
Color value
)

Visual Basic [image] Copy Code

Public Function SetInnerColor( _
value As Color _
) As ZoomControl

Parameters

value

Return Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.SetMaxZoomFactor Method

ZoomControl.SetMaxZoomFactor Method
[image]

Sets the maximum zoom level allowed to set through this control.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ZoomControl SetMaxZoomFactor (
double value
)

Visual Basic [image] Copy Code

Public Function SetMaxZoomFactor( _
value As Double _
) As ZoomControl

Parameters

value

Return Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.SetMinZoomFactor Method

ZoomControl.SetMinZoomFactor Method
[image]

Sets the minimum zoom level allowed to set through this control.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ZoomControl SetMinZoomFactor (
double value
)

Visual Basic [image] Copy Code

Public Function SetMinZoomFactor( _
value As Double _
) As ZoomControl

Parameters

value

Return Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.SetPadding Method

ZoomControl.SetPadding Method
[image]

Sets the padding of the control's contents.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ZoomControl SetPadding (
int value
)

Visual Basic [image] Copy Code

Public Function SetPadding( _
value As Integer _
) As ZoomControl

Parameters

value

Return Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.SetScrollStep Method

ZoomControl.SetScrollStep Method
[image]

Sets the scroll offset added when users click the pan arrows.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ZoomControl SetScrollStep (
double value
)

Visual Basic [image] Copy Code

Public Function SetScrollStep( _
value As Double _
) As ZoomControl

Parameters

value

Return Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.SetShadowColor Method

ZoomControl.SetShadowColor Method
[image]

Sets the shadow color.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ZoomControl SetShadowColor (
Color value
)

Visual Basic [image] Copy Code

Public Function SetShadowColor( _
value As Color _
) As ZoomControl

Parameters

value

Return Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.SetShowLabel Method

ZoomControl.SetShowLabel Method
[image]

Sets a value indicating whether the label that shows the current zoom level should be visible.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ZoomControl SetShowLabel (
bool value
)

Visual Basic [image] Copy Code

Public Function SetShowLabel( _
value As Boolean _
) As ZoomControl

Parameters

value

Return Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.SetSnapToZoomStep Method

ZoomControl.SetSnapToZoomStep Method
[image]

Sets a value indicating whether the trackbar should snap to ZoomStep values when dragged.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ZoomControl SetSnapToZoomStep (
bool value
)

Visual Basic [image] Copy Code

Public Function SetSnapToZoomStep( _
value As Boolean _
) As ZoomControl

Parameters

value

Return Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.SetTargetId Method

ZoomControl.SetTargetId Method
[image]

Sets the id of the target view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ZoomControl SetTargetId (
string value
)

Visual Basic [image] Copy Code

Public Function SetTargetId( _
value As String _
) As ZoomControl

Parameters

value

Return Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.SetTextColor Method

ZoomControl.SetTextColor Method
[image]

Sets the brush of the the label that shows the current zoom level.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ZoomControl SetTextColor (
Color value
)

Visual Basic [image] Copy Code

Public Function SetTextColor( _
value As Color _
) As ZoomControl

Parameters

value

Return Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.SetTickPosition Method

ZoomControl.SetTickPosition Method
[image]

Sets the current tick position of the trackbar.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ZoomControl SetTickPosition (
TickPosition value
)

Visual Basic [image] Copy Code

Public Function SetTickPosition( _
value As TickPosition _
) As ZoomControl

Parameters

value

Return Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.SetWidth Method

ZoomControl.SetWidth Method
[image]

Sets the width of the view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ZoomControl SetWidth (
int value
)

Visual Basic [image] Copy Code

Public Function SetWidth( _
value As Integer _
) As ZoomControl

Parameters

value

The width of the view in pixels

Return Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.SetZoomFactor Method

ZoomControl.SetZoomFactor Method
[image]

Sets the id of the target view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ZoomControl SetZoomFactor (
double value
)

Visual Basic [image] Copy Code

Public Function SetZoomFactor( _
value As Double _
) As ZoomControl

Parameters

value

Return Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.SetZoomStep Method

ZoomControl.SetZoomStep Method
[image]

Sets the amount by which to change zoom level when + and - buttons are clicked.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ZoomControl SetZoomStep (
double value
)

Visual Basic [image] Copy Code

Public Function SetZoomStep( _
value As Double _
) As ZoomControl

Parameters

value

Return Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.ToJson Method

ZoomControl.ToJson Method
[image]

Serializes the ZoomControl's data to JSON.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static string ToJson (
ZoomControl view
)

Visual Basic [image] Copy Code

Public Shared Function ToJson( _
view As ZoomControl _
) As String

Parameters

view

Return Value

The JSON string.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl Properties

ZoomControl Properties
[image]

Public Properties

Name | Description
ActiveColor | Gets or sets the color used to render depressed buttons.
AddScriptReferences | Gets or sets a value indicating whether the control should render references to the client scripts.
BackColor | Gets or sets the background color of the control.
BorderColor | Gets or sets the color of ZoomControl elements' borders.
ClientScriptLocation | Gets or sets the URL to the MindFusion.Diagramming.js file.
ClientSideMode | Gets or sets a value indicating which library will be used in the control's client-side scripts.
CornerRadius | Gets or sets the corner radius of rounded child elements.
Enabled | Gets or sets a value indicating whether handling of mouse events is enabled.
Fill | Gets or sets the brush used to fill the ZoomControl elements.
Height | Gets or sets the height of the control.
Id | Gets or sets the id of the view.
InnerColor | Gets or sets the color of plus, minus and arrow icons.
JQueryLocation | Gets or sets the URL to the JQuery script file.
MaxZoomFactor | The maximum zoom level allowed to set through this control.
MinZoomFactor | The minimum zoom level allowed to set through this control.
Padding | Gets or sets the padding of the control's contents.
ScrollStep | Gets or sets the scroll offset added when users click the pan arrows.
ShadowColor | Gets or sets the shadow color.
ShowLabel | Gets or sets a value indicating whether the label that shows the current zoom level should be visible.
SnapToZoomStep | Gets or sets a value indicating whether the trackbar should snap to ZoomStep values when dragged.
TargetId | Gets or sets the id of the target view.
TextColor | Gets or sets the brush of the the label that shows the current zoom level.
TickPosition | Gets or sets the current tick position of the trackbar.
Width | Gets or sets the width of the control.
ZoomFactor | Gets or sets the current zoom level.
ZoomStep | Gets or sets the amount by which to change zoom level when + and - buttons are clicked.

See Also

ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.ActiveColor Property

ZoomControl.ActiveColor Property
[image]

Gets or sets the color used to render depressed buttons.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Color ActiveColor { get; set; }

Visual Basic [image] Copy Code

Public Property ActiveColor As Color

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.AddScriptReferences Property

ZoomControl.AddScriptReferences Property
[image]

Gets or sets a value indicating whether the control should render references to the client scripts.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public bool AddScriptReferences { get; set; }

Visual Basic [image] Copy Code

Public Property AddScriptReferences As Boolean

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.BackColor Property

ZoomControl.BackColor Property
[image]

Gets or sets the background color of the control.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Color BackColor { get; set; }

Visual Basic [image] Copy Code

Public Property BackColor As Color

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.BorderColor Property

ZoomControl.BorderColor Property
[image]

Gets or sets the color of ZoomControl elements' borders.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Color BorderColor { get; set; }

Visual Basic [image] Copy Code

Public Property BorderColor As Color

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.ClientScriptLocation Property

ZoomControl.ClientScriptLocation Property
[image]

Gets or sets the URL to the MindFusion.Diagramming.js file.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string ClientScriptLocation { get; set; }

Visual Basic [image] Copy Code

Public Property ClientScriptLocation As String

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.ClientSideMode Property

ZoomControl.ClientSideMode Property
[image]

Gets or sets a value indicating which library will be used in the control's client-side scripts.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public ClientSideMode ClientSideMode { get; set; }

Visual Basic [image] Copy Code

Public Property ClientSideMode As ClientSideMode

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.CornerRadius Property

ZoomControl.CornerRadius Property
[image]

Gets or sets the corner radius of rounded child elements.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public int CornerRadius { get; set; }

Visual Basic [image] Copy Code

Public Property CornerRadius As Integer

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.Enabled Property

ZoomControl.Enabled Property
[image]

Gets or sets a value indicating whether handling of mouse events is enabled.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public bool Enabled { get; set; }

Visual Basic [image] Copy Code

Public Property Enabled As Boolean

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.Fill Property

ZoomControl.Fill Property
[image]

Gets or sets the brush used to fill the ZoomControl elements.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Brush Fill { get; set; }

Visual Basic [image] Copy Code

Public Property Fill As Brush

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.Height Property

ZoomControl.Height Property
[image]

Gets or sets the height of the control.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public int Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Integer

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.Id Property

ZoomControl.Id Property
[image]

Gets or sets the id of the view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string Id { get; set; }

Visual Basic [image] Copy Code

Public Property Id As String

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.InnerColor Property

ZoomControl.InnerColor Property
[image]

Gets or sets the color of plus, minus and arrow icons.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Color InnerColor { get; set; }

Visual Basic [image] Copy Code

Public Property InnerColor As Color

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.JQueryLocation Property

ZoomControl.JQueryLocation Property
[image]

Gets or sets the URL to the JQuery script file.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string JQueryLocation { get; set; }

Visual Basic [image] Copy Code

Public Property JQueryLocation As String

Property Value

Remarks

This property is used only if ClientSideMode is set to ClientSideMode.JQuery.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.MaxZoomFactor Property

ZoomControl.MaxZoomFactor Property
[image]

The maximum zoom level allowed to set through this control.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public double MaxZoomFactor { get; set; }

Visual Basic [image] Copy Code

Public Property MaxZoomFactor As Double

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.MinZoomFactor Property

ZoomControl.MinZoomFactor Property
[image]

The minimum zoom level allowed to set through this control.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public double MinZoomFactor { get; set; }

Visual Basic [image] Copy Code

Public Property MinZoomFactor As Double

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.Padding Property

ZoomControl.Padding Property
[image]

Gets or sets the padding of the control's contents.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public int Padding { get; set; }

Visual Basic [image] Copy Code

Public Property Padding As Integer

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.ScrollStep Property

ZoomControl.ScrollStep Property
[image]

Gets or sets the scroll offset added when users click the pan arrows.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public double ScrollStep { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollStep As Double

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.ShadowColor Property

ZoomControl.ShadowColor Property
[image]

Gets or sets the shadow color.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Color ShadowColor { get; set; }

Visual Basic [image] Copy Code

Public Property ShadowColor As Color

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.ShowLabel Property

ZoomControl.ShowLabel Property
[image]

Gets or sets a value indicating whether the label that shows the current zoom level should be visible.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public bool ShowLabel { get; set; }

Visual Basic [image] Copy Code

Public Property ShowLabel As Boolean

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.SnapToZoomStep Property

ZoomControl.SnapToZoomStep Property
[image]

Gets or sets a value indicating whether the trackbar should snap to ZoomStep values when dragged.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public bool SnapToZoomStep { get; set; }

Visual Basic [image] Copy Code

Public Property SnapToZoomStep As Boolean

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.TargetId Property

ZoomControl.TargetId Property
[image]

Gets or sets the id of the target view.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public string TargetId { get; set; }

Visual Basic [image] Copy Code

Public Property TargetId As String

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.TextColor Property

ZoomControl.TextColor Property
[image]

Gets or sets the brush of the the label that shows the current zoom level.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public Color TextColor { get; set; }

Visual Basic [image] Copy Code

Public Property TextColor As Color

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.TickPosition Property

ZoomControl.TickPosition Property
[image]

Gets or sets the current tick position of the trackbar.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public TickPosition TickPosition { get; set; }

Visual Basic [image] Copy Code

Public Property TickPosition As TickPosition

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.Width Property

ZoomControl.Width Property
[image]

Gets or sets the width of the control.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public int Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Integer

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.ZoomFactor Property

ZoomControl.ZoomFactor Property
[image]

Gets or sets the current zoom level.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public double ZoomFactor { get; set; }

Visual Basic [image] Copy Code

Public Property ZoomFactor As Double

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControl.ZoomStep Property

ZoomControl.ZoomStep Property
[image]

Gets or sets the amount by which to change zoom level when + and - buttons are clicked.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public double ZoomStep { get; set; }

Visual Basic [image] Copy Code

Public Property ZoomStep As Double

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControlExtensions Class

ZoomControlExtensions Class
[image]

Contains extension methods of ZoomControl.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public sealed class ZoomControlExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class ZoomControlExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Mvc.ZoomControlExtensions

See Also

ZoomControlExtensions Members
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControlExtensions Members

ZoomControlExtensions Members
Methods
[image]

Contains extension methods of ZoomControl.

The following tables list the members exposed by the ZoomControlExtensions type.

Public Methods

Name | Description
ZoomControl | Overloaded.

See Also

ZoomControlExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControlExtensions Methods

ZoomControlExtensions Methods
[image]

Public Methods

Name | Description
ZoomControl | Overloaded.

See Also

ZoomControlExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControlExtensions.ZoomControl Method

ZoomControlExtensions.ZoomControl Method
[image]

Overload List

Name | Description
ZoomControlExtensions.ZoomControl (HtmlHelper, String, String) | Returns a ZoomControl by using the specified HTML helper.
ZoomControlExtensions.ZoomControl (HtmlHelper, String, String, IDictionary(String, Object)) | Returns a ZoomControl by using the specified HTML helper.
ZoomControlExtensions.ZoomControl (HtmlHelper, String, String, Object) | Returns a ZoomControl by using the specified HTML helper.
ZoomControlExtensions.ZoomControl (HtmlHelper, String, String, String) | Returns a ZoomControl by using the specified HTML helper.
ZoomControlExtensions.ZoomControl (HtmlHelper, String, String, String, IDictionary(String, Object)) | Returns a ZoomControl by using the specified HTML helper.
ZoomControlExtensions.ZoomControl (HtmlHelper, String, String, String, Object) | Returns a ZoomControl by using the specified HTML helper.
ZoomControlExtensions.ZoomControl (HtmlHelper, ZoomControl) | Returns a ZoomControl by using the specified HTML helper.
ZoomControlExtensions.ZoomControl (HtmlHelper, ZoomControl, IDictionary(String, Object)) | Returns a ZoomControl by using the specified HTML helper.
ZoomControlExtensions.ZoomControl (HtmlHelper, ZoomControl, Object) | Returns a ZoomControl by using the specified HTML helper.
ZoomControlExtensions.ZoomControl (HtmlHelper, ZoomControl, String) | Returns a ZoomControl by using the specified HTML helper.
ZoomControlExtensions.ZoomControl (HtmlHelper, ZoomControl, String, IDictionary(String, Object)) | Returns a ZoomControl by using the specified HTML helper.
ZoomControlExtensions.ZoomControl (HtmlHelper, ZoomControl, String, Object) | Returns a ZoomControl by using the specified HTML helper.

See Also

ZoomControlExtensions Members
ZoomControlExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControlExtensions.ZoomControl Method (HtmlHelper, String, String)

ZoomControlExtensions.ZoomControl Method (HtmlHelper, String, String)
See Also
[image]

Returns a ZoomControl by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString ZoomControl (
HtmlHelper helper,
string id,
string diagramViewId
)

Visual Basic [image] Copy Code

Public Shared Function ZoomControl( _
helper As HtmlHelper, _
id As String, _
diagramViewId As String _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the ZoomControl

diagramViewId

The Id of the DiagramView

Return Value

See Also

ZoomControl Method Overload List
ZoomControlExtensions Members
ZoomControlExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControlExtensions.ZoomControl Method (HtmlHelper, String, String, IDictionary(String, Object))

ZoomControlExtensions.ZoomControl Method (HtmlHelper, String, String, IDictionary(String, Object))
See Also
[image]

Returns a ZoomControl by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString ZoomControl (
HtmlHelper helper,
string id,
string diagramViewId,
IDictionary<string, Object> htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function ZoomControl( _
helper As HtmlHelper, _
id As String, _
diagramViewId As String, _
htmlAttributes As IDictionary(Of String, Object) _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the ZoomControl

diagramViewId

The Id of the DiagramView

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

ZoomControl Method Overload List
ZoomControlExtensions Members
ZoomControlExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControlExtensions.ZoomControl Method (HtmlHelper, String, String, Object)

ZoomControlExtensions.ZoomControl Method (HtmlHelper, String, String, Object)
See Also
[image]

Returns a ZoomControl by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString ZoomControl (
HtmlHelper helper,
string id,
string diagramViewId,
Object htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function ZoomControl( _
helper As HtmlHelper, _
id As String, _
diagramViewId As String, _
htmlAttributes As Object _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the ZoomControl

diagramViewId

The Id of the DiagramView

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

ZoomControl Method Overload List
ZoomControlExtensions Members
ZoomControlExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControlExtensions.ZoomControl Method (HtmlHelper, String, String, String)

ZoomControlExtensions.ZoomControl Method (HtmlHelper, String, String, String)
See Also
[image]

Returns a ZoomControl by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString ZoomControl (
HtmlHelper helper,
string id,
string diagramViewId,
string initFunction
)

Visual Basic [image] Copy Code

Public Shared Function ZoomControl( _
helper As HtmlHelper, _
id As String, _
diagramViewId As String, _
initFunction As String _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the ZoomControl

diagramViewId

The Id of the DiagramView

initFunction

The name of the function that will contain the initializing scripts for the control.

Return Value

See Also

ZoomControl Method Overload List
ZoomControlExtensions Members
ZoomControlExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControlExtensions.ZoomControl Method (HtmlHelper, String, String, String, IDictionary(String, Object))

ZoomControlExtensions.ZoomControl Method (HtmlHelper, String, String, String, IDictionary(String, Object))
See Also
[image]

Returns a ZoomControl by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString ZoomControl (
HtmlHelper helper,
string id,
string diagramViewId,
string initFunction,
IDictionary<string, Object> htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function ZoomControl( _
helper As HtmlHelper, _
id As String, _
diagramViewId As String, _
initFunction As String, _
htmlAttributes As IDictionary(Of String, Object) _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the ZoomControl

diagramViewId

The Id of the DiagramView

initFunction

The name of the function that will contain the initializing scripts for the control.

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

ZoomControl Method Overload List
ZoomControlExtensions Members
ZoomControlExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControlExtensions.ZoomControl Method (HtmlHelper, String, String, String, Object)

ZoomControlExtensions.ZoomControl Method (HtmlHelper, String, String, String, Object)
See Also
[image]

Returns a ZoomControl by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString ZoomControl (
HtmlHelper helper,
string id,
string diagramViewId,
string initFunction,
Object htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function ZoomControl( _
helper As HtmlHelper, _
id As String, _
diagramViewId As String, _
initFunction As String, _
htmlAttributes As Object _
) As MvcHtmlString

Parameters

helper

The HTML helper

id

The Id of the ZoomControl

diagramViewId

The Id of the DiagramView

initFunction

The name of the function that will contain the initializing scripts for the control.

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

ZoomControl Method Overload List
ZoomControlExtensions Members
ZoomControlExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControlExtensions.ZoomControl Method (HtmlHelper, ZoomControl)

ZoomControlExtensions.ZoomControl Method (HtmlHelper, ZoomControl)
See Also
[image]

Returns a ZoomControl by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString ZoomControl (
HtmlHelper helper,
ZoomControl control
)

Visual Basic [image] Copy Code

Public Shared Function ZoomControl( _
helper As HtmlHelper, _
control As ZoomControl _
) As MvcHtmlString

Parameters

helper

The HTML helper

control

The ZoomControl

Return Value

See Also

ZoomControl Method Overload List
ZoomControlExtensions Members
ZoomControlExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControlExtensions.ZoomControl Method (HtmlHelper, ZoomControl, IDictionary(String, Object))

ZoomControlExtensions.ZoomControl Method (HtmlHelper, ZoomControl, IDictionary(String, Object))
See Also
[image]

Returns a ZoomControl by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString ZoomControl (
HtmlHelper helper,
ZoomControl control,
IDictionary<string, Object> htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function ZoomControl( _
helper As HtmlHelper, _
control As ZoomControl, _
htmlAttributes As IDictionary(Of String, Object) _
) As MvcHtmlString

Parameters

helper

The HTML helper

control

The ZoomControl

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

ZoomControl Method Overload List
ZoomControlExtensions Members
ZoomControlExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControlExtensions.ZoomControl Method (HtmlHelper, ZoomControl, Object)

ZoomControlExtensions.ZoomControl Method (HtmlHelper, ZoomControl, Object)
See Also
[image]

Returns a ZoomControl by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString ZoomControl (
HtmlHelper helper,
ZoomControl control,
Object htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function ZoomControl( _
helper As HtmlHelper, _
control As ZoomControl, _
htmlAttributes As Object _
) As MvcHtmlString

Parameters

helper

The HTML helper

control

The ZoomControl

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

ZoomControl Method Overload List
ZoomControlExtensions Members
ZoomControlExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControlExtensions.ZoomControl Method (HtmlHelper, ZoomControl, String)

ZoomControlExtensions.ZoomControl Method (HtmlHelper, ZoomControl, String)
See Also
[image]

Returns a ZoomControl by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString ZoomControl (
HtmlHelper helper,
ZoomControl control,
string initFunction
)

Visual Basic [image] Copy Code

Public Shared Function ZoomControl( _
helper As HtmlHelper, _
control As ZoomControl, _
initFunction As String _
) As MvcHtmlString

Parameters

helper

The HTML helper

control

The ZoomControl

initFunction

The name of the function that will contain the initializing scripts for the control.

Return Value

See Also

ZoomControl Method Overload List
ZoomControlExtensions Members
ZoomControlExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControlExtensions.ZoomControl Method (HtmlHelper, ZoomControl, String, IDictionary(String, Object))

ZoomControlExtensions.ZoomControl Method (HtmlHelper, ZoomControl, String, IDictionary(String, Object))
See Also
[image]

Returns a ZoomControl by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString ZoomControl (
HtmlHelper helper,
ZoomControl control,
string initFunction,
IDictionary<string, Object> htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function ZoomControl( _
helper As HtmlHelper, _
control As ZoomControl, _
initFunction As String, _
htmlAttributes As IDictionary(Of String, Object) _
) As MvcHtmlString

Parameters

helper

The HTML helper

control

The ZoomControl

initFunction

The name of the function that will contain the initializing scripts for the control.

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

ZoomControl Method Overload List
ZoomControlExtensions Members
ZoomControlExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Diagramming.Mvc.ZoomControlExtensions.ZoomControl Method (HtmlHelper, ZoomControl, String, Object)

ZoomControlExtensions.ZoomControl Method (HtmlHelper, ZoomControl, String, Object)
See Also
[image]

Returns a ZoomControl by using the specified HTML helper.

Namespace: MindFusion.Diagramming.Mvc
Assembly: MindFusion.Diagramming.Mvc

Syntax

C# [image] Copy Code

public static MvcHtmlString ZoomControl (
HtmlHelper helper,
ZoomControl control,
string initFunction,
Object htmlAttributes
)

Visual Basic [image] Copy Code

Public Shared Function ZoomControl( _
helper As HtmlHelper, _
control As ZoomControl, _
initFunction As String, _
htmlAttributes As Object _
) As MvcHtmlString

Parameters

helper

The HTML helper

control

The ZoomControl

initFunction

The name of the function that will contain the initializing scripts for the control.

htmlAttributes

An object containing the HTML attributes for the control.

Return Value

See Also

ZoomControl Method Overload List
ZoomControlExtensions Members
ZoomControlExtensions Class
MindFusion.Diagramming.Mvc Namespace


MindFusion.Drawing Namespace

MindFusion.Drawing Namespace
Classes Interfaces Enumerations

Classes

Class | Description
Brush | Brush objects are used to fill the interiors of geometric shapes. Brush is abstract base class inherited by SolidBrush, HatchBrush, TextureBrush, PathGradientBrush and LinearGradientBrush.
BrushCollection | A collection of MindFusion.Drawing.Brush objects.
GdiGraphics | A wrapper of the System.Drawing.Graphics class that implements the IGraphics interface.
GraphicObject | The base class for graphical objects such as pens and brushes.
HatchBrush | HatchBrush objects represent rectangular brushes with a hatch style, a foreground color, and a background color that are used to fill the interiors of geometric shapes.
LinearGradientBrush | LinearGradientBrush objects represent brushes that fill the interiors of geometric shapes with a linear gradient.
PathGradientBrush | PathGradientBrush represents a brush that fills the interiors of geometric shapes with a gradient.
Pen | Pen instances are used to draw the outline of geometric shapes.
PenCollection | A collection of MindFusion.Drawing.Pen objects.
SolidBrush | SolidBrush objects represent brushes of a single color that are used to fill the interiors of geometric shapes.
TextureBrush | TextureBrush objects represent brushes that use images to fill the interiors of geometric shapes.

Interfaces

Interface | Description
IGraphics | This interface exposes the public interface of the .NET System.Drawing.Graphics class.

Enumerations

Enumeration | Description
ImageAlign | Specifies the position and alignment of a picture relative to its destination rectangle.


MindFusion.Drawing.Brush Class

Brush Class
Remarks See Also
[image]

Brush objects are used to fill the interiors of geometric shapes. Brush is abstract base class inherited by SolidBrush, HatchBrush, TextureBrush, PathGradientBrush and LinearGradientBrush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public abstract class Brush : GraphicObject

Visual Basic [image] Copy Code

Public MustInherit Class Brush
Inherits GraphicObject

Remarks

The Brush-derived classes act as proxies for the .NET standard GDI+ System.Drawing.Brush-derived classes. There are two reasons to use proxy classes instead the original GDI classes:

  • First, the GDI resources are limited and would be exhausted by keeping a GDI brushes all the time; by using proxies GDI brushes can be created only at the time of drawing, and immediately disposed after that.
  • Second, the GDI Brush classes do not support serialization; the proxy-classes implement the required interfaces instead.

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject
MindFusion.Drawing.Brush

See Also

Brush Members
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush Members

Brush Members
Constructors Methods
[image]

Brush objects are used to fill the interiors of geometric shapes. Brush is abstract base class inherited by SolidBrush, HatchBrush, TextureBrush, PathGradientBrush and LinearGradientBrush.

The following tables list the members exposed by the Brush type.

Protected Constructors

Name | Description
Brush | Initializes a new instance of the Brush class.

Public Methods

Name | Description
CreateGdiBrush | Overloaded. Returns an instance of a System.Drawing.Brush-derived class corresponding to the current brush.
Deserialize | Creates and returns a new brush according to its string representation.
Serialize | Serializes the specified brush to a string.

See Also

Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush Constructor

Brush Constructor
[image]

Initializes a new instance of the Brush class.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

protected Brush ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush Methods

Brush Methods
[image]

Public Methods

Name | Description
CreateGdiBrush | Overloaded. Returns an instance of a System.Drawing.Brush-derived class corresponding to the current brush.
Deserialize | Creates and returns a new brush according to its string representation.
Serialize | Serializes the specified brush to a string.

See Also

Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush.CreateGdiBrush Method

Brush.CreateGdiBrush Method
[image]

Returns an instance of a System.Drawing.Brush-derived class corresponding to the current brush.

Overload List

Name | Description
Brush.CreateGdiBrush (RectangleF) | Returns an instance of a System.Drawing.Brush-derived class that can be used to paint in a GDI+ Graphics object.
Brush.CreateGdiBrush (RectangleF, Single, Single) | Returns an instance of a System.Drawing.Brush-derived class that can be used to paint in a GDI+ Graphics object. The specified offset is used for texture or pattern brushes whose contents must scroll with the rest of the drawn image.

See Also

Brush Members
Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush.CreateGdiBrush Method (RectangleF)

Brush.CreateGdiBrush Method (RectangleF)
See Also
[image]

Returns an instance of a System.Drawing.Brush-derived class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public abstract Brush CreateGdiBrush (
RectangleF rc
)

Visual Basic [image] Copy Code

Public MustOverride Function CreateGdiBrush( _
rc As RectangleF _
) As Brush

Parameters

rc

The rectangle in which painting will be performed.

Return Value

An instance of the System.Drawing.Brush class corresponding to this brush.

See Also

CreateGdiBrush Method Overload List
Brush Members
Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush.CreateGdiBrush Method (RectangleF, Single, Single)

Brush.CreateGdiBrush Method (RectangleF, Single, Single)
See Also
[image]

Returns an instance of a System.Drawing.Brush-derived class that can be used to paint in a GDI+ Graphics object. The specified offset is used for texture or pattern brushes whose contents must scroll with the rest of the drawn image.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual Brush CreateGdiBrush (
RectangleF rc,
float dx,
float dy
)

Visual Basic [image] Copy Code

Public Overridable Function CreateGdiBrush( _
rc As RectangleF, _
dx As Single, _
dy As Single _
) As Brush

Parameters

rc

The rectangle in which painting will be performed.

dx

Specifies a horizontal offset to apply to this brush.

dy

Specifies a vertical offset to apply to this brush.

Return Value

An instance of the System.Drawing.Brush class corresponding to this brush.

See Also

CreateGdiBrush Method Overload List
Brush Members
Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush.Deserialize Method

Brush.Deserialize Method
[image]

Creates and returns a new brush according to its string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Brush Deserialize (
string image
)

Visual Basic [image] Copy Code

Public Shared Function Deserialize ( _
image As String _
) As Brush

Parameters

image

A string that represents the serialized bursh.

Return Value

An instance of a Brush-derived class.

See Also

Brush Members
Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush.Serialize Method

Brush.Serialize Method
[image]

Serializes the specified brush to a string.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static string Serialize (
Brush brush
)

Visual Basic [image] Copy Code

Public Shared Function Serialize ( _
brush As Brush _
) As String

Parameters

brush

The Brush object to serialize.

Return Value

A string that represents the specified brush.

See Also

Brush Members
Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection Class

BrushCollection Class
[image]

A collection of MindFusion.Drawing.Brush objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public sealed class BrushCollection : CollectionBase, ICloneable

Visual Basic [image] Copy Code

Public NotInheritable Class BrushCollection
Inherits CollectionBase
Implements ICloneable

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Drawing.BrushCollection

See Also

BrushCollection Members
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection Members

BrushCollection Members
Constructors Properties Methods
[image]

A collection of MindFusion.Drawing.Brush objects.

The following tables list the members exposed by the BrushCollection type.

Public Constructors

Name | Description
BrushCollection | Overloaded. Initializes a new instance of the BrushCollection class.

Public Properties

Name | Description
DefaultBrush | Gets or sets the default brush added to a brush collection from within a design-time editor.
Item | Gets or sets the Brush, located at the specified position.

Public Methods

Name | Description
Add | Adds the specified Brush to the collection.
Clone | Returns a shallow copy of this BrushCollection object.
Contains | Checks whether the specified Brush is contained in the collection.
IndexOf | Returns the index of the first occurrence of the specified Brush.
Insert | Inserts the specified Brush at the specified position within the collection.
Remove | Removes the first occurrence of the specified Brush from the collection.
RemoveAt | Removes the Brush at the specified index.

See Also

BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection Constructor

BrushCollection Constructor
[image]

Initializes a new instance of the BrushCollection class.

Overload List

Name | Description
BrushCollection () | Initializes a new empty instance of the BrushCollection class.
BrushCollection (String) | Initializes a new instance of the BrushCollection class using the specified string representation.

See Also

BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection Constructor ()

BrushCollection Constructor ()
See Also
[image]

Initializes a new empty instance of the BrushCollection class.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public BrushCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

BrushCollection Constructor Overload List
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection Constructor (String)

BrushCollection Constructor (String)
See Also
[image]

Initializes a new instance of the BrushCollection class using the specified string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public BrushCollection (
string representation
)

Visual Basic [image] Copy Code

Public New ( _
representation As String _
)

Parameters

representation
The string that represents serialized contents of a BrushCollection.

See Also

BrushCollection Constructor Overload List
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection Methods

BrushCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified Brush to the collection.
Clone | Returns a shallow copy of this BrushCollection object.
Contains | Checks whether the specified Brush is contained in the collection.
IndexOf | Returns the index of the first occurrence of the specified Brush.
Insert | Inserts the specified Brush at the specified position within the collection.
Remove | Removes the first occurrence of the specified Brush from the collection.
RemoveAt | Removes the Brush at the specified index.

See Also

BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection.Add Method

BrushCollection.Add Method
[image]

Adds the specified Brush to the collection.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public int Add (
Brush brush
)

Visual Basic [image] Copy Code

Public Function Add ( _
brush As Brush _
) As Integer

Parameters

brush

The Brush object to add to the end of the collection.

Return Value

The zero-based index within the collection of the newly added brush.

See Also

BrushCollection Members
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection.Clone Method

BrushCollection.Clone Method
[image]

Returns a shallow copy of this BrushCollection object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual Object Clone ()

Visual Basic [image] Copy Code

Public Overridable Function Clone () As Object

Return Value

An instance of the BrushCollection class.

See Also

BrushCollection Members
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection.Contains Method

BrushCollection.Contains Method
[image]

Checks whether the specified Brush is contained in the collection.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public bool Contains (
Brush brush
)

Visual Basic [image] Copy Code

Public Function Contains ( _
brush As Brush _
) As Boolean

Parameters

brush

The Brush object to search for in the collection.

Return Value

true if the specified brush is contained in the collection; otherwise, false.

See Also

BrushCollection Members
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection.IndexOf Method

BrushCollection.IndexOf Method
[image]

Returns the index of the first occurrence of the specified Brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public int IndexOf (
Brush brush
)

Visual Basic [image] Copy Code

Public Function IndexOf ( _
brush As Brush _
) As Integer

Parameters

brush

The Brush object to locate in the collection.

Return Value

The zero-based index of the first occurrence of brush within the entire collection, if found; otherwise, -1.

See Also

BrushCollection Members
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection.Insert Method

BrushCollection.Insert Method
[image]

Inserts the specified Brush at the specified position within the collection.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void Insert (
int index,
Brush brush
)

Visual Basic [image] Copy Code

Public Sub Insert ( _
index As Integer, _
brush As Brush _
)

Parameters

index
The zero-based index at which to insert the brush.
brush
The Brush object to add to the collection.

See Also

BrushCollection Members
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection.Remove Method

BrushCollection.Remove Method
[image]

Removes the first occurrence of the specified Brush from the collection.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void Remove (
Brush brush
)

Visual Basic [image] Copy Code

Public Sub Remove ( _
brush As Brush _
)

Parameters

brush

The Brush object to remove from the collection.

See Also

BrushCollection Members
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection.RemoveAt Method

BrushCollection.RemoveAt Method
[image]

Removes the Brush at the specified index.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public new void RemoveAt (
int index
)

Visual Basic [image] Copy Code

Public Shadows Sub RemoveAt( _
index As Integer _
)

Parameters

index

The index at which the Brush object should be removed.

See Also

BrushCollection Members
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection Properties

BrushCollection Properties
[image]

Public Properties

Name | Description
DefaultBrush | Gets or sets the default brush added to a brush collection from within a design-time editor.
Item | Gets or sets the Brush, located at the specified position.

See Also

BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection.DefaultBrush Property

BrushCollection.DefaultBrush Property
[image]

Gets or sets the default brush added to a brush collection from within a design-time editor.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Brush DefaultBrush { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultBrush As Brush

Property Value

An instance of the Brush class.

See Also

BrushCollection Members
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection.Item Property

BrushCollection.Item Property
[image]

Gets or sets the Brush, located at the specified position.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Brush Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Property Item ( _
index As Integer _
) As Brush

Parameters

index

The zero-based index of the brush to set or retrieve.

Property Value

An instance of the Brush class that represents the brush at the specified position.

See Also

BrushCollection Members
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics Class

GdiGraphics Class
[image]

A wrapper of the System.Drawing.Graphics class that implements the IGraphics interface.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class GdiGraphics : IGraphics

Visual Basic [image] Copy Code

Public Class GdiGraphics
Implements IGraphics

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GdiGraphics

See Also

GdiGraphics Members
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics Members

GdiGraphics Members
Constructors Properties Methods
[image]

A wrapper of the System.Drawing.Graphics class that implements the IGraphics interface.

The following tables list the members exposed by the GdiGraphics type.

Public Constructors

Name | Description
GdiGraphics | Initializes a new instance of the GdiGraphics class over the specified GDI+ Graphics object.

Public Properties

Name | Description
Clip | Gets or sets a .NET Region object that limits the drawing region of this GdiGraphics object.
ClipBounds | Gets a .NET RectangleF structure that bounds the clipping region of this GdiGraphics object.
CompositingMode | Gets or sets a value that specifies how composited images are drawn to this GdiGraphics object.
CompositingQuality | Gets or sets the rendering quality of composited images drawn to this GdiGraphics object.
DpiX | Gets the horizontal resolution of this GdiGraphics object.
DpiY | Gets the vertical resolution of this GdiGraphics object.
Graphics | Gets a reference to the underlying .NET Graphics object.
InterpolationMode | Gets or sets the interpolation mode associated with this GdiGraphics object.
IsClipEmpty | Gets a value indicating whether the clipping region of this GdiGraphics object is empty.
IsVisibleClipEmpty | Gets a value indicating whether the visible clipping region of this GdiGraphics object is empty.
PageScale | Gets or sets the scaling between world units and page units for this GdiGraphics object.
PageUnit | Gets or sets the unit of measure used for page coordinates in this GdiGraphics object.
PixelOffsetMode | Gets or set a value specifying how pixels are offset during rendering of this GdiGraphics object.
RenderingOrigin | Gets or sets the rendering origin of this GdiGraphics object for dithering and for hatch brushes.
SmoothingMode | Gets or sets the rendering quality for this GdiGraphics object.
TextContrast | Gets or sets the gamma correction value for rendering text.
TextRenderingHint | Gets or sets the rendering mode for text associated with this GdiGraphics object.
Transform | Gets or sets the world transformation for this GdiGraphics object.
VisibleClipBounds | Gets the bounding rectangle of the visible clipping region of this GdiGraphics object.

Public Methods

Name | Description
AddMetafileComment | Adds a comment to the current Metafile object.
BeginContainer | Overloaded. Saves a graphics container with the current state of this GdiGraphics object and opens and uses a new graphics container.
BeginHyperLink |
Clear | Clears the entire drawing surface and fills it with the specified background color.
Dispose | Releases all resources used by this GdiGraphics object.
DrawArc | Overloaded. Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
DrawBezier | Overloaded. Draws a Bйzier spline defined by four .NET Point structures.
DrawBeziers | Overloaded. Draws a series of Bйzier splines from an array of Point structures.
DrawClosedCurve | Overloaded. Draws a closed cardinal spline defined by an array of Point structures.
DrawCurve | Overloaded. Draws a cardinal spline through a specified array of Point structures.
DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawIcon | Overloaded. Draws the image represented by the specified .NET Icon object at the specified coordinates.
DrawIconUnstretched | Draws the image represented by the specified .NET Icon object without scaling the image.
DrawImage | Overloaded. Draws the specified .NET Image object at the specified location and with the original size.
DrawImageUnscaled | Overloaded. Draws the specified image using its original physical size at the location specified by a coordinate pair.
DrawLine | Overloaded. Draws a line connecting the two points specified by coordinate pairs.
DrawLines | Overloaded. Draws a series of line segments that connect an array of Point structures.
DrawPath | Draws a .NET GraphicsPath object.
DrawPie | Overloaded. Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.
DrawPolygon | Overloaded. Draws a polygon defined by an array of Point or PointF structures.
DrawRectangle | Overloaded. Draws a rectangle specified by a coordinate pair, a width, and a height.
DrawRectangles | Overloaded. Draws a series of rectangles specified by Rectangle or RectangleF structures.
DrawString | Overloaded. Draws the specified text string at the specified location with the specified Brush and Font objects.
EndContainer | Closes the current graphics container and restores the state of this GdiGraphics object to the state saved by a call to the BeginContainer method.
EndHyperLink |
EnumerateMetafile | Overloaded. Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.
ExcludeClip | Overloaded. Updates the clip region of this GdiGraphics object to exclude the area specified by a .NET Rectangle structure.
FillClosedCurve | Overloaded. Fills the interior a closed cardinal spline curve defined by an array of Point structures.
FillEllipse | Overloaded. Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.
FillPath | Fills the interior of a .NET GraphicsPath object.
FillPie | Overloaded. Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.
FillPolygon | Overloaded. Fills the interior of a polygon defined by an array of points specified by Point structures.
FillRectangle | Overloaded. Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.
FillRectangles | Overloaded. Fills the interiors of a series of rectangles specified by Rectangle structures.
FillRegion | Fills the interior of a .NET Region object.
Flush | Overloaded. Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.
GetFontHeight |
GetHdc | Gets the handle to the device context associated with this GdiGraphics.
GetNearestColor | Gets the nearest color to the specified Color structure.
IntersectClip | Overloaded. Updates the clip region of this GdiGraphics object to the intersection of the current clip region and the specified Rectangle structure.
IsVisible | Overloaded. Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this GdiGraphics object.
MeasureCharacterRanges | Gets an array of Region objects, each of which bounds a range of character positions within the specified string.
MeasureString | Overloaded. Measures the specified string when drawn with the specified Font object.
MultiplyTransform | Overloaded. Multiplies the world transformation of this GdiGraphics object and specified the .NET Matrix object.
ReleaseHdc | Releases a device context handle obtained by a previous call to the GetHdc method of this GdiGraphics object.
ReleaseHdcInternal | Internal method. Do not use.
ResetClip | Resets the clip region of this GdiGraphics object to an infinite region.
ResetTransform | Resets the world transformation matrix of this GdiGraphics object to the identity matrix.
Restore | Restores the state of this GdiGraphics object to the state represented by a GraphicsState object.
RotateTransform | Overloaded. Applies the specified rotation to the transformation matrix of this GdiGraphics object.
Save | Saves the current state of this GdiGraphics object and identifies the saved state with a GraphicsState object.
ScaleTransform | Overloaded. Applies the specified scaling operation to the transformation matrix of this GdiGraphics object by prepending it to the object's transformation matrix.
SetClip | Overloaded. Sets the clipping region of this GdiGraphics object.
TransformPoints | Overloaded. Transforms an array of points from one coordinate space to another using the current world and page transformations of this GdiGraphics object.
TranslateClip | Overloaded. Translates the clipping region of this GdiGraphics object by specified amounts in the horizontal and vertical directions.
TranslateTransform | Overloaded. Prepends the specified translation to the transformation matrix of this GdiGraphics object.

See Also

GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics Constructor

GdiGraphics Constructor
[image]

Initializes a new instance of the GdiGraphics class over the specified GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public GdiGraphics (
Graphics graphics
)

Visual Basic [image] Copy Code

Public New ( _
graphics As Graphics _
)

Parameters

graphics
The .NET Graphics object to wrap.

See Also

GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics Methods

GdiGraphics Methods
[image]

Public Methods

Name | Description
AddMetafileComment | Adds a comment to the current Metafile object.
BeginContainer | Overloaded. Saves a graphics container with the current state of this GdiGraphics object and opens and uses a new graphics container.
BeginHyperLink |
Clear | Clears the entire drawing surface and fills it with the specified background color.
Dispose | Releases all resources used by this GdiGraphics object.
DrawArc | Overloaded. Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
DrawBezier | Overloaded. Draws a Bйzier spline defined by four .NET Point structures.
DrawBeziers | Overloaded. Draws a series of Bйzier splines from an array of Point structures.
DrawClosedCurve | Overloaded. Draws a closed cardinal spline defined by an array of Point structures.
DrawCurve | Overloaded. Draws a cardinal spline through a specified array of Point structures.
DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawIcon | Overloaded. Draws the image represented by the specified .NET Icon object at the specified coordinates.
DrawIconUnstretched | Draws the image represented by the specified .NET Icon object without scaling the image.
DrawImage | Overloaded. Draws the specified .NET Image object at the specified location and with the original size.
DrawImageUnscaled | Overloaded. Draws the specified image using its original physical size at the location specified by a coordinate pair.
DrawLine | Overloaded. Draws a line connecting the two points specified by coordinate pairs.
DrawLines | Overloaded. Draws a series of line segments that connect an array of Point structures.
DrawPath | Draws a .NET GraphicsPath object.
DrawPie | Overloaded. Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.
DrawPolygon | Overloaded. Draws a polygon defined by an array of Point or PointF structures.
DrawRectangle | Overloaded. Draws a rectangle specified by a coordinate pair, a width, and a height.
DrawRectangles | Overloaded. Draws a series of rectangles specified by Rectangle or RectangleF structures.
DrawString | Overloaded. Draws the specified text string at the specified location with the specified Brush and Font objects.
EndContainer | Closes the current graphics container and restores the state of this GdiGraphics object to the state saved by a call to the BeginContainer method.
EndHyperLink |
EnumerateMetafile | Overloaded. Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.
ExcludeClip | Overloaded. Updates the clip region of this GdiGraphics object to exclude the area specified by a .NET Rectangle structure.
FillClosedCurve | Overloaded. Fills the interior a closed cardinal spline curve defined by an array of Point structures.
FillEllipse | Overloaded. Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.
FillPath | Fills the interior of a .NET GraphicsPath object.
FillPie | Overloaded. Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.
FillPolygon | Overloaded. Fills the interior of a polygon defined by an array of points specified by Point structures.
FillRectangle | Overloaded. Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.
FillRectangles | Overloaded. Fills the interiors of a series of rectangles specified by Rectangle structures.
FillRegion | Fills the interior of a .NET Region object.
Flush | Overloaded. Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.
GetFontHeight |
GetHdc | Gets the handle to the device context associated with this GdiGraphics.
GetNearestColor | Gets the nearest color to the specified Color structure.
IntersectClip | Overloaded. Updates the clip region of this GdiGraphics object to the intersection of the current clip region and the specified Rectangle structure.
IsVisible | Overloaded. Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this GdiGraphics object.
MeasureCharacterRanges | Gets an array of Region objects, each of which bounds a range of character positions within the specified string.
MeasureString | Overloaded. Measures the specified string when drawn with the specified Font object.
MultiplyTransform | Overloaded. Multiplies the world transformation of this GdiGraphics object and specified the .NET Matrix object.
ReleaseHdc | Releases a device context handle obtained by a previous call to the GetHdc method of this GdiGraphics object.
ReleaseHdcInternal | Internal method. Do not use.
ResetClip | Resets the clip region of this GdiGraphics object to an infinite region.
ResetTransform | Resets the world transformation matrix of this GdiGraphics object to the identity matrix.
Restore | Restores the state of this GdiGraphics object to the state represented by a GraphicsState object.
RotateTransform | Overloaded. Applies the specified rotation to the transformation matrix of this GdiGraphics object.
Save | Saves the current state of this GdiGraphics object and identifies the saved state with a GraphicsState object.
ScaleTransform | Overloaded. Applies the specified scaling operation to the transformation matrix of this GdiGraphics object by prepending it to the object's transformation matrix.
SetClip | Overloaded. Sets the clipping region of this GdiGraphics object.
TransformPoints | Overloaded. Transforms an array of points from one coordinate space to another using the current world and page transformations of this GdiGraphics object.
TranslateClip | Overloaded. Translates the clipping region of this GdiGraphics object by specified amounts in the horizontal and vertical directions.
TranslateTransform | Overloaded. Prepends the specified translation to the transformation matrix of this GdiGraphics object.

See Also

GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.AddMetafileComment Method

GdiGraphics.AddMetafileComment Method
[image]

Adds a comment to the current Metafile object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void AddMetafileComment (
byte[] data
)

Visual Basic [image] Copy Code

Public Overridable Sub AddMetafileComment( _
data() As Byte _
)

Parameters

data
Array of bytes that contains the comment.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.BeginContainer Method

GdiGraphics.BeginContainer Method
[image]

Saves a graphics container with the current state of this GdiGraphics object and opens and uses a new graphics container.

Overload List

Name | Description
GdiGraphics.BeginContainer () | Saves a graphics container with the current state of this GdiGraphics object and opens and uses a new graphics container.
GdiGraphics.BeginContainer (Rectangle, Rectangle, GraphicsUnit) | Saves a graphics container with the current state of this GdiGraphics object and opens and uses a new graphics container with the specified scale transformation.
GdiGraphics.BeginContainer (RectangleF, RectangleF, GraphicsUnit) | Saves a graphics container with the current state of this GdiGraphics object and opens and uses a new graphics container with the specified scale transformation.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.BeginContainer Method ()

GdiGraphics.BeginContainer Method ()
See Also
[image]

Saves a graphics container with the current state of this GdiGraphics object and opens and uses a new graphics container.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual GraphicsContainer BeginContainer ()

Visual Basic [image] Copy Code

Public Overridable Function BeginContainer () As GraphicsContainer

Return Value

This method returns a .NET GraphicsContainer object that represents the state of this GdiGraphics object at the time of the method call.

See Also

BeginContainer Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.BeginContainer Method (Rectangle, Rectangle, GraphicsUnit)

GdiGraphics.BeginContainer Method (Rectangle, Rectangle, GraphicsUnit)
See Also
[image]

Saves a graphics container with the current state of this GdiGraphics object and opens and uses a new graphics container with the specified scale transformation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual GraphicsContainer BeginContainer (
Rectangle dstrect,
Rectangle srcrect,
GraphicsUnit unit
)

Visual Basic [image] Copy Code

Public Overridable Function BeginContainer( _
dstrect As Rectangle, _
srcrect As Rectangle, _
unit As GraphicsUnit _
) As GraphicsContainer

Parameters

dstrect
A .NET Rectangle structure that, together with the srcrect parameter, specifies a scale transformation for the container.
srcrect
A .NET Rectangle structure that, together with the dstrect parameter, specifies a scale transformation for the container.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure for the container.

Return Value

This method returns a .NET GraphicsContainer object that represents the state of this GdiGraphics object at the time of the method call.

See Also

BeginContainer Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.BeginContainer Method (RectangleF, RectangleF, GraphicsUnit)

GdiGraphics.BeginContainer Method (RectangleF, RectangleF, GraphicsUnit)
See Also
[image]

Saves a graphics container with the current state of this GdiGraphics object and opens and uses a new graphics container with the specified scale transformation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual GraphicsContainer BeginContainer (
RectangleF dstrect,
RectangleF srcrect,
GraphicsUnit unit
)

Visual Basic [image] Copy Code

Public Overridable Function BeginContainer( _
dstrect As RectangleF, _
srcrect As RectangleF, _
unit As GraphicsUnit _
) As GraphicsContainer

Parameters

dstrect
A .NET RectangleF structure that, together with the srcrect parameter, specifies a scale transformation for the new graphics container.
srcrect
A .NET RectangleF structure that, together with the dstrect parameter, specifies a scale transformation for the new graphics container.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure for the container.

Return Value

This method returns a .NET GraphicsContainer object that represents the state of this GdiGraphics object at the time of the method call.

See Also

BeginContainer Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.BeginHyperLink Method

GdiGraphics.BeginHyperLink Method
[image]

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void BeginHyperLink (
string url,
string target
)

Visual Basic [image] Copy Code

Public Overridable Sub BeginHyperLink( _
url As String, _
target As String _
)

Parameters

url

target

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Clear Method

GdiGraphics.Clear Method
[image]

Clears the entire drawing surface and fills it with the specified background color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void Clear (
Color color
)

Visual Basic [image] Copy Code

Public Overridable Sub Clear( _
color As Color _
)

Parameters

color
A .NET Color structure that represents the background color of the drawing surface.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Dispose Method

GdiGraphics.Dispose Method
[image]

Releases all resources used by this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void Dispose ()

Visual Basic [image] Copy Code

Public Overridable Sub Dispose ()

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawArc Method

GdiGraphics.DrawArc Method
[image]

Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

Overload List

Name | Description
GdiGraphics.DrawArc (Pen, Int32, Int32, Int32, Int32, Int32, Int32) | Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
GdiGraphics.DrawArc (Pen, Rectangle, Single, Single) | Draws an arc representing a portion of an ellipse specified by a .NET Rectangle structure.
GdiGraphics.DrawArc (Pen, RectangleF, Single, Single) | Draws an arc representing a portion of an ellipse specified by a .NET RectangleF structure.
GdiGraphics.DrawArc (Pen, Single, Single, Single, Single, Single, Single) | Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawArc Method (Pen, Int32, Int32, Int32, Int32, Int32, Int32)

GdiGraphics.DrawArc Method (Pen, Int32, Int32, Int32, Int32, Int32, Int32)
See Also
[image]

Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawArc (
Pen pen,
int x,
int y,
int width,
int height,
int startAngle,
int sweepAngle
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawArc( _
pen As Pen, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer, _
startAngle As Integer, _
sweepAngle As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the arc.
x
The x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
The width of the rectangle that defines the ellipse.
height
The height of the rectangle that defines the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

See Also

DrawArc Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawArc Method (Pen, Rectangle, Single, Single)

GdiGraphics.DrawArc Method (Pen, Rectangle, Single, Single)
See Also
[image]

Draws an arc representing a portion of an ellipse specified by a .NET Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawArc (
Pen pen,
Rectangle rect,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawArc( _
pen As Pen, _
rect As Rectangle, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the arc.
rect
A .NET RectangleF structure that defines the boundaries of the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

See Also

DrawArc Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawArc Method (Pen, RectangleF, Single, Single)

GdiGraphics.DrawArc Method (Pen, RectangleF, Single, Single)
See Also
[image]

Draws an arc representing a portion of an ellipse specified by a .NET RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawArc (
Pen pen,
RectangleF rect,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawArc( _
pen As Pen, _
rect As RectangleF, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the arc.
rect
A .NET RectangleF structure that defines the boundaries of the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

See Also

DrawArc Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawArc Method (Pen, Single, Single, Single, Single, Single, Single)

GdiGraphics.DrawArc Method (Pen, Single, Single, Single, Single, Single, Single)
See Also
[image]

Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawArc (
Pen pen,
float x,
float y,
float width,
float height,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawArc( _
pen As Pen, _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the arc.
x
The x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
The width of the rectangle that defines the ellipse.
height
The height of the rectangle that defines the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

See Also

DrawArc Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawBezier Method

GdiGraphics.DrawBezier Method
[image]

Draws a Bйzier spline defined by four .NET Point structures.

Overload List

Name | Description
GdiGraphics.DrawBezier (Pen, Point, Point, Point, Point) | Draws a Bйzier spline defined by four Point structures.
GdiGraphics.DrawBezier (Pen, PointF, PointF, PointF, PointF) | Draws a Bйzier spline defined by four PointF structures.
GdiGraphics.DrawBezier (Pen, Single, Single, Single, Single, Single, Single, Single, Single) | Draws a Bйzier spline defined by four ordered pairs of coordinates that represent points.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawBezier Method (Pen, Point, Point, Point, Point)

GdiGraphics.DrawBezier Method (Pen, Point, Point, Point, Point)
See Also
[image]

Draws a Bйzier spline defined by four Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawBezier (
Pen pen,
Point pt1,
Point pt2,
Point pt3,
Point pt4
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawBezier( _
pen As Pen, _
pt1 As Point, _
pt2 As Point, _
pt3 As Point, _
pt4 As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
pt1
A .NET Point structure that represents the starting point of the curve.
pt2
A .NET Point structure that represents the first control point for the curve.
pt3
A .NET Point structure that represents the second control point for the curve.
pt4
A .NET Point structure that represents the ending point of the curve.

See Also

DrawBezier Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawBezier Method (Pen, PointF, PointF, PointF, PointF)

GdiGraphics.DrawBezier Method (Pen, PointF, PointF, PointF, PointF)
See Also
[image]

Draws a Bйzier spline defined by four PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawBezier (
Pen pen,
PointF pt1,
PointF pt2,
PointF pt3,
PointF pt4
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawBezier( _
pen As Pen, _
pt1 As PointF, _
pt2 As PointF, _
pt3 As PointF, _
pt4 As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
pt1
A .NET PointF structure that represents the starting point of the curve.
pt2
A .NET PointF structure that represents the first control point for the curve.
pt3
A .NET PointF structure that represents the second control point for the curve.
pt4
A .NET PointF structure that represents the ending point of the curve.

See Also

DrawBezier Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawBezier Method (Pen, Single, Single, Single, Single, Single, Single, Single, Single)

GdiGraphics.DrawBezier Method (Pen, Single, Single, Single, Single, Single, Single, Single, Single)
See Also
[image]

Draws a Bйzier spline defined by four ordered pairs of coordinates that represent points.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawBezier (
Pen pen,
float x1,
float y1,
float x2,
float y2,
float x3,
float y3,
float x4,
float y4
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawBezier( _
pen As Pen, _
x1 As Single, _
y1 As Single, _
x2 As Single, _
y2 As Single, _
x3 As Single, _
y3 As Single, _
x4 As Single, _
y4 As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
x1
The x-coordinate of the starting point of the curve.
y1
The y-coordinate of the starting point of the curve.
x2
The x-coordinate of the first control point of the curve.
y2
The y-coordinate of the first control point of the curve.
x3
The x-coordinate of the second control point of the curve.
y3
The y-coordinate of the second control point of the curve.
x4
The x-coordinate of the ending point of the curve.
y4
The y-coordinate of the ending point of the curve.

See Also

DrawBezier Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawBeziers Method

GdiGraphics.DrawBeziers Method
[image]

Draws a series of Bйzier splines from an array of Point structures.

Overload List

Name | Description
GdiGraphics.DrawBeziers (Pen, Point[]) | Draws a series of Bйzier splines from an array of Point structures.
GdiGraphics.DrawBeziers (Pen, PointF[]) | Draws a series of Bйzier splines from an array of PointF structures.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawBeziers Method (Pen, Point[])

GdiGraphics.DrawBeziers Method (Pen, Point[])
See Also
[image]

Draws a series of Bйzier splines from an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawBeziers (
Pen pen,
Point[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawBeziers( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
points
An array of .NET Point structures that represent the points that determine the curve.

See Also

DrawBeziers Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawBeziers Method (Pen, PointF[])

GdiGraphics.DrawBeziers Method (Pen, PointF[])
See Also
[image]

Draws a series of Bйzier splines from an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawBeziers (
Pen pen,
PointF[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawBeziers( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
points
An array of .NET PointF structures that represent the points that determine the curve.

See Also

DrawBeziers Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawClosedCurve Method

GdiGraphics.DrawClosedCurve Method
[image]

Draws a closed cardinal spline defined by an array of Point structures.

Overload List

Name | Description
GdiGraphics.DrawClosedCurve (Pen, Point[]) | Draws a closed cardinal spline defined by an array of Point structures.
GdiGraphics.DrawClosedCurve (Pen, Point[], Single, FillMode) | Draws a closed cardinal spline defined by an array of Point structures using a specified tension.
GdiGraphics.DrawClosedCurve (Pen, PointF[]) | Draws a closed cardinal spline defined by an array of PointF structures.
GdiGraphics.DrawClosedCurve (Pen, PointF[], Single, FillMode) | Draws a closed cardinal spline defined by an array of PointF structures using a specified tension.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawClosedCurve Method (Pen, Point[])

GdiGraphics.DrawClosedCurve Method (Pen, Point[])
See Also
[image]

Draws a closed cardinal spline defined by an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawClosedCurve (
Pen pen,
Point[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawClosedCurve( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.

See Also

DrawClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawClosedCurve Method (Pen, Point[], Single, FillMode)

GdiGraphics.DrawClosedCurve Method (Pen, Point[], Single, FillMode)
See Also
[image]

Draws a closed cardinal spline defined by an array of Point structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawClosedCurve (
Pen pen,
Point[] points,
float tension,
FillMode fillmode
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawClosedCurve( _
pen As Pen, _
points() As Point, _
tension As Single, _
fillmode As FillMode _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled. This parameter is required but ignored.

See Also

DrawClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawClosedCurve Method (Pen, PointF[])

GdiGraphics.DrawClosedCurve Method (Pen, PointF[])
See Also
[image]

Draws a closed cardinal spline defined by an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawClosedCurve (
Pen pen,
PointF[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawClosedCurve( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of PointF structures that define the spline.

See Also

DrawClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawClosedCurve Method (Pen, PointF[], Single, FillMode)

GdiGraphics.DrawClosedCurve Method (Pen, PointF[], Single, FillMode)
See Also
[image]

Draws a closed cardinal spline defined by an array of PointF structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawClosedCurve (
Pen pen,
PointF[] points,
float tension,
FillMode fillmode
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawClosedCurve( _
pen As Pen, _
points() As PointF, _
tension As Single, _
fillmode As FillMode _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of PointF structures that define the spline.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.
fillmode
Member of the FillMode enumeration that determines how the curve is filled. This parameter is required but is ignored.

See Also

DrawClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawCurve Method

GdiGraphics.DrawCurve Method
[image]

Draws a cardinal spline through a specified array of Point structures.

Overload List

Name | Description
GdiGraphics.DrawCurve (Pen, Point[]) | Draws a cardinal spline through a specified array of Point structures.
GdiGraphics.DrawCurve (Pen, Point[], Int32, Int32, Single) | Draws a cardinal spline through a specified array of Point structures using a specified tension.
GdiGraphics.DrawCurve (Pen, Point[], Single) | Draws a cardinal spline through a specified array of Point structures using a specified tension.
GdiGraphics.DrawCurve (Pen, PointF[]) | Draws a cardinal spline through a specified array of PointF structures.
GdiGraphics.DrawCurve (Pen, PointF[], Int32, Int32) | Draws a cardinal spline through a specified array of PointF structures. The drawing begins offset from the beginning of the array.
GdiGraphics.DrawCurve (Pen, PointF[], Int32, Int32, Single) | Draws a cardinal spline through a specified array of PointF structures using a specified tension. The drawing begins offset from the beginning of the array.
GdiGraphics.DrawCurve (Pen, PointF[], Single) | Draws a cardinal spline through a specified array of PointF structures using a specified tension.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawCurve Method (Pen, Point[])

GdiGraphics.DrawCurve Method (Pen, Point[])
See Also
[image]

Draws a cardinal spline through a specified array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawCurve (
Pen pen,
Point[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawCurve( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.

See Also

DrawCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawCurve Method (Pen, Point[], Int32, Int32, Single)

GdiGraphics.DrawCurve Method (Pen, Point[], Int32, Int32, Single)
See Also
[image]

Draws a cardinal spline through a specified array of Point structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawCurve (
Pen pen,
Point[] points,
int offset,
int numberOfSegments,
float tension
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawCurve( _
pen As Pen, _
points() As Point, _
offset As Integer, _
numberOfSegments As Integer, _
tension As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.
offset
The offset from the first element in the array of the points parameter to the starting point in the curve.
numberOfSegments
The number of segments after the starting point to include in the curve.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

DrawCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawCurve Method (Pen, Point[], Single)

GdiGraphics.DrawCurve Method (Pen, Point[], Single)
See Also
[image]

Draws a cardinal spline through a specified array of Point structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawCurve (
Pen pen,
Point[] points,
float tension
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawCurve( _
pen As Pen, _
points() As Point, _
tension As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

DrawCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawCurve Method (Pen, PointF[])

GdiGraphics.DrawCurve Method (Pen, PointF[])
See Also
[image]

Draws a cardinal spline through a specified array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawCurve (
Pen pen,
PointF[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawCurve( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET PointF structures that define the spline.

See Also

DrawCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawCurve Method (Pen, PointF[], Int32, Int32)

GdiGraphics.DrawCurve Method (Pen, PointF[], Int32, Int32)
See Also
[image]

Draws a cardinal spline through a specified array of PointF structures. The drawing begins offset from the beginning of the array.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawCurve (
Pen pen,
PointF[] points,
int offset,
int numberOfSegments
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawCurve( _
pen As Pen, _
points() As PointF, _
offset As Integer, _
numberOfSegments As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET PointF structures that define the spline.
offset
The offset from the first element in the array of the points parameter to the starting point in the curve.
numberOfSegments
The number of segments after the starting point to include in the curve.

See Also

DrawCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawCurve Method (Pen, PointF[], Int32, Int32, Single)

GdiGraphics.DrawCurve Method (Pen, PointF[], Int32, Int32, Single)
See Also
[image]

Draws a cardinal spline through a specified array of PointF structures using a specified tension. The drawing begins offset from the beginning of the array.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawCurve (
Pen pen,
PointF[] points,
int offset,
int numberOfSegments,
float tension
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawCurve( _
pen As Pen, _
points() As PointF, _
offset As Integer, _
numberOfSegments As Integer, _
tension As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET PointF structures that define the spline.
offset
The offset from the first element in the array of the points parameter to the starting point in the curve.
numberOfSegments
The number of segments after the starting point to include in the curve.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

DrawCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawCurve Method (Pen, PointF[], Single)

GdiGraphics.DrawCurve Method (Pen, PointF[], Single)
See Also
[image]

Draws a cardinal spline through a specified array of PointF structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawCurve (
Pen pen,
PointF[] points,
float tension
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawCurve( _
pen As Pen, _
points() As PointF, _
tension As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET PointF structures that represent the points that define the curve.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

DrawCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawEllipse Method

GdiGraphics.DrawEllipse Method
[image]

Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Overload List

Name | Description
GdiGraphics.DrawEllipse (Pen, Int32, Int32, Int32, Int32) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
GdiGraphics.DrawEllipse (Pen, Rectangle) | Draws an ellipse specified by a bounding Rectangle structure.
GdiGraphics.DrawEllipse (Pen, RectangleF) | Draws an ellipse defined by a bounding RectangleF structure.
GdiGraphics.DrawEllipse (Pen, Single, Single, Single, Single) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawEllipse Method (Pen, Int32, Int32, Int32, Int32)

GdiGraphics.DrawEllipse Method (Pen, Int32, Int32, Int32, Int32)
See Also
[image]

Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawEllipse (
Pen pen,
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawEllipse( _
pen As Pen, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the ellipse.
x

The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.

y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
The width of the bounding rectangle that defines the ellipse.
height
The height of the bounding rectangle that defines the ellipse.

See Also

DrawEllipse Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawEllipse Method (Pen, Rectangle)

GdiGraphics.DrawEllipse Method (Pen, Rectangle)
See Also
[image]

Draws an ellipse specified by a bounding Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawEllipse (
Pen pen,
Rectangle rect
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawEllipse( _
pen As Pen, _
rect As Rectangle _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the ellipse.
rect
A .NET Rectangle structure that defines the boundaries of the ellipse.

See Also

DrawEllipse Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawEllipse Method (Pen, RectangleF)

GdiGraphics.DrawEllipse Method (Pen, RectangleF)
See Also
[image]

Draws an ellipse defined by a bounding RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawEllipse (
Pen pen,
RectangleF rect
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawEllipse( _
pen As Pen, _
rect As RectangleF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the ellipse.
rect
A .NET RectangleF structure that defines the boundaries of the ellipse.

See Also

DrawEllipse Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawEllipse Method (Pen, Single, Single, Single, Single)

GdiGraphics.DrawEllipse Method (Pen, Single, Single, Single, Single)
See Also
[image]

Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawEllipse (
Pen pen,
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawEllipse( _
pen As Pen, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the ellipse.
x

The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.

y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
The width of the bounding rectangle that defines the ellipse.
height
The height of the bounding rectangle that defines the ellipse.

See Also

DrawEllipse Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawIcon Method

GdiGraphics.DrawIcon Method
[image]

Draws the image represented by the specified .NET Icon object at the specified coordinates.

Overload List

Name | Description
GdiGraphics.DrawIcon (Icon, Int32, Int32) | Draws the image represented by the specified .NET Icon object at the specified coordinates.
GdiGraphics.DrawIcon (Icon, Rectangle) | Draws the image represented by the specified .NET Icon object within the area specified by a Rectangle structure.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawIcon Method (Icon, Int32, Int32)

GdiGraphics.DrawIcon Method (Icon, Int32, Int32)
See Also
[image]

Draws the image represented by the specified .NET Icon object at the specified coordinates.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawIcon (
Icon icon,
int x,
int y
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawIcon( _
icon As Icon, _
x As Integer, _
y As Integer _
)

Parameters

icon
A .NET Icon object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.

See Also

DrawIcon Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawIcon Method (Icon, Rectangle)

GdiGraphics.DrawIcon Method (Icon, Rectangle)
See Also
[image]

Draws the image represented by the specified .NET Icon object within the area specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawIcon (
Icon icon,
Rectangle targetRect
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawIcon( _
icon As Icon, _
targetRect As Rectangle _
)

Parameters

icon
A .NET Icon object to draw.
targetRect
A .NET Rectangle structure that specifies the location and size of the resulting image on the display surface. The image contained in the icon parameter is scaled to the dimensions of this rectangular area.

See Also

DrawIcon Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawIconUnstretched Method

GdiGraphics.DrawIconUnstretched Method
[image]

Draws the image represented by the specified .NET Icon object without scaling the image.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawIconUnstretched (
Icon icon,
Rectangle targetRect
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawIconUnstretched( _
icon As Icon, _
targetRect As Rectangle _
)

Parameters

icon
A .NET Icon object to draw.
targetRect
A .NET Rectangle structure that specifies the location and size of the resulting image. The image is not scaled to fit this rectangle, but retains its original size. If the image is larger than the rectangle, it is clipped to fit inside it.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method

GdiGraphics.DrawImage Method
[image]

Draws the specified .NET Image object at the specified location and with the original size.

Overload List

Name | Description
GdiGraphics.DrawImage (Image, Int32, Int32) | Draws the specified image, using its original physical size, at the location specified by a coordinate pair.
GdiGraphics.DrawImage (Image, Int32, Int32, Int32, Int32) | Draws the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Int32, Int32, Rectangle, GraphicsUnit) | Draws a portion of an image at a specified location.
GdiGraphics.DrawImage (Image, Point) | Draws the specified .NET Image object, using its original physical size, at the specified location.
GdiGraphics.DrawImage (Image, Point[]) | Draws the specified .NET Image object at the specified location and with the specified shape and size.
GdiGraphics.DrawImage (Image, Point[], Rectangle, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes) | Draws the specified portion of the specified .NET Image object at the specified location.
GdiGraphics.DrawImage (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, Int32) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, PointF) | Draws the specified .NET Image object, using its original physical size, at the specified location.
GdiGraphics.DrawImage (Image, PointF[]) | Draws the specified .NET Image object at the specified location and with the specified shape and size.
GdiGraphics.DrawImage (Image, PointF[], RectangleF, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, Int32) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle) | Draws the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, IntPtr) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle, Rectangle, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, IntPtr) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, RectangleF) | Draws the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, RectangleF, RectangleF, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Single, Single) | Draws the specified .NET Image object, using its original physical size, at the specified location.
GdiGraphics.DrawImage (Image, Single, Single, RectangleF, GraphicsUnit) | Draws a portion of an image at a specified location.
GdiGraphics.DrawImage (Image, Single, Single, Single, Single) | Draws the specified .NET Image object at the specified location and with the specified size.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Int32, Int32)

GdiGraphics.DrawImage Method (Image, Int32, Int32)
See Also
[image]

Draws the specified image, using its original physical size, at the location specified by a coordinate pair.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
int x,
int y
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
x As Integer, _
y As Integer _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Int32, Int32, Int32, Int32)

GdiGraphics.DrawImage Method (Image, Int32, Int32, Int32, Int32)
See Also
[image]

Draws the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
width
The width of the drawn image.
height
The height of the drawn image.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Int32, Int32, Rectangle, GraphicsUnit)

GdiGraphics.DrawImage Method (Image, Int32, Int32, Rectangle, GraphicsUnit)
See Also
[image]

Draws a portion of an image at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
int x,
int y,
Rectangle srcRect,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
x As Integer, _
y As Integer, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Point)

GdiGraphics.DrawImage Method (Image, Point)
See Also
[image]

Draws the specified .NET Image object, using its original physical size, at the specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
Point point
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
point As Point _
)

Parameters

image
A .NET Image object to draw.
point
A .NET Point structure that represents the location of the upper-left corner of the drawn image.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Point[])

GdiGraphics.DrawImage Method (Image, Point[])
See Also
[image]

Draws the specified .NET Image object at the specified location and with the specified shape and size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
Point[] destPoints
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
destPoints() As Point _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET Point structures that define a parallelogram.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit)

GdiGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
destPoints() As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET Point structures that define a parallelogram.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes)

GdiGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit srcUnit,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
destPoints() As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET Point structures that define a parallelogram.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort)

GdiGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void DrawImage (
Image image,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit srcUnit,
ImageAttributes imageAttr,
Graphics.DrawImageAbort callback
)

Visual Basic [image] Copy Code

Public Sub DrawImage( _
image As Image, _
destPoints() As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes, _
callback As Graphics.DrawImageAbort _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET Point structures that define a parallelogram.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.
callback
A .NET Graphics.DrawImageAbort delegate that specifies a method to call during the drawing of the image. This method is called frequently to check whether to stop execution of the DrawImage method according to application-determined criteria.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, Int32)

GdiGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, Int32)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void DrawImage (
Image image,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit srcUnit,
ImageAttributes imageAttr,
Graphics.DrawImageAbort callback,
int callbackData
)

Visual Basic [image] Copy Code

Public Sub DrawImage( _
image As Image, _
destPoints() As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes, _
callback As Graphics.DrawImageAbort, _
callbackData As Integer _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET Point structures that define a parallelogram.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.
callback
A .NET Graphics.DrawImageAbort delegate that specifies a method to call during the drawing of the image. This method is called frequently to check whether to stop execution of the DrawImage method according to application-determined criteria.
callbackData

Value specifying additional data for the Graphics.DrawImageAbort delegate to use when checking whether to stop execution of the DrawImage method.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, PointF)

GdiGraphics.DrawImage Method (Image, PointF)
See Also
[image]

Draws the specified .NET Image object, using its original physical size, at the specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
PointF point
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
point As PointF _
)

Parameters

image
A .NET Image object to draw.
point
A .NET Point structure that represents the location of the upper-left corner of the drawn image.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, PointF[])

GdiGraphics.DrawImage Method (Image, PointF[])
See Also
[image]

Draws the specified .NET Image object at the specified location and with the specified shape and size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
PointF[] destPoints
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
destPoints() As PointF _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET PointF structures that define a parallelogram.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit)

GdiGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
destPoints() As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET PointF structures that define a parallelogram.
srcRect
A .NET RectangleF structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes)

GdiGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit srcUnit,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
destPoints() As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET PointF structures that define a parallelogram.
srcRect
A .NET RectangleF structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort)

GdiGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void DrawImage (
Image image,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit srcUnit,
ImageAttributes imageAttr,
Graphics.DrawImageAbort callback
)

Visual Basic [image] Copy Code

Public Sub DrawImage( _
image As Image, _
destPoints() As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes, _
callback As Graphics.DrawImageAbort _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET PointF structures that define a parallelogram.
srcRect
A .NET Rectanglef structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.
callback
A .NET Graphics.DrawImageAbort delegate that specifies a method to call during the drawing of the image. This method is called frequently to check whether to stop execution of the DrawImage method according to application-determined criteria.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, Int32)

GdiGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, Int32)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void DrawImage (
Image image,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit srcUnit,
ImageAttributes imageAttr,
Graphics.DrawImageAbort callback,
int callbackData
)

Visual Basic [image] Copy Code

Public Sub DrawImage( _
image As Image, _
destPoints() As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes, _
callback As Graphics.DrawImageAbort, _
callbackData As Integer _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET PointF structures that define a parallelogram.
srcRect
A .NET RectangleF structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.
callback
A .NET Graphics.DrawImageAbort delegate that specifies a method to call during the drawing of the image. This method is called frequently to check whether to stop execution of the DrawImage method according to application-determined criteria.
callbackData
Value specifying additional data for the Graphics.DrawImageAbort delegate to use when checking whether to stop execution of the DrawImage method.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle)

GdiGraphics.DrawImage Method (Image, Rectangle)
See Also
[image]

Draws the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
Rectangle rect
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
rect As Rectangle _
)

Parameters

image
A .NET Image object to draw.
rect
A .NET Rectangle structure that specifies the location and size of the drawn image.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit)

GdiGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
Rectangle destRect,
int srcX,
int srcY,
int srcWidth,
int srcHeight,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcX As Integer, _
srcY As Integer, _
srcWidth As Integer, _
srcHeight As Integer, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes)

GdiGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
Rectangle destRect,
int srcX,
int srcY,
int srcWidth,
int srcHeight,
GraphicsUnit srcUnit,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcX As Integer, _
srcY As Integer, _
srcWidth As Integer, _
srcHeight As Integer, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort)

GdiGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void DrawImage (
Image image,
Rectangle destRect,
int srcX,
int srcY,
int srcWidth,
int srcHeight,
GraphicsUnit srcUnit,
ImageAttributes imageAttr,
Graphics.DrawImageAbort callback
)

Visual Basic [image] Copy Code

Public Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcX As Integer, _
srcY As Integer, _
srcWidth As Integer, _
srcHeight As Integer, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes, _
callback As Graphics.DrawImageAbort _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.
callback
A .NET Graphics.DrawImageAbort delegate that specifies a method to call during the drawing of the image. This method is called frequently to check whether to stop execution of the DrawImage method according to application-determined criteria.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, IntPtr)

GdiGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, IntPtr)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void DrawImage (
Image image,
Rectangle destRect,
int srcX,
int srcY,
int srcWidth,
int srcHeight,
GraphicsUnit srcUnit,
ImageAttributes imageAttrs,
Graphics.DrawImageAbort callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcX As Integer, _
srcY As Integer, _
srcWidth As Integer, _
srcHeight As Integer, _
srcUnit As GraphicsUnit, _
imageAttrs As ImageAttributes, _
callback As Graphics.DrawImageAbort, _
callbackData As IntPtr _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.
imageAttrs
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.
callback
A .NET Graphics.DrawImageAbort delegate that specifies a method to call during the drawing of the image. This method is called frequently to check whether to stop execution of the DrawImage method according to application-determined criteria.
callbackData
Value specifying additional data for the DrawImageAbort delegate to use when checking whether to stop execution of the DrawImage method.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle, Rectangle, GraphicsUnit)

GdiGraphics.DrawImage Method (Image, Rectangle, Rectangle, GraphicsUnit)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
Rectangle destRect,
Rectangle srcRect,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit)

GdiGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
Rectangle destRect,
float srcX,
float srcY,
float srcWidth,
float srcHeight,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcX As Single, _
srcY As Single, _
srcWidth As Single, _
srcHeight As Single, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes)

GdiGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
Rectangle destRect,
float srcX,
float srcY,
float srcWidth,
float srcHeight,
GraphicsUnit srcUnit,
ImageAttributes imageAttrs
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcX As Single, _
srcY As Single, _
srcWidth As Single, _
srcHeight As Single, _
srcUnit As GraphicsUnit, _
imageAttrs As ImageAttributes _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.
imageAttrs
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort)

GdiGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void DrawImage (
Image image,
Rectangle destRect,
float srcX,
float srcY,
float srcWidth,
float srcHeight,
GraphicsUnit srcUnit,
ImageAttributes imageAttrs,
Graphics.DrawImageAbort callback
)

Visual Basic [image] Copy Code

Public Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcX As Single, _
srcY As Single, _
srcWidth As Single, _
srcHeight As Single, _
srcUnit As GraphicsUnit, _
imageAttrs As ImageAttributes, _
callback As Graphics.DrawImageAbort _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.
imageAttrs
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.
callback
A .NET Graphics.DrawImageAbort delegate that specifies a method to call during the drawing of the image. This method is called frequently to check whether to stop execution of the DrawImage method according to application-determined criteria.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, IntPtr)

GdiGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, IntPtr)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void DrawImage (
Image image,
Rectangle destRect,
float srcX,
float srcY,
float srcWidth,
float srcHeight,
GraphicsUnit srcUnit,
ImageAttributes imageAttrs,
Graphics.DrawImageAbort callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcX As Single, _
srcY As Single, _
srcWidth As Single, _
srcHeight As Single, _
srcUnit As GraphicsUnit, _
imageAttrs As ImageAttributes, _
callback As Graphics.DrawImageAbort, _
callbackData As IntPtr _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.
imageAttrs
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.
callback
A .NET Graphics.DrawImageAbort delegate that specifies a method to call during the drawing of the image. This method is called frequently to check whether to stop execution of the DrawImage method according to application-determined criteria.
callbackData
Value specifying additional data for the DrawImageAbort delegate to use when checking whether to stop execution of the DrawImage method.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, RectangleF)

GdiGraphics.DrawImage Method (Image, RectangleF)
See Also
[image]

Draws the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
RectangleF rect
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
rect As RectangleF _
)

Parameters

image
A .NET Image object to draw.
rect
A .NET RectangleF structure that specifies the location and size of the drawn image.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, RectangleF, RectangleF, GraphicsUnit)

GdiGraphics.DrawImage Method (Image, RectangleF, RectangleF, GraphicsUnit)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
RectangleF destRect,
RectangleF srcRect,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
destRect As RectangleF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET RectangleF structure.
srcRect
A .NET RectangleF structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Single, Single)

GdiGraphics.DrawImage Method (Image, Single, Single)
See Also
[image]

Draws the specified .NET Image object, using its original physical size, at the specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
float x,
float y
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
x As Single, _
y As Single _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Single, Single, RectangleF, GraphicsUnit)

GdiGraphics.DrawImage Method (Image, Single, Single, RectangleF, GraphicsUnit)
See Also
[image]

Draws a portion of an image at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
float x,
float y,
RectangleF srcRect,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
x As Single, _
y As Single, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
srcRect
A .NET RectangleF structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Single, Single, Single, Single)

GdiGraphics.DrawImage Method (Image, Single, Single, Single, Single)
See Also
[image]

Draws the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
width
The width of the drawn image.
height
The height of the drawn image.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImageUnscaled Method

GdiGraphics.DrawImageUnscaled Method
[image]

Draws the specified image using its original physical size at the location specified by a coordinate pair.

Overload List

Name | Description
GdiGraphics.DrawImageUnscaled (Image, Int32, Int32) | Draws the specified image using its original physical size at the location specified by a coordinate pair.
GdiGraphics.DrawImageUnscaled (Image, Int32, Int32, Int32, Int32) | Draws a specified image using its original physical size at a specified location.
GdiGraphics.DrawImageUnscaled (Image, Point) | Draws a specified image using its original physical size at a specified location.
GdiGraphics.DrawImageUnscaled (Image, Rectangle) | Draws a specified image using its original physical size at a specified location.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImageUnscaled Method (Image, Int32, Int32)

GdiGraphics.DrawImageUnscaled Method (Image, Int32, Int32)
See Also
[image]

Draws the specified image using its original physical size at the location specified by a coordinate pair.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImageUnscaled (
Image image,
int x,
int y
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImageUnscaled( _
image As Image, _
x As Integer, _
y As Integer _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.

See Also

DrawImageUnscaled Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImageUnscaled Method (Image, Int32, Int32, Int32, Int32)

GdiGraphics.DrawImageUnscaled Method (Image, Int32, Int32, Int32, Int32)
See Also
[image]

Draws a specified image using its original physical size at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImageUnscaled (
Image image,
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImageUnscaled( _
image As Image, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
width
Not used.
height
Not used.

See Also

DrawImageUnscaled Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImageUnscaled Method (Image, Point)

GdiGraphics.DrawImageUnscaled Method (Image, Point)
See Also
[image]

Draws a specified image using its original physical size at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImageUnscaled (
Image image,
Point point
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImageUnscaled( _
image As Image, _
point As Point _
)

Parameters

image
A .NET Image object to draw.
point
A .NET Point structure that specifies the upper-left corner of the drawn image.

See Also

DrawImageUnscaled Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImageUnscaled Method (Image, Rectangle)

GdiGraphics.DrawImageUnscaled Method (Image, Rectangle)
See Also
[image]

Draws a specified image using its original physical size at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImageUnscaled (
Image image,
Rectangle rect
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImageUnscaled( _
image As Image, _
rect As Rectangle _
)

Parameters

image
A .NET Image object to draw.
rect
A .NET Rectangle structure that specifies the drawn image.

See Also

DrawImageUnscaled Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawLine Method

GdiGraphics.DrawLine Method
[image]

Draws a line connecting the two points specified by coordinate pairs.

Overload List

Name | Description
GdiGraphics.DrawLine (Pen, Int32, Int32, Int32, Int32) | Draws a line connecting the two points specified by coordinate pairs.
GdiGraphics.DrawLine (Pen, Point, Point) | Draws a line connecting two Point structures.
GdiGraphics.DrawLine (Pen, PointF, PointF) | Draws a line connecting two PointF structures.
GdiGraphics.DrawLine (Pen, Single, Single, Single, Single) | Draws a line connecting the two points specified by coordinate pairs.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawLine Method (Pen, Int32, Int32, Int32, Int32)

GdiGraphics.DrawLine Method (Pen, Int32, Int32, Int32, Int32)
See Also
[image]

Draws a line connecting the two points specified by coordinate pairs.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawLine (
Pen pen,
int x1,
int y1,
int x2,
int y2
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawLine( _
pen As Pen, _
x1 As Integer, _
y1 As Integer, _
x2 As Integer, _
y2 As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line.
x1
The x-coordinate of the first point.
y1
The y-coordinate of the first point.
x2
The x-coordinate of the second point.
y2
The y-coordinate of the second point.

See Also

DrawLine Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawLine Method (Pen, Point, Point)

GdiGraphics.DrawLine Method (Pen, Point, Point)
See Also
[image]

Draws a line connecting two Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawLine (
Pen pen,
Point pt1,
Point pt2
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawLine( _
pen As Pen, _
pt1 As Point, _
pt2 As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line.
pt1
A .NET Point structure that represents the first point to connect.
pt2
A .NET Point structure that represents the second point to connect.

See Also

DrawLine Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawLine Method (Pen, PointF, PointF)

GdiGraphics.DrawLine Method (Pen, PointF, PointF)
See Also
[image]

Draws a line connecting two PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawLine (
Pen pen,
PointF pt1,
PointF pt2
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawLine( _
pen As Pen, _
pt1 As PointF, _
pt2 As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line.
pt1
A .NET PointF structure that represents the first point to connect.
pt2
A .NET PointF structure that represents the second point to connect.

See Also

DrawLine Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawLine Method (Pen, Single, Single, Single, Single)

GdiGraphics.DrawLine Method (Pen, Single, Single, Single, Single)
See Also
[image]

Draws a line connecting the two points specified by coordinate pairs.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawLine (
Pen pen,
float x1,
float y1,
float x2,
float y2
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawLine( _
pen As Pen, _
x1 As Single, _
y1 As Single, _
x2 As Single, _
y2 As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line.
x1
The x-coordinate of the first point.
y1
The y-coordinate of the first point.
x2
The x-coordinate of the second point.
y2
The y-coordinate of the second point.

See Also

DrawLine Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawLines Method

GdiGraphics.DrawLines Method
[image]

Draws a series of line segments that connect an array of Point structures.

Overload List

Name | Description
GdiGraphics.DrawLines (Pen, Point[]) | Draws a series of line segments that connect an array of Point structures.
GdiGraphics.DrawLines (Pen, PointF[]) | Draws a series of line segments that connect an array of PointF structures.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawLines Method (Pen, Point[])

GdiGraphics.DrawLines Method (Pen, Point[])
See Also
[image]

Draws a series of line segments that connect an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawLines (
Pen pen,
Point[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawLines( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line segments.
points
An array of .NET Point structures that represent the points to connect.

See Also

DrawLines Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawLines Method (Pen, PointF[])

GdiGraphics.DrawLines Method (Pen, PointF[])
See Also
[image]

Draws a series of line segments that connect an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawLines (
Pen pen,
PointF[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawLines( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line segments.
points
An array of .NET PointF structures that represent the points to connect.

See Also

DrawLines Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawPath Method

GdiGraphics.DrawPath Method
[image]

Draws a .NET GraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawPath (
Pen pen,
GraphicsPath path
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawPath( _
pen As Pen, _
path As GraphicsPath _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the path.
path
A .NET GraphicsPath object to draw.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawPie Method

GdiGraphics.DrawPie Method
[image]

Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.

Overload List

Name | Description
GdiGraphics.DrawPie (Pen, Int32, Int32, Int32, Int32, Int32, Int32) | Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.
GdiGraphics.DrawPie (Pen, Rectangle, Single, Single) | Draws a pie shape defined by an ellipse specified by a Rectangle structure and two radial lines.
GdiGraphics.DrawPie (Pen, RectangleF, Single, Single) | Draws a pie shape defined by an ellipse specified by a RectangleF structure and two radial lines.
GdiGraphics.DrawPie (Pen, Single, Single, Single, Single, Single, Single) | Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawPie Method (Pen, Int32, Int32, Int32, Int32, Int32, Int32)

GdiGraphics.DrawPie Method (Pen, Int32, Int32, Int32, Int32, Int32, Int32)
See Also
[image]

Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawPie (
Pen pen,
int x,
int y,
int width,
int height,
int startAngle,
int sweepAngle
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawPie( _
pen As Pen, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer, _
startAngle As Integer, _
sweepAngle As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the pie shape.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
width
The width of the bounding rectangle that defines the ellipse from which the pie shape comes.
height
The height of the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

See Also

DrawPie Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawPie Method (Pen, Rectangle, Single, Single)

GdiGraphics.DrawPie Method (Pen, Rectangle, Single, Single)
See Also
[image]

Draws a pie shape defined by an ellipse specified by a Rectangle structure and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawPie (
Pen pen,
Rectangle rect,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawPie( _
pen As Pen, _
rect As Rectangle, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the pie shape.
rect
A .NET Rectangle structure that represents the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

See Also

DrawPie Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawPie Method (Pen, RectangleF, Single, Single)

GdiGraphics.DrawPie Method (Pen, RectangleF, Single, Single)
See Also
[image]

Draws a pie shape defined by an ellipse specified by a RectangleF structure and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawPie (
Pen pen,
RectangleF rect,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawPie( _
pen As Pen, _
rect As RectangleF, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the pie shape.
rect
A .NET RectangleF structure that represents the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

See Also

DrawPie Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawPie Method (Pen, Single, Single, Single, Single, Single, Single)

GdiGraphics.DrawPie Method (Pen, Single, Single, Single, Single, Single, Single)
See Also
[image]

Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawPie (
Pen pen,
float x,
float y,
float width,
float height,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawPie( _
pen As Pen, _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the pie shape.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
width
The width of the bounding rectangle that defines the ellipse from which the pie shape comes.
height
The height of the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

See Also

DrawPie Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawPolygon Method

GdiGraphics.DrawPolygon Method
[image]

Draws a polygon defined by an array of Point or PointF structures.

Overload List

Name | Description
GdiGraphics.DrawPolygon (Pen, Point[]) | Draws a polygon defined by an array of Point structures.
GdiGraphics.DrawPolygon (Pen, PointF[]) | Draws a polygon defined by an array of PointF structures.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawPolygon Method (Pen, Point[])

GdiGraphics.DrawPolygon Method (Pen, Point[])
See Also
[image]

Draws a polygon defined by an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawPolygon (
Pen pen,
Point[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawPolygon( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the polygon.
points
An array of .NET Point structures that represent the vertices of the polygon.

See Also

DrawPolygon Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawPolygon Method (Pen, PointF[])

GdiGraphics.DrawPolygon Method (Pen, PointF[])
See Also
[image]

Draws a polygon defined by an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawPolygon (
Pen pen,
PointF[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawPolygon( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the polygon.
points
An array of .NET PointF structures that represent the vertices of the polygon.

See Also

DrawPolygon Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawRectangle Method

GdiGraphics.DrawRectangle Method
[image]

Draws a rectangle specified by a coordinate pair, a width, and a height.

Overload List

Name | Description
GdiGraphics.DrawRectangle (Pen, Int32, Int32, Int32, Int32) | Draws a rectangle specified by a coordinate pair, a width, and a height.
GdiGraphics.DrawRectangle (Pen, Rectangle) | Draws a rectangle specified by a Rectangle structure.
GdiGraphics.DrawRectangle (Pen, Single, Single, Single, Single) | Draws a rectangle specified by a coordinate pair, a width, and a height.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawRectangle Method (Pen, Int32, Int32, Int32, Int32)

GdiGraphics.DrawRectangle Method (Pen, Int32, Int32, Int32, Int32)
See Also
[image]

Draws a rectangle specified by a coordinate pair, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawRectangle (
Pen pen,
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawRectangle( _
pen As Pen, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the rectangle.
x
The x-coordinate of the upper-left corner of the rectangle to draw.
y
The y-coordinate of the upper-left corner of the rectangle to draw.
width
The width of the rectangle to draw.
height
The height of the rectangle to draw.

See Also

DrawRectangle Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawRectangle Method (Pen, Rectangle)

GdiGraphics.DrawRectangle Method (Pen, Rectangle)
See Also
[image]

Draws a rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawRectangle (
Pen pen,
Rectangle rect
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawRectangle( _
pen As Pen, _
rect As Rectangle _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the rectangle.
rect
A .NET Rectangle structure that represents the rectangle to draw.

See Also

DrawRectangle Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawRectangle Method (Pen, Single, Single, Single, Single)

GdiGraphics.DrawRectangle Method (Pen, Single, Single, Single, Single)
See Also
[image]

Draws a rectangle specified by a coordinate pair, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawRectangle (
Pen pen,
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawRectangle( _
pen As Pen, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the rectangle.
x
The x-coordinate of the upper-left corner of the rectangle to draw.
y
The y-coordinate of the upper-left corner of the rectangle to draw.
width
The width of the rectangle to draw.
height
The height of the rectangle to draw.

See Also

DrawRectangle Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawRectangles Method

GdiGraphics.DrawRectangles Method
[image]

Draws a series of rectangles specified by Rectangle or RectangleF structures.

Overload List

Name | Description
GdiGraphics.DrawRectangles (Pen, Rectangle[]) | Draws a series of rectangles specified by Rectangle structures.
GdiGraphics.DrawRectangles (Pen, RectangleF[]) | Draws a series of rectangles specified by RectangleF structures.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawRectangles Method (Pen, Rectangle[])

GdiGraphics.DrawRectangles Method (Pen, Rectangle[])
See Also
[image]

Draws a series of rectangles specified by Rectangle structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawRectangles (
Pen pen,
Rectangle[] rects
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawRectangles( _
pen As Pen, _
rects() As Rectangle _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the outlines of the rectangles.
rects
An array of .NET Rectangle structures that represent the rectangles to draw.

See Also

DrawRectangles Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawRectangles Method (Pen, RectangleF[])

GdiGraphics.DrawRectangles Method (Pen, RectangleF[])
See Also
[image]

Draws a series of rectangles specified by RectangleF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawRectangles (
Pen pen,
RectangleF[] rects
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawRectangles( _
pen As Pen, _
rects() As RectangleF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the outlines of the rectangles.
rects
An array of .NET RectangleF structures that represent the rectangles to draw.

See Also

DrawRectangles Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawString Method

GdiGraphics.DrawString Method
[image]

Draws the specified text string at the specified location with the specified Brush and Font objects.

Overload List

Name | Description
GdiGraphics.DrawString (String, Font, Brush, PointF) | Draws the specified text string at the specified location with the specified Brush and Font objects.
GdiGraphics.DrawString (String, Font, Brush, PointF, StringFormat) | Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.
GdiGraphics.DrawString (String, Font, Brush, RectangleF) | Draws the specified text string in the specified rectangle with the specified Brush and Font objects.
GdiGraphics.DrawString (String, Font, Brush, RectangleF, StringFormat) | Draws the specified text string in the specified rectangle with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.
GdiGraphics.DrawString (String, Font, Brush, Single, Single) | Draws the specified text string at the specified location with the specified Brush and Font objects.
GdiGraphics.DrawString (String, Font, Brush, Single, Single, StringFormat) | Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawString Method (String, Font, Brush, PointF)

GdiGraphics.DrawString Method (String, Font, Brush, PointF)
See Also
[image]

Draws the specified text string at the specified location with the specified Brush and Font objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawString (
string s,
Font font,
Brush brush,
PointF point
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawString( _
s As String, _
font As Font, _
brush As Brush, _
point As PointF _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
point
A .NET PointF structure that specifies the upper-left corner of the drawn text.

See Also

DrawString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawString Method (String, Font, Brush, PointF, StringFormat)

GdiGraphics.DrawString Method (String, Font, Brush, PointF, StringFormat)
See Also
[image]

Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawString (
string s,
Font font,
Brush brush,
PointF point,
StringFormat format
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawString( _
s As String, _
font As Font, _
brush As Brush, _
point As PointF, _
format As StringFormat _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
point
A .NET PointF structure that specifies the upper-left corner of the drawn text.
format
A .NET StringFormat object that specifies formatting attributes, such as line spacing and alignment, that are applied to the drawn text.

See Also

DrawString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawString Method (String, Font, Brush, RectangleF)

GdiGraphics.DrawString Method (String, Font, Brush, RectangleF)
See Also
[image]

Draws the specified text string in the specified rectangle with the specified Brush and Font objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawString (
string s,
Font font,
Brush brush,
RectangleF layoutRectangle
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawString( _
s As String, _
font As Font, _
brush As Brush, _
layoutRectangle As RectangleF _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
layoutRectangle
A .NET RectangleF structure that specifies the location of the drawn text.

See Also

DrawString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawString Method (String, Font, Brush, RectangleF, StringFormat)

GdiGraphics.DrawString Method (String, Font, Brush, RectangleF, StringFormat)
See Also
[image]

Draws the specified text string in the specified rectangle with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawString (
string s,
Font font,
Brush brush,
RectangleF layoutRectangle,
StringFormat format
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawString( _
s As String, _
font As Font, _
brush As Brush, _
layoutRectangle As RectangleF, _
format As StringFormat _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
layoutRectangle
A .NET RectangleF structure that specifies the location of the drawn text.
format
A .NET StringFormat object that specifies formatting attributes, such as line spacing and alignment, that are applied to the drawn text.

See Also

DrawString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawString Method (String, Font, Brush, Single, Single)

GdiGraphics.DrawString Method (String, Font, Brush, Single, Single)
See Also
[image]

Draws the specified text string at the specified location with the specified Brush and Font objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawString (
string s,
Font font,
Brush brush,
float x,
float y
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawString( _
s As String, _
font As Font, _
brush As Brush, _
x As Single, _
y As Single _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
x
The x-coordinate of the upper-left corner of the drawn text.
y
The y-coordinate of the upper-left corner of the drawn text.

See Also

DrawString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawString Method (String, Font, Brush, Single, Single, StringFormat)

GdiGraphics.DrawString Method (String, Font, Brush, Single, Single, StringFormat)
See Also
[image]

Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawString (
string s,
Font font,
Brush brush,
float x,
float y,
StringFormat format
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawString( _
s As String, _
font As Font, _
brush As Brush, _
x As Single, _
y As Single, _
format As StringFormat _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
x
The x-coordinate of the upper-left corner of the drawn text.
y
The y-coordinate of the upper-left corner of the drawn text.
format
A .NET StringFormat object that specifies formatting attributes, such as line spacing and alignment, that are applied to the drawn text.

See Also

DrawString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EndContainer Method

GdiGraphics.EndContainer Method
[image]

Closes the current graphics container and restores the state of this GdiGraphics object to the state saved by a call to the BeginContainer method.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void EndContainer (
GraphicsContainer container
)

Visual Basic [image] Copy Code

Public Overridable Sub EndContainer( _
container As GraphicsContainer _
)

Parameters

container
A .NET GraphicsContainer object that represents the container this method restores.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EndHyperLink Method

GdiGraphics.EndHyperLink Method
[image]

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void EndHyperLink ()

Visual Basic [image] Copy Code

Public Overridable Sub EndHyperLink ()

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method

GdiGraphics.EnumerateMetafile Method
[image]

Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.

Overload List

Name | Description
GdiGraphics.EnumerateMetafile (Metafile, Point, Graphics.EnumerateMetafileProc) | Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.
GdiGraphics.EnumerateMetafile (Metafile, Point, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.
GdiGraphics.EnumerateMetafile (Metafile, Point, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, Point, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point.
GdiGraphics.EnumerateMetafile (Metafile, Point, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point.
GdiGraphics.EnumerateMetafile (Metafile, Point, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, Point[], Graphics.EnumerateMetafileProc) | Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram.
GdiGraphics.EnumerateMetafile (Metafile, Point[], Graphics.EnumerateMetafileProc, IntPtr) | Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram.
GdiGraphics.EnumerateMetafile (Metafile, Point[], Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, Point[], Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram.
GdiGraphics.EnumerateMetafile (Metafile, Point[], Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram.
GdiGraphics.EnumerateMetafile (Metafile, Point[], Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, PointF, Graphics.EnumerateMetafileProc) | Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.
GdiGraphics.EnumerateMetafile (Metafile, PointF, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.
GdiGraphics.EnumerateMetafile (Metafile, PointF, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, PointF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point.
GdiGraphics.EnumerateMetafile (Metafile, PointF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point.
GdiGraphics.EnumerateMetafile (Metafile, PointF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, PointF[], Graphics.EnumerateMetafileProc) | Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram.
GdiGraphics.EnumerateMetafile (Metafile, PointF[], Graphics.EnumerateMetafileProc, IntPtr) | Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram.
GdiGraphics.EnumerateMetafile (Metafile, PointF[], Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, PointF[], RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram.
GdiGraphics.EnumerateMetafile (Metafile, PointF[], RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram.
GdiGraphics.EnumerateMetafile (Metafile, PointF[], RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, Rectangle, Graphics.EnumerateMetafileProc) | Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle.
GdiGraphics.EnumerateMetafile (Metafile, Rectangle, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle.
GdiGraphics.EnumerateMetafile (Metafile, Rectangle, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, Rectangle, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc) | Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle.
GdiGraphics.EnumerateMetafile (Metafile, Rectangle, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle.
GdiGraphics.EnumerateMetafile (Metafile, Rectangle, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, RectangleF, Graphics.EnumerateMetafileProc) | Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle.
GdiGraphics.EnumerateMetafile (Metafile, RectangleF, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle.
GdiGraphics.EnumerateMetafile (Metafile, RectangleF, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, RectangleF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc) | Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle.
GdiGraphics.EnumerateMetafile (Metafile, RectangleF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle.
GdiGraphics.EnumerateMetafile (Metafile, RectangleF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle using specified image attributes.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, Point, Graphics.EnumerateMetafileProc)
See Also
[image]

Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Point destPoint,
Graphics.EnumerateMetafileProc callback
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoint As Point, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET Point structure that specifies the location of the upper-left corner of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, Point, Graphics.EnumerateMetafileProc, IntPtr)
See Also
[image]

Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Point destPoint,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoint As Point, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET Point structure that specifies the location of the upper-left corner of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, Point, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also
[image]

Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Point destPoint,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoint As Point, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET Point structure that specifies the location of the upper-left corner of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, Point, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc)
See Also
[image]

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Point destPoint,
Rectangle srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoint As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET Point structure that specifies the location of the upper-left corner of the drawn metafile.
srcRect
A .NET Rectangle structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, Point, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)
See Also
[image]

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Point destPoint,
Rectangle srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoint As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET Point structure that specifies the location of the upper-left corner of the drawn metafile.
srcRect
A .NET Rectangle structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, Point, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also
[image]

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Point destPoint,
Rectangle srcRect,
GraphicsUnit unit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoint As Point, _
srcRect As Rectangle, _
unit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET Point structure that specifies the location of the upper-left corner of the drawn metafile.
srcRect
A .NET Rectangle structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Graphics.EnumerateMetafileProc)
See Also
[image]

Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Point[] destPoints,
Graphics.EnumerateMetafileProc callback
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoints() As Point, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET Point structures that define a parallelogram that determines the size and location of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Graphics.EnumerateMetafileProc, IntPtr)
See Also
[image]

Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Point[] destPoints,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoints() As Point, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET Point structures that define a parallelogram that determines the size and location of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also
[image]

Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Point[] destPoints,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoints() As Point, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET Point structures that define a parallelogram that determines the size and location of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc)
See Also
[image]

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoints() As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET Point structures that define a parallelogram that determines the size and location of the drawn metafile.
srcRect
A .NET Rectangle structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)
See Also
[image]

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoints() As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET Point structures that define a parallelogram that determines the size and location of the drawn metafile.
srcRect
A .NET Rectangle structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also
[image]

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit unit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoints() As Point, _
srcRect As Rectangle, _
unit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET Point structures that define a parallelogram that determines the size and location of the drawn metafile.
srcRect
A .NET Rectangle structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF, Graphics.EnumerateMetafileProc)
See Also
[image]

Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
PointF destPoint,
Graphics.EnumerateMetafileProc callback
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoint As PointF, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET PointF structure that specifies the location of the upper-left corner of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF, Graphics.EnumerateMetafileProc, IntPtr)
See Also
[image]

Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
PointF destPoint,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoint As PointF, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET PointF structure that specifies the location of the upper-left corner of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also
[image]

Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
PointF destPoint,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoint As PointF, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET PointF structure that specifies the location of the upper-left corner of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc)
See Also
[image]

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
PointF destPoint,
RectangleF srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoint As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET PointF structure that specifies the location of the upper-left corner of the drawn metafile.
srcRect
A .NET RectangleF structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)
See Also
[image]

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
PointF destPoint,
RectangleF srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoint As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET PointF structure that specifies the location of the upper-left corner of the drawn metafile.
srcRect
A .NET RectangleF structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also
[image]

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
PointF destPoint,
RectangleF srcRect,
GraphicsUnit unit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoint As PointF, _
srcRect As RectangleF, _
unit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET PointF structure that specifies the location of the upper-left corner of the drawn metafile.
srcRect
A .NET RectangleF structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], Graphics.EnumerateMetafileProc)
See Also
[image]

Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
PointF[] destPoints,
Graphics.EnumerateMetafileProc callback
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoints() As PointF, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET PointF structures that define a parallelogram that determines the size and location of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], Graphics.EnumerateMetafileProc, IntPtr)
See Also
[image]

Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
PointF[] destPoints,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoints() As PointF, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET PointF structures that define a parallelogram that determines the size and location of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also
[image]

Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
PointF[] destPoints,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoints() As PointF, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET PointF structures that define a parallelogram that determines the size and location of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc)
See Also
[image]

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoints() As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET PointF structures that define a parallelogram that determines the size and location of the drawn metafile.
srcRect
A .NET RectangleF structures that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)
See Also
[image]

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoints() As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET PointF structures that define a parallelogram that determines the size and location of the drawn metafile.
srcRect
A .NET RectangleF structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also
[image]

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit unit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoints() As PointF, _
srcRect As RectangleF, _
unit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET PointF structures that define a parallelogram that determines the size and location of the drawn metafile.
srcRect
A .NET RectangleF structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Graphics.EnumerateMetafileProc)
See Also
[image]

Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Rectangle destRect,
Graphics.EnumerateMetafileProc callback
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destRect As Rectangle, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Graphics.EnumerateMetafileProc, IntPtr)
See Also
[image]

Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Rectangle destRect,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destRect As Rectangle, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also
[image]

Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Rectangle destRect,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destRect As Rectangle, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET RectangleF structure that specifies the location and size of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc)
See Also
[image]

Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Rectangle destRect,
Rectangle srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destRect As Rectangle, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn metafile.
srcRect
A .NET Rectangle structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)
See Also
[image]

Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Rectangle destRect,
Rectangle srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destRect As Rectangle, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn metafile.
srcRect
A .NET Rectangle structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also
[image]

Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Rectangle destRect,
Rectangle srcRect,
GraphicsUnit unit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destRect As Rectangle, _
srcRect As Rectangle, _
unit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn metafile.
srcRect
A .NET Rectangle structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, Graphics.EnumerateMetafileProc)
See Also
[image]

Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
RectangleF destRect,
Graphics.EnumerateMetafileProc callback
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destRect As RectangleF, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET RectangleF structure that specifies the location and size of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, Graphics.EnumerateMetafileProc, IntPtr)
See Also
[image]

Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
RectangleF destRect,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destRect As RectangleF, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET RectangleF structure that specifies the location and size of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also
[image]

Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
RectangleF destRect,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destRect As RectangleF, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET RectangleF structure that specifies the location and size of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc)
See Also
[image]

Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
RectangleF destRect,
RectangleF srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destRect As RectangleF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET RectangleF structure that specifies the location and size of the drawn metafile.
srcRect
A .NET RectangleF structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)
See Also
[image]

Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
RectangleF destRect,
RectangleF srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destRect As RectangleF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET RectangleF structure that specifies the location and size of the drawn metafile.
srcRect
A .NET RectangleF structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also
[image]

Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
RectangleF destRect,
RectangleF srcRect,
GraphicsUnit unit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destRect As RectangleF, _
srcRect As RectangleF, _
unit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET RectangleF structure that specifies the location and size of the drawn metafile.
srcRect
A .NET RectangleF structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ExcludeClip Method

GdiGraphics.ExcludeClip Method
[image]

Updates the clip region of this GdiGraphics object to exclude the area specified by a .NET Rectangle structure.

Overload List

Name | Description
GdiGraphics.ExcludeClip (Rectangle) | Updates the clip region of this GdiGraphics object to exclude the area specified by a Rectangle structure.
GdiGraphics.ExcludeClip (Region) | Updates the clip region of this GdiGraphics object to exclude the area specified by a Region object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ExcludeClip Method (Rectangle)

GdiGraphics.ExcludeClip Method (Rectangle)
See Also
[image]

Updates the clip region of this GdiGraphics object to exclude the area specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void ExcludeClip (
Rectangle rect
)

Visual Basic [image] Copy Code

Public Overridable Sub ExcludeClip( _
rect As Rectangle _
)

Parameters

rect
A .NET Rectangle structure that specifies the rectangle to exclude from the clip region.

See Also

ExcludeClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ExcludeClip Method (Region)

GdiGraphics.ExcludeClip Method (Region)
See Also
[image]

Updates the clip region of this GdiGraphics object to exclude the area specified by a Region object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void ExcludeClip (
Region region
)

Visual Basic [image] Copy Code

Public Overridable Sub ExcludeClip( _
region As Region _
)

Parameters

region
A .NET Region object that specifies the region to exclude from the clip region.

See Also

ExcludeClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillClosedCurve Method

GdiGraphics.FillClosedCurve Method
[image]

Fills the interior a closed cardinal spline curve defined by an array of Point structures.

Overload List

Name | Description
GdiGraphics.FillClosedCurve (Brush, Point[]) | Fills the interior a closed cardinal spline curve defined by an array of Point structures.
GdiGraphics.FillClosedCurve (Brush, Point[], FillMode) | Fills the interior a closed cardinal spline curve defined by an array of Point structures using the specified fill mode.
GdiGraphics.FillClosedCurve (Brush, Point[], FillMode, Single) | Fills the interior a closed cardinal spline curve defined by an array of Point structures using the specified fill mode and tension.
GdiGraphics.FillClosedCurve (Brush, PointF[]) | Fills the interior a closed cardinal spline curve defined by an array of PointF structures.
GdiGraphics.FillClosedCurve (Brush, PointF[], FillMode) | Fills the interior a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode.
GdiGraphics.FillClosedCurve (Brush, PointF[], FillMode, Single) | Fills the interior a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode and tension.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillClosedCurve Method (Brush, Point[])

GdiGraphics.FillClosedCurve Method (Brush, Point[])
See Also
[image]

Fills the interior a closed cardinal spline curve defined by an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillClosedCurve (
Brush brush,
Point[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub FillClosedCurve( _
brush As Brush, _
points() As Point _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that define the spline.

See Also

FillClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillClosedCurve Method (Brush, Point[], FillMode)

GdiGraphics.FillClosedCurve Method (Brush, Point[], FillMode)
See Also
[image]

Fills the interior a closed cardinal spline curve defined by an array of Point structures using the specified fill mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillClosedCurve (
Brush brush,
Point[] points,
FillMode fillmode
)

Visual Basic [image] Copy Code

Public Overridable Sub FillClosedCurve( _
brush As Brush, _
points() As Point, _
fillmode As FillMode _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that define the spline.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled.

See Also

FillClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillClosedCurve Method (Brush, Point[], FillMode, Single)

GdiGraphics.FillClosedCurve Method (Brush, Point[], FillMode, Single)
See Also
[image]

Fills the interior a closed cardinal spline curve defined by an array of Point structures using the specified fill mode and tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillClosedCurve (
Brush brush,
Point[] points,
FillMode fillmode,
float tension
)

Visual Basic [image] Copy Code

Public Overridable Sub FillClosedCurve( _
brush As Brush, _
points() As Point, _
fillmode As FillMode, _
tension As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that define the spline.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

FillClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillClosedCurve Method (Brush, PointF[])

GdiGraphics.FillClosedCurve Method (Brush, PointF[])
See Also
[image]

Fills the interior a closed cardinal spline curve defined by an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillClosedCurve (
Brush brush,
PointF[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub FillClosedCurve( _
brush As Brush, _
points() As PointF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that define the spline.

See Also

FillClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillClosedCurve Method (Brush, PointF[], FillMode)

GdiGraphics.FillClosedCurve Method (Brush, PointF[], FillMode)
See Also
[image]

Fills the interior a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillClosedCurve (
Brush brush,
PointF[] points,
FillMode fillmode
)

Visual Basic [image] Copy Code

Public Overridable Sub FillClosedCurve( _
brush As Brush, _
points() As PointF, _
fillmode As FillMode _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that define the spline.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled.

See Also

FillClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillClosedCurve Method (Brush, PointF[], FillMode, Single)

GdiGraphics.FillClosedCurve Method (Brush, PointF[], FillMode, Single)
See Also
[image]

Fills the interior a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode and tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillClosedCurve (
Brush brush,
PointF[] points,
FillMode fillmode,
float tension
)

Visual Basic [image] Copy Code

Public Overridable Sub FillClosedCurve( _
brush As Brush, _
points() As PointF, _
fillmode As FillMode, _
tension As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that define the spline.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

FillClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillEllipse Method

GdiGraphics.FillEllipse Method
[image]

Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

Overload List

Name | Description
GdiGraphics.FillEllipse (Brush, Int32, Int32, Int32, Int32) | Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.
GdiGraphics.FillEllipse (Brush, Rectangle) | Fills the interior of an ellipse defined by a bounding rectangle specified by a Rectangle structure.
GdiGraphics.FillEllipse (Brush, RectangleF) | Fills the interior of an ellipse defined by a bounding rectangle specified by a RectangleF structure.
GdiGraphics.FillEllipse (Brush, Single, Single, Single, Single) | Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillEllipse Method (Brush, Int32, Int32, Int32, Int32)

GdiGraphics.FillEllipse Method (Brush, Int32, Int32, Int32, Int32)
See Also
[image]

Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillEllipse (
Brush brush,
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Public Overridable Sub FillEllipse( _
brush As Brush, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
The width of the bounding rectangle that defines the ellipse.
height
The height of the bounding rectangle that defines the ellipse.

See Also

FillEllipse Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillEllipse Method (Brush, Rectangle)

GdiGraphics.FillEllipse Method (Brush, Rectangle)
See Also
[image]

Fills the interior of an ellipse defined by a bounding rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillEllipse (
Brush brush,
Rectangle rect
)

Visual Basic [image] Copy Code

Public Overridable Sub FillEllipse( _
brush As Brush, _
rect As Rectangle _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET Rectangle structure that represents the bounding rectangle that defines the ellipse.

See Also

FillEllipse Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillEllipse Method (Brush, RectangleF)

GdiGraphics.FillEllipse Method (Brush, RectangleF)
See Also
[image]

Fills the interior of an ellipse defined by a bounding rectangle specified by a RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillEllipse (
Brush brush,
RectangleF rect
)

Visual Basic [image] Copy Code

Public Overridable Sub FillEllipse( _
brush As Brush, _
rect As RectangleF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET RectangleF structure that represents the bounding rectangle that defines the ellipse.

See Also

FillEllipse Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillEllipse Method (Brush, Single, Single, Single, Single)

GdiGraphics.FillEllipse Method (Brush, Single, Single, Single, Single)
See Also
[image]

Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillEllipse (
Brush brush,
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Public Overridable Sub FillEllipse( _
brush As Brush, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
The width of the bounding rectangle that defines the ellipse.
height
The height of the bounding rectangle that defines the ellipse.

See Also

FillEllipse Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPath Method

GdiGraphics.FillPath Method
[image]

Fills the interior of a .NET GraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillPath (
Brush brush,
GraphicsPath path
)

Visual Basic [image] Copy Code

Public Overridable Sub FillPath( _
brush As Brush, _
path As GraphicsPath _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
path
A .NET GraphicsPath object that represents the path to fill.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPie Method

GdiGraphics.FillPie Method
[image]

Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.

Overload List

Name | Description
GdiGraphics.FillPie (Brush, Int32, Int32, Int32, Int32, Int32, Int32) | Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.
GdiGraphics.FillPie (Brush, Rectangle, Single, Single) | Fills the interior of a pie section defined by an ellipse specified by a RectangleF structure and two radial lines.
GdiGraphics.FillPie (Brush, Single, Single, Single, Single, Single, Single) | Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPie Method (Brush, Int32, Int32, Int32, Int32, Int32, Int32)

GdiGraphics.FillPie Method (Brush, Int32, Int32, Int32, Int32, Int32, Int32)
See Also
[image]

Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillPie (
Brush brush,
int x,
int y,
int width,
int height,
int startAngle,
int sweepAngle
)

Visual Basic [image] Copy Code

Public Overridable Sub FillPie( _
brush As Brush, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer, _
startAngle As Integer, _
sweepAngle As Integer _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
width
The width of the bounding rectangle that defines the ellipse from which the pie section comes.
height
The height of the bounding rectangle that defines the ellipse from which the pie section comes.
startAngle
The angle in degrees measured clockwise from the x-axis to the first side of the pie section.
sweepAngle
The angle in degrees measured clockwise from the startAngle parameter to the second side of the pie section.

See Also

FillPie Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPie Method (Brush, Rectangle, Single, Single)

GdiGraphics.FillPie Method (Brush, Rectangle, Single, Single)
See Also
[image]

Fills the interior of a pie section defined by an ellipse specified by a RectangleF structure and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillPie (
Brush brush,
Rectangle rect,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Public Overridable Sub FillPie( _
brush As Brush, _
rect As Rectangle, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET Rectangle structure that represents the bounding rectangle that defines the ellipse from which the pie section comes.
startAngle
The angle in degrees measured clockwise from the x-axis to the first side of the pie section.
sweepAngle
The angle in degrees measured clockwise from the startAngle parameter to the second side of the pie section.

See Also

FillPie Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPie Method (Brush, Single, Single, Single, Single, Single, Single)

GdiGraphics.FillPie Method (Brush, Single, Single, Single, Single, Single, Single)
See Also
[image]

Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillPie (
Brush brush,
float x,
float y,
float width,
float height,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Public Overridable Sub FillPie( _
brush As Brush, _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
width
The width of the bounding rectangle that defines the ellipse from which the pie section comes.
height
The height of the bounding rectangle that defines the ellipse from which the pie section comes.
startAngle
The angle in degrees measured clockwise from the x-axis to the first side of the pie section.
sweepAngle
The angle in degrees measured clockwise from the startAngle parameter to the second side of the pie section.

See Also

FillPie Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPolygon Method

GdiGraphics.FillPolygon Method
[image]

Fills the interior of a polygon defined by an array of points specified by Point structures.

Overload List

Name | Description
GdiGraphics.FillPolygon (Brush, Point[]) | Fills the interior of a polygon defined by an array of points specified by Point structures.
GdiGraphics.FillPolygon (Brush, Point[], FillMode) | Fills the interior of a polygon defined by an array of points specified by Point structures using the specified fill mode.
GdiGraphics.FillPolygon (Brush, PointF[]) | Fills the interior of a polygon defined by an array of points specified by PointF structures.
GdiGraphics.FillPolygon (Brush, PointF[], FillMode) | Fills the interior of a polygon defined by an array of points specified by PointF structures using the specified fill mode.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPolygon Method (Brush, Point[])

GdiGraphics.FillPolygon Method (Brush, Point[])
See Also
[image]

Fills the interior of a polygon defined by an array of points specified by Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillPolygon (
Brush brush,
Point[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub FillPolygon( _
brush As Brush, _
points() As Point _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that represent the vertices of the polygon to fill.

See Also

FillPolygon Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPolygon Method (Brush, Point[], FillMode)

GdiGraphics.FillPolygon Method (Brush, Point[], FillMode)
See Also
[image]

Fills the interior of a polygon defined by an array of points specified by Point structures using the specified fill mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillPolygon (
Brush brush,
Point[] points,
FillMode fillMode
)

Visual Basic [image] Copy Code

Public Overridable Sub FillPolygon( _
brush As Brush, _
points() As Point, _
fillMode As FillMode _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that represent the vertices of the polygon to fill.
fillMode
Member of the .NET FillMode enumeration that determines the style of the fill.

See Also

FillPolygon Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPolygon Method (Brush, PointF[])

GdiGraphics.FillPolygon Method (Brush, PointF[])
See Also
[image]

Fills the interior of a polygon defined by an array of points specified by PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillPolygon (
Brush brush,
PointF[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub FillPolygon( _
brush As Brush, _
points() As PointF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that represent the vertices of the polygon to fill.

See Also

FillPolygon Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPolygon Method (Brush, PointF[], FillMode)

GdiGraphics.FillPolygon Method (Brush, PointF[], FillMode)
See Also
[image]

Fills the interior of a polygon defined by an array of points specified by PointF structures using the specified fill mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillPolygon (
Brush brush,
PointF[] points,
FillMode fillMode
)

Visual Basic [image] Copy Code

Public Overridable Sub FillPolygon( _
brush As Brush, _
points() As PointF, _
fillMode As FillMode _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that represent the vertices of the polygon to fill.
fillMode
Member of the .NET FillMode enumeration that determines the style of the fill.

See Also

FillPolygon Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillRectangle Method

GdiGraphics.FillRectangle Method
[image]

Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.

Overload List

Name | Description
GdiGraphics.FillRectangle (Brush, Int32, Int32, Int32, Int32) | Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.
GdiGraphics.FillRectangle (Brush, Rectangle) | Fills the interior of a rectangle specified by a Rectangle structure.
GdiGraphics.FillRectangle (Brush, RectangleF) | Fills the interior of a rectangle specified by a RectangleF structure.
GdiGraphics.FillRectangle (Brush, Single, Single, Single, Single) | Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillRectangle Method (Brush, Int32, Int32, Int32, Int32)

GdiGraphics.FillRectangle Method (Brush, Int32, Int32, Int32, Int32)
See Also
[image]

Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillRectangle (
Brush brush,
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Public Overridable Sub FillRectangle( _
brush As Brush, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the rectangle to fill.
y
The y-coordinate of the upper-left corner of the rectangle to fill.
width
The width of the rectangle to fill.
height
The height of the rectangle to fill.

See Also

FillRectangle Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillRectangle Method (Brush, Rectangle)

GdiGraphics.FillRectangle Method (Brush, Rectangle)
See Also
[image]

Fills the interior of a rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillRectangle (
Brush brush,
Rectangle rect
)

Visual Basic [image] Copy Code

Public Overridable Sub FillRectangle( _
brush As Brush, _
rect As Rectangle _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET Rectangle structure that represents the rectangle to fill.

See Also

FillRectangle Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillRectangle Method (Brush, RectangleF)

GdiGraphics.FillRectangle Method (Brush, RectangleF)
See Also
[image]

Fills the interior of a rectangle specified by a RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillRectangle (
Brush brush,
RectangleF rect
)

Visual Basic [image] Copy Code

Public Overridable Sub FillRectangle( _
brush As Brush, _
rect As RectangleF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET RectangleF structure that represents the rectangle to fill.

See Also

FillRectangle Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillRectangle Method (Brush, Single, Single, Single, Single)

GdiGraphics.FillRectangle Method (Brush, Single, Single, Single, Single)
See Also
[image]

Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillRectangle (
Brush brush,
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Public Overridable Sub FillRectangle( _
brush As Brush, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the rectangle to fill.
y
The y-coordinate of the upper-left corner of the rectangle to fill.
width
The width of the rectangle to fill.
height
The height of the rectangle to fill.

See Also

FillRectangle Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillRectangles Method

GdiGraphics.FillRectangles Method
[image]

Fills the interiors of a series of rectangles specified by Rectangle structures.

Overload List

Name | Description
GdiGraphics.FillRectangles (Brush, Rectangle[]) | Fills the interiors of a series of rectangles specified by Rectangle structures.
GdiGraphics.FillRectangles (Brush, RectangleF[]) | Fills the interiors of a series of rectangles specified by RectangleF structures.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillRectangles Method (Brush, Rectangle[])

GdiGraphics.FillRectangles Method (Brush, Rectangle[])
See Also
[image]

Fills the interiors of a series of rectangles specified by Rectangle structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillRectangles (
Brush brush,
Rectangle[] rects
)

Visual Basic [image] Copy Code

Public Overridable Sub FillRectangles( _
brush As Brush, _
rects() As Rectangle _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rects
An array of .NET Rectangle structures that represent the rectangles to fill.

See Also

FillRectangles Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillRectangles Method (Brush, RectangleF[])

GdiGraphics.FillRectangles Method (Brush, RectangleF[])
See Also
[image]

Fills the interiors of a series of rectangles specified by RectangleF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillRectangles (
Brush brush,
RectangleF[] rects
)

Visual Basic [image] Copy Code

Public Overridable Sub FillRectangles( _
brush As Brush, _
rects() As RectangleF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rects
An array of .NET RectangleF structures that represent the rectangles to fill.

See Also

FillRectangles Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillRegion Method

GdiGraphics.FillRegion Method
[image]

Fills the interior of a .NET Region object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillRegion (
Brush brush,
Region region
)

Visual Basic [image] Copy Code

Public Overridable Sub FillRegion( _
brush As Brush, _
region As Region _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
region
A .NET Region object that represents the area to fill.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Flush Method

GdiGraphics.Flush Method
[image]

Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.

Overload List

Name | Description
GdiGraphics.Flush () | Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.
GdiGraphics.Flush (FlushIntention) | Forces execution of all pending graphics operations with the method waiting or not waiting, as specified, to return before the operations finish.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Flush Method ()

GdiGraphics.Flush Method ()
See Also
[image]

Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void Flush ()

Visual Basic [image] Copy Code

Public Overridable Sub Flush ()

See Also

Flush Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Flush Method (FlushIntention)

GdiGraphics.Flush Method (FlushIntention)
See Also
[image]

Forces execution of all pending graphics operations with the method waiting or not waiting, as specified, to return before the operations finish.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void Flush (
FlushIntention intention
)

Visual Basic [image] Copy Code

Public Overridable Sub Flush( _
intention As FlushIntention _
)

Parameters

intention
Member of the .NET FlushIntention enumeration that specifies whether the method returns immediately or waits for any existing operations to finish.

See Also

Flush Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.GetFontHeight Method

GdiGraphics.GetFontHeight Method
[image]

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual float GetFontHeight (
Font font
)

Visual Basic [image] Copy Code

Public Overridable Function GetFontHeight( _
font As Font _
) As Single

Parameters

font

Return Value

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.GetHdc Method

GdiGraphics.GetHdc Method
[image]

Gets the handle to the device context associated with this GdiGraphics.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual IntPtr GetHdc ()

Visual Basic [image] Copy Code

Public Overridable Function GetHdc () As IntPtr

Return Value

Handle to the device context associated with this GdiGraphics.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.GetNearestColor Method

GdiGraphics.GetNearestColor Method
[image]

Gets the nearest color to the specified Color structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual Color GetNearestColor (
Color color
)

Visual Basic [image] Copy Code

Public Overridable Function GetNearestColor( _
color As Color _
) As Color

Parameters

color
A .NET Color structure for which to find a match.

Return Value

A .NET Color structure that represents the nearest color to the one specified with the color parameter.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IntersectClip Method

GdiGraphics.IntersectClip Method
[image]

Updates the clip region of this GdiGraphics object to the intersection of the current clip region and the specified Rectangle structure.

Overload List

Name | Description
GdiGraphics.IntersectClip (Rectangle) | Updates the clip region of this GdiGraphics object to the intersection of the current clip region and the specified Rectangle structure.
GdiGraphics.IntersectClip (RectangleF) | Updates the clip region of this GdiGraphics object to the intersection of the current clip region and the specified RectangleF structure.
GdiGraphics.IntersectClip (Region) | Updates the clip region of this GdiGraphics object to the intersection of the current clip region and the specified Region object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IntersectClip Method (Rectangle)

GdiGraphics.IntersectClip Method (Rectangle)
See Also
[image]

Updates the clip region of this GdiGraphics object to the intersection of the current clip region and the specified Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void IntersectClip (
Rectangle rect
)

Visual Basic [image] Copy Code

Public Overridable Sub IntersectClip( _
rect As Rectangle _
)

Parameters

rect
A .NET Rectangle structure to intersect with the current clip region.

See Also

IntersectClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IntersectClip Method (RectangleF)

GdiGraphics.IntersectClip Method (RectangleF)
See Also
[image]

Updates the clip region of this GdiGraphics object to the intersection of the current clip region and the specified RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void IntersectClip (
RectangleF rect
)

Visual Basic [image] Copy Code

Public Overridable Sub IntersectClip( _
rect As RectangleF _
)

Parameters

rect
A .NET RectangleF structure to intersect with the current clip region.

See Also

IntersectClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IntersectClip Method (Region)

GdiGraphics.IntersectClip Method (Region)
See Also
[image]

Updates the clip region of this GdiGraphics object to the intersection of the current clip region and the specified Region object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void IntersectClip (
Region region
)

Visual Basic [image] Copy Code

Public Overridable Sub IntersectClip( _
region As Region _
)

Parameters

region
A .NET Region object to intersect with the current region.

See Also

IntersectClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisible Method

GdiGraphics.IsVisible Method
[image]

Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this GdiGraphics object.

Overload List

Name | Description
GdiGraphics.IsVisible (Int32, Int32) | Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this GdiGraphics object.
GdiGraphics.IsVisible (Int32, Int32, Int32, Int32) | Indicates whether the rectangle specified by a pair of coordinates, a width, and a height is contained within the visible clip region of this GdiGraphics object.
GdiGraphics.IsVisible (Point) | Indicates whether the specified Point structure is contained within the visible clip region of this GdiGraphics object.
GdiGraphics.IsVisible (PointF) | Indicates whether the specified PointF structure is contained within the visible clip region of this GdiGraphics object.
GdiGraphics.IsVisible (Rectangle) | Indicates whether the rectangle specified by a Rectangle structure is contained within the visible clip region of this GdiGraphics object.
GdiGraphics.IsVisible (RectangleF) | Indicates whether the rectangle specified by a RectangleF structure is contained within the visible clip region of this GdiGraphics object.
GdiGraphics.IsVisible (Single, Single) | Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this GdiGraphics object.
GdiGraphics.IsVisible (Single, Single, Single, Single) | Indicates whether the rectangle specified by a pair of coordinates, a width, and a height is contained within the visible clip region of this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisible Method (Int32, Int32)

GdiGraphics.IsVisible Method (Int32, Int32)
See Also
[image]

Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual bool IsVisible (
int x,
int y
)

Visual Basic [image] Copy Code

Public Overridable Function IsVisible( _
x As Integer, _
y As Integer _
) As Boolean

Parameters

x
The x-coordinate of the point to test for visibility.
y
The y-coordinate of the point to test for visibility.

Return Value

This method returns true if the point defined by the x and y parameters is contained within the visible clip region of this GdiGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisible Method (Int32, Int32, Int32, Int32)

GdiGraphics.IsVisible Method (Int32, Int32, Int32, Int32)
See Also
[image]

Indicates whether the rectangle specified by a pair of coordinates, a width, and a height is contained within the visible clip region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual bool IsVisible (
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Public Overridable Function IsVisible( _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
) As Boolean

Parameters

x
The x-coordinate of the upper-left corner of the rectangle to test for visibility.
y
The y-coordinate of the upper-left corner of the rectangle to test for visibility.
width
The width of the rectangle to test for visibility.
height
The height of the rectangle to test for visibility.

Return Value

This method returns true if the rectangle defined by the x, y, width, and height parameters is contained within the visible clip region of this GdiGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisible Method (Point)

GdiGraphics.IsVisible Method (Point)
See Also
[image]

Indicates whether the specified Point structure is contained within the visible clip region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual bool IsVisible (
Point point
)

Visual Basic [image] Copy Code

Public Overridable Function IsVisible( _
point As Point _
) As Boolean

Parameters

point
A .NET Point structure to test for visibility.

Return Value

This method returns true if the point specified by the point parameter is contained within the visible clip region of this GdiGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisible Method (PointF)

GdiGraphics.IsVisible Method (PointF)
See Also
[image]

Indicates whether the specified PointF structure is contained within the visible clip region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual bool IsVisible (
PointF point
)

Visual Basic [image] Copy Code

Public Overridable Function IsVisible( _
point As PointF _
) As Boolean

Parameters

point
A .NET PointF structure to test for visibility.

Return Value

This method returns true if the point specified by the point parameter is contained within the visible clip region of this GdiGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisible Method (Rectangle)

GdiGraphics.IsVisible Method (Rectangle)
See Also
[image]

Indicates whether the rectangle specified by a Rectangle structure is contained within the visible clip region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual bool IsVisible (
Rectangle rect
)

Visual Basic [image] Copy Code

Public Overridable Function IsVisible( _
rect As Rectangle _
) As Boolean

Parameters

rect
A .NET Rectangle structure to test for visibility.

Return Value

This method returns true if the rectangle specified by the rect parameter is contained within the visible clip region of this GdiGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisible Method (RectangleF)

GdiGraphics.IsVisible Method (RectangleF)
See Also
[image]

Indicates whether the rectangle specified by a RectangleF structure is contained within the visible clip region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual bool IsVisible (
RectangleF rect
)

Visual Basic [image] Copy Code

Public Overridable Function IsVisible( _
rect As RectangleF _
) As Boolean

Parameters

rect
A .NET RectangleF structure to test for visibility.

Return Value

This method returns true if the rectangle specified by the rect parameter is contained within the visible clip region of this GdiGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisible Method (Single, Single)

GdiGraphics.IsVisible Method (Single, Single)
See Also
[image]

Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual bool IsVisible (
float x,
float y
)

Visual Basic [image] Copy Code

Public Overridable Function IsVisible( _
x As Single, _
y As Single _
) As Boolean

Parameters

x
The x-coordinate of the point to test for visibility.
y
The y-coordinate of the point to test for visibility.

Return Value

This method returns true if the point defined by the x and y parameters is contained within the visible clip region of this GdiGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisible Method (Single, Single, Single, Single)

GdiGraphics.IsVisible Method (Single, Single, Single, Single)
See Also
[image]

Indicates whether the rectangle specified by a pair of coordinates, a width, and a height is contained within the visible clip region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual bool IsVisible (
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Public Overridable Function IsVisible( _
x As Single, _
y As Single, _
width As Single, _
height As Single _
) As Boolean

Parameters

x
The x-coordinate of the upper-left corner of the rectangle to test for visibility.
y
The y-coordinate of the upper-left corner of the rectangle to test for visibility.
width
The width of the rectangle to test for visibility.
height
The height of the rectangle to test for visibility.

Return Value

This method returns true if the rectangle defined by the x, y, width, and height parameters is contained within the visible clip region of this GdiGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MeasureCharacterRanges Method

GdiGraphics.MeasureCharacterRanges Method
[image]

Gets an array of Region objects, each of which bounds a range of character positions within the specified string.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual RectangleF[] MeasureCharacterRanges (
string text,
Font font,
RectangleF layoutRect,
StringFormat stringFormat
)

Visual Basic [image] Copy Code

Public Overridable Function MeasureCharacterRanges( _
text As String, _
font As Font, _
layoutRect As RectangleF, _
stringFormat As StringFormat _
) As RectangleF()

Parameters

text
The string to measure.
font
A .NET Font object that defines the text format of the string.
layoutRect
A .NET RectangleF structure that specifies the layout rectangle for the string.
stringFormat
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.

Return Value

This method returns an array of .NET Region objects, each of which bounds a range of character positions within the specified string.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MeasureString Method

GdiGraphics.MeasureString Method
[image]

Measures the specified string when drawn with the specified Font object.

Overload List

Name | Description
GdiGraphics.MeasureString (String, Font) | Measures the specified string when drawn with the specified Font object.
GdiGraphics.MeasureString (String, Font, Int32) | Measures the specified string when drawn with the specified Font object.
GdiGraphics.MeasureString (String, Font, Int32, StringFormat) | Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.
GdiGraphics.MeasureString (String, Font, PointF, StringFormat) | Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.
GdiGraphics.MeasureString (String, Font, SizeF) | Measures the specified string when drawn with the specified Font object within the specified layout area.
GdiGraphics.MeasureString (String, Font, SizeF, StringFormat) | Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.
GdiGraphics.MeasureString (String, Font, SizeF, StringFormat, Int32@, Int32@) | Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MeasureString Method (String, Font)

GdiGraphics.MeasureString Method (String, Font)
See Also
[image]

Measures the specified string when drawn with the specified Font object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual SizeF MeasureString (
string text,
Font font
)

Visual Basic [image] Copy Code

Public Overridable Function MeasureString( _
text As String, _
font As Font _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object that defines the text format of the string.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified by the text parameter as drawn with the font parameter.

See Also

MeasureString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MeasureString Method (String, Font, Int32)

GdiGraphics.MeasureString Method (String, Font, Int32)
See Also
[image]

Measures the specified string when drawn with the specified Font object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual SizeF MeasureString (
string text,
Font font,
int width
)

Visual Basic [image] Copy Code

Public Overridable Function MeasureString( _
text As String, _
font As Font, _
width As Integer _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object that defines the format of the string.
width
The maximum width of the string in pixels.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified in the text parameter as drawn with the font parameter.

See Also

MeasureString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MeasureString Method (String, Font, Int32, StringFormat)

GdiGraphics.MeasureString Method (String, Font, Int32, StringFormat)
See Also
[image]

Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual SizeF MeasureString (
string text,
Font font,
int width,
StringFormat format
)

Visual Basic [image] Copy Code

Public Overridable Function MeasureString( _
text As String, _
font As Font, _
width As Integer, _
format As StringFormat _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object that defines the text format of the string.
width
The maximum width of the string.
format
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified in the text parameter as drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MeasureString Method (String, Font, PointF, StringFormat)

GdiGraphics.MeasureString Method (String, Font, PointF, StringFormat)
See Also
[image]

Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual SizeF MeasureString (
string text,
Font font,
PointF origin,
StringFormat stringFormat
)

Visual Basic [image] Copy Code

Public Overridable Function MeasureString( _
text As String, _
font As Font, _
origin As PointF, _
stringFormat As StringFormat _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object defines the text format of the string.
origin
A .NET PointF structure that represents the upper-left corner of the string.
stringFormat
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.

Return Value

This method returns a .NET SizeF structure that represents the size of the string, in pixels, of the text parameter as drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MeasureString Method (String, Font, SizeF)

GdiGraphics.MeasureString Method (String, Font, SizeF)
See Also
[image]

Measures the specified string when drawn with the specified Font object within the specified layout area.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual SizeF MeasureString (
string text,
Font font,
SizeF layoutArea
)

Visual Basic [image] Copy Code

Public Overridable Function MeasureString( _
text As String, _
font As Font, _
layoutArea As SizeF _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object defines the text format of the string.
layoutArea
A .NET SizeF structure that specifies the maximum layout area for the text.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified in the text parameter as drawn with the font parameter.

See Also

MeasureString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MeasureString Method (String, Font, SizeF, StringFormat)

GdiGraphics.MeasureString Method (String, Font, SizeF, StringFormat)
See Also
[image]

Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual SizeF MeasureString (
string text,
Font font,
SizeF layoutArea,
StringFormat stringFormat
)

Visual Basic [image] Copy Code

Public Overridable Function MeasureString( _
text As String, _
font As Font, _
layoutArea As SizeF, _
stringFormat As StringFormat _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object defines the text format of the string.
layoutArea
A .NET SizeF structure that specifies the maximum layout area for the text.
stringFormat
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified in the text parameter as drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MeasureString Method (String, Font, SizeF, StringFormat, Int32@, Int32@)

GdiGraphics.MeasureString Method (String, Font, SizeF, StringFormat, Int32@, Int32@)
See Also
[image]

Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual SizeF MeasureString (
string text,
Font font,
SizeF layoutArea,
StringFormat stringFormat,
ref int charactersFitted,
ref int linesFilled
)

Visual Basic [image] Copy Code

Public Overridable Function MeasureString( _
text As String, _
font As Font, _
layoutArea As SizeF, _
stringFormat As StringFormat, _
ByRef charactersFitted As Integer, _
ByRef linesFilled As Integer _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object that defines the text format of the string.
layoutArea
A .NET SizeF structure that specifies the maximum layout area for the text.
stringFormat
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.
charactersFitted
Number of characters in the string.
linesFilled
Number of text lines in the string.

Return Value

This method returns a .NET SizeF structure that represents the size of the string, in pixels, of the text parameter as drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MultiplyTransform Method

GdiGraphics.MultiplyTransform Method
[image]

Multiplies the world transformation of this GdiGraphics object and specified the .NET Matrix object.

Overload List

Name | Description
GdiGraphics.MultiplyTransform (Matrix) | Multiplies the world transformation of this GdiGraphics object and specified the Matrix object.
GdiGraphics.MultiplyTransform (Matrix, MatrixOrder) | Multiplies the world transformation of this GdiGraphics object and specified the Matrix object in the specified order.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MultiplyTransform Method (Matrix)

GdiGraphics.MultiplyTransform Method (Matrix)
See Also
[image]

Multiplies the world transformation of this GdiGraphics object and specified the Matrix object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void MultiplyTransform (
Matrix matrix
)

Visual Basic [image] Copy Code

Public Overridable Sub MultiplyTransform( _
matrix As Matrix _
)

Parameters

matrix
A 4x4 .NET Matrix object that multiplies the world transformation.

See Also

MultiplyTransform Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MultiplyTransform Method (Matrix, MatrixOrder)

GdiGraphics.MultiplyTransform Method (Matrix, MatrixOrder)
See Also
[image]

Multiplies the world transformation of this GdiGraphics object and specified the Matrix object in the specified order.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void MultiplyTransform (
Matrix matrix,
MatrixOrder order
)

Visual Basic [image] Copy Code

Public Overridable Sub MultiplyTransform( _
matrix As Matrix, _
order As MatrixOrder _
)

Parameters

matrix
A 4x4 .NET Matrix object that multiplies the world transformation.
order
Member of the .NET MatrixOrder enumeration that determines the order of the multiplication.

See Also

MultiplyTransform Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ReleaseHdc Method

GdiGraphics.ReleaseHdc Method
[image]

Releases a device context handle obtained by a previous call to the GetHdc method of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void ReleaseHdc (
IntPtr hdc
)

Visual Basic [image] Copy Code

Public Overridable Sub ReleaseHdc( _
hdc As IntPtr _
)

Parameters

hdc
Handle to a device context obtained by a previous call to the GetHdc method of this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ReleaseHdcInternal Method

GdiGraphics.ReleaseHdcInternal Method
[image]

Internal method. Do not use.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void ReleaseHdcInternal (
IntPtr hdc
)

Visual Basic [image] Copy Code

Public Overridable Sub ReleaseHdcInternal( _
hdc As IntPtr _
)

Parameters

hdc
Handle to a device context.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ResetClip Method

GdiGraphics.ResetClip Method
[image]

Resets the clip region of this GdiGraphics object to an infinite region.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void ResetClip ()

Visual Basic [image] Copy Code

Public Overridable Sub ResetClip ()

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ResetTransform Method

GdiGraphics.ResetTransform Method
[image]

Resets the world transformation matrix of this GdiGraphics object to the identity matrix.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void ResetTransform ()

Visual Basic [image] Copy Code

Public Overridable Sub ResetTransform ()

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Restore Method

GdiGraphics.Restore Method
[image]

Restores the state of this GdiGraphics object to the state represented by a GraphicsState object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void Restore (
GraphicsState gstate
)

Visual Basic [image] Copy Code

Public Overridable Sub Restore( _
gstate As GraphicsState _
)

Parameters

gstate
A .NET GraphicsState object that represents the state to which to restore this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.RotateTransform Method

GdiGraphics.RotateTransform Method
[image]

Applies the specified rotation to the transformation matrix of this GdiGraphics object.

Overload List

Name | Description
GdiGraphics.RotateTransform (Single) | Applies the specified rotation to the transformation matrix of this GdiGraphics object.
GdiGraphics.RotateTransform (Single, MatrixOrder) | Applies the specified rotation to the transformation matrix of this GdiGraphics object in the specified order.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.RotateTransform Method (Single)

GdiGraphics.RotateTransform Method (Single)
See Also
[image]

Applies the specified rotation to the transformation matrix of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void RotateTransform (
float angle
)

Visual Basic [image] Copy Code

Public Overridable Sub RotateTransform( _
angle As Single _
)

Parameters

angle
The angle of rotation in degrees.

See Also

RotateTransform Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.RotateTransform Method (Single, MatrixOrder)

GdiGraphics.RotateTransform Method (Single, MatrixOrder)
See Also
[image]

Applies the specified rotation to the transformation matrix of this GdiGraphics object in the specified order.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void RotateTransform (
float angle,
MatrixOrder order
)

Visual Basic [image] Copy Code

Public Overridable Sub RotateTransform( _
angle As Single, _
order As MatrixOrder _
)

Parameters

angle
The angle of rotation in degrees.
order
Member of the .NET MatrixOrder enumeration that specifies whether the rotation is appended or prepended to the matrix transformation.

See Also

RotateTransform Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Save Method

GdiGraphics.Save Method
[image]

Saves the current state of this GdiGraphics object and identifies the saved state with a GraphicsState object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual GraphicsState Save ()

Visual Basic [image] Copy Code

Public Overridable Function Save () As GraphicsState

Return Value

This method returns a .NET GraphicsState object that represents the saved state of this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ScaleTransform Method

GdiGraphics.ScaleTransform Method
[image]

Applies the specified scaling operation to the transformation matrix of this GdiGraphics object by prepending it to the object's transformation matrix.

Overload List

Name | Description
GdiGraphics.ScaleTransform (Single, Single) | Applies the specified scaling operation to the transformation matrix of this GdiGraphics object by prepending it to the object's transformation matrix.
GdiGraphics.ScaleTransform (Single, Single, MatrixOrder) | Applies the specified scaling operation to the transformation matrix of this GdiGraphics object in the specified order.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ScaleTransform Method (Single, Single)

GdiGraphics.ScaleTransform Method (Single, Single)
See Also
[image]

Applies the specified scaling operation to the transformation matrix of this GdiGraphics object by prepending it to the object's transformation matrix.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void ScaleTransform (
float sx,
float sy
)

Visual Basic [image] Copy Code

Public Overridable Sub ScaleTransform( _
sx As Single, _
sy As Single _
)

Parameters

sx
The scale factor in the x direction.
sy
The scale factor in the y direction.

See Also

ScaleTransform Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ScaleTransform Method (Single, Single, MatrixOrder)

GdiGraphics.ScaleTransform Method (Single, Single, MatrixOrder)
See Also
[image]

Applies the specified scaling operation to the transformation matrix of this GdiGraphics object in the specified order.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void ScaleTransform (
float sx,
float sy,
MatrixOrder order
)

Visual Basic [image] Copy Code

Public Overridable Sub ScaleTransform( _
sx As Single, _
sy As Single, _
order As MatrixOrder _
)

Parameters

sx
The scale factor in the x direction.
sy
The scale factor in the y direction.
order
Member of the .NET MatrixOrder enumeration that specifies whether the scaling operation is prepended or appended to the transformation matrix.

See Also

ScaleTransform Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method

GdiGraphics.SetClip Method
[image]

Sets the clipping region of this GdiGraphics object.

Overload List

Name | Description
GdiGraphics.SetClip (GraphicsPath) | Sets the clipping region of this GdiGraphics object to the specified .NET GraphicsPath object.
GdiGraphics.SetClip (GraphicsPath, CombineMode) | Sets the clipping region of this GdiGraphics object to the result of the specified operation combining the current clip region and the specified .NET GraphicsPath object.
GdiGraphics.SetClip (IGraphics) | Sets the clipping region of this GdiGraphics object to the Clip property of the specified IGraphics object.
GdiGraphics.SetClip (IGraphics, CombineMode) | Sets the clipping region of this GdiGraphics object to the result of the specified combining operation of the current clip region and the Clip property of the specified IGraphics object.
GdiGraphics.SetClip (Rectangle) | Sets the clipping region of this GdiGraphics object to the rectangle specified by a Rectangle structure.
GdiGraphics.SetClip (Rectangle, CombineMode) | Sets the clipping region of this GdiGraphics object to the result of the specified operation combining the current clip region and the rectangle specified by a Rectangle structure.
GdiGraphics.SetClip (RectangleF) | Sets the clipping region of this GdiGraphics object to the rectangle specified by a RectangleF structure.
GdiGraphics.SetClip (RectangleF, CombineMode) | Sets the clipping region of this GdiGraphics object to the result of the specified operation combining the current clip region and the rectangle specified by a RectangleF structure.
GdiGraphics.SetClip (Region, CombineMode) | Sets the clipping region of this GdiGraphics object to the result of the specified operation combining the current clip region and the specified Region object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method (GraphicsPath)

GdiGraphics.SetClip Method (GraphicsPath)
See Also
[image]

Sets the clipping region of this GdiGraphics object to the specified .NET GraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void SetClip (
GraphicsPath path
)

Visual Basic [image] Copy Code

Public Overridable Sub SetClip( _
path As GraphicsPath _
)

Parameters

path
A .NET GraphicsPath object that represents the new clip region.

See Also

SetClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method (GraphicsPath, CombineMode)

GdiGraphics.SetClip Method (GraphicsPath, CombineMode)
See Also
[image]

Sets the clipping region of this GdiGraphics object to the result of the specified operation combining the current clip region and the specified .NET GraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void SetClip (
GraphicsPath path,
CombineMode combineMode
)

Visual Basic [image] Copy Code

Public Overridable Sub SetClip( _
path As GraphicsPath, _
combineMode As CombineMode _
)

Parameters

path
A .NET GraphicsPath object to combine.
combineMode
Member of the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method (IGraphics)

GdiGraphics.SetClip Method (IGraphics)
See Also
[image]

Sets the clipping region of this GdiGraphics object to the Clip property of the specified IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void SetClip (
IGraphics g
)

Visual Basic [image] Copy Code

Public Overridable Sub SetClip( _
g As IGraphics _
)

Parameters

g
An IGraphics object from which to take the new clip region.

See Also

SetClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method (IGraphics, CombineMode)

GdiGraphics.SetClip Method (IGraphics, CombineMode)
See Also
[image]

Sets the clipping region of this GdiGraphics object to the result of the specified combining operation of the current clip region and the Clip property of the specified IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void SetClip (
IGraphics g,
CombineMode combineMode
)

Visual Basic [image] Copy Code

Public Overridable Sub SetClip( _
g As IGraphics, _
combineMode As CombineMode _
)

Parameters

g
An IGraphics object that specifies the clip region to combine.
combineMode
Member of the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method (Rectangle)

GdiGraphics.SetClip Method (Rectangle)
See Also
[image]

Sets the clipping region of this GdiGraphics object to the rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void SetClip (
Rectangle rect
)

Visual Basic [image] Copy Code

Public Overridable Sub SetClip( _
rect As Rectangle _
)

Parameters

rect
A .NET Rectangle structure that represents the new clip region.

See Also

SetClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method (Rectangle, CombineMode)

GdiGraphics.SetClip Method (Rectangle, CombineMode)
See Also
[image]

Sets the clipping region of this GdiGraphics object to the result of the specified operation combining the current clip region and the rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void SetClip (
Rectangle rect,
CombineMode combineMode
)

Visual Basic [image] Copy Code

Public Overridable Sub SetClip( _
rect As Rectangle, _
combineMode As CombineMode _
)

Parameters

rect
A .NET Rectangle structure to combine.
combineMode
Member of the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method (RectangleF)

GdiGraphics.SetClip Method (RectangleF)
See Also
[image]

Sets the clipping region of this GdiGraphics object to the rectangle specified by a RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void SetClip (
RectangleF rect
)

Visual Basic [image] Copy Code

Public Overridable Sub SetClip( _
rect As RectangleF _
)

Parameters

rect
A .NET RectangleF structure that represents the new clip region.

See Also

SetClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method (RectangleF, CombineMode)

GdiGraphics.SetClip Method (RectangleF, CombineMode)
See Also
[image]

Sets the clipping region of this GdiGraphics object to the result of the specified operation combining the current clip region and the rectangle specified by a RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void SetClip (
RectangleF rect,
CombineMode combineMode
)

Visual Basic [image] Copy Code

Public Overridable Sub SetClip( _
rect As RectangleF, _
combineMode As CombineMode _
)

Parameters

rect
A .NET RectangleF structure to combine.
combineMode
Member of the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method (Region, CombineMode)

GdiGraphics.SetClip Method (Region, CombineMode)
See Also
[image]

Sets the clipping region of this GdiGraphics object to the result of the specified operation combining the current clip region and the specified Region object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void SetClip (
Region region,
CombineMode combineMode
)

Visual Basic [image] Copy Code

Public Overridable Sub SetClip( _
region As Region, _
combineMode As CombineMode _
)

Parameters

region
A .NET Region object to combine.
combineMode
Member from the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TransformPoints Method

GdiGraphics.TransformPoints Method
[image]

Transforms an array of points from one coordinate space to another using the current world and page transformations of this GdiGraphics object.

Overload List

Name | Description
GdiGraphics.TransformPoints (CoordinateSpace, CoordinateSpace, Point[]) | Transforms an array of points from one coordinate space to another using the current world and page transformations of this GdiGraphics object.
GdiGraphics.TransformPoints (CoordinateSpace, CoordinateSpace, PointF[]) | Transforms an array of points from one coordinate space to another using the current world and page transformations of this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TransformPoints Method (CoordinateSpace, CoordinateSpace, Point[])

GdiGraphics.TransformPoints Method (CoordinateSpace, CoordinateSpace, Point[])
See Also
[image]

Transforms an array of points from one coordinate space to another using the current world and page transformations of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void TransformPoints (
CoordinateSpace destSpace,
CoordinateSpace srcSpace,
Point[] pts
)

Visual Basic [image] Copy Code

Public Overridable Sub TransformPoints( _
destSpace As CoordinateSpace, _
srcSpace As CoordinateSpace, _
pts() As Point _
)

Parameters

destSpace
Member of the .NET CoordinateSpace enumeration that specifies the destination coordinate space.
srcSpace
Member of the .NET CoordinateSpace enumeration that specifies the source coordinate space.
pts
An array of .NET Point structures that represents the points to transformation.

See Also

TransformPoints Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TransformPoints Method (CoordinateSpace, CoordinateSpace, PointF[])

GdiGraphics.TransformPoints Method (CoordinateSpace, CoordinateSpace, PointF[])
See Also
[image]

Transforms an array of points from one coordinate space to another using the current world and page transformations of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void TransformPoints (
CoordinateSpace destSpace,
CoordinateSpace srcSpace,
PointF[] pts
)

Visual Basic [image] Copy Code

Public Overridable Sub TransformPoints( _
destSpace As CoordinateSpace, _
srcSpace As CoordinateSpace, _
pts() As PointF _
)

Parameters

destSpace
Member of the .NET CoordinateSpace enumeration that specifies the destination coordinate space.
srcSpace
Member of the .NET CoordinateSpace enumeration that specifies the source coordinate space.
pts
An array of .NET PointF structures that represent the points to transform.

See Also

TransformPoints Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TranslateClip Method

GdiGraphics.TranslateClip Method
[image]

Translates the clipping region of this GdiGraphics object by specified amounts in the horizontal and vertical directions.

Overload List

Name | Description
GdiGraphics.TranslateClip (Int32, Int32) | Translates the clipping region of this GdiGraphics object by specified amounts in the horizontal and vertical directions.
GdiGraphics.TranslateClip (Single, Single) | Translates the clipping region of this GdiGraphics object by specified amounts in the horizontal and vertical directions.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TranslateClip Method (Int32, Int32)

GdiGraphics.TranslateClip Method (Int32, Int32)
See Also
[image]

Translates the clipping region of this GdiGraphics object by specified amounts in the horizontal and vertical directions.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void TranslateClip (
int dx,
int dy
)

Visual Basic [image] Copy Code

Public Overridable Sub TranslateClip( _
dx As Integer, _
dy As Integer _
)

Parameters

dx
The x component of the translation.
dy
The y component of the translation.

See Also

TranslateClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TranslateClip Method (Single, Single)

GdiGraphics.TranslateClip Method (Single, Single)
See Also
[image]

Translates the clipping region of this GdiGraphics object by specified amounts in the horizontal and vertical directions.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void TranslateClip (
float dx,
float dy
)

Visual Basic [image] Copy Code

Public Overridable Sub TranslateClip( _
dx As Single, _
dy As Single _
)

Parameters

dx
The x component of the translation.
dy
The y component of the translation.

See Also

TranslateClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TranslateTransform Method

GdiGraphics.TranslateTransform Method
[image]

Prepends the specified translation to the transformation matrix of this GdiGraphics object.

Overload List

Name | Description
GdiGraphics.TranslateTransform (Single, Single) | Prepends the specified translation to the transformation matrix of this GdiGraphics object.
GdiGraphics.TranslateTransform (Single, Single, MatrixOrder) | Applies the specified translation to the transformation matrix of this GdiGraphics object in the specified order.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TranslateTransform Method (Single, Single)

GdiGraphics.TranslateTransform Method (Single, Single)
See Also
[image]

Prepends the specified translation to the transformation matrix of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void TranslateTransform (
float dx,
float dy
)

Visual Basic [image] Copy Code

Public Overridable Sub TranslateTransform( _
dx As Single, _
dy As Single _
)

Parameters

dx
The x component of the translation.
dy
The y component of the translation.

See Also

TranslateTransform Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TranslateTransform Method (Single, Single, MatrixOrder)

GdiGraphics.TranslateTransform Method (Single, Single, MatrixOrder)
See Also
[image]

Applies the specified translation to the transformation matrix of this GdiGraphics object in the specified order.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void TranslateTransform (
float dx,
float dy,
MatrixOrder order
)

Visual Basic [image] Copy Code

Public Overridable Sub TranslateTransform( _
dx As Single, _
dy As Single, _
order As MatrixOrder _
)

Parameters

dx
The x component of the translation.
dy
The y component of the translation.
order
Member of the .NET MatrixOrder enumeration that specifies whether the translation is prepended or appended to the transformation matrix.

See Also

TranslateTransform Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics Properties

GdiGraphics Properties
[image]

Public Properties

Name | Description
Clip | Gets or sets a .NET Region object that limits the drawing region of this GdiGraphics object.
ClipBounds | Gets a .NET RectangleF structure that bounds the clipping region of this GdiGraphics object.
CompositingMode | Gets or sets a value that specifies how composited images are drawn to this GdiGraphics object.
CompositingQuality | Gets or sets the rendering quality of composited images drawn to this GdiGraphics object.
DpiX | Gets the horizontal resolution of this GdiGraphics object.
DpiY | Gets the vertical resolution of this GdiGraphics object.
Graphics | Gets a reference to the underlying .NET Graphics object.
InterpolationMode | Gets or sets the interpolation mode associated with this GdiGraphics object.
IsClipEmpty | Gets a value indicating whether the clipping region of this GdiGraphics object is empty.
IsVisibleClipEmpty | Gets a value indicating whether the visible clipping region of this GdiGraphics object is empty.
PageScale | Gets or sets the scaling between world units and page units for this GdiGraphics object.
PageUnit | Gets or sets the unit of measure used for page coordinates in this GdiGraphics object.
PixelOffsetMode | Gets or set a value specifying how pixels are offset during rendering of this GdiGraphics object.
RenderingOrigin | Gets or sets the rendering origin of this GdiGraphics object for dithering and for hatch brushes.
SmoothingMode | Gets or sets the rendering quality for this GdiGraphics object.
TextContrast | Gets or sets the gamma correction value for rendering text.
TextRenderingHint | Gets or sets the rendering mode for text associated with this GdiGraphics object.
Transform | Gets or sets the world transformation for this GdiGraphics object.
VisibleClipBounds | Gets the bounding rectangle of the visible clipping region of this GdiGraphics object.

See Also

GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Clip Property

GdiGraphics.Clip Property
[image]

Gets or sets a .NET Region object that limits the drawing region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual Region Clip { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Clip As Region

Property Value

This property specifies a .NET Region object that limits the portion of this GdiGraphics object that is currently available for drawing.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ClipBounds Property

GdiGraphics.ClipBounds Property
[image]

Gets a .NET RectangleF structure that bounds the clipping region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual RectangleF ClipBounds { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property ClipBounds As RectangleF

Property Value

This property indicates a .NET RectangleF structure that represents a bounding rectangle for the clipping region of this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.CompositingMode Property

GdiGraphics.CompositingMode Property
[image]

Gets or sets a value that specifies how composited images are drawn to this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual CompositingMode CompositingMode { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property CompositingMode As CompositingMode

Property Value

This property specifies a member of the .NET CompositingMode enumeration.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.CompositingQuality Property

GdiGraphics.CompositingQuality Property
[image]

Gets or sets the rendering quality of composited images drawn to this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual CompositingQuality CompositingQuality { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property CompositingQuality As CompositingQuality

Property Value

This property specifies a member of the .NET CompositingQuality enumeration.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DpiX Property

GdiGraphics.DpiX Property
[image]

Gets the horizontal resolution of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual float DpiX { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property DpiX As Single

Property Value

This property indicates a value, in dots per inch, for the horizontal resolution supported by this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DpiY Property

GdiGraphics.DpiY Property
[image]

Gets the vertical resolution of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual float DpiY { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property DpiY As Single

Property Value

This property indicates a value, in dots per inch, for the vertical resolution supported by this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Graphics Property

GdiGraphics.Graphics Property
[image]

Gets a reference to the underlying .NET Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Graphics Graphics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Graphics As Graphics

Property Value

An instance of the .NET System.Drawing.Graphics class.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.InterpolationMode Property

GdiGraphics.InterpolationMode Property
[image]

Gets or sets the interpolation mode associated with this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual InterpolationMode InterpolationMode { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property InterpolationMode As InterpolationMode

Property Value

This property specifies a member of the InterpolationMode enumeration associated with this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsClipEmpty Property

GdiGraphics.IsClipEmpty Property
[image]

Gets a value indicating whether the clipping region of this GdiGraphics object is empty.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual bool IsClipEmpty { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property IsClipEmpty As Boolean

Property Value

This property is true if the clipping region of this GdiGraphics object is empty; otherwise, false.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisibleClipEmpty Property

GdiGraphics.IsVisibleClipEmpty Property
[image]

Gets a value indicating whether the visible clipping region of this GdiGraphics object is empty.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual bool IsVisibleClipEmpty { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property IsVisibleClipEmpty As Boolean

Property Value

This property is true if the visible portion of the clipping region of this GdiGraphics object is empty; otherwise, false.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.PageScale Property

GdiGraphics.PageScale Property
[image]

Gets or sets the scaling between world units and page units for this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual float PageScale { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property PageScale As Single

Property Value

This property specifies a value for the scaling between world units and page units for this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.PageUnit Property

GdiGraphics.PageUnit Property
[image]

Gets or sets the unit of measure used for page coordinates in this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual GraphicsUnit PageUnit { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property PageUnit As GraphicsUnit

Property Value

This property specifies a member of the .NET GraphicsUnit enumeration.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.PixelOffsetMode Property

GdiGraphics.PixelOffsetMode Property
[image]

Gets or set a value specifying how pixels are offset during rendering of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual PixelOffsetMode PixelOffsetMode { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property PixelOffsetMode As PixelOffsetMode

Property Value

This property specifies a member of the .NET PixelOffsetMode enumeration.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.RenderingOrigin Property

GdiGraphics.RenderingOrigin Property
[image]

Gets or sets the rendering origin of this GdiGraphics object for dithering and for hatch brushes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual Point RenderingOrigin { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property RenderingOrigin As Point

Property Value

This property specifies a .NET Point structure that represents the dither origin for 8-bits-per-pixel and 16-bits-per-pixel dithering and is also used to set the origin for hatch brushes.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SmoothingMode Property

GdiGraphics.SmoothingMode Property
[image]

Gets or sets the rendering quality for this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual SmoothingMode SmoothingMode { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property SmoothingMode As SmoothingMode

Property Value

This property specifies a member of the .NET SmoothingMode enumeration.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TextContrast Property

GdiGraphics.TextContrast Property
[image]

Gets or sets the gamma correction value for rendering text.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual int TextContrast { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property TextContrast As Integer

Property Value

This property specifies a value of the gamma correction used for rendering antialiased and ClearType text.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TextRenderingHint Property

GdiGraphics.TextRenderingHint Property
[image]

Gets or sets the rendering mode for text associated with this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual TextRenderingHint TextRenderingHint { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property TextRenderingHint As TextRenderingHint

Property Value

This property specifies a member of the .NET TextRenderingHint enumeration.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Transform Property

GdiGraphics.Transform Property
[image]

Gets or sets the world transformation for this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual Matrix Transform { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Transform As Matrix

Property Value

This property specifies a Matrix object that represents the world transformation for this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.VisibleClipBounds Property

GdiGraphics.VisibleClipBounds Property
[image]

Gets the bounding rectangle of the visible clipping region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual RectangleF VisibleClipBounds { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property VisibleClipBounds As RectangleF

Property Value

A .NET RectangleF structure that represents a bounding rectangle for the visible clipping region of this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject Class

GraphicObject Class
[image]

The base class for graphical objects such as pens and brushes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public abstract class GraphicObject : ICloneable

Visual Basic [image] Copy Code

Public MustInherit Class GraphicObject
Implements ICloneable

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject

See Also

GraphicObject Members
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject Members

GraphicObject Members
Constructors Methods
[image]

The base class for graphical objects such as pens and brushes.

The following tables list the members exposed by the GraphicObject type.

Protected Constructors

Name | Description
GraphicObject | Initializes a new instance of the GraphicObject class.

Public Methods

Name | Description
Clone | Creates an exact copy of the graphic object.
Deserialize | Creates and returns a new graphics object according to its string representation.
Equals | Determines whether two GraphicObject instances are equal.
GetHashCode | Returns a hash code for this object.
Serialize | Serializes the specified object to a string.

See Also

GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject Constructor

GraphicObject Constructor
[image]

Initializes a new instance of the GraphicObject class.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

protected GraphicObject ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject Methods

GraphicObject Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of the graphic object.
Deserialize | Creates and returns a new graphics object according to its string representation.
Equals | Determines whether two GraphicObject instances are equal.
GetHashCode | Returns a hash code for this object.
Serialize | Serializes the specified object to a string.

See Also

GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject.Clone Method

GraphicObject.Clone Method
[image]

Creates an exact copy of the graphic object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public abstract Object Clone ()

Visual Basic [image] Copy Code

Public MustOverride Function Clone () As Object

Return Value

An instance of the GraphicObject class.

See Also

GraphicObject Members
GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject.Deserialize Method

GraphicObject.Deserialize Method
[image]

Creates and returns a new graphics object according to its string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static GraphicObject Deserialize (
string image
)

Visual Basic [image] Copy Code

Public Shared Function Deserialize ( _
image As String _
) As GraphicObject

Parameters

image
A string that represents the serialized object.

Return Value

An instance of the GraphicObject class.

See Also

GraphicObject Members
GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject.Equals Method

GraphicObject.Equals Method
[image]

Determines whether two GraphicObject instances are equal.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

The object to compare to this one.

Return Value

true is the objects are equal; otherwise, false.

See Also

GraphicObject Members
GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject.GetHashCode Method

GraphicObject.GetHashCode Method
[image]

Returns a hash code for this object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

A hash code for this object.

See Also

GraphicObject Members
GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject.Serialize Method

GraphicObject.Serialize Method
[image]

Serializes the specified object to a string.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static string Serialize (
GraphicObject obj
)

Visual Basic [image] Copy Code

Public Shared Function Serialize ( _
obj As GraphicObject _
) As String

Parameters

obj
The graphic object to serialize.

Return Value

A string that represents the specified object.

See Also

GraphicObject Members
GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Class

HatchBrush Class
Remarks See Also
[image]

HatchBrush objects represent rectangular brushes with a hatch style, a foreground color, and a background color that are used to fill the interiors of geometric shapes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class HatchBrush : Brush, ISerializable

Visual Basic [image] Copy Code

Public Class HatchBrush
Inherits Brush
Implements ISerializable

Remarks

The HatchBrush class acts as a proxy for the .NET standard GDI+ System.Drawing.Drawing2D.HatchBrush class.

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject
MindFusion.Drawing.Brush
MindFusion.Drawing.HatchBrush

See Also

HatchBrush Members
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Members

HatchBrush Members
Constructors Properties Methods
[image]

HatchBrush objects represent rectangular brushes with a hatch style, a foreground color, and a background color that are used to fill the interiors of geometric shapes.

The following tables list the members exposed by the HatchBrush type.

Public Constructors

Name | Description
HatchBrush | Overloaded. Initialize a new instance of the HatchBrush class with the specified attributes.

Public Properties

Name | Description
BackgroundColor | Gets or sets the color of spaces between the hatch lines drawn by this brush.
ForegroundColor | Gets or sets the color of hatch lines drawn by this brush.
HatchStyle | Gets or sets the hatch style of this brush.

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Returns an instance of the System.Drawing.Drawing2D.HatchBrush class that can be used to paint in a GDI+ Graphics object.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "Hatch".

See Also

HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Constructor

HatchBrush Constructor
[image]

Initialize a new instance of the HatchBrush class with the specified attributes.

Overload List

Name | Description
HatchBrush (HatchStyle, Color) | Initializes a new instance of the HatchBrush class with the specified hatch style and color.
HatchBrush (HatchStyle, Color, Color) | Initializes a new instance of the HatchBrush class with the specified style, foreground color and background color.
HatchBrush (String) | Initializes a new instance of the HatchBrush class according to its string representation.

See Also

HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Constructor (HatchStyle, Color)

HatchBrush Constructor (HatchStyle, Color)
See Also
[image]

Initializes a new instance of the HatchBrush class with the specified hatch style and color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public HatchBrush (
HatchStyle hatchStyle,
Color foreColor
)

Visual Basic [image] Copy Code

Public New ( _
hatchStyle As HatchStyle, _
foreColor As Color _
)

Parameters

hatchStyle
A member of the .NET HatchStyle enumeration that represents the pattern drawn by this brush.
foreColor
A Color structure that specifies the color of lines drawn by this brush.

See Also

HatchBrush Constructor Overload List
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Constructor (HatchStyle, Color, Color)

HatchBrush Constructor (HatchStyle, Color, Color)
See Also
[image]

Initializes a new instance of the HatchBrush class with the specified style, foreground color and background color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public HatchBrush (
HatchStyle hatchStyle,
Color foreColor,
Color backColor
)

Visual Basic [image] Copy Code

Public New ( _
hatchStyle As HatchStyle, _
foreColor As Color, _
backColor As Color _
)

Parameters

hatchStyle
A member of the .NET HatchStyle enumeration that represents the pattern drawn by this brush.
foreColor
A Color structure that specifies the color of lines drawn by this brush.
backColor
A Color structure that specifies the color of spaces between the lines drawn by this brush.

See Also

HatchBrush Constructor Overload List
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Constructor (String)

HatchBrush Constructor (String)
See Also
[image]

Initializes a new instance of the HatchBrush class according to its string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public HatchBrush (
string representation
)

Visual Basic [image] Copy Code

Public New ( _
representation As String _
)

Parameters

representation
A string that represents the serialized bursh.

See Also

HatchBrush Constructor Overload List
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Methods

HatchBrush Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Returns an instance of the System.Drawing.Drawing2D.HatchBrush class that can be used to paint in a GDI+ Graphics object.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "Hatch".

See Also

HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.Clone Method

HatchBrush.Clone Method
[image]

Creates an exact copy of this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

An instance of the HatchBrush class.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.CreateGdiBrush Method

HatchBrush.CreateGdiBrush Method
[image]

Returns an instance of the System.Drawing.Drawing2D.HatchBrush class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Brush CreateGdiBrush (
RectangleF rc
)

Visual Basic [image] Copy Code

Public Overrides Function CreateGdiBrush( _
rc As RectangleF _
) As Brush

Parameters

rc

The rectangle in which painting will be performed.

Return Value

An instance of the System.Drawing.Brush class corresponding to this brush.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.GetObjectData Method

HatchBrush.GetObjectData Method
[image]

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void GetObjectData (
SerializationInfo info,
StreamingContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub GetObjectData( _
info As SerializationInfo, _
context As StreamingContext _
)

Parameters

info

The object that holds the serialized object data.

context

The contextual information about the source or destination.

Remarks

This method is not intended to be used directly from your code.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.ToString Method

HatchBrush.ToString Method
[image]

Returns "Hatch".

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string representing this brush.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Properties

HatchBrush Properties
[image]

Public Properties

Name | Description
BackgroundColor | Gets or sets the color of spaces between the hatch lines drawn by this brush.
ForegroundColor | Gets or sets the color of hatch lines drawn by this brush.
HatchStyle | Gets or sets the hatch style of this brush.

See Also

HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.BackgroundColor Property

HatchBrush.BackgroundColor Property
[image]

Gets or sets the color of spaces between the hatch lines drawn by this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Color BackgroundColor { get; set; }

Visual Basic [image] Copy Code

Public Property BackgroundColor As Color

Property Value

An instance of the .NET Color structure that represents the background color of this brush.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.ForegroundColor Property

HatchBrush.ForegroundColor Property
[image]

Gets or sets the color of hatch lines drawn by this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Color ForegroundColor { get; set; }

Visual Basic [image] Copy Code

Public Property ForegroundColor As Color

Property Value

An instance of the .NET Color structure that represents the foreground color of this brush.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.HatchStyle Property

HatchBrush.HatchStyle Property
[image]

Gets or sets the hatch style of this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public HatchStyle HatchStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HatchStyle As HatchStyle

Property Value

A member of the .NET HatchStyle enumeration that represents the pattern of this brush.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics Interface

IGraphics Interface
[image]

This interface exposes the public interface of the .NET System.Drawing.Graphics class.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public interface IGraphics

Visual Basic [image] Copy Code

Public Interface IGraphics

See Also

IGraphics Members
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics Members

IGraphics Members
Properties Methods
[image]

This interface exposes the public interface of the .NET System.Drawing.Graphics class.

The following tables list the members exposed by the IGraphics type.

Public Properties

Name | Description
Clip | Gets or sets a .NET Region object that limits the drawing region of this IGraphics object.
ClipBounds | Gets a .NET RectangleF structure that bounds the clipping region of this IGraphics object.
CompositingMode | Gets or sets a value that specifies how composited images are drawn to this IGraphics object.
CompositingQuality | Gets or sets the rendering quality of composited images drawn to this IGraphics object.
DpiX | Gets the horizontal resolution of this IGraphics object.
DpiY | Gets the vertical resolution of this IGraphics object.
InterpolationMode | Gets or sets the interpolation mode associated with this IGraphics object.
IsClipEmpty | Gets a value indicating whether the clipping region of this IGraphics object is empty.
IsVisibleClipEmpty | Gets a value indicating whether the visible clipping region of this IGraphics object is empty.
PageScale | Gets or sets the scaling between world units and page units for this IGraphics object.
PageUnit | Gets or sets the unit of measure used for page coordinates in this IGraphics object.
PixelOffsetMode | Gets or set a value specifying how pixels are offset during rendering of this IGraphics object.
RenderingOrigin | Gets or sets the rendering origin of this IGraphics object for dithering and for hatch brushes.
SmoothingMode | Gets or sets the rendering quality for this IGraphics object.
TextContrast | Gets or sets the gamma correction value for rendering text.
TextRenderingHint | Gets or sets the rendering mode for text associated with this IGraphics object.
Transform | Gets or sets the world transformation for this IGraphics object.
VisibleClipBounds | Gets or sets the bounding rectangle of the visible clipping region of this IGraphics object.

Public Methods

Name | Description
AddMetafileComment | Adds a comment to the current Metafile object.
BeginContainer | Overloaded. Saves a graphics container with the current state of this IGraphics object and opens and uses a new graphics container.
BeginHyperLink |
Clear | Clears the entire drawing surface and fills it with the specified background color.
Dispose | Releases all resources used by this IGraphics object.
DrawArc | Overloaded. Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
DrawBezier | Overloaded. Draws a Bйzier spline defined by four .NET Point structures.
DrawBeziers | Overloaded. Draws a series of Bйzier splines from an array of Point structures.
DrawClosedCurve | Overloaded. Draws a closed cardinal spline defined by an array of Point structures.
DrawCurve | Overloaded. Draws a cardinal spline through a specified array of Point structures.
DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawIcon | Overloaded. Draws the image represented by the specified .NET Icon object at the specified coordinates.
DrawIconUnstretched | Draws the image represented by the specified .NET Icon object without scaling the image.
DrawImage | Overloaded. Draws the specified .NET Image object at the specified location and with the original size.
DrawImageUnscaled | Overloaded. Draws the specified image using its original physical size at the location specified by a coordinate pair.
DrawLine | Overloaded. Draws a line connecting the two points specified by coordinate pairs.
DrawLines | Overloaded. Draws a series of line segments that connect an array of Point structures.
DrawPath | Draws a .NET GraphicsPath object.
DrawPie | Overloaded. Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.
DrawPolygon | Overloaded. Draws a polygon defined by an array of Point structures.
DrawRectangle | Overloaded. Draws a rectangle specified by a coordinate pair, a width, and a height.
DrawRectangles | Overloaded. Draws a series of rectangles specified by Rectangle structures.
DrawString | Overloaded. Draws the specified text string at the specified location with the specified Brush and Font objects.
EndContainer | Closes the current graphics container and restores the state of this IGraphics object to the state saved by a call to the BeginContainer method.
EndHyperLink |
ExcludeClip | Overloaded. Updates the clip region of this IGraphics object to exclude the area specified by a .NET Rectangle structure.
FillClosedCurve | Overloaded. Fills the interior a closed cardinal spline curve defined by an array of Point structures.
FillEllipse | Overloaded. Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.
FillPath | Fills the interior of a .NET GraphicsPath object.
FillPie | Overloaded. Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.
FillPolygon | Overloaded. Fills the interior of a polygon defined by an array of points specified by Point structures.
FillRectangle | Overloaded. Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.
FillRectangles | Overloaded. Fills the interiors of a series of rectangles specified by Rectangle structures.
FillRegion | Fills the interior of a .NET Region object.
Flush | Overloaded. Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.
GetFontHeight |
GetHdc | Gets the handle to the device context associated with this IGraphics.
GetNearestColor | Gets the nearest color to the specified Color structure.
IntersectClip | Overloaded. Updates the clip region of this IGraphics object to the intersection of the current clip region and the specified Rectangle structure.
IsVisible | Overloaded. Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this IGraphics object.
MeasureCharacterRanges | Gets an array of Region objects, each of which bounds a range of character positions within the specified string.
MeasureString | Overloaded. Measures the specified string when drawn with the specified Font object.
MultiplyTransform | Overloaded. Multiplies the world transformation of this IGraphics object and specified the .NET Matrix object.
ReleaseHdc | Releases a device context handle obtained by a previous call to the GetHdc method of this IGraphics object.
ReleaseHdcInternal | Internal method. Do not use.
ResetClip | Resets the clip region of this IGraphics object to an infinite region.
ResetTransform | Resets the world transformation matrix of this IGraphics object to the identity matrix.
Restore | Restores the state of this IGraphics object to the state represented by a GraphicsState object.
RotateTransform | Overloaded. Applies the specified rotation to the transformation matrix of this IGraphics object.
Save | Saves the current state of this IGraphics object and identifies the saved state with a GraphicsState object.
ScaleTransform | Overloaded. Applies the specified scaling operation to the transformation matrix of this IGraphics object by prepending it to the object's transformation matrix.
SetClip | Overloaded. Sets the clipping region of this IGraphics object to the Clip property of the specified IGraphics object.
TransformPoints | Overloaded. Transforms an array of points from one coordinate space to another using the current world and page transformations of this IGraphics object.
TranslateClip | Overloaded. Translates the clipping region of this IGraphics object by specified amounts in the horizontal and vertical directions.
TranslateTransform | Overloaded. Prepends the specified translation to the transformation matrix of this IGraphics object.

See Also

IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics Methods

IGraphics Methods
[image]

Public Methods

Name | Description
AddMetafileComment | Adds a comment to the current Metafile object.
BeginContainer | Overloaded. Saves a graphics container with the current state of this IGraphics object and opens and uses a new graphics container.
BeginHyperLink |
Clear | Clears the entire drawing surface and fills it with the specified background color.
Dispose | Releases all resources used by this IGraphics object.
DrawArc | Overloaded. Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
DrawBezier | Overloaded. Draws a Bйzier spline defined by four .NET Point structures.
DrawBeziers | Overloaded. Draws a series of Bйzier splines from an array of Point structures.
DrawClosedCurve | Overloaded. Draws a closed cardinal spline defined by an array of Point structures.
DrawCurve | Overloaded. Draws a cardinal spline through a specified array of Point structures.
DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawIcon | Overloaded. Draws the image represented by the specified .NET Icon object at the specified coordinates.
DrawIconUnstretched | Draws the image represented by the specified .NET Icon object without scaling the image.
DrawImage | Overloaded. Draws the specified .NET Image object at the specified location and with the original size.
DrawImageUnscaled | Overloaded. Draws the specified image using its original physical size at the location specified by a coordinate pair.
DrawLine | Overloaded. Draws a line connecting the two points specified by coordinate pairs.
DrawLines | Overloaded. Draws a series of line segments that connect an array of Point structures.
DrawPath | Draws a .NET GraphicsPath object.
DrawPie | Overloaded. Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.
DrawPolygon | Overloaded. Draws a polygon defined by an array of Point structures.
DrawRectangle | Overloaded. Draws a rectangle specified by a coordinate pair, a width, and a height.
DrawRectangles | Overloaded. Draws a series of rectangles specified by Rectangle structures.
DrawString | Overloaded. Draws the specified text string at the specified location with the specified Brush and Font objects.
EndContainer | Closes the current graphics container and restores the state of this IGraphics object to the state saved by a call to the BeginContainer method.
EndHyperLink |
ExcludeClip | Overloaded. Updates the clip region of this IGraphics object to exclude the area specified by a .NET Rectangle structure.
FillClosedCurve | Overloaded. Fills the interior a closed cardinal spline curve defined by an array of Point structures.
FillEllipse | Overloaded. Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.
FillPath | Fills the interior of a .NET GraphicsPath object.
FillPie | Overloaded. Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.
FillPolygon | Overloaded. Fills the interior of a polygon defined by an array of points specified by Point structures.
FillRectangle | Overloaded. Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.
FillRectangles | Overloaded. Fills the interiors of a series of rectangles specified by Rectangle structures.
FillRegion | Fills the interior of a .NET Region object.
Flush | Overloaded. Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.
GetFontHeight |
GetHdc | Gets the handle to the device context associated with this IGraphics.
GetNearestColor | Gets the nearest color to the specified Color structure.
IntersectClip | Overloaded. Updates the clip region of this IGraphics object to the intersection of the current clip region and the specified Rectangle structure.
IsVisible | Overloaded. Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this IGraphics object.
MeasureCharacterRanges | Gets an array of Region objects, each of which bounds a range of character positions within the specified string.
MeasureString | Overloaded. Measures the specified string when drawn with the specified Font object.
MultiplyTransform | Overloaded. Multiplies the world transformation of this IGraphics object and specified the .NET Matrix object.
ReleaseHdc | Releases a device context handle obtained by a previous call to the GetHdc method of this IGraphics object.
ReleaseHdcInternal | Internal method. Do not use.
ResetClip | Resets the clip region of this IGraphics object to an infinite region.
ResetTransform | Resets the world transformation matrix of this IGraphics object to the identity matrix.
Restore | Restores the state of this IGraphics object to the state represented by a GraphicsState object.
RotateTransform | Overloaded. Applies the specified rotation to the transformation matrix of this IGraphics object.
Save | Saves the current state of this IGraphics object and identifies the saved state with a GraphicsState object.
ScaleTransform | Overloaded. Applies the specified scaling operation to the transformation matrix of this IGraphics object by prepending it to the object's transformation matrix.
SetClip | Overloaded. Sets the clipping region of this IGraphics object to the Clip property of the specified IGraphics object.
TransformPoints | Overloaded. Transforms an array of points from one coordinate space to another using the current world and page transformations of this IGraphics object.
TranslateClip | Overloaded. Translates the clipping region of this IGraphics object by specified amounts in the horizontal and vertical directions.
TranslateTransform | Overloaded. Prepends the specified translation to the transformation matrix of this IGraphics object.

See Also

IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.AddMetafileComment Method

IGraphics.AddMetafileComment Method
[image]

Adds a comment to the current Metafile object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void AddMetafileComment (
byte[] data
)

Visual Basic [image] Copy Code

Sub AddMetafileComment( _
data() As Byte _
)

Parameters

data
Array of bytes that contains the comment.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.BeginContainer Method

IGraphics.BeginContainer Method
[image]

Saves a graphics container with the current state of this IGraphics object and opens and uses a new graphics container.

Overload List

Name | Description
IGraphics.BeginContainer () | Saves a graphics container with the current state of this IGraphics object and opens and uses a new graphics container.
IGraphics.BeginContainer (Rectangle, Rectangle, GraphicsUnit) | Saves a graphics container with the current state of this IGraphics object and opens and uses a new graphics container with the specified scale transformation.
IGraphics.BeginContainer (RectangleF, RectangleF, GraphicsUnit) | Saves a graphics container with the current state of this IGraphics object and opens and uses a new graphics container with the specified scale transformation.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.BeginContainer Method ()

IGraphics.BeginContainer Method ()
See Also
[image]

Saves a graphics container with the current state of this IGraphics object and opens and uses a new graphics container.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

GraphicsContainer BeginContainer ()

Visual Basic [image] Copy Code

Function BeginContainer () As GraphicsContainer

Return Value

This method returns a .NET GraphicsContainer object that represents the state of this IGraphics object at the time of the method call.

See Also

BeginContainer Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.BeginContainer Method (Rectangle, Rectangle, GraphicsUnit)

IGraphics.BeginContainer Method (Rectangle, Rectangle, GraphicsUnit)
See Also
[image]

Saves a graphics container with the current state of this IGraphics object and opens and uses a new graphics container with the specified scale transformation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

GraphicsContainer BeginContainer (
Rectangle dstrect,
Rectangle srcrect,
GraphicsUnit unit
)

Visual Basic [image] Copy Code

Function BeginContainer( _
dstrect As Rectangle, _
srcrect As Rectangle, _
unit As GraphicsUnit _
) As GraphicsContainer

Parameters

dstrect
A .NET Rectangle structure that, together with the srcrect parameter, specifies a scale transformation for the container.
srcrect
A .NET Rectangle structure that, together with the dstrect parameter, specifies a scale transformation for the container.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure for the container.

Return Value

This method returns a .NET GraphicsContainer object that represents the state of this IGraphics object at the time of the method call.

See Also

BeginContainer Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.BeginContainer Method (RectangleF, RectangleF, GraphicsUnit)

IGraphics.BeginContainer Method (RectangleF, RectangleF, GraphicsUnit)
See Also
[image]

Saves a graphics container with the current state of this IGraphics object and opens and uses a new graphics container with the specified scale transformation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

GraphicsContainer BeginContainer (
RectangleF dstrect,
RectangleF srcrect,
GraphicsUnit unit
)

Visual Basic [image] Copy Code

Function BeginContainer( _
dstrect As RectangleF, _
srcrect As RectangleF, _
unit As GraphicsUnit _
) As GraphicsContainer

Parameters

dstrect
A .NET RectangleF structure that, together with the srcrect parameter, specifies a scale transformation for the new graphics container.
srcrect
A .NET RectangleF structure that, together with the dstrect parameter, specifies a scale transformation for the new graphics container.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure for the container.

Return Value

This method returns a .NET GraphicsContainer object that represents the state of this IGraphics object at the time of the method call.

See Also

BeginContainer Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.BeginHyperLink Method

IGraphics.BeginHyperLink Method
[image]

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void BeginHyperLink (
string url,
string target
)

Visual Basic [image] Copy Code

Sub BeginHyperLink( _
url As String, _
target As String _
)

Parameters

url

target

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Clear Method

IGraphics.Clear Method
[image]

Clears the entire drawing surface and fills it with the specified background color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void Clear (
Color color
)

Visual Basic [image] Copy Code

Sub Clear( _
color As Color _
)

Parameters

color
A .NET Color structure that represents the background color of the drawing surface.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Dispose Method

IGraphics.Dispose Method
[image]

Releases all resources used by this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void Dispose ()

Visual Basic [image] Copy Code

Sub Dispose ()

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawArc Method

IGraphics.DrawArc Method
[image]

Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

Overload List

Name | Description
IGraphics.DrawArc (Pen, Int32, Int32, Int32, Int32, Int32, Int32) | Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
IGraphics.DrawArc (Pen, Rectangle, Single, Single) | Draws an arc representing a portion of an ellipse specified by a .NET Rectangle structure.
IGraphics.DrawArc (Pen, RectangleF, Single, Single) | Draws an arc representing a portion of an ellipse specified by a .NET RectangleF structure.
IGraphics.DrawArc (Pen, Single, Single, Single, Single, Single, Single) | Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawArc Method (Pen, Int32, Int32, Int32, Int32, Int32, Int32)

IGraphics.DrawArc Method (Pen, Int32, Int32, Int32, Int32, Int32, Int32)
See Also
[image]

Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawArc (
Pen pen,
int x,
int y,
int width,
int height,
int startAngle,
int sweepAngle
)

Visual Basic [image] Copy Code

Sub DrawArc( _
pen As Pen, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer, _
startAngle As Integer, _
sweepAngle As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the arc.
x
The x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
The width of the rectangle that defines the ellipse.
height
The height of the rectangle that defines the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

See Also

DrawArc Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawArc Method (Pen, Rectangle, Single, Single)

IGraphics.DrawArc Method (Pen, Rectangle, Single, Single)
See Also
[image]

Draws an arc representing a portion of an ellipse specified by a .NET Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawArc (
Pen pen,
Rectangle rect,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Sub DrawArc( _
pen As Pen, _
rect As Rectangle, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the arc.
rect
A .NET Rectangle structure that defines the boundaries of the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

See Also

DrawArc Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawArc Method (Pen, RectangleF, Single, Single)

IGraphics.DrawArc Method (Pen, RectangleF, Single, Single)
See Also
[image]

Draws an arc representing a portion of an ellipse specified by a .NET RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawArc (
Pen pen,
RectangleF rect,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Sub DrawArc( _
pen As Pen, _
rect As RectangleF, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the arc.
rect
A .NET RectangleF structure that defines the boundaries of the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

See Also

DrawArc Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawArc Method (Pen, Single, Single, Single, Single, Single, Single)

IGraphics.DrawArc Method (Pen, Single, Single, Single, Single, Single, Single)
See Also
[image]

Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawArc (
Pen pen,
float x,
float y,
float width,
float height,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Sub DrawArc( _
pen As Pen, _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the arc.
x
The x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
The width of the rectangle that defines the ellipse.
height
The height of the rectangle that defines the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

See Also

DrawArc Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawBezier Method

IGraphics.DrawBezier Method
[image]

Draws a Bйzier spline defined by four .NET Point structures.

Overload List

Name | Description
IGraphics.DrawBezier (Pen, Point, Point, Point, Point) | Draws a Bйzier spline defined by four Point structures.
IGraphics.DrawBezier (Pen, PointF, PointF, PointF, PointF) | Draws a Bйzier spline defined by four PointF structures.
IGraphics.DrawBezier (Pen, Single, Single, Single, Single, Single, Single, Single, Single) | Draws a Bйzier spline defined by four ordered pairs of coordinates that represent points.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawBezier Method (Pen, Point, Point, Point, Point)

IGraphics.DrawBezier Method (Pen, Point, Point, Point, Point)
See Also
[image]

Draws a Bйzier spline defined by four Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawBezier (
Pen pen,
Point pt1,
Point pt2,
Point pt3,
Point pt4
)

Visual Basic [image] Copy Code

Sub DrawBezier( _
pen As Pen, _
pt1 As Point, _
pt2 As Point, _
pt3 As Point, _
pt4 As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
pt1
A .NET Point structure that represents the starting point of the curve.
pt2
A .NET Point structure that represents the first control point for the curve.
pt3
A .NET Point structure that represents the second control point for the curve.
pt4
A .NET Point structure that represents the ending point of the curve.

See Also

DrawBezier Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawBezier Method (Pen, PointF, PointF, PointF, PointF)

IGraphics.DrawBezier Method (Pen, PointF, PointF, PointF, PointF)
See Also
[image]

Draws a Bйzier spline defined by four PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawBezier (
Pen pen,
PointF pt1,
PointF pt2,
PointF pt3,
PointF pt4
)

Visual Basic [image] Copy Code

Sub DrawBezier( _
pen As Pen, _
pt1 As PointF, _
pt2 As PointF, _
pt3 As PointF, _
pt4 As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
pt1
A .NET PointF structure that represents the starting point of the curve.
pt2
A .NET PointF structure that represents the first control point for the curve.
pt3
A .NET PointF structure that represents the second control point for the curve.
pt4
A .NET PointF structure that represents the ending point of the curve.

See Also

DrawBezier Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawBezier Method (Pen, Single, Single, Single, Single, Single, Single, Single, Single)

IGraphics.DrawBezier Method (Pen, Single, Single, Single, Single, Single, Single, Single, Single)
See Also
[image]

Draws a Bйzier spline defined by four ordered pairs of coordinates that represent points.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawBezier (
Pen pen,
float x1,
float y1,
float x2,
float y2,
float x3,
float y3,
float x4,
float y4
)

Visual Basic [image] Copy Code

Sub DrawBezier( _
pen As Pen, _
x1 As Single, _
y1 As Single, _
x2 As Single, _
y2 As Single, _
x3 As Single, _
y3 As Single, _
x4 As Single, _
y4 As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
x1
The x-coordinate of the starting point of the curve.
y1
The y-coordinate of the starting point of the curve.
x2
The x-coordinate of the first control point of the curve.
y2
The y-coordinate of the first control point of the curve.
x3
The x-coordinate of the second control point of the curve.
y3
The y-coordinate of the second control point of the curve.
x4
The x-coordinate of the ending point of the curve.
y4
The y-coordinate of the ending point of the curve.

See Also

DrawBezier Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawBeziers Method

IGraphics.DrawBeziers Method
[image]

Draws a series of Bйzier splines from an array of Point structures.

Overload List

Name | Description
IGraphics.DrawBeziers (Pen, Point[]) | Draws a series of Bйzier splines from an array of Point structures.
IGraphics.DrawBeziers (Pen, PointF[]) | Draws a series of Bйzier splines from an array of PointF structures.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawBeziers Method (Pen, Point[])

IGraphics.DrawBeziers Method (Pen, Point[])
See Also
[image]

Draws a series of Bйzier splines from an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawBeziers (
Pen pen,
Point[] points
)

Visual Basic [image] Copy Code

Sub DrawBeziers( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
points
An array of .NET Point structures that represent the points that determine the curve.

See Also

DrawBeziers Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawBeziers Method (Pen, PointF[])

IGraphics.DrawBeziers Method (Pen, PointF[])
See Also
[image]

Draws a series of Bйzier splines from an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawBeziers (
Pen pen,
PointF[] points
)

Visual Basic [image] Copy Code

Sub DrawBeziers( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
points
An array of .NET PointF structures that represent the points that determine the curve.

See Also

DrawBeziers Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawClosedCurve Method

IGraphics.DrawClosedCurve Method
[image]

Draws a closed cardinal spline defined by an array of Point structures.

Overload List

Name | Description
IGraphics.DrawClosedCurve (Pen, Point[]) | Draws a closed cardinal spline defined by an array of Point structures.
IGraphics.DrawClosedCurve (Pen, Point[], Single, FillMode) | Draws a closed cardinal spline defined by an array of Point structures using a specified tension.
IGraphics.DrawClosedCurve (Pen, PointF[]) | Draws a closed cardinal spline defined by an array of PointF structures.
IGraphics.DrawClosedCurve (Pen, PointF[], Single, FillMode) | Draws a closed cardinal spline defined by an array of PointF structures using a specified tension.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawClosedCurve Method (Pen, Point[])

IGraphics.DrawClosedCurve Method (Pen, Point[])
See Also
[image]

Draws a closed cardinal spline defined by an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawClosedCurve (
Pen pen,
Point[] points
)

Visual Basic [image] Copy Code

Sub DrawClosedCurve( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.

See Also

DrawClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawClosedCurve Method (Pen, Point[], Single, FillMode)

IGraphics.DrawClosedCurve Method (Pen, Point[], Single, FillMode)
See Also
[image]

Draws a closed cardinal spline defined by an array of Point structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawClosedCurve (
Pen pen,
Point[] points,
float tension,
FillMode fillmode
)

Visual Basic [image] Copy Code

Sub DrawClosedCurve( _
pen As Pen, _
points() As Point, _
tension As Single, _
fillmode As FillMode _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled. This parameter is required but ignored.

See Also

DrawClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawClosedCurve Method (Pen, PointF[])

IGraphics.DrawClosedCurve Method (Pen, PointF[])
See Also
[image]

Draws a closed cardinal spline defined by an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawClosedCurve (
Pen pen,
PointF[] points
)

Visual Basic [image] Copy Code

Sub DrawClosedCurve( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of PointF structures that define the spline.

See Also

DrawClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawClosedCurve Method (Pen, PointF[], Single, FillMode)

IGraphics.DrawClosedCurve Method (Pen, PointF[], Single, FillMode)
See Also
[image]

Draws a closed cardinal spline defined by an array of PointF structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawClosedCurve (
Pen pen,
PointF[] points,
float tension,
FillMode fillmode
)

Visual Basic [image] Copy Code

Sub DrawClosedCurve( _
pen As Pen, _
points() As PointF, _
tension As Single, _
fillmode As FillMode _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of PointF structures that define the spline.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.
fillmode
Member of the FillMode enumeration that determines how the curve is filled. This parameter is required but is ignored.

See Also

DrawClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawCurve Method

IGraphics.DrawCurve Method
[image]

Draws a cardinal spline through a specified array of Point structures.

Overload List

Name | Description
IGraphics.DrawCurve (Pen, Point[]) | Draws a cardinal spline through a specified array of Point structures.
IGraphics.DrawCurve (Pen, Point[], Int32, Int32, Single) | Draws a cardinal spline through a specified array of Point structures using a specified tension.
IGraphics.DrawCurve (Pen, Point[], Single) | Draws a cardinal spline through a specified array of Point structures using a specified tension.
IGraphics.DrawCurve (Pen, PointF[]) | Draws a cardinal spline through a specified array of PointF structures.
IGraphics.DrawCurve (Pen, PointF[], Int32, Int32) | Draws a cardinal spline through a specified array of PointF structures. The drawing begins offset from the beginning of the array.
IGraphics.DrawCurve (Pen, PointF[], Int32, Int32, Single) | Draws a cardinal spline through a specified array of PointF structures using a specified tension. The drawing begins offset from the beginning of the array.
IGraphics.DrawCurve (Pen, PointF[], Single) | Draws a cardinal spline through a specified array of PointF structures using a specified tension.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawCurve Method (Pen, Point[])

IGraphics.DrawCurve Method (Pen, Point[])
See Also
[image]

Draws a cardinal spline through a specified array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawCurve (
Pen pen,
Point[] points
)

Visual Basic [image] Copy Code

Sub DrawCurve( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.

See Also

DrawCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawCurve Method (Pen, Point[], Int32, Int32, Single)

IGraphics.DrawCurve Method (Pen, Point[], Int32, Int32, Single)
See Also
[image]

Draws a cardinal spline through a specified array of Point structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawCurve (
Pen pen,
Point[] points,
int offset,
int numberOfSegments,
float tension
)

Visual Basic [image] Copy Code

Sub DrawCurve( _
pen As Pen, _
points() As Point, _
offset As Integer, _
numberOfSegments As Integer, _
tension As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.
offset
The offset from the first element in the array of the points parameter to the starting point in the curve.
numberOfSegments
The number of segments after the starting point to include in the curve.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

DrawCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawCurve Method (Pen, Point[], Single)

IGraphics.DrawCurve Method (Pen, Point[], Single)
See Also
[image]

Draws a cardinal spline through a specified array of Point structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawCurve (
Pen pen,
Point[] points,
float tension
)

Visual Basic [image] Copy Code

Sub DrawCurve( _
pen As Pen, _
points() As Point, _
tension As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

DrawCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawCurve Method (Pen, PointF[])

IGraphics.DrawCurve Method (Pen, PointF[])
See Also
[image]

Draws a cardinal spline through a specified array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawCurve (
Pen pen,
PointF[] points
)

Visual Basic [image] Copy Code

Sub DrawCurve( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET PointF structures that define the spline.

See Also

DrawCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawCurve Method (Pen, PointF[], Int32, Int32)

IGraphics.DrawCurve Method (Pen, PointF[], Int32, Int32)
See Also
[image]

Draws a cardinal spline through a specified array of PointF structures. The drawing begins offset from the beginning of the array.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawCurve (
Pen pen,
PointF[] points,
int offset,
int numberOfSegments
)

Visual Basic [image] Copy Code

Sub DrawCurve( _
pen As Pen, _
points() As PointF, _
offset As Integer, _
numberOfSegments As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET PointF structures that define the spline.
offset
The offset from the first element in the array of the points parameter to the starting point in the curve.
numberOfSegments
The number of segments after the starting point to include in the curve.

See Also

DrawCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawCurve Method (Pen, PointF[], Int32, Int32, Single)

IGraphics.DrawCurve Method (Pen, PointF[], Int32, Int32, Single)
See Also
[image]

Draws a cardinal spline through a specified array of PointF structures using a specified tension. The drawing begins offset from the beginning of the array.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawCurve (
Pen pen,
PointF[] points,
int offset,
int numberOfSegments,
float tension
)

Visual Basic [image] Copy Code

Sub DrawCurve( _
pen As Pen, _
points() As PointF, _
offset As Integer, _
numberOfSegments As Integer, _
tension As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET PointF structures that define the spline.
offset
The offset from the first element in the array of the points parameter to the starting point in the curve.
numberOfSegments
The number of segments after the starting point to include in the curve.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

DrawCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawCurve Method (Pen, PointF[], Single)

IGraphics.DrawCurve Method (Pen, PointF[], Single)
See Also
[image]

Draws a cardinal spline through a specified array of PointF structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawCurve (
Pen pen,
PointF[] points,
float tension
)

Visual Basic [image] Copy Code

Sub DrawCurve( _
pen As Pen, _
points() As PointF, _
tension As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET PointF structures that represent the points that define the curve.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

DrawCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawEllipse Method

IGraphics.DrawEllipse Method
[image]

Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Overload List

Name | Description
IGraphics.DrawEllipse (Pen, Int32, Int32, Int32, Int32) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
IGraphics.DrawEllipse (Pen, Rectangle) | Draws an ellipse specified by a bounding Rectangle structure.
IGraphics.DrawEllipse (Pen, RectangleF) | Draws an ellipse defined by a bounding RectangleF structure.
IGraphics.DrawEllipse (Pen, Single, Single, Single, Single) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawEllipse Method (Pen, Int32, Int32, Int32, Int32)

IGraphics.DrawEllipse Method (Pen, Int32, Int32, Int32, Int32)
See Also
[image]

Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawEllipse (
Pen pen,
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Sub DrawEllipse( _
pen As Pen, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the ellipse.
x

The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.

y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
The width of the bounding rectangle that defines the ellipse.
height
The height of the bounding rectangle that defines the ellipse.

See Also

DrawEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawEllipse Method (Pen, Rectangle)

IGraphics.DrawEllipse Method (Pen, Rectangle)
See Also
[image]

Draws an ellipse specified by a bounding Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawEllipse (
Pen pen,
Rectangle rect
)

Visual Basic [image] Copy Code

Sub DrawEllipse( _
pen As Pen, _
rect As Rectangle _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the ellipse.
rect
A .NET Rectangle structure that defines the boundaries of the ellipse.

See Also

DrawEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawEllipse Method (Pen, RectangleF)

IGraphics.DrawEllipse Method (Pen, RectangleF)
See Also
[image]

Draws an ellipse defined by a bounding RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawEllipse (
Pen pen,
RectangleF rect
)

Visual Basic [image] Copy Code

Sub DrawEllipse( _
pen As Pen, _
rect As RectangleF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the ellipse.
rect
A .NET RectangleF structure that defines the boundaries of the ellipse.

See Also

DrawEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawEllipse Method (Pen, Single, Single, Single, Single)

IGraphics.DrawEllipse Method (Pen, Single, Single, Single, Single)
See Also
[image]

Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawEllipse (
Pen pen,
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Sub DrawEllipse( _
pen As Pen, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the ellipse.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
The width of the bounding rectangle that defines the ellipse.
height
The height of the bounding rectangle that defines the ellipse.

See Also

DrawEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawIcon Method

IGraphics.DrawIcon Method
[image]

Draws the image represented by the specified .NET Icon object at the specified coordinates.

Overload List

Name | Description
IGraphics.DrawIcon (Icon, Int32, Int32) | Draws the image represented by the specified .NET Icon object at the specified coordinates.
IGraphics.DrawIcon (Icon, Rectangle) | Draws the image represented by the specified .NET Icon object within the area specified by a Rectangle structure.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawIcon Method (Icon, Int32, Int32)

IGraphics.DrawIcon Method (Icon, Int32, Int32)
See Also
[image]

Draws the image represented by the specified .NET Icon object at the specified coordinates.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawIcon (
Icon icon,
int x,
int y
)

Visual Basic [image] Copy Code

Sub DrawIcon( _
icon As Icon, _
x As Integer, _
y As Integer _
)

Parameters

icon
A .NET Icon object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.

See Also

DrawIcon Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawIcon Method (Icon, Rectangle)

IGraphics.DrawIcon Method (Icon, Rectangle)
See Also
[image]

Draws the image represented by the specified .NET Icon object within the area specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawIcon (
Icon icon,
Rectangle targetRect
)

Visual Basic [image] Copy Code

Sub DrawIcon( _
icon As Icon, _
targetRect As Rectangle _
)

Parameters

icon
A .NET Icon object to draw.
targetRect
A .NET Rectangle structure that specifies the location and size of the resulting image on the display surface. The image contained in the icon parameter is scaled to the dimensions of this rectangular area.

See Also

DrawIcon Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawIconUnstretched Method

IGraphics.DrawIconUnstretched Method
[image]

Draws the image represented by the specified .NET Icon object without scaling the image.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawIconUnstretched (
Icon icon,
Rectangle targetRect
)

Visual Basic [image] Copy Code

Sub DrawIconUnstretched( _
icon As Icon, _
targetRect As Rectangle _
)

Parameters

icon
A .NET Icon object to draw.
targetRect
A .NET Rectangle structure that specifies the location and size of the resulting image. The image is not scaled to fit this rectangle, but retains its original size. If the image is larger than the rectangle, it is clipped to fit inside it.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method

IGraphics.DrawImage Method
[image]

Draws the specified .NET Image object at the specified location and with the original size.

Overload List

Name | Description
IGraphics.DrawImage (Image, Int32, Int32) | Draws the specified image, using its original physical size, at the location specified by a coordinate pair.
IGraphics.DrawImage (Image, Int32, Int32, Int32, Int32) | Draws the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, Int32, Int32, Rectangle, GraphicsUnit) | Draws a portion of an image at a specified location.
IGraphics.DrawImage (Image, Point) | Draws the specified .NET Image object, using its original physical size, at the specified location.
IGraphics.DrawImage (Image, Point[]) | Draws the specified .NET Image object at the specified location and with the specified shape and size.
IGraphics.DrawImage (Image, Point[], Rectangle, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes) | Draws the specified portion of the specified .NET Image object at the specified location.
IGraphics.DrawImage (Image, PointF) | Draws the specified .NET Image object, using its original physical size, at the specified location.
IGraphics.DrawImage (Image, PointF[]) | Draws the specified .NET Image object at the specified location and with the specified shape and size.
IGraphics.DrawImage (Image, PointF[], RectangleF, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, Rectangle) | Draws the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, Rectangle, Rectangle, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, RectangleF) | Draws the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, RectangleF, RectangleF, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, Single, Single) | Draws the specified .NET Image object, using its original physical size, at the specified location.
IGraphics.DrawImage (Image, Single, Single, RectangleF, GraphicsUnit) | Draws a portion of an image at a specified location.
IGraphics.DrawImage (Image, Single, Single, Single, Single) | Draws the specified .NET Image object at the specified location and with the specified size.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Int32, Int32)

IGraphics.DrawImage Method (Image, Int32, Int32)
See Also
[image]

Draws the specified image, using its original physical size, at the location specified by a coordinate pair.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
int x,
int y
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
x As Integer, _
y As Integer _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Int32, Int32, Int32, Int32)

IGraphics.DrawImage Method (Image, Int32, Int32, Int32, Int32)
See Also
[image]

Draws the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
width
The width of the drawn image.
height
The height of the drawn image.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Int32, Int32, Rectangle, GraphicsUnit)

IGraphics.DrawImage Method (Image, Int32, Int32, Rectangle, GraphicsUnit)
See Also
[image]

Draws a portion of an image at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
int x,
int y,
Rectangle srcRect,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
x As Integer, _
y As Integer, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Point)

IGraphics.DrawImage Method (Image, Point)
See Also
[image]

Draws the specified .NET Image object, using its original physical size, at the specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
Point point
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
point As Point _
)

Parameters

image
A .NET Image object to draw.
point
A .NET Point structure that represents the location of the upper-left corner of the drawn image.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Point[])

IGraphics.DrawImage Method (Image, Point[])
See Also
[image]

Draws the specified .NET Image object at the specified location and with the specified shape and size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
Point[] destPoints
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
destPoints() As Point _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET Point structures that define a parallelogram.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit)

IGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
destPoints() As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET Point structures that define a parallelogram.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes)

IGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit srcUnit,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
destPoints() As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET Point structures that define a parallelogram.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, PointF)

IGraphics.DrawImage Method (Image, PointF)
See Also
[image]

Draws the specified .NET Image object, using its original physical size, at the specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
PointF point
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
point As PointF _
)

Parameters

image
A .NET Image object to draw.
point
A .NET PointF structure that represents the upper-left corner of the drawn image.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, PointF[])

IGraphics.DrawImage Method (Image, PointF[])
See Also
[image]

Draws the specified .NET Image object at the specified location and with the specified shape and size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
PointF[] destPoints
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
destPoints() As PointF _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET PointF structures that define a parallelogram.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit)

IGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
destPoints() As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET PointF structures that define a parallelogram.
srcRect
A .NET RectangleF structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes)

IGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit srcUnit,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
destPoints() As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET PointF structures that define a parallelogram.
srcRect
A .NET RectangleF structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Rectangle)

IGraphics.DrawImage Method (Image, Rectangle)
See Also
[image]

Draws the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
Rectangle rect
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
rect As Rectangle _
)

Parameters

image
A .NET Image object to draw.
rect
A .NET Rectangle structure that specifies the location and size of the drawn image.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit)

IGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
Rectangle destRect,
int srcX,
int srcY,
int srcWidth,
int srcHeight,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcX As Integer, _
srcY As Integer, _
srcWidth As Integer, _
srcHeight As Integer, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes)

IGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
Rectangle destRect,
int srcX,
int srcY,
int srcWidth,
int srcHeight,
GraphicsUnit srcUnit,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcX As Integer, _
srcY As Integer, _
srcWidth As Integer, _
srcHeight As Integer, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Rectangle, Rectangle, GraphicsUnit)

IGraphics.DrawImage Method (Image, Rectangle, Rectangle, GraphicsUnit)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
Rectangle destRect,
Rectangle srcRect,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit)

IGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
Rectangle destRect,
float srcX,
float srcY,
float srcWidth,
float srcHeight,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcX As Single, _
srcY As Single, _
srcWidth As Single, _
srcHeight As Single, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes)

IGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
Rectangle destRect,
float srcX,
float srcY,
float srcWidth,
float srcHeight,
GraphicsUnit srcUnit,
ImageAttributes imageAttrs
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcX As Single, _
srcY As Single, _
srcWidth As Single, _
srcHeight As Single, _
srcUnit As GraphicsUnit, _
imageAttrs As ImageAttributes _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.
imageAttrs
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, RectangleF)

IGraphics.DrawImage Method (Image, RectangleF)
See Also
[image]

Draws the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
RectangleF rect
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
rect As RectangleF _
)

Parameters

image
A .NET Image object to draw.
rect
A .NET RectangleF structure that specifies the location and size of the drawn image.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, RectangleF, RectangleF, GraphicsUnit)

IGraphics.DrawImage Method (Image, RectangleF, RectangleF, GraphicsUnit)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
RectangleF destRect,
RectangleF srcRect,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
destRect As RectangleF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET RectangleF structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcRect
A .NET RectangleF structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Single, Single)

IGraphics.DrawImage Method (Image, Single, Single)
See Also
[image]

Draws the specified .NET Image object, using its original physical size, at the specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
float x,
float y
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
x As Single, _
y As Single _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Single, Single, RectangleF, GraphicsUnit)

IGraphics.DrawImage Method (Image, Single, Single, RectangleF, GraphicsUnit)
See Also
[image]

Draws a portion of an image at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
float x,
float y,
RectangleF srcRect,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
x As Single, _
y As Single, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
srcRect
A .NET RectangleF structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Single, Single, Single, Single)

IGraphics.DrawImage Method (Image, Single, Single, Single, Single)
See Also
[image]

Draws the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
width
The width of the drawn image.
height
The height of the drawn image.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImageUnscaled Method

IGraphics.DrawImageUnscaled Method
[image]

Draws the specified image using its original physical size at the location specified by a coordinate pair.

Overload List

Name | Description
IGraphics.DrawImageUnscaled (Image, Int32, Int32) | Draws the specified image using its original physical size at the location specified by a coordinate pair.
IGraphics.DrawImageUnscaled (Image, Int32, Int32, Int32, Int32) | Draws a specified image using its original physical size at a specified location.
IGraphics.DrawImageUnscaled (Image, Point) | Draws a specified image using its original physical size at a specified location.
IGraphics.DrawImageUnscaled (Image, Rectangle) | Draws a specified image using its original physical size at a specified location.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImageUnscaled Method (Image, Int32, Int32)

IGraphics.DrawImageUnscaled Method (Image, Int32, Int32)
See Also
[image]

Draws the specified image using its original physical size at the location specified by a coordinate pair.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImageUnscaled (
Image image,
int x,
int y
)

Visual Basic [image] Copy Code

Sub DrawImageUnscaled( _
image As Image, _
x As Integer, _
y As Integer _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.

See Also

DrawImageUnscaled Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImageUnscaled Method (Image, Int32, Int32, Int32, Int32)

IGraphics.DrawImageUnscaled Method (Image, Int32, Int32, Int32, Int32)
See Also
[image]

Draws a specified image using its original physical size at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImageUnscaled (
Image image,
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Sub DrawImageUnscaled( _
image As Image, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
width
Not used.
height
Not used.

See Also

DrawImageUnscaled Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImageUnscaled Method (Image, Point)

IGraphics.DrawImageUnscaled Method (Image, Point)
See Also
[image]

Draws a specified image using its original physical size at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImageUnscaled (
Image image,
Point point
)

Visual Basic [image] Copy Code

Sub DrawImageUnscaled( _
image As Image, _
point As Point _
)

Parameters

image
A .NET Image object to draw.
point
A .NET Point structure that specifies the upper-left corner of the drawn image.

See Also

DrawImageUnscaled Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImageUnscaled Method (Image, Rectangle)

IGraphics.DrawImageUnscaled Method (Image, Rectangle)
See Also
[image]

Draws a specified image using its original physical size at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImageUnscaled (
Image image,
Rectangle rect
)

Visual Basic [image] Copy Code

Sub DrawImageUnscaled( _
image As Image, _
rect As Rectangle _
)

Parameters

image
A .NET Image object to draw.
rect
A .NET Rectangle that specifies the upper-left corner of the drawn image. The X and Y properties of the rectangle specify the upper-left corner. The Width and Height properties are ignored.

See Also

DrawImageUnscaled Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLine Method

IGraphics.DrawLine Method
[image]

Draws a line connecting the two points specified by coordinate pairs.

Overload List

Name | Description
IGraphics.DrawLine (Pen, Int32, Int32, Int32, Int32) | Draws a line connecting the two points specified by coordinate pairs.
IGraphics.DrawLine (Pen, Point, Point) | Draws a line connecting two Point structures.
IGraphics.DrawLine (Pen, PointF, PointF) | Draws a line connecting two PointF structures.
IGraphics.DrawLine (Pen, Single, Single, Single, Single) | Draws a line connecting the two points specified by coordinate pairs.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLine Method (Pen, Int32, Int32, Int32, Int32)

IGraphics.DrawLine Method (Pen, Int32, Int32, Int32, Int32)
See Also
[image]

Draws a line connecting the two points specified by coordinate pairs.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawLine (
Pen pen,
int x1,
int y1,
int x2,
int y2
)

Visual Basic [image] Copy Code

Sub DrawLine( _
pen As Pen, _
x1 As Integer, _
y1 As Integer, _
x2 As Integer, _
y2 As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line.
x1
The x-coordinate of the first point.
y1
The y-coordinate of the first point.
x2
The x-coordinate of the second point.
y2
The y-coordinate of the second point.

See Also

DrawLine Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLine Method (Pen, Point, Point)

IGraphics.DrawLine Method (Pen, Point, Point)
See Also
[image]

Draws a line connecting two Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawLine (
Pen pen,
Point pt1,
Point pt2
)

Visual Basic [image] Copy Code

Sub DrawLine( _
pen As Pen, _
pt1 As Point, _
pt2 As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line.
pt1
A .NET Point structure that represents the first point to connect.
pt2
A .NET Point structure that represents the second point to connect.

See Also

DrawLine Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLine Method (Pen, PointF, PointF)

IGraphics.DrawLine Method (Pen, PointF, PointF)
See Also
[image]

Draws a line connecting two PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawLine (
Pen pen,
PointF pt1,
PointF pt2
)

Visual Basic [image] Copy Code

Sub DrawLine( _
pen As Pen, _
pt1 As PointF, _
pt2 As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line.
pt1
A .NET PointF structure that represents the first point to connect.
pt2
A .NET PointF structure that represents the second point to connect.

See Also

DrawLine Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLine Method (Pen, Single, Single, Single, Single)

IGraphics.DrawLine Method (Pen, Single, Single, Single, Single)
See Also
[image]

Draws a line connecting the two points specified by coordinate pairs.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawLine (
Pen pen,
float x1,
float y1,
float x2,
float y2
)

Visual Basic [image] Copy Code

Sub DrawLine( _
pen As Pen, _
x1 As Single, _
y1 As Single, _
x2 As Single, _
y2 As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line.
x1
The x-coordinate of the first point.
y1
The y-coordinate of the first point.
x2
The x-coordinate of the second point.
y2
The y-coordinate of the second point.

See Also

DrawLine Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLines Method

IGraphics.DrawLines Method
[image]

Draws a series of line segments that connect an array of Point structures.

Overload List

Name | Description
IGraphics.DrawLines (Pen, Point[]) | Draws a series of line segments that connect an array of Point structures.
IGraphics.DrawLines (Pen, PointF[]) | Draws a series of line segments that connect an array of PointF structures.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLines Method (Pen, Point[])

IGraphics.DrawLines Method (Pen, Point[])
See Also
[image]

Draws a series of line segments that connect an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawLines (
Pen pen,
Point[] points
)

Visual Basic [image] Copy Code

Sub DrawLines( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line segments.
points
An array of .NET Point structures that represent the points to connect.

See Also

DrawLines Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLines Method (Pen, PointF[])

IGraphics.DrawLines Method (Pen, PointF[])
See Also
[image]

Draws a series of line segments that connect an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawLines (
Pen pen,
PointF[] points
)

Visual Basic [image] Copy Code

Sub DrawLines( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line segments.
points
An array of .NET PointF structures that represent the points to connect.

See Also

DrawLines Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPath Method

IGraphics.DrawPath Method
[image]

Draws a .NET GraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawPath (
Pen pen,
GraphicsPath path
)

Visual Basic [image] Copy Code

Sub DrawPath( _
pen As Pen, _
path As GraphicsPath _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the path.
path
A .NET GraphicsPath object to draw.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPie Method

IGraphics.DrawPie Method
[image]

Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.

Overload List

Name | Description
IGraphics.DrawPie (Pen, Int32, Int32, Int32, Int32, Int32, Int32) | Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.
IGraphics.DrawPie (Pen, Rectangle, Single, Single) | Draws a pie shape defined by an ellipse specified by a Rectangle structure and two radial lines.
IGraphics.DrawPie (Pen, RectangleF, Single, Single) | Draws a pie shape defined by an ellipse specified by a RectangleF structure and two radial lines.
IGraphics.DrawPie (Pen, Single, Single, Single, Single, Single, Single) | Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPie Method (Pen, Int32, Int32, Int32, Int32, Int32, Int32)

IGraphics.DrawPie Method (Pen, Int32, Int32, Int32, Int32, Int32, Int32)
See Also
[image]

Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawPie (
Pen pen,
int x,
int y,
int width,
int height,
int startAngle,
int sweepAngle
)

Visual Basic [image] Copy Code

Sub DrawPie( _
pen As Pen, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer, _
startAngle As Integer, _
sweepAngle As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the pie shape.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
width
The width of the bounding rectangle that defines the ellipse from which the pie shape comes.
height
The height of the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

See Also

DrawPie Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPie Method (Pen, Rectangle, Single, Single)

IGraphics.DrawPie Method (Pen, Rectangle, Single, Single)
See Also
[image]

Draws a pie shape defined by an ellipse specified by a Rectangle structure and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawPie (
Pen pen,
Rectangle rect,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Sub DrawPie( _
pen As Pen, _
rect As Rectangle, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the pie shape.
rect
A .NET Rectangle structure that represents the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

See Also

DrawPie Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPie Method (Pen, RectangleF, Single, Single)

IGraphics.DrawPie Method (Pen, RectangleF, Single, Single)
See Also
[image]

Draws a pie shape defined by an ellipse specified by a RectangleF structure and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawPie (
Pen pen,
RectangleF rect,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Sub DrawPie( _
pen As Pen, _
rect As RectangleF, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the pie shape.
rect
A .NET RectangleF structure that represents the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

See Also

DrawPie Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPie Method (Pen, Single, Single, Single, Single, Single, Single)

IGraphics.DrawPie Method (Pen, Single, Single, Single, Single, Single, Single)
See Also
[image]

Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawPie (
Pen pen,
float x,
float y,
float width,
float height,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Sub DrawPie( _
pen As Pen, _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the pie shape.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
width
The width of the bounding rectangle that defines the ellipse from which the pie shape comes.
height
The height of the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

See Also

DrawPie Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPolygon Method

IGraphics.DrawPolygon Method
[image]

Draws a polygon defined by an array of Point structures.

Overload List

Name | Description
IGraphics.DrawPolygon (Pen, Point[]) | Draws a polygon defined by an array of Point structures.
IGraphics.DrawPolygon (Pen, PointF[]) | Draws a polygon defined by an array of PointF structures.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPolygon Method (Pen, Point[])

IGraphics.DrawPolygon Method (Pen, Point[])
See Also
[image]

Draws a polygon defined by an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawPolygon (
Pen pen,
Point[] points
)

Visual Basic [image] Copy Code

Sub DrawPolygon( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the polygon.
points
An array of .NET Point structures that represent the vertices of the polygon.

See Also

DrawPolygon Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPolygon Method (Pen, PointF[])

IGraphics.DrawPolygon Method (Pen, PointF[])
See Also
[image]

Draws a polygon defined by an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawPolygon (
Pen pen,
PointF[] points
)

Visual Basic [image] Copy Code

Sub DrawPolygon( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the polygon.
points
An array of .NET PointF structures that represent the vertices of the polygon.

See Also

DrawPolygon Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawRectangle Method

IGraphics.DrawRectangle Method
[image]

Draws a rectangle specified by a coordinate pair, a width, and a height.

Overload List

Name | Description
IGraphics.DrawRectangle (Pen, Int32, Int32, Int32, Int32) | Draws a rectangle specified by a coordinate pair, a width, and a height.
IGraphics.DrawRectangle (Pen, Rectangle) | Draws a rectangle specified by a Rectangle structure.
IGraphics.DrawRectangle (Pen, Single, Single, Single, Single) | Draws a rectangle specified by a coordinate pair, a width, and a height.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawRectangle Method (Pen, Int32, Int32, Int32, Int32)

IGraphics.DrawRectangle Method (Pen, Int32, Int32, Int32, Int32)
See Also
[image]

Draws a rectangle specified by a coordinate pair, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawRectangle (
Pen pen,
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Sub DrawRectangle( _
pen As Pen, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the rectangle.
x
The x-coordinate of the upper-left corner of the rectangle to draw.
y
The y-coordinate of the upper-left corner of the rectangle to draw.
width
The width of the rectangle to draw.
height
The height of the rectangle to draw.

See Also

DrawRectangle Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawRectangle Method (Pen, Rectangle)

IGraphics.DrawRectangle Method (Pen, Rectangle)
See Also
[image]

Draws a rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawRectangle (
Pen pen,
Rectangle rect
)

Visual Basic [image] Copy Code

Sub DrawRectangle( _
pen As Pen, _
rect As Rectangle _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the rectangle.
rect
A .NET Rectangle structure that represents the rectangle to draw.

See Also

DrawRectangle Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawRectangle Method (Pen, Single, Single, Single, Single)

IGraphics.DrawRectangle Method (Pen, Single, Single, Single, Single)
See Also
[image]

Draws a rectangle specified by a coordinate pair, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawRectangle (
Pen pen,
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Sub DrawRectangle( _
pen As Pen, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the rectangle.
x
The x-coordinate of the upper-left corner of the rectangle to draw.
y
The y-coordinate of the upper-left corner of the rectangle to draw.
width
The width of the rectangle to draw.
height
The height of the rectangle to draw.

See Also

DrawRectangle Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawRectangles Method

IGraphics.DrawRectangles Method
[image]

Draws a series of rectangles specified by Rectangle structures.

Overload List

Name | Description
IGraphics.DrawRectangles (Pen, Rectangle[]) | Draws a series of rectangles specified by Rectangle structures.
IGraphics.DrawRectangles (Pen, RectangleF[]) | Draws a series of rectangles specified by RectangleF structures.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawRectangles Method (Pen, Rectangle[])

IGraphics.DrawRectangles Method (Pen, Rectangle[])
See Also
[image]

Draws a series of rectangles specified by Rectangle structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawRectangles (
Pen pen,
Rectangle[] rects
)

Visual Basic [image] Copy Code

Sub DrawRectangles( _
pen As Pen, _
rects() As Rectangle _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the outlines of the rectangles.
rects
An array of .NET Rectangle structures that represent the rectangles to draw.

See Also

DrawRectangles Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawRectangles Method (Pen, RectangleF[])

IGraphics.DrawRectangles Method (Pen, RectangleF[])
See Also
[image]

Draws a series of rectangles specified by RectangleF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawRectangles (
Pen pen,
RectangleF[] rects
)

Visual Basic [image] Copy Code

Sub DrawRectangles( _
pen As Pen, _
rects() As RectangleF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the outlines of the rectangles.
rects
An array of .NET RectangleF structures that represent the rectangles to draw.

See Also

DrawRectangles Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawString Method

IGraphics.DrawString Method
[image]

Draws the specified text string at the specified location with the specified Brush and Font objects.

Overload List

Name | Description
IGraphics.DrawString (String, Font, Brush, PointF) | Draws the specified text string at the specified location with the specified Brush and Font objects.
IGraphics.DrawString (String, Font, Brush, PointF, StringFormat) | Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.
IGraphics.DrawString (String, Font, Brush, RectangleF) | Draws the specified text string in the specified rectangle with the specified Brush and Font objects.
IGraphics.DrawString (String, Font, Brush, RectangleF, StringFormat) | Draws the specified text string in the specified rectangle with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.
IGraphics.DrawString (String, Font, Brush, Single, Single) | Draws the specified text string at the specified location with the specified Brush and Font objects.
IGraphics.DrawString (String, Font, Brush, Single, Single, StringFormat) | Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawString Method (String, Font, Brush, PointF)

IGraphics.DrawString Method (String, Font, Brush, PointF)
See Also
[image]

Draws the specified text string at the specified location with the specified Brush and Font objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawString (
string s,
Font font,
Brush brush,
PointF point
)

Visual Basic [image] Copy Code

Sub DrawString( _
s As String, _
font As Font, _
brush As Brush, _
point As PointF _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
point
A .NET PointF structure that specifies the upper-left corner of the drawn text.

See Also

DrawString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawString Method (String, Font, Brush, PointF, StringFormat)

IGraphics.DrawString Method (String, Font, Brush, PointF, StringFormat)
See Also
[image]

Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawString (
string s,
Font font,
Brush brush,
PointF point,
StringFormat format
)

Visual Basic [image] Copy Code

Sub DrawString( _
s As String, _
font As Font, _
brush As Brush, _
point As PointF, _
format As StringFormat _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
point
A .NET PointF structure that specifies the upper-left corner of the drawn text.
format
A .NET StringFormat object that specifies formatting attributes, such as line spacing and alignment, that are applied to the drawn text.

See Also

DrawString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawString Method (String, Font, Brush, RectangleF)

IGraphics.DrawString Method (String, Font, Brush, RectangleF)
See Also
[image]

Draws the specified text string in the specified rectangle with the specified Brush and Font objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawString (
string s,
Font font,
Brush brush,
RectangleF layoutRectangle
)

Visual Basic [image] Copy Code

Sub DrawString( _
s As String, _
font As Font, _
brush As Brush, _
layoutRectangle As RectangleF _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
layoutRectangle
A .NET RectangleF structure that specifies the location of the drawn text.

See Also

DrawString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawString Method (String, Font, Brush, RectangleF, StringFormat)

IGraphics.DrawString Method (String, Font, Brush, RectangleF, StringFormat)
See Also
[image]

Draws the specified text string in the specified rectangle with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawString (
string s,
Font font,
Brush brush,
RectangleF layoutRectangle,
StringFormat format
)

Visual Basic [image] Copy Code

Sub DrawString( _
s As String, _
font As Font, _
brush As Brush, _
layoutRectangle As RectangleF, _
format As StringFormat _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
layoutRectangle
A .NET RectangleF structure that specifies the location of the drawn text.
format
A .NET StringFormat object that specifies formatting attributes, such as line spacing and alignment, that are applied to the drawn text.

See Also

DrawString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawString Method (String, Font, Brush, Single, Single)

IGraphics.DrawString Method (String, Font, Brush, Single, Single)
See Also
[image]

Draws the specified text string at the specified location with the specified Brush and Font objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawString (
string s,
Font font,
Brush brush,
float x,
float y
)

Visual Basic [image] Copy Code

Sub DrawString( _
s As String, _
font As Font, _
brush As Brush, _
x As Single, _
y As Single _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
x
The x-coordinate of the upper-left corner of the drawn text.
y
The y-coordinate of the upper-left corner of the drawn text.

See Also

DrawString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawString Method (String, Font, Brush, Single, Single, StringFormat)

IGraphics.DrawString Method (String, Font, Brush, Single, Single, StringFormat)
See Also
[image]

Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawString (
string s,
Font font,
Brush brush,
float x,
float y,
StringFormat format
)

Visual Basic [image] Copy Code

Sub DrawString( _
s As String, _
font As Font, _
brush As Brush, _
x As Single, _
y As Single, _
format As StringFormat _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
x
The x-coordinate of the upper-left corner of the drawn text.
y
The y-coordinate of the upper-left corner of the drawn text.
format
A .NET StringFormat object that specifies formatting attributes, such as line spacing and alignment, that are applied to the drawn text.

See Also

DrawString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.EndContainer Method

IGraphics.EndContainer Method
[image]

Closes the current graphics container and restores the state of this IGraphics object to the state saved by a call to the BeginContainer method.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void EndContainer (
GraphicsContainer container
)

Visual Basic [image] Copy Code

Sub EndContainer( _
container As GraphicsContainer _
)

Parameters

container
A .NET GraphicsContainer object that represents the container this method restores.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.EndHyperLink Method

IGraphics.EndHyperLink Method
[image]

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void EndHyperLink ()

Visual Basic [image] Copy Code

Sub EndHyperLink ()

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ExcludeClip Method

IGraphics.ExcludeClip Method
[image]

Updates the clip region of this IGraphics object to exclude the area specified by a .NET Rectangle structure.

Overload List

Name | Description
IGraphics.ExcludeClip (Rectangle) | Updates the clip region of this IGraphics object to exclude the area specified by a Rectangle structure.
IGraphics.ExcludeClip (Region) | Updates the clip region of this IGraphics object to exclude the area specified by a Region object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ExcludeClip Method (Rectangle)

IGraphics.ExcludeClip Method (Rectangle)
See Also
[image]

Updates the clip region of this IGraphics object to exclude the area specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void ExcludeClip (
Rectangle rect
)

Visual Basic [image] Copy Code

Sub ExcludeClip( _
rect As Rectangle _
)

Parameters

rect
A .NET Rectangle structure that specifies the rectangle to exclude from the clip region.

See Also

ExcludeClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ExcludeClip Method (Region)

IGraphics.ExcludeClip Method (Region)
See Also
[image]

Updates the clip region of this IGraphics object to exclude the area specified by a Region object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void ExcludeClip (
Region region
)

Visual Basic [image] Copy Code

Sub ExcludeClip( _
region As Region _
)

Parameters

region
A .NET Region object that specifies the region to exclude from the clip region.

See Also

ExcludeClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillClosedCurve Method

IGraphics.FillClosedCurve Method
[image]

Fills the interior a closed cardinal spline curve defined by an array of Point structures.

Overload List

Name | Description
IGraphics.FillClosedCurve (Brush, Point[]) | Fills the interior a closed cardinal spline curve defined by an array of Point structures.
IGraphics.FillClosedCurve (Brush, Point[], FillMode) | Fills the interior a closed cardinal spline curve defined by an array of Point structures using the specified fill mode.
IGraphics.FillClosedCurve (Brush, Point[], FillMode, Single) | Fills the interior a closed cardinal spline curve defined by an array of Point structures using the specified fill mode and tension.
IGraphics.FillClosedCurve (Brush, PointF[]) | Fills the interior a closed cardinal spline curve defined by an array of PointF structures.
IGraphics.FillClosedCurve (Brush, PointF[], FillMode) | Fills the interior a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode.
IGraphics.FillClosedCurve (Brush, PointF[], FillMode, Single) | Fills the interior a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode and tension.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillClosedCurve Method (Brush, Point[])

IGraphics.FillClosedCurve Method (Brush, Point[])
See Also
[image]

Fills the interior a closed cardinal spline curve defined by an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillClosedCurve (
Brush brush,
Point[] points
)

Visual Basic [image] Copy Code

Sub FillClosedCurve( _
brush As Brush, _
points() As Point _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that define the spline.

See Also

FillClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillClosedCurve Method (Brush, Point[], FillMode)

IGraphics.FillClosedCurve Method (Brush, Point[], FillMode)
See Also
[image]

Fills the interior a closed cardinal spline curve defined by an array of Point structures using the specified fill mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillClosedCurve (
Brush brush,
Point[] points,
FillMode fillmode
)

Visual Basic [image] Copy Code

Sub FillClosedCurve( _
brush As Brush, _
points() As Point, _
fillmode As FillMode _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that define the spline.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled.

See Also

FillClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillClosedCurve Method (Brush, Point[], FillMode, Single)

IGraphics.FillClosedCurve Method (Brush, Point[], FillMode, Single)
See Also
[image]

Fills the interior a closed cardinal spline curve defined by an array of Point structures using the specified fill mode and tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillClosedCurve (
Brush brush,
Point[] points,
FillMode fillmode,
float tension
)

Visual Basic [image] Copy Code

Sub FillClosedCurve( _
brush As Brush, _
points() As Point, _
fillmode As FillMode, _
tension As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that define the spline.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

FillClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillClosedCurve Method (Brush, PointF[])

IGraphics.FillClosedCurve Method (Brush, PointF[])
See Also
[image]

Fills the interior a closed cardinal spline curve defined by an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillClosedCurve (
Brush brush,
PointF[] points
)

Visual Basic [image] Copy Code

Sub FillClosedCurve( _
brush As Brush, _
points() As PointF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that define the spline.

See Also

FillClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillClosedCurve Method (Brush, PointF[], FillMode)

IGraphics.FillClosedCurve Method (Brush, PointF[], FillMode)
See Also
[image]

Fills the interior a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillClosedCurve (
Brush brush,
PointF[] points,
FillMode fillmode
)

Visual Basic [image] Copy Code

Sub FillClosedCurve( _
brush As Brush, _
points() As PointF, _
fillmode As FillMode _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that define the spline.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled.

See Also

FillClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillClosedCurve Method (Brush, PointF[], FillMode, Single)

IGraphics.FillClosedCurve Method (Brush, PointF[], FillMode, Single)
See Also
[image]

Fills the interior a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode and tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillClosedCurve (
Brush brush,
PointF[] points,
FillMode fillmode,
float tension
)

Visual Basic [image] Copy Code

Sub FillClosedCurve( _
brush As Brush, _
points() As PointF, _
fillmode As FillMode, _
tension As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that define the spline.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

FillClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillEllipse Method

IGraphics.FillEllipse Method
[image]

Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

Overload List

Name | Description
IGraphics.FillEllipse (Brush, Int32, Int32, Int32, Int32) | Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.
IGraphics.FillEllipse (Brush, Rectangle) | Fills the interior of an ellipse defined by a bounding rectangle specified by a Rectangle structure.
IGraphics.FillEllipse (Brush, RectangleF) | Fills the interior of an ellipse defined by a bounding rectangle specified by a RectangleF structure.
IGraphics.FillEllipse (Brush, Single, Single, Single, Single) | Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillEllipse Method (Brush, Int32, Int32, Int32, Int32)

IGraphics.FillEllipse Method (Brush, Int32, Int32, Int32, Int32)
See Also
[image]

Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillEllipse (
Brush brush,
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Sub FillEllipse( _
brush As Brush, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
The width of the bounding rectangle that defines the ellipse.
height
The height of the bounding rectangle that defines the ellipse.

See Also

FillEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillEllipse Method (Brush, Rectangle)

IGraphics.FillEllipse Method (Brush, Rectangle)
See Also
[image]

Fills the interior of an ellipse defined by a bounding rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillEllipse (
Brush brush,
Rectangle rect
)

Visual Basic [image] Copy Code

Sub FillEllipse( _
brush As Brush, _
rect As Rectangle _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET Rectangle structure that represents the bounding rectangle that defines the ellipse.

See Also

FillEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillEllipse Method (Brush, RectangleF)

IGraphics.FillEllipse Method (Brush, RectangleF)
See Also
[image]

Fills the interior of an ellipse defined by a bounding rectangle specified by a RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillEllipse (
Brush brush,
RectangleF rect
)

Visual Basic [image] Copy Code

Sub FillEllipse( _
brush As Brush, _
rect As RectangleF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET RectangleF structure that represents the bounding rectangle that defines the ellipse.

See Also

FillEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillEllipse Method (Brush, Single, Single, Single, Single)

IGraphics.FillEllipse Method (Brush, Single, Single, Single, Single)
See Also
[image]

Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillEllipse (
Brush brush,
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Sub FillEllipse( _
brush As Brush, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
The width of the bounding rectangle that defines the ellipse.
height
The height of the bounding rectangle that defines the ellipse.

See Also

FillEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPath Method

IGraphics.FillPath Method
[image]

Fills the interior of a .NET GraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillPath (
Brush brush,
GraphicsPath path
)

Visual Basic [image] Copy Code

Sub FillPath( _
brush As Brush, _
path As GraphicsPath _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
path
A .NET GraphicsPath object that represents the path to fill.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPie Method

IGraphics.FillPie Method
[image]

Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.

Overload List

Name | Description
IGraphics.FillPie (Brush, Int32, Int32, Int32, Int32, Int32, Int32) | Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.
IGraphics.FillPie (Brush, Rectangle, Single, Single) | Fills the interior of a pie section defined by an ellipse specified by a RectangleF structure and two radial lines.
IGraphics.FillPie (Brush, Single, Single, Single, Single, Single, Single) | Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPie Method (Brush, Int32, Int32, Int32, Int32, Int32, Int32)

IGraphics.FillPie Method (Brush, Int32, Int32, Int32, Int32, Int32, Int32)
See Also
[image]

Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillPie (
Brush brush,
int x,
int y,
int width,
int height,
int startAngle,
int sweepAngle
)

Visual Basic [image] Copy Code

Sub FillPie( _
brush As Brush, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer, _
startAngle As Integer, _
sweepAngle As Integer _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
width
The width of the bounding rectangle that defines the ellipse from which the pie section comes.
height
The height of the bounding rectangle that defines the ellipse from which the pie section comes.
startAngle
The angle in degrees measured clockwise from the x-axis to the first side of the pie section.
sweepAngle
The angle in degrees measured clockwise from the startAngle parameter to the second side of the pie section.

See Also

FillPie Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPie Method (Brush, Rectangle, Single, Single)

IGraphics.FillPie Method (Brush, Rectangle, Single, Single)
See Also
[image]

Fills the interior of a pie section defined by an ellipse specified by a RectangleF structure and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillPie (
Brush brush,
Rectangle rect,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Sub FillPie( _
brush As Brush, _
rect As Rectangle, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET Rectangle structure that represents the bounding rectangle that defines the ellipse from which the pie section comes.
startAngle
The angle in degrees measured clockwise from the x-axis to the first side of the pie section.
sweepAngle
The angle in degrees measured clockwise from the startAngle parameter to the second side of the pie section.

See Also

FillPie Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPie Method (Brush, Single, Single, Single, Single, Single, Single)

IGraphics.FillPie Method (Brush, Single, Single, Single, Single, Single, Single)
See Also
[image]

Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillPie (
Brush brush,
float x,
float y,
float width,
float height,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Sub FillPie( _
brush As Brush, _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
width
The width of the bounding rectangle that defines the ellipse from which the pie section comes.
height
The height of the bounding rectangle that defines the ellipse from which the pie section comes.
startAngle
The angle in degrees measured clockwise from the x-axis to the first side of the pie section.
sweepAngle
The angle in degrees measured clockwise from the startAngle parameter to the second side of the pie section.

See Also

FillPie Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPolygon Method

IGraphics.FillPolygon Method
[image]

Fills the interior of a polygon defined by an array of points specified by Point structures.

Overload List

Name | Description
IGraphics.FillPolygon (Brush, Point[]) | Fills the interior of a polygon defined by an array of points specified by Point structures.
IGraphics.FillPolygon (Brush, Point[], FillMode) | Fills the interior of a polygon defined by an array of points specified by Point structures using the specified fill mode.
IGraphics.FillPolygon (Brush, PointF[]) | Fills the interior of a polygon defined by an array of points specified by PointF structures.
IGraphics.FillPolygon (Brush, PointF[], FillMode) | Fills the interior of a polygon defined by an array of points specified by PointF structures using the specified fill mode.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPolygon Method (Brush, Point[])

IGraphics.FillPolygon Method (Brush, Point[])
See Also
[image]

Fills the interior of a polygon defined by an array of points specified by Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillPolygon (
Brush brush,
Point[] points
)

Visual Basic [image] Copy Code

Sub FillPolygon( _
brush As Brush, _
points() As Point _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that represent the vertices of the polygon to fill.

See Also

FillPolygon Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPolygon Method (Brush, Point[], FillMode)

IGraphics.FillPolygon Method (Brush, Point[], FillMode)
See Also
[image]

Fills the interior of a polygon defined by an array of points specified by Point structures using the specified fill mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillPolygon (
Brush brush,
Point[] points,
FillMode fillMode
)

Visual Basic [image] Copy Code

Sub FillPolygon( _
brush As Brush, _
points() As Point, _
fillMode As FillMode _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that represent the vertices of the polygon to fill.
fillMode
Member of the .NET FillMode enumeration that determines the style of the fill.

See Also

FillPolygon Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPolygon Method (Brush, PointF[])

IGraphics.FillPolygon Method (Brush, PointF[])
See Also
[image]

Fills the interior of a polygon defined by an array of points specified by PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillPolygon (
Brush brush,
PointF[] points
)

Visual Basic [image] Copy Code

Sub FillPolygon( _
brush As Brush, _
points() As PointF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that represent the vertices of the polygon to fill.

See Also

FillPolygon Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPolygon Method (Brush, PointF[], FillMode)

IGraphics.FillPolygon Method (Brush, PointF[], FillMode)
See Also
[image]

Fills the interior of a polygon defined by an array of points specified by PointF structures using the specified fill mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillPolygon (
Brush brush,
PointF[] points,
FillMode fillMode
)

Visual Basic [image] Copy Code

Sub FillPolygon( _
brush As Brush, _
points() As PointF, _
fillMode As FillMode _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that represent the vertices of the polygon to fill.
fillMode
Member of the .NET FillMode enumeration that determines the style of the fill.

See Also

FillPolygon Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRectangle Method

IGraphics.FillRectangle Method
[image]

Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.

Overload List

Name | Description
IGraphics.FillRectangle (Brush, Int32, Int32, Int32, Int32) | Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.
IGraphics.FillRectangle (Brush, Rectangle) | Fills the interior of a rectangle specified by a Rectangle structure.
IGraphics.FillRectangle (Brush, RectangleF) | Fills the interior of a rectangle specified by a RectangleF structure.
IGraphics.FillRectangle (Brush, Single, Single, Single, Single) | Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRectangle Method (Brush, Int32, Int32, Int32, Int32)

IGraphics.FillRectangle Method (Brush, Int32, Int32, Int32, Int32)
See Also
[image]

Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillRectangle (
Brush brush,
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Sub FillRectangle( _
brush As Brush, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the rectangle to fill.
y
The y-coordinate of the upper-left corner of the rectangle to fill.
width
The width of the rectangle to fill.
height
The height of the rectangle to fill.

See Also

FillRectangle Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRectangle Method (Brush, Rectangle)

IGraphics.FillRectangle Method (Brush, Rectangle)
See Also
[image]

Fills the interior of a rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillRectangle (
Brush brush,
Rectangle rect
)

Visual Basic [image] Copy Code

Sub FillRectangle( _
brush As Brush, _
rect As Rectangle _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET Rectangle structure that represents the rectangle to fill.

See Also

FillRectangle Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRectangle Method (Brush, RectangleF)

IGraphics.FillRectangle Method (Brush, RectangleF)
See Also
[image]

Fills the interior of a rectangle specified by a RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillRectangle (
Brush brush,
RectangleF rect
)

Visual Basic [image] Copy Code

Sub FillRectangle( _
brush As Brush, _
rect As RectangleF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET RectangleF structure that represents the rectangle to fill.

See Also

FillRectangle Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRectangle Method (Brush, Single, Single, Single, Single)

IGraphics.FillRectangle Method (Brush, Single, Single, Single, Single)
See Also
[image]

Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillRectangle (
Brush brush,
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Sub FillRectangle( _
brush As Brush, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the rectangle to fill.
y
The y-coordinate of the upper-left corner of the rectangle to fill.
width
The width of the rectangle to fill.
height
The height of the rectangle to fill.

See Also

FillRectangle Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRectangles Method

IGraphics.FillRectangles Method
[image]

Fills the interiors of a series of rectangles specified by Rectangle structures.

Overload List

Name | Description
IGraphics.FillRectangles (Brush, Rectangle[]) | Fills the interiors of a series of rectangles specified by Rectangle structures.
IGraphics.FillRectangles (Brush, RectangleF[]) | Fills the interiors of a series of rectangles specified by RectangleF structures.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRectangles Method (Brush, Rectangle[])

IGraphics.FillRectangles Method (Brush, Rectangle[])
See Also
[image]

Fills the interiors of a series of rectangles specified by Rectangle structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillRectangles (
Brush brush,
Rectangle[] rects
)

Visual Basic [image] Copy Code

Sub FillRectangles( _
brush As Brush, _
rects() As Rectangle _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rects
An array of .NET Rectangle structures that represent the rectangles to fill.

See Also

FillRectangles Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRectangles Method (Brush, RectangleF[])

IGraphics.FillRectangles Method (Brush, RectangleF[])
See Also
[image]

Fills the interiors of a series of rectangles specified by RectangleF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillRectangles (
Brush brush,
RectangleF[] rects
)

Visual Basic [image] Copy Code

Sub FillRectangles( _
brush As Brush, _
rects() As RectangleF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rects
An array of .NET RectangleF structures that represent the rectangles to fill.

See Also

FillRectangles Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRegion Method

IGraphics.FillRegion Method
[image]

Fills the interior of a .NET Region object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillRegion (
Brush brush,
Region region
)

Visual Basic [image] Copy Code

Sub FillRegion( _
brush As Brush, _
region As Region _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
region
A .NET Region object that represents the area to fill.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Flush Method

IGraphics.Flush Method
[image]

Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.

Overload List

Name | Description
IGraphics.Flush () | Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.
IGraphics.Flush (FlushIntention) | Forces execution of all pending graphics operations with the method waiting or not waiting, as specified, to return before the operations finish.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Flush Method ()

IGraphics.Flush Method ()
See Also
[image]

Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void Flush ()

Visual Basic [image] Copy Code

Sub Flush ()

See Also

Flush Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Flush Method (FlushIntention)

IGraphics.Flush Method (FlushIntention)
See Also
[image]

Forces execution of all pending graphics operations with the method waiting or not waiting, as specified, to return before the operations finish.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void Flush (
FlushIntention intention
)

Visual Basic [image] Copy Code

Sub Flush( _
intention As FlushIntention _
)

Parameters

intention
Member of the .NET FlushIntention enumeration that specifies whether the method returns immediately or waits for any existing operations to finish.

See Also

Flush Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.GetFontHeight Method

IGraphics.GetFontHeight Method
[image]

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

float GetFontHeight (
Font font
)

Visual Basic [image] Copy Code

Function GetFontHeight( _
font As Font _
) As Single

Parameters

font

Return Value

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.GetHdc Method

IGraphics.GetHdc Method
[image]

Gets the handle to the device context associated with this IGraphics.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

IntPtr GetHdc ()

Visual Basic [image] Copy Code

Function GetHdc () As IntPtr

Return Value

Handle to the device context associated with this IGraphics.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.GetNearestColor Method

IGraphics.GetNearestColor Method
[image]

Gets the nearest color to the specified Color structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

Color GetNearestColor (
Color color
)

Visual Basic [image] Copy Code

Function GetNearestColor( _
color As Color _
) As Color

Parameters

color
A .NET Color structure for which to find a match.

Return Value

A .NET Color structure that represents the nearest color to the one specified with the color parameter.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IntersectClip Method

IGraphics.IntersectClip Method
[image]

Updates the clip region of this IGraphics object to the intersection of the current clip region and the specified Rectangle structure.

Overload List

Name | Description
IGraphics.IntersectClip (Rectangle) | Updates the clip region of this IGraphics object to the intersection of the current clip region and the specified Rectangle structure.
IGraphics.IntersectClip (RectangleF) | Updates the clip region of this IGraphics object to the intersection of the current clip region and the specified RectangleF structure.
IGraphics.IntersectClip (Region) | Updates the clip region of this IGraphics object to the intersection of the current clip region and the specified Region object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IntersectClip Method (Rectangle)

IGraphics.IntersectClip Method (Rectangle)
See Also
[image]

Updates the clip region of this IGraphics object to the intersection of the current clip region and the specified Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void IntersectClip (
Rectangle rect
)

Visual Basic [image] Copy Code

Sub IntersectClip( _
rect As Rectangle _
)

Parameters

rect
A .NET Rectangle structure to intersect with the current clip region.

See Also

IntersectClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IntersectClip Method (RectangleF)

IGraphics.IntersectClip Method (RectangleF)
See Also
[image]

Updates the clip region of this IGraphics object to the intersection of the current clip region and the specified RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void IntersectClip (
RectangleF rect
)

Visual Basic [image] Copy Code

Sub IntersectClip( _
rect As RectangleF _
)

Parameters

rect
A .NET RectangleF structure to intersect with the current clip region.

See Also

IntersectClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IntersectClip Method (Region)

IGraphics.IntersectClip Method (Region)
See Also
[image]

Updates the clip region of this IGraphics object to the intersection of the current clip region and the specified Region object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void IntersectClip (
Region region
)

Visual Basic [image] Copy Code

Sub IntersectClip( _
region As Region _
)

Parameters

region
A .NET Region object to intersect with the current region.

See Also

IntersectClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisible Method

IGraphics.IsVisible Method
[image]

Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this IGraphics object.

Overload List

Name | Description
IGraphics.IsVisible (Int32, Int32) | Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this IGraphics object.
IGraphics.IsVisible (Int32, Int32, Int32, Int32) | Indicates whether the rectangle specified by a pair of coordinates, a width, and a height is contained within the visible clip region of this IGraphics object.
IGraphics.IsVisible (Point) | Indicates whether the specified Point structure is contained within the visible clip region of this IGraphics object.
IGraphics.IsVisible (PointF) | Indicates whether the specified PointF structure is contained within the visible clip region of this IGraphics object.
IGraphics.IsVisible (Rectangle) | Indicates whether the rectangle specified by a Rectangle structure is contained within the visible clip region of this IGraphics object.
IGraphics.IsVisible (RectangleF) | Indicates whether the rectangle specified by a RectangleF structure is contained within the visible clip region of this IGraphics object.
IGraphics.IsVisible (Single, Single) | Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this IGraphics object.
IGraphics.IsVisible (Single, Single, Single, Single) | Indicates whether the rectangle specified by a pair of coordinates, a width, and a height is contained within the visible clip region of this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisible Method (Int32, Int32)

IGraphics.IsVisible Method (Int32, Int32)
See Also
[image]

Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

bool IsVisible (
int x,
int y
)

Visual Basic [image] Copy Code

Function IsVisible( _
x As Integer, _
y As Integer _
) As Boolean

Parameters

x
The x-coordinate of the point to test for visibility.
y
The y-coordinate of the point to test for visibility.

Return Value

This method returns true if the point defined by the x and y parameters is contained within the visible clip region of this IGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisible Method (Int32, Int32, Int32, Int32)

IGraphics.IsVisible Method (Int32, Int32, Int32, Int32)
See Also
[image]

Indicates whether the rectangle specified by a pair of coordinates, a width, and a height is contained within the visible clip region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

bool IsVisible (
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Function IsVisible( _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
) As Boolean

Parameters

x
The x-coordinate of the upper-left corner of the rectangle to test for visibility.
y
The y-coordinate of the upper-left corner of the rectangle to test for visibility.
width
The width of the rectangle to test for visibility.
height
The height of the rectangle to test for visibility.

Return Value

This method returns true if the rectangle defined by the x, y, width, and height parameters is contained within the visible clip region of this IGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisible Method (Point)

IGraphics.IsVisible Method (Point)
See Also
[image]

Indicates whether the specified Point structure is contained within the visible clip region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

bool IsVisible (
Point point
)

Visual Basic [image] Copy Code

Function IsVisible( _
point As Point _
) As Boolean

Parameters

point
A .NET Point structure to test for visibility.

Return Value

This method returns true if the point specified by the point parameter is contained within the visible clip region of this IGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisible Method (PointF)

IGraphics.IsVisible Method (PointF)
See Also
[image]

Indicates whether the specified PointF structure is contained within the visible clip region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

bool IsVisible (
PointF point
)

Visual Basic [image] Copy Code

Function IsVisible( _
point As PointF _
) As Boolean

Parameters

point
A .NET PointF structure to test for visibility.

Return Value

This method returns true if the point specified by the point parameter is contained within the visible clip region of this IGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisible Method (Rectangle)

IGraphics.IsVisible Method (Rectangle)
See Also
[image]

Indicates whether the rectangle specified by a Rectangle structure is contained within the visible clip region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

bool IsVisible (
Rectangle rect
)

Visual Basic [image] Copy Code

Function IsVisible( _
rect As Rectangle _
) As Boolean

Parameters

rect
A .NET Rectangle structure to test for visibility.

Return Value

This method returns true if the rectangle specified by the rect parameter is contained within the visible clip region of this IGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisible Method (RectangleF)

IGraphics.IsVisible Method (RectangleF)
See Also
[image]

Indicates whether the rectangle specified by a RectangleF structure is contained within the visible clip region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

bool IsVisible (
RectangleF rect
)

Visual Basic [image] Copy Code

Function IsVisible( _
rect As RectangleF _
) As Boolean

Parameters

rect
A .NET RectangleF structure to test for visibility.

Return Value

This method returns true if the rectangle specified by the rect parameter is contained within the visible clip region of this IGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisible Method (Single, Single)

IGraphics.IsVisible Method (Single, Single)
See Also
[image]

Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

bool IsVisible (
float x,
float y
)

Visual Basic [image] Copy Code

Function IsVisible( _
x As Single, _
y As Single _
) As Boolean

Parameters

x
The x-coordinate of the point to test for visibility.
y
The y-coordinate of the point to test for visibility.

Return Value

This method returns true if the point defined by the x and y parameters is contained within the visible clip region of this IGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisible Method (Single, Single, Single, Single)

IGraphics.IsVisible Method (Single, Single, Single, Single)
See Also
[image]

Indicates whether the rectangle specified by a pair of coordinates, a width, and a height is contained within the visible clip region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

bool IsVisible (
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Function IsVisible( _
x As Single, _
y As Single, _
width As Single, _
height As Single _
) As Boolean

Parameters

x
The x-coordinate of the upper-left corner of the rectangle to test for visibility.
y
The y-coordinate of the upper-left corner of the rectangle to test for visibility.
width
The width of the rectangle to test for visibility.
height
The height of the rectangle to test for visibility.

Return Value

This method returns true if the rectangle defined by the x, y, width, and height parameters is contained within the visible clip region of this IGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureCharacterRanges Method

IGraphics.MeasureCharacterRanges Method
[image]

Gets an array of Region objects, each of which bounds a range of character positions within the specified string.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

RectangleF[] MeasureCharacterRanges (
string text,
Font font,
RectangleF layoutRect,
StringFormat stringFormat
)

Visual Basic [image] Copy Code

Function MeasureCharacterRanges( _
text As String, _
font As Font, _
layoutRect As RectangleF, _
stringFormat As StringFormat _
) As RectangleF()

Parameters

text
The string to measure.
font
A .NET Font object that defines the text format of the string.
layoutRect
A .NET RectangleF structure that specifies the layout rectangle for the string.
stringFormat
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.

Return Value

This method returns an array of .NET Region objects, each of which bounds a range of character positions within the specified string.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureString Method

IGraphics.MeasureString Method
[image]

Measures the specified string when drawn with the specified Font object.

Overload List

Name | Description
IGraphics.MeasureString (String, Font) | Measures the specified string when drawn with the specified Font object.
IGraphics.MeasureString (String, Font, Int32) | Measures the specified string when drawn with the specified Font object.
IGraphics.MeasureString (String, Font, Int32, StringFormat) | Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.
IGraphics.MeasureString (String, Font, PointF, StringFormat) | Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.
IGraphics.MeasureString (String, Font, SizeF) | Measures the specified string when drawn with the specified Font object within the specified layout area.
IGraphics.MeasureString (String, Font, SizeF, StringFormat) | Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.
IGraphics.MeasureString (String, Font, SizeF, StringFormat, Int32@, Int32@) | Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureString Method (String, Font)

IGraphics.MeasureString Method (String, Font)
See Also
[image]

Measures the specified string when drawn with the specified Font object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

SizeF MeasureString (
string text,
Font font
)

Visual Basic [image] Copy Code

Function MeasureString( _
text As String, _
font As Font _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object that defines the text format of the string.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified by the text parameter as drawn with the font parameter.

See Also

MeasureString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureString Method (String, Font, Int32)

IGraphics.MeasureString Method (String, Font, Int32)
See Also
[image]

Measures the specified string when drawn with the specified Font object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

SizeF MeasureString (
string text,
Font font,
int width
)

Visual Basic [image] Copy Code

Function MeasureString( _
text As String, _
font As Font, _
width As Integer _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object that defines the format of the string.
width
The maximum width of the string in pixels.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified in the text parameter as drawn with the font parameter.

See Also

MeasureString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureString Method (String, Font, Int32, StringFormat)

IGraphics.MeasureString Method (String, Font, Int32, StringFormat)
See Also
[image]

Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

SizeF MeasureString (
string text,
Font font,
int width,
StringFormat format
)

Visual Basic [image] Copy Code

Function MeasureString( _
text As String, _
font As Font, _
width As Integer, _
format As StringFormat _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object that defines the text format of the string.
width
The maximum width of the string.
format
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified in the text parameter as drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureString Method (String, Font, PointF, StringFormat)

IGraphics.MeasureString Method (String, Font, PointF, StringFormat)
See Also
[image]

Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

SizeF MeasureString (
string text,
Font font,
PointF origin,
StringFormat stringFormat
)

Visual Basic [image] Copy Code

Function MeasureString( _
text As String, _
font As Font, _
origin As PointF, _
stringFormat As StringFormat _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object defines the text format of the string.
origin
A .NET PointF structure that represents the upper-left corner of the string.
stringFormat
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.

Return Value

This method returns a .NET SizeF structure that represents the size of the string, in pixels, of the text parameter as drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureString Method (String, Font, SizeF)

IGraphics.MeasureString Method (String, Font, SizeF)
See Also
[image]

Measures the specified string when drawn with the specified Font object within the specified layout area.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

SizeF MeasureString (
string text,
Font font,
SizeF layoutArea
)

Visual Basic [image] Copy Code

Function MeasureString( _
text As String, _
font As Font, _
layoutArea As SizeF _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object defines the text format of the string.
layoutArea
A .NET SizeF structure that specifies the maximum layout area for the text.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified in the text parameter as drawn with the font parameter.

See Also

MeasureString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureString Method (String, Font, SizeF, StringFormat)

IGraphics.MeasureString Method (String, Font, SizeF, StringFormat)
See Also
[image]

Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

SizeF MeasureString (
string text,
Font font,
SizeF layoutArea,
StringFormat stringFormat
)

Visual Basic [image] Copy Code

Function MeasureString( _
text As String, _
font As Font, _
layoutArea As SizeF, _
stringFormat As StringFormat _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object defines the text format of the string.
layoutArea
A .NET SizeF structure that specifies the maximum layout area for the text.
stringFormat
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified in the text parameter as drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureString Method (String, Font, SizeF, StringFormat, Int32@, Int32@)

IGraphics.MeasureString Method (String, Font, SizeF, StringFormat, Int32@, Int32@)
See Also
[image]

Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

SizeF MeasureString (
string text,
Font font,
SizeF layoutArea,
StringFormat stringFormat,
ref int charactersFitted,
ref int linesFilled
)

Visual Basic [image] Copy Code

Function MeasureString( _
text As String, _
font As Font, _
layoutArea As SizeF, _
stringFormat As StringFormat, _
ByRef charactersFitted As Integer, _
ByRef linesFilled As Integer _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object that defines the text format of the string.
layoutArea
A .NET SizeF structure that specifies the maximum layout area for the text.
stringFormat
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.
charactersFitted
Number of characters in the string.
linesFilled
Number of text lines in the string.

Return Value

This method returns a .NET SizeF structure that represents the size of the string, in pixels, of the text parameter as drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MultiplyTransform Method

IGraphics.MultiplyTransform Method
[image]

Multiplies the world transformation of this IGraphics object and specified the .NET Matrix object.

Overload List

Name | Description
IGraphics.MultiplyTransform (Matrix) | Multiplies the world transformation of this IGraphics object and specified the Matrix object.
IGraphics.MultiplyTransform (Matrix, MatrixOrder) | Multiplies the world transformation of this IGraphics object and specified the Matrix object in the specified order.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MultiplyTransform Method (Matrix)

IGraphics.MultiplyTransform Method (Matrix)
See Also
[image]

Multiplies the world transformation of this IGraphics object and specified the Matrix object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void MultiplyTransform (
Matrix matrix
)

Visual Basic [image] Copy Code

Sub MultiplyTransform( _
matrix As Matrix _
)

Parameters

matrix
A 4x4 .NET Matrix object that multiplies the world transformation.

See Also

MultiplyTransform Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MultiplyTransform Method (Matrix, MatrixOrder)

IGraphics.MultiplyTransform Method (Matrix, MatrixOrder)
See Also
[image]

Multiplies the world transformation of this IGraphics object and specified the Matrix object in the specified order.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void MultiplyTransform (
Matrix matrix,
MatrixOrder order
)

Visual Basic [image] Copy Code

Sub MultiplyTransform( _
matrix As Matrix, _
order As MatrixOrder _
)

Parameters

matrix
A 4x4 .NET Matrix object that multiplies the world transformation.
order
Member of the .NET MatrixOrder enumeration that determines the order of the multiplication.

See Also

MultiplyTransform Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ReleaseHdc Method

IGraphics.ReleaseHdc Method
[image]

Releases a device context handle obtained by a previous call to the GetHdc method of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void ReleaseHdc (
IntPtr hdc
)

Visual Basic [image] Copy Code

Sub ReleaseHdc( _
hdc As IntPtr _
)

Parameters

hdc
Handle to a device context obtained by a previous call to the GetHdc method of this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ReleaseHdcInternal Method

IGraphics.ReleaseHdcInternal Method
[image]

Internal method. Do not use.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void ReleaseHdcInternal (
IntPtr hdc
)

Visual Basic [image] Copy Code

Sub ReleaseHdcInternal( _
hdc As IntPtr _
)

Parameters

hdc
Handle to a device context.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ResetClip Method

IGraphics.ResetClip Method
[image]

Resets the clip region of this IGraphics object to an infinite region.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void ResetClip ()

Visual Basic [image] Copy Code

Sub ResetClip ()

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ResetTransform Method

IGraphics.ResetTransform Method
[image]

Resets the world transformation matrix of this IGraphics object to the identity matrix.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void ResetTransform ()

Visual Basic [image] Copy Code

Sub ResetTransform ()

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Restore Method

IGraphics.Restore Method
[image]

Restores the state of this IGraphics object to the state represented by a GraphicsState object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void Restore (
GraphicsState gstate
)

Visual Basic [image] Copy Code

Sub Restore( _
gstate As GraphicsState _
)

Parameters

gstate
A .NET GraphicsState object that represents the state to which to restore this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.RotateTransform Method

IGraphics.RotateTransform Method
[image]

Applies the specified rotation to the transformation matrix of this IGraphics object.

Overload List

Name | Description
IGraphics.RotateTransform (Single) | Applies the specified rotation to the transformation matrix of this IGraphics object.
IGraphics.RotateTransform (Single, MatrixOrder) | Applies the specified rotation to the transformation matrix of this IGraphics object in the specified order.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.RotateTransform Method (Single)

IGraphics.RotateTransform Method (Single)
See Also
[image]

Applies the specified rotation to the transformation matrix of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void RotateTransform (
float angle
)

Visual Basic [image] Copy Code

Sub RotateTransform( _
angle As Single _
)

Parameters

angle
The angle of rotation in degrees.

See Also

RotateTransform Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.RotateTransform Method (Single, MatrixOrder)

IGraphics.RotateTransform Method (Single, MatrixOrder)
See Also
[image]

Applies the specified rotation to the transformation matrix of this IGraphics object in the specified order.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void RotateTransform (
float angle,
MatrixOrder order
)

Visual Basic [image] Copy Code

Sub RotateTransform( _
angle As Single, _
order As MatrixOrder _
)

Parameters

angle
The angle of rotation in degrees.
order
Member of the .NET MatrixOrder enumeration that specifies whether the rotation is appended or prepended to the matrix transformation.

See Also

RotateTransform Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Save Method

IGraphics.Save Method
[image]

Saves the current state of this IGraphics object and identifies the saved state with a GraphicsState object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

GraphicsState Save ()

Visual Basic [image] Copy Code

Function Save () As GraphicsState

Return Value

This method returns a .NET GraphicsState object that represents the saved state of this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ScaleTransform Method

IGraphics.ScaleTransform Method
[image]

Applies the specified scaling operation to the transformation matrix of this IGraphics object by prepending it to the object's transformation matrix.

Overload List

Name | Description
IGraphics.ScaleTransform (Single, Single) | Applies the specified scaling operation to the transformation matrix of this IGraphics object by prepending it to the object's transformation matrix.
IGraphics.ScaleTransform (Single, Single, MatrixOrder) | Applies the specified scaling operation to the transformation matrix of this IGraphics object in the specified order.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ScaleTransform Method (Single, Single)

IGraphics.ScaleTransform Method (Single, Single)
See Also
[image]

Applies the specified scaling operation to the transformation matrix of this IGraphics object by prepending it to the object's transformation matrix.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void ScaleTransform (
float sx,
float sy
)

Visual Basic [image] Copy Code

Sub ScaleTransform( _
sx As Single, _
sy As Single _
)

Parameters

sx
The scale factor in the x direction.
sy
The scale factor in the y direction.

See Also

ScaleTransform Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ScaleTransform Method (Single, Single, MatrixOrder)

IGraphics.ScaleTransform Method (Single, Single, MatrixOrder)
See Also
[image]

Applies the specified scaling operation to the transformation matrix of this IGraphics object in the specified order.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void ScaleTransform (
float sx,
float sy,
MatrixOrder order
)

Visual Basic [image] Copy Code

Sub ScaleTransform( _
sx As Single, _
sy As Single, _
order As MatrixOrder _
)

Parameters

sx
The scale factor in the x direction.
sy
The scale factor in the y direction.
order
Member of the .NET MatrixOrder enumeration that specifies whether the scaling operation is prepended or appended to the transformation matrix.

See Also

ScaleTransform Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method

IGraphics.SetClip Method
[image]

Sets the clipping region of this IGraphics object to the Clip property of the specified IGraphics object.

Overload List

Name | Description
IGraphics.SetClip (GraphicsPath) | Sets the clipping region of this IGraphics object to the specified .NET GraphicsPath object.
IGraphics.SetClip (GraphicsPath, CombineMode) | Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the specified .NET GraphicsPath object.
IGraphics.SetClip (IGraphics) | Sets the clipping region of this IGraphics object to the Clip property of the specified IGraphics object.
IGraphics.SetClip (IGraphics, CombineMode) | Sets the clipping region of this IGraphics object to the result of the specified combining operation of the current clip region and the Clip property of the specified IGraphics object.
IGraphics.SetClip (Rectangle) | Sets the clipping region of this IGraphics object to the rectangle specified by a Rectangle structure.
IGraphics.SetClip (Rectangle, CombineMode) | Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the rectangle specified by a Rectangle structure.
IGraphics.SetClip (RectangleF) | Sets the clipping region of this IGraphics object to the rectangle specified by a RectangleF structure.
IGraphics.SetClip (RectangleF, CombineMode) | Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the rectangle specified by a RectangleF structure.
IGraphics.SetClip (Region, CombineMode) | Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the specified Region object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (GraphicsPath)

IGraphics.SetClip Method (GraphicsPath)
See Also
[image]

Sets the clipping region of this IGraphics object to the specified .NET GraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void SetClip (
GraphicsPath path
)

Visual Basic [image] Copy Code

Sub SetClip( _
path As GraphicsPath _
)

Parameters

path
A .NET GraphicsPath object that represents the new clip region.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (GraphicsPath, CombineMode)

IGraphics.SetClip Method (GraphicsPath, CombineMode)
See Also
[image]

Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the specified .NET GraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void SetClip (
GraphicsPath path,
CombineMode combineMode
)

Visual Basic [image] Copy Code

Sub SetClip( _
path As GraphicsPath, _
combineMode As CombineMode _
)

Parameters

path
A .NET GraphicsPath object to combine.
combineMode
Member of the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (IGraphics)

IGraphics.SetClip Method (IGraphics)
See Also
[image]

Sets the clipping region of this IGraphics object to the Clip property of the specified IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public abstract void SetClip (
IGraphics g
)

Visual Basic [image] Copy Code

Public MustOverride Sub SetClip ( _
g As IGraphics _
)

Parameters

g
An IGraphics object from which to take the new clip region.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (IGraphics, CombineMode)

IGraphics.SetClip Method (IGraphics, CombineMode)
See Also
[image]

Sets the clipping region of this IGraphics object to the result of the specified combining operation of the current clip region and the Clip property of the specified IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public abstract void SetClip (
IGraphics g,
CombineMode combineMode
)

Visual Basic [image] Copy Code

Public MustOverride Sub SetClip ( _
g As IGraphics, _
combineMode As CombineMode _
)

Parameters

g
An IGraphics object that specifies the clip region to combine.
combineMode
Member of the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (Rectangle)

IGraphics.SetClip Method (Rectangle)
See Also
[image]

Sets the clipping region of this IGraphics object to the rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void SetClip (
Rectangle rect
)

Visual Basic [image] Copy Code

Sub SetClip( _
rect As Rectangle _
)

Parameters

rect
A .NET Rectangle structure that represents the new clip region.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (Rectangle, CombineMode)

IGraphics.SetClip Method (Rectangle, CombineMode)
See Also
[image]

Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void SetClip (
Rectangle rect,
CombineMode combineMode
)

Visual Basic [image] Copy Code

Sub SetClip( _
rect As Rectangle, _
combineMode As CombineMode _
)

Parameters

rect
A .NET Rectangle structure to combine.
combineMode
Member of the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (RectangleF)

IGraphics.SetClip Method (RectangleF)
See Also
[image]

Sets the clipping region of this IGraphics object to the rectangle specified by a RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void SetClip (
RectangleF rect
)

Visual Basic [image] Copy Code

Sub SetClip( _
rect As RectangleF _
)

Parameters

rect
A .NET RectangleF structure that represents the new clip region.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (RectangleF, CombineMode)

IGraphics.SetClip Method (RectangleF, CombineMode)
See Also
[image]

Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the rectangle specified by a RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void SetClip (
RectangleF rect,
CombineMode combineMode
)

Visual Basic [image] Copy Code

Sub SetClip( _
rect As RectangleF, _
combineMode As CombineMode _
)

Parameters

rect
A .NET RectangleF structure to combine.
combineMode
Member of the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (Region, CombineMode)

IGraphics.SetClip Method (Region, CombineMode)
See Also
[image]

Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the specified Region object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void SetClip (
Region region,
CombineMode combineMode
)

Visual Basic [image] Copy Code

Sub SetClip( _
region As Region, _
combineMode As CombineMode _
)

Parameters

region
A .NET Region object to combine.
combineMode
Member from the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TransformPoints Method

IGraphics.TransformPoints Method
[image]

Transforms an array of points from one coordinate space to another using the current world and page transformations of this IGraphics object.

Overload List

Name | Description
IGraphics.TransformPoints (CoordinateSpace, CoordinateSpace, Point[]) | Transforms an array of points from one coordinate space to another using the current world and page transformations of this IGraphics object.
IGraphics.TransformPoints (CoordinateSpace, CoordinateSpace, PointF[]) | Transforms an array of points from one coordinate space to another using the current world and page transformations of this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TransformPoints Method (CoordinateSpace, CoordinateSpace, Point[])

IGraphics.TransformPoints Method (CoordinateSpace, CoordinateSpace, Point[])
See Also
[image]

Transforms an array of points from one coordinate space to another using the current world and page transformations of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void TransformPoints (
CoordinateSpace destSpace,
CoordinateSpace srcSpace,
Point[] pts
)

Visual Basic [image] Copy Code

Sub TransformPoints( _
destSpace As CoordinateSpace, _
srcSpace As CoordinateSpace, _
pts() As Point _
)

Parameters

destSpace
Member of the .NET CoordinateSpace enumeration that specifies the destination coordinate space.
srcSpace
Member of the .NET CoordinateSpace enumeration that specifies the source coordinate space.
pts
An array of .NET Point structures that represents the points to transformation.

See Also

TransformPoints Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TransformPoints Method (CoordinateSpace, CoordinateSpace, PointF[])

IGraphics.TransformPoints Method (CoordinateSpace, CoordinateSpace, PointF[])
See Also
[image]

Transforms an array of points from one coordinate space to another using the current world and page transformations of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void TransformPoints (
CoordinateSpace destSpace,
CoordinateSpace srcSpace,
PointF[] pts
)

Visual Basic [image] Copy Code

Sub TransformPoints( _
destSpace As CoordinateSpace, _
srcSpace As CoordinateSpace, _
pts() As PointF _
)

Parameters

destSpace
Member of the .NET CoordinateSpace enumeration that specifies the destination coordinate space.
srcSpace
Member of the .NET CoordinateSpace enumeration that specifies the source coordinate space.
pts
An array of .NET PointF structures that represent the points to transform.

See Also

TransformPoints Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TranslateClip Method

IGraphics.TranslateClip Method
[image]

Translates the clipping region of this IGraphics object by specified amounts in the horizontal and vertical directions.

Overload List

Name | Description
IGraphics.TranslateClip (Int32, Int32) | Translates the clipping region of this IGraphics object by specified amounts in the horizontal and vertical directions.
IGraphics.TranslateClip (Single, Single) | Translates the clipping region of this IGraphics object by specified amounts in the horizontal and vertical directions.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TranslateClip Method (Int32, Int32)

IGraphics.TranslateClip Method (Int32, Int32)
See Also
[image]

Translates the clipping region of this IGraphics object by specified amounts in the horizontal and vertical directions.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void TranslateClip (
int dx,
int dy
)

Visual Basic [image] Copy Code

Sub TranslateClip( _
dx As Integer, _
dy As Integer _
)

Parameters

dx
The x component of the translation.
dy
The y component of the translation.

See Also

TranslateClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TranslateClip Method (Single, Single)

IGraphics.TranslateClip Method (Single, Single)
See Also
[image]

Translates the clipping region of this IGraphics object by specified amounts in the horizontal and vertical directions.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void TranslateClip (
float dx,
float dy
)

Visual Basic [image] Copy Code

Sub TranslateClip( _
dx As Single, _
dy As Single _
)

Parameters

dx
The x component of the translation.
dy
The y component of the translation.

See Also

TranslateClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TranslateTransform Method

IGraphics.TranslateTransform Method
[image]

Prepends the specified translation to the transformation matrix of this IGraphics object.

Overload List

Name | Description
IGraphics.TranslateTransform (Single, Single) | Prepends the specified translation to the transformation matrix of this IGraphics object.
IGraphics.TranslateTransform (Single, Single, MatrixOrder) | Applies the specified translation to the transformation matrix of this IGraphics object in the specified order.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TranslateTransform Method (Single, Single)

IGraphics.TranslateTransform Method (Single, Single)
See Also
[image]

Prepends the specified translation to the transformation matrix of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void TranslateTransform (
float dx,
float dy
)

Visual Basic [image] Copy Code

Sub TranslateTransform( _
dx As Single, _
dy As Single _
)

Parameters

dx
The x component of the translation.
dy
The y component of the translation.

See Also

TranslateTransform Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TranslateTransform Method (Single, Single, MatrixOrder)

IGraphics.TranslateTransform Method (Single, Single, MatrixOrder)
See Also
[image]

Applies the specified translation to the transformation matrix of this IGraphics object in the specified order.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void TranslateTransform (
float dx,
float dy,
MatrixOrder order
)

Visual Basic [image] Copy Code

Sub TranslateTransform( _
dx As Single, _
dy As Single, _
order As MatrixOrder _
)

Parameters

dx
The x component of the translation.
dy
The y component of the translation.
order
Member of the .NET MatrixOrder enumeration that specifies whether the translation is prepended or appended to the transformation matrix.

See Also

TranslateTransform Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics Properties

IGraphics Properties
[image]

Public Properties

Name | Description
Clip | Gets or sets a .NET Region object that limits the drawing region of this IGraphics object.
ClipBounds | Gets a .NET RectangleF structure that bounds the clipping region of this IGraphics object.
CompositingMode | Gets or sets a value that specifies how composited images are drawn to this IGraphics object.
CompositingQuality | Gets or sets the rendering quality of composited images drawn to this IGraphics object.
DpiX | Gets the horizontal resolution of this IGraphics object.
DpiY | Gets the vertical resolution of this IGraphics object.
InterpolationMode | Gets or sets the interpolation mode associated with this IGraphics object.
IsClipEmpty | Gets a value indicating whether the clipping region of this IGraphics object is empty.
IsVisibleClipEmpty | Gets a value indicating whether the visible clipping region of this IGraphics object is empty.
PageScale | Gets or sets the scaling between world units and page units for this IGraphics object.
PageUnit | Gets or sets the unit of measure used for page coordinates in this IGraphics object.
PixelOffsetMode | Gets or set a value specifying how pixels are offset during rendering of this IGraphics object.
RenderingOrigin | Gets or sets the rendering origin of this IGraphics object for dithering and for hatch brushes.
SmoothingMode | Gets or sets the rendering quality for this IGraphics object.
TextContrast | Gets or sets the gamma correction value for rendering text.
TextRenderingHint | Gets or sets the rendering mode for text associated with this IGraphics object.
Transform | Gets or sets the world transformation for this IGraphics object.
VisibleClipBounds | Gets or sets the bounding rectangle of the visible clipping region of this IGraphics object.

See Also

IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Clip Property

IGraphics.Clip Property
[image]

Gets or sets a .NET Region object that limits the drawing region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

Region Clip { get; set; }

Visual Basic [image] Copy Code

Property Clip As Region

Property Value

This property specifies a .NET Region object that limits the portion of this IGraphics object that is currently available for drawing.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ClipBounds Property

IGraphics.ClipBounds Property
[image]

Gets a .NET RectangleF structure that bounds the clipping region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

RectangleF ClipBounds { get; }

Visual Basic [image] Copy Code

ReadOnly Property ClipBounds As RectangleF

Property Value

This property indicates a .NET RectangleF structure that represents a bounding rectangle for the clipping region of this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.CompositingMode Property

IGraphics.CompositingMode Property
[image]

Gets or sets a value that specifies how composited images are drawn to this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

CompositingMode CompositingMode { get; set; }

Visual Basic [image] Copy Code

Property CompositingMode As CompositingMode

Property Value

This property specifies a member of the .NET CompositingMode enumeration.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.CompositingQuality Property

IGraphics.CompositingQuality Property
[image]

Gets or sets the rendering quality of composited images drawn to this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

CompositingQuality CompositingQuality { get; set; }

Visual Basic [image] Copy Code

Property CompositingQuality As CompositingQuality

Property Value

This property specifies a member of the .NET CompositingQuality enumeration.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DpiX Property

IGraphics.DpiX Property
[image]

Gets the horizontal resolution of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

float DpiX { get; }

Visual Basic [image] Copy Code

ReadOnly Property DpiX As Single

Property Value

This property indicates a value, in dots per inch, for the horizontal resolution supported by this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DpiY Property

IGraphics.DpiY Property
[image]

Gets the vertical resolution of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

float DpiY { get; }

Visual Basic [image] Copy Code

ReadOnly Property DpiY As Single

Property Value

This property indicates a value, in dots per inch, for the vertical resolution supported by this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.InterpolationMode Property

IGraphics.InterpolationMode Property
[image]

Gets or sets the interpolation mode associated with this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

InterpolationMode InterpolationMode { get; set; }

Visual Basic [image] Copy Code

Property InterpolationMode As InterpolationMode

Property Value

This property specifies a member of the InterpolationMode enumeration associated with this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsClipEmpty Property

IGraphics.IsClipEmpty Property
[image]

Gets a value indicating whether the clipping region of this IGraphics object is empty.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

bool IsClipEmpty { get; }

Visual Basic [image] Copy Code

ReadOnly Property IsClipEmpty As Boolean

Property Value

This property is true if the clipping region of this IGraphics object is empty; otherwise, false.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisibleClipEmpty Property

IGraphics.IsVisibleClipEmpty Property
[image]

Gets a value indicating whether the visible clipping region of this IGraphics object is empty.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

bool IsVisibleClipEmpty { get; }

Visual Basic [image] Copy Code

ReadOnly Property IsVisibleClipEmpty As Boolean

Property Value

This property is true if the visible portion of the clipping region of this IGraphics object is empty; otherwise, false.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.PageScale Property

IGraphics.PageScale Property
[image]

Gets or sets the scaling between world units and page units for this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

float PageScale { get; set; }

Visual Basic [image] Copy Code

Property PageScale As Single

Property Value

This property specifies a value for the scaling between world units and page units for this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.PageUnit Property

IGraphics.PageUnit Property
[image]

Gets or sets the unit of measure used for page coordinates in this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

GraphicsUnit PageUnit { get; set; }

Visual Basic [image] Copy Code

Property PageUnit As GraphicsUnit

Property Value

This property specifies a member of the .NET GraphicsUnit enumeration.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.PixelOffsetMode Property

IGraphics.PixelOffsetMode Property
[image]

Gets or set a value specifying how pixels are offset during rendering of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

PixelOffsetMode PixelOffsetMode { get; set; }

Visual Basic [image] Copy Code

Property PixelOffsetMode As PixelOffsetMode

Property Value

This property specifies a member of the .NET PixelOffsetMode enumeration

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.RenderingOrigin Property

IGraphics.RenderingOrigin Property
[image]

Gets or sets the rendering origin of this IGraphics object for dithering and for hatch brushes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

Point RenderingOrigin { get; set; }

Visual Basic [image] Copy Code

Property RenderingOrigin As Point

Property Value

This property specifies a .NET Point structure that represents the dither origin for 8-bits-per-pixel and 16-bits-per-pixel dithering and is also used to set the origin for hatch brushes.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SmoothingMode Property

IGraphics.SmoothingMode Property
[image]

Gets or sets the rendering quality for this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

SmoothingMode SmoothingMode { get; set; }

Visual Basic [image] Copy Code

Property SmoothingMode As SmoothingMode

Property Value

This property specifies a member of the .NET SmoothingMode enumeration.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TextContrast Property

IGraphics.TextContrast Property
[image]

Gets or sets the gamma correction value for rendering text.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

int TextContrast { get; set; }

Visual Basic [image] Copy Code

Property TextContrast As Integer

Property Value

This property specifies a value of the gamma correction used for rendering antialiased and ClearType text.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TextRenderingHint Property

IGraphics.TextRenderingHint Property
[image]

Gets or sets the rendering mode for text associated with this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

TextRenderingHint TextRenderingHint { get; set; }

Visual Basic [image] Copy Code

Property TextRenderingHint As TextRenderingHint

Property Value

This property specifies a member of the .NET TextRenderingHint enumeration.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Transform Property

IGraphics.Transform Property
[image]

Gets or sets the world transformation for this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

Matrix Transform { get; set; }

Visual Basic [image] Copy Code

Property Transform As Matrix

Property Value

This property specifies a Matrix object that represents the world transformation for this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.VisibleClipBounds Property

IGraphics.VisibleClipBounds Property
[image]

Gets or sets the bounding rectangle of the visible clipping region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

RectangleF VisibleClipBounds { get; }

Visual Basic [image] Copy Code

ReadOnly Property VisibleClipBounds As RectangleF

Property Value

A .NET RectangleF structure that represents a bounding rectangle for the visible clipping region of this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.ImageAlign Enumeration

ImageAlign Enumeration
[image]

Specifies the position and alignment of a picture relative to its destination rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public enum ImageAlign

Visual Basic [image] Copy Code

Public Enum ImageAlign

Members

Member name | Description
BottomCenter | The image is centered horizontally and aligned to the bottom side.
BottomLeft | The image is aligned to the bottom left corner.
BottomRight | The image is aligned to the bottom right corner.
Center | The image is centered.
Fit | The image is resized to fit the size the destination rectangle.
MiddleLeft | The image is centered vertically and aligned to the left-hand side.
MiddleRight | The image is centered vertically and aligned to the right-hand side.
Stretch | The image is stretched to fill the destination rectangle.
Tile | The image is tiled across the destination rectangle.
TopCenter | The image is centered horizontally and aligned to the top side.
TopLeft | The image is aligned to the top left corner.
TopRight | The image is aligned o the top right corner.

See Also

MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Class

LinearGradientBrush Class
Remarks See Also
[image]

LinearGradientBrush objects represent brushes that fill the interiors of geometric shapes with a linear gradient.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class LinearGradientBrush : Brush, ISerializable

Visual Basic [image] Copy Code

Public Class LinearGradientBrush
Inherits Brush
Implements ISerializable

Remarks

The LinearGradientBrush class acts as a proxy for the .NET standard GDI+ System.Drawing.Drawing2D.LinearGradientBrush class.

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject
MindFusion.Drawing.Brush
MindFusion.Drawing.LinearGradientBrush

See Also

LinearGradientBrush Members
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Members

LinearGradientBrush Members
Constructors Properties Methods
[image]

LinearGradientBrush objects represent brushes that fill the interiors of geometric shapes with a linear gradient.

The following tables list the members exposed by the LinearGradientBrush type.

Public Constructors

Name | Description
LinearGradientBrush | Overloaded. Initializes a new instance of the LinearGradientBrush class.

Public Properties

Name | Description
Angle | Gets or sets the angle of the gradient's orientation line.
Blend | Gets or sets a .NET Blend object that specifies positions and factors that define a custom falloff for the gradient.
InterpolationColors | Gets or sets a .NET ColorBlend object that defines a multicolor linear gradient.
LinearColors | Gets or sets the starting and ending colors of the gradient.

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Creates an instance of the System.Drawing.Drawing2D.LinearGradientBrush class that can be used to paint in a GDI+ Graphics object.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "Gradient".

See Also

LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Constructor

LinearGradientBrush Constructor
[image]

Initializes a new instance of the LinearGradientBrush class.

Overload List

Name | Description
LinearGradientBrush (Color, Color) | Initializes a new instance of the LinearGradientBrush class with the specified start and end colors.
LinearGradientBrush (Color, Color, Single) | Initializes a new instance of the LinearGradientBrush class with the specified start and end colors and an orientation angle measured in degrees.
LinearGradientBrush (String) | Initializes a new instance of the LinearGradientBrush class given its string representation.

See Also

LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Constructor (Color, Color)

LinearGradientBrush Constructor (Color, Color)
See Also
[image]

Initializes a new instance of the LinearGradientBrush class with the specified start and end colors.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public LinearGradientBrush (
Color color1,
Color color2
)

Visual Basic [image] Copy Code

Public New ( _
color1 As Color, _
color2 As Color _
)

Parameters

color1

The first color of the gradient.

color2

The second color of the gradient.

See Also

LinearGradientBrush Constructor Overload List
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Constructor (Color, Color, Single)

LinearGradientBrush Constructor (Color, Color, Single)
See Also
[image]

Initializes a new instance of the LinearGradientBrush class with the specified start and end colors and an orientation angle measured in degrees.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public LinearGradientBrush (
Color color1,
Color color2,
float angle
)

Visual Basic [image] Copy Code

Public New ( _
color1 As Color, _
color2 As Color, _
angle As Single _
)

Parameters

color1

The first color of the gradient.

color2

The second color of the gradient.

angle

The gradient direction angle.

See Also

LinearGradientBrush Constructor Overload List
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Constructor (String)

LinearGradientBrush Constructor (String)
See Also
[image]

Initializes a new instance of the LinearGradientBrush class given its string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public LinearGradientBrush (
string representation
)

Visual Basic [image] Copy Code

Public New ( _
representation As String _
)

Parameters

representation
A string that represents the serialized bursh.

See Also

LinearGradientBrush Constructor Overload List
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Methods

LinearGradientBrush Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Creates an instance of the System.Drawing.Drawing2D.LinearGradientBrush class that can be used to paint in a GDI+ Graphics object.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "Gradient".

See Also

LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.Clone Method

LinearGradientBrush.Clone Method
[image]

Creates an exact copy of this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

An instance of the LinearGradientBrush class.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.CreateGdiBrush Method

LinearGradientBrush.CreateGdiBrush Method
[image]

Creates an instance of the System.Drawing.Drawing2D.LinearGradientBrush class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Brush CreateGdiBrush (
RectangleF rc
)

Visual Basic [image] Copy Code

Public Overrides Function CreateGdiBrush( _
rc As RectangleF _
) As Brush

Parameters

rc

The rectangle in which painting will be performed.

Return Value

An instance of the System.Drawing.Brush class corresponding to this brush.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.GetObjectData Method

LinearGradientBrush.GetObjectData Method
[image]

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void GetObjectData (
SerializationInfo info,
StreamingContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub GetObjectData( _
info As SerializationInfo, _
context As StreamingContext _
)

Parameters

info

The object that holds the serialized object data.

context

The contextual information about the source or destination.

Remarks

This method is not intended to be used directly from your code.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.ToString Method

LinearGradientBrush.ToString Method
[image]

Returns "Gradient".

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string representing this brush.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Properties

LinearGradientBrush Properties
[image]

Public Properties

Name | Description
Angle | Gets or sets the angle of the gradient's orientation line.
Blend | Gets or sets a .NET Blend object that specifies positions and factors that define a custom falloff for the gradient.
InterpolationColors | Gets or sets a .NET ColorBlend object that defines a multicolor linear gradient.
LinearColors | Gets or sets the starting and ending colors of the gradient.

See Also

LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.Angle Property

LinearGradientBrush.Angle Property
[image]

Gets or sets the angle of the gradient's orientation line.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public float Angle { get; set; }

Visual Basic [image] Copy Code

Public Property Angle As Single

Property Value

A float value that represents he angle, measured in degrees clockwise from the x-axis, of the gradient's orientation line.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.Blend Property

LinearGradientBrush.Blend Property
[image]

Gets or sets a .NET Blend object that specifies positions and factors that define a custom falloff for the gradient.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Blend Blend { get; set; }

Visual Basic [image] Copy Code

Public Property Blend As Blend

Property Value

An instance of the .NET Blend class that represents a custom falloff for the gradient.

Remarks

A Blend object contains corresponding arrays of blend factors and positions. The blend factors specify the percentages of the starting color and ending color to use at the corresponding position. The positions are specified as a percentage of distance along the gradient line.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.InterpolationColors Property

LinearGradientBrush.InterpolationColors Property
[image]

Gets or sets a .NET ColorBlend object that defines a multicolor linear gradient.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public ColorBlend InterpolationColors { get; set; }

Visual Basic [image] Copy Code

Public Property InterpolationColors As ColorBlend

Property Value

An instance of the .NET ColorBlend class that defines a multicolor linear gradient.

Remarks

A ColorBlend object contains corresponding arrays of colors and positions. The positions are values from 0 through 1 that specify the percentage of the distance along the gradient line where the corresponding color is located.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.LinearColors Property

LinearGradientBrush.LinearColors Property
[image]

Gets or sets the starting and ending colors of the gradient.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Color[] LinearColors { get; set; }

Visual Basic [image] Copy Code

Public Property LinearColors As Color()

Property Value

An array of two .NET Color objects that represents the starting and ending colors of the gradient.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush Class

PathGradientBrush Class
Remarks See Also
[image]

PathGradientBrush represents a brush that fills the interiors of geometric shapes with a gradient.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class PathGradientBrush : Brush, ISerializable

Visual Basic [image] Copy Code

Public Class PathGradientBrush
Inherits Brush
Implements ISerializable

Remarks

The PathGradientBrush class acts as a proxy for the .NET standard GDI+ System.Drawing.Drawing2D.PathGradientBrush class.

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject
MindFusion.Drawing.Brush
MindFusion.Drawing.PathGradientBrush

See Also

PathGradientBrush Members
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush Members

PathGradientBrush Members
Constructors Properties Methods
[image]

PathGradientBrush represents a brush that fills the interiors of geometric shapes with a gradient.

The following tables list the members exposed by the PathGradientBrush type.

Public Constructors

Name | Description
PathGradientBrush | Overloaded. Initializes a new instance of the PathGradientBrush class.

Public Properties

Name | Description
CenterColor | Gets or sets the color at the center of the gradient path.
CenterPoint | Gets or sets the center of the gradient path.
InterpolationColors | Gets or sets a ColorBlend object that defines a multiple color gradient.
SurroundingColor | Gets or sets the color drawn at the borders of the gradient path.

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Returns an instance of the System.Drawing.Drawing2D.PathGradientBrush class that can be used to paint in a GDI+ Graphics object.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "PathGradient".

See Also

PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush Constructor

PathGradientBrush Constructor
[image]

Initializes a new instance of the PathGradientBrush class.

Overload List

Name | Description
PathGradientBrush (Color, Color) | Initializes a new instance of the PathGradientBrush class with the specified center and surrounding colors.
PathGradientBrush (String) | Initializes a new instance of the PathGradientBrush class given its string representation.

See Also

PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush Constructor (Color, Color)

PathGradientBrush Constructor (Color, Color)
See Also
[image]

Initializes a new instance of the PathGradientBrush class with the specified center and surrounding colors.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public PathGradientBrush (
Color centerColor,
Color surroundingColor
)

Visual Basic [image] Copy Code

Public New ( _
centerColor As Color, _
surroundingColor As Color _
)

Parameters

centerColor

Specifies an initial center color.

surroundingColor

Specifies an initial surrounding color.

See Also

PathGradientBrush Constructor Overload List
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush Constructor (String)

PathGradientBrush Constructor (String)
See Also
[image]

Initializes a new instance of the PathGradientBrush class given its string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public PathGradientBrush (
string representation
)

Visual Basic [image] Copy Code

Public New ( _
representation As String _
)

Parameters

representation

A string that represents the serialized bursh.

See Also

PathGradientBrush Constructor Overload List
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush Methods

PathGradientBrush Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Returns an instance of the System.Drawing.Drawing2D.PathGradientBrush class that can be used to paint in a GDI+ Graphics object.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "PathGradient".

See Also

PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.Clone Method

PathGradientBrush.Clone Method
[image]

Creates an exact copy of this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

An instance of the PathGradientBrush class.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.CreateGdiBrush Method

PathGradientBrush.CreateGdiBrush Method
[image]

Returns an instance of the System.Drawing.Drawing2D.PathGradientBrush class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Brush CreateGdiBrush (
RectangleF rc
)

Visual Basic [image] Copy Code

Public Overrides Function CreateGdiBrush( _
rc As RectangleF _
) As Brush

Parameters

rc

The rectangle in which painting will be performed.

Return Value

An instance of the System.Drawing.Brush class corresponding to this brush.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.GetObjectData Method

PathGradientBrush.GetObjectData Method
[image]

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void GetObjectData (
SerializationInfo info,
StreamingContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub GetObjectData( _
info As SerializationInfo, _
context As StreamingContext _
)

Parameters

info

The object that holds the serialized object data.

context

The contextual information about the source or destination.

Remarks

This method is not intended to be used directly from your code.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.ToString Method

PathGradientBrush.ToString Method
[image]

Returns "PathGradient".

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string representing this brush.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush Properties

PathGradientBrush Properties
[image]

Public Properties

Name | Description
CenterColor | Gets or sets the color at the center of the gradient path.
CenterPoint | Gets or sets the center of the gradient path.
InterpolationColors | Gets or sets a ColorBlend object that defines a multiple color gradient.
SurroundingColor | Gets or sets the color drawn at the borders of the gradient path.

See Also

PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.CenterColor Property

PathGradientBrush.CenterColor Property
[image]

Gets or sets the color at the center of the gradient path.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Color CenterColor { get; set; }

Visual Basic [image] Copy Code

Public Property CenterColor As Color

Property Value

Instance of the .NET Color structure that represents the color at the center of the path gradient.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.CenterPoint Property

PathGradientBrush.CenterPoint Property
[image]

Gets or sets the center of the gradient path.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public PointF CenterPoint { get; set; }

Visual Basic [image] Copy Code

Public Property CenterPoint As PointF

Property Value

A .NET PointF structure that represents the center point of the path gradient.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.InterpolationColors Property

PathGradientBrush.InterpolationColors Property
[image]

Gets or sets a ColorBlend object that defines a multiple color gradient.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public ColorBlend InterpolationColors { get; set; }

Visual Basic [image] Copy Code

Public Property InterpolationColors As ColorBlend

Property Value

Instance of the .NET ColorBlend object that defines a multicolor linear gradient.

Remarks

A ColorBlend object contains corresponding arrays of colors and positions. The positions are values from 0 through 1 that specify the percentage of the distance along the gradient path where the corresponding color is located.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.SurroundingColor Property

PathGradientBrush.SurroundingColor Property
[image]

Gets or sets the color drawn at the borders of the gradient path.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Color SurroundingColor { get; set; }

Visual Basic [image] Copy Code

Public Property SurroundingColor As Color

Property Value

Instance of .NET Color structure that represents the color at the border of the path gradient.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Class

Pen Class
Remarks See Also
[image]

Pen instances are used to draw the outline of geometric shapes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class Pen : GraphicObject, ISerializable

Visual Basic [image] Copy Code

Public Class Pen
Inherits GraphicObject
Implements ISerializable

Remarks

The Pen class acts as a proxy for the .NET standard GDI+ System.Drawing.Pen class.

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject
MindFusion.Drawing.Pen

See Also

Pen Members
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Members

Pen Members
Constructors Properties Methods
[image]

Pen instances are used to draw the outline of geometric shapes.

The following tables list the members exposed by the Pen type.

Public Constructors

Name | Description
Pen | Overloaded. Initialize a new instance of the Pen class.

Public Properties

Name | Description
Brush | Gets or sets the Brush object that determines attributes of this pen.
Color | Gets or sets the color of this pen.
CompoundArray | Gets or sets an array values that specify a compound pen. A compound pen draws a compound line made up of parallel lines and spaces.
DashOffset | Gets or sets the distance from the start of a line to the beginning of a dash pattern.
DashPattern | Gets or sets an array of custom dashes and spaces.
DashStyle | Gets or sets the style used for dashed lines drawn with this pen.
LineJoin | Gets or sets the join style for the ends of two consecutive lines drawn with this pen.
MiterLimit | Gets or sets the limit of the thickness of the join on a mitered corner.
Width | Gets or sets the width of the pen.

Public Methods

Name | Description
Clone | Creates an exact copy of this pen.
CreateGdiPen | Overloaded. Returns an instance of the System.Drawing.Pen class corresponding to the current pen.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the pen.
Serialize | Serializes the specified pen to a string.
ToString | Returns the string representation of this Pen object.

See Also

Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Constructor

Pen Constructor
[image]

Initialize a new instance of the Pen class.

Overload List

Name | Description
Pen (Brush) | Initializes a new instance of the Pen class with a specified Brush object.
Pen (Brush, Single) | Initializes a new instance of the Pen class with the specified Brush object and the specified width.
Pen (Color) | Initializes a new instance of the Pen class with the specified color.
Pen (Color, Single) | Initializes a new instance of the Pen class with the specified color and width.
Pen (String) | Initializes a new instance of the Pen class given its string representation.

See Also

Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Constructor (Brush)

Pen Constructor (Brush)
See Also
[image]

Initializes a new instance of the Pen class with a specified Brush object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Pen (
Brush brush
)

Visual Basic [image] Copy Code

Public Sub Pen ( _
brush As Brush _
)

Parameters

brush
A Brush instance that determines the fill properties of the new pen.

See Also

Pen Constructor Overload List
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Constructor (Brush, Single)

Pen Constructor (Brush, Single)
See Also
[image]

Initializes a new instance of the Pen class with the specified Brush object and the specified width.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Pen (
Brush brush,
float width
)

Visual Basic [image] Copy Code

Public Sub Pen ( _
brush As Brush, _
width As Single _
)

Parameters

brush
A Brush instance that determines the fill properties of the new pen.
width
The width of the new pen.

See Also

Pen Constructor Overload List
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Constructor (Color)

Pen Constructor (Color)
See Also
[image]

Initializes a new instance of the Pen class with the specified color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Pen (
Color color
)

Visual Basic [image] Copy Code

Public New ( _
color As Color _
)

Parameters

color
A Color structure that specifies the color of the new pen.

See Also

Pen Constructor Overload List
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Constructor (Color, Single)

Pen Constructor (Color, Single)
See Also
[image]

Initializes a new instance of the Pen class with the specified color and width.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Pen (
Color color,
float width
)

Visual Basic [image] Copy Code

Public New ( _
color As Color, _
width As Single _
)

Parameters

color
A Color structure that specifies the color of the new pen.
width
The width of the new pen.

See Also

Pen Constructor Overload List
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Constructor (String)

Pen Constructor (String)
See Also
[image]

Initializes a new instance of the Pen class given its string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Pen (
string representation
)

Visual Basic [image] Copy Code

Public New ( _
representation As String _
)

Parameters

representation
A string that represents the serialized pen.

See Also

Pen Constructor Overload List
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Methods

Pen Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this pen.
CreateGdiPen | Overloaded. Returns an instance of the System.Drawing.Pen class corresponding to the current pen.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the pen.
Serialize | Serializes the specified pen to a string.
ToString | Returns the string representation of this Pen object.

See Also

Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.Clone Method

Pen.Clone Method
[image]

Creates an exact copy of this pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

An instance of the Pen class.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.CreateGdiPen Method

Pen.CreateGdiPen Method
[image]

Returns an instance of the System.Drawing.Pen class corresponding to the current pen.

Overload List

Name | Description
Pen.CreateGdiPen () | Returns an instance of the System.Drawing.Pen class that can be used to paint in a GDI+ Graphics object.
Pen.CreateGdiPen (RectangleF) | Returns an instance of the System.Drawing.Pen class that can be used to paint in a GDI+ Graphics object.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.CreateGdiPen Method ()

Pen.CreateGdiPen Method ()
See Also
[image]

Returns an instance of the System.Drawing.Pen class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Pen CreateGdiPen ()

Visual Basic [image] Copy Code

Public Function CreateGdiPen () As Pen

Return Value

A System.Drawing.Pen instance corresponding to this pen.

See Also

CreateGdiPen Method Overload List
Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.CreateGdiPen Method (RectangleF)

Pen.CreateGdiPen Method (RectangleF)
See Also
[image]

Returns an instance of the System.Drawing.Pen class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Pen CreateGdiPen (
RectangleF rc
)

Visual Basic [image] Copy Code

Public Function CreateGdiPen( _
rc As RectangleF _
) As Pen

Parameters

rc

The rectangle in which painting will be performed.

Return Value

A System.Drawing.Pen instance corresponding to this pen.

See Also

CreateGdiPen Method Overload List
Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.GetObjectData Method

Pen.GetObjectData Method
[image]

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void GetObjectData (
SerializationInfo info,
StreamingContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub GetObjectData( _
info As SerializationInfo, _
context As StreamingContext _
)

Parameters

info

The object that holds the serialized object data.

context

The contextual information about the source or destination.

Remarks

This method is not intended to be used directly from your code.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.Serialize Method

Pen.Serialize Method
[image]

Serializes the specified pen to a string.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static string Serialize (
Pen pen
)

Visual Basic [image] Copy Code

Public Shared Function Serialize ( _
pen As Pen _
) As String

Parameters

pen

The Pen object to serialize.

Return Value

A string that represents the specified pen.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.ToString Method

Pen.ToString Method
[image]

Returns the string representation of this Pen object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string representing this pen.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Properties

Pen Properties
[image]

Public Properties

Name | Description
Brush | Gets or sets the Brush object that determines attributes of this pen.
Color | Gets or sets the color of this pen.
CompoundArray | Gets or sets an array values that specify a compound pen. A compound pen draws a compound line made up of parallel lines and spaces.
DashOffset | Gets or sets the distance from the start of a line to the beginning of a dash pattern.
DashPattern | Gets or sets an array of custom dashes and spaces.
DashStyle | Gets or sets the style used for dashed lines drawn with this pen.
LineJoin | Gets or sets the join style for the ends of two consecutive lines drawn with this pen.
MiterLimit | Gets or sets the limit of the thickness of the join on a mitered corner.
Width | Gets or sets the width of the pen.

See Also

Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.Brush Property

Pen.Brush Property
[image]

Gets or sets the Brush object that determines attributes of this pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

An instance of the Brush class that determines attributes of this pen.

Remarks

Setting this property causes the pen to draw filled lines and curves. It overrides the Color property of the pen.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.Color Property

Pen.Color Property
[image]

Gets or sets the color of this pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Color Color { get; set; }

Visual Basic [image] Copy Code

Public Property Color As Color

Property Value

An instance of the .NET Color structure that represents the color of this pen.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.CompoundArray Property

Pen.CompoundArray Property
[image]

Gets or sets an array values that specify a compound pen. A compound pen draws a compound line made up of parallel lines and spaces.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public float[] CompoundArray { get; set; }

Visual Basic [image] Copy Code

Public Property CompoundArray As Single()

Property Value

An array of real numbers that specifies the compound array. The elements in the array must be in increasing order, not less than 0, and not greater than 1.

Remarks

A compound line is made up of alternating parallel lines and spaces of varying widths. The values in the array specify the starting points of each component of the compound line relative to the pen's width. The first value in the array specifies where the first component (a line) begins as a fraction of the distance across the width of the pen. The second value in the array specifies the beginning of the next component (a space) as a fraction of the distance across the width of the pen. The final value in the array specifies where the last component ends.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.DashOffset Property

Pen.DashOffset Property
[image]

Gets or sets the distance from the start of a line to the beginning of a dash pattern.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public float DashOffset { get; set; }

Visual Basic [image] Copy Code

Public Property DashOffset As Single

Property Value

A float value representing the distance from the start of a line to the beginning of a dash pattern.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.DashPattern Property

Pen.DashPattern Property
[image]

Gets or sets an array of custom dashes and spaces.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public float[] DashPattern { get; set; }

Visual Basic [image] Copy Code

Public Property DashPattern As Single()

Property Value

An array of real numbers that specify the lengths of alternating dashes and spaces in dashed lines.

Remarks

The elements in the array set the length of each dash and space in the dash pattern. The first element sets the length of a dash, the second element sets the length of a space, the third element sets the length of a dash, and so on.The length of each dash and space in the dash pattern is the product of the element value in the array and the width of the pen.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.DashStyle Property

Pen.DashStyle Property
[image]

Gets or sets the style used for dashed lines drawn with this pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public DashStyle DashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property DashStyle As DashStyle

Property Value

A member of the .NET DashStyle enumeration that represents the style used for dashed lines.

Remarks

A value of DashStyle.Custom for this property specifies that a custom pattern of dashes and spaces, defined by the DashPattern property, make up lines drawn with this pen.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.LineJoin Property

Pen.LineJoin Property
[image]

Gets or sets the join style for the ends of two consecutive lines drawn with this pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public LineJoin LineJoin { get; set; }

Visual Basic [image] Copy Code

Public Property LineJoin As LineJoin

Property Value

A member of the .NET LineJoin enumeration that represents the join style for the ends of two consecutive lines.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.MiterLimit Property

Pen.MiterLimit Property
[image]

Gets or sets the limit of the thickness of the join on a mitered corner.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public float MiterLimit { get; set; }

Visual Basic [image] Copy Code

Public Property MiterLimit As Single

Property Value

A floag value representing the limit of the thickness of the join on a mitered corner. The default is 10.0f.

Remarks

The miter length is the distance from the intersection of the line walls on the inside of the join to the intersection of the line walls outside of the join. The miter length can be large when the angle between two lines is small. The miter limit is the maximum allowed ratio of miter length to stroke width. If the miter length of the join of the intersection exceeds the limit of the join, then the join will be beveled to keep it within the limit of the join of the intersection.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.Width Property

Pen.Width Property
[image]

Gets or sets the width of the pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public float Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Single

Property Value

A float value indicating the width of the pen.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection Class

PenCollection Class
[image]

A collection of MindFusion.Drawing.Pen objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class PenCollection : CollectionBase, ICloneable

Visual Basic [image] Copy Code

Public Class PenCollection
Inherits CollectionBase
Implements ICloneable

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Drawing.PenCollection

See Also

PenCollection Members
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection Members

PenCollection Members
Constructors Properties Methods
[image]

A collection of MindFusion.Drawing.Pen objects.

The following tables list the members exposed by the PenCollection type.

Public Constructors

Name | Description
PenCollection | Overloaded. Initializes a new instance of the PenCollection class.

Public Properties

Name | Description
Item | Gets or sets the Pen, located at the specified position.

Public Methods

Name | Description
Add | Adds the specified Pen to the collection.
Clone | Returns a shallow copy of this PenCollection object.
Contains | Checks whether the specified Pen is contained in the collection.
IndexOf | Returns the index of the first occurrence of the specified Pen.
Insert | Inserts the specified Pen at the specified position within the collection.
Remove | Removes the first occurrence of the specified Pen from the collection.
RemoveAt | Removes the Pen at the specified index.

See Also

PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection Constructor

PenCollection Constructor
[image]

Initializes a new instance of the PenCollection class.

Overload List

Name | Description
PenCollection () | Initializes a new empty instance of the PenCollection class.
PenCollection (String) | Initializes a new instance of the PenCollection class using the specified string representation.

See Also

PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection Constructor ()

PenCollection Constructor ()
See Also
[image]

Initializes a new empty instance of the PenCollection class.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public PenCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection Constructor (String)

PenCollection Constructor (String)
See Also
[image]

Initializes a new instance of the PenCollection class using the specified string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public PenCollection (
string representation
)

Visual Basic [image] Copy Code

Public New ( _
representation As String _
)

Parameters

representation
The string that represents serialized contents of a PenCollection.

See Also

PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection Methods

PenCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified Pen to the collection.
Clone | Returns a shallow copy of this PenCollection object.
Contains | Checks whether the specified Pen is contained in the collection.
IndexOf | Returns the index of the first occurrence of the specified Pen.
Insert | Inserts the specified Pen at the specified position within the collection.
Remove | Removes the first occurrence of the specified Pen from the collection.
RemoveAt | Removes the Pen at the specified index.

See Also

PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection.Add Method

PenCollection.Add Method
[image]

Adds the specified Pen to the collection.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public int Add (
Pen value
)

Visual Basic [image] Copy Code

Public Function Add ( _
value As Pen _
) As Integer

Parameters

value
The Pen object to add to the end of the collection.

Return Value

The zero-based index within the collection of the newly added pen.

See Also

PenCollection Members
PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection.Clone Method

PenCollection.Clone Method
[image]

Returns a shallow copy of this PenCollection object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual Object Clone ()

Visual Basic [image] Copy Code

Public Overridable Function Clone () As Object

Return Value

An instance of the PenCollection class.

See Also

PenCollection Members
PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection.Contains Method

PenCollection.Contains Method
[image]

Checks whether the specified Pen is contained in the collection.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public bool Contains (
Pen value
)

Visual Basic [image] Copy Code

Public Function Contains ( _
value As Pen _
) As Boolean

Parameters

value
The Pen object to search for in the collection.

Return Value

true if the specified pen is contained in the collection; otherwise, false.

See Also

PenCollection Members
PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection.IndexOf Method

PenCollection.IndexOf Method
[image]

Returns the index of the first occurrence of the specified Pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public int IndexOf (
Pen value
)

Visual Basic [image] Copy Code

Public Function IndexOf ( _
value As Pen _
) As Integer

Parameters

value
The Pen object to locate in the collection.

Return Value

The zero-based index of the first occurrence of value within the entire collection, if found; otherwise, -1.

See Also

PenCollection Members
PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection.Insert Method

PenCollection.Insert Method
[image]

Inserts the specified Pen at the specified position within the collection.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void Insert (
int index,
Pen value
)

Visual Basic [image] Copy Code

Public Sub Insert ( _
index As Integer, _
value As Pen _
)

Parameters

index
The zero-based index at which to insert the pen.
value
The Pen object to add to the collection.

See Also

PenCollection Members
PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection.Remove Method

PenCollection.Remove Method
[image]

Removes the first occurrence of the specified Pen from the collection.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void Remove (
Pen value
)

Visual Basic [image] Copy Code

Public Sub Remove ( _
value As Pen _
)

Parameters

value
The Pen object to remove from the collection.

See Also

PenCollection Members
PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection.RemoveAt Method

PenCollection.RemoveAt Method
[image]

Removes the Pen at the specified index.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public new void RemoveAt (
int index
)

Visual Basic [image] Copy Code

Public Shadows Sub RemoveAt( _
index As Integer _
)

Parameters

index
The index at which the Pen object should be removed.

See Also

PenCollection Members
PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection Properties

PenCollection Properties
[image]

Public Properties

Name | Description
Item | Gets or sets the Pen, located at the specified position.

See Also

PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection.Item Property

PenCollection.Item Property
[image]

Gets or sets the Pen, located at the specified position.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Pen Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Property Item ( _
index As Integer _
) As Pen

Parameters

index
The zero-based index of the element to get or set.

Property Value

The Pen element at the specified index.

Remarks

This property provides the ability to access a specific Pen element in the PenCollection.

See Also

PenCollection Members
PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Class

SolidBrush Class
Remarks See Also
[image]

SolidBrush objects represent brushes of a single color that are used to fill the interiors of geometric shapes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class SolidBrush : Brush, ISerializable

Visual Basic [image] Copy Code

Public Class SolidBrush
Inherits Brush
Implements ISerializable

Remarks

The SolidBrush class acts as a proxy for the .NET standard GDI+ System.Drawing.SolidBrush class.

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject
MindFusion.Drawing.Brush
MindFusion.Drawing.SolidBrush

See Also

SolidBrush Members
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Members

SolidBrush Members
Constructors Properties Methods
[image]

SolidBrush objects represent brushes of a single color that are used to fill the interiors of geometric shapes.

The following tables list the members exposed by the SolidBrush type.

Public Constructors

Name | Description
SolidBrush | Overloaded. Initializes a new instance of the SolidBrush class.

Public Properties

Name | Description
Color | Gets or sets the color of this brush.

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Returns an instance of the System.Drawing.SolidBrush class that can be used to paint in a GDI+ Graphics object.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "Solid".

See Also

SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Constructor

SolidBrush Constructor
[image]

Initializes a new instance of the SolidBrush class.

Overload List

Name | Description
SolidBrush (Color) | Initializes a new instance of the SolidBrush class with the specified color.
SolidBrush (String) | Initializes a new instance of the SolidBrush class given its string representation.

See Also

SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Constructor (Color)

SolidBrush Constructor (Color)
See Also
[image]

Initializes a new instance of the SolidBrush class with the specified color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public SolidBrush (
Color color
)

Visual Basic [image] Copy Code

Public New ( _
color As Color _
)

Parameters

color
A Color object that specifies the color of the new brush.

See Also

SolidBrush Constructor Overload List
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Constructor (String)

SolidBrush Constructor (String)
See Also
[image]

Initializes a new instance of the SolidBrush class given its string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public SolidBrush (
string representation
)

Visual Basic [image] Copy Code

Public New ( _
representation As String _
)

Parameters

representation
A string that represents the serialized bursh.

See Also

SolidBrush Constructor Overload List
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Methods

SolidBrush Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Returns an instance of the System.Drawing.SolidBrush class that can be used to paint in a GDI+ Graphics object.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "Solid".

See Also

SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush.Clone Method

SolidBrush.Clone Method
[image]

Creates an exact copy of this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

An instance of the SolidBrush class.

See Also

SolidBrush Members
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush.CreateGdiBrush Method

SolidBrush.CreateGdiBrush Method
[image]

Returns an instance of the System.Drawing.SolidBrush class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Brush CreateGdiBrush (
RectangleF rc
)

Visual Basic [image] Copy Code

Public Overrides Function CreateGdiBrush( _
rc As RectangleF _
) As Brush

Parameters

rc

The rectangle in which painting will be performed.

Return Value

An instance of the System.Drawing.Brush class corresponding to this brush.

See Also

SolidBrush Members
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush.GetObjectData Method

SolidBrush.GetObjectData Method
[image]

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void GetObjectData (
SerializationInfo info,
StreamingContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub GetObjectData( _
info As SerializationInfo, _
context As StreamingContext _
)

Parameters

info

The object that holds the serialized object data.

context

The contextual information about the source or destination.

Remarks

This method is not intended to be used directly from your code.

See Also

SolidBrush Members
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush.ToString Method

SolidBrush.ToString Method
[image]

Returns "Solid".

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string representing this brush.

See Also

SolidBrush Members
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Properties

SolidBrush Properties
[image]

Public Properties

Name | Description
Color | Gets or sets the color of this brush.

See Also

SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush.Color Property

SolidBrush.Color Property
[image]

Gets or sets the color of this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Color Color { get; set; }

Visual Basic [image] Copy Code

Public Property Color As Color

Property Value

Instance of the .NET Color structure that represents the color of this brush.

See Also

SolidBrush Members
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush Class

TextureBrush Class
Remarks See Also
[image]

TextureBrush objects represent brushes that use images to fill the interiors of geometric shapes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class TextureBrush : Brush, ISerializable

Visual Basic [image] Copy Code

Public Class TextureBrush
Inherits Brush
Implements ISerializable

Remarks

The TextureBrush class acts as a proxy for the .NET standard GDI+ System.Drawing.TextureBrush class.

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject
MindFusion.Drawing.Brush
MindFusion.Drawing.TextureBrush

See Also

TextureBrush Members
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush Members

TextureBrush Members
Constructors Properties Methods
[image]

TextureBrush objects represent brushes that use images to fill the interiors of geometric shapes.

The following tables list the members exposed by the TextureBrush type.

Public Constructors

Name | Description
TextureBrush | Overloaded. Initializes a new instance of the TextureBrush class.

Public Properties

Name | Description
Image | Gets or sets the Image instance associated with this brush.
ScaleFactor | Gets or sets the scale factor applied to all texture brushes.
WrapMode | Gets or sets a value that indicates the wrap mode for this brush.

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Overloaded. Returns an instance of a System.Drawing.Brush-derived class corresponding to the current brush.
Equals | Determines whether two TextureBrush instances are equal.
GetHashCode | Returns the hash code for this brush instance.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "Texture".

See Also

TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush Constructor

TextureBrush Constructor
[image]

Initializes a new instance of the TextureBrush class.

Overload List

Name | Description
TextureBrush (Image) | Initializes a new instance of the TextureBrush class with the specified image.
TextureBrush (Image, WrapMode) | Initializes a new instance of the TextureBrush class with the specified image and wrap mode.
TextureBrush (String) | Initializes a new instance of TextureBrush class given its string representation.

See Also

TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush Constructor (Image)

TextureBrush Constructor (Image)
See Also
[image]

Initializes a new instance of the TextureBrush class with the specified image.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public TextureBrush (
Image image
)

Visual Basic [image] Copy Code

Public New ( _
image As Image _
)

Parameters

image
The Image object with which this brush fills interiors.

See Also

TextureBrush Constructor Overload List
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush Constructor (Image, WrapMode)

TextureBrush Constructor (Image, WrapMode)
See Also
[image]

Initializes a new instance of the TextureBrush class with the specified image and wrap mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public TextureBrush (
Image image,
WrapMode wrapMode
)

Visual Basic [image] Copy Code

Public New ( _
image As Image, _
wrapMode As WrapMode _
)

Parameters

image

Sets the texture image.

wrapMode

Sets the texture wrap mode.

See Also

TextureBrush Constructor Overload List
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush Constructor (String)

TextureBrush Constructor (String)
See Also
[image]

Initializes a new instance of TextureBrush class given its string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public TextureBrush (
string representation
)

Visual Basic [image] Copy Code

Public New ( _
representation As String _
)

Parameters

representation
A string that represents the serialized bursh.

See Also

TextureBrush Constructor Overload List
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush Methods

TextureBrush Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Overloaded. Returns an instance of a System.Drawing.Brush-derived class corresponding to the current brush.
Equals | Determines whether two TextureBrush instances are equal.
GetHashCode | Returns the hash code for this brush instance.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "Texture".

See Also

TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.Clone Method

TextureBrush.Clone Method
[image]

Creates an exact copy of this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

An instance of the TextureBrush class.

See Also

TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.CreateGdiBrush Method

TextureBrush.CreateGdiBrush Method
[image]

Returns an instance of a System.Drawing.Brush-derived class corresponding to the current brush.

Overload List

Name | Description
TextureBrush.CreateGdiBrush (RectangleF) | Creates an instance of the System.Drawing.TextureBrush class that can be used to paint in a GDI+ Graphics object.
TextureBrush.CreateGdiBrush (RectangleF, Single, Single) | Creates an instance of the System.Drawing.TextureBrush class that can be used to paint in a GDI+ Graphics object.

See Also

TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.CreateGdiBrush Method (RectangleF)

TextureBrush.CreateGdiBrush Method (RectangleF)
See Also
[image]

Creates an instance of the System.Drawing.TextureBrush class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Brush CreateGdiBrush (
RectangleF rc
)

Visual Basic [image] Copy Code

Public Overrides Function CreateGdiBrush( _
rc As RectangleF _
) As Brush

Parameters

rc

The rectangle in which painting will be performed.

Return Value

An instance of the System.Drawing.Brush class corresponding to this brush.

See Also

CreateGdiBrush Method Overload List
TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.CreateGdiBrush Method (RectangleF, Single, Single)

TextureBrush.CreateGdiBrush Method (RectangleF, Single, Single)
See Also
[image]

Creates an instance of the System.Drawing.TextureBrush class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Brush CreateGdiBrush (
RectangleF rc,
float dx,
float dy
)

Visual Basic [image] Copy Code

Public Overrides Function CreateGdiBrush( _
rc As RectangleF, _
dx As Single, _
dy As Single _
) As Brush

Parameters

rc

The rectangle in which painting will be performed.

dx

Specifies a horizontal offset to apply to this brush.

dy

Specifies a vertical offset to apply to this brush.

Return Value

An instance of the System.Drawing.Brush class corresponding to this brush.

See Also

CreateGdiBrush Method Overload List
TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.Equals Method

TextureBrush.Equals Method
[image]

Determines whether two TextureBrush instances are equal.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj
The object to compare to this one.

Return Value

true is the brushes are equal; otherwise, false.

See Also

TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.GetHashCode Method

TextureBrush.GetHashCode Method
[image]

Returns the hash code for this brush instance.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

A hash code for this object.

See Also

TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.GetObjectData Method

TextureBrush.GetObjectData Method
[image]

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void GetObjectData (
SerializationInfo info,
StreamingContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub GetObjectData( _
info As SerializationInfo, _
context As StreamingContext _
)

Parameters

info

The object that holds the serialized object data.

context

The contextual information about the source or destination.

Remarks

This method is not intended to be used directly from your code.

See Also

TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.ToString Method

TextureBrush.ToString Method
[image]

Returns "Texture".

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string representing this brush.

See Also

TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush Properties

TextureBrush Properties
[image]

Public Properties

Name | Description
Image | Gets or sets the Image instance associated with this brush.
ScaleFactor | Gets or sets the scale factor applied to all texture brushes.
WrapMode | Gets or sets a value that indicates the wrap mode for this brush.

See Also

TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.Image Property

TextureBrush.Image Property
[image]

Gets or sets the Image instance associated with this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Image Image { get; set; }

Visual Basic [image] Copy Code

Public Property Image As Image

Property Value

Instance of the .NET Image class that represents the image with which this brush fills shapes.

See Also

TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.ScaleFactor Property

TextureBrush.ScaleFactor Property
[image]

Gets or sets the scale factor applied to all texture brushes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static float ScaleFactor { get; set; }

Visual Basic [image] Copy Code

Public Shared Property ScaleFactor As Single

Property Value

See Also

TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.WrapMode Property

TextureBrush.WrapMode Property
[image]

Gets or sets a value that indicates the wrap mode for this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public WrapMode WrapMode { get; set; }

Visual Basic [image] Copy Code

Public Property WrapMode As WrapMode

Property Value

A member of the .NET WrapMode enumeration that specifies how fills drawn with this brush are tiled.

See Also

TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Layout Namespace

MindFusion.Layout Namespace
Classes Interfaces Structures Delegates Enumerations

The types in this namespace support the MvcDiagram layout functionality and are not supposed to be used directly.

Classes

Class | Description
AnnealLayoutStatistics | Contains the accumulated costs for a graph configuration produced by AnnealLayout.
ConnectorRules | Represents a set of rules that are applied according to the logic identifiers of links.
FlowLayoutKeys | Defines keys that can be used to define FlowLayout rules.
FlowLayoutRules | A class representing a set of rules that define the behavior of the FlowLayout class.
LayoutRules | Summary description for LayoutRules.
NodeRules | Represents a set of rules that are applied according to the logic identifiers of node pairs.
Pair | Represents a coupling between two arbitrary objects.
SimpleKeys | Defines keys that can be used to define FlowLayout rules.
SimpleLinkLogic | Contains link identifiers for the predefined SimpleRules set of rules.
SimpleNodeLogic | Contains node identifiers for the predefined SimpleRules set of rules.
SimpleRules | Class of simple rules applicable to the Flowlayout algorithm.

Interfaces

Interface | Description
RoutingOptions | Allows customization of various aspects of the link routing algorithm.

Structures

Structure | Description
Point3D | Represents the coordinates of a point in a 3-dimensional space.

Delegates

Delegate | Description
RouteHeuristics | The link routing algorithm uses a heuristic function of this type in its prediction steps.

Enumerations

Enumeration | Description
AssistantType | Indicates the type of an assistant node in a tree.
BaseLayout | Specifies how OrthogonalRouter should arrange nodes.
FlowLayoutTraits | Values used as keys in FlowLayout rules.
HierarchicalLayoutTraits | Indicates item traits specific to hierarchical layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.
LayeredLayoutTraits | Indicates item traits specific to layered layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.
OrderDirection | Values controlling the direction of link segments in FlowLayout rules.
PartitionMethod | Identifies graph partitioning methods supported by CompositeLayout.
PreferredRules | Specifies which set of rules to use.
SimpleOrientation | Specifies the preferred orientation for the main connector type in FlowLayout.
SpringLayoutMethod | Specifies what energy model SpringLayout should use for the simulation.
SpringLayoutTraits | Indicates item traits specific to SpringLayout. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.
SwimlaneLayoutTraits | Indicates item traits specific to swimlane layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.
TreeLayoutTraits | Indicates item traits specific to tree layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.
TreeMapLayoutTraits | Indicates item traits specific to tree map layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.


MindFusion.Layout.AnnealLayoutStatistics Class

AnnealLayoutStatistics Class
[image]

Contains the accumulated costs for a graph configuration produced by AnnealLayout.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class AnnealLayoutStatistics

Visual Basic [image] Copy Code

Public Class AnnealLayoutStatistics

Inheritance Hierarchy

System.Object
MindFusion.Layout.AnnealLayoutStatistics

See Also

AnnealLayoutStatistics Members
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics Members

AnnealLayoutStatistics Members
Constructors Properties Methods
[image]

Contains the accumulated costs for a graph configuration produced by AnnealLayout.

The following tables list the members exposed by the AnnealLayoutStatistics type.

Public Constructors

Name | Description
AnnealLayoutStatistics |

Public Properties

Name | Description
BoundaryCost | The total distance-to-boundary cost of a graph configuration.
DistributionCost | The total distribution cost of a graph configuration.
EdgeCrossingsCost | The total edge crossings cost of a graph configuration.
EdgeCrossingsFound | The number of edge crossings in the graph configuration.
EdgeLengthsCost | The total edge lengths cost of a graph configuration.
NodeEdgeDistance | The total node-to-edge-distance cost of a graph configuration.

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics Constructor

AnnealLayoutStatistics Constructor
[image]

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnnealLayoutStatistics ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics Methods

AnnealLayoutStatistics Methods
[image]

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.ToString Method

AnnealLayoutStatistics.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics Properties

AnnealLayoutStatistics Properties
[image]

Public Properties

Name | Description
BoundaryCost | The total distance-to-boundary cost of a graph configuration.
DistributionCost | The total distribution cost of a graph configuration.
EdgeCrossingsCost | The total edge crossings cost of a graph configuration.
EdgeCrossingsFound | The number of edge crossings in the graph configuration.
EdgeLengthsCost | The total edge lengths cost of a graph configuration.
NodeEdgeDistance | The total node-to-edge-distance cost of a graph configuration.

See Also

AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.BoundaryCost Property

AnnealLayoutStatistics.BoundaryCost Property
[image]

The total distance-to-boundary cost of a graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double BoundaryCost { get; set; }

Visual Basic [image] Copy Code

Public Property BoundaryCost As Double

Property Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.DistributionCost Property

AnnealLayoutStatistics.DistributionCost Property
[image]

The total distribution cost of a graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double DistributionCost { get; set; }

Visual Basic [image] Copy Code

Public Property DistributionCost As Double

Property Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.EdgeCrossingsCost Property

AnnealLayoutStatistics.EdgeCrossingsCost Property
[image]

The total edge crossings cost of a graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double EdgeCrossingsCost { get; set; }

Visual Basic [image] Copy Code

Public Property EdgeCrossingsCost As Double

Property Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.EdgeCrossingsFound Property

AnnealLayoutStatistics.EdgeCrossingsFound Property
[image]

The number of edge crossings in the graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int EdgeCrossingsFound { get; set; }

Visual Basic [image] Copy Code

Public Property EdgeCrossingsFound As Integer

Property Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.EdgeLengthsCost Property

AnnealLayoutStatistics.EdgeLengthsCost Property
[image]

The total edge lengths cost of a graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double EdgeLengthsCost { get; set; }

Visual Basic [image] Copy Code

Public Property EdgeLengthsCost As Double

Property Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.NodeEdgeDistance Property

AnnealLayoutStatistics.NodeEdgeDistance Property
[image]

The total node-to-edge-distance cost of a graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeEdgeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeEdgeDistance As Double

Property Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AssistantType Enumeration

AssistantType Enumeration
[image]

Indicates the type of an assistant node in a tree.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum AssistantType

Visual Basic [image] Copy Code

Public Enum AssistantType

Members

Member name | Description
None | The node is not an assistant.
Normal | The node is an assistant and its relative position is determined automatically by the layout.
Left | The node is an assistant and it is always positioned to the left of its parent.
Right | The node is an assistant and it is always positioned to the right of its parent.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.BaseLayout Enumeration

BaseLayout Enumeration
[image]

Specifies how OrthogonalRouter should arrange nodes.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum BaseLayout

Visual Basic [image] Copy Code

Public Enum BaseLayout

Members

Member name | Description
Layered | Use LayeredLayout to arrange nodes.
Grid | Use GridLayout to arrange nodes.
Custom | Use the current node configuration.
Cascading | Use TreeLayout to arrange nodes.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.ConnectorRules Class

ConnectorRules Class
[image]

Represents a set of rules that are applied according to the logic identifiers of links.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ConnectorRules : LayoutRules

Visual Basic [image] Copy Code

Public Class ConnectorRules
Inherits LayoutRules

Inheritance Hierarchy

System.Object
MindFusion.Layout.LayoutRules
MindFusion.Layout.ConnectorRules

See Also

ConnectorRules Members
MindFusion.Layout Namespace


MindFusion.Layout.ConnectorRules Members

ConnectorRules Members
Properties Methods
[image]

Represents a set of rules that are applied according to the logic identifiers of links.

The following tables list the members exposed by the ConnectorRules type.

Public Properties

Name | Description
DownOriented | Specifies a set of link identifiers for which nodes connected through such links will be placed downwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.
HorizontalBendOrientation | Specifies whether links should start with a horizontal segment.
LeftOriented | Specifies a set of link identifiers for which nodes connected through such links will be placed leftwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.
RightOriented | Specifies a set of link identifiers for which nodes connected through such links will be placed rightwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.
UpOriented | Specifies a set of link identifiers for which nodes connected via such links will be placed upwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.

Public Methods

Name | Description
AddLayoutRule | Overloaded. (Inherited from LayoutRules.)
BuildKey | Builds a key - object for the new rule, as a pair of two objects: obj1 and obj2. (Inherited from LayoutRules.)
GetLayoutRule | If there is rule with key - Key initializes - Value otherwise fails; (Inherited from LayoutRules.)
ValidateRules | Checks if there is a rule for each key in KeyList (Inherited from LayoutRules.)

See Also

ConnectorRules Class
MindFusion.Layout Namespace


MindFusion.Layout.ConnectorRules Properties

ConnectorRules Properties
[image]

Public Properties

Name | Description
DownOriented | Specifies a set of link identifiers for which nodes connected through such links will be placed downwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.
HorizontalBendOrientation | Specifies whether links should start with a horizontal segment.
LeftOriented | Specifies a set of link identifiers for which nodes connected through such links will be placed leftwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.
RightOriented | Specifies a set of link identifiers for which nodes connected through such links will be placed rightwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.
UpOriented | Specifies a set of link identifiers for which nodes connected via such links will be placed upwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.

See Also

ConnectorRules Class
MindFusion.Layout Namespace


MindFusion.Layout.ConnectorRules.DownOriented Property

ConnectorRules.DownOriented Property
[image]

Specifies a set of link identifiers for which nodes connected through such links will be placed downwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object DownOriented { get; set; }

Visual Basic [image] Copy Code

Public Property DownOriented As Object

Property Value

See Also

ConnectorRules Members
ConnectorRules Class
MindFusion.Layout Namespace


MindFusion.Layout.ConnectorRules.HorizontalBendOrientation Property

ConnectorRules.HorizontalBendOrientation Property
[image]

Specifies whether links should start with a horizontal segment.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool HorizontalBendOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalBendOrientation As Boolean

Property Value

See Also

ConnectorRules Members
ConnectorRules Class
MindFusion.Layout Namespace


MindFusion.Layout.ConnectorRules.LeftOriented Property

ConnectorRules.LeftOriented Property
[image]

Specifies a set of link identifiers for which nodes connected through such links will be placed leftwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object LeftOriented { get; set; }

Visual Basic [image] Copy Code

Public Property LeftOriented As Object

Property Value

See Also

ConnectorRules Members
ConnectorRules Class
MindFusion.Layout Namespace


MindFusion.Layout.ConnectorRules.RightOriented Property

ConnectorRules.RightOriented Property
[image]

Specifies a set of link identifiers for which nodes connected through such links will be placed rightwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object RightOriented { get; set; }

Visual Basic [image] Copy Code

Public Property RightOriented As Object

Property Value

See Also

ConnectorRules Members
ConnectorRules Class
MindFusion.Layout Namespace


MindFusion.Layout.ConnectorRules.UpOriented Property

ConnectorRules.UpOriented Property
[image]

Specifies a set of link identifiers for which nodes connected via such links will be placed upwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object UpOriented { get; set; }

Visual Basic [image] Copy Code

Public Property UpOriented As Object

Property Value

See Also

ConnectorRules Members
ConnectorRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutKeys Class

FlowLayoutKeys Class
[image]

Defines keys that can be used to define FlowLayout rules.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class FlowLayoutKeys : SimpleKeys

Visual Basic [image] Copy Code

Public Class FlowLayoutKeys
Inherits SimpleKeys

Inheritance Hierarchy

System.Object
MindFusion.Layout.SimpleKeys
MindFusion.Layout.FlowLayoutKeys

See Also

FlowLayoutKeys Members
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutKeys Members

FlowLayoutKeys Members
Constructors Fields Properties Methods
[image]

Defines keys that can be used to define FlowLayout rules.

The following tables list the members exposed by the FlowLayoutKeys type.

Public Constructors

Name | Description
FlowLayoutKeys | Initializes a new instance of the FlowLayoutKeys class.

Public Fields

Name | Description
ConnectorTypes | Specifies a list of connector identifiers. (Inherited from SimpleKeys.)
FirstGroupLevelNegative | A rule defining which nodes should be placed above the "Control Flow" line. Associate an array of the node types logic identifiers with this key. (Inherited from SimpleKeys.)
FirstGroupLevelPositive | A rule defining which nodes should be placed below the "Control Flow" line. Associate an array of the node types logic identifiers with this key. (Inherited from SimpleKeys.)
GroupEndNodes | Specifies which nodes should be considered the end of the current sub-group. Associate an array of the node types logic identifiers with this key. (Inherited from SimpleKeys.)
GroupStartNodes | Specifies which nodes should be considered the start of a new sub-group. Associate an array of the node types logic identifiers with this key. (Inherited from SimpleKeys.)
MainConnectorOrientation | Specifies the orientation of the "Control Flow" sequence of links, and thus the main orientation for the layout. (Inherited from SimpleKeys.)
MainSubgroupConnector | Defines which type of connectors can be used as guideline (defining the graph control flow). (Inherited from SimpleKeys.)
PossibleConnection | Specifies what kind of node connections are allowed. (Inherited from SimpleKeys.)
PossibleNodeLogic | Specifies a list of identifiers for nodes that should be processed by FlowLayout.
SemiLevel | Specifies a list of identifiers for nodes that should be placed with some offset from the main sequence line.

Public Properties

Name | Description
AllKeys | A list of all keys defined in this class. (Inherited from SimpleKeys.)

Public Methods

Name | Description
ValidateRules | Checks if there is a rule for each key in the key list. (Inherited from SimpleKeys.)

See Also

FlowLayoutKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutKeys Fields

FlowLayoutKeys Fields
[image]

Public Fields

Name | Description
ConnectorTypes | Specifies a list of connector identifiers. (Inherited from SimpleKeys.)
FirstGroupLevelNegative | A rule defining which nodes should be placed above the "Control Flow" line. Associate an array of the node types logic identifiers with this key. (Inherited from SimpleKeys.)
FirstGroupLevelPositive | A rule defining which nodes should be placed below the "Control Flow" line. Associate an array of the node types logic identifiers with this key. (Inherited from SimpleKeys.)
GroupEndNodes | Specifies which nodes should be considered the end of the current sub-group. Associate an array of the node types logic identifiers with this key. (Inherited from SimpleKeys.)
GroupStartNodes | Specifies which nodes should be considered the start of a new sub-group. Associate an array of the node types logic identifiers with this key. (Inherited from SimpleKeys.)
MainConnectorOrientation | Specifies the orientation of the "Control Flow" sequence of links, and thus the main orientation for the layout. (Inherited from SimpleKeys.)
MainSubgroupConnector | Defines which type of connectors can be used as guideline (defining the graph control flow). (Inherited from SimpleKeys.)
PossibleConnection | Specifies what kind of node connections are allowed. (Inherited from SimpleKeys.)
PossibleNodeLogic | Specifies a list of identifiers for nodes that should be processed by FlowLayout.
SemiLevel | Specifies a list of identifiers for nodes that should be placed with some offset from the main sequence line.

See Also

FlowLayoutKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutKeys.PossibleNodeLogic Field

FlowLayoutKeys.PossibleNodeLogic Field
[image]

Specifies a list of identifiers for nodes that should be processed by FlowLayout.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string PossibleNodeLogic

Visual Basic [image] Copy Code

Public Shared PossibleNodeLogic As String

See Also

FlowLayoutKeys Members
FlowLayoutKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutKeys.SemiLevel Field

FlowLayoutKeys.SemiLevel Field
[image]

Specifies a list of identifiers for nodes that should be placed with some offset from the main sequence line.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string SemiLevel

Visual Basic [image] Copy Code

Public Shared SemiLevel As String

See Also

FlowLayoutKeys Members
FlowLayoutKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutKeys Constructor

FlowLayoutKeys Constructor
[image]

Initializes a new instance of the FlowLayoutKeys class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FlowLayoutKeys ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

FlowLayoutKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules Class

FlowLayoutRules Class
[image]

A class representing a set of rules that define the behavior of the FlowLayout class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class FlowLayoutRules : LayoutRules

Visual Basic [image] Copy Code

Public Class FlowLayoutRules
Inherits LayoutRules

Inheritance Hierarchy

System.Object
MindFusion.Layout.LayoutRules
MindFusion.Layout.FlowLayoutRules

See Also

FlowLayoutRules Members
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules Members

FlowLayoutRules Members
Constructors Properties Methods
[image]

A class representing a set of rules that define the behavior of the FlowLayout class.

The following tables list the members exposed by the FlowLayoutRules type.

Public Constructors

Name | Description
FlowLayoutRules | Initializes a new instance of the FlowLayoutRules class.

Public Properties

Name | Description
ConnectorRules | A set of rules that are applied according to the logic identifiers of links.
NodeRules | A set of rules that are applied according to the logic identifiers of node pairs.
PreferredRules | Specifies which set of rules to use.

Public Methods

Name | Description
AddBendRule | Overloaded.
AddIncomingBendRule | Overloaded.
AddLayoutRule | Overloaded. (Inherited from LayoutRules.)
AddOutgoingBendRule | Overloaded.
BuildKey | Builds a key - object for the new rule, as a pair of two objects: obj1 and obj2. (Inherited from LayoutRules.)
GetLayoutRule | If there is rule with key - Key initializes - Value otherwise fails; (Inherited from LayoutRules.)
UseRuleManagedLinkBend | Specifies whether FlowLayout should use custom link-bending rules specified through the various Add*BendRule methods.
ValidateRules | Checks if there is a rule for each key in KeyList (Inherited from LayoutRules.)

See Also

FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules Constructor

FlowLayoutRules Constructor
[image]

Initializes a new instance of the FlowLayoutRules class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FlowLayoutRules ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules Methods

FlowLayoutRules Methods
[image]

Public Methods

Name | Description
AddBendRule | Overloaded.
AddIncomingBendRule | Overloaded.
AddLayoutRule | Overloaded. (Inherited from LayoutRules.)
AddOutgoingBendRule | Overloaded.
BuildKey | Builds a key - object for the new rule, as a pair of two objects: obj1 and obj2. (Inherited from LayoutRules.)
GetLayoutRule | If there is rule with key - Key initializes - Value otherwise fails; (Inherited from LayoutRules.)
UseRuleManagedLinkBend | Specifies whether FlowLayout should use custom link-bending rules specified through the various Add*BendRule methods.
ValidateRules | Checks if there is a rule for each key in KeyList (Inherited from LayoutRules.)

See Also

FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddBendRule Method

FlowLayoutRules.AddBendRule Method
[image]

Overload List

Name | Description
FlowLayoutRules.AddBendRule (String, String, OrderDirection) | Adds a rule for the orientation of the starting or ending segment of a link according to the type of the node connected to that link.
FlowLayoutRules.AddBendRule (String, String, OrderDirection[]) | Adds a rule for the orientation of the starting or ending segments of a link according to the type of the node connected to that link.
FlowLayoutRules.AddBendRule (String, String[], OrderDirection) | Adds a rule for the orientation of the starting or ending segment of a link according to the type of the node connected to that link.
FlowLayoutRules.AddBendRule (String, String[], OrderDirection[]) | Adds a rule for the orientation of the starting or ending segments of a link according to the type of the node connected to that link.
FlowLayoutRules.AddBendRule (String[], String, OrderDirection) | Adds a rule for the orientation of the starting or ending segment of a link according to the type of the node connected to that link.
FlowLayoutRules.AddBendRule (String[], String, OrderDirection[]) | Adds a rule for the orientation of the starting or ending segments of a link according to the type of the node connected to that link.

See Also

FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddBendRule Method (String, String, OrderDirection)

FlowLayoutRules.AddBendRule Method (String, String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting or ending segment of a link according to the type of the node connected to that link.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddBendRule (
string nodeType,
string linkType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddBendRule ( _
nodeType As String, _
linkType As String, _
direction As OrderDirection _
) As Boolean

Parameters

nodeType

The logic identifier of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

direction
An OrderDirection value defining the orientation of the links starting or ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddBendRule Method (String, String, OrderDirection[])

FlowLayoutRules.AddBendRule Method (String, String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting or ending segments of a link according to the type of the node connected to that link.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddBendRule (
string nodeType,
string linkType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddBendRule( _
nodeType As String, _
linkType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

nodeType

The logic identifier of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

directions
An array of OrderDirection values defining the orientation of the links starting or ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddBendRule Method (String, String[], OrderDirection)

FlowLayoutRules.AddBendRule Method (String, String[], OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting or ending segment of a link according to the type of the node connected to that link.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddBendRule (
string nodeType,
string[] linkTypes,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddBendRule ( _
nodeType As String, _
linkTypes As String(), _
direction As OrderDirection _
) As Boolean

Parameters

nodeType

The logic identifier of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

direction
An OrderDirection value defining the orientation of the links starting or ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddBendRule Method (String, String[], OrderDirection[])

FlowLayoutRules.AddBendRule Method (String, String[], OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting or ending segments of a link according to the type of the node connected to that link.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddBendRule (
string nodeType,
string[] linkTypes,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddBendRule( _
nodeType As String, _
linkTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

nodeType

The logic identifier of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links starting or ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddBendRule Method (String[], String, OrderDirection)

FlowLayoutRules.AddBendRule Method (String[], String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting or ending segment of a link according to the type of the node connected to that link.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddBendRule (
string[] nodeTypes,
string linkType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddBendRule ( _
nodeTypes As String(), _
linkType As String, _
direction As OrderDirection _
) As Boolean

Parameters

nodeTypes

The logic identifiers of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

direction
An OrderDirection value defining the orientation of the links starting or ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddBendRule Method (String[], String, OrderDirection[])

FlowLayoutRules.AddBendRule Method (String[], String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting or ending segments of a link according to the type of the node connected to that link.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddBendRule (
string[] nodeTypes,
string linkType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddBendRule( _
nodeTypes() As String, _
linkType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

nodeTypes

The logic identifiers of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links starting or ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method

FlowLayoutRules.AddIncomingBendRule Method
[image]

Overload List

Name | Description
FlowLayoutRules.AddIncomingBendRule (String, String, OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination node.
FlowLayoutRules.AddIncomingBendRule (String, String, OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination node.
FlowLayoutRules.AddIncomingBendRule (String, String, String, OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String, String, String, OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String, String, String[], OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String, String, String[], OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String, String[], OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination node.
FlowLayoutRules.AddIncomingBendRule (String, String[], OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination node.
FlowLayoutRules.AddIncomingBendRule (String, String[], String, OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String, String[], String, OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String, String[], String[], OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String, String[], String[], OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String[], String, OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination node.
FlowLayoutRules.AddIncomingBendRule (String[], String, OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination node.
FlowLayoutRules.AddIncomingBendRule (String[], String, String, OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String[], String, String, OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String[], String, String[], OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String[], String, String[], OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String[], String[], OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination node.
FlowLayoutRules.AddIncomingBendRule (String[], String[], OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination node.
FlowLayoutRules.AddIncomingBendRule (String[], String[], String, OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String[], String[], String, OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String[], String[], String[], OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String[], String[], String[], OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.

See Also

FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String, OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String, String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string destNodeType,
string linkType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule ( _
destNodeType As String, _
linkType As String, _
direction As OrderDirection _
) As Boolean

Parameters

destNodeType

The logic identifier of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

direction
An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String, OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String, String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string destNodeType,
string linkType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule ( _
destNodeType As String, _
linkType As String, _
directions As OrderDirection() _
) As Boolean

Parameters

destNodeType

The logic identifier of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

directions
An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String, String, OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String, String, String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string destNodeType,
string linkType,
string originNodeType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule ( _
destNodeType As String, _
linkType As String, _
originNodeType As String, _
direction As OrderDirection _
) As Boolean

Parameters

destNodeType

The logic identifier of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

originNodeType

The logic identifier of nodes this rule should be applied to.

direction
An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String, String, OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String, String, String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string destNodeType,
string linkType,
string originNodeType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeType As String, _
linkType As String, _
originNodeType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeType

The logic identifier of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

originNodeType

The logic identifier of nodes this rule should be applied to.

directions
An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String, String[], OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String, String, String[], OrderDirection)
See Also
[image]

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string destNodeType,
string linkType,
string[] originNodeTypes,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule ( _
destNodeType As String, _
linkType As String, _
originNodeTypes As String(), _
direction As OrderDirection _
) As Boolean

Parameters

destNodeType

The logic identifier of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

direction
An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String, String[], OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String, String, String[], OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string destNodeType,
string linkType,
string[] originNodeTypes,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeType As String, _
linkType As String, _
originNodeTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeType

The logic identifier of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

directions
An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String[], OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String, String[], OrderDirection)
See Also
[image]

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string destNodeType,
string[] linkTypes,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule ( _
destNodeType As String, _
linkTypes As String(), _
direction As OrderDirection _
) As Boolean

Parameters

destNodeType

The logic identifier of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

direction
An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String[], OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String, String[], OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string destNodeType,
string[] linkTypes,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeType As String, _
linkTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeType

The logic identifier of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

directions
An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String[], String, OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String, String[], String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string destNodeType,
string[] linkTypes,
string originNodeType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule ( _
destNodeType As String, _
linkTypes As String(), _
originNodeType As String, _
direction As OrderDirection _
) As Boolean

Parameters

destNodeType

The logic identifier of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

originNodeType

The logic identifier of nodes this rule should be applied to.

direction
An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String[], String, OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String, String[], String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string destNodeType,
string[] linkTypes,
string originNodeType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeType As String, _
linkTypes() As String, _
originNodeType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeType

The logic identifier of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

originNodeType

The logic identifier of nodes this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String[], String[], OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String, String[], String[], OrderDirection)
See Also
[image]

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string destNodeType,
string[] linkTypes,
string[] originNodeTypes,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule ( _
destNodeType As String, _
linkTypes As String(), _
originNodeTypes As String(), _
direction As OrderDirection _
) As Boolean

Parameters

destNodeType

The logic identifier of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

direction
An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String[], String[], OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String, String[], String[], OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string destNodeType,
string[] linkTypes,
string[] originNodeTypes,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeType As String, _
linkTypes() As String, _
originNodeTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeType

The logic identifier of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String, OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String[], String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string[] destNodeTypes,
string linkType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule ( _
destNodeTypes As String(), _
linkType As String, _
direction As OrderDirection _
) As Boolean

Parameters

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

direction
An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String, OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String[], String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string[] destNodeTypes,
string linkType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeTypes() As String, _
linkType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String, String, OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String[], String, String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string[] destNodeTypes,
string linkType,
string originNodeType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule ( _
destNodeTypes As String(), _
linkType As String, _
originNodeType As String, _
direction As OrderDirection _
) As Boolean

Parameters

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

originNodeType

The logic identifier of nodes this rule should be applied to.

direction
An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String, String, OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String[], String, String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string[] destNodeTypes,
string linkType,
string originNodeType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeTypes() As String, _
linkType As String, _
originNodeType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

originNodeType

The logic identifier of nodes this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String, String[], OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String[], String, String[], OrderDirection)
See Also
[image]

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string[] destNodeTypes,
string linkType,
string[] originNodeTypes,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule ( _
destNodeTypes As String(), _
linkType As String, _
originNodeTypes As String(), _
direction As OrderDirection _
) As Boolean

Parameters

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

direction
An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String, String[], OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String[], String, String[], OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string[] destNodeTypes,
string linkType,
string[] originNodeTypes,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeTypes() As String, _
linkType As String, _
originNodeTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String[], OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String[], String[], OrderDirection)
See Also
[image]

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string[] destNodeTypes,
string[] linkTypes,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule ( _
destNodeTypes As String(), _
linkTypes As String(), _
direction As OrderDirection _
) As Boolean

Parameters

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

direction
An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String[], OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String[], String[], OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string[] destNodeTypes,
string[] linkTypes,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeTypes() As String, _
linkTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String[], String, OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String[], String[], String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string[] destNodeTypes,
string[] linkTypes,
string originNodeType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule ( _
destNodeTypes As String(), _
linkTypes As String(), _
originNodeType As String, _
direction As OrderDirection _
) As Boolean

Parameters

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

originNodeType

The logic identifier of nodes this rule should be applied to.

direction
An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String[], String, OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String[], String[], String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string[] destNodeTypes,
string[] linkTypes,
string originNodeType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeTypes() As String, _
linkTypes() As String, _
originNodeType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

originNodeType

The logic identifier of nodes this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String[], String[], OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String[], String[], String[], OrderDirection)
See Also
[image]

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string[] destNodeTypes,
string[] linkTypes,
string[] originNodeTypes,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule ( _
destNodeTypes As String(), _
linkTypes As String(), _
originNodeTypes As String(), _
direction As OrderDirection _
) As Boolean

Parameters

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

direction
An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String[], String[], OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String[], String[], String[], OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string[] destNodeTypes,
string[] linkTypes,
string[] originNodeTypes,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeTypes() As String, _
linkTypes() As String, _
originNodeTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

directions
An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method

FlowLayoutRules.AddOutgoingBendRule Method
[image]

Overload List

Name | Description
FlowLayoutRules.AddOutgoingBendRule (String, String, OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String, OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String, String, OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String, String, OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String, String[], OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String, String[], OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String[], OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String[], OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String[], String, OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String[], String, OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String[], String[], OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String[], String[], OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String, OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String, OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String, String, OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String, String, OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String, String[], OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String, String[], OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String[], OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String[], OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String[], String, OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String[], String, OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String[], String[], OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String[], String[], OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

See Also

FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String, OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String, String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string originNodeType,
string linkType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule ( _
originNodeType As String, _
linkType As String, _
direction As OrderDirection _
) As Boolean

Parameters

originNodeType
The logic identifier of nodes this rule to be applied to.
linkType
The logic identifier of links this rule will be applied to.
direction
An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String, OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String, String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string originNodeType,
string linkType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeType As String, _
linkType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeType

The logic identifier of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String, String, OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String, String, String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string originNodeType,
string linkType,
string destNodeType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule ( _
originNodeType As String, _
linkType As String, _
destNodeType As String, _
direction As OrderDirection _
) As Boolean

Parameters

originNodeType
The logic identifier of nodes this rule will be applied to.
linkType
The logic identifier of links this rule will be applied to.
destNodeType
The logic identifier of nodes this rule will be applied to.
direction
An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String, String, OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String, String, String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string originNodeType,
string linkType,
string destNodeType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeType As String, _
linkType As String, _
destNodeType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeType

The logic identifier of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

destNodeType

The logic identifier of nodes this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String, String[], OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String, String, String[], OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string originNodeType,
string linkType,
string[] destNodeTypes,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule ( _
originNodeType As String, _
linkType As String, _
destNodeTypes As String(), _
direction As OrderDirection _
) As Boolean

Parameters

originNodeType
The logic identifier of nodes this rule will be applied to.
linkType
The logic identifier of links this rule will be applied to.
destNodeTypes
The logic identifiers of nodes this rule will be applied to.
direction
An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String, String[], OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String, String, String[], OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string originNodeType,
string linkType,
string[] destNodeTypes,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeType As String, _
linkType As String, _
destNodeTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeType

The logic identifier of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String[], OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String, String[], OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string originNodeType,
string[] linkTypes,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule ( _
originNodeType As String, _
linkTypes As String(), _
direction As OrderDirection _
) As Boolean

Parameters

originNodeType

The logic identifier of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

direction
An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String[], OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String, String[], OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string originNodeType,
string[] linkTypes,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeType As String, _
linkTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeType

The logic identifier of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String[], String, OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String, String[], String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string originNodeType,
string[] linkTypes,
string destNodeType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule ( _
originNodeType As String, _
linkTypes As String(), _
destNodeType As String, _
direction As OrderDirection _
) As Boolean

Parameters

originNodeType

The logic identifier of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

destNodeType

The logic identifier of nodes this rule should be applied to.

direction
An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String[], String, OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String, String[], String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string originNodeType,
string[] linkTypes,
string destNodeType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeType As String, _
linkTypes() As String, _
destNodeType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeType

The logic identifier of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

destNodeType

The logic identifier of nodes this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String[], String[], OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String, String[], String[], OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string originNodeType,
string[] linkTypes,
string[] destNodeTypes,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule ( _
originNodeType As String, _
linkTypes As String(), _
destNodeTypes As String(), _
direction As OrderDirection _
) As Boolean

Parameters

originNodeType
The logic identifier of nodes this rule to apply to.
linkTypes
The logic identifiers of links this rule to be applied to.
destNodeTypes
The logic identifiers of nodes this rule to be applied to.
direction
An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String[], String[], OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String, String[], String[], OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string originNodeType,
string[] linkTypes,
string[] destNodeTypes,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeType As String, _
linkTypes() As String, _
destNodeTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeType

The logic identifier of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String, OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String[], String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string linkType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule ( _
originNodeTypes As String(), _
linkType As String, _
direction As OrderDirection _
) As Boolean

Parameters

originNodeTypes
The logic identifiers of nodes this rule to be applied to.
linkType
The logic identifier of links this rule to be applied to.
direction
An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String, OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String[], String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string linkType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeTypes() As String, _
linkType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeTypes
The logic identifiers of nodes this rule to be applied to.
linkType

The logic identifier of links this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String, String, OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String[], String, String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string linkType,
string destNodeType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule ( _
originNodeTypes As String(), _
linkType As String, _
destNodeType As String, _
direction As OrderDirection _
) As Boolean

Parameters

originNodeTypes
The logic identifiers of nodes this rule to apply.
linkType
The logic identifier of links this rule to apply.
destNodeType
The logic identifier of nodes this rule will be applied to.
direction
An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String, String, OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String[], String, String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string linkType,
string destNodeType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeTypes() As String, _
linkType As String, _
destNodeType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeTypes
The logic identifiers of nodes this rule to be applied to.
linkType
The logic identifier of links this rule to be applied to.
destNodeType
The logic identifier of nodes this rule to be applied to.
directions

An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String, String[], OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String[], String, String[], OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string linkType,
string[] destNodeTypes,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule ( _
originNodeTypes As String(), _
linkType As String, _
destNodeTypes As String(), _
direction As OrderDirection _
) As Boolean

Parameters

originNodeTypes
The logic identifiers of nodes this rule to be applied to.
linkType
The logic identifier of links this rule to be applied to.
destNodeTypes
The logic identifiers of nodes this rule to be applied to.
direction
An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String, String[], OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String[], String, String[], OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string linkType,
string[] destNodeTypes,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeTypes() As String, _
linkType As String, _
destNodeTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeTypes
The logic identifiers of nodes this rule to be applied to.
linkType
The logic identifier of links this rule to be applied to.
destNodeTypes
The logic identifiers of nodes this rule to be applied to.
directions

An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string[] linkTypes,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule ( _
originNodeTypes As String(), _
linkTypes As String(), _
direction As OrderDirection _
) As Boolean

Parameters

originNodeTypes
The logic identifiers of nodes this rule to be applied to.
linkTypes
The logic identifiers of links this rule to be applied to.
direction
An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string[] linkTypes,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeTypes() As String, _
linkTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkTypes

The logic identifier of links this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], String, OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string[] linkTypes,
string destNodeType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule ( _
originNodeTypes As String(), _
linkTypes As String(), _
destNodeType As String, _
direction As OrderDirection _
) As Boolean

Parameters

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

destNodeType

The logic identifier of nodes this rule should be applied to.

direction
An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], String, OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string[] linkTypes,
string destNodeType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeTypes() As String, _
linkTypes() As String, _
destNodeType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

destNodeType

The logic identifier of nodes this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], String[], OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], String[], OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string[] linkTypes,
string[] destNodeTypes,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule ( _
originNodeTypes As String(), _
linkTypes As String(), _
destNodeTypes As String(), _
direction As OrderDirection _
) As Boolean

Parameters

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

direction
An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], String[], OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], String[], OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string[] linkTypes,
string[] destNodeTypes,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeTypes() As String, _
linkTypes() As String, _
destNodeTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.UseRuleManagedLinkBend Method

FlowLayoutRules.UseRuleManagedLinkBend Method
[image]

Specifies whether FlowLayout should use custom link-bending rules specified through the various Add*BendRule methods.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool UseRuleManagedLinkBend (
bool ruleManaged
)

Visual Basic [image] Copy Code

Public Function UseRuleManagedLinkBend( _
ruleManaged As Boolean _
) As Boolean

Parameters

ruleManaged
true to use custom link-bending rules; otherwise, false.

Return Value

true if this rule has been set successfully; otherwise, false.

See Also

FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules Properties

FlowLayoutRules Properties
[image]

Public Properties

Name | Description
ConnectorRules | A set of rules that are applied according to the logic identifiers of links.
NodeRules | A set of rules that are applied according to the logic identifiers of node pairs.
PreferredRules | Specifies which set of rules to use.

See Also

FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.ConnectorRules Property

FlowLayoutRules.ConnectorRules Property
[image]

A set of rules that are applied according to the logic identifiers of links.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ConnectorRules ConnectorRules { get; set; }

Visual Basic [image] Copy Code

Public Property ConnectorRules As ConnectorRules

Property Value

See Also

FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.NodeRules Property

FlowLayoutRules.NodeRules Property
[image]

A set of rules that are applied according to the logic identifiers of node pairs.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeRules NodeRules { get; set; }

Visual Basic [image] Copy Code

Public Property NodeRules As NodeRules

Property Value

See Also

FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.PreferredRules Property

FlowLayoutRules.PreferredRules Property
[image]

Specifies which set of rules to use.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PreferredRules PreferredRules { get; set; }

Visual Basic [image] Copy Code

Public Property PreferredRules As PreferredRules

Property Value

See Also

FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutTraits Enumeration

FlowLayoutTraits Enumeration
[image]

Values used as keys in FlowLayout rules.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum FlowLayoutTraits

Visual Basic [image] Copy Code

Public Enum FlowLayoutTraits

Members

Member name | Description
PossibleConnection | For internal use.
OrderingRule | Specified the preferred order for nodes.
NodeDirection | For internal use.
NodeDistance | Specifies the distance left between this node and the next in the sequence.
LaneNode | Specifies that FlowLayout should treat a node as a lane.
LogicID | Specifies a string used to identify items in FlowLayout rules.
Lane | Specifies the lane to which a node should be assigned.
VerticalSubgroupsAlignment | A boolean value specifying the alignment of nodes within a group.
StandardLinkBend | For internal use.
InLink | Identifies possible incoming links in FlowLayout rules.
OutLink | Identifies possible outgoing links in FlowLayout rules.
NotSpecified | For internal use.
VerticalDisconnectedGroupsAlignment | A boolean value specifying the alignment of nodes within a group.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.HierarchicalLayoutTraits Enumeration

HierarchicalLayoutTraits Enumeration
[image]

Indicates item traits specific to hierarchical layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum HierarchicalLayoutTraits

Visual Basic [image] Copy Code

Public Enum HierarchicalLayoutTraits

Members

Member name | Description
Level | The number associated with this key specifies the index of the level of the item in the level-planar graph.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.LayeredLayoutTraits Enumeration

LayeredLayoutTraits Enumeration
[image]

Indicates item traits specific to layered layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum LayeredLayoutTraits

Visual Basic [image] Copy Code

Public Enum LayeredLayoutTraits

Members

Member name | Description
Layer | The number associated with this key specifies the index of the layer the layout should attempt to place the node to. Specifying a negative number indicates a layer starting from the last. For example, -1 would indicate the last layer, -2 - the layer before the last, and so on.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules Class

LayoutRules Class
[image]

Summary description for LayoutRules.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LayoutRules

Visual Basic [image] Copy Code

Public Class LayoutRules

Inheritance Hierarchy

System.Object
MindFusion.Layout.LayoutRules
MindFusion.Layout.ConnectorRules
MindFusion.Layout.FlowLayoutRules
MindFusion.Layout.NodeRules
MindFusion.Layout.SimpleRules

See Also

LayoutRules Members
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules Members

LayoutRules Members
Constructors Methods
[image]

Summary description for LayoutRules.

The following tables list the members exposed by the LayoutRules type.

Public Constructors

Name | Description
LayoutRules | Initializes a new instance of the LayoutRules class.

Public Methods

Name | Description
AddLayoutRule | Overloaded.
BuildKey | Builds a key - object for the new rule, as a pair of two objects: obj1 and obj2.
GetLayoutRule | If there is rule with key - Key initializes - Value otherwise fails;
ValidateRules | Checks if there is a rule for each key in KeyList

See Also

LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules Constructor

LayoutRules Constructor
[image]

Initializes a new instance of the LayoutRules class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LayoutRules ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules Methods

LayoutRules Methods
[image]

Public Methods

Name | Description
AddLayoutRule | Overloaded.
BuildKey | Builds a key - object for the new rule, as a pair of two objects: obj1 and obj2.
GetLayoutRule | If there is rule with key - Key initializes - Value otherwise fails;
ValidateRules | Checks if there is a rule for each key in KeyList

See Also

LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.AddLayoutRule Method

LayoutRules.AddLayoutRule Method
[image]

Overload List

Name | Description
LayoutRules.AddLayoutRule (Object, Object) | Adds or sets a new rule, depending on if the rule with key - Key already exists or no;
LayoutRules.AddLayoutRule (Object, Object, Object) | Builds a key as a pair of the objects Object1 and Object2 and adds or sets a new rule, with this key and value - Value;

See Also

LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.AddLayoutRule Method (Object, Object)

LayoutRules.AddLayoutRule Method (Object, Object)
See Also
[image]

Adds or sets a new rule, depending on if the rule with key - Key already exists or no;

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddLayoutRule (
Object Key,
Object Value
)

Visual Basic [image] Copy Code

Public Function AddLayoutRule( _
Key As Object, _
Value As Object _
) As Boolean

Parameters

Key

Value

Return Value

See Also

AddLayoutRule Method Overload List
LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.AddLayoutRule Method (Object, Object, Object)

LayoutRules.AddLayoutRule Method (Object, Object, Object)
See Also
[image]

Builds a key as a pair of the objects Object1 and Object2 and adds or sets a new rule, with this key and value - Value;

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddLayoutRule (
Object Object1,
Object Object2,
Object Value
)

Visual Basic [image] Copy Code

Public Function AddLayoutRule( _
Object1 As Object, _
Object2 As Object, _
Value As Object _
) As Boolean

Parameters

Object1

Object2

Value

Return Value

See Also

AddLayoutRule Method Overload List
LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.BuildKey Method

LayoutRules.BuildKey Method
[image]

Builds a key - object for the new rule, as a pair of two objects: obj1 and obj2.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object BuildKey (
Object obj1,
Object obj2
)

Visual Basic [image] Copy Code

Public Function BuildKey( _
obj1 As Object, _
obj2 As Object _
) As Object

Parameters

obj1

obj2

Return Value

See Also

LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.GetLayoutRule Method

LayoutRules.GetLayoutRule Method
[image]

If there is rule with key - Key initializes - Value otherwise fails;

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool GetLayoutRule (
Object Key,
out Object Value
)

Visual Basic [image] Copy Code

Public Overridable Function GetLayoutRule( _
Key As Object, _
<System.Runtime.InteropServices.Out()> ByRef Value As Object _
) As Boolean

Parameters

Key

Value

Return Value

See Also

LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.ValidateRules Method

LayoutRules.ValidateRules Method
[image]

Checks if there is a rule for each key in KeyList

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ValidateRules (
ArrayList KeyList
)

Visual Basic [image] Copy Code

Public Function ValidateRules( _
KeyList As ArrayList _
) As Boolean

Parameters

KeyList

Return Value

See Also

LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules Class

NodeRules Class
[image]

Represents a set of rules that are applied according to the logic identifiers of node pairs.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class NodeRules : LayoutRules

Visual Basic [image] Copy Code

Public Class NodeRules
Inherits LayoutRules

Inheritance Hierarchy

System.Object
MindFusion.Layout.LayoutRules
MindFusion.Layout.NodeRules

See Also

NodeRules Members
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules Members

NodeRules Members
Properties Methods
[image]

Represents a set of rules that are applied according to the logic identifiers of node pairs.

The following tables list the members exposed by the NodeRules type.

Public Properties

Name | Description
FirstGroupLevelNegative | A rule defining which nodes should be placed above the "Control Flow" line. Assign an array of the node types logic identifiers to this property.
FirstGroupLevelPositive | A rule defining which nodes should be placed below the "Control Flow" line. Assign an array of the node types logic identifiers to this property.
GroupEndNodes | Specifies which nodes should be considered the end of the current sub-group. Assign an array of the node types logic identifiers to this property.
GroupStartNodes | Specifies which nodes should be considered the start of a new sub-group. Assign an array of the node types logic identifiers to this property.
MainConnectorId | Specifies which type of connectors define the control flow in the process represented by the arranged diagram.
MainConnectorOrientation | Specifies the orientation of the "Control Flow" sequence of links, and thus the main orientation for the layout.
VerticalDisconnectedGroupsAlignment | Specifies whether disconnected subgroups from the same lane should be aligned and arranged vertically.
VerticalSubgroupsAlignment | Specifies whether connected subgroups from the same lane should be aligned and arranged vertically.

Public Methods

Name | Description
AddLayoutRule | Overloaded. (Inherited from LayoutRules.)
BuildKey | Builds a key - object for the new rule, as a pair of two objects: obj1 and obj2. (Inherited from LayoutRules.)
GetLayoutRule | If there is rule with key - Key initializes - Value otherwise fails; (Inherited from LayoutRules.)
ValidateRules | Checks if there is a rule for each key in KeyList (Inherited from LayoutRules.)

See Also

NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules Properties

NodeRules Properties
[image]

Public Properties

Name | Description
FirstGroupLevelNegative | A rule defining which nodes should be placed above the "Control Flow" line. Assign an array of the node types logic identifiers to this property.
FirstGroupLevelPositive | A rule defining which nodes should be placed below the "Control Flow" line. Assign an array of the node types logic identifiers to this property.
GroupEndNodes | Specifies which nodes should be considered the end of the current sub-group. Assign an array of the node types logic identifiers to this property.
GroupStartNodes | Specifies which nodes should be considered the start of a new sub-group. Assign an array of the node types logic identifiers to this property.
MainConnectorId | Specifies which type of connectors define the control flow in the process represented by the arranged diagram.
MainConnectorOrientation | Specifies the orientation of the "Control Flow" sequence of links, and thus the main orientation for the layout.
VerticalDisconnectedGroupsAlignment | Specifies whether disconnected subgroups from the same lane should be aligned and arranged vertically.
VerticalSubgroupsAlignment | Specifies whether connected subgroups from the same lane should be aligned and arranged vertically.

See Also

NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules.FirstGroupLevelNegative Property

NodeRules.FirstGroupLevelNegative Property
[image]

A rule defining which nodes should be placed above the "Control Flow" line. Assign an array of the node types logic identifiers to this property.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object FirstGroupLevelNegative { get; set; }

Visual Basic [image] Copy Code

Public Property FirstGroupLevelNegative As Object

Property Value

See Also

NodeRules Members
NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules.FirstGroupLevelPositive Property

NodeRules.FirstGroupLevelPositive Property
[image]

A rule defining which nodes should be placed below the "Control Flow" line. Assign an array of the node types logic identifiers to this property.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object FirstGroupLevelPositive { get; set; }

Visual Basic [image] Copy Code

Public Property FirstGroupLevelPositive As Object

Property Value

See Also

NodeRules Members
NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules.GroupEndNodes Property

NodeRules.GroupEndNodes Property
[image]

Specifies which nodes should be considered the end of the current sub-group. Assign an array of the node types logic identifiers to this property.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object GroupEndNodes { get; set; }

Visual Basic [image] Copy Code

Public Property GroupEndNodes As Object

Property Value

See Also

NodeRules Members
NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules.GroupStartNodes Property

NodeRules.GroupStartNodes Property
[image]

Specifies which nodes should be considered the start of a new sub-group. Assign an array of the node types logic identifiers to this property.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object GroupStartNodes { get; set; }

Visual Basic [image] Copy Code

Public Property GroupStartNodes As Object

Property Value

See Also

NodeRules Members
NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules.MainConnectorId Property

NodeRules.MainConnectorId Property
[image]

Specifies which type of connectors define the control flow in the process represented by the arranged diagram.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string MainConnectorId { get; set; }

Visual Basic [image] Copy Code

Public Property MainConnectorId As String

Property Value

See Also

NodeRules Members
NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules.MainConnectorOrientation Property

NodeRules.MainConnectorOrientation Property
[image]

Specifies the orientation of the "Control Flow" sequence of links, and thus the main orientation for the layout.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SimpleOrientation MainConnectorOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property MainConnectorOrientation As SimpleOrientation

Property Value

See Also

NodeRules Members
NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules.VerticalDisconnectedGroupsAlignment Property

NodeRules.VerticalDisconnectedGroupsAlignment Property
[image]

Specifies whether disconnected subgroups from the same lane should be aligned and arranged vertically.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool VerticalDisconnectedGroupsAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalDisconnectedGroupsAlignment As Boolean

Property Value

See Also

NodeRules Members
NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules.VerticalSubgroupsAlignment Property

NodeRules.VerticalSubgroupsAlignment Property
[image]

Specifies whether connected subgroups from the same lane should be aligned and arranged vertically.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool VerticalSubgroupsAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalSubgroupsAlignment As Boolean

Property Value

See Also

NodeRules Members
NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.OrderDirection Enumeration

OrderDirection Enumeration
[image]

Values controlling the direction of link segments in FlowLayout rules.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum OrderDirection

Visual Basic [image] Copy Code

Public Enum OrderDirection

Members

Member name | Description
Leftward | Specifies leftward link direction.
Rightward | Specifies rightward link direction.
Upward | Specifies upward link direction.
Downward | Specifies downward link direction.
NotSpecified | Unspecified link direction.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.Pair Class

Pair Class
[image]

Represents a coupling between two arbitrary objects.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Pair : IComparable

Visual Basic [image] Copy Code

Public Class Pair
Implements IComparable

Inheritance Hierarchy

System.Object
MindFusion.Layout.Pair

See Also

Pair Members
MindFusion.Layout Namespace


MindFusion.Layout.Pair Members

Pair Members
Constructors Properties Methods
[image]

Represents a coupling between two arbitrary objects.

The following tables list the members exposed by the Pair type.

Public Constructors

Name | Description
Pair | Overloaded.

Public Properties

Name | Description
FirstObject | Gets or sets the first pair object.
PairElements | Gets the elements of the pair as an arraylist.
SecondObject | Gets or sets the second pair object.

Public Methods

Name | Description
CompareTo | Implements IComparable.CompareTo.
Equals | Object.Equals override.
GetHashCode | Object.GetHashCode override.

See Also

Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair Constructor

Pair Constructor
[image]

Overload List

Name | Description
Pair () | Initializes a new instance of the Pair class.
Pair (Object, Object) | Initializes a new instance of the Pair class.

See Also

Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair Constructor ()

Pair Constructor ()
See Also
[image]

Initializes a new instance of the Pair class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pair ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Pair Constructor Overload List
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair Constructor (Object, Object)

Pair Constructor (Object, Object)
See Also
[image]

Initializes a new instance of the Pair class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pair (
Object obj1,
Object obj2
)

Visual Basic [image] Copy Code

Public New ( _
obj1 As Object, _
obj2 As Object _
)

Parameters

obj1

obj2

See Also

Pair Constructor Overload List
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair Methods

Pair Methods
[image]

Public Methods

Name | Description
CompareTo | Implements IComparable.CompareTo.
Equals | Object.Equals override.
GetHashCode | Object.GetHashCode override.

See Also

Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.CompareTo Method

Pair.CompareTo Method
[image]

Implements IComparable.CompareTo.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int CompareTo (
Object obj
)

Visual Basic [image] Copy Code

Public Function CompareTo( _
obj As Object _
) As Integer

Parameters

obj

Return Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.Equals Method

Pair.Equals Method
[image]

Object.Equals override.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

Return Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.GetHashCode Method

Pair.GetHashCode Method
[image]

Object.GetHashCode override.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair Properties

Pair Properties
[image]

Public Properties

Name | Description
FirstObject | Gets or sets the first pair object.
PairElements | Gets the elements of the pair as an arraylist.
SecondObject | Gets or sets the second pair object.

See Also

Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.FirstObject Property

Pair.FirstObject Property
[image]

Gets or sets the first pair object.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object FirstObject { get; set; }

Visual Basic [image] Copy Code

Public Property FirstObject As Object

Property Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.PairElements Property

Pair.PairElements Property
[image]

Gets the elements of the pair as an arraylist.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ArrayList PairElements { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PairElements As ArrayList

Property Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.SecondObject Property

Pair.SecondObject Property
[image]

Gets or sets the second pair object.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object SecondObject { get; set; }

Visual Basic [image] Copy Code

Public Property SecondObject As Object

Property Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.PartitionMethod Enumeration

PartitionMethod Enumeration
[image]

Identifies graph partitioning methods supported by CompositeLayout.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum PartitionMethod

Visual Basic [image] Copy Code

Public Enum PartitionMethod

Members

Member name | Description
BiconnectedComponents | Partition graphs by their biconnected components.
ShortestPath | Partition graphs by node paths distance.
Custom | Custom partitioning.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.Point3D Structure

Point3D Structure
[image]

Represents the coordinates of a point in a 3-dimensional space.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public struct Point3D

Visual Basic [image] Copy Code

Public Structure Point3D

See Also

Point3D Members
MindFusion.Layout Namespace


MindFusion.Layout.Point3D Members

Point3D Members
Constructors Properties
[image]

Represents the coordinates of a point in a 3-dimensional space.

The following tables list the members exposed by the Point3D type.

Public Constructors

Name | Description
Point3D | Initializes a new instance of the Point3D class.

Public Properties

Name | Description
X | Gets or sets the X coordinate of this point.
Y | Gets or sets the Y coordinate of this point.
Z | Gets or sets the Z coordinate of this point.

See Also

Point3D Structure
MindFusion.Layout Namespace


MindFusion.Layout.Point3D Constructor

Point3D Constructor
[image]

Initializes a new instance of the Point3D class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point3D (
float x,
float y,
float z
)

Visual Basic [image] Copy Code

Public New ( _
x As Single, _
y As Single, _
z As Single _
)

Parameters

x

y

z

See Also

Point3D Structure
MindFusion.Layout Namespace


MindFusion.Layout.Point3D Properties

Point3D Properties
[image]

Public Properties

Name | Description
X | Gets or sets the X coordinate of this point.
Y | Gets or sets the Y coordinate of this point.
Z | Gets or sets the Z coordinate of this point.

See Also

Point3D Structure
MindFusion.Layout Namespace


MindFusion.Layout.Point3D.X Property

Point3D.X Property
[image]

Gets or sets the X coordinate of this point.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float X { get; set; }

Visual Basic [image] Copy Code

Public Property X As Single

Property Value

See Also

Point3D Members
Point3D Structure
MindFusion.Layout Namespace


MindFusion.Layout.Point3D.Y Property

Point3D.Y Property
[image]

Gets or sets the Y coordinate of this point.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Y { get; set; }

Visual Basic [image] Copy Code

Public Property Y As Single

Property Value

See Also

Point3D Members
Point3D Structure
MindFusion.Layout Namespace


MindFusion.Layout.Point3D.Z Property

Point3D.Z Property
[image]

Gets or sets the Z coordinate of this point.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float Z { get; set; }

Visual Basic [image] Copy Code

Public Property Z As Single

Property Value

See Also

Point3D Members
Point3D Structure
MindFusion.Layout Namespace


MindFusion.Layout.PreferredRules Enumeration

PreferredRules Enumeration
[image]

Specifies which set of rules to use.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum PreferredRules

Visual Basic [image] Copy Code

Public Enum PreferredRules

Members

Member name | Description
ConnectorRules | Use connector rules.
NodeRules | Use node rules.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.RouteHeuristics Delegate

RouteHeuristics Delegate
[image]

The link routing algorithm uses a heuristic function of this type in its prediction steps.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate int RouteHeuristics (
Point start,
Point end
)

Visual Basic [image] Copy Code

Public Delegate Function RouteHeuristics( _
start As Point, _
end As Point _
) As Integer

Parameters

start

A Point specifying the first of the points, between which the distance is calculated.

end

A Point specifying the first of the points, between which the distance is calculated.

Return Value

An integer value indicating the calculated distance between the specified points.

Remarks

Functions of this type can be assigned to the RouteHeuristics property of the RoutingOptions class.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions Interface

RoutingOptions Interface
[image]

Allows customization of various aspects of the link routing algorithm.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface RoutingOptions

Visual Basic [image] Copy Code

Public Interface RoutingOptions

Inheritors

MindFusion.Diagramming.RoutingOptions

See Also

RoutingOptions Members
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions Members

RoutingOptions Members
Properties
[image]

Allows customization of various aspects of the link routing algorithm.

The following tables list the members exposed by the RoutingOptions type.

Public Properties

Name | Description
GridSize | Gets or sets the size of the pieces of the routing grid.
IgnoreAnchoring | For internal use.
LengthCost | Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.
NodeVicinityCost | Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.

See Also

RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions Properties

RoutingOptions Properties
[image]

Public Properties

Name | Description
GridSize | Gets or sets the size of the pieces of the routing grid.
IgnoreAnchoring | For internal use.
LengthCost | Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.
NodeVicinityCost | Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.

See Also

RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions.GridSize Property

RoutingOptions.GridSize Property
[image]

Gets or sets the size of the pieces of the routing grid.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

float GridSize { get; set; }

Visual Basic [image] Copy Code

Property GridSize As Single

Property Value

See Also

RoutingOptions Members
RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions.IgnoreAnchoring Property

RoutingOptions.IgnoreAnchoring Property
[image]

For internal use.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

bool IgnoreAnchoring { get; }

Visual Basic [image] Copy Code

ReadOnly Property IgnoreAnchoring As Boolean

Property Value

See Also

RoutingOptions Members
RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions.LengthCost Property

RoutingOptions.LengthCost Property
[image]

Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

byte LengthCost { get; }

Visual Basic [image] Copy Code

ReadOnly Property LengthCost As Byte

Property Value

See Also

RoutingOptions Members
RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions.NodeVicinityCost Property

RoutingOptions.NodeVicinityCost Property
[image]

Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

byte NodeVicinityCost { get; }

Visual Basic [image] Copy Code

ReadOnly Property NodeVicinityCost As Byte

Property Value

See Also

RoutingOptions Members
RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions.TurnCost Property

RoutingOptions.TurnCost Property
[image]

Gets or sets a value added to the total cost of a route if it makes a turn.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

byte TurnCost { get; }

Visual Basic [image] Copy Code

ReadOnly Property TurnCost As Byte

Property Value

See Also

RoutingOptions Members
RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys Class

SimpleKeys Class
[image]

Defines keys that can be used to define FlowLayout rules.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class SimpleKeys

Visual Basic [image] Copy Code

Public Class SimpleKeys

Inheritance Hierarchy

System.Object
MindFusion.Layout.SimpleKeys
MindFusion.Layout.FlowLayoutKeys

See Also

SimpleKeys Members
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys Members

SimpleKeys Members
Constructors Fields Properties Methods
[image]

Defines keys that can be used to define FlowLayout rules.

The following tables list the members exposed by the SimpleKeys type.

Public Constructors

Name | Description
SimpleKeys | Initializes a new instance of the SimpleKeys class.

Public Fields

Name | Description
ConnectorTypes | Specifies a list of connector identifiers.
FirstGroupLevelNegative | A rule defining which nodes should be placed above the "Control Flow" line. Associate an array of the node types logic identifiers with this key.
FirstGroupLevelPositive | A rule defining which nodes should be placed below the "Control Flow" line. Associate an array of the node types logic identifiers with this key.
GroupEndNodes | Specifies which nodes should be considered the end of the current sub-group. Associate an array of the node types logic identifiers with this key.
GroupStartNodes | Specifies which nodes should be considered the start of a new sub-group. Associate an array of the node types logic identifiers with this key.
MainConnectorOrientation | Specifies the orientation of the "Control Flow" sequence of links, and thus the main orientation for the layout.
MainSubgroupConnector | Defines which type of connectors can be used as guideline (defining the graph control flow).
PossibleConnection | Specifies what kind of node connections are allowed.

Public Properties

Name | Description
AllKeys | A list of all keys defined in this class.

Public Methods

Name | Description
ValidateRules | Checks if there is a rule for each key in the key list.

See Also

SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys Fields

SimpleKeys Fields
[image]

Public Fields

Name | Description
ConnectorTypes | Specifies a list of connector identifiers.
FirstGroupLevelNegative | A rule defining which nodes should be placed above the "Control Flow" line. Associate an array of the node types logic identifiers with this key.
FirstGroupLevelPositive | A rule defining which nodes should be placed below the "Control Flow" line. Associate an array of the node types logic identifiers with this key.
GroupEndNodes | Specifies which nodes should be considered the end of the current sub-group. Associate an array of the node types logic identifiers with this key.
GroupStartNodes | Specifies which nodes should be considered the start of a new sub-group. Associate an array of the node types logic identifiers with this key.
MainConnectorOrientation | Specifies the orientation of the "Control Flow" sequence of links, and thus the main orientation for the layout.
MainSubgroupConnector | Defines which type of connectors can be used as guideline (defining the graph control flow).
PossibleConnection | Specifies what kind of node connections are allowed.

See Also

SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.ConnectorTypes Field

SimpleKeys.ConnectorTypes Field
[image]

Specifies a list of connector identifiers.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string ConnectorTypes

Visual Basic [image] Copy Code

Public Shared ConnectorTypes As String

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.FirstGroupLevelNegative Field

SimpleKeys.FirstGroupLevelNegative Field
[image]

A rule defining which nodes should be placed above the "Control Flow" line. Associate an array of the node types logic identifiers with this key.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FirstGroupLevelNegative

Visual Basic [image] Copy Code

Public Shared FirstGroupLevelNegative As String

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.FirstGroupLevelPositive Field

SimpleKeys.FirstGroupLevelPositive Field
[image]

A rule defining which nodes should be placed below the "Control Flow" line. Associate an array of the node types logic identifiers with this key.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FirstGroupLevelPositive

Visual Basic [image] Copy Code

Public Shared FirstGroupLevelPositive As String

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.GroupEndNodes Field

SimpleKeys.GroupEndNodes Field
[image]

Specifies which nodes should be considered the end of the current sub-group. Associate an array of the node types logic identifiers with this key.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string GroupEndNodes

Visual Basic [image] Copy Code

Public Shared GroupEndNodes As String

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.GroupStartNodes Field

SimpleKeys.GroupStartNodes Field
[image]

Specifies which nodes should be considered the start of a new sub-group. Associate an array of the node types logic identifiers with this key.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string GroupStartNodes

Visual Basic [image] Copy Code

Public Shared GroupStartNodes As String

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.MainConnectorOrientation Field

SimpleKeys.MainConnectorOrientation Field
[image]

Specifies the orientation of the "Control Flow" sequence of links, and thus the main orientation for the layout.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string MainConnectorOrientation

Visual Basic [image] Copy Code

Public Shared MainConnectorOrientation As String

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.MainSubgroupConnector Field

SimpleKeys.MainSubgroupConnector Field
[image]

Defines which type of connectors can be used as guideline (defining the graph control flow).

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string MainSubgroupConnector

Visual Basic [image] Copy Code

Public Shared MainSubgroupConnector As String

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.PossibleConnection Field

SimpleKeys.PossibleConnection Field
[image]

Specifies what kind of node connections are allowed.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string PossibleConnection

Visual Basic [image] Copy Code

Public Shared PossibleConnection As String

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys Constructor

SimpleKeys Constructor
[image]

Initializes a new instance of the SimpleKeys class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SimpleKeys ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys Methods

SimpleKeys Methods
[image]

Public Methods

Name | Description
ValidateRules | Checks if there is a rule for each key in the key list.

See Also

SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.ValidateRules Method

SimpleKeys.ValidateRules Method
[image]

Checks if there is a rule for each key in the key list.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ValidateRules (
LayoutRules lr
)

Visual Basic [image] Copy Code

Public Function ValidateRules( _
lr As LayoutRules _
) As Boolean

Parameters

lr

Return Value

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys Properties

SimpleKeys Properties
[image]

Public Properties

Name | Description
AllKeys | A list of all keys defined in this class.

See Also

SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.AllKeys Property

SimpleKeys.AllKeys Property
[image]

A list of all keys defined in this class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ArrayList AllKeys { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AllKeys As ArrayList

Property Value

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleLinkLogic Class

SimpleLinkLogic Class
[image]

Contains link identifiers for the predefined SimpleRules set of rules.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class SimpleLinkLogic

Visual Basic [image] Copy Code

Public Class SimpleLinkLogic

Inheritance Hierarchy

System.Object
MindFusion.Layout.SimpleLinkLogic

See Also

SimpleLinkLogic Members
MindFusion.Layout Namespace


MindFusion.Layout.SimpleLinkLogic Members

SimpleLinkLogic Members
Constructors Fields
[image]

Contains link identifiers for the predefined SimpleRules set of rules.

The following tables list the members exposed by the SimpleLinkLogic type.

Public Constructors

Name | Description
SimpleLinkLogic | Initializes a new instance of the SimpleLinkLogic class.

Public Fields

Name | Description
Master | Identifier for the main connector type.
NotSpecified | Unspecified connector type.
Slave | Identifier for the secondary connector type.

See Also

SimpleLinkLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleLinkLogic Fields

SimpleLinkLogic Fields
[image]

Public Fields

Name | Description
Master | Identifier for the main connector type.
NotSpecified | Unspecified connector type.
Slave | Identifier for the secondary connector type.

See Also

SimpleLinkLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleLinkLogic.Master Field

SimpleLinkLogic.Master Field
[image]

Identifier for the main connector type.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string Master

Visual Basic [image] Copy Code

Public Shared Master As String

See Also

SimpleLinkLogic Members
SimpleLinkLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleLinkLogic.NotSpecified Field

SimpleLinkLogic.NotSpecified Field
[image]

Unspecified connector type.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string NotSpecified

Visual Basic [image] Copy Code

Public Shared NotSpecified As String

See Also

SimpleLinkLogic Members
SimpleLinkLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleLinkLogic.Slave Field

SimpleLinkLogic.Slave Field
[image]

Identifier for the secondary connector type.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string Slave

Visual Basic [image] Copy Code

Public Shared Slave As String

See Also

SimpleLinkLogic Members
SimpleLinkLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleLinkLogic Constructor

SimpleLinkLogic Constructor
[image]

Initializes a new instance of the SimpleLinkLogic class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SimpleLinkLogic ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SimpleLinkLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleNodeLogic Class

SimpleNodeLogic Class
[image]

Contains node identifiers for the predefined SimpleRules set of rules.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class SimpleNodeLogic

Visual Basic [image] Copy Code

Public Class SimpleNodeLogic

Inheritance Hierarchy

System.Object
MindFusion.Layout.SimpleNodeLogic

See Also

SimpleNodeLogic Members
MindFusion.Layout Namespace


MindFusion.Layout.SimpleNodeLogic Members

SimpleNodeLogic Members
Constructors Fields
[image]

Contains node identifiers for the predefined SimpleRules set of rules.

The following tables list the members exposed by the SimpleNodeLogic type.

Public Constructors

Name | Description
SimpleNodeLogic |

Public Fields

Name | Description
Action | Identifier for action nodes.
End | Identifier for group end nodes.
NotSpecified | Unspecified node type.
Start | Identifier for group start nodes.

See Also

SimpleNodeLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleNodeLogic Fields

SimpleNodeLogic Fields
[image]

Public Fields

Name | Description
Action | Identifier for action nodes.
End | Identifier for group end nodes.
NotSpecified | Unspecified node type.
Start | Identifier for group start nodes.

See Also

SimpleNodeLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleNodeLogic.Action Field

SimpleNodeLogic.Action Field
[image]

Identifier for action nodes.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string Action

Visual Basic [image] Copy Code

Public Shared Action As String

See Also

SimpleNodeLogic Members
SimpleNodeLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleNodeLogic.End Field

SimpleNodeLogic.End Field
[image]

Identifier for group end nodes.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string End

Visual Basic [image] Copy Code

Public Shared End As String

See Also

SimpleNodeLogic Members
SimpleNodeLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleNodeLogic.NotSpecified Field

SimpleNodeLogic.NotSpecified Field
[image]

Unspecified node type.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string NotSpecified

Visual Basic [image] Copy Code

Public Shared NotSpecified As String

See Also

SimpleNodeLogic Members
SimpleNodeLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleNodeLogic.Start Field

SimpleNodeLogic.Start Field
[image]

Identifier for group start nodes.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string Start

Visual Basic [image] Copy Code

Public Shared Start As String

See Also

SimpleNodeLogic Members
SimpleNodeLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleNodeLogic Constructor

SimpleNodeLogic Constructor
[image]

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SimpleNodeLogic ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SimpleNodeLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleOrientation Enumeration

SimpleOrientation Enumeration
[image]

Specifies the preferred orientation for the main connector type in FlowLayout.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum SimpleOrientation

Visual Basic [image] Copy Code

Public Enum SimpleOrientation

Members

Member name | Description
LeftToRight | Specifies left-to-right orientation.
RightToLeft | Specifies right-to-left orientation.
BottomToTop | Specifies bottom-to-top orientation.
TopToBottom | Specifies top-to-bottom orientation.
None | Unspecified orientation.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules Class

SimpleRules Class
[image]

Class of simple rules applicable to the Flowlayout algorithm.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class SimpleRules : LayoutRules

Visual Basic [image] Copy Code

Public Class SimpleRules
Inherits LayoutRules

Inheritance Hierarchy

System.Object
MindFusion.Layout.LayoutRules
MindFusion.Layout.SimpleRules

See Also

SimpleRules Members
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules Members

SimpleRules Members
Constructors Properties Methods
[image]

Class of simple rules applicable to the Flowlayout algorithm.

The following tables list the members exposed by the SimpleRules type.

Public Constructors

Name | Description
SimpleRules | Overloaded.

Public Properties

Name | Description
EndSubgproupNode | Defines which type of nodes will be used as a "sub group end" node;
MainConnectorOrientation | A key defining the space orientation of a "Control Flow" and respectively for the layout;
MainSubgproupConnector | Defines which type of connectors can be used as guideline (defining the graph control flow).
StartSubgproupNode | Defines which type of nodes will be used as a "sub group" start node.

Public Methods

Name | Description
AddLayoutRule | Overloaded. (Inherited from LayoutRules.)
BuildKey | Builds a key - object for the new rule, as a pair of two objects: obj1 and obj2. (Inherited from LayoutRules.)
GetLayoutRule | If there is rule with key - Key initializes - Value otherwise fails; (Inherited from LayoutRules.)
ValidateRules | Checks if there is a rule for each key in KeyList (Inherited from LayoutRules.)

See Also

SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules Constructor

SimpleRules Constructor
[image]

Overload List

Name | Description
SimpleRules () | Initializes a new instance of the SimpleRules class.
SimpleRules (ArrayList, ArrayList, String) | Initializes a new instance of the SimpleRules class.
SimpleRules (ArrayList, ArrayList, String, SimpleOrientation) | Initializes a new instance of the SimpleRules class.

See Also

SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules Constructor ()

SimpleRules Constructor ()
See Also
[image]

Initializes a new instance of the SimpleRules class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SimpleRules ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SimpleRules Constructor Overload List
SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules Constructor (ArrayList, ArrayList, String)

SimpleRules Constructor (ArrayList, ArrayList, String)
See Also
[image]

Initializes a new instance of the SimpleRules class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SimpleRules (
ArrayList strtSubGroupNodeType_ls,
ArrayList endSubGroupNodeType_ls,
string mainConnector
)

Visual Basic [image] Copy Code

Public New ( _
strtSubGroupNodeType_ls As ArrayList, _
endSubGroupNodeType_ls As ArrayList, _
mainConnector As String _
)

Parameters

strtSubGroupNodeType_ls

endSubGroupNodeType_ls

mainConnector

See Also

SimpleRules Constructor Overload List
SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules Constructor (ArrayList, ArrayList, String, SimpleOrientation)

SimpleRules Constructor (ArrayList, ArrayList, String, SimpleOrientation)
See Also
[image]

Initializes a new instance of the SimpleRules class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SimpleRules (
ArrayList strtSubGroupNodeType_ls,
ArrayList endSubGroupNodeType_ls,
string mainConnector,
SimpleOrientation mainConnectorOrdrDrctn
)

Visual Basic [image] Copy Code

Public New ( _
strtSubGroupNodeType_ls As ArrayList, _
endSubGroupNodeType_ls As ArrayList, _
mainConnector As String, _
mainConnectorOrdrDrctn As SimpleOrientation _
)

Parameters

strtSubGroupNodeType_ls

endSubGroupNodeType_ls

mainConnector

mainConnectorOrdrDrctn

See Also

SimpleRules Constructor Overload List
SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules Properties

SimpleRules Properties
[image]

Public Properties

Name | Description
EndSubgproupNode | Defines which type of nodes will be used as a "sub group end" node;
MainConnectorOrientation | A key defining the space orientation of a "Control Flow" and respectively for the layout;
MainSubgproupConnector | Defines which type of connectors can be used as guideline (defining the graph control flow).
StartSubgproupNode | Defines which type of nodes will be used as a "sub group" start node.

See Also

SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules.EndSubgproupNode Property

SimpleRules.EndSubgproupNode Property
[image]

Defines which type of nodes will be used as a "sub group end" node;

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ArrayList EndSubgproupNode { get; set; }

Visual Basic [image] Copy Code

Public Property EndSubgproupNode As ArrayList

Property Value

See Also

SimpleRules Members
SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules.MainConnectorOrientation Property

SimpleRules.MainConnectorOrientation Property
[image]

A key defining the space orientation of a "Control Flow" and respectively for the layout;

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SimpleOrientation MainConnectorOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property MainConnectorOrientation As SimpleOrientation

Property Value

See Also

SimpleRules Members
SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules.MainSubgproupConnector Property

SimpleRules.MainSubgproupConnector Property
[image]

Defines which type of connectors can be used as guideline (defining the graph control flow).

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string MainSubgproupConnector { get; set; }

Visual Basic [image] Copy Code

Public Property MainSubgproupConnector As String

Property Value

See Also

SimpleRules Members
SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules.StartSubgproupNode Property

SimpleRules.StartSubgproupNode Property
[image]

Defines which type of nodes will be used as a "sub group" start node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ArrayList StartSubgproupNode { get; set; }

Visual Basic [image] Copy Code

Public Property StartSubgproupNode As ArrayList

Property Value

See Also

SimpleRules Members
SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SpringLayoutMethod Enumeration

SpringLayoutMethod Enumeration
[image]

Specifies what energy model SpringLayout should use for the simulation.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum SpringLayoutMethod

Visual Basic [image] Copy Code

Public Enum SpringLayoutMethod

Members

Member name | Description
Classic | Use Hooke's law of elasticity to treat links as springs, and Coulomb's inverse square law to implement repulsion between nodes.
FruchtermanReingold | Use artificial attraction forces for links and repulsion forces for nodes that cancel each other at about the distance specified in NodeDistance, along with a simulated cooling schedule used for fine-tuning. Based on the method of Thomas Fruchterman and Edward Reingold.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.SpringLayoutTraits Enumeration

SpringLayoutTraits Enumeration
[image]

Indicates item traits specific to SpringLayout. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum SpringLayoutTraits

Visual Basic [image] Copy Code

Public Enum SpringLayoutTraits

Members

Member name | Description
Frozen | If the LayoutTraits value associated with a node through this key is true, SpringLayout considers the repulsion forces exerted by the node to other nodes, but ignores forces acting on the node and keeps it in place.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.SwimlaneLayoutTraits Enumeration

SwimlaneLayoutTraits Enumeration
[image]

Indicates item traits specific to swimlane layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum SwimlaneLayoutTraits

Visual Basic [image] Copy Code

Public Enum SwimlaneLayoutTraits

Members

Member name | Description
Lane | Specifies the lane to which a node should be assigned.
SortOrder | Specifies custom sort order of nodes in the same lane.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.TreeLayoutTraits Enumeration

TreeLayoutTraits Enumeration
[image]

Indicates item traits specific to tree layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum TreeLayoutTraits

Visual Basic [image] Copy Code

Public Enum TreeLayoutTraits

Members

Member name | Description
Assistant | If the LayoutTraits value associated with a node through this key is true, centered TreeLayout treats this node as an "assistant" during the arrangement. If the value is false or is not present, the node is treated as "subordinate". The associated value can also be of type AssistantType if it is required to specify the position of the assistant node relative to its parent. This value is considered when the EnableAssistants property of TreeLayout is set to true.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.TreeMapLayoutTraits Enumeration

TreeMapLayoutTraits Enumeration
[image]

Indicates item traits specific to tree map layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum TreeMapLayoutTraits

Visual Basic [image] Copy Code

Public Enum TreeMapLayoutTraits

Members

Member name | Description
HeaderSize | The header size of a master node in a tree-map layout.

See Also

MindFusion.Layout Namespace


Table of Predefined Shapes

Table of Predefined Shapes

Shape | Identifier | Common Uses
 | Actor | An user An actor in use case model
 | Alternative | An alternative in SDL An extraction in flowcharts Storage in quality management
 | Arrow1 | Use as desired
 | Arrow2 | Use as desired
 | Arrow3 | Transportation in quality management A reference point
 | Arrow4 | Use as desired
 | Arrow5 | Use as desired
 | Arrow6 | Use as desired
 | Arrow7 | A signal Electronic transmission of data
 | Arrow8 | Use as desired
 | Arrow9 | Use as desired
 | BeginLoop | Begin of a loop
 | BpmnComplex | BPMN Gateways: Complex Decision/Merge
 | BpmnDataBasedXor | BPMN Gateways: Data-Based Exclusive Decision/Merge (XOR)
 | BpmnEndCancel | BPMN Events: Cancel (End)
 | BpmnEndCompensation | BPMN Events: Compensation (End)
 | BpmnEndError | BPMN Events: Error (End)
 | BpmnEndLink | BPMN Events: Link (End)
 | BpmnEndMessage | BPMN Events: Message (End)
 | BpmnEndMultiple | BPMN Events: Multiple (End)
 | BpmnEndTerminate | BPMN Events: Terminate (End)
 | BpmnEventBasedXor | BPMN Gateways: Event-Based Exclusive Decision/Merge (XOR)
 | BpmnInclusive | BPMN Gateways: Inclusive Decision/Merge (OR)
 | BpmnIntermediateCancel | BPMN Events: Cancel (Intermediate)
 | BpmnIntermediateCompensation | BPMN Events: Compensation (Intermediate)
 | BpmnIntermediateError | BPMN Events: Error (Intermediate)
 | BpmnIntermediateLink | BPMN Events: Link (Intermediate)
 | BpmnIntermediateMessage | BPMN Events: Message (Intermediate)
 | BpmnIntermediateMultiple | BPMN Events: Multiple (Intermediate)
 | BpmnIntermediateRule | BPMN Events: Rule (Intermediate)
 | BpmnIntermediateTimer | BPMN Events: Timer (Intermediate)
 | BpmnParallelFork | BPMN Gateways: Parallel Fork/Join (AND)
 | BpmnStartLink | BPMN Events: Link (Start)
 | BpmnStartMessage | BPMN Events: Message (Start)
 | BpmnStartMultiple | BPMN Events: Multiple (Start)
 | BpmnStartRule | BPMN Events: Rule (Start)
 | BpmnStartTimer | BPMN Events: Timer (Start)
 | Cloud | Object instance in data flow diagrams
 | Collate | A collation in flowcharts
 | ConeDown | Use as desired
 | ConeUp | Use as desired
 | ConnectedIssues | Connected issues in quality management
 | CreateRequest | Request to create in SDL
 | Cross | Use as desired
 | Cube | Use as desired
 | Cylinder | Use as desired
 | Database | A database in flowcharts
 | DataTransmition | Electronic transmission of data
 | DDelay | Use as desired
 | Decagon | Use as desired
 | Decision | Decision in flowcharts A comparison in flowcharts Relationship in data flow diagrams
 | Decision2 | A decision in SDL
 | Delay | A delay in process diagrams
 | DInDelay | Use as desired
 | DirectAccessStorage | A direct access storage
 | DiskStorage | Data stored on disk in flowcharts
 | Display | Data that is displayed for human use
 | DividedEvent | An event
 | DividedProcess | A process or document in flowcharts Entity in data flow diagrams
 | Document | A document
 | Donut | Use as desired
 | DOutDelay | Use as desired
 | Ellipse | A cross-reference within the same page of a flowchart Process in data flow diagrams State in data flow diagrams A continuation of the flowchart in SDL An use case Operation in quality management
 | EndLoop | End of a loop
 | ExternalOrganization | An external organization
 | ExternalProcess | An external process
 | File | A file
 | FramedRectangle | Use as desired
 | Gate | A gateway
 | Heart | Use as desired
 | Heptagon | Use as desired
 | Hourglass | Use as desired
 | Input | Data that is input by manual means
 | InternalStorage | An internal storage
 | Interrupt | An interrupt
 | Interrupt2 | An interrupt
 | IsoProcess | Iso9000 process
 | Junction | A summing junction A return in SDL
 | Lightning | Use as desired
 | LinedDocument | A document in flowcharts
 | ManualOperation | Operation performed by a human
 | Merge | A merger in flowcharts Inbound goods in quality management Non-electronic file Stop state in data flow diagrams
 | MessageFromUser | A message from user side in SDL
 | MessageToUser | A message to user side in SDL
 | Microform | A microform
 | MicroformProcessing | A microform processing
 | MicroformRecording | A microform recording
 | MultiDocument | A multiple document in flowcharts
 | MultiProc | A multiple process or document in flowcharts
 | Octagon | Use as desired
 | OfflineStorage | An offline storage
 | OffpageConnection | A cross-reference to another page of a flowchart
 | OffpageReference | A cross-reference to another page of a flowchart A foreign module
 | Or | An 'or' statement
 | Pentagon | Use as desired
 | Plaque | Use as desired
 | PrimitiveFromCall | A primitive from call control in SDL
 | PrimitiveToCall | A primitive to call control in SDL
 | Procedure | Procedure in SDL
 | Process | A process or document in flowcharts A file or data storage
 | Prysm | Use as desired
 | PunchedCard | A punched card
 | PyramidDown | Use as desired
 | PyramidUp | Use as desired
 | Rectangle | A metric operation 'External interactor' in data flow diagrams Inspection in quality management
 | RightTriangle | Use as desired
 | RoundRect | A process or item in flowcharts An event An issue in quality management
 | RSave | Input or output data in flowcharts
 | Save | A save in SDL Input or output data in flowcharts
 | Sort | A sort operation
 | Sphere | Use as desired
 | Star | Use as desired
 | Star4Pointed | Use as desired
 | Star5Pointed | Use as desired
 | Star6Pointed | Use as desired
 | Star7Pointed | Use as desired
 | Star16Pointed | Use as desired
 | Star24Pointed | Use as desired
 | Star32Pointed | Use as desired
 | Start | Start of a program flow A starting point in SDL
 | Tape | Sequentially accessible data
 | Terminator | Start or end of a program flow
 | TransmittalTape | A transmittal tape
 | Trapezoid | Use as desired


Technical Support

Technical Support

Detailed information about everything connected with software products offered by MindFusion - online documentation, demos, information about forthcoming products can be found at http://www.mindfusion.eu/ [image] . The site is updated every day, so make sure you visit it regularly to catch up with the newest from us.

Apart from that, MindFusion employs a dedicated and technically proficient support team. This guarantees that all your questions and inquiries will be answered in quick and professional manner. They can be reached by e-mail at mailto:support@mindfusion.eu [image] or by phone at +359 889 199 729.

You can post a question about MvcDiagram on the discussion board:

http://mindfusion.eu/Forum/YaBB.pl?board=mvcdg_disc

or visit our help desk site:

http://mindfusion.eu/cgi/HelpDesk/index.php

We will be happy to hear any suggestions and recommendations you might have regarding MvcDiagram. We do take in account the opinion of every single person who has shown interest in our products.


MindFusion Products

MindFusion Products

MindFusion offers various programming components for different platforms. Below is a list of our products with links to their sections on our website as well link to download a trial version. Clients that have already purchased a product use an increasing discount for each subsequent one.

Diagramming | Links
Diagramming for WPF | Product Information Download
Diagramming for Silverlight | Product Information Download
Diagramming for WinForms | Product Information Download
Diagramming for ASP.NET | Product Information Download
Diagramming for ActiveX | Product Information Download
Diagramming for .NET Compact | Product Information Download
Diagramming for Java Swing | Product Information Download
Diagramming for JavaScript | Product Information Download
DiagramViewer for iOS/Cocoa Touch | Product Information Download
DiagramViewer for Android | Product Information Download

Charting | Links
Charting for WPF | Product Information Download
Charting for Silverlight | Product Information Download
Charting for WinForms | Product Information Download
Charting for ASP.NET | Product Information Download

Scheduling | Links
Scheduling for WinForms | Product Information Download
Scheduling for ASP.NET | Product Information Download
Scheduling for .NET Compact | Product Information Download
Scheduling for WPF | Product Information Download
Scheduling for Silverlight | Product Information Download
Scheduling for Java Swing | Product Information Download

Spreadsheet | Links
Spreadsheet for WinForms | Product Information Download
Spreadsheet for WPF | Product Information Download

Reporting | Links
Reporting for WinForms | Product Information Download
Reporting for WPF | Product Information Download
Reporting for Silverlight | Product Information Download

Mapping | Links
Mapping for WinForms | Product Information Download
Mapping for WPF | Product Information Download
Mapping for Silverlight | Product Information Download

Suites | Links
Pack for WPF | Product Information Download
Pack for WinForms | Product Information Download
Pack for ASP.NET | Product Information Download
Pack for Java FX | Product Information Download
Pack for Scheduling | Product Information Download
Pack for Silverlight | Product Information Download


Acknowledgements

Acknowledgements

Our thanks to:

  • Joe Stegman, who permitted us to use his PNGEncoder class in the MvcDiagram implementation.

  • Jon Harris, who permitted us to port his PQTree Java code for the MindFusion.GraphLib implementation.

  • Nader Alkhatib, who contributed his LogicGates project as a sample for the MvcDiagram package.

  • Mark James for the Silk icon set (http://www.famfamfam.com/lab/icons/silk/ [image] )

  • ic#code for their #ziplib [image] , used for implementing some custom MSI actions in MindFusion setup kits.


MindFusion.Diagramming.Commands.EditTextCmd Constructor

EditTextCmd Constructor
[image]

Initializes a new instance of the EditTextCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public EditTextCmd (
InplaceEditable item,
string newText
)

Visual Basic [image] Copy Code

Public New ( _
item As InplaceEditable, _
newText As String _
)

Parameters

item

The diagram element whose text will be changed.

newText

The new text.

See Also

EditTextCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ResizeTableColumnCmd Constructor

ResizeTableColumnCmd Constructor
[image]

Initializes a new instance of the ResizeTableColumnCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ResizeTableColumnCmd (
TableNode tableNode,
TableNode.Column column
)

Visual Basic [image] Copy Code

Public New ( _
tableNode As TableNode, _
column As TableNode.Column _
)

Parameters

tableNode

column

See Also

ResizeTableColumnCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ResizeTableRowCmd Constructor

ResizeTableRowCmd Constructor
[image]

Initializes a new instance of the ResizeTableRowCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ResizeTableRowCmd (
TableNode tableNode,
TableNode.Row row
)

Visual Basic [image] Copy Code

Public New ( _
tableNode As TableNode, _
row As TableNode.Row _
)

Parameters

tableNode

row

See Also

ResizeTableRowCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawVisioNodesBehavior Constructor

DrawVisioNodesBehavior Constructor
[image]

Initializes a new instance of the DrawVisioNodesBehavior class.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C# [image] Copy Code

protected DrawVisioNodesBehavior (
DiagramView diagramView
)

Visual Basic [image] Copy Code

Protected New ( _
diagramView As DiagramView _
)

Parameters

diagramView

The DiagramView this behavior will be associated with.

See Also

DrawVisioNodesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkVisioNodesBehavior Constructor

LinkVisioNodesBehavior Constructor
[image]

Initializes a new instance of the LinkVisioNodesBehavior class.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C# [image] Copy Code

protected LinkVisioNodesBehavior (
DiagramView diagramView
)

Visual Basic [image] Copy Code

Protected New ( _
diagramView As DiagramView _
)

Parameters

diagramView

The DiagramView this behavior will be associated with.

See Also

LinkVisioNodesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.DiagramPage Events

DiagramPage Events
[image]

Public Events

Name | Description
ActionRecorded | Raised when an action is recorded in the undo buffer. (Inherited from DiagramBase.)
ActionRecording | A validation event raised before an action is recorded in the undo buffer. (Inherited from DiagramBase.)
ActionRedone | Raised when an action is redone. (Inherited from DiagramBase.)
ActionUndone | Raised when an action is undone. (Inherited from DiagramBase.)
ActiveLayerChanged | Raised when the diagram's active layer has changed. (Inherited from DiagramBase.)
BeginLoad | Raised when the component starts loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
BoundsChanged | Raised when the Bounds property value has changed. (Inherited from DiagramBase.)
CellClicked | Raised when the user clicks a table’s cell. (Inherited from DiagramBase.)
CellDoubleClicked | Raised when the user double-clicks a table’s cell. (Inherited from DiagramBase.)
CellTextEdited | Raised when the user edits the text of a table’s cell. (Inherited from DiagramBase.)
CellTextEditing | A validation event that lets you approve or reject changes made to the text of a table’s cell. (Inherited from DiagramBase.)
Clicked | Raised when the user clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area. (Inherited from DiagramBase.)
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area. (Inherited from DiagramBase.)
ContentVisibilityChanged | Raised when the visibility of container's content changes. (Inherited from DiagramBase.)
DefaultShapeChanged | Raised when the DefaultShape property value has changed. (Inherited from DiagramBase.)
DeserializeTag | Raised when the Tag of a diagram item must be deserialized from XML format. (Inherited from DiagramBase.)
DestinationAnchorChanged | Raised when the DestinationAnchor property value of a link has changed. (Inherited from DiagramBase.)
DirtyChanged | Raised when the Dirty property value has changed. (Inherited from DiagramBase.)
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
DrawAdjustmentHandles | Raised when item’s adjustment handles must be custom drawn. (Inherited from DiagramBase.)
DrawAnchorPoint | Raised when an anchor point must be custom drawn. (Inherited from DiagramBase.)
DrawBackground | Raised to let you custom draw the diagram background. (Inherited from DiagramBase.)
DrawCell | Raised when a table’s cell must be custom drawn. (Inherited from DiagramBase.)
DrawForeground | Raised to let you custom draw the diagram foreground. (Inherited from DiagramBase.)
DrawLink | Raised when a diagram link must be custom drawn. (Inherited from DiagramBase.)
DrawNode | Raised when a diagram node must be custom drawn. (Inherited from DiagramBase.)
EndLoad | Raised when the component ends loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
ExpandButtonClicked | Raised when the user clicks the [±] button of an Expandable node. (Inherited from DiagramBase.)
GroupDestroyed | Raised when a Group object is destroyed. (Inherited from DiagramBase.)
HitTestAdjustmentHandles | Raised when custom hit testing of item’s adjustment handles must be performed. (Inherited from DiagramBase.)
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created. (Inherited from DiagramBase.)
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created. (Inherited from DiagramBase.)
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
LayerVisibilityChanged | Raised when the visibility of a Layer changes. (Inherited from DiagramBase.)
LinkActivated | Raised when a link becomes the ActiveItem. (Inherited from DiagramBase.)
LinkClicked | Raised when the user clicks a link. (Inherited from DiagramBase.)
LinkCreateCancelled | Raised when the user cancels link creation. (Inherited from DiagramBase.)
LinkCreated | Raised when the user draws a new link. (Inherited from DiagramBase.)
LinkCreating | A validation event raised while the user is drawing a new link. (Inherited from DiagramBase.)
LinkDeactivated | Raised when a link is no longer the ActiveItem. (Inherited from DiagramBase.)
LinkDeleted | Raised when a link is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkDeselected | Raised when a link is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDoubleClicked | Raised when the user double-clicks a link. (Inherited from DiagramBase.)
LinkModified | Raised when the user moves any control point of a link. (Inherited from DiagramBase.)
LinkModifyCancelled | Raised when the user cancels move or resize operation being done on a link. (Inherited from DiagramBase.)
LinkModifying | A validation event raised while the user is modifying a link. (Inherited from DiagramBase.)
LinkPasted | Raised when a link has been pasted from the clipboard. (Inherited from DiagramBase.)
LinkPointed | Raised when the mouse pointer hovers over a link. (Inherited from DiagramBase.)
LinkRouted | Raised when a link is routed by the auto-routing algorithm. (Inherited from DiagramBase.)
LinkSelected | Raised when a link is selected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkSelecting | Raised when the user tries to select a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkSplit | Raised when the user splits a link interactively. (Inherited from DiagramBase.)
LinkStartModifying | A validation event raised when the user starts modifying a link. (Inherited from DiagramBase.)
LinkTextEdited | Raised when the user edits the text of a link. (Inherited from DiagramBase.)
LinkTextEditing | A validation event that lets you approve or reject changes made to the text of a link. (Inherited from DiagramBase.)
MeasureUnitChanged | Raised when the MeasureUnit property value has changed. (Inherited from DiagramBase.)
NodeActivated | Raised when a node becomes the ActiveItem. (Inherited from DiagramBase.)
NodeClicked | Raised when the user clicks a node. (Inherited from DiagramBase.)
NodeCreateCancelled | Raised when the user cancels node creation. (Inherited from DiagramBase.)
NodeCreated | Raised when the user draws a new node. (Inherited from DiagramBase.)
NodeCreating | A validation event raised while the user is drawing a new node. (Inherited from DiagramBase.)
NodeDeactivated | Raised when a node is no longer the ActiveItem. (Inherited from DiagramBase.)
NodeDeleted | Raised when a node is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeDeselected | Raised when a node is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDoubleClicked | Raised when the user double-clicks a node. (Inherited from DiagramBase.)
NodeModified | Raised when the user moves or resizes a node. (Inherited from DiagramBase.)
NodeModifyCancelled | Raised when the user cancels move or resize operation being done on a node. (Inherited from DiagramBase.)
NodeModifying | A validation event raised while the user is moving or resizing a node. (Inherited from DiagramBase.)
NodePasted | Raised when a node has been pasted from the clipboard. (Inherited from DiagramBase.)
NodePointed | Raised when the mouse pointer hovers over a node. (Inherited from DiagramBase.)
NodeSelected | Raised when a node is selected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeSelecting | Raised when the user tries to select a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeStartModifying | A validation event raised when the user starts modifying a node. (Inherited from DiagramBase.)
NodeTextEdited | Raised when the user edits the text of a node. (Inherited from DiagramBase.)
NodeTextEditing | A validation event that lets you approve or reject changes made to the text of a node. (Inherited from DiagramBase.)
OriginAnchorChanged | Raised when the OriginAnchor property value of a link has changed. (Inherited from DiagramBase.)
QueryAlignTarget | Raised to validate a node as target for alignment guides when AutoAlignNodes is enabled. (Inherited from DiagramBase.)
Repaint | Raised when the diagram views should be repainted. (Inherited from DiagramBase.)
RequestCacheReset | Raised when an object within the diagram requests a reset of the cached bitmap. (Inherited from DiagramBase.)
RequestClipboard | Raised when an object within the diagram requests an operation with the clipboard. (Inherited from DiagramBase.)
RequestTimer | Raised when an object within the diagram needs to start or stop a timer. (Inherited from DiagramBase.)
SelectionChanged | Raised when an item is added to or removed from the selection (Inherited from DiagramBase.)
SelectionModified | Raised when the user moves multiple selected items. (Inherited from DiagramBase.)
SelectionModifying | Raised while the user is moving multiple selected items, this event lets you cancel the modification. (Inherited from DiagramBase.)
SerializeTag | Raised when the Tag of a diagram item must be serialized into an XML document. (Inherited from DiagramBase.)
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape. (Inherited from DiagramBase.)
ShapeModified | Raised when the user modifies the shape of a ShapeNode by moving one of the control points corresponding to shape formula parameters. (Inherited from DiagramBase.)
TableColumnResized | Raised when the user finishes resizing a column in a table. (Inherited from DiagramBase.)
TableColumnResizing | Raised when the user resizes a column in a table interactively. (Inherited from DiagramBase.)
TableRowResized | Raised when the user finishes resizing a row in a table. (Inherited from DiagramBase.)
TableRowResizing | Raised when the user resizes a row in a table interactively. (Inherited from DiagramBase.)
TableSectionCollapsed | Raised when the user collapses the rows of a table’s section by clicking the [-] button in the section's header row. (Inherited from DiagramBase.)
TableSectionExpanded | Raised when the user expands the rows of a table's section by clicking the [+] button in the section’s header row. (Inherited from DiagramBase.)
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node. (Inherited from DiagramBase.)
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node. (Inherited from DiagramBase.)
TreeItemTextEditing | A validation event that lets you approve or reject changes made to the text of a TreeViewNode's item. (Inherited from DiagramBase.)
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point. (Inherited from DiagramBase.)
ViewRemoved | Raised when a DiagramView is detached from this diagram. (Inherited from DiagramBase.)

See Also

DiagramPage Class


MindFusion.Diagramming.Commands.EditTextCmd.Execute Method

EditTextCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

EditTextCmd Members
EditTextCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.EditTextCmd.Redo Method

EditTextCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

EditTextCmd Members
EditTextCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.EditTextCmd.Undo Method

EditTextCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

EditTextCmd Members
EditTextCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ResizeTableColumnCmd.Execute Method

ResizeTableColumnCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

ResizeTableColumnCmd Members
ResizeTableColumnCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ResizeTableColumnCmd.Redo Method

ResizeTableColumnCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

ResizeTableColumnCmd Members
ResizeTableColumnCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ResizeTableColumnCmd.Undo Method

ResizeTableColumnCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

ResizeTableColumnCmd Members
ResizeTableColumnCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ResizeTableRowCmd.Execute Method

ResizeTableRowCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

ResizeTableRowCmd Members
ResizeTableRowCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ResizeTableRowCmd.Redo Method

ResizeTableRowCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

ResizeTableRowCmd Members
ResizeTableRowCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ResizeTableRowCmd.Undo Method

ResizeTableRowCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

ResizeTableRowCmd Members
ResizeTableRowCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Manipulators.Button.OnClick Method

Button.OnClick Method
[image]

Manipulator.HitTest override.

Namespace: MindFusion.Diagramming.Manipulators
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void OnClick (
PointF point
)

Visual Basic [image] Copy Code

Public Overrides Sub OnClick( _
point As PointF _
)

Parameters

point

See Also

Button Members
Button Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator.Apply Method

Manipulator.Apply Method
[image]

Calls OnClick with argument transformed to local coordinates if necessary.

Namespace: MindFusion.Diagramming.Manipulators
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Apply (
PointF diagramCoord
)

Visual Basic [image] Copy Code

Public Sub Apply( _
diagramCoord As PointF _
)

Parameters

diagramCoord

A PointF instance specifying diagram coordinates.

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator.Cancel Method

Manipulator.Cancel Method
[image]

Called when the manipulator should cancel the current manipulation.

Namespace: MindFusion.Diagramming.Manipulators
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void Cancel ()

Visual Basic [image] Copy Code

Public Overridable Sub Cancel ()

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator.OnClick Method

Manipulator.OnClick Method
[image]

Runs the action associated with this manipulator.

Namespace: MindFusion.Diagramming.Manipulators
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract void OnClick (
PointF point
)

Visual Basic [image] Copy Code

Public MustOverride Sub OnClick( _
point As PointF _
)

Parameters

point

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator.SetMouseCursor Method

Manipulator.SetMouseCursor Method
[image]

Returns the cursor that should be displayed when the mouse pointer is over this manipulator.

Namespace: MindFusion.Diagramming.Manipulators
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual CursorHint SetMouseCursor (
PointF point
)

Visual Basic [image] Copy Code

Public Overridable Function SetMouseCursor( _
point As PointF _
) As CursorHint

Parameters

point

A PointF specifying mouse position in diagram coordinates.

Return Value

A member of the CursorHint enumeration.

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawVisioNodesBehavior.CreateNode Method

DrawVisioNodesBehavior.CreateNode Method
[image]

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C# [image] Copy Code

protected override DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

DrawVisioNodesBehavior Members
DrawVisioNodesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkVisioNodesBehavior.CreateNode Method

LinkVisioNodesBehavior.CreateNode Method
[image]

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C# [image] Copy Code

protected override DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

LinkVisioNodesBehavior Members
LinkVisioNodesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.Commands.EditTextCmd.Item Property

EditTextCmd.Item Property
[image]

Gets the diagram element changed by this command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public InplaceEditable Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As InplaceEditable

Property Value

See Also

EditTextCmd Members
EditTextCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ResizeTableColumnCmd.TableNode Property

ResizeTableColumnCmd.TableNode Property
[image]

Gets a reference to table affected by this operation.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode TableNode { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TableNode As TableNode

Property Value

See Also

ResizeTableColumnCmd Members
ResizeTableColumnCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ResizeTableRowCmd.TableNode Property

ResizeTableRowCmd.TableNode Property
[image]

Gets a reference to table affected by this operation.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode TableNode { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TableNode As TableNode

Property Value

See Also

ResizeTableRowCmd Members
ResizeTableRowCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.WinForms.DiagramView.LicenseKey Property

DiagramView.LicenseKey Property
[image]

Gets or sets the license key of the control.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C# [image] Copy Code

public string LicenseKey { get; set; }

Visual Basic [image] Copy Code

Public Property LicenseKey As String

Property Value

A string value.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.TabbedDiagramView.MaxTabSize Property

TabbedDiagramView.MaxTabSize Property
[image]

Gets or sets the maximum size of the tabs.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C# [image] Copy Code

public int MaxTabSize { get; set; }

Visual Basic [image] Copy Code

Public Property MaxTabSize As Integer

Property Value

An integer value. The default is 100.

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.Commands.EditTextCmd Class

EditTextCmd Class
[image]

Represents undoable edit operations.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class EditTextCmd : Command

Visual Basic [image] Copy Code

Public Class EditTextCmd
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.EditTextCmd

See Also

EditTextCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.EditTextCmd Properties

EditTextCmd Properties
[image]

Public Properties

Name | Description
Item | Gets the diagram element changed by this command.

See Also

EditTextCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.EditTextCmd Members

EditTextCmd Members
Constructors Properties Methods
[image]

Represents undoable edit operations.

The following tables list the members exposed by the EditTextCmd type.

Public Constructors

Name | Description
EditTextCmd | Initializes a new instance of the EditTextCmd class.

Public Properties

Name | Description
Item | Gets the diagram element changed by this command.

Protected Methods

Name | Description
Execute | Carries out the command action.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

EditTextCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.EditTextCmd Methods

EditTextCmd Methods
[image]

Protected Methods

Name | Description
Execute | Carries out the command action.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

EditTextCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ResizeTableColumnCmd Class

ResizeTableColumnCmd Class
Remarks See Also
[image]

Implements resizing of table's columns.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ResizeTableColumnCmd : Command

Visual Basic [image] Copy Code

Public Class ResizeTableColumnCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming in response to resizing table's columns interactively. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.ResizeTableColumnCmd

See Also

ResizeTableColumnCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ResizeTableColumnCmd Properties

ResizeTableColumnCmd Properties
[image]

Public Properties

Name | Description
TableNode | Gets a reference to table affected by this operation.

See Also

ResizeTableColumnCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ResizeTableColumnCmd Members

ResizeTableColumnCmd Members
Constructors Properties Methods
[image]

Implements resizing of table's columns.

The following tables list the members exposed by the ResizeTableColumnCmd type.

Public Constructors

Name | Description
ResizeTableColumnCmd | Initializes a new instance of the ResizeTableColumnCmd class.

Public Properties

Name | Description
TableNode | Gets a reference to table affected by this operation.

Protected Methods

Name | Description
Execute | Carries out the command action.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ResizeTableColumnCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ResizeTableColumnCmd Methods

ResizeTableColumnCmd Methods
[image]

Protected Methods

Name | Description
Execute | Carries out the command action.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ResizeTableColumnCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ResizeTableRowCmd Class

ResizeTableRowCmd Class
Remarks See Also
[image]

Implements resizing of table's rows.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ResizeTableRowCmd : Command

Visual Basic [image] Copy Code

Public Class ResizeTableRowCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming in response to resizing table's rows interactively. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.ResizeTableRowCmd

See Also

ResizeTableRowCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ResizeTableRowCmd Properties

ResizeTableRowCmd Properties
[image]

Public Properties

Name | Description
TableNode | Gets a reference to table affected by this operation.

See Also

ResizeTableRowCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ResizeTableRowCmd Members

ResizeTableRowCmd Members
Constructors Properties Methods
[image]

Implements resizing of table's rows.

The following tables list the members exposed by the ResizeTableRowCmd type.

Public Constructors

Name | Description
ResizeTableRowCmd | Initializes a new instance of the ResizeTableRowCmd class.

Public Properties

Name | Description
TableNode | Gets a reference to table affected by this operation.

Protected Methods

Name | Description
Execute | Carries out the command action.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ResizeTableRowCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ResizeTableRowCmd Methods

ResizeTableRowCmd Methods
[image]

Protected Methods

Name | Description
Execute | Carries out the command action.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ResizeTableRowCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.WinForms.ControlNodeStyle Events

ControlNodeStyle Events
[image]

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

ControlNodeStyle Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawVisioNodesBehavior Class

DrawVisioNodesBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.DrawVisioNodes.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C# [image] Copy Code

public class DrawVisioNodesBehavior : DrawNodesBehavior

Visual Basic [image] Copy Code

Public Class DrawVisioNodesBehavior
Inherits DrawNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.WinForms.Interaction
MindFusion.Diagramming.WinForms.Behaviors.BehaviorBase
MindFusion.Diagramming.WinForms.Behaviors.DrawNodesBehavior
MindFusion.Diagramming.WinForms.Behaviors.DrawVisioNodesBehavior

See Also

DrawVisioNodesBehavior Members
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawVisioNodesBehavior Members

DrawVisioNodesBehavior Members
Constructors Methods
[image]

This class is used when the diagram behavior is set to Behavior.DrawVisioNodes.

The following tables list the members exposed by the DrawVisioNodesBehavior type.

Protected Constructors

Name | Description
DrawVisioNodesBehavior | Initializes a new instance of the DrawVisioNodesBehavior class.

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

See Also

DrawVisioNodesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawVisioNodesBehavior Methods

DrawVisioNodesBehavior Methods
[image]

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

See Also

DrawVisioNodesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkVisioNodesBehavior Class

LinkVisioNodesBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.LinkVisioNodes.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C# [image] Copy Code

public class LinkVisioNodesBehavior : LinkNodesBehavior

Visual Basic [image] Copy Code

Public Class LinkVisioNodesBehavior
Inherits LinkNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.WinForms.Interaction
MindFusion.Diagramming.WinForms.Behaviors.BehaviorBase
MindFusion.Diagramming.WinForms.Behaviors.LinkNodesBehavior
MindFusion.Diagramming.WinForms.Behaviors.LinkVisioNodesBehavior

See Also

LinkVisioNodesBehavior Members
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkVisioNodesBehavior Members

LinkVisioNodesBehavior Members
Constructors Methods
[image]

This class is used when the diagram behavior is set to Behavior.LinkVisioNodes.

The following tables list the members exposed by the LinkVisioNodesBehavior type.

Protected Constructors

Name | Description
LinkVisioNodesBehavior | Initializes a new instance of the LinkVisioNodesBehavior class.

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

See Also

LinkVisioNodesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkVisioNodesBehavior Methods

LinkVisioNodesBehavior Methods
[image]

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

See Also

LinkVisioNodesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace