Introduction

DiagramRT Programmer's Guide
Introduction

DiagramRT is a general-purpose software component that can be used to display various types of diagrams and charts, in many different formats. It is implemented as a WinRT control and can be easily integrated into any application targeting the Microsoft WinRT platform. By providing your software with ready to use capabilities for visualizing and editing relational data, DiagramRT saves you from hundreds of hours of coding and debugging efforts.

DiagramRT can give graphical representation to:

  • Workflow processes
  • Class relationships
  • Graphs and networks
  • Entity-relationship / database diagrams
  • IVR systems
  • Industrial automation processes
  • Genealogy trees
  • Algorithms and flowcharts
  • Organizational charts
  • XML documents
  • Classification hierarchies
  • And much more

DiagramRT provides intuitive user-interaction model for creating or editing diagrams. In addition, its programmatic interface places at your disposal many useful functions, ranging from printing and XML serialization to path-finding and automatic layout algorithms.

© 2015 MindFusion


General Information

General Information

The DiagramRT Component

  • Redistribution is royalty free
  • Assembly is strong-named
  • Can be purchased with source code
  • Is written in C#

User Interaction

  • Several user interaction modes
  • Scrolling and zooming
  • Copy and paste support
  • Panning
  • Automatic scrolling while dragging items with the mouse
  • Alignment to grid
  • Node alignment guides
  • Multiple selection
  • Tool-tips
  • Docking points can be defined for nodes
  • Undo / redo support
  • Links can auto-snap to nearest node

Programming

  • Programmatic access to the diagram elements
  • Numerous properties for customizing appearance and behavior
  • Numerous utility methods
  • Path finding and cycle detection
  • Rich event set

Store and Retrieve Diagrams into/from

  • Files
  • .NET streams
  • ASCII strings
  • XML documents

Diagram Elements

  • Use any WinRT control as a diagram node
  • More than 100 predefined node shapes
  • Ability to define custom shapes and shape libraries
  • Rotation of shapes at arbitrary angles
  • Container nodes
  • Tables with unlimited number of rows and columns
  • Table cells can span several columns and rows
  • Assign diagram items to layers
  • Display hierarchical data in TreeView nodes
  • Sections of table rows can be expanded or collapsed
  • Links can comprise multiple segments
  • Link segments can be straight lines or curves
  • Display multiple labels per link
  • Support for custom node and link types

Automatic Layout

  • Spring-Embedder graph layout
  • Directional tree layout
  • Radial tree layout
  • Fractal tree layout
  • Layered graph layout
  • Grid layout
  • Simulated Annealing graph layout
  • One-way graph layout
  • Orthogonal graph layout
  • Circular graph layout
  • Topological graph layout
  • Source code flowchart layout
  • Decision flowchart layout
  • Process diagrams layout
  • Tree map layout
  • Swimlane diagrams layout
  • Cascading graph layout
  • Hierarchical graph layout
  • Triangular graph layout
  • Multi-level graph layout
  • Automatic link routing

Appearance

  • Nodes can display images and text
  • Various text alignment styles
  • Text can be laid out in polygonal areas
  • Styled HTML-like text formatting
  • Customizable fonts and colors
  • Custom painting of nodes
  • Shadows
  • User-assigned mouse cursors
  • Z-order
  • Rich choice of pen and brush styles
  • Transparent nodes
  • Invisible nodes
  • Embossment and shadow dispersion visual effects
  • A background swimlane grid

Behavior

  • Lock diagram elements
  • Read-only mode supported
  • Tables can be scrolled
  • Collapse and expand hierarchy branches
  • In-place text editing
  • Dynamic positioning of links relative to connected nodes

Link Diagram Items

  • Nodes to nodes
  • Table rows to table rows
  • Nodes to table rows
  • Unconnected links

Auxiliary Controls

  • Ruler control
  • VirtualizingDiagram control
  • NodeListView control
  • LayerListView control
  • TabbedDiagramView control
  • Zoom control


What's New in this Release

What's New in this Release

The list below describes recent changes and additions to DiagramRT:

New in version 1.2

Foldable containers

Set the Foldable property of ContainerNode to let users fold and unfold containers by clicking up/down arrow in their caption bars. The Folded property lets you fold or unfold containers programmatically. When folded, the child nodes of a container are hidden and its height is set to the caption bar height. The control raises ContainerFolded and ContainerUnfolded events when users fold or unfold a container interactively.

Improved arrowhead rendering

  • Arrowheads are rendered as a single path when possible and several arrowhead Shape definitions have been changed to implement mitered joints when HeadStrokeThickness is set to a bigger value.
  • The point where end segments connect to arrowheads can be specified via the LinkSegmentInset property of the Shape class. Shape definitions from the ArrowHeads class set it to suitable default value. This allows using transparent or semi-transparent brushes without seeing the link line drawn behind arrowheads.

License keys

There is no separate trial build of the control assemblies anymore. Instead, set the LicenseKey property to disable the component's evaluation mode and stop displaying trial messages. If your application contains more than one Diagram instance or other controls by MindFusion, you could call MindFusion.Licensing.LicenseManager.AddLicense(key) to specify the key once instead of setting it per each control. License key strings are listed on the Keys & Downloads page at MindFusion's customer portal.

Miscellaneous

  • Set the Brush property of LinkLabel to fill the background of link labels.
  • The Anchoring.Keep option is now honored by OrthogonalRouter.
  • The ChangeUnit method sets a new MeasureUnit and scales the coordinates of diagram items to keep them the same size.
  • Fixed node spacing in bottom-to-top TreeLayout.
  • The updateLinks parameter of SetBounds lets you specify whether link positions should change when setting node's new position.

New in version 1.1

Tree map layout

Tree maps represent hierarchies by nesting child nodes within their parents, where the areas of leaf nodes are proportional to their Weight values. Unlike other layout algorithms, TreeMapLayout expects hierarchies to be defined via grouping or containment (see AttachTo method and ContainerNode class), and will ignore any links in the diagram. The diagram area covered by the topmost nodes in a hierarchy is specified via the LayoutArea property. By default, the layout tries to keep the ratio of node sides as close as possible to one. However this could make it hard to distinguish separate levels of the hierarchy. To alleviate that, set Squarify to false, and child nodes will be arranged either as a row or a column inside their parent node, alternating directions for each level. The drawback is that when Weight ratios differ greatly or nodes contain many children, some nodes could end up with very narrow rectangles.

Decision flowchart layout

DecisionLayout arranges simple flowcharts consisting of decision boxes with up to three outgoing links per node and activity boxes with a single outgoing link per node. The nodes are arranged in columns and rows, whose distance depends on the HorizontalPadding and VerticalPadding property values. When links share the same row or column, they are placed at a distance specified via LinkPadding. The layout arranges nodes recursively starting from StartNode. If StartNode is not specified, the algorithm selects the root of the deepest branch of the graph's spanning tree as start node.

Miscellaneous

  • Layout algorithms now automatically resize diagram's Bounds if it's not large enough to fit the arranged content. To revert to old behavior and keep fixed Bounds size, set GrowToFit to false.
  • LinkLabels are now copied by DiagramLink copy constructor and clipboard methods.
  • ContainerNode now displays a caption bar when its Shape is set to Rectangle or RoundRect. The caption bar height is controlled via the CaptionHeight property.


Version History

Version History

The list below describes recent changes and additions to DiagramRT:

New in version 1.0.1

Zoom control

The ZoomControl class lets users change interactively the current zoom level and scroll position of a Diagram. To set it up, add a ZoomControl to the page, place it anywhere over the target diagram, and set the control's Target property to that diagram. Set the ZoomStep and ScrollStep properties to specify the amount added to view's zoom level or scroll position by ZoomControl's buttons. You can customize the control's appearance by setting properties such as Fill, Stroke, CornerRadius and TickPosition.

Miscellaneous

  • Enable the AllowRenamePages property of TabbedDiagramView to let users rename a DiagramPage interactively by clicking its tab.
  • Several new stock shapes added: RightTriangle, Decagon, Trapezoid, Star4Pointed, Star5Pointed, Star6Pointed, Star7Pointed, Star16Pointed, Star24Pointed, Star32Pointed, Donut, Plaque.
  • New RoundAndSquare and RoundAndSquare2 handle styles can be set as the HandlesStyle of nodes.
  • The projection of a node on the scales of Ruler control now shows the boundaries of the rotated node shape. To ignore rotation as in older versions, set ProjectRotatedBounds to false.
  • The ScrollZoneSize property specifies the size of the region near viewport borders that triggers auto-scrolling.
  • Set the HandlesStyle property of nodes to Custom to implement custom appearance and hit-testing for adjustment handles. The control raises DrawAdjustmentHandles and HitTestAdjustmentHandles events for such nodes.
  • The SetSelfLoopShape event is raised when a link becomes a self-loop, giving you a chance to set a custom shape for the link.
  • The SelectionMoving and SelectionMoved events have been renamed to SelectionModifying and SelectionModified respectively.
  • Various bug fixes.
  • The selection handles are now smaller but provide a larger hit-test box for easier interaction on touch devices.


Getting Started

Getting Started

Creating a new WinRT Application using Microsoft Visual Studio 2013

  • Select File -> New -> Project from the Visual Studio menu.
  • In the New Project dialog box, expand the Templates -> Visual C# -> Windows Store node (or alternatively Templates -> Other Languages -> Visual Basic -> Windows Store node) and select the Blank App (XAML) project template from the pane in the middle.
  • Fill in the name of the application (for example MyApp), the location and, optionally, the solution name, and click OK.
  • Visual Studio automatically creates and opens a blank project for the Windows Store with all required files to get you started.
  • Activate the Solution Explorer by pressing CTRL+ALT+L or by selecting View -> Solution Explorer from the menu.
  • The App.xaml file represents the application. Application-scope resources can be defined in the resource dictionary of the application. The MainPage.xaml contains the primary window of the application, defined in XAML, and the MainPage.xaml.cs (or MainPage.xaml.vb) file contains the window's code-behind, such as additional initialization and event handlers.
  • Double-click on MainPage.xaml to open the window for editing in the Visual Studio desiger.

Adding the DiagramRT controls to the Visual Studio Toolbox

  • Activate the Visual Studio Toolbox by pressing CTRL+ALT+X or by selecting View -> Toolbox from the menu.
  • Create a new category tab by right-clicking anywhere within the Toolbox' client area and selecting Add Tab from the context menu. Enter the name of the new tab (for example, MindFusion.Diagramming) and press ENTER.
  • Initially the tab does not contain any controls. Make sure the tab is selected and expanded and right-click on the tab title or inside the tab area and select Choose Items from the context menu.
  • In the Choose Toolbox Items dialog select the Windows XAML Components tab and click the Browse button. Navigate to the MindFusion.Diagramming.dll and MindFusion.Diagramming.Controls.dll assemblies, select them and click OK. These assemblies are located in the 'CLR4 (.NET 4.0 and .NET 4.5)' subfolder of the installation folder (usually C:\Program Files\MindFusion\MindFusion.Diagramming for WinRT).
  • The newly created Toolbox tab is now populated with all controls from the two assemblies. You can drag any of the controls from the toolbox onto the design surface of the window to create the respective control and add it to the window.
  • Creating a control from the Toolbox automatically adds the required references to the project as well as the required XML namespace declarations. If Visual Studio does not add the references automatically, open the Solution Explorer, right-click on the References section and choose Add Reference. Navigate to the MindFusion.Diagramming.dll, MindFusoin.Diagramming.Controls.dll, and MindFusion.Graphs.dll and click OK.

Adding the Diagram control to the application

While the MainPage is open in the Visual Studio designer, drag the Diagram item from the Toolbox and drop it anywhere on the page's surface. This will create a new Diagram object at the drop location. The markup of the Diagram will look similar to the following:

XAML [image] Copy Code

<Diagramming:Diagram HorizontalAlignment="Left" Margin="407,222,0,-577" VerticalAlignment="Top"/>

Note that the Diagramming namespace is automatically declared in the page tag:

XAML [image] Copy Code

xmlns:Diagramming="using:MindFusion.Diagramming"

You can adjust the position of the diagram, set the desired properties and handle the necessary events. To be able to access the Diagram object in the code-behind of the page, set a name to the diagram:

XAML [image] Copy Code

<Diagramming:Diagram x:Name="myDiagram"...

Now, you can access the diagram in the code-behind, after the InitialzeComponent call in the page's constructor. For example, you can create nodes and links in the diagram like this:

C# [image] Copy Code

this.InitializeComponent();
var node1 = myDiagram.Factory.CreateShapeNode(10, 10, 50, 50);
var node2 = myDiagram.Factory.CreateShapeNode(100, 100, 50, 50);
myDiagram.Factory.CreateDiagramLink(node1, node2);

Setting the properties of the Diagram control

You can set the control properties either by typing them directly in the XAML code or through the Properties Window. To display the Properties Windows, select View -> Properties Window from the menu. For example, set the AlignToGrid property to true and Background to DarkTurquoise:

XAML [image] Copy Code

<Diagramming:Diagram x:Name="myDiagram" AlignToGrid="True" Background="DarkTurquoise"...

Running the application

Press F5 or click Start Debugging to run the application.


Programming Interface Overview

Programming Interface Overview


Diagram Structure

Diagram Structure


Standard Item Types

Standard Item Types

Diagram elements in DiagramRT are represented by ShapeNode, ContainerNode, TableNode, ControlNode and DiagramLink instances. Combined and linked together, they can form complex data structures such as process or entity-relationship diagrams, class hierarchies, networks and graphs. Each of their rich features can be customized through numerous methods and properties.

Shape Nodes

Shape nodes can represent geometric shapes, flowchart elements, icons in network diagrams, and so on. They can display both graphics and text in different fonts, sizes and colors. There are more than 100 predefined node shapes and apart from them, DiagramRT offers an easy way to define custom shapes. ShapeNode appearance can be customized further by adding UIElement-derived objects to the Canvas contained in each node.

Table Nodes

Tables can be used to represent table schemas in database diagrams or classes in class-hierarchies. A table contains cells arranged in a grid, and every cell can display text and/or image. Cells, columns and rows can be customized in various ways - there are properties available for setting their extents, style, image and text alignment. Tables' dimensions can be programmatically changed; inserting, appending or deleting rows and columns can be done in a very comprehensive, intuitive way whenever you might need it. Tables can also display background images and graphics.

Container Nodes

A ContainerNode can contain other diagram nodes. When a container is moved, the contained nodes move too. Containers can be folded to hide the contained nodes, and unfolded back to show them again. Nodes inside a container can be linked to nodes both inside and outside of it. When a container is folded, the links connecting its children with outside nodes align to the container's outlines. Containers can be nested within each other to unlimited depth.

Control Hosts

A ControlNode can host any WinRT control. The hosted control might be any of the standard WinRT types such as DataGrid or Button. Custom controls are also supported. A ControlNode can be connected with links to any other nodes - control nodes, shapes or tables.

TreeView Nodes

The TreeViewNode class represents nodes that can display hierarchical data. The root items displayed in the node can be accessed through the RootItems property. New items can be added to and removed from the returned collection. The root items can have child items on their own and so on. For more information, refer to the TreeViewItem class.

Links

Links are used to represent various types of connections and relations in diagrams. DiagramRT offers three basic link types:

  • polyline links composed of straight-line segments;
  • curved links composed of Bézier-spline segments;
  • Cascading links composed of horizontal and vertical segments, alternating their orientation so that every segment is orthogonal to its neighbor.

A link can be connected to a node at each of the link's ends. It is also possible to have unconnected links - having one or both of their ends not connected to nodes. Some customizable link's properties are: arrowheads, style, text, pen width and style, modification behavior and number of segments.

See Also

 Controlling User Interaction


Creating and Deleting Items

Creating and Deleting Items

Creating Items Programmatically

In order to add a new node or link to a diagram, create an instance of the item class by using the new operator and add it to the diagram's Nodes or Links collection. This works the same way for adding both items from your custom class or ones from the DiagramRT predefined types.

There are several shortcut methods provided for creating instances of the predefined node and link types. The methods are members of the diagram's Factory object:

  • The CreateShapeNode method creates a ShapeNode at the specified position.
  • The CreateTableNode method creates a TableNode at a specified position.
  • The CreateContainerNode method creates a ContainerNode at the specified position.
  • There are several overloads of the CreateDiagramLink method that allow connecting two nodes of the same type or of different types.

Drawing New Items

Users can draw diagram elements with the mouse. The Behavior property specifies what type of elements should be created when a user starts drawing. When an item is created, an initialization event is raised to let you customize the item appearance before showing it on the screen. The initialization events include InitializeNode and InitializeLink. While items are being drawn, the control raises validation events such as NodeCreating to let you validate the operation and prevent creating items at a specific location. When the user releases the mouse button, the item is added to the collection that contains items from the same type (for example Nodes) and an event is raised, for example NodeCreated.

Deleting Items

Call the Remove method of the Nodes or Links collection to delete an item from the diagram. The ClearAll method clears diagram contents by deleting all items.


Accessing Items

Accessing Items

One of the most common tasks when using the component is iterating over all items in the diagram document or navigating through the connections between items - from a node to the incoming or outgoing links, or from a link to its origin and destination nodes. To enumerate items of a diagram use the Items, Links or Nodes collections. The nodes that a link connects are referenced by the link's Destination and Origin properties. To access the links that are connected to a node, use its IncomingLinks and OutgoingLinks collections. The first collection contains references to all links pointing to the node, the second - to the links that start from it. Links can connect to rows of a table; to find such links use table's Rows collection and the IncomingLinks and OutgoingLinks collections. A shortcut for accessing the other end of a relation in entity-relationship diagrams is provided by the RelatedOneToMany and RelatedManyToOne properties of the Row class.

Selected Items

If only one item is selected, it is considered the active item and can be accessed with the ActiveItem property. The type of this property is DiagramItem; you can get the actual type of the selected item through WinRT reflection. Multiple items can be selected when clicking or dragging with the CTRL key pressed at the same time. Multiple-selection is represented by the Selection property of the Diagram class. The Selection object provides collections to access the selected Links and Nodes.

Finding Items

You can search for diagram items by their tag using the FindLink and FindNode methods. Tag objects are compared by calling the Equals method of the System.Object class. Thus if the tags are of value type, they are compared by value (that is bitwise equality). If they are of reference type their Equals method is used. If there are more items with the same tag, the first one will be returned. If no item with the specified tag exists, a null reference (Nothing in Visual Basic) will be returned.


Collapsing and Expanding Tree Branches

Collapsing and Expanding Tree Branches

If a diagram represents a tree structure, the tree branch starting from a node can be collapsed or expanded again in order to hide or display hierarchy details. To enable this, set the Expandable property. To get or set whether a tree branch is expanded or collapsed, use the Expanded property of its root node.

Displaying Expand/Collapse Button

If the Expandable property of a node is set to true, there is a [±] button displayed beside the node to allow users to collapse or expand the tree branch starting there. The button location can be customized through the diagram's ExpandButtonPosition property, and its color change through ExpandButtonBrush. By default, pressing that button automatically toggles the Expanded property of the node and raises the TreeExpanded or TreeCollapsed events.

Defining Tree Direction

A node can be connected to other nodes through outgoing and incoming links. Setting the ExpandOnIncoming property specifies which items connected to a node will be regarded as its descendants. If ExpandOnIncoming is false (default value) then each node will be regarded as a parent of its outgoing links and the items attached to them. If ExpandOnIncoming is set to true, the node's incoming links define its children. So that property specifies the direction of parent-children relationship between diagram items and respectively the overall direction in which collapsing / expanding is done.

Expanding a Branch Recursively

Use the RecursiveExpand property to specify whether the whole tree branch starting from a node will be shown when expanding, or only the first level of descendants.

Custom Expand/Collapse Functionality

The ExpandButtonAction property lets you override the standard functionality of the [±] button. Set this property to RaiseEvents and handle the ExpandButtonClicked event if you need to implement your own expand/collapse logic.


Layers

Layers

Items can be assigned to layers, and layers can be hidden, locked or moved up/down in the Z order as a group. Layer objects provide Visible, Locked and ZIndex properties, which will affect all items in the respective layer. Layers also expose a Title property shown in the LayerListView control. Newly drawn items are added to the layer specified via Diagram.ActiveLayer.

Set the LayerIndex property of items to associate them with layers in the Diagram.Layers collection. If LayerIndex has the default value of -1, the item is not associated with any layer and its visibility depends only on the item's own Visible property.

Layer list control

The LayerListView control provides user interface for working with Layer objects. The control presents a list of the specified Diagram's layers, showing their title and an overview image of the objects in each layer, and also allows editing of layer's Visible and Locked properties and choosing the Diagram's currently active layer. New layers can be added to the Diagram by clicking the + button and removed by clicking the - button.


Attaching and Grouping Items

Attaching and Grouping Items

DiagramRT allows attaching a node to another node, establishing a subordinate - master relationship between them. The easiest way to attach nodes is to call the AttachTo method. When a master node is moved, its subordinated nodes follow it, so that the initial distance between the nodes stays constant. This happens both when a user moves the master node around, and when the node position is changed using a method or a property.

Possible Uses

  • Attach a Transparent shape node to another node and set its Text, so that the shape node acts as an additional label assigned to the master node.
  • Attach a shape node to another node and set its Image, so it acts as an additional icon displayed inside or near the master node.
  • Attach a shape node or a table to another node and handle NodeClicked or similar events to perform some action on the master node. This makes the subordinated node act as a button or another type of UI element attached to the master node.
  • In all previous cases, the Locked property can be set for attached nodes, which are used only as decorations embellishing the main item. That prevents users from selecting, modifying or drawing links to the subordinates.
  • Attach child elements in a tree branch to the branch root, so that when a user moves a tree node, the node's children moves simultaneously with it. Modifying an item in such hierarchical group makes the modification pervade through all dependant subordinated items.

Hierarchical Grouping

Every node in a group can be the master node of another group, that is, a node can be subordinate in one group and meanwhile be another group's master. DiagramRT doesn't impose any limits to the depth and width of group hierarchies built that way. However, it is not possible to put a node as a subordinate in more than one groups because the hierarchy relations would become ambiguous.

Unions

It is possible to create such groups, that if any item in the hierarchy is modified, all other items are updated too. This can be done by putting the items in circular chain of dependencies - that is, item1 is attached to item2, item2 to item3 ... itemN to item1. If any of these items is modified, the change will propagate through the chain until it reaches its originator.

Accessing Group Items

The master node in a group can be accessed using the MasterNode property of attached nodes. The AttachedNodes collection of a master node contains references to all subordinate nodes attached to it.


Multiple Diagram Pages

Multiple Diagram Pages

The DiagramDocument class represents a collection of diagram pages or sheets, represented by DiagramPage objects. New pages can be added to the document and existing pages can be removed and reordered via the Pages collection. The SaveToXml methods of DiagramDocument save all pages in a single file, and respectively the LoadFromXml methods load all pages from the file. DiagramDocument can also load files created by the serialization methods of Diagram, and will show them in a single page. Note that the opposite is not true: Diagram cannot load directly a DiagramDocument file.

DiagramPage is derived from Diagram and only adds a Title property, so any code that processes Diagram objects will work with DiagramPage objects too. A diagram document forwards each event raised by its pages, giving you a chance to use the same handler for events raised by different pages. If a page should implement distinct user interaction or validation logic, it is also possible to attach handlers to the Diagram events inherited by DiagramPage.

The package includes a TabbedDiagramView control that presents all pages of a document in a tabbed user interface where each tab corresponds to a page. The page displayed in the active tab is exposed by the CurrentPage property of TabbedDiagramView. The active page can be changed interactively by activating its associated tab. New pages can be added and removed to/from the document through buttons in the tab tray and the pages can be rearranged by dragging their associated tabs with the mouse.


User Interaction

User Interaction


Controlling User Interaction

Controlling User Interaction

There are several ways to control user actions on the diagram as a whole, or on individual items in the diagram.

Specify How User's Actions are Interpreted

The Behavior property provides several predefined sets of rules specifying how user input with the mouse or keyboard is interpreted. If Behavior is set to LinkShapes, mouse dragging started from an unoccupied point of the document is processed as a ShapeNode creation request and dragging over a node creates a link.

Note

Such behavior leads to some extra work when creating overlaying nodes - users need to draw the second node on an empty area and move it over the first one afterwards. If you want to avoid that, use the DrawShapes behavior.

If LinkTables is set, dragging the mouse over an empty area creates a table and dragging over a table creates a link. Behavior options also include DrawLinks, DrawTables and Modify.

Validation Events

The control raises various validation events during user interaction. While the user draws new items, there are the NodeCreating and LinkCreating events raised. While modifying existing items, there are the NodeModifying and LinkModifying events raised. Setting the Cancel argument to true prevents the operation being completed at the current location. Calling their CancelDrag method immediately stops the user interaction. When the user presses the Del key, the control raises NodeDeleting or LinkDeleting to give you a chance to prevent the operation.

Setting Diagram Bounds

DiagramNode's size can be get or set with the Bounds property. By default, users are able to move items outside the diagram bounds. To prevent this, enable the RestrictItemsToBounds property. It provides three options to restrict item positions. They might not be restricted at all. The most restrictive option is to keep items entirely inside the document area. Another option allows items to be partially outside the document area but having at least a small visible part inside.

The Canvas property gets a Canvas area of the Diagram. To add an item or a Selection to the Canvas area, use the respective AddToCanvas method.

Item Constraints

Constraints upon how users are allowed to modify a node are set through the Constraints and EnabledHandles properties. The former can be used to constrain the move direction, node size and aspect ratio. The latter enables or disables specific manipulation handles of a node. That allows making the node non-moveable, non-resizable, or resizable only horizontally/vertically.

Items can be locked by seting the Locked property. Locked items are excluded from selection and users cannot select, move or modify them.

Control How Links Connect to Nodes

The AllowIncomingLinks property of the DiagramNode class lets you specify whether incoming links can be drawn to a node. The AllowOutgoingLinks property lets you do that for outgoing links.
Anchor points define where link's ends should be placed when a user attaches a link to a node. A pattern of anchor points can be assigned to a node by setting the node's AnchorPattern. Additionally, the LinkCreating and LinkModifying validation events provide you with further control over the user's actions.

In-place Text Editing

The text of nodes and tables can be edited in-place by double-clicking the respective items. To enable the feature set the AllowInplaceEdit property to true. For tables, both captions and cells can be edited in this way. Depending on the type of item being edited, one of these events can be fired when editing completes: NodeTextEdited, LinkTextEdited. In-place editing mode is exited when users click outside the text entry control. Pressing ENTER or ESC exits in-place editing mode if respectively InplaceEditAcceptOnEnter and InplaceEditCancelOnEsc are enabled.

Miscellaneous

  • AllowMultipleResize specifies whether the user can resize multiple selected items simultaneously.
  • AllowUnconnectedLinks specifies whether the user is allowed to draw links that are not connected to a node.


Single and Multiple Selection

Single and Multiple Selection

Selecting and Modifying Items

In order to move or modify a diagram element, users drag its adjustment handles. Adjustment handles appear around an item when it is selected. Each handle can be dragged to perform specific transformation on the item. The appearance and behavior of modification handles can be altered by the HandlesStyle property. Depending on the value assigned to ModificationStart, those handles can also appear automatically when the mouse pointer hovers over an item.

Active Item

If only one diagram item is selected, it is considered the 'active' item. One of the items in a multiple-selection is also regarded as active; it is usually the one selected last. The active item has white modification handles drawn around it, while other items in multiple-selection have gray handles. The active item is probably the one users are most interested in while editing a diagram, and your program can update its state and user-interface according to that. Access to the active item is provided by the ActiveItem property of the Diagram class.

Multiple-Selection

Selection of diagram items in is represented by an instance of the Selection class. This class provides methods to programmatically select or deselect items and properties that specify how the selection looks and behaves. A property of the Diagram class, also called Selection, exposes the items selected within the current document. Multiple items can be selected, thus moved at the same time. To programmatically add items to or remove them from the multiple-selection invoke one of the AddItem, and RemoveItem methods. The Clear method deselects all items and the Change method selects a single item, deselecting all others. Setting AllowMultipleSelection to false disables multiple selection.

Drawing a Selection Rectangle

To select multiple items, users must draw a selection rectangle with the left mouse button while holding down the CTRL key. The MiddleButtonActions and RightButtonActions properties let you enable drawing the selection rectangle using the middle or right mouse button.

Appearance

The visual style of selection handles is defined through the attributes exposed by ActiveItemHandlesStyle, SelectedItemHandlesStyle and DisabledHandlesStyle properties. Colors of the selection rectangle can be changed by setting the selection's Stroke and Brush properties. Another property related to selection visualization is the diagram's SelectionOnTop, which specifies whether selected items must be painted according to their z-order position or on top of the non-selected items.

Enumerating Items

The Selection class exposes the selected items as WinRT collections. The Items collection references all selected items, getting them as DiagramItem instances. The Nodes and Links collections keep references to the selected items of specific classes. Alternatively you might enumerate all items in the diagram and check their Selected property.

Automatic Selection

Setting the SelectAfterCreate property to true automatically selects each newly created item, so users can modify it immediately.


Automatic Alignment

Automatic Alignment

The following features help the user align items interactively.

Alignment Grid

Items are aligned to a grid when AlignToGrid is enabled. More information is available in the Alignment Grid topic.

Align nodes to nodes

If AutoAlignNodes is enabled, the node currently being drawn or resized is aligned to another node so that a pair of their vertical or horizontal sides become collinear. To specify the maximal distance at which nodes are aligned, set the AutoAlignDistance property. The pair of aligned nodes is indicated visually by drawing an alignment guide using the pen assigned to AlignmentGuidePen.

Snap links to nearby nodes

The currently drawn or modified link can automatically snap to the nearest border point of the nearest node when AutoSnapLinks is set. The maximal distance at which links will connect to a nearby node is set via AutoSnapDistance.


Clipboard Operations

Clipboard Operations

A single diagram item or a selection of items can be copied or cut to the Windows clipboard. This is done programmatically using the CopyToClipboard and CutToClipboard methods. To paste the clipboard contents into the current diagram call PasteFromClipboard.

MindFusion.Diagramming does not provide keyboard interface to clipboard operations. You might assign the standard CTRL+C, CTRL+X and CTRL+V shortcuts to menu items and handle them by calling the respective methods.


Handling Events

Handling Events

Most events are raised only in response to users actions. If you need to execute the same code after user actions and API calls, move the common code to a method and invoke the method both in the respective event handler and after the API method or property setter call. A notable exception is the *Deleted set of events (NodeDeleted, LinkDeleted), which are also raised when items are deleted programmatically, because in some circumstances deleting an item could delete other items related to it.

When a user starts drawing a new item with the mouse, the control raises an initialization event to let you set the appearance properties of the item. That is, for a node, the control raises InitializeNode.

While the user is holding down the mouse button and drawing, a validation event is raised to let you cancel the item creation (for example, NodeCreating). If the action is not cancelled, a creation event is raised to let your application know about the new item (for example, NodeCreated). There are events raised when users modify items, for example, NodeModifying and NodeModified. Call the CancelDrag method to cancel the item modification or creation from the *Modifying or *Creating events raised for nodes or links.

When a user presses the DEL key, there is a validation event raised to let you confirm deleting an item (for example, NodeDeleting), and if not cancelled, there is an item-deleted event raised (for example, NodeDeleted).

There are many other events related to various activities a user could carry out on the diagram. The full set of events can be found here:
Diagram Events


Scrolling and Zooming

Scrolling and Zooming

In order to enable scrolling, you must place the Diagram control inside a ScrollViewer or a Ruler.

Diagram Size

The diagram size is set through the Bounds property. Its value is a Rect instance that specifies the origin of the diagram coordinate system and the diagram size. The diagram can be resized automatically when the user moves or resizes nodes, as specified by the AutoResize property value. Call ResizeToFitItems after building a diagram programmatically to make it fit its items.

Programmatic Scrolling

Use the ScrollX and ScrollY properties to get the current scroll position or to scroll the document contents programmatically. These properties correspond to the HorizontalOffset and VerticalOffset values of the parent ScrollViewer, but are converted to the current MeasureUnit.

Zooming

Zooming is controlled by the ZoomFactor property. The zoom factor is expressed as a percentage, 100% meaning no zoom. Higher than 100% makes the diagram items look closer and bigger on the screen - zooming in. Less than 100% makes items look further and smaller on screen - zooming out. To zoom and scroll the view so it fits a specified rectangular document area to the control's client area, call ZoomToRect.

Panning

The diagram view can be panned by holding SHIFT while dragging the mouse with the left button down. To enable panning without using the SHIFT key, set Behavior to Pan.

Zoom control

The ZoomControl class lets users change interactively the current zoom level and scroll position of a Diagram. To set it up, add a ZoomControl to the page, place it anywhere over the target diagram, and set the control's Target property to that diagram. Set the ZoomStep and ScrollStep properties to specify the amount added to view's zoom level or scroll position by ZoomControl's buttons. You can customize the control's appearance by setting properties such as Fill, Stroke, CornerRadius and TickPosition.


In-place Editing the Contents of Items

In-place Editing the Contents of Items

Standard in-place editing

To activate the standard in-place editing of the text of DiagramRT objects, set the AllowInplaceEdit property to true. AllowInplaceEdit allows in-place editing the content of a diagram element by double-clicking it. In-place editing mode can be accepted and exited by clicking anywhere outside the text-field.

If you want to change the way of accepting and rejecting changes, the following Diagram properties allow by pressing the ENTER and ESC keys to perform that: InplaceEditAcceptOnEnter and InplaceEditCancelOnEsc. When InplaceEditAcceptOnEnter is set to true, pressing the ENTER key causes accepting changes and exiting in-place editing mode. If InplaceEditAcceptOnEnter is set to false, pressing ENTER inserts a new line in the text while in-place editing mode is active. If InplaceEditCancelOnEsc is set to true, pressing the ESC key performs rejecting changes and exiting in-place editing mode.

In-place editing can be applied to the following properties: ShapeNode.Text, DiagramLink.Text, Cell.Text, and TableNode.Caption. For tables, both captions and cells can be edited in this way.

If you want to enable or disable in-place editing of a specific table's cell, handle the CellTextEditing event. To enable or disable in-place editing of nodes, handle the NodeTextEditing event. For a DiagramLink object, the LinkTextEditing event is raised while in-place editing. These validation events let you prevent users from editing the text in the particular object if it is necessary.

When in-place editing of a node is completed, the NodeTextEdited event is raised. For a table's cell, handle the CellTextEdited event. LinkTextEdited event is raised when in-place editing of a DiagramLink object completes.

By default, DiagramRT creates a TextBox control to let users edit item's text. The EnterInplaceEditMode event allows customizing the properties of that control, or attaching event handlers to it. InplaceEditFont specifies the font of the in-place edited text box. Actually, InplaceEditFont is assigned to the Font property of that text box.

When leaving in-place editing mode, the LeaveInplaceEditMode event is raised. This event is raised in all cases of closing the in-place editing control, for example, when the user accepts or cancels the changes made to an item's text, or when the EndEdit method is called.

To enter in-place editing mode programmatically and let users edit an item's text inline, call the BeginEdit method of Diagram. The EndEdit method exits in-place editing mode.

In-place editing of custom items

The InplaceEditable interface allows implementing the standard in-place editing for custom defined items. By means of the methods of this interface, you can specify the position of the in-place editing textbox control and copy the entered text to a property of the edited item. GetEditRect returns the destination rectangle of the in-place editing box. GetTextToEdit represents the initial contents of the in-place editing box. SetEditedText sets the edited text to the object after completing the in-place editing.


Undo and Redo

Undo and Redo

If the UndoEnabled property is set to true, the control records users actions and allows undoing them later. The records are stored in a list, and can be undone consecutively by calling the Undo method. An action that has been undone can be redone by calling the Redo method. You can enable or disable UI elements that undo or redo commands by binding them to the CanUndo and CanRedo properties.

The control also runs and saves in the undo history AddItemCommand and RemoveItemCommand commands when items are programmatically added or removed from the Items collection of the Diagram. No other changes are recorded automatically when done from code. If support for undo/redo of such changes is required, they must be done through the ExecuteCommand method.

To allow undoing changes of DiagramItem properties, create a ChangeItemCommand instance before setting the property values, and call ExecuteCommand afterwards. Any other types of undoable changes can be implemented by deriving from the Command class and overriding its Execute, Undo and Redo methods.


Placement and Layout

Placement and Layout


Items Placement - Position, Size and Z-order

Items Placement - Position, Size and Z-order

Location and Size of Nodes

Use the Bounds property to get or change the location and size of a node. To find nodes located at a specific position in the diagram, call the GetNodeAt method. To find a node in the vicinity of a point, call GetNearestNode.

Links Control Points

Links have two or more control points, depending on their Shape and SegmentCount. You can get access to the control points by the link's ControlPoints collection. You must call UpdateFromPoints after moving control points of a link; that's needed in order to repaint the link and update its internal state variables. The Bounds property is read-only. It returns the smallest rectangle that bounds all link points. To find a link that passes near a specific point of the diagram, call the GetLinkAt method.

Link Dynamics

The Dynamic property of a link can be enabled to make the link automatically recalculate its end point positions if the nodes connected to the link are moved or resized; the end points are moved in such a way that the link points to the centers of the connected nodes.

Links have an AutoRoute property that enables or disables automatic routing of a link. Routed links avoid nodes by finding the shortest path between their origin and destination that does not cross any other nodes. The link routing algorithm can be tuned by using the properties exposed by RoutingOptions.

The AutoSnapLinks and AutoSnapDistance properties specify whether links should automatically snap to the nearest node while their end points are being moved.

Interactive Moving or Resizing

End-users of your application can move or resize the diagram elements. They do this by selecting an item and dragging any of its adjustment handles, a point inside its interior, any of its sides or a selection frame. The HandlesStyle property of nodes controls how interaction can be performed. Additionally it defines the representation of selected items on screen. EnabledHandles lets you disable specific manipulations users are allowed to perform on a node, for example resizing the item horizontally or moving it. If an item is modified interactively, the NodeModified or LinkModified event is raised, depending on the item's type.

Controlling the Z-order

The Z-order defines how items are ordered on the Z-axis - so that one looks above or below another. You can use the ZIndex property to get or set the index of an item within the Z-order array.


Alignment Grid

Alignment Grid

DiagramRT provides an alignment grid to help users place the diagram items more precisely. To activate the grid, set the AlignToGrid property to true. If the grid is active while an item is being created or modified, the item's control-points are aligned to the nearest grid points. The distance between adjacent grid points is set by the GridSizeX and GridSizeY properties. The GridOffsetX and GridOffsetY properties allow specifying the horizontal and vertical offset of the first point in the alignment grid.

Items created or modified by a user are automatically aligned to the grid. However, if items are placed in the diagram programmatically, their coordinates are set to the specified positions without aligning. In such cases use AlignPointToGrid if items must be placed exactly at grid points.

The grid can be either visible or invisible, depending on whether the ShowGrid value is true or false. If visible, the grid is painted as a matrix of points or as series of crossing lines, as specified by the GridStyle property. GridColor defines the color with which the alignment points or lines are painted.


Lanes Grid

Lanes Grid

The classes from the MindFusion.Diagramming.Lanes namespace let you develop process maps and lane diagrams, useful in business process planning and reporting. Processes consist of consecutive operations accomplished by people involved, technical installations, means of contact, and flow of information. The DiagramLite lane grid features allow indicating and arranging related diagram items in complicated processes and systems, such as Swimlane diagrams (known as Rummler-Brache diagram) or Gantt Charts (planning and scheduling of projects). A lane in the grid can visually contain nodes, links, shapes or images, that represent tasks fulfilled in specified periods of time by people, companies or departments.

The MindFusion.Diagramming.Lanes namespace provides the Grid, Header, HeaderCollection and Style classes, the ICell interface and the ResizeType enumeration. These types expose additional properties and methods that let you define your own grids as required by your application logic. Grids can include varying number of lanes, divided into child rows and columns whose intersections form cells. The cells color and style can be customized too.

Use the EnableLanes property of the Diagram class to display lanes in your application. The LaneGrid lets you setup the rows and columns in the grid by defining horizontal and vertical lanes, where each lane can be titled by its own header and/or subheadings. The grid can be resized by setting the ColumnCount and RowCount properties or by adding headers to the ColumnHeaders and RowHeaders collections. A column or row can be divided into child elements by adding to the SubHeaders collection of a Header, which lets you form a complex hierarchy of unlimited depth. The intersection of rows and columns can be either a simple cell for bottommost elements in the hierarchy, or a group of cells for parent rows and columns. Cells or cell groups can be accessed via the grid class Item property, that lets you index cells either by their integer positions, or by their Header objects.

If the AllowResizeHeaders property of the Grid class is enabled, users can resize the grid columns and rows as desired. The CellBoundsChanged event is raised when a cell is resized. An application can handle this event in order to rearrange or resize nodes so that they stay within a specific column or row of the grid.

The position of the grid and grid headers within the diagram is defined via TopMargin and LeftMargin, which specify the grid offset relative to Bounds. HookHeaders enables lane headers to be anchored to the left or right side of the control's visible area. The sizes of headers at different levels in the lane hierarchy can be set in a single operation by the RowHeadersWidths and ColumnHeadersHeights properties.

The appearance of the lanes grid can be customized further via the AlignCells property, which specifies whether cells are aligned to each other, the HeadersOnTop poperty, which specifies whether headers should appear on top of the Z-order, and the TopLeftAreaStyle specifying the appearance of the grid's top-left corner.

The Grid class provides many miscellaneous methods that can be used to find grid elements, for determining their bounds and for hit-testing: FindColumn, FindRow, GetCellBounds, GetCellColumn, GetCellFromPoint, GetCellRow, GetColumn, GetRow, GetRowIndex, GetColumnHeaderBounds, GetColumnIndex, GetHeaderBounds, GetRowHeaderBounds, GetHeaderFromPoint.


Laying Out Diagrams Automatically

Laying Out Diagrams Automatically

Applications that process hierarchical or more complex entity-relationship data might need to present that data to end-users in an aesthetical and visually appealing manner. Such applications would store their data as graph of connected nodes possibly having additional information attached to them. However, position and size coordinates of nodes might be unnecessary and/or unavailable. DiagramRT provides a way to automatically arrange the nodes of a diagram, applying attractive layouts on the overall structure of the diagram. To utilize that functionality, an application can create a diagram by assigning generic coordinates to its nodes, instantiating a layout object and invoking the layout's Arrange method. The Arrange methods can be prevented from changing positions of individual items by setting the IgnoreLayout property of those items to true.

The classes that implement automatic layout algorithms are located in the MindFusion.Diagramming.Layout namespace. The following sections list the available algorithms categorized by their general implementation strategy: force-directed algorithms, graph topology based algorithms and semantics based algorithms.


Force-directed layout algorithms

Force-directed layout algorithms

Force-directed algorithms simulate forces acting between objects in the graph and iteratively run a physical simulation that pulls the objects closer or pushes them apart. At each iteration the energy associated with the simulated system decreases, and the node positions calculated by this process usually lead to evenly distributed nodes and uniform link lengths.

Spring-Embedder Graph Layout

Spring-Embedder is force-directed layout algorithm. It simulates a physical system in which nodes repulse each other, and the links between them act as confining springs. Graphs processed by Spring-Embedder have their nodes distributed uniformly across the diagram area. The algorithm can be applied on a graph by creating a SpringLayout object and calling its Arrange method. Members of SpringLayout allow you to set the desired distance between graph nodes (see NodeDistance) and the number of iteration steps to use while calculating node positions (see IterationCount). You can also specify that DiagramRT tries to minimize link crossings through the MinimizeCrossings property. If you select that option, the algorithm would produce better result with more iteration steps. However, it needs more time to complete if more steps are specified. In VB.NET and C#, Spring-Embedder layout might be applied like this:

C# [image] Copy Code

using MindFusion.Diagramming;
using MindFusion.Diagramming.Layout;

...

private void button1_Click(object sender, EventArgs e)
{
SpringLayout sl = new SpringLayout();
sl.IterationCount = 500;
sl.NodeDistance = 30;
sl.Arrange(diagram);
}

Visual Basic [image] Copy Code

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click

Dim sl As New SpringLayout()
sl.IterationCount = 500
sl.NodeDistance = 30
sl.Arrange(diagram)

End Sub

Grid Graph Layout

The GridLayout algorithm arranges diagram nodes in a grid, keeping connected nodes close together. The algorithm strives to achieve a small number of link crossings. It is based on an iterative process whose initial steps shuffle the grid nodes randomly. That can lead to very different results each time the algorithm is run.

To apply the layout to a diagram, create a GridLayout instance, set its members and invoke the Arrange method. Grid layout might be applied like this:

C# [image] Copy Code

using MindFusion.Diagramming;
using MindFusion.Diagramming.Layout;

...

private void button1_Click(object sender, EventArgs e)
{
GridLayout gl = new GridLayout();
gl.GridSize = 75;
gl.Arrange(diagram);
}

Visual Basic [image] Copy Code

Imports MindFusion.Diagramming
Imports MindFusion.Diagramming.Layout

...

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click

Dim gl As New GridLayout()
gl.GridSize = 75
gl.Arrange(diagram)

End Sub

Simulated Annealing Graph Layout

The AnnealLayout class implements the Simulated Annealing graph layout algorithm. Simulated Annealing is a general-purpose optimization method used to solve large-scale combinatorial problems by simulating the process of heating and cooling of metal to achieve freedom from defects. Finding a nice arrangement of a graph is a combinatorial problem that can be reduced to assigning costs to graph configurations and finding the minimum cost configuration. AnnealLayout assigns costs to graph configurations by evaluating different aesthetic criteria such as distance between nodes, length of links and the number of link crossings. Thus the best configuration found will have good aesthetic properties.

Circular Graph Layout

CircularLayout distributes nodes evenly on the circumference of a circle at positions that result in as few link crossing as possible. Set its Radius property to specify the size of the layout circle. Use SiftingRounds to set the number of fine-tuning crossing-reduction iterations.


Topology based layout algorithms

Topology based layout algorithms

The following algorithms are based on the topological features of the graph being arranged, such as the size and adjacency of faces (a face is a region bounded by links) and the overall direction of links. The algorithms differ in the shape they apply to graph faces and the manner in which faces are embedded in the plane.

The following algorithms are based on the topological features of the graph being arranged, such as the size and adjacency of faces (a face is a region bounded by links) and the overall direction of links. The algorithms differ in the shape they apply to graph faces and the manner in which faces are embedded in the plane.

One-way Graph Layout

The OneWayLayout class ensures that links enter into nodes from the same general direction and exit them from the opposite side. If the graph contains cycles, some links bend around the nodes to keep the enter/exit direction consistent. The algorithm aims to minimize the number of such links.

Topological Graph Layout

If the underlying graph if acyclic, TopologicalLayout arranges the nodes linearly in such a way that each node comes before all destination nodes of its outgoing links. The links are drawn as curves above the chain of nodes, with their height proportional to the distance between the nodes. If the graph is not acyclic, the layout algorithm finds an ordering with a minimal number of back links, and draws the back links below the chain of nodes.

Orthogonal Graph Layout

The OrthogonalLayout class implements an orthogonal graph layout algorithm. Each link is drawn as a chain of alternating horizontal and vertical segments. Nodes are placed in a way that facilitates few links bends and crossings. This algorithm was designed for planar graphs where the nodes have at most four incident links, and produces best results with such graphs as input. It can arrange any arbitrary graph as well, by adding some dummy nodes and links to planarize the graph and reduce its vertex degree, and removing them after the layout. However this might lead to using larger area than necessary, due to the space occupied by dummy elements.

Orthogonal Router

OrthogonalRouter is a secondary layout algorithm that can be used to arrange links after an initial node arrangement has already been applied. The orthogonal layout is useful when there are much more links than nodes in a graph. The algorithm strives to achieve the following criteria, while preserving as much of the initial node configuration as possible.

  • inks must not overlap;
  • only vertical and horizontal routing lines are used;
  • graph routing is performed with respect to the specified main layout direction;
  • links crossings are minimized;
  • bends are minimized;

Cascade Graph Layout

CascadeLayout places nodes on a virtual grid and arranges links orthogonally, such that if the source graph is planar all links are guaranteed to have no more than two bends and will not intersect. By default the layout method arranges nodes in rows and link segments in columns; this can be changed by setting the Orientation property.

Triangular Graph Layout

TriangularLayout places nodes on a virtual grid, such that if the source graph is planar, all links are guaranteed to have a single segment and not intersect. If the graph is not planar, its intersecting links can be optionally segmented and bended in order to improve readability. The layout method places the nodes from the external face on a triangle and recursively adds the rest of the nodes as vertices of internal triangles. As a result, it is very effective for near maximal-planar (a.k.a. triangular) graphs.


Semantics based layout algorithms

Semantics based layout algorithms

The following algorithms arrange the diagram in a way that shows the semantics of individual items or the overall graph structure, such as hierarchical relations between objects, loops and decisions in flowcharts, assignments of nodes to layers or swimlanes.

Tree Layout

If application's data is structured hierarchically, it is appropriate to apply tree layout on it. To do this, create a TreeLayout object and call its Arrange method. Members of TreeLayout control many aspects of the layout process. The type of layout can be directional or radial. You can choose how much space to leave between tree levels and between nodes on the same level. For directional layouts, the style of links in the arranged tree can be set to straight, orthogonal or curved. Global tree direction and alignment can be customized too. In VB.NET and C#, tree layout might be applied like this:

C# [image] Copy Code

using MindFusion.Diagramming;
using MindFusion.Diagramming.Layout;

...

private void button1_Click(object sender, EventArgs e)
{
TreeLayout tl = new TreeLayout();
tl.Type = TreeLayoutType.Cascading;
tl.Direction = TreeLayoutDirection.LeftToRight;
tl.LinkStyle = TreeLayoutLinkType.Cascading2;
tl.LevelDistance = 10;
tl.Arrange(diagram);
}

Visual Basic [image] Copy Code

Imports MindFusion.Diagramming
Imports MindFusion.Diagramming.Layout

...

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click

Dim tl As New TreeLayout()
tl.Type = TreeLayoutType.Cascading
tl.Direction = TreeLayoutDirection.LeftToRight
tl.LinkStyle = TreeLayoutLinkType.Cascading2
tl.LevelDistance = 10
tl.Arrange(diagram)

End Sub

Fractal Tree Layout

FractalLayout is a tree layout algorithm that places child nodes symmetrically around their parent node. Nodes at the lowest level are arranged directly in a circle around their parent. At the upper level, the already arranged nodes form branches that are arranged in a circle around the new parent node. The algorithm is recursively repeated till the highest level is reached. If nodes in the tree have uniform number of children, the end result has fractal-like appearance (subsets of the graph look like scaled-down copies of the whole graph).
You can choose which node should be displayed at the center of the topmost circle by setting the Root property. If it is not specified, the algorithm automatically selects a root that leads to more balanced distribution of nodes.

Layered Graph Layout

The LayeredLayout algorithm arranges diagram nodes in layers according to several criteria, most important of which are: connected nodes must be placed close together; links must flow in one direction if possible; links must cross as few layers as possible; links must not cross other links. To apply the layout to a diagram, create a LayeredLayout instance, set its members and invoke the Arrange method. In C# and VB.NET, layered layout can be applied like this:

C# [image] Copy Code

using MindFusion.Diagramming;
using MindFusion.Diagramming.Layout;

...

private void btnArrange_Click(object sender, System.EventArgs e)
{
LayeredLayout ll = new LayeredLayout();
ll.Orientation = MindFusion.Diagramming.Layout.Orientation.Horizontal;
ll.SplitLayers = true;
ll.LayerDistance = 35;
ll.Arrange(diagram);
}

Visual Basic [image] Copy Code

Imports MindFusion.Diagramming
Imports MindFusion.Diagramming.Layout

...

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click

Dim ll = New LayeredLayout()
ll.Orientation = MindFusion.Diagramming.Layout.Orientation.Horizontal
ll.SplitLayers = True
ll.LayerDistance = 35
ll.Arrange(Diagram)

End Sub

Tree map layout

Tree maps represent hierarchies by nesting child nodes within their parents, where the areas of leaf nodes are proportional to their Weight values. Unlike other layout algorithms, TreeMapLayout expects hierarchies to be defined via grouping or containment (see AttachTo method and ContainerNode class), and will ignore any links in the diagram. The diagram area covered by the topmost nodes in a hierarchy is specified via the LayoutArea property. By default, the layout tries to keep the ratio of node sides as close as possible to one. However this could make it hard to distinguish separate levels of the hierarchy. To alleviate that, set Squarify to false, and child nodes will be arranged either as a row or a column inside their parent node, alternating directions for each level. The drawback is that when Weight ratios differ greatly or nodes contain many children, some nodes could end up with very narrow rectangles.

Decision flowchart layout

DecisionLayout arranges simple flowcharts consisting of decision boxes with up to three outgoing links per node and activity boxes with a single outgoing link per node. The nodes are arranged in columns and rows, whose distance depends on the HorizontalPadding and VerticalPadding property values. When links share the same row or column, they are placed at a distance specified via LinkPadding. The layout arranges nodes recursively starting from StartNode. If StartNode is not specified, the algorithm selects the root of the deepest branch of the graph's spanning tree as start node.

Flowchart Graph Layout

FlowchartLayout recognizes program code -like patterns in the graph, such as loops, sequences and if/switch branchings, and arranges them recursively. FlowchartLayout could be used to arrange other types of graphs as well, though with some restrictions. For example it treats all back links as loops in the code, and expects that they are nested - loop links starting closer to the stop node should end closer to the start node. Another similar restriction is that there shouldn't be any cross-links that connect different branches of a decision sub-graph.

Swimlane Layout

SwimlaneLayout can be used to arrange process diagrams in which nodes representing activities are placed in swimlanes representing resources. The index of the resource allocated to an activity should be assigned to the corresponding node's LayoutTraits[SwimlaneLayoutTraits.Lane].

By default, the algorithm works with the diagram's LaneGrid, but its SwimlaneGrid property can be set to any class that implements ISwimlaneGrid. This allows applying the layout to a custom-drawn grid rendered through a custom control template, or one composed of locked background nodes.

Hierarchical Graph Layout

HierarchicalLayout places nodes on user-defined levels, such that if the source graph is level-planar, all links are guaranteed to have a single segment and not intersect. The layout method requires that for each node LayoutTraits contains a HierarchicalLayoutTraits.Level entry specifying the level, and no two connected nodes must be on the same level.


Multi-level layout algorithms

Multi-level layout algorithms

Multi-level algorithms are used to arrange very large graphs quickly by running other layout algorithms on small parts of the original diagram. Since layout algorithms are usually of polynomial complexity, applying them on smaller subgraphs considerably reduces the overall running time. Multi-level algorithms typically construct a virtual graph that is coarse representation of the diagram, where each virtual node represents a set of actual nodes and links between them. Each set is arranged independently from the others, then the virtual graph is arranged too and the actual sets are placed at the positions of the virtual nodes.

Composite Graph Layout

CompositeLayout partitions the diagram into several subgraphs and applies the algorithm specified via the SubgraphLayout property on each part. If the part is a tree, it is arranged using the algorithm specified via the SubtreeLayout property, which is set to a radial TreeLayout instance by default. Finally the algorithm specified via MasterLayout is applied on the graph that represents the overall partition. By running the polynomial-complexity layout algorithms on small subgraphs, CompositeLayout is able to process a large graph much faster than if a layout algorithm is applied on the whole graph.

CompositeLayout can run on custom partitions specified as lists of nodes, or automatically partition the diagram via two automatic methods based on graph connectivity and graph path lengths. Set the PartitionMethod and CustomPartition properties to specify how the diagram should be partitioned.


Link Routing

Link Routing

Routed links avoid nodes marked as Obstacles by finding the shortest path between their origin and destination that does not cross any other nodes.

Setting Up a Link Router

The control finds paths for links affected by modifications of nearby nodes by calling methods of an object that implements the ILinkRouter interface. This object can be get or set through the LinkRouter property of the Diagram class. WpfDiagram provides two classes that implement ILinkRouter - GridRouter and QuickRouter. By default LinkRouter is set to a QuickRouter instance.

Automatic or Explicit Routing

The RouteAllLinks method can be invoked to explicitly rearrange links in a way they do not cross nodes. In addition, links have an AutoRoute property that enables or disables automatic routing of a link; that property is initialized from the diagram's RouteLinks member. The TriggerRerouting member of the RoutingOptions class specifies when links must be rerouted automatically.

Tuning the Routing Algorithm

When a GridRouter is used, the RoutingOptions class allows customizing various aspects of the routing algorithm. That algorithm evaluates possible paths aiming to find one that has a minimal cost. The values of LengthCost, TurnCost, CrossingCost and NodeVicinityCost are added to the total cost of a route and have a great influence over the shape of the chosen path. The StartOrientation and EndOrientation properties specify the orientation of the first and last segments of routed links.


Anchor Points and Patterns

Anchor Points and Patterns

Anchor Points

For each node you can define one or more points to which links must dock when connecting to that node. Such points are represented by instances of the AnchorPoint class. The position of an anchor point relative to node's bounding rectangle is specified by the X and Y properties. Their values are expressed as percent of the node's width and height to accommodate for moving and resizing. The final location of an anchor point is determined by this simple calculation:

C# [image] Copy Code

return new PointF(
nodeRect.X + nodeRect.Width * X / 100,
nodeRect.Y + nodeRect.Height * Y / 100);

Visual Basic [image] Copy Code

Return New PointF( _
nodeRect.X + nodeRect.Width * X / 100, _
nodeRect.Y + nodeRect.Height * Y / 100)

You can control whether an anchor point accepts incoming or outgoing links or both. That is done by the AllowIncoming and AllowOutgoing properties. When a link is drawn, its ends are aligned to the nearest anchors allowing docking of the respective end type. Another way to control whether links can be connected to an anchor point is to handle the ValidateAnchorPoint event.

Anchor Patterns

An AnchorPattern instance defines a set of anchor points to be used together. When creating an anchor pattern, pass to its constructor an array of AnchorPoint objects. The AnchorPattern class exposes several predefined patterns as static properties. An existing pattern can be assigned as a single entity to the AnchorPattern property of nodes. The following example creates a pattern of four anchor points:

C# [image] Copy Code

apat1 = new AnchorPattern(new AnchorPoint[] {
new AnchorPoint(50, 0, true, true),
new AnchorPoint(100, 50, true, true),
new AnchorPoint(50, 100, true, true),
new AnchorPoint(0, 50, true, true)});

Visual Basic [image] Copy Code

apat1 = new AnchorPattern(new AnchorPoint() { _
new AnchorPoint(50, 0, true, true), _
new AnchorPoint(100, 50, true, true), _
new AnchorPoint(50, 100, true, true), _
new AnchorPoint(0, 50, true, true) })

The points are located at the middles of bounding rectangle sides of nodes to which the pattern is assigned. All four points accept both incoming and outgoing links.

Anchor Patterns and Tables

A distinct anchor pattern can be assigned to every row of a table. When a link is connected to a row, the respective end of the link is aligned to the nearest AnchorPoint assigned to that row. If a row does not have associated anchor points of the appropriate type (incoming/outgoing), the link will be connected to the nearest row that has such anchors defined. If none of the rows of a table has an associated anchor pattern, links are connected to the middle of the left or right side of the pointed row.


Appearance

Appearance


Styles and Themes

Styles and Themes

The style and theme system provides a consistent way to customize the appearance of a Diagram and its items. By using styles and themes, it is easier to achieve coherent look and feel across the entire diagram. In addition, changing the look and feel can be achieved by simply replacing the current theme. New themes can be designed in the visual environment of the Theme Editor tool and subsequently used and distributed as XML files. Several pre-defined theme files are installed under the Themes subfolder of the control's root installation folder.

Styles

DiagramRT styling system uses regular WinRT Style objects. To apply a style to an individual diagram item set the style to the item's Style property - the same way you would apply a style to a regular FrameworkElement object. All rules that apply to the WinRT Style objects are in effect here as well. For example, you can define a Style as a resource, then reference this resource from diagram items declared in XAML. To apply a style for all items of a particular type, define a Style object within the current scope with its TargetType set to the appropriate type. Alternatively you can use a Theme (see the following section).

Themes

The theme in DiagramRT is a set of styles, each associated with specific item type. When the theme is applied to a diagram, the styles registered in the theme affect all objects of their associated type.

Themes are represented by the Theme class and can be assigned to Diagram objects through the Theme property. Styles are associated with types within the theme through the RegisterStyle method. The following code creates a new theme, with a single style for ShapeNode items and applies this theme to an existing diagram.

C# [image] Copy Code

Theme theme = new Theme();
Style style = new Style(typeof(ShapeNode));
style.Setters.Add(new Setter(ShapeNode.FontFamilyProperty, new FontFamily("Courier New")));
theme.RegisterStyle(typeof(ShapeNode), style);
diagram.Theme = theme;

VB.NET [image] Copy Code

Dim theme As New Theme()
Dim style As New Style(GetType(ShapeNode))
style.Setters.Add(New Setter(ShapeNode.FontFamilyProperty, New FontFamily("Courier New")))
theme.RegisterStyle(GetType(ShapeNode), style)
diagram.Theme = theme

Alternatively, themes can be loaded from XML files by calling the LoadFromXml method. Such XML files can be produced by the Theme Editor tool, or by calling the SaveToXml method of an existing theme.

Another way to implicitly register styles with themes is through a set of shortcut properties exposed by the Diagram class, namely DiagramLinkStyle, ShapeNodeStyle, TableNodeStyle, ContainerNodeStyle, and TreeViewNodeStyle. Setting any of these properties automatically registers the property value as a style within the currently associated theme. These properties are particularly useful for specifying styles through XAML. The following example illustrates this:

XAML [image] Copy Code

<d:Diagram xmlns:d="using:MindFusion.Diagramming">
<d:Diagram.ShapeNodeStyle>
<Style TargetType="d:ShapeNode">
<Setter Property="Stroke" Value="Green" />
</Style>
</d:Diagram.ShapeNodeStyle>
</d:Diagram>

Theme Editor

The Theme Editor provides simple visual environment for theme creation and modification. The editor displays a sample diagram with items of various types and exposes a list of all style properties through a property grid to the left. Any modification of the style properties in the grid is immediately reflected on the diagram to give a preview on what effect the change would have if the theme is applied to a diagram. The theme can be saved at any time through the Save menu. Existing themes can be opened and modified.

The following image illustrates the Theme Editor in action:


Customizing the Appearance of Items

Customizing the Appearance of Items

For every DiagramRT item, different visual styles and properties can be set as described in the following paragraphs.

Pen Width and Style

The borders of nodes and the lines of links are drawn using a pen whose color, width and style can be customized through the Stroke, StrokeThickness and StrokeDashArray properties.

Color of Diagram Elements

The color of link segments can be set using the Stroke property. The borders of arrowheads are drawn using HeadPen. Brush specifies how closed arrowhead shapes are filled. It is also possible to define distinct fill style for each type of arrowheads by means of the HeadBrush, BaseBrush and IntermediateBrush properties. TextBrush is used for rendering link's text.

Nodes have three properties for colors: the color of node borders is specified through the Stroke property; the interior of a node is filled using Brush; TextBrush specifies the color in which text is rendered. Tables have a special property for their caption color - CaptionBrush.

Text

Diagram items can have associated text, displayed inside or over them. Text of shape nodes is set via their Text property. The text format and alignment style is specified using TextFormat. To make a node big enough to display its text without clipping, call its ResizeToFitText method.

Links have their text drawn horizontally above their middle segment or rotated as specified by TextStyle; the string to display can be set using the Text property.

Tables have caption text specified by Caption; table cells expose the Text property.

All diagram items expose Font property, specifying the name, style and size of the font of item's text. The color of item's text is set in its corresponding TextBrush property.

Images

Shape nodes and tables can display images inside them. Use the Image property to load images into the nodes. Alternatively, specify the image files location using ImageWebLocation or ImageResourceLocation properties of nodes and the nodes will automatically load the images. Images can be positioned in different ways: they can be tiled, stretched or aligned to the containing nodes' centers or sides. Use ImageAlign property to specify how images are placed within the corresponding nodes. An image shown inside a node is clipped in accordance with the shape of that node.

Table cells can have Image and ImageAlign assigned too. For example that might be used to display an icon for the key field of a database table.

DiagramLink-specific Properties

The shape and orientation of link segments is specified by the Shape property; the number of segments is specified by the SegmentCount property. The form and size of the arrowhead shape is set using the HeadShape and HeadShapeSize properties. Shapes displayed at the origin of links are defined by BaseShape and BaseShapeSize. Shapes can be displayed at middles of segments, helping to follow the path of long links. They are defined by the IntermediateShape and IntermediateShapeSize properties. The lines of arrowhead shapes are painted using the HeadPen pen.

Link Crossings

Intersection points where links cross their paths can be rendered as arcs or breaks, as specified by LinkCrossings. It depends on the Z-order, which links jump over the others, or which links appear cut by the others. If LinkCrossings is set to Arcs, links with higher ZIndex jump over those with lower ZIndex. If set to Cut, links at lower Z-position are cut by links at higher Z. Radius of arcs and breaks can be set through the CrossingRadius property.

ShapeNode-specific Properties

The shape of a node is defined using its Shape property. Shape templates can be applied to a shape node with an orientation of 0/90/180/270 degrees as specified through the ShapeOrientation property. Your own drawing code may be invoked for a node, depending on the value of CustomDraw. Shape nodes can be marked as Transparent, having only their text or images rendered.

TableNode-specific Properties

The outline of a table can be either a rectangle or rounded rectangle, as specified by the Style property. The borders of table cells can be rendered in different ways, depending on the value of CellFrameStyle. The table caption area is painted using the CaptionBackBrush brush. Custom painting can be performed on a table and its cells as set in the CustomDraw and CellCustomDraw properties.


Styles and Control Templates

Styles and Control Templates

DiagramItem ultimately derives from the Control class, and so diagram items can be styled and templated. For example, you can define the following style in a ResourceDictionary inside the page xaml:

XAML [image] Copy Code

<Style x:Key="MyNodeStyle" TargetType="diaglite:ShapeNode">
<Setter Property="Brush" Value="White" />
<Setter Property="Stroke" Value="Blue" />
</Style>

Then you can assign the style to a new node as shown in this example:

C# [image] Copy Code

var node = new ShapeNode();
node.Style = (Style)Resources["MyNodeStyle"];
node.Text = "test";
diagram.Nodes.Add(node);

At the time of writing this, nodes that are created interactively have some local values set for their dependency properties, since they are initialized from the Diagram default-value properties such as ShapeBrush. To apply a style to such nodes, you might have to clear their local values first:

C# [image] Copy Code

private void OnNodeCreated(object sender, NodeEventArgs e)
{
var shapeNode = e.Node as ShapeNode;
if (shapeNode != null)
{
shapeNode.ClearValue(DiagramItem.BrushProperty);
shapeNode.ClearValue(DiagramItem.StrokeProperty);
shapeNode.Style = (Style)Resources["MyNodeStyle"];
}
}

Using styles, it is also possible to define new control templates for diagram nodes. For example the code below defines a more light-weight template for ShapeNode objects:

XAML [image] Copy Code

<Style x:Key="MyNodeTemplate" TargetType="diaglite:ShapeNode">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="diaglite:ShapeNode">
<Canvas x:Name="Adorner">

<Path x:Name="Shape"
Data="{TemplateBinding ShapeGeometry}"
Fill="{TemplateBinding Brush}">
</Path>

<TextBlock
Width="{TemplateBinding Width}"
Height="{TemplateBinding Height}"
Text="{TemplateBinding Text}"
Foreground="{TemplateBinding TextBrush}"
TextAlignment="Center">
</TextBlock>

</Canvas>
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

The DiagramItem class also defines two visual state groups. The group SelectionStates contains the Unselected and Selected states. The MouseStates group contains the MouseOut, MouseOver and MouseDown states. Note that the control does not provide any built-in animations for transitions between these states. If that's required, it can be implemented through custom Xaml templates where Storyboard objects are associated with states through the VisualStateManager.VisualStateGroups property. For example, in a node template defines a named UI element called "rect", its color can be animated when a node is selected as shown below:

XAML [image] Copy Code

<VisualStateManager.VisualStateGroups>
<VisualStateGroup Name="SelectionStates">
<VisualState Name="Unselected" />
<VisualState Name="Selected">
<Storyboard>
<ColorAnimation To="Red" Storyboard.TargetName="rect" Storyboard.TargetProperty="(Stroke).(Color)" />
</Storyboard>
</VisualState>
</VisualStateGroup>
</VisualStateManager.VisualStateGroups>


Default Control Templates of Diagram Items

Default Control Templates of Diagram Items

Below you can find the XAML for the default control templates defined by DiagramRT. You could copy the code of a template and insert some additional elements when you need to build upon the predefined appearance of items.

XAML [image] Copy Code

<ResourceDictionary
xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
xmlns:local="clr-namespace:MindFusion.Diagramming"
xmlns:lanes="clr-namespace:MindFusion.Diagramming.Lanes">

<local:DashArrayConverter x:Key="dashArrayConverter" />
<local:VisibilityConverter x:Key="visibilityConverter" />
<local:ThicknessConverter x:Key="thicknessConverter" />
<local:TextWrappingConverter x:Key="textWrappingConverter" />

<Style TargetType="local:Diagram">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:Diagram">
<Canvas Background="{TemplateBinding Background}">
<Canvas x:Name="laneGridCellContainer" Visibility="{Binding EnableLanes, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource visibilityConverter}}" Canvas.ZIndex="0" />
<Canvas x:Name="laneGridColumnHeaderContainer" Visibility="{Binding EnableLanes, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource visibilityConverter}}" Canvas.ZIndex="1" />
<Canvas x:Name="laneGridRowHeaderContainer" Visibility="{Binding EnableLanes, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource visibilityConverter}}" Canvas.ZIndex="1" />
<ContentPresenter Canvas.ZIndex="2" />
<Canvas x:Name="foregroundLayer" Canvas.ZIndex="3" />
</Canvas>
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

<Style TargetType="lanes:FourSidedBorder">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="lanes:FourSidedBorder">
<Border
BorderBrush="{Binding BorderStyle.LeftBorderPen.Brush, RelativeSource={RelativeSource TemplatedParent}}"
BorderThickness="{Binding BorderStyle.LeftBorderPen.Thickness, Converter={StaticResource thicknessConverter}, ConverterParameter=Left, RelativeSource={RelativeSource TemplatedParent}}">
<Border
BorderBrush="{Binding BorderStyle.TopBorderPen.Brush, RelativeSource={RelativeSource TemplatedParent}}"
BorderThickness="{Binding BorderStyle.TopBorderPen.Thickness, Converter={StaticResource thicknessConverter}, ConverterParameter=Top, RelativeSource={RelativeSource TemplatedParent}}">
<Border
BorderBrush="{Binding BorderStyle.RightBorderPen.Brush, RelativeSource={RelativeSource TemplatedParent}}"
BorderThickness="{Binding BorderStyle.RightBorderPen.Thickness, Converter={StaticResource thicknessConverter}, ConverterParameter=Right, RelativeSource={RelativeSource TemplatedParent}}">
<Border
BorderBrush="{Binding BorderStyle.BottomBorderPen.Brush, RelativeSource={RelativeSource TemplatedParent}}"
BorderThickness="{Binding BorderStyle.BottomBorderPen.Thickness, Converter={StaticResource thicknessConverter}, ConverterParameter=Bottom, RelativeSource={RelativeSource TemplatedParent}}">
<Border
Background="{Binding BorderStyle.BackgroundBrush, RelativeSource={RelativeSource TemplatedParent}}">
<ContentPresenter />
</Border>
</Border>
</Border>
</Border>
</Border>
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

<Style TargetType="lanes:LaneGridHeaderPresenter">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="lanes:LaneGridHeaderPresenter">
<lanes:FourSidedBorder BorderStyle="{Binding Style}">
<TextBlock Text="{Binding Title}" />
</lanes:FourSidedBorder>
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

<Style TargetType="lanes:LaneGridCellPresenter">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="lanes:LaneGridCellPresenter">
<lanes:FourSidedBorder BorderStyle="{Binding Style}" />
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

<Style TargetType="local:LinkLabel">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:LinkLabel">
<TextBlock
Text="{TemplateBinding Text}"
Foreground="{TemplateBinding Foreground}"
FontFamily="{TemplateBinding FontFamily}"
FontSize="{TemplateBinding FontSize}"
FontStretch="{TemplateBinding FontStretch}"
FontStyle="{TemplateBinding FontStyle}"
FontWeight="{TemplateBinding FontWeight}"
TextWrapping="{Binding EnableWrap, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource textWrappingConverter}}"
MaxWidth="{TemplateBinding MaxWidth}"
MaxHeight="{TemplateBinding MaxHeight}"
Margin="{TemplateBinding Margin}" />
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

<Style TargetType="local:ShapeNode">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:ShapeNode">
<Canvas x:Name="Adorner">

<Path x:Name="Shape"
Data="{TemplateBinding ShapeGeometry}"
Stroke="{TemplateBinding Stroke}"
DataContext="{TemplateBinding StrokeDashArray}"
StrokeDashArray="{Binding Converter={StaticResource dashArrayConverter}}"
StrokeDashCap="{TemplateBinding StrokeDashCap}"
StrokeDashOffset="{TemplateBinding StrokeDashOffset}"
StrokeEndLineCap="{TemplateBinding StrokeEndLineCap}"
StrokeLineJoin="{TemplateBinding StrokeLineJoin}"
StrokeMiterLimit="{TemplateBinding StrokeMiterLimit}"
StrokeStartLineCap="{TemplateBinding StrokeStartLineCap}"
StrokeThickness="{TemplateBinding StrokeThickness}"
Fill="{TemplateBinding Brush}"
Visibility="{TemplateBinding ShapeVisibility}"
Opacity="{TemplateBinding ShapeOpacity}" />

<Grid Width="{TemplateBinding Width}" Height="{TemplateBinding Height}">
<Image x:Name="Image"
Source="{TemplateBinding Image}"
HorizontalAlignment="{TemplateBinding HorizontalImageAlignment}"
VerticalAlignment="{TemplateBinding VerticalImageAlignment}"
Stretch="{TemplateBinding ImageStretch}">
</Image>
</Grid>

<Grid
Margin="{TemplateBinding TextMargin}"
Width="{TemplateBinding TextWidth}"
Height="{TemplateBinding TextHeight}"
HorizontalAlignment="Left"
VerticalAlignment="Top">

<TextBlock
Text="{TemplateBinding Text}"
FontFamily="{TemplateBinding FontFamily}"
FontSize="{TemplateBinding FontSize}"
FontStretch="{TemplateBinding FontStretch}"
FontStyle="{TemplateBinding FontStyle}"
FontWeight="{TemplateBinding FontWeight}"
HorizontalAlignment="{TemplateBinding HorizontalTextBlockAlignment}"
VerticalAlignment="{TemplateBinding VerticalTextBlockAlignment}"
TextAlignment="{TemplateBinding TextAlignment}"
TextWrapping="{TemplateBinding TextWrapping}"
Foreground="{TemplateBinding TextBrush}">
</TextBlock>

</Grid>

<ContentPresenter
Content="{TemplateBinding DecorationsContainer}"
Visibility="{TemplateBinding ShapeVisibility}" />

<Grid Name="EffectsContainer" />

</Canvas>
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

<Style TargetType="local:TableNode">
<Setter Property="BorderRadius" Value="8"/>
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:TableNode">
<Canvas x:Name="Adorner">

<Canvas.Resources>
<local:GeometryCloneConverter x:Key="geometryCloneConverter"/>
</Canvas.Resources>

<Grid x:Name="ContainerGrid"
HorizontalAlignment="Stretch"
VerticalAlignment="Stretch"
Width="{TemplateBinding Width}"
Height="{TemplateBinding Height}"
Clip="{Binding BorderGeometry, Mode=OneWay,
RelativeSource={RelativeSource TemplatedParent},
Converter={StaticResource geometryCloneConverter}}"
Background="{TemplateBinding Brush}"
Opacity="{TemplateBinding ShapeOpacity}">

<Grid.RowDefinitions>
<RowDefinition Height="Auto" />
<RowDefinition Height="*" />
</Grid.RowDefinitions>

<Rectangle Fill="{TemplateBinding CaptionBackBrush}" />

<TextBlock
Text="{TemplateBinding Caption}"
FontFamily="{TemplateBinding FontFamily}"
FontSize="{TemplateBinding FontSize}"
FontStretch="{TemplateBinding FontStretch}"
FontStyle="{TemplateBinding FontStyle}"
FontWeight="{TemplateBinding FontWeight}"
TextAlignment="Center"
Foreground="{TemplateBinding TextBrush}"
Height="{TemplateBinding CaptionHeight}"/>

<Rectangle Height="1" VerticalAlignment="Bottom"
HorizontalAlignment="Stretch" Fill="Black"/>

<Grid x:Name="RowsGrid" Grid.Row="1" />

</Grid>

<Path
Stroke="{TemplateBinding Stroke}"
DataContext="{TemplateBinding StrokeDashArray}"
StrokeDashArray="{Binding Converter={StaticResource dashArrayConverter}}"
StrokeDashCap="{TemplateBinding StrokeDashCap}"
StrokeDashOffset="{TemplateBinding StrokeDashOffset}"
StrokeEndLineCap="{TemplateBinding StrokeEndLineCap}"
StrokeLineJoin="{TemplateBinding StrokeLineJoin}"
StrokeMiterLimit="{TemplateBinding StrokeMiterLimit}"
StrokeStartLineCap="{TemplateBinding StrokeStartLineCap}"
StrokeThickness="{TemplateBinding StrokeThickness}"
Data="{Binding BorderGeometry, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource geometryCloneConverter}}" />

<Grid Name="EffectsContainer" />

</Canvas>
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

<Style TargetType="local:Cell">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:Cell">
<Border HorizontalAlignment="Stretch" VerticalAlignment="Stretch"
BorderThickness="0, 0, 1, 1" BorderBrush="Black">
<TextBlock
Text="{TemplateBinding Text}"
Foreground="{TemplateBinding Foreground}"
TextAlignment="{TemplateBinding TextAlignment}"
FontFamily="{TemplateBinding FontFamily}"
FontSize="{TemplateBinding FontSize}"
FontStretch="{TemplateBinding FontStretch}"
FontStyle="{TemplateBinding FontStyle}"
FontWeight="{TemplateBinding FontWeight}"
Margin="2, 1, 2, 1" />
</Border>
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

<Style TargetType="local:TreeViewNode">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:TreeViewNode">
<Canvas x:Name="Adorner">
<Canvas.Resources>
<local:GeometryCloneConverter x:Key="geometryCloneConverter"/>
</Canvas.Resources>

<Rectangle Fill="{TemplateBinding Brush}"
Opacity="{TemplateBinding ShapeOpacity}"
Width="{TemplateBinding Width}"
Height="{TemplateBinding Height}" />

<Grid Margin="0" x:Name="ContainerGrid"
Width="{TemplateBinding Width}"
Height="{TemplateBinding Height}">
<Grid.RowDefinitions>
<RowDefinition Height="Auto" />
<RowDefinition Height="*" />
</Grid.RowDefinitions>

<Grid Grid.Row="0" VerticalAlignment="Top" Height="{TemplateBinding CaptionHeight}">
<Grid.ColumnDefinitions>
<ColumnDefinition Width="Auto" />
<ColumnDefinition Width="*" />
</Grid.ColumnDefinitions>

<Image x:Name="Image"
Height="{TemplateBinding CaptionHeight}"
Source="{TemplateBinding CaptionImage}"
Stretch="UniformToFill"
VerticalAlignment="Top"
HorizontalAlignment="Left"
Grid.Column="0" Grid.Row="0" />

<TextBlock
Text="{TemplateBinding Caption}"
FontFamily="{TemplateBinding FontFamily}"
FontSize="{TemplateBinding FontSize}"
FontStretch="{TemplateBinding FontStretch}"
FontStyle="{TemplateBinding FontStyle}"
FontWeight="{TemplateBinding FontWeight}"
Grid.Column="1"
Padding="0"
VerticalAlignment="Center"
HorizontalAlignment="Left"
TextAlignment="Center"
Height="{TemplateBinding CaptionHeight}" />

<Rectangle Height="1"
Grid.ColumnSpan="2"
VerticalAlignment="Bottom"
HorizontalAlignment="Stretch"
Fill="Black"/>
</Grid>
<Grid Grid.Row="1">

<ScrollViewer
x:Name="ScrollViewer"
Padding="0" Margin="0"
HorizontalScrollBarVisibility="Hidden">
<local:TreeView Visibility="Visible"
Margin="0"
ItemsSource="{TemplateBinding RootItems}"
/>
</ScrollViewer>
</Grid>
</Grid>

<Path StrokeThickness="1" Stroke="Black"
Data="{Binding BorderGeometry, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource geometryCloneConverter}}"/>

<Grid Name="EffectsContainer" />

</Canvas>
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

<Style TargetType="local:TreeViewItem">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:TreeViewItem">
<Grid Background="{TemplateBinding Background}">
<Grid.RowDefinitions>
<RowDefinition Height="{TemplateBinding LabelHeight}" />
<RowDefinition Height="Auto" />
</Grid.RowDefinitions>

<Grid.ColumnDefinitions>
<ColumnDefinition
MaxWidth="15"
MinWidth="15"
Width="{TemplateBinding ExpanderButtonWidth}" />
<ColumnDefinition Width="Auto" />
<ColumnDefinition Width="*" />
</Grid.ColumnDefinitions>

<Border
x:Name="ExpanderButton"
Visibility="{TemplateBinding ExpanderVisibility}"
HorizontalAlignment="Center"
VerticalAlignment="Center"
Width="11" Height="11" Padding="0"
BorderBrush="#FF9D9D9D" BorderThickness="1">

<Border.Background>
<LinearGradientBrush>
<LinearGradientBrush.GradientStops>
<GradientStop Offset="0.0" Color="#FFFDFDFD" />
<GradientStop Offset="1.0" Color="#FFBDBDBD" />
</LinearGradientBrush.GradientStops>
</LinearGradientBrush>
</Border.Background>
<Grid>
<Grid Visibility="{TemplateBinding ExpandedIconVisibility}">
<Path
Data="M 4.5,1 L 4.5,8"
StrokeThickness="1"
StrokeLineJoin="Miter">
<Path.Stroke>
<SolidColorBrush Color="#FF000000" />
</Path.Stroke>
</Path>
</Grid>
<Grid>
<Path
Margin="0"
Data="M 1,4.5 L 8,4.5"
StrokeLineJoin="Miter" StrokeThickness="1">
<Path.Stroke>
<SolidColorBrush Color="#FF000000" />
</Path.Stroke>
</Path>
</Grid>
</Grid>
</Border>

<Image Grid.Column="1" Source="{TemplateBinding Image}"
Stretch="{TemplateBinding ImageStretch}"
x:Name="Image" IsHitTestVisible="False" />

<Grid Grid.Column="2" Height="{TemplateBinding LabelHeight}"
VerticalAlignment="Center" IsHitTestVisible="False" >

<TextBlock x:Name="TextBlock"
Text="{TemplateBinding Label}"
FontFamily="{TemplateBinding FontFamily}"
FontSize="{TemplateBinding FontSize}"
FontStretch="{TemplateBinding FontStretch}"
FontStyle="{TemplateBinding FontStyle}"
FontWeight="{TemplateBinding FontWeight}"
Foreground="{TemplateBinding LabelBrush}"
VerticalAlignment="Center"
Padding="0" />
</Grid>

<Grid Grid.Row="1" Grid.Column="0" Grid.ColumnSpan="3">
<local:TreeView x:Name="ItemsHost"
Visibility="{TemplateBinding ItemsVisibility}"
Margin="{TemplateBinding TreeDepth}"
ItemsSource="{TemplateBinding Children}" />
</Grid>
</Grid>
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

<Style TargetType="local:ExpandButton">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:ExpandButton">
<Grid>
<VisualStateManager.VisualStateGroups>
<VisualStateGroup x:Name="CommonStates">
<VisualState x:Name="Expanded" />
<VisualState x:Name="Collapsed">
<Storyboard>
<DoubleAnimation Duration="0"
Storyboard.TargetName="CollapsedVisible"
Storyboard.TargetProperty="(UIElement.Opacity)"
To="1"/>
</Storyboard>
</VisualState>
</VisualStateGroup>
</VisualStateManager.VisualStateGroups>
<Viewbox StretchDirection="Both" VerticalAlignment="Center" HorizontalAlignment="Center" >
<Border BorderBrush="{TemplateBinding BorderBrush}"
BorderThickness="{TemplateBinding BorderThickness}"
Background="{TemplateBinding Background}">
<Grid VerticalAlignment="Stretch" HorizontalAlignment="Stretch">
<Grid>
<Path Margin="0" Data="M 1,4.5 L 8,4.5"
StrokeLineJoin="Miter" StrokeThickness="1">
<Path.Stroke>
<SolidColorBrush Color="#FF000000" />
</Path.Stroke>
</Path>
</Grid>
<Grid x:Name="CollapsedVisible" Opacity="0">
<Path Data="M 4.5,1 L 4.5,8" StrokeThickness="1"
StrokeLineJoin="Miter">
<Path.Stroke>
<SolidColorBrush Color="#FF000000" />
</Path.Stroke>
</Path>
</Grid>
</Grid>
</Border>
</Viewbox>
</Grid>
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

<!-- Magnifier -->
<Style TargetType="local:Magnifier">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:Magnifier">
<Grid>
<Ellipse Fill="{TemplateBinding Background}" />
<Ellipse x:Name="PART_Lens" />
<Ellipse Fill="CornflowerBlue" Opacity="0.3" />
<Ellipse Opacity="0.3">
<Ellipse.Fill>
<RadialGradientBrush>
<GradientStop Color="#00000000" Offset="0.0"/>
<GradientStop Color="#50000000" Offset="0.8"/>
<GradientStop Color="#C8000000" Offset="1.0"/>
</RadialGradientBrush>
</Ellipse.Fill>
</Ellipse>
<Ellipse Stroke="Black" StrokeThickness="4" />
<Ellipse Stroke="#333333" StrokeThickness="1" Margin="1" />
</Grid>
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

</ResourceDictionary>


Modifying the Diagram Appearance

Modifying the Diagram Appearance

You can customize most of DiagramRT visualization effects.

Background

The Diagram background area can be filled using a solid brush, gradient, texture or color patterns, by setting the BackBrush property. Background theme can also be an image set by the BackgroundImage property. The image can be any from the supported by the System.Drawing.Image file formats - metafiles, icons, bitmaps, jpegs or gifs. Background image can be centered, aligned to a corner of the control or document, tiled or stretched to cover the drawing area - depending on the BackgroundImageAlign property value. It is possible to paint the area outside Bounds using a distinct brush by setting the ExteriorBrush property.

Selection

The color of selection handles drawn around the active item can be set with the ActiveItemHandlesBrush property. Items in multiple-selection have their handles drawn in the color specified by the SelectedItemHandlesBrush property. Disabled manipulation handles are painted in DisabledHandlesColor when ShowDisabledHandles is enabled (see EnabledHandles). The Style property of the Selection class controls the way multiple-selection is displayed.

Mouse Cursors

Different mouse cursor icons can be set to give context-sensitive feedback to users, prompting them if creation/modification of an item is possible. The following properties specify what cursors are displayed at different situations: PointerCursor, MoveCursor, DisallowCursor, DrawLinkCursor, AllowLinkCursor, DisallowLinkCursor, HorizontalResizeCursor, VerticalResizeCursor, DiagonalResizeCursor, CounterDiagonalResizeCursor. DiagramRT displays the PanCursor while panning the diagram view. Set the OverrideCursor property if you need to set a cursor that does not depend on the current context.

Grid Settings

An alignment grid is drawn if the ShowGrid is set to true. The GridColor property specifies the color of grid points.


Tutorials

Tutorials

The tutorials in this section assume you have already added a Diagram object to your DiagramRT application. Visual Studio solutions that contain the full source code from the tutorials are available in the Samples folder under the DiagramRT installation folder.


Tutorial 1: Loading Graph Data

Tutorial 1: Loading Graph Data

This tutorial shows how to load graph data from XML and create diagram objects corresponding to the graph nodes and edges.

  1. Right-click the Assets folder in Solution Explorer and choose Add -> New Item from the context menu. Create a new XML file called SampleGraph.xml and add to it content in the following form:

XML [image] Copy Code

<?xml version="1.0" encoding="utf-8" ?>
<Graph>
<Nodes>
<Node id="0" name="start" />
<Node id="1" name="activity 1" />
<Node id="2" name="task 1" />
<Node id="3" name="task 2" />
<Node id="4" name="activity 2" />
<Node id="5" name="task 3" />
<Node id="6" name="task 4" />
<Node id="7" name="activity 3" />
<Node id="8" name="task 5" />
<Node id="9" name="task 6" />
<Node id="10" name="end" />
</Nodes>
<Links>
<Link origin="0" target="1" />
<Link origin="1" target="2" />
<Link origin="1" target="3" />
<Link origin="2" target="4" />
<Link origin="3" target="4" />
<Link origin="4" target="5" />
<Link origin="4" target="6" />
<Link origin="5" target="10" />
<Link origin="6" target="10" />
<Link origin="0" target="7" />
<Link origin="7" target="8" />
<Link origin="8" target="9" />
<Link origin="1" target="9" />
<Link origin="9" target="10" />
</Links>
</Graph>

  2. Make sure that the file's "Build Action" property is set to "Content".
  3. Add a Loaded event handler to the main page of the application:

Xaml [image] Copy Code

<Page ...
Loaded="Page_Loaded" ...>

C# [image] Copy Code

private void Page_Loaded(object sender, RoutedEventArgs e)
{
}

  4. Add the following variables to the Loaded handler: "nodeMap" maps diagram nodes to their identifiers, and "bounds" contains the default node size.

C# [image] Copy Code

var nodeMap = new Dictionary<string, DiagramNode>();
var bounds = new Rect(0, 0, 60, 20);

  5. Load the XML document and its root element using the Linq for XML API:

C# [image] Copy Code

// load the graph xml
var package = Windows.ApplicationModel.Package.Current;
var loc = package.InstalledLocation;
var xml = XDocument.Load(loc.Path + "\\Assets\\SampleGraph.xml");
var graph = xml.Element("Graph");

  6. Load the graph node elements and create their corresponding ShapeNode objects by calling the CreateShapeNode method of the Factory class. CreateShapeNode is just a shortcut to creating a ShapeNode instance using the "new" operator and adding it to the Nodes collection of the diagram. Additionally, this code maps the new node to the "id" attribute of the XML element, and sets the node's Text to the value of the "name" attribute.

C# [image] Copy Code

// load node data
var nodes = xml.Descendants("Node");
foreach (var node in nodes)
{
var diagramNode = diagram.Factory.CreateShapeNode(bounds);
nodeMap[node.Attribute("id").Value] = diagramNode;
diagramNode.Text = node.Attribute("name").Value;
}

  7. Load the graph links and create corresponding DiagramLink objects. The Origin and Destination of the links are accessed by their ids through the "nodeMap" dictionary.

C# [image] Copy Code

// load link data
var links = xml.Descendants("Link");
foreach (var link in links)
{
diagram.Factory.CreateDiagramLink(
nodeMap[link.Attribute("origin").Value],
nodeMap[link.Attribute("target").Value]);
}

  8. Arrange the diagram using the LayeredLayout class.

C# [image] Copy Code

// arrange the graph
var layout = new LayeredLayout();
layout.Arrange(diagram);

  9. Build and run the project. If everything is fine, you should see this representation of the graph:


Tutorial 2: Loading Hierarchical Data

Tutorial 2: Loading Hierarchical Data

This tutorial shows how to load hierarchical data recursively from XML and create diagram items corresponding to the hierarchy.

  1. Right-click the Assets folder in Solution Explorer and choose Add -> New Item from the context menu. Create a new XML file called SampleTree.xml and add to it content in the following form:

XML [image] Copy Code

<?xml version="1.0" encoding="utf-8" ?>
<Project>
<Activity Name="Activity 1">
<Activity Name="sub-activity 1">
<Activity Name="sub-activity 1-1" />
<Activity Name="sub-activity 1-2" />
</Activity>
<Activity Name="sub-activity 2">
<Activity Name="sub-activity 2-1" />
<Activity Name="sub-activity 2-2" />
<Activity Name="sub-activity 2-3" />
</Activity>
<Activity Name="sub-activity 3">
<Activity Name="sub-activity 3-1" />
<Activity Name="sub-activity 3-2" />
</Activity>
</Activity>
<Activity Name="Activity 2">
<Activity Name="sub-activity 1">
<Activity Name="sub-activity 1-1" />
<Activity Name="sub-activity 1-2" />
<Activity Name="sub-activity 1-3" />
</Activity>
<Activity Name="sub-activity 2">
<Activity Name="sub-activity 2-1" />
<Activity Name="sub-activity 2-2" />
</Activity>
</Activity>
<Activity Name="Activity 3">
<Activity Name="sub-activity 1">
<Activity Name="sub-activity 1-1" />
<Activity Name="sub-activity 1-2" />
<Activity Name="sub-activity 1-3" />
<Activity Name="sub-activity 1-4" />
</Activity>
<Activity Name="sub-activity 2" />
<Activity Name="sub-activity 3">
<Activity Name="sub-activity 3-1" />
<Activity Name="sub-activity 3-2" />
</Activity>
</Activity>
</Project>

  2. Make sure that the file's "Build Action" property is set to "Content".
  3. Add a Loaded event handler to the main page of the application:

Xaml [image] Copy Code

<Page ...
Loaded="Page_Loaded" ...>

C# [image] Copy Code

private void Page_Loaded(object sender, RoutedEventArgs e)
{
}

  4. Add the following member ot the page class to hold the default node size.

C# [image] Copy Code

Rect nodeBounds = new Rect(0, 0, 100, 20);

  5. Create the tree root node, and call the CreateChildren method, which builds the tree recursively.

C# [image] Copy Code

var root = diagram.Factory.CreateShapeNode(nodeBounds);
root.Text = "Project";
var package = Windows.ApplicationModel.Package.Current;
var loc = package.InstalledLocation;
var document = XDocument.Load(loc.Path + "\\Assets\\SampleTree.xml");
CreateChildren(root, document.Element("Project"));

  6. Define CreateChildren as follows. It takes as parameters the parent DiagramNode and parent XML element, iterates the child XML elements to build the next level of the hierarchy, and creates corresponding diagram items by calling CreateShapeNode and CreateDiagramLink.

C# [image] Copy Code

private void CreateChildren(DiagramNode parentDiagNode, XElement parentXmlElement)
{
foreach (var element in parentXmlElement.Elements("Activity"))
{
var node = diagram.Factory.CreateShapeNode(nodeBounds);
node.Text = element.Attribute("Name").Value;
diagram.Factory.CreateDiagramLink(parentDiagNode, node);
CreateChildren(node, element);
}
}

  7. Use TreeLayout to arrange the diagram. Add the following code to the end of the Loaded handler.

C# [image] Copy Code

var layout = new TreeLayout();
layout.Type = TreeLayoutType.Cascading;
layout.Direction = TreeLayoutDirection.LeftToRight;
layout.LinkStyle = TreeLayoutLinkType.Cascading2;
layout.NodeDistance = 5;
layout.LevelDistance = -25; // let horizontal positions overlap
layout.Arrange(diagram);

  8. Build and run the project. If everything is fine, you should see this representation of the hierarchy:


Tutorial 3: Create a Custom Node Type

Tutorial 3: Create a Custom Node Type

This tutorial shows how to define a custom node class that inherits ShapeNode and adds several new properties. Its appearance is defined using a custom control template.

  1. Right-click the project in Solution Explorer and create a new folder, named Theme. Right-click this folder and choose Add -> New Item from the context menu. Create a new Resource Dictionary file called Generic.xaml and add the following control template to it. Note that ShapeGeometry, Stroke, Brush, Image and Text are properties of the base ShapeNode class. Title and FullName are new properties defined in the custom class.

Xaml [image] Copy Code

<ResourceDictionary xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation" xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml" xmlns:local="using:Tutorial3">
<Style TargetType="local:OrgChartNode">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:OrgChartNode">
<Canvas x:Name="Adorner">
<Path Data="{TemplateBinding ShapeGeometry}" Stroke="{TemplateBinding Stroke}" Fill="{TemplateBinding Brush}" />
<Grid Width="{TemplateBinding Width}" Height="{TemplateBinding Height}">
<Grid.ColumnDefinitions>
<ColumnDefinition Width="80" />
<ColumnDefinition Width="*" />
</Grid.ColumnDefinitions>
<Image Source="{TemplateBinding Image}" HorizontalAlignment="Stretch" VerticalAlignment="Stretch" Stretch="Uniform"></Image>
<StackPanel Margin="4,8,0,0" Orientation="Vertical" Grid.Column="1">
<TextBlock Text="{TemplateBinding Title}" Foreground="Black" FontWeight="800" />
<TextBlock Text="{TemplateBinding FullName}" Foreground="Blue" />
<TextBlock Text="{TemplateBinding Text}" Foreground="Black" FontSize="9" />
</StackPanel>
</Grid>
</Canvas>
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>
</ResourceDictionary>

  2. Add to the project a new class called OrgChartNode. Make it derive from ShapeNode.

C# [image] Copy Code

using Windows.UI.Xaml;
using MindFusion.Diagramming;

namespace Tutorial3
{
public class OrgChartNode : ShapeNode
{
}
}

  3. Add a constructor that sets DefaultStyleKey to associate the node class with the contol template defined in the resource dictionary. Note that "OrgChartNode" is set as TargetType for both the Style and ControlTemplate elements in the XAML.

C# [image] Copy Code

public OrgChartNode()
{
DefaultStyleKey = typeof(OrgChartNode);
}

  4. Define the custom Title and FullName dependency properties.

C# [image] Copy Code

public string Title
{
get { return (string)GetValue(TitleProperty); }
set { SetValue(TitleProperty, value); }
}

public static readonly DependencyProperty TitleProperty = DependencyProperty.Register(
"Title",
typeof(string),
typeof(OrgChartNode),
new PropertyMetadata(""));

public string FullName
{
get { return (string)GetValue(FullNameProperty); }
set { SetValue(FullNameProperty, value); }
}

public static readonly DependencyProperty FullNameProperty = DependencyProperty.Register(
"FullName",
typeof(string),
typeof(OrgChartNode),
new PropertyMetadata(""));

  5. Add a Loaded event handler to the main page of the application.

Xaml [image] Copy Code

<Page ...
Loaded="Page_Loaded" ...>

C# [image] Copy Code

private void Page_Loaded(object sender, RoutedEventArgs e)
{
}

  6. Add a few instances of the OrgChartNode class. Note that the two nodes use images from the Assets folder in their presentation. Make sure to add the images with the same name.

C# [image] Copy Code

var node1 = new OrgChartNode
{
Bounds = new Rect(100, 60, 240, 100),
Title = "CEO",
FullName = "John Smith",
Text = "Our beloved leader. \r\n" +
"The CEO of this great corporation.",
Image = new BitmapImage(
new Uri(loc.Path + "\\Assets\\016.png", UriKind.Absolute))
};
diagram.Nodes.Add(node1);

var node2 = new OrgChartNode
{
Bounds = new Rect(220, 220, 240, 100),
Title = "CIO",
FullName = "Bob Smith",
Text = "The CIO of this great corporation.",
Image = new BitmapImage(
new Uri(loc.Path + "\\Assets\\ac0026-64.png", UriKind.Absolute))
};
diagram.Nodes.Add(node2);

diagram.Factory.CreateDiagramLink(node1, node2);

  7. Build and run the project. You should see the custom nodes rendered like this:


Tutorial 4: Custom Nodes Integration

Tutorial 4: Custom Nodes Integration

This tutorial builds upon the OrgChartNode type from Tutorial 3. It shows how to fully integrate the custom type with other DiagramRT features, such as serialization, undo support, creating nodes by drag-and-drop or drawing with the mouse on the canvas.

  1. Add a NodeListView to the page and add a few OrgChartNode objects as its children:

Xaml [image] Copy Code

<diag:NodeListView Width="150" x:Name="nodeList" />

C# [image] Copy Code

nodeList.Items.Add(new OrgChartNode()
{
Bounds = new Rect(0, 0, 140, 70),
Title = "CEO",
FullName = "Type here",
Text = "Chief executive officer",
ImageWebLocation = Windows.ApplicationModel.Package.Current.InstalledLocation.Path + "\\Assets\\016.png"
});
nodeList.Items.Add(new OrgChartNode()
{
Bounds = new Rect(0, 0, 140, 70),
Title = "CIO",
FullName = "Type here",
Text = "Chief information officer",
ImageWebLocation = Windows.ApplicationModel.Package.Current.InstalledLocation.Path + "\\Assets\\ac0026-64.png"
});

  2. Add a copy constructor to the OrgChartNode class. The control throws an exception if you try to create via drag-and-drop an instance of a class without copy constructor:

C# [image] Copy Code

// Required for creating nodes by dragging them from the NodeListView
public OrgChartNode(OrgChartNode prototype) : base(prototype)
{
DefaultStyleKey = typeof(OrgChartNode);
Title = prototype.Title;
FullName = prototype.FullName;
}

  3. In order to enable drawing OrgChartNodes with the mouse, inherit the LinkNodesBehavior and override its CreateNode method. You could also inherit BehaviorBase or any of its derived classes, and override either CreateNode or StartDraw:

C# [image] Copy Code

public class OrgChartBehavior : LinkNodesBehavior
{
public OrgChartBehavior(Diagram diagram) : base(diagram) { }

protected override DiagramNode CreateNode()
{
return new OrgChartNode();
}
}

  4. Assign an instance of the behavior class to the CustomBehavior property of the Diagram class:

C# [image] Copy Code

private void Page_Loaded(object sender, RoutedEventArgs e)
{
// enable drawing OrgChartNodes with the mouse
diagram.CustomBehavior = new OrgChartBehavior(diagram);
}

  5. To implement serialization of any new properties added by a custom item class, override the SaveToXml and LoadFromXml methods of the base DiagramItem class:

C# [image] Copy Code

// serialization support for custom properties

protected override void SaveToXml(System.Xml.Linq.XElement xmlElement, XmlPersistContext context)
{
base.SaveToXml(xmlElement, context);
context.WriteString(Title, "Title", xmlElement);
context.WriteString(FullName, "FullName", xmlElement);
}

protected override void LoadFromXml(System.Xml.Linq.XElement xmlElement, XmlPersistContext context)
{
base.LoadFromXml(xmlElement, context);
Title = context.ReadString("Title", xmlElement);
FullName = context.ReadString("FullName", xmlElement);
}

  6. Call the static RegisterItemClass method to assign an XML element name to the custom item type:

C# [image] Copy Code

private void Page_Loaded(object sender, RoutedEventArgs e)
{
// enable serialization of the custom class
Diagram.RegisterItemClass(typeof(OrgChartNode), "my:OrgChartNode", 1);

// enable drawing OrgChartNodes with the mouse
diagram.CustomBehavior = new OrgChartBehavior(diagram);
}

  7. In order to enable undo / redo of changes done on OrgChartNode, create a DiagramItemState-derived class that contains member corresponding to the additional properties defined by OrgChartNode:

C# [image] Copy Code

public class OrgChartNodeState : ShapeNodeState
{
internal string Title;
internal string FullName;
}

  8. Override the CreateState, SaveState and RestoreState methods:

C# [image] Copy Code

// undo and redo support

protected override DiagramItemState CreateState()
{
return new OrgChartNodeState();
}

protected override DiagramItemState SaveState()
{
var state = (OrgChartNodeState)base.SaveState();
state.Title = Title;
state.FullName = FullName;
return state;
}

protected override void RestoreState(DiagramItemState itemState)
{
base.RestoreState(itemState);

var state = (OrgChartNodeState)itemState;
Title = state.Title;
FullName = state.FullName;
}

  9. The full source code for this tutorial with several additional UI controls that invoke serialization and undo methods is available in the Samples\CSharp\Tutorial4 subfolder under the DiagramRT installation folder.


Reference

Reference


MindFusion.Diagramming Namespace

MindFusion.Diagramming Namespace
Classes Interfaces Structures Delegates Enumerations

Classes

Class | Description
AddItemCommand | Implements creation of new diagram items.
AdjustmentHandle | The members of this class specify which selection handles of an item should be enabled or disabled.
AnchorPattern | Represents a set of anchor points, which specify the exact locations where links are allowed to connect to nodes.
AnchorPoint | Represents a location in a node to which links are allowed to connect.
AnchorPointCollection | Represents a strongly-typed collection of anchor points.
AnchorPointDetails | Contains information about the location where links connects to a node.
ArcTemplate | Represents an arc segment in a Shape definition.
ArrowHeads | Contains predefined arrowhead shapes.
BehaviorBase | An abstract base class for types that define how the control reacts to users' actions with a mouse or other pointing devices.
BezierTemplate | Represents a Bezier curve in a Shape definition.
BoolValueConverter | Converts boolean to Visibility.
Brushes | Brushes contains some predefined Brush objects used by the control.
Cell | Represents a cell in a TableNode instance.
CellEventArgs | Contains the arguments passed to event handlers, such as CellClicked.
ChangeItemCommand | Handles undo / redo of property changes.
Clip | A helper class which can provide ClipToBounds functionality in WinRT.
CollectionBase(T, E) | Defines a collection that raises events to notify when elements are added to or removed from it.
Column | Represents a column of a TableNode.
Command | Represents an action that changes the diagram and whose effects can be undone.
CompositeCommand | Represents a set of Command instances as a single operation. Undoing or redoing the composite action, respectively undoes or redoes all its constituent subactions at the same time.
ConnectionPoint | This class represents a connection between an edge and a node in a graph. It decouples the DiagramLink class from the DiagramNode class, allowing edges to connect different types of nodes without knowing anything of their implementation details. Each DiagramLink object contains two ConnectionPoint instances describing the connections at both ends of the link.
Constants | Contains various global constants, also provides measure unit independent constants.
ContainerChildEventArgs | Contains arguments passed to ContainerChildEventHandler,
ContainerNode | Represents a diagram node that can contain other nodes.
ContainerNodeState | Represents the state of a ContainerNode.
ControlNode | ControlNode instances represent diagram nodes which can host WinRT controls.
ControlNodeEventArgs | Contains the arguments passes to handlers of the control host serialization events.
ControlNodeState | Represents the state of a ControlNode.
Converter | Provides capabilities to convert various types to and from strings in a culture-independent way.
DashArrayConverter | Used to clone DoubleCollection instances when implementing StrokeDashArray in control templates, since DoubleCollections cannot be shared between controls.
DashStyle | Defines the dash style of a Pen.
DashStyles | Provides several stock pen dash styles.
Diagram | The Diagram class represents a flow diagram.
DiagramBase | The base class of the Diagram and DiagramDocument classes.
DiagramDocument | Represents a collection of diagram pages.
DiagramEventArgs | Contains the arguments passed to event handlers, such as Clicked and DoubleClicked.
DiagramItem | Represents an item in the diagram document. All classes representing diagram elements derive from DiagramItem.
DiagramItemCollection | Represents a strongly typed collection of DiagramItem objects.
DiagramItemState | Saves the state of this diagram item.
DiagramLink | Represents a link between two diagram nodes.
DiagramLinkCollection | Represents a strongly typed collection of DiagramLink objects.
DiagramLinkState | Contains a snapshot of the internal state of a DiagramLink. Instances of this class are used to store the state of links for later undo or redo operations.
DiagramNode | DiagramNode is an abstract base class from which the ShapeNode, TableNode and ControlNode classes derive. DiagramNode instances can represent graph vertices, nodes in organizational or flow diagrams, entities in ER diagrams, and so on.
DiagramNodeCollection | Represents a strongly typed collection of diagram nodes.
DiagramNodeState | Contains a snapshot of the internal state of a DiagramNode. Instances of this class are used to store the state of nodes for later undo or redo operations. If you derive from DiagramNode and need to implement undo support for the additional internal state defined by your class, do so by deriving from DiagramNodeState and overriding the createState, saveState and restoreState methods.
DiagramPage | Represents a single page in a DiagramDocument object.
DiagramPageEventArgs | Contains the arguments passed to DiagramPage-related event handlers.
DiagramPageValidationEventArgs | Contains the arguments passed to handlers of DiagramPage validation events.
DiagramTabControl | Represents a TabControl that displays DiagramTabItem items.
DiagramTabItem | Represents a tab item in a DiagramTabControl.
DiagramTabItemButton | For internal use.
DockToVisibilityConverter | Converts Dock to Visibility.
DoNothingBehavior | Implements the DoNothing behavior.
DrawContainersBehavior | Implements the DrawContainers behavior.
DrawControlsBehavior | This class is used when the diagram behavior is set to BehaviorType.DrawControls.
DrawHandlesEventArgs | Contains the arguments passed to the HitTestAdjustmentHandles event handlers.
DrawLinksBehavior | This class is used when the diagram behavior is set to Behavior.DrawLinks.
DrawNodesBehavior | The base class for behavior types that allow drawing of nodes, but not links.
DrawShapesBehavior | Implements the DrawShapes behavior.
DrawTablesBehavior | Implements the DrawTables behavior.
DrawTreeViewsBehavior | This class is used when the diagram behavior is set to Behavior.DrawTreeViews.
DummyConnectionPoint | Represents connection points for unconnected links.
DummyNode | Represents virtual nodes used for disconnected links.
EditLinkTextEventArgs | Contains the arguments passed to the EditLinkTextEventArgs event handlers.
EditNodeTextEventArgs | Contains the arguments passed to the NodeTextEdited event handlers.
ElementTemplate | The base class for the elements that can be used in Shape definitions. This is the parent class of specific element types, such as ArcTemplate, LineTemplate, RoundRectangleTemplate and BezierTemplate.
ExpandButton | Represents the expand/collapse button displayed beside Expandable nodes.
Factory | Provides shortcut methods for creating and adding instances of the standard WpfDiagram item types. Call the class methods through the Factory property of the Diagram class.
FilledRectangle | Control that is displayed in ControlNodes by default to make them visible.
FoldButton | Represents the fold / unfold button of containers.
GeometryCloneConverter | Implements cloning of RectangleGeometry objects, required because geometries cannot be shared by multiple bindings.
GraphicsUnit | Specifies units of measure for a given data.
GridRouter | Implements a link routing algorithm that uses a grid to represent the free and occupied regions in the diagram.
HandlesVisualStyle | Defines stroke and brush attributes used to draw selection handles.
HatchBrush | Emulates GDI+ hatch brushes using the WPF ImageBrush class.
HitTestEventArgs | Contains the arguments passed to the HitTestAdjustmentHandles event handlers.
InPlaceEditEventArgs | Contains the arguments passed to the EnterInplaceEditMode and LeaveInplaceEditMode event handlers.
Interaction | Encapsulates the current state of user interaction with the control.
InteractionState | Encapsulates the current state of user interaction with the control.
ItemCollectionBase(T) | A base collection class for the diagram item collections.
ItemEventArgs | Contains the arguments passed to item instantiation event handlers.
Layer | Represents a layer in a Diagram object.
LayerListBox | Represents the ListBox control inside a LayerListView.
LayerListBoxItem | Represents an item in a LayerListBox control.
LayerListView | Represents a list box with MindFusion.Diagramming.Layer objects.
LineTemplate | Represents a line segment in a shape definition.
LinkContainersBehavior | This class is used when the diagram behavior is set to Behavior.LinkContainers.
LinkControlsBehavior | This class is used when the diagram behavior is set to Behavior.LinkControls.
LinkEventArgs | Contains the arguments passed to handlers of link related events, such as LinkCreated and LinkDeleted.
LinkLabel | Represents a label displayed by a DiagramLink. New labels can be added to a link by calling the DiagramLink.AddLabel method.
LinkNodesBehavior | The base class for behavior types that allow drawing both nodes and links.
LinkShapeEventArgs | Contains the arguments passed to the SetSelfLoopShape event handler.
LinkShapesBehavior | This class is used when the diagram behavior is set to Behavior.LinkShapes.
LinkTablesBehavior | This class is used when the diagram behavior is set to Behavior.LinkTables.
LinkTreeViewsBehavior | This class is used when the diagram behavior is set to Behavior.LinkTreeViews.
LinkValidationEventArgs | Contains the arguments passed to handlers of link validation events.
MillimeterConverter | Returns millimeter size in current measure unit.
ModifyBehavior | This class is used when the diagram behavior is set to Behavior.Modify.
NodeConstraints | Defines specific constraints that can be applied to the size and location of nodes.
NodeEffect | Represents the base class of all visual effects that can be applied to the nodes in a Diagram.
NodeEventArgs | Contains the arguments passed to handlers of node-related events.
NodeListView | A ListBox control with support for hosting DiagramNode -derived objects and dragging them to the Diagram control. Items' labels can be set by assigning them to the Tag property of nodes.
NodeListViewEventArgs | Contains data about the DragDropCompleted event.
NodeValidationEventArgs | Contains the arguments passed to handlers of node validation events.
OrientationVisibilityConverter | Converts Orientation to Visibility.
Overview | The Overview control provides a scaled-down view of a Diagram contents and allows scrolling and zooming the diagram with the mouse.
PageRenamedEventArgs | Contains arguments for the PageRenamed event.
PanBehavior | This class is used when the diagram behavior is set to Behavior.Pan.
Pen | Pen instances are used to draw the outline of geometric shapes.
PrintOptions | Provides properties that allow customization of various aspects of printing and print-preview.
QuickRouter | Implements a very fast link routing algorithm that uses a tree to represent the free and occupied regions in the diagram.
RemoveItemCommand | Implements deletion of diagram items.
RenderOptions | Provides properties that allow customization of various aspects of printing and print-preview.
RoundRectangleTemplate | Represents an ElementTemplate that draws round rectangle.
RoutingOptions | Allows customization of various aspects of the link routing algorithm.
Row | Represents a row in a TableNode object.
Ruler | The Ruler control provides horizontal and vertical scales that help users measure diagram items.
ScrollArrowEventArgs | Contains arguments for the ScrollArrowClicked event.
Selection | Represents a set of items selected in the diagram document.
SelectionCopy | Used internally in the implementation of copy/paste functions.
SelectOnlyBehavior | This class is used when the diagram behavior is set to Behavior.SelectOnly.
SerializeTagEventArgs | Contains the arguments passed to the SerializeTag and DeserializeTag event handlers.
Shape | An instance of this class represents a shape defined through a series of arc, line and Bezier segments. The segments can be a part of the shape outline, in which case they define the part of the shape is filled, used for hit-testing and for aligning links to the node edges. Segments can also be added as decoration elements, in which case they only affect the appearance of a ShapeNode.
ShapeConverter | Converts from Shape to other data types.
ShapeDecoration | That class contained an array of shape template elements that define shape decorations. Can contain lines, arcs and Bézier curves. The shape is closed and filled.
ShapeLibrary | The ShapeLibrary class represents a collection of Shape definitions stored together.
ShapeNode | ShapeNode instances are diagram nodes that represent geometric shapes.
ShapeNodeState | Represents the state of a ShapeNode.
Shapes | Provides alternative methods of access to the predefined shapes, that allows code completion and IntelliSense support, which is not available when using Shape.FromId.
StringFormat | Specifies the text alignment for labels displayed inside diagram items.
StrokeConverter | Scales stroke thickness values to reverse the effect of Viewbox scaling.
TabbedDiagramView | Represents a control that can display DiagramDocument objects. The individual diagram pages can be activated through the tabs in the tray located at one of the view sides.
TabHeaderPanel | This class is for internal use only.
TableNode | Tables are diagram nodes that can contain multiple cells and can be related to other nodes through their rows.
TableNodeState | Represents the state of a TableNode.
TabThicknessConverter | Converts Dock to Thickness.
TextWrappingConverter | Converts boolean values to TextWrapping values.
Theme | Represents a set of Style objects for different diagram item types.
ThicknessConverter | Converts strings to Thickness values.
TranslateLayer | A UIElement that is child to Diagram and contains all its items. It allows to apply translation on all items without changing the diagram object. This is used for implemention Diagram.Bounds, e.g. when Bounds = (20,20,40,40) Item at coordinate 20,20 must be rendered at Diagram coordinate 0,0.
TreeItemCollection | Represents a strongly typed collection of TreeViewItem objects.
TreeView | A container for the child items of a TreeViewItem.
TreeViewConnectionPoint | Represents a connection between a link and a TreeViewNode.
TreeViewItem | Represents a constituent item of the hierarchy displayed inside a TreeViewNode.
TreeViewItemState | Represents the state of a TreeViewItem.
TreeViewNode | Represents nodes that can draw hierarchical data.
TreeViewNodeState | Represents the state of a TreeViewNode.
UndoEventArgs | Contains the arguments passed to the ActionRecorded, ActionUndone and ActionRedone event handlers.
Utilities | Contains common helper methods.
VirtualizingDiagram | Implements virtualization of diagram elements.
VirtualLinkEventArgs | Contains arguments passed to handlers of the LinkRealized event.
VirtualNodeEventArgs | Contains arguments passed to handlers of the NodeRealized event.
VisibilityConverter | Converts boolean property values to Visibility values.
XmlPersistContext | Contains methods that can help you serialize and deserialize Diagram items to end from XML documents.
ZoomButton | The button used in ZoomControl.
ZoomControl | ZoomControl lets users zoom and pan a target Diagram interactively.

Interfaces

Interface | Description
ILinkRouter | Defines methods that should be implemented by a link-router component. The control calls them when a new link path should be set in response to changes in the diagram, such as adding or modifying nodes.
InplaceEditable | Represents an in-place editable object.
IZoomTarget | Specifies the capabilities required by ZoomControl from its target controls.

Structures

Structure | Description
PointI | Point with integer coordinates.

Delegates

Delegate | Description
InstantiateLink | Represent a method that creates actual DiagramLink objects to represent data items on screen.
InstantiateLinkData | Represents a method that instantiates data items for links drawn by the user.
InstantiateNode | Represent a method that creates actual DiagramNode -derived objects to represent data items on screen.
InstantiateNodeData | Represents a method that instantiates data items for nodes drawn by the user.
ItemEventHandler(T) | Represents methods that will handle general item-related events.
ResolveNodePosition | Represents a method that determines the position of a data item within the diagram.

Enumerations

Enumeration | Description
Action | Specifies the possible actions a user can carry out on diagram items.
AdjustmentHandles | Identifies the distinct selection handles of a node.
Alignment | Generalized alignment enum.
Anchoring | Defines values that specify how automatic layout algorithms align links to anchor points.
AutoResize | Defines in which directions automatic resizing can enlarge the diagram scrollable area.
Behavior | Defines values that specify how the component responds to actions performed by the user.
DelKeyAction | Specifies the type of action performed when the user presses the DEL key.
DirectionConstraint | Defines values that specify in what direction to constrain node movement.
Dock | Specifies a dock destination.
ExpandButtonAction | Specifies what action is triggered by the +/- buttons that are displayed near expandable nodes.
ExpandButtonPosition | Defines values that specify possible locations for expand/collapse buttons.
Granularity | Specifies the granularity of the obstacles map generated by QuickRouter.
GridStyle | Defines values that specify the visual style of the alignment grid.
HandlesStyle | Enumerates possible visual styles for frames that are drawn around selected nodes.
HatchStyle | Represents hatch patterns corresponding to GDI+ HatchBrush objects.
HitTestPriority | Defines values that specify the order of item hit-testing.
ImageAlign | Specifies the position and alignment of a picture in a box or table, or that of the background image.
LinkCrossings | Defines values that indicate how to render link intersection points.
LinkShape | Specifies available link shapes.
MarkStyle | Specifies the visual style of anchor point marks.
ModificationStart | Specifies how the user can start modifying an item.
MouseButton | Specifies constants that define which mouse button was pressed.
Orientation | Defines values that specify the orientation of the first segment of cascading links.
RelativeToLink | Specifies how the link labels are positioned.
RerouteLinks | Provides values indicating in what circumstances links must be rerouted automatically.
RulerUnit | Specifies a measurement unit for the Ruler.
SaveToStringFormat | Specifies in what format to save the diagram when generating a string using the SaveToString method.
ScrollDirection | Identifies the direction of a scroll arrow.
ShowAnchors | Specifies when anchors points should be displayed.
SimpleShape | Defines the possible values for the Shape property of tables.
StringAlignment | Replaces System.Drawing.StringAlignment
TabAlignment | Specifies the alignment of the tab headers in a TabControl.
TabLayoutMode | Specifies how tab items are arranged in the header of a TabControl.
TableConnectionStyle | Specifies the possible values for the ConnectionStyle property of tables.
TabRotation | Specifies the rotation of the tab items in a DiagramTabControl.
TickPosition | Specifies the position of trackbar ticks.
TreeViewConnectionStyle | Specifies the possible values for the ConnectionStyle property of TreeViewNodes.


MindFusion.Diagramming.Action Enumeration

Action Enumeration
See Also
[image]

Specifies the possible actions a user can carry out on diagram items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum Action

Visual Basic [image] Copy Code

Public Enum Action

Members

Member name | Description
Create | Draw a new item.
Modify | Modify an existing item.
None | Do not perform any action.
Split | Split a link's segment.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.AddItemCommand Class

AddItemCommand Class
Remarks See Also
[image]

Implements creation of new diagram items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class AddItemCommand : Command

Visual Basic [image] Copy Code

Public Class AddItemCommand
Inherits Command

Remarks

The control automatically creates instances of this class when items are added either interactively or from code.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Command
MindFusion.Diagramming.AddItemCommand

See Also

AddItemCommand Members
MindFusion.Diagramming Namespace
RemoveItemCommand Class
ChangeItemCommand Class


MindFusion.Diagramming.AddItemCommand Members

AddItemCommand Members
Constructors Properties Methods
[image]

Implements creation of new diagram items.

The following tables list the members exposed by the AddItemCommand type.

Public Constructors

Name | Description
AddItemCommand | Initializes a new instance of the AddItemCommand class.

Inherited Public Properties

Name | Description
Diagram | Gets the Diagram modified by this Command object. (Inherited from Command.)

Public Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

Inherited Public Methods

Name | Description
Execute | Carries out an action that changes the diagram in some way. (Inherited from Command.)
Redo | Repeats an action that has been undone. (Inherited from Command.)
Undo | Undoes an action, restoring the diagram to the state it was in before carrying out the action. (Inherited from Command.)

See Also

AddItemCommand Class


MindFusion.Diagramming.AddItemCommand Constructor

AddItemCommand Constructor
[image]

Initializes a new instance of the AddItemCommand class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AddItemCommand (
Diagram diagram,
DiagramItem item
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram, _
item As DiagramItem _
)

Parameters

diagram
A Diagram to which the new item is added.
item
A new DiagramItem that should be added to the Diagram.

See Also

AddItemCommand Class


MindFusion.Diagramming.AddItemCommand Methods

AddItemCommand Methods
[image]

Public Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

Inherited Public Methods

Name | Description
Execute | Carries out an action that changes the diagram in some way. (Inherited from Command.)
Redo | Repeats an action that has been undone. (Inherited from Command.)
Undo | Undoes an action, restoring the diagram to the state it was in before carrying out the action. (Inherited from Command.)

See Also

AddItemCommand Class


MindFusion.Diagramming.AddItemCommand.Execute Method

AddItemCommand.Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Execute ()

Visual Basic [image] Copy Code

Public Overrides Sub Execute ()

See Also

AddItemCommand Members
AddItemCommand Class


MindFusion.Diagramming.AddItemCommand.Redo Method

AddItemCommand.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Redo ()

Visual Basic [image] Copy Code

Public Overrides Sub Redo ()

See Also

AddItemCommand Members
AddItemCommand Class


MindFusion.Diagramming.AddItemCommand.Undo Method

AddItemCommand.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Undo ()

Visual Basic [image] Copy Code

Public Overrides Sub Undo ()

See Also

AddItemCommand Members
AddItemCommand Class


MindFusion.Diagramming.AdjustmentHandle Class

AdjustmentHandle Class
[image]

The members of this class specify which selection handles of an item should be enabled or disabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class AdjustmentHandle

Visual Basic [image] Copy Code

Public Class AdjustmentHandle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.AdjustmentHandle

See Also

AdjustmentHandle Members


MindFusion.Diagramming.AdjustmentHandle Members

AdjustmentHandle Members
Constructors Properties
[image]

The members of this class specify which selection handles of an item should be enabled or disabled.

The following tables list the members exposed by the AdjustmentHandle type.

Public Constructors

Name | Description
AdjustmentHandle | Initializes a new instance of the AdjustmentHandle class.

Public Properties

Name | Description
Index | Gets or sets the index of the AdjustmentHandle instance.
Item | A DiagramItem instance whose adjustment handles are enabled or disabled.

See Also

AdjustmentHandle Class


MindFusion.Diagramming.AdjustmentHandle Constructor

AdjustmentHandle Constructor
[image]

Initializes a new instance of the AdjustmentHandle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AdjustmentHandle (
DiagramItem item,
int index
)

Visual Basic [image] Copy Code

Public Sub AdjustmentHandle ( _
item As DiagramItem, _
index As Integer _
)

Parameters

item
A DiagramItem instance whose adjustment handles are enabled or disabled.
index

See Also

AdjustmentHandle Class


MindFusion.Diagramming.AdjustmentHandle Properties

AdjustmentHandle Properties
[image]

Public Properties

Name | Description
Index | Gets or sets the index of the AdjustmentHandle instance.
Item | A DiagramItem instance whose adjustment handles are enabled or disabled.

See Also

AdjustmentHandle Class


MindFusion.Diagramming.AdjustmentHandle.Index Property

AdjustmentHandle.Index Property
[image]

Gets or sets the index of the AdjustmentHandle instance.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Index { get; set; }

Visual Basic [image] Copy Code

Public Property Index As Integer

Property Value

See Also

AdjustmentHandle Members
AdjustmentHandle Class


MindFusion.Diagramming.AdjustmentHandle.Item Property

AdjustmentHandle.Item Property
[image]

A DiagramItem instance whose adjustment handles are enabled or disabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem Item { get; set; }

Visual Basic [image] Copy Code

Public Property Item As DiagramItem

Property Value

See Also

AdjustmentHandle Members
AdjustmentHandle Class


MindFusion.Diagramming.AdjustmentHandles Enumeration

AdjustmentHandles Enumeration
[image]

Identifies the distinct selection handles of a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum AdjustmentHandles

Visual Basic [image] Copy Code

Public Enum AdjustmentHandles

Members

Member name | Description
All | All selection handles areenabled and canbe used to modify the node.
BottomHandles | The bottom-left, bottom-center and bottom-right handles are enabled.
CornerHandles | The four corner handles are enabled.
HeightHandles | All top and bottom handles are enabled.
LeftHandles | The top-left, middle-left and bottom-left handles are enabled.
MiddleHandles | The four middle handles are enabled.
Move | The center selection handle is enabled and can be used to move the node.
None | Specifies that none of the selection handles can be used to modify the node.
ResizeBottomCenter | The bottom-center handle is enabled and can be used to resize the node vertically.
ResizeBottomLeft | The bottom-left handle is enabled and can be used to resize the node.
ResizeBottomRight | The bottom-right handle is enabled and can be used to resize the node.
ResizeHandles | The eight resize handles are enabled.
ResizeMiddleLeft | The middle-left handle is enabled and can be used to resize the node horizontally.
ResizeMiddleRight | The middle-right handle is enabled and can be used to resize the node horizontally.
ResizeTopCenter | The top-center handle is enabled and can be used to resize the node vertically.
ResizeTopLeft | The top-left handle is enabled and can be used to resize the node.
ResizeTopRight | The top-right handle is enabled and can be used to resize the node.
RightHandles | The top-right, bottom-right and middle-right handles are enabled.
Rotate | The rotation handle is enabled and can be used to rotate the node.
TopHandles | The top-left, top-center and top-right handles are enabled.
WidthHandles | All left and right handles are enabled.

Remarks

Members of this enumeration can be assigned to the EnabledHandles property of nodes.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.Alignment Enumeration

Alignment Enumeration
[image]

Generalized alignment enum.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum Alignment

Visual Basic [image] Copy Code

Public Enum Alignment

Members

Member name | Description
Far | Specifies that alignment is to the far extent of the layout rectangle.
Near | Specifies that alignment is towards the origin of the layout rectangle.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.Anchoring Enumeration

Anchoring Enumeration
[image]

Defines values that specify how automatic layout algorithms align links to anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum Anchoring

Visual Basic [image] Copy Code

Public Enum Anchoring

Members

Member name | Description
Ignore | Anchor points are ignored.
Keep | Links are aligned to their original anchor points.
Reassign | Links are aligned to new anchor points, depending on the positions of graph nodes after a layout is applied.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.AnchorPattern Class

AnchorPattern Class
[image]

Represents a set of anchor points, which specify the exact locations where links are allowed to connect to nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class AnchorPattern

Visual Basic [image] Copy Code

Public Class AnchorPattern

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.AnchorPattern

See Also

AnchorPattern Members


MindFusion.Diagramming.AnchorPattern Members

AnchorPattern Members
Constructors Properties Methods
[image]

Represents a set of anchor points, which specify the exact locations where links are allowed to connect to nodes.

The following tables list the members exposed by the AnchorPattern type.

Public Constructors

Name | Description
AnchorPattern | Overloaded.

Public Properties

Name | Description
Decision1In3Out | Gets the predefined anchor pattern Decision1In3Out.
Decision2In2Out | Gets the predefined anchor pattern Decision2In2Out.
Id | Gets the AnchorPattern unique identifier.
LeftInRightOut | Gets the predefined anchor pattern LeftInRightOut.
Points | Gets a collection of the anchor points in this pattern.
TopInBottomOut | Gets the predefined anchor pattern TopInBottomOut.

Public Methods

Name | Description
Clone | Creates an exact clone of this AnchorPattern object.
FromId | Returns a reference to the anchor pattern with the specified string identifier.
Register | Registers the specified anchor pattern as shared.

See Also

AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Constructor

AnchorPattern Constructor
[image]

Overload List

Name | Description
AnchorPattern () | Intializes a new empty instance of the AnchorPattern class.
AnchorPattern (AnchorPoint[]) | Intializes a new instance of the AnchorPattern class with the specified anchor points.
AnchorPattern (AnchorPoint[], String) | Intializes a new instance of the AnchorPattern class with the specified anchor points.
AnchorPattern (AnchorPointCollection) | Intializes a new instance of the AnchorPattern class with the specified anchor points.
AnchorPattern (AnchorPointCollection, String) | Intializes a new instance of the AnchorPattern class with the specified anchor points.
AnchorPattern (String) | Intializes a new empty instance of the AnchorPattern class.

See Also

AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Constructor ()

AnchorPattern Constructor ()
See Also
[image]

Intializes a new empty instance of the AnchorPattern class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Constructor (AnchorPoint[])

AnchorPattern Constructor (AnchorPoint[])
See Also
[image]

Intializes a new instance of the AnchorPattern class with the specified anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern (
AnchorPoint[] points
)

Visual Basic [image] Copy Code

Public New ( _
points() As AnchorPoint _
)

Parameters

points
Contains the initial set of AnchorPoint instances for the new pattern.

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Constructor (AnchorPoint[], String)

AnchorPattern Constructor (AnchorPoint[], String)
See Also
[image]

Intializes a new instance of the AnchorPattern class with the specified anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern (
AnchorPoint[] points,
string id
)

Visual Basic [image] Copy Code

Public New ( _
points() As AnchorPoint, _
id As String _
)

Parameters

points
Contains the initial set of AnchorPoint instances for the new pattern.
id

An unique identifier for this anchor pattern.

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Constructor (AnchorPointCollection)

AnchorPattern Constructor (AnchorPointCollection)
See Also
[image]

Intializes a new instance of the AnchorPattern class with the specified anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern (
AnchorPointCollection points
)

Visual Basic [image] Copy Code

Public Sub AnchorPattern ( _
points As AnchorPointCollection _
)

Parameters

points
A collection of AnchorPoint objects.

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Constructor (AnchorPointCollection, String)

AnchorPattern Constructor (AnchorPointCollection, String)
See Also
[image]

Intializes a new instance of the AnchorPattern class with the specified anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern (
AnchorPointCollection points,
string id
)

Visual Basic [image] Copy Code

Public Sub AnchorPattern ( _
points As AnchorPointCollection, _
id As String _
)

Parameters

points
A collection of AnchorPoint objects.
id

An unique identifier for this anchor pattern.

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Constructor (String)

AnchorPattern Constructor (String)
See Also
[image]

Intializes a new empty instance of the AnchorPattern class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern (
string id
)

Visual Basic [image] Copy Code

Public New ( _
id As String _
)

Parameters

id

An unique identifier for this anchor pattern.

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Methods

AnchorPattern Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact clone of this AnchorPattern object.
FromId | Returns a reference to the anchor pattern with the specified string identifier.
Register | Registers the specified anchor pattern as shared.

See Also

AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.Clone Method

AnchorPattern.Clone Method
[image]

Creates an exact clone of this AnchorPattern object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

An instance of the AnchorPattern class.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.FromId Method

AnchorPattern.FromId Method
[image]

Returns a reference to the anchor pattern with the specified string identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static AnchorPattern FromId (
string id
)

Visual Basic [image] Copy Code

Public Shared Function FromId ( _
id As String _
) As AnchorPattern

Parameters

id
A string identifying an AnchorPattern instance.

Return Value

The AnchorPattern object whose Id is equal to the id parameter, or null (Nothing in Visual Basic) if no such object exists.

Remarks

The id argument should match an identifier passed to the constructor of an existing AnchorPattern object.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.Register Method

AnchorPattern.Register Method
[image]

Registers the specified anchor pattern as shared.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void Register (
AnchorPattern pattern
)

Visual Basic [image] Copy Code

Public Shared Sub Register ( _
pattern As AnchorPattern _
)

Parameters

pattern
The AnchorPattern to register.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Properties

AnchorPattern Properties
[image]

Public Properties

Name | Description
Decision1In3Out | Gets the predefined anchor pattern Decision1In3Out.
Decision2In2Out | Gets the predefined anchor pattern Decision2In2Out.
Id | Gets the AnchorPattern unique identifier.
LeftInRightOut | Gets the predefined anchor pattern LeftInRightOut.
Points | Gets a collection of the anchor points in this pattern.
TopInBottomOut | Gets the predefined anchor pattern TopInBottomOut.

See Also

AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.Decision1In3Out Property

AnchorPattern.Decision1In3Out Property
[image]

Gets the predefined anchor pattern Decision1In3Out.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static AnchorPattern Decision1In3Out { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Decision1In3Out As AnchorPattern

Property Value

Remarks

Incoming links connect to the top vertex; outgoing links can start from the other vertices.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.Decision2In2Out Property

AnchorPattern.Decision2In2Out Property
[image]

Gets the predefined anchor pattern Decision2In2Out.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static AnchorPattern Decision2In2Out { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Decision2In2Out As AnchorPattern

Property Value

Remarks

Incoming links can connect with the top and left vertices; outgoing links can start from the right and bottom vertices.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.Id Property

AnchorPattern.Id Property
[image]

Gets the AnchorPattern unique identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Id { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Id As String

Property Value

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.LeftInRightOut Property

AnchorPattern.LeftInRightOut Property
[image]

Gets the predefined anchor pattern LeftInRightOut.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static AnchorPattern LeftInRightOut { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property LeftInRightOut As AnchorPattern

Property Value

Remarks

The middle point of a node's bounding rectangle left side is anchor for incoming links; that on the right side - for outgoing.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.Points Property

AnchorPattern.Points Property
[image]

Gets a collection of the anchor points in this pattern.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPointCollection Points { get; set; }

Visual Basic [image] Copy Code

Public Property Points As AnchorPointCollection

Property Value

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.TopInBottomOut Property

AnchorPattern.TopInBottomOut Property
[image]

Gets the predefined anchor pattern TopInBottomOut.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static AnchorPattern TopInBottomOut { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property TopInBottomOut As AnchorPattern

Property Value

Remarks

The middle point of a node's bounding rectangle top side is anchor for incoming links; that on the bottom - for outgoing.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPoint Class

AnchorPoint Class
[image]

Represents a location in a node to which links are allowed to connect.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class AnchorPoint

Visual Basic [image] Copy Code

Public NotInheritable Class AnchorPoint

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.AnchorPoint

See Also

AnchorPoint Members


MindFusion.Diagramming.AnchorPoint Members

AnchorPoint Members
Constructors Properties Methods
[image]

Represents a location in a node to which links are allowed to connect.

The following tables list the members exposed by the AnchorPoint type.

Public Constructors

Name | Description
AnchorPoint | Overloaded.

Public Properties

Name | Description
AllowIncoming | Gets or sets a value indicating whether incoming links can be connected to this anchor.
AllowOutgoing | Gets or sets a value indicating whether the anchor point accepts outgoing connections.
Brush | Gets or sets the brush of the anchor point mark.
Column | Gets or sets the column index of a cell with which the anchor point is associated.
MarkStyle | Gets or sets the appearance of the anchor point mark.
Size | Gets or sets the size of the anchor point.
Tag | Gets or sets a user-defined data associated with the anchor point.
ToolTip | Gets or sets a tooltip text that should be displayed when the mouse hovers over an anchor point mark.
X | Gets or sets the horizontal position of the anchor point expressed as percent of a node's width.
Y | Gets or sets the vertical position of the anchor point expressed as percent of a node's height.

Public Methods

Name | Description
Clone | Creates an exact clone of this AnchorPoint object.

See Also

AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Constructor

AnchorPoint Constructor
[image]

Overload List

Name | Description
AnchorPoint (Double, Double) | Initializes a new instance of the AnchorPoint class with the specified coordinates.
AnchorPoint (Double, Double, Boolean, Boolean) | Initializes a new instance of the AnchorPoint class with the specified coordinates and restrictions.
AnchorPoint (Double, Double, Boolean, Boolean, Brush, Int32) | Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions and brush.
AnchorPoint (Double, Double, Boolean, Boolean, Brush, Int32, Object) | Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions, brush and tag.
AnchorPoint (Double, Double, Boolean, Boolean, MarkStyle) | Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions and style.
AnchorPoint (Double, Double, Boolean, Boolean, MarkStyle, Brush) | Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions, style and brush.

See Also

AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Constructor (Double, Double)

AnchorPoint Constructor (Double, Double)
See Also
[image]

Initializes a new instance of the AnchorPoint class with the specified coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPoint (
double x,
double y
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double _
)

Parameters

x

The horizontal position of the anchor expressed as percent of the width of a node.

y

The vertical position of the anchor expressed as percent of the height of a node.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Constructor (Double, Double, Boolean, Boolean)

AnchorPoint Constructor (Double, Double, Boolean, Boolean)
See Also
[image]

Initializes a new instance of the AnchorPoint class with the specified coordinates and restrictions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPoint (
double x,
double y,
bool allowIncoming,
bool allowOutgoing
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
allowIncoming As Boolean, _
allowOutgoing As Boolean _
)

Parameters

x

The horizontal position of the anchor expressed as percent of the width of a node.

y

The vertical position of the anchor expressed as percent of the height of a node.

allowIncoming

Specifies whether incoming links can connect to this anchor.

allowOutgoing

Specifies whether outgoing links can connect to this anchor.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Constructor (Double, Double, Boolean, Boolean, Brush, Int32)

AnchorPoint Constructor (Double, Double, Boolean, Boolean, Brush, Int32)
See Also
[image]

Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions and brush.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPoint (
double x,
double y,
bool allowIncoming,
bool allowOutgoing,
Brush brush,
int col
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
allowIncoming As Boolean, _
allowOutgoing As Boolean, _
brush As Brush, _
col As Integer _
)

Parameters

x

The horizontal position of the anchor expressed as percent of the width of a node.

y

The vertical position of the anchor expressed as percent of the height of a node.

allowIncoming

Specifies whether incoming links can connect to this anchor.

allowOutgoing

Specifies whether outgoing links can connect to this anchor.

brush

The brush with which the anchor mark is painted.

col

Specifies a table's column, with which an anchor point is associated.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Constructor (Double, Double, Boolean, Boolean, Brush, Int32, Object)

AnchorPoint Constructor (Double, Double, Boolean, Boolean, Brush, Int32, Object)
See Also
[image]

Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions, brush and tag.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPoint (
double x,
double y,
bool allowIncoming,
bool allowOutgoing,
Brush brush,
int col,
Object tag
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
allowIncoming As Boolean, _
allowOutgoing As Boolean, _
brush As Brush, _
col As Integer, _
tag As Object _
)

Parameters

x

The horizontal position of the anchor expressed as percent of the width of a node.

y

The vertical position of the anchor expressed as percent of the height of a node.

allowIncoming

Specifies whether incoming links can connect to this anchor.

allowOutgoing

Specifies whether outgoing links can connect to this anchor.

brush

The brush with which the anchor mark is painted.

col

The table's column, with which an anchor point is associated.

tag

User-defined data associated with the anchor point.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Constructor (Double, Double, Boolean, Boolean, MarkStyle)

AnchorPoint Constructor (Double, Double, Boolean, Boolean, MarkStyle)
See Also
[image]

Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions and style.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPoint (
double x,
double y,
bool allowIncoming,
bool allowOutgoing,
MarkStyle markStyle
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
allowIncoming As Boolean, _
allowOutgoing As Boolean, _
markStyle As MarkStyle _
)

Parameters

x

The horizontal position of the anchor expressed as percent of the width of a node.

y

The vertical position of the anchor expressed as percent of the height of a node.

allowIncoming

Specifies whether incoming links can connect to this anchor.

allowOutgoing

Specifies whether outgoing links can connect to this anchor.

markStyle

Defines how the anchor point is marked visually.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Constructor (Double, Double, Boolean, Boolean, MarkStyle, Brush)

AnchorPoint Constructor (Double, Double, Boolean, Boolean, MarkStyle, Brush)
See Also
[image]

Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions, style and brush.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPoint (
double x,
double y,
bool allowIncoming,
bool allowOutgoing,
MarkStyle markStyle,
Brush brush
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
allowIncoming As Boolean, _
allowOutgoing As Boolean, _
markStyle As MarkStyle, _
brush As Brush _
)

Parameters

x

The horizontal position of the anchor expressed as percent of the width of a node.

y

The vertical position of the anchor expressed as percent of the height of a node.

allowIncoming

Specifies whether incoming links can connect to this anchor.

allowOutgoing

Specifies whether outgoing links can connect to this anchor.

markStyle

Defines how the anchor point is marked visually.

brush

The brush with which the anchor mark is painted.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Methods

AnchorPoint Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact clone of this AnchorPoint object.

See Also

AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.Clone Method

AnchorPoint.Clone Method
[image]

Creates an exact clone of this AnchorPoint object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

An instance of the AnchorPoint class.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Properties

AnchorPoint Properties
[image]

Public Properties

Name | Description
AllowIncoming | Gets or sets a value indicating whether incoming links can be connected to this anchor.
AllowOutgoing | Gets or sets a value indicating whether the anchor point accepts outgoing connections.
Brush | Gets or sets the brush of the anchor point mark.
Column | Gets or sets the column index of a cell with which the anchor point is associated.
MarkStyle | Gets or sets the appearance of the anchor point mark.
Size | Gets or sets the size of the anchor point.
Tag | Gets or sets a user-defined data associated with the anchor point.
ToolTip | Gets or sets a tooltip text that should be displayed when the mouse hovers over an anchor point mark.
X | Gets or sets the horizontal position of the anchor point expressed as percent of a node's width.
Y | Gets or sets the vertical position of the anchor point expressed as percent of a node's height.

See Also

AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.AllowIncoming Property

AnchorPoint.AllowIncoming Property
[image]

Gets or sets a value indicating whether incoming links can be connected to this anchor.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowIncoming { get; set; }

Visual Basic [image] Copy Code

Public Property AllowIncoming As Boolean

Property Value

Remarks

If no incoming anchors are defined for a node, links end points can be placed anywhere inside that node, unless AllowUnanchoredLinks is disabled.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.AllowOutgoing Property

AnchorPoint.AllowOutgoing Property
[image]

Gets or sets a value indicating whether the anchor point accepts outgoing connections.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowOutgoing { get; set; }

Visual Basic [image] Copy Code

Public Property AllowOutgoing As Boolean

Property Value

Remarks

If no outgoing anchors are defined for a node, links start points can be placed anywhere inside that node, unless AllowUnanchoredLinks is disabled.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.Brush Property

AnchorPoint.Brush Property
[image]

Gets or sets the brush of the anchor point mark.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

An instance of the Windows.UI.Xaml.Media.Brush class.

Remarks

The anchor mark shape specified by MarkStyle is painted with this brush.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.Column Property

AnchorPoint.Column Property
[image]

Gets or sets the column index of a cell with which the anchor point is associated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Column { get; set; }

Visual Basic [image] Copy Code

Public Property Column As Integer

Property Value

Remarks

If Column is set to -1, the point relative coordinates specify percents of row's extents. Otherwise the point coordinates specify percents of cell's extents.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.MarkStyle Property

AnchorPoint.MarkStyle Property
[image]

Gets or sets the appearance of the anchor point mark.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MarkStyle MarkStyle { get; set; }

Visual Basic [image] Copy Code

Public Property MarkStyle As MarkStyle

Property Value

Remarks

A member of the MarkStyle enumeration. The default value is X.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming Namespace
Size Property


MindFusion.Diagramming.AnchorPoint.Size Property

AnchorPoint.Size Property
[image]

Gets or sets the size of the anchor point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Size { get; set; }

Visual Basic [image] Copy Code

Public Property Size As Double

Property Value

The size of the anchor point mark, specified in MeasureUnit units. The default value is 10.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming Namespace
MarkStyle Property


MindFusion.Diagramming.AnchorPoint.Tag Property

AnchorPoint.Tag Property
[image]

Gets or sets a user-defined data associated with the anchor point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.ToolTip Property

AnchorPoint.ToolTip Property
[image]

Gets or sets a tooltip text that should be displayed when the mouse hovers over an anchor point mark.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object ToolTip { get; set; }

Visual Basic [image] Copy Code

Public Property ToolTip As Object

Property Value

Remarks

When the mouse rests for a while over an anchor point, the tool-tip text is displayed in a small popup window near the mouse cursor.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.X Property

AnchorPoint.X Property
[image]

Gets or sets the horizontal position of the anchor point expressed as percent of a node's width.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double X { get; set; }

Visual Basic [image] Copy Code

Public Property X As Double

Property Value

Remarks

Set the property value to a number from 0 to 100, otherwise you might get unexpected behavior.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.Y Property

AnchorPoint.Y Property
[image]

Gets or sets the vertical position of the anchor point expressed as percent of a node's height.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Y { get; set; }

Visual Basic [image] Copy Code

Public Property Y As Double

Property Value

Remarks

Set the property value to a number from 0 to 100, otherwise you might get unexpected behavior.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPointCollection Class

AnchorPointCollection Class
[image]

Represents a strongly-typed collection of anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class AnchorPointCollection : CollectionBase<AnchorPoint, AnchorPoint>

Visual Basic [image] Copy Code

Public Class AnchorPointCollection
Inherits CollectionBase(Of AnchorPoint, AnchorPoint)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.CollectionBase(AnchorPoint, AnchorPoint)
MindFusion.Diagramming.AnchorPointCollection

See Also

AnchorPointCollection Members


MindFusion.Diagramming.AnchorPointCollection Members

AnchorPointCollection Members
Constructors Fields Properties Methods
[image]

Represents a strongly-typed collection of anchor points.

The following tables list the members exposed by the AnchorPointCollection type.

Public Constructors

Name | Description
AnchorPointCollection | Overloaded.

Inherited Protected Fields

Name | Description
itemEventArgs | An ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector. (Inherited from CollectionBase.)
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items. (Inherited from CollectionBase.)

Inherited Public Properties

Name | Description
Count | Gets the number of items contained in the collection. (Inherited from CollectionBase.)
IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from CollectionBase.)
Item | An indexer that lets you access the element at the specified position. (Inherited from CollectionBase.)

Inherited Public Methods

Name | Description
Add | Adds an item to the collection. (Inherited from CollectionBase.)
Clear | Removes all items from the collection. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the List(T). (Inherited from CollectionBase.)
CopyTo | (Inherited from CollectionBase.)
GetEnumerator | Returns an enumerator for this collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts an element into the Collection at the specified index. (Inherited from CollectionBase.)
Remove | Removes the first occurrence of a specific object from the collection. (Inherited from CollectionBase.)
RemoveAt | Removes the element at the specified index of the collection. (Inherited from CollectionBase.)

Inherited Protected Methods

Name | Description
RaiseAdding | Raises the Adding event. (Inherited from CollectionBase.)
RaiseInserting | Raises the Inserting event. (Inherited from CollectionBase.)
RaiseRemoving | Raises the Removing event. (Inherited from CollectionBase.)

See Also

AnchorPointCollection Class


MindFusion.Diagramming.AnchorPointCollection Constructor

AnchorPointCollection Constructor
[image]

Overload List

Name | Description
AnchorPointCollection () | Initializes a new instance of the AnchorPointCollection class.
AnchorPointCollection (AnchorPoint[]) | Initializes a new instance of the AnchorPointCollection class.

See Also

AnchorPointCollection Class


MindFusion.Diagramming.AnchorPointCollection Constructor ()

AnchorPointCollection Constructor ()
See Also
[image]

Initializes a new instance of the AnchorPointCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPointCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AnchorPointCollection Constructor Overload List
AnchorPointCollection Class


MindFusion.Diagramming.AnchorPointCollection Constructor (AnchorPoint[])

AnchorPointCollection Constructor (AnchorPoint[])
See Also
[image]

Initializes a new instance of the AnchorPointCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPointCollection (
AnchorPoint[] array
)

Visual Basic [image] Copy Code

Public New ( _
array() As AnchorPoint _
)

Parameters

array

See Also

AnchorPointCollection Constructor Overload List
AnchorPointCollection Class


MindFusion.Diagramming.AnchorPointDetails Class

AnchorPointDetails Class
Remarks See Also
[image]

Contains information about the location where links connects to a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class AnchorPointDetails

Visual Basic [image] Copy Code

Public Class AnchorPointDetails

Remarks

AnchorPoint objects can be shared and cannot store information about the context in which they are used. This task is handled by AnchorPointDetails.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.AnchorPointDetails

See Also

AnchorPointDetails Members


MindFusion.Diagramming.AnchorPointDetails Members

AnchorPointDetails Members
Methods
[image]

Contains information about the location where links connects to a node.

The following tables list the members exposed by the AnchorPointDetails type.

Public Methods

Name | Description
Clone | Clones this AnchorPointDetails instance.

See Also

AnchorPointDetails Class


MindFusion.Diagramming.AnchorPointDetails Methods

AnchorPointDetails Methods
[image]

Public Methods

Name | Description
Clone | Clones this AnchorPointDetails instance.

See Also

AnchorPointDetails Class


MindFusion.Diagramming.AnchorPointDetails.Clone Method

AnchorPointDetails.Clone Method
[image]

Clones this AnchorPointDetails instance.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPointDetails Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As AnchorPointDetails

Return Value

An AnchorPointDetails object cloned from this instance.

See Also

AnchorPointDetails Members
AnchorPointDetails Class


MindFusion.Diagramming.ArcTemplate Class

ArcTemplate Class
[image]

Represents an arc segment in a Shape definition.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ArcTemplate : ElementTemplate

Visual Basic [image] Copy Code

Public Class ArcTemplate
Inherits ElementTemplate

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ElementTemplate
MindFusion.Diagramming.ArcTemplate

See Also

ArcTemplate Members


MindFusion.Diagramming.ArcTemplate Members

ArcTemplate Members
Constructors Properties Methods
[image]

Represents an arc segment in a Shape definition.

The following tables list the members exposed by the ArcTemplate type.

Public Constructors

Name | Description
ArcTemplate | Overloaded.

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of this element.
StartAngle | Gets the start angle of this arc element.
SweepAngle | Gets the sweep angle of this arc element.

Inherited Public Properties

Name | Description
Color | Gest or sets the outline color of this element. (Inherited from ElementTemplate.)
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

Public Methods

Name | Description
Clone | Creates an exact clone of this ArcTemplate object.

Inherited Public Methods

Name | Description
Clone | Creates an exact copy of this element. (Inherited from ElementTemplate.)
CompareTo | IComparable.CompareTo implementation. (Inherited from ElementTemplate.)

See Also

ArcTemplate Class


MindFusion.Diagramming.ArcTemplate Constructor

ArcTemplate Constructor
[image]

Overload List

Name | Description
ArcTemplate (Double, Double, Double, Double, Double, Double) | Initializes a new istance of the ArcTemplate class with the specified coordinates.
ArcTemplate (Double, Double, Double, Double, Double, Double, Color, Double) | Initializes a new istance of the ArcTemplate class with the specified coordinates and visualization settings.

See Also

ArcTemplate Class


MindFusion.Diagramming.ArcTemplate Constructor (Double, Double, Double, Double, Double, Double)

ArcTemplate Constructor (Double, Double, Double, Double, Double, Double)
See Also
[image]

Initializes a new istance of the ArcTemplate class with the specified coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ArcTemplate (
double x,
double y,
double w,
double h,
double a,
double s
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
w As Double, _
h As Double, _
a As Double, _
s As Double _
)

Parameters

x

The x-coordinate of the upper left corner of the ellipse's bounding rectangle.

y

The y-coordinate of the upper left corner of the ellipse's bounding rectangle.

w

The width of the ellipse's bounding rectangle.

h

The height of the ellipse's bounding rectangle.

a

The clockwise angle, in degrees, between the horizontal axis of the ellipse and the starting point of the arc.

s

The clockwise angle, in degrees, between the starting point and the ending point of the arc.

Remarks

An arc template is defined by an ellipse and starting and sweeping angles.

See Also

ArcTemplate Constructor Overload List
ArcTemplate Class


MindFusion.Diagramming.ArcTemplate Constructor (Double, Double, Double, Double, Double, Double, Color, Double)

ArcTemplate Constructor (Double, Double, Double, Double, Double, Double, Color, Double)
See Also
[image]

Initializes a new istance of the ArcTemplate class with the specified coordinates and visualization settings.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ArcTemplate (
double x,
double y,
double w,
double h,
double a,
double s,
Color color,
double width
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
w As Double, _
h As Double, _
a As Double, _
s As Double, _
color As Color, _
width As Double _
)

Parameters

x

The x-coordinate of the upper left corner of the ellipse's bounding rectangle.

y

The y-coordinate of the upper left corner of the ellipse's bounding rectangle.

w

The width of the ellipse's bounding rectangle.

h

The height of the ellipse's bounding rectangle.

a

The clockwise angle, in degrees, between the horizontal axis of the ellipse and the starting point of the arc.

s

The clockwise angle, in degrees, between the starting point and the ending point of the arc.

color

The color of this segment.

width

The width of this segment.

Remarks

An arc template is defined by an ellipse and starting and sweeping angles.

See Also

ArcTemplate Constructor Overload List
ArcTemplate Class


MindFusion.Diagramming.ArcTemplate Methods

ArcTemplate Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact clone of this ArcTemplate object.

Inherited Public Methods

Name | Description
Clone | Creates an exact copy of this element. (Inherited from ElementTemplate.)
CompareTo | IComparable.CompareTo implementation. (Inherited from ElementTemplate.)

See Also

ArcTemplate Class


MindFusion.Diagramming.ArcTemplate.Clone Method

ArcTemplate.Clone Method
[image]

Creates an exact clone of this ArcTemplate object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

An instance of the ArcTemplate class.

See Also

ArcTemplate Members
ArcTemplate Class


MindFusion.Diagramming.ArcTemplate Properties

ArcTemplate Properties
[image]

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of this element.
StartAngle | Gets the start angle of this arc element.
SweepAngle | Gets the sweep angle of this arc element.

Inherited Public Properties

Name | Description
Color | Gest or sets the outline color of this element. (Inherited from ElementTemplate.)
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

See Also

ArcTemplate Class


MindFusion.Diagramming.ArcTemplate.Bounds Property

ArcTemplate.Bounds Property
[image]

Gets the bounding rectangle of this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As Rect

Property Value

See Also

ArcTemplate Members
ArcTemplate Class


MindFusion.Diagramming.ArcTemplate.StartAngle Property

ArcTemplate.StartAngle Property
[image]

Gets the start angle of this arc element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double StartAngle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StartAngle As Double

Property Value

See Also

ArcTemplate Members
ArcTemplate Class


MindFusion.Diagramming.ArcTemplate.SweepAngle Property

ArcTemplate.SweepAngle Property
[image]

Gets the sweep angle of this arc element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double SweepAngle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SweepAngle As Double

Property Value

See Also

ArcTemplate Members
ArcTemplate Class


MindFusion.Diagramming.ArrowHeads Class

ArrowHeads Class
Remarks See Also
[image]

Contains predefined arrowhead shapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class ArrowHeads

Visual Basic [image] Copy Code

Public NotInheritable Class ArrowHeads

Remarks

Shape objects exposed as properties of this class can be assigned to the HeadShape, BaseShape and IntermediateShape properties of links.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ArrowHeads

See Also

ArrowHeads Members


MindFusion.Diagramming.ArrowHeads Members

ArrowHeads Members
Properties
[image]

Contains predefined arrowhead shapes.

The following tables list the members exposed by the ArrowHeads type.

Public Properties

Name | Description
Arrow | Display an arrow-like shape.
BackSlash | Display a back slash.
BowArrow | Display a bow arrow.
CenteredCircle | Display a circle.
Circle | Display a circle.
DefaultFlow | "Default flow" in BPMN diagrams.
DoubleArrow | Display a double arrow.
None | Do not display an arrowhead shape.
Pentagon | Display a pentagon.
PointerArrow | Display a pointer arrow.
Quill | Display a quill.
Reversed | Reversed arrowhead.
RevTriangle | Display a reversed triangle.
RevWithCirc | Reversed arrowhead with a circle.
RevWithLine | Reversed arrowhead with intersecting line.
Rhombus | Display a rhombus.
Slash | Display a slash.
Tetragon | Display a tetragon.
Triangle | Display a triangle.

See Also

ArrowHeads Class


MindFusion.Diagramming.ArrowHeads Properties

ArrowHeads Properties
[image]

Public Properties

Name | Description
Arrow | Display an arrow-like shape.
BackSlash | Display a back slash.
BowArrow | Display a bow arrow.
CenteredCircle | Display a circle.
Circle | Display a circle.
DefaultFlow | "Default flow" in BPMN diagrams.
DoubleArrow | Display a double arrow.
None | Do not display an arrowhead shape.
Pentagon | Display a pentagon.
PointerArrow | Display a pointer arrow.
Quill | Display a quill.
Reversed | Reversed arrowhead.
RevTriangle | Display a reversed triangle.
RevWithCirc | Reversed arrowhead with a circle.
RevWithLine | Reversed arrowhead with intersecting line.
Rhombus | Display a rhombus.
Slash | Display a slash.
Tetragon | Display a tetragon.
Triangle | Display a triangle.

See Also

ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.Arrow Property

ArrowHeads.Arrow Property
[image]

Display an arrow-like shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow { get; set; }

Visual Basic [image] Copy Code

Public Shared Property Arrow As Shape

Property Value

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.BackSlash Property

ArrowHeads.BackSlash Property
[image]

Display a back slash.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BackSlash { get; set; }

Visual Basic [image] Copy Code

Public Shared Property BackSlash As Shape

Property Value

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.BowArrow Property

ArrowHeads.BowArrow Property
[image]

Display a bow arrow.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BowArrow { get; set; }

Visual Basic [image] Copy Code

Public Shared Property BowArrow As Shape

Property Value

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.CenteredCircle Property

ArrowHeads.CenteredCircle Property
[image]

Display a circle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape CenteredCircle { get; set; }

Visual Basic [image] Copy Code

Public Shared Property CenteredCircle As Shape

Property Value

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.Circle Property

ArrowHeads.Circle Property
[image]

Display a circle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Circle { get; set; }

Visual Basic [image] Copy Code

Public Shared Property Circle As Shape

Property Value

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.DefaultFlow Property

ArrowHeads.DefaultFlow Property
[image]

"Default flow" in BPMN diagrams.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DefaultFlow { get; set; }

Visual Basic [image] Copy Code

Public Shared Property DefaultFlow As Shape

Property Value

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.DoubleArrow Property

ArrowHeads.DoubleArrow Property
[image]

Display a double arrow.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DoubleArrow { get; set; }

Visual Basic [image] Copy Code

Public Shared Property DoubleArrow As Shape

Property Value

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.None Property

ArrowHeads.None Property
[image]

Do not display an arrowhead shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape None { get; set; }

Visual Basic [image] Copy Code

Public Shared Property None As Shape

Property Value

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.Pentagon Property

ArrowHeads.Pentagon Property
[image]

Display a pentagon.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Pentagon { get; set; }

Visual Basic [image] Copy Code

Public Shared Property Pentagon As Shape

Property Value

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.PointerArrow Property

ArrowHeads.PointerArrow Property
[image]

Display a pointer arrow.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape PointerArrow { get; set; }

Visual Basic [image] Copy Code

Public Shared Property PointerArrow As Shape

Property Value

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.Quill Property

ArrowHeads.Quill Property
[image]

Display a quill.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Quill { get; set; }

Visual Basic [image] Copy Code

Public Shared Property Quill As Shape

Property Value

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.Reversed Property

ArrowHeads.Reversed Property
[image]

Reversed arrowhead.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Reversed { get; set; }

Visual Basic [image] Copy Code

Public Shared Property Reversed As Shape

Property Value

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.RevTriangle Property

ArrowHeads.RevTriangle Property
[image]

Display a reversed triangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape RevTriangle { get; set; }

Visual Basic [image] Copy Code

Public Shared Property RevTriangle As Shape

Property Value

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.RevWithCirc Property

ArrowHeads.RevWithCirc Property
[image]

Reversed arrowhead with a circle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape RevWithCirc { get; set; }

Visual Basic [image] Copy Code

Public Shared Property RevWithCirc As Shape

Property Value

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.RevWithLine Property

ArrowHeads.RevWithLine Property
[image]

Reversed arrowhead with intersecting line.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape RevWithLine { get; set; }

Visual Basic [image] Copy Code

Public Shared Property RevWithLine As Shape

Property Value

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.Rhombus Property

ArrowHeads.Rhombus Property
[image]

Display a rhombus.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Rhombus { get; set; }

Visual Basic [image] Copy Code

Public Shared Property Rhombus As Shape

Property Value

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.Slash Property

ArrowHeads.Slash Property
[image]

Display a slash.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Slash { get; set; }

Visual Basic [image] Copy Code

Public Shared Property Slash As Shape

Property Value

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.Tetragon Property

ArrowHeads.Tetragon Property
[image]

Display a tetragon.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Tetragon { get; set; }

Visual Basic [image] Copy Code

Public Shared Property Tetragon As Shape

Property Value

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.Triangle Property

ArrowHeads.Triangle Property
[image]

Display a triangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Triangle { get; set; }

Visual Basic [image] Copy Code

Public Shared Property Triangle As Shape

Property Value

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.AutoResize Enumeration

AutoResize Enumeration
[image]

Defines in which directions automatic resizing can enlarge the diagram scrollable area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum AutoResize

Visual Basic [image] Copy Code

Public Enum AutoResize

Members

Member name | Description
AllDirections | Enlarge the diagram area in any direction if an item is moved outside the boundaries.
None | Do not enlarge the diagram area automatically.
RightAndDown | Enlarge the diagram area to the right and down if an item is moved outside the boundaries in these directions.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.Behavior Enumeration

Behavior Enumeration
[image]

Defines values that specify how the component responds to actions performed by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum Behavior

Visual Basic [image] Copy Code

Public Enum Behavior

Members

Member name | Description
Custom | Specifies that user input is handled by the BehaviorBase-derived object assigned to CustomBehavior.
DoNothing | The control ignores users actions with the mouse, but raises the appropriate mouse events. This mode allows applications to implement their own mouse-drawing behavior, disabling the default response to users actions.
DrawContainers | Drawing with the mouse creates ContainerNode instances.
DrawControls | Drawing with the mouse creates ControlNode instances.
DrawLinks | Drawing started over a node creates a DiagramLink. Otherwise a lasso rectangle is displayed allowing the selection of items.
DrawShapes | Drawing with the mouse creates ShapeNode instances.
DrawTables | Drawing with the mouse creates TableNode instances.
DrawTreeViews | Drawing with the mouse creates TreeViewNode instances.
LinkContainers | Drawing over empty document area creates a ContainerNode instance. Drawing started over a node creates a DiagramLink.
LinkControls | Drawing over empty document area creates a ControlNode instance. Drawing started over a node creates a DiagramLink.
LinkShapes | A mode that is suitable for creating flowcharts and process diagrams. Drawing over empty document area creates a ShapeNode instance. Drawing started over a node creates a DiagramLink.
LinkTables | A mode that is suitable for creating entity-relationship diagrams. Drawing over empty document area creates a TableNode instance. Drawing started over a node creates a DiagramLink.
LinkTreeViews | Drawing over empty document area creates a TreeViewNode instance. Drawing started over a node creates a DiagramLink.
Magnify | Dragging with the mouse displays the magnifier tool.
Modify | Objects can be selected and modified. New objects cannot be created.
Pan | Dragging the diagram with the mouse causes scrolling if the Diagram is child of a ScrollViewer.
SelectOnly | Allow only selection of existing items. Modifying them or drawing new ones is disabled.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.BehaviorBase Class

BehaviorBase Class
Remarks See Also
[image]

An abstract base class for types that define how the control reacts to users' actions with a mouse or other pointing devices.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class BehaviorBase : Interaction

Visual Basic [image] Copy Code

Public MustInherit Class BehaviorBase
Inherits Interaction

Remarks

DiagramRT comes with several predefined BehaviorBase-derived classes that can be selected through the Behavior property of the Diagram class. Custom behavior objects can be assigned to the CustomBehavior property.

To define a custom behavior class, implement the StartDraw method which specifies how the control responds when a user starts to draw with the mouse. StartDraw should create a new diagram element if necessary, and return an InteractionState object that describes the interaction.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction
MindFusion.Diagramming.BehaviorBase
MindFusion.Diagramming.DoNothingBehavior
MindFusion.Diagramming.DrawLinksBehavior
MindFusion.Diagramming.DrawNodesBehavior
MindFusion.Diagramming.LinkNodesBehavior
MindFusion.Diagramming.ModifyBehavior
MindFusion.Diagramming.PanBehavior
MindFusion.Diagramming.SelectOnlyBehavior

See Also

BehaviorBase Members


MindFusion.Diagramming.BehaviorBase Members

BehaviorBase Members
Constructors Properties Methods
[image]

An abstract base class for types that define how the control reacts to users' actions with a mouse or other pointing devices.

The following tables list the members exposed by the BehaviorBase type.

Public Constructors

Name | Description
BehaviorBase | Initializes a new instance of the BehaviorBase class.

Protected Properties

Name | Description
InteractionState | Gets or sets an InteractionState instance that tracks the modification currently being done on an item.
MouseDownPoint | Gets or sets the position of the mouse when its button has been pressed.

Inherited Protected Properties

Name | Description
Diagram | The Diagram object that is being modified. (Inherited from Interaction.)

Public Methods

Name | Description
SetMouseCursor | Invoked while the mouse is moved to let Behavior objects set the mouse cursor depending on the context.
StartDraw | Invoked when a user presses the left mouse button inside the diagram drawing area.

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior.
OnMouseDown | Interaction.OnMouseDown override.
OnMouseMove | Raises the MouseMove event.
OnMouseUp | Interaction.OnMouseUp override.
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state.
StartInteraction | Invoked by the control when the user presses the left mouse button.

Inherited Protected Methods

Name | Description
OnMouseDown | Called when a mouse button is pressed. (Inherited from Interaction.)
OnMouseMove | Called when the mouse pointer is moved over the control. (Inherited from Interaction.)
OnMouseUp | Called when a mouse button is released. (Inherited from Interaction.)

See Also

BehaviorBase Class


MindFusion.Diagramming.BehaviorBase Constructor

BehaviorBase Constructor
[image]

Initializes a new instance of the BehaviorBase class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public BehaviorBase (
Diagram diagram
)

Visual Basic [image] Copy Code

Public Sub BehaviorBase ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram this behavior will be associated with.

See Also

BehaviorBase Class


MindFusion.Diagramming.BehaviorBase Methods

BehaviorBase Methods
[image]

Public Methods

Name | Description
SetMouseCursor | Invoked while the mouse is moved to let Behavior objects set the mouse cursor depending on the context.
StartDraw | Invoked when a user presses the left mouse button inside the diagram drawing area.

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior.
OnMouseDown | Interaction.OnMouseDown override.
OnMouseMove | Raises the MouseMove event.
OnMouseUp | Interaction.OnMouseUp override.
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state.
StartInteraction | Invoked by the control when the user presses the left mouse button.

Inherited Protected Methods

Name | Description
OnMouseDown | Called when a mouse button is pressed. (Inherited from Interaction.)
OnMouseMove | Called when the mouse pointer is moved over the control. (Inherited from Interaction.)
OnMouseUp | Called when a mouse button is released. (Inherited from Interaction.)

See Also

BehaviorBase Class


MindFusion.Diagramming.BehaviorBase.CreateLink Method

BehaviorBase.CreateLink Method
[image]

Creates a link of the type appropriate for the current behavior.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramLink CreateLink (
DiagramNode origin,
Point point
)

Visual Basic [image] Copy Code

Protected Overridable Function CreateLink ( _
origin As DiagramNode, _
point As Point _
) As DiagramLink

Parameters

origin
The link's origin node.
point
The link's start point.

Return Value

An instance of DiagramLink or a derived class.

Remarks

The default implementation returns a DiagramLink object. Override this method to create an instance of a custom class derived from DiagramLink when the user starts drawing a new link.

See Also

BehaviorBase Members
BehaviorBase Class


MindFusion.Diagramming.BehaviorBase.OnMouseDown Method

BehaviorBase.OnMouseDown Method
[image]

Interaction.OnMouseDown override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override bool OnMouseDown (
e
)

Visual Basic [image] Copy Code

Protected Overrides Function OnMouseDown( _
e As _
) As Boolean

Parameters

e

Return Value

See Also

BehaviorBase Members
BehaviorBase Class


MindFusion.Diagramming.BehaviorBase.OnMouseMove Method

BehaviorBase.OnMouseMove Method
[image]

Raises the MouseMove event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnMouseMove (
e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseMove( _
e As _
)

Parameters

e

See Also

BehaviorBase Members
BehaviorBase Class


MindFusion.Diagramming.BehaviorBase.OnMouseUp Method

BehaviorBase.OnMouseUp Method
[image]

Interaction.OnMouseUp override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnMouseUp (
e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseUp( _
e As _
)

Parameters

e

See Also

BehaviorBase Members
BehaviorBase Class


MindFusion.Diagramming.BehaviorBase.SetModfCursor Method

BehaviorBase.SetModfCursor Method
[image]

Updates the current cursor according to the specified cursor position and diagram state.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Cursor SetModfCursor (
Point pt,
int handle,
bool active,
bool autoh
)

Visual Basic [image] Copy Code

Protected Function SetModfCursor( _
pt As Point, _
handle As Integer, _
active As Boolean, _
autoh As Boolean _
) As Cursor

Parameters

pt

A Point structure that specifies the current mouse position.

handle

The index of the adjustment handle, at which the mouse points.

active
Specifies whether the mouse is over the ActiveItem.
autoh
true when the mouse is over a DiagramItem and the ModificationStart property is set to AutoHandles.

Return Value

A Cursor instance.

Remarks

SetMouseCursor overrides can call this method to get the default cursor shown for move or resize operations.

See Also

BehaviorBase Members
BehaviorBase Class


MindFusion.Diagramming.BehaviorBase.SetMouseCursor Method

BehaviorBase.SetMouseCursor Method
[image]

Invoked while the mouse is moved to let Behavior objects set the mouse cursor depending on the context.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract Cursor SetMouseCursor (
Point point,
out bool startInteraction
)

Visual Basic [image] Copy Code

Public MustOverride Function SetMouseCursor( _
point As Point, _
<System.Runtime.InteropServices.Out()> ByRef startInteraction As Boolean _
) As Cursor

Parameters

point

A Point structure that specifies the position of the mouse cursor.

startInteraction
Reserved for future use.

Return Value

A Windows.UI.Xaml.Input.Cursor instance.

See Also

BehaviorBase Members
BehaviorBase Class


MindFusion.Diagramming.BehaviorBase.StartDraw Method

BehaviorBase.StartDraw Method
[image]

Invoked when a user presses the left mouse button inside the diagram drawing area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract InteractionState StartDraw (
Point point
)

Visual Basic [image] Copy Code

Public MustOverride Function StartDraw ( _
point As Point _
) As InteractionState

Parameters

point

A Point structure, which specifies the current position of the mouse cursor, in document coordinates.

Return Value

An instance of the InteractionState class, which specifies whether dragging the mouse should create or modify an item.

See Also

BehaviorBase Members
BehaviorBase Class


MindFusion.Diagramming.BehaviorBase.StartInteraction Method

BehaviorBase.StartInteraction Method
[image]

Invoked by the control when the user presses the left mouse button.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual InteractionState StartInteraction (
Point point
)

Visual Basic [image] Copy Code

Protected Overridable Function StartInteraction( _
point As Point _
) As InteractionState

Parameters

point

A Point instance specifying the mouse location.

Return Value

An InteractionState instance representing the interactive action that should be started.

Remarks

This method implements common actions shared between all behavior classes. It invokes the public StartDraw method implemented by derived classes to start behavior-specific actions. Override this method to prevent common operations such as drawing lasso selection or moving the active item.

See Also

BehaviorBase Members
BehaviorBase Class


MindFusion.Diagramming.BehaviorBase Properties

BehaviorBase Properties
[image]

Protected Properties

Name | Description
InteractionState | Gets or sets an InteractionState instance that tracks the modification currently being done on an item.
MouseDownPoint | Gets or sets the position of the mouse when its button has been pressed.

Inherited Protected Properties

Name | Description
Diagram | The Diagram object that is being modified. (Inherited from Interaction.)

See Also

BehaviorBase Class


MindFusion.Diagramming.BehaviorBase.InteractionState Property

BehaviorBase.InteractionState Property
[image]

Gets or sets an InteractionState instance that tracks the modification currently being done on an item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected InteractionState InteractionState { get; set; }

Visual Basic [image] Copy Code

Protected Property InteractionState As InteractionState

Property Value

An InteractionState instance.

See Also

BehaviorBase Members
BehaviorBase Class


MindFusion.Diagramming.BehaviorBase.MouseDownPoint Property

BehaviorBase.MouseDownPoint Property
[image]

Gets or sets the position of the mouse when its button has been pressed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Nullable<Point> MouseDownPoint { get; set; }

Visual Basic [image] Copy Code

Protected Property MouseDownPoint As Nullable(Of Point)

Property Value

A Windows.UI.Xaml.Point structure containing the mouse pointer coordinates.

See Also

BehaviorBase Members
BehaviorBase Class


MindFusion.Diagramming.BezierTemplate Class

BezierTemplate Class
[image]

Represents a Bezier curve in a Shape definition.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class BezierTemplate : ElementTemplate

Visual Basic [image] Copy Code

Public Class BezierTemplate
Inherits ElementTemplate

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ElementTemplate
MindFusion.Diagramming.BezierTemplate

See Also

BezierTemplate Members


MindFusion.Diagramming.BezierTemplate Members

BezierTemplate Members
Constructors Properties Methods
[image]

Represents a Bezier curve in a Shape definition.

The following tables list the members exposed by the BezierTemplate type.

Public Constructors

Name | Description
BezierTemplate | Overloaded.

Inherited Public Properties

Name | Description
Color | Gest or sets the outline color of this element. (Inherited from ElementTemplate.)
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

Public Methods

Name | Description
Clone | Creates an exact copy of this BezierTemplate element.

Inherited Public Methods

Name | Description
Clone | Creates an exact copy of this element. (Inherited from ElementTemplate.)
CompareTo | IComparable.CompareTo implementation. (Inherited from ElementTemplate.)

See Also

BezierTemplate Class


MindFusion.Diagramming.BezierTemplate Constructor

BezierTemplate Constructor
[image]

Overload List

Name | Description
BezierTemplate (Double, Double, Double, Double, Double, Double, Double, Double) | Initializes a new instance of the BezierTemplate class with the specified coordinates.
BezierTemplate (Double, Double, Double, Double, Double, Double, Double, Double, Color, Double) | Initializes a new instance of the BezierTemplate class with the specified coordinates and visualization settings.

See Also

BezierTemplate Class


MindFusion.Diagramming.BezierTemplate Constructor (Double, Double, Double, Double, Double, Double, Double, Double)

BezierTemplate Constructor (Double, Double, Double, Double, Double, Double, Double, Double)
See Also
[image]

Initializes a new instance of the BezierTemplate class with the specified coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public BezierTemplate (
double x1,
double y1,
double x2,
double y2,
double x3,
double y3,
double x4,
double y4
)

Visual Basic [image] Copy Code

Public New ( _
x1 As Double, _
y1 As Double, _
x2 As Double, _
y2 As Double, _
x3 As Double, _
y3 As Double, _
x4 As Double, _
y4 As Double _
)

Parameters

x1

The x-coordinate of the first control point of the curve.

y1

The y-coordinate of the first control point of the curve.

x2

The x-coordinate of the second control point of the curve.

y2

The y-coordinate of the second control point of the curve.

x3

The x-coordinate of the third control point of the curve.

y3

The y-coordinate of the third control point of the curve.

x4

The x-coordinate of the fourth control point of the curve.

y4

The y-coordinate of the fourth control point of the curve.

Remarks

A Bézier spline is defined by four control points. The spline goes through the first and last points, and the other two define the tension of the spline.

See Also

BezierTemplate Constructor Overload List
BezierTemplate Class


MindFusion.Diagramming.BezierTemplate Constructor (Double, Double, Double, Double, Double, Double, Double, Double, Color, Double)

BezierTemplate Constructor (Double, Double, Double, Double, Double, Double, Double, Double, Color, Double)
See Also
[image]

Initializes a new instance of the BezierTemplate class with the specified coordinates and visualization settings.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public BezierTemplate (
double x1,
double y1,
double x2,
double y2,
double x3,
double y3,
double x4,
double y4,
Color color,
double width
)

Visual Basic [image] Copy Code

Public New ( _
x1 As Double, _
y1 As Double, _
x2 As Double, _
y2 As Double, _
x3 As Double, _
y3 As Double, _
x4 As Double, _
y4 As Double, _
color As Color, _
width As Double _
)

Parameters

x1

The x-coordinate of the first control point of the curve.

y1

The y-coordinate of the first control point of the curve.

x2

The x-coordinate of the second control point of the curve.

y2

The y-coordinate of the second control point of the curve.

x3

The x-coordinate of the third control point of the curve.

y3

The y-coordinate of the third control point of the curve.

x4

The x-coordinate of the fourth control point of the curve.

y4

The y-coordinate of the fourth control point of the curve.

color

The color of this segment.

width

The width of this segment.

Remarks

A Bézier spline is defined by four control points. The spline goes through the first and last points, and the other two define the tension of the spline.

See Also

BezierTemplate Constructor Overload List
BezierTemplate Class


MindFusion.Diagramming.BezierTemplate Methods

BezierTemplate Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this BezierTemplate element.

Inherited Public Methods

Name | Description
Clone | Creates an exact copy of this element. (Inherited from ElementTemplate.)
CompareTo | IComparable.CompareTo implementation. (Inherited from ElementTemplate.)

See Also

BezierTemplate Class


MindFusion.Diagramming.BezierTemplate.Clone Method

BezierTemplate.Clone Method
[image]

Creates an exact copy of this BezierTemplate element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

An instance of the BezierTemplate class.

See Also

BezierTemplate Members
BezierTemplate Class


MindFusion.Diagramming.BoolValueConverter Class

BoolValueConverter Class
[image]

Converts boolean to Visibility.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public class BoolValueConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class BoolValueConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.BoolValueConverter

See Also

BoolValueConverter Members


MindFusion.Diagramming.BoolValueConverter Members

BoolValueConverter Members
Constructors Methods
[image]

Converts boolean to Visibility.

The following tables list the members exposed by the BoolValueConverter type.

Public Constructors

Name | Description
BoolValueConverter |

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

BoolValueConverter Class


MindFusion.Diagramming.BoolValueConverter Constructor

BoolValueConverter Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public BoolValueConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

BoolValueConverter Class


MindFusion.Diagramming.BoolValueConverter Methods

BoolValueConverter Methods
[image]

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

BoolValueConverter Class


MindFusion.Diagramming.BoolValueConverter.Convert Method

BoolValueConverter.Convert Method
[image]

IValueConverter.Convert implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo l
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
l As CultureInfo _
) As Object

Parameters

value

targetType

parameter

l

Return Value

See Also

BoolValueConverter Members
BoolValueConverter Class


MindFusion.Diagramming.BoolValueConverter.ConvertBack Method

BoolValueConverter.ConvertBack Method
[image]

IValueConverter.ConvertBack implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo l
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
l As CultureInfo _
) As Object

Parameters

value

targetType

parameter

l

Return Value

See Also

BoolValueConverter Members
BoolValueConverter Class


MindFusion.Diagramming.Brushes Class

Brushes Class
[image]

Brushes contains some predefined Brush objects used by the control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class Brushes

Visual Basic [image] Copy Code

Public NotInheritable Class Brushes

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Brushes

See Also

Brushes Members


MindFusion.Diagramming.Brushes Members

Brushes Members
Fields
[image]

Brushes contains some predefined Brush objects used by the control.

The following tables list the members exposed by the Brushes type.

Public Fields

Name | Description
Black | A solid black brush.
Blue | A solid blue brush.
Cyan | A solid cyan brush.
Gray | A solid gray brush.
Green | A solid green brush.
LightGray | A solid light gray brush.
Red | A solid red brush.
Transparent | A transparent brush.
White | A solid white brush.
Yellow | A solid yellow brush.

See Also

Brushes Class


MindFusion.Diagramming.Brushes Fields

Brushes Fields
[image]

Public Fields

Name | Description
Black | A solid black brush.
Blue | A solid blue brush.
Cyan | A solid cyan brush.
Gray | A solid gray brush.
Green | A solid green brush.
LightGray | A solid light gray brush.
Red | A solid red brush.
Transparent | A transparent brush.
White | A solid white brush.
Yellow | A solid yellow brush.

See Also

Brushes Class


MindFusion.Diagramming.Brushes.Black Field

Brushes.Black Field
[image]

A solid black brush.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly Brush Black

Visual Basic [image] Copy Code

Public Shared ReadOnly Black As Brush

See Also

Brushes Members
Brushes Class


MindFusion.Diagramming.Brushes.Blue Field

Brushes.Blue Field
[image]

A solid blue brush.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly Brush Blue

Visual Basic [image] Copy Code

Public Shared ReadOnly Blue As Brush

See Also

Brushes Members
Brushes Class


MindFusion.Diagramming.Brushes.Cyan Field

Brushes.Cyan Field
[image]

A solid cyan brush.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly Brush Cyan

Visual Basic [image] Copy Code

Public Shared ReadOnly Cyan As Brush

See Also

Brushes Members
Brushes Class


MindFusion.Diagramming.Brushes.Gray Field

Brushes.Gray Field
[image]

A solid gray brush.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly Brush Gray

Visual Basic [image] Copy Code

Public Shared ReadOnly Gray As Brush

See Also

Brushes Members
Brushes Class


MindFusion.Diagramming.Brushes.Green Field

Brushes.Green Field
[image]

A solid green brush.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly Brush Green

Visual Basic [image] Copy Code

Public Shared ReadOnly Green As Brush

See Also

Brushes Members
Brushes Class


MindFusion.Diagramming.Brushes.LightGray Field

Brushes.LightGray Field
[image]

A solid light gray brush.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly Brush LightGray

Visual Basic [image] Copy Code

Public Shared ReadOnly LightGray As Brush

See Also

Brushes Members
Brushes Class


MindFusion.Diagramming.Brushes.Red Field

Brushes.Red Field
[image]

A solid red brush.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly Brush Red

Visual Basic [image] Copy Code

Public Shared ReadOnly Red As Brush

See Also

Brushes Members
Brushes Class


MindFusion.Diagramming.Brushes.Transparent Field

Brushes.Transparent Field
[image]

A transparent brush.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly Brush Transparent

Visual Basic [image] Copy Code

Public Shared ReadOnly Transparent As Brush

See Also

Brushes Members
Brushes Class


MindFusion.Diagramming.Brushes.White Field

Brushes.White Field
[image]

A solid white brush.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly Brush White

Visual Basic [image] Copy Code

Public Shared ReadOnly White As Brush

See Also

Brushes Members
Brushes Class


MindFusion.Diagramming.Brushes.Yellow Field

Brushes.Yellow Field
[image]

A solid yellow brush.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly Brush Yellow

Visual Basic [image] Copy Code

Public Shared ReadOnly Yellow As Brush

See Also

Brushes Members
Brushes Class


MindFusion.Diagramming.Cell Class

Cell Class
Remarks See Also
[image]

Represents a cell in a TableNode instance.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Cell : InplaceEditable

Visual Basic [image] Copy Code

Public Class Cell
Implements InplaceEditable

Remarks

Cells are the building blocks of tables. They get their height and width indirectly, from the width of table columns and the height of table rows as set by the ColumnWidth and RowHeight properties. Cells can hold text, which is set by their Text property. Color of the text in the cells is set with the TextBrush property. Appearance of a cell can be customized further by the Brush and Image properties.

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
MindFusion.Diagramming.Cell

See Also

Cell Members


MindFusion.Diagramming.Cell Members

Cell Members
Constructors Fields Properties Methods
[image]

Represents a cell in a TableNode instance.

The following tables list the members exposed by the Cell type.

Public Constructors

Name | Description
Cell | Initializes a new instance of the Cell class.

Public Fields

Name | Description
TextAlignmentProperty | Identifies the TextAlignment dependency property.
TextProperty | Identifies the Text dependency property.

Public Properties

Name | Description
Table | Gets or sets a reference to the TableNode containing this cell.
Text | Gets or sets text displayed inside the cell. This is a dependency property.
TextAlignment | Gets or sets how the text should be aligned inside this cell. This is a dependency property.

Protected Methods

Name | Description
LoadFromXml | Loads the cell content from an XML element.
SaveToXml | Saves the cell content into an XML element.

See Also

Cell Class


MindFusion.Diagramming.Cell Fields

Cell Fields
[image]

Public Fields

Name | Description
TextAlignmentProperty | Identifies the TextAlignment dependency property.
TextProperty | Identifies the Text dependency property.

See Also

Cell Class


MindFusion.Diagramming.Cell.TextAlignmentProperty Field

Cell.TextAlignmentProperty Field
[image]

Identifies the TextAlignment dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextAlignmentProperty As DependencyProperty

See Also

Cell Members
Cell Class


MindFusion.Diagramming.Cell.TextProperty Field

Cell.TextProperty Field
[image]

Identifies the Text dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextProperty As DependencyProperty

See Also

Cell Members
Cell Class


MindFusion.Diagramming.Cell Constructor

Cell Constructor
[image]

Initializes a new instance of the Cell class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Cell (
TableNode table
)

Visual Basic [image] Copy Code

Public Sub Cell ( _
table As TableNode _
)

Parameters

table
The TableNode this cell belongs to.

See Also

Cell Class


MindFusion.Diagramming.Cell Methods

Cell Methods
[image]

Protected Methods

Name | Description
LoadFromXml | Loads the cell content from an XML element.
SaveToXml | Saves the cell content into an XML element.

See Also

Cell Class


MindFusion.Diagramming.Cell.LoadFromXml Method

Cell.LoadFromXml Method
[image]

Loads the cell content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void LoadFromXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub LoadFromXml ( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement containing the cell's data.

context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

Cell Members
Cell Class


MindFusion.Diagramming.Cell.SaveToXml Method

Cell.SaveToXml Method
[image]

Saves the cell content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void SaveToXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub SaveToXml ( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement the cell's data should be stored into.

context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

Cell Members
Cell Class


MindFusion.Diagramming.Cell Properties

Cell Properties
[image]

Public Properties

Name | Description
Table | Gets or sets a reference to the TableNode containing this cell.
Text | Gets or sets text displayed inside the cell. This is a dependency property.
TextAlignment | Gets or sets how the text should be aligned inside this cell. This is a dependency property.

See Also

Cell Class


MindFusion.Diagramming.Cell.Table Property

Cell.Table Property
[image]

Gets or sets a reference to the TableNode containing this cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode Table { get; set; }

Visual Basic [image] Copy Code

Public Property Table As TableNode

Property Value

A TableNode object.

See Also

Cell Members
Cell Class


MindFusion.Diagramming.Cell.Text Property

Cell.Text Property
[image]

Gets or sets text displayed inside the cell. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Text { get; set; }

Visual Basic [image] Copy Code

Public Property Text As String

Property Value

A string of text that should be displayed in the cell. The default is an empty string.

Remarks

The property specifies the text that appears inside a cell.

See Also

Cell Members
Cell Class
MindFusion.Diagramming Namespace
TextAlignment Property


MindFusion.Diagramming.Cell.TextAlignment Property

Cell.TextAlignment Property
[image]

Gets or sets how the text should be aligned inside this cell. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TextAlignment TextAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property TextAlignment As TextAlignment

Property Value

One of the Windows.UI.Xaml.TextAlignment enumeration values. The default is Left.

See Also

Cell Members
Cell Class
MindFusion.Diagramming Namespace
Text Property


MindFusion.Diagramming.CellEventArgs Class

CellEventArgs Class
[image]

Contains the arguments passed to event handlers, such as CellClicked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class CellEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class CellEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.CellEventArgs

See Also

CellEventArgs Members


MindFusion.Diagramming.CellEventArgs Members

CellEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to event handlers, such as CellClicked.

The following tables list the members exposed by the CellEventArgs type.

Public Constructors

Name | Description
CellEventArgs | Initializes a new instance of the CellEventArgs class.

Public Properties

Name | Description
Cell | Gets the cell for which the event is raised.
Column | Gets the index of the table's column that contains Cell.
MousePosition | Gets the current mouse pointer position.
Row | Gets the index of the table's row that contains Cell.
Table | Get the table that contains Cell.

See Also

CellEventArgs Class


MindFusion.Diagramming.CellEventArgs Constructor

CellEventArgs Constructor
[image]

Initializes a new instance of the CellEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CellEventArgs (
Cell cell,
Point mousePosition,
int column,
int row
)

Visual Basic [image] Copy Code

Public Sub CellEventArgs ( _
cell As Cell, _
mousePosition As Point, _
column As Integer, _
row As Integer _
)

Parameters

cell
The Cell related to the event.
mousePosition

The position of the mouse at the time the event was raised.

column

The zero-based index of the column related to the event.

row

The zero-based index of the row related to the event.

See Also

CellEventArgs Class


MindFusion.Diagramming.CellEventArgs Properties

CellEventArgs Properties
[image]

Public Properties

Name | Description
Cell | Gets the cell for which the event is raised.
Column | Gets the index of the table's column that contains Cell.
MousePosition | Gets the current mouse pointer position.
Row | Gets the index of the table's row that contains Cell.
Table | Get the table that contains Cell.

See Also

CellEventArgs Class


MindFusion.Diagramming.CellEventArgs.Cell Property

CellEventArgs.Cell Property
[image]

Gets the cell for which the event is raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Cell Cell { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Cell As Cell

Property Value

See Also

CellEventArgs Members
CellEventArgs Class


MindFusion.Diagramming.CellEventArgs.Column Property

CellEventArgs.Column Property
[image]

Gets the index of the table's column that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Column { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Column As Integer

Property Value

See Also

CellEventArgs Members
CellEventArgs Class


MindFusion.Diagramming.CellEventArgs.MousePosition Property

CellEventArgs.MousePosition Property
[image]

Gets the current mouse pointer position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point MousePosition { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MousePosition As Point

Property Value

See Also

CellEventArgs Members
CellEventArgs Class


MindFusion.Diagramming.CellEventArgs.Row Property

CellEventArgs.Row Property
[image]

Gets the index of the table's row that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Row { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Row As Integer

Property Value

See Also

CellEventArgs Members
CellEventArgs Class


MindFusion.Diagramming.CellEventArgs.Table Property

CellEventArgs.Table Property
[image]

Get the table that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode Table { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Table As TableNode

Property Value

See Also

CellEventArgs Members
CellEventArgs Class


MindFusion.Diagramming.ChangeItemCommand Class

ChangeItemCommand Class
Remarks See Also
[image]

Handles undo / redo of property changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ChangeItemCommand : Command

Visual Basic [image] Copy Code

Public Class ChangeItemCommand
Inherits Command

Remarks

The ChangeItemCommand constructor records the state of an item, and its Undo and Redo methods restore the item to either its old or new state.

Example

See ExecuteCommand for an example showing how item's state is saved for later undo / redo.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Command
MindFusion.Diagramming.ChangeItemCommand

See Also

ChangeItemCommand Members


MindFusion.Diagramming.ChangeItemCommand Members

ChangeItemCommand Members
Constructors Properties Methods
[image]

Handles undo / redo of property changes.

The following tables list the members exposed by the ChangeItemCommand type.

Public Constructors

Name | Description
ChangeItemCommand | Initializes a new instance of the ChangeItemCommand class.

Inherited Public Properties

Name | Description
Diagram | Gets the Diagram modified by this Command object. (Inherited from Command.)

Public Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

Inherited Public Methods

Name | Description
Execute | Carries out an action that changes the diagram in some way. (Inherited from Command.)
Redo | Repeats an action that has been undone. (Inherited from Command.)
Undo | Undoes an action, restoring the diagram to the state it was in before carrying out the action. (Inherited from Command.)

See Also

ChangeItemCommand Class


MindFusion.Diagramming.ChangeItemCommand Constructor

ChangeItemCommand Constructor
[image]

Initializes a new instance of the ChangeItemCommand class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ChangeItemCommand (
Diagram diagram,
DiagramItem item
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram, _
item As DiagramItem _
)

Parameters

diagram

A Diagram whose item is changed.

item

A new DiagramItem that will be modified.

See Also

ChangeItemCommand Class


MindFusion.Diagramming.ChangeItemCommand Methods

ChangeItemCommand Methods
[image]

Public Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

Inherited Public Methods

Name | Description
Execute | Carries out an action that changes the diagram in some way. (Inherited from Command.)
Redo | Repeats an action that has been undone. (Inherited from Command.)
Undo | Undoes an action, restoring the diagram to the state it was in before carrying out the action. (Inherited from Command.)

See Also

ChangeItemCommand Class


MindFusion.Diagramming.ChangeItemCommand.Execute Method

ChangeItemCommand.Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Execute ()

Visual Basic [image] Copy Code

Public Overrides Sub Execute ()

See Also

ChangeItemCommand Members
ChangeItemCommand Class


MindFusion.Diagramming.ChangeItemCommand.Redo Method

ChangeItemCommand.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Redo ()

Visual Basic [image] Copy Code

Public Overrides Sub Redo ()

See Also

ChangeItemCommand Members
ChangeItemCommand Class


MindFusion.Diagramming.ChangeItemCommand.Undo Method

ChangeItemCommand.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Undo ()

Visual Basic [image] Copy Code

Public Overrides Sub Undo ()

See Also

ChangeItemCommand Members
ChangeItemCommand Class


MindFusion.Diagramming.Clip Class

Clip Class
[image]

A helper class which can provide ClipToBounds functionality in WinRT.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public class Clip

Visual Basic [image] Copy Code

Public Class Clip

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Clip

See Also

Clip Members


MindFusion.Diagramming.Clip Members

Clip Members
Constructors Fields Attached Properties Methods
[image]

A helper class which can provide ClipToBounds functionality in WinRT.

The following tables list the members exposed by the Clip type.

Public Constructors

Name | Description
Clip |

Public Fields

Name | Description
ToBoundsProperty | Identifies the ToBounds attached property.

Public Attached Properties

Name | Description
ToBoundsProperty |

Public Methods

Name | Description
GetToBounds | Gets the value of the Clip.ToBounds attached property for a given dependency object.
SetToBounds | Sets the value of the Clip.ToBounds attached property for a given dependency object.

See Also

Clip Class


MindFusion.Diagramming.Clip Fields

Clip Fields
[image]

Public Fields

Name | Description
ToBoundsProperty | Identifies the ToBounds attached property.

See Also

Clip Class


MindFusion.Diagramming.Clip.ToBoundsProperty Field

Clip.ToBoundsProperty Field
[image]

Identifies the ToBounds attached property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ToBoundsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ToBoundsProperty As DependencyProperty

See Also

Clip Members
Clip Class


MindFusion.Diagramming.Clip Constructor

Clip Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public Clip ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Clip Class


MindFusion.Diagramming.Clip Methods

Clip Methods
[image]

Public Methods

Name | Description
GetToBounds | Gets the value of the Clip.ToBounds attached property for a given dependency object.
SetToBounds | Sets the value of the Clip.ToBounds attached property for a given dependency object.

See Also

Clip Class


MindFusion.Diagramming.Clip.GetToBounds Method

Clip.GetToBounds Method
[image]

Gets the value of the Clip.ToBounds attached property for a given dependency object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static bool GetToBounds (
DependencyObject element
)

Visual Basic [image] Copy Code

Public Shared Function GetToBounds( _
element As DependencyObject _
) As Boolean

Parameters

element

The element from which the property value is read.

Return Value

The value of the Clip.ToBounds property for the specified element.

See Also

Clip Members
Clip Class


MindFusion.Diagramming.Clip.SetToBounds Method

Clip.SetToBounds Method
[image]

Sets the value of the Clip.ToBounds attached property for a given dependency object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static void SetToBounds (
DependencyObject element,
bool value
)

Visual Basic [image] Copy Code

Public Shared Sub SetToBounds( _
element As DependencyObject, _
value As Boolean _
)

Parameters

element

The element to which the property value is written.

value

The value of the Clip.ToBounds property for the specified element.

See Also

Clip Members
Clip Class


MindFusion.Diagramming.Clip Attached Properties

Clip Attached Properties
[image]

Public Attached Properties

Name | Description
ToBoundsProperty |

See Also

Clip Class


MindFusion.Diagramming.Clip.ToBounds Attached Property

Clip.ToBounds Attached Property
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

See Clip.GetToBounds, Clip.SetToBounds

Visual Basic [image] Copy Code

See Clip.GetToBounds, Clip.SetToBounds

Property Value

See Also

Clip Members
Clip Class


MindFusion.Diagramming.CollectionBase(T, E) Class

CollectionBase(T, E) Class
[image]

Defines a collection that raises events to notify when elements are added to or removed from it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class CollectionBase<T, E> : IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable where T : E

Visual Basic [image] Copy Code

Public Class CollectionBase(Of T As E, E)
Implements IList(Of T), ICollection(Of T), IEnumerable(Of T), IEnumerable

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.CollectionBase(T, E)
MindFusion.Diagramming.AnchorPointCollection
MindFusion.Diagramming.ItemCollectionBase(T)
MindFusion.Diagramming.TreeItemCollection

See Also

CollectionBase(T, E) Members


MindFusion.Diagramming.CollectionBase(T, E) Members

CollectionBase(T, E) Members
Constructors Fields Properties Methods
[image]

Defines a collection that raises events to notify when elements are added to or removed from it.

The following tables list the members exposed by the CollectionBase(T, E) type.

Public Constructors

Name | Description
CollectionBase | Overloaded.

Protected Fields

Name | Description
itemEventArgs | An ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector.
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items.

Public Properties

Name | Description
Count | Gets the number of items contained in the collection.
IsReadOnly | Gets a value indicating whether the collection is read-only.
Item | An indexer that lets you access the element at the specified position.

Public Methods

Name | Description
Add | Adds an item to the collection.
Clear | Removes all items from the collection.
Contains | Determines whether an element is in the List(T).
CopyTo |
GetEnumerator | Returns an enumerator for this collection.
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection.
Insert | Inserts an element into the Collection at the specified index.
Remove | Removes the first occurrence of a specific object from the collection.
RemoveAt | Removes the element at the specified index of the collection.

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event.
RaiseInserting | Raises the Inserting event.
RaiseRemoving | Raises the Removing event.

See Also

CollectionBase(T, E) Class


MindFusion.Diagramming.CollectionBase(T, E) Fields

CollectionBase(T, E) Fields
[image]

Protected Fields

Name | Description
itemEventArgs | An ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector.
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items.

See Also

CollectionBase(T, E) Class


MindFusion.Diagramming.CollectionBase(T, E).itemEventArgs Field

CollectionBase(T, E).itemEventArgs Field
[image]

An ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected ItemEventArgs<E> itemEventArgs

Visual Basic [image] Copy Code

Protected itemEventArgs As ItemEventArgs(Of E)

See Also

CollectionBase(T, E) Members
CollectionBase(T, E) Class


MindFusion.Diagramming.CollectionBase(T, E).notifyParent Field

CollectionBase(T, E).notifyParent Field
[image]

If enabled, the collection raises events to let their containing objects handle the addition or removal of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected bool notifyParent

Visual Basic [image] Copy Code

Protected notifyParent As Boolean

See Also

CollectionBase(T, E) Members
CollectionBase(T, E) Class


MindFusion.Diagramming.CollectionBase(T, E) Constructor

CollectionBase(T, E) Constructor
[image]

Overload List

Name | Description
CollectionBase(T, E) () | Initializes a new instance of the CollectionBase class.
CollectionBase(T, E) (CollectionBase(T, E)) | Initializes a new instance of the CollectionBase class.

See Also

CollectionBase(T, E) Class


MindFusion.Diagramming.CollectionBase(T, E) Constructor ()

CollectionBase(T, E) Constructor ()
See Also
[image]

Initializes a new instance of the CollectionBase class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CollectionBase<T, E> ()

Visual Basic [image] Copy Code

Public Sub New(Of T, E) ()

See Also

CollectionBase(T, E) Constructor Overload List
CollectionBase(T, E) Class


MindFusion.Diagramming.CollectionBase(T, E) Constructor (CollectionBase(T, E))

CollectionBase(T, E) Constructor (CollectionBase(T, E))
See Also
[image]

Initializes a new instance of the CollectionBase class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CollectionBase<T, E> (
CollectionBase<T, E> prototype
)

Visual Basic [image] Copy Code

Public New (Of T, E) ( _
prototype As CollectionBase(Of T, E) _
)

Parameters

prototype

See Also

CollectionBase(T, E) Constructor Overload List
CollectionBase(T, E) Class


MindFusion.Diagramming.CollectionBase(T, E) Methods

CollectionBase(T, E) Methods
[image]

Public Methods

Name | Description
Add | Adds an item to the collection.
Clear | Removes all items from the collection.
Contains | Determines whether an element is in the List(T).
CopyTo |
GetEnumerator | Returns an enumerator for this collection.
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection.
Insert | Inserts an element into the Collection at the specified index.
Remove | Removes the first occurrence of a specific object from the collection.
RemoveAt | Removes the element at the specified index of the collection.

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event.
RaiseInserting | Raises the Inserting event.
RaiseRemoving | Raises the Removing event.

See Also

CollectionBase(T, E) Class


MindFusion.Diagramming.CollectionBase(T, E).Add Method

CollectionBase(T, E).Add Method
[image]

Adds an item to the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Add (
T item
)

Visual Basic [image] Copy Code

Public Sub Add( _
item As T _
)

Parameters

item

The item to add to the collection.

See Also

CollectionBase(T, E) Members
CollectionBase(T, E) Class


MindFusion.Diagramming.CollectionBase(T, E).Clear Method

CollectionBase(T, E).Clear Method
[image]

Removes all items from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Clear ()

Visual Basic [image] Copy Code

Public Sub Clear ()

See Also

CollectionBase(T, E) Members
CollectionBase(T, E) Class


MindFusion.Diagramming.CollectionBase(T, E).Contains Method

CollectionBase(T, E).Contains Method
[image]

Determines whether an element is in the List(T).

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Contains (
T item
)

Visual Basic [image] Copy Code

Public Function Contains( _
item As T _
) As Boolean

Parameters

item

The object to locate in the List(T).

Return Value

true if item is found in the collection; otherwise, false.

See Also

CollectionBase(T, E) Members
CollectionBase(T, E) Class


MindFusion.Diagramming.CollectionBase(T, E).CopyTo Method

CollectionBase(T, E).CopyTo Method
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void CopyTo (
T[] array,
int arrayIndex
)

Visual Basic [image] Copy Code

Public Sub CopyTo( _
array() As T, _
arrayIndex As Integer _
)

Parameters

array

arrayIndex

See Also

CollectionBase(T, E) Members
CollectionBase(T, E) Class


MindFusion.Diagramming.CollectionBase(T, E).GetEnumerator Method

CollectionBase(T, E).GetEnumerator Method
[image]

Returns an enumerator for this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IEnumerator<T> GetEnumerator ()

Visual Basic [image] Copy Code

Public Function GetEnumerator () As IEnumerator(Of T)

Return Value

A System.Collections.IEnumerator for the collection.

See Also

CollectionBase(T, E) Members
CollectionBase(T, E) Class


MindFusion.Diagramming.CollectionBase(T, E).IndexOf Method

CollectionBase(T, E).IndexOf Method
[image]

Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int IndexOf (
T item
)

Visual Basic [image] Copy Code

Public Function IndexOf( _
item As T _
) As Integer

Parameters

item

The object to locate in the List(T).

Return Value

The zero-based index of the first occurrence of item within the entire collection, if found; otherwise, -1.

See Also

CollectionBase(T, E) Members
CollectionBase(T, E) Class


MindFusion.Diagramming.CollectionBase(T, E).Insert Method

CollectionBase(T, E).Insert Method
[image]

Inserts an element into the Collection at the specified index.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Insert (
int index,
T item
)

Visual Basic [image] Copy Code

Public Sub Insert( _
index As Integer, _
item As T _
)

Parameters

index

The zero-based index at which item should be inserted.

item

The object to insert.

See Also

CollectionBase(T, E) Members
CollectionBase(T, E) Class


MindFusion.Diagramming.CollectionBase(T, E).RaiseAdding Method

CollectionBase(T, E).RaiseAdding Method
[image]

Raises the Adding event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void RaiseAdding (
T item
)

Visual Basic [image] Copy Code

Protected Sub RaiseAdding( _
item As T _
)

Parameters

item

The diagram item that is being added.

See Also

CollectionBase(T, E) Members
CollectionBase(T, E) Class


MindFusion.Diagramming.CollectionBase(T, E).RaiseInserting Method

CollectionBase(T, E).RaiseInserting Method
[image]

Raises the Inserting event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void RaiseInserting (
T item,
int index
)

Visual Basic [image] Copy Code

Protected Sub RaiseInserting( _
item As T, _
index As Integer _
)

Parameters

item

The diagram item that is being inserted.

index

Index of the new item.

See Also

CollectionBase(T, E) Members
CollectionBase(T, E) Class


MindFusion.Diagramming.CollectionBase(T, E).RaiseRemoving Method

CollectionBase(T, E).RaiseRemoving Method
[image]

Raises the Removing event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void RaiseRemoving (
T item
)

Visual Basic [image] Copy Code

Protected Sub RaiseRemoving( _
item As T _
)

Parameters

item

The diagram item that is being removed.

See Also

CollectionBase(T, E) Members
CollectionBase(T, E) Class


MindFusion.Diagramming.CollectionBase(T, E).Remove Method

CollectionBase(T, E).Remove Method
[image]

Removes the first occurrence of a specific object from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Remove (
T item
)

Visual Basic [image] Copy Code

Public Function Remove( _
item As T _
) As Boolean

Parameters

item

The object to remove from the collection.

Return Value

true if item is successfully removed; otherwise, false. This method also returns false if item was not found in the original collection.

See Also

CollectionBase(T, E) Members
CollectionBase(T, E) Class


MindFusion.Diagramming.CollectionBase(T, E).RemoveAt Method

CollectionBase(T, E).RemoveAt Method
[image]

Removes the element at the specified index of the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RemoveAt (
int index
)

Visual Basic [image] Copy Code

Public Sub RemoveAt( _
index As Integer _
)

Parameters

index

The zero-based index of the element to remove.

See Also

CollectionBase(T, E) Members
CollectionBase(T, E) Class


MindFusion.Diagramming.CollectionBase(T, E) Properties

CollectionBase(T, E) Properties
[image]

Public Properties

Name | Description
Count | Gets the number of items contained in the collection.
IsReadOnly | Gets a value indicating whether the collection is read-only.
Item | An indexer that lets you access the element at the specified position.

See Also

CollectionBase(T, E) Class


MindFusion.Diagramming.CollectionBase(T, E).Count Property

CollectionBase(T, E).Count Property
[image]

Gets the number of items contained in the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Count { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Count As Integer

Property Value

See Also

CollectionBase(T, E) Members
CollectionBase(T, E) Class


MindFusion.Diagramming.CollectionBase(T, E).IsReadOnly Property

CollectionBase(T, E).IsReadOnly Property
[image]

Gets a value indicating whether the collection is read-only.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsReadOnly { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsReadOnly As Boolean

Property Value

Remarks

A collection that is read-only does not allow the addition, removal, or modification of elements after the collection is created.

See Also

CollectionBase(T, E) Members
CollectionBase(T, E) Class


MindFusion.Diagramming.CollectionBase(T, E).Item Property

CollectionBase(T, E).Item Property
[image]

An indexer that lets you access the element at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public T Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Property Item( _
index As Integer _
) As T

Parameters

index

Property Value

See Also

CollectionBase(T, E) Members
CollectionBase(T, E) Class


MindFusion.Diagramming.Column Class

Column Class
Remarks See Also
[image]

Represents a column of a TableNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Column

Visual Basic [image] Copy Code

Public Class Column

Remarks

The width of a column can be set by its Width property. The width of a column determines the width of all cells contained within the column. When resizing a table, its columns can be resized too. That depends on the value of ColumnStyle, which specifies whether columns are with fixed width or they resize to keep column-to-table width ratio.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Column

See Also

Column Members


MindFusion.Diagramming.Column Members

Column Members
Constructors Properties Methods
[image]

Represents a column of a TableNode.

The following tables list the members exposed by the Column type.

Public Constructors

Name | Description
Column | Initializes a new instance of the Column class.

Public Properties

Name | Description
Width | Gets or sets the width of the table column.

Protected Methods

Name | Description
LoadFromXml | Loads the column properties from an XML element.
SaveToXml | Saves the column properties into an XML element.

See Also

Column Class


MindFusion.Diagramming.Column Constructor

Column Constructor
[image]

Initializes a new instance of the Column class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Column (
TableNode tableNode
)

Visual Basic [image] Copy Code

Public Sub Column ( _
tableNode As TableNode _
)

Parameters

tableNode
The TableNode this column belongs to.

See Also

Column Class


MindFusion.Diagramming.Column Methods

Column Methods
[image]

Protected Methods

Name | Description
LoadFromXml | Loads the column properties from an XML element.
SaveToXml | Saves the column properties into an XML element.

See Also

Column Class


MindFusion.Diagramming.Column.LoadFromXml Method

Column.LoadFromXml Method
[image]

Loads the column properties from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void LoadFromXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub LoadFromXml ( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.
context

An XmlElement containing the column's data.

See Also

Column Members
Column Class


MindFusion.Diagramming.Column.SaveToXml Method

Column.SaveToXml Method
[image]

Saves the column properties into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void SaveToXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub SaveToXml ( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement the column's data should be stored into.

context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

Column Members
Column Class


MindFusion.Diagramming.Column Properties

Column Properties
[image]

Public Properties

Name | Description
Width | Gets or sets the width of the table column.

See Also

Column Class


MindFusion.Diagramming.Column.Width Property

Column.Width Property
[image]

Gets or sets the width of the table column.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Double

Property Value

See Also

Column Members
Column Class


MindFusion.Diagramming.Command Class

Command Class
[image]

Represents an action that changes the diagram and whose effects can be undone.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class Command

Visual Basic [image] Copy Code

Public MustInherit Class Command

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Command
MindFusion.Diagramming.AddItemCommand
MindFusion.Diagramming.ChangeItemCommand
MindFusion.Diagramming.CompositeCommand
MindFusion.Diagramming.RemoveItemCommand

See Also

Command Members


MindFusion.Diagramming.Command Members

Command Members
Constructors Properties Methods
[image]

Represents an action that changes the diagram and whose effects can be undone.

The following tables list the members exposed by the Command type.

Public Constructors

Name | Description
Command | Initializes a new instance of the Command class.

Public Properties

Name | Description
Diagram | Gets the Diagram modified by this Command object.

Public Methods

Name | Description
Execute | Carries out an action that changes the diagram in some way.
Redo | Repeats an action that has been undone.
Undo | Undoes an action, restoring the diagram to the state it was in before carrying out the action.

See Also

Command Class


MindFusion.Diagramming.Command Constructor

Command Constructor
[image]

Initializes a new instance of the Command class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Command (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram

See Also

Command Class


MindFusion.Diagramming.Command Methods

Command Methods
[image]

Public Methods

Name | Description
Execute | Carries out an action that changes the diagram in some way.
Redo | Repeats an action that has been undone.
Undo | Undoes an action, restoring the diagram to the state it was in before carrying out the action.

See Also

Command Class


MindFusion.Diagramming.Command.Execute Method

Command.Execute Method
[image]

Carries out an action that changes the diagram in some way.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract void Execute ()

Visual Basic [image] Copy Code

Public MustOverride Sub Execute ()

See Also

Command Members
Command Class


MindFusion.Diagramming.Command.Redo Method

Command.Redo Method
[image]

Repeats an action that has been undone.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract void Redo ()

Visual Basic [image] Copy Code

Public MustOverride Sub Redo ()

See Also

Command Members
Command Class


MindFusion.Diagramming.Command.Undo Method

Command.Undo Method
[image]

Undoes an action, restoring the diagram to the state it was in before carrying out the action.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract void Undo ()

Visual Basic [image] Copy Code

Public MustOverride Sub Undo ()

See Also

Command Members
Command Class


MindFusion.Diagramming.Command Properties

Command Properties
[image]

Public Properties

Name | Description
Diagram | Gets the Diagram modified by this Command object.

See Also

Command Class


MindFusion.Diagramming.Command.Diagram Property

Command.Diagram Property
[image]

Gets the Diagram modified by this Command object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Diagram Diagram { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Diagram As Diagram

Property Value

See Also

Command Members
Command Class


MindFusion.Diagramming.CompositeCommand Class

CompositeCommand Class
[image]

Represents a set of Command instances as a single operation. Undoing or redoing the composite action, respectively undoes or redoes all its constituent subactions at the same time.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class CompositeCommand : Command

Visual Basic [image] Copy Code

Public Class CompositeCommand
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Command
MindFusion.Diagramming.CompositeCommand

See Also

CompositeCommand Members


MindFusion.Diagramming.CompositeCommand Members

CompositeCommand Members
Constructors Properties Methods
[image]

Represents a set of Command instances as a single operation. Undoing or redoing the composite action, respectively undoes or redoes all its constituent subactions at the same time.

The following tables list the members exposed by the CompositeCommand type.

Public Constructors

Name | Description
CompositeCommand | Initializes a new instance of the CompositeCommand class.

Public Properties

Name | Description
Commands | Gets a list containing the child Command objects.

Inherited Public Properties

Name | Description
Diagram | Gets the Diagram modified by this Command object. (Inherited from Command.)

Public Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

Inherited Public Methods

Name | Description
Execute | Carries out an action that changes the diagram in some way. (Inherited from Command.)
Redo | Repeats an action that has been undone. (Inherited from Command.)
Undo | Undoes an action, restoring the diagram to the state it was in before carrying out the action. (Inherited from Command.)

See Also

CompositeCommand Class


MindFusion.Diagramming.CompositeCommand Constructor

CompositeCommand Constructor
[image]

Initializes a new instance of the CompositeCommand class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CompositeCommand (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram

The Diagram modified by this command.

See Also

CompositeCommand Class


MindFusion.Diagramming.CompositeCommand Methods

CompositeCommand Methods
[image]

Public Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

Inherited Public Methods

Name | Description
Execute | Carries out an action that changes the diagram in some way. (Inherited from Command.)
Redo | Repeats an action that has been undone. (Inherited from Command.)
Undo | Undoes an action, restoring the diagram to the state it was in before carrying out the action. (Inherited from Command.)

See Also

CompositeCommand Class


MindFusion.Diagramming.CompositeCommand.Execute Method

CompositeCommand.Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Execute ()

Visual Basic [image] Copy Code

Public Overrides Sub Execute ()

See Also

CompositeCommand Members
CompositeCommand Class


MindFusion.Diagramming.CompositeCommand.Redo Method

CompositeCommand.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Redo ()

Visual Basic [image] Copy Code

Public Overrides Sub Redo ()

See Also

CompositeCommand Members
CompositeCommand Class


MindFusion.Diagramming.CompositeCommand.Undo Method

CompositeCommand.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Undo ()

Visual Basic [image] Copy Code

Public Overrides Sub Undo ()

See Also

CompositeCommand Members
CompositeCommand Class


MindFusion.Diagramming.CompositeCommand Properties

CompositeCommand Properties
[image]

Public Properties

Name | Description
Commands | Gets a list containing the child Command objects.

Inherited Public Properties

Name | Description
Diagram | Gets the Diagram modified by this Command object. (Inherited from Command.)

See Also

CompositeCommand Class


MindFusion.Diagramming.CompositeCommand.Commands Property

CompositeCommand.Commands Property
[image]

Gets a list containing the child Command objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<Command> Commands { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Commands As List(Of Command)

Property Value

See Also

CompositeCommand Members
CompositeCommand Class


MindFusion.Diagramming.ConnectionPoint Class

ConnectionPoint Class
[image]

This class represents a connection between an edge and a node in a graph. It decouples the DiagramLink class from the DiagramNode class, allowing edges to connect different types of nodes without knowing anything of their implementation details. Each DiagramLink object contains two ConnectionPoint instances describing the connections at both ends of the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ConnectionPoint

Visual Basic [image] Copy Code

Public Class ConnectionPoint

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ConnectionPoint
MindFusion.Diagramming.DummyConnectionPoint
MindFusion.Diagramming.TreeViewConnectionPoint

See Also

ConnectionPoint Members


MindFusion.Diagramming.ConnectionPoint Members

ConnectionPoint Members
Constructors Properties Methods
[image]

This class represents a connection between an edge and a node in a graph. It decouples the DiagramLink class from the DiagramNode class, allowing edges to connect different types of nodes without knowing anything of their implementation details. Each DiagramLink object contains two ConnectionPoint instances describing the connections at both ends of the link.

The following tables list the members exposed by the ConnectionPoint type.

Public Constructors

Name | Description
ConnectionPoint | Initializes a new instance of the ConnectionPoint class between the specified node and link.

Public Properties

Name | Description
AnchorPointIndex | Gets or sets the index of the destination anchor point within the AnchorPattern that contains it.
RelativePosition | Gets or sets the position of this connection point, relative to the associated node's bounding rectangle, expressed in percents.
Row | Gets the index of a constituent item within the associated node where the link represented by this connection point is connected, or -1, if the link is connected to the node itself.

Protected Properties

Name | Description
Incoming | Gets a flag indicating whether this connection point is at the origin or the destination of the associated link.
Link | Gets the link associated with this connection point.
Node | Gets the node associated with this connection point.

Public Methods

Name | Description
AddLinkToNode | Adds the link associated with this connection point to the associated node.
GetAnchorPos | Returns the point from the node's associated anchor pattern (if any) with the specified index or the link's initial point.
GetEndPoint | Calculates the coordinates of this connection point expressed in document coordinates.
GetInitialPoint | Returns a point (usually the center of the bounding rectangle) contained within the associated node.
GetIntersection | Calculates the intersection point between the specified line segment and the contour of the node associated with this connection point.
GetNodeRect | Returns the bounding rectangle of the node associated with this connection point.
LinkChanges | Checks whether the link would change if attached to the specified node at the specified point.
NodesIntersect | Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect.
RemoveLinkFromNode | Removes the link associated with this connection point from the associated node.
SaveEndRelative | Updates the coordinates of the connection point represented by this link, relative to the bounding rectangle of the associated node.
UpdateRow | Sets the row within the table this connection point should be associated with.

Protected Methods

Name | Description
GetNearestAnchorPoint | Returns the nearest anchor point pertinent to this connection.
GetNearestBorderPoint | Returns the nearest point lying on the node border.

See Also

ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint Constructor

ConnectionPoint Constructor
[image]

Initializes a new instance of the ConnectionPoint class between the specified node and link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ConnectionPoint (
DiagramNode node,
DiagramLink link,
bool incoming
)

Visual Basic [image] Copy Code

Public Sub ConnectionPoint ( _
node As DiagramNode, _
link As DiagramLink, _
incoming As Boolean _
)

Parameters

node
The node whose connection to a link is managed by this ConnectionPoint.
link
The link whose connection to a node is managed by this ConnectionPoint.
incoming
Specifies which end of the link is represented by this ConnectionPoint.

See Also

ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint Methods

ConnectionPoint Methods
[image]

Public Methods

Name | Description
AddLinkToNode | Adds the link associated with this connection point to the associated node.
GetAnchorPos | Returns the point from the node's associated anchor pattern (if any) with the specified index or the link's initial point.
GetEndPoint | Calculates the coordinates of this connection point expressed in document coordinates.
GetInitialPoint | Returns a point (usually the center of the bounding rectangle) contained within the associated node.
GetIntersection | Calculates the intersection point between the specified line segment and the contour of the node associated with this connection point.
GetNodeRect | Returns the bounding rectangle of the node associated with this connection point.
LinkChanges | Checks whether the link would change if attached to the specified node at the specified point.
NodesIntersect | Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect.
RemoveLinkFromNode | Removes the link associated with this connection point from the associated node.
SaveEndRelative | Updates the coordinates of the connection point represented by this link, relative to the bounding rectangle of the associated node.
UpdateRow | Sets the row within the table this connection point should be associated with.

Protected Methods

Name | Description
GetNearestAnchorPoint | Returns the nearest anchor point pertinent to this connection.
GetNearestBorderPoint | Returns the nearest point lying on the node border.

See Also

ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.AddLinkToNode Method

ConnectionPoint.AddLinkToNode Method
[image]

Adds the link associated with this connection point to the associated node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void AddLinkToNode ()

Visual Basic [image] Copy Code

Public Overridable Sub AddLinkToNode ()

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.GetAnchorPos Method

ConnectionPoint.GetAnchorPos Method
[image]

Returns the point from the node's associated anchor pattern (if any) with the specified index or the link's initial point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool GetAnchorPos (
int anchorIdx,
ref Point point
)

Visual Basic [image] Copy Code

Public Overridable Function GetAnchorPos( _
anchorIdx As Integer, _
ByRef point As Point _
) As Boolean

Parameters

anchorIdx
The index of the node's associated anchor pattern.
point
The link's initial point.

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.GetEndPoint Method

ConnectionPoint.GetEndPoint Method
[image]

Calculates the coordinates of this connection point expressed in document coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Point GetEndPoint ()

Visual Basic [image] Copy Code

Public Overridable Function GetEndPoint () As Point

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.GetInitialPoint Method

ConnectionPoint.GetInitialPoint Method
[image]

Returns a point (usually the center of the bounding rectangle) contained within the associated node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Point GetInitialPoint ()

Visual Basic [image] Copy Code

Public Overridable Function GetInitialPoint () As Point

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.GetIntersection Method

ConnectionPoint.GetIntersection Method
[image]

Calculates the intersection point between the specified line segment and the contour of the node associated with this connection point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Point GetIntersection (
Point pt1,
Point pt2
)

Visual Basic [image] Copy Code

Public Overridable Function GetIntersection( _
pt1 As Point, _
pt2 As Point _
) As Point

Parameters

pt1

The first point of the segment.

pt2

The second point of the segment.

Return Value

A Point object representing the intersection point.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.GetNearestAnchorPoint Method

ConnectionPoint.GetNearestAnchorPoint Method
[image]

Returns the nearest anchor point pertinent to this connection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual AnchorPointDetails GetNearestAnchorPoint (
Point point
)

Visual Basic [image] Copy Code

Protected Overridable Function GetNearestAnchorPoint( _
point As Point _
) As AnchorPointDetails

Parameters

point
A Point instance specifying location in the diagram.

Return Value

An AnchorPointDetails specifying the anchor point properties.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.GetNearestBorderPoint Method

ConnectionPoint.GetNearestBorderPoint Method
[image]

Returns the nearest point lying on the node border.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual AnchorPointDetails GetNearestBorderPoint (
Point point
)

Visual Basic [image] Copy Code

Protected Overridable Function GetNearestBorderPoint( _
point As Point _
) As AnchorPointDetails

Parameters

point
A Point instance specifying location in the diagram.

Return Value

An AnchorPointDetails specifying the anchor point properties.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.GetNodeRect Method

ConnectionPoint.GetNodeRect Method
[image]

Returns the bounding rectangle of the node associated with this connection point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Rect GetNodeRect (
bool rotated
)

Visual Basic [image] Copy Code

Public Overridable Function GetNodeRect( _
rotated As Boolean _
) As Rect

Parameters

rotated

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.LinkChanges Method

ConnectionPoint.LinkChanges Method
[image]

Checks whether the link would change if attached to the specified node at the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool LinkChanges (
DiagramItem item,
Point point,
bool isDiagramCoordinate
)

Visual Basic [image] Copy Code

Public Overridable Function LinkChanges ( _
item As DiagramItem, _
point As Point, _
isDiagramCoordinate As Boolean _
) As Boolean

Parameters

item
A DiagramItem under the mouse cursor.
point
A point where the link will be connected.
isDiagramCoordinate
true if the point is specified in diagram coordinate; false if specified in local item coordinates.

Return Value

true if the link would connect to a different entity (e.g. node, table cell, tree item) if dropped at the specified location, otherwise false.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.NodesIntersect Method

ConnectionPoint.NodesIntersect Method
[image]

Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool NodesIntersect (
ConnectionPoint connectionPoint
)

Visual Basic [image] Copy Code

Public Function NodesIntersect ( _
connectionPoint As ConnectionPoint _
) As Boolean

Parameters

connectionPoint
A ConnectionPoint instance.

Return Value

true if the node associated with the current connection point and the node associated with the specified connection point intersect; otherwise, false.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.RemoveLinkFromNode Method

ConnectionPoint.RemoveLinkFromNode Method
[image]

Removes the link associated with this connection point from the associated node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void RemoveLinkFromNode ()

Visual Basic [image] Copy Code

Public Overridable Sub RemoveLinkFromNode ()

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.SaveEndRelative Method

ConnectionPoint.SaveEndRelative Method
[image]

Updates the coordinates of the connection point represented by this link, relative to the bounding rectangle of the associated node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void SaveEndRelative ()

Visual Basic [image] Copy Code

Public Overridable Sub SaveEndRelative ()

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.UpdateRow Method

ConnectionPoint.UpdateRow Method
[image]

Sets the row within the table this connection point should be associated with.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void UpdateRow (
int rowIndex
)

Visual Basic [image] Copy Code

Public Overridable Sub UpdateRow( _
rowIndex As Integer _
)

Parameters

rowIndex
Index of the new row associated with this connection.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint Properties

ConnectionPoint Properties
[image]

Public Properties

Name | Description
AnchorPointIndex | Gets or sets the index of the destination anchor point within the AnchorPattern that contains it.
RelativePosition | Gets or sets the position of this connection point, relative to the associated node's bounding rectangle, expressed in percents.
Row | Gets the index of a constituent item within the associated node where the link represented by this connection point is connected, or -1, if the link is connected to the node itself.

Protected Properties

Name | Description
Incoming | Gets a flag indicating whether this connection point is at the origin or the destination of the associated link.
Link | Gets the link associated with this connection point.
Node | Gets the node associated with this connection point.

See Also

ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.AnchorPointIndex Property

ConnectionPoint.AnchorPointIndex Property
[image]

Gets or sets the index of the destination anchor point within the AnchorPattern that contains it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int AnchorPointIndex { get; set; }

Visual Basic [image] Copy Code

Public Property AnchorPointIndex As Integer

Property Value

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.Incoming Property

ConnectionPoint.Incoming Property
[image]

Gets a flag indicating whether this connection point is at the origin or the destination of the associated link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected bool Incoming { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property Incoming As Boolean

Property Value

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.Link Property

ConnectionPoint.Link Property
[image]

Gets the link associated with this connection point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DiagramLink Link { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property Link As DiagramLink

Property Value

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.Node Property

ConnectionPoint.Node Property
[image]

Gets the node associated with this connection point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramNode Node { get; }

Visual Basic [image] Copy Code

Protected Overridable ReadOnly Property Node As DiagramNode

Property Value

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.RelativePosition Property

ConnectionPoint.RelativePosition Property
[image]

Gets or sets the position of this connection point, relative to the associated node's bounding rectangle, expressed in percents.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point RelativePosition { get; set; }

Visual Basic [image] Copy Code

Public Property RelativePosition As Point

Property Value

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.Row Property

ConnectionPoint.Row Property
[image]

Gets the index of a constituent item within the associated node where the link represented by this connection point is connected, or -1, if the link is connected to the node itself.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual int Row { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property Row As Integer

Property Value

An integer value specifying the row index.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.Constants Class

Constants Class
[image]

Contains various global constants, also provides measure unit independent constants.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Constants

Visual Basic [image] Copy Code

Public Class Constants

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Constants

See Also

Constants Members


MindFusion.Diagramming.Constants Members

Constants Members
Constructors Fields Methods
[image]

Contains various global constants, also provides measure unit independent constants.

The following tables list the members exposed by the Constants type.

Public Constructors

Name | Description
Constants |

Public Fields

Name | Description
E | A very small positive real number (0.01).

Public Methods

Name | Description
GetAutoScroll | Gets the number of units to scroll the control during autoscrolling operation.
GetExpandButtonSize | Gets the size of the expand/collapse manipulator icon.
GetInflation | Gets a relax value used when testing object intersections.
GetLineHitTest | Gets a value specifying relative distance from an arrow used during hit-testing operations.
GetMillimeter | Gets the size of one millimeter.
GetMinArrowheadSize | Gets the minimum allowed size of an arrowhead.
GetPixel | Gets the size of one pixel.
GetReflWth2 | Gets the initial distance between adjacent control points of a reflexive link along the X-axis.
GetSelPtTest | Gets a relax value used during selection handles hit-testing.

See Also

Constants Class


MindFusion.Diagramming.Constants Fields

Constants Fields
[image]

Public Fields

Name | Description
E | A very small positive real number (0.01).

See Also

Constants Class


MindFusion.Diagramming.Constants.E Field

Constants.E Field
[image]

A very small positive real number (0.01).

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double E

Visual Basic [image] Copy Code

Public Shared E As Double

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants Constructor

Constants Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Constants ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Constants Class


MindFusion.Diagramming.Constants.GetAutoScroll Method

Constants.GetAutoScroll Method
[image]

Gets the number of units to scroll the control during autoscrolling operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetAutoScroll (
GraphicsUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetAutoScroll( _
currUnit As GraphicsUnit _
) As Double

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetExpandButtonSize Method

Constants.GetExpandButtonSize Method
[image]

Gets the size of the expand/collapse manipulator icon.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetExpandButtonSize (
GraphicsUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetExpandButtonSize( _
currUnit As GraphicsUnit _
) As Double

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetInflation Method

Constants.GetInflation Method
[image]

Gets a relax value used when testing object intersections.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetInflation ()

Visual Basic [image] Copy Code

Public Shared Function GetInflation () As Double

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetLineHitTest Method

Constants.GetLineHitTest Method
[image]

Gets a value specifying relative distance from an arrow used during hit-testing operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetLineHitTest (
GraphicsUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetLineHitTest( _
currUnit As GraphicsUnit _
) As Double

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetMillimeter Method

Constants.GetMillimeter Method
[image]

Gets the size of one millimeter.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetMillimeter (
GraphicsUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetMillimeter( _
currUnit As GraphicsUnit _
) As Double

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetMinArrowheadSize Method

Constants.GetMinArrowheadSize Method
[image]

Gets the minimum allowed size of an arrowhead.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetMinArrowheadSize ()

Visual Basic [image] Copy Code

Public Shared Function GetMinArrowheadSize () As Double

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetPixel Method

Constants.GetPixel Method
[image]

Gets the size of one pixel.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetPixel (
GraphicsUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetPixel( _
currUnit As GraphicsUnit _
) As Double

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetReflWth2 Method

Constants.GetReflWth2 Method
[image]

Gets the initial distance between adjacent control points of a reflexive link along the X-axis.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetReflWth2 ()

Visual Basic [image] Copy Code

Public Shared Function GetReflWth2 () As Double

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetSelPtTest Method

Constants.GetSelPtTest Method
[image]

Gets a relax value used during selection handles hit-testing.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetSelPtTest (
GraphicsUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetSelPtTest( _
currUnit As GraphicsUnit _
) As Double

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.ContainerChildEventArgs Class

ContainerChildEventArgs Class
[image]

Contains arguments passed to ContainerChildEventHandler,

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ContainerChildEventArgs : NodeEventArgs

Visual Basic [image] Copy Code

Public Class ContainerChildEventArgs
Inherits NodeEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.NodeEventArgs
MindFusion.Diagramming.ContainerChildEventArgs

See Also

ContainerChildEventArgs Members


MindFusion.Diagramming.ContainerChildEventArgs Members

ContainerChildEventArgs Members
Constructors Properties Methods
[image]

Contains arguments passed to ContainerChildEventHandler,

The following tables list the members exposed by the ContainerChildEventArgs type.

Public Constructors

Name | Description
ContainerChildEventArgs | Initializes a new instance of the ContainerChildEventArgs class.

Public Properties

Name | Description
Container | The parent ContainerNode of the Node belongs.

Inherited Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from NodeEventArgs.)
MouseButton | Gets which mouse button has been pressed. (Inherited from NodeEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from NodeEventArgs.)
Node | Gets the node for which the event was raised. (Inherited from NodeEventArgs.)

Public Methods

Name | Description
ToString | NodeEventArgs.ToString override.

See Also

ContainerChildEventArgs Class


MindFusion.Diagramming.ContainerChildEventArgs Constructor

ContainerChildEventArgs Constructor
[image]

Initializes a new instance of the ContainerChildEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerChildEventArgs (
ContainerNode container,
DiagramNode node
)

Visual Basic [image] Copy Code

Public New ( _
container As ContainerNode, _
node As DiagramNode _
)

Parameters

container

node

See Also

ContainerChildEventArgs Class


MindFusion.Diagramming.ContainerChildEventArgs Methods

ContainerChildEventArgs Methods
[image]

Public Methods

Name | Description
ToString | NodeEventArgs.ToString override.

See Also

ContainerChildEventArgs Class


MindFusion.Diagramming.ContainerChildEventArgs.ToString Method

ContainerChildEventArgs.ToString Method
[image]

NodeEventArgs.ToString override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

See Also

ContainerChildEventArgs Members
ContainerChildEventArgs Class


MindFusion.Diagramming.ContainerChildEventArgs Properties

ContainerChildEventArgs Properties
[image]

Public Properties

Name | Description
Container | The parent ContainerNode of the Node belongs.

Inherited Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from NodeEventArgs.)
MouseButton | Gets which mouse button has been pressed. (Inherited from NodeEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from NodeEventArgs.)
Node | Gets the node for which the event was raised. (Inherited from NodeEventArgs.)

See Also

ContainerChildEventArgs Class


MindFusion.Diagramming.ContainerChildEventArgs.Container Property

ContainerChildEventArgs.Container Property
[image]

The parent ContainerNode of the Node belongs.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode Container { get; set; }

Visual Basic [image] Copy Code

Public Property Container As ContainerNode

Property Value

See Also

ContainerChildEventArgs Members
ContainerChildEventArgs Class


MindFusion.Diagramming.ContainerNode Class

ContainerNode Class
Remarks See Also
[image]

Represents a diagram node that can contain other nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ContainerNode : ShapeNode

Visual Basic [image] Copy Code

Public Class ContainerNode
Inherits ShapeNode

Remarks

By default, users can drag nodes into or out from a container interactively. To prevent this, disable the AllowAddChildren and AllowRemoveChildren properties.

The Children collection contains references to the child nodes of a container. Its Add and Remove methods can be used to add or remove nodes programmatically. The Container property of a node can be used to access its parent container.

A container node can be folded and unfolded, either interactively or programmatically, as specified through the Foldable and Folded properties.

ContainerNode inherits many other properties and methods from its base class, ShapeNode.

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
Windows.UI.Xaml.Controls.ContentControl
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.ShapeNode
MindFusion.Diagramming.ContainerNode

See Also

ContainerNode Members


MindFusion.Diagramming.ContainerNode Members

ContainerNode Members
Constructors Fields Properties Methods
[image]

Represents a diagram node that can contain other nodes.

The following tables list the members exposed by the ContainerNode type.

Public Constructors

Name | Description
ContainerNode | Overloaded.

Public Fields

Name | Description
CaptionHeightProperty | Identifies the CaptionHeight dependency property.
FoldableProperty | Identifies the Foldable dependency property.

Inherited Public Fields

Name | Description
AutoCaptureMouseProperty | Identifies the AutoCaptureMouse dependency property. (Inherited from DiagramItem.)
BoundsProperty | Identifies the Bounds dependency property. (Inherited from DiagramNode.)
BrushProperty | Identifies the Brush dependency property. (Inherited from DiagramItem.)
DecorationsContainerProperty | Identifies the DecorationsContainer dependency property. (Inherited from ShapeNode.)
EffectsSourceProperty | Identifies the EffectsSource dependency property. (Inherited from DiagramNode.)
HorizontalImageAlignmentProperty | Identifies the HorizontalImageAlignment dependency property. (Inherited from ShapeNode.)
HorizontalTextBlockAlignmentProperty | Identifies the HorizontalTextBlockAlignment dependency property. (Inherited from ShapeNode.)
HyperLinkProperty | Identifies the HyperLink dependency property. (Inherited from DiagramItem.)
ImageProperty | Identifies the Image dependency property. (Inherited from ShapeNode.)
ImageStretchProperty | Identifies the ImageStretch dependency property. (Inherited from ShapeNode.)
IsMouseDownProperty | Identifies the IsMouseDown dependency property. (Inherited from DiagramItem.)
IsMouseOverProperty | Identifies the IsMouseOver dependency property. (Inherited from DiagramItem.)
MasterNodeProperty | Identifies the MasterNode dependency property. (Inherited from DiagramNode.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from DiagramNode.)
ShapeGeometryProperty | Identifies the ShapeGeometry dependency property. (Inherited from ShapeNode.)
ShapeOpacityProperty | Identifies the ShapeOpacity dependency property. (Inherited from DiagramNode.)
ShapeProperty | Identifies the Shape dependency property. (Inherited from ShapeNode.)
ShapeVisibilityProperty | Identifies the ShapeVisibility dependency property. (Inherited from ShapeNode.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from DiagramItem.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from ShapeNode.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)
TextHeightProperty | Identifies the TextHeight dependency property. (Inherited from ShapeNode.)
TextMarginProperty | Identifies the TextMargin dependency property. (Inherited from ShapeNode.)
TextProperty | Identifies the Text dependency property. (Inherited from ShapeNode.)
TextWidthProperty | Identifies the TextWidth dependency property. (Inherited from ShapeNode.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from ShapeNode.)
TransparentProperty | Identifies the Transparent dependency property. (Inherited from ShapeNode.)
VerticalImageAlignmentProperty | Identifies the VerticalImageAlignment dependency property. (Inherited from ShapeNode.)
VerticalTextBlockAlignmentProperty | Identifies the VerticalTextBlockAlignment dependency property. (Inherited from ShapeNode.)

Inherited Protected Fields

Name | Description
handles | A list of the Rectangle objects that represent the item's adjustment handles. (Inherited from DiagramItem.)

Public Properties

Name | Description
AllowAddChildren | Gets or sets a value indicating whether users are allowed to add nodes to this container.
AllowRemoveChildren | Gets or sets a value indicating whether users are allowed to remove nodes from this container.
CaptionHeight | Gets or sets the height of the container's caption bar. This is a dependency property.
Children | Gets the collection of child nodes of this container.
Foldable | Gets or sets a value indicating whether the user is allowed to fold this container.
Folded | Gets or sets a value indicating whether this container is folded.
UnfoldedSize | Returns the original size of a folded container.
Visible | Gets or sets a value indicating whether the container is visible.

Inherited Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
AttachedNodes | Returns the nodes attached to this node. (Inherited from DiagramNode.)
AutoCaptureMouse | Gets or sets whether the item should capture the mouse input when the left button is pressed over it. This is a dependency property. (Inherited from DiagramItem.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. This is a dependency property. (Inherited from DiagramNode.)
Brush | Gets or sets the Brush that specifies how to paint the interior of the item. This is a dependency property. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Container | Gets the ContainerNode that contains this node. (Inherited from DiagramNode.)
DecorationsContainer | Gets a Grid that contains the ShapeNode decoration elements. (Inherited from ShapeNode.)
Diagram | Gets the parent diagram. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramItem.)
HorizontalImageAlignment | Gets or sets the horizontal alignment of the ShapeNode's image. (Inherited from ShapeNode.)
HorizontalTextBlockAlignment | Gets or sets the horizontal alignment of the TextBlock used to display the ShapeNode text relative to its container Grid. (Inherited from ShapeNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. This is a dependency property. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
Image | Gets or sets the image that is displayed in this shape node. This is a dependency property. (Inherited from ShapeNode.)
ImageAlign | Gets or sets the alignment of the image displayed in this shape node. (Inherited from ShapeNode.)
ImageResourceLocation | Gets or sets the resource path to an image that should be displayed in this ShapeNode. (Inherited from ShapeNode.)
ImageStretch | Gets or sets a value that describes how the ShapeNode's image should be stretched to fill the destination rectangle. (Inherited from ShapeNode.)
ImageWebLocation | Gets or sets the URL of the image displayed in this ShapeNode. (Inherited from ShapeNode.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
IsMouseDown | Gets a value indicating whether the mouse button is pressed over this item. This is a dependency property. (Inherited from DiagramItem.)
IsMouseOver | Gets a value indicating whether the mouse pointer is located over this item. This is a dependency property. (Inherited from DiagramItem.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterNode | Gets the node to which this node is attached. This is a dependency property. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
RotationAngle | Gets or sets the angle at which this node is rotated. This is a dependency property. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Shape | Gets or sets a reference to the node's geometric shape definition. (Inherited from ShapeNode.)
ShapeGeometry | Gets a Geometry object that represents the ShapeNode outline and is automatically generated from the current Shape and Bounds values. (Inherited from ShapeNode.)
ShapeOpacity | Gets or sets the shape opacity of this node. This is a dependency property. (Inherited from DiagramNode.)
ShapeVisibility | For internal use. (Inherited from ShapeNode.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline nodes. This is a dependency property. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashOffset | Gets or sets a double value that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. This is a dependency property. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
Text | Gets or sets the text displayed inside the shape node. This is a dependency property. (Inherited from ShapeNode.)
TextAlignment | Gets or sets how the text should be aligned in the ShapeNode's text box. (Inherited from ShapeNode.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
TextFormat | Gets or sets the alignment of the text that is displayed inside shape nodes. (Inherited from ShapeNode.)
TextHeight | Gets or sets the height of the ShapeNode text area. (Inherited from ShapeNode.)
TextMargin | Gets or sets the offset of the ShapeNode text area from the origin of its container Grid. (Inherited from ShapeNode.)
TextWidth | Gets or sets the width of the ShapeNode text area. (Inherited from ShapeNode.)
TextWrapping | Gets or sets whether text wraps when it extends beyond the available width of the node. This is a dependency property. (Inherited from ShapeNode.)
ToolTip | Gets or sets the contents of the tooltip displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
Transparent | Gets or sets a value indicating whether this shape node is transparent. This is a dependency property. (Inherited from ShapeNode.)
VerticalImageAlignment | Gets or sets the vertical alignment of the ShapeNode's image. (Inherited from ShapeNode.)
VerticalTextBlockAlignment | Gets or sets the vertical alignment of the TextBlock used to display the ShapeNode text relative to its container Grid. (Inherited from ShapeNode.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of the object. (Inherited from DiagramItem.)

Inherited Protected Properties

Name | Description
Size | Gets the size of this item. (Inherited from DiagramItem.)

Public Methods

Name | Description
ContainsRecursively | Determines whether this container contains the specified node, either directly or recursively through other containers.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
OnBoundsChanged | DiagramNode.OnBoundsChanged override.
OnDragOut | Invoked when a diagram item is being dragged out of this node.
OnDragOver | Invoked when a diagram item is being dragged over this node.
OnDropOver | Invoked when a diagram item is dropped over this node.

Protected Methods

Name | Description
AddFoldButton | Adds the FoldButton to the node's Adoner.
CancelDrag | DiagramItem.CancelDrag override.
CreateState | DiagramItem.CreateState override.
EndDrag | DiagramItem.EndDrag override.
LoadFromXml | Loads the item content from an XML element.
OnChildModified | Called when a child node has been modified.
OnRemove | DiagramNode.OnRemove override.
RestoreState | DiagramItem.RestoreState override.
SaveState | DiagramItem.SaveState override.
SaveToXml | Saves the item content into an XML element.
ScaleElements | DiagramNode.ScaleElements override.
StartDrag | DiagramItem.StartDrag override.
UpdateVisuals | ShapeNode.UpdateVisuals override.

Inherited Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
Attach | Attaches the specified subordinate node to this node, so that when this node is moved, the subordinate follows it. (Inherited from DiagramNode.)
AttachTo | Attaches this node to the specified master node so that when the master is moved, the attached node follows it. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
ContainsPoint | DiagramItem.ContainsPoint override. (Inherited from DiagramNode.)
Detach | Overloaded. (Inherited from DiagramNode.)
GetAllIncomingLinks | Gets a collection of all links entering this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Get a collection of all links going out of this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramNode.GetOutlinePoly override. (Inherited from ShapeNode.)
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from DiagramNode.)
OnBoundsChanged | Called when the location and size of this node change. (Inherited from DiagramNode.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
ResizeToFitImage | Makes the shape node as big as the image it displays. (Inherited from ShapeNode.)
ResizeToFitText | Makes the shape node big enough to display its text without clipping. (Inherited from ShapeNode.)
RestoreLocationState | DiagramItem.RestoreLocationState override. (Inherited from DiagramNode.)
SaveLocationState | DiagramItem.SaveLocationState override. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point in diagram coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Gets the diagram coordinates of a point specified in the local coordinate system of this item. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Inherited Protected Methods

Name | Description
AddAnchorPointVisuals | Adds the AnchorPatern points to the node's Adorner. (Inherited from DiagramNode.)
AddExpandButton | Adds the ExpandButton to the node's Adoner. (Inherited from DiagramNode.)
AddHandlesToCanvas | Overloaded. (Inherited from DiagramNode.)
AllowDrag | Invoked to validate the drag operation. (Inherited from DiagramItem.)
CancelDrag | DiagramItem.CancelDrag override. (Inherited from DiagramNode.)
CreateAnchorPointVisual | Creates a Path that represents the specified AnchorPoint. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
CreateState | DiagramItem.CreateState override. (Inherited from ShapeNode.)
EndDrag | DiagramItem.EndDrag override. (Inherited from DiagramNode.)
GetOutline | DiagramNode.GetOutline override. (Inherited from ShapeNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
LoadFromXml | Loads the item content from an XML element. (Inherited from ShapeNode.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramNode.)
OnMouseEnter | Control.OnMouseEnter override. (Inherited from DiagramItem.)
OnMouseLeave | Control.OnMouseLeave override. (Inherited from DiagramItem.)
OnMouseLeftButtonDown | Control.OnMouseLeftButtonDown override. (Inherited from DiagramItem.)
OnMouseLeftButtonUp | Control.OnMouseLeftButtonUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
RemoveAnchorPointVisuals | Removes the AnchorPatern points from the node's Adorner. (Inherited from DiagramNode.)
RemoveHandlesFromCanvas | Invoked when the item's selection handles should be removed. (Inherited from DiagramItem.)
RestoreState | DiagramItem.RestoreState override. (Inherited from ShapeNode.)
SaveState | DiagramItem.SaveState override. (Inherited from ShapeNode.)
SaveToXml | Saves the item content into an XML element. (Inherited from ShapeNode.)
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
StartDrag | DiagramItem.StartDrag override. (Inherited from DiagramNode.)
UpdateDrag | DiagramItem.UpdateDrag override. (Inherited from DiagramNode.)
UpdateHandleColors | Sets the handle colors according to the current selection state of the item and the enabled bits in the EnabledHandles property. (Inherited from DiagramItem.)
UpdateHandlePositions | Invoked when the item's selection handles should change their position. (Inherited from DiagramItem.)
UpdateStates | Sets the current VisualStates of this item. (Inherited from DiagramItem.)
UpdateVisuals | DiagramNode.UpdateVisuals override. (Inherited from ShapeNode.)

See Also

ContainerNode Class


MindFusion.Diagramming.ContainerNode Fields

ContainerNode Fields
[image]

Public Fields

Name | Description
CaptionHeightProperty | Identifies the CaptionHeight dependency property.
FoldableProperty | Identifies the Foldable dependency property.

Inherited Public Fields

Name | Description
AutoCaptureMouseProperty | Identifies the AutoCaptureMouse dependency property. (Inherited from DiagramItem.)
BoundsProperty | Identifies the Bounds dependency property. (Inherited from DiagramNode.)
BrushProperty | Identifies the Brush dependency property. (Inherited from DiagramItem.)
DecorationsContainerProperty | Identifies the DecorationsContainer dependency property. (Inherited from ShapeNode.)
EffectsSourceProperty | Identifies the EffectsSource dependency property. (Inherited from DiagramNode.)
HorizontalImageAlignmentProperty | Identifies the HorizontalImageAlignment dependency property. (Inherited from ShapeNode.)
HorizontalTextBlockAlignmentProperty | Identifies the HorizontalTextBlockAlignment dependency property. (Inherited from ShapeNode.)
HyperLinkProperty | Identifies the HyperLink dependency property. (Inherited from DiagramItem.)
ImageProperty | Identifies the Image dependency property. (Inherited from ShapeNode.)
ImageStretchProperty | Identifies the ImageStretch dependency property. (Inherited from ShapeNode.)
IsMouseDownProperty | Identifies the IsMouseDown dependency property. (Inherited from DiagramItem.)
IsMouseOverProperty | Identifies the IsMouseOver dependency property. (Inherited from DiagramItem.)
MasterNodeProperty | Identifies the MasterNode dependency property. (Inherited from DiagramNode.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from DiagramNode.)
ShapeGeometryProperty | Identifies the ShapeGeometry dependency property. (Inherited from ShapeNode.)
ShapeOpacityProperty | Identifies the ShapeOpacity dependency property. (Inherited from DiagramNode.)
ShapeProperty | Identifies the Shape dependency property. (Inherited from ShapeNode.)
ShapeVisibilityProperty | Identifies the ShapeVisibility dependency property. (Inherited from ShapeNode.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from DiagramItem.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from ShapeNode.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)
TextHeightProperty | Identifies the TextHeight dependency property. (Inherited from ShapeNode.)
TextMarginProperty | Identifies the TextMargin dependency property. (Inherited from ShapeNode.)
TextProperty | Identifies the Text dependency property. (Inherited from ShapeNode.)
TextWidthProperty | Identifies the TextWidth dependency property. (Inherited from ShapeNode.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from ShapeNode.)
TransparentProperty | Identifies the Transparent dependency property. (Inherited from ShapeNode.)
VerticalImageAlignmentProperty | Identifies the VerticalImageAlignment dependency property. (Inherited from ShapeNode.)
VerticalTextBlockAlignmentProperty | Identifies the VerticalTextBlockAlignment dependency property. (Inherited from ShapeNode.)

Inherited Protected Fields

Name | Description
handles | A list of the Rectangle objects that represent the item's adjustment handles. (Inherited from DiagramItem.)

See Also

ContainerNode Class


MindFusion.Diagramming.ContainerNode.CaptionHeightProperty Field

ContainerNode.CaptionHeightProperty Field
[image]

Identifies the CaptionHeight dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CaptionHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CaptionHeightProperty As DependencyProperty

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.FoldableProperty Field

ContainerNode.FoldableProperty Field
[image]

Identifies the Foldable dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FoldableProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FoldableProperty As DependencyProperty

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode Constructor

ContainerNode Constructor
[image]

Overload List

Name | Description
ContainerNode () | Initializes a new instance of the ContainerNode class.
ContainerNode (ContainerNode) | Initializes a new instance of the ContainerNode class.
ContainerNode (Diagram) | Initializes a new instance of the ContainerNode class.

See Also

ContainerNode Class


MindFusion.Diagramming.ContainerNode Constructor ()

ContainerNode Constructor ()
See Also
[image]

Initializes a new instance of the ContainerNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode ()

Visual Basic [image] Copy Code

Public Sub New ()

Remarks

This constructor leaves the node's dependency properties in their default state, without local values. This allows the node to be styled through the WinRT styling mechanism.

See Also

ContainerNode Constructor Overload List
ContainerNode Class


MindFusion.Diagramming.ContainerNode Constructor (ContainerNode)

ContainerNode Constructor (ContainerNode)
See Also
[image]

Initializes a new instance of the ContainerNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode (
ContainerNode prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As ContainerNode _
)

Parameters

prototype

See Also

ContainerNode Constructor Overload List
ContainerNode Class


MindFusion.Diagramming.ContainerNode Constructor (Diagram)

ContainerNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the ContainerNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode (
Diagram parent
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram _
)

Parameters

parent

See Also

ContainerNode Constructor Overload List
ContainerNode Class


MindFusion.Diagramming.ContainerNode Methods

ContainerNode Methods
[image]

Public Methods

Name | Description
ContainsRecursively | Determines whether this container contains the specified node, either directly or recursively through other containers.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
OnBoundsChanged | DiagramNode.OnBoundsChanged override.
OnDragOut | Invoked when a diagram item is being dragged out of this node.
OnDragOver | Invoked when a diagram item is being dragged over this node.
OnDropOver | Invoked when a diagram item is dropped over this node.

Protected Methods

Name | Description
AddFoldButton | Adds the FoldButton to the node's Adoner.
CancelDrag | DiagramItem.CancelDrag override.
CreateState | DiagramItem.CreateState override.
EndDrag | DiagramItem.EndDrag override.
LoadFromXml | Loads the item content from an XML element.
OnChildModified | Called when a child node has been modified.
OnRemove | DiagramNode.OnRemove override.
RestoreState | DiagramItem.RestoreState override.
SaveState | DiagramItem.SaveState override.
SaveToXml | Saves the item content into an XML element.
ScaleElements | DiagramNode.ScaleElements override.
StartDrag | DiagramItem.StartDrag override.
UpdateVisuals | ShapeNode.UpdateVisuals override.

Inherited Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
Attach | Attaches the specified subordinate node to this node, so that when this node is moved, the subordinate follows it. (Inherited from DiagramNode.)
AttachTo | Attaches this node to the specified master node so that when the master is moved, the attached node follows it. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
ContainsPoint | DiagramItem.ContainsPoint override. (Inherited from DiagramNode.)
Detach | Overloaded. (Inherited from DiagramNode.)
GetAllIncomingLinks | Gets a collection of all links entering this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Get a collection of all links going out of this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramNode.GetOutlinePoly override. (Inherited from ShapeNode.)
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from DiagramNode.)
OnBoundsChanged | Called when the location and size of this node change. (Inherited from DiagramNode.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
ResizeToFitImage | Makes the shape node as big as the image it displays. (Inherited from ShapeNode.)
ResizeToFitText | Makes the shape node big enough to display its text without clipping. (Inherited from ShapeNode.)
RestoreLocationState | DiagramItem.RestoreLocationState override. (Inherited from DiagramNode.)
SaveLocationState | DiagramItem.SaveLocationState override. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point in diagram coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Gets the diagram coordinates of a point specified in the local coordinate system of this item. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Inherited Protected Methods

Name | Description
AddAnchorPointVisuals | Adds the AnchorPatern points to the node's Adorner. (Inherited from DiagramNode.)
AddExpandButton | Adds the ExpandButton to the node's Adoner. (Inherited from DiagramNode.)
AddHandlesToCanvas | Overloaded. (Inherited from DiagramNode.)
AllowDrag | Invoked to validate the drag operation. (Inherited from DiagramItem.)
CancelDrag | DiagramItem.CancelDrag override. (Inherited from DiagramNode.)
CreateAnchorPointVisual | Creates a Path that represents the specified AnchorPoint. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
CreateState | DiagramItem.CreateState override. (Inherited from ShapeNode.)
EndDrag | DiagramItem.EndDrag override. (Inherited from DiagramNode.)
GetOutline | DiagramNode.GetOutline override. (Inherited from ShapeNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
LoadFromXml | Loads the item content from an XML element. (Inherited from ShapeNode.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramNode.)
OnMouseEnter | Control.OnMouseEnter override. (Inherited from DiagramItem.)
OnMouseLeave | Control.OnMouseLeave override. (Inherited from DiagramItem.)
OnMouseLeftButtonDown | Control.OnMouseLeftButtonDown override. (Inherited from DiagramItem.)
OnMouseLeftButtonUp | Control.OnMouseLeftButtonUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
RemoveAnchorPointVisuals | Removes the AnchorPatern points from the node's Adorner. (Inherited from DiagramNode.)
RemoveHandlesFromCanvas | Invoked when the item's selection handles should be removed. (Inherited from DiagramItem.)
RestoreState | DiagramItem.RestoreState override. (Inherited from ShapeNode.)
SaveState | DiagramItem.SaveState override. (Inherited from ShapeNode.)
SaveToXml | Saves the item content into an XML element. (Inherited from ShapeNode.)
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
StartDrag | DiagramItem.StartDrag override. (Inherited from DiagramNode.)
UpdateDrag | DiagramItem.UpdateDrag override. (Inherited from DiagramNode.)
UpdateHandleColors | Sets the handle colors according to the current selection state of the item and the enabled bits in the EnabledHandles property. (Inherited from DiagramItem.)
UpdateHandlePositions | Invoked when the item's selection handles should change their position. (Inherited from DiagramItem.)
UpdateStates | Sets the current VisualStates of this item. (Inherited from DiagramItem.)
UpdateVisuals | DiagramNode.UpdateVisuals override. (Inherited from ShapeNode.)

See Also

ContainerNode Class


MindFusion.Diagramming.ContainerNode.AddFoldButton Method

ContainerNode.AddFoldButton Method
[image]

Adds the FoldButton to the node's Adoner.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void AddFoldButton ()

Visual Basic [image] Copy Code

Protected Sub AddFoldButton ()

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.CancelDrag Method

ContainerNode.CancelDrag Method
[image]

DiagramItem.CancelDrag override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void CancelDrag (
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub CancelDrag( _
ist As InteractionState _
)

Parameters

ist

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.ContainsRecursively Method

ContainerNode.ContainsRecursively Method
[image]

Determines whether this container contains the specified node, either directly or recursively through other containers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ContainsRecursively (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Function ContainsRecursively( _
node As DiagramNode _
) As Boolean

Parameters

node

The DiagramNode to check.

Return Value

true if this container contains the node; otherwise, false.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.CreateState Method

ContainerNode.CreateState Method
[image]

DiagramItem.CreateState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramItemState CreateState ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateState () As DiagramItemState

Return Value

A ContainerNodeState instance.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.EndDrag Method

ContainerNode.EndDrag Method
[image]

DiagramItem.EndDrag override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void EndDrag (
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub EndDrag( _
ist As InteractionState _
)

Parameters

ist

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.LoadFromXml Method

ContainerNode.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void LoadFromXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromXml( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
A Linq XElement containing the item's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.OnApplyTemplate Method

ContainerNode.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.OnBoundsChanged Method

ContainerNode.OnBoundsChanged Method
[image]

DiagramNode.OnBoundsChanged override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void OnBoundsChanged (
Rect oldRect,
Rect newRect,
bool updateLinks,
bool updateChildren,
bool updateStorage
)

Visual Basic [image] Copy Code

Public Overrides Sub OnBoundsChanged( _
oldRect As Rect, _
newRect As Rect, _
updateLinks As Boolean, _
updateChildren As Boolean, _
updateStorage As Boolean _
)

Parameters

oldRect

newRect

updateLinks

updateChildren

updateStorage

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.OnChildModified Method

ContainerNode.OnChildModified Method
[image]

Called when a child node has been modified.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnChildModified (
DiagramNode node,
AdjustmentHandles handle
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnChildModified ( _
node As DiagramNode, _
handle As AdjustmentHandles _
)

Parameters

node
The DiagramNode that has been moved or resized.
handle

The adjustment handle used to modify the node.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.OnDragOut Method

ContainerNode.OnDragOut Method
[image]

Invoked when a diagram item is being dragged out of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void OnDragOut (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Overrides Sub OnDragOut ( _
item As DiagramItem _
)

Parameters

item
The DiagramItem being dragged.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.OnDragOver Method

ContainerNode.OnDragOver Method
[image]

Invoked when a diagram item is being dragged over this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool OnDragOver (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Overrides Function OnDragOver( _
item As DiagramItem _
) As Boolean

Parameters

item
The DiagramItem being dragged.

Return Value

false if the diagram should notify nodes below this one; otherwise, true.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.OnDropOver Method

ContainerNode.OnDropOver Method
[image]

Invoked when a diagram item is dropped over this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool OnDropOver (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Overrides Function OnDropOver ( _
item As DiagramItem _
) As Boolean

Parameters

item
The DiagramItem being dragged.

Return Value

false if the diagram should notify nodes below this one; otherwise, true.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.OnRemove Method

ContainerNode.OnRemove Method
[image]

DiagramNode.OnRemove override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnRemove ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnRemove ()

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.RestoreState Method

ContainerNode.RestoreState Method
[image]

DiagramItem.RestoreState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void RestoreState (
DiagramItemState itemState
)

Visual Basic [image] Copy Code

Protected Overridable Sub RestoreState ( _
itemState As DiagramItemState _
)

Parameters

itemState
A ContainerNodeState instance.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.SaveState Method

ContainerNode.SaveState Method
[image]

DiagramItem.SaveState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramItemState SaveState ()

Visual Basic [image] Copy Code

Protected Overridable Function SaveState () As DiagramItemState

Return Value

A ContainerNodeState instance.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.SaveToXml Method

ContainerNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SaveToXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveToXml( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
A Linq XElement the item's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.ScaleElements Method

ContainerNode.ScaleElements Method
[image]

DiagramNode.ScaleElements override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void ScaleElements (
double scale
)

Visual Basic [image] Copy Code

Protected Overrides Sub ScaleElements( _
scale As Double _
)

Parameters

scale

The value by which to multiply node elements' sizes.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.StartDrag Method

ContainerNode.StartDrag Method
[image]

DiagramItem.StartDrag override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void StartDrag (
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub StartDrag( _
ist As InteractionState _
)

Parameters

ist

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.UpdateVisuals Method

ContainerNode.UpdateVisuals Method
[image]

ShapeNode.UpdateVisuals override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void UpdateVisuals (
bool updateEffects
)

Visual Basic [image] Copy Code

Protected Overrides Sub UpdateVisuals( _
updateEffects As Boolean _
)

Parameters

updateEffects

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode Properties

ContainerNode Properties
[image]

Public Properties

Name | Description
AllowAddChildren | Gets or sets a value indicating whether users are allowed to add nodes to this container.
AllowRemoveChildren | Gets or sets a value indicating whether users are allowed to remove nodes from this container.
CaptionHeight | Gets or sets the height of the container's caption bar. This is a dependency property.
Children | Gets the collection of child nodes of this container.
Foldable | Gets or sets a value indicating whether the user is allowed to fold this container.
Folded | Gets or sets a value indicating whether this container is folded.
UnfoldedSize | Returns the original size of a folded container.
Visible | Gets or sets a value indicating whether the container is visible.

Inherited Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
AttachedNodes | Returns the nodes attached to this node. (Inherited from DiagramNode.)
AutoCaptureMouse | Gets or sets whether the item should capture the mouse input when the left button is pressed over it. This is a dependency property. (Inherited from DiagramItem.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. This is a dependency property. (Inherited from DiagramNode.)
Brush | Gets or sets the Brush that specifies how to paint the interior of the item. This is a dependency property. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Container | Gets the ContainerNode that contains this node. (Inherited from DiagramNode.)
DecorationsContainer | Gets a Grid that contains the ShapeNode decoration elements. (Inherited from ShapeNode.)
Diagram | Gets the parent diagram. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramItem.)
HorizontalImageAlignment | Gets or sets the horizontal alignment of the ShapeNode's image. (Inherited from ShapeNode.)
HorizontalTextBlockAlignment | Gets or sets the horizontal alignment of the TextBlock used to display the ShapeNode text relative to its container Grid. (Inherited from ShapeNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. This is a dependency property. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
Image | Gets or sets the image that is displayed in this shape node. This is a dependency property. (Inherited from ShapeNode.)
ImageAlign | Gets or sets the alignment of the image displayed in this shape node. (Inherited from ShapeNode.)
ImageResourceLocation | Gets or sets the resource path to an image that should be displayed in this ShapeNode. (Inherited from ShapeNode.)
ImageStretch | Gets or sets a value that describes how the ShapeNode's image should be stretched to fill the destination rectangle. (Inherited from ShapeNode.)
ImageWebLocation | Gets or sets the URL of the image displayed in this ShapeNode. (Inherited from ShapeNode.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
IsMouseDown | Gets a value indicating whether the mouse button is pressed over this item. This is a dependency property. (Inherited from DiagramItem.)
IsMouseOver | Gets a value indicating whether the mouse pointer is located over this item. This is a dependency property. (Inherited from DiagramItem.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterNode | Gets the node to which this node is attached. This is a dependency property. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
RotationAngle | Gets or sets the angle at which this node is rotated. This is a dependency property. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Shape | Gets or sets a reference to the node's geometric shape definition. (Inherited from ShapeNode.)
ShapeGeometry | Gets a Geometry object that represents the ShapeNode outline and is automatically generated from the current Shape and Bounds values. (Inherited from ShapeNode.)
ShapeOpacity | Gets or sets the shape opacity of this node. This is a dependency property. (Inherited from DiagramNode.)
ShapeVisibility | For internal use. (Inherited from ShapeNode.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline nodes. This is a dependency property. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashOffset | Gets or sets a double value that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. This is a dependency property. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
Text | Gets or sets the text displayed inside the shape node. This is a dependency property. (Inherited from ShapeNode.)
TextAlignment | Gets or sets how the text should be aligned in the ShapeNode's text box. (Inherited from ShapeNode.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
TextFormat | Gets or sets the alignment of the text that is displayed inside shape nodes. (Inherited from ShapeNode.)
TextHeight | Gets or sets the height of the ShapeNode text area. (Inherited from ShapeNode.)
TextMargin | Gets or sets the offset of the ShapeNode text area from the origin of its container Grid. (Inherited from ShapeNode.)
TextWidth | Gets or sets the width of the ShapeNode text area. (Inherited from ShapeNode.)
TextWrapping | Gets or sets whether text wraps when it extends beyond the available width of the node. This is a dependency property. (Inherited from ShapeNode.)
ToolTip | Gets or sets the contents of the tooltip displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
Transparent | Gets or sets a value indicating whether this shape node is transparent. This is a dependency property. (Inherited from ShapeNode.)
VerticalImageAlignment | Gets or sets the vertical alignment of the ShapeNode's image. (Inherited from ShapeNode.)
VerticalTextBlockAlignment | Gets or sets the vertical alignment of the TextBlock used to display the ShapeNode text relative to its container Grid. (Inherited from ShapeNode.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of the object. (Inherited from DiagramItem.)

Inherited Protected Properties

Name | Description
Size | Gets the size of this item. (Inherited from DiagramItem.)

See Also

ContainerNode Class


MindFusion.Diagramming.ContainerNode.AllowAddChildren Property

ContainerNode.AllowAddChildren Property
[image]

Gets or sets a value indicating whether users are allowed to add nodes to this container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowAddChildren { get; set; }

Visual Basic [image] Copy Code

Public Property AllowAddChildren As Boolean

Property Value

true to let users add child nodes to this container; otherwise, false. The default value is true.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace
AllowRemoveChildren Property


MindFusion.Diagramming.ContainerNode.AllowRemoveChildren Property

ContainerNode.AllowRemoveChildren Property
[image]

Gets or sets a value indicating whether users are allowed to remove nodes from this container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowRemoveChildren { get; set; }

Visual Basic [image] Copy Code

Public Property AllowRemoveChildren As Boolean

Property Value

true to let users remove a child node; otherwise, false. The default value is true.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace
AllowAddChildren Property


MindFusion.Diagramming.ContainerNode.CaptionHeight Property

ContainerNode.CaptionHeight Property
[image]

Gets or sets the height of the container's caption bar. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double CaptionHeight { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionHeight As Double

Property Value

A double value specifying the height of the caption bar. The default value is 20.

Remarks

You can assign 0 to this property to hide the caption bar and display Text centered in the node's Bounds.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.Children Property

ContainerNode.Children Property
[image]

Gets the collection of child nodes of this container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeCollection Children { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Children As DiagramNodeCollection

Property Value

An instance of the DiagramNodeCollection class.

Remarks

You can use the Add and Remove methods of this collection to programmatically add or remove child nodes.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace
DiagramNode.Container Property


MindFusion.Diagramming.ContainerNode.Foldable Property

ContainerNode.Foldable Property
[image]

Gets or sets a value indicating whether the user is allowed to fold this container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Foldable { get; set; }

Visual Basic [image] Copy Code

Public Property Foldable As Boolean

Property Value

true if the container can be folded; otherwise, false. Initialized with the value of ContainersFoldable.

Remarks

A foldable container can be folded and unfolded by clicking the up/down arrow displayed in the caption area.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace
Folded Property


MindFusion.Diagramming.ContainerNode.Folded Property

ContainerNode.Folded Property
[image]

Gets or sets a value indicating whether this container is folded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Folded { get; set; }

Visual Basic [image] Copy Code

Public Property Folded As Boolean

Property Value

true if the container is folded; otherwise, false. The default is false.

Remarks

When folded, the container children are not visible, and only its caption bar is displayed.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace
Foldable Property


MindFusion.Diagramming.ContainerNode.UnfoldedSize Property

ContainerNode.UnfoldedSize Property
[image]

Returns the original size of a folded container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Size UnfoldedSize { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property UnfoldedSize As Size

Property Value

A Size instance containing the original size of the container.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.Visible Property

ContainerNode.Visible Property
[image]

Gets or sets a value indicating whether the container is visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Visible As Boolean

Property Value

true if the container is visible; otherwise, false.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNodeState Class

ContainerNodeState Class
[image]

Represents the state of a ContainerNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ContainerNodeState : ShapeNodeState

Visual Basic [image] Copy Code

Public Class ContainerNodeState
Inherits ShapeNodeState

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemState
MindFusion.Diagramming.DiagramNodeState
MindFusion.Diagramming.ShapeNodeState
MindFusion.Diagramming.ContainerNodeState

See Also

ContainerNodeState Members


MindFusion.Diagramming.ContainerNodeState Members

ContainerNodeState Members
Constructors
[image]

Represents the state of a ContainerNode.

The following tables list the members exposed by the ContainerNodeState type.

Public Constructors

Name | Description
ContainerNodeState |

See Also

ContainerNodeState Class


MindFusion.Diagramming.ContainerNodeState Constructor

ContainerNodeState Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNodeState ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ContainerNodeState Class


MindFusion.Diagramming.ControlNode Class

ControlNode Class
[image]

ControlNode instances represent diagram nodes which can host WinRT controls.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ControlNode : DiagramNode

Visual Basic [image] Copy Code

Public Class ControlNode
Inherits DiagramNode

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
Windows.UI.Xaml.Controls.ContentControl
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.ControlNode

See Also

ControlNode Members


MindFusion.Diagramming.ControlNode Members

ControlNode Members
Constructors Fields Properties Methods
[image]

ControlNode instances represent diagram nodes which can host WinRT controls.

The following tables list the members exposed by the ControlNode type.

Public Constructors

Name | Description
ControlNode | Overloaded.

Inherited Public Fields

Name | Description
AutoCaptureMouseProperty | Identifies the AutoCaptureMouse dependency property. (Inherited from DiagramItem.)
BoundsProperty | Identifies the Bounds dependency property. (Inherited from DiagramNode.)
BrushProperty | Identifies the Brush dependency property. (Inherited from DiagramItem.)
EffectsSourceProperty | Identifies the EffectsSource dependency property. (Inherited from DiagramNode.)
HyperLinkProperty | Identifies the HyperLink dependency property. (Inherited from DiagramItem.)
IsMouseDownProperty | Identifies the IsMouseDown dependency property. (Inherited from DiagramItem.)
IsMouseOverProperty | Identifies the IsMouseOver dependency property. (Inherited from DiagramItem.)
MasterNodeProperty | Identifies the MasterNode dependency property. (Inherited from DiagramNode.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from DiagramNode.)
ShapeOpacityProperty | Identifies the ShapeOpacity dependency property. (Inherited from DiagramNode.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from DiagramItem.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)

Inherited Protected Fields

Name | Description
handles | A list of the Rectangle objects that represent the item's adjustment handles. (Inherited from DiagramItem.)

Public Properties

Name | Description
Control | Gets or sets the FrameworkElement control that is associated with the ControlNode.

Inherited Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
AttachedNodes | Returns the nodes attached to this node. (Inherited from DiagramNode.)
AutoCaptureMouse | Gets or sets whether the item should capture the mouse input when the left button is pressed over it. This is a dependency property. (Inherited from DiagramItem.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. This is a dependency property. (Inherited from DiagramNode.)
Brush | Gets or sets the Brush that specifies how to paint the interior of the item. This is a dependency property. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Container | Gets the ContainerNode that contains this node. (Inherited from DiagramNode.)
Diagram | Gets the parent diagram. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramItem.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. This is a dependency property. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
IsMouseDown | Gets a value indicating whether the mouse button is pressed over this item. This is a dependency property. (Inherited from DiagramItem.)
IsMouseOver | Gets a value indicating whether the mouse pointer is located over this item. This is a dependency property. (Inherited from DiagramItem.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterNode | Gets the node to which this node is attached. This is a dependency property. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
RotationAngle | Gets or sets the angle at which this node is rotated. This is a dependency property. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShapeOpacity | Gets or sets the shape opacity of this node. This is a dependency property. (Inherited from DiagramNode.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline nodes. This is a dependency property. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashOffset | Gets or sets a double value that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. This is a dependency property. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
ToolTip | Gets or sets the contents of the tooltip displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of the object. (Inherited from DiagramItem.)

Inherited Protected Properties

Name | Description
Size | Gets the size of this item. (Inherited from DiagramItem.)

Protected Methods

Name | Description
CreateState | DiagramItem.CreateState override.
LoadFromXml | Loads the item content from an XML element.
RestoreState | DiagramItem.RestoreState override.
SaveState | DiagramItem.SaveState override.
SaveToXml | Saves the item content into an XML element.
UpdateVisuals | DiagramNode.UpdateVisuals override.

Inherited Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
Attach | Attaches the specified subordinate node to this node, so that when this node is moved, the subordinate follows it. (Inherited from DiagramNode.)
AttachTo | Attaches this node to the specified master node so that when the master is moved, the attached node follows it. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
ContainsPoint | DiagramItem.ContainsPoint override. (Inherited from DiagramNode.)
Detach | Overloaded. (Inherited from DiagramNode.)
GetAllIncomingLinks | Gets a collection of all links entering this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Get a collection of all links going out of this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from DiagramNode.)
OnBoundsChanged | Called when the location and size of this node change. (Inherited from DiagramNode.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RestoreLocationState | DiagramItem.RestoreLocationState override. (Inherited from DiagramNode.)
SaveLocationState | DiagramItem.SaveLocationState override. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point in diagram coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Gets the diagram coordinates of a point specified in the local coordinate system of this item. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Inherited Protected Methods

Name | Description
AddAnchorPointVisuals | Adds the AnchorPatern points to the node's Adorner. (Inherited from DiagramNode.)
AddExpandButton | Adds the ExpandButton to the node's Adoner. (Inherited from DiagramNode.)
AddHandlesToCanvas | Overloaded. (Inherited from DiagramNode.)
AllowDrag | Invoked to validate the drag operation. (Inherited from DiagramItem.)
CancelDrag | DiagramItem.CancelDrag override. (Inherited from DiagramNode.)
CreateAnchorPointVisual | Creates a Path that represents the specified AnchorPoint. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
EndDrag | DiagramItem.EndDrag override. (Inherited from DiagramNode.)
GetOutline | Creates a Geometry object that describes the outline of the node. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
LoadFromXml | DiagramItem.LoadFromXml override. (Inherited from DiagramNode.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramNode.)
OnMouseEnter | Control.OnMouseEnter override. (Inherited from DiagramItem.)
OnMouseLeave | Control.OnMouseLeave override. (Inherited from DiagramItem.)
OnMouseLeftButtonDown | Control.OnMouseLeftButtonDown override. (Inherited from DiagramItem.)
OnMouseLeftButtonUp | Control.OnMouseLeftButtonUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
RemoveAnchorPointVisuals | Removes the AnchorPatern points from the node's Adorner. (Inherited from DiagramNode.)
RemoveHandlesFromCanvas | Invoked when the item's selection handles should be removed. (Inherited from DiagramItem.)
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramNode.)
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
StartDrag | DiagramItem.StartDrag override. (Inherited from DiagramNode.)
UpdateDrag | DiagramItem.UpdateDrag override. (Inherited from DiagramNode.)
UpdateHandleColors | Sets the handle colors according to the current selection state of the item and the enabled bits in the EnabledHandles property. (Inherited from DiagramItem.)
UpdateHandlePositions | Invoked when the item's selection handles should change their position. (Inherited from DiagramItem.)
UpdateStates | Sets the current VisualStates of this item. (Inherited from DiagramItem.)
UpdateVisuals | DiagramItem.UpdateVisuals override. (Inherited from DiagramNode.)

See Also

ControlNode Class


MindFusion.Diagramming.ControlNode Constructor

ControlNode Constructor
[image]

Overload List

Name | Description
ControlNode () | Initializes a new instance of the ControlNode class.
ControlNode (ControlNode, FrameworkElement) | Initializes a new instance of the ControlNode class using the specified control node as a prototype.
ControlNode (Diagram) | Initializes a new instance of the ControlNode class.
ControlNode (Diagram, FrameworkElement) | Initializes a new instance of the ControlNode class.

See Also

ControlNode Class


MindFusion.Diagramming.ControlNode Constructor ()

ControlNode Constructor ()
See Also
[image]

Initializes a new instance of the ControlNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ControlNode ()

Visual Basic [image] Copy Code

Public Sub New ()

Remarks

This constructor leaves the node's dependency properties in their default state, without local values. This allows the node to be styled through the WinRT styling mechanism.

See Also

ControlNode Constructor Overload List
ControlNode Class


MindFusion.Diagramming.ControlNode Constructor (ControlNode, FrameworkElement)

ControlNode Constructor (ControlNode, FrameworkElement)
See Also
[image]

Initializes a new instance of the ControlNode class using the specified control node as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ControlNode (
ControlNode prototype,
FrameworkElement control
)

Visual Basic [image] Copy Code

Public New ( _
prototype As ControlNode, _
control As FrameworkElement _
)

Parameters

prototype
The ControlNode from which to copy values for the node properties.
control
A FrameworkElement object to be hosted inside the new node.

See Also

ControlNode Constructor Overload List
ControlNode Class


MindFusion.Diagramming.ControlNode Constructor (Diagram)

ControlNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the ControlNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ControlNode (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram

See Also

ControlNode Constructor Overload List
ControlNode Class


MindFusion.Diagramming.ControlNode Constructor (Diagram, FrameworkElement)

ControlNode Constructor (Diagram, FrameworkElement)
See Also
[image]

Initializes a new instance of the ControlNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ControlNode (
Diagram parent,
FrameworkElement control
)

Visual Basic [image] Copy Code

Public Sub ControlNode ( _
parent As Diagram, _
control As FrameworkElement _
)

Parameters

parent
The Diagram from which to obtain default values for the node properties.
control
A FrameworkElement object.

See Also

ControlNode Constructor Overload List
ControlNode Class


MindFusion.Diagramming.ControlNode Methods

ControlNode Methods
[image]

Protected Methods

Name | Description
CreateState | DiagramItem.CreateState override.
LoadFromXml | Loads the item content from an XML element.
RestoreState | DiagramItem.RestoreState override.
SaveState | DiagramItem.SaveState override.
SaveToXml | Saves the item content into an XML element.
UpdateVisuals | DiagramNode.UpdateVisuals override.

Inherited Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
Attach | Attaches the specified subordinate node to this node, so that when this node is moved, the subordinate follows it. (Inherited from DiagramNode.)
AttachTo | Attaches this node to the specified master node so that when the master is moved, the attached node follows it. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
ContainsPoint | DiagramItem.ContainsPoint override. (Inherited from DiagramNode.)
Detach | Overloaded. (Inherited from DiagramNode.)
GetAllIncomingLinks | Gets a collection of all links entering this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Get a collection of all links going out of this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from DiagramNode.)
OnBoundsChanged | Called when the location and size of this node change. (Inherited from DiagramNode.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RestoreLocationState | DiagramItem.RestoreLocationState override. (Inherited from DiagramNode.)
SaveLocationState | DiagramItem.SaveLocationState override. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point in diagram coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Gets the diagram coordinates of a point specified in the local coordinate system of this item. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Inherited Protected Methods

Name | Description
AddAnchorPointVisuals | Adds the AnchorPatern points to the node's Adorner. (Inherited from DiagramNode.)
AddExpandButton | Adds the ExpandButton to the node's Adoner. (Inherited from DiagramNode.)
AddHandlesToCanvas | Overloaded. (Inherited from DiagramNode.)
AllowDrag | Invoked to validate the drag operation. (Inherited from DiagramItem.)
CancelDrag | DiagramItem.CancelDrag override. (Inherited from DiagramNode.)
CreateAnchorPointVisual | Creates a Path that represents the specified AnchorPoint. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
EndDrag | DiagramItem.EndDrag override. (Inherited from DiagramNode.)
GetOutline | Creates a Geometry object that describes the outline of the node. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
LoadFromXml | DiagramItem.LoadFromXml override. (Inherited from DiagramNode.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramNode.)
OnMouseEnter | Control.OnMouseEnter override. (Inherited from DiagramItem.)
OnMouseLeave | Control.OnMouseLeave override. (Inherited from DiagramItem.)
OnMouseLeftButtonDown | Control.OnMouseLeftButtonDown override. (Inherited from DiagramItem.)
OnMouseLeftButtonUp | Control.OnMouseLeftButtonUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
RemoveAnchorPointVisuals | Removes the AnchorPatern points from the node's Adorner. (Inherited from DiagramNode.)
RemoveHandlesFromCanvas | Invoked when the item's selection handles should be removed. (Inherited from DiagramItem.)
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramNode.)
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
StartDrag | DiagramItem.StartDrag override. (Inherited from DiagramNode.)
UpdateDrag | DiagramItem.UpdateDrag override. (Inherited from DiagramNode.)
UpdateHandleColors | Sets the handle colors according to the current selection state of the item and the enabled bits in the EnabledHandles property. (Inherited from DiagramItem.)
UpdateHandlePositions | Invoked when the item's selection handles should change their position. (Inherited from DiagramItem.)
UpdateStates | Sets the current VisualStates of this item. (Inherited from DiagramItem.)
UpdateVisuals | DiagramItem.UpdateVisuals override. (Inherited from DiagramNode.)

See Also

ControlNode Class


MindFusion.Diagramming.ControlNode.CreateState Method

ControlNode.CreateState Method
[image]

DiagramItem.CreateState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramItemState CreateState ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateState () As DiagramItemState

Return Value

A ControlNodeState instance.

See Also

ControlNode Members
ControlNode Class


MindFusion.Diagramming.ControlNode.LoadFromXml Method

ControlNode.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void LoadFromXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromXml( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement containing the item's data.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ControlNode Members
ControlNode Class


MindFusion.Diagramming.ControlNode.RestoreState Method

ControlNode.RestoreState Method
[image]

DiagramItem.RestoreState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void RestoreState (
DiagramItemState itemState
)

Visual Basic [image] Copy Code

Protected Overridable Sub RestoreState ( _
itemState As DiagramItemState _
)

Parameters

itemState
A ControlNodeState instance.

See Also

ControlNode Members
ControlNode Class


MindFusion.Diagramming.ControlNode.SaveState Method

ControlNode.SaveState Method
[image]

DiagramItem.SaveState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramItemState SaveState ()

Visual Basic [image] Copy Code

Protected Overridable Function SaveState () As DiagramItemState

Return Value

A ControlNodeState instance.

See Also

ControlNode Members
ControlNode Class


MindFusion.Diagramming.ControlNode.SaveToXml Method

ControlNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SaveToXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveToXml( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement the item's data should be stored into.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ControlNode Members
ControlNode Class


MindFusion.Diagramming.ControlNode.UpdateVisuals Method

ControlNode.UpdateVisuals Method
[image]

DiagramNode.UpdateVisuals override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void UpdateVisuals (
bool updateEffects
)

Visual Basic [image] Copy Code

Protected Overrides Sub UpdateVisuals( _
updateEffects As Boolean _
)

Parameters

updateEffects

See Also

ControlNode Members
ControlNode Class


MindFusion.Diagramming.ControlNode Properties

ControlNode Properties
[image]

Public Properties

Name | Description
Control | Gets or sets the FrameworkElement control that is associated with the ControlNode.

Inherited Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
AttachedNodes | Returns the nodes attached to this node. (Inherited from DiagramNode.)
AutoCaptureMouse | Gets or sets whether the item should capture the mouse input when the left button is pressed over it. This is a dependency property. (Inherited from DiagramItem.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. This is a dependency property. (Inherited from DiagramNode.)
Brush | Gets or sets the Brush that specifies how to paint the interior of the item. This is a dependency property. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Container | Gets the ContainerNode that contains this node. (Inherited from DiagramNode.)
Diagram | Gets the parent diagram. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramItem.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. This is a dependency property. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
IsMouseDown | Gets a value indicating whether the mouse button is pressed over this item. This is a dependency property. (Inherited from DiagramItem.)
IsMouseOver | Gets a value indicating whether the mouse pointer is located over this item. This is a dependency property. (Inherited from DiagramItem.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterNode | Gets the node to which this node is attached. This is a dependency property. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
RotationAngle | Gets or sets the angle at which this node is rotated. This is a dependency property. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShapeOpacity | Gets or sets the shape opacity of this node. This is a dependency property. (Inherited from DiagramNode.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline nodes. This is a dependency property. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashOffset | Gets or sets a double value that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. This is a dependency property. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
ToolTip | Gets or sets the contents of the tooltip displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of the object. (Inherited from DiagramItem.)

Inherited Protected Properties

Name | Description
Size | Gets the size of this item. (Inherited from DiagramItem.)

See Also

ControlNode Class


MindFusion.Diagramming.ControlNode.Control Property

ControlNode.Control Property
[image]

Gets or sets the FrameworkElement control that is associated with the ControlNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FrameworkElement Control { get; set; }

Visual Basic [image] Copy Code

Public Property Control As FrameworkElement

Property Value

See Also

ControlNode Members
ControlNode Class


MindFusion.Diagramming.ControlNodeEventArgs Class

ControlNodeEventArgs Class
[image]

Contains the arguments passes to handlers of the control host serialization events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ControlNodeEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ControlNodeEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.ControlNodeEventArgs

See Also

ControlNodeEventArgs Members


MindFusion.Diagramming.ControlNodeEventArgs Members

ControlNodeEventArgs Members
Properties
[image]

Contains the arguments passes to handlers of the control host serialization events.

The following tables list the members exposed by the ControlNodeEventArgs type.

Public Properties

Name | Description
Context | Gets a context object that can help you write and read various values.
Handled | Gets or sets a value indicating whether the event is handled.
Node | Gets a reference to the ControlNode being serialized or deserialized.
XmlElement | Gets a stream object where you can store or retrieve any custom information.

See Also

ControlNodeEventArgs Class


MindFusion.Diagramming.ControlNodeEventArgs Properties

ControlNodeEventArgs Properties
[image]

Public Properties

Name | Description
Context | Gets a context object that can help you write and read various values.
Handled | Gets or sets a value indicating whether the event is handled.
Node | Gets a reference to the ControlNode being serialized or deserialized.
XmlElement | Gets a stream object where you can store or retrieve any custom information.

See Also

ControlNodeEventArgs Class


MindFusion.Diagramming.ControlNodeEventArgs.Context Property

ControlNodeEventArgs.Context Property
[image]

Gets a context object that can help you write and read various values.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlPersistContext Context { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Context As XmlPersistContext

Property Value

See Also

ControlNodeEventArgs Members
ControlNodeEventArgs Class


MindFusion.Diagramming.ControlNodeEventArgs.Handled Property

ControlNodeEventArgs.Handled Property
[image]

Gets or sets a value indicating whether the event is handled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Handled { get; set; }

Visual Basic [image] Copy Code

Public Property Handled As Boolean

Property Value

Remarks

Always set this flag to true if you perform custom tag serialization.

See Also

ControlNodeEventArgs Members
ControlNodeEventArgs Class


MindFusion.Diagramming.ControlNodeEventArgs.Node Property

ControlNodeEventArgs.Node Property
[image]

Gets a reference to the ControlNode being serialized or deserialized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ControlNode Node { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Node As ControlNode

Property Value

See Also

ControlNodeEventArgs Members
ControlNodeEventArgs Class


MindFusion.Diagramming.ControlNodeEventArgs.XmlElement Property

ControlNodeEventArgs.XmlElement Property
[image]

Gets a stream object where you can store or retrieve any custom information.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement XmlElement { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property XmlElement As XElement

Property Value

See Also

ControlNodeEventArgs Members
ControlNodeEventArgs Class


MindFusion.Diagramming.ControlNodeState Class

ControlNodeState Class
[image]

Represents the state of a ControlNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ControlNodeState : DiagramNodeState

Visual Basic [image] Copy Code

Public Class ControlNodeState
Inherits DiagramNodeState

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemState
MindFusion.Diagramming.DiagramNodeState
MindFusion.Diagramming.ControlNodeState

See Also

ControlNodeState Members


MindFusion.Diagramming.ControlNodeState Members

ControlNodeState Members
Constructors
[image]

Represents the state of a ControlNode.

The following tables list the members exposed by the ControlNodeState type.

Public Constructors

Name | Description
ControlNodeState |

See Also

ControlNodeState Class


MindFusion.Diagramming.ControlNodeState Constructor

ControlNodeState Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ControlNodeState ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ControlNodeState Class


MindFusion.Diagramming.Converter Class

Converter Class
[image]

Provides capabilities to convert various types to and from strings in a culture-independent way.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class Converter

Visual Basic [image] Copy Code

Public NotInheritable Class Converter

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Converter

See Also

Converter Members


MindFusion.Diagramming.Converter Members

Converter Members
Fields Methods
[image]

Provides capabilities to convert various types to and from strings in a culture-independent way.

The following tables list the members exposed by the Converter type.

Public Fields

Name | Description
NAMESPACE | The XML namespace for shape library files.

Public Methods

Name | Description
FromBoolean | Converts the specified bool value to string.
FromByte | Converts the specified byte value to string.
FromChar | Converts the specified char value to string.
FromColor | Converts the specified color value to string in the format #AARRGGBB.
FromDecimal | Converts the specified decimal to string.
FromDouble | Converts the specified double value to string.
FromEnum | Converts the specified enum value to a string.
FromInt16 | Converts the specified 16-bit integer value to string.
FromInt32 | Converts the specified 32-bit integer value to string.
FromInt64 | Converts the specified 64-bit integer to string.
FromSByte | Converts the specified 8-bit signed integer to string.
FromSingle | Overloaded.
FromStream | Converts the specified stream to string.
FromStreamV4 | Converts the specified memory stream to string.
FromUInt16 | Converts the specified unsigned 16-bit integer value to string.
FromUInt32 | Converts the specified unsigned 32-bit integer value to string.
FromUInt64 | Converts the specified unsigned 64-bit integer value to string.
FromXmlElement | Deserializes a Point object from the specified XmlElement.
SaveTo | Writes the specified point to the specified XmlWriter.
ToBoolean | Converts the specified string value to bool.
ToBrush | Converts the specified string value to Brush.
ToByte | Converts the specified string value to byte value.
ToChar | Converts the specified string value to char.
ToColor | Converts the specified string value to Color.
ToDecimal | Converts the specified string value to decimal.
ToDouble | Converts the specifed string value to double.
ToEnum | Converts the specified string value to its corresponding enumeration member of the specified type.
ToImage | Converts the specified string value to image.
ToInt16 | Converts the specified string value to 16-bit integer.
ToInt32 | Overloaded.
ToInt64 | Converts the specified string value to 64-bit integer.
ToSByte | Converts the specified string value to 8-bit signed integer.
ToSingle | Converts the specified string value to float.
ToStream | Converts the specified string value to stream.
ToStreamV4 | Converts the specified string value to stream.
ToUint16 | Converts the specified string value to unsigned 16-bit integer.
ToUint32 | Converts the specified string value to unsigned 32-bit integer.
ToUint64 | Converts the specified string value to unsigned 64-bit integer.

See Also

Converter Class


MindFusion.Diagramming.Converter Fields

Converter Fields
[image]

Public Fields

Name | Description
NAMESPACE | The XML namespace for shape library files.

See Also

Converter Class


MindFusion.Diagramming.Converter.NAMESPACE Field

Converter.NAMESPACE Field
[image]

The XML namespace for shape library files.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string NAMESPACE

Visual Basic [image] Copy Code

Public Shared NAMESPACE As String

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter Methods

Converter Methods
[image]

Public Methods

Name | Description
FromBoolean | Converts the specified bool value to string.
FromByte | Converts the specified byte value to string.
FromChar | Converts the specified char value to string.
FromColor | Converts the specified color value to string in the format #AARRGGBB.
FromDecimal | Converts the specified decimal to string.
FromDouble | Converts the specified double value to string.
FromEnum | Converts the specified enum value to a string.
FromInt16 | Converts the specified 16-bit integer value to string.
FromInt32 | Converts the specified 32-bit integer value to string.
FromInt64 | Converts the specified 64-bit integer to string.
FromSByte | Converts the specified 8-bit signed integer to string.
FromSingle | Overloaded.
FromStream | Converts the specified stream to string.
FromStreamV4 | Converts the specified memory stream to string.
FromUInt16 | Converts the specified unsigned 16-bit integer value to string.
FromUInt32 | Converts the specified unsigned 32-bit integer value to string.
FromUInt64 | Converts the specified unsigned 64-bit integer value to string.
FromXmlElement | Deserializes a Point object from the specified XmlElement.
SaveTo | Writes the specified point to the specified XmlWriter.
ToBoolean | Converts the specified string value to bool.
ToBrush | Converts the specified string value to Brush.
ToByte | Converts the specified string value to byte value.
ToChar | Converts the specified string value to char.
ToColor | Converts the specified string value to Color.
ToDecimal | Converts the specified string value to decimal.
ToDouble | Converts the specifed string value to double.
ToEnum | Converts the specified string value to its corresponding enumeration member of the specified type.
ToImage | Converts the specified string value to image.
ToInt16 | Converts the specified string value to 16-bit integer.
ToInt32 | Overloaded.
ToInt64 | Converts the specified string value to 64-bit integer.
ToSByte | Converts the specified string value to 8-bit signed integer.
ToSingle | Converts the specified string value to float.
ToStream | Converts the specified string value to stream.
ToStreamV4 | Converts the specified string value to stream.
ToUint16 | Converts the specified string value to unsigned 16-bit integer.
ToUint32 | Converts the specified string value to unsigned 32-bit integer.
ToUint64 | Converts the specified string value to unsigned 64-bit integer.

See Also

Converter Class


MindFusion.Diagramming.Converter.FromBoolean Method

Converter.FromBoolean Method
[image]

Converts the specified bool value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromBoolean (
bool val
)

Visual Basic [image] Copy Code

Public Shared Function FromBoolean( _
val As Boolean _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromByte Method

Converter.FromByte Method
[image]

Converts the specified byte value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromByte (
byte val
)

Visual Basic [image] Copy Code

Public Shared Function FromByte( _
val As Byte _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromChar Method

Converter.FromChar Method
[image]

Converts the specified char value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromChar (
char val
)

Visual Basic [image] Copy Code

Public Shared Function FromChar( _
val As Char _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromColor Method

Converter.FromColor Method
[image]

Converts the specified color value to string in the format #AARRGGBB.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromColor (
Color val
)

Visual Basic [image] Copy Code

Public Shared Function FromColor( _
val As Color _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromDecimal Method

Converter.FromDecimal Method
[image]

Converts the specified decimal to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromDecimal (
decimal val
)

Visual Basic [image] Copy Code

Public Shared Function FromDecimal( _
val As Decimal _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromDouble Method

Converter.FromDouble Method
[image]

Converts the specified double value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromDouble (
double val
)

Visual Basic [image] Copy Code

Public Shared Function FromDouble( _
val As Double _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromEnum Method

Converter.FromEnum Method
[image]

Converts the specified enum value to a string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromEnum (
Object val
)

Visual Basic [image] Copy Code

Public Shared Function FromEnum( _
val As Object _
) As String

Parameters

val

The value to convert.

Return Value

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromInt16 Method

Converter.FromInt16 Method
[image]

Converts the specified 16-bit integer value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromInt16 (
short val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt16( _
val As Short _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromInt32 Method

Converter.FromInt32 Method
[image]

Converts the specified 32-bit integer value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromInt32 (
int val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt32( _
val As Integer _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromInt64 Method

Converter.FromInt64 Method
[image]

Converts the specified 64-bit integer to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromInt64 (
long val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt64( _
val As Long _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromSByte Method

Converter.FromSByte Method
[image]

Converts the specified 8-bit signed integer to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromSByte (
sbyte val
)

Visual Basic [image] Copy Code

Public Shared Function FromSByte( _
val As SByte _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromSingle Method

Converter.FromSingle Method
[image]

Overload List

Name | Description
Converter.FromSingle (Double) | Converts the specified double value to string.
Converter.FromSingle (Single) | Converts the specified float value to string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromSingle Method (Double)

Converter.FromSingle Method (Double)
See Also
[image]

Converts the specified double value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromSingle (
double val
)

Visual Basic [image] Copy Code

Public Shared Function FromSingle( _
val As Double _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

FromSingle Method Overload List
Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromSingle Method (Single)

Converter.FromSingle Method (Single)
See Also
[image]

Converts the specified float value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromSingle (
float val
)

Visual Basic [image] Copy Code

Public Shared Function FromSingle( _
val As Single _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

FromSingle Method Overload List
Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromStream Method

Converter.FromStream Method
[image]

Converts the specified stream to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromStream (
Stream val
)

Visual Basic [image] Copy Code

Public Shared Function FromStream( _
val As Stream _
) As String

Parameters

val

The Stream object to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromStreamV4 Method

Converter.FromStreamV4 Method
[image]

Converts the specified memory stream to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromStreamV4 (
MemoryStream val
)

Visual Basic [image] Copy Code

Public Shared Function FromStreamV4( _
val As MemoryStream _
) As String

Parameters

val

The Stream object to convert.

Return Value

A string representing the specified value.

Remarks

This method is used in XML file format 4 and earlier.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromUInt16 Method

Converter.FromUInt16 Method
[image]

Converts the specified unsigned 16-bit integer value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromUInt16 (
ushort val
)

Visual Basic [image] Copy Code

Public Shared Function FromUInt16( _
val As UShort _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromUInt32 Method

Converter.FromUInt32 Method
[image]

Converts the specified unsigned 32-bit integer value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromUInt32 (
uint val
)

Visual Basic [image] Copy Code

Public Shared Function FromUInt32( _
val As UInteger _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromUInt64 Method

Converter.FromUInt64 Method
[image]

Converts the specified unsigned 64-bit integer value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromUInt64 (
ulong val
)

Visual Basic [image] Copy Code

Public Shared Function FromUInt64( _
val As ULong _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromXmlElement Method

Converter.FromXmlElement Method
[image]

Deserializes a Point object from the specified XmlElement.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Point FromXmlElement (
XElement point
)

Visual Basic [image] Copy Code

Public Shared Function FromXmlElement( _
point As XElement _
) As Point

Parameters

point

The XmlElement representing the serialized point.

Return Value

A Point object deserialized from the specified XmlElement.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.SaveTo Method

Converter.SaveTo Method
[image]

Writes the specified point to the specified XmlWriter.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void SaveTo (
XmlWriter w,
Point p
)

Visual Basic [image] Copy Code

Public Shared Sub SaveTo( _
w As XmlWriter, _
p As Point _
)

Parameters

w
The System.Xml.XmlWriter object to write to.
p
The Windows.UI.Xaml.Point object to be serialized.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToBoolean Method

Converter.ToBoolean Method
[image]

Converts the specified string value to bool.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static bool ToBoolean (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToBoolean( _
s As String _
) As Boolean

Parameters

s

The string value to convert from.

Return Value

A boolean value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToBrush Method

Converter.ToBrush Method
[image]

Converts the specified string value to Brush.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Brush ToBrush (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToBrush( _
s As String _
) As Brush

Parameters

s

The string value to convert from.

Return Value

An instance of the Windows.UI.Xaml.Media.Brush class.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToByte Method

Converter.ToByte Method
[image]

Converts the specified string value to byte value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static byte ToByte (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToByte( _
s As String _
) As Byte

Parameters

s

The string value to convert from.

Return Value

A byte value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToChar Method

Converter.ToChar Method
[image]

Converts the specified string value to char.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static char ToChar (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToChar( _
s As String _
) As Char

Parameters

s

The string value to convert from.

Return Value

A char value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToColor Method

Converter.ToColor Method
[image]

Converts the specified string value to Color.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Color ToColor (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToColor( _
s As String _
) As Color

Parameters

s

The string value to convert from.

Return Value

A Color value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToDecimal Method

Converter.ToDecimal Method
[image]

Converts the specified string value to decimal.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static decimal ToDecimal (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToDecimal( _
s As String _
) As Decimal

Parameters

s

The string value to convert from.

Return Value

A decimal value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToDouble Method

Converter.ToDouble Method
[image]

Converts the specifed string value to double.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double ToDouble (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToDouble( _
s As String _
) As Double

Parameters

s

The string value to convert from.

Return Value

A double value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToEnum Method

Converter.ToEnum Method
[image]

Converts the specified string value to its corresponding enumeration member of the specified type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Object ToEnum (
Type type,
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToEnum( _
type As Type, _
s As String _
) As Object

Parameters

type

The type of the enumeration to convert to.

s

The string value to convert from.

Return Value

A member of the specified enumeration that is deserialized from the specified string, possibly a null reference (Nothing in Visual Basic) if the deserialization failed.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToImage Method

Converter.ToImage Method
[image]

Converts the specified string value to image.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static ImageSource ToImage (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToImage( _
s As String _
) As ImageSource

Parameters

s

The string value to convert from.

Return Value

A .NET Image object that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToInt16 Method

Converter.ToInt16 Method
[image]

Converts the specified string value to 16-bit integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static short ToInt16 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt16( _
s As String _
) As Short

Parameters

s

The string value to convert from.

Return Value

A 16-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToInt32 Method

Converter.ToInt32 Method
[image]

Overload List

Name | Description
Converter.ToInt32 (String) | Converts the specified string value to 32-bit integer.
Converter.ToInt32 (String, Int32) | Converts the specified string value to 32-bit integer without throwing exceptions. In case the specified string cannot be converted, the specified default value is returned.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToInt32 Method (String)

Converter.ToInt32 Method (String)
See Also
[image]

Converts the specified string value to 32-bit integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static int ToInt32 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt32( _
s As String _
) As Integer

Parameters

s

The string value to convert from.

Return Value

A 32-bit integer value that is deserialized from the specified string.

See Also

ToInt32 Method Overload List
Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToInt32 Method (String, Int32)

Converter.ToInt32 Method (String, Int32)
See Also
[image]

Converts the specified string value to 32-bit integer without throwing exceptions. In case the specified string cannot be converted, the specified default value is returned.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static int ToInt32 (
string s,
int defaultValue
)

Visual Basic [image] Copy Code

Public Shared Function ToInt32( _
s As String, _
defaultValue As Integer _
) As Integer

Parameters

s

The string value to convert from.

defaultValue

The default value to return if s cannot be deserialized.

Return Value

A 32-bit integer value that is deserialized from the specified string.

See Also

ToInt32 Method Overload List
Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToInt64 Method

Converter.ToInt64 Method
[image]

Converts the specified string value to 64-bit integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static long ToInt64 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt64( _
s As String _
) As Long

Parameters

s

The string value to convert from.

Return Value

A 64-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToSByte Method

Converter.ToSByte Method
[image]

Converts the specified string value to 8-bit signed integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static sbyte ToSByte (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToSByte( _
s As String _
) As SByte

Parameters

s

The string value to convert from.

Return Value

An 8-bit signed integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToSingle Method

Converter.ToSingle Method
[image]

Converts the specified string value to float.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float ToSingle (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToSingle( _
s As String _
) As Single

Parameters

s

The string value to convert from.

Return Value

A float value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToStream Method

Converter.ToStream Method
[image]

Converts the specified string value to stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Stream ToStream (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToStream( _
s As String _
) As Stream

Parameters

s

The string value to convert from.

Return Value

A System.IO.Stream object that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToStreamV4 Method

Converter.ToStreamV4 Method
[image]

Converts the specified string value to stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Stream ToStreamV4 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToStreamV4( _
s As String _
) As Stream

Parameters

s

The string value to convert from.

Return Value

A .NET Stream object that is deserialized from the specified string.

Remarks

This method is used in XML file format 4 and earlier.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToUint16 Method

Converter.ToUint16 Method
[image]

Converts the specified string value to unsigned 16-bit integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static ushort ToUint16 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToUint16( _
s As String _
) As UShort

Parameters

s

The string value to convert from.

Return Value

An unsigned 16-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToUint32 Method

Converter.ToUint32 Method
[image]

Converts the specified string value to unsigned 32-bit integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static uint ToUint32 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToUint32( _
s As String _
) As UInteger

Parameters

s

The string value to convert from.

Return Value

An unsigned 32-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToUint64 Method

Converter.ToUint64 Method
[image]

Converts the specified string value to unsigned 64-bit integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static ulong ToUint64 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToUint64( _
s As String _
) As ULong

Parameters

s

The string value to convert from.

Return Value

Remarks

An unsigned 64-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.DashArrayConverter Class

DashArrayConverter Class
[image]

Used to clone DoubleCollection instances when implementing StrokeDashArray in control templates, since DoubleCollections cannot be shared between controls.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DashArrayConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class DashArrayConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DashArrayConverter

See Also

DashArrayConverter Members


MindFusion.Diagramming.DashArrayConverter Members

DashArrayConverter Members
Constructors Methods
[image]

Used to clone DoubleCollection instances when implementing StrokeDashArray in control templates, since DoubleCollections cannot be shared between controls.

The following tables list the members exposed by the DashArrayConverter type.

Public Constructors

Name | Description
DashArrayConverter | Initializes a new instance of the DashArrayConverter class.

Public Methods

Name | Description
Convert | Clones the specified DoubleCollection instance.
ConvertBack | Not implemented.

See Also

DashArrayConverter Class


MindFusion.Diagramming.DashArrayConverter Constructor

DashArrayConverter Constructor
[image]

Initializes a new instance of the DashArrayConverter class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DashArrayConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DashArrayConverter Class


MindFusion.Diagramming.DashArrayConverter Methods

DashArrayConverter Methods
[image]

Public Methods

Name | Description
Convert | Clones the specified DoubleCollection instance.
ConvertBack | Not implemented.

See Also

DashArrayConverter Class


MindFusion.Diagramming.DashArrayConverter.Convert Method

DashArrayConverter.Convert Method
[image]

Clones the specified DoubleCollection instance.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo l
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
l As CultureInfo _
) As Object

Parameters

value

targetType

parameter

l

Return Value

See Also

DashArrayConverter Members
DashArrayConverter Class


MindFusion.Diagramming.DashArrayConverter.ConvertBack Method

DashArrayConverter.ConvertBack Method
[image]

Not implemented.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo l
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
l As CultureInfo _
) As Object

Parameters

value

targetType

parameter

l

Return Value

See Also

DashArrayConverter Members
DashArrayConverter Class


MindFusion.Diagramming.DashStyle Class

DashStyle Class
[image]

Defines the dash style of a Pen.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DashStyle

Visual Basic [image] Copy Code

Public Class DashStyle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DashStyle

See Also

DashStyle Members


MindFusion.Diagramming.DashStyle Members

DashStyle Members
Constructors Properties Methods
[image]

Defines the dash style of a Pen.

The following tables list the members exposed by the DashStyle type.

Public Constructors

Name | Description
DashStyle | Overloaded.

Public Properties

Name | Description
Dashes | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline shapes.
Offset | Gets or sets the distance from the start of a line to the beginning of a dash pattern.

Public Methods

Name | Description
Clone | Creates an exact copy of this pen.

See Also

DashStyle Class


MindFusion.Diagramming.DashStyle Constructor

DashStyle Constructor
[image]

Overload List

Name | Description
DashStyle () | Initializes a new instance of the DashStyle class.
DashStyle (DoubleCollection, Double) | Initializes a new instance of the DashStyle class.

See Also

DashStyle Class


MindFusion.Diagramming.DashStyle Constructor ()

DashStyle Constructor ()
See Also
[image]

Initializes a new instance of the DashStyle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DashStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DashStyle Constructor Overload List
DashStyle Class


MindFusion.Diagramming.DashStyle Constructor (DoubleCollection, Double)

DashStyle Constructor (DoubleCollection, Double)
See Also
[image]

Initializes a new instance of the DashStyle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DashStyle (
DoubleCollection dashes,
double offset
)

Visual Basic [image] Copy Code

Public New ( _
dashes As DoubleCollection, _
offset As Double _
)

Parameters

dashes

offset

See Also

DashStyle Constructor Overload List
DashStyle Class


MindFusion.Diagramming.DashStyle Methods

DashStyle Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this pen.

See Also

DashStyle Class


MindFusion.Diagramming.DashStyle.Clone Method

DashStyle.Clone Method
[image]

Creates an exact copy of this pen.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DashStyle Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As DashStyle

Return Value

An instance of the Pen class.

See Also

DashStyle Members
DashStyle Class


MindFusion.Diagramming.DashStyle Properties

DashStyle Properties
[image]

Public Properties

Name | Description
Dashes | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline shapes.
Offset | Gets or sets the distance from the start of a line to the beginning of a dash pattern.

See Also

DashStyle Class


MindFusion.Diagramming.DashStyle.Dashes Property

DashStyle.Dashes Property
[image]

Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline shapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DoubleCollection Dashes { get; set; }

Visual Basic [image] Copy Code

Public Property Dashes As DoubleCollection

Property Value

See Also

DashStyle Members
DashStyle Class


MindFusion.Diagramming.DashStyle.Offset Property

DashStyle.Offset Property
[image]

Gets or sets the distance from the start of a line to the beginning of a dash pattern.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Offset { get; set; }

Visual Basic [image] Copy Code

Public Property Offset As Double

Property Value

See Also

DashStyle Members
DashStyle Class


MindFusion.Diagramming.DashStyles Class

DashStyles Class
[image]

Provides several stock pen dash styles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DashStyles

Visual Basic [image] Copy Code

Public Class DashStyles

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DashStyles

See Also

DashStyles Members


MindFusion.Diagramming.DashStyles Members

DashStyles Members
Constructors Properties
[image]

Provides several stock pen dash styles.

The following tables list the members exposed by the DashStyles type.

Public Constructors

Name | Description
DashStyles |

Public Properties

Name | Description
Dash | Gets a DashStyle object that draws dashed lines.
DashDot | Gets a DashStyle object that draws lines with a dash-dot pattern.
DashDotDot | Gets a DashStyle object that draws lines with a dash-dot-dot pattern.
Dot | Gets a DashStyle object that draws dotted lines.
Solid | Gets a DashStyle object that draws solid lines.

See Also

DashStyles Class


MindFusion.Diagramming.DashStyles Constructor

DashStyles Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DashStyles ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DashStyles Class


MindFusion.Diagramming.DashStyles Properties

DashStyles Properties
[image]

Public Properties

Name | Description
Dash | Gets a DashStyle object that draws dashed lines.
DashDot | Gets a DashStyle object that draws lines with a dash-dot pattern.
DashDotDot | Gets a DashStyle object that draws lines with a dash-dot-dot pattern.
Dot | Gets a DashStyle object that draws dotted lines.
Solid | Gets a DashStyle object that draws solid lines.

See Also

DashStyles Class


MindFusion.Diagramming.DashStyles.Dash Property

DashStyles.Dash Property
[image]

Gets a DashStyle object that draws dashed lines.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static DashStyle Dash { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Dash As DashStyle

Property Value

See Also

DashStyles Members
DashStyles Class


MindFusion.Diagramming.DashStyles.DashDot Property

DashStyles.DashDot Property
[image]

Gets a DashStyle object that draws lines with a dash-dot pattern.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static DashStyle DashDot { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DashDot As DashStyle

Property Value

See Also

DashStyles Members
DashStyles Class


MindFusion.Diagramming.DashStyles.DashDotDot Property

DashStyles.DashDotDot Property
[image]

Gets a DashStyle object that draws lines with a dash-dot-dot pattern.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static DashStyle DashDotDot { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DashDotDot As DashStyle

Property Value

See Also

DashStyles Members
DashStyles Class


MindFusion.Diagramming.DashStyles.Dot Property

DashStyles.Dot Property
[image]

Gets a DashStyle object that draws dotted lines.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static DashStyle Dot { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Dot As DashStyle

Property Value

See Also

DashStyles Members
DashStyles Class


MindFusion.Diagramming.DashStyles.Solid Property

DashStyles.Solid Property
[image]

Gets a DashStyle object that draws solid lines.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static DashStyle Solid { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Solid As DashStyle

Property Value

See Also

DashStyles Members
DashStyles Class


MindFusion.Diagramming.DelKeyAction Enumeration

DelKeyAction Enumeration
[image]

Specifies the type of action performed when the user presses the DEL key.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum DelKeyAction

Visual Basic [image] Copy Code

Public Enum DelKeyAction

Members

Member name | Description
DeleteActiveItem | Indicates that only the ActiveItem is deleted.
DeleteSelectedItems | Indicates that all selected items are deleted.
None | Indicates that nothing happens.

Remarks

Members of this enumeration can be assigned to the DelKeyAction property of Diagram.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.Diagram Class

Diagram Class
Remarks See Also
[image]

The Diagram class represents a flow diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Diagram : DiagramBase

Visual Basic [image] Copy Code

Public Class Diagram
Inherits DiagramBase

Remarks

A diagram can contain connected nodes and links. Nodes are instances of DiagramNode-derived classes. Nodes are stored in the Nodes collection. Links in MindFusion.Diagramming are instances of the DiagramLink class and are stored in the Links collection.

Managing Items

Items can be created by using the new operator and added to the diagram by means of the Add method of the Nodes or Links collection. Items are deleted by using the Remove method of the respective collection. There are shortcut methods provided by the diagram's Factory object that can be used to create an item and add it to the diagram with just one method call. Use the CreateTableNode, CreateShapeNode and CreateDiagramLink factory methods to create new items of the respective type.

Serialization

Use the SaveToXml and LoadFromXml methods to serialize a diagram into/from XML documents on disk on in memory. Handle SerializeTag and DeserializeTag to implement serialization of custom data assigned to the Tag property of items.

Controlling Users' Actions

The Behavior property specifies how the control responds to user actions with the mouse. To use a custom behavior class, set the CustomBehavior property.

Users actions can be validated by handling various events, fired while items are being created, modified or deleted.

The following properties control whether the user is allowed to do some kinds of actions: AllowInplaceEdit, AllowMultipleResize, AllowUnconnectedLinks.

The order in which items are hit-tested when clicking on them depends on the value of HitTestPriority.

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
Windows.UI.Xaml.Controls.ContentControl
MindFusion.Diagramming.DiagramBase
MindFusion.Diagramming.Diagram
MindFusion.Diagramming.DiagramPage
MindFusion.Diagramming.VirtualizingDiagram

See Also

Diagram Members


MindFusion.Diagramming.Diagram Members

Diagram Members
Constructors Fields Properties Methods Events
[image]

The Diagram class represents a flow diagram.

The following tables list the members exposed by the Diagram type.

Public Constructors

Name | Description
Diagram | Initializes a new instance of the Diagram class.

Public Fields

Name | Description
AdjustmentHandlesSizeProperty | Identifies the AdjustmentHandlesSize dependency property.
AlignmentGuidePenProperty | Identifies the AlignmentGuidePen dependency property.
AllowMultipleResizeProperty | Identifies the AllowMultipleResize dependency property.
AllowUnconnectedLinksProperty | Identifies the AllowUnconnectedLinks dependency property.
AutoScrollProperty | Identifies the AutoScroll dependency property.
CanRedoProperty | Identifies the CanRedo dependency property.
CanUndoProperty | Identifies the CanUndo dependency property.
ContainerNodeStyleProperty | Identifies the ContainerNodeStyle dependency property.
DiagramLinkStyleProperty | Identifies the DiagramLinkStyle dependency property.
Dummy | A shared DummyNode instance.
EnableLanesProperty | Identifies the EnableLanes dependency property.
ExpandButtonTemplateProperty | Identifies the ExpandButtonTemplate dependancy property.
GridDashArrayProperty | Identifies the GridDashArray dependency property.
GridPointSizeProperty | Identifies the GridPointSize dependency property.
NodeEffectsSourceProperty | Identifies the NodeEffectsSource dependency property.
ShapeNodeStyleProperty | Identifies the ShapeNodeStyle dependency property.
TableNodeStyleProperty | Identifies the TableNodeStyle dependency property.
TreeViewNodeStyleProperty | Identifeis the TreeViewNodeStyle dependency property.
ZoomFactorProperty | Identifies the ZoomFactor property.

Public Properties

Name | Description
ActiveItem | Gets or sets the active diagram element.
ActiveItemHandlesStyle | Gets or sets the visual style of adjustment handles of the active item.
ActiveLayer | Gets or sets the zero-based index of the active layer.
AdjustmentHandlesSize | Gets or sets the size of the handles, which appear around selected objects. This is a dependency property.
AlignmentGuidePen | Gets or sets the pen used to draw alignment guides. This is a dependency property.
AlignToGrid | Gets or sets a value indicating whether the diagram items should be aligned to a grid.
AllowInplaceEdit | Gets or sets a value indicating whether in-place editing of the text of objects is enabled.
AllowMultipleResize | Specifies whether multiple selected nodes can be resized simultaneously. This is a dependency property.
AllowUnconnectedLinks | Gets or sets a value indicating whether users are allowed to draw links that are not connected to any node. This is a dependency property.
AutoAlignDistance | Gets or sets the maximal horizontal or vertical distance at which a node aligns to the borders ot other nodes.
AutoAlignNodes | Gets or sets whether nodes should automatically align to the borders ot other nodes during user interaction.
AutoResize | Gets or sets a value indicating whether the document area should be resized automatically so it fits the diagram contents.
AutoScroll | Gets or sets a value indicating whether auto scrolling of the document area is enabled. This is a dependency property.
AutoSnapDistance | Specifies the maximum distance at which links auto-snap to nodes.
AutoSnapLinks | Specifies whether link end points should automatically snap to the nearest diagram node.
BackBrush | Gets or sets the brush used for painting the diagram background.
Behavior | Gets or sets a value indicating how the control responds to user actions.
Bounds | Gets or sets a value representing the size of the diagram's scrollable area.
CanRedo | Gets or sets a value indicating whether there is a command in the redo history which can be redone.
CanUndo | Gets or sets a value indicating whether there is a command in the undo history which can be undone.
ContainerNodeStyle | Gets or sets the theme-level style for container nodes. This is a dependency property.
ContainersFoldable | Gets or sets the default value for the Foldable property of containers.
CrossingRadius | Gets or sets the radius length of decorations displayed at link intersection points.
CustomBehavior | Gets or sets a custom behavior object specifying how DiagramRT responds to mouse input.
DefaultControlType | Gets or sets the type of the controls that will be hosted by default in newly create ControlNode objects.
DefaultShape | Gets or sets the default shape of shape nodes.
DelKeyAction | Gets or sets a value that specifies what action should be performed when the user hits the Del key.
DiagramLinkStyle | Gets or sets the theme-level style for diagram links. This is a dependency property.
DisabledHandlesStyle | Gets or sets the visual style of disabled adjustment handles.
DocumentPlane | DocumentPlane is visual child of diagram and ancestor of all diagram items. The DocumentPlane element is translated with respect to Diagram element so that the point Diagram.Bounds.TopLeft from the DocumentPlane is rendered at Diagram element location (0,0). The coordinate system of the DocumentPlane is the document coordinate system. The intended use of this property is mainly in MouseMove event handling
DynamicLinks | Gets or sets the default value for the Dynamic property of new links.
Enabled | Enables or disables handling of mouse events.
EnableLanes | Gets or sets whether lanes are enabled. This is a dependency property.
ExpandButtonAction | Gets or sets a value indicating what should happen when a user clicks the [+/-] button that is displayed near expandable nodes.
ExpandButtonBrush | Gets or sets the brush used to fill expand/collapse buttons of nodes.
ExpandButtonPosition | Gets or sets where expand/collapse buttons are located relatively to their nodes.
ExpandButtonTemplate | Gets or sets a custom ControlTemplate for the ExpandButton class.
ExpandOnIncoming | Gets or sets a value, indicating in which direction object hierarchies are expanded.
Factory | Gets a Factory instance that lets you add programmatically new items to the diagram.
GridColor | Gets or sets the color of the grid points.
GridDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to draw grid lines. This is a dependency property.
GridOffsetX | Gets or sets the horizontal offset of the first point of the alignment grid.
GridOffsetY | Gets or sets the vertical offset of the first point of the alignment grid.
GridPointSize | Gets or sets the size of shapes used to represent grid points. This is a dependency property.
GridSizeX | Gets or sets the horizontal distance between adjacent grid points.
GridSizeY | Gets or sets the vertical distance between adjacent grid points.
GridStyle | Gets or sets the visual style of the alignment grid.
HitTestPriority | Gets or sets a value indicating the order in which items are hit-tested.
InplaceEditAcceptOnEnter | Gets or sets a value indicating whether pressing the ENTER key should exit in-place editing mode and accept changes made to text.
InplaceEditCancelOnEsc | Gets or sets a value indicating whether pressing the ESC key should exit inplace-edit mode and reject changes made to text.
Interaction | Gets an InteractionState instance representing the current action being carried out by the user.
Items | Represents a strongly typed collection of DiagramItem objects.
LaneGrid | Gets the Grid instance that represents the lane grid.
Layers | Gets a list of the layers in the current diagram.
LicenseKey | Gets or sets the license key of the control.
LinkBaseShape | Gets or sets the shape displayed at the base of new links.
LinkBaseShapeSize | Gets or sets the default size of the base of new links.
LinkBrush | Gets or sets the default value for the Brush property of links.
LinkCrossings | Gets or sets how to render the intersection points where links cross their paths.
LinkHeadShape | Gets or sets the shape displayed as head of new links.
LinkHeadShapeSize | Gets or sets the default size of arrowheads.
LinkIntermediateShape | Gets or sets default shape to be displayed in the middle of each segment of links.
LinkIntermediateShapeSize | Gets or sets the default size of the shapes at middles of link segments.
LinkPen | Gets or sets the default value for the Pen property of links.
LinkRouter | Gets or sets the component used to find paths for auto-routed links when diagram nodes are added or their positions change.
Links | Gets a DiagramLinkCollection containing the links.
LinkSegments | Gets or sets the default number of link segments.
LinkShape | Gets or sets the default style of diagram links.
MeasureUnit | Gets or sets the unit of measure used for logical coordinates in this diagram.
ModificationStart | Gets or sets how users can start modifying diagram items.
NodeEffects | Gets a collection with all effects applied to the nodes of this diagram.
Nodes | Gets a DiagramNodeCollection containing the nodes.
NodesExpandable | Gets or sets a value indicating whether newly created nodes can be expanded.
OverrideCursor | Sets the cursor and stops changing it depending on the context.
PrintOptions | Gets an object which provides customization properties for printed diagrams.
RecursiveExpand | Gets or sets value indicating how a tree is expanded.
RoundedLinks | Gets or sets a value indicating whether the joins between segments of Polyline and Cascading links should be rounded.
RoundedLinksRadius | Gets or sets the radius of arc joins of rounded links' segments.
RouteLinks | Gets or sets a value indicating whether links should avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes.
RoutingOptions | Gets an object, which allows customizing various parameters of the link routing algorithm.
ScrollX | Gets or sets the document's X scroll position.
ScrollY | Gets or sets the document's Y scroll position.
ScrollZoneSize | Gets or sets the size of the auto scroll zone near the edges of the control.
SelectedItemHandlesStyle | Gets or sets the visual style of adjustment handles of selected items.
Selection | Gets the Selection instance that represents the selection of items in this diagram.
ShapeBrush | Gets or sets the default value for the Brush property of shape nodes.
ShapeHandlesStyle | Gets or sets the default value for the HandlesStyle property of new shape nodes.
ShapeNodeStyle | Gets or sets the theme-level style for shape nodes. This is a dependency property.
ShapePen | Gets or sets the default value for the Pen property of new ShapeNode objects.
ShowAnchors | Gets or sets a value indicating whether and when node anchor points should be displayed.
ShowGrid | Gets or sets a value indicating whether the alignment grid is visible.
TableBrush | Gets or sets the default value for the Brush property of tables.
TableCaption | Gets or sets the default text for tables' captions.
TableCaptionHeight | Gets or sets the default height of table captions.
TableColumnCount | Gets or sets the default number of table columns.
TableColumnWidth | Gets or sets the default width of tables' columns.
TableNodeStyle | Gets or sets the theme-level style for table nodes. This is a dependency property.
TableRowCount | Gets or sets the default number of table rows.
TableRowHeight | Gets or sets the default height of tables' rows.
Theme | Gets or sets the theme associated with the diagram.
TreeViewNodeStyle | Gets or sets the theme-level style for treeview nodes. This is a dependency property.
UndoEnabled | Gets or sets a value indicating whether saving action records for later undo is enabled.
Viewport | Returns the visible portion of the diagram area.
ZoomFactor | Gets or sets the zoom factor used to scale up or down the Diagram.

Public Methods

Name | Description
AlignPointToGrid | Returns a point of the alignment grid nearest to the one passed as an argument.
ArrangeLinkLabels | Rearranges link labels whose AutoArrange property is enabled.
BeginEdit | Overloaded.
CancelCompositeOperation | Stops recording undo/redo commands into a CompositeCommand and discards the records created so far.
CancelDrag | Cancels the current drag operation.
ChangeUnit | Sets new MeasureUnit value and scales the coordinates of diagram items so that their absolute size remains unchanged.
ClearAll | Removes all items from the diagram.
CommitCompositeOperation | Stops recording undo/redo commands into a CompositeCommand and saves the composite in the history queue.
CopySelection | Creates a copy of the currently selected objects and groups.
CreateThemeFromDefaults | Creates a Theme object representing the default properties of the diagram.
EndDelayUpdate | Continue updating the visual state of items.
EndEdit | Exits the in-place editing mode and either accepts or rejects the changes made to the item's text.
ExecuteCommand | Executes the specified command on this diagram.
FindLinkById | Finds the link that has the specified id value.
FindNodeById | Finds the node that has the specified id value.
GetContentBounds | Returns the smallest rectangle that bounds all diagram objects.
GetItemAt | Overloaded.
GetLinkAt | Overloaded. Finds and returns the top-most link that lies at the specified location.
GetNearestNode | Returns the node nearest to the specified point.
GetNodeAt | Overloaded.
GetNodesInViewport | Returns all nodes visible in the current viewport.
HitTestManipulators | Tests whether the specified point is within the manipulator of a diagram object and triggers the manipulator.
Invalidate | Causes the entire visible diagram area to be repainted.
IsItemInteractive | Checks if the specified item can be modified interactively.
IsItemLocked | Checks if the specified item is locked.
IsItemVisible | Checks if the specified item is currently visible.
LoadFromString | Decodes diagram contents from a string that was created with SaveToString.
LoadFromXml | Overloaded.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
PasteSelection | Adds the specified items and groups to this diagram.
RaiseClicked | Raises the Clicked event.
RaiseClicked | Raises the appropriate *Clicked event according to the type of the specified item.
RaiseCreated | Raises the appropriate *Created event according to the type of the specified item.
RaiseDeleting | Raises the LinkDeleting or NodeDeleting event according to the type of the specified item.
RaiseDoubleClicked | Overloaded.
RaiseLinkTextEdited | Raises the LinkTextEdited event.
RaiseNodeTextEdited | Raises the NodeTextEdited event.
RaisePasted | Raises the appropriate Pasted event.
Redo | Executes again an action saved in the command history.
RegisterClass | Registers a class for serialization support.
RegisterItemClass | Registers a diagram item class for serialization support.
ResizeToFitItem | Resizes the document extents so that the specified item is contained within.
ResizeToFitItems | Overloaded. Resizes the document scrollable area so it fits all diagram items.
RouteAllLinks | Routes all links in the diagram in a way they do not cross nodes.
SaveToString | Returns a serialized form of the diagram as string
SaveToXml | Overloaded.
SetScrollerParent | Binds the lane-grid header positions to the offset of a ScrollViewer's scrollbars.
SetZoomFactor | Sets the zoom factor, preserving the on-screen position of the specified diagram point.
StartCompositeOperation | Starts recording undo/redo commands into a CompositeCommand.
StartDelayUpdate | Stops updating the visual state of items.
StartInteraction | Overloaded.
Undo | Undoes an action saved in the command history.
UpdateRuntimeIndices | For internal use.
UpdateVisualZIndices | For internal use.
ZoomToRect | Zooms and scrolls the view to fit the specified document rectangle in the Diagram's visible area.

Protected Methods

Name | Description
ArrangeOverride | FrameworkElement.ArrangeOverride override.
OnMouseRightButtonDown | Control.OnMouseRightButtonDown override.
OnMouseRightButtonUp | Control.OnMouseRightButtonUp override.
RemoveItem | Removes the specified item from the diagram and creates a record in the undo/redo history.

Inherited Protected Methods

Name | Description
OnActionRedone | Raises the ActionRedone event. (Inherited from DiagramBase.)
OnActionUndone | Raises the ActionUndone event. (Inherited from DiagramBase.)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramBase.)
OnCellClicked | Raises the CellClicked event. (Inherited from DiagramBase.)
OnCellDoubleClicked | Raises the CellDoubleClicked event. (Inherited from DiagramBase.)
OnClicked | Raises the Clicked event. (Inherited from DiagramBase.)
OnContainerChildAdded | Raises the ContainerChildAdded event. (Inherited from DiagramBase.)
OnContainerChildRemoved | Raises the ContainerChildRemoved event. (Inherited from DiagramBase.)
OnContainerFolded | Raises the ContainerFolded event. (Inherited from DiagramBase.)
OnContainerUnfolded | Raises the ContainerUnfolded event. (Inherited from DiagramBase.)
OnDeserializeControl | Raises the DeserializeControl event. (Inherited from DiagramBase.)
OnDeserializeTag | Raises the DeserializeTag event. (Inherited from DiagramBase.)
OnDoubleClicked | Raises the DoubleClicked event. (Inherited from DiagramBase.)
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event. (Inherited from DiagramBase.)
OnEnterInplaceEditMode | Raises the EnterInplaceEditMode event. (Inherited from DiagramBase.)
OnExpandButtonClicked | Raises the ExpandButtonClicked event. (Inherited from DiagramBase.)
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event. (Inherited from DiagramBase.)
OnInitializeLink | Raises the InitializeLink event. (Inherited from DiagramBase.)
OnInitializeNode | Raises the InitializeNode event. (Inherited from DiagramBase.)
OnItemAdded | Raises the ItemAdded event. (Inherited from DiagramBase.)
OnItemRemoved | Raises the ItemRemoved event. (Inherited from DiagramBase.)
OnLaneGridCellCreated | Raises the LaneGridCellCreated event. (Inherited from DiagramBase.)
OnLaneGridHeaderCreated | Raises the LaneGridHeaderCreated event. (Inherited from DiagramBase.)
OnLeaveInplaceEditMode | Raises the LeaveInplaceEditMode event. (Inherited from DiagramBase.)
OnLinkActivated | Raises the LinkActivated event. (Inherited from DiagramBase.)
OnLinkClicked | Raises the LinkClicked event. (Inherited from DiagramBase.)
OnLinkCreated | Raises the LinkCreated event. (Inherited from DiagramBase.)
OnLinkCreating | Raises the LinkCreating event. (Inherited from DiagramBase.)
OnLinkDeactivated | Raises the LinkDeactivated event. (Inherited from DiagramBase.)
OnLinkDeleted | Raises the LinkDeleted event. (Inherited from DiagramBase.)
OnLinkDeleting | Raises the LinkDeleting event. (Inherited from DiagramBase.)
OnLinkDeselected | Raises the LinkDeselected event. (Inherited from DiagramBase.)
OnLinkDoubleClicked | Raises the LinkDoubleClicked event. (Inherited from DiagramBase.)
OnLinkModified | Raises the LinkModified event. (Inherited from DiagramBase.)
OnLinkModifying | Raises the LinkModifying event. (Inherited from DiagramBase.)
OnLinkPasted | Raises the LinkPasted event. (Inherited from DiagramBase.)
OnLinkRouted | Raises the LinkRouted event. (Inherited from DiagramBase.)
OnLinkSelected | Raises the LinkSelected event. (Inherited from DiagramBase.)
OnLinkTextEdited | Raises the LinkTextEdited event. (Inherited from DiagramBase.)
OnMagnifierFactorChanged | Raises the MagnifierFactorChanged event. (Inherited from DiagramBase.)
OnMeasureUnitChanged | Raises the MeasureUnitChanged event. (Inherited from DiagramBase.)
OnNodeActivated | Raises the NodeActivated event. (Inherited from DiagramBase.)
OnNodeClicked | Raises the NodeClicked event. (Inherited from DiagramBase.)
OnNodeCreated | Raises the NodeCreated event. (Inherited from DiagramBase.)
OnNodeCreating | Raises the NodeCreating event. (Inherited from DiagramBase.)
OnNodeDeactivated | Raises the NodeDeactivated event. (Inherited from DiagramBase.)
OnNodeDeleted | Raises the NodeDeleted event. (Inherited from DiagramBase.)
OnNodeDeleting | Raises the NodeDeleting event. (Inherited from DiagramBase.)
OnNodeDeselected | Raises the NodeDeselected event. (Inherited from DiagramBase.)
OnNodeDoubleClicked | Raises the NodeDoubleClicked event. (Inherited from DiagramBase.)
OnNodeModified | Raises the NodeModified event. (Inherited from DiagramBase.)
OnNodeModifying | Raises the NodeModifying event. (Inherited from DiagramBase.)
OnNodePasted | Raises the NodePasted event. (Inherited from DiagramBase.)
OnNodeSelected | Raises the NodeSelected event. (Inherited from DiagramBase.)
OnNodeTextEdited | Raises the NodeTextEdited event. (Inherited from DiagramBase.)
OnRepaint | Raises the Repaint event. (Inherited from DiagramBase.)
OnSelectionChanged | Raises the SelectionChanged event. (Inherited from DiagramBase.)
OnSelectionModified | Raises the SelectionModified event. (Inherited from DiagramBase.)
OnSelectionModifying | Raises the SelectionModifying event. (Inherited from DiagramBase.)
OnSerializeControl | Raises the SerializeControl event. (Inherited from DiagramBase.)
OnSerializeTag | Raises the SerializeTag event. (Inherited from DiagramBase.)
OnSetSelfLoopShape | Raises the SetSelfLoopShape event. (Inherited from DiagramBase.)
OnTreeCollapsed | Raises the TreeCollapsed event. (Inherited from DiagramBase.)
OnTreeExpanded | Raises the TreeExpanded event. (Inherited from DiagramBase.)
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event. (Inherited from DiagramBase.)
OnZoomFactorChanged | Raises the ZoomFactorChanged event. (Inherited from DiagramBase.)

Inherited Public Events

Name | Description
ActionRedone | Raised when an action is redone. (Inherited from DiagramBase.)
ActionUndone | Raised when an action is undone. (Inherited from DiagramBase.)
ActiveLayerChanged | Raised when the diagram's active layer has changed. (Inherited from DiagramBase.)
BoundsChanged | Raised when the Bounds property value has changed. (Inherited from DiagramBase.)
CellClicked | Raised when the user clicks a table's cell. (Inherited from DiagramBase.)
CellDoubleClicked | Raised when the user double-clicks a table's cell. (Inherited from DiagramBase.)
Clicked | Raised when the user clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area. (Inherited from DiagramBase.)
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area. (Inherited from DiagramBase.)
DeserializeControl | Lets you load the attributes of controls hosted inside ControlNodes. (Inherited from DiagramBase.)
DeserializeTag | Raised when the Tag or Id of a diagram item must be deserialized from XML format. (Inherited from DiagramBase.)
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
DrawAdjustmentHandles | Raised when item's adjustment handles must be custom drawn. (Inherited from DiagramBase.)
EnterInplaceEditMode | Raised when entering inplace-edit mode. (Inherited from DiagramBase.)
ExpandButtonClicked | Raised when the user clicks the [+/-] button of an Expandable node. (Inherited from DiagramBase.)
HitTestAdjustmentHandles | Raised when custom hit testing of item's adjustment handles must be performed. (Inherited from DiagramBase.)
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created. (Inherited from DiagramBase.)
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created. (Inherited from DiagramBase.)
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
LaneGridCellCreated | Raised when a lane grid's cell has been created to allow additional cusomtization of its presentation. (Inherited from DiagramBase.)
LaneGridHeaderCreated | Raised when a lane grid's header has been created to allow additional cusomtization of its presentation. (Inherited from DiagramBase.)
LeaveInplaceEditMode | Raised when leaving inplace-edit mode. (Inherited from DiagramBase.)
LinkActivated | Raised when a link becomes the ActiveItem. (Inherited from DiagramBase.)
LinkClicked | Raised when the user clicks a link. (Inherited from DiagramBase.)
LinkCreated | Raised when the user draws a new link. (Inherited from DiagramBase.)
LinkCreating | A validation event raised while the user is drawing a new link. (Inherited from DiagramBase.)
LinkDeactivated | Raised when a link is no longer the ActiveItem. (Inherited from DiagramBase.)
LinkDeleted | Raised when a link is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkDeselected | Raised when a link is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDoubleClicked | Raised when the user double-clicks a link. (Inherited from DiagramBase.)
LinkModified | Raised when the user moves any control point of a link. (Inherited from DiagramBase.)
LinkModifying | A validation event raised while the user is modifying a link. (Inherited from DiagramBase.)
LinkPasted | Raised when a link has been pasted from the clipboard. (Inherited from DiagramBase.)
LinkRouted | Raised when a link is routed by the auto-routing algorithm. (Inherited from DiagramBase.)
LinkSelected | Raised when a link is selected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkTextEdited | Raised when the user edits the text of a link. (Inherited from DiagramBase.)
MagnifierFactorChanged | Occurs when the magnifier factor changes. (Inherited from DiagramBase.)
MeasureUnitChanged | Raised when the MeasureUnit property value has changed. (Inherited from DiagramBase.)
NodeActivated | Raised when a node becomes the ActiveItem. (Inherited from DiagramBase.)
NodeClicked | Raised when the user clicks a node. (Inherited from DiagramBase.)
NodeCreated | Occurs when the user draws a new node. (Inherited from DiagramBase.)
NodeCreating | A validation event raised while the user is drawing a new node. (Inherited from DiagramBase.)
NodeDeactivated | Raised when a node is no longer the ActiveItem. (Inherited from DiagramBase.)
NodeDeleted | Raised when a node is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeDeselected | Raised when a node is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDoubleClicked | Raised when the user double-clicks a node. (Inherited from DiagramBase.)
NodeModified | Raised when the user moves or resizes a node. (Inherited from DiagramBase.)
NodeModifying | A validation event raised while the user is moving or resizing a node. (Inherited from DiagramBase.)
NodePasted | Raised when a node has been pasted from the clipboard. (Inherited from DiagramBase.)
NodeSelected | Raised when a node is selected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeTextEdited | Raised when the user edits the text of a node. (Inherited from DiagramBase.)
Repaint | Raised when the diagram views should be repainted. (Inherited from DiagramBase.)
SelectionChanged | Raised when an item is added to or removed from the selection. (Inherited from DiagramBase.)
SelectionModified | Raised when the user moves or resizes multiple selected items. (Inherited from DiagramBase.)
SelectionModifying | Raised while the user is moving or resizing multiple selected items, this event lets you cancel the modification. (Inherited from DiagramBase.)
SerializeControl | Lets you save the attributes of controls hosted inside ControlNodes. (Inherited from DiagramBase.)
SerializeTag | Raised when the Tag of a diagram item must be serialized into an XML document. (Inherited from DiagramBase.)
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape. (Inherited from DiagramBase.)
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node. (Inherited from DiagramBase.)
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node. (Inherited from DiagramBase.)
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point. (Inherited from DiagramBase.)
ZoomFactorChanged | Occurs when the zoom factor changes. (Inherited from DiagramBase.)

See Also

Diagram Class


MindFusion.Diagramming.Diagram Fields

Diagram Fields
[image]

Public Fields

Name | Description
AdjustmentHandlesSizeProperty | Identifies the AdjustmentHandlesSize dependency property.
AlignmentGuidePenProperty | Identifies the AlignmentGuidePen dependency property.
AllowMultipleResizeProperty | Identifies the AllowMultipleResize dependency property.
AllowUnconnectedLinksProperty | Identifies the AllowUnconnectedLinks dependency property.
AutoScrollProperty | Identifies the AutoScroll dependency property.
CanRedoProperty | Identifies the CanRedo dependency property.
CanUndoProperty | Identifies the CanUndo dependency property.
ContainerNodeStyleProperty | Identifies the ContainerNodeStyle dependency property.
DiagramLinkStyleProperty | Identifies the DiagramLinkStyle dependency property.
Dummy | A shared DummyNode instance.
EnableLanesProperty | Identifies the EnableLanes dependency property.
ExpandButtonTemplateProperty | Identifies the ExpandButtonTemplate dependancy property.
GridDashArrayProperty | Identifies the GridDashArray dependency property.
GridPointSizeProperty | Identifies the GridPointSize dependency property.
NodeEffectsSourceProperty | Identifies the NodeEffectsSource dependency property.
ShapeNodeStyleProperty | Identifies the ShapeNodeStyle dependency property.
TableNodeStyleProperty | Identifies the TableNodeStyle dependency property.
TreeViewNodeStyleProperty | Identifeis the TreeViewNodeStyle dependency property.
ZoomFactorProperty | Identifies the ZoomFactor property.

See Also

Diagram Class


MindFusion.Diagramming.Diagram.AdjustmentHandlesSizeProperty Field

Diagram.AdjustmentHandlesSizeProperty Field
[image]

Identifies the AdjustmentHandlesSize dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static DependencyProperty AdjustmentHandlesSizeProperty

Visual Basic [image] Copy Code

Public Shared AdjustmentHandlesSizeProperty As DependencyProperty

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AlignmentGuidePenProperty Field

Diagram.AlignmentGuidePenProperty Field
[image]

Identifies the AlignmentGuidePen dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static DependencyProperty AlignmentGuidePenProperty

Visual Basic [image] Copy Code

Public Shared AlignmentGuidePenProperty As DependencyProperty

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AllowMultipleResizeProperty Field

Diagram.AllowMultipleResizeProperty Field
[image]

Identifies the AllowMultipleResize dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static DependencyProperty AllowMultipleResizeProperty

Visual Basic [image] Copy Code

Public Shared AllowMultipleResizeProperty As DependencyProperty

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AllowUnconnectedLinksProperty Field

Diagram.AllowUnconnectedLinksProperty Field
[image]

Identifies the AllowUnconnectedLinks dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static DependencyProperty AllowUnconnectedLinksProperty

Visual Basic [image] Copy Code

Public Shared AllowUnconnectedLinksProperty As DependencyProperty

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AutoScrollProperty Field

Diagram.AutoScrollProperty Field
[image]

Identifies the AutoScroll dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static DependencyProperty AutoScrollProperty

Visual Basic [image] Copy Code

Public Shared AutoScrollProperty As DependencyProperty

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.CanRedoProperty Field

Diagram.CanRedoProperty Field
[image]

Identifies the CanRedo dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CanRedoProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CanRedoProperty As DependencyProperty

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.CanUndoProperty Field

Diagram.CanUndoProperty Field
[image]

Identifies the CanUndo dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CanUndoProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CanUndoProperty As DependencyProperty

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ContainerNodeStyleProperty Field

Diagram.ContainerNodeStyleProperty Field
[image]

Identifies the ContainerNodeStyle dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static DependencyProperty ContainerNodeStyleProperty

Visual Basic [image] Copy Code

Public Shared ContainerNodeStyleProperty As DependencyProperty

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.DiagramLinkStyleProperty Field

Diagram.DiagramLinkStyleProperty Field
[image]

Identifies the DiagramLinkStyle dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static DependencyProperty DiagramLinkStyleProperty

Visual Basic [image] Copy Code

Public Shared DiagramLinkStyleProperty As DependencyProperty

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Dummy Field

Diagram.Dummy Field
[image]

A shared DummyNode instance.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DummyNode Dummy

Visual Basic [image] Copy Code

Public Dummy As DummyNode

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.EnableLanesProperty Field

Diagram.EnableLanesProperty Field
[image]

Identifies the EnableLanes dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EnableLanesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EnableLanesProperty As DependencyProperty

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ExpandButtonTemplateProperty Field

Diagram.ExpandButtonTemplateProperty Field
[image]

Identifies the ExpandButtonTemplate dependancy property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ExpandButtonTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ExpandButtonTemplateProperty As DependencyProperty

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GridDashArrayProperty Field

Diagram.GridDashArrayProperty Field
[image]

Identifies the GridDashArray dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GridDashArrayProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GridDashArrayProperty As DependencyProperty

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GridPointSizeProperty Field

Diagram.GridPointSizeProperty Field
[image]

Identifies the GridPointSize dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GridPointSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GridPointSizeProperty As DependencyProperty

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.NodeEffectsSourceProperty Field

Diagram.NodeEffectsSourceProperty Field
[image]

Identifies the NodeEffectsSource dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty NodeEffectsSourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly NodeEffectsSourceProperty As DependencyProperty

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ShapeNodeStyleProperty Field

Diagram.ShapeNodeStyleProperty Field
[image]

Identifies the ShapeNodeStyle dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static DependencyProperty ShapeNodeStyleProperty

Visual Basic [image] Copy Code

Public Shared ShapeNodeStyleProperty As DependencyProperty

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TableNodeStyleProperty Field

Diagram.TableNodeStyleProperty Field
[image]

Identifies the TableNodeStyle dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static DependencyProperty TableNodeStyleProperty

Visual Basic [image] Copy Code

Public Shared TableNodeStyleProperty As DependencyProperty

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TreeViewNodeStyleProperty Field

Diagram.TreeViewNodeStyleProperty Field
[image]

Identifeis the TreeViewNodeStyle dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static DependencyProperty TreeViewNodeStyleProperty

Visual Basic [image] Copy Code

Public Shared TreeViewNodeStyleProperty As DependencyProperty

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ZoomFactorProperty Field

Diagram.ZoomFactorProperty Field
[image]

Identifies the ZoomFactor property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ZoomFactorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ZoomFactorProperty As DependencyProperty

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram Constructor

Diagram Constructor
[image]

Initializes a new instance of the Diagram class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Diagram ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Diagram Class


MindFusion.Diagramming.Diagram Methods

Diagram Methods
[image]

Public Methods

Name | Description
AlignPointToGrid | Returns a point of the alignment grid nearest to the one passed as an argument.
ArrangeLinkLabels | Rearranges link labels whose AutoArrange property is enabled.
BeginEdit | Overloaded.
CancelCompositeOperation | Stops recording undo/redo commands into a CompositeCommand and discards the records created so far.
CancelDrag | Cancels the current drag operation.
ChangeUnit | Sets new MeasureUnit value and scales the coordinates of diagram items so that their absolute size remains unchanged.
ClearAll | Removes all items from the diagram.
CommitCompositeOperation | Stops recording undo/redo commands into a CompositeCommand and saves the composite in the history queue.
CopySelection | Creates a copy of the currently selected objects and groups.
CreateThemeFromDefaults | Creates a Theme object representing the default properties of the diagram.
EndDelayUpdate | Continue updating the visual state of items.
EndEdit | Exits the in-place editing mode and either accepts or rejects the changes made to the item's text.
ExecuteCommand | Executes the specified command on this diagram.
FindLinkById | Finds the link that has the specified id value.
FindNodeById | Finds the node that has the specified id value.
GetContentBounds | Returns the smallest rectangle that bounds all diagram objects.
GetItemAt | Overloaded.
GetLinkAt | Overloaded. Finds and returns the top-most link that lies at the specified location.
GetNearestNode | Returns the node nearest to the specified point.
GetNodeAt | Overloaded.
GetNodesInViewport | Returns all nodes visible in the current viewport.
HitTestManipulators | Tests whether the specified point is within the manipulator of a diagram object and triggers the manipulator.
Invalidate | Causes the entire visible diagram area to be repainted.
IsItemInteractive | Checks if the specified item can be modified interactively.
IsItemLocked | Checks if the specified item is locked.
IsItemVisible | Checks if the specified item is currently visible.
LoadFromString | Decodes diagram contents from a string that was created with SaveToString.
LoadFromXml | Overloaded.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
PasteSelection | Adds the specified items and groups to this diagram.
RaiseClicked | Raises the Clicked event.
RaiseClicked | Raises the appropriate *Clicked event according to the type of the specified item.
RaiseCreated | Raises the appropriate *Created event according to the type of the specified item.
RaiseDeleting | Raises the LinkDeleting or NodeDeleting event according to the type of the specified item.
RaiseDoubleClicked | Overloaded.
RaiseLinkTextEdited | Raises the LinkTextEdited event.
RaiseNodeTextEdited | Raises the NodeTextEdited event.
RaisePasted | Raises the appropriate Pasted event.
Redo | Executes again an action saved in the command history.
RegisterClass | Registers a class for serialization support.
RegisterItemClass | Registers a diagram item class for serialization support.
ResizeToFitItem | Resizes the document extents so that the specified item is contained within.
ResizeToFitItems | Overloaded. Resizes the document scrollable area so it fits all diagram items.
RouteAllLinks | Routes all links in the diagram in a way they do not cross nodes.
SaveToString | Returns a serialized form of the diagram as string
SaveToXml | Overloaded.
SetScrollerParent | Binds the lane-grid header positions to the offset of a ScrollViewer's scrollbars.
SetZoomFactor | Sets the zoom factor, preserving the on-screen position of the specified diagram point.
StartCompositeOperation | Starts recording undo/redo commands into a CompositeCommand.
StartDelayUpdate | Stops updating the visual state of items.
StartInteraction | Overloaded.
Undo | Undoes an action saved in the command history.
UpdateRuntimeIndices | For internal use.
UpdateVisualZIndices | For internal use.
ZoomToRect | Zooms and scrolls the view to fit the specified document rectangle in the Diagram's visible area.

Protected Methods

Name | Description
ArrangeOverride | FrameworkElement.ArrangeOverride override.
OnMouseRightButtonDown | Control.OnMouseRightButtonDown override.
OnMouseRightButtonUp | Control.OnMouseRightButtonUp override.
RemoveItem | Removes the specified item from the diagram and creates a record in the undo/redo history.

Inherited Protected Methods

Name | Description
OnActionRedone | Raises the ActionRedone event. (Inherited from DiagramBase.)
OnActionUndone | Raises the ActionUndone event. (Inherited from DiagramBase.)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramBase.)
OnCellClicked | Raises the CellClicked event. (Inherited from DiagramBase.)
OnCellDoubleClicked | Raises the CellDoubleClicked event. (Inherited from DiagramBase.)
OnClicked | Raises the Clicked event. (Inherited from DiagramBase.)
OnContainerChildAdded | Raises the ContainerChildAdded event. (Inherited from DiagramBase.)
OnContainerChildRemoved | Raises the ContainerChildRemoved event. (Inherited from DiagramBase.)
OnContainerFolded | Raises the ContainerFolded event. (Inherited from DiagramBase.)
OnContainerUnfolded | Raises the ContainerUnfolded event. (Inherited from DiagramBase.)
OnDeserializeControl | Raises the DeserializeControl event. (Inherited from DiagramBase.)
OnDeserializeTag | Raises the DeserializeTag event. (Inherited from DiagramBase.)
OnDoubleClicked | Raises the DoubleClicked event. (Inherited from DiagramBase.)
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event. (Inherited from DiagramBase.)
OnEnterInplaceEditMode | Raises the EnterInplaceEditMode event. (Inherited from DiagramBase.)
OnExpandButtonClicked | Raises the ExpandButtonClicked event. (Inherited from DiagramBase.)
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event. (Inherited from DiagramBase.)
OnInitializeLink | Raises the InitializeLink event. (Inherited from DiagramBase.)
OnInitializeNode | Raises the InitializeNode event. (Inherited from DiagramBase.)
OnItemAdded | Raises the ItemAdded event. (Inherited from DiagramBase.)
OnItemRemoved | Raises the ItemRemoved event. (Inherited from DiagramBase.)
OnLaneGridCellCreated | Raises the LaneGridCellCreated event. (Inherited from DiagramBase.)
OnLaneGridHeaderCreated | Raises the LaneGridHeaderCreated event. (Inherited from DiagramBase.)
OnLeaveInplaceEditMode | Raises the LeaveInplaceEditMode event. (Inherited from DiagramBase.)
OnLinkActivated | Raises the LinkActivated event. (Inherited from DiagramBase.)
OnLinkClicked | Raises the LinkClicked event. (Inherited from DiagramBase.)
OnLinkCreated | Raises the LinkCreated event. (Inherited from DiagramBase.)
OnLinkCreating | Raises the LinkCreating event. (Inherited from DiagramBase.)
OnLinkDeactivated | Raises the LinkDeactivated event. (Inherited from DiagramBase.)
OnLinkDeleted | Raises the LinkDeleted event. (Inherited from DiagramBase.)
OnLinkDeleting | Raises the LinkDeleting event. (Inherited from DiagramBase.)
OnLinkDeselected | Raises the LinkDeselected event. (Inherited from DiagramBase.)
OnLinkDoubleClicked | Raises the LinkDoubleClicked event. (Inherited from DiagramBase.)
OnLinkModified | Raises the LinkModified event. (Inherited from DiagramBase.)
OnLinkModifying | Raises the LinkModifying event. (Inherited from DiagramBase.)
OnLinkPasted | Raises the LinkPasted event. (Inherited from DiagramBase.)
OnLinkRouted | Raises the LinkRouted event. (Inherited from DiagramBase.)
OnLinkSelected | Raises the LinkSelected event. (Inherited from DiagramBase.)
OnLinkTextEdited | Raises the LinkTextEdited event. (Inherited from DiagramBase.)
OnMagnifierFactorChanged | Raises the MagnifierFactorChanged event. (Inherited from DiagramBase.)
OnMeasureUnitChanged | Raises the MeasureUnitChanged event. (Inherited from DiagramBase.)
OnNodeActivated | Raises the NodeActivated event. (Inherited from DiagramBase.)
OnNodeClicked | Raises the NodeClicked event. (Inherited from DiagramBase.)
OnNodeCreated | Raises the NodeCreated event. (Inherited from DiagramBase.)
OnNodeCreating | Raises the NodeCreating event. (Inherited from DiagramBase.)
OnNodeDeactivated | Raises the NodeDeactivated event. (Inherited from DiagramBase.)
OnNodeDeleted | Raises the NodeDeleted event. (Inherited from DiagramBase.)
OnNodeDeleting | Raises the NodeDeleting event. (Inherited from DiagramBase.)
OnNodeDeselected | Raises the NodeDeselected event. (Inherited from DiagramBase.)
OnNodeDoubleClicked | Raises the NodeDoubleClicked event. (Inherited from DiagramBase.)
OnNodeModified | Raises the NodeModified event. (Inherited from DiagramBase.)
OnNodeModifying | Raises the NodeModifying event. (Inherited from DiagramBase.)
OnNodePasted | Raises the NodePasted event. (Inherited from DiagramBase.)
OnNodeSelected | Raises the NodeSelected event. (Inherited from DiagramBase.)
OnNodeTextEdited | Raises the NodeTextEdited event. (Inherited from DiagramBase.)
OnRepaint | Raises the Repaint event. (Inherited from DiagramBase.)
OnSelectionChanged | Raises the SelectionChanged event. (Inherited from DiagramBase.)
OnSelectionModified | Raises the SelectionModified event. (Inherited from DiagramBase.)
OnSelectionModifying | Raises the SelectionModifying event. (Inherited from DiagramBase.)
OnSerializeControl | Raises the SerializeControl event. (Inherited from DiagramBase.)
OnSerializeTag | Raises the SerializeTag event. (Inherited from DiagramBase.)
OnSetSelfLoopShape | Raises the SetSelfLoopShape event. (Inherited from DiagramBase.)
OnTreeCollapsed | Raises the TreeCollapsed event. (Inherited from DiagramBase.)
OnTreeExpanded | Raises the TreeExpanded event. (Inherited from DiagramBase.)
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event. (Inherited from DiagramBase.)
OnZoomFactorChanged | Raises the ZoomFactorChanged event. (Inherited from DiagramBase.)

See Also

Diagram Class


MindFusion.Diagramming.Diagram.AlignPointToGrid Method

Diagram.AlignPointToGrid Method
[image]

Returns a point of the alignment grid nearest to the one passed as an argument.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point AlignPointToGrid (
Point point
)

Visual Basic [image] Copy Code

Public Function AlignPointToGrid( _
point As Point _
) As Point

Parameters

point

A point specified in diagram coordinates.

Return Value

A point from the alignment grid.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ArrangeLinkLabels Method

Diagram.ArrangeLinkLabels Method
[image]

Rearranges link labels whose AutoArrange property is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ArrangeLinkLabels ()

Visual Basic [image] Copy Code

Public Sub ArrangeLinkLabels ()

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LinkLabel Class


MindFusion.Diagramming.Diagram.ArrangeOverride Method

Diagram.ArrangeOverride Method
[image]

FrameworkElement.ArrangeOverride override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size ArrangeOverride (
Size finalSize
)

Visual Basic [image] Copy Code

Protected Overrides Function ArrangeOverride( _
finalSize As Size _
) As Size

Parameters

finalSize

Return Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.BeginEdit Method

Diagram.BeginEdit Method
[image]

Overload List

Name | Description
Diagram.BeginEdit (InplaceEditable) | Begins in-place editing of the specified object.
Diagram.BeginEdit (InplaceEditable, Point) | Enters in-place editing mode, letting the user edit the text of the specified item.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.BeginEdit Method (InplaceEditable)

Diagram.BeginEdit Method (InplaceEditable)
See Also
[image]

Begins in-place editing of the specified object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void BeginEdit (
InplaceEditable item
)

Visual Basic [image] Copy Code

Public Sub BeginEdit ( _
item As InplaceEditable _
)

Parameters

item
The diagram item or table's cell whose text should be edited.

See Also

BeginEdit Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.BeginEdit Method (InplaceEditable, Point)

Diagram.BeginEdit Method (InplaceEditable, Point)
See Also
[image]

Enters in-place editing mode, letting the user edit the text of the specified item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void BeginEdit (
InplaceEditable editable,
Point mousePosition
)

Visual Basic [image] Copy Code

Public Sub BeginEdit ( _
editable As InplaceEditable, _
mousePosition As Point _
)

Parameters

editable

The diagram item or table's cell whose text should be edited.

mousePosition

A Point specifying where the in-place edit box should appear.

Remarks

If AllowInplaceEdit is enabled, the user can start editing the text of an item by double-clicking the item.

See Also

BeginEdit Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.CancelCompositeOperation Method

Diagram.CancelCompositeOperation Method
[image]

Stops recording undo/redo commands into a CompositeCommand and discards the records created so far.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void CancelCompositeOperation ()

Visual Basic [image] Copy Code

Public Sub CancelCompositeOperation ()

Remarks

You must call either CommitCompositeOperation or this method when the diagram modifications are done after a StartCompositeOperation call.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
UndoEnabled Property


MindFusion.Diagramming.Diagram.CancelDrag Method

Diagram.CancelDrag Method
[image]

Cancels the current drag operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void CancelDrag ()

Visual Basic [image] Copy Code

Public Sub CancelDrag ()

Remarks

This method is useful in situations when the current draw operation must be cancelled, for example when starting drag-and-drop from the MouseMove event handler.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ChangeUnit Method

Diagram.ChangeUnit Method
[image]

Sets new MeasureUnit value and scales the coordinates of diagram items so that their absolute size remains unchanged.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ChangeUnit (
GraphicsUnit newUnit
)

Visual Basic [image] Copy Code

Public Sub ChangeUnit( _
newUnit As GraphicsUnit _
)

Parameters

newUnit

A GraphicsUnit value specifying the new unit.

Remarks

This method scales the coordinates of nodes' Bounds values and links' ControlPoints to preserve their size when measured in the new unit. In addition, it scales values of some size and distance -related properties such as HeadShapeSize and CaptionHeight.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ClearAll Method

Diagram.ClearAll Method
[image]

Removes all items from the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void ClearAll ()

Visual Basic [image] Copy Code

Public Overridable Sub ClearAll ()

Remarks

This method also clears the undo/redo history. To remove all items as an undoable operation, remove them from the Items collection enclosed between StartCompositeOperation and CommitCompositeOperation calls.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.CommitCompositeOperation Method

Diagram.CommitCompositeOperation Method
[image]

Stops recording undo/redo commands into a CompositeCommand and saves the composite in the history queue.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void CommitCompositeOperation ()

Visual Basic [image] Copy Code

Public Sub CommitCompositeOperation ()

Remarks

You must call either CancelCompositeOperation or this method when the diagram modifications are done after a StartCompositeOperation call.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
UndoEnabled Property


MindFusion.Diagramming.Diagram.CopySelection Method

Diagram.CopySelection Method
[image]

Creates a copy of the currently selected objects and groups.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SelectionCopy CopySelection (
bool unconnectedLinks
)

Visual Basic [image] Copy Code

Public Function CopySelection ( _
unconnectedLinks As Boolean _
) As SelectionCopy

Parameters

unconnectedLinks
true to allow copying unconnected links; otherwise, false.

Return Value

An instance of the SelectionCopy class.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
PasteSelection Method


MindFusion.Diagramming.Diagram.CreateThemeFromDefaults Method

Diagram.CreateThemeFromDefaults Method
[image]

Creates a Theme object representing the default properties of the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Theme CreateThemeFromDefaults ()

Visual Basic [image] Copy Code

Public Function CreateThemeFromDefaults () As Theme

Return Value

An instance of the Theme class.

Remarks

This method is only for compatibility with files saved with versions earlier than 3.0.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.EndDelayUpdate Method

Diagram.EndDelayUpdate Method
[image]

Continue updating the visual state of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void EndDelayUpdate ()

Visual Basic [image] Copy Code

Public Sub EndDelayUpdate ()

Remarks

Call this method to resume updating the appearance of items after a call to StartDelayUpdate.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.EndEdit Method

Diagram.EndEdit Method
[image]

Exits the in-place editing mode and either accepts or rejects the changes made to the item's text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void EndEdit (
bool accept
)

Visual Basic [image] Copy Code

Public Sub EndEdit( _
accept As Boolean _
)

Parameters

accept
true to accept changes made to text; false to reject them.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ExecuteCommand Method

Diagram.ExecuteCommand Method
[image]

Executes the specified command on this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ExecuteCommand (
Command command
)

Visual Basic [image] Copy Code

Public Sub ExecuteCommand ( _
command As Command _
)

Parameters

command
The Command to execute.

Remarks

If undo/redo is enabled, the command is saved in the undo history or added to the active composite command.

AddItemCommand and RemoveItemCommand objects are created automatically by the control when adding or removing items, both programmatically or interactively. Calling this method explicitly could be necessary in order to save item's state for later undo using a ChangeItemCommand, or to run a custom operation represented by a class derived from Command.

Example

The following example shows the pattern that should be used to save the state of an item for later undo.

C# [image] Copy Code
var node = diagram.ActiveItem as ShapeNode;
if (node != null)
{
var change = new ChangeItemCommand(diagram, node);
node.Text = "new text";
node.Brush = new SolidColorBrush(Colors.Red);
diagram.ExecuteCommand(change);
}

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
UndoEnabled Property
Undo Method
StartCompositeOperation Method


MindFusion.Diagramming.Diagram.FindLinkById Method

Diagram.FindLinkById Method
[image]

Finds the link that has the specified id value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink FindLinkById (
Object id
)

Visual Basic [image] Copy Code

Public Function FindLinkById ( _
id As Object _
) As DiagramLink

Parameters

id
An object used as a link id.

Return Value

A DiagramLink whose Id equals to the specified value if such link exists; otherwise, null (Nothing in Visual Basic).

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
FindNodeById Method


MindFusion.Diagramming.Diagram.FindNodeById Method

Diagram.FindNodeById Method
[image]

Finds the node that has the specified id value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode FindNodeById (
Object id
)

Visual Basic [image] Copy Code

Public Function FindNodeById ( _
id As Object _
) As DiagramNode

Parameters

id
A WinRT object used as a node id.

Return Value

A DiagramNode whose Id equals to the specified value if such node exists; otherwise, null (Nothing in Visual Basic).

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
FindLinkById Method


MindFusion.Diagramming.Diagram.GetContentBounds Method

Diagram.GetContentBounds Method
[image]

Returns the smallest rectangle that bounds all diagram objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect GetContentBounds (
bool forPrint,
bool onlyVisible
)

Visual Basic [image] Copy Code

Public Function GetContentBounds( _
forPrint As Boolean, _
onlyVisible As Boolean _
) As Rect

Parameters

forPrint

Specifies whether only printable items should be considered.

onlyVisible

Specifies whether only visible items should be considered.

Return Value

The smallest rectangle that bounds all diagram items.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetItemAt Method

Diagram.GetItemAt Method
[image]

Overload List

Name | Description
Diagram.GetItemAt (Point) | Finds and returns the top-most diagram item that lies at the specified location.
Diagram.GetItemAt (Point, Boolean) | Finds and returns the top-most diagram item that lies at the specified location.
Diagram.GetItemAt (Point, Boolean, Boolean) | Finds and returns the top-most diagram item that lies at the specified location.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetItemAt Method (Point)

Diagram.GetItemAt Method (Point)
See Also
[image]

Finds and returns the top-most diagram item that lies at the specified location.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem GetItemAt (
Point point
)

Visual Basic [image] Copy Code

Public Function GetItemAt ( _
point As Point _
) As DiagramItem

Parameters

point
A Windows.UI.Xaml.Point instance identifying a diagram location.

Return Value

The DiagramItem found or null (Nothing in Visual Basic) if no item has been found.

See Also

GetItemAt Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetItemAt Method (Point, Boolean)

Diagram.GetItemAt Method (Point, Boolean)
See Also
[image]

Finds and returns the top-most diagram item that lies at the specified location.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem GetItemAt (
Point point,
bool excludeLocked
)

Visual Basic [image] Copy Code

Public Function GetItemAt ( _
point As Point, _
excludeLocked As Boolean _
) As DiagramItem

Parameters

point
A Windows.UI.Xaml.Point instance identifying a diagram location.
excludeLocked

true to ignore locked items, otherwise false.

Return Value

The DiagramItem found or null (Nothing in Visual Basic) if no item has been found.

See Also

GetItemAt Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Items Property
GetNodeAt Method


MindFusion.Diagramming.Diagram.GetItemAt Method (Point, Boolean, Boolean)

Diagram.GetItemAt Method (Point, Boolean, Boolean)
See Also
[image]

Finds and returns the top-most diagram item that lies at the specified location.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem GetItemAt (
Point point,
bool excludeLocked,
bool onlyHitTestVisible
)

Visual Basic [image] Copy Code

Public Function GetItemAt( _
point As Point, _
excludeLocked As Boolean, _
onlyHitTestVisible As Boolean _
) As DiagramItem

Parameters

point

A Point instance identifying a diagram location.

excludeLocked

Specifies whether to ignore locked items.

onlyHitTestVisible

Specifies whether to include only items whose HitTestVisible property is enabled.

Return Value

The DiagramItem found or null (Nothing in Visual Basic) if no item has been found.

See Also

GetItemAt Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetLinkAt Method

Diagram.GetLinkAt Method
[image]

Finds and returns the top-most link that lies at the specified location.

Overload List

Name | Description
Diagram.GetLinkAt (Point, Double) | Finds and returns the top-most link that lies at the specified location.
Diagram.GetLinkAt (Point, Double, Boolean) | Finds and returns the top-most link that lies at the specified location, optionally excluding locked links from the search.
Diagram.GetLinkAt (Point, Double, Boolean, Int32@) | Finds and returns the top-most link that lies at the specified location, optionally excluding locked links from the search. The zero-based index of the exact link segment at the specified position is also returned.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetLinkAt Method (Point, Double)

Diagram.GetLinkAt Method (Point, Double)
See Also
[image]

Finds and returns the top-most link that lies at the specified location.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink GetLinkAt (
Point pt,
double maxDist
)

Visual Basic [image] Copy Code

Public Function GetLinkAt( _
pt As Point, _
maxDist As Double _
) As DiagramLink

Parameters

pt
A Point instance identifying a diagram location.
maxDist

The maximal distance between the point and a link, within which to consider the point as lying on the link.

Return Value

The DiagramLink found or a null reference (Nothing in Visual Basic) if no item has been found.

Remarks

Call the method to get the link at a certain place in the document. The method searches starting from the top of z-order and returns the first link found.

See Also

GetLinkAt Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetLinkAt Method (Point, Double, Boolean)

Diagram.GetLinkAt Method (Point, Double, Boolean)
See Also
[image]

Finds and returns the top-most link that lies at the specified location, optionally excluding locked links from the search.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink GetLinkAt (
Point pt,
double maxDist,
bool exclLocked
)

Visual Basic [image] Copy Code

Public Function GetLinkAt( _
pt As Point, _
maxDist As Double, _
exclLocked As Boolean _
) As DiagramLink

Parameters

pt
A Point instance identifying a diagram location.
maxDist

The maximal distance between the point and a link, within which to consider the point as lying on the link.

exclLocked

Specifies that locked links should be ignored by the search.

Return Value

The DiagramLink found or a null reference (Nothing in Visual Basic) if no item has been found.

Remarks

Call the method to get the link at a certain place in the document. The method searches starting from the top of z-order and returns the first link found.

See Also

GetLinkAt Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetLinkAt Method (Point, Double, Boolean, Int32@)

Diagram.GetLinkAt Method (Point, Double, Boolean, Int32@)
See Also
[image]

Finds and returns the top-most link that lies at the specified location, optionally excluding locked links from the search. The zero-based index of the exact link segment at the specified position is also returned.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink GetLinkAt (
Point pt,
double maxDist,
bool exclLocked,
ref int segmNum
)

Visual Basic [image] Copy Code

Public Function GetLinkAt( _
pt As Point, _
maxDist As Double, _
exclLocked As Boolean, _
ByRef segmNum As Integer _
) As DiagramLink

Parameters

pt
A Point instance identifying a diagram location.
maxDist

The maximal distance between the point and a link, within which to consider the point as lying on the link.

exclLocked

Specifies that locked links should be ignored by the search.

segmNum

The zero-based index of the link's segment at which the point is lying is returned here.

Return Value

The DiagramLink found or a null reference (Nothing in Visual Basic) if no item has been found.

Remarks

Call the method to get the link at a certain place in the document. The method searches starting from the top of z-order and returns the first link found.

See Also

GetLinkAt Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetNearestNode Method

Diagram.GetNearestNode Method
[image]

Returns the node nearest to the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode GetNearestNode (
Point pt,
double maxDistance,
DiagramNode ignored
)

Visual Basic [image] Copy Code

Public Function GetNearestNode ( _
pt As Point, _
maxDistance As Double, _
ignored As DiagramNode _
) As DiagramNode

Parameters

pt
A point in the diagram.
maxDistance
The maximum distance from the point at which to look for nodes.
ignored

A node that should be ignored.

Return Value

The DiagramNode nearest to the specified point.

Remarks

The last argument is useful when calling this method from NodeCreated and NodeModified handlers and the affected node should not be included in the search.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetNodeAt Method

Diagram.GetNodeAt Method
[image]

Overload List

Name | Description
Diagram.GetNodeAt (Point) | Finds and returns the top-most node that lies at the specified location.
Diagram.GetNodeAt (Point, Boolean) | Finds and returns the top-most node that lies at the specified location.
Diagram.GetNodeAt (Point, Boolean, Boolean) | Finds and returns the top-most node that lies at the specified location.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetNodeAt Method (Point)

Diagram.GetNodeAt Method (Point)
See Also
[image]

Finds and returns the top-most node that lies at the specified location.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode GetNodeAt (
Point point
)

Visual Basic [image] Copy Code

Public Function GetNodeAt ( _
point As Point _
) As DiagramNode

Parameters

point

A Point instance identifying a diagram location.

Return Value

The DiagramNode found or a null reference (Nothing in Visual Basic) if no item has been found.

See Also

GetNodeAt Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetNodeAt Method (Point, Boolean)

Diagram.GetNodeAt Method (Point, Boolean)
See Also
[image]

Finds and returns the top-most node that lies at the specified location.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode GetNodeAt (
Point point,
bool excludeLocked
)

Visual Basic [image] Copy Code

Public Function GetNodeAt ( _
point As Point, _
excludeLocked As Boolean _
) As DiagramNode

Parameters

point
A Windows.UI.Xaml.Point instance identifying a diagram location.
excludeLocked
true if nodes that are locked should be omitted by searching; otherwise, false.

Return Value

The DiagramNode found or a null reference (Nothing in Visual Basic) if no node has been found.

See Also

GetNodeAt Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Nodes Property
GetItemAt Method


MindFusion.Diagramming.Diagram.GetNodeAt Method (Point, Boolean, Boolean)

Diagram.GetNodeAt Method (Point, Boolean, Boolean)
See Also
[image]

Finds and returns the top-most node that lies at the specified location.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode GetNodeAt (
Point point,
bool excludeLocked,
bool onlyHitTestVisible
)

Visual Basic [image] Copy Code

Public Function GetNodeAt( _
point As Point, _
excludeLocked As Boolean, _
onlyHitTestVisible As Boolean _
) As DiagramNode

Parameters

point

A Point instance identifying a diagram location.

excludeLocked

true if nodes that are locked should be omitted by searching; otherwise, false.

onlyHitTestVisible

Specifies whether to include only items whose HitTestVisible property is enabled.

Return Value

The DiagramNode found or a null reference (Nothing in Visual Basic) if no item has been found.

See Also

GetNodeAt Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetNodesInViewport Method

Diagram.GetNodesInViewport Method
[image]

Returns all nodes visible in the current viewport.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeCollection GetNodesInViewport ()

Visual Basic [image] Copy Code

Public Function GetNodesInViewport () As DiagramNodeCollection

Return Value

A DiagramNodeCollection that contains the viewport nodes.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.HitTestManipulators Method

Diagram.HitTestManipulators Method
[image]

Tests whether the specified point is within the manipulator of a diagram object and triggers the manipulator.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool HitTestManipulators (
Point pt
)

Visual Basic [image] Copy Code

Public Function HitTestManipulators( _
pt As Point _
) As Boolean

Parameters

pt
A Windows.UI.Xaml.Point instance specifying the point to test.

Return Value

true to indicate whether there is a manipulator at the specified location; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Invalidate Method

Diagram.Invalidate Method
[image]

Causes the entire visible diagram area to be repainted.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Invalidate ()

Visual Basic [image] Copy Code

Public Sub Invalidate ()

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.IsItemInteractive Method

Diagram.IsItemInteractive Method
[image]

Checks if the specified item can be modified interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsItemInteractive (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function IsItemInteractive( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem to check.

Return Value

true, if the item is currently visible and unlocked and it is not associated with a hidden or locked layer; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.IsItemLocked Method

Diagram.IsItemLocked Method
[image]

Checks if the specified item is locked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsItemLocked (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function IsItemLocked( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem to check.

Return Value

true, if the item's Locked property is set to true or if the item is associated with a locked layer; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.IsItemVisible Method

Diagram.IsItemVisible Method
[image]

Checks if the specified item is currently visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsItemVisible (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function IsItemVisible( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem to check.

Return Value

true if the item's Visible property is set to true and the item is not associated with a hidden layer; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LoadFromString Method

Diagram.LoadFromString Method
[image]

Decodes diagram contents from a string that was created with SaveToString.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromString (
string str
)

Visual Basic [image] Copy Code

Public Sub LoadFromString( _
str As String _
)

Parameters

str

A string containing the serialized diagram contents.

Remarks

Loads a diagram document from a string. The string must have been created by the SaveToString method.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LoadFromXml Method

Diagram.LoadFromXml Method
[image]

Overload List

Name | Description
Diagram.LoadFromXml (Stream) | Loads the contents of an XML diagram document from the specified stream.
Diagram.LoadFromXml (String) | Loads the contents of the XML diagram document from the specified file into the control.
Diagram.LoadFromXml (XDocument) | Loads the contents of the XML diagram document represented by the specified XmlDocument into the control.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LoadFromXml Method (Stream)

Diagram.LoadFromXml Method (Stream)
See Also
[image]

Loads the contents of an XML diagram document from the specified stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
Stream stream
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
stream As Stream _
)

Parameters

stream

See Also

LoadFromXml Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LoadFromXml Method (String)

Diagram.LoadFromXml Method (String)
See Also
[image]

Loads the contents of the XML diagram document from the specified file into the control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
fileName As String _
)

Parameters

fileName

The name of the XML file the data should be read from.

Remarks

The method reads a diagram previously saved by the SaveToXml method.

See Also

LoadFromXml Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LoadFromXml Method (XDocument)

Diagram.LoadFromXml Method (XDocument)
See Also
[image]

Loads the contents of the XML diagram document represented by the specified XmlDocument into the control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
XDocument document
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
document As XDocument _
)

Parameters

document
A System.Xml.Linq.XDocument object from which to load the diagram data.

Remarks

The method reads a diagram previously saved by the SaveToXml method.

See Also

LoadFromXml Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.OnApplyTemplate Method

Diagram.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Overrides Sub OnApplyTemplate ()

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.OnMouseRightButtonDown Method

Diagram.OnMouseRightButtonDown Method
[image]

Control.OnMouseRightButtonDown override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnMouseRightButtonDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseRightButtonDown( _
e As MouseButtonEventArgs _
)

Parameters

e

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.OnMouseRightButtonUp Method

Diagram.OnMouseRightButtonUp Method
[image]

Control.OnMouseRightButtonUp override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnMouseRightButtonUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseRightButtonUp( _
e As MouseButtonEventArgs _
)

Parameters

e

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.PasteSelection Method

Diagram.PasteSelection Method
[image]

Adds the specified items and groups to this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool PasteSelection (
SelectionCopy data,
double dx,
double dy
)

Visual Basic [image] Copy Code

Public Function PasteSelection ( _
data As SelectionCopy, _
dx As Double, _
dy As Double _
) As Boolean

Parameters

data
A SelectionCopy object returned by a previous call to CopySelection.
dx
Horizontal offset of pasted items from their original positions.
dy
Vertical offset of pasted items from their original positions.

Return Value

true if data contains any items; otherwise, false.

Remarks

This method can be used in conjunction with CopySelection to copy selected items from one Diagram instance to another.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
CopySelection Method
LinkPasted Event
NodePasted Event


MindFusion.Diagramming.Diagram.RaiseClicked Method

Diagram.RaiseClicked Method
[image]

Raises the Clicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseClicked (
MouseButton mouseButton,
Point mousePosition
)

Visual Basic [image] Copy Code

Public Sub RaiseClicked ( _
mouseButton As MouseButton, _
mousePosition As Point _
)

Parameters

mouseButton

mousePosition

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseClicked Method

Diagram.RaiseClicked Method
[image]

Raises the appropriate *Clicked event according to the type of the specified item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseClicked (
DiagramItem item,
Point mousePosition,
MouseButton mouseButton
)

Visual Basic [image] Copy Code

Public Sub RaiseClicked( _
item As DiagramItem, _
mousePosition As Point, _
mouseButton As MouseButton _
)

Parameters

item

The DiagramItem related to the event.

mousePosition

The current mouse position, in document coordinates.

mouseButton

The mouse button related to the event.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseCreated Method

Diagram.RaiseCreated Method
[image]

Raises the appropriate *Created event according to the type of the specified item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseCreated (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Sub RaiseCreated ( _
item As DiagramItem _
)

Parameters

item
The DiagramItem related to the event.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseDeleting Method

Diagram.RaiseDeleting Method
[image]

Raises the LinkDeleting or NodeDeleting event according to the type of the specified item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RaiseDeleting (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function RaiseDeleting ( _
item As DiagramItem _
) As Boolean

Parameters

item
The DiagramItem related to the event.

Return Value

true if the operation has been confirmed; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseDoubleClicked Method

Diagram.RaiseDoubleClicked Method
[image]

Overload List

Name | Description
Diagram.RaiseDoubleClicked (DiagramItem, Point, MouseButton) | Raises the DoubleClicked event of the Diagram class.
Diagram.RaiseDoubleClicked (MouseButton, Point) | Raises the DoubleClicked event of the Diagram class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseDoubleClicked Method (DiagramItem, Point, MouseButton)

Diagram.RaiseDoubleClicked Method (DiagramItem, Point, MouseButton)
See Also
[image]

Raises the DoubleClicked event of the Diagram class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseDoubleClicked (
DiagramItem item,
Point mousePosition,
MouseButton mouseButton
)

Visual Basic [image] Copy Code

Public Sub RaiseDoubleClicked( _
item As DiagramItem, _
mousePosition As Point, _
mouseButton As MouseButton _
)

Parameters

item

The DiagramItem related to the event.

mousePosition

The current cursor position, in document coordinates.

mouseButton

The mouse button related to the event.

See Also

RaiseDoubleClicked Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseDoubleClicked Method (MouseButton, Point)

Diagram.RaiseDoubleClicked Method (MouseButton, Point)
See Also
[image]

Raises the DoubleClicked event of the Diagram class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseDoubleClicked (
MouseButton mouseButton,
Point mousePosition
)

Visual Basic [image] Copy Code

Public Sub RaiseDoubleClicked ( _
mouseButton As MouseButton, _
mousePosition As Point _
)

Parameters

mouseButton

The mouse button that was double-clicked.

mousePosition

The current cursor position, in document coordinates.

See Also

RaiseDoubleClicked Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseLinkTextEdited Method

Diagram.RaiseLinkTextEdited Method
[image]

Raises the LinkTextEdited event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseLinkTextEdited (
DiagramLink link,
string oldText,
string newText
)

Visual Basic [image] Copy Code

Public Sub RaiseLinkTextEdited ( _
link As DiagramLink, _
oldText As String, _
newText As String _
)

Parameters

link
The DiagramLink related to the event.
oldText

The old text of the link.

newText

The new text of the link.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseNodeTextEdited Method

Diagram.RaiseNodeTextEdited Method
[image]

Raises the NodeTextEdited event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseNodeTextEdited (
DiagramNode node,
string oldText,
string newText
)

Visual Basic [image] Copy Code

Public Sub RaiseNodeTextEdited ( _
node As DiagramNode, _
oldText As String, _
newText As String _
)

Parameters

node
The DiagramNode related to the event.
oldText

The old text of the node.

newText

The new text of the node.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaisePasted Method

Diagram.RaisePasted Method
[image]

Raises the appropriate Pasted event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaisePasted (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Sub RaisePasted( _
item As DiagramItem _
)

Parameters

item

The DiagramItem related to the event.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Redo Method

Diagram.Redo Method
[image]

Executes again an action saved in the command history.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Redo ()

Visual Basic [image] Copy Code

Public Sub Redo ()

Remarks

Calling this method has no effect before Undo has been called at least once. Any command that has been undone can later be redone by Redo. The method processes the commands in the same order they were initially executed, which is opposite to the order in which they are undone.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
UndoEnabled Property
CanRedo Property
ExecuteCommand Method
ActionRedone Event


MindFusion.Diagramming.Diagram.RegisterClass Method

Diagram.RegisterClass Method
[image]

Registers a class for serialization support.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void RegisterClass (
Type classType,
string classId,
int classVersion
)

Visual Basic [image] Copy Code

Public Shared Sub RegisterClass( _
classType As Type, _
classId As String, _
classVersion As Integer _
)

Parameters

classType

A Type instance identifying the class.

classId

A class identifier to use when saving and loading objects of the specified type.

classVersion

A revision number of the serialization format.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RegisterItemClass Method

Diagram.RegisterItemClass Method
[image]

Registers a diagram item class for serialization support.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void RegisterItemClass (
Type itemClass,
string classId,
int classVersion
)

Visual Basic [image] Copy Code

Public Shared Sub RegisterItemClass( _
itemClass As Type, _
classId As String, _
classVersion As Integer _
)

Parameters

itemClass
A System.Type instance identifying the item class.
classId

A class identifier to use when saving and loading items of the specified type.

classVersion

A revision number of the item's class serialization format.

Remarks

When using custom item types, use this method to enable saving and loading the custom item instances to/from XML or binary files. The version identifier must be increased when the format in which items are saved changes. It can be used when loading files to let your application load items data from an older format. All custom item classes must provide a parameterless constructor, or one that takes a Diagram argument. Failing to do so would result in exceptions during the load process, since the diagram will be unable to create items from the custom type.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RemoveItem Method

Diagram.RemoveItem Method
[image]

Removes the specified item from the diagram and creates a record in the undo/redo history.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void RemoveItem (
DiagramItem item
)

Visual Basic [image] Copy Code

Protected Overridable Sub RemoveItem ( _
item As DiagramItem _
)

Parameters

item
The item that should be removed from the diagram.

Remarks

The Diagram object calls this method automatically when an item is removed from the Items collection. Classes that inherit Diagram can override it to implement some additional processing, but in any case they must call the base method.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ResizeToFitItem Method

Diagram.ResizeToFitItem Method
[image]

Resizes the document extents so that the specified item is contained within.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ResizeToFitItem (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Sub ResizeToFitItem ( _
item As DiagramItem _
)

Parameters

item
A DiagramItem whose bounding rectangle should be added to the diagram area.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ResizeToFitItems Method

Diagram.ResizeToFitItems Method
[image]

Resizes the document scrollable area so it fits all diagram items.

Overload List

Name | Description
Diagram.ResizeToFitItems (Double) | Resizes the document scrollable area so it fits all diagram items.
Diagram.ResizeToFitItems (Double, Boolean) | Resizes the document scrollable area so it fits all diagram items, optionally considering ony the visible items.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Bounds Property
AutoResize Property


MindFusion.Diagramming.Diagram.ResizeToFitItems Method (Double)

Diagram.ResizeToFitItems Method (Double)
See Also
[image]

Resizes the document scrollable area so it fits all diagram items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ResizeToFitItems (
double margins
)

Visual Basic [image] Copy Code

Public Sub ResizeToFitItems( _
margins As Double _
)

Parameters

margins
Size of the margin area that should be left around the diagram.

Remarks

Resizes the document area to be just as big as needed, for example, the smallest rectangle containing all diagram items. For aesthetic reasons, additional space can be left around the outmost items as a margin. Invoking the method on an empty document produces no result.

See Also

ResizeToFitItems Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Bounds Property
AutoResize Property


MindFusion.Diagramming.Diagram.ResizeToFitItems Method (Double, Boolean)

Diagram.ResizeToFitItems Method (Double, Boolean)
See Also
[image]

Resizes the document scrollable area so it fits all diagram items, optionally considering ony the visible items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ResizeToFitItems (
double margins,
bool onlyVisible
)

Visual Basic [image] Copy Code

Public Sub ResizeToFitItems( _
margins As Double, _
onlyVisible As Boolean _
)

Parameters

margins
Size of the margin area that should be left around the diagram.
onlyVisible
Specifies whether only the bounds of the Visible items should be included in the new document area.

Remarks

Resizes the document area to be just as big as needed, for example the smallest rectangle containing all diagram items. For aesthetic reasons, additional space can be left around the outmost items as a margin. Invoking the method on an empty document produces no result.

See Also

ResizeToFitItems Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Bounds Property
AutoResize Property


MindFusion.Diagramming.Diagram.RouteAllLinks Method

Diagram.RouteAllLinks Method
[image]

Routes all links in the diagram in a way they do not cross nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RouteAllLinks ()

Visual Basic [image] Copy Code

Public Sub RouteAllLinks ()

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.SaveToString Method

Diagram.SaveToString Method
[image]

Returns a serialized form of the diagram as string

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string SaveToString (
SaveToStringFormat options
)

Visual Basic [image] Copy Code

Public Function SaveToString( _
options As SaveToStringFormat _
) As String

Parameters

options

Return Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.SaveToXml Method

Diagram.SaveToXml Method
[image]

Overload List

Name | Description
Diagram.SaveToXml (Stream) | Saves the diagram to the specified stream as an XML document.
Diagram.SaveToXml (String) | Saves the diagram to the specified file as an XML document.
Diagram.SaveToXml (XDocument) | Saves the diagram to the specified XML document.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.SaveToXml Method (Stream)

Diagram.SaveToXml Method (Stream)
See Also
[image]

Saves the diagram to the specified stream as an XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
Stream s
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
s As Stream _
)

Parameters

s
An instance of a System.IO.Stream-derived class.

Remarks

Serializes the current diagram as a sequence of bytes represented by stream.

See Also

SaveToXml Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.SaveToXml Method (String)

Diagram.SaveToXml Method (String)
See Also
[image]

Saves the diagram to the specified file as an XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
fileName As String _
)

Parameters

fileName

The full path and name of the disk file where the diagram should be saved.

Remarks

Diagram data can be loaded from an XML file or document using the LoadFromXml method.

See Also

SaveToXml Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.SaveToXml Method (XDocument)

Diagram.SaveToXml Method (XDocument)
See Also
[image]

Saves the diagram to the specified XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void SaveToXml (
XDocument document
)

Visual Basic [image] Copy Code

Public Overridable Sub SaveToXml( _
document As XDocument _
)

Parameters

document
A System.Xml.Linq.XDocument object where the diagram should be saved.

Remarks

Diagram data can be loaded from an XML file or document using the LoadFromXml method.

See Also

SaveToXml Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.SetScrollerParent Method

Diagram.SetScrollerParent Method
[image]

Binds the lane-grid header positions to the offset of a ScrollViewer's scrollbars.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetScrollerParent (
ScrollViewer parent
)

Visual Basic [image] Copy Code

Public Sub SetScrollerParent( _
parent As ScrollViewer _
)

Parameters

parent

The ScrollViewer that contains the diagram.

Remarks

You must call this method in order to enable the "hooked headers" feature of the LaneGrid when the diagram is inside a ScrollViewer. It is called automatically when the diagram is placed inside a Ruler control.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.SetZoomFactor Method

Diagram.SetZoomFactor Method
[image]

Sets the zoom factor, preserving the on-screen position of the specified diagram point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetZoomFactor (
double zoomFactor,
Point pivotPoint
)

Visual Basic [image] Copy Code

Public Sub SetZoomFactor( _
zoomFactor As Double, _
pivotPoint As Point _
)

Parameters

zoomFactor

The new zoom factor.

pivotPoint

A Point instance specifying the zoom center.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.StartCompositeOperation Method

Diagram.StartCompositeOperation Method
[image]

Starts recording undo/redo commands into a CompositeCommand.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void StartCompositeOperation ()

Visual Basic [image] Copy Code

Public Sub StartCompositeOperation ()

Remarks

After the diagram modifications are done, call CommitCompositeOperation or CancelCompositeOperation.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
UndoEnabled Property


MindFusion.Diagramming.Diagram.StartDelayUpdate Method

Diagram.StartDelayUpdate Method
[image]

Stops updating the visual state of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void StartDelayUpdate ()

Visual Basic [image] Copy Code

Public Sub StartDelayUpdate ()

Remarks

Call this method before performing bulk operations that change properties affecting the appearance of many items. Call EndDelayUpdate when finished to update the visual state of the affected items.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.StartInteraction Method

Diagram.StartInteraction Method
[image]

Overload List

Name | Description
Diagram.StartInteraction (InteractionState) | Starts the specified interactive operation. Subsequent mouse movements will modify or create the item specified through the InteractionState instance.
Diagram.StartInteraction (MouseButtonEventArgs) | Starts interaction according to the input devices' state and the current behavior.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.StartInteraction Method (InteractionState)

Diagram.StartInteraction Method (InteractionState)
See Also
[image]

Starts the specified interactive operation. Subsequent mouse movements will modify or create the item specified through the InteractionState instance.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void StartInteraction (
InteractionState interactionState
)

Visual Basic [image] Copy Code

Public Sub StartInteraction ( _
interactionState As InteractionState _
)

Parameters

interactionState
An InteractionState instance

See Also

StartInteraction Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.StartInteraction Method (MouseButtonEventArgs)

Diagram.StartInteraction Method (MouseButtonEventArgs)
See Also
[image]

Starts interaction according to the input devices' state and the current behavior.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual Interaction StartInteraction (
e
)

Visual Basic [image] Copy Code

Protected Overridable Function StartInteraction ( _
e As Interaction

Parameters

e
A PointerRoutedEventArgs

Return Value

An Interaction instance representing the operation.

See Also

StartInteraction Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Undo Method

Diagram.Undo Method
[image]

Undoes an action saved in the command history.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Undo ()

Visual Basic [image] Copy Code

Public Sub Undo ()

Remarks

The control supports unlimited undo/redo depth. This method moves the "current command" pointer one position back, and calling it again will undo the previous command. The commands can later be redone by calling Redo.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
UndoEnabled Property
CanUndo Property
ActionUndone Event


MindFusion.Diagramming.Diagram.UpdateRuntimeIndices Method

Diagram.UpdateRuntimeIndices Method
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void UpdateRuntimeIndices ()

Visual Basic [image] Copy Code

Public Sub UpdateRuntimeIndices ()

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.UpdateVisualZIndices Method

Diagram.UpdateVisualZIndices Method
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void UpdateVisualZIndices ()

Visual Basic [image] Copy Code

Public Sub UpdateVisualZIndices ()

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ZoomToRect Method

Diagram.ZoomToRect Method
[image]

Zooms and scrolls the view to fit the specified document rectangle in the Diagram's visible area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ZoomToRect (
Rect rect
)

Visual Basic [image] Copy Code

Public Sub ZoomToRect( _
rect As Rect _
)

Parameters

rect
A Rect instance specifying the viewport position and size.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram Properties

Diagram Properties
[image]

Public Properties

Name | Description
ActiveItem | Gets or sets the active diagram element.
ActiveItemHandlesStyle | Gets or sets the visual style of adjustment handles of the active item.
ActiveLayer | Gets or sets the zero-based index of the active layer.
AdjustmentHandlesSize | Gets or sets the size of the handles, which appear around selected objects. This is a dependency property.
AlignmentGuidePen | Gets or sets the pen used to draw alignment guides. This is a dependency property.
AlignToGrid | Gets or sets a value indicating whether the diagram items should be aligned to a grid.
AllowInplaceEdit | Gets or sets a value indicating whether in-place editing of the text of objects is enabled.
AllowMultipleResize | Specifies whether multiple selected nodes can be resized simultaneously. This is a dependency property.
AllowUnconnectedLinks | Gets or sets a value indicating whether users are allowed to draw links that are not connected to any node. This is a dependency property.
AutoAlignDistance | Gets or sets the maximal horizontal or vertical distance at which a node aligns to the borders ot other nodes.
AutoAlignNodes | Gets or sets whether nodes should automatically align to the borders ot other nodes during user interaction.
AutoResize | Gets or sets a value indicating whether the document area should be resized automatically so it fits the diagram contents.
AutoScroll | Gets or sets a value indicating whether auto scrolling of the document area is enabled. This is a dependency property.
AutoSnapDistance | Specifies the maximum distance at which links auto-snap to nodes.
AutoSnapLinks | Specifies whether link end points should automatically snap to the nearest diagram node.
BackBrush | Gets or sets the brush used for painting the diagram background.
Behavior | Gets or sets a value indicating how the control responds to user actions.
Bounds | Gets or sets a value representing the size of the diagram's scrollable area.
CanRedo | Gets or sets a value indicating whether there is a command in the redo history which can be redone.
CanUndo | Gets or sets a value indicating whether there is a command in the undo history which can be undone.
ContainerNodeStyle | Gets or sets the theme-level style for container nodes. This is a dependency property.
ContainersFoldable | Gets or sets the default value for the Foldable property of containers.
CrossingRadius | Gets or sets the radius length of decorations displayed at link intersection points.
CustomBehavior | Gets or sets a custom behavior object specifying how DiagramRT responds to mouse input.
DefaultControlType | Gets or sets the type of the controls that will be hosted by default in newly create ControlNode objects.
DefaultShape | Gets or sets the default shape of shape nodes.
DelKeyAction | Gets or sets a value that specifies what action should be performed when the user hits the Del key.
DiagramLinkStyle | Gets or sets the theme-level style for diagram links. This is a dependency property.
DisabledHandlesStyle | Gets or sets the visual style of disabled adjustment handles.
DocumentPlane | DocumentPlane is visual child of diagram and ancestor of all diagram items. The DocumentPlane element is translated with respect to Diagram element so that the point Diagram.Bounds.TopLeft from the DocumentPlane is rendered at Diagram element location (0,0). The coordinate system of the DocumentPlane is the document coordinate system. The intended use of this property is mainly in MouseMove event handling
DynamicLinks | Gets or sets the default value for the Dynamic property of new links.
Enabled | Enables or disables handling of mouse events.
EnableLanes | Gets or sets whether lanes are enabled. This is a dependency property.
ExpandButtonAction | Gets or sets a value indicating what should happen when a user clicks the [+/-] button that is displayed near expandable nodes.
ExpandButtonBrush | Gets or sets the brush used to fill expand/collapse buttons of nodes.
ExpandButtonPosition | Gets or sets where expand/collapse buttons are located relatively to their nodes.
ExpandButtonTemplate | Gets or sets a custom ControlTemplate for the ExpandButton class.
ExpandOnIncoming | Gets or sets a value, indicating in which direction object hierarchies are expanded.
Factory | Gets a Factory instance that lets you add programmatically new items to the diagram.
GridColor | Gets or sets the color of the grid points.
GridDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to draw grid lines. This is a dependency property.
GridOffsetX | Gets or sets the horizontal offset of the first point of the alignment grid.
GridOffsetY | Gets or sets the vertical offset of the first point of the alignment grid.
GridPointSize | Gets or sets the size of shapes used to represent grid points. This is a dependency property.
GridSizeX | Gets or sets the horizontal distance between adjacent grid points.
GridSizeY | Gets or sets the vertical distance between adjacent grid points.
GridStyle | Gets or sets the visual style of the alignment grid.
HitTestPriority | Gets or sets a value indicating the order in which items are hit-tested.
InplaceEditAcceptOnEnter | Gets or sets a value indicating whether pressing the ENTER key should exit in-place editing mode and accept changes made to text.
InplaceEditCancelOnEsc | Gets or sets a value indicating whether pressing the ESC key should exit inplace-edit mode and reject changes made to text.
Interaction | Gets an InteractionState instance representing the current action being carried out by the user.
Items | Represents a strongly typed collection of DiagramItem objects.
LaneGrid | Gets the Grid instance that represents the lane grid.
Layers | Gets a list of the layers in the current diagram.
LicenseKey | Gets or sets the license key of the control.
LinkBaseShape | Gets or sets the shape displayed at the base of new links.
LinkBaseShapeSize | Gets or sets the default size of the base of new links.
LinkBrush | Gets or sets the default value for the Brush property of links.
LinkCrossings | Gets or sets how to render the intersection points where links cross their paths.
LinkHeadShape | Gets or sets the shape displayed as head of new links.
LinkHeadShapeSize | Gets or sets the default size of arrowheads.
LinkIntermediateShape | Gets or sets default shape to be displayed in the middle of each segment of links.
LinkIntermediateShapeSize | Gets or sets the default size of the shapes at middles of link segments.
LinkPen | Gets or sets the default value for the Pen property of links.
LinkRouter | Gets or sets the component used to find paths for auto-routed links when diagram nodes are added or their positions change.
Links | Gets a DiagramLinkCollection containing the links.
LinkSegments | Gets or sets the default number of link segments.
LinkShape | Gets or sets the default style of diagram links.
MeasureUnit | Gets or sets the unit of measure used for logical coordinates in this diagram.
ModificationStart | Gets or sets how users can start modifying diagram items.
NodeEffects | Gets a collection with all effects applied to the nodes of this diagram.
Nodes | Gets a DiagramNodeCollection containing the nodes.
NodesExpandable | Gets or sets a value indicating whether newly created nodes can be expanded.
OverrideCursor | Sets the cursor and stops changing it depending on the context.
PrintOptions | Gets an object which provides customization properties for printed diagrams.
RecursiveExpand | Gets or sets value indicating how a tree is expanded.
RoundedLinks | Gets or sets a value indicating whether the joins between segments of Polyline and Cascading links should be rounded.
RoundedLinksRadius | Gets or sets the radius of arc joins of rounded links' segments.
RouteLinks | Gets or sets a value indicating whether links should avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes.
RoutingOptions | Gets an object, which allows customizing various parameters of the link routing algorithm.
ScrollX | Gets or sets the document's X scroll position.
ScrollY | Gets or sets the document's Y scroll position.
ScrollZoneSize | Gets or sets the size of the auto scroll zone near the edges of the control.
SelectedItemHandlesStyle | Gets or sets the visual style of adjustment handles of selected items.
Selection | Gets the Selection instance that represents the selection of items in this diagram.
ShapeBrush | Gets or sets the default value for the Brush property of shape nodes.
ShapeHandlesStyle | Gets or sets the default value for the HandlesStyle property of new shape nodes.
ShapeNodeStyle | Gets or sets the theme-level style for shape nodes. This is a dependency property.
ShapePen | Gets or sets the default value for the Pen property of new ShapeNode objects.
ShowAnchors | Gets or sets a value indicating whether and when node anchor points should be displayed.
ShowGrid | Gets or sets a value indicating whether the alignment grid is visible.
TableBrush | Gets or sets the default value for the Brush property of tables.
TableCaption | Gets or sets the default text for tables' captions.
TableCaptionHeight | Gets or sets the default height of table captions.
TableColumnCount | Gets or sets the default number of table columns.
TableColumnWidth | Gets or sets the default width of tables' columns.
TableNodeStyle | Gets or sets the theme-level style for table nodes. This is a dependency property.
TableRowCount | Gets or sets the default number of table rows.
TableRowHeight | Gets or sets the default height of tables' rows.
Theme | Gets or sets the theme associated with the diagram.
TreeViewNodeStyle | Gets or sets the theme-level style for treeview nodes. This is a dependency property.
UndoEnabled | Gets or sets a value indicating whether saving action records for later undo is enabled.
Viewport | Returns the visible portion of the diagram area.
ZoomFactor | Gets or sets the zoom factor used to scale up or down the Diagram.

See Also

Diagram Class


MindFusion.Diagramming.Diagram.ActiveItem Property

Diagram.ActiveItem Property
[image]

Gets or sets the active diagram element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem ActiveItem { get; set; }

Visual Basic [image] Copy Code

Public Property ActiveItem As DiagramItem

Property Value

A reference to the DiagramItem instance that is currently active.

Remarks

Use this property to get the active item - the one selected by the user or the last put in a multiple Selection.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ActiveItemHandlesStyle Property


MindFusion.Diagramming.Diagram.ActiveItemHandlesStyle Property

Diagram.ActiveItemHandlesStyle Property
[image]

Gets or sets the visual style of adjustment handles of the active item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HandlesVisualStyle ActiveItemHandlesStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ActiveItemHandlesStyle As HandlesVisualStyle

Property Value

An instance of the HandlesVisualStyle class.

Remarks

This style object provides stroke and fill attributes that let you customize the appearance of adjustment handles drawn around the active item.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ActiveItem Property


MindFusion.Diagramming.Diagram.ActiveLayer Property

Diagram.ActiveLayer Property
[image]

Gets or sets the zero-based index of the active layer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ActiveLayer { get; set; }

Visual Basic [image] Copy Code

Public Property ActiveLayer As Integer

Property Value

An integer value that specifies the index of the active layer.

Remarks

The LayerIndex of newly drawn items is automatically set to the value of this property.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Layers Property


MindFusion.Diagramming.Diagram.AdjustmentHandlesSize Property

Diagram.AdjustmentHandlesSize Property
[image]

Gets or sets the size of the handles, which appear around selected objects. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double AdjustmentHandlesSize { get; set; }

Visual Basic [image] Copy Code

Public Property AdjustmentHandlesSize As Double

Property Value

A double value specifying the size of selection handles. The default is 15.

Remarks

Use the property to set the size of the manipulation handles, which appear around selected items.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AlignmentGuidePen Property

Diagram.AlignmentGuidePen Property
[image]

Gets or sets the pen used to draw alignment guides. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen AlignmentGuidePen { get; set; }

Visual Basic [image] Copy Code

Public Property AlignmentGuidePen As Pen

Property Value

An instance of the Pen class.

Remarks

This pen is used to draw alignment guides shown when AutoAlignNodes is enabled.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AlignToGrid Property

Diagram.AlignToGrid Property
[image]

Gets or sets a value indicating whether the diagram items should be aligned to a grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AlignToGrid { get; set; }

Visual Basic [image] Copy Code

Public Property AlignToGrid As Boolean

Property Value

true if the grid is activated; otherwise, false. The default is true.

Remarks

When the property is set to true, the sides of every newly created diagram item are aligned to the nearest grid points.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AllowInplaceEdit Property

Diagram.AllowInplaceEdit Property
[image]

Gets or sets a value indicating whether in-place editing of the text of objects is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowInplaceEdit { get; set; }

Visual Basic [image] Copy Code

Public Property AllowInplaceEdit As Boolean

Property Value

true if in-place editing is allowed, otherwise false. The default is false.

Remarks

Specifies whether users are allowed to edit in-place text of diagram nodes. If enabled, a text-entry field appears at node's position when the node is double-clicked. In-place editing mode can be exited by clicking anywhere outside the text field. When this happens, the control raises NodeTextEdited if a DiagramNode has been edited, or LinkTextEdited if a DiagramLink has been edited.

To enter or exit in-place editing mode programmatically, use the BeginEdit and EndEdit methods of Diagram.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AllowMultipleResize Property

Diagram.AllowMultipleResize Property
[image]

Specifies whether multiple selected nodes can be resized simultaneously. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowMultipleResize { get; set; }

Visual Basic [image] Copy Code

Public Property AllowMultipleResize As Boolean

Property Value

true to let the user resize multiple selected nodes; otherwise, false. The default value is false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AllowUnconnectedLinks Property

Diagram.AllowUnconnectedLinks Property
[image]

Gets or sets a value indicating whether users are allowed to draw links that are not connected to any node. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowUnconnectedLinks { get; set; }

Visual Basic [image] Copy Code

Public Property AllowUnconnectedLinks As Boolean

Property Value

true to allow drawing unconnected links; otherwise, false. The default is false.

Remarks

If the property is set to true, users will be able to draw links from or to any point of the document. Depending on which end of a link is unconnected, its Origin or Destination nodes might be of type DummyNode.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AutoAlignDistance Property

Diagram.AutoAlignDistance Property
[image]

Gets or sets the maximal horizontal or vertical distance at which a node aligns to the borders ot other nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double AutoAlignDistance { get; set; }

Visual Basic [image] Copy Code

Public Property AutoAlignDistance As Double

Property Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AutoAlignNodes Property

Diagram.AutoAlignNodes Property
[image]

Gets or sets whether nodes should automatically align to the borders ot other nodes during user interaction.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoAlignNodes { get; set; }

Visual Basic [image] Copy Code

Public Property AutoAlignNodes As Boolean

Property Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AutoResize Property

Diagram.AutoResize Property
[image]

Gets or sets a value indicating whether the document area should be resized automatically so it fits the diagram contents.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AutoResize AutoResize { get; set; }

Visual Basic [image] Copy Code

Public Property AutoResize As AutoResize

Property Value

A member of the AutoResize enumeration. The default is RightAndDown.

Remarks

If automatic resizing is enabled, the size of the document scrollable area is updated each time an item is created, deleted or moved by the end-user. To resize the diagram after programmatic changes, call the ResizeToFitItems method.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Bounds Property
AutoScroll Property


MindFusion.Diagramming.Diagram.AutoScroll Property

Diagram.AutoScroll Property
[image]

Gets or sets a value indicating whether auto scrolling of the document area is enabled. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoScroll { get; set; }

Visual Basic [image] Copy Code

Public Property AutoScroll As Boolean

Property Value

true if the diagram should scroll automatically; otherwise, false. The default value is false.

Remarks

If enabled, the control will scroll its content automatically when the user drags the mouse near the viewport edges. This works only if the diagram is placed inside a ScrollViewer or a Ruler.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Bounds Property
AutoResize Property


MindFusion.Diagramming.Diagram.AutoSnapDistance Property

Diagram.AutoSnapDistance Property
[image]

Specifies the maximum distance at which links auto-snap to nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double AutoSnapDistance { get; set; }

Visual Basic [image] Copy Code

Public Property AutoSnapDistance As Double

Property Value

A double value specifying the maximum distance.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
AutoSnapLinks Property


MindFusion.Diagramming.Diagram.AutoSnapLinks Property

Diagram.AutoSnapLinks Property
[image]

Specifies whether link end points should automatically snap to the nearest diagram node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoSnapLinks { get; set; }

Visual Basic [image] Copy Code

Public Property AutoSnapLinks As Boolean

Property Value

true to snap links to nearest node, otherwise false; the default value is false.

Remarks

Only nodes at a distance smaller than AutoSnapDistance are considered. A link does not snap to its current origin or destination nodes if that would create a self-loop.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.BackBrush Property

Diagram.BackBrush Property
[image]

Gets or sets the brush used for painting the diagram background.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush BackBrush { get; set; }

Visual Basic [image] Copy Code

Public Property BackBrush As Brush

Property Value

Remarks

This property enables more spectacular background painting with effects such as gradients, textures and color patterns.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Behavior Property

Diagram.Behavior Property
[image]

Gets or sets a value indicating how the control responds to user actions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Behavior Behavior { get; set; }

Visual Basic [image] Copy Code

Public Property Behavior As Behavior

Property Value

A member of the Behavior enumeration. The default is LinkShapes.

Remarks

The property specifies how the control responds to user actions with the mouse. The default value, LinkShapes, facilitates drawing of flowchart diagrams. LinkTables causes creating table nodes and links while the user draws with the mouse, allowing creation of entity-relationship or class-hierarchy diagrams. There are several more values that can be assigned to the property, that make the control draw single types of items, for example only shape nodes, only control nodes, only links, and so on. These are useful when implementing the ability to select specific drawing tools in applications.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Bounds Property

Diagram.Bounds Property
[image]

Gets or sets a value representing the size of the diagram's scrollable area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect Bounds { get; set; }

Visual Basic [image] Copy Code

Public Property Bounds As Rect

Property Value

A Windows.UI.Xaml.Rect specifying the diagram size. The default is A4 size (210 x 297 millimeters).

Remarks

You should use this property to set the diagram size rather then Width and Height inherited from Control. Width and Height are automatically set to the Bounds dimensions combined with a scale transform derived from the MeasureUnit and ZoomFactor values.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ResizeToFitItems Method
AutoResize Property


MindFusion.Diagramming.Diagram.CanRedo Property

Diagram.CanRedo Property
[image]

Gets or sets a value indicating whether there is a command in the redo history which can be redone.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool CanRedo { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CanRedo As Boolean

Property Value

true if the undo queue contains operations that can be redone; otherwise, false.

Remarks

You can bind the IsEnabled property of menu items or buttons to this property.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Redo Method
CanUndo Property


MindFusion.Diagramming.Diagram.CanUndo Property

Diagram.CanUndo Property
[image]

Gets or sets a value indicating whether there is a command in the undo history which can be undone.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool CanUndo { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CanUndo As Boolean

Property Value

true if the undo queue contains operations that can be undone; otherwise, false.

Remarks

You can bind the IsEnabled property of menu items or buttons to this property.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Undo Method
CanRedo Property


MindFusion.Diagramming.Diagram.ContainerNodeStyle Property

Diagram.ContainerNodeStyle Property
[image]

Gets or sets the theme-level style for container nodes. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Style ContainerNodeStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ContainerNodeStyle As Style

Property Value

A Windows.UI.Xaml.Style instance.

Remarks

This property provides a shortcut for associating a style with the ContainerNode type in the current theme.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Styles and Themes


MindFusion.Diagramming.Diagram.ContainersFoldable Property

Diagram.ContainersFoldable Property
[image]

Gets or sets the default value for the Foldable property of containers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ContainersFoldable { get; set; }

Visual Basic [image] Copy Code

Public Property ContainersFoldable As Boolean

Property Value

A boolean value specifying whether containers are initially foldable. The default is true.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.CrossingRadius Property

Diagram.CrossingRadius Property
[image]

Gets or sets the radius length of decorations displayed at link intersection points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double CrossingRadius { get; set; }

Visual Basic [image] Copy Code

Public Property CrossingRadius As Double

Property Value

A double value specifying the radius of the arcs drawn at link intersection points.

Remarks

If LinkCrossings is set to Cut, link segments are cut at intersection points and this property defines the length of the break left between adjacent cut points. If LinkCrossings is set to Arcs, this property defines the radius of the arcs drawn over intersection points.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.CustomBehavior Property

Diagram.CustomBehavior Property
[image]

Gets or sets a custom behavior object specifying how DiagramRT responds to mouse input.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public BehaviorBase CustomBehavior { get; set; }

Visual Basic [image] Copy Code

Public Property CustomBehavior As BehaviorBase

Property Value

An instance of a BehaviorBase-derived class. The default value is null (Nothing in Visual Basic).

Remarks

DiagramRT provides several stock implementations of the BehaviorBase class that can be used by assigning a member of the Behavior enumeration to the diagram's Behavior property. Create a custom behavior class only if the predefined ones don't meet your application requirements.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.DefaultControlType Property

Diagram.DefaultControlType Property
[image]

Gets or sets the type of the controls that will be hosted by default in newly create ControlNode objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Type DefaultControlType { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultControlType As Type

Property Value

A reference to the System.Type that specifies a class of .NET controls to create.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.DefaultShape Property

Diagram.DefaultShape Property
[image]

Gets or sets the default shape of shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape DefaultShape { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultShape As Shape

Property Value

An instance of the Shape class. The default is the RoundRect shape.

Remarks

The Shape property of newly created shape nodes is initialized with the value of this property. It defines a series of lines, arcs and curves composed in a complex shape. There are 87 predefined shapes exposed as static members of the Shape class. You can also define your own shapes as shown below.

Example

The following example demonstrates how to create a custom shape and set it as a default in the diagram:

C# [image] Copy Code
private void example_Click(object sender, RoutedEventArgs e)
{
// Define a custom shape
// this is the same as: fc.DefaultShape = Shape.FromId("Tape");
diagram.DefaultShape = new Shape(
new ElementTemplate[] {
new LineTemplate(50, 100, 85, 100),
new LineTemplate(85, 100, 85, 90),
new LineTemplate(85, 90, 70, 90),
new BezierTemplate(70, 90, 85, 90, 100, 75, 100, 50),
new BezierTemplate(100, 50, 100, 25, 75, 0, 50, 0),
new BezierTemplate(50, 0, 25, 0, 0, 25, 0, 50),
new BezierTemplate(0, 50, 0, 75, 25, 100, 50, 100) },
FillRule.EvenOdd);
}
Visual Basic [image] Copy Code

Private Sub example_Click(ByVal sender As System.Object, ByVal e As System.Windows.RoutedEventArgs) Handles example.Click

' Define a custom shape
' this is the same as: fc.DefaultShape = Shape.FromId("Tape")
diagram.DefaultShape = New Shape( _
New ElementTemplate() { _
New LineTemplate(50, 100, 85, 100), _
New LineTemplate(85, 100, 85, 90), _
New LineTemplate(85, 90, 70, 90), _
New BezierTemplate(70, 90, 85, 90, 100, 75, 100, 50), _
New BezierTemplate(100, 50, 100, 25, 75, 0, 50, 0), _
New BezierTemplate(50, 0, 25, 0, 0, 25, 0, 50), _
New BezierTemplate(0, 50, 0, 75, 25, 100, 50, 100)}, _
FillRule.EvenOdd)

End Sub

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.DelKeyAction Property

Diagram.DelKeyAction Property
[image]

Gets or sets a value that specifies what action should be performed when the user hits the Del key.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DelKeyAction DelKeyAction { get; set; }

Visual Basic [image] Copy Code

Public Property DelKeyAction As DelKeyAction

Property Value

A member of the DelKeyAction enumeration. The default value is DeleteSelectedItems.

Remarks

Depending on this property value, the control can delete all selected items, delete only the active item, or ignore the Del key press. To prevent the user form deleting specific items, handle the NodeDeleting or LinkDeleting event and set e.Cancel = true if the selected item should not be deleted.

Set IsTabStop to false for the ScrollViewer that contains the Diagram control. Otherwise the diagram does not receive KeyDown events and cannot handle the Del key.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Selection Property
ActiveItem Property


MindFusion.Diagramming.Diagram.DiagramLinkStyle Property

Diagram.DiagramLinkStyle Property
[image]

Gets or sets the theme-level style for diagram links. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Style DiagramLinkStyle { get; set; }

Visual Basic [image] Copy Code

Public Property DiagramLinkStyle As Style

Property Value

A Windows.UI.Xaml.Style instance.

Remarks

This property provides a shortcut for associating a style with the DiagramLink type in the current theme.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Styles and Themes


MindFusion.Diagramming.Diagram.DisabledHandlesStyle Property

Diagram.DisabledHandlesStyle Property
[image]

Gets or sets the visual style of disabled adjustment handles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HandlesVisualStyle DisabledHandlesStyle { get; set; }

Visual Basic [image] Copy Code

Public Property DisabledHandlesStyle As HandlesVisualStyle

Property Value

An instance of the HandlesVisualStyle class.

Remarks

This style object provides stroke and fill attributes that let you customize the appearance of disabled adjustment handles.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
EnabledHandles Property


MindFusion.Diagramming.Diagram.DocumentPlane Property

Diagram.DocumentPlane Property
[image]

DocumentPlane is visual child of diagram and ancestor of all diagram items. The DocumentPlane element is translated with respect to Diagram element so that the point Diagram.Bounds.TopLeft from the DocumentPlane is rendered at Diagram element location (0,0). The coordinate system of the DocumentPlane is the document coordinate system. The intended use of this property is mainly in MouseMove event handling

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Panel DocumentPlane { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DocumentPlane As Panel

Property Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.DynamicLinks Property

Diagram.DynamicLinks Property
[image]

Gets or sets the default value for the Dynamic property of new links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool DynamicLinks { get; set; }

Visual Basic [image] Copy Code

Public Property DynamicLinks As Boolean

Property Value

Remarks

Use the property to specify whether links automatically reposition their end segments, so they keep pointing to the centers of connected nodes.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Enabled Property

Diagram.Enabled Property
[image]

Enables or disables handling of mouse events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Enabled { get; set; }

Visual Basic [image] Copy Code

Public Property Enabled As Boolean

Property Value

true to enable mouse input handling; otherwise, false. The default value is true.

Remarks

Setting this property to false is similar to Behavior.DoNothing, but in addition there aren't any item click events raised.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.EnableLanes Property

Diagram.EnableLanes Property
[image]

Gets or sets whether lanes are enabled. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableLanes { get; set; }

Visual Basic [image] Copy Code

Public Property EnableLanes As Boolean

Property Value

true to show the lane grid, otherwise false. The default value is false.

Remarks

You can customize the lane grid through the LaneGrid property.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ExpandButtonAction Property

Diagram.ExpandButtonAction Property
[image]

Gets or sets a value indicating what should happen when a user clicks the [+/-] button that is displayed near expandable nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ExpandButtonAction ExpandButtonAction { get; set; }

Visual Basic [image] Copy Code

Public Property ExpandButtonAction As ExpandButtonAction

Property Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ExpandButtonBrush Property

Diagram.ExpandButtonBrush Property
[image]

Gets or sets the brush used to fill expand/collapse buttons of nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush ExpandButtonBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ExpandButtonBrush As Brush

Property Value

A Windows.UI.Xaml.Media.Brush object used to fill the expand/collapse buttons.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ExpandButtonPosition Property
NodesExpandable Property


MindFusion.Diagramming.Diagram.ExpandButtonPosition Property

Diagram.ExpandButtonPosition Property
[image]

Gets or sets where expand/collapse buttons are located relatively to their nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ExpandButtonPosition ExpandButtonPosition { get; set; }

Visual Basic [image] Copy Code

Public Property ExpandButtonPosition As ExpandButtonPosition

Property Value

A member of the ExpandButtonPosition enumeration. The default is OuterRight.

Remarks

If diagram links tend to flow vertically, it would be useful to have the expand/collapse buttons stay at the left- or right-hand side of nodes. If diagram links tend to flow horizontally, choose position for expand buttons such that they stay above or below nodes. That will prevent button icons from being overlapped by links.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
NodesExpandable Property
ExpandButtonAction Property
ExpandButtonBrush Property


MindFusion.Diagramming.Diagram.ExpandButtonTemplate Property

Diagram.ExpandButtonTemplate Property
[image]

Gets or sets a custom ControlTemplate for the ExpandButton class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ControlTemplate ExpandButtonTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property ExpandButtonTemplate As ControlTemplate

Property Value

A ControlTemplate instance that defines the visual structure of the expand/collapse button.

Example

Xaml

<ControlTemplate x:Key="CustomExpandButton" TargetType="diag:ExpandButton">
<Border Background="#7DFFFFFF"
BorderBrush="#FF000000"
BorderThickness="1">
<VisualStateManager.VisualStateGroups>
<VisualStateGroup x:Name="States">
<VisualState x:Name="Expanded" />
<VisualState x:Name="Collapsed">
<Storyboard>
<ColorAnimation Duration="0"
Storyboard.TargetName="ExpanderRect"
Storyboard.TargetProperty="(Rectangle.Fill).(SolidColorBrush.Color)"
To="#FFFF0000"/>
</Storyboard>
</VisualState>
</VisualStateGroup>
</VisualStateManager.VisualStateGroups>
<Rectangle x:Name="ExpanderRect"
Height="5" Width="5" Fill="#FF00FF00" />
</Border>
</ControlTemplate>

<diag:Diagram Name="diagram" ExpandButtonTemplate="{StaticResource CustomExpandButton}"

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
NodesExpandable Property


MindFusion.Diagramming.Diagram.ExpandOnIncoming Property

Diagram.ExpandOnIncoming Property
[image]

Gets or sets a value, indicating in which direction object hierarchies are expanded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ExpandOnIncoming { get; set; }

Visual Basic [image] Copy Code

Public Property ExpandOnIncoming As Boolean

Property Value

Remarks

Use this property when presenting tree structures with enabled collapse/expand.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Factory Property

Diagram.Factory Property
[image]

Gets a Factory instance that lets you add programmatically new items to the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Factory Factory { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Factory As Factory

Property Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GridColor Property

Diagram.GridColor Property
[image]

Gets or sets the color of the grid points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color GridColor { get; set; }

Visual Basic [image] Copy Code

Public Property GridColor As Color

Property Value

An instance of the Windows.UI.Xaml.Media.Color structure. The default is Color.FromArgb(140, 140, 150).

Remarks

Use the property to specify the color of grid points and lines.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GridDashArray Property

Diagram.GridDashArray Property
[image]

Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to draw grid lines. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DoubleCollection GridDashArray { get; set; }

Visual Basic [image] Copy Code

Public Property GridDashArray As DoubleCollection

Property Value

A Windows.UI.Xaml.Media.DoubleCollection instance.

Remarks

The dash style defined by this collection is applied to grid lines drawn when GridStyle is set to Lines.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ShowGrid Property
GridColor Property


MindFusion.Diagramming.Diagram.GridOffsetX Property

Diagram.GridOffsetX Property
[image]

Gets or sets the horizontal offset of the first point of the alignment grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double GridOffsetX { get; set; }

Visual Basic [image] Copy Code

Public Property GridOffsetX As Double

Property Value

A double value that specifies the horizontal grid offset. The default is Double.NaN.

Remarks

The property specifies the offset of the first point of the alignment grid.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GridOffsetY Property

Diagram.GridOffsetY Property
[image]

Gets or sets the vertical offset of the first point of the alignment grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double GridOffsetY { get; set; }

Visual Basic [image] Copy Code

Public Property GridOffsetY As Double

Property Value

A double value that specifies the vertical grid offset. The default is Double.NaN.

Remarks

The property specifies the offset of the first point of the alignment grid.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GridPointSize Property

Diagram.GridPointSize Property
[image]

Gets or sets the size of shapes used to represent grid points. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double GridPointSize { get; set; }

Visual Basic [image] Copy Code

Public Property GridPointSize As Double

Property Value

The size of shapes drawn at grid points. The default value is 5.

Remarks

Currently this value is used only when GridStyle is set to Crosses.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ShowGrid Property
GridColor Property


MindFusion.Diagramming.Diagram.GridSizeX Property

Diagram.GridSizeX Property
[image]

Gets or sets the horizontal distance between adjacent grid points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double GridSizeX { get; set; }

Visual Basic [image] Copy Code

Public Property GridSizeX As Double

Property Value

A double number specifying the horizontal distance between grid points. The default is 4.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GridSizeY Property

Diagram.GridSizeY Property
[image]

Gets or sets the vertical distance between adjacent grid points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double GridSizeY { get; set; }

Visual Basic [image] Copy Code

Public Property GridSizeY As Double

Property Value

A double number specifying the vertical distance between grid points. The default is 4.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GridStyle Property

Diagram.GridStyle Property
[image]

Gets or sets the visual style of the alignment grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GridStyle GridStyle { get; set; }

Visual Basic [image] Copy Code

Public Property GridStyle As GridStyle

Property Value

A member of the GridStyle enumeration. The default is Points.

Remarks

Specifies how the alignment grid is drawn. If the property value is set to Points, the grid is painted as a matrix of points. If set to Lines, the grid is represented as a series of crossing horizontal and vertical lines. Grid points or lines are painted with the color set in GridColor; the distance between them is specified by the GridSizeX and GridSizeY properties.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.HitTestPriority Property

Diagram.HitTestPriority Property
[image]

Gets or sets a value indicating the order in which items are hit-tested.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HitTestPriority HitTestPriority { get; set; }

Visual Basic [image] Copy Code

Public Property HitTestPriority As HitTestPriority

Property Value

A member of the HitTestPriority enumeration. The default value is NodesBeforeLinks.

Remarks

For easier selection, links have a hit-detection area several pixels wider than their visible segment lines. However, if several links with higher z-index cross a node, it would be difficult to select it. The HitTestPriority property allows altering hit-test results in such situations. If set to NodesBeforeLinks, nodes are hit-tested before all links. ZOrder makes all items tested in decreasing z-order, independently of their type.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.InplaceEditAcceptOnEnter Property

Diagram.InplaceEditAcceptOnEnter Property
[image]

Gets or sets a value indicating whether pressing the ENTER key should exit in-place editing mode and accept changes made to text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool InplaceEditAcceptOnEnter { get; set; }

Visual Basic [image] Copy Code

Public Property InplaceEditAcceptOnEnter As Boolean

Property Value

true to accept changes and exit in-place editing mode when ENTER is pressed; otherwise, false. The default is false.

Remarks

If the value of this property is false, pressing the ENTER key inserts a new line in the text while in-place editing mode is active.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.InplaceEditCancelOnEsc Property

Diagram.InplaceEditCancelOnEsc Property
[image]

Gets or sets a value indicating whether pressing the ESC key should exit inplace-edit mode and reject changes made to text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool InplaceEditCancelOnEsc { get; set; }

Visual Basic [image] Copy Code

Public Property InplaceEditCancelOnEsc As Boolean

Property Value

true to reject changes and exit in-place editing mode when ESC is pressed; otherwise, false. The default is true.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Interaction Property

Diagram.Interaction Property
[image]

Gets an InteractionState instance representing the current action being carried out by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public InteractionState Interaction { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Interaction As InteractionState

Property Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Items Property

Diagram.Items Property
[image]

Represents a strongly typed collection of DiagramItem objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemCollection Items { get; set; }

Visual Basic [image] Copy Code

Public Property Items As DiagramItemCollection

Property Value

An instance of the DiagramItemCollection class.

Remarks

This collection gives you access to all items contained in this document. You can also use it to add new items to the diagram.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LaneGrid Property

Diagram.LaneGrid Property
[image]

Gets the Grid instance that represents the lane grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Grid LaneGrid { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LaneGrid As Grid

Property Value

Remarks

The Grid object gives you full control over the lane grid. For example, it lets you set the number of rows and columns in the grid, add headers, customize the appearance, subscribe to events and so on.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Layers Property

Diagram.Layers Property
[image]

Gets a list of the layers in the current diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IList<Layer> Layers { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Layers As IList(Of Layer)

Property Value

A list of Layer objects.

Remarks

Diagram items are associated with elements of this collection via their LayerIndex property.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Layers
ActiveLayer Property


MindFusion.Diagramming.Diagram.LicenseKey Property

Diagram.LicenseKey Property
[image]

Gets or sets the license key of the control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string LicenseKey { get; set; }

Visual Basic [image] Copy Code

Public Property LicenseKey As String

Property Value

A string containing the license key.

Remarks

Set this property to disable the component's evaluation mode and stop displaying trial messages. If your application contains more than one Diagram instance or other controls by MindFusion, you could call the MindFusion.Licensing.LicenseManager.AddLicense method to specify the key once instead of setting it per each control.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkBaseShape Property

Diagram.LinkBaseShape Property
[image]

Gets or sets the shape displayed at the base of new links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape LinkBaseShape { get; set; }

Visual Basic [image] Copy Code

Public Property LinkBaseShape As Shape

Property Value

A Shape instance that represents an arrowhead shape. The default is None.

Remarks

This property specifies the default shape displayed as arrowhead at the links' origin points. The ArrowHeads class exposes several predefined shapes as static properties.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkBaseShapeSize Property

Diagram.LinkBaseShapeSize Property
[image]

Gets or sets the default size of the base of new links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LinkBaseShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property LinkBaseShapeSize As Double

Property Value

A double value that specifies the size. The default is 5.

Remarks

The property specifies the size of the graphical shapes that are displayed at the start of new diagram links, for example, at the beginning of the links.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkBrush Property

Diagram.LinkBrush Property
[image]

Gets or sets the default value for the Brush property of links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush LinkBrush { get; set; }

Visual Basic [image] Copy Code

Public Property LinkBrush As Brush

Property Value

An instance of a .NET Windows.UI.Xaml.Media.Brush-derived class.

Remarks

The property provides a default value for the brush, with which an arrowhead's interior is filled.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkCrossings Property

Diagram.LinkCrossings Property
[image]

Gets or sets how to render the intersection points where links cross their paths.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkCrossings LinkCrossings { get; set; }

Visual Basic [image] Copy Code

Public Property LinkCrossings As LinkCrossings

Property Value

A member of the LinkCrossings enumeration. The default is Straight.

Remarks

Intersection points where links cross each other's paths can be rendered as arcs or breaks, depending on the value of this property. The z-order defines which links jump over the others or which links are cut by the others. If LinkCrossings is set to Arcs, links with higher ZIndex jump over those with lower ZIndex. If set to Cut, segments of links at lower z-position are cut by links at higher z-position. Radius of arcs and breaks can be set by the CrossingRadius property.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkHeadShape Property

Diagram.LinkHeadShape Property
[image]

Gets or sets the shape displayed as head of new links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape LinkHeadShape { get; set; }

Visual Basic [image] Copy Code

Public Property LinkHeadShape As Shape

Property Value

A Shape instance that represents an arrowhead shape. The default is Arrow.

Remarks

This property specifies the default shape displayed as arrowhead at the links' end points. The ArrowHeads class exposes several predefined shapes as static properties.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkHeadShapeSize Property

Diagram.LinkHeadShapeSize Property
[image]

Gets or sets the default size of arrowheads.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LinkHeadShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property LinkHeadShapeSize As Double

Property Value

A double value that measures the size. The default is 5.

Remarks

The property specifies how big the shapes of new arrowheads are.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkIntermediateShape Property

Diagram.LinkIntermediateShape Property
[image]

Gets or sets default shape to be displayed in the middle of each segment of links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape LinkIntermediateShape { get; set; }

Visual Basic [image] Copy Code

Public Property LinkIntermediateShape As Shape

Property Value

A Shape instance that represents an arrowhead shape. The default is None.

Remarks

The property specifies default shape to be displayed at the middle of each segment of new links. It facilitates users by following the path of a link across the diagram, especially for longer links in large documents. The ArrowHeads class exposes several predefined shapes as static properties.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkIntermediateShapeSize Property

Diagram.LinkIntermediateShapeSize Property
[image]

Gets or sets the default size of the shapes at middles of link segments.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LinkIntermediateShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property LinkIntermediateShapeSize As Double

Property Value

A double value that measures the size. The default is 5.

Remarks

Specifies default value for the IntermediateShapeSize property of new links.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkPen Property

Diagram.LinkPen Property
[image]

Gets or sets the default value for the Pen property of links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen LinkPen { get; set; }

Visual Basic [image] Copy Code

Public Property LinkPen As Pen

Property Value

An instance of the Pen class.

Remarks

This property specifies the default value for the Pen property of new links.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkRouter Property

Diagram.LinkRouter Property
[image]

Gets or sets the component used to find paths for auto-routed links when diagram nodes are added or their positions change.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ILinkRouter LinkRouter { get; set; }

Visual Basic [image] Copy Code

Public Property LinkRouter As ILinkRouter

Property Value

An instance of a class implementing the ILinkRouter interface. The currently available implementations incude GridRouter and QuickRouter.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Links Property

Diagram.Links Property
[image]

Gets a DiagramLinkCollection containing the links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection Links { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Links As DiagramLinkCollection

Property Value

An instance of the DiagramLinkCollection class.

Remarks

Links provides type-safe access to all links in the current diagram. Any diagram element can be accessed also by the DiagramItemCollection.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkSegments Property

Diagram.LinkSegments Property
[image]

Gets or sets the default number of link segments.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int LinkSegments { get; set; }

Visual Basic [image] Copy Code

Public Property LinkSegments As Integer

Property Value

An integer value specifying how many segments links consists of. The default is 1.

Remarks

Use the property to create more indented links, when necessary.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkShape Property

Diagram.LinkShape Property
[image]

Gets or sets the default style of diagram links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkShape LinkShape { get; set; }

Visual Basic [image] Copy Code

Public Property LinkShape As LinkShape

Property Value

A member of the LinkShape enumeration. The default value is Polyline.

Remarks

Use this property to specify what kind of segments new links are composed of. The segments of a link could be Bezier curves or straight lines, and they can be restricted to be horizontal / vertical only.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.MeasureUnit Property

Diagram.MeasureUnit Property
[image]

Gets or sets the unit of measure used for logical coordinates in this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GraphicsUnit MeasureUnit { get; set; }

Visual Basic [image] Copy Code

Public Property MeasureUnit As GraphicsUnit

Property Value

An instance of the GraphicsUnit class.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ChangeUnit Method


MindFusion.Diagramming.Diagram.ModificationStart Property

Diagram.ModificationStart Property
[image]

Gets or sets how users can start modifying diagram items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ModificationStart ModificationStart { get; set; }

Visual Basic [image] Copy Code

Public Property ModificationStart As ModificationStart

Property Value

A member of the ModificationStart enumeration. The default is SelectedOnly.

Remarks

Use this property to specify what should users do in order to start item modification.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.NodeEffects Property

Diagram.NodeEffects Property
[image]

Gets a collection with all effects applied to the nodes of this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IList<NodeEffect> NodeEffects { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NodeEffects As IList(Of NodeEffect)

Property Value

A list of NodeEffect objects.

Remarks

Effects from this collection are applied to each node in the diagram, unless the node's own Effects collection starts with a null element.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Node Effects


MindFusion.Diagramming.Diagram.Nodes Property

Diagram.Nodes Property
[image]

Gets a DiagramNodeCollection containing the nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeCollection Nodes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Nodes As DiagramNodeCollection

Property Value

An instance of the DiagramNodeCollection class.

Remarks

Nodes provides type-safe access to all nodes in the current diagram. Any diagram element can be accessed also by using the DiagramItemCollection.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.NodesExpandable Property

Diagram.NodesExpandable Property
[image]

Gets or sets a value indicating whether newly created nodes can be expanded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool NodesExpandable { get; set; }

Visual Basic [image] Copy Code

Public Property NodesExpandable As Boolean

Property Value

A boolean value assigned to the Expandable property of new nodes. The default is false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ExpandButtonTemplate Property


MindFusion.Diagramming.Diagram.OverrideCursor Property

Diagram.OverrideCursor Property
[image]

Sets the cursor and stops changing it depending on the context.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Cursor OverrideCursor { get; set; }

Visual Basic [image] Copy Code

Public Property OverrideCursor As Cursor

Property Value

A Windows.UI.Xaml.Input.Cursor instance. The default value is null (Nothing in Visual Basic).

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.PrintOptions Property

Diagram.PrintOptions Property
[image]

Gets an object which provides customization properties for printed diagrams.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PrintOptions PrintOptions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PrintOptions As PrintOptions

Property Value

An instance of the PrintOptions class.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Print Method


MindFusion.Diagramming.Diagram.RecursiveExpand Property

Diagram.RecursiveExpand Property
[image]

Gets or sets value indicating how a tree is expanded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RecursiveExpand { get; set; }

Visual Basic [image] Copy Code

Public Property RecursiveExpand As Boolean

Property Value

Remarks

Use the property when representing tree structures, which hide some of their elements.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RoundedLinks Property

Diagram.RoundedLinks Property
[image]

Gets or sets a value indicating whether the joins between segments of Polyline and Cascading links should be rounded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RoundedLinks { get; set; }

Visual Basic [image] Copy Code

Public Property RoundedLinks As Boolean

Property Value

true to render rounded segment joins; otherwise, false. The default is false.

Remarks

The value of this property is considered when drawing links whose Shape is set to Polyline or Cascading. If the property is enabled, the joins between the segments of all such links are drawn as arcs, whose radius equals the value of RoundedLinksRadius.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramLink.Shape Property
LinkCrossings Property


MindFusion.Diagramming.Diagram.RoundedLinksRadius Property

Diagram.RoundedLinksRadius Property
[image]

Gets or sets the radius of arc joins of rounded links' segments.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double RoundedLinksRadius { get; set; }

Visual Basic [image] Copy Code

Public Property RoundedLinksRadius As Double

Property Value

The radius of arcs drawn at segment joins. The default value is 10.

Remarks

The value of this property is used when RoundedLinks is enabled. It specifies the radius of the arcs drawn as joins between link segments.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
CrossingRadius Property


MindFusion.Diagramming.Diagram.RouteLinks Property

Diagram.RouteLinks Property
[image]

Gets or sets a value indicating whether links should avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RouteLinks { get; set; }

Visual Basic [image] Copy Code

Public Property RouteLinks As Boolean

Property Value

true to route links around nodes, otherwise false. The default value is false.

Remarks

This value is assigned to the AutoRoute property of new links.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LinkRouted Event


MindFusion.Diagramming.Diagram.RoutingOptions Property

Diagram.RoutingOptions Property
[image]

Gets an object, which allows customizing various parameters of the link routing algorithm.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RoutingOptions RoutingOptions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RoutingOptions As RoutingOptions

Property Value

An instance of the RoutingOptions class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ScrollX Property

Diagram.ScrollX Property
[image]

Gets or sets the document's X scroll position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ScrollX { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollX As Double

Property Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ScrollY Property

Diagram.ScrollY Property
[image]

Gets or sets the document's Y scroll position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ScrollY { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollY As Double

Property Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ScrollZoneSize Property

Diagram.ScrollZoneSize Property
[image]

Gets or sets the size of the auto scroll zone near the edges of the control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ScrollZoneSize { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollZoneSize As Integer

Property Value

An integer specifying the size in pixels of the area near the view edges where auto-scrolling is triggered. The default value is 8.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
AutoScroll Property


MindFusion.Diagramming.Diagram.SelectedItemHandlesStyle Property

Diagram.SelectedItemHandlesStyle Property
[image]

Gets or sets the visual style of adjustment handles of selected items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HandlesVisualStyle SelectedItemHandlesStyle { get; set; }

Visual Basic [image] Copy Code

Public Property SelectedItemHandlesStyle As HandlesVisualStyle

Property Value

An instance of the HandlesVisualStyle class.

Remarks

This style object provides stroke and fill attributes that let you customize the appearance of adjustment handles drawn around selected items.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Selection Property


MindFusion.Diagramming.Diagram.Selection Property

Diagram.Selection Property
[image]

Gets the Selection instance that represents the selection of items in this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Selection Selection { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Selection As Selection

Property Value

An instance of the Selection class representing the current selection.

Remarks

Use this property to get the items currently selected by a user. Items can be enumerated by the Items member of the Selection class. An item from the selection is considered the active one and can be accessed by using ActiveItem.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SelectedItemHandlesStyle Property


MindFusion.Diagramming.Diagram.ShapeBrush Property

Diagram.ShapeBrush Property
[image]

Gets or sets the default value for the Brush property of shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush ShapeBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeBrush As Brush

Property Value

An instance of a .NET Windows.UI.Xaml.Media.Brush-derived class.

Remarks

The property provides a default value for the brush, with which a node' interior is filled.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ShapeHandlesStyle Property

Diagram.ShapeHandlesStyle Property
[image]

Gets or sets the default value for the HandlesStyle property of new shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HandlesStyle ShapeHandlesStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeHandlesStyle As HandlesStyle

Property Value

Remarks

This property provides default value for the HandlesStyle property of new shape nodes, created either programmatically or by the user.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ShapeNodeStyle Property

Diagram.ShapeNodeStyle Property
[image]

Gets or sets the theme-level style for shape nodes. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Style ShapeNodeStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeNodeStyle As Style

Property Value

A Windows.UI.Xaml.Style instance.

Remarks

This property provides a shortcut for associating a style with the ShapeNode type in the current theme.

Example

Xaml [image] Copy Code

<diag:Diagram Name="diagram"
DefaultShape="Rectangle">
<diag:Diagram.ShapeNodeStyle>
<Style TargetType="diag:ShapeNode">
<Setter Property="Brush" Value="LightBlue" />
</Style>
</diag:Diagram.ShapeNodeStyle>
</diag:Diagram>

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Styles and Themes


MindFusion.Diagramming.Diagram.ShapePen Property

Diagram.ShapePen Property
[image]

Gets or sets the default value for the Pen property of new ShapeNode objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen ShapePen { get; set; }

Visual Basic [image] Copy Code

Public Property ShapePen As Pen

Property Value

An instance of the Pen class.

Remarks

This property provides a default value for the pen with which shape nodes border lines are painted.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ShowAnchors Property

Diagram.ShowAnchors Property
[image]

Gets or sets a value indicating whether and when node anchor points should be displayed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShowAnchors ShowAnchors { get; set; }

Visual Basic [image] Copy Code

Public Property ShowAnchors As ShowAnchors

Property Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ShowGrid Property

Diagram.ShowGrid Property
[image]

Gets or sets a value indicating whether the alignment grid is visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ShowGrid { get; set; }

Visual Basic [image] Copy Code

Public Property ShowGrid As Boolean

Property Value

true if the grid is visible; otherwise, false. The default is false.

Remarks

If it is visible, the grid is painted as either a matrix of points or crossing horizontal and vertical lines. That depends on the value of GridStyle.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TableBrush Property

Diagram.TableBrush Property
[image]

Gets or sets the default value for the Brush property of tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush TableBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TableBrush As Brush

Property Value

Remarks

The property provides a default value for the brush, with which a table' interior is filled.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TableCaption Property

Diagram.TableCaption Property
[image]

Gets or sets the default text for tables' captions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string TableCaption { get; set; }

Visual Basic [image] Copy Code

Public Property TableCaption As String

Property Value

Remarks

The Caption property of new tables is initialized with the value of TableCaption.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TableCaptionHeight Property

Diagram.TableCaptionHeight Property
[image]

Gets or sets the default height of table captions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double TableCaptionHeight { get; set; }

Visual Basic [image] Copy Code

Public Property TableCaptionHeight As Double

Property Value

Remarks

The value of this property is used to initialize the CaptionHeight property of new tables.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TableColumnCount Property

Diagram.TableColumnCount Property
[image]

Gets or sets the default number of table columns.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int TableColumnCount { get; set; }

Visual Basic [image] Copy Code

Public Property TableColumnCount As Integer

Property Value

Remarks

This value is used to initialize the ColumnCount property of new tables.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TableColumnWidth Property

Diagram.TableColumnWidth Property
[image]

Gets or sets the default width of tables' columns.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double TableColumnWidth { get; set; }

Visual Basic [image] Copy Code

Public Property TableColumnWidth As Double

Property Value

Remarks

This property is used to initialize the ColumnWidth property of new tables.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TableNodeStyle Property

Diagram.TableNodeStyle Property
[image]

Gets or sets the theme-level style for table nodes. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Style TableNodeStyle { get; set; }

Visual Basic [image] Copy Code

Public Property TableNodeStyle As Style

Property Value

A Windows.UI.Xaml.Style instance.

Remarks

This property provides a shortcut for associating a style with the TableNode type in the current theme.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Styles and Themes


MindFusion.Diagramming.Diagram.TableRowCount Property

Diagram.TableRowCount Property
[image]

Gets or sets the default number of table rows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int TableRowCount { get; set; }

Visual Basic [image] Copy Code

Public Property TableRowCount As Integer

Property Value

Remarks

Use the property to set the initial number of rows for newly created tables.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TableRowHeight Property

Diagram.TableRowHeight Property
[image]

Gets or sets the default height of tables' rows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double TableRowHeight { get; set; }

Visual Basic [image] Copy Code

Public Property TableRowHeight As Double

Property Value

Remarks

TableRowHeight is used to initialize the RowHeight property of new tables.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Theme Property

Diagram.Theme Property
[image]

Gets or sets the theme associated with the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Theme Theme { get; set; }

Visual Basic [image] Copy Code

Public Property Theme As Theme

Property Value

An instance of the Theme class.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Styles and Themes


MindFusion.Diagramming.Diagram.TreeViewNodeStyle Property

Diagram.TreeViewNodeStyle Property
[image]

Gets or sets the theme-level style for treeview nodes. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Style TreeViewNodeStyle { get; set; }

Visual Basic [image] Copy Code

Public Property TreeViewNodeStyle As Style

Property Value

A Windows.UI.Xaml.Style instance.

Remarks

This property provides a shortcut for associating a style with the TreeViewNode type in the current theme.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Styles and Themes


MindFusion.Diagramming.Diagram.UndoEnabled Property

Diagram.UndoEnabled Property
[image]

Gets or sets a value indicating whether saving action records for later undo is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool UndoEnabled { get; set; }

Visual Basic [image] Copy Code

Public Property UndoEnabled As Boolean

Property Value

true to save actions for later undo; otherwise false. The default is false.

Remarks

To undo the last recorded action, call the Undo method. It can be redone again by calling Redo. Custom operations can be integrated into the DiagramRT undo/redo system by deriving from the Command class and running the operations by means of the ExecuteCommand method.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
StartCompositeOperation Method


MindFusion.Diagramming.Diagram.Viewport Property

Diagram.Viewport Property
[image]

Returns the visible portion of the diagram area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect Viewport { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Viewport As Rect

Property Value

A Windows.UI.Xaml.Rect instance.

Remarks

When the Diagram is placed inside a ScrollViewer, this property returns what part of the diagram is currently visible within the viewer.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ZoomFactor Property

Diagram.ZoomFactor Property
[image]

Gets or sets the zoom factor used to scale up or down the Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ZoomFactor { get; set; }

Visual Basic [image] Copy Code

Public Property ZoomFactor As Double

Property Value

A double value specifying percent of the original diagram size. The default is 100.

Remarks

Use the property to set how far the diagram items should look. Values smaller than 100 make items appear further, bigger than 100 - nearer. The default value is 100, specifying that no scaling transformation is applied.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ZoomControl Class
MagnifierFactor Property


MindFusion.Diagramming.Diagram Events

Diagram Events
[image]

Inherited Public Events

Name | Description
ActionRedone | Raised when an action is redone. (Inherited from DiagramBase.)
ActionUndone | Raised when an action is undone. (Inherited from DiagramBase.)
ActiveLayerChanged | Raised when the diagram's active layer has changed. (Inherited from DiagramBase.)
BoundsChanged | Raised when the Bounds property value has changed. (Inherited from DiagramBase.)
CellClicked | Raised when the user clicks a table's cell. (Inherited from DiagramBase.)
CellDoubleClicked | Raised when the user double-clicks a table's cell. (Inherited from DiagramBase.)
Clicked | Raised when the user clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area. (Inherited from DiagramBase.)
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area. (Inherited from DiagramBase.)
DeserializeControl | Lets you load the attributes of controls hosted inside ControlNodes. (Inherited from DiagramBase.)
DeserializeTag | Raised when the Tag or Id of a diagram item must be deserialized from XML format. (Inherited from DiagramBase.)
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
DrawAdjustmentHandles | Raised when item's adjustment handles must be custom drawn. (Inherited from DiagramBase.)
EnterInplaceEditMode | Raised when entering inplace-edit mode. (Inherited from DiagramBase.)
ExpandButtonClicked | Raised when the user clicks the [+/-] button of an Expandable node. (Inherited from DiagramBase.)
HitTestAdjustmentHandles | Raised when custom hit testing of item's adjustment handles must be performed. (Inherited from DiagramBase.)
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created. (Inherited from DiagramBase.)
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created. (Inherited from DiagramBase.)
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
LaneGridCellCreated | Raised when a lane grid's cell has been created to allow additional cusomtization of its presentation. (Inherited from DiagramBase.)
LaneGridHeaderCreated | Raised when a lane grid's header has been created to allow additional cusomtization of its presentation. (Inherited from DiagramBase.)
LeaveInplaceEditMode | Raised when leaving inplace-edit mode. (Inherited from DiagramBase.)
LinkActivated | Raised when a link becomes the ActiveItem. (Inherited from DiagramBase.)
LinkClicked | Raised when the user clicks a link. (Inherited from DiagramBase.)
LinkCreated | Raised when the user draws a new link. (Inherited from DiagramBase.)
LinkCreating | A validation event raised while the user is drawing a new link. (Inherited from DiagramBase.)
LinkDeactivated | Raised when a link is no longer the ActiveItem. (Inherited from DiagramBase.)
LinkDeleted | Raised when a link is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkDeselected | Raised when a link is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDoubleClicked | Raised when the user double-clicks a link. (Inherited from DiagramBase.)
LinkModified | Raised when the user moves any control point of a link. (Inherited from DiagramBase.)
LinkModifying | A validation event raised while the user is modifying a link. (Inherited from DiagramBase.)
LinkPasted | Raised when a link has been pasted from the clipboard. (Inherited from DiagramBase.)
LinkRouted | Raised when a link is routed by the auto-routing algorithm. (Inherited from DiagramBase.)
LinkSelected | Raised when a link is selected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkTextEdited | Raised when the user edits the text of a link. (Inherited from DiagramBase.)
MagnifierFactorChanged | Occurs when the magnifier factor changes. (Inherited from DiagramBase.)
MeasureUnitChanged | Raised when the MeasureUnit property value has changed. (Inherited from DiagramBase.)
NodeActivated | Raised when a node becomes the ActiveItem. (Inherited from DiagramBase.)
NodeClicked | Raised when the user clicks a node. (Inherited from DiagramBase.)
NodeCreated | Occurs when the user draws a new node. (Inherited from DiagramBase.)
NodeCreating | A validation event raised while the user is drawing a new node. (Inherited from DiagramBase.)
NodeDeactivated | Raised when a node is no longer the ActiveItem. (Inherited from DiagramBase.)
NodeDeleted | Raised when a node is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeDeselected | Raised when a node is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDoubleClicked | Raised when the user double-clicks a node. (Inherited from DiagramBase.)
NodeModified | Raised when the user moves or resizes a node. (Inherited from DiagramBase.)
NodeModifying | A validation event raised while the user is moving or resizing a node. (Inherited from DiagramBase.)
NodePasted | Raised when a node has been pasted from the clipboard. (Inherited from DiagramBase.)
NodeSelected | Raised when a node is selected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeTextEdited | Raised when the user edits the text of a node. (Inherited from DiagramBase.)
Repaint | Raised when the diagram views should be repainted. (Inherited from DiagramBase.)
SelectionChanged | Raised when an item is added to or removed from the selection. (Inherited from DiagramBase.)
SelectionModified | Raised when the user moves or resizes multiple selected items. (Inherited from DiagramBase.)
SelectionModifying | Raised while the user is moving or resizing multiple selected items, this event lets you cancel the modification. (Inherited from DiagramBase.)
SerializeControl | Lets you save the attributes of controls hosted inside ControlNodes. (Inherited from DiagramBase.)
SerializeTag | Raised when the Tag of a diagram item must be serialized into an XML document. (Inherited from DiagramBase.)
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape. (Inherited from DiagramBase.)
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node. (Inherited from DiagramBase.)
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node. (Inherited from DiagramBase.)
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point. (Inherited from DiagramBase.)
ZoomFactorChanged | Occurs when the zoom factor changes. (Inherited from DiagramBase.)

See Also

Diagram Class


MindFusion.Diagramming.DiagramBase Class

DiagramBase Class
[image]

The base class of the Diagram and DiagramDocument classes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class DiagramBase : ContentControl

Visual Basic [image] Copy Code

Public MustInherit Class DiagramBase
Inherits ContentControl

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
Windows.UI.Xaml.Controls.ContentControl
MindFusion.Diagramming.DiagramBase
MindFusion.Diagramming.Diagram
MindFusion.Diagramming.DiagramDocument

See Also

DiagramBase Members


MindFusion.Diagramming.DiagramBase Members

DiagramBase Members
Constructors Methods Events
[image]

The base class of the Diagram and DiagramDocument classes.

The following tables list the members exposed by the DiagramBase type.

Protected Constructors

Name | Description
DiagramBase | Initializes a new instance of the DiagramBase class.

Protected Methods

Name | Description
OnActionRedone | Raises the ActionRedone event.
OnActionUndone | Raises the ActionUndone event.
OnBoundsChanged | Raises the BoundsChanged event.
OnCellClicked | Raises the CellClicked event.
OnCellDoubleClicked | Raises the CellDoubleClicked event.
OnClicked | Raises the Clicked event.
OnContainerChildAdded | Raises the ContainerChildAdded event.
OnContainerChildRemoved | Raises the ContainerChildRemoved event.
OnContainerFolded | Raises the ContainerFolded event.
OnContainerUnfolded | Raises the ContainerUnfolded event.
OnDeserializeControl | Raises the DeserializeControl event.
OnDeserializeTag | Raises the DeserializeTag event.
OnDoubleClicked | Raises the DoubleClicked event.
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event.
OnEnterInplaceEditMode | Raises the EnterInplaceEditMode event.
OnExpandButtonClicked | Raises the ExpandButtonClicked event.
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event.
OnInitializeLink | Raises the InitializeLink event.
OnInitializeNode | Raises the InitializeNode event.
OnItemAdded | Raises the ItemAdded event.
OnItemRemoved | Raises the ItemRemoved event.
OnLaneGridCellCreated | Raises the LaneGridCellCreated event.
OnLaneGridHeaderCreated | Raises the LaneGridHeaderCreated event.
OnLeaveInplaceEditMode | Raises the LeaveInplaceEditMode event.
OnLinkActivated | Raises the LinkActivated event.
OnLinkClicked | Raises the LinkClicked event.
OnLinkCreated | Raises the LinkCreated event.
OnLinkCreating | Raises the LinkCreating event.
OnLinkDeactivated | Raises the LinkDeactivated event.
OnLinkDeleted | Raises the LinkDeleted event.
OnLinkDeleting | Raises the LinkDeleting event.
OnLinkDeselected | Raises the LinkDeselected event.
OnLinkDoubleClicked | Raises the LinkDoubleClicked event.
OnLinkModified | Raises the LinkModified event.
OnLinkModifying | Raises the LinkModifying event.
OnLinkPasted | Raises the LinkPasted event.
OnLinkRouted | Raises the LinkRouted event.
OnLinkSelected | Raises the LinkSelected event.
OnLinkTextEdited | Raises the LinkTextEdited event.
OnMagnifierFactorChanged | Raises the MagnifierFactorChanged event.
OnMeasureUnitChanged | Raises the MeasureUnitChanged event.
OnNodeActivated | Raises the NodeActivated event.
OnNodeClicked | Raises the NodeClicked event.
OnNodeCreated | Raises the NodeCreated event.
OnNodeCreating | Raises the NodeCreating event.
OnNodeDeactivated | Raises the NodeDeactivated event.
OnNodeDeleted | Raises the NodeDeleted event.
OnNodeDeleting | Raises the NodeDeleting event.
OnNodeDeselected | Raises the NodeDeselected event.
OnNodeDoubleClicked | Raises the NodeDoubleClicked event.
OnNodeModified | Raises the NodeModified event.
OnNodeModifying | Raises the NodeModifying event.
OnNodePasted | Raises the NodePasted event.
OnNodeSelected | Raises the NodeSelected event.
OnNodeTextEdited | Raises the NodeTextEdited event.
OnRepaint | Raises the Repaint event.
OnSelectionChanged | Raises the SelectionChanged event.
OnSelectionModified | Raises the SelectionModified event.
OnSelectionModifying | Raises the SelectionModifying event.
OnSerializeControl | Raises the SerializeControl event.
OnSerializeTag | Raises the SerializeTag event.
OnSetSelfLoopShape | Raises the SetSelfLoopShape event.
OnTreeCollapsed | Raises the TreeCollapsed event.
OnTreeExpanded | Raises the TreeExpanded event.
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event.
OnZoomFactorChanged | Raises the ZoomFactorChanged event.

Public Events

Name | Description
ActionRedone | Raised when an action is redone.
ActionUndone | Raised when an action is undone.
ActiveLayerChanged | Raised when the diagram's active layer has changed.
BoundsChanged | Raised when the Bounds property value has changed.
CellClicked | Raised when the user clicks a table's cell.
CellDoubleClicked | Raised when the user double-clicks a table's cell.
Clicked | Raised when the user clicks the diagram at a point where no items are located.
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user.
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user.
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area.
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area.
DeserializeControl | Lets you load the attributes of controls hosted inside ControlNodes.
DeserializeTag | Raised when the Tag or Id of a diagram item must be deserialized from XML format.
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located.
DrawAdjustmentHandles | Raised when item's adjustment handles must be custom drawn.
EnterInplaceEditMode | Raised when entering inplace-edit mode.
ExpandButtonClicked | Raised when the user clicks the [+/-] button of an Expandable node.
HitTestAdjustmentHandles | Raised when custom hit testing of item's adjustment handles must be performed.
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created.
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created.
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively.
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively.
LaneGridCellCreated | Raised when a lane grid's cell has been created to allow additional cusomtization of its presentation.
LaneGridHeaderCreated | Raised when a lane grid's header has been created to allow additional cusomtization of its presentation.
LeaveInplaceEditMode | Raised when leaving inplace-edit mode.
LinkActivated | Raised when a link becomes the ActiveItem.
LinkClicked | Raised when the user clicks a link.
LinkCreated | Raised when the user draws a new link.
LinkCreating | A validation event raised while the user is drawing a new link.
LinkDeactivated | Raised when a link is no longer the ActiveItem.
LinkDeleted | Raised when a link is deleted, either programmatically or by the user.
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation.
LinkDeselected | Raised when a link is deselected, either programmatically or by the user.
LinkDoubleClicked | Raised when the user double-clicks a link.
LinkModified | Raised when the user moves any control point of a link.
LinkModifying | A validation event raised while the user is modifying a link.
LinkPasted | Raised when a link has been pasted from the clipboard.
LinkRouted | Raised when a link is routed by the auto-routing algorithm.
LinkSelected | Raised when a link is selected, either programmatically or by the user.
LinkTextEdited | Raised when the user edits the text of a link.
MagnifierFactorChanged | Occurs when the magnifier factor changes.
MeasureUnitChanged | Raised when the MeasureUnit property value has changed.
NodeActivated | Raised when a node becomes the ActiveItem.
NodeClicked | Raised when the user clicks a node.
NodeCreated | Occurs when the user draws a new node.
NodeCreating | A validation event raised while the user is drawing a new node.
NodeDeactivated | Raised when a node is no longer the ActiveItem.
NodeDeleted | Raised when a node is deleted, either programmatically or by the user.
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation.
NodeDeselected | Raised when a node is deselected, either programmatically or by the user.
NodeDoubleClicked | Raised when the user double-clicks a node.
NodeModified | Raised when the user moves or resizes a node.
NodeModifying | A validation event raised while the user is moving or resizing a node.
NodePasted | Raised when a node has been pasted from the clipboard.
NodeSelected | Raised when a node is selected, either programmatically or by the user.
NodeTextEdited | Raised when the user edits the text of a node.
Repaint | Raised when the diagram views should be repainted.
SelectionChanged | Raised when an item is added to or removed from the selection.
SelectionModified | Raised when the user moves or resizes multiple selected items.
SelectionModifying | Raised while the user is moving or resizing multiple selected items, this event lets you cancel the modification.
SerializeControl | Lets you save the attributes of controls hosted inside ControlNodes.
SerializeTag | Raised when the Tag of a diagram item must be serialized into an XML document.
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape.
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node.
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node.
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point.
ZoomFactorChanged | Occurs when the zoom factor changes.

See Also

DiagramBase Class


MindFusion.Diagramming.DiagramBase Constructor

DiagramBase Constructor
[image]

Initializes a new instance of the DiagramBase class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DiagramBase ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

DiagramBase Class


MindFusion.Diagramming.DiagramBase Methods

DiagramBase Methods
[image]

Protected Methods

Name | Description
OnActionRedone | Raises the ActionRedone event.
OnActionUndone | Raises the ActionUndone event.
OnBoundsChanged | Raises the BoundsChanged event.
OnCellClicked | Raises the CellClicked event.
OnCellDoubleClicked | Raises the CellDoubleClicked event.
OnClicked | Raises the Clicked event.
OnContainerChildAdded | Raises the ContainerChildAdded event.
OnContainerChildRemoved | Raises the ContainerChildRemoved event.
OnContainerFolded | Raises the ContainerFolded event.
OnContainerUnfolded | Raises the ContainerUnfolded event.
OnDeserializeControl | Raises the DeserializeControl event.
OnDeserializeTag | Raises the DeserializeTag event.
OnDoubleClicked | Raises the DoubleClicked event.
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event.
OnEnterInplaceEditMode | Raises the EnterInplaceEditMode event.
OnExpandButtonClicked | Raises the ExpandButtonClicked event.
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event.
OnInitializeLink | Raises the InitializeLink event.
OnInitializeNode | Raises the InitializeNode event.
OnItemAdded | Raises the ItemAdded event.
OnItemRemoved | Raises the ItemRemoved event.
OnLaneGridCellCreated | Raises the LaneGridCellCreated event.
OnLaneGridHeaderCreated | Raises the LaneGridHeaderCreated event.
OnLeaveInplaceEditMode | Raises the LeaveInplaceEditMode event.
OnLinkActivated | Raises the LinkActivated event.
OnLinkClicked | Raises the LinkClicked event.
OnLinkCreated | Raises the LinkCreated event.
OnLinkCreating | Raises the LinkCreating event.
OnLinkDeactivated | Raises the LinkDeactivated event.
OnLinkDeleted | Raises the LinkDeleted event.
OnLinkDeleting | Raises the LinkDeleting event.
OnLinkDeselected | Raises the LinkDeselected event.
OnLinkDoubleClicked | Raises the LinkDoubleClicked event.
OnLinkModified | Raises the LinkModified event.
OnLinkModifying | Raises the LinkModifying event.
OnLinkPasted | Raises the LinkPasted event.
OnLinkRouted | Raises the LinkRouted event.
OnLinkSelected | Raises the LinkSelected event.
OnLinkTextEdited | Raises the LinkTextEdited event.
OnMagnifierFactorChanged | Raises the MagnifierFactorChanged event.
OnMeasureUnitChanged | Raises the MeasureUnitChanged event.
OnNodeActivated | Raises the NodeActivated event.
OnNodeClicked | Raises the NodeClicked event.
OnNodeCreated | Raises the NodeCreated event.
OnNodeCreating | Raises the NodeCreating event.
OnNodeDeactivated | Raises the NodeDeactivated event.
OnNodeDeleted | Raises the NodeDeleted event.
OnNodeDeleting | Raises the NodeDeleting event.
OnNodeDeselected | Raises the NodeDeselected event.
OnNodeDoubleClicked | Raises the NodeDoubleClicked event.
OnNodeModified | Raises the NodeModified event.
OnNodeModifying | Raises the NodeModifying event.
OnNodePasted | Raises the NodePasted event.
OnNodeSelected | Raises the NodeSelected event.
OnNodeTextEdited | Raises the NodeTextEdited event.
OnRepaint | Raises the Repaint event.
OnSelectionChanged | Raises the SelectionChanged event.
OnSelectionModified | Raises the SelectionModified event.
OnSelectionModifying | Raises the SelectionModifying event.
OnSerializeControl | Raises the SerializeControl event.
OnSerializeTag | Raises the SerializeTag event.
OnSetSelfLoopShape | Raises the SetSelfLoopShape event.
OnTreeCollapsed | Raises the TreeCollapsed event.
OnTreeExpanded | Raises the TreeExpanded event.
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event.
OnZoomFactorChanged | Raises the ZoomFactorChanged event.

See Also

DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnActionRedone Method

DiagramBase.OnActionRedone Method
[image]

Raises the ActionRedone event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnActionRedone (
UndoEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnActionRedone( _
e As UndoEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnActionUndone Method

DiagramBase.OnActionUndone Method
[image]

Raises the ActionUndone event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnActionUndone (
UndoEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnActionUndone( _
e As UndoEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnBoundsChanged Method

DiagramBase.OnBoundsChanged Method
[image]

Raises the BoundsChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnBoundsChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnBoundsChanged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnCellClicked Method

DiagramBase.OnCellClicked Method
[image]

Raises the CellClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnCellClicked (
CellEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCellClicked( _
e As CellEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnCellDoubleClicked Method

DiagramBase.OnCellDoubleClicked Method
[image]

Raises the CellDoubleClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnCellDoubleClicked (
CellEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCellDoubleClicked( _
e As CellEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnClicked Method

DiagramBase.OnClicked Method
[image]

Raises the Clicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnClicked (
DiagramEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnClicked( _
e As DiagramEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnContainerChildAdded Method

DiagramBase.OnContainerChildAdded Method
[image]

Raises the ContainerChildAdded event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnContainerChildAdded (
ContainerChildEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnContainerChildAdded( _
e As ContainerChildEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnContainerChildRemoved Method

DiagramBase.OnContainerChildRemoved Method
[image]

Raises the ContainerChildRemoved event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnContainerChildRemoved (
ContainerChildEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnContainerChildRemoved( _
e As ContainerChildEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnContainerFolded Method

DiagramBase.OnContainerFolded Method
[image]

Raises the ContainerFolded event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnContainerFolded (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnContainerFolded( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnContainerUnfolded Method

DiagramBase.OnContainerUnfolded Method
[image]

Raises the ContainerUnfolded event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnContainerUnfolded (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnContainerUnfolded( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnDeserializeControl Method

DiagramBase.OnDeserializeControl Method
[image]

Raises the DeserializeControl event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDeserializeControl (
ControlNodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDeserializeControl( _
e As ControlNodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnDeserializeTag Method

DiagramBase.OnDeserializeTag Method
[image]

Raises the DeserializeTag event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDeserializeTag (
SerializeTagEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDeserializeTag( _
e As SerializeTagEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnDoubleClicked Method

DiagramBase.OnDoubleClicked Method
[image]

Raises the DoubleClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDoubleClicked (
DiagramEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDoubleClicked( _
e As DiagramEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnDrawAdjustmentHandles Method

DiagramBase.OnDrawAdjustmentHandles Method
[image]

Raises the DrawAdjustmentHandles event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDrawAdjustmentHandles (
DrawHandlesEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrawAdjustmentHandles( _
e As DrawHandlesEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnEnterInplaceEditMode Method

DiagramBase.OnEnterInplaceEditMode Method
[image]

Raises the EnterInplaceEditMode event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnEnterInplaceEditMode (
InPlaceEditEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnEnterInplaceEditMode( _
e As InPlaceEditEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnExpandButtonClicked Method

DiagramBase.OnExpandButtonClicked Method
[image]

Raises the ExpandButtonClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnExpandButtonClicked (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnExpandButtonClicked( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnHitTestAdjustmentHandles Method

DiagramBase.OnHitTestAdjustmentHandles Method
[image]

Raises the HitTestAdjustmentHandles event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnHitTestAdjustmentHandles (
HitTestEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnHitTestAdjustmentHandles( _
e As HitTestEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnInitializeLink Method

DiagramBase.OnInitializeLink Method
[image]

Raises the InitializeLink event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnInitializeLink (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnInitializeLink( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnInitializeNode Method

DiagramBase.OnInitializeNode Method
[image]

Raises the InitializeNode event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnInitializeNode (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnInitializeNode( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnItemAdded Method

DiagramBase.OnItemAdded Method
[image]

Raises the ItemAdded event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnItemAdded (
ItemEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemAdded( _
e As ItemEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnItemRemoved Method

DiagramBase.OnItemRemoved Method
[image]

Raises the ItemRemoved event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnItemRemoved (
ItemEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemRemoved( _
e As ItemEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLaneGridCellCreated Method

DiagramBase.OnLaneGridCellCreated Method
[image]

Raises the LaneGridCellCreated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLaneGridCellCreated (
GridCellEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLaneGridCellCreated( _
e As GridCellEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLaneGridHeaderCreated Method

DiagramBase.OnLaneGridHeaderCreated Method
[image]

Raises the LaneGridHeaderCreated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLaneGridHeaderCreated (
GridHeaderEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLaneGridHeaderCreated( _
e As GridHeaderEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLeaveInplaceEditMode Method

DiagramBase.OnLeaveInplaceEditMode Method
[image]

Raises the LeaveInplaceEditMode event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLeaveInplaceEditMode (
InPlaceEditEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLeaveInplaceEditMode( _
e As InPlaceEditEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkActivated Method

DiagramBase.OnLinkActivated Method
[image]

Raises the LinkActivated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkActivated (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkActivated( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkClicked Method

DiagramBase.OnLinkClicked Method
[image]

Raises the LinkClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkClicked (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkClicked( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkCreated Method

DiagramBase.OnLinkCreated Method
[image]

Raises the LinkCreated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkCreated (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkCreated( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkCreating Method

DiagramBase.OnLinkCreating Method
[image]

Raises the LinkCreating event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkCreating (
LinkValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkCreating( _
e As LinkValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkDeactivated Method

DiagramBase.OnLinkDeactivated Method
[image]

Raises the LinkDeactivated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkDeactivated (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkDeactivated( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkDeleted Method

DiagramBase.OnLinkDeleted Method
[image]

Raises the LinkDeleted event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkDeleted (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkDeleted( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkDeleting Method

DiagramBase.OnLinkDeleting Method
[image]

Raises the LinkDeleting event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkDeleting (
LinkValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkDeleting( _
e As LinkValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkDeselected Method

DiagramBase.OnLinkDeselected Method
[image]

Raises the LinkDeselected event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkDeselected (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkDeselected( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkDoubleClicked Method

DiagramBase.OnLinkDoubleClicked Method
[image]

Raises the LinkDoubleClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkDoubleClicked (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkDoubleClicked( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkModified Method

DiagramBase.OnLinkModified Method
[image]

Raises the LinkModified event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkModified (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkModified( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkModifying Method

DiagramBase.OnLinkModifying Method
[image]

Raises the LinkModifying event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkModifying (
LinkValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkModifying( _
e As LinkValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkPasted Method

DiagramBase.OnLinkPasted Method
[image]

Raises the LinkPasted event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkPasted (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkPasted( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkRouted Method

DiagramBase.OnLinkRouted Method
[image]

Raises the LinkRouted event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkRouted (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkRouted( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkSelected Method

DiagramBase.OnLinkSelected Method
[image]

Raises the LinkSelected event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkSelected (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkSelected( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkTextEdited Method

DiagramBase.OnLinkTextEdited Method
[image]

Raises the LinkTextEdited event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkTextEdited (
EditLinkTextEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkTextEdited( _
e As EditLinkTextEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnMagnifierFactorChanged Method

DiagramBase.OnMagnifierFactorChanged Method
[image]

Raises the MagnifierFactorChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnMagnifierFactorChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMagnifierFactorChanged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnMeasureUnitChanged Method

DiagramBase.OnMeasureUnitChanged Method
[image]

Raises the MeasureUnitChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnMeasureUnitChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMeasureUnitChanged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeActivated Method

DiagramBase.OnNodeActivated Method
[image]

Raises the NodeActivated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeActivated (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeActivated( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeClicked Method

DiagramBase.OnNodeClicked Method
[image]

Raises the NodeClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeClicked (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeClicked( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeCreated Method

DiagramBase.OnNodeCreated Method
[image]

Raises the NodeCreated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeCreated (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeCreated( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeCreating Method

DiagramBase.OnNodeCreating Method
[image]

Raises the NodeCreating event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeCreating (
NodeValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeCreating( _
e As NodeValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeDeactivated Method

DiagramBase.OnNodeDeactivated Method
[image]

Raises the NodeDeactivated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeDeactivated (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeDeactivated( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeDeleted Method

DiagramBase.OnNodeDeleted Method
[image]

Raises the NodeDeleted event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeDeleted (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeDeleted( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeDeleting Method

DiagramBase.OnNodeDeleting Method
[image]

Raises the NodeDeleting event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeDeleting (
NodeValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeDeleting( _
e As NodeValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeDeselected Method

DiagramBase.OnNodeDeselected Method
[image]

Raises the NodeDeselected event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeDeselected (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeDeselected( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeDoubleClicked Method

DiagramBase.OnNodeDoubleClicked Method
[image]

Raises the NodeDoubleClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeDoubleClicked (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeDoubleClicked( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeModified Method

DiagramBase.OnNodeModified Method
[image]

Raises the NodeModified event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeModified (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeModified( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeModifying Method

DiagramBase.OnNodeModifying Method
[image]

Raises the NodeModifying event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeModifying (
NodeValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeModifying( _
e As NodeValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodePasted Method

DiagramBase.OnNodePasted Method
[image]

Raises the NodePasted event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodePasted (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodePasted( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeSelected Method

DiagramBase.OnNodeSelected Method
[image]

Raises the NodeSelected event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeSelected (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeSelected( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeTextEdited Method

DiagramBase.OnNodeTextEdited Method
[image]

Raises the NodeTextEdited event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeTextEdited (
EditNodeTextEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeTextEdited( _
e As EditNodeTextEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnRepaint Method

DiagramBase.OnRepaint Method
[image]

Raises the Repaint event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnRepaint (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRepaint( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnSelectionChanged Method

DiagramBase.OnSelectionChanged Method
[image]

Raises the SelectionChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnSelectionChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSelectionChanged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnSelectionModified Method

DiagramBase.OnSelectionModified Method
[image]

Raises the SelectionModified event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnSelectionModified (
SelectionEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSelectionModified( _
e As SelectionEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnSelectionModifying Method

DiagramBase.OnSelectionModifying Method
[image]

Raises the SelectionModifying event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnSelectionModifying (
SelectionValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSelectionModifying( _
e As SelectionValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnSerializeControl Method

DiagramBase.OnSerializeControl Method
[image]

Raises the SerializeControl event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnSerializeControl (
ControlNodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSerializeControl( _
e As ControlNodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnSerializeTag Method

DiagramBase.OnSerializeTag Method
[image]

Raises the SerializeTag event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnSerializeTag (
SerializeTagEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSerializeTag( _
e As SerializeTagEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnSetSelfLoopShape Method

DiagramBase.OnSetSelfLoopShape Method
[image]

Raises the SetSelfLoopShape event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnSetSelfLoopShape (
LinkShapeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSetSelfLoopShape( _
e As LinkShapeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnTreeCollapsed Method

DiagramBase.OnTreeCollapsed Method
[image]

Raises the TreeCollapsed event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnTreeCollapsed (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTreeCollapsed( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnTreeExpanded Method

DiagramBase.OnTreeExpanded Method
[image]

Raises the TreeExpanded event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnTreeExpanded (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTreeExpanded( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnValidateAnchorPoint Method

DiagramBase.OnValidateAnchorPoint Method
[image]

Raises the ValidateAnchorPoint event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnValidateAnchorPoint (
LinkValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnValidateAnchorPoint( _
e As LinkValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnZoomFactorChanged Method

DiagramBase.OnZoomFactorChanged Method
[image]

Raises the ZoomFactorChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnZoomFactorChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnZoomFactorChanged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase Events

DiagramBase Events
[image]

Public Events

Name | Description
ActionRedone | Raised when an action is redone.
ActionUndone | Raised when an action is undone.
ActiveLayerChanged | Raised when the diagram's active layer has changed.
BoundsChanged | Raised when the Bounds property value has changed.
CellClicked | Raised when the user clicks a table's cell.
CellDoubleClicked | Raised when the user double-clicks a table's cell.
Clicked | Raised when the user clicks the diagram at a point where no items are located.
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user.
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user.
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area.
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area.
DeserializeControl | Lets you load the attributes of controls hosted inside ControlNodes.
DeserializeTag | Raised when the Tag or Id of a diagram item must be deserialized from XML format.
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located.
DrawAdjustmentHandles | Raised when item's adjustment handles must be custom drawn.
EnterInplaceEditMode | Raised when entering inplace-edit mode.
ExpandButtonClicked | Raised when the user clicks the [+/-] button of an Expandable node.
HitTestAdjustmentHandles | Raised when custom hit testing of item's adjustment handles must be performed.
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created.
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created.
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively.
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively.
LaneGridCellCreated | Raised when a lane grid's cell has been created to allow additional cusomtization of its presentation.
LaneGridHeaderCreated | Raised when a lane grid's header has been created to allow additional cusomtization of its presentation.
LeaveInplaceEditMode | Raised when leaving inplace-edit mode.
LinkActivated | Raised when a link becomes the ActiveItem.
LinkClicked | Raised when the user clicks a link.
LinkCreated | Raised when the user draws a new link.
LinkCreating | A validation event raised while the user is drawing a new link.
LinkDeactivated | Raised when a link is no longer the ActiveItem.
LinkDeleted | Raised when a link is deleted, either programmatically or by the user.
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation.
LinkDeselected | Raised when a link is deselected, either programmatically or by the user.
LinkDoubleClicked | Raised when the user double-clicks a link.
LinkModified | Raised when the user moves any control point of a link.
LinkModifying | A validation event raised while the user is modifying a link.
LinkPasted | Raised when a link has been pasted from the clipboard.
LinkRouted | Raised when a link is routed by the auto-routing algorithm.
LinkSelected | Raised when a link is selected, either programmatically or by the user.
LinkTextEdited | Raised when the user edits the text of a link.
MagnifierFactorChanged | Occurs when the magnifier factor changes.
MeasureUnitChanged | Raised when the MeasureUnit property value has changed.
NodeActivated | Raised when a node becomes the ActiveItem.
NodeClicked | Raised when the user clicks a node.
NodeCreated | Occurs when the user draws a new node.
NodeCreating | A validation event raised while the user is drawing a new node.
NodeDeactivated | Raised when a node is no longer the ActiveItem.
NodeDeleted | Raised when a node is deleted, either programmatically or by the user.
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation.
NodeDeselected | Raised when a node is deselected, either programmatically or by the user.
NodeDoubleClicked | Raised when the user double-clicks a node.
NodeModified | Raised when the user moves or resizes a node.
NodeModifying | A validation event raised while the user is moving or resizing a node.
NodePasted | Raised when a node has been pasted from the clipboard.
NodeSelected | Raised when a node is selected, either programmatically or by the user.
NodeTextEdited | Raised when the user edits the text of a node.
Repaint | Raised when the diagram views should be repainted.
SelectionChanged | Raised when an item is added to or removed from the selection.
SelectionModified | Raised when the user moves or resizes multiple selected items.
SelectionModifying | Raised while the user is moving or resizing multiple selected items, this event lets you cancel the modification.
SerializeControl | Lets you save the attributes of controls hosted inside ControlNodes.
SerializeTag | Raised when the Tag of a diagram item must be serialized into an XML document.
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape.
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node.
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node.
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point.
ZoomFactorChanged | Occurs when the zoom factor changes.

See Also

DiagramBase Class


MindFusion.Diagramming.DiagramBase.ActionRedone Event

DiagramBase.ActionRedone Event
[image]

Raised when an action is redone.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<UndoEventArgs> ActionRedone

Visual Basic [image] Copy Code

Public Event ActionRedone As EventHandler(Of UndoEventArgs)

Event Data

ActionRedone event handlers receive an argument of type UndoEventArgs. The following UndoEventArgs members provide information relevant to the event:

Member name | Description
Command | Refers to the Command that has been redone.

Remarks

This event is raised during calls to Redo. It is raised both for top-level commands and for the constituent actions of composite commands.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
ActionUndone Event


MindFusion.Diagramming.DiagramBase.ActionUndone Event

DiagramBase.ActionUndone Event
[image]

Raised when an action is undone.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<UndoEventArgs> ActionUndone

Visual Basic [image] Copy Code

Public Event ActionUndone As EventHandler(Of UndoEventArgs)

Event Data

ActionUndone event handlers receive an argument of type UndoEventArgs. The following UndoEventArgs members provide information relevant to the event:

Member name | Description
Command | Refers to the Command that has been undone.

Remarks

This event is raised during calls to Undo. It is raised both for top-level commands and for the constituent actions of composite commands.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
ActionRedone Event


MindFusion.Diagramming.DiagramBase.ActiveLayerChanged Event

DiagramBase.ActiveLayerChanged Event
[image]

Raised when the diagram's active layer has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler ActiveLayerChanged

Visual Basic [image] Copy Code

Public Event ActiveLayerChanged As EventHandler

Event Data

ActiveLayerChanged event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.BoundsChanged Event

DiagramBase.BoundsChanged Event
[image]

Raised when the Bounds property value has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler BoundsChanged

Visual Basic [image] Copy Code

Public Event BoundsChanged As EventHandler

Event Data

BoundsChanged event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.CellClicked Event

DiagramBase.CellClicked Event
[image]

Raised when the user clicks a table's cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<CellEventArgs> CellClicked

Visual Basic [image] Copy Code

Public Event CellClicked As EventHandler(Of CellEventArgs)

Event Data

CellClicked event handlers receive an argument of type CellEventArgs. The following CellEventArgs members provide information relevant to the event:

Member name | Description
Cell | The Cell that has been clicked.
Column | Index of the column containing the clicked cell.
MousePosition | A Point specifying the mouse cursor position.
Row | Index of the row containing the clicked cell.
Table | The TableNode that contains the clicked cell.

Remarks

If there is some handler attached to this event, NodeClicked won't be raised for the table that contains the clicked cell, but only CellClicked.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
NodeClicked Event
CellDoubleClicked Event


MindFusion.Diagramming.DiagramBase.CellDoubleClicked Event

DiagramBase.CellDoubleClicked Event
[image]

Raised when the user double-clicks a table's cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<CellEventArgs> CellDoubleClicked

Visual Basic [image] Copy Code

Public Event CellDoubleClicked As EventHandler(Of CellEventArgs)

Event Data

CellDoubleClicked event handlers receive an argument of type CellEventArgs. The following CellEventArgs members provide information relevant to the event:

Member name | Description
Cell | The Cell that has been double-clicked.
Column | Index of the column containing the clicked cell.
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A Point specifying the mouse cursor position.
Row | Index of the row containing the clicked cell.
Table | The TableNode that contains the clicked cell.

Remarks

If there is some handler attached to this event, NodeDoubleClicked won't be raised for the table that contains the clicked cell, but only CellDoubleClicked.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
NodeDoubleClicked Event
CellClicked Event


MindFusion.Diagramming.DiagramBase.Clicked Event

DiagramBase.Clicked Event
[image]

Raised when the user clicks the diagram at a point where no items are located.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<DiagramEventArgs> Clicked

Visual Basic [image] Copy Code

Public Event Clicked As EventHandler(Of DiagramEventArgs)

Event Data

Clicked event handlers receive an argument of type DiagramEventArgs. The following DiagramEventArgs members provide information relevant to the event:

Member name | Description
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A Point specifying the mouse cursor position.

Remarks

This event is raised only if the user clicks an unoccupied point of the diagram. If the user clicks a diagram item, one of the following events is raised: NodeClicked, CellClicked or LinkClicked.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
DoubleClicked Event


MindFusion.Diagramming.DiagramBase.ContainerChildAdded Event

DiagramBase.ContainerChildAdded Event
[image]

Raised when a node is added to a ContainerNode, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<ContainerChildEventArgs> ContainerChildAdded

Visual Basic [image] Copy Code

Public Event ContainerChildAdded As EventHandler(Of ContainerChildEventArgs)

Event Data

ContainerChildAdded event handlers receive an argument of type ContainerChildEventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
AllowAddChildren Property
ContainerChildRemoved Event


MindFusion.Diagramming.DiagramBase.ContainerChildRemoved Event

DiagramBase.ContainerChildRemoved Event
[image]

Raised when a node is removed from a ContainerNode, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<ContainerChildEventArgs> ContainerChildRemoved

Visual Basic [image] Copy Code

Public Event ContainerChildRemoved As EventHandler(Of ContainerChildEventArgs)

Event Data

ContainerChildRemoved event handlers receive an argument of type ContainerChildEventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
AllowRemoveChildren Property
ContainerChildAdded Event


MindFusion.Diagramming.DiagramBase.ContainerFolded Event

DiagramBase.ContainerFolded Event
[image]

Raised when the user folds a container by clicking the arrow-up button in the container's caption area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> ContainerFolded

Visual Basic [image] Copy Code

Public Event ContainerFolded As EventHandler(Of NodeEventArgs)

Remarks

ContainerFolded event handlers receive an argument of type NodeEventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
Foldable Property
ContainerUnfolded Event


MindFusion.Diagramming.DiagramBase.ContainerUnfolded Event

DiagramBase.ContainerUnfolded Event
[image]

Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> ContainerUnfolded

Visual Basic [image] Copy Code

Public Event ContainerUnfolded As EventHandler(Of NodeEventArgs)

Event Data

ContainerUnfolded event handlers receive an argument of type NodeEventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
ContainerFolded Event


MindFusion.Diagramming.DiagramBase.DeserializeControl Event

DiagramBase.DeserializeControl Event
[image]

Lets you load the attributes of controls hosted inside ControlNodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<ControlNodeEventArgs> DeserializeControl

Visual Basic [image] Copy Code

Public Event DeserializeControl As EventHandler(Of ControlNodeEventArgs)

Event Data

DeserializeControl event handlers receive an argument of type ControlNodeEventArgs. The following ControlNodeEventArgs members provide information relevant to the event:

Member name | Description
Handled | Gets or sets a value indicating whether the event is handled.
Node | Gets a reference to the ControlNode being serialized or deserialized.
XmlElement | Gets an XElement you can retrieve the control information from.

Remarks

Handle this event to load the content of nodes saved using SerializeControl.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
DeserializeTag Event
SerializeControl Event


MindFusion.Diagramming.DiagramBase.DeserializeTag Event

DiagramBase.DeserializeTag Event
[image]

Raised when the Tag or Id of a diagram item must be deserialized from XML format.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<SerializeTagEventArgs> DeserializeTag

Visual Basic [image] Copy Code

Public Event DeserializeTag As EventHandler(Of SerializeTagEventArgs)

Event Data

DeserializeTag event handlers receive an argument of type SerializeTagEventArgs. The following SerializeTagEventArgs members provide information relevant to the event:

Member name | Description
Context | An XmlPersistContext object providing information about the document being deserialized, along with methods that help you deserialize data from XML.
Handled | Set this flag to true if you perform custom tag deserialization.
Object | The object whose Tag is being deserialized. This object can be either a diagram item, cell or anchor point.
PropertyName | Gets the name of the property being serialized.
Representation | An XmlElement instance that contains the XML representation of a Tag value.
Tag | Set this property to the object that has been deserialized.

Remarks

Only tags of simple value types can be saved and loaded automatically to/from the XML document. You must provide your own serialization for complex types by implementing this event and SerializeTag.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
DeserializeControl Event
SerializeTag Event


MindFusion.Diagramming.DiagramBase.DoubleClicked Event

DiagramBase.DoubleClicked Event
[image]

Raised when the user double-clicks the diagram at a point where no items are located.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<DiagramEventArgs> DoubleClicked

Visual Basic [image] Copy Code

Public Event DoubleClicked As EventHandler(Of DiagramEventArgs)

Event Data

DoubleClicked event handlers receive an argument of type DiagramEventArgs. The following DiagramEventArgs members provide information relevant to the event:

Member name | Description
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A Point specifying the mouse cursor position.

Remarks

This event is raised only if the user double-clicks an unoccupied point of the diagram. If the user double-clicks a diagram item, one of the following events is raised: NodeDoubleClicked, CellDoubleClicked or LinkDoubleClicked.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
Clicked Event


MindFusion.Diagramming.DiagramBase.DrawAdjustmentHandles Event

DiagramBase.DrawAdjustmentHandles Event
[image]

Raised when item's adjustment handles must be custom drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<DrawHandlesEventArgs> DrawAdjustmentHandles

Visual Basic [image] Copy Code

Public Event DrawAdjustmentHandles As EventHandler(Of DrawHandlesEventArgs)

Remarks

DrawAdjustmentHandles is raised for selected items whose HandlesStyle is set to Custom.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.EnterInplaceEditMode Event

DiagramBase.EnterInplaceEditMode Event
[image]

Raised when entering inplace-edit mode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<InPlaceEditEventArgs> EnterInplaceEditMode

Visual Basic [image] Copy Code

Public Event EnterInplaceEditMode As EventHandler(Of InPlaceEditEventArgs)

Event Data

EnterInplaceEditMode event handlers receive an argument of type InPlaceEditEventArgs. The following InPlaceEditEventArgs members provide information relevant to the event:

Member name | Description
Item | The item or table cell whose text will be edited.
Node | The node whose text will be edited. If Item is a cell, this property returns the TableNode that contains that cell.
TextBox | The TextBox control where the user can edit the text.

Remarks

This event allows setting properties of the TextBox control used for in-place editing or attaching custom event handlers to that control. A TextBox instance is created each time in-place editing starts, so it could be necessary to set its properties and register event handlers each time EnterInplaceEditMode is raised.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
AllowInplaceEdit Property
LeaveInplaceEditMode Event


MindFusion.Diagramming.DiagramBase.ExpandButtonClicked Event

DiagramBase.ExpandButtonClicked Event
[image]

Raised when the user clicks the [+/-] button of an Expandable node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> ExpandButtonClicked

Visual Basic [image] Copy Code

Public Event ExpandButtonClicked As EventHandler(Of NodeEventArgs)

Event Data

ExpandButtonClicked event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode whose [±] button has been clicked.

Remarks

This event is raised only if ExpandButtonAction is set to RaiseEvents. Otherwise either the TreeCollapsed or TreeExpanded event is raised, depending on the state of the node.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.HitTestAdjustmentHandles Event

DiagramBase.HitTestAdjustmentHandles Event
[image]

Raised when custom hit testing of item's adjustment handles must be performed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<HitTestEventArgs> HitTestAdjustmentHandles

Visual Basic [image] Copy Code

Public Event HitTestAdjustmentHandles As EventHandler(Of HitTestEventArgs)

Remarks

HitTestAdjustmentHandles is raised for selected items whose HandlesStyle is set to Custom. For links, set the result to the index of the link's control point that has been hit. For nodes, set the result to 0, 1, 2, 3 for the corner resize handles, 4, 5, 6, 7 for the side center resize handles, 8 for the move handle and 9 for the rotation handle.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.InitializeLink Event

DiagramBase.InitializeLink Event
[image]

Raised when the user starts drawing a new link, just after the DiagramLink instance is created.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> InitializeLink

Visual Basic [image] Copy Code

Public Event InitializeLink As EventHandler(Of LinkEventArgs)

Event Data

InitializeLink event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The new DiagramLink instance.

Remarks

This event is raised immediately after the user starts drawing a new link. It lets you set the appearance properties of the link if you need their values to be different from the default ones defined in the Diagram object, or if they don't have correspondent properties in the Diagram class. The Initialize* events are intended only for initializing the appearance of items. Do not alter the structure of the diagram from their handlers, that is, do not create new items nor delete existing ones; if you do that, the control will be in an undefined state and will likely throw an exception at some point.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
InitializeNode Event


MindFusion.Diagramming.DiagramBase.InitializeNode Event

DiagramBase.InitializeNode Event
[image]

Raised when the user starts drawing a new node, just after the DiagramNode instance is created.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> InitializeNode

Visual Basic [image] Copy Code

Public Event InitializeNode As EventHandler(Of NodeEventArgs)

Event Data

InitializeNode event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The new DiagramNode instance.

Remarks

This event is raised immediately after the user starts drawing a new node. It lets you set the appearance properties of the node if you need their values to be different from the default ones defined in the Diagram object, or if they don't have correspondent properties in the Diagram class. The Initialize* events are intended only for initializing the appearance of items. Do not alter the structure of the diagram from their handlers, that is, do not create new items nor delete existing ones; if you do that, the control will be in an undefined state and will likely throw an exception at some point.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
InitializeLink Event


MindFusion.Diagramming.DiagramBase.ItemAdded Event

DiagramBase.ItemAdded Event
[image]

Raised when an item is added to the diagram, either programmatically or interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemAdded

Visual Basic [image] Copy Code

Public Event ItemAdded As EventHandler(Of ItemEventArgs)

Event Data

ItemAdded event handlers receive an argument of type ItemEventArgs. The following ItemEventArgs members provide information relevant to the event:

Member name | Description
Item | The DiagramItem that has been added to the diagram.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
ItemRemoved Event


MindFusion.Diagramming.DiagramBase.ItemRemoved Event

DiagramBase.ItemRemoved Event
[image]

Raised when an item is removed from the diagram, either programmatically or interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemRemoved

Visual Basic [image] Copy Code

Public Event ItemRemoved As EventHandler(Of ItemEventArgs)

Event Data

ItemRemoved event handlers receive an argument of type ItemEventArgs. The following ItemEventArgs members provide information relevant to the event:

Member name | Description
Item | The DiagramItem that has been removed from the diagram.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
ItemAdded Event


MindFusion.Diagramming.DiagramBase.LaneGridCellCreated Event

DiagramBase.LaneGridCellCreated Event
[image]

Raised when a lane grid's cell has been created to allow additional cusomtization of its presentation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<GridCellEventArgs> LaneGridCellCreated

Visual Basic [image] Copy Code

Public Event LaneGridCellCreated As EventHandler(Of GridCellEventArgs)

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LaneGridHeaderCreated Event

DiagramBase.LaneGridHeaderCreated Event
[image]

Raised when a lane grid's header has been created to allow additional cusomtization of its presentation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<GridHeaderEventArgs> LaneGridHeaderCreated

Visual Basic [image] Copy Code

Public Event LaneGridHeaderCreated As EventHandler(Of GridHeaderEventArgs)

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LeaveInplaceEditMode Event

DiagramBase.LeaveInplaceEditMode Event
[image]

Raised when leaving inplace-edit mode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<InPlaceEditEventArgs> LeaveInplaceEditMode

Visual Basic [image] Copy Code

Public Event LeaveInplaceEditMode As EventHandler(Of InPlaceEditEventArgs)

Event Data

LeaveInplaceEditMode event handlers receive an argument of type InPlaceEditEventArgs. The following InPlaceEditEventArgs members provide information relevant to the event:

Member name | Description
Item | The item or table cell whose text has been edited.
Node | The node whose text has been edited. If Item is a cell, this property returns the TableNode containing the cell.
TextBox | The TextBox control used to edit the text.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
EnterInplaceEditMode Event


MindFusion.Diagramming.DiagramBase.LinkActivated Event

DiagramBase.LinkActivated Event
[image]

Raised when a link becomes the ActiveItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkActivated

Visual Basic [image] Copy Code

Public Event LinkActivated As EventHandler(Of LinkEventArgs)

Event Data

LinkActivated event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has become the ActiveItem.

Remarks

When the event is raised, ActiveItem already refers to the activated link. If multiple-selection is disabled, the active item is the only item selected by the user; otherwise it is usually the one added last to the selection.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
LinkSelected Event


MindFusion.Diagramming.DiagramBase.LinkClicked Event

DiagramBase.LinkClicked Event
[image]

Raised when the user clicks a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkClicked

Visual Basic [image] Copy Code

Public Event LinkClicked As EventHandler(Of LinkEventArgs)

Event Data

LinkClicked event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been clicked.
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A Point specifying the mouse cursor position.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
LinkDoubleClicked Event


MindFusion.Diagramming.DiagramBase.LinkCreated Event

DiagramBase.LinkCreated Event
[image]

Raised when the user draws a new link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkCreated

Visual Basic [image] Copy Code

Public Event LinkCreated As EventHandler(Of LinkEventArgs)

Event Data

LinkCreated event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been created.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
InitializeLink Event
LinkDeleted Event


MindFusion.Diagramming.DiagramBase.LinkCreating Event

DiagramBase.LinkCreating Event
[image]

A validation event raised while the user is drawing a new link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkValidationEventArgs> LinkCreating

Visual Basic [image] Copy Code

Public Event LinkCreating As EventHandler(Of LinkValidationEventArgs)

Event Data

LinkCreating event handlers receive an argument of type LinkValidationEventArgs. The following LinkValidationEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that is being created.
MousePosition | A Point specifying the mouse cursor position.
Destination | The DiagramNode that will be set as the link's Destination if this event is validated.
AnchorIndex | Index of the anchor point to which the link will be connected if this event is validated.
TableRow | Index of the table row to which the link will be connected if this event is validated.
Cancel | Set this property to true to prevent the user from creating the link at the current location. That displays the Stop mouse cursor and releasing the button will cancel the operation.
CancelDrag | Call this method to immediately stop the link creation.

Remarks

LinkCreating is raised after each mouse movement while drawing a new link. Setting Cancel to true will change the mouse cursor to a Stop icon. The event is raised once again when the mouse button is released. Setting Cancel to true in that case will cancel the link creation.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
LinkCreated Event
LinkModifying Event


MindFusion.Diagramming.DiagramBase.LinkDeactivated Event

DiagramBase.LinkDeactivated Event
[image]

Raised when a link is no longer the ActiveItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkDeactivated

Visual Basic [image] Copy Code

Public Event LinkDeactivated As EventHandler(Of LinkEventArgs)

Event Data

LinkDeactivated event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | A DiagramLink that was the ActiveItem.

Remarks

LinkDeactivated is raised when the ActiveItem changes and before that it referred to a link.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
LinkDeselected Event


MindFusion.Diagramming.DiagramBase.LinkDeleted Event

DiagramBase.LinkDeleted Event
[image]

Raised when a link is deleted, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkDeleted

Visual Basic [image] Copy Code

Public Event LinkDeleted As EventHandler(Of LinkEventArgs)

Event Data

LinkDeleted event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been deleted.

Remarks

The link is removed from the Items and Links collections before the event is raised. From within an event handler you can still check the values of simple properties such as Text or Tag. Before deleting a node, all links that link to it a deleted too. So there might be several LinkDeleted events raised before NodeDeleted is raised.

To prevent users from deleting a link by pressing the DEL key, handle the LinkDeleting event.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
LinkCreated Event


MindFusion.Diagramming.DiagramBase.LinkDeleting Event

DiagramBase.LinkDeleting Event
[image]

Raised when the user tries to delete a link, this event lets you cancel the operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkValidationEventArgs> LinkDeleting

Visual Basic [image] Copy Code

Public Event LinkDeleting As EventHandler(Of LinkValidationEventArgs)

Event Data

LinkDeleting event handlers receive an argument of type LinkValidationEventArgs. The following LinkValidationEventArgs members provide information relevant to the event:

Member name | Description
Link | A DiagramLink that the user is trying to delete by pressing the DEL key.
Cancel | Set this property to true to prevent the user from deleting the link.

Remarks

When users delete a node, its connecting links are deleted too. However, in that case LinkDeleting validation events are not raised, but just NodeDeleting.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
DelKeyAction Property


MindFusion.Diagramming.DiagramBase.LinkDeselected Event

DiagramBase.LinkDeselected Event
[image]

Raised when a link is deselected, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkDeselected

Visual Basic [image] Copy Code

Public Event LinkDeselected As EventHandler(Of LinkEventArgs)

Event Data

LinkDeselected event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been deselected.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
LinkSelected Event


MindFusion.Diagramming.DiagramBase.LinkDoubleClicked Event

DiagramBase.LinkDoubleClicked Event
[image]

Raised when the user double-clicks a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkDoubleClicked

Visual Basic [image] Copy Code

Public Event LinkDoubleClicked As EventHandler(Of LinkEventArgs)

Event Data

LinkDoubleClicked event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been double-clicked.
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A Point specifying the mouse cursor position.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
LinkClicked Event


MindFusion.Diagramming.DiagramBase.LinkModified Event

DiagramBase.LinkModified Event
[image]

Raised when the user moves any control point of a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkModified

Visual Basic [image] Copy Code

Public Event LinkModified As EventHandler(Of LinkEventArgs)

Event Data

LinkModified event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been modified.
MousePosition | A Point specifying the mouse cursor position.
AdjustmentHandle | Index of the adjustment handle that has been moved.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
LinkModifying Event


MindFusion.Diagramming.DiagramBase.LinkModifying Event

DiagramBase.LinkModifying Event
[image]

A validation event raised while the user is modifying a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkValidationEventArgs> LinkModifying

Visual Basic [image] Copy Code

Public Event LinkModifying As EventHandler(Of LinkValidationEventArgs)

Event Data

LinkModifying event handlers receive an argument of type LinkValidationEventArgs. The following LinkValidationEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that is being modified.
MousePosition | A Point specifying the mouse cursor position.
AdjustmentHandle | Index of the adjustment handle that is being moved.
ChangingOrigin | A value indicating whether the operation changes the origin of the link.
Origin | The DiagramNode that will be set as the link's Origin if this event is validated.
ChangingDestination | A value indicating whether the operation changes the destination of the link.
Destination | The DiagramNode that will be set as the link's Destination if this event is validated.
AnchorIndex | Index of the anchor point to which the link will be connected if this event is validated.
TableRow | Index of the table row to which the link will be connected if this event is validated.
Cancel | Set this property to true to prevent the user from ending the modification at the current location. That displays the Stop mouse cursor and releasing the button will cancel the operation.
CancelDrag | Call this method to immediately stop the link modification.

Remarks

This event is raised after each mouse movement while modifying a link. Setting Cancel to true will change the mouse cursor to a Stop icon. The event is raised once again when the mouse button is released. Setting Cancel to true in that case will cancel the modification and return the link to its original state.

The AdjustmentHandle index corresponds to the link's control point that is being dragged.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
LinkModified Event


MindFusion.Diagramming.DiagramBase.LinkPasted Event

DiagramBase.LinkPasted Event
[image]

Raised when a link has been pasted from the clipboard.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkPasted

Visual Basic [image] Copy Code

Public Event LinkPasted As EventHandler(Of LinkEventArgs)

Event Data

LinkPasted event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been pasted from the clipboard.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
PasteFromClipboard Method


MindFusion.Diagramming.DiagramBase.LinkRouted Event

DiagramBase.LinkRouted Event
[image]

Raised when a link is routed by the auto-routing algorithm.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkRouted

Visual Basic [image] Copy Code

Public Event LinkRouted As EventHandler(Of LinkEventArgs)

Event Data

LinkRouted event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been routed.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
AutoRoute Property


MindFusion.Diagramming.DiagramBase.LinkSelected Event

DiagramBase.LinkSelected Event
[image]

Raised when a link is selected, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkSelected

Visual Basic [image] Copy Code

Public Event LinkSelected As EventHandler(Of LinkEventArgs)

Event Data

LinkSelected event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been selected.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
LinkDeselected Event
SelectionChanged Event


MindFusion.Diagramming.DiagramBase.LinkTextEdited Event

DiagramBase.LinkTextEdited Event
[image]

Raised when the user edits the text of a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<EditLinkTextEventArgs> LinkTextEdited

Visual Basic [image] Copy Code

Public Event LinkTextEdited As EventHandler(Of EditLinkTextEventArgs)

Event Data

LinkTextEdited event handlers receive an argument of type EditLinkTextEventArgs. The following EditLinkTextEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink whose text has been edited.
NewText | The link's new text.
OldText | The link's old text.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
AllowInplaceEdit Property
EnterInplaceEditMode Event
BeginEdit Method


MindFusion.Diagramming.DiagramBase.MagnifierFactorChanged Event

DiagramBase.MagnifierFactorChanged Event
[image]

Occurs when the magnifier factor changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler MagnifierFactorChanged

Visual Basic [image] Copy Code

Public Event MagnifierFactorChanged As EventHandler

Event Data

MagnifierFactorChanged event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
MagnifierFactor Property


MindFusion.Diagramming.DiagramBase.MeasureUnitChanged Event

DiagramBase.MeasureUnitChanged Event
[image]

Raised when the MeasureUnit property value has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler MeasureUnitChanged

Visual Basic [image] Copy Code

Public Event MeasureUnitChanged As EventHandler

Event Data

MeasureUnitChanged event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.NodeActivated Event

DiagramBase.NodeActivated Event
[image]

Raised when a node becomes the ActiveItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeActivated

Visual Basic [image] Copy Code

Public Event NodeActivated As EventHandler(Of NodeEventArgs)

Event Data

NodeActivated event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has become the ActiveItem.

Remarks

When this event is raised, ActiveItem already refers to the activated node. If multiple-selection is disabled, the active item is the only item selected by the user; otherwise usually it is the one added last to the selection.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
NodeSelected Event


MindFusion.Diagramming.DiagramBase.NodeClicked Event

DiagramBase.NodeClicked Event
[image]

Raised when the user clicks a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeClicked

Visual Basic [image] Copy Code

Public Event NodeClicked As EventHandler(Of NodeEventArgs)

Event Data

NodeClicked event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been clicked.
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A Point specifying the mouse cursor position.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
NodeDoubleClicked Event


MindFusion.Diagramming.DiagramBase.NodeCreated Event

DiagramBase.NodeCreated Event
[image]

Occurs when the user draws a new node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeCreated

Visual Basic [image] Copy Code

Public Event NodeCreated As EventHandler(Of NodeEventArgs)

Event Data

NodeCreated event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been created.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
InitializeNode Event
NodeDeleted Event


MindFusion.Diagramming.DiagramBase.NodeCreating Event

DiagramBase.NodeCreating Event
[image]

A validation event raised while the user is drawing a new node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeValidationEventArgs> NodeCreating

Visual Basic [image] Copy Code

Public Event NodeCreating As EventHandler(Of NodeValidationEventArgs)

Event Data

NodeCreating event handlers receive an argument of type NodeValidationEventArgs. The following NodeValidationEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that is being created.
MousePosition | A Point specifying the mouse cursor position.
Cancel | Set this property to true to prevent the user from creating the node at the current location. That displays the Stop mouse cursor and releasing the button will cancel the operation.
CancelDrag | Call this method to immediately stop the node creation.

Remarks

NodeCreating is raised after each mouse movement while drawing a new node. Setting Cancel to true will change the mouse cursor to a Stop icon. The event is raised once again when the mouse button is released. Setting Cancel to true in that case will cancel the node creation.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
NodeCreated Event


MindFusion.Diagramming.DiagramBase.NodeDeactivated Event

DiagramBase.NodeDeactivated Event
[image]

Raised when a node is no longer the ActiveItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeDeactivated

Visual Basic [image] Copy Code

Public Event NodeDeactivated As EventHandler(Of NodeEventArgs)

Event Data

NodeDeactivated event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | A DiagramNode that was the ActiveItem.

Remarks

NodeDeactivated is raised when the ActiveItem changes and before that it referred to a node.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
NodeActivated Event
NodeDeselected Event


MindFusion.Diagramming.DiagramBase.NodeDeleted Event

DiagramBase.NodeDeleted Event
[image]

Raised when a node is deleted, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeDeleted

Visual Basic [image] Copy Code

Public Event NodeDeleted As EventHandler(Of NodeEventArgs)

Event Data

NodeDeleted event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been deleted.

Remarks

When this event is raised, the node is already removed from the Items and Nodes collections and all links connected to the node are deleted. From within an event handler you can still check the values of simple properties of the node such as Text or Tag.

To prevent users from deleting a node by pressing the DEL key, handle the NodeCreating event.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
NodeDeleting Event
NodeCreated Event


MindFusion.Diagramming.DiagramBase.NodeDeleting Event

DiagramBase.NodeDeleting Event
[image]

Raised when the user tries to delete a node, this event lets you cancel the operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeValidationEventArgs> NodeDeleting

Visual Basic [image] Copy Code

Public Event NodeDeleting As EventHandler(Of NodeValidationEventArgs)

Event Data

NodeDeleting event handlers receive an argument of type NodeValidationEventArgs. The following NodeValidationEventArgs members provide information relevant to the event:

Member name | Description
Node | A DiagramNode that the user is trying to delete by pressing the DEL key.
Cancel | Set this property to true to prevent the user from deleting the node.

Remarks

When the user deletes a node, the links connected to it are deleted too. However, the LinkDeleting validation event is not raised in that case.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
DelKeyAction Property
NodeDeleted Event


MindFusion.Diagramming.DiagramBase.NodeDeselected Event

DiagramBase.NodeDeselected Event
[image]

Raised when a node is deselected, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeDeselected

Visual Basic [image] Copy Code

Public Event NodeDeselected As EventHandler(Of NodeEventArgs)

Event Data

NodeDeselected event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been deselected.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
NodeSelected Event


MindFusion.Diagramming.DiagramBase.NodeDoubleClicked Event

DiagramBase.NodeDoubleClicked Event
[image]

Raised when the user double-clicks a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeDoubleClicked

Visual Basic [image] Copy Code

Public Event NodeDoubleClicked As EventHandler(Of NodeEventArgs)

Event Data

NodeDoubleClicked event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been double-clicked.
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A Point specifying the mouse cursor position.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
NodeClicked Event


MindFusion.Diagramming.DiagramBase.NodeModified Event

DiagramBase.NodeModified Event
[image]

Raised when the user moves or resizes a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeModified

Visual Basic [image] Copy Code

Public Event NodeModified As EventHandler(Of NodeEventArgs)

Event Data

NodeModified event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been modified.
MousePosition | A Point specifying the mouse cursor position.
AdjustmentHandle | The adjustment handle that has been moved.

Remarks

NodeModified is not raised if the node position is changed programmatically. The event occurs only when the user has dragged an adjustment handle to a new position.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
NodeModifying Event
EnabledHandles Property


MindFusion.Diagramming.DiagramBase.NodeModifying Event

DiagramBase.NodeModifying Event
[image]

A validation event raised while the user is moving or resizing a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeValidationEventArgs> NodeModifying

Visual Basic [image] Copy Code

Public Event NodeModifying As EventHandler(Of NodeValidationEventArgs)

Event Data

NodeModifying event handlers receive an argument of type NodeValidationEventArgs. The following NodeValidationEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that is being modified.
MousePosition | A Point specifying the mouse cursor position.
AdjustmentHandle | The adjustment handle that is being moved.
Cancel | Set this property to true to prevent the user from ending the modification at the current location. That displays the Stop mouse cursor and releasing the button will cancel the operation.
CancelDrag | Call this method to immediately stop the node modification.

Remarks

This event is raised after each mouse movement while modifying a node. Setting Cancel to true will change the mouse cursor to a Stop icon. The event is raised once again when the mouse button is released. Setting Cancel to true in that case will cancel the modification and return the node to its original location.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
NodeModified Event
EnabledHandles Property


MindFusion.Diagramming.DiagramBase.NodePasted Event

DiagramBase.NodePasted Event
[image]

Raised when a node has been pasted from the clipboard.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodePasted

Visual Basic [image] Copy Code

Public Event NodePasted As EventHandler(Of NodeEventArgs)

Event Data

NodePasted event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been pasted from the clipboard.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
PasteFromClipboard Method


MindFusion.Diagramming.DiagramBase.NodeSelected Event

DiagramBase.NodeSelected Event
[image]

Raised when a node is selected, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeSelected

Visual Basic [image] Copy Code

Public Event NodeSelected As EventHandler(Of NodeEventArgs)

Event Data

NodeSelected event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been selected.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
NodeDeselected Event
SelectionChanged Event


MindFusion.Diagramming.DiagramBase.NodeTextEdited Event

DiagramBase.NodeTextEdited Event
[image]

Raised when the user edits the text of a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<EditNodeTextEventArgs> NodeTextEdited

Visual Basic [image] Copy Code

Public Event NodeTextEdited As EventHandler(Of EditNodeTextEventArgs)

Event Data

NodeTextEdited event handlers receive an argument of type EditNodeTextEventArgs. The following EditNodeTextEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode whose text has been edited.
NewText | The node's new text.
OldText | The node's old text.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
AllowInplaceEdit Property
EnterInplaceEditMode Event
BeginEdit Method


MindFusion.Diagramming.DiagramBase.Repaint Event

DiagramBase.Repaint Event
[image]

Raised when the diagram views should be repainted.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler Repaint

Visual Basic [image] Copy Code

Public Event Repaint As EventHandler

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.SelectionChanged Event

DiagramBase.SelectionChanged Event
[image]

Raised when an item is added to or removed from the selection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler SelectionChanged

Visual Basic [image] Copy Code

Public Event SelectionChanged As EventHandler

Event Data

SelectionChanged event handlers receive an argument of type EventArgs.

Remarks

Use the Nodes and Links properties of the diagram's Selection to find out which items are currently selected.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
NodeSelected Event
LinkSelected Event
NodeDeselected Event
LinkDeselected Event


MindFusion.Diagramming.DiagramBase.SelectionModified Event

DiagramBase.SelectionModified Event
[image]

Raised when the user moves or resizes multiple selected items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler SelectionModified

Visual Basic [image] Copy Code

Public Event SelectionModified As EventHandler

Event Data

SelectionModified event handlers receive an argument of type EventArgs.

Remarks

Use the Nodes and Links properties of the diagram's Selection to find out which items have been moved.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.SelectionModifying Event

DiagramBase.SelectionModifying Event
[image]

Raised while the user is moving or resizing multiple selected items, this event lets you cancel the modification.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<SelectionValidationEventArgs> SelectionModifying

Visual Basic [image] Copy Code

Public Event SelectionModifying As EventHandler(Of SelectionValidationEventArgs)

Event Data

SelectionModifying event handlers receive an argument of type ValidationEventArgs. The following ValidationEventArgs members provide information relevant to the event:

Member name | Description
Cancel | Set this property to true to prevent the user from placing the selected items at the current location. That displays the Stop mouse cursor and releasing the button will cancel the operation.
CancelDrag | Call this method to immediately stop the modification.

Remarks

This event is raised after each mouse movement while modifying a selection of items. Setting Cancel to true will change the mouse cursor to a Stop icon. The event is raised once again when the mouse button is released. Setting Cancel to true in that case will cancel the modification and return the items to their original position.

Use the Selection property of the Diagram class to access the selected items.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.SerializeControl Event

DiagramBase.SerializeControl Event
[image]

Lets you save the attributes of controls hosted inside ControlNodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<ControlNodeEventArgs> SerializeControl

Visual Basic [image] Copy Code

Public Event SerializeControl As EventHandler(Of ControlNodeEventArgs)

Event Data

SerializeControl event handlers receive an argument of type ControlNodeEventArgs. The following ControlNodeEventArgs members provide information relevant to the event:

Member name | Description
Handled | Gets or sets a value indicating whether the event is handled.
Node | Gets a reference to the ControlNode being serialized or deserialized.
XmlElement | The parent XElement where control data should be saved.

Example

C# [image] Copy Code

private void OnDiagramSerializeControl(object sender, ControlNodeEventArgs e)
{
TextBox control = e.Node.Control as TextBox;
e.Handled = true;
e.Context.WriteString(control.Text, &quot;Text&quot;, e.XmlElement);
}

private void OnDiagramDeserializeControl(object sender, ControlNodeEventArgs e)
{
e.Handled = true;
string text = e.Context.ReadString(&quot;Text&quot;, e.XmlElement);
e.Node.Control = new TextBox() { Text = text};
}

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.SerializeTag Event

DiagramBase.SerializeTag Event
[image]

Raised when the Tag of a diagram item must be serialized into an XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<SerializeTagEventArgs> SerializeTag

Visual Basic [image] Copy Code

Public Event SerializeTag As EventHandler(Of SerializeTagEventArgs)

Event Data

SerializeTag event handlers receive an argument of type SerializeTagEventArgs. The following SerializeTagEventArgs members provide information relevant to the event:

Member name | Description
Context | Gets a context object that can help you write and read various values.
Handled | Gets or sets a value indicating whether the event is handled.
Object | Gets the diagram or diagram element whose Tag is being saved.
PropertyName | Gets the name of the property being serialized.
Representation | Gets or sets an XElement where the tag should be serialized/deserialized.
Tag | Gets or sets the tag object being serialized/deserialized.

Example

C# [image] Copy Code

private void OnDiagramSerializeTag(object sender, SerializeTagEventArgs e)
{
e.Handled = true;
e.Context.WriteString(e.Tag as string, "Author", e.Representation);
}

void OnDiagramDeserializeTag(object sender, SerializeTagEventArgs e)
{
e.Handled = true;
string author = e.Context.ReadString("Author", e.Representation);

e.Tag = author;
}

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
DeserializeTag Event
SerializeControl Event


MindFusion.Diagramming.DiagramBase.SetSelfLoopShape Event

DiagramBase.SetSelfLoopShape Event
[image]

Raised when a link becomes a self-loop, giving you a chance to override the default look shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkShapeEventArgs> SetSelfLoopShape

Visual Basic [image] Copy Code

Public Event SetSelfLoopShape As EventHandler(Of LinkShapeEventArgs)

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.TreeCollapsed Event

DiagramBase.TreeCollapsed Event
[image]

Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> TreeCollapsed

Visual Basic [image] Copy Code

Public Event TreeCollapsed As EventHandler(Of NodeEventArgs)

Event Data

TreeCollapsed event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The root DiagramNode of the collapsed tree branch.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
TreeExpanded Event
ExpandButtonAction Property


MindFusion.Diagramming.DiagramBase.TreeExpanded Event

DiagramBase.TreeExpanded Event
[image]

Raised when a user expands a tree branch by clicking the [+] button of an Expandable node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> TreeExpanded

Visual Basic [image] Copy Code

Public Event TreeExpanded As EventHandler(Of NodeEventArgs)

Event Data

TreeExpanded event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The root DiagramNode of the expanded tree branch.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming Namespace
TreeCollapsed Event
ExpandButtonAction Property


MindFusion.Diagramming.DiagramBase.ValidateAnchorPoint Event

DiagramBase.ValidateAnchorPoint Event
[image]

A validation event that lets you approve or reject connecting a link to an anchor point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkValidationEventArgs> ValidateAnchorPoint

Visual Basic [image] Copy Code

Public Event ValidateAnchorPoint As EventHandler(Of LinkValidationEventArgs)

Event Data

ValidateAnchorPoint event handlers receive an argument of type LinkValidationEventArgs. The following LinkValidationEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that will be connected to the anchor point.
MousePosition | A Point specifying the mouse cursor position.
AdjustmentHandle | Index of the adjustment handle that is being moved.
ChangingOrigin | A value indicating whether the operation changes the origin of the link.
ChangingDestination | A value indicating whether the operation changes the destination of the link.
Node | The DiagramNode to which the link will be connected.
AnchorIndex | Index of an anchor point to which the link will be connected if this event is validated.
Cancel | Set this property to true to prevent connecting the link to specified point.

Remarks

This event is raised for each point of an AnchorPattern while a link's end point is being moved over a node. If none of the anchor points are validated, the mouse cursor icon changes to a Stop icon, indicating that the link cannot be connected to that node.

When the mouse button is released over a node, the event is raised again for the node's anchor points. From all validated anchor points, the one nearest to the dragged link end point is used to dock the link.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.ZoomFactorChanged Event

DiagramBase.ZoomFactorChanged Event
[image]

Occurs when the zoom factor changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler ZoomFactorChanged

Visual Basic [image] Copy Code

Public Event ZoomFactorChanged As EventHandler

Event Data

ZoomFactorChanged event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramDocument Class

DiagramDocument Class
[image]

Represents a collection of diagram pages.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramDocument : DiagramBase

Visual Basic [image] Copy Code

Public Class DiagramDocument
Inherits DiagramBase

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
Windows.UI.Xaml.Controls.ContentControl
MindFusion.Diagramming.DiagramBase
MindFusion.Diagramming.DiagramDocument

See Also

DiagramDocument Members


MindFusion.Diagramming.DiagramDocument Members

DiagramDocument Members
Constructors Properties Methods Events
[image]

Represents a collection of diagram pages.

The following tables list the members exposed by the DiagramDocument type.

Public Constructors

Name | Description
DiagramDocument | Initializes a new instance of the DiagramDocument class.

Public Properties

Name | Description
Pages | Gets a list of the diagram pages contained in this document.

Public Methods

Name | Description
FindPage | Returns the first page with the specified title.
LoadFromString | Loads a diagram from the specified string.
LoadFromXml | Overloaded.
SaveToString | Overloaded.
SaveToXml | Overloaded.

Inherited Protected Methods

Name | Description
OnActionRedone | Raises the ActionRedone event. (Inherited from DiagramBase.)
OnActionUndone | Raises the ActionUndone event. (Inherited from DiagramBase.)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramBase.)
OnCellClicked | Raises the CellClicked event. (Inherited from DiagramBase.)
OnCellDoubleClicked | Raises the CellDoubleClicked event. (Inherited from DiagramBase.)
OnClicked | Raises the Clicked event. (Inherited from DiagramBase.)
OnContainerChildAdded | Raises the ContainerChildAdded event. (Inherited from DiagramBase.)
OnContainerChildRemoved | Raises the ContainerChildRemoved event. (Inherited from DiagramBase.)
OnContainerFolded | Raises the ContainerFolded event. (Inherited from DiagramBase.)
OnContainerUnfolded | Raises the ContainerUnfolded event. (Inherited from DiagramBase.)
OnDeserializeControl | Raises the DeserializeControl event. (Inherited from DiagramBase.)
OnDeserializeTag | Raises the DeserializeTag event. (Inherited from DiagramBase.)
OnDoubleClicked | Raises the DoubleClicked event. (Inherited from DiagramBase.)
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event. (Inherited from DiagramBase.)
OnEnterInplaceEditMode | Raises the EnterInplaceEditMode event. (Inherited from DiagramBase.)
OnExpandButtonClicked | Raises the ExpandButtonClicked event. (Inherited from DiagramBase.)
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event. (Inherited from DiagramBase.)
OnInitializeLink | Raises the InitializeLink event. (Inherited from DiagramBase.)
OnInitializeNode | Raises the InitializeNode event. (Inherited from DiagramBase.)
OnItemAdded | Raises the ItemAdded event. (Inherited from DiagramBase.)
OnItemRemoved | Raises the ItemRemoved event. (Inherited from DiagramBase.)
OnLaneGridCellCreated | Raises the LaneGridCellCreated event. (Inherited from DiagramBase.)
OnLaneGridHeaderCreated | Raises the LaneGridHeaderCreated event. (Inherited from DiagramBase.)
OnLeaveInplaceEditMode | Raises the LeaveInplaceEditMode event. (Inherited from DiagramBase.)
OnLinkActivated | Raises the LinkActivated event. (Inherited from DiagramBase.)
OnLinkClicked | Raises the LinkClicked event. (Inherited from DiagramBase.)
OnLinkCreated | Raises the LinkCreated event. (Inherited from DiagramBase.)
OnLinkCreating | Raises the LinkCreating event. (Inherited from DiagramBase.)
OnLinkDeactivated | Raises the LinkDeactivated event. (Inherited from DiagramBase.)
OnLinkDeleted | Raises the LinkDeleted event. (Inherited from DiagramBase.)
OnLinkDeleting | Raises the LinkDeleting event. (Inherited from DiagramBase.)
OnLinkDeselected | Raises the LinkDeselected event. (Inherited from DiagramBase.)
OnLinkDoubleClicked | Raises the LinkDoubleClicked event. (Inherited from DiagramBase.)
OnLinkModified | Raises the LinkModified event. (Inherited from DiagramBase.)
OnLinkModifying | Raises the LinkModifying event. (Inherited from DiagramBase.)
OnLinkPasted | Raises the LinkPasted event. (Inherited from DiagramBase.)
OnLinkRouted | Raises the LinkRouted event. (Inherited from DiagramBase.)
OnLinkSelected | Raises the LinkSelected event. (Inherited from DiagramBase.)
OnLinkTextEdited | Raises the LinkTextEdited event. (Inherited from DiagramBase.)
OnMagnifierFactorChanged | Raises the MagnifierFactorChanged event. (Inherited from DiagramBase.)
OnMeasureUnitChanged | Raises the MeasureUnitChanged event. (Inherited from DiagramBase.)
OnNodeActivated | Raises the NodeActivated event. (Inherited from DiagramBase.)
OnNodeClicked | Raises the NodeClicked event. (Inherited from DiagramBase.)
OnNodeCreated | Raises the NodeCreated event. (Inherited from DiagramBase.)
OnNodeCreating | Raises the NodeCreating event. (Inherited from DiagramBase.)
OnNodeDeactivated | Raises the NodeDeactivated event. (Inherited from DiagramBase.)
OnNodeDeleted | Raises the NodeDeleted event. (Inherited from DiagramBase.)
OnNodeDeleting | Raises the NodeDeleting event. (Inherited from DiagramBase.)
OnNodeDeselected | Raises the NodeDeselected event. (Inherited from DiagramBase.)
OnNodeDoubleClicked | Raises the NodeDoubleClicked event. (Inherited from DiagramBase.)
OnNodeModified | Raises the NodeModified event. (Inherited from DiagramBase.)
OnNodeModifying | Raises the NodeModifying event. (Inherited from DiagramBase.)
OnNodePasted | Raises the NodePasted event. (Inherited from DiagramBase.)
OnNodeSelected | Raises the NodeSelected event. (Inherited from DiagramBase.)
OnNodeTextEdited | Raises the NodeTextEdited event. (Inherited from DiagramBase.)
OnRepaint | Raises the Repaint event. (Inherited from DiagramBase.)
OnSelectionChanged | Raises the SelectionChanged event. (Inherited from DiagramBase.)
OnSelectionModified | Raises the SelectionModified event. (Inherited from DiagramBase.)
OnSelectionModifying | Raises the SelectionModifying event. (Inherited from DiagramBase.)
OnSerializeControl | Raises the SerializeControl event. (Inherited from DiagramBase.)
OnSerializeTag | Raises the SerializeTag event. (Inherited from DiagramBase.)
OnSetSelfLoopShape | Raises the SetSelfLoopShape event. (Inherited from DiagramBase.)
OnTreeCollapsed | Raises the TreeCollapsed event. (Inherited from DiagramBase.)
OnTreeExpanded | Raises the TreeExpanded event. (Inherited from DiagramBase.)
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event. (Inherited from DiagramBase.)
OnZoomFactorChanged | Raises the ZoomFactorChanged event. (Inherited from DiagramBase.)

Inherited Public Events

Name | Description
ActionRedone | Raised when an action is redone. (Inherited from DiagramBase.)
ActionUndone | Raised when an action is undone. (Inherited from DiagramBase.)
ActiveLayerChanged | Raised when the diagram's active layer has changed. (Inherited from DiagramBase.)
BoundsChanged | Raised when the Bounds property value has changed. (Inherited from DiagramBase.)
CellClicked | Raised when the user clicks a table's cell. (Inherited from DiagramBase.)
CellDoubleClicked | Raised when the user double-clicks a table's cell. (Inherited from DiagramBase.)
Clicked | Raised when the user clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area. (Inherited from DiagramBase.)
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area. (Inherited from DiagramBase.)
DeserializeControl | Lets you load the attributes of controls hosted inside ControlNodes. (Inherited from DiagramBase.)
DeserializeTag | Raised when the Tag or Id of a diagram item must be deserialized from XML format. (Inherited from DiagramBase.)
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
DrawAdjustmentHandles | Raised when item's adjustment handles must be custom drawn. (Inherited from DiagramBase.)
EnterInplaceEditMode | Raised when entering inplace-edit mode. (Inherited from DiagramBase.)
ExpandButtonClicked | Raised when the user clicks the [+/-] button of an Expandable node. (Inherited from DiagramBase.)
HitTestAdjustmentHandles | Raised when custom hit testing of item's adjustment handles must be performed. (Inherited from DiagramBase.)
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created. (Inherited from DiagramBase.)
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created. (Inherited from DiagramBase.)
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
LaneGridCellCreated | Raised when a lane grid's cell has been created to allow additional cusomtization of its presentation. (Inherited from DiagramBase.)
LaneGridHeaderCreated | Raised when a lane grid's header has been created to allow additional cusomtization of its presentation. (Inherited from DiagramBase.)
LeaveInplaceEditMode | Raised when leaving inplace-edit mode. (Inherited from DiagramBase.)
LinkActivated | Raised when a link becomes the ActiveItem. (Inherited from DiagramBase.)
LinkClicked | Raised when the user clicks a link. (Inherited from DiagramBase.)
LinkCreated | Raised when the user draws a new link. (Inherited from DiagramBase.)
LinkCreating | A validation event raised while the user is drawing a new link. (Inherited from DiagramBase.)
LinkDeactivated | Raised when a link is no longer the ActiveItem. (Inherited from DiagramBase.)
LinkDeleted | Raised when a link is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkDeselected | Raised when a link is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDoubleClicked | Raised when the user double-clicks a link. (Inherited from DiagramBase.)
LinkModified | Raised when the user moves any control point of a link. (Inherited from DiagramBase.)
LinkModifying | A validation event raised while the user is modifying a link. (Inherited from DiagramBase.)
LinkPasted | Raised when a link has been pasted from the clipboard. (Inherited from DiagramBase.)
LinkRouted | Raised when a link is routed by the auto-routing algorithm. (Inherited from DiagramBase.)
LinkSelected | Raised when a link is selected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkTextEdited | Raised when the user edits the text of a link. (Inherited from DiagramBase.)
MagnifierFactorChanged | Occurs when the magnifier factor changes. (Inherited from DiagramBase.)
MeasureUnitChanged | Raised when the MeasureUnit property value has changed. (Inherited from DiagramBase.)
NodeActivated | Raised when a node becomes the ActiveItem. (Inherited from DiagramBase.)
NodeClicked | Raised when the user clicks a node. (Inherited from DiagramBase.)
NodeCreated | Occurs when the user draws a new node. (Inherited from DiagramBase.)
NodeCreating | A validation event raised while the user is drawing a new node. (Inherited from DiagramBase.)
NodeDeactivated | Raised when a node is no longer the ActiveItem. (Inherited from DiagramBase.)
NodeDeleted | Raised when a node is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeDeselected | Raised when a node is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDoubleClicked | Raised when the user double-clicks a node. (Inherited from DiagramBase.)
NodeModified | Raised when the user moves or resizes a node. (Inherited from DiagramBase.)
NodeModifying | A validation event raised while the user is moving or resizing a node. (Inherited from DiagramBase.)
NodePasted | Raised when a node has been pasted from the clipboard. (Inherited from DiagramBase.)
NodeSelected | Raised when a node is selected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeTextEdited | Raised when the user edits the text of a node. (Inherited from DiagramBase.)
Repaint | Raised when the diagram views should be repainted. (Inherited from DiagramBase.)
SelectionChanged | Raised when an item is added to or removed from the selection. (Inherited from DiagramBase.)
SelectionModified | Raised when the user moves or resizes multiple selected items. (Inherited from DiagramBase.)
SelectionModifying | Raised while the user is moving or resizing multiple selected items, this event lets you cancel the modification. (Inherited from DiagramBase.)
SerializeControl | Lets you save the attributes of controls hosted inside ControlNodes. (Inherited from DiagramBase.)
SerializeTag | Raised when the Tag of a diagram item must be serialized into an XML document. (Inherited from DiagramBase.)
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape. (Inherited from DiagramBase.)
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node. (Inherited from DiagramBase.)
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node. (Inherited from DiagramBase.)
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point. (Inherited from DiagramBase.)
ZoomFactorChanged | Occurs when the zoom factor changes. (Inherited from DiagramBase.)

See Also

DiagramDocument Class


MindFusion.Diagramming.DiagramDocument Constructor

DiagramDocument Constructor
[image]

Initializes a new instance of the DiagramDocument class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramDocument ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramDocument Class


MindFusion.Diagramming.DiagramDocument Methods

DiagramDocument Methods
[image]

Public Methods

Name | Description
FindPage | Returns the first page with the specified title.
LoadFromString | Loads a diagram from the specified string.
LoadFromXml | Overloaded.
SaveToString | Overloaded.
SaveToXml | Overloaded.

Inherited Protected Methods

Name | Description
OnActionRedone | Raises the ActionRedone event. (Inherited from DiagramBase.)
OnActionUndone | Raises the ActionUndone event. (Inherited from DiagramBase.)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramBase.)
OnCellClicked | Raises the CellClicked event. (Inherited from DiagramBase.)
OnCellDoubleClicked | Raises the CellDoubleClicked event. (Inherited from DiagramBase.)
OnClicked | Raises the Clicked event. (Inherited from DiagramBase.)
OnContainerChildAdded | Raises the ContainerChildAdded event. (Inherited from DiagramBase.)
OnContainerChildRemoved | Raises the ContainerChildRemoved event. (Inherited from DiagramBase.)
OnContainerFolded | Raises the ContainerFolded event. (Inherited from DiagramBase.)
OnContainerUnfolded | Raises the ContainerUnfolded event. (Inherited from DiagramBase.)
OnDeserializeControl | Raises the DeserializeControl event. (Inherited from DiagramBase.)
OnDeserializeTag | Raises the DeserializeTag event. (Inherited from DiagramBase.)
OnDoubleClicked | Raises the DoubleClicked event. (Inherited from DiagramBase.)
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event. (Inherited from DiagramBase.)
OnEnterInplaceEditMode | Raises the EnterInplaceEditMode event. (Inherited from DiagramBase.)
OnExpandButtonClicked | Raises the ExpandButtonClicked event. (Inherited from DiagramBase.)
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event. (Inherited from DiagramBase.)
OnInitializeLink | Raises the InitializeLink event. (Inherited from DiagramBase.)
OnInitializeNode | Raises the InitializeNode event. (Inherited from DiagramBase.)
OnItemAdded | Raises the ItemAdded event. (Inherited from DiagramBase.)
OnItemRemoved | Raises the ItemRemoved event. (Inherited from DiagramBase.)
OnLaneGridCellCreated | Raises the LaneGridCellCreated event. (Inherited from DiagramBase.)
OnLaneGridHeaderCreated | Raises the LaneGridHeaderCreated event. (Inherited from DiagramBase.)
OnLeaveInplaceEditMode | Raises the LeaveInplaceEditMode event. (Inherited from DiagramBase.)
OnLinkActivated | Raises the LinkActivated event. (Inherited from DiagramBase.)
OnLinkClicked | Raises the LinkClicked event. (Inherited from DiagramBase.)
OnLinkCreated | Raises the LinkCreated event. (Inherited from DiagramBase.)
OnLinkCreating | Raises the LinkCreating event. (Inherited from DiagramBase.)
OnLinkDeactivated | Raises the LinkDeactivated event. (Inherited from DiagramBase.)
OnLinkDeleted | Raises the LinkDeleted event. (Inherited from DiagramBase.)
OnLinkDeleting | Raises the LinkDeleting event. (Inherited from DiagramBase.)
OnLinkDeselected | Raises the LinkDeselected event. (Inherited from DiagramBase.)
OnLinkDoubleClicked | Raises the LinkDoubleClicked event. (Inherited from DiagramBase.)
OnLinkModified | Raises the LinkModified event. (Inherited from DiagramBase.)
OnLinkModifying | Raises the LinkModifying event. (Inherited from DiagramBase.)
OnLinkPasted | Raises the LinkPasted event. (Inherited from DiagramBase.)
OnLinkRouted | Raises the LinkRouted event. (Inherited from DiagramBase.)
OnLinkSelected | Raises the LinkSelected event. (Inherited from DiagramBase.)
OnLinkTextEdited | Raises the LinkTextEdited event. (Inherited from DiagramBase.)
OnMagnifierFactorChanged | Raises the MagnifierFactorChanged event. (Inherited from DiagramBase.)
OnMeasureUnitChanged | Raises the MeasureUnitChanged event. (Inherited from DiagramBase.)
OnNodeActivated | Raises the NodeActivated event. (Inherited from DiagramBase.)
OnNodeClicked | Raises the NodeClicked event. (Inherited from DiagramBase.)
OnNodeCreated | Raises the NodeCreated event. (Inherited from DiagramBase.)
OnNodeCreating | Raises the NodeCreating event. (Inherited from DiagramBase.)
OnNodeDeactivated | Raises the NodeDeactivated event. (Inherited from DiagramBase.)
OnNodeDeleted | Raises the NodeDeleted event. (Inherited from DiagramBase.)
OnNodeDeleting | Raises the NodeDeleting event. (Inherited from DiagramBase.)
OnNodeDeselected | Raises the NodeDeselected event. (Inherited from DiagramBase.)
OnNodeDoubleClicked | Raises the NodeDoubleClicked event. (Inherited from DiagramBase.)
OnNodeModified | Raises the NodeModified event. (Inherited from DiagramBase.)
OnNodeModifying | Raises the NodeModifying event. (Inherited from DiagramBase.)
OnNodePasted | Raises the NodePasted event. (Inherited from DiagramBase.)
OnNodeSelected | Raises the NodeSelected event. (Inherited from DiagramBase.)
OnNodeTextEdited | Raises the NodeTextEdited event. (Inherited from DiagramBase.)
OnRepaint | Raises the Repaint event. (Inherited from DiagramBase.)
OnSelectionChanged | Raises the SelectionChanged event. (Inherited from DiagramBase.)
OnSelectionModified | Raises the SelectionModified event. (Inherited from DiagramBase.)
OnSelectionModifying | Raises the SelectionModifying event. (Inherited from DiagramBase.)
OnSerializeControl | Raises the SerializeControl event. (Inherited from DiagramBase.)
OnSerializeTag | Raises the SerializeTag event. (Inherited from DiagramBase.)
OnSetSelfLoopShape | Raises the SetSelfLoopShape event. (Inherited from DiagramBase.)
OnTreeCollapsed | Raises the TreeCollapsed event. (Inherited from DiagramBase.)
OnTreeExpanded | Raises the TreeExpanded event. (Inherited from DiagramBase.)
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event. (Inherited from DiagramBase.)
OnZoomFactorChanged | Raises the ZoomFactorChanged event. (Inherited from DiagramBase.)

See Also

DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.FindPage Method

DiagramDocument.FindPage Method
[image]

Returns the first page with the specified title.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramPage FindPage (
string title,
StringComparison comparison
)

Visual Basic [image] Copy Code

Public Function FindPage( _
title As String, _
comparison As StringComparison _
) As DiagramPage

Parameters

title

comparison

Return Value

A DiagramPage instance.

See Also

DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.LoadFromString Method

DiagramDocument.LoadFromString Method
[image]

Loads a diagram from the specified string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromString (
string str
)

Visual Basic [image] Copy Code

Public Sub LoadFromString( _
str As String _
)

Parameters

str

See Also

DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.LoadFromXml Method

DiagramDocument.LoadFromXml Method
[image]

Overload List

Name | Description
DiagramDocument.LoadFromXml (Stream) | Loads the contents of an XML diagram document from the specified stream.
DiagramDocument.LoadFromXml (String) | Loads the document from the specified XML file.
DiagramDocument.LoadFromXml (XDocument) | Loads the document from the specified XDocument object.

See Also

DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.LoadFromXml Method (Stream)

DiagramDocument.LoadFromXml Method (Stream)
See Also
[image]

Loads the contents of an XML diagram document from the specified stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
Stream stream
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
stream As Stream _
)

Parameters

stream

See Also

LoadFromXml Method Overload List
DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.LoadFromXml Method (String)

DiagramDocument.LoadFromXml Method (String)
See Also
[image]

Loads the document from the specified XML file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
fileName As String _
)

Parameters

fileName

The name of the file the data should be read from.

See Also

LoadFromXml Method Overload List
DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.LoadFromXml Method (XDocument)

DiagramDocument.LoadFromXml Method (XDocument)
See Also
[image]

Loads the document from the specified XDocument object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
XDocument document
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
document As XDocument _
)

Parameters

document

A .NET XDocument object from which to load the diagram data.

See Also

LoadFromXml Method Overload List
DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.SaveToString Method

DiagramDocument.SaveToString Method
[image]

Overload List

Name | Description
DiagramDocument.SaveToString () | Saves the document as an ASCII string.
DiagramDocument.SaveToString (SaveToStringFormat, Boolean) | Saves the document as an ASCII string.

See Also

DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.SaveToString Method ()

DiagramDocument.SaveToString Method ()
See Also
[image]

Saves the document as an ASCII string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string SaveToString ()

Visual Basic [image] Copy Code

Public Function SaveToString () As String

Return Value

See Also

SaveToString Method Overload List
DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.SaveToString Method (SaveToStringFormat, Boolean)

DiagramDocument.SaveToString Method (SaveToStringFormat, Boolean)
See Also
[image]

Saves the document as an ASCII string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string SaveToString (
SaveToStringFormat format,
bool clearDirty
)

Visual Basic [image] Copy Code

Public Function SaveToString( _
format As SaveToStringFormat, _
clearDirty As Boolean _
) As String

Parameters

format

One of the SaveToStringFormat values.

clearDirty

Indicates whether the 'dirty' flag should be cleared.

Return Value

See Also

SaveToString Method Overload List
DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.SaveToXml Method

DiagramDocument.SaveToXml Method
[image]

Overload List

Name | Description
DiagramDocument.SaveToXml (Stream) | Saves the diagram to the specified stream as an XML document.
DiagramDocument.SaveToXml (String) | Saves the document to the specified file in an XML format.
DiagramDocument.SaveToXml (XDocument) | Saves the document to the specified XDocument object.

See Also

DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.SaveToXml Method (Stream)

DiagramDocument.SaveToXml Method (Stream)
See Also
[image]

Saves the diagram to the specified stream as an XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
Stream s
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
s As Stream _
)

Parameters

s

An instance of a System.IO.Stream-derived class.

Remarks

Serializes the current diagram as a sequence of bytes represented by stream.

See Also

SaveToXml Method Overload List
DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.SaveToXml Method (String)

DiagramDocument.SaveToXml Method (String)
See Also
[image]

Saves the document to the specified file in an XML format.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
fileName As String _
)

Parameters

fileName

The name of the file where the document should be saved.

See Also

SaveToXml Method Overload List
DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.SaveToXml Method (XDocument)

DiagramDocument.SaveToXml Method (XDocument)
See Also
[image]

Saves the document to the specified XDocument object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
XDocument document
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
document As XDocument _
)

Parameters

document

A .NET XDocument object where the document should be saved.

See Also

SaveToXml Method Overload List
DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramDocument Properties

DiagramDocument Properties
[image]

Public Properties

Name | Description
Pages | Gets a list of the diagram pages contained in this document.

See Also

DiagramDocument Class


MindFusion.Diagramming.DiagramDocument.Pages Property

DiagramDocument.Pages Property
[image]

Gets a list of the diagram pages contained in this document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ObservableCollection<DiagramPage> Pages { get; set; }

Visual Basic [image] Copy Code

Public Property Pages As ObservableCollection(Of DiagramPage)

Property Value

A list of all document pages.

See Also

DiagramDocument Members
DiagramDocument Class


MindFusion.Diagramming.DiagramEventArgs Class

DiagramEventArgs Class
[image]

Contains the arguments passed to event handlers, such as Clicked and DoubleClicked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DiagramEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.DiagramEventArgs

See Also

DiagramEventArgs Members


MindFusion.Diagramming.DiagramEventArgs Members

DiagramEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to event handlers, such as Clicked and DoubleClicked.

The following tables list the members exposed by the DiagramEventArgs type.

Public Constructors

Name | Description
DiagramEventArgs | Initializes a new instance of the DiagramEventArgs class.

Public Properties

Name | Description
MouseButton | Gets or sets which mouse button has been pressed.
MousePosition | Gets or sets the current mouse pointer position.

See Also

DiagramEventArgs Class


MindFusion.Diagramming.DiagramEventArgs Constructor

DiagramEventArgs Constructor
[image]

Initializes a new instance of the DiagramEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramEventArgs (
MouseButton mouseButton,
Point mousePosition
)

Visual Basic [image] Copy Code

Public New ( _
mouseButton As MouseButton, _
mousePosition As Point _
)

Parameters

mouseButton

The mouse button related to the event.

mousePosition

The cursor location at the time the event is raised, expressed in document coordinates.

See Also

DiagramEventArgs Class


MindFusion.Diagramming.DiagramEventArgs Properties

DiagramEventArgs Properties
[image]

Public Properties

Name | Description
MouseButton | Gets or sets which mouse button has been pressed.
MousePosition | Gets or sets the current mouse pointer position.

See Also

DiagramEventArgs Class


MindFusion.Diagramming.DiagramEventArgs.MouseButton Property

DiagramEventArgs.MouseButton Property
[image]

Gets or sets which mouse button has been pressed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MouseButton MouseButton { get; set; }

Visual Basic [image] Copy Code

Public Property MouseButton As MouseButton

Property Value

A member of the MouseButton enumeration indicating which button was clicked.

See Also

DiagramEventArgs Members
DiagramEventArgs Class


MindFusion.Diagramming.DiagramEventArgs.MousePosition Property

DiagramEventArgs.MousePosition Property
[image]

Gets or sets the current mouse pointer position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point MousePosition { get; set; }

Visual Basic [image] Copy Code

Public Property MousePosition As Point

Property Value

A Windows.UI.Xaml.Point object.

See Also

DiagramEventArgs Members
DiagramEventArgs Class


MindFusion.Diagramming.DiagramItem Class

DiagramItem Class
Remarks See Also
[image]

Represents an item in the diagram document. All classes representing diagram elements derive from DiagramItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class DiagramItem : ContentControl

Visual Basic [image] Copy Code

Public MustInherit Class DiagramItem
Inherits ContentControl

Remarks

All items in the diagram document - links and nodes - share common base class called DiagramItem. Its main function is to provide interface for the most common methods and properties of every diagram element.

Items can be locked for interactive modification through the Locked property. Locked items can still be modified programmatically. Items can also be marked as locked for automatic layout methods through the IgnoreLayout property.

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
Windows.UI.Xaml.Controls.ContentControl
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramLink
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.Selection

See Also

DiagramItem Members


MindFusion.Diagramming.DiagramItem Members

DiagramItem Members
Constructors Fields Properties Methods
[image]

Represents an item in the diagram document. All classes representing diagram elements derive from DiagramItem.

The following tables list the members exposed by the DiagramItem type.

Protected Constructors

Name | Description
DiagramItem | Overloaded.

Public Fields

Name | Description
AutoCaptureMouseProperty | Identifies the AutoCaptureMouse dependency property.
BrushProperty | Identifies the Brush dependency property.
HyperLinkProperty | Identifies the HyperLink dependency property.
IsMouseDownProperty | Identifies the IsMouseDown dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property.
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property.
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property.
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property.
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property.
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
TextBrushProperty | Identifies the TextBrush dependency property.

Protected Fields

Name | Description
handles | A list of the Rectangle objects that represent the item's adjustment handles.

Public Properties

Name | Description
AutoCaptureMouse | Gets or sets whether the item should capture the mouse input when the left button is pressed over it. This is a dependency property.
Brush | Gets or sets the Brush that specifies how to paint the interior of the item. This is a dependency property.
Diagram | Gets the parent diagram.
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like.
HyperLink | Gets or sets the hyperlink associated with this diagram item. This is a dependency property.
Id | Gets or sets user-defined identifier associated with this item.
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods.
IsMouseDown | Gets a value indicating whether the mouse button is pressed over this item. This is a dependency property.
IsMouseOver | Gets a value indicating whether the mouse pointer is located over this item. This is a dependency property.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer.
LayoutTraits | Contains properties specific to each layout algorithm.
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item.
RuntimeIndex | For internal use.
Selected | Gets or sets a value indicating whether a diagram item is selected.
Stroke | Gets or sets the Brush that specifies how the item outline is painted.
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline nodes. This is a dependency property.
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn.
StrokeDashOffset | Gets or sets a double value that specifies the distance within the dash pattern where a dash begins. This is a dependency property.
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke.
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline.
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. This is a dependency property.
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke.
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline.
TextBrush | Gets or sets the brush used to draw the item's text.
ToolTip | Gets or sets the contents of the tooltip displayed when the mouse pointer rests over the diagram element.
Visible | Gets or sets a value indicating whether this item is visible.
Weight | Gets or sets a weight value used in layout and path-finding algorithms.
ZIndex | Gets or sets the z-order position of the object.

Protected Properties

Name | Description
Size | Gets the size of this item.

Public Methods

Name | Description
Clone | Creates a copy of this item.
ContainsPoint | Determines whether this item contains the specified point.
GetBounds | Gets the bounding rectangle of this item.
GetOutlinePoly | Gets a polygon approximating the outline of this object.
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow.
GetRotatedBounds | Gets the bounding rectangle of this item when it is rotated.
HitTestHandle | Determines whether a selection handle of this item is located at the specified point.
NotInteractive | Gets whether the user is prevented from manipulating this item.
OnApplyTemplate | Control.OnApplyTemplate override.
RestoreLocationState | Restores the state of this diagram item.
SaveLocationState | Saves the state of this diagram item.
TransformDiagramToItem | Transforms a point in diagram coordinates to item coordinates.
TransformItemToDiagram | Gets the diagram coordinates of a point specified in the local coordinate system of this item.
ZBottom | Moves the item to the bottom of the z-order.
ZLevelDown | Moves the item one level down in the z-order.
ZLevelUp | Moves the item one level up in the z-order.
ZTop | Moves the item to the top of the z-order.

Protected Methods

Name | Description
AddHandlesToCanvas | Overloaded.
AllowDrag | Invoked to validate the drag operation.
CancelDrag | Invoked when the interactive modification of this object has been canceled.
CreateState | Creates an item state corresponding to the type of this diagram item.
EndDrag | Invoked when the user stops dragging this item.
LoadFromXml | Loads the item content from an XML element.
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo.
OnChildModified | Called when a group child node has been modified.
OnLoad | Called after successful deserialization.
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes.
OnMouseEnter | Control.OnMouseEnter override.
OnMouseLeave | Control.OnMouseLeave override.
OnMouseLeftButtonDown | Control.OnMouseLeftButtonDown override.
OnMouseLeftButtonUp | Control.OnMouseLeftButtonUp override.
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo.
RemoveHandlesFromCanvas | Invoked when the item's selection handles should be removed.
RestoreState | Restores the state of this diagram item.
SaveState | Saves the state of this diagram item.
SaveToXml | Saves the item content into an XML element.
StartDrag | Invoked when the user starts dragging this item.
UpdateDrag | Invoked while the user drags this item.
UpdateHandleColors | Sets the handle colors according to the current selection state of the item and the enabled bits in the EnabledHandles property.
UpdateHandlePositions | Invoked when the item's selection handles should change their position.
UpdateStates | Sets the current VisualStates of this item.
UpdateVisuals | Invoked when an item should update its visual elements.

See Also

DiagramItem Class


MindFusion.Diagramming.DiagramItem Fields

DiagramItem Fields
[image]

Public Fields

Name | Description
AutoCaptureMouseProperty | Identifies the AutoCaptureMouse dependency property.
BrushProperty | Identifies the Brush dependency property.
HyperLinkProperty | Identifies the HyperLink dependency property.
IsMouseDownProperty | Identifies the IsMouseDown dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property.
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property.
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property.
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property.
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property.
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
TextBrushProperty | Identifies the TextBrush dependency property.

Protected Fields

Name | Description
handles | A list of the Rectangle objects that represent the item's adjustment handles.

See Also

DiagramItem Class


MindFusion.Diagramming.DiagramItem.AutoCaptureMouseProperty Field

DiagramItem.AutoCaptureMouseProperty Field
[image]

Identifies the AutoCaptureMouse dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AutoCaptureMouseProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AutoCaptureMouseProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.BrushProperty Field

DiagramItem.BrushProperty Field
[image]

Identifies the Brush dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BrushProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.handles Field

DiagramItem.handles Field
[image]

A list of the Rectangle objects that represent the item's adjustment handles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected List<Shape> handles

Visual Basic [image] Copy Code

Protected handles As List(Of Shape)

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.HyperLinkProperty Field

DiagramItem.HyperLinkProperty Field
[image]

Identifies the HyperLink dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HyperLinkProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HyperLinkProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.IsMouseDownProperty Field

DiagramItem.IsMouseDownProperty Field
[image]

Identifies the IsMouseDown dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsMouseDownProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsMouseDownProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.IsMouseOverProperty Field

DiagramItem.IsMouseOverProperty Field
[image]

Identifies the IsMouseOver dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsMouseOverProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.StrokeDashArrayProperty Field

DiagramItem.StrokeDashArrayProperty Field
[image]

Identifies the StrokeDashArray dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeDashArrayProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeDashArrayProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.StrokeDashCapProperty Field

DiagramItem.StrokeDashCapProperty Field
[image]

Identifies the StrokeDashCap dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeDashCapProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeDashCapProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.StrokeDashOffsetProperty Field

DiagramItem.StrokeDashOffsetProperty Field
[image]

Identifies the StrokeDashOffset dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeDashOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeDashOffsetProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.StrokeEndLineCapProperty Field

DiagramItem.StrokeEndLineCapProperty Field
[image]

Identifies the StrokeEndLineCap dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeEndLineCapProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeEndLineCapProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.StrokeLineJoinProperty Field

DiagramItem.StrokeLineJoinProperty Field
[image]

Identifies the StrokeLineJoin dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeLineJoinProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeLineJoinProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.StrokeMiterLimitProperty Field

DiagramItem.StrokeMiterLimitProperty Field
[image]

Identifies the StrokeMiterLimit dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeMiterLimitProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeMiterLimitProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.StrokeProperty Field

DiagramItem.StrokeProperty Field
[image]

Identifies the Stroke dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.StrokeStartLineCapProperty Field

DiagramItem.StrokeStartLineCapProperty Field
[image]

Identifies the StrokeStartLineCap dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeStartLineCapProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeStartLineCapProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.StrokeThicknessProperty Field

DiagramItem.StrokeThicknessProperty Field
[image]

Identifies the StrokeThickness dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeThicknessProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.TextBrushProperty Field

DiagramItem.TextBrushProperty Field
[image]

Identifies the TextBrush dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextBrushProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem Constructor

DiagramItem Constructor
[image]

Overload List

Name | Description
DiagramItem () | Initializes a new instance of the DiagramItem class.
DiagramItem (Diagram) | Initializes a new instance of the DiagramItem class.
DiagramItem (DiagramItem) | Initializes a new instance of the DiagramItem class using the specified diagram item as a prototype.

See Also

DiagramItem Class


MindFusion.Diagramming.DiagramItem Constructor ()

DiagramItem Constructor ()
See Also
[image]

Initializes a new instance of the DiagramItem class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DiagramItem ()

Visual Basic [image] Copy Code

Protected Sub New ()

Remarks

This constructor leaves the item's dependency properties in their default state, without local values. This allows the item to be styled through the WinRT styling mechanism.

See Also

DiagramItem Constructor Overload List
DiagramItem Class


MindFusion.Diagramming.DiagramItem Constructor (Diagram)

DiagramItem Constructor (Diagram)
See Also
[image]

Initializes a new instance of the DiagramItem class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem (
Diagram parent
)

Visual Basic [image] Copy Code

Public Sub DiagramItem ( _
parent As Diagram _
)

Parameters

parent
The Diagram from which to obtain default values for the item properties.

Remarks

This constructor initializes the DiagramItem properties with the values specified in the respective default-value properties of the Diagram object.

See Also

DiagramItem Constructor Overload List
DiagramItem Class


MindFusion.Diagramming.DiagramItem Constructor (DiagramItem)

DiagramItem Constructor (DiagramItem)
See Also
[image]

Initializes a new instance of the DiagramItem class using the specified diagram item as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem (
DiagramItem prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As DiagramItem _
)

Parameters

prototype
The item to use as a prototype. The properties of the new item are initialized from the property values of this item.

Remarks

This constructor copies the DiagramItem property values from the specified prototype item.

See Also

DiagramItem Constructor Overload List
DiagramItem Class


MindFusion.Diagramming.DiagramItem Methods

DiagramItem Methods
[image]

Public Methods

Name | Description
Clone | Creates a copy of this item.
ContainsPoint | Determines whether this item contains the specified point.
GetBounds | Gets the bounding rectangle of this item.
GetOutlinePoly | Gets a polygon approximating the outline of this object.
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow.
GetRotatedBounds | Gets the bounding rectangle of this item when it is rotated.
HitTestHandle | Determines whether a selection handle of this item is located at the specified point.
NotInteractive | Gets whether the user is prevented from manipulating this item.
OnApplyTemplate | Control.OnApplyTemplate override.
RestoreLocationState | Restores the state of this diagram item.
SaveLocationState | Saves the state of this diagram item.
TransformDiagramToItem | Transforms a point in diagram coordinates to item coordinates.
TransformItemToDiagram | Gets the diagram coordinates of a point specified in the local coordinate system of this item.
ZBottom | Moves the item to the bottom of the z-order.
ZLevelDown | Moves the item one level down in the z-order.
ZLevelUp | Moves the item one level up in the z-order.
ZTop | Moves the item to the top of the z-order.

Protected Methods

Name | Description
AddHandlesToCanvas | Overloaded.
AllowDrag | Invoked to validate the drag operation.
CancelDrag | Invoked when the interactive modification of this object has been canceled.
CreateState | Creates an item state corresponding to the type of this diagram item.
EndDrag | Invoked when the user stops dragging this item.
LoadFromXml | Loads the item content from an XML element.
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo.
OnChildModified | Called when a group child node has been modified.
OnLoad | Called after successful deserialization.
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes.
OnMouseEnter | Control.OnMouseEnter override.
OnMouseLeave | Control.OnMouseLeave override.
OnMouseLeftButtonDown | Control.OnMouseLeftButtonDown override.
OnMouseLeftButtonUp | Control.OnMouseLeftButtonUp override.
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo.
RemoveHandlesFromCanvas | Invoked when the item's selection handles should be removed.
RestoreState | Restores the state of this diagram item.
SaveState | Saves the state of this diagram item.
SaveToXml | Saves the item content into an XML element.
StartDrag | Invoked when the user starts dragging this item.
UpdateDrag | Invoked while the user drags this item.
UpdateHandleColors | Sets the handle colors according to the current selection state of the item and the enabled bits in the EnabledHandles property.
UpdateHandlePositions | Invoked when the item's selection handles should change their position.
UpdateStates | Sets the current VisualStates of this item.
UpdateVisuals | Invoked when an item should update its visual elements.

See Also

DiagramItem Class


MindFusion.Diagramming.DiagramItem.AddHandlesToCanvas Method

DiagramItem.AddHandlesToCanvas Method
[image]

Overload List

Name | Description
DiagramItem.AddHandlesToCanvas () | Invoked when the item's selection handles should be added to the diagram's Canvas object.
DiagramItem.AddHandlesToCanvas (IList(Point)) | Invoked when the item's selection handles should be added to the diagram's Canvas object.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.AddHandlesToCanvas Method ()

DiagramItem.AddHandlesToCanvas Method ()
See Also
[image]

Invoked when the item's selection handles should be added to the diagram's Canvas object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected abstract void AddHandlesToCanvas ()

Visual Basic [image] Copy Code

Protected MustOverride Sub AddHandlesToCanvas ()

See Also

AddHandlesToCanvas Method Overload List
DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.AddHandlesToCanvas Method (IList(Point))

DiagramItem.AddHandlesToCanvas Method (IList(Point))
See Also
[image]

Invoked when the item's selection handles should be added to the diagram's Canvas object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void AddHandlesToCanvas (
IList<Point> positions
)

Visual Basic [image] Copy Code

Protected Overridable Sub AddHandlesToCanvas( _
positions As IList(Of Point) _
)

Parameters

positions

See Also

AddHandlesToCanvas Method Overload List
DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.AllowDrag Method

DiagramItem.AllowDrag Method
[image]

Invoked to validate the drag operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual bool AllowDrag (
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overridable Function AllowDrag( _
ist As InteractionState _
) As Boolean

Parameters

ist

Return Value

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.CancelDrag Method

DiagramItem.CancelDrag Method
[image]

Invoked when the interactive modification of this object has been canceled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void CancelDrag (
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overridable Sub CancelDrag( _
ist As InteractionState _
)

Parameters

ist

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Clone Method

DiagramItem.Clone Method
[image]

Creates a copy of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual DiagramItem Clone (
bool clipboard
)

Visual Basic [image] Copy Code

Public Overridable Function Clone( _
clipboard As Boolean _
) As DiagramItem

Parameters

clipboard

true if the copy will be stored in the Windows clipboard; otherwise, false.

Return Value

The copy of this item.

Remarks

The default implementation of this item invokes the item's class copy constructor through reflection. If your custom type does not provide a copy constructor, you must implement this method to provide for clipboard operations support.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ContainsPoint Method

DiagramItem.ContainsPoint Method
[image]

Determines whether this item contains the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool ContainsPoint (
Point point
)

Visual Basic [image] Copy Code

Public Overridable Function ContainsPoint( _
point As Point _
) As Boolean

Parameters

point

The point to check.

Return Value

true it this item contains the specified point; otherwise, false.

Remarks

This method is used during hit-testing to see if the mouse is inside the item.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.CreateState Method

DiagramItem.CreateState Method
[image]

Creates an item state corresponding to the type of this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramItemState CreateState ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateState () As DiagramItemState

Return Value

An instance of DiagramItemState or a derived class.

Remarks

This method is used by the undo/redo system to create a DiagramItemState -derived object that corresponds to the item class. Custom item classes must override CreateState in order to implement undo/redo support for any additional members they define. This method should be overridden together with SaveState and RestoreState.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.EndDrag Method

DiagramItem.EndDrag Method
[image]

Invoked when the user stops dragging this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected abstract void EndDrag (
InteractionState ist
)

Visual Basic [image] Copy Code

Protected MustOverride Sub EndDrag ( _
ist As InteractionState _
)

Parameters

ist

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.GetBounds Method

DiagramItem.GetBounds Method
[image]

Gets the bounding rectangle of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract Rect GetBounds ()

Visual Basic [image] Copy Code

Public MustOverride Function GetBounds () As Rect

Return Value

The rectangle that bounds this item.

Remarks

The Bounds property getter returns the result of this method.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.GetOutlinePoly Method

DiagramItem.GetOutlinePoly Method
[image]

Gets a polygon approximating the outline of this object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual List<Point> GetOutlinePoly ()

Visual Basic [image] Copy Code

Public Overridable Function GetOutlinePoly () As List(Of Point)

Return Value

A list of points that define the item's outline.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.GetRepaintRect Method

DiagramItem.GetRepaintRect Method
[image]

Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Rect GetRepaintRect (
bool includeConnected
)

Visual Basic [image] Copy Code

Public Overridable Function GetRepaintRect( _
includeConnected As Boolean _
) As Rect

Parameters

includeConnected
true is related items should be considered too; otherwise, false.

Return Value

A rectangular region that should be repainted when this item is modified.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.GetRotatedBounds Method

DiagramItem.GetRotatedBounds Method
[image]

Gets the bounding rectangle of this item when it is rotated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract Rect GetRotatedBounds ()

Visual Basic [image] Copy Code

Public MustOverride Function GetRotatedBounds () As Rect

Return Value

A rectangle that bounds the rotated shape of the item.

Remarks

This method is invoked during hit-testing to do a quick test whether a point is within the item's bounds, before calling the possibly more time-consuming ContainsPoint method.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.HitTestHandle Method

DiagramItem.HitTestHandle Method
[image]

Determines whether a selection handle of this item is located at the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract bool HitTestHandle (
Point point,
ref int handle
)

Visual Basic [image] Copy Code

Public MustOverride Function HitTestHandle( _
point As Point, _
ByRef handle As Integer _
) As Boolean

Parameters

point

A Point value specifying where to look for a selection handle.

handle

A reference to an integer variable, which receives the index of the found selection handle.

Return Value

true if there is a selection handle at the specified location; otherwise, false.

Remarks

You might use this method when implementing custom hit-testing by handling the HitTestAdjustmentHandles event for nodes whose HandlesStyle is set to Custom.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.LoadFromXml Method

DiagramItem.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFromXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFromXml ( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement containing the item's data.

context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

This method is invoked when an item is being deserialized from a diagram file saved in XML format.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.NotInteractive Method

DiagramItem.NotInteractive Method
[image]

Gets whether the user is prevented from manipulating this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool NotInteractive ()

Visual Basic [image] Copy Code

Public Overridable Function NotInteractive () As Boolean

Return Value

true to prevent user interaction with this item; otherwise, false.

Remarks

The default implementation prevents manipulation of invisible or locked items.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.OnAdd Method

DiagramItem.OnAdd Method
[image]

Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnAdd ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnAdd ()

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.OnApplyTemplate Method

DiagramItem.OnApplyTemplate Method
[image]

Control.OnApplyTemplate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Overrides Sub OnApplyTemplate ()

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.OnChildModified Method

DiagramItem.OnChildModified Method
[image]

Called when a group child node has been modified.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnChildModified (
DiagramNode node,
AdjustmentHandles handle
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnChildModified( _
node As DiagramNode, _
handle As AdjustmentHandles _
)

Parameters

node

The node that has been modified.

handle

The adjustment handle used to modify the node.

Remarks

Override this method if you need to know when a node from the SubordinateGroup is modified.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.OnLoad Method

DiagramItem.OnLoad Method
[image]

Called after successful deserialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLoad ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnLoad ()

Remarks

Override this method if you need to update the state of items after successfully loading a diagram.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.OnMeasureUnitChanged Method

DiagramItem.OnMeasureUnitChanged Method
[image]

Called when the diagram's MeasureUnit changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnMeasureUnitChanged ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnMeasureUnitChanged ()

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.OnMouseEnter Method

DiagramItem.OnMouseEnter Method
[image]

Control.OnMouseEnter override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnMouseEnter (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseEnter( _
e As MouseEventArgs _
)

Parameters

e

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.OnMouseLeave Method

DiagramItem.OnMouseLeave Method
[image]

Control.OnMouseLeave override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnMouseLeave (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseLeave( _
e As MouseEventArgs _
)

Parameters

e

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.OnMouseLeftButtonDown Method

DiagramItem.OnMouseLeftButtonDown Method
[image]

Control.OnMouseLeftButtonDown override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnMouseLeftButtonDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseLeftButtonDown( _
e As MouseButtonEventArgs _
)

Parameters

e

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.OnMouseLeftButtonUp Method

DiagramItem.OnMouseLeftButtonUp Method
[image]

Control.OnMouseLeftButtonUp override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnMouseLeftButtonUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseLeftButtonUp( _
e As MouseButtonEventArgs _
)

Parameters

e

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.OnRemove Method

DiagramItem.OnRemove Method
[image]

Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnRemove ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnRemove ()

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.RemoveHandlesFromCanvas Method

DiagramItem.RemoveHandlesFromCanvas Method
[image]

Invoked when the item's selection handles should be removed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void RemoveHandlesFromCanvas ()

Visual Basic [image] Copy Code

Protected Overridable Sub RemoveHandlesFromCanvas ()

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.RestoreLocationState Method

DiagramItem.RestoreLocationState Method
[image]

Restores the state of this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void RestoreLocationState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Public Overridable Sub RestoreLocationState ( _
state As DiagramItemState _
)

Parameters

state
A DiagramItemState that represents previous state of the item.

Remarks

This method is used to move an item to its original location if the current modification done by the user is cancelled.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
LinkModifying Event
NodeModifying Event


MindFusion.Diagramming.DiagramItem.RestoreState Method

DiagramItem.RestoreState Method
[image]

Restores the state of this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void RestoreState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Overridable Sub RestoreState ( _
state As DiagramItemState _
)

Parameters

state
A DiagramItemState that represents previous state of the item.

Remarks

This method is used by the undo/redo system to restore an item to a previous state. Custom item classes must override RestoreState in order to implement undo/redo support for any additional members they define. This method should be overridden together with CreateState and SaveState.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.SaveLocationState Method

DiagramItem.SaveLocationState Method
[image]

Saves the state of this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual DiagramItemState SaveLocationState ()

Visual Basic [image] Copy Code

Public Overridable Function SaveLocationState () As DiagramItemState

Return Value

A DiagramItemState that represents the current state of the item.

Remarks

This method is used to save the location of an item when the user starts modifying it. If the operation is cancelled, the item is restore to the saved state.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.SaveState Method

DiagramItem.SaveState Method
[image]

Saves the state of this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual DiagramItemState SaveState ()

Visual Basic [image] Copy Code

Public Overridable Function SaveState () As DiagramItemState

Return Value

A DiagramItemState that represents the current state of the item.

Remarks

This method is used by the undo/redo system to save the state of an item. Custom item classes must override SaveState in order to implement undo/redo support for any additional members they define. This method should be overridden together with CreateState and RestoreState.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.SaveToXml Method

DiagramItem.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveToXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveToXml( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement the item's data should be stored into.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

This method is invoked when an item is being serialized into an XML-format diagram file.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.StartDrag Method

DiagramItem.StartDrag Method
[image]

Invoked when the user starts dragging this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void StartDrag (
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overridable Sub StartDrag ( _
ist As InteractionState _
)

Parameters

ist

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.TransformDiagramToItem Method

DiagramItem.TransformDiagramToItem Method
[image]

Transforms a point in diagram coordinates to item coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point TransformDiagramToItem (
Point diagramPoint
)

Visual Basic [image] Copy Code

Public Function TransformDiagramToItem( _
diagramPoint As Point _
) As Point

Parameters

diagramPoint
A Point in diagram coordinates.

Return Value

A Point in local item coordinates.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.TransformItemToDiagram Method

DiagramItem.TransformItemToDiagram Method
[image]

Gets the diagram coordinates of a point specified in the local coordinate system of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point TransformItemToDiagram (
Point itemPoint
)

Visual Basic [image] Copy Code

Public Function TransformItemToDiagram( _
itemPoint As Point _
) As Point

Parameters

itemPoint

A Point in the item's coordinate system.

Return Value

A Point in the diagram coordinate system.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.UpdateDrag Method

DiagramItem.UpdateDrag Method
[image]

Invoked while the user drags this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected abstract void UpdateDrag (
InteractionState ist
)

Visual Basic [image] Copy Code

Protected MustOverride Sub UpdateDrag ( _
ist As InteractionState _
)

Parameters

ist

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.UpdateHandleColors Method

DiagramItem.UpdateHandleColors Method
[image]

Sets the handle colors according to the current selection state of the item and the enabled bits in the EnabledHandles property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void UpdateHandleColors ()

Visual Basic [image] Copy Code

Protected Overridable Sub UpdateHandleColors ()

Remarks

Override this method to set the handles appearance if the attributes exposed through the HandlesVisualStyle properties are not sufficient for your requirements.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.UpdateHandlePositions Method

DiagramItem.UpdateHandlePositions Method
[image]

Invoked when the item's selection handles should change their position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void UpdateHandlePositions (
IList<Point> positions
)

Visual Basic [image] Copy Code

Protected Overridable Sub UpdateHandlePositions( _
positions As IList(Of Point) _
)

Parameters

positions

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.UpdateStates Method

DiagramItem.UpdateStates Method
[image]

Sets the current VisualStates of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void UpdateStates (
bool useTransitions
)

Visual Basic [image] Copy Code

Protected Overridable Sub UpdateStates( _
useTransitions As Boolean _
)

Parameters

useTransitions
true to use visual transition between states; otherwise, false.

Remarks

Currently DiagramItem supports two visual state groups. The group SelectionStates contains the Unselected and Selected states. The MouseStates group contains the MouseOut, MouseOver and MouseDown states. If you define additional visual states for a derived item, override this method to implement state transitions for them.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.UpdateVisuals Method

DiagramItem.UpdateVisuals Method
[image]

Invoked when an item should update its visual elements.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void UpdateVisuals (
bool updateEffects
)

Visual Basic [image] Copy Code

Protected Overridable Sub UpdateVisuals( _
updateEffects As Boolean _
)

Parameters

updateEffects

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ZBottom Method

DiagramItem.ZBottom Method
[image]

Moves the item to the bottom of the z-order.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ZBottom (
bool keepInLayer
)

Visual Basic [image] Copy Code

Public Sub ZBottom( _
keepInLayer As Boolean _
)

Parameters

keepInLayer
true keeps the item in its original layer; false allows moving the item across layers.

Remarks

Call this method to move the item to the bottom of the z-order.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ZLevelDown Method

DiagramItem.ZLevelDown Method
[image]

Moves the item one level down in the z-order.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ZLevelDown (
bool keepInLayer
)

Visual Basic [image] Copy Code

Public Sub ZLevelDown( _
keepInLayer As Boolean _
)

Parameters

keepInLayer

true keeps the item in its original layer; false allows moving the item across layers.

Remarks

Call this method to change the item's position in z-order with one level down.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ZLevelUp Method

DiagramItem.ZLevelUp Method
[image]

Moves the item one level up in the z-order.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ZLevelUp (
bool keepInLayer
)

Visual Basic [image] Copy Code

Public Sub ZLevelUp( _
keepInLayer As Boolean _
)

Parameters

keepInLayer

true keeps the item in its original layer; false allows moving the item across layers.

Remarks

Call this method to change the item's position in z-order with one level up.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ZTop Method

DiagramItem.ZTop Method
[image]

Moves the item to the top of the z-order.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ZTop (
bool keepInLayer
)

Visual Basic [image] Copy Code

Public Sub ZTop( _
keepInLayer As Boolean _
)

Parameters

keepInLayer

true keeps the item in its original layer; false allows moving the item across layers.

Remarks

Call this method to move the item to the top of the z-order.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem Properties

DiagramItem Properties
[image]

Public Properties

Name | Description
AutoCaptureMouse | Gets or sets whether the item should capture the mouse input when the left button is pressed over it. This is a dependency property.
Brush | Gets or sets the Brush that specifies how to paint the interior of the item. This is a dependency property.
Diagram | Gets the parent diagram.
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like.
HyperLink | Gets or sets the hyperlink associated with this diagram item. This is a dependency property.
Id | Gets or sets user-defined identifier associated with this item.
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods.
IsMouseDown | Gets a value indicating whether the mouse button is pressed over this item. This is a dependency property.
IsMouseOver | Gets a value indicating whether the mouse pointer is located over this item. This is a dependency property.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer.
LayoutTraits | Contains properties specific to each layout algorithm.
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item.
RuntimeIndex | For internal use.
Selected | Gets or sets a value indicating whether a diagram item is selected.
Stroke | Gets or sets the Brush that specifies how the item outline is painted.
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline nodes. This is a dependency property.
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn.
StrokeDashOffset | Gets or sets a double value that specifies the distance within the dash pattern where a dash begins. This is a dependency property.
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke.
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline.
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. This is a dependency property.
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke.
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline.
TextBrush | Gets or sets the brush used to draw the item's text.
ToolTip | Gets or sets the contents of the tooltip displayed when the mouse pointer rests over the diagram element.
Visible | Gets or sets a value indicating whether this item is visible.
Weight | Gets or sets a weight value used in layout and path-finding algorithms.
ZIndex | Gets or sets the z-order position of the object.

Protected Properties

Name | Description
Size | Gets the size of this item.

See Also

DiagramItem Class


MindFusion.Diagramming.DiagramItem.AutoCaptureMouse Property

DiagramItem.AutoCaptureMouse Property
[image]

Gets or sets whether the item should capture the mouse input when the left button is pressed over it. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoCaptureMouse { get; set; }

Visual Basic [image] Copy Code

Public Property AutoCaptureMouse As Boolean

Property Value

true to capture mouse input; otherwise, false. The default value is true.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Brush Property

DiagramItem.Brush Property
[image]

Gets or sets the Brush that specifies how to paint the interior of the item. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

An instance of the Windows.UI.Xaml.Media.Brush class.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Diagram Property

DiagramItem.Diagram Property
[image]

Gets the parent diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Diagram Diagram { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Diagram As Diagram

Property Value

A reference to the Diagram instance containing this item.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.HandlesStyle Property

DiagramItem.HandlesStyle Property
[image]

Gets or sets a value indicating how the node adjustment handles behave and what do they look like.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HandlesStyle HandlesStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HandlesStyle As HandlesStyle

Property Value

A member of the HandlesStyle enumeration. The default value is SquareHandles.

Remarks

Specifies how node selection status is indicated visually. In addition, this property defines how manipulation of the node can be done, that is, how to move it, resize it or link it to other nodes. You can assign any of the HandlesStyle values to this property.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
HitTestHandle Method


MindFusion.Diagramming.DiagramItem.HyperLink Property

DiagramItem.HyperLink Property
[image]

Gets or sets the hyperlink associated with this diagram item. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string HyperLink { get; set; }

Visual Basic [image] Copy Code

Public Property HyperLink As String

Property Value

A string value containing the hyperlink URL.

Remarks

The control does not automatically navigate to the specified URL when an item is clicked. If this is required, you could use the classes from the Windows.UI.Xaml.Browser namespace to navigate to the specified resource in response to events such as LinkClicked and NodeClicked.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Id Property

DiagramItem.Id Property
[image]

Gets or sets user-defined identifier associated with this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Id { get; set; }

Visual Basic [image] Copy Code

Public Property Id As Object

Property Value

An instance of any class derived from System.Object.

Remarks

This property contains data that you define and is not used by the control in any way. You can associate with the item any value of a primitive data type, an object from the WinRT class library or a custom class. If the id is a primitive value, it is serialized together with the item containing it when saving / loading the diagram. To serialize identifiers from complex types, handle the SerializeTag and DeserializeTag events.

Call FindNodeById or FindLinkById to find diagram items with the specified id. These methods compare identifiers by value using the Equals method.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.IgnoreLayout Property

DiagramItem.IgnoreLayout Property
[image]

Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IgnoreLayout { get; set; }

Visual Basic [image] Copy Code

Public Property IgnoreLayout As Boolean

Property Value

true if the item must stay at its place nevertheless an automatic layout is performed; otherwise, false. The default is false.

Remarks

Enable IgnoreLayout to specify that Arrange method of layout classes should ignore an item. If enabled, the position of an item won't be changed. This property applies to visible nodes. Invisible nodes are always ignored by automatic layout methods.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.IsMouseDown Property

DiagramItem.IsMouseDown Property
[image]

Gets a value indicating whether the mouse button is pressed over this item. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsMouseDown { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsMouseDown As Boolean

Property Value

true if the mouse is pressed over this item; otherwise, false.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.IsMouseOver Property

DiagramItem.IsMouseOver Property
[image]

Gets a value indicating whether the mouse pointer is located over this item. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsMouseOver { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsMouseOver As Boolean

Property Value

true if the mouse pointer is over this item; otherwise, false.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.LayerIndex Property

DiagramItem.LayerIndex Property
[image]

Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int LayerIndex { get; set; }

Visual Basic [image] Copy Code

Public Property LayerIndex As Integer

Property Value

An integer value that specifies the index of the layer.

Remarks

This property specifies the index of a Layer instance within the Layers collection of the Diagram.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.LayoutTraits Property

DiagramItem.LayoutTraits Property
[image]

Contains properties specific to each layout algorithm.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IDictionary<Object, Object> LayoutTraits { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LayoutTraits As IDictionary(Of Object, Object)

Property Value

A hashtable of key-value pairs that define layout-specific properties for this item.

Remarks

This property is used by some automatic layout classes to get attributes pertinent just for a specific layout:

  • SpringLayout looks for values associated with SpringLayoutTraits members.
  • LayeredLayout looks for values associated with LayeredLayoutTraits members.
  • TreeLayout looks for values associated with TreeLayoutTraits members.
  • HierarchicalLayout looks for values associated with HierarchicalLayoutTraits members.
  • SwimlaneLayout looks for values associated with SwimlaneLayoutTraits members.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Locked Property

DiagramItem.Locked Property
[image]

Gets or sets a value indicating whether users are allowed to edit the diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Locked { get; set; }

Visual Basic [image] Copy Code

Public Property Locked As Boolean

Property Value

true to prevent users from editing a diagram element; otherwise, false. The default is false.

Remarks

A locked item cannot be selected, moved or resized interactively. Additionaly, its text cannot be edited in-place.

Locked nodes still can be moved or resized programmatically through the Bounds property. Positions of locked links' control points can be changed programmatically too - through their ControlPoints collections.

Locked items positions can be changed also by the automatic layout algorithms. To prevent automatic layout methods from changing positions of individual items, set the IgnoreLayout property of DiagramItem to false.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
Visible Property


MindFusion.Diagramming.DiagramItem.RuntimeIndex Property

DiagramItem.RuntimeIndex Property
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int RuntimeIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RuntimeIndex As Integer

Property Value

A sequental integer id for this item.

Remarks

Valid only after calling UpdateRuntimeIndices.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Selected Property

DiagramItem.Selected Property
[image]

Gets or sets a value indicating whether a diagram item is selected.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Selected { get; set; }

Visual Basic [image] Copy Code

Public Property Selected As Boolean

Property Value

Remarks

Use the property to check which items are selected by the user, or to programmatically select items if needed.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Size Property

DiagramItem.Size Property
[image]

Gets the size of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Size Size { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property Size As Size

Property Value

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Stroke Property

DiagramItem.Stroke Property
[image]

Gets or sets the Brush that specifies how the item outline is painted.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush Stroke { get; set; }

Visual Basic [image] Copy Code

Public Property Stroke As Brush

Property Value

A Windows.UI.Xaml.Media.Brush that specifies how the item outline is painted. The default is a black brush.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
StrokeThickness Property


MindFusion.Diagramming.DiagramItem.StrokeDashArray Property

DiagramItem.StrokeDashArray Property
[image]

Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline nodes. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DoubleCollection StrokeDashArray { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeDashArray As DoubleCollection

Property Value

A Windows.UI.Xaml.Media.DoubleCollection that specifies the pattern of dashes and gaps. The default is an empty collection.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
StrokeDashOffset Property
StrokeDashCap Property


MindFusion.Diagramming.DiagramItem.StrokeDashCap Property

DiagramItem.StrokeDashCap Property
[image]

Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PenLineCap StrokeDashCap { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeDashCap As PenLineCap

Property Value

One of the Windows.UI.Xaml.Media.PenLineCap values. The default is Flat.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.StrokeDashOffset Property

DiagramItem.StrokeDashOffset Property
[image]

Gets or sets a double value that specifies the distance within the dash pattern where a dash begins. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double StrokeDashOffset { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeDashOffset As Double

Property Value

A double value that represents the distance within the dash pattern where a dash begins. The default value is 0.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.StrokeEndLineCap Property

DiagramItem.StrokeEndLineCap Property
[image]

Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PenLineCap StrokeEndLineCap { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeEndLineCap As PenLineCap

Property Value

One of the Windows.UI.Xaml.Media.PenLineCap values. The default is Flat.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.StrokeLineJoin Property

DiagramItem.StrokeLineJoin Property
[image]

Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PenLineJoin StrokeLineJoin { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeLineJoin As PenLineJoin

Property Value

One of the Windows.UI.Xaml.Media.PenLineJoin values. The default is Miter.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.StrokeMiterLimit Property

DiagramItem.StrokeMiterLimit Property
[image]

Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double StrokeMiterLimit { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeMiterLimit As Double

Property Value

The limit on the ratio of the miter length to the StrokeThickness of an item. This value must be a positive number greater than or equal to 1.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.StrokeStartLineCap Property

DiagramItem.StrokeStartLineCap Property
[image]

Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PenLineCap StrokeStartLineCap { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeStartLineCap As PenLineCap

Property Value

One of the Windows.UI.Xaml.Media.PenLineCap values. The default is Flat.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.StrokeThickness Property

DiagramItem.StrokeThickness Property
[image]

Gets or sets the width of the DiagramItem stroke outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double StrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThickness As Double

Property Value

The width of the item outline. The default value is 0.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
Stroke Property


MindFusion.Diagramming.DiagramItem.TextBrush Property

DiagramItem.TextBrush Property
[image]

Gets or sets the brush used to draw the item's text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush TextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TextBrush As Brush

Property Value

An instance of the Windows.UI.Xaml.Media.Brush class. The default is Brushes.Black.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ToolTip Property

DiagramItem.ToolTip Property
[image]

Gets or sets the contents of the tooltip displayed when the mouse pointer rests over the diagram element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object ToolTip { get; set; }

Visual Basic [image] Copy Code

Public Property ToolTip As Object

Property Value

An instance of the System.Object class.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Visible Property

DiagramItem.Visible Property
[image]

Gets or sets a value indicating whether this item is visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Visible As Boolean

Property Value

Remarks

Invisible items are not drawn at all.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Weight Property

DiagramItem.Weight Property
[image]

Gets or sets a weight value used in layout and path-finding algorithms.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Weight { get; set; }

Visual Basic [image] Copy Code

Public Property Weight As Double

Property Value

A double value specifying item's relative weight. The default value is 1.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ZIndex Property

DiagramItem.ZIndex Property
[image]

Gets or sets the z-order position of the object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ZIndex { get; set; }

Visual Basic [image] Copy Code

Public Property ZIndex As Integer

Property Value

An integer value specifying the position of the diagram item within the z-order.

Remarks

Use the property to arrange item in z-order. Items with lower ZIndex appear behind items with higher ZIndex.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItemCollection Class

DiagramItemCollection Class
[image]

Represents a strongly typed collection of DiagramItem objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramItemCollection : ItemCollectionBase<DiagramItem>

Visual Basic [image] Copy Code

Public Class DiagramItemCollection
Inherits ItemCollectionBase(Of DiagramItem)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.CollectionBase(DiagramItem, DiagramItem)
MindFusion.Diagramming.ItemCollectionBase(DiagramItem)
MindFusion.Diagramming.DiagramItemCollection

See Also

DiagramItemCollection Members


MindFusion.Diagramming.DiagramItemCollection Members

DiagramItemCollection Members
Constructors Fields Properties Methods
[image]

Represents a strongly typed collection of DiagramItem objects.

The following tables list the members exposed by the DiagramItemCollection type.

Public Constructors

Name | Description
DiagramItemCollection | Overloaded.

Inherited Protected Fields

Name | Description
itemEventArgs | An ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector. (Inherited from CollectionBase.)
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items. (Inherited from CollectionBase.)

Inherited Public Properties

Name | Description
Count | Gets the number of items contained in the collection. (Inherited from CollectionBase.)
IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from CollectionBase.)
Item | An indexer that lets you access the element at the specified position. (Inherited from CollectionBase.)

Inherited Public Methods

Name | Description
Add | Adds an item to the collection. (Inherited from CollectionBase.)
Clear | Removes all items from the collection. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the List(T). (Inherited from CollectionBase.)
CopyTo | (Inherited from CollectionBase.)
GetEnumerator | Returns an enumerator for this collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts an element into the Collection at the specified index. (Inherited from CollectionBase.)
Remove | Removes the first occurrence of a specific object from the collection. (Inherited from CollectionBase.)
RemoveAt | Removes the element at the specified index of the collection. (Inherited from CollectionBase.)

Inherited Protected Methods

Name | Description
RaiseAdding | Raises the Adding event. (Inherited from CollectionBase.)
RaiseInserting | Raises the Inserting event. (Inherited from CollectionBase.)
RaiseRemoving | Raises the Removing event. (Inherited from CollectionBase.)

See Also

DiagramItemCollection Class


MindFusion.Diagramming.DiagramItemCollection Constructor

DiagramItemCollection Constructor
[image]

Overload List

Name | Description
DiagramItemCollection () | Initializes a new instance of the DiagramItemCollection class.
DiagramItemCollection (DiagramItemCollection) | Initializes a new instance of the DiagramItemCollection class.

See Also

DiagramItemCollection Class


MindFusion.Diagramming.DiagramItemCollection Constructor ()

DiagramItemCollection Constructor ()
See Also
[image]

Initializes a new instance of the DiagramItemCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramItemCollection Constructor Overload List
DiagramItemCollection Class


MindFusion.Diagramming.DiagramItemCollection Constructor (DiagramItemCollection)

DiagramItemCollection Constructor (DiagramItemCollection)
See Also
[image]

Initializes a new instance of the DiagramItemCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemCollection (
DiagramItemCollection prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As DiagramItemCollection _
)

Parameters

prototype

See Also

DiagramItemCollection Constructor Overload List
DiagramItemCollection Class


MindFusion.Diagramming.DiagramItemState Class

DiagramItemState Class
[image]

Saves the state of this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramItemState

Visual Basic [image] Copy Code

Public Class DiagramItemState

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemState
MindFusion.Diagramming.DiagramLinkState
MindFusion.Diagramming.DiagramNodeState

See Also

DiagramItemState Members


MindFusion.Diagramming.DiagramItemState Members

DiagramItemState Members
Constructors
[image]

Saves the state of this diagram item.

The following tables list the members exposed by the DiagramItemState type.

Public Constructors

Name | Description
DiagramItemState | Initializes a new instance of the DiagramItemState class.

See Also

DiagramItemState Class


MindFusion.Diagramming.DiagramItemState Constructor

DiagramItemState Constructor
[image]

Initializes a new instance of the DiagramItemState class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemState ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramItemState Class


MindFusion.Diagramming.DiagramLink Class

DiagramLink Class
Remarks See Also
[image]

Represents a link between two diagram nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramLink : DiagramItem, InplaceEditable

Visual Basic [image] Copy Code

Public Class DiagramLink
Inherits DiagramItem
Implements InplaceEditable

Remarks

Links between nodes in DiagramLite are represented by instances of the DiagramLink class. Links connect at most two nodes, which can be accessed via the Origin and Destination properties. If connected to node anchor points, the point indices can be accessed using the OriginAnchor and DestinationAnchor properties. To control whether users are allowed to change link end points, set AllowMoveStart and AllowMoveEnd.

Links are built of smaller parts called segments, which can be straight lines, cascading orthogonal lines or Bezier curves. The type of segments is set through the Shape property. The number of link's segments is specified by the SegmentCount property. Access to control point locations is provided by the ControlPoints collection.

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
Windows.UI.Xaml.Controls.ContentControl
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramLink

See Also

DiagramLink Members


MindFusion.Diagramming.DiagramLink Members

DiagramLink Members
Constructors Fields Properties Methods
[image]

Represents a link between two diagram nodes.

The following tables list the members exposed by the DiagramLink type.

Public Constructors

Name | Description
DiagramLink | Overloaded.

Public Fields

Name | Description
AllowMoveEndProperty | Identifies the AllowMoveEnd dependency property.
AllowMoveStartProperty | Identifies the AllowMoveStart dependency property.
BaseBrushProperty | Identifies the BaseBrush dependency property.
HeadBrushProperty | Identifies the HeadBrush dependency property.
HeadStrokeProperty | Identifies the HeadStroke dependency property.
HeadStrokeThicknessProperty | Identifies the HeadStrokeThickness dependency property.
IntermediateBrushProperty | Identifies the IntermediateBrush dependency property.
TextProperty | Identifies the Text dependency property.

Inherited Public Fields

Name | Description
AutoCaptureMouseProperty | Identifies the AutoCaptureMouse dependency property. (Inherited from DiagramItem.)
BrushProperty | Identifies the Brush dependency property. (Inherited from DiagramItem.)
HyperLinkProperty | Identifies the HyperLink dependency property. (Inherited from DiagramItem.)
IsMouseDownProperty | Identifies the IsMouseDown dependency property. (Inherited from DiagramItem.)
IsMouseOverProperty | Identifies the IsMouseOver dependency property. (Inherited from DiagramItem.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from DiagramItem.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)

Inherited Protected Fields

Name | Description
handles | A list of the Rectangle objects that represent the item's adjustment handles. (Inherited from DiagramItem.)

Public Properties

Name | Description
AllowMoveEnd | Gets or sets a value indicating whether the user is allowed to move the end point of a link. This is a dependency property
AllowMoveStart | Gets or sets a value indicating whether the user is allowed to move the first control point of a link. This is a dependency property.
AutoRoute | Gets or sets a value indicating whether a link should avoid nodes by going the shortest path from its origin to its destination without crossing any other nodes.
BaseBrush | Gets or sets the brush used to paint the link's BaseShape.
BaseShape | Gets or sets what shape to display at the beginning of a link.
BaseShapeSize | Gets or sets the size of the BaseShape shape.
CascadeOrientation | Gets or sets the orientation of the first segment of a cascading link.
ControlPoints | Gets or sets a collection of the control points of this link.
Destination | Gets or sets the destination node of this link.
DestinationAnchor | Gets or sets the index of the destination anchor point within the AnchorPattern that contains it.
DestinationIndex | Gets or sets the index of link's destination anchor point or table row.
DestinationRow | Gets or sets the row to which this link should be connected when the destination node is a table.
Dynamic | Gets or sets a value indicating whether a link automatically adjusts its end points positions in order to keep pointing to the centers of nodes that it connects.
EndPoint | Gets or sets the mouse position where the user ended drawing ot modifying a link.
HeadBrush | Gets or sets the brush used to paint the link's arrowhead shape.
HeadShape | Gets or sets the shape of this link's arrowhead.
HeadShapeSize | Gets or sets the size of the arrowhead shape.
HeadStroke | Gets or sets the Brush that specifies how the arrowhead stroke outline is painted. This is a dependency property.
HeadStrokeThickness | Gets or sets the width of the arrowhead stroke outline. This is a dependency property.
IntermediateBrush | Gets or sets the brush used to paint the link's IntermediateShape.
IntermediateShape | Gets or sets the shape displayed at the middle of each segment of the link.
IntermediateShapeSize | Gets or sets the size of the IntermediateShape shape.
IsConnected | Gets a value indicating whether the link is connected to nodes at both its ends.
Labels | Returns the list of all labels displayed by this link.
Origin | Gets or sets the origin node of the link.
OriginAnchor | Gets or sets the index of the origin anchor point within the AnchorPattern that contains it.
OriginIndex | Gets or sets the index of link's origin anchor point or table row.
OriginRow | Gets or sets the row to which this link should be connected when the origin node is a table.
SegmentCount | Gets or sets the number of segments of this link.
Shape | Gets or sets the type of link segments and how they are positioned one relatively to another.
StartPoint | Gets or sets the mouse position where the user starts drawing or modifying the link.
Text | Gets or sets the text displayed over a link. This is a dependency property.
TextBlock | The control which displays the link text.

Protected Properties

Name | Description
TargetNode | A node that will become the link's Origin or Destination if the current link drawing or modification operation completes at the current mouse pointer location.

Inherited Public Properties

Name | Description
AutoCaptureMouse | Gets or sets whether the item should capture the mouse input when the left button is pressed over it. This is a dependency property. (Inherited from DiagramItem.)
Brush | Gets or sets the Brush that specifies how to paint the interior of the item. This is a dependency property. (Inherited from DiagramItem.)
Diagram | Gets the parent diagram. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramItem.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. This is a dependency property. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IsMouseDown | Gets a value indicating whether the mouse button is pressed over this item. This is a dependency property. (Inherited from DiagramItem.)
IsMouseOver | Gets a value indicating whether the mouse pointer is located over this item. This is a dependency property. (Inherited from DiagramItem.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline nodes. This is a dependency property. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashOffset | Gets or sets a double value that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. This is a dependency property. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
ToolTip | Gets or sets the contents of the tooltip displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of the object. (Inherited from DiagramItem.)

Inherited Protected Properties

Name | Description
Size | Gets the size of this item. (Inherited from DiagramItem.)

Public Methods

Name | Description
AddLabel | Overloaded.
ContainsPoint | Determines whether this link contains the specified point.
GetBounds | Gets the bounding rectangle of this link.
GetNearestSegment | Gets the index of the links segment closest to the specified point.
GetRotatedBounds | DiagramItem.GetRotatedBounds override.
HitTestHandle | DiagramItem.HitTestHandle override.
Intersects | Checks whether the link contour intersects with the outline of the specified node.
LabelFromPoint | Returns the label whose layout rectangle contains the specified point.
ReassignAnchorPoints | Attaches the link end points to the anchor points defined for the link's origin and destination nodes.
RemoveLabel | Removes the specified label from this link.
RestoreLocationState | DiagramItem.RestoreLocationState override.
Route | Routes this link, regardless of whether the link's AutoRoute flag is enabled.
SaveLocationState | DiagramItem.SaveLocationState override.
UpdateFromPoints | Updates the link's internal state after the link's control points have been changed.

Protected Methods

Name | Description
AddHandlesToCanvas | Overloaded.
AllowDrag | Invoked to validate the drag operation.
CreateState | DiagramItem.CreateState override.
EndDrag | DiagramItem.EndDrag override.
LoadFromXml | Loads the link content from an XML element.
OnLoad | DiagramItem.OnLoad override.
RestoreState | DiagramItem.RestoreState override.
SaveState | DiagramItem.SaveState override.
SaveToXml | Saves the link content into an XML element.
StartDrag | DiagramItem.StartDrag override.
UpdateDrag | DiagramItem.UpdateDrag override.
UpdateDynamicLink | Updates the control points of a dynamic link while one of the nodes it connects is being moved or resized.
UpdateTextLayout | Positions the TextBlock control displaying the link's text. Override to implement custom positioning if desired.
UpdateVisuals | DiagramItem.UpdateVisuals override.

Inherited Public Methods

Name | Description
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
ContainsPoint | Determines whether this item contains the specified point. (Inherited from DiagramItem.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetOutlinePoly | Gets a polygon approximating the outline of this object. (Inherited from DiagramItem.)
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow. (Inherited from DiagramItem.)
GetRotatedBounds | Gets the bounding rectangle of this item when it is rotated. (Inherited from DiagramItem.)
HitTestHandle | Determines whether a selection handle of this item is located at the specified point. (Inherited from DiagramItem.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnApplyTemplate | Control.OnApplyTemplate override. (Inherited from DiagramItem.)
RestoreLocationState | Restores the state of this diagram item. (Inherited from DiagramItem.)
SaveLocationState | Saves the state of this diagram item. (Inherited from DiagramItem.)
TransformDiagramToItem | Transforms a point in diagram coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Gets the diagram coordinates of a point specified in the local coordinate system of this item. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Inherited Protected Methods

Name | Description
AddHandlesToCanvas | Overloaded. (Inherited from DiagramItem.)
AllowDrag | Invoked to validate the drag operation. (Inherited from DiagramItem.)
CancelDrag | Invoked when the interactive modification of this object has been canceled. (Inherited from DiagramItem.)
CreateState | Creates an item state corresponding to the type of this diagram item. (Inherited from DiagramItem.)
EndDrag | Invoked when the user stops dragging this item. (Inherited from DiagramItem.)
LoadFromXml | Loads the item content from an XML element. (Inherited from DiagramItem.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnMouseEnter | Control.OnMouseEnter override. (Inherited from DiagramItem.)
OnMouseLeave | Control.OnMouseLeave override. (Inherited from DiagramItem.)
OnMouseLeftButtonDown | Control.OnMouseLeftButtonDown override. (Inherited from DiagramItem.)
OnMouseLeftButtonUp | Control.OnMouseLeftButtonUp override. (Inherited from DiagramItem.)
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
RemoveHandlesFromCanvas | Invoked when the item's selection handles should be removed. (Inherited from DiagramItem.)
RestoreState | Restores the state of this diagram item. (Inherited from DiagramItem.)
SaveState | Saves the state of this diagram item. (Inherited from DiagramItem.)
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramItem.)
StartDrag | Invoked when the user starts dragging this item. (Inherited from DiagramItem.)
UpdateDrag | Invoked while the user drags this item. (Inherited from DiagramItem.)
UpdateHandleColors | Sets the handle colors according to the current selection state of the item and the enabled bits in the EnabledHandles property. (Inherited from DiagramItem.)
UpdateHandlePositions | Invoked when the item's selection handles should change their position. (Inherited from DiagramItem.)
UpdateStates | Sets the current VisualStates of this item. (Inherited from DiagramItem.)
UpdateVisuals | Invoked when an item should update its visual elements. (Inherited from DiagramItem.)

See Also

DiagramLink Class


MindFusion.Diagramming.DiagramLink Fields

DiagramLink Fields
[image]

Public Fields

Name | Description
AllowMoveEndProperty | Identifies the AllowMoveEnd dependency property.
AllowMoveStartProperty | Identifies the AllowMoveStart dependency property.
BaseBrushProperty | Identifies the BaseBrush dependency property.
HeadBrushProperty | Identifies the HeadBrush dependency property.
HeadStrokeProperty | Identifies the HeadStroke dependency property.
HeadStrokeThicknessProperty | Identifies the HeadStrokeThickness dependency property.
IntermediateBrushProperty | Identifies the IntermediateBrush dependency property.
TextProperty | Identifies the Text dependency property.

Inherited Public Fields

Name | Description
AutoCaptureMouseProperty | Identifies the AutoCaptureMouse dependency property. (Inherited from DiagramItem.)
BrushProperty | Identifies the Brush dependency property. (Inherited from DiagramItem.)
HyperLinkProperty | Identifies the HyperLink dependency property. (Inherited from DiagramItem.)
IsMouseDownProperty | Identifies the IsMouseDown dependency property. (Inherited from DiagramItem.)
IsMouseOverProperty | Identifies the IsMouseOver dependency property. (Inherited from DiagramItem.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from DiagramItem.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)

Inherited Protected Fields

Name | Description
handles | A list of the Rectangle objects that represent the item's adjustment handles. (Inherited from DiagramItem.)

See Also

DiagramLink Class


MindFusion.Diagramming.DiagramLink.AllowMoveEndProperty Field

DiagramLink.AllowMoveEndProperty Field
[image]

Identifies the AllowMoveEnd dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static DependencyProperty AllowMoveEndProperty

Visual Basic [image] Copy Code

Public Shared AllowMoveEndProperty As DependencyProperty

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.AllowMoveStartProperty Field

DiagramLink.AllowMoveStartProperty Field
[image]

Identifies the AllowMoveStart dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static DependencyProperty AllowMoveStartProperty

Visual Basic [image] Copy Code

Public Shared AllowMoveStartProperty As DependencyProperty

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.BaseBrushProperty Field

DiagramLink.BaseBrushProperty Field
[image]

Identifies the BaseBrush dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BaseBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BaseBrushProperty As DependencyProperty

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.HeadBrushProperty Field

DiagramLink.HeadBrushProperty Field
[image]

Identifies the HeadBrush dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeadBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeadBrushProperty As DependencyProperty

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.HeadStrokeProperty Field

DiagramLink.HeadStrokeProperty Field
[image]

Identifies the HeadStroke dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeadStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeadStrokeProperty As DependencyProperty

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.HeadStrokeThicknessProperty Field

DiagramLink.HeadStrokeThicknessProperty Field
[image]

Identifies the HeadStrokeThickness dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeadStrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeadStrokeThicknessProperty As DependencyProperty

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.IntermediateBrushProperty Field

DiagramLink.IntermediateBrushProperty Field
[image]

Identifies the IntermediateBrush dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IntermediateBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IntermediateBrushProperty As DependencyProperty

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.TextProperty Field

DiagramLink.TextProperty Field
[image]

Identifies the Text dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextProperty As DependencyProperty

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink Constructor

DiagramLink Constructor
[image]

Overload List

Name | Description
DiagramLink () | Initializes a new instance of the DiagramLink class.
DiagramLink (Diagram) | Initializes a new instance of the DiagramLink class.
DiagramLink (Diagram, DiagramNode, DiagramNode) | Initializes a new instance of the DiagramLink class between the specified nodes using the specified diagram link as a prototype.
DiagramLink (Diagram, DiagramNode, Point) | Initializes a new instance of the DiagramLink class between the specified node and the specified point with default values supplied from the specified Diagram.
DiagramLink (DiagramLink) | Initializes a new instance of the DiagramLink class using the specified diagram link as a prototype.

See Also

DiagramLink Class


MindFusion.Diagramming.DiagramLink Constructor ()

DiagramLink Constructor ()
See Also
[image]

Initializes a new instance of the DiagramLink class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink ()

Visual Basic [image] Copy Code

Public Sub New ()

Remarks

This constructor leaves the link's dependency properties in their default state, without local values. This allows the link to be styled through the WinRT styling mechanism.

See Also

DiagramLink Constructor Overload List
DiagramLink Class


MindFusion.Diagramming.DiagramLink Constructor (Diagram)

DiagramLink Constructor (Diagram)
See Also
[image]

Initializes a new instance of the DiagramLink class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink (
Diagram parent
)

Visual Basic [image] Copy Code

Public Sub DiagramLink ( _
parent As Diagram _
)

Parameters

parent
The Diagram from which to obtain default values for the link properties.

See Also

DiagramLink Constructor Overload List
DiagramLink Class


MindFusion.Diagramming.DiagramLink Constructor (Diagram, DiagramNode, DiagramNode)

DiagramLink Constructor (Diagram, DiagramNode, DiagramNode)
See Also
[image]

Initializes a new instance of the DiagramLink class between the specified nodes using the specified diagram link as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink (
Diagram parent,
DiagramNode origin,
DiagramNode destination
)

Visual Basic [image] Copy Code

Public Function DiagramLink ( _
parent As Diagram, _
origin As DiagramNode, _
destination As DiagramNode _
)

Parameters

parent
The Diagram from which to obtain default values for the link properties.
origin

The origin node of the new link.

destination

The destination node of the new link.

See Also

DiagramLink Constructor Overload List
DiagramLink Class


MindFusion.Diagramming.DiagramLink Constructor (Diagram, DiagramNode, Point)

DiagramLink Constructor (Diagram, DiagramNode, Point)
See Also
[image]

Initializes a new instance of the DiagramLink class between the specified node and the specified point with default values supplied from the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink (
Diagram parent,
DiagramNode origin,
Point point
)

Visual Basic [image] Copy Code

Public Function DiagramLink ( _
parent As Diagram, _
origin As DiagramNode, _
point As Point _
)

Parameters

parent
The Diagram from which to obtain default values for the link properties.
origin

The origin node of the new link.

point

The destination point of the new link.

See Also

DiagramLink Constructor Overload List
DiagramLink Class


MindFusion.Diagramming.DiagramLink Constructor (DiagramLink)

DiagramLink Constructor (DiagramLink)
See Also
[image]

Initializes a new instance of the DiagramLink class using the specified diagram link as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink (
DiagramLink prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As DiagramLink _
)

Parameters

prototype
The link to use as a prototype. The properties of the new link are initialized from the property values of this link.

Remarks

This constructor copies the DiagramLink property values from the specified prototype link.

See Also

DiagramLink Constructor Overload List
DiagramLink Class


MindFusion.Diagramming.DiagramLink Methods

DiagramLink Methods
[image]

Public Methods

Name | Description
AddLabel | Overloaded.
ContainsPoint | Determines whether this link contains the specified point.
GetBounds | Gets the bounding rectangle of this link.
GetNearestSegment | Gets the index of the links segment closest to the specified point.
GetRotatedBounds | DiagramItem.GetRotatedBounds override.
HitTestHandle | DiagramItem.HitTestHandle override.
Intersects | Checks whether the link contour intersects with the outline of the specified node.
LabelFromPoint | Returns the label whose layout rectangle contains the specified point.
ReassignAnchorPoints | Attaches the link end points to the anchor points defined for the link's origin and destination nodes.
RemoveLabel | Removes the specified label from this link.
RestoreLocationState | DiagramItem.RestoreLocationState override.
Route | Routes this link, regardless of whether the link's AutoRoute flag is enabled.
SaveLocationState | DiagramItem.SaveLocationState override.
UpdateFromPoints | Updates the link's internal state after the link's control points have been changed.

Protected Methods

Name | Description
AddHandlesToCanvas | Overloaded.
AllowDrag | Invoked to validate the drag operation.
CreateState | DiagramItem.CreateState override.
EndDrag | DiagramItem.EndDrag override.
LoadFromXml | Loads the link content from an XML element.
OnLoad | DiagramItem.OnLoad override.
RestoreState | DiagramItem.RestoreState override.
SaveState | DiagramItem.SaveState override.
SaveToXml | Saves the link content into an XML element.
StartDrag | DiagramItem.StartDrag override.
UpdateDrag | DiagramItem.UpdateDrag override.
UpdateDynamicLink | Updates the control points of a dynamic link while one of the nodes it connects is being moved or resized.
UpdateTextLayout | Positions the TextBlock control displaying the link's text. Override to implement custom positioning if desired.
UpdateVisuals | DiagramItem.UpdateVisuals override.

Inherited Public Methods

Name | Description
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
ContainsPoint | Determines whether this item contains the specified point. (Inherited from DiagramItem.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetOutlinePoly | Gets a polygon approximating the outline of this object. (Inherited from DiagramItem.)
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow. (Inherited from DiagramItem.)
GetRotatedBounds | Gets the bounding rectangle of this item when it is rotated. (Inherited from DiagramItem.)
HitTestHandle | Determines whether a selection handle of this item is located at the specified point. (Inherited from DiagramItem.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnApplyTemplate | Control.OnApplyTemplate override. (Inherited from DiagramItem.)
RestoreLocationState | Restores the state of this diagram item. (Inherited from DiagramItem.)
SaveLocationState | Saves the state of this diagram item. (Inherited from DiagramItem.)
TransformDiagramToItem | Transforms a point in diagram coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Gets the diagram coordinates of a point specified in the local coordinate system of this item. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Inherited Protected Methods

Name | Description
AddHandlesToCanvas | Overloaded. (Inherited from DiagramItem.)
AllowDrag | Invoked to validate the drag operation. (Inherited from DiagramItem.)
CancelDrag | Invoked when the interactive modification of this object has been canceled. (Inherited from DiagramItem.)
CreateState | Creates an item state corresponding to the type of this diagram item. (Inherited from DiagramItem.)
EndDrag | Invoked when the user stops dragging this item. (Inherited from DiagramItem.)
LoadFromXml | Loads the item content from an XML element. (Inherited from DiagramItem.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnMouseEnter | Control.OnMouseEnter override. (Inherited from DiagramItem.)
OnMouseLeave | Control.OnMouseLeave override. (Inherited from DiagramItem.)
OnMouseLeftButtonDown | Control.OnMouseLeftButtonDown override. (Inherited from DiagramItem.)
OnMouseLeftButtonUp | Control.OnMouseLeftButtonUp override. (Inherited from DiagramItem.)
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
RemoveHandlesFromCanvas | Invoked when the item's selection handles should be removed. (Inherited from DiagramItem.)
RestoreState | Restores the state of this diagram item. (Inherited from DiagramItem.)
SaveState | Saves the state of this diagram item. (Inherited from DiagramItem.)
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramItem.)
StartDrag | Invoked when the user starts dragging this item. (Inherited from DiagramItem.)
UpdateDrag | Invoked while the user drags this item. (Inherited from DiagramItem.)
UpdateHandleColors | Sets the handle colors according to the current selection state of the item and the enabled bits in the EnabledHandles property. (Inherited from DiagramItem.)
UpdateHandlePositions | Invoked when the item's selection handles should change their position. (Inherited from DiagramItem.)
UpdateStates | Sets the current VisualStates of this item. (Inherited from DiagramItem.)
UpdateVisuals | Invoked when an item should update its visual elements. (Inherited from DiagramItem.)

See Also

DiagramLink Class


MindFusion.Diagramming.DiagramLink.AddHandlesToCanvas Method

DiagramLink.AddHandlesToCanvas Method
[image]

Overload List

Name | Description
DiagramLink.AddHandlesToCanvas () | DiagramItem.AddHandlesToCanvas override.
DiagramLink.AddHandlesToCanvas (IList(Point)) | DiagramItem.AddHandlesToCanvas override.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.AddHandlesToCanvas Method ()

DiagramLink.AddHandlesToCanvas Method ()
See Also
[image]

DiagramItem.AddHandlesToCanvas override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void AddHandlesToCanvas ()

Visual Basic [image] Copy Code

Protected Overrides Sub AddHandlesToCanvas ()

See Also

AddHandlesToCanvas Method Overload List
DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.AddHandlesToCanvas Method (IList(Point))

DiagramLink.AddHandlesToCanvas Method (IList(Point))
See Also
[image]

DiagramItem.AddHandlesToCanvas override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void AddHandlesToCanvas (
IList<Point> positions
)

Visual Basic [image] Copy Code

Protected Overrides Sub AddHandlesToCanvas( _
positions As IList(Of Point) _
)

Parameters

positions

See Also

AddHandlesToCanvas Method Overload List
DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.AddLabel Method

DiagramLink.AddLabel Method
[image]

Overload List

Name | Description
DiagramLink.AddLabel (LinkLabel) | Adds the specified label to this link.
DiagramLink.AddLabel (String) | Adds a new label to this link.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.AddLabel Method (LinkLabel)

DiagramLink.AddLabel Method (LinkLabel)
See Also
[image]

Adds the specified label to this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AddLabel (
LinkLabel label
)

Visual Basic [image] Copy Code

Public Sub AddLabel( _
label As LinkLabel _
)

Parameters

label

A LinkLabel instance.

See Also

AddLabel Method Overload List
DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
RemoveLabel Method
Labels Property


MindFusion.Diagramming.DiagramLink.AddLabel Method (String)

DiagramLink.AddLabel Method (String)
See Also
[image]

Adds a new label to this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkLabel AddLabel (
string text
)

Visual Basic [image] Copy Code

Public Function AddLabel( _
text As String _
) As LinkLabel

Parameters

text

The label's text.

Return Value

A LinkLabel instance.

See Also

AddLabel Method Overload List
DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
RemoveLabel Method
Labels Property


MindFusion.Diagramming.DiagramLink.AllowDrag Method

DiagramLink.AllowDrag Method
[image]

Invoked to validate the drag operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override bool AllowDrag (
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Function AllowDrag( _
ist As InteractionState _
) As Boolean

Parameters

ist

Return Value

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.ContainsPoint Method

DiagramLink.ContainsPoint Method
[image]

Determines whether this link contains the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
point As Point _
) As Boolean

Parameters

point

The point to check.

Return Value

true if this link contains the specified point; otherwise, false.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.CreateState Method

DiagramLink.CreateState Method
[image]

DiagramItem.CreateState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramItemState CreateState ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateState () As DiagramItemState

Return Value

A DiagramLinkState instance.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.EndDrag Method

DiagramLink.EndDrag Method
[image]

DiagramItem.EndDrag override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void EndDrag (
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overridable Sub EndDrag ( _
ist As InteractionState _
)

Parameters

ist

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.GetBounds Method

DiagramLink.GetBounds Method
[image]

Gets the bounding rectangle of this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Rect GetBounds ()

Visual Basic [image] Copy Code

Public Overrides Function GetBounds () As Rect

Return Value

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.GetNearestSegment Method

DiagramLink.GetNearestSegment Method
[image]

Gets the index of the links segment closest to the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int GetNearestSegment (
Point point
)

Visual Basic [image] Copy Code

Public Function GetNearestSegment( _
point As Point _
) As Integer

Parameters

point

A point specified in diagram coordinates.

Return Value

Index of the link segment closest to the specified point.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.GetRotatedBounds Method

DiagramLink.GetRotatedBounds Method
[image]

DiagramItem.GetRotatedBounds override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Rect GetRotatedBounds ()

Visual Basic [image] Copy Code

Public Overrides Function GetRotatedBounds () As Rect

Return Value

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.HitTestHandle Method

DiagramLink.HitTestHandle Method
[image]

DiagramItem.HitTestHandle override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool HitTestHandle (
Point point,
ref int handle
)

Visual Basic [image] Copy Code

Public Overrides Function HitTestHandle( _
point As Point, _
ByRef handle As Integer _
) As Boolean

Parameters

point

handle

Return Value

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Intersects Method

DiagramLink.Intersects Method
[image]

Checks whether the link contour intersects with the outline of the specified node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Intersects (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Function Intersects( _
node As DiagramNode _
) As Boolean

Parameters

node

Return Value

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.LabelFromPoint Method

DiagramLink.LabelFromPoint Method
[image]

Returns the label whose layout rectangle contains the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkLabel LabelFromPoint (
Point point
)

Visual Basic [image] Copy Code

Public Function LabelFromPoint( _
point As Point _
) As LinkLabel

Parameters

point

A Point instance.

Return Value

The LinkLabel that contains the specified point.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.LoadFromXml Method

DiagramLink.LoadFromXml Method
[image]

Loads the link content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFromXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFromXml ( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement containing the item's data.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.OnLoad Method

DiagramLink.OnLoad Method
[image]

DiagramItem.OnLoad override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnLoad ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnLoad ()

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.ReassignAnchorPoints Method

DiagramLink.ReassignAnchorPoints Method
[image]

Attaches the link end points to the anchor points defined for the link's origin and destination nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ReassignAnchorPoints ()

Visual Basic [image] Copy Code

Public Sub ReassignAnchorPoints ()

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
Origin Property
OriginAnchor Property
DestinationÂ Property
DestinationAnchor Property


MindFusion.Diagramming.DiagramLink.RemoveLabel Method

DiagramLink.RemoveLabel Method
[image]

Removes the specified label from this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RemoveLabel (
LinkLabel label
)

Visual Basic [image] Copy Code

Public Sub RemoveLabel( _
label As LinkLabel _
)

Parameters

label

A LinkLabel instance.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
AddLabel Method
Labels Property


MindFusion.Diagramming.DiagramLink.RestoreLocationState Method

DiagramLink.RestoreLocationState Method
[image]

DiagramItem.RestoreLocationState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void RestoreLocationState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Public Overrides Sub RestoreLocationState ( _
state As DiagramItemState _
)

Parameters

state
A DiagramLinkState instance.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.RestoreState Method

DiagramLink.RestoreState Method
[image]

DiagramItem.RestoreState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void RestoreState (
DiagramItemState itemState
)

Visual Basic [image] Copy Code

Protected Overridable Sub RestoreState ( _
itemState As DiagramItemState _
)

Parameters

itemState
A DiagramLinkState instance.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Route Method

DiagramLink.Route Method
[image]

Routes this link, regardless of whether the link's AutoRoute flag is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Route ()

Visual Basic [image] Copy Code

Public Function Route () As Boolean

Return Value

true is a route has been successfully found; otherwise, false.

Remarks

Routing may fail if there is a large background node whose Obstacle property is enabled, or if the value of RoutingOptions.GridSize is too big for the average distance between adjacent nodes in the diagram.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.SaveLocationState Method

DiagramLink.SaveLocationState Method
[image]

DiagramItem.SaveLocationState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override DiagramItemState SaveLocationState ()

Visual Basic [image] Copy Code

Public Overrides Function SaveLocationState () As DiagramItemState

Return Value

A DiagramLinkState instance.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.SaveState Method

DiagramLink.SaveState Method
[image]

DiagramItem.SaveState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override DiagramItemState SaveState ()

Visual Basic [image] Copy Code

Public Overrides Function SaveState () As DiagramItemState

Return Value

A DiagramLinkState instance.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.SaveToXml Method

DiagramLink.SaveToXml Method
[image]

Saves the link content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveToXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveToXml ( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement the link's data should be stored into.

context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.StartDrag Method

DiagramLink.StartDrag Method
[image]

DiagramItem.StartDrag override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void StartDrag (
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overridable Sub StartDrag ( _
ist As InteractionState _
)

Parameters

ist
An InteractionState instance containing information about the action that's currently being carried out by the user.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.UpdateDrag Method

DiagramLink.UpdateDrag Method
[image]

DiagramItem.UpdateDrag override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void UpdateDrag (
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overridable Sub UpdateDrag ( _
ist As InteractionState _
)

Parameters

ist

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.UpdateDynamicLink Method

DiagramLink.UpdateDynamicLink Method
[image]

Updates the control points of a dynamic link while one of the nodes it connects is being moved or resized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void UpdateDynamicLink ()

Visual Basic [image] Copy Code

Protected Overridable Sub UpdateDynamicLink ()

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
Dynamic Property


MindFusion.Diagramming.DiagramLink.UpdateFromPoints Method

DiagramLink.UpdateFromPoints Method
[image]

Updates the link's internal state after the link's control points have been changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void UpdateFromPoints ()

Visual Basic [image] Copy Code

Public Sub UpdateFromPoints ()

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.UpdateTextLayout Method

DiagramLink.UpdateTextLayout Method
[image]

Positions the TextBlock control displaying the link's text. Override to implement custom positioning if desired.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void UpdateTextLayout ()

Visual Basic [image] Copy Code

Protected Overridable Sub UpdateTextLayout ()

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.UpdateVisuals Method

DiagramLink.UpdateVisuals Method
[image]

DiagramItem.UpdateVisuals override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void UpdateVisuals (
bool updateEffects
)

Visual Basic [image] Copy Code

Protected Overrides Sub UpdateVisuals( _
updateEffects As Boolean _
)

Parameters

updateEffects

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink Properties

DiagramLink Properties
[image]

Public Properties

Name | Description
AllowMoveEnd | Gets or sets a value indicating whether the user is allowed to move the end point of a link. This is a dependency property
AllowMoveStart | Gets or sets a value indicating whether the user is allowed to move the first control point of a link. This is a dependency property.
AutoRoute | Gets or sets a value indicating whether a link should avoid nodes by going the shortest path from its origin to its destination without crossing any other nodes.
BaseBrush | Gets or sets the brush used to paint the link's BaseShape.
BaseShape | Gets or sets what shape to display at the beginning of a link.
BaseShapeSize | Gets or sets the size of the BaseShape shape.
CascadeOrientation | Gets or sets the orientation of the first segment of a cascading link.
ControlPoints | Gets or sets a collection of the control points of this link.
Destination | Gets or sets the destination node of this link.
DestinationAnchor | Gets or sets the index of the destination anchor point within the AnchorPattern that contains it.
DestinationIndex | Gets or sets the index of link's destination anchor point or table row.
DestinationRow | Gets or sets the row to which this link should be connected when the destination node is a table.
Dynamic | Gets or sets a value indicating whether a link automatically adjusts its end points positions in order to keep pointing to the centers of nodes that it connects.
EndPoint | Gets or sets the mouse position where the user ended drawing ot modifying a link.
HeadBrush | Gets or sets the brush used to paint the link's arrowhead shape.
HeadShape | Gets or sets the shape of this link's arrowhead.
HeadShapeSize | Gets or sets the size of the arrowhead shape.
HeadStroke | Gets or sets the Brush that specifies how the arrowhead stroke outline is painted. This is a dependency property.
HeadStrokeThickness | Gets or sets the width of the arrowhead stroke outline. This is a dependency property.
IntermediateBrush | Gets or sets the brush used to paint the link's IntermediateShape.
IntermediateShape | Gets or sets the shape displayed at the middle of each segment of the link.
IntermediateShapeSize | Gets or sets the size of the IntermediateShape shape.
IsConnected | Gets a value indicating whether the link is connected to nodes at both its ends.
Labels | Returns the list of all labels displayed by this link.
Origin | Gets or sets the origin node of the link.
OriginAnchor | Gets or sets the index of the origin anchor point within the AnchorPattern that contains it.
OriginIndex | Gets or sets the index of link's origin anchor point or table row.
OriginRow | Gets or sets the row to which this link should be connected when the origin node is a table.
SegmentCount | Gets or sets the number of segments of this link.
Shape | Gets or sets the type of link segments and how they are positioned one relatively to another.
StartPoint | Gets or sets the mouse position where the user starts drawing or modifying the link.
Text | Gets or sets the text displayed over a link. This is a dependency property.
TextBlock | The control which displays the link text.

Protected Properties

Name | Description
TargetNode | A node that will become the link's Origin or Destination if the current link drawing or modification operation completes at the current mouse pointer location.

Inherited Public Properties

Name | Description
AutoCaptureMouse | Gets or sets whether the item should capture the mouse input when the left button is pressed over it. This is a dependency property. (Inherited from DiagramItem.)
Brush | Gets or sets the Brush that specifies how to paint the interior of the item. This is a dependency property. (Inherited from DiagramItem.)
Diagram | Gets the parent diagram. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramItem.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. This is a dependency property. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IsMouseDown | Gets a value indicating whether the mouse button is pressed over this item. This is a dependency property. (Inherited from DiagramItem.)
IsMouseOver | Gets a value indicating whether the mouse pointer is located over this item. This is a dependency property. (Inherited from DiagramItem.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline nodes. This is a dependency property. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashOffset | Gets or sets a double value that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. This is a dependency property. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
ToolTip | Gets or sets the contents of the tooltip displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of the object. (Inherited from DiagramItem.)

Inherited Protected Properties

Name | Description
Size | Gets the size of this item. (Inherited from DiagramItem.)

See Also

DiagramLink Class


MindFusion.Diagramming.DiagramLink.AllowMoveEnd Property

DiagramLink.AllowMoveEnd Property
[image]

Gets or sets a value indicating whether the user is allowed to move the end point of a link. This is a dependency property

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowMoveEnd { get; set; }

Visual Basic [image] Copy Code

Public Property AllowMoveEnd As Boolean

Property Value

true to enable users to move the end point of the link; otherwise, false. The default value is true.

Remarks

Set this property to false to prevent the link destination to be changed interactively. Alternatively, handle the LinkModifying event to implement selective validation of attaching a link to different diagram nodes.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
AllowMoveStart Property
Locked Property


MindFusion.Diagramming.DiagramLink.AllowMoveStart Property

DiagramLink.AllowMoveStart Property
[image]

Gets or sets a value indicating whether the user is allowed to move the first control point of a link. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowMoveStart { get; set; }

Visual Basic [image] Copy Code

Public Property AllowMoveStart As Boolean

Property Value

true to enable users to move the start point of the link; otherwise false. The default value is true.

Remarks

Set the property to false to prevent the link origin to be changed interactively. Alternatively, handle the LinkModifying event to implement selective validation of attaching a link to different diagram nodes.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
AllowMoveEnd Property
Locked Property


MindFusion.Diagramming.DiagramLink.AutoRoute Property

DiagramLink.AutoRoute Property
[image]

Gets or sets a value indicating whether a link should avoid nodes by going the shortest path from its origin to its destination without crossing any other nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoRoute { get; set; }

Visual Basic [image] Copy Code

Public Property AutoRoute As Boolean

Property Value

true to route this link; otherwise, false. Initialized with the value of RouteLinks.

Remarks

If AutoRoute is enabled, a link automatically finds the shortest possible path between its origin and destination that doesn't intersect Obstacle nodes. The number and orientation of the link's segments are updated when the nodes it links are moved around. The positions of end points of a routed link are not changed, unless the link is also set to Dynamic.

It is best to use AutoRoute with links of the Cascading style.

Performance note

Links whose AutoRoute property is enabled are re-routed if they intersect with newly created nodes. Thus when constructing a large diagram programmatically, each link might be re-routed many times, once for each newly added node whose location arguments collide with link's bounding rectangle. That might slow down diagram creation a lot. To avoid it, first create all nodes, and afterwards the link; that requires a single calculation for each link's route.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
RoutingOptions Class
LinkRouted Event


MindFusion.Diagramming.DiagramLink.BaseBrush Property

DiagramLink.BaseBrush Property
[image]

Gets or sets the brush used to paint the link's BaseShape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush BaseBrush { get; set; }

Visual Basic [image] Copy Code

Public Property BaseBrush As Brush

Property Value

An instance of a Brush -derived class. The default value is null (Nothing in Visual Basic).

Remarks

If this property is not set, the arrowhead is filled using the link's Brush.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.BaseShape Property

DiagramLink.BaseShape Property
[image]

Gets or sets what shape to display at the beginning of a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape BaseShape { get; set; }

Visual Basic [image] Copy Code

Public Property BaseShape As Shape

Property Value

A Shape instance that represents an arrowhead shape. Initialized with the value of LinkBaseShape.

Remarks

The property specifies the shape that is displayed at the beginning of a link, that is, the point where it is connected with its Origin node. This shape is rotated simultaneously with the first segment of the link so that it follows the overall link direction.

The ArrowHeads class exposes several predefined shapes as static properties.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
HeadShape Property
IntermediateShape Property
BaseBrush Property
BaseShapeSize Property


MindFusion.Diagramming.DiagramLink.BaseShapeSize Property

DiagramLink.BaseShapeSize Property
[image]

Gets or sets the size of the BaseShape shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double BaseShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property BaseShapeSize As Double

Property Value

Remarks

The property specifies how big is the shape that is displayed at the origin of a link.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.CascadeOrientation Property

DiagramLink.CascadeOrientation Property
[image]

Gets or sets the orientation of the first segment of a cascading link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation CascadeOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property CascadeOrientation As Orientation

Property Value

Remarks

Use this property to specify the orientation of the first segment of a link whose Shape is set to Cascading.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.ControlPoints Property

DiagramLink.ControlPoints Property
[image]

Gets or sets a collection of the control points of this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<Point> ControlPoints { get; set; }

Visual Basic [image] Copy Code

Public Property ControlPoints As List(Of Point)

Property Value

A collection of control points that specify the link's shape.

Remarks

You can specify new positions of a link's points through that property. The number of points in the collection depends on the Shape and SegmentCount of the link. Links made of Bézier-splines has four control points for each segment. Links of the other styles have two control points per segment. Adjacent segments share a common control point. Check the Count property of the collection to get the number of points. After setting new positions of control points you must call the UpdateFromPoints method.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Destination Property

DiagramLink.Destination Property
[image]

Gets or sets the destination node of this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Destination { get; set; }

Visual Basic [image] Copy Code

Public Property Destination As DiagramNode

Property Value

A DiagramNode instance.

Remarks

The link's destination can be changed programmatically with this property. If any of the connected nodes has an AnchorPattern defined, links ends are placed at the nearest anchor points of the two nodes. If AutoRoute is enabled, the link is routed when changing its origin or destination.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.DestinationAnchor Property

DiagramLink.DestinationAnchor Property
[image]

Gets or sets the index of the destination anchor point within the AnchorPattern that contains it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int DestinationAnchor { get; set; }

Visual Basic [image] Copy Code

Public Property DestinationAnchor As Integer

Property Value

An integer index of an anchor point within the AnchorPattern containing it.

Remarks

Specifies the index of an anchor point contained within the Destination anchor pattern. The link is docked and stays connected to that point if the node is moved or resized.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.DestinationIndex Property

DiagramLink.DestinationIndex Property
[image]

Gets or sets the index of link's destination anchor point or table row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int DestinationIndex { get; set; }

Visual Basic [image] Copy Code

Public Property DestinationIndex As Integer

Property Value

An integer value specifying the index of table's row or the index of an anchor point within its containing AnchorPattern.

Remarks

If a link's destination is a shape node, this property lets you get or set the index of an anchor point at which the link docks to the node. If there is no AnchorPattern defined for the destination node, the property returns -1. If the link is connected to a table, the property returns or changes the related row of that table.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.DestinationRow Property

DiagramLink.DestinationRow Property
[image]

Gets or sets the row to which this link should be connected when the destination node is a table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int DestinationRow { get; set; }

Visual Basic [image] Copy Code

Public Property DestinationRow As Integer

Property Value

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Dynamic Property

DiagramLink.Dynamic Property
[image]

Gets or sets a value indicating whether a link automatically adjusts its end points positions in order to keep pointing to the centers of nodes that it connects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Dynamic { get; set; }

Visual Basic [image] Copy Code

Public Property Dynamic As Boolean

Property Value

Remarks

Use the property to specify whether a link automatically repositions its end segments, so they keep pointing to the centers of nodes connected by that link.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
UpdateDynamicLink Method


MindFusion.Diagramming.DiagramLink.EndPoint Property

DiagramLink.EndPoint Property
[image]

Gets or sets the mouse position where the user ended drawing ot modifying a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point EndPoint { get; set; }

Visual Basic [image] Copy Code

Public Property EndPoint As Point

Property Value

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.HeadBrush Property

DiagramLink.HeadBrush Property
[image]

Gets or sets the brush used to paint the link's arrowhead shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush HeadBrush { get; set; }

Visual Basic [image] Copy Code

Public Property HeadBrush As Brush

Property Value

An instance of a Brush -derived class. The default value is null (Nothing in Visual Basic).

Remarks

If this property is not set, the arrowhead is filled using the link's Brush.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
HeadShape Property


MindFusion.Diagramming.DiagramLink.HeadShape Property

DiagramLink.HeadShape Property
[image]

Gets or sets the shape of this link's arrowhead.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape HeadShape { get; set; }

Visual Basic [image] Copy Code

Public Property HeadShape As Shape

Property Value

A Shape instance that represents an arrowhead shape. Initialized with the value of LinkHeadShape.

Remarks

The property specifies what shape is displayed as an arrowhead. This shape is rotated simultaneously with the last segment of the link so that it follows the overall link direction.

The ArrowHeads class exposes several predefined shapes as static properties.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
BaseShape Property
IntermediateShape Property
HeadBrush Property
HeadShapeSize Property


MindFusion.Diagramming.DiagramLink.HeadShapeSize Property

DiagramLink.HeadShapeSize Property
[image]

Gets or sets the size of the arrowhead shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double HeadShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property HeadShapeSize As Double

Property Value

Remarks

The property specifies how big the shape of the arrowhead is.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.HeadStroke Property

DiagramLink.HeadStroke Property
[image]

Gets or sets the Brush that specifies how the arrowhead stroke outline is painted. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush HeadStroke { get; set; }

Visual Basic [image] Copy Code

Public Property HeadStroke As Brush

Property Value

An instance of the Windows.UI.Xaml.Media.Brush class.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.HeadStrokeThickness Property

DiagramLink.HeadStrokeThickness Property
[image]

Gets or sets the width of the arrowhead stroke outline. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double HeadStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property HeadStrokeThickness As Double

Property Value

A double value specifying the thickness of arrowhead outlines. The default value is 1.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.IntermediateBrush Property

DiagramLink.IntermediateBrush Property
[image]

Gets or sets the brush used to paint the link's IntermediateShape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush IntermediateBrush { get; set; }

Visual Basic [image] Copy Code

Public Property IntermediateBrush As Brush

Property Value

An instance of a Brush -derived class. The default value is null (Nothing in Visual Basic).

Remarks

If this property is not set, the arrowheads are filled using the link's Brush.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.IntermediateShape Property

DiagramLink.IntermediateShape Property
[image]

Gets or sets the shape displayed at the middle of each segment of the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape IntermediateShape { get; set; }

Visual Basic [image] Copy Code

Public Property IntermediateShape As Shape

Property Value

A Shape instance that represents an arrowhead shape. Initialized with the value of LinkIntermediateShape.

Remarks

The property specifies what shape to display at the middle of each segment of a link. This could help users follow the direction of long links more easily.

The ArrowHeads class exposes several predefined shapes as static properties.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
BaseShape Property
HeadShape Property
IntermediateBrush Property
IntermediateShapeSize Property


MindFusion.Diagramming.DiagramLink.IntermediateShapeSize Property

DiagramLink.IntermediateShapeSize Property
[image]

Gets or sets the size of the IntermediateShape shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double IntermediateShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property IntermediateShapeSize As Double

Property Value

Remarks

The property specifies how big are the shapes that are displayed in the middle of link segments.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.IsConnected Property

DiagramLink.IsConnected Property
[image]

Gets a value indicating whether the link is connected to nodes at both its ends.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsConnected { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsConnected As Boolean

Property Value

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Labels Property

DiagramLink.Labels Property
[image]

Returns the list of all labels displayed by this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IList<LinkLabel> Labels { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Labels As IList(Of LinkLabel)

Property Value

A list of LinkLabel objects.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
AddLabel Method
RemoveLabel Method


MindFusion.Diagramming.DiagramLink.Origin Property

DiagramLink.Origin Property
[image]

Gets or sets the origin node of the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Origin { get; set; }

Visual Basic [image] Copy Code

Public Property Origin As DiagramNode

Property Value

Remarks

The link's origin can be changed programmatically with this property. If any of the connected nodes has an AnchorPattern defined, links ends are placed at the nearest anchor points of the two nodes. If AutoRoute is enabled, the link is routed when changing its origin or destination.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.OriginAnchor Property

DiagramLink.OriginAnchor Property
[image]

Gets or sets the index of the origin anchor point within the AnchorPattern that contains it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int OriginAnchor { get; set; }

Visual Basic [image] Copy Code

Public Property OriginAnchor As Integer

Property Value

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.OriginIndex Property

DiagramLink.OriginIndex Property
[image]

Gets or sets the index of link's origin anchor point or table row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int OriginIndex { get; set; }

Visual Basic [image] Copy Code

Public Property OriginIndex As Integer

Property Value

An integer value specifying the index of table's row or index of an anchor point within its containing AnchorPattern.

Remarks

If a link's origin is a shape node, this property lets you get or set the index of an anchor point at which the link docks to the node. If there is no AnchorPattern defined for the origin node, the property returns -1. If the link is connected to a table, the property returns or changes the related row of that table.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.OriginRow Property

DiagramLink.OriginRow Property
[image]

Gets or sets the row to which this link should be connected when the origin node is a table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int OriginRow { get; set; }

Visual Basic [image] Copy Code

Public Property OriginRow As Integer

Property Value

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.SegmentCount Property

DiagramLink.SegmentCount Property
[image]

Gets or sets the number of segments of this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int SegmentCount { get; set; }

Visual Basic [image] Copy Code

Public Property SegmentCount As Integer

Property Value

An integer value specifying how many segments the link consists of. Initialized with the value of LinkSegments.

Remarks

Use this property to make a link more indented, when necessary.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Shape Property

DiagramLink.Shape Property
[image]

Gets or sets the type of link segments and how they are positioned one relatively to another.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkShape Shape { get; set; }

Visual Basic [image] Copy Code

Public Property Shape As LinkShape

Property Value

A member of the LinkShape enumeration.

Remarks

This property specifies whether the segments of a link are straight lines or curves.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.StartPoint Property

DiagramLink.StartPoint Property
[image]

Gets or sets the mouse position where the user starts drawing or modifying the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point StartPoint { get; set; }

Visual Basic [image] Copy Code

Public Property StartPoint As Point

Property Value

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.TargetNode Property

DiagramLink.TargetNode Property
[image]

A node that will become the link's Origin or Destination if the current link drawing or modification operation completes at the current mouse pointer location.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DiagramNode TargetNode { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property TargetNode As DiagramNode

Property Value

A DiagramNode instance representing the target node.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Text Property

DiagramLink.Text Property
[image]

Gets or sets the text displayed over a link. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Text { get; set; }

Visual Basic [image] Copy Code

Public Property Text As String

Property Value

A string containing the link label.

Remarks

Gets or sets the text that is drawn over a link. Use this to provide to end-users a short description of the relation's purpose.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
Labels Property


MindFusion.Diagramming.DiagramLink.TextBlock Property

DiagramLink.TextBlock Property
[image]

The control which displays the link text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TextBlock TextBlock { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TextBlock As TextBlock

Property Value

A Windows.UI.Xaml.Controls.TextBlock instance.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLinkCollection Class

DiagramLinkCollection Class
[image]

Represents a strongly typed collection of DiagramLink objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramLinkCollection : ItemCollectionBase<DiagramLink>

Visual Basic [image] Copy Code

Public Class DiagramLinkCollection
Inherits ItemCollectionBase(Of DiagramLink)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.CollectionBase(DiagramLink, DiagramItem)
MindFusion.Diagramming.ItemCollectionBase(DiagramLink)
MindFusion.Diagramming.DiagramLinkCollection

See Also

DiagramLinkCollection Members


MindFusion.Diagramming.DiagramLinkCollection Members

DiagramLinkCollection Members
Constructors Fields Properties Methods
[image]

Represents a strongly typed collection of DiagramLink objects.

The following tables list the members exposed by the DiagramLinkCollection type.

Public Constructors

Name | Description
DiagramLinkCollection | Initializes a new instance of the DiagramLinkCollection class.

Inherited Protected Fields

Name | Description
itemEventArgs | An ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector. (Inherited from CollectionBase.)
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items. (Inherited from CollectionBase.)

Inherited Public Properties

Name | Description
Count | Gets the number of items contained in the collection. (Inherited from CollectionBase.)
IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from CollectionBase.)
Item | An indexer that lets you access the element at the specified position. (Inherited from CollectionBase.)

Inherited Public Methods

Name | Description
Add | Adds an item to the collection. (Inherited from CollectionBase.)
Clear | Removes all items from the collection. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the List(T). (Inherited from CollectionBase.)
CopyTo | (Inherited from CollectionBase.)
GetEnumerator | Returns an enumerator for this collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts an element into the Collection at the specified index. (Inherited from CollectionBase.)
Remove | Removes the first occurrence of a specific object from the collection. (Inherited from CollectionBase.)
RemoveAt | Removes the element at the specified index of the collection. (Inherited from CollectionBase.)

Inherited Protected Methods

Name | Description
RaiseAdding | Raises the Adding event. (Inherited from CollectionBase.)
RaiseInserting | Raises the Inserting event. (Inherited from CollectionBase.)
RaiseRemoving | Raises the Removing event. (Inherited from CollectionBase.)

See Also

DiagramLinkCollection Class


MindFusion.Diagramming.DiagramLinkCollection Constructor

DiagramLinkCollection Constructor
[image]

Initializes a new instance of the DiagramLinkCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramLinkCollection Class


MindFusion.Diagramming.DiagramLinkState Class

DiagramLinkState Class
[image]

Contains a snapshot of the internal state of a DiagramLink. Instances of this class are used to store the state of links for later undo or redo operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramLinkState : DiagramItemState

Visual Basic [image] Copy Code

Public Class DiagramLinkState
Inherits DiagramItemState

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemState
MindFusion.Diagramming.DiagramLinkState

See Also

DiagramLinkState Members


MindFusion.Diagramming.DiagramLinkState Members

DiagramLinkState Members
Constructors Properties
[image]

Contains a snapshot of the internal state of a DiagramLink. Instances of this class are used to store the state of links for later undo or redo operations.

The following tables list the members exposed by the DiagramLinkState type.

Public Constructors

Name | Description
DiagramLinkState |

Public Properties

Name | Description
ControlPoints | Gets or sets a collection of the control points of this link.

See Also

DiagramLinkState Class


MindFusion.Diagramming.DiagramLinkState Constructor

DiagramLinkState Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkState ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramLinkState Class


MindFusion.Diagramming.DiagramLinkState Properties

DiagramLinkState Properties
[image]

Public Properties

Name | Description
ControlPoints | Gets or sets a collection of the control points of this link.

See Also

DiagramLinkState Class


MindFusion.Diagramming.DiagramLinkState.ControlPoints Property

DiagramLinkState.ControlPoints Property
[image]

Gets or sets a collection of the control points of this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<Point> ControlPoints { get; set; }

Visual Basic [image] Copy Code

Public Property ControlPoints As List(Of Point)

Property Value

Remarks

You can specify new positions of a link's points through that property. The number of points in the collection depends on the Shape and SegmentCount of the link. Links made of Bézier-splines has four control points for each segment. Links of the other styles have two control points per segment. Adjacent segments share a common control point.

See Also

DiagramLinkState Members
DiagramLinkState Class


MindFusion.Diagramming.DiagramNode Class

DiagramNode Class
[image]

DiagramNode is an abstract base class from which the ShapeNode, TableNode and ControlNode classes derive. DiagramNode instances can represent graph vertices, nodes in organizational or flow diagrams, entities in ER diagrams, and so on.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramNode : DiagramItem

Visual Basic [image] Copy Code

Public Class DiagramNode
Inherits DiagramItem

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
Windows.UI.Xaml.Controls.ContentControl
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.ControlNode
MindFusion.Diagramming.DummyNode
MindFusion.Diagramming.ShapeNode
MindFusion.Diagramming.TableNode
MindFusion.Diagramming.TreeViewNode

See Also

DiagramNode Members


MindFusion.Diagramming.DiagramNode Members

DiagramNode Members
Constructors Fields Properties Methods
[image]

DiagramNode is an abstract base class from which the ShapeNode, TableNode and ControlNode classes derive. DiagramNode instances can represent graph vertices, nodes in organizational or flow diagrams, entities in ER diagrams, and so on.

The following tables list the members exposed by the DiagramNode type.

Public Constructors

Name | Description
DiagramNode | Overloaded.

Public Fields

Name | Description
BoundsProperty | Identifies the Bounds dependency property.
EffectsSourceProperty | Identifies the EffectsSource dependency property.
MasterNodeProperty | Identifies the MasterNode dependency property.
RotationAngleProperty | Identifies the RotationAngle dependency property.
ShapeOpacityProperty | Identifies the ShapeOpacity dependency property.

Inherited Public Fields

Name | Description
AutoCaptureMouseProperty | Identifies the AutoCaptureMouse dependency property. (Inherited from DiagramItem.)
BrushProperty | Identifies the Brush dependency property. (Inherited from DiagramItem.)
HyperLinkProperty | Identifies the HyperLink dependency property. (Inherited from DiagramItem.)
IsMouseDownProperty | Identifies the IsMouseDown dependency property. (Inherited from DiagramItem.)
IsMouseOverProperty | Identifies the IsMouseOver dependency property. (Inherited from DiagramItem.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from DiagramItem.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)

Inherited Protected Fields

Name | Description
handles | A list of the Rectangle objects that represent the item's adjustment handles. (Inherited from DiagramItem.)

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node.
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node.
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node.
AttachedNodes | Returns the nodes attached to this node.
Bounds | Gets or sets the rectangle that defines the position of the diagram node. This is a dependency property.
Constraints | Allows applying constraints to the location and size of the node.
Container | Gets the ContainerNode that contains this node.
Effects | Gets a collection with all effects applied to this node.
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node.
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node.
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded.
IncomingLinks | Gets a collection of links that point to the node.
MasterNode | Gets the node to which this node is attached. This is a dependency property.
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm.
OutgoingLinks | Gets a collection of links that start from this node.
RotationAngle | Gets or sets the angle at which this node is rotated. This is a dependency property.
ShapeOpacity | Gets or sets the shape opacity of this node. This is a dependency property.

Inherited Public Properties

Name | Description
AutoCaptureMouse | Gets or sets whether the item should capture the mouse input when the left button is pressed over it. This is a dependency property. (Inherited from DiagramItem.)
Brush | Gets or sets the Brush that specifies how to paint the interior of the item. This is a dependency property. (Inherited from DiagramItem.)
Diagram | Gets the parent diagram. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramItem.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. This is a dependency property. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IsMouseDown | Gets a value indicating whether the mouse button is pressed over this item. This is a dependency property. (Inherited from DiagramItem.)
IsMouseOver | Gets a value indicating whether the mouse pointer is located over this item. This is a dependency property. (Inherited from DiagramItem.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline nodes. This is a dependency property. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashOffset | Gets or sets a double value that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. This is a dependency property. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
ToolTip | Gets or sets the contents of the tooltip displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of the object. (Inherited from DiagramItem.)

Inherited Protected Properties

Name | Description
Size | Gets the size of this item. (Inherited from DiagramItem.)

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type.
Attach | Attaches the specified subordinate node to this node, so that when this node is moved, the subordinate follows it.
AttachTo | Attaches this node to the specified master node so that when the master is moved, the attached node follows it.
ContainsPoint | DiagramItem.ContainsPoint override.
Detach | Overloaded.
GetAllIncomingLinks | Gets a collection of all links entering this node.
GetAllLinks | Gets all links connected to this node.
GetAllOutgoingLinks | Get a collection of all links going out of this node.
GetBounds | Gets the bounding rectangle of this item.
GetCenter | Gets the center of this node's bounding rectangle.
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point.
GetOutlinePoly | DiagramItem.GetOutlinePoly override.
HitTestHandle | DiagramItem.HitTestHandle override.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
OnBoundsChanged | Called when the location and size of this node change.
OnDragOut | Invoked when a diagram item is being dragged out of this node.
OnDragOver | Invoked when a diagram item is being dragged over this node.
OnDropOver | Invoked when a diagram item is dropped over this node.
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed.
ReassignUnanchoredLinks | Reassigns unanchored links
RestoreLocationState | DiagramItem.RestoreLocationState override.
SaveLocationState | DiagramItem.SaveLocationState override.
SetBounds | Sets the location and size of this node.

Protected Methods

Name | Description
AddAnchorPointVisuals | Adds the AnchorPatern points to the node's Adorner.
AddExpandButton | Adds the ExpandButton to the node's Adoner.
AddHandlesToCanvas | Overloaded.
CancelDrag | DiagramItem.CancelDrag override.
CreateAnchorPointVisual | Creates a Path that represents the specified AnchorPoint.
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point.
CreateState | DiagramItem.CreateState override.
EndDrag | DiagramItem.EndDrag override.
GetOutline | Creates a Geometry object that describes the outline of the node.
GetRotatedBounds | Overloaded.
LoadFromXml | DiagramItem.LoadFromXml override.
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo.
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes.
OnRemove | DiagramItem.OnRemove override.
RemoveAnchorPointVisuals | Removes the AnchorPatern points from the node's Adorner.
RestoreState | DiagramItem.RestoreState override.
SaveState | DiagramItem.SaveState override.
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount.
SetIncomingLinks | Sets the incoming links collection of this node.
SetOutgoingLinks | Sets the outgoing links collection of this node.
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it.
StartDrag | DiagramItem.StartDrag override.
UpdateDrag | DiagramItem.UpdateDrag override.
UpdateVisuals | DiagramItem.UpdateVisuals override.

Inherited Public Methods

Name | Description
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
ContainsPoint | Determines whether this item contains the specified point. (Inherited from DiagramItem.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetOutlinePoly | Gets a polygon approximating the outline of this object. (Inherited from DiagramItem.)
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow. (Inherited from DiagramItem.)
GetRotatedBounds | Gets the bounding rectangle of this item when it is rotated. (Inherited from DiagramItem.)
HitTestHandle | Determines whether a selection handle of this item is located at the specified point. (Inherited from DiagramItem.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnApplyTemplate | Control.OnApplyTemplate override. (Inherited from DiagramItem.)
RestoreLocationState | Restores the state of this diagram item. (Inherited from DiagramItem.)
SaveLocationState | Saves the state of this diagram item. (Inherited from DiagramItem.)
TransformDiagramToItem | Transforms a point in diagram coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Gets the diagram coordinates of a point specified in the local coordinate system of this item. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Inherited Protected Methods

Name | Description
AddHandlesToCanvas | Overloaded. (Inherited from DiagramItem.)
AllowDrag | Invoked to validate the drag operation. (Inherited from DiagramItem.)
CancelDrag | Invoked when the interactive modification of this object has been canceled. (Inherited from DiagramItem.)
CreateState | Creates an item state corresponding to the type of this diagram item. (Inherited from DiagramItem.)
EndDrag | Invoked when the user stops dragging this item. (Inherited from DiagramItem.)
LoadFromXml | Loads the item content from an XML element. (Inherited from DiagramItem.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnMouseEnter | Control.OnMouseEnter override. (Inherited from DiagramItem.)
OnMouseLeave | Control.OnMouseLeave override. (Inherited from DiagramItem.)
OnMouseLeftButtonDown | Control.OnMouseLeftButtonDown override. (Inherited from DiagramItem.)
OnMouseLeftButtonUp | Control.OnMouseLeftButtonUp override. (Inherited from DiagramItem.)
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
RemoveHandlesFromCanvas | Invoked when the item's selection handles should be removed. (Inherited from DiagramItem.)
RestoreState | Restores the state of this diagram item. (Inherited from DiagramItem.)
SaveState | Saves the state of this diagram item. (Inherited from DiagramItem.)
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramItem.)
StartDrag | Invoked when the user starts dragging this item. (Inherited from DiagramItem.)
UpdateDrag | Invoked while the user drags this item. (Inherited from DiagramItem.)
UpdateHandleColors | Sets the handle colors according to the current selection state of the item and the enabled bits in the EnabledHandles property. (Inherited from DiagramItem.)
UpdateHandlePositions | Invoked when the item's selection handles should change their position. (Inherited from DiagramItem.)
UpdateStates | Sets the current VisualStates of this item. (Inherited from DiagramItem.)
UpdateVisuals | Invoked when an item should update its visual elements. (Inherited from DiagramItem.)

See Also

DiagramNode Class


MindFusion.Diagramming.DiagramNode Fields

DiagramNode Fields
[image]

Public Fields

Name | Description
BoundsProperty | Identifies the Bounds dependency property.
EffectsSourceProperty | Identifies the EffectsSource dependency property.
MasterNodeProperty | Identifies the MasterNode dependency property.
RotationAngleProperty | Identifies the RotationAngle dependency property.
ShapeOpacityProperty | Identifies the ShapeOpacity dependency property.

Inherited Public Fields

Name | Description
AutoCaptureMouseProperty | Identifies the AutoCaptureMouse dependency property. (Inherited from DiagramItem.)
BrushProperty | Identifies the Brush dependency property. (Inherited from DiagramItem.)
HyperLinkProperty | Identifies the HyperLink dependency property. (Inherited from DiagramItem.)
IsMouseDownProperty | Identifies the IsMouseDown dependency property. (Inherited from DiagramItem.)
IsMouseOverProperty | Identifies the IsMouseOver dependency property. (Inherited from DiagramItem.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from DiagramItem.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)

Inherited Protected Fields

Name | Description
handles | A list of the Rectangle objects that represent the item's adjustment handles. (Inherited from DiagramItem.)

See Also

DiagramNode Class


MindFusion.Diagramming.DiagramNode.BoundsProperty Field

DiagramNode.BoundsProperty Field
[image]

Identifies the Bounds dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BoundsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BoundsProperty As DependencyProperty

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.EffectsSourceProperty Field

DiagramNode.EffectsSourceProperty Field
[image]

Identifies the EffectsSource dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EffectsSourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EffectsSourceProperty As DependencyProperty

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.MasterNodeProperty Field

DiagramNode.MasterNodeProperty Field
[image]

Identifies the MasterNode dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MasterNodeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MasterNodeProperty As DependencyProperty

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.RotationAngleProperty Field

DiagramNode.RotationAngleProperty Field
[image]

Identifies the RotationAngle dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RotationAngleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RotationAngleProperty As DependencyProperty

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.ShapeOpacityProperty Field

DiagramNode.ShapeOpacityProperty Field
[image]

Identifies the ShapeOpacity dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShapeOpacityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShapeOpacityProperty As DependencyProperty

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode Constructor

DiagramNode Constructor
[image]

Overload List

Name | Description
DiagramNode () | Initializes a new DiagramNode instance.
DiagramNode (Diagram) | Initializes a new DiagramNode instance by setting its properties to the default values defined in the specified Diagram.
DiagramNode (DiagramNode) | Initializes a new instance of the DiagramNode class using the specified diagram node as a prototype.

See Also

DiagramNode Class


MindFusion.Diagramming.DiagramNode Constructor ()

DiagramNode Constructor ()
See Also
[image]

Initializes a new DiagramNode instance.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode ()

Visual Basic [image] Copy Code

Public Sub New ()

Remarks

This constructor leaves the node's dependency properties in their default state, without local values. This allows the node to be styled through the WinRT styling mechanism.

See Also

DiagramNode Constructor Overload List
DiagramNode Class


MindFusion.Diagramming.DiagramNode Constructor (Diagram)

DiagramNode Constructor (Diagram)
See Also
[image]

Initializes a new DiagramNode instance by setting its properties to the default values defined in the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode (
Diagram parent
)

Visual Basic [image] Copy Code

Public Function DiagramNode ( _
parent As Diagram _
)

Parameters

parent
A Diagram instance whose default nodeattributes are copied to this node.

See Also

DiagramNode Constructor Overload List
DiagramNode Class


MindFusion.Diagramming.DiagramNode Constructor (DiagramNode)

DiagramNode Constructor (DiagramNode)
See Also
[image]

Initializes a new instance of the DiagramNode class using the specified diagram node as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode (
DiagramNode prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As DiagramNode _
)

Parameters

prototype
The node to use as a prototype. The properties of the new node are initialized from the property values of this node.

Remarks

This constructor copies the DiagramNode property values from the specified prototype node.

See Also

DiagramNode Constructor Overload List
DiagramNode Class


MindFusion.Diagramming.DiagramNode Methods

DiagramNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type.
Attach | Attaches the specified subordinate node to this node, so that when this node is moved, the subordinate follows it.
AttachTo | Attaches this node to the specified master node so that when the master is moved, the attached node follows it.
ContainsPoint | DiagramItem.ContainsPoint override.
Detach | Overloaded.
GetAllIncomingLinks | Gets a collection of all links entering this node.
GetAllLinks | Gets all links connected to this node.
GetAllOutgoingLinks | Get a collection of all links going out of this node.
GetBounds | Gets the bounding rectangle of this item.
GetCenter | Gets the center of this node's bounding rectangle.
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point.
GetOutlinePoly | DiagramItem.GetOutlinePoly override.
HitTestHandle | DiagramItem.HitTestHandle override.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
OnBoundsChanged | Called when the location and size of this node change.
OnDragOut | Invoked when a diagram item is being dragged out of this node.
OnDragOver | Invoked when a diagram item is being dragged over this node.
OnDropOver | Invoked when a diagram item is dropped over this node.
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed.
ReassignUnanchoredLinks | Reassigns unanchored links
RestoreLocationState | DiagramItem.RestoreLocationState override.
SaveLocationState | DiagramItem.SaveLocationState override.
SetBounds | Sets the location and size of this node.

Protected Methods

Name | Description
AddAnchorPointVisuals | Adds the AnchorPatern points to the node's Adorner.
AddExpandButton | Adds the ExpandButton to the node's Adoner.
AddHandlesToCanvas | Overloaded.
CancelDrag | DiagramItem.CancelDrag override.
CreateAnchorPointVisual | Creates a Path that represents the specified AnchorPoint.
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point.
CreateState | DiagramItem.CreateState override.
EndDrag | DiagramItem.EndDrag override.
GetOutline | Creates a Geometry object that describes the outline of the node.
GetRotatedBounds | Overloaded.
LoadFromXml | DiagramItem.LoadFromXml override.
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo.
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes.
OnRemove | DiagramItem.OnRemove override.
RemoveAnchorPointVisuals | Removes the AnchorPatern points from the node's Adorner.
RestoreState | DiagramItem.RestoreState override.
SaveState | DiagramItem.SaveState override.
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount.
SetIncomingLinks | Sets the incoming links collection of this node.
SetOutgoingLinks | Sets the outgoing links collection of this node.
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it.
StartDrag | DiagramItem.StartDrag override.
UpdateDrag | DiagramItem.UpdateDrag override.
UpdateVisuals | DiagramItem.UpdateVisuals override.

Inherited Public Methods

Name | Description
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
ContainsPoint | Determines whether this item contains the specified point. (Inherited from DiagramItem.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetOutlinePoly | Gets a polygon approximating the outline of this object. (Inherited from DiagramItem.)
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow. (Inherited from DiagramItem.)
GetRotatedBounds | Gets the bounding rectangle of this item when it is rotated. (Inherited from DiagramItem.)
HitTestHandle | Determines whether a selection handle of this item is located at the specified point. (Inherited from DiagramItem.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnApplyTemplate | Control.OnApplyTemplate override. (Inherited from DiagramItem.)
RestoreLocationState | Restores the state of this diagram item. (Inherited from DiagramItem.)
SaveLocationState | Saves the state of this diagram item. (Inherited from DiagramItem.)
TransformDiagramToItem | Transforms a point in diagram coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Gets the diagram coordinates of a point specified in the local coordinate system of this item. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Inherited Protected Methods

Name | Description
AddHandlesToCanvas | Overloaded. (Inherited from DiagramItem.)
AllowDrag | Invoked to validate the drag operation. (Inherited from DiagramItem.)
CancelDrag | Invoked when the interactive modification of this object has been canceled. (Inherited from DiagramItem.)
CreateState | Creates an item state corresponding to the type of this diagram item. (Inherited from DiagramItem.)
EndDrag | Invoked when the user stops dragging this item. (Inherited from DiagramItem.)
LoadFromXml | Loads the item content from an XML element. (Inherited from DiagramItem.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnMouseEnter | Control.OnMouseEnter override. (Inherited from DiagramItem.)
OnMouseLeave | Control.OnMouseLeave override. (Inherited from DiagramItem.)
OnMouseLeftButtonDown | Control.OnMouseLeftButtonDown override. (Inherited from DiagramItem.)
OnMouseLeftButtonUp | Control.OnMouseLeftButtonUp override. (Inherited from DiagramItem.)
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
RemoveHandlesFromCanvas | Invoked when the item's selection handles should be removed. (Inherited from DiagramItem.)
RestoreState | Restores the state of this diagram item. (Inherited from DiagramItem.)
SaveState | Saves the state of this diagram item. (Inherited from DiagramItem.)
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramItem.)
StartDrag | Invoked when the user starts dragging this item. (Inherited from DiagramItem.)
UpdateDrag | Invoked while the user drags this item. (Inherited from DiagramItem.)
UpdateHandleColors | Sets the handle colors according to the current selection state of the item and the enabled bits in the EnabledHandles property. (Inherited from DiagramItem.)
UpdateHandlePositions | Invoked when the item's selection handles should change their position. (Inherited from DiagramItem.)
UpdateStates | Sets the current VisualStates of this item. (Inherited from DiagramItem.)
UpdateVisuals | Invoked when an item should update its visual elements. (Inherited from DiagramItem.)

See Also

DiagramNode Class


MindFusion.Diagramming.DiagramNode.AcceptLinks Method

DiagramNode.AcceptLinks Method
[image]

Determines whether the node can be connected with links of the specified type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool AcceptLinks (
bool outgoing
)

Visual Basic [image] Copy Code

Public Overridable Function AcceptLinks( _
outgoing As Boolean _
) As Boolean

Parameters

outgoing

true to check for outgoing links; otherwise, false.

Return Value

true if the node accepts connections of the specified type; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.AddAnchorPointVisuals Method

DiagramNode.AddAnchorPointVisuals Method
[image]

Adds the AnchorPatern points to the node's Adorner.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void AddAnchorPointVisuals (
AnchorPattern ?nchorPattern,
List<Path> pointVisuals,
bool updatePositions
)

Visual Basic [image] Copy Code

Protected Overridable Sub AddAnchorPointVisuals( _
?nchorPattern As AnchorPattern, _
pointVisuals As List(Of Path), _
updatePositions As Boolean _
)

Parameters

?nchorPattern

pointVisuals

updatePositions

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.AddExpandButton Method

DiagramNode.AddExpandButton Method
[image]

Adds the ExpandButton to the node's Adoner.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void AddExpandButton ()

Visual Basic [image] Copy Code

Protected Sub AddExpandButton ()

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.AddHandlesToCanvas Method

DiagramNode.AddHandlesToCanvas Method
[image]

Overload List

Name | Description
DiagramNode.AddHandlesToCanvas () | DiagramItem.AddHandlesToCanvas override.
DiagramNode.AddHandlesToCanvas (IList(Point)) | DiagramItem.AddHandlesToCanvas override.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.AddHandlesToCanvas Method ()

DiagramNode.AddHandlesToCanvas Method ()
See Also
[image]

DiagramItem.AddHandlesToCanvas override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void AddHandlesToCanvas ()

Visual Basic [image] Copy Code

Protected Overrides Sub AddHandlesToCanvas ()

See Also

AddHandlesToCanvas Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.AddHandlesToCanvas Method (IList(Point))

DiagramNode.AddHandlesToCanvas Method (IList(Point))
See Also
[image]

DiagramItem.AddHandlesToCanvas override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void AddHandlesToCanvas (
IList<Point> positions
)

Visual Basic [image] Copy Code

Protected Overrides Sub AddHandlesToCanvas( _
positions As IList(Of Point) _
)

Parameters

positions

See Also

AddHandlesToCanvas Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Attach Method

DiagramNode.Attach Method
[image]

Attaches the specified subordinate node to this node, so that when this node is moved, the subordinate follows it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Attach (
DiagramNode subordinate
)

Visual Basic [image] Copy Code

Public Sub Attach( _
subordinate As DiagramNode _
)

Parameters

subordinate

A DiagramNode instance specifying the node that should be attached.

Remarks

Layout algorithms can treat a group of attached nodes either as a single node to be placed in the arranged graph, or as distinct nodes whose final positions are set independently from the initial group layout. This is controlled via the KeepGroupLayout property.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
Detach Method
AttachedNodes Property


MindFusion.Diagramming.DiagramNode.AttachTo Method

DiagramNode.AttachTo Method
[image]

Attaches this node to the specified master node so that when the master is moved, the attached node follows it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AttachTo (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Sub AttachTo( _
node As DiagramNode _
)

Parameters

node

A DiagramNode instance specifying the master node.

Remarks

Layout algorithms can treat a group of attached nodes either as a single node to be placed in the arranged graph, or as distinct nodes whose final positions are set independently from the initial group layout. This is controlled via the KeepGroupLayout property.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
Detach Method
MasterNode Property


MindFusion.Diagramming.DiagramNode.CancelDrag Method

DiagramNode.CancelDrag Method
[image]

DiagramItem.CancelDrag override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void CancelDrag (
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub CancelDrag( _
ist As InteractionState _
)

Parameters

ist

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.ContainsPoint Method

DiagramNode.ContainsPoint Method
[image]

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
point As Point _
) As Boolean

Parameters

point
The point to check.

Return Value

true if this node contains the specified point; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.CreateAnchorPointVisual Method

DiagramNode.CreateAnchorPointVisual Method
[image]

Creates a Path that represents the specified AnchorPoint.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual Path CreateAnchorPointVisual (
AnchorPoint point
)

Visual Basic [image] Copy Code

Protected Overridable Function CreateAnchorPointVisual( _
point As AnchorPoint _
) As Path

Parameters

point

Return Value

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.CreateConnectionPoint Method

DiagramNode.CreateConnectionPoint Method
[image]

Creates a connection point between this node and the specified link at the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual ConnectionPoint CreateConnectionPoint (
DiagramLink link,
Point point,
bool incoming
)

Visual Basic [image] Copy Code

Protected Overridable Function CreateConnectionPoint ( _
link As DiagramLink, _
point As Point, _
incoming As Boolean _
) As ConnectionPoint

Parameters

link
A DiagramLink that should be connected to this node.
point

The point at which the link should be connected.

incoming

true if link is an incoming link, otherwise, false.

Return Value

A ConnectionPoint instance representing the connection.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.CreateState Method

DiagramNode.CreateState Method
[image]

DiagramItem.CreateState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramItemState CreateState ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateState () As DiagramItemState

Return Value

A DiagramNodeState instance.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Detach Method

DiagramNode.Detach Method
[image]

Overload List

Name | Description
DiagramNode.Detach () | Detaches this node from its current master node.
DiagramNode.Detach (DiagramNode) | Detaches the specified subordinate node from this node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Detach Method ()

DiagramNode.Detach Method ()
See Also
[image]

Detaches this node from its current master node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Detach ()

Visual Basic [image] Copy Code

Public Sub Detach ()

Remarks

This method does nothing if the node hasn't been previously attached to another node via the Attach or AttachTo methods.

See Also

Detach Method Overload List
DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
MasterNode Property


MindFusion.Diagramming.DiagramNode.Detach Method (DiagramNode)

DiagramNode.Detach Method (DiagramNode)
See Also
[image]

Detaches the specified subordinate node from this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Detach (
DiagramNode subordinate
)

Visual Basic [image] Copy Code

Public Sub Detach( _
subordinate As DiagramNode _
)

Parameters

subordinate

The node that should be detached.

Remarks

This method does nothing if the specified node hasn't been previously attached to this node via the Attach or AttachTo methods.

See Also

Detach Method Overload List
DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
AttachedNodes Property


MindFusion.Diagramming.DiagramNode.EndDrag Method

DiagramNode.EndDrag Method
[image]

DiagramItem.EndDrag override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void EndDrag (
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub EndDrag( _
ist As InteractionState _
)

Parameters

ist

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetAllIncomingLinks Method

DiagramNode.GetAllIncomingLinks Method
[image]

Gets a collection of all links entering this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection GetAllIncomingLinks ()

Visual Basic [image] Copy Code

Public Function GetAllIncomingLinks () As DiagramLinkCollection

Return Value

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetAllLinks Method

DiagramNode.GetAllLinks Method
[image]

Gets all links connected to this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection GetAllLinks ()

Visual Basic [image] Copy Code

Public Function GetAllLinks () As DiagramLinkCollection

Return Value

A DiagramLinkCollection containing the links connected to this node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetAllOutgoingLinks Method

DiagramNode.GetAllOutgoingLinks Method
[image]

Get a collection of all links going out of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection GetAllOutgoingLinks ()

Visual Basic [image] Copy Code

Public Function GetAllOutgoingLinks () As DiagramLinkCollection

Return Value

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetBounds Method

DiagramNode.GetBounds Method
[image]

Gets the bounding rectangle of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Rect GetBounds ()

Visual Basic [image] Copy Code

Public Overrides Function GetBounds () As Rect

Return Value

The rectangle that bounds this item.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetCenter Method

DiagramNode.GetCenter Method
[image]

Gets the center of this node's bounding rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point GetCenter ()

Visual Basic [image] Copy Code

Public Function GetCenter () As Point

Return Value

A Point object representing the center point of this node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetIntersection Method

DiagramNode.GetIntersection Method
[image]

Calculates the intersecion point between the segment defined by the specified point pair and the node's outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Point GetIntersection (
Point segmentStart,
Point segmentEnd
)

Visual Basic [image] Copy Code

Public Overridable Function GetIntersection( _
segmentStart As Point, _
segmentEnd As Point _
) As Point

Parameters

segmentStart

The first point of the segment.

segmentEnd

The second point of the segment.

Return Value

A Point object representing the intersection point.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetNearestBorderPoint Method

DiagramNode.GetNearestBorderPoint Method
[image]

Returns a point that lies on the outline of this node, at the shortest distance from the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point GetNearestBorderPoint (
Point point
)

Visual Basic [image] Copy Code

Public Function GetNearestBorderPoint( _
point As Point _
) As Point

Parameters

point
A Point instance.

Return Value

A Point instance that identifies the point from the node border located at minimum distance from the specified point.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetOutline Method

DiagramNode.GetOutline Method
[image]

Creates a Geometry object that describes the outline of the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual Geometry GetOutline ()

Visual Basic [image] Copy Code

Protected Overridable Function GetOutline () As Geometry

Return Value

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetOutlinePoly Method

DiagramNode.GetOutlinePoly Method
[image]

DiagramItem.GetOutlinePoly override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override List<Point> GetOutlinePoly ()

Visual Basic [image] Copy Code

Public Overrides Function GetOutlinePoly () As List(Of Point)

Return Value

A polygon approximating the outline of this diagram item.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetRotatedBounds Method

DiagramNode.GetRotatedBounds Method
[image]

Overload List

Name | Description
DiagramNode.GetRotatedBounds () | Gets the bounding rectangle of this item when it is rotated.
DiagramNode.GetRotatedBounds (Rect, Point, Double) | Gets the bounding rectangle of this node, when it is rotated at the specified angle around the specified pivot.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetRotatedBounds Method ()

DiagramNode.GetRotatedBounds Method ()
See Also
[image]

Gets the bounding rectangle of this item when it is rotated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Rect GetRotatedBounds ()

Visual Basic [image] Copy Code

Public Overrides Function GetRotatedBounds () As Rect

Return Value

A rectangle that bounds the rotated shape of the item.

Remarks

This method is invoked during hit-testing to do a quick test whether a point is within the item's bounds, before calling the possibly more time-consuming ContainsPoint method.

See Also

GetRotatedBounds Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetRotatedBounds Method (Rect, Point, Double)

DiagramNode.GetRotatedBounds Method (Rect, Point, Double)
See Also
[image]

Gets the bounding rectangle of this node, when it is rotated at the specified angle around the specified pivot.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Rect GetRotatedBounds (
Rect rect,
Point center,
double angle
)

Visual Basic [image] Copy Code

Protected Function GetRotatedBounds( _
rect As Rect, _
center As Point, _
angle As Double _
) As Rect

Parameters

rect

center

angle

Return Value

See Also

GetRotatedBounds Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.HitTestHandle Method

DiagramNode.HitTestHandle Method
[image]

DiagramItem.HitTestHandle override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool HitTestHandle (
Point point,
ref int handle
)

Visual Basic [image] Copy Code

Public Overrides Function HitTestHandle( _
point As Point, _
ByRef handle As Integer _
) As Boolean

Parameters

point

A Point value specifying where to look for a selection handle.

handle

A reference to an integer variable, which receives the index of the found selection handle.

Return Value

true if there is a selection handle at the specified location; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.LoadFromXml Method

DiagramNode.LoadFromXml Method
[image]

DiagramItem.LoadFromXml override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFromXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFromXml ( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement containing the item's data.

context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnAdd Method

DiagramNode.OnAdd Method
[image]

Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnAdd ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnAdd ()

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnApplyTemplate Method

DiagramNode.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Overrides Sub OnApplyTemplate ()

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnBoundsChanged Method

DiagramNode.OnBoundsChanged Method
[image]

Called when the location and size of this node change.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void OnBoundsChanged (
Rect oldRect,
Rect newRect,
bool updateLinks,
bool updateChildren,
bool updateStorage
)

Visual Basic [image] Copy Code

Public Overridable Sub OnBoundsChanged( _
oldRect As Rect, _
newRect As Rect, _
updateLinks As Boolean, _
updateChildren As Boolean, _
updateStorage As Boolean _
)

Parameters

oldRect

Specifies the old position of the node.

newRect

Specifies the new position of the node.

updateLinks

Specifies whether the position of links connected to this node should be updated too.

updateChildren

Specifies whether position of child nodes should be updated too.

updateStorage

true to update the stored value, otherwise false.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnDragOut Method

DiagramNode.OnDragOut Method
[image]

Invoked when a diagram item is being dragged out of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void OnDragOut (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Overridable Sub OnDragOut( _
item As DiagramItem _
)

Parameters

item

The DiagramItem that is dragged out of the node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnDragOver Method

DiagramNode.OnDragOver Method
[image]

Invoked when a diagram item is being dragged over this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool OnDragOver (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Overridable Function OnDragOver( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem that is dragged over the node.

Return Value

false if the diagram should notify nodes below this one; otherwise, true.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnDropOver Method

DiagramNode.OnDropOver Method
[image]

Invoked when a diagram item is dropped over this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool OnDropOver (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Overridable Function OnDropOver( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem that is dropped over the node.

Return Value

false if the diagram should notify nodes below this one; otherwise, true.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnMeasureUnitChanged Method

DiagramNode.OnMeasureUnitChanged Method
[image]

Called when the diagram's MeasureUnit changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnMeasureUnitChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnMeasureUnitChanged ()

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnRemove Method

DiagramNode.OnRemove Method
[image]

DiagramItem.OnRemove override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnRemove ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnRemove ()

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.ReassignAnchorPoints Method

DiagramNode.ReassignAnchorPoints Method
[image]

Reassigns links to anchor points so that they are evenly disctributed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ReassignAnchorPoints ()

Visual Basic [image] Copy Code

Public Sub ReassignAnchorPoints ()

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.ReassignUnanchoredLinks Method

DiagramNode.ReassignUnanchoredLinks Method
[image]

Reassigns unanchored links

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ReassignUnanchoredLinks ()

Visual Basic [image] Copy Code

Public Sub ReassignUnanchoredLinks ()

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.RemoveAnchorPointVisuals Method

DiagramNode.RemoveAnchorPointVisuals Method
[image]

Removes the AnchorPatern points from the node's Adorner.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void RemoveAnchorPointVisuals (
List<Path> anchorPointVisuals
)

Visual Basic [image] Copy Code

Protected Sub RemoveAnchorPointVisuals( _
anchorPointVisuals As List(Of Path) _
)

Parameters

anchorPointVisuals

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.RestoreLocationState Method

DiagramNode.RestoreLocationState Method
[image]

DiagramItem.RestoreLocationState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void RestoreLocationState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Public Overrides Sub RestoreLocationState ( _
state As DiagramItemState _
)

Parameters

state
A DiagramNodeState instance.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.RestoreState Method

DiagramNode.RestoreState Method
[image]

DiagramItem.RestoreState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void RestoreState (
DiagramItemState itemState
)

Visual Basic [image] Copy Code

Protected Overridable Sub RestoreState ( _
itemState As DiagramItemState _
)

Parameters

itemState
A DiagramNodeState instance.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SaveLocationState Method

DiagramNode.SaveLocationState Method
[image]

DiagramItem.SaveLocationState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override DiagramItemState SaveLocationState ()

Visual Basic [image] Copy Code

Public Overrides Function SaveLocationState () As DiagramItemState

Return Value

A DiagramNodeState instance.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SaveState Method

DiagramNode.SaveState Method
[image]

DiagramItem.SaveState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override DiagramItemState SaveState ()

Visual Basic [image] Copy Code

Public Overrides Function SaveState () As DiagramItemState

Return Value

A DiagramItemState instance.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SaveToXml Method

DiagramNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveToXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveToXml ( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement the item's data should be stored into.

context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.ScaleElements Method

DiagramNode.ScaleElements Method
[image]

Scales the node's elements by specified amount.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void ScaleElements (
double scale
)

Visual Basic [image] Copy Code

Protected Overrides Sub ScaleElements( _
scale As Double _
)

Parameters

scale

The value by which to multiply node elements' sizes.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SetBounds Method

DiagramNode.SetBounds Method
[image]

Sets the location and size of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetBounds (
Rect newRect,
bool updateChildren,
bool updateLinks
)

Visual Basic [image] Copy Code

Public Sub SetBounds( _
newRect As Rect, _
updateChildren As Boolean, _
updateLinks As Boolean _
)

Parameters

newRect

A Rect instance specifying the new location and size of the node.

updateChildren

true to update the position of child nodes, otherwise false.

updateLinks

Specifies whether the position of links connected to this node should be updated too.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SetIncomingLinks Method

DiagramNode.SetIncomingLinks Method
[image]

Sets the incoming links collection of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void SetIncomingLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Protected Sub SetIncomingLinks ( _
links As DiagramLinkCollection _
)

Parameters

links
A DiagramLinkCollection containing the node's incoming links.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SetOutgoingLinks Method

DiagramNode.SetOutgoingLinks Method
[image]

Sets the outgoing links collection of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void SetOutgoingLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Protected Sub SetOutgoingLinks ( _
links As DiagramLinkCollection _
)

Parameters

links
A DiagramLinkCollection containing the node's outgoing links.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SetReflexive Method

DiagramNode.SetReflexive Method
[image]

Invoked to let a node set the shape of a reflexive link connected to it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SetReflexive (
Action action,
DiagramLink link
)

Visual Basic [image] Copy Code

Protected Overridable Sub SetReflexive ( _
action As Action, _
link As DiagramLink _
)

Parameters

action
An Action member specifying whether the link has been created or modified.
link

Reference to the link.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.StartDrag Method

DiagramNode.StartDrag Method
[image]

DiagramItem.StartDrag override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void StartDrag (
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub StartDrag( _
ist As InteractionState _
)

Parameters

ist

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.UpdateDrag Method

DiagramNode.UpdateDrag Method
[image]

DiagramItem.UpdateDrag override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void UpdateDrag (
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overridable Sub UpdateDrag ( _
ist As InteractionState _
)

Parameters

ist

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.UpdateVisuals Method

DiagramNode.UpdateVisuals Method
[image]

DiagramItem.UpdateVisuals override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void UpdateVisuals (
bool updateEffects
)

Visual Basic [image] Copy Code

Protected Overrides Sub UpdateVisuals( _
updateEffects As Boolean _
)

Parameters

updateEffects

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode Properties

DiagramNode Properties
[image]

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node.
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node.
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node.
AttachedNodes | Returns the nodes attached to this node.
Bounds | Gets or sets the rectangle that defines the position of the diagram node. This is a dependency property.
Constraints | Allows applying constraints to the location and size of the node.
Container | Gets the ContainerNode that contains this node.
Effects | Gets a collection with all effects applied to this node.
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node.
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node.
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded.
IncomingLinks | Gets a collection of links that point to the node.
MasterNode | Gets the node to which this node is attached. This is a dependency property.
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm.
OutgoingLinks | Gets a collection of links that start from this node.
RotationAngle | Gets or sets the angle at which this node is rotated. This is a dependency property.
ShapeOpacity | Gets or sets the shape opacity of this node. This is a dependency property.

Inherited Public Properties

Name | Description
AutoCaptureMouse | Gets or sets whether the item should capture the mouse input when the left button is pressed over it. This is a dependency property. (Inherited from DiagramItem.)
Brush | Gets or sets the Brush that specifies how to paint the interior of the item. This is a dependency property. (Inherited from DiagramItem.)
Diagram | Gets the parent diagram. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramItem.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. This is a dependency property. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IsMouseDown | Gets a value indicating whether the mouse button is pressed over this item. This is a dependency property. (Inherited from DiagramItem.)
IsMouseOver | Gets a value indicating whether the mouse pointer is located over this item. This is a dependency property. (Inherited from DiagramItem.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline nodes. This is a dependency property. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashOffset | Gets or sets a double value that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. This is a dependency property. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
ToolTip | Gets or sets the contents of the tooltip displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of the object. (Inherited from DiagramItem.)

Inherited Protected Properties

Name | Description
Size | Gets the size of this item. (Inherited from DiagramItem.)

See Also

DiagramNode Class


MindFusion.Diagramming.DiagramNode.AllowIncomingLinks Property

DiagramNode.AllowIncomingLinks Property
[image]

Gets or sets a value indicating whether users are allowed to draw incoming links to this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowIncomingLinks { get; set; }

Visual Basic [image] Copy Code

Public Property AllowIncomingLinks As Boolean

Property Value

true to let users draw incoming links to this node; otherwise, false. The default is true.

Remarks

Links to a node can be created programmatically regardless of the value of this property.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
IncomingLinks Property
AllowOutgoingLinks Property


MindFusion.Diagramming.DiagramNode.AllowOutgoingLinks Property

DiagramNode.AllowOutgoingLinks Property
[image]

Gets or sets a value indicating whether users are allowed to draw outgoing links from this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowOutgoingLinks { get; set; }

Visual Basic [image] Copy Code

Public Property AllowOutgoingLinks As Boolean

Property Value

true to let users draw outgoing links from this node; otherwise, false. The default is true.

Remarks

Links from a node can be created programmatically regardless of the value of this property.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
OutgoingLinks Property
AllowIncomingLinks Property


MindFusion.Diagramming.DiagramNode.AnchorPattern Property

DiagramNode.AnchorPattern Property
[image]

Gets or sets the anchor points to which links are attached when connected to the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern AnchorPattern { get; set; }

Visual Basic [image] Copy Code

Public Property AnchorPattern As AnchorPattern

Property Value

An instance of the AnchorPattern class.

Remarks

This property specifies a set of points to which links can be attached.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
ValidateAnchorPoint Event


MindFusion.Diagramming.DiagramNode.AttachedNodes Property

DiagramNode.AttachedNodes Property
[image]

Returns the nodes attached to this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IEnumerable<DiagramNode> AttachedNodes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AttachedNodes As IEnumerable(Of DiagramNode)

Property Value

A collection of nodes attached to this node via the Attach or AttachTo methods.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
MasterNode Property


MindFusion.Diagramming.DiagramNode.Bounds Property

DiagramNode.Bounds Property
[image]

Gets or sets the rectangle that defines the position of the diagram node. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect Bounds { get; set; }

Visual Basic [image] Copy Code

Public Property Bounds As Rect

Property Value

An instance of the Windows.UI.Xaml.Rect structure.

Remarks

Use this property to set or get the size and/or location of a node. Moving a node also updates the control points coordinates of all links connected to it. To change the position of a node without affecting related items, call the SetBounds method.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Constraints Property

DiagramNode.Constraints Property
[image]

Allows applying constraints to the location and size of the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeConstraints Constraints { get; set; }

Visual Basic [image] Copy Code

Public Property Constraints As NodeConstraints

Property Value

An instance of the NodeConstraints class.

Remarks

These constraints are considered when a user modifies the node interactively. They are ignored if node placement is changed programmatically by using methods and properties.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
EnabledHandles Property


MindFusion.Diagramming.DiagramNode.Container Property

DiagramNode.Container Property
[image]

Gets the ContainerNode that contains this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode Container { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Container As ContainerNode

Property Value

A ContainerNode instance.

Remarks

To place a node inside a container, add it to the Children collection of ContainerNode. Users can add nodes interactively if the container's AllowAddChildren property is enabled.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Effects Property

DiagramNode.Effects Property
[image]

Gets a collection with all effects applied to this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IList<NodeEffect> Effects { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Effects As IList(Of NodeEffect)

Property Value

A list of NodeEffect objects.

Remarks

The local node effects are applied after the diagram-wide node effects defined in NodeEffects. However, if the first effect in this list is null (Nothing in Visual Basic), the diagram effects are ignored.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.EnabledHandles Property

DiagramNode.EnabledHandles Property
[image]

Gets or sets the kinds of modifications that end-users are permitted to perform on the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AdjustmentHandles EnabledHandles { get; set; }

Visual Basic [image] Copy Code

Public Property EnabledHandles As AdjustmentHandles

Property Value

A combination of the AdjustmentHandles enumeration members. The default is AdjustmentHandles.All.

Remarks

Disabling some selection handles allows restricting the types of modifications that users can perform on a node. Each manipulation handle can be enabled or disabled by setting or clearing the respective flag in the combination.

For example, to make a node resizable only horizontally, set this property to a combination of the Move, ResizeMiddleLeft and ResizeMiddleRight flags. That will disable all manipulation handles, except the left and right ones, which allow horizontal resizing, and the central one allowing movement of the node.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
Constraints Property
Diagram.DisabledHandlesStyle Property


MindFusion.Diagramming.DiagramNode.Expandable Property

DiagramNode.Expandable Property
[image]

Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Expandable { get; set; }

Visual Basic [image] Copy Code

Public Property Expandable As Boolean

Property Value

true to display expand/collapse button beside the node; otherwise false.

Remarks

This property is useful mostly when nodes form a tree-like hierarchical structure.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
Diagram.NodesExpandable Property
Diagram.ExpandButtonTemplate Property


MindFusion.Diagramming.DiagramNode.Expanded Property

DiagramNode.Expanded Property
[image]

Gets or sets a value indicating whether the subtree starting from this node is expanded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool Expanded { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Expanded As Boolean

Property Value

Remarks

This property is useful mostly when nodes form a tree-like hierarchical structure.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.IncomingLinks Property

DiagramNode.IncomingLinks Property
[image]

Gets a collection of links that point to the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection IncomingLinks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IncomingLinks As DiagramLinkCollection

Property Value

A reference to a DiagramLinkCollection object.

Remarks

Use this collection to get access to every link pointing to the node, as well as get the number of such links. If the node is a TableNode, links that connect to it as a whole entity are included in the collection, while links that connect to particular row of the table are included in that row's IncomingLinks collection.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
OutgoingLinks Property
AllowIncomingLinks Property


MindFusion.Diagramming.DiagramNode.MasterNode Property

DiagramNode.MasterNode Property
[image]

Gets the node to which this node is attached. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode MasterNode { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MasterNode As DiagramNode

Property Value

A DiagramNode reference specifying the node to which this node has been previously attached via the Attach or AttachTo method.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
AttachedNodes Property


MindFusion.Diagramming.DiagramNode.Obstacle Property

DiagramNode.Obstacle Property
[image]

Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Obstacle { get; set; }

Visual Basic [image] Copy Code

Public Property Obstacle As Boolean

Property Value

true makes routed links look for a path going around this node; false lets links cross the node. The default is true.

Remarks

It is useful to set this property to false for background nodes used as decorative containers or labels.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
DiagramLink.AutoRoute Property
Diagram.RouteAllLinks Method


MindFusion.Diagramming.DiagramNode.OutgoingLinks Property

DiagramNode.OutgoingLinks Property
[image]

Gets a collection of links that start from this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection OutgoingLinks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OutgoingLinks As DiagramLinkCollection

Property Value

A reference to a DiagramLinkCollection object.

Remarks

Use this collection to get access to every link starting from the node, as well as get the number of such links. If the node is a TableNode, links that connect to it as a whole entity are included in the collection, while links that connect to particular row of the table are included in that row's OutgoingLinks collection.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
AllowOutgoingLinks Property
IncomingLinks Property


MindFusion.Diagramming.DiagramNode.RotationAngle Property

DiagramNode.RotationAngle Property
[image]

Gets or sets the angle at which this node is rotated. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double RotationAngle { get; set; }

Visual Basic [image] Copy Code

Public Property RotationAngle As Double

Property Value

A double value specifying the rotation angle. The default is 0.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.ShapeOpacity Property

DiagramNode.ShapeOpacity Property
[image]

Gets or sets the shape opacity of this node. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ShapeOpacity { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeOpacity As Double

Property Value

A double value specifying the shape opacity. The default value is 1.

Remarks

For internal use only.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNodeCollection Class

DiagramNodeCollection Class
[image]

Represents a strongly typed collection of diagram nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramNodeCollection : ItemCollectionBase<DiagramNode>

Visual Basic [image] Copy Code

Public Class DiagramNodeCollection
Inherits ItemCollectionBase(Of DiagramNode)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.CollectionBase(DiagramNode, DiagramItem)
MindFusion.Diagramming.ItemCollectionBase(DiagramNode)
MindFusion.Diagramming.DiagramNodeCollection

See Also

DiagramNodeCollection Members


MindFusion.Diagramming.DiagramNodeCollection Members

DiagramNodeCollection Members
Constructors Fields Properties Methods
[image]

Represents a strongly typed collection of diagram nodes.

The following tables list the members exposed by the DiagramNodeCollection type.

Public Constructors

Name | Description
DiagramNodeCollection | Initializes a new instance of the DiagramNodeCollection class.

Inherited Protected Fields

Name | Description
itemEventArgs | An ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector. (Inherited from CollectionBase.)
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items. (Inherited from CollectionBase.)

Inherited Public Properties

Name | Description
Count | Gets the number of items contained in the collection. (Inherited from CollectionBase.)
IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from CollectionBase.)
Item | An indexer that lets you access the element at the specified position. (Inherited from CollectionBase.)

Inherited Public Methods

Name | Description
Add | Adds an item to the collection. (Inherited from CollectionBase.)
Clear | Removes all items from the collection. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the List(T). (Inherited from CollectionBase.)
CopyTo | (Inherited from CollectionBase.)
GetEnumerator | Returns an enumerator for this collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts an element into the Collection at the specified index. (Inherited from CollectionBase.)
Remove | Removes the first occurrence of a specific object from the collection. (Inherited from CollectionBase.)
RemoveAt | Removes the element at the specified index of the collection. (Inherited from CollectionBase.)

Inherited Protected Methods

Name | Description
RaiseAdding | Raises the Adding event. (Inherited from CollectionBase.)
RaiseInserting | Raises the Inserting event. (Inherited from CollectionBase.)
RaiseRemoving | Raises the Removing event. (Inherited from CollectionBase.)

See Also

DiagramNodeCollection Class


MindFusion.Diagramming.DiagramNodeCollection Constructor

DiagramNodeCollection Constructor
[image]

Initializes a new instance of the DiagramNodeCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramNodeCollection Class


MindFusion.Diagramming.DiagramNodeState Class

DiagramNodeState Class
[image]

Contains a snapshot of the internal state of a DiagramNode. Instances of this class are used to store the state of nodes for later undo or redo operations. If you derive from DiagramNode and need to implement undo support for the additional internal state defined by your class, do so by deriving from DiagramNodeState and overriding the createState, saveState and restoreState methods.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramNodeState : DiagramItemState

Visual Basic [image] Copy Code

Public Class DiagramNodeState
Inherits DiagramItemState

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemState
MindFusion.Diagramming.DiagramNodeState
MindFusion.Diagramming.ControlNodeState
MindFusion.Diagramming.ShapeNodeState
MindFusion.Diagramming.TableNodeState
MindFusion.Diagramming.TreeViewNodeState

See Also

DiagramNodeState Members


MindFusion.Diagramming.DiagramNodeState Members

DiagramNodeState Members
Constructors
[image]

Contains a snapshot of the internal state of a DiagramNode. Instances of this class are used to store the state of nodes for later undo or redo operations. If you derive from DiagramNode and need to implement undo support for the additional internal state defined by your class, do so by deriving from DiagramNodeState and overriding the createState, saveState and restoreState methods.

The following tables list the members exposed by the DiagramNodeState type.

Public Constructors

Name | Description
DiagramNodeState |

See Also

DiagramNodeState Class


MindFusion.Diagramming.DiagramNodeState Constructor

DiagramNodeState Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeState ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramNodeState Class


MindFusion.Diagramming.DiagramNodeState Properties

DiagramNodeState Properties
[image]

See Also

DiagramNodeState Class


MindFusion.Diagramming.DiagramPage Class

DiagramPage Class
[image]

Represents a single page in a DiagramDocument object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramPage : Diagram

Visual Basic [image] Copy Code

Public Class DiagramPage
Inherits Diagram

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
Windows.UI.Xaml.Controls.ContentControl
MindFusion.Diagramming.DiagramBase
MindFusion.Diagramming.Diagram
MindFusion.Diagramming.DiagramPage

See Also

DiagramPage Members


MindFusion.Diagramming.DiagramPage Members

DiagramPage Members
Constructors Fields Properties Methods Events
[image]

Represents a single page in a DiagramDocument object.

The following tables list the members exposed by the DiagramPage type.

Public Constructors

Name | Description
DiagramPage | Initializes a new instance of the DiagramPage class.

Public Fields

Name | Description
IconProperty | Identifies the Icon dependency property.
TitleBrushProperty | Identifies the TitleBrush dependency property.
TitleProperty | Identifies the Title dependency property.

Inherited Public Fields

Name | Description
AdjustmentHandlesSizeProperty | Identifies the AdjustmentHandlesSize dependency property. (Inherited from Diagram.)
AlignmentGuidePenProperty | Identifies the AlignmentGuidePen dependency property. (Inherited from Diagram.)
AllowMultipleResizeProperty | Identifies the AllowMultipleResize dependency property. (Inherited from Diagram.)
AllowUnconnectedLinksProperty | Identifies the AllowUnconnectedLinks dependency property. (Inherited from Diagram.)
AutoScrollProperty | Identifies the AutoScroll dependency property. (Inherited from Diagram.)
CanRedoProperty | Identifies the CanRedo dependency property. (Inherited from Diagram.)
CanUndoProperty | Identifies the CanUndo dependency property. (Inherited from Diagram.)
ContainerNodeStyleProperty | Identifies the ContainerNodeStyle dependency property. (Inherited from Diagram.)
DiagramLinkStyleProperty | Identifies the DiagramLinkStyle dependency property. (Inherited from Diagram.)
Dummy | A shared DummyNode instance. (Inherited from Diagram.)
EnableLanesProperty | Identifies the EnableLanes dependency property. (Inherited from Diagram.)
ExpandButtonTemplateProperty | Identifies the ExpandButtonTemplate dependancy property. (Inherited from Diagram.)
GridDashArrayProperty | Identifies the GridDashArray dependency property. (Inherited from Diagram.)
GridPointSizeProperty | Identifies the GridPointSize dependency property. (Inherited from Diagram.)
NodeEffectsSourceProperty | Identifies the NodeEffectsSource dependency property. (Inherited from Diagram.)
ShapeNodeStyleProperty | Identifies the ShapeNodeStyle dependency property. (Inherited from Diagram.)
TableNodeStyleProperty | Identifies the TableNodeStyle dependency property. (Inherited from Diagram.)
TreeViewNodeStyleProperty | Identifeis the TreeViewNodeStyle dependency property. (Inherited from Diagram.)
ZoomFactorProperty | Identifies the ZoomFactor property. (Inherited from Diagram.)

Public Properties

Name | Description
Icon | Gets or sets an image associated with the page. This is a dependency property.
Title | Gets or sets the page title. This is a dependency property.
TitleBrush | Gets or sets the brush of the title when the title is displayed. This is a dependency property.

Inherited Public Properties

Name | Description
ActiveItem | Gets or sets the active diagram element. (Inherited from Diagram.)
ActiveItemHandlesStyle | Gets or sets the visual style of adjustment handles of the active item. (Inherited from Diagram.)
ActiveLayer | Gets or sets the zero-based index of the active layer. (Inherited from Diagram.)
AdjustmentHandlesSize | Gets or sets the size of the handles, which appear around selected objects. This is a dependency property. (Inherited from Diagram.)
AlignmentGuidePen | Gets or sets the pen used to draw alignment guides. This is a dependency property. (Inherited from Diagram.)
AlignToGrid | Gets or sets a value indicating whether the diagram items should be aligned to a grid. (Inherited from Diagram.)
AllowInplaceEdit | Gets or sets a value indicating whether in-place editing of the text of objects is enabled. (Inherited from Diagram.)
AllowMultipleResize | Specifies whether multiple selected nodes can be resized simultaneously. This is a dependency property. (Inherited from Diagram.)
AllowUnconnectedLinks | Gets or sets a value indicating whether users are allowed to draw links that are not connected to any node. This is a dependency property. (Inherited from Diagram.)
AutoAlignDistance | Gets or sets the maximal horizontal or vertical distance at which a node aligns to the borders ot other nodes. (Inherited from Diagram.)
AutoAlignNodes | Gets or sets whether nodes should automatically align to the borders ot other nodes during user interaction. (Inherited from Diagram.)
AutoResize | Gets or sets a value indicating whether the document area should be resized automatically so it fits the diagram contents. (Inherited from Diagram.)
AutoScroll | Gets or sets a value indicating whether auto scrolling of the document area is enabled. This is a dependency property. (Inherited from Diagram.)
AutoSnapDistance | Specifies the maximum distance at which links auto-snap to nodes. (Inherited from Diagram.)
AutoSnapLinks | Specifies whether link end points should automatically snap to the nearest diagram node. (Inherited from Diagram.)
BackBrush | Gets or sets the brush used for painting the diagram background. (Inherited from Diagram.)
Behavior | Gets or sets a value indicating how the control responds to user actions. (Inherited from Diagram.)
Bounds | Gets or sets a value representing the size of the diagram's scrollable area. (Inherited from Diagram.)
CanRedo | Gets or sets a value indicating whether there is a command in the redo history which can be redone. (Inherited from Diagram.)
CanUndo | Gets or sets a value indicating whether there is a command in the undo history which can be undone. (Inherited from Diagram.)
ContainerNodeStyle | Gets or sets the theme-level style for container nodes. This is a dependency property. (Inherited from Diagram.)
ContainersFoldable | Gets or sets the default value for the Foldable property of containers. (Inherited from Diagram.)
CrossingRadius | Gets or sets the radius length of decorations displayed at link intersection points. (Inherited from Diagram.)
CustomBehavior | Gets or sets a custom behavior object specifying how DiagramRT responds to mouse input. (Inherited from Diagram.)
DefaultControlType | Gets or sets the type of the controls that will be hosted by default in newly create ControlNode objects. (Inherited from Diagram.)
DefaultShape | Gets or sets the default shape of shape nodes. (Inherited from Diagram.)
DelKeyAction | Gets or sets a value that specifies what action should be performed when the user hits the Del key. (Inherited from Diagram.)
DiagramLinkStyle | Gets or sets the theme-level style for diagram links. This is a dependency property. (Inherited from Diagram.)
DisabledHandlesStyle | Gets or sets the visual style of disabled adjustment handles. (Inherited from Diagram.)
DocumentPlane | DocumentPlane is visual child of diagram and ancestor of all diagram items. The DocumentPlane element is translated with respect to Diagram element so that the point Diagram.Bounds.TopLeft from the DocumentPlane is rendered at Diagram element location (0,0). The coordinate system of the DocumentPlane is the document coordinate system. The intended use of this property is mainly in MouseMove event handling (Inherited from Diagram.)
DynamicLinks | Gets or sets the default value for the Dynamic property of new links. (Inherited from Diagram.)
Enabled | Enables or disables handling of mouse events. (Inherited from Diagram.)
EnableLanes | Gets or sets whether lanes are enabled. This is a dependency property. (Inherited from Diagram.)
ExpandButtonAction | Gets or sets a value indicating what should happen when a user clicks the [+/-] button that is displayed near expandable nodes. (Inherited from Diagram.)
ExpandButtonBrush | Gets or sets the brush used to fill expand/collapse buttons of nodes. (Inherited from Diagram.)
ExpandButtonPosition | Gets or sets where expand/collapse buttons are located relatively to their nodes. (Inherited from Diagram.)
ExpandButtonTemplate | Gets or sets a custom ControlTemplate for the ExpandButton class. (Inherited from Diagram.)
ExpandOnIncoming | Gets or sets a value, indicating in which direction object hierarchies are expanded. (Inherited from Diagram.)
Factory | Gets a Factory instance that lets you add programmatically new items to the diagram. (Inherited from Diagram.)
GridColor | Gets or sets the color of the grid points. (Inherited from Diagram.)
GridDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to draw grid lines. This is a dependency property. (Inherited from Diagram.)
GridOffsetX | Gets or sets the horizontal offset of the first point of the alignment grid. (Inherited from Diagram.)
GridOffsetY | Gets or sets the vertical offset of the first point of the alignment grid. (Inherited from Diagram.)
GridPointSize | Gets or sets the size of shapes used to represent grid points. This is a dependency property. (Inherited from Diagram.)
GridSizeX | Gets or sets the horizontal distance between adjacent grid points. (Inherited from Diagram.)
GridSizeY | Gets or sets the vertical distance between adjacent grid points. (Inherited from Diagram.)
GridStyle | Gets or sets the visual style of the alignment grid. (Inherited from Diagram.)
HitTestPriority | Gets or sets a value indicating the order in which items are hit-tested. (Inherited from Diagram.)
InplaceEditAcceptOnEnter | Gets or sets a value indicating whether pressing the ENTER key should exit in-place editing mode and accept changes made to text. (Inherited from Diagram.)
InplaceEditCancelOnEsc | Gets or sets a value indicating whether pressing the ESC key should exit inplace-edit mode and reject changes made to text. (Inherited from Diagram.)
Interaction | Gets an InteractionState instance representing the current action being carried out by the user. (Inherited from Diagram.)
Items | Represents a strongly typed collection of DiagramItem objects. (Inherited from Diagram.)
LaneGrid | Gets the Grid instance that represents the lane grid. (Inherited from Diagram.)
Layers | Gets a list of the layers in the current diagram. (Inherited from Diagram.)
LicenseKey | Gets or sets the license key of the control. (Inherited from Diagram.)
LinkBaseShape | Gets or sets the shape displayed at the base of new links. (Inherited from Diagram.)
LinkBaseShapeSize | Gets or sets the default size of the base of new links. (Inherited from Diagram.)
LinkBrush | Gets or sets the default value for the Brush property of links. (Inherited from Diagram.)
LinkCrossings | Gets or sets how to render the intersection points where links cross their paths. (Inherited from Diagram.)
LinkHeadShape | Gets or sets the shape displayed as head of new links. (Inherited from Diagram.)
LinkHeadShapeSize | Gets or sets the default size of arrowheads. (Inherited from Diagram.)
LinkIntermediateShape | Gets or sets default shape to be displayed in the middle of each segment of links. (Inherited from Diagram.)
LinkIntermediateShapeSize | Gets or sets the default size of the shapes at middles of link segments. (Inherited from Diagram.)
LinkPen | Gets or sets the default value for the Pen property of links. (Inherited from Diagram.)
LinkRouter | Gets or sets the component used to find paths for auto-routed links when diagram nodes are added or their positions change. (Inherited from Diagram.)
Links | Gets a DiagramLinkCollection containing the links. (Inherited from Diagram.)
LinkSegments | Gets or sets the default number of link segments. (Inherited from Diagram.)
LinkShape | Gets or sets the default style of diagram links. (Inherited from Diagram.)
MeasureUnit | Gets or sets the unit of measure used for logical coordinates in this diagram. (Inherited from Diagram.)
ModificationStart | Gets or sets how users can start modifying diagram items. (Inherited from Diagram.)
NodeEffects | Gets a collection with all effects applied to the nodes of this diagram. (Inherited from Diagram.)
Nodes | Gets a DiagramNodeCollection containing the nodes. (Inherited from Diagram.)
NodesExpandable | Gets or sets a value indicating whether newly created nodes can be expanded. (Inherited from Diagram.)
OverrideCursor | Sets the cursor and stops changing it depending on the context. (Inherited from Diagram.)
PrintOptions | Gets an object which provides customization properties for printed diagrams. (Inherited from Diagram.)
RecursiveExpand | Gets or sets value indicating how a tree is expanded. (Inherited from Diagram.)
RoundedLinks | Gets or sets a value indicating whether the joins between segments of Polyline and Cascading links should be rounded. (Inherited from Diagram.)
RoundedLinksRadius | Gets or sets the radius of arc joins of rounded links' segments. (Inherited from Diagram.)
RouteLinks | Gets or sets a value indicating whether links should avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes. (Inherited from Diagram.)
RoutingOptions | Gets an object, which allows customizing various parameters of the link routing algorithm. (Inherited from Diagram.)
ScrollX | Gets or sets the document's X scroll position. (Inherited from Diagram.)
ScrollY | Gets or sets the document's Y scroll position. (Inherited from Diagram.)
ScrollZoneSize | Gets or sets the size of the auto scroll zone near the edges of the control. (Inherited from Diagram.)
SelectedItemHandlesStyle | Gets or sets the visual style of adjustment handles of selected items. (Inherited from Diagram.)
Selection | Gets the Selection instance that represents the selection of items in this diagram. (Inherited from Diagram.)
ShapeBrush | Gets or sets the default value for the Brush property of shape nodes. (Inherited from Diagram.)
ShapeHandlesStyle | Gets or sets the default value for the HandlesStyle property of new shape nodes. (Inherited from Diagram.)
ShapeNodeStyle | Gets or sets the theme-level style for shape nodes. This is a dependency property. (Inherited from Diagram.)
ShapePen | Gets or sets the default value for the Pen property of new ShapeNode objects. (Inherited from Diagram.)
ShowAnchors | Gets or sets a value indicating whether and when node anchor points should be displayed. (Inherited from Diagram.)
ShowGrid | Gets or sets a value indicating whether the alignment grid is visible. (Inherited from Diagram.)
TableBrush | Gets or sets the default value for the Brush property of tables. (Inherited from Diagram.)
TableCaption | Gets or sets the default text for tables' captions. (Inherited from Diagram.)
TableCaptionHeight | Gets or sets the default height of table captions. (Inherited from Diagram.)
TableColumnCount | Gets or sets the default number of table columns. (Inherited from Diagram.)
TableColumnWidth | Gets or sets the default width of tables' columns. (Inherited from Diagram.)
TableNodeStyle | Gets or sets the theme-level style for table nodes. This is a dependency property. (Inherited from Diagram.)
TableRowCount | Gets or sets the default number of table rows. (Inherited from Diagram.)
TableRowHeight | Gets or sets the default height of tables' rows. (Inherited from Diagram.)
Theme | Gets or sets the theme associated with the diagram. (Inherited from Diagram.)
TreeViewNodeStyle | Gets or sets the theme-level style for treeview nodes. This is a dependency property. (Inherited from Diagram.)
UndoEnabled | Gets or sets a value indicating whether saving action records for later undo is enabled. (Inherited from Diagram.)
Viewport | Returns the visible portion of the diagram area. (Inherited from Diagram.)
ZoomFactor | Gets or sets the zoom factor used to scale up or down the Diagram. (Inherited from Diagram.)

Inherited Public Methods

Name | Description
AlignPointToGrid | Returns a point of the alignment grid nearest to the one passed as an argument. (Inherited from Diagram.)
ArrangeLinkLabels | Rearranges link labels whose AutoArrange property is enabled. (Inherited from Diagram.)
BeginEdit | Overloaded. (Inherited from Diagram.)
CancelCompositeOperation | Stops recording undo/redo commands into a CompositeCommand and discards the records created so far. (Inherited from Diagram.)
CancelDrag | Cancels the current drag operation. (Inherited from Diagram.)
ChangeUnit | Sets new MeasureUnit value and scales the coordinates of diagram items so that their absolute size remains unchanged. (Inherited from Diagram.)
ClearAll | Removes all items from the diagram. (Inherited from Diagram.)
CommitCompositeOperation | Stops recording undo/redo commands into a CompositeCommand and saves the composite in the history queue. (Inherited from Diagram.)
CopySelection | Creates a copy of the currently selected objects and groups. (Inherited from Diagram.)
CreateThemeFromDefaults | Creates a Theme object representing the default properties of the diagram. (Inherited from Diagram.)
EndDelayUpdate | Continue updating the visual state of items. (Inherited from Diagram.)
EndEdit | Exits the in-place editing mode and either accepts or rejects the changes made to the item's text. (Inherited from Diagram.)
ExecuteCommand | Executes the specified command on this diagram. (Inherited from Diagram.)
FindLinkById | Finds the link that has the specified id value. (Inherited from Diagram.)
FindNodeById | Finds the node that has the specified id value. (Inherited from Diagram.)
GetContentBounds | Returns the smallest rectangle that bounds all diagram objects. (Inherited from Diagram.)
GetItemAt | Overloaded. (Inherited from Diagram.)
GetLinkAt | Overloaded. Finds and returns the top-most link that lies at the specified location. (Inherited from Diagram.)
GetNearestNode | Returns the node nearest to the specified point. (Inherited from Diagram.)
GetNodeAt | Overloaded. (Inherited from Diagram.)
GetNodesInViewport | Returns all nodes visible in the current viewport. (Inherited from Diagram.)
HitTestManipulators | Tests whether the specified point is within the manipulator of a diagram object and triggers the manipulator. (Inherited from Diagram.)
Invalidate | Causes the entire visible diagram area to be repainted. (Inherited from Diagram.)
IsItemInteractive | Checks if the specified item can be modified interactively. (Inherited from Diagram.)
IsItemLocked | Checks if the specified item is locked. (Inherited from Diagram.)
IsItemVisible | Checks if the specified item is currently visible. (Inherited from Diagram.)
LoadFromString | Decodes diagram contents from a string that was created with SaveToString. (Inherited from Diagram.)
LoadFromXml | Overloaded. (Inherited from Diagram.)
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from Diagram.)
PasteSelection | Adds the specified items and groups to this diagram. (Inherited from Diagram.)
RaiseClicked | Raises the Clicked event. (Inherited from Diagram.)
RaiseClicked | Raises the appropriate *Clicked event according to the type of the specified item. (Inherited from Diagram.)
RaiseCreated | Raises the appropriate *Created event according to the type of the specified item. (Inherited from Diagram.)
RaiseDeleting | Raises the LinkDeleting or NodeDeleting event according to the type of the specified item. (Inherited from Diagram.)
RaiseDoubleClicked | Overloaded. (Inherited from Diagram.)
RaiseLinkTextEdited | Raises the LinkTextEdited event. (Inherited from Diagram.)
RaiseNodeTextEdited | Raises the NodeTextEdited event. (Inherited from Diagram.)
RaisePasted | Raises the appropriate Pasted event. (Inherited from Diagram.)
Redo | Executes again an action saved in the command history. (Inherited from Diagram.)
RegisterClass | Registers a class for serialization support. (Inherited from Diagram.)
RegisterItemClass | Registers a diagram item class for serialization support. (Inherited from Diagram.)
ResizeToFitItem | Resizes the document extents so that the specified item is contained within. (Inherited from Diagram.)
ResizeToFitItems | Overloaded. Resizes the document scrollable area so it fits all diagram items. (Inherited from Diagram.)
RouteAllLinks | Routes all links in the diagram in a way they do not cross nodes. (Inherited from Diagram.)
SaveToString | Returns a serialized form of the diagram as string (Inherited from Diagram.)
SaveToXml | Overloaded. (Inherited from Diagram.)
SetScrollerParent | Binds the lane-grid header positions to the offset of a ScrollViewer's scrollbars. (Inherited from Diagram.)
SetZoomFactor | Sets the zoom factor, preserving the on-screen position of the specified diagram point. (Inherited from Diagram.)
StartCompositeOperation | Starts recording undo/redo commands into a CompositeCommand. (Inherited from Diagram.)
StartDelayUpdate | Stops updating the visual state of items. (Inherited from Diagram.)
StartInteraction | Overloaded. (Inherited from Diagram.)
Undo | Undoes an action saved in the command history. (Inherited from Diagram.)
UpdateRuntimeIndices | For internal use. (Inherited from Diagram.)
UpdateVisualZIndices | For internal use. (Inherited from Diagram.)
ZoomToRect | Zooms and scrolls the view to fit the specified document rectangle in the Diagram's visible area. (Inherited from Diagram.)

Inherited Protected Methods

Name | Description
ArrangeOverride | FrameworkElement.ArrangeOverride override. (Inherited from Diagram.)
OnActionRedone | Raises the ActionRedone event. (Inherited from DiagramBase.)
OnActionUndone | Raises the ActionUndone event. (Inherited from DiagramBase.)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramBase.)
OnCellClicked | Raises the CellClicked event. (Inherited from DiagramBase.)
OnCellDoubleClicked | Raises the CellDoubleClicked event. (Inherited from DiagramBase.)
OnClicked | Raises the Clicked event. (Inherited from DiagramBase.)
OnContainerChildAdded | Raises the ContainerChildAdded event. (Inherited from DiagramBase.)
OnContainerChildRemoved | Raises the ContainerChildRemoved event. (Inherited from DiagramBase.)
OnContainerFolded | Raises the ContainerFolded event. (Inherited from DiagramBase.)
OnContainerUnfolded | Raises the ContainerUnfolded event. (Inherited from DiagramBase.)
OnDeserializeControl | Raises the DeserializeControl event. (Inherited from DiagramBase.)
OnDeserializeTag | Raises the DeserializeTag event. (Inherited from DiagramBase.)
OnDoubleClicked | Raises the DoubleClicked event. (Inherited from DiagramBase.)
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event. (Inherited from DiagramBase.)
OnEnterInplaceEditMode | Raises the EnterInplaceEditMode event. (Inherited from DiagramBase.)
OnExpandButtonClicked | Raises the ExpandButtonClicked event. (Inherited from DiagramBase.)
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event. (Inherited from DiagramBase.)
OnInitializeLink | Raises the InitializeLink event. (Inherited from DiagramBase.)
OnInitializeNode | Raises the InitializeNode event. (Inherited from DiagramBase.)
OnItemAdded | Raises the ItemAdded event. (Inherited from DiagramBase.)
OnItemRemoved | Raises the ItemRemoved event. (Inherited from DiagramBase.)
OnLaneGridCellCreated | Raises the LaneGridCellCreated event. (Inherited from DiagramBase.)
OnLaneGridHeaderCreated | Raises the LaneGridHeaderCreated event. (Inherited from DiagramBase.)
OnLeaveInplaceEditMode | Raises the LeaveInplaceEditMode event. (Inherited from DiagramBase.)
OnLinkActivated | Raises the LinkActivated event. (Inherited from DiagramBase.)
OnLinkClicked | Raises the LinkClicked event. (Inherited from DiagramBase.)
OnLinkCreated | Raises the LinkCreated event. (Inherited from DiagramBase.)
OnLinkCreating | Raises the LinkCreating event. (Inherited from DiagramBase.)
OnLinkDeactivated | Raises the LinkDeactivated event. (Inherited from DiagramBase.)
OnLinkDeleted | Raises the LinkDeleted event. (Inherited from DiagramBase.)
OnLinkDeleting | Raises the LinkDeleting event. (Inherited from DiagramBase.)
OnLinkDeselected | Raises the LinkDeselected event. (Inherited from DiagramBase.)
OnLinkDoubleClicked | Raises the LinkDoubleClicked event. (Inherited from DiagramBase.)
OnLinkModified | Raises the LinkModified event. (Inherited from DiagramBase.)
OnLinkModifying | Raises the LinkModifying event. (Inherited from DiagramBase.)
OnLinkPasted | Raises the LinkPasted event. (Inherited from DiagramBase.)
OnLinkRouted | Raises the LinkRouted event. (Inherited from DiagramBase.)
OnLinkSelected | Raises the LinkSelected event. (Inherited from DiagramBase.)
OnLinkTextEdited | Raises the LinkTextEdited event. (Inherited from DiagramBase.)
OnMagnifierFactorChanged | Raises the MagnifierFactorChanged event. (Inherited from DiagramBase.)
OnMeasureUnitChanged | Raises the MeasureUnitChanged event. (Inherited from DiagramBase.)
OnMouseRightButtonDown | Control.OnMouseRightButtonDown override. (Inherited from Diagram.)
OnMouseRightButtonUp | Control.OnMouseRightButtonUp override. (Inherited from Diagram.)
OnNodeActivated | Raises the NodeActivated event. (Inherited from DiagramBase.)
OnNodeClicked | Raises the NodeClicked event. (Inherited from DiagramBase.)
OnNodeCreated | Raises the NodeCreated event. (Inherited from DiagramBase.)
OnNodeCreating | Raises the NodeCreating event. (Inherited from DiagramBase.)
OnNodeDeactivated | Raises the NodeDeactivated event. (Inherited from DiagramBase.)
OnNodeDeleted | Raises the NodeDeleted event. (Inherited from DiagramBase.)
OnNodeDeleting | Raises the NodeDeleting event. (Inherited from DiagramBase.)
OnNodeDeselected | Raises the NodeDeselected event. (Inherited from DiagramBase.)
OnNodeDoubleClicked | Raises the NodeDoubleClicked event. (Inherited from DiagramBase.)
OnNodeModified | Raises the NodeModified event. (Inherited from DiagramBase.)
OnNodeModifying | Raises the NodeModifying event. (Inherited from DiagramBase.)
OnNodePasted | Raises the NodePasted event. (Inherited from DiagramBase.)
OnNodeSelected | Raises the NodeSelected event. (Inherited from DiagramBase.)
OnNodeTextEdited | Raises the NodeTextEdited event. (Inherited from DiagramBase.)
OnRepaint | Raises the Repaint event. (Inherited from DiagramBase.)
OnSelectionChanged | Raises the SelectionChanged event. (Inherited from DiagramBase.)
OnSelectionModified | Raises the SelectionModified event. (Inherited from DiagramBase.)
OnSelectionModifying | Raises the SelectionModifying event. (Inherited from DiagramBase.)
OnSerializeControl | Raises the SerializeControl event. (Inherited from DiagramBase.)
OnSerializeTag | Raises the SerializeTag event. (Inherited from DiagramBase.)
OnSetSelfLoopShape | Raises the SetSelfLoopShape event. (Inherited from DiagramBase.)
OnTreeCollapsed | Raises the TreeCollapsed event. (Inherited from DiagramBase.)
OnTreeExpanded | Raises the TreeExpanded event. (Inherited from DiagramBase.)
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event. (Inherited from DiagramBase.)
OnZoomFactorChanged | Raises the ZoomFactorChanged event. (Inherited from DiagramBase.)
RemoveItem | Removes the specified item from the diagram and creates a record in the undo/redo history. (Inherited from Diagram.)

Inherited Public Events

Name | Description
ActionRedone | Raised when an action is redone. (Inherited from DiagramBase.)
ActionUndone | Raised when an action is undone. (Inherited from DiagramBase.)
ActiveLayerChanged | Raised when the diagram's active layer has changed. (Inherited from DiagramBase.)
BoundsChanged | Raised when the Bounds property value has changed. (Inherited from DiagramBase.)
CellClicked | Raised when the user clicks a table's cell. (Inherited from DiagramBase.)
CellDoubleClicked | Raised when the user double-clicks a table's cell. (Inherited from DiagramBase.)
Clicked | Raised when the user clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area. (Inherited from DiagramBase.)
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area. (Inherited from DiagramBase.)
DeserializeControl | Lets you load the attributes of controls hosted inside ControlNodes. (Inherited from DiagramBase.)
DeserializeTag | Raised when the Tag or Id of a diagram item must be deserialized from XML format. (Inherited from DiagramBase.)
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
DrawAdjustmentHandles | Raised when item's adjustment handles must be custom drawn. (Inherited from DiagramBase.)
EnterInplaceEditMode | Raised when entering inplace-edit mode. (Inherited from DiagramBase.)
ExpandButtonClicked | Raised when the user clicks the [+/-] button of an Expandable node. (Inherited from DiagramBase.)
HitTestAdjustmentHandles | Raised when custom hit testing of item's adjustment handles must be performed. (Inherited from DiagramBase.)
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created. (Inherited from DiagramBase.)
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created. (Inherited from DiagramBase.)
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
LaneGridCellCreated | Raised when a lane grid's cell has been created to allow additional cusomtization of its presentation. (Inherited from DiagramBase.)
LaneGridHeaderCreated | Raised when a lane grid's header has been created to allow additional cusomtization of its presentation. (Inherited from DiagramBase.)
LeaveInplaceEditMode | Raised when leaving inplace-edit mode. (Inherited from DiagramBase.)
LinkActivated | Raised when a link becomes the ActiveItem. (Inherited from DiagramBase.)
LinkClicked | Raised when the user clicks a link. (Inherited from DiagramBase.)
LinkCreated | Raised when the user draws a new link. (Inherited from DiagramBase.)
LinkCreating | A validation event raised while the user is drawing a new link. (Inherited from DiagramBase.)
LinkDeactivated | Raised when a link is no longer the ActiveItem. (Inherited from DiagramBase.)
LinkDeleted | Raised when a link is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkDeselected | Raised when a link is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDoubleClicked | Raised when the user double-clicks a link. (Inherited from DiagramBase.)
LinkModified | Raised when the user moves any control point of a link. (Inherited from DiagramBase.)
LinkModifying | A validation event raised while the user is modifying a link. (Inherited from DiagramBase.)
LinkPasted | Raised when a link has been pasted from the clipboard. (Inherited from DiagramBase.)
LinkRouted | Raised when a link is routed by the auto-routing algorithm. (Inherited from DiagramBase.)
LinkSelected | Raised when a link is selected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkTextEdited | Raised when the user edits the text of a link. (Inherited from DiagramBase.)
MagnifierFactorChanged | Occurs when the magnifier factor changes. (Inherited from DiagramBase.)
MeasureUnitChanged | Raised when the MeasureUnit property value has changed. (Inherited from DiagramBase.)
NodeActivated | Raised when a node becomes the ActiveItem. (Inherited from DiagramBase.)
NodeClicked | Raised when the user clicks a node. (Inherited from DiagramBase.)
NodeCreated | Occurs when the user draws a new node. (Inherited from DiagramBase.)
NodeCreating | A validation event raised while the user is drawing a new node. (Inherited from DiagramBase.)
NodeDeactivated | Raised when a node is no longer the ActiveItem. (Inherited from DiagramBase.)
NodeDeleted | Raised when a node is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeDeselected | Raised when a node is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDoubleClicked | Raised when the user double-clicks a node. (Inherited from DiagramBase.)
NodeModified | Raised when the user moves or resizes a node. (Inherited from DiagramBase.)
NodeModifying | A validation event raised while the user is moving or resizing a node. (Inherited from DiagramBase.)
NodePasted | Raised when a node has been pasted from the clipboard. (Inherited from DiagramBase.)
NodeSelected | Raised when a node is selected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeTextEdited | Raised when the user edits the text of a node. (Inherited from DiagramBase.)
Repaint | Raised when the diagram views should be repainted. (Inherited from DiagramBase.)
SelectionChanged | Raised when an item is added to or removed from the selection. (Inherited from DiagramBase.)
SelectionModified | Raised when the user moves or resizes multiple selected items. (Inherited from DiagramBase.)
SelectionModifying | Raised while the user is moving or resizing multiple selected items, this event lets you cancel the modification. (Inherited from DiagramBase.)
SerializeControl | Lets you save the attributes of controls hosted inside ControlNodes. (Inherited from DiagramBase.)
SerializeTag | Raised when the Tag of a diagram item must be serialized into an XML document. (Inherited from DiagramBase.)
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape. (Inherited from DiagramBase.)
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node. (Inherited from DiagramBase.)
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node. (Inherited from DiagramBase.)
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point. (Inherited from DiagramBase.)
ZoomFactorChanged | Occurs when the zoom factor changes. (Inherited from DiagramBase.)

See Also

DiagramPage Class


MindFusion.Diagramming.DiagramPage Fields

DiagramPage Fields
[image]

Public Fields

Name | Description
IconProperty | Identifies the Icon dependency property.
TitleBrushProperty | Identifies the TitleBrush dependency property.
TitleProperty | Identifies the Title dependency property.

Inherited Public Fields

Name | Description
AdjustmentHandlesSizeProperty | Identifies the AdjustmentHandlesSize dependency property. (Inherited from Diagram.)
AlignmentGuidePenProperty | Identifies the AlignmentGuidePen dependency property. (Inherited from Diagram.)
AllowMultipleResizeProperty | Identifies the AllowMultipleResize dependency property. (Inherited from Diagram.)
AllowUnconnectedLinksProperty | Identifies the AllowUnconnectedLinks dependency property. (Inherited from Diagram.)
AutoScrollProperty | Identifies the AutoScroll dependency property. (Inherited from Diagram.)
CanRedoProperty | Identifies the CanRedo dependency property. (Inherited from Diagram.)
CanUndoProperty | Identifies the CanUndo dependency property. (Inherited from Diagram.)
ContainerNodeStyleProperty | Identifies the ContainerNodeStyle dependency property. (Inherited from Diagram.)
DiagramLinkStyleProperty | Identifies the DiagramLinkStyle dependency property. (Inherited from Diagram.)
Dummy | A shared DummyNode instance. (Inherited from Diagram.)
EnableLanesProperty | Identifies the EnableLanes dependency property. (Inherited from Diagram.)
ExpandButtonTemplateProperty | Identifies the ExpandButtonTemplate dependancy property. (Inherited from Diagram.)
GridDashArrayProperty | Identifies the GridDashArray dependency property. (Inherited from Diagram.)
GridPointSizeProperty | Identifies the GridPointSize dependency property. (Inherited from Diagram.)
NodeEffectsSourceProperty | Identifies the NodeEffectsSource dependency property. (Inherited from Diagram.)
ShapeNodeStyleProperty | Identifies the ShapeNodeStyle dependency property. (Inherited from Diagram.)
TableNodeStyleProperty | Identifies the TableNodeStyle dependency property. (Inherited from Diagram.)
TreeViewNodeStyleProperty | Identifeis the TreeViewNodeStyle dependency property. (Inherited from Diagram.)
ZoomFactorProperty | Identifies the ZoomFactor property. (Inherited from Diagram.)

See Also

DiagramPage Class


MindFusion.Diagramming.DiagramPage.IconProperty Field

DiagramPage.IconProperty Field
[image]

Identifies the Icon dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IconProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IconProperty As DependencyProperty

See Also

DiagramPage Members
DiagramPage Class


MindFusion.Diagramming.DiagramPage.TitleBrushProperty Field

DiagramPage.TitleBrushProperty Field
[image]

Identifies the TitleBrush dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleBrushProperty As DependencyProperty

See Also

DiagramPage Members
DiagramPage Class


MindFusion.Diagramming.DiagramPage.TitleProperty Field

DiagramPage.TitleProperty Field
[image]

Identifies the Title dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleProperty As DependencyProperty

See Also

DiagramPage Members
DiagramPage Class


MindFusion.Diagramming.DiagramPage Constructor

DiagramPage Constructor
[image]

Initializes a new instance of the DiagramPage class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramPage ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramPage Class


MindFusion.Diagramming.DiagramPage Properties

DiagramPage Properties
[image]

Public Properties

Name | Description
Icon | Gets or sets an image associated with the page. This is a dependency property.
Title | Gets or sets the page title. This is a dependency property.
TitleBrush | Gets or sets the brush of the title when the title is displayed. This is a dependency property.

Inherited Public Properties

Name | Description
ActiveItem | Gets or sets the active diagram element. (Inherited from Diagram.)
ActiveItemHandlesStyle | Gets or sets the visual style of adjustment handles of the active item. (Inherited from Diagram.)
ActiveLayer | Gets or sets the zero-based index of the active layer. (Inherited from Diagram.)
AdjustmentHandlesSize | Gets or sets the size of the handles, which appear around selected objects. This is a dependency property. (Inherited from Diagram.)
AlignmentGuidePen | Gets or sets the pen used to draw alignment guides. This is a dependency property. (Inherited from Diagram.)
AlignToGrid | Gets or sets a value indicating whether the diagram items should be aligned to a grid. (Inherited from Diagram.)
AllowInplaceEdit | Gets or sets a value indicating whether in-place editing of the text of objects is enabled. (Inherited from Diagram.)
AllowMultipleResize | Specifies whether multiple selected nodes can be resized simultaneously. This is a dependency property. (Inherited from Diagram.)
AllowUnconnectedLinks | Gets or sets a value indicating whether users are allowed to draw links that are not connected to any node. This is a dependency property. (Inherited from Diagram.)
AutoAlignDistance | Gets or sets the maximal horizontal or vertical distance at which a node aligns to the borders ot other nodes. (Inherited from Diagram.)
AutoAlignNodes | Gets or sets whether nodes should automatically align to the borders ot other nodes during user interaction. (Inherited from Diagram.)
AutoResize | Gets or sets a value indicating whether the document area should be resized automatically so it fits the diagram contents. (Inherited from Diagram.)
AutoScroll | Gets or sets a value indicating whether auto scrolling of the document area is enabled. This is a dependency property. (Inherited from Diagram.)
AutoSnapDistance | Specifies the maximum distance at which links auto-snap to nodes. (Inherited from Diagram.)
AutoSnapLinks | Specifies whether link end points should automatically snap to the nearest diagram node. (Inherited from Diagram.)
BackBrush | Gets or sets the brush used for painting the diagram background. (Inherited from Diagram.)
Behavior | Gets or sets a value indicating how the control responds to user actions. (Inherited from Diagram.)
Bounds | Gets or sets a value representing the size of the diagram's scrollable area. (Inherited from Diagram.)
CanRedo | Gets or sets a value indicating whether there is a command in the redo history which can be redone. (Inherited from Diagram.)
CanUndo | Gets or sets a value indicating whether there is a command in the undo history which can be undone. (Inherited from Diagram.)
ContainerNodeStyle | Gets or sets the theme-level style for container nodes. This is a dependency property. (Inherited from Diagram.)
ContainersFoldable | Gets or sets the default value for the Foldable property of containers. (Inherited from Diagram.)
CrossingRadius | Gets or sets the radius length of decorations displayed at link intersection points. (Inherited from Diagram.)
CustomBehavior | Gets or sets a custom behavior object specifying how DiagramRT responds to mouse input. (Inherited from Diagram.)
DefaultControlType | Gets or sets the type of the controls that will be hosted by default in newly create ControlNode objects. (Inherited from Diagram.)
DefaultShape | Gets or sets the default shape of shape nodes. (Inherited from Diagram.)
DelKeyAction | Gets or sets a value that specifies what action should be performed when the user hits the Del key. (Inherited from Diagram.)
DiagramLinkStyle | Gets or sets the theme-level style for diagram links. This is a dependency property. (Inherited from Diagram.)
DisabledHandlesStyle | Gets or sets the visual style of disabled adjustment handles. (Inherited from Diagram.)
DocumentPlane | DocumentPlane is visual child of diagram and ancestor of all diagram items. The DocumentPlane element is translated with respect to Diagram element so that the point Diagram.Bounds.TopLeft from the DocumentPlane is rendered at Diagram element location (0,0). The coordinate system of the DocumentPlane is the document coordinate system. The intended use of this property is mainly in MouseMove event handling (Inherited from Diagram.)
DynamicLinks | Gets or sets the default value for the Dynamic property of new links. (Inherited from Diagram.)
Enabled | Enables or disables handling of mouse events. (Inherited from Diagram.)
EnableLanes | Gets or sets whether lanes are enabled. This is a dependency property. (Inherited from Diagram.)
ExpandButtonAction | Gets or sets a value indicating what should happen when a user clicks the [+/-] button that is displayed near expandable nodes. (Inherited from Diagram.)
ExpandButtonBrush | Gets or sets the brush used to fill expand/collapse buttons of nodes. (Inherited from Diagram.)
ExpandButtonPosition | Gets or sets where expand/collapse buttons are located relatively to their nodes. (Inherited from Diagram.)
ExpandButtonTemplate | Gets or sets a custom ControlTemplate for the ExpandButton class. (Inherited from Diagram.)
ExpandOnIncoming | Gets or sets a value, indicating in which direction object hierarchies are expanded. (Inherited from Diagram.)
Factory | Gets a Factory instance that lets you add programmatically new items to the diagram. (Inherited from Diagram.)
GridColor | Gets or sets the color of the grid points. (Inherited from Diagram.)
GridDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to draw grid lines. This is a dependency property. (Inherited from Diagram.)
GridOffsetX | Gets or sets the horizontal offset of the first point of the alignment grid. (Inherited from Diagram.)
GridOffsetY | Gets or sets the vertical offset of the first point of the alignment grid. (Inherited from Diagram.)
GridPointSize | Gets or sets the size of shapes used to represent grid points. This is a dependency property. (Inherited from Diagram.)
GridSizeX | Gets or sets the horizontal distance between adjacent grid points. (Inherited from Diagram.)
GridSizeY | Gets or sets the vertical distance between adjacent grid points. (Inherited from Diagram.)
GridStyle | Gets or sets the visual style of the alignment grid. (Inherited from Diagram.)
HitTestPriority | Gets or sets a value indicating the order in which items are hit-tested. (Inherited from Diagram.)
InplaceEditAcceptOnEnter | Gets or sets a value indicating whether pressing the ENTER key should exit in-place editing mode and accept changes made to text. (Inherited from Diagram.)
InplaceEditCancelOnEsc | Gets or sets a value indicating whether pressing the ESC key should exit inplace-edit mode and reject changes made to text. (Inherited from Diagram.)
Interaction | Gets an InteractionState instance representing the current action being carried out by the user. (Inherited from Diagram.)
Items | Represents a strongly typed collection of DiagramItem objects. (Inherited from Diagram.)
LaneGrid | Gets the Grid instance that represents the lane grid. (Inherited from Diagram.)
Layers | Gets a list of the layers in the current diagram. (Inherited from Diagram.)
LicenseKey | Gets or sets the license key of the control. (Inherited from Diagram.)
LinkBaseShape | Gets or sets the shape displayed at the base of new links. (Inherited from Diagram.)
LinkBaseShapeSize | Gets or sets the default size of the base of new links. (Inherited from Diagram.)
LinkBrush | Gets or sets the default value for the Brush property of links. (Inherited from Diagram.)
LinkCrossings | Gets or sets how to render the intersection points where links cross their paths. (Inherited from Diagram.)
LinkHeadShape | Gets or sets the shape displayed as head of new links. (Inherited from Diagram.)
LinkHeadShapeSize | Gets or sets the default size of arrowheads. (Inherited from Diagram.)
LinkIntermediateShape | Gets or sets default shape to be displayed in the middle of each segment of links. (Inherited from Diagram.)
LinkIntermediateShapeSize | Gets or sets the default size of the shapes at middles of link segments. (Inherited from Diagram.)
LinkPen | Gets or sets the default value for the Pen property of links. (Inherited from Diagram.)
LinkRouter | Gets or sets the component used to find paths for auto-routed links when diagram nodes are added or their positions change. (Inherited from Diagram.)
Links | Gets a DiagramLinkCollection containing the links. (Inherited from Diagram.)
LinkSegments | Gets or sets the default number of link segments. (Inherited from Diagram.)
LinkShape | Gets or sets the default style of diagram links. (Inherited from Diagram.)
MeasureUnit | Gets or sets the unit of measure used for logical coordinates in this diagram. (Inherited from Diagram.)
ModificationStart | Gets or sets how users can start modifying diagram items. (Inherited from Diagram.)
NodeEffects | Gets a collection with all effects applied to the nodes of this diagram. (Inherited from Diagram.)
Nodes | Gets a DiagramNodeCollection containing the nodes. (Inherited from Diagram.)
NodesExpandable | Gets or sets a value indicating whether newly created nodes can be expanded. (Inherited from Diagram.)
OverrideCursor | Sets the cursor and stops changing it depending on the context. (Inherited from Diagram.)
PrintOptions | Gets an object which provides customization properties for printed diagrams. (Inherited from Diagram.)
RecursiveExpand | Gets or sets value indicating how a tree is expanded. (Inherited from Diagram.)
RoundedLinks | Gets or sets a value indicating whether the joins between segments of Polyline and Cascading links should be rounded. (Inherited from Diagram.)
RoundedLinksRadius | Gets or sets the radius of arc joins of rounded links' segments. (Inherited from Diagram.)
RouteLinks | Gets or sets a value indicating whether links should avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes. (Inherited from Diagram.)
RoutingOptions | Gets an object, which allows customizing various parameters of the link routing algorithm. (Inherited from Diagram.)
ScrollX | Gets or sets the document's X scroll position. (Inherited from Diagram.)
ScrollY | Gets or sets the document's Y scroll position. (Inherited from Diagram.)
ScrollZoneSize | Gets or sets the size of the auto scroll zone near the edges of the control. (Inherited from Diagram.)
SelectedItemHandlesStyle | Gets or sets the visual style of adjustment handles of selected items. (Inherited from Diagram.)
Selection | Gets the Selection instance that represents the selection of items in this diagram. (Inherited from Diagram.)
ShapeBrush | Gets or sets the default value for the Brush property of shape nodes. (Inherited from Diagram.)
ShapeHandlesStyle | Gets or sets the default value for the HandlesStyle property of new shape nodes. (Inherited from Diagram.)
ShapeNodeStyle | Gets or sets the theme-level style for shape nodes. This is a dependency property. (Inherited from Diagram.)
ShapePen | Gets or sets the default value for the Pen property of new ShapeNode objects. (Inherited from Diagram.)
ShowAnchors | Gets or sets a value indicating whether and when node anchor points should be displayed. (Inherited from Diagram.)
ShowGrid | Gets or sets a value indicating whether the alignment grid is visible. (Inherited from Diagram.)
TableBrush | Gets or sets the default value for the Brush property of tables. (Inherited from Diagram.)
TableCaption | Gets or sets the default text for tables' captions. (Inherited from Diagram.)
TableCaptionHeight | Gets or sets the default height of table captions. (Inherited from Diagram.)
TableColumnCount | Gets or sets the default number of table columns. (Inherited from Diagram.)
TableColumnWidth | Gets or sets the default width of tables' columns. (Inherited from Diagram.)
TableNodeStyle | Gets or sets the theme-level style for table nodes. This is a dependency property. (Inherited from Diagram.)
TableRowCount | Gets or sets the default number of table rows. (Inherited from Diagram.)
TableRowHeight | Gets or sets the default height of tables' rows. (Inherited from Diagram.)
Theme | Gets or sets the theme associated with the diagram. (Inherited from Diagram.)
TreeViewNodeStyle | Gets or sets the theme-level style for treeview nodes. This is a dependency property. (Inherited from Diagram.)
UndoEnabled | Gets or sets a value indicating whether saving action records for later undo is enabled. (Inherited from Diagram.)
Viewport | Returns the visible portion of the diagram area. (Inherited from Diagram.)
ZoomFactor | Gets or sets the zoom factor used to scale up or down the Diagram. (Inherited from Diagram.)

See Also

DiagramPage Class


MindFusion.Diagramming.DiagramPage.Icon Property

DiagramPage.Icon Property
[image]

Gets or sets an image associated with the page. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ImageSource Icon { get; set; }

Visual Basic [image] Copy Code

Public Property Icon As ImageSource

Property Value

A WinRT ImageSource object.

See Also

DiagramPage Members
DiagramPage Class


MindFusion.Diagramming.DiagramPage.Title Property

DiagramPage.Title Property
[image]

Gets or sets the page title. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

A string value.

See Also

DiagramPage Members
DiagramPage Class


MindFusion.Diagramming.DiagramPage.TitleBrush Property

DiagramPage.TitleBrush Property
[image]

Gets or sets the brush of the title when the title is displayed. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush TitleBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TitleBrush As Brush

Property Value

An instance of a Windows.UI.Xaml.Media.Brush -derived class.

See Also

DiagramPage Members
DiagramPage Class


MindFusion.Diagramming.DiagramPageEventArgs Class

DiagramPageEventArgs Class
[image]

Contains the arguments passed to DiagramPage-related event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramPageEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DiagramPageEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.DiagramPageEventArgs
MindFusion.Diagramming.DiagramPageValidationEventArgs

See Also

DiagramPageEventArgs Members


MindFusion.Diagramming.DiagramPageEventArgs Members

DiagramPageEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to DiagramPage-related event handlers.

The following tables list the members exposed by the DiagramPageEventArgs type.

Public Constructors

Name | Description
DiagramPageEventArgs | Initializes a new instance of the DiagramPageEventArgs class.

Public Properties

Name | Description
DiagramPage | Gets the DiagramPage related to the event.

See Also

DiagramPageEventArgs Class


MindFusion.Diagramming.DiagramPageEventArgs Constructor

DiagramPageEventArgs Constructor
[image]

Initializes a new instance of the DiagramPageEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramPageEventArgs (
DiagramPage diagramPage
)

Visual Basic [image] Copy Code

Public New ( _
diagramPage As DiagramPage _
)

Parameters

diagramPage

The DiagramPage related to the event.

See Also

DiagramPageEventArgs Class


MindFusion.Diagramming.DiagramPageEventArgs Properties

DiagramPageEventArgs Properties
[image]

Public Properties

Name | Description
DiagramPage | Gets the DiagramPage related to the event.

See Also

DiagramPageEventArgs Class


MindFusion.Diagramming.DiagramPageEventArgs.DiagramPage Property

DiagramPageEventArgs.DiagramPage Property
[image]

Gets the DiagramPage related to the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramPage DiagramPage { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DiagramPage As DiagramPage

Property Value

See Also

DiagramPageEventArgs Members
DiagramPageEventArgs Class


MindFusion.Diagramming.DiagramPageValidationEventArgs Class

DiagramPageValidationEventArgs Class
[image]

Contains the arguments passed to handlers of DiagramPage validation events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramPageValidationEventArgs : DiagramPageEventArgs

Visual Basic [image] Copy Code

Public Class DiagramPageValidationEventArgs
Inherits DiagramPageEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.DiagramPageEventArgs
MindFusion.Diagramming.DiagramPageValidationEventArgs

See Also

DiagramPageValidationEventArgs Members


MindFusion.Diagramming.DiagramPageValidationEventArgs Members

DiagramPageValidationEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to handlers of DiagramPage validation events.

The following tables list the members exposed by the DiagramPageValidationEventArgs type.

Public Constructors

Name | Description
DiagramPageValidationEventArgs | Initializes a new instance of the DiagramPageValidationEventArgs class.

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to cancel the current operation.

Inherited Public Properties

Name | Description
DiagramPage | Gets the DiagramPage related to the event. (Inherited from DiagramPageEventArgs.)

See Also

DiagramPageValidationEventArgs Class


MindFusion.Diagramming.DiagramPageValidationEventArgs Constructor

DiagramPageValidationEventArgs Constructor
[image]

Initializes a new instance of the DiagramPageValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramPageValidationEventArgs (
DiagramPage diagramPage
)

Visual Basic [image] Copy Code

Public New ( _
diagramPage As DiagramPage _
)

Parameters

diagramPage

The DiagramPage related to the event.

See Also

DiagramPageValidationEventArgs Class


MindFusion.Diagramming.DiagramPageValidationEventArgs Properties

DiagramPageValidationEventArgs Properties
[image]

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to cancel the current operation.

Inherited Public Properties

Name | Description
DiagramPage | Gets the DiagramPage related to the event. (Inherited from DiagramPageEventArgs.)

See Also

DiagramPageValidationEventArgs Class


MindFusion.Diagramming.DiagramPageValidationEventArgs.Cancel Property

DiagramPageValidationEventArgs.Cancel Property
[image]

Gets or sets a value indicating whether to cancel the current operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

Remarks

Set this property to true to prevent the user from completing the operation.

See Also

DiagramPageValidationEventArgs Members
DiagramPageValidationEventArgs Class


MindFusion.Diagramming.DiagramTabControl Class

DiagramTabControl Class
[image]

Represents a TabControl that displays DiagramTabItem items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public class DiagramTabControl : ItemsControl

Visual Basic [image] Copy Code

Public Class DiagramTabControl
Inherits ItemsControl

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
Windows.UI.Xaml.Controls.ItemsControl
MindFusion.Diagramming.DiagramTabControl

See Also

DiagramTabControl Members


MindFusion.Diagramming.DiagramTabControl Members

DiagramTabControl Members
Constructors Fields Properties Methods
[image]

Represents a TabControl that displays DiagramTabItem items.

The following tables list the members exposed by the DiagramTabControl type.

Public Constructors

Name | Description
DiagramTabControl | Initializes a new instance of the DiagramTabControl class.

Public Fields

Name | Description
AllowRenamePagesProperty | Identifies the AllowRenamePages dependency property.
AllowReorderProperty | Identifies the AllowReorder dependency property.
ScrollOffsetProperty | Identifies the ScrollOffset dependency property.
ScrollStepProperty | Identifies the ScrollStep dependency property.
SelectedContentProperty | Identifies the SelectedContent dependency property.
SelectedIndexProperty | Identifies the SelectedIndex dependency property.
SelectedItemProperty | Identifies the SelectedItem dependency property.
ShowAddButtonsProperty | Identifies the ShowAddButtons dependency property.
ShowCloseButtonsProperty | Identifies the ShowCloseButtons dependency property.
ShowCreateNewTabProperty | Identifies the ShowCreateNewTab dependency property.
ShowNavigationButtonsProperty | Identifies the ShowNavigationButtons dependency property.
ShowTabsProperty | Identifies the ShowTabs dependency property.
TabAlignmentProperty | Identifies the TabAlignment dependency property.
TabLayoutModeProperty | Identifies the TabLayoutMode dependency property.
TabRotationProperty | Identifies the TabRotation dependency property.
TabStripPlacementProperty | Identifies the TabStripPlacement dependency property.

Public Properties

Name | Description
AllowRenamePages | Gets or sets a value indicating whether tabs can be renamed.
AllowReorder | Gets or sets a value indicating whether interactive reordering of tabs is allowed. This is a dependency property.
ScrollOffset | Gets or sets the scroll amount when TabLayoutMode is set to Scroll. This is a dependency property.
ScrollStep | Gets or sets the scroll step when TabLayoutMode is set to Scroll. This is a dependency property.
SelectedContent | Gets or sets the content of the currently selected item. This is a dependency property.
SelectedIndex | Gets or sets the index of the currently selected item. This is a dependency property.
SelectedItem | Gets or sets the currently selected item. This is a dependency property.
ShowAddButtons | Gets or sets a value indicating whether to display a add button for each tab. This is a dependency property.
ShowCloseButtons | Gets or sets a value indicating whether to display a close button for each tab. This is a dependency property.
ShowCreateNewTab | Gets or sets a value indicating whether to display the 'Create New Tab' button. This is a dependency property.
ShowNavigationButtons | Gets or sets a value indicating whether the tab navigation buttons. This is a dependency property.
ShowTabs | Gets or sets a value indicating whether the tabs are visible. This is a dependency property.
TabAlignment | Gets or sets the alignment of the tab headers. This is a dependency property.
TabLayoutMode | Gets or sets a value indicating how tab headers are arranged when the available space is insufficient. This is a dependency property.
TabRotation | Gets or sets the rotation of the tab headers. This is a dependency property.
TabStripPlacement | Gets or sets the alignment of the tab headers. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
GetContainerForItemOverride | ItemsControl.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | ItemsControl.IsItemItsOwnContainerOverride override.
OnPageRenamed | Raises the PageRenamed event.
OnPointerMoved | Control.OnPointerMoved override.
OnPointerPressed | Control.OnPointerPressed override.
OnPointerReleased | Control.OnPointerReleased override.
PrepareContainerForItemOverride | ItemsControl.PrepareContainerForItemOverride override.

See Also

DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl Fields

DiagramTabControl Fields
[image]

Public Fields

Name | Description
AllowRenamePagesProperty | Identifies the AllowRenamePages dependency property.
AllowReorderProperty | Identifies the AllowReorder dependency property.
ScrollOffsetProperty | Identifies the ScrollOffset dependency property.
ScrollStepProperty | Identifies the ScrollStep dependency property.
SelectedContentProperty | Identifies the SelectedContent dependency property.
SelectedIndexProperty | Identifies the SelectedIndex dependency property.
SelectedItemProperty | Identifies the SelectedItem dependency property.
ShowAddButtonsProperty | Identifies the ShowAddButtons dependency property.
ShowCloseButtonsProperty | Identifies the ShowCloseButtons dependency property.
ShowCreateNewTabProperty | Identifies the ShowCreateNewTab dependency property.
ShowNavigationButtonsProperty | Identifies the ShowNavigationButtons dependency property.
ShowTabsProperty | Identifies the ShowTabs dependency property.
TabAlignmentProperty | Identifies the TabAlignment dependency property.
TabLayoutModeProperty | Identifies the TabLayoutMode dependency property.
TabRotationProperty | Identifies the TabRotation dependency property.
TabStripPlacementProperty | Identifies the TabStripPlacement dependency property.

See Also

DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.AllowRenamePagesProperty Field

DiagramTabControl.AllowRenamePagesProperty Field
[image]

Identifies the AllowRenamePages dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowRenamePagesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowRenamePagesProperty As DependencyProperty

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.AllowReorderProperty Field

DiagramTabControl.AllowReorderProperty Field
[image]

Identifies the AllowReorder dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowReorderProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowReorderProperty As DependencyProperty

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.ScrollOffsetProperty Field

DiagramTabControl.ScrollOffsetProperty Field
[image]

Identifies the ScrollOffset dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScrollOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScrollOffsetProperty As DependencyProperty

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.ScrollStepProperty Field

DiagramTabControl.ScrollStepProperty Field
[image]

Identifies the ScrollStep dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScrollStepProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScrollStepProperty As DependencyProperty

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.SelectedContentProperty Field

DiagramTabControl.SelectedContentProperty Field
[image]

Identifies the SelectedContent dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedContentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedContentProperty As DependencyProperty

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.SelectedIndexProperty Field

DiagramTabControl.SelectedIndexProperty Field
[image]

Identifies the SelectedIndex dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedIndexProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedIndexProperty As DependencyProperty

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.SelectedItemProperty Field

DiagramTabControl.SelectedItemProperty Field
[image]

Identifies the SelectedItem dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedItemProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedItemProperty As DependencyProperty

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.ShowAddButtonsProperty Field

DiagramTabControl.ShowAddButtonsProperty Field
[image]

Identifies the ShowAddButtons dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowAddButtonsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowAddButtonsProperty As DependencyProperty

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.ShowCloseButtonsProperty Field

DiagramTabControl.ShowCloseButtonsProperty Field
[image]

Identifies the ShowCloseButtons dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowCloseButtonsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowCloseButtonsProperty As DependencyProperty

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.ShowCreateNewTabProperty Field

DiagramTabControl.ShowCreateNewTabProperty Field
[image]

Identifies the ShowCreateNewTab dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowCreateNewTabProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowCreateNewTabProperty As DependencyProperty

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.ShowNavigationButtonsProperty Field

DiagramTabControl.ShowNavigationButtonsProperty Field
[image]

Identifies the ShowNavigationButtons dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowNavigationButtonsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowNavigationButtonsProperty As DependencyProperty

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.ShowTabsProperty Field

DiagramTabControl.ShowTabsProperty Field
[image]

Identifies the ShowTabs dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowTabsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowTabsProperty As DependencyProperty

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.TabAlignmentProperty Field

DiagramTabControl.TabAlignmentProperty Field
[image]

Identifies the TabAlignment dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TabAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TabAlignmentProperty As DependencyProperty

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.TabLayoutModeProperty Field

DiagramTabControl.TabLayoutModeProperty Field
[image]

Identifies the TabLayoutMode dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TabLayoutModeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TabLayoutModeProperty As DependencyProperty

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.TabRotationProperty Field

DiagramTabControl.TabRotationProperty Field
[image]

Identifies the TabRotation dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TabRotationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TabRotationProperty As DependencyProperty

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.TabStripPlacementProperty Field

DiagramTabControl.TabStripPlacementProperty Field
[image]

Identifies the TabStripPlacement dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TabStripPlacementProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TabStripPlacementProperty As DependencyProperty

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl Constructor

DiagramTabControl Constructor
[image]

Initializes a new instance of the DiagramTabControl class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public DiagramTabControl ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl Methods

DiagramTabControl Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
GetContainerForItemOverride | ItemsControl.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | ItemsControl.IsItemItsOwnContainerOverride override.
OnPageRenamed | Raises the PageRenamed event.
OnPointerMoved | Control.OnPointerMoved override.
OnPointerPressed | Control.OnPointerPressed override.
OnPointerReleased | Control.OnPointerReleased override.
PrepareContainerForItemOverride | ItemsControl.PrepareContainerForItemOverride override.

See Also

DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.GetContainerForItemOverride Method

DiagramTabControl.GetContainerForItemOverride Method
[image]

ItemsControl.GetContainerForItemOverride override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

protected override DependencyObject GetContainerForItemOverride ()

Visual Basic [image] Copy Code

Protected Overrides Function GetContainerForItemOverride () As DependencyObject

Return Value

The element that is used to display the given item.

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.IsItemItsOwnContainerOverride Method

DiagramTabControl.IsItemItsOwnContainerOverride Method
[image]

ItemsControl.IsItemItsOwnContainerOverride override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

protected override bool IsItemItsOwnContainerOverride (
Object item
)

Visual Basic [image] Copy Code

Protected Overrides Function IsItemItsOwnContainerOverride( _
item As Object _
) As Boolean

Parameters

item

The item to check.

Return Value

true if the item is (or is eligible to be) its own container; otherwise, false.

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.OnApplyTemplate Method

DiagramTabControl.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Overrides Sub OnApplyTemplate ()

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.OnPageRenamed Method

DiagramTabControl.OnPageRenamed Method
[image]

Raises the PageRenamed event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

protected virtual void OnPageRenamed (
PageRenamedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPageRenamed( _
e As PageRenamedEventArgs _
)

Parameters

e

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.OnPointerMoved Method

DiagramTabControl.OnPointerMoved Method
[image]

Control.OnPointerMoved override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

protected override void OnPointerMoved (
PointerRoutedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPointerMoved( _
e As PointerRoutedEventArgs _
)

Parameters

e

The PointerRoutedEventArgs that contains the event data.

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.OnPointerPressed Method

DiagramTabControl.OnPointerPressed Method
[image]

Control.OnPointerPressed override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

protected override void OnPointerPressed (
PointerRoutedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPointerPressed( _
e As PointerRoutedEventArgs _
)

Parameters

e

The PointerRoutedEventArgs that contains the event data.

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.OnPointerReleased Method

DiagramTabControl.OnPointerReleased Method
[image]

Control.OnPointerReleased override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

protected override void OnPointerReleased (
PointerRoutedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPointerReleased( _
e As PointerRoutedEventArgs _
)

Parameters

e

The PointerRoutedEventArgs that contains the event data.

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.PrepareContainerForItemOverride Method

DiagramTabControl.PrepareContainerForItemOverride Method
[image]

ItemsControl.PrepareContainerForItemOverride override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

protected override void PrepareContainerForItemOverride (
DependencyObject element,
Object item
)

Visual Basic [image] Copy Code

Protected Overrides Sub PrepareContainerForItemOverride( _
element As DependencyObject, _
item As Object _
)

Parameters

element

Element used to display the specified item.

item

Specified item.

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl Properties

DiagramTabControl Properties
[image]

Public Properties

Name | Description
AllowRenamePages | Gets or sets a value indicating whether tabs can be renamed.
AllowReorder | Gets or sets a value indicating whether interactive reordering of tabs is allowed. This is a dependency property.
ScrollOffset | Gets or sets the scroll amount when TabLayoutMode is set to Scroll. This is a dependency property.
ScrollStep | Gets or sets the scroll step when TabLayoutMode is set to Scroll. This is a dependency property.
SelectedContent | Gets or sets the content of the currently selected item. This is a dependency property.
SelectedIndex | Gets or sets the index of the currently selected item. This is a dependency property.
SelectedItem | Gets or sets the currently selected item. This is a dependency property.
ShowAddButtons | Gets or sets a value indicating whether to display a add button for each tab. This is a dependency property.
ShowCloseButtons | Gets or sets a value indicating whether to display a close button for each tab. This is a dependency property.
ShowCreateNewTab | Gets or sets a value indicating whether to display the 'Create New Tab' button. This is a dependency property.
ShowNavigationButtons | Gets or sets a value indicating whether the tab navigation buttons. This is a dependency property.
ShowTabs | Gets or sets a value indicating whether the tabs are visible. This is a dependency property.
TabAlignment | Gets or sets the alignment of the tab headers. This is a dependency property.
TabLayoutMode | Gets or sets a value indicating how tab headers are arranged when the available space is insufficient. This is a dependency property.
TabRotation | Gets or sets the rotation of the tab headers. This is a dependency property.
TabStripPlacement | Gets or sets the alignment of the tab headers. This is a dependency property.

See Also

DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.AllowRenamePages Property

DiagramTabControl.AllowRenamePages Property
[image]

Gets or sets a value indicating whether tabs can be renamed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public bool AllowRenamePages { get; set; }

Visual Basic [image] Copy Code

Public Property AllowRenamePages As Boolean

Property Value

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.AllowReorder Property

DiagramTabControl.AllowReorder Property
[image]

Gets or sets a value indicating whether interactive reordering of tabs is allowed. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public bool AllowReorder { get; set; }

Visual Basic [image] Copy Code

Public Property AllowReorder As Boolean

Property Value

true to allow interactive tab reordering; otherwise, false. The default is false.

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.ScrollOffset Property

DiagramTabControl.ScrollOffset Property
[image]

Gets or sets the scroll amount when TabLayoutMode is set to Scroll. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public double ScrollOffset { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollOffset As Double

Property Value

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.ScrollStep Property

DiagramTabControl.ScrollStep Property
[image]

Gets or sets the scroll step when TabLayoutMode is set to Scroll. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public double ScrollStep { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollStep As Double

Property Value

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.SelectedContent Property

DiagramTabControl.SelectedContent Property
[image]

Gets or sets the content of the currently selected item. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public Object SelectedContent { get; set; }

Visual Basic [image] Copy Code

Public Property SelectedContent As Object

Property Value

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.SelectedIndex Property

DiagramTabControl.SelectedIndex Property
[image]

Gets or sets the index of the currently selected item. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public int SelectedIndex { get; set; }

Visual Basic [image] Copy Code

Public Property SelectedIndex As Integer

Property Value

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.SelectedItem Property

DiagramTabControl.SelectedItem Property
[image]

Gets or sets the currently selected item. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public Object SelectedItem { get; set; }

Visual Basic [image] Copy Code

Public Property SelectedItem As Object

Property Value

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.ShowAddButtons Property

DiagramTabControl.ShowAddButtons Property
[image]

Gets or sets a value indicating whether to display a add button for each tab. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public bool ShowAddButtons { get; set; }

Visual Basic [image] Copy Code

Public Property ShowAddButtons As Boolean

Property Value

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.ShowCloseButtons Property

DiagramTabControl.ShowCloseButtons Property
[image]

Gets or sets a value indicating whether to display a close button for each tab. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public bool ShowCloseButtons { get; set; }

Visual Basic [image] Copy Code

Public Property ShowCloseButtons As Boolean

Property Value

true to enable interactive tab deletion; otherwise, false. The default is true.

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.ShowCreateNewTab Property

DiagramTabControl.ShowCreateNewTab Property
[image]

Gets or sets a value indicating whether to display the 'Create New Tab' button. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public bool ShowCreateNewTab { get; set; }

Visual Basic [image] Copy Code

Public Property ShowCreateNewTab As Boolean

Property Value

true to enable interactive tab deletion; otherwise, false. The default is true.

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.ShowNavigationButtons Property

DiagramTabControl.ShowNavigationButtons Property
[image]

Gets or sets a value indicating whether the tab navigation buttons. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public bool ShowNavigationButtons { get; set; }

Visual Basic [image] Copy Code

Public Property ShowNavigationButtons As Boolean

Property Value

true to enable tab navigation; otherwise, false. The default is true.

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.ShowTabs Property

DiagramTabControl.ShowTabs Property
[image]

Gets or sets a value indicating whether the tabs are visible. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public bool ShowTabs { get; set; }

Visual Basic [image] Copy Code

Public Property ShowTabs As Boolean

Property Value

true to display the tabs tray; otherwise, false. The default is true.

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.TabAlignment Property

DiagramTabControl.TabAlignment Property
[image]

Gets or sets the alignment of the tab headers. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public TabAlignment TabAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property TabAlignment As TabAlignment

Property Value

A member of the TabAlignment enumeration. The default value is Near.

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.TabLayoutMode Property

DiagramTabControl.TabLayoutMode Property
[image]

Gets or sets a value indicating how tab headers are arranged when the available space is insufficient. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public TabLayoutMode TabLayoutMode { get; set; }

Visual Basic [image] Copy Code

Public Property TabLayoutMode As TabLayoutMode

Property Value

A member of the TabLayoutMode enumeration. The default value is Wrap.

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.TabRotation Property

DiagramTabControl.TabRotation Property
[image]

Gets or sets the rotation of the tab headers. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public TabRotation TabRotation { get; set; }

Visual Basic [image] Copy Code

Public Property TabRotation As TabRotation

Property Value

A member of the TabRotation enumeration. The default value is None.

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabControl.TabStripPlacement Property

DiagramTabControl.TabStripPlacement Property
[image]

Gets or sets the alignment of the tab headers. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public Dock TabStripPlacement { get; set; }

Visual Basic [image] Copy Code

Public Property TabStripPlacement As Dock

Property Value

A member of the Dock enumeration. The default value is Top.

See Also

DiagramTabControl Members
DiagramTabControl Class


MindFusion.Diagramming.DiagramTabItem Class

DiagramTabItem Class
[image]

Represents a tab item in a DiagramTabControl.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public class DiagramTabItem : ContentControl

Visual Basic [image] Copy Code

Public Class DiagramTabItem
Inherits ContentControl

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
Windows.UI.Xaml.Controls.ContentControl
MindFusion.Diagramming.DiagramTabItem

See Also

DiagramTabItem Members


MindFusion.Diagramming.DiagramTabItem Members

DiagramTabItem Members
Constructors Fields Properties Methods Events
[image]

Represents a tab item in a DiagramTabControl.

The following tables list the members exposed by the DiagramTabItem type.

Public Constructors

Name | Description
DiagramTabItem | Initializes a new instance of the DiagramTabItem class.

Public Fields

Name | Description
HeaderProperty | Identifies the Header dependency property.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property.
IsDropTargetProperty | Identifies the IsDropTarget dependency property.
IsSelectedProperty | Identifies the IsSelected dependency property.
ShowAddButtonProperty | Identifies the ShowAddButton dependency property.
ShowCloseButtonProperty | Identifies the ShowCloseButton dependency property.
TabRotationProperty | This member is for internal use only.
TabStripPlacementProperty | This member is for internal use only.

Public Properties

Name | Description
Header | Gets or sets the content of the window title bar. This is a dependency property.
HeaderTemplate | Gets or sets the template used to display the content of the window's title. This is a dependency property.
IsDropTarget | Gets or sets a value indicating whether the item is a target of a tab reordering operation. This is a dependency property.
IsSelected | Gets or sets a value indicating whether this items is selected. This is a dependency property.
ShowAddButton | Gets or sets a value indicating whether the add button is visible. This is a dependency property.
ShowCloseButton | Gets or sets a value indicating whether the close button is visible. This is a dependency property.
TabRotation | This member is for internal use only.
TabStripPlacement | This member is for internal use only.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
ArrangeOverride | FrameworkElement.ArrangeOverride override.
OnAddTab | Raises the AddTab event.
OnIsSelectedChanged | Raises the SelectedChanged event.
OnRemoveTab | Raises the RemoveTab event.

Public Events

Name | Description
AddTab | Raised when the 'Add Tab' button in the item's header is clicked.
IsSelectedChanged | Raised when the IsSelected property has changed.
RemoveTab | Raised when the 'Remove Tab' button in the item's header is clicked.

See Also

DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem Fields

DiagramTabItem Fields
[image]

Public Fields

Name | Description
HeaderProperty | Identifies the Header dependency property.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property.
IsDropTargetProperty | Identifies the IsDropTarget dependency property.
IsSelectedProperty | Identifies the IsSelected dependency property.
ShowAddButtonProperty | Identifies the ShowAddButton dependency property.
ShowCloseButtonProperty | Identifies the ShowCloseButton dependency property.
TabRotationProperty | This member is for internal use only.
TabStripPlacementProperty | This member is for internal use only.

See Also

DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem.HeaderProperty Field

DiagramTabItem.HeaderProperty Field
[image]

Identifies the Header dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderProperty As DependencyProperty

See Also

DiagramTabItem Members
DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem.HeaderTemplateProperty Field

DiagramTabItem.HeaderTemplateProperty Field
[image]

Identifies the HeaderTemplate dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderTemplateProperty As DependencyProperty

See Also

DiagramTabItem Members
DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem.IsDropTargetProperty Field

DiagramTabItem.IsDropTargetProperty Field
[image]

Identifies the IsDropTarget dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsDropTargetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsDropTargetProperty As DependencyProperty

See Also

DiagramTabItem Members
DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem.IsSelectedProperty Field

DiagramTabItem.IsSelectedProperty Field
[image]

Identifies the IsSelected dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsSelectedProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsSelectedProperty As DependencyProperty

See Also

DiagramTabItem Members
DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem.ShowAddButtonProperty Field

DiagramTabItem.ShowAddButtonProperty Field
[image]

Identifies the ShowAddButton dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowAddButtonProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowAddButtonProperty As DependencyProperty

See Also

DiagramTabItem Members
DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem.ShowCloseButtonProperty Field

DiagramTabItem.ShowCloseButtonProperty Field
[image]

Identifies the ShowCloseButton dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowCloseButtonProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowCloseButtonProperty As DependencyProperty

See Also

DiagramTabItem Members
DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem.TabRotationProperty Field

DiagramTabItem.TabRotationProperty Field
[image]

This member is for internal use only.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TabRotationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TabRotationProperty As DependencyProperty

See Also

DiagramTabItem Members
DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem.TabStripPlacementProperty Field

DiagramTabItem.TabStripPlacementProperty Field
[image]

This member is for internal use only.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TabStripPlacementProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TabStripPlacementProperty As DependencyProperty

See Also

DiagramTabItem Members
DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem Constructor

DiagramTabItem Constructor
[image]

Initializes a new instance of the DiagramTabItem class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public DiagramTabItem ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem Methods

DiagramTabItem Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
ArrangeOverride | FrameworkElement.ArrangeOverride override.
OnAddTab | Raises the AddTab event.
OnIsSelectedChanged | Raises the SelectedChanged event.
OnRemoveTab | Raises the RemoveTab event.

See Also

DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem.ArrangeOverride Method

DiagramTabItem.ArrangeOverride Method
[image]

FrameworkElement.ArrangeOverride override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

protected override Size ArrangeOverride (
Size finalSize
)

Visual Basic [image] Copy Code

Protected Overrides Function ArrangeOverride( _
finalSize As Size _
) As Size

Parameters

finalSize

Return Value

See Also

DiagramTabItem Members
DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem.OnAddTab Method

DiagramTabItem.OnAddTab Method
[image]

Raises the AddTab event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

protected virtual void OnAddTab (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnAddTab( _
e As EventArgs _
)

Parameters

e

An object, containing the event data.

See Also

DiagramTabItem Members
DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem.OnApplyTemplate Method

DiagramTabItem.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Overrides Sub OnApplyTemplate ()

See Also

DiagramTabItem Members
DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem.OnIsSelectedChanged Method

DiagramTabItem.OnIsSelectedChanged Method
[image]

Raises the SelectedChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

protected virtual void OnIsSelectedChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnIsSelectedChanged( _
e As EventArgs _
)

Parameters

e

An object, containing the event data.

See Also

DiagramTabItem Members
DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem.OnRemoveTab Method

DiagramTabItem.OnRemoveTab Method
[image]

Raises the RemoveTab event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

protected virtual void OnRemoveTab (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRemoveTab( _
e As EventArgs _
)

Parameters

e

An object, containing the event data.

See Also

DiagramTabItem Members
DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem Properties

DiagramTabItem Properties
[image]

Public Properties

Name | Description
Header | Gets or sets the content of the window title bar. This is a dependency property.
HeaderTemplate | Gets or sets the template used to display the content of the window's title. This is a dependency property.
IsDropTarget | Gets or sets a value indicating whether the item is a target of a tab reordering operation. This is a dependency property.
IsSelected | Gets or sets a value indicating whether this items is selected. This is a dependency property.
ShowAddButton | Gets or sets a value indicating whether the add button is visible. This is a dependency property.
ShowCloseButton | Gets or sets a value indicating whether the close button is visible. This is a dependency property.
TabRotation | This member is for internal use only.
TabStripPlacement | This member is for internal use only.

See Also

DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem.Header Property

DiagramTabItem.Header Property
[image]

Gets or sets the content of the window title bar. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public Object Header { get; set; }

Visual Basic [image] Copy Code

Public Property Header As Object

Property Value

The default value is null.

See Also

DiagramTabItem Members
DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem.HeaderTemplate Property

DiagramTabItem.HeaderTemplate Property
[image]

Gets or sets the template used to display the content of the window's title. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public DataTemplate HeaderTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderTemplate As DataTemplate

Property Value

A DataTemplate instance. The default value is null.

See Also

DiagramTabItem Members
DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem.IsDropTarget Property

DiagramTabItem.IsDropTarget Property
[image]

Gets or sets a value indicating whether the item is a target of a tab reordering operation. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public bool IsDropTarget { get; set; }

Visual Basic [image] Copy Code

Public Property IsDropTarget As Boolean

Property Value

true if the item is being reordered, otherwise false.

See Also

DiagramTabItem Members
DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem.IsSelected Property

DiagramTabItem.IsSelected Property
[image]

Gets or sets a value indicating whether this items is selected. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public bool IsSelected { get; set; }

Visual Basic [image] Copy Code

Public Property IsSelected As Boolean

Property Value

true if the item is selected, otherwise false.

See Also

DiagramTabItem Members
DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem.ShowAddButton Property

DiagramTabItem.ShowAddButton Property
[image]

Gets or sets a value indicating whether the add button is visible. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public bool ShowAddButton { get; set; }

Visual Basic [image] Copy Code

Public Property ShowAddButton As Boolean

Property Value

true to enable the add button; otherwise, false. The default is false.

See Also

DiagramTabItem Members
DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem.ShowCloseButton Property

DiagramTabItem.ShowCloseButton Property
[image]

Gets or sets a value indicating whether the close button is visible. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public bool ShowCloseButton { get; set; }

Visual Basic [image] Copy Code

Public Property ShowCloseButton As Boolean

Property Value

true to enable interactive tab deletion; otherwise, false. The default is false.

See Also

DiagramTabItem Members
DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem.TabRotation Property

DiagramTabItem.TabRotation Property
[image]

This member is for internal use only.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public TabRotation TabRotation { get; set; }

Visual Basic [image] Copy Code

Public Property TabRotation As TabRotation

Property Value

A member of the TabRotation enumeration. The default value is None.

See Also

DiagramTabItem Members
DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem.TabStripPlacement Property

DiagramTabItem.TabStripPlacement Property
[image]

This member is for internal use only.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public Dock TabStripPlacement { get; set; }

Visual Basic [image] Copy Code

Public Property TabStripPlacement As Dock

Property Value

A member of the Dock enumeration. The default value is Top.

See Also

DiagramTabItem Members
DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem Events

DiagramTabItem Events
[image]

Public Events

Name | Description
AddTab | Raised when the 'Add Tab' button in the item's header is clicked.
IsSelectedChanged | Raised when the IsSelected property has changed.
RemoveTab | Raised when the 'Remove Tab' button in the item's header is clicked.

See Also

DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem.AddTab Event

DiagramTabItem.AddTab Event
[image]

Raised when the 'Add Tab' button in the item's header is clicked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public event EventHandler AddTab

Visual Basic [image] Copy Code

Public Event AddTab As EventHandler

See Also

DiagramTabItem Members
DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem.IsSelectedChanged Event

DiagramTabItem.IsSelectedChanged Event
[image]

Raised when the IsSelected property has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public event EventHandler IsSelectedChanged

Visual Basic [image] Copy Code

Public Event IsSelectedChanged As EventHandler

See Also

DiagramTabItem Members
DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItem.RemoveTab Event

DiagramTabItem.RemoveTab Event
[image]

Raised when the 'Remove Tab' button in the item's header is clicked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public event EventHandler RemoveTab

Visual Basic [image] Copy Code

Public Event RemoveTab As EventHandler

See Also

DiagramTabItem Members
DiagramTabItem Class


MindFusion.Diagramming.DiagramTabItemButton Class

DiagramTabItemButton Class
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public class DiagramTabItemButton : Button

Visual Basic [image] Copy Code

Public Class DiagramTabItemButton
Inherits Button

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
Windows.UI.Xaml.Controls.ContentControl
Windows.UI.Xaml.Controls.Primitives.ButtonBase
Windows.UI.Xaml.Controls.Button
MindFusion.Diagramming.DiagramTabItemButton

See Also

DiagramTabItemButton Members


MindFusion.Diagramming.DiagramTabItemButton Members

DiagramTabItemButton Members
Constructors Fields Properties Methods
[image]

For internal use.

The following tables list the members exposed by the DiagramTabItemButton type.

Public Constructors

Name | Description
DiagramTabItemButton |

Public Fields

Name | Description
ClickableProperty | For internal use.

Public Properties

Name | Description
Clickable | For internal use.

Protected Methods

Name | Description
OnPointerEntered | Control.OnPointerEntered override.
OnPointerExited | Control.OnPointerExited override.
OnPointerPressed | Control.OnPointerPressed override.
OnPointerReleased | Control.OnPointerReleased override.

See Also

DiagramTabItemButton Class


MindFusion.Diagramming.DiagramTabItemButton Fields

DiagramTabItemButton Fields
[image]

Public Fields

Name | Description
ClickableProperty | For internal use.

See Also

DiagramTabItemButton Class


MindFusion.Diagramming.DiagramTabItemButton.ClickableProperty Field

DiagramTabItemButton.ClickableProperty Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ClickableProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ClickableProperty As DependencyProperty

See Also

DiagramTabItemButton Members
DiagramTabItemButton Class


MindFusion.Diagramming.DiagramTabItemButton Constructor

DiagramTabItemButton Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public DiagramTabItemButton ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramTabItemButton Class


MindFusion.Diagramming.DiagramTabItemButton Methods

DiagramTabItemButton Methods
[image]

Protected Methods

Name | Description
OnPointerEntered | Control.OnPointerEntered override.
OnPointerExited | Control.OnPointerExited override.
OnPointerPressed | Control.OnPointerPressed override.
OnPointerReleased | Control.OnPointerReleased override.

See Also

DiagramTabItemButton Class


MindFusion.Diagramming.DiagramTabItemButton.OnPointerEntered Method

DiagramTabItemButton.OnPointerEntered Method
[image]

Control.OnPointerEntered override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

protected override void OnPointerEntered (
PointerRoutedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPointerEntered( _
e As PointerRoutedEventArgs _
)

Parameters

e

The PointerRoutedEventArgs that contains the event data.

See Also

DiagramTabItemButton Members
DiagramTabItemButton Class


MindFusion.Diagramming.DiagramTabItemButton.OnPointerExited Method

DiagramTabItemButton.OnPointerExited Method
[image]

Control.OnPointerExited override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

protected override void OnPointerExited (
PointerRoutedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPointerExited( _
e As PointerRoutedEventArgs _
)

Parameters

e

The PointerRoutedEventArgs that contains the event data.

See Also

DiagramTabItemButton Members
DiagramTabItemButton Class


MindFusion.Diagramming.DiagramTabItemButton.OnPointerPressed Method

DiagramTabItemButton.OnPointerPressed Method
[image]

Control.OnPointerPressed override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

protected override void OnPointerPressed (
PointerRoutedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPointerPressed( _
e As PointerRoutedEventArgs _
)

Parameters

e

The PointerRoutedEventArgs that contains the event data.

See Also

DiagramTabItemButton Members
DiagramTabItemButton Class


MindFusion.Diagramming.DiagramTabItemButton.OnPointerReleased Method

DiagramTabItemButton.OnPointerReleased Method
[image]

Control.OnPointerReleased override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

protected override void OnPointerReleased (
PointerRoutedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPointerReleased( _
e As PointerRoutedEventArgs _
)

Parameters

e

The PointerRoutedEventArgs that contains the event data.

See Also

DiagramTabItemButton Members
DiagramTabItemButton Class


MindFusion.Diagramming.DiagramTabItemButton Properties

DiagramTabItemButton Properties
[image]

Public Properties

Name | Description
Clickable | For internal use.

See Also

DiagramTabItemButton Class


MindFusion.Diagramming.DiagramTabItemButton.Clickable Property

DiagramTabItemButton.Clickable Property
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public bool Clickable { get; set; }

Visual Basic [image] Copy Code

Public Property Clickable As Boolean

Property Value

See Also

DiagramTabItemButton Members
DiagramTabItemButton Class


MindFusion.Diagramming.DirectionConstraint Enumeration

DirectionConstraint Enumeration
[image]

Defines values that specify in what direction to constrain node movement.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum DirectionConstraint

Visual Basic [image] Copy Code

Public Enum DirectionConstraint

Members

Member name | Description
Horizontal | Users are allowed to move the node horizontally.
None | No restrictions.
Vertical | Users are allowed to move the node vertically.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.Dock Enumeration

Dock Enumeration
[image]

Specifies a dock destination.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public enum Dock

Visual Basic [image] Copy Code

Public Enum Dock

Members

Member name | Description
Bottom | Indicates docking to the bottom side.
Center | Indicates docking in the middle.
Left | Indicates docking to the left side.
Right | Indicates docking to the right side.
Top | Indicates docking to the top side.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.DockToVisibilityConverter Class

DockToVisibilityConverter Class
[image]

Converts Dock to Visibility.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public class DockToVisibilityConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class DockToVisibilityConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DockToVisibilityConverter

See Also

DockToVisibilityConverter Members


MindFusion.Diagramming.DockToVisibilityConverter Members

DockToVisibilityConverter Members
Constructors Methods
[image]

Converts Dock to Visibility.

The following tables list the members exposed by the DockToVisibilityConverter type.

Public Constructors

Name | Description
DockToVisibilityConverter |

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

DockToVisibilityConverter Class


MindFusion.Diagramming.DockToVisibilityConverter Constructor

DockToVisibilityConverter Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public DockToVisibilityConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DockToVisibilityConverter Class


MindFusion.Diagramming.DockToVisibilityConverter Methods

DockToVisibilityConverter Methods
[image]

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

DockToVisibilityConverter Class


MindFusion.Diagramming.DockToVisibilityConverter.Convert Method

DockToVisibilityConverter.Convert Method
[image]

IValueConverter.Convert implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo l
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
l As CultureInfo _
) As Object

Parameters

value

targetType

parameter

l

Return Value

See Also

DockToVisibilityConverter Members
DockToVisibilityConverter Class


MindFusion.Diagramming.DockToVisibilityConverter.ConvertBack Method

DockToVisibilityConverter.ConvertBack Method
[image]

IValueConverter.ConvertBack implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo l
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
l As CultureInfo _
) As Object

Parameters

value

targetType

parameter

l

Return Value

See Also

DockToVisibilityConverter Members
DockToVisibilityConverter Class


MindFusion.Diagramming.DoNothingBehavior Class

DoNothingBehavior Class
[image]

Implements the DoNothing behavior.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DoNothingBehavior : BehaviorBase

Visual Basic [image] Copy Code

Public Class DoNothingBehavior
Inherits BehaviorBase

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction
MindFusion.Diagramming.BehaviorBase
MindFusion.Diagramming.DoNothingBehavior

See Also

DoNothingBehavior Members


MindFusion.Diagramming.DoNothingBehavior Members

DoNothingBehavior Members
Constructors Properties Methods
[image]

Implements the DoNothing behavior.

The following tables list the members exposed by the DoNothingBehavior type.

Protected Constructors

Name | Description
DoNothingBehavior | Initializes a new instance of the ModifyBehavior class.

Inherited Protected Properties

Name | Description
Diagram | The Diagram object that is being modified. (Inherited from Interaction.)
InteractionState | Gets or sets an InteractionState instance that tracks the modification currently being done on an item. (Inherited from BehaviorBase.)
MouseDownPoint | Gets or sets the position of the mouse when its button has been pressed. (Inherited from BehaviorBase.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Protected Methods

Name | Description
OnMouseDown | BehaviorBase.OnMouseDown override.
OnMouseMove | BehaviorBase.OnMouseMove override.
OnMouseUp | BehaviorBase.OnMouseUp override.

Inherited Public Methods

Name | Description
SetMouseCursor | Invoked while the mouse is moved to let Behavior objects set the mouse cursor depending on the context. (Inherited from BehaviorBase.)
StartDraw | Invoked when a user presses the left mouse button inside the diagram drawing area. (Inherited from BehaviorBase.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DoNothingBehavior Class


MindFusion.Diagramming.DoNothingBehavior Constructor

DoNothingBehavior Constructor
[image]

Initializes a new instance of the ModifyBehavior class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DoNothingBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected New ( _
diagram As Diagram _
)

Parameters

diagram

The Diagram this behavior will be associated with.

See Also

DoNothingBehavior Class


MindFusion.Diagramming.DoNothingBehavior Methods

DoNothingBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Protected Methods

Name | Description
OnMouseDown | BehaviorBase.OnMouseDown override.
OnMouseMove | BehaviorBase.OnMouseMove override.
OnMouseUp | BehaviorBase.OnMouseUp override.

Inherited Public Methods

Name | Description
SetMouseCursor | Invoked while the mouse is moved to let Behavior objects set the mouse cursor depending on the context. (Inherited from BehaviorBase.)
StartDraw | Invoked when a user presses the left mouse button inside the diagram drawing area. (Inherited from BehaviorBase.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DoNothingBehavior Class


MindFusion.Diagramming.DoNothingBehavior.OnMouseDown Method

DoNothingBehavior.OnMouseDown Method
[image]

BehaviorBase.OnMouseDown override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override bool OnMouseDown (
e
)

Visual Basic [image] Copy Code

Protected Overrides Function OnMouseDown( _
e As _
) As Boolean

Parameters

e

Return Value

See Also

DoNothingBehavior Members
DoNothingBehavior Class


MindFusion.Diagramming.DoNothingBehavior.OnMouseMove Method

DoNothingBehavior.OnMouseMove Method
[image]

BehaviorBase.OnMouseMove override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnMouseMove (
e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseMove( _
e As _
)

Parameters

e

See Also

DoNothingBehavior Members
DoNothingBehavior Class


MindFusion.Diagramming.DoNothingBehavior.OnMouseUp Method

DoNothingBehavior.OnMouseUp Method
[image]

BehaviorBase.OnMouseUp override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnMouseUp (
e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseUp( _
e As _
)

Parameters

e

See Also

DoNothingBehavior Members
DoNothingBehavior Class


MindFusion.Diagramming.DoNothingBehavior.SetMouseCursor Method

DoNothingBehavior.SetMouseCursor Method
[image]

BehaviorBase.SetMouseCursor override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Cursor SetMouseCursor (
Point point,
out bool startInteraction
)

Visual Basic [image] Copy Code

Public Overrides Function SetMouseCursor( _
point As Point, _
<System.Runtime.InteropServices.Out()> ByRef startInteraction As Boolean _
) As Cursor

Parameters

point

startInteraction

Return Value

See Also

DoNothingBehavior Members
DoNothingBehavior Class


MindFusion.Diagramming.DoNothingBehavior.StartDraw Method

DoNothingBehavior.StartDraw Method
[image]

BehaviorBase.StartDraw override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override InteractionState StartDraw (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function StartDraw( _
point As Point _
) As InteractionState

Parameters

point

A Point structure, which specifies the current position of the mouse cursor, in document coordinates.

Return Value

An instance of the InteractionState class.

See Also

DoNothingBehavior Members
DoNothingBehavior Class


MindFusion.Diagramming.DrawContainersBehavior Class

DrawContainersBehavior Class
[image]

Implements the DrawContainers behavior.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DrawContainersBehavior : DrawNodesBehavior

Visual Basic [image] Copy Code

Public Class DrawContainersBehavior
Inherits DrawNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction
MindFusion.Diagramming.BehaviorBase
MindFusion.Diagramming.DrawNodesBehavior
MindFusion.Diagramming.DrawContainersBehavior

See Also

DrawContainersBehavior Members


MindFusion.Diagramming.DrawContainersBehavior Members

DrawContainersBehavior Members
Constructors Properties Methods
[image]

Implements the DrawContainers behavior.

The following tables list the members exposed by the DrawContainersBehavior type.

Protected Constructors

Name | Description
DrawContainersBehavior | Initializes a new instance of the DrawShapesBehavior class.

Inherited Protected Properties

Name | Description
Diagram | The Diagram object that is being modified. (Inherited from Interaction.)
InteractionState | Gets or sets an InteractionState instance that tracks the modification currently being done on an item. (Inherited from BehaviorBase.)
MouseDownPoint | Gets or sets the position of the mouse when its button has been pressed. (Inherited from BehaviorBase.)

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

Inherited Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from DrawNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from DrawNodesBehavior.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | Creates a node of the type appropriate for the current behavior. (Inherited from DrawNodesBehavior.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawContainersBehavior Class


MindFusion.Diagramming.DrawContainersBehavior Constructor

DrawContainersBehavior Constructor
[image]

Initializes a new instance of the DrawShapesBehavior class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DrawContainersBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected New ( _
diagram As Diagram _
)

Parameters

diagram

The Diagram this behavior will be associated with.

See Also

DrawContainersBehavior Class


MindFusion.Diagramming.DrawContainersBehavior Methods

DrawContainersBehavior Methods
[image]

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

Inherited Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from DrawNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from DrawNodesBehavior.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | Creates a node of the type appropriate for the current behavior. (Inherited from DrawNodesBehavior.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawContainersBehavior Class


MindFusion.Diagramming.DrawContainersBehavior.CreateNode Method

DrawContainersBehavior.CreateNode Method
[image]

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

DrawContainersBehavior Members
DrawContainersBehavior Class


MindFusion.Diagramming.DrawControlsBehavior Class

DrawControlsBehavior Class
[image]

This class is used when the diagram behavior is set to BehaviorType.DrawControls.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DrawControlsBehavior : DrawNodesBehavior

Visual Basic [image] Copy Code

Public Class DrawControlsBehavior
Inherits DrawNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction
MindFusion.Diagramming.BehaviorBase
MindFusion.Diagramming.DrawNodesBehavior
MindFusion.Diagramming.DrawControlsBehavior

See Also

DrawControlsBehavior Members


MindFusion.Diagramming.DrawControlsBehavior Members

DrawControlsBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to BehaviorType.DrawControls.

The following tables list the members exposed by the DrawControlsBehavior type.

Public Constructors

Name | Description
DrawControlsBehavior | Initializes a new instance of the DrawControlsBehavior class.

Inherited Protected Properties

Name | Description
Diagram | The Diagram object that is being modified. (Inherited from Interaction.)
InteractionState | Gets or sets an InteractionState instance that tracks the modification currently being done on an item. (Inherited from BehaviorBase.)
MouseDownPoint | Gets or sets the position of the mouse when its button has been pressed. (Inherited from BehaviorBase.)

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

Inherited Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from DrawNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from DrawNodesBehavior.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | Creates a node of the type appropriate for the current behavior. (Inherited from DrawNodesBehavior.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawControlsBehavior Class


MindFusion.Diagramming.DrawControlsBehavior Constructor

DrawControlsBehavior Constructor
[image]

Initializes a new instance of the DrawControlsBehavior class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DrawControlsBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram this behavior will be associated with.

See Also

DrawControlsBehavior Class


MindFusion.Diagramming.DrawControlsBehavior Methods

DrawControlsBehavior Methods
[image]

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

Inherited Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from DrawNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from DrawNodesBehavior.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | Creates a node of the type appropriate for the current behavior. (Inherited from DrawNodesBehavior.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawControlsBehavior Class


MindFusion.Diagramming.DrawControlsBehavior.CreateNode Method

DrawControlsBehavior.CreateNode Method
[image]

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateNode () As DiagramNode

Return Value

See Also

DrawControlsBehavior Members
DrawControlsBehavior Class


MindFusion.Diagramming.DrawHandlesEventArgs Class

DrawHandlesEventArgs Class
[image]

Contains the arguments passed to the HitTestAdjustmentHandles event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DrawHandlesEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DrawHandlesEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.DrawHandlesEventArgs

See Also

DrawHandlesEventArgs Members


MindFusion.Diagramming.DrawHandlesEventArgs Members

DrawHandlesEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the HitTestAdjustmentHandles event handlers.

The following tables list the members exposed by the DrawHandlesEventArgs type.

Public Constructors

Name | Description
DrawHandlesEventArgs | Initializes a new instance of the HitTestEventArgs class.

Public Properties

Name | Description
Handles | Gets a list of WinRT Shape objects representing adjustment handles.
Item | Gets the item whose adjustment handles should be rendered.
Positions | Gets a list of points specifying default handle positions.

See Also

DrawHandlesEventArgs Class


MindFusion.Diagramming.DrawHandlesEventArgs Constructor

DrawHandlesEventArgs Constructor
[image]

Initializes a new instance of the HitTestEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DrawHandlesEventArgs (
List<Shape> handles,
IList<Point> positions,
DiagramItem item
)

Visual Basic [image] Copy Code

Public New ( _
handles As List(Of Shape), _
positions As IList(Of Point), _
item As DiagramItem _
)

Parameters

handles

A list of WinRT Shape objects representing adjustment handles.

positions

A list of points specifying default handle positions.

item

The DiagramItem whose selection handles should be rendered.

See Also

DrawHandlesEventArgs Class


MindFusion.Diagramming.DrawHandlesEventArgs Properties

DrawHandlesEventArgs Properties
[image]

Public Properties

Name | Description
Handles | Gets a list of WinRT Shape objects representing adjustment handles.
Item | Gets the item whose adjustment handles should be rendered.
Positions | Gets a list of points specifying default handle positions.

See Also

DrawHandlesEventArgs Class


MindFusion.Diagramming.DrawHandlesEventArgs.Handles Property

DrawHandlesEventArgs.Handles Property
[image]

Gets a list of WinRT Shape objects representing adjustment handles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<Shape> Handles { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Handles As List(Of Shape)

Property Value

See Also

DrawHandlesEventArgs Members
DrawHandlesEventArgs Class


MindFusion.Diagramming.DrawHandlesEventArgs.Item Property

DrawHandlesEventArgs.Item Property
[image]

Gets the item whose adjustment handles should be rendered.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As DiagramItem

Property Value

See Also

DrawHandlesEventArgs Members
DrawHandlesEventArgs Class


MindFusion.Diagramming.DrawHandlesEventArgs.Positions Property

DrawHandlesEventArgs.Positions Property
[image]

Gets a list of points specifying default handle positions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IList<Point> Positions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Positions As IList(Of Point)

Property Value

See Also

DrawHandlesEventArgs Members
DrawHandlesEventArgs Class


MindFusion.Diagramming.DrawLinksBehavior Class

DrawLinksBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.DrawLinks.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DrawLinksBehavior : BehaviorBase

Visual Basic [image] Copy Code

Public Class DrawLinksBehavior
Inherits BehaviorBase

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction
MindFusion.Diagramming.BehaviorBase
MindFusion.Diagramming.DrawLinksBehavior

See Also

DrawLinksBehavior Members


MindFusion.Diagramming.DrawLinksBehavior Members

DrawLinksBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.DrawLinks.

The following tables list the members exposed by the DrawLinksBehavior type.

Protected Constructors

Name | Description
DrawLinksBehavior | Initializes a new instance of the DrawLinksBehavior class.

Inherited Protected Properties

Name | Description
Diagram | The Diagram object that is being modified. (Inherited from Interaction.)
InteractionState | Gets or sets an InteractionState instance that tracks the modification currently being done on an item. (Inherited from BehaviorBase.)
MouseDownPoint | Gets or sets the position of the mouse when its button has been pressed. (Inherited from BehaviorBase.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Inherited Public Methods

Name | Description
SetMouseCursor | Invoked while the mouse is moved to let Behavior objects set the mouse cursor depending on the context. (Inherited from BehaviorBase.)
StartDraw | Invoked when a user presses the left mouse button inside the diagram drawing area. (Inherited from BehaviorBase.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawLinksBehavior Class


MindFusion.Diagramming.DrawLinksBehavior Constructor

DrawLinksBehavior Constructor
[image]

Initializes a new instance of the DrawLinksBehavior class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DrawLinksBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected Function DrawLinksBehavior ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram this behavior will be associated with.

See Also

DrawLinksBehavior Class


MindFusion.Diagramming.DrawLinksBehavior Methods

DrawLinksBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Inherited Public Methods

Name | Description
SetMouseCursor | Invoked while the mouse is moved to let Behavior objects set the mouse cursor depending on the context. (Inherited from BehaviorBase.)
StartDraw | Invoked when a user presses the left mouse button inside the diagram drawing area. (Inherited from BehaviorBase.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawLinksBehavior Class


MindFusion.Diagramming.DrawLinksBehavior.SetMouseCursor Method

DrawLinksBehavior.SetMouseCursor Method
[image]

BehaviorBase.SetMouseCursor override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Cursor SetMouseCursor (
Point point,
out bool startInteraction
)

Visual Basic [image] Copy Code

Public Overrides Function SetMouseCursor( _
point As Point, _
<System.Runtime.InteropServices.Out()> ByRef startInteraction As Boolean _
) As Cursor

Parameters

point

startInteraction

Return Value

See Also

DrawLinksBehavior Members
DrawLinksBehavior Class


MindFusion.Diagramming.DrawLinksBehavior.StartDraw Method

DrawLinksBehavior.StartDraw Method
[image]

BehaviorBase.StartDraw override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override InteractionState StartDraw (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function StartDraw ( _
point As Point _
) As InteractionState

Parameters

point
A Point structure, which specifies the current position of the mouse cursor, in document coordinates.

Return Value

An instance of the InteractionState class.

See Also

DrawLinksBehavior Members
DrawLinksBehavior Class


MindFusion.Diagramming.DrawNodesBehavior Class

DrawNodesBehavior Class
[image]

The base class for behavior types that allow drawing of nodes, but not links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class DrawNodesBehavior : BehaviorBase

Visual Basic [image] Copy Code

Public MustInherit Class DrawNodesBehavior
Inherits BehaviorBase

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction
MindFusion.Diagramming.BehaviorBase
MindFusion.Diagramming.DrawNodesBehavior
MindFusion.Diagramming.DrawContainersBehavior
MindFusion.Diagramming.DrawControlsBehavior
MindFusion.Diagramming.DrawShapesBehavior
MindFusion.Diagramming.DrawTablesBehavior
MindFusion.Diagramming.DrawTreeViewsBehavior

See Also

DrawNodesBehavior Members


MindFusion.Diagramming.DrawNodesBehavior Members

DrawNodesBehavior Members
Constructors Properties Methods
[image]

The base class for behavior types that allow drawing of nodes, but not links.

The following tables list the members exposed by the DrawNodesBehavior type.

Protected Constructors

Name | Description
DrawNodesBehavior | Initializes a new instance of the DrawNodesBehavior class.

Inherited Protected Properties

Name | Description
Diagram | The Diagram object that is being modified. (Inherited from Interaction.)
InteractionState | Gets or sets an InteractionState instance that tracks the modification currently being done on an item. (Inherited from BehaviorBase.)
MouseDownPoint | Gets or sets the position of the mouse when its button has been pressed. (Inherited from BehaviorBase.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Protected Methods

Name | Description
CreateNode | Creates a node of the type appropriate for the current behavior.

Inherited Public Methods

Name | Description
SetMouseCursor | Invoked while the mouse is moved to let Behavior objects set the mouse cursor depending on the context. (Inherited from BehaviorBase.)
StartDraw | Invoked when a user presses the left mouse button inside the diagram drawing area. (Inherited from BehaviorBase.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawNodesBehavior Class


MindFusion.Diagramming.DrawNodesBehavior Constructor

DrawNodesBehavior Constructor
[image]

Initializes a new instance of the DrawNodesBehavior class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DrawNodesBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected Function DrawNodesBehavior ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram this behavior will be associated with.

See Also

DrawNodesBehavior Class


MindFusion.Diagramming.DrawNodesBehavior Methods

DrawNodesBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Protected Methods

Name | Description
CreateNode | Creates a node of the type appropriate for the current behavior.

Inherited Public Methods

Name | Description
SetMouseCursor | Invoked while the mouse is moved to let Behavior objects set the mouse cursor depending on the context. (Inherited from BehaviorBase.)
StartDraw | Invoked when a user presses the left mouse button inside the diagram drawing area. (Inherited from BehaviorBase.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawNodesBehavior Class


MindFusion.Diagramming.DrawNodesBehavior.CreateNode Method

DrawNodesBehavior.CreateNode Method
[image]

Creates a node of the type appropriate for the current behavior.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected abstract DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected MustOverride Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

DrawNodesBehavior Members
DrawNodesBehavior Class


MindFusion.Diagramming.DrawNodesBehavior.SetMouseCursor Method

DrawNodesBehavior.SetMouseCursor Method
[image]

BehaviorBase.SetMouseCursor override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Cursor SetMouseCursor (
Point point,
out bool startInteraction
)

Visual Basic [image] Copy Code

Public Overrides Function SetMouseCursor( _
point As Point, _
<System.Runtime.InteropServices.Out()> ByRef startInteraction As Boolean _
) As Cursor

Parameters

point

startInteraction

Return Value

See Also

DrawNodesBehavior Members
DrawNodesBehavior Class


MindFusion.Diagramming.DrawNodesBehavior.StartDraw Method

DrawNodesBehavior.StartDraw Method
[image]

BehaviorBase.StartDraw override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override InteractionState StartDraw (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function StartDraw ( _
point As Point _
) As InteractionState

Parameters

point
A Point structure, which specifies the current position of the mouse cursor, in document coordinates.

Return Value

An instance of the InteractionState class.

See Also

DrawNodesBehavior Members
DrawNodesBehavior Class


MindFusion.Diagramming.DrawShapesBehavior Class

DrawShapesBehavior Class
[image]

Implements the DrawShapes behavior.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DrawShapesBehavior : DrawNodesBehavior

Visual Basic [image] Copy Code

Public Class DrawShapesBehavior
Inherits DrawNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction
MindFusion.Diagramming.BehaviorBase
MindFusion.Diagramming.DrawNodesBehavior
MindFusion.Diagramming.DrawShapesBehavior

See Also

DrawShapesBehavior Members


MindFusion.Diagramming.DrawShapesBehavior Members

DrawShapesBehavior Members
Constructors Properties Methods
[image]

Implements the DrawShapes behavior.

The following tables list the members exposed by the DrawShapesBehavior type.

Protected Constructors

Name | Description
DrawShapesBehavior | Initializes a new instance of the DrawShapesBehavior class.

Inherited Protected Properties

Name | Description
Diagram | The Diagram object that is being modified. (Inherited from Interaction.)
InteractionState | Gets or sets an InteractionState instance that tracks the modification currently being done on an item. (Inherited from BehaviorBase.)
MouseDownPoint | Gets or sets the position of the mouse when its button has been pressed. (Inherited from BehaviorBase.)

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

Inherited Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from DrawNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from DrawNodesBehavior.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | Creates a node of the type appropriate for the current behavior. (Inherited from DrawNodesBehavior.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawShapesBehavior Class


MindFusion.Diagramming.DrawShapesBehavior Constructor

DrawShapesBehavior Constructor
[image]

Initializes a new instance of the DrawShapesBehavior class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DrawShapesBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected Function DrawShapesBehavior ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram this behavior will be associated with.

See Also

DrawShapesBehavior Class


MindFusion.Diagramming.DrawShapesBehavior Methods

DrawShapesBehavior Methods
[image]

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

Inherited Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from DrawNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from DrawNodesBehavior.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | Creates a node of the type appropriate for the current behavior. (Inherited from DrawNodesBehavior.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawShapesBehavior Class


MindFusion.Diagramming.DrawShapesBehavior.CreateNode Method

DrawShapesBehavior.CreateNode Method
[image]

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

DrawShapesBehavior Members
DrawShapesBehavior Class


MindFusion.Diagramming.DrawTablesBehavior Class

DrawTablesBehavior Class
[image]

Implements the DrawTables behavior.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DrawTablesBehavior : DrawNodesBehavior

Visual Basic [image] Copy Code

Public Class DrawTablesBehavior
Inherits DrawNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction
MindFusion.Diagramming.BehaviorBase
MindFusion.Diagramming.DrawNodesBehavior
MindFusion.Diagramming.DrawTablesBehavior

See Also

DrawTablesBehavior Members


MindFusion.Diagramming.DrawTablesBehavior Members

DrawTablesBehavior Members
Constructors Properties Methods
[image]

Implements the DrawTables behavior.

The following tables list the members exposed by the DrawTablesBehavior type.

Protected Constructors

Name | Description
DrawTablesBehavior | Initializes a new instance of the DrawTablesBehavior class.

Inherited Protected Properties

Name | Description
Diagram | The Diagram object that is being modified. (Inherited from Interaction.)
InteractionState | Gets or sets an InteractionState instance that tracks the modification currently being done on an item. (Inherited from BehaviorBase.)
MouseDownPoint | Gets or sets the position of the mouse when its button has been pressed. (Inherited from BehaviorBase.)

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

Inherited Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from DrawNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from DrawNodesBehavior.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | Creates a node of the type appropriate for the current behavior. (Inherited from DrawNodesBehavior.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawTablesBehavior Class


MindFusion.Diagramming.DrawTablesBehavior Constructor

DrawTablesBehavior Constructor
[image]

Initializes a new instance of the DrawTablesBehavior class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DrawTablesBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected Function DrawTablesBehavior ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram this behavior will be associated with.

See Also

DrawTablesBehavior Class


MindFusion.Diagramming.DrawTablesBehavior Methods

DrawTablesBehavior Methods
[image]

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

Inherited Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from DrawNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from DrawNodesBehavior.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | Creates a node of the type appropriate for the current behavior. (Inherited from DrawNodesBehavior.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawTablesBehavior Class


MindFusion.Diagramming.DrawTablesBehavior.CreateNode Method

DrawTablesBehavior.CreateNode Method
[image]

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

DrawTablesBehavior Members
DrawTablesBehavior Class


MindFusion.Diagramming.DrawTreeViewsBehavior Class

DrawTreeViewsBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.DrawTreeViews.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DrawTreeViewsBehavior : DrawNodesBehavior

Visual Basic [image] Copy Code

Public Class DrawTreeViewsBehavior
Inherits DrawNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction
MindFusion.Diagramming.BehaviorBase
MindFusion.Diagramming.DrawNodesBehavior
MindFusion.Diagramming.DrawTreeViewsBehavior

See Also

DrawTreeViewsBehavior Members


MindFusion.Diagramming.DrawTreeViewsBehavior Members

DrawTreeViewsBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.DrawTreeViews.

The following tables list the members exposed by the DrawTreeViewsBehavior type.

Protected Constructors

Name | Description
DrawTreeViewsBehavior | Initializes a new instance of the DrawTreeViewsBehavior class.

Inherited Protected Properties

Name | Description
Diagram | The Diagram object that is being modified. (Inherited from Interaction.)
InteractionState | Gets or sets an InteractionState instance that tracks the modification currently being done on an item. (Inherited from BehaviorBase.)
MouseDownPoint | Gets or sets the position of the mouse when its button has been pressed. (Inherited from BehaviorBase.)

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

Inherited Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from DrawNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from DrawNodesBehavior.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | Creates a node of the type appropriate for the current behavior. (Inherited from DrawNodesBehavior.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawTreeViewsBehavior Class


MindFusion.Diagramming.DrawTreeViewsBehavior Constructor

DrawTreeViewsBehavior Constructor
[image]

Initializes a new instance of the DrawTreeViewsBehavior class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DrawTreeViewsBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected New ( _
diagram As Diagram _
)

Parameters

diagram

The Diagram this behavior will be associated with.

See Also

DrawTreeViewsBehavior Class


MindFusion.Diagramming.DrawTreeViewsBehavior Methods

DrawTreeViewsBehavior Methods
[image]

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

Inherited Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from DrawNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from DrawNodesBehavior.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | Creates a node of the type appropriate for the current behavior. (Inherited from DrawNodesBehavior.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawTreeViewsBehavior Class


MindFusion.Diagramming.DrawTreeViewsBehavior.CreateNode Method

DrawTreeViewsBehavior.CreateNode Method
[image]

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateNode () As DiagramNode

Return Value

An instance of the TreeViewNode class.

See Also

DrawTreeViewsBehavior Members
DrawTreeViewsBehavior Class


MindFusion.Diagramming.DummyConnectionPoint Class

DummyConnectionPoint Class
[image]

Represents connection points for unconnected links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DummyConnectionPoint : ConnectionPoint

Visual Basic [image] Copy Code

Public Class DummyConnectionPoint
Inherits ConnectionPoint

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ConnectionPoint
MindFusion.Diagramming.DummyConnectionPoint

See Also

DummyConnectionPoint Members


MindFusion.Diagramming.DummyConnectionPoint Members

DummyConnectionPoint Members
Constructors Properties Methods
[image]

Represents connection points for unconnected links.

The following tables list the members exposed by the DummyConnectionPoint type.

Public Constructors

Name | Description
DummyConnectionPoint | Initializes a new instance of the DummyConnectionPoint class.

Protected Properties

Name | Description
Node | Gets a dummy node associated with this connection point.

Inherited Public Properties

Name | Description
AnchorPointIndex | Gets or sets the index of the destination anchor point within the AnchorPattern that contains it. (Inherited from ConnectionPoint.)
RelativePosition | Gets or sets the position of this connection point, relative to the associated node's bounding rectangle, expressed in percents. (Inherited from ConnectionPoint.)
Row | Gets the index of a constituent item within the associated node where the link represented by this connection point is connected, or -1, if the link is connected to the node itself. (Inherited from ConnectionPoint.)

Inherited Protected Properties

Name | Description
Incoming | Gets a flag indicating whether this connection point is at the origin or the destination of the associated link. (Inherited from ConnectionPoint.)
Link | Gets the link associated with this connection point. (Inherited from ConnectionPoint.)
Node | Gets the node associated with this connection point. (Inherited from ConnectionPoint.)

Public Methods

Name | Description
AddLinkToNode | ConnectionPoint.AddLinkToNode override.
GetEndPoint | ConnectionPoint.SaveEndRelative override.
GetInitialPoint | ConnectionPoint.GetInitialPoint override.
GetNodeRect | ConnectionPoint.GetNodeRect override.
RemoveLinkFromNode | ConnectionPoint.RemoveLinkFromNode override.
SaveEndRelative | ConnectionPoint.SaveEndRelative override.

Protected Methods

Name | Description
GetNearestBorderPoint | ConnectionPoint.GetNearestBorderPoint override.

Inherited Public Methods

Name | Description
AddLinkToNode | Adds the link associated with this connection point to the associated node. (Inherited from ConnectionPoint.)
GetAnchorPos | Returns the point from the node's associated anchor pattern (if any) with the specified index or the link's initial point. (Inherited from ConnectionPoint.)
GetEndPoint | Calculates the coordinates of this connection point expressed in document coordinates. (Inherited from ConnectionPoint.)
GetInitialPoint | Returns a point (usually the center of the bounding rectangle) contained within the associated node. (Inherited from ConnectionPoint.)
GetIntersection | Calculates the intersection point between the specified line segment and the contour of the node associated with this connection point. (Inherited from ConnectionPoint.)
GetNodeRect | Returns the bounding rectangle of the node associated with this connection point. (Inherited from ConnectionPoint.)
LinkChanges | Checks whether the link would change if attached to the specified node at the specified point. (Inherited from ConnectionPoint.)
NodesIntersect | Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect. (Inherited from ConnectionPoint.)
RemoveLinkFromNode | Removes the link associated with this connection point from the associated node. (Inherited from ConnectionPoint.)
SaveEndRelative | Updates the coordinates of the connection point represented by this link, relative to the bounding rectangle of the associated node. (Inherited from ConnectionPoint.)
UpdateRow | Sets the row within the table this connection point should be associated with. (Inherited from ConnectionPoint.)

Inherited Protected Methods

Name | Description
GetNearestAnchorPoint | Returns the nearest anchor point pertinent to this connection. (Inherited from ConnectionPoint.)
GetNearestBorderPoint | Returns the nearest point lying on the node border. (Inherited from ConnectionPoint.)

See Also

DummyConnectionPoint Class


MindFusion.Diagramming.DummyConnectionPoint Constructor

DummyConnectionPoint Constructor
[image]

Initializes a new instance of the DummyConnectionPoint class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DummyConnectionPoint (
DiagramLink link,
bool incoming,
Point point
)

Visual Basic [image] Copy Code

Public Function DummyConnectionPoint ( _
link As DiagramLink, _
incoming As Boolean, _
point As Point _
)

Parameters

link

incoming

point

See Also

DummyConnectionPoint Class


MindFusion.Diagramming.DummyConnectionPoint Methods

DummyConnectionPoint Methods
[image]

Public Methods

Name | Description
AddLinkToNode | ConnectionPoint.AddLinkToNode override.
GetEndPoint | ConnectionPoint.SaveEndRelative override.
GetInitialPoint | ConnectionPoint.GetInitialPoint override.
GetNodeRect | ConnectionPoint.GetNodeRect override.
RemoveLinkFromNode | ConnectionPoint.RemoveLinkFromNode override.
SaveEndRelative | ConnectionPoint.SaveEndRelative override.

Protected Methods

Name | Description
GetNearestBorderPoint | ConnectionPoint.GetNearestBorderPoint override.

Inherited Public Methods

Name | Description
AddLinkToNode | Adds the link associated with this connection point to the associated node. (Inherited from ConnectionPoint.)
GetAnchorPos | Returns the point from the node's associated anchor pattern (if any) with the specified index or the link's initial point. (Inherited from ConnectionPoint.)
GetEndPoint | Calculates the coordinates of this connection point expressed in document coordinates. (Inherited from ConnectionPoint.)
GetInitialPoint | Returns a point (usually the center of the bounding rectangle) contained within the associated node. (Inherited from ConnectionPoint.)
GetIntersection | Calculates the intersection point between the specified line segment and the contour of the node associated with this connection point. (Inherited from ConnectionPoint.)
GetNodeRect | Returns the bounding rectangle of the node associated with this connection point. (Inherited from ConnectionPoint.)
LinkChanges | Checks whether the link would change if attached to the specified node at the specified point. (Inherited from ConnectionPoint.)
NodesIntersect | Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect. (Inherited from ConnectionPoint.)
RemoveLinkFromNode | Removes the link associated with this connection point from the associated node. (Inherited from ConnectionPoint.)
SaveEndRelative | Updates the coordinates of the connection point represented by this link, relative to the bounding rectangle of the associated node. (Inherited from ConnectionPoint.)
UpdateRow | Sets the row within the table this connection point should be associated with. (Inherited from ConnectionPoint.)

Inherited Protected Methods

Name | Description
GetNearestAnchorPoint | Returns the nearest anchor point pertinent to this connection. (Inherited from ConnectionPoint.)
GetNearestBorderPoint | Returns the nearest point lying on the node border. (Inherited from ConnectionPoint.)

See Also

DummyConnectionPoint Class


MindFusion.Diagramming.DummyConnectionPoint.AddLinkToNode Method

DummyConnectionPoint.AddLinkToNode Method
[image]

ConnectionPoint.AddLinkToNode override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void AddLinkToNode ()

Visual Basic [image] Copy Code

Public Overrides Sub AddLinkToNode ()

See Also

DummyConnectionPoint Members
DummyConnectionPoint Class


MindFusion.Diagramming.DummyConnectionPoint.GetEndPoint Method

DummyConnectionPoint.GetEndPoint Method
[image]

ConnectionPoint.SaveEndRelative override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Point GetEndPoint ()

Visual Basic [image] Copy Code

Public Overrides Function GetEndPoint () As Point

Return Value

See Also

DummyConnectionPoint Members
DummyConnectionPoint Class


MindFusion.Diagramming.DummyConnectionPoint.GetInitialPoint Method

DummyConnectionPoint.GetInitialPoint Method
[image]

ConnectionPoint.GetInitialPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Point GetInitialPoint ()

Visual Basic [image] Copy Code

Public Overrides Function GetInitialPoint () As Point

Return Value

See Also

DummyConnectionPoint Members
DummyConnectionPoint Class


MindFusion.Diagramming.DummyConnectionPoint.GetNearestBorderPoint Method

DummyConnectionPoint.GetNearestBorderPoint Method
[image]

ConnectionPoint.GetNearestBorderPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override AnchorPointDetails GetNearestBorderPoint (
Point point
)

Visual Basic [image] Copy Code

Protected Overrides Function GetNearestBorderPoint( _
point As Point _
) As AnchorPointDetails

Parameters

point
A Point instance specifying location in the diagram.

Return Value

An AnchorPointDetails specifying the anchor point properties.

See Also

DummyConnectionPoint Members
DummyConnectionPoint Class


MindFusion.Diagramming.DummyConnectionPoint.GetNodeRect Method

DummyConnectionPoint.GetNodeRect Method
[image]

ConnectionPoint.GetNodeRect override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Rect GetNodeRect (
bool rotated
)

Visual Basic [image] Copy Code

Public Overrides Function GetNodeRect( _
rotated As Boolean _
) As Rect

Parameters

rotated

Return Value

See Also

DummyConnectionPoint Members
DummyConnectionPoint Class


MindFusion.Diagramming.DummyConnectionPoint.RemoveLinkFromNode Method

DummyConnectionPoint.RemoveLinkFromNode Method
[image]

ConnectionPoint.RemoveLinkFromNode override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void RemoveLinkFromNode ()

Visual Basic [image] Copy Code

Public Overrides Sub RemoveLinkFromNode ()

See Also

DummyConnectionPoint Members
DummyConnectionPoint Class


MindFusion.Diagramming.DummyConnectionPoint.SaveEndRelative Method

DummyConnectionPoint.SaveEndRelative Method
[image]

ConnectionPoint.SaveEndRelative override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void SaveEndRelative ()

Visual Basic [image] Copy Code

Public Overrides Sub SaveEndRelative ()

See Also

DummyConnectionPoint Members
DummyConnectionPoint Class


MindFusion.Diagramming.DummyConnectionPoint Properties

DummyConnectionPoint Properties
[image]

Protected Properties

Name | Description
Node | Gets a dummy node associated with this connection point.

Inherited Public Properties

Name | Description
AnchorPointIndex | Gets or sets the index of the destination anchor point within the AnchorPattern that contains it. (Inherited from ConnectionPoint.)
RelativePosition | Gets or sets the position of this connection point, relative to the associated node's bounding rectangle, expressed in percents. (Inherited from ConnectionPoint.)
Row | Gets the index of a constituent item within the associated node where the link represented by this connection point is connected, or -1, if the link is connected to the node itself. (Inherited from ConnectionPoint.)

Inherited Protected Properties

Name | Description
Incoming | Gets a flag indicating whether this connection point is at the origin or the destination of the associated link. (Inherited from ConnectionPoint.)
Link | Gets the link associated with this connection point. (Inherited from ConnectionPoint.)
Node | Gets the node associated with this connection point. (Inherited from ConnectionPoint.)

See Also

DummyConnectionPoint Class


MindFusion.Diagramming.DummyConnectionPoint.Node Property

DummyConnectionPoint.Node Property
[image]

Gets a dummy node associated with this connection point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramNode Node { get; }

Visual Basic [image] Copy Code

Protected Overridable ReadOnly Property Node As DiagramNode

Property Value

See Also

DummyConnectionPoint Members
DummyConnectionPoint Class


MindFusion.Diagramming.DummyNode Class

DummyNode Class
[image]

Represents virtual nodes used for disconnected links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DummyNode : DiagramNode

Visual Basic [image] Copy Code

Public Class DummyNode
Inherits DiagramNode

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
Windows.UI.Xaml.Controls.ContentControl
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.DummyNode

See Also

DummyNode Members


MindFusion.Diagramming.DummyNode Members

DummyNode Members
Constructors Fields Properties Methods
[image]

Represents virtual nodes used for disconnected links.

The following tables list the members exposed by the DummyNode type.

Public Constructors

Name | Description
DummyNode | Initializes a new instance of the DummyNode class.

Inherited Public Fields

Name | Description
AutoCaptureMouseProperty | Identifies the AutoCaptureMouse dependency property. (Inherited from DiagramItem.)
BoundsProperty | Identifies the Bounds dependency property. (Inherited from DiagramNode.)
BrushProperty | Identifies the Brush dependency property. (Inherited from DiagramItem.)
EffectsSourceProperty | Identifies the EffectsSource dependency property. (Inherited from DiagramNode.)
HyperLinkProperty | Identifies the HyperLink dependency property. (Inherited from DiagramItem.)
IsMouseDownProperty | Identifies the IsMouseDown dependency property. (Inherited from DiagramItem.)
IsMouseOverProperty | Identifies the IsMouseOver dependency property. (Inherited from DiagramItem.)
MasterNodeProperty | Identifies the MasterNode dependency property. (Inherited from DiagramNode.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from DiagramNode.)
ShapeOpacityProperty | Identifies the ShapeOpacity dependency property. (Inherited from DiagramNode.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from DiagramItem.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)

Inherited Protected Fields

Name | Description
handles | A list of the Rectangle objects that represent the item's adjustment handles. (Inherited from DiagramItem.)

Inherited Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
AttachedNodes | Returns the nodes attached to this node. (Inherited from DiagramNode.)
AutoCaptureMouse | Gets or sets whether the item should capture the mouse input when the left button is pressed over it. This is a dependency property. (Inherited from DiagramItem.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. This is a dependency property. (Inherited from DiagramNode.)
Brush | Gets or sets the Brush that specifies how to paint the interior of the item. This is a dependency property. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Container | Gets the ContainerNode that contains this node. (Inherited from DiagramNode.)
Diagram | Gets the parent diagram. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramItem.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. This is a dependency property. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
IsMouseDown | Gets a value indicating whether the mouse button is pressed over this item. This is a dependency property. (Inherited from DiagramItem.)
IsMouseOver | Gets a value indicating whether the mouse pointer is located over this item. This is a dependency property. (Inherited from DiagramItem.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterNode | Gets the node to which this node is attached. This is a dependency property. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
RotationAngle | Gets or sets the angle at which this node is rotated. This is a dependency property. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShapeOpacity | Gets or sets the shape opacity of this node. This is a dependency property. (Inherited from DiagramNode.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline nodes. This is a dependency property. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashOffset | Gets or sets a double value that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. This is a dependency property. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
ToolTip | Gets or sets the contents of the tooltip displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of the object. (Inherited from DiagramItem.)

Inherited Protected Properties

Name | Description
Size | Gets the size of this item. (Inherited from DiagramItem.)

Public Methods

Name | Description
GetIntersection | DiagramNode.GetIntersection override.

Protected Methods

Name | Description
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
UpdateVisuals | DiagramNode.UpdateVisuals override.

Inherited Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
Attach | Attaches the specified subordinate node to this node, so that when this node is moved, the subordinate follows it. (Inherited from DiagramNode.)
AttachTo | Attaches this node to the specified master node so that when the master is moved, the attached node follows it. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
ContainsPoint | DiagramItem.ContainsPoint override. (Inherited from DiagramNode.)
Detach | Overloaded. (Inherited from DiagramNode.)
GetAllIncomingLinks | Gets a collection of all links entering this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Get a collection of all links going out of this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from DiagramNode.)
OnBoundsChanged | Called when the location and size of this node change. (Inherited from DiagramNode.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RestoreLocationState | DiagramItem.RestoreLocationState override. (Inherited from DiagramNode.)
SaveLocationState | DiagramItem.SaveLocationState override. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point in diagram coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Gets the diagram coordinates of a point specified in the local coordinate system of this item. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Inherited Protected Methods

Name | Description
AddAnchorPointVisuals | Adds the AnchorPatern points to the node's Adorner. (Inherited from DiagramNode.)
AddExpandButton | Adds the ExpandButton to the node's Adoner. (Inherited from DiagramNode.)
AddHandlesToCanvas | Overloaded. (Inherited from DiagramNode.)
AllowDrag | Invoked to validate the drag operation. (Inherited from DiagramItem.)
CancelDrag | DiagramItem.CancelDrag override. (Inherited from DiagramNode.)
CreateAnchorPointVisual | Creates a Path that represents the specified AnchorPoint. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
EndDrag | DiagramItem.EndDrag override. (Inherited from DiagramNode.)
GetOutline | Creates a Geometry object that describes the outline of the node. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
LoadFromXml | DiagramItem.LoadFromXml override. (Inherited from DiagramNode.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramNode.)
OnMouseEnter | Control.OnMouseEnter override. (Inherited from DiagramItem.)
OnMouseLeave | Control.OnMouseLeave override. (Inherited from DiagramItem.)
OnMouseLeftButtonDown | Control.OnMouseLeftButtonDown override. (Inherited from DiagramItem.)
OnMouseLeftButtonUp | Control.OnMouseLeftButtonUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
RemoveAnchorPointVisuals | Removes the AnchorPatern points from the node's Adorner. (Inherited from DiagramNode.)
RemoveHandlesFromCanvas | Invoked when the item's selection handles should be removed. (Inherited from DiagramItem.)
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramNode.)
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
StartDrag | DiagramItem.StartDrag override. (Inherited from DiagramNode.)
UpdateDrag | DiagramItem.UpdateDrag override. (Inherited from DiagramNode.)
UpdateHandleColors | Sets the handle colors according to the current selection state of the item and the enabled bits in the EnabledHandles property. (Inherited from DiagramItem.)
UpdateHandlePositions | Invoked when the item's selection handles should change their position. (Inherited from DiagramItem.)
UpdateStates | Sets the current VisualStates of this item. (Inherited from DiagramItem.)
UpdateVisuals | DiagramItem.UpdateVisuals override. (Inherited from DiagramNode.)

See Also

DummyNode Class


MindFusion.Diagramming.DummyNode Constructor

DummyNode Constructor
[image]

Initializes a new instance of the DummyNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DummyNode (
Diagram parent
)

Visual Basic [image] Copy Code

Public Function DummyNode ( _
parent As Diagram _
)

Parameters

parent
The Diagram this node will be associated with.

See Also

DummyNode Class


MindFusion.Diagramming.DummyNode Methods

DummyNode Methods
[image]

Public Methods

Name | Description
GetIntersection | DiagramNode.GetIntersection override.

Protected Methods

Name | Description
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
UpdateVisuals | DiagramNode.UpdateVisuals override.

Inherited Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
Attach | Attaches the specified subordinate node to this node, so that when this node is moved, the subordinate follows it. (Inherited from DiagramNode.)
AttachTo | Attaches this node to the specified master node so that when the master is moved, the attached node follows it. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
ContainsPoint | DiagramItem.ContainsPoint override. (Inherited from DiagramNode.)
Detach | Overloaded. (Inherited from DiagramNode.)
GetAllIncomingLinks | Gets a collection of all links entering this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Get a collection of all links going out of this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from DiagramNode.)
OnBoundsChanged | Called when the location and size of this node change. (Inherited from DiagramNode.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RestoreLocationState | DiagramItem.RestoreLocationState override. (Inherited from DiagramNode.)
SaveLocationState | DiagramItem.SaveLocationState override. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point in diagram coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Gets the diagram coordinates of a point specified in the local coordinate system of this item. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Inherited Protected Methods

Name | Description
AddAnchorPointVisuals | Adds the AnchorPatern points to the node's Adorner. (Inherited from DiagramNode.)
AddExpandButton | Adds the ExpandButton to the node's Adoner. (Inherited from DiagramNode.)
AddHandlesToCanvas | Overloaded. (Inherited from DiagramNode.)
AllowDrag | Invoked to validate the drag operation. (Inherited from DiagramItem.)
CancelDrag | DiagramItem.CancelDrag override. (Inherited from DiagramNode.)
CreateAnchorPointVisual | Creates a Path that represents the specified AnchorPoint. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
EndDrag | DiagramItem.EndDrag override. (Inherited from DiagramNode.)
GetOutline | Creates a Geometry object that describes the outline of the node. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
LoadFromXml | DiagramItem.LoadFromXml override. (Inherited from DiagramNode.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramNode.)
OnMouseEnter | Control.OnMouseEnter override. (Inherited from DiagramItem.)
OnMouseLeave | Control.OnMouseLeave override. (Inherited from DiagramItem.)
OnMouseLeftButtonDown | Control.OnMouseLeftButtonDown override. (Inherited from DiagramItem.)
OnMouseLeftButtonUp | Control.OnMouseLeftButtonUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
RemoveAnchorPointVisuals | Removes the AnchorPatern points from the node's Adorner. (Inherited from DiagramNode.)
RemoveHandlesFromCanvas | Invoked when the item's selection handles should be removed. (Inherited from DiagramItem.)
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramNode.)
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
StartDrag | DiagramItem.StartDrag override. (Inherited from DiagramNode.)
UpdateDrag | DiagramItem.UpdateDrag override. (Inherited from DiagramNode.)
UpdateHandleColors | Sets the handle colors according to the current selection state of the item and the enabled bits in the EnabledHandles property. (Inherited from DiagramItem.)
UpdateHandlePositions | Invoked when the item's selection handles should change their position. (Inherited from DiagramItem.)
UpdateStates | Sets the current VisualStates of this item. (Inherited from DiagramItem.)
UpdateVisuals | DiagramItem.UpdateVisuals override. (Inherited from DiagramNode.)

See Also

DummyNode Class


MindFusion.Diagramming.DummyNode.CreateConnectionPoint Method

DummyNode.CreateConnectionPoint Method
[image]

DiagramNode.CreateConnectionPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual ConnectionPoint CreateConnectionPoint (
DiagramLink link,
Point point,
bool incoming
)

Visual Basic [image] Copy Code

Protected Overridable Function CreateConnectionPoint ( _
link As DiagramLink, _
point As Point, _
incoming As Boolean _
) As ConnectionPoint

Parameters

link

point

incoming

Return Value

See Also

DummyNode Members
DummyNode Class


MindFusion.Diagramming.DummyNode.GetIntersection Method

DummyNode.GetIntersection Method
[image]

DiagramNode.GetIntersection override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Point GetIntersection (
Point segmentStart,
Point segmentEnd
)

Visual Basic [image] Copy Code

Public Overrides Function GetIntersection( _
segmentStart As Point, _
segmentEnd As Point _
) As Point

Parameters

segmentStart

The first point of the segment.

segmentEnd

The second point of the segment.

Return Value

The DummyNode implementation of this method always returns segmentStart as the result.

See Also

DummyNode Members
DummyNode Class


MindFusion.Diagramming.DummyNode.UpdateVisuals Method

DummyNode.UpdateVisuals Method
[image]

DiagramNode.UpdateVisuals override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void UpdateVisuals (
bool updateEffects
)

Visual Basic [image] Copy Code

Protected Overrides Sub UpdateVisuals( _
updateEffects As Boolean _
)

Parameters

updateEffects

See Also

DummyNode Members
DummyNode Class


MindFusion.Diagramming.EditLinkTextEventArgs Class

EditLinkTextEventArgs Class
[image]

Contains the arguments passed to the EditLinkTextEventArgs event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class EditLinkTextEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class EditLinkTextEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.EditLinkTextEventArgs

See Also

EditLinkTextEventArgs Members


MindFusion.Diagramming.EditLinkTextEventArgs Members

EditLinkTextEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the EditLinkTextEventArgs event handlers.

The following tables list the members exposed by the EditLinkTextEventArgs type.

Public Constructors

Name | Description
EditLinkTextEventArgs | Initializes a new instance of the EditLinkTextEventArgs class.

Public Properties

Name | Description
Link | Gets the link whose text was edited.
NewText | Gets the new text.
OldText | Gets the text before in-place editing.

See Also

EditLinkTextEventArgs Class


MindFusion.Diagramming.EditLinkTextEventArgs Constructor

EditLinkTextEventArgs Constructor
[image]

Initializes a new instance of the EditLinkTextEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public EditLinkTextEventArgs (
DiagramLink link,
string oldText,
string newText
)

Visual Basic [image] Copy Code

Public Function EditLinkTextEventArgs ( _
link As DiagramLink, _
oldText As String, _
newText As String _
)

Parameters

link

oldText

newText

See Also

EditLinkTextEventArgs Class


MindFusion.Diagramming.EditLinkTextEventArgs Properties

EditLinkTextEventArgs Properties
[image]

Public Properties

Name | Description
Link | Gets the link whose text was edited.
NewText | Gets the new text.
OldText | Gets the text before in-place editing.

See Also

EditLinkTextEventArgs Class


MindFusion.Diagramming.EditLinkTextEventArgs.Link Property

EditLinkTextEventArgs.Link Property
[image]

Gets the link whose text was edited.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink Link { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Link As DiagramLink

Property Value

See Also

EditLinkTextEventArgs Members
EditLinkTextEventArgs Class


MindFusion.Diagramming.EditLinkTextEventArgs.NewText Property

EditLinkTextEventArgs.NewText Property
[image]

Gets the new text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string NewText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewText As String

Property Value

A string specifying the new text of the link.

See Also

EditLinkTextEventArgs Members
EditLinkTextEventArgs Class


MindFusion.Diagramming.EditLinkTextEventArgs.OldText Property

EditLinkTextEventArgs.OldText Property
[image]

Gets the text before in-place editing.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string OldText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldText As String

Property Value

A string specifying the old text of the link.

See Also

EditLinkTextEventArgs Members
EditLinkTextEventArgs Class


MindFusion.Diagramming.EditNodeTextEventArgs Class

EditNodeTextEventArgs Class
[image]

Contains the arguments passed to the NodeTextEdited event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class EditNodeTextEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class EditNodeTextEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.EditNodeTextEventArgs

See Also

EditNodeTextEventArgs Members


MindFusion.Diagramming.EditNodeTextEventArgs Members

EditNodeTextEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the NodeTextEdited event handlers.

The following tables list the members exposed by the EditNodeTextEventArgs type.

Public Constructors

Name | Description
EditNodeTextEventArgs | Initializes a new instance of the EditNodeTextEventArgs class.

Public Properties

Name | Description
NewText | Gets the text that has just been entered by the user.
Node | Gets the node whose text has been edited.
OldText | Gets the text that had been displayed in the node before the user edited it.

See Also

EditNodeTextEventArgs Class


MindFusion.Diagramming.EditNodeTextEventArgs Constructor

EditNodeTextEventArgs Constructor
[image]

Initializes a new instance of the EditNodeTextEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public EditNodeTextEventArgs (
DiagramNode node,
string oldText,
string newText
)

Visual Basic [image] Copy Code

Public Function EditNodeTextEventArgs ( _
node As DiagramNode, _
oldText As String, _
newText As String _
)

Parameters

node
The DiagramNode related to the event.
oldText

The old text of the node.

newText

The new text of the node.

See Also

EditNodeTextEventArgs Class


MindFusion.Diagramming.EditNodeTextEventArgs Properties

EditNodeTextEventArgs Properties
[image]

Public Properties

Name | Description
NewText | Gets the text that has just been entered by the user.
Node | Gets the node whose text has been edited.
OldText | Gets the text that had been displayed in the node before the user edited it.

See Also

EditNodeTextEventArgs Class


MindFusion.Diagramming.EditNodeTextEventArgs.NewText Property

EditNodeTextEventArgs.NewText Property
[image]

Gets the text that has just been entered by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string NewText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewText As String

Property Value

A string specifying the new text of the node.

See Also

EditNodeTextEventArgs Members
EditNodeTextEventArgs Class


MindFusion.Diagramming.EditNodeTextEventArgs.Node Property

EditNodeTextEventArgs.Node Property
[image]

Gets the node whose text has been edited.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Node { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Node As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

EditNodeTextEventArgs Members
EditNodeTextEventArgs Class


MindFusion.Diagramming.EditNodeTextEventArgs.OldText Property

EditNodeTextEventArgs.OldText Property
[image]

Gets the text that had been displayed in the node before the user edited it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string OldText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldText As String

Property Value

A string specifying the old text of the node.

See Also

EditNodeTextEventArgs Members
EditNodeTextEventArgs Class


MindFusion.Diagramming.ElementTemplate Class

ElementTemplate Class
[image]

The base class for the elements that can be used in Shape definitions. This is the parent class of specific element types, such as ArcTemplate, LineTemplate, RoundRectangleTemplate and BezierTemplate.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class ElementTemplate : IComparable

Visual Basic [image] Copy Code

Public MustInherit Class ElementTemplate
Implements IComparable

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ElementTemplate
MindFusion.Diagramming.ArcTemplate
MindFusion.Diagramming.BezierTemplate
MindFusion.Diagramming.LineTemplate
MindFusion.Diagramming.RoundRectangleTemplate

See Also

ElementTemplate Members


MindFusion.Diagramming.ElementTemplate Members

ElementTemplate Members
Constructors Properties Methods
[image]

The base class for the elements that can be used in Shape definitions. This is the parent class of specific element types, such as ArcTemplate, LineTemplate, RoundRectangleTemplate and BezierTemplate.

The following tables list the members exposed by the ElementTemplate type.

Protected Constructors

Name | Description
ElementTemplate | Initializes a new instance of the ElementTemplate class.

Public Properties

Name | Description
Color | Gest or sets the outline color of this element.
Width | Gets or sets the outline width of this element.

Public Methods

Name | Description
Clone | Creates an exact copy of this element.
CompareTo | IComparable.CompareTo implementation.

See Also

ElementTemplate Class


MindFusion.Diagramming.ElementTemplate Constructor

ElementTemplate Constructor
[image]

Initializes a new instance of the ElementTemplate class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected ElementTemplate ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

ElementTemplate Class


MindFusion.Diagramming.ElementTemplate Methods

ElementTemplate Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this element.
CompareTo | IComparable.CompareTo implementation.

See Also

ElementTemplate Class


MindFusion.Diagramming.ElementTemplate.Clone Method

ElementTemplate.Clone Method
[image]

Creates an exact copy of this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract Object Clone ()

Visual Basic [image] Copy Code

Public MustOverride Function Clone () As Object

Return Value

An instance of the appropriate type that represents the element clone.

See Also

ElementTemplate Members
ElementTemplate Class


MindFusion.Diagramming.ElementTemplate.CompareTo Method

ElementTemplate.CompareTo Method
[image]

IComparable.CompareTo implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int CompareTo (
Object obj
)

Visual Basic [image] Copy Code

Public Function CompareTo( _
obj As Object _
) As Integer

Parameters

obj

Return Value

See Also

ElementTemplate Members
ElementTemplate Class


MindFusion.Diagramming.ElementTemplate Properties

ElementTemplate Properties
[image]

Public Properties

Name | Description
Color | Gest or sets the outline color of this element.
Width | Gets or sets the outline width of this element.

See Also

ElementTemplate Class


MindFusion.Diagramming.ElementTemplate.Color Property

ElementTemplate.Color Property
[image]

Gest or sets the outline color of this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color Color { get; set; }

Visual Basic [image] Copy Code

Public Property Color As Color

Property Value

An instance of the Windows.UI.Xaml.Media.Color structure.

See Also

ElementTemplate Members
ElementTemplate Class


MindFusion.Diagramming.ElementTemplate.Width Property

ElementTemplate.Width Property
[image]

Gets or sets the outline width of this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Double

Property Value

A double value specifying the width of the outline.

See Also

ElementTemplate Members
ElementTemplate Class


MindFusion.Diagramming.ExpandButton Class

ExpandButton Class
[image]

Represents the expand/collapse button displayed beside Expandable nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ExpandButton : Button

Visual Basic [image] Copy Code

Public Class ExpandButton
Inherits Button

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
Windows.UI.Xaml.Controls.ContentControl
Windows.UI.Xaml.Controls.Primitives.ButtonBase
Windows.UI.Xaml.Controls.Button
MindFusion.Diagramming.ExpandButton

See Also

ExpandButton Members


MindFusion.Diagramming.ExpandButton Members

ExpandButton Members
Constructors Fields Properties Methods
[image]

Represents the expand/collapse button displayed beside Expandable nodes.

The following tables list the members exposed by the ExpandButton type.

Public Constructors

Name | Description
ExpandButton | Initializes a new instance of the ExpandButton class

Public Fields

Name | Description
ExpandedProperty | Identifies the Expanded dependancy property

Public Properties

Name | Description
Expanded | Gets or sets the visual state of the ExpandButton instance

Public Methods

Name | Description
OnApplyTemplate | Control.OnApplyTemplate override.

Protected Methods

Name | Description
UpdateStates | Sets the current VisualStates of this button.

See Also

ExpandButton Class


MindFusion.Diagramming.ExpandButton Fields

ExpandButton Fields
[image]

Public Fields

Name | Description
ExpandedProperty | Identifies the Expanded dependancy property

See Also

ExpandButton Class


MindFusion.Diagramming.ExpandButton.ExpandedProperty Field

ExpandButton.ExpandedProperty Field
[image]

Identifies the Expanded dependancy property

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ExpandedProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ExpandedProperty As DependencyProperty

See Also

ExpandButton Members
ExpandButton Class


MindFusion.Diagramming.ExpandButton Constructor

ExpandButton Constructor
[image]

Initializes a new instance of the ExpandButton class

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ExpandButton ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ExpandButton Class


MindFusion.Diagramming.ExpandButton Methods

ExpandButton Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | Control.OnApplyTemplate override.

Protected Methods

Name | Description
UpdateStates | Sets the current VisualStates of this button.

See Also

ExpandButton Class


MindFusion.Diagramming.ExpandButton.OnApplyTemplate Method

ExpandButton.OnApplyTemplate Method
[image]

Control.OnApplyTemplate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Overrides Sub OnApplyTemplate ()

See Also

ExpandButton Members
ExpandButton Class


MindFusion.Diagramming.ExpandButton.UpdateStates Method

ExpandButton.UpdateStates Method
[image]

Sets the current VisualStates of this button.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void UpdateStates (
bool useTransitions
)

Visual Basic [image] Copy Code

Protected Overridable Sub UpdateStates( _
useTransitions As Boolean _
)

Parameters

useTransitions

true to use visual transition between states; otherwise, false.

See Also

ExpandButton Members
ExpandButton Class


MindFusion.Diagramming.ExpandButton Properties

ExpandButton Properties
[image]

Public Properties

Name | Description
Expanded | Gets or sets the visual state of the ExpandButton instance

See Also

ExpandButton Class


MindFusion.Diagramming.ExpandButton.Expanded Property

ExpandButton.Expanded Property
[image]

Gets or sets the visual state of the ExpandButton instance

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Expanded { get; set; }

Visual Basic [image] Copy Code

Public Property Expanded As Boolean

Property Value

true if the tree branch associated with this button is expanded, otherwise false.

Remarks

Set to true to go to Expanded visual state; Set to false to go to Collapsed visual state

See Also

ExpandButton Members
ExpandButton Class


MindFusion.Diagramming.ExpandButtonAction Enumeration

ExpandButtonAction Enumeration
[image]

Specifies what action is triggered by the +/- buttons that are displayed near expandable nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum ExpandButtonAction

Visual Basic [image] Copy Code

Public Enum ExpandButtonAction

Members

Member name | Description
ExpandTreeBranch | Expands or collapses the children of a node in a tree-like diagram and raises the TreeExpanded or TreeCollapsed event.
RaiseEvents | Raises the ExpandButtonClicked event.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.ExpandButtonPosition Enumeration

ExpandButtonPosition Enumeration
[image]

Defines values that specify possible locations for expand/collapse buttons.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum ExpandButtonPosition

Visual Basic [image] Copy Code

Public Enum ExpandButtonPosition

Members

Member name | Description
OuterBottom | Place expand/collapse buttons at the bottom side of their nodes.
OuterLeft | Place expand/collapse buttons at the left-hand side of their nodes.
OuterLowerLeft | Place expand/collapse buttons at the lower-left corner of their nodes.
OuterLowerRight | Place expand/collapse buttons at the lower-right corner of their nodes.
OuterRight | Place expand/collapse buttons at the right-hand side of their nodes.
OuterTop | Place expand/collapse buttons at the top side of their nodes.
OuterUpperLeft | Place expand/collapse buttons at the upper-left corner of their nodes.
OuterUpperRight | Place expand/collapse buttons at the upper-right corner of their nodes.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.Factory Class

Factory Class
[image]

Provides shortcut methods for creating and adding instances of the standard WpfDiagram item types. Call the class methods through the Factory property of the Diagram class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Factory

Visual Basic [image] Copy Code

Public Class Factory

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Factory

See Also

Factory Members


MindFusion.Diagramming.Factory Members

Factory Members
Constructors Methods
[image]

Provides shortcut methods for creating and adding instances of the standard WpfDiagram item types. Call the class methods through the Factory property of the Diagram class.

The following tables list the members exposed by the Factory type.

Public Constructors

Name | Description
Factory | Initializes a new instance of the Factory class over the specified Diagram.

Public Methods

Name | Description
CreateContainerNode | Overloaded.
CreateDiagramLink | Overloaded.
CreateShapeNode | Overloaded.
CreateTableNode | Overloaded.
CreateTreeViewNode | Overloaded.

See Also

Factory Class


MindFusion.Diagramming.Factory Constructor

Factory Constructor
[image]

Initializes a new instance of the Factory class over the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Factory (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram

The Diagram object for which to create the new factory.

See Also

Factory Class


MindFusion.Diagramming.Factory Methods

Factory Methods
[image]

Public Methods

Name | Description
CreateContainerNode | Overloaded.
CreateDiagramLink | Overloaded.
CreateShapeNode | Overloaded.
CreateTableNode | Overloaded.
CreateTreeViewNode | Overloaded.

See Also

Factory Class


MindFusion.Diagramming.Factory.CreateContainerNode Method

Factory.CreateContainerNode Method
[image]

Overload List

Name | Description
Factory.CreateContainerNode (Double, Double, Double, Double) | Creates a new ContainerNode instance at the specified location with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateContainerNode (Point, Size) | Creates a new ContainerNode instance at the specified location with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateContainerNode (Rect) | Creates a new ContainerNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateContainerNode Method (Double, Double, Double, Double)

Factory.CreateContainerNode Method (Double, Double, Double, Double)
See Also
[image]

Creates a new ContainerNode instance at the specified location with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode CreateContainerNode (
double x,
double y,
double width,
double height
)

Visual Basic [image] Copy Code

Public Function CreateContainerNode( _
x As Double, _
y As Double, _
width As Double, _
height As Double _
) As ContainerNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

Return Value

The newly created ContainerNode instance.

Remarks

The method creates a container node at the position specified by x and y. The size of the container is set by width and height.

See Also

CreateContainerNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateContainerNode Method (Point, Size)

Factory.CreateContainerNode Method (Point, Size)
See Also
[image]

Creates a new ContainerNode instance at the specified location with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode CreateContainerNode (
Point location,
Size size
)

Visual Basic [image] Copy Code

Public Function CreateContainerNode( _
location As Point, _
size As Size _
) As ContainerNode

Parameters

location

The location of the ContainerNode object.

size

The size of the ContainerNode object.

Return Value

The newly created ContainerNode instance.

Remarks

The method creates a container node at the position specified by location. The size of the container is set by size.

See Also

CreateContainerNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateContainerNode Method (Rect)

Factory.CreateContainerNode Method (Rect)
See Also
[image]

Creates a new ContainerNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode CreateContainerNode (
Rect bounds
)

Visual Basic [image] Copy Code

Public Function CreateContainerNode( _
bounds As Rect _
) As ContainerNode

Parameters

bounds

The initial bounding rectangle of the new node.

Return Value

The newly created ContainerNode instance.

Remarks

The method creates a container node with the position and size specified by bounds.

See Also

CreateContainerNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateDiagramLink Method

Factory.CreateDiagramLink Method
[image]

Overload List

Name | Description
Factory.CreateDiagramLink (DiagramNode, DiagramNode) | Creates a new DiagramLink instance between the specified nodes and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (DiagramNode, Point) | Creates a new DiagramLink instance between the specified node and the specified point, and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (DiagramNode, TableNode, Int32) | Creates a new DiagramLink instance between the specified nodes and the specified table, and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (Point, DiagramNode) | Creates a new DiagramLink instance between the specified point and the specified node, and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (Point, Point) | Creates a new DiagramLink instance between the specified points and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (ShapeNode, Int32, ShapeNode, Int32) | Creates a new DiagramLink instance between the specified nodes and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (TableNode, Int32, DiagramNode) | Creates a new DiagramLink instance between the specified table and the specified node, and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (TableNode, Int32, TableNode, Int32) | Creates a new DiagramLink instance between the specified tables and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (TableNode, TableNode) | Creates a new DiagramLink instance between the specified tables and adds it to the Links collection of the underlying diagram.

See Also

Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateDiagramLink Method (DiagramNode, DiagramNode)

Factory.CreateDiagramLink Method (DiagramNode, DiagramNode)
See Also
[image]

Creates a new DiagramLink instance between the specified nodes and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
DiagramNode origin,
DiagramNode destination
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As DiagramNode, _
destination As DiagramNode _
) As DiagramLink

Parameters

origin

The origin node.

destination

The destination node.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the nodes specified by origin and destination.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateDiagramLink Method (DiagramNode, Point)

Factory.CreateDiagramLink Method (DiagramNode, Point)
See Also
[image]

Creates a new DiagramLink instance between the specified node and the specified point, and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
DiagramNode origin,
Point destination
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As DiagramNode, _
destination As Point _
) As DiagramLink

Parameters

origin

The origin node.

destination

The destination point.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the node specified by origin and the point specified by destination.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateDiagramLink Method (DiagramNode, TableNode, Int32)

Factory.CreateDiagramLink Method (DiagramNode, TableNode, Int32)
See Also
[image]

Creates a new DiagramLink instance between the specified nodes and the specified table, and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
DiagramNode origin,
TableNode destination,
int destRow
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As DiagramNode, _
destination As TableNode, _
destRow As Integer _
) As DiagramLink

Parameters

origin

The origin node.

destination

The destination node.

destRow

The zero-based index of the destination table row of the new link.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the node specified by origin and the table specified by destination.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateDiagramLink Method (Point, DiagramNode)

Factory.CreateDiagramLink Method (Point, DiagramNode)
See Also
[image]

Creates a new DiagramLink instance between the specified point and the specified node, and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
Point origin,
DiagramNode destination
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As Point, _
destination As DiagramNode _
) As DiagramLink

Parameters

origin

The origin point.

destination

The destination node.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the point specified by origin and the node specified by destination.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateDiagramLink Method (Point, Point)

Factory.CreateDiagramLink Method (Point, Point)
See Also
[image]

Creates a new DiagramLink instance between the specified points and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
Point origin,
Point destination
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As Point, _
destination As Point _
) As DiagramLink

Parameters

origin

The origin point.

destination

The destination point.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the points specified by origin and destination.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateDiagramLink Method (ShapeNode, Int32, ShapeNode, Int32)

Factory.CreateDiagramLink Method (ShapeNode, Int32, ShapeNode, Int32)
See Also
[image]

Creates a new DiagramLink instance between the specified nodes and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
ShapeNode origin,
int originAnchor,
ShapeNode destination,
int destAnchor
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As ShapeNode, _
originAnchor As Integer, _
destination As ShapeNode, _
destAnchor As Integer _
) As DiagramLink

Parameters

origin

The origin node.

originAnchor

The index of an anchor point within the origin node's AnchorPattern.

destination

The destination node.

destAnchor

The index of an anchor point within the destination node's AnchorPattern.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the shape nodes specified by origin and destination.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateDiagramLink Method (TableNode, Int32, DiagramNode)

Factory.CreateDiagramLink Method (TableNode, Int32, DiagramNode)
See Also
[image]

Creates a new DiagramLink instance between the specified table and the specified node, and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
TableNode origin,
int originRow,
DiagramNode destination
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As TableNode, _
originRow As Integer, _
destination As DiagramNode _
) As DiagramLink

Parameters

origin

The origin node.

originRow

The zero-based index of the destination table row of the new link.

destination

The destination node.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the table specified by origin and the node specified by destination.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateDiagramLink Method (TableNode, Int32, TableNode, Int32)

Factory.CreateDiagramLink Method (TableNode, Int32, TableNode, Int32)
See Also
[image]

Creates a new DiagramLink instance between the specified tables and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
TableNode origin,
int originRow,
TableNode destination,
int destRow
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As TableNode, _
originRow As Integer, _
destination As TableNode, _
destRow As Integer _
) As DiagramLink

Parameters

origin

The origin node.

originRow

The zero-based index of the origin table row of the new link.

destination

The destination node.

destRow

The zero-based index of the destination table row of the new link.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the tables specified by origin and destination.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateDiagramLink Method (TableNode, TableNode)

Factory.CreateDiagramLink Method (TableNode, TableNode)
See Also
[image]

Creates a new DiagramLink instance between the specified tables and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
TableNode origin,
TableNode destination
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As TableNode, _
destination As TableNode _
) As DiagramLink

Parameters

origin

The origin node.

destination

The destination node.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the tables specified by origin and destination.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateShapeNode Method

Factory.CreateShapeNode Method
[image]

Overload List

Name | Description
Factory.CreateShapeNode (Double, Double, Double, Double) | Creates a new ShapeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateShapeNode (Double, Double, Double, Double, Shape) | Creates a new ShapeNode instance at the specified position with the specified size and shape, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateShapeNode (Point, Size) | Creates a new ShapeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateShapeNode (Point, Size, Shape) | Creates a new ShapeNode instance at the specified position with the specified size and shape, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateShapeNode (Rect) | Creates a new ShapeNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.
Factory.CreateShapeNode (Rect, Shape) | Creates a new ShapeNode instance with the specified dimensions and shape, and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateShapeNode Method (Double, Double, Double, Double)

Factory.CreateShapeNode Method (Double, Double, Double, Double)
See Also
[image]

Creates a new ShapeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode CreateShapeNode (
double x,
double y,
double width,
double height
)

Visual Basic [image] Copy Code

Public Function CreateShapeNode( _
x As Double, _
y As Double, _
width As Double, _
height As Double _
) As ShapeNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node at the position specified by x and y. The size of the node is set by width and height.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateShapeNode Method (Double, Double, Double, Double, Shape)

Factory.CreateShapeNode Method (Double, Double, Double, Double, Shape)
See Also
[image]

Creates a new ShapeNode instance at the specified position with the specified size and shape, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode CreateShapeNode (
double x,
double y,
double width,
double height,
Shape shape
)

Visual Basic [image] Copy Code

Public Function CreateShapeNode( _
x As Double, _
y As Double, _
width As Double, _
height As Double, _
shape As Shape _
) As ShapeNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

shape

The shape of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node at the position specified by x and y. The size of the node is set by width and height. The shape of the new node is specified by shape.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateShapeNode Method (Point, Size)

Factory.CreateShapeNode Method (Point, Size)
See Also
[image]

Creates a new ShapeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode CreateShapeNode (
Point location,
Size size
)

Visual Basic [image] Copy Code

Public Function CreateShapeNode( _
location As Point, _
size As Size _
) As ShapeNode

Parameters

location

The position of the new node.

size

The size of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node at the position specified by location. The size of the node is set by size.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateShapeNode Method (Point, Size, Shape)

Factory.CreateShapeNode Method (Point, Size, Shape)
See Also
[image]

Creates a new ShapeNode instance at the specified position with the specified size and shape, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode CreateShapeNode (
Point location,
Size size,
Shape shape
)

Visual Basic [image] Copy Code

Public Function CreateShapeNode( _
location As Point, _
size As Size, _
shape As Shape _
) As ShapeNode

Parameters

location

The position of the new node.

size

The size of the new node.

shape

The shape of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node at the position specified by location. The size of the node is set by size. The shape of the new node is specified by shape.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateShapeNode Method (Rect)

Factory.CreateShapeNode Method (Rect)
See Also
[image]

Creates a new ShapeNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode CreateShapeNode (
Rect bounds
)

Visual Basic [image] Copy Code

Public Function CreateShapeNode( _
bounds As Rect _
) As ShapeNode

Parameters

bounds

The bounding rectangle of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node with dimensions specified by bounds.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateShapeNode Method (Rect, Shape)

Factory.CreateShapeNode Method (Rect, Shape)
See Also
[image]

Creates a new ShapeNode instance with the specified dimensions and shape, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode CreateShapeNode (
Rect bounds,
Shape shape
)

Visual Basic [image] Copy Code

Public Function CreateShapeNode( _
bounds As Rect, _
shape As Shape _
) As ShapeNode

Parameters

bounds

The bounding rectangle of the new node.

shape

The shape of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node with dimensions specified by bounds. The shape of the new node is specified by shape.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateTableNode Method

Factory.CreateTableNode Method
[image]

Overload List

Name | Description
Factory.CreateTableNode (Double, Double, Double, Double) | Creates a new TableNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTableNode (Double, Double, Double, Double, Int32, Int32) | Creates a new TableNode instance at the specified position with the specified size and the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTableNode (Point, Size) | Creates a new TableNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTableNode (Point, Size, Int32, Int32) | Creates a new TableNode instance at the specified position with the specified size and with the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTableNode (Rect) | Creates a new TableNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTableNode (Rect, Int32, Int32) | Creates a new TableNode instance with the specified dimensions and with the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateTableNode Method (Double, Double, Double, Double)

Factory.CreateTableNode Method (Double, Double, Double, Double)
See Also
[image]

Creates a new TableNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode CreateTableNode (
double x,
double y,
double width,
double height
)

Visual Basic [image] Copy Code

Public Function CreateTableNode( _
x As Double, _
y As Double, _
width As Double, _
height As Double _
) As TableNode

Parameters

x

The x-coordinate of the upper-left corner of the new table.

y

The y-coordinate of the upper-left corner of the new table.

width

The width of the new table.

height

The height of the new table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node at the position specified by x and y. The size of the node is set by width and height.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateTableNode Method (Double, Double, Double, Double, Int32, Int32)

Factory.CreateTableNode Method (Double, Double, Double, Double, Int32, Int32)
See Also
[image]

Creates a new TableNode instance at the specified position with the specified size and the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode CreateTableNode (
double x,
double y,
double width,
double height,
int columns,
int rows
)

Visual Basic [image] Copy Code

Public Function CreateTableNode( _
x As Double, _
y As Double, _
width As Double, _
height As Double, _
columns As Integer, _
rows As Integer _
) As TableNode

Parameters

x

The x-coordinate of the upper-left corner of the new table.

y

The y-coordinate of the upper-left corner of the new table.

width

The width if the new table.

height

The height of the new table.

columns

The initial number of columns in the table.

rows

The initial number of rows in the table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node at the position specified by x and y. The size of the node is set by width and height. The initial number of columns and rows in the table is specified by columns and rows respectively.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateTableNode Method (Point, Size)

Factory.CreateTableNode Method (Point, Size)
See Also
[image]

Creates a new TableNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode CreateTableNode (
Point location,
Size size
)

Visual Basic [image] Copy Code

Public Function CreateTableNode( _
location As Point, _
size As Size _
) As TableNode

Parameters

location

The position of the new table.

size

The size of the new table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node at the position specified by location. The size of the node is set by size.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateTableNode Method (Point, Size, Int32, Int32)

Factory.CreateTableNode Method (Point, Size, Int32, Int32)
See Also
[image]

Creates a new TableNode instance at the specified position with the specified size and with the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode CreateTableNode (
Point location,
Size size,
int columns,
int rows
)

Visual Basic [image] Copy Code

Public Function CreateTableNode( _
location As Point, _
size As Size, _
columns As Integer, _
rows As Integer _
) As TableNode

Parameters

location

The position of the new table.

size

The size of the new table.

columns

The initial number of columns in the table.

rows

The initial number of rows in the table.

Return Value

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateTableNode Method (Rect)

Factory.CreateTableNode Method (Rect)
See Also
[image]

Creates a new TableNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode CreateTableNode (
Rect bounds
)

Visual Basic [image] Copy Code

Public Function CreateTableNode( _
bounds As Rect _
) As TableNode

Parameters

bounds

The bounding rectangle of the new table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node with dimensions specified by bounds.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateTableNode Method (Rect, Int32, Int32)

Factory.CreateTableNode Method (Rect, Int32, Int32)
See Also
[image]

Creates a new TableNode instance with the specified dimensions and with the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode CreateTableNode (
Rect bounds,
int columns,
int rows
)

Visual Basic [image] Copy Code

Public Function CreateTableNode( _
bounds As Rect, _
columns As Integer, _
rows As Integer _
) As TableNode

Parameters

bounds

The bounding rectangle of the new table.

columns

The initial number of columns in the table.

rows

The initial number of rows in the table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node with dimensions specified by bounds. The initial number of columns and rows in the table is specified by columns and rows respectively.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateTreeViewNode Method

Factory.CreateTreeViewNode Method
[image]

Overload List

Name | Description
Factory.CreateTreeViewNode (Double, Double, Double, Double) | Creates a new TreeViewNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTreeViewNode (Point, Size) | Creates a new TreeViewNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTreeViewNode (Rect) | Creates a new TreeViewNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateTreeViewNode Method (Double, Double, Double, Double)

Factory.CreateTreeViewNode Method (Double, Double, Double, Double)
See Also
[image]

Creates a new TreeViewNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewNode CreateTreeViewNode (
double x,
double y,
double width,
double height
)

Visual Basic [image] Copy Code

Public Function CreateTreeViewNode( _
x As Double, _
y As Double, _
width As Double, _
height As Double _
) As TreeViewNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

Return Value

The newly created TreeViewNode instance.

Remarks

The method creates a treeview node at the position specified by x and y. The size of the node is set by width and height.

See Also

CreateTreeViewNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateTreeViewNode Method (Point, Size)

Factory.CreateTreeViewNode Method (Point, Size)
See Also
[image]

Creates a new TreeViewNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewNode CreateTreeViewNode (
Point location,
Size size
)

Visual Basic [image] Copy Code

Public Function CreateTreeViewNode( _
location As Point, _
size As Size _
) As TreeViewNode

Parameters

location

The position of the new node.

size

The size of the new node.

Return Value

The newly created TreeViewNode instance.

Remarks

The method creates a treeview node at the position specified by location. The size of the node is set by size.

See Also

CreateTreeViewNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateTreeViewNode Method (Rect)

Factory.CreateTreeViewNode Method (Rect)
See Also
[image]

Creates a new TreeViewNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewNode CreateTreeViewNode (
Rect bounds
)

Visual Basic [image] Copy Code

Public Function CreateTreeViewNode( _
bounds As Rect _
) As TreeViewNode

Parameters

bounds

The bounding rectangle of the new node.

Return Value

The newly created TreeViewNode instance.

Remarks

The method creates a treeview node with dimensions specified by bounds.

See Also

CreateTreeViewNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.FilledRectangle Class

FilledRectangle Class
[image]

Control that is displayed in ControlNodes by default to make them visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class FilledRectangle : Grid

Visual Basic [image] Copy Code

Public Class FilledRectangle
Inherits Grid

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Panel
Windows.UI.Xaml.Controls.Grid
MindFusion.Diagramming.FilledRectangle

See Also

FilledRectangle Members


MindFusion.Diagramming.FilledRectangle Members

FilledRectangle Members
Constructors
[image]

Control that is displayed in ControlNodes by default to make them visible.

The following tables list the members exposed by the FilledRectangle type.

Public Constructors

Name | Description
FilledRectangle | Initializes a new instance of the FilledRectangle class.

See Also

FilledRectangle Class


MindFusion.Diagramming.FilledRectangle Constructor

FilledRectangle Constructor
[image]

Initializes a new instance of the FilledRectangle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FilledRectangle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

FilledRectangle Class


MindFusion.Diagramming.FoldButton Class

FoldButton Class
[image]

Represents the fold / unfold button of containers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class FoldButton : Button

Visual Basic [image] Copy Code

Public Class FoldButton
Inherits Button

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
Windows.UI.Xaml.Controls.ContentControl
Windows.UI.Xaml.Controls.Primitives.ButtonBase
Windows.UI.Xaml.Controls.Button
MindFusion.Diagramming.FoldButton

See Also

FoldButton Members


MindFusion.Diagramming.FoldButton Members

FoldButton Members
Constructors Fields Properties Methods
[image]

Represents the fold / unfold button of containers.

The following tables list the members exposed by the FoldButton type.

Public Constructors

Name | Description
FoldButton | Initializes a new instance of the FoldButton class

Public Fields

Name | Description
FoldedProperty | Identifies the Folded dependancy property

Public Properties

Name | Description
Folded | Gets or sets the visual state of the FoldButton instance

Public Methods

Name | Description
OnApplyTemplate | Overrides Control.OnApplyTemplate.

Protected Methods

Name | Description
UpdateStates | Sets the current VisualStates of this button.

See Also

FoldButton Class


MindFusion.Diagramming.FoldButton Fields

FoldButton Fields
[image]

Public Fields

Name | Description
FoldedProperty | Identifies the Folded dependancy property

See Also

FoldButton Class


MindFusion.Diagramming.FoldButton.FoldedProperty Field

FoldButton.FoldedProperty Field
[image]

Identifies the Folded dependancy property

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FoldedProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FoldedProperty As DependencyProperty

See Also

FoldButton Members
FoldButton Class


MindFusion.Diagramming.FoldButton Constructor

FoldButton Constructor
[image]

Initializes a new instance of the FoldButton class

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FoldButton ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

FoldButton Class


MindFusion.Diagramming.FoldButton Methods

FoldButton Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | Overrides Control.OnApplyTemplate.

Protected Methods

Name | Description
UpdateStates | Sets the current VisualStates of this button.

See Also

FoldButton Class


MindFusion.Diagramming.FoldButton.OnApplyTemplate Method

FoldButton.OnApplyTemplate Method
[image]

Overrides Control.OnApplyTemplate.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

FoldButton Members
FoldButton Class


MindFusion.Diagramming.FoldButton.UpdateStates Method

FoldButton.UpdateStates Method
[image]

Sets the current VisualStates of this button.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void UpdateStates (
bool useTransitions
)

Visual Basic [image] Copy Code

Protected Overridable Sub UpdateStates( _
useTransitions As Boolean _
)

Parameters

useTransitions

true to use visual transition between states; otherwise, false.

See Also

FoldButton Members
FoldButton Class


MindFusion.Diagramming.FoldButton Properties

FoldButton Properties
[image]

Public Properties

Name | Description
Folded | Gets or sets the visual state of the FoldButton instance

See Also

FoldButton Class


MindFusion.Diagramming.FoldButton.Folded Property

FoldButton.Folded Property
[image]

Gets or sets the visual state of the FoldButton instance

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Folded { get; set; }

Visual Basic [image] Copy Code

Public Property Folded As Boolean

Property Value

Remarks

Set to true to go to Folded visual tate; Set to false to go to Unfolded visual state

See Also

FoldButton Members
FoldButton Class


MindFusion.Diagramming.GeometryCloneConverter Class

GeometryCloneConverter Class
[image]

Implements cloning of RectangleGeometry objects, required because geometries cannot be shared by multiple bindings.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class GeometryCloneConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class GeometryCloneConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.GeometryCloneConverter

See Also

GeometryCloneConverter Members


MindFusion.Diagramming.GeometryCloneConverter Members

GeometryCloneConverter Members
Constructors Methods
[image]

Implements cloning of RectangleGeometry objects, required because geometries cannot be shared by multiple bindings.

The following tables list the members exposed by the GeometryCloneConverter type.

Public Constructors

Name | Description
GeometryCloneConverter |

Public Methods

Name | Description
Convert | Implements IValueConverter.Convert.
ConvertBack | Implements IValueConverter.ConvertBack.

See Also

GeometryCloneConverter Class


MindFusion.Diagramming.GeometryCloneConverter Constructor

GeometryCloneConverter Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GeometryCloneConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

GeometryCloneConverter Class


MindFusion.Diagramming.GeometryCloneConverter Methods

GeometryCloneConverter Methods
[image]

Public Methods

Name | Description
Convert | Implements IValueConverter.Convert.
ConvertBack | Implements IValueConverter.ConvertBack.

See Also

GeometryCloneConverter Class


MindFusion.Diagramming.GeometryCloneConverter.Convert Method

GeometryCloneConverter.Convert Method
[image]

Implements IValueConverter.Convert.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

targetType

parameter

culture

Return Value

See Also

GeometryCloneConverter Members
GeometryCloneConverter Class


MindFusion.Diagramming.GeometryCloneConverter.ConvertBack Method

GeometryCloneConverter.ConvertBack Method
[image]

Implements IValueConverter.ConvertBack.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

targetType

parameter

culture

Return Value

See Also

GeometryCloneConverter Members
GeometryCloneConverter Class


MindFusion.Diagramming.Granularity Enumeration

Granularity Enumeration
[image]

Specifies the granularity of the obstacles map generated by QuickRouter.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum Granularity

Visual Basic [image] Copy Code

Public Enum Granularity

Members

Member name | Description
CoarseGrained | Merge map tiles if possible to create a coarse-grained map. The fewer tiles in the map lead to faster path-finding.
FineGrained | Reserved for future use.
Normal | Use the map tiles found by the initial division algorithm.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.GraphicsUnit Class

GraphicsUnit Class
[image]

Specifies units of measure for a given data.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class GraphicsUnit

Visual Basic [image] Copy Code

Public Class GraphicsUnit

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.GraphicsUnit

See Also

GraphicsUnit Members


MindFusion.Diagramming.GraphicsUnit Members

GraphicsUnit Members
Constructors Fields Properties Methods
[image]

Specifies units of measure for a given data.

The following tables list the members exposed by the GraphicsUnit type.

Public Constructors

Name | Description
GraphicsUnit | Initializes a new instance of the GraphicsUnit class with the specified base resolution.

Public Fields

Name | Description
Display | Specifies the unit of measure of the display device. Typically pixels for video displays, and 1/100 inch for printers.
Document | Specifies the document unit (1/300 inch) as the unit of measure.
Inch | Specifies the inch as the unit of measure.
Millimeter | Specifies the millimeter as the unit of measure.
Pixel | Specifies a device pixel as the unit of measure.
Point | Specifies a printer's point (1/72 inch) as the unit of measure.
World | Specifies the world coordinate system unit as the unit of measure.
WpfPoint | Specifies a device-independent pixel as the unit of measure.

Public Properties

Name | Description
Id | The unit id
Name | The unit Name

Protected Properties

Name | Description
UnitsPerInch | Gets the base resolution of this GraphicsUnit object.

Public Methods

Name | Description
Convert | Overloaded.
FromId | Overloaded.
ToString | Object.ToString override.

See Also

GraphicsUnit Class


MindFusion.Diagramming.GraphicsUnit Fields

GraphicsUnit Fields
[image]

Public Fields

Name | Description
Display | Specifies the unit of measure of the display device. Typically pixels for video displays, and 1/100 inch for printers.
Document | Specifies the document unit (1/300 inch) as the unit of measure.
Inch | Specifies the inch as the unit of measure.
Millimeter | Specifies the millimeter as the unit of measure.
Pixel | Specifies a device pixel as the unit of measure.
Point | Specifies a printer's point (1/72 inch) as the unit of measure.
World | Specifies the world coordinate system unit as the unit of measure.
WpfPoint | Specifies a device-independent pixel as the unit of measure.

See Also

GraphicsUnit Class


MindFusion.Diagramming.GraphicsUnit.Display Field

GraphicsUnit.Display Field
[image]

Specifies the unit of measure of the display device. Typically pixels for video displays, and 1/100 inch for printers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly GraphicsUnit Display

Visual Basic [image] Copy Code

Public Shared ReadOnly Display As GraphicsUnit

See Also

GraphicsUnit Members
GraphicsUnit Class


MindFusion.Diagramming.GraphicsUnit.Document Field

GraphicsUnit.Document Field
[image]

Specifies the document unit (1/300 inch) as the unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly GraphicsUnit Document

Visual Basic [image] Copy Code

Public Shared ReadOnly Document As GraphicsUnit

See Also

GraphicsUnit Members
GraphicsUnit Class


MindFusion.Diagramming.GraphicsUnit.Inch Field

GraphicsUnit.Inch Field
[image]

Specifies the inch as the unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly GraphicsUnit Inch

Visual Basic [image] Copy Code

Public Shared ReadOnly Inch As GraphicsUnit

See Also

GraphicsUnit Members
GraphicsUnit Class


MindFusion.Diagramming.GraphicsUnit.Millimeter Field

GraphicsUnit.Millimeter Field
[image]

Specifies the millimeter as the unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly GraphicsUnit Millimeter

Visual Basic [image] Copy Code

Public Shared ReadOnly Millimeter As GraphicsUnit

See Also

GraphicsUnit Members
GraphicsUnit Class


MindFusion.Diagramming.GraphicsUnit.Pixel Field

GraphicsUnit.Pixel Field
[image]

Specifies a device pixel as the unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly GraphicsUnit Pixel

Visual Basic [image] Copy Code

Public Shared ReadOnly Pixel As GraphicsUnit

See Also

GraphicsUnit Members
GraphicsUnit Class


MindFusion.Diagramming.GraphicsUnit.Point Field

GraphicsUnit.Point Field
[image]

Specifies a printer's point (1/72 inch) as the unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly GraphicsUnit Point

Visual Basic [image] Copy Code

Public Shared ReadOnly Point As GraphicsUnit

See Also

GraphicsUnit Members
GraphicsUnit Class


MindFusion.Diagramming.GraphicsUnit.World Field

GraphicsUnit.World Field
[image]

Specifies the world coordinate system unit as the unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly GraphicsUnit World

Visual Basic [image] Copy Code

Public Shared ReadOnly World As GraphicsUnit

See Also

GraphicsUnit Members
GraphicsUnit Class


MindFusion.Diagramming.GraphicsUnit.WpfPoint Field

GraphicsUnit.WpfPoint Field
[image]

Specifies a device-independent pixel as the unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly GraphicsUnit WpfPoint

Visual Basic [image] Copy Code

Public Shared ReadOnly WpfPoint As GraphicsUnit

See Also

GraphicsUnit Members
GraphicsUnit Class


MindFusion.Diagramming.GraphicsUnit Constructor

GraphicsUnit Constructor
[image]

Initializes a new instance of the GraphicsUnit class with the specified base resolution.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GraphicsUnit (
double unitsPerInch,
string name
)

Visual Basic [image] Copy Code

Public New ( _
unitsPerInch As Double, _
name As String _
)

Parameters

unitsPerInch

name

See Also

GraphicsUnit Class


MindFusion.Diagramming.GraphicsUnit Methods

GraphicsUnit Methods
[image]

Public Methods

Name | Description
Convert | Overloaded.
FromId | Overloaded.
ToString | Object.ToString override.

See Also

GraphicsUnit Class


MindFusion.Diagramming.GraphicsUnit.Convert Method

GraphicsUnit.Convert Method
[image]

Overload List

Name | Description
GraphicsUnit.Convert (Double, GraphicsUnit) | Converts amount from this unit to specified unit.
GraphicsUnit.Convert (Point, GraphicsUnit) | Convenience method for converting points to specified units
GraphicsUnit.Convert (Rect, GraphicsUnit) | Convenience method for converting Rect to specified units

See Also

GraphicsUnit Members
GraphicsUnit Class


MindFusion.Diagramming.GraphicsUnit.Convert Method (Double, GraphicsUnit)

GraphicsUnit.Convert Method (Double, GraphicsUnit)
See Also
[image]

Converts amount from this unit to specified unit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Convert (
double amount,
GraphicsUnit targetUnit
)

Visual Basic [image] Copy Code

Public Function Convert( _
amount As Double, _
targetUnit As GraphicsUnit _
) As Double

Parameters

amount

targetUnit

Return Value

See Also

Convert Method Overload List
GraphicsUnit Members
GraphicsUnit Class


MindFusion.Diagramming.GraphicsUnit.Convert Method (Point, GraphicsUnit)

GraphicsUnit.Convert Method (Point, GraphicsUnit)
See Also
[image]

Convenience method for converting points to specified units

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point Convert (
Point p,
GraphicsUnit targetUnit
)

Visual Basic [image] Copy Code

Public Function Convert( _
p As Point, _
targetUnit As GraphicsUnit _
) As Point

Parameters

p

targetUnit

Return Value

See Also

Convert Method Overload List
GraphicsUnit Members
GraphicsUnit Class


MindFusion.Diagramming.GraphicsUnit.Convert Method (Rect, GraphicsUnit)

GraphicsUnit.Convert Method (Rect, GraphicsUnit)
See Also
[image]

Convenience method for converting Rect to specified units

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect Convert (
Rect r,
GraphicsUnit targetUnit
)

Visual Basic [image] Copy Code

Public Function Convert( _
r As Rect, _
targetUnit As GraphicsUnit _
) As Rect

Parameters

r

targetUnit

Return Value

See Also

Convert Method Overload List
GraphicsUnit Members
GraphicsUnit Class


MindFusion.Diagramming.GraphicsUnit.FromId Method

GraphicsUnit.FromId Method
[image]

Overload List

Name | Description
GraphicsUnit.FromId (Int32, Diagram) | Returns a GraphicsUnit from its integer id. Parameter diagram is used if the id denotes the current diagram id (GraphicsUnit.World)
GraphicsUnit.FromId (Int32, GraphicsUnit) | Returns the GraphicsUnit that has the specified id

See Also

GraphicsUnit Members
GraphicsUnit Class


MindFusion.Diagramming.GraphicsUnit.FromId Method (Int32, Diagram)

GraphicsUnit.FromId Method (Int32, Diagram)
See Also
[image]

Returns a GraphicsUnit from its integer id. Parameter diagram is used if the id denotes the current diagram id (GraphicsUnit.World)

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static GraphicsUnit FromId (
int id,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Shared Function FromId( _
id As Integer, _
diagram As Diagram _
) As GraphicsUnit

Parameters

id

diagram

Return Value

See Also

FromId Method Overload List
GraphicsUnit Members
GraphicsUnit Class


MindFusion.Diagramming.GraphicsUnit.FromId Method (Int32, GraphicsUnit)

GraphicsUnit.FromId Method (Int32, GraphicsUnit)
See Also
[image]

Returns the GraphicsUnit that has the specified id

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static GraphicsUnit FromId (
int id,
GraphicsUnit measureUnit
)

Visual Basic [image] Copy Code

Public Shared Function FromId( _
id As Integer, _
measureUnit As GraphicsUnit _
) As GraphicsUnit

Parameters

id

measureUnit

Return Value

See Also

FromId Method Overload List
GraphicsUnit Members
GraphicsUnit Class


MindFusion.Diagramming.GraphicsUnit.ToString Method

GraphicsUnit.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

See Also

GraphicsUnit Members
GraphicsUnit Class


MindFusion.Diagramming.GraphicsUnit Properties

GraphicsUnit Properties
[image]

Public Properties

Name | Description
Id | The unit id
Name | The unit Name

Protected Properties

Name | Description
UnitsPerInch | Gets the base resolution of this GraphicsUnit object.

See Also

GraphicsUnit Class


MindFusion.Diagramming.GraphicsUnit.Id Property

GraphicsUnit.Id Property
[image]

The unit id

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Id { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Id As Integer

Property Value

See Also

GraphicsUnit Members
GraphicsUnit Class


MindFusion.Diagramming.GraphicsUnit.Name Property

GraphicsUnit.Name Property
[image]

The unit Name

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Name { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Name As String

Property Value

See Also

GraphicsUnit Members
GraphicsUnit Class


MindFusion.Diagramming.GraphicsUnit.UnitsPerInch Property

GraphicsUnit.UnitsPerInch Property
[image]

Gets the base resolution of this GraphicsUnit object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual double UnitsPerInch { get; }

Visual Basic [image] Copy Code

Protected Overridable ReadOnly Property UnitsPerInch As Double

Property Value

See Also

GraphicsUnit Members
GraphicsUnit Class


MindFusion.Diagramming.GridRouter Class

GridRouter Class
Remarks See Also
[image]

Implements a link routing algorithm that uses a grid to represent the free and occupied regions in the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class GridRouter : ILinkRouter

Visual Basic [image] Copy Code

Public Class GridRouter
Implements ILinkRouter

Remarks

To use this class for link routing simply assign its instance to the LinkRouter property of the Diagram class.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.GridRouter

See Also

GridRouter Members


MindFusion.Diagramming.GridRouter Members

GridRouter Members
Constructors Properties Methods
[image]

Implements a link routing algorithm that uses a grid to represent the free and occupied regions in the diagram.

The following tables list the members exposed by the GridRouter type.

Public Constructors

Name | Description
GridRouter |

Public Properties

Name | Description
Diagram | Gets or sets the diagram this router is associated with.

Public Methods

Name | Description
Resume | Implements ILinkRouter.Resume.
RouteLink | Implements ILinkRouter.RouteLink.
RouteLinks | Implements ILinkRouter.RouteLinks.
Suspend | Implements ILinkRouter.Suspend.

See Also

GridRouter Class


MindFusion.Diagramming.GridRouter Constructor

GridRouter Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GridRouter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

GridRouter Class


MindFusion.Diagramming.GridRouter Methods

GridRouter Methods
[image]

Public Methods

Name | Description
Resume | Implements ILinkRouter.Resume.
RouteLink | Implements ILinkRouter.RouteLink.
RouteLinks | Implements ILinkRouter.RouteLinks.
Suspend | Implements ILinkRouter.Suspend.

See Also

GridRouter Class


MindFusion.Diagramming.GridRouter.Resume Method

GridRouter.Resume Method
[image]

Implements ILinkRouter.Resume.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Resume (
bool routeDeferredLinks
)

Visual Basic [image] Copy Code

Public Sub Resume( _
routeDeferredLinks As Boolean _
)

Parameters

routeDeferredLinks
true if the links should be routed, otherwise false.

See Also

GridRouter Members
GridRouter Class


MindFusion.Diagramming.GridRouter.RouteLink Method

GridRouter.RouteLink Method
[image]

Implements ILinkRouter.RouteLink.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool RouteLink (
DiagramLink link
)

Visual Basic [image] Copy Code

Public Overridable Function RouteLink ( _
link As DiagramLink _
) As Boolean

Parameters

link
The DiagramLink to route.

Return Value

true if a path has been found successfully, otherwise false.

See Also

GridRouter Members
GridRouter Class


MindFusion.Diagramming.GridRouter.RouteLinks Method

GridRouter.RouteLinks Method
[image]

Implements ILinkRouter.RouteLinks.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void RouteLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Public Overridable Sub RouteLinks ( _
links As DiagramLinkCollection _
)

Parameters

links
A list of DiagramLink objects that should be routed.

See Also

GridRouter Members
GridRouter Class


MindFusion.Diagramming.GridRouter.Suspend Method

GridRouter.Suspend Method
[image]

Implements ILinkRouter.Suspend.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Suspend ()

Visual Basic [image] Copy Code

Public Sub Suspend ()

See Also

GridRouter Members
GridRouter Class


MindFusion.Diagramming.GridRouter Properties

GridRouter Properties
[image]

Public Properties

Name | Description
Diagram | Gets or sets the diagram this router is associated with.

See Also

GridRouter Class


MindFusion.Diagramming.GridRouter.Diagram Property

GridRouter.Diagram Property
[image]

Gets or sets the diagram this router is associated with.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Diagram Diagram { get; set; }

Visual Basic [image] Copy Code

Public Property Diagram As Diagram

Property Value

See Also

GridRouter Members
GridRouter Class


MindFusion.Diagramming.GridStyle Enumeration

GridStyle Enumeration
[image]

Defines values that specify the visual style of the alignment grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum GridStyle

Visual Basic [image] Copy Code

Public Enum GridStyle

Members

Member name | Description
Crosses | The grid is painted as a matrix of crosses.
Lines | The grid is represented as a series of crossing horizontal and vertical lines.
Points | The grid is painted as a matrix of points.

Remarks

Members of this numeration can be assigned to the GridStyle property of the Diagram class.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.HandlesStyle Enumeration

HandlesStyle Enumeration
[image]

Enumerates possible visual styles for frames that are drawn around selected nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum HandlesStyle

Visual Basic [image] Copy Code

Public Enum HandlesStyle

Members

Member name | Description
Custom | WpfDiagram raises the DrawHandles and HitTestAdjustmentHandles events to let your application perform custom drawing and hit testing of selection handles.
DashFrame | If selected, a node is drawn with a dashed frame. The frame enables resizing the node. The center of the node allows moving it and the edge area enables creating links.
EasyMove | Any point of the interior of a node enables moving the node, except a small area in the center that allows creating links. Best used with ModificationStart set to AutoHandles.
HatchFrame | If selected, the object is drawn with hatched frame. Modifications can be done as with DashFrame.
HatchHandles | If selected, a node is drawn with both hatched frame and modification handles. The frame enable moving the node, and the handles enable resizing. Links are created from any point of the interior.
HatchHandles2 | Looks like HatchHandles, but allows moving the node from the interior area. Links are created from the points near the edge.
HatchHandles3 | Behaves like HatchHandles2, but paints the selection frame using a denser brush pattern.
Invisible | There is no visible difference between selected and unselected node.
InvisibleMove | There aren't any selection handles displayed. The selected node can be only moved, but not resized.
MoveOnly | If a node is selected, it can be only moved. Best used with ModificationStart set to AutoHandles.
RoundAndSquare | Corner resize handles are round, remaining handles are square.
RoundAndSquare2 | Corner resize handles are round, remaining handles are square. In addition, there is a dashed frame drawn around selected nodes.
SquareHandles | If selected, the node is drawn with square modification handles.
SquareHandles2 | Square resize handles are drawn around a selected node. There isn't a move-handle in the center as with the SquareHandles style, but nodes can be moved by dragging their interior or caption areas. Links can be created by drawing from near the edges of a node.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.HandlesVisualStyle Class

HandlesVisualStyle Class
Remarks See Also
[image]

Defines stroke and brush attributes used to draw selection handles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class HandlesVisualStyle

Visual Basic [image] Copy Code

Public Class HandlesVisualStyle

Remarks

The component uses several different HandlesVisualStyle objects depending on the context. They can be accessed through the ActiveItemHandlesStyle, SelectedItemHandlesStyle and DisabledHandlesStyle properties of the Diagram class.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.HandlesVisualStyle

See Also

HandlesVisualStyle Members


MindFusion.Diagramming.HandlesVisualStyle Members

HandlesVisualStyle Members
Constructors Properties
[image]

Defines stroke and brush attributes used to draw selection handles.

The following tables list the members exposed by the HandlesVisualStyle type.

Public Constructors

Name | Description
HandlesVisualStyle | Initializes a new instance of the HandlesVisualStyle class.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the handle shape.
HatchBrush | Gets or sets a Brush used to draw hatch frames.
PatternBrush | Gets or sets a Brush used to draw selection frames for the MoveOnly style.
RotationHandleBrush | Gets or sets a Brush used to fill the interior of the rotation handle.
Stroke | Gets or sets the brush used to stroke the outline of the handle shape.
StrokeDashArray | Gets or sets the stroke dash pattern.
StrokeThickness | Gets or sets the stroke thickness.

See Also

HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle Constructor

HandlesVisualStyle Constructor
[image]

Initializes a new instance of the HandlesVisualStyle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HandlesVisualStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle Properties

HandlesVisualStyle Properties
[image]

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the handle shape.
HatchBrush | Gets or sets a Brush used to draw hatch frames.
PatternBrush | Gets or sets a Brush used to draw selection frames for the MoveOnly style.
RotationHandleBrush | Gets or sets a Brush used to fill the interior of the rotation handle.
Stroke | Gets or sets the brush used to stroke the outline of the handle shape.
StrokeDashArray | Gets or sets the stroke dash pattern.
StrokeThickness | Gets or sets the stroke thickness.

See Also

HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle.Brush Property

HandlesVisualStyle.Brush Property
[image]

Gets or sets the brush used to fill the handle shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

Instance of a Windows.UI.Xaml.Media.Brush -derived class.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle.HatchBrush Property

HandlesVisualStyle.HatchBrush Property
[image]

Gets or sets a Brush used to draw hatch frames.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush HatchBrush { get; set; }

Visual Basic [image] Copy Code

Public Property HatchBrush As Brush

Property Value

Instance of a Windows.UI.Xaml.Media.Brush -derived class.

Remarks

This brush is used to draw the hatch pattern for HandlesStyle types that display hatch frames.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle.PatternBrush Property

HandlesVisualStyle.PatternBrush Property
[image]

Gets or sets a Brush used to draw selection frames for the MoveOnly style.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush PatternBrush { get; set; }

Visual Basic [image] Copy Code

Public Property PatternBrush As Brush

Property Value

Instance of a Windows.UI.Xaml.Media.Brush -derived class.

Remarks

This brush is used to render the dot pattern for the HatchHandles3 and MoveOnly HandlesStyle types.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle.RotationHandleBrush Property

HandlesVisualStyle.RotationHandleBrush Property
[image]

Gets or sets a Brush used to fill the interior of the rotation handle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush RotationHandleBrush { get; set; }

Visual Basic [image] Copy Code

Public Property RotationHandleBrush As Brush

Property Value

Instance of a Windows.UI.Xaml.Media.Brush -derived class.

Remarks

If this property is set to null, the rotation brush is painted using Brush.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle.Stroke Property

HandlesVisualStyle.Stroke Property
[image]

Gets or sets the brush used to stroke the outline of the handle shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush Stroke { get; set; }

Visual Basic [image] Copy Code

Public Property Stroke As Brush

Property Value

Instance of a Windows.UI.Xaml.Media.Brush -derived class.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle.StrokeDashArray Property

HandlesVisualStyle.StrokeDashArray Property
[image]

Gets or sets the stroke dash pattern.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DoubleCollection StrokeDashArray { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeDashArray As DoubleCollection

Property Value

A DoubleCollection value specifying the stroke dash pattern.

Remarks

This value is used only if HandlesStyle is set to DashFrame.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle.StrokeThickness Property

HandlesVisualStyle.StrokeThickness Property
[image]

Gets or sets the stroke thickness.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double StrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThickness As Double

Property Value

A double value specifying the stroke thickness.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class


MindFusion.Diagramming.HatchBrush Class

HatchBrush Class
[image]

Emulates GDI+ hatch brushes using the WPF ImageBrush class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class HatchBrush

Visual Basic [image] Copy Code

Public Class HatchBrush

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.HatchBrush

See Also

HatchBrush Members


MindFusion.Diagramming.HatchBrush Members

HatchBrush Members
Constructors Methods
[image]

Emulates GDI+ hatch brushes using the WPF ImageBrush class.

The following tables list the members exposed by the HatchBrush type.

Public Constructors

Name | Description
HatchBrush |

Public Methods

Name | Description
CreateInstance | Returns an ImageBrush instance corresponding to a GDI+ HatchBrush.

See Also

HatchBrush Class


MindFusion.Diagramming.HatchBrush Constructor

HatchBrush Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HatchBrush ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

HatchBrush Class


MindFusion.Diagramming.HatchBrush Methods

HatchBrush Methods
[image]

Public Methods

Name | Description
CreateInstance | Returns an ImageBrush instance corresponding to a GDI+ HatchBrush.

See Also

HatchBrush Class


MindFusion.Diagramming.HatchBrush.CreateInstance Method

HatchBrush.CreateInstance Method
[image]

Returns an ImageBrush instance corresponding to a GDI+ HatchBrush.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Brush CreateInstance (
HatchStyle hatchStyle,
Color foreColor,
Color backColor,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Shared Function CreateInstance( _
hatchStyle As HatchStyle, _
foreColor As Color, _
backColor As Color, _
diagram As Diagram _
) As Brush

Parameters

hatchStyle

A HatchStyle member specifying the hatch pattern.

foreColor

The hatch foreground color.

backColor

The hatch background color.

diagram

A Diagram instance.

Return Value

An ImageBrush instance.

See Also

HatchBrush Members
HatchBrush Class


MindFusion.Diagramming.HatchStyle Enumeration

HatchStyle Enumeration
[image]

Represents hatch patterns corresponding to GDI+ HatchBrush objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum HatchStyle

Visual Basic [image] Copy Code

Public Enum HatchStyle

Members

Member name | Description
BackwardDiagonal | A pattern of lines on a diagonal from upper right to lower left.
Cross | Specifies horizontal and vertical lines that cross.
DarkDownwardDiagonal | Specifies diagonal lines that slant to the right from top points to bottom points, are spaced 50 percent closer together than, and are twice the width of ForwardDiagonal.
DarkHorizontal | Specifies horizontal lines that are spaced 50 percent closer together than Horizontal and are twice the width of Horizontal.
DarkUpwardDiagonal | Specifies diagonal lines that slant to the left from top points to bottom points, are spaced 50 percent closer together than BackwardDiagonal, and are twice its width.
DarkVertical | Specifies vertical lines that are spaced 50 percent closer together than Vertical and are twice its width.
DashedDownwardDiagonal | Specifies dashed diagonal lines, that slant to the right from top points to bottom points.
DashedHorizontal | Specifies dashed horizontal lines.
DashedUpwardDiagonal | Specifies dashed diagonal lines, that slant to the left from top points to bottom points.
DashedVertical | Specifies dashed vertical lines.
DiagonalBrick | Specifies a hatch that has the appearance of layered bricks that slant to the left from top points to bottom points.
DiagonalCross | A pattern of crisscross diagonal lines.
Divot | Specifies a hatch that has the appearance of divots.
DottedDiamond | Specifies forward diagonal and backward diagonal lines, each of which is composed of dots, that cross.
DottedGrid | Specifies horizontal and vertical lines, each of which is composed of dots, that cross.
ForwardDiagonal | A pattern of lines on a diagonal from upper left to lower right.
Horizontal | A pattern of horizontal lines.
HorizontalBrick | Specifies a hatch that has the appearance of horizontally layered bricks.
LargeCheckerBoard | Specifies a hatch that has the appearance of a checkerboard with squares that are twice the size of SmallCheckerBoard.
LargeConfetti | Specifies a hatch that has the appearance of confetti, and is composed of larger pieces than SmallConfetti.
LargeGrid | Specifies the hatch style Cross.
LightDownwardDiagonal | Specifies diagonal lines that slant to the right from top points to bottom points and are spaced 50 percent closer together than ForwardDiagonal, but are not antialiased.
LightHorizontal | Specifies horizontal lines that are spaced 50 percent closer together than Horizontal.
LightUpwardDiagonal | Specifies diagonal lines that slant to the left from top points to bottom points and are spaced 50 percent closer together than BackwardDiagonal.
LightVertical | Specifies vertical lines that are spaced 50 percent closer together than Vertical.
Max | Specifies hatch style SolidDiamond.
Min | Specifies hatch style Horizontal.
NarrowHorizontal | Specifies horizontal lines that are spaced 75 percent closer together than hatch style Horizontal.
NarrowVertical | Specifies vertical lines that are spaced 75 percent closer together than hatch style Vertical.
OutlinedDiamond | Specifies forward diagonal and backward diagonal lines that cross.
Percent05 | Specifies a 5-percent hatch. The ratio of foreground color to background color is 5:100.
Percent10 | Specifies a 10-percent hatch. The ratio of foreground color to background color is 10:100.
Percent20 | Specifies a 20-percent hatch. The ratio of foreground color to background color is 20:100.
Percent25 | Specifies a 25-percent hatch. The ratio of foreground color to background color is 25:100.
Percent30 | Specifies a 30-percent hatch. The ratio of foreground color to background color is 30:100.
Percent40 | Specifies a 40-percent hatch. The ratio of foreground color to background color is 40:100.
Percent50 | Specifies a 50-percent hatch. The ratio of foreground color to background color is 50:100.
Percent60 | Specifies a 60-percent hatch. The ratio of foreground color to background color is 60:100.
Percent70 | Specifies a 70-percent hatch. The ratio of foreground color to background color is 70:100.
Percent75 | Specifies a 75-percent hatch. The ratio of foreground color to background color is 75:100.
Percent80 | Specifies a 80-percent hatch. The ratio of foreground color to background color is 80:100.
Percent90 | Specifies a 90-percent hatch. The ratio of foreground color to background color is 90:100.
Plaid | Specifies a hatch that has the appearance of a plaid material.
Shingle | Specifies a hatch that has the appearance of diagonally layered shingles that slant to the right from top points to bottom points.
SmallCheckerBoard | Specifies a hatch that has the appearance of a checkerboard.
SmallConfetti | Specifies a hatch that has the appearance of confetti.
SmallGrid | Specifies horizontal and vertical lines that cross and are spaced 50 percent closer together than hatch style Cross.
SolidDiamond | Specifies a hatch that has the appearance of a checkerboard placed diagonally.
Sphere | Specifies a hatch that has the appearance of spheres laid adjacent to one another.
Trellis | Specifies a hatch that has the appearance of a trellis.
Vertical | A pattern of vertical lines.
Wave | Specifies horizontal lines that are composed of tildes.
Weave | Specifies a hatch that has the appearance of a woven material.
WideDownwardDiagonal | Specifies diagonal lines that slant to the right from top points to bottom points, have the same spacing as hatch style ForwardDiagonal, and are triple its width.
WideUpwardDiagonal | Specifies diagonal lines that slant to the left from top points to bottom points, have the same spacing as hatch style BackwardDiagonal, and are triple its width.
ZigZag | Specifies horizontal lines that are composed of zigzags.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.HitTestEventArgs Class

HitTestEventArgs Class
[image]

Contains the arguments passed to the HitTestAdjustmentHandles event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class HitTestEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class HitTestEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.HitTestEventArgs

See Also

HitTestEventArgs Members


MindFusion.Diagramming.HitTestEventArgs Members

HitTestEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the HitTestAdjustmentHandles event handlers.

The following tables list the members exposed by the HitTestEventArgs type.

Public Constructors

Name | Description
HitTestEventArgs | Initializes a new instance of the HitTestEventArgs class.

Public Properties

Name | Description
HitResult | Gets or sets the index of the selection handle that has been hit.
Item | Gets the item whose adjustment handles are being hit-tested.
MousePosition | Gets the current cursor position, expressed in document coordinates.

See Also

HitTestEventArgs Class


MindFusion.Diagramming.HitTestEventArgs Constructor

HitTestEventArgs Constructor
[image]

Initializes a new instance of the HitTestEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HitTestEventArgs (
DiagramItem item,
Point mousePosition
)

Visual Basic [image] Copy Code

Public New ( _
item As DiagramItem, _
mousePosition As Point _
)

Parameters

item

The DiagramItem related to the event.

mousePosition

The cursor location at the time the event is raised, expressed in document coordinates.

See Also

HitTestEventArgs Class


MindFusion.Diagramming.HitTestEventArgs Properties

HitTestEventArgs Properties
[image]

Public Properties

Name | Description
HitResult | Gets or sets the index of the selection handle that has been hit.
Item | Gets the item whose adjustment handles are being hit-tested.
MousePosition | Gets the current cursor position, expressed in document coordinates.

See Also

HitTestEventArgs Class


MindFusion.Diagramming.HitTestEventArgs.HitResult Property

HitTestEventArgs.HitResult Property
[image]

Gets or sets the index of the selection handle that has been hit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int HitResult { get; set; }

Visual Basic [image] Copy Code

Public Property HitResult As Integer

Property Value

See Also

HitTestEventArgs Members
HitTestEventArgs Class


MindFusion.Diagramming.HitTestEventArgs.Item Property

HitTestEventArgs.Item Property
[image]

Gets the item whose adjustment handles are being hit-tested.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As DiagramItem

Property Value

See Also

HitTestEventArgs Members
HitTestEventArgs Class


MindFusion.Diagramming.HitTestEventArgs.MousePosition Property

HitTestEventArgs.MousePosition Property
[image]

Gets the current cursor position, expressed in document coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point MousePosition { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MousePosition As Point

Property Value

See Also

HitTestEventArgs Members
HitTestEventArgs Class


MindFusion.Diagramming.HitTestPriority Enumeration

HitTestPriority Enumeration
[image]

Defines values that specify the order of item hit-testing.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum HitTestPriority

Visual Basic [image] Copy Code

Public Enum HitTestPriority

Members

Member name | Description
NodesBeforeLinks | Test nodes first, then links.
ZOrder | Test items in decreasing z-order, independently of their types.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.ILinkRouter Interface

ILinkRouter Interface
[image]

Defines methods that should be implemented by a link-router component. The control calls them when a new link path should be set in response to changes in the diagram, such as adding or modifying nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface ILinkRouter

Visual Basic [image] Copy Code

Public Interface ILinkRouter

Inheritors

MindFusion.Diagramming.GridRouter
MindFusion.Diagramming.QuickRouter

See Also

ILinkRouter Members


MindFusion.Diagramming.ILinkRouter Members

ILinkRouter Members
Properties Methods
[image]

Defines methods that should be implemented by a link-router component. The control calls them when a new link path should be set in response to changes in the diagram, such as adding or modifying nodes.

The following tables list the members exposed by the ILinkRouter type.

Public Properties

Name | Description
Diagram | Gets or sets the diagram this router is associated with.

Public Methods

Name | Description
Resume | Called when the control ends a batch update operation that might affect many links.
RouteLink | Called when a single link must be routed.
RouteLinks | Called when more than one links must be routed.
Suspend | Called when the control starts a batch update operation that might affect many links. Implementations might collect the links specified through RouteLink and RouteLinks calls and defer finding their paths for when Resume is called.

See Also

ILinkRouter Interface


MindFusion.Diagramming.ILinkRouter Methods

ILinkRouter Methods
[image]

Public Methods

Name | Description
Resume | Called when the control ends a batch update operation that might affect many links.
RouteLink | Called when a single link must be routed.
RouteLinks | Called when more than one links must be routed.
Suspend | Called when the control starts a batch update operation that might affect many links. Implementations might collect the links specified through RouteLink and RouteLinks calls and defer finding their paths for when Resume is called.

See Also

ILinkRouter Interface


MindFusion.Diagramming.ILinkRouter.Resume Method

ILinkRouter.Resume Method
[image]

Called when the control ends a batch update operation that might affect many links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void Resume (
bool routeDeferredLinks
)

Visual Basic [image] Copy Code

Sub Resume( _
routeDeferredLinks As Boolean _
)

Parameters

routeDeferredLinks
true if the links should be routed, otherwise false.

See Also

ILinkRouter Members
ILinkRouter Interface
MindFusion.Diagramming Namespace
Suspend Method


MindFusion.Diagramming.ILinkRouter.RouteLink Method

ILinkRouter.RouteLink Method
[image]

Called when a single link must be routed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract bool RouteLink (
DiagramLink link
)

Visual Basic [image] Copy Code

Public MustOverride Function RouteLink ( _
link As DiagramLink _
) As Boolean

Parameters

link
A DiagramLink object representing the link.

Return Value

true if a path has been found, otherwise false.

See Also

ILinkRouter Members
ILinkRouter Interface


MindFusion.Diagramming.ILinkRouter.RouteLinks Method

ILinkRouter.RouteLinks Method
[image]

Called when more than one links must be routed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract void RouteLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Public MustOverride Sub RouteLinks ( _
links As DiagramLinkCollection _
)

Parameters

links
A DiagramLinkCollection containing the links that should be routed.

See Also

ILinkRouter Members
ILinkRouter Interface


MindFusion.Diagramming.ILinkRouter.Suspend Method

ILinkRouter.Suspend Method
[image]

Called when the control starts a batch update operation that might affect many links. Implementations might collect the links specified through RouteLink and RouteLinks calls and defer finding their paths for when Resume is called.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void Suspend ()

Visual Basic [image] Copy Code

Sub Suspend ()

See Also

ILinkRouter Members
ILinkRouter Interface


MindFusion.Diagramming.ILinkRouter Properties

ILinkRouter Properties
[image]

Public Properties

Name | Description
Diagram | Gets or sets the diagram this router is associated with.

See Also

ILinkRouter Interface


MindFusion.Diagramming.ILinkRouter.Diagram Property

ILinkRouter.Diagram Property
[image]

Gets or sets the diagram this router is associated with.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

Diagram Diagram { get; set; }

Visual Basic [image] Copy Code

Property Diagram As Diagram

Property Value

See Also

ILinkRouter Members
ILinkRouter Interface


MindFusion.Diagramming.ImageAlign Enumeration

ImageAlign Enumeration
[image]

Specifies the position and alignment of a picture in a box or table, or that of the background image.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum ImageAlign

Visual Basic [image] Copy Code

Public Enum ImageAlign

Members

Member name | Description
BottomCenter | The image is centered horizontally and aligned to the bottom side.
BottomLeft | The image is aligned to the bottom left corner.
BottomRight | The image is aligned to the bottom right corner.
Center | The image is centered in the node or diagram.
Fit | The image is resized to fit the size of the object or the component's client area.
MiddleLeft | The image is centered vertically and aligned to the left-hand side.
MiddleRight | The image is centered vertically and aligned to the right-hand side.
Stretch | The image is stretched to fill the object or the component's client area.
TopCenter | The image is centered horizontally and aligned to the top side.
TopLeft | The image is aligned to the top left corner.
TopRight | The image is aligned to the top right corner.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.InplaceEditable Interface

InplaceEditable Interface
[image]

Represents an in-place editable object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface InplaceEditable

Visual Basic [image] Copy Code

Public Interface InplaceEditable

Inheritors

MindFusion.Diagramming.Cell
MindFusion.Diagramming.DiagramLink
MindFusion.Diagramming.LinkLabel
MindFusion.Diagramming.ShapeNode
MindFusion.Diagramming.TableNode
MindFusion.Diagramming.TreeViewItem
MindFusion.Diagramming.TreeViewNode

See Also

InplaceEditable Members


MindFusion.Diagramming.InplaceEditable Members

InplaceEditable Members
Methods
[image]

Represents an in-place editable object.

The following tables list the members exposed by the InplaceEditable type.

Public Methods

Name | Description
GetDiagramItem | Returns the item to which the GetEditRect is relative.
GetEditRect | Returns the rectangle where the in-place editing text box appears in coordinates relative to the item returned by GetDiagramItem.
GetTextToEdit | Returns the text of the object which is displayed initially when the object is in-place edited.
SetEditedText | Sets the edited text to the object after the in-place editing operation has been completed successfully.

See Also

InplaceEditable Interface


MindFusion.Diagramming.InplaceEditable Methods

InplaceEditable Methods
[image]

Public Methods

Name | Description
GetDiagramItem | Returns the item to which the GetEditRect is relative.
GetEditRect | Returns the rectangle where the in-place editing text box appears in coordinates relative to the item returned by GetDiagramItem.
GetTextToEdit | Returns the text of the object which is displayed initially when the object is in-place edited.
SetEditedText | Sets the edited text to the object after the in-place editing operation has been completed successfully.

See Also

InplaceEditable Interface


MindFusion.Diagramming.InplaceEditable.GetDiagramItem Method

InplaceEditable.GetDiagramItem Method
[image]

Returns the item to which the GetEditRect is relative.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract DiagramItem GetDiagramItem ()

Visual Basic [image] Copy Code

Public MustOverride Function GetDiagramItem () As DiagramItem

Return Value

See Also

InplaceEditable Members
InplaceEditable Interface


MindFusion.Diagramming.InplaceEditable.GetEditRect Method

InplaceEditable.GetEditRect Method
[image]

Returns the rectangle where the in-place editing text box appears in coordinates relative to the item returned by GetDiagramItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

Rect GetEditRect (
Point mousePosition
)

Visual Basic [image] Copy Code

Function GetEditRect( _
mousePosition As Point _
) As Rect

Parameters

mousePosition
A Windows.UI.Xaml.Point object.

Return Value

A Rect instance that represents the destination rectangle of the in-place editing box.

See Also

InplaceEditable Members
InplaceEditable Interface


MindFusion.Diagramming.InplaceEditable.GetTextToEdit Method

InplaceEditable.GetTextToEdit Method
[image]

Returns the text of the object which is displayed initially when the object is in-place edited.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

string GetTextToEdit ()

Visual Basic [image] Copy Code

Function GetTextToEdit () As String

Return Value

A string value that represents the initial contents of the in-place editing box.

See Also

InplaceEditable Members
InplaceEditable Interface


MindFusion.Diagramming.InplaceEditable.SetEditedText Method

InplaceEditable.SetEditedText Method
[image]

Sets the edited text to the object after the in-place editing operation has been completed successfully.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void SetEditedText (
string newText
)

Visual Basic [image] Copy Code

Sub SetEditedText( _
newText As String _
)

Parameters

newText

The new text of the in-place edited object.

See Also

InplaceEditable Members
InplaceEditable Interface


MindFusion.Diagramming.InPlaceEditEventArgs Class

InPlaceEditEventArgs Class
[image]

Contains the arguments passed to the EnterInplaceEditMode and LeaveInplaceEditMode event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class InPlaceEditEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class InPlaceEditEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.InPlaceEditEventArgs

See Also

InPlaceEditEventArgs Members


MindFusion.Diagramming.InPlaceEditEventArgs Members

InPlaceEditEventArgs Members
Properties
[image]

Contains the arguments passed to the EnterInplaceEditMode and LeaveInplaceEditMode event handlers.

The following tables list the members exposed by the InPlaceEditEventArgs type.

Public Properties

Name | Description
Item | Gets a reference to the item being edited.
Node | Gets the diagram node being edited.
TextBox | Gets the control used to edit the item's text.

See Also

InPlaceEditEventArgs Class


MindFusion.Diagramming.InPlaceEditEventArgs Properties

InPlaceEditEventArgs Properties
[image]

Public Properties

Name | Description
Item | Gets a reference to the item being edited.
Node | Gets the diagram node being edited.
TextBox | Gets the control used to edit the item's text.

See Also

InPlaceEditEventArgs Class


MindFusion.Diagramming.InPlaceEditEventArgs.Item Property

InPlaceEditEventArgs.Item Property
[image]

Gets a reference to the item being edited.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public InplaceEditable Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As InplaceEditable

Property Value

An InplaceEditable reference representing the item being edited.

See Also

InPlaceEditEventArgs Members
InPlaceEditEventArgs Class


MindFusion.Diagramming.InPlaceEditEventArgs.Node Property

InPlaceEditEventArgs.Node Property
[image]

Gets the diagram node being edited.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Node { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Node As DiagramNode

Property Value

An instance of the DiagramNode class that represents the node being edited.

See Also

InPlaceEditEventArgs Members
InPlaceEditEventArgs Class


MindFusion.Diagramming.InPlaceEditEventArgs.TextBox Property

InPlaceEditEventArgs.TextBox Property
[image]

Gets the control used to edit the item's text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TextBox TextBox { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TextBox As TextBox

Property Value

An instance of the WinRT Windows.UI.Xaml.Controls.TextBox class.

See Also

InPlaceEditEventArgs Members
InPlaceEditEventArgs Class


MindFusion.Diagramming.InstantiateLink Delegate

InstantiateLink Delegate
[image]

Represent a method that creates actual DiagramLink objects to represent data items on screen.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate DiagramLink InstantiateLink (
Object dataItem
)

Visual Basic [image] Copy Code

Public Delegate Function InstantiateLink ( _
dataItem As Object _
) As DiagramLink

Parameters

dataItem

A data item that should be shown on screen.

Return Value

A DiagramLink instance.

Remarks

The delegate method can be assigned to the InstantiateLink property of VirtualizingDiagram to create instances of a custom link type.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.InstantiateLinkData Delegate

InstantiateLinkData Delegate
[image]

Represents a method that instantiates data items for links drawn by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate Object InstantiateLinkData (
DiagramLink link
)

Visual Basic [image] Copy Code

Public Delegate Function InstantiateLinkData ( _
link As DiagramLink _
) As Object

Parameters

link
A DiagramLink drawn by the user.

Return Value

A data item for the new link.

Remarks

The delegate method can be assigned to the InstantiateLinkData property of VirtualizingDiagram to create data items when the user draws new links.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.InstantiateNode Delegate

InstantiateNode Delegate
[image]

Represent a method that creates actual DiagramNode -derived objects to represent data items on screen.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate DiagramNode InstantiateNode (
Object dataItem
)

Visual Basic [image] Copy Code

Public Delegate Function InstantiateNode ( _
dataItem As Object _
) As DiagramNode

Parameters

dataItem

A data item that should be shown on screen.

Return Value

A DiagramNode instance.

Remarks

The delegate method can be assigned to the InstantiateNode property of VirtualizingDiagram to create instances of a custom node type.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.InstantiateNodeData Delegate

InstantiateNodeData Delegate
[image]

Represents a method that instantiates data items for nodes drawn by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate Object InstantiateNodeData (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Delegate Function InstantiateNodeData ( _
node As DiagramNode _
) As Object

Parameters

node

A DiagramNode drawn by the user.

Return Value

A data item for the new node.

Remarks

The delegate method can be assigned to the InstantiateNodeData property of VirtualizingDiagram to create data items when the user draws new nodes.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.Interaction Class

Interaction Class
[image]

Encapsulates the current state of user interaction with the control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class Interaction

Visual Basic [image] Copy Code

Public MustInherit Class Interaction

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction
MindFusion.Diagramming.BehaviorBase

See Also

Interaction Members


MindFusion.Diagramming.Interaction Members

Interaction Members
Constructors Properties Methods
[image]

Encapsulates the current state of user interaction with the control.

The following tables list the members exposed by the Interaction type.

Protected Constructors

Name | Description
Interaction | Initializes a new instance of the Interaction class.

Protected Properties

Name | Description
Diagram | The Diagram object that is being modified.

Protected Methods

Name | Description
OnMouseDown | Called when a mouse button is pressed.
OnMouseMove | Called when the mouse pointer is moved over the control.
OnMouseUp | Called when a mouse button is released.

See Also

Interaction Class


MindFusion.Diagramming.Interaction Constructor

Interaction Constructor
[image]

Initializes a new instance of the Interaction class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Interaction (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected Function Interaction ( _
diagram As Diagram _
)

Parameters

diagram
A Diagram object.

See Also

Interaction Class


MindFusion.Diagramming.Interaction Methods

Interaction Methods
[image]

Protected Methods

Name | Description
OnMouseDown | Called when a mouse button is pressed.
OnMouseMove | Called when the mouse pointer is moved over the control.
OnMouseUp | Called when a mouse button is released.

See Also

Interaction Class


MindFusion.Diagramming.Interaction.OnMouseDown Method

Interaction.OnMouseDown Method
[image]

Called when a mouse button is pressed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected abstract bool OnMouseDown (
e
)

Visual Basic [image] Copy Code

Protected MustOverride Function OnMouseDown( _
e As _
) As Boolean

Parameters

e

Return Value

See Also

Interaction Members
Interaction Class


MindFusion.Diagramming.Interaction.OnMouseMove Method

Interaction.OnMouseMove Method
[image]

Called when the mouse pointer is moved over the control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected abstract void OnMouseMove (
e
)

Visual Basic [image] Copy Code

Protected MustOverride Sub OnMouseMove( _
e As _
)

Parameters

e

See Also

Interaction Members
Interaction Class


MindFusion.Diagramming.Interaction.OnMouseUp Method

Interaction.OnMouseUp Method
[image]

Called when a mouse button is released.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected abstract void OnMouseUp (
e
)

Visual Basic [image] Copy Code

Protected MustOverride Sub OnMouseUp( _
e As _
)

Parameters

e

See Also

Interaction Members
Interaction Class


MindFusion.Diagramming.Interaction Properties

Interaction Properties
[image]

Protected Properties

Name | Description
Diagram | The Diagram object that is being modified.

See Also

Interaction Class


MindFusion.Diagramming.Interaction.Diagram Property

Interaction.Diagram Property
[image]

The Diagram object that is being modified.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Diagram Diagram { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property Diagram As Diagram

Property Value

A Diagram instance.

See Also

Interaction Members
Interaction Class


MindFusion.Diagramming.InteractionState Class

InteractionState Class
[image]

Encapsulates the current state of user interaction with the control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class InteractionState

Visual Basic [image] Copy Code

Public Class InteractionState

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.InteractionState

See Also

InteractionState Members


MindFusion.Diagramming.InteractionState Members

InteractionState Members
Constructors Fields Properties Methods
[image]

Encapsulates the current state of user interaction with the control.

The following tables list the members exposed by the InteractionState type.

Public Constructors

Name | Description
InteractionState | Overloaded.

Protected Fields

Name | Description
originalStates | Contains the original state of the items that are being modified.

Public Properties

Name | Description
Action | Gets or sets the type of Action currently performed by the user in the Diagram.
AdjustmentHandle | Gets or sets the index of the selection handle to be modified.
CurrentItem | Gets a reference to the DiagramItem to be created or modified.
CurrentPoint | Gets or sets the current location of the mouse pointer.
DeltaX | Gets the horizontal distance the mouse has been moved since the modification began.
DeltaY | Gets the vertical distance the mouse has been moved since the modification began.
OriginalStates | Stores the original state of items from before the modification began.
StartPoint | Gets or sets the mouse position where the interaction starts.

Public Methods

Name | Description
Cancel | Cancels the user interaction.
CancelNow | Instruct the interaction to terminate on the next pass.
Commit | Invoked to commit the changes made by the user.
IsAllowed | Checks whether the current interaction can be completed at the specified point.
ShouldCancelDrag | Gets a value indicating whether the interaction should terminate on the next pass.
Start | This method is invoked in the beginning of the interaction, usually when the user presses the left mouse button over a modification handle.

See Also

InteractionState Class


MindFusion.Diagramming.InteractionState Fields

InteractionState Fields
[image]

Protected Fields

Name | Description
originalStates | Contains the original state of the items that are being modified.

See Also

InteractionState Class


MindFusion.Diagramming.InteractionState.originalStates Field

InteractionState.originalStates Field
[image]

Contains the original state of the items that are being modified.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Dictionary<DiagramItem, DiagramItemState> originalStates

Visual Basic [image] Copy Code

Protected originalStates As Dictionary(Of DiagramItem, DiagramItemState)

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState Constructor

InteractionState Constructor
[image]

Overload List

Name | Description
InteractionState (DiagramItem, Action, AdjustmentHandle, Point) | Initializes a new instance of the InteractionState class.
InteractionState (DiagramItem, Action, Int32, Point) | Initializes a new instance of the InteractionState class.

See Also

InteractionState Class


MindFusion.Diagramming.InteractionState Constructor (DiagramItem, Action, AdjustmentHandle, Point)

InteractionState Constructor (DiagramItem, Action, AdjustmentHandle, Point)
See Also
[image]

Initializes a new instance of the InteractionState class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public InteractionState (
DiagramItem modifiedItem,
Action action,
AdjustmentHandle adjustmentHandle,
Point startPoint
)

Visual Basic [image] Copy Code

Public New ( _
modifiedItem As DiagramItem, _
action As Action, _
adjustmentHandle As AdjustmentHandle, _
startPoint As Point _
)

Parameters

modifiedItem

The DiagramItem to be created or modified.

action

One of the Action enumeration values, specifying what kind of action to perform.

adjustmentHandle

The index of the selection handle to be dragged with the mouse, defines what kind of modification to perform.

startPoint

A Point specifying the mouse position where the user starts to draw or modify an item.

See Also

InteractionState Constructor Overload List
InteractionState Class


MindFusion.Diagramming.InteractionState Constructor (DiagramItem, Action, Int32, Point)

InteractionState Constructor (DiagramItem, Action, Int32, Point)
See Also
[image]

Initializes a new instance of the InteractionState class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public InteractionState (
DiagramItem modifiedItem,
Action action,
int adjustmentHandle,
Point startPoint
)

Visual Basic [image] Copy Code

Public Function InteractionState ( _
modifiedItem As DiagramItem, _
action As Action, _
adjustmentHandle As Integer, _
startPoint As Point _
)

Parameters

modifiedItem
The DiagramItem to be created or modified.
action
One of the Action enumeration values, specifying what kind of action to perform.
adjustmentHandle

The index of the selection handle to be dragged with the mouse, defines what kind of modification to perform.

startPoint

A Point specifying the mouse position where the user starts to draw or modify an item.

See Also

InteractionState Constructor Overload List
InteractionState Class


MindFusion.Diagramming.InteractionState Methods

InteractionState Methods
[image]

Public Methods

Name | Description
Cancel | Cancels the user interaction.
CancelNow | Instruct the interaction to terminate on the next pass.
Commit | Invoked to commit the changes made by the user.
IsAllowed | Checks whether the current interaction can be completed at the specified point.
ShouldCancelDrag | Gets a value indicating whether the interaction should terminate on the next pass.
Start | This method is invoked in the beginning of the interaction, usually when the user presses the left mouse button over a modification handle.

See Also

InteractionState Class


MindFusion.Diagramming.InteractionState.Cancel Method

InteractionState.Cancel Method
[image]

Cancels the user interaction.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Cancel (
Diagram diagram
)

Visual Basic [image] Copy Code

Public Sub Cancel( _
diagram As Diagram _
)

Parameters

diagram

The Diagram, at which the action is performed.

Remarks

Call this method to cancel interaction, usually in response to the user clicking the right mouse button while dragging.

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.CancelNow Method

InteractionState.CancelNow Method
[image]

Instruct the interaction to terminate on the next pass.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void CancelNow ()

Visual Basic [image] Copy Code

Public Sub CancelNow ()

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.Commit Method

InteractionState.Commit Method
[image]

Invoked to commit the changes made by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Commit (
Point currentPoint
)

Visual Basic [image] Copy Code

Public Sub Commit( _
currentPoint As Point _
)

Parameters

currentPoint

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.IsAllowed Method

InteractionState.IsAllowed Method
[image]

Checks whether the current interaction can be completed at the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsAllowed (
Point point
)

Visual Basic [image] Copy Code

Public Function IsAllowed( _
point As Point _
) As Boolean

Parameters

point

Return Value

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.ShouldCancelDrag Method

InteractionState.ShouldCancelDrag Method
[image]

Gets a value indicating whether the interaction should terminate on the next pass.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ShouldCancelDrag ()

Visual Basic [image] Copy Code

Public Function ShouldCancelDrag () As Boolean

Return Value

true if the interaction should terminate; otherwise, false.

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.Start Method

InteractionState.Start Method
[image]

This method is invoked in the beginning of the interaction, usually when the user presses the left mouse button over a modification handle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Start ()

Visual Basic [image] Copy Code

Public Sub Start ()

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState Properties

InteractionState Properties
[image]

Public Properties

Name | Description
Action | Gets or sets the type of Action currently performed by the user in the Diagram.
AdjustmentHandle | Gets or sets the index of the selection handle to be modified.
CurrentItem | Gets a reference to the DiagramItem to be created or modified.
CurrentPoint | Gets or sets the current location of the mouse pointer.
DeltaX | Gets the horizontal distance the mouse has been moved since the modification began.
DeltaY | Gets the vertical distance the mouse has been moved since the modification began.
OriginalStates | Stores the original state of items from before the modification began.
StartPoint | Gets or sets the mouse position where the interaction starts.

See Also

InteractionState Class


MindFusion.Diagramming.InteractionState.Action Property

InteractionState.Action Property
[image]

Gets or sets the type of Action currently performed by the user in the Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Action Action { get; set; }

Visual Basic [image] Copy Code

Public Property Action As Action

Property Value

A member of the Action enumeration that specifies what kind of action the user currently performes on the Diagram.

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.AdjustmentHandle Property

InteractionState.AdjustmentHandle Property
[image]

Gets or sets the index of the selection handle to be modified.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AdjustmentHandle AdjustmentHandle { get; set; }

Visual Basic [image] Copy Code

Public Property AdjustmentHandle As AdjustmentHandle

Property Value

An integer value specifying the index of the handle to be modified.

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.CurrentItem Property

InteractionState.CurrentItem Property
[image]

Gets a reference to the DiagramItem to be created or modified.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem CurrentItem { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CurrentItem As DiagramItem

Property Value

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.CurrentPoint Property

InteractionState.CurrentPoint Property
[image]

Gets or sets the current location of the mouse pointer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point CurrentPoint { get; set; }

Visual Basic [image] Copy Code

Public Property CurrentPoint As Point

Property Value

A WinRT Windows.UI.Xaml Point object that specifies the current location of the cursor, in document coordinates.

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.DeltaX Property

InteractionState.DeltaX Property
[image]

Gets the horizontal distance the mouse has been moved since the modification began.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double DeltaX { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DeltaX As Double

Property Value

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.DeltaY Property

InteractionState.DeltaY Property
[image]

Gets the vertical distance the mouse has been moved since the modification began.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double DeltaY { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DeltaY As Double

Property Value

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.OriginalStates Property

InteractionState.OriginalStates Property
[image]

Stores the original state of items from before the modification began.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Dictionary<DiagramItem, DiagramItemState> OriginalStates { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OriginalStates As Dictionary(Of DiagramItem, DiagramItemState)

Property Value

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.InteractionState.StartPoint Property

InteractionState.StartPoint Property
[image]

Gets or sets the mouse position where the interaction starts.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point StartPoint { get; set; }

Visual Basic [image] Copy Code

Public Property StartPoint As Point

Property Value

A Point specifying the mouse position where the user started to draw or modify an item.

See Also

InteractionState Members
InteractionState Class


MindFusion.Diagramming.ItemCollectionBase(T) Class

ItemCollectionBase(T) Class
[image]

A base collection class for the diagram item collections.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ItemCollectionBase<T> : CollectionBase<T, DiagramItem> where T : DiagramItem

Visual Basic [image] Copy Code

Public Class ItemCollectionBase(Of T As DiagramItem)
Inherits CollectionBase(Of T, DiagramItem)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.CollectionBase(T, DiagramItem)
MindFusion.Diagramming.ItemCollectionBase(T)
MindFusion.Diagramming.DiagramItemCollection
MindFusion.Diagramming.DiagramLinkCollection
MindFusion.Diagramming.DiagramNodeCollection

See Also

ItemCollectionBase(T) Members


MindFusion.Diagramming.ItemCollectionBase(T) Members

ItemCollectionBase(T) Members
Constructors Fields Properties Methods
[image]

A base collection class for the diagram item collections.

The following tables list the members exposed by the ItemCollectionBase(T) type.

Public Constructors

Name | Description
ItemCollectionBase | Overloaded.

Inherited Protected Fields

Name | Description
itemEventArgs | An ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector. (Inherited from CollectionBase.)
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items. (Inherited from CollectionBase.)

Inherited Public Properties

Name | Description
Count | Gets the number of items contained in the collection. (Inherited from CollectionBase.)
IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from CollectionBase.)
Item | An indexer that lets you access the element at the specified position. (Inherited from CollectionBase.)

Inherited Public Methods

Name | Description
Add | Adds an item to the collection. (Inherited from CollectionBase.)
Clear | Removes all items from the collection. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the List(T). (Inherited from CollectionBase.)
CopyTo | (Inherited from CollectionBase.)
GetEnumerator | Returns an enumerator for this collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts an element into the Collection at the specified index. (Inherited from CollectionBase.)
Remove | Removes the first occurrence of a specific object from the collection. (Inherited from CollectionBase.)
RemoveAt | Removes the element at the specified index of the collection. (Inherited from CollectionBase.)

Inherited Protected Methods

Name | Description
RaiseAdding | Raises the Adding event. (Inherited from CollectionBase.)
RaiseInserting | Raises the Inserting event. (Inherited from CollectionBase.)
RaiseRemoving | Raises the Removing event. (Inherited from CollectionBase.)

See Also

ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T) Constructor

ItemCollectionBase(T) Constructor
[image]

Overload List

Name | Description
ItemCollectionBase(T) () | Initializes a new instance of the ItemCollectionBase class.
ItemCollectionBase(T) (ItemCollectionBase(T)) | Initializes a new instance of the ItemCollectionBase class.

See Also

ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T) Constructor ()

ItemCollectionBase(T) Constructor ()
See Also
[image]

Initializes a new instance of the ItemCollectionBase class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ItemCollectionBase<T> ()

Visual Basic [image] Copy Code

Public Sub New(Of T) ()

See Also

ItemCollectionBase(T) Constructor Overload List
ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T) Constructor (ItemCollectionBase(T))

ItemCollectionBase(T) Constructor (ItemCollectionBase(T))
See Also
[image]

Initializes a new instance of the ItemCollectionBase class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ItemCollectionBase<T> (
ItemCollectionBase<T> prototype
)

Visual Basic [image] Copy Code

Public New (Of T) ( _
prototype As ItemCollectionBase(Of T) _
)

Parameters

prototype

See Also

ItemCollectionBase(T) Constructor Overload List
ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemEventArgs Class

ItemEventArgs Class
[image]

Contains the arguments passed to item instantiation event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ItemEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.ItemEventArgs

See Also

ItemEventArgs Members


MindFusion.Diagramming.ItemEventArgs Members

ItemEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to item instantiation event handlers.

The following tables list the members exposed by the ItemEventArgs type.

Public Constructors

Name | Description
ItemEventArgs | Initializes a new instance of the ItemEventArgs class.

Public Properties

Name | Description
Index | Gets an integer index related to the event.
Item | Gets the item for which the event is raised.

See Also

ItemEventArgs Class


MindFusion.Diagramming.ItemEventArgs Constructor

ItemEventArgs Constructor
[image]

Initializes a new instance of the ItemEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ItemEventArgs (
DiagramItem item
)

Visual Basic [image] Copy Code

Public New ( _
item As DiagramItem _
)

Parameters

item

The DiagramItem related to the event.

See Also

ItemEventArgs Class


MindFusion.Diagramming.ItemEventArgs Properties

ItemEventArgs Properties
[image]

Public Properties

Name | Description
Index | Gets an integer index related to the event.
Item | Gets the item for which the event is raised.

See Also

ItemEventArgs Class


MindFusion.Diagramming.ItemEventArgs.Index Property

ItemEventArgs.Index Property
[image]

Gets an integer index related to the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Index { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Index As Integer

Property Value

See Also

ItemEventArgs Members
ItemEventArgs Class


MindFusion.Diagramming.ItemEventArgs.Item Property

ItemEventArgs.Item Property
[image]

Gets the item for which the event is raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public UIElement Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As UIElement

Property Value

See Also

ItemEventArgs Members
ItemEventArgs Class


MindFusion.Diagramming.ItemEventArgs(T) Class

ItemEventArgs(T) Class
[image]

Contains the arguments passed to item instantiation event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ItemEventArgs<T> : EventArgs

Visual Basic [image] Copy Code

Public Class ItemEventArgs(Of T)
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.ItemEventArgs(T)

See Also

ItemEventArgs(T) Members


MindFusion.Diagramming.ItemEventArgs(T) Members

ItemEventArgs(T) Members
Constructors Properties
[image]

Contains the arguments passed to item instantiation event handlers.

The following tables list the members exposed by the ItemEventArgs(T) type.

Public Constructors

Name | Description
ItemEventArgs | Initializes a new instance of the ItemEventArgs class.

Public Properties

Name | Description
Index | Gets the index of the item.
Item | Gets the item.

See Also

ItemEventArgs(T) Class


MindFusion.Diagramming.ItemEventArgs(T) Constructor

ItemEventArgs(T) Constructor
[image]

Initializes a new instance of the ItemEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ItemEventArgs<T> (
T item
)

Visual Basic [image] Copy Code

Public New (Of T) ( _
item As T _
)

Parameters

item

See Also

ItemEventArgs(T) Class


MindFusion.Diagramming.ItemEventArgs(T) Properties

ItemEventArgs(T) Properties
[image]

Public Properties

Name | Description
Index | Gets the index of the item.
Item | Gets the item.

See Also

ItemEventArgs(T) Class


MindFusion.Diagramming.ItemEventArgs(T).Index Property

ItemEventArgs(T).Index Property
[image]

Gets the index of the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Index { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Index As Integer

Property Value

See Also

ItemEventArgs(T) Members
ItemEventArgs(T) Class


MindFusion.Diagramming.ItemEventArgs(T).Item Property

ItemEventArgs(T).Item Property
[image]

Gets the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public T Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As T

Property Value

See Also

ItemEventArgs(T) Members
ItemEventArgs(T) Class


MindFusion.Diagramming.ItemEventHandler(T) Delegate

ItemEventHandler(T) Delegate
[image]

Represents methods that will handle general item-related events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate void ItemEventHandler<T> (
Object sender,
ItemEventArgs<T> e
)

Visual Basic [image] Copy Code

Public Delegate Sub ItemEventHandler(Of T) ( _
sender As Object, _
e As ItemEventArgs(Of T) _
)

Parameters

sender

The source of the event.

e
An ItemEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.IZoomTarget Interface

IZoomTarget Interface
[image]

Specifies the capabilities required by ZoomControl from its target controls.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface IZoomTarget

Visual Basic [image] Copy Code

Public Interface IZoomTarget

Inheritors

MindFusion.Diagramming.Diagram

See Also

IZoomTarget Members


MindFusion.Diagramming.IZoomTarget Members

IZoomTarget Members
Methods Events
[image]

Specifies the capabilities required by ZoomControl from its target controls.

The following tables list the members exposed by the IZoomTarget type.

Public Methods

Name | Description
GetScrollX | Sets the horizontal scroll position.
GetScrollY | Gets the vertical scroll position.
GetZoomLevel | Gets the current zoom level.
SetScrollX | Sets the horizontal scroll position.
SetScrollY | Sets the vertical scroll position.
SetZoomLevel | Sets a new zoom level.

Public Events

Name | Description
ZoomLevelChanged | Raised to notify that the target's zoom level has changed.

See Also

IZoomTarget Interface


MindFusion.Diagramming.IZoomTarget Methods

IZoomTarget Methods
[image]

Public Methods

Name | Description
GetScrollX | Sets the horizontal scroll position.
GetScrollY | Gets the vertical scroll position.
GetZoomLevel | Gets the current zoom level.
SetScrollX | Sets the horizontal scroll position.
SetScrollY | Sets the vertical scroll position.
SetZoomLevel | Sets a new zoom level.

See Also

IZoomTarget Interface


MindFusion.Diagramming.IZoomTarget.GetScrollX Method

IZoomTarget.GetScrollX Method
[image]

Sets the horizontal scroll position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

double GetScrollX ()

Visual Basic [image] Copy Code

Function GetScrollX () As Double

Return Value

A double value specifying the horizontal scroll position.

See Also

IZoomTarget Members
IZoomTarget Interface


MindFusion.Diagramming.IZoomTarget.GetScrollY Method

IZoomTarget.GetScrollY Method
[image]

Gets the vertical scroll position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

double GetScrollY ()

Visual Basic [image] Copy Code

Function GetScrollY () As Double

Return Value

A double value specifying the vertical scroll position.

See Also

IZoomTarget Members
IZoomTarget Interface


MindFusion.Diagramming.IZoomTarget.GetZoomLevel Method

IZoomTarget.GetZoomLevel Method
[image]

Gets the current zoom level.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

double GetZoomLevel ()

Visual Basic [image] Copy Code

Function GetZoomLevel () As Double

Return Value

A double value specifying the zoom level.

See Also

IZoomTarget Members
IZoomTarget Interface


MindFusion.Diagramming.IZoomTarget.SetScrollX Method

IZoomTarget.SetScrollX Method
[image]

Sets the horizontal scroll position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void SetScrollX (
double scrollX
)

Visual Basic [image] Copy Code

Sub SetScrollX( _
scrollX As Double _
)

Parameters

scrollX

A double value specifying the horizontal scroll position.

See Also

IZoomTarget Members
IZoomTarget Interface


MindFusion.Diagramming.IZoomTarget.SetScrollY Method

IZoomTarget.SetScrollY Method
[image]

Sets the vertical scroll position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void SetScrollY (
double scrollY
)

Visual Basic [image] Copy Code

Sub SetScrollY( _
scrollY As Double _
)

Parameters

scrollY

A double value specifying the vertical scroll position.

See Also

IZoomTarget Members
IZoomTarget Interface


MindFusion.Diagramming.IZoomTarget.SetZoomLevel Method

IZoomTarget.SetZoomLevel Method
[image]

Sets a new zoom level.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void SetZoomLevel (
double zoom
)

Visual Basic [image] Copy Code

Sub SetZoomLevel( _
zoom As Double _
)

Parameters

zoom

A double value specifying the zoom level.

See Also

IZoomTarget Members
IZoomTarget Interface


MindFusion.Diagramming.IZoomTarget Events

IZoomTarget Events
[image]

Public Events

Name | Description
ZoomLevelChanged | Raised to notify that the target's zoom level has changed.

See Also

IZoomTarget Interface


MindFusion.Diagramming.IZoomTarget.ZoomLevelChanged Event

IZoomTarget.ZoomLevelChanged Event
[image]

Raised to notify that the target's zoom level has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

event EventHandler ZoomLevelChanged

Visual Basic [image] Copy Code

Event ZoomLevelChanged As EventHandler

See Also

IZoomTarget Members
IZoomTarget Interface


MindFusion.Diagramming.Layer Class

Layer Class
[image]

Represents a layer in a Diagram object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Layer : DependencyObject

Visual Basic [image] Copy Code

Public Class Layer
Inherits DependencyObject

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
MindFusion.Diagramming.Layer

See Also

Layer Members


MindFusion.Diagramming.Layer Members

Layer Members
Constructors Fields Properties
[image]

Represents a layer in a Diagram object.

The following tables list the members exposed by the Layer type.

Public Constructors

Name | Description
Layer | Initializes a new instance of the Layer class.

Public Fields

Name | Description
ActiveProperty | Identifies the Active dependency property.
LockedProperty | Identifies the Locked dependency property.
TitleProperty | Identifies the Title dependency property.
VisibleProperty | Identifies the Visible dependency property.

Public Properties

Name | Description
Active | Gets or sets a value indicating whether this layer is the active layer of the Diagram. This is a dependency property.
Diagram | For internal use.
Locked | Gets or sets a value indicating whether the layer is locked. This is a dependency property.
Title | Gets or sets a title associated with the layer. This is a dependency property.
Visible | Gets or sets a value indicating whether the layer is visible. This is a dependency property.
ZIndex | Gets or sets the z-index of the layer.

See Also

Layer Class


MindFusion.Diagramming.Layer Fields

Layer Fields
[image]

Public Fields

Name | Description
ActiveProperty | Identifies the Active dependency property.
LockedProperty | Identifies the Locked dependency property.
TitleProperty | Identifies the Title dependency property.
VisibleProperty | Identifies the Visible dependency property.

See Also

Layer Class


MindFusion.Diagramming.Layer.ActiveProperty Field

Layer.ActiveProperty Field
[image]

Identifies the Active dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ActiveProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ActiveProperty As DependencyProperty

See Also

Layer Members
Layer Class


MindFusion.Diagramming.Layer.LockedProperty Field

Layer.LockedProperty Field
[image]

Identifies the Locked dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LockedProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LockedProperty As DependencyProperty

See Also

Layer Members
Layer Class


MindFusion.Diagramming.Layer.TitleProperty Field

Layer.TitleProperty Field
[image]

Identifies the Title dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleProperty As DependencyProperty

See Also

Layer Members
Layer Class


MindFusion.Diagramming.Layer.VisibleProperty Field

Layer.VisibleProperty Field
[image]

Identifies the Visible dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty VisibleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly VisibleProperty As DependencyProperty

See Also

Layer Members
Layer Class


MindFusion.Diagramming.Layer Constructor

Layer Constructor
[image]

Initializes a new instance of the Layer class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Layer ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Layer Class


MindFusion.Diagramming.Layer Properties

Layer Properties
[image]

Public Properties

Name | Description
Active | Gets or sets a value indicating whether this layer is the active layer of the Diagram. This is a dependency property.
Diagram | For internal use.
Locked | Gets or sets a value indicating whether the layer is locked. This is a dependency property.
Title | Gets or sets a title associated with the layer. This is a dependency property.
Visible | Gets or sets a value indicating whether the layer is visible. This is a dependency property.
ZIndex | Gets or sets the z-index of the layer.

See Also

Layer Class


MindFusion.Diagramming.Layer.Active Property

Layer.Active Property
[image]

Gets or sets a value indicating whether this layer is the active layer of the Diagram. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Active { get; set; }

Visual Basic [image] Copy Code

Public Property Active As Boolean

Property Value

true if the layer is the currently active layer; otherwise, false.

See Also

Layer Members
Layer Class


MindFusion.Diagramming.Layer.Diagram Property

Layer.Diagram Property
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Diagram Diagram { get; set; }

Visual Basic [image] Copy Code

Public Property Diagram As Diagram

Property Value

See Also

Layer Members
Layer Class


MindFusion.Diagramming.Layer.Locked Property

Layer.Locked Property
[image]

Gets or sets a value indicating whether the layer is locked. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Locked { get; set; }

Visual Basic [image] Copy Code

Public Property Locked As Boolean

Property Value

true if the layer is locked; otherwise, false.

Remarks

Items associated with locked layers cannot be modified interactively, regardless of their own Locked property.

See Also

Layer Members
Layer Class


MindFusion.Diagramming.Layer.Title Property

Layer.Title Property
[image]

Gets or sets a title associated with the layer. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

A string value.

See Also

Layer Members
Layer Class


MindFusion.Diagramming.Layer.Visible Property

Layer.Visible Property
[image]

Gets or sets a value indicating whether the layer is visible. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Property Visible As Boolean

Property Value

true if the layer is visible; otherwise, false.

Remarks

Items associated with hidden layers are not displayed, regardless of their own Visible property.

See Also

Layer Members
Layer Class


MindFusion.Diagramming.Layer.ZIndex Property

Layer.ZIndex Property
[image]

Gets or sets the z-index of the layer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ZIndex { get; set; }

Visual Basic [image] Copy Code

Public Property ZIndex As Integer

Property Value

An integer value.

See Also

Layer Members
Layer Class


MindFusion.Diagramming.LayerListBox Class

LayerListBox Class
[image]

Represents the ListBox control inside a LayerListView.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public class LayerListBox : ListBox

Visual Basic [image] Copy Code

Public Class LayerListBox
Inherits ListBox

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
Windows.UI.Xaml.Controls.ItemsControl
Windows.UI.Xaml.Controls.Primitives.Selector
Windows.UI.Xaml.Controls.ListBox
MindFusion.Diagramming.LayerListBox

See Also

LayerListBox Members


MindFusion.Diagramming.LayerListBox Members

LayerListBox Members
Constructors Methods
[image]

Represents the ListBox control inside a LayerListView.

The following tables list the members exposed by the LayerListBox type.

Public Constructors

Name | Description
LayerListBox | Initializes a new instance of the LayerListBox class.

Protected Methods

Name | Description
GetContainerForItemOverride | ListBox.GetContainerForItemOverride override.

See Also

LayerListBox Class


MindFusion.Diagramming.LayerListBox Constructor

LayerListBox Constructor
[image]

Initializes a new instance of the LayerListBox class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public LayerListBox ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LayerListBox Class


MindFusion.Diagramming.LayerListBox Methods

LayerListBox Methods
[image]

Protected Methods

Name | Description
GetContainerForItemOverride | ListBox.GetContainerForItemOverride override.

See Also

LayerListBox Class


MindFusion.Diagramming.LayerListBox.GetContainerForItemOverride Method

LayerListBox.GetContainerForItemOverride Method
[image]

ListBox.GetContainerForItemOverride override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

protected override DependencyObject GetContainerForItemOverride ()

Visual Basic [image] Copy Code

Protected Overrides Function GetContainerForItemOverride () As DependencyObject

Return Value

See Also

LayerListBox Members
LayerListBox Class


MindFusion.Diagramming.LayerListBoxItem Class

LayerListBoxItem Class
[image]

Represents an item in a LayerListBox control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public class LayerListBoxItem : ListBoxItem

Visual Basic [image] Copy Code

Public Class LayerListBoxItem
Inherits ListBoxItem

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
Windows.UI.Xaml.Controls.ContentControl
Windows.UI.Xaml.Controls.ListBoxItem
MindFusion.Diagramming.LayerListBoxItem

See Also

LayerListBoxItem Members


MindFusion.Diagramming.LayerListBoxItem Members

LayerListBoxItem Members
Constructors Fields Properties
[image]

Represents an item in a LayerListBox control.

The following tables list the members exposed by the LayerListBoxItem type.

Public Constructors

Name | Description
LayerListBoxItem | Overloaded.

Public Fields

Name | Description
ParentViewProperty | Identifies the ParentView dependency property.

Public Properties

Name | Description
ParentView | Gets or sets the LayerListView control containing this item. This is a dependency property.

See Also

LayerListBoxItem Class


MindFusion.Diagramming.LayerListBoxItem Fields

LayerListBoxItem Fields
[image]

Public Fields

Name | Description
ParentViewProperty | Identifies the ParentView dependency property.

See Also

LayerListBoxItem Class


MindFusion.Diagramming.LayerListBoxItem.ParentViewProperty Field

LayerListBoxItem.ParentViewProperty Field
[image]

Identifies the ParentView dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ParentViewProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ParentViewProperty As DependencyProperty

See Also

LayerListBoxItem Members
LayerListBoxItem Class


MindFusion.Diagramming.LayerListBoxItem Constructor

LayerListBoxItem Constructor
[image]

Overload List

Name | Description
LayerListBoxItem () | Initializes a new instance of the LayerListBoxItem class.
LayerListBoxItem (LayerListView) | Initializes a new instance of the LayerListBoxItem class.

See Also

LayerListBoxItem Class


MindFusion.Diagramming.LayerListBoxItem Constructor ()

LayerListBoxItem Constructor ()
See Also
[image]

Initializes a new instance of the LayerListBoxItem class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public LayerListBoxItem ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LayerListBoxItem Constructor Overload List
LayerListBoxItem Class


MindFusion.Diagramming.LayerListBoxItem Constructor (LayerListView)

LayerListBoxItem Constructor (LayerListView)
See Also
[image]

Initializes a new instance of the LayerListBoxItem class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public LayerListBoxItem (
LayerListView parentView
)

Visual Basic [image] Copy Code

Public New ( _
parentView As LayerListView _
)

Parameters

parentView

See Also

LayerListBoxItem Constructor Overload List
LayerListBoxItem Class


MindFusion.Diagramming.LayerListBoxItem Properties

LayerListBoxItem Properties
[image]

Public Properties

Name | Description
ParentView | Gets or sets the LayerListView control containing this item. This is a dependency property.

See Also

LayerListBoxItem Class


MindFusion.Diagramming.LayerListBoxItem.ParentView Property

LayerListBoxItem.ParentView Property
[image]

Gets or sets the LayerListView control containing this item. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public LayerListView ParentView { get; set; }

Visual Basic [image] Copy Code

Public Property ParentView As LayerListView

Property Value

See Also

LayerListBoxItem Members
LayerListBoxItem Class


MindFusion.Diagramming.LayerListView Class

LayerListView Class
[image]

Represents a list box with MindFusion.Diagramming.Layer objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public class LayerListView : Control

Visual Basic [image] Copy Code

Public Class LayerListView
Inherits Control

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
MindFusion.Diagramming.LayerListView

See Also

LayerListView Members


MindFusion.Diagramming.LayerListView Members

LayerListView Members
Constructors Fields Properties Methods
[image]

Represents a list box with MindFusion.Diagramming.Layer objects.

The following tables list the members exposed by the LayerListView type.

Public Constructors

Name | Description
LayerListView | Initializes a new instance of the LayerListView class.

Public Fields

Name | Description
AllowTitleEditProperty | Identifies the AllowTitleEdit dependency property.
CheckBoxSizeProperty | Identifies the CheckBoxSize dependency property.
DiagramProperty | Identifies the Diagram dependency property.
ItemHeightProperty | Identifies the ItemHeight dependency property.
OverviewWidthProperty | Identifies the OverviewWidth dependency property.

Public Properties

Name | Description
AllowTitleEdit | Gets or sets a value indicating whether layer titles can be in-place edited. This is a dependency property.
CheckBoxSize | Gets or sets the size of the layer checkboxes. This is a dependency property.
Diagram | Gets or sets the diagram associated with this control. This is a dependency property.
ItemHeight | Gets or sets the height of the items. This is a dependency property.
OverviewWidth | Gets or sets the width of the layer overview. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

See Also

LayerListView Class


MindFusion.Diagramming.LayerListView Fields

LayerListView Fields
[image]

Public Fields

Name | Description
AllowTitleEditProperty | Identifies the AllowTitleEdit dependency property.
CheckBoxSizeProperty | Identifies the CheckBoxSize dependency property.
DiagramProperty | Identifies the Diagram dependency property.
ItemHeightProperty | Identifies the ItemHeight dependency property.
OverviewWidthProperty | Identifies the OverviewWidth dependency property.

See Also

LayerListView Class


MindFusion.Diagramming.LayerListView.AllowTitleEditProperty Field

LayerListView.AllowTitleEditProperty Field
[image]

Identifies the AllowTitleEdit dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowTitleEditProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowTitleEditProperty As DependencyProperty

See Also

LayerListView Members
LayerListView Class


MindFusion.Diagramming.LayerListView.CheckBoxSizeProperty Field

LayerListView.CheckBoxSizeProperty Field
[image]

Identifies the CheckBoxSize dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CheckBoxSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CheckBoxSizeProperty As DependencyProperty

See Also

LayerListView Members
LayerListView Class


MindFusion.Diagramming.LayerListView.DiagramProperty Field

LayerListView.DiagramProperty Field
[image]

Identifies the Diagram dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DiagramProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DiagramProperty As DependencyProperty

See Also

LayerListView Members
LayerListView Class


MindFusion.Diagramming.LayerListView.ItemHeightProperty Field

LayerListView.ItemHeightProperty Field
[image]

Identifies the ItemHeight dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemHeightProperty As DependencyProperty

See Also

LayerListView Members
LayerListView Class


MindFusion.Diagramming.LayerListView.OverviewWidthProperty Field

LayerListView.OverviewWidthProperty Field
[image]

Identifies the OverviewWidth dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OverviewWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OverviewWidthProperty As DependencyProperty

See Also

LayerListView Members
LayerListView Class


MindFusion.Diagramming.LayerListView Constructor

LayerListView Constructor
[image]

Initializes a new instance of the LayerListView class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public LayerListView ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LayerListView Class


MindFusion.Diagramming.LayerListView Methods

LayerListView Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

See Also

LayerListView Class


MindFusion.Diagramming.LayerListView.OnApplyTemplate Method

LayerListView.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Overrides Sub OnApplyTemplate ()

See Also

LayerListView Members
LayerListView Class


MindFusion.Diagramming.LayerListView Properties

LayerListView Properties
[image]

Public Properties

Name | Description
AllowTitleEdit | Gets or sets a value indicating whether layer titles can be in-place edited. This is a dependency property.
CheckBoxSize | Gets or sets the size of the layer checkboxes. This is a dependency property.
Diagram | Gets or sets the diagram associated with this control. This is a dependency property.
ItemHeight | Gets or sets the height of the items. This is a dependency property.
OverviewWidth | Gets or sets the width of the layer overview. This is a dependency property.

See Also

LayerListView Class


MindFusion.Diagramming.LayerListView.AllowTitleEdit Property

LayerListView.AllowTitleEdit Property
[image]

Gets or sets a value indicating whether layer titles can be in-place edited. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public bool AllowTitleEdit { get; set; }

Visual Basic [image] Copy Code

Public Property AllowTitleEdit As Boolean

Property Value

true to allow in-place editing of layer titles; otherwise, false. The default is false.

See Also

LayerListView Members
LayerListView Class


MindFusion.Diagramming.LayerListView.CheckBoxSize Property

LayerListView.CheckBoxSize Property
[image]

Gets or sets the size of the layer checkboxes. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public double CheckBoxSize { get; set; }

Visual Basic [image] Copy Code

Public Property CheckBoxSize As Double

Property Value

A double value specifying the size of checkboxes. The default value is 18.

See Also

LayerListView Members
LayerListView Class


MindFusion.Diagramming.LayerListView.Diagram Property

LayerListView.Diagram Property
[image]

Gets or sets the diagram associated with this control. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public Diagram Diagram { get; set; }

Visual Basic [image] Copy Code

Public Property Diagram As Diagram

Property Value

A Diagram object.

See Also

LayerListView Members
LayerListView Class


MindFusion.Diagramming.LayerListView.ItemHeight Property

LayerListView.ItemHeight Property
[image]

Gets or sets the height of the items. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public double ItemHeight { get; set; }

Visual Basic [image] Copy Code

Public Property ItemHeight As Double

Property Value

A double value. The default is 55.

See Also

LayerListView Members
LayerListView Class


MindFusion.Diagramming.LayerListView.OverviewWidth Property

LayerListView.OverviewWidth Property
[image]

Gets or sets the width of the layer overview. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public double OverviewWidth { get; set; }

Visual Basic [image] Copy Code

Public Property OverviewWidth As Double

Property Value

A double value. The default is 55.

See Also

LayerListView Members
LayerListView Class


MindFusion.Diagramming.LineTemplate Class

LineTemplate Class
[image]

Represents a line segment in a shape definition.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LineTemplate : ElementTemplate

Visual Basic [image] Copy Code

Public Class LineTemplate
Inherits ElementTemplate

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ElementTemplate
MindFusion.Diagramming.LineTemplate

See Also

LineTemplate Members


MindFusion.Diagramming.LineTemplate Members

LineTemplate Members
Constructors Properties Methods
[image]

Represents a line segment in a shape definition.

The following tables list the members exposed by the LineTemplate type.

Public Constructors

Name | Description
LineTemplate | Overloaded.

Inherited Public Properties

Name | Description
Color | Gest or sets the outline color of this element. (Inherited from ElementTemplate.)
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

Public Methods

Name | Description
Clone | Create an exact copy of this LineTemplate element.

Inherited Public Methods

Name | Description
Clone | Creates an exact copy of this element. (Inherited from ElementTemplate.)
CompareTo | IComparable.CompareTo implementation. (Inherited from ElementTemplate.)

See Also

LineTemplate Class


MindFusion.Diagramming.LineTemplate Constructor

LineTemplate Constructor
[image]

Overload List

Name | Description
LineTemplate (Double, Double, Double, Double) | Initializes a new instance of the LineTemplate class with the specified start and end point.
LineTemplate (Double, Double, Double, Double, Color, Double) | Initializes a new instance of the LineTemplate class with the specified start and end points, and the specified color and style.

See Also

LineTemplate Class


MindFusion.Diagramming.LineTemplate Constructor (Double, Double, Double, Double)

LineTemplate Constructor (Double, Double, Double, Double)
See Also
[image]

Initializes a new instance of the LineTemplate class with the specified start and end point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LineTemplate (
double x1,
double y1,
double x2,
double y2
)

Visual Basic [image] Copy Code

Public New ( _
x1 As Double, _
y1 As Double, _
x2 As Double, _
y2 As Double _
)

Parameters

x1

The x-coordinate of the first point, expressed in percents of a shape node's bounding rectangle.

y1

The y-coordinate of the first point, expressed in percents of a shape node's bounding rectangle.

x2

The x-coordinate of the second point, expressed in percents of a shape node's bounding rectangle.

y2

The y-coordinate of the second point, expressed in percents of a shape node's bounding rectangle.

Remarks

A line template is defined by two points whose coordinates are passed as arguments.

See Also

LineTemplate Constructor Overload List
LineTemplate Class


MindFusion.Diagramming.LineTemplate Constructor (Double, Double, Double, Double, Color, Double)

LineTemplate Constructor (Double, Double, Double, Double, Color, Double)
See Also
[image]

Initializes a new instance of the LineTemplate class with the specified start and end points, and the specified color and style.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LineTemplate (
double x1,
double y1,
double x2,
double y2,
Color color,
double width
)

Visual Basic [image] Copy Code

Public New ( _
x1 As Double, _
y1 As Double, _
x2 As Double, _
y2 As Double, _
color As Color, _
width As Double _
)

Parameters

x1

The x-coordinate of the first point, expressed in percents of a shape node's bounding rectangle.

y1

The y-coordinate of the first point, expressed in percents of a shape node's bounding rectangle.

x2

The x-coordinate of the second point, expressed in percents of a shape node's bounding rectangle.

y2

The y-coordinate of the second point, expressed in percents of a shape node's bounding rectangle.

color

The color of this segment.

width

The width of this segment.

Remarks

A line template is defined by two points whose coordinates are passed as arguments.

See Also

LineTemplate Constructor Overload List
LineTemplate Class


MindFusion.Diagramming.LineTemplate Methods

LineTemplate Methods
[image]

Public Methods

Name | Description
Clone | Create an exact copy of this LineTemplate element.

Inherited Public Methods

Name | Description
Clone | Creates an exact copy of this element. (Inherited from ElementTemplate.)
CompareTo | IComparable.CompareTo implementation. (Inherited from ElementTemplate.)

See Also

LineTemplate Class


MindFusion.Diagramming.LineTemplate.Clone Method

LineTemplate.Clone Method
[image]

Create an exact copy of this LineTemplate element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

An instance of the LineTemplate class.

See Also

LineTemplate Members
LineTemplate Class


MindFusion.Diagramming.LinkContainersBehavior Class

LinkContainersBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.LinkContainers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LinkContainersBehavior : LinkNodesBehavior

Visual Basic [image] Copy Code

Public Class LinkContainersBehavior
Inherits LinkNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction
MindFusion.Diagramming.BehaviorBase
MindFusion.Diagramming.LinkNodesBehavior
MindFusion.Diagramming.LinkContainersBehavior

See Also

LinkContainersBehavior Members


MindFusion.Diagramming.LinkContainersBehavior Members

LinkContainersBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.LinkContainers.

The following tables list the members exposed by the LinkContainersBehavior type.

Protected Constructors

Name | Description
LinkContainersBehavior | Initializes a new instance of the LinkContainersBehavior class.

Inherited Protected Properties

Name | Description
Diagram | The Diagram object that is being modified. (Inherited from Interaction.)
InteractionState | Gets or sets an InteractionState instance that tracks the modification currently being done on an item. (Inherited from BehaviorBase.)
MouseDownPoint | Gets or sets the position of the mouse when its button has been pressed. (Inherited from BehaviorBase.)

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

Inherited Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | Creates a node of the type appropriate for the current behavior. (Inherited from LinkNodesBehavior.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkContainersBehavior Class


MindFusion.Diagramming.LinkContainersBehavior Constructor

LinkContainersBehavior Constructor
[image]

Initializes a new instance of the LinkContainersBehavior class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected LinkContainersBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected New ( _
diagram As Diagram _
)

Parameters

diagram

The DiagramView this behavior will be associated with.

See Also

LinkContainersBehavior Class


MindFusion.Diagramming.LinkContainersBehavior Methods

LinkContainersBehavior Methods
[image]

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

Inherited Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | Creates a node of the type appropriate for the current behavior. (Inherited from LinkNodesBehavior.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkContainersBehavior Class


MindFusion.Diagramming.LinkContainersBehavior.CreateNode Method

LinkContainersBehavior.CreateNode Method
[image]

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

LinkContainersBehavior Members
LinkContainersBehavior Class


MindFusion.Diagramming.LinkControlsBehavior Class

LinkControlsBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.LinkControls.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LinkControlsBehavior : LinkNodesBehavior

Visual Basic [image] Copy Code

Public Class LinkControlsBehavior
Inherits LinkNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction
MindFusion.Diagramming.BehaviorBase
MindFusion.Diagramming.LinkNodesBehavior
MindFusion.Diagramming.LinkControlsBehavior

See Also

LinkControlsBehavior Members


MindFusion.Diagramming.LinkControlsBehavior Members

LinkControlsBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.LinkControls.

The following tables list the members exposed by the LinkControlsBehavior type.

Public Constructors

Name | Description
LinkControlsBehavior | Initializes a new instance of the LinkControlsBehavior class.

Inherited Protected Properties

Name | Description
Diagram | The Diagram object that is being modified. (Inherited from Interaction.)
InteractionState | Gets or sets an InteractionState instance that tracks the modification currently being done on an item. (Inherited from BehaviorBase.)
MouseDownPoint | Gets or sets the position of the mouse when its button has been pressed. (Inherited from BehaviorBase.)

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

Inherited Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | Creates a node of the type appropriate for the current behavior. (Inherited from LinkNodesBehavior.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkControlsBehavior Class


MindFusion.Diagramming.LinkControlsBehavior Constructor

LinkControlsBehavior Constructor
[image]

Initializes a new instance of the LinkControlsBehavior class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkControlsBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Public Function LinkControlsBehavior ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram this behavior will be associated with.

See Also

LinkControlsBehavior Class


MindFusion.Diagramming.LinkControlsBehavior Methods

LinkControlsBehavior Methods
[image]

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

Inherited Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | Creates a node of the type appropriate for the current behavior. (Inherited from LinkNodesBehavior.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkControlsBehavior Class


MindFusion.Diagramming.LinkControlsBehavior.CreateNode Method

LinkControlsBehavior.CreateNode Method
[image]

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateNode () As DiagramNode

Return Value

See Also

LinkControlsBehavior Members
LinkControlsBehavior Class


MindFusion.Diagramming.LinkCrossings Enumeration

LinkCrossings Enumeration
[image]

Defines values that indicate how to render link intersection points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum LinkCrossings

Visual Basic [image] Copy Code

Public Enum LinkCrossings

Members

Member name | Description
Arcs | An arc is drawn at the intersection point of two links. It connects the segments of the link at higher Z position and goes over the link at lower Z.
Cut | The intersection segments of links at lower Z position are cut by links at higher Z position.
Straight | No special indication for link intersection points.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.LinkEventArgs Class

LinkEventArgs Class
[image]

Contains the arguments passed to handlers of link related events, such as LinkCreated and LinkDeleted.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LinkEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class LinkEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.LinkEventArgs
MindFusion.Diagramming.LinkShapeEventArgs
MindFusion.Diagramming.LinkValidationEventArgs
MindFusion.Diagramming.VirtualLinkEventArgs

See Also

LinkEventArgs Members


MindFusion.Diagramming.LinkEventArgs Members

LinkEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to handlers of link related events, such as LinkCreated and LinkDeleted.

The following tables list the members exposed by the LinkEventArgs type.

Public Constructors

Name | Description
LinkEventArgs | Overloaded.

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user.
Link | Gets the link for which the event raised.
MouseButton | Gets which mouse button was pressed.
MousePosition | Gets or sets the current mouse pointer position.

See Also

LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs Constructor

LinkEventArgs Constructor
[image]

Overload List

Name | Description
LinkEventArgs (DiagramLink) | Initializes a new instance of the LinkEventArgs class.
LinkEventArgs (DiagramLink, Point, Int32) | Initializes a new instance of the LinkEventArgs class.
LinkEventArgs (DiagramLink, Point, MouseButton) | Initializes a new instance of the LinkEventArgs class.

See Also

LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs Constructor (DiagramLink)

LinkEventArgs Constructor (DiagramLink)
See Also
[image]

Initializes a new instance of the LinkEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkEventArgs (
DiagramLink link
)

Visual Basic [image] Copy Code

Public Function LinkEventArgs ( _
link As DiagramLink _
)

Parameters

link
The DiagramLink related to the event.

See Also

LinkEventArgs Constructor Overload List
LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs Constructor (DiagramLink, Point, Int32)

LinkEventArgs Constructor (DiagramLink, Point, Int32)
See Also
[image]

Initializes a new instance of the LinkEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkEventArgs (
DiagramLink link,
Point mousePosition,
int adjustmentHandle
)

Visual Basic [image] Copy Code

Public Function LinkEventArgs ( _
link As DiagramLink, _
mousePosition As Point, _
adjustmentHandle As Integer _
)

Parameters

link
The DiagramLink related to the event.
mousePosition

The mouse button related to the event.

adjustmentHandle

The position of the mouse cursor, in document coordinates.

See Also

LinkEventArgs Constructor Overload List
LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs Constructor (DiagramLink, Point, MouseButton)

LinkEventArgs Constructor (DiagramLink, Point, MouseButton)
See Also
[image]

Initializes a new instance of the LinkEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkEventArgs (
DiagramLink link,
Point mousePosition,
MouseButton mouseButton
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink, _
mousePosition As Point, _
mouseButton As MouseButton _
)

Parameters

link

The DiagramLink related to the event.

mousePosition

The zero-based index of the control point related to the event.

mouseButton

The position of the mouse cursor, in document coordinates.

See Also

LinkEventArgs Constructor Overload List
LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs Properties

LinkEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user.
Link | Gets the link for which the event raised.
MouseButton | Gets which mouse button was pressed.
MousePosition | Gets or sets the current mouse pointer position.

See Also

LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs.AdjustmentHandle Property

LinkEventArgs.AdjustmentHandle Property
[image]

Gets or sets the adjustment handle being moved by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int AdjustmentHandle { get; set; }

Visual Basic [image] Copy Code

Public Property AdjustmentHandle As Integer

Property Value

An integer that represents the index of the link's control point being moved.

See Also

LinkEventArgs Members
LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs.Link Property

LinkEventArgs.Link Property
[image]

Gets the link for which the event raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink Link { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Link As DiagramLink

Property Value

A DiagramLink instance.

See Also

LinkEventArgs Members
LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs.MouseButton Property

LinkEventArgs.MouseButton Property
[image]

Gets which mouse button was pressed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MouseButton MouseButton { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MouseButton As MouseButton

Property Value

See Also

LinkEventArgs Members
LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs.MousePosition Property

LinkEventArgs.MousePosition Property
[image]

Gets or sets the current mouse pointer position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point MousePosition { get; set; }

Visual Basic [image] Copy Code

Public Property MousePosition As Point

Property Value

A WinRT Windows.UI.Xaml Point object specifying the current mouse position.

See Also

LinkEventArgs Members
LinkEventArgs Class


MindFusion.Diagramming.LinkLabel Class

LinkLabel Class
[image]

Represents a label displayed by a DiagramLink. New labels can be added to a link by calling the DiagramLink.AddLabel method.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LinkLabel : Control, InplaceEditable

Visual Basic [image] Copy Code

Public Class LinkLabel
Inherits Control
Implements InplaceEditable

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
MindFusion.Diagramming.LinkLabel

See Also

LinkLabel Members


MindFusion.Diagramming.LinkLabel Members

LinkLabel Members
Constructors Fields Properties Methods
[image]

Represents a label displayed by a DiagramLink. New labels can be added to a link by calling the DiagramLink.AddLabel method.

The following tables list the members exposed by the LinkLabel type.

Public Constructors

Name | Description
LinkLabel | Overloaded.

Public Fields

Name | Description
EnableWrapProperty | Identifies the EnableWrap dependency property.
HorizontalOffsetProperty | Identifies the HorizontalOffset dependency property.
IndexProperty | Identifies the Index dependency property.
RelativeToProperty | Identifies the RelativeTo dependency property.
TextProperty | Identifies the Text dependency property
VerticalOffsetProperty | Identifies the VerticalOffset dependency property.

Public Properties

Name | Description
AutoArrange | Gets or sets a value indicating whether the label can be auto arranged.
Brush | Gets or sets the brush used to draw the label's background.
EnableWrap | Gets or sets a value indicating whether the label's text can be wrapped. This is a dependency property.
HorizontalOffset | Gets or sets the label's horizontal offset. This is a dependency property.
Index | Gets or sets the index of the segment or control point this label is relative to. This is a dependency property.
Link | Gets or sets the DiagramLink that displays this label.
RelativeTo | Gets or sets the label's relative positioning. This is a dependency property.
Text | Gets or sets the label's text. This is a dependency property.
VerticalOffset | Gets or sets the label's vertical offset. This is a dependency property.

Public Methods

Name | Description
Clone | Creates a clone of this label.
GetDiagramItem | InplaceEditable.GetDiagramItem implementation.
GetEditRect | InplaceEditable.GetEditRect implementation.
GetTextToEdit | InplaceEditable.GetTextToEdit implementation.
LoadFromXml | Loads the label from the specified XML element.
SaveToXml | Saves the label into the specified XML element.
SetControlPointPosition | Positions this label relatively to the specified control point.
SetEditedText | InplaceEditable.SetEditedText implementation.
SetLinkLengthPosition | Positions this label relatively to the link length.
SetSegmentPosition | Positions this label relatively to the specified link segment.

Protected Methods

Name | Description
PointAlongLength | Returns a point lying on a polyline that is positioned at a relative position along the polyline's length.

See Also

LinkLabel Class


MindFusion.Diagramming.LinkLabel Fields

LinkLabel Fields
[image]

Public Fields

Name | Description
EnableWrapProperty | Identifies the EnableWrap dependency property.
HorizontalOffsetProperty | Identifies the HorizontalOffset dependency property.
IndexProperty | Identifies the Index dependency property.
RelativeToProperty | Identifies the RelativeTo dependency property.
TextProperty | Identifies the Text dependency property
VerticalOffsetProperty | Identifies the VerticalOffset dependency property.

See Also

LinkLabel Class


MindFusion.Diagramming.LinkLabel.EnableWrapProperty Field

LinkLabel.EnableWrapProperty Field
[image]

Identifies the EnableWrap dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EnableWrapProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EnableWrapProperty As DependencyProperty

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.HorizontalOffsetProperty Field

LinkLabel.HorizontalOffsetProperty Field
[image]

Identifies the HorizontalOffset dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HorizontalOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HorizontalOffsetProperty As DependencyProperty

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.IndexProperty Field

LinkLabel.IndexProperty Field
[image]

Identifies the Index dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IndexProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IndexProperty As DependencyProperty

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.RelativeToProperty Field

LinkLabel.RelativeToProperty Field
[image]

Identifies the RelativeTo dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RelativeToProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RelativeToProperty As DependencyProperty

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.TextProperty Field

LinkLabel.TextProperty Field
[image]

Identifies the Text dependency property

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextProperty As DependencyProperty

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.VerticalOffsetProperty Field

LinkLabel.VerticalOffsetProperty Field
[image]

Identifies the VerticalOffset dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty VerticalOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly VerticalOffsetProperty As DependencyProperty

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel Constructor

LinkLabel Constructor
[image]

Overload List

Name | Description
LinkLabel () | Initializes a new instance of the LinkLabel class.
LinkLabel (DiagramLink) | Initializes a new instance of the LinkLabel class.
LinkLabel (DiagramLink, String) | Initializes a new instance of the LinkLabel class.

See Also

LinkLabel Class


MindFusion.Diagramming.LinkLabel Constructor ()

LinkLabel Constructor ()
See Also
[image]

Initializes a new instance of the LinkLabel class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkLabel ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LinkLabel Constructor Overload List
LinkLabel Class


MindFusion.Diagramming.LinkLabel Constructor (DiagramLink)

LinkLabel Constructor (DiagramLink)
See Also
[image]

Initializes a new instance of the LinkLabel class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkLabel (
DiagramLink link
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink _
)

Parameters

link

The DiagramLink that displays the label.

See Also

LinkLabel Constructor Overload List
LinkLabel Class


MindFusion.Diagramming.LinkLabel Constructor (DiagramLink, String)

LinkLabel Constructor (DiagramLink, String)
See Also
[image]

Initializes a new instance of the LinkLabel class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkLabel (
DiagramLink link,
string text
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink, _
text As String _
)

Parameters

link

The DiagramLink that displays the label.

text

The label's text.

See Also

LinkLabel Constructor Overload List
LinkLabel Class


MindFusion.Diagramming.LinkLabel Methods

LinkLabel Methods
[image]

Public Methods

Name | Description
Clone | Creates a clone of this label.
GetDiagramItem | InplaceEditable.GetDiagramItem implementation.
GetEditRect | InplaceEditable.GetEditRect implementation.
GetTextToEdit | InplaceEditable.GetTextToEdit implementation.
LoadFromXml | Loads the label from the specified XML element.
SaveToXml | Saves the label into the specified XML element.
SetControlPointPosition | Positions this label relatively to the specified control point.
SetEditedText | InplaceEditable.SetEditedText implementation.
SetLinkLengthPosition | Positions this label relatively to the link length.
SetSegmentPosition | Positions this label relatively to the specified link segment.

Protected Methods

Name | Description
PointAlongLength | Returns a point lying on a polyline that is positioned at a relative position along the polyline's length.

See Also

LinkLabel Class


MindFusion.Diagramming.LinkLabel.Clone Method

LinkLabel.Clone Method
[image]

Creates a clone of this label.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual LinkLabel Clone ()

Visual Basic [image] Copy Code

Public Overridable Function Clone () As LinkLabel

Return Value

A new LinkLabel instance that is an exact copy of this label.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.GetDiagramItem Method

LinkLabel.GetDiagramItem Method
[image]

InplaceEditable.GetDiagramItem implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem GetDiagramItem ()

Visual Basic [image] Copy Code

Public Function GetDiagramItem () As DiagramItem

Return Value

A DiagramItem object.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.GetEditRect Method

LinkLabel.GetEditRect Method
[image]

InplaceEditable.GetEditRect implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect GetEditRect (
Point mousePosition
)

Visual Basic [image] Copy Code

Public Function GetEditRect( _
mousePosition As Point _
) As Rect

Parameters

mousePosition

A Point instance specifying the mouse position.

Return Value

A Rect specifying the text box position.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.GetTextToEdit Method

LinkLabel.GetTextToEdit Method
[image]

InplaceEditable.GetTextToEdit implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string GetTextToEdit ()

Visual Basic [image] Copy Code

Public Function GetTextToEdit () As String

Return Value

A string value.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.LoadFromXml Method

LinkLabel.LoadFromXml Method
[image]

Loads the label from the specified XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

A XmlElement instance.

context

A XmlPersistContext instance.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.PointAlongLength Method

LinkLabel.PointAlongLength Method
[image]

Returns a point lying on a polyline that is positioned at a relative position along the polyline's length.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Point PointAlongLength (
double lengthFactor,
List<Point> segments
)

Visual Basic [image] Copy Code

Protected Function PointAlongLength( _
lengthFactor As Double, _
segments As List(Of Point) _
) As Point

Parameters

lengthFactor

A value from 0 to 1 specifying a portion of link's length.

segments

A list of points specifying the polyline segments.

Return Value

A Point instance.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.SaveToXml Method

LinkLabel.SaveToXml Method
[image]

Saves the label into the specified XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

A XmlElement instance.

context

A XmlPersistContext instance.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.SetControlPointPosition Method

LinkLabel.SetControlPointPosition Method
[image]

Positions this label relatively to the specified control point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetControlPointPosition (
int controlPoint,
float dx,
float dy
)

Visual Basic [image] Copy Code

Public Sub SetControlPointPosition( _
controlPoint As Integer, _
dx As Single, _
dy As Single _
)

Parameters

controlPoint

The control point index.

dx

Horizontal offset from the point.

dy

Vertical offset from the point.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.SetEditedText Method

LinkLabel.SetEditedText Method
[image]

InplaceEditable.SetEditedText implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetEditedText (
string newText
)

Visual Basic [image] Copy Code

Public Sub SetEditedText( _
newText As String _
)

Parameters

newText

The new text of the in-place edited object.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.SetLinkLengthPosition Method

LinkLabel.SetLinkLengthPosition Method
[image]

Positions this label relatively to the link length.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetLinkLengthPosition (
float lengthFactor
)

Visual Basic [image] Copy Code

Public Sub SetLinkLengthPosition( _
lengthFactor As Single _
)

Parameters

lengthFactor

A value between 0 and 1 specifying the position of the label relatively to the link's length.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.SetSegmentPosition Method

LinkLabel.SetSegmentPosition Method
[image]

Positions this label relatively to the specified link segment.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetSegmentPosition (
int segment,
float dx,
float dy
)

Visual Basic [image] Copy Code

Public Sub SetSegmentPosition( _
segment As Integer, _
dx As Single, _
dy As Single _
)

Parameters

segment

The segment index.

dx

Horizontal offset from the segment center.

dy

Vertical offset from the segment center.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel Properties

LinkLabel Properties
[image]

Public Properties

Name | Description
AutoArrange | Gets or sets a value indicating whether the label can be auto arranged.
Brush | Gets or sets the brush used to draw the label's background.
EnableWrap | Gets or sets a value indicating whether the label's text can be wrapped. This is a dependency property.
HorizontalOffset | Gets or sets the label's horizontal offset. This is a dependency property.
Index | Gets or sets the index of the segment or control point this label is relative to. This is a dependency property.
Link | Gets or sets the DiagramLink that displays this label.
RelativeTo | Gets or sets the label's relative positioning. This is a dependency property.
Text | Gets or sets the label's text. This is a dependency property.
VerticalOffset | Gets or sets the label's vertical offset. This is a dependency property.

See Also

LinkLabel Class


MindFusion.Diagramming.LinkLabel.AutoArrange Property

LinkLabel.AutoArrange Property
[image]

Gets or sets a value indicating whether the label can be auto arranged.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoArrange { get; set; }

Visual Basic [image] Copy Code

Public Property AutoArrange As Boolean

Property Value

true to automatically place the label; otherwise, false.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.Brush Property

LinkLabel.Brush Property
[image]

Gets or sets the brush used to draw the label's background.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

A Brush used to paint the label's background. The default value is null.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.EnableWrap Property

LinkLabel.EnableWrap Property
[image]

Gets or sets a value indicating whether the label's text can be wrapped. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableWrap { get; set; }

Visual Basic [image] Copy Code

Public Property EnableWrap As Boolean

Property Value

true to enable text wrapping; otherwise, false.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.HorizontalOffset Property

LinkLabel.HorizontalOffset Property
[image]

Gets or sets the label's horizontal offset. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double HorizontalOffset { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalOffset As Double

Property Value

A double value.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.Index Property

LinkLabel.Index Property
[image]

Gets or sets the index of the segment or control point this label is relative to. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Index { get; set; }

Visual Basic [image] Copy Code

Public Property Index As Integer

Property Value

An integer value.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.Link Property

LinkLabel.Link Property
[image]

Gets or sets the DiagramLink that displays this label.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink Link { get; set; }

Visual Basic [image] Copy Code

Public Property Link As DiagramLink

Property Value

A DiagramLink object.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.RelativeTo Property

LinkLabel.RelativeTo Property
[image]

Gets or sets the label's relative positioning. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RelativeToLink RelativeTo { get; set; }

Visual Basic [image] Copy Code

Public Property RelativeTo As RelativeToLink

Property Value

A member of the RelativeToLink enumeration. The default is LinkLength.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.Text Property

LinkLabel.Text Property
[image]

Gets or sets the label's text. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Text { get; set; }

Visual Basic [image] Copy Code

Public Property Text As String

Property Value

A string specifying the label's text.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.VerticalOffset Property

LinkLabel.VerticalOffset Property
[image]

Gets or sets the label's vertical offset. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double VerticalOffset { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalOffset As Double

Property Value

A double value.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkNodesBehavior Class

LinkNodesBehavior Class
[image]

The base class for behavior types that allow drawing both nodes and links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class LinkNodesBehavior : BehaviorBase

Visual Basic [image] Copy Code

Public MustInherit Class LinkNodesBehavior
Inherits BehaviorBase

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction
MindFusion.Diagramming.BehaviorBase
MindFusion.Diagramming.LinkNodesBehavior
MindFusion.Diagramming.LinkContainersBehavior
MindFusion.Diagramming.LinkControlsBehavior
MindFusion.Diagramming.LinkShapesBehavior
MindFusion.Diagramming.LinkTablesBehavior
MindFusion.Diagramming.LinkTreeViewsBehavior

See Also

LinkNodesBehavior Members


MindFusion.Diagramming.LinkNodesBehavior Members

LinkNodesBehavior Members
Constructors Properties Methods
[image]

The base class for behavior types that allow drawing both nodes and links.

The following tables list the members exposed by the LinkNodesBehavior type.

Protected Constructors

Name | Description
LinkNodesBehavior | Initializes a new instance of the LinkNodesBehavior class.

Inherited Protected Properties

Name | Description
Diagram | The Diagram object that is being modified. (Inherited from Interaction.)
InteractionState | Gets or sets an InteractionState instance that tracks the modification currently being done on an item. (Inherited from BehaviorBase.)
MouseDownPoint | Gets or sets the position of the mouse when its button has been pressed. (Inherited from BehaviorBase.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Protected Methods

Name | Description
CreateNode | Creates a node of the type appropriate for the current behavior.

Inherited Public Methods

Name | Description
SetMouseCursor | Invoked while the mouse is moved to let Behavior objects set the mouse cursor depending on the context. (Inherited from BehaviorBase.)
StartDraw | Invoked when a user presses the left mouse button inside the diagram drawing area. (Inherited from BehaviorBase.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkNodesBehavior Class


MindFusion.Diagramming.LinkNodesBehavior Constructor

LinkNodesBehavior Constructor
[image]

Initializes a new instance of the LinkNodesBehavior class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected LinkNodesBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected Function LinkNodesBehavior ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram this behavior will be associated with.

See Also

LinkNodesBehavior Class


MindFusion.Diagramming.LinkNodesBehavior Methods

LinkNodesBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Protected Methods

Name | Description
CreateNode | Creates a node of the type appropriate for the current behavior.

Inherited Public Methods

Name | Description
SetMouseCursor | Invoked while the mouse is moved to let Behavior objects set the mouse cursor depending on the context. (Inherited from BehaviorBase.)
StartDraw | Invoked when a user presses the left mouse button inside the diagram drawing area. (Inherited from BehaviorBase.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkNodesBehavior Class


MindFusion.Diagramming.LinkNodesBehavior.CreateNode Method

LinkNodesBehavior.CreateNode Method
[image]

Creates a node of the type appropriate for the current behavior.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected abstract DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected MustOverride Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

LinkNodesBehavior Members
LinkNodesBehavior Class


MindFusion.Diagramming.LinkNodesBehavior.SetMouseCursor Method

LinkNodesBehavior.SetMouseCursor Method
[image]

BehaviorBase.SetMouseCursor override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Cursor SetMouseCursor (
Point point,
out bool startInteraction
)

Visual Basic [image] Copy Code

Public Overrides Function SetMouseCursor( _
point As Point, _
<System.Runtime.InteropServices.Out()> ByRef startInteraction As Boolean _
) As Cursor

Parameters

point

startInteraction

Return Value

See Also

LinkNodesBehavior Members
LinkNodesBehavior Class


MindFusion.Diagramming.LinkNodesBehavior.StartDraw Method

LinkNodesBehavior.StartDraw Method
[image]

BehaviorBase.StartDraw override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override InteractionState StartDraw (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function StartDraw ( _
point As Point _
) As InteractionState

Parameters

point

A Point structure, which specifies the current position of the mouse cursor, in document coordinates.

Return Value

An instance of the InteractionState class.

See Also

LinkNodesBehavior Members
LinkNodesBehavior Class


MindFusion.Diagramming.LinkShape Enumeration

LinkShape Enumeration
[image]

Specifies available link shapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum LinkShape

Visual Basic [image] Copy Code

Public Enum LinkShape

Members

Member name | Description
Bezier | The segments of a link are Bézier curves.
Cascading | The segments of a link are horizontal and vertical lines, each one orthogonal to each adjacent segment.
Polyline | The segments of the link are straight lines.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.LinkShapeEventArgs Class

LinkShapeEventArgs Class
[image]

Contains the arguments passed to the SetSelfLoopShape event handler.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LinkShapeEventArgs : LinkEventArgs

Visual Basic [image] Copy Code

Public Class LinkShapeEventArgs
Inherits LinkEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.LinkEventArgs
MindFusion.Diagramming.LinkShapeEventArgs

See Also

LinkShapeEventArgs Members


MindFusion.Diagramming.LinkShapeEventArgs Members

LinkShapeEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the SetSelfLoopShape event handler.

The following tables list the members exposed by the LinkShapeEventArgs type.

Public Constructors

Name | Description
LinkShapeEventArgs | Initializes a new instance of the LinkShapeEventArgs class.

Public Properties

Name | Description
Handled | Indicates whether the event handler has set a custom loop shape.

Inherited Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from LinkEventArgs.)
Link | Gets the link for which the event raised. (Inherited from LinkEventArgs.)
MouseButton | Gets which mouse button was pressed. (Inherited from LinkEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from LinkEventArgs.)

See Also

LinkShapeEventArgs Class


MindFusion.Diagramming.LinkShapeEventArgs Constructor

LinkShapeEventArgs Constructor
[image]

Initializes a new instance of the LinkShapeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkShapeEventArgs (
DiagramLink link
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink _
)

Parameters

link

The DiagramLink that becomes a self-loop.

See Also

LinkShapeEventArgs Class


MindFusion.Diagramming.LinkShapeEventArgs Properties

LinkShapeEventArgs Properties
[image]

Public Properties

Name | Description
Handled | Indicates whether the event handler has set a custom loop shape.

Inherited Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from LinkEventArgs.)
Link | Gets the link for which the event raised. (Inherited from LinkEventArgs.)
MouseButton | Gets which mouse button was pressed. (Inherited from LinkEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from LinkEventArgs.)

See Also

LinkShapeEventArgs Class


MindFusion.Diagramming.LinkShapeEventArgs.Handled Property

LinkShapeEventArgs.Handled Property
[image]

Indicates whether the event handler has set a custom loop shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Handled { get; set; }

Visual Basic [image] Copy Code

Public Property Handled As Boolean

Property Value

See Also

LinkShapeEventArgs Members
LinkShapeEventArgs Class


MindFusion.Diagramming.LinkShapesBehavior Class

LinkShapesBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.LinkShapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LinkShapesBehavior : LinkNodesBehavior

Visual Basic [image] Copy Code

Public Class LinkShapesBehavior
Inherits LinkNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction
MindFusion.Diagramming.BehaviorBase
MindFusion.Diagramming.LinkNodesBehavior
MindFusion.Diagramming.LinkShapesBehavior

See Also

LinkShapesBehavior Members


MindFusion.Diagramming.LinkShapesBehavior Members

LinkShapesBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.LinkShapes.

The following tables list the members exposed by the LinkShapesBehavior type.

Protected Constructors

Name | Description
LinkShapesBehavior | Initializes a new instance of the LinkShapesBehavior class.

Inherited Protected Properties

Name | Description
Diagram | The Diagram object that is being modified. (Inherited from Interaction.)
InteractionState | Gets or sets an InteractionState instance that tracks the modification currently being done on an item. (Inherited from BehaviorBase.)
MouseDownPoint | Gets or sets the position of the mouse when its button has been pressed. (Inherited from BehaviorBase.)

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

Inherited Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | Creates a node of the type appropriate for the current behavior. (Inherited from LinkNodesBehavior.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkShapesBehavior Class


MindFusion.Diagramming.LinkShapesBehavior Constructor

LinkShapesBehavior Constructor
[image]

Initializes a new instance of the LinkShapesBehavior class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected LinkShapesBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected Function LinkShapesBehavior ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram this behavior will be associated with.

See Also

LinkShapesBehavior Class


MindFusion.Diagramming.LinkShapesBehavior Methods

LinkShapesBehavior Methods
[image]

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

Inherited Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | Creates a node of the type appropriate for the current behavior. (Inherited from LinkNodesBehavior.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkShapesBehavior Class


MindFusion.Diagramming.LinkShapesBehavior.CreateNode Method

LinkShapesBehavior.CreateNode Method
[image]

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

LinkShapesBehavior Members
LinkShapesBehavior Class


MindFusion.Diagramming.LinkTablesBehavior Class

LinkTablesBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.LinkTables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LinkTablesBehavior : LinkNodesBehavior

Visual Basic [image] Copy Code

Public Class LinkTablesBehavior
Inherits LinkNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction
MindFusion.Diagramming.BehaviorBase
MindFusion.Diagramming.LinkNodesBehavior
MindFusion.Diagramming.LinkTablesBehavior

See Also

LinkTablesBehavior Members


MindFusion.Diagramming.LinkTablesBehavior Members

LinkTablesBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.LinkTables.

The following tables list the members exposed by the LinkTablesBehavior type.

Protected Constructors

Name | Description
LinkTablesBehavior | Initializes a new instance of the LinkTablesBehavior class.

Inherited Protected Properties

Name | Description
Diagram | The Diagram object that is being modified. (Inherited from Interaction.)
InteractionState | Gets or sets an InteractionState instance that tracks the modification currently being done on an item. (Inherited from BehaviorBase.)
MouseDownPoint | Gets or sets the position of the mouse when its button has been pressed. (Inherited from BehaviorBase.)

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

Inherited Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | Creates a node of the type appropriate for the current behavior. (Inherited from LinkNodesBehavior.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkTablesBehavior Class


MindFusion.Diagramming.LinkTablesBehavior Constructor

LinkTablesBehavior Constructor
[image]

Initializes a new instance of the LinkTablesBehavior class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected LinkTablesBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected Function LinkTablesBehavior ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram this behavior will be associated with.

See Also

LinkTablesBehavior Class


MindFusion.Diagramming.LinkTablesBehavior Methods

LinkTablesBehavior Methods
[image]

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

Inherited Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | Creates a node of the type appropriate for the current behavior. (Inherited from LinkNodesBehavior.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkTablesBehavior Class


MindFusion.Diagramming.LinkTablesBehavior.CreateNode Method

LinkTablesBehavior.CreateNode Method
[image]

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateNode () As DiagramNode

Return Value

See Also

LinkTablesBehavior Members
LinkTablesBehavior Class


MindFusion.Diagramming.LinkTreeViewsBehavior Class

LinkTreeViewsBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.LinkTreeViews.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LinkTreeViewsBehavior : LinkNodesBehavior

Visual Basic [image] Copy Code

Public Class LinkTreeViewsBehavior
Inherits LinkNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction
MindFusion.Diagramming.BehaviorBase
MindFusion.Diagramming.LinkNodesBehavior
MindFusion.Diagramming.LinkTreeViewsBehavior

See Also

LinkTreeViewsBehavior Members


MindFusion.Diagramming.LinkTreeViewsBehavior Members

LinkTreeViewsBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.LinkTreeViews.

The following tables list the members exposed by the LinkTreeViewsBehavior type.

Protected Constructors

Name | Description
LinkTreeViewsBehavior | Initializes a new instance of the LinkTreeViewsBehavior class.

Inherited Protected Properties

Name | Description
Diagram | The Diagram object that is being modified. (Inherited from Interaction.)
InteractionState | Gets or sets an InteractionState instance that tracks the modification currently being done on an item. (Inherited from BehaviorBase.)
MouseDownPoint | Gets or sets the position of the mouse when its button has been pressed. (Inherited from BehaviorBase.)

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

Inherited Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | Creates a node of the type appropriate for the current behavior. (Inherited from LinkNodesBehavior.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkTreeViewsBehavior Class


MindFusion.Diagramming.LinkTreeViewsBehavior Constructor

LinkTreeViewsBehavior Constructor
[image]

Initializes a new instance of the LinkTreeViewsBehavior class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected LinkTreeViewsBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected New ( _
diagram As Diagram _
)

Parameters

diagram

The Diagram this behavior will be associated with.

See Also

LinkTreeViewsBehavior Class


MindFusion.Diagramming.LinkTreeViewsBehavior Methods

LinkTreeViewsBehavior Methods
[image]

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

Inherited Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | Creates a node of the type appropriate for the current behavior. (Inherited from LinkNodesBehavior.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkTreeViewsBehavior Class


MindFusion.Diagramming.LinkTreeViewsBehavior.CreateNode Method

LinkTreeViewsBehavior.CreateNode Method
[image]

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

LinkTreeViewsBehavior Members
LinkTreeViewsBehavior Class


MindFusion.Diagramming.LinkValidationEventArgs Class

LinkValidationEventArgs Class
[image]

Contains the arguments passed to handlers of link validation events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LinkValidationEventArgs : LinkEventArgs

Visual Basic [image] Copy Code

Public Class LinkValidationEventArgs
Inherits LinkEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.LinkEventArgs
MindFusion.Diagramming.LinkValidationEventArgs

See Also

LinkValidationEventArgs Members


MindFusion.Diagramming.LinkValidationEventArgs Members

LinkValidationEventArgs Members
Constructors Properties Methods
[image]

Contains the arguments passed to handlers of link validation events.

The following tables list the members exposed by the LinkValidationEventArgs type.

Public Constructors

Name | Description
LinkValidationEventArgs | Overloaded.

Public Properties

Name | Description
AnchorIndex | Gets the anchor point related to a link validation event.
Cancel | Gets or sets a value indicating whether to cancel the current operation.
ChangingDestination | Gets a value indicating whether the user modifies the link's destination end point.
ChangingOrigin | Gets a value indicating whether the user modifies the link's origin end point.
Destination | Gets the node that will become the link's destination if the event is validated.
Node | Gets the node to which the link will be connected.
Origin | Gets the node that would become the link's origin if the event is validated.
SelectionRectangle | Gets the current selection rectangle.
TableRow | Gets the table row related to a link validation event.

Inherited Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from LinkEventArgs.)
Link | Gets the link for which the event raised. (Inherited from LinkEventArgs.)
MouseButton | Gets which mouse button was pressed. (Inherited from LinkEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from LinkEventArgs.)

Public Methods

Name | Description
CancelDrag | Cancels the creation or modification of the link.

See Also

LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs Constructor

LinkValidationEventArgs Constructor
[image]

Overload List

Name | Description
LinkValidationEventArgs (DiagramLink) | Initializes a new instance of the LinkValidationEventArgs class.
LinkValidationEventArgs (DiagramLink, Point, Int32, DiagramNode, Int32, Int32) | Initializes a new instance of the LinkValidationEventArgs class.
LinkValidationEventArgs (DiagramLink, Rect) | Initializes a new instance of the LinkValidationEventArgs class.

See Also

LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs Constructor (DiagramLink)

LinkValidationEventArgs Constructor (DiagramLink)
See Also
[image]

Initializes a new instance of the LinkValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkValidationEventArgs (
DiagramLink link
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink _
)

Parameters

link

The DiagramLink related to the event.

See Also

LinkValidationEventArgs Constructor Overload List
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs Constructor (DiagramLink, Point, Int32, DiagramNode, Int32, Int32)

LinkValidationEventArgs Constructor (DiagramLink, Point, Int32, DiagramNode, Int32, Int32)
See Also
[image]

Initializes a new instance of the LinkValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkValidationEventArgs (
DiagramLink link,
Point mousePosition,
int adjustmentHandle,
DiagramNode node,
int anchorIndex,
int tableRow
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink, _
mousePosition As Point, _
adjustmentHandle As Integer, _
node As DiagramNode, _
anchorIndex As Integer, _
tableRow As Integer _
)

Parameters

link

The DiagramLink related to the event.

mousePosition

The position of the mouse cursor, in document coordinates.

adjustmentHandle

The zero-based index of the control point related to the event.

node

The DiagramNode related to the event.

anchorIndex

The zero-based index of the anchor point related to the event.

tableRow

The zero-based index of the table row related to the event.

See Also

LinkValidationEventArgs Constructor Overload List
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs Constructor (DiagramLink, Rect)

LinkValidationEventArgs Constructor (DiagramLink, Rect)
See Also
[image]

Initializes a new instance of the LinkValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkValidationEventArgs (
DiagramLink link,
Rect selectionRectangle
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink, _
selectionRectangle As Rect _
)

Parameters

link

The DiagramLink related to the event.

selectionRectangle

A .NET Rect object that represents the current selection rectangle.

See Also

LinkValidationEventArgs Constructor Overload List
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs Methods

LinkValidationEventArgs Methods
[image]

Public Methods

Name | Description
CancelDrag | Cancels the creation or modification of the link.

See Also

LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.CancelDrag Method

LinkValidationEventArgs.CancelDrag Method
[image]

Cancels the creation or modification of the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void CancelDrag ()

Visual Basic [image] Copy Code

Public Sub CancelDrag ()

Remarks

Calling this method immediately stops the operation.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs Properties

LinkValidationEventArgs Properties
[image]

Public Properties

Name | Description
AnchorIndex | Gets the anchor point related to a link validation event.
Cancel | Gets or sets a value indicating whether to cancel the current operation.
ChangingDestination | Gets a value indicating whether the user modifies the link's destination end point.
ChangingOrigin | Gets a value indicating whether the user modifies the link's origin end point.
Destination | Gets the node that will become the link's destination if the event is validated.
Node | Gets the node to which the link will be connected.
Origin | Gets the node that would become the link's origin if the event is validated.
SelectionRectangle | Gets the current selection rectangle.
TableRow | Gets the table row related to a link validation event.

Inherited Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from LinkEventArgs.)
Link | Gets the link for which the event raised. (Inherited from LinkEventArgs.)
MouseButton | Gets which mouse button was pressed. (Inherited from LinkEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from LinkEventArgs.)

See Also

LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.AnchorIndex Property

LinkValidationEventArgs.AnchorIndex Property
[image]

Gets the anchor point related to a link validation event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int AnchorIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AnchorIndex As Integer

Property Value

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.Cancel Property

LinkValidationEventArgs.Cancel Property
[image]

Gets or sets a value indicating whether to cancel the current operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

Remarks

Set this property to true to prevent the user from completing the operation.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.ChangingDestination Property

LinkValidationEventArgs.ChangingDestination Property
[image]

Gets a value indicating whether the user modifies the link's destination end point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ChangingDestination { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ChangingDestination As Boolean

Property Value

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.ChangingOrigin Property

LinkValidationEventArgs.ChangingOrigin Property
[image]

Gets a value indicating whether the user modifies the link's origin end point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ChangingOrigin { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ChangingOrigin As Boolean

Property Value

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.Destination Property

LinkValidationEventArgs.Destination Property
[image]

Gets the node that will become the link's destination if the event is validated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Destination { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Destination As DiagramNode

Property Value

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.Node Property

LinkValidationEventArgs.Node Property
[image]

Gets the node to which the link will be connected.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Node { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Node As DiagramNode

Property Value

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.Origin Property

LinkValidationEventArgs.Origin Property
[image]

Gets the node that would become the link's origin if the event is validated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Origin { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Origin As DiagramNode

Property Value

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.SelectionRectangle Property

LinkValidationEventArgs.SelectionRectangle Property
[image]

Gets the current selection rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect SelectionRectangle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SelectionRectangle As Rect

Property Value

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.TableRow Property

LinkValidationEventArgs.TableRow Property
[image]

Gets the table row related to a link validation event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int TableRow { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TableRow As Integer

Property Value

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.MarkStyle Enumeration

MarkStyle Enumeration
[image]

Specifies the visual style of anchor point marks.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum MarkStyle

Visual Basic [image] Copy Code

Public Enum MarkStyle

Members

Member name | Description
Circle | Anchor point marked with a circle.
Cross | No visual indication for the anchor point.
None | No visual indication for the anchor point.
Rectangle | Anchor point marked with a rectangle.
X | Anchor point marked with an 'X'.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.MillimeterConverter Class

MillimeterConverter Class
[image]

Returns millimeter size in current measure unit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class MillimeterConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class MillimeterConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.MillimeterConverter

See Also

MillimeterConverter Members


MindFusion.Diagramming.MillimeterConverter Members

MillimeterConverter Members
Constructors Methods
[image]

Returns millimeter size in current measure unit.

The following tables list the members exposed by the MillimeterConverter type.

Public Constructors

Name | Description
MillimeterConverter |

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

MillimeterConverter Class


MindFusion.Diagramming.MillimeterConverter Constructor

MillimeterConverter Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MillimeterConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

MillimeterConverter Class


MindFusion.Diagramming.MillimeterConverter Methods

MillimeterConverter Methods
[image]

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

MillimeterConverter Class


MindFusion.Diagramming.MillimeterConverter.Convert Method

MillimeterConverter.Convert Method
[image]

IValueConverter.Convert implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo l
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
l As CultureInfo _
) As Object

Parameters

value

targetType

parameter

l

Return Value

See Also

MillimeterConverter Members
MillimeterConverter Class


MindFusion.Diagramming.MillimeterConverter.ConvertBack Method

MillimeterConverter.ConvertBack Method
[image]

IValueConverter.ConvertBack implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo l
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
l As CultureInfo _
) As Object

Parameters

value

targetType

parameter

l

Return Value

See Also

MillimeterConverter Members
MillimeterConverter Class


MindFusion.Diagramming.ModificationStart Enumeration

ModificationStart Enumeration
[image]

Specifies how the user can start modifying an item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum ModificationStart

Visual Basic [image] Copy Code

Public Enum ModificationStart

Members

Member name | Description
AutoHandles | Adjustment handles appear automatically around the object under the mouse; it can be modified without selecting it first.
SelectedOnly | Only selected objects can be modified.

Remarks

This enumeration specifies the possible values of the ModificationStart property.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.ModifyBehavior Class

ModifyBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.Modify.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ModifyBehavior : BehaviorBase

Visual Basic [image] Copy Code

Public Class ModifyBehavior
Inherits BehaviorBase

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction
MindFusion.Diagramming.BehaviorBase
MindFusion.Diagramming.ModifyBehavior

See Also

ModifyBehavior Members


MindFusion.Diagramming.ModifyBehavior Members

ModifyBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.Modify.

The following tables list the members exposed by the ModifyBehavior type.

Protected Constructors

Name | Description
ModifyBehavior | Initializes a new instance of the ModifyBehavior class.

Inherited Protected Properties

Name | Description
Diagram | The Diagram object that is being modified. (Inherited from Interaction.)
InteractionState | Gets or sets an InteractionState instance that tracks the modification currently being done on an item. (Inherited from BehaviorBase.)
MouseDownPoint | Gets or sets the position of the mouse when its button has been pressed. (Inherited from BehaviorBase.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Inherited Public Methods

Name | Description
SetMouseCursor | Invoked while the mouse is moved to let Behavior objects set the mouse cursor depending on the context. (Inherited from BehaviorBase.)
StartDraw | Invoked when a user presses the left mouse button inside the diagram drawing area. (Inherited from BehaviorBase.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

ModifyBehavior Class


MindFusion.Diagramming.ModifyBehavior Constructor

ModifyBehavior Constructor
[image]

Initializes a new instance of the ModifyBehavior class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected ModifyBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected Function ModifyBehavior ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram this behavior will be associated with.

See Also

ModifyBehavior Class


MindFusion.Diagramming.ModifyBehavior Methods

ModifyBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Inherited Public Methods

Name | Description
SetMouseCursor | Invoked while the mouse is moved to let Behavior objects set the mouse cursor depending on the context. (Inherited from BehaviorBase.)
StartDraw | Invoked when a user presses the left mouse button inside the diagram drawing area. (Inherited from BehaviorBase.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

ModifyBehavior Class


MindFusion.Diagramming.ModifyBehavior.SetMouseCursor Method

ModifyBehavior.SetMouseCursor Method
[image]

BehaviorBase.SetMouseCursor override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Cursor SetMouseCursor (
Point point,
out bool startInteraction
)

Visual Basic [image] Copy Code

Public Overrides Function SetMouseCursor( _
point As Point, _
<System.Runtime.InteropServices.Out()> ByRef startInteraction As Boolean _
) As Cursor

Parameters

point

startInteraction

Return Value

See Also

ModifyBehavior Members
ModifyBehavior Class


MindFusion.Diagramming.ModifyBehavior.StartDraw Method

ModifyBehavior.StartDraw Method
[image]

BehaviorBase.StartDraw override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override InteractionState StartDraw (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function StartDraw ( _
point As Point _
) As InteractionState

Parameters

point

A Point structure, which specifies the current position of the mouse cursor, in document coordinates.

Return Value

An instance of the InteractionState class.

See Also

ModifyBehavior Members
ModifyBehavior Class


MindFusion.Diagramming.MouseButton Enumeration

MouseButton Enumeration
[image]

Specifies constants that define which mouse button was pressed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum MouseButton

Visual Basic [image] Copy Code

Public Enum MouseButton

Members

Member name | Description
Left | The left mouse button was pressed.
Middle | The middle mouse button was pressed.
None | No mouse button was pressed.
Right | The right mouse button was pressed.
XButton1 | The first XButton was pressed.
XButton2 | The second XButton was pressed.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.NodeConstraints Class

NodeConstraints Class
Remarks See Also
[image]

Defines specific constraints that can be applied to the size and location of nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class NodeConstraints

Visual Basic [image] Copy Code

Public Class NodeConstraints

Remarks

Instances of this class can be assigned to the Constraints property of nodes.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.NodeConstraints

See Also

NodeConstraints Members


MindFusion.Diagramming.NodeConstraints Members

NodeConstraints Members
Constructors Properties Methods
[image]

Defines specific constraints that can be applied to the size and location of nodes.

The following tables list the members exposed by the NodeConstraints type.

Public Constructors

Name | Description
NodeConstraints | Initializes a new instance of the NodeConstraints class.

Public Properties

Name | Description
DisableMirroring | Gets or sets a value indicating whether the user can drag a side of the node past its opposite side, so that they switch positions.
KeepInsideParent | Gets or sets a value indicating whether a node should always stay in the boundaries of its container.
KeepRatio | Gets or sets a value indicating whether the initial width/height ratio of a node should be preserved.
MaxHeight | Gets or sets the maximum node height allowed.
MaxWidth | Gets or sets the maximum node width allowed.
MinHeight | Gets or sets the minimum node height allowed.
MinWidth | Gets or sets the minimum node width allowed.
MoveDirection | Gets or sets constraints on movement direction.

Public Methods

Name | Description
Clone | Creates a copy of this object.

See Also

NodeConstraints Class


MindFusion.Diagramming.NodeConstraints Constructor

NodeConstraints Constructor
[image]

Initializes a new instance of the NodeConstraints class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeConstraints ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

NodeConstraints Class


MindFusion.Diagramming.NodeConstraints Methods

NodeConstraints Methods
[image]

Public Methods

Name | Description
Clone | Creates a copy of this object.

See Also

NodeConstraints Class


MindFusion.Diagramming.NodeConstraints.Clone Method

NodeConstraints.Clone Method
[image]

Creates a copy of this object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

An Object instance that is a copy of the current NodeConstraints instance.

See Also

NodeConstraints Members
NodeConstraints Class


MindFusion.Diagramming.NodeConstraints Properties

NodeConstraints Properties
[image]

Public Properties

Name | Description
DisableMirroring | Gets or sets a value indicating whether the user can drag a side of the node past its opposite side, so that they switch positions.
KeepInsideParent | Gets or sets a value indicating whether a node should always stay in the boundaries of its container.
KeepRatio | Gets or sets a value indicating whether the initial width/height ratio of a node should be preserved.
MaxHeight | Gets or sets the maximum node height allowed.
MaxWidth | Gets or sets the maximum node width allowed.
MinHeight | Gets or sets the minimum node height allowed.
MinWidth | Gets or sets the minimum node width allowed.
MoveDirection | Gets or sets constraints on movement direction.

See Also

NodeConstraints Class


MindFusion.Diagramming.NodeConstraints.DisableMirroring Property

NodeConstraints.DisableMirroring Property
[image]

Gets or sets a value indicating whether the user can drag a side of the node past its opposite side, so that they switch positions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool DisableMirroring { get; set; }

Visual Basic [image] Copy Code

Public Property DisableMirroring As Boolean

Property Value

true to disable mirroring; otherwise false. The default value is false.

See Also

NodeConstraints Members
NodeConstraints Class


MindFusion.Diagramming.NodeConstraints.KeepInsideParent Property

NodeConstraints.KeepInsideParent Property
[image]

Gets or sets a value indicating whether a node should always stay in the boundaries of its container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool KeepInsideParent { get; set; }

Visual Basic [image] Copy Code

Public Property KeepInsideParent As Boolean

Property Value

true if users should be prevented from moving the node out of its container; otherwise, false. The default is false.

Remarks

This property lets you restrict nodes placed inside a ContainerNode to prevent users from moving a child node out of the bounds of their parent.

See Also

NodeConstraints Members
NodeConstraints Class
MindFusion.Diagramming Namespace
Container Property


MindFusion.Diagramming.NodeConstraints.KeepRatio Property

NodeConstraints.KeepRatio Property
[image]

Gets or sets a value indicating whether the initial width/height ratio of a node should be preserved.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool KeepRatio { get; set; }

Visual Basic [image] Copy Code

Public Property KeepRatio As Boolean

Property Value

true if the node width to height ratio should be preserved; otherwise, false. The default is false.

See Also

NodeConstraints Members
NodeConstraints Class


MindFusion.Diagramming.NodeConstraints.MaxHeight Property

NodeConstraints.MaxHeight Property
[image]

Gets or sets the maximum node height allowed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double MaxHeight { get; set; }

Visual Basic [image] Copy Code

Public Property MaxHeight As Double

Property Value

0 = no height constraints; any other value specifies the maximum node height allowed.

See Also

NodeConstraints Members
NodeConstraints Class


MindFusion.Diagramming.NodeConstraints.MaxWidth Property

NodeConstraints.MaxWidth Property
[image]

Gets or sets the maximum node width allowed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double MaxWidth { get; set; }

Visual Basic [image] Copy Code

Public Property MaxWidth As Double

Property Value

0 = no width constraints; any other value specifies the maximum node width allowed.

See Also

NodeConstraints Members
NodeConstraints Class


MindFusion.Diagramming.NodeConstraints.MinHeight Property

NodeConstraints.MinHeight Property
[image]

Gets or sets the minimum node height allowed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double MinHeight { get; set; }

Visual Basic [image] Copy Code

Public Property MinHeight As Double

Property Value

0 = no height constraints; any other value specifies the minimum node height allowed.

See Also

NodeConstraints Members
NodeConstraints Class


MindFusion.Diagramming.NodeConstraints.MinWidth Property

NodeConstraints.MinWidth Property
[image]

Gets or sets the minimum node width allowed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double MinWidth { get; set; }

Visual Basic [image] Copy Code

Public Property MinWidth As Double

Property Value

0 = no width constraints; any other value specifies the minimum node width allowed.

See Also

NodeConstraints Members
NodeConstraints Class


MindFusion.Diagramming.NodeConstraints.MoveDirection Property

NodeConstraints.MoveDirection Property
[image]

Gets or sets constraints on movement direction.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DirectionConstraint MoveDirection { get; set; }

Visual Basic [image] Copy Code

Public Property MoveDirection As DirectionConstraint

Property Value

See Also

NodeConstraints Members
NodeConstraints Class


MindFusion.Diagramming.NodeEffect Class

NodeEffect Class
Remarks See Also
[image]

Represents the base class of all visual effects that can be applied to the nodes in a Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class NodeEffect : INotifyPropertyChanged

Visual Basic [image] Copy Code

Public MustInherit Class NodeEffect
Implements INotifyPropertyChanged

Remarks

Effects can be applied by adding instances of the concrete effect classes to the NodeEffects collection of the Diagram.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.NodeEffect

See Also

NodeEffect Members


MindFusion.Diagramming.NodeEffect Members

NodeEffect Members
Constructors Methods Events
[image]

Represents the base class of all visual effects that can be applied to the nodes in a Diagram.

The following tables list the members exposed by the NodeEffect type.

Protected Constructors

Name | Description
NodeEffect | Initializes a new instance of the NodeEffect class.

Public Methods

Name | Description
Clone | ICloneable.Clone implementation.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

NodeEffect Class


MindFusion.Diagramming.NodeEffect Constructor

NodeEffect Constructor
[image]

Initializes a new instance of the NodeEffect class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected NodeEffect ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

NodeEffect Class


MindFusion.Diagramming.NodeEffect Methods

NodeEffect Methods
[image]

Public Methods

Name | Description
Clone | ICloneable.Clone implementation.

See Also

NodeEffect Class


MindFusion.Diagramming.NodeEffect.Clone Method

NodeEffect.Clone Method
[image]

ICloneable.Clone implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract Object Clone ()

Visual Basic [image] Copy Code

Public MustOverride Function Clone () As Object

Return Value

A new effect that is a copy of this effect.

See Also

NodeEffect Members
NodeEffect Class


MindFusion.Diagramming.NodeEffect Events

NodeEffect Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

NodeEffect Class


MindFusion.Diagramming.NodeEffect.PropertyChanged Event

NodeEffect.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

See Also

NodeEffect Members
NodeEffect Class


MindFusion.Diagramming.NodeEventArgs Class

NodeEventArgs Class
[image]

Contains the arguments passed to handlers of node-related events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class NodeEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class NodeEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.NodeEventArgs
MindFusion.Diagramming.ContainerChildEventArgs
MindFusion.Diagramming.NodeValidationEventArgs
MindFusion.Diagramming.VirtualNodeEventArgs

See Also

NodeEventArgs Members


MindFusion.Diagramming.NodeEventArgs Members

NodeEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to handlers of node-related events.

The following tables list the members exposed by the NodeEventArgs type.

Public Constructors

Name | Description
NodeEventArgs | Overloaded.

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user.
MouseButton | Gets which mouse button has been pressed.
MousePosition | Gets or sets the current mouse pointer position.
Node | Gets the node for which the event was raised.

See Also

NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs Constructor

NodeEventArgs Constructor
[image]

Overload List

Name | Description
NodeEventArgs (DiagramNode) | Initializes a new instance of the NodeEventArgs class.
NodeEventArgs (DiagramNode, MouseButton, Point) | Initializes a new instance of the NodeEventArgs class.
NodeEventArgs (DiagramNode, Point) | Initializes a new instance of the NodeEventArgs class.
NodeEventArgs (DiagramNode, Point, AdjustmentHandles) | Initializes a new instance of the NodeEventArgs class.

See Also

NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs Constructor (DiagramNode)

NodeEventArgs Constructor (DiagramNode)
See Also
[image]

Initializes a new instance of the NodeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeEventArgs (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Function NodeEventArgs ( _
node As DiagramNode _
)

Parameters

node
The DiagramNode related to the event.

See Also

NodeEventArgs Constructor Overload List
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs Constructor (DiagramNode, MouseButton, Point)

NodeEventArgs Constructor (DiagramNode, MouseButton, Point)
See Also
[image]

Initializes a new instance of the NodeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeEventArgs (
DiagramNode node,
MouseButton mouseButton,
Point mousePosition
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode, _
mouseButton As MouseButton, _
mousePosition As Point _
)

Parameters

node

The DiagramNode related to the event.

mouseButton

The mouse button related to the event.

mousePosition

The position of the mouse cursor, in document coordinates.

See Also

NodeEventArgs Constructor Overload List
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs Constructor (DiagramNode, Point)

NodeEventArgs Constructor (DiagramNode, Point)
See Also
[image]

Initializes a new instance of the NodeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeEventArgs (
DiagramNode node,
Point mousePosition
)

Visual Basic [image] Copy Code

Public Function NodeEventArgs ( _
node As DiagramNode, _
mousePosition As Point _
)

Parameters

node
The DiagramNode related to the event.
mousePosition

The position of the mouse cursor, in document coordinates.

See Also

NodeEventArgs Constructor Overload List
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs Constructor (DiagramNode, Point, AdjustmentHandles)

NodeEventArgs Constructor (DiagramNode, Point, AdjustmentHandles)
See Also
[image]

Initializes a new instance of the NodeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeEventArgs (
DiagramNode node,
Point mousePosition,
AdjustmentHandles adjustmentHandle
)

Visual Basic [image] Copy Code

Public Function NodeEventArgs ( _
node As DiagramNode, _
mousePosition As Point, _
adjustmentHandle As AdjustmentHandles _
)

Parameters

node
The DiagramNode related to the event.
mousePosition

The position of the mouse cursor, in document coordinates.

adjustmentHandle

The zero-based index of the adjustment handle related to the event.

See Also

NodeEventArgs Constructor Overload List
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs Properties

NodeEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user.
MouseButton | Gets which mouse button has been pressed.
MousePosition | Gets or sets the current mouse pointer position.
Node | Gets the node for which the event was raised.

See Also

NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs.AdjustmentHandle Property

NodeEventArgs.AdjustmentHandle Property
[image]

Gets or sets the adjustment handle being moved by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AdjustmentHandles AdjustmentHandle { get; set; }

Visual Basic [image] Copy Code

Public Property AdjustmentHandle As AdjustmentHandles

Property Value

A member of the AdjustmentHandles enumeration specifying what handle has been used.

See Also

NodeEventArgs Members
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs.MouseButton Property

NodeEventArgs.MouseButton Property
[image]

Gets which mouse button has been pressed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MouseButton MouseButton { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MouseButton As MouseButton

Property Value

See Also

NodeEventArgs Members
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs.MousePosition Property

NodeEventArgs.MousePosition Property
[image]

Gets or sets the current mouse pointer position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point MousePosition { get; set; }

Visual Basic [image] Copy Code

Public Property MousePosition As Point

Property Value

A WinRT Windows.UI.Xaml Point object specifying the current mouse position.

See Also

NodeEventArgs Members
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs.Node Property

NodeEventArgs.Node Property
[image]

Gets the node for which the event was raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Node { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Node As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

NodeEventArgs Members
NodeEventArgs Class


MindFusion.Diagramming.NodeListView Class

NodeListView Class
[image]

A ListBox control with support for hosting DiagramNode -derived objects and dragging them to the Diagram control. Items' labels can be set by assigning them to the Tag property of nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public class NodeListView : ListBox

Visual Basic [image] Copy Code

Public Class NodeListView
Inherits ListBox

Example

The following example show how to add two nodes to the list using Xaml and set up their labels.

XAML [image] Copy Code

<d:NodeListView Grid.Column="2">
<d:ShapeNode Shape="Rectangle" Tag="Task" />
<d:ShapeNode Shape="Decision" Tag="Branch" />
</d:NodeListView>

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
Windows.UI.Xaml.Controls.ItemsControl
Windows.UI.Xaml.Controls.Primitives.Selector
Windows.UI.Xaml.Controls.ListBox
MindFusion.Diagramming.NodeListView

See Also

NodeListView Members


MindFusion.Diagramming.NodeListView Members

NodeListView Members
Constructors Methods Events
[image]

A ListBox control with support for hosting DiagramNode -derived objects and dragging them to the Diagram control. Items' labels can be set by assigning them to the Tag property of nodes.

The following tables list the members exposed by the NodeListView type.

Public Constructors

Name | Description
NodeListView | Creates an instance of NodeListView

Protected Methods

Name | Description
GetContainerForItemOverride | ItemsControl.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | ItemsControl.IsItemItsOwnContainerOverride override.
OnPointerReleased | ItemsControl.OnMouseLeftButtonUp override.
PrepareContainerForItemOverride | ItemsControl.PrepareContainerForItemOverride override.

Public Events

Name | Description
DragDropCompleted | Raised when a node is created by drag-and-drop from the list to the diagram canvas.

See Also

NodeListView Class


MindFusion.Diagramming.NodeListView Constructor

NodeListView Constructor
[image]

Creates an instance of NodeListView

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public NodeListView ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

NodeListView Class


MindFusion.Diagramming.NodeListView Methods

NodeListView Methods
[image]

Protected Methods

Name | Description
GetContainerForItemOverride | ItemsControl.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | ItemsControl.IsItemItsOwnContainerOverride override.
OnPointerReleased | ItemsControl.OnMouseLeftButtonUp override.
PrepareContainerForItemOverride | ItemsControl.PrepareContainerForItemOverride override.

See Also

NodeListView Class


MindFusion.Diagramming.NodeListView.GetContainerForItemOverride Method

NodeListView.GetContainerForItemOverride Method
[image]

ItemsControl.GetContainerForItemOverride override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

protected override DependencyObject GetContainerForItemOverride ()

Visual Basic [image] Copy Code

Protected Overrides Function GetContainerForItemOverride () As DependencyObject

Return Value

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.IsItemItsOwnContainerOverride Method

NodeListView.IsItemItsOwnContainerOverride Method
[image]

ItemsControl.IsItemItsOwnContainerOverride override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

protected override bool IsItemItsOwnContainerOverride (
Object item
)

Visual Basic [image] Copy Code

Protected Overrides Function IsItemItsOwnContainerOverride( _
item As Object _
) As Boolean

Parameters

item

Return Value

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.OnPointerReleased Method

NodeListView.OnPointerReleased Method
[image]

ItemsControl.OnMouseLeftButtonUp override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

protected override void OnPointerReleased (
PointerRoutedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPointerReleased( _
e As PointerRoutedEventArgs _
)

Parameters

e

The PointerRoutedEventArgs that contains the event data.

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.PrepareContainerForItemOverride Method

NodeListView.PrepareContainerForItemOverride Method
[image]

ItemsControl.PrepareContainerForItemOverride override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

protected override void PrepareContainerForItemOverride (
DependencyObject element,
Object item
)

Visual Basic [image] Copy Code

Protected Overrides Sub PrepareContainerForItemOverride( _
element As DependencyObject, _
item As Object _
)

Parameters

element

item

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView Events

NodeListView Events
[image]

Public Events

Name | Description
DragDropCompleted | Raised when a node is created by drag-and-drop from the list to the diagram canvas.

See Also

NodeListView Class


MindFusion.Diagramming.NodeListView.DragDropCompleted Event

NodeListView.DragDropCompleted Event
[image]

Raised when a node is created by drag-and-drop from the list to the diagram canvas.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public event EventHandler<NodeListViewEventArgs> DragDropCompleted

Visual Basic [image] Copy Code

Public Event DragDropCompleted As EventHandler(Of NodeListViewEventArgs)

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListViewEventArgs Class

NodeListViewEventArgs Class
[image]

Contains data about the DragDropCompleted event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public class NodeListViewEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class NodeListViewEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.NodeListViewEventArgs

See Also

NodeListViewEventArgs Members


MindFusion.Diagramming.NodeListViewEventArgs Members

NodeListViewEventArgs Members
Constructors Properties
[image]

Contains data about the DragDropCompleted event.

The following tables list the members exposed by the NodeListViewEventArgs type.

Public Constructors

Name | Description
NodeListViewEventArgs |

Public Properties

Name | Description
NewNode | Gets the newly created diagram node.
SourceNode | Gets the listview node that was dragged to the diagram canvas.

See Also

NodeListViewEventArgs Class


MindFusion.Diagramming.NodeListViewEventArgs Constructor

NodeListViewEventArgs Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public NodeListViewEventArgs ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

NodeListViewEventArgs Class


MindFusion.Diagramming.NodeListViewEventArgs Properties

NodeListViewEventArgs Properties
[image]

Public Properties

Name | Description
NewNode | Gets the newly created diagram node.
SourceNode | Gets the listview node that was dragged to the diagram canvas.

See Also

NodeListViewEventArgs Class


MindFusion.Diagramming.NodeListViewEventArgs.NewNode Property

NodeListViewEventArgs.NewNode Property
[image]

Gets the newly created diagram node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public DiagramNode NewNode { get; set; }

Visual Basic [image] Copy Code

Public Property NewNode As DiagramNode

Property Value

See Also

NodeListViewEventArgs Members
NodeListViewEventArgs Class


MindFusion.Diagramming.NodeListViewEventArgs.SourceNode Property

NodeListViewEventArgs.SourceNode Property
[image]

Gets the listview node that was dragged to the diagram canvas.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public DiagramNode SourceNode { get; set; }

Visual Basic [image] Copy Code

Public Property SourceNode As DiagramNode

Property Value

See Also

NodeListViewEventArgs Members
NodeListViewEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs Class

NodeValidationEventArgs Class
[image]

Contains the arguments passed to handlers of node validation events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class NodeValidationEventArgs : NodeEventArgs

Visual Basic [image] Copy Code

Public Class NodeValidationEventArgs
Inherits NodeEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.NodeEventArgs
MindFusion.Diagramming.NodeValidationEventArgs

See Also

NodeValidationEventArgs Members


MindFusion.Diagramming.NodeValidationEventArgs Members

NodeValidationEventArgs Members
Constructors Properties Methods
[image]

Contains the arguments passed to handlers of node validation events.

The following tables list the members exposed by the NodeValidationEventArgs type.

Public Constructors

Name | Description
NodeValidationEventArgs | Overloaded.

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to cancel the current operation.
SelectionRectangle | Gets the current selection rectangle.

Inherited Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from NodeEventArgs.)
MouseButton | Gets which mouse button has been pressed. (Inherited from NodeEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from NodeEventArgs.)
Node | Gets the node for which the event was raised. (Inherited from NodeEventArgs.)

Public Methods

Name | Description
CancelDrag | Cancels the creation or modification of the node.

See Also

NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs Constructor

NodeValidationEventArgs Constructor
[image]

Overload List

Name | Description
NodeValidationEventArgs (DiagramNode) | Initializes a new instance of the NodeValidationEventArgs class.
NodeValidationEventArgs (DiagramNode, Point, AdjustmentHandles) | Initializes a new instance of the NodeValidationEventArgs class.
NodeValidationEventArgs (DiagramNode, Rect) | Initializes a new instance of the NodeValidationEventArgs class.

See Also

NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs Constructor (DiagramNode)

NodeValidationEventArgs Constructor (DiagramNode)
See Also
[image]

Initializes a new instance of the NodeValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeValidationEventArgs (
DiagramNode node
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode _
)

Parameters

node

The DiagramNode related to the event.

See Also

NodeValidationEventArgs Constructor Overload List
NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs Constructor (DiagramNode, Point, AdjustmentHandles)

NodeValidationEventArgs Constructor (DiagramNode, Point, AdjustmentHandles)
See Also
[image]

Initializes a new instance of the NodeValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeValidationEventArgs (
DiagramNode node,
Point mousePosition,
AdjustmentHandles adjustmentHandle
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode, _
mousePosition As Point, _
adjustmentHandle As AdjustmentHandles _
)

Parameters

node

The DiagramNode related to the event.

mousePosition

The position of the mouse cursor, in document coordinates.

adjustmentHandle

The zero-based index of the adjustment handle related to the event.

See Also

NodeValidationEventArgs Constructor Overload List
NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs Constructor (DiagramNode, Rect)

NodeValidationEventArgs Constructor (DiagramNode, Rect)
See Also
[image]

Initializes a new instance of the NodeValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeValidationEventArgs (
DiagramNode node,
Rect selectionRectangle
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode, _
selectionRectangle As Rect _
)

Parameters

node

The DiagramNode related to the event.

selectionRectangle

A .NET RectangeF object representing the selection reactangle.

See Also

NodeValidationEventArgs Constructor Overload List
NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs Methods

NodeValidationEventArgs Methods
[image]

Public Methods

Name | Description
CancelDrag | Cancels the creation or modification of the node.

See Also

NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs.CancelDrag Method

NodeValidationEventArgs.CancelDrag Method
[image]

Cancels the creation or modification of the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void CancelDrag ()

Visual Basic [image] Copy Code

Public Sub CancelDrag ()

Remarks

Calling this method immediately stops the operation.

See Also

NodeValidationEventArgs Members
NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs Properties

NodeValidationEventArgs Properties
[image]

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to cancel the current operation.
SelectionRectangle | Gets the current selection rectangle.

Inherited Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from NodeEventArgs.)
MouseButton | Gets which mouse button has been pressed. (Inherited from NodeEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from NodeEventArgs.)
Node | Gets the node for which the event was raised. (Inherited from NodeEventArgs.)

See Also

NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs.Cancel Property

NodeValidationEventArgs.Cancel Property
[image]

Gets or sets a value indicating whether to cancel the current operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

Remarks

Set this property to true to prevent the user from completing the operation.

See Also

NodeValidationEventArgs Members
NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs.SelectionRectangle Property

NodeValidationEventArgs.SelectionRectangle Property
[image]

Gets the current selection rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect SelectionRectangle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SelectionRectangle As Rect

Property Value

See Also

NodeValidationEventArgs Members
NodeValidationEventArgs Class


MindFusion.Diagramming.Orientation Enumeration

Orientation Enumeration
[image]

Defines values that specify the orientation of the first segment of cascading links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum Orientation

Visual Basic [image] Copy Code

Public Enum Orientation

Members

Member name | Description
Auto | The control determines automatically the initial direction of link's first segment.
Horizontal | The first segment of the link is always horizontal.
Vertical | The first segment of the link is always vertical.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.OrientationVisibilityConverter Class

OrientationVisibilityConverter Class
[image]

Converts Orientation to Visibility.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public class OrientationVisibilityConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class OrientationVisibilityConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.OrientationVisibilityConverter

See Also

OrientationVisibilityConverter Members


MindFusion.Diagramming.OrientationVisibilityConverter Members

OrientationVisibilityConverter Members
Constructors Methods
[image]

Converts Orientation to Visibility.

The following tables list the members exposed by the OrientationVisibilityConverter type.

Public Constructors

Name | Description
OrientationVisibilityConverter |

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

OrientationVisibilityConverter Class


MindFusion.Diagramming.OrientationVisibilityConverter Constructor

OrientationVisibilityConverter Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public OrientationVisibilityConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

OrientationVisibilityConverter Class


MindFusion.Diagramming.OrientationVisibilityConverter Methods

OrientationVisibilityConverter Methods
[image]

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

OrientationVisibilityConverter Class


MindFusion.Diagramming.OrientationVisibilityConverter.Convert Method

OrientationVisibilityConverter.Convert Method
[image]

IValueConverter.Convert implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo l
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
l As CultureInfo _
) As Object

Parameters

value

targetType

parameter

l

Return Value

See Also

OrientationVisibilityConverter Members
OrientationVisibilityConverter Class


MindFusion.Diagramming.OrientationVisibilityConverter.ConvertBack Method

OrientationVisibilityConverter.ConvertBack Method
[image]

IValueConverter.ConvertBack implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo l
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
l As CultureInfo _
) As Object

Parameters

value

targetType

parameter

l

Return Value

See Also

OrientationVisibilityConverter Members
OrientationVisibilityConverter Class


MindFusion.Diagramming.Overview Class

Overview Class
Remarks See Also
[image]

The Overview control provides a scaled-down view of a Diagram contents and allows scrolling and zooming the diagram with the mouse.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Overview : Grid

Visual Basic [image] Copy Code

Public Class Overview
Inherits Grid

Remarks

To specify which Diagram instance is shown in the overview, set the Document property of the Overview class. The scale in which the overview control paints items is determined by ScaleFactor and FitAll. FitAll makes the whole diagram fit into the control.

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Panel
Windows.UI.Xaml.Controls.Grid
MindFusion.Diagramming.Overview

See Also

Overview Members


MindFusion.Diagramming.Overview Members

Overview Members
Constructors Properties Methods
[image]

The Overview control provides a scaled-down view of a Diagram contents and allows scrolling and zooming the diagram with the mouse.

The following tables list the members exposed by the Overview type.

Public Constructors

Name | Description
Overview | Initializes a new instance of the Overview class.

Public Properties

Name | Description
Background | Gets or sets the background brush of the overview control.
DimBrush | Gets or sets a color used to blend with the part of the diagram that is not visible in the Diagram‘s client rectangle.
Document | Gets or sets the Diagram instance whose contents to display in the overview control.
FitAll | Gets or sets a value indicating whether to fit the whole diagram inside the overview window control.
ScaleFactor | Gets or sets a fixed scale factor to be used when FitAll is disabled.
ShowScrollbars | Gets or sets a value indicating whether the scrollbars of the overview control are visible.
TrackingRectPen | Gets or stes the Pen object used to draw the tracking rectangle border.

Public Methods

Name | Description
Update | Causes the control to recalculate all internals and repaint its client area.

Protected Methods

Name | Description
OnMouseMove | Control.OnMouseMove override.
OnMouseWheel | Control.OnMouseWheel override.

See Also

Overview Class


MindFusion.Diagramming.Overview Constructor

Overview Constructor
[image]

Initializes a new instance of the Overview class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Overview ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Overview Class


MindFusion.Diagramming.Overview Methods

Overview Methods
[image]

Public Methods

Name | Description
Update | Causes the control to recalculate all internals and repaint its client area.

Protected Methods

Name | Description
OnMouseMove | Control.OnMouseMove override.
OnMouseWheel | Control.OnMouseWheel override.

See Also

Overview Class


MindFusion.Diagramming.Overview.OnMouseMove Method

Overview.OnMouseMove Method
[image]

Control.OnMouseMove override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void OnMouseMove (
e
)

Visual Basic [image] Copy Code

Protected Sub OnMouseMove( _
e As _
)

Parameters

e

See Also

Overview Members
Overview Class


MindFusion.Diagramming.Overview.OnMouseWheel Method

Overview.OnMouseWheel Method
[image]

Control.OnMouseWheel override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void OnMouseWheel (
e
)

Visual Basic [image] Copy Code

Protected Sub OnMouseWheel( _
e As _
)

Parameters

e

See Also

Overview Members
Overview Class


MindFusion.Diagramming.Overview.Update Method

Overview.Update Method
[image]

Causes the control to recalculate all internals and repaint its client area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Update ()

Visual Basic [image] Copy Code

Public Sub Update ()

See Also

Overview Members
Overview Class


MindFusion.Diagramming.Overview Properties

Overview Properties
[image]

Public Properties

Name | Description
Background | Gets or sets the background brush of the overview control.
DimBrush | Gets or sets a color used to blend with the part of the diagram that is not visible in the Diagram‘s client rectangle.
Document | Gets or sets the Diagram instance whose contents to display in the overview control.
FitAll | Gets or sets a value indicating whether to fit the whole diagram inside the overview window control.
ScaleFactor | Gets or sets a fixed scale factor to be used when FitAll is disabled.
ShowScrollbars | Gets or sets a value indicating whether the scrollbars of the overview control are visible.
TrackingRectPen | Gets or stes the Pen object used to draw the tracking rectangle border.

See Also

Overview Class


MindFusion.Diagramming.Overview.Background Property

Overview.Background Property
[image]

Gets or sets the background brush of the overview control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public new Brush Background { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property Background As Brush

Property Value

An instance of Windows.UI.Xaml.Media.Brush derived class.

See Also

Overview Members
Overview Class


MindFusion.Diagramming.Overview.DimBrush Property

Overview.DimBrush Property
[image]

Gets or sets a color used to blend with the part of the diagram that is not visible in the Diagram‘s client rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush DimBrush { get; set; }

Visual Basic [image] Copy Code

Public Property DimBrush As Brush

Property Value

An instance of Windows.UI.Xaml.Media.Brush derived class.

Remarks

The diagram portion that is currently visible in the client rectangle is painted in the overview using the exact item and background colors. Colors in the area outside that rectangle are alpha-blended with the value of DimBrush.

See Also

Overview Members
Overview Class


MindFusion.Diagramming.Overview.Document Property

Overview.Document Property
[image]

Gets or sets the Diagram instance whose contents to display in the overview control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Diagram Document { get; set; }

Visual Basic [image] Copy Code

Public Property Document As Diagram

Property Value

A Diagram instance bound to this Overview control.

Remarks

The overview control needs a Diagram reference to present the diagram in overview mode.

See Also

Overview Members
Overview Class


MindFusion.Diagramming.Overview.FitAll Property

Overview.FitAll Property
[image]

Gets or sets a value indicating whether to fit the whole diagram inside the overview window control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool FitAll { get; set; }

Visual Basic [image] Copy Code

Public Property FitAll As Boolean

Property Value

true to fit the whole diagram in the overview; otherwise false. The default is false.

Remarks

If enabled, the ScaleFactor is changed to a suitable value, small enough to make the diagram's contents entirely visible.

See Also

Overview Members
Overview Class


MindFusion.Diagramming.Overview.ScaleFactor Property

Overview.ScaleFactor Property
[image]

Gets or sets a fixed scale factor to be used when FitAll is disabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ScaleFactor { get; set; }

Visual Basic [image] Copy Code

Public Property ScaleFactor As Double

Property Value

A double value specifying the scale as percent of actual output. The default is 30.

Remarks

This factor is combined with the diagram's own ZoomFactor to get the final scale.

See Also

Overview Members
Overview Class


MindFusion.Diagramming.Overview.ShowScrollbars Property

Overview.ShowScrollbars Property
[image]

Gets or sets a value indicating whether the scrollbars of the overview control are visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ShowScrollbars { get; set; }

Visual Basic [image] Copy Code

Public Property ShowScrollbars As Boolean

Property Value

true to show scrollbars; otherwise, false. The default is false.

See Also

Overview Members
Overview Class


MindFusion.Diagramming.Overview.TrackingRectPen Property

Overview.TrackingRectPen Property
[image]

Gets or stes the Pen object used to draw the tracking rectangle border.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen TrackingRectPen { get; set; }

Visual Basic [image] Copy Code

Public Property TrackingRectPen As Pen

Property Value

A Windows.UI.Xaml.Media.Pen instance.

See Also

Overview Members
Overview Class


MindFusion.Diagramming.PageRenamedEventArgs Class

PageRenamedEventArgs Class
[image]

Contains arguments for the PageRenamed event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public class PageRenamedEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class PageRenamedEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.PageRenamedEventArgs

See Also

PageRenamedEventArgs Members


MindFusion.Diagramming.PageRenamedEventArgs Members

PageRenamedEventArgs Members
Constructors Properties
[image]

Contains arguments for the PageRenamed event.

The following tables list the members exposed by the PageRenamedEventArgs type.

Public Constructors

Name | Description
PageRenamedEventArgs | Initializes a new instance of the PageRenamedEventArgs class.

Public Properties

Name | Description
NewTitle | Specifies the new title.
OldTitle | Specifies the old title.
Page | Specifies which page has been renamed.

See Also

PageRenamedEventArgs Class


MindFusion.Diagramming.PageRenamedEventArgs Constructor

PageRenamedEventArgs Constructor
[image]

Initializes a new instance of the PageRenamedEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public PageRenamedEventArgs (
DiagramPage page,
string oldTitle,
string newTitle
)

Visual Basic [image] Copy Code

Public New ( _
page As DiagramPage, _
oldTitle As String, _
newTitle As String _
)

Parameters

page

A reference to the DiagramPage that has been renamed,

oldTitle

The original value of page's Title.

newTitle

The new value of page's Title.

See Also

PageRenamedEventArgs Class


MindFusion.Diagramming.PageRenamedEventArgs Properties

PageRenamedEventArgs Properties
[image]

Public Properties

Name | Description
NewTitle | Specifies the new title.
OldTitle | Specifies the old title.
Page | Specifies which page has been renamed.

See Also

PageRenamedEventArgs Class


MindFusion.Diagramming.PageRenamedEventArgs.NewTitle Property

PageRenamedEventArgs.NewTitle Property
[image]

Specifies the new title.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public string NewTitle { get; set; }

Visual Basic [image] Copy Code

Public Property NewTitle As String

Property Value

A string specifying the new title.

See Also

PageRenamedEventArgs Members
PageRenamedEventArgs Class


MindFusion.Diagramming.PageRenamedEventArgs.OldTitle Property

PageRenamedEventArgs.OldTitle Property
[image]

Specifies the old title.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public string OldTitle { get; set; }

Visual Basic [image] Copy Code

Public Property OldTitle As String

Property Value

A string specifying the original title.

See Also

PageRenamedEventArgs Members
PageRenamedEventArgs Class


MindFusion.Diagramming.PageRenamedEventArgs.Page Property

PageRenamedEventArgs.Page Property
[image]

Specifies which page has been renamed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public DiagramPage Page { get; set; }

Visual Basic [image] Copy Code

Public Property Page As DiagramPage

Property Value

The DiagramPage instance that has been renamed.

See Also

PageRenamedEventArgs Members
PageRenamedEventArgs Class


MindFusion.Diagramming.PanBehavior Class

PanBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.Pan.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class PanBehavior : BehaviorBase

Visual Basic [image] Copy Code

Public Class PanBehavior
Inherits BehaviorBase

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction
MindFusion.Diagramming.BehaviorBase
MindFusion.Diagramming.PanBehavior

See Also

PanBehavior Members


MindFusion.Diagramming.PanBehavior Members

PanBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.Pan.

The following tables list the members exposed by the PanBehavior type.

Public Constructors

Name | Description
PanBehavior | Initializes a new instance of the PanBehavior class.

Inherited Protected Properties

Name | Description
Diagram | The Diagram object that is being modified. (Inherited from Interaction.)
InteractionState | Gets or sets an InteractionState instance that tracks the modification currently being done on an item. (Inherited from BehaviorBase.)
MouseDownPoint | Gets or sets the position of the mouse when its button has been pressed. (Inherited from BehaviorBase.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Protected Methods

Name | Description
OnMouseDown | BehaviorBase.OnMouseDown override.
OnMouseMove | BehaviorBase.OnMouseMove override.
OnMouseUp | BehaviorBase.OnMouseUp override.

Inherited Public Methods

Name | Description
SetMouseCursor | Invoked while the mouse is moved to let Behavior objects set the mouse cursor depending on the context. (Inherited from BehaviorBase.)
StartDraw | Invoked when a user presses the left mouse button inside the diagram drawing area. (Inherited from BehaviorBase.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

PanBehavior Class


MindFusion.Diagramming.PanBehavior Constructor

PanBehavior Constructor
[image]

Initializes a new instance of the PanBehavior class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PanBehavior (
Diagram d
)

Visual Basic [image] Copy Code

Public New ( _
d As Diagram _
)

Parameters

d

The diagram that is panned.

See Also

PanBehavior Class


MindFusion.Diagramming.PanBehavior Methods

PanBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Protected Methods

Name | Description
OnMouseDown | BehaviorBase.OnMouseDown override.
OnMouseMove | BehaviorBase.OnMouseMove override.
OnMouseUp | BehaviorBase.OnMouseUp override.

Inherited Public Methods

Name | Description
SetMouseCursor | Invoked while the mouse is moved to let Behavior objects set the mouse cursor depending on the context. (Inherited from BehaviorBase.)
StartDraw | Invoked when a user presses the left mouse button inside the diagram drawing area. (Inherited from BehaviorBase.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

PanBehavior Class


MindFusion.Diagramming.PanBehavior.OnMouseDown Method

PanBehavior.OnMouseDown Method
[image]

BehaviorBase.OnMouseDown override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override bool OnMouseDown (
e
)

Visual Basic [image] Copy Code

Protected Overrides Function OnMouseDown( _
e As _
) As Boolean

Parameters

e

Return Value

See Also

PanBehavior Members
PanBehavior Class


MindFusion.Diagramming.PanBehavior.OnMouseMove Method

PanBehavior.OnMouseMove Method
[image]

BehaviorBase.OnMouseMove override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnMouseMove (
e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseMove( _
e As _
)

Parameters

e

See Also

PanBehavior Members
PanBehavior Class


MindFusion.Diagramming.PanBehavior.OnMouseUp Method

PanBehavior.OnMouseUp Method
[image]

BehaviorBase.OnMouseUp override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnMouseUp (
PointerRoutedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseUp( _
e As PointerRoutedEventArgs _
)

Parameters

e

See Also

PanBehavior Members
PanBehavior Class


MindFusion.Diagramming.PanBehavior.SetMouseCursor Method

PanBehavior.SetMouseCursor Method
[image]

BehaviorBase.SetMouseCursor override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Cursor SetMouseCursor (
Point point,
out bool startInteraction
)

Visual Basic [image] Copy Code

Public Overrides Function SetMouseCursor( _
point As Point, _
<System.Runtime.InteropServices.Out()> ByRef startInteraction As Boolean _
) As Cursor

Parameters

point

startInteraction

Return Value

See Also

PanBehavior Members
PanBehavior Class


MindFusion.Diagramming.PanBehavior.StartDraw Method

PanBehavior.StartDraw Method
[image]

BehaviorBase.StartDraw override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override InteractionState StartDraw (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function StartDraw ( _
point As Point _
) As InteractionState

Parameters

point

A Point structure, which specifies the current position of the mouse cursor, in document coordinates.

Return Value

An instance of the InteractionState class.

See Also

PanBehavior Members
PanBehavior Class


MindFusion.Diagramming.Pen Class

Pen Class
Remarks See Also
[image]

Pen instances are used to draw the outline of geometric shapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Pen : DependencyObject

Visual Basic [image] Copy Code

Public Class Pen
Inherits DependencyObject

Remarks

This class and properties that are its instances are used for compatibility with MindFusion.Diagramming APIs for other platforms. In WinRT you should use the Stroke, StrokeThickness and related properties defined in DiagramItem.

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
MindFusion.Diagramming.Pen

See Also

Pen Members


MindFusion.Diagramming.Pen Members

Pen Members
Constructors Fields Properties Methods
[image]

Pen instances are used to draw the outline of geometric shapes.

The following tables list the members exposed by the Pen type.

Public Constructors

Name | Description
Pen | Overloaded.

Public Fields

Name | Description
BrushProperty | Identifies the Brush dependency property.
ThicknessProperty | Identifies the Thickness dependency property.

Public Properties

Name | Description
Brush | Gets or sets the Brush object that defines the appearance of this pen.
DashStyle | Gets or sets the dash style of lines frawn with this pen.
Thickness | Gets or sets the width of the pen.

Public Methods

Name | Description
Clone | Creates an exact copy of this pen.

See Also

Pen Class


MindFusion.Diagramming.Pen Fields

Pen Fields
[image]

Public Fields

Name | Description
BrushProperty | Identifies the Brush dependency property.
ThicknessProperty | Identifies the Thickness dependency property.

See Also

Pen Class


MindFusion.Diagramming.Pen.BrushProperty Field

Pen.BrushProperty Field
[image]

Identifies the Brush dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BrushProperty As DependencyProperty

See Also

Pen Members
Pen Class


MindFusion.Diagramming.Pen.ThicknessProperty Field

Pen.ThicknessProperty Field
[image]

Identifies the Thickness dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ThicknessProperty As DependencyProperty

See Also

Pen Members
Pen Class


MindFusion.Diagramming.Pen Constructor

Pen Constructor
[image]

Overload List

Name | Description
Pen () | Initialize a new instance of the Pen class.
Pen (Brush) | Initialize a new instance of the Pen class.
Pen (Brush, Double) | Initialize a new instance of the Pen class.
Pen (Brush, Double, DashStyle) | Initialize a new instance of the Pen class.

See Also

Pen Class


MindFusion.Diagramming.Pen Constructor ()

Pen Constructor ()
See Also
[image]

Initialize a new instance of the Pen class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Pen Constructor Overload List
Pen Class


MindFusion.Diagramming.Pen Constructor (Brush)

Pen Constructor (Brush)
See Also
[image]

Initialize a new instance of the Pen class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen (
Brush brush
)

Visual Basic [image] Copy Code

Public New ( _
brush As Brush _
)

Parameters

brush

See Also

Pen Constructor Overload List
Pen Class


MindFusion.Diagramming.Pen Constructor (Brush, Double)

Pen Constructor (Brush, Double)
See Also
[image]

Initialize a new instance of the Pen class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen (
Brush brush,
double thickness
)

Visual Basic [image] Copy Code

Public New ( _
brush As Brush, _
thickness As Double _
)

Parameters

brush

thickness

See Also

Pen Constructor Overload List
Pen Class


MindFusion.Diagramming.Pen Constructor (Brush, Double, DashStyle)

Pen Constructor (Brush, Double, DashStyle)
See Also
[image]

Initialize a new instance of the Pen class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen (
Brush brush,
double thickness,
DashStyle dashStyle
)

Visual Basic [image] Copy Code

Public New ( _
brush As Brush, _
thickness As Double, _
dashStyle As DashStyle _
)

Parameters

brush

thickness

dashStyle

See Also

Pen Constructor Overload List
Pen Class


MindFusion.Diagramming.Pen Methods

Pen Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this pen.

See Also

Pen Class


MindFusion.Diagramming.Pen.Clone Method

Pen.Clone Method
[image]

Creates an exact copy of this pen.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Pen

Return Value

An instance of the Pen class.

See Also

Pen Members
Pen Class


MindFusion.Diagramming.Pen Properties

Pen Properties
[image]

Public Properties

Name | Description
Brush | Gets or sets the Brush object that defines the appearance of this pen.
DashStyle | Gets or sets the dash style of lines frawn with this pen.
Thickness | Gets or sets the width of the pen.

See Also

Pen Class


MindFusion.Diagramming.Pen.Brush Property

Pen.Brush Property
[image]

Gets or sets the Brush object that defines the appearance of this pen.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

An instance of the Windows.UI.Xaml.Media.Brush class.

See Also

Pen Members
Pen Class


MindFusion.Diagramming.Pen.DashStyle Property

Pen.DashStyle Property
[image]

Gets or sets the dash style of lines frawn with this pen.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DashStyle DashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property DashStyle As DashStyle

Property Value

An instance of the DashStyle class.

See Also

Pen Members
Pen Class


MindFusion.Diagramming.Pen.Thickness Property

Pen.Thickness Property
[image]

Gets or sets the width of the pen.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Thickness { get; set; }

Visual Basic [image] Copy Code

Public Property Thickness As Double

Property Value

A double value specifying the width of lines drawn with this pen. The default value is 1.

See Also

Pen Members
Pen Class


MindFusion.Diagramming.PointI Structure

PointI Structure
[image]

Point with integer coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public struct PointI

Visual Basic [image] Copy Code

Public Structure PointI

See Also

PointI Members


MindFusion.Diagramming.PointI Members

PointI Members
Constructors Fields Methods
[image]

Point with integer coordinates.

The following tables list the members exposed by the PointI type.

Public Constructors

Name | Description
PointI | Initializes a new instance of the PointI class.

Public Fields

Name | Description
X | The X coordinate of this point.
Y | The Y coordinate of this point.

Public Methods

Name | Description
ToPoint | Converts the current point to a Windows.UI.Xaml.Point object.
ToString | Object.ToString override.

See Also

PointI Structure


MindFusion.Diagramming.PointI Fields

PointI Fields
[image]

Public Fields

Name | Description
X | The X coordinate of this point.
Y | The Y coordinate of this point.

See Also

PointI Structure


MindFusion.Diagramming.PointI.X Field

PointI.X Field
[image]

The X coordinate of this point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int X

Visual Basic [image] Copy Code

Public X As Integer

See Also

PointI Members
PointI Structure


MindFusion.Diagramming.PointI.Y Field

PointI.Y Field
[image]

The Y coordinate of this point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Y

Visual Basic [image] Copy Code

Public Y As Integer

See Also

PointI Members
PointI Structure


MindFusion.Diagramming.PointI Constructor

PointI Constructor
[image]

Initializes a new instance of the PointI class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointI (
int X,
int Y
)

Visual Basic [image] Copy Code

Public New ( _
X As Integer, _
Y As Integer _
)

Parameters

X

Y

See Also

PointI Structure


MindFusion.Diagramming.PointI Methods

PointI Methods
[image]

Public Methods

Name | Description
ToPoint | Converts the current point to a Windows.UI.Xaml.Point object.
ToString | Object.ToString override.

See Also

PointI Structure


MindFusion.Diagramming.PointI.ToPoint Method

PointI.ToPoint Method
[image]

Converts the current point to a Windows.UI.Xaml.Point object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point ToPoint ()

Visual Basic [image] Copy Code

Public Function ToPoint () As Point

Return Value

See Also

PointI Members
PointI Structure


MindFusion.Diagramming.PointI.ToString Method

PointI.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

See Also

PointI Members
PointI Structure


MindFusion.Diagramming.PrintOptions Class

PrintOptions Class
[image]

Provides properties that allow customization of various aspects of printing and print-preview.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class PrintOptions : RenderOptions

Visual Basic [image] Copy Code

Public Class PrintOptions
Inherits RenderOptions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.RenderOptions
MindFusion.Diagramming.PrintOptions

See Also

PrintOptions Members


MindFusion.Diagramming.PrintOptions Members

PrintOptions Members
Constructors Properties Methods
[image]

Provides properties that allow customization of various aspects of printing and print-preview.

The following tables list the members exposed by the PrintOptions type.

Public Constructors

Name | Description
PrintOptions | Initializes a new instance of the PrintOptions class.

Public Properties

Name | Description
DocumentName | Gets or sets the name of the printed document.
HeaderFormat | Gets or sets the format of page headers.
Margins | Gets or sets the margins for the printed pages.

Inherited Public Properties

Name | Description
Scale | Gets or sets the scale of the print output relatively to the original on-screen size of the diagram. (Inherited from RenderOptions.)

Public Methods

Name | Description
Clone | Creates a copy of the current PrintOptions instance.

See Also

PrintOptions Class


MindFusion.Diagramming.PrintOptions Constructor

PrintOptions Constructor
[image]

Initializes a new instance of the PrintOptions class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PrintOptions (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram

See Also

PrintOptions Class


MindFusion.Diagramming.PrintOptions Methods

PrintOptions Methods
[image]

Public Methods

Name | Description
Clone | Creates a copy of the current PrintOptions instance.

See Also

PrintOptions Class


MindFusion.Diagramming.PrintOptions.Clone Method

PrintOptions.Clone Method
[image]

Creates a copy of the current PrintOptions instance.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PrintOptions Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As PrintOptions

Return Value

See Also

PrintOptions Members
PrintOptions Class


MindFusion.Diagramming.PrintOptions Properties

PrintOptions Properties
[image]

Public Properties

Name | Description
DocumentName | Gets or sets the name of the printed document.
HeaderFormat | Gets or sets the format of page headers.
Margins | Gets or sets the margins for the printed pages.

Inherited Public Properties

Name | Description
Scale | Gets or sets the scale of the print output relatively to the original on-screen size of the diagram. (Inherited from RenderOptions.)

See Also

PrintOptions Class


MindFusion.Diagramming.PrintOptions.DocumentName Property

PrintOptions.DocumentName Property
[image]

Gets or sets the name of the printed document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string DocumentName { get; set; }

Visual Basic [image] Copy Code

Public Property DocumentName As String

Property Value

This string is displayed in the print queue status window and in page headers.

See Also

PrintOptions Members
PrintOptions Class


MindFusion.Diagramming.PrintOptions.HeaderFormat Property

PrintOptions.HeaderFormat Property
[image]

Gets or sets the format of page headers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string HeaderFormat { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderFormat As String

Property Value

A string value specifying the name of the printed document. The default is "%D , Page %P".

Remarks

The header format string can contain fixed text and format specifiers. Currently, there are two format specifiers supported: %D is a placeholder for the document title; %P is a placholder for the page number.

See Also

PrintOptions Members
PrintOptions Class


MindFusion.Diagramming.PrintOptions.Margins Property

PrintOptions.Margins Property
[image]

Gets or sets the margins for the printed pages.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Thickness Margins { get; set; }

Visual Basic [image] Copy Code

Public Property Margins As Thickness

Property Value

An instance of the .NET Windows.UI.Xaml.Thickness structure. The default is 1-inch margins on all sides.

See Also

PrintOptions Members
PrintOptions Class


MindFusion.Diagramming.QuickRouter Class

QuickRouter Class
Remarks See Also
[image]

Implements a very fast link routing algorithm that uses a tree to represent the free and occupied regions in the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class QuickRouter : ILinkRouter

Visual Basic [image] Copy Code

Public Class QuickRouter
Implements ILinkRouter

Remarks

To use this class for link routing simply assign its instance to the LinkRouter property of the Diagram class.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.QuickRouter

See Also

QuickRouter Members


MindFusion.Diagramming.QuickRouter Members

QuickRouter Members
Constructors Properties Methods
[image]

Implements a very fast link routing algorithm that uses a tree to represent the free and occupied regions in the diagram.

The following tables list the members exposed by the QuickRouter type.

Public Constructors

Name | Description
QuickRouter | Overloaded.

Public Properties

Name | Description
Diagram | Gets or sets the diagram this router is associated with.
Granularity | Gets or sets the granularity of the obstacles map generated by QuickRouter.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.
UBendMaxLen | Gets or sets the maximum U-bend length.

Public Methods

Name | Description
Resume | Implements ILinkRouter.Resume.
RouteAllLinks | Routes all links in the diagram.
RouteLink | Implements ILinkRouter.RouteLink.
RouteLinks | Implements ILinkRouter.RouteLinks.
Suspend | Implements ILinkRouter.Suspend.

See Also

QuickRouter Class


MindFusion.Diagramming.QuickRouter Constructor

QuickRouter Constructor
[image]

Overload List

Name | Description
QuickRouter () | Initializes a new instance of the QuickRouter class.
QuickRouter (Diagram) | Initializes a new instance of the QuickRouter class.

See Also

QuickRouter Class


MindFusion.Diagramming.QuickRouter Constructor ()

QuickRouter Constructor ()
See Also
[image]

Initializes a new instance of the QuickRouter class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public QuickRouter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

QuickRouter Constructor Overload List
QuickRouter Class


MindFusion.Diagramming.QuickRouter Constructor (Diagram)

QuickRouter Constructor (Diagram)
See Also
[image]

Initializes a new instance of the QuickRouter class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public QuickRouter (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram

See Also

QuickRouter Constructor Overload List
QuickRouter Class


MindFusion.Diagramming.QuickRouter Methods

QuickRouter Methods
[image]

Public Methods

Name | Description
Resume | Implements ILinkRouter.Resume.
RouteAllLinks | Routes all links in the diagram.
RouteLink | Implements ILinkRouter.RouteLink.
RouteLinks | Implements ILinkRouter.RouteLinks.
Suspend | Implements ILinkRouter.Suspend.

See Also

QuickRouter Class


MindFusion.Diagramming.QuickRouter.Resume Method

QuickRouter.Resume Method
[image]

Implements ILinkRouter.Resume.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Resume (
bool routeDeferredLinks
)

Visual Basic [image] Copy Code

Public Sub Resume( _
routeDeferredLinks As Boolean _
)

Parameters

routeDeferredLinks
true if the links should be routed, otherwise false.

See Also

QuickRouter Members
QuickRouter Class


MindFusion.Diagramming.QuickRouter.RouteAllLinks Method

QuickRouter.RouteAllLinks Method
[image]

Routes all links in the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RouteAllLinks ()

Visual Basic [image] Copy Code

Public Sub RouteAllLinks ()

See Also

QuickRouter Members
QuickRouter Class


MindFusion.Diagramming.QuickRouter.RouteLink Method

QuickRouter.RouteLink Method
[image]

Implements ILinkRouter.RouteLink.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool RouteLink (
DiagramLink link
)

Visual Basic [image] Copy Code

Public Overridable Function RouteLink ( _
link As DiagramLink _
) As Boolean

Parameters

link
The DiagramLink to route.

Return Value

true if a path has been found successfully, otherwise false.

See Also

QuickRouter Members
QuickRouter Class


MindFusion.Diagramming.QuickRouter.RouteLinks Method

QuickRouter.RouteLinks Method
[image]

Implements ILinkRouter.RouteLinks.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void RouteLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Public Overridable Sub RouteLinks ( _
links As DiagramLinkCollection _
)

Parameters

links
A list of DiagramLink objects that should be routed.

See Also

QuickRouter Members
QuickRouter Class


MindFusion.Diagramming.QuickRouter.Suspend Method

QuickRouter.Suspend Method
[image]

Implements ILinkRouter.Suspend.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Suspend ()

Visual Basic [image] Copy Code

Public Sub Suspend ()

See Also

QuickRouter Members
QuickRouter Class


MindFusion.Diagramming.QuickRouter Properties

QuickRouter Properties
[image]

Public Properties

Name | Description
Diagram | Gets or sets the diagram this router is associated with.
Granularity | Gets or sets the granularity of the obstacles map generated by QuickRouter.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.
UBendMaxLen | Gets or sets the maximum U-bend length.

See Also

QuickRouter Class


MindFusion.Diagramming.QuickRouter.Diagram Property

QuickRouter.Diagram Property
[image]

Gets or sets the diagram this router is associated with.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Diagram Diagram { get; set; }

Visual Basic [image] Copy Code

Public Property Diagram As Diagram

Property Value

See Also

QuickRouter Members
QuickRouter Class


MindFusion.Diagramming.QuickRouter.Granularity Property

QuickRouter.Granularity Property
[image]

Gets or sets the granularity of the obstacles map generated by QuickRouter.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Granularity Granularity { get; set; }

Visual Basic [image] Copy Code

Public Property Granularity As Granularity

Property Value

A member of the Granularity enumeration. The default value is CoarseGrained.

Remarks

A CoarseGrained obstacle map leads to faster path finding, however the found paths might be longer than necessary in a small percent of the cases. The coarse-grained map also takes slightly more time to build, so you might disable it if there are aren't many links in the diagram.

See Also

QuickRouter Members
QuickRouter Class


MindFusion.Diagramming.QuickRouter.TurnCost Property

QuickRouter.TurnCost Property
[image]

Gets or sets a value added to the total cost of a route if it makes a turn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double TurnCost { get; set; }

Visual Basic [image] Copy Code

Public Property TurnCost As Double

Property Value

A double value specifying the turn cost. The default is 50.

See Also

QuickRouter Members
QuickRouter Class


MindFusion.Diagramming.QuickRouter.UBendMaxLen Property

QuickRouter.UBendMaxLen Property
[image]

Gets or sets the maximum U-bend length.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double UBendMaxLen { get; set; }

Visual Basic [image] Copy Code

Public Property UBendMaxLen As Double

Property Value

A double value specifying the maximum length of U-bends in millimeters. The default is 30.

See Also

QuickRouter Members
QuickRouter Class


MindFusion.Diagramming.RelativeToLink Enumeration

RelativeToLink Enumeration
[image]

Specifies how the link labels are positioned.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum RelativeToLink

Visual Basic [image] Copy Code

Public Enum RelativeToLink

Members

Member name | Description
ControlPoint | Indicates that the link labels are positioned relative to a specified control point.
LinkLength | Indicates that the link labels are positioned relative to the link.
Segment | Indicates that the link labels are positioned relative to a specified segment.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.RemoveItemCommand Class

RemoveItemCommand Class
[image]

Implements deletion of diagram items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class RemoveItemCommand : Command

Visual Basic [image] Copy Code

Public Class RemoveItemCommand
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Command
MindFusion.Diagramming.RemoveItemCommand

See Also

RemoveItemCommand Members


MindFusion.Diagramming.RemoveItemCommand Members

RemoveItemCommand Members
Constructors Properties Methods
[image]

Implements deletion of diagram items.

The following tables list the members exposed by the RemoveItemCommand type.

Public Constructors

Name | Description
RemoveItemCommand | Initializes a new instance of the RemoveItemCommand class.

Inherited Public Properties

Name | Description
Diagram | Gets the Diagram modified by this Command object. (Inherited from Command.)

Public Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

Inherited Public Methods

Name | Description
Execute | Carries out an action that changes the diagram in some way. (Inherited from Command.)
Redo | Repeats an action that has been undone. (Inherited from Command.)
Undo | Undoes an action, restoring the diagram to the state it was in before carrying out the action. (Inherited from Command.)

See Also

RemoveItemCommand Class


MindFusion.Diagramming.RemoveItemCommand Constructor

RemoveItemCommand Constructor
[image]

Initializes a new instance of the RemoveItemCommand class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RemoveItemCommand (
Diagram diagram,
DiagramItem item
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram, _
item As DiagramItem _
)

Parameters

diagram
A Diagram from which the item is removed.
item
A DiagramItem that should be removed from the Diagram.

See Also

RemoveItemCommand Class


MindFusion.Diagramming.RemoveItemCommand Methods

RemoveItemCommand Methods
[image]

Public Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

Inherited Public Methods

Name | Description
Execute | Carries out an action that changes the diagram in some way. (Inherited from Command.)
Redo | Repeats an action that has been undone. (Inherited from Command.)
Undo | Undoes an action, restoring the diagram to the state it was in before carrying out the action. (Inherited from Command.)

See Also

RemoveItemCommand Class


MindFusion.Diagramming.RemoveItemCommand.Execute Method

RemoveItemCommand.Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Execute ()

Visual Basic [image] Copy Code

Public Overrides Sub Execute ()

See Also

RemoveItemCommand Members
RemoveItemCommand Class


MindFusion.Diagramming.RemoveItemCommand.Redo Method

RemoveItemCommand.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Redo ()

Visual Basic [image] Copy Code

Public Overrides Sub Redo ()

See Also

RemoveItemCommand Members
RemoveItemCommand Class


MindFusion.Diagramming.RemoveItemCommand.Undo Method

RemoveItemCommand.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Undo ()

Visual Basic [image] Copy Code

Public Overrides Sub Undo ()

See Also

RemoveItemCommand Members
RemoveItemCommand Class


MindFusion.Diagramming.RenderOptions Class

RenderOptions Class
[image]

Provides properties that allow customization of various aspects of printing and print-preview.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class RenderOptions

Visual Basic [image] Copy Code

Public Class RenderOptions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.RenderOptions
MindFusion.Diagramming.PrintOptions

See Also

RenderOptions Members


MindFusion.Diagramming.RenderOptions Members

RenderOptions Members
Constructors Properties
[image]

Provides properties that allow customization of various aspects of printing and print-preview.

The following tables list the members exposed by the RenderOptions type.

Public Constructors

Name | Description
RenderOptions | Initializes a new instance of the RenderOptions class.

Public Properties

Name | Description
Scale | Gets or sets the scale of the print output relatively to the original on-screen size of the diagram.

See Also

RenderOptions Class


MindFusion.Diagramming.RenderOptions Constructor

RenderOptions Constructor
[image]

Initializes a new instance of the RenderOptions class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RenderOptions ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RenderOptions Class


MindFusion.Diagramming.RenderOptions Properties

RenderOptions Properties
[image]

Public Properties

Name | Description
Scale | Gets or sets the scale of the print output relatively to the original on-screen size of the diagram.

See Also

RenderOptions Class


MindFusion.Diagramming.RenderOptions.Scale Property

RenderOptions.Scale Property
[image]

Gets or sets the scale of the print output relatively to the original on-screen size of the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Scale { get; set; }

Visual Basic [image] Copy Code

Public Property Scale As Double

Property Value

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RerouteLinks Enumeration

RerouteLinks Enumeration
[image]

Provides values indicating in what circumstances links must be rerouted automatically.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum RerouteLinks

Visual Basic [image] Copy Code

Public Enum RerouteLinks

Members

Member name | Description
Never | Do not reroute links automatically.
WhenIntersectNode | Reroute a link if it intersects a node.
WhenModified | Reroute a link if its end points are moved around.
WhileCreating | Route new links while users draw them. This flag can be combined with any of the previous two flags.

Remarks

These values can be assigned to the TriggerRerouting property of RoutingOptions.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.ResolveNodePosition Delegate

ResolveNodePosition Delegate
[image]

Represents a method that determines the position of a data item within the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate Rect ResolveNodePosition (
Object dataItem
)

Visual Basic [image] Copy Code

Public Delegate Function ResolveNodePosition( _
dataItem As Object _
) As Rect

Parameters

dataItem

A data item whose position should be returned.

Return Value

A Windows.UI.Xaml.Rect specifying the item's position.

Remarks

By default, VirtualizingDiagram determines the position of a data item by inspecting its X, Y, Width and Height properties through reflection. By assigning this delegate method to the ResolveNodePosition property of VirtualizingDiagram, you can place items whose position properties are named differently or whose position is stored elsewhere.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.RoundRectangleTemplate Class

RoundRectangleTemplate Class
[image]

Represents an ElementTemplate that draws round rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class RoundRectangleTemplate : ElementTemplate

Visual Basic [image] Copy Code

Public Class RoundRectangleTemplate
Inherits ElementTemplate

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ElementTemplate
MindFusion.Diagramming.RoundRectangleTemplate

See Also

RoundRectangleTemplate Members


MindFusion.Diagramming.RoundRectangleTemplate Members

RoundRectangleTemplate Members
Constructors Properties Methods
[image]

Represents an ElementTemplate that draws round rectangle.

The following tables list the members exposed by the RoundRectangleTemplate type.

Public Constructors

Name | Description
RoundRectangleTemplate | Overloaded.

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of this element.
Radius | Gets or sets the round radius of this element.

Inherited Public Properties

Name | Description
Color | Gest or sets the outline color of this element. (Inherited from ElementTemplate.)
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

Public Methods

Name | Description
Clone | Creates an exact copy of this RoundRectangleTemplate element.

Inherited Public Methods

Name | Description
Clone | Creates an exact copy of this element. (Inherited from ElementTemplate.)
CompareTo | IComparable.CompareTo implementation. (Inherited from ElementTemplate.)

See Also

RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate Constructor

RoundRectangleTemplate Constructor
[image]

Overload List

Name | Description
RoundRectangleTemplate () | Initializes a new istance of the RoundRectangleTemplate class.
RoundRectangleTemplate (Double, Double, Double, Double, Double) | Initializes a new istance of the RoundRectangleTemplate class with the specified settings.

See Also

RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate Constructor ()

RoundRectangleTemplate Constructor ()
See Also
[image]

Initializes a new istance of the RoundRectangleTemplate class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RoundRectangleTemplate ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RoundRectangleTemplate Constructor Overload List
RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate Constructor (Double, Double, Double, Double, Double)

RoundRectangleTemplate Constructor (Double, Double, Double, Double, Double)
See Also
[image]

Initializes a new istance of the RoundRectangleTemplate class with the specified settings.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RoundRectangleTemplate (
double x,
double y,
double w,
double h,
double r
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
w As Double, _
h As Double, _
r As Double _
)

Parameters

x

The x-coordinate of the top-left corner of the rectangle, expressed in percents of a shape node's bounding rectangle.

y

The y-coordinate of the top-left corner of the rectangle, expressed in percents of a shape node's bounding rectangle.

w

The width of the rectangle, expressed in percents of a shape node's bounding rectangle.

h

The height of the rectangle, expressed in percents of a shape node's bounding rectangle.

r

The round radius of the rectangle.

See Also

RoundRectangleTemplate Constructor Overload List
RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate Methods

RoundRectangleTemplate Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this RoundRectangleTemplate element.

Inherited Public Methods

Name | Description
Clone | Creates an exact copy of this element. (Inherited from ElementTemplate.)
CompareTo | IComparable.CompareTo implementation. (Inherited from ElementTemplate.)

See Also

RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate.Clone Method

RoundRectangleTemplate.Clone Method
[image]

Creates an exact copy of this RoundRectangleTemplate element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

An instance of the RoundRectangleTemplate class.

See Also

RoundRectangleTemplate Members
RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate Properties

RoundRectangleTemplate Properties
[image]

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of this element.
Radius | Gets or sets the round radius of this element.

Inherited Public Properties

Name | Description
Color | Gest or sets the outline color of this element. (Inherited from ElementTemplate.)
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

See Also

RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate.Bounds Property

RoundRectangleTemplate.Bounds Property
[image]

Gets the bounding rectangle of this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As Rect

Property Value

See Also

RoundRectangleTemplate Members
RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate.Radius Property

RoundRectangleTemplate.Radius Property
[image]

Gets or sets the round radius of this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Radius { get; set; }

Visual Basic [image] Copy Code

Public Property Radius As Double

Property Value

See Also

RoundRectangleTemplate Members
RoundRectangleTemplate Class


MindFusion.Diagramming.RoutingOptions Class

RoutingOptions Class
Remarks See Also
[image]

Allows customization of various aspects of the link routing algorithm.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class RoutingOptions : RoutingOptions

Visual Basic [image] Copy Code

Public Class RoutingOptions
Implements RoutingOptions

Remarks

Use the RoutingOptions member of the Diagram class to access the sole instance of this class.

MindFusion.Diagramming uses a cost minimization algorithm to route links between nodes. For each link, there is a routing grid built for the area that encloses the link and its origin and destination nodes. The size of the grid pieces is set via GridSize. Each piece of the grid is marked as an obstacle if it intersects an Obstacle node. Some cost values are assigned to the remaining pieces, depending on how distant they are from nodes and other links.

That algorithm evaluates possible paths across the routing grid aiming to find one that has a minimal cost. The values of LengthCost, TurnCost, CrossingCost and NodeVicinityCost are added to the total cost of a route and have a great influence over the shape of the chosen path.

The StartOrientation and EndOrientation properties specify the orientation of the first and last segments of routed links, and Anchoring specifies whether link ends should be aligned to the anchor points defined for nodes.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.RoutingOptions

See Also

RoutingOptions Members


MindFusion.Diagramming.RoutingOptions Members

RoutingOptions Members
Properties Methods
[image]

Allows customization of various aspects of the link routing algorithm.

The following tables list the members exposed by the RoutingOptions type.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating whether to align link ends to the anchor points of nodes.
CrossingCost | Gets or sets a value added to the total cost of a route if it causes a link to cross another link.
Distance | Gets a heuristic delegate function that returns the real distance sqrt(dx^2 + dy^2) between two pieces of the routing grid.
DistSquare | Gets a heuristic delegate function that returns the square distance dx^2 + dy^2 as a cost evaluation of the distance between two pieces of the routing grid.
DontOptimizeLongRoutes | Gets or sets a value indicating whether long routes don't have their number of segments minimized in order to save up processing time.
EndOrientation | Gets or sets the desired orientation of the last segments of routed links.
GridSize | Gets or sets the size of the pieces of the routing grid.
IgnoreAnchoring | For internal use.
LengthCost | Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.
MaxAbs | Gets a heuristic delegate function that returns max(dx, dy) as a cost evaluation of the distance between two pieces of the routing grid.
NodeVicinityCost | Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.
NodeVicinitySize | Gets or sets the size of a buffer zone around a node in which routes get a penalty cost if they pass through it.
RouteHeuristics | Gets or sets a heuristic function used to evaluate the distance between two pieces of the routing grid.
SmartPolylineEnds | Gets or sets a value indicating whether the end segments of polyline links should be oriented orthogonally to the node bounds.
StartOrientation | Gets or sets the desired orientation of the first segments of routed links.
TriggerRerouting | Gets or sets a value indicating under what circumstances links are rerouted automatically.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.

Public Methods

Name | Description
SetDefaultMode | Resets all routing properties to their default values.
SetMinSegmentsMode | Assigns a predefined set of values to the routing properties which allows finding paths that have a small number of segments.
SetQuickMode | Assigns a predefined set of values to the routing properties which allows finding paths quickly but the found paths are of low quality.

See Also

RoutingOptions Class


MindFusion.Diagramming.RoutingOptions Methods

RoutingOptions Methods
[image]

Public Methods

Name | Description
SetDefaultMode | Resets all routing properties to their default values.
SetMinSegmentsMode | Assigns a predefined set of values to the routing properties which allows finding paths that have a small number of segments.
SetQuickMode | Assigns a predefined set of values to the routing properties which allows finding paths quickly but the found paths are of low quality.

See Also

RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.SetDefaultMode Method

RoutingOptions.SetDefaultMode Method
[image]

Resets all routing properties to their default values.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetDefaultMode ()

Visual Basic [image] Copy Code

Public Sub SetDefaultMode ()

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.SetMinSegmentsMode Method

RoutingOptions.SetMinSegmentsMode Method
[image]

Assigns a predefined set of values to the routing properties which allows finding paths that have a small number of segments.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetMinSegmentsMode ()

Visual Basic [image] Copy Code

Public Sub SetMinSegmentsMode ()

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.SetQuickMode Method

RoutingOptions.SetQuickMode Method
[image]

Assigns a predefined set of values to the routing properties which allows finding paths quickly but the found paths are of low quality.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetQuickMode ()

Visual Basic [image] Copy Code

Public Sub SetQuickMode ()

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions Properties

RoutingOptions Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating whether to align link ends to the anchor points of nodes.
CrossingCost | Gets or sets a value added to the total cost of a route if it causes a link to cross another link.
Distance | Gets a heuristic delegate function that returns the real distance sqrt(dx^2 + dy^2) between two pieces of the routing grid.
DistSquare | Gets a heuristic delegate function that returns the square distance dx^2 + dy^2 as a cost evaluation of the distance between two pieces of the routing grid.
DontOptimizeLongRoutes | Gets or sets a value indicating whether long routes don't have their number of segments minimized in order to save up processing time.
EndOrientation | Gets or sets the desired orientation of the last segments of routed links.
GridSize | Gets or sets the size of the pieces of the routing grid.
IgnoreAnchoring | For internal use.
LengthCost | Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.
MaxAbs | Gets a heuristic delegate function that returns max(dx, dy) as a cost evaluation of the distance between two pieces of the routing grid.
NodeVicinityCost | Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.
NodeVicinitySize | Gets or sets the size of a buffer zone around a node in which routes get a penalty cost if they pass through it.
RouteHeuristics | Gets or sets a heuristic function used to evaluate the distance between two pieces of the routing grid.
SmartPolylineEnds | Gets or sets a value indicating whether the end segments of polyline links should be oriented orthogonally to the node bounds.
StartOrientation | Gets or sets the desired orientation of the first segments of routed links.
TriggerRerouting | Gets or sets a value indicating under what circumstances links are rerouted automatically.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.

See Also

RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.Anchoring Property

RoutingOptions.Anchoring Property
[image]

Gets or sets a value indicating whether to align link ends to the anchor points of nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Anchoring Anchoring { get; set; }

Visual Basic [image] Copy Code

Public Property Anchoring As Anchoring

Property Value

Remarks

By default, the routing algorithm ignores anchor points. To make it align link ends to the points specified in the AnchorPattern property of nodes, set Anchoring to Keep or Reassign. Keep specifies that the routing algorithm will not change the positions of link end points. You can use Reassign to cause the routing algorithm to choose new end points for a link from the ones specified in the AnchorPattern of its origin and destination nodes.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.CrossingCost Property

RoutingOptions.CrossingCost Property
[image]

Gets or sets a value added to the total cost of a route if it causes a link to cross another link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public byte CrossingCost { get; set; }

Visual Basic [image] Copy Code

Public Property CrossingCost As Byte

Property Value

A byte value specifying the crossing cost. The default is 4.

Remarks

This is a penalty value added to the total cost of an evaluated link route if it crosses another link. The routing algorithm aims to find paths that have a minimal cost, so assigning a greater value to CrossingCost leads to fewer link intersections. At this time CrossingCost processing is implemented only for links with LinkShape set to Cascading.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.Distance Property

RoutingOptions.Distance Property
[image]

Gets a heuristic delegate function that returns the real distance sqrt(dx^2 + dy^2) between two pieces of the routing grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static RouteHeuristics Distance { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Distance As RouteHeuristics

Property Value

Remarks

Distance is a predefined delegate that assigns to pieces a heuristic value equaling the piece distance to the target. Thus of the four pieces adjacent to the current one, the piece closest to the target has the smallest value and the route generation continues through it. Distance is the default value of the RouteHeuristics property.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.DistSquare Property

RoutingOptions.DistSquare Property
[image]

Gets a heuristic delegate function that returns the square distance dx^2 + dy^2 as a cost evaluation of the distance between two pieces of the routing grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static RouteHeuristics DistSquare { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DistSquare As RouteHeuristics

Property Value

A predefined RouteHeuristics delegate instance.

Remarks

DistSquare is a predefined delegate that assigns to pieces a heuristic value equaling the piece distance to the target raised to the second power. DistSquare can be assigned to the RouteHeuristics property. By returning larger values than the default heuristic function Distance, it makes the prediction part of the routing algorithm have greater impact on the evaluated routes.That would lead to faster path-finding, but the real cost functions might have less impact and thus the quality of the found routes could be low.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.DontOptimizeLongRoutes Property

RoutingOptions.DontOptimizeLongRoutes Property
[image]

Gets or sets a value indicating whether long routes don't have their number of segments minimized in order to save up processing time.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool DontOptimizeLongRoutes { get; set; }

Visual Basic [image] Copy Code

Public Property DontOptimizeLongRoutes As Boolean

Property Value

true to disable route optimization for long links; otherwise, false. The default is false.

Remarks

Segment optimization done on routed links might need much processing time. The control allows disabling that optimization for long links. That would make the found routes have a "staircase" pattern when they run diagonally.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.EndOrientation Property

RoutingOptions.EndOrientation Property
[image]

Gets or sets the desired orientation of the last segments of routed links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation EndOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property EndOrientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Auto.

Remarks

For some diagrams it might be desirable that first and last segments of links always have a specific direction. For example, in database ER diagrams links usually connect to table rows on the left- or right-hand sides of tables; in that case their end segments must be horizontal. EndOrientation specifies what orientation of links' last segments to be applied by the routing algorithm.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.GridSize Property

RoutingOptions.GridSize Property
[image]

Gets or sets the size of the pieces of the routing grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double GridSize { get; set; }

Visual Basic [image] Copy Code

Public Property GridSize As Double

Property Value

A float value specifying the size of the pieces of the routing grid. The default is 4.

Remarks

A smaller size of routing grid pieces helps finding more precise paths, however since the number of pieces increases, there would be more time needed to find a path.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.IgnoreAnchoring Property

RoutingOptions.IgnoreAnchoring Property
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IgnoreAnchoring { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IgnoreAnchoring As Boolean

Property Value

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.LengthCost Property

RoutingOptions.LengthCost Property
[image]

Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public byte LengthCost { get; set; }

Visual Basic [image] Copy Code

Public Property LengthCost As Byte

Property Value

A byte value specifying the length cost. The default is 2.

Remarks

This is a penalty value added to the total cost of an evaluated link route for each piece of the routing grid it occupies. The routing algorithm aims to find paths that have a minimal cost, so assigning a greater value to LengthCost leads to generating shorter paths.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.MaxAbs Property

RoutingOptions.MaxAbs Property
[image]

Gets a heuristic delegate function that returns max(dx, dy) as a cost evaluation of the distance between two pieces of the routing grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static RouteHeuristics MaxAbs { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MaxAbs As RouteHeuristics

Property Value

A predefined RouteHeuristics delegate instance.

Remarks

MaxAbs is a predefined delegate that assigns to pieces the higher value from the horizontal or vertical -only distances between a piece and the target. MaxAbs can be assigned to the RouteHeuristics property. By returning smaller values than the default heuristic function Distance, it makes the prediction part of the routing algorithm have less impact on the evaluated routes. That might lead to slower path-finding, but the real cost functions would have greater impact and thus the quality of the found routes could be higher.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.NodeVicinityCost Property

RoutingOptions.NodeVicinityCost Property
[image]

Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public byte NodeVicinityCost { get; set; }

Visual Basic [image] Copy Code

Public Property NodeVicinityCost As Byte

Property Value

A byte value specifying the node vicinity cost. The default is 2.

Remarks

This is a penalty value added to the total cost of an evaluated link route if it passes too close to a node. The routing algorithm aims to find paths that have a minimal cost, so assigning a greater value to NodeVicinityCost makes links avoid passing close to nodes. The size of the buffer area around nodes in which passing links get a penalty cost is set by NodeVicinitySize.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.NodeVicinitySize Property

RoutingOptions.NodeVicinitySize Property
[image]

Gets or sets the size of a buffer zone around a node in which routes get a penalty cost if they pass through it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeVicinitySize { get; set; }

Visual Basic [image] Copy Code

Public Property NodeVicinitySize As Double

Property Value

A floag value specifying the size of the buffer area in which passing routes receive a penalty cost. The default is 12.

Remarks

The pieces of the routing grid that are closest to a node have the value of NodeVicinityCost assigned as their cost. The outer pieces of the buffer zone are assigned a portion of NodeVicinityCost proportional to their distance to the node.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.RouteHeuristics Property

RoutingOptions.RouteHeuristics Property
[image]

Gets or sets a heuristic function used to evaluate the distance between two pieces of the routing grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RouteHeuristics RouteHeuristics { get; set; }

Visual Basic [image] Copy Code

Public Property RouteHeuristics As RouteHeuristics

Property Value

A RouteHeuristics delegate used to evaluate the distance from a current routing grid piece to the target one. The default is Distance.

Remarks

While generating a path, the routing algorithm evaluates pieces of the routing grid adjacent to the current one. It takes into account the cost for passing trough a piece and adds to that cost a heuristic value calculated by RouteHeuristics. So the smaller heuristic value a piece has, the greater the chance the found route to go through that piece.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.SmartPolylineEnds Property

RoutingOptions.SmartPolylineEnds Property
[image]

Gets or sets a value indicating whether the end segments of polyline links should be oriented orthogonally to the node bounds.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SmartPolylineEnds { get; set; }

Visual Basic [image] Copy Code

Public Property SmartPolylineEnds As Boolean

Property Value

true to orient the end segments orthogonally to the node bounds; otherwise, false.

Remarks

This property is valid only for links of style Polyline.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.StartOrientation Property

RoutingOptions.StartOrientation Property
[image]

Gets or sets the desired orientation of the first segments of routed links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation StartOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property StartOrientation As Orientation

Property Value

A member of the Orientation enumeration. The default is Auto.

Remarks

For some diagrams it might be desirable that first and last segments of links always have a specific direction. For example, in database ER diagrams links usually connect to table rows on the left- or right-hand sides of tables; in that case their end segments must be horizontal. StartOrientation specifies what orientation of links' first segments to be applied by the routing algorithm.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.TriggerRerouting Property

RoutingOptions.TriggerRerouting Property
[image]

Gets or sets a value indicating under what circumstances links are rerouted automatically.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RerouteLinks TriggerRerouting { get; set; }

Visual Basic [image] Copy Code

Public Property TriggerRerouting As RerouteLinks

Property Value

A member of the RerouteLinks enumeration. The default is WhenModified.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.TurnCost Property

RoutingOptions.TurnCost Property
[image]

Gets or sets a value added to the total cost of a route if it makes a turn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public byte TurnCost { get; set; }

Visual Basic [image] Copy Code

Public Property TurnCost As Byte

Property Value

A byte value specifying the turn cost. The default is 4.

Remarks

This is a penalty value added to the total cost of an evaluated link route for each turn it makes. The routing algorithm aims to find paths that have a minimal cost, so assigning a greater value to TurnCost leads paths that make less turns (hence they have less segments).

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.Row Class

Row Class
[image]

Represents a row in a TableNode object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Row

Visual Basic [image] Copy Code

Public Class Row

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Row

See Also

Row Members


MindFusion.Diagramming.Row Members

Row Members
Constructors Properties Methods
[image]

Represents a row in a TableNode object.

The following tables list the members exposed by the Row type.

Public Constructors

Name | Description
Row | Initializes a new instance of the Row class.

Public Properties

Name | Description
AnchorPattern | Gets or sets a set of anchor points to which links can dock when connected to this row.
Height | Gets or sets the height of the table row.
IncomingLinks | Gets a collection of all links that point to this table row.
OutgoingLinks | Gets a collection of all links that go out of this table row.

Protected Methods

Name | Description
LoadFromXml | Loads the row properties from an XML element.
SaveToXml | Saves the row properties into an XML element.

See Also

Row Class


MindFusion.Diagramming.Row Constructor

Row Constructor
[image]

Initializes a new instance of the Row class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Row (
TableNode tableNode
)

Visual Basic [image] Copy Code

Public New ( _
tableNode As TableNode _
)

Parameters

tableNode
The TableNode this row belongs to.

See Also

Row Class


MindFusion.Diagramming.Row Methods

Row Methods
[image]

Protected Methods

Name | Description
LoadFromXml | Loads the row properties from an XML element.
SaveToXml | Saves the row properties into an XML element.

See Also

Row Class


MindFusion.Diagramming.Row.LoadFromXml Method

Row.LoadFromXml Method
[image]

Loads the row properties from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void LoadFromXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub LoadFromXml ( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement containing the row's data.

context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

Row Members
Row Class


MindFusion.Diagramming.Row.SaveToXml Method

Row.SaveToXml Method
[image]

Saves the row properties into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void SaveToXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub SaveToXml ( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement the row's data should be stored into.

context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

Row Members
Row Class


MindFusion.Diagramming.Row Properties

Row Properties
[image]

Public Properties

Name | Description
AnchorPattern | Gets or sets a set of anchor points to which links can dock when connected to this row.
Height | Gets or sets the height of the table row.
IncomingLinks | Gets a collection of all links that point to this table row.
OutgoingLinks | Gets a collection of all links that go out of this table row.

See Also

Row Class


MindFusion.Diagramming.Row.AnchorPattern Property

Row.AnchorPattern Property
[image]

Gets or sets a set of anchor points to which links can dock when connected to this row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern AnchorPattern { get; set; }

Visual Basic [image] Copy Code

Public Property AnchorPattern As AnchorPattern

Property Value

Remarks

AnchorPattern defines a set of locations where links connected to a row are allowed to connect. When a link is connected to a row, the respective end of the link is aligned to the nearest AnchorPoint assigned to that row. If a row does not have associated anchor points of the appropriate type (incoming/outgoing), the link will be connected to the nearest row that has such anchors defined. If none of the rows of a table has an associated anchor pattern, links are connected to the middle of the left or right side of the pointed row.

See Also

Row Members
Row Class


MindFusion.Diagramming.Row.Height Property

Row.Height Property
[image]

Gets or sets the height of the table row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Double

Property Value

See Also

Row Members
Row Class


MindFusion.Diagramming.Row.IncomingLinks Property

Row.IncomingLinks Property
[image]

Gets a collection of all links that point to this table row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection IncomingLinks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IncomingLinks As DiagramLinkCollection

Property Value

Remarks

The property returns a collection of all links that point to this table row. Use it to access the links or get their number.

See Also

Row Members
Row Class


MindFusion.Diagramming.Row.OutgoingLinks Property

Row.OutgoingLinks Property
[image]

Gets a collection of all links that go out of this table row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection OutgoingLinks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OutgoingLinks As DiagramLinkCollection

Property Value

Remarks

The property returns a collection of all links that start from this table row. Use it to access the links or get their number.

See Also

Row Members
Row Class


MindFusion.Diagramming.Ruler Class

Ruler Class
Remarks See Also
[image]

The Ruler control provides horizontal and vertical scales that help users measure diagram items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Ruler : Grid

Visual Basic [image] Copy Code

Public Class Ruler
Inherits Grid

Remarks

To set which Diagram instance is shown in a ruler, add it as a child to the Ruler element by placing the <Diagram> tags within the <Ruler> tags in XAML. Note that the Ruler contains an internal ScrollViewer, so you should not add an additional viewer to enable scrolling.

The ruler tracks mouse movements and modifications being performed on an item, and displays markers over the scales indicating the current position in diagram's coordinate system. The colors of these markers can be changed using the PointerColor and ProjectionColor properties.

The ruler allows aligning several items by clicking on a scale and dragging. That displays alignment guides which follow the mouse pointer and move all selected items on their way. If no diagram elements are selected, all items are moved.

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Panel
Windows.UI.Xaml.Controls.Grid
MindFusion.Diagramming.Ruler

See Also

Ruler Members


MindFusion.Diagramming.Ruler Members

Ruler Members
Constructors Fields Properties Methods
[image]

The Ruler control provides horizontal and vertical scales that help users measure diagram items.

The following tables list the members exposed by the Ruler type.

Public Constructors

Name | Description
Ruler | Initializes a new instance of the Ruler control.

Public Fields

Name | Description
HorizontalOffsetProperty | Identifies the HorizontalOffset dependency property.
VerticalOffsetProperty | Identifies the VerticalOffset dependency property.

Public Properties

Name | Description
Document | Gets or sets the Diagram object this ruler is associated with.
HorizontalOffset | Gets a value that contains the horizontal offset of the scrolled diagram.
HorizontalScaleAlignment | Gets or sets the alignment of the horizontal scale.
HorizontalScaleVisible | Specifies whether the horizontal ruler scale is visible.
InchDivisions | Gets or sets the number of minor divisions to show when Unit is set to Inch.
PointerColor | Gets or sets the color used to paint cursor projections.
ProjectionColor | Gets or sets the color used to paint the projection of the active node.
ProjectRotatedBounds | Gets or sets whether the projection of nodes on ruler's scales rotates with them.
ScaleColor | Gets or sets the color used to paint the color of the ruler scales.
ShowIcon | Gets or sets a value indicating whether to show the icon between the horizontal and vertical scales.
Unit | Gets or sets the measure unit used by the ruler.
VerticalOffset | Gets a value that contains the vertical offset of the scrolled diagram.
VerticalScaleAlignment | Gets or sets the alignment of the vertical scale.
VerticalScaleVisible | Specifies whether the vertical ruler scale is visible.

Public Methods

Name | Description
UpdateNodeProjection | Updates the active node's projection positions on the ruler scales.

See Also

Ruler Class


MindFusion.Diagramming.Ruler Fields

Ruler Fields
[image]

Public Fields

Name | Description
HorizontalOffsetProperty | Identifies the HorizontalOffset dependency property.
VerticalOffsetProperty | Identifies the VerticalOffset dependency property.

See Also

Ruler Class


MindFusion.Diagramming.Ruler.HorizontalOffsetProperty Field

Ruler.HorizontalOffsetProperty Field
[image]

Identifies the HorizontalOffset dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HorizontalOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HorizontalOffsetProperty As DependencyProperty

See Also

Ruler Members
Ruler Class


MindFusion.Diagramming.Ruler.VerticalOffsetProperty Field

Ruler.VerticalOffsetProperty Field
[image]

Identifies the VerticalOffset dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty VerticalOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly VerticalOffsetProperty As DependencyProperty

See Also

Ruler Members
Ruler Class


MindFusion.Diagramming.Ruler Constructor

Ruler Constructor
[image]

Initializes a new instance of the Ruler control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Ruler ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Ruler Class


MindFusion.Diagramming.Ruler Methods

Ruler Methods
[image]

Public Methods

Name | Description
UpdateNodeProjection | Updates the active node's projection positions on the ruler scales.

See Also

Ruler Class


MindFusion.Diagramming.Ruler.UpdateNodeProjection Method

Ruler.UpdateNodeProjection Method
[image]

Updates the active node's projection positions on the ruler scales.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void UpdateNodeProjection ()

Visual Basic [image] Copy Code

Public Sub UpdateNodeProjection ()

See Also

Ruler Members
Ruler Class


MindFusion.Diagramming.Ruler Properties

Ruler Properties
[image]

Public Properties

Name | Description
Document | Gets or sets the Diagram object this ruler is associated with.
HorizontalOffset | Gets a value that contains the horizontal offset of the scrolled diagram.
HorizontalScaleAlignment | Gets or sets the alignment of the horizontal scale.
HorizontalScaleVisible | Specifies whether the horizontal ruler scale is visible.
InchDivisions | Gets or sets the number of minor divisions to show when Unit is set to Inch.
PointerColor | Gets or sets the color used to paint cursor projections.
ProjectionColor | Gets or sets the color used to paint the projection of the active node.
ProjectRotatedBounds | Gets or sets whether the projection of nodes on ruler's scales rotates with them.
ScaleColor | Gets or sets the color used to paint the color of the ruler scales.
ShowIcon | Gets or sets a value indicating whether to show the icon between the horizontal and vertical scales.
Unit | Gets or sets the measure unit used by the ruler.
VerticalOffset | Gets a value that contains the vertical offset of the scrolled diagram.
VerticalScaleAlignment | Gets or sets the alignment of the vertical scale.
VerticalScaleVisible | Specifies whether the vertical ruler scale is visible.

See Also

Ruler Class


MindFusion.Diagramming.Ruler.Document Property

Ruler.Document Property
[image]

Gets or sets the Diagram object this ruler is associated with.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Diagram Document { get; set; }

Visual Basic [image] Copy Code

Public Property Document As Diagram

Property Value

An instance of the Diagram class contained within the ruler.

See Also

Ruler Members
Ruler Class


MindFusion.Diagramming.Ruler.HorizontalOffset Property

Ruler.HorizontalOffset Property
[image]

Gets a value that contains the horizontal offset of the scrolled diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double HorizontalOffset { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property HorizontalOffset As Double

Property Value

A double value that contains the horizontal offset of the scrolled diagram.

See Also

Ruler Members
Ruler Class


MindFusion.Diagramming.Ruler.HorizontalScaleAlignment Property

Ruler.HorizontalScaleAlignment Property
[image]

Gets or sets the alignment of the horizontal scale.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Alignment HorizontalScaleAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalScaleAlignment As Alignment

Property Value

A member of the Alignment enumeration. The default value is Near.

See Also

Ruler Members
Ruler Class


MindFusion.Diagramming.Ruler.HorizontalScaleVisible Property

Ruler.HorizontalScaleVisible Property
[image]

Specifies whether the horizontal ruler scale is visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Visibility HorizontalScaleVisible { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalScaleVisible As Visibility

Property Value

One of the Windows.UI.Xaml.Visibility values. The default is Visible.

See Also

Ruler Members
Ruler Class


MindFusion.Diagramming.Ruler.InchDivisions Property

Ruler.InchDivisions Property
[image]

Gets or sets the number of minor divisions to show when Unit is set to Inch.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int InchDivisions { get; set; }

Visual Basic [image] Copy Code

Public Property InchDivisions As Integer

Property Value

An integer value specifying the number of minor divisions shown at 100% zoom level. The default value is 8.

See Also

Ruler Members
Ruler Class


MindFusion.Diagramming.Ruler.PointerColor Property

Ruler.PointerColor Property
[image]

Gets or sets the color used to paint cursor projections.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color PointerColor { get; set; }

Visual Basic [image] Copy Code

Public Property PointerColor As Color

Property Value

A Windows.UI.Xaml.Media.Color instance specifying the color of the pointer projection lines. The default is red color.

See Also

Ruler Members
Ruler Class


MindFusion.Diagramming.Ruler.ProjectionColor Property

Ruler.ProjectionColor Property
[image]

Gets or sets the color used to paint the projection of the active node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color ProjectionColor { get; set; }

Visual Basic [image] Copy Code

Public Property ProjectionColor As Color

Property Value

A Windows.UI.Xaml.Media.Color instance specifying the color of the selected node's projection on the scales. The default is LightSteelBlue.

See Also

Ruler Members
Ruler Class


MindFusion.Diagramming.Ruler.ProjectRotatedBounds Property

Ruler.ProjectRotatedBounds Property
[image]

Gets or sets whether the projection of nodes on ruler's scales rotates with them.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ProjectRotatedBounds { get; set; }

Visual Basic [image] Copy Code

Public Property ProjectRotatedBounds As Boolean

Property Value

true if node's projection should match the boundaries of rotated node shape, or false to ignore rotation and project only the coordinates of node's Bounds. The default value is true.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming Namespace
ProjectionColor Property


MindFusion.Diagramming.Ruler.ScaleColor Property

Ruler.ScaleColor Property
[image]

Gets or sets the color used to paint the color of the ruler scales.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color ScaleColor { get; set; }

Visual Basic [image] Copy Code

Public Property ScaleColor As Color

Property Value

A Windows.UI.Xaml.Media.Color used to fill the ruler scales. The default is White.

See Also

Ruler Members
Ruler Class


MindFusion.Diagramming.Ruler.ShowIcon Property

Ruler.ShowIcon Property
[image]

Gets or sets a value indicating whether to show the icon between the horizontal and vertical scales.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ShowIcon { get; set; }

Visual Basic [image] Copy Code

Public Property ShowIcon As Boolean

Property Value

true to display the icon, otherwise false. The default is true.

See Also

Ruler Members
Ruler Class


MindFusion.Diagramming.Ruler.Unit Property

Ruler.Unit Property
[image]

Gets or sets the measure unit used by the ruler.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RulerUnit Unit { get; set; }

Visual Basic [image] Copy Code

Public Property Unit As RulerUnit

Property Value

A member of the RulerUnit enumeration specifying what units are displayed in the scales. The default is Millimeter.

See Also

Ruler Members
Ruler Class


MindFusion.Diagramming.Ruler.VerticalOffset Property

Ruler.VerticalOffset Property
[image]

Gets a value that contains the vertical offset of the scrolled diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double VerticalOffset { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property VerticalOffset As Double

Property Value

A double value that contains the vertical offset of the scrolled diagram.

See Also

Ruler Members
Ruler Class


MindFusion.Diagramming.Ruler.VerticalScaleAlignment Property

Ruler.VerticalScaleAlignment Property
[image]

Gets or sets the alignment of the vertical scale.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Alignment VerticalScaleAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalScaleAlignment As Alignment

Property Value

A member of the Alignment enumeration. The default value is Near.

See Also

Ruler Members
Ruler Class


MindFusion.Diagramming.Ruler.VerticalScaleVisible Property

Ruler.VerticalScaleVisible Property
[image]

Specifies whether the vertical ruler scale is visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Visibility VerticalScaleVisible { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalScaleVisible As Visibility

Property Value

One of the Windows.UI.Xaml.Visibility values. The default is Visible.

See Also

Ruler Members
Ruler Class


MindFusion.Diagramming.RulerUnit Enumeration

RulerUnit Enumeration
[image]

Specifies a measurement unit for the Ruler.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum RulerUnit

Visual Basic [image] Copy Code

Public Enum RulerUnit

Members

Member name | Description
Inch | Indicates an inch.
Millimeter | Indicates a millimeter.
Percent | Indicates percent.
Pixel | Indicates a pixel.
Point | Indicates a point.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.SaveToStringFormat Enumeration

SaveToStringFormat Enumeration
[image]

Specifies in what format to save the diagram when generating a string using the SaveToString method.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum SaveToStringFormat

Visual Basic [image] Copy Code

Public Enum SaveToStringFormat

Members

Member name | Description
Base64 | Indicates a Base64 ASCII encoding.
Xml | Indicates a non-compressed XML output.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.ScrollArrowEventArgs Class

ScrollArrowEventArgs Class
[image]

Contains arguments for the ScrollArrowClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ScrollArrowEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ScrollArrowEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.ScrollArrowEventArgs

See Also

ScrollArrowEventArgs Members


MindFusion.Diagramming.ScrollArrowEventArgs Members

ScrollArrowEventArgs Members
Constructors Properties
[image]

Contains arguments for the ScrollArrowClicked event.

The following tables list the members exposed by the ScrollArrowEventArgs type.

Public Constructors

Name | Description
ScrollArrowEventArgs | Initializes a new instance of the ScrollArrowEventArgs class.

Public Properties

Name | Description
Direction | Specifies which arrow button has been clicked.

See Also

ScrollArrowEventArgs Class


MindFusion.Diagramming.ScrollArrowEventArgs Constructor

ScrollArrowEventArgs Constructor
[image]

Initializes a new instance of the ScrollArrowEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ScrollArrowEventArgs (
ScrollDirection p
)

Visual Basic [image] Copy Code

Public New ( _
p As ScrollDirection _
)

Parameters

p

See Also

ScrollArrowEventArgs Class


MindFusion.Diagramming.ScrollArrowEventArgs Properties

ScrollArrowEventArgs Properties
[image]

Public Properties

Name | Description
Direction | Specifies which arrow button has been clicked.

See Also

ScrollArrowEventArgs Class


MindFusion.Diagramming.ScrollArrowEventArgs.Direction Property

ScrollArrowEventArgs.Direction Property
[image]

Specifies which arrow button has been clicked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ScrollDirection Direction { get; set; }

Visual Basic [image] Copy Code

Public Property Direction As ScrollDirection

Property Value

See Also

ScrollArrowEventArgs Members
ScrollArrowEventArgs Class


MindFusion.Diagramming.ScrollDirection Enumeration

ScrollDirection Enumeration
[image]

Identifies the direction of a scroll arrow.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum ScrollDirection

Visual Basic [image] Copy Code

Public Enum ScrollDirection

Members

Member name | Description
Bottom | Scroll to the bottom.
Left | Scroll to the left.
Right | Scroll to the right.
Top | Scroll to the top.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.Selection Class

Selection Class
Remarks See Also
[image]

Represents a set of items selected in the diagram document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Selection : DiagramItem

Visual Basic [image] Copy Code

Public Class Selection
Inherits DiagramItem

Remarks

In a diagram document several items can be selected simultaneously. If more than one item is selected, the compound set of selected items is handled by an instance of the Selection class. Items in the selection can be of any element type. The Items property gives a collection of all the items in the selection. You can get type-safe access to items of specific class by the Links and Nodes collections properties.

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
Windows.UI.Xaml.Controls.ContentControl
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.Selection

See Also

Selection Members


MindFusion.Diagramming.Selection Members

Selection Members
Constructors Fields Properties Methods
[image]

Represents a set of items selected in the diagram document.

The following tables list the members exposed by the Selection type.

Public Constructors

Name | Description
Selection | Initializes a new instance of the Selection class.

Inherited Public Fields

Name | Description
AutoCaptureMouseProperty | Identifies the AutoCaptureMouse dependency property. (Inherited from DiagramItem.)
BrushProperty | Identifies the Brush dependency property. (Inherited from DiagramItem.)
HyperLinkProperty | Identifies the HyperLink dependency property. (Inherited from DiagramItem.)
IsMouseDownProperty | Identifies the IsMouseDown dependency property. (Inherited from DiagramItem.)
IsMouseOverProperty | Identifies the IsMouseOver dependency property. (Inherited from DiagramItem.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from DiagramItem.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)

Inherited Protected Fields

Name | Description
handles | A list of the Rectangle objects that represent the item's adjustment handles. (Inherited from DiagramItem.)

Public Properties

Name | Description
AllowMultipleSelection | Gets or sets a value indicating whether more than one items can be selected simultaneously.
Items | Gets the selected diagram items.
Links | Gets a collection of all selected links.
Nodes | Gets a collection of all selected nodes.

Inherited Public Properties

Name | Description
AutoCaptureMouse | Gets or sets whether the item should capture the mouse input when the left button is pressed over it. This is a dependency property. (Inherited from DiagramItem.)
Brush | Gets or sets the Brush that specifies how to paint the interior of the item. This is a dependency property. (Inherited from DiagramItem.)
Diagram | Gets the parent diagram. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramItem.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. This is a dependency property. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IsMouseDown | Gets a value indicating whether the mouse button is pressed over this item. This is a dependency property. (Inherited from DiagramItem.)
IsMouseOver | Gets a value indicating whether the mouse pointer is located over this item. This is a dependency property. (Inherited from DiagramItem.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline nodes. This is a dependency property. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashOffset | Gets or sets a double value that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. This is a dependency property. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
ToolTip | Gets or sets the contents of the tooltip displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of the object. (Inherited from DiagramItem.)

Inherited Protected Properties

Name | Description
Size | Gets the size of this item. (Inherited from DiagramItem.)

Public Methods

Name | Description
AddItem | Adds a new item to the current selection.
Change | Selects an item and deselects all others.
Clear | Removes all items from the selection.
GetBounds | Gets the bounding rectangle of this item.
GetRotatedBounds | Gets the bounding rectangle of this item when it is rotated.
HitTestHandle | DiagramItem.HitTestHandle override.
RemoveItem | Removes an item from the selection.
Toggle | Toggles the selection state of an item.

Protected Methods

Name | Description
AddHandlesToCanvas | DiagramItem.AddHandlesToCanvas override.
CancelDrag | DiagramItem.CancelDrag override.
EndDrag | DiagramItem.EndDrag override.
OnRemove | DiagramItem.OnRemove override.
StartDrag | DiagramItem.StartDrag override.
UpdateDrag | DiagramItem.UpdateDrag override.
UpdateVisuals | DiagramItem.UpdateVisuals override.

Inherited Public Methods

Name | Description
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
ContainsPoint | Determines whether this item contains the specified point. (Inherited from DiagramItem.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetOutlinePoly | Gets a polygon approximating the outline of this object. (Inherited from DiagramItem.)
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow. (Inherited from DiagramItem.)
GetRotatedBounds | Gets the bounding rectangle of this item when it is rotated. (Inherited from DiagramItem.)
HitTestHandle | Determines whether a selection handle of this item is located at the specified point. (Inherited from DiagramItem.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnApplyTemplate | Control.OnApplyTemplate override. (Inherited from DiagramItem.)
RestoreLocationState | Restores the state of this diagram item. (Inherited from DiagramItem.)
SaveLocationState | Saves the state of this diagram item. (Inherited from DiagramItem.)
TransformDiagramToItem | Transforms a point in diagram coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Gets the diagram coordinates of a point specified in the local coordinate system of this item. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Inherited Protected Methods

Name | Description
AddHandlesToCanvas | Overloaded. (Inherited from DiagramItem.)
AllowDrag | Invoked to validate the drag operation. (Inherited from DiagramItem.)
CancelDrag | Invoked when the interactive modification of this object has been canceled. (Inherited from DiagramItem.)
CreateState | Creates an item state corresponding to the type of this diagram item. (Inherited from DiagramItem.)
EndDrag | Invoked when the user stops dragging this item. (Inherited from DiagramItem.)
LoadFromXml | Loads the item content from an XML element. (Inherited from DiagramItem.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnMouseEnter | Control.OnMouseEnter override. (Inherited from DiagramItem.)
OnMouseLeave | Control.OnMouseLeave override. (Inherited from DiagramItem.)
OnMouseLeftButtonDown | Control.OnMouseLeftButtonDown override. (Inherited from DiagramItem.)
OnMouseLeftButtonUp | Control.OnMouseLeftButtonUp override. (Inherited from DiagramItem.)
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
RemoveHandlesFromCanvas | Invoked when the item's selection handles should be removed. (Inherited from DiagramItem.)
RestoreState | Restores the state of this diagram item. (Inherited from DiagramItem.)
SaveState | Saves the state of this diagram item. (Inherited from DiagramItem.)
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramItem.)
StartDrag | Invoked when the user starts dragging this item. (Inherited from DiagramItem.)
UpdateDrag | Invoked while the user drags this item. (Inherited from DiagramItem.)
UpdateHandleColors | Sets the handle colors according to the current selection state of the item and the enabled bits in the EnabledHandles property. (Inherited from DiagramItem.)
UpdateHandlePositions | Invoked when the item's selection handles should change their position. (Inherited from DiagramItem.)
UpdateStates | Sets the current VisualStates of this item. (Inherited from DiagramItem.)
UpdateVisuals | Invoked when an item should update its visual elements. (Inherited from DiagramItem.)

See Also

Selection Class


MindFusion.Diagramming.Selection Constructor

Selection Constructor
[image]

Initializes a new instance of the Selection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Selection (
Diagram parent
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram _
)

Parameters

parent

See Also

Selection Class


MindFusion.Diagramming.Selection Methods

Selection Methods
[image]

Public Methods

Name | Description
AddItem | Adds a new item to the current selection.
Change | Selects an item and deselects all others.
Clear | Removes all items from the selection.
GetBounds | Gets the bounding rectangle of this item.
GetRotatedBounds | Gets the bounding rectangle of this item when it is rotated.
HitTestHandle | DiagramItem.HitTestHandle override.
RemoveItem | Removes an item from the selection.
Toggle | Toggles the selection state of an item.

Protected Methods

Name | Description
AddHandlesToCanvas | DiagramItem.AddHandlesToCanvas override.
CancelDrag | DiagramItem.CancelDrag override.
EndDrag | DiagramItem.EndDrag override.
OnRemove | DiagramItem.OnRemove override.
StartDrag | DiagramItem.StartDrag override.
UpdateDrag | DiagramItem.UpdateDrag override.
UpdateVisuals | DiagramItem.UpdateVisuals override.

Inherited Public Methods

Name | Description
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
ContainsPoint | Determines whether this item contains the specified point. (Inherited from DiagramItem.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetOutlinePoly | Gets a polygon approximating the outline of this object. (Inherited from DiagramItem.)
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow. (Inherited from DiagramItem.)
GetRotatedBounds | Gets the bounding rectangle of this item when it is rotated. (Inherited from DiagramItem.)
HitTestHandle | Determines whether a selection handle of this item is located at the specified point. (Inherited from DiagramItem.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnApplyTemplate | Control.OnApplyTemplate override. (Inherited from DiagramItem.)
RestoreLocationState | Restores the state of this diagram item. (Inherited from DiagramItem.)
SaveLocationState | Saves the state of this diagram item. (Inherited from DiagramItem.)
TransformDiagramToItem | Transforms a point in diagram coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Gets the diagram coordinates of a point specified in the local coordinate system of this item. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Inherited Protected Methods

Name | Description
AddHandlesToCanvas | Overloaded. (Inherited from DiagramItem.)
AllowDrag | Invoked to validate the drag operation. (Inherited from DiagramItem.)
CancelDrag | Invoked when the interactive modification of this object has been canceled. (Inherited from DiagramItem.)
CreateState | Creates an item state corresponding to the type of this diagram item. (Inherited from DiagramItem.)
EndDrag | Invoked when the user stops dragging this item. (Inherited from DiagramItem.)
LoadFromXml | Loads the item content from an XML element. (Inherited from DiagramItem.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnMouseEnter | Control.OnMouseEnter override. (Inherited from DiagramItem.)
OnMouseLeave | Control.OnMouseLeave override. (Inherited from DiagramItem.)
OnMouseLeftButtonDown | Control.OnMouseLeftButtonDown override. (Inherited from DiagramItem.)
OnMouseLeftButtonUp | Control.OnMouseLeftButtonUp override. (Inherited from DiagramItem.)
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
RemoveHandlesFromCanvas | Invoked when the item's selection handles should be removed. (Inherited from DiagramItem.)
RestoreState | Restores the state of this diagram item. (Inherited from DiagramItem.)
SaveState | Saves the state of this diagram item. (Inherited from DiagramItem.)
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramItem.)
StartDrag | Invoked when the user starts dragging this item. (Inherited from DiagramItem.)
UpdateDrag | Invoked while the user drags this item. (Inherited from DiagramItem.)
UpdateHandleColors | Sets the handle colors according to the current selection state of the item and the enabled bits in the EnabledHandles property. (Inherited from DiagramItem.)
UpdateHandlePositions | Invoked when the item's selection handles should change their position. (Inherited from DiagramItem.)
UpdateStates | Sets the current VisualStates of this item. (Inherited from DiagramItem.)
UpdateVisuals | Invoked when an item should update its visual elements. (Inherited from DiagramItem.)

See Also

Selection Class


MindFusion.Diagramming.Selection.AddHandlesToCanvas Method

Selection.AddHandlesToCanvas Method
[image]

DiagramItem.AddHandlesToCanvas override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void AddHandlesToCanvas ()

Visual Basic [image] Copy Code

Protected Overrides Sub AddHandlesToCanvas ()

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.AddItem Method

Selection.AddItem Method
[image]

Adds a new item to the current selection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AddItem (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Sub AddItem ( _
item As DiagramItem _
)

Parameters

item
The DiagramItem to be added to the selection.

Remarks

This method adds a new item to the selection. It also deactivates the ActiveItem, if any, and makes the newly added item the active one.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.CancelDrag Method

Selection.CancelDrag Method
[image]

DiagramItem.CancelDrag override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void CancelDrag (
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub CancelDrag( _
ist As InteractionState _
)

Parameters

ist

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.Change Method

Selection.Change Method
[image]

Selects an item and deselects all others.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Change (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Sub Change ( _
item As DiagramItem _
)

Parameters

item
The DiagramItem which should be made active.

Remarks

Call this method to select an item and make it the ActiveItem. The method doesn't let you select locked items.

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace
Toggle Method
Clear Method
AddItem Method


MindFusion.Diagramming.Selection.Clear Method

Selection.Clear Method
[image]

Removes all items from the selection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Clear ()

Visual Basic [image] Copy Code

Public Sub Clear ()

Remarks

Call Clear to deselect all items. The items are not deleted. The method also sets the diagram's ActiveItem to null (Nothing in Visual Basic).

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.EndDrag Method

Selection.EndDrag Method
[image]

DiagramItem.EndDrag override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void EndDrag (
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub EndDrag( _
ist As InteractionState _
)

Parameters

ist

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.GetBounds Method

Selection.GetBounds Method
[image]

Gets the bounding rectangle of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Rect GetBounds ()

Visual Basic [image] Copy Code

Public Overrides Function GetBounds () As Rect

Return Value

The rectangle that bounds this item.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.GetRotatedBounds Method

Selection.GetRotatedBounds Method
[image]

Gets the bounding rectangle of this item when it is rotated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Rect GetRotatedBounds ()

Visual Basic [image] Copy Code

Public Overrides Function GetRotatedBounds () As Rect

Return Value

A rectangle that bounds the rotated shape of the item.

Remarks

This method is invoked during hit-testing to do a quick test whether a point is within the item's bounds, before calling the possibly more time-consuming ContainsPoint method.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.HitTestHandle Method

Selection.HitTestHandle Method
[image]

DiagramItem.HitTestHandle override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool HitTestHandle (
Point point,
ref int handle
)

Visual Basic [image] Copy Code

Public Overrides Function HitTestHandle( _
point As Point, _
ByRef handle As Integer _
) As Boolean

Parameters

point

handle

Return Value

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.OnRemove Method

Selection.OnRemove Method
[image]

DiagramItem.OnRemove override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnRemove ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnRemove ()

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.RemoveItem Method

Selection.RemoveItem Method
[image]

Removes an item from the selection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RemoveItem (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function RemoveItem ( _
item As DiagramItem _
) As Boolean

Parameters

item
The DiagramItem to be removed from the selection.

Return Value

true if the item has been successfully removed; otherwise, false.

Remarks

Call this method to deselect an item. Note that the item is not deleted, but just removed from the selection.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.StartDrag Method

Selection.StartDrag Method
[image]

DiagramItem.StartDrag override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void StartDrag (
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overridable Sub StartDrag ( _
ist As InteractionState _
)

Parameters

ist

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.Toggle Method

Selection.Toggle Method
[image]

Toggles the selection state of an item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Toggle (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Sub Toggle ( _
item As DiagramItem _
)

Parameters

item
The DiagramItem whose selection state should be changed.

Remarks

Call this method to toggle an item's selection state. The method selects the diagram item passed as argument if previously it was deselected. If the item was selected, the method deselects it.

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace
Change Method
AddItem Method


MindFusion.Diagramming.Selection.UpdateDrag Method

Selection.UpdateDrag Method
[image]

DiagramItem.UpdateDrag override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void UpdateDrag (
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub UpdateDrag( _
ist As InteractionState _
)

Parameters

ist

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.UpdateVisuals Method

Selection.UpdateVisuals Method
[image]

DiagramItem.UpdateVisuals override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void UpdateVisuals (
bool updateEffects
)

Visual Basic [image] Copy Code

Protected Overrides Sub UpdateVisuals( _
updateEffects As Boolean _
)

Parameters

updateEffects

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection Properties

Selection Properties
[image]

Public Properties

Name | Description
AllowMultipleSelection | Gets or sets a value indicating whether more than one items can be selected simultaneously.
Items | Gets the selected diagram items.
Links | Gets a collection of all selected links.
Nodes | Gets a collection of all selected nodes.

Inherited Public Properties

Name | Description
AutoCaptureMouse | Gets or sets whether the item should capture the mouse input when the left button is pressed over it. This is a dependency property. (Inherited from DiagramItem.)
Brush | Gets or sets the Brush that specifies how to paint the interior of the item. This is a dependency property. (Inherited from DiagramItem.)
Diagram | Gets the parent diagram. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramItem.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. This is a dependency property. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IsMouseDown | Gets a value indicating whether the mouse button is pressed over this item. This is a dependency property. (Inherited from DiagramItem.)
IsMouseOver | Gets a value indicating whether the mouse pointer is located over this item. This is a dependency property. (Inherited from DiagramItem.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline nodes. This is a dependency property. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashOffset | Gets or sets a double value that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. This is a dependency property. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
ToolTip | Gets or sets the contents of the tooltip displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of the object. (Inherited from DiagramItem.)

Inherited Protected Properties

Name | Description
Size | Gets the size of this item. (Inherited from DiagramItem.)

See Also

Selection Class


MindFusion.Diagramming.Selection.AllowMultipleSelection Property

Selection.AllowMultipleSelection Property
[image]

Gets or sets a value indicating whether more than one items can be selected simultaneously.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowMultipleSelection { get; set; }

Visual Basic [image] Copy Code

Public Property AllowMultipleSelection As Boolean

Property Value

A boolean flag indicating whether multiple items can be selected simultaneously by the user.

Remarks

The property controls whether multiple items can be selected interactively. If it is disabled, multiple items can still be selected programmatically.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.Items Property

Selection.Items Property
[image]

Gets the selected diagram items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemCollection Items { get; set; }

Visual Basic [image] Copy Code

Public Property Items As DiagramItemCollection

Property Value

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.Links Property

Selection.Links Property
[image]

Gets a collection of all selected links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection Links { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Links As DiagramLinkCollection

Property Value

An instance of the DiagramLinkCollection class that represents the selected diagram items.

Remarks

You can select nodes programmatically by adding them to this collection.

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace
Items Property
Nodes Property


MindFusion.Diagramming.Selection.Nodes Property

Selection.Nodes Property
[image]

Gets a collection of all selected nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeCollection Nodes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Nodes As DiagramNodeCollection

Property Value

An instance of the DiagramNodeCollection class that represents the nodes in the selection.

Remarks

You can select nodes programmatically by adding them to this collection.

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace
Items Property
Links Property


MindFusion.Diagramming.SelectionCopy Class

SelectionCopy Class
[image]

Used internally in the implementation of copy/paste functions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class SelectionCopy

Visual Basic [image] Copy Code

Public NotInheritable Class SelectionCopy

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.SelectionCopy

See Also

SelectionCopy Members


MindFusion.Diagramming.SelectionCopy Members

SelectionCopy Members
Constructors Properties
[image]

Used internally in the implementation of copy/paste functions.

The following tables list the members exposed by the SelectionCopy type.

Public Constructors

Name | Description
SelectionCopy | Initializes a new instance of the SelectionCopy class.

Public Properties

Name | Description
Items | Gets the underlying collection of items.
OriginalItems | Gets a collection of the original items.

See Also

SelectionCopy Class


MindFusion.Diagramming.SelectionCopy Constructor

SelectionCopy Constructor
[image]

Initializes a new instance of the SelectionCopy class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SelectionCopy (
DiagramItemCollection items,
DiagramItemCollection originalItems
)

Visual Basic [image] Copy Code

Public New ( _
items As DiagramItemCollection, _
originalItems As DiagramItemCollection _
)

Parameters

items

A collection containing the item copies.

originalItems

A collection containing the original items.

Remarks

This constructor supports the FlowChart.NET infrastructure and is not intended to be used directly from your code.

See Also

SelectionCopy Class


MindFusion.Diagramming.SelectionCopy Properties

SelectionCopy Properties
[image]

Public Properties

Name | Description
Items | Gets the underlying collection of items.
OriginalItems | Gets a collection of the original items.

See Also

SelectionCopy Class


MindFusion.Diagramming.SelectionCopy.Items Property

SelectionCopy.Items Property
[image]

Gets the underlying collection of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemCollection Items { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Items As DiagramItemCollection

Property Value

See Also

SelectionCopy Members
SelectionCopy Class


MindFusion.Diagramming.SelectionCopy.OriginalItems Property

SelectionCopy.OriginalItems Property
[image]

Gets a collection of the original items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemCollection OriginalItems { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OriginalItems As DiagramItemCollection

Property Value

See Also

SelectionCopy Members
SelectionCopy Class


MindFusion.Diagramming.SelectOnlyBehavior Class

SelectOnlyBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.SelectOnly.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class SelectOnlyBehavior : BehaviorBase

Visual Basic [image] Copy Code

Public Class SelectOnlyBehavior
Inherits BehaviorBase

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction
MindFusion.Diagramming.BehaviorBase
MindFusion.Diagramming.SelectOnlyBehavior

See Also

SelectOnlyBehavior Members


MindFusion.Diagramming.SelectOnlyBehavior Members

SelectOnlyBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.SelectOnly.

The following tables list the members exposed by the SelectOnlyBehavior type.

Public Constructors

Name | Description
SelectOnlyBehavior | Initializes a new instance of the SelectOnlyBehavior class.

Inherited Protected Properties

Name | Description
Diagram | The Diagram object that is being modified. (Inherited from Interaction.)
InteractionState | Gets or sets an InteractionState instance that tracks the modification currently being done on an item. (Inherited from BehaviorBase.)
MouseDownPoint | Gets or sets the position of the mouse when its button has been pressed. (Inherited from BehaviorBase.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Protected Methods

Name | Description
StartInteraction | Invoked by the control when the user presses the left mouse button.

Inherited Public Methods

Name | Description
SetMouseCursor | Invoked while the mouse is moved to let Behavior objects set the mouse cursor depending on the context. (Inherited from BehaviorBase.)
StartDraw | Invoked when a user presses the left mouse button inside the diagram drawing area. (Inherited from BehaviorBase.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

SelectOnlyBehavior Class


MindFusion.Diagramming.SelectOnlyBehavior Constructor

SelectOnlyBehavior Constructor
[image]

Initializes a new instance of the SelectOnlyBehavior class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SelectOnlyBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram

The Diagram this behavior will be associated with.

See Also

SelectOnlyBehavior Class


MindFusion.Diagramming.SelectOnlyBehavior Methods

SelectOnlyBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Protected Methods

Name | Description
StartInteraction | Invoked by the control when the user presses the left mouse button.

Inherited Public Methods

Name | Description
SetMouseCursor | Invoked while the mouse is moved to let Behavior objects set the mouse cursor depending on the context. (Inherited from BehaviorBase.)
StartDraw | Invoked when a user presses the left mouse button inside the diagram drawing area. (Inherited from BehaviorBase.)

Inherited Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Raises the MouseMove event. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartInteraction | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

SelectOnlyBehavior Class


MindFusion.Diagramming.SelectOnlyBehavior.SetMouseCursor Method

SelectOnlyBehavior.SetMouseCursor Method
[image]

BehaviorBase.SetMouseCursor override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Cursor SetMouseCursor (
Point point,
out bool startInteraction
)

Visual Basic [image] Copy Code

Public Overrides Function SetMouseCursor( _
point As Point, _
<System.Runtime.InteropServices.Out()> ByRef startInteraction As Boolean _
) As Cursor

Parameters

point

startInteraction

Return Value

See Also

SelectOnlyBehavior Members
SelectOnlyBehavior Class


MindFusion.Diagramming.SelectOnlyBehavior.StartDraw Method

SelectOnlyBehavior.StartDraw Method
[image]

BehaviorBase.StartDraw override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override InteractionState StartDraw (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function StartDraw( _
point As Point _
) As InteractionState

Parameters

point

Return Value

See Also

SelectOnlyBehavior Members
SelectOnlyBehavior Class


MindFusion.Diagramming.SelectOnlyBehavior.StartInteraction Method

SelectOnlyBehavior.StartInteraction Method
[image]

Invoked by the control when the user presses the left mouse button.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override InteractionState StartInteraction (
Point point
)

Visual Basic [image] Copy Code

Protected Overrides Function StartInteraction( _
point As Point _
) As InteractionState

Parameters

point

Return Value

Remarks

This method is invoked first and it relies on the public StartDraw method implemented by derived behavior classes.

See Also

SelectOnlyBehavior Members
SelectOnlyBehavior Class


MindFusion.Diagramming.SerializeTagEventArgs Class

SerializeTagEventArgs Class
[image]

Contains the arguments passed to the SerializeTag and DeserializeTag event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class SerializeTagEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class SerializeTagEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.SerializeTagEventArgs

See Also

SerializeTagEventArgs Members


MindFusion.Diagramming.SerializeTagEventArgs Members

SerializeTagEventArgs Members
Properties
[image]

Contains the arguments passed to the SerializeTag and DeserializeTag event handlers.

The following tables list the members exposed by the SerializeTagEventArgs type.

Public Properties

Name | Description
Context | Gets a context object that can help you write and read various values.
Handled | Gets or sets a value indicating whether the event is handled.
Object | Gets or sets an XmlElement object where the tag should be serialized/deserialized.
PropertyName | Gets the name of the property being serialized.
Representation | Gets or sets the string representation of the tag object being serialized / deserialized.
Tag | Gets or sets the tag object being serialized/deserialized.

See Also

SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs Properties

SerializeTagEventArgs Properties
[image]

Public Properties

Name | Description
Context | Gets a context object that can help you write and read various values.
Handled | Gets or sets a value indicating whether the event is handled.
Object | Gets or sets an XmlElement object where the tag should be serialized/deserialized.
PropertyName | Gets the name of the property being serialized.
Representation | Gets or sets the string representation of the tag object being serialized / deserialized.
Tag | Gets or sets the tag object being serialized/deserialized.

See Also

SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs.Context Property

SerializeTagEventArgs.Context Property
[image]

Gets a context object that can help you write and read various values.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlPersistContext Context { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Context As XmlPersistContext

Property Value

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs.Handled Property

SerializeTagEventArgs.Handled Property
[image]

Gets or sets a value indicating whether the event is handled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Handled { get; set; }

Visual Basic [image] Copy Code

Public Property Handled As Boolean

Property Value

Remarks

Always set this flag to true if you perform custom tag serialization.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs.Object Property

SerializeTagEventArgs.Object Property
[image]

Gets or sets an XmlElement object where the tag should be serialized/deserialized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Object { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Object As Object

Property Value

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs.PropertyName Property

SerializeTagEventArgs.PropertyName Property
[image]

Gets the name of the property being serialized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string PropertyName { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PropertyName As String

Property Value

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs.Representation Property

SerializeTagEventArgs.Representation Property
[image]

Gets or sets the string representation of the tag object being serialized / deserialized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement Representation { get; set; }

Visual Basic [image] Copy Code

Public Property Representation As XElement

Property Value

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs.Tag Property

SerializeTagEventArgs.Tag Property
[image]

Gets or sets the tag object being serialized/deserialized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Diagramming.Shape Class

Shape Class
[image]

An instance of this class represents a shape defined through a series of arc, line and Bezier segments. The segments can be a part of the shape outline, in which case they define the part of the shape is filled, used for hit-testing and for aligning links to the node edges. Segments can also be added as decoration elements, in which case they only affect the appearance of a ShapeNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Shape

Visual Basic [image] Copy Code

Public Class Shape

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Shape

See Also

Shape Members


MindFusion.Diagramming.Shape Members

Shape Members
Constructors Properties Methods
[image]

An instance of this class represents a shape defined through a series of arc, line and Bezier segments. The segments can be a part of the shape outline, in which case they define the part of the shape is filled, used for hit-testing and for aligning links to the node edges. Segments can also be added as decoration elements, in which case they only affect the appearance of a ShapeNode.

The following tables list the members exposed by the Shape type.

Public Constructors

Name | Description
Shape | Overloaded.

Public Properties

Name | Description
FillRule | Gets or sets a value indicating how areas are filled if the outline pathOutline of the shape intersects itself.
Id | Gets or sets the shape identifier.
IsArrowhead | Specifies if this shape is used as arrowhead.
LinkSegmentInset | Specifies what length of link's line segment is drawn inside the arrowhead shape, expressed as percents of arrowhead size.
Outline | Gets the outline of this shape.
Shapes | Gets a read-only collection of all named shapes.
TextRectangle | Specifies the label position for this shape.

Public Methods

Name | Description
CreateOutlineGeometry | Creates a PathGeometry corresponding to the shape outline.
FromId | Returns a reference to the shape with the specified string identifier.
LoadFromXml | Loads the shape content from an XML element.
SaveToXml | Saves the shape content into an XML element.

See Also

Shape Class


MindFusion.Diagramming.Shape Constructor

Shape Constructor
[image]

Overload List

Name | Description
Shape (Byte[]) | Initializes a new instance of the Shape class with the specified outline.
Shape (Byte[], String) | Initializes a new instance of the Shape class with the specified outline and id.
Shape (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillRule) | Initializes a new instance of the Shape class with the specified outline, decorations and text area.
Shape (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillRule, String) | Initializes a new instance of the Shape class with the specified outline, decorations, text area and id.
Shape (ElementTemplate[], ElementTemplate[], FillRule, String, ShapeDecoration[]) | Initializes a new instance of the Shape class with the specified outline, decorations, text area and id.
Shape (ElementTemplate[], ElementTemplate[], Rect, FillRule) | Initializes a new instance of the Shape class with the specified outline, decorations and text area.
Shape (ElementTemplate[], ElementTemplate[], Rect, FillRule, String) | Initializes a new instance of the Shape class with the specified outline, decorations, text area and id.
Shape (ElementTemplate[], ElementTemplate[], Rect, FillRule, String, ShapeDecoration[]) | Initializes a new instance of the Shape class with the specified outline, decorations, text area and id.
Shape (ElementTemplate[], FillRule) | Initializes a new instance of the Shape class with the specified outline.
Shape (ElementTemplate[], FillRule, String) | Initializes a new instance of the Shape class with the specified outline and id.

See Also

Shape Class


MindFusion.Diagramming.Shape Constructor (Byte[])

Shape Constructor (Byte[])
See Also
[image]

Initializes a new instance of the Shape class with the specified outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
byte[] outline
)

Visual Basic [image] Copy Code

Public New ( _
outline() As Byte _
)

Parameters

outline

An array containing even number of coordinate values, which define the points of the shape outline.

Remarks

The specified array should contain even number of values. Each odd value represents the x-coordinate and each even value represents the y-coordinate of the corresponding point in the shape outline.

See Also

Shape Constructor Overload List
Shape Class


MindFusion.Diagramming.Shape Constructor (Byte[], String)

Shape Constructor (Byte[], String)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline and id.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
byte[] outline,
string id
)

Visual Basic [image] Copy Code

Public New ( _
outline() As Byte, _
id As String _
)

Parameters

outline

An array containing even number of coordinate values, which define the points of the shape outline.

id

The string identifier of the new shape.

Remarks

The specified array should contain even number of values. Each odd value represents the x-coordinate and each even value represents the y-coordinate of the corresponding point in the shape outline.

See Also

Shape Constructor Overload List
Shape Class


MindFusion.Diagramming.Shape Constructor (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillRule)

Shape Constructor (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillRule)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline, decorations and text area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
ElementTemplate[] elements,
ElementTemplate[] decorations,
ElementTemplate[] textArea,
FillRule fillRule
)

Visual Basic [image] Copy Code

Public New ( _
elements() As ElementTemplate, _
decorations() As ElementTemplate, _
textArea() As ElementTemplate, _
fillRule As FillRule _
)

Parameters

elements

An array of shape template elements that define the outline of a shape. Can contain lines, arcs and Bézier curves.

decorations

An array of shape template elements that define shape decorations. Can contain lines, arcs and Bézier curves. Decorations are visual elements that do not take part in hit testing and clipping.

textArea

An array of shape template elements that define the region of a node in which text is laid out and rendered. Can contain lines, arcs and Bézier curves. Latter two are approximated to polygons by the text-formatting algorithm.

fillRule

Specifies how areas are filled if the outline pathOutline intersects itself.

See Also

Shape Constructor Overload List
Shape Class


MindFusion.Diagramming.Shape Constructor (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillRule, String)

Shape Constructor (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillRule, String)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline, decorations, text area and id.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
ElementTemplate[] elements,
ElementTemplate[] decorations,
ElementTemplate[] textArea,
FillRule fillRule,
string id
)

Visual Basic [image] Copy Code

Public New ( _
elements() As ElementTemplate, _
decorations() As ElementTemplate, _
textArea() As ElementTemplate, _
fillRule As FillRule, _
id As String _
)

Parameters

elements

An array of shape template elements that define the outline of a shape. Can contain lines, arcs and Bézier curves.

decorations

An array of shape template elements that define shape decorations. Can contain lines, arcs and Bézier curves. Decorations are visual elements that do not take part in hit testing and clipping.

textArea

An array of shape template elements that define the region of a node in which text is laid out and rendered. Can contain lines, arcs and Bézier curves. Latter two are approximated to polygons by the text-formatting algorithm.

fillRule

Specifies how areas are filled if the outline pathOutline intersects itself.

id

The string identifier of the new shape.

See Also

Shape Constructor Overload List
Shape Class


MindFusion.Diagramming.Shape Constructor (ElementTemplate[], ElementTemplate[], FillRule, String, ShapeDecoration[])

Shape Constructor (ElementTemplate[], ElementTemplate[], FillRule, String, ShapeDecoration[])
See Also
[image]

Initializes a new instance of the Shape class with the specified outline, decorations, text area and id.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
ElementTemplate[] elements,
ElementTemplate[] decorations,
FillRule fillRule,
string id,
ShapeDecoration[] closedDecorations
)

Visual Basic [image] Copy Code

Public New ( _
elements() As ElementTemplate, _
decorations() As ElementTemplate, _
fillRule As FillRule, _
id As String, _
closedDecorations() As ShapeDecoration _
)

Parameters

elements

An array of shape template elements that define the outline of a shape. Can contain lines, arcs and Bézier curves.

decorations

An array of shape template elements that define shape decorations. Can contain lines, arcs and Bézier curves. Decorations are visual elements that do not take part in hit testing and clipping.

fillRule

Specifies how areas are filled if the outline pathOutline intersects itself.

id

The string identifier of the new shape.

closedDecorations

An array of shape decoration objects that define regions of closed decoration shapes. Those shapes are drawn over the decoration elements.

See Also

Shape Constructor Overload List
Shape Class


MindFusion.Diagramming.Shape Constructor (ElementTemplate[], ElementTemplate[], Rect, FillRule)

Shape Constructor (ElementTemplate[], ElementTemplate[], Rect, FillRule)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline, decorations and text area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
ElementTemplate[] elements,
ElementTemplate[] decorations,
Rect textRectangle,
FillRule fillRule
)

Visual Basic [image] Copy Code

Public New ( _
elements() As ElementTemplate, _
decorations() As ElementTemplate, _
textRectangle As Rect, _
fillRule As FillRule _
)

Parameters

elements

An array of shape template elements that define the outline of a shape. Can contain lines, arcs and Bézier curves.

decorations

An array of shape template elements that define shape decorations. Can contain lines, arcs and Bézier curves. Decorations are visual elements that do not take part in hit testing and clipping.

textRectangle

Rectangle that define the region of a node in which text is laid out and rendered.

fillRule

Specifies how areas are filled if the outline pathOutline intersects itself.

See Also

Shape Constructor Overload List
Shape Class


MindFusion.Diagramming.Shape Constructor (ElementTemplate[], ElementTemplate[], Rect, FillRule, String)

Shape Constructor (ElementTemplate[], ElementTemplate[], Rect, FillRule, String)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline, decorations, text area and id.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
ElementTemplate[] elements,
ElementTemplate[] decorations,
Rect textRectangle,
FillRule fillRule,
string id
)

Visual Basic [image] Copy Code

Public New ( _
elements() As ElementTemplate, _
decorations() As ElementTemplate, _
textRectangle As Rect, _
fillRule As FillRule, _
id As String _
)

Parameters

elements

An array of shape template elements that define the outline of a shape. Can contain lines, arcs and Bézier curves.

decorations

An array of shape template elements that define shape decorations. Can contain lines, arcs and Bézier curves. Decorations are visual elements that do not take part in hit testing and clipping.

textRectangle

An array of shape template elements that define the region of a node in which text is laid out and rendered. Can contain lines, arcs and Bézier curves. Latter two are approximated to polygons by the text-formatting algorithm.

fillRule

Specifies how areas are filled if the outline pathOutline intersects itself.

id

The string identifier of the new shape.

See Also

Shape Constructor Overload List
Shape Class


MindFusion.Diagramming.Shape Constructor (ElementTemplate[], ElementTemplate[], Rect, FillRule, String, ShapeDecoration[])

Shape Constructor (ElementTemplate[], ElementTemplate[], Rect, FillRule, String, ShapeDecoration[])
See Also
[image]

Initializes a new instance of the Shape class with the specified outline, decorations, text area and id.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
ElementTemplate[] elements,
ElementTemplate[] decorations,
Rect textRectangle,
FillRule fillRule,
string id,
ShapeDecoration[] closedDecorations
)

Visual Basic [image] Copy Code

Public New ( _
elements() As ElementTemplate, _
decorations() As ElementTemplate, _
textRectangle As Rect, _
fillRule As FillRule, _
id As String, _
closedDecorations() As ShapeDecoration _
)

Parameters

elements

An array of shape template elements that define the outline of a shape. Can contain lines, arcs and Bézier curves.

decorations

An array of shape template elements that define shape decorations. Can contain lines, arcs and Bézier curves. Decorations are visual elements that do not take part in hit testing and clipping.

textRectangle

An array of shape template elements that define the region of a node in which text is laid out and rendered. Can contain lines, arcs and Bézier curves. Latter two are approximated to polygons by the text-formatting algorithm.

fillRule

Specifies how areas are filled if the outline pathOutline intersects itself.

id

The string identifier of the new shape.

closedDecorations

An array of shape decoration objects that define regions of closed decoration shapes from template elements. Those objects have own brush, pen and fill rule. Those shapes are drawn over the decoration elements.

See Also

Shape Constructor Overload List
Shape Class


MindFusion.Diagramming.Shape Constructor (ElementTemplate[], FillRule)

Shape Constructor (ElementTemplate[], FillRule)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
ElementTemplate[] elements,
FillRule fillRule
)

Visual Basic [image] Copy Code

Public New ( _
elements() As ElementTemplate, _
fillRule As FillRule _
)

Parameters

elements

An array of shape template elements that define the outline of a shape. Can contain lines, arcs and Bézier curves.

fillRule

Specifies how areas are filled if the outline pathOutline intersects itself.

See Also

Shape Constructor Overload List
Shape Class


MindFusion.Diagramming.Shape Constructor (ElementTemplate[], FillRule, String)

Shape Constructor (ElementTemplate[], FillRule, String)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline and id.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
ElementTemplate[] elements,
FillRule fillRule,
string id
)

Visual Basic [image] Copy Code

Public New ( _
elements() As ElementTemplate, _
fillRule As FillRule, _
id As String _
)

Parameters

elements

Refers to an array of shape template elements that define the outline of a shape. Can contain lines, arcs and Bézier curves.

fillRule

Specifies how areas are filled if the outline pathOutline intersects itself.

id

The string identifier of the new shape.

See Also

Shape Constructor Overload List
Shape Class


MindFusion.Diagramming.Shape Methods

Shape Methods
[image]

Public Methods

Name | Description
CreateOutlineGeometry | Creates a PathGeometry corresponding to the shape outline.
FromId | Returns a reference to the shape with the specified string identifier.
LoadFromXml | Loads the shape content from an XML element.
SaveToXml | Saves the shape content into an XML element.

See Also

Shape Class


MindFusion.Diagramming.Shape.CreateOutlineGeometry Method

Shape.CreateOutlineGeometry Method
[image]

Creates a PathGeometry corresponding to the shape outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PathGeometry CreateOutlineGeometry (
double w,
double h,
GraphicsUnit unit
)

Visual Basic [image] Copy Code

Public Function CreateOutlineGeometry( _
w As Double, _
h As Double, _
unit As GraphicsUnit _
) As PathGeometry

Parameters

w

Specifies the shape's width.

h

Specifies the shape's height.

unit

The current measure unit.

Return Value

A PathGeometry instance.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.FromId Method

Shape.FromId Method
[image]

Returns a reference to the shape with the specified string identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape FromId (
string id
)

Visual Basic [image] Copy Code

Public Shared Function FromId( _
id As String _
) As Shape

Parameters

id

The identifier of the shape of interest.

Return Value

A reference to the Shape with the specified identifier or a null reference (Nothing in Visual Basic) if there is no such shape.

Remarks

The id argument should match an identifier passed to a constructor of the existing shape templates.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.LoadFromXml Method

Shape.LoadFromXml Method
[image]

Loads the shape content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml ( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
The XElement containing the shape's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.SaveToXml Method

Shape.SaveToXml Method
[image]

Saves the shape content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub SaveToXml ( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
The XElement the shape's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape Properties

Shape Properties
[image]

Public Properties

Name | Description
FillRule | Gets or sets a value indicating how areas are filled if the outline pathOutline of the shape intersects itself.
Id | Gets or sets the shape identifier.
IsArrowhead | Specifies if this shape is used as arrowhead.
LinkSegmentInset | Specifies what length of link's line segment is drawn inside the arrowhead shape, expressed as percents of arrowhead size.
Outline | Gets the outline of this shape.
Shapes | Gets a read-only collection of all named shapes.
TextRectangle | Specifies the label position for this shape.

See Also

Shape Class


MindFusion.Diagramming.Shape.FillRule Property

Shape.FillRule Property
[image]

Gets or sets a value indicating how areas are filled if the outline pathOutline of the shape intersects itself.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FillRule FillRule { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property FillRule As FillRule

Property Value

A member of the Windows.UI.Xaml.Media.FillRule enumeration.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.Id Property

Shape.Id Property
[image]

Gets or sets the shape identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Id { get; set; }

Visual Basic [image] Copy Code

Public Property Id As String

Property Value

Remarks

Once assigned through the constructor, the shape identifier should not be changed, that is, do not use the set accessor of this property.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.IsArrowhead Property

Shape.IsArrowhead Property
[image]

Specifies if this shape is used as arrowhead.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsArrowhead { get; set; }

Visual Basic [image] Copy Code

Public Property IsArrowhead As Boolean

Property Value

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.LinkSegmentInset Property

Shape.LinkSegmentInset Property
[image]

Specifies what length of link's line segment is drawn inside the arrowhead shape, expressed as percents of arrowhead size.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float LinkSegmentInset { get; set; }

Visual Basic [image] Copy Code

Public Property LinkSegmentInset As Single

Property Value

A float value specifying percents of arrowhead size. The default value is 100.

Remarks

The inset value matters when using transparent or semi-transparent arrowhead brush, or when the link's StrokeThickness is bigger than one pixel and its cap might extend beyond the arrowhead outline. LinkSegmentInset is set to appropriate values for all shapes from the ArrowHeads class. You might want to set it when using custom arrowhead shapes for which the link's end segment should not reach all the way to the arrowhead tip.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.Outline Property

Shape.Outline Property
[image]

Gets the outline of this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ElementTemplate[] Outline { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Outline As ElementTemplate()

Property Value

An array of ElementTemplate objects that define the shape outline.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.Shapes Property

Shape.Shapes Property
[image]

Gets a read-only collection of all named shapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Dictionary<string, Shape> Shapes { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Shapes As Dictionary(Of String, Shape)

Property Value

A System.Collections.Generic.Dictionary object.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.TextRectangle Property

Shape.TextRectangle Property
[image]

Specifies the label position for this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect TextRectangle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TextRectangle As Rect

Property Value

An instance of the Rect class, specifying the label position as percents of the node width and height.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.ShapeConverter Class

ShapeConverter Class
Remarks See Also
[image]

Converts from Shape to other data types.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ShapeConverter : TypeConverter

Visual Basic [image] Copy Code

Public Class ShapeConverter
Inherits TypeConverter

Remarks

This converter allows referring to predefined shapes by their IDs from XAML.

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
MindFusion.Diagramming.ShapeConverter

See Also

ShapeConverter Members


MindFusion.Diagramming.ShapeConverter Members

ShapeConverter Members
Constructors Methods
[image]

Converts from Shape to other data types.

The following tables list the members exposed by the ShapeConverter type.

Public Constructors

Name | Description
ShapeConverter |

Public Methods

Name | Description
CanConvertFrom | TypeConverter.CanConvertFrom override.
CanConvertTo | TypeConverter.CanConvertTo override.
ConvertFrom | TypeConverter.ConvertFrom override.
ConvertTo | TypeConverter.ConvertTo override.

See Also

ShapeConverter Class


MindFusion.Diagramming.ShapeConverter Constructor

ShapeConverter Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ShapeConverter Class


MindFusion.Diagramming.ShapeConverter Methods

ShapeConverter Methods
[image]

Public Methods

Name | Description
CanConvertFrom | TypeConverter.CanConvertFrom override.
CanConvertTo | TypeConverter.CanConvertTo override.
ConvertFrom | TypeConverter.ConvertFrom override.
ConvertTo | TypeConverter.ConvertTo override.

See Also

ShapeConverter Class


MindFusion.Diagramming.ShapeConverter.CanConvertFrom Method

ShapeConverter.CanConvertFrom Method
[image]

TypeConverter.CanConvertFrom override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool CanConvertFrom (
ITypeDescriptorContext context,
Type sourceType
)

Visual Basic [image] Copy Code

Public Overrides Function CanConvertFrom( _
context As ITypeDescriptorContext, _
sourceType As Type _
) As Boolean

Parameters

context

sourceType

Return Value

See Also

ShapeConverter Members
ShapeConverter Class


MindFusion.Diagramming.ShapeConverter.CanConvertTo Method

ShapeConverter.CanConvertTo Method
[image]

TypeConverter.CanConvertTo override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool CanConvertTo (
ITypeDescriptorContext context,
Type destinationType
)

Visual Basic [image] Copy Code

Public Overrides Function CanConvertTo( _
context As ITypeDescriptorContext, _
destinationType As Type _
) As Boolean

Parameters

context

destinationType

Return Value

See Also

ShapeConverter Members
ShapeConverter Class


MindFusion.Diagramming.ShapeConverter.ConvertFrom Method

ShapeConverter.ConvertFrom Method
[image]

TypeConverter.ConvertFrom override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Object ConvertFrom (
ITypeDescriptorContext context,
CultureInfo culture,
Object value
)

Visual Basic [image] Copy Code

Public Overrides Function ConvertFrom( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object _
) As Object

Parameters

context

culture

value

Return Value

See Also

ShapeConverter Members
ShapeConverter Class


MindFusion.Diagramming.ShapeConverter.ConvertTo Method

ShapeConverter.ConvertTo Method
[image]

TypeConverter.ConvertTo override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Object ConvertTo (
ITypeDescriptorContext context,
CultureInfo culture,
Object value,
Type destinationType
)

Visual Basic [image] Copy Code

Public Overrides Function ConvertTo( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object, _
destinationType As Type _
) As Object

Parameters

context

culture

value

destinationType

Return Value

See Also

ShapeConverter Members
ShapeConverter Class


MindFusion.Diagramming.ShapeDecoration Class

ShapeDecoration Class
[image]

That class contained an array of shape template elements that define shape decorations. Can contain lines, arcs and Bézier curves. The shape is closed and filled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ShapeDecoration

Visual Basic [image] Copy Code

Public Class ShapeDecoration

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ShapeDecoration

See Also

ShapeDecoration Members


MindFusion.Diagramming.ShapeDecoration Members

ShapeDecoration Members
Constructors Properties Methods
[image]

That class contained an array of shape template elements that define shape decorations. Can contain lines, arcs and Bézier curves. The shape is closed and filled.

The following tables list the members exposed by the ShapeDecoration type.

Public Constructors

Name | Description
ShapeDecoration | Initializes a new instance of the ShapeDecoration class with the specified outline, brush, pen and rule.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of this shape.
FillRule | Gets or sets a value indicating how areas are filled if the outline pathOutline of the shape intersects itself.
Pen | Gets or sets the pen used to paint the frame of the shape.

Public Methods

Name | Description
LoadFromXml | Loads the ShapeDecoration definition from an XML document.
SaveToXml | Saves the ShapeDecoration definition in an XML document.

See Also

ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration Constructor

ShapeDecoration Constructor
[image]

Initializes a new instance of the ShapeDecoration class with the specified outline, brush, pen and rule.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeDecoration (
ElementTemplate[] elements,
Brush brush,
FillRule rule,
Pen pen
)

Visual Basic [image] Copy Code

Public New ( _
elements() As ElementTemplate, _
brush As Brush, _
rule As FillRule, _
pen As Pen _
)

Parameters

elements

An array of shape template elements that define shape decoration.

brush

Used to fill the interior of the shape.

rule

Specifies how areas are filled if the outline pathOutline intersects itself.

pen

Used to paint the frame of the shape.

See Also

ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration Methods

ShapeDecoration Methods
[image]

Public Methods

Name | Description
LoadFromXml | Loads the ShapeDecoration definition from an XML document.
SaveToXml | Saves the ShapeDecoration definition in an XML document.

See Also

ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration.LoadFromXml Method

ShapeDecoration.LoadFromXml Method
[image]

Loads the ShapeDecoration definition from an XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml ( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
The parent XElement object.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ShapeDecoration Members
ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration.SaveToXml Method

ShapeDecoration.SaveToXml Method
[image]

Saves the ShapeDecoration definition in an XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub SaveToXml ( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
The parent XElement object.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ShapeDecoration Members
ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration Properties

ShapeDecoration Properties
[image]

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of this shape.
FillRule | Gets or sets a value indicating how areas are filled if the outline pathOutline of the shape intersects itself.
Pen | Gets or sets the pen used to paint the frame of the shape.

See Also

ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration.Brush Property

ShapeDecoration.Brush Property
[image]

Gets or sets the brush used to fill the interior of this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

See Also

ShapeDecoration Members
ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration.FillRule Property

ShapeDecoration.FillRule Property
[image]

Gets or sets a value indicating how areas are filled if the outline pathOutline of the shape intersects itself.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FillRule FillRule { get; set; }

Visual Basic [image] Copy Code

Public Property FillRule As FillRule

Property Value

See Also

ShapeDecoration Members
ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration.Pen Property

ShapeDecoration.Pen Property
[image]

Gets or sets the pen used to paint the frame of the shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen Pen { get; set; }

Visual Basic [image] Copy Code

Public Property Pen As Pen

Property Value

See Also

ShapeDecoration Members
ShapeDecoration Class


MindFusion.Diagramming.ShapeLibrary Class

ShapeLibrary Class
[image]

The ShapeLibrary class represents a collection of Shape definitions stored together.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ShapeLibrary

Visual Basic [image] Copy Code

Public Class ShapeLibrary

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ShapeLibrary

See Also

ShapeLibrary Members


MindFusion.Diagramming.ShapeLibrary Members

ShapeLibrary Members
Constructors Properties Methods
[image]

The ShapeLibrary class represents a collection of Shape definitions stored together.

The following tables list the members exposed by the ShapeLibrary type.

Public Constructors

Name | Description
ShapeLibrary | Overloaded.

Public Properties

Name | Description
Shapes | Gets or sets the list with all shapes contained in the library.

Public Methods

Name | Description
LoadFrom | Loads a shape library from the specified file.
LoadFromXml | Overloaded.
SaveToXml | Overloaded.

See Also

ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary Constructor

ShapeLibrary Constructor
[image]

Overload List

Name | Description
ShapeLibrary () | Initializes a new empty instance of the ShapeLibrary class.
ShapeLibrary (Shape[]) | Initializes a new instance of the ShapeLibrary class.

See Also

ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary Constructor ()

ShapeLibrary Constructor ()
See Also
[image]

Initializes a new empty instance of the ShapeLibrary class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeLibrary ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ShapeLibrary Constructor Overload List
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary Constructor (Shape[])

ShapeLibrary Constructor (Shape[])
See Also
[image]

Initializes a new instance of the ShapeLibrary class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeLibrary (
Shape[] shapes
)

Visual Basic [image] Copy Code

Public New ( _
shapes() As Shape _
)

Parameters

shapes

An array of Shape object to initialize the libarary with.

See Also

ShapeLibrary Constructor Overload List
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary Methods

ShapeLibrary Methods
[image]

Public Methods

Name | Description
LoadFrom | Loads a shape library from the specified file.
LoadFromXml | Overloaded.
SaveToXml | Overloaded.

See Also

ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.LoadFrom Method

ShapeLibrary.LoadFrom Method
[image]

Loads a shape library from the specified file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static ShapeLibrary LoadFrom (
string fileName
)

Visual Basic [image] Copy Code

Public Shared Function LoadFrom( _
fileName As String _
) As ShapeLibrary

Parameters

fileName

The name of the file that contains the shape library.

Return Value

An instance of the ShapeLibrary class whose Shapes array contains the loaded shape definitions.

See Also

ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.LoadFromXml Method

ShapeLibrary.LoadFromXml Method
[image]

Overload List

Name | Description
ShapeLibrary.LoadFromXml (String) | Loads this library from the specified file.
ShapeLibrary.LoadFromXml (XDocument) | Loads the shape library from the specified XML document.
ShapeLibrary.LoadFromXml (XDocument, String) | Loads the library from the specified XML document. All locations of images associated with shapes in the library are loaded relative to the specified library path.

See Also

ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.LoadFromXml Method (String)

ShapeLibrary.LoadFromXml Method (String)
See Also
[image]

Loads this library from the specified file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
fileName As String _
)

Parameters

fileName

The name of the file from which to load the shape library.

See Also

LoadFromXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.LoadFromXml Method (XDocument)

ShapeLibrary.LoadFromXml Method (XDocument)
See Also
[image]

Loads the shape library from the specified XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
XDocument document
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
document As XDocument _
)

Parameters

document

The document to load the library from.

See Also

LoadFromXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.LoadFromXml Method (XDocument, String)

ShapeLibrary.LoadFromXml Method (XDocument, String)
See Also
[image]

Loads the library from the specified XML document. All locations of images associated with shapes in the library are loaded relative to the specified library path.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
XDocument document,
string libraryPath
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
document As XDocument, _
libraryPath As String _
)

Parameters

document

libraryPath

Remarks

If the path is an empty string or null, image locations are loaded relative to the BaseURI of the specified document.

See Also

LoadFromXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.SaveToXml Method

ShapeLibrary.SaveToXml Method
[image]

Overload List

Name | Description
ShapeLibrary.SaveToXml (Stream) | Saves this library to the specified stream.
ShapeLibrary.SaveToXml (String) | Saves this library to the specified file.
ShapeLibrary.SaveToXml (XDocument) | Saves the shape library into the specified XML document. All locations of images associated with shapes in the library are saved relative to the specified destination path.

See Also

ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.SaveToXml Method (Stream)

ShapeLibrary.SaveToXml Method (Stream)
See Also
[image]

Saves this library to the specified stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
Stream s
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
s As Stream _
)

Parameters

s

The Stream this library should be saved to.

See Also

SaveToXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.SaveToXml Method (String)

ShapeLibrary.SaveToXml Method (String)
See Also
[image]

Saves this library to the specified file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
fileName As String _
)

Parameters

fileName

The name of the file where to save the shape library.

See Also

SaveToXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.SaveToXml Method (XDocument)

ShapeLibrary.SaveToXml Method (XDocument)
See Also
[image]

Saves the shape library into the specified XML document. All locations of images associated with shapes in the library are saved relative to the specified destination path.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
XDocument document
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
document As XDocument _
)

Parameters

document

Remarks

If the path is an empty string or null, image locations are written as absolute.

See Also

SaveToXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary Properties

ShapeLibrary Properties
[image]

Public Properties

Name | Description
Shapes | Gets or sets the list with all shapes contained in the library.

See Also

ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.Shapes Property

ShapeLibrary.Shapes Property
[image]

Gets or sets the list with all shapes contained in the library.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape[] Shapes { get; set; }

Visual Basic [image] Copy Code

Public Property Shapes As Shape()

Property Value

See Also

ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeNode Class

ShapeNode Class
Remarks See Also
[image]

ShapeNode instances are diagram nodes that represent geometric shapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ShapeNode : DiagramNode, InplaceEditable

Visual Basic [image] Copy Code

Public Class ShapeNode
Inherits DiagramNode
Implements InplaceEditable

Remarks

A ShapeNode instance might represent nodes in graphs, tree, process diagrams, and so on. The shape of a node is specified by the Shape property. Shapes can be rotated, either interactively using the rotation handle above the node, or programmatically using the RotationAngle property. Shape nodes can display images and text. Set an image to be painted inside a node by assigning it to the Image property. The position of the image within the node as well as its alignment are set by the ImageAlign property. To make a node as big as its image, call ResizeToFitImage.

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
Windows.UI.Xaml.Controls.ContentControl
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.ShapeNode
MindFusion.Diagramming.ContainerNode

See Also

ShapeNode Members


MindFusion.Diagramming.ShapeNode Members

ShapeNode Members
Constructors Fields Properties Methods
[image]

ShapeNode instances are diagram nodes that represent geometric shapes.

The following tables list the members exposed by the ShapeNode type.

Public Constructors

Name | Description
ShapeNode | Overloaded.

Public Fields

Name | Description
DecorationsContainerProperty | Identifies the DecorationsContainer dependency property.
HorizontalImageAlignmentProperty | Identifies the HorizontalImageAlignment dependency property.
HorizontalTextBlockAlignmentProperty | Identifies the HorizontalTextBlockAlignment dependency property.
ImageProperty | Identifies the Image dependency property.
ImageStretchProperty | Identifies the ImageStretch dependency property.
ShapeGeometryProperty | Identifies the ShapeGeometry dependency property.
ShapeProperty | Identifies the Shape dependency property.
ShapeVisibilityProperty | Identifies the ShapeVisibility dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property.
TextHeightProperty | Identifies the TextHeight dependency property.
TextMarginProperty | Identifies the TextMargin dependency property.
TextProperty | Identifies the Text dependency property.
TextWidthProperty | Identifies the TextWidth dependency property.
TextWrappingProperty | Identifies the TextWrapping dependency property.
TransparentProperty | Identifies the Transparent dependency property.
VerticalImageAlignmentProperty | Identifies the VerticalImageAlignment dependency property.
VerticalTextBlockAlignmentProperty | Identifies the VerticalTextBlockAlignment dependency property.

Inherited Public Fields

Name | Description
AutoCaptureMouseProperty | Identifies the AutoCaptureMouse dependency property. (Inherited from DiagramItem.)
BoundsProperty | Identifies the Bounds dependency property. (Inherited from DiagramNode.)
BrushProperty | Identifies the Brush dependency property. (Inherited from DiagramItem.)
EffectsSourceProperty | Identifies the EffectsSource dependency property. (Inherited from DiagramNode.)
HyperLinkProperty | Identifies the HyperLink dependency property. (Inherited from DiagramItem.)
IsMouseDownProperty | Identifies the IsMouseDown dependency property. (Inherited from DiagramItem.)
IsMouseOverProperty | Identifies the IsMouseOver dependency property. (Inherited from DiagramItem.)
MasterNodeProperty | Identifies the MasterNode dependency property. (Inherited from DiagramNode.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from DiagramNode.)
ShapeOpacityProperty | Identifies the ShapeOpacity dependency property. (Inherited from DiagramNode.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from DiagramItem.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)

Inherited Protected Fields

Name | Description
handles | A list of the Rectangle objects that represent the item's adjustment handles. (Inherited from DiagramItem.)

Public Properties

Name | Description
DecorationsContainer | Gets a Grid that contains the ShapeNode decoration elements.
HorizontalImageAlignment | Gets or sets the horizontal alignment of the ShapeNode's image.
HorizontalTextBlockAlignment | Gets or sets the horizontal alignment of the TextBlock used to display the ShapeNode text relative to its container Grid.
Image | Gets or sets the image that is displayed in this shape node. This is a dependency property.
ImageAlign | Gets or sets the alignment of the image displayed in this shape node.
ImageResourceLocation | Gets or sets the resource path to an image that should be displayed in this ShapeNode.
ImageStretch | Gets or sets a value that describes how the ShapeNode's image should be stretched to fill the destination rectangle.
ImageWebLocation | Gets or sets the URL of the image displayed in this ShapeNode.
Shape | Gets or sets a reference to the node's geometric shape definition.
ShapeGeometry | Gets a Geometry object that represents the ShapeNode outline and is automatically generated from the current Shape and Bounds values.
ShapeVisibility | For internal use.
Text | Gets or sets the text displayed inside the shape node. This is a dependency property.
TextAlignment | Gets or sets how the text should be aligned in the ShapeNode's text box.
TextFormat | Gets or sets the alignment of the text that is displayed inside shape nodes.
TextHeight | Gets or sets the height of the ShapeNode text area.
TextMargin | Gets or sets the offset of the ShapeNode text area from the origin of its container Grid.
TextWidth | Gets or sets the width of the ShapeNode text area.
TextWrapping | Gets or sets whether text wraps when it extends beyond the available width of the node. This is a dependency property.
Transparent | Gets or sets a value indicating whether this shape node is transparent. This is a dependency property.
VerticalImageAlignment | Gets or sets the vertical alignment of the ShapeNode's image.
VerticalTextBlockAlignment | Gets or sets the vertical alignment of the TextBlock used to display the ShapeNode text relative to its container Grid.

Inherited Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
AttachedNodes | Returns the nodes attached to this node. (Inherited from DiagramNode.)
AutoCaptureMouse | Gets or sets whether the item should capture the mouse input when the left button is pressed over it. This is a dependency property. (Inherited from DiagramItem.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. This is a dependency property. (Inherited from DiagramNode.)
Brush | Gets or sets the Brush that specifies how to paint the interior of the item. This is a dependency property. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Container | Gets the ContainerNode that contains this node. (Inherited from DiagramNode.)
Diagram | Gets the parent diagram. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramItem.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. This is a dependency property. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
IsMouseDown | Gets a value indicating whether the mouse button is pressed over this item. This is a dependency property. (Inherited from DiagramItem.)
IsMouseOver | Gets a value indicating whether the mouse pointer is located over this item. This is a dependency property. (Inherited from DiagramItem.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterNode | Gets the node to which this node is attached. This is a dependency property. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
RotationAngle | Gets or sets the angle at which this node is rotated. This is a dependency property. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShapeOpacity | Gets or sets the shape opacity of this node. This is a dependency property. (Inherited from DiagramNode.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline nodes. This is a dependency property. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashOffset | Gets or sets a double value that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. This is a dependency property. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
ToolTip | Gets or sets the contents of the tooltip displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of the object. (Inherited from DiagramItem.)

Inherited Protected Properties

Name | Description
Size | Gets the size of this item. (Inherited from DiagramItem.)

Public Methods

Name | Description
GetOutlinePoly | DiagramNode.GetOutlinePoly override.
ResizeToFitImage | Makes the shape node as big as the image it displays.
ResizeToFitText | Makes the shape node big enough to display its text without clipping.

Protected Methods

Name | Description
CreateState | DiagramItem.CreateState override.
GetOutline | DiagramNode.GetOutline override.
LoadFromXml | Loads the item content from an XML element.
RestoreState | DiagramItem.RestoreState override.
SaveState | DiagramItem.SaveState override.
SaveToXml | Saves the item content into an XML element.
UpdateVisuals | DiagramNode.UpdateVisuals override.

Inherited Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
Attach | Attaches the specified subordinate node to this node, so that when this node is moved, the subordinate follows it. (Inherited from DiagramNode.)
AttachTo | Attaches this node to the specified master node so that when the master is moved, the attached node follows it. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
ContainsPoint | DiagramItem.ContainsPoint override. (Inherited from DiagramNode.)
Detach | Overloaded. (Inherited from DiagramNode.)
GetAllIncomingLinks | Gets a collection of all links entering this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Get a collection of all links going out of this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from DiagramNode.)
OnBoundsChanged | Called when the location and size of this node change. (Inherited from DiagramNode.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RestoreLocationState | DiagramItem.RestoreLocationState override. (Inherited from DiagramNode.)
SaveLocationState | DiagramItem.SaveLocationState override. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point in diagram coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Gets the diagram coordinates of a point specified in the local coordinate system of this item. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Inherited Protected Methods

Name | Description
AddAnchorPointVisuals | Adds the AnchorPatern points to the node's Adorner. (Inherited from DiagramNode.)
AddExpandButton | Adds the ExpandButton to the node's Adoner. (Inherited from DiagramNode.)
AddHandlesToCanvas | Overloaded. (Inherited from DiagramNode.)
AllowDrag | Invoked to validate the drag operation. (Inherited from DiagramItem.)
CancelDrag | DiagramItem.CancelDrag override. (Inherited from DiagramNode.)
CreateAnchorPointVisual | Creates a Path that represents the specified AnchorPoint. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
EndDrag | DiagramItem.EndDrag override. (Inherited from DiagramNode.)
GetOutline | Creates a Geometry object that describes the outline of the node. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
LoadFromXml | DiagramItem.LoadFromXml override. (Inherited from DiagramNode.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramNode.)
OnMouseEnter | Control.OnMouseEnter override. (Inherited from DiagramItem.)
OnMouseLeave | Control.OnMouseLeave override. (Inherited from DiagramItem.)
OnMouseLeftButtonDown | Control.OnMouseLeftButtonDown override. (Inherited from DiagramItem.)
OnMouseLeftButtonUp | Control.OnMouseLeftButtonUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
RemoveAnchorPointVisuals | Removes the AnchorPatern points from the node's Adorner. (Inherited from DiagramNode.)
RemoveHandlesFromCanvas | Invoked when the item's selection handles should be removed. (Inherited from DiagramItem.)
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramNode.)
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
StartDrag | DiagramItem.StartDrag override. (Inherited from DiagramNode.)
UpdateDrag | DiagramItem.UpdateDrag override. (Inherited from DiagramNode.)
UpdateHandleColors | Sets the handle colors according to the current selection state of the item and the enabled bits in the EnabledHandles property. (Inherited from DiagramItem.)
UpdateHandlePositions | Invoked when the item's selection handles should change their position. (Inherited from DiagramItem.)
UpdateStates | Sets the current VisualStates of this item. (Inherited from DiagramItem.)
UpdateVisuals | DiagramItem.UpdateVisuals override. (Inherited from DiagramNode.)

See Also

ShapeNode Class


MindFusion.Diagramming.ShapeNode Fields

ShapeNode Fields
[image]

Public Fields

Name | Description
DecorationsContainerProperty | Identifies the DecorationsContainer dependency property.
HorizontalImageAlignmentProperty | Identifies the HorizontalImageAlignment dependency property.
HorizontalTextBlockAlignmentProperty | Identifies the HorizontalTextBlockAlignment dependency property.
ImageProperty | Identifies the Image dependency property.
ImageStretchProperty | Identifies the ImageStretch dependency property.
ShapeGeometryProperty | Identifies the ShapeGeometry dependency property.
ShapeProperty | Identifies the Shape dependency property.
ShapeVisibilityProperty | Identifies the ShapeVisibility dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property.
TextHeightProperty | Identifies the TextHeight dependency property.
TextMarginProperty | Identifies the TextMargin dependency property.
TextProperty | Identifies the Text dependency property.
TextWidthProperty | Identifies the TextWidth dependency property.
TextWrappingProperty | Identifies the TextWrapping dependency property.
TransparentProperty | Identifies the Transparent dependency property.
VerticalImageAlignmentProperty | Identifies the VerticalImageAlignment dependency property.
VerticalTextBlockAlignmentProperty | Identifies the VerticalTextBlockAlignment dependency property.

Inherited Public Fields

Name | Description
AutoCaptureMouseProperty | Identifies the AutoCaptureMouse dependency property. (Inherited from DiagramItem.)
BoundsProperty | Identifies the Bounds dependency property. (Inherited from DiagramNode.)
BrushProperty | Identifies the Brush dependency property. (Inherited from DiagramItem.)
EffectsSourceProperty | Identifies the EffectsSource dependency property. (Inherited from DiagramNode.)
HyperLinkProperty | Identifies the HyperLink dependency property. (Inherited from DiagramItem.)
IsMouseDownProperty | Identifies the IsMouseDown dependency property. (Inherited from DiagramItem.)
IsMouseOverProperty | Identifies the IsMouseOver dependency property. (Inherited from DiagramItem.)
MasterNodeProperty | Identifies the MasterNode dependency property. (Inherited from DiagramNode.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from DiagramNode.)
ShapeOpacityProperty | Identifies the ShapeOpacity dependency property. (Inherited from DiagramNode.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from DiagramItem.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)

Inherited Protected Fields

Name | Description
handles | A list of the Rectangle objects that represent the item's adjustment handles. (Inherited from DiagramItem.)

See Also

ShapeNode Class


MindFusion.Diagramming.ShapeNode.DecorationsContainerProperty Field

ShapeNode.DecorationsContainerProperty Field
[image]

Identifies the DecorationsContainer dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DecorationsContainerProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DecorationsContainerProperty As DependencyProperty

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.HorizontalImageAlignmentProperty Field

ShapeNode.HorizontalImageAlignmentProperty Field
[image]

Identifies the HorizontalImageAlignment dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HorizontalImageAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HorizontalImageAlignmentProperty As DependencyProperty

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.HorizontalTextBlockAlignmentProperty Field

ShapeNode.HorizontalTextBlockAlignmentProperty Field
[image]

Identifies the HorizontalTextBlockAlignment dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HorizontalTextBlockAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HorizontalTextBlockAlignmentProperty As DependencyProperty

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.ImageProperty Field

ShapeNode.ImageProperty Field
[image]

Identifies the Image dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ImageProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ImageProperty As DependencyProperty

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.ImageStretchProperty Field

ShapeNode.ImageStretchProperty Field
[image]

Identifies the ImageStretch dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ImageStretchProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ImageStretchProperty As DependencyProperty

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.ShapeGeometryProperty Field

ShapeNode.ShapeGeometryProperty Field
[image]

Identifies the ShapeGeometry dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShapeGeometryProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShapeGeometryProperty As DependencyProperty

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.ShapeProperty Field

ShapeNode.ShapeProperty Field
[image]

Identifies the Shape dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShapeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShapeProperty As DependencyProperty

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.ShapeVisibilityProperty Field

ShapeNode.ShapeVisibilityProperty Field
[image]

Identifies the ShapeVisibility dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShapeVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShapeVisibilityProperty As DependencyProperty

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.TextAlignmentProperty Field

ShapeNode.TextAlignmentProperty Field
[image]

Identifies the TextAlignment dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextAlignmentProperty As DependencyProperty

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.TextHeightProperty Field

ShapeNode.TextHeightProperty Field
[image]

Identifies the TextHeight dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextHeightProperty As DependencyProperty

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.TextMarginProperty Field

ShapeNode.TextMarginProperty Field
[image]

Identifies the TextMargin dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextMarginProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextMarginProperty As DependencyProperty

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.TextProperty Field

ShapeNode.TextProperty Field
[image]

Identifies the Text dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextProperty As DependencyProperty

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.TextWidthProperty Field

ShapeNode.TextWidthProperty Field
[image]

Identifies the TextWidth dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextWidthProperty As DependencyProperty

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.TextWrappingProperty Field

ShapeNode.TextWrappingProperty Field
[image]

Identifies the TextWrapping dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextWrappingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextWrappingProperty As DependencyProperty

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.TransparentProperty Field

ShapeNode.TransparentProperty Field
[image]

Identifies the Transparent dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TransparentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TransparentProperty As DependencyProperty

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.VerticalImageAlignmentProperty Field

ShapeNode.VerticalImageAlignmentProperty Field
[image]

Identifies the VerticalImageAlignment dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty VerticalImageAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly VerticalImageAlignmentProperty As DependencyProperty

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.VerticalTextBlockAlignmentProperty Field

ShapeNode.VerticalTextBlockAlignmentProperty Field
[image]

Identifies the VerticalTextBlockAlignment dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty VerticalTextBlockAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly VerticalTextBlockAlignmentProperty As DependencyProperty

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode Constructor

ShapeNode Constructor
[image]

Overload List

Name | Description
ShapeNode () | Initializes a new instance of the ShapeNode class.
ShapeNode (Diagram) | Initializes a new instance of the ShapeNode class with default values supplied form the specified Diagram.
ShapeNode (ShapeNode) | Initializes a new instance of the ShapeNode class using the specified node as a prototype.

See Also

ShapeNode Class


MindFusion.Diagramming.ShapeNode Constructor ()

ShapeNode Constructor ()
See Also
[image]

Initializes a new instance of the ShapeNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode ()

Visual Basic [image] Copy Code

Public Sub New ()

Remarks

This constructor leaves the node's dependency properties in their default state, without local values. This allows the node to be styled through the WinRT styling mechanism.

See Also

ShapeNode Constructor Overload List
ShapeNode Class


MindFusion.Diagramming.ShapeNode Constructor (Diagram)

ShapeNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the ShapeNode class with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode (
Diagram parent
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram _
)

Parameters

parent
The Diagram from which to obtain default values for the node properties.

Remarks

This constructor initializes the ShapeNode properties with the values specified in the respective default-value properties of the Diagram object.

See Also

ShapeNode Constructor Overload List
ShapeNode Class


MindFusion.Diagramming.ShapeNode Constructor (ShapeNode)

ShapeNode Constructor (ShapeNode)
See Also
[image]

Initializes a new instance of the ShapeNode class using the specified node as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode (
ShapeNode prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As ShapeNode _
)

Parameters

prototype
The node to use as a prototype. The properties of the new node are initialized from the property values of this node.

Remarks

This constructor copies the ShapeNode property values from the specified prototype node.

See Also

ShapeNode Constructor Overload List
ShapeNode Class


MindFusion.Diagramming.ShapeNode Methods

ShapeNode Methods
[image]

Public Methods

Name | Description
GetOutlinePoly | DiagramNode.GetOutlinePoly override.
ResizeToFitImage | Makes the shape node as big as the image it displays.
ResizeToFitText | Makes the shape node big enough to display its text without clipping.

Protected Methods

Name | Description
CreateState | DiagramItem.CreateState override.
GetOutline | DiagramNode.GetOutline override.
LoadFromXml | Loads the item content from an XML element.
RestoreState | DiagramItem.RestoreState override.
SaveState | DiagramItem.SaveState override.
SaveToXml | Saves the item content into an XML element.
UpdateVisuals | DiagramNode.UpdateVisuals override.

Inherited Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
Attach | Attaches the specified subordinate node to this node, so that when this node is moved, the subordinate follows it. (Inherited from DiagramNode.)
AttachTo | Attaches this node to the specified master node so that when the master is moved, the attached node follows it. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
ContainsPoint | DiagramItem.ContainsPoint override. (Inherited from DiagramNode.)
Detach | Overloaded. (Inherited from DiagramNode.)
GetAllIncomingLinks | Gets a collection of all links entering this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Get a collection of all links going out of this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from DiagramNode.)
OnBoundsChanged | Called when the location and size of this node change. (Inherited from DiagramNode.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RestoreLocationState | DiagramItem.RestoreLocationState override. (Inherited from DiagramNode.)
SaveLocationState | DiagramItem.SaveLocationState override. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point in diagram coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Gets the diagram coordinates of a point specified in the local coordinate system of this item. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Inherited Protected Methods

Name | Description
AddAnchorPointVisuals | Adds the AnchorPatern points to the node's Adorner. (Inherited from DiagramNode.)
AddExpandButton | Adds the ExpandButton to the node's Adoner. (Inherited from DiagramNode.)
AddHandlesToCanvas | Overloaded. (Inherited from DiagramNode.)
AllowDrag | Invoked to validate the drag operation. (Inherited from DiagramItem.)
CancelDrag | DiagramItem.CancelDrag override. (Inherited from DiagramNode.)
CreateAnchorPointVisual | Creates a Path that represents the specified AnchorPoint. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
EndDrag | DiagramItem.EndDrag override. (Inherited from DiagramNode.)
GetOutline | Creates a Geometry object that describes the outline of the node. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
LoadFromXml | DiagramItem.LoadFromXml override. (Inherited from DiagramNode.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramNode.)
OnMouseEnter | Control.OnMouseEnter override. (Inherited from DiagramItem.)
OnMouseLeave | Control.OnMouseLeave override. (Inherited from DiagramItem.)
OnMouseLeftButtonDown | Control.OnMouseLeftButtonDown override. (Inherited from DiagramItem.)
OnMouseLeftButtonUp | Control.OnMouseLeftButtonUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
RemoveAnchorPointVisuals | Removes the AnchorPatern points from the node's Adorner. (Inherited from DiagramNode.)
RemoveHandlesFromCanvas | Invoked when the item's selection handles should be removed. (Inherited from DiagramItem.)
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramNode.)
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
StartDrag | DiagramItem.StartDrag override. (Inherited from DiagramNode.)
UpdateDrag | DiagramItem.UpdateDrag override. (Inherited from DiagramNode.)
UpdateHandleColors | Sets the handle colors according to the current selection state of the item and the enabled bits in the EnabledHandles property. (Inherited from DiagramItem.)
UpdateHandlePositions | Invoked when the item's selection handles should change their position. (Inherited from DiagramItem.)
UpdateStates | Sets the current VisualStates of this item. (Inherited from DiagramItem.)
UpdateVisuals | DiagramItem.UpdateVisuals override. (Inherited from DiagramNode.)

See Also

ShapeNode Class


MindFusion.Diagramming.ShapeNode.CreateState Method

ShapeNode.CreateState Method
[image]

DiagramItem.CreateState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramItemState CreateState ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateState () As DiagramItemState

Return Value

A ShapeNodeState instance.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.GetOutline Method

ShapeNode.GetOutline Method
[image]

DiagramNode.GetOutline override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Geometry GetOutline ()

Visual Basic [image] Copy Code

Protected Overrides Function GetOutline () As Geometry

Return Value

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.GetOutlinePoly Method

ShapeNode.GetOutlinePoly Method
[image]

DiagramNode.GetOutlinePoly override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override List<Point> GetOutlinePoly ()

Visual Basic [image] Copy Code

Public Overrides Function GetOutlinePoly () As List(Of Point)

Return Value

A list of points that define the node's outline.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.LoadFromXml Method

ShapeNode.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void LoadFromXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromXml( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement containing the item's data.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.ResizeToFitImage Method

ShapeNode.ResizeToFitImage Method
[image]

Makes the shape node as big as the image it displays.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ResizeToFitImage ()

Visual Basic [image] Copy Code

Public Sub ResizeToFitImage ()

Remarks

Call this method to make a shape node exactly the same size as the image it contains.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.ResizeToFitText Method

ShapeNode.ResizeToFitText Method
[image]

Makes the shape node big enough to display its text without clipping.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ResizeToFitText ()

Visual Basic [image] Copy Code

Public Sub ResizeToFitText ()

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
Text Property


MindFusion.Diagramming.ShapeNode.RestoreState Method

ShapeNode.RestoreState Method
[image]

DiagramItem.RestoreState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void RestoreState (
DiagramItemState itemState
)

Visual Basic [image] Copy Code

Protected Overridable Sub RestoreState ( _
itemState As DiagramItemState _
)

Parameters

itemState
A ShapeNodeState instance.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.SaveState Method

ShapeNode.SaveState Method
[image]

DiagramItem.SaveState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramItemState SaveState ()

Visual Basic [image] Copy Code

Protected Overridable Function SaveState () As DiagramItemState

Return Value

A ShapeNodeState instance.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.SaveToXml Method

ShapeNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SaveToXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveToXml( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement the item's data should be stored into.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.UpdateVisuals Method

ShapeNode.UpdateVisuals Method
[image]

DiagramNode.UpdateVisuals override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void UpdateVisuals (
bool updateEffects
)

Visual Basic [image] Copy Code

Protected Overrides Sub UpdateVisuals( _
updateEffects As Boolean _
)

Parameters

updateEffects

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode Properties

ShapeNode Properties
[image]

Public Properties

Name | Description
DecorationsContainer | Gets a Grid that contains the ShapeNode decoration elements.
HorizontalImageAlignment | Gets or sets the horizontal alignment of the ShapeNode's image.
HorizontalTextBlockAlignment | Gets or sets the horizontal alignment of the TextBlock used to display the ShapeNode text relative to its container Grid.
Image | Gets or sets the image that is displayed in this shape node. This is a dependency property.
ImageAlign | Gets or sets the alignment of the image displayed in this shape node.
ImageResourceLocation | Gets or sets the resource path to an image that should be displayed in this ShapeNode.
ImageStretch | Gets or sets a value that describes how the ShapeNode's image should be stretched to fill the destination rectangle.
ImageWebLocation | Gets or sets the URL of the image displayed in this ShapeNode.
Shape | Gets or sets a reference to the node's geometric shape definition.
ShapeGeometry | Gets a Geometry object that represents the ShapeNode outline and is automatically generated from the current Shape and Bounds values.
ShapeVisibility | For internal use.
Text | Gets or sets the text displayed inside the shape node. This is a dependency property.
TextAlignment | Gets or sets how the text should be aligned in the ShapeNode's text box.
TextFormat | Gets or sets the alignment of the text that is displayed inside shape nodes.
TextHeight | Gets or sets the height of the ShapeNode text area.
TextMargin | Gets or sets the offset of the ShapeNode text area from the origin of its container Grid.
TextWidth | Gets or sets the width of the ShapeNode text area.
TextWrapping | Gets or sets whether text wraps when it extends beyond the available width of the node. This is a dependency property.
Transparent | Gets or sets a value indicating whether this shape node is transparent. This is a dependency property.
VerticalImageAlignment | Gets or sets the vertical alignment of the ShapeNode's image.
VerticalTextBlockAlignment | Gets or sets the vertical alignment of the TextBlock used to display the ShapeNode text relative to its container Grid.

Inherited Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
AttachedNodes | Returns the nodes attached to this node. (Inherited from DiagramNode.)
AutoCaptureMouse | Gets or sets whether the item should capture the mouse input when the left button is pressed over it. This is a dependency property. (Inherited from DiagramItem.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. This is a dependency property. (Inherited from DiagramNode.)
Brush | Gets or sets the Brush that specifies how to paint the interior of the item. This is a dependency property. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Container | Gets the ContainerNode that contains this node. (Inherited from DiagramNode.)
Diagram | Gets the parent diagram. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramItem.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. This is a dependency property. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
IsMouseDown | Gets a value indicating whether the mouse button is pressed over this item. This is a dependency property. (Inherited from DiagramItem.)
IsMouseOver | Gets a value indicating whether the mouse pointer is located over this item. This is a dependency property. (Inherited from DiagramItem.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterNode | Gets the node to which this node is attached. This is a dependency property. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
RotationAngle | Gets or sets the angle at which this node is rotated. This is a dependency property. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShapeOpacity | Gets or sets the shape opacity of this node. This is a dependency property. (Inherited from DiagramNode.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline nodes. This is a dependency property. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashOffset | Gets or sets a double value that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. This is a dependency property. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
ToolTip | Gets or sets the contents of the tooltip displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of the object. (Inherited from DiagramItem.)

Inherited Protected Properties

Name | Description
Size | Gets the size of this item. (Inherited from DiagramItem.)

See Also

ShapeNode Class


MindFusion.Diagramming.ShapeNode.DecorationsContainer Property

ShapeNode.DecorationsContainer Property
[image]

Gets a Grid that contains the ShapeNode decoration elements.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Grid DecorationsContainer { get; set; }

Visual Basic [image] Copy Code

Public Property DecorationsContainer As Grid

Property Value

A Windows.UI.Xaml.Controls.Grid instance.

Remarks

The control automatically adds to this grid Geometry objects that correspond to the decoration elements defined in the node's Shape. The grid is displayed by the ShapeNode default ControlTemplate through a ContentPresenter.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.HorizontalImageAlignment Property

ShapeNode.HorizontalImageAlignment Property
[image]

Gets or sets the horizontal alignment of the ShapeNode's image.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HorizontalAlignment HorizontalImageAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalImageAlignment As HorizontalAlignment

Property Value

One of the Windows.UI.Xaml.HorizontalAlignment enumeration values. The default is Stretch.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.HorizontalTextBlockAlignment Property

ShapeNode.HorizontalTextBlockAlignment Property
[image]

Gets or sets the horizontal alignment of the TextBlock used to display the ShapeNode text relative to its container Grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HorizontalAlignment HorizontalTextBlockAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalTextBlockAlignment As HorizontalAlignment

Property Value

One of the Windows.UI.Xaml.HorizontalAlignment enumeration values. The default value is Center.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.Image Property

ShapeNode.Image Property
[image]

Gets or sets the image that is displayed in this shape node. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ImageSource Image { get; set; }

Visual Basic [image] Copy Code

Public Property Image As ImageSource

Property Value

An instance of the WinRT ImageSource class. The default value is null (Nothing in Visual Basic).

Remarks

This property lets you display an image inside the node. Use the ImageAlign property to specify how the image is aligned to that area. By default, the image is displayed in the center of the bounding rectangle of the node.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.ImageAlign Property

ShapeNode.ImageAlign Property
[image]

Gets or sets the alignment of the image displayed in this shape node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ImageAlign ImageAlign { get; set; }

Visual Basic [image] Copy Code

Public Property ImageAlign As ImageAlign

Property Value

A member of the ImageAlign enumeration. The default is Center.

Remarks

This property specifies how the Image is aligned to the bounding rectangle of this node.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
Image Property


MindFusion.Diagramming.ShapeNode.ImageResourceLocation Property

ShapeNode.ImageResourceLocation Property
[image]

Gets or sets the resource path to an image that should be displayed in this ShapeNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ImageResourceLocation { get; set; }

Visual Basic [image] Copy Code

Public Property ImageResourceLocation As String

Property Value

A valid URI string that identifies the image to be loaded through Application.GetResourceStream(Uri).

Remarks

Assigning a valid path to this property will automatically load the image and assign it to the Image property.

This property is saved and restored when serializing the diagram as XML. During the execution of LoadFromXml, the images are automatically loaded if they are still accessible through the specified URI.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
Image Property
ImageWebLocation Property


MindFusion.Diagramming.ShapeNode.ImageStretch Property

ShapeNode.ImageStretch Property
[image]

Gets or sets a value that describes how the ShapeNode's image should be stretched to fill the destination rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Stretch ImageStretch { get; set; }

Visual Basic [image] Copy Code

Public Property ImageStretch As Stretch

Property Value

One of the Windows.UI.Xaml.Media.Stretch enumeration values. The default is Uniform.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.ImageWebLocation Property

ShapeNode.ImageWebLocation Property
[image]

Gets or sets the URL of the image displayed in this ShapeNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ImageWebLocation { get; set; }

Visual Basic [image] Copy Code

Public Property ImageWebLocation As String

Property Value

A valid URL string that identifies the image to be loaded through the BitmapImage(Uri) constructor.

Remarks

Assigning a valid URL to this property will automatically load the image, either from a local file or over http connection. Relative URLs are resolved against the directory containing the *.xap file.

This property is saved and restored when serializing the diagram as XML. During the execution of LoadFromXml, the images are automatically loaded if they are still accessible through the specified URL.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
Image Property
ImageResourceLocation Property


MindFusion.Diagramming.ShapeNode.Shape Property

ShapeNode.Shape Property
[image]

Gets or sets a reference to the node's geometric shape definition.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape Shape { get; set; }

Visual Basic [image] Copy Code

Public Property Shape As Shape

Property Value

An instance of the Shape class. Initialized from DefaultShape.

Remarks

Use this property to assign a geometric shape to a node.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.ShapeGeometry Property

ShapeNode.ShapeGeometry Property
[image]

Gets a Geometry object that represents the ShapeNode outline and is automatically generated from the current Shape and Bounds values.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Geometry ShapeGeometry { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeGeometry As Geometry

Property Value

A Windows.UI.Xaml.Media.Geometry object representing the shape outline.

Remarks

The default ShapeNode ControlTemplate sets this object as value of the Data property of a Windows.UI.Xaml.Shapes.Shape that renders the node's outline.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.ShapeVisibility Property

ShapeNode.ShapeVisibility Property
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Visibility ShapeVisibility { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeVisibility As Visibility

Property Value

A double value specifying the shape's opacity. The default value is 1.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.Text Property

ShapeNode.Text Property
[image]

Gets or sets the text displayed inside the shape node. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Text { get; set; }

Visual Basic [image] Copy Code

Public Property Text As String

Property Value

A string containing the node's text.

Remarks

This property specifies the text that is drawn inside the shape. The text appearance can be customized through the TextBrush and TextFormat properties.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
TextBrush Property
TextFormat Property


MindFusion.Diagramming.ShapeNode.TextAlignment Property

ShapeNode.TextAlignment Property
[image]

Gets or sets how the text should be aligned in the ShapeNode's text box.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TextAlignment TextAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property TextAlignment As TextAlignment

Property Value

One of the Windows.UI.Xaml.TextAlignment enumeration values. The default is Center.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.TextFormat Property

ShapeNode.TextFormat Property
[image]

Gets or sets the alignment of the text that is displayed inside shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringFormat TextFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TextFormat As StringFormat

Property Value

An instance of the StringFormat class.

Remarks

Use this property to specify the wrapping mode and alignment of the text that is contained in nodes.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
Text Property
TextBrush Property


MindFusion.Diagramming.ShapeNode.TextHeight Property

ShapeNode.TextHeight Property
[image]

Gets or sets the height of the ShapeNode text area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double TextHeight { get; set; }

Visual Basic [image] Copy Code

Public Property TextHeight As Double

Property Value

Calculated automatically from the node size and the text area definition in the currently applied Shape.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.TextMargin Property

ShapeNode.TextMargin Property
[image]

Gets or sets the offset of the ShapeNode text area from the origin of its container Grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Thickness TextMargin { get; set; }

Visual Basic [image] Copy Code

Public Property TextMargin As Thickness

Property Value

Calculated automatically from the node size and the text area definition in the currently applied Shape.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.TextWidth Property

ShapeNode.TextWidth Property
[image]

Gets or sets the width of the ShapeNode text area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double TextWidth { get; set; }

Visual Basic [image] Copy Code

Public Property TextWidth As Double

Property Value

Calculated automatically from the node size and the text area definition in the currently applied Shape.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.TextWrapping Property

ShapeNode.TextWrapping Property
[image]

Gets or sets whether text wraps when it extends beyond the available width of the node. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TextWrapping TextWrapping { get; set; }

Visual Basic [image] Copy Code

Public Property TextWrapping As TextWrapping

Property Value

An instance of the Windows.UI.Xaml.TextWrapping enumeration. The default value is Wrap.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.Transparent Property

ShapeNode.Transparent Property
[image]

Gets or sets a value indicating whether this shape node is transparent. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Transparent { get; set; }

Visual Basic [image] Copy Code

Public Property Transparent As Boolean

Property Value

Remarks

If a node is transparent, only its image and text are drawn. Shape, filling and frames are not painted.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.VerticalImageAlignment Property

ShapeNode.VerticalImageAlignment Property
[image]

Gets or sets the vertical alignment of the ShapeNode's image.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public VerticalAlignment VerticalImageAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalImageAlignment As VerticalAlignment

Property Value

One of the Windows.UI.Xaml.VerticalAlignment enumeration values. The default is Stretch.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.VerticalTextBlockAlignment Property

ShapeNode.VerticalTextBlockAlignment Property
[image]

Gets or sets the vertical alignment of the TextBlock used to display the ShapeNode text relative to its container Grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public VerticalAlignment VerticalTextBlockAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalTextBlockAlignment As VerticalAlignment

Property Value

One of the Windows.UI.Xaml.VerticalAlignment enumeration values. The default value is Center.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNodeState Class

ShapeNodeState Class
[image]

Represents the state of a ShapeNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ShapeNodeState : DiagramNodeState

Visual Basic [image] Copy Code

Public Class ShapeNodeState
Inherits DiagramNodeState

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemState
MindFusion.Diagramming.DiagramNodeState
MindFusion.Diagramming.ShapeNodeState
MindFusion.Diagramming.ContainerNodeState

See Also

ShapeNodeState Members


MindFusion.Diagramming.ShapeNodeState Members

ShapeNodeState Members
Constructors
[image]

Represents the state of a ShapeNode.

The following tables list the members exposed by the ShapeNodeState type.

Public Constructors

Name | Description
ShapeNodeState |

See Also

ShapeNodeState Class


MindFusion.Diagramming.ShapeNodeState Constructor

ShapeNodeState Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNodeState ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ShapeNodeState Class


MindFusion.Diagramming.Shapes Class

Shapes Class
[image]

Provides alternative methods of access to the predefined shapes, that allows code completion and IntelliSense support, which is not available when using Shape.FromId.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Shapes

Visual Basic [image] Copy Code

Public Class Shapes

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Shapes

See Also

Shapes Members
MindFusion.Diagramming Namespace
Table of Predefined Shapes


MindFusion.Diagramming.Shapes Members

Shapes Members
Properties
[image]

Provides alternative methods of access to the predefined shapes, that allows code completion and IntelliSense support, which is not available when using Shape.FromId.

The following tables list the members exposed by the Shapes type.

Public Properties

Name | Description
Actor | Gets the Actor predefined shape.
Alternative | Gets the Alternative predefined shape.
Arrow1 | Gets the Arrow1 predefined shape.
Arrow2 | Gets the Arrow2 predefined shape.
Arrow3 | Gets the Arrow3 predefined shape.
Arrow4 | Gets the Arrow4 predefined shape.
Arrow5 | Gets the Arrow5 predefined shape.
Arrow6 | Gets the Arrow6 predefined shape.
Arrow7 | Gets the Arrow7 predefined shape.
Arrow8 | Gets the Arrow8 predefined shape.
Arrow9 | Gets the Arrow9 predefined shape.
BeginLoop | Gets the BeginLoop predefined shape.
BpmnComplex | Gets the BpmnComplex predefined shape.
BpmnDataBasedXor | Gets the BpmnDataBasedXor predefined shape.
BpmnEndCancel | Gets the BpmnEndCancel predefined shape.
BpmnEndCompensation | Gets the BpmnEndCompensation predefined shape.
BpmnEndError | Gets the BpmnEndError predefined shape.
BpmnEndLink | Gets the BpmnEndLink predefined shape.
BpmnEndMessage | Gets the BpmnEndMessage predefined shape.
BpmnEndMultiple | Gets the BpmnEndMultiple predefined shape.
BpmnEndTerminate | Gets the BpmnEndTerminate predefined shape.
BpmnEventBasedXor | Gets the BpmnEventBasedXor predefined shape.
BpmnInclusive | Gets the BpmnInclusive predefined shape.
BpmnIntermediateCancel | Gets the BpmnIntermediateCancel predefined shape.
BpmnIntermediateCompensation | Gets the BpmnIntermediateCompensation predefined shape.
BpmnIntermediateError | Gets the BpmnIntermediateError predefined shape.
BpmnIntermediateLink | Gets the BpmnIntermediateLink predefined shape.
BpmnIntermediateMessage | Gets the BpmnIntermediateMessage predefined shape.
BpmnIntermediateMultiple | Gets the BpmnIntermediateMultiple predefined shape.
BpmnIntermediateRule | Gets the BpmnIntermediateRule predefined shape.
BpmnIntermediateTimer | Gets the BpmnIntermediateTimer predefined shape.
BpmnParallelFork | Gets the BpmnParallelFork predefined shape.
BpmnStartLink | Gets the BpmnStartLink predefined shape.
BpmnStartMessage | Gets the BpmnStartMessage predefined shape.
BpmnStartMultiple | Gets the BpmnStartMultiple predefined shape.
BpmnStartRule | Gets the BpmnStartRule predefined shape.
BpmnStartTimer | Gets the BpmnStartTimer predefined shape.
Cloud | Gets the Cloud predefined shape.
Collate | Gets the Collate predefined shape.
ConeDown | Gets the ConeDown predefined shape.
ConeUp | Gets the ConeUp predefined shape.
ConnectedIssues | Gets the ConnectedIssues predefined shape.
CreateRequest | Gets the CreateRequest predefined shape.
Cross | Gets the Cross predefined shape.
Cube | Gets the Cube predefined shape.
Cylinder | Gets the Cylinder predefined shape.
Database | Gets the Database predefined shape.
DataTransmition | Gets the DataTransmition predefined shape.
DDelay | Gets the DDelay predefined shape.
Decagon | Gets the Decagon predefined shape.
Decision | Gets the Decision predefined shape.
Decision2 | Gets the Decision2 predefined shape.
Delay | Gets the Delay predefined shape.
DInDelay | Gets the DInDelay predefined shape.
DirectAccessStorage | Gets the DirectAccessStorage predefined shape.
DiskStorage | Gets the DiskStorage predefined shape.
Display | Gets the Display predefined shape.
DividedEvent | Gets the DividedEvent predefined shape.
DividedProcess | Gets the DividedProcess predefined shape.
Document | Gets the Document predefined shape.
Donut | Gets the Donut predefined shape.
DOutDelay | Gets the DOutDelay predefined shape.
Ellipse | Gets the Ellipse predefined shape.
EndLoop | Gets the EndLoop predefined shape.
ExternalOrganization | Gets the ExternalOrganization predefined shape.
ExternalProcess | Gets the ExternalProcess predefined shape.
File | Gets the File predefined shape.
FramedRectangle | Gets the FramedRectangle predefined shape.
Gate | Gets the Gate predefined shape.
Heart | Gets the Heart predefined shape.
Heptagon | Gets the Heptagon predefined shape.
Hourglass | Gets the Hourglass predefined shape.
Input | Gets the Input predefined shape.
InternalStorage | Gets the InternalStorage predefined shape.
Interrupt | Gets the Interrupt predefined shape.
Interrupt2 | Gets the Interrupt2 predefined shape.
IsoProcess | Gets the IsoProcess predefined shape.
Junction | Gets the Junction predefined shape.
Lightning | Gets the Lightning predefined shape.
LinedDocument | Gets the LinedDocument predefined shape.
ManualOperation | Gets the ManualOperation predefined shape.
Merge | Gets the Merge predefined shape.
MessageFromUser | Gets the MessageFromUser predefined shape.
MessageToUser | Gets the MessageToUser predefined shape.
Microform | Gets the Microform predefined shape.
MicroformProcessing | Gets the MicroformProcessing predefined shape.
MicroformRecording | Gets the MicroformRecording predefined shape.
MultiDocument | Gets the MultiDocument predefined shape.
MultiProc | Gets the MultiProc predefined shape.
Octagon | Gets the Octagon predefined shape.
OfflineStorage | Gets the OfflineStorage predefined shape.
OffpageConnection | Gets the OffpageConnection predefined shape.
OffpageReference | Gets the OffpageReference predefined shape.
Or | Gets the Or predefined shape.
Pentagon | Gets the Pentagon predefined shape.
Plaque | Gets the Plaque predefined shape.
PrimitiveFromCall | Gets the PrimitiveFromCall predefined shape.
PrimitiveToCall | Gets the PrimitiveToCall predefined shape.
Procedure | Gets the Procedure predefined shape.
Process | Gets the Process predefined shape.
Prysm | Gets the Prysm predefined shape.
PunchedCard | Gets the PunchedCard predefined shape.
PyramidDown | Gets the PyramidDown predefined shape.
PyramidUp | Gets the PyramidUp predefined shape.
Rectangle | Gets the Rectangle predefined shape.
RightTriangle | Gets the RightTriangle predefined shape.
RoundRect | Gets the RoundRect predefined shape.
RSave | Gets the RSave predefined shape.
Save | Gets the Save predefined shape.
Sort | Gets the Sort predefined shape.
Sphere | Gets the Sphere predefined shape.
Star | Gets the Star predefined shape.
Star16Pointed | Gets the Star16Pointed predefined shape.
Star24Pointed | Gets the Star24Pointed predefined shape.
Star32Pointed | Gets the Star32Pointed predefined shape.
Star4Pointed | Gets the Star4Pointed predefined shape.
Star5Pointed | Gets the Star5Pointed predefined shape.
Star6Pointed | Gets the Star6Pointed predefined shape.
Star7Pointed | Gets the Star7Pointed predefined shape.
Start | Gets the Start predefined shape.
Tape | Gets the Tape predefined shape.
Terminator | Gets the Terminator predefined shape.
TransmittalTape | Gets the TransmittalTape predefined shape.
Trapezoid | Gets the Trapezoid predefined shape.

See Also

Shapes Class


MindFusion.Diagramming.Shapes Properties

Shapes Properties
[image]

Public Properties

Name | Description
Actor | Gets the Actor predefined shape.
Alternative | Gets the Alternative predefined shape.
Arrow1 | Gets the Arrow1 predefined shape.
Arrow2 | Gets the Arrow2 predefined shape.
Arrow3 | Gets the Arrow3 predefined shape.
Arrow4 | Gets the Arrow4 predefined shape.
Arrow5 | Gets the Arrow5 predefined shape.
Arrow6 | Gets the Arrow6 predefined shape.
Arrow7 | Gets the Arrow7 predefined shape.
Arrow8 | Gets the Arrow8 predefined shape.
Arrow9 | Gets the Arrow9 predefined shape.
BeginLoop | Gets the BeginLoop predefined shape.
BpmnComplex | Gets the BpmnComplex predefined shape.
BpmnDataBasedXor | Gets the BpmnDataBasedXor predefined shape.
BpmnEndCancel | Gets the BpmnEndCancel predefined shape.
BpmnEndCompensation | Gets the BpmnEndCompensation predefined shape.
BpmnEndError | Gets the BpmnEndError predefined shape.
BpmnEndLink | Gets the BpmnEndLink predefined shape.
BpmnEndMessage | Gets the BpmnEndMessage predefined shape.
BpmnEndMultiple | Gets the BpmnEndMultiple predefined shape.
BpmnEndTerminate | Gets the BpmnEndTerminate predefined shape.
BpmnEventBasedXor | Gets the BpmnEventBasedXor predefined shape.
BpmnInclusive | Gets the BpmnInclusive predefined shape.
BpmnIntermediateCancel | Gets the BpmnIntermediateCancel predefined shape.
BpmnIntermediateCompensation | Gets the BpmnIntermediateCompensation predefined shape.
BpmnIntermediateError | Gets the BpmnIntermediateError predefined shape.
BpmnIntermediateLink | Gets the BpmnIntermediateLink predefined shape.
BpmnIntermediateMessage | Gets the BpmnIntermediateMessage predefined shape.
BpmnIntermediateMultiple | Gets the BpmnIntermediateMultiple predefined shape.
BpmnIntermediateRule | Gets the BpmnIntermediateRule predefined shape.
BpmnIntermediateTimer | Gets the BpmnIntermediateTimer predefined shape.
BpmnParallelFork | Gets the BpmnParallelFork predefined shape.
BpmnStartLink | Gets the BpmnStartLink predefined shape.
BpmnStartMessage | Gets the BpmnStartMessage predefined shape.
BpmnStartMultiple | Gets the BpmnStartMultiple predefined shape.
BpmnStartRule | Gets the BpmnStartRule predefined shape.
BpmnStartTimer | Gets the BpmnStartTimer predefined shape.
Cloud | Gets the Cloud predefined shape.
Collate | Gets the Collate predefined shape.
ConeDown | Gets the ConeDown predefined shape.
ConeUp | Gets the ConeUp predefined shape.
ConnectedIssues | Gets the ConnectedIssues predefined shape.
CreateRequest | Gets the CreateRequest predefined shape.
Cross | Gets the Cross predefined shape.
Cube | Gets the Cube predefined shape.
Cylinder | Gets the Cylinder predefined shape.
Database | Gets the Database predefined shape.
DataTransmition | Gets the DataTransmition predefined shape.
DDelay | Gets the DDelay predefined shape.
Decagon | Gets the Decagon predefined shape.
Decision | Gets the Decision predefined shape.
Decision2 | Gets the Decision2 predefined shape.
Delay | Gets the Delay predefined shape.
DInDelay | Gets the DInDelay predefined shape.
DirectAccessStorage | Gets the DirectAccessStorage predefined shape.
DiskStorage | Gets the DiskStorage predefined shape.
Display | Gets the Display predefined shape.
DividedEvent | Gets the DividedEvent predefined shape.
DividedProcess | Gets the DividedProcess predefined shape.
Document | Gets the Document predefined shape.
Donut | Gets the Donut predefined shape.
DOutDelay | Gets the DOutDelay predefined shape.
Ellipse | Gets the Ellipse predefined shape.
EndLoop | Gets the EndLoop predefined shape.
ExternalOrganization | Gets the ExternalOrganization predefined shape.
ExternalProcess | Gets the ExternalProcess predefined shape.
File | Gets the File predefined shape.
FramedRectangle | Gets the FramedRectangle predefined shape.
Gate | Gets the Gate predefined shape.
Heart | Gets the Heart predefined shape.
Heptagon | Gets the Heptagon predefined shape.
Hourglass | Gets the Hourglass predefined shape.
Input | Gets the Input predefined shape.
InternalStorage | Gets the InternalStorage predefined shape.
Interrupt | Gets the Interrupt predefined shape.
Interrupt2 | Gets the Interrupt2 predefined shape.
IsoProcess | Gets the IsoProcess predefined shape.
Junction | Gets the Junction predefined shape.
Lightning | Gets the Lightning predefined shape.
LinedDocument | Gets the LinedDocument predefined shape.
ManualOperation | Gets the ManualOperation predefined shape.
Merge | Gets the Merge predefined shape.
MessageFromUser | Gets the MessageFromUser predefined shape.
MessageToUser | Gets the MessageToUser predefined shape.
Microform | Gets the Microform predefined shape.
MicroformProcessing | Gets the MicroformProcessing predefined shape.
MicroformRecording | Gets the MicroformRecording predefined shape.
MultiDocument | Gets the MultiDocument predefined shape.
MultiProc | Gets the MultiProc predefined shape.
Octagon | Gets the Octagon predefined shape.
OfflineStorage | Gets the OfflineStorage predefined shape.
OffpageConnection | Gets the OffpageConnection predefined shape.
OffpageReference | Gets the OffpageReference predefined shape.
Or | Gets the Or predefined shape.
Pentagon | Gets the Pentagon predefined shape.
Plaque | Gets the Plaque predefined shape.
PrimitiveFromCall | Gets the PrimitiveFromCall predefined shape.
PrimitiveToCall | Gets the PrimitiveToCall predefined shape.
Procedure | Gets the Procedure predefined shape.
Process | Gets the Process predefined shape.
Prysm | Gets the Prysm predefined shape.
PunchedCard | Gets the PunchedCard predefined shape.
PyramidDown | Gets the PyramidDown predefined shape.
PyramidUp | Gets the PyramidUp predefined shape.
Rectangle | Gets the Rectangle predefined shape.
RightTriangle | Gets the RightTriangle predefined shape.
RoundRect | Gets the RoundRect predefined shape.
RSave | Gets the RSave predefined shape.
Save | Gets the Save predefined shape.
Sort | Gets the Sort predefined shape.
Sphere | Gets the Sphere predefined shape.
Star | Gets the Star predefined shape.
Star16Pointed | Gets the Star16Pointed predefined shape.
Star24Pointed | Gets the Star24Pointed predefined shape.
Star32Pointed | Gets the Star32Pointed predefined shape.
Star4Pointed | Gets the Star4Pointed predefined shape.
Star5Pointed | Gets the Star5Pointed predefined shape.
Star6Pointed | Gets the Star6Pointed predefined shape.
Star7Pointed | Gets the Star7Pointed predefined shape.
Start | Gets the Start predefined shape.
Tape | Gets the Tape predefined shape.
Terminator | Gets the Terminator predefined shape.
TransmittalTape | Gets the TransmittalTape predefined shape.
Trapezoid | Gets the Trapezoid predefined shape.

See Also

Shapes Class


MindFusion.Diagramming.Shapes.Actor Property

Shapes.Actor Property
[image]

Gets the Actor predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Actor { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Actor As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Alternative Property

Shapes.Alternative Property
[image]

Gets the Alternative predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Alternative { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Alternative As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow1 Property

Shapes.Arrow1 Property
[image]

Gets the Arrow1 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow1 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow1 As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow2 Property

Shapes.Arrow2 Property
[image]

Gets the Arrow2 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow2 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow2 As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow3 Property

Shapes.Arrow3 Property
[image]

Gets the Arrow3 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow3 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow3 As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow4 Property

Shapes.Arrow4 Property
[image]

Gets the Arrow4 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow4 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow4 As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow5 Property

Shapes.Arrow5 Property
[image]

Gets the Arrow5 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow5 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow5 As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow6 Property

Shapes.Arrow6 Property
[image]

Gets the Arrow6 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow6 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow6 As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow7 Property

Shapes.Arrow7 Property
[image]

Gets the Arrow7 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow7 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow7 As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow8 Property

Shapes.Arrow8 Property
[image]

Gets the Arrow8 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow8 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow8 As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow9 Property

Shapes.Arrow9 Property
[image]

Gets the Arrow9 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow9 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow9 As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BeginLoop Property

Shapes.BeginLoop Property
[image]

Gets the BeginLoop predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BeginLoop { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BeginLoop As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnComplex Property

Shapes.BpmnComplex Property
[image]

Gets the BpmnComplex predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnComplex { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnComplex As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnDataBasedXor Property

Shapes.BpmnDataBasedXor Property
[image]

Gets the BpmnDataBasedXor predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnDataBasedXor { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnDataBasedXor As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndCancel Property

Shapes.BpmnEndCancel Property
[image]

Gets the BpmnEndCancel predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnEndCancel { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndCancel As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndCompensation Property

Shapes.BpmnEndCompensation Property
[image]

Gets the BpmnEndCompensation predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnEndCompensation { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndCompensation As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndError Property

Shapes.BpmnEndError Property
[image]

Gets the BpmnEndError predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnEndError { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndError As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndLink Property

Shapes.BpmnEndLink Property
[image]

Gets the BpmnEndLink predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnEndLink { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndLink As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndMessage Property

Shapes.BpmnEndMessage Property
[image]

Gets the BpmnEndMessage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnEndMessage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndMessage As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndMultiple Property

Shapes.BpmnEndMultiple Property
[image]

Gets the BpmnEndMultiple predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnEndMultiple { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndMultiple As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndTerminate Property

Shapes.BpmnEndTerminate Property
[image]

Gets the BpmnEndTerminate predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnEndTerminate { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndTerminate As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEventBasedXor Property

Shapes.BpmnEventBasedXor Property
[image]

Gets the BpmnEventBasedXor predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnEventBasedXor { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEventBasedXor As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnInclusive Property

Shapes.BpmnInclusive Property
[image]

Gets the BpmnInclusive predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnInclusive { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnInclusive As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateCancel Property

Shapes.BpmnIntermediateCancel Property
[image]

Gets the BpmnIntermediateCancel predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateCancel { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateCancel As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateCompensation Property

Shapes.BpmnIntermediateCompensation Property
[image]

Gets the BpmnIntermediateCompensation predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateCompensation { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateCompensation As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateError Property

Shapes.BpmnIntermediateError Property
[image]

Gets the BpmnIntermediateError predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateError { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateError As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateLink Property

Shapes.BpmnIntermediateLink Property
[image]

Gets the BpmnIntermediateLink predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateLink { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateLink As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateMessage Property

Shapes.BpmnIntermediateMessage Property
[image]

Gets the BpmnIntermediateMessage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateMessage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateMessage As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateMultiple Property

Shapes.BpmnIntermediateMultiple Property
[image]

Gets the BpmnIntermediateMultiple predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateMultiple { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateMultiple As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateRule Property

Shapes.BpmnIntermediateRule Property
[image]

Gets the BpmnIntermediateRule predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateRule { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateRule As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateTimer Property

Shapes.BpmnIntermediateTimer Property
[image]

Gets the BpmnIntermediateTimer predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateTimer { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateTimer As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnParallelFork Property

Shapes.BpmnParallelFork Property
[image]

Gets the BpmnParallelFork predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnParallelFork { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnParallelFork As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnStartLink Property

Shapes.BpmnStartLink Property
[image]

Gets the BpmnStartLink predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnStartLink { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnStartLink As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnStartMessage Property

Shapes.BpmnStartMessage Property
[image]

Gets the BpmnStartMessage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnStartMessage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnStartMessage As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnStartMultiple Property

Shapes.BpmnStartMultiple Property
[image]

Gets the BpmnStartMultiple predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnStartMultiple { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnStartMultiple As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnStartRule Property

Shapes.BpmnStartRule Property
[image]

Gets the BpmnStartRule predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnStartRule { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnStartRule As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnStartTimer Property

Shapes.BpmnStartTimer Property
[image]

Gets the BpmnStartTimer predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnStartTimer { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnStartTimer As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Cloud Property

Shapes.Cloud Property
[image]

Gets the Cloud predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Cloud { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Cloud As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Collate Property

Shapes.Collate Property
[image]

Gets the Collate predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Collate { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Collate As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.ConeDown Property

Shapes.ConeDown Property
[image]

Gets the ConeDown predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape ConeDown { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ConeDown As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.ConeUp Property

Shapes.ConeUp Property
[image]

Gets the ConeUp predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape ConeUp { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ConeUp As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.ConnectedIssues Property

Shapes.ConnectedIssues Property
[image]

Gets the ConnectedIssues predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape ConnectedIssues { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ConnectedIssues As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.CreateRequest Property

Shapes.CreateRequest Property
[image]

Gets the CreateRequest predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape CreateRequest { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property CreateRequest As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Cross Property

Shapes.Cross Property
[image]

Gets the Cross predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Cross { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Cross As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Cube Property

Shapes.Cube Property
[image]

Gets the Cube predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Cube { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Cube As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Cylinder Property

Shapes.Cylinder Property
[image]

Gets the Cylinder predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Cylinder { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Cylinder As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Database Property

Shapes.Database Property
[image]

Gets the Database predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Database { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Database As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DataTransmition Property

Shapes.DataTransmition Property
[image]

Gets the DataTransmition predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DataTransmition { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DataTransmition As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DDelay Property

Shapes.DDelay Property
[image]

Gets the DDelay predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DDelay { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DDelay As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Decagon Property

Shapes.Decagon Property
[image]

Gets the Decagon predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Decagon { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Decagon As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Decision Property

Shapes.Decision Property
[image]

Gets the Decision predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Decision { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Decision As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Decision2 Property

Shapes.Decision2 Property
[image]

Gets the Decision2 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Decision2 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Decision2 As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Delay Property

Shapes.Delay Property
[image]

Gets the Delay predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Delay { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Delay As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DInDelay Property

Shapes.DInDelay Property
[image]

Gets the DInDelay predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DInDelay { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DInDelay As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DirectAccessStorage Property

Shapes.DirectAccessStorage Property
[image]

Gets the DirectAccessStorage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DirectAccessStorage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DirectAccessStorage As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DiskStorage Property

Shapes.DiskStorage Property
[image]

Gets the DiskStorage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DiskStorage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DiskStorage As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Display Property

Shapes.Display Property
[image]

Gets the Display predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Display { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Display As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DividedEvent Property

Shapes.DividedEvent Property
[image]

Gets the DividedEvent predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DividedEvent { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DividedEvent As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DividedProcess Property

Shapes.DividedProcess Property
[image]

Gets the DividedProcess predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DividedProcess { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DividedProcess As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Document Property

Shapes.Document Property
[image]

Gets the Document predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Document { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Document As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Donut Property

Shapes.Donut Property
[image]

Gets the Donut predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Donut { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Donut As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DOutDelay Property

Shapes.DOutDelay Property
[image]

Gets the DOutDelay predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DOutDelay { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DOutDelay As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Ellipse Property

Shapes.Ellipse Property
[image]

Gets the Ellipse predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Ellipse { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Ellipse As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.EndLoop Property

Shapes.EndLoop Property
[image]

Gets the EndLoop predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape EndLoop { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property EndLoop As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace
Table of Predefined Shapes


MindFusion.Diagramming.Shapes.ExternalOrganization Property

Shapes.ExternalOrganization Property
[image]

Gets the ExternalOrganization predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape ExternalOrganization { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ExternalOrganization As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace
Table of Predefined Shapes


MindFusion.Diagramming.Shapes.ExternalProcess Property

Shapes.ExternalProcess Property
[image]

Gets the ExternalProcess predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape ExternalProcess { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ExternalProcess As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.File Property

Shapes.File Property
[image]

Gets the File predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape File { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property File As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.FramedRectangle Property

Shapes.FramedRectangle Property
[image]

Gets the FramedRectangle predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape FramedRectangle { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property FramedRectangle As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace
Table of Predefined Shapes


MindFusion.Diagramming.Shapes.Gate Property

Shapes.Gate Property
[image]

Gets the Gate predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Gate { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Gate As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Heart Property

Shapes.Heart Property
[image]

Gets the Heart predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Heart { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Heart As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Heptagon Property

Shapes.Heptagon Property
[image]

Gets the Heptagon predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Heptagon { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Heptagon As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Hourglass Property

Shapes.Hourglass Property
[image]

Gets the Hourglass predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Hourglass { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Hourglass As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Input Property

Shapes.Input Property
[image]

Gets the Input predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Input { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Input As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.InternalStorage Property

Shapes.InternalStorage Property
[image]

Gets the InternalStorage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape InternalStorage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property InternalStorage As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Interrupt Property

Shapes.Interrupt Property
[image]

Gets the Interrupt predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Interrupt { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Interrupt As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Interrupt2 Property

Shapes.Interrupt2 Property
[image]

Gets the Interrupt2 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Interrupt2 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Interrupt2 As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.IsoProcess Property

Shapes.IsoProcess Property
[image]

Gets the IsoProcess predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape IsoProcess { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property IsoProcess As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Junction Property

Shapes.Junction Property
[image]

Gets the Junction predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Junction { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Junction As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Lightning Property

Shapes.Lightning Property
[image]

Gets the Lightning predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Lightning { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Lightning As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.LinedDocument Property

Shapes.LinedDocument Property
[image]

Gets the LinedDocument predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape LinedDocument { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property LinedDocument As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.ManualOperation Property

Shapes.ManualOperation Property
[image]

Gets the ManualOperation predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape ManualOperation { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ManualOperation As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Merge Property

Shapes.Merge Property
[image]

Gets the Merge predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Merge { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Merge As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.MessageFromUser Property

Shapes.MessageFromUser Property
[image]

Gets the MessageFromUser predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape MessageFromUser { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MessageFromUser As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace
Table of Predefined Shapes


MindFusion.Diagramming.Shapes.MessageToUser Property

Shapes.MessageToUser Property
[image]

Gets the MessageToUser predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape MessageToUser { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MessageToUser As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace
Table of Predefined Shapes


MindFusion.Diagramming.Shapes.Microform Property

Shapes.Microform Property
[image]

Gets the Microform predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Microform { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Microform As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace
Table of Predefined Shapes


MindFusion.Diagramming.Shapes.MicroformProcessing Property

Shapes.MicroformProcessing Property
[image]

Gets the MicroformProcessing predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape MicroformProcessing { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MicroformProcessing As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace
Table of Predefined Shapes


MindFusion.Diagramming.Shapes.MicroformRecording Property

Shapes.MicroformRecording Property
[image]

Gets the MicroformRecording predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape MicroformRecording { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MicroformRecording As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace
Table of Predefined Shapes


MindFusion.Diagramming.Shapes.MultiDocument Property

Shapes.MultiDocument Property
[image]

Gets the MultiDocument predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape MultiDocument { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MultiDocument As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace
Table of Predefined Shapes


MindFusion.Diagramming.Shapes.MultiProc Property

Shapes.MultiProc Property
[image]

Gets the MultiProc predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape MultiProc { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MultiProc As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace
Table of Predefined Shapes


MindFusion.Diagramming.Shapes.Octagon Property

Shapes.Octagon Property
[image]

Gets the Octagon predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Octagon { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Octagon As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace
Table of Predefined Shapes


MindFusion.Diagramming.Shapes.OfflineStorage Property

Shapes.OfflineStorage Property
[image]

Gets the OfflineStorage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape OfflineStorage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property OfflineStorage As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.OffpageConnection Property

Shapes.OffpageConnection Property
[image]

Gets the OffpageConnection predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape OffpageConnection { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property OffpageConnection As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.OffpageReference Property

Shapes.OffpageReference Property
[image]

Gets the OffpageReference predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape OffpageReference { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property OffpageReference As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Or Property

Shapes.Or Property
[image]

Gets the Or predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Or { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Or As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Pentagon Property

Shapes.Pentagon Property
[image]

Gets the Pentagon predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Pentagon { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Pentagon As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Plaque Property

Shapes.Plaque Property
[image]

Gets the Plaque predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Plaque { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Plaque As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.PrimitiveFromCall Property

Shapes.PrimitiveFromCall Property
[image]

Gets the PrimitiveFromCall predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape PrimitiveFromCall { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PrimitiveFromCall As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.PrimitiveToCall Property

Shapes.PrimitiveToCall Property
[image]

Gets the PrimitiveToCall predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape PrimitiveToCall { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PrimitiveToCall As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Procedure Property

Shapes.Procedure Property
[image]

Gets the Procedure predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Procedure { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Procedure As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Process Property

Shapes.Process Property
[image]

Gets the Process predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Process { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Process As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Prysm Property

Shapes.Prysm Property
[image]

Gets the Prysm predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Prysm { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Prysm As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.PunchedCard Property

Shapes.PunchedCard Property
[image]

Gets the PunchedCard predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape PunchedCard { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PunchedCard As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.PyramidDown Property

Shapes.PyramidDown Property
[image]

Gets the PyramidDown predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape PyramidDown { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PyramidDown As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.PyramidUp Property

Shapes.PyramidUp Property
[image]

Gets the PyramidUp predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape PyramidUp { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PyramidUp As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Rectangle Property

Shapes.Rectangle Property
[image]

Gets the Rectangle predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Rectangle { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Rectangle As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.RightTriangle Property

Shapes.RightTriangle Property
[image]

Gets the RightTriangle predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape RightTriangle { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property RightTriangle As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.RoundRect Property

Shapes.RoundRect Property
[image]

Gets the RoundRect predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape RoundRect { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property RoundRect As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.RSave Property

Shapes.RSave Property
[image]

Gets the RSave predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape RSave { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property RSave As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Save Property

Shapes.Save Property
[image]

Gets the Save predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Save { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Save As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Sort Property

Shapes.Sort Property
[image]

Gets the Sort predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Sort { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Sort As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Sphere Property

Shapes.Sphere Property
[image]

Gets the Sphere predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Sphere { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Sphere As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star Property

Shapes.Star Property
[image]

Gets the Star predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Star { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star16Pointed Property

Shapes.Star16Pointed Property
[image]

Gets the Star16Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Star16Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star16Pointed As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star24Pointed Property

Shapes.Star24Pointed Property
[image]

Gets the Star24Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Star24Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star24Pointed As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star32Pointed Property

Shapes.Star32Pointed Property
[image]

Gets the Star32Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Star32Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star32Pointed As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star4Pointed Property

Shapes.Star4Pointed Property
[image]

Gets the Star4Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Star4Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star4Pointed As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star5Pointed Property

Shapes.Star5Pointed Property
[image]

Gets the Star5Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Star5Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star5Pointed As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star6Pointed Property

Shapes.Star6Pointed Property
[image]

Gets the Star6Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Star6Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star6Pointed As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star7Pointed Property

Shapes.Star7Pointed Property
[image]

Gets the Star7Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Star7Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star7Pointed As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Start Property

Shapes.Start Property
[image]

Gets the Start predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Start { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Start As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Tape Property

Shapes.Tape Property
[image]

Gets the Tape predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Tape { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Tape As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Terminator Property

Shapes.Terminator Property
[image]

Gets the Terminator predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Terminator { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Terminator As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.TransmittalTape Property

Shapes.TransmittalTape Property
[image]

Gets the TransmittalTape predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape TransmittalTape { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property TransmittalTape As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Trapezoid Property

Shapes.Trapezoid Property
[image]

Gets the Trapezoid predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Trapezoid { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Trapezoid As Shape

Property Value

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.ShowAnchors Enumeration

ShowAnchors Enumeration
[image]

Specifies when anchors points should be displayed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum ShowAnchors

Visual Basic [image] Copy Code

Public Enum ShowAnchors

Members

Member name | Description
Always | Anchor point marks are always painted.
Auto | Anchor point marks are shown for the node under the mouse cursor.
Never | Anchor point marks are never painted.
Selected | Anchor point marks are painted for the selected node.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.SimpleShape Enumeration

SimpleShape Enumeration
[image]

Defines the possible values for the Shape property of tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum SimpleShape

Visual Basic [image] Copy Code

Public Enum SimpleShape

Members

Member name | Description
Rectangle | Sets table's shape to rectangle.
RoundedRectangle | Sets table's shape to rounded rectangle.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.StringAlignment Enumeration

StringAlignment Enumeration
[image]

Replaces System.Drawing.StringAlignment

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum StringAlignment

Visual Basic [image] Copy Code

Public Enum StringAlignment

Members

Member name | Description
Center | Specifies that text is aligned in the center of the layout rectangle.
Far | Specifies that text is aligned far from the origin position of the layout rectangle. In a left-to-right layout, the far position is right. In a right-to-left layout, the far position is left.
Near | Specifies the text be aligned near the layout. In a left-to-right layout, the near position is left. In a right-to-left layout, the near position is right.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.StringFormat Class

StringFormat Class
[image]

Specifies the text alignment for labels displayed inside diagram items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class StringFormat

Visual Basic [image] Copy Code

Public Class StringFormat

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.StringFormat

See Also

StringFormat Members


MindFusion.Diagramming.StringFormat Members

StringFormat Members
Constructors Properties
[image]

Specifies the text alignment for labels displayed inside diagram items.

The following tables list the members exposed by the StringFormat type.

Public Constructors

Name | Description
StringFormat | Overloaded.

Public Properties

Name | Description
Alignment | Gets or sets the horizontal text alignment.
LineAlignment | Gets or sets the vertical text alignment.

See Also

StringFormat Class


MindFusion.Diagramming.StringFormat Constructor

StringFormat Constructor
[image]

Overload List

Name | Description
StringFormat () | Initializes a new StringFormat object.
StringFormat (StringAlignment, StringAlignment) | Initializes a new StringFormat object.
StringFormat (StringFormat) | Initializes a new StringFormat object.

See Also

StringFormat Class


MindFusion.Diagramming.StringFormat Constructor ()

StringFormat Constructor ()
See Also
[image]

Initializes a new StringFormat object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringFormat ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

StringFormat Constructor Overload List
StringFormat Class


MindFusion.Diagramming.StringFormat Constructor (StringAlignment, StringAlignment)

StringFormat Constructor (StringAlignment, StringAlignment)
See Also
[image]

Initializes a new StringFormat object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringFormat (
StringAlignment alignment,
StringAlignment lineAlignment
)

Visual Basic [image] Copy Code

Public New ( _
alignment As StringAlignment, _
lineAlignment As StringAlignment _
)

Parameters

alignment

lineAlignment

See Also

StringFormat Constructor Overload List
StringFormat Class


MindFusion.Diagramming.StringFormat Constructor (StringFormat)

StringFormat Constructor (StringFormat)
See Also
[image]

Initializes a new StringFormat object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringFormat (
StringFormat sf
)

Visual Basic [image] Copy Code

Public New ( _
sf As StringFormat _
)

Parameters

sf

See Also

StringFormat Constructor Overload List
StringFormat Class


MindFusion.Diagramming.StringFormat Properties

StringFormat Properties
[image]

Public Properties

Name | Description
Alignment | Gets or sets the horizontal text alignment.
LineAlignment | Gets or sets the vertical text alignment.

See Also

StringFormat Class


MindFusion.Diagramming.StringFormat.Alignment Property

StringFormat.Alignment Property
[image]

Gets or sets the horizontal text alignment.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringAlignment Alignment { get; set; }

Visual Basic [image] Copy Code

Public Property Alignment As StringAlignment

Property Value

A member of the StringAlignment enumeration.

See Also

StringFormat Members
StringFormat Class


MindFusion.Diagramming.StringFormat.LineAlignment Property

StringFormat.LineAlignment Property
[image]

Gets or sets the vertical text alignment.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringAlignment LineAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property LineAlignment As StringAlignment

Property Value

A member of the StringAlignment enumeration.

See Also

StringFormat Members
StringFormat Class


MindFusion.Diagramming.StrokeConverter Class

StrokeConverter Class
[image]

Scales stroke thickness values to reverse the effect of Viewbox scaling.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class StrokeConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class StrokeConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.StrokeConverter

See Also

StrokeConverter Members


MindFusion.Diagramming.StrokeConverter Members

StrokeConverter Members
Constructors Methods
[image]

Scales stroke thickness values to reverse the effect of Viewbox scaling.

The following tables list the members exposed by the StrokeConverter type.

Public Constructors

Name | Description
StrokeConverter |

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

StrokeConverter Class


MindFusion.Diagramming.StrokeConverter Constructor

StrokeConverter Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StrokeConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

StrokeConverter Class


MindFusion.Diagramming.StrokeConverter Methods

StrokeConverter Methods
[image]

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

StrokeConverter Class


MindFusion.Diagramming.StrokeConverter.Convert Method

StrokeConverter.Convert Method
[image]

IValueConverter.Convert implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo l
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
l As CultureInfo _
) As Object

Parameters

value

targetType

parameter

l

Return Value

See Also

StrokeConverter Members
StrokeConverter Class


MindFusion.Diagramming.StrokeConverter.ConvertBack Method

StrokeConverter.ConvertBack Method
[image]

IValueConverter.ConvertBack implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo l
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
l As CultureInfo _
) As Object

Parameters

value

targetType

parameter

l

Return Value

See Also

StrokeConverter Members
StrokeConverter Class


MindFusion.Diagramming.TabAlignment Enumeration

TabAlignment Enumeration
[image]

Specifies the alignment of the tab headers in a TabControl.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public enum TabAlignment

Visual Basic [image] Copy Code

Public Enum TabAlignment

Members

Member name | Description
Center | The headers are centered in the available space.
Far | The headers are aligned to the far end of the available space.
Near | The headers are aligned to the near end of the available space.
Stretch | The headers are resized to fill the available space.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.TabbedDiagramView Class

TabbedDiagramView Class
Remarks See Also
[image]

Represents a control that can display DiagramDocument objects. The individual diagram pages can be activated through the tabs in the tray located at one of the view sides.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public class TabbedDiagramView : Control

Visual Basic [image] Copy Code

Public Class TabbedDiagramView
Inherits Control

Remarks

The appearance and behavior of the tab tray can be customized using various properties.

The ShowTabs property indicates whether the tray is visible. The location of the tray is specified through the TabAlignment property. ShowCreateNewTab and ShowTabNavigationButtons determine the visibility of the buttons for interactive tab creation and tab navigation respectively. ShowTabCloseButtons specifies whether the tabs can be closed interactively, by clicking on the small 'x' button displayed in each tab. AllowTabReorder enables interactive tab rearrangement by mouse dragging.

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
MindFusion.Diagramming.TabbedDiagramView

See Also

TabbedDiagramView Members


MindFusion.Diagramming.TabbedDiagramView Members

TabbedDiagramView Members
Constructors Fields Properties Methods Events
[image]

Represents a control that can display DiagramDocument objects. The individual diagram pages can be activated through the tabs in the tray located at one of the view sides.

The following tables list the members exposed by the TabbedDiagramView type.

Public Constructors

Name | Description
TabbedDiagramView | Initializes a new instance of the TabbedDiagramView class.

Public Fields

Name | Description
AllowRenamePagesProperty | Identifies the AllowRenamePages dependency property.
AllowTabReorderProperty | Identifies the AllowTabReorder dependency property.
CurrentPageProperty | Identifies the CurrentPage dependency property.
DocumentProperty | Identifies the Document dependency property.
ShowCreateNewTabProperty | Identifies the ShowCreateNewTab dependency property.
ShowTabCloseButtonsProperty | Identifies the ShowTabCloseButtons dependency property.
ShowTabNavigationButtonsProperty | Identifies the ShowTabNavigationButtons dependency property.
ShowTabsProperty | Identifies the ShowTabs dependency property.
TabAlignmentProperty | Identifies the TabAlignment dependency property.

Public Properties

Name | Description
AllowRenamePages | Gets or sets whether DiagramPage titles can be renamed interactively.
AllowTabReorder | Gets or sets a value indicating whether tabs can be rearranged interactively. This is a dependency property.
CurrentPage | Gets or sets the currently active page. This is a dependency property.
Document | Gets or sets the displayed diagram document. This is a dependency property.
ShowCreateNewTab | Gets or sets a value indicating whether to display the 'Create New Tab' button. This is a dependency property.
ShowTabCloseButtons | Gets or sets a value indicating whether to display a close button for each tab. This is a dependency property.
ShowTabNavigationButtons | Gets or sets a value indicating whether the tab navigation buttons. This is a dependency property.
ShowTabs | Gets or sets a value indicating whether the tabs are visible. This is a dependency property.
TabAlignment | Gets or sets the tabs alignment. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
OnCurrentPageChanged | Raises the CurrentPageChanged event.
OnPageAdded | Raises the PageAdded event.
OnPageRemoved | Raises the PageRemoved event.
OnPageRemoving | Raises the PageRemoving event.
OnPageRenamed | Raises the PageRenamed event.

Public Events

Name | Description
CurrentPageChanged | Raised when the currently active page is changed.
PageAdded | Raised when a new page is added to the view interactively, that is, when the user clicks on the 'Create New Tab' button.
PageRemoved | Raised when a page is removed interactively, that is, when the user clicks the close button of its associated tab.
PageRemoving | Raised when a page is about to be removed interactively, that is, when the user clicks the close button of its associated tab.
PageRenamed | Raised when the page has been renamed.

See Also

TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView Fields

TabbedDiagramView Fields
[image]

Public Fields

Name | Description
AllowRenamePagesProperty | Identifies the AllowRenamePages dependency property.
AllowTabReorderProperty | Identifies the AllowTabReorder dependency property.
CurrentPageProperty | Identifies the CurrentPage dependency property.
DocumentProperty | Identifies the Document dependency property.
ShowCreateNewTabProperty | Identifies the ShowCreateNewTab dependency property.
ShowTabCloseButtonsProperty | Identifies the ShowTabCloseButtons dependency property.
ShowTabNavigationButtonsProperty | Identifies the ShowTabNavigationButtons dependency property.
ShowTabsProperty | Identifies the ShowTabs dependency property.
TabAlignmentProperty | Identifies the TabAlignment dependency property.

See Also

TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.AllowRenamePagesProperty Field

TabbedDiagramView.AllowRenamePagesProperty Field
[image]

Identifies the AllowRenamePages dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowRenamePagesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowRenamePagesProperty As DependencyProperty

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.AllowTabReorderProperty Field

TabbedDiagramView.AllowTabReorderProperty Field
[image]

Identifies the AllowTabReorder dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowTabReorderProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowTabReorderProperty As DependencyProperty

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.CurrentPageProperty Field

TabbedDiagramView.CurrentPageProperty Field
[image]

Identifies the CurrentPage dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CurrentPageProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CurrentPageProperty As DependencyProperty

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.DocumentProperty Field

TabbedDiagramView.DocumentProperty Field
[image]

Identifies the Document dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DocumentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DocumentProperty As DependencyProperty

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.ShowCreateNewTabProperty Field

TabbedDiagramView.ShowCreateNewTabProperty Field
[image]

Identifies the ShowCreateNewTab dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowCreateNewTabProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowCreateNewTabProperty As DependencyProperty

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.ShowTabCloseButtonsProperty Field

TabbedDiagramView.ShowTabCloseButtonsProperty Field
[image]

Identifies the ShowTabCloseButtons dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowTabCloseButtonsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowTabCloseButtonsProperty As DependencyProperty

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.ShowTabNavigationButtonsProperty Field

TabbedDiagramView.ShowTabNavigationButtonsProperty Field
[image]

Identifies the ShowTabNavigationButtons dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowTabNavigationButtonsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowTabNavigationButtonsProperty As DependencyProperty

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.ShowTabsProperty Field

TabbedDiagramView.ShowTabsProperty Field
[image]

Identifies the ShowTabs dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowTabsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowTabsProperty As DependencyProperty

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.TabAlignmentProperty Field

TabbedDiagramView.TabAlignmentProperty Field
[image]

Identifies the TabAlignment dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TabAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TabAlignmentProperty As DependencyProperty

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView Constructor

TabbedDiagramView Constructor
[image]

Initializes a new instance of the TabbedDiagramView class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public TabbedDiagramView ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView Methods

TabbedDiagramView Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
OnCurrentPageChanged | Raises the CurrentPageChanged event.
OnPageAdded | Raises the PageAdded event.
OnPageRemoved | Raises the PageRemoved event.
OnPageRemoving | Raises the PageRemoving event.
OnPageRenamed | Raises the PageRenamed event.

See Also

TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.OnApplyTemplate Method

TabbedDiagramView.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Overrides Sub OnApplyTemplate ()

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.OnCurrentPageChanged Method

TabbedDiagramView.OnCurrentPageChanged Method
[image]

Raises the CurrentPageChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

protected virtual void OnCurrentPageChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCurrentPageChanged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.OnPageAdded Method

TabbedDiagramView.OnPageAdded Method
[image]

Raises the PageAdded event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

protected virtual void OnPageAdded (
DiagramPageEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPageAdded( _
e As DiagramPageEventArgs _
)

Parameters

e

An object providing the event data.

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.OnPageRemoved Method

TabbedDiagramView.OnPageRemoved Method
[image]

Raises the PageRemoved event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

protected virtual void OnPageRemoved (
DiagramPageEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPageRemoved( _
e As DiagramPageEventArgs _
)

Parameters

e

An object providing the event data.

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.OnPageRemoving Method

TabbedDiagramView.OnPageRemoving Method
[image]

Raises the PageRemoving event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

protected virtual void OnPageRemoving (
DiagramPageValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPageRemoving( _
e As DiagramPageValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.OnPageRenamed Method

TabbedDiagramView.OnPageRenamed Method
[image]

Raises the PageRenamed event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

protected virtual void OnPageRenamed (
PageRenamedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPageRenamed( _
e As PageRenamedEventArgs _
)

Parameters

e

An object providing the event data.

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView Properties

TabbedDiagramView Properties
[image]

Public Properties

Name | Description
AllowRenamePages | Gets or sets whether DiagramPage titles can be renamed interactively.
AllowTabReorder | Gets or sets a value indicating whether tabs can be rearranged interactively. This is a dependency property.
CurrentPage | Gets or sets the currently active page. This is a dependency property.
Document | Gets or sets the displayed diagram document. This is a dependency property.
ShowCreateNewTab | Gets or sets a value indicating whether to display the 'Create New Tab' button. This is a dependency property.
ShowTabCloseButtons | Gets or sets a value indicating whether to display a close button for each tab. This is a dependency property.
ShowTabNavigationButtons | Gets or sets a value indicating whether the tab navigation buttons. This is a dependency property.
ShowTabs | Gets or sets a value indicating whether the tabs are visible. This is a dependency property.
TabAlignment | Gets or sets the tabs alignment. This is a dependency property.

See Also

TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.AllowRenamePages Property

TabbedDiagramView.AllowRenamePages Property
[image]

Gets or sets whether DiagramPage titles can be renamed interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public bool AllowRenamePages { get; set; }

Visual Basic [image] Copy Code

Public Property AllowRenamePages As Boolean

Property Value

true to let users edit page titles, or false otherwise.

Remarks

When this property is enabled, users can rename the active DiagramPage interactively by clicking its tab.

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming Namespace
PageRenamed Event


MindFusion.Diagramming.TabbedDiagramView.AllowTabReorder Property

TabbedDiagramView.AllowTabReorder Property
[image]

Gets or sets a value indicating whether tabs can be rearranged interactively. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public bool AllowTabReorder { get; set; }

Visual Basic [image] Copy Code

Public Property AllowTabReorder As Boolean

Property Value

true to allow interactive tab reordering; otherwise, false. The default is false.

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.CurrentPage Property

TabbedDiagramView.CurrentPage Property
[image]

Gets or sets the currently active page. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public DiagramPage CurrentPage { get; set; }

Visual Basic [image] Copy Code

Public Property CurrentPage As DiagramPage

Property Value

A DiagramPage object.

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.Document Property

TabbedDiagramView.Document Property
[image]

Gets or sets the displayed diagram document. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public DiagramDocument Document { get; set; }

Visual Basic [image] Copy Code

Public Property Document As DiagramDocument

Property Value

A DiagramDocument object.

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.ShowCreateNewTab Property

TabbedDiagramView.ShowCreateNewTab Property
[image]

Gets or sets a value indicating whether to display the 'Create New Tab' button. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public bool ShowCreateNewTab { get; set; }

Visual Basic [image] Copy Code

Public Property ShowCreateNewTab As Boolean

Property Value

true to enable interactive tab creation; otherwise, false. The default is true.

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.ShowTabCloseButtons Property

TabbedDiagramView.ShowTabCloseButtons Property
[image]

Gets or sets a value indicating whether to display a close button for each tab. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public bool ShowTabCloseButtons { get; set; }

Visual Basic [image] Copy Code

Public Property ShowTabCloseButtons As Boolean

Property Value

true to enable interactive tab deletion; otherwise, false. The default is true.

Remarks

Interactive tab deletion can still be validated through the PageRemoving event.

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.ShowTabNavigationButtons Property

TabbedDiagramView.ShowTabNavigationButtons Property
[image]

Gets or sets a value indicating whether the tab navigation buttons. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public bool ShowTabNavigationButtons { get; set; }

Visual Basic [image] Copy Code

Public Property ShowTabNavigationButtons As Boolean

Property Value

true to enable tab navigation; otherwise, false. The default is true.

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.ShowTabs Property

TabbedDiagramView.ShowTabs Property
[image]

Gets or sets a value indicating whether the tabs are visible. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public bool ShowTabs { get; set; }

Visual Basic [image] Copy Code

Public Property ShowTabs As Boolean

Property Value

true to display the tabs tray; otherwise, false. The default is true.

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.TabAlignment Property

TabbedDiagramView.TabAlignment Property
[image]

Gets or sets the tabs alignment. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public Dock TabAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property TabAlignment As Dock

Property Value

A member of the Dock enumeration. The default is Bottom.

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView Events

TabbedDiagramView Events
[image]

Public Events

Name | Description
CurrentPageChanged | Raised when the currently active page is changed.
PageAdded | Raised when a new page is added to the view interactively, that is, when the user clicks on the 'Create New Tab' button.
PageRemoved | Raised when a page is removed interactively, that is, when the user clicks the close button of its associated tab.
PageRemoving | Raised when a page is about to be removed interactively, that is, when the user clicks the close button of its associated tab.
PageRenamed | Raised when the page has been renamed.

See Also

TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.CurrentPageChanged Event

TabbedDiagramView.CurrentPageChanged Event
[image]

Raised when the currently active page is changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public event EventHandler CurrentPageChanged

Visual Basic [image] Copy Code

Public Event CurrentPageChanged As EventHandler

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.PageAdded Event

TabbedDiagramView.PageAdded Event
[image]

Raised when a new page is added to the view interactively, that is, when the user clicks on the 'Create New Tab' button.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public event EventHandler<DiagramPageEventArgs> PageAdded

Visual Basic [image] Copy Code

Public Event PageAdded As EventHandler(Of DiagramPageEventArgs)

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.PageRemoved Event

TabbedDiagramView.PageRemoved Event
[image]

Raised when a page is removed interactively, that is, when the user clicks the close button of its associated tab.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public event EventHandler<DiagramPageEventArgs> PageRemoved

Visual Basic [image] Copy Code

Public Event PageRemoved As EventHandler(Of DiagramPageEventArgs)

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.PageRemoving Event

TabbedDiagramView.PageRemoving Event
[image]

Raised when a page is about to be removed interactively, that is, when the user clicks the close button of its associated tab.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public event EventHandler<DiagramPageValidationEventArgs> PageRemoving

Visual Basic [image] Copy Code

Public Event PageRemoving As EventHandler(Of DiagramPageValidationEventArgs)

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabbedDiagramView.PageRenamed Event

TabbedDiagramView.PageRenamed Event
[image]

Raised when the page has been renamed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public event EventHandler<PageRenamedEventArgs> PageRenamed

Visual Basic [image] Copy Code

Public Event PageRenamed As EventHandler(Of PageRenamedEventArgs)

Event Data

PageRenamed event handlers receive an argument of type PageRenamedEventArgs.

Remarks

Users can rename pages interactively when the AllowRenamePages property is enabled.

See Also

TabbedDiagramView Members
TabbedDiagramView Class


MindFusion.Diagramming.TabHeaderPanel Class

TabHeaderPanel Class
[image]

This class is for internal use only.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public class TabHeaderPanel : Panel

Visual Basic [image] Copy Code

Public Class TabHeaderPanel
Inherits Panel

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Panel
MindFusion.Diagramming.TabHeaderPanel

See Also

TabHeaderPanel Members


MindFusion.Diagramming.TabHeaderPanel Members

TabHeaderPanel Members
Constructors Fields Properties Methods
[image]

This class is for internal use only.

The following tables list the members exposed by the TabHeaderPanel type.

Public Constructors

Name | Description
TabHeaderPanel | Initializes a new instance of the TabHeaderPanel class.

Public Fields

Name | Description
ScrollOffsetProperty | Identifies the ScrollOffset dependency property.
SelectedIndexProperty | Identifies the SelectedIndex dependency property.
TabAlignmentProperty | Identifies the TabAlignment dependency property.
TabLayoutModeProperty | Identifies the TabLayoutMode dependency property.
TabRotationProperty | Identifies the TabRotation dependency property.
TabStripPlacementProperty | Identifies the TabStripPlacement dependency property.

Public Properties

Name | Description
ScrollOffset | Gets or sets the panel offset. This is a dependency property.
SelectedIndex | Gets or sets the index of the selected tab. This is a dependency property.
TabAlignment | Gets or sets the tab alignment. This is a dependency property.
TabLayoutMode | Gets or sets the tab layout mode. This is a dependency property.
TabRotation | Gets or sets the tab rotation. This is a dependency property.
TabStripPlacement | Gets or sets the tab placement. This is a dependency property.

Protected Methods

Name | Description
ArrangeOverride | FrameworkElement.ArrangeOverride override.
MeasureOverride | FrameworkElement.MeasureOverride override.

See Also

TabHeaderPanel Class


MindFusion.Diagramming.TabHeaderPanel Fields

TabHeaderPanel Fields
[image]

Public Fields

Name | Description
ScrollOffsetProperty | Identifies the ScrollOffset dependency property.
SelectedIndexProperty | Identifies the SelectedIndex dependency property.
TabAlignmentProperty | Identifies the TabAlignment dependency property.
TabLayoutModeProperty | Identifies the TabLayoutMode dependency property.
TabRotationProperty | Identifies the TabRotation dependency property.
TabStripPlacementProperty | Identifies the TabStripPlacement dependency property.

See Also

TabHeaderPanel Class


MindFusion.Diagramming.TabHeaderPanel.ScrollOffsetProperty Field

TabHeaderPanel.ScrollOffsetProperty Field
[image]

Identifies the ScrollOffset dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScrollOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScrollOffsetProperty As DependencyProperty

See Also

TabHeaderPanel Members
TabHeaderPanel Class


MindFusion.Diagramming.TabHeaderPanel.SelectedIndexProperty Field

TabHeaderPanel.SelectedIndexProperty Field
[image]

Identifies the SelectedIndex dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedIndexProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedIndexProperty As DependencyProperty

See Also

TabHeaderPanel Members
TabHeaderPanel Class


MindFusion.Diagramming.TabHeaderPanel.TabAlignmentProperty Field

TabHeaderPanel.TabAlignmentProperty Field
[image]

Identifies the TabAlignment dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TabAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TabAlignmentProperty As DependencyProperty

See Also

TabHeaderPanel Members
TabHeaderPanel Class


MindFusion.Diagramming.TabHeaderPanel.TabLayoutModeProperty Field

TabHeaderPanel.TabLayoutModeProperty Field
[image]

Identifies the TabLayoutMode dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TabLayoutModeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TabLayoutModeProperty As DependencyProperty

See Also

TabHeaderPanel Members
TabHeaderPanel Class


MindFusion.Diagramming.TabHeaderPanel.TabRotationProperty Field

TabHeaderPanel.TabRotationProperty Field
[image]

Identifies the TabRotation dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TabRotationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TabRotationProperty As DependencyProperty

See Also

TabHeaderPanel Members
TabHeaderPanel Class


MindFusion.Diagramming.TabHeaderPanel.TabStripPlacementProperty Field

TabHeaderPanel.TabStripPlacementProperty Field
[image]

Identifies the TabStripPlacement dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TabStripPlacementProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TabStripPlacementProperty As DependencyProperty

See Also

TabHeaderPanel Members
TabHeaderPanel Class


MindFusion.Diagramming.TabHeaderPanel Constructor

TabHeaderPanel Constructor
[image]

Initializes a new instance of the TabHeaderPanel class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public TabHeaderPanel ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TabHeaderPanel Class


MindFusion.Diagramming.TabHeaderPanel Methods

TabHeaderPanel Methods
[image]

Protected Methods

Name | Description
ArrangeOverride | FrameworkElement.ArrangeOverride override.
MeasureOverride | FrameworkElement.MeasureOverride override.

See Also

TabHeaderPanel Class


MindFusion.Diagramming.TabHeaderPanel.ArrangeOverride Method

TabHeaderPanel.ArrangeOverride Method
[image]

FrameworkElement.ArrangeOverride override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

protected override Size ArrangeOverride (
Size finalSize
)

Visual Basic [image] Copy Code

Protected Overrides Function ArrangeOverride( _
finalSize As Size _
) As Size

Parameters

finalSize

Return Value

See Also

TabHeaderPanel Members
TabHeaderPanel Class


MindFusion.Diagramming.TabHeaderPanel.MeasureOverride Method

TabHeaderPanel.MeasureOverride Method
[image]

FrameworkElement.MeasureOverride override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size availableSize
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
availableSize As Size _
) As Size

Parameters

availableSize

Return Value

See Also

TabHeaderPanel Members
TabHeaderPanel Class


MindFusion.Diagramming.TabHeaderPanel Properties

TabHeaderPanel Properties
[image]

Public Properties

Name | Description
ScrollOffset | Gets or sets the panel offset. This is a dependency property.
SelectedIndex | Gets or sets the index of the selected tab. This is a dependency property.
TabAlignment | Gets or sets the tab alignment. This is a dependency property.
TabLayoutMode | Gets or sets the tab layout mode. This is a dependency property.
TabRotation | Gets or sets the tab rotation. This is a dependency property.
TabStripPlacement | Gets or sets the tab placement. This is a dependency property.

See Also

TabHeaderPanel Class


MindFusion.Diagramming.TabHeaderPanel.ScrollOffset Property

TabHeaderPanel.ScrollOffset Property
[image]

Gets or sets the panel offset. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public double ScrollOffset { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollOffset As Double

Property Value

See Also

TabHeaderPanel Members
TabHeaderPanel Class


MindFusion.Diagramming.TabHeaderPanel.SelectedIndex Property

TabHeaderPanel.SelectedIndex Property
[image]

Gets or sets the index of the selected tab. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public int SelectedIndex { get; set; }

Visual Basic [image] Copy Code

Public Property SelectedIndex As Integer

Property Value

See Also

TabHeaderPanel Members
TabHeaderPanel Class


MindFusion.Diagramming.TabHeaderPanel.TabAlignment Property

TabHeaderPanel.TabAlignment Property
[image]

Gets or sets the tab alignment. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public TabAlignment TabAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property TabAlignment As TabAlignment

Property Value

See Also

TabHeaderPanel Members
TabHeaderPanel Class


MindFusion.Diagramming.TabHeaderPanel.TabLayoutMode Property

TabHeaderPanel.TabLayoutMode Property
[image]

Gets or sets the tab layout mode. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public TabLayoutMode TabLayoutMode { get; set; }

Visual Basic [image] Copy Code

Public Property TabLayoutMode As TabLayoutMode

Property Value

See Also

TabHeaderPanel Members
TabHeaderPanel Class


MindFusion.Diagramming.TabHeaderPanel.TabRotation Property

TabHeaderPanel.TabRotation Property
[image]

Gets or sets the tab rotation. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public TabRotation TabRotation { get; set; }

Visual Basic [image] Copy Code

Public Property TabRotation As TabRotation

Property Value

See Also

TabHeaderPanel Members
TabHeaderPanel Class


MindFusion.Diagramming.TabHeaderPanel.TabStripPlacement Property

TabHeaderPanel.TabStripPlacement Property
[image]

Gets or sets the tab placement. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public Dock TabStripPlacement { get; set; }

Visual Basic [image] Copy Code

Public Property TabStripPlacement As Dock

Property Value

See Also

TabHeaderPanel Members
TabHeaderPanel Class


MindFusion.Diagramming.TabLayoutMode Enumeration

TabLayoutMode Enumeration
[image]

Specifies how tab items are arranged in the header of a TabControl.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public enum TabLayoutMode

Visual Basic [image] Copy Code

Public Enum TabLayoutMode

Members

Member name | Description
Scroll | The TabControl can scroll the tab items.
Wrap | The tab items wrap to a new line when the available space is not sufficient.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.TableConnectionStyle Enumeration

TableConnectionStyle Enumeration
[image]

Specifies the possible values for the ConnectionStyle property of tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum TableConnectionStyle

Visual Basic [image] Copy Code

Public Enum TableConnectionStyle

Members

Member name | Description
Both | Users are allowed to create relations both to the rows of a table or the the table as a whole.
Rows | Users are allowed to create relations to the rows of a table.
Table | Users are allowed to create relations to a table as whole entity.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.TableNode Class

TableNode Class
[image]

Tables are diagram nodes that can contain multiple cells and can be related to other nodes through their rows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TableNode : DiagramNode, InplaceEditable

Visual Basic [image] Copy Code

Public Class TableNode
Inherits DiagramNode
Implements InplaceEditable

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
Windows.UI.Xaml.Controls.ContentControl
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.TableNode

See Also

TableNode Members


MindFusion.Diagramming.TableNode Members

TableNode Members
Constructors Fields Properties Methods
[image]

Tables are diagram nodes that can contain multiple cells and can be related to other nodes through their rows.

The following tables list the members exposed by the TableNode type.

Public Constructors

Name | Description
TableNode | Overloaded.

Public Fields

Name | Description
BorderGeometryProperty | Identifies the BorderGeometry dependency property.
BorderRadiusProperty | Identifies the BorderRadius dependency property.
CaptionBackBrushProperty | Identifies the CaptionBackBrush dependency property.
CaptionHeightProperty | Identifies the CaptionHeight dependency property.
CaptionProperty | Identifies the Caption dependency property.
CellTextBrushProperty | Identifies the CellTextBrush dependency property.

Inherited Public Fields

Name | Description
AutoCaptureMouseProperty | Identifies the AutoCaptureMouse dependency property. (Inherited from DiagramItem.)
BoundsProperty | Identifies the Bounds dependency property. (Inherited from DiagramNode.)
BrushProperty | Identifies the Brush dependency property. (Inherited from DiagramItem.)
EffectsSourceProperty | Identifies the EffectsSource dependency property. (Inherited from DiagramNode.)
HyperLinkProperty | Identifies the HyperLink dependency property. (Inherited from DiagramItem.)
IsMouseDownProperty | Identifies the IsMouseDown dependency property. (Inherited from DiagramItem.)
IsMouseOverProperty | Identifies the IsMouseOver dependency property. (Inherited from DiagramItem.)
MasterNodeProperty | Identifies the MasterNode dependency property. (Inherited from DiagramNode.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from DiagramNode.)
ShapeOpacityProperty | Identifies the ShapeOpacity dependency property. (Inherited from DiagramNode.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from DiagramItem.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)

Inherited Protected Fields

Name | Description
handles | A list of the Rectangle objects that represent the item's adjustment handles. (Inherited from DiagramItem.)

Public Properties

Name | Description
BorderGeometry | Gets or sets the RectangleGeometry object that defines the TableNode outline.
BorderRadius | Gets or sets the radius of the TableNode border rectangle.
Caption | Gets or sets the text displayed as caption of the table. This is a dependency property
CaptionBackBrush | Gets or sets the brush used to paint the caption area of this table. This is a dependency property.
CaptionBrush | Gets or sets the color of the text used as table caption.
CaptionHeight | Gets or sets the height of the table's caption area. This is a dependency property.
CellTextBrush | Gets or sets the text color of the table cells. This is a dependency property.
ColumnCount | Gets the number of columns in the table.
Columns | Gets a list of all columns in the table.
ColumnWidth | Gets or sets the default width of the table columns.
Item | Gets or sets the Cell instance at the specified position.
RowAnchorPattern | Gets or sets the default anchor pattern for the rows of a table.
RowCount | Gets the number of rows in the table.
RowHeight | Gets or sets the default height of table rows.
Rows | Gets a list of all rows in the table.

Inherited Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
AttachedNodes | Returns the nodes attached to this node. (Inherited from DiagramNode.)
AutoCaptureMouse | Gets or sets whether the item should capture the mouse input when the left button is pressed over it. This is a dependency property. (Inherited from DiagramItem.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. This is a dependency property. (Inherited from DiagramNode.)
Brush | Gets or sets the Brush that specifies how to paint the interior of the item. This is a dependency property. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Container | Gets the ContainerNode that contains this node. (Inherited from DiagramNode.)
Diagram | Gets the parent diagram. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramItem.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. This is a dependency property. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
IsMouseDown | Gets a value indicating whether the mouse button is pressed over this item. This is a dependency property. (Inherited from DiagramItem.)
IsMouseOver | Gets a value indicating whether the mouse pointer is located over this item. This is a dependency property. (Inherited from DiagramItem.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterNode | Gets the node to which this node is attached. This is a dependency property. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
RotationAngle | Gets or sets the angle at which this node is rotated. This is a dependency property. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShapeOpacity | Gets or sets the shape opacity of this node. This is a dependency property. (Inherited from DiagramNode.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline nodes. This is a dependency property. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashOffset | Gets or sets a double value that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. This is a dependency property. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
ToolTip | Gets or sets the contents of the tooltip displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of the object. (Inherited from DiagramItem.)

Inherited Protected Properties

Name | Description
Size | Gets the size of this item. (Inherited from DiagramItem.)

Public Methods

Name | Description
AddColumn | Adds new empty column at the right end of the table.
AddRow | Adds new empty row at the bottom of the table.
CellFromPoint | Returns the row and column indices of the cell located at the specified point, taking into consideration the cells span.
DeleteColumn | Deletes the column with the specified index within the table.
DeleteRow | Deletes the row at the specified position within the table.
GetIntersection | DiagramNode.GetIntersection override.
InsertColumn | Inserts new empty column at the specified position within the table.
InsertRow | Inserts new empty row at the specified position within the table.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
OnBoundsChanged | DiagramNode.OnBoundsChanged override.
RedimTable | Sets new number of rows and columns for this table.

Protected Methods

Name | Description
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
CreateState | DiagramItem.CreateState override.
GetOutline | DiagramNode.GetOutline override.
LoadFromXml | Loads the item content from an XML element.
RestoreState | DiagramItem.RestoreState override.
SaveState | DiagramItem.SaveState override.
SaveToXml | Saves the item content into an XML element.
ScaleElements | DiagramNode.ScaleElements override.
SetReflexive | DiagramNode.SetReflexive override.

Inherited Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
Attach | Attaches the specified subordinate node to this node, so that when this node is moved, the subordinate follows it. (Inherited from DiagramNode.)
AttachTo | Attaches this node to the specified master node so that when the master is moved, the attached node follows it. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
ContainsPoint | DiagramItem.ContainsPoint override. (Inherited from DiagramNode.)
Detach | Overloaded. (Inherited from DiagramNode.)
GetAllIncomingLinks | Gets a collection of all links entering this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Get a collection of all links going out of this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from DiagramNode.)
OnBoundsChanged | Called when the location and size of this node change. (Inherited from DiagramNode.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RestoreLocationState | DiagramItem.RestoreLocationState override. (Inherited from DiagramNode.)
SaveLocationState | DiagramItem.SaveLocationState override. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point in diagram coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Gets the diagram coordinates of a point specified in the local coordinate system of this item. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Inherited Protected Methods

Name | Description
AddAnchorPointVisuals | Adds the AnchorPatern points to the node's Adorner. (Inherited from DiagramNode.)
AddExpandButton | Adds the ExpandButton to the node's Adoner. (Inherited from DiagramNode.)
AddHandlesToCanvas | Overloaded. (Inherited from DiagramNode.)
AllowDrag | Invoked to validate the drag operation. (Inherited from DiagramItem.)
CancelDrag | DiagramItem.CancelDrag override. (Inherited from DiagramNode.)
CreateAnchorPointVisual | Creates a Path that represents the specified AnchorPoint. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
EndDrag | DiagramItem.EndDrag override. (Inherited from DiagramNode.)
GetOutline | Creates a Geometry object that describes the outline of the node. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
LoadFromXml | DiagramItem.LoadFromXml override. (Inherited from DiagramNode.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramNode.)
OnMouseEnter | Control.OnMouseEnter override. (Inherited from DiagramItem.)
OnMouseLeave | Control.OnMouseLeave override. (Inherited from DiagramItem.)
OnMouseLeftButtonDown | Control.OnMouseLeftButtonDown override. (Inherited from DiagramItem.)
OnMouseLeftButtonUp | Control.OnMouseLeftButtonUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
RemoveAnchorPointVisuals | Removes the AnchorPatern points from the node's Adorner. (Inherited from DiagramNode.)
RemoveHandlesFromCanvas | Invoked when the item's selection handles should be removed. (Inherited from DiagramItem.)
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramNode.)
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
StartDrag | DiagramItem.StartDrag override. (Inherited from DiagramNode.)
UpdateDrag | DiagramItem.UpdateDrag override. (Inherited from DiagramNode.)
UpdateHandleColors | Sets the handle colors according to the current selection state of the item and the enabled bits in the EnabledHandles property. (Inherited from DiagramItem.)
UpdateHandlePositions | Invoked when the item's selection handles should change their position. (Inherited from DiagramItem.)
UpdateStates | Sets the current VisualStates of this item. (Inherited from DiagramItem.)
UpdateVisuals | DiagramItem.UpdateVisuals override. (Inherited from DiagramNode.)

See Also

TableNode Class


MindFusion.Diagramming.TableNode Fields

TableNode Fields
[image]

Public Fields

Name | Description
BorderGeometryProperty | Identifies the BorderGeometry dependency property.
BorderRadiusProperty | Identifies the BorderRadius dependency property.
CaptionBackBrushProperty | Identifies the CaptionBackBrush dependency property.
CaptionHeightProperty | Identifies the CaptionHeight dependency property.
CaptionProperty | Identifies the Caption dependency property.
CellTextBrushProperty | Identifies the CellTextBrush dependency property.

Inherited Public Fields

Name | Description
AutoCaptureMouseProperty | Identifies the AutoCaptureMouse dependency property. (Inherited from DiagramItem.)
BoundsProperty | Identifies the Bounds dependency property. (Inherited from DiagramNode.)
BrushProperty | Identifies the Brush dependency property. (Inherited from DiagramItem.)
EffectsSourceProperty | Identifies the EffectsSource dependency property. (Inherited from DiagramNode.)
HyperLinkProperty | Identifies the HyperLink dependency property. (Inherited from DiagramItem.)
IsMouseDownProperty | Identifies the IsMouseDown dependency property. (Inherited from DiagramItem.)
IsMouseOverProperty | Identifies the IsMouseOver dependency property. (Inherited from DiagramItem.)
MasterNodeProperty | Identifies the MasterNode dependency property. (Inherited from DiagramNode.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from DiagramNode.)
ShapeOpacityProperty | Identifies the ShapeOpacity dependency property. (Inherited from DiagramNode.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from DiagramItem.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)

Inherited Protected Fields

Name | Description
handles | A list of the Rectangle objects that represent the item's adjustment handles. (Inherited from DiagramItem.)

See Also

TableNode Class


MindFusion.Diagramming.TableNode.BorderGeometryProperty Field

TableNode.BorderGeometryProperty Field
[image]

Identifies the BorderGeometry dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BorderGeometryProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BorderGeometryProperty As DependencyProperty

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.BorderRadiusProperty Field

TableNode.BorderRadiusProperty Field
[image]

Identifies the BorderRadius dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BorderRadiusProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BorderRadiusProperty As DependencyProperty

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.CaptionBackBrushProperty Field

TableNode.CaptionBackBrushProperty Field
[image]

Identifies the CaptionBackBrush dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CaptionBackBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CaptionBackBrushProperty As DependencyProperty

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.CaptionHeightProperty Field

TableNode.CaptionHeightProperty Field
[image]

Identifies the CaptionHeight dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CaptionHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CaptionHeightProperty As DependencyProperty

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.CaptionProperty Field

TableNode.CaptionProperty Field
[image]

Identifies the Caption dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CaptionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CaptionProperty As DependencyProperty

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.CellTextBrushProperty Field

TableNode.CellTextBrushProperty Field
[image]

Identifies the CellTextBrush dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellTextBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CellTextBrushProperty As DependencyProperty

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode Constructor

TableNode Constructor
[image]

Overload List

Name | Description
TableNode () | Initializes a new instance of the TableNode class.
TableNode (Diagram) | Initializes a new instance of the TableNode class.
TableNode (TableNode) | Initializes a new instance of the TableNode class using the specified node as a prototype.

See Also

TableNode Class


MindFusion.Diagramming.TableNode Constructor ()

TableNode Constructor ()
See Also
[image]

Initializes a new instance of the TableNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode ()

Visual Basic [image] Copy Code

Public Sub New ()

Remarks

This constructor leaves the node's dependency properties in their default state, without local values. This allows the node to be styled through the WinRT styling mechanism.

See Also

TableNode Constructor Overload List
TableNode Class


MindFusion.Diagramming.TableNode Constructor (Diagram)

TableNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the TableNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode (
Diagram parent
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram _
)

Parameters

parent

The Diagram from which to obtain default values for the node properties.

Remarks

This constructor initializes the TableNode properties with the values specified in the respective default-value properties of the Diagram object.

See Also

TableNode Constructor Overload List
TableNode Class


MindFusion.Diagramming.TableNode Constructor (TableNode)

TableNode Constructor (TableNode)
See Also
[image]

Initializes a new instance of the TableNode class using the specified node as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode (
TableNode prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As TableNode _
)

Parameters

prototype
The table node to use as a prototype. The properties of the new table are initialized from the property values of prototype.

Remarks

This constructor copies the TableNode property values from the specified prototype node.

See Also

TableNode Constructor Overload List
TableNode Class


MindFusion.Diagramming.TableNode Methods

TableNode Methods
[image]

Public Methods

Name | Description
AddColumn | Adds new empty column at the right end of the table.
AddRow | Adds new empty row at the bottom of the table.
CellFromPoint | Returns the row and column indices of the cell located at the specified point, taking into consideration the cells span.
DeleteColumn | Deletes the column with the specified index within the table.
DeleteRow | Deletes the row at the specified position within the table.
GetIntersection | DiagramNode.GetIntersection override.
InsertColumn | Inserts new empty column at the specified position within the table.
InsertRow | Inserts new empty row at the specified position within the table.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
OnBoundsChanged | DiagramNode.OnBoundsChanged override.
RedimTable | Sets new number of rows and columns for this table.

Protected Methods

Name | Description
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
CreateState | DiagramItem.CreateState override.
GetOutline | DiagramNode.GetOutline override.
LoadFromXml | Loads the item content from an XML element.
RestoreState | DiagramItem.RestoreState override.
SaveState | DiagramItem.SaveState override.
SaveToXml | Saves the item content into an XML element.
ScaleElements | DiagramNode.ScaleElements override.
SetReflexive | DiagramNode.SetReflexive override.

Inherited Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
Attach | Attaches the specified subordinate node to this node, so that when this node is moved, the subordinate follows it. (Inherited from DiagramNode.)
AttachTo | Attaches this node to the specified master node so that when the master is moved, the attached node follows it. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
ContainsPoint | DiagramItem.ContainsPoint override. (Inherited from DiagramNode.)
Detach | Overloaded. (Inherited from DiagramNode.)
GetAllIncomingLinks | Gets a collection of all links entering this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Get a collection of all links going out of this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from DiagramNode.)
OnBoundsChanged | Called when the location and size of this node change. (Inherited from DiagramNode.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RestoreLocationState | DiagramItem.RestoreLocationState override. (Inherited from DiagramNode.)
SaveLocationState | DiagramItem.SaveLocationState override. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point in diagram coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Gets the diagram coordinates of a point specified in the local coordinate system of this item. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Inherited Protected Methods

Name | Description
AddAnchorPointVisuals | Adds the AnchorPatern points to the node's Adorner. (Inherited from DiagramNode.)
AddExpandButton | Adds the ExpandButton to the node's Adoner. (Inherited from DiagramNode.)
AddHandlesToCanvas | Overloaded. (Inherited from DiagramNode.)
AllowDrag | Invoked to validate the drag operation. (Inherited from DiagramItem.)
CancelDrag | DiagramItem.CancelDrag override. (Inherited from DiagramNode.)
CreateAnchorPointVisual | Creates a Path that represents the specified AnchorPoint. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
EndDrag | DiagramItem.EndDrag override. (Inherited from DiagramNode.)
GetOutline | Creates a Geometry object that describes the outline of the node. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
LoadFromXml | DiagramItem.LoadFromXml override. (Inherited from DiagramNode.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramNode.)
OnMouseEnter | Control.OnMouseEnter override. (Inherited from DiagramItem.)
OnMouseLeave | Control.OnMouseLeave override. (Inherited from DiagramItem.)
OnMouseLeftButtonDown | Control.OnMouseLeftButtonDown override. (Inherited from DiagramItem.)
OnMouseLeftButtonUp | Control.OnMouseLeftButtonUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
RemoveAnchorPointVisuals | Removes the AnchorPatern points from the node's Adorner. (Inherited from DiagramNode.)
RemoveHandlesFromCanvas | Invoked when the item's selection handles should be removed. (Inherited from DiagramItem.)
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramNode.)
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
StartDrag | DiagramItem.StartDrag override. (Inherited from DiagramNode.)
UpdateDrag | DiagramItem.UpdateDrag override. (Inherited from DiagramNode.)
UpdateHandleColors | Sets the handle colors according to the current selection state of the item and the enabled bits in the EnabledHandles property. (Inherited from DiagramItem.)
UpdateHandlePositions | Invoked when the item's selection handles should change their position. (Inherited from DiagramItem.)
UpdateStates | Sets the current VisualStates of this item. (Inherited from DiagramItem.)
UpdateVisuals | DiagramItem.UpdateVisuals override. (Inherited from DiagramNode.)

See Also

TableNode Class


MindFusion.Diagramming.TableNode.AddColumn Method

TableNode.AddColumn Method
[image]

Adds new empty column at the right end of the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int AddColumn ()

Visual Basic [image] Copy Code

Public Function AddColumn () As Integer

Return Value

Returns the index of the newly added column within the Columns collection.

Remarks

Call the method to add new columns at the end of the table. The size of the table is automatically updated and the columns are added to the column collection.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.AddRow Method

TableNode.AddRow Method
[image]

Adds new empty row at the bottom of the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int AddRow ()

Visual Basic [image] Copy Code

Public Function AddRow () As Integer

Return Value

Returns the index of the newly added row within the Rows collection.

Remarks

Call the method to add new rows at the end of the table. The size of the table is automatically updated and the rows are added to the row collection.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.CellFromPoint Method

TableNode.CellFromPoint Method
[image]

Returns the row and column indices of the cell located at the specified point, taking into consideration the cells span.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool CellFromPoint (
Point point,
bool isDiagramCoordinate,
ref int row,
ref int col
)

Visual Basic [image] Copy Code

Public Function CellFromPoint( _
point As Point, _
isDiagramCoordinate As Boolean, _
ByRef row As Integer, _
ByRef col As Integer _
) As Boolean

Parameters

point

The point to check.

isDiagramCoordinate
true if the point is specified in logical diagram coordinates; false if the point is specified in local coordinates with respect to the table.
row

Receives the row index if a cell is found at the specified position.

col

Receives the column index if a cell is found at the specified position.

Return Value

true if a cell of this table contains the specified point; otherwise, false.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.CreateConnectionPoint Method

TableNode.CreateConnectionPoint Method
[image]

DiagramNode.CreateConnectionPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual ConnectionPoint CreateConnectionPoint (
DiagramLink link,
Point pt,
bool incoming
)

Visual Basic [image] Copy Code

Protected Overridable Function CreateConnectionPoint ( _
link As DiagramLink, _
pt As Point, _
incoming As Boolean _
) As ConnectionPoint

Parameters

link
A DiagramLink that should be connected to this node.
pt

The point at which the link should be connected.

incoming
true if link is an incoming link; otherwise, false.

Return Value

A ConnectionPoint instance representing the connection.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.CreateState Method

TableNode.CreateState Method
[image]

DiagramItem.CreateState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramItemState CreateState ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateState () As DiagramItemState

Return Value

A TableNodeState instance.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.DeleteColumn Method

TableNode.DeleteColumn Method
[image]

Deletes the column with the specified index within the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void DeleteColumn (
int col
)

Visual Basic [image] Copy Code

Public Sub DeleteColumn( _
col As Integer _
)

Parameters

col

The zero-based index of the column to be deleted.

Remarks

Call the method to delete a column from the table. The size of the table is automatically updated and the columns are removed from the column collection.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.DeleteRow Method

TableNode.DeleteRow Method
[image]

Deletes the row at the specified position within the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void DeleteRow (
int row
)

Visual Basic [image] Copy Code

Public Sub DeleteRow( _
row As Integer _
)

Parameters

row

The zero-based index of the row to be deleted.

Remarks

Call the method to delete a row from the table. The size of the table is automatically updated and the rows are removed from the row collection.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.GetIntersection Method

TableNode.GetIntersection Method
[image]

DiagramNode.GetIntersection override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Point GetIntersection (
Point segmentStart,
Point segmentEnd
)

Visual Basic [image] Copy Code

Public Overrides Function GetIntersection( _
segmentStart As Point, _
segmentEnd As Point _
) As Point

Parameters

segmentStart

The first point of the segment.

segmentEnd

The second point of the segment.

Return Value

A Point object representing the intersection point.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.GetOutline Method

TableNode.GetOutline Method
[image]

DiagramNode.GetOutline override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Geometry GetOutline ()

Visual Basic [image] Copy Code

Protected Overrides Function GetOutline () As Geometry

Return Value

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.InsertColumn Method

TableNode.InsertColumn Method
[image]

Inserts new empty column at the specified position within the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void InsertColumn (
int col
)

Visual Basic [image] Copy Code

Public Sub InsertColumn( _
col As Integer _
)

Parameters

col

The zero-based index of the column to be inserted.

Remarks

Call the method to add new column at a given position in the table. The size of the table is automatically updated and the columns are added to the column collection.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.InsertRow Method

TableNode.InsertRow Method
[image]

Inserts new empty row at the specified position within the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void InsertRow (
int row
)

Visual Basic [image] Copy Code

Public Sub InsertRow( _
row As Integer _
)

Parameters

row

The zero-based index of the row to be inserted.

Remarks

Call the method to add new row at a given position in the table. The size of the table is automatically updated and the rows are added to the row collection.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.LoadFromXml Method

TableNode.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFromXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFromXml ( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement containing the item's data.

context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.OnApplyTemplate Method

TableNode.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Overrides Sub OnApplyTemplate ()

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.OnBoundsChanged Method

TableNode.OnBoundsChanged Method
[image]

DiagramNode.OnBoundsChanged override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void OnBoundsChanged (
Rect oldRect,
Rect newRect,
bool updateLinks,
bool updateChildren,
bool updateStorage
)

Visual Basic [image] Copy Code

Public Overrides Sub OnBoundsChanged( _
oldRect As Rect, _
newRect As Rect, _
updateLinks As Boolean, _
updateChildren As Boolean, _
updateStorage As Boolean _
)

Parameters

oldRect

newRect

updateLinks

updateChildren

updateStorage

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.RedimTable Method

TableNode.RedimTable Method
[image]

Sets new number of rows and columns for this table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RedimTable (
int cols,
int rows
)

Visual Basic [image] Copy Code

Public Sub RedimTable( _
cols As Integer, _
rows As Integer _
)

Parameters

cols

The new number of columns.

rows

The new number of rows.

Remarks

This method does not preserve the old contents of table cells. After its invocation all cells are empty and columns and rows are with default sizes.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.RestoreState Method

TableNode.RestoreState Method
[image]

DiagramItem.RestoreState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void RestoreState (
DiagramItemState itemState
)

Visual Basic [image] Copy Code

Protected Overridable Sub RestoreState ( _
itemState As DiagramItemState _
)

Parameters

itemState
A TableNodeState instance.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.SaveState Method

TableNode.SaveState Method
[image]

DiagramItem.SaveState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramItemState SaveState ()

Visual Basic [image] Copy Code

Protected Overridable Function SaveState () As DiagramItemState

Return Value

A TableNodeState instance.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.SaveToXml Method

TableNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveToXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveToXml ( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement the item's data should be stored into.

context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.ScaleElements Method

TableNode.ScaleElements Method
[image]

DiagramNode.ScaleElements override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void ScaleElements (
double scale
)

Visual Basic [image] Copy Code

Protected Overrides Sub ScaleElements( _
scale As Double _
)

Parameters

scale

The value by which to multiply node elements' sizes.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.SetReflexive Method

TableNode.SetReflexive Method
[image]

DiagramNode.SetReflexive override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SetReflexive (
Action action,
DiagramLink link
)

Visual Basic [image] Copy Code

Protected Overridable Sub SetReflexive ( _
action As Action, _
link As DiagramLink _
)

Parameters

action

Specifies whether the link has been created or modified.

link

Reference to the link.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode Properties

TableNode Properties
[image]

Public Properties

Name | Description
BorderGeometry | Gets or sets the RectangleGeometry object that defines the TableNode outline.
BorderRadius | Gets or sets the radius of the TableNode border rectangle.
Caption | Gets or sets the text displayed as caption of the table. This is a dependency property
CaptionBackBrush | Gets or sets the brush used to paint the caption area of this table. This is a dependency property.
CaptionBrush | Gets or sets the color of the text used as table caption.
CaptionHeight | Gets or sets the height of the table's caption area. This is a dependency property.
CellTextBrush | Gets or sets the text color of the table cells. This is a dependency property.
ColumnCount | Gets the number of columns in the table.
Columns | Gets a list of all columns in the table.
ColumnWidth | Gets or sets the default width of the table columns.
Item | Gets or sets the Cell instance at the specified position.
RowAnchorPattern | Gets or sets the default anchor pattern for the rows of a table.
RowCount | Gets the number of rows in the table.
RowHeight | Gets or sets the default height of table rows.
Rows | Gets a list of all rows in the table.

Inherited Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
AttachedNodes | Returns the nodes attached to this node. (Inherited from DiagramNode.)
AutoCaptureMouse | Gets or sets whether the item should capture the mouse input when the left button is pressed over it. This is a dependency property. (Inherited from DiagramItem.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. This is a dependency property. (Inherited from DiagramNode.)
Brush | Gets or sets the Brush that specifies how to paint the interior of the item. This is a dependency property. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Container | Gets the ContainerNode that contains this node. (Inherited from DiagramNode.)
Diagram | Gets the parent diagram. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramItem.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. This is a dependency property. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
IsMouseDown | Gets a value indicating whether the mouse button is pressed over this item. This is a dependency property. (Inherited from DiagramItem.)
IsMouseOver | Gets a value indicating whether the mouse pointer is located over this item. This is a dependency property. (Inherited from DiagramItem.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterNode | Gets the node to which this node is attached. This is a dependency property. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
RotationAngle | Gets or sets the angle at which this node is rotated. This is a dependency property. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShapeOpacity | Gets or sets the shape opacity of this node. This is a dependency property. (Inherited from DiagramNode.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline nodes. This is a dependency property. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashOffset | Gets or sets a double value that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. This is a dependency property. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
ToolTip | Gets or sets the contents of the tooltip displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of the object. (Inherited from DiagramItem.)

Inherited Protected Properties

Name | Description
Size | Gets the size of this item. (Inherited from DiagramItem.)

See Also

TableNode Class


MindFusion.Diagramming.TableNode.BorderGeometry Property

TableNode.BorderGeometry Property
[image]

Gets or sets the RectangleGeometry object that defines the TableNode outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleGeometry BorderGeometry { get; set; }

Visual Basic [image] Copy Code

Public Property BorderGeometry As RectangleGeometry

Property Value

A Windows.UI.Xaml.Media.RectangleGeometry object generated automatically according to the node's Bounds and BorderRadius values.

Remarks

This object is used by the table's control template to render its border.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.BorderRadius Property

TableNode.BorderRadius Property
[image]

Gets or sets the radius of the TableNode border rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double BorderRadius { get; set; }

Visual Basic [image] Copy Code

Public Property BorderRadius As Double

Property Value

A double value specifying the radius of the border round corners. The default is 8.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.Caption Property

TableNode.Caption Property
[image]

Gets or sets the text displayed as caption of the table. This is a dependency property

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Caption { get; set; }

Visual Basic [image] Copy Code

Public Property Caption As String

Property Value

A string containing the text of the caption.

Remarks

Text color and alignment can be customized by the CaptionBrush, CaptionBackBrush, and CaptionHeight properties. Styled text allows applying various attributes to the text characters. Attributes are specified by embedding HTML-like formatting tags within the raw text.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.CaptionBackBrush Property

TableNode.CaptionBackBrush Property
[image]

Gets or sets the brush used to paint the caption area of this table. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush CaptionBackBrush { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionBackBrush As Brush

Property Value

An instance of a Windows.UI.Xaml.Media.Brush-derived class.

Remarks

This property refers to a brush object used to paint the interior of the caption area. You can assign to it an instance of one of the following classes: GradientBrush, SolidColorBrush or TileBrush, located in the Windows.UI.Xaml.Media namespace. If there is no brush assigned to this property, the caption area is painted using the Brush property of the TableNode class.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.CaptionBrush Property

TableNode.CaptionBrush Property
[image]

Gets or sets the color of the text used as table caption.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush CaptionBrush { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionBrush As Brush

Property Value

An instance of a Windows.UI.Xaml.Media.Brush-derived class. The default is Brushes.Black.

Remarks

Use the property to make table caption more distinguished.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.CaptionHeight Property

TableNode.CaptionHeight Property
[image]

Gets or sets the height of the table's caption area. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double CaptionHeight { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionHeight As Double

Property Value

Remarks

Keep in mind that tables are moved by clicking their captions and dragging. Don't make captions too narrow or they would become harder to move.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.CellTextBrush Property

TableNode.CellTextBrush Property
[image]

Gets or sets the text color of the table cells. This is a dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush CellTextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property CellTextBrush As Brush

Property Value

An instance of a Windows.UI.Xaml.Media.Brush-derived class. The default is Brushes.Black.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.ColumnCount Property

TableNode.ColumnCount Property
[image]

Gets the number of columns in the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ColumnCount { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ColumnCount As Integer

Property Value

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.Columns Property

TableNode.Columns Property
[image]

Gets a list of all columns in the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<Column> Columns { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Columns As List(Of Column)

Property Value

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.ColumnWidth Property

TableNode.ColumnWidth Property
[image]

Gets or sets the default width of the table columns.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ColumnWidth { get; set; }

Visual Basic [image] Copy Code

Public Property ColumnWidth As Double

Property Value

Remarks

The value of this property is used to initialize the width of new columns when they are created.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.Item Property

TableNode.Item Property
[image]

Gets or sets the Cell instance at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Cell Item [
int col,
int row
] { get; set; }

Visual Basic [image] Copy Code

Public Property Item ( _
col As Integer, _
row As Integer _
) As Cell

Parameters

col
The zero-based index of the cell's column.
row

The zero-based index of the cell's row.

Property Value

An instance of the Cell class that represents the cell of the table at the specified position.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.RowAnchorPattern Property

TableNode.RowAnchorPattern Property
[image]

Gets or sets the default anchor pattern for the rows of a table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern RowAnchorPattern { get; set; }

Visual Basic [image] Copy Code

Public Property RowAnchorPattern As AnchorPattern

Property Value

An instance of the AnchorPattern class.

Remarks

RowAnchorPattern defines a set of locations where links connected to a row are allowed to connect. When a link is connected to a row, the respective end of the link is aligned to the nearest AnchorPoint assigned to that row. If a row does not have associated anchor points of the appropriate type (incoming/outgoing), the link will be connected to the nearest row that has such anchors defined. If none of the rows of a table has an associated anchor pattern, links are connected to the middle of the left or right side of the pointed row.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.RowCount Property

TableNode.RowCount Property
[image]

Gets the number of rows in the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int RowCount { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RowCount As Integer

Property Value

Remarks

If you increase the number of rows the content of the initial rows will remain intact. If you decrease the number, the last rows are removed and the other remain unchanged.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.RowHeight Property

TableNode.RowHeight Property
[image]

Gets or sets the default height of table rows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double RowHeight { get; set; }

Visual Basic [image] Copy Code

Public Property RowHeight As Double

Property Value

Remarks

The value of this property is used to initialize the height of new rows when they are created.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.Rows Property

TableNode.Rows Property
[image]

Gets a list of all rows in the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<Row> Rows { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Rows As List(Of Row)

Property Value

Remarks

The property refers to the collection of all rows that compose the table. Do not add or remove rows through this collection, but use the table's AddRow, InsertRow or DeleteRow methods.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNodeState Class

TableNodeState Class
[image]

Represents the state of a TableNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TableNodeState : DiagramNodeState

Visual Basic [image] Copy Code

Public Class TableNodeState
Inherits DiagramNodeState

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemState
MindFusion.Diagramming.DiagramNodeState
MindFusion.Diagramming.TableNodeState

See Also

TableNodeState Members


MindFusion.Diagramming.TableNodeState Members

TableNodeState Members
Constructors
[image]

Represents the state of a TableNode.

The following tables list the members exposed by the TableNodeState type.

Public Constructors

Name | Description
TableNodeState |

See Also

TableNodeState Class


MindFusion.Diagramming.TableNodeState Constructor

TableNodeState Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNodeState ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TableNodeState Class


MindFusion.Diagramming.TabRotation Enumeration

TabRotation Enumeration
[image]

Specifies the rotation of the tab items in a DiagramTabControl.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public enum TabRotation

Visual Basic [image] Copy Code

Public Enum TabRotation

Members

Member name | Description
Clockwise | Indicates that the items are rotated clockwise.
Counterclockwise | Indicates that the items are rotated counterclockwise.
None | Indicates that the items are not rotated.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.TabThicknessConverter Class

TabThicknessConverter Class
[image]

Converts Dock to Thickness.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public class TabThicknessConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class TabThicknessConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.TabThicknessConverter

See Also

TabThicknessConverter Members


MindFusion.Diagramming.TabThicknessConverter Members

TabThicknessConverter Members
Constructors Methods
[image]

Converts Dock to Thickness.

The following tables list the members exposed by the TabThicknessConverter type.

Public Constructors

Name | Description
TabThicknessConverter |

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

TabThicknessConverter Class


MindFusion.Diagramming.TabThicknessConverter Constructor

TabThicknessConverter Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public TabThicknessConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TabThicknessConverter Class


MindFusion.Diagramming.TabThicknessConverter Methods

TabThicknessConverter Methods
[image]

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

TabThicknessConverter Class


MindFusion.Diagramming.TabThicknessConverter.Convert Method

TabThicknessConverter.Convert Method
[image]

IValueConverter.Convert implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo l
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
l As CultureInfo _
) As Object

Parameters

value

targetType

parameter

l

Return Value

See Also

TabThicknessConverter Members
TabThicknessConverter Class


MindFusion.Diagramming.TabThicknessConverter.ConvertBack Method

TabThicknessConverter.ConvertBack Method
[image]

IValueConverter.ConvertBack implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.Controls

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo l
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
l As CultureInfo _
) As Object

Parameters

value

targetType

parameter

l

Return Value

See Also

TabThicknessConverter Members
TabThicknessConverter Class


MindFusion.Diagramming.TextWrappingConverter Class

TextWrappingConverter Class
[image]

Converts boolean values to TextWrapping values.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TextWrappingConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class TextWrappingConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.TextWrappingConverter

See Also

TextWrappingConverter Members


MindFusion.Diagramming.TextWrappingConverter Members

TextWrappingConverter Members
Constructors Methods
[image]

Converts boolean values to TextWrapping values.

The following tables list the members exposed by the TextWrappingConverter type.

Public Constructors

Name | Description
TextWrappingConverter |

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

TextWrappingConverter Class


MindFusion.Diagramming.TextWrappingConverter Constructor

TextWrappingConverter Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TextWrappingConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TextWrappingConverter Class


MindFusion.Diagramming.TextWrappingConverter Methods

TextWrappingConverter Methods
[image]

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

TextWrappingConverter Class


MindFusion.Diagramming.TextWrappingConverter.Convert Method

TextWrappingConverter.Convert Method
[image]

IValueConverter.Convert implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo l
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
l As CultureInfo _
) As Object

Parameters

value

targetType

parameter

l

Return Value

See Also

TextWrappingConverter Members
TextWrappingConverter Class


MindFusion.Diagramming.TextWrappingConverter.ConvertBack Method

TextWrappingConverter.ConvertBack Method
[image]

IValueConverter.ConvertBack implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo l
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
l As CultureInfo _
) As Object

Parameters

value

targetType

parameter

l

Return Value

See Also

TextWrappingConverter Members
TextWrappingConverter Class


MindFusion.Diagramming.Theme Class

Theme Class
[image]

Represents a set of Style objects for different diagram item types.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Theme

Visual Basic [image] Copy Code

Public Class Theme

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Theme

See Also

Theme Members
MindFusion.Diagramming Namespace
Styles and Themes


MindFusion.Diagramming.Theme Members

Theme Members
Constructors Methods
[image]

Represents a set of Style objects for different diagram item types.

The following tables list the members exposed by the Theme type.

Public Constructors

Name | Description
Theme | Initializes a new instance of the Theme class.

Public Methods

Name | Description
GetStyle | Gets the Style object, if any, associated with the specified type.
LoadFromString | Loads the theme from an XML string.
LoadFromXml | Overloaded.
RegisterStyle | Registers the specified Style object for the items of the specified type.
SaveToString | Saves the theme into an XML string.
SaveToXml | Overloaded.
UnregisterStyle | Unregisters the Style object associated with the specified type.

See Also

Theme Class


MindFusion.Diagramming.Theme Constructor

Theme Constructor
[image]

Initializes a new instance of the Theme class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Theme ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Theme Class


MindFusion.Diagramming.Theme Methods

Theme Methods
[image]

Public Methods

Name | Description
GetStyle | Gets the Style object, if any, associated with the specified type.
LoadFromString | Loads the theme from an XML string.
LoadFromXml | Overloaded.
RegisterStyle | Registers the specified Style object for the items of the specified type.
SaveToString | Saves the theme into an XML string.
SaveToXml | Overloaded.
UnregisterStyle | Unregisters the Style object associated with the specified type.

See Also

Theme Class


MindFusion.Diagramming.Theme.GetStyle Method

Theme.GetStyle Method
[image]

Gets the Style object, if any, associated with the specified type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Style GetStyle (
Type type
)

Visual Basic [image] Copy Code

Public Function GetStyle( _
type As Type _
) As Style

Parameters

type

The runtime type whose style to retrieve.

Return Value

The Style associated with the type, or null.

See Also

Theme Members
Theme Class


MindFusion.Diagramming.Theme.LoadFromString Method

Theme.LoadFromString Method
[image]

Loads the theme from an XML string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromString (
string xml
)

Visual Basic [image] Copy Code

Public Sub LoadFromString( _
xml As String _
)

Parameters

xml

The string to load from.

See Also

Theme Members
Theme Class


MindFusion.Diagramming.Theme.LoadFromXml Method

Theme.LoadFromXml Method
[image]

Overload List

Name | Description
Theme.LoadFromXml (Stream) | Loads the theme from a stream.
Theme.LoadFromXml (String) | Loads the theme from an XML file.

See Also

Theme Members
Theme Class


MindFusion.Diagramming.Theme.LoadFromXml Method (Stream)

Theme.LoadFromXml Method (Stream)
See Also
[image]

Loads the theme from a stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
Stream stream
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
stream As Stream _
)

Parameters

stream

See Also

LoadFromXml Method Overload List
Theme Members
Theme Class


MindFusion.Diagramming.Theme.LoadFromXml Method (String)

Theme.LoadFromXml Method (String)
See Also
[image]

Loads the theme from an XML file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
fileName As String _
)

Parameters

fileName

The name of the file to load from.

See Also

LoadFromXml Method Overload List
Theme Members
Theme Class


MindFusion.Diagramming.Theme.RegisterStyle Method

Theme.RegisterStyle Method
[image]

Registers the specified Style object for the items of the specified type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RegisterStyle (
Type type,
Style style
)

Visual Basic [image] Copy Code

Public Sub RegisterStyle( _
type As Type, _
style As Style _
)

Parameters

type

The runtime type to register.

style

The style to associate with the specified type. The previously associated style, if any, is discarded.

See Also

Theme Members
Theme Class


MindFusion.Diagramming.Theme.SaveToString Method

Theme.SaveToString Method
[image]

Saves the theme into an XML string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string SaveToString ()

Visual Basic [image] Copy Code

Public Function SaveToString () As String

Return Value

The serialized string.

See Also

Theme Members
Theme Class


MindFusion.Diagramming.Theme.SaveToXml Method

Theme.SaveToXml Method
[image]

Overload List

Name | Description
Theme.SaveToXml (Stream) | Saves the theme to an XML file.
Theme.SaveToXml (String) | Saves the theme to the specified file in an XML format.

See Also

Theme Members
Theme Class


MindFusion.Diagramming.Theme.SaveToXml Method (Stream)

Theme.SaveToXml Method (Stream)
See Also
[image]

Saves the theme to an XML file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
Stream stream
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
stream As Stream _
)

Parameters

stream

The stream to save to.

See Also

SaveToXml Method Overload List
Theme Members
Theme Class


MindFusion.Diagramming.Theme.SaveToXml Method (String)

Theme.SaveToXml Method (String)
See Also
[image]

Saves the theme to the specified file in an XML format.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
fileName As String _
)

Parameters

fileName

The name of the file where the theme should be saved.

See Also

SaveToXml Method Overload List
Theme Members
Theme Class


MindFusion.Diagramming.Theme.UnregisterStyle Method

Theme.UnregisterStyle Method
[image]

Unregisters the Style object associated with the specified type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void UnregisterStyle (
Type type
)

Visual Basic [image] Copy Code

Public Sub UnregisterStyle( _
type As Type _
)

Parameters

type

The runtime type to unregister.

See Also

Theme Members
Theme Class


MindFusion.Diagramming.ThicknessConverter Class

ThicknessConverter Class
[image]

Converts strings to Thickness values.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ThicknessConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class ThicknessConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ThicknessConverter

See Also

ThicknessConverter Members


MindFusion.Diagramming.ThicknessConverter Members

ThicknessConverter Members
Constructors Methods
[image]

Converts strings to Thickness values.

The following tables list the members exposed by the ThicknessConverter type.

Public Constructors

Name | Description
ThicknessConverter |

Public Methods

Name | Description
Convert | Implements IValueConverter.Convert.
ConvertBack | Not implemented.

See Also

ThicknessConverter Class


MindFusion.Diagramming.ThicknessConverter Constructor

ThicknessConverter Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ThicknessConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ThicknessConverter Class


MindFusion.Diagramming.ThicknessConverter Methods

ThicknessConverter Methods
[image]

Public Methods

Name | Description
Convert | Implements IValueConverter.Convert.
ConvertBack | Not implemented.

See Also

ThicknessConverter Class


MindFusion.Diagramming.ThicknessConverter.Convert Method

ThicknessConverter.Convert Method
[image]

Implements IValueConverter.Convert.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo l
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
l As CultureInfo _
) As Object

Parameters

value

targetType

parameter

l

Return Value

See Also

ThicknessConverter Members
ThicknessConverter Class


MindFusion.Diagramming.ThicknessConverter.ConvertBack Method

ThicknessConverter.ConvertBack Method
[image]

Not implemented.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo l
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
l As CultureInfo _
) As Object

Parameters

value

targetType

parameter

l

Return Value

See Also

ThicknessConverter Members
ThicknessConverter Class


MindFusion.Diagramming.TickPosition Enumeration

TickPosition Enumeration
[image]

Specifies the position of trackbar ticks.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum TickPosition

Visual Basic [image] Copy Code

Public Enum TickPosition

Members

Member name | Description
Both | Ticks are rendered on both sides of the trackbar.
Left | Ticks are rendered on the left side of the trackbar.
None | There are no ticks rendered.
Right | Ticks are rendered on the right side of the trackbar.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.TranslateLayer Class

TranslateLayer Class
[image]

A UIElement that is child to Diagram and contains all its items. It allows to apply translation on all items without changing the diagram object. This is used for implemention Diagram.Bounds, e.g. when Bounds = (20,20,40,40) Item at coordinate 20,20 must be rendered at Diagram coordinate 0,0.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TranslateLayer : Canvas

Visual Basic [image] Copy Code

Public Class TranslateLayer
Inherits Canvas

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Panel
Windows.UI.Xaml.Controls.Canvas
MindFusion.Diagramming.TranslateLayer

See Also

TranslateLayer Members


MindFusion.Diagramming.TranslateLayer Members

TranslateLayer Members
Constructors
[image]

A UIElement that is child to Diagram and contains all its items. It allows to apply translation on all items without changing the diagram object. This is used for implemention Diagram.Bounds, e.g. when Bounds = (20,20,40,40) Item at coordinate 20,20 must be rendered at Diagram coordinate 0,0.

The following tables list the members exposed by the TranslateLayer type.

Public Constructors

Name | Description
TranslateLayer | Constructor used by XAML

See Also

TranslateLayer Class


MindFusion.Diagramming.TranslateLayer Constructor

TranslateLayer Constructor
[image]

Constructor used by XAML

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TranslateLayer ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TranslateLayer Class


MindFusion.Diagramming.TreeItemCollection Class

TreeItemCollection Class
[image]

Represents a strongly typed collection of TreeViewItem objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TreeItemCollection : CollectionBase<TreeViewItem, TreeViewItem>

Visual Basic [image] Copy Code

Public Class TreeItemCollection
Inherits CollectionBase(Of TreeViewItem, TreeViewItem)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.CollectionBase(TreeViewItem, TreeViewItem)
MindFusion.Diagramming.TreeItemCollection

See Also

TreeItemCollection Members


MindFusion.Diagramming.TreeItemCollection Members

TreeItemCollection Members
Constructors Fields Properties Methods
[image]

Represents a strongly typed collection of TreeViewItem objects.

The following tables list the members exposed by the TreeItemCollection type.

Public Constructors

Name | Description
TreeItemCollection | Overloaded.

Inherited Protected Fields

Name | Description
itemEventArgs | An ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector. (Inherited from CollectionBase.)
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items. (Inherited from CollectionBase.)

Inherited Public Properties

Name | Description
Count | Gets the number of items contained in the collection. (Inherited from CollectionBase.)
IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from CollectionBase.)
Item | An indexer that lets you access the element at the specified position. (Inherited from CollectionBase.)

Inherited Public Methods

Name | Description
Add | Adds an item to the collection. (Inherited from CollectionBase.)
Clear | Removes all items from the collection. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the List(T). (Inherited from CollectionBase.)
CopyTo | (Inherited from CollectionBase.)
GetEnumerator | Returns an enumerator for this collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts an element into the Collection at the specified index. (Inherited from CollectionBase.)
Remove | Removes the first occurrence of a specific object from the collection. (Inherited from CollectionBase.)
RemoveAt | Removes the element at the specified index of the collection. (Inherited from CollectionBase.)

Inherited Protected Methods

Name | Description
RaiseAdding | Raises the Adding event. (Inherited from CollectionBase.)
RaiseInserting | Raises the Inserting event. (Inherited from CollectionBase.)
RaiseRemoving | Raises the Removing event. (Inherited from CollectionBase.)

See Also

TreeItemCollection Class


MindFusion.Diagramming.TreeItemCollection Constructor

TreeItemCollection Constructor
[image]

Overload List

Name | Description
TreeItemCollection () | Initializes a new instance of the TreeItemCollection class.
TreeItemCollection (Boolean) | Initializes a new instance of the TreeItemCollection class.
TreeItemCollection (TreeItemCollection) | Initializes a new instance of the TreeItemCollection class.

See Also

TreeItemCollection Class


MindFusion.Diagramming.TreeItemCollection Constructor ()

TreeItemCollection Constructor ()
See Also
[image]

Initializes a new instance of the TreeItemCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeItemCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TreeItemCollection Constructor Overload List
TreeItemCollection Class


MindFusion.Diagramming.TreeItemCollection Constructor (Boolean)

TreeItemCollection Constructor (Boolean)
See Also
[image]

Initializes a new instance of the TreeItemCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeItemCollection (
bool notifyParent
)

Visual Basic [image] Copy Code

Public New ( _
notifyParent As Boolean _
)

Parameters

notifyParent

See Also

TreeItemCollection Constructor Overload List
TreeItemCollection Class


MindFusion.Diagramming.TreeItemCollection Constructor (TreeItemCollection)

TreeItemCollection Constructor (TreeItemCollection)
See Also
[image]

Initializes a new instance of the TreeItemCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeItemCollection (
TreeItemCollection prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As TreeItemCollection _
)

Parameters

prototype

See Also

TreeItemCollection Constructor Overload List
TreeItemCollection Class


MindFusion.Diagramming.TreeView Class

TreeView Class
Remarks See Also
[image]

A container for the child items of a TreeViewItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TreeView : ItemsControl

Visual Basic [image] Copy Code

Public Class TreeView
Inherits ItemsControl

Remarks

For internal use.

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
Windows.UI.Xaml.Controls.ItemsControl
MindFusion.Diagramming.TreeView

See Also

TreeView Members


MindFusion.Diagramming.TreeView Members

TreeView Members
Constructors Methods
[image]

A container for the child items of a TreeViewItem.

The following tables list the members exposed by the TreeView type.

Public Constructors

Name | Description
TreeView | Initializes a new instance of the TreeView class.

Protected Methods

Name | Description
GetContainerForItemOverride | ItemsControl.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | ItemsControl.IsItemItsOwnContainerOverride override.

See Also

TreeView Class


MindFusion.Diagramming.TreeView Constructor

TreeView Constructor
[image]

Initializes a new instance of the TreeView class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeView ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TreeView Class


MindFusion.Diagramming.TreeView Methods

TreeView Methods
[image]

Protected Methods

Name | Description
GetContainerForItemOverride | ItemsControl.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | ItemsControl.IsItemItsOwnContainerOverride override.

See Also

TreeView Class


MindFusion.Diagramming.TreeView.GetContainerForItemOverride Method

TreeView.GetContainerForItemOverride Method
[image]

ItemsControl.GetContainerForItemOverride override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override DependencyObject GetContainerForItemOverride ()

Visual Basic [image] Copy Code

Protected Overrides Function GetContainerForItemOverride () As DependencyObject

Return Value

See Also

TreeView Members
TreeView Class


MindFusion.Diagramming.TreeView.IsItemItsOwnContainerOverride Method

TreeView.IsItemItsOwnContainerOverride Method
[image]

ItemsControl.IsItemItsOwnContainerOverride override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override bool IsItemItsOwnContainerOverride (
Object item
)

Visual Basic [image] Copy Code

Protected Overrides Function IsItemItsOwnContainerOverride( _
item As Object _
) As Boolean

Parameters

item

Return Value

See Also

TreeView Members
TreeView Class


MindFusion.Diagramming.TreeViewConnectionPoint Class

TreeViewConnectionPoint Class
[image]

Represents a connection between a link and a TreeViewNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TreeViewConnectionPoint : ConnectionPoint

Visual Basic [image] Copy Code

Public Class TreeViewConnectionPoint
Inherits ConnectionPoint

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ConnectionPoint
MindFusion.Diagramming.TreeViewConnectionPoint

See Also

TreeViewConnectionPoint Members


MindFusion.Diagramming.TreeViewConnectionPoint Members

TreeViewConnectionPoint Members
Constructors Properties Methods
[image]

Represents a connection between a link and a TreeViewNode.

The following tables list the members exposed by the TreeViewConnectionPoint type.

Public Constructors

Name | Description
TreeViewConnectionPoint | Initializes a new instance of the TreeViewConnectionPoint class.

Public Properties

Name | Description
Row | ConnectionPoint.Row override.

Inherited Public Properties

Name | Description
AnchorPointIndex | Gets or sets the index of the destination anchor point within the AnchorPattern that contains it. (Inherited from ConnectionPoint.)
RelativePosition | Gets or sets the position of this connection point, relative to the associated node's bounding rectangle, expressed in percents. (Inherited from ConnectionPoint.)
Row | Gets the index of a constituent item within the associated node where the link represented by this connection point is connected, or -1, if the link is connected to the node itself. (Inherited from ConnectionPoint.)

Inherited Protected Properties

Name | Description
Incoming | Gets a flag indicating whether this connection point is at the origin or the destination of the associated link. (Inherited from ConnectionPoint.)
Link | Gets the link associated with this connection point. (Inherited from ConnectionPoint.)
Node | Gets the node associated with this connection point. (Inherited from ConnectionPoint.)

Public Methods

Name | Description
AddLinkToNode | ConnectionPoint.AddLinkToNode override.
GetEndPoint | ConnectionPoint.GetEndPoint override.
GetInitialPoint | ConnectionPoint.GetInitialPoint override.
GetIntersection | ConnectionPoint.GetIntersection override.
LinkChanges | ConnectionPoint.LinkChanges override.
RemoveLinkFromNode | ConnectionPoint.RemoveLinkFromNode override.
SaveEndRelative | ConnectionPoint.SaveEndRelative override.
UpdateRow | Sets the row within the table this connection point should be associated with.

Protected Methods

Name | Description
GetNearestAnchorPoint | ConnectionPoint.GetNearestAnchorPoint override.
GetNearestBorderPoint | ConnectionPoint.GetNearestBorderPoint override.

Inherited Public Methods

Name | Description
AddLinkToNode | Adds the link associated with this connection point to the associated node. (Inherited from ConnectionPoint.)
GetAnchorPos | Returns the point from the node's associated anchor pattern (if any) with the specified index or the link's initial point. (Inherited from ConnectionPoint.)
GetEndPoint | Calculates the coordinates of this connection point expressed in document coordinates. (Inherited from ConnectionPoint.)
GetInitialPoint | Returns a point (usually the center of the bounding rectangle) contained within the associated node. (Inherited from ConnectionPoint.)
GetIntersection | Calculates the intersection point between the specified line segment and the contour of the node associated with this connection point. (Inherited from ConnectionPoint.)
GetNodeRect | Returns the bounding rectangle of the node associated with this connection point. (Inherited from ConnectionPoint.)
LinkChanges | Checks whether the link would change if attached to the specified node at the specified point. (Inherited from ConnectionPoint.)
NodesIntersect | Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect. (Inherited from ConnectionPoint.)
RemoveLinkFromNode | Removes the link associated with this connection point from the associated node. (Inherited from ConnectionPoint.)
SaveEndRelative | Updates the coordinates of the connection point represented by this link, relative to the bounding rectangle of the associated node. (Inherited from ConnectionPoint.)
UpdateRow | Sets the row within the table this connection point should be associated with. (Inherited from ConnectionPoint.)

Inherited Protected Methods

Name | Description
GetNearestAnchorPoint | Returns the nearest anchor point pertinent to this connection. (Inherited from ConnectionPoint.)
GetNearestBorderPoint | Returns the nearest point lying on the node border. (Inherited from ConnectionPoint.)

See Also

TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint Constructor

TreeViewConnectionPoint Constructor
[image]

Initializes a new instance of the TreeViewConnectionPoint class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewConnectionPoint (
TreeViewNode node,
DiagramLink link,
bool incoming,
TreeViewItem item
)

Visual Basic [image] Copy Code

Public New ( _
node As TreeViewNode, _
link As DiagramLink, _
incoming As Boolean, _
item As TreeViewItem _
)

Parameters

node

A TreeViewNode instance.

link

A DiagramLink instance.

incoming

Specifies which end of the link is represented by this TreeViewConnectionPoint.

item

The TreeViewItem to which the link connects.

See Also

TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint Methods

TreeViewConnectionPoint Methods
[image]

Public Methods

Name | Description
AddLinkToNode | ConnectionPoint.AddLinkToNode override.
GetEndPoint | ConnectionPoint.GetEndPoint override.
GetInitialPoint | ConnectionPoint.GetInitialPoint override.
GetIntersection | ConnectionPoint.GetIntersection override.
LinkChanges | ConnectionPoint.LinkChanges override.
RemoveLinkFromNode | ConnectionPoint.RemoveLinkFromNode override.
SaveEndRelative | ConnectionPoint.SaveEndRelative override.
UpdateRow | Sets the row within the table this connection point should be associated with.

Protected Methods

Name | Description
GetNearestAnchorPoint | ConnectionPoint.GetNearestAnchorPoint override.
GetNearestBorderPoint | ConnectionPoint.GetNearestBorderPoint override.

Inherited Public Methods

Name | Description
AddLinkToNode | Adds the link associated with this connection point to the associated node. (Inherited from ConnectionPoint.)
GetAnchorPos | Returns the point from the node's associated anchor pattern (if any) with the specified index or the link's initial point. (Inherited from ConnectionPoint.)
GetEndPoint | Calculates the coordinates of this connection point expressed in document coordinates. (Inherited from ConnectionPoint.)
GetInitialPoint | Returns a point (usually the center of the bounding rectangle) contained within the associated node. (Inherited from ConnectionPoint.)
GetIntersection | Calculates the intersection point between the specified line segment and the contour of the node associated with this connection point. (Inherited from ConnectionPoint.)
GetNodeRect | Returns the bounding rectangle of the node associated with this connection point. (Inherited from ConnectionPoint.)
LinkChanges | Checks whether the link would change if attached to the specified node at the specified point. (Inherited from ConnectionPoint.)
NodesIntersect | Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect. (Inherited from ConnectionPoint.)
RemoveLinkFromNode | Removes the link associated with this connection point from the associated node. (Inherited from ConnectionPoint.)
SaveEndRelative | Updates the coordinates of the connection point represented by this link, relative to the bounding rectangle of the associated node. (Inherited from ConnectionPoint.)
UpdateRow | Sets the row within the table this connection point should be associated with. (Inherited from ConnectionPoint.)

Inherited Protected Methods

Name | Description
GetNearestAnchorPoint | Returns the nearest anchor point pertinent to this connection. (Inherited from ConnectionPoint.)
GetNearestBorderPoint | Returns the nearest point lying on the node border. (Inherited from ConnectionPoint.)

See Also

TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.AddLinkToNode Method

TreeViewConnectionPoint.AddLinkToNode Method
[image]

ConnectionPoint.AddLinkToNode override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void AddLinkToNode ()

Visual Basic [image] Copy Code

Public Overrides Sub AddLinkToNode ()

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.GetEndPoint Method

TreeViewConnectionPoint.GetEndPoint Method
[image]

ConnectionPoint.GetEndPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Point GetEndPoint ()

Visual Basic [image] Copy Code

Public Overrides Function GetEndPoint () As Point

Return Value

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.GetInitialPoint Method

TreeViewConnectionPoint.GetInitialPoint Method
[image]

ConnectionPoint.GetInitialPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Point GetInitialPoint ()

Visual Basic [image] Copy Code

Public Overrides Function GetInitialPoint () As Point

Return Value

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.GetIntersection Method

TreeViewConnectionPoint.GetIntersection Method
[image]

ConnectionPoint.GetIntersection override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Point GetIntersection (
Point pt1,
Point pt2
)

Visual Basic [image] Copy Code

Public Overrides Function GetIntersection( _
pt1 As Point, _
pt2 As Point _
) As Point

Parameters

pt1

pt2

Return Value

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.GetNearestAnchorPoint Method

TreeViewConnectionPoint.GetNearestAnchorPoint Method
[image]

ConnectionPoint.GetNearestAnchorPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override AnchorPointDetails GetNearestAnchorPoint (
Point point
)

Visual Basic [image] Copy Code

Protected Overrides Function GetNearestAnchorPoint( _
point As Point _
) As AnchorPointDetails

Parameters

point

Return Value

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.GetNearestBorderPoint Method

TreeViewConnectionPoint.GetNearestBorderPoint Method
[image]

ConnectionPoint.GetNearestBorderPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override AnchorPointDetails GetNearestBorderPoint (
Point point
)

Visual Basic [image] Copy Code

Protected Overrides Function GetNearestBorderPoint( _
point As Point _
) As AnchorPointDetails

Parameters

point

Return Value

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.LinkChanges Method

TreeViewConnectionPoint.LinkChanges Method
[image]

ConnectionPoint.LinkChanges override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool LinkChanges (
DiagramItem item,
Point point,
bool isDiagramCoordinate
)

Visual Basic [image] Copy Code

Public Overrides Function LinkChanges( _
item As DiagramItem, _
point As Point, _
isDiagramCoordinate As Boolean _
) As Boolean

Parameters

item

point

isDiagramCoordinate

Return Value

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.RemoveLinkFromNode Method

TreeViewConnectionPoint.RemoveLinkFromNode Method
[image]

ConnectionPoint.RemoveLinkFromNode override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void RemoveLinkFromNode ()

Visual Basic [image] Copy Code

Public Overrides Sub RemoveLinkFromNode ()

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.SaveEndRelative Method

TreeViewConnectionPoint.SaveEndRelative Method
[image]

ConnectionPoint.SaveEndRelative override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void SaveEndRelative ()

Visual Basic [image] Copy Code

Public Overrides Sub SaveEndRelative ()

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.UpdateRow Method

TreeViewConnectionPoint.UpdateRow Method
[image]

Sets the row within the table this connection point should be associated with.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void UpdateRow (
int rowIndex
)

Visual Basic [image] Copy Code

Public Overrides Sub UpdateRow( _
rowIndex As Integer _
)

Parameters

rowIndex

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint Properties

TreeViewConnectionPoint Properties
[image]

Public Properties

Name | Description
Row | ConnectionPoint.Row override.

Inherited Public Properties

Name | Description
AnchorPointIndex | Gets or sets the index of the destination anchor point within the AnchorPattern that contains it. (Inherited from ConnectionPoint.)
RelativePosition | Gets or sets the position of this connection point, relative to the associated node's bounding rectangle, expressed in percents. (Inherited from ConnectionPoint.)
Row | Gets the index of a constituent item within the associated node where the link represented by this connection point is connected, or -1, if the link is connected to the node itself. (Inherited from ConnectionPoint.)

Inherited Protected Properties

Name | Description
Incoming | Gets a flag indicating whether this connection point is at the origin or the destination of the associated link. (Inherited from ConnectionPoint.)
Link | Gets the link associated with this connection point. (Inherited from ConnectionPoint.)
Node | Gets the node associated with this connection point. (Inherited from ConnectionPoint.)

See Also

TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.Row Property

TreeViewConnectionPoint.Row Property
[image]

ConnectionPoint.Row override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override int Row { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Row As Integer

Property Value

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionStyle Enumeration

TreeViewConnectionStyle Enumeration
[image]

Specifies the possible values for the ConnectionStyle property of TreeViewNodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum TreeViewConnectionStyle

Visual Basic [image] Copy Code

Public Enum TreeViewConnectionStyle

Members

Member name | Description
Items | Users are allowed to create relations to the items of a TreeViewNode.
Node | Users are allowed to create relations to the TreeViewNode as an integral entity.

See Also

MindFusion.Diagramming Namespace

© 2015 MindFusion


MindFusion.Diagramming.TreeViewItem Class

TreeViewItem Class
Remarks See Also
[image]

Represents a constituent item of the hierarchy displayed inside a TreeViewNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TreeViewItem : Control, INotifyPropertyChanged, InplaceEditable

Visual Basic [image] Copy Code

Public Class TreeViewItem
Inherits Control
Implements INotifyPropertyChanged, InplaceEditable

Remarks

The items of a TreeViewNode can be traversed recursively starting from the node's RootItems. Given an item, you can find its parent and child items by means of the Parent and Children properties.

If the ConnectionStyle of a node is set to Items, links connect to specific items of the node. Such links can be accessed by means of the IncomingLinks and OutgoingLinks collections.

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
MindFusion.Diagramming.TreeViewItem

See Also

TreeViewItem Members


MindFusion.Diagramming.TreeViewItem Members

TreeViewItem Members
Constructors Fields Properties Methods Events
[image]

Represents a constituent item of the hierarchy displayed inside a TreeViewNode.

The following tables list the members exposed by the TreeViewItem type.

Public Constructors

Name | Description
TreeViewItem | Overloaded.

Public Fields

Name | Description
ChildrenProperty | Identifies the Children dependency property.
ExpandedIconVisibilityProperty | Identifies the ExpandedIconVisibility dependency property.
ExpandedProperty | Identifies the Expanded dependency property.
ExpanderButtonWidthProperty | Identifies the ExpanderButtonWidth dependency property.
ExpanderVisibilityProperty | Identifies the ExpanderVisibility dependency property.
HasItemsProperty | Identifies the HasItems dependency property.
ImageProperty | Identifies the Image dependency property.
ImageStretchProperty | Identifies the ImageStretch dependency property.
ItemsVisibilityProperty | Identifies the ItemsVisibility dependency property.
LabelBrushProperty | Identifies the LabelBrush dependency property.
LabelHeightProperty | Identifies the LabelHeight dependency property.
LabelProperty | Identifies the Label dependency property.
TreeDepthProperty | Identifies the TreeDepth dependency property.

Public Properties

Name | Description
Children | Gets a list of this item's children in the hierarchy.
Expanded | Gets or sets whether this item is expanded to show its children.
ExpandedIconVisibility | Gets a value indicating whether the expand / collapse button should be rendered in expanded state.
ExpanderButtonWidth | Gets or sets the width of the expand / collapse button.
ExpanderVisibility | Gets a value that indicates whether the control template should render the expand button for a node.
HasItems | Gets a value indicating whether this item has child items.
Image | Gets or sets the image that is displayed in this treeview item.
ImageStretch | Gets or sets an ImageStretch value specifying how the image should be stretched.
IncomingLinks | Gets a collection of all links that point to this item.
ItemsVisibility | Gets a value indicating whether the control template should render the child items of a TreeViewItem.
Label | Gets or sets the label of this item.
LabelBrush | Gets or sets the label color of this item.
LabelHeight | Gets a value specifying the height of this TreeViewItem.
OutgoingLinks | Gets a collection of all links that go out from this item.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
CreateState | Creates an item state corresponding to the type of this tree item.
RestoreState | Restores the state of this tree item.
SaveState | Saves the state of this tree item.

Public Events

Name | Description
PropertyChanged | Raised when a property value changes.

See Also

TreeViewItem Class


MindFusion.Diagramming.TreeViewItem Fields

TreeViewItem Fields
[image]

Public Fields

Name | Description
ChildrenProperty | Identifies the Children dependency property.
ExpandedIconVisibilityProperty | Identifies the ExpandedIconVisibility dependency property.
ExpandedProperty | Identifies the Expanded dependency property.
ExpanderButtonWidthProperty | Identifies the ExpanderButtonWidth dependency property.
ExpanderVisibilityProperty | Identifies the ExpanderVisibility dependency property.
HasItemsProperty | Identifies the HasItems dependency property.
ImageProperty | Identifies the Image dependency property.
ImageStretchProperty | Identifies the ImageStretch dependency property.
ItemsVisibilityProperty | Identifies the ItemsVisibility dependency property.
LabelBrushProperty | Identifies the LabelBrush dependency property.
LabelHeightProperty | Identifies the LabelHeight dependency property.
LabelProperty | Identifies the Label dependency property.
TreeDepthProperty | Identifies the TreeDepth dependency property.

See Also

TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.ChildrenProperty Field

TreeViewItem.ChildrenProperty Field
[image]

Identifies the Children dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ChildrenProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ChildrenProperty As DependencyProperty

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.ExpandedIconVisibilityProperty Field

TreeViewItem.ExpandedIconVisibilityProperty Field
[image]

Identifies the ExpandedIconVisibility dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ExpandedIconVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ExpandedIconVisibilityProperty As DependencyProperty

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.ExpandedProperty Field

TreeViewItem.ExpandedProperty Field
[image]

Identifies the Expanded dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ExpandedProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ExpandedProperty As DependencyProperty

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.ExpanderButtonWidthProperty Field

TreeViewItem.ExpanderButtonWidthProperty Field
[image]

Identifies the ExpanderButtonWidth dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ExpanderButtonWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ExpanderButtonWidthProperty As DependencyProperty

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.ExpanderVisibilityProperty Field

TreeViewItem.ExpanderVisibilityProperty Field
[image]

Identifies the ExpanderVisibility dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ExpanderVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ExpanderVisibilityProperty As DependencyProperty

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.HasItemsProperty Field

TreeViewItem.HasItemsProperty Field
[image]

Identifies the HasItems dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HasItemsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HasItemsProperty As DependencyProperty

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.ImageProperty Field

TreeViewItem.ImageProperty Field
[image]

Identifies the Image dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ImageProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ImageProperty As DependencyProperty

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.ImageStretchProperty Field

TreeViewItem.ImageStretchProperty Field
[image]

Identifies the ImageStretch dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ImageStretchProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ImageStretchProperty As DependencyProperty

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.ItemsVisibilityProperty Field

TreeViewItem.ItemsVisibilityProperty Field
[image]

Identifies the ItemsVisibility dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemsVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemsVisibilityProperty As DependencyProperty

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.LabelBrushProperty Field

TreeViewItem.LabelBrushProperty Field
[image]

Identifies the LabelBrush dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelBrushProperty As DependencyProperty

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.LabelHeightProperty Field

TreeViewItem.LabelHeightProperty Field
[image]

Identifies the LabelHeight dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelHeightProperty As DependencyProperty

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.LabelProperty Field

TreeViewItem.LabelProperty Field
[image]

Identifies the Label dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelProperty As DependencyProperty

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.TreeDepthProperty Field

TreeViewItem.TreeDepthProperty Field
[image]

Identifies the TreeDepth dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TreeDepthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TreeDepthProperty As DependencyProperty

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem Constructor

TreeViewItem Constructor
[image]

Overload List

Name | Description
TreeViewItem () | Initializes a new instance of the TreeViewItem class.
TreeViewItem (TreeViewItem) | Initializes a new instance of the TreeViewItem class using the specified item as a prototype.

See Also

TreeViewItem Class


MindFusion.Diagramming.TreeViewItem Constructor ()

TreeViewItem Constructor ()
See Also
[image]

Initializes a new instance of the TreeViewItem class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewItem ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TreeViewItem Constructor Overload List
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem Constructor (TreeViewItem)

TreeViewItem Constructor (TreeViewItem)
See Also
[image]

Initializes a new instance of the TreeViewItem class using the specified item as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewItem (
TreeViewItem prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As TreeViewItem _
)

Parameters

prototype

The treeview item to use as a prototype. The properties of the new treeview are initialized from the property values of prototype.

Remarks

This constructor copies the TreeViewItem property values from the specified prototype item.

See Also

TreeViewItem Constructor Overload List
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem Methods

TreeViewItem Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
CreateState | Creates an item state corresponding to the type of this tree item.
RestoreState | Restores the state of this tree item.
SaveState | Saves the state of this tree item.

See Also

TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.CreateState Method

TreeViewItem.CreateState Method
[image]

Creates an item state corresponding to the type of this tree item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected TreeViewItemState CreateState ()

Visual Basic [image] Copy Code

Protected Function CreateState () As TreeViewItemState

Return Value

An instance of TreeViewItemState or a derived class.

Remarks

This method is used by the undo/redo system to create a TreeViewItemState -derived object that corresponds to the item class. Custom item classes must override CreateState in order to implement undo/redo support for any additional members they define. This method should be overridden together with SaveState and RestoreState.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.OnApplyTemplate Method

TreeViewItem.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Overrides Sub OnApplyTemplate ()

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.RestoreState Method

TreeViewItem.RestoreState Method
[image]

Restores the state of this tree item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void RestoreState (
TreeViewItemState itemState
)

Visual Basic [image] Copy Code

Protected Sub RestoreState ( _
itemState As TreeViewItemState _
)

Parameters

itemState
A TreeViewItemState that represents previous state of the item.

Remarks

This method is used by the undo/redo system to restore an item to a previous state. Custom item classes must override RestoreState in order to implement undo/redo support for any additional members they define. This method should be overridden together with CreateState and SaveState.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.SaveState Method

TreeViewItem.SaveState Method
[image]

Saves the state of this tree item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected TreeViewItemState SaveState ()

Visual Basic [image] Copy Code

Protected Function SaveState () As TreeViewItemState

Return Value

A TreeViewItemState that represents the current state of the item.

Remarks

This method is used by the undo/redo system to save the state of an item. Custom item classes must override SaveState in order to implement undo/redo support for any additional members they define. This method should be overridden together with CreateState and RestoreState.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem Properties

TreeViewItem Properties
[image]

Public Properties

Name | Description
Children | Gets a list of this item's children in the hierarchy.
Expanded | Gets or sets whether this item is expanded to show its children.
ExpandedIconVisibility | Gets a value indicating whether the expand / collapse button should be rendered in expanded state.
ExpanderButtonWidth | Gets or sets the width of the expand / collapse button.
ExpanderVisibility | Gets a value that indicates whether the control template should render the expand button for a node.
HasItems | Gets a value indicating whether this item has child items.
Image | Gets or sets the image that is displayed in this treeview item.
ImageStretch | Gets or sets an ImageStretch value specifying how the image should be stretched.
IncomingLinks | Gets a collection of all links that point to this item.
ItemsVisibility | Gets a value indicating whether the control template should render the child items of a TreeViewItem.
Label | Gets or sets the label of this item.
LabelBrush | Gets or sets the label color of this item.
LabelHeight | Gets a value specifying the height of this TreeViewItem.
OutgoingLinks | Gets a collection of all links that go out from this item.

See Also

TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.Children Property

TreeViewItem.Children Property
[image]

Gets a list of this item's children in the hierarchy.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeItemCollection Children { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Children As TreeItemCollection

Property Value

An instance of the TreeItemCollection class.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.Expanded Property

TreeViewItem.Expanded Property
[image]

Gets or sets whether this item is expanded to show its children.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Expanded { get; set; }

Visual Basic [image] Copy Code

Public Property Expanded As Boolean

Property Value

true to show the children of this item, otherwise false; the default value is true.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.ExpandedIconVisibility Property

TreeViewItem.ExpandedIconVisibility Property
[image]

Gets a value indicating whether the expand / collapse button should be rendered in expanded state.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Visibility ExpandedIconVisibility { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ExpandedIconVisibility As Visibility

Property Value

A member of the Windows.UI.Xaml.Visibility enumeration.

Remarks

This property is exposed for use from custom TreeViewItem templates.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.ExpanderButtonWidth Property

TreeViewItem.ExpanderButtonWidth Property
[image]

Gets or sets the width of the expand / collapse button.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ExpanderButtonWidth { get; set; }

Visual Basic [image] Copy Code

Public Property ExpanderButtonWidth As Double

Property Value

A double value specifying the size of the expand / collapse button. The default is 15.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.ExpanderVisibility Property

TreeViewItem.ExpanderVisibility Property
[image]

Gets a value that indicates whether the control template should render the expand button for a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Visibility ExpanderVisibility { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ExpanderVisibility As Visibility

Property Value

A member of the Windows.UI.Xaml.Visibility enumeration.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.HasItems Property

TreeViewItem.HasItems Property
[image]

Gets a value indicating whether this item has child items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool HasItems { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property HasItems As Boolean

Property Value

true if the item contains child items, otherwise false.

Remarks

This property is exposed for use from custom TreeViewItem templates.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.Image Property

TreeViewItem.Image Property
[image]

Gets or sets the image that is displayed in this treeview item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ImageSource Image { get; set; }

Visual Basic [image] Copy Code

Public Property Image As ImageSource

Property Value

An instance of the WinRT ImageSource class. The default value is null (Nothing in Visual Basic).

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.ImageStretch Property

TreeViewItem.ImageStretch Property
[image]

Gets or sets an ImageStretch value specifying how the image should be stretched.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Stretch ImageStretch { get; set; }

Visual Basic [image] Copy Code

Public Property ImageStretch As Stretch

Property Value

One of the Windows.UI.Xaml.Media.Stretch enumeration values. The default is UniformToFill.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.IncomingLinks Property

TreeViewItem.IncomingLinks Property
[image]

Gets a collection of all links that point to this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection IncomingLinks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IncomingLinks As DiagramLinkCollection

Property Value

An instance of the DiagramLinkCollection class.

Remarks

The property returns a collection of all links that point to this item. Use it to access the links or get their number.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.ItemsVisibility Property

TreeViewItem.ItemsVisibility Property
[image]

Gets a value indicating whether the control template should render the child items of a TreeViewItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Visibility ItemsVisibility { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ItemsVisibility As Visibility

Property Value

A member of the Windows.UI.Xaml.Visibility enumeration.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.Label Property

TreeViewItem.Label Property
[image]

Gets or sets the label of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Label { get; set; }

Visual Basic [image] Copy Code

Public Property Label As String

Property Value

A string specifying the item's label.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.LabelBrush Property

TreeViewItem.LabelBrush Property
[image]

Gets or sets the label color of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush LabelBrush { get; set; }

Visual Basic [image] Copy Code

Public Property LabelBrush As Brush

Property Value

A Windows.UI.Xaml.Media.Brush instance specifying the label color. The default is null.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.LabelHeight Property

TreeViewItem.LabelHeight Property
[image]

Gets a value specifying the height of this TreeViewItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LabelHeight { get; set; }

Visual Basic [image] Copy Code

Public Property LabelHeight As Double

Property Value

A double value specifying the item height. The default is 20.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.OutgoingLinks Property

TreeViewItem.OutgoingLinks Property
[image]

Gets a collection of all links that go out from this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection OutgoingLinks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OutgoingLinks As DiagramLinkCollection

Property Value

An instance of the DiagramLinkCollection class.

Remarks

The property returns a collection of all links that start from this item. Use it to access the links or get their number.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem Events

TreeViewItem Events
[image]

Public Events

Name | Description
PropertyChanged | Raised when a property value changes.

See Also

TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.PropertyChanged Event

TreeViewItem.PropertyChanged Event
[image]

Raised when a property value changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItemState Class

TreeViewItemState Class
[image]

Represents the state of a TreeViewItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TreeViewItemState

Visual Basic [image] Copy Code

Public Class TreeViewItemState

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.TreeViewItemState

See Also

TreeViewItemState Members


MindFusion.Diagramming.TreeViewItemState Members

TreeViewItemState Members
Constructors
[image]

Represents the state of a TreeViewItem.

The following tables list the members exposed by the TreeViewItemState type.

Public Constructors

Name | Description
TreeViewItemState |

See Also

TreeViewItemState Class


MindFusion.Diagramming.TreeViewItemState Constructor

TreeViewItemState Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewItemState ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TreeViewItemState Class


MindFusion.Diagramming.TreeViewNode Class

TreeViewNode Class
Remarks See Also
[image]

Represents nodes that can draw hierarchical data.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TreeViewNode : DiagramNode, InplaceEditable

Visual Basic [image] Copy Code

Public Class TreeViewNode
Inherits DiagramNode
Implements InplaceEditable

Remarks

The root items displayed in the node can be accessed through the RootItems property. New items can be added to and removed from the returned collection. The root items can have child items on their own and so on. For more information, refer to the TreeViewItem class.

The text and image displayed in the node caption can be customized through the Caption and CaptionImage properties respectively. The text color can be set through CaptionBrush.

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
Windows.UI.Xaml.Controls.ContentControl
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.TreeViewNode

See Also

TreeViewNode Members


MindFusion.Diagramming.TreeViewNode Members

TreeViewNode Members
Constructors Fields Properties Methods
[image]

Represents nodes that can draw hierarchical data.

The following tables list the members exposed by the TreeViewNode type.

Public Constructors

Name | Description
TreeViewNode | Overloaded.

Public Fields

Name | Description
BorderGeometryProperty | Identifies the BorderGeometry dependency property.
CaptionHeightProperty | Identifies the CaptionHeight dependency property.
CaptionImageProperty | Identifies the CaptionImage dependency property.
CaptionProperty | Identifies the Caption dependency property.
RootItemsProperty | Identifies the CaptionHeight dependency property.
ScrollableProperty | Identifies the Scrollable dependency property.

Inherited Public Fields

Name | Description
AutoCaptureMouseProperty | Identifies the AutoCaptureMouse dependency property. (Inherited from DiagramItem.)
BoundsProperty | Identifies the Bounds dependency property. (Inherited from DiagramNode.)
BrushProperty | Identifies the Brush dependency property. (Inherited from DiagramItem.)
EffectsSourceProperty | Identifies the EffectsSource dependency property. (Inherited from DiagramNode.)
HyperLinkProperty | Identifies the HyperLink dependency property. (Inherited from DiagramItem.)
IsMouseDownProperty | Identifies the IsMouseDown dependency property. (Inherited from DiagramItem.)
IsMouseOverProperty | Identifies the IsMouseOver dependency property. (Inherited from DiagramItem.)
MasterNodeProperty | Identifies the MasterNode dependency property. (Inherited from DiagramNode.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from DiagramNode.)
ShapeOpacityProperty | Identifies the ShapeOpacity dependency property. (Inherited from DiagramNode.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from DiagramItem.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)

Inherited Protected Fields

Name | Description
handles | A list of the Rectangle objects that represent the item's adjustment handles. (Inherited from DiagramItem.)

Public Properties

Name | Description
BorderGeometry | Gets or sets the RectangleGeometry object that defines the TreeViewNode outline.
Caption | Gets or sets the text displayed as caption of the node.
CaptionHeight | Gets or sets the height of the node's caption area.
CaptionImage | Gets or sets the image displayed as caption of the node.
ConnectionStyle | Gets or sets a value indicating whether drawing a link from/to this node should connect an item or the whole node as an integral entity.
RootItems | Gets a list of the root TreeViewItem objects displayed in this node.

Inherited Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
AttachedNodes | Returns the nodes attached to this node. (Inherited from DiagramNode.)
AutoCaptureMouse | Gets or sets whether the item should capture the mouse input when the left button is pressed over it. This is a dependency property. (Inherited from DiagramItem.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. This is a dependency property. (Inherited from DiagramNode.)
Brush | Gets or sets the Brush that specifies how to paint the interior of the item. This is a dependency property. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Container | Gets the ContainerNode that contains this node. (Inherited from DiagramNode.)
Diagram | Gets the parent diagram. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramItem.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. This is a dependency property. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
IsMouseDown | Gets a value indicating whether the mouse button is pressed over this item. This is a dependency property. (Inherited from DiagramItem.)
IsMouseOver | Gets a value indicating whether the mouse pointer is located over this item. This is a dependency property. (Inherited from DiagramItem.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterNode | Gets the node to which this node is attached. This is a dependency property. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
RotationAngle | Gets or sets the angle at which this node is rotated. This is a dependency property. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShapeOpacity | Gets or sets the shape opacity of this node. This is a dependency property. (Inherited from DiagramNode.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline nodes. This is a dependency property. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashOffset | Gets or sets a double value that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. This is a dependency property. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
ToolTip | Gets or sets the contents of the tooltip displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of the object. (Inherited from DiagramItem.)

Inherited Protected Properties

Name | Description
Size | Gets the size of this item. (Inherited from DiagramItem.)

Public Methods

Name | Description
AcceptLinks | DiagramNode.AcceptLinks override.
GetItemRect | Gets the location and size of the specified TreeViewItem.
ItemFromPoint | Returns the item at the specified location.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
OnBoundsChanged | DiagramNode.OnBoundsChanged override.
ResizeToFitText | Resizes the tree view so that it is large enough to fit the text of its items.

Protected Methods

Name | Description
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
CreateState | DiagramItem.CreateState override.
GetOutline | DiagramNode.GetOutline override.
LoadFromXml | Loads the item content from an XML element.
RestoreState | DiagramItem.RestoreState override.
SaveState | DiagramItem.SaveState override.
SaveToXml | Saves the item content into an XML element.
ScaleElements | DiagramNode.ScaleElements override.
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it.

Inherited Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
Attach | Attaches the specified subordinate node to this node, so that when this node is moved, the subordinate follows it. (Inherited from DiagramNode.)
AttachTo | Attaches this node to the specified master node so that when the master is moved, the attached node follows it. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
ContainsPoint | DiagramItem.ContainsPoint override. (Inherited from DiagramNode.)
Detach | Overloaded. (Inherited from DiagramNode.)
GetAllIncomingLinks | Gets a collection of all links entering this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Get a collection of all links going out of this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from DiagramNode.)
OnBoundsChanged | Called when the location and size of this node change. (Inherited from DiagramNode.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RestoreLocationState | DiagramItem.RestoreLocationState override. (Inherited from DiagramNode.)
SaveLocationState | DiagramItem.SaveLocationState override. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point in diagram coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Gets the diagram coordinates of a point specified in the local coordinate system of this item. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Inherited Protected Methods

Name | Description
AddAnchorPointVisuals | Adds the AnchorPatern points to the node's Adorner. (Inherited from DiagramNode.)
AddExpandButton | Adds the ExpandButton to the node's Adoner. (Inherited from DiagramNode.)
AddHandlesToCanvas | Overloaded. (Inherited from DiagramNode.)
AllowDrag | Invoked to validate the drag operation. (Inherited from DiagramItem.)
CancelDrag | DiagramItem.CancelDrag override. (Inherited from DiagramNode.)
CreateAnchorPointVisual | Creates a Path that represents the specified AnchorPoint. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
EndDrag | DiagramItem.EndDrag override. (Inherited from DiagramNode.)
GetOutline | Creates a Geometry object that describes the outline of the node. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
LoadFromXml | DiagramItem.LoadFromXml override. (Inherited from DiagramNode.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramNode.)
OnMouseEnter | Control.OnMouseEnter override. (Inherited from DiagramItem.)
OnMouseLeave | Control.OnMouseLeave override. (Inherited from DiagramItem.)
OnMouseLeftButtonDown | Control.OnMouseLeftButtonDown override. (Inherited from DiagramItem.)
OnMouseLeftButtonUp | Control.OnMouseLeftButtonUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
RemoveAnchorPointVisuals | Removes the AnchorPatern points from the node's Adorner. (Inherited from DiagramNode.)
RemoveHandlesFromCanvas | Invoked when the item's selection handles should be removed. (Inherited from DiagramItem.)
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramNode.)
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
StartDrag | DiagramItem.StartDrag override. (Inherited from DiagramNode.)
UpdateDrag | DiagramItem.UpdateDrag override. (Inherited from DiagramNode.)
UpdateHandleColors | Sets the handle colors according to the current selection state of the item and the enabled bits in the EnabledHandles property. (Inherited from DiagramItem.)
UpdateHandlePositions | Invoked when the item's selection handles should change their position. (Inherited from DiagramItem.)
UpdateStates | Sets the current VisualStates of this item. (Inherited from DiagramItem.)
UpdateVisuals | DiagramItem.UpdateVisuals override. (Inherited from DiagramNode.)

See Also

TreeViewNode Class


MindFusion.Diagramming.TreeViewNode Fields

TreeViewNode Fields
[image]

Public Fields

Name | Description
BorderGeometryProperty | Identifies the BorderGeometry dependency property.
CaptionHeightProperty | Identifies the CaptionHeight dependency property.
CaptionImageProperty | Identifies the CaptionImage dependency property.
CaptionProperty | Identifies the Caption dependency property.
RootItemsProperty | Identifies the CaptionHeight dependency property.
ScrollableProperty | Identifies the Scrollable dependency property.

Inherited Public Fields

Name | Description
AutoCaptureMouseProperty | Identifies the AutoCaptureMouse dependency property. (Inherited from DiagramItem.)
BoundsProperty | Identifies the Bounds dependency property. (Inherited from DiagramNode.)
BrushProperty | Identifies the Brush dependency property. (Inherited from DiagramItem.)
EffectsSourceProperty | Identifies the EffectsSource dependency property. (Inherited from DiagramNode.)
HyperLinkProperty | Identifies the HyperLink dependency property. (Inherited from DiagramItem.)
IsMouseDownProperty | Identifies the IsMouseDown dependency property. (Inherited from DiagramItem.)
IsMouseOverProperty | Identifies the IsMouseOver dependency property. (Inherited from DiagramItem.)
MasterNodeProperty | Identifies the MasterNode dependency property. (Inherited from DiagramNode.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from DiagramNode.)
ShapeOpacityProperty | Identifies the ShapeOpacity dependency property. (Inherited from DiagramNode.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from DiagramItem.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)

Inherited Protected Fields

Name | Description
handles | A list of the Rectangle objects that represent the item's adjustment handles. (Inherited from DiagramItem.)

See Also

TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.BorderGeometryProperty Field

TreeViewNode.BorderGeometryProperty Field
[image]

Identifies the BorderGeometry dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BorderGeometryProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BorderGeometryProperty As DependencyProperty

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.CaptionHeightProperty Field

TreeViewNode.CaptionHeightProperty Field
[image]

Identifies the CaptionHeight dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CaptionHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CaptionHeightProperty As DependencyProperty

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.CaptionImageProperty Field

TreeViewNode.CaptionImageProperty Field
[image]

Identifies the CaptionImage dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CaptionImageProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CaptionImageProperty As DependencyProperty

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.CaptionProperty Field

TreeViewNode.CaptionProperty Field
[image]

Identifies the Caption dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CaptionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CaptionProperty As DependencyProperty

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.RootItemsProperty Field

TreeViewNode.RootItemsProperty Field
[image]

Identifies the CaptionHeight dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RootItemsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RootItemsProperty As DependencyProperty

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.ScrollableProperty Field

TreeViewNode.ScrollableProperty Field
[image]

Identifies the Scrollable dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScrollableProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScrollableProperty As DependencyProperty

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode Constructor

TreeViewNode Constructor
[image]

Overload List

Name | Description
TreeViewNode () | Initializes a new instance of the TreeViewNode class.
TreeViewNode (Diagram) | Initializes a new instance of the TreeViewNode class.
TreeViewNode (TreeViewNode) | Initializes a new instance of the TreeViewNode class using the specified node as a prototype.

See Also

TreeViewNode Class


MindFusion.Diagramming.TreeViewNode Constructor ()

TreeViewNode Constructor ()
See Also
[image]

Initializes a new instance of the TreeViewNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewNode ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TreeViewNode Constructor Overload List
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode Constructor (Diagram)

TreeViewNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the TreeViewNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewNode (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram from which to obtain default values for the node properties.

Remarks

This constructor initializes the TreeViewNode properties with the values specified in the respective default-value properties of the Diagram object.

See Also

TreeViewNode Constructor Overload List
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode Constructor (TreeViewNode)

TreeViewNode Constructor (TreeViewNode)
See Also
[image]

Initializes a new instance of the TreeViewNode class using the specified node as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewNode (
TreeViewNode prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As TreeViewNode _
)

Parameters

prototype

The treeview node to use as a prototype. The properties of the new treeview are initialized from the property values of prototype.

Remarks

This constructor copies the TreeViewNode property values from the specified prototype node.

See Also

TreeViewNode Constructor Overload List
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode Methods

TreeViewNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | DiagramNode.AcceptLinks override.
GetItemRect | Gets the location and size of the specified TreeViewItem.
ItemFromPoint | Returns the item at the specified location.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
OnBoundsChanged | DiagramNode.OnBoundsChanged override.
ResizeToFitText | Resizes the tree view so that it is large enough to fit the text of its items.

Protected Methods

Name | Description
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
CreateState | DiagramItem.CreateState override.
GetOutline | DiagramNode.GetOutline override.
LoadFromXml | Loads the item content from an XML element.
RestoreState | DiagramItem.RestoreState override.
SaveState | DiagramItem.SaveState override.
SaveToXml | Saves the item content into an XML element.
ScaleElements | DiagramNode.ScaleElements override.
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it.

Inherited Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
Attach | Attaches the specified subordinate node to this node, so that when this node is moved, the subordinate follows it. (Inherited from DiagramNode.)
AttachTo | Attaches this node to the specified master node so that when the master is moved, the attached node follows it. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
ContainsPoint | DiagramItem.ContainsPoint override. (Inherited from DiagramNode.)
Detach | Overloaded. (Inherited from DiagramNode.)
GetAllIncomingLinks | Gets a collection of all links entering this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Get a collection of all links going out of this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from DiagramNode.)
OnBoundsChanged | Called when the location and size of this node change. (Inherited from DiagramNode.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RestoreLocationState | DiagramItem.RestoreLocationState override. (Inherited from DiagramNode.)
SaveLocationState | DiagramItem.SaveLocationState override. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point in diagram coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Gets the diagram coordinates of a point specified in the local coordinate system of this item. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Inherited Protected Methods

Name | Description
AddAnchorPointVisuals | Adds the AnchorPatern points to the node's Adorner. (Inherited from DiagramNode.)
AddExpandButton | Adds the ExpandButton to the node's Adoner. (Inherited from DiagramNode.)
AddHandlesToCanvas | Overloaded. (Inherited from DiagramNode.)
AllowDrag | Invoked to validate the drag operation. (Inherited from DiagramItem.)
CancelDrag | DiagramItem.CancelDrag override. (Inherited from DiagramNode.)
CreateAnchorPointVisual | Creates a Path that represents the specified AnchorPoint. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
EndDrag | DiagramItem.EndDrag override. (Inherited from DiagramNode.)
GetOutline | Creates a Geometry object that describes the outline of the node. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
LoadFromXml | DiagramItem.LoadFromXml override. (Inherited from DiagramNode.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramNode.)
OnMouseEnter | Control.OnMouseEnter override. (Inherited from DiagramItem.)
OnMouseLeave | Control.OnMouseLeave override. (Inherited from DiagramItem.)
OnMouseLeftButtonDown | Control.OnMouseLeftButtonDown override. (Inherited from DiagramItem.)
OnMouseLeftButtonUp | Control.OnMouseLeftButtonUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
RemoveAnchorPointVisuals | Removes the AnchorPatern points from the node's Adorner. (Inherited from DiagramNode.)
RemoveHandlesFromCanvas | Invoked when the item's selection handles should be removed. (Inherited from DiagramItem.)
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramNode.)
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
StartDrag | DiagramItem.StartDrag override. (Inherited from DiagramNode.)
UpdateDrag | DiagramItem.UpdateDrag override. (Inherited from DiagramNode.)
UpdateHandleColors | Sets the handle colors according to the current selection state of the item and the enabled bits in the EnabledHandles property. (Inherited from DiagramItem.)
UpdateHandlePositions | Invoked when the item's selection handles should change their position. (Inherited from DiagramItem.)
UpdateStates | Sets the current VisualStates of this item. (Inherited from DiagramItem.)
UpdateVisuals | DiagramItem.UpdateVisuals override. (Inherited from DiagramNode.)

See Also

TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.AcceptLinks Method

TreeViewNode.AcceptLinks Method
[image]

DiagramNode.AcceptLinks override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool AcceptLinks (
bool outgoing
)

Visual Basic [image] Copy Code

Public Overrides Function AcceptLinks( _
outgoing As Boolean _
) As Boolean

Parameters

outgoing

true to check for outgoing links; otherwise, false.

Return Value

true if the node accepts connections of the specified type; otherwise, false.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.CreateConnectionPoint Method

TreeViewNode.CreateConnectionPoint Method
[image]

DiagramNode.CreateConnectionPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual ConnectionPoint CreateConnectionPoint (
DiagramLink link,
Point pt,
bool incoming
)

Visual Basic [image] Copy Code

Protected Overridable Function CreateConnectionPoint ( _
link As DiagramLink, _
pt As Point, _
incoming As Boolean _
) As ConnectionPoint

Parameters

link
A DiagramLink that should be connected to this node.
pt

The point at which the link should be connected.

incoming
true if link is an incoming link; otherwise, false.

Return Value

A ConnectionPoint instance representing the connection.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.CreateState Method

TreeViewNode.CreateState Method
[image]

DiagramItem.CreateState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramItemState CreateState ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateState () As DiagramItemState

Return Value

A TreeViewNodeState object containing a snapshot of the node's properties.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.GetItemRect Method

TreeViewNode.GetItemRect Method
[image]

Gets the location and size of the specified TreeViewItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect GetItemRect (
TreeViewItem treeItem
)

Visual Basic [image] Copy Code

Public Function GetItemRect ( _
treeItem As TreeViewItem _
) As Rect

Parameters

treeItem
A TreeViewItem instance.

Return Value

A Rect specifying the item's position and size.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.GetOutline Method

TreeViewNode.GetOutline Method
[image]

DiagramNode.GetOutline override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Geometry GetOutline ()

Visual Basic [image] Copy Code

Protected Overrides Function GetOutline () As Geometry

Return Value

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.ItemFromPoint Method

TreeViewNode.ItemFromPoint Method
[image]

Returns the item at the specified location.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewItem ItemFromPoint (
Point point,
bool isDiagramCoordinate
)

Visual Basic [image] Copy Code

Public Function ItemFromPoint( _
point As Point, _
isDiagramCoordinate As Boolean _
) As TreeViewItem

Parameters

point

The point to check.

isDiagramCoordinate

true if the point is specified in diagram coordinates; false if the point is specified in item local coordinates.

Return Value

The TreeViewItem instance that contains the specified point.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.LoadFromXml Method

TreeViewNode.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFromXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFromXml ( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XElement containing the item's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.OnApplyTemplate Method

TreeViewNode.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Overrides Sub OnApplyTemplate ()

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.OnBoundsChanged Method

TreeViewNode.OnBoundsChanged Method
[image]

DiagramNode.OnBoundsChanged override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void OnBoundsChanged (
Rect oldRect,
Rect newRect,
bool updateLinks,
bool updateChildren,
bool updateStorage
)

Visual Basic [image] Copy Code

Public Overrides Sub OnBoundsChanged( _
oldRect As Rect, _
newRect As Rect, _
updateLinks As Boolean, _
updateChildren As Boolean, _
updateStorage As Boolean _
)

Parameters

oldRect

newRect

updateLinks

updateChildren

updateStorage

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.ResizeToFitText Method

TreeViewNode.ResizeToFitText Method
[image]

Resizes the tree view so that it is large enough to fit the text of its items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ResizeToFitText ()

Visual Basic [image] Copy Code

Public Sub ResizeToFitText ()

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.RestoreState Method

TreeViewNode.RestoreState Method
[image]

DiagramItem.RestoreState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void RestoreState (
DiagramItemState itemState
)

Visual Basic [image] Copy Code

Protected Overridable Sub RestoreState ( _
itemState As DiagramItemState _
)

Parameters

itemState
A TreeViewNodeState instance containing a snapshot of the item's properties.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.SaveState Method

TreeViewNode.SaveState Method
[image]

DiagramItem.SaveState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramItemState SaveState ()

Visual Basic [image] Copy Code

Protected Overridable Function SaveState () As DiagramItemState

Return Value

A TreeViewNodeState object containing the node's saved properties.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.SaveToXml Method

TreeViewNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveToXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveToXml ( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XElement the item's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.ScaleElements Method

TreeViewNode.ScaleElements Method
[image]

DiagramNode.ScaleElements override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void ScaleElements (
double scale
)

Visual Basic [image] Copy Code

Protected Overrides Sub ScaleElements( _
scale As Double _
)

Parameters

scale

The value by which to multiply node elements' sizes.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.SetReflexive Method

TreeViewNode.SetReflexive Method
[image]

Invoked to let a node set the shape of a reflexive link connected to it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SetReflexive (
Action action,
DiagramLink link
)

Visual Basic [image] Copy Code

Protected Overrides Sub SetReflexive( _
action As Action, _
link As DiagramLink _
)

Parameters

action

Specifies what action is being carried out by the user.

link

Reference to the link.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode Properties

TreeViewNode Properties
[image]

Public Properties

Name | Description
BorderGeometry | Gets or sets the RectangleGeometry object that defines the TreeViewNode outline.
Caption | Gets or sets the text displayed as caption of the node.
CaptionHeight | Gets or sets the height of the node's caption area.
CaptionImage | Gets or sets the image displayed as caption of the node.
ConnectionStyle | Gets or sets a value indicating whether drawing a link from/to this node should connect an item or the whole node as an integral entity.
RootItems | Gets a list of the root TreeViewItem objects displayed in this node.

Inherited Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
AttachedNodes | Returns the nodes attached to this node. (Inherited from DiagramNode.)
AutoCaptureMouse | Gets or sets whether the item should capture the mouse input when the left button is pressed over it. This is a dependency property. (Inherited from DiagramItem.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. This is a dependency property. (Inherited from DiagramNode.)
Brush | Gets or sets the Brush that specifies how to paint the interior of the item. This is a dependency property. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Container | Gets the ContainerNode that contains this node. (Inherited from DiagramNode.)
Diagram | Gets the parent diagram. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramItem.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. This is a dependency property. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
IsMouseDown | Gets a value indicating whether the mouse button is pressed over this item. This is a dependency property. (Inherited from DiagramItem.)
IsMouseOver | Gets a value indicating whether the mouse pointer is located over this item. This is a dependency property. (Inherited from DiagramItem.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterNode | Gets the node to which this node is attached. This is a dependency property. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
RotationAngle | Gets or sets the angle at which this node is rotated. This is a dependency property. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShapeOpacity | Gets or sets the shape opacity of this node. This is a dependency property. (Inherited from DiagramNode.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline nodes. This is a dependency property. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashOffset | Gets or sets a double value that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. This is a dependency property. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
ToolTip | Gets or sets the contents of the tooltip displayed when the mouse pointer rests over the diagram element. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of the object. (Inherited from DiagramItem.)

Inherited Protected Properties

Name | Description
Size | Gets the size of this item. (Inherited from DiagramItem.)

See Also

TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.BorderGeometry Property

TreeViewNode.BorderGeometry Property
[image]

Gets or sets the RectangleGeometry object that defines the TreeViewNode outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RectangleGeometry BorderGeometry { get; set; }

Visual Basic [image] Copy Code

Public Property BorderGeometry As RectangleGeometry

Property Value

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.Caption Property

TreeViewNode.Caption Property
[image]

Gets or sets the text displayed as caption of the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Caption { get; set; }

Visual Basic [image] Copy Code

Public Property Caption As String

Property Value

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.CaptionHeight Property

TreeViewNode.CaptionHeight Property
[image]

Gets or sets the height of the node's caption area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double CaptionHeight { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionHeight As Double

Property Value

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.CaptionImage Property

TreeViewNode.CaptionImage Property
[image]

Gets or sets the image displayed as caption of the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ImageSource CaptionImage { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionImage As ImageSource

Property Value

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.ConnectionStyle Property

TreeViewNode.ConnectionStyle Property
[image]

Gets or sets a value indicating whether drawing a link from/to this node should connect an item or the whole node as an integral entity.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewConnectionStyle ConnectionStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ConnectionStyle As TreeViewConnectionStyle

Property Value

A member of the TreeViewConnectionStyle enumeration. The default value is Items.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.RootItems Property

TreeViewNode.RootItems Property
[image]

Gets a list of the root TreeViewItem objects displayed in this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeItemCollection RootItems { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RootItems As TreeItemCollection

Property Value

An instance of the TreeItemCollection class.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNodeState Class

TreeViewNodeState Class
[image]

Represents the state of a TreeViewNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TreeViewNodeState : DiagramNodeState

Visual Basic [image] Copy Code

Public Class TreeViewNodeState
Inherits DiagramNodeState

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemState
MindFusion.Diagramming.DiagramNodeState
MindFusion.Diagramming.TreeViewNodeState

See Also

TreeViewNodeState Members


MindFusion.Diagramming.TreeViewNodeState Members

TreeViewNodeState Members
Constructors
[image]

Represents the state of a TreeViewNode.

The following tables list the members exposed by the TreeViewNodeState type.

Public Constructors

Name | Description
TreeViewNodeState |

See Also

TreeViewNodeState Class


MindFusion.Diagramming.TreeViewNodeState Constructor

TreeViewNodeState Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewNodeState ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TreeViewNodeState Class


MindFusion.Diagramming.UndoEventArgs Class

UndoEventArgs Class
[image]

Contains the arguments passed to the ActionRecorded, ActionUndone and ActionRedone event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class UndoEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class UndoEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.UndoEventArgs

See Also

UndoEventArgs Members


MindFusion.Diagramming.UndoEventArgs Members

UndoEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the ActionRecorded, ActionUndone and ActionRedone event handlers.

The following tables list the members exposed by the UndoEventArgs type.

Public Constructors

Name | Description
UndoEventArgs | Initializes a new instance of the UndoEventArgs class.

Public Properties

Name | Description
Command | Gets a reference to the Command instance related to the event being handled.

See Also

UndoEventArgs Class


MindFusion.Diagramming.UndoEventArgs Constructor

UndoEventArgs Constructor
[image]

Initializes a new instance of the UndoEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public UndoEventArgs (
Command command
)

Visual Basic [image] Copy Code

Public New ( _
command As Command _
)

Parameters

command

The Command related to the event.

See Also

UndoEventArgs Class


MindFusion.Diagramming.UndoEventArgs Properties

UndoEventArgs Properties
[image]

Public Properties

Name | Description
Command | Gets a reference to the Command instance related to the event being handled.

See Also

UndoEventArgs Class


MindFusion.Diagramming.UndoEventArgs.Command Property

UndoEventArgs.Command Property
[image]

Gets a reference to the Command instance related to the event being handled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Command Command { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Command As Command

Property Value

An instance of the Command class.

See Also

UndoEventArgs Members
UndoEventArgs Class


MindFusion.Diagramming.Utilities Class

Utilities Class
[image]

Contains common helper methods.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class Utilities

Visual Basic [image] Copy Code

Public NotInheritable Class Utilities

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Utilities

See Also

Utilities Members


MindFusion.Diagramming.Utilities Members

Utilities Members
Methods
[image]

Contains common helper methods.

The following tables list the members exposed by the Utilities type.

Public Methods

Name | Description
AddArc | Overloaded.
AddBezier | Adds a Bezier curve to the specified PathFigure.
AddBeziers | Adds a series of Bezier curves to the specified PathFigure.
AddLine | Overloaded.
AddPolyLine | Overloaded.
AddRoundRect | Overloaded.
ApproxArc | Approximates an arc by a series of line segments.
ApproxBezier | Overloaded.
ApproxRoundRect | Overloaded.
ArcPoint | Returns the point that lies on an ellipse bounded by the specified rectangle at the specified angle.
BottomLeft | Returns the bottom left point of the specified rectangle.
BottomRight | Returns the bottom right point of the specified rectangle.
CalcBezierCoef | Calculates the bezier coefficients in the equation of the specified bezier curve.
CartesianToPolar | Converts Cartesian coordinates to the corresponding polar coordinates, using the specified point as a center of the coordinate system.
Ccw | Determines, given three points, if when travelling from the first to the second to the third, we travel in a counterclockwise direction.
Center | Returns the center of the specified rectangle.
CheckIntersect | Checks if the specified rectangle and circle intersect.
Closer | Overloaded.
Contains | Checks whether the specified hashtable contains the specified key.
Degrees | Converts the specified value from degrees to radians.
Distance | Overloaded.
DistanceSq | Calculates the square of the distance between the specified points.
DistanceToLine | Returns the distance from a point to a line.
DistanceToLineSquared | Returns the squared distance between the specified points.
DistanceToSegment | Returns the distance from a point to a line segment.
DistanceToSegmentSquared | Returns the squared distance from a point to a line segment.
DistToBezier | Calculates the shortest distance from the specified point to the specified bezier curve.
DistToPolyline | Overloaded.
DistToRectPoint | Returns the nearest to pt point that lies on the outline of rectangle.
FromLTRB | Creates a new Windows.UI.Xaml.Rect out of the specified coordinates.
GetBezierPt | Gets the point from the specified bezier curve, corresponding to the specified parameter t [0, 1].
GetEllipseIntr | Calculate the intersection point between the ellipse with the specified bounds and the line segment defined by the specified points.
GetLoadedType | Gets the type with the specified name.
GetMinArrowheadSize | Gets the minimum allowed size of an arrowhead.
GetRect | Gets the position and size of the specified element on the canvas.
GetRectIntr | Calculates the intersection point between the specified rectangle and the line segment defined by the specified points.
GetReflHth | Gets the initial distance between adjacent control points of a reflexive arrow along the Y-axis.
GetReflWth2 | Gets the initial distance between adjacent control points of a reflexive link along the X-axis.
GetRootVisual | Gets the application's root visual element.
Inflate | Adds the specified amount to the rectangle dimensions in all directions.
Intersect | Determines whether the specified line segments intersect.
IntersectsLineSegment | Gets the intersection point of a line segments and a rectangle.
LineIntersect | Finds the intersection point of the lines defined by the specified point pairs.
LineIntersectNaN | Finds the intersection point of the lines defined by the specified point pairs.
LineSegmentsIntersect | Gets the intersection point of two line segments AB and CD.
LoadImage | Loads an image from the specified stream.
MatchPointsMinLength | Returns an array of node anchor points which match current node links anchor point
MeasureText | Measures the specified text when drawn with the specified font.
MidPoint | Returns the middle point of the segment defined by the specified points.
MinDistToRect | Calculates the minimum distance between a given point and a given rectangle.
NearestPoint | Returns the element from the specified point array nearest to the specified point.
Offset | Moves the specified rectangle by the specified offset.
PointInEllipse | Checks whether the specified point is contained in the ellipse defined by the specified rectangle.
PointInRect | Checks whether the specified rectangle contains the specified point.
PolarToCartesian | Converts polar coordinates to the corresponding Cartesian coordinates, using the specified point as a center of the coordinate system.
Radians | Converts the specified value from degrees to radians.
RectIntersects | Determines if rectangle intersects with rect.
SegmentIntersect | Checks whether the segments defined by the specified point pairs intersect and returns the intersection point.
TopLeft | Returns the top left point of the specified rectangle.
TopRight | Returns the top right point of the specified rectangle.
UnionNonEmptyRects | Returns the smallest possible rectangle containing both of the specified rectangles, but only if the rectangles are non-empty.
UnionRects | Returns the smallest possible rectangle containing both of the specified rectangles.

See Also

Utilities Class


MindFusion.Diagramming.Utilities Methods

Utilities Methods
[image]

Public Methods

Name | Description
AddArc | Overloaded.
AddBezier | Adds a Bezier curve to the specified PathFigure.
AddBeziers | Adds a series of Bezier curves to the specified PathFigure.
AddLine | Overloaded.
AddPolyLine | Overloaded.
AddRoundRect | Overloaded.
ApproxArc | Approximates an arc by a series of line segments.
ApproxBezier | Overloaded.
ApproxRoundRect | Overloaded.
ArcPoint | Returns the point that lies on an ellipse bounded by the specified rectangle at the specified angle.
BottomLeft | Returns the bottom left point of the specified rectangle.
BottomRight | Returns the bottom right point of the specified rectangle.
CalcBezierCoef | Calculates the bezier coefficients in the equation of the specified bezier curve.
CartesianToPolar | Converts Cartesian coordinates to the corresponding polar coordinates, using the specified point as a center of the coordinate system.
Ccw | Determines, given three points, if when travelling from the first to the second to the third, we travel in a counterclockwise direction.
Center | Returns the center of the specified rectangle.
CheckIntersect | Checks if the specified rectangle and circle intersect.
Closer | Overloaded.
Contains | Checks whether the specified hashtable contains the specified key.
Degrees | Converts the specified value from degrees to radians.
Distance | Overloaded.
DistanceSq | Calculates the square of the distance between the specified points.
DistanceToLine | Returns the distance from a point to a line.
DistanceToLineSquared | Returns the squared distance between the specified points.
DistanceToSegment | Returns the distance from a point to a line segment.
DistanceToSegmentSquared | Returns the squared distance from a point to a line segment.
DistToBezier | Calculates the shortest distance from the specified point to the specified bezier curve.
DistToPolyline | Overloaded.
DistToRectPoint | Returns the nearest to pt point that lies on the outline of rectangle.
FromLTRB | Creates a new Windows.UI.Xaml.Rect out of the specified coordinates.
GetBezierPt | Gets the point from the specified bezier curve, corresponding to the specified parameter t [0, 1].
GetEllipseIntr | Calculate the intersection point between the ellipse with the specified bounds and the line segment defined by the specified points.
GetLoadedType | Gets the type with the specified name.
GetMinArrowheadSize | Gets the minimum allowed size of an arrowhead.
GetRect | Gets the position and size of the specified element on the canvas.
GetRectIntr | Calculates the intersection point between the specified rectangle and the line segment defined by the specified points.
GetReflHth | Gets the initial distance between adjacent control points of a reflexive arrow along the Y-axis.
GetReflWth2 | Gets the initial distance between adjacent control points of a reflexive link along the X-axis.
GetRootVisual | Gets the application's root visual element.
Inflate | Adds the specified amount to the rectangle dimensions in all directions.
Intersect | Determines whether the specified line segments intersect.
IntersectsLineSegment | Gets the intersection point of a line segments and a rectangle.
LineIntersect | Finds the intersection point of the lines defined by the specified point pairs.
LineIntersectNaN | Finds the intersection point of the lines defined by the specified point pairs.
LineSegmentsIntersect | Gets the intersection point of two line segments AB and CD.
LoadImage | Loads an image from the specified stream.
MatchPointsMinLength | Returns an array of node anchor points which match current node links anchor point
MeasureText | Measures the specified text when drawn with the specified font.
MidPoint | Returns the middle point of the segment defined by the specified points.
MinDistToRect | Calculates the minimum distance between a given point and a given rectangle.
NearestPoint | Returns the element from the specified point array nearest to the specified point.
Offset | Moves the specified rectangle by the specified offset.
PointInEllipse | Checks whether the specified point is contained in the ellipse defined by the specified rectangle.
PointInRect | Checks whether the specified rectangle contains the specified point.
PolarToCartesian | Converts polar coordinates to the corresponding Cartesian coordinates, using the specified point as a center of the coordinate system.
Radians | Converts the specified value from degrees to radians.
RectIntersects | Determines if rectangle intersects with rect.
SegmentIntersect | Checks whether the segments defined by the specified point pairs intersect and returns the intersection point.
TopLeft | Returns the top left point of the specified rectangle.
TopRight | Returns the top right point of the specified rectangle.
UnionNonEmptyRects | Returns the smallest possible rectangle containing both of the specified rectangles, but only if the rectangles are non-empty.
UnionRects | Returns the smallest possible rectangle containing both of the specified rectangles.

See Also

Utilities Class


MindFusion.Diagramming.Utilities.AddArc Method

Utilities.AddArc Method
[image]

Overload List

Name | Description
Utilities.AddArc (PathFigure, Double, Double, Double, Double, Double, Double, Boolean) | Adds an arc segment to the specified PathFigure.
Utilities.AddArc (PathFigure, Rect, Double, Double, Boolean) | Adds an arc segment to the specified PathFigure.

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.AddArc Method (PathFigure, Double, Double, Double, Double, Double, Double, Boolean)

Utilities.AddArc Method (PathFigure, Double, Double, Double, Double, Double, Double, Boolean)
See Also
[image]

Adds an arc segment to the specified PathFigure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void AddArc (
PathFigure path,
double x,
double y,
double w,
double h,
double startAngle,
double sweep,
bool setStartPoint
)

Visual Basic [image] Copy Code

Public Shared Sub AddArc( _
path As PathFigure, _
x As Double, _
y As Double, _
w As Double, _
h As Double, _
startAngle As Double, _
sweep As Double, _
setStartPoint As Boolean _
)

Parameters

path

x

y

w

h

startAngle

sweep

setStartPoint

See Also

AddArc Method Overload List
Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.AddArc Method (PathFigure, Rect, Double, Double, Boolean)

Utilities.AddArc Method (PathFigure, Rect, Double, Double, Boolean)
See Also
[image]

Adds an arc segment to the specified PathFigure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static PathFigure AddArc (
PathFigure pf,
Rect r,
double start,
double sweep,
bool setStartPoint
)

Visual Basic [image] Copy Code

Public Shared Function AddArc( _
pf As PathFigure, _
r As Rect, _
start As Double, _
sweep As Double, _
setStartPoint As Boolean _
) As PathFigure

Parameters

pf

r

start

sweep

setStartPoint

Return Value

See Also

AddArc Method Overload List
Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.AddBezier Method

Utilities.AddBezier Method
[image]

Adds a Bezier curve to the specified PathFigure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void AddBezier (
PathFigure path,
double[] points
)

Visual Basic [image] Copy Code

Public Shared Sub AddBezier( _
path As PathFigure, _
points() As Double _
)

Parameters

path

points

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.AddBeziers Method

Utilities.AddBeziers Method
[image]

Adds a series of Bezier curves to the specified PathFigure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void AddBeziers (
PathFigure figure,
Point[] points
)

Visual Basic [image] Copy Code

Public Shared Sub AddBeziers( _
figure As PathFigure, _
points() As Point _
)

Parameters

figure

points

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.AddLine Method

Utilities.AddLine Method
[image]

Overload List

Name | Description
Utilities.AddLine (PathFigure, Double, Double, Double, Double) | Adds a line segment to the specified PathFigure.
Utilities.AddLine (PathFigure, Point, Point) | Adds a line segment to the specified PathFigure.

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.AddLine Method (PathFigure, Double, Double, Double, Double)

Utilities.AddLine Method (PathFigure, Double, Double, Double, Double)
See Also
[image]

Adds a line segment to the specified PathFigure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static PathFigure AddLine (
PathFigure p,
double x1,
double y1,
double x2,
double y2
)

Visual Basic [image] Copy Code

Public Shared Function AddLine( _
p As PathFigure, _
x1 As Double, _
y1 As Double, _
x2 As Double, _
y2 As Double _
) As PathFigure

Parameters

p

x1

y1

x2

y2

Return Value

See Also

AddLine Method Overload List
Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.AddLine Method (PathFigure, Point, Point)

Utilities.AddLine Method (PathFigure, Point, Point)
See Also
[image]

Adds a line segment to the specified PathFigure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static PathFigure AddLine (
PathFigure p,
Point p1,
Point p2
)

Visual Basic [image] Copy Code

Public Shared Function AddLine( _
p As PathFigure, _
p1 As Point, _
p2 As Point _
) As PathFigure

Parameters

p

p1

p2

Return Value

See Also

AddLine Method Overload List
Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.AddPolyLine Method

Utilities.AddPolyLine Method
[image]

Overload List

Name | Description
Utilities.AddPolyLine (PathFigure, Point[]) | Adds a series of line segments to the specified PathFigure.
Utilities.AddPolyLine (PathFigure, PointCollection) | Adds a series of line segments to the specified PathFigure.

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.AddPolyLine Method (PathFigure, Point[])

Utilities.AddPolyLine Method (PathFigure, Point[])
See Also
[image]

Adds a series of line segments to the specified PathFigure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void AddPolyLine (
PathFigure figure,
Point[] shape
)

Visual Basic [image] Copy Code

Public Shared Sub AddPolyLine( _
figure As PathFigure, _
shape() As Point _
)

Parameters

figure

shape

See Also

AddPolyLine Method Overload List
Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.AddPolyLine Method (PathFigure, PointCollection)

Utilities.AddPolyLine Method (PathFigure, PointCollection)
See Also
[image]

Adds a series of line segments to the specified PathFigure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void AddPolyLine (
PathFigure figure,
PointCollection collection
)

Visual Basic [image] Copy Code

Public Shared Sub AddPolyLine( _
figure As PathFigure, _
collection As PointCollection _
)

Parameters

figure

collection

See Also

AddPolyLine Method Overload List
Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.AddRoundRect Method

Utilities.AddRoundRect Method
[image]

Overload List

Name | Description
Utilities.AddRoundRect (PathFigure, Double, Double, Double, Double, Double, Boolean) | Creates a graphics path of a rounded rectangle with the specified dimensions and round radius.
Utilities.AddRoundRect (PathFigure, Rect, Double, Boolean) | Adds a rounded rectangle to the specified path figure.

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.AddRoundRect Method (PathFigure, Double, Double, Double, Double, Double, Boolean)

Utilities.AddRoundRect Method (PathFigure, Double, Double, Double, Double, Double, Boolean)
See Also
[image]

Creates a graphics path of a rounded rectangle with the specified dimensions and round radius.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static PathFigure AddRoundRect (
PathFigure gp,
double x,
double y,
double width,
double height,
double r,
bool setStartPoint
)

Visual Basic [image] Copy Code

Public Shared Function AddRoundRect( _
gp As PathFigure, _
x As Double, _
y As Double, _
width As Double, _
height As Double, _
r As Double, _
setStartPoint As Boolean _
) As PathFigure

Parameters

gp

x

y

width

height

r

setStartPoint

Return Value

See Also

AddRoundRect Method Overload List
Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.AddRoundRect Method (PathFigure, Rect, Double, Boolean)

Utilities.AddRoundRect Method (PathFigure, Rect, Double, Boolean)
See Also
[image]

Adds a rounded rectangle to the specified path figure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static PathFigure AddRoundRect (
PathFigure pf,
Rect rc,
double r,
bool setStartPoint
)

Visual Basic [image] Copy Code

Public Shared Function AddRoundRect( _
pf As PathFigure, _
rc As Rect, _
r As Double, _
setStartPoint As Boolean _
) As PathFigure

Parameters

pf

rc

r

setStartPoint

Return Value

See Also

AddRoundRect Method Overload List
Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.ApproxArc Method

Utilities.ApproxArc Method
[image]

Approximates an arc by a series of line segments.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static List<Point> ApproxArc (
Point tl,
Point br,
double a,
double s
)

Visual Basic [image] Copy Code

Public Shared Function ApproxArc( _
tl As Point, _
br As Point, _
a As Double, _
s As Double _
) As List(Of Point)

Parameters

tl
A Windows.UI.Xaml.Point specifying the top-left position of the rectangle that bounds the arc's ellipse.
br
A Windows.UI.Xaml.Point specifying the top-left position of the rectangle that bounds the arc's ellipse.
a
The arc's start angle.
s
The arc's sweep angle.

Return Value

A list of points that approximate the arc as series of straight line segments.

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.ApproxBezier Method

Utilities.ApproxBezier Method
[image]

Overload List

Name | Description
Utilities.ApproxBezier (Point[], Int32) | Approximates a Bezier curve by a series of line segments.
Utilities.ApproxBezier (Point[], Int32, Int32) | Approximates the specified bezier curve with a polyline. The specified quality parameter varies in the interval [1, ...) and is proportional to the number of points in the resulting polyline.

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.ApproxBezier Method (Point[], Int32)

Utilities.ApproxBezier Method (Point[], Int32)
See Also
[image]

Approximates a Bezier curve by a series of line segments.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static List<Point> ApproxBezier (
Point[] points,
int quality
)

Visual Basic [image] Copy Code

Public Shared Function ApproxBezier( _
points() As Point, _
quality As Integer _
) As List(Of Point)

Parameters

points
A list of Bezier control points.
quality
Specifies the approximation quality.

Return Value

A list of points that approximate the curve as a series of straight line segments.

See Also

ApproxBezier Method Overload List
Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.ApproxBezier Method (Point[], Int32, Int32)

Utilities.ApproxBezier Method (Point[], Int32, Int32)
See Also
[image]

Approximates the specified bezier curve with a polyline. The specified quality parameter varies in the interval [1, ...) and is proportional to the number of points in the resulting polyline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Point[] ApproxBezier (
Point[] points,
int startIdx,
int quality
)

Visual Basic [image] Copy Code

Public Shared Function ApproxBezier( _
points() As Point, _
startIdx As Integer, _
quality As Integer _
) As Point()

Parameters

points
A list of Bezier control points.
startIdx

Index of the first point in the points array to include in the approximation.

quality
Specifies the approximation quality.

Return Value

A list of points that approximate the curve as a series of straight line segments.

See Also

ApproxBezier Method Overload List
Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.ApproxRoundRect Method

Utilities.ApproxRoundRect Method
[image]

Overload List

Name | Description
Utilities.ApproxRoundRect (Double, Double, Double, Double, Double) | Approximates a rounded rectangle by a series of line segments.
Utilities.ApproxRoundRect (Rect, Double) | Approximates a rounded rectangle by a series of line segments.

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.ApproxRoundRect Method (Double, Double, Double, Double, Double)

Utilities.ApproxRoundRect Method (Double, Double, Double, Double, Double)
See Also
[image]

Approximates a rounded rectangle by a series of line segments.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static List<Point> ApproxRoundRect (
double x,
double y,
double width,
double height,
double r
)

Visual Basic [image] Copy Code

Public Shared Function ApproxRoundRect( _
x As Double, _
y As Double, _
width As Double, _
height As Double, _
r As Double _
) As List(Of Point)

Parameters

x
The rectangle's horizontal position.
y
The rectangle's vertical position.
width
The rectangle's width.
height
The rectangle's height.
r
Radius of arcs drawn at the rectangle's corners.

Return Value

A list of points that approximate the rounded rectangle as a series of straight line segments.

See Also

ApproxRoundRect Method Overload List
Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.ApproxRoundRect Method (Rect, Double)

Utilities.ApproxRoundRect Method (Rect, Double)
See Also
[image]

Approximates a rounded rectangle by a series of line segments.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static List<Point> ApproxRoundRect (
Rect rect,
double r
)

Visual Basic [image] Copy Code

Public Shared Function ApproxRoundRect( _
rect As Rect, _
r As Double _
) As List(Of Point)

Parameters

rect
A Rect instance specifying the rectangle's position and size.
r
Radius of arcs drawn at the rectangle's corners.

Return Value

A list of points that approximate the rounded rectangle as a series of straight line segments.

See Also

ApproxRoundRect Method Overload List
Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.ArcPoint Method

Utilities.ArcPoint Method
[image]

Returns the point that lies on an ellipse bounded by the specified rectangle at the specified angle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Point ArcPoint (
Rect r,
double angle
)

Visual Basic [image] Copy Code

Public Shared Function ArcPoint( _
r As Rect, _
angle As Double _
) As Point

Parameters

r

angle

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.BottomLeft Method

Utilities.BottomLeft Method
[image]

Returns the bottom left point of the specified rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Point BottomLeft (
Rect rect
)

Visual Basic [image] Copy Code

Public Shared Function BottomLeft( _
rect As Rect _
) As Point

Parameters

rect

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.BottomRight Method

Utilities.BottomRight Method
[image]

Returns the bottom right point of the specified rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Point BottomRight (
Rect rect
)

Visual Basic [image] Copy Code

Public Shared Function BottomRight( _
rect As Rect _
) As Point

Parameters

rect

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.CalcBezierCoef Method

Utilities.CalcBezierCoef Method
[image]

Calculates the bezier coefficients in the equation of the specified bezier curve.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void CalcBezierCoef (
ref double a0,
ref double a1,
ref double a2,
ref double a3,
ref double b0,
ref double b1,
ref double b2,
ref double b3,
ref double u,
ref double s,
ref double z,
ref double x4,
ref double y4
)

Visual Basic [image] Copy Code

Public Shared Sub CalcBezierCoef( _
ByRef a0 As Double, _
ByRef a1 As Double, _
ByRef a2 As Double, _
ByRef a3 As Double, _
ByRef b0 As Double, _
ByRef b1 As Double, _
ByRef b2 As Double, _
ByRef b3 As Double, _
ByRef u As Double, _
ByRef s As Double, _
ByRef z As Double, _
ByRef x4 As Double, _
ByRef y4 As Double _
)

Parameters

a0

a1

a2

a3

b0

b1

b2

b3

u

s

z

x4

y4

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.CartesianToPolar Method

Utilities.CartesianToPolar Method
[image]

Converts Cartesian coordinates to the corresponding polar coordinates, using the specified point as a center of the coordinate system.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void CartesianToPolar (
Point coordCenter,
Point point,
ref double a,
ref double r
)

Visual Basic [image] Copy Code

Public Shared Sub CartesianToPolar( _
coordCenter As Point, _
point As Point, _
ByRef a As Double, _
ByRef r As Double _
)

Parameters

coordCenter

point

a

r

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.Ccw Method

Utilities.Ccw Method
[image]

Determines, given three points, if when travelling from the first to the second to the third, we travel in a counterclockwise direction.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static int Ccw (
Point p0,
Point p1,
Point p2
)

Visual Basic [image] Copy Code

Public Shared Function Ccw( _
p0 As Point, _
p1 As Point, _
p2 As Point _
) As Integer

Parameters

p0

p1

p2

Return Value

Remarks

1 if the movement is in a counterclockwise direction, -1 if not.

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.Center Method

Utilities.Center Method
[image]

Returns the center of the specified rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Point Center (
Rect r
)

Visual Basic [image] Copy Code

Public Shared Function Center( _
r As Rect _
) As Point

Parameters

r

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.CheckIntersect Method

Utilities.CheckIntersect Method
[image]

Checks if the specified rectangle and circle intersect.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static bool CheckIntersect (
Point pt,
Rect rc,
double rad
)

Visual Basic [image] Copy Code

Public Shared Function CheckIntersect( _
pt As Point, _
rc As Rect, _
rad As Double _
) As Boolean

Parameters

pt

rc

rad

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.Closer Method

Utilities.Closer Method
[image]

Overload List

Name | Description
Utilities.Closer (Double, Double, Double) | Returns the point from the specified pair, which lies closer to the specified pivot.
Utilities.Closer (Point, Point, Point) | Returns the point from the specified pair, which lies closer to the specified pivot.

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.Closer Method (Double, Double, Double)

Utilities.Closer Method (Double, Double, Double)
See Also
[image]

Returns the point from the specified pair, which lies closer to the specified pivot.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double Closer (
double pivot,
double choice1,
double choice2
)

Visual Basic [image] Copy Code

Public Shared Function Closer( _
pivot As Double, _
choice1 As Double, _
choice2 As Double _
) As Double

Parameters

pivot

choice1

choice2

Return Value

See Also

Closer Method Overload List
Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.Closer Method (Point, Point, Point)

Utilities.Closer Method (Point, Point, Point)
See Also
[image]

Returns the point from the specified pair, which lies closer to the specified pivot.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Point Closer (
Point pivot,
Point p1,
Point p2
)

Visual Basic [image] Copy Code

Public Shared Function Closer( _
pivot As Point, _
p1 As Point, _
p2 As Point _
) As Point

Parameters

pivot

p1

p2

Return Value

See Also

Closer Method Overload List
Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.Contains(T, S) Method

Utilities.Contains(T, S) Method
[image]

Checks whether the specified hashtable contains the specified key.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static bool Contains<T, S> (
IDictionary<T, S> dictionary,
T key
)

Visual Basic [image] Copy Code

Public Shared Function Contains(Of T, S) ( _
dictionary As IDictionary(Of T, S), _
key As T _
) As Boolean

Parameters

dictionary

key

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.Degrees Method

Utilities.Degrees Method
[image]

Converts the specified value from degrees to radians.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double Degrees (
double radians
)

Visual Basic [image] Copy Code

Public Shared Function Degrees( _
radians As Double _
) As Double

Parameters

radians

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.Distance Method

Utilities.Distance Method
[image]

Overload List

Name | Description
Utilities.Distance (Double, Double) | Calculates the length of the hypotenuse of a right rectangle whose catheti have the specified length.
Utilities.Distance (Point, Point) | Returns the distance between the specified points.

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.Distance Method (Double, Double)

Utilities.Distance Method (Double, Double)
See Also
[image]

Calculates the length of the hypotenuse of a right rectangle whose catheti have the specified length.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double Distance (
double x,
double y
)

Visual Basic [image] Copy Code

Public Shared Function Distance( _
x As Double, _
y As Double _
) As Double

Parameters

x

y

Return Value

See Also

Distance Method Overload List
Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.Distance Method (Point, Point)

Utilities.Distance Method (Point, Point)
See Also
[image]

Returns the distance between the specified points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double Distance (
Point p1,
Point p2
)

Visual Basic [image] Copy Code

Public Shared Function Distance( _
p1 As Point, _
p2 As Point _
) As Double

Parameters

p1

p2

Return Value

See Also

Distance Method Overload List
Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.DistanceSq Method

Utilities.DistanceSq Method
[image]

Calculates the square of the distance between the specified points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double DistanceSq (
Point pt1,
Point pt2
)

Visual Basic [image] Copy Code

Public Shared Function DistanceSq( _
pt1 As Point, _
pt2 As Point _
) As Double

Parameters

pt1

pt2

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.DistanceToLine Method

Utilities.DistanceToLine Method
[image]

Returns the distance from a point to a line.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double DistanceToLine (
Point p,
Point a,
Point b
)

Visual Basic [image] Copy Code

Public Shared Function DistanceToLine( _
p As Point, _
a As Point, _
b As Point _
) As Double

Parameters

p

a

b

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.DistanceToLineSquared Method

Utilities.DistanceToLineSquared Method
[image]

Returns the squared distance between the specified points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double DistanceToLineSquared (
Point p,
Point a,
Point b
)

Visual Basic [image] Copy Code

Public Shared Function DistanceToLineSquared( _
p As Point, _
a As Point, _
b As Point _
) As Double

Parameters

p

a

b

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.DistanceToSegment Method

Utilities.DistanceToSegment Method
[image]

Returns the distance from a point to a line segment.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double DistanceToSegment (
Point p,
Point a,
Point b
)

Visual Basic [image] Copy Code

Public Shared Function DistanceToSegment( _
p As Point, _
a As Point, _
b As Point _
) As Double

Parameters

p

a

b

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.DistanceToSegmentSquared Method

Utilities.DistanceToSegmentSquared Method
[image]

Returns the squared distance from a point to a line segment.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double DistanceToSegmentSquared (
Point p,
Point a,
Point b
)

Visual Basic [image] Copy Code

Public Shared Function DistanceToSegmentSquared( _
p As Point, _
a As Point, _
b As Point _
) As Double

Parameters

p

a

b

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.DistToBezier Method

Utilities.DistToBezier Method
[image]

Calculates the shortest distance from the specified point to the specified bezier curve.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double DistToBezier (
Point pt,
IList bez_pts,
int nPoints
)

Visual Basic [image] Copy Code

Public Shared Function DistToBezier( _
pt As Point, _
bez_pts As IList, _
nPoints As Integer _
) As Double

Parameters

pt

bez_pts

nPoints

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.DistToPolyline Method

Utilities.DistToPolyline Method
[image]

Overload List

Name | Description
Utilities.DistToPolyline (Point, IList, Int32) | Calculates the shortest distance from the specified point to the specified polyline.
Utilities.DistToPolyline (Point, IList, Int32, Int32@) | Calculates the shortest distance from the specified point to the specified polyline, also returning the index of the segment the point is closest to.

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.DistToPolyline Method (Point, IList, Int32)

Utilities.DistToPolyline Method (Point, IList, Int32)
See Also
[image]

Calculates the shortest distance from the specified point to the specified polyline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double DistToPolyline (
Point pt,
IList line_pts,
int nPoints
)

Visual Basic [image] Copy Code

Public Shared Function DistToPolyline( _
pt As Point, _
line_pts As IList, _
nPoints As Integer _
) As Double

Parameters

pt

line_pts

nPoints

Return Value

See Also

DistToPolyline Method Overload List
Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.DistToPolyline Method (Point, IList, Int32, Int32@)

Utilities.DistToPolyline Method (Point, IList, Int32, Int32@)
See Also
[image]

Calculates the shortest distance from the specified point to the specified polyline, also returning the index of the segment the point is closest to.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double DistToPolyline (
Point pt,
IList line_pts,
int nPoints,
ref int segmNum
)

Visual Basic [image] Copy Code

Public Shared Function DistToPolyline( _
pt As Point, _
line_pts As IList, _
nPoints As Integer, _
ByRef segmNum As Integer _
) As Double

Parameters

pt

line_pts

nPoints

segmNum

Return Value

See Also

DistToPolyline Method Overload List
Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.DistToRectPoint Method

Utilities.DistToRectPoint Method
[image]

Returns the nearest to pt point that lies on the outline of rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Point DistToRectPoint (
Point pt,
Rect r
)

Visual Basic [image] Copy Code

Public Shared Function DistToRectPoint( _
pt As Point, _
r As Rect _
) As Point

Parameters

pt

r

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.FromLTRB Method

Utilities.FromLTRB Method
[image]

Creates a new Windows.UI.Xaml.Rect out of the specified coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Rect FromLTRB (
double l,
double t,
double r,
double b
)

Visual Basic [image] Copy Code

Public Shared Function FromLTRB( _
l As Double, _
t As Double, _
r As Double, _
b As Double _
) As Rect

Parameters

l

t

r

b

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.GetBezierPt Method

Utilities.GetBezierPt Method
[image]

Gets the point from the specified bezier curve, corresponding to the specified parameter t [0, 1].

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Point GetBezierPt (
List<Point> points,
int segment,
double t
)

Visual Basic [image] Copy Code

Public Shared Function GetBezierPt( _
points As List(Of Point), _
segment As Integer, _
t As Double _
) As Point

Parameters

points

segment

t

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.GetEllipseIntr Method

Utilities.GetEllipseIntr Method
[image]

Calculate the intersection point between the ellipse with the specified bounds and the line segment defined by the specified points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void GetEllipseIntr (
Rect rcBox,
Point pt1,
Point pt2,
ref Point pt
)

Visual Basic [image] Copy Code

Public Shared Sub GetEllipseIntr( _
rcBox As Rect, _
pt1 As Point, _
pt2 As Point, _
ByRef pt As Point _
)

Parameters

rcBox

pt1

pt2

pt

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.GetLoadedType Method

Utilities.GetLoadedType Method
[image]

Gets the type with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Type GetLoadedType (
string typeName
)

Visual Basic [image] Copy Code

Public Shared Function GetLoadedType( _
typeName As String _
) As Type

Parameters

typeName

The full name of the type.

Return Value

An instance of the System.Type class.

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.GetMinArrowheadSize Method

Utilities.GetMinArrowheadSize Method
[image]

Gets the minimum allowed size of an arrowhead.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetMinArrowheadSize ()

Visual Basic [image] Copy Code

Public Shared Function GetMinArrowheadSize () As Double

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.GetRect Method

Utilities.GetRect Method
[image]

Gets the position and size of the specified element on the canvas.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Rect GetRect (
FrameworkElement element
)

Visual Basic [image] Copy Code

Public Shared Function GetRect( _
element As FrameworkElement _
) As Rect

Parameters

element

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.GetRectIntr Method

Utilities.GetRectIntr Method
[image]

Calculates the intersection point between the specified rectangle and the line segment defined by the specified points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void GetRectIntr (
Rect rcBox,
Point pt1,
Point pt2,
ref Point pt
)

Visual Basic [image] Copy Code

Public Shared Sub GetRectIntr( _
rcBox As Rect, _
pt1 As Point, _
pt2 As Point, _
ByRef pt As Point _
)

Parameters

rcBox

pt1

pt2

pt

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.GetReflHth Method

Utilities.GetReflHth Method
[image]

Gets the initial distance between adjacent control points of a reflexive arrow along the Y-axis.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetReflHth ()

Visual Basic [image] Copy Code

Public Shared Function GetReflHth () As Double

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.GetReflWth2 Method

Utilities.GetReflWth2 Method
[image]

Gets the initial distance between adjacent control points of a reflexive link along the X-axis.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetReflWth2 ()

Visual Basic [image] Copy Code

Public Shared Function GetReflWth2 () As Double

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.GetRootVisual Method

Utilities.GetRootVisual Method
[image]

Gets the application's root visual element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static UIElement GetRootVisual (
Application application
)

Visual Basic [image] Copy Code

Public Shared Function GetRootVisual( _
application As Application _
) As UIElement

Parameters

application

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.Inflate Method

Utilities.Inflate Method
[image]

Adds the specified amount to the rectangle dimensions in all directions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Rect Inflate (
Rect rect,
double x,
double y
)

Visual Basic [image] Copy Code

Public Shared Function Inflate( _
rect As Rect, _
x As Double, _
y As Double _
) As Rect

Parameters

rect

x

y

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.Intersect Method

Utilities.Intersect Method
[image]

Determines whether the specified line segments intersect.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static bool Intersect (
Point p1,
Point p2,
Point p3,
Point p4
)

Visual Basic [image] Copy Code

Public Shared Function Intersect( _
p1 As Point, _
p2 As Point, _
p3 As Point, _
p4 As Point _
) As Boolean

Parameters

p1

p2

p3

p4

Return Value

true if the segments intersect, false if not.

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.IntersectsLineSegment Method

Utilities.IntersectsLineSegment Method
[image]

Gets the intersection point of a line segments and a rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static bool IntersectsLineSegment (
Rect rect,
Point A,
Point B,
ref Point P
)

Visual Basic [image] Copy Code

Public Shared Function IntersectsLineSegment( _
rect As Rect, _
A As Point, _
B As Point, _
ByRef P As Point _
) As Boolean

Parameters

rect

A

B

P

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.LineIntersect Method

Utilities.LineIntersect Method
[image]

Finds the intersection point of the lines defined by the specified point pairs.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Point LineIntersect (
Point m1,
Point m2,
Point n1,
Point n2
)

Visual Basic [image] Copy Code

Public Shared Function LineIntersect( _
m1 As Point, _
m2 As Point, _
n1 As Point, _
n2 As Point _
) As Point

Parameters

m1

m2

n1

n2

Return Value

The intersection point of the specified lines or Point(float.MinValue, float.MinValue) if the lines do not intersect.

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.LineIntersectNaN Method

Utilities.LineIntersectNaN Method
[image]

Finds the intersection point of the lines defined by the specified point pairs.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Point LineIntersectNaN (
Point m1,
Point m2,
Point n1,
Point n2
)

Visual Basic [image] Copy Code

Public Shared Function LineIntersectNaN( _
m1 As Point, _
m2 As Point, _
n1 As Point, _
n2 As Point _
) As Point

Parameters

m1

m2

n1

n2

Return Value

The intersection point of the specified lines or Point(double.NaN, double.NaN) if the lines do not intersect.

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.LineSegmentsIntersect Method

Utilities.LineSegmentsIntersect Method
[image]

Gets the intersection point of two line segments AB and CD.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static bool LineSegmentsIntersect (
Point A,
Point B,
Point C,
Point D,
ref Point P
)

Visual Basic [image] Copy Code

Public Shared Function LineSegmentsIntersect( _
A As Point, _
B As Point, _
C As Point, _
D As Point, _
ByRef P As Point _
) As Boolean

Parameters

A

B

C

D

P

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.LoadImage Method

Utilities.LoadImage Method
[image]

Loads an image from the specified stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static BitmapImage LoadImage (
s
)

Visual Basic [image] Copy Code

Public Shared Function LoadImage( _
s As _
) As BitmapImage

Parameters

s

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.MatchPointsMinLength Method

Utilities.MatchPointsMinLength Method
[image]

Returns an array of node anchor points which match current node links anchor point

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static int[] MatchPointsMinLength (
Point[] nodeAnchorPoints,
int[] pointRealIndexes,
Point[] fixedLinksAnchorPoints,
List<Int32> usedAnchorPointIndexes
)

Visual Basic [image] Copy Code

Public Shared Function MatchPointsMinLength( _
nodeAnchorPoints() As Point, _
pointRealIndexes() As Integer, _
fixedLinksAnchorPoints() As Point, _
usedAnchorPointIndexes As List(Of Int32) _
) As Integer()

Parameters

nodeAnchorPoints

pointRealIndexes

fixedLinksAnchorPoints

usedAnchorPointIndexes

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.MeasureText Method

Utilities.MeasureText Method
[image]

Measures the specified text when drawn with the specified font.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Size MeasureText (
string text,
FontFamily fontFamily,
double fontSize
)

Visual Basic [image] Copy Code

Public Shared Function MeasureText( _
text As String, _
fontFamily As FontFamily, _
fontSize As Double _
) As Size

Parameters

text

The string to measure.

fontFamily

A FontFamily instance specifying the font.

fontSize

A double value specifying the font size.

Return Value

A Size instance representing the text size.

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.MidPoint Method

Utilities.MidPoint Method
[image]

Returns the middle point of the segment defined by the specified points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Point MidPoint (
Point pt1,
Point pt2
)

Visual Basic [image] Copy Code

Public Shared Function MidPoint( _
pt1 As Point, _
pt2 As Point _
) As Point

Parameters

pt1

The first point.

pt2

The second point.

Return Value

A Point instance that represents the middle point.

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.MinDistToRect Method

Utilities.MinDistToRect Method
[image]

Calculates the minimum distance between a given point and a given rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double MinDistToRect (
Point pt,
Rect rc
)

Visual Basic [image] Copy Code

Public Shared Function MinDistToRect( _
pt As Point, _
rc As Rect _
) As Double

Parameters

pt

rc

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.NearestPoint Method

Utilities.NearestPoint Method
[image]

Returns the element from the specified point array nearest to the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Point NearestPoint (
Point point,
Point[] points
)

Visual Basic [image] Copy Code

Public Shared Function NearestPoint( _
point As Point, _
points() As Point _
) As Point

Parameters

point

A Point instance.

points

An array for whose members to find the minimum distance to the specified point.

Return Value

The array member nearest to the specified point.

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.Offset Method

Utilities.Offset Method
[image]

Moves the specified rectangle by the specified offset.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Rect Offset (
Rect rect,
double x,
double y
)

Visual Basic [image] Copy Code

Public Shared Function Offset( _
rect As Rect, _
x As Double, _
y As Double _
) As Rect

Parameters

rect

x

y

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.PointInEllipse Method

Utilities.PointInEllipse Method
[image]

Checks whether the specified point is contained in the ellipse defined by the specified rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static bool PointInEllipse (
Point pt,
Rect rc
)

Visual Basic [image] Copy Code

Public Shared Function PointInEllipse( _
pt As Point, _
rc As Rect _
) As Boolean

Parameters

pt

rc

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.PointInRect Method

Utilities.PointInRect Method
[image]

Checks whether the specified rectangle contains the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static bool PointInRect (
Point pt,
Rect rc
)

Visual Basic [image] Copy Code

Public Shared Function PointInRect( _
pt As Point, _
rc As Rect _
) As Boolean

Parameters

pt

rc

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.PolarToCartesian Method

Utilities.PolarToCartesian Method
[image]

Converts polar coordinates to the corresponding Cartesian coordinates, using the specified point as a center of the coordinate system.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Point PolarToCartesian (
Point coordCenter,
double a,
double r
)

Visual Basic [image] Copy Code

Public Shared Function PolarToCartesian( _
coordCenter As Point, _
a As Double, _
r As Double _
) As Point

Parameters

coordCenter

a

r

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.Radians Method

Utilities.Radians Method
[image]

Converts the specified value from degrees to radians.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double Radians (
double degrees
)

Visual Basic [image] Copy Code

Public Shared Function Radians( _
degrees As Double _
) As Double

Parameters

degrees

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.RectIntersects Method

Utilities.RectIntersects Method
[image]

Determines if rectangle intersects with rect.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static bool RectIntersects (
Rect rectangle,
Rect rect
)

Visual Basic [image] Copy Code

Public Shared Function RectIntersects( _
rectangle As Rect, _
rect As Rect _
) As Boolean

Parameters

rectangle

rect

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.SegmentIntersect Method

Utilities.SegmentIntersect Method
[image]

Checks whether the segments defined by the specified point pairs intersect and returns the intersection point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static bool SegmentIntersect (
Point s1,
Point s2,
Point l1,
Point l2,
ref Point pt
)

Visual Basic [image] Copy Code

Public Shared Function SegmentIntersect( _
s1 As Point, _
s2 As Point, _
l1 As Point, _
l2 As Point, _
ByRef pt As Point _
) As Boolean

Parameters

s1

s2

l1

l2

pt

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.TopLeft Method

Utilities.TopLeft Method
[image]

Returns the top left point of the specified rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Point TopLeft (
Rect rect
)

Visual Basic [image] Copy Code

Public Shared Function TopLeft( _
rect As Rect _
) As Point

Parameters

rect

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.TopRight Method

Utilities.TopRight Method
[image]

Returns the top right point of the specified rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Point TopRight (
Rect rect
)

Visual Basic [image] Copy Code

Public Shared Function TopRight( _
rect As Rect _
) As Point

Parameters

rect

Return Value

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.UnionNonEmptyRects Method

Utilities.UnionNonEmptyRects Method
[image]

Returns the smallest possible rectangle containing both of the specified rectangles, but only if the rectangles are non-empty.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Rect UnionNonEmptyRects (
Rect rc1,
Rect rc2
)

Visual Basic [image] Copy Code

Public Shared Function UnionNonEmptyRects( _
rc1 As Rect, _
rc2 As Rect _
) As Rect

Parameters

rc1

The first rectangle.

rc2

The second rectangle.

Return Value

A Windows.UI.Xaml.Rect instance that represents the union of the specified arguments.

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.Utilities.UnionRects Method

Utilities.UnionRects Method
[image]

Returns the smallest possible rectangle containing both of the specified rectangles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Rect UnionRects (
Rect a,
Rect b
)

Visual Basic [image] Copy Code

Public Shared Function UnionRects( _
a As Rect, _
b As Rect _
) As Rect

Parameters

a

The first rectangle.

b

The second rectangle.

Return Value

A Windows.UI.Xaml.Rect instance that represents the union of the specified arguments.

See Also

Utilities Members
Utilities Class


MindFusion.Diagramming.VirtualizingDiagram Class

VirtualizingDiagram Class
Remarks See Also
[image]

Implements virtualization of diagram elements.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class VirtualizingDiagram : Diagram

Visual Basic [image] Copy Code

Public Class VirtualizingDiagram
Inherits Diagram

Remarks

VirtualizingDiagram can display very large diagrams where there are actual DiagramNode and DiagramLink instances created only for the elements that should be currently shown on screen. This helps keeping the WinRT visual tree small and could lead to huge performance improvements if there are thousands of elements in the diagram.

The data items that should be displayed as nodes must be assigned to the NodesSource property, and the data items that should be displayed as links must be assigned to the LinksSource property. The BindingMode property specifies whether the data source should be updated when the user draws new diagram items interactively.

When the diagram is displayed initially, or while the user scrolls it, VirtualizingDiagram automatically creates ShapeNode and DiagramLink instances for the items that should be shown on screen. You can create diagram items of a different type via the InstantiateNode and InstantiateLink callbacks. Similarly when the user draws diagram items, the control calls the InstantiateNodeData and InstantiateLinkData delegates to create data items for the new diagram items.

VirtualizingDiagram assumes that node data items expose X and Y properties of type double specifying the node positions, and optional Width and Height properties specifying the node sizes. If Width and Height are not present, the nodes size is set to DefaultNodeSize. It is also possible to specify custom positions via the ResolveNodePosition delegate. Link data items must expose Origin and Destination properties that are references to items from NodesSource.

VirtualizingDiagram is a child class of Diagram and derives all of its properties and events. This lets you specify default appearance properties the usual way, and handle events such as NodeClicked to detect clicks over the visible items. Note that the base Nodes and Links collections will contain items only for the currently visible portion of the diagram.

When handling Diagram events raised for nodes and links, use the GetDataItem method to find out which item from the data source is associated with an actual diagram item. Vice versa, call GetDiagramNode and GetDiagramLink to find out the diagram item currently shown for a data item, if any.

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
Windows.UI.Xaml.Controls.ContentControl
MindFusion.Diagramming.DiagramBase
MindFusion.Diagramming.Diagram
MindFusion.Diagramming.VirtualizingDiagram

See Also

VirtualizingDiagram Members


MindFusion.Diagramming.VirtualizingDiagram Members

VirtualizingDiagram Members
Constructors Fields Properties Methods Events
[image]

Implements virtualization of diagram elements.

The following tables list the members exposed by the VirtualizingDiagram type.

Public Constructors

Name | Description
VirtualizingDiagram | Initializes a new instance of the VirtualizingDiagram class.

Public Fields

Name | Description
HorizontalOffsetProperty | Identifies the HorizontalOffset dependency property.
LinksSourceProperty | Identifies the LinksSource dependency property.
NodesSourceProperty | Identifies the NodesSource dependency property.
VerticalOffsetProperty | Identifies the VerticalOffset dependency property.
ViewportHeightProperty | Identifies the ViewportHeight dependency property.
ViewportWidthProperty | Identifies the ViewportWidth dependency property.

Inherited Public Fields

Name | Description
AdjustmentHandlesSizeProperty | Identifies the AdjustmentHandlesSize dependency property. (Inherited from Diagram.)
AlignmentGuidePenProperty | Identifies the AlignmentGuidePen dependency property. (Inherited from Diagram.)
AllowMultipleResizeProperty | Identifies the AllowMultipleResize dependency property. (Inherited from Diagram.)
AllowUnconnectedLinksProperty | Identifies the AllowUnconnectedLinks dependency property. (Inherited from Diagram.)
AutoScrollProperty | Identifies the AutoScroll dependency property. (Inherited from Diagram.)
CanRedoProperty | Identifies the CanRedo dependency property. (Inherited from Diagram.)
CanUndoProperty | Identifies the CanUndo dependency property. (Inherited from Diagram.)
ContainerNodeStyleProperty | Identifies the ContainerNodeStyle dependency property. (Inherited from Diagram.)
DiagramLinkStyleProperty | Identifies the DiagramLinkStyle dependency property. (Inherited from Diagram.)
Dummy | A shared DummyNode instance. (Inherited from Diagram.)
EnableLanesProperty | Identifies the EnableLanes dependency property. (Inherited from Diagram.)
ExpandButtonTemplateProperty | Identifies the ExpandButtonTemplate dependancy property. (Inherited from Diagram.)
GridDashArrayProperty | Identifies the GridDashArray dependency property. (Inherited from Diagram.)
GridPointSizeProperty | Identifies the GridPointSize dependency property. (Inherited from Diagram.)
NodeEffectsSourceProperty | Identifies the NodeEffectsSource dependency property. (Inherited from Diagram.)
ShapeNodeStyleProperty | Identifies the ShapeNodeStyle dependency property. (Inherited from Diagram.)
TableNodeStyleProperty | Identifies the TableNodeStyle dependency property. (Inherited from Diagram.)
TreeViewNodeStyleProperty | Identifeis the TreeViewNodeStyle dependency property. (Inherited from Diagram.)
ZoomFactorProperty | Identifies the ZoomFactor property. (Inherited from Diagram.)

Public Properties

Name | Description
BindingMode | Gets or sets a value that indicates the direction of the data flow in the binding.
DefaultNodeSize | Gets or sets the default node size used when data elements do not contain Width and Height properties.
HorizontalOffset | Gets or sets the horizontal offset of the scrolled diagram.
InstantiateLink | A delegate called to create a DiagramLink instance when realizing data items on screen.
InstantiateLinkData | A delegate called to create a data item for a link drawn by the user.
InstantiateNode | A delegate called to create a DiagramNode instance when realizing data items on screen.
InstantiateNodeData | A delegate called to create a data item for a node drawn by the user.
LinksSource | Gets or sets a collection whose elements will be rendered as links in the diagram.
NodesSource | Gets or sets a collection whose elements will be rendered as nodes in the diagram.
ResolveNodePosition | A delegate called to determine the position of a node within the diagram.
VerticalOffset | Gets or sets the vertical offset of the scrolled diagram.
ViewportHeight | Gets or sets the height of the diagram viewport.
ViewportWidth | Gets or sets the width of the diagram viewport.
VisualCacheSize | Gets or sets the size of the cache storing actual nodes and links that will be reused for displaying new data elements while scrolling.

Inherited Public Properties

Name | Description
ActiveItem | Gets or sets the active diagram element. (Inherited from Diagram.)
ActiveItemHandlesStyle | Gets or sets the visual style of adjustment handles of the active item. (Inherited from Diagram.)
ActiveLayer | Gets or sets the zero-based index of the active layer. (Inherited from Diagram.)
AdjustmentHandlesSize | Gets or sets the size of the handles, which appear around selected objects. This is a dependency property. (Inherited from Diagram.)
AlignmentGuidePen | Gets or sets the pen used to draw alignment guides. This is a dependency property. (Inherited from Diagram.)
AlignToGrid | Gets or sets a value indicating whether the diagram items should be aligned to a grid. (Inherited from Diagram.)
AllowInplaceEdit | Gets or sets a value indicating whether in-place editing of the text of objects is enabled. (Inherited from Diagram.)
AllowMultipleResize | Specifies whether multiple selected nodes can be resized simultaneously. This is a dependency property. (Inherited from Diagram.)
AllowUnconnectedLinks | Gets or sets a value indicating whether users are allowed to draw links that are not connected to any node. This is a dependency property. (Inherited from Diagram.)
AutoAlignDistance | Gets or sets the maximal horizontal or vertical distance at which a node aligns to the borders ot other nodes. (Inherited from Diagram.)
AutoAlignNodes | Gets or sets whether nodes should automatically align to the borders ot other nodes during user interaction. (Inherited from Diagram.)
AutoResize | Gets or sets a value indicating whether the document area should be resized automatically so it fits the diagram contents. (Inherited from Diagram.)
AutoScroll | Gets or sets a value indicating whether auto scrolling of the document area is enabled. This is a dependency property. (Inherited from Diagram.)
AutoSnapDistance | Specifies the maximum distance at which links auto-snap to nodes. (Inherited from Diagram.)
AutoSnapLinks | Specifies whether link end points should automatically snap to the nearest diagram node. (Inherited from Diagram.)
BackBrush | Gets or sets the brush used for painting the diagram background. (Inherited from Diagram.)
Behavior | Gets or sets a value indicating how the control responds to user actions. (Inherited from Diagram.)
Bounds | Gets or sets a value representing the size of the diagram's scrollable area. (Inherited from Diagram.)
CanRedo | Gets or sets a value indicating whether there is a command in the redo history which can be redone. (Inherited from Diagram.)
CanUndo | Gets or sets a value indicating whether there is a command in the undo history which can be undone. (Inherited from Diagram.)
ContainerNodeStyle | Gets or sets the theme-level style for container nodes. This is a dependency property. (Inherited from Diagram.)
ContainersFoldable | Gets or sets the default value for the Foldable property of containers. (Inherited from Diagram.)
CrossingRadius | Gets or sets the radius length of decorations displayed at link intersection points. (Inherited from Diagram.)
CustomBehavior | Gets or sets a custom behavior object specifying how DiagramRT responds to mouse input. (Inherited from Diagram.)
DefaultControlType | Gets or sets the type of the controls that will be hosted by default in newly create ControlNode objects. (Inherited from Diagram.)
DefaultShape | Gets or sets the default shape of shape nodes. (Inherited from Diagram.)
DelKeyAction | Gets or sets a value that specifies what action should be performed when the user hits the Del key. (Inherited from Diagram.)
DiagramLinkStyle | Gets or sets the theme-level style for diagram links. This is a dependency property. (Inherited from Diagram.)
DisabledHandlesStyle | Gets or sets the visual style of disabled adjustment handles. (Inherited from Diagram.)
DocumentPlane | DocumentPlane is visual child of diagram and ancestor of all diagram items. The DocumentPlane element is translated with respect to Diagram element so that the point Diagram.Bounds.TopLeft from the DocumentPlane is rendered at Diagram element location (0,0). The coordinate system of the DocumentPlane is the document coordinate system. The intended use of this property is mainly in MouseMove event handling (Inherited from Diagram.)
DynamicLinks | Gets or sets the default value for the Dynamic property of new links. (Inherited from Diagram.)
Enabled | Enables or disables handling of mouse events. (Inherited from Diagram.)
EnableLanes | Gets or sets whether lanes are enabled. This is a dependency property. (Inherited from Diagram.)
ExpandButtonAction | Gets or sets a value indicating what should happen when a user clicks the [+/-] button that is displayed near expandable nodes. (Inherited from Diagram.)
ExpandButtonBrush | Gets or sets the brush used to fill expand/collapse buttons of nodes. (Inherited from Diagram.)
ExpandButtonPosition | Gets or sets where expand/collapse buttons are located relatively to their nodes. (Inherited from Diagram.)
ExpandButtonTemplate | Gets or sets a custom ControlTemplate for the ExpandButton class. (Inherited from Diagram.)
ExpandOnIncoming | Gets or sets a value, indicating in which direction object hierarchies are expanded. (Inherited from Diagram.)
Factory | Gets a Factory instance that lets you add programmatically new items to the diagram. (Inherited from Diagram.)
GridColor | Gets or sets the color of the grid points. (Inherited from Diagram.)
GridDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to draw grid lines. This is a dependency property. (Inherited from Diagram.)
GridOffsetX | Gets or sets the horizontal offset of the first point of the alignment grid. (Inherited from Diagram.)
GridOffsetY | Gets or sets the vertical offset of the first point of the alignment grid. (Inherited from Diagram.)
GridPointSize | Gets or sets the size of shapes used to represent grid points. This is a dependency property. (Inherited from Diagram.)
GridSizeX | Gets or sets the horizontal distance between adjacent grid points. (Inherited from Diagram.)
GridSizeY | Gets or sets the vertical distance between adjacent grid points. (Inherited from Diagram.)
GridStyle | Gets or sets the visual style of the alignment grid. (Inherited from Diagram.)
HitTestPriority | Gets or sets a value indicating the order in which items are hit-tested. (Inherited from Diagram.)
InplaceEditAcceptOnEnter | Gets or sets a value indicating whether pressing the ENTER key should exit in-place editing mode and accept changes made to text. (Inherited from Diagram.)
InplaceEditCancelOnEsc | Gets or sets a value indicating whether pressing the ESC key should exit inplace-edit mode and reject changes made to text. (Inherited from Diagram.)
Interaction | Gets an InteractionState instance representing the current action being carried out by the user. (Inherited from Diagram.)
Items | Represents a strongly typed collection of DiagramItem objects. (Inherited from Diagram.)
LaneGrid | Gets the Grid instance that represents the lane grid. (Inherited from Diagram.)
Layers | Gets a list of the layers in the current diagram. (Inherited from Diagram.)
LicenseKey | Gets or sets the license key of the control. (Inherited from Diagram.)
LinkBaseShape | Gets or sets the shape displayed at the base of new links. (Inherited from Diagram.)
LinkBaseShapeSize | Gets or sets the default size of the base of new links. (Inherited from Diagram.)
LinkBrush | Gets or sets the default value for the Brush property of links. (Inherited from Diagram.)
LinkCrossings | Gets or sets how to render the intersection points where links cross their paths. (Inherited from Diagram.)
LinkHeadShape | Gets or sets the shape displayed as head of new links. (Inherited from Diagram.)
LinkHeadShapeSize | Gets or sets the default size of arrowheads. (Inherited from Diagram.)
LinkIntermediateShape | Gets or sets default shape to be displayed in the middle of each segment of links. (Inherited from Diagram.)
LinkIntermediateShapeSize | Gets or sets the default size of the shapes at middles of link segments. (Inherited from Diagram.)
LinkPen | Gets or sets the default value for the Pen property of links. (Inherited from Diagram.)
LinkRouter | Gets or sets the component used to find paths for auto-routed links when diagram nodes are added or their positions change. (Inherited from Diagram.)
Links | Gets a DiagramLinkCollection containing the links. (Inherited from Diagram.)
LinkSegments | Gets or sets the default number of link segments. (Inherited from Diagram.)
LinkShape | Gets or sets the default style of diagram links. (Inherited from Diagram.)
MeasureUnit | Gets or sets the unit of measure used for logical coordinates in this diagram. (Inherited from Diagram.)
ModificationStart | Gets or sets how users can start modifying diagram items. (Inherited from Diagram.)
NodeEffects | Gets a collection with all effects applied to the nodes of this diagram. (Inherited from Diagram.)
Nodes | Gets a DiagramNodeCollection containing the nodes. (Inherited from Diagram.)
NodesExpandable | Gets or sets a value indicating whether newly created nodes can be expanded. (Inherited from Diagram.)
OverrideCursor | Sets the cursor and stops changing it depending on the context. (Inherited from Diagram.)
PrintOptions | Gets an object which provides customization properties for printed diagrams. (Inherited from Diagram.)
RecursiveExpand | Gets or sets value indicating how a tree is expanded. (Inherited from Diagram.)
RoundedLinks | Gets or sets a value indicating whether the joins between segments of Polyline and Cascading links should be rounded. (Inherited from Diagram.)
RoundedLinksRadius | Gets or sets the radius of arc joins of rounded links' segments. (Inherited from Diagram.)
RouteLinks | Gets or sets a value indicating whether links should avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes. (Inherited from Diagram.)
RoutingOptions | Gets an object, which allows customizing various parameters of the link routing algorithm. (Inherited from Diagram.)
ScrollX | Gets or sets the document's X scroll position. (Inherited from Diagram.)
ScrollY | Gets or sets the document's Y scroll position. (Inherited from Diagram.)
ScrollZoneSize | Gets or sets the size of the auto scroll zone near the edges of the control. (Inherited from Diagram.)
SelectedItemHandlesStyle | Gets or sets the visual style of adjustment handles of selected items. (Inherited from Diagram.)
Selection | Gets the Selection instance that represents the selection of items in this diagram. (Inherited from Diagram.)
ShapeBrush | Gets or sets the default value for the Brush property of shape nodes. (Inherited from Diagram.)
ShapeHandlesStyle | Gets or sets the default value for the HandlesStyle property of new shape nodes. (Inherited from Diagram.)
ShapeNodeStyle | Gets or sets the theme-level style for shape nodes. This is a dependency property. (Inherited from Diagram.)
ShapePen | Gets or sets the default value for the Pen property of new ShapeNode objects. (Inherited from Diagram.)
ShowAnchors | Gets or sets a value indicating whether and when node anchor points should be displayed. (Inherited from Diagram.)
ShowGrid | Gets or sets a value indicating whether the alignment grid is visible. (Inherited from Diagram.)
TableBrush | Gets or sets the default value for the Brush property of tables. (Inherited from Diagram.)
TableCaption | Gets or sets the default text for tables' captions. (Inherited from Diagram.)
TableCaptionHeight | Gets or sets the default height of table captions. (Inherited from Diagram.)
TableColumnCount | Gets or sets the default number of table columns. (Inherited from Diagram.)
TableColumnWidth | Gets or sets the default width of tables' columns. (Inherited from Diagram.)
TableNodeStyle | Gets or sets the theme-level style for table nodes. This is a dependency property. (Inherited from Diagram.)
TableRowCount | Gets or sets the default number of table rows. (Inherited from Diagram.)
TableRowHeight | Gets or sets the default height of tables' rows. (Inherited from Diagram.)
Theme | Gets or sets the theme associated with the diagram. (Inherited from Diagram.)
TreeViewNodeStyle | Gets or sets the theme-level style for treeview nodes. This is a dependency property. (Inherited from Diagram.)
UndoEnabled | Gets or sets a value indicating whether saving action records for later undo is enabled. (Inherited from Diagram.)
Viewport | Returns the visible portion of the diagram area. (Inherited from Diagram.)
ZoomFactor | Gets or sets the zoom factor used to scale up or down the Diagram. (Inherited from Diagram.)

Public Methods

Name | Description
GetDataItem | Gets the item from the data source that is represented by the specified DiagramItem.
GetDiagramLink | Gets the DiagramLink that represents the specified data item on screen.
GetDiagramNode | Gets the DiagramNode that represents the specified data item on screen.
RaiseRealized | Raises the appropriate *Realized event according to the type of the specified item.

Protected Methods

Name | Description
OnLinkCreated | DiagramBase.OnLinkCreated override.
OnLinkDeleted | DiagramBase.OnLinkDeleted override.
OnLinkModified | DiagramBase.OnLinkModified override.
OnLinkRealized | Raises the LinkRealized event.
OnNodeCreated | DiagramBase.OnNodeCreated override.
OnNodeDeleted | DiagramBase.OnNodeDeleted override.
OnNodeDeleting | DiagramBase.OnNodeDeleting override.
OnNodeModified | DiagramBase.OnNodeModified override.
OnNodeRealized | Raises the NodeRealized event.

Inherited Public Methods

Name | Description
AlignPointToGrid | Returns a point of the alignment grid nearest to the one passed as an argument. (Inherited from Diagram.)
ArrangeLinkLabels | Rearranges link labels whose AutoArrange property is enabled. (Inherited from Diagram.)
BeginEdit | Overloaded. (Inherited from Diagram.)
CancelCompositeOperation | Stops recording undo/redo commands into a CompositeCommand and discards the records created so far. (Inherited from Diagram.)
CancelDrag | Cancels the current drag operation. (Inherited from Diagram.)
ChangeUnit | Sets new MeasureUnit value and scales the coordinates of diagram items so that their absolute size remains unchanged. (Inherited from Diagram.)
ClearAll | Removes all items from the diagram. (Inherited from Diagram.)
CommitCompositeOperation | Stops recording undo/redo commands into a CompositeCommand and saves the composite in the history queue. (Inherited from Diagram.)
CopySelection | Creates a copy of the currently selected objects and groups. (Inherited from Diagram.)
CreateThemeFromDefaults | Creates a Theme object representing the default properties of the diagram. (Inherited from Diagram.)
EndDelayUpdate | Continue updating the visual state of items. (Inherited from Diagram.)
EndEdit | Exits the in-place editing mode and either accepts or rejects the changes made to the item's text. (Inherited from Diagram.)
ExecuteCommand | Executes the specified command on this diagram. (Inherited from Diagram.)
FindLinkById | Finds the link that has the specified id value. (Inherited from Diagram.)
FindNodeById | Finds the node that has the specified id value. (Inherited from Diagram.)
GetContentBounds | Returns the smallest rectangle that bounds all diagram objects. (Inherited from Diagram.)
GetItemAt | Overloaded. (Inherited from Diagram.)
GetLinkAt | Overloaded. Finds and returns the top-most link that lies at the specified location. (Inherited from Diagram.)
GetNearestNode | Returns the node nearest to the specified point. (Inherited from Diagram.)
GetNodeAt | Overloaded. (Inherited from Diagram.)
GetNodesInViewport | Returns all nodes visible in the current viewport. (Inherited from Diagram.)
HitTestManipulators | Tests whether the specified point is within the manipulator of a diagram object and triggers the manipulator. (Inherited from Diagram.)
Invalidate | Causes the entire visible diagram area to be repainted. (Inherited from Diagram.)
IsItemInteractive | Checks if the specified item can be modified interactively. (Inherited from Diagram.)
IsItemLocked | Checks if the specified item is locked. (Inherited from Diagram.)
IsItemVisible | Checks if the specified item is currently visible. (Inherited from Diagram.)
LoadFromString | Decodes diagram contents from a string that was created with SaveToString. (Inherited from Diagram.)
LoadFromXml | Overloaded. (Inherited from Diagram.)
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from Diagram.)
PasteSelection | Adds the specified items and groups to this diagram. (Inherited from Diagram.)
RaiseClicked | Raises the Clicked event. (Inherited from Diagram.)
RaiseClicked | Raises the appropriate *Clicked event according to the type of the specified item. (Inherited from Diagram.)
RaiseCreated | Raises the appropriate *Created event according to the type of the specified item. (Inherited from Diagram.)
RaiseDeleting | Raises the LinkDeleting or NodeDeleting event according to the type of the specified item. (Inherited from Diagram.)
RaiseDoubleClicked | Overloaded. (Inherited from Diagram.)
RaiseLinkTextEdited | Raises the LinkTextEdited event. (Inherited from Diagram.)
RaiseNodeTextEdited | Raises the NodeTextEdited event. (Inherited from Diagram.)
RaisePasted | Raises the appropriate Pasted event. (Inherited from Diagram.)
Redo | Executes again an action saved in the command history. (Inherited from Diagram.)
RegisterClass | Registers a class for serialization support. (Inherited from Diagram.)
RegisterItemClass | Registers a diagram item class for serialization support. (Inherited from Diagram.)
ResizeToFitItem | Resizes the document extents so that the specified item is contained within. (Inherited from Diagram.)
ResizeToFitItems | Overloaded. Resizes the document scrollable area so it fits all diagram items. (Inherited from Diagram.)
RouteAllLinks | Routes all links in the diagram in a way they do not cross nodes. (Inherited from Diagram.)
SaveToString | Returns a serialized form of the diagram as string (Inherited from Diagram.)
SaveToXml | Overloaded. (Inherited from Diagram.)
SetScrollerParent | Binds the lane-grid header positions to the offset of a ScrollViewer's scrollbars. (Inherited from Diagram.)
SetZoomFactor | Sets the zoom factor, preserving the on-screen position of the specified diagram point. (Inherited from Diagram.)
StartCompositeOperation | Starts recording undo/redo commands into a CompositeCommand. (Inherited from Diagram.)
StartDelayUpdate | Stops updating the visual state of items. (Inherited from Diagram.)
StartInteraction | Overloaded. (Inherited from Diagram.)
Undo | Undoes an action saved in the command history. (Inherited from Diagram.)
UpdateRuntimeIndices | For internal use. (Inherited from Diagram.)
UpdateVisualZIndices | For internal use. (Inherited from Diagram.)
ZoomToRect | Zooms and scrolls the view to fit the specified document rectangle in the Diagram's visible area. (Inherited from Diagram.)

Inherited Protected Methods

Name | Description
ArrangeOverride | FrameworkElement.ArrangeOverride override. (Inherited from Diagram.)
OnActionRedone | Raises the ActionRedone event. (Inherited from DiagramBase.)
OnActionUndone | Raises the ActionUndone event. (Inherited from DiagramBase.)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramBase.)
OnCellClicked | Raises the CellClicked event. (Inherited from DiagramBase.)
OnCellDoubleClicked | Raises the CellDoubleClicked event. (Inherited from DiagramBase.)
OnClicked | Raises the Clicked event. (Inherited from DiagramBase.)
OnContainerChildAdded | Raises the ContainerChildAdded event. (Inherited from DiagramBase.)
OnContainerChildRemoved | Raises the ContainerChildRemoved event. (Inherited from DiagramBase.)
OnContainerFolded | Raises the ContainerFolded event. (Inherited from DiagramBase.)
OnContainerUnfolded | Raises the ContainerUnfolded event. (Inherited from DiagramBase.)
OnDeserializeControl | Raises the DeserializeControl event. (Inherited from DiagramBase.)
OnDeserializeTag | Raises the DeserializeTag event. (Inherited from DiagramBase.)
OnDoubleClicked | Raises the DoubleClicked event. (Inherited from DiagramBase.)
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event. (Inherited from DiagramBase.)
OnEnterInplaceEditMode | Raises the EnterInplaceEditMode event. (Inherited from DiagramBase.)
OnExpandButtonClicked | Raises the ExpandButtonClicked event. (Inherited from DiagramBase.)
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event. (Inherited from DiagramBase.)
OnInitializeLink | Raises the InitializeLink event. (Inherited from DiagramBase.)
OnInitializeNode | Raises the InitializeNode event. (Inherited from DiagramBase.)
OnItemAdded | Raises the ItemAdded event. (Inherited from DiagramBase.)
OnItemRemoved | Raises the ItemRemoved event. (Inherited from DiagramBase.)
OnLaneGridCellCreated | Raises the LaneGridCellCreated event. (Inherited from DiagramBase.)
OnLaneGridHeaderCreated | Raises the LaneGridHeaderCreated event. (Inherited from DiagramBase.)
OnLeaveInplaceEditMode | Raises the LeaveInplaceEditMode event. (Inherited from DiagramBase.)
OnLinkActivated | Raises the LinkActivated event. (Inherited from DiagramBase.)
OnLinkClicked | Raises the LinkClicked event. (Inherited from DiagramBase.)
OnLinkCreated | Raises the LinkCreated event. (Inherited from DiagramBase.)
OnLinkCreating | Raises the LinkCreating event. (Inherited from DiagramBase.)
OnLinkDeactivated | Raises the LinkDeactivated event. (Inherited from DiagramBase.)
OnLinkDeleted | Raises the LinkDeleted event. (Inherited from DiagramBase.)
OnLinkDeleting | Raises the LinkDeleting event. (Inherited from DiagramBase.)
OnLinkDeselected | Raises the LinkDeselected event. (Inherited from DiagramBase.)
OnLinkDoubleClicked | Raises the LinkDoubleClicked event. (Inherited from DiagramBase.)
OnLinkModified | Raises the LinkModified event. (Inherited from DiagramBase.)
OnLinkModifying | Raises the LinkModifying event. (Inherited from DiagramBase.)
OnLinkPasted | Raises the LinkPasted event. (Inherited from DiagramBase.)
OnLinkRouted | Raises the LinkRouted event. (Inherited from DiagramBase.)
OnLinkSelected | Raises the LinkSelected event. (Inherited from DiagramBase.)
OnLinkTextEdited | Raises the LinkTextEdited event. (Inherited from DiagramBase.)
OnMagnifierFactorChanged | Raises the MagnifierFactorChanged event. (Inherited from DiagramBase.)
OnMeasureUnitChanged | Raises the MeasureUnitChanged event. (Inherited from DiagramBase.)
OnMouseRightButtonDown | Control.OnMouseRightButtonDown override. (Inherited from Diagram.)
OnMouseRightButtonUp | Control.OnMouseRightButtonUp override. (Inherited from Diagram.)
OnNodeActivated | Raises the NodeActivated event. (Inherited from DiagramBase.)
OnNodeClicked | Raises the NodeClicked event. (Inherited from DiagramBase.)
OnNodeCreated | Raises the NodeCreated event. (Inherited from DiagramBase.)
OnNodeCreating | Raises the NodeCreating event. (Inherited from DiagramBase.)
OnNodeDeactivated | Raises the NodeDeactivated event. (Inherited from DiagramBase.)
OnNodeDeleted | Raises the NodeDeleted event. (Inherited from DiagramBase.)
OnNodeDeleting | Raises the NodeDeleting event. (Inherited from DiagramBase.)
OnNodeDeselected | Raises the NodeDeselected event. (Inherited from DiagramBase.)
OnNodeDoubleClicked | Raises the NodeDoubleClicked event. (Inherited from DiagramBase.)
OnNodeModified | Raises the NodeModified event. (Inherited from DiagramBase.)
OnNodeModifying | Raises the NodeModifying event. (Inherited from DiagramBase.)
OnNodePasted | Raises the NodePasted event. (Inherited from DiagramBase.)
OnNodeSelected | Raises the NodeSelected event. (Inherited from DiagramBase.)
OnNodeTextEdited | Raises the NodeTextEdited event. (Inherited from DiagramBase.)
OnRepaint | Raises the Repaint event. (Inherited from DiagramBase.)
OnSelectionChanged | Raises the SelectionChanged event. (Inherited from DiagramBase.)
OnSelectionModified | Raises the SelectionModified event. (Inherited from DiagramBase.)
OnSelectionModifying | Raises the SelectionModifying event. (Inherited from DiagramBase.)
OnSerializeControl | Raises the SerializeControl event. (Inherited from DiagramBase.)
OnSerializeTag | Raises the SerializeTag event. (Inherited from DiagramBase.)
OnSetSelfLoopShape | Raises the SetSelfLoopShape event. (Inherited from DiagramBase.)
OnTreeCollapsed | Raises the TreeCollapsed event. (Inherited from DiagramBase.)
OnTreeExpanded | Raises the TreeExpanded event. (Inherited from DiagramBase.)
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event. (Inherited from DiagramBase.)
OnZoomFactorChanged | Raises the ZoomFactorChanged event. (Inherited from DiagramBase.)
RemoveItem | Removes the specified item from the diagram and creates a record in the undo/redo history. (Inherited from Diagram.)

Public Events

Name | Description
LinkRealized | Raised when an actual DiagramLink instance is created to represent a data item from LinksSource.
NodeRealized | Raised when an actual DiagramNode instance is created to represent a data item from NodesSource.

Inherited Public Events

Name | Description
ActionRedone | Raised when an action is redone. (Inherited from DiagramBase.)
ActionUndone | Raised when an action is undone. (Inherited from DiagramBase.)
ActiveLayerChanged | Raised when the diagram's active layer has changed. (Inherited from DiagramBase.)
BoundsChanged | Raised when the Bounds property value has changed. (Inherited from DiagramBase.)
CellClicked | Raised when the user clicks a table's cell. (Inherited from DiagramBase.)
CellDoubleClicked | Raised when the user double-clicks a table's cell. (Inherited from DiagramBase.)
Clicked | Raised when the user clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area. (Inherited from DiagramBase.)
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area. (Inherited from DiagramBase.)
DeserializeControl | Lets you load the attributes of controls hosted inside ControlNodes. (Inherited from DiagramBase.)
DeserializeTag | Raised when the Tag or Id of a diagram item must be deserialized from XML format. (Inherited from DiagramBase.)
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
DrawAdjustmentHandles | Raised when item's adjustment handles must be custom drawn. (Inherited from DiagramBase.)
EnterInplaceEditMode | Raised when entering inplace-edit mode. (Inherited from DiagramBase.)
ExpandButtonClicked | Raised when the user clicks the [+/-] button of an Expandable node. (Inherited from DiagramBase.)
HitTestAdjustmentHandles | Raised when custom hit testing of item's adjustment handles must be performed. (Inherited from DiagramBase.)
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created. (Inherited from DiagramBase.)
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created. (Inherited from DiagramBase.)
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
LaneGridCellCreated | Raised when a lane grid's cell has been created to allow additional cusomtization of its presentation. (Inherited from DiagramBase.)
LaneGridHeaderCreated | Raised when a lane grid's header has been created to allow additional cusomtization of its presentation. (Inherited from DiagramBase.)
LeaveInplaceEditMode | Raised when leaving inplace-edit mode. (Inherited from DiagramBase.)
LinkActivated | Raised when a link becomes the ActiveItem. (Inherited from DiagramBase.)
LinkClicked | Raised when the user clicks a link. (Inherited from DiagramBase.)
LinkCreated | Raised when the user draws a new link. (Inherited from DiagramBase.)
LinkCreating | A validation event raised while the user is drawing a new link. (Inherited from DiagramBase.)
LinkDeactivated | Raised when a link is no longer the ActiveItem. (Inherited from DiagramBase.)
LinkDeleted | Raised when a link is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkDeselected | Raised when a link is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDoubleClicked | Raised when the user double-clicks a link. (Inherited from DiagramBase.)
LinkModified | Raised when the user moves any control point of a link. (Inherited from DiagramBase.)
LinkModifying | A validation event raised while the user is modifying a link. (Inherited from DiagramBase.)
LinkPasted | Raised when a link has been pasted from the clipboard. (Inherited from DiagramBase.)
LinkRouted | Raised when a link is routed by the auto-routing algorithm. (Inherited from DiagramBase.)
LinkSelected | Raised when a link is selected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkTextEdited | Raised when the user edits the text of a link. (Inherited from DiagramBase.)
MagnifierFactorChanged | Occurs when the magnifier factor changes. (Inherited from DiagramBase.)
MeasureUnitChanged | Raised when the MeasureUnit property value has changed. (Inherited from DiagramBase.)
NodeActivated | Raised when a node becomes the ActiveItem. (Inherited from DiagramBase.)
NodeClicked | Raised when the user clicks a node. (Inherited from DiagramBase.)
NodeCreated | Occurs when the user draws a new node. (Inherited from DiagramBase.)
NodeCreating | A validation event raised while the user is drawing a new node. (Inherited from DiagramBase.)
NodeDeactivated | Raised when a node is no longer the ActiveItem. (Inherited from DiagramBase.)
NodeDeleted | Raised when a node is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeDeselected | Raised when a node is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDoubleClicked | Raised when the user double-clicks a node. (Inherited from DiagramBase.)
NodeModified | Raised when the user moves or resizes a node. (Inherited from DiagramBase.)
NodeModifying | A validation event raised while the user is moving or resizing a node. (Inherited from DiagramBase.)
NodePasted | Raised when a node has been pasted from the clipboard. (Inherited from DiagramBase.)
NodeSelected | Raised when a node is selected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeTextEdited | Raised when the user edits the text of a node. (Inherited from DiagramBase.)
Repaint | Raised when the diagram views should be repainted. (Inherited from DiagramBase.)
SelectionChanged | Raised when an item is added to or removed from the selection. (Inherited from DiagramBase.)
SelectionModified | Raised when the user moves or resizes multiple selected items. (Inherited from DiagramBase.)
SelectionModifying | Raised while the user is moving or resizing multiple selected items, this event lets you cancel the modification. (Inherited from DiagramBase.)
SerializeControl | Lets you save the attributes of controls hosted inside ControlNodes. (Inherited from DiagramBase.)
SerializeTag | Raised when the Tag of a diagram item must be serialized into an XML document. (Inherited from DiagramBase.)
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape. (Inherited from DiagramBase.)
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node. (Inherited from DiagramBase.)
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node. (Inherited from DiagramBase.)
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point. (Inherited from DiagramBase.)
ZoomFactorChanged | Occurs when the zoom factor changes. (Inherited from DiagramBase.)

See Also

VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram Fields

VirtualizingDiagram Fields
[image]

Public Fields

Name | Description
HorizontalOffsetProperty | Identifies the HorizontalOffset dependency property.
LinksSourceProperty | Identifies the LinksSource dependency property.
NodesSourceProperty | Identifies the NodesSource dependency property.
VerticalOffsetProperty | Identifies the VerticalOffset dependency property.
ViewportHeightProperty | Identifies the ViewportHeight dependency property.
ViewportWidthProperty | Identifies the ViewportWidth dependency property.

Inherited Public Fields

Name | Description
AdjustmentHandlesSizeProperty | Identifies the AdjustmentHandlesSize dependency property. (Inherited from Diagram.)
AlignmentGuidePenProperty | Identifies the AlignmentGuidePen dependency property. (Inherited from Diagram.)
AllowMultipleResizeProperty | Identifies the AllowMultipleResize dependency property. (Inherited from Diagram.)
AllowUnconnectedLinksProperty | Identifies the AllowUnconnectedLinks dependency property. (Inherited from Diagram.)
AutoScrollProperty | Identifies the AutoScroll dependency property. (Inherited from Diagram.)
CanRedoProperty | Identifies the CanRedo dependency property. (Inherited from Diagram.)
CanUndoProperty | Identifies the CanUndo dependency property. (Inherited from Diagram.)
ContainerNodeStyleProperty | Identifies the ContainerNodeStyle dependency property. (Inherited from Diagram.)
DiagramLinkStyleProperty | Identifies the DiagramLinkStyle dependency property. (Inherited from Diagram.)
Dummy | A shared DummyNode instance. (Inherited from Diagram.)
EnableLanesProperty | Identifies the EnableLanes dependency property. (Inherited from Diagram.)
ExpandButtonTemplateProperty | Identifies the ExpandButtonTemplate dependancy property. (Inherited from Diagram.)
GridDashArrayProperty | Identifies the GridDashArray dependency property. (Inherited from Diagram.)
GridPointSizeProperty | Identifies the GridPointSize dependency property. (Inherited from Diagram.)
NodeEffectsSourceProperty | Identifies the NodeEffectsSource dependency property. (Inherited from Diagram.)
ShapeNodeStyleProperty | Identifies the ShapeNodeStyle dependency property. (Inherited from Diagram.)
TableNodeStyleProperty | Identifies the TableNodeStyle dependency property. (Inherited from Diagram.)
TreeViewNodeStyleProperty | Identifeis the TreeViewNodeStyle dependency property. (Inherited from Diagram.)
ZoomFactorProperty | Identifies the ZoomFactor property. (Inherited from Diagram.)

See Also

VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram.HorizontalOffsetProperty Field

VirtualizingDiagram.HorizontalOffsetProperty Field
[image]

Identifies the HorizontalOffset dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static DependencyProperty HorizontalOffsetProperty

Visual Basic [image] Copy Code

Public Shared HorizontalOffsetProperty As DependencyProperty

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram.LinksSourceProperty Field

VirtualizingDiagram.LinksSourceProperty Field
[image]

Identifies the LinksSource dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static DependencyProperty LinksSourceProperty

Visual Basic [image] Copy Code

Public Shared LinksSourceProperty As DependencyProperty

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram.NodesSourceProperty Field

VirtualizingDiagram.NodesSourceProperty Field
[image]

Identifies the NodesSource dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static DependencyProperty NodesSourceProperty

Visual Basic [image] Copy Code

Public Shared NodesSourceProperty As DependencyProperty

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram.VerticalOffsetProperty Field

VirtualizingDiagram.VerticalOffsetProperty Field
[image]

Identifies the VerticalOffset dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static DependencyProperty VerticalOffsetProperty

Visual Basic [image] Copy Code

Public Shared VerticalOffsetProperty As DependencyProperty

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram.ViewportHeightProperty Field

VirtualizingDiagram.ViewportHeightProperty Field
[image]

Identifies the ViewportHeight dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static DependencyProperty ViewportHeightProperty

Visual Basic [image] Copy Code

Public Shared ViewportHeightProperty As DependencyProperty

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram.ViewportWidthProperty Field

VirtualizingDiagram.ViewportWidthProperty Field
[image]

Identifies the ViewportWidth dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static DependencyProperty ViewportWidthProperty

Visual Basic [image] Copy Code

Public Shared ViewportWidthProperty As DependencyProperty

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram Constructor

VirtualizingDiagram Constructor
[image]

Initializes a new instance of the VirtualizingDiagram class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public VirtualizingDiagram ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram Methods

VirtualizingDiagram Methods
[image]

Public Methods

Name | Description
GetDataItem | Gets the item from the data source that is represented by the specified DiagramItem.
GetDiagramLink | Gets the DiagramLink that represents the specified data item on screen.
GetDiagramNode | Gets the DiagramNode that represents the specified data item on screen.
RaiseRealized | Raises the appropriate *Realized event according to the type of the specified item.

Protected Methods

Name | Description
OnLinkCreated | DiagramBase.OnLinkCreated override.
OnLinkDeleted | DiagramBase.OnLinkDeleted override.
OnLinkModified | DiagramBase.OnLinkModified override.
OnLinkRealized | Raises the LinkRealized event.
OnNodeCreated | DiagramBase.OnNodeCreated override.
OnNodeDeleted | DiagramBase.OnNodeDeleted override.
OnNodeDeleting | DiagramBase.OnNodeDeleting override.
OnNodeModified | DiagramBase.OnNodeModified override.
OnNodeRealized | Raises the NodeRealized event.

Inherited Public Methods

Name | Description
AlignPointToGrid | Returns a point of the alignment grid nearest to the one passed as an argument. (Inherited from Diagram.)
ArrangeLinkLabels | Rearranges link labels whose AutoArrange property is enabled. (Inherited from Diagram.)
BeginEdit | Overloaded. (Inherited from Diagram.)
CancelCompositeOperation | Stops recording undo/redo commands into a CompositeCommand and discards the records created so far. (Inherited from Diagram.)
CancelDrag | Cancels the current drag operation. (Inherited from Diagram.)
ChangeUnit | Sets new MeasureUnit value and scales the coordinates of diagram items so that their absolute size remains unchanged. (Inherited from Diagram.)
ClearAll | Removes all items from the diagram. (Inherited from Diagram.)
CommitCompositeOperation | Stops recording undo/redo commands into a CompositeCommand and saves the composite in the history queue. (Inherited from Diagram.)
CopySelection | Creates a copy of the currently selected objects and groups. (Inherited from Diagram.)
CreateThemeFromDefaults | Creates a Theme object representing the default properties of the diagram. (Inherited from Diagram.)
EndDelayUpdate | Continue updating the visual state of items. (Inherited from Diagram.)
EndEdit | Exits the in-place editing mode and either accepts or rejects the changes made to the item's text. (Inherited from Diagram.)
ExecuteCommand | Executes the specified command on this diagram. (Inherited from Diagram.)
FindLinkById | Finds the link that has the specified id value. (Inherited from Diagram.)
FindNodeById | Finds the node that has the specified id value. (Inherited from Diagram.)
GetContentBounds | Returns the smallest rectangle that bounds all diagram objects. (Inherited from Diagram.)
GetItemAt | Overloaded. (Inherited from Diagram.)
GetLinkAt | Overloaded. Finds and returns the top-most link that lies at the specified location. (Inherited from Diagram.)
GetNearestNode | Returns the node nearest to the specified point. (Inherited from Diagram.)
GetNodeAt | Overloaded. (Inherited from Diagram.)
GetNodesInViewport | Returns all nodes visible in the current viewport. (Inherited from Diagram.)
HitTestManipulators | Tests whether the specified point is within the manipulator of a diagram object and triggers the manipulator. (Inherited from Diagram.)
Invalidate | Causes the entire visible diagram area to be repainted. (Inherited from Diagram.)
IsItemInteractive | Checks if the specified item can be modified interactively. (Inherited from Diagram.)
IsItemLocked | Checks if the specified item is locked. (Inherited from Diagram.)
IsItemVisible | Checks if the specified item is currently visible. (Inherited from Diagram.)
LoadFromString | Decodes diagram contents from a string that was created with SaveToString. (Inherited from Diagram.)
LoadFromXml | Overloaded. (Inherited from Diagram.)
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from Diagram.)
PasteSelection | Adds the specified items and groups to this diagram. (Inherited from Diagram.)
RaiseClicked | Raises the Clicked event. (Inherited from Diagram.)
RaiseClicked | Raises the appropriate *Clicked event according to the type of the specified item. (Inherited from Diagram.)
RaiseCreated | Raises the appropriate *Created event according to the type of the specified item. (Inherited from Diagram.)
RaiseDeleting | Raises the LinkDeleting or NodeDeleting event according to the type of the specified item. (Inherited from Diagram.)
RaiseDoubleClicked | Overloaded. (Inherited from Diagram.)
RaiseLinkTextEdited | Raises the LinkTextEdited event. (Inherited from Diagram.)
RaiseNodeTextEdited | Raises the NodeTextEdited event. (Inherited from Diagram.)
RaisePasted | Raises the appropriate Pasted event. (Inherited from Diagram.)
Redo | Executes again an action saved in the command history. (Inherited from Diagram.)
RegisterClass | Registers a class for serialization support. (Inherited from Diagram.)
RegisterItemClass | Registers a diagram item class for serialization support. (Inherited from Diagram.)
ResizeToFitItem | Resizes the document extents so that the specified item is contained within. (Inherited from Diagram.)
ResizeToFitItems | Overloaded. Resizes the document scrollable area so it fits all diagram items. (Inherited from Diagram.)
RouteAllLinks | Routes all links in the diagram in a way they do not cross nodes. (Inherited from Diagram.)
SaveToString | Returns a serialized form of the diagram as string (Inherited from Diagram.)
SaveToXml | Overloaded. (Inherited from Diagram.)
SetScrollerParent | Binds the lane-grid header positions to the offset of a ScrollViewer's scrollbars. (Inherited from Diagram.)
SetZoomFactor | Sets the zoom factor, preserving the on-screen position of the specified diagram point. (Inherited from Diagram.)
StartCompositeOperation | Starts recording undo/redo commands into a CompositeCommand. (Inherited from Diagram.)
StartDelayUpdate | Stops updating the visual state of items. (Inherited from Diagram.)
StartInteraction | Overloaded. (Inherited from Diagram.)
Undo | Undoes an action saved in the command history. (Inherited from Diagram.)
UpdateRuntimeIndices | For internal use. (Inherited from Diagram.)
UpdateVisualZIndices | For internal use. (Inherited from Diagram.)
ZoomToRect | Zooms and scrolls the view to fit the specified document rectangle in the Diagram's visible area. (Inherited from Diagram.)

Inherited Protected Methods

Name | Description
ArrangeOverride | FrameworkElement.ArrangeOverride override. (Inherited from Diagram.)
OnActionRedone | Raises the ActionRedone event. (Inherited from DiagramBase.)
OnActionUndone | Raises the ActionUndone event. (Inherited from DiagramBase.)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramBase.)
OnCellClicked | Raises the CellClicked event. (Inherited from DiagramBase.)
OnCellDoubleClicked | Raises the CellDoubleClicked event. (Inherited from DiagramBase.)
OnClicked | Raises the Clicked event. (Inherited from DiagramBase.)
OnContainerChildAdded | Raises the ContainerChildAdded event. (Inherited from DiagramBase.)
OnContainerChildRemoved | Raises the ContainerChildRemoved event. (Inherited from DiagramBase.)
OnContainerFolded | Raises the ContainerFolded event. (Inherited from DiagramBase.)
OnContainerUnfolded | Raises the ContainerUnfolded event. (Inherited from DiagramBase.)
OnDeserializeControl | Raises the DeserializeControl event. (Inherited from DiagramBase.)
OnDeserializeTag | Raises the DeserializeTag event. (Inherited from DiagramBase.)
OnDoubleClicked | Raises the DoubleClicked event. (Inherited from DiagramBase.)
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event. (Inherited from DiagramBase.)
OnEnterInplaceEditMode | Raises the EnterInplaceEditMode event. (Inherited from DiagramBase.)
OnExpandButtonClicked | Raises the ExpandButtonClicked event. (Inherited from DiagramBase.)
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event. (Inherited from DiagramBase.)
OnInitializeLink | Raises the InitializeLink event. (Inherited from DiagramBase.)
OnInitializeNode | Raises the InitializeNode event. (Inherited from DiagramBase.)
OnItemAdded | Raises the ItemAdded event. (Inherited from DiagramBase.)
OnItemRemoved | Raises the ItemRemoved event. (Inherited from DiagramBase.)
OnLaneGridCellCreated | Raises the LaneGridCellCreated event. (Inherited from DiagramBase.)
OnLaneGridHeaderCreated | Raises the LaneGridHeaderCreated event. (Inherited from DiagramBase.)
OnLeaveInplaceEditMode | Raises the LeaveInplaceEditMode event. (Inherited from DiagramBase.)
OnLinkActivated | Raises the LinkActivated event. (Inherited from DiagramBase.)
OnLinkClicked | Raises the LinkClicked event. (Inherited from DiagramBase.)
OnLinkCreated | Raises the LinkCreated event. (Inherited from DiagramBase.)
OnLinkCreating | Raises the LinkCreating event. (Inherited from DiagramBase.)
OnLinkDeactivated | Raises the LinkDeactivated event. (Inherited from DiagramBase.)
OnLinkDeleted | Raises the LinkDeleted event. (Inherited from DiagramBase.)
OnLinkDeleting | Raises the LinkDeleting event. (Inherited from DiagramBase.)
OnLinkDeselected | Raises the LinkDeselected event. (Inherited from DiagramBase.)
OnLinkDoubleClicked | Raises the LinkDoubleClicked event. (Inherited from DiagramBase.)
OnLinkModified | Raises the LinkModified event. (Inherited from DiagramBase.)
OnLinkModifying | Raises the LinkModifying event. (Inherited from DiagramBase.)
OnLinkPasted | Raises the LinkPasted event. (Inherited from DiagramBase.)
OnLinkRouted | Raises the LinkRouted event. (Inherited from DiagramBase.)
OnLinkSelected | Raises the LinkSelected event. (Inherited from DiagramBase.)
OnLinkTextEdited | Raises the LinkTextEdited event. (Inherited from DiagramBase.)
OnMagnifierFactorChanged | Raises the MagnifierFactorChanged event. (Inherited from DiagramBase.)
OnMeasureUnitChanged | Raises the MeasureUnitChanged event. (Inherited from DiagramBase.)
OnMouseRightButtonDown | Control.OnMouseRightButtonDown override. (Inherited from Diagram.)
OnMouseRightButtonUp | Control.OnMouseRightButtonUp override. (Inherited from Diagram.)
OnNodeActivated | Raises the NodeActivated event. (Inherited from DiagramBase.)
OnNodeClicked | Raises the NodeClicked event. (Inherited from DiagramBase.)
OnNodeCreated | Raises the NodeCreated event. (Inherited from DiagramBase.)
OnNodeCreating | Raises the NodeCreating event. (Inherited from DiagramBase.)
OnNodeDeactivated | Raises the NodeDeactivated event. (Inherited from DiagramBase.)
OnNodeDeleted | Raises the NodeDeleted event. (Inherited from DiagramBase.)
OnNodeDeleting | Raises the NodeDeleting event. (Inherited from DiagramBase.)
OnNodeDeselected | Raises the NodeDeselected event. (Inherited from DiagramBase.)
OnNodeDoubleClicked | Raises the NodeDoubleClicked event. (Inherited from DiagramBase.)
OnNodeModified | Raises the NodeModified event. (Inherited from DiagramBase.)
OnNodeModifying | Raises the NodeModifying event. (Inherited from DiagramBase.)
OnNodePasted | Raises the NodePasted event. (Inherited from DiagramBase.)
OnNodeSelected | Raises the NodeSelected event. (Inherited from DiagramBase.)
OnNodeTextEdited | Raises the NodeTextEdited event. (Inherited from DiagramBase.)
OnRepaint | Raises the Repaint event. (Inherited from DiagramBase.)
OnSelectionChanged | Raises the SelectionChanged event. (Inherited from DiagramBase.)
OnSelectionModified | Raises the SelectionModified event. (Inherited from DiagramBase.)
OnSelectionModifying | Raises the SelectionModifying event. (Inherited from DiagramBase.)
OnSerializeControl | Raises the SerializeControl event. (Inherited from DiagramBase.)
OnSerializeTag | Raises the SerializeTag event. (Inherited from DiagramBase.)
OnSetSelfLoopShape | Raises the SetSelfLoopShape event. (Inherited from DiagramBase.)
OnTreeCollapsed | Raises the TreeCollapsed event. (Inherited from DiagramBase.)
OnTreeExpanded | Raises the TreeExpanded event. (Inherited from DiagramBase.)
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event. (Inherited from DiagramBase.)
OnZoomFactorChanged | Raises the ZoomFactorChanged event. (Inherited from DiagramBase.)
RemoveItem | Removes the specified item from the diagram and creates a record in the undo/redo history. (Inherited from Diagram.)

See Also

VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram.GetDataItem Method

VirtualizingDiagram.GetDataItem Method
[image]

Gets the item from the data source that is represented by the specified DiagramItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object GetDataItem (
DiagramItem diagramItem
)

Visual Basic [image] Copy Code

Public Function GetDataItem ( _
diagramItem As DiagramItem _
) As Object

Parameters

diagramItem
A DiagramItem representing the specified data item on screen.

Return Value

An object from the data source.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming Namespace
GetDiagramLink Method
GetDiagramNode Method


MindFusion.Diagramming.VirtualizingDiagram.GetDiagramLink Method

VirtualizingDiagram.GetDiagramLink Method
[image]

Gets the DiagramLink that represents the specified data item on screen.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink GetDiagramLink (
Object dataItem
)

Visual Basic [image] Copy Code

Public Function GetDiagramLink ( _
dataItem As Object _
) As DiagramLink

Parameters

dataItem
An element of LinksSource.

Return Value

A DiagramLink representing the specified data item, or null if the item is not shown on screen.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming Namespace
GetDataItem Method
GetDiagramNode Method


MindFusion.Diagramming.VirtualizingDiagram.GetDiagramNode Method

VirtualizingDiagram.GetDiagramNode Method
[image]

Gets the DiagramNode that represents the specified data item on screen.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode GetDiagramNode (
Object dataItem
)

Visual Basic [image] Copy Code

Public Function GetDiagramNode ( _
dataItem As Object _
) As DiagramNode

Parameters

dataItem
An element of NodesSource.

Return Value

A DiagramNode representing the specified data item, or null if the item is not shown on screen.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming Namespace
GetDataItem Method
GetDiagramLink Method


MindFusion.Diagramming.VirtualizingDiagram.OnLinkCreated Method

VirtualizingDiagram.OnLinkCreated Method
[image]

DiagramBase.OnLinkCreated override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnLinkCreated (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnLinkCreated( _
e As LinkEventArgs _
)

Parameters

e

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram.OnLinkDeleted Method

VirtualizingDiagram.OnLinkDeleted Method
[image]

DiagramBase.OnLinkDeleted override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnLinkDeleted (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnLinkDeleted( _
e As LinkEventArgs _
)

Parameters

e

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram.OnLinkModified Method

VirtualizingDiagram.OnLinkModified Method
[image]

DiagramBase.OnLinkModified override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnLinkModified (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnLinkModified( _
e As LinkEventArgs _
)

Parameters

e

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram.OnLinkRealized Method

VirtualizingDiagram.OnLinkRealized Method
[image]

Raises the LinkRealized event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void OnLinkRealized (
VirtualLinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Sub OnLinkRealized( _
e As VirtualLinkEventArgs _
)

Parameters

e

A LinkEventArgs that contains the event data.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram.OnNodeCreated Method

VirtualizingDiagram.OnNodeCreated Method
[image]

DiagramBase.OnNodeCreated override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnNodeCreated (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnNodeCreated( _
e As NodeEventArgs _
)

Parameters

e

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram.OnNodeDeleted Method

VirtualizingDiagram.OnNodeDeleted Method
[image]

DiagramBase.OnNodeDeleted override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnNodeDeleted (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnNodeDeleted( _
e As NodeEventArgs _
)

Parameters

e

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram.OnNodeDeleting Method

VirtualizingDiagram.OnNodeDeleting Method
[image]

DiagramBase.OnNodeDeleting override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnNodeDeleting (
NodeValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnNodeDeleting( _
e As NodeValidationEventArgs _
)

Parameters

e

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram.OnNodeModified Method

VirtualizingDiagram.OnNodeModified Method
[image]

DiagramBase.OnNodeModified override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnNodeModified (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnNodeModified( _
e As NodeEventArgs _
)

Parameters

e

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram.OnNodeRealized Method

VirtualizingDiagram.OnNodeRealized Method
[image]

Raises the NodeRealized event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void OnNodeRealized (
VirtualNodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Sub OnNodeRealized( _
e As VirtualNodeEventArgs _
)

Parameters

e

A NodeEventArgs that contains the event data.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram.RaiseRealized Method

VirtualizingDiagram.RaiseRealized Method
[image]

Raises the appropriate *Realized event according to the type of the specified item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseRealized (
DiagramItem item,
Object dataItem
)

Visual Basic [image] Copy Code

Public Sub RaiseRealized( _
item As DiagramItem, _
dataItem As Object _
)

Parameters

item

The DiagramItem related to the event.

dataItem

The data item related to the event.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram Properties

VirtualizingDiagram Properties
[image]

Public Properties

Name | Description
BindingMode | Gets or sets a value that indicates the direction of the data flow in the binding.
DefaultNodeSize | Gets or sets the default node size used when data elements do not contain Width and Height properties.
HorizontalOffset | Gets or sets the horizontal offset of the scrolled diagram.
InstantiateLink | A delegate called to create a DiagramLink instance when realizing data items on screen.
InstantiateLinkData | A delegate called to create a data item for a link drawn by the user.
InstantiateNode | A delegate called to create a DiagramNode instance when realizing data items on screen.
InstantiateNodeData | A delegate called to create a data item for a node drawn by the user.
LinksSource | Gets or sets a collection whose elements will be rendered as links in the diagram.
NodesSource | Gets or sets a collection whose elements will be rendered as nodes in the diagram.
ResolveNodePosition | A delegate called to determine the position of a node within the diagram.
VerticalOffset | Gets or sets the vertical offset of the scrolled diagram.
ViewportHeight | Gets or sets the height of the diagram viewport.
ViewportWidth | Gets or sets the width of the diagram viewport.
VisualCacheSize | Gets or sets the size of the cache storing actual nodes and links that will be reused for displaying new data elements while scrolling.

Inherited Public Properties

Name | Description
ActiveItem | Gets or sets the active diagram element. (Inherited from Diagram.)
ActiveItemHandlesStyle | Gets or sets the visual style of adjustment handles of the active item. (Inherited from Diagram.)
ActiveLayer | Gets or sets the zero-based index of the active layer. (Inherited from Diagram.)
AdjustmentHandlesSize | Gets or sets the size of the handles, which appear around selected objects. This is a dependency property. (Inherited from Diagram.)
AlignmentGuidePen | Gets or sets the pen used to draw alignment guides. This is a dependency property. (Inherited from Diagram.)
AlignToGrid | Gets or sets a value indicating whether the diagram items should be aligned to a grid. (Inherited from Diagram.)
AllowInplaceEdit | Gets or sets a value indicating whether in-place editing of the text of objects is enabled. (Inherited from Diagram.)
AllowMultipleResize | Specifies whether multiple selected nodes can be resized simultaneously. This is a dependency property. (Inherited from Diagram.)
AllowUnconnectedLinks | Gets or sets a value indicating whether users are allowed to draw links that are not connected to any node. This is a dependency property. (Inherited from Diagram.)
AutoAlignDistance | Gets or sets the maximal horizontal or vertical distance at which a node aligns to the borders ot other nodes. (Inherited from Diagram.)
AutoAlignNodes | Gets or sets whether nodes should automatically align to the borders ot other nodes during user interaction. (Inherited from Diagram.)
AutoResize | Gets or sets a value indicating whether the document area should be resized automatically so it fits the diagram contents. (Inherited from Diagram.)
AutoScroll | Gets or sets a value indicating whether auto scrolling of the document area is enabled. This is a dependency property. (Inherited from Diagram.)
AutoSnapDistance | Specifies the maximum distance at which links auto-snap to nodes. (Inherited from Diagram.)
AutoSnapLinks | Specifies whether link end points should automatically snap to the nearest diagram node. (Inherited from Diagram.)
BackBrush | Gets or sets the brush used for painting the diagram background. (Inherited from Diagram.)
Behavior | Gets or sets a value indicating how the control responds to user actions. (Inherited from Diagram.)
Bounds | Gets or sets a value representing the size of the diagram's scrollable area. (Inherited from Diagram.)
CanRedo | Gets or sets a value indicating whether there is a command in the redo history which can be redone. (Inherited from Diagram.)
CanUndo | Gets or sets a value indicating whether there is a command in the undo history which can be undone. (Inherited from Diagram.)
ContainerNodeStyle | Gets or sets the theme-level style for container nodes. This is a dependency property. (Inherited from Diagram.)
ContainersFoldable | Gets or sets the default value for the Foldable property of containers. (Inherited from Diagram.)
CrossingRadius | Gets or sets the radius length of decorations displayed at link intersection points. (Inherited from Diagram.)
CustomBehavior | Gets or sets a custom behavior object specifying how DiagramRT responds to mouse input. (Inherited from Diagram.)
DefaultControlType | Gets or sets the type of the controls that will be hosted by default in newly create ControlNode objects. (Inherited from Diagram.)
DefaultShape | Gets or sets the default shape of shape nodes. (Inherited from Diagram.)
DelKeyAction | Gets or sets a value that specifies what action should be performed when the user hits the Del key. (Inherited from Diagram.)
DiagramLinkStyle | Gets or sets the theme-level style for diagram links. This is a dependency property. (Inherited from Diagram.)
DisabledHandlesStyle | Gets or sets the visual style of disabled adjustment handles. (Inherited from Diagram.)
DocumentPlane | DocumentPlane is visual child of diagram and ancestor of all diagram items. The DocumentPlane element is translated with respect to Diagram element so that the point Diagram.Bounds.TopLeft from the DocumentPlane is rendered at Diagram element location (0,0). The coordinate system of the DocumentPlane is the document coordinate system. The intended use of this property is mainly in MouseMove event handling (Inherited from Diagram.)
DynamicLinks | Gets or sets the default value for the Dynamic property of new links. (Inherited from Diagram.)
Enabled | Enables or disables handling of mouse events. (Inherited from Diagram.)
EnableLanes | Gets or sets whether lanes are enabled. This is a dependency property. (Inherited from Diagram.)
ExpandButtonAction | Gets or sets a value indicating what should happen when a user clicks the [+/-] button that is displayed near expandable nodes. (Inherited from Diagram.)
ExpandButtonBrush | Gets or sets the brush used to fill expand/collapse buttons of nodes. (Inherited from Diagram.)
ExpandButtonPosition | Gets or sets where expand/collapse buttons are located relatively to their nodes. (Inherited from Diagram.)
ExpandButtonTemplate | Gets or sets a custom ControlTemplate for the ExpandButton class. (Inherited from Diagram.)
ExpandOnIncoming | Gets or sets a value, indicating in which direction object hierarchies are expanded. (Inherited from Diagram.)
Factory | Gets a Factory instance that lets you add programmatically new items to the diagram. (Inherited from Diagram.)
GridColor | Gets or sets the color of the grid points. (Inherited from Diagram.)
GridDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to draw grid lines. This is a dependency property. (Inherited from Diagram.)
GridOffsetX | Gets or sets the horizontal offset of the first point of the alignment grid. (Inherited from Diagram.)
GridOffsetY | Gets or sets the vertical offset of the first point of the alignment grid. (Inherited from Diagram.)
GridPointSize | Gets or sets the size of shapes used to represent grid points. This is a dependency property. (Inherited from Diagram.)
GridSizeX | Gets or sets the horizontal distance between adjacent grid points. (Inherited from Diagram.)
GridSizeY | Gets or sets the vertical distance between adjacent grid points. (Inherited from Diagram.)
GridStyle | Gets or sets the visual style of the alignment grid. (Inherited from Diagram.)
HitTestPriority | Gets or sets a value indicating the order in which items are hit-tested. (Inherited from Diagram.)
InplaceEditAcceptOnEnter | Gets or sets a value indicating whether pressing the ENTER key should exit in-place editing mode and accept changes made to text. (Inherited from Diagram.)
InplaceEditCancelOnEsc | Gets or sets a value indicating whether pressing the ESC key should exit inplace-edit mode and reject changes made to text. (Inherited from Diagram.)
Interaction | Gets an InteractionState instance representing the current action being carried out by the user. (Inherited from Diagram.)
Items | Represents a strongly typed collection of DiagramItem objects. (Inherited from Diagram.)
LaneGrid | Gets the Grid instance that represents the lane grid. (Inherited from Diagram.)
Layers | Gets a list of the layers in the current diagram. (Inherited from Diagram.)
LicenseKey | Gets or sets the license key of the control. (Inherited from Diagram.)
LinkBaseShape | Gets or sets the shape displayed at the base of new links. (Inherited from Diagram.)
LinkBaseShapeSize | Gets or sets the default size of the base of new links. (Inherited from Diagram.)
LinkBrush | Gets or sets the default value for the Brush property of links. (Inherited from Diagram.)
LinkCrossings | Gets or sets how to render the intersection points where links cross their paths. (Inherited from Diagram.)
LinkHeadShape | Gets or sets the shape displayed as head of new links. (Inherited from Diagram.)
LinkHeadShapeSize | Gets or sets the default size of arrowheads. (Inherited from Diagram.)
LinkIntermediateShape | Gets or sets default shape to be displayed in the middle of each segment of links. (Inherited from Diagram.)
LinkIntermediateShapeSize | Gets or sets the default size of the shapes at middles of link segments. (Inherited from Diagram.)
LinkPen | Gets or sets the default value for the Pen property of links. (Inherited from Diagram.)
LinkRouter | Gets or sets the component used to find paths for auto-routed links when diagram nodes are added or their positions change. (Inherited from Diagram.)
Links | Gets a DiagramLinkCollection containing the links. (Inherited from Diagram.)
LinkSegments | Gets or sets the default number of link segments. (Inherited from Diagram.)
LinkShape | Gets or sets the default style of diagram links. (Inherited from Diagram.)
MeasureUnit | Gets or sets the unit of measure used for logical coordinates in this diagram. (Inherited from Diagram.)
ModificationStart | Gets or sets how users can start modifying diagram items. (Inherited from Diagram.)
NodeEffects | Gets a collection with all effects applied to the nodes of this diagram. (Inherited from Diagram.)
Nodes | Gets a DiagramNodeCollection containing the nodes. (Inherited from Diagram.)
NodesExpandable | Gets or sets a value indicating whether newly created nodes can be expanded. (Inherited from Diagram.)
OverrideCursor | Sets the cursor and stops changing it depending on the context. (Inherited from Diagram.)
PrintOptions | Gets an object which provides customization properties for printed diagrams. (Inherited from Diagram.)
RecursiveExpand | Gets or sets value indicating how a tree is expanded. (Inherited from Diagram.)
RoundedLinks | Gets or sets a value indicating whether the joins between segments of Polyline and Cascading links should be rounded. (Inherited from Diagram.)
RoundedLinksRadius | Gets or sets the radius of arc joins of rounded links' segments. (Inherited from Diagram.)
RouteLinks | Gets or sets a value indicating whether links should avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes. (Inherited from Diagram.)
RoutingOptions | Gets an object, which allows customizing various parameters of the link routing algorithm. (Inherited from Diagram.)
ScrollX | Gets or sets the document's X scroll position. (Inherited from Diagram.)
ScrollY | Gets or sets the document's Y scroll position. (Inherited from Diagram.)
ScrollZoneSize | Gets or sets the size of the auto scroll zone near the edges of the control. (Inherited from Diagram.)
SelectedItemHandlesStyle | Gets or sets the visual style of adjustment handles of selected items. (Inherited from Diagram.)
Selection | Gets the Selection instance that represents the selection of items in this diagram. (Inherited from Diagram.)
ShapeBrush | Gets or sets the default value for the Brush property of shape nodes. (Inherited from Diagram.)
ShapeHandlesStyle | Gets or sets the default value for the HandlesStyle property of new shape nodes. (Inherited from Diagram.)
ShapeNodeStyle | Gets or sets the theme-level style for shape nodes. This is a dependency property. (Inherited from Diagram.)
ShapePen | Gets or sets the default value for the Pen property of new ShapeNode objects. (Inherited from Diagram.)
ShowAnchors | Gets or sets a value indicating whether and when node anchor points should be displayed. (Inherited from Diagram.)
ShowGrid | Gets or sets a value indicating whether the alignment grid is visible. (Inherited from Diagram.)
TableBrush | Gets or sets the default value for the Brush property of tables. (Inherited from Diagram.)
TableCaption | Gets or sets the default text for tables' captions. (Inherited from Diagram.)
TableCaptionHeight | Gets or sets the default height of table captions. (Inherited from Diagram.)
TableColumnCount | Gets or sets the default number of table columns. (Inherited from Diagram.)
TableColumnWidth | Gets or sets the default width of tables' columns. (Inherited from Diagram.)
TableNodeStyle | Gets or sets the theme-level style for table nodes. This is a dependency property. (Inherited from Diagram.)
TableRowCount | Gets or sets the default number of table rows. (Inherited from Diagram.)
TableRowHeight | Gets or sets the default height of tables' rows. (Inherited from Diagram.)
Theme | Gets or sets the theme associated with the diagram. (Inherited from Diagram.)
TreeViewNodeStyle | Gets or sets the theme-level style for treeview nodes. This is a dependency property. (Inherited from Diagram.)
UndoEnabled | Gets or sets a value indicating whether saving action records for later undo is enabled. (Inherited from Diagram.)
Viewport | Returns the visible portion of the diagram area. (Inherited from Diagram.)
ZoomFactor | Gets or sets the zoom factor used to scale up or down the Diagram. (Inherited from Diagram.)

See Also

VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram.BindingMode Property

VirtualizingDiagram.BindingMode Property
[image]

Gets or sets a value that indicates the direction of the data flow in the binding.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public BindingMode BindingMode { get; set; }

Visual Basic [image] Copy Code

Public Property BindingMode As BindingMode

Property Value

A member of the Windows.UI.Xaml.Data.BindingMode enumeration. The default value is OneWay.

Remarks

If you set BindingMode to TwoWay, you should also implement the InstantiateNodeData and InstantiateLinkData callbacks to create data items when the user draws new diagram items. Set the base Behavior property to control exactly what type of items the user is allowed to draw.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming Namespace
LinksSource Property
NodesSource Property


MindFusion.Diagramming.VirtualizingDiagram.DefaultNodeSize Property

VirtualizingDiagram.DefaultNodeSize Property
[image]

Gets or sets the default node size used when data elements do not contain Width and Height properties.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Size DefaultNodeSize { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultNodeSize As Size

Property Value

A Windows.UI.Xaml.Size instance specifying the default node size.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming Namespace
ResolveNodePosition Property


MindFusion.Diagramming.VirtualizingDiagram.HorizontalOffset Property

VirtualizingDiagram.HorizontalOffset Property
[image]

Gets or sets the horizontal offset of the scrolled diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public new double HorizontalOffset { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property HorizontalOffset As Double

Property Value

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram.InstantiateLink Property

VirtualizingDiagram.InstantiateLink Property
[image]

A delegate called to create a DiagramLink instance when realizing data items on screen.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public InstantiateLink InstantiateLink { get; set; }

Visual Basic [image] Copy Code

Public Property InstantiateLink As InstantiateLink

Property Value

An InstantiateLink delegate method.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming Namespace
InstantiateNode Property


MindFusion.Diagramming.VirtualizingDiagram.InstantiateLinkData Property

VirtualizingDiagram.InstantiateLinkData Property
[image]

A delegate called to create a data item for a link drawn by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public InstantiateLinkData InstantiateLinkData { get; set; }

Visual Basic [image] Copy Code

Public Property InstantiateLinkData As InstantiateLinkData

Property Value

An InstantiateLinkData delegate method.

Remarks

This method is called if BindingMode is set to TwoWay.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming Namespace
InstantiateNodeData Property


MindFusion.Diagramming.VirtualizingDiagram.InstantiateNode Property

VirtualizingDiagram.InstantiateNode Property
[image]

A delegate called to create a DiagramNode instance when realizing data items on screen.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public InstantiateNode InstantiateNode { get; set; }

Visual Basic [image] Copy Code

Public Property InstantiateNode As InstantiateNode

Property Value

An InstantiateNode delegate method.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming Namespace
InstantiateLink Property


MindFusion.Diagramming.VirtualizingDiagram.InstantiateNodeData Property

VirtualizingDiagram.InstantiateNodeData Property
[image]

A delegate called to create a data item for a node drawn by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public InstantiateNodeData InstantiateNodeData { get; set; }

Visual Basic [image] Copy Code

Public Property InstantiateNodeData As InstantiateNodeData

Property Value

An InstantiateNodeData delegate method.

Remarks

This method is called if BindingMode is set to TwoWay.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming Namespace
InstantiateLinkData Property


MindFusion.Diagramming.VirtualizingDiagram.LinksSource Property

VirtualizingDiagram.LinksSource Property
[image]

Gets or sets a collection whose elements will be rendered as links in the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IList LinksSource { get; set; }

Visual Basic [image] Copy Code

Public Property LinksSource As IList

Property Value

A collection containing data items that should be displayed as diagram links.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming Namespace
NodesSource Property
BindingMode Property


MindFusion.Diagramming.VirtualizingDiagram.NodesSource Property

VirtualizingDiagram.NodesSource Property
[image]

Gets or sets a collection whose elements will be rendered as nodes in the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IList NodesSource { get; set; }

Visual Basic [image] Copy Code

Public Property NodesSource As IList

Property Value

A collection containing data items that should be displayed as diagram nodes.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming Namespace
LinksSource Property
BindingMode Property


MindFusion.Diagramming.VirtualizingDiagram.ResolveNodePosition Property

VirtualizingDiagram.ResolveNodePosition Property
[image]

A delegate called to determine the position of a node within the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ResolveNodePosition ResolveNodePosition { get; set; }

Visual Basic [image] Copy Code

Public Property ResolveNodePosition As ResolveNodePosition

Property Value

A ResolveNodePosition delegate method.

Remarks

By default, VirtualizingDiagram determines the position of a data item by inspecting its X, Y, Width and Height properties through reflection. By assigning a callback to the ResolveNodePosition property, you can place items whose position properties are named differently or whose position is stored elsewhere.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming Namespace
DefaultNodeSize Property


MindFusion.Diagramming.VirtualizingDiagram.VerticalOffset Property

VirtualizingDiagram.VerticalOffset Property
[image]

Gets or sets the vertical offset of the scrolled diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public new double VerticalOffset { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property VerticalOffset As Double

Property Value

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram.ViewportHeight Property

VirtualizingDiagram.ViewportHeight Property
[image]

Gets or sets the height of the diagram viewport.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ViewportHeight { get; set; }

Visual Basic [image] Copy Code

Public Property ViewportHeight As Double

Property Value

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram.ViewportWidth Property

VirtualizingDiagram.ViewportWidth Property
[image]

Gets or sets the width of the diagram viewport.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ViewportWidth { get; set; }

Visual Basic [image] Copy Code

Public Property ViewportWidth As Double

Property Value

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram.VisualCacheSize Property

VirtualizingDiagram.VisualCacheSize Property
[image]

Gets or sets the size of the cache storing actual nodes and links that will be reused for displaying new data elements while scrolling.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int VisualCacheSize { get; set; }

Visual Basic [image] Copy Code

Public Property VisualCacheSize As Integer

Property Value

An integer specifying the cache size. The default value is 100.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram Events

VirtualizingDiagram Events
[image]

Public Events

Name | Description
LinkRealized | Raised when an actual DiagramLink instance is created to represent a data item from LinksSource.
NodeRealized | Raised when an actual DiagramNode instance is created to represent a data item from NodesSource.

Inherited Public Events

Name | Description
ActionRedone | Raised when an action is redone. (Inherited from DiagramBase.)
ActionUndone | Raised when an action is undone. (Inherited from DiagramBase.)
ActiveLayerChanged | Raised when the diagram's active layer has changed. (Inherited from DiagramBase.)
BoundsChanged | Raised when the Bounds property value has changed. (Inherited from DiagramBase.)
CellClicked | Raised when the user clicks a table's cell. (Inherited from DiagramBase.)
CellDoubleClicked | Raised when the user double-clicks a table's cell. (Inherited from DiagramBase.)
Clicked | Raised when the user clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area. (Inherited from DiagramBase.)
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area. (Inherited from DiagramBase.)
DeserializeControl | Lets you load the attributes of controls hosted inside ControlNodes. (Inherited from DiagramBase.)
DeserializeTag | Raised when the Tag or Id of a diagram item must be deserialized from XML format. (Inherited from DiagramBase.)
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
DrawAdjustmentHandles | Raised when item's adjustment handles must be custom drawn. (Inherited from DiagramBase.)
EnterInplaceEditMode | Raised when entering inplace-edit mode. (Inherited from DiagramBase.)
ExpandButtonClicked | Raised when the user clicks the [+/-] button of an Expandable node. (Inherited from DiagramBase.)
HitTestAdjustmentHandles | Raised when custom hit testing of item's adjustment handles must be performed. (Inherited from DiagramBase.)
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created. (Inherited from DiagramBase.)
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created. (Inherited from DiagramBase.)
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
LaneGridCellCreated | Raised when a lane grid's cell has been created to allow additional cusomtization of its presentation. (Inherited from DiagramBase.)
LaneGridHeaderCreated | Raised when a lane grid's header has been created to allow additional cusomtization of its presentation. (Inherited from DiagramBase.)
LeaveInplaceEditMode | Raised when leaving inplace-edit mode. (Inherited from DiagramBase.)
LinkActivated | Raised when a link becomes the ActiveItem. (Inherited from DiagramBase.)
LinkClicked | Raised when the user clicks a link. (Inherited from DiagramBase.)
LinkCreated | Raised when the user draws a new link. (Inherited from DiagramBase.)
LinkCreating | A validation event raised while the user is drawing a new link. (Inherited from DiagramBase.)
LinkDeactivated | Raised when a link is no longer the ActiveItem. (Inherited from DiagramBase.)
LinkDeleted | Raised when a link is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkDeselected | Raised when a link is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDoubleClicked | Raised when the user double-clicks a link. (Inherited from DiagramBase.)
LinkModified | Raised when the user moves any control point of a link. (Inherited from DiagramBase.)
LinkModifying | A validation event raised while the user is modifying a link. (Inherited from DiagramBase.)
LinkPasted | Raised when a link has been pasted from the clipboard. (Inherited from DiagramBase.)
LinkRouted | Raised when a link is routed by the auto-routing algorithm. (Inherited from DiagramBase.)
LinkSelected | Raised when a link is selected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkTextEdited | Raised when the user edits the text of a link. (Inherited from DiagramBase.)
MagnifierFactorChanged | Occurs when the magnifier factor changes. (Inherited from DiagramBase.)
MeasureUnitChanged | Raised when the MeasureUnit property value has changed. (Inherited from DiagramBase.)
NodeActivated | Raised when a node becomes the ActiveItem. (Inherited from DiagramBase.)
NodeClicked | Raised when the user clicks a node. (Inherited from DiagramBase.)
NodeCreated | Occurs when the user draws a new node. (Inherited from DiagramBase.)
NodeCreating | A validation event raised while the user is drawing a new node. (Inherited from DiagramBase.)
NodeDeactivated | Raised when a node is no longer the ActiveItem. (Inherited from DiagramBase.)
NodeDeleted | Raised when a node is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeDeselected | Raised when a node is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDoubleClicked | Raised when the user double-clicks a node. (Inherited from DiagramBase.)
NodeModified | Raised when the user moves or resizes a node. (Inherited from DiagramBase.)
NodeModifying | A validation event raised while the user is moving or resizing a node. (Inherited from DiagramBase.)
NodePasted | Raised when a node has been pasted from the clipboard. (Inherited from DiagramBase.)
NodeSelected | Raised when a node is selected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeTextEdited | Raised when the user edits the text of a node. (Inherited from DiagramBase.)
Repaint | Raised when the diagram views should be repainted. (Inherited from DiagramBase.)
SelectionChanged | Raised when an item is added to or removed from the selection. (Inherited from DiagramBase.)
SelectionModified | Raised when the user moves or resizes multiple selected items. (Inherited from DiagramBase.)
SelectionModifying | Raised while the user is moving or resizing multiple selected items, this event lets you cancel the modification. (Inherited from DiagramBase.)
SerializeControl | Lets you save the attributes of controls hosted inside ControlNodes. (Inherited from DiagramBase.)
SerializeTag | Raised when the Tag of a diagram item must be serialized into an XML document. (Inherited from DiagramBase.)
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape. (Inherited from DiagramBase.)
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node. (Inherited from DiagramBase.)
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node. (Inherited from DiagramBase.)
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point. (Inherited from DiagramBase.)
ZoomFactorChanged | Occurs when the zoom factor changes. (Inherited from DiagramBase.)

See Also

VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram.LinkRealized Event

VirtualizingDiagram.LinkRealized Event
[image]

Raised when an actual DiagramLink instance is created to represent a data item from LinksSource.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<VirtualLinkEventArgs> LinkRealized

Visual Basic [image] Copy Code

Public Event LinkRealized As EventHandler(Of VirtualLinkEventArgs)

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class


MindFusion.Diagramming.VirtualizingDiagram.NodeRealized Event

VirtualizingDiagram.NodeRealized Event
[image]

Raised when an actual DiagramNode instance is created to represent a data item from NodesSource.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<VirtualNodeEventArgs> NodeRealized

Visual Basic [image] Copy Code

Public Event NodeRealized As EventHandler(Of VirtualNodeEventArgs)

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class


MindFusion.Diagramming.VirtualLinkEventArgs Class

VirtualLinkEventArgs Class
[image]

Contains arguments passed to handlers of the LinkRealized event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class VirtualLinkEventArgs : LinkEventArgs

Visual Basic [image] Copy Code

Public Class VirtualLinkEventArgs
Inherits LinkEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.LinkEventArgs
MindFusion.Diagramming.VirtualLinkEventArgs

See Also

VirtualLinkEventArgs Members


MindFusion.Diagramming.VirtualLinkEventArgs Members

VirtualLinkEventArgs Members
Constructors Properties
[image]

Contains arguments passed to handlers of the LinkRealized event.

The following tables list the members exposed by the VirtualLinkEventArgs type.

Public Constructors

Name | Description
VirtualLinkEventArgs | Initializes a new instance of the VirtualLinkEventArgs class.

Public Properties

Name | Description
DataItem | The data item just shown on screen.

Inherited Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from LinkEventArgs.)
Link | Gets the link for which the event raised. (Inherited from LinkEventArgs.)
MouseButton | Gets which mouse button was pressed. (Inherited from LinkEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from LinkEventArgs.)

See Also

VirtualLinkEventArgs Class


MindFusion.Diagramming.VirtualLinkEventArgs Constructor

VirtualLinkEventArgs Constructor
[image]

Initializes a new instance of the VirtualLinkEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public VirtualLinkEventArgs (
DiagramLink link,
Object dataItem
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink, _
dataItem As Object _
)

Parameters

link

The DiagramLink created to represent the data item on screen.

dataItem

The data item just shown on screen.

See Also

VirtualLinkEventArgs Class


MindFusion.Diagramming.VirtualLinkEventArgs Properties

VirtualLinkEventArgs Properties
[image]

Public Properties

Name | Description
DataItem | The data item just shown on screen.

Inherited Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from LinkEventArgs.)
Link | Gets the link for which the event raised. (Inherited from LinkEventArgs.)
MouseButton | Gets which mouse button was pressed. (Inherited from LinkEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from LinkEventArgs.)

See Also

VirtualLinkEventArgs Class


MindFusion.Diagramming.VirtualLinkEventArgs.DataItem Property

VirtualLinkEventArgs.DataItem Property
[image]

The data item just shown on screen.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object DataItem { get; set; }

Visual Basic [image] Copy Code

Public Property DataItem As Object

Property Value

See Also

VirtualLinkEventArgs Members
VirtualLinkEventArgs Class


MindFusion.Diagramming.VirtualNodeEventArgs Class

VirtualNodeEventArgs Class
[image]

Contains arguments passed to handlers of the NodeRealized event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class VirtualNodeEventArgs : NodeEventArgs

Visual Basic [image] Copy Code

Public Class VirtualNodeEventArgs
Inherits NodeEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.NodeEventArgs
MindFusion.Diagramming.VirtualNodeEventArgs

See Also

VirtualNodeEventArgs Members


MindFusion.Diagramming.VirtualNodeEventArgs Members

VirtualNodeEventArgs Members
Constructors Properties
[image]

Contains arguments passed to handlers of the NodeRealized event.

The following tables list the members exposed by the VirtualNodeEventArgs type.

Public Constructors

Name | Description
VirtualNodeEventArgs | Initializes a new instance of the VirtualNodeEventArgs class.

Public Properties

Name | Description
DataItem | The data item just shown on screen.

Inherited Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from NodeEventArgs.)
MouseButton | Gets which mouse button has been pressed. (Inherited from NodeEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from NodeEventArgs.)
Node | Gets the node for which the event was raised. (Inherited from NodeEventArgs.)

See Also

VirtualNodeEventArgs Class


MindFusion.Diagramming.VirtualNodeEventArgs Constructor

VirtualNodeEventArgs Constructor
[image]

Initializes a new instance of the VirtualNodeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public VirtualNodeEventArgs (
DiagramNode node,
Object dataItem
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode, _
dataItem As Object _
)

Parameters

node

The DiagramNode created to represent the data item on screen.

dataItem

The data item just shown on screen.

See Also

VirtualNodeEventArgs Class


MindFusion.Diagramming.VirtualNodeEventArgs Properties

VirtualNodeEventArgs Properties
[image]

Public Properties

Name | Description
DataItem | The data item just shown on screen.

Inherited Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from NodeEventArgs.)
MouseButton | Gets which mouse button has been pressed. (Inherited from NodeEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from NodeEventArgs.)
Node | Gets the node for which the event was raised. (Inherited from NodeEventArgs.)

See Also

VirtualNodeEventArgs Class


MindFusion.Diagramming.VirtualNodeEventArgs.DataItem Property

VirtualNodeEventArgs.DataItem Property
[image]

The data item just shown on screen.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object DataItem { get; set; }

Visual Basic [image] Copy Code

Public Property DataItem As Object

Property Value

See Also

VirtualNodeEventArgs Members
VirtualNodeEventArgs Class


MindFusion.Diagramming.VisibilityConverter Class

VisibilityConverter Class
[image]

Converts boolean property values to Visibility values.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class VisibilityConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class VisibilityConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.VisibilityConverter

See Also

VisibilityConverter Members


MindFusion.Diagramming.VisibilityConverter Members

VisibilityConverter Members
Constructors Methods
[image]

Converts boolean property values to Visibility values.

The following tables list the members exposed by the VisibilityConverter type.

Public Constructors

Name | Description
VisibilityConverter |

Public Methods

Name | Description
Convert | Implements IValueConverter.Convert.
ConvertBack | Not implemented.

See Also

VisibilityConverter Class


MindFusion.Diagramming.VisibilityConverter Constructor

VisibilityConverter Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public VisibilityConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

VisibilityConverter Class


MindFusion.Diagramming.VisibilityConverter Methods

VisibilityConverter Methods
[image]

Public Methods

Name | Description
Convert | Implements IValueConverter.Convert.
ConvertBack | Not implemented.

See Also

VisibilityConverter Class


MindFusion.Diagramming.VisibilityConverter.Convert Method

VisibilityConverter.Convert Method
[image]

Implements IValueConverter.Convert.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo l
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
l As CultureInfo _
) As Object

Parameters

value

targetType

parameter

l

Return Value

See Also

VisibilityConverter Members
VisibilityConverter Class


MindFusion.Diagramming.VisibilityConverter.ConvertBack Method

VisibilityConverter.ConvertBack Method
[image]

Not implemented.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo l
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
l As CultureInfo _
) As Object

Parameters

value

targetType

parameter

l

Return Value

See Also

VisibilityConverter Members
VisibilityConverter Class


MindFusion.Diagramming.XmlPersistContext Class

XmlPersistContext Class
[image]

Contains methods that can help you serialize and deserialize Diagram items to end from XML documents.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class XmlPersistContext

Visual Basic [image] Copy Code

Public Class XmlPersistContext

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.XmlPersistContext

See Also

XmlPersistContext Members


MindFusion.Diagramming.XmlPersistContext Members

XmlPersistContext Members
Constructors Fields Properties Methods
[image]

Contains methods that can help you serialize and deserialize Diagram items to end from XML documents.

The following tables list the members exposed by the XmlPersistContext type.

Public Constructors

Name | Description
XmlPersistContext | Overloaded.

Public Fields

Name | Description
LatestFormat | Specifies the latest file format revision number.

Public Properties

Name | Description
ClassVersion | Gets the class version of the currently deserialized item.
Diagram | Gets the underlying diagram object.
FileVersion | Gets the format revision number for the file being currently serialized.
XmlDocument | Gets the underlying XML document.

Public Methods

Name | Description
AddChildElement | Overloaded.
ReadAnchorPattern | Reads an AnchorPattern with the specified name.
ReadBool | Overloaded.
ReadBrush | Reads a Brush object with the specified name.
ReadByte | Reads a byte value with the specified name.
ReadChar | Reads a char value with the specified name.
ReadColor | Reads a color with the specified name.
ReadColorArray | Reads a color array with the specified name.
ReadControl | Loads a Control object.
ReadDecimal | Reads a decimal value with the specified name.
ReadDouble | Overloaded.
ReadDoubleCollection | Loads a DoubleCollection.
ReadEffect | Overloaded.
ReadEnum | Overloaded.
ReadFloat | Overloaded.
ReadFloatArray | Reads a double array with the specified name.
ReadFont | Reads a Font object with the specified name.
ReadFontFamily | Reads a FontFamily object with the specified name.
ReadFontStyle | Reads a FontStyle object with the specified name.
ReadFontUnit | Reads a FontUnit object with the specified name.
ReadHashtable | Reads a hash table object with the specified name.
ReadImage | Reads an Image object with the specified name.
ReadInt | Overloaded.
ReadItemReference | Overloaded.
ReadLong | Reads a long value with the specified name.
ReadNodeConstraints | Reads a NodeConstraints object with the specified name.
ReadObject | Reads an object with the specified name.
ReadPen | Reads a Pen object with the specified name.
ReadPointCollection | Reads a PointCollection object with the specified name.
ReadPointF | Overloaded.
ReadRectangleF | Reads a Rect object with the specified name.
ReadSByte | Reads a 8-bit signed integer value with the specified name.
ReadShape | Overloaded.
ReadShort | Reads a short value with the specified name.
ReadSizeF | Reads a Size object with the specified name.
ReadStream | Reads a stream with the specified name.
ReadString | Overloaded.
ReadStringFormat | Reads a StringFormat object with the specified name.
ReadTag | Reads the specified tag for the specified object.
ReadTheme | Reads a Theme object with the specified name.
ReadUInt | Reads an unsigned integer value with the specified name.
ReadULong | Reads an unsigned long value with the specified name.
ReadUShort | Reads an unsigned short value with the specified name.
WriteAnchorPattern | Writes the specified anchor pattern.
WriteBool | Writes a boolean value with the specified name.
WriteBrush | Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.
WriteByte | Write a byte value with the specified name.
WriteChar | Write a char value with the specified name.
WriteColor | Writes the specified color.
WriteColorArray | Writes the specified array.
WriteControl | Saves a user control hosted.
WriteDecimal | Write a decimal value with the specified name.
WriteDouble | Writes a double value with the specified name.
WriteDoubleCollection | Writes the specified array.
WriteEffect | Writes a reference to the specified effect. The effect is registered within the internal hashtable for subsequent serialization.
WriteEnum | Writes the specified enum value.
WriteFloat | Writes a float value with the specified name.
WriteFloatArray | Writes the specified array.
WriteFont | Writes the specified font.
WriteFontFamily | Writes a FontFamily object with the specified name.
WriteFontStyle | Writes a FontStyle object with the specified name.
WriteGroup | Writes the group of nodes attached to the specified node.
WriteHashtable | Writes the specified hashtable.
WriteImage | Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.
WriteInt | Writes an integer value with the specified name.
WriteItemReference | Writes a reference to the specified item with the specified name.
WriteLong | Writes a long value with the specified name.
WriteNodeConstraints | Writes the specified NodeConstraints object.
WriteObject | Writes the specified object under the specified name.
WritePen | Overloaded.
WritePointCollection | Writes the specified point collection.
WritePointF | Overloaded.
WriteRectangleF | Writes a RectangleF with the specified name.
WriteSByte | Write a 8-bit signed integer value with the specified name.
WriteShape | Writes the specified shape with the specified name.
WriteShort | Writes a short value with the specified name.
WriteSizeF | Writes a Size with the specified name.
WriteStream | Writes the specified stream.
WriteString | Writes a string value with the specified name.
WriteStringFormat | Writes the specified StringFormat object.
WriteTag | Writes the specified tag of the specified object.
WriteTheme | Writes the specified Theme object.
WriteTraits | Used to save item's LayoutTraits.
WriteUInt | Writes an unsigned integer value with the specified name.
WriteULong | Writes an unsigned long value with the specified name.
WriteUShort | Writes an unsigned short value with the specified name.
WriteXaml | Serializes an object to XAML.

See Also

XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext Fields

XmlPersistContext Fields
[image]

Public Fields

Name | Description
LatestFormat | Specifies the latest file format revision number.

See Also

XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.LatestFormat Field

XmlPersistContext.LatestFormat Field
[image]

Specifies the latest file format revision number.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static int LatestFormat

Visual Basic [image] Copy Code

Public Shared LatestFormat As Integer

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext Constructor

XmlPersistContext Constructor
[image]

Overload List

Name | Description
XmlPersistContext (Diagram, XDocument) | Initializes a new instance of the XmlPersistContext class.
XmlPersistContext (Diagram, XDocument, Int32) | Initializes a new instance of the XmlPersistContext class.

See Also

XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext Constructor (Diagram, XDocument)

XmlPersistContext Constructor (Diagram, XDocument)
See Also
[image]

Initializes a new instance of the XmlPersistContext class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlPersistContext (
Diagram diagram,
XDocument document
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram, _
document As XDocument _
)

Parameters

diagram
The Diagram this class will operate on.
document
The System.Xml.Linq.XDocument object to serialize/deserialize to/from.

See Also

XmlPersistContext Constructor Overload List
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext Constructor (Diagram, XDocument, Int32)

XmlPersistContext Constructor (Diagram, XDocument, Int32)
See Also
[image]

Initializes a new instance of the XmlPersistContext class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlPersistContext (
Diagram diagram,
XDocument document,
int fileVersion
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram, _
document As XDocument, _
fileVersion As Integer _
)

Parameters

diagram

The Diagram this class will operate on.

document

The .NET XmlDocument to serialize/deserialize to/from.

fileVersion

Specifies the current file format number.

See Also

XmlPersistContext Constructor Overload List
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext Methods

XmlPersistContext Methods
[image]

Public Methods

Name | Description
AddChildElement | Overloaded.
ReadAnchorPattern | Reads an AnchorPattern with the specified name.
ReadBool | Overloaded.
ReadBrush | Reads a Brush object with the specified name.
ReadByte | Reads a byte value with the specified name.
ReadChar | Reads a char value with the specified name.
ReadColor | Reads a color with the specified name.
ReadColorArray | Reads a color array with the specified name.
ReadControl | Loads a Control object.
ReadDecimal | Reads a decimal value with the specified name.
ReadDouble | Overloaded.
ReadDoubleCollection | Loads a DoubleCollection.
ReadEffect | Overloaded.
ReadEnum | Overloaded.
ReadFloat | Overloaded.
ReadFloatArray | Reads a double array with the specified name.
ReadFont | Reads a Font object with the specified name.
ReadFontFamily | Reads a FontFamily object with the specified name.
ReadFontStyle | Reads a FontStyle object with the specified name.
ReadFontUnit | Reads a FontUnit object with the specified name.
ReadHashtable | Reads a hash table object with the specified name.
ReadImage | Reads an Image object with the specified name.
ReadInt | Overloaded.
ReadItemReference | Overloaded.
ReadLong | Reads a long value with the specified name.
ReadNodeConstraints | Reads a NodeConstraints object with the specified name.
ReadObject | Reads an object with the specified name.
ReadPen | Reads a Pen object with the specified name.
ReadPointCollection | Reads a PointCollection object with the specified name.
ReadPointF | Overloaded.
ReadRectangleF | Reads a Rect object with the specified name.
ReadSByte | Reads a 8-bit signed integer value with the specified name.
ReadShape | Overloaded.
ReadShort | Reads a short value with the specified name.
ReadSizeF | Reads a Size object with the specified name.
ReadStream | Reads a stream with the specified name.
ReadString | Overloaded.
ReadStringFormat | Reads a StringFormat object with the specified name.
ReadTag | Reads the specified tag for the specified object.
ReadTheme | Reads a Theme object with the specified name.
ReadUInt | Reads an unsigned integer value with the specified name.
ReadULong | Reads an unsigned long value with the specified name.
ReadUShort | Reads an unsigned short value with the specified name.
WriteAnchorPattern | Writes the specified anchor pattern.
WriteBool | Writes a boolean value with the specified name.
WriteBrush | Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.
WriteByte | Write a byte value with the specified name.
WriteChar | Write a char value with the specified name.
WriteColor | Writes the specified color.
WriteColorArray | Writes the specified array.
WriteControl | Saves a user control hosted.
WriteDecimal | Write a decimal value with the specified name.
WriteDouble | Writes a double value with the specified name.
WriteDoubleCollection | Writes the specified array.
WriteEffect | Writes a reference to the specified effect. The effect is registered within the internal hashtable for subsequent serialization.
WriteEnum | Writes the specified enum value.
WriteFloat | Writes a float value with the specified name.
WriteFloatArray | Writes the specified array.
WriteFont | Writes the specified font.
WriteFontFamily | Writes a FontFamily object with the specified name.
WriteFontStyle | Writes a FontStyle object with the specified name.
WriteGroup | Writes the group of nodes attached to the specified node.
WriteHashtable | Writes the specified hashtable.
WriteImage | Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.
WriteInt | Writes an integer value with the specified name.
WriteItemReference | Writes a reference to the specified item with the specified name.
WriteLong | Writes a long value with the specified name.
WriteNodeConstraints | Writes the specified NodeConstraints object.
WriteObject | Writes the specified object under the specified name.
WritePen | Overloaded.
WritePointCollection | Writes the specified point collection.
WritePointF | Overloaded.
WriteRectangleF | Writes a RectangleF with the specified name.
WriteSByte | Write a 8-bit signed integer value with the specified name.
WriteShape | Writes the specified shape with the specified name.
WriteShort | Writes a short value with the specified name.
WriteSizeF | Writes a Size with the specified name.
WriteStream | Writes the specified stream.
WriteString | Writes a string value with the specified name.
WriteStringFormat | Writes the specified StringFormat object.
WriteTag | Writes the specified tag of the specified object.
WriteTheme | Writes the specified Theme object.
WriteTraits | Used to save item's LayoutTraits.
WriteUInt | Writes an unsigned integer value with the specified name.
WriteULong | Writes an unsigned long value with the specified name.
WriteUShort | Writes an unsigned short value with the specified name.
WriteXaml | Serializes an object to XAML.

See Also

XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.AddChildElement Method

XmlPersistContext.AddChildElement Method
[image]

Overload List

Name | Description
XmlPersistContext.AddChildElement (String, XElement) | Adds a new child node with the specified name to the specified parent node.
XmlPersistContext.AddChildElement (String, XElement, String) | Adds a new child node with the specified name and value to the specified parent node.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.AddChildElement Method (String, XElement)

XmlPersistContext.AddChildElement Method (String, XElement)
See Also
[image]

Adds a new child node with the specified name to the specified parent node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement AddChildElement (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function AddChildElement( _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

elementName

The name of the new child node to be added to the parent node.

parentElement

The parent node that the child node will be added to.

Return Value

A System.Xml.Linq.XDocument object.

See Also

AddChildElement Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.AddChildElement Method (String, XElement, String)

XmlPersistContext.AddChildElement Method (String, XElement, String)
See Also
[image]

Adds a new child node with the specified name and value to the specified parent node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement AddChildElement (
string elementName,
XElement parentElement,
string innerText
)

Visual Basic [image] Copy Code

Public Function AddChildElement( _
elementName As String, _
parentElement As XElement, _
innerText As String _
) As XElement

Parameters

elementName

The desired name of the new node.

parentElement

The parent element of the newly created node.

innerText

The desired value of the new node.

Return Value

See Also

AddChildElement Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadAnchorPattern Method

XmlPersistContext.ReadAnchorPattern Method
[image]

Reads an AnchorPattern with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern ReadAnchorPattern (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadAnchorPattern ( _
elementName As String, _
parentElement As XElement _
) As AnchorPattern

Parameters

elementName

The name of the element containing the AnchorPattern object.

parentElement

The parent element of the node with the specified name.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadBool Method

XmlPersistContext.ReadBool Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadBool (String, XElement) | Reads a boolean value with the specified name.
XmlPersistContext.ReadBool (String, XElement, Boolean) | Reads a boolean value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadBool Method (String, XElement)

XmlPersistContext.ReadBool Method (String, XElement)
See Also
[image]

Reads a boolean value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ReadBool (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadBool( _
elementName As String, _
parentElement As XElement _
) As Boolean

Parameters

elementName

The name of the element containing the bool value.

parentElement

The parent element of the node with the specified name.

Return Value

See Also

ReadBool Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadBool Method (String, XElement, Boolean)

XmlPersistContext.ReadBool Method (String, XElement, Boolean)
See Also
[image]

Reads a boolean value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ReadBool (
string elementName,
XElement parentElement,
bool defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadBool( _
elementName As String, _
parentElement As XElement, _
defaultValue As Boolean _
) As Boolean

Parameters

elementName

The name of the element containing the bool value.

parentElement

The parent element of the node with the specified name.

defaultValue

The value to return if the specified element is not found.

Return Value

See Also

ReadBool Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadBrush Method

XmlPersistContext.ReadBrush Method
[image]

Reads a Brush object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush ReadBrush (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadBrush( _
elementName As String, _
parentElement As XElement _
) As Brush

Parameters

elementName
The name of the element containing the Brush object.
parentElement

The parent element of the node with the specified name.

Return Value

An instance of the Windows.UI.Xaml.Media.Brush class.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadByte Method

XmlPersistContext.ReadByte Method
[image]

Reads a byte value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public byte ReadByte (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadByte( _
elementName As String, _
parentElement As XElement _
) As Byte

Parameters

elementName

The name of the element containing the byte value.

parentElement

The parent element of the node with the specified name.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadChar Method

XmlPersistContext.ReadChar Method
[image]

Reads a char value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public char ReadChar (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadChar( _
elementName As String, _
parentElement As XElement _
) As Char

Parameters

elementName

The name of the element containing the char value.

parentElement

The parent element of the node with the specified name.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadColor Method

XmlPersistContext.ReadColor Method
[image]

Reads a color with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color ReadColor (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadColor( _
elementName As String, _
parentElement As XElement _
) As Color

Parameters

elementName
The name of the element containing the WinRT Color object.
parentElement

The parent element of the node with the specified name.

Return Value

An instance of the Windows.UI.Xaml.Media.Color structure. Returns Black if there is no element with the specified name under the specified parent.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadColorArray Method

XmlPersistContext.ReadColorArray Method
[image]

Reads a color array with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color[] ReadColorArray (
string elementName,
string subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadColorArray( _
elementName As String, _
subElementName As String, _
parentElement As XElement _
) As Color()

Parameters

elementName

The name of the element containing the array.

subElementName

The name of the elements containing the individual array values.

parentElement

The parent element of the node with the specified name.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadControl Method

XmlPersistContext.ReadControl Method
[image]

Loads a Control object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FrameworkElement ReadControl (
ControlNode node,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadControl( _
node As ControlNode, _
elementName As String, _
parentElement As XElement _
) As FrameworkElement

Parameters

node

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadDecimal Method

XmlPersistContext.ReadDecimal Method
[image]

Reads a decimal value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public decimal ReadDecimal (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDecimal( _
elementName As String, _
parentElement As XElement _
) As Decimal

Parameters

elementName

The name of the element containing the decimal value.

parentElement

The parent element of the node with the specified name.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadDouble Method

XmlPersistContext.ReadDouble Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadDouble (String, XElement) | Reads a double value with the specified name.
XmlPersistContext.ReadDouble (String, XElement, Double) | Reads a double value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadDouble Method (String, XElement)

XmlPersistContext.ReadDouble Method (String, XElement)
See Also
[image]

Reads a double value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ReadDouble (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDouble( _
elementName As String, _
parentElement As XElement _
) As Double

Parameters

elementName

The name of the element containing the double value.

parentElement

The parent element of the node with the specified name.

Return Value

See Also

ReadDouble Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadDouble Method (String, XElement, Double)

XmlPersistContext.ReadDouble Method (String, XElement, Double)
See Also
[image]

Reads a double value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ReadDouble (
string elementName,
XElement parentElement,
double defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadDouble( _
elementName As String, _
parentElement As XElement, _
defaultValue As Double _
) As Double

Parameters

elementName

The name of the element containing the double value.

parentElement

The parent element of the node with the specified name.

defaultValue

The value to be returned if the element is not found.

Return Value

See Also

ReadDouble Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadDoubleCollection Method

XmlPersistContext.ReadDoubleCollection Method
[image]

Loads a DoubleCollection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DoubleCollection ReadDoubleCollection (
string elementName,
string subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDoubleCollection( _
elementName As String, _
subElementName As String, _
parentElement As XElement _
) As DoubleCollection

Parameters

elementName

subElementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadEffect Method

XmlPersistContext.ReadEffect Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadEffect (String, XElement) | Reads a NodeEffect object with the specified name.
XmlPersistContext.ReadEffect (XElement) | Reads a NodeEffect object from the specified element.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadEffect Method (String, XElement)

XmlPersistContext.ReadEffect Method (String, XElement)
See Also
[image]

Reads a NodeEffect object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeEffect ReadEffect (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadEffect( _
elementName As String, _
parentElement As XElement _
) As NodeEffect

Parameters

elementName

parentElement

Return Value

See Also

ReadEffect Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadEffect Method (XElement)

XmlPersistContext.ReadEffect Method (XElement)
See Also
[image]

Reads a NodeEffect object from the specified element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeEffect ReadEffect (
XElement element
)

Visual Basic [image] Copy Code

Public Function ReadEffect( _
element As XElement _
) As NodeEffect

Parameters

element

Return Value

See Also

ReadEffect Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadEnum Method

XmlPersistContext.ReadEnum Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadEnum (String, XElement) | Reads an enum value with the specified name.
XmlPersistContext.ReadEnum (String, XElement, Object) | Reads an enum value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadEnum Method (String, XElement)

XmlPersistContext.ReadEnum Method (String, XElement)
See Also
[image]

Reads an enum value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object ReadEnum (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadEnum( _
elementName As String, _
parentElement As XElement _
) As Object

Parameters

elementName

The name of the element containing the enum value.

parentElement

The parent element of the node with the specified name.

Return Value

See Also

ReadEnum Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadEnum Method (String, XElement, Object)

XmlPersistContext.ReadEnum Method (String, XElement, Object)
See Also
[image]

Reads an enum value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object ReadEnum (
string elementName,
XElement parentElement,
Object defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadEnum( _
elementName As String, _
parentElement As XElement, _
defaultValue As Object _
) As Object

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadEnum Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadFloat Method

XmlPersistContext.ReadFloat Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadFloat (String, XElement) | Reads a double value with the specified name.
XmlPersistContext.ReadFloat (String, XElement, Single) | Reads a double value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadFloat Method (String, XElement)

XmlPersistContext.ReadFloat Method (String, XElement)
See Also
[image]

Reads a double value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ReadFloat (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFloat( _
elementName As String, _
parentElement As XElement _
) As Double

Parameters

elementName

The name of the element containing the float value.

parentElement

The parent element of the node with the specified name.

Return Value

See Also

ReadFloat Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadFloat Method (String, XElement, Single)

XmlPersistContext.ReadFloat Method (String, XElement, Single)
See Also
[image]

Reads a double value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ReadFloat (
string elementName,
XElement parentElement,
float defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadFloat( _
elementName As String, _
parentElement As XElement, _
defaultValue As Single _
) As Double

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadFloat Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadFloatArray Method

XmlPersistContext.ReadFloatArray Method
[image]

Reads a double array with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double[] ReadFloatArray (
string elementName,
string subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFloatArray( _
elementName As String, _
subElementName As String, _
parentElement As XElement _
) As Double()

Parameters

elementName

The name of the element containing the array.

subElementName

The name of the elements containing the individual array values.

parentElement

The parent element of the node with the specified name.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadFont Method

XmlPersistContext.ReadFont Method
[image]

Reads a Font object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ReadFont (
string elementName,
XElement parentElement,
Control dest
)

Visual Basic [image] Copy Code

Public Sub ReadFont( _
elementName As String, _
parentElement As XElement, _
dest As Control _
)

Parameters

elementName

parentElement

dest

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadFontFamily Method

XmlPersistContext.ReadFontFamily Method
[image]

Reads a FontFamily object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FontFamily ReadFontFamily (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFontFamily( _
elementName As String, _
parentElement As XElement _
) As FontFamily

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadFontStyle Method

XmlPersistContext.ReadFontStyle Method
[image]

Reads a FontStyle object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object ReadFontStyle (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFontStyle( _
elementName As String, _
parentElement As XElement _
) As Object

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadFontUnit Method

XmlPersistContext.ReadFontUnit Method
[image]

Reads a FontUnit object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GraphicsUnit ReadFontUnit (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFontUnit( _
elementName As String, _
parentElement As XElement _
) As GraphicsUnit

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadHashtable Method

XmlPersistContext.ReadHashtable Method
[image]

Reads a hash table object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Dictionary<Object, Object> ReadHashtable (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadHashtable( _
elementName As String, _
parentElement As XElement _
) As Dictionary(Of Object, Object)

Parameters

elementName
The name of the element containing the System.Collections.Generic.Dictionary Hashtable object.
parentElement

The parent element of the node with the specified name.

Return Value

A System.Collections.Generic.Dictionary object. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadImage Method

XmlPersistContext.ReadImage Method
[image]

Reads an Image object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ImageSource ReadImage (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadImage( _
elementName As String, _
parentElement As XElement _
) As ImageSource

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadInt Method

XmlPersistContext.ReadInt Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadInt (String, XElement) | Reads an integer value with the specified name.
XmlPersistContext.ReadInt (String, XElement, Int32) | Reads an integer value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadInt Method (String, XElement)

XmlPersistContext.ReadInt Method (String, XElement)
See Also
[image]

Reads an integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ReadInt (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadInt( _
elementName As String, _
parentElement As XElement _
) As Integer

Parameters

elementName

The name of the element containing the integer value.

parentElement

The parent element of the node with the specified name.

Return Value

See Also

ReadInt Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadInt Method (String, XElement, Int32)

XmlPersistContext.ReadInt Method (String, XElement, Int32)
See Also
[image]

Reads an integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ReadInt (
string elementName,
XElement parentElement,
int defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadInt( _
elementName As String, _
parentElement As XElement, _
defaultValue As Integer _
) As Integer

Parameters

elementName

The name of the element containing the integer value.

parentElement

The parent element of the node with the specified name.

defaultValue

The value returned if the specified element is not found.

Return Value

See Also

ReadInt Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadItemReference Method

XmlPersistContext.ReadItemReference Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadItemReference (String, XElement) | Reads a reference to the item with the specified name.
XmlPersistContext.ReadItemReference (XElement) | Reads an item reference from the specified element.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadItemReference Method (String, XElement)

XmlPersistContext.ReadItemReference Method (String, XElement)
See Also
[image]

Reads a reference to the item with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem ReadItemReference (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadItemReference( _
elementName As String, _
parentElement As XElement _
) As DiagramItem

Parameters

elementName

The name of the element containing the Shape object.

parentElement

The parent element of the node with the specified name.

Return Value

See Also

ReadItemReference Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadItemReference Method (XElement)

XmlPersistContext.ReadItemReference Method (XElement)
See Also
[image]

Reads an item reference from the specified element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem ReadItemReference (
XElement itemElement
)

Visual Basic [image] Copy Code

Public Function ReadItemReference( _
itemElement As XElement _
) As DiagramItem

Parameters

itemElement

Return Value

See Also

ReadItemReference Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadLong Method

XmlPersistContext.ReadLong Method
[image]

Reads a long value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public long ReadLong (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadLong( _
elementName As String, _
parentElement As XElement _
) As Long

Parameters

elementName

The name of the element containing the long value.

parentElement

The parent element of the node with the specified name.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadNodeConstraints Method

XmlPersistContext.ReadNodeConstraints Method
[image]

Reads a NodeConstraints object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeConstraints ReadNodeConstraints (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadNodeConstraints( _
elementName As String, _
parentElement As XElement _
) As NodeConstraints

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadObject Method

XmlPersistContext.ReadObject Method
[image]

Reads an object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object ReadObject (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadObject( _
elementName As String, _
parentElement As XElement _
) As Object

Parameters

elementName

The name of the element containing the object.

parentElement

The parent element of the node with the specified name.

Return Value

Remarks

An object. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent or if the object cannot be deserialized.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadPen Method

XmlPersistContext.ReadPen Method
[image]

Reads a Pen object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen ReadPen (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadPen( _
elementName As String, _
parentElement As XElement _
) As Pen

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadPointCollection Method

XmlPersistContext.ReadPointCollection Method
[image]

Reads a PointCollection object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<Point> ReadPointCollection (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadPointCollection( _
elementName As String, _
parentElement As XElement _
) As List(Of Point)

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadPointF Method

XmlPersistContext.ReadPointF Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadPointF (String, XElement) | Reads a Point object with the specified name.
XmlPersistContext.ReadPointF (XElement) | Reads a Point object from the specified element.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadPointF Method (String, XElement)

XmlPersistContext.ReadPointF Method (String, XElement)
See Also
[image]

Reads a Point object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point ReadPointF (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadPointF( _
elementName As String, _
parentElement As XElement _
) As Point

Parameters

elementName
The name of the element containing the WinRT Windows.UI.Xaml Point object .
parentElement

The parent element of the node with the specified name.

Return Value

See Also

ReadPointF Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadPointF Method (XElement)

XmlPersistContext.ReadPointF Method (XElement)
See Also
[image]

Reads a Point object from the specified element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point ReadPointF (
XElement element
)

Visual Basic [image] Copy Code

Public Function ReadPointF( _
element As XElement _
) As Point

Parameters

element

Return Value

See Also

ReadPointF Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadRectangleF Method

XmlPersistContext.ReadRectangleF Method
[image]

Reads a Rect object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect ReadRectangleF (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadRectangleF( _
elementName As String, _
parentElement As XElement _
) As Rect

Parameters

elementName

The name of the element containing the RectangleF object.

parentElement

The parent element of the node with the specified name.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadSByte Method

XmlPersistContext.ReadSByte Method
[image]

Reads a 8-bit signed integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sbyte ReadSByte (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadSByte( _
elementName As String, _
parentElement As XElement _
) As SByte

Parameters

elementName

The name of the element containing the signed byte value.

parentElement

The parent element of the node with the specified name.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadShape Method

XmlPersistContext.ReadShape Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadShape (String, XElement) | Reads a Shape object with the specified name.
XmlPersistContext.ReadShape (String, XElement, Shape) | Reads a Shape object with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadShape Method (String, XElement)

XmlPersistContext.ReadShape Method (String, XElement)
See Also
[image]

Reads a Shape object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape ReadShape (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadShape( _
elementName As String, _
parentElement As XElement _
) As Shape

Parameters

elementName

parentElement

Return Value

See Also

ReadShape Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadShape Method (String, XElement, Shape)

XmlPersistContext.ReadShape Method (String, XElement, Shape)
See Also
[image]

Reads a Shape object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape ReadShape (
string elementName,
XElement parentElement,
Shape defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadShape( _
elementName As String, _
parentElement As XElement, _
defaultValue As Shape _
) As Shape

Parameters

elementName

The name of the element containing the Shape object.

parentElement

The parent element of the node with the specified name.

defaultValue

The value to return if the XML element does not exist.

Return Value

See Also

ReadShape Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadShort Method

XmlPersistContext.ReadShort Method
[image]

Reads a short value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public short ReadShort (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadShort( _
elementName As String, _
parentElement As XElement _
) As Short

Parameters

elementName

The name of the element containing the short value.

parentElement

The name of the element containing the short value.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadSizeF Method

XmlPersistContext.ReadSizeF Method
[image]

Reads a Size object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Size ReadSizeF (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadSizeF( _
elementName As String, _
parentElement As XElement _
) As Size

Parameters

elementName
The name of the element containing the Windows.UI.Xaml.Size object.
parentElement

The parent element of the node with the specified name.

Return Value

A Windows.UI.Xaml.Size object. Returns Size.Empty if there is no element with the specified name under the specified parent.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadStream Method

XmlPersistContext.ReadStream Method
[image]

Reads a stream with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Stream ReadStream (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadStream( _
elementName As String, _
parentElement As XElement _
) As Stream

Parameters

elementName

The name of the element containing the .NET Stream object.

parentElement

The parent element of the node with the specified name.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadString Method

XmlPersistContext.ReadString Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadString (String, XElement) | Reads a string value with the specified name.
XmlPersistContext.ReadString (String, XElement, String) | Reads a string value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadString Method (String, XElement)

XmlPersistContext.ReadString Method (String, XElement)
See Also
[image]

Reads a string value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ReadString (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadString( _
elementName As String, _
parentElement As XElement _
) As String

Parameters

elementName

The name of the element containing the string value.

parentElement

The parent element of the node with the specified name.

Return Value

A string value. Returns an empty string if there is no element with the specified name under the specified parent.

See Also

ReadString Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadString Method (String, XElement, String)

XmlPersistContext.ReadString Method (String, XElement, String)
See Also
[image]

Reads a string value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ReadString (
string elementName,
XElement parentElement,
string defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadString( _
elementName As String, _
parentElement As XElement, _
defaultValue As String _
) As String

Parameters

elementName

The name of the element containing the string value.

parentElement

The parent element of the node with the specified name.

defaultValue

The value to return if the specified element is not found.

Return Value

A string value. Returns an empty string if there is no element with the specified name under the specified parent and defaultValue.

See Also

ReadString Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadStringFormat Method

XmlPersistContext.ReadStringFormat Method
[image]

Reads a StringFormat object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringFormat ReadStringFormat (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadStringFormat( _
elementName As String, _
parentElement As XElement _
) As StringFormat

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadTag Method

XmlPersistContext.ReadTag Method
[image]

Reads the specified tag for the specified object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object ReadTag (
Object item,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadTag( _
item As Object, _
elementName As String, _
parentElement As XElement _
) As Object

Parameters

item

The Item whose tag is being deserialized.

elementName

The name of the element containing the tag object.

parentElement

The parent element of the node with the specified name.

Return Value

Remarks

Tags are read similarly to arbitrary objects except that the client of the diagram is given a chance to perform custom deserialization through event handling.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadTheme Method

XmlPersistContext.ReadTheme Method
[image]

Reads a Theme object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Theme ReadTheme (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadTheme( _
elementName As String, _
parentElement As XElement _
) As Theme

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadUInt Method

XmlPersistContext.ReadUInt Method
[image]

Reads an unsigned integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public uint ReadUInt (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadUInt( _
elementName As String, _
parentElement As XElement _
) As UInteger

Parameters

elementName

The name of the element containing the unsigned integer value.

parentElement

The parent element of the node with the specified name.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadULong Method

XmlPersistContext.ReadULong Method
[image]

Reads an unsigned long value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ulong ReadULong (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadULong( _
elementName As String, _
parentElement As XElement _
) As ULong

Parameters

elementName

The name of the element containing the unsigned long value.

parentElement

The parent element of the node with the specified name.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadUShort Method

XmlPersistContext.ReadUShort Method
[image]

Reads an unsigned short value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ushort ReadUShort (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadUShort( _
elementName As String, _
parentElement As XElement _
) As UShort

Parameters

elementName

The name of the element containing the unsigned short value.

parentElement

The name of the element containing the unsigned short value.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteAnchorPattern Method

XmlPersistContext.WriteAnchorPattern Method
[image]

Writes the specified anchor pattern.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteAnchorPattern (
AnchorPattern anchorPattern,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteAnchorPattern( _
anchorPattern As AnchorPattern, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

anchorPattern

The AnchorPattern instance to be written.

elementName

The name of the element under which the object should be written.

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteBool Method

XmlPersistContext.WriteBool Method
[image]

Writes a boolean value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteBool (
bool boolValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteBool( _
boolValue As Boolean, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

boolValue

The bool value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteBrush Method

XmlPersistContext.WriteBrush Method
[image]

Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteBrush (
Brush brush,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteBrush( _
brush As Brush, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

brush
The Brush to which a reference is written.
elementName

The name of the element under which the object should be written.

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteByte Method

XmlPersistContext.WriteByte Method
[image]

Write a byte value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteByte (
byte byteValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteByte( _
byteValue As Byte, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

byteValue

The byte value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteChar Method

XmlPersistContext.WriteChar Method
[image]

Write a char value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteChar (
char charValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteChar( _
charValue As Char, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

charValue

The char value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteColor Method

XmlPersistContext.WriteColor Method
[image]

Writes the specified color.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteColor (
Color color,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteColor( _
color As Color, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

color
The Windows.UI.Xaml.Media.Color object to write.
elementName

The name of the element under which the object should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the System.Xml.Linq.XElement class representing the newly created XML element.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteColorArray Method

XmlPersistContext.WriteColorArray Method
[image]

Writes the specified array.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteColorArray (
Color[] array,
string elementName,
string subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteColorArray( _
array() As Color, _
elementName As String, _
subElementName As String, _
parentElement As XElement _
) As XElement

Parameters

array

The Color array to write.

elementName

The name of the element under which the array should be written.

subElementName

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteControl Method

XmlPersistContext.WriteControl Method
[image]

Saves a user control hosted.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteControl (
Object item,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteControl( _
item As Object, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

item

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteDecimal Method

XmlPersistContext.WriteDecimal Method
[image]

Write a decimal value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteDecimal (
decimal decimalValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDecimal( _
decimalValue As Decimal, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

decimalValue

The decimal value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteDouble Method

XmlPersistContext.WriteDouble Method
[image]

Writes a double value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteDouble (
double doubleValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDouble( _
doubleValue As Double, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

doubleValue

The double value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteDoubleCollection Method

XmlPersistContext.WriteDoubleCollection Method
[image]

Writes the specified array.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteDoubleCollection (
DoubleCollection collection,
string elementName,
string subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDoubleCollection( _
collection As DoubleCollection, _
elementName As String, _
subElementName As String, _
parentElement As XElement _
) As XElement

Parameters

collection

The collection to write.

elementName

The name of the element under which the collection should be written.

subElementName

The name of the XML elements under which the individual collection values will be written.

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteEffect Method

XmlPersistContext.WriteEffect Method
[image]

Writes a reference to the specified effect. The effect is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteEffect (
NodeEffect effect,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteEffect( _
effect As NodeEffect, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

effect

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteEnum Method

XmlPersistContext.WriteEnum Method
[image]

Writes the specified enum value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteEnum (
Object enumValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteEnum( _
enumValue As Object, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

enumValue

The enum value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteFloat Method

XmlPersistContext.WriteFloat Method
[image]

Writes a float value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteFloat (
double floatValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFloat( _
floatValue As Double, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

floatValue

The float value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteFloatArray Method

XmlPersistContext.WriteFloatArray Method
[image]

Writes the specified array.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteFloatArray (
double[] array,
string elementName,
string subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFloatArray( _
array() As Double, _
elementName As String, _
subElementName As String, _
parentElement As XElement _
) As XElement

Parameters

array

The array to write.

elementName

The name of the element under which the array should be written.

subElementName

The name of the XML elements under which the individual array values will be written.

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteFont Method

XmlPersistContext.WriteFont Method
[image]

Writes the specified font.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteFont (
Control control,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFont( _
control As Control, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

control

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteFontFamily Method

XmlPersistContext.WriteFontFamily Method
[image]

Writes a FontFamily object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteFontFamily (
FontFamily fontFamily,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFontFamily( _
fontFamily As FontFamily, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

fontFamily

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteFontStyle Method

XmlPersistContext.WriteFontStyle Method
[image]

Writes a FontStyle object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteFontStyle (
Object fontValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFontStyle( _
fontValue As Object, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

fontValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteGroup Method

XmlPersistContext.WriteGroup Method
[image]

Writes the group of nodes attached to the specified node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteGroup (
DiagramNode group,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteGroup( _
group As DiagramNode, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

group

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteHashtable Method

XmlPersistContext.WriteHashtable Method
[image]

Writes the specified hashtable.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteHashtable (
Dictionary<Object, Object> hashtable,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteHashtable( _
hashtable As Dictionary(Of Object, Object), _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

hashtable

The hashtable to write.

elementName

The name of the element under which the hashtable is written.

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteImage Method

XmlPersistContext.WriteImage Method
[image]

Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteImage (
ImageSource image,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteImage( _
image As ImageSource, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

image

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteInt Method

XmlPersistContext.WriteInt Method
[image]

Writes an integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteInt (
int intValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteInt( _
intValue As Integer, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

intValue

The integer value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteItemReference Method

XmlPersistContext.WriteItemReference Method
[image]

Writes a reference to the specified item with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteItemReference (
DiagramItem item,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteItemReference( _
item As DiagramItem, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

item

The DiagramItem to which a reference is written.

elementName

The name of the element under which the object should be written.

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteLong Method

XmlPersistContext.WriteLong Method
[image]

Writes a long value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteLong (
long longValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteLong( _
longValue As Long, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

longValue

The long value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteNodeConstraints Method

XmlPersistContext.WriteNodeConstraints Method
[image]

Writes the specified NodeConstraints object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteNodeConstraints (
NodeConstraints nodeConstraints,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteNodeConstraints( _
nodeConstraints As NodeConstraints, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

nodeConstraints

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteObject Method

XmlPersistContext.WriteObject Method
[image]

Writes the specified object under the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteObject (
Object objectValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteObject( _
objectValue As Object, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

objectValue

The object to write.

elementName

The name of the element under which the object is written.

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WritePen Method

XmlPersistContext.WritePen Method
[image]

Overload List

Name | Description
XmlPersistContext.WritePen (Pen, String, XElement) | Writes the specified pen.
XmlPersistContext.WritePen (Pen, String, XElement, Boolean) | Writes the specified pen.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WritePen Method (Pen, String, XElement)

XmlPersistContext.WritePen Method (Pen, String, XElement)
See Also
[image]

Writes the specified pen.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WritePen (
Pen pen,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePen( _
pen As Pen, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

pen

elementName

parentElement

Return Value

See Also

WritePen Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WritePen Method (Pen, String, XElement, Boolean)

XmlPersistContext.WritePen Method (Pen, String, XElement, Boolean)
See Also
[image]

Writes the specified pen.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WritePen (
Pen pen,
string elementName,
XElement parentElement,
bool withBrushContent
)

Visual Basic [image] Copy Code

Public Function WritePen( _
pen As Pen, _
elementName As String, _
parentElement As XElement, _
withBrushContent As Boolean _
) As XElement

Parameters

pen

elementName

parentElement

withBrushContent

Return Value

See Also

WritePen Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WritePointCollection Method

XmlPersistContext.WritePointCollection Method
[image]

Writes the specified point collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WritePointCollection (
List<Point> points,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePointCollection( _
points As List(Of Point), _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

points

The List of points that is written.

elementName

The name of the element under which the object should be written.

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WritePointF Method

XmlPersistContext.WritePointF Method
[image]

Overload List

Name | Description
XmlPersistContext.WritePointF (Double, Double, String, XElement) | Writes the specified PointF under the specified name. The x and y components of the point are written as attributes.
XmlPersistContext.WritePointF (Point, String, XElement) | Writes a Point with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WritePointF Method (Double, Double, String, XElement)

XmlPersistContext.WritePointF Method (Double, Double, String, XElement)
See Also
[image]

Writes the specified PointF under the specified name. The x and y components of the point are written as attributes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WritePointF (
double x,
double y,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePointF( _
x As Double, _
y As Double, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

x

y

elementName

parentElement

Return Value

See Also

WritePointF Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WritePointF Method (Point, String, XElement)

XmlPersistContext.WritePointF Method (Point, String, XElement)
See Also
[image]

Writes a Point with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WritePointF (
Point point,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePointF( _
point As Point, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

point
The WinRT Windows.UI.Xaml Point object to write.
elementName

The name of the element under which the object should be written.

parentElement

The parent element of the newly created node.

Return Value

See Also

WritePointF Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteRectangleF Method

XmlPersistContext.WriteRectangleF Method
[image]

Writes a RectangleF with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteRectangleF (
Rect rectangle,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteRectangleF( _
rectangle As Rect, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

rectangle
The Windows.UI.Xaml.Rect object to write.
elementName

The name of the element under which the object should be written.

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteSByte Method

XmlPersistContext.WriteSByte Method
[image]

Write a 8-bit signed integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteSByte (
sbyte byteValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteSByte( _
byteValue As SByte, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

byteValue

The signed byte value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteShape Method

XmlPersistContext.WriteShape Method
[image]

Writes the specified shape with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteShape (
Shape shape,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteShape( _
shape As Shape, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

shape

The Shape that is written.

elementName

The name of the element under which the object should be written.

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteShort Method

XmlPersistContext.WriteShort Method
[image]

Writes a short value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteShort (
short shortValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteShort( _
shortValue As Short, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

shortValue

The short value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteSizeF Method

XmlPersistContext.WriteSizeF Method
[image]

Writes a Size with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteSizeF (
Size size,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteSizeF( _
size As Size, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

size
The Windows.UI.Xaml.Size object to write.
elementName

The name of the element under which the object should be written.

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteStream Method

XmlPersistContext.WriteStream Method
[image]

Writes the specified stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteStream (
Stream stream,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteStream( _
stream As Stream, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

stream
The System.IO.Stream object to write.
elementName

The name of the element under which the object should be written.

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteString Method

XmlPersistContext.WriteString Method
[image]

Writes a string value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteString (
string stringValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteString( _
stringValue As String, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

stringValue

The string value to write.

elementName

The name of the element that will be written.

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteStringFormat Method

XmlPersistContext.WriteStringFormat Method
[image]

Writes the specified StringFormat object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteStringFormat (
StringFormat stringFormat,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteStringFormat( _
stringFormat As StringFormat, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

stringFormat

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteTag Method

XmlPersistContext.WriteTag Method
[image]

Writes the specified tag of the specified object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteTag (
Object item,
Object tagValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteTag( _
item As Object, _
tagValue As Object, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

item

A reference to the item or resource whose tag is being written.

tagValue

The tag object to write.

elementName

The name of the element under which the object should be written.

parentElement

The parent element of the newly created node.

Return Value

Remarks

Tags are written similarly to arbitrary objects except that the client of the diagram is given a chance to perform custom serialization through event handling.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteTheme Method

XmlPersistContext.WriteTheme Method
[image]

Writes the specified Theme object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteTheme (
Theme theme,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteTheme( _
theme As Theme, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

theme

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteTraits Method

XmlPersistContext.WriteTraits Method
[image]

Used to save item's LayoutTraits.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteTraits (
Dictionary<Object, Object> traits,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteTraits( _
traits As Dictionary(Of Object, Object), _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

traits

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteUInt Method

XmlPersistContext.WriteUInt Method
[image]

Writes an unsigned integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteUInt (
uint uintValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteUInt( _
uintValue As UInteger, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

uintValue

The unsigned integer value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteULong Method

XmlPersistContext.WriteULong Method
[image]

Writes an unsigned long value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteULong (
ulong ulongValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteULong( _
ulongValue As ULong, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

ulongValue

The unsigned long value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteUShort Method

XmlPersistContext.WriteUShort Method
[image]

Writes an unsigned short value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteUShort (
ushort ushortValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteUShort( _
ushortValue As UShort, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

ushortValue

The unsigned short value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteXaml Method

XmlPersistContext.WriteXaml Method
[image]

Serializes an object to XAML.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteXaml (
Object elt,
string name,
XElement parent
)

Visual Basic [image] Copy Code

Public Function WriteXaml( _
elt As Object, _
name As String, _
parent As XElement _
) As XElement

Parameters

elt

The System.Xml.Linq.XElement value to write.

name

The name of the element under which the value should be written.

parent

The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext Properties

XmlPersistContext Properties
[image]

Public Properties

Name | Description
ClassVersion | Gets the class version of the currently deserialized item.
Diagram | Gets the underlying diagram object.
FileVersion | Gets the format revision number for the file being currently serialized.
XmlDocument | Gets the underlying XML document.

See Also

XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ClassVersion Property

XmlPersistContext.ClassVersion Property
[image]

Gets the class version of the currently deserialized item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ClassVersion { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ClassVersion As Integer

Property Value

Remarks

This property is only useful when deserializing items.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.Diagram Property

XmlPersistContext.Diagram Property
[image]

Gets the underlying diagram object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Diagram Diagram { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Diagram As Diagram

Property Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.FileVersion Property

XmlPersistContext.FileVersion Property
[image]

Gets the format revision number for the file being currently serialized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int FileVersion { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property FileVersion As Integer

Property Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.XmlDocument Property

XmlPersistContext.XmlDocument Property
[image]

Gets the underlying XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XDocument XmlDocument { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property XmlDocument As XDocument

Property Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.ZoomButton Class

ZoomButton Class
[image]

The button used in ZoomControl.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ZoomButton : Button

Visual Basic [image] Copy Code

Public Class ZoomButton
Inherits Button

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
Windows.UI.Xaml.Controls.ContentControl
Windows.UI.Xaml.Controls.Primitives.ButtonBase
Windows.UI.Xaml.Controls.Button
MindFusion.Diagramming.ZoomButton

See Also

ZoomButton Members


MindFusion.Diagramming.ZoomButton Members

ZoomButton Members
Constructors Fields Properties Methods
[image]

The button used in ZoomControl.

The following tables list the members exposed by the ZoomButton type.

Public Constructors

Name | Description
ZoomButton | Initializes a new instance of the ZoomButton class.

Public Fields

Name | Description
ClipGeometryProperty | Identifies the ClipGeometry dependency property.
GlassEffectVisibilityProperty | Identifies the GlassEffectVisibility dependency property.
GlowFillProperty | Identifies the GlowFill dependency property.
GlowStrokeProperty | Identifies the GlowStroke dependency property.

Public Properties

Name | Description
GlassEffectVisibility | Sets wheather or not the Glass Effect will be visible.
GlowFill | Gets or sets the brush used to render background when mouse is over.
GlowStroke | Gets or sets the brush used to render border brush when mouse is over.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

See Also

ZoomButton Class


MindFusion.Diagramming.ZoomButton Fields

ZoomButton Fields
[image]

Public Fields

Name | Description
ClipGeometryProperty | Identifies the ClipGeometry dependency property.
GlassEffectVisibilityProperty | Identifies the GlassEffectVisibility dependency property.
GlowFillProperty | Identifies the GlowFill dependency property.
GlowStrokeProperty | Identifies the GlowStroke dependency property.

See Also

ZoomButton Class


MindFusion.Diagramming.ZoomButton.ClipGeometryProperty Field

ZoomButton.ClipGeometryProperty Field
[image]

Identifies the ClipGeometry dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ClipGeometryProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ClipGeometryProperty As DependencyProperty

See Also

ZoomButton Members
ZoomButton Class


MindFusion.Diagramming.ZoomButton.GlassEffectVisibilityProperty Field

ZoomButton.GlassEffectVisibilityProperty Field
[image]

Identifies the GlassEffectVisibility dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GlassEffectVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GlassEffectVisibilityProperty As DependencyProperty

See Also

ZoomButton Members
ZoomButton Class


MindFusion.Diagramming.ZoomButton.GlowFillProperty Field

ZoomButton.GlowFillProperty Field
[image]

Identifies the GlowFill dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GlowFillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GlowFillProperty As DependencyProperty

See Also

ZoomButton Members
ZoomButton Class


MindFusion.Diagramming.ZoomButton.GlowStrokeProperty Field

ZoomButton.GlowStrokeProperty Field
[image]

Identifies the GlowStroke dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GlowStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GlowStrokeProperty As DependencyProperty

See Also

ZoomButton Members
ZoomButton Class


MindFusion.Diagramming.ZoomButton Constructor

ZoomButton Constructor
[image]

Initializes a new instance of the ZoomButton class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ZoomButton ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ZoomButton Class


MindFusion.Diagramming.ZoomButton Methods

ZoomButton Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

See Also

ZoomButton Class


MindFusion.Diagramming.ZoomButton.OnApplyTemplate Method

ZoomButton.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Overrides Sub OnApplyTemplate ()

See Also

ZoomButton Members
ZoomButton Class


MindFusion.Diagramming.ZoomButton Properties

ZoomButton Properties
[image]

Public Properties

Name | Description
GlassEffectVisibility | Sets wheather or not the Glass Effect will be visible.
GlowFill | Gets or sets the brush used to render background when mouse is over.
GlowStroke | Gets or sets the brush used to render border brush when mouse is over.

See Also

ZoomButton Class


MindFusion.Diagramming.ZoomButton.GlassEffectVisibility Property

ZoomButton.GlassEffectVisibility Property
[image]

Sets wheather or not the Glass Effect will be visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Visibility GlassEffectVisibility { get; set; }

Visual Basic [image] Copy Code

Public Property GlassEffectVisibility As Visibility

Property Value

See Also

ZoomButton Members
ZoomButton Class


MindFusion.Diagramming.ZoomButton.GlowFill Property

ZoomButton.GlowFill Property
[image]

Gets or sets the brush used to render background when mouse is over.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush GlowFill { get; set; }

Visual Basic [image] Copy Code

Public Property GlowFill As Brush

Property Value

See Also

ZoomButton Members
ZoomButton Class


MindFusion.Diagramming.ZoomButton.GlowStroke Property

ZoomButton.GlowStroke Property
[image]

Gets or sets the brush used to render border brush when mouse is over.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush GlowStroke { get; set; }

Visual Basic [image] Copy Code

Public Property GlowStroke As Brush

Property Value

See Also

ZoomButton Members
ZoomButton Class


MindFusion.Diagramming.ZoomControl Class

ZoomControl Class
Remarks See Also
[image]

ZoomControl lets users zoom and pan a target Diagram interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ZoomControl : Control

Visual Basic [image] Copy Code

Public Class ZoomControl
Inherits Control

Remarks

The ZoomControl class lets users change interactively the current zoom level and scroll position of a Diagram. To set it up, add a ZoomControl to the page, place it anywhere over the target diagram, and set the control's Target property to that diagram. Set the ZoomStep and ScrollStep properties to specify the amount added to view's zoom level or scroll position by ZoomControl's buttons. You can customize the control's appearance by setting properties such as Fill, Stroke, CornerRadius and TickPosition.

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
MindFusion.Diagramming.ZoomControl

See Also

ZoomControl Members


MindFusion.Diagramming.ZoomControl Members

ZoomControl Members
Constructors Fields Properties Methods Events
[image]

ZoomControl lets users zoom and pan a target Diagram interactively.

The following tables list the members exposed by the ZoomControl type.

Public Constructors

Name | Description
ZoomControl | Initializes a new instance of the ZoomControl class.

Public Fields

Name | Description
AxisFillProperty | Identifies the AxisFill dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
FillProperty | Identifies the Fill dependency property.
GlassEffectVisibilityProperty | Identifies the GlassEffectVisibility dependency property.
GlowFillProperty | Identifies the GlowFill dependency property.
GlowStrokeProperty | Identifies the GlowStroke dependency property.
InnerStrokeProperty | Identifies the InnerStroke dependency property.
LabelFillProperty | Identifies the LabelFill dependency property.
LabelFormatProperty | Identifies the LabelFormat dependency property.
LabelTextProperty | Identifies the LabelText dependency property.
LabelVisibilityProperty | Identifies the LabelVisibility dependency property.
MaxZoomFactorProperty | Identifies the MaxZoomFactor dependency property.
MinZoomFactorProperty | Identifies the MinZoomFactor dependency property.
PanFillProperty | Identifies the PanFill dependency property.
PanGlowFillProperty | Identifies the PanGlowFill dependency property.
ScrollStepProperty | Identifies the ScrollStep dependency property.
SnapToZoomStepProperty | Identifies the SnapToZoomStep dependency property.
StrokeProperty | Identifies the Stroke dependency property.
TargetProperty | Identifies the Target dependency property.
TickPositionProperty | Identifies the TickPosition dependency property.
ZoomFactorProperty | Identifies the ZoomFactor dependency property.
ZoomStepProperty | Identifies the ZoomStep dependency property.

Public Properties

Name | Description
AxisFill | Gets or sets the brush of ZoomControl axis.
CornerRadius | Gets or sets the corner radius of rounded child elements.
Fill | Gets or sets the brush used to fill the ZoomControl buttons.
GlassEffectVisibility | Gets or sets wheather the Glass Effect should be visible.
GlowFill | Gets or sets the brush used to fill the ZoomControl buttons when mouse is over.
GlowStroke | Gets or sets the brush of ZoomControl buttons' borders when mouse is over.
InnerStroke | Gets or sets the brush of plus, minus and arrow icons.
LabelFill | Gets or sets the fill of the zoom level label.
LabelFormat | Gets or sets the zoom level label format.
LabelVisibility | Gets or sets the zoom level label visibility.
MaxZoomFactor | The maximum zoom level allowed to set through this control.
MinZoomFactor | The minimum zoom level allowed to set through this control.
PanFill | Gets or sets the brush used to fill the ZoomControl depressed pan-buttons.
PanGlowFill | Gets or sets the brush used to fill the ZoomControl pan-buttons when mouse is over.
ScrollStep | Gets or sets the scroll offset added when users click the pan arrows.
SnapToZoomStep | Gets or sets whether the trackbar should snap to ZoomStep values when dragged.
Stroke | Gets or sets the brush of ZoomControl buttons' borders.
Target | Gets or sets the target diagram controlled by this ZoomControl.
TickPosition | Gets or sets the current tick position of the trackbar.
ZoomFactor | Gets or sets the current zoom level.
ZoomStep | Gets or sets the amount by which to change zoom level when + and - buttons are clicked.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
SetZoomFactor | Sets the current zoom level.

Public Events

Name | Description
ScrollArrowClicked | Raised when a scroll arrow has been clicked.
ZoomFactorChanged | Raised when the zoom level changes.

See Also

ZoomControl Class


MindFusion.Diagramming.ZoomControl Fields

ZoomControl Fields
[image]

Public Fields

Name | Description
AxisFillProperty | Identifies the AxisFill dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
FillProperty | Identifies the Fill dependency property.
GlassEffectVisibilityProperty | Identifies the GlassEffectVisibility dependency property.
GlowFillProperty | Identifies the GlowFill dependency property.
GlowStrokeProperty | Identifies the GlowStroke dependency property.
InnerStrokeProperty | Identifies the InnerStroke dependency property.
LabelFillProperty | Identifies the LabelFill dependency property.
LabelFormatProperty | Identifies the LabelFormat dependency property.
LabelTextProperty | Identifies the LabelText dependency property.
LabelVisibilityProperty | Identifies the LabelVisibility dependency property.
MaxZoomFactorProperty | Identifies the MaxZoomFactor dependency property.
MinZoomFactorProperty | Identifies the MinZoomFactor dependency property.
PanFillProperty | Identifies the PanFill dependency property.
PanGlowFillProperty | Identifies the PanGlowFill dependency property.
ScrollStepProperty | Identifies the ScrollStep dependency property.
SnapToZoomStepProperty | Identifies the SnapToZoomStep dependency property.
StrokeProperty | Identifies the Stroke dependency property.
TargetProperty | Identifies the Target dependency property.
TickPositionProperty | Identifies the TickPosition dependency property.
ZoomFactorProperty | Identifies the ZoomFactor dependency property.
ZoomStepProperty | Identifies the ZoomStep dependency property.

See Also

ZoomControl Class


MindFusion.Diagramming.ZoomControl.AxisFillProperty Field

ZoomControl.AxisFillProperty Field
[image]

Identifies the AxisFill dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AxisFillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AxisFillProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.CornerRadiusProperty Field

ZoomControl.CornerRadiusProperty Field
[image]

Identifies the CornerRadius dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CornerRadiusProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.FillProperty Field

ZoomControl.FillProperty Field
[image]

Identifies the Fill dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FillProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.GlassEffectVisibilityProperty Field

ZoomControl.GlassEffectVisibilityProperty Field
[image]

Identifies the GlassEffectVisibility dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GlassEffectVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GlassEffectVisibilityProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.GlowFillProperty Field

ZoomControl.GlowFillProperty Field
[image]

Identifies the GlowFill dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GlowFillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GlowFillProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.GlowStrokeProperty Field

ZoomControl.GlowStrokeProperty Field
[image]

Identifies the GlowStroke dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GlowStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GlowStrokeProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.InnerStrokeProperty Field

ZoomControl.InnerStrokeProperty Field
[image]

Identifies the InnerStroke dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerStrokeProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.LabelFillProperty Field

ZoomControl.LabelFillProperty Field
[image]

Identifies the LabelFill dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFillProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.LabelFormatProperty Field

ZoomControl.LabelFormatProperty Field
[image]

Identifies the LabelFormat dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFormatProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.LabelTextProperty Field

ZoomControl.LabelTextProperty Field
[image]

Identifies the LabelText dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelTextProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelTextProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.LabelVisibilityProperty Field

ZoomControl.LabelVisibilityProperty Field
[image]

Identifies the LabelVisibility dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelVisibilityProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.MaxZoomFactorProperty Field

ZoomControl.MaxZoomFactorProperty Field
[image]

Identifies the MaxZoomFactor dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MaxZoomFactorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MaxZoomFactorProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.MinZoomFactorProperty Field

ZoomControl.MinZoomFactorProperty Field
[image]

Identifies the MinZoomFactor dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinZoomFactorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinZoomFactorProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.PanFillProperty Field

ZoomControl.PanFillProperty Field
[image]

Identifies the PanFill dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PanFillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PanFillProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.PanGlowFillProperty Field

ZoomControl.PanGlowFillProperty Field
[image]

Identifies the PanGlowFill dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PanGlowFillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PanGlowFillProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.ScrollStepProperty Field

ZoomControl.ScrollStepProperty Field
[image]

Identifies the ScrollStep dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScrollStepProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScrollStepProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.SnapToZoomStepProperty Field

ZoomControl.SnapToZoomStepProperty Field
[image]

Identifies the SnapToZoomStep dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SnapToZoomStepProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SnapToZoomStepProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.StrokeProperty Field

ZoomControl.StrokeProperty Field
[image]

Identifies the Stroke dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.TargetProperty Field

ZoomControl.TargetProperty Field
[image]

Identifies the Target dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TargetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TargetProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.TickPositionProperty Field

ZoomControl.TickPositionProperty Field
[image]

Identifies the TickPosition dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TickPositionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TickPositionProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.ZoomFactorProperty Field

ZoomControl.ZoomFactorProperty Field
[image]

Identifies the ZoomFactor dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ZoomFactorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ZoomFactorProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.ZoomStepProperty Field

ZoomControl.ZoomStepProperty Field
[image]

Identifies the ZoomStep dependency property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ZoomStepProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ZoomStepProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl Constructor

ZoomControl Constructor
[image]

Initializes a new instance of the ZoomControl class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ZoomControl ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ZoomControl Class


MindFusion.Diagramming.ZoomControl Methods

ZoomControl Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
SetZoomFactor | Sets the current zoom level.

See Also

ZoomControl Class


MindFusion.Diagramming.ZoomControl.OnApplyTemplate Method

ZoomControl.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Overrides Sub OnApplyTemplate ()

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.SetZoomFactor Method

ZoomControl.SetZoomFactor Method
[image]

Sets the current zoom level.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetZoomFactor (
double value,
bool applyConstraints
)

Visual Basic [image] Copy Code

Public Sub SetZoomFactor( _
value As Double, _
applyConstraints As Boolean _
)

Parameters

value

A float value specifying the new zoom level.

applyConstraints

true to apply min/max constraints and align to ZoomStep, or false otherwise.

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl Properties

ZoomControl Properties
[image]

Public Properties

Name | Description
AxisFill | Gets or sets the brush of ZoomControl axis.
CornerRadius | Gets or sets the corner radius of rounded child elements.
Fill | Gets or sets the brush used to fill the ZoomControl buttons.
GlassEffectVisibility | Gets or sets wheather the Glass Effect should be visible.
GlowFill | Gets or sets the brush used to fill the ZoomControl buttons when mouse is over.
GlowStroke | Gets or sets the brush of ZoomControl buttons' borders when mouse is over.
InnerStroke | Gets or sets the brush of plus, minus and arrow icons.
LabelFill | Gets or sets the fill of the zoom level label.
LabelFormat | Gets or sets the zoom level label format.
LabelVisibility | Gets or sets the zoom level label visibility.
MaxZoomFactor | The maximum zoom level allowed to set through this control.
MinZoomFactor | The minimum zoom level allowed to set through this control.
PanFill | Gets or sets the brush used to fill the ZoomControl depressed pan-buttons.
PanGlowFill | Gets or sets the brush used to fill the ZoomControl pan-buttons when mouse is over.
ScrollStep | Gets or sets the scroll offset added when users click the pan arrows.
SnapToZoomStep | Gets or sets whether the trackbar should snap to ZoomStep values when dragged.
Stroke | Gets or sets the brush of ZoomControl buttons' borders.
Target | Gets or sets the target diagram controlled by this ZoomControl.
TickPosition | Gets or sets the current tick position of the trackbar.
ZoomFactor | Gets or sets the current zoom level.
ZoomStep | Gets or sets the amount by which to change zoom level when + and - buttons are clicked.

See Also

ZoomControl Class


MindFusion.Diagramming.ZoomControl.AxisFill Property

ZoomControl.AxisFill Property
[image]

Gets or sets the brush of ZoomControl axis.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush AxisFill { get; set; }

Visual Basic [image] Copy Code

Public Property AxisFill As Brush

Property Value

A Windows.UI.Xaml.Media.Brush instance.

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.CornerRadius Property

ZoomControl.CornerRadius Property
[image]

Gets or sets the corner radius of rounded child elements.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double CornerRadius { get; set; }

Visual Basic [image] Copy Code

Public Property CornerRadius As Double

Property Value

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.Fill Property

ZoomControl.Fill Property
[image]

Gets or sets the brush used to fill the ZoomControl buttons.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush Fill { get; set; }

Visual Basic [image] Copy Code

Public Property Fill As Brush

Property Value

A Windows.UI.Xaml.Media.Brush instance.

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.GlassEffectVisibility Property

ZoomControl.GlassEffectVisibility Property
[image]

Gets or sets wheather the Glass Effect should be visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Visibility GlassEffectVisibility { get; set; }

Visual Basic [image] Copy Code

Public Property GlassEffectVisibility As Visibility

Property Value

A member of the Windows.UI.Xaml.Visibility enumeration. The default value is Visible.

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.GlowFill Property

ZoomControl.GlowFill Property
[image]

Gets or sets the brush used to fill the ZoomControl buttons when mouse is over.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush GlowFill { get; set; }

Visual Basic [image] Copy Code

Public Property GlowFill As Brush

Property Value

A Windows.UI.Xaml.Media.Brush instance.

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.GlowStroke Property

ZoomControl.GlowStroke Property
[image]

Gets or sets the brush of ZoomControl buttons' borders when mouse is over.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush GlowStroke { get; set; }

Visual Basic [image] Copy Code

Public Property GlowStroke As Brush

Property Value

A Windows.UI.Xaml.Media.Brush instance.

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.InnerStroke Property

ZoomControl.InnerStroke Property
[image]

Gets or sets the brush of plus, minus and arrow icons.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush InnerStroke { get; set; }

Visual Basic [image] Copy Code

Public Property InnerStroke As Brush

Property Value

A Windows.UI.Xaml.Media.Brush instance.

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.LabelFill Property

ZoomControl.LabelFill Property
[image]

Gets or sets the fill of the zoom level label.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush LabelFill { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFill As Brush

Property Value

A Windows.UI.Xaml.Media.Brush instance.

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.LabelFormat Property

ZoomControl.LabelFormat Property
[image]

Gets or sets the zoom level label format.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string LabelFormat { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFormat As String

Property Value

A string specifying the numeric format of the zoom level label.

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.LabelVisibility Property

ZoomControl.LabelVisibility Property
[image]

Gets or sets the zoom level label visibility.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Visibility LabelVisibility { get; set; }

Visual Basic [image] Copy Code

Public Property LabelVisibility As Visibility

Property Value

A member of the Windows.UI.Xaml.Visibility enumeration. The default value is Visible.

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.MaxZoomFactor Property

ZoomControl.MaxZoomFactor Property
[image]

The maximum zoom level allowed to set through this control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double MaxZoomFactor { get; set; }

Visual Basic [image] Copy Code

Public Property MaxZoomFactor As Double

Property Value

A double value specifying the maximum zoom level. The default value is 200.

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.MinZoomFactor Property

ZoomControl.MinZoomFactor Property
[image]

The minimum zoom level allowed to set through this control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double MinZoomFactor { get; set; }

Visual Basic [image] Copy Code

Public Property MinZoomFactor As Double

Property Value

A double value specifying the minimum zoom level. The default value is 0.

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.PanFill Property

ZoomControl.PanFill Property
[image]

Gets or sets the brush used to fill the ZoomControl depressed pan-buttons.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush PanFill { get; set; }

Visual Basic [image] Copy Code

Public Property PanFill As Brush

Property Value

A Windows.UI.Xaml.Media.Brush instance.

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.PanGlowFill Property

ZoomControl.PanGlowFill Property
[image]

Gets or sets the brush used to fill the ZoomControl pan-buttons when mouse is over.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush PanGlowFill { get; set; }

Visual Basic [image] Copy Code

Public Property PanGlowFill As Brush

Property Value

A Windows.UI.Xaml.Media.Brush instance.

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.ScrollStep Property

ZoomControl.ScrollStep Property
[image]

Gets or sets the scroll offset added when users click the pan arrows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ScrollStep { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollStep As Double

Property Value

A double value specifying the scroll offset. The default value is 10.

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.SnapToZoomStep Property

ZoomControl.SnapToZoomStep Property
[image]

Gets or sets whether the trackbar should snap to ZoomStep values when dragged.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SnapToZoomStep { get; set; }

Visual Basic [image] Copy Code

Public Property SnapToZoomStep As Boolean

Property Value

true to snap to multiples of ZoomStep, or false otherwise. The default value is true.

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.Stroke Property

ZoomControl.Stroke Property
[image]

Gets or sets the brush of ZoomControl buttons' borders.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush Stroke { get; set; }

Visual Basic [image] Copy Code

Public Property Stroke As Brush

Property Value

A Windows.UI.Xaml.Media.Brush instance.

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.Target Property

ZoomControl.Target Property
[image]

Gets or sets the target diagram controlled by this ZoomControl.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IZoomTarget Target { get; set; }

Visual Basic [image] Copy Code

Public Property Target As IZoomTarget

Property Value

A Diagram instance.

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.TickPosition Property

ZoomControl.TickPosition Property
[image]

Gets or sets the current tick position of the trackbar.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TickPosition TickPosition { get; set; }

Visual Basic [image] Copy Code

Public Property TickPosition As TickPosition

Property Value

A member of the TickPosition enumeration. The default value is Left.

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.ZoomFactor Property

ZoomControl.ZoomFactor Property
[image]

Gets or sets the current zoom level.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ZoomFactor { get; set; }

Visual Basic [image] Copy Code

Public Property ZoomFactor As Double

Property Value

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.ZoomStep Property

ZoomControl.ZoomStep Property
[image]

Gets or sets the amount by which to change zoom level when + and - buttons are clicked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ZoomStep { get; set; }

Visual Basic [image] Copy Code

Public Property ZoomStep As Double

Property Value

A double value specifying the zoom level change. The default value is 10.

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl Events

ZoomControl Events
[image]

Public Events

Name | Description
ScrollArrowClicked | Raised when a scroll arrow has been clicked.
ZoomFactorChanged | Raised when the zoom level changes.

See Also

ZoomControl Class


MindFusion.Diagramming.ZoomControl.ScrollArrowClicked Event

ZoomControl.ScrollArrowClicked Event
[image]

Raised when a scroll arrow has been clicked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<ScrollArrowEventArgs> ScrollArrowClicked

Visual Basic [image] Copy Code

Public Event ScrollArrowClicked As EventHandler(Of ScrollArrowEventArgs)

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.ZoomControl.ZoomFactorChanged Event

ZoomControl.ZoomFactorChanged Event
[image]

Raised when the zoom level changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler ZoomFactorChanged

Visual Basic [image] Copy Code

Public Event ZoomFactorChanged As EventHandler

See Also

ZoomControl Members
ZoomControl Class


MindFusion.Diagramming.Lanes Namespace

MindFusion.Diagramming.Lanes Namespace
Classes Interfaces Delegates Enumerations

Contains classes that let you display lanes and grids in DiagramLite.

The lane grid lets you emphasize the relationship between a group of diagram items by displaying them in a distinct lane or cell within the grid. For example, your diagram might display a complicated processes that involves several departments of an organization. Each department might be represented by a lane, and the nodes that represent the responsibilities of a single department will be displayed in the same lane. The lanes can be further divided into cells. For example, that could be used to display a timeline and allocate the diagram nodes to specific dates.

To display lanes or a grid, set the EnableLanes property of the Diagram class to true. In order to customize the grid, set the various attributes exposed by the LaneGrid property, which lets you specify the number of rows and columns, add headers, customize the cell appearance, and so on.

Classes

Class | Description
Cell | Represents a single cell in a lane grid.
CellBoundsEventArgs | Contains the arguments passed to handlers of the CellBoundsChanged event.
FourSidedBorder | Implements a border control with distinct appearance of each of its sides.
Grid | Represents a lane grid.
Grid.HeaderEventArgs | Contains the arguments passed to handlers of header-related events.
GridCellEventArgs | Contains the arguments passed to the handlers of the LaneGridCellCreated event.
GridHeaderEventArgs | Contains the arguments passed to the handlers of the LaneGridHeaderCreated event.
Header | Represents a header in a grid view.
HeaderCollection | Represents a strongly-typed collection of Header objects.
LaneGridCellPresenter | Renders the content of lane-grid cells.
LaneGridHeaderPresenter | Renders the content of lane headers.
Style | Encapsulates the appearance properties of an element in a lane grid.

Interfaces

Interface | Description
ICell | Defines a base for cells in a lane list.

Delegates

Delegate | Description
CellBoundsEventHandler | Represents methods that will handle the CellBoundsChanged event.

Enumerations

Enumeration | Description
ResizeType | Specifies how to resize child columns and rows in the lanes grid when their parent column or row is resized.


MindFusion.Diagramming.Lanes.Cell Class

Cell Class
[image]

Represents a single cell in a lane grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Cell : ICell, INotifyPropertyChanged

Visual Basic [image] Copy Code

Public Class Cell
Implements ICell, INotifyPropertyChanged

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Lanes.Cell

See Also

Cell Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Cell Members

Cell Members
Constructors Properties Events
[image]

Represents a single cell in a lane grid.

The following tables list the members exposed by the Cell type.

Public Constructors

Name | Description
Cell | Initializes a new instance of the cell class.

Public Properties

Name | Description
ActualHeight | Gets or sets the actual height of this header within the diagram.
ActualWidth | Gets or sets the actual width of this header within the diagram.
ActualX | Gets or sets the actual x-coordinate of this header within the diagram.
ActualY | Gets or sets the actual y-coordinate of this header within the diagram.
Style | Gets or sets the style of the cell.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

Cell Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Cell Constructor

Cell Constructor
[image]

Initializes a new instance of the cell class.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Cell ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Cell Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Cell Properties

Cell Properties
[image]

Public Properties

Name | Description
ActualHeight | Gets or sets the actual height of this header within the diagram.
ActualWidth | Gets or sets the actual width of this header within the diagram.
ActualX | Gets or sets the actual x-coordinate of this header within the diagram.
ActualY | Gets or sets the actual y-coordinate of this header within the diagram.
Style | Gets or sets the style of the cell.

See Also

Cell Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Cell.ActualHeight Property

Cell.ActualHeight Property
[image]

Gets or sets the actual height of this header within the diagram.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ActualHeight { get; set; }

Visual Basic [image] Copy Code

Public Property ActualHeight As Double

Property Value

Remarks

The associated header presenter binds its Height to this property.

See Also

Cell Members
Cell Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Cell.ActualWidth Property

Cell.ActualWidth Property
[image]

Gets or sets the actual width of this header within the diagram.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ActualWidth { get; set; }

Visual Basic [image] Copy Code

Public Property ActualWidth As Double

Property Value

Remarks

The associated header presenter binds its Width to this property.

See Also

Cell Members
Cell Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Cell.ActualX Property

Cell.ActualX Property
[image]

Gets or sets the actual x-coordinate of this header within the diagram.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ActualX { get; set; }

Visual Basic [image] Copy Code

Public Property ActualX As Double

Property Value

Remarks

The associated header presenter binds its Canvas.Left to this property.

See Also

Cell Members
Cell Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Cell.ActualY Property

Cell.ActualY Property
[image]

Gets or sets the actual y-coordinate of this header within the diagram.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ActualY { get; set; }

Visual Basic [image] Copy Code

Public Property ActualY As Double

Property Value

Remarks

The associated header presenter binds its Canvas.Top to this property.

See Also

Cell Members
Cell Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Cell.Style Property

Cell.Style Property
[image]

Gets or sets the style of the cell.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Style Style { get; set; }

Visual Basic [image] Copy Code

Public Property Style As Style

Property Value

See Also

Cell Members
Cell Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Cell Events

Cell Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

Cell Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Cell.PropertyChanged Event

Cell.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

See Also

Cell Members
Cell Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.CellBoundsEventArgs Class

CellBoundsEventArgs Class
[image]

Contains the arguments passed to handlers of the CellBoundsChanged event.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class CellBoundsEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class CellBoundsEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Lanes.CellBoundsEventArgs

See Also

CellBoundsEventArgs Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.CellBoundsEventArgs Members

CellBoundsEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the CellBoundsChanged event.

The following tables list the members exposed by the CellBoundsEventArgs type.

Public Properties

Name | Description
Cell | Gets the cell which has been resized.
NewBounds | Gets the new bounding rectangle of the cell.
OldBounds | Gets the old bounding rectangle of the cell.

See Also

CellBoundsEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.CellBoundsEventArgs Properties

CellBoundsEventArgs Properties
[image]

Public Properties

Name | Description
Cell | Gets the cell which has been resized.
NewBounds | Gets the new bounding rectangle of the cell.
OldBounds | Gets the old bounding rectangle of the cell.

See Also

CellBoundsEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.CellBoundsEventArgs.Cell Property

CellBoundsEventArgs.Cell Property
[image]

Gets the cell which has been resized.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ICell Cell { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Cell As ICell

Property Value

An instance of a class implementing the ICell interface that represents the cell that has been resized.

See Also

CellBoundsEventArgs Members
CellBoundsEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.CellBoundsEventArgs.NewBounds Property

CellBoundsEventArgs.NewBounds Property
[image]

Gets the new bounding rectangle of the cell.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect NewBounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewBounds As Rect

Property Value

A Rect object specifying the new bounding rectangle of the cell.

See Also

CellBoundsEventArgs Members
CellBoundsEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.CellBoundsEventArgs.OldBounds Property

CellBoundsEventArgs.OldBounds Property
[image]

Gets the old bounding rectangle of the cell.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect OldBounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldBounds As Rect

Property Value

A Rect object specifying the old bounding rectangle of the cell.

See Also

CellBoundsEventArgs Members
CellBoundsEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.CellBoundsEventHandler Delegate

CellBoundsEventHandler Delegate
[image]

Represents methods that will handle the CellBoundsChanged event.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate void CellBoundsEventHandler (
Object sender,
CellBoundsEventArgs e
)

Visual Basic [image] Copy Code

Public Delegate Sub CellBoundsEventHandler ( _
sender As Object, _
e As CellBoundsEventArgs _
)

Parameters

sender

The source of the event.

e
A CellBoundsEventArgs that contains the event data.

See Also

MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.FourSidedBorder Class

FourSidedBorder Class
Remarks See Also
[image]

Implements a border control with distinct appearance of each of its sides.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class FourSidedBorder : ContentControl

Visual Basic [image] Copy Code

Public Class FourSidedBorder
Inherits ContentControl

Remarks

This class is used to draw cell borders in the default Cell template.

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
Windows.UI.Xaml.Controls.ContentControl
MindFusion.Diagramming.Lanes.FourSidedBorder

See Also

FourSidedBorder Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.FourSidedBorder Members

FourSidedBorder Members
Constructors Fields Properties
[image]

Implements a border control with distinct appearance of each of its sides.

The following tables list the members exposed by the FourSidedBorder type.

Public Constructors

Name | Description
FourSidedBorder | Initializes a new instance of the FourSidedBorder class.

Public Fields

Name | Description
BorderStyleProperty | Identifies the BorderStyle dependency property.

Public Properties

Name | Description
BorderStyle | Gets or sets a Style object that specifies the appearance of the border sides.

See Also

FourSidedBorder Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.FourSidedBorder Fields

FourSidedBorder Fields
[image]

Public Fields

Name | Description
BorderStyleProperty | Identifies the BorderStyle dependency property.

See Also

FourSidedBorder Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.FourSidedBorder.BorderStyleProperty Field

FourSidedBorder.BorderStyleProperty Field
[image]

Identifies the BorderStyle dependency property.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BorderStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BorderStyleProperty As DependencyProperty

See Also

FourSidedBorder Members
FourSidedBorder Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.FourSidedBorder Constructor

FourSidedBorder Constructor
[image]

Initializes a new instance of the FourSidedBorder class.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FourSidedBorder ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

FourSidedBorder Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.FourSidedBorder Properties

FourSidedBorder Properties
[image]

Public Properties

Name | Description
BorderStyle | Gets or sets a Style object that specifies the appearance of the border sides.

See Also

FourSidedBorder Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.FourSidedBorder.BorderStyle Property

FourSidedBorder.BorderStyle Property
[image]

Gets or sets a Style object that specifies the appearance of the border sides.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Style BorderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property BorderStyle As Style

Property Value

See Also

FourSidedBorder Members
FourSidedBorder Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid Class

Grid Class
Remarks See Also
[image]

Represents a lane grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Grid : INotifyPropertyChanged

Visual Basic [image] Copy Code

Public Class Grid
Implements INotifyPropertyChanged

Remarks

The Grid class lets you define a background grid or table that can be used in Swimlane diagrams or Gantt charts. To activate the grid, set the EnableLanes property of the Diagram class to true.

Grids can include varying number of lanes, divided into child rows and columns whose intersections form cells. The grid can be resized by setting the ColumnCount and RowCount properties or by adding headers to the ColumnHeaders and RowHeaders collections. A column or row can be divided into child elements by adding to the SubHeaders collection of a Header, which lets you form a complex hierarchy of unlimited depth.

The intersection of rows and columns can be either a simple cell for bottommost elements in the lane hierarchy, or a group of cells for parent rows and columns. Cells or cell groups can be accessed by the Item property, that lets you index cells either by their integer positions, or by their Header objects.

If the AllowResizeHeaders property of the Grid class is enabled, users can resize the grid columns and rows as desired. The CellBoundsChanged event is raised when lane cell bounds are resized.

The position of the grid and grid headers within the diagram document is defined by TopMargin and LeftMargin, which specify the grid offset relative to Bounds. HookHeaders enables lane headers to be anchored to the left or right side of the control's visible area. The sizes of headers at different levels in the lane hierarchy can be set in a single operation by using the RowHeadersWidths and ColumnHeadersHeights proeprties.

The appearance of the lanes grid can be customized further in the AlignCells property which specifies whether cells are aligned to each other, the HeadersOnTop poperty which specifies whether headers should appear on top of the z-order, and the TopLeftAreaStyle specifying the appearance of the grid's top left corner.

The Grid class provides many miscellaneous methods that can be used to find grid elements, for determining their bounds and for hit-testing.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Lanes.Grid

See Also

Grid Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid Members

Grid Members
Properties Methods Events
[image]

Represents a lane grid.

The following tables list the members exposed by the Grid type.

Public Properties

Name | Description
AllowResizeHeaders | Gets or sets a value indicating whether users can resize the headers of the grid interactively.
ColumnCount | Gets or sets the number of columns in the grid.
ColumnHeaders | Gets the collection with the topmost column headers.
ColumnHeadersHeights | Gets or sets an array with double values specifying the heights of individual column levels. If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the height is calculated as the maximum height of the columns in that level.
HeadersOnTop | Gets or sets a value indicating whether lane headers appear at the top of the z-order above all other items.
HookHeaders | Gets or sets a value indicating whether headers will be anchored to the corresponding side (that is, the column header anchored to the top side and the row header anchored to the left side).
Item | Overloaded.
LeftMargin | Gets or sets the offset of the lane grid from the left side of the document bounds.
MinHeaderSize | Gets or sets the minimum size of a header.
RowCount | Gets or sets the number of rows in the grid.
RowHeaders | Gets the collection with the leftmost row headers.
RowHeadersWidths | Gets or sets an array with double values specifying the widths of individual row levels. If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the width is calculated as the maximum width of the rows in that level.
TopLeftAreaStyle | Gets or sets the style of the area above all row headers and to the left of all column headers.
TopLeftAreaVisibility | Gets or sets the visibility of the area above all row headers and to the left of all column headers.
TopMargin | Gets or sets the offset of the lane grid from the top side of the document bounds.

Public Methods

Name | Description
FindColumn | Returns the first column header matching the specified caption.
FindRow | Finds the first row whose header caption matches the specified string.
GetCellBounds | Overloaded. Returns the bounding rectangle of a cell or cluster of cells.
GetCellColumn | Returns the column index of the specified cell.
GetCellFromPoint | Gets the cell located at the specified point.
GetCellRow | Returns the row index of the specified cell.
GetColumn | Returns the column header with the specified index from the bottommost column header level.
GetColumnHeaderBounds | Returns the bounding rectangle of all column headers.
GetColumnIndex | Returns the 0-based index of the specified column.
GetHeaderBounds | Returns the bounding rectangle of the specified header.
GetHeaderFromPoint | Gets the Header that is located at the specified point.
GetRow | Returns the row header with the specified index from the bottommost row header level.
GetRowHeaderBounds | Returns the bounding rectangle of all row headers.
GetRowIndex | Returns the 0-based index of the specified row.
Insert | Inserts a new header after the specified header and returns a reference to it.
InsertAfter | Inserts a new header after the specified header and returns a reference to it.
InsertBefore | Inserts a new header before the specified header and returns a reference to it.
RaiseHeaderAdded | Raises the HeaderAdded event from outside the lane grid.

Public Events

Name | Description
CellBoundsChanged | Raised when the bounding rectangle of a cell has been changed.
HeaderAdded | Raised when a header has been inserted to the grid either interactively or through a call to the InsertBefore or InsertAfter methods.
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid Methods

Grid Methods
[image]

Public Methods

Name | Description
FindColumn | Returns the first column header matching the specified caption.
FindRow | Finds the first row whose header caption matches the specified string.
GetCellBounds | Overloaded. Returns the bounding rectangle of a cell or cluster of cells.
GetCellColumn | Returns the column index of the specified cell.
GetCellFromPoint | Gets the cell located at the specified point.
GetCellRow | Returns the row index of the specified cell.
GetColumn | Returns the column header with the specified index from the bottommost column header level.
GetColumnHeaderBounds | Returns the bounding rectangle of all column headers.
GetColumnIndex | Returns the 0-based index of the specified column.
GetHeaderBounds | Returns the bounding rectangle of the specified header.
GetHeaderFromPoint | Gets the Header that is located at the specified point.
GetRow | Returns the row header with the specified index from the bottommost row header level.
GetRowHeaderBounds | Returns the bounding rectangle of all row headers.
GetRowIndex | Returns the 0-based index of the specified row.
Insert | Inserts a new header after the specified header and returns a reference to it.
InsertAfter | Inserts a new header after the specified header and returns a reference to it.
InsertBefore | Inserts a new header before the specified header and returns a reference to it.
RaiseHeaderAdded | Raises the HeaderAdded event from outside the lane grid.

See Also

Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.FindColumn Method

Grid.FindColumn Method
[image]

Returns the first column header matching the specified caption.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Header FindColumn (
string title
)

Visual Basic [image] Copy Code

Public Function FindColumn ( _
title As String _
) As Header

Parameters

title

A string containing the header title to look for.

Return Value

Returns the first column Header that has the specified caption.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.FindRow Method

Grid.FindRow Method
[image]

Finds the first row whose header caption matches the specified string.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Header FindRow (
string title
)

Visual Basic [image] Copy Code

Public Function FindRow ( _
title As String _
) As Header

Parameters

title

A string containing the header title to look for.

Return Value

Returns the first row Header that has the specified caption.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetCellBounds Method

Grid.GetCellBounds Method
[image]

Returns the bounding rectangle of a cell or cluster of cells.

Overload List

Name | Description
Grid.GetCellBounds (ICell) | Returns the bounding rectangle of the specified cell.
Grid.GetCellBounds (Int32, Int32) | Returns the bounding rectangle of the cell with the specified row and column.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetCellBounds Method (ICell)

Grid.GetCellBounds Method (ICell)
See Also
[image]

Returns the bounding rectangle of the specified cell.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect GetCellBounds (
ICell cell
)

Visual Basic [image] Copy Code

Public Function GetCellBounds ( _
cell As ICell _
) As Rect

Parameters

cell

An ICell object representing a cell or a group of cells in the grid.

Return Value

A Rect instance representing the rectangle that bounds the specified cell or group of cells.

See Also

GetCellBounds Method Overload List
Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetCellBounds Method (Int32, Int32)

Grid.GetCellBounds Method (Int32, Int32)
See Also
[image]

Returns the bounding rectangle of the cell with the specified row and column.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect GetCellBounds (
int c,
int r
)

Visual Basic [image] Copy Code

Public Function GetCellBounds( _
c As Integer, _
r As Integer _
) As Rect

Parameters

c

r

Return Value

A Rect instance representing the rectangle that bounds the specified cell.

See Also

GetCellBounds Method Overload List
Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetCellColumn Method

Grid.GetCellColumn Method
[image]

Returns the column index of the specified cell.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int GetCellColumn (
ICell cell
)

Visual Basic [image] Copy Code

Public Function GetCellColumn ( _
cell As ICell _
) As Integer

Parameters

cell

An ICell object representing a single cell in the grid.

Return Value

The index of the column that contains cell; -1 if cell is not found or refers to a group of cells.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetCellFromPoint Method

Grid.GetCellFromPoint Method
[image]

Gets the cell located at the specified point.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ICell GetCellFromPoint (
Point point,
ref Rect cellBounds
)

Visual Basic [image] Copy Code

Public Function GetCellFromPoint ( _
point As Point, _
ByRef cellBounds As Rect _
) As ICell

Parameters

point
A Point instance specifying a point within the grid.
cellBounds
A Rect instance that receives the coordinates of the found cell.

Return Value

An ICell reference to the found cell, or null (Nothing in Visual Basic) if there is no cell located at the specified point.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetCellRow Method

Grid.GetCellRow Method
[image]

Returns the row index of the specified cell.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int GetCellRow (
ICell cell
)

Visual Basic [image] Copy Code

Public Function GetCellRow ( _
cell As ICell _
) As Integer

Parameters

cell

An ICell object representing a single cell in the grid.

Return Value

The index of the row that contains cell; -1 if cell is not found or refers to a group of cells.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetColumn Method

Grid.GetColumn Method
[image]

Returns the column header with the specified index from the bottommost column header level.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Header GetColumn (
int index
)

Visual Basic [image] Copy Code

Public Function GetColumn ( _
index As Integer _
) As Header

Parameters

index

An integer value specifying the column index.

Return Value

A Header object representing the column at the specified index. A grid column that contains child columns cannot be accessed by index; only the bottommost child elements in the hierarchy are considered by this method.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetColumnHeaderBounds Method

Grid.GetColumnHeaderBounds Method
[image]

Returns the bounding rectangle of all column headers.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect GetColumnHeaderBounds ()

Visual Basic [image] Copy Code

Public Function GetColumnHeaderBounds () As Rect

Return Value

A Rect that bounds all column headers.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetColumnIndex Method

Grid.GetColumnIndex Method
[image]

Returns the 0-based index of the specified column.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int GetColumnIndex (
Header column
)

Visual Basic [image] Copy Code

Public Function GetColumnIndex( _
column As Header _
) As Integer

Parameters

column

A Header instance that represents a grid column.

Return Value

The index of column, or -1 if the specified header represents a row or a group of child columns.

Remarks

Only works for bottommost headers. If the specified column is a group header, returns -1.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetHeaderBounds Method

Grid.GetHeaderBounds Method
[image]

Returns the bounding rectangle of the specified header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect GetHeaderBounds (
Header header,
bool includeSubHeaders
)

Visual Basic [image] Copy Code

Public Function GetHeaderBounds( _
header As Header, _
includeSubHeaders As Boolean _
) As Rect

Parameters

header

The Header object whose coordinates to return.

includeSubHeaders

true to include the coordinates of the child headers in the returned rectangle; otherwise, false.

Return Value

A Rect that bounds the specified header, and optionally its child headers.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetHeaderFromPoint Method

Grid.GetHeaderFromPoint Method
[image]

Gets the Header that is located at the specified point.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Header GetHeaderFromPoint (
Point point,
ref Rect headerBounds
)

Visual Basic [image] Copy Code

Public Function GetHeaderFromPoint( _
point As Point, _
ByRef headerBounds As Rect _
) As Header

Parameters

point

A Point instance specifying a point within the grid.

headerBounds

A Rect instance that receives the coordinates of the found header.

Return Value

The found Header object, or null (Nothing in Visual Basic) if there is no header located at the specified point.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetRow Method

Grid.GetRow Method
[image]

Returns the row header with the specified index from the bottommost row header level.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Header GetRow (
int index
)

Visual Basic [image] Copy Code

Public Function GetRow ( _
index As Integer _
) As Header

Parameters

index

An integer value specifying the row index.

Return Value

A Header object representing the row at the specified index. A grid row that contains child rows cannot be accessed by index; only the bottommost child elements in the hierarchy are considered by this method.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetRowHeaderBounds Method

Grid.GetRowHeaderBounds Method
[image]

Returns the bounding rectangle of all row headers.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect GetRowHeaderBounds ()

Visual Basic [image] Copy Code

Public Function GetRowHeaderBounds () As Rect

Return Value

A Rect that bounds all row headers.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetRowIndex Method

Grid.GetRowIndex Method
[image]

Returns the 0-based index of the specified row.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int GetRowIndex (
Header row
)

Visual Basic [image] Copy Code

Public Function GetRowIndex( _
row As Header _
) As Integer

Parameters

row

A Header instance that represents a grid row.

Return Value

The index of row, or -1 if the specified header represents a column or a group of child rows.

Remarks

Only works for bottommost headers. If the specified row is a group header, returns -1;

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.Insert Method

Grid.Insert Method
[image]

Inserts a new header after the specified header and returns a reference to it.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Header Insert (
Header header,
bool after
)

Visual Basic [image] Copy Code

Public Function Insert( _
header As Header, _
after As Boolean _
) As Header

Parameters

header

The header after which to insert the new header.

after

The relative position of the new header

Return Value

A reference to the newly created header.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.InsertAfter Method

Grid.InsertAfter Method
[image]

Inserts a new header after the specified header and returns a reference to it.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Header InsertAfter (
Header header
)

Visual Basic [image] Copy Code

Public Function InsertAfter ( _
header As Header _
) As Header

Parameters

header

The header after which to insert the new header.

Return Value

A reference to the newly created header.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.InsertBefore Method

Grid.InsertBefore Method
[image]

Inserts a new header before the specified header and returns a reference to it.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Header InsertBefore (
Header header
)

Visual Basic [image] Copy Code

Public Function InsertBefore ( _
header As Header _
) As Header

Parameters

header

The header before which to insert the new header.

Return Value

A reference to the newly created header.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.RaiseHeaderAdded Method

Grid.RaiseHeaderAdded Method
[image]

Raises the HeaderAdded event from outside the lane grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseHeaderAdded (
Header header
)

Visual Basic [image] Copy Code

Public Sub RaiseHeaderAdded( _
header As Header _
)

Parameters

header

Remarks

This method is for internal use only.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid Properties

Grid Properties
[image]

Public Properties

Name | Description
AllowResizeHeaders | Gets or sets a value indicating whether users can resize the headers of the grid interactively.
ColumnCount | Gets or sets the number of columns in the grid.
ColumnHeaders | Gets the collection with the topmost column headers.
ColumnHeadersHeights | Gets or sets an array with double values specifying the heights of individual column levels. If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the height is calculated as the maximum height of the columns in that level.
HeadersOnTop | Gets or sets a value indicating whether lane headers appear at the top of the z-order above all other items.
HookHeaders | Gets or sets a value indicating whether headers will be anchored to the corresponding side (that is, the column header anchored to the top side and the row header anchored to the left side).
Item | Overloaded.
LeftMargin | Gets or sets the offset of the lane grid from the left side of the document bounds.
MinHeaderSize | Gets or sets the minimum size of a header.
RowCount | Gets or sets the number of rows in the grid.
RowHeaders | Gets the collection with the leftmost row headers.
RowHeadersWidths | Gets or sets an array with double values specifying the widths of individual row levels. If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the width is calculated as the maximum width of the rows in that level.
TopLeftAreaStyle | Gets or sets the style of the area above all row headers and to the left of all column headers.
TopLeftAreaVisibility | Gets or sets the visibility of the area above all row headers and to the left of all column headers.
TopMargin | Gets or sets the offset of the lane grid from the top side of the document bounds.

See Also

Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.AllowResizeHeaders Property

Grid.AllowResizeHeaders Property
[image]

Gets or sets a value indicating whether users can resize the headers of the grid interactively.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowResizeHeaders { get; set; }

Visual Basic [image] Copy Code

Public Property AllowResizeHeaders As Boolean

Property Value

true to let users resize the grid elements; otherwise, false. The default is true.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.ColumnCount Property

Grid.ColumnCount Property
[image]

Gets or sets the number of columns in the grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ColumnCount { get; set; }

Visual Basic [image] Copy Code

Public Property ColumnCount As Integer

Property Value

An integer value indicating the number of columns in the grid.

Remarks

If a smaller value is assigned to this property, the control will reduce the number of child columns. If all child columns in a parent column are removed, the parent will be removed too. To have greater control over where in the hierarchy columns will be added or removed, use the ColumnHeaders and the SubHeaders properties.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.ColumnHeaders Property

Grid.ColumnHeaders Property
[image]

Gets the collection with the topmost column headers.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HeaderCollection ColumnHeaders { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ColumnHeaders As HeaderCollection

Property Value

An instance of the HeaderCollection class containing the topmost column headers.

Remarks

Adding headers to or removing them from this collection also adds or removes top-level columns. Columns can be further divided into child columns by adding to the SubHeaders collection of the Header that represents a parent column.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.ColumnHeadersHeights Property

Grid.ColumnHeadersHeights Property
[image]

Gets or sets an array with double values specifying the heights of individual column levels. If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the height is calculated as the maximum height of the columns in that level.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double[] ColumnHeadersHeights { get; set; }

Visual Basic [image] Copy Code

Public Property ColumnHeadersHeights As Double()

Property Value

An array of double values where each value represents the height of an individual level of column headers.

Remarks

The first level of column headers is the one defined by the ColumnHeaders collection. Each next level is defnied by the SubHeaders collection of the headers in the upper level.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.HeadersOnTop Property

Grid.HeadersOnTop Property
[image]

Gets or sets a value indicating whether lane headers appear at the top of the z-order above all other items.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool HeadersOnTop { get; set; }

Visual Basic [image] Copy Code

Public Property HeadersOnTop As Boolean

Property Value

true if lane headers should be displayed on top, otherwise false. The default is true.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.HookHeaders Property

Grid.HookHeaders Property
[image]

Gets or sets a value indicating whether headers will be anchored to the corresponding side (that is, the column header anchored to the top side and the row header anchored to the left side).

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool HookHeaders { get; set; }

Visual Basic [image] Copy Code

Public Property HookHeaders As Boolean

Property Value

true if lane headers should be anchored to their corresponding side; otherwise, false. The default is true.

Remarks

You must call SetScrollerParent in order to enable the "hooked headers" feature when the diagram is inside a ScrollViewer.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.Item Property

Grid.Item Property
[image]

Overload List

Name | Description
Grid.Item (Header, Header) | Gets the cell or the cluster of cells corresponding to the specified row and column.
Grid.Item (Int32, Int32) | Gets the cell at the specified position.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.Item Property (Header, Header)

Grid.Item Property (Header, Header)
See Also
[image]

Gets the cell or the cluster of cells corresponding to the specified row and column.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ICell Item [
Header column,
Header row
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item ( _
column As Header, _
row As Header _
) As ICell

Parameters

column

A Header object that represents the column of the cell to get.

row
A Header object that represents the row of the cell to get.

Property Value

An ICell instance representing all grid cell corresponding to the specified headers.

Remarks

If both Header parameters are null (Nothing in Visual Basic), a group containing all cells in the grid is returned. If only one of the Header parameters is null, the returned cell group contains all cells from the row or a column specified through the other parameter. This feature lets you set the Style of all cells in a group through a single assignment.

See Also

Item Property Overload List
Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.Item Property (Int32, Int32)

Grid.Item Property (Int32, Int32)
See Also
[image]

Gets the cell at the specified position.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ICell Item [
int column,
int row
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item ( _
column As Integer, _
row As Integer _
) As ICell

Parameters

column
An integer value that represents the column of the cell to get.
row
An integer value that represents the index of the row to get.

Property Value

An ICell instance representing the cell at the specified position.

See Also

Item Property Overload List
Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.LeftMargin Property

Grid.LeftMargin Property
[image]

Gets or sets the offset of the lane grid from the left side of the document bounds.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LeftMargin { get; set; }

Visual Basic [image] Copy Code

Public Property LeftMargin As Double

Property Value

A double value specifying the left margin size in MeasureUnit.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.MinHeaderSize Property

Grid.MinHeaderSize Property
[image]

Gets or sets the minimum size of a header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double MinHeaderSize { get; set; }

Visual Basic [image] Copy Code

Public Property MinHeaderSize As Double

Property Value

A double value specifying the minimal size of a header. The default is 10.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.RowCount Property

Grid.RowCount Property
[image]

Gets or sets the number of rows in the grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int RowCount { get; set; }

Visual Basic [image] Copy Code

Public Property RowCount As Integer

Property Value

An integer value indicating the number of rows in the grid.

Remarks

If a smaller value is assigned to this property, the control will reduce the number of child rows. If all child rows in a parent row are removed, the parent will be removed too. To have greater control over where in the hierarchy rows will be added or removed, use the RowHeaders and the SubHeaders properties.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.RowHeaders Property

Grid.RowHeaders Property
[image]

Gets the collection with the leftmost row headers.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HeaderCollection RowHeaders { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RowHeaders As HeaderCollection

Property Value

An instance of the HeaderCollection class containing the leftmost row headers.

Remarks

Adding headers to or removing them from this collection also adds or removes top-level rows. Rows can be further divided into child rows by adding to the SubHeaders collection of the Header that represents a parent row.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.RowHeadersWidths Property

Grid.RowHeadersWidths Property
[image]

Gets or sets an array with double values specifying the widths of individual row levels. If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the width is calculated as the maximum width of the rows in that level.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double[] RowHeadersWidths { get; set; }

Visual Basic [image] Copy Code

Public Property RowHeadersWidths As Double()

Property Value

An array of double values where each value represents the width of an individual level of row headers.

Remarks

The first level of row headers is the one defined by the RowHeaders collection. Each next level is defnied by the SubHeaders collection of the headers in the upper level.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.TopLeftAreaStyle Property

Grid.TopLeftAreaStyle Property
[image]

Gets or sets the style of the area above all row headers and to the left of all column headers.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Style TopLeftAreaStyle { get; set; }

Visual Basic [image] Copy Code

Public Property TopLeftAreaStyle As Style

Property Value

An instance of the Style class specifying how to paint the top left corner. The default value is null (Nothing in Visual Basic).

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.TopLeftAreaVisibility Property

Grid.TopLeftAreaVisibility Property
[image]

Gets or sets the visibility of the area above all row headers and to the left of all column headers.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Visibility TopLeftAreaVisibility { get; set; }

Visual Basic [image] Copy Code

Public Property TopLeftAreaVisibility As Visibility

Property Value

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.TopMargin Property

Grid.TopMargin Property
[image]

Gets or sets the offset of the lane grid from the top side of the document bounds.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double TopMargin { get; set; }

Visual Basic [image] Copy Code

Public Property TopMargin As Double

Property Value

A double value specifying the top margin size in MeasureUnit.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid Events

Grid Events
[image]

Public Events

Name | Description
CellBoundsChanged | Raised when the bounding rectangle of a cell has been changed.
HeaderAdded | Raised when a header has been inserted to the grid either interactively or through a call to the InsertBefore or InsertAfter methods.
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.CellBoundsChanged Event

Grid.CellBoundsChanged Event
[image]

Raised when the bounding rectangle of a cell has been changed.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event CellBoundsEventHandler CellBoundsChanged

Visual Basic [image] Copy Code

Public Event CellBoundsChanged As CellBoundsEventHandler

Event Data

CellBoundsChanged event handlers receive an argument of type CellBoundsEventArgs.

Remarks

By default, diagram items are not affected by resizing cells in the lanes grid. By handling this event, you can move or resize items so that they stay aligned to their enclosing grid elements, as suits your application logic.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.HeaderAdded Event

Grid.HeaderAdded Event
[image]

Raised when a header has been inserted to the grid either interactively or through a call to the InsertBefore or InsertAfter methods.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<Grid.HeaderEventArgs> HeaderAdded

Visual Basic [image] Copy Code

Public Event HeaderAdded As EventHandler(Of Grid.HeaderEventArgs)

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.PropertyChanged Event

Grid.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.HeaderEventArgs Class

Grid.HeaderEventArgs Class
[image]

Contains the arguments passed to handlers of header-related events.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Grid.HeaderEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class Grid.HeaderEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Lanes.Grid.HeaderEventArgs

See Also

Grid.HeaderEventArgs Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.HeaderEventArgs Members

Grid.HeaderEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of header-related events.

The following tables list the members exposed by the Grid.HeaderEventArgs type.

Public Properties

Name | Description
Header | Gets or sets the header related to the event.

See Also

Grid.HeaderEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.HeaderEventArgs Properties

Grid.HeaderEventArgs Properties
[image]

Public Properties

Name | Description
Header | Gets or sets the header related to the event.

See Also

Grid.HeaderEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.HeaderEventArgs.Header Property

Grid.HeaderEventArgs.Header Property
[image]

Gets or sets the header related to the event.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Header Header { get; set; }

Visual Basic [image] Copy Code

Public Property Header As Header

Property Value

See Also

Grid.HeaderEventArgs Members
Grid.HeaderEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.GridCellEventArgs Class

GridCellEventArgs Class
[image]

Contains the arguments passed to the handlers of the LaneGridCellCreated event.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class GridCellEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class GridCellEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Lanes.GridCellEventArgs

See Also

GridCellEventArgs Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.GridCellEventArgs Members

GridCellEventArgs Members
Properties
[image]

Contains the arguments passed to the handlers of the LaneGridCellCreated event.

The following tables list the members exposed by the GridCellEventArgs type.

Public Properties

Name | Description
Cell | Gets a reference to the related cell.
Presenter | Gets a reference to the element representing the cell in the visual tree.

See Also

GridCellEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.GridCellEventArgs Properties

GridCellEventArgs Properties
[image]

Public Properties

Name | Description
Cell | Gets a reference to the related cell.
Presenter | Gets a reference to the element representing the cell in the visual tree.

See Also

GridCellEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.GridCellEventArgs.Cell Property

GridCellEventArgs.Cell Property
[image]

Gets a reference to the related cell.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ICell Cell { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Cell As ICell

Property Value

See Also

GridCellEventArgs Members
GridCellEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.GridCellEventArgs.Presenter Property

GridCellEventArgs.Presenter Property
[image]

Gets a reference to the element representing the cell in the visual tree.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LaneGridCellPresenter Presenter { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Presenter As LaneGridCellPresenter

Property Value

See Also

GridCellEventArgs Members
GridCellEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.GridHeaderEventArgs Class

GridHeaderEventArgs Class
[image]

Contains the arguments passed to the handlers of the LaneGridHeaderCreated event.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class GridHeaderEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class GridHeaderEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Lanes.GridHeaderEventArgs

See Also

GridHeaderEventArgs Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.GridHeaderEventArgs Members

GridHeaderEventArgs Members
Properties
[image]

Contains the arguments passed to the handlers of the LaneGridHeaderCreated event.

The following tables list the members exposed by the GridHeaderEventArgs type.

Public Properties

Name | Description
Header | Gets a reference to the related header.
Presenter | Gets a reference to the element representing the header in the visual tree.

See Also

GridHeaderEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.GridHeaderEventArgs Properties

GridHeaderEventArgs Properties
[image]

Public Properties

Name | Description
Header | Gets a reference to the related header.
Presenter | Gets a reference to the element representing the header in the visual tree.

See Also

GridHeaderEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.GridHeaderEventArgs.Header Property

GridHeaderEventArgs.Header Property
[image]

Gets a reference to the related header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Header Header { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Header As Header

Property Value

See Also

GridHeaderEventArgs Members
GridHeaderEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.GridHeaderEventArgs.Presenter Property

GridHeaderEventArgs.Presenter Property
[image]

Gets a reference to the element representing the header in the visual tree.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LaneGridHeaderPresenter Presenter { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Presenter As LaneGridHeaderPresenter

Property Value

See Also

GridHeaderEventArgs Members
GridHeaderEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header Class

Header Class
Remarks See Also
[image]

Represents a header in a grid view.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Header : INotifyPropertyChanged

Visual Basic [image] Copy Code

Public Class Header
Implements INotifyPropertyChanged

Remarks

The Header class provides the properties to define and adjust headers in the lanes grid.

The size of a header can be set through the Height and Width properties. Note that the size of the rows and columns in the grid is controlled through the size of their headers. The SubHeaders property lets you add child rows or columns to the grid. The ResizeType property is used to specify how to resize child columns and rows when the topmost headers are resized. The possible values for the ResizeType property are defined in the ResizeType enumeration.

In order to specify the color, font or alignment of the header Title, set the header's Style property.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Lanes.Header

See Also

Header Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header Members

Header Members
Constructors Properties Events
[image]

Represents a header in a grid view.

The following tables list the members exposed by the Header type.

Public Constructors

Name | Description
Header | Overloaded. Initializes a new instance of the Header class.

Public Properties

Name | Description
ActualHeight | Gets or sets the actual height of this header within the diagram.
ActualWidth | Gets or sets the actual width of this header within the diagram.
ActualX | Gets or sets the actual x-coordinate of this header within the diagram.
ActualY | Gets or sets the actual y-coordinate of this header within the diagram.
Height | Gets or sets the height of this header.
IsColumnHeader | Gets a value indicating whether this header is a column header.
IsRowHeader | Gets a value indicating whether this header is a row header.
ResizeType | Gets or sets how a row or a column is resized relatively to its parent.
Style | Gets or sets the style of this header.
SubHeaders | Gets a collection of the subheaders of this header.
Title | Gets or sets the header caption.
Width | Gets or sets the width of this header.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header Constructor

Header Constructor
[image]

Initializes a new instance of the Header class.

Overload List

Name | Description
Header () | Initializes a new instance of the Header class.
Header (String) | Initializes a new instance of the Header class with the specified title.

See Also

Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header Constructor ()

Header Constructor ()
See Also
[image]

Initializes a new instance of the Header class.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Header ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Header Constructor Overload List
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header Constructor (String)

Header Constructor (String)
See Also
[image]

Initializes a new instance of the Header class with the specified title.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Header (
string title
)

Visual Basic [image] Copy Code

Public New ( _
title As String _
)

Parameters

title

A string value that represents the title for this Header object.

See Also

Header Constructor Overload List
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header Properties

Header Properties
[image]

Public Properties

Name | Description
ActualHeight | Gets or sets the actual height of this header within the diagram.
ActualWidth | Gets or sets the actual width of this header within the diagram.
ActualX | Gets or sets the actual x-coordinate of this header within the diagram.
ActualY | Gets or sets the actual y-coordinate of this header within the diagram.
Height | Gets or sets the height of this header.
IsColumnHeader | Gets a value indicating whether this header is a column header.
IsRowHeader | Gets a value indicating whether this header is a row header.
ResizeType | Gets or sets how a row or a column is resized relatively to its parent.
Style | Gets or sets the style of this header.
SubHeaders | Gets a collection of the subheaders of this header.
Title | Gets or sets the header caption.
Width | Gets or sets the width of this header.

See Also

Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.ActualHeight Property

Header.ActualHeight Property
[image]

Gets or sets the actual height of this header within the diagram.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ActualHeight { get; set; }

Visual Basic [image] Copy Code

Public Property ActualHeight As Double

Property Value

Remarks

The associated header presenter binds its Height to this property.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.ActualWidth Property

Header.ActualWidth Property
[image]

Gets or sets the actual width of this header within the diagram.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ActualWidth { get; set; }

Visual Basic [image] Copy Code

Public Property ActualWidth As Double

Property Value

Remarks

The associated header presenter binds its Width to this property.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.ActualX Property

Header.ActualX Property
[image]

Gets or sets the actual x-coordinate of this header within the diagram.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ActualX { get; set; }

Visual Basic [image] Copy Code

Public Property ActualX As Double

Property Value

Remarks

The associated header presenter binds its Canvas.Left to this property.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.ActualY Property

Header.ActualY Property
[image]

Gets or sets the actual y-coordinate of this header within the diagram.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ActualY { get; set; }

Visual Basic [image] Copy Code

Public Property ActualY As Double

Property Value

Remarks

The associated header presenter binds its Canvas.Top to this property.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.Height Property

Header.Height Property
[image]

Gets or sets the height of this header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Double

Property Value

A double value specifying the header height. The default is 0.

Remarks

If this is a row header, the property specifies the height of the whole row.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.IsColumnHeader Property

Header.IsColumnHeader Property
[image]

Gets a value indicating whether this header is a column header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool IsColumnHeader { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property IsColumnHeader As Boolean

Property Value

true if the header is a column header; otherwise, false.

Remarks

Both IsColumnHeader and IsRowHeader return false if the header is not attached to a lane grid.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.IsRowHeader Property

Header.IsRowHeader Property
[image]

Gets a value indicating whether this header is a row header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool IsRowHeader { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property IsRowHeader As Boolean

Property Value

true if the header is a row header; otherwise, false.

Remarks

Both IsColumnHeader and IsRowHeader return false if the header is not attached to a lane grid.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.ResizeType Property

Header.ResizeType Property
[image]

Gets or sets how a row or a column is resized relatively to its parent.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ResizeType ResizeType { get; set; }

Visual Basic [image] Copy Code

Public Property ResizeType As ResizeType

Property Value

A member of the ResizeType enumeration. The default is Proportional.

Remarks

When a topmost header is resized, the child elements of the row or column related to the header either keep their size or are resized as set through this property.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.Style Property

Header.Style Property
[image]

Gets or sets the style of this header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Style Style { get; set; }

Visual Basic [image] Copy Code

Public Property Style As Style

Property Value

An instance of the Style class that specifies the appearance of the header.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.SubHeaders Property

Header.SubHeaders Property
[image]

Gets a collection of the subheaders of this header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HeaderCollection SubHeaders { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SubHeaders As HeaderCollection

Property Value

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.Title Property

Header.Title Property
[image]

Gets or sets the header caption.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

A string containing the caption text. The default is an empty string.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.Width Property

Header.Width Property
[image]

Gets or sets the width of this header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Double

Property Value

A double value specifying the header width. The default is 0.

Remarks

If this is a column header, the property specifies the width of the whole column.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header Events

Header Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.PropertyChanged Event

Header.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection Class

HeaderCollection Class
Remarks See Also
[image]

Represents a strongly-typed collection of Header objects.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class HeaderCollection : IList<Header>, ICollection<Header>, IEnumerable<Header>, IEnumerable, INotifyCollectionChanged

Visual Basic [image] Copy Code

Public Class HeaderCollection
Implements IList(Of Header), ICollection(Of Header), IEnumerable(Of Header), IEnumerable, INotifyCollectionChanged

Remarks

The ColumnHeaders and RowHeaders properties of the Grid class are of this collection type. Adding or removing headers to them automatically adds or removes parent columns and rows to the grid. Adding to or removing form the SubHeaders property of the Header class automatically adds or removes child columns or rows.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Lanes.HeaderCollection

See Also

HeaderCollection Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection Members

HeaderCollection Members
Properties Methods Events
[image]

Represents a strongly-typed collection of Header objects.

The following tables list the members exposed by the HeaderCollection type.

Public Properties

Name | Description
Count | ICollection.Count implementation.
IsReadOnly | ICollection.IsReadOnly implementation.
Item | Gets or sets the Header at the specified position.

Public Methods

Name | Description
Add | Adds the specified header to the collection.
Clear | Removes all headers from the collection.
Contains | Checks whether a Header is in the collection.
CopyTo | ICollection.CopyTo implementation.
GetEnumerator | IEnumerable.GetEnumerator implementation.
IndexOf | Gets the index of the specified header within this collection.
Insert | Inserts the specified Header at the specified position within the HeaderCollection.
Remove | Removes the first occurrence of the specified Header from the collection.
RemoveAt | Removes the Header at the specified position within the collection.

Public Events

Name | Description
CollectionChanged | INotifyCollectionChanged.CollectionChanged implementation.

See Also

HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection Methods

HeaderCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified header to the collection.
Clear | Removes all headers from the collection.
Contains | Checks whether a Header is in the collection.
CopyTo | ICollection.CopyTo implementation.
GetEnumerator | IEnumerable.GetEnumerator implementation.
IndexOf | Gets the index of the specified header within this collection.
Insert | Inserts the specified Header at the specified position within the HeaderCollection.
Remove | Removes the first occurrence of the specified Header from the collection.
RemoveAt | Removes the Header at the specified position within the collection.

See Also

HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.Add Method

HeaderCollection.Add Method
[image]

Adds the specified header to the collection.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Add (
Header header
)

Visual Basic [image] Copy Code

Public Sub Add( _
header As Header _
)

Parameters

header

The Header object to add.

Remarks

The method adds a Header object to the end of the collection. If you need to place the Header at a certain position, you should use Insert method instead.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.Clear Method

HeaderCollection.Clear Method
[image]

Removes all headers from the collection.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Clear ()

Visual Basic [image] Copy Code

Public Sub Clear ()

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.Contains Method

HeaderCollection.Contains Method
[image]

Checks whether a Header is in the collection.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Contains (
Header header
)

Visual Basic [image] Copy Code

Public Function Contains( _
header As Header _
) As Boolean

Parameters

header

The Header to locate in the collection.

Return Value

true if the header was found in the collection; otherwise, false.

Remarks

Call the method to determine whether a Header is contained within the collection. If not, you can add it with the Add method. Otherwise, if it is there, you can remove it with Remove.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.CopyTo Method

HeaderCollection.CopyTo Method
[image]

ICollection.CopyTo implementation.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void CopyTo (
Header[] array,
int arrayIndex
)

Visual Basic [image] Copy Code

Public Sub CopyTo( _
array() As Header, _
arrayIndex As Integer _
)

Parameters

array

arrayIndex

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.GetEnumerator Method

HeaderCollection.GetEnumerator Method
[image]

IEnumerable.GetEnumerator implementation.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IEnumerator<Header> GetEnumerator ()

Visual Basic [image] Copy Code

Public Function GetEnumerator () As IEnumerator(Of Header)

Return Value

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.IndexOf Method

HeaderCollection.IndexOf Method
[image]

Gets the index of the specified header within this collection.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int IndexOf (
Header header
)

Visual Basic [image] Copy Code

Public Function IndexOf( _
header As Header _
) As Integer

Parameters

header

The Header to locate in the HeaderCollection. The value can be a null reference (Nothing in Visual Basic).

Return Value

The zero-based index of the first occurrence of value within the entire HeaderCollection, if found; otherwise, -1.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.Insert Method

HeaderCollection.Insert Method
[image]

Inserts the specified Header at the specified position within the HeaderCollection.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Insert (
int index,
Header header
)

Visual Basic [image] Copy Code

Public Sub Insert( _
index As Integer, _
header As Header _
)

Parameters

index

The zero-based index at which the Header should be inserted.

header

The Header object to insert.

Remarks

Use this method to insert Header objects at a specific position in the collection. If you do not need to specify header's position, use the Add method instead, which adds new headers to the end of the list.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.Remove Method

HeaderCollection.Remove Method
[image]

Removes the first occurrence of the specified Header from the collection.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Remove (
Header header
)

Visual Basic [image] Copy Code

Public Function Remove( _
header As Header _
) As Boolean

Parameters

header

The Header object to remove.

Return Value

Remarks

Use this method to remove headers from the collection. Headers can be added to the collection with the Add or Insert methods.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.RemoveAt Method

HeaderCollection.RemoveAt Method
[image]

Removes the Header at the specified position within the collection.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RemoveAt (
int index
)

Visual Basic [image] Copy Code

Public Sub RemoveAt( _
index As Integer _
)

Parameters

index

The index at which the Header object should be removed.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection Properties

HeaderCollection Properties
[image]

Public Properties

Name | Description
Count | ICollection.Count implementation.
IsReadOnly | ICollection.IsReadOnly implementation.
Item | Gets or sets the Header at the specified position.

See Also

HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.Count Property

HeaderCollection.Count Property
[image]

ICollection.Count implementation.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Count { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Count As Integer

Property Value

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.IsReadOnly Property

HeaderCollection.IsReadOnly Property
[image]

ICollection.IsReadOnly implementation.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsReadOnly { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsReadOnly As Boolean

Property Value

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.Item Property

HeaderCollection.Item Property
[image]

Gets or sets the Header at the specified position.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Header Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Property Item( _
index As Integer _
) As Header

Parameters

index

Property Value

An instance of the Header class that represents the header at the specified position.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection Events

HeaderCollection Events
[image]

Public Events

Name | Description
CollectionChanged | INotifyCollectionChanged.CollectionChanged implementation.

See Also

HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.CollectionChanged Event

HeaderCollection.CollectionChanged Event
[image]

INotifyCollectionChanged.CollectionChanged implementation.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event NotifyCollectionChangedEventHandler CollectionChanged

Visual Basic [image] Copy Code

Public Event CollectionChanged As NotifyCollectionChangedEventHandler

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.ICell Interface

ICell Interface
[image]

Defines a base for cells in a lane list.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface ICell

Visual Basic [image] Copy Code

Public Interface ICell

Inheritors

MindFusion.Diagramming.Lanes.Cell

See Also

ICell Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.ICell Members

ICell Members
Properties
[image]

Defines a base for cells in a lane list.

The following tables list the members exposed by the ICell type.

Public Properties

Name | Description
Style | Gets or sets the Style of the cell or group of cells.

See Also

ICell Interface
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.ICell Properties

ICell Properties
[image]

Public Properties

Name | Description
Style | Gets or sets the Style of the cell or group of cells.

See Also

ICell Interface
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.ICell.Style Property

ICell.Style Property
[image]

Gets or sets the Style of the cell or group of cells.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

Style Style { get; set; }

Visual Basic [image] Copy Code

Property Style As Style

Property Value

An instance of the Lanes.Style class that specifies the style of this cell.

Remarks

The Item property of the Grid class lets you access a group of cells through a single ICell reference, which lets you set the style of all cells in the group with a single assignment.

See Also

ICell Members
ICell Interface
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.LaneGridCellPresenter Class

LaneGridCellPresenter Class
[image]

Renders the content of lane-grid cells.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LaneGridCellPresenter : Control

Visual Basic [image] Copy Code

Public Class LaneGridCellPresenter
Inherits Control

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
MindFusion.Diagramming.Lanes.LaneGridCellPresenter

See Also

LaneGridCellPresenter Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.LaneGridCellPresenter Members

LaneGridCellPresenter Members
Constructors
[image]

Renders the content of lane-grid cells.

The following tables list the members exposed by the LaneGridCellPresenter type.

Public Constructors

Name | Description
LaneGridCellPresenter | Initializes a new instance of the LaneGridCellPresenter class.

See Also

LaneGridCellPresenter Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.LaneGridCellPresenter Constructor

LaneGridCellPresenter Constructor
[image]

Initializes a new instance of the LaneGridCellPresenter class.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LaneGridCellPresenter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LaneGridCellPresenter Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.LaneGridHeaderPresenter Class

LaneGridHeaderPresenter Class
[image]

Renders the content of lane headers.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LaneGridHeaderPresenter : Control

Visual Basic [image] Copy Code

Public Class LaneGridHeaderPresenter
Inherits Control

Inheritance Hierarchy

System.Object
Windows.UI.Xaml.DependencyObject
Windows.UI.Xaml.UIElement
Windows.UI.Xaml.FrameworkElement
Windows.UI.Xaml.Controls.Control
MindFusion.Diagramming.Lanes.LaneGridHeaderPresenter

See Also

LaneGridHeaderPresenter Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.LaneGridHeaderPresenter Members

LaneGridHeaderPresenter Members
Constructors
[image]

Renders the content of lane headers.

The following tables list the members exposed by the LaneGridHeaderPresenter type.

Public Constructors

Name | Description
LaneGridHeaderPresenter | Initializes a new instance of the LaneGridHeaderPresenter class.

See Also

LaneGridHeaderPresenter Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.LaneGridHeaderPresenter Constructor

LaneGridHeaderPresenter Constructor
[image]

Initializes a new instance of the LaneGridHeaderPresenter class.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LaneGridHeaderPresenter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LaneGridHeaderPresenter Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.ResizeType Enumeration

ResizeType Enumeration
[image]

Specifies how to resize child columns and rows in the lanes grid when their parent column or row is resized.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum ResizeType

Visual Basic [image] Copy Code

Public Enum ResizeType

Members

Member name | Description
Fixed | The header's size (width or height) is fixed and does not change when its parent header is being resized unless all its siblings have fixed size too.
Proportional | The header resizes in proportion to its parent header.

See Also

MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style Class

Style Class
[image]

Encapsulates the appearance properties of an element in a lane grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Style : INotifyPropertyChanged

Visual Basic [image] Copy Code

Public Class Style
Implements INotifyPropertyChanged

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Lanes.Style

See Also

Style Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style Members

Style Members
Constructors Properties Events
[image]

Encapsulates the appearance properties of an element in a lane grid.

The following tables list the members exposed by the Style type.

Public Constructors

Name | Description
Style | Initializes a new instance of the Style class.

Public Properties

Name | Description
BackgroundBrush | Gets or sets the background Brush of this style.
BottomBorderPen | Gets or sets the Pen for drawing the bottom border for this style.
LeftBorderPen | Gets or sets the Pen for drawing the left border for this style.
RightBorderPen | Gets or sets the Pen for drawing the right border for this style.
TopBorderPen | Gets or sets the Pen for drawing the top border for this style.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style Constructor

Style Constructor
[image]

Initializes a new instance of the Style class.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Style ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style Properties

Style Properties
[image]

Public Properties

Name | Description
BackgroundBrush | Gets or sets the background Brush of this style.
BottomBorderPen | Gets or sets the Pen for drawing the bottom border for this style.
LeftBorderPen | Gets or sets the Pen for drawing the left border for this style.
RightBorderPen | Gets or sets the Pen for drawing the right border for this style.
TopBorderPen | Gets or sets the Pen for drawing the top border for this style.

See Also

Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.BackgroundBrush Property

Style.BackgroundBrush Property
[image]

Gets or sets the background Brush of this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Brush BackgroundBrush { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property BackgroundBrush As Brush

Property Value

An instance of the Windows.UI.Xaml.Media.Brush class.

Remarks

You can assign to this property an instance of one of the following classes: BitmapCacheBrush, GradientBrush, SolidColorBrush, or TileBrush, located in the Windows.UI.Xaml.Media namespace.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.BottomBorderPen Property

Style.BottomBorderPen Property
[image]

Gets or sets the Pen for drawing the bottom border for this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Pen BottomBorderPen { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property BottomBorderPen As Pen

Property Value

An instance of the Windows.UI.Xaml.Media.Pen class.

Remarks

The property refers to a Pen used to paint the bottom border of a cell.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.LeftBorderPen Property

Style.LeftBorderPen Property
[image]

Gets or sets the Pen for drawing the left border for this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Pen LeftBorderPen { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property LeftBorderPen As Pen

Property Value

An instance of the Windows.UI.Xaml.Media.Pen class.

Remarks

The property refers to a Pen used for painting the left border of a cell.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.RightBorderPen Property

Style.RightBorderPen Property
[image]

Gets or sets the Pen for drawing the right border for this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Pen RightBorderPen { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property RightBorderPen As Pen

Property Value

An instance of the Windows.UI.Xaml.Media.Pen class.

Remarks

The property refers to the Pen used for painting the right border of a cell.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.TopBorderPen Property

Style.TopBorderPen Property
[image]

Gets or sets the Pen for drawing the top border for this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Pen TopBorderPen { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property TopBorderPen As Pen

Property Value

An instance of the Windows.UI.Xaml.Media.Pen class.

Remarks

The property refers to the Pen used for painting the top border of a cell.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style Events

Style Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.PropertyChanged Event

Style.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Layout Namespace

MindFusion.Diagramming.Layout Namespace
Classes Interfaces Delegates Enumerations

Classes

Class | Description
AnnealLayout | Implements a simulated annealing graph layout algorithm.
CascadeLayout | Performs cascading layout on simple, connected graphs.
CircularLayout | Implements a circular graph layout algorithm. Nodes are distributed evenly on the circumference of a circle at positions that result in as few link crossing as possible.
CompositeLayout | Implements a multi-level graph layout algorithm.
DecisionLayout | Implements a flowchart layout algorithm.
FlowchartLayout | FlowchartLayout can be used to arrange flowcharts representing program source code.
FractalLayout | A tree layout algorithm that places child nodes symmetrically around their parent node.
GridLayout | Implements a grid graph layout algorithm.
HierarchicalLayout | Performs hierarchical layout on simple, connected, level-planar graphs.
LaneGrid | Represents an ISwimlaneGrid which operates on a MindFusion.Diagramming.Lanes.Grid object.
LayeredLayout | Implements a layered graph layout algorithm.
LayeredLayoutStatistics | Encapsulates information about a layered layout which has already complete.
Layout | The base class for all layout classes.
OneWayLayout | Implements a one-way graph layout algorithm.
OrthogonalLayout | Implements an orthogonal graph layout algorithm. Each link is drawn as a chain of alternating horizontal and vertical segments. Nodes are placed in a way that facilitates few links bends and crossings.
OrthogonalRouter | Implements an orthogonal link routing algorithm.
Path | Represents a sequence of connected DiagramNode and DiagramLink elements.
PathFinder | Provides methods that help you find paths and cycles in a graph.
SolarLayout | A tree layout algorithm that places child nodes around their parent node, such that the child nodes do not overlap. The algorithm optionally bends the links to prevent them from crossing nodes.
SpringLayout | Implements the Spring-Embedder graph layout algorithm.
SwimlaneLayout | Implements an algorithm which arranges nodes in lanes.
TopologicalLayout | Implements a topological ordering.
TreeLayout | Implements several algorithms for arranging tree structures.
TreeMapLayout | Implements a tree map layout algorithm.
TriangularLayout | Performs triangular layout on simple, connected graphs.

Interfaces

Interface | Description
ILayout | Common interface for all layout classes.
ISwimlaneGrid | Represents an object which can be used by a SwimlaneLayout to adjust the corresponding swimlane grid.

Delegates

Delegate | Description
LayoutLink | Represents methods that are called by the layout algorithms when the position of a link changes.
LayoutNode | Represents methods that are called by the layout algorithms when the position of a node changes.
LayoutProgress | Represents methods that are called to report on progress of layout algorithms.
LayoutSubgraph | Represents methods that are called by the layout algorithms in order to perform custom arrangement of a subgraph.

Enumerations

Enumeration | Description
Direction | Specifies a layout direction.
LayeredLayoutLinkType | Specifies the style of the links after they are laid out.
MultipleGraphsPlacement | Specifies graph orientation.
Orientation | Specifies axial orientation.
SpringLayoutLinkType | Specifies the style of the diagram links after they are laid out.
TreeLayoutBalance | Specifies how to order child nodes in order to produce tree layouts with custom balance.
TreeLayoutDirections | Specifies the direction of a tree layout.
TreeLayoutLinkType | Specifies the shape of the diagram links after they are laid out.
TreeLayoutType | Specifies the type of a tree layout.


MindFusion.Diagramming.Layout.AnnealLayout Class

AnnealLayout Class
Remarks See Also
[image]

Implements a simulated annealing graph layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class AnnealLayout : Layout

Visual Basic [image] Copy Code

Public Class AnnealLayout
Inherits Layout

Remarks

Simulated Annealing is a general-purpose optimization method used to solve large-scale combinatorial problems by simulating the process of heating and cooling of metal to achieve freedom from defects. Finding a nice arrangement of a graph is a combinatorial problem that can be reduced to assigning costs to graph configurations and finding the minimum cost configuration. In that case, a cost is assigned to a graph configuration by evaluating different aesthetic criteria such as distance between nodes, length of links and the number of link crossings.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.AnnealLayout

See Also

AnnealLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout Members

AnnealLayout Members
Constructors Properties Methods
[image]

Implements a simulated annealing graph layout algorithm.

The following tables list the members exposed by the AnnealLayout type.

Public Constructors

Name | Description
AnnealLayout | Initializes a new instance of the AnnealLayout class.

Public Properties

Name | Description
ApproximateLinkLength | Gets or sets a value indicating whether the layout should approximate the length of graph links by calculating the distance between the centers of their incident nodes.
BoundaryFactor | Gets or sets a value indicating the importance of the distance between nodes and the layout area boundaries, relative to the other criteria considered by the algorithm.
CrossingLinksCost | Gets or sets a value indicating the importance of the low number of link crossings, relative to the other criteria considered by the algorithm.
DistributionFactor | Gets or sets a value indicating the importance of the node distribution, relative to the other criteria considered by the algorithm.
GatherStatistics | Specifies whether the layout should gather statistics while running.
InitialTemperature | Gets or sets the initial temperature of the simulated annealing process.
IterationsPerStage | Gets or sets how many node shift iterations to perform at each stage of the algorithm.
LayoutArea | Gets or sets the size of the layout area.
LinkLengthFactor | Gets or sets a value indicating the importance of the short length of links, relative to the other criteria considered by the algorithm.
Name | Gets a user-friendly name of the layout.
NodeLinkCrossingCost | Gets or sets a value indicating the importance of low number of overlaps between links and nodes relative to the other criteria considered by the algorithm.
NodeLinkDistFactor | Gets or sets a value indicating the importance of the distance between nodes and links, relative to the other criteria considered by the algorithm.
Randomize | Gets or sets a value indicating whether the nodes should be placed at random positions when the layout routine starts.
Root | Gets or sets a node indicating which subgraph of the diagram should be laid out.
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.
Stages | Gets or sets how many cool-down stages the algorithm should simulate.
Statistics | Returns statistics about the layout execution and end results.
TemperatureScale | Gets or sets how much the simulated temperature is decreased at each stage of the algorithm.
WidthHeightRatio | Gets or sets what width/height ratio the layout area should have.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

Public Methods

Name | Description
BeginArrange | Initializes the layout object for a step-by-step execution.
EndArrange | Completes the step-by-step execution.
Iterate | Runs one or more layout iterations.

Inherited Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)

See Also

AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout Constructor

AnnealLayout Constructor
[image]

Initializes a new instance of the AnnealLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnnealLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout Methods

AnnealLayout Methods
[image]

Public Methods

Name | Description
BeginArrange | Initializes the layout object for a step-by-step execution.
EndArrange | Completes the step-by-step execution.
Iterate | Runs one or more layout iterations.

Inherited Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)

See Also

AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.BeginArrange Method

AnnealLayout.BeginArrange Method
[image]

Initializes the layout object for a step-by-step execution.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool BeginArrange (
Diagram diagram,
DiagramItemCollection items
)

Visual Basic [image] Copy Code

Public Function BeginArrange ( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram
The Diagram that will be arranged.
items

A collection of nodes and links from diagram that define the subgraph to arrange.

Return Value

true if the layout object has been initialized successfully; otherwise, false.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.EndArrange Method

AnnealLayout.EndArrange Method
[image]

Completes the step-by-step execution.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void EndArrange ()

Visual Basic [image] Copy Code

Public Sub EndArrange ()

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.Iterate Method

AnnealLayout.Iterate Method
[image]

Runs one or more layout iterations.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Iterate (
int iterationFrom,
int iterationTo
)

Visual Basic [image] Copy Code

Public Sub Iterate( _
iterationFrom As Integer, _
iterationTo As Integer _
)

Parameters

iterationFrom

Specifies from which iteration to start.

iterationTo

Specifies at which iteration to stop.

Remarks

Use this method to create an animation of the layout process, for example, by calling it from a timer. Call BeginArrange to prepare the layout object for use of Iterate, and call EndArrange when done. Each call to Iterate starts from the iteration next to the one where the previous call has stopped.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout Properties

AnnealLayout Properties
[image]

Public Properties

Name | Description
ApproximateLinkLength | Gets or sets a value indicating whether the layout should approximate the length of graph links by calculating the distance between the centers of their incident nodes.
BoundaryFactor | Gets or sets a value indicating the importance of the distance between nodes and the layout area boundaries, relative to the other criteria considered by the algorithm.
CrossingLinksCost | Gets or sets a value indicating the importance of the low number of link crossings, relative to the other criteria considered by the algorithm.
DistributionFactor | Gets or sets a value indicating the importance of the node distribution, relative to the other criteria considered by the algorithm.
GatherStatistics | Specifies whether the layout should gather statistics while running.
InitialTemperature | Gets or sets the initial temperature of the simulated annealing process.
IterationsPerStage | Gets or sets how many node shift iterations to perform at each stage of the algorithm.
LayoutArea | Gets or sets the size of the layout area.
LinkLengthFactor | Gets or sets a value indicating the importance of the short length of links, relative to the other criteria considered by the algorithm.
Name | Gets a user-friendly name of the layout.
NodeLinkCrossingCost | Gets or sets a value indicating the importance of low number of overlaps between links and nodes relative to the other criteria considered by the algorithm.
NodeLinkDistFactor | Gets or sets a value indicating the importance of the distance between nodes and links, relative to the other criteria considered by the algorithm.
Randomize | Gets or sets a value indicating whether the nodes should be placed at random positions when the layout routine starts.
Root | Gets or sets a node indicating which subgraph of the diagram should be laid out.
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.
Stages | Gets or sets how many cool-down stages the algorithm should simulate.
Statistics | Returns statistics about the layout execution and end results.
TemperatureScale | Gets or sets how much the simulated temperature is decreased at each stage of the algorithm.
WidthHeightRatio | Gets or sets what width/height ratio the layout area should have.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

See Also

AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.ApproximateLinkLength Property

AnnealLayout.ApproximateLinkLength Property
[image]

Gets or sets a value indicating whether the layout should approximate the length of graph links by calculating the distance between the centers of their incident nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ApproximateLinkLength { get; set; }

Visual Basic [image] Copy Code

Public Property ApproximateLinkLength As Boolean

Property Value

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.BoundaryFactor Property

AnnealLayout.BoundaryFactor Property
[image]

Gets or sets a value indicating the importance of the distance between nodes and the layout area boundaries, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double BoundaryFactor { get; set; }

Visual Basic [image] Copy Code

Public Property BoundaryFactor As Double

Property Value

Remarks

Assigning a larger value to this property will make the algorithm choose graph configurations in which nodes are placed farther from the layout area bounds, that is, nodes will tend to gather in the center of the layout area.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.CrossingLinksCost Property

AnnealLayout.CrossingLinksCost Property
[image]

Gets or sets a value indicating the importance of the low number of link crossings, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double CrossingLinksCost { get; set; }

Visual Basic [image] Copy Code

Public Property CrossingLinksCost As Double

Property Value

Remarks

Assigning a larger value to this property will make the algorithm choose graph configurations with fewer link crossings.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.DefaultMarginValue Property

AnnealLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.DistributionFactor Property

AnnealLayout.DistributionFactor Property
[image]

Gets or sets a value indicating the importance of the node distribution, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double DistributionFactor { get; set; }

Visual Basic [image] Copy Code

Public Property DistributionFactor As Double

Property Value

Remarks

Assigning a larger value to this property will make the algorithm choose graph configurations in which the nodes are placed farther one from another.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.GatherStatistics Property

AnnealLayout.GatherStatistics Property
[image]

Specifies whether the layout should gather statistics while running.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool GatherStatistics { get; set; }

Visual Basic [image] Copy Code

Public Property GatherStatistics As Boolean

Property Value

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.InitialTemperature Property

AnnealLayout.InitialTemperature Property
[image]

Gets or sets the initial temperature of the simulated annealing process.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double InitialTemperature { get; set; }

Visual Basic [image] Copy Code

Public Property InitialTemperature As Double

Property Value

Remarks

A low initial temperature prevents nodes from moving far from their initial position.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.IterationsPerStage Property

AnnealLayout.IterationsPerStage Property
[image]

Gets or sets how many node shift iterations to perform at each stage of the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int IterationsPerStage { get; set; }

Visual Basic [image] Copy Code

Public Property IterationsPerStage As Integer

Property Value

Remarks

IterationsPerStage specifies how many node configurations to evaluate at each stage of the temperature cool-down simulation.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.LayoutArea Property

AnnealLayout.LayoutArea Property
[image]

Gets or sets the size of the layout area.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect LayoutArea { get; set; }

Visual Basic [image] Copy Code

Public Property LayoutArea As Rect

Property Value

A Windows.UI.Xaml.Rect representing the boundaries of the layout area.

Remarks

If the layout area is not explicitly set, the algorithm will choose one suitable for the graph size.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.LinkLengthFactor Property

AnnealLayout.LinkLengthFactor Property
[image]

Gets or sets a value indicating the importance of the short length of links, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LinkLengthFactor { get; set; }

Visual Basic [image] Copy Code

Public Property LinkLengthFactor As Double

Property Value

Remarks

Assigning a larger value to this property will make the algorithm choose graph configurations in which links are shorter.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.Name Property

AnnealLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.NodeLinkCrossingCost Property

AnnealLayout.NodeLinkCrossingCost Property
[image]

Gets or sets a value indicating the importance of low number of overlaps between links and nodes relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeLinkCrossingCost { get; set; }

Visual Basic [image] Copy Code

Public Property NodeLinkCrossingCost As Double

Property Value

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.NodeLinkDistFactor Property

AnnealLayout.NodeLinkDistFactor Property
[image]

Gets or sets a value indicating the importance of the distance between nodes and links, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeLinkDistFactor { get; set; }

Visual Basic [image] Copy Code

Public Property NodeLinkDistFactor As Double

Property Value

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.Randomize Property

AnnealLayout.Randomize Property
[image]

Gets or sets a value indicating whether the nodes should be placed at random positions when the layout routine starts.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Randomize { get; set; }

Visual Basic [image] Copy Code

Public Property Randomize As Boolean

Property Value

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.Root Property

AnnealLayout.Root Property
[image]

Gets or sets a node indicating which subgraph of the diagram should be laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As DiagramNode

Property Value

Remarks

If a root nodes is specified and SplitGraph is enabled, only the graph that contains the root node is laid out by Arrange.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.SplitGraph Property

AnnealLayout.SplitGraph Property
[image]

Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SplitGraph { get; set; }

Visual Basic [image] Copy Code

Public Property SplitGraph As Boolean

Property Value

Remarks

If this property is set to true, each independent graph in the diagram is laid out in its own layout area. Otherwise all subgraphs are arranged in the same layout area.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.Stages Property

AnnealLayout.Stages Property
[image]

Gets or sets how many cool-down stages the algorithm should simulate.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Stages { get; set; }

Visual Basic [image] Copy Code

Public Property Stages As Integer

Property Value

Remarks

At each stage the algorithm evaluates different graph arrangements produced by modifying the best configuration from the previous stage.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.Statistics Property

AnnealLayout.Statistics Property
[image]

Returns statistics about the layout execution and end results.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnnealLayoutStatistics Statistics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Statistics As AnnealLayoutStatistics

Property Value

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.TemperatureScale Property

AnnealLayout.TemperatureScale Property
[image]

Gets or sets how much the simulated temperature is decreased at each stage of the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double TemperatureScale { get; set; }

Visual Basic [image] Copy Code

Public Property TemperatureScale As Double

Property Value

Remarks

This value should be in the interval (0, 1). The algorithm produces better results when running for many Stages with a gradual temperature decrease, that is, a TemperatureScale closer to 1.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.WidthHeightRatio Property

AnnealLayout.WidthHeightRatio Property
[image]

Gets or sets what width/height ratio the layout area should have.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double WidthHeightRatio { get; set; }

Visual Basic [image] Copy Code

Public Property WidthHeightRatio As Double

Property Value

Remarks

If the LayoutArea is not explicitly set, the algorithm will choose one suitable for the graph size. In that case the WidthHeightRatio property specifies how much larger the layout area width should be than its height.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CascadeLayout Class

CascadeLayout Class
Remarks See Also
[image]

Performs cascading layout on simple, connected graphs.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class CascadeLayout : Layout

Visual Basic [image] Copy Code

Public Class CascadeLayout
Inherits Layout

Remarks

CascadeLayout places nodes on a virtual grid and arranges links orthogonally, such that if the source graph is planar all links are guaranteed to have no more than two bends and will not intersect. By default the layout method arranges nodes in rows and link segments in columns; this can be changed by setting the Orientation property.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.CascadeLayout

See Also

CascadeLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CascadeLayout Members

CascadeLayout Members
Constructors Properties Methods
[image]

Performs cascading layout on simple, connected graphs.

The following tables list the members exposed by the CascadeLayout type.

Public Constructors

Name | Description
CascadeLayout | Initializes a new instance of the CascadeLayout class.

Public Properties

Name | Description
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged graph.
Padding | Gets or sets the spacing between nodes in adjacent layers.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

Inherited Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)

See Also

CascadeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CascadeLayout Constructor

CascadeLayout Constructor
[image]

Initializes a new instance of the CascadeLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CascadeLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CascadeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CascadeLayout Properties

CascadeLayout Properties
[image]

Public Properties

Name | Description
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged graph.
Padding | Gets or sets the spacing between nodes in adjacent layers.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

See Also

CascadeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CascadeLayout.DefaultMarginValue Property

CascadeLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

CascadeLayout Members
CascadeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CascadeLayout.Name Property

CascadeLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Cascade layout".

See Also

CascadeLayout Members
CascadeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CascadeLayout.Orientation Property

CascadeLayout.Orientation Property
[image]

Gets or sets the orientation of the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Vertical.

See Also

CascadeLayout Members
CascadeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CascadeLayout.Padding Property

CascadeLayout.Padding Property
[image]

Gets or sets the spacing between nodes in adjacent layers.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Padding { get; set; }

Visual Basic [image] Copy Code

Public Property Padding As Double

Property Value

The default value is 55.

See Also

CascadeLayout Members
CascadeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout Class

CircularLayout Class
[image]

Implements a circular graph layout algorithm. Nodes are distributed evenly on the circumference of a circle at positions that result in as few link crossing as possible.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class CircularLayout : Layout

Visual Basic [image] Copy Code

Public Class CircularLayout
Inherits Layout

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.CircularLayout

See Also

CircularLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout Members

CircularLayout Members
Constructors Properties Methods
[image]

Implements a circular graph layout algorithm. Nodes are distributed evenly on the circumference of a circle at positions that result in as few link crossing as possible.

The following tables list the members exposed by the CircularLayout type.

Public Constructors

Name | Description
CircularLayout | Initializes a new instance of the CircularLayout class with the default settings.

Public Properties

Name | Description
AutoRadiusFactor | Gets or sets a multiplier for the automatically calculated radius when Radius is set to 0.
Name | Gets a user-friendly name of the layout.
Radius | Gets or sets the radius of the layout circle.
SiftingRounds | Gets or sets the number of sifting rounds to perform during the layout.
SplitGraph | Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

Inherited Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)

See Also

CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout Constructor

CircularLayout Constructor
[image]

Initializes a new instance of the CircularLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CircularLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout Properties

CircularLayout Properties
[image]

Public Properties

Name | Description
AutoRadiusFactor | Gets or sets a multiplier for the automatically calculated radius when Radius is set to 0.
Name | Gets a user-friendly name of the layout.
Radius | Gets or sets the radius of the layout circle.
SiftingRounds | Gets or sets the number of sifting rounds to perform during the layout.
SplitGraph | Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

See Also

CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout.AutoRadiusFactor Property

CircularLayout.AutoRadiusFactor Property
[image]

Gets or sets a multiplier for the automatically calculated radius when Radius is set to 0.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double AutoRadiusFactor { get; set; }

Visual Basic [image] Copy Code

Public Property AutoRadiusFactor As Double

Property Value

See Also

CircularLayout Members
CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout.DefaultMarginValue Property

CircularLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

CircularLayout Members
CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout.Name Property

CircularLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

See Also

CircularLayout Members
CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout.Radius Property

CircularLayout.Radius Property
[image]

Gets or sets the radius of the layout circle.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Radius { get; set; }

Visual Basic [image] Copy Code

Public Property Radius As Double

Property Value

A double value specifying the radius. The default value is 225.

Remarks

If this property is set to 0, the layout will try to find an appropriate radius depending on the number and size of the participating nodes.

See Also

CircularLayout Members
CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout.SiftingRounds Property

CircularLayout.SiftingRounds Property
[image]

Gets or sets the number of sifting rounds to perform during the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int SiftingRounds { get; set; }

Visual Basic [image] Copy Code

Public Property SiftingRounds As Integer

Property Value

An integer value specifying the number of sifting rounds. The default value is 1.

Remarks

After calculating the initial placement of nodes using a fast but inaccurate layout function, the algorithm can run a few sifting rounds to reduce the link crossings, as set in this property.

See Also

CircularLayout Members
CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout.SplitGraph Property

CircularLayout.SplitGraph Property
[image]

Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SplitGraph { get; set; }

Visual Basic [image] Copy Code

Public Property SplitGraph As Boolean

Property Value

See Also

CircularLayout Members
CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout Class

CompositeLayout Class
Remarks See Also
[image]

Implements a multi-level graph layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class CompositeLayout : Layout

Visual Basic [image] Copy Code

Public Class CompositeLayout
Inherits Layout

Remarks

CompositeLayout partitions the diagram into several subgraphs and applies the algorithm specified via the SubgraphLayout property on each part. If the part is a tree, it is arranged using the algorithm specified via the SubtreeLayout property, which is set to a radial TreeLayout instance by default. Finally the algorithm specified via MasterLayout is applied on the graph that represents the overall partition. By running the polynomial-complexity layout algorithms on small subgraphs, CompositeLayout is able to process a large graph much faster than if a layout algorithm is applied on the whole graph.

CompositeLayout can run on custom partitions specified as lists of nodes, or automatically partition the diagram via two automatic methods based on graph connectivity and graph path lengths. Set the PartitionMethod and CustomPartition properties to specify how the diagram should be partitioned.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.CompositeLayout

See Also

CompositeLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout Members

CompositeLayout Members
Constructors Properties Methods
[image]

Implements a multi-level graph layout algorithm.

The following tables list the members exposed by the CompositeLayout type.

Public Constructors

Name | Description
CompositeLayout | Initializes a new instance of the CompositeLayout class.

Public Properties

Name | Description
BendLinks | Gets or sets a value indicating whether the links in the trees from the additional partitioning pass will bend to avoid crossing leaves in the same tree.
CustomLayout | Gets or sets a custom layout method that should be invoked to arrange subgraphs.
CustomPartition | Gets or sets the custom partition to use when PartitionMethod is set to Custom.
DesiredSubgraphSize | Gets or sets the preferred number of nodes in the subgraphs allocated by the layout algorithm.
EmphasizeTrees | Gets or sets a value indicating whether a cut-vertex between tree and non-tree subgraphs should be considered part of the tree.
MasterLayout | Gets or sets a layout that should be applied globally to the diagram.
Name | Gets a user-friendly name of the layout.
PartitionMethod | Gets or sets the partitioning method used to decompose the diagram into subgraphs.
RotateSubgraphs | Gets or sets a value indicating whether subgraphs are rotated to minimize intersections with cross-partition links.
SubgraphLayout | Gets or sets a layout that should be applied to general subgraphs.
SubtreeLayout | Gets or sets a layout that should be applied to subgraphs representing trees.
Tolerance | A multiplier applied to DesiredSubgraphSize to define the allowed subgraph size range.
UseAdditionalPartitioning | Gets or sets a value indicating whether to use an additional partitioning pass on the result of the initial partitioning. This additional partitioning is simplified - it only looks for trees with depth 2.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

Inherited Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)

See Also

CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout Constructor

CompositeLayout Constructor
[image]

Initializes a new instance of the CompositeLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CompositeLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout Properties

CompositeLayout Properties
[image]

Public Properties

Name | Description
BendLinks | Gets or sets a value indicating whether the links in the trees from the additional partitioning pass will bend to avoid crossing leaves in the same tree.
CustomLayout | Gets or sets a custom layout method that should be invoked to arrange subgraphs.
CustomPartition | Gets or sets the custom partition to use when PartitionMethod is set to Custom.
DesiredSubgraphSize | Gets or sets the preferred number of nodes in the subgraphs allocated by the layout algorithm.
EmphasizeTrees | Gets or sets a value indicating whether a cut-vertex between tree and non-tree subgraphs should be considered part of the tree.
MasterLayout | Gets or sets a layout that should be applied globally to the diagram.
Name | Gets a user-friendly name of the layout.
PartitionMethod | Gets or sets the partitioning method used to decompose the diagram into subgraphs.
RotateSubgraphs | Gets or sets a value indicating whether subgraphs are rotated to minimize intersections with cross-partition links.
SubgraphLayout | Gets or sets a layout that should be applied to general subgraphs.
SubtreeLayout | Gets or sets a layout that should be applied to subgraphs representing trees.
Tolerance | A multiplier applied to DesiredSubgraphSize to define the allowed subgraph size range.
UseAdditionalPartitioning | Gets or sets a value indicating whether to use an additional partitioning pass on the result of the initial partitioning. This additional partitioning is simplified - it only looks for trees with depth 2.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

See Also

CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout.BendLinks Property

CompositeLayout.BendLinks Property
[image]

Gets or sets a value indicating whether the links in the trees from the additional partitioning pass will bend to avoid crossing leaves in the same tree.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool BendLinks { get; set; }

Visual Basic [image] Copy Code

Public Property BendLinks As Boolean

Property Value

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout.CustomLayout Property

CompositeLayout.CustomLayout Property
[image]

Gets or sets a custom layout method that should be invoked to arrange subgraphs.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LayoutSubgraph CustomLayout { get; set; }

Visual Basic [image] Copy Code

Public Property CustomLayout As LayoutSubgraph

Property Value

A LayoutSubgraph delegate object.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout.CustomPartition Property

CompositeLayout.CustomPartition Property
[image]

Gets or sets the custom partition to use when PartitionMethod is set to Custom.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<DiagramNodeCollection> CustomPartition { get; set; }

Visual Basic [image] Copy Code

Public Property CustomPartition As List(Of DiagramNodeCollection)

Property Value

A list of DiagramNodeCollection objects that partitions the diagram into subgraphs.

Remarks

This value is used if PartitionMethod is set to Custom.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout.DefaultMarginValue Property

CompositeLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

Returns new Size(5, 5).

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout.DesiredSubgraphSize Property

CompositeLayout.DesiredSubgraphSize Property
[image]

Gets or sets the preferred number of nodes in the subgraphs allocated by the layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int DesiredSubgraphSize { get; set; }

Visual Basic [image] Copy Code

Public Property DesiredSubgraphSize As Integer

Property Value

An integer value specifying the desired number of nodes in each subgraph.

Remarks

This property is considered by the automatic partitioning algorithm when generating subgraphs. Usually the subgraphs won't contain exactly as many nodes, but are within the Tolerance range around the property value.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout.EmphasizeTrees Property

CompositeLayout.EmphasizeTrees Property
[image]

Gets or sets a value indicating whether a cut-vertex between tree and non-tree subgraphs should be considered part of the tree.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EmphasizeTrees { get; set; }

Visual Basic [image] Copy Code

Public Property EmphasizeTrees As Boolean

Property Value

true to add cut-vertices to trees, otherwise false. The default value is true.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace
SubtreeLayout Property


MindFusion.Diagramming.Layout.CompositeLayout.MasterLayout Property

CompositeLayout.MasterLayout Property
[image]

Gets or sets a layout that should be applied globally to the diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Layout MasterLayout { get; set; }

Visual Basic [image] Copy Code

Public Property MasterLayout As Layout

Property Value

An instance of Layout-derived class. The default is AnnealLayout.

Remarks

Each subset in the layout partition is considered a node in a graph representing the diagram. MasterLayout is used to arrange that graph, while SubgraphLayout and SubtreeLayout are applied on the partition subsets. Since in the general case subsets will occupy areas of varying size, MasterLayout should be set to an instance of a layout class that can handle nodes of non-uniform dimensions.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout.Name Property

CompositeLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Composite layout".

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout.PartitionMethod Property

CompositeLayout.PartitionMethod Property
[image]

Gets or sets the partitioning method used to decompose the diagram into subgraphs.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PartitionMethod PartitionMethod { get; set; }

Visual Basic [image] Copy Code

Public Property PartitionMethod As PartitionMethod

Property Value

A member of the PartitionMethod enumeration. The default value is BiconnectedComponents.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout.RotateSubgraphs Property

CompositeLayout.RotateSubgraphs Property
[image]

Gets or sets a value indicating whether subgraphs are rotated to minimize intersections with cross-partition links.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RotateSubgraphs { get; set; }

Visual Basic [image] Copy Code

Public Property RotateSubgraphs As Boolean

Property Value

true to rotate subgraphs, otherwise false. The default value is false.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout.SubgraphLayout Property

CompositeLayout.SubgraphLayout Property
[image]

Gets or sets a layout that should be applied to general subgraphs.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Layout SubgraphLayout { get; set; }

Visual Basic [image] Copy Code

Public Property SubgraphLayout As Layout

Property Value

An instance of Layout-derived class. The default is CircularLayout.

Remarks

If the subgraph is a tree, CompositeLayout uses SubtreeLayout to arrange it.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace
MasterLayout Property


MindFusion.Diagramming.Layout.CompositeLayout.SubtreeLayout Property

CompositeLayout.SubtreeLayout Property
[image]

Gets or sets a layout that should be applied to subgraphs representing trees.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Layout SubtreeLayout { get; set; }

Visual Basic [image] Copy Code

Public Property SubtreeLayout As Layout

Property Value

An instance of Layout-derived class. The default is radial TreeLayout.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace
MasterLayout Property
SubgraphLayout Property
PartitionMethod Property


MindFusion.Diagramming.Layout.CompositeLayout.Tolerance Property

CompositeLayout.Tolerance Property
[image]

A multiplier applied to DesiredSubgraphSize to define the allowed subgraph size range.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Tolerance { get; set; }

Visual Basic [image] Copy Code

Public Property Tolerance As Double

Property Value

A double value specifying the tolerance range. The default is 0.2.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CompositeLayout.UseAdditionalPartitioning Property

CompositeLayout.UseAdditionalPartitioning Property
[image]

Gets or sets a value indicating whether to use an additional partitioning pass on the result of the initial partitioning. This additional partitioning is simplified - it only looks for trees with depth 2.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool UseAdditionalPartitioning { get; set; }

Visual Basic [image] Copy Code

Public Property UseAdditionalPartitioning As Boolean

Property Value

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout Class

DecisionLayout Class
Remarks See Also
[image]

Implements a flowchart layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DecisionLayout : Layout

Visual Basic [image] Copy Code

Public Class DecisionLayout
Inherits Layout

Remarks

This algorithm arranges simple flowcharts consisting of decision boxes with up to three outgoing links per node and activity boxes with a single outgoing link per node. The nodes are arranged in columns and rows, whose distance depends on the HorizontalPadding and VerticalPadding property values. When links share the same row or column, they are placed at a distance specified via LinkPadding.

The layout arranges nodes recursively starting from StartNode. If StartNode is not specified, the algorithm selects the root of the deepest branch of the graph's spanning tree as start node.

The overall orientation of the layout can be set via the Orientation property. There is no distinction made between yes/no links, and the node sides by which links are aligned depend only on the order of links in OutgoingLinks collection. If you have a preferred position for links depending on their yes/no type, make sure the OutgoingLinks collections of nodes are sorted by links' logical values.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.DecisionLayout

See Also

DecisionLayout Members
MindFusion.Diagramming.Layout Namespace
FlowchartLayout Class


MindFusion.Diagramming.Layout.DecisionLayout Members

DecisionLayout Members
Constructors Properties Methods
[image]

Implements a flowchart layout algorithm.

The following tables list the members exposed by the DecisionLayout type.

Public Constructors

Name | Description
DecisionLayout | Initializes a new instance of the DecisionLayout class with the default settings.

Public Properties

Name | Description
HorizontalPadding | Gets or sets the horizontal distance between adjacent nodes.
LinkPadding | Gets or sets the distance between parallel links.
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged diagram.
StartNode | Gets or sets the initial (top-left) node in the arranged diagram.
VerticalPadding | Gets or sets the vertical distance between adjacent nodes.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

Inherited Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)

See Also

DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout Constructor

DecisionLayout Constructor
[image]

Initializes a new instance of the DecisionLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DecisionLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout Properties

DecisionLayout Properties
[image]

Public Properties

Name | Description
HorizontalPadding | Gets or sets the horizontal distance between adjacent nodes.
LinkPadding | Gets or sets the distance between parallel links.
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged diagram.
StartNode | Gets or sets the initial (top-left) node in the arranged diagram.
VerticalPadding | Gets or sets the vertical distance between adjacent nodes.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

See Also

DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout.DefaultMarginValue Property

DecisionLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

Returns new Size(5, 5).

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout.HorizontalPadding Property

DecisionLayout.HorizontalPadding Property
[image]

Gets or sets the horizontal distance between adjacent nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double HorizontalPadding { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalPadding As Double

Property Value

A double value specifying the distance between adjacent nodes in same row. The default value is 45.

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout.LinkPadding Property

DecisionLayout.LinkPadding Property
[image]

Gets or sets the distance between parallel links.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LinkPadding { get; set; }

Visual Basic [image] Copy Code

Public Property LinkPadding As Double

Property Value

A double value specifying the distance between links that share the same row or column. The default value is 6.

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout.Name Property

DecisionLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Decision layout".

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout.Orientation Property

DecisionLayout.Orientation Property
[image]

Gets or sets the orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration specifying the overall layout orientation. The default value is Vertical.

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout.StartNode Property

DecisionLayout.StartNode Property
[image]

Gets or sets the initial (top-left) node in the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode StartNode { get; set; }

Visual Basic [image] Copy Code

Public Property StartNode As DiagramNode

Property Value

A DiagramNode instance specifying the start node.

Remarks

If this property is null, the layout will pick-up the start node automatically.

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout.VerticalPadding Property

DecisionLayout.VerticalPadding Property
[image]

Gets or sets the vertical distance between adjacent nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double VerticalPadding { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalPadding As Double

Property Value

A double value specifying the distance between adjacent nodes in same column. The default value is 45.

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Direction Enumeration

Direction Enumeration
[image]

Specifies a layout direction.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum Direction

Visual Basic [image] Copy Code

Public Enum Direction

Members

Member name | Description
Reversed | Indicates either right-to-left or bottom-to-top direction.
Straight | Indicates either left-to-right or top-to-bottom direction.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout Class

FlowchartLayout Class
Remarks See Also
[image]

FlowchartLayout can be used to arrange flowcharts representing program source code.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class FlowchartLayout : Layout

Visual Basic [image] Copy Code

Public Class FlowchartLayout
Inherits Layout

Remarks

The algorithm recognizes program code -like patterns in the graph, such as loops, sequences and if/switch branchings, and arranges them recursively. FlowchartLayout could be used to arrange other types of graphs as well, though with some restrictions. For example it treats all back links as loops in the code, and expects that they are nested - loop links starting closer to the stop node should end closer to the start node. Another similar restriction is that there shouldn't be any cross-links that connect different branches of a decision sub-graph.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.FlowchartLayout

See Also

FlowchartLayout Members
MindFusion.Diagramming.Layout Namespace
DecisionLayout Class


MindFusion.Diagramming.Layout.FlowchartLayout Members

FlowchartLayout Members
Constructors Properties Methods
[image]

FlowchartLayout can be used to arrange flowcharts representing program source code.

The following tables list the members exposed by the FlowchartLayout type.

Public Constructors

Name | Description
FlowchartLayout | Initializes a new instance of the FlowchartLayout class.

Public Properties

Name | Description
BranchPadding | Gets or sets how much space to leave between adjacent decision branches in the flowchart.
IgnoreRepeatingLinks | Gets or sets a value indicating whether to ignore repeating links.
LinkPadding | Gets or sets how much space to leave between adjacent back links designating nested loops.
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the distance between consecutive nodes in the flowchart.
Orientation | Gets or sets the overall orientation of the arranged diagram.
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

Inherited Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)

See Also

FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout Constructor

FlowchartLayout Constructor
[image]

Initializes a new instance of the FlowchartLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FlowchartLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout Properties

FlowchartLayout Properties
[image]

Public Properties

Name | Description
BranchPadding | Gets or sets how much space to leave between adjacent decision branches in the flowchart.
IgnoreRepeatingLinks | Gets or sets a value indicating whether to ignore repeating links.
LinkPadding | Gets or sets how much space to leave between adjacent back links designating nested loops.
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the distance between consecutive nodes in the flowchart.
Orientation | Gets or sets the overall orientation of the arranged diagram.
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

See Also

FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout.BranchPadding Property

FlowchartLayout.BranchPadding Property
[image]

Gets or sets how much space to leave between adjacent decision branches in the flowchart.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double BranchPadding { get; set; }

Visual Basic [image] Copy Code

Public Property BranchPadding As Double

Property Value

A double value specifying the distance between adjacent branches.

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout.DefaultMarginValue Property

FlowchartLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout.IgnoreRepeatingLinks Property

FlowchartLayout.IgnoreRepeatingLinks Property
[image]

Gets or sets a value indicating whether to ignore repeating links.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IgnoreRepeatingLinks { get; set; }

Visual Basic [image] Copy Code

Public Property IgnoreRepeatingLinks As Boolean

Property Value

true to ignore repeating links, otherwise false. The default value is false.

Remarks

If there are many links connecting the same pair of nodes in the same direction, the analysis of the inherent flowchart structure might fail. In such cases, set this property to true.

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout.LinkPadding Property

FlowchartLayout.LinkPadding Property
[image]

Gets or sets how much space to leave between adjacent back links designating nested loops.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LinkPadding { get; set; }

Visual Basic [image] Copy Code

Public Property LinkPadding As Double

Property Value

A double value specifying the distance between adjacent back links.

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout.Name Property

FlowchartLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout.NodeDistance Property

FlowchartLayout.NodeDistance Property
[image]

Gets or sets the distance between consecutive nodes in the flowchart.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Double

Property Value

A double value specifying the distance between neighbor nodes in the same sequence.

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout.Orientation Property

FlowchartLayout.Orientation Property
[image]

Gets or sets the overall orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Vertical.

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout.SplitGraph Property

FlowchartLayout.SplitGraph Property
[image]

Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SplitGraph { get; set; }

Visual Basic [image] Copy Code

Public Property SplitGraph As Boolean

Property Value

true to arrange each subgraph on its own, otherwise false. The default value is true.

Remarks

If this property is set to true, each independent graph in the diagram is laid out in its own layout area. Otherwise all subgraphs are arranged in the same layout area.

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FractalLayout Class

FractalLayout Class
Remarks See Also
[image]

A tree layout algorithm that places child nodes symmetrically around their parent node.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class FractalLayout : Layout

Visual Basic [image] Copy Code

Public Class FractalLayout
Inherits Layout

Remarks

Nodes at the lowest level are arranged directly in a circle around their parent. At the upper level, the already arranged nodes form branches that are arranged in a circle around the new parent node. The algorithm is recursively repeated till the highest level is reached.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.FractalLayout

See Also

FractalLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FractalLayout Members

FractalLayout Members
Constructors Properties Methods
[image]

A tree layout algorithm that places child nodes symmetrically around their parent node.

The following tables list the members exposed by the FractalLayout type.

Public Constructors

Name | Description
FractalLayout | Initializes a new instance of the FractalLayout class.

Public Properties

Name | Description
Name | Gets a user-friendly name of the layout.
Root | Gets or sets the tree root.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

Inherited Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)

See Also

FractalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FractalLayout Constructor

FractalLayout Constructor
[image]

Initializes a new instance of the FractalLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FractalLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

FractalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FractalLayout Properties

FractalLayout Properties
[image]

Public Properties

Name | Description
Name | Gets a user-friendly name of the layout.
Root | Gets or sets the tree root.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

See Also

FractalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FractalLayout.DefaultMarginValue Property

FractalLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

FractalLayout Members
FractalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FractalLayout.Name Property

FractalLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

See Also

FractalLayout Members
FractalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FractalLayout.Root Property

FractalLayout.Root Property
[image]

Gets or sets the tree root.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As Object

Property Value

See Also

FractalLayout Members
FractalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout Class

GridLayout Class
Remarks See Also
[image]

Implements a grid graph layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class GridLayout : Layout

Visual Basic [image] Copy Code

Public Class GridLayout
Inherits Layout

Remarks

GridLayout arranges diagram nodes in a grid, keeping connected nodes close together. The algorithm strives to achieve a small number of link crossings. It is based on an iterative process whose initial steps shuffle the grid nodes randomly. That can lead to very different results each time the algorithm is run.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.GridLayout

See Also

GridLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout Members

GridLayout Members
Constructors Properties Methods
[image]

Implements a grid graph layout algorithm.

The following tables list the members exposed by the GridLayout type.

Public Constructors

Name | Description
GridLayout | Initializes a new instance of the GridLayout class.

Public Properties

Name | Description
EndNode | Gets or sets the node that is placed at the lower right corner of the grid.
GridSize | Gets or sets the desired distance between adjacent grid points.
Iterations | Gets or sets for how many iterations to run the grid layout algorithm.
Name | Gets a user-friendly name of the layout.
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
Root | Gets or sets a node indicating which subgraph of the diagram should be laid out.
SplitGraph | Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.
StartNode | Gets or sets the node that is placed at the upper left corner of the grid.
TimeLimit | Gets or sets a time-out value for the path-finding part of the grid layout algorithm.
UseLongestPath | Gets or sets a value indicating whether the algorithm should arrange nodes around the longest path in the graph.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

Inherited Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)

See Also

GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout Constructor

GridLayout Constructor
[image]

Initializes a new instance of the GridLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GridLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout Properties

GridLayout Properties
[image]

Public Properties

Name | Description
EndNode | Gets or sets the node that is placed at the lower right corner of the grid.
GridSize | Gets or sets the desired distance between adjacent grid points.
Iterations | Gets or sets for how many iterations to run the grid layout algorithm.
Name | Gets a user-friendly name of the layout.
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
Root | Gets or sets a node indicating which subgraph of the diagram should be laid out.
SplitGraph | Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.
StartNode | Gets or sets the node that is placed at the upper left corner of the grid.
TimeLimit | Gets or sets a time-out value for the path-finding part of the grid layout algorithm.
UseLongestPath | Gets or sets a value indicating whether the algorithm should arrange nodes around the longest path in the graph.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

See Also

GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.DefaultMarginValue Property

GridLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.EndNode Property

GridLayout.EndNode Property
[image]

Gets or sets the node that is placed at the lower right corner of the grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode EndNode { get; set; }

Visual Basic [image] Copy Code

Public Property EndNode As DiagramNode

Property Value

Remarks

If you assign a node to that property, then StartNode cannot be null and must be set too. GridLayout usually produces better layouts if both StartNode and EndNode are null references; in such a case the algorithm automatically selects suitable nodes.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.GridSize Property

GridLayout.GridSize Property
[image]

Gets or sets the desired distance between adjacent grid points.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double GridSize { get; set; }

Visual Basic [image] Copy Code

Public Property GridSize As Double

Property Value

Remarks

When placing a node at a grid position, the node center point is aligned to the grid point at that position.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.Iterations Property

GridLayout.Iterations Property
[image]

Gets or sets for how many iterations to run the grid layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Iterations { get; set; }

Visual Basic [image] Copy Code

Public Property Iterations As Integer

Property Value

Remarks

More iterations would yield better layouts but require more time to complete.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.Name Property

GridLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.RandomSeed Property

GridLayout.RandomSeed Property
[image]

Gets or sets the randomization seed to use for generating random node positions.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int RandomSeed { get; set; }

Visual Basic [image] Copy Code

Public Property RandomSeed As Integer

Property Value

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.Root Property

GridLayout.Root Property
[image]

Gets or sets a node indicating which subgraph of the diagram should be laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As DiagramNode

Property Value

An instance of the DiagramNode class that represents the root node.

Remarks

All links and nodes that can be reached from the root by following recursively its links form a graph. If the root is specified, only the graph which it defines is laid out by Arrange.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.SplitGraph Property

GridLayout.SplitGraph Property
[image]

Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SplitGraph { get; set; }

Visual Basic [image] Copy Code

Public Property SplitGraph As Boolean

Property Value

true if unconnected graphs in the diagram are laid out independently; otherwise, false. The default is true.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.StartNode Property

GridLayout.StartNode Property
[image]

Gets or sets the node that is placed at the upper left corner of the grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode StartNode { get; set; }

Visual Basic [image] Copy Code

Public Property StartNode As DiagramNode

Property Value

An instance of the DiagramNode class. The default is null (Nothing in Visual Basic).

Remarks

If you assign a node to that property, then EndNode cannot be null and must be set too. GridLayout usually produces better layouts if both StartNode and EndNode are null references; in such a case the algorithm automatically selects suitable nodes.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.TimeLimit Property

GridLayout.TimeLimit Property
[image]

Gets or sets a time-out value for the path-finding part of the grid layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public long TimeLimit { get; set; }

Visual Basic [image] Copy Code

Public Property TimeLimit As Long

Property Value

An integer value specifying time-out in milliseconds.

Remarks

The grid layout algorithm arranges graph nodes and links along the longest path in the graph. Large graphs with many links could contain hundreds of thousands of possible paths, so finding the longest one would be very time-consuming. When the time-out set with this property occurs, the path-finding routine stops and the layout algorithm uses the longest path known at that moment. Usually, for graphs containing several hundreds of nodes, 1-2 seconds are enough to find a path long enough to produce a nice layout.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.UseLongestPath Property

GridLayout.UseLongestPath Property
[image]

Gets or sets a value indicating whether the algorithm should arrange nodes around the longest path in the graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool UseLongestPath { get; set; }

Visual Basic [image] Copy Code

Public Property UseLongestPath As Boolean

Property Value

true to look for the longest path in the graph and arrange nodes around it; otherwise, false.

Remarks

Initially, the algorithm places nodes and links from the longest path in the graph at the grid diagonal, and arranges the rest of the nodes around the diagonal. Large graphs with many links could contain hundreds of thousands of possible paths, so finding the longest one would be very time-consuming. Disabling this property will let you skip the path-finding part of the algorithm, which will make it work much faster.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.HierarchicalLayout Class

HierarchicalLayout Class
Remarks See Also
[image]

Performs hierarchical layout on simple, connected, level-planar graphs.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class HierarchicalLayout : Layout

Visual Basic [image] Copy Code

Public Class HierarchicalLayout
Inherits Layout

Remarks

HierarchicalLayout places nodes on user-defined levels, such that if the source graph is level-planar, all links are guaranteed to have a single segment and will not intersect. A graph is considered level-planar if it is possible to draw it without link intersections when its nodes are positioned on predefined levels. The layout method requires that for each node LayoutTraits contains a HierarchicalLayoutTraits.Level entry specifying the level, and no two connected nodes must be on the same level.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.HierarchicalLayout

See Also

HierarchicalLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.HierarchicalLayout Members

HierarchicalLayout Members
Constructors Properties Methods
[image]

Performs hierarchical layout on simple, connected, level-planar graphs.

The following tables list the members exposed by the HierarchicalLayout type.

Public Constructors

Name | Description
HierarchicalLayout | Initializes a new instance of the HierarchicalLayout class.

Public Properties

Name | Description
LevelDistance | Gets or sets the distance between adjacent levels in the hierarchical layout.
LinkBendFactor | Gets or sets the bending factor of links.
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged graph.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

Inherited Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)

See Also

HierarchicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.HierarchicalLayout Constructor

HierarchicalLayout Constructor
[image]

Initializes a new instance of the HierarchicalLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HierarchicalLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

HierarchicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.HierarchicalLayout Properties

HierarchicalLayout Properties
[image]

Public Properties

Name | Description
LevelDistance | Gets or sets the distance between adjacent levels in the hierarchical layout.
LinkBendFactor | Gets or sets the bending factor of links.
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged graph.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

See Also

HierarchicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.HierarchicalLayout.DefaultMarginValue Property

HierarchicalLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

HierarchicalLayout Members
HierarchicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.HierarchicalLayout.LevelDistance Property

HierarchicalLayout.LevelDistance Property
[image]

Gets or sets the distance between adjacent levels in the hierarchical layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LevelDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LevelDistance As Double

Property Value

The default value is 150.

See Also

HierarchicalLayout Members
HierarchicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.HierarchicalLayout.LinkBendFactor Property

HierarchicalLayout.LinkBendFactor Property
[image]

Gets or sets the bending factor of links.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LinkBendFactor { get; set; }

Visual Basic [image] Copy Code

Public Property LinkBendFactor As Double

Property Value

The default value is 1.

Remarks

A value of 1 indicates that the links should not bend. A value less than 1 indicates that the links should bend towards the geometric center of the graph. A value greater than 1 indicates that the links should bend outwards.

See Also

HierarchicalLayout Members
HierarchicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.HierarchicalLayout.Name Property

HierarchicalLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Hierarchical layout".

See Also

HierarchicalLayout Members
HierarchicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.HierarchicalLayout.Orientation Property

HierarchicalLayout.Orientation Property
[image]

Gets or sets the orientation of the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Vertical.

See Also

HierarchicalLayout Members
HierarchicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout Interface

ILayout Interface
[image]

Common interface for all layout classes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface ILayout

Visual Basic [image] Copy Code

Public Interface ILayout

Inheritors

MindFusion.Diagramming.Layout.Layout

See Also

ILayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout Members

ILayout Members
Properties Methods
[image]

Common interface for all layout classes.

The following tables list the members exposed by the ILayout type.

Public Properties

Name | Description
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.

Public Methods

Name | Description
Arrange |
Arrange | Applies the layout to the specified Diagram instance.

See Also

ILayout Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout Methods

ILayout Methods
[image]

Public Methods

Name | Description
Arrange |
Arrange | Applies the layout to the specified Diagram instance.

See Also

ILayout Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout.Arrange Method (VirtualizingDiagram)

ILayout.Arrange Method (VirtualizingDiagram)
See Also
[image]

Applies the layout to the specified VirtualizingDiagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

bool Arrange (
VirtualizingDiagram diagram
)

Visual Basic [image] Copy Code

Function Arrange( _
diagram As VirtualizingDiagram _
) As Boolean

Parameters

diagram

The VirtualizingDiagram that should be arranged.

Return Value

Returns whether the arrangement was successful.

See Also

ILayout Members
ILayout Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout.Arrange Method

ILayout.Arrange Method
[image]

Applies the layout to the specified Diagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract bool Arrange (
Diagram diagram
)

Visual Basic [image] Copy Code

Public MustOverride Function Arrange ( _
diagram As Diagram _
) As Boolean

Parameters

diagram
The Diagram that should be arranged.

Return Value

Returns whether the arrangement was successful.

See Also

ILayout Members
ILayout Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout Properties

ILayout Properties
[image]

Public Properties

Name | Description
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.

See Also

ILayout Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout.LayoutLink Property

ILayout.LayoutLink Property
[image]

Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract LayoutLink LayoutLink { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property LayoutLink As LayoutLink

Property Value

An instance of the LayoutLink delegate.

See Also

ILayout Members
ILayout Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout.LayoutNode Property

ILayout.LayoutNode Property
[image]

Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract LayoutNode LayoutNode { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property LayoutNode As LayoutNode

Property Value

An instance of the LayoutNode delegate.

See Also

ILayout Members
ILayout Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid Interface

ISwimlaneGrid Interface
[image]

Represents an object which can be used by a SwimlaneLayout to adjust the corresponding swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface ISwimlaneGrid

Visual Basic [image] Copy Code

Public Interface ISwimlaneGrid

Inheritors

MindFusion.Diagramming.Layout.LaneGrid

See Also

ISwimlaneGrid Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid Members

ISwimlaneGrid Members
Methods
[image]

Represents an object which can be used by a SwimlaneLayout to adjust the corresponding swimlane grid.

The following tables list the members exposed by the ISwimlaneGrid type.

Public Methods

Name | Description
GetColumnCount | Gets the number of columns in the grid.
GetColumnWidth | Gets the the width of the specified column in the swimlane grid.
GetRowCount | Gets the number of rows in the swimlane grid.
GetRowHeight | Gets the the height of the specified row in the swimlane grid.
SetColumnCount | Sets the number of columns in the swimlane grid.
SetColumnWidth | Sets the the width of the specified column in the swimlane grid.
SetLeftMargin | Sets the left margin of the swimlane grid.
SetRowCount | Sets the number of rows in the swimlane grid.
SetRowHeight | Sets the the height of the specified row in the swimlane grid.
SetTopMargin | Sets the top margin of the swimlane grid.

See Also

ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid Methods

ISwimlaneGrid Methods
[image]

Public Methods

Name | Description
GetColumnCount | Gets the number of columns in the grid.
GetColumnWidth | Gets the the width of the specified column in the swimlane grid.
GetRowCount | Gets the number of rows in the swimlane grid.
GetRowHeight | Gets the the height of the specified row in the swimlane grid.
SetColumnCount | Sets the number of columns in the swimlane grid.
SetColumnWidth | Sets the the width of the specified column in the swimlane grid.
SetLeftMargin | Sets the left margin of the swimlane grid.
SetRowCount | Sets the number of rows in the swimlane grid.
SetRowHeight | Sets the the height of the specified row in the swimlane grid.
SetTopMargin | Sets the top margin of the swimlane grid.

See Also

ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.GetColumnCount Method

ISwimlaneGrid.GetColumnCount Method
[image]

Gets the number of columns in the grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

int GetColumnCount ()

Visual Basic [image] Copy Code

Function GetColumnCount () As Integer

Return Value

The number of columns in the grid.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.GetColumnWidth Method

ISwimlaneGrid.GetColumnWidth Method
[image]

Gets the the width of the specified column in the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

double GetColumnWidth (
int index
)

Visual Basic [image] Copy Code

Function GetColumnWidth( _
index As Integer _
) As Double

Parameters

index

The zero-based index of the column.

Return Value

The width of the column.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.GetRowCount Method

ISwimlaneGrid.GetRowCount Method
[image]

Gets the number of rows in the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

int GetRowCount ()

Visual Basic [image] Copy Code

Function GetRowCount () As Integer

Return Value

The number of rows in the grid.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.GetRowHeight Method

ISwimlaneGrid.GetRowHeight Method
[image]

Gets the the height of the specified row in the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

double GetRowHeight (
int index
)

Visual Basic [image] Copy Code

Function GetRowHeight( _
index As Integer _
) As Double

Parameters

index

The zero-based index of the row.

Return Value

The height of the row.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.SetColumnCount Method

ISwimlaneGrid.SetColumnCount Method
[image]

Sets the number of columns in the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void SetColumnCount (
int value
)

Visual Basic [image] Copy Code

Sub SetColumnCount( _
value As Integer _
)

Parameters

value

A non-negative integer value specifying the number of columns.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.SetColumnWidth Method

ISwimlaneGrid.SetColumnWidth Method
[image]

Sets the the width of the specified column in the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void SetColumnWidth (
int index,
double value
)

Visual Basic [image] Copy Code

Sub SetColumnWidth( _
index As Integer, _
value As Double _
)

Parameters

index

The zero-based index of the column.

value

The new width of the column.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.SetLeftMargin Method

ISwimlaneGrid.SetLeftMargin Method
[image]

Sets the left margin of the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void SetLeftMargin (
double value
)

Visual Basic [image] Copy Code

Sub SetLeftMargin( _
value As Double _
)

Parameters

value

The distance between the left side of the grid and the diagram bounds.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.SetRowCount Method

ISwimlaneGrid.SetRowCount Method
[image]

Sets the number of rows in the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void SetRowCount (
int value
)

Visual Basic [image] Copy Code

Sub SetRowCount( _
value As Integer _
)

Parameters

value

A non-negative integer value specifying the number of rows.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.SetRowHeight Method

ISwimlaneGrid.SetRowHeight Method
[image]

Sets the the height of the specified row in the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void SetRowHeight (
int index,
double value
)

Visual Basic [image] Copy Code

Sub SetRowHeight( _
index As Integer, _
value As Double _
)

Parameters

index

The zero-based index of the row.

value

The new height of the row.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.SetTopMargin Method

ISwimlaneGrid.SetTopMargin Method
[image]

Sets the top margin of the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void SetTopMargin (
double value
)

Visual Basic [image] Copy Code

Sub SetTopMargin( _
value As Double _
)

Parameters

value

The distance between the top side of the grid and the diagram bounds.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid Class

LaneGrid Class
[image]

Represents an ISwimlaneGrid which operates on a MindFusion.Diagramming.Lanes.Grid object.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LaneGrid : ISwimlaneGrid

Visual Basic [image] Copy Code

Public Class LaneGrid
Implements ISwimlaneGrid

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.LaneGrid

See Also

LaneGrid Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid Members

LaneGrid Members
Constructors Methods
[image]

Represents an ISwimlaneGrid which operates on a MindFusion.Diagramming.Lanes.Grid object.

The following tables list the members exposed by the LaneGrid type.

Public Constructors

Name | Description
LaneGrid | Initializes a new instance of the LaneGrid class.

Public Methods

Name | Description
GetColumnCount | ISwimlaneGrid.GetColumnCount implementation.
GetColumnWidth | ISwimlaneGrid.GetColumnCount implementation.
GetRowCount | ISwimlaneGrid.GetRowCount implementation.
GetRowHeight | ISwimlaneGrid.GetRowHeight implementation.
SetColumnCount | ISwimlaneGrid.SetColumnCount implementation.
SetColumnWidth | ISwimlaneGrid.SetColumnCount implementation.
SetLeftMargin | ISwimlaneGrid.SetLeftMargin implementation.
SetRowCount | ISwimlaneGrid.SetRowCount implementation.
SetRowHeight | ISwimlaneGrid.SetRowHeight implementation.
SetTopMargin | ISwimlaneGrid.SetTopMargin implementation.

See Also

LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid Constructor

LaneGrid Constructor
[image]

Initializes a new instance of the LaneGrid class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LaneGrid (
Grid grid
)

Visual Basic [image] Copy Code

Public New ( _
grid As Grid _
)

Parameters

grid

See Also

LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid Methods

LaneGrid Methods
[image]

Public Methods

Name | Description
GetColumnCount | ISwimlaneGrid.GetColumnCount implementation.
GetColumnWidth | ISwimlaneGrid.GetColumnCount implementation.
GetRowCount | ISwimlaneGrid.GetRowCount implementation.
GetRowHeight | ISwimlaneGrid.GetRowHeight implementation.
SetColumnCount | ISwimlaneGrid.SetColumnCount implementation.
SetColumnWidth | ISwimlaneGrid.SetColumnCount implementation.
SetLeftMargin | ISwimlaneGrid.SetLeftMargin implementation.
SetRowCount | ISwimlaneGrid.SetRowCount implementation.
SetRowHeight | ISwimlaneGrid.SetRowHeight implementation.
SetTopMargin | ISwimlaneGrid.SetTopMargin implementation.

See Also

LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.GetColumnCount Method

LaneGrid.GetColumnCount Method
[image]

ISwimlaneGrid.GetColumnCount implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int GetColumnCount ()

Visual Basic [image] Copy Code

Public Function GetColumnCount () As Integer

Return Value

The number of columns in the grid.

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.GetColumnWidth Method

LaneGrid.GetColumnWidth Method
[image]

ISwimlaneGrid.GetColumnCount implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double GetColumnWidth (
int index
)

Visual Basic [image] Copy Code

Public Function GetColumnWidth( _
index As Integer _
) As Double

Parameters

index
The zero-based index of the column.

Return Value

The width of the column.

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.GetRowCount Method

LaneGrid.GetRowCount Method
[image]

ISwimlaneGrid.GetRowCount implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int GetRowCount ()

Visual Basic [image] Copy Code

Public Function GetRowCount () As Integer

Return Value

The number of rows in the grid.

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.GetRowHeight Method

LaneGrid.GetRowHeight Method
[image]

ISwimlaneGrid.GetRowHeight implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double GetRowHeight (
int index
)

Visual Basic [image] Copy Code

Public Function GetRowHeight( _
index As Integer _
) As Double

Parameters

index
The zero-based index of the row.

Return Value

The height of the row.

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.SetColumnCount Method

LaneGrid.SetColumnCount Method
[image]

ISwimlaneGrid.SetColumnCount implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetColumnCount (
int value
)

Visual Basic [image] Copy Code

Public Sub SetColumnCount( _
value As Integer _
)

Parameters

value

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.SetColumnWidth Method

LaneGrid.SetColumnWidth Method
[image]

ISwimlaneGrid.SetColumnCount implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetColumnWidth (
int index,
double value
)

Visual Basic [image] Copy Code

Public Sub SetColumnWidth( _
index As Integer, _
value As Double _
)

Parameters

index

value

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.SetLeftMargin Method

LaneGrid.SetLeftMargin Method
[image]

ISwimlaneGrid.SetLeftMargin implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetLeftMargin (
double value
)

Visual Basic [image] Copy Code

Public Sub SetLeftMargin( _
value As Double _
)

Parameters

value

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.SetRowCount Method

LaneGrid.SetRowCount Method
[image]

ISwimlaneGrid.SetRowCount implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetRowCount (
int value
)

Visual Basic [image] Copy Code

Public Sub SetRowCount( _
value As Integer _
)

Parameters

value

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.SetRowHeight Method

LaneGrid.SetRowHeight Method
[image]

ISwimlaneGrid.SetRowHeight implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetRowHeight (
int index,
double value
)

Visual Basic [image] Copy Code

Public Sub SetRowHeight( _
index As Integer, _
value As Double _
)

Parameters

index

value

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.SetTopMargin Method

LaneGrid.SetTopMargin Method
[image]

ISwimlaneGrid.SetTopMargin implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetTopMargin (
double value
)

Visual Basic [image] Copy Code

Public Sub SetTopMargin( _
value As Double _
)

Parameters

value

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout Class

LayeredLayout Class
Remarks See Also
[image]

Implements a layered graph layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LayeredLayout : Layout

Visual Basic [image] Copy Code

Public Class LayeredLayout
Inherits Layout

Remarks

To apply this layout to a diagram, create a LayeredLayout instance, set its members and invoke the Arrange method. Arrange lays out all subgraphs in a diagram, unless the Root property is set.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.LayeredLayout

See Also

LayeredLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout Members

LayeredLayout Members
Constructors Properties Methods
[image]

Implements a layered graph layout algorithm.

The following tables list the members exposed by the LayeredLayout type.

Public Constructors

Name | Description
LayeredLayout | Overloaded.

Public Properties

Name | Description
Direction | Gets or sets the direction of the arranged diagram.
EnableCustomLayers | Gets or sets a value indicating whether to indicating whether the layered layout will honor the LayeredLayoutTraits.Layer flags.
EndNode | Gets or sets the node that should be placed in the last layer of the arranged graph.
EnforceLinkFlow | Gets or sets a value indicating whether to attempt to force all links to go in the same direction. If the graph being arranged has cycles, some of the links will still go backward.
IgnoreNodeSize | Gets or sets a value indicating whether the distance between adjacent nodes in the final layout should be independent of the nodes' size.
KeepRootPosition | Gets or sets a value indicating whether to preserve the position of the root node.
LayerDistance | Gets or sets the desired distance between layer axis lines.
LinksCompactFactor | Gets or sets a value indicating how much to compact the outermost arrows.
LinkType | Gets or sets the appearance of the links in the final layout.
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the desired distance between adjacent nodes in a layer.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Root | Gets or sets a node indicating which subgraph of the diagram must be laid out.
SplitLayers | Gets or sets a value indicating whether to split layers that are much wider than the other layers.
StableSort | Gets or sets a value indicating whether to apply stable sorting during the layout algorithm.
StartNode | Gets or sets the node that should be placed in the first layer of the arranged graph.
Statistics | Gets layout-specific information about the nodes and links participating in the layout.
StraightenLongLinks | Gets or sets whether the layout algorithm should strive to straighten links that cross more than one layer of the graph.
SwapPairsIterations | Gets or sets how many times to perform pair-swapping iterations on each layer.
TimeLimit | Gets or sets a time-out value for the path-finding part of the layered layout algorithm.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

Inherited Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)

See Also

LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout Constructor

LayeredLayout Constructor
[image]

Overload List

Name | Description
LayeredLayout () | Initializes a new instance of the LayeredLayout class with the default settings.
LayeredLayout (Orientation, Double, Double, Size) | Initializes a new instance of the LayeredLayout class with the specified settings.

See Also

LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout Constructor ()

LayeredLayout Constructor ()
See Also
[image]

Initializes a new instance of the LayeredLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LayeredLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LayeredLayout Constructor Overload List
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout Constructor (Orientation, Double, Double, Size)

LayeredLayout Constructor (Orientation, Double, Double, Size)
See Also
[image]

Initializes a new instance of the LayeredLayout class with the specified settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LayeredLayout (
Orientation orientation,
double layerDistance,
double nodeDistance,
Size margins
)

Visual Basic [image] Copy Code

Public New ( _
orientation As Orientation, _
layerDistance As Double, _
nodeDistance As Double, _
margins As Size _
)

Parameters

orientation

The orientation of the layout.

layerDistance

The distance between adjacent layers.

nodeDistance

The distance between adjacent nodes within the same layer.

margins

The margin between the produced graph and the left side of the diagram bounding rectangle.

See Also

LayeredLayout Constructor Overload List
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout Properties

LayeredLayout Properties
[image]

Public Properties

Name | Description
Direction | Gets or sets the direction of the arranged diagram.
EnableCustomLayers | Gets or sets a value indicating whether to indicating whether the layered layout will honor the LayeredLayoutTraits.Layer flags.
EndNode | Gets or sets the node that should be placed in the last layer of the arranged graph.
EnforceLinkFlow | Gets or sets a value indicating whether to attempt to force all links to go in the same direction. If the graph being arranged has cycles, some of the links will still go backward.
IgnoreNodeSize | Gets or sets a value indicating whether the distance between adjacent nodes in the final layout should be independent of the nodes' size.
KeepRootPosition | Gets or sets a value indicating whether to preserve the position of the root node.
LayerDistance | Gets or sets the desired distance between layer axis lines.
LinksCompactFactor | Gets or sets a value indicating how much to compact the outermost arrows.
LinkType | Gets or sets the appearance of the links in the final layout.
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the desired distance between adjacent nodes in a layer.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Root | Gets or sets a node indicating which subgraph of the diagram must be laid out.
SplitLayers | Gets or sets a value indicating whether to split layers that are much wider than the other layers.
StableSort | Gets or sets a value indicating whether to apply stable sorting during the layout algorithm.
StartNode | Gets or sets the node that should be placed in the first layer of the arranged graph.
Statistics | Gets layout-specific information about the nodes and links participating in the layout.
StraightenLongLinks | Gets or sets whether the layout algorithm should strive to straighten links that cross more than one layer of the graph.
SwapPairsIterations | Gets or sets how many times to perform pair-swapping iterations on each layer.
TimeLimit | Gets or sets a time-out value for the path-finding part of the layered layout algorithm.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

See Also

LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.DefaultMarginValue Property

LayeredLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.Direction Property

LayeredLayout.Direction Property
[image]

Gets or sets the direction of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Direction Direction { get; set; }

Visual Basic [image] Copy Code

Public Property Direction As Direction

Property Value

Remarks

If Orientation is set to Horizontal, Direction.Straight stands for "left to right" and Direction.Reversed for "right to left". If Orientation is set to Vertical, Direction.Straight stands for "top to bottom" and Direction.Reversed for "bottom to top".

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.EnableCustomLayers Property

LayeredLayout.EnableCustomLayers Property
[image]

Gets or sets a value indicating whether to indicating whether the layered layout will honor the LayeredLayoutTraits.Layer flags.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableCustomLayers { get; set; }

Visual Basic [image] Copy Code

Public Property EnableCustomLayers As Boolean

Property Value

true to use custom layers, otherwise false. The default is false.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.EndNode Property

LayeredLayout.EndNode Property
[image]

Gets or sets the node that should be placed in the last layer of the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object EndNode { get; set; }

Visual Basic [image] Copy Code

Public Property EndNode As Object

Property Value

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.EnforceLinkFlow Property

LayeredLayout.EnforceLinkFlow Property
[image]

Gets or sets a value indicating whether to attempt to force all links to go in the same direction. If the graph being arranged has cycles, some of the links will still go backward.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnforceLinkFlow { get; set; }

Visual Basic [image] Copy Code

Public Property EnforceLinkFlow As Boolean

Property Value

true if all links should follow the same general direction when possible, otherwise false. The default is false.

Remarks

If this property is enabled, the layout usually occupies a larger area. In addition, the EnableCustomLayers and SplitLayers properties cannot be used in conjunction with it and are ignored.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.IgnoreNodeSize Property

LayeredLayout.IgnoreNodeSize Property
[image]

Gets or sets a value indicating whether the distance between adjacent nodes in the final layout should be independent of the nodes' size.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IgnoreNodeSize { get; set; }

Visual Basic [image] Copy Code

Public Property IgnoreNodeSize As Boolean

Property Value

true to ignore the node size; otherwise, false. The default is true.

Remarks

At this time, considering the size of nodes deteriorates the performance of the algorithm, so that's disabled by default.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.KeepRootPosition Property

LayeredLayout.KeepRootPosition Property
[image]

Gets or sets a value indicating whether to preserve the position of the root node.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool KeepRootPosition { get; set; }

Visual Basic [image] Copy Code

Public Property KeepRootPosition As Boolean

Property Value

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.LayerDistance Property

LayeredLayout.LayerDistance Property
[image]

Gets or sets the desired distance between layer axis lines.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LayerDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LayerDistance As Double

Property Value

A double value specifying the distance between layers.

Remarks

This value is assigned to the LayerDistance property of the base LayeredLayout.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.LinksCompactFactor Property

LayeredLayout.LinksCompactFactor Property
[image]

Gets or sets a value indicating how much to compact the outermost arrows.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LinksCompactFactor { get; set; }

Visual Basic [image] Copy Code

Public Property LinksCompactFactor As Double

Property Value

Remarks

Links and nodes on the same graph layer are distributed uniformly as specified by the NodeDistance value. However, if there are more than 2-3 outermost links on a layer, they usually take up too much space without improving the visual quality of the diagram layout. This property allows compacting such links to save space. The factor specifies roughly a fraction of NodeDistance to leave between outer links.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.LinkType Property

LayeredLayout.LinkType Property
[image]

Gets or sets the appearance of the links in the final layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LayeredLayoutLinkType LinkType { get; set; }

Visual Basic [image] Copy Code

Public Property LinkType As LayeredLayoutLinkType

Property Value

A member of the LayeredLayoutLinkType enumeration. The default is Straight.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.Name Property

LayeredLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.NodeDistance Property

LayeredLayout.NodeDistance Property
[image]

Gets or sets the desired distance between adjacent nodes in a layer.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Double

Property Value

A double value specifying the distance between adjacent nodes.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.Orientation Property

LayeredLayout.Orientation Property
[image]

Gets or sets the overall orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default is Vertical.

Remarks

Specify Orientation.Vertical to have links flow in vertical direction and Orientation.Horizontal to have links flow in horizontal direction. The orientation of the resulting layers is opposite to that of the links. Thus, if the link tends to go in a vertical direction, the nodes are distributed in horizontal layers.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.Root Property

LayeredLayout.Root Property
[image]

Gets or sets a node indicating which subgraph of the diagram must be laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As DiagramNode

Property Value

An instance of the DiagramNode class. The default is a null reference (Nothing in Visual Basic).

Remarks

All links and nodes that can be reached from the root by following recursively its links form a graph. If the root is specified, only the graph containing it is laid out by Arrange.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.SplitLayers Property

LayeredLayout.SplitLayers Property
[image]

Gets or sets a value indicating whether to split layers that are much wider than the other layers.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SplitLayers { get; set; }

Visual Basic [image] Copy Code

Public Property SplitLayers As Boolean

Property Value

true to split wide layers; otherwise, false. The default is false.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.StableSort Property

LayeredLayout.StableSort Property
[image]

Gets or sets a value indicating whether to apply stable sorting during the layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool StableSort { get; set; }

Visual Basic [image] Copy Code

Public Property StableSort As Boolean

Property Value

true to apply stable sorting algorithm, otherwise false. The default value is false.

Remarks

By default .NET sorts arrays using unstable sort, where if two elements have equal values, their order might not be the same between different runs of the sort method. This could lead to LayeredLayout not preserving the order of some nodes in a layer between different runs if there are more than one candidates for the same position. If you need the same order to be reproduced consistently, set StableSort to true.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.StartNode Property

LayeredLayout.StartNode Property
[image]

Gets or sets the node that should be placed in the first layer of the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object StartNode { get; set; }

Visual Basic [image] Copy Code

Public Property StartNode As Object

Property Value

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.Statistics Property

LayeredLayout.Statistics Property
[image]

Gets layout-specific information about the nodes and links participating in the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LayeredLayoutStatistics Statistics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Statistics As LayeredLayoutStatistics

Property Value

A LayeredLayoutStatistics instance.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.StraightenLongLinks Property

LayeredLayout.StraightenLongLinks Property
[image]

Gets or sets whether the layout algorithm should strive to straighten links that cross more than one layer of the graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool StraightenLongLinks { get; set; }

Visual Basic [image] Copy Code

Public Property StraightenLongLinks As Boolean

Property Value

If this property is enabled, links that cross multiple layers have at most two bends. Because of the additional horizontal alignment contraints, the arranged graph osually occupies a larger area than when not using StraightenLongLinks.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.SwapPairsIterations Property

LayeredLayout.SwapPairsIterations Property
[image]

Gets or sets how many times to perform pair-swapping iterations on each layer.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int SwapPairsIterations { get; set; }

Visual Basic [image] Copy Code

Public Property SwapPairsIterations As Integer

Property Value

An integer value specifying how many pair-swapping iterations to perform. The default is 5.

Remarks

The algorithm swaps node pairs on each layer aiming to decrease the number of crossing links. Setting a higher value to this property helps to decrease the number of crossings.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.TimeLimit Property

LayeredLayout.TimeLimit Property
[image]

Gets or sets a time-out value for the path-finding part of the layered layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public long TimeLimit { get; set; }

Visual Basic [image] Copy Code

Public Property TimeLimit As Long

Property Value

An integer value specifying time-out in milliseconds. The default is 10000 (10 seconds).

Remarks

The layered layout algorithm arranges graph nodes and links along the longest path in the graph. Large graphs with many links could contain hundreds of thousands of possible paths, so finding the longest one would be very time-consuming. When the time-out set with this property occurs, the path-finding routine stops and the layout algorithm uses the longest path known at that moment. Usually, for graphs containing several hundreds of nodes, 1-2 seconds are enough to find a long-enough path to produce nice layered layout.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayoutLinkType Enumeration

LayeredLayoutLinkType Enumeration
[image]

Specifies the style of the links after they are laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum LayeredLayoutLinkType

Visual Basic [image] Copy Code

Public Enum LayeredLayoutLinkType

Members

Member name | Description
Cascading | Indicates cascading links.
Straight | Indicates straight links.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayoutStatistics Class

LayeredLayoutStatistics Class
[image]

Encapsulates information about a layered layout which has already complete.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class LayeredLayoutStatistics

Visual Basic [image] Copy Code

Public NotInheritable Class LayeredLayoutStatistics

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.LayeredLayoutStatistics

See Also

LayeredLayoutStatistics Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayoutStatistics Members

LayeredLayoutStatistics Members
Properties
[image]

Encapsulates information about a layered layout which has already complete.

The following tables list the members exposed by the LayeredLayoutStatistics type.

Public Properties

Name | Description
LayerCount | Gets the total number of layers in the layout. If more than one subgraph is laid out, this property returns the number of layers in the last subgraph.
LinkLayerCount | Gets a mapping between links and the number of layers they run through.
NodeGridPositions | Gets a mapping between nodes and their assigned grid positions.
NodeLayerIndices | Gets a mapping between nodes and their assigned layers.

See Also

LayeredLayoutStatistics Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayoutStatistics Properties

LayeredLayoutStatistics Properties
[image]

Public Properties

Name | Description
LayerCount | Gets the total number of layers in the layout. If more than one subgraph is laid out, this property returns the number of layers in the last subgraph.
LinkLayerCount | Gets a mapping between links and the number of layers they run through.
NodeGridPositions | Gets a mapping between nodes and their assigned grid positions.
NodeLayerIndices | Gets a mapping between nodes and their assigned layers.

See Also

LayeredLayoutStatistics Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayoutStatistics.LayerCount Property

LayeredLayoutStatistics.LayerCount Property
[image]

Gets the total number of layers in the layout. If more than one subgraph is laid out, this property returns the number of layers in the last subgraph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int LayerCount { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LayerCount As Integer

Property Value

See Also

LayeredLayoutStatistics Members
LayeredLayoutStatistics Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayoutStatistics.LinkLayerCount Property

LayeredLayoutStatistics.LinkLayerCount Property
[image]

Gets a mapping between links and the number of layers they run through.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Dictionary<Object, Int32> LinkLayerCount { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LinkLayerCount As Dictionary(Of Object, Int32)

Property Value

See Also

LayeredLayoutStatistics Members
LayeredLayoutStatistics Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayoutStatistics.NodeGridPositions Property

LayeredLayoutStatistics.NodeGridPositions Property
[image]

Gets a mapping between nodes and their assigned grid positions.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Dictionary<Object, Double> NodeGridPositions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NodeGridPositions As Dictionary(Of Object, Double)

Property Value

See Also

LayeredLayoutStatistics Members
LayeredLayoutStatistics Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayoutStatistics.NodeLayerIndices Property

LayeredLayoutStatistics.NodeLayerIndices Property
[image]

Gets a mapping between nodes and their assigned layers.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Dictionary<Object, Int32> NodeLayerIndices { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NodeLayerIndices As Dictionary(Of Object, Int32)

Property Value

See Also

LayeredLayoutStatistics Members
LayeredLayoutStatistics Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout Class

Layout Class
[image]

The base class for all layout classes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class Layout : ILayout

Visual Basic [image] Copy Code

Public MustInherit Class Layout
Implements ILayout

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.AnnealLayout
MindFusion.Diagramming.Layout.CascadeLayout
MindFusion.Diagramming.Layout.CircularLayout
MindFusion.Diagramming.Layout.CompositeLayout
MindFusion.Diagramming.Layout.DecisionLayout
MindFusion.Diagramming.Layout.FlowchartLayout
MindFusion.Diagramming.Layout.FractalLayout
MindFusion.Diagramming.Layout.GridLayout
MindFusion.Diagramming.Layout.HierarchicalLayout
MindFusion.Diagramming.Layout.LayeredLayout
MindFusion.Diagramming.Layout.OneWayLayout
MindFusion.Diagramming.Layout.OrthogonalLayout
MindFusion.Diagramming.Layout.OrthogonalRouter
MindFusion.Diagramming.Layout.SolarLayout
MindFusion.Diagramming.Layout.SpringLayout
MindFusion.Diagramming.Layout.SwimlaneLayout
MindFusion.Diagramming.Layout.TopologicalLayout
MindFusion.Diagramming.Layout.TreeLayout
MindFusion.Diagramming.Layout.TreeMapLayout
MindFusion.Diagramming.Layout.TriangularLayout

See Also

Layout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout Members

Layout Members
Constructors Properties Methods
[image]

The base class for all layout classes.

The following tables list the members exposed by the Layout type.

Protected Constructors

Name | Description
Layout | Initializes a new instance of the Layout class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes.
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.
Name | Gets a user-friendly name of the layout.
Progress | Gets or sets the progress callback delegate.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts.

Public Methods

Name | Description
Arrange | Overloaded.

See Also

Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout Constructor

Layout Constructor
[image]

Initializes a new instance of the Layout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Layout ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout Methods

Layout Methods
[image]

Public Methods

Name | Description
Arrange | Overloaded.

See Also

Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Arrange Method

Layout.Arrange Method
[image]

Overload List

Name | Description
Layout.Arrange (Diagram) | Applies the layout to the specified Diagram instance.
Layout.Arrange (Diagram, DiagramItemCollection) | Applies the layout on the specified subset of items from the specified Diagram instance.
Layout.Arrange (VirtualizingDiagram) | Applies the layout to the specified VirtualizingDiagram instance.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Arrange Method (Diagram)

Layout.Arrange Method (Diagram)
See Also
[image]

Applies the layout to the specified Diagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool Arrange (
Diagram diagram
)

Visual Basic [image] Copy Code

Public Overridable Function Arrange ( _
diagram As Diagram _
) As Boolean

Parameters

diagram
The Diagram that should be arranged.

Return Value

true if the diagram has been arranged successfully; otherwise, false.

See Also

Arrange Method Overload List
Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Arrange Method (Diagram, DiagramItemCollection)

Layout.Arrange Method (Diagram, DiagramItemCollection)
See Also
[image]

Applies the layout on the specified subset of items from the specified Diagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract bool Arrange (
Diagram diagram,
DiagramItemCollection items
)

Visual Basic [image] Copy Code

Public MustOverride Function Arrange ( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram
The Diagram that should be arranged.
items

A collection of nodes and links from diagram that define the subgraph to arrange.

Return Value

true if the diagram has been arranged successfully; otherwise, false.

See Also

Arrange Method Overload List
Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Arrange Method (VirtualizingDiagram)

Layout.Arrange Method (VirtualizingDiagram)
See Also
[image]

Applies the layout to the specified VirtualizingDiagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool Arrange (
VirtualizingDiagram diagram
)

Visual Basic [image] Copy Code

Public Overridable Function Arrange( _
diagram As VirtualizingDiagram _
) As Boolean

Parameters

diagram

The VirtualizingDiagram that should be arranged.

Return Value

true if the diagram has been arranged successfully; otherwise, false.

See Also

Arrange Method Overload List
Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout Properties

Layout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes.
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.
Name | Gets a user-friendly name of the layout.
Progress | Gets or sets the progress callback delegate.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts.

See Also

Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Anchoring Property

Layout.Anchoring Property
[image]

Gets or sets how to align links to the anchor points of nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Anchoring Anchoring { get; set; }

Visual Basic [image] Copy Code

Public Property Anchoring As Anchoring

Property Value

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.DefaultMarginValue Property

Layout.DefaultMarginValue Property
[image]

Gets the default value for the Margins property, which may vary accross different layouts.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected abstract Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected MustOverride ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.GrowToFit Property

Layout.GrowToFit Property
[image]

Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool GrowToFit { get; set; }

Visual Basic [image] Copy Code

Public Property GrowToFit As Boolean

Property Value

true to grow diagram's Bounds if the arranged items would not fit, or false otherwise. The default value is true.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.KeepGroupLayout Property

Layout.KeepGroupLayout Property
[image]

Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool KeepGroupLayout { get; set; }

Visual Basic [image] Copy Code

Public Property KeepGroupLayout As Boolean

Property Value

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.LayoutLink Property

Layout.LayoutLink Property
[image]

Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual LayoutLink LayoutLink { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property LayoutLink As LayoutLink

Property Value

An instance of the LayoutLink delegate.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.LayoutNode Property

Layout.LayoutNode Property
[image]

Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual LayoutNode LayoutNode { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property LayoutNode As LayoutNode

Property Value

An instance of the LayoutNode delegate.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Margins Property

Layout.Margins Property
[image]

Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Size Margins { get; set; }

Visual Basic [image] Copy Code

Public Property Margins As Size

Property Value

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.MultipleGraphsPlacement Property

Layout.MultipleGraphsPlacement Property
[image]

Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MultipleGraphsPlacement MultipleGraphsPlacement { get; set; }

Visual Basic [image] Copy Code

Public Property MultipleGraphsPlacement As MultipleGraphsPlacement

Property Value

A member of the MultipleGraphsPlacement enumeration. The default value is Horizontal.

Remarks

If the diagram contains several unconnected subgraphs, each of them is processed by the algorithm independently from the others. This property specifies how such subgraphs should be placed one relatively to another. The possible options are to arrange them in a row, in a column, or in such a way that the diagram covers a minimal area.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Name Property

Layout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract string Name { get; }

Visual Basic [image] Copy Code

Public MustOverride ReadOnly Property Name As String

Property Value

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Progress Property

Layout.Progress Property
[image]

Gets or sets the progress callback delegate.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual LayoutProgress Progress { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Progress As LayoutProgress

Property Value

An instance of the LayoutProgress delegate.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayoutLink Delegate

LayoutLink Delegate
[image]

Represents methods that are called by the layout algorithms when the position of a link changes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate void LayoutLink (
Object link
)

Visual Basic [image] Copy Code

Public Delegate Sub LayoutLink( _
link As Object _
)

Parameters

link

A reference to the link being laid out.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayoutNode Delegate

LayoutNode Delegate
[image]

Represents methods that are called by the layout algorithms when the position of a node changes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate void LayoutNode (
Object node,
Rect oldBounds
)

Visual Basic [image] Copy Code

Public Delegate Sub LayoutNode( _
node As Object, _
oldBounds As Rect _
)

Parameters

node

A reference to the node being laid out.

oldBounds

The bounding rectangle of the node before it was repositioned by the layouting algorithm.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayoutProgress Delegate

LayoutProgress Delegate
[image]

Represents methods that are called to report on progress of layout algorithms.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate void LayoutProgress (
int current,
int total
)

Visual Basic [image] Copy Code

Public Delegate Sub LayoutProgress( _
current As Integer, _
total As Integer _
)

Parameters

current

An integer value specifying the current relative progress of the layout algorithm.

total

An integer value specifying the total number of steps required by the layouting algorithm in order to finish.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayoutSubgraph Delegate

LayoutSubgraph Delegate
[image]

Represents methods that are called by the layout algorithms in order to perform custom arrangement of a subgraph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate bool LayoutSubgraph (
Diagram diagram,
IEnumerable items
)

Visual Basic [image] Copy Code

Public Delegate Function LayoutSubgraph( _
diagram As Diagram, _
items As IEnumerable _
) As Boolean

Parameters

diagram

The diagram being arranged.

items

The subset of items to arrange.

Return Value

true if the items were arranged; otherwise, false.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.MultipleGraphsPlacement Enumeration

MultipleGraphsPlacement Enumeration
[image]

Specifies graph orientation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum MultipleGraphsPlacement

Visual Basic [image] Copy Code

Public Enum MultipleGraphsPlacement

Members

Member name | Description
Horizontal | Indicates that graphs should be placed in a row.
HorizontalSortAscending | Indicates that graphs should be placed in a row and sorted by the number of vertices they contain in an ascending order.
HorizontalSortDescending | Indicates that graphs should be placed in a row and sorted by the number of vertices they contain in a descending order.
MinimalArea | Indicates that graphs should be placed so that they cover minimal area.
Vertical | Indicates that graphs should be placed in a column.
VerticalSortAscending | Indicates that graphs should be placed in a column and sorted by the number of vertices they contain in an ascending order.
VerticalSortDescending | Indicates that graphs should be placed in a column and sorted by the number of vertices they contain in a descending order.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OneWayLayout Class

OneWayLayout Class
Remarks See Also
[image]

Implements a one-way graph layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class OneWayLayout : Layout

Visual Basic [image] Copy Code

Public Class OneWayLayout
Inherits Layout

Remarks

The one-way layout ensures that links enter into nodes from the same general direction and exit them from the opposite side. If the graph contains cycles, some links bend around the nodes to keep the enter/exit direction consistent. The algorithm aims to minimize the number of such links.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.OneWayLayout

See Also

OneWayLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OneWayLayout Members

OneWayLayout Members
Constructors Properties Methods
[image]

Implements a one-way graph layout algorithm.

The following tables list the members exposed by the OneWayLayout type.

Public Constructors

Name | Description
OneWayLayout | Initializes a new instance of the OneWayLayout class with the default settings.

Public Properties

Name | Description
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the minimum spacing between adjacent nodes in the final layout.
Orientation | Gets or sets the orientation of the arranged graph.
RoundedLinks | Gets or sets a value indicating whether the layout should smooth link bends.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

Inherited Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)

See Also

OneWayLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OneWayLayout Constructor

OneWayLayout Constructor
[image]

Initializes a new instance of the OneWayLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public OneWayLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

OneWayLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OneWayLayout Properties

OneWayLayout Properties
[image]

Public Properties

Name | Description
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the minimum spacing between adjacent nodes in the final layout.
Orientation | Gets or sets the orientation of the arranged graph.
RoundedLinks | Gets or sets a value indicating whether the layout should smooth link bends.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

See Also

OneWayLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OneWayLayout.DefaultMarginValue Property

OneWayLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

OneWayLayout Members
OneWayLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OneWayLayout.Name Property

OneWayLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

See Also

OneWayLayout Members
OneWayLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OneWayLayout.NodeDistance Property

OneWayLayout.NodeDistance Property
[image]

Gets or sets the minimum spacing between adjacent nodes in the final layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Double

Property Value

A double value specifying the desired distance between nodes. The default value is 20.

See Also

OneWayLayout Members
OneWayLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OneWayLayout.Orientation Property

OneWayLayout.Orientation Property
[image]

Gets or sets the orientation of the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Vertical.

See Also

OneWayLayout Members
OneWayLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OneWayLayout.RoundedLinks Property

OneWayLayout.RoundedLinks Property
[image]

Gets or sets a value indicating whether the layout should smooth link bends.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RoundedLinks { get; set; }

Visual Basic [image] Copy Code

Public Property RoundedLinks As Boolean

Property Value

true to change links' Shape to Bezier; otherwise, false.

See Also

OneWayLayout Members
OneWayLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Orientation Enumeration

Orientation Enumeration
[image]

Specifies axial orientation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum Orientation

Visual Basic [image] Copy Code

Public Enum Orientation

Members

Member name | Description
Horizontal | Indicates horizontal orientation.
Vertical | Indicates vertical orientation.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout Class

OrthogonalLayout Class
Remarks See Also
[image]

Implements an orthogonal graph layout algorithm. Each link is drawn as a chain of alternating horizontal and vertical segments. Nodes are placed in a way that facilitates few links bends and crossings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class OrthogonalLayout : Layout

Visual Basic [image] Copy Code

Public Class OrthogonalLayout
Inherits Layout

Remarks

This algorithm was designed for planar graphs where the nodes have at most four incident links, and produces best results with such graphs as input. It can arrange any arbitrary graph as well, by adding some dummy nodes and links to planarize the graph and reduce its vertex degree, and removing them after the layout. However this might lead to using larger area than necessary, due to the space occupied by dummy elements.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.OrthogonalLayout

See Also

OrthogonalLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout Members

OrthogonalLayout Members
Constructors Properties Methods
[image]

Implements an orthogonal graph layout algorithm. Each link is drawn as a chain of alternating horizontal and vertical segments. Nodes are placed in a way that facilitates few links bends and crossings.

The following tables list the members exposed by the OrthogonalLayout type.

Public Constructors

Name | Description
OrthogonalLayout | Initializes a new instance of the OrthogonalLayout class with the default settings.

Public Properties

Name | Description
Directed | Gets or sets a value indicating whether the graph being laid out is directed.
MinimizeLinkBends | Gets or sets a value indicating whether the layout should minimize link bends.
MinLaneSize | Gets or sets a value indicating the minimum size of a lane.
Name | Gets a user-friendly name of the layout.
Padding | Gets or sets a value indicating how much space to leave between nodes in adjacent lanes.
Refine | Gets or sets a value indicating whether to refine the layout.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

Inherited Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)

See Also

OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout Constructor

OrthogonalLayout Constructor
[image]

Initializes a new instance of the OrthogonalLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public OrthogonalLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout Properties

OrthogonalLayout Properties
[image]

Public Properties

Name | Description
Directed | Gets or sets a value indicating whether the graph being laid out is directed.
MinimizeLinkBends | Gets or sets a value indicating whether the layout should minimize link bends.
MinLaneSize | Gets or sets a value indicating the minimum size of a lane.
Name | Gets a user-friendly name of the layout.
Padding | Gets or sets a value indicating how much space to leave between nodes in adjacent lanes.
Refine | Gets or sets a value indicating whether to refine the layout.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

See Also

OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout.DefaultMarginValue Property

OrthogonalLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout.Directed Property

OrthogonalLayout.Directed Property
[image]

Gets or sets a value indicating whether the graph being laid out is directed.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Directed { get; set; }

Visual Basic [image] Copy Code

Public Property Directed As Boolean

Property Value

true to consider the direction of graph edges, false to ignore it; the default value is false.

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout.MinimizeLinkBends Property

OrthogonalLayout.MinimizeLinkBends Property
[image]

Gets or sets a value indicating whether the layout should minimize link bends.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool MinimizeLinkBends { get; set; }

Visual Basic [image] Copy Code

Public Property MinimizeLinkBends As Boolean

Property Value

true to minimize link bends, otherwise false. The default value is true.

Remarks

If this option is disabled, the layout class applies a fast linear time algorithm, however the layouts produced usually contain more bending links and occupy more space. If enabled, the layout class applies an algorithm of polynomial complexity and runs much slower.

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout.MinLaneSize Property

OrthogonalLayout.MinLaneSize Property
[image]

Gets or sets a value indicating the minimum size of a lane.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double MinLaneSize { get; set; }

Visual Basic [image] Copy Code

Public Property MinLaneSize As Double

Property Value

A float value specifying the minimum lane size. The default value is 35.

Remarks

The result of the layout's Arrange is a grid that contains the diagram's nodes and links. This property specifies the size of lanes which does not contain nodes, but only links.

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout.Name Property

OrthogonalLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout.Padding Property

OrthogonalLayout.Padding Property
[image]

Gets or sets a value indicating how much space to leave between nodes in adjacent lanes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Padding { get; set; }

Visual Basic [image] Copy Code

Public Property Padding As Double

Property Value

A float value specifying the padding. The default is 55.

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout.Refine Property

OrthogonalLayout.Refine Property
[image]

Gets or sets a value indicating whether to refine the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Refine { get; set; }

Visual Basic [image] Copy Code

Public Property Refine As Boolean

Property Value

true to run a refinement pass, otherwise false. The default value is true.

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter Class

OrthogonalRouter Class
Remarks See Also
[image]

Implements an orthogonal link routing algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class OrthogonalRouter : Layout

Visual Basic [image] Copy Code

Public Class OrthogonalRouter
Inherits Layout

Remarks

OrthogonalRouter is a secondary layout algorithm that can be used to arrange links after an initial node arrangement has already been applied. The orthogonal layout is useful when there are much more links than nodes in a graph. The algorithm strives to achieve the following criteria, while preserving as much of the initial node configuration as possible. - links must not overlap; - only vertical and horizontal routing lines are used; - graph routing is performed with respect to the specified main layout direction; - links crossings are minimized; - bends are minimized;

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.OrthogonalRouter

See Also

OrthogonalRouter Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter Members

OrthogonalRouter Members
Constructors Properties Methods
[image]

Implements an orthogonal link routing algorithm.

The following tables list the members exposed by the OrthogonalRouter type.

Public Constructors

Name | Description
OrthogonalRouter | Initializes a new instance of the OrthogonalRouter class.

Public Properties

Name | Description
BendDistance | Gets or sets how far from its adjacent node a link should bend.
Direction | Gets or sets the direction of the arranged diagram when BaseLayout is set to Layered.
EndOrientation | Gets or sets the desired orientation of the last segments of routed links.
GridSize | Gets or sets the distance between adjacent grid points when BaseLayout is set to Grid.
LayerDistance | Gets or sets the desired distance between layer axis lines.
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the desired distance between adjacent nodes in a layer.
Orientation | Gets or sets the overall orientation of the arranged diagram when BaseLayout is set to Layered.
PutEndPointsAtNodeBorders | Gets or sets a value indicating whether the end points of a link should be placed at the outlines of the nodes connected by that link.
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
StartOrientation | Gets or sets the desired orientation of the first segments of routed links.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

Inherited Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)

See Also

OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter Constructor

OrthogonalRouter Constructor
[image]

Initializes a new instance of the OrthogonalRouter class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public OrthogonalRouter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter Properties

OrthogonalRouter Properties
[image]

Public Properties

Name | Description
BendDistance | Gets or sets how far from its adjacent node a link should bend.
Direction | Gets or sets the direction of the arranged diagram when BaseLayout is set to Layered.
EndOrientation | Gets or sets the desired orientation of the last segments of routed links.
GridSize | Gets or sets the distance between adjacent grid points when BaseLayout is set to Grid.
LayerDistance | Gets or sets the desired distance between layer axis lines.
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the desired distance between adjacent nodes in a layer.
Orientation | Gets or sets the overall orientation of the arranged diagram when BaseLayout is set to Layered.
PutEndPointsAtNodeBorders | Gets or sets a value indicating whether the end points of a link should be placed at the outlines of the nodes connected by that link.
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
StartOrientation | Gets or sets the desired orientation of the first segments of routed links.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

See Also

OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.BendDistance Property

OrthogonalRouter.BendDistance Property
[image]

Gets or sets how far from its adjacent node a link should bend.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double BendDistance { get; set; }

Visual Basic [image] Copy Code

Public Property BendDistance As Double

Property Value

A double value specifying the distance from a link's first bend to its adjacent node. The default is 0, specifying that the algorithm should automatically choose a value for this parameter.

Remarks

This should be a value between 0 and 1, specifying a distance proportional to the node size.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.DefaultMarginValue Property

OrthogonalRouter.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.Direction Property

OrthogonalRouter.Direction Property
[image]

Gets or sets the direction of the arranged diagram when BaseLayout is set to Layered.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Direction Direction { get; set; }

Visual Basic [image] Copy Code

Public Property Direction As Direction

Property Value

A member of the Direction.

Remarks

This value is assigned to the Direction property of the base LayeredLayout.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.EndOrientation Property

OrthogonalRouter.EndOrientation Property
[image]

Gets or sets the desired orientation of the last segments of routed links.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation EndOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property EndOrientation As Orientation

Property Value

A member of the Orientation enumeration.

Remarks

If this property is set to Horizontal, links will end at the left or right sides of nodes. If set to Vertical, links will end at the top or bottom sides.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.GridSize Property

OrthogonalRouter.GridSize Property
[image]

Gets or sets the distance between adjacent grid points when BaseLayout is set to Grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double GridSize { get; set; }

Visual Basic [image] Copy Code

Public Property GridSize As Double

Property Value

Remarks

This value is assigned to the GridSize property of the base GridLayout.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.LayerDistance Property

OrthogonalRouter.LayerDistance Property
[image]

Gets or sets the desired distance between layer axis lines.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LayerDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LayerDistance As Double

Property Value

A double value specifying the distance between layers.

Remarks

Gets or sets the distance between layers when BaseLayout is set to Layered or Cascading.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.Name Property

OrthogonalRouter.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.NodeDistance Property

OrthogonalRouter.NodeDistance Property
[image]

Gets or sets the desired distance between adjacent nodes in a layer.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Double

Property Value

Remarks

Gets or sets the distance between nodes in the same layer when BaseLayout is set to Layered or Cascading.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.Orientation Property

OrthogonalRouter.Orientation Property
[image]

Gets or sets the overall orientation of the arranged diagram when BaseLayout is set to Layered.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

An instance of the Orientation enumeration. The default is Vertical.

Remarks

This value is assigned to the Orientation property of the base LayeredLayout.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.PutEndPointsAtNodeBorders Property

OrthogonalRouter.PutEndPointsAtNodeBorders Property
[image]

Gets or sets a value indicating whether the end points of a link should be placed at the outlines of the nodes connected by that link.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool PutEndPointsAtNodeBorders { get; set; }

Visual Basic [image] Copy Code

Public Property PutEndPointsAtNodeBorders As Boolean

Property Value

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.RandomSeed Property

OrthogonalRouter.RandomSeed Property
[image]

Gets or sets the randomization seed to use for generating random node positions.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int RandomSeed { get; set; }

Visual Basic [image] Copy Code

Public Property RandomSeed As Integer

Property Value

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.StartOrientation Property

OrthogonalRouter.StartOrientation Property
[image]

Gets or sets the desired orientation of the first segments of routed links.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation StartOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property StartOrientation As Orientation

Property Value

Remarks

If this property is set to Horizontal, links will end at the left or right sides of nodes. If set to Vertical, links will end at the top or bottom sides.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Path Class

Path Class
[image]

Represents a sequence of connected DiagramNode and DiagramLink elements.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class Path

Visual Basic [image] Copy Code

Public NotInheritable Class Path

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Path

See Also

Path Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Path Members

Path Members
Properties Methods
[image]

Represents a sequence of connected DiagramNode and DiagramLink elements.

The following tables list the members exposed by the Path type.

Public Properties

Name | Description
Items | Gets a collection of all DiagramNode and DiagramLink elements in the path.
Length | Gets the length of the Path expressed as the number of links participating in it.
Links | Gets a collection of all DiagramLink elements participating in the path.
Nodes | Gets a collection of all DiagramNode elements participating in the path.

Public Methods

Name | Description
GetWeight | Calculates the weight of this Path by accumulating the Weight of all participating Diagram elements.

See Also

Path Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Path Methods

Path Methods
[image]

Public Methods

Name | Description
GetWeight | Calculates the weight of this Path by accumulating the Weight of all participating Diagram elements.

See Also

Path Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Path.GetWeight Method

Path.GetWeight Method
[image]

Calculates the weight of this Path by accumulating the Weight of all participating Diagram elements.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double GetWeight (
bool incNodes,
bool incLinks
)

Visual Basic [image] Copy Code

Public Function GetWeight( _
incNodes As Boolean, _
incLinks As Boolean _
) As Double

Parameters

incNodes
A boolean value, which specifies whether the Weight of DiagramNode elements should be considered.
incLinks
A boolean value, which specifies whether the Weight of DiagramLink elements should be considered.

Return Value

A double value that represents the total weight of the elements in this Path according to the incNodes and incLinks parameters.

See Also

Path Members
Path Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Path Properties

Path Properties
[image]

Public Properties

Name | Description
Items | Gets a collection of all DiagramNode and DiagramLink elements in the path.
Length | Gets the length of the Path expressed as the number of links participating in it.
Links | Gets a collection of all DiagramLink elements participating in the path.
Nodes | Gets a collection of all DiagramNode elements participating in the path.

See Also

Path Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Path.Items Property

Path.Items Property
[image]

Gets a collection of all DiagramNode and DiagramLink elements in the path.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemCollection Items { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Items As DiagramItemCollection

Property Value

An instance of the DiagramItemCollection class.

Remarks

The collection contains consecutive DiagramNode and DiagramLink objects.

See Also

Path Members
Path Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Path.Length Property

Path.Length Property
[image]

Gets the length of the Path expressed as the number of links participating in it.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Length { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Length As Integer

Property Value

An integer value that represents the number of edges (links) in the path.

See Also

Path Members
Path Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Path.Links Property

Path.Links Property
[image]

Gets a collection of all DiagramLink elements participating in the path.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection Links { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Links As DiagramLinkCollection

Property Value

An instance of the DiagramLinkCollection class.

Remarks

Use Nodes to get all DiagramNode elements in the Path.

See Also

Path Members
Path Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Path.Nodes Property

Path.Nodes Property
[image]

Gets a collection of all DiagramNode elements participating in the path.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemCollection Nodes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Nodes As DiagramItemCollection

Property Value

An instance of the DiagramItemCollection class.

Remarks

Use Links to get all DiagramLinks elements in the Path.

See Also

Path Members
Path Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.PathFinder Class

PathFinder Class
Remarks See Also
[image]

Provides methods that help you find paths and cycles in a graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class PathFinder

Visual Basic [image] Copy Code

Public NotInheritable Class PathFinder

Remarks

By default the direction of links is taken into account when looking for paths or cycles. In that case the direction of a path is considered to be the direction defined by the outgoing links of nodes. Use the second constructor override to specify that link direction should be ignored when looking for paths.

A path-finder object caches graph information between method calls in order to achieve better performance when path and cycle -finding methods are called on the same diagram more than once. However if the diagram structure changes, you must create a new PathFinder instance in order to use the new structure of the diagram graph.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.PathFinder

See Also

PathFinder Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.PathFinder Members

PathFinder Members
Constructors Methods
[image]

Provides methods that help you find paths and cycles in a graph.

The following tables list the members exposed by the PathFinder type.

Public Constructors

Name | Description
PathFinder | Overloaded.

Public Methods

Name | Description
FindAllCycles | Finds all cycles in the underlying diagram.
FindAllPaths | Overloaded. Finds and returns all paths that exist between two DiagramNode objects.
FindCycle | Overloaded. Finds a cycle in the underlying diagram.
FindLongestPath | Overloaded. Finds the longest path in the underlying diagram.
FindShortestPath | Overloaded. Finds the shortest path in the underlying diagram.

See Also

PathFinder Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.PathFinder Constructor

PathFinder Constructor
[image]

Overload List

Name | Description
PathFinder (Diagram) | Initializes a new instance of the PathFinder class. Path-finding will depend on the direction of links.
PathFinder (Diagram, Boolean) | Initializes a new instance of the PathFinder class, optionally ignoring the link direction.

See Also

PathFinder Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.PathFinder Constructor (Diagram)

PathFinder Constructor (Diagram)
See Also
[image]

Initializes a new instance of the PathFinder class. Path-finding will depend on the direction of links.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PathFinder (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram
An instance of the Diagram class in which to look for paths or cycles.

Remarks

The PathFinder methods look for paths and cycles in the Diagram instance specified through the argument. The diagram is treated as a directed graph and the direction of links is considered when looking for a path, that is, a path continues from a node only through its OutgoingLinks.

See Also

PathFinder Constructor Overload List
PathFinder Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.PathFinder Constructor (Diagram, Boolean)

PathFinder Constructor (Diagram, Boolean)
See Also
[image]

Initializes a new instance of the PathFinder class, optionally ignoring the link direction.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PathFinder (
Diagram diagram,
bool ignoreDirection
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram, _
ignoreDirection As Boolean _
)

Parameters

diagram
A Diagram instance in which to look for paths or cycles.
ignoreDirection

Specifies whether the direction of links should be considered when looking for paths or cycles.

Remarks

The PathFinder methods look for paths and cycles in the Diagram instance specified with the first argument. By default, the diagram is treated as a directed graph and the direction of links is considered when looking for a path, that is, a path continues from a node only through its OutgoingLinks.

To ignore the direction of links, pass true as a value of the ignoreDirection argument; then the path-finding algorithm will look for paths both through the OutgoingLinks and IncomingLinks collections of nodes. If you do not want to ignore the direction of links you can use the alternative constructor.

See Also

PathFinder Constructor Overload List
PathFinder Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.PathFinder Methods

PathFinder Methods
[image]

Public Methods

Name | Description
FindAllCycles | Finds all cycles in the underlying diagram.
FindAllPaths | Overloaded. Finds and returns all paths that exist between two DiagramNode objects.
FindCycle | Overloaded. Finds a cycle in the underlying diagram.
FindLongestPath | Overloaded. Finds the longest path in the underlying diagram.
FindShortestPath | Overloaded. Finds the shortest path in the underlying diagram.

See Also

PathFinder Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.PathFinder.FindAllCycles Method

PathFinder.FindAllCycles Method
[image]

Finds all cycles in the underlying diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<Path> FindAllCycles ()

Visual Basic [image] Copy Code

Public Function FindAllCycles () As List(Of Path)

Return Value

A collection of Path objects; if no cycles are detected, the collection is empty.

See Also

PathFinder Members
PathFinder Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.PathFinder.FindAllPaths Method

PathFinder.FindAllPaths Method
[image]

Finds and returns all paths that exist between two DiagramNode objects.

Overload List

Name | Description
PathFinder.FindAllPaths (DiagramNode, DiagramNode) | Finds and returns all paths that exist between two DiagramNode objects.
PathFinder.FindAllPaths (DiagramNode, DiagramNode, Int32) | Finds and returns all paths that exist between two DiagramNode objects.

See Also

PathFinder Members
PathFinder Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.PathFinder.FindAllPaths Method (DiagramNode, DiagramNode)

PathFinder.FindAllPaths Method (DiagramNode, DiagramNode)
See Also
[image]

Finds and returns all paths that exist between two DiagramNode objects.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<Path> FindAllPaths (
DiagramNode from,
DiagramNode to
)

Visual Basic [image] Copy Code

Public Function FindAllPaths ( _
from As DiagramNode, _
to As DiagramNode _
) As List(Of Path)

Parameters

from
The first DiagramNode in the Path.
to
The last DiagramNode in the Path.

Return Value

A collection of Path objects; if no paths are found, the collection is empty.

Remarks

The returned Path instances include the from an to nodes.

See Also

FindAllPaths Method Overload List
PathFinder Members
PathFinder Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.PathFinder.FindAllPaths Method (DiagramNode, DiagramNode, Int32)

PathFinder.FindAllPaths Method (DiagramNode, DiagramNode, Int32)
See Also
[image]

Finds and returns all paths that exist between two DiagramNode objects.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<Path> FindAllPaths (
DiagramNode from,
DiagramNode to,
int maxPaths
)

Visual Basic [image] Copy Code

Public Function FindAllPaths ( _
from As DiagramNode, _
to As DiagramNode, _
maxPaths As Integer _
) As List(Of Path)

Parameters

from
The first DiagramNode in the Path.
to
The last DiagramNode in the Path.
maxPaths

The maximum number of paths to find.

Return Value

A collection of Path objects; if no paths are found, the collection is empty.

Remarks

The returned Path instances include the from an to nodes.

See Also

FindAllPaths Method Overload List
PathFinder Members
PathFinder Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.PathFinder.FindCycle Method

PathFinder.FindCycle Method
[image]

Finds a cycle in the underlying diagram.

Overload List

Name | Description
PathFinder.FindCycle () | Finds a cycle in the Diagram.
PathFinder.FindCycle (DiagramNode) | Detects whether the specified DiagramNode participates in a cycle.

See Also

PathFinder Members
PathFinder Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.PathFinder.FindCycle Method ()

PathFinder.FindCycle Method ()
See Also
[image]

Finds a cycle in the Diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Path FindCycle ()

Visual Basic [image] Copy Code

Public Function FindCycle () As Path

Return Value

A Path instance that represents the found cycle; null (Nothing in Visual Basic) if no cycle is detected.

See Also

FindCycle Method Overload List
PathFinder Members
PathFinder Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.PathFinder.FindCycle Method (DiagramNode)

PathFinder.FindCycle Method (DiagramNode)
See Also
[image]

Detects whether the specified DiagramNode participates in a cycle.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Path FindCycle (
DiagramNode participant
)

Visual Basic [image] Copy Code

Public Function FindCycle ( _
participant As DiagramNode _
) As Path

Parameters

participant
A DiagramNode element which should participate in the found cycle.

Return Value

A Path instance that represents the found cycle; null (Nothing in Visual Basic) if no cycle is detected.

See Also

FindCycle Method Overload List
PathFinder Members
PathFinder Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.PathFinder.FindLongestPath Method

PathFinder.FindLongestPath Method
[image]

Finds the longest path in the underlying diagram.

Overload List

Name | Description
PathFinder.FindLongestPath () | Finds the longest path in the graph.
PathFinder.FindLongestPath (DiagramNode, DiagramNode) | Finds the longest path between the specified DiagramNode objects.
PathFinder.FindLongestPath (Int64) | Finds the longest path in the diagram.

See Also

PathFinder Members
PathFinder Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.PathFinder.FindLongestPath Method ()

PathFinder.FindLongestPath Method ()
See Also
[image]

Finds the longest path in the graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Path FindLongestPath ()

Visual Basic [image] Copy Code

Public Function FindLongestPath () As Path

Return Value

A Path instance that represents the longest path found; null (Nothing in Visual Basic) if there are no DiagramNode elements in the graph.

See Also

FindLongestPath Method Overload List
PathFinder Members
PathFinder Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.PathFinder.FindLongestPath Method (DiagramNode, DiagramNode)

PathFinder.FindLongestPath Method (DiagramNode, DiagramNode)
See Also
[image]

Finds the longest path between the specified DiagramNode objects.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Path FindLongestPath (
DiagramNode from,
DiagramNode to
)

Visual Basic [image] Copy Code

Public Function FindLongestPath ( _
from As DiagramNode, _
to As DiagramNode _
) As Path

Parameters

from
The first DiagramNode element in the Path.
to
The last DiagramNode element in the Path.

Return Value

A Path instance that represents the longest path found; null (Nothing in Visual Basic) if there is no Path connecting from and to.

See Also

FindLongestPath Method Overload List
PathFinder Members
PathFinder Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.PathFinder.FindLongestPath Method (Int64)

PathFinder.FindLongestPath Method (Int64)
See Also
[image]

Finds the longest path in the diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Path FindLongestPath (
long timeLimit
)

Visual Basic [image] Copy Code

Public Function FindLongestPath ( _
timeLimit As Long _
) As Path

Parameters

timeLimit

The maximum duaration of the search process, in milliseconds.

Return Value

The longest Path found; null (Nothing in Visual Basic) if no Path has been found.

See Also

FindLongestPath Method Overload List
PathFinder Members
PathFinder Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.PathFinder.FindShortestPath Method

PathFinder.FindShortestPath Method
[image]

Finds the shortest path in the underlying diagram.

Overload List

Name | Description
PathFinder.FindShortestPath (DiagramNode, DiagramNode) | Finds and returns the shortest Path between the specified DiagramNode objects.
PathFinder.FindShortestPath (DiagramNode, DiagramNode, Boolean, Boolean) | Finds and returns the shortest path between two DiagramNode elements, considering the Weight of the nodes, the Weight of the links or both.

See Also

PathFinder Members
PathFinder Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.PathFinder.FindShortestPath Method (DiagramNode, DiagramNode)

PathFinder.FindShortestPath Method (DiagramNode, DiagramNode)
See Also
[image]

Finds and returns the shortest Path between the specified DiagramNode objects.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Path FindShortestPath (
DiagramNode from,
DiagramNode to
)

Visual Basic [image] Copy Code

Public Function FindShortestPath ( _
from As DiagramNode, _
to As DiagramNode _
) As Path

Parameters

from
The first DiagramNode in the Path.
to
The last DiagramNode in the Path.

Return Value

A Path instance that represents the shortest path found; null (Nothing in Visual Basic) if there is no path connecting from and to.

See Also

FindShortestPath Method Overload List
PathFinder Members
PathFinder Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.PathFinder.FindShortestPath Method (DiagramNode, DiagramNode, Boolean, Boolean)

PathFinder.FindShortestPath Method (DiagramNode, DiagramNode, Boolean, Boolean)
See Also
[image]

Finds and returns the shortest path between two DiagramNode elements, considering the Weight of the nodes, the Weight of the links or both.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Path FindShortestPath (
DiagramNode from,
DiagramNode to,
bool useNodeWeights,
bool useLinkWeights
)

Visual Basic [image] Copy Code

Public Function FindShortestPath ( _
from As DiagramNode, _
to As DiagramNode, _
useNodeWeights As Boolean, _
useLinkWeights As Boolean _
) As Path

Parameters

from
The first DiagramNode in the Path.
to
The last DiagramNode in the Path.
useNodeWeights
If true, the Path with minimal total weight is found, summing the Weight of nodes in the Path.
useLinkWeights
If true, the Path with minimal total weight is found, summing the Weight of links in the Path.

Return Value

A Path instance that represents the shortest Path found or null (Nothing in Visual Basic) if there is no Path connecting from and to.

See Also

FindShortestPath Method Overload List
PathFinder Members
PathFinder Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SolarLayout Class

SolarLayout Class
[image]

A tree layout algorithm that places child nodes around their parent node, such that the child nodes do not overlap. The algorithm optionally bends the links to prevent them from crossing nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class SolarLayout : Layout

Visual Basic [image] Copy Code

Public Class SolarLayout
Inherits Layout

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.SolarLayout

See Also

SolarLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SolarLayout Members

SolarLayout Members
Constructors Properties Methods
[image]

A tree layout algorithm that places child nodes around their parent node, such that the child nodes do not overlap. The algorithm optionally bends the links to prevent them from crossing nodes.

The following tables list the members exposed by the SolarLayout type.

Public Constructors

Name | Description
SolarLayout | Initializes a new instance of the SolarLayout class.

Public Properties

Name | Description
BendLinks | Gets or sets a value indicating whether links are bend to prevent them from crossing nodes.
HonorInitialNodeDisposition | Gets or sets a value indicating whether the initial position of a child node relative to its parent node is preserved in the final layout.
IgnoreLinkDirection | Gets or sets a value indicating whether the tree layout algorithm should ignore the direction of links when arranging a tree.
KeepRootPosition | Gets or sets a value indicating whether to keep the root node at its original position.
LevelDistance | Gets or sets the minimal distance between a parent node and its children.
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the minimal distance between siblings.
ReversedLinks | Gets or sets a value indicating the link direction that relates parent nodes to child nodes.
Root | Gets or sets the tree root.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

Inherited Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)

See Also

SolarLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SolarLayout Constructor

SolarLayout Constructor
[image]

Initializes a new instance of the SolarLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SolarLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SolarLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SolarLayout Properties

SolarLayout Properties
[image]

Public Properties

Name | Description
BendLinks | Gets or sets a value indicating whether links are bend to prevent them from crossing nodes.
HonorInitialNodeDisposition | Gets or sets a value indicating whether the initial position of a child node relative to its parent node is preserved in the final layout.
IgnoreLinkDirection | Gets or sets a value indicating whether the tree layout algorithm should ignore the direction of links when arranging a tree.
KeepRootPosition | Gets or sets a value indicating whether to keep the root node at its original position.
LevelDistance | Gets or sets the minimal distance between a parent node and its children.
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the minimal distance between siblings.
ReversedLinks | Gets or sets a value indicating the link direction that relates parent nodes to child nodes.
Root | Gets or sets the tree root.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

See Also

SolarLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SolarLayout.BendLinks Property

SolarLayout.BendLinks Property
[image]

Gets or sets a value indicating whether links are bend to prevent them from crossing nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool BendLinks { get; set; }

Visual Basic [image] Copy Code

Public Property BendLinks As Boolean

Property Value

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SolarLayout.DefaultMarginValue Property

SolarLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SolarLayout.HonorInitialNodeDisposition Property

SolarLayout.HonorInitialNodeDisposition Property
[image]

Gets or sets a value indicating whether the initial position of a child node relative to its parent node is preserved in the final layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool HonorInitialNodeDisposition { get; set; }

Visual Basic [image] Copy Code

Public Property HonorInitialNodeDisposition As Boolean

Property Value

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SolarLayout.IgnoreLinkDirection Property

SolarLayout.IgnoreLinkDirection Property
[image]

Gets or sets a value indicating whether the tree layout algorithm should ignore the direction of links when arranging a tree.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IgnoreLinkDirection { get; set; }

Visual Basic [image] Copy Code

Public Property IgnoreLinkDirection As Boolean

Property Value

Remarks

Parent-child direction is considered the one in which nodes go further from the root, instead that of the links.

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SolarLayout.KeepRootPosition Property

SolarLayout.KeepRootPosition Property
[image]

Gets or sets a value indicating whether to keep the root node at its original position.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool KeepRootPosition { get; set; }

Visual Basic [image] Copy Code

Public Property KeepRootPosition As Boolean

Property Value

Remarks

If the root position is not kept, that is, the value of this property is false, the entire tree is dispositioned after the layout is complete, according to the values of Margins.

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SolarLayout.LevelDistance Property

SolarLayout.LevelDistance Property
[image]

Gets or sets the minimal distance between a parent node and its children.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LevelDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LevelDistance As Double

Property Value

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SolarLayout.Name Property

SolarLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SolarLayout.NodeDistance Property

SolarLayout.NodeDistance Property
[image]

Gets or sets the minimal distance between siblings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Double

Property Value

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SolarLayout.ReversedLinks Property

SolarLayout.ReversedLinks Property
[image]

Gets or sets a value indicating the link direction that relates parent nodes to child nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ReversedLinks { get; set; }

Visual Basic [image] Copy Code

Public Property ReversedLinks As Boolean

Property Value

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SolarLayout.Root Property

SolarLayout.Root Property
[image]

Gets or sets the tree root.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As DiagramNode

Property Value

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Class

SpringLayout Class
Remarks See Also
[image]

Implements the Spring-Embedder graph layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class SpringLayout : Layout

Visual Basic [image] Copy Code

Public Class SpringLayout
Inherits Layout

Remarks

Spring-Embedder produces layouts having uniform distribution of nodes by simulating a physical system in which nodes repulse each other and the links between them act as confining springs. Nodes are moved around in an iterative process. The forces that act on a node are calculated, taking in account the positions of surrounding nodes and links from the previous iteration.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.SpringLayout

See Also

SpringLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Members

SpringLayout Members
Constructors Properties Methods
[image]

Implements the Spring-Embedder graph layout algorithm.

The following tables list the members exposed by the SpringLayout type.

Public Constructors

Name | Description
SpringLayout | Overloaded.

Public Properties

Name | Description
EnableClusters | Gets or sets a value indicating whether to enable allocation of nodes to distinct clusters.
IterationCount | Gets or sets for how many iterations to run the layout routine.
LayoutArea | Gets or sets the size of the layout area.
LayoutMethod | Specifies what energy model to use for the simulation.
LinkType | Gets or sets the appearance of the links in the final layout.
MinimizeCrossings | Gets or sets a value indicating whether crossing minimization mode is enabled.
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the desired distance between nodes.
Randomize | Gets or sets a value indicating whether nodes should be placed at random positions when the layout routine starts.
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
RepulsionFactor | Gets or sets the multiplier applied to repulsion forces between nodes.
Root | Gets or sets a node indicating which subgraph of the diagram must be laid out.
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.
Stretch | Gets or sets the link stretch factor.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

Public Methods

Name | Description
BeginArrange | Initializes the layout object for a step-by-step execution.
EndArrange | Completes the step-by-step execution.
Iterate | Runs one or more layout iterations.

Inherited Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)

See Also

SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Constructor

SpringLayout Constructor
[image]

Overload List

Name | Description
SpringLayout () | Initializes a new instance of the SpringLayout class with the default settings.
SpringLayout (Int32, Double, Boolean) | Initializes a new instance of the SpringLayout class with the specified settings.
SpringLayout (Int32, Double, Boolean, Boolean) | Initializes a new instance of the SpringLayout class with the specified settings.

See Also

SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Constructor ()

SpringLayout Constructor ()
See Also
[image]

Initializes a new instance of the SpringLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SpringLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SpringLayout Constructor Overload List
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Constructor (Int32, Double, Boolean)

SpringLayout Constructor (Int32, Double, Boolean)
See Also
[image]

Initializes a new instance of the SpringLayout class with the specified settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SpringLayout (
int iterationCount,
double nodeDistance,
bool minimizeCrossings
)

Visual Basic [image] Copy Code

Public New ( _
iterationCount As Integer, _
nodeDistance As Double, _
minimizeCrossings As Boolean _
)

Parameters

iterationCount

The number of iterations to perform.

nodeDistance

The distance between nodes.

minimizeCrossings

Specifies whether to try to minimize crossings while layouting.

See Also

SpringLayout Constructor Overload List
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Constructor (Int32, Double, Boolean, Boolean)

SpringLayout Constructor (Int32, Double, Boolean, Boolean)
See Also
[image]

Initializes a new instance of the SpringLayout class with the specified settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SpringLayout (
int iterationCount,
double nodeDistance,
bool minimizeCrossings,
bool keepGroupLayout
)

Visual Basic [image] Copy Code

Public New ( _
iterationCount As Integer, _
nodeDistance As Double, _
minimizeCrossings As Boolean, _
keepGroupLayout As Boolean _
)

Parameters

iterationCount

The number of iterations to perform.

nodeDistance

The distance between nodes.

minimizeCrossings

Specifies whether to try to minimize crossings while layouting.

keepGroupLayout

Specifies whether to keep the relative position of grouped items.

See Also

SpringLayout Constructor Overload List
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Methods

SpringLayout Methods
[image]

Public Methods

Name | Description
BeginArrange | Initializes the layout object for a step-by-step execution.
EndArrange | Completes the step-by-step execution.
Iterate | Runs one or more layout iterations.

Inherited Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)

See Also

SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.BeginArrange Method

SpringLayout.BeginArrange Method
[image]

Initializes the layout object for a step-by-step execution.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool BeginArrange (
Diagram diagram,
DiagramItemCollection items
)

Visual Basic [image] Copy Code

Public Function BeginArrange ( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram
The Diagram that is arranged.
items

A collection of nodes and links from diagram that define the subgraph to arrange.

Return Value

Remarks

You can use this method together with Iterate and EndArrange to display an animation of the layout process. To run all iterations of the proces at once and display just the end result, call Arrange.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.EndArrange Method

SpringLayout.EndArrange Method
[image]

Completes the step-by-step execution.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void EndArrange ()

Visual Basic [image] Copy Code

Public Sub EndArrange ()

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.Iterate Method

SpringLayout.Iterate Method
[image]

Runs one or more layout iterations.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Iterate (
int iterationFrom,
int iterationTo
)

Visual Basic [image] Copy Code

Public Sub Iterate( _
iterationFrom As Integer, _
iterationTo As Integer _
)

Parameters

iterationFrom

Specifies from which iteration to start.

iterationTo

Specifies at which iteration to stop.

Remarks

Use this method to create an animation of the layout process, for example, by calling it from a timer. Call BeginArrange to prepare the layout object for use of Iterate, and call EndArrange when done. Each call to Iterate starts from the iteration next to the one where the previous call has stopped.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Properties

SpringLayout Properties
[image]

Public Properties

Name | Description
EnableClusters | Gets or sets a value indicating whether to enable allocation of nodes to distinct clusters.
IterationCount | Gets or sets for how many iterations to run the layout routine.
LayoutArea | Gets or sets the size of the layout area.
LayoutMethod | Specifies what energy model to use for the simulation.
LinkType | Gets or sets the appearance of the links in the final layout.
MinimizeCrossings | Gets or sets a value indicating whether crossing minimization mode is enabled.
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the desired distance between nodes.
Randomize | Gets or sets a value indicating whether nodes should be placed at random positions when the layout routine starts.
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
RepulsionFactor | Gets or sets the multiplier applied to repulsion forces between nodes.
Root | Gets or sets a node indicating which subgraph of the diagram must be laid out.
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.
Stretch | Gets or sets the link stretch factor.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

See Also

SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.DefaultMarginValue Property

SpringLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.EnableClusters Property

SpringLayout.EnableClusters Property
[image]

Gets or sets a value indicating whether to enable allocation of nodes to distinct clusters.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableClusters { get; set; }

Visual Basic [image] Copy Code

Public Property EnableClusters As Boolean

Property Value

true to detect and process node clusters; otherwise, false. The default is false.

Remarks

If enabled, the SpringLayout algorithm detects node clusters and places them at distinct positions. Each cluster consists of a center node surrounded by several local nodes. Clusters might be connected with other clusters through their center nodes. Best-looking results are achieved when there aren't links between the local nodes in a cluster.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.IterationCount Property

SpringLayout.IterationCount Property
[image]

Gets or sets for how many iterations to run the layout routine.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int IterationCount { get; set; }

Visual Basic [image] Copy Code

Public Property IterationCount As Integer

Property Value

An integer number specifying the number of iterations.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.LayoutArea Property

SpringLayout.LayoutArea Property
[image]

Gets or sets the size of the layout area.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect LayoutArea { get; set; }

Visual Basic [image] Copy Code

Public Property LayoutArea As Rect

Property Value

A Windows.UI.Xaml.Rect representing the boundaries of the layout area. The default is Rect.Empty.

Remarks

If the layout area is not explicitly set, the algorithm will choose one suitable for the graph size.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.LayoutMethod Property

SpringLayout.LayoutMethod Property
[image]

Specifies what energy model to use for the simulation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SpringLayoutMethod LayoutMethod { get; set; }

Visual Basic [image] Copy Code

Public Property LayoutMethod As SpringLayoutMethod

Property Value

A member of the SpringLayoutMethod enumeration. The default value is FruchtermanReingold.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.LinkType Property

SpringLayout.LinkType Property
[image]

Gets or sets the appearance of the links in the final layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SpringLayoutLinkType LinkType { get; set; }

Visual Basic [image] Copy Code

Public Property LinkType As SpringLayoutLinkType

Property Value

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.MinimizeCrossings Property

SpringLayout.MinimizeCrossings Property
[image]

Gets or sets a value indicating whether crossing minimization mode is enabled.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool MinimizeCrossings { get; set; }

Visual Basic [image] Copy Code

Public Property MinimizeCrossings As Boolean

Property Value

Remarks

If enabled, the algorithm tries to decrease number of crossing links. For better results, use greater IterationCount.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.Name Property

SpringLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.NodeDistance Property

SpringLayout.NodeDistance Property
[image]

Gets or sets the desired distance between nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Double

Property Value

Remarks

The final distance between connected nodes is determined by multiplying the Weight of the link that connects them by the value of NodeDistance.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.Randomize Property

SpringLayout.Randomize Property
[image]

Gets or sets a value indicating whether nodes should be placed at random positions when the layout routine starts.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Randomize { get; set; }

Visual Basic [image] Copy Code

Public Property Randomize As Boolean

Property Value

true to start with random node positions, otherwise false. The default value is false.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace
RandomSeed Property


MindFusion.Diagramming.Layout.SpringLayout.RandomSeed Property

SpringLayout.RandomSeed Property
[image]

Gets or sets the randomization seed to use for generating random node positions.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int RandomSeed { get; set; }

Visual Basic [image] Copy Code

Public Property RandomSeed As Integer

Property Value

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.RepulsionFactor Property

SpringLayout.RepulsionFactor Property
[image]

Gets or sets the multiplier applied to repulsion forces between nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double RepulsionFactor { get; set; }

Visual Basic [image] Copy Code

Public Property RepulsionFactor As Double

Property Value

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.Root Property

SpringLayout.Root Property
[image]

Gets or sets a node indicating which subgraph of the diagram must be laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As DiagramNode

Property Value

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.SplitGraph Property

SpringLayout.SplitGraph Property
[image]

Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SplitGraph { get; set; }

Visual Basic [image] Copy Code

Public Property SplitGraph As Boolean

Property Value

true if unconnected graphs in the diagram should be laid out independently; otherwise, false. The default is true.

Remarks

If this property is set to true, each independent graph in the diagram is laid out in its own layout area. Otherwise all subgraphs are arranged in the same layout area. If a Root node is specified and SplitGraph is enabled, only the graph that contains the root node will be arranged.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.Stretch Property

SpringLayout.Stretch Property
[image]

Gets or sets the link stretch factor.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Stretch { get; set; }

Visual Basic [image] Copy Code

Public Property Stretch As Double

Property Value

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayoutLinkType Enumeration

SpringLayoutLinkType Enumeration
[image]

Specifies the style of the diagram links after they are laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum SpringLayoutLinkType

Visual Basic [image] Copy Code

Public Enum SpringLayoutLinkType

Members

Member name | Description
Rounded | Indicates Bézier links with a single segment.
Straight | Indicates straight links with a single segment.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout Class

SwimlaneLayout Class
Remarks See Also
[image]

Implements an algorithm which arranges nodes in lanes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class SwimlaneLayout : Layout

Visual Basic [image] Copy Code

Public Class SwimlaneLayout
Inherits Layout

Remarks

This layout algorithm can be used to arrange process diagrams in which nodes representing activities are placed in swimlanes representing resources. The index of the resource allocated to an activity should be assigned to the corresponding node's LayoutTraits[SwimlaneLayoutTraits.Lane].

By default, the algorithm works with the diagram's LaneGrid, but its SwimlaneGrid property can be set to any class that implements ISwimlaneGrid. This allows applying the layout to a custom-drawn grid rendered via a control template, or one composed of locked background nodes.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.SwimlaneLayout

See Also

SwimlaneLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout Members

SwimlaneLayout Members
Constructors Properties Methods
[image]

Implements an algorithm which arranges nodes in lanes.

The following tables list the members exposed by the SwimlaneLayout type.

Public Constructors

Name | Description
SwimlaneLayout | Initializes a new instance of the SwimlaneLayout class with the default settings.

Public Properties

Name | Description
CollapseEmptyLanes | Get or sets a value indicating whether lanes without associated nodes will shrink to zero size. By default, empty lanes will have size equal to LaneDistance.
CompactNodes | Gets or sets a value indicating whether the nodes within individual lanes are compacted.
CustomSortOrder | Gets or sets a value indicating whether the nodes in a lane should be arranged according to the custom sort order specified through LayoutTraits.
Direction | Gets or sets the direction of the arranged diagram.
KeepLaneSizes | Gets or sets a value indicating whether the layout will attempt to preserve the original sizes of the lanes in the supplied grid.
LaneDistance | Gets or sets the spacing between adjacent lanes in the final layout.
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the spacing between adjacent nodes within a lane in the final layout.
Orientation | Gets or sets the overall orientation of the arranged diagram.
SwimlaneGrid | Gets or sets the object through which the layout can manipulate the swimlane grid.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

Inherited Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)

See Also

SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout Constructor

SwimlaneLayout Constructor
[image]

Initializes a new instance of the SwimlaneLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SwimlaneLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout Properties

SwimlaneLayout Properties
[image]

Public Properties

Name | Description
CollapseEmptyLanes | Get or sets a value indicating whether lanes without associated nodes will shrink to zero size. By default, empty lanes will have size equal to LaneDistance.
CompactNodes | Gets or sets a value indicating whether the nodes within individual lanes are compacted.
CustomSortOrder | Gets or sets a value indicating whether the nodes in a lane should be arranged according to the custom sort order specified through LayoutTraits.
Direction | Gets or sets the direction of the arranged diagram.
KeepLaneSizes | Gets or sets a value indicating whether the layout will attempt to preserve the original sizes of the lanes in the supplied grid.
LaneDistance | Gets or sets the spacing between adjacent lanes in the final layout.
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the spacing between adjacent nodes within a lane in the final layout.
Orientation | Gets or sets the overall orientation of the arranged diagram.
SwimlaneGrid | Gets or sets the object through which the layout can manipulate the swimlane grid.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

See Also

SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.CollapseEmptyLanes Property

SwimlaneLayout.CollapseEmptyLanes Property
[image]

Get or sets a value indicating whether lanes without associated nodes will shrink to zero size. By default, empty lanes will have size equal to LaneDistance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool CollapseEmptyLanes { get; set; }

Visual Basic [image] Copy Code

Public Property CollapseEmptyLanes As Boolean

Property Value

true to collapse empty lanes, otherwise false. The default value is false.

Remarks

To be able to shrink the lanes of a LaneGrid to zero size, the MinHeaderSize property of the lane grid must be set to an appropriate value.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.CompactNodes Property

SwimlaneLayout.CompactNodes Property
[image]

Gets or sets a value indicating whether the nodes within individual lanes are compacted.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool CompactNodes { get; set; }

Visual Basic [image] Copy Code

Public Property CompactNodes As Boolean

Property Value

true to compact nodes, otherwise false. The default value is true.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.CustomSortOrder Property

SwimlaneLayout.CustomSortOrder Property
[image]

Gets or sets a value indicating whether the nodes in a lane should be arranged according to the custom sort order specified through LayoutTraits.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool CustomSortOrder { get; set; }

Visual Basic [image] Copy Code

Public Property CustomSortOrder As Boolean

Property Value

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.DefaultMarginValue Property

SwimlaneLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.Direction Property

SwimlaneLayout.Direction Property
[image]

Gets or sets the direction of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Direction Direction { get; set; }

Visual Basic [image] Copy Code

Public Property Direction As Direction

Property Value

A member of the Direction enumeration. The default value is Straight.

Remarks

If Orientation is set to Horizontal, Direction.Straight stands for "left to right" and Direction.Reversed for "right to left". If Orientation is set to Vertical, Direction.Straight stands for "top to bottom" and Direction.Reversed for "bottom to top".

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.KeepLaneSizes Property

SwimlaneLayout.KeepLaneSizes Property
[image]

Gets or sets a value indicating whether the layout will attempt to preserve the original sizes of the lanes in the supplied grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool KeepLaneSizes { get; set; }

Visual Basic [image] Copy Code

Public Property KeepLaneSizes As Boolean

Property Value

true to preserve lane sizes, otherwise false. The default value is false.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.LaneDistance Property

SwimlaneLayout.LaneDistance Property
[image]

Gets or sets the spacing between adjacent lanes in the final layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LaneDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LaneDistance As Double

Property Value

The default value is 75.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.Name Property

SwimlaneLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Swimlane layout".

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.NodeDistance Property

SwimlaneLayout.NodeDistance Property
[image]

Gets or sets the spacing between adjacent nodes within a lane in the final layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Double

Property Value

The default value is 92.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.Orientation Property

SwimlaneLayout.Orientation Property
[image]

Gets or sets the overall orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Horizontal.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.SwimlaneGrid Property

SwimlaneLayout.SwimlaneGrid Property
[image]

Gets or sets the object through which the layout can manipulate the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ISwimlaneGrid SwimlaneGrid { get; set; }

Visual Basic [image] Copy Code

Public Property SwimlaneGrid As ISwimlaneGrid

Property Value

Remarks

If this is null at the time of layout, the layout will operate on the diagram's lane grid.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout Class

TopologicalLayout Class
Remarks See Also
[image]

Implements a topological ordering.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TopologicalLayout : Layout

Visual Basic [image] Copy Code

Public Class TopologicalLayout
Inherits Layout

Remarks

If the underlying graph if acyclic, TopologicalLayout arranges the nodes linearly in such a way that each node comes before all destination nodes of its outgoing links. The links are drawn as curves above the chain of nodes, with their height proportional to the distance between the nodes. If the graph is not acyclic, the layout algorithm finds an ordering with a minimal number of back links, and draws the back links below the chain of nodes.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.TopologicalLayout

See Also

TopologicalLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout Members

TopologicalLayout Members
Constructors Properties Methods
[image]

Implements a topological ordering.

The following tables list the members exposed by the TopologicalLayout type.

Public Constructors

Name | Description
TopologicalLayout | Initializes a new instance of the TopologicalLayout class.

Public Properties

Name | Description
BendAdjacentLinks | Gets or sets a value indicating whether to bend links connecting adjacent nodes or draw them as straight lines.
Direction | Gets or sets the direction of the arranged diagram.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the distance between adjacent nodes in the diagram.
Orientation | Gets or sets the overall orientation of the arranged diagram.
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

Inherited Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)

See Also

TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout Constructor

TopologicalLayout Constructor
[image]

Initializes a new instance of the TopologicalLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TopologicalLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout Properties

TopologicalLayout Properties
[image]

Public Properties

Name | Description
BendAdjacentLinks | Gets or sets a value indicating whether to bend links connecting adjacent nodes or draw them as straight lines.
Direction | Gets or sets the direction of the arranged diagram.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the distance between adjacent nodes in the diagram.
Orientation | Gets or sets the overall orientation of the arranged diagram.
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

See Also

TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout.BendAdjacentLinks Property

TopologicalLayout.BendAdjacentLinks Property
[image]

Gets or sets a value indicating whether to bend links connecting adjacent nodes or draw them as straight lines.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool BendAdjacentLinks { get; set; }

Visual Basic [image] Copy Code

Public Property BendAdjacentLinks As Boolean

Property Value

true to bend adjacent links; otherwise, false. The default value is false.

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout.DefaultMarginValue Property

TopologicalLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout.Direction Property

TopologicalLayout.Direction Property
[image]

Gets or sets the direction of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Direction Direction { get; set; }

Visual Basic [image] Copy Code

Public Property Direction As Direction

Property Value

A member of the Direction enumeration. The default value is Straight.

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout.MultipleGraphsPlacement Property

TopologicalLayout.MultipleGraphsPlacement Property
[image]

Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public new MultipleGraphsPlacement MultipleGraphsPlacement { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property MultipleGraphsPlacement As MultipleGraphsPlacement

Property Value

A member of the MultipleGraphsPlacement enumeration. The default value is Vertical.

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout.Name Property

TopologicalLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout.NodeDistance Property

TopologicalLayout.NodeDistance Property
[image]

Gets or sets the distance between adjacent nodes in the diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Double

Property Value

A double value specifying the distance between nodes. The default value is 75.

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout.Orientation Property

TopologicalLayout.Orientation Property
[image]

Gets or sets the overall orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Horizontal.

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout.SplitGraph Property

TopologicalLayout.SplitGraph Property
[image]

Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SplitGraph { get; set; }

Visual Basic [image] Copy Code

Public Property SplitGraph As Boolean

Property Value

true to arrange each subgraph on its own; otherwise, false. The default value is true.

Remarks

If this property is set to true, each independent graph in the diagram is laid out in its own layout area. Otherwise all subgraphs are arranged in the same layout area.

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace
MultipleGraphsPlacement Property


MindFusion.Diagramming.Layout.TreeLayout Class

TreeLayout Class
Remarks See Also
[image]

Implements several algorithms for arranging tree structures.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TreeLayout : Layout

Visual Basic [image] Copy Code

Public Class TreeLayout
Inherits Layout

Remarks

Call the Arrange method of a TreeLayout instance to apply directional or radial layout on a tree/subtree in the current diagram.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.TreeLayout

See Also

TreeLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Members

TreeLayout Members
Constructors Properties Methods
[image]

Implements several algorithms for arranging tree structures.

The following tables list the members exposed by the TreeLayout type.

Public Constructors

Name | Description
TreeLayout | Overloaded.

Public Properties

Name | Description
Balance | Gets or sets a value indicating the ordering of the child nodes in order to produce layouts with custom balance.
CompactAssistants | Gets or sets a value indicating whether the "assistant" nodes on the same side of a single parent are arranged as close enough to each other as possible. Turning this off will force the nodes on one side to be aligned with their counterparts in the other and occasionally leaving space between adjacent branches.
Direction | Gets or sets the tree direction.
EnableAssistants | Gets or sets a value indicating whether the "assistant" trait is regarded when performing the layout.
IgnoreLinkDirection | Gets or sets a value indicating whether the tree layout algorithm should ignore the direction of links when arranging a tree.
KeepRootPosition | Gets or sets a value indicating whether to keep the root node at its original position.
LevelDistance | Gets or sets how much space to leave between levels of the tree.
LinkOffset | Gets or sets the links' offset from the centers of the nodes. This property is applicable only for Centered tree layouts.
LinkStyle | Gets or sets a value indicating how links in the arranged tree should look.
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets how much space to leave between nodes on the same level.
ReversedLinks | Gets or sets a value indicating the link direction that relates parent nodes to child nodes.
Root | Gets or sets the root node of the tree.
StretchFactor | Gets or sets the stretch factor applied on Radial tree layouts.
Type | Gets or sets what type of tree layout to apply to the diagram.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

Public Methods

Name | Description
UpdateLink | Updates the style and position of the specified link.

Inherited Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)

See Also

TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor

TreeLayout Constructor
[image]

Overload List

Name | Description
TreeLayout () | Initializes a new instance of the TreeLayout class with the default settings.
TreeLayout (Object) | Initializes a new instance of the TreeLayout class with the specified node as root.
TreeLayout (Object, TreeLayoutType) | Initializes a new instance of the TreeLayout class with the specified node as root and the specified type.
TreeLayout (Object, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Double, Double, Boolean, Size) | Initializes a new instance of the TreeLayout class with the specified settings.
TreeLayout (Object, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Double, Double, Boolean, Size, Boolean) | Initializes a new instance of the TreeLayout class.
TreeLayout (TreeLayoutType) | Initializes a new instance of the TreeLayout class with the specified type.

See Also

TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor ()

TreeLayout Constructor ()
See Also
[image]

Initializes a new instance of the TreeLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor (Object)

TreeLayout Constructor (Object)
See Also
[image]

Initializes a new instance of the TreeLayout class with the specified node as root.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayout (
Object root
)

Visual Basic [image] Copy Code

Public New ( _
root As Object _
)

Parameters

root

The root of the arranged tree.

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor (Object, TreeLayoutType)

TreeLayout Constructor (Object, TreeLayoutType)
See Also
[image]

Initializes a new instance of the TreeLayout class with the specified node as root and the specified type.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayout (
Object root,
TreeLayoutType type
)

Visual Basic [image] Copy Code

Public New ( _
root As Object, _
type As TreeLayoutType _
)

Parameters

root

The root of the arranged tree.

type

The type of the tree layout.

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor (Object, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Double, Double, Boolean, Size)

TreeLayout Constructor (Object, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Double, Double, Boolean, Size)
See Also
[image]

Initializes a new instance of the TreeLayout class with the specified settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayout (
Object root,
TreeLayoutType type,
bool reversedLinks,
TreeLayoutLinkType linkStyle,
TreeLayoutDirections direction,
double levelDistance,
double nodeDistance,
bool keepRootPosition,
Size margins
)

Visual Basic [image] Copy Code

Public New ( _
root As Object, _
type As TreeLayoutType, _
reversedLinks As Boolean, _
linkStyle As TreeLayoutLinkType, _
direction As TreeLayoutDirections, _
levelDistance As Double, _
nodeDistance As Double, _
keepRootPosition As Boolean, _
margins As Size _
)

Parameters

root

The root of the arranged tree.

type

The type of the tree layout.

reversedLinks

Specifies whether the parent-to-child direction in the tree should be reversed, that is, from the end of the link towards its beginning.

linkStyle

The style of the links in the produced layout.

direction

The layout direction.

levelDistance

The distance between adjacent levels.

nodeDistance

The distance between adjacent nodes.

keepRootPosition

Specifies whether to keep the position of the tree root.

margins

The margin between the produced tree and the left side of the diagram bounding rectangle.

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor (Object, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Double, Double, Boolean, Size, Boolean)

TreeLayout Constructor (Object, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Double, Double, Boolean, Size, Boolean)
See Also
[image]

Initializes a new instance of the TreeLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayout (
Object root,
TreeLayoutType type,
bool reversedLinks,
TreeLayoutLinkType linkStyle,
TreeLayoutDirections direction,
double levelDistance,
double nodeDistance,
bool keepRootPosition,
Size margins,
bool keepGroupLayout
)

Visual Basic [image] Copy Code

Public New ( _
root As Object, _
type As TreeLayoutType, _
reversedLinks As Boolean, _
linkStyle As TreeLayoutLinkType, _
direction As TreeLayoutDirections, _
levelDistance As Double, _
nodeDistance As Double, _
keepRootPosition As Boolean, _
margins As Size, _
keepGroupLayout As Boolean _
)

Parameters

root

The root of the arranged tree.

type

The type of the tree layout.

reversedLinks

Specifies whether the parent-to-child direction in the tree should be reversed, that is, from the end of the link towards its beginning.

linkStyle

The style of the links in the produced layout.

direction

The layout direction.

levelDistance

The distance between adjacent levels.

nodeDistance

The distance between adjacent nodes.

keepRootPosition

Specifies whether to keep the position of the tree root.

margins

The margin between the produced tree and the left side of the diagram bounding rectangle.

keepGroupLayout

Specifies whether to keep the relative position of grouped items.

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor (TreeLayoutType)

TreeLayout Constructor (TreeLayoutType)
See Also
[image]

Initializes a new instance of the TreeLayout class with the specified type.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayout (
TreeLayoutType type
)

Visual Basic [image] Copy Code

Public New ( _
type As TreeLayoutType _
)

Parameters

type

The type of the tree layout.

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Methods

TreeLayout Methods
[image]

Public Methods

Name | Description
UpdateLink | Updates the style and position of the specified link.

Inherited Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)

See Also

TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.UpdateLink Method

TreeLayout.UpdateLink Method
[image]

Updates the style and position of the specified link.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void UpdateLink (
DiagramLink a,
bool ignoredDirection
)

Visual Basic [image] Copy Code

Public Sub UpdateLink ( _
a As DiagramLink, _
ignoredDirection As Boolean _
)

Parameters

a
A DiagramLink that will be updated.
ignoredDirection

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Properties

TreeLayout Properties
[image]

Public Properties

Name | Description
Balance | Gets or sets a value indicating the ordering of the child nodes in order to produce layouts with custom balance.
CompactAssistants | Gets or sets a value indicating whether the "assistant" nodes on the same side of a single parent are arranged as close enough to each other as possible. Turning this off will force the nodes on one side to be aligned with their counterparts in the other and occasionally leaving space between adjacent branches.
Direction | Gets or sets the tree direction.
EnableAssistants | Gets or sets a value indicating whether the "assistant" trait is regarded when performing the layout.
IgnoreLinkDirection | Gets or sets a value indicating whether the tree layout algorithm should ignore the direction of links when arranging a tree.
KeepRootPosition | Gets or sets a value indicating whether to keep the root node at its original position.
LevelDistance | Gets or sets how much space to leave between levels of the tree.
LinkOffset | Gets or sets the links' offset from the centers of the nodes. This property is applicable only for Centered tree layouts.
LinkStyle | Gets or sets a value indicating how links in the arranged tree should look.
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets how much space to leave between nodes on the same level.
ReversedLinks | Gets or sets a value indicating the link direction that relates parent nodes to child nodes.
Root | Gets or sets the root node of the tree.
StretchFactor | Gets or sets the stretch factor applied on Radial tree layouts.
Type | Gets or sets what type of tree layout to apply to the diagram.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

See Also

TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.Balance Property

TreeLayout.Balance Property
[image]

Gets or sets a value indicating the ordering of the child nodes in order to produce layouts with custom balance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayoutBalance Balance { get; set; }

Visual Basic [image] Copy Code

Public Property Balance As TreeLayoutBalance

Property Value

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.CompactAssistants Property

TreeLayout.CompactAssistants Property
[image]

Gets or sets a value indicating whether the "assistant" nodes on the same side of a single parent are arranged as close enough to each other as possible. Turning this off will force the nodes on one side to be aligned with their counterparts in the other and occasionally leaving space between adjacent branches.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool CompactAssistants { get; set; }

Visual Basic [image] Copy Code

Public Property CompactAssistants As Boolean

Property Value

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.DefaultMarginValue Property

TreeLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.Direction Property

TreeLayout.Direction Property
[image]

Gets or sets the tree direction.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayoutDirection Direction { get; set; }

Visual Basic [image] Copy Code

Public Property Direction As TreeLayoutDirection

Property Value

A member of the TreeLayoutDirection.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.EnableAssistants Property

TreeLayout.EnableAssistants Property
[image]

Gets or sets a value indicating whether the "assistant" trait is regarded when performing the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableAssistants { get; set; }

Visual Basic [image] Copy Code

Public Property EnableAssistants As Boolean

Property Value

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.IgnoreLinkDirection Property

TreeLayout.IgnoreLinkDirection Property
[image]

Gets or sets a value indicating whether the tree layout algorithm should ignore the direction of links when arranging a tree.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IgnoreLinkDirection { get; set; }

Visual Basic [image] Copy Code

Public Property IgnoreLinkDirection As Boolean

Property Value

Remarks

Parent-child direction is considered the one in which nodes go further from the root, instead that of the links. If IgnoreLinkDirection is set to true, you must explicitly specify the tree Root.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.KeepRootPosition Property

TreeLayout.KeepRootPosition Property
[image]

Gets or sets a value indicating whether to keep the root node at its original position.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool KeepRootPosition { get; set; }

Visual Basic [image] Copy Code

Public Property KeepRootPosition As Boolean

Property Value

true to keep the root position; otherwise, false.

Remarks

If the root position is not kept, that is, the value of this property is false, the entire tree is dispositioned after the layout is complete, according to the values of Margins.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.LevelDistance Property

TreeLayout.LevelDistance Property
[image]

Gets or sets how much space to leave between levels of the tree.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LevelDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LevelDistance As Double

Property Value

A double value specifying the distance between adjacent levels in the tree.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.LinkOffset Property

TreeLayout.LinkOffset Property
[image]

Gets or sets the links' offset from the centers of the nodes. This property is applicable only for Centered tree layouts.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LinkOffset { get; set; }

Visual Basic [image] Copy Code

Public Property LinkOffset As Double

Property Value

A double value.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.LinkStyle Property

TreeLayout.LinkStyle Property
[image]

Gets or sets a value indicating how links in the arranged tree should look.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayoutLinkType LinkStyle { get; set; }

Visual Basic [image] Copy Code

Public Property LinkStyle As TreeLayoutLinkType

Property Value

Remarks

This property is ignored if Type is set to Radial.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.Name Property

TreeLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.NodeDistance Property

TreeLayout.NodeDistance Property
[image]

Gets or sets how much space to leave between nodes on the same level.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Double

Property Value

Remarks

This property is ignored if Type is set to Radial.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.ReversedLinks Property

TreeLayout.ReversedLinks Property
[image]

Gets or sets a value indicating the link direction that relates parent nodes to child nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ReversedLinks { get; set; }

Visual Basic [image] Copy Code

Public Property ReversedLinks As Boolean

Property Value

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.Root Property

TreeLayout.Root Property
[image]

Gets or sets the root node of the tree.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As DiagramNode

Property Value

A DiagramNode instance specifying the root of the tree.

Remarks

If not set, the layout will try to find the root automatically.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.StretchFactor Property

TreeLayout.StretchFactor Property
[image]

Gets or sets the stretch factor applied on Radial tree layouts.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double StretchFactor { get; set; }

Visual Basic [image] Copy Code

Public Property StretchFactor As Double

Property Value

Remarks

When applying a radial layout, node layers are laid out in concentric circles around the Root node. Stretching them by changing this property makes layers laid out in elliptic outlines.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.Type Property

TreeLayout.Type Property
[image]

Gets or sets what type of tree layout to apply to the diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayoutType Type { get; set; }

Visual Basic [image] Copy Code

Public Property Type As TreeLayoutType

Property Value

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayoutBalance Enumeration

TreeLayoutBalance Enumeration
[image]

Specifies how to order child nodes in order to produce tree layouts with custom balance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum TreeLayoutBalance

Visual Basic [image] Copy Code

Public Enum TreeLayoutBalance

Members

Member name | Description
LeftHeavy | Indicates that the child nodes with most total children will be processed first, thus producing a left-heavy layout.
Original | Indicates that the child order should not be changed.
Preserve | Indicates that the layout will attempt to preserve the initial relative ordering of nodes.
Reversed | Indicates that the child order should be reversed.
RightHeavy | Indicates that the child nodes with least total children will be processed first, thus producing a right-heavy layout.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayoutDirections Enumeration

TreeLayoutDirections Enumeration
[image]

Specifies the direction of a tree layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum TreeLayoutDirections

Visual Basic [image] Copy Code

Public Enum TreeLayoutDirections

Members

Member name | Description
BottomToTop | Indicates a bottom-to-top direction.
LeftToRight | Indicates a left-to-right direction.
RightToLeft | Indicates a right-to-left direction.
TopToBottom | Indicates a top-to-bottom direction.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayoutLinkType Enumeration

TreeLayoutLinkType Enumeration
[image]

Specifies the shape of the diagram links after they are laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum TreeLayoutLinkType

Visual Basic [image] Copy Code

Public Enum TreeLayoutLinkType

Members

Member name | Description
Cascading2 | Indicates cascading links with two segments.
Cascading3 | Indicates cascading links with three segments.
Rounded | Indicates Bézier links with a single segment.
Straight | Indicates straight links with a single segment.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayoutType Enumeration

TreeLayoutType Enumeration
[image]

Specifies the type of a tree layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum TreeLayoutType

Visual Basic [image] Copy Code

Public Enum TreeLayoutType

Members

Member name | Description
Cascading | Indicates cascading tree layout.
Centered | Indicates centered tree layout.
HorizontalVertical | Indicates a Horizontal-Vertical binary tree layout.
Radial | Indicates radial tree layout.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout Class

TreeMapLayout Class
Remarks See Also
[image]

Implements a tree map layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TreeMapLayout : Layout

Visual Basic [image] Copy Code

Public Class TreeMapLayout
Inherits Layout

Remarks

Tree maps represent hierarchies by nesting child nodes within their parents, where the areas of leaf nodes are proportional to their Weight values. Unlike other layout algorithms, TreeMapLayout expects hierarchies to be defined via grouping or containment (see AttachTo method and ContainerNode class), and will ignore any links in the diagram.

The diagram area covered by the topmost nodes in a hierarchy is specified via the LayoutArea property. By default, the layout tries to keep the ratio of node sides as close as possible to one. However this could make it hard to distinguish separate levels of the hierarchy. To alleviate that, set Squarify to false, and child nodes will be arranged either as a row or a column inside their parent node, alternating directions for each level. The drawback is that when Weight ratios differ greatly or nodes contain many children, some nodes could end up with very narrow rectangles.

The padding size between parent nodes and their outermost children is specified via the ContainerPadding property. The padding size between child nodes is specified via Padding.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.TreeMapLayout

See Also

TreeMapLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout Members

TreeMapLayout Members
Constructors Properties Methods
[image]

Implements a tree map layout algorithm.

The following tables list the members exposed by the TreeMapLayout type.

Public Constructors

Name | Description
TreeMapLayout | Initializes a new instance of the TreeMapLayout class with the default settings.

Public Properties

Name | Description
ContainerPadding | Gets or sets the padding inside containers.
LayoutArea | Gets or sets the rectangle in which the layout will try to arrange the nodes, or null, to use the diagram bounds.
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged diagram.
Padding | Gets or sets the distance between adjacent nodes.
Squarify | Gets or sets a value indicating whether the layout should attempt to keep the dimension ratio of the nodes closer to 1.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

Inherited Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)

See Also

TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout Constructor

TreeMapLayout Constructor
[image]

Initializes a new instance of the TreeMapLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeMapLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout Properties

TreeMapLayout Properties
[image]

Public Properties

Name | Description
ContainerPadding | Gets or sets the padding inside containers.
LayoutArea | Gets or sets the rectangle in which the layout will try to arrange the nodes, or null, to use the diagram bounds.
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged diagram.
Padding | Gets or sets the distance between adjacent nodes.
Squarify | Gets or sets a value indicating whether the layout should attempt to keep the dimension ratio of the nodes closer to 1.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

See Also

TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout.ContainerPadding Property

TreeMapLayout.ContainerPadding Property
[image]

Gets or sets the padding inside containers.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ContainerPadding { get; set; }

Visual Basic [image] Copy Code

Public Property ContainerPadding As Double

Property Value

A double value specifying the padding size between parent nodes and their outermost children. The default value is 0.

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace
Padding Property


MindFusion.Diagramming.Layout.TreeMapLayout.DefaultMarginValue Property

TreeMapLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

Returns new Size(5, 5).

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout.LayoutArea Property

TreeMapLayout.LayoutArea Property
[image]

Gets or sets the rectangle in which the layout will try to arrange the nodes, or null, to use the diagram bounds.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Nullable<Rect> LayoutArea { get; set; }

Visual Basic [image] Copy Code

Public Property LayoutArea As Nullable(Of Rect)

Property Value

A Rect? specifying the area where topmost nodes in the hierarchy are laid out. The default value is null.

Remarks

If this property is not set, the algorithm uses the value of diagram's Bounds property as target layout rectangle.

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout.Name Property

TreeMapLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Tree map layout".

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout.Orientation Property

TreeMapLayout.Orientation Property
[image]

Gets or sets the orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Vertical

Remarks

This value is used only when Squarify is set to false, and specifies the orientation of the topmost level of the hierarchy. The algorithm alternates the orientation of each subsequent level, arranging its nodes either in rows or columns.

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout.Padding Property

TreeMapLayout.Padding Property
[image]

Gets or sets the distance between adjacent nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Padding { get; set; }

Visual Basic [image] Copy Code

Public Property Padding As Double

Property Value

A double value specifying the padding size between sibling nodes. The default value is 3.

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace
ContainerPadding Property


MindFusion.Diagramming.Layout.TreeMapLayout.Squarify Property

TreeMapLayout.Squarify Property
[image]

Gets or sets a value indicating whether the layout should attempt to keep the dimension ratio of the nodes closer to 1.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Squarify { get; set; }

Visual Basic [image] Copy Code

Public Property Squarify As Boolean

Property Value

true to keep the ratio of node sides as close as possible to one, or false otherwise. The default value is true.

Remarks

If set to false, each level of the hierarchy is arranged in rows or columns with same height/width, which might create very narrow rectangles when Weight values differ greatly or nodes have many children. The alternating orientation between levels however helps to distinguish between different levels in the hierarchy. The initial direction of nodes (in topmost level) depends on the value of Orientation.

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TriangularLayout Class

TriangularLayout Class
Remarks See Also
[image]

Performs triangular layout on simple, connected graphs.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TriangularLayout : Layout

Visual Basic [image] Copy Code

Public Class TriangularLayout
Inherits Layout

Remarks

TriangularLayout places nodes on a virtual grid, such that if the source graph is planar, all links are guaranteed to have a single segment and not intersect. If the graph is not planar, its intersecting links can be optionally segmented and bended in order to improve readability. The layout method places the nodes from the external face on a triangle and recursively adds the rest of the nodes as vertices of internal triangles. As a result, it is very effective for near maximal-planar (a.k.a. triangular) graphs.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.TriangularLayout

See Also

TriangularLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TriangularLayout Members

TriangularLayout Members
Constructors Properties Methods
[image]

Performs triangular layout on simple, connected graphs.

The following tables list the members exposed by the TriangularLayout type.

Public Constructors

Name | Description
TriangularLayout | Initializes a new instance of the TriangularLayout class.

Public Properties

Name | Description
BendNonplanarLinks | Gets or sets a value indicating whether the intersecting links in a non-planar graphs will be segmented and bended to improve presentation.
GridSize | Gets or sets the size of the virtual grid the layout will place vertices on.
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged graph.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

Inherited Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)

See Also

TriangularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TriangularLayout Constructor

TriangularLayout Constructor
[image]

Initializes a new instance of the TriangularLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TriangularLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TriangularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TriangularLayout Properties

TriangularLayout Properties
[image]

Public Properties

Name | Description
BendNonplanarLinks | Gets or sets a value indicating whether the intersecting links in a non-planar graphs will be segmented and bended to improve presentation.
GridSize | Gets or sets the size of the virtual grid the layout will place vertices on.
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged graph.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Inherited Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout. (Inherited from Layout.)
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Inherited Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts. (Inherited from Layout.)

See Also

TriangularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TriangularLayout.BendNonplanarLinks Property

TriangularLayout.BendNonplanarLinks Property
[image]

Gets or sets a value indicating whether the intersecting links in a non-planar graphs will be segmented and bended to improve presentation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool BendNonplanarLinks { get; set; }

Visual Basic [image] Copy Code

Public Property BendNonplanarLinks As Boolean

Property Value

true to bend links, otherwise false. The default value is false.

See Also

TriangularLayout Members
TriangularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TriangularLayout.DefaultMarginValue Property

TriangularLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

TriangularLayout Members
TriangularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TriangularLayout.GridSize Property

TriangularLayout.GridSize Property
[image]

Gets or sets the size of the virtual grid the layout will place vertices on.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double GridSize { get; set; }

Visual Basic [image] Copy Code

Public Property GridSize As Double

Property Value

The default value is 75.

See Also

TriangularLayout Members
TriangularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TriangularLayout.Name Property

TriangularLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Triangular layout".

See Also

TriangularLayout Members
TriangularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TriangularLayout.Orientation Property

TriangularLayout.Orientation Property
[image]

Gets or sets the orientation of the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Vertical.

See Also

TriangularLayout Members
TriangularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Geometry2D Namespace

MindFusion.Geometry2D Namespace
Classes

Classes

Class | Description
Convert | Provides various conversions.
Line | Represents a line in the plane defined by two points.
Polygon | Represents immutable closed plane figure with three or more straight sides.
ReadOnlyPointList | Represents a read-only collection of points.


MindFusion.Geometry2D.Convert Class

Convert Class
[image]

Provides various conversions.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class Convert

Visual Basic [image] Copy Code

Public NotInheritable Class Convert

Inheritance Hierarchy

System.Object
MindFusion.Geometry2D.Convert

See Also

Convert Members
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Convert Members

Convert Members
Methods
[image]

Provides various conversions.

The following tables list the members exposed by the Convert type.

Public Methods

Name | Description
CartesianToPolar | Converts Cartesian coordinates to the corresponding polar coordinates, using the specified point as a center of the coordinate system.
PolarToCartesian | Converts polar coordinates to the corresponding Cartesian coordinates, using the specified point as a center of the coordinate system.

See Also

Convert Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Convert Methods

Convert Methods
[image]

Public Methods

Name | Description
CartesianToPolar | Converts Cartesian coordinates to the corresponding polar coordinates, using the specified point as a center of the coordinate system.
PolarToCartesian | Converts polar coordinates to the corresponding Cartesian coordinates, using the specified point as a center of the coordinate system.

See Also

Convert Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Convert.CartesianToPolar Method

Convert.CartesianToPolar Method
[image]

Converts Cartesian coordinates to the corresponding polar coordinates, using the specified point as a center of the coordinate system.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void CartesianToPolar (
Point coordCenter,
Point point,
ref double a,
ref double r
)

Visual Basic [image] Copy Code

Public Shared Sub CartesianToPolar( _
coordCenter As Point, _
point As Point, _
ByRef a As Double, _
ByRef r As Double _
)

Parameters

coordCenter

A Point specifying the center of the Cartesian coordinate system.

point

A Point specifying the Cartesian point to transform.

a

Receives the angle of the specified point, in the polar coordinate space.

r

Receives the radius of the specified point, in the polar coordinate space.

See Also

Convert Members
Convert Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Convert.PolarToCartesian Method

Convert.PolarToCartesian Method
[image]

Converts polar coordinates to the corresponding Cartesian coordinates, using the specified point as a center of the coordinate system.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Point PolarToCartesian (
Point coordCenter,
double a,
double r
)

Visual Basic [image] Copy Code

Public Shared Function PolarToCartesian( _
coordCenter As Point, _
a As Double, _
r As Double _
) As Point

Parameters

coordCenter

A Point specifying the center of the polar coordinate system.

a

The angle of the specified point, in the polar coordinate space.

r

The radius of the specified point, in the polar coordinate space.

Return Value

See Also

Convert Members
Convert Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Line Class

Line Class
[image]

Represents a line in the plane defined by two points.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Line

Visual Basic [image] Copy Code

Public Class Line

Inheritance Hierarchy

System.Object
MindFusion.Geometry2D.Line

See Also

Line Members
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Line Members

Line Members
Constructors Properties Methods
[image]

Represents a line in the plane defined by two points.

The following tables list the members exposed by the Line type.

Public Constructors

Name | Description
Line | Overloaded.

Public Properties

Name | Description
A | Gets or sets the first point defining the line.
B | Gets or sets the second point defining the line.
Bounds | Gets the smallest rectangle bounding the segment which defines the line.

Public Methods

Name | Description
ContainsInSegment | Checks whether the given point lies on the line segment.
IntersectLine | Overloaded.
IntersectSegment | Overloaded.

See Also

Line Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Line Constructor

Line Constructor
[image]

Overload List

Name | Description
Line (Line) | Initializes a new instance of the Line class.
Line (Point, Point) | Initializes a new instance of the Line class.

See Also

Line Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Line Constructor (Line)

Line Constructor (Line)
See Also
[image]

Initializes a new instance of the Line class.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Line (
Line line
)

Visual Basic [image] Copy Code

Public New ( _
line As Line _
)

Parameters

line

The Line object from which to initialize the new line.

See Also

Line Constructor Overload List
Line Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Line Constructor (Point, Point)

Line Constructor (Point, Point)
See Also
[image]

Initializes a new instance of the Line class.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Line (
Point a,
Point b
)

Visual Basic [image] Copy Code

Public New ( _
a As Point, _
b As Point _
)

Parameters

a

The first point defining the new line.

b

The second point defining the new line.

See Also

Line Constructor Overload List
Line Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Line Methods

Line Methods
[image]

Public Methods

Name | Description
ContainsInSegment | Checks whether the given point lies on the line segment.
IntersectLine | Overloaded.
IntersectSegment | Overloaded.

See Also

Line Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Line.ContainsInSegment Method

Line.ContainsInSegment Method
[image]

Checks whether the given point lies on the line segment.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ContainsInSegment (
Point point
)

Visual Basic [image] Copy Code

Public Function ContainsInSegment( _
point As Point _
) As Boolean

Parameters

point

The point to check.

Return Value

See Also

Line Members
Line Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Line.IntersectLine Method

Line.IntersectLine Method
[image]

Overload List

Name | Description
Line.IntersectLine (Line) | Calculates the intersection point with the specified line. If there is no intersection the return value is an infinite point.
Line.IntersectLine (Point, Point) | Calculates the intersection point with the line defined by the given points. If there is no intersection the return value is an infinite point.

See Also

Line Members
Line Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Line.IntersectLine Method (Line)

Line.IntersectLine Method (Line)
See Also
[image]

Calculates the intersection point with the specified line. If there is no intersection the return value is an infinite point.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point IntersectLine (
Line line
)

Visual Basic [image] Copy Code

Public Function IntersectLine( _
line As Line _
) As Point

Parameters

line

The Line object to intersect the current line with.

Return Value

A Point object representing the intersection point.

See Also

IntersectLine Method Overload List
Line Members
Line Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Line.IntersectLine Method (Point, Point)

Line.IntersectLine Method (Point, Point)
See Also
[image]

Calculates the intersection point with the line defined by the given points. If there is no intersection the return value is an infinite point.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point IntersectLine (
Point a,
Point b
)

Visual Basic [image] Copy Code

Public Function IntersectLine( _
a As Point, _
b As Point _
) As Point

Parameters

a

The first point defining the line to intersect with.

b

The second point defining the line to intersect with.

Return Value

See Also

IntersectLine Method Overload List
Line Members
Line Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Line.IntersectSegment Method

Line.IntersectSegment Method
[image]

Overload List

Name | Description
Line.IntersectSegment (Line) | Calculates the intersection point with the given line segment. If there is no intersection the return value is an infinite point.
Line.IntersectSegment (Point, Point) | Calculates the intersection point with the line segment defined by the given points. If there is no intersection the return value is an infinite point.

See Also

Line Members
Line Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Line.IntersectSegment Method (Line)

Line.IntersectSegment Method (Line)
See Also
[image]

Calculates the intersection point with the given line segment. If there is no intersection the return value is an infinite point.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point IntersectSegment (
Line line
)

Visual Basic [image] Copy Code

Public Function IntersectSegment( _
line As Line _
) As Point

Parameters

line

The Line object defining the segment to intersect the current line with.

Return Value

A Point object representing the intersection point.

See Also

IntersectSegment Method Overload List
Line Members
Line Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Line.IntersectSegment Method (Point, Point)

Line.IntersectSegment Method (Point, Point)
See Also
[image]

Calculates the intersection point with the line segment defined by the given points. If there is no intersection the return value is an infinite point.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point IntersectSegment (
Point a,
Point b
)

Visual Basic [image] Copy Code

Public Function IntersectSegment( _
a As Point, _
b As Point _
) As Point

Parameters

a

The first point of the segment to intersect with.

b

The second point of the segment to intersect with.

Return Value

A Point object representing the intersection point.

See Also

IntersectSegment Method Overload List
Line Members
Line Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Line Properties

Line Properties
[image]

Public Properties

Name | Description
A | Gets or sets the first point defining the line.
B | Gets or sets the second point defining the line.
Bounds | Gets the smallest rectangle bounding the segment which defines the line.

See Also

Line Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Line.A Property

Line.A Property
[image]

Gets or sets the first point defining the line.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point A { get; set; }

Visual Basic [image] Copy Code

Public Property A As Point

Property Value

See Also

Line Members
Line Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Line.B Property

Line.B Property
[image]

Gets or sets the second point defining the line.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point B { get; set; }

Visual Basic [image] Copy Code

Public Property B As Point

Property Value

See Also

Line Members
Line Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Line.Bounds Property

Line.Bounds Property
[image]

Gets the smallest rectangle bounding the segment which defines the line.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As Rect

Property Value

See Also

Line Members
Line Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Polygon Class

Polygon Class
[image]

Represents immutable closed plane figure with three or more straight sides.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Polygon

Visual Basic [image] Copy Code

Public Class Polygon

Inheritance Hierarchy

System.Object
MindFusion.Geometry2D.Polygon

See Also

Polygon Members
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Polygon Members

Polygon Members
Constructors Properties Methods
[image]

Represents immutable closed plane figure with three or more straight sides.

The following tables list the members exposed by the Polygon type.

Public Constructors

Name | Description
Polygon | Overloaded.

Public Properties

Name | Description
Bounds | Gets the smallest rectangle bounding the polygon.
Points | Gets a collection of the polygon points.

Public Methods

Name | Description
Contains | Checks whether the specified point lies whithin the polygon.
FindConvexVertex | Finds a convex vertex of the polygon.
GetInternalPoint | Finds a point inside the polygon.
IntersectLine | Overloaded.
IntersectSegment | Overloaded.

See Also

Polygon Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Polygon Constructor

Polygon Constructor
[image]

Overload List

Name | Description
Polygon (List(Point)) | Initializes a new instance of the Polygon class from the specified collection of points.
Polygon (Rect) | Initializes a new instance of the Polygon class from the specified rectangle.

See Also

Polygon Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Polygon Constructor (List(Point))

Polygon Constructor (List(Point))
See Also
[image]

Initializes a new instance of the Polygon class from the specified collection of points.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Polygon (
List<Point> points
)

Visual Basic [image] Copy Code

Public New ( _
points As List(Of Point) _
)

Parameters

points

See Also

Polygon Constructor Overload List
Polygon Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Polygon Constructor (Rect)

Polygon Constructor (Rect)
See Also
[image]

Initializes a new instance of the Polygon class from the specified rectangle.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Polygon (
Rect rect
)

Visual Basic [image] Copy Code

Public New ( _
rect As Rect _
)

Parameters

rect

See Also

Polygon Constructor Overload List
Polygon Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Polygon Methods

Polygon Methods
[image]

Public Methods

Name | Description
Contains | Checks whether the specified point lies whithin the polygon.
FindConvexVertex | Finds a convex vertex of the polygon.
GetInternalPoint | Finds a point inside the polygon.
IntersectLine | Overloaded.
IntersectSegment | Overloaded.

See Also

Polygon Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Polygon.Contains Method

Polygon.Contains Method
[image]

Checks whether the specified point lies whithin the polygon.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Contains (
Point point
)

Visual Basic [image] Copy Code

Public Function Contains( _
point As Point _
) As Boolean

Parameters

point

The Point object to check.

Return Value

See Also

Polygon Members
Polygon Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Polygon.FindConvexVertex Method

Polygon.FindConvexVertex Method
[image]

Finds a convex vertex of the polygon.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int FindConvexVertex ()

Visual Basic [image] Copy Code

Public Function FindConvexVertex () As Integer

Return Value

See Also

Polygon Members
Polygon Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Polygon.GetInternalPoint Method

Polygon.GetInternalPoint Method
[image]

Finds a point inside the polygon.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point GetInternalPoint ()

Visual Basic [image] Copy Code

Public Function GetInternalPoint () As Point

Return Value

See Also

Polygon Members
Polygon Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Polygon.IntersectLine Method

Polygon.IntersectLine Method
[image]

Overload List

Name | Description
Polygon.IntersectLine (Line) | Calculates the intersections between the polygon and the given line. The result is a list containing all points of intersection.
Polygon.IntersectLine (Point, Point) | Calculates the intersections between the polygon and the line defined by the given points. The result is a list containing all points of intersection.

See Also

Polygon Members
Polygon Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Polygon.IntersectLine Method (Line)

Polygon.IntersectLine Method (Line)
See Also
[image]

Calculates the intersections between the polygon and the given line. The result is a list containing all points of intersection.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointList IntersectLine (
Line line
)

Visual Basic [image] Copy Code

Public Function IntersectLine ( _
line As Line _
) As PointList

Parameters

line

The Line object to intersect with.

Return Value

See Also

IntersectLine Method Overload List
Polygon Members
Polygon Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Polygon.IntersectLine Method (Point, Point)

Polygon.IntersectLine Method (Point, Point)
See Also
[image]

Calculates the intersections between the polygon and the line defined by the given points. The result is a list containing all points of intersection.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<Point> IntersectLine (
Point a,
Point b
)

Visual Basic [image] Copy Code

Public Function IntersectLine( _
a As Point, _
b As Point _
) As List(Of Point)

Parameters

a

The first point defining the line to intersect with.

b

The second point defining the line to intersect with.

Return Value

See Also

IntersectLine Method Overload List
Polygon Members
Polygon Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Polygon.IntersectSegment Method

Polygon.IntersectSegment Method
[image]

Overload List

Name | Description
Polygon.IntersectSegment (Line) | Calculates the intersections between the polygon and the given line segment. The result is a list containing all points of intersection.
Polygon.IntersectSegment (Point, Point) | Calculates the intersections between the polygon and the line segment defined by the given points. The result is a list containing all points of intersection.

See Also

Polygon Members
Polygon Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Polygon.IntersectSegment Method (Line)

Polygon.IntersectSegment Method (Line)
See Also
[image]

Calculates the intersections between the polygon and the given line segment. The result is a list containing all points of intersection.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<Point> IntersectSegment (
Line line
)

Visual Basic [image] Copy Code

Public Function IntersectSegment( _
line As Line _
) As List(Of Point)

Parameters

line

The Line object defining the segment to intersect with.

Return Value

See Also

IntersectSegment Method Overload List
Polygon Members
Polygon Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Polygon.IntersectSegment Method (Point, Point)

Polygon.IntersectSegment Method (Point, Point)
See Also
[image]

Calculates the intersections between the polygon and the line segment defined by the given points. The result is a list containing all points of intersection.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<Point> IntersectSegment (
Point a,
Point b
)

Visual Basic [image] Copy Code

Public Function IntersectSegment( _
a As Point, _
b As Point _
) As List(Of Point)

Parameters

a

The first point defining the segment to intersect with.

b

The second point defining the segment to intersect with.

Return Value

See Also

IntersectSegment Method Overload List
Polygon Members
Polygon Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Polygon Properties

Polygon Properties
[image]

Public Properties

Name | Description
Bounds | Gets the smallest rectangle bounding the polygon.
Points | Gets a collection of the polygon points.

See Also

Polygon Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Polygon.Bounds Property

Polygon.Bounds Property
[image]

Gets the smallest rectangle bounding the polygon.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As Rect

Property Value

See Also

Polygon Members
Polygon Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.Polygon.Points Property

Polygon.Points Property
[image]

Gets a collection of the polygon points.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ReadOnlyPointList Points { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Points As ReadOnlyPointList

Property Value

See Also

Polygon Members
Polygon Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.ReadOnlyPointList Class

ReadOnlyPointList Class
[image]

Represents a read-only collection of points.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ReadOnlyPointList : List<Point>

Visual Basic [image] Copy Code

Public Class ReadOnlyPointList
Inherits List(Of Point)

Inheritance Hierarchy

System.Object
System.Collections.Generic.List(Point)
MindFusion.Geometry2D.ReadOnlyPointList

See Also

ReadOnlyPointList Members
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.ReadOnlyPointList Members

ReadOnlyPointList Members
Constructors
[image]

Represents a read-only collection of points.

The following tables list the members exposed by the ReadOnlyPointList type.

Public Constructors

Name | Description
ReadOnlyPointList | Initializes a new instance of the ReadOnlyPointList class.

See Also

ReadOnlyPointList Class
MindFusion.Geometry2D Namespace


MindFusion.Geometry2D.ReadOnlyPointList Constructor

ReadOnlyPointList Constructor
[image]

Initializes a new instance of the ReadOnlyPointList class.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ReadOnlyPointList (
ICollection points
)

Visual Basic [image] Copy Code

Public New ( _
points As ICollection _
)

Parameters

points

The underlying point collection.

See Also

ReadOnlyPointList Class
MindFusion.Geometry2D Namespace


MindFusion.Layout Namespace

MindFusion.Layout Namespace
Classes Interfaces Delegates Enumerations

Classes

Class | Description
AnnealLayoutStatistics | Contains the accumulated costs for a graph configuration produced by AnnealLayout.
LayoutRules | Summary description for LayoutRules.
Pair | Represents a coupling between two arbitrary objects.

Interfaces

Interface | Description
RoutingOptions | Allows customization of various aspects of the link routing algorithm.

Delegates

Delegate | Description
RouteHeuristics | The link routing algorithm uses a heuristic function of this type in its prediction steps.

Enumerations

Enumeration | Description
AssistantType | Indicates the type of an assistant node in a tree.
BaseLayout | Specifies how OrthogonalRouter should arrange nodes.
HierarchicalLayoutTraits | Indicates item traits specific to hierarchical layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.
LayeredLayoutTraits | Indicates item traits specific to LayeredLayout. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.
PartitionMethod | Identifies graph partitioning methods supported by CompositeLayout.
SpringLayoutMethod | Specifies what energy model SpringLayout should use for the simulation.
SpringLayoutTraits | Indicates item traits specific to SpringLayout. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.
SwimlaneLayoutTraits | Indicates item traits specific to swimlane layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.
TreeLayoutTraits | Indicates item traits specific to tree layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.
TreeMapLayoutTraits | Indicates item traits specific to tree map layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.


MindFusion.Layout.AnnealLayoutStatistics Class

AnnealLayoutStatistics Class
[image]

Contains the accumulated costs for a graph configuration produced by AnnealLayout.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class AnnealLayoutStatistics

Visual Basic [image] Copy Code

Public Class AnnealLayoutStatistics

Inheritance Hierarchy

System.Object
MindFusion.Layout.AnnealLayoutStatistics

See Also

AnnealLayoutStatistics Members
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics Members

AnnealLayoutStatistics Members
Constructors Properties Methods
[image]

Contains the accumulated costs for a graph configuration produced by AnnealLayout.

The following tables list the members exposed by the AnnealLayoutStatistics type.

Public Constructors

Name | Description
AnnealLayoutStatistics | Initializes a new instance of the AnnealLayoutStatistics class.

Public Properties

Name | Description
BoundaryCost | The total distance-to-boundary cost of a graph configuration.
DistributionCost | The total distribution cost of a graph configuration.
EdgeCrossingsCost | The total edge crossings cost of a graph configuration.
EdgeCrossingsFound | The number of edge crossings in the graph configuration.
EdgeLengthsCost | The total edge lengths cost of a graph configuration.
NodeEdgeDistance | The total node-to-edge-distance cost of a graph configuration.

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics Constructor

AnnealLayoutStatistics Constructor
[image]

Initializes a new instance of the AnnealLayoutStatistics class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnnealLayoutStatistics ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics Methods

AnnealLayoutStatistics Methods
[image]

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.ToString Method

AnnealLayoutStatistics.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics Properties

AnnealLayoutStatistics Properties
[image]

Public Properties

Name | Description
BoundaryCost | The total distance-to-boundary cost of a graph configuration.
DistributionCost | The total distribution cost of a graph configuration.
EdgeCrossingsCost | The total edge crossings cost of a graph configuration.
EdgeCrossingsFound | The number of edge crossings in the graph configuration.
EdgeLengthsCost | The total edge lengths cost of a graph configuration.
NodeEdgeDistance | The total node-to-edge-distance cost of a graph configuration.

See Also

AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.BoundaryCost Property

AnnealLayoutStatistics.BoundaryCost Property
[image]

The total distance-to-boundary cost of a graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double BoundaryCost { get; set; }

Visual Basic [image] Copy Code

Public Property BoundaryCost As Double

Property Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.DistributionCost Property

AnnealLayoutStatistics.DistributionCost Property
[image]

The total distribution cost of a graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double DistributionCost { get; set; }

Visual Basic [image] Copy Code

Public Property DistributionCost As Double

Property Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.EdgeCrossingsCost Property

AnnealLayoutStatistics.EdgeCrossingsCost Property
[image]

The total edge crossings cost of a graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double EdgeCrossingsCost { get; set; }

Visual Basic [image] Copy Code

Public Property EdgeCrossingsCost As Double

Property Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.EdgeCrossingsFound Property

AnnealLayoutStatistics.EdgeCrossingsFound Property
[image]

The number of edge crossings in the graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int EdgeCrossingsFound { get; set; }

Visual Basic [image] Copy Code

Public Property EdgeCrossingsFound As Integer

Property Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.EdgeLengthsCost Property

AnnealLayoutStatistics.EdgeLengthsCost Property
[image]

The total edge lengths cost of a graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double EdgeLengthsCost { get; set; }

Visual Basic [image] Copy Code

Public Property EdgeLengthsCost As Double

Property Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.NodeEdgeDistance Property

AnnealLayoutStatistics.NodeEdgeDistance Property
[image]

The total node-to-edge-distance cost of a graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeEdgeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeEdgeDistance As Double

Property Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AssistantType Enumeration

AssistantType Enumeration
[image]

Indicates the type of an assistant node in a tree.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum AssistantType

Visual Basic [image] Copy Code

Public Enum AssistantType

Members

Member name | Description
Left | The node is an assistant and it is always positioned to the left of its parent.
None | The node is not an assistant.
Normal | The node is an assistant and its relative position is determined automatically by the layout.
Right | The node is an assistant and it is always positioned to the right of its parent.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.BaseLayout Enumeration

BaseLayout Enumeration
[image]

Specifies how OrthogonalRouter should arrange nodes.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum BaseLayout

Visual Basic [image] Copy Code

Public Enum BaseLayout

Members

Member name | Description
Cascading | Use TreeLayout to arrange nodes.
Custom | Use the current node configuration.
Grid | Use GridLayout to arrange nodes.
Layered | Use LayeredLayout to arrange nodes.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.HierarchicalLayoutTraits Enumeration

HierarchicalLayoutTraits Enumeration
[image]

Indicates item traits specific to hierarchical layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum HierarchicalLayoutTraits

Visual Basic [image] Copy Code

Public Enum HierarchicalLayoutTraits

Members

Member name | Description
Level | The number associated with this key specifies the index of the level of the item in the level-planar graph.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.LayeredLayoutTraits Enumeration

LayeredLayoutTraits Enumeration
[image]

Indicates item traits specific to LayeredLayout. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum LayeredLayoutTraits

Visual Basic [image] Copy Code

Public Enum LayeredLayoutTraits

Members

Member name | Description
Layer | The number associated with this key specifies the index of the layer the layout should attempt to place the node to. Specifying a negative number indicates a layer starting from the last. For example, -1 would indicate the last layer, -2 - the layer before the last, and so on.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules Class

LayoutRules Class
[image]

Summary description for LayoutRules.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LayoutRules

Visual Basic [image] Copy Code

Public Class LayoutRules

Inheritance Hierarchy

System.Object
MindFusion.Layout.LayoutRules

See Also

LayoutRules Members
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules Members

LayoutRules Members
Constructors Methods
[image]

Summary description for LayoutRules.

The following tables list the members exposed by the LayoutRules type.

Public Constructors

Name | Description
LayoutRules | Initializes a new instance of the LayoutRules class.

Public Methods

Name | Description
AddLayoutRule | Overloaded.
BuildKey | Builds a key - object for the new rule, as a pair of two objects: obj1 and obj2
GetLayoutRule | If there is rule with key - Key initializes - Value otherwise fails;
ValidateRules | Checks if there is a rule for each key in KeyList

See Also

LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules Constructor

LayoutRules Constructor
[image]

Initializes a new instance of the LayoutRules class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LayoutRules ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules Methods

LayoutRules Methods
[image]

Public Methods

Name | Description
AddLayoutRule | Overloaded.
BuildKey | Builds a key - object for the new rule, as a pair of two objects: obj1 and obj2
GetLayoutRule | If there is rule with key - Key initializes - Value otherwise fails;
ValidateRules | Checks if there is a rule for each key in KeyList

See Also

LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.AddLayoutRule Method

LayoutRules.AddLayoutRule Method
[image]

Overload List

Name | Description
LayoutRules.AddLayoutRule (Object, Object) | Adds or sets a new rule, depending on if the rule with key - Key already exists or no;
LayoutRules.AddLayoutRule (Object, Object, Object) | Builds a key as a pair of the objects Object1 and Object2 and adds or sets a new rule, with this key anf value - Value;

See Also

LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.AddLayoutRule Method (Object, Object)

LayoutRules.AddLayoutRule Method (Object, Object)
See Also
[image]

Adds or sets a new rule, depending on if the rule with key - Key already exists or no;

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddLayoutRule (
Object Key,
Object Value
)

Visual Basic [image] Copy Code

Public Function AddLayoutRule( _
Key As Object, _
Value As Object _
) As Boolean

Parameters

Key

Value

Return Value

See Also

AddLayoutRule Method Overload List
LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.AddLayoutRule Method (Object, Object, Object)

LayoutRules.AddLayoutRule Method (Object, Object, Object)
See Also
[image]

Builds a key as a pair of the objects Object1 and Object2 and adds or sets a new rule, with this key anf value - Value;

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddLayoutRule (
Object Object1,
Object Object2,
Object Value
)

Visual Basic [image] Copy Code

Public Function AddLayoutRule( _
Object1 As Object, _
Object2 As Object, _
Value As Object _
) As Boolean

Parameters

Object1

Object2

Value

Return Value

See Also

AddLayoutRule Method Overload List
LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.BuildKey Method

LayoutRules.BuildKey Method
[image]

Builds a key - object for the new rule, as a pair of two objects: obj1 and obj2

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object BuildKey (
Object obj1,
Object obj2
)

Visual Basic [image] Copy Code

Public Function BuildKey( _
obj1 As Object, _
obj2 As Object _
) As Object

Parameters

obj1

obj2

Return Value

See Also

LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.GetLayoutRule Method

LayoutRules.GetLayoutRule Method
[image]

If there is rule with key - Key initializes - Value otherwise fails;

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool GetLayoutRule (
Object Key,
out Object Value
)

Visual Basic [image] Copy Code

Public Overridable Function GetLayoutRule( _
Key As Object, _
<System.Runtime.InteropServices.Out()> ByRef Value As Object _
) As Boolean

Parameters

Key

Value

Return Value

See Also

LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.ValidateRules Method

LayoutRules.ValidateRules Method
[image]

Checks if there is a rule for each key in KeyList

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ValidateRules (
ICollection KeyList
)

Visual Basic [image] Copy Code

Public Function ValidateRules( _
KeyList As ICollection _
) As Boolean

Parameters

KeyList

Return Value

See Also

LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair Class

Pair Class
[image]

Represents a coupling between two arbitrary objects.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Pair : IComparable

Visual Basic [image] Copy Code

Public Class Pair
Implements IComparable

Inheritance Hierarchy

System.Object
MindFusion.Layout.Pair

See Also

Pair Members
MindFusion.Layout Namespace


MindFusion.Layout.Pair Members

Pair Members
Constructors Properties Methods
[image]

Represents a coupling between two arbitrary objects.

The following tables list the members exposed by the Pair type.

Public Constructors

Name | Description
Pair | Overloaded.

Public Properties

Name | Description
FirstObject | Gets or sets the first pair object.
PairElements | Gets the elements of the pair as an arraylist
SecondObject | Gets or sets the second pair object.

Public Methods

Name | Description
CompareTo | Implements IComparable.CompareTo.
Equals | Object.Equals override.
GetHashCode | Object.GetHashCode override.

See Also

Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair Constructor

Pair Constructor
[image]

Overload List

Name | Description
Pair () | Initializes a new instance of the Pair class.
Pair (Object, Object) | Initializes a new instance of the Pair class.

See Also

Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair Constructor ()

Pair Constructor ()
See Also
[image]

Initializes a new instance of the Pair class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pair ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Pair Constructor Overload List
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair Constructor (Object, Object)

Pair Constructor (Object, Object)
See Also
[image]

Initializes a new instance of the Pair class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pair (
Object obj1,
Object obj2
)

Visual Basic [image] Copy Code

Public New ( _
obj1 As Object, _
obj2 As Object _
)

Parameters

obj1

obj2

See Also

Pair Constructor Overload List
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair Methods

Pair Methods
[image]

Public Methods

Name | Description
CompareTo | Implements IComparable.CompareTo.
Equals | Object.Equals override.
GetHashCode | Object.GetHashCode override.

See Also

Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.CompareTo Method

Pair.CompareTo Method
[image]

Implements IComparable.CompareTo.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int CompareTo (
Object obj
)

Visual Basic [image] Copy Code

Public Function CompareTo( _
obj As Object _
) As Integer

Parameters

obj

Return Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.Equals Method

Pair.Equals Method
[image]

Object.Equals override.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

Return Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.GetHashCode Method

Pair.GetHashCode Method
[image]

Object.GetHashCode override.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair Properties

Pair Properties
[image]

Public Properties

Name | Description
FirstObject | Gets or sets the first pair object.
PairElements | Gets the elements of the pair as an arraylist
SecondObject | Gets or sets the second pair object.

See Also

Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.FirstObject Property

Pair.FirstObject Property
[image]

Gets or sets the first pair object.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object FirstObject { get; set; }

Visual Basic [image] Copy Code

Public Property FirstObject As Object

Property Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.PairElements Property

Pair.PairElements Property
[image]

Gets the elements of the pair as an arraylist

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<Object> PairElements { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PairElements As List(Of Object)

Property Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.SecondObject Property

Pair.SecondObject Property
[image]

Gets or sets the second pair object.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object SecondObject { get; set; }

Visual Basic [image] Copy Code

Public Property SecondObject As Object

Property Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.PartitionMethod Enumeration

PartitionMethod Enumeration
[image]

Identifies graph partitioning methods supported by CompositeLayout.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum PartitionMethod

Visual Basic [image] Copy Code

Public Enum PartitionMethod

Members

Member name | Description
BiconnectedComponents | Partition graphs by their biconnected components.
Custom | Custom partitioning.
ShortestPath | Partition graphs by node paths distance.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.RouteHeuristics Delegate

RouteHeuristics Delegate
[image]

The link routing algorithm uses a heuristic function of this type in its prediction steps.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate int RouteHeuristics (
PointI start,
PointI end
)

Visual Basic [image] Copy Code

Public Delegate Function RouteHeuristics( _
start As PointI, _
end As PointI _
) As Integer

Parameters

start

A Point specifying the first of the points, between which the distance is calculated.

end

A Point specifying the first of the points, between which the distance is calculated.

Return Value

An integer value indicating the calculated distance between the specified points.

Remarks

Functions of this type can be assigned to the RouteHeuristics property of the RoutingOptions class.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions Interface

RoutingOptions Interface
[image]

Allows customization of various aspects of the link routing algorithm.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface RoutingOptions

Visual Basic [image] Copy Code

Public Interface RoutingOptions

Inheritors

MindFusion.Diagramming.RoutingOptions

See Also

RoutingOptions Members
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions Members

RoutingOptions Members
Properties
[image]

Allows customization of various aspects of the link routing algorithm.

The following tables list the members exposed by the RoutingOptions type.

Public Properties

Name | Description
GridSize | Gets or sets the size of the pieces of the routing grid.
IgnoreAnchoring | For internal use.
LengthCost | Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.
NodeVicinityCost | Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.

See Also

RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions Properties

RoutingOptions Properties
[image]

Public Properties

Name | Description
GridSize | Gets or sets the size of the pieces of the routing grid.
IgnoreAnchoring | For internal use.
LengthCost | Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.
NodeVicinityCost | Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.

See Also

RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions.GridSize Property

RoutingOptions.GridSize Property
[image]

Gets or sets the size of the pieces of the routing grid.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

double GridSize { get; set; }

Visual Basic [image] Copy Code

Property GridSize As Double

Property Value

See Also

RoutingOptions Members
RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions.IgnoreAnchoring Property

RoutingOptions.IgnoreAnchoring Property
[image]

For internal use.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

bool IgnoreAnchoring { get; }

Visual Basic [image] Copy Code

ReadOnly Property IgnoreAnchoring As Boolean

Property Value

See Also

RoutingOptions Members
RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions.LengthCost Property

RoutingOptions.LengthCost Property
[image]

Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

byte LengthCost { get; }

Visual Basic [image] Copy Code

ReadOnly Property LengthCost As Byte

Property Value

See Also

RoutingOptions Members
RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions.NodeVicinityCost Property

RoutingOptions.NodeVicinityCost Property
[image]

Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

byte NodeVicinityCost { get; }

Visual Basic [image] Copy Code

ReadOnly Property NodeVicinityCost As Byte

Property Value

See Also

RoutingOptions Members
RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions.TurnCost Property

RoutingOptions.TurnCost Property
[image]

Gets or sets a value added to the total cost of a route if it makes a turn.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

byte TurnCost { get; }

Visual Basic [image] Copy Code

ReadOnly Property TurnCost As Byte

Property Value

See Also

RoutingOptions Members
RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.SpringLayoutMethod Enumeration

SpringLayoutMethod Enumeration
[image]

Specifies what energy model SpringLayout should use for the simulation.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum SpringLayoutMethod

Visual Basic [image] Copy Code

Public Enum SpringLayoutMethod

Members

Member name | Description
Classic | Use Hooke's law of elasticity to treat links as springs, and Coulomb's inverse square law to implement repulsion between nodes.
FruchtermanReingold | Use artificial attraction forces for links and repulsion forces for nodes that cancel each other at about the distance specified in NodeDistance, along with a simulated cooling schedule used for fine-tuning. Based on the method of Thomas Fruchterman and Edward Reingold.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.SpringLayoutTraits Enumeration

SpringLayoutTraits Enumeration
[image]

Indicates item traits specific to SpringLayout. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum SpringLayoutTraits

Visual Basic [image] Copy Code

Public Enum SpringLayoutTraits

Members

Member name | Description
Frozen | If the LayoutTraits value associated with a node through this key is true, SpringLayout considers the repulsion forces exerted by the node to other nodes, but ignores forces acting on the node and keeps it in place.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.SwimlaneLayoutTraits Enumeration

SwimlaneLayoutTraits Enumeration
[image]

Indicates item traits specific to swimlane layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum SwimlaneLayoutTraits

Visual Basic [image] Copy Code

Public Enum SwimlaneLayoutTraits

Members

Member name | Description
Lane | Specifies the lane to which a node should be assigned.
SortOrder | Specifies custom sort order of nodes in the same lane.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.TreeLayoutTraits Enumeration

TreeLayoutTraits Enumeration
[image]

Indicates item traits specific to tree layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum TreeLayoutTraits

Visual Basic [image] Copy Code

Public Enum TreeLayoutTraits

Members

Member name | Description
Assistant | If the LayoutTraits value associated with a node through this key is true, the centered TreeLayout treats this node as an "assistant" during the arrangement. If the value is false or is not present, the node is treated as "subordinate". The associated value can also be of type AssistantType if it is required to specify the position of the assistant node relative to its parent. This value is considered when the EnableAssistants property of TreeLayout is set to true.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.TreeMapLayoutTraits Enumeration

TreeMapLayoutTraits Enumeration
[image]

Indicates item traits specific to tree map layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum TreeMapLayoutTraits

Visual Basic [image] Copy Code

Public Enum TreeMapLayoutTraits

Members

Member name | Description
HeaderSize | The header size of a master node in a tree-map layout.

See Also

MindFusion.Layout Namespace


Table of Predefined Shapes

Table of Predefined Shapes

Shape | Identifier | Common Uses
 | Actor | An user An actor in use case model
 | Alternative | An alternative in SDL An extraction in flowcharts Storage in quality management
 | Arrow1 | Use as desired
 | Arrow2 | Use as desired
 | Arrow3 | Transportation in quality management A reference point
 | Arrow4 | Use as desired
 | Arrow5 | Use as desired
 | Arrow6 | Use as desired
 | Arrow7 | A signal Electronic transmission of data
 | Arrow8 | Use as desired
 | Arrow9 | Use as desired
 | BeginLoop | Begin of a loop
 | BpmnComplex | BPMN Gateways: Complex Decision/Merge
 | BpmnDataBasedXor | BPMN Gateways: Data-Based Exclusive Decision/Merge (XOR)
 | BpmnEndCancel | BPMN Events: Cancel (End)
 | BpmnEndCompensation | BPMN Events: Compensation (End)
 | BpmnEndError | BPMN Events: Error (End)
 | BpmnEndLink | BPMN Events: Link (End)
 | BpmnEndMessage | BPMN Events: Message (End)
 | BpmnEndMultiple | BPMN Events: Multiple (End)
 | BpmnEndTerminate | BPMN Events: Terminate (End)
 | BpmnEventBasedXor | BPMN Gateways: Event-Based Exclusive Decision/Merge (XOR)
 | BpmnInclusive | BPMN Gateways: Inclusive Decision/Merge (OR)
 | BpmnIntermediateCancel | BPMN Events: Cancel (Intermediate)
 | BpmnIntermediateCompensation | BPMN Events: Compensation (Intermediate)
 | BpmnIntermediateError | BPMN Events: Error (Intermediate)
 | BpmnIntermediateLink | BPMN Events: Link (Intermediate)
 | BpmnIntermediateMessage | BPMN Events: Message (Intermediate)
 | BpmnIntermediateMultiple | BPMN Events: Multiple (Intermediate)
 | BpmnIntermediateRule | BPMN Events: Rule (Intermediate)
 | BpmnIntermediateTimer | BPMN Events: Timer (Intermediate)
 | BpmnParallelFork | BPMN Gateways: Parallel Fork/Join (AND)
 | BpmnStartLink | BPMN Events: Link (Start)
 | BpmnStartMessage | BPMN Events: Message (Start)
 | BpmnStartMultiple | BPMN Events: Multiple (Start)
 | BpmnStartRule | BPMN Events: Rule (Start)
 | BpmnStartTimer | BPMN Events: Timer (Start)
 | Cloud | Object instance in data flow diagrams
 | Collate | A collation in flowcharts
 | ConeDown | Use as desired
 | ConeUp | Use as desired
 | ConnectedIssues | Connected issues in quality management
 | CreateRequest | Request to create in SDL
 | Cross | Use as desired
 | Cube | Use as desired
 | Cylinder | Use as desired
 | Database | A database in flowcharts
 | DataTransmition | Electronic transmission of data
 | DDelay | Use as desired
 | Decagon | Use as desired
 | Decision | Decision in flowcharts A comparison in flowcharts Relationship in data flow diagrams
 | Decision2 | A decision in SDL
 | Delay | A delay in process diagrams
 | DInDelay | Use as desired
 | DirectAccessStorage | A direct access storage
 | DiskStorage | Data stored on disk in flowcharts
 | Display | Data that is displayed for human use
 | DividedEvent | An event
 | DividedProcess | A process or document in flowcharts Entity in data flow diagrams
 | Document | A document
 | Donut | Use as desired
 | DOutDelay | Use as desired
 | Ellipse | A cross-reference within the same page of a flowchart Process in data flow diagrams State in data flow diagrams A continuation of the flowchart in SDL An use case Operation in quality management
 | EndLoop | End of a loop
 | ExternalOrganization | An external organization
 | ExternalProcess | An external process
 | File | A file
 | FramedRectangle | Use as desired
 | Gate | A gateway
 | Heart | Use as desired
 | Heptagon | Use as desired
 | Hourglass | Use as desired
 | Input | Data that is input by manual means
 | InternalStorage | An internal storage
 | Interrupt | An interrupt
 | Interrupt2 | An interrupt
 | IsoProcess | Iso9000 process
 | Junction | A summing junction A return in SDL
 | Lightning | Use as desired
 | LinedDocument | A document in flowcharts
 | ManualOperation | Operation performed by a human
 | Merge | A merger in flowcharts Inbound goods in quality management Non-electronic file Stop state in data flow diagrams
 | MessageFromUser | A message from user side in SDL
 | MessageToUser | A message to user side in SDL
 | Microform | A microform
 | MicroformProcessing | A microform processing
 | MicroformRecording | A microform recording
 | MultiDocument | A multiple document in flowcharts
 | MultiProc | A multiple process or document in flowcharts
 | Octagon | Use as desired
 | OfflineStorage | An offline storage
 | OffpageConnection | A cross-reference to another page of a flowchart
 | OffpageReference | A cross-reference to another page of a flowchart A foreign module
 | Or | An 'or' statement
 | Pentagon | Use as desired
 | Plaque | Use as desired
 | PrimitiveFromCall | A primitive from call control in SDL
 | PrimitiveToCall | A primitive to call control in SDL
 | Procedure | Procedure in SDL
 | Process | A process or document in flowcharts A file or data storage
 | Prysm | Use as desired
 | PunchedCard | A punched card
 | PyramidDown | Use as desired
 | PyramidUp | Use as desired
 | Rectangle | A metric operation 'External interactor' in data flow diagrams Inspection in quality management
 | RightTriangle | Use as desired
 | RoundRect | A process or item in flowcharts An event An issue in quality management
 | RSave | Input or output data in flowcharts
 | Save | A save in SDL Input or output data in flowcharts
 | Sort | A sort operation
 | Sphere | Use as desired
 | Star | Use as desired
 | Star4Pointed | Use as desired
 | Star5Pointed | Use as desired
 | Star6Pointed | Use as desired
 | Star7Pointed | Use as desired
 | Star16Pointed | Use as desired
 | Star24Pointed | Use as desired
 | Star32Pointed | Use as desired
 | Start | Start of a program flow A starting point in SDL
 | Tape | Sequentially accessible data
 | Terminator | Start or end of a program flow
 | TransmittalTape | A transmittal tape
 | Trapezoid | Use as desired


Technical Support

Technical Support

Detailed information about everything connected with software products offered by MindFusion - online documentation, demos, information about forthcoming products can be found at http://www.mindfusion.eu [image] . The site is updated every day, so make sure you visit it regularly to catch up with the newest from us.

Apart from that, MindFusion employs a dedicated and technically proficient support team. This guarantees that all your questions and inquiries will be answered in quick and professional manner. They can be reached by e-mail at support@mindfusion.eu [image] or by phone at +359 889 199 729.

You can post a question on the DiagramRT discussion board here:

http://mindfusion.eu/Forum/YaBB.pl?board=diaglite_disc

or visit our Help Desk site:

http://www.mindfusion.eu/HelpDesk/index.php

We will be happy to hear any suggestions and recommendations you might have regarding DiagramRT. We take in account the opinion of every single person who has shown interest in our products [image] .


MindFusion Products

MindFusion Products

MindFusion offers various programming components for different platforms. Below is a list of our products with links to their sections on our website as well link to download a trial version. Clients that have already purchased a product use an increasing discount for each subsequent one.

Diagramming | Links
Diagramming for WPF | Product Information Download
Diagramming for Silverlight | Product Information Download
Diagramming for WinForms | Product Information Download
Diagramming for ASP.NET | Product Information Download
Diagramming for ActiveX | Product Information Download
Diagramming for .NET Compact | Product Information Download
Diagramming for Java Swing | Product Information Download
Diagramming for JavaScript | Product Information Download
DiagramViewer for iOS/Cocoa Touch | Product Information Download
DiagramViewer for Android | Product Information Download

Charting | Links
Charting for WPF | Product Information Download
Charting for Silverlight | Product Information Download
Charting for WinForms | Product Information Download
Charting for ASP.NET | Product Information Download

Scheduling | Links
Scheduling for WinForms | Product Information Download
Scheduling for ASP.NET | Product Information Download
Scheduling for .NET Compact | Product Information Download
Scheduling for WPF | Product Information Download
Scheduling for Silverlight | Product Information Download
Scheduling for Java Swing | Product Information Download

Spreadsheet | Links
Spreadsheet for WinForms | Product Information Download
Spreadsheet for WPF | Product Information Download

Reporting | Links
Reporting for WinForms | Product Information Download
Reporting for WPF | Product Information Download
Reporting for Silverlight | Product Information Download

Mapping | Links
Mapping for WinForms | Product Information Download
Mapping for WPF | Product Information Download
Mapping for Silverlight | Product Information Download

Suites | Links
Pack for WPF | Product Information Download
Pack for WinForms | Product Information Download
Pack for ASP.NET | Product Information Download
Pack for Java FX | Product Information Download
Pack for Scheduling | Product Information Download
Pack for Silverlight | Product Information Download


Acknowledgements

Acknowledgements

Our thanks to:

  • Joe Stegman, who permitted us to use his PNGEncoder class in the DiagramRT implementation.

  • Jon Harris, who permitted us to port his PQTree Java code for the MindFusion.GraphLib implementation.

  • Nader Alkhatib, who contributed his LogicGates project as a sample for the DiagramRT package.

  • Mark James for the Silk icon set (http://www.famfamfam.com/lab/icons/silk/ [image] )

  • ic#code for their #ziplib [image] , used for implementing some custom MSI actions in MindFusion setup kits.